Namespaces

http://www.emgu.com
A cross platform .Net wrapper for the OpenCV image-processing library. Allows OpenCV functions to be called from .NET compatible languages such as C#, VB, VC++, IronPython. The wrapper can be compiled in Mono and run on Windows, Android, iOS, Windows Phone, Mac OS X and Linux.
Namespaces
Namespace | Description
Emgu.CV | Wrapper of OpenCV's image processing functions. Base functions (L1) can be found in CvInvoke class
Emgu.CV.Aruco | ArUco Marker Detection
Emgu.CV.BgSegm | Background Segmentation.
Emgu.CV.Bioinspired | Biologically inspired vision models and derivated tools
Emgu.CV.Cuda | NVidia Cuda image processing functions
Emgu.CV.Cvb | Contains interface for the CvBlob library
Emgu.CV.CvEnum | OpenCV Enumeration
Emgu.CV.Dnn | Deep Neural Network module
Emgu.CV.Dpm | Deformable Part-based Models
Emgu.CV.Face | The module contains some recently added functionality that has not been stabilized, or functionality that is considered optional.
Emgu.CV.Features2D | Contains classes for 2D feature detection, extraction and matching.
Emgu.CV.Flann | Fast Library for Approximate Nearest Neighbors (Marius Muja and David Lowe)
Emgu.CV.Freetype | Drawing UTF-8 strings with freetype/harfbuzz
Emgu.CV.Fuzzy | Fuzzy image processing
Emgu.CV.Geodetic | Contains library that can be use for geomatic transformation.
Emgu.CV.Hfs | Hierarchical Feature Selection for Efficient Image Segmentation
Emgu.CV.ImgHash | The module brings implementations of different image hashing algorithms.
Emgu.CV.ML | Wrapper of OpenCV's Machine Learning Library
Emgu.CV.ML.MlEnum | OpenCV's Machine Learning enumeration
Emgu.CV.Ocl | Open CL module
Emgu.CV.OCR | Optical character recognition. Wraps the tesseract-ocr engine.
Emgu.CV.PhaseUnwrapping | Phase Unwrapping API
Emgu.CV.Plot | This Plot module allows you to easily plot data in 1D or 2D.
Emgu.CV.PpfMatch3d |
Emgu.CV.Quality |
Emgu.CV.Reflection | Code that use reflection to get image information from Emgu CV objects
Emgu.CV.Saliency | Saliency API
Emgu.CV.Shape | The module contains algorithms that embed a notion of shape distance. These algorithms may be used for shape matching and retrieval, or shape comparison.
Emgu.CV.Stereo |
Emgu.CV.Stitching | Image stitching
Emgu.CV.Structure | Wrapped OpenCV structures
Emgu.CV.Superres | The Super Resolution module contains a set of functions and classes that can be used to solve the problem of resolution enhancement.
Emgu.CV.Text | This module provides different algorithms for text detection and recognition in natural scene images.
Emgu.CV.Tiff | Contains writer classes that can be used to write different tiff formats, such as tile tiff and geotiff.
Emgu.CV.Tracking | Long-term optical tracking API
Emgu.CV.Util | A collection of utilities used by Emgu.CV projects
Emgu.CV.VideoStab | The video stabilization module contains a set of functions and classes that can be used to solve the problem of video stabilization.
Emgu.CV.XFeatures2D | Extra 2D Features Framework
Emgu.CV.XImgproc | Extended Image Processing
Emgu.CV.XObjdetect | Extended object detection
Emgu.CV.XPhoto | Additional photo processing algorithms
Emgu.Util | A collection of utilities used by Emgu projects
Emgu.Util.TypeEnum | Various enumeration for Emgu.Util namespace
For questions and discussions please visit http://www.emgu.com/forum

2019 Emgu Corporation, All Rights Reserved,

Send comments on this topic to support@emgu.com


Emgu.CV Namespace

Wrapper of OpenCV's image processing functions. Base functions (L1) can be found in CvInvoke class
Classes
 | Class | Description
Public class | Affine3d | The Affine3 matrix, double precision.
Public class | AlgorithmExtensions | Extension methods to the IAlgorithm interface
Public class | AlignExposures | The base class for algorithms that align images of the same scene with different exposures
Public class | AlignMTB | This algorithm converts images to median threshold bitmaps (1 for pixels brighter than median luminance and 0 otherwise) and than aligns the resulting bitmaps using bit operations.
Public class | Backend | The backend for video
Public class | BackgroundSubtractorExtension | A static class that provide extension methods to backgroundSubtractor
Public class | BackgroundSubtractorKNN | K-nearest neighbors - based Background/Foreground Segmentation Algorithm.
Public class | BackgroundSubtractorMOG2 | The class implements the following algorithm: "Improved adaptive Gaussian mixture model for background subtraction" Z.Zivkovic International Conference Pattern Recognition, UK, August, 2004. http://www.zoranz.net/Publications/zivkovic2004ICPR.pdf
Public class | CalibrateCRF | The base class for camera response calibration algorithms.
Public class | CalibrateDebevec | Inverse camera response function is extracted for each brightness value by minimizing an objective function as linear system. Objective function is constructed using pixel values on the same position in all images, extra term is added to make the result smoother.
Public class | CalibrateRobertson | Inverse camera response function is extracted for each brightness value by minimizing an objective function as linear system. This algorithm uses all image pixels.
Public class | CascadeClassifier | The Cascade Classifier
Public class | ColorInfoAttribute | Attribute used to specify color information
Public class | ContribInvoke | Class that contains entry points for the Contrib module.
Public class | ConvolutionKernelF | A convolution kernel
Public class | CvArrayTDepth | Wrapped CvArr
Public class | CvInvoke | Class that provide access to native OpenCV functions
Public class | CvInvokeCvErrorCallback | Define an error callback that can be registered using cvRedirectError function
Public class | CvString | Wrapper for cv::String. This class support UTF-8 chars.
Public class | DenseHistogram | A Uniform Multi-dimensional Dense Histogram
Public class | DenseOpticalFlowExtensions | Extension methods for IDenseOpticalFlow
Public class | DenseRLOFOpticalFlow | Fast dense optical flow computation based on robust local optical flow (RLOF) algorithms and sparse-to-dense interpolation scheme.
Public class | DenseRLOFOpticalFlowInterpolationType | Interpolation type used to compute the dense optical flow.
Public class | DISOpticalFlow | DIS optical flow algorithm. This class implements the Dense Inverse Search(DIS) optical flow algorithm.Includes three presets with preselected parameters to provide reasonable trade-off between speed and quality.However, even the slowest preset is still relatively fast, use DeepFlow if you need better quality and don't care about speed. More details about the algorithm can be found at: Till Kroeger, Radu Timofte, Dengxin Dai, and Luc Van Gool. Fast optical flow using dense inverse search. In Proceedings of the European Conference on Computer Vision (ECCV), 2016.
Public class | DISOpticalFlowPreset | Preset
Public class | DualTVL1OpticalFlow | Dual TV L1 Optical Flow Algorithm.
Public class | FarnebackOpticalFlow | Class computing a dense optical flow using the Gunnar Farneback's algorithm.
Public class | FileNode | File Storage Node class. The node is used to store each and every element of the file storage opened for reading. When XML/YAML file is read, it is first parsed and stored in the memory as a hierarchical collection of nodes. Each node can be a "leaf" that is contain a single number or a string, or be a collection of other nodes. There can be named collections (mappings) where each element has a name and it is accessed by a name, and ordered collections (sequences) where elements do not have names but rather accessed by index. Type of the file node can be determined using FileNode::type method. Note that file nodes are only used for navigating file storages opened for reading. When a file storage is opened for writing, no data is stored in memory after it is written.
Public class | FileNodeType | Type of the file storage node
Public class | FileStorage | XML/YAML file storage class that encapsulates all the information necessary for writing or reading data to/from a file.
Public class | FileStorageMode | File storage mode
Public class | Fisheye | Fisheye Camera model
Public class | FisheyeCalibrationFlag | Fisheye calibration flag.
Public class | HOGDescriptor | A HOG descriptor
Public class | IInputArrayExtensions | Extension methods for IInputArrays
Public class | ImageTColor, TDepth | An Image is a wrapper to IplImage of OpenCV.
Public class | InputArray | This is the proxy class for passing read-only input arrays into OpenCV functions.
Public class | InputArrayType | Input array type
Public class | InputOutputArray | This type is very similar to InputArray except that it is used for input/output function parameters.
Public class | KalmanFilter | The class implements a standard Kalman filter. However, you can modify transitionMatrix, controlMatrix, and measurementMatrix to get an extended Kalman filter functionality.
Public class | LineIterator | The class is used to iterate over all the pixels on the raster line segment connecting two specified points.
Public class | MapTColor, TDepth | A Map is similar to an Image, except that the location of the pixels is defined by its area and resolution
Public class | Mat | The equivalent of cv::Mat
Public class | MatDataAllocator | Matrix data allocator. Base class for Mat that handles the matrix data allocation and deallocation
Public class | MatNDTDepth | A MatND is a wrapper to cvMatND of OpenCV.
Public class | MatrixTDepth | A Matrix is a wrapper to cvMat of OpenCV.
Public class | MergeDebevec | The resulting HDR image is calculated as weighted average of the exposures considering exposure values and camera response.
Public class | MergeExposures | The base class algorithms that can merge exposure sequence to a single image.
Public class | MergeMertens | Pixels are weighted using contrast, saturation and well-exposedness measures, than images are combined using laplacian pyramids. The resulting image weight is constructed as weighted average of contrast, saturation and well-exposedness measures. The resulting image doesn't require tonemapping and can be converted to 8-bit image by multiplying by 255, but it's recommended to apply gamma correction and/or linear tonemapping.
Public class | MergeRobertson | The resulting HDR image is calculated as weighted average of the exposures considering exposure values and camera response
Public class | Moments | The equivalent of cv::Moments
Public class | MotionHistory | The motion history class
Public class | OptFlowDeepFlow | DeepFlow optical flow algorithm implementation.
Public class | OpticalFlowPCAFlow | PCAFlow algorithm.
Public class | OutputArray | This type is very similar to InputArray except that it is used for output function parameters.
Public class | PointCollection | A collection of points
Public class | QRCodeDetector | A QR code detector
Public class | Quaternions | A unit quaternions that defines rotation in 3D
Public class | RLOFOpticalFlowParameter | This is used store and set up the parameters of the robust local optical flow (RLOF) algorithm.
Public class | RLOFOpticalFlowParameterSolverType | The solver type
Public class | RLOFOpticalFlowParameterSupportRegionType | The support region type
Public class | RNG | Random Number Generator.
Public class | RNGDistType | Distribution type
Public class | RotationMatrix2D | A (2x3) 2D rotation matrix. This Matrix defines an Affine Transform
Public class | RotationVector3D | A (3x1) Rodrigues rotation vector. Rotation vector is a compact representation of rotation matrix. Direction of the rotation vector is the rotation axis and the length of the vector is the rotation angle around the axis.
Public class | ScalarArray | An implementation of IInputArray intented to convert data to IInputArray
Public class | SparseMatrixTDepth | Create a sparse matrix
Public class | SparseOpticalFlowExtensions | Extension methods for ISparseOpticalFlow
Public class | SparsePyrLKOpticalFlow | The class can calculate an optical flow for a sparse feature set using the iterative Lucas-Kanade method with pyramids.
Public class | SparseRLOFOpticalFlow | Class used for calculation sparse optical flow and feature tracking with robust local optical flow (RLOF) algorithms.
Public class | StereoBM | Class for computing stereo correspondence using the block matching algorithm, introduced and contributed to OpenCV by K. Konolige.
Public class | StereoSGBM | This is a variation of "Stereo Processing by Semiglobal Matching and Mutual Information" by Heiko Hirschmuller. We match blocks rather than individual pixels, thus the algorithm is called SGBM (Semi-global block matching)
Public class | StereoSGBMMode | The SGBM mode
Public class | Subdiv2D | Planar Subdivision, can be use to compute Delaunnay's triangulation or Voroni diagram.
Public class | TimedImageTColor, TDepth | The Image which contains time stamp which specified what time this image is created
Public class | Tonemap | Base class for tonemapping algorithms - tools that are used to map HDR image to 8-bit range.
Public class | TonemapDrago | Adaptive logarithmic mapping is a fast global tonemapping algorithm that scales the image in logarithmic domain. Since it's a global operator the same function is applied to all the pixels, it is controlled by the bias parameter.
Public class | TonemapMantiuk | This algorithm transforms image to contrast using gradients on all levels of gaussian pyramid, transforms contrast values to HVS response and scales the response. After this the image is reconstructed from new contrast values.
Public class | TonemapReinhard | This is a global tonemapping operator that models human visual system. Mapping function is controlled by adaptation parameter, that is computed using light adaptation and color adaptation.
Public class | UMat | The equivalent of cv::Mat, should only be used if you know what you are doing. In most case you should use the Matrix class instead
Public class | UMatUsage | Allocation usage.
Public class | VariationalRefinement | This class implements variational refinement of the input flow field.
Public class | VideoCapture | Capture images from either camera or video file.
Public class | VideoCaptureAPI | VideoCapture API backends identifier.
Public class | VideoCaptureCaptureModuleType | The type of capture source
Public class | VideoWriter | Create a video writer that write images to video format
Public class | VideoWriterWriterProperty | The VideoWriter property
Public class | Viz3d | Represents a 3D visualizer window.
Public class | VoronoiFacet | A Voronoi Facet
Public class | WArrow | This 3D Widget defines an arrow.
Public class | WCircle | This 3D Widget defines a circle.
Public class | WCloud | This 3D Widget defines a point cloud.
Public class | WCone | This 3D Widget defines a cone.
Public class | WCoordinateSystem | This 3D Widget represents a coordinate system.
Public class | WCube | This 3D Widget defines a cube.
Public class | WCylinder | This 3D Widget defines a cylinder.
Public class | WText | This 2D Widget represents text overlay.
Interfaces
 | Interface | Description
Public interface | IAlgorithm | Interface to the algorithm class
Public interface | IBackgroundSubtractor | Interface to the BackgroundSubtractor class
Public interface | ICapture | The interface that is used for WCF to provide a image capture service
Public interface | IColor | A color type
Public interface | IConvexPolygon | An interface for the convex polygon
Public interface | IConvexPolygonF | An interface for the convex polygon
Public interface | IDenseOpticalFlow | Dense Optical flow
Public interface | IDuplexCapture | The interface to request a duplex image capture
Public interface | IDuplexCaptureCallback | The interface for DuplexCaptureCallback
Public interface | IInputArray | This is the proxy class for passing read-only input arrays into OpenCV functions.
Public interface | IInputArrayOfArrays | InputArrayOfArrays
Public interface | IInputOutputArray | This type is very similar to InputArray except that it is used for input/output function parameters.
Public interface | IOutputArray | This type is very similar to InputArray except that it is used for output function parameters.
Public interface | IOutputArrayOfArrays | OutputArrayOfArrays
Public interface | ISparseOpticalFlow | Sparse Optical flow
Public interface | IStereoMatcher | The stereo matcher interface
Public interface | IWidget | Interface for all widgets
Public interface | IWidget2D | Interface for all widget2D
Public interface | IWidget3D | Interface for all widget3D


Affine3d Class

The Affine3 matrix, double precision.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVAffine3d

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Affine3d : UnmanagedObject
Public Class Affine3d
    Inherits UnmanagedObject
public ref class Affine3d : public UnmanagedObject
type Affine3d =
    class
        inherit UnmanagedObject
    end

The Affine3d type exposes the following members.

Constructors
 | Name | Description
Public method | Affine3d | Create an empty Affine3, double precision matrix
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Affine3 model (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the 3x3 matrix's value as a double vector (of size 9)
 | Identity | Create a new identity matrix
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Rotate | Rotate the Affine3 matrix by a Rodrigues vector
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate | Translate the Affine3 matrix by the given value
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


Affine3d Constructor

Create an empty Affine3, double precision matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Affine3d()
Public Sub New
public:
Affine3d()
new : unit -> Affine3d
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d Properties

The Affine3d type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d Methods

The Affine3d type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Affine3 model (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the 3x3 matrix's value as a double vector (of size 9)
 | Identity | Create a new identity matrix
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Rotate | Rotate the Affine3 matrix by a Rodrigues vector
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate | Translate the Affine3 matrix by the given value
Top
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d.DisposeObject Method

Emgu CV Library Documentation

Affine3dDisposeObject Method

Release the unmanaged memory associated with this Affine3 model

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d.GetValues Method

Affine3dGetValues Method

Get the 3x3 matrix's value as a double vector (of size 9)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double[] GetValues()
Public Function GetValues As Double()
public:
array<double>^ GetValues()
member GetValues : unit -> float[]

Return Value

Type: Double
The 3x3 matrix's value as a double vector (of size 9)
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d.Identity Method

Affine3dIdentity Method

Create a new identity matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Affine3d Identity()
Public Shared Function Identity As Affine3d
public:
static Affine3d^ Identity()
static member Identity : unit -> Affine3d

Return Value

Type: Affine3d
The identity affine 3d matrix
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d.Rotate Method

Affine3dRotate Method

Rotate the Affine3 matrix by a Rodrigues vector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Affine3d Rotate(
    double r0,
    double r1,
    double r2
)
Public Function Rotate (
    r0 As Double,
    r1 As Double,
    r2 As Double
) As Affine3d
public:
Affine3d^ Rotate(
    double r0,
    double r1,
    double r2
)
member Rotate :
        r0 : float *
        r1 : float *
        r2 : float -> Affine3d

Parameters

r0
Type: SystemDouble
Value of the Rodrigues vector
r1
Type: SystemDouble
Value of the Rodrigues vector
r2
Type: SystemDouble
Value of the Rodrigues vector

Return Value

Type: Affine3d
The rotated Affine3 matrix
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d.Translate Method

Affine3dTranslate Method

Translate the Affine3 matrix by the given value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Affine3d Translate(
    double t0,
    double t1,
    double t2
)
Public Function Translate (
    t0 As Double,
    t1 As Double,
    t2 As Double
) As Affine3d
public:
Affine3d^ Translate(
    double t0,
    double t1,
    double t2
)
member Translate :
        t0 : float *
        t1 : float *
        t2 : float -> Affine3d

Parameters

t0
Type: SystemDouble
Value of the translation vector
t1
Type: SystemDouble
Value of the translation vector
t2
Type: SystemDouble
Value of the translation vector

Return Value

Type: Affine3d
The translated Affine3 matrix
See Also

Reference

Affine3d Class
Emgu.CV Namespace


Affine3d Fields

The Affine3d type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Affine3d Class
Emgu.CV Namespace


AlgorithmExtensions Class

Extension methods to the IAlgorithm interface
Inheritance Hierarchy
SystemObject
Emgu.CVAlgorithmExtensions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class AlgorithmExtensions
<ExtensionAttribute>
Public NotInheritable Class AlgorithmExtensions
[ExtensionAttribute]
public ref class AlgorithmExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type AlgorithmExtensions =  class end

The AlgorithmExtensions type exposes the following members.

Methods
Name | Description
Clear | Clear the algorithm
GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string.
IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read.
Load | Loads algorithm from the file
LoadFromString | Loads algorithm from a String
Read | Reads algorithm parameters from a file storage.
Save | Save the algorithm to file
SaveToString | Save the algorithm to a string
Write(IAlgorithm, FileStorage) | Stores algorithm parameters in a file storage
Write(IAlgorithm, FileStorage, String) | Stores algorithm parameters in a file storage
Top
See Also

Reference

Emgu.CV Namespace


AlgorithmExtensions Methods

The AlgorithmExtensions type exposes the following members.

Methods
Name | Description
Clear | Clear the algorithm
GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string.
IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read.
Load | Loads algorithm from the file
LoadFromString | Loads algorithm from a String
Read | Reads algorithm parameters from a file storage.
Save | Save the algorithm to file
SaveToString | Save the algorithm to a string
Write(IAlgorithm, FileStorage) | Stores algorithm parameters in a file storage
Write(IAlgorithm, FileStorage, String) | Stores algorithm parameters in a file storage
Top
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.Clear Method

AlgorithmExtensionsClear Method

Clear the algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Clear(
    this IAlgorithm algorithm
)
<ExtensionAttribute>
Public Shared Sub Clear (
    algorithm As IAlgorithm
)
public:
[ExtensionAttribute]
static void Clear(
    IAlgorithm^ algorithm
)
[<ExtensionAttribute>]
static member Clear :
        algorithm : IAlgorithm -> unit

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.GetDefaultName Method

AlgorithmExtensionsGetDefaultName Method

Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultName(
    this IAlgorithm algorithm
)
<ExtensionAttribute>
Public Shared Function GetDefaultName (
    algorithm As IAlgorithm
) As String
public:
[ExtensionAttribute]
static String^ GetDefaultName(
    IAlgorithm^ algorithm
)
[<ExtensionAttribute>]
static member GetDefaultName :
        algorithm : IAlgorithm -> string

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm

Return Value

Type: String
Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.IsEmpty Method

AlgorithmExtensionsIsEmpty Method

Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsEmpty(
    this IAlgorithm algorithm
)
<ExtensionAttribute>
Public Shared Function IsEmpty (
    algorithm As IAlgorithm
) As Boolean
public:
[ExtensionAttribute]
static bool IsEmpty(
    IAlgorithm^ algorithm
)
[<ExtensionAttribute>]
static member IsEmpty :
        algorithm : IAlgorithm -> bool

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm

Return Value

Type: Boolean
Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.Load Method

AlgorithmExtensionsLoad Method

Loads algorithm from the file

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Load(
    this IAlgorithm algorithm,
    string fileName,
    string objName = null,
    string encoding = null
)
<ExtensionAttribute>
Public Shared Sub Load (
    algorithm As IAlgorithm,
    fileName As String,
    Optional objName As String = Nothing,
    Optional encoding As String = Nothing
)
public:
[ExtensionAttribute]
static void Load(
    IAlgorithm^ algorithm,
    String^ fileName,
    String^ objName = nullptr,
    String^ encoding = nullptr
)
[<ExtensionAttribute>]
static member Load :
        algorithm : IAlgorithm *
        fileName : string *
        ?objName : string *
        ?encoding : string
(* Defaults:
        let _objName = defaultArg objName null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm
fileName
Type: SystemString
Name of the file to read.
objName (Optional)
Type: SystemString
The optional name of the node to read (if empty, the first top-level node will be used)
encoding (Optional)
Type: SystemString
Encoding of the file. Note that UTF-16 XML encoding is not supported currently and you should use 8-bit encoding instead of it.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.LoadFromString Method

AlgorithmExtensionsLoadFromString Method

Loads algorithm from a String

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void LoadFromString(
    this IAlgorithm algorithm,
    string strModel,
    string objName = null,
    string encoding = null
)
<ExtensionAttribute>
Public Shared Sub LoadFromString (
    algorithm As IAlgorithm,
    strModel As String,
    Optional objName As String = Nothing,
    Optional encoding As String = Nothing
)
public:
[ExtensionAttribute]
static void LoadFromString(
    IAlgorithm^ algorithm,
    String^ strModel,
    String^ objName = nullptr,
    String^ encoding = nullptr
)
[<ExtensionAttribute>]
static member LoadFromString :
        algorithm : IAlgorithm *
        strModel : string *
        ?objName : string *
        ?encoding : string
(* Defaults:
        let _objName = defaultArg objName null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm
strModel
Type: SystemString
The string variable containing the model you want to load.
objName (Optional)
Type: SystemString
The optional name of the node to read (if empty, the first top-level node will be used)
encoding (Optional)
Type: SystemString
Encoding of the file. Note that UTF-16 XML encoding is not supported currently and you should use 8-bit encoding instead of it.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.Read Method

AlgorithmExtensionsRead Method

Reads algorithm parameters from a file storage.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Read(
    this IAlgorithm algorithm,
    FileNode node
)
<ExtensionAttribute>
Public Shared Sub Read (
    algorithm As IAlgorithm,
    node As FileNode
)
public:
[ExtensionAttribute]
static void Read(
    IAlgorithm^ algorithm,
    FileNode^ node
)
[<ExtensionAttribute>]
static member Read :
        algorithm : IAlgorithm *
        node : FileNode -> unit

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm.
node
Type: Emgu.CVFileNode
The node from file storage.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.Save Method

AlgorithmExtensionsSave Method

Save the algorithm to file

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    this IAlgorithm algorithm,
    string fileName
)
<ExtensionAttribute>
Public Shared Sub Save (
    algorithm As IAlgorithm,
    fileName As String
)
public:
[ExtensionAttribute]
static void Save(
    IAlgorithm^ algorithm,
    String^ fileName
)
[<ExtensionAttribute>]
static member Save :
        algorithm : IAlgorithm *
        fileName : string -> unit

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm
fileName
Type: SystemString
The file name where this algorithm will be saved to

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.SaveToString Method

AlgorithmExtensionsSaveToString Method

Save the algorithm to a string

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string SaveToString(
    this IAlgorithm algorithm,
    string format = ".xml"
)
<ExtensionAttribute>
Public Shared Function SaveToString (
    algorithm As IAlgorithm,
    Optional format As String = ".xml"
) As String
public:
[ExtensionAttribute]
static String^ SaveToString(
    IAlgorithm^ algorithm,
    String^ format = L".xml"
)
[<ExtensionAttribute>]
static member SaveToString :
        algorithm : IAlgorithm *
        ?format : string
(* Defaults:
        let _format = defaultArg format ".xml"
*)
-> string

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm
format (Optional)
Type: SystemString
file format, can be .xml or .yml

Return Value

Type: String
The algorithm as an yml string

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.Write Method

AlgorithmExtensionsWrite Method

Overload List
Name | Description
Write(IAlgorithm, FileStorage) | Stores algorithm parameters in a file storage
Write(IAlgorithm, FileStorage, String) | Stores algorithm parameters in a file storage
Top
See Also

Reference

AlgorithmExtensions Class
Emgu.CV Namespace


AlgorithmExtensions.Write Method (IAlgorithm, FileStorage)

AlgorithmExtensionsWrite Method (IAlgorithm, FileStorage)

http://www.emgu.com
Stores algorithm parameters in a file storage

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Write(
    this IAlgorithm algorithm,
    FileStorage storage
)
<ExtensionAttribute>
Public Shared Sub Write (
    algorithm As IAlgorithm,
    storage As FileStorage
)
public:
[ExtensionAttribute]
static void Write(
    IAlgorithm^ algorithm,
    FileStorage^ storage
)
[<ExtensionAttribute>]
static member Write :
        algorithm : IAlgorithm *
        storage : FileStorage -> unit

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm.
storage
Type: Emgu.CVFileStorage
The storage.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Write Overload
Emgu.CV Namespace


AlgorithmExtensions.Write Method (IAlgorithm, FileStorage, String)

AlgorithmExtensionsWrite Method (IAlgorithm, FileStorage, String)

http://www.emgu.com
Stores algorithm parameters in a file storage

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Write(
    this IAlgorithm algorithm,
    FileStorage storage,
    string name
)
<ExtensionAttribute>
Public Shared Sub Write (
    algorithm As IAlgorithm,
    storage As FileStorage,
    name As String
)
public:
[ExtensionAttribute]
static void Write(
    IAlgorithm^ algorithm,
    FileStorage^ storage,
    String^ name
)
[<ExtensionAttribute>]
static member Write :
        algorithm : IAlgorithm *
        storage : FileStorage *
        name : string -> unit

Parameters

algorithm
Type: Emgu.CVIAlgorithm
The algorithm.
storage
Type: Emgu.CVFileStorage
The storage.
name
Type: SystemString
Simplified API for language bindings

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AlgorithmExtensions Class
Write Overload
Emgu.CV Namespace


AlignExposures Class

The base class for algorithms that align images of the same scene with different exposures
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVAlignExposures
Emgu.CVAlignMTB

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class AlignExposures : UnmanagedObject
Public MustInherit Class AlignExposures
    Inherits UnmanagedObject
public ref class AlignExposures abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type AlignExposures =
    class
        inherit UnmanagedObject
    end

The AlignExposures type exposes the following members.

Constructors
 | Name | Description
Protected method | AlignExposures | Initializes a new instance of the AlignExposures class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointer that points to the CalibrateCRF object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Aligns images.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _alignExposuresPtr | The pointer to the native AlignExposures object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


AlignExposures Constructor

Initializes a new instance of the AlignExposures class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected AlignExposures()
Protected Sub New
protected:
AlignExposures()
new : unit -> AlignExposures
See Also

Reference

AlignExposures Class
Emgu.CV Namespace


AlignExposures Properties

The AlignExposures type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AlignExposures Class
Emgu.CV Namespace


AlignExposures Methods

The AlignExposures type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointer that points to the CalibrateCRF object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Aligns images.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AlignExposures Class
Emgu.CV Namespace


AlignExposures.DisposeObject Method

AlignExposuresDisposeObject Method

Reset the pointer that points to the CalibrateCRF object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

AlignExposures Class
Emgu.CV Namespace


AlignExposures.Process Method

AlignExposuresProcess Method

Aligns images.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Process(
    IInputArrayOfArrays src,
    VectorOfMat dst,
    IInputArray times,
    IInputArray response
)
Public Sub Process (
    src As IInputArrayOfArrays,
    dst As VectorOfMat,
    times As IInputArray,
    response As IInputArray
)
public:
void Process(
    IInputArrayOfArrays^ src,
    VectorOfMat^ dst,
    IInputArray^ times,
    IInputArray^ response
)
member Process :
        src : IInputArrayOfArrays *
        dst : VectorOfMat *
        times : IInputArray *
        response : IInputArray -> unit

Parameters

src
Type: Emgu.CVIInputArrayOfArrays
vector of input images
dst
Type: Emgu.CV.UtilVectorOfMat
vector of aligned images
times
Type: Emgu.CVIInputArray
vector of exposure time values for each image
response
Type: Emgu.CVIInputArray
256x1 matrix with inverse camera response function for each pixel value, it should have the same number of channels as images.
See Also

Reference

AlignExposures Class
Emgu.CV Namespace


AlignExposures Fields

The AlignExposures type exposes the following members.

Fields
 | Name | Description
Protected field | _alignExposuresPtr | The pointer to the native AlignExposures object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AlignExposures Class
Emgu.CV Namespace


AlignExposures._alignExposuresPtr Field

AlignExposures_alignExposuresPtr Field

The pointer to the native AlignExposures object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _alignExposuresPtr
Protected _alignExposuresPtr As IntPtr
protected:
IntPtr _alignExposuresPtr
val mutable _alignExposuresPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

AlignExposures Class
Emgu.CV Namespace


AlignMTB Class

This algorithm converts images to median threshold bitmaps (1 for pixels brighter than median luminance and 0 otherwise) and than aligns the resulting bitmaps using bit operations.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVAlignExposures
Emgu.CVAlignMTB

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class AlignMTB : AlignExposures
Public Class AlignMTB
    Inherits AlignExposures
public ref class AlignMTB : public AlignExposures
type AlignMTB =
    class
        inherit AlignExposures
    end

The AlignMTB type exposes the following members.

Constructors
 | Name | Description
Public method | AlignMTB | Create an AlignMTB object
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this AlignMTB object (Overrides AlignExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Aligns images. (Inherited from AlignExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _alignExposuresPtr | The pointer to the native AlignExposures object (Inherited from AlignExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


AlignMTB Constructor

Create an AlignMTB object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public AlignMTB(
    int maxBits = 6,
    int excludeRange = 4,
    bool cut = true
)
Public Sub New (
    Optional maxBits As Integer = 6,
    Optional excludeRange As Integer = 4,
    Optional cut As Boolean = true
)
public:
AlignMTB(
    int maxBits = 6,
    int excludeRange = 4,
    bool cut = true
)
new :
        ?maxBits : int *
        ?excludeRange : int *
        ?cut : bool
(* Defaults:
        let _maxBits = defaultArg maxBits 6
        let _excludeRange = defaultArg excludeRange 4
        let _cut = defaultArg cut true
*)
-> AlignMTB

Parameters

maxBits (Optional)
Type: SystemInt32
logarithm to the base 2 of maximal shift in each dimension. Values of 5 and 6 are usually good enough (31 and 63 pixels shift respectively).
excludeRange (Optional)
Type: SystemInt32
range for exclusion bitmap that is constructed to suppress noise around the median value.
cut (Optional)
Type: SystemBoolean
if true cuts images, otherwise fills the new regions with zeros.
See Also

Reference

AlignMTB Class
Emgu.CV Namespace


AlignMTB Properties

The AlignMTB type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AlignMTB Class
Emgu.CV Namespace


AlignMTB Methods

The AlignMTB type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this AlignMTB object (Overrides AlignExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Aligns images. (Inherited from AlignExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AlignMTB Class
Emgu.CV Namespace


AlignMTB.DisposeObject Method

AlignMTBDisposeObject Method

Release the unmanaged memory associated with this AlignMTB object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

AlignMTB Class
Emgu.CV Namespace


AlignMTB Fields

The AlignMTB type exposes the following members.

Fields
 | Name | Description
Protected field | _alignExposuresPtr | The pointer to the native AlignExposures object (Inherited from AlignExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AlignMTB Class
Emgu.CV Namespace


Backend Class

The backend for video
Inheritance Hierarchy
SystemObject
Emgu.CVBackend

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Backend
Public Class Backend
public ref class Backend
type Backend =  class end

The Backend type exposes the following members.

Constructors
 | Name | Description
Public method | Backend | Create a backend given its id
Top
Properties
 | Name | Description
Public property | ID | The ID of the backend.
Public property | Name | The name of the backend
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.CV Namespace


Backend Constructor

Create a backend given its id

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Backend(
    int id
)
Public Sub New (
    id As Integer
)
public:
Backend(
    int id
)
new :
        id : int -> Backend

Parameters

id
Type: SystemInt32
The id of the backend
See Also

Reference

Backend Class
Emgu.CV Namespace


Backend Properties

The Backend type exposes the following members.

Properties
 | Name | Description
Public property | ID | The ID of the backend.
Public property | Name | The name of the backend
Top
See Also

Reference

Backend Class
Emgu.CV Namespace


Backend.ID Property

BackendID Property

The ID of the backend.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get
public:
property int ID {
    int get ();
}
member ID : int with get

Property Value

Type: Int32
See Also

Reference

Backend Class
Emgu.CV Namespace


Backend.Name Property

BackendName Property

The name of the backend

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

Backend Class
Emgu.CV Namespace


Backend Methods

The Backend type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Backend Class
Emgu.CV Namespace


BackgroundSubtractorExtension Class

A static class that provide extension methods to backgroundSubtractor
Inheritance Hierarchy
SystemObject
Emgu.CVBackgroundSubtractorExtension

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class BackgroundSubtractorExtension
<ExtensionAttribute>
Public NotInheritable Class BackgroundSubtractorExtension
[ExtensionAttribute]
public ref class BackgroundSubtractorExtension abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type BackgroundSubtractorExtension =  class end

The BackgroundSubtractorExtension type exposes the following members.

Methods
Name | Description
Apply | Update the background model
GetBackgroundImage | Computes a background image.
Top
See Also

Reference

Emgu.CV Namespace


BackgroundSubtractorExtension Methods

The BackgroundSubtractorExtension type exposes the following members.

Methods
Name | Description
Apply | Update the background model
GetBackgroundImage | Computes a background image.
Top
See Also

Reference

BackgroundSubtractorExtension Class
Emgu.CV Namespace


BackgroundSubtractorExtension.Apply Method

BackgroundSubtractorExtensionApply Method

Update the background model

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Apply(
    this IBackgroundSubtractor subtractor,
    IInputArray image,
    IOutputArray fgMask,
    double learningRate = -1
)
<ExtensionAttribute>
Public Shared Sub Apply (
    subtractor As IBackgroundSubtractor,
    image As IInputArray,
    fgMask As IOutputArray,
    Optional learningRate As Double = -1
)
public:
[ExtensionAttribute]
static void Apply(
    IBackgroundSubtractor^ subtractor,
    IInputArray^ image,
    IOutputArray^ fgMask,
    double learningRate = -1
)
[<ExtensionAttribute>]
static member Apply :
        subtractor : IBackgroundSubtractor *
        image : IInputArray *
        fgMask : IOutputArray *
        ?learningRate : float
(* Defaults:
        let _learningRate = defaultArg learningRate -1
*)
-> unit

Parameters

subtractor
Type: Emgu.CVIBackgroundSubtractor
The background subtractor
image
Type: Emgu.CVIInputArray
The image that is used to update the background model
fgMask
Type: Emgu.CVIOutputArray
The output foreground mask
learningRate (Optional)
Type: SystemDouble
Use -1 for default

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IBackgroundSubtractor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BackgroundSubtractorExtension Class
Emgu.CV Namespace


BackgroundSubtractorExtension.GetBackgroundImage Method

BackgroundSubtractorExtensionGetBackgroundImage Method

Computes a background image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GetBackgroundImage(
    this IBackgroundSubtractor subtractor,
    IOutputArray backgroundImage
)
<ExtensionAttribute>
Public Shared Sub GetBackgroundImage (
    subtractor As IBackgroundSubtractor,
    backgroundImage As IOutputArray
)
public:
[ExtensionAttribute]
static void GetBackgroundImage(
    IBackgroundSubtractor^ subtractor,
    IOutputArray^ backgroundImage
)
[<ExtensionAttribute>]
static member GetBackgroundImage :
        subtractor : IBackgroundSubtractor *
        backgroundImage : IOutputArray -> unit

Parameters

subtractor
Type: Emgu.CVIBackgroundSubtractor
The background subtractor
backgroundImage
Type: Emgu.CVIOutputArray
The output background image

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IBackgroundSubtractor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Sometimes the background image can be very blurry, as it contain the average background statistics.
See Also

Reference

BackgroundSubtractorExtension Class
Emgu.CV Namespace


BackgroundSubtractorKNN Class

K-nearest neighbors - based Background/Foreground Segmentation Algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVBackgroundSubtractorKNN

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSubtractorKNN : UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
Public Class BackgroundSubtractorKNN
    Inherits UnmanagedObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class BackgroundSubtractorKNN : public UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
type BackgroundSubtractorKNN =
    class
        inherit UnmanagedObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The BackgroundSubtractorKNN type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundSubtractorKNN | Create a K-nearest neighbors - based Background/Foreground Segmentation Algorithm.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | DetectShadows | If true, the algorithm detects shadows and marks them.
Public property | Dist2Threshold | The threshold on the squared distance between the pixel and the sample to decide whether a pixel is close to a data sample.
Public property | History | The number of last frames that affect the background model
Public property | KNNSamples | The number of neighbours, the k in the kNN. K is the number of samples that need to be within dist2Threshold in order to decide that pixel is matching the kNN background model.
Public property | NSamples | The number of data samples in the background model
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShadowThreshold | A shadow is detected if pixel is a darker version of the background. The shadow threshold (Tau in the paper) is a threshold defining how much darker the shadow can be. Tau= 0.5 means that if a pixel is more than twice darker then it is not shadow.
Public property | ShadowValue | Shadow value is the value used to mark shadows in the foreground mask. Default value is 127. Value 0 in the mask always means background, 255 means foreground.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


BackgroundSubtractorKNN Constructor

Create a K-nearest neighbors - based Background/Foreground Segmentation Algorithm.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundSubtractorKNN(
    int history,
    double dist2Threshold,
    bool detectShadows
)
Public Sub New (
    history As Integer,
    dist2Threshold As Double,
    detectShadows As Boolean
)
public:
BackgroundSubtractorKNN(
    int history,
    double dist2Threshold,
    bool detectShadows
)
new :
        history : int *
        dist2Threshold : float *
        detectShadows : bool -> BackgroundSubtractorKNN

Parameters

history
Type: SystemInt32
Length of the history.
dist2Threshold
Type: SystemDouble
Threshold on the squared distance between the pixel and the sample to decide whether a pixel is close to that sample. This parameter does not affect the background update.
detectShadows
Type: SystemBoolean
If true, the algorithm will detect shadows and mark them. It decreases the speed a bit, so if you do not need this feature, set the parameter to false.
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN Properties

The BackgroundSubtractorKNN type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | DetectShadows | If true, the algorithm detects shadows and marks them.
Public property | Dist2Threshold | The threshold on the squared distance between the pixel and the sample to decide whether a pixel is close to a data sample.
Public property | History | The number of last frames that affect the background model
Public property | KNNSamples | The number of neighbours, the k in the kNN. K is the number of samples that need to be within dist2Threshold in order to decide that pixel is matching the kNN background model.
Public property | NSamples | The number of data samples in the background model
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShadowThreshold | A shadow is detected if pixel is a darker version of the background. The shadow threshold (Tau in the paper) is a threshold defining how much darker the shadow can be. Tau= 0.5 means that if a pixel is more than twice darker then it is not shadow.
Public property | ShadowValue | Shadow value is the value used to mark shadows in the foreground mask. Default value is 127. Value 0 in the mask always means background, 255 means foreground.
Top
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.AlgorithmPtr Property

BackgroundSubtractorKNNAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.BackgroundSubtractorPtr Property

BackgroundSubtractorKNNBackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.DetectShadows Property

BackgroundSubtractorKNNDetectShadows Property

If true, the algorithm detects shadows and marks them.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DetectShadows { get; set; }
Public Property DetectShadows As Boolean
    Get
    Set
public:
property bool DetectShadows {
    bool get ();
    void set (bool value);
}
member DetectShadows : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.Dist2Threshold Property

BackgroundSubtractorKNNDist2Threshold Property

The threshold on the squared distance between the pixel and the sample to decide whether a pixel is close to a data sample.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Dist2Threshold { get; set; }
Public Property Dist2Threshold As Double
    Get
    Set
public:
property double Dist2Threshold {
    double get ();
    void set (double value);
}
member Dist2Threshold : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.History Property

BackgroundSubtractorKNNHistory Property

The number of last frames that affect the background model

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int History { get; set; }
Public Property History As Integer
    Get
    Set
public:
property int History {
    int get ();
    void set (int value);
}
member History : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.KNNSamples Property

BackgroundSubtractorKNNKNNSamples Property

The number of neighbours, the k in the kNN. K is the number of samples that need to be within dist2Threshold in order to decide that pixel is matching the kNN background model.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int KNNSamples { get; set; }
Public Property KNNSamples As Integer
    Get
    Set
public:
property int KNNSamples {
    int get ();
    void set (int value);
}
member KNNSamples : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.NSamples Property

BackgroundSubtractorKNNNSamples Property

The number of data samples in the background model

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NSamples { get; set; }
Public Property NSamples As Integer
    Get
    Set
public:
property int NSamples {
    int get ();
    void set (int value);
}
member NSamples : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.ShadowThreshold Property

BackgroundSubtractorKNNShadowThreshold Property

A shadow is detected if pixel is a darker version of the background. The shadow threshold (Tau in the paper) is a threshold defining how much darker the shadow can be. Tau= 0.5 means that if a pixel is more than twice darker then it is not shadow.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ShadowThreshold { get; set; }
Public Property ShadowThreshold As Double
    Get
    Set
public:
property double ShadowThreshold {
    double get ();
    void set (double value);
}
member ShadowThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.ShadowValue Property

BackgroundSubtractorKNNShadowValue Property

Shadow value is the value used to mark shadows in the foreground mask. Default value is 127. Value 0 in the mask always means background, 255 means foreground.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ShadowValue { get; set; }
Public Property ShadowValue As Integer
    Get
    Set
public:
property int ShadowValue {
    int get ();
    void set (int value);
}
member ShadowValue : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN Methods

The BackgroundSubtractorKNN type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN.DisposeObject Method

BackgroundSubtractorKNNDisposeObject Method

Release all the unmanaged memory associated with this background model.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorKNN Fields

The BackgroundSubtractorKNN type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorKNN Class
Emgu.CV Namespace


BackgroundSubtractorMOG2 Class

The class implements the following algorithm: "Improved adaptive Gaussian mixture model for background subtraction" Z.Zivkovic International Conference Pattern Recognition, UK, August, 2004. http://www.zoranz.net/Publications/zivkovic2004ICPR.pdf
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVBackgroundSubtractorMOG2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSubtractorMOG2 : UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
Public Class BackgroundSubtractorMOG2
    Inherits UnmanagedObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class BackgroundSubtractorMOG2 : public UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
type BackgroundSubtractorMOG2 =
    class
        inherit UnmanagedObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The BackgroundSubtractorMOG2 type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundSubtractorMOG2 | Create an "Improved adaptive Gaussian mixture model for background subtraction".
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundRatio | If a foreground pixel keeps semi-constant value for about backgroundRatio * history frames, it's considered background and added to the model as a center of a new component. It corresponds to TB parameter in the paper.
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | ComplexityReductionThreshold | The maximum variance
Public property | DetectShadows | If true, the algorithm detects shadows and marks them.
Public property | History | The number of last frames that affect the background model
Public property | NMixtures | The number of gaussian components in the background model
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShadowThreshold | A shadow is detected if pixel is a darker version of the background. The shadow threshold (Tau in the paper) is a threshold defining how much darker the shadow can be. Tau= 0.5 means that if a pixel is more than twice darker then it is not shadow.
Public property | ShadowValue | Shadow value is the value used to mark shadows in the foreground mask. Default value is 127. Value 0 in the mask always means background, 255 means foreground.
Public property | VarInit | Tg=3*3=9 is default. A smaller Tg value generates more components. A higher Tg value may result in a small number of components but they can grow too large.
Public property | VarMax | The minimum variance
Public property | VarMin | The initial variance of each gaussian component
Public property | VarThreshold | The main threshold on the squared Mahalanobis distance to decide if the sample is well described by the background model or not. Related to Cthr from the paper.
Public property | VarThresholdGen | The variance threshold for the pixel-model match used for new mixture component generation. Threshold for the squared Mahalanobis distance that helps decide when a sample is close to the existing components (corresponds to Tg in the paper). If a pixel is not close to any component, it is considered foreground or added as a new component. 3 sigma =%gt
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


BackgroundSubtractorMOG2 Constructor

Create an "Improved adaptive Gaussian mixture model for background subtraction".

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundSubtractorMOG2(
    int history = 500,
    float varThreshold = 16f,
    bool shadowDetection = true
)
Public Sub New (
    Optional history As Integer = 500,
    Optional varThreshold As Single = 16F,
    Optional shadowDetection As Boolean = true
)
public:
BackgroundSubtractorMOG2(
    int history = 500,
    float varThreshold = 16f,
    bool shadowDetection = true
)
new :
        ?history : int *
        ?varThreshold : float32 *
        ?shadowDetection : bool
(* Defaults:
        let _history = defaultArg history 500
        let _varThreshold = defaultArg varThreshold 16f
        let _shadowDetection = defaultArg shadowDetection true
*)
-> BackgroundSubtractorMOG2

Parameters

history (Optional)
Type: SystemInt32
The length of the history.
varThreshold (Optional)
Type: SystemSingle
The maximum allowed number of mixture components. Actual number is determined dynamically per pixel.
shadowDetection (Optional)
Type: SystemBoolean
If true, the algorithm will detect shadows and mark them. It decreases the speed a bit, so if you do not need this feature, set the parameter to false.
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2 Properties

The BackgroundSubtractorMOG2 type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundRatio | If a foreground pixel keeps semi-constant value for about backgroundRatio * history frames, it's considered background and added to the model as a center of a new component. It corresponds to TB parameter in the paper.
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | ComplexityReductionThreshold | The maximum variance
Public property | DetectShadows | If true, the algorithm detects shadows and marks them.
Public property | History | The number of last frames that affect the background model
Public property | NMixtures | The number of gaussian components in the background model
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShadowThreshold | A shadow is detected if pixel is a darker version of the background. The shadow threshold (Tau in the paper) is a threshold defining how much darker the shadow can be. Tau= 0.5 means that if a pixel is more than twice darker then it is not shadow.
Public property | ShadowValue | Shadow value is the value used to mark shadows in the foreground mask. Default value is 127. Value 0 in the mask always means background, 255 means foreground.
Public property | VarInit | Tg=3*3=9 is default. A smaller Tg value generates more components. A higher Tg value may result in a small number of components but they can grow too large.
Public property | VarMax | The minimum variance
Public property | VarMin | The initial variance of each gaussian component
Public property | VarThreshold | The main threshold on the squared Mahalanobis distance to decide if the sample is well described by the background model or not. Related to Cthr from the paper.
Public property | VarThresholdGen | The variance threshold for the pixel-model match used for new mixture component generation. Threshold for the squared Mahalanobis distance that helps decide when a sample is close to the existing components (corresponds to Tg in the paper). If a pixel is not close to any component, it is considered foreground or added as a new component. 3 sigma =%gt
Top
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.AlgorithmPtr Property

BackgroundSubtractorMOG2AlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.BackgroundRatio Property

BackgroundSubtractorMOG2BackgroundRatio Property

If a foreground pixel keeps semi-constant value for about backgroundRatio * history frames, it's considered background and added to the model as a center of a new component. It corresponds to TB parameter in the paper.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double BackgroundRatio { get; set; }
Public Property BackgroundRatio As Double
    Get
    Set
public:
property double BackgroundRatio {
    double get ();
    void set (double value);
}
member BackgroundRatio : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.BackgroundSubtractorPtr Property

BackgroundSubtractorMOG2BackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.ComplexityReductionThreshold Property

BackgroundSubtractorMOG2ComplexityReductionThreshold Property

http://www.emgu.com
The maximum variance

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ComplexityReductionThreshold { get; set; }
Public Property ComplexityReductionThreshold As Double
    Get
    Set
public:
property double ComplexityReductionThreshold {
    double get ();
    void set (double value);
}
member ComplexityReductionThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.DetectShadows Property

BackgroundSubtractorMOG2DetectShadows Property

If true, the algorithm detects shadows and marks them.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DetectShadows { get; set; }
Public Property DetectShadows As Boolean
    Get
    Set
public:
property bool DetectShadows {
    bool get ();
    void set (bool value);
}
member DetectShadows : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.History Property

BackgroundSubtractorMOG2History Property

The number of last frames that affect the background model

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int History { get; set; }
Public Property History As Integer
    Get
    Set
public:
property int History {
    int get ();
    void set (int value);
}
member History : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.NMixtures Property

BackgroundSubtractorMOG2NMixtures Property

The number of gaussian components in the background model

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NMixtures { get; set; }
Public Property NMixtures As Integer
    Get
    Set
public:
property int NMixtures {
    int get ();
    void set (int value);
}
member NMixtures : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.ShadowThreshold Property

BackgroundSubtractorMOG2ShadowThreshold Property

A shadow is detected if pixel is a darker version of the background. The shadow threshold (Tau in the paper) is a threshold defining how much darker the shadow can be. Tau= 0.5 means that if a pixel is more than twice darker then it is not shadow.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ShadowThreshold { get; set; }
Public Property ShadowThreshold As Double
    Get
    Set
public:
property double ShadowThreshold {
    double get ();
    void set (double value);
}
member ShadowThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.ShadowValue Property

BackgroundSubtractorMOG2ShadowValue Property

Shadow value is the value used to mark shadows in the foreground mask. Default value is 127. Value 0 in the mask always means background, 255 means foreground.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ShadowValue { get; set; }
Public Property ShadowValue As Integer
    Get
    Set
public:
property int ShadowValue {
    int get ();
    void set (int value);
}
member ShadowValue : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.VarInit Property

BackgroundSubtractorMOG2VarInit Property

Tg=3*3=9 is default. A smaller Tg value generates more components. A higher Tg value may result in a small number of components but they can grow too large.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double VarInit { get; set; }
Public Property VarInit As Double
    Get
    Set
public:
property double VarInit {
    double get ();
    void set (double value);
}
member VarInit : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.VarMax Property

BackgroundSubtractorMOG2VarMax Property

The minimum variance

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double VarMax { get; set; }
Public Property VarMax As Double
    Get
    Set
public:
property double VarMax {
    double get ();
    void set (double value);
}
member VarMax : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.VarMin Property

BackgroundSubtractorMOG2VarMin Property

The initial variance of each gaussian component

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double VarMin { get; set; }
Public Property VarMin As Double
    Get
    Set
public:
property double VarMin {
    double get ();
    void set (double value);
}
member VarMin : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.VarThreshold Property

BackgroundSubtractorMOG2VarThreshold Property

The main threshold on the squared Mahalanobis distance to decide if the sample is well described by the background model or not. Related to Cthr from the paper.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double VarThreshold { get; set; }
Public Property VarThreshold As Double
    Get
    Set
public:
property double VarThreshold {
    double get ();
    void set (double value);
}
member VarThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.VarThresholdGen Property

BackgroundSubtractorMOG2VarThresholdGen Property

The variance threshold for the pixel-model match used for new mixture component generation. Threshold for the squared Mahalanobis distance that helps decide when a sample is close to the existing components (corresponds to Tg in the paper). If a pixel is not close to any component, it is considered foreground or added as a new component. 3 sigma =%gt

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double VarThresholdGen { get; set; }
Public Property VarThresholdGen As Double
    Get
    Set
public:
property double VarThresholdGen {
    double get ();
    void set (double value);
}
member VarThresholdGen : float with get, set

Property Value

Type: Double
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2 Methods

The BackgroundSubtractorMOG2 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2.DisposeObject Method

BackgroundSubtractorMOG2DisposeObject Method

Release all the unmanaged memory associated with this background model.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


BackgroundSubtractorMOG2 Fields

The BackgroundSubtractorMOG2 type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorMOG2 Class
Emgu.CV Namespace


CalibrateCRF Class

The base class for camera response calibration algorithms.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCalibrateCRF
Emgu.CVCalibrateDebevec
Emgu.CVCalibrateRobertson

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class CalibrateCRF : UnmanagedObject
Public MustInherit Class CalibrateCRF
    Inherits UnmanagedObject
public ref class CalibrateCRF abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type CalibrateCRF =
    class
        inherit UnmanagedObject
    end

The CalibrateCRF type exposes the following members.

Constructors
 | Name | Description
Protected method | CalibrateCRF | Initializes a new instance of the CalibrateCRF class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointer that points to the CalibrateCRF object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Recovers inverse camera response.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _calibrateCRFPtr | The pointer to the calibrateCRF object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


CalibrateCRF Constructor

Initializes a new instance of the CalibrateCRF class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected CalibrateCRF()
Protected Sub New
protected:
CalibrateCRF()
new : unit -> CalibrateCRF
See Also

Reference

CalibrateCRF Class
Emgu.CV Namespace


CalibrateCRF Properties

The CalibrateCRF type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CalibrateCRF Class
Emgu.CV Namespace


CalibrateCRF Methods

The CalibrateCRF type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointer that points to the CalibrateCRF object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Recovers inverse camera response.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalibrateCRF Class
Emgu.CV Namespace


CalibrateCRF.DisposeObject Method

CalibrateCRFDisposeObject Method

Reset the pointer that points to the CalibrateCRF object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CalibrateCRF Class
Emgu.CV Namespace


CalibrateCRF.Process Method

CalibrateCRFProcess Method

Recovers inverse camera response.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Process(
    IInputArray src,
    IOutputArray dst,
    IInputArray times
)
Public Sub Process (
    src As IInputArray,
    dst As IOutputArray,
    times As IInputArray
)
public:
void Process(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ times
)
member Process :
        src : IInputArray *
        dst : IOutputArray *
        times : IInputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Vector of input images
dst
Type: Emgu.CVIOutputArray
256x1 matrix with inverse camera response function
times
Type: Emgu.CVIInputArray
Vector of exposure time values for each image
See Also

Reference

CalibrateCRF Class
Emgu.CV Namespace


CalibrateCRF Fields

The CalibrateCRF type exposes the following members.

Fields
 | Name | Description
Protected field | _calibrateCRFPtr | The pointer to the calibrateCRF object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CalibrateCRF Class
Emgu.CV Namespace


CalibrateCRF._calibrateCRFPtr Field

CalibrateCRF_calibrateCRFPtr Field

The pointer to the calibrateCRF object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _calibrateCRFPtr
Protected _calibrateCRFPtr As IntPtr
protected:
IntPtr _calibrateCRFPtr
val mutable _calibrateCRFPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

CalibrateCRF Class
Emgu.CV Namespace


CalibrateDebevec Class

Inverse camera response function is extracted for each brightness value by minimizing an objective function as linear system. Objective function is constructed using pixel values on the same position in all images, extra term is added to make the result smoother.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCalibrateCRF
Emgu.CVCalibrateDebevec

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CalibrateDebevec : CalibrateCRF
Public Class CalibrateDebevec
    Inherits CalibrateCRF
public ref class CalibrateDebevec : public CalibrateCRF
type CalibrateDebevec =
    class
        inherit CalibrateCRF
    end

The CalibrateDebevec type exposes the following members.

Constructors
 | Name | Description
Public method | CalibrateDebevec | Creates CalibrateDebevec object.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this CalibrateCRF object (Overrides CalibrateCRFDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Recovers inverse camera response. (Inherited from CalibrateCRF.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _calibrateCRFPtr | The pointer to the calibrateCRF object (Inherited from CalibrateCRF.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


CalibrateDebevec Constructor

Creates CalibrateDebevec object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CalibrateDebevec(
    int samples = 70,
    float lambda = 10f,
    bool random = false
)
Public Sub New (
    Optional samples As Integer = 70,
    Optional lambda As Single = 10F,
    Optional random As Boolean = false
)
public:
CalibrateDebevec(
    int samples = 70,
    float lambda = 10f,
    bool random = false
)
new :
        ?samples : int *
        ?lambda : float32 *
        ?random : bool
(* Defaults:
        let _samples = defaultArg samples 70
        let _lambda = defaultArg lambda 10f
        let _random = defaultArg random false
*)
-> CalibrateDebevec

Parameters

samples (Optional)
Type: SystemInt32
Number of pixel locations to use
lambda (Optional)
Type: SystemSingle
Smoothness term weight. Greater values produce smoother results, but can alter the response.
random (Optional)
Type: SystemBoolean
If true sample pixel locations are chosen at random, otherwise the form a rectangular grid.
See Also

Reference

CalibrateDebevec Class
Emgu.CV Namespace


CalibrateDebevec Properties

The CalibrateDebevec type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CalibrateDebevec Class
Emgu.CV Namespace


CalibrateDebevec Methods

The CalibrateDebevec type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this CalibrateCRF object (Overrides CalibrateCRFDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Recovers inverse camera response. (Inherited from CalibrateCRF.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalibrateDebevec Class
Emgu.CV Namespace


CalibrateDebevec.DisposeObject Method

CalibrateDebevecDisposeObject Method

Release the unmanaged memory associated with this CalibrateCRF object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CalibrateDebevec Class
Emgu.CV Namespace


CalibrateDebevec Fields

The CalibrateDebevec type exposes the following members.

Fields
 | Name | Description
Protected field | _calibrateCRFPtr | The pointer to the calibrateCRF object (Inherited from CalibrateCRF.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CalibrateDebevec Class
Emgu.CV Namespace


CalibrateRobertson Class

Inverse camera response function is extracted for each brightness value by minimizing an objective function as linear system. This algorithm uses all image pixels.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCalibrateCRF
Emgu.CVCalibrateRobertson

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CalibrateRobertson : CalibrateCRF
Public Class CalibrateRobertson
    Inherits CalibrateCRF
public ref class CalibrateRobertson : public CalibrateCRF
type CalibrateRobertson =
    class
        inherit CalibrateCRF
    end

The CalibrateRobertson type exposes the following members.

Constructors
 | Name | Description
Public method | CalibrateRobertson | Creates CalibrateRobertson object.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this CalibrateCRF object (Overrides CalibrateCRFDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Recovers inverse camera response. (Inherited from CalibrateCRF.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _calibrateCRFPtr | The pointer to the calibrateCRF object (Inherited from CalibrateCRF.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


CalibrateRobertson Constructor

Creates CalibrateRobertson object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CalibrateRobertson(
    int maxIter = 30,
    float threshold = 0.01f
)
Public Sub New (
    Optional maxIter As Integer = 30,
    Optional threshold As Single = 0.01F
)
public:
CalibrateRobertson(
    int maxIter = 30,
    float threshold = 0.01f
)
new :
        ?maxIter : int *
        ?threshold : float32
(* Defaults:
        let _maxIter = defaultArg maxIter 30
        let _threshold = defaultArg threshold 0.01f
*)
-> CalibrateRobertson

Parameters

maxIter (Optional)
Type: SystemInt32
maximal number of Gauss-Seidel solver iterations.
threshold (Optional)
Type: SystemSingle
get difference between results of two successive steps of the minimization.
See Also

Reference

CalibrateRobertson Class
Emgu.CV Namespace


CalibrateRobertson Properties

The CalibrateRobertson type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CalibrateRobertson Class
Emgu.CV Namespace


CalibrateRobertson Methods

The CalibrateRobertson type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this CalibrateCRF object (Overrides CalibrateCRFDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Recovers inverse camera response. (Inherited from CalibrateCRF.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalibrateRobertson Class
Emgu.CV Namespace


CalibrateRobertson.DisposeObject Method

CalibrateRobertsonDisposeObject Method

Release the unmanaged memory associated with this CalibrateCRF object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CalibrateRobertson Class
Emgu.CV Namespace


CalibrateRobertson Fields

The CalibrateRobertson type exposes the following members.

Fields
 | Name | Description
Protected field | _calibrateCRFPtr | The pointer to the calibrateCRF object (Inherited from CalibrateCRF.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CalibrateRobertson Class
Emgu.CV Namespace


CascadeClassifier Class

The Cascade Classifier
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCascadeClassifier

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CascadeClassifier : UnmanagedObject
Public Class CascadeClassifier
    Inherits UnmanagedObject
public ref class CascadeClassifier : public UnmanagedObject
type CascadeClassifier =
    class
        inherit UnmanagedObject
    end

The CascadeClassifier type exposes the following members.

Constructors
 | Name | Description
Public method | CascadeClassifier | Create a cascade classifier
Public method | CascadeClassifier(String) | Create a CascadeClassifier from the specific file
Top
Properties
 | Name | Description
Public property | IsOldFormatCascade | Get if the cascade is old format
Public property | OriginalWindowSize | Get the original window size
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | DetectMultiScale | Finds rectangular regions in the given image that are likely to contain objects the cascade has been trained for and returns those regions as a sequence of rectangles. The function scans the image several times at different scales. Each time it considers overlapping regions in the image. It may also apply some heuristics to reduce number of analyzed regions, such as Canny prunning. After it has proceeded and collected the candidate rectangles (regions that passed the classifier cascade), it groups them and returns a sequence of average rectangles for each large enough group.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the CascadeClassifier Object and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Load the cascade classifier from a file node
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


CascadeClassifier Constructor

Overload List
 | Name | Description
Public method | CascadeClassifier | Create a cascade classifier
Public method | CascadeClassifier(String) | Create a CascadeClassifier from the specific file
Top
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier Constructor

Create a cascade classifier

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CascadeClassifier()
Public Sub New
public:
CascadeClassifier()
new : unit -> CascadeClassifier
See Also

Reference

CascadeClassifier Class
CascadeClassifier Overload
Emgu.CV Namespace


CascadeClassifier Constructor (String)

Create a CascadeClassifier from the specific file

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CascadeClassifier(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
CascadeClassifier(
    String^ fileName
)
new :
        fileName : string -> CascadeClassifier

Parameters

fileName
Type: SystemString
The name of the file that contains the CascadeClassifier
See Also

Reference

CascadeClassifier Class
CascadeClassifier Overload
Emgu.CV Namespace


CascadeClassifier Properties

The CascadeClassifier type exposes the following members.

Properties
 | Name | Description
Public property | IsOldFormatCascade | Get if the cascade is old format
Public property | OriginalWindowSize | Get the original window size
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier.IsOldFormatCascade Property

CascadeClassifierIsOldFormatCascade Property

Get if the cascade is old format

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOldFormatCascade { get; }
Public ReadOnly Property IsOldFormatCascade As Boolean
    Get
public:
property bool IsOldFormatCascade {
    bool get ();
}
member IsOldFormatCascade : bool with get

Property Value

Type: Boolean
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier.OriginalWindowSize Property

CascadeClassifierOriginalWindowSize Property

Get the original window size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size OriginalWindowSize { get; }
Public ReadOnly Property OriginalWindowSize As Size
    Get
public:
property Size^ OriginalWindowSize {
    Size^ get ();
}
member OriginalWindowSize : Size with get

Property Value

Type: Size
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier Methods

The CascadeClassifier type exposes the following members.

Methods
 | Name | Description
Public method | DetectMultiScale | Finds rectangular regions in the given image that are likely to contain objects the cascade has been trained for and returns those regions as a sequence of rectangles. The function scans the image several times at different scales. Each time it considers overlapping regions in the image. It may also apply some heuristics to reduce number of analyzed regions, such as Canny prunning. After it has proceeded and collected the candidate rectangles (regions that passed the classifier cascade), it groups them and returns a sequence of average rectangles for each large enough group.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the CascadeClassifier Object and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Load the cascade classifier from a file node
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier.DetectMultiScale Method

CascadeClassifierDetectMultiScale Method

Finds rectangular regions in the given image that are likely to contain objects the cascade has been trained for and returns those regions as a sequence of rectangles. The function scans the image several times at different scales. Each time it considers overlapping regions in the image. It may also apply some heuristics to reduce number of analyzed regions, such as Canny prunning. After it has proceeded and collected the candidate rectangles (regions that passed the classifier cascade), it groups them and returns a sequence of average rectangles for each large enough group.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle[] DetectMultiScale(
    IInputArray image,
    double scaleFactor = 1.1,
    int minNeighbors = 3,
    Size minSize = null,
    Size maxSize = null
)
Public Function DetectMultiScale (
    image As IInputArray,
    Optional scaleFactor As Double = 1.1,
    Optional minNeighbors As Integer = 3,
    Optional minSize As Size = Nothing,
    Optional maxSize As Size = Nothing
) As Rectangle()
public:
array<Rectangle^>^ DetectMultiScale(
    IInputArray^ image,
    double scaleFactor = 1.1,
    int minNeighbors = 3,
    Size^ minSize = nullptr,
    Size^ maxSize = nullptr
)
member DetectMultiScale :
        image : IInputArray *
        ?scaleFactor : float *
        ?minNeighbors : int *
        ?minSize : Size *
        ?maxSize : Size
(* Defaults:
        let _scaleFactor = defaultArg scaleFactor 1.1
        let _minNeighbors = defaultArg minNeighbors 3
        let _minSize = defaultArg minSize null
        let _maxSize = defaultArg maxSize null
*)
-> Rectangle[]

Parameters

image
Type: Emgu.CVIInputArray
The image where the objects are to be detected from
scaleFactor (Optional)
Type: SystemDouble
The factor by which the search window is scaled between the subsequent scans, for example, 1.1 means increasing window by 10%
minNeighbors (Optional)
Type: SystemInt32
Minimum number (minus 1) of neighbor rectangles that makes up an object. All the groups of a smaller number of rectangles than min_neighbors-1 are rejected. If min_neighbors is 0, the function does not any grouping at all and returns all the detected candidate rectangles, which may be useful if the user wants to apply a customized grouping procedure. Use 3 for default.
minSize (Optional)
Type: System.DrawingSize
Minimum window size. Use Size.Empty for default, where it is set to the size of samples the classifier has been trained on (~20x20 for face detection)
maxSize (Optional)
Type: System.DrawingSize
Maximum window size. Use Size.Empty for default, where the parameter will be ignored.

Return Value

Type: Rectangle
The objects detected, one array per channel
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier.DisposeObject Method

CascadeClassifierDisposeObject Method

Release the CascadeClassifier Object and all the memory associate with it

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier.Read Method

CascadeClassifierRead Method

Load the cascade classifier from a file node

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Read(
    FileNode node
)
Public Function Read (
    node As FileNode
) As Boolean
public:
bool Read(
    FileNode^ node
)
member Read :
        node : FileNode -> bool

Parameters

node
Type: Emgu.CVFileNode
The file node, The file may contain a new cascade classifier only.

Return Value

Type: Boolean
True if the classifier can be imported.
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


CascadeClassifier Fields

The CascadeClassifier type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CascadeClassifier Class
Emgu.CV Namespace


ColorInfoAttribute Class

Attribute used to specify color information
Inheritance Hierarchy
SystemObject
SystemAttribute
Emgu.CVColorInfoAttribute

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ColorInfoAttribute : Attribute
Public NotInheritable Class ColorInfoAttribute
    Inherits Attribute
public ref class ColorInfoAttribute sealed : public Attribute
[<SealedAttribute>]
type ColorInfoAttribute =
    class
        inherit Attribute
    end

The ColorInfoAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ColorInfoAttribute | The code which is used for color conversion
Top
Properties
 | Name | Description
Public property | ConversionCodename | The code which is used for color conversion
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.CV Namespace


ColorInfoAttribute Constructor

The code which is used for color conversion

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ColorInfoAttribute()
Public Sub New
public:
ColorInfoAttribute()
new : unit -> ColorInfoAttribute
See Also

Reference

ColorInfoAttribute Class
Emgu.CV Namespace


ColorInfoAttribute Properties

The ColorInfoAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ConversionCodename | The code which is used for color conversion
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ColorInfoAttribute Class
Emgu.CV Namespace


ColorInfoAttribute.ConversionCodename Property

ColorInfoAttributeConversionCodename Property

The code which is used for color conversion

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ConversionCodename { get; set; }
Public Property ConversionCodename As String
    Get
    Set
public:
property String^ ConversionCodename {
    String^ get ();
    void set (String^ value);
}
member ConversionCodename : string with get, set

Property Value

Type: String
See Also

Reference

ColorInfoAttribute Class
Emgu.CV Namespace


ColorInfoAttribute Methods

The ColorInfoAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorInfoAttribute Class
Emgu.CV Namespace


ContribInvoke Class

Class that contains entry points for the Contrib module.
Inheritance Hierarchy
SystemObject
Emgu.CVContribInvoke

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class ContribInvoke
Public NotInheritable Class ContribInvoke
public ref class ContribInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ContribInvoke =  class end
See Also

Reference

Emgu.CV Namespace


ConvolutionKernelF Class

A convolution kernel
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArray Single
Emgu.CVMatrix Single
Emgu.CVConvolutionKernelF

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ConvolutionKernelF : Matrix<float>
Public Class ConvolutionKernelF
    Inherits Matrix(Of Single)
public ref class ConvolutionKernelF : public Matrix<float>
type ConvolutionKernelF =
    class
        inherit Matrix<float32>
    end

The ConvolutionKernelF type exposes the following members.

Constructors
 | Name | Description
Public method | ConvolutionKernelF(Single) | Create a convolution kernel using the specific floating point matrix
Public method | ConvolutionKernelF(Int32, Int32) | Create a convolution kernel with the specific number of rows and cols
Public method | ConvolutionKernelF(Single, Point) | Create a convolution kernel using the specific floating point matrix and center
Public method | ConvolutionKernelF(MatrixSingle, Point) | Create a convolution kernel using the specific matrix and center
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Center | The center of the convolution kernel
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix (Inherited from MatrixTDepth.)
Public property | Det | Returns determinant of the square matrix (Inherited from MatrixTDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | Item | Get or Set the value in the specific row and col (Inherited from MatrixTDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from MatrixTDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMat | The MCvMat structure format (Inherited from MatrixTDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this matrix (Inherited from MatrixTDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from MatrixTDepth.)
Public property | Sum | Return the sum of the elements in this matrix (Inherited from MatrixTDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | Add(TDepth) | Elementwise add a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Add(MatrixTDepth) | Elementwise add another matrix with the current matrix (Inherited from MatrixTDepth.)
Protected method | AllocateData | Allocate data for the array (Inherited from MatrixTDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a copy of this matrix (Inherited from MatrixTDepth.)
Public method | Cmp | This function compare the current matrix with mat2 and returns the comparison mask (Inherited from MatrixTDepth.)
Public method | ConcateHorizontal | Concate the current matrix with another matrix horizontally. If this matrix is n x m1 and otherMatrix is n x m2, the resulting matrix is n x (m1 + m2). (Inherited from MatrixTDepth.)
Public method | ConcateVertical | Concate the current matrix with another matrix vertically. If this matrix is n1 x m and otherMatrix is n2 x m, the resulting matrix is (n1+n2) x m. (Inherited from MatrixTDepth.)
Public method | ConvertTOtherDepth | Convert this matrix to different depth (Inherited from MatrixTDepth.)
Public method | CopyBlank | Return a matrix of the same size with all elements equals 0 (Inherited from MatrixTDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Inherited from MatrixTDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatrixTDepth) | Return true if every element of this matrix equals elements in mat2 (Inherited from MatrixTDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Flip | Get a flipped copy of the convolution kernel
Public method | GetCol | Get the specific column of the matrix (Inherited from MatrixTDepth.)
Public method | GetCols | Get the Matrix, corresponding to a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | GetDiag | Return the main diagonal element of this matrix (Inherited from MatrixTDepth.)
Public method | GetDiag(Int32) | Return the specific diagonal elements of this matrix (Inherited from MatrixTDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from CvArrayTDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetRow | Get the specific row of the matrix (Inherited from MatrixTDepth.)
Public method | GetRows | Return the matrix corresponding to a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a submatrix corresponding to a specified rectangle (Inherited from MatrixTDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max locations and values for the matrix (Inherited from MatrixTDepth.)
Public method | Mul(Double) | Multiply the current matrix with scale (Inherited from MatrixTDepth.)
Public method | Mul(MatrixTDepth) | Multiply the current matrix with mat2 (Inherited from MatrixTDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveCols | Return the matrix without a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | RemoveRows | Return the matrix without a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | Reshape | Get reshaped matrix which also share the same data with the current matrix (Inherited from MatrixTDepth.)
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | Split | Get all channels for the multi channel matrix (Inherited from MatrixTDepth.)
Public method | Sub(TDepth) | Elementwise subtract a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Sub(MatrixTDepth) | Elementwise subtract another matrix from the current matrix (Inherited from MatrixTDepth.)
Public method | SubR | result = val - this (Inherited from MatrixTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | Transpose | Obtain the transpose of the convolution kernel
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Top
Fields
 | Name | Description
Protected field | _center | The center of the convolution kernel
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


ConvolutionKernelF Constructor

Overload List
 | Name | Description
Public method | ConvolutionKernelF(Single) | Create a convolution kernel using the specific floating point matrix
Public method | ConvolutionKernelF(Int32, Int32) | Create a convolution kernel with the specific number of rows and cols
Public method | ConvolutionKernelF(Single, Point) | Create a convolution kernel using the specific floating point matrix and center
Public method | ConvolutionKernelF(MatrixSingle, Point) | Create a convolution kernel using the specific matrix and center
Top
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


ConvolutionKernelF Constructor (Single[,])

ConvolutionKernelF Constructor (Single)

http://www.emgu.com
Create a convolution kernel using the specific floating point matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ConvolutionKernelF(
    float[,] kernel
)
Public Sub New (
    kernel As Single(,)
)
public:
ConvolutionKernelF(
    array<float,2>^ kernel
)
new :
        kernel : float32[,] -> ConvolutionKernelF

Parameters

kernel
Type: SystemSingle
The values for the convolution kernel
See Also

Reference

ConvolutionKernelF Class
ConvolutionKernelF Overload
Emgu.CV Namespace


ConvolutionKernelF Constructor (Int32, Int32)

Create a convolution kernel with the specific number of rows and cols

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ConvolutionKernelF(
    int rows,
    int cols
)
Public Sub New (
    rows As Integer,
    cols As Integer
)
public:
ConvolutionKernelF(
    int rows,
    int cols
)
new :
        rows : int *
        cols : int -> ConvolutionKernelF

Parameters

rows
Type: SystemInt32
The number of raws for the convolution kernel
cols
Type: SystemInt32
The number of columns for the convolution kernel
See Also

Reference

ConvolutionKernelF Class
ConvolutionKernelF Overload
Emgu.CV Namespace


ConvolutionKernelF Constructor (Single[,], Point)

ConvolutionKernelF Constructor (Single, Point)

http://www.emgu.com
Create a convolution kernel using the specific floating point matrix and center

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ConvolutionKernelF(
    float[,] kernel,
    Point center
)
Public Sub New (
    kernel As Single(,),
    center As Point
)
public:
ConvolutionKernelF(
    array<float,2>^ kernel,
    Point^ center
)
new :
        kernel : float32[,] *
        center : Point -> ConvolutionKernelF

Parameters

kernel
Type: SystemSingle
The values for the convolution kernel
center
Type: System.DrawingPoint
The center for the convolution kernel
See Also

Reference

ConvolutionKernelF Class
ConvolutionKernelF Overload
Emgu.CV Namespace


ConvolutionKernelF Constructor (Matrix(Single), Point)

ConvolutionKernelF Constructor (MatrixSingle, Point)

http://www.emgu.com
Create a convolution kernel using the specific matrix and center

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ConvolutionKernelF(
    Matrix<float> kernel,
    Point center
)
Public Sub New (
    kernel As Matrix(Of Single),
    center As Point
)
public:
ConvolutionKernelF(
    Matrix<float>^ kernel,
    Point^ center
)
new :
        kernel : Matrix<float32> *
        center : Point -> ConvolutionKernelF

Parameters

kernel
Type: Emgu.CVMatrix Single
The values for the convolution kernel
center
Type: System.DrawingPoint
The center of the kernel
See Also

Reference

ConvolutionKernelF Class
ConvolutionKernelF Overload
Emgu.CV Namespace


ConvolutionKernelF Properties

The ConvolutionKernelF type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Center | The center of the convolution kernel
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix (Inherited from MatrixTDepth.)
Public property | Det | Returns determinant of the square matrix (Inherited from MatrixTDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | Item | Get or Set the value in the specific row and col (Inherited from MatrixTDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from MatrixTDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMat | The MCvMat structure format (Inherited from MatrixTDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this matrix (Inherited from MatrixTDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from MatrixTDepth.)
Public property | Sum | Return the sum of the elements in this matrix (Inherited from MatrixTDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


ConvolutionKernelF.Center Property

ConvolutionKernelFCenter Property

The center of the convolution kernel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point Center { get; set; }
Public Property Center As Point
    Get
    Set
public:
property Point^ Center {
    Point^ get ();
    void set (Point^ value);
}
member Center : Point with get, set

Property Value

Type: Point
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


ConvolutionKernelF Methods

The ConvolutionKernelF type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | Add(TDepth) | Elementwise add a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Add(MatrixTDepth) | Elementwise add another matrix with the current matrix (Inherited from MatrixTDepth.)
Protected method | AllocateData | Allocate data for the array (Inherited from MatrixTDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a copy of this matrix (Inherited from MatrixTDepth.)
Public method | Cmp | This function compare the current matrix with mat2 and returns the comparison mask (Inherited from MatrixTDepth.)
Public method | ConcateHorizontal | Concate the current matrix with another matrix horizontally. If this matrix is n x m1 and otherMatrix is n x m2, the resulting matrix is n x (m1 + m2). (Inherited from MatrixTDepth.)
Public method | ConcateVertical | Concate the current matrix with another matrix vertically. If this matrix is n1 x m and otherMatrix is n2 x m, the resulting matrix is (n1+n2) x m. (Inherited from MatrixTDepth.)
Public method | ConvertTOtherDepth | Convert this matrix to different depth (Inherited from MatrixTDepth.)
Public method | CopyBlank | Return a matrix of the same size with all elements equals 0 (Inherited from MatrixTDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Inherited from MatrixTDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatrixTDepth) | Return true if every element of this matrix equals elements in mat2 (Inherited from MatrixTDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Flip | Get a flipped copy of the convolution kernel
Public method | GetCol | Get the specific column of the matrix (Inherited from MatrixTDepth.)
Public method | GetCols | Get the Matrix, corresponding to a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | GetDiag | Return the main diagonal element of this matrix (Inherited from MatrixTDepth.)
Public method | GetDiag(Int32) | Return the specific diagonal elements of this matrix (Inherited from MatrixTDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from CvArrayTDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetRow | Get the specific row of the matrix (Inherited from MatrixTDepth.)
Public method | GetRows | Return the matrix corresponding to a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a submatrix corresponding to a specified rectangle (Inherited from MatrixTDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max locations and values for the matrix (Inherited from MatrixTDepth.)
Public method | Mul(Double) | Multiply the current matrix with scale (Inherited from MatrixTDepth.)
Public method | Mul(MatrixTDepth) | Multiply the current matrix with mat2 (Inherited from MatrixTDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveCols | Return the matrix without a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | RemoveRows | Return the matrix without a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | Reshape | Get reshaped matrix which also share the same data with the current matrix (Inherited from MatrixTDepth.)
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | Split | Get all channels for the multi channel matrix (Inherited from MatrixTDepth.)
Public method | Sub(TDepth) | Elementwise subtract a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Sub(MatrixTDepth) | Elementwise subtract another matrix from the current matrix (Inherited from MatrixTDepth.)
Public method | SubR | result = val - this (Inherited from MatrixTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | Transpose | Obtain the transpose of the convolution kernel
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Top
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


ConvolutionKernelF.Flip Method

ConvolutionKernelFFlip Method

Get a flipped copy of the convolution kernel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ConvolutionKernelF Flip(
    FlipType flipType
)
Public Function Flip (
    flipType As FlipType
) As ConvolutionKernelF
public:
ConvolutionKernelF^ Flip(
    FlipType^ flipType
)
member Flip :
        flipType : FlipType -> ConvolutionKernelF

Parameters

flipType
Type: Emgu.CV.CvEnumFlipType
The type of the flipping

Return Value

Type: ConvolutionKernelF
The flipped copy of this image
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


ConvolutionKernelF.Transpose Method

ConvolutionKernelFTranspose Method

Obtain the transpose of the convolution kernel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ConvolutionKernelF Transpose()
Public Function Transpose As ConvolutionKernelF
public:
ConvolutionKernelF^ Transpose()
member Transpose : unit -> ConvolutionKernelF

Return Value

Type: ConvolutionKernelF
A transposed convolution kernel
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


ConvolutionKernelF Fields

The ConvolutionKernelF type exposes the following members.

Fields
 | Name | Description
Protected field | _center | The center of the convolution kernel
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


ConvolutionKernelF._center Field

ConvolutionKernelF_center Field

The center of the convolution kernel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Point _center
Protected _center As Point
protected:
Point^ _center
val mutable _center: Point

Field Value

Type: Point
See Also

Reference

ConvolutionKernelF Class
Emgu.CV Namespace


CvArray(TDepth) Class

CvArrayTDepth Class

Wrapped CvArr
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArrayTDepth
Emgu.CVImageTColor, TDepth
Emgu.CVMatNDTDepth
Emgu.CVMatrixTDepth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class CvArray<TDepth> : UnmanagedObject,
    IXmlSerializable, IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
where TDepth : new()

Public MustInherit Class CvArray(Of TDepth As New)
    Inherits UnmanagedObject
    Implements IXmlSerializable, IInputOutputArray, IInputArray, IDisposable,
    IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
generic<typename TDepth>
where TDepth : gcnew()
public ref class CvArray abstract : public UnmanagedObject,
    IXmlSerializable, IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[<AbstractClassAttribute>]
type CvArray<'TDepth when 'TDepth : new()> =
    class
        inherit UnmanagedObject
        interface IXmlSerializable
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

Type Parameters

TDepth
The type of elements in this CvArray

The CvArrayTDepth type exposes the following members.

Constructors
 | Name | Description
Protected method | CvArrayTDepth | Initializes a new instance of the CvArrayTDepth class
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array
Public property | Cols | The number of cols for this array
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI
Public property | ManagedArray | Get the underneath managed array
Public property | Mat | Get the Mat header that represent this CvArr
Public property | Norm | The norm of this Array
Public property | NumberOfChannels | Get the number of channels of the array
Public property | Ptr | The pointer to the internal structure
Public property | Rows | The number of rows for this array
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression
Public property | Size | Get the size of the array
 | SizeOfElement | Get the size of element in bytes
Public property | Trace | Sum of diagonal elements of the matrix
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other
Public method | _Min(Double) | Inplace compute the elementwise minimum value
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2
Public method | _Not | Inplace compute the complement for all array elements
Public method | _Or | Inplace Or operation with otherArray
Protected method | AllocateData | Allocate data for the array
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false.
Public method | CopyTo | Copy the current array to destination
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Free the _dataHandle if it is set (Overrides DisposableObjectDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I))
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array.
Public method | GetInputOutputArray | The unmanaged pointer to the input output array.
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | The unmanaged pointer to the output array.
Public method | GetSchema | Get the xml schema
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadXml | Function to call when deserializing this object from XML
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Save | Save the CvArray as image
Public method | SetIdentity | Initialize the identity matrix
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask
Public method | SetZero | Set the values to zero
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat
Public method | WriteXml | Function to call when serializing this object to XML
Top
Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr
Protected field | _dataHandle | The pinned GCHandle to _array;
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


CvArray(TDepth) Constructor

CvArrayTDepth Constructor

Initializes a new instance of the CvArrayTDepth class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected CvArray()
Protected Sub New
protected:
CvArray()
new : unit -> CvArray
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth) Properties

CvArrayTDepth Properties

The CvArrayTDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array
Public property | Cols | The number of cols for this array
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI
Public property | ManagedArray | Get the underneath managed array
Public property | Mat | Get the Mat header that represent this CvArr
Public property | Norm | The norm of this Array
Public property | NumberOfChannels | Get the number of channels of the array
Public property | Ptr | The pointer to the internal structure
Public property | Rows | The number of rows for this array
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression
Public property | Size | Get the size of the array
 | SizeOfElement | Get the size of element in bytes
Public property | Trace | Sum of diagonal elements of the matrix
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Bytes Property

CvArrayTDepthBytes Property

Get or Set an Array of bytes that represent the data in this array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] Bytes { get; set; }
Public Property Bytes As Byte()
    Get
    Set
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Bytes : byte[] with get, set

Property Value

Type: Byte
Remarks
Should only be used for serialization & deserialization
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Cols Property

CvArrayTDepthCols Property

The number of cols for this array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Cols { get; }
Public ReadOnly Property Cols As Integer
    Get
public:
property int Cols {
    int get ();
}
member Cols : int with get

Property Value

Type: Int32
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Height Property

CvArrayTDepthHeight Property

Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
property int Height {
    int get ();
}
member Height : int with get

Property Value

Type: Int32
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).ManagedArray Property

CvArrayTDepthManagedArray Property

Get the underneath managed array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract Array ManagedArray { get; set; }
Public MustOverride Property ManagedArray As Array
    Get
    Set
public:
virtual property Array^ ManagedArray {
    Array^ get () abstract;
    void set (Array^ value) abstract;
}
abstract ManagedArray : Array with get, set

Property Value

Type: Array
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Mat Property

CvArrayTDepthMat Property

Get the Mat header that represent this CvArr

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Mat { get; }
Public ReadOnly Property Mat As Mat
    Get
public:
property Mat^ Mat {
    Mat^ get ();
}
member Mat : Mat with get

Property Value

Type: Mat
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Norm Property

CvArrayTDepthNorm Property

The norm of this Array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Norm { get; }
Public ReadOnly Property Norm As Double
    Get
public:
property double Norm {
    double get ();
}
member Norm : float with get

Property Value

Type: Double
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).NumberOfChannels Property

CvArrayTDepthNumberOfChannels Property

Get the number of channels of the array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract int NumberOfChannels { get; }
Public MustOverride ReadOnly Property NumberOfChannels As Integer
    Get
public:
virtual property int NumberOfChannels {
    int get () abstract;
}
abstract NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Ptr Property

CvArrayTDepthPtr Property

The pointer to the internal structure

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Ptr { get; set; }
Public Property Ptr As IntPtr
    Get
    Set
public:
property IntPtr Ptr {
    IntPtr get ();
    void set (IntPtr value);
}
member Ptr : IntPtr with get, set

Property Value

Type: IntPtr
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Rows Property

CvArrayTDepthRows Property

The number of rows for this array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get
public:
property int Rows {
    int get ();
}
member Rows : int with get

Property Value

Type: Int32
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).SerializationCompressionRatio Property

CvArrayTDepthSerializationCompressionRatio Property

Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int SerializationCompressionRatio { get; set; }
Public Property SerializationCompressionRatio As Integer
    Get
    Set
public:
property int SerializationCompressionRatio {
    int get ();
    void set (int value);
}
member SerializationCompressionRatio : int with get, set

Property Value

Type: Int32
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Size Property

CvArrayTDepthSize Property

Get the size of the array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual Size Size { get; }
Public Overridable ReadOnly Property Size As Size
    Get
public:
virtual property Size^ Size {
    Size^ get ();
}
abstract Size : Size with get
override Size : Size with get

Property Value

Type: Size
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).SizeOfElement Property

CvArrayTDepthSizeOfElement Property

Get the size of element in bytes

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfElement { get; }
Public Shared ReadOnly Property SizeOfElement As Integer
    Get
public:
static property int SizeOfElement {
    int get ();
}
static member SizeOfElement : int with get

Property Value

Type: Int32
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Trace Property

CvArrayTDepthTrace Property

Sum of diagonal elements of the matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar Trace { get; }
Public ReadOnly Property Trace As MCvScalar
    Get
public:
property MCvScalar^ Trace {
    MCvScalar^ get ();
}
member Trace : MCvScalar with get

Property Value

Type: MCvScalar
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Width Property

CvArrayTDepthWidth Property

Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}
member Width : int with get

Property Value

Type: Int32
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth) Methods

CvArrayTDepth Methods

The CvArrayTDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other
Public method | _Min(Double) | Inplace compute the elementwise minimum value
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2
Public method | _Not | Inplace compute the complement for all array elements
Public method | _Or | Inplace Or operation with otherArray
Protected method | AllocateData | Allocate data for the array
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false.
Public method | CopyTo | Copy the current array to destination
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Free the _dataHandle if it is set (Overrides DisposableObjectDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I))
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array.
Public method | GetInputOutputArray | The unmanaged pointer to the input output array.
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | The unmanaged pointer to the output array.
Public method | GetSchema | Get the xml schema
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadXml | Function to call when deserializing this object from XML
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Save | Save the CvArray as image
Public method | SetIdentity | Initialize the identity matrix
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask
Public method | SetZero | Set the values to zero
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat
Public method | WriteXml | Function to call when serializing this object to XML
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._And Method

CvArrayTDepth_And Method

Inplace And operation with otherArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _And(
    CvArray<TDepth> otherArray
)
Public Sub _And (
    otherArray As CvArray(Of TDepth)
)
public:
void _And(
    CvArray<TDepth>^ otherArray
)
member _And :
        otherArray : CvArray<'TDepth> -> unit

Parameters

otherArray
Type: Emgu.CVCvArray TDepth
The other array to perform AND operation
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._Max Method

CvArrayTDepth_Max Method

Overload List
 | Name | Description
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._Max Method (Double)

CvArrayTDepth_Max Method (Double)

http://www.emgu.com
Inplace compute the elementwise maximum value with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Max(
    double value
)
Public Sub _Max (
    value As Double
)
public:
void _Max(
    double value
)
member _Max :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value to be compare with
See Also

Reference

CvArrayTDepth Class
_Max Overload
Emgu.CV Namespace


CvArray(TDepth)._Max Method (CvArray(TDepth))

CvArrayTDepth_Max Method (CvArrayTDepth)

http://www.emgu.com
Inplace elementwise maximize the current Array with other

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Max(
    CvArray<TDepth> other
)
Public Sub _Max (
    other As CvArray(Of TDepth)
)
public:
void _Max(
    CvArray<TDepth>^ other
)
member _Max :
        other : CvArray<'TDepth> -> unit

Parameters

other
Type: Emgu.CVCvArray TDepth
The other array to be elementwise maximized with this array
See Also

Reference

CvArrayTDepth Class
_Max Overload
Emgu.CV Namespace


CvArray(TDepth)._Min Method

CvArrayTDepth_Min Method

Overload List
 | Name | Description
Public method | _Min(Double) | Inplace compute the elementwise minimum value
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._Min Method (Double)

CvArrayTDepth_Min Method (Double)

http://www.emgu.com
Inplace compute the elementwise minimum value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Min(
    double value
)
Public Sub _Min (
    value As Double
)
public:
void _Min(
    double value
)
member _Min :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value to compare with
See Also

Reference

CvArrayTDepth Class
_Min Overload
Emgu.CV Namespace


CvArray(TDepth)._Min Method (CvArray(TDepth))

CvArrayTDepth_Min Method (CvArrayTDepth)

http://www.emgu.com
Inplace elementwise minimize the current Array with other

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Min(
    CvArray<TDepth> other
)
Public Sub _Min (
    other As CvArray(Of TDepth)
)
public:
void _Min(
    CvArray<TDepth>^ other
)
member _Min :
        other : CvArray<'TDepth> -> unit

Parameters

other
Type: Emgu.CVCvArray TDepth
The other array to be elementwise minimized with this array
See Also

Reference

CvArrayTDepth Class
_Min Overload
Emgu.CV Namespace


CvArray(TDepth)._Mul Method

CvArrayTDepth_Mul Method

Overload List
 | Name | Description
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._Mul Method (Double)

CvArrayTDepth_Mul Method (Double)

http://www.emgu.com
Inplace multiply elements of the Array by scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Mul(
    double scale
)
Public Sub _Mul (
    scale As Double
)
public:
void _Mul(
    double scale
)
member _Mul :
        scale : float -> unit

Parameters

scale
Type: SystemDouble
The scale to be multiplyed
See Also

Reference

CvArrayTDepth Class
_Mul Overload
Emgu.CV Namespace


CvArray(TDepth)._Mul Method (CvArray(TDepth))

CvArrayTDepth_Mul Method (CvArrayTDepth)

http://www.emgu.com
Inplace elementwise multiply the current Array with src2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Mul(
    CvArray<TDepth> src2
)
Public Sub _Mul (
    src2 As CvArray(Of TDepth)
)
public:
void _Mul(
    CvArray<TDepth>^ src2
)
member _Mul :
        src2 : CvArray<'TDepth> -> unit

Parameters

src2
Type: Emgu.CVCvArray TDepth
The other array to be elementwise multiplied with
See Also

Reference

CvArrayTDepth Class
_Mul Overload
Emgu.CV Namespace


CvArray(TDepth)._Not Method

CvArrayTDepth_Not Method

Inplace compute the complement for all array elements

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Not()
Public Sub _Not
public:
void _Not()
member _Not : unit -> unit
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._Or Method

CvArrayTDepth_Or Method

Inplace Or operation with otherArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Or(
    CvArray<TDepth> otherArray
)
Public Sub _Or (
    otherArray As CvArray(Of TDepth)
)
public:
void _Or(
    CvArray<TDepth>^ otherArray
)
member _Or :
        otherArray : CvArray<'TDepth> -> unit

Parameters

otherArray
Type: Emgu.CVCvArray TDepth
The other array to perform OR operation
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).AllocateData Method

CvArrayTDepthAllocateData Method

Allocate data for the array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected abstract void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
)
Protected MustOverride Sub AllocateData (
    rows As Integer,
    cols As Integer,
    numberOfChannels As Integer
)
protected:
virtual void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
) abstract
abstract AllocateData :
        rows : int *
        cols : int *
        numberOfChannels : int -> unit

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of columns
numberOfChannels
Type: SystemInt32
The number of channels of this cvArray
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).CheckRange Method

CvArrayTDepthCheckRange Method

Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool CheckRange(
    double min,
    double max,
    ref Point position
)
Public Function CheckRange (
    min As Double,
    max As Double,
    ByRef position As Point
) As Boolean
public:
bool CheckRange(
    double min,
    double max,
    Point^% position
)
member CheckRange :
        min : float *
        max : float *
        position : Point byref -> bool

Parameters

min
Type: SystemDouble
The inclusive lower boundary of valid values range
max
Type: SystemDouble
The exclusive upper boundary of valid values range
position
Type: System.DrawingPoint
This will be filled with the position of the first outlier

Return Value

Type: Boolean
True if all values are in range
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).CopyTo Method

CvArrayTDepthCopyTo Method

Copy the current array to destination

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    CvArray<TDepth> destination
)
Public Sub CopyTo (
    destination As CvArray(Of TDepth)
)
public:
void CopyTo(
    CvArray<TDepth>^ destination
)
member CopyTo :
        destination : CvArray<'TDepth> -> unit

Parameters

destination
Type: Emgu.CVCvArray TDepth
The destination Array
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).DeserializeObjectData Method

CvArrayTDepthDeserializeObjectData Method

A function used for runtime deserailization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void DeserializeObjectData(
    SerializationInfo info,
    StreamingContext context
)
Protected Overridable Sub DeserializeObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
virtual void DeserializeObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
)
abstract DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).DisposeObject Method

CvArrayTDepthDisposeObject Method

Free the _dataHandle if it is set

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).DotProduct Method

CvArrayTDepthDotProduct Method

Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I))

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double DotProduct(
    CvArray<TDepth> otherArray
)
Public Function DotProduct (
    otherArray As CvArray(Of TDepth)
) As Double
public:
double DotProduct(
    CvArray<TDepth>^ otherArray
)
member DotProduct :
        otherArray : CvArray<'TDepth> -> float

Parameters

otherArray
Type: Emgu.CVCvArray TDepth
The other Array to apply dot product with

Return Value

Type: Double
src1 dot src2
Remarks
In case of multiple channel arrays the results for all channels are accumulated. In particular, cvDotProduct(a,a), where a is a complex vector, will return ||a||^2. The function can process multi-dimensional arrays, row by row, layer by layer and so on.
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).GetInputArray Method

CvArrayTDepthGetInputArray Method

The unmanaged pointer to the input array.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).GetInputOutputArray Method

CvArrayTDepthGetInputOutputArray Method

The unmanaged pointer to the input output array.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).GetObjectData Method

CvArrayTDepthGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).GetOutputArray Method

CvArrayTDepthGetOutputArray Method

The unmanaged pointer to the output array.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).GetSchema Method

CvArrayTDepthGetSchema Method

Get the xml schema

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public XmlSchema GetSchema()
Public Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() sealed
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
The xml schema

Implements

IXmlSerializableGetSchema
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).ReadXml Method

CvArrayTDepthReadXml Method

Function to call when deserializing this object from XML

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void ReadXml(
    XmlReader reader
)
Public Overridable Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
)
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The xml reader

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Reduce(TOtherDepth) Method

CvArrayTDepthReduceTOtherDepth Method

Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Reduce<TOtherDepth>(
    CvArray<TOtherDepth> array1D,
    ReduceDimension dim,
    ReduceType type
)
where TOtherDepth : new()

Public Sub Reduce(Of TOtherDepth As New) (
    array1D As CvArray(Of TOtherDepth),
    dim As ReduceDimension,
    type As ReduceType
)
public:
generic<typename TOtherDepth>
where TOtherDepth : gcnew()
void Reduce(
    CvArray<TOtherDepth>^ array1D,
    ReduceDimension^ dim,
    ReduceType^ type
)
member Reduce :
        array1D : CvArray<'TOtherDepth> *
        dim : ReduceDimension *
        type : ReduceType -> unit  when 'TOtherDepth : new()

Parameters

array1D
Type: Emgu.CVCvArray TOtherDepth
The destination single-row/single-column vector that accumulates somehow all the matrix rows/columns
dim
Type: Emgu.CV.CvEnumReduceDimension
The dimension index along which the matrix is reduce.
type
Type: Emgu.CV.CvEnumReduceType
The reduction operation type

Type Parameters

TOtherDepth
The type of depth of the reduced array
Remarks
The function can be used to compute horizontal and vertical projections of an raster image. In case of CV_REDUCE_SUM and CV_REDUCE_AVG the output may have a larger element bit-depth to preserve accuracy. And multi-channel arrays are also supported in these two reduction modes
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).Save Method

CvArrayTDepthSave Method

Save the CvArray as image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Save(
    string fileName
)
Public Overridable Sub Save (
    fileName As String
)
public:
virtual void Save(
    String^ fileName
)
abstract Save :
        fileName : string -> unit
override Save :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The name of the image to save
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).SetIdentity Method

CvArrayTDepthSetIdentity Method

Overload List
 | Name | Description
Public method | SetIdentity | Initialize the identity matrix
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).SetIdentity Method

CvArrayTDepthSetIdentity Method

Initialize the identity matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetIdentity()
Public Sub SetIdentity
public:
void SetIdentity()
member SetIdentity : unit -> unit
See Also

Reference

CvArrayTDepth Class
SetIdentity Overload
Emgu.CV Namespace


CvArray(TDepth).SetIdentity Method (MCvScalar)

CvArrayTDepthSetIdentity Method (MCvScalar)

http://www.emgu.com
Initializes scaled identity matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetIdentity(
    MCvScalar value
)
Public Sub SetIdentity (
    value As MCvScalar
)
public:
void SetIdentity(
    MCvScalar^ value
)
member SetIdentity :
        value : MCvScalar -> unit

Parameters

value
Type: Emgu.CV.StructureMCvScalar
The value on the diagonal
See Also

Reference

CvArrayTDepth Class
SetIdentity Overload
Emgu.CV Namespace


CvArray(TDepth).SetRandNormal Method

CvArrayTDepthSetRandNormal Method

Inplace fills Array with normally distributed random numbers

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetRandNormal(
    MCvScalar mean,
    MCvScalar std
)
Public Sub SetRandNormal (
    mean As MCvScalar,
    std As MCvScalar
)
public:
void SetRandNormal(
    MCvScalar^ mean,
    MCvScalar^ std
)
member SetRandNormal :
        mean : MCvScalar *
        std : MCvScalar -> unit

Parameters

mean
Type: Emgu.CV.StructureMCvScalar
The mean value of random numbers
std
Type: Emgu.CV.StructureMCvScalar
The standard deviation of random numbers
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).SetRandUniform Method

CvArrayTDepthSetRandUniform Method

Inplace fills Array with uniformly distributed random numbers

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetRandUniform(
    MCvScalar floorValue,
    MCvScalar ceilingValue
)
Public Sub SetRandUniform (
    floorValue As MCvScalar,
    ceilingValue As MCvScalar
)
public:
void SetRandUniform(
    MCvScalar^ floorValue,
    MCvScalar^ ceilingValue
)
member SetRandUniform :
        floorValue : MCvScalar *
        ceilingValue : MCvScalar -> unit

Parameters

floorValue
Type: Emgu.CV.StructureMCvScalar
the inclusive lower boundary of random numbers range
ceilingValue
Type: Emgu.CV.StructureMCvScalar
the exclusive upper boundary of random numbers range
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).SetValue Method

CvArrayTDepthSetValue Method

Overload List
 | Name | Description
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).SetValue Method (Double, CvArray(Byte))

CvArrayTDepthSetValue Method (Double, CvArrayByte)

http://www.emgu.com
Set the element of the Array to value, using the specific mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    double value,
    CvArray<byte> mask = null
)
Public Sub SetValue (
    value As Double,
    Optional mask As CvArray(Of Byte) = Nothing
)
public:
void SetValue(
    double value,
    CvArray<unsigned char>^ mask = nullptr
)
member SetValue :
        value : float *
        ?mask : CvArray<byte>
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

value
Type: SystemDouble
The value to be set
mask (Optional)
Type: Emgu.CVCvArray Byte
The mask for the operation
See Also

Reference

CvArrayTDepth Class
SetValue Overload
Emgu.CV Namespace


CvArray(TDepth).SetValue Method (MCvScalar, CvArray(Byte))

CvArrayTDepthSetValue Method (MCvScalar, CvArrayByte)

http://www.emgu.com
Set the element of the Array to value, using the specific mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    MCvScalar value,
    CvArray<byte> mask = null
)
Public Sub SetValue (
    value As MCvScalar,
    Optional mask As CvArray(Of Byte) = Nothing
)
public:
void SetValue(
    MCvScalar^ value,
    CvArray<unsigned char>^ mask = nullptr
)
member SetValue :
        value : MCvScalar *
        ?mask : CvArray<byte>
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

value
Type: Emgu.CV.StructureMCvScalar
The value to be set
mask (Optional)
Type: Emgu.CVCvArray Byte
The mask for the operation
See Also

Reference

CvArrayTDepth Class
SetValue Overload
Emgu.CV Namespace


CvArray(TDepth).SetZero Method

CvArrayTDepthSetZero Method

Set the values to zero

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetZero()
Public Sub SetZero
public:
void SetZero()
member SetZero : unit -> unit
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).ToUMat Method

CvArrayTDepthToUMat Method

Get the umat representation of this mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat ToUMat()
Public Function ToUMat As UMat
public:
UMat^ ToUMat()
member ToUMat : unit -> UMat

Return Value

Type: UMat
The UMat
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth).WriteXml Method

CvArrayTDepthWriteXml Method

Function to call when serializing this object to XML

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void WriteXml(
    XmlWriter writer
)
Public Overridable Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
)
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The xml writer

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth) Fields

CvArrayTDepth Fields

The CvArrayTDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr
Protected field | _dataHandle | The pinned GCHandle to _array;
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._cvMat Field

CvArrayTDepth_cvMat Field

The Mat header that represent this CvArr

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Mat _cvMat
Protected _cvMat As Mat
protected:
Mat^ _cvMat
val mutable _cvMat: Mat

Field Value

Type: Mat
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvArray(TDepth)._dataHandle Field

CvArrayTDepth_dataHandle Field

The pinned GCHandle to _array;

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected GCHandle _dataHandle
Protected _dataHandle As GCHandle
protected:
GCHandle^ _dataHandle
val mutable _dataHandle: GCHandle

Field Value

Type: GCHandle
See Also

Reference

CvArrayTDepth Class
Emgu.CV Namespace


CvInvoke Class

Class that provide access to native OpenCV functions
Inheritance Hierarchy
SystemObject
Emgu.CVCvInvoke

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class CvInvoke
<ExtensionAttribute>
Public NotInheritable Class CvInvoke
[ExtensionAttribute]
public ref class CvInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type CvInvoke =  class end

The CvInvoke type exposes the following members.

Properties
Name | Description
Backends | Returns list of all built-in backends
BuildInformation | Returns full configuration time cmake output. Returned value is raw cmake output including version control system revision, compiler version, compiler flags, enabled modules and third party libraries, etc.Output format depends on target architecture.
CameraBackends | Returns list of available backends which works via cv::VideoCapture(int index)
HaveOpenCL | Check if we have OpenCL
HaveOpenCLCompatibleGpuDevice | Gets a value indicating whether this device have open CL compatible gpu device.
NumberOfCPUs | Returns the number of logical CPUs available for the process.
NumThreads | Get or set the number of threads that are used by parallelized OpenCV functions
StreamBackends | Returns list of available backends which works via cv::VideoCapture(filename)
ThreadNum | Returns the index, from 0 to cvGetNumThreads()-1, of the thread that called the function. It is a wrapper for the function omp_get_thread_num() from OpenMP runtime. The retrieved index may be used to access local-thread data inside the parallelized code fragments.
UseOpenCL | Get or set if OpenCL should be used
UseOptimized | Enables or disables the optimized code.
WriterBackends | Returns list of available backends which works via cv::VideoWriter()
Top
Methods
Name Description
AbsDiff
Calculates absolute difference between two arrays. dst(I)c = abs(src1(I)c - src2(I)c). All the arrays must have the same data type and the same size (or ROI size)
Accumulate
Adds the whole image or its selected region to accumulator sum
AccumulateProduct
Adds product of 2 images or thier selected regions to accumulator acc
AccumulateSquare
Adds the input src or its selected region, raised to power 2, to the accumulator sqsum
AccumulateWeighted
Calculates weighted sum of input src and the accumulator acc so that acc becomes a running average of frame sequence: acc(x,y)=(1-alpha) * acc(x,y) + alpha * image(x,y) if mask(x,y)!=0 where alpha regulates update speed (how fast accumulator forgets about previous frames).
AdaptiveThreshold
Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1.
Add
Adds one array to another one: dst(I)=src1(I)+src2(I) if mask(I)!=0All the arrays must have the same type, except the mask, and the same size (or ROI size)
AddWeighted
Calculated weighted sum of two arrays as following: dst(I)=src1(I)*alpha+src2(I)*beta+gamma All the arrays must have the same type and the same size (or ROI size)
ApplyColorMap(IInputArray, IOutputArray, ColorMapType)
Applies a GNU Octave/MATLAB equivalent colormap on a given image.
ApplyColorMap(IInputArray, IOutputArray, IInputArray)
Applies a user colormap on a given image.
ApproxPolyDP
Approximates a polygonal curve(s) with the specified precision.
ArcLength
Calculates a contour perimeter or a curve length
ArrowedLine
Draws a arrow segment pointing from the first point to the second one.
BilateralFilter
Applies the bilateral filter to an image.
BitwiseAnd
Calculates per-element bit-wise logical conjunction of two arrays: dst(I)=src1(I) & src2(I) if mask(I)!=0 In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size
BitwiseNot
Inverses every bit of every array element:
BitwiseOr
Calculates per-element bit-wise disjunction of two arrays: dst(I)=src1(I)|src2(I) In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size
BitwiseXor
Calculates per-element bit-wise logical conjunction of two arrays: dst(I)=src1(I)^src2(I) if mask(I)!=0 In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size
BlendLinear
Performs linear blending of two images: dst(i, j)=weights1(i, j) x src1(i, j) + weights2(i, j) x src2(i, j)
Blur
Blurs an image using the normalized box filter.
BoundingRectangle
Returns the up-right bounding rectangle for 2d point set
BoxFilter
Blurs an image using the box filter.
BoxPoints(RotatedRect)
Calculates vertices of the input 2d box.
BoxPoints(RotatedRect, IOutputArray)
Calculates vertices of the input 2d box.
BuildOpticalFlowPyramid
Constructs the image pyramid which can be passed to calcOpticalFlowPyrLK.
BuildPyramid
The function constructs a vector of images and builds the Gaussian pyramid by recursively applying pyrDown to the previously built pyramid layers, starting from dst[0]==src.
CalcBackProject
Calculates the back projection of a histogram.
CalcCovarMatrix
Calculates the covariance matrix of a set of vectors.
CalcGlobalOrientation
Calculates the general motion direction in the selected region and returns the angle between 0 and 360. At first the function builds the orientation histogram and finds the basic orientation as a coordinate of the histogram maximum. After that the function calculates the shift relative to the basic orientation as a weighted sum of all orientation vectors: the more recent is the motion, the greater is the weight. The resultant angle is a circular sum of the basic orientation and the shift.
CalcHist
Calculates a histogram of a set of arrays.
CalcMotionGradient
Calculates the derivatives Dx and Dy of mhi and then calculates gradient orientation as: orientation(x,y)=arctan(Dy(x,y)/Dx(x,y)) where both Dx(x,y)' and Dy(x,y)' signs are taken into account (as in cvCartToPolar function). After that mask is filled to indicate where the orientation is valid (see delta1 and delta2 description).
CalcOpticalFlowFarneback(IInputArray, IInputArray, IInputOutputArray, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)
Computes dense optical flow using Gunnar Farneback's algorithm
CalcOpticalFlowFarneback(ImageGray, Byte, ImageGray, Byte, ImageGray, Single, ImageGray, Single, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)
Computes dense optical flow using Gunnar Farneback's algorithm
CalcOpticalFlowPyrLK(IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Size, Int32, MCvTermCriteria, LKFlowFlag, Double)
Implements sparse iterative version of Lucas-Kanade optical flow in pyramids ([Bouguet00]). It calculates coordinates of the feature points on the current video frame given their coordinates on the previous frame. The function finds the coordinates with sub-pixel accuracy.
CalcOpticalFlowPyrLK(IInputArray, IInputArray, PointF, Size, Int32, MCvTermCriteria, PointF, Byte, Single, LKFlowFlag, Double)
Calculates optical flow for a sparse feature set using iterative Lucas-Kanade method in pyramids
CalibrateCamera(IInputArray, IInputArray, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)
Estimates intrinsic camera parameters and extrinsic parameters for each of the views
CalibrateCamera(MCvPoint3D32f, PointF, Size, IInputOutputArray, IInputOutputArray, CalibType, MCvTermCriteria, Mat, Mat)
Estimates intrinsic camera parameters and extrinsic parameters for each of the views
CalibrateHandEye
Computes Hand-Eye calibration
CalibrationMatrixValues
Computes various useful camera (sensor/lens) characteristics using the computed camera calibration matrix, image frame resolution in pixels and the physical aperture size
CamShift
Implements CAMSHIFT object tracking algorithm ([Bradski98]). First, it finds an object center using cvMeanShift and, after that, calculates the object size and orientation.
Canny(IInputArray, IInputArray, IOutputArray, Double, Double, Boolean)
Finds the edges on the input dx, dy and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.
Canny(IInputArray, IOutputArray, Double, Double, Int32, Boolean)
Finds the edges on the input image and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.
CartToPolar
Calculates the magnitude and angle of 2D vectors. magnitude(I)=sqrt( x(I)^2+y(I)^2 ), angle(I)=atan2( y(I)/x(I) ) The angles are calculated with accuracy about 0.3 degrees. For the point (0,0), the angle is set to 0.
CheckLibraryLoaded
Check to make sure all the unmanaged libraries are loaded
CheckRange
Check that every array element is neither NaN nor +- inf. The functions also check that each value is between minVal and maxVal. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions either return false (when quiet=true) or throw an exception.
Circle
Draws a simple or filled circle with given center and radius. The circle is clipped by ROI rectangle.
CLAHE
Contrast Limited Adaptive Histogram Equalization (CLAHE)
ClipLine
Calculates a part of the line segment which is entirely in the rectangle.
ColorChange
Given an original color image, two differently colored versions of this image can be mixed seamlessly.
Compare
Compares the corresponding elements of two arrays and fills the destination mask array: dst(I)=src1(I) op src2(I), dst(I) is set to 0xff (all '1'-bits) if the particular relation between the elements is true and 0 otherwise. All the arrays must have the same type, except the destination, and the same size (or ROI size)
CompareHist
Compares two histograms.
Compute
Computes disparity map for the specified stereo pair
ComputeCorrespondEpilines
For every point in one of the two images of stereo-pair the function cvComputeCorrespondEpilines finds equation of a line that contains the corresponding point (i.e. projection of the same 3D point) in the other image. Each line is encoded by a vector of 3 elements l=[a,b,c]^T, so that: l^T*[x, y, 1]^T=0, or a*x + b*y + c = 0 From the fundamental matrix definition (see cvFindFundamentalMatrix discussion), line l2 for a point p1 in the first image (which_image=1) can be computed as: l2=F*p1 and the line l1 for a point p2 in the second image (which_image=1) can be computed as: l1=F^T*p2Line coefficients are defined up to a scale. They are normalized (a2+b2=1) are stored into correspondent_lines
ConnectedComponents
Computes the connected components labeled image of boolean image
ConnectedComponentsWithStats
Computes the connected components labeled image of boolean image
ContourArea
Calculates area of the whole contour or contour section.
ConvertMaps
Converts image transformation maps from one representation to another.
ConvertPointsFromHomogeneous
Converts points from homogeneous to Euclidean space.
ConvertPointsToHomogeneous
Converts points from Euclidean to homogeneous space.
ConvertScaleAbs
Similar to cvCvtScale but it stores absolute values of the conversion results: dst(I)=abs(src(I)*scale + (shift,shift,...)) The function supports only destination arrays of 8u (8-bit unsigned integers) type, for other types the function can be emulated by combination of cvConvertScale and cvAbs functions.
ConvexHull(PointF, Boolean)
Finds convex hull of 2D point set using Sklansky's algorithm
ConvexHull(IInputArray, IOutputArray, Boolean, Boolean)
The function cvConvexHull2 finds convex hull of 2D point set using Sklansky's algorithm.
ConvexityDefects
Finds the convexity defects of a contour.
CopyMakeBorder
Copies the source 2D array into interior of destination array and makes a border of the specified type around the copied area. The function is useful when one needs to emulate border type that is different from the one embedded into a specific algorithm implementation. For example, morphological functions, as well as most of other filtering functions in OpenCV, internally use replication border type, while the user may need zero border or a border, filled with 1's or 255's
CornerHarris
Runs the Harris edge detector on image. Similarly to cvCornerMinEigenVal and cvCornerEigenValsAndVecs, for each pixel it calculates 2x2 gradient covariation matrix M over block_size x block_size neighborhood. Then, it stores det(M) - k*trace(M)^2 to the destination image. Corners in the image can be found as local maxima of the destination image.
CornerSubPix
Iterates to find the sub-pixel accurate location of corners, or radial saddle points
CorrectMatches
Refines coordinates of corresponding points.
CountNonZero
Returns the number of non-zero elements in arr: result = sumI arr(I)!=0 In case of IplImage both ROI and COI are supported.
CreateHanningWindow
This function computes a Hanning window coefficients in two dimensions.
CvArrToMat
Converts CvMat, IplImage , or CvMatND to Mat.
cvCheckArr
Checks that every array element is neither NaN nor Infinity. If CV_CHECK_RANGE is set, it also checks that every element is greater than or equal to minVal and less than maxVal.
cvClearND
Clears (sets to zero) the particular element of dense array or deletes the element of sparse array. If the element does not exists, the function does nothing
cvConvertScale
This function has several different purposes and thus has several synonyms. It copies one array to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel arrays are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination array element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate cvConvert synonym. If source and destination array types have equal types, this is also a special case that can be used to scale and shift a matrix or an image and that fits to cvScale synonym.
cvCopy
Copies selected elements from input array to output array: dst(I)=src(I) if mask(I)!=0. If any of the passed arrays is of IplImage type, then its ROI and COI fields are used. Both arrays must have the same type, the same number of dimensions and the same size. The function can also copy sparse arrays (mask is not supported in this case).
cvCreateImage
Creates the header and allocates data.
cvCreateImageHeader
Allocates, initializes, and returns the structure IplImage.
cvCreateMat
Allocates header for the new matrix and underlying data, and returns a pointer to the created matrix. Matrices are stored row by row. All the rows are aligned by 4 bytes.
cvCreateSparseMat
The function allocates a multi-dimensional sparse array. Initially the array contain no elements, that is Get or GetReal returns zero for every index
cvGet1D
Return the particular array element
cvGet2D
Return the particular array element
cvGet3D
Return the particular array element
cvGetCol
Return the header, corresponding to a specified column of the input array
cvGetCols
Return the header, corresponding to a specified col span of the input array
cvGetDiag
returns the header, corresponding to a specified diagonal of the input array
cvGetImage
Returns image header for the input array that can be matrix - CvMat*, or image - IplImage*.
cvGetImageCOI
Returns channel of interest of the image (it returns 0 if all the channels are selected).
cvGetImageROI
Returns channel of interest of the image (it returns 0 if all the channels are selected).
cvGetMat
Returns matrix header for the input array that can be matrix - CvMat, image - IplImage or multi-dimensional dense array - CvMatND* (latter case is allowed only if allowND != 0) . In the case of matrix the function simply returns the input pointer. In the case of IplImage* or CvMatND* it initializes header structure with parameters of the current image ROI and returns pointer to this temporary structure. Because COI is not supported by CvMat, it is returned separately.
cvGetRawData
Fills output variables with low-level information about the array data. All output parameters are optional, so some of the pointers may be set to NULL. If the array is IplImage with ROI set, parameters of ROI are returned.
cvGetReal1D
Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.
cvGetReal2D
Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.
cvGetReal3D
Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.
cvGetRow
Return the header, corresponding to a specified row of the input array
cvGetRows
Return the header, corresponding to a specified row span of the input array
cvGetSize
Returns number of rows (CvSize::height) and number of columns (CvSize::width) of the input matrix or image. In case of image the size of ROI is returned.
cvGetSubRect
Returns header, corresponding to a specified rectangle of the input array. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array. ROI is taken into account by the function so the sub-array of ROI is actually extracted.
cvInitImageHeader
Initializes the image header structure, pointer to which is passed by the user, and returns the pointer.
cvInitMatHeader
Initializes already allocated CvMat structure. It can be used to process raw data with OpenCV matrix functions.
cvInitMatNDHeader
Initializes CvMatND structure allocated by the user
cvMaxRect
Finds minimum area rectangle that contains both input rectangles inside
cvRange
Initializes the matrix as following: arr(i,j)=(end-start)*(i*cols(arr)+j)/(cols(arr)*rows(arr))
cvReleaseImage
Releases the header and the image data.
cvReleaseImageHeader
Releases the header.
cvReleaseMat
Decrements the matrix data reference counter and releases matrix header
cvReleaseSparseMat
The function releases the sparse array and clears the array pointer upon exit.
cvResetImageROI
Releases image ROI. After that the whole image is considered selected.
cvReshape
initializes CvMat header so that it points to the same data as the original array but has different shape - different number of channels, different number of rows or both
cvSet2D
Assign the new value to the particular element of array
cvSetData
Assigns user data to the array header.
cvSetImageCOI
Sets the channel of interest to a given value. Value 0 means that all channels are selected, 1 means that the first channel is selected etc. If ROI is NULL and coi != 0, ROI is allocated.
cvSetImageROI
Sets the image ROI to a given rectangle. If ROI is NULL and the value of the parameter rect is not equal to the whole image, ROI is allocated.
cvSetReal1D
Assign the new value to the particular element of single-channel array
cvSetReal2D
Assign the new value to the particular element of single-channel array
cvSetReal3D
Assign the new value to the particular element of single-channel array
cvSetRealND
Assign the new value to the particular element of single-channel array
CvtColor(IInputArray, IOutputArray, ColorConversion, Int32)
Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).
CvtColor(IInputArray, IOutputArray, Type, Type)
Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).
Dct
Performs forward or inverse transform of 1D or 2D floating-point array
Decolor
Transforms a color image to a grayscale image. It is a basic tool in digital printing, stylized black-and-white photograph rendering, and in many single channel image processing applications
DefaultLoadUnmanagedModules
Attempts to load opencv modules from the specific location
DenoiseTVL1
Primal-dual algorithm is an algorithm for solving special types of variational problems (that is, finding a function to minimize some functional). As the image denoising, in particular, may be seen as the variational problem, primal-dual algorithm then can be used to perform denoising and this is exactly what is implemented.
DestroyAllWindows
Destroys all of the HighGUI windows.
DestroyWindow
Destroys the window with a given name
DetailEnhance
This filter enhances the details of a particular image.
Determinant
Returns determinant of the square matrix mat. The direct method is used for small matrices and Gaussian elimination is used for larger matrices. For symmetric positive-determined matrices it is also possible to run SVD with U=V=NULL and then calculate determinant as a product of the diagonal elements of W
Dft
Performs forward or inverse transform of 1D or 2D floating-point array In case of real (single-channel) data, the packed format, borrowed from IPL, is used to to represent a result of forward Fourier transform or input for inverse Fourier transform
Dilate
Dilates the source image using the specified structuring element that determines the shape of a pixel neighborhood over which the maximum is taken The function supports the in-place mode. Dilation can be applied several (iterations) times. In case of color image each channel is processed independently
DistanceTransform
Calculates distance to closest zero pixel for all non-zero pixels of source image
Divide
Divides one array by another: dst(I)=scale * src1(I)/src2(I), if src1!=IntPtr.Zero; dst(I)=scale/src2(I), if src1==IntPtr.Zero; All the arrays must have the same type, and the same size (or ROI size)
DrawChessboardCorners
Draws the individual chessboard corners detected (as red circles) in case if the board was not found (pattern_was_found=0) or the colored corners connected with lines when the board was found (pattern_was_found != 0).
DrawContours
Draws contours outlines or filled contours.
DrawMarker
EdgePreservingFilter
Filtering is the fundamental operation in image and video processing. Edge-preserving smoothing filters are used in many different applications.
Eigen
Computes eigenvalues and eigenvectors of a symmetric matrix
Ellipse(IInputOutputArray, RotatedRect, MCvScalar, Int32, LineType, Int32)
Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.
Ellipse(IInputOutputArray, Point, Size, Double, Double, Double, MCvScalar, Int32, LineType, Int32)
Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.
EMD
Computes the 'minimal work' distance between two weighted point configurations.
EqualizeHist
The algorithm normalizes brightness and increases contrast of the image
Erode
Erodes the source image using the specified structuring element that determines the shape of a pixel neighborhood over which the minimum is taken: dst=erode(src,element): dst(x,y)=min((x',y') in element)) src(x+x',y+y') The function supports the in-place mode. Erosion can be applied several (iterations) times. In case of color image each channel is processed independently.
ErrorStr
Returns the textual description for the specified error status code. In case of unknown status the function returns NULL pointer.
EstimateAffine2D(PointF, PointF, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)
Computes an optimal affine transformation between two 2D point sets.
EstimateAffine2D(IInputArray, IInputArray, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)
Computes an optimal affine transformation between two 2D point sets.
EstimateAffine3D(IInputArray, IInputArray, IOutputArray, IOutputArray, Double, Double)
Computes an optimal affine transformation between two 3D point sets.
EstimateAffine3D(MCvPoint3D32f, MCvPoint3D32f, MatrixDouble, Byte, Double, Double)
Computes an optimal affine transformation between two 3D point sets.
EstimateAffinePartial2D
Computes an optimal limited affine transformation with 4 degrees of freedom between two 2D point sets.
Exp
Calculates exponent of every element of input array: dst(I)=exp(src(I)) Maximum relative error is 7e-6. Currently, the function converts denormalized values to zeros on output
ExtractChannel
Extract the specific channel from the image
FastNlMeansDenoising
Perform image denoising using Non-local Means Denoising algorithm: http://www.ipol.im/pub/algo/bcm_non_local_means_denoising/ with several computational optimizations. Noise expected to be a Gaussian white noise.
FastNlMeansDenoisingColored
Perform image denoising using Non-local Means Denoising algorithm (modified for color image): http://www.ipol.im/pub/algo/bcm_non_local_means_denoising/ with several computational optimizations. Noise expected to be a Gaussian white noise. The function converts image to CIELAB colorspace and then separately denoise L and AB components with given h parameters using fastNlMeansDenoising function.
FillConvexPoly
Fills convex polygon interior. This function is much faster than The function cvFillPoly and can fill not only the convex polygons but any monotonic polygon, i.e. a polygon whose contour intersects every horizontal line (scan line) twice at the most
FillPoly
Fills the area bounded by one or more polygons.
Filter2D
Applies arbitrary linear filter to the image. In-place operation is supported. When the aperture is partially outside the image, the function interpolates outlier pixel values from the nearest pixels that is inside the image
FilterSpeckles
Filters off small noise blobs (speckles) in the disparity map.
Find4QuadCornerSubpix
Finds subpixel-accurate positions of the chessboard corners
FindChessboardCorners
Attempts to determine whether the input image is a view of the chessboard pattern and locate internal chessboard corners
FindChessboardCornersSB
Finds the positions of internal corners of the chessboard using a sector based approach.
FindCirclesGrid(ImageGray, Byte, Size, CalibCgType, Feature2D)
Finds centers in the grid of circles
FindCirclesGrid(IInputArray, Size, IOutputArray, CalibCgType, Feature2D)
Finds centers in the grid of circles
FindContours
Retrieves contours from the binary image and returns the number of retrieved contours. The pointer firstContour is filled by the function. It will contain pointer to the first most outer contour or IntPtr.Zero if no contours is detected (if the image is completely black). Other contours may be reached from firstContour using h_next and v_next links. The sample in cvDrawContours discussion shows how to use contours for connected component detection. Contours can be also used for shape analysis and object recognition - see squares.c in OpenCV sample directory The function modifies the source image content
FindContourTree
Retrieves contours from the binary image as a contour tree. The pointer firstContour is filled by the function. It is provided as a convenient way to obtain the hierarchy value as int[,]. The function modifies the source image content
FindEssentialMat
Calculates an essential matrix from the corresponding points in two images.
FindFundamentalMat
Calculates fundamental matrix using one of four methods listed above and returns the number of fundamental matrices found (1 or 3) and 0, if no matrix is found.
FindHomography(PointF, PointF, RobustEstimationAlgorithm, Double, IOutputArray)
Finds perspective transformation H=||h_ij|| between the source and the destination planes
FindHomography(IInputArray, IInputArray, RobustEstimationAlgorithm, Double, IOutputArray)
Finds perspective transformation H=||hij|| between the source and the destination planes
FindNonZero
Find the location of the non-zero pixel
FindTransformECC
Finds the geometric transform (warp) between two images in terms of the ECC criterion
FitEllipse
Fits an ellipse around a set of 2D points.
FitEllipseAMS
The function calculates the ellipse that fits a set of 2D points. The Approximate Mean Square (AMS) is used.
FitEllipseDirect
The function calculates the ellipse that fits a set of 2D points. The Direct least square (Direct) method by [58] is used.
FitLine(IInputArray, IOutputArray, DistType, Double, Double, Double)
Fits line to 2D or 3D point set
FitLine(PointF, PointF, PointF, DistType, Double, Double, Double)
Fits line to 2D or 3D point set
Flip
Flips the array in one of different 3 ways (row and column indices are 0-based)
FloodFill
Fills a connected component with given color.
GaussianBlur
Blurs an image using a Gaussian filter.
Gemm
Performs generalized matrix multiplication: dst = alpha*op(src1)*op(src2) + beta*op(src3), where op(X) is X or XT
GetAffineTransform(PointF, PointF)
Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.
GetAffineTransform(IInputArray, IOutputArray)
Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.
GetCvStructSizes
This function retrieve the Open CV structure sizes in unmanaged code
GetDefaultNewCameraMatrix
Returns the default new camera matrix.
GetDepthType(Type)
Get the corresponding opencv depth type
GetDepthType(DepthType)
Get the corresponding depth type
GetErrMode
Returns the current error mode
GetErrStatus
Returns the current error status - the value set with the last cvSetErrStatus call. Note, that in Leaf mode the program terminates immediately after error occurred, so to always get control after the function call, one should call cvSetErrMode and set Parent or Silent error mode.
GetModuleFormatString
Get the module format string.
GetOptimalDFTSize
Returns the minimum number N that is greater to equal to size0, such that DFT of a vector of size N can be computed fast. In the current implementation N=2^p x 3^q x 5^r for some p, q, r.
GetOptimalNewCameraMatrix
Returns the new camera matrix based on the free scaling parameter.
GetPerspectiveTransform(PointF, PointF)
calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.
GetPerspectiveTransform(IInputArray, IInputArray)
calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.
GetRectSubPix
Extracts pixels from src: dst(x, y) = src(x + center.x - (width(dst)-1)*0.5, y + center.y - (height(dst)-1)*0.5) where the values of pixels at non-integer coordinates are retrieved using bilinear interpolation. Every channel of multiple-channel images is processed independently. Whereas the rectangle center must be inside the image, the whole rectangle may be partially occluded. In this case, the replication border mode is used to get pixel values beyond the image boundaries.
GetRotationMatrix2D
Calculates rotation matrix
GetStructuringElement
Returns a structuring element of the specified size and shape for morphological operations.
GetTextSize
Calculates the width and height of a text string.
GrabCut
The grab cut algorithm for segmentation
GroupRectangles(VectorOfRect, Int32, Double)
Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, VectorOfInt, Int32, Double)
Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, VectorOfInt, VectorOfDouble, Int32, Double)
Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, Int32, Double, VectorOfInt, VectorOfDouble)
Groups the object candidate rectangles.
GroupRectanglesMeanshift
Groups the object candidate rectangles.
HConcat
Horizontally concatenate two images
HoughCircles(IInputArray, HoughType, Double, Double, Double, Double, Int32, Int32)
Finds circles in a grayscale image using the Hough transform
HoughCircles(IInputArray, IOutputArray, HoughType, Double, Double, Double, Double, Int32, Int32)
Finds circles in grayscale image using some modification of Hough transform
HoughLines
Finds lines in a binary image using the standard Hough transform.
HoughLinesP(IInputArray, Double, Double, Int32, Double, Double)
Finds line segments in a binary image using the probabilistic Hough transform.
HoughLinesP(IInputArray, IOutputArray, Double, Double, Int32, Double, Double)
Finds line segments in a binary image using the probabilistic Hough transform.
HuMoments(Moments)
Calculates seven Hu invariants
HuMoments(Moments, IOutputArray)
Calculates seven Hu invariants
IlluminationChange
Applying an appropriate non-linear transformation to the gradient field inside the selection and then integrating back with a Poisson solver, modifies locally the apparent illumination of an image.
Imdecode(Byte, ImreadModes, Mat)
Decode image stored in the buffer
Imdecode(IInputArray, ImreadModes, Mat)
Decode image stored in the buffer
Imencode
encode image and store the result as a byte vector.
Imread
Loads an image from the specified file and returns the pointer to the loaded image. Currently the following file formats are supported:
Windows bitmaps - BMP, DIB;
JPEG files - JPEG, JPG, JPE;
Portable Network Graphics - PNG;
Portable image format - PBM, PGM, PPM;
Sun rasters - SR, RAS;
TIFF files - TIFF, TIF;
OpenEXR HDR images - EXR;
JPEG 2000 images - jp2.
Imreadmulti
The function imreadmulti loads a multi-page image from the specified file into a vector of Mat objects.
Imshow
Shows the image in the specified window
Imwrite
Saves the image to the specified file. The image format is chosen depending on the filename extension, see cvLoadImage. Only 8-bit single-channel or 3-channel (with 'BGR' channel order) images can be saved using this function. If the format, depth or channel order is different, use cvCvtScale and cvCvtColor to convert it before saving, or use universal cvSave to save the image to XML or YAML format
InitCameraMatrix2D
Finds an initial camera matrix from 3D-2D point correspondences.
InitUndistortRectifyMap
This function is an extended version of cvInitUndistortMap. That is, in addition to the correction of lens distortion, the function can also apply arbitrary perspective transformation R and finally it can scale and shift the image according to the new camera matrix
Inpaint
Reconstructs the selected image area from the pixel near the area boundary. The function may be used to remove dust and scratches from a scanned photo, or to remove undesirable objects from still images or video.
InRange
Performs range check for every element of the input array: dst(I)=lower(I)_0 <= src(I)_0 <= upper(I)_0 For single-channel arrays, dst(I)=lower(I)_0 <= src(I)_0 <= upper(I)_0 && lower(I)_1 <= src(I)_1 <= upper(I)_1 For two-channel arrays etc. dst(I) is set to 0xff (all '1'-bits) if src(I) is within the range and 0 otherwise. All the arrays must have the same type, except the destination, and the same size (or ROI size)
InsertChannel
Insert the specific channel to the image
Integral
Calculates one or more integral images for the source image Using these integral images, one may calculate sum, mean, standard deviation over arbitrary up-right or rotated rectangular region of the image in a constant time. It makes possible to do a fast blurring or fast block correlation with variable window size etc. In case of multi-channel images sums for each channel are accumulated independently.
IntersectConvexConvex
finds intersection of two convex polygons
Invert
Finds the inverse or pseudo-inverse of a matrix. This function inverts the matrix src and stores the result in dst . When the matrix src is singular or non-square, the function calculates the pseudo-inverse matrix (the dst matrix) so that norm(src*dst - I) is minimal, where I is an identity matrix.
InvertAffineTransform
Inverts an affine transformation
IsContourConvex
The function tests whether the input contour is convex or not. The contour must be simple, that is, without self-intersections. Otherwise, the function output is undefined.
Kmeans
Implements k-means algorithm that finds centers of cluster_count clusters and groups the input samples around the clusters. On output labels(i) contains a cluster index for sample stored in the i-th row of samples matrix
Laplacian
Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator: dst(x,y) = d2src/dx2 + d2src/dy2 Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0| Similar to cvSobel function, no scaling is done and the same combinations of input and output formats are supported.
Line
Draws the line segment between pt1 and pt2 points in the image. The line is clipped by the image or ROI rectangle. For non-antialiased lines with integer coordinates the 8-connected or 4-connected Bresenham algorithm is used. Thick lines are drawn with rounding endings. Antialiased lines are drawn using Gaussian filtering.
LinearPolar
The function emulates the human "foveal" vision and can be used for fast scale and rotation-invariant template matching, for object tracking etc.
LoadUnmanagedModules
Attempts to load opencv modules from the specific location
Log
Calculates natural logarithm of absolute value of every element of input array: dst(I)=log(abs(src(I))), src(I)!=0 dst(I)=C, src(I)=0 Where C is large negative number (-700 in the current implementation)
LogPolar
The function emulates the human "foveal" vision and can be used for fast scale and rotation-invariant template matching, for object tracking etc.
LUT
Fills the destination array with values from the look-up table. Indices of the entries are taken from the source array. That is, the function processes each element of src as following: dst(I)=lut[src(I)+DELTA] where DELTA=0 if src has depth CV_8U, and DELTA=128 if src has depth CV_8S
Mahalanobis
Calculates the weighted distance between two vectors and returns it
MakeType
This function performs the same as MakeType macro
MatchShapes
Compares two shapes. The 3 implemented methods all use Hu moments
MatchTemplate
This function is similiar to cvCalcBackProjectPatch. It slids through image, compares overlapped patches of size wxh with templ using the specified method and stores the comparison results to result
Max
Calculates per-element maximum of two arrays: dst(I)=max(src1(I), src2(I)) All the arrays must have a single channel, the same data type and the same size (or ROI size).
Mean
Calculates the average value M of array elements, independently for each channel: N = sumI mask(I)!=0 Mc = 1/N * sumI,mask(I)!=0 arr(I)c If the array is IplImage and COI is set, the function processes the selected channel only and stores the average to the first scalar component (S0).
MeanShift
Iterates to find the object center given its back projection and initial position of search window. The iterations are made until the search window center moves by less than the given value and/or until the function has done the maximum number of iterations.
MeanStdDev(IInputArray, IOutputArray, IOutputArray, IInputArray)
Calculates a mean and standard deviation of array elements.
MeanStdDev(IInputArray, MCvScalar, MCvScalar, IInputArray)
The function cvAvgSdv calculates the average value and standard deviation of array elements, independently for each channel
MedianBlur
Blurs an image using the median filter.
Merge
This function is the opposite to cvSplit. If the destination array has N channels then if the first N input channels are not IntPtr.Zero, all they are copied to the destination array, otherwise if only a single source channel of the first N is not IntPtr.Zero, this particular channel is copied into the destination array, otherwise an error is raised. Rest of source channels (beyond the first N) must always be IntPtr.Zero. For IplImage cvCopy with COI set can be also used to insert a single channel into the image.
Min
Calculates per-element minimum of two arrays: dst(I)=min(src1(I),src2(I)) All the arrays must have a single channel, the same data type and the same size (or ROI size).
MinAreaRect(PointF)
Find the bounding rectangle for the specific array of points
MinAreaRect(IInputArray)
Finds a rotated rectangle of the minimum area enclosing the input 2D point set.
MinEnclosingCircle(PointF)
Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)
MinEnclosingCircle(IInputArray)
Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)
MinEnclosingTriangle
Finds a triangle of minimum area enclosing a 2D point set and returns its area.
MinMaxIdx
Finds the global minimum and maximum in an array
MinMaxLoc
Finds minimum and maximum element values and their positions. The extremums are searched over the whole array, selected ROI (in case of IplImage) or, if mask is not IntPtr.Zero, in the specified array region. If the array has more than one channel, it must be IplImage with COI set. In case if multi-dimensional arrays min_loc->x and max_loc->x will contain raw (linear) positions of the extremums
MixChannels
The function cvMixChannels is a generalized form of cvSplit and cvMerge and some forms of cvCvtColor. It can be used to change the order of the planes, add/remove alpha channel, extract or insert a single plane or multiple planes etc.
Moments
Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characeteristics including 7 Hu invariants.
MorphologyEx
Performs advanced morphological transformations.
MulSpectrums
Performs per-element multiplication of the two CCS-packed or complex matrices that are results of real or complex Fourier transform.
Multiply
Calculates per-element product of two arrays: dst(I)=scale*src1(I)*src2(I) All the arrays must have the same type, and the same size (or ROI size)
MulTransposed
Calculates the product of src and its transposition. The function evaluates dst=scale(src-delta)*(src-delta)^T if order=0, and dst=scale(src-delta)^T*(src-delta) otherwise.
NamedWindow
Creates a window which can be used as a placeholder for images and trackbars. Created windows are reffered by their names. If the window with such a name already exists, the function does nothing.
Norm(IInputArray, NormType, IInputArray)
Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.
Norm(IInputArray, IInputOutputArray, NormType, IInputArray)
Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.
Normalize
normalizes the input array so that it's norm or value range takes the certain value(s).
OclFinish
Finishes OpenCL queue.
OclGetPlatformsSummary
Get the OpenCL platform summary as a string
OclSetDefaultDevice
Set the default opencl device
PatchNaNs
Converts NaN's to the given number
PCABackProject
Reconstructs vectors from their PC projections.
PCACompute(IInputArray, IInputOutputArray, IOutputArray, Double)
Performs Principal Component Analysis of the supplied dataset.
PCACompute(IInputArray, IInputOutputArray, IOutputArray, Int32)
Performs Principal Component Analysis of the supplied dataset.
PCAProject
Projects vector(s) to the principal component subspace.
PencilSketch
Pencil-like non-photorealistic line drawing
PerspectiveTransform(PointF, IInputArray)
Transforms every element of src in the following way: (x, y) -> (x'/w, y'/w), where (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise
PerspectiveTransform(IInputArray, IOutputArray, IInputArray)
Transforms every element of src (by treating it as 2D or 3D vector) in the following way: (x, y, z) -> (x'/w, y'/w, z'/w) or (x, y) -> (x'/w, y'/w), where (x', y', z', w') = mat4x4 * (x, y, z, 1) or (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise
PhaseCorrelate
The function is used to detect translational shifts that occur between two images. The operation takes advantage of the Fourier shift theorem for detecting the translational shift in the frequency domain. It can be used for fast image registration as well as motion estimation.
PointPolygonTest
Determines whether the point is inside contour, outside, or lies on an edge (or coinsides with a vertex). It returns positive, negative or zero value, correspondingly
PolarToCart
Calculates either x-coordinate, y-coordinate or both of every vector magnitude(I)* exp(angle(I)*j), j=sqrt(-1): x(I)=magnitude(I)*cos(angle(I)), y(I)=magnitude(I)*sin(angle(I))
Polylines(IInputOutputArray, IInputArray, Boolean, MCvScalar, Int32, LineType, Int32)
Draws a single or multiple polygonal curves
Polylines(IInputOutputArray, Point, Boolean, MCvScalar, Int32, LineType, Int32)
Draws a single or multiple polygonal curves
Pow
Raises every element of input array to p: dst(I)=src(I)p, if p is integer dst(I)=abs(src(I))p, otherwise That is, for non-integer power exponent the absolute values of input array elements are used. However, it is possible to get true values for negative values using some extra operations, as the following sample, computing cube root of array elements, shows: CvSize size = cvGetSize(src); CvMat* mask = cvCreateMat( size.height, size.width, CV_8UC1 ); cvCmpS( src, 0, mask, CV_CMP_LT ); /* find negative elements */ cvPow( src, dst, 1./3 ); cvSubRS( dst, cvScalarAll(0), dst, mask ); /* negate the results of negative inputs */ cvReleaseMat( &mask ); For some values of power, such as integer values, 0.5 and -0.5, specialized faster algorithms are used.
ProjectPoints(MCvPoint3D32f, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, Double)
Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters.
ProjectPoints(IInputArray, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Double)
Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters. Note, that with intrinsic and/or extrinsic parameters set to special values, the function can be used to compute just extrinsic transformation or just intrinsic transformation (i.e. distortion of a sparse set of points).
PSNR
Computes PSNR image/video quality metric
PutText
Renders the text in the image with the specified font and color. The printed text is clipped by ROI rectangle. Symbols that do not belong to the specified font are replaced with the rectangle symbol.
PyrDown
Performs downsampling step of Gaussian pyramid decomposition. First it convolves source image with the specified filter and then downsamples the image by rejecting even rows and columns.
PyrMeanShiftFiltering
Filters image using meanshift algorithm
PyrUp
Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples the source image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the destination image is four times larger than the source image.
Randn(IInputOutputArray, IInputArray, IInputArray)
Fills the array with normally distributed random numbers.
Randn(IInputOutputArray, MCvScalar, MCvScalar)
Fills the array with normally distributed random numbers.
RandShuffle
Shuffles the matrix by swapping randomly chosen pairs of the matrix elements on each iteration (where each element may contain several components in case of multi-channel arrays)
Randu(IInputOutputArray, IInputArray, IInputArray)
Generates a single uniformly-distributed random number or an array of random numbers.
Randu(IInputOutputArray, MCvScalar, MCvScalar)
Generates a single uniformly-distributed random number or an array of random numbers.
ReadCloud
Read point cloud from file
Rectangle
Draws a rectangle specified by a CvRect structure
RedirectError(IntPtr, IntPtr, IntPtr)
Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.
RedirectError(CvInvokeCvErrorCallback, IntPtr, IntPtr)
Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.
Reduce
Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.
Remap
Applies a generic geometrical transformation to an image.
Repeat
Fills the destination array with source array tiled: dst(i,j)=src(i mod rows(src), j mod cols(src))So the destination array may be as larger as well as smaller than the source array
ReprojectImageTo3D
Transforms 1-channel disparity map to 3-channel image, a 3D surface.
Resize
Resizes the image src down to or up to the specified size
ResizeForFrame
Resize an image such that it fits in a given frame
Rodrigues
Converts a rotation vector to rotation matrix or vice versa. Rotation vector is a compact representation of rotation matrix. Direction of the rotation vector is the rotation axis and the length of the vector is the rotation angle around the axis.
Rotate
Rotates a 2D array in multiples of 90 degrees.
RotatedRectangleIntersection
Finds out if there is any intersection between two rotated rectangles.
SanityCheck
Check if the size of the C structures match those of C#
Scharr
Calculates the first x- or y- image derivative using Scharr operator.
SeamlessClone
Image editing tasks concern either global changes (color/intensity corrections, filters, deformations) or local changes concerned to a selection. Here we are interested in achieving local changes, ones that are restricted to a region manually selected (ROI), in a seamless and effortless manner. The extent of the changes ranges from slight distortions to complete replacement by novel content
SegmentMotion
Finds all the motion segments and marks them in segMask with individual values each (1,2,...). It also returns a sequence of CvConnectedComp structures, one per each motion components. After than the motion direction for every component can be calculated with cvCalcGlobalOrientation using extracted mask of the particular component (using cvCmp)
SelectROI
Selects ROI on the given image. Function creates a window and allows user to select a ROI using mouse. Controls: use space or enter to finish selection, use key c to cancel selection (function will return the zero cv::Rect).
SelectROIs
Selects ROIs on the given image. Function creates a window and allows user to select a ROIs using mouse. Controls: use space or enter to finish current selection and start a new one, use esc to terminate multiple ROI selection process.
SepFilter2D
The function applies a separable linear filter to the image. That is, first, every row of src is filtered with the 1D kernel kernelX. Then, every column of the result is filtered with the 1D kernel kernelY. The final result shifted by delta is stored in dst .
SetErrMode
Sets the specified error mode.
SetErrStatus
Sets the error status to the specified value. Mostly, the function is used to reset the error status (set to it CV_StsOk) to recover after error. In other cases it is more natural to call cvError or CV_ERROR.
SetIdentity
Initializes scaled identity matrix: arr(i,j)=value if i=j, 0 otherwise
Sobel
The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative. The first case corresponds to

              |-1  0  1|
              |-2  0  2|
              |-1  0  1|
kernel and the second one corresponds to
              |-1 -2 -1|
              | 0  0  0|
              | 1  2  1|
or
              | 1  2  1|
              | 0  0  0|
              |-1 -2 -1|
kernel, depending on the image origin (origin field of IplImage structure). No scaling is done, so the destination image usually has larger by absolute value numbers than the source image. To avoid overflow, the function requires 16-bit destination image if the source image is 8-bit. The result can be converted back to 8-bit using cvConvertScale or cvConvertScaleAbs functions. Besides 8-bit images the function can process 32-bit floating-point images. Both source and destination must be single-channel images of equal size or ROI size
Solve
Solves linear system (src1)*(dst) = (src2)
SolveCubic
finds real roots of a cubic equation: coeffs[0]*x^3 + coeffs[1]*x^2 + coeffs[2]*x + coeffs[3] = 0 (if coeffs is 4-element vector) or x^3 + coeffs[0]*x^2 + coeffs[1]*x + coeffs[2] = 0 (if coeffs is 3-element vector)
SolveLP
Solve given (non-integer) linear programming problem using the Simplex Algorithm (Simplex Method). What we mean here by “linear programming problem” (or LP problem, for short) can be formulated as: Maximize c x subject to: Ax <= b and x >= 0
SolveP3P
Finds an object pose from 3 3D-2D point correspondences.
SolvePnP(IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)
Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error
SolvePnP(MCvPoint3D32f, PointF, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)
Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error.
SolvePnPGeneric
Finds an object pose from 3D-2D point correspondences.
SolvePnPRansac
Finds an object pose from 3D-2D point correspondences using the RANSAC scheme.
SolvePnPRefineLM
Refine a pose (the translation and the rotation that transform a 3D point expressed in the object coordinate frame to the camera coordinate frame) from a 3D-2D point correspondences and starting from an initial solution
SolvePnPRefineVVS
Refine a pose (the translation and the rotation that transform a 3D point expressed in the object coordinate frame to the camera coordinate frame) from a 3D-2D point correspondences and starting from an initial solution.
SolvePoly
Finds all real and complex roots of any degree polynomial with real coefficients
Sort
Sorts each matrix row or each matrix column in ascending or descending order.So you should pass two operation flags to get desired behaviour.
SortIdx
Sorts each matrix row or each matrix column in the ascending or descending order.So you should pass two operation flags to get desired behaviour. Instead of reordering the elements themselves, it stores the indices of sorted elements in the output array.
SpatialGradient
Calculates the first order image derivative in both x and y using a Sobel operator. Equivalent to calling: Sobel(src, dx, CV_16SC1, 1, 0, 3 ); Sobel(src, dy, CV_16SC1, 0, 1, 3 );
Split
Divides a multi-channel array into separate single-channel arrays. Two modes are available for the operation. If the source array has N channels then if the first N destination channels are not IntPtr.Zero, all they are extracted from the source array, otherwise if only a single destination channel of the first N is not IntPtr.Zero, this particular channel is extracted, otherwise an error is raised. Rest of destination channels (beyond the first N) must always be IntPtr.Zero. For IplImage cvCopy with COI set can be also used to extract a single channel from the image
SqrBoxFilter
Calculates the normalized sum of squares of the pixel values overlapping the filter. For every pixel(x, y) in the source image, the function calculates the sum of squares of those neighboring pixel values which overlap the filter placed over the pixel(x, y). The unnormalized square box filter can be useful in computing local image statistics such as the the local variance and standard deviation around the neighborhood of a pixel.
Sqrt
Calculate square root of each source array element. in the case of multichannel arrays each channel is processed independently. The function accuracy is approximately the same as of the built-in std::sqrt.
StereoCalibrate(IInputArray, IInputArray, IInputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)
Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the fist camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T
StereoCalibrate(MCvPoint3D32f, PointF, PointF, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)
Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the first camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T
StereoRectify
computes the rotation matrices for each camera that (virtually) make both camera image planes the same plane. Consequently, that makes all the epipolar lines parallel and thus simplifies the dense stereo correspondence problem. On input the function takes the matrices computed by cvStereoCalibrate and on output it gives 2 rotation matrices and also 2 projection matrices in the new coordinates. The function is normally called after cvStereoCalibrate that computes both camera matrices, the distortion coefficients, R and T
StereoRectifyUncalibrated
Computes the rectification transformations without knowing intrinsic parameters of the cameras and their relative position in space, hence the suffix "Uncalibrated". Another related difference from cvStereoRectify is that the function outputs not the rectification transformations in the object (3D) space, but the planar perspective transformations, encoded by the homography matrices H1 and H2. The function implements the following algorithm [Hartley99].
Stylization
Stylization aims to produce digital imagery with a wide variety of effects not focused on photorealism. Edge-aware filters are ideal for stylization, as they can abstract regions of low contrast while preserving, or enhancing, high-contrast features.
Subtract
Subtracts one array from another one: dst(I)=src1(I)-src2(I) if mask(I)!=0 All the arrays must have the same type, except the mask, and the same size (or ROI size)
Sum
Calculates sum S of array elements, independently for each channel Sc = sumI arr(I)c If the array is IplImage and COI is set, the function processes the selected channel only and stores the sum to the first scalar component (S0).
SVBackSubst
Performs a singular value back substitution.
SVDecomp
Decomposes matrix A into a product of a diagonal matrix and two orthogonal matrices: A=U*W*VT Where W is diagonal matrix of singular values that can be coded as a 1D vector of singular values and U and V. All the singular values are non-negative and sorted (together with U and V columns) in descenting order.
Swap(Mat, Mat)
Swaps two matrices
Swap(UMat, UMat)
Swaps two matrices
TextureFlattening
By retaining only the gradients at edge locations, before integrating with the Poisson solver, one washes out the texture of the selected region, giving its contents a flat aspect. Here Canny Edge Detector is used.
Threshold
Applies a fixed-level threshold to each array element. The function applies fixed-level thresholding to a multiple-channel array. The function is typically used to get a bi-level (binary) image out of a grayscale image ( compare could be also used for this purpose) or for removing a noise, that is, filtering out pixels with too small or too large values. There are several types of thresholding supported by the function. They are determined by type parameter.
Trace
Returns sum of diagonal elements of the matrix mat.
Transform
Performs matrix transformation of every element of array src and stores the results in dst Both source and destination arrays should have the same depth and the same size or selected ROI size. transmat and shiftvec should be real floating-point matrices.
Transpose
Transposes matrix src1: dst(i,j)=src(j,i) Note that no complex conjugation is done in case of complex matrix. Conjugation should be done separately: look at the sample code in cvXorS for example
TriangulatePoints
Reconstructs points by triangulation.
Undistort
Transforms the image to compensate radial and tangential lens distortion.
UndistortPoints
Similar to cvInitUndistortRectifyMap and is opposite to it at the same time. The functions are similar in that they both are used to correct lens distortion and to perform the optional perspective (rectification) transformation. They are opposite because the function cvInitUndistortRectifyMap does actually perform the reverse transformation in order to initialize the maps properly, while this function does the forward transformation.
UpdateMotionHistory
Updates the motion history image as following:
mhi(x,y)=timestamp  if silhouette(x,y)!=0
        0          if silhouette(x,y)=0 and mhi(x,y)<timestamp-duration
        mhi(x,y)   otherwise
That is, MHI pixels where motion occurs are set to the current timestamp, while the pixels where motion happened far ago are cleared.
VConcat
Vertically concatenate two images
WaitKey
Waits for key event infinitely (delay <= 0) or for "delay" milliseconds.
WarpAffine
Applies an affine transformation to an image.
WarpPerspective
Applies a perspective transformation to an image
Watershed
Implements one of the variants of watershed, non-parametric marker-based segmentation algorithm, described in [Meyer92] Before passing the image to the function, user has to outline roughly the desired regions in the image markers with positive (>0) indices, i.e. every region is represented as one or more connected components with the pixel values 1, 2, 3 etc. Those components will be "seeds" of the future image regions. All the other pixels in markers, which relation to the outlined regions is not known and should be defined by the algorithm, should be set to 0's. On the output of the function, each pixel in markers is set to one of values of the "seed" components, or to -1 at boundaries between the regions.
WriteCloud
Write point cloud to file
Top
Fields
Name | Description
BoolMarshalType | Represent a bool value in C++
BoolToIntMarshalType | Represent a int value in C++
CvCallingConvention | Opencv's calling convention
CvErrorHandlerIgnoreError | An error handler which will ignore any error and continue
CvErrorHandlerThrowException | The default Exception callback to handle Error thrown by OpenCV
ExternCudaLibrary | The file name of the cvextern library
ExternLibrary | The file name of the cvextern library
MorphologyDefaultBorderValue | The default morphology value.
OpencvFFMpegLibrary | The file name of the opencv_ffmpeg library
OpenCVModuleList | The List of the opencv modules
StringMarshalType | string marshaling type
Top
See Also

Reference

Emgu.CV Namespace


CvInvoke Properties

The CvInvoke type exposes the following members.

Properties
Name | Description
Backends | Returns list of all built-in backends
BuildInformation | Returns full configuration time cmake output. Returned value is raw cmake output including version control system revision, compiler version, compiler flags, enabled modules and third party libraries, etc.Output format depends on target architecture.
CameraBackends | Returns list of available backends which works via cv::VideoCapture(int index)
HaveOpenCL | Check if we have OpenCL
HaveOpenCLCompatibleGpuDevice | Gets a value indicating whether this device have open CL compatible gpu device.
NumberOfCPUs | Returns the number of logical CPUs available for the process.
NumThreads | Get or set the number of threads that are used by parallelized OpenCV functions
StreamBackends | Returns list of available backends which works via cv::VideoCapture(filename)
ThreadNum | Returns the index, from 0 to cvGetNumThreads()-1, of the thread that called the function. It is a wrapper for the function omp_get_thread_num() from OpenMP runtime. The retrieved index may be used to access local-thread data inside the parallelized code fragments.
UseOpenCL | Get or set if OpenCL should be used
UseOptimized | Enables or disables the optimized code.
WriterBackends | Returns list of available backends which works via cv::VideoWriter()
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Backends Property

CvInvokeBackends Property

Returns list of all built-in backends

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Backend[] Backends { get; }
Public Shared ReadOnly Property Backends As Backend()
    Get
public:
static property array<Backend^>^ Backends {
    array<Backend^>^ get ();
}
static member Backends : Backend[] with get

Property Value

Type: Backend
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BuildInformation Property

CvInvokeBuildInformation Property

Returns full configuration time cmake output. Returned value is raw cmake output including version control system revision, compiler version, compiler flags, enabled modules and third party libraries, etc.Output format depends on target architecture.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string BuildInformation { get; }
Public Shared ReadOnly Property BuildInformation As String
    Get
public:
static property String^ BuildInformation {
    String^ get ();
}
static member BuildInformation : string with get

Property Value

Type: String
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CameraBackends Property

CvInvokeCameraBackends Property

Returns list of available backends which works via cv::VideoCapture(int index)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Backend[] CameraBackends { get; }
Public Shared ReadOnly Property CameraBackends As Backend()
    Get
public:
static property array<Backend^>^ CameraBackends {
    array<Backend^>^ get ();
}
static member CameraBackends : Backend[] with get

Property Value

Type: Backend
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HaveOpenCL Property

CvInvokeHaveOpenCL Property

Check if we have OpenCL

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HaveOpenCL { get; }
Public Shared ReadOnly Property HaveOpenCL As Boolean
    Get
public:
static property bool HaveOpenCL {
    bool get ();
}
static member HaveOpenCL : bool with get

Property Value

Type: Boolean
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HaveOpenCLCompatibleGpuDevice Property

CvInvokeHaveOpenCLCompatibleGpuDevice Property

Gets a value indicating whether this device have open CL compatible gpu device.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HaveOpenCLCompatibleGpuDevice { get; }
Public Shared ReadOnly Property HaveOpenCLCompatibleGpuDevice As Boolean
    Get
public:
static property bool HaveOpenCLCompatibleGpuDevice {
    bool get ();
}
static member HaveOpenCLCompatibleGpuDevice : bool with get

Property Value

Type: Boolean
true if have open CL compatible gpu device; otherwise, false.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.NumberOfCPUs Property

CvInvokeNumberOfCPUs Property

Returns the number of logical CPUs available for the process.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int NumberOfCPUs { get; }
Public Shared ReadOnly Property NumberOfCPUs As Integer
    Get
public:
static property int NumberOfCPUs {
    int get ();
}
static member NumberOfCPUs : int with get

Property Value

Type: Int32
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.NumThreads Property

CvInvokeNumThreads Property

Get or set the number of threads that are used by parallelized OpenCV functions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int NumThreads { get; set; }
Public Shared Property NumThreads As Integer
    Get
    Set
public:
static property int NumThreads {
    int get ();
    void set (int value);
}
static member NumThreads : int with get, set

Property Value

Type: Int32
Remarks
When the argument is zero or negative, and at the beginning of the program, the number of threads is set to the number of processors in the system, as returned by the function omp_get_num_procs() from OpenMP runtime.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.StreamBackends Property

CvInvokeStreamBackends Property

Returns list of available backends which works via cv::VideoCapture(filename)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Backend[] StreamBackends { get; }
Public Shared ReadOnly Property StreamBackends As Backend()
    Get
public:
static property array<Backend^>^ StreamBackends {
    array<Backend^>^ get ();
}
static member StreamBackends : Backend[] with get

Property Value

Type: Backend
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ThreadNum Property

CvInvokeThreadNum Property

Returns the index, from 0 to cvGetNumThreads()-1, of the thread that called the function. It is a wrapper for the function omp_get_thread_num() from OpenMP runtime. The retrieved index may be used to access local-thread data inside the parallelized code fragments.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int ThreadNum { get; }
Public Shared ReadOnly Property ThreadNum As Integer
    Get
public:
static property int ThreadNum {
    int get ();
}
static member ThreadNum : int with get

Property Value

Type: Int32
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.UseOpenCL Property

CvInvokeUseOpenCL Property

Get or set if OpenCL should be used

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool UseOpenCL { get; set; }
Public Shared Property UseOpenCL As Boolean
    Get
    Set
public:
static property bool UseOpenCL {
    bool get ();
    void set (bool value);
}
static member UseOpenCL : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.UseOptimized Property

CvInvokeUseOptimized Property

Enables or disables the optimized code.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool UseOptimized { get; set; }
Public Shared Property UseOptimized As Boolean
    Get
    Set
public:
static property bool UseOptimized {
    bool get ();
    void set (bool value);
}
static member UseOptimized : bool with get, set

Property Value

Type: Boolean
true if [use optimized]; otherwise, false.
Remarks
The function can be used to dynamically turn on and off optimized code (code that uses SSE2, AVX, and other instructions on the platforms that support it). It sets a global flag that is further checked by OpenCV functions. Since the flag is not checked in the inner OpenCV loops, it is only safe to call the function on the very top level in your application where you can be sure that no other OpenCV function is currently executed.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.WriterBackends Property

CvInvokeWriterBackends Property

Returns list of available backends which works via cv::VideoWriter()

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Backend[] WriterBackends { get; }
Public Shared ReadOnly Property WriterBackends As Backend()
    Get
public:
static property array<Backend^>^ WriterBackends {
    array<Backend^>^ get ();
}
static member WriterBackends : Backend[] with get

Property Value

Type: Backend
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke Methods

The CvInvoke type exposes the following members.

Methods
Name Description
AbsDiff
Calculates absolute difference between two arrays. dst(I)c = abs(src1(I)c - src2(I)c). All the arrays must have the same data type and the same size (or ROI size)
Accumulate
Adds the whole image or its selected region to accumulator sum
AccumulateProduct
Adds product of 2 images or thier selected regions to accumulator acc
AccumulateSquare
Adds the input src or its selected region, raised to power 2, to the accumulator sqsum
AccumulateWeighted
Calculates weighted sum of input src and the accumulator acc so that acc becomes a running average of frame sequence: acc(x,y)=(1-alpha) * acc(x,y) + alpha * image(x,y) if mask(x,y)!=0 where alpha regulates update speed (how fast accumulator forgets about previous frames).
AdaptiveThreshold
Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1.
Add
Adds one array to another one: dst(I)=src1(I)+src2(I) if mask(I)!=0All the arrays must have the same type, except the mask, and the same size (or ROI size)
AddWeighted
Calculated weighted sum of two arrays as following: dst(I)=src1(I)*alpha+src2(I)*beta+gamma All the arrays must have the same type and the same size (or ROI size)
ApplyColorMap(IInputArray, IOutputArray, ColorMapType)
Applies a GNU Octave/MATLAB equivalent colormap on a given image.
ApplyColorMap(IInputArray, IOutputArray, IInputArray)
Applies a user colormap on a given image.
ApproxPolyDP
Approximates a polygonal curve(s) with the specified precision.
ArcLength
Calculates a contour perimeter or a curve length
ArrowedLine
Draws a arrow segment pointing from the first point to the second one.
BilateralFilter
Applies the bilateral filter to an image.
BitwiseAnd
Calculates per-element bit-wise logical conjunction of two arrays: dst(I)=src1(I) & src2(I) if mask(I)!=0 In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size
BitwiseNot
Inverses every bit of every array element:
BitwiseOr
Calculates per-element bit-wise disjunction of two arrays: dst(I)=src1(I)|src2(I) In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size
BitwiseXor
Calculates per-element bit-wise logical conjunction of two arrays: dst(I)=src1(I)^src2(I) if mask(I)!=0 In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size
BlendLinear
Performs linear blending of two images: dst(i, j)=weights1(i, j) x src1(i, j) + weights2(i, j) x src2(i, j)
Blur
Blurs an image using the normalized box filter.
BoundingRectangle
Returns the up-right bounding rectangle for 2d point set
BoxFilter
Blurs an image using the box filter.
BoxPoints(RotatedRect)
Calculates vertices of the input 2d box.
BoxPoints(RotatedRect, IOutputArray)
Calculates vertices of the input 2d box.
BuildOpticalFlowPyramid
Constructs the image pyramid which can be passed to calcOpticalFlowPyrLK.
BuildPyramid
The function constructs a vector of images and builds the Gaussian pyramid by recursively applying pyrDown to the previously built pyramid layers, starting from dst[0]==src.
CalcBackProject
Calculates the back projection of a histogram.
CalcCovarMatrix
Calculates the covariance matrix of a set of vectors.
CalcGlobalOrientation
Calculates the general motion direction in the selected region and returns the angle between 0 and 360. At first the function builds the orientation histogram and finds the basic orientation as a coordinate of the histogram maximum. After that the function calculates the shift relative to the basic orientation as a weighted sum of all orientation vectors: the more recent is the motion, the greater is the weight. The resultant angle is a circular sum of the basic orientation and the shift.
CalcHist
Calculates a histogram of a set of arrays.
CalcMotionGradient
Calculates the derivatives Dx and Dy of mhi and then calculates gradient orientation as: orientation(x,y)=arctan(Dy(x,y)/Dx(x,y)) where both Dx(x,y)' and Dy(x,y)' signs are taken into account (as in cvCartToPolar function). After that mask is filled to indicate where the orientation is valid (see delta1 and delta2 description).
CalcOpticalFlowFarneback(IInputArray, IInputArray, IInputOutputArray, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)
Computes dense optical flow using Gunnar Farneback's algorithm
CalcOpticalFlowFarneback(ImageGray, Byte, ImageGray, Byte, ImageGray, Single, ImageGray, Single, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)
Computes dense optical flow using Gunnar Farneback's algorithm
CalcOpticalFlowPyrLK(IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Size, Int32, MCvTermCriteria, LKFlowFlag, Double)
Implements sparse iterative version of Lucas-Kanade optical flow in pyramids ([Bouguet00]). It calculates coordinates of the feature points on the current video frame given their coordinates on the previous frame. The function finds the coordinates with sub-pixel accuracy.
CalcOpticalFlowPyrLK(IInputArray, IInputArray, PointF, Size, Int32, MCvTermCriteria, PointF, Byte, Single, LKFlowFlag, Double)
Calculates optical flow for a sparse feature set using iterative Lucas-Kanade method in pyramids
CalibrateCamera(IInputArray, IInputArray, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)
Estimates intrinsic camera parameters and extrinsic parameters for each of the views
CalibrateCamera(MCvPoint3D32f, PointF, Size, IInputOutputArray, IInputOutputArray, CalibType, MCvTermCriteria, Mat, Mat)
Estimates intrinsic camera parameters and extrinsic parameters for each of the views
CalibrateHandEye
Computes Hand-Eye calibration
CalibrationMatrixValues
Computes various useful camera (sensor/lens) characteristics using the computed camera calibration matrix, image frame resolution in pixels and the physical aperture size
CamShift
Implements CAMSHIFT object tracking algorithm ([Bradski98]). First, it finds an object center using cvMeanShift and, after that, calculates the object size and orientation.
Canny(IInputArray, IInputArray, IOutputArray, Double, Double, Boolean)
Finds the edges on the input dx, dy and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.
Canny(IInputArray, IOutputArray, Double, Double, Int32, Boolean)
Finds the edges on the input image and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.
CartToPolar
Calculates the magnitude and angle of 2D vectors. magnitude(I)=sqrt( x(I)^2+y(I)^2 ), angle(I)=atan2( y(I)/x(I) ) The angles are calculated with accuracy about 0.3 degrees. For the point (0,0), the angle is set to 0.
CheckLibraryLoaded
Check to make sure all the unmanaged libraries are loaded
CheckRange
Check that every array element is neither NaN nor +- inf. The functions also check that each value is between minVal and maxVal. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions either return false (when quiet=true) or throw an exception.
Circle
Draws a simple or filled circle with given center and radius. The circle is clipped by ROI rectangle.
CLAHE
Contrast Limited Adaptive Histogram Equalization (CLAHE)
ClipLine
Calculates a part of the line segment which is entirely in the rectangle.
ColorChange
Given an original color image, two differently colored versions of this image can be mixed seamlessly.
Compare
Compares the corresponding elements of two arrays and fills the destination mask array: dst(I)=src1(I) op src2(I), dst(I) is set to 0xff (all '1'-bits) if the particular relation between the elements is true and 0 otherwise. All the arrays must have the same type, except the destination, and the same size (or ROI size)
CompareHist
Compares two histograms.
Compute
Computes disparity map for the specified stereo pair
ComputeCorrespondEpilines
For every point in one of the two images of stereo-pair the function cvComputeCorrespondEpilines finds equation of a line that contains the corresponding point (i.e. projection of the same 3D point) in the other image. Each line is encoded by a vector of 3 elements l=[a,b,c]^T, so that: l^T*[x, y, 1]^T=0, or a*x + b*y + c = 0 From the fundamental matrix definition (see cvFindFundamentalMatrix discussion), line l2 for a point p1 in the first image (which_image=1) can be computed as: l2=F*p1 and the line l1 for a point p2 in the second image (which_image=1) can be computed as: l1=F^T*p2Line coefficients are defined up to a scale. They are normalized (a2+b2=1) are stored into correspondent_lines
ConnectedComponents
Computes the connected components labeled image of boolean image
ConnectedComponentsWithStats
Computes the connected components labeled image of boolean image
ContourArea
Calculates area of the whole contour or contour section.
ConvertMaps
Converts image transformation maps from one representation to another.
ConvertPointsFromHomogeneous
Converts points from homogeneous to Euclidean space.
ConvertPointsToHomogeneous
Converts points from Euclidean to homogeneous space.
ConvertScaleAbs
Similar to cvCvtScale but it stores absolute values of the conversion results: dst(I)=abs(src(I)*scale + (shift,shift,...)) The function supports only destination arrays of 8u (8-bit unsigned integers) type, for other types the function can be emulated by combination of cvConvertScale and cvAbs functions.
ConvexHull(PointF, Boolean)
Finds convex hull of 2D point set using Sklansky's algorithm
ConvexHull(IInputArray, IOutputArray, Boolean, Boolean)
The function cvConvexHull2 finds convex hull of 2D point set using Sklansky's algorithm.
ConvexityDefects
Finds the convexity defects of a contour.
CopyMakeBorder
Copies the source 2D array into interior of destination array and makes a border of the specified type around the copied area. The function is useful when one needs to emulate border type that is different from the one embedded into a specific algorithm implementation. For example, morphological functions, as well as most of other filtering functions in OpenCV, internally use replication border type, while the user may need zero border or a border, filled with 1's or 255's
CornerHarris
Runs the Harris edge detector on image. Similarly to cvCornerMinEigenVal and cvCornerEigenValsAndVecs, for each pixel it calculates 2x2 gradient covariation matrix M over block_size x block_size neighborhood. Then, it stores det(M) - k*trace(M)^2 to the destination image. Corners in the image can be found as local maxima of the destination image.
CornerSubPix
Iterates to find the sub-pixel accurate location of corners, or radial saddle points
CorrectMatches
Refines coordinates of corresponding points.
CountNonZero
Returns the number of non-zero elements in arr: result = sumI arr(I)!=0 In case of IplImage both ROI and COI are supported.
CreateHanningWindow
This function computes a Hanning window coefficients in two dimensions.
CvArrToMat
Converts CvMat, IplImage , or CvMatND to Mat.
cvCheckArr
Checks that every array element is neither NaN nor Infinity. If CV_CHECK_RANGE is set, it also checks that every element is greater than or equal to minVal and less than maxVal.
cvClearND
Clears (sets to zero) the particular element of dense array or deletes the element of sparse array. If the element does not exists, the function does nothing
cvConvertScale
This function has several different purposes and thus has several synonyms. It copies one array to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel arrays are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination array element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate cvConvert synonym. If source and destination array types have equal types, this is also a special case that can be used to scale and shift a matrix or an image and that fits to cvScale synonym.
cvCopy
Copies selected elements from input array to output array: dst(I)=src(I) if mask(I)!=0. If any of the passed arrays is of IplImage type, then its ROI and COI fields are used. Both arrays must have the same type, the same number of dimensions and the same size. The function can also copy sparse arrays (mask is not supported in this case).
cvCreateImage
Creates the header and allocates data.
cvCreateImageHeader
Allocates, initializes, and returns the structure IplImage.
cvCreateMat
Allocates header for the new matrix and underlying data, and returns a pointer to the created matrix. Matrices are stored row by row. All the rows are aligned by 4 bytes.
cvCreateSparseMat
The function allocates a multi-dimensional sparse array. Initially the array contain no elements, that is Get or GetReal returns zero for every index
cvGet1D
Return the particular array element
cvGet2D
Return the particular array element
cvGet3D
Return the particular array element
cvGetCol
Return the header, corresponding to a specified column of the input array
cvGetCols
Return the header, corresponding to a specified col span of the input array
cvGetDiag
returns the header, corresponding to a specified diagonal of the input array
cvGetImage
Returns image header for the input array that can be matrix - CvMat*, or image - IplImage*.
cvGetImageCOI
Returns channel of interest of the image (it returns 0 if all the channels are selected).
cvGetImageROI
Returns channel of interest of the image (it returns 0 if all the channels are selected).
cvGetMat
Returns matrix header for the input array that can be matrix - CvMat, image - IplImage or multi-dimensional dense array - CvMatND* (latter case is allowed only if allowND != 0) . In the case of matrix the function simply returns the input pointer. In the case of IplImage* or CvMatND* it initializes header structure with parameters of the current image ROI and returns pointer to this temporary structure. Because COI is not supported by CvMat, it is returned separately.
cvGetRawData
Fills output variables with low-level information about the array data. All output parameters are optional, so some of the pointers may be set to NULL. If the array is IplImage with ROI set, parameters of ROI are returned.
cvGetReal1D
Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.
cvGetReal2D
Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.
cvGetReal3D
Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.
cvGetRow
Return the header, corresponding to a specified row of the input array
cvGetRows
Return the header, corresponding to a specified row span of the input array
cvGetSize
Returns number of rows (CvSize::height) and number of columns (CvSize::width) of the input matrix or image. In case of image the size of ROI is returned.
cvGetSubRect
Returns header, corresponding to a specified rectangle of the input array. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array. ROI is taken into account by the function so the sub-array of ROI is actually extracted.
cvInitImageHeader
Initializes the image header structure, pointer to which is passed by the user, and returns the pointer.
cvInitMatHeader
Initializes already allocated CvMat structure. It can be used to process raw data with OpenCV matrix functions.
cvInitMatNDHeader
Initializes CvMatND structure allocated by the user
cvMaxRect
Finds minimum area rectangle that contains both input rectangles inside
cvRange
Initializes the matrix as following: arr(i,j)=(end-start)*(i*cols(arr)+j)/(cols(arr)*rows(arr))
cvReleaseImage
Releases the header and the image data.
cvReleaseImageHeader
Releases the header.
cvReleaseMat
Decrements the matrix data reference counter and releases matrix header
cvReleaseSparseMat
The function releases the sparse array and clears the array pointer upon exit.
cvResetImageROI
Releases image ROI. After that the whole image is considered selected.
cvReshape
initializes CvMat header so that it points to the same data as the original array but has different shape - different number of channels, different number of rows or both
cvSet2D
Assign the new value to the particular element of array
cvSetData
Assigns user data to the array header.
cvSetImageCOI
Sets the channel of interest to a given value. Value 0 means that all channels are selected, 1 means that the first channel is selected etc. If ROI is NULL and coi != 0, ROI is allocated.
cvSetImageROI
Sets the image ROI to a given rectangle. If ROI is NULL and the value of the parameter rect is not equal to the whole image, ROI is allocated.
cvSetReal1D
Assign the new value to the particular element of single-channel array
cvSetReal2D
Assign the new value to the particular element of single-channel array
cvSetReal3D
Assign the new value to the particular element of single-channel array
cvSetRealND
Assign the new value to the particular element of single-channel array
CvtColor(IInputArray, IOutputArray, ColorConversion, Int32)
Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).
CvtColor(IInputArray, IOutputArray, Type, Type)
Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).
Dct
Performs forward or inverse transform of 1D or 2D floating-point array
Decolor
Transforms a color image to a grayscale image. It is a basic tool in digital printing, stylized black-and-white photograph rendering, and in many single channel image processing applications
DefaultLoadUnmanagedModules
Attempts to load opencv modules from the specific location
DenoiseTVL1
Primal-dual algorithm is an algorithm for solving special types of variational problems (that is, finding a function to minimize some functional). As the image denoising, in particular, may be seen as the variational problem, primal-dual algorithm then can be used to perform denoising and this is exactly what is implemented.
DestroyAllWindows
Destroys all of the HighGUI windows.
DestroyWindow
Destroys the window with a given name
DetailEnhance
This filter enhances the details of a particular image.
Determinant
Returns determinant of the square matrix mat. The direct method is used for small matrices and Gaussian elimination is used for larger matrices. For symmetric positive-determined matrices it is also possible to run SVD with U=V=NULL and then calculate determinant as a product of the diagonal elements of W
Dft
Performs forward or inverse transform of 1D or 2D floating-point array In case of real (single-channel) data, the packed format, borrowed from IPL, is used to to represent a result of forward Fourier transform or input for inverse Fourier transform
Dilate
Dilates the source image using the specified structuring element that determines the shape of a pixel neighborhood over which the maximum is taken The function supports the in-place mode. Dilation can be applied several (iterations) times. In case of color image each channel is processed independently
DistanceTransform
Calculates distance to closest zero pixel for all non-zero pixels of source image
Divide
Divides one array by another: dst(I)=scale * src1(I)/src2(I), if src1!=IntPtr.Zero; dst(I)=scale/src2(I), if src1==IntPtr.Zero; All the arrays must have the same type, and the same size (or ROI size)
DrawChessboardCorners
Draws the individual chessboard corners detected (as red circles) in case if the board was not found (pattern_was_found=0) or the colored corners connected with lines when the board was found (pattern_was_found != 0).
DrawContours
Draws contours outlines or filled contours.
DrawMarker
EdgePreservingFilter
Filtering is the fundamental operation in image and video processing. Edge-preserving smoothing filters are used in many different applications.
Eigen
Computes eigenvalues and eigenvectors of a symmetric matrix
Ellipse(IInputOutputArray, RotatedRect, MCvScalar, Int32, LineType, Int32)
Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.
Ellipse(IInputOutputArray, Point, Size, Double, Double, Double, MCvScalar, Int32, LineType, Int32)
Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.
EMD
Computes the 'minimal work' distance between two weighted point configurations.
EqualizeHist
The algorithm normalizes brightness and increases contrast of the image
Erode
Erodes the source image using the specified structuring element that determines the shape of a pixel neighborhood over which the minimum is taken: dst=erode(src,element): dst(x,y)=min((x',y') in element)) src(x+x',y+y') The function supports the in-place mode. Erosion can be applied several (iterations) times. In case of color image each channel is processed independently.
ErrorStr
Returns the textual description for the specified error status code. In case of unknown status the function returns NULL pointer.
EstimateAffine2D(PointF, PointF, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)
Computes an optimal affine transformation between two 2D point sets.
EstimateAffine2D(IInputArray, IInputArray, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)
Computes an optimal affine transformation between two 2D point sets.
EstimateAffine3D(IInputArray, IInputArray, IOutputArray, IOutputArray, Double, Double)
Computes an optimal affine transformation between two 3D point sets.
EstimateAffine3D(MCvPoint3D32f, MCvPoint3D32f, MatrixDouble, Byte, Double, Double)
Computes an optimal affine transformation between two 3D point sets.
EstimateAffinePartial2D
Computes an optimal limited affine transformation with 4 degrees of freedom between two 2D point sets.
Exp
Calculates exponent of every element of input array: dst(I)=exp(src(I)) Maximum relative error is 7e-6. Currently, the function converts denormalized values to zeros on output
ExtractChannel
Extract the specific channel from the image
FastNlMeansDenoising
Perform image denoising using Non-local Means Denoising algorithm: http://www.ipol.im/pub/algo/bcm_non_local_means_denoising/ with several computational optimizations. Noise expected to be a Gaussian white noise.
FastNlMeansDenoisingColored
Perform image denoising using Non-local Means Denoising algorithm (modified for color image): http://www.ipol.im/pub/algo/bcm_non_local_means_denoising/ with several computational optimizations. Noise expected to be a Gaussian white noise. The function converts image to CIELAB colorspace and then separately denoise L and AB components with given h parameters using fastNlMeansDenoising function.
FillConvexPoly
Fills convex polygon interior. This function is much faster than The function cvFillPoly and can fill not only the convex polygons but any monotonic polygon, i.e. a polygon whose contour intersects every horizontal line (scan line) twice at the most
FillPoly
Fills the area bounded by one or more polygons.
Filter2D
Applies arbitrary linear filter to the image. In-place operation is supported. When the aperture is partially outside the image, the function interpolates outlier pixel values from the nearest pixels that is inside the image
FilterSpeckles
Filters off small noise blobs (speckles) in the disparity map.
Find4QuadCornerSubpix
Finds subpixel-accurate positions of the chessboard corners
FindChessboardCorners
Attempts to determine whether the input image is a view of the chessboard pattern and locate internal chessboard corners
FindChessboardCornersSB
Finds the positions of internal corners of the chessboard using a sector based approach.
FindCirclesGrid(ImageGray, Byte, Size, CalibCgType, Feature2D)
Finds centers in the grid of circles
FindCirclesGrid(IInputArray, Size, IOutputArray, CalibCgType, Feature2D)
Finds centers in the grid of circles
FindContours
Retrieves contours from the binary image and returns the number of retrieved contours. The pointer firstContour is filled by the function. It will contain pointer to the first most outer contour or IntPtr.Zero if no contours is detected (if the image is completely black). Other contours may be reached from firstContour using h_next and v_next links. The sample in cvDrawContours discussion shows how to use contours for connected component detection. Contours can be also used for shape analysis and object recognition - see squares.c in OpenCV sample directory The function modifies the source image content
FindContourTree
Retrieves contours from the binary image as a contour tree. The pointer firstContour is filled by the function. It is provided as a convenient way to obtain the hierarchy value as int[,]. The function modifies the source image content
FindEssentialMat
Calculates an essential matrix from the corresponding points in two images.
FindFundamentalMat
Calculates fundamental matrix using one of four methods listed above and returns the number of fundamental matrices found (1 or 3) and 0, if no matrix is found.
FindHomography(PointF, PointF, RobustEstimationAlgorithm, Double, IOutputArray)
Finds perspective transformation H=||h_ij|| between the source and the destination planes
FindHomography(IInputArray, IInputArray, RobustEstimationAlgorithm, Double, IOutputArray)
Finds perspective transformation H=||hij|| between the source and the destination planes
FindNonZero
Find the location of the non-zero pixel
FindTransformECC
Finds the geometric transform (warp) between two images in terms of the ECC criterion
FitEllipse
Fits an ellipse around a set of 2D points.
FitEllipseAMS
The function calculates the ellipse that fits a set of 2D points. The Approximate Mean Square (AMS) is used.
FitEllipseDirect
The function calculates the ellipse that fits a set of 2D points. The Direct least square (Direct) method by [58] is used.
FitLine(IInputArray, IOutputArray, DistType, Double, Double, Double)
Fits line to 2D or 3D point set
FitLine(PointF, PointF, PointF, DistType, Double, Double, Double)
Fits line to 2D or 3D point set
Flip
Flips the array in one of different 3 ways (row and column indices are 0-based)
FloodFill
Fills a connected component with given color.
GaussianBlur
Blurs an image using a Gaussian filter.
Gemm
Performs generalized matrix multiplication: dst = alpha*op(src1)*op(src2) + beta*op(src3), where op(X) is X or XT
GetAffineTransform(PointF, PointF)
Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.
GetAffineTransform(IInputArray, IOutputArray)
Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.
GetCvStructSizes
This function retrieve the Open CV structure sizes in unmanaged code
GetDefaultNewCameraMatrix
Returns the default new camera matrix.
GetDepthType(Type)
Get the corresponding opencv depth type
GetDepthType(DepthType)
Get the corresponding depth type
GetErrMode
Returns the current error mode
GetErrStatus
Returns the current error status - the value set with the last cvSetErrStatus call. Note, that in Leaf mode the program terminates immediately after error occurred, so to always get control after the function call, one should call cvSetErrMode and set Parent or Silent error mode.
GetModuleFormatString
Get the module format string.
GetOptimalDFTSize
Returns the minimum number N that is greater to equal to size0, such that DFT of a vector of size N can be computed fast. In the current implementation N=2^p x 3^q x 5^r for some p, q, r.
GetOptimalNewCameraMatrix
Returns the new camera matrix based on the free scaling parameter.
GetPerspectiveTransform(PointF, PointF)
calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.
GetPerspectiveTransform(IInputArray, IInputArray)
calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.
GetRectSubPix
Extracts pixels from src: dst(x, y) = src(x + center.x - (width(dst)-1)*0.5, y + center.y - (height(dst)-1)*0.5) where the values of pixels at non-integer coordinates are retrieved using bilinear interpolation. Every channel of multiple-channel images is processed independently. Whereas the rectangle center must be inside the image, the whole rectangle may be partially occluded. In this case, the replication border mode is used to get pixel values beyond the image boundaries.
GetRotationMatrix2D
Calculates rotation matrix
GetStructuringElement
Returns a structuring element of the specified size and shape for morphological operations.
GetTextSize
Calculates the width and height of a text string.
GrabCut
The grab cut algorithm for segmentation
GroupRectangles(VectorOfRect, Int32, Double)
Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, VectorOfInt, Int32, Double)
Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, VectorOfInt, VectorOfDouble, Int32, Double)
Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, Int32, Double, VectorOfInt, VectorOfDouble)
Groups the object candidate rectangles.
GroupRectanglesMeanshift
Groups the object candidate rectangles.
HConcat
Horizontally concatenate two images
HoughCircles(IInputArray, HoughType, Double, Double, Double, Double, Int32, Int32)
Finds circles in a grayscale image using the Hough transform
HoughCircles(IInputArray, IOutputArray, HoughType, Double, Double, Double, Double, Int32, Int32)
Finds circles in grayscale image using some modification of Hough transform
HoughLines
Finds lines in a binary image using the standard Hough transform.
HoughLinesP(IInputArray, Double, Double, Int32, Double, Double)
Finds line segments in a binary image using the probabilistic Hough transform.
HoughLinesP(IInputArray, IOutputArray, Double, Double, Int32, Double, Double)
Finds line segments in a binary image using the probabilistic Hough transform.
HuMoments(Moments)
Calculates seven Hu invariants
HuMoments(Moments, IOutputArray)
Calculates seven Hu invariants
IlluminationChange
Applying an appropriate non-linear transformation to the gradient field inside the selection and then integrating back with a Poisson solver, modifies locally the apparent illumination of an image.
Imdecode(Byte, ImreadModes, Mat)
Decode image stored in the buffer
Imdecode(IInputArray, ImreadModes, Mat)
Decode image stored in the buffer
Imencode
encode image and store the result as a byte vector.
Imread
Loads an image from the specified file and returns the pointer to the loaded image. Currently the following file formats are supported:
Windows bitmaps - BMP, DIB;
JPEG files - JPEG, JPG, JPE;
Portable Network Graphics - PNG;
Portable image format - PBM, PGM, PPM;
Sun rasters - SR, RAS;
TIFF files - TIFF, TIF;
OpenEXR HDR images - EXR;
JPEG 2000 images - jp2.
Imreadmulti
The function imreadmulti loads a multi-page image from the specified file into a vector of Mat objects.
Imshow
Shows the image in the specified window
Imwrite
Saves the image to the specified file. The image format is chosen depending on the filename extension, see cvLoadImage. Only 8-bit single-channel or 3-channel (with 'BGR' channel order) images can be saved using this function. If the format, depth or channel order is different, use cvCvtScale and cvCvtColor to convert it before saving, or use universal cvSave to save the image to XML or YAML format
InitCameraMatrix2D
Finds an initial camera matrix from 3D-2D point correspondences.
InitUndistortRectifyMap
This function is an extended version of cvInitUndistortMap. That is, in addition to the correction of lens distortion, the function can also apply arbitrary perspective transformation R and finally it can scale and shift the image according to the new camera matrix
Inpaint
Reconstructs the selected image area from the pixel near the area boundary. The function may be used to remove dust and scratches from a scanned photo, or to remove undesirable objects from still images or video.
InRange
Performs range check for every element of the input array: dst(I)=lower(I)_0 <= src(I)_0 <= upper(I)_0 For single-channel arrays, dst(I)=lower(I)_0 <= src(I)_0 <= upper(I)_0 && lower(I)_1 <= src(I)_1 <= upper(I)_1 For two-channel arrays etc. dst(I) is set to 0xff (all '1'-bits) if src(I) is within the range and 0 otherwise. All the arrays must have the same type, except the destination, and the same size (or ROI size)
InsertChannel
Insert the specific channel to the image
Integral
Calculates one or more integral images for the source image Using these integral images, one may calculate sum, mean, standard deviation over arbitrary up-right or rotated rectangular region of the image in a constant time. It makes possible to do a fast blurring or fast block correlation with variable window size etc. In case of multi-channel images sums for each channel are accumulated independently.
IntersectConvexConvex
finds intersection of two convex polygons
Invert
Finds the inverse or pseudo-inverse of a matrix. This function inverts the matrix src and stores the result in dst . When the matrix src is singular or non-square, the function calculates the pseudo-inverse matrix (the dst matrix) so that norm(src*dst - I) is minimal, where I is an identity matrix.
InvertAffineTransform
Inverts an affine transformation
IsContourConvex
The function tests whether the input contour is convex or not. The contour must be simple, that is, without self-intersections. Otherwise, the function output is undefined.
Kmeans
Implements k-means algorithm that finds centers of cluster_count clusters and groups the input samples around the clusters. On output labels(i) contains a cluster index for sample stored in the i-th row of samples matrix
Laplacian
Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator: dst(x,y) = d2src/dx2 + d2src/dy2 Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0| Similar to cvSobel function, no scaling is done and the same combinations of input and output formats are supported.
Line
Draws the line segment between pt1 and pt2 points in the image. The line is clipped by the image or ROI rectangle. For non-antialiased lines with integer coordinates the 8-connected or 4-connected Bresenham algorithm is used. Thick lines are drawn with rounding endings. Antialiased lines are drawn using Gaussian filtering.
LinearPolar
The function emulates the human "foveal" vision and can be used for fast scale and rotation-invariant template matching, for object tracking etc.
LoadUnmanagedModules
Attempts to load opencv modules from the specific location
Log
Calculates natural logarithm of absolute value of every element of input array: dst(I)=log(abs(src(I))), src(I)!=0 dst(I)=C, src(I)=0 Where C is large negative number (-700 in the current implementation)
LogPolar
The function emulates the human "foveal" vision and can be used for fast scale and rotation-invariant template matching, for object tracking etc.
LUT
Fills the destination array with values from the look-up table. Indices of the entries are taken from the source array. That is, the function processes each element of src as following: dst(I)=lut[src(I)+DELTA] where DELTA=0 if src has depth CV_8U, and DELTA=128 if src has depth CV_8S
Mahalanobis
Calculates the weighted distance between two vectors and returns it
MakeType
This function performs the same as MakeType macro
MatchShapes
Compares two shapes. The 3 implemented methods all use Hu moments
MatchTemplate
This function is similiar to cvCalcBackProjectPatch. It slids through image, compares overlapped patches of size wxh with templ using the specified method and stores the comparison results to result
Max
Calculates per-element maximum of two arrays: dst(I)=max(src1(I), src2(I)) All the arrays must have a single channel, the same data type and the same size (or ROI size).
Mean
Calculates the average value M of array elements, independently for each channel: N = sumI mask(I)!=0 Mc = 1/N * sumI,mask(I)!=0 arr(I)c If the array is IplImage and COI is set, the function processes the selected channel only and stores the average to the first scalar component (S0).
MeanShift
Iterates to find the object center given its back projection and initial position of search window. The iterations are made until the search window center moves by less than the given value and/or until the function has done the maximum number of iterations.
MeanStdDev(IInputArray, IOutputArray, IOutputArray, IInputArray)
Calculates a mean and standard deviation of array elements.
MeanStdDev(IInputArray, MCvScalar, MCvScalar, IInputArray)
The function cvAvgSdv calculates the average value and standard deviation of array elements, independently for each channel
MedianBlur
Blurs an image using the median filter.
Merge
This function is the opposite to cvSplit. If the destination array has N channels then if the first N input channels are not IntPtr.Zero, all they are copied to the destination array, otherwise if only a single source channel of the first N is not IntPtr.Zero, this particular channel is copied into the destination array, otherwise an error is raised. Rest of source channels (beyond the first N) must always be IntPtr.Zero. For IplImage cvCopy with COI set can be also used to insert a single channel into the image.
Min
Calculates per-element minimum of two arrays: dst(I)=min(src1(I),src2(I)) All the arrays must have a single channel, the same data type and the same size (or ROI size).
MinAreaRect(PointF)
Find the bounding rectangle for the specific array of points
MinAreaRect(IInputArray)
Finds a rotated rectangle of the minimum area enclosing the input 2D point set.
MinEnclosingCircle(PointF)
Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)
MinEnclosingCircle(IInputArray)
Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)
MinEnclosingTriangle
Finds a triangle of minimum area enclosing a 2D point set and returns its area.
MinMaxIdx
Finds the global minimum and maximum in an array
MinMaxLoc
Finds minimum and maximum element values and their positions. The extremums are searched over the whole array, selected ROI (in case of IplImage) or, if mask is not IntPtr.Zero, in the specified array region. If the array has more than one channel, it must be IplImage with COI set. In case if multi-dimensional arrays min_loc->x and max_loc->x will contain raw (linear) positions of the extremums
MixChannels
The function cvMixChannels is a generalized form of cvSplit and cvMerge and some forms of cvCvtColor. It can be used to change the order of the planes, add/remove alpha channel, extract or insert a single plane or multiple planes etc.
Moments
Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characeteristics including 7 Hu invariants.
MorphologyEx
Performs advanced morphological transformations.
MulSpectrums
Performs per-element multiplication of the two CCS-packed or complex matrices that are results of real or complex Fourier transform.
Multiply
Calculates per-element product of two arrays: dst(I)=scale*src1(I)*src2(I) All the arrays must have the same type, and the same size (or ROI size)
MulTransposed
Calculates the product of src and its transposition. The function evaluates dst=scale(src-delta)*(src-delta)^T if order=0, and dst=scale(src-delta)^T*(src-delta) otherwise.
NamedWindow
Creates a window which can be used as a placeholder for images and trackbars. Created windows are reffered by their names. If the window with such a name already exists, the function does nothing.
Norm(IInputArray, NormType, IInputArray)
Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.
Norm(IInputArray, IInputOutputArray, NormType, IInputArray)
Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.
Normalize
normalizes the input array so that it's norm or value range takes the certain value(s).
OclFinish
Finishes OpenCL queue.
OclGetPlatformsSummary
Get the OpenCL platform summary as a string
OclSetDefaultDevice
Set the default opencl device
PatchNaNs
Converts NaN's to the given number
PCABackProject
Reconstructs vectors from their PC projections.
PCACompute(IInputArray, IInputOutputArray, IOutputArray, Double)
Performs Principal Component Analysis of the supplied dataset.
PCACompute(IInputArray, IInputOutputArray, IOutputArray, Int32)
Performs Principal Component Analysis of the supplied dataset.
PCAProject
Projects vector(s) to the principal component subspace.
PencilSketch
Pencil-like non-photorealistic line drawing
PerspectiveTransform(PointF, IInputArray)
Transforms every element of src in the following way: (x, y) -> (x'/w, y'/w), where (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise
PerspectiveTransform(IInputArray, IOutputArray, IInputArray)
Transforms every element of src (by treating it as 2D or 3D vector) in the following way: (x, y, z) -> (x'/w, y'/w, z'/w) or (x, y) -> (x'/w, y'/w), where (x', y', z', w') = mat4x4 * (x, y, z, 1) or (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise
PhaseCorrelate
The function is used to detect translational shifts that occur between two images. The operation takes advantage of the Fourier shift theorem for detecting the translational shift in the frequency domain. It can be used for fast image registration as well as motion estimation.
PointPolygonTest
Determines whether the point is inside contour, outside, or lies on an edge (or coinsides with a vertex). It returns positive, negative or zero value, correspondingly
PolarToCart
Calculates either x-coordinate, y-coordinate or both of every vector magnitude(I)* exp(angle(I)*j), j=sqrt(-1): x(I)=magnitude(I)*cos(angle(I)), y(I)=magnitude(I)*sin(angle(I))
Polylines(IInputOutputArray, IInputArray, Boolean, MCvScalar, Int32, LineType, Int32)
Draws a single or multiple polygonal curves
Polylines(IInputOutputArray, Point, Boolean, MCvScalar, Int32, LineType, Int32)
Draws a single or multiple polygonal curves
Pow
Raises every element of input array to p: dst(I)=src(I)p, if p is integer dst(I)=abs(src(I))p, otherwise That is, for non-integer power exponent the absolute values of input array elements are used. However, it is possible to get true values for negative values using some extra operations, as the following sample, computing cube root of array elements, shows: CvSize size = cvGetSize(src); CvMat* mask = cvCreateMat( size.height, size.width, CV_8UC1 ); cvCmpS( src, 0, mask, CV_CMP_LT ); /* find negative elements */ cvPow( src, dst, 1./3 ); cvSubRS( dst, cvScalarAll(0), dst, mask ); /* negate the results of negative inputs */ cvReleaseMat( &mask ); For some values of power, such as integer values, 0.5 and -0.5, specialized faster algorithms are used.
ProjectPoints(MCvPoint3D32f, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, Double)
Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters.
ProjectPoints(IInputArray, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Double)
Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters. Note, that with intrinsic and/or extrinsic parameters set to special values, the function can be used to compute just extrinsic transformation or just intrinsic transformation (i.e. distortion of a sparse set of points).
PSNR
Computes PSNR image/video quality metric
PutText
Renders the text in the image with the specified font and color. The printed text is clipped by ROI rectangle. Symbols that do not belong to the specified font are replaced with the rectangle symbol.
PyrDown
Performs downsampling step of Gaussian pyramid decomposition. First it convolves source image with the specified filter and then downsamples the image by rejecting even rows and columns.
PyrMeanShiftFiltering
Filters image using meanshift algorithm
PyrUp
Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples the source image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the destination image is four times larger than the source image.
Randn(IInputOutputArray, IInputArray, IInputArray)
Fills the array with normally distributed random numbers.
Randn(IInputOutputArray, MCvScalar, MCvScalar)
Fills the array with normally distributed random numbers.
RandShuffle
Shuffles the matrix by swapping randomly chosen pairs of the matrix elements on each iteration (where each element may contain several components in case of multi-channel arrays)
Randu(IInputOutputArray, IInputArray, IInputArray)
Generates a single uniformly-distributed random number or an array of random numbers.
Randu(IInputOutputArray, MCvScalar, MCvScalar)
Generates a single uniformly-distributed random number or an array of random numbers.
ReadCloud
Read point cloud from file
Rectangle
Draws a rectangle specified by a CvRect structure
RedirectError(IntPtr, IntPtr, IntPtr)
Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.
RedirectError(CvInvokeCvErrorCallback, IntPtr, IntPtr)
Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.
Reduce
Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.
Remap
Applies a generic geometrical transformation to an image.
Repeat
Fills the destination array with source array tiled: dst(i,j)=src(i mod rows(src), j mod cols(src))So the destination array may be as larger as well as smaller than the source array
ReprojectImageTo3D
Transforms 1-channel disparity map to 3-channel image, a 3D surface.
Resize
Resizes the image src down to or up to the specified size
ResizeForFrame
Resize an image such that it fits in a given frame
Rodrigues
Converts a rotation vector to rotation matrix or vice versa. Rotation vector is a compact representation of rotation matrix. Direction of the rotation vector is the rotation axis and the length of the vector is the rotation angle around the axis.
Rotate
Rotates a 2D array in multiples of 90 degrees.
RotatedRectangleIntersection
Finds out if there is any intersection between two rotated rectangles.
SanityCheck
Check if the size of the C structures match those of C#
Scharr
Calculates the first x- or y- image derivative using Scharr operator.
SeamlessClone
Image editing tasks concern either global changes (color/intensity corrections, filters, deformations) or local changes concerned to a selection. Here we are interested in achieving local changes, ones that are restricted to a region manually selected (ROI), in a seamless and effortless manner. The extent of the changes ranges from slight distortions to complete replacement by novel content
SegmentMotion
Finds all the motion segments and marks them in segMask with individual values each (1,2,...). It also returns a sequence of CvConnectedComp structures, one per each motion components. After than the motion direction for every component can be calculated with cvCalcGlobalOrientation using extracted mask of the particular component (using cvCmp)
SelectROI
Selects ROI on the given image. Function creates a window and allows user to select a ROI using mouse. Controls: use space or enter to finish selection, use key c to cancel selection (function will return the zero cv::Rect).
SelectROIs
Selects ROIs on the given image. Function creates a window and allows user to select a ROIs using mouse. Controls: use space or enter to finish current selection and start a new one, use esc to terminate multiple ROI selection process.
SepFilter2D
The function applies a separable linear filter to the image. That is, first, every row of src is filtered with the 1D kernel kernelX. Then, every column of the result is filtered with the 1D kernel kernelY. The final result shifted by delta is stored in dst .
SetErrMode
Sets the specified error mode.
SetErrStatus
Sets the error status to the specified value. Mostly, the function is used to reset the error status (set to it CV_StsOk) to recover after error. In other cases it is more natural to call cvError or CV_ERROR.
SetIdentity
Initializes scaled identity matrix: arr(i,j)=value if i=j, 0 otherwise
Sobel
The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative. The first case corresponds to

              |-1  0  1|
              |-2  0  2|
              |-1  0  1|
kernel and the second one corresponds to
              |-1 -2 -1|
              | 0  0  0|
              | 1  2  1|
or
              | 1  2  1|
              | 0  0  0|
              |-1 -2 -1|
kernel, depending on the image origin (origin field of IplImage structure). No scaling is done, so the destination image usually has larger by absolute value numbers than the source image. To avoid overflow, the function requires 16-bit destination image if the source image is 8-bit. The result can be converted back to 8-bit using cvConvertScale or cvConvertScaleAbs functions. Besides 8-bit images the function can process 32-bit floating-point images. Both source and destination must be single-channel images of equal size or ROI size
Solve
Solves linear system (src1)*(dst) = (src2)
SolveCubic
finds real roots of a cubic equation: coeffs[0]*x^3 + coeffs[1]*x^2 + coeffs[2]*x + coeffs[3] = 0 (if coeffs is 4-element vector) or x^3 + coeffs[0]*x^2 + coeffs[1]*x + coeffs[2] = 0 (if coeffs is 3-element vector)
SolveLP
Solve given (non-integer) linear programming problem using the Simplex Algorithm (Simplex Method). What we mean here by “linear programming problem” (or LP problem, for short) can be formulated as: Maximize c x subject to: Ax <= b and x >= 0
SolveP3P
Finds an object pose from 3 3D-2D point correspondences.
SolvePnP(IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)
Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error
SolvePnP(MCvPoint3D32f, PointF, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)
Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error.
SolvePnPGeneric
Finds an object pose from 3D-2D point correspondences.
SolvePnPRansac
Finds an object pose from 3D-2D point correspondences using the RANSAC scheme.
SolvePnPRefineLM
Refine a pose (the translation and the rotation that transform a 3D point expressed in the object coordinate frame to the camera coordinate frame) from a 3D-2D point correspondences and starting from an initial solution
SolvePnPRefineVVS
Refine a pose (the translation and the rotation that transform a 3D point expressed in the object coordinate frame to the camera coordinate frame) from a 3D-2D point correspondences and starting from an initial solution.
SolvePoly
Finds all real and complex roots of any degree polynomial with real coefficients
Sort
Sorts each matrix row or each matrix column in ascending or descending order.So you should pass two operation flags to get desired behaviour.
SortIdx
Sorts each matrix row or each matrix column in the ascending or descending order.So you should pass two operation flags to get desired behaviour. Instead of reordering the elements themselves, it stores the indices of sorted elements in the output array.
SpatialGradient
Calculates the first order image derivative in both x and y using a Sobel operator. Equivalent to calling: Sobel(src, dx, CV_16SC1, 1, 0, 3 ); Sobel(src, dy, CV_16SC1, 0, 1, 3 );
Split
Divides a multi-channel array into separate single-channel arrays. Two modes are available for the operation. If the source array has N channels then if the first N destination channels are not IntPtr.Zero, all they are extracted from the source array, otherwise if only a single destination channel of the first N is not IntPtr.Zero, this particular channel is extracted, otherwise an error is raised. Rest of destination channels (beyond the first N) must always be IntPtr.Zero. For IplImage cvCopy with COI set can be also used to extract a single channel from the image
SqrBoxFilter
Calculates the normalized sum of squares of the pixel values overlapping the filter. For every pixel(x, y) in the source image, the function calculates the sum of squares of those neighboring pixel values which overlap the filter placed over the pixel(x, y). The unnormalized square box filter can be useful in computing local image statistics such as the the local variance and standard deviation around the neighborhood of a pixel.
Sqrt
Calculate square root of each source array element. in the case of multichannel arrays each channel is processed independently. The function accuracy is approximately the same as of the built-in std::sqrt.
StereoCalibrate(IInputArray, IInputArray, IInputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)
Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the fist camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T
StereoCalibrate(MCvPoint3D32f, PointF, PointF, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)
Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the first camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T
StereoRectify
computes the rotation matrices for each camera that (virtually) make both camera image planes the same plane. Consequently, that makes all the epipolar lines parallel and thus simplifies the dense stereo correspondence problem. On input the function takes the matrices computed by cvStereoCalibrate and on output it gives 2 rotation matrices and also 2 projection matrices in the new coordinates. The function is normally called after cvStereoCalibrate that computes both camera matrices, the distortion coefficients, R and T
StereoRectifyUncalibrated
Computes the rectification transformations without knowing intrinsic parameters of the cameras and their relative position in space, hence the suffix "Uncalibrated". Another related difference from cvStereoRectify is that the function outputs not the rectification transformations in the object (3D) space, but the planar perspective transformations, encoded by the homography matrices H1 and H2. The function implements the following algorithm [Hartley99].
Stylization
Stylization aims to produce digital imagery with a wide variety of effects not focused on photorealism. Edge-aware filters are ideal for stylization, as they can abstract regions of low contrast while preserving, or enhancing, high-contrast features.
Subtract
Subtracts one array from another one: dst(I)=src1(I)-src2(I) if mask(I)!=0 All the arrays must have the same type, except the mask, and the same size (or ROI size)
Sum
Calculates sum S of array elements, independently for each channel Sc = sumI arr(I)c If the array is IplImage and COI is set, the function processes the selected channel only and stores the sum to the first scalar component (S0).
SVBackSubst
Performs a singular value back substitution.
SVDecomp
Decomposes matrix A into a product of a diagonal matrix and two orthogonal matrices: A=U*W*VT Where W is diagonal matrix of singular values that can be coded as a 1D vector of singular values and U and V. All the singular values are non-negative and sorted (together with U and V columns) in descenting order.
Swap(Mat, Mat)
Swaps two matrices
Swap(UMat, UMat)
Swaps two matrices
TextureFlattening
By retaining only the gradients at edge locations, before integrating with the Poisson solver, one washes out the texture of the selected region, giving its contents a flat aspect. Here Canny Edge Detector is used.
Threshold
Applies a fixed-level threshold to each array element. The function applies fixed-level thresholding to a multiple-channel array. The function is typically used to get a bi-level (binary) image out of a grayscale image ( compare could be also used for this purpose) or for removing a noise, that is, filtering out pixels with too small or too large values. There are several types of thresholding supported by the function. They are determined by type parameter.
Trace
Returns sum of diagonal elements of the matrix mat.
Transform
Performs matrix transformation of every element of array src and stores the results in dst Both source and destination arrays should have the same depth and the same size or selected ROI size. transmat and shiftvec should be real floating-point matrices.
Transpose
Transposes matrix src1: dst(i,j)=src(j,i) Note that no complex conjugation is done in case of complex matrix. Conjugation should be done separately: look at the sample code in cvXorS for example
TriangulatePoints
Reconstructs points by triangulation.
Undistort
Transforms the image to compensate radial and tangential lens distortion.
UndistortPoints
Similar to cvInitUndistortRectifyMap and is opposite to it at the same time. The functions are similar in that they both are used to correct lens distortion and to perform the optional perspective (rectification) transformation. They are opposite because the function cvInitUndistortRectifyMap does actually perform the reverse transformation in order to initialize the maps properly, while this function does the forward transformation.
UpdateMotionHistory
Updates the motion history image as following:
mhi(x,y)=timestamp  if silhouette(x,y)!=0
        0          if silhouette(x,y)=0 and mhi(x,y)<timestamp-duration
        mhi(x,y)   otherwise
That is, MHI pixels where motion occurs are set to the current timestamp, while the pixels where motion happened far ago are cleared.
VConcat
Vertically concatenate two images
WaitKey
Waits for key event infinitely (delay <= 0) or for "delay" milliseconds.
WarpAffine
Applies an affine transformation to an image.
WarpPerspective
Applies a perspective transformation to an image
Watershed
Implements one of the variants of watershed, non-parametric marker-based segmentation algorithm, described in [Meyer92] Before passing the image to the function, user has to outline roughly the desired regions in the image markers with positive (>0) indices, i.e. every region is represented as one or more connected components with the pixel values 1, 2, 3 etc. Those components will be "seeds" of the future image regions. All the other pixels in markers, which relation to the outlined regions is not known and should be defined by the algorithm, should be set to 0's. On the output of the function, each pixel in markers is set to one of values of the "seed" components, or to -1 at boundaries between the regions.
WriteCloud
Write point cloud to file
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.AbsDiff Method

CvInvokeAbsDiff Method

Calculates absolute difference between two arrays. dst(I)c = abs(src1(I)c - src2(I)c). All the arrays must have the same data type and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AbsDiff(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst
)
Public Shared Sub AbsDiff (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray
)
public:
static void AbsDiff(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst
)
static member AbsDiff :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray -> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Accumulate Method

CvInvokeAccumulate Method

Adds the whole image or its selected region to accumulator sum

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Accumulate(
    IInputArray src,
    IInputOutputArray dst,
    IInputArray mask = null
)
Public Shared Sub Accumulate (
    src As IInputArray,
    dst As IInputOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void Accumulate(
    IInputArray^ src,
    IInputOutputArray^ dst,
    IInputArray^ mask = nullptr
)
static member Accumulate :
        src : IInputArray *
        dst : IInputOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input image, 1- or 3-channel, 8-bit or 32-bit floating point. (each channel of multi-channel image is processed independently).
dst
Type: Emgu.CVIInputOutputArray
Accumulator of the same number of channels as input image, 32-bit or 64-bit floating-point.
mask (Optional)
Type: Emgu.CVIInputArray
Optional operation mask
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.AccumulateProduct Method

CvInvokeAccumulateProduct Method

Adds product of 2 images or thier selected regions to accumulator acc

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AccumulateProduct(
    IInputArray src1,
    IInputArray src2,
    IInputOutputArray dst,
    IInputArray mask = null
)
Public Shared Sub AccumulateProduct (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IInputOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void AccumulateProduct(
    IInputArray^ src1,
    IInputArray^ src2,
    IInputOutputArray^ dst,
    IInputArray^ mask = nullptr
)
static member AccumulateProduct :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IInputOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
First input image, 1- or 3-channel, 8-bit or 32-bit floating point (each channel of multi-channel image is processed independently)
src2
Type: Emgu.CVIInputArray
Second input image, the same format as the first one
dst
Type: Emgu.CVIInputOutputArray
Accumulator of the same number of channels as input images, 32-bit or 64-bit floating-point
mask (Optional)
Type: Emgu.CVIInputArray
Optional operation mask
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.AccumulateSquare Method

CvInvokeAccumulateSquare Method

Adds the input src or its selected region, raised to power 2, to the accumulator sqsum

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AccumulateSquare(
    IInputArray src,
    IInputOutputArray dst,
    IInputArray mask = null
)
Public Shared Sub AccumulateSquare (
    src As IInputArray,
    dst As IInputOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void AccumulateSquare(
    IInputArray^ src,
    IInputOutputArray^ dst,
    IInputArray^ mask = nullptr
)
static member AccumulateSquare :
        src : IInputArray *
        dst : IInputOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input image, 1- or 3-channel, 8-bit or 32-bit floating point (each channel of multi-channel image is processed independently)
dst
Type: Emgu.CVIInputOutputArray
Accumulator of the same number of channels as input image, 32-bit or 64-bit floating-point
mask (Optional)
Type: Emgu.CVIInputArray
Optional operation mask
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.AccumulateWeighted Method

CvInvokeAccumulateWeighted Method

Calculates weighted sum of input src and the accumulator acc so that acc becomes a running average of frame sequence: acc(x,y)=(1-alpha) * acc(x,y) + alpha * image(x,y) if mask(x,y)!=0 where alpha regulates update speed (how fast accumulator forgets about previous frames).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AccumulateWeighted(
    IInputArray src,
    IInputOutputArray dst,
    double alpha,
    IInputArray mask = null
)
Public Shared Sub AccumulateWeighted (
    src As IInputArray,
    dst As IInputOutputArray,
    alpha As Double,
    Optional mask As IInputArray = Nothing
)
public:
static void AccumulateWeighted(
    IInputArray^ src,
    IInputOutputArray^ dst,
    double alpha,
    IInputArray^ mask = nullptr
)
static member AccumulateWeighted :
        src : IInputArray *
        dst : IInputOutputArray *
        alpha : float *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input image, 1- or 3-channel, 8-bit or 32-bit floating point (each channel of multi-channel image is processed independently).
dst
Type: Emgu.CVIInputOutputArray
Accumulator of the same number of channels as input image, 32-bit or 64-bit floating-point.
alpha
Type: SystemDouble
Weight of input image
mask (Optional)
Type: Emgu.CVIInputArray
Optional operation mask
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.AdaptiveThreshold Method

CvInvokeAdaptiveThreshold Method

Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AdaptiveThreshold(
    IInputArray src,
    IOutputArray dst,
    double maxValue,
    AdaptiveThresholdType adaptiveType,
    ThresholdType thresholdType,
    int blockSize,
    double param1
)
Public Shared Sub AdaptiveThreshold (
    src As IInputArray,
    dst As IOutputArray,
    maxValue As Double,
    adaptiveType As AdaptiveThresholdType,
    thresholdType As ThresholdType,
    blockSize As Integer,
    param1 As Double
)
public:
static void AdaptiveThreshold(
    IInputArray^ src,
    IOutputArray^ dst,
    double maxValue,
    AdaptiveThresholdType^ adaptiveType,
    ThresholdType^ thresholdType,
    int blockSize,
    double param1
)
static member AdaptiveThreshold :
        src : IInputArray *
        dst : IOutputArray *
        maxValue : float *
        adaptiveType : AdaptiveThresholdType *
        thresholdType : ThresholdType *
        blockSize : int *
        param1 : float -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source array (single-channel, 8-bit of 32-bit floating point).
dst
Type: Emgu.CVIOutputArray
Destination array; must be either the same type as src or 8-bit.
maxValue
Type: SystemDouble
Maximum value to use with CV_THRESH_BINARY and CV_THRESH_BINARY_INV thresholding types
adaptiveType
Type: Emgu.CV.CvEnumAdaptiveThresholdType
Adaptive_method
thresholdType
Type: Emgu.CV.CvEnumThresholdType
Thresholding type. must be one of CV_THRESH_BINARY, CV_THRESH_BINARY_INV
blockSize
Type: SystemInt32
The size of a pixel neighborhood that is used to calculate a threshold value for the pixel: 3, 5, 7, ...
param1
Type: SystemDouble
Constant subtracted from mean or weighted mean. It may be negative.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Add Method

CvInvokeAdd Method

Adds one array to another one: dst(I)=src1(I)+src2(I) if mask(I)!=0All the arrays must have the same type, except the mask, and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Add(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null,
    DepthType dtype = -1
)
Public Shared Sub Add (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional dtype As DepthType = -1
)
public:
static void Add(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    DepthType^ dtype = -1
)
static member Add :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?dtype : DepthType
(* Defaults:
        let _mask = defaultArg mask null
        let _dtype = defaultArg dtype -1
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array.
src2
Type: Emgu.CVIInputArray
The second source array.
dst
Type: Emgu.CVIOutputArray
The destination array.
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask, 8-bit single channel array; specifies elements of destination array to be changed.
dtype (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth type of the output array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.AddWeighted Method

CvInvokeAddWeighted Method

Calculated weighted sum of two arrays as following: dst(I)=src1(I)*alpha+src2(I)*beta+gamma All the arrays must have the same type and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AddWeighted(
    IInputArray src1,
    double alpha,
    IInputArray src2,
    double beta,
    double gamma,
    IOutputArray dst,
    DepthType dtype = -1
)
Public Shared Sub AddWeighted (
    src1 As IInputArray,
    alpha As Double,
    src2 As IInputArray,
    beta As Double,
    gamma As Double,
    dst As IOutputArray,
    Optional dtype As DepthType = -1
)
public:
static void AddWeighted(
    IInputArray^ src1,
    double alpha,
    IInputArray^ src2,
    double beta,
    double gamma,
    IOutputArray^ dst,
    DepthType^ dtype = -1
)
static member AddWeighted :
        src1 : IInputArray *
        alpha : float *
        src2 : IInputArray *
        beta : float *
        gamma : float *
        dst : IOutputArray *
        ?dtype : DepthType
(* Defaults:
        let _dtype = defaultArg dtype -1
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array.
alpha
Type: SystemDouble
Weight of the first array elements.
src2
Type: Emgu.CVIInputArray
The second source array.
beta
Type: SystemDouble
Weight of the second array elements.
gamma
Type: SystemDouble
Scalar, added to each sum.
dst
Type: Emgu.CVIOutputArray
The destination array.
dtype (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array; when both input arrays have the same depth
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ApplyColorMap Method

CvInvokeApplyColorMap Method

Overload List
Name | Description
ApplyColorMap(IInputArray, IOutputArray, ColorMapType) | Applies a GNU Octave/MATLAB equivalent colormap on a given image.
ApplyColorMap(IInputArray, IOutputArray, IInputArray) | Applies a user colormap on a given image.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ApplyColorMap Method (IInputArray, IOutputArray, ColorMapType)

CvInvokeApplyColorMap Method (IInputArray, IOutputArray, ColorMapType)

http://www.emgu.com
Applies a GNU Octave/MATLAB equivalent colormap on a given image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ApplyColorMap(
    IInputArray src,
    IOutputArray dst,
    ColorMapType colorMapType
)
Public Shared Sub ApplyColorMap (
    src As IInputArray,
    dst As IOutputArray,
    colorMapType As ColorMapType
)
public:
static void ApplyColorMap(
    IInputArray^ src,
    IOutputArray^ dst,
    ColorMapType^ colorMapType
)
static member ApplyColorMap :
        src : IInputArray *
        dst : IOutputArray *
        colorMapType : ColorMapType -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image, grayscale or colored of type CV_8UC1 or CV_8UC3
dst
Type: Emgu.CVIOutputArray
The result is the colormapped source image
colorMapType
Type: Emgu.CV.CvEnumColorMapType
The type of color map
See Also

Reference

CvInvoke Class
ApplyColorMap Overload
Emgu.CV Namespace


CvInvoke.ApplyColorMap Method (IInputArray, IOutputArray, IInputArray)

CvInvokeApplyColorMap Method (IInputArray, IOutputArray, IInputArray)

http://www.emgu.com
Applies a user colormap on a given image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ApplyColorMap(
    IInputArray src,
    IOutputArray dst,
    IInputArray userColorMap
)
Public Shared Sub ApplyColorMap (
    src As IInputArray,
    dst As IOutputArray,
    userColorMap As IInputArray
)
public:
static void ApplyColorMap(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ userColorMap
)
static member ApplyColorMap :
        src : IInputArray *
        dst : IOutputArray *
        userColorMap : IInputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image, grayscale or colored of type CV_8UC1 or CV_8UC3.
dst
Type: Emgu.CVIOutputArray
The result is the colormapped source image.
userColorMap
Type: Emgu.CVIInputArray
The colormap to apply of type CV_8UC1 or CV_8UC3 and size 256
See Also

Reference

CvInvoke Class
ApplyColorMap Overload
Emgu.CV Namespace


CvInvoke.ApproxPolyDP Method

CvInvokeApproxPolyDP Method

Approximates a polygonal curve(s) with the specified precision.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ApproxPolyDP(
    IInputArray curve,
    IOutputArray approxCurve,
    double epsilon,
    bool closed
)
Public Shared Sub ApproxPolyDP (
    curve As IInputArray,
    approxCurve As IOutputArray,
    epsilon As Double,
    closed As Boolean
)
public:
static void ApproxPolyDP(
    IInputArray^ curve,
    IOutputArray^ approxCurve,
    double epsilon,
    bool closed
)
static member ApproxPolyDP :
        curve : IInputArray *
        approxCurve : IOutputArray *
        epsilon : float *
        closed : bool -> unit

Parameters

curve
Type: Emgu.CVIInputArray
Input vector of a 2D point
approxCurve
Type: Emgu.CVIOutputArray
Result of the approximation. The type should match the type of the input curve.
epsilon
Type: SystemDouble
Parameter specifying the approximation accuracy. This is the maximum distance between the original curve and its approximation.
closed
Type: SystemBoolean
If true, the approximated curve is closed (its first and last vertices are connected). Otherwise, it is not closed.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ArcLength Method

CvInvokeArcLength Method

Calculates a contour perimeter or a curve length

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double ArcLength(
    IInputArray curve,
    bool isClosed
)
Public Shared Function ArcLength (
    curve As IInputArray,
    isClosed As Boolean
) As Double
public:
static double ArcLength(
    IInputArray^ curve,
    bool isClosed
)
static member ArcLength :
        curve : IInputArray *
        isClosed : bool -> float

Parameters

curve
Type: Emgu.CVIInputArray
Sequence or array of the curve points
isClosed
Type: SystemBoolean
Indicates whether the curve is closed or not.

Return Value

Type: Double
Contour perimeter or a curve length
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ArrowedLine Method

CvInvokeArrowedLine Method

Draws a arrow segment pointing from the first point to the second one.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ArrowedLine(
    IInputOutputArray img,
    Point pt1,
    Point pt2,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0,
    double tipLength = 0.1
)
Public Shared Sub ArrowedLine (
    img As IInputOutputArray,
    pt1 As Point,
    pt2 As Point,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0,
    Optional tipLength As Double = 0.1
)
public:
static void ArrowedLine(
    IInputOutputArray^ img,
    Point^ pt1,
    Point^ pt2,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0,
    double tipLength = 0.1
)
static member ArrowedLine :
        img : IInputOutputArray *
        pt1 : Point *
        pt2 : Point *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int *
        ?tipLength : float
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
        let _tipLength = defaultArg tipLength 0.1
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image
pt1
Type: System.DrawingPoint
The point the arrow starts from.
pt2
Type: System.DrawingPoint
The point the arrow points to.
color
Type: Emgu.CV.StructureMCvScalar
Line color.
thickness (Optional)
Type: SystemInt32
Line thickness.
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the line.
shift (Optional)
Type: SystemInt32
Number of fractional bits in the point coordinates.
tipLength (Optional)
Type: SystemDouble
The length of the arrow tip in relation to the arrow length
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BilateralFilter Method

CvInvokeBilateralFilter Method

Applies the bilateral filter to an image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BilateralFilter(
    IInputArray src,
    IOutputArray dst,
    int d,
    double sigmaColor,
    double sigmaSpace,
    BorderType borderType = 4
)
Public Shared Sub BilateralFilter (
    src As IInputArray,
    dst As IOutputArray,
    d As Integer,
    sigmaColor As Double,
    sigmaSpace As Double,
    Optional borderType As BorderType = 4
)
public:
static void BilateralFilter(
    IInputArray^ src,
    IOutputArray^ dst,
    int d,
    double sigmaColor,
    double sigmaSpace,
    BorderType^ borderType = 4
)
static member BilateralFilter :
        src : IInputArray *
        dst : IOutputArray *
        d : int *
        sigmaColor : float *
        sigmaSpace : float *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source 8-bit or floating-point, 1-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Destination image of the same size and type as src .
d
Type: SystemInt32
Diameter of each pixel neighborhood that is used during filtering. If it is non-positive, it is computed from sigmaSpace .
sigmaColor
Type: SystemDouble
Filter sigma in the color space. A larger value of the parameter means that farther colors within the pixel neighborhood (see sigmaSpace ) will be mixed together, resulting in larger areas of semi-equal color.
sigmaSpace
Type: SystemDouble
Filter sigma in the coordinate space. A larger value of the parameter means that farther pixels will influence each other as long as their colors are close enough (see sigmaColor ). When d>0 , it specifies the neighborhood size regardless of sigmaSpace. Otherwise, d is proportional to sigmaSpace.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border mode used to extrapolate pixels outside of the image.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BitwiseAnd Method

CvInvokeBitwiseAnd Method

Calculates per-element bit-wise logical conjunction of two arrays: dst(I)=src1(I) & src2(I) if mask(I)!=0 In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseAnd(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null
)
Public Shared Sub BitwiseAnd (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void BitwiseAnd(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr
)
static member BitwiseAnd :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask, 8-bit single channel array; specifies elements of destination array to be changed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BitwiseNot Method

CvInvokeBitwiseNot Method

Inverses every bit of every array element:

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseNot(
    IInputArray src,
    IOutputArray dst,
    IInputArray mask = null
)
Public Shared Sub BitwiseNot (
    src As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void BitwiseNot(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr
)
static member BitwiseNot :
        src : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source array
dst
Type: Emgu.CVIOutputArray
The destination array
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask for the operation, use null to ignore
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BitwiseOr Method

CvInvokeBitwiseOr Method

Calculates per-element bit-wise disjunction of two arrays: dst(I)=src1(I)|src2(I) In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseOr(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null
)
Public Shared Sub BitwiseOr (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void BitwiseOr(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr
)
static member BitwiseOr :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask, 8-bit single channel array; specifies elements of destination array to be changed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BitwiseXor Method

CvInvokeBitwiseXor Method

Calculates per-element bit-wise logical conjunction of two arrays: dst(I)=src1(I)^src2(I) if mask(I)!=0 In the case of floating-point arrays their bit representations are used for the operation. All the arrays must have the same type, except the mask, and the same size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseXor(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null
)
Public Shared Sub BitwiseXor (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void BitwiseXor(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr
)
static member BitwiseXor :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
mask (Optional)
Type: Emgu.CVIInputArray
Mask, 8-bit single channel array; specifies elements of destination array to be changed.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BlendLinear Method

CvInvokeBlendLinear Method

Performs linear blending of two images: dst(i, j)=weights1(i, j) x src1(i, j) + weights2(i, j) x src2(i, j)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BlendLinear(
    IInputArray src1,
    IInputArray src2,
    IInputArray weights1,
    IInputArray weights2,
    IOutputArray dst
)
Public Shared Sub BlendLinear (
    src1 As IInputArray,
    src2 As IInputArray,
    weights1 As IInputArray,
    weights2 As IInputArray,
    dst As IOutputArray
)
public:
static void BlendLinear(
    IInputArray^ src1,
    IInputArray^ src2,
    IInputArray^ weights1,
    IInputArray^ weights2,
    IOutputArray^ dst
)
static member BlendLinear :
        src1 : IInputArray *
        src2 : IInputArray *
        weights1 : IInputArray *
        weights2 : IInputArray *
        dst : IOutputArray -> unit

Parameters

src1
Type: Emgu.CVIInputArray
It has a type of CV_8UC(n) or CV_32FC(n), where n is a positive integer.
src2
Type: Emgu.CVIInputArray
It has the same type and size as src1.
weights1
Type: Emgu.CVIInputArray
It has a type of CV_32FC1 and the same size with src1.
weights2
Type: Emgu.CVIInputArray
It has a type of CV_32FC1 and the same size with src1.
dst
Type: Emgu.CVIOutputArray
It is created if it does not have the same size and type with src1.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Blur Method

CvInvokeBlur Method

Blurs an image using the normalized box filter.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Blur(
    IInputArray src,
    IOutputArray dst,
    Size ksize,
    Point anchor,
    BorderType borderType = 4
)
Public Shared Sub Blur (
    src As IInputArray,
    dst As IOutputArray,
    ksize As Size,
    anchor As Point,
    Optional borderType As BorderType = 4
)
public:
static void Blur(
    IInputArray^ src,
    IOutputArray^ dst,
    Size^ ksize,
    Point^ anchor,
    BorderType^ borderType = 4
)
static member Blur :
        src : IInputArray *
        dst : IOutputArray *
        ksize : Size *
        anchor : Point *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
input image; it can have any number of channels, which are processed independently, but the depth should be CV_8U, CV_16U, CV_16S, CV_32F or CV_64F.
dst
Type: Emgu.CVIOutputArray
Output image of the same size and type as src.
ksize
Type: System.DrawingSize
Blurring kernel size.
anchor
Type: System.DrawingPoint
Anchor point; default value Point(-1,-1) means that the anchor is at the kernel center.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border mode used to extrapolate pixels outside of the image.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BoundingRectangle Method

CvInvokeBoundingRectangle Method

Returns the up-right bounding rectangle for 2d point set

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Rectangle BoundingRectangle(
    IInputArray points
)
Public Shared Function BoundingRectangle (
    points As IInputArray
) As Rectangle
public:
static Rectangle^ BoundingRectangle(
    IInputArray^ points
)
static member BoundingRectangle :
        points : IInputArray -> Rectangle

Parameters

points
Type: Emgu.CVIInputArray
Input 2D point set, stored in std::vector or Mat.

Return Value

Type: Rectangle
The up-right bounding rectangle for 2d point set
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BoxFilter Method

CvInvokeBoxFilter Method

Blurs an image using the box filter.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BoxFilter(
    IInputArray src,
    IOutputArray dst,
    DepthType ddepth,
    Size ksize,
    Point anchor,
    bool normalize = true,
    BorderType borderType = 4
)
Public Shared Sub BoxFilter (
    src As IInputArray,
    dst As IOutputArray,
    ddepth As DepthType,
    ksize As Size,
    anchor As Point,
    Optional normalize As Boolean = true,
    Optional borderType As BorderType = 4
)
public:
static void BoxFilter(
    IInputArray^ src,
    IOutputArray^ dst,
    DepthType^ ddepth,
    Size^ ksize,
    Point^ anchor,
    bool normalize = true,
    BorderType^ borderType = 4
)
static member BoxFilter :
        src : IInputArray *
        dst : IOutputArray *
        ddepth : DepthType *
        ksize : Size *
        anchor : Point *
        ?normalize : bool *
        ?borderType : BorderType
(* Defaults:
        let _normalize = defaultArg normalize true
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input image.
dst
Type: Emgu.CVIOutputArray
Output image of the same size and type as src.
ddepth
Type: Emgu.CV.CvEnumDepthType
The output image depth (-1 to use src.depth()).
ksize
Type: System.DrawingSize
Blurring kernel size.
anchor
Type: System.DrawingPoint
Anchor point; default value Point(-1,-1) means that the anchor is at the kernel center.
normalize (Optional)
Type: SystemBoolean
Specifying whether the kernel is normalized by its area or not.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border mode used to extrapolate pixels outside of the image.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BoxPoints Method

CvInvokeBoxPoints Method

Overload List
Name | Description
BoxPoints(RotatedRect) | Calculates vertices of the input 2d box.
BoxPoints(RotatedRect, IOutputArray) | Calculates vertices of the input 2d box.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BoxPoints Method (RotatedRect)

CvInvokeBoxPoints Method (RotatedRect)

http://www.emgu.com
Calculates vertices of the input 2d box.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static PointF[] BoxPoints(
    RotatedRect box
)
Public Shared Function BoxPoints (
    box As RotatedRect
) As PointF()
public:
static array<PointF^>^ BoxPoints(
    RotatedRect^ box
)
static member BoxPoints :
        box : RotatedRect -> PointF[]

Parameters

box
Type: Emgu.CV.StructureRotatedRect
The box

Return Value

Type: PointF
The four vertices of rectangles.
See Also

Reference

CvInvoke Class
BoxPoints Overload
Emgu.CV Namespace


CvInvoke.BoxPoints Method (RotatedRect, IOutputArray)

CvInvokeBoxPoints Method (RotatedRect, IOutputArray)

http://www.emgu.com
Calculates vertices of the input 2d box.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BoxPoints(
    RotatedRect box,
    IOutputArray points
)
Public Shared Sub BoxPoints (
    box As RotatedRect,
    points As IOutputArray
)
public:
static void BoxPoints(
    RotatedRect^ box,
    IOutputArray^ points
)
static member BoxPoints :
        box : RotatedRect *
        points : IOutputArray -> unit

Parameters

box
Type: Emgu.CV.StructureRotatedRect
The box
points
Type: Emgu.CVIOutputArray
The output array of four vertices of rectangles.
See Also

Reference

CvInvoke Class
BoxPoints Overload
Emgu.CV Namespace


CvInvoke.BuildOpticalFlowPyramid Method

CvInvokeBuildOpticalFlowPyramid Method

Constructs the image pyramid which can be passed to calcOpticalFlowPyrLK.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int BuildOpticalFlowPyramid(
    IInputArray img,
    IOutputArrayOfArrays pyramid,
    Size winSize,
    int maxLevel,
    bool withDerivatives = true,
    BorderType pyrBorder = 4,
    BorderType derivBorder = 0,
    bool tryReuseInputImage = true
)
Public Shared Function BuildOpticalFlowPyramid (
    img As IInputArray,
    pyramid As IOutputArrayOfArrays,
    winSize As Size,
    maxLevel As Integer,
    Optional withDerivatives As Boolean = true,
    Optional pyrBorder As BorderType = 4,
    Optional derivBorder As BorderType = 0,
    Optional tryReuseInputImage As Boolean = true
) As Integer
public:
static int BuildOpticalFlowPyramid(
    IInputArray^ img,
    IOutputArrayOfArrays^ pyramid,
    Size^ winSize,
    int maxLevel,
    bool withDerivatives = true,
    BorderType^ pyrBorder = 4,
    BorderType^ derivBorder = 0,
    bool tryReuseInputImage = true
)
static member BuildOpticalFlowPyramid :
        img : IInputArray *
        pyramid : IOutputArrayOfArrays *
        winSize : Size *
        maxLevel : int *
        ?withDerivatives : bool *
        ?pyrBorder : BorderType *
        ?derivBorder : BorderType *
        ?tryReuseInputImage : bool
(* Defaults:
        let _withDerivatives = defaultArg withDerivatives true
        let _pyrBorder = defaultArg pyrBorder 4
        let _derivBorder = defaultArg derivBorder 0
        let _tryReuseInputImage = defaultArg tryReuseInputImage true
*)
-> int

Parameters

img
Type: Emgu.CVIInputArray
8-bit input image.
pyramid
Type: Emgu.CVIOutputArrayOfArrays
Output pyramid.
winSize
Type: System.DrawingSize
Window size of optical flow algorithm. Must be not less than winSize argument of calcOpticalFlowPyrLK. It is needed to calculate required padding for pyramid levels.
maxLevel
Type: SystemInt32
0-based maximal pyramid level number.
withDerivatives (Optional)
Type: SystemBoolean
Set to precompute gradients for the every pyramid level. If pyramid is constructed without the gradients then calcOpticalFlowPyrLK will calculate them internally.
pyrBorder (Optional)
Type: Emgu.CV.CvEnumBorderType
The border mode for pyramid layers.
derivBorder (Optional)
Type: Emgu.CV.CvEnumBorderType
The border mode for gradients.
tryReuseInputImage (Optional)
Type: SystemBoolean
put ROI of input image into the pyramid if possible. You can pass false to force data copying.

Return Value

Type: Int32
Number of levels in constructed pyramid. Can be less than maxLevel.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BuildPyramid Method

CvInvokeBuildPyramid Method

The function constructs a vector of images and builds the Gaussian pyramid by recursively applying pyrDown to the previously built pyramid layers, starting from dst[0]==src.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BuildPyramid(
    IInputArray src,
    IOutputArrayOfArrays dst,
    int maxlevel,
    BorderType borderType = 4
)
Public Shared Sub BuildPyramid (
    src As IInputArray,
    dst As IOutputArrayOfArrays,
    maxlevel As Integer,
    Optional borderType As BorderType = 4
)
public:
static void BuildPyramid(
    IInputArray^ src,
    IOutputArrayOfArrays^ dst,
    int maxlevel,
    BorderType^ borderType = 4
)
static member BuildPyramid :
        src : IInputArray *
        dst : IOutputArrayOfArrays *
        maxlevel : int *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image. Check pyrDown for the list of supported types.
dst
Type: Emgu.CVIOutputArrayOfArrays
Destination vector of maxlevel+1 images of the same type as src. dst[0] will be the same as src. dst[1] is the next pyramid layer, a smoothed and down-sized src, and so on.
maxlevel
Type: SystemInt32
0-based index of the last (the smallest) pyramid layer. It must be non-negative.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcBackProject Method

CvInvokeCalcBackProject Method

Calculates the back projection of a histogram.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcBackProject(
    IInputArrayOfArrays images,
    int[] channels,
    IInputArray hist,
    IOutputArray backProject,
    float[] ranges,
    double scale = 1
)
Public Shared Sub CalcBackProject (
    images As IInputArrayOfArrays,
    channels As Integer(),
    hist As IInputArray,
    backProject As IOutputArray,
    ranges As Single(),
    Optional scale As Double = 1
)
public:
static void CalcBackProject(
    IInputArrayOfArrays^ images,
    array<int>^ channels,
    IInputArray^ hist,
    IOutputArray^ backProject,
    array<float>^ ranges,
    double scale = 1
)
static member CalcBackProject :
        images : IInputArrayOfArrays *
        channels : int[] *
        hist : IInputArray *
        backProject : IOutputArray *
        ranges : float32[] *
        ?scale : float
(* Defaults:
        let _scale = defaultArg scale 1
*)
-> unit

Parameters

images
Type: Emgu.CVIInputArrayOfArrays
Source arrays. They all should have the same depth, CV_8U or CV_32F , and the same size. Each of them can have an arbitrary number of channels.
channels
Type: SystemInt32
Number of source images.
hist
Type: Emgu.CVIInputArray
Input histogram that can be dense or sparse.
backProject
Type: Emgu.CVIOutputArray
Destination back projection array that is a single-channel array of the same size and depth as images[0] .
ranges
Type: SystemSingle
Array of arrays of the histogram bin boundaries in each dimension.
scale (Optional)
Type: SystemDouble
Optional scale factor for the output back projection.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcCovarMatrix Method

CvInvokeCalcCovarMatrix Method

Calculates the covariance matrix of a set of vectors.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcCovarMatrix(
    IInputArray samples,
    IOutputArray covar,
    IInputOutputArray mean,
    CovarMethod flags,
    DepthType ctype = 6
)
Public Shared Sub CalcCovarMatrix (
    samples As IInputArray,
    covar As IOutputArray,
    mean As IInputOutputArray,
    flags As CovarMethod,
    Optional ctype As DepthType = 6
)
public:
static void CalcCovarMatrix(
    IInputArray^ samples,
    IOutputArray^ covar,
    IInputOutputArray^ mean,
    CovarMethod^ flags,
    DepthType^ ctype = 6
)
static member CalcCovarMatrix :
        samples : IInputArray *
        covar : IOutputArray *
        mean : IInputOutputArray *
        flags : CovarMethod *
        ?ctype : DepthType
(* Defaults:
        let _ctype = defaultArg ctype 6
*)
-> unit

Parameters

samples
Type: Emgu.CVIInputArray
Samples stored either as separate matrices or as rows/columns of a single matrix.
covar
Type: Emgu.CVIOutputArray
Output covariance matrix of the type ctype and square size.
mean
Type: Emgu.CVIInputOutputArray
Input or output (depending on the flags) array as the average value of the input vectors.
flags
Type: Emgu.CV.CvEnumCovarMethod
Operation flags
ctype (Optional)
Type: Emgu.CV.CvEnumDepthType
Type of the matrix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcGlobalOrientation Method

CvInvokeCalcGlobalOrientation Method

Calculates the general motion direction in the selected region and returns the angle between 0 and 360. At first the function builds the orientation histogram and finds the basic orientation as a coordinate of the histogram maximum. After that the function calculates the shift relative to the basic orientation as a weighted sum of all orientation vectors: the more recent is the motion, the greater is the weight. The resultant angle is a circular sum of the basic orientation and the shift.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CalcGlobalOrientation(
    IInputArray orientation,
    IInputArray mask,
    IInputArray mhi,
    double timestamp,
    double duration
)
Public Shared Function CalcGlobalOrientation (
    orientation As IInputArray,
    mask As IInputArray,
    mhi As IInputArray,
    timestamp As Double,
    duration As Double
) As Double
public:
static double CalcGlobalOrientation(
    IInputArray^ orientation,
    IInputArray^ mask,
    IInputArray^ mhi,
    double timestamp,
    double duration
)
static member CalcGlobalOrientation :
        orientation : IInputArray *
        mask : IInputArray *
        mhi : IInputArray *
        timestamp : float *
        duration : float -> float

Parameters

orientation
Type: Emgu.CVIInputArray
Motion gradient orientation image; calculated by the function cvCalcMotionGradient.
mask
Type: Emgu.CVIInputArray
Mask image. It may be a conjunction of valid gradient mask, obtained with cvCalcMotionGradient and mask of the region, whose direction needs to be calculated.
mhi
Type: Emgu.CVIInputArray
Motion history image.
timestamp
Type: SystemDouble
Current time in milliseconds or other units, it is better to store time passed to cvUpdateMotionHistory before and reuse it here, because running cvUpdateMotionHistory and cvCalcMotionGradient on large images may take some time.
duration
Type: SystemDouble
Maximal duration of motion track in milliseconds, the same as in cvUpdateMotionHistory

Return Value

Type: Double
The angle
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcHist Method

CvInvokeCalcHist Method

Calculates a histogram of a set of arrays.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcHist(
    IInputArrayOfArrays images,
    int[] channels,
    IInputArray mask,
    IOutputArray hist,
    int[] histSize,
    float[] ranges,
    bool accumulate
)
Public Shared Sub CalcHist (
    images As IInputArrayOfArrays,
    channels As Integer(),
    mask As IInputArray,
    hist As IOutputArray,
    histSize As Integer(),
    ranges As Single(),
    accumulate As Boolean
)
public:
static void CalcHist(
    IInputArrayOfArrays^ images,
    array<int>^ channels,
    IInputArray^ mask,
    IOutputArray^ hist,
    array<int>^ histSize,
    array<float>^ ranges,
    bool accumulate
)
static member CalcHist :
        images : IInputArrayOfArrays *
        channels : int[] *
        mask : IInputArray *
        hist : IOutputArray *
        histSize : int[] *
        ranges : float32[] *
        accumulate : bool -> unit

Parameters

images
Type: Emgu.CVIInputArrayOfArrays
Source arrays. They all should have the same depth, CV_8U or CV_32F , and the same size. Each of them can have an arbitrary number of channels.
channels
Type: SystemInt32
List of the channels used to compute the histogram.
mask
Type: Emgu.CVIInputArray
Optional mask. If the matrix is not empty, it must be an 8-bit array of the same size as images[i] . The non-zero mask elements mark the array elements counted in the histogram.
hist
Type: Emgu.CVIOutputArray
Output histogram
histSize
Type: SystemInt32
Array of histogram sizes in each dimension.
ranges
Type: SystemSingle
Array of the dims arrays of the histogram bin boundaries in each dimension.
accumulate
Type: SystemBoolean
Accumulation flag. If it is set, the histogram is not cleared in the beginning when it is allocated. This feature enables you to compute a single histogram from several sets of arrays, or to update the histogram in time.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcMotionGradient Method

CvInvokeCalcMotionGradient Method

Calculates the derivatives Dx and Dy of mhi and then calculates gradient orientation as: orientation(x,y)=arctan(Dy(x,y)/Dx(x,y)) where both Dx(x,y)' and Dy(x,y)' signs are taken into account (as in cvCartToPolar function). After that mask is filled to indicate where the orientation is valid (see delta1 and delta2 description).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcMotionGradient(
    IInputArray mhi,
    IOutputArray mask,
    IOutputArray orientation,
    double delta1,
    double delta2,
    int apertureSize = 3
)
Public Shared Sub CalcMotionGradient (
    mhi As IInputArray,
    mask As IOutputArray,
    orientation As IOutputArray,
    delta1 As Double,
    delta2 As Double,
    Optional apertureSize As Integer = 3
)
public:
static void CalcMotionGradient(
    IInputArray^ mhi,
    IOutputArray^ mask,
    IOutputArray^ orientation,
    double delta1,
    double delta2,
    int apertureSize = 3
)
static member CalcMotionGradient :
        mhi : IInputArray *
        mask : IOutputArray *
        orientation : IOutputArray *
        delta1 : float *
        delta2 : float *
        ?apertureSize : int
(* Defaults:
        let _apertureSize = defaultArg apertureSize 3
*)
-> unit

Parameters

mhi
Type: Emgu.CVIInputArray
Motion history image
mask
Type: Emgu.CVIOutputArray
Mask image; marks pixels where motion gradient data is correct. Output parameter.
orientation
Type: Emgu.CVIOutputArray
Motion gradient orientation image; contains angles from 0 to ~360.
delta1
Type: SystemDouble
The function finds minimum (m(x,y)) and maximum (M(x,y)) mhi values over each pixel (x,y) neihborhood and assumes the gradient is valid only if min(delta1,delta2) <= M(x,y)-m(x,y) <= max(delta1,delta2).
delta2
Type: SystemDouble
The function finds minimum (m(x,y)) and maximum (M(x,y)) mhi values over each pixel (x,y) neihborhood and assumes the gradient is valid only if min(delta1,delta2) <= M(x,y)-m(x,y) <= max(delta1,delta2).
apertureSize (Optional)
Type: SystemInt32
Aperture size of derivative operators used by the function: CV_SCHARR, 1, 3, 5 or 7 (see cvSobel).
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcOpticalFlowFarneback Method

CvInvokeCalcOpticalFlowFarneback Method

Overload List
Name | Description
CalcOpticalFlowFarneback(IInputArray, IInputArray, IInputOutputArray, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag) | Computes dense optical flow using Gunnar Farneback's algorithm
CalcOpticalFlowFarneback(ImageGray, Byte, ImageGray, Byte, ImageGray, Single, ImageGray, Single, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag) | Computes dense optical flow using Gunnar Farneback's algorithm
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcOpticalFlowFarneback Method (IInputArray, IInputArray, IInputOutputArray, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)

CvInvokeCalcOpticalFlowFarneback Method (IInputArray, IInputArray, IInputOutputArray, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)

http://www.emgu.com
Computes dense optical flow using Gunnar Farneback's algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcOpticalFlowFarneback(
    IInputArray prev0,
    IInputArray next0,
    IInputOutputArray flow,
    double pyrScale,
    int levels,
    int winSize,
    int iterations,
    int polyN,
    double polySigma,
    OpticalflowFarnebackFlag flags
)
Public Shared Sub CalcOpticalFlowFarneback (
    prev0 As IInputArray,
    next0 As IInputArray,
    flow As IInputOutputArray,
    pyrScale As Double,
    levels As Integer,
    winSize As Integer,
    iterations As Integer,
    polyN As Integer,
    polySigma As Double,
    flags As OpticalflowFarnebackFlag
)
public:
static void CalcOpticalFlowFarneback(
    IInputArray^ prev0,
    IInputArray^ next0,
    IInputOutputArray^ flow,
    double pyrScale,
    int levels,
    int winSize,
    int iterations,
    int polyN,
    double polySigma,
    OpticalflowFarnebackFlag^ flags
)
static member CalcOpticalFlowFarneback :
        prev0 : IInputArray *
        next0 : IInputArray *
        flow : IInputOutputArray *
        pyrScale : float *
        levels : int *
        winSize : int *
        iterations : int *
        polyN : int *
        polySigma : float *
        flags : OpticalflowFarnebackFlag -> unit

Parameters

prev0
Type: Emgu.CVIInputArray
The first 8-bit single-channel input image
next0
Type: Emgu.CVIInputArray
The second input image of the same size and the same type as prevImg
flow
Type: Emgu.CVIInputOutputArray
The computed flow image; will have the same size as prevImg and type CV 32FC2
pyrScale
Type: SystemDouble
Specifies the image scale (!1) to build the pyramids for each image. pyrScale=0.5 means the classical pyramid, where each next layer is twice smaller than the previous
levels
Type: SystemInt32
The number of pyramid layers, including the initial image. levels=1 means that no extra layers are created and only the original images are used
winSize
Type: SystemInt32
The averaging window size; The larger values increase the algorithm robustness to image noise and give more chances for fast motion detection, but yield more blurred motion field
iterations
Type: SystemInt32
The number of iterations the algorithm does at each pyramid level
polyN
Type: SystemInt32
Size of the pixel neighborhood used to find polynomial expansion in each pixel. The larger values mean that the image will be approximated with smoother surfaces, yielding more robust algorithm and more blurred motion field. Typically, poly n=5 or 7
polySigma
Type: SystemDouble
Standard deviation of the Gaussian that is used to smooth derivatives that are used as a basis for the polynomial expansion. For poly n=5 you can set poly sigma=1.1, for poly n=7 a good value would be poly sigma=1.5
flags
Type: Emgu.CV.CvEnumOpticalflowFarnebackFlag
The operation flags
See Also

Reference

CvInvoke Class
CalcOpticalFlowFarneback Overload
Emgu.CV Namespace


CvInvoke.CalcOpticalFlowFarneback Method (Image(Gray, Byte), Image(Gray, Byte), Image(Gray, Single), Image(Gray, Single), Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)

CvInvokeCalcOpticalFlowFarneback Method (ImageGray, Byte, ImageGray, Byte, ImageGray, Single, ImageGray, Single, Double, Int32, Int32, Int32, Int32, Double, OpticalflowFarnebackFlag)

http://www.emgu.com
Computes dense optical flow using Gunnar Farneback's algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcOpticalFlowFarneback(
    Image<Gray, byte> prev0,
    Image<Gray, byte> next0,
    Image<Gray, float> flowX,
    Image<Gray, float> flowY,
    double pyrScale,
    int levels,
    int winSize,
    int iterations,
    int polyN,
    double polySigma,
    OpticalflowFarnebackFlag flags
)
Public Shared Sub CalcOpticalFlowFarneback (
    prev0 As Image(Of Gray, Byte),
    next0 As Image(Of Gray, Byte),
    flowX As Image(Of Gray, Single),
    flowY As Image(Of Gray, Single),
    pyrScale As Double,
    levels As Integer,
    winSize As Integer,
    iterations As Integer,
    polyN As Integer,
    polySigma As Double,
    flags As OpticalflowFarnebackFlag
)
public:
static void CalcOpticalFlowFarneback(
    Image<Gray^, unsigned char>^ prev0,
    Image<Gray^, unsigned char>^ next0,
    Image<Gray^, float>^ flowX,
    Image<Gray^, float>^ flowY,
    double pyrScale,
    int levels,
    int winSize,
    int iterations,
    int polyN,
    double polySigma,
    OpticalflowFarnebackFlag^ flags
)
static member CalcOpticalFlowFarneback :
        prev0 : Image<Gray, byte> *
        next0 : Image<Gray, byte> *
        flowX : Image<Gray, float32> *
        flowY : Image<Gray, float32> *
        pyrScale : float *
        levels : int *
        winSize : int *
        iterations : int *
        polyN : int *
        polySigma : float *
        flags : OpticalflowFarnebackFlag -> unit

Parameters

prev0
Type: Emgu.CVImage Gray, Byte
The first 8-bit single-channel input image
next0
Type: Emgu.CVImage Gray, Byte
The second input image of the same size and the same type as prevImg
flowX
Type: Emgu.CVImage Gray, Single
The computed flow image for x-velocity; will have the same size as prevImg
flowY
Type: Emgu.CVImage Gray, Single
The computed flow image for y-velocity; will have the same size as prevImg
pyrScale
Type: SystemDouble
Specifies the image scale (!1) to build the pyramids for each image. pyrScale=0.5 means the classical pyramid, where each next layer is twice smaller than the previous
levels
Type: SystemInt32
The number of pyramid layers, including the initial image. levels=1 means that no extra layers are created and only the original images are used
winSize
Type: SystemInt32
The averaging window size; The larger values increase the algorithm robustness to image noise and give more chances for fast motion detection, but yield more blurred motion field
iterations
Type: SystemInt32
The number of iterations the algorithm does at each pyramid level
polyN
Type: SystemInt32
Size of the pixel neighborhood used to find polynomial expansion in each pixel. The larger values mean that the image will be approximated with smoother surfaces, yielding more robust algorithm and more blurred motion field. Typically, poly n=5 or 7
polySigma
Type: SystemDouble
Standard deviation of the Gaussian that is used to smooth derivatives that are used as a basis for the polynomial expansion. For poly n=5 you can set poly sigma=1.1, for poly n=7 a good value would be poly sigma=1.5
flags
Type: Emgu.CV.CvEnumOpticalflowFarnebackFlag
The operation flags
See Also

Reference

CvInvoke Class
CalcOpticalFlowFarneback Overload
Emgu.CV Namespace


CvInvoke.CalcOpticalFlowPyrLK Method

CvInvokeCalcOpticalFlowPyrLK Method

Overload List
Name | Description
CalcOpticalFlowPyrLK(IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Size, Int32, MCvTermCriteria, LKFlowFlag, Double) | Implements sparse iterative version of Lucas-Kanade optical flow in pyramids ([Bouguet00]). It calculates coordinates of the feature points on the current video frame given their coordinates on the previous frame. The function finds the coordinates with sub-pixel accuracy.
CalcOpticalFlowPyrLK(IInputArray, IInputArray, PointF, Size, Int32, MCvTermCriteria, PointF, Byte, Single, LKFlowFlag, Double) | Calculates optical flow for a sparse feature set using iterative Lucas-Kanade method in pyramids
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalcOpticalFlowPyrLK Method (IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Size, Int32, MCvTermCriteria, LKFlowFlag, Double)

CvInvokeCalcOpticalFlowPyrLK Method (IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Size, Int32, MCvTermCriteria, LKFlowFlag, Double)

http://www.emgu.com
Implements sparse iterative version of Lucas-Kanade optical flow in pyramids ([Bouguet00]). It calculates coordinates of the feature points on the current video frame given their coordinates on the previous frame. The function finds the coordinates with sub-pixel accuracy.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcOpticalFlowPyrLK(
    IInputArray prevImg,
    IInputArray nextImg,
    IInputArray prevPts,
    IInputOutputArray nextPts,
    IOutputArray status,
    IOutputArray err,
    Size winSize,
    int maxLevel,
    MCvTermCriteria criteria,
    LKFlowFlag flags = 0,
    double minEigThreshold = 0.0001
)
Public Shared Sub CalcOpticalFlowPyrLK (
    prevImg As IInputArray,
    nextImg As IInputArray,
    prevPts As IInputArray,
    nextPts As IInputOutputArray,
    status As IOutputArray,
    err As IOutputArray,
    winSize As Size,
    maxLevel As Integer,
    criteria As MCvTermCriteria,
    Optional flags As LKFlowFlag = 0,
    Optional minEigThreshold As Double = 0.0001
)
public:
static void CalcOpticalFlowPyrLK(
    IInputArray^ prevImg,
    IInputArray^ nextImg,
    IInputArray^ prevPts,
    IInputOutputArray^ nextPts,
    IOutputArray^ status,
    IOutputArray^ err,
    Size^ winSize,
    int maxLevel,
    MCvTermCriteria^ criteria,
    LKFlowFlag^ flags = 0,
    double minEigThreshold = 0.0001
)
static member CalcOpticalFlowPyrLK :
        prevImg : IInputArray *
        nextImg : IInputArray *
        prevPts : IInputArray *
        nextPts : IInputOutputArray *
        status : IOutputArray *
        err : IOutputArray *
        winSize : Size *
        maxLevel : int *
        criteria : MCvTermCriteria *
        ?flags : LKFlowFlag *
        ?minEigThreshold : float
(* Defaults:
        let _flags = defaultArg flags 0
        let _minEigThreshold = defaultArg minEigThreshold 0.0001
*)
-> unit

Parameters

prevImg
Type: Emgu.CVIInputArray
First frame, at time t.
nextImg
Type: Emgu.CVIInputArray
Second frame, at time t + dt .
prevPts
Type: Emgu.CVIInputArray
Array of points for which the flow needs to be found.
nextPts
Type: Emgu.CVIInputOutputArray
Array of 2D points containing calculated new positions of input
status
Type: Emgu.CVIOutputArray
Array. Every element of the array is set to 1 if the flow for the corresponding feature has been found, 0 otherwise.
err
Type: Emgu.CVIOutputArray
Array of double numbers containing difference between patches around the original and moved points. Optional parameter; can be NULL
winSize
Type: System.DrawingSize
Size of the search window of each pyramid level.
maxLevel
Type: SystemInt32
Maximal pyramid level number. If 0 , pyramids are not used (single level), if 1 , two levels are used, etc.
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Specifies when the iteration process of finding the flow for each point on each pyramid level should be stopped.
flags (Optional)
Type: Emgu.CV.CvEnumLKFlowFlag
Miscellaneous flags
minEigThreshold (Optional)
Type: SystemDouble
the algorithm calculates the minimum eigen value of a 2x2 normal matrix of optical flow equations (this matrix is called a spatial gradient matrix in [Bouguet00]), divided by number of pixels in a window; if this value is less than minEigThreshold, then a corresponding feature is filtered out and its flow is not processed, so it allows to remove bad points and get a performance boost.
Remarks
Both parameters prev_pyr and curr_pyr comply with the following rules: if the image pointer is 0, the function allocates the buffer internally, calculates the pyramid, and releases the buffer after processing. Otherwise, the function calculates the pyramid and stores it in the buffer unless the flag CV_LKFLOW_PYR_A[B]_READY is set. The image should be large enough to fit the Gaussian pyramid data. After the function call both pyramids are calculated and the readiness flag for the corresponding image can be set in the next call (i.e., typically, for all the image pairs except the very first one CV_LKFLOW_PYR_A_READY is set).
See Also

Reference

CvInvoke Class
CalcOpticalFlowPyrLK Overload
Emgu.CV Namespace


CvInvoke.CalcOpticalFlowPyrLK Method (IInputArray, IInputArray, PointF[], Size, Int32, MCvTermCriteria, PointF[], Byte[], Single[], LKFlowFlag, Double)

CvInvokeCalcOpticalFlowPyrLK Method (IInputArray, IInputArray, PointF, Size, Int32, MCvTermCriteria, PointF, Byte, Single, LKFlowFlag, Double)

http://www.emgu.com
Calculates optical flow for a sparse feature set using iterative Lucas-Kanade method in pyramids

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcOpticalFlowPyrLK(
    IInputArray prev,
    IInputArray curr,
    PointF[] prevFeatures,
    Size winSize,
    int level,
    MCvTermCriteria criteria,
    out PointF[] currFeatures,
    out byte[] status,
    out float[] trackError,
    LKFlowFlag flags = 0,
    double minEigThreshold = 0.0001
)
Public Shared Sub CalcOpticalFlowPyrLK (
    prev As IInputArray,
    curr As IInputArray,
    prevFeatures As PointF(),
    winSize As Size,
    level As Integer,
    criteria As MCvTermCriteria,
    <OutAttribute> ByRef currFeatures As PointF(),
    <OutAttribute> ByRef status As Byte(),
    <OutAttribute> ByRef trackError As Single(),
    Optional flags As LKFlowFlag = 0,
    Optional minEigThreshold As Double = 0.0001
)
public:
static void CalcOpticalFlowPyrLK(
    IInputArray^ prev,
    IInputArray^ curr,
    array<PointF^>^ prevFeatures,
    Size^ winSize,
    int level,
    MCvTermCriteria^ criteria,
    [OutAttribute] array<PointF^>^% currFeatures,
    [OutAttribute] array<unsigned char>^% status,
    [OutAttribute] array<float>^% trackError,
    LKFlowFlag^ flags = 0,
    double minEigThreshold = 0.0001
)
static member CalcOpticalFlowPyrLK :
        prev : IInputArray *
        curr : IInputArray *
        prevFeatures : PointF[] *
        winSize : Size *
        level : int *
        criteria : MCvTermCriteria *
        currFeatures : PointF[] byref *
        status : byte[] byref *
        trackError : float32[] byref *
        ?flags : LKFlowFlag *
        ?minEigThreshold : float
(* Defaults:
        let _flags = defaultArg flags 0
        let _minEigThreshold = defaultArg minEigThreshold 0.0001
*)
-> unit

Parameters

prev
Type: Emgu.CVIInputArray
First frame, at time t
curr
Type: Emgu.CVIInputArray
Second frame, at time t + dt
prevFeatures
Type: System.DrawingPointF
Array of points for which the flow needs to be found
winSize
Type: System.DrawingSize
Size of the search window of each pyramid level
level
Type: SystemInt32
Maximal pyramid level number. If 0 , pyramids are not used (single level), if 1 , two levels are used, etc
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Specifies when the iteration process of finding the flow for each point on each pyramid level should be stopped
currFeatures
Type: System.DrawingPointF
Array of 2D points containing calculated new positions of input features in the second image
status
Type: SystemByte
Array. Every element of the array is set to 1 if the flow for the corresponding feature has been found, 0 otherwise
trackError
Type: SystemSingle
Array of double numbers containing difference between patches around the original and moved points
flags (Optional)
Type: Emgu.CV.CvEnumLKFlowFlag
Flags
minEigThreshold (Optional)
Type: SystemDouble
the algorithm calculates the minimum eigen value of a 2x2 normal matrix of optical flow equations (this matrix is called a spatial gradient matrix in [Bouguet00]), divided by number of pixels in a window; if this value is less than minEigThreshold, then a corresponding feature is filtered out and its flow is not processed, so it allows to remove bad points and get a performance boost.
See Also

Reference

CvInvoke Class
CalcOpticalFlowPyrLK Overload
Emgu.CV Namespace


CvInvoke.CalibrateCamera Method

CvInvokeCalibrateCamera Method

Overload List
Name | Description
CalibrateCamera(IInputArray, IInputArray, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Estimates intrinsic camera parameters and extrinsic parameters for each of the views
CalibrateCamera(MCvPoint3D32f, PointF, Size, IInputOutputArray, IInputOutputArray, CalibType, MCvTermCriteria, Mat, Mat) | Estimates intrinsic camera parameters and extrinsic parameters for each of the views
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalibrateCamera Method (IInputArray, IInputArray, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

CvInvokeCalibrateCamera Method (IInputArray, IInputArray, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

http://www.emgu.com
Estimates intrinsic camera parameters and extrinsic parameters for each of the views

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CalibrateCamera(
    IInputArray objectPoints,
    IInputArray imagePoints,
    Size imageSize,
    IInputOutputArray cameraMatrix,
    IInputOutputArray distortionCoeffs,
    IOutputArray rotationVectors,
    IOutputArray translationVectors,
    CalibType flags,
    MCvTermCriteria termCriteria
)
Public Shared Function CalibrateCamera (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    imageSize As Size,
    cameraMatrix As IInputOutputArray,
    distortionCoeffs As IInputOutputArray,
    rotationVectors As IOutputArray,
    translationVectors As IOutputArray,
    flags As CalibType,
    termCriteria As MCvTermCriteria
) As Double
public:
static double CalibrateCamera(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    Size^ imageSize,
    IInputOutputArray^ cameraMatrix,
    IInputOutputArray^ distortionCoeffs,
    IOutputArray^ rotationVectors,
    IOutputArray^ translationVectors,
    CalibType^ flags,
    MCvTermCriteria^ termCriteria
)
static member CalibrateCamera :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        imageSize : Size *
        cameraMatrix : IInputOutputArray *
        distortionCoeffs : IInputOutputArray *
        rotationVectors : IOutputArray *
        translationVectors : IOutputArray *
        flags : CalibType *
        termCriteria : MCvTermCriteria -> float

Parameters

objectPoints
Type: Emgu.CVIInputArray
The joint matrix of object points, 3xN or Nx3, where N is the total number of points in all views
imagePoints
Type: Emgu.CVIInputArray
The joint matrix of corresponding image points, 2xN or Nx2, where N is the total number of points in all views
imageSize
Type: System.DrawingSize
Size of the image, used only to initialize intrinsic camera matrix
cameraMatrix
Type: Emgu.CVIInputOutputArray
The output camera matrix (A) [fx 0 cx; 0 fy cy; 0 0 1]. If CV_CALIB_USE_INTRINSIC_GUESS and/or CV_CALIB_FIX_ASPECT_RATION are specified, some or all of fx, fy, cx, cy must be initialized
distortionCoeffs
Type: Emgu.CVIInputOutputArray
The output 4x1 or 1x4 vector of distortion coefficients [k1, k2, p1, p2]
rotationVectors
Type: Emgu.CVIOutputArray
The output 3xM or Mx3 array of rotation vectors (compact representation of rotation matrices, see cvRodrigues2).
translationVectors
Type: Emgu.CVIOutputArray
The output 3xM or Mx3 array of translation vectors
flags
Type: Emgu.CV.CvEnumCalibType
Different flags
termCriteria
Type: Emgu.CV.StructureMCvTermCriteria
The termination criteria

Return Value

Type: Double
The final reprojection error
See Also

Reference

CvInvoke Class
CalibrateCamera Overload
Emgu.CV Namespace


CvInvoke.CalibrateCamera Method (MCvPoint3D32f[][], PointF[][], Size, IInputOutputArray, IInputOutputArray, CalibType, MCvTermCriteria, Mat[], Mat[])

CvInvokeCalibrateCamera Method (MCvPoint3D32f, PointF, Size, IInputOutputArray, IInputOutputArray, CalibType, MCvTermCriteria, Mat, Mat)

http://www.emgu.com
Estimates intrinsic camera parameters and extrinsic parameters for each of the views

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CalibrateCamera(
    MCvPoint3D32f[][] objectPoints,
    PointF[][] imagePoints,
    Size imageSize,
    IInputOutputArray cameraMatrix,
    IInputOutputArray distortionCoeffs,
    CalibType calibrationType,
    MCvTermCriteria termCriteria,
    out Mat[] rotationVectors,
    out Mat[] translationVectors
)
Public Shared Function CalibrateCamera (
    objectPoints As MCvPoint3D32f()(),
    imagePoints As PointF()(),
    imageSize As Size,
    cameraMatrix As IInputOutputArray,
    distortionCoeffs As IInputOutputArray,
    calibrationType As CalibType,
    termCriteria As MCvTermCriteria,
    <OutAttribute> ByRef rotationVectors As Mat(),
    <OutAttribute> ByRef translationVectors As Mat()
) As Double
public:
static double CalibrateCamera(
    array<array<MCvPoint3D32f^>^>^ objectPoints,
    array<array<PointF^>^>^ imagePoints,
    Size^ imageSize,
    IInputOutputArray^ cameraMatrix,
    IInputOutputArray^ distortionCoeffs,
    CalibType^ calibrationType,
    MCvTermCriteria^ termCriteria,
    [OutAttribute] array<Mat^>^% rotationVectors,
    [OutAttribute] array<Mat^>^% translationVectors
)
static member CalibrateCamera :
        objectPoints : MCvPoint3D32f[][] *
        imagePoints : PointF[][] *
        imageSize : Size *
        cameraMatrix : IInputOutputArray *
        distortionCoeffs : IInputOutputArray *
        calibrationType : CalibType *
        termCriteria : MCvTermCriteria *
        rotationVectors : Mat[] byref *
        translationVectors : Mat[] byref -> float

Parameters

objectPoints
Type: Emgu.CV.StructureMCvPoint3D32f
The 3D location of the object points. The first index is the index of image, second index is the index of the point
imagePoints
Type: System.DrawingPointF
The 2D image location of the points. The first index is the index of the image, second index is the index of the point
imageSize
Type: System.DrawingSize
The size of the image, used only to initialize intrinsic camera matrix
cameraMatrix
Type: Emgu.CVIInputOutputArray
The output camera matrix (A) [fx 0 cx; 0 fy cy; 0 0 1]. If CV_CALIB_USE_INTRINSIC_GUESS and/or CV_CALIB_FIX_ASPECT_RATION are specified, some or all of fx, fy, cx, cy must be initialized
distortionCoeffs
Type: Emgu.CVIInputOutputArray
The output 4x1 or 1x4 vector of distortion coefficients [k1, k2, p1, p2]
calibrationType
Type: Emgu.CV.CvEnumCalibType
cCalibration type
termCriteria
Type: Emgu.CV.StructureMCvTermCriteria
The termination criteria
rotationVectors
Type: Emgu.CVMat
The output 3xM or Mx3 array of rotation vectors (compact representation of rotation matrices, see cvRodrigues2).
translationVectors
Type: Emgu.CVMat
The output 3xM or Mx3 array of translation vectors

Return Value

Type: Double
The final reprojection error
See Also

Reference

CvInvoke Class
CalibrateCamera Overload
Emgu.CV Namespace


CvInvoke.CalibrateHandEye Method

CvInvokeCalibrateHandEye Method

Computes Hand-Eye calibration

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalibrateHandEye(
    IInputArrayOfArrays rGripper2base,
    IInputArrayOfArrays tGripper2base,
    IInputArrayOfArrays rTarget2cam,
    IInputArrayOfArrays tTarget2cam,
    IOutputArray rCam2gripper,
    IOutputArray tCam2gripper,
    HandEyeCalibrationMethod method
)
Public Shared Sub CalibrateHandEye (
    rGripper2base As IInputArrayOfArrays,
    tGripper2base As IInputArrayOfArrays,
    rTarget2cam As IInputArrayOfArrays,
    tTarget2cam As IInputArrayOfArrays,
    rCam2gripper As IOutputArray,
    tCam2gripper As IOutputArray,
    method As HandEyeCalibrationMethod
)
public:
static void CalibrateHandEye(
    IInputArrayOfArrays^ rGripper2base,
    IInputArrayOfArrays^ tGripper2base,
    IInputArrayOfArrays^ rTarget2cam,
    IInputArrayOfArrays^ tTarget2cam,
    IOutputArray^ rCam2gripper,
    IOutputArray^ tCam2gripper,
    HandEyeCalibrationMethod^ method
)
static member CalibrateHandEye :
        rGripper2base : IInputArrayOfArrays *
        tGripper2base : IInputArrayOfArrays *
        rTarget2cam : IInputArrayOfArrays *
        tTarget2cam : IInputArrayOfArrays *
        rCam2gripper : IOutputArray *
        tCam2gripper : IOutputArray *
        method : HandEyeCalibrationMethod -> unit

Parameters

rGripper2base
Type: Emgu.CVIInputArrayOfArrays
Rotation part extracted from the homogeneous matrix that transforms a point expressed in the gripper frame to the robot base frame. This is a vector (vector<Mat>) that contains the rotation matrices for all the transformations from gripper frame to robot base frame.
tGripper2base
Type: Emgu.CVIInputArrayOfArrays
Translation part extracted from the homogeneous matrix that transforms a point expressed in the gripper frame to the robot base frame. This is a vector (vector<Mat>) that contains the translation vectors for all the transformations from gripper frame to robot base frame.
rTarget2cam
Type: Emgu.CVIInputArrayOfArrays
Rotation part extracted from the homogeneous matrix that transforms a point expressed in the target frame to the camera frame. This is a vector (vector<Mat>) that contains the rotation matrices for all the transformations from calibration target frame to camera frame.
tTarget2cam
Type: Emgu.CVIInputArrayOfArrays
Rotation part extracted from the homogeneous matrix that transforms a point expressed in the target frame to the camera frame. This is a vector (vector<Mat>) that contains the translation vectors for all the transformations from calibration target frame to camera frame.
rCam2gripper
Type: Emgu.CVIOutputArray
Estimated rotation part extracted from the homogeneous matrix that transforms a point expressed in the camera frame to the gripper frame.
tCam2gripper
Type: Emgu.CVIOutputArray
Estimated translation part extracted from the homogeneous matrix that transforms a point expressed in the camera frame to the gripper frame.
method
Type: Emgu.CV.CvEnumHandEyeCalibrationMethod
One of the implemented Hand-Eye calibration method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CalibrationMatrixValues Method

CvInvokeCalibrationMatrixValues Method

Computes various useful camera (sensor/lens) characteristics using the computed camera calibration matrix, image frame resolution in pixels and the physical aperture size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalibrationMatrixValues(
    IInputArray cameraMatrix,
    Size imageSize,
    double apertureWidth,
    double apertureHeight,
    ref double fovx,
    ref double fovy,
    ref double focalLength,
    ref MCvPoint2D64f principalPoint,
    ref double aspectRatio
)
Public Shared Sub CalibrationMatrixValues (
    cameraMatrix As IInputArray,
    imageSize As Size,
    apertureWidth As Double,
    apertureHeight As Double,
    ByRef fovx As Double,
    ByRef fovy As Double,
    ByRef focalLength As Double,
    ByRef principalPoint As MCvPoint2D64f,
    ByRef aspectRatio As Double
)
public:
static void CalibrationMatrixValues(
    IInputArray^ cameraMatrix,
    Size^ imageSize,
    double apertureWidth,
    double apertureHeight,
    double% fovx,
    double% fovy,
    double% focalLength,
    MCvPoint2D64f^% principalPoint,
    double% aspectRatio
)
static member CalibrationMatrixValues :
        cameraMatrix : IInputArray *
        imageSize : Size *
        apertureWidth : float *
        apertureHeight : float *
        fovx : float byref *
        fovy : float byref *
        focalLength : float byref *
        principalPoint : MCvPoint2D64f byref *
        aspectRatio : float byref -> unit

Parameters

cameraMatrix
Type: Emgu.CVIInputArray
The matrix of intrinsic parameters
imageSize
Type: System.DrawingSize
Image size in pixels
apertureWidth
Type: SystemDouble
Aperture width in real-world units (optional input parameter). Set it to 0 if not used
apertureHeight
Type: SystemDouble
Aperture width in real-world units (optional input parameter). Set it to 0 if not used
fovx
Type: SystemDouble
Field of view angle in x direction in degrees
fovy
Type: SystemDouble
Field of view angle in y direction in degrees
focalLength
Type: SystemDouble
Focal length in real-world units
principalPoint
Type: Emgu.CV.StructureMCvPoint2D64f
The principal point in real-world units
aspectRatio
Type: SystemDouble
The pixel aspect ratio ~ fy/f
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CamShift Method

CvInvokeCamShift Method

Implements CAMSHIFT object tracking algorithm ([Bradski98]). First, it finds an object center using cvMeanShift and, after that, calculates the object size and orientation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotatedRect CamShift(
    IInputArray probImage,
    ref Rectangle window,
    MCvTermCriteria criteria
)
Public Shared Function CamShift (
    probImage As IInputArray,
    ByRef window As Rectangle,
    criteria As MCvTermCriteria
) As RotatedRect
public:
static RotatedRect^ CamShift(
    IInputArray^ probImage,
    Rectangle^% window,
    MCvTermCriteria^ criteria
)
static member CamShift :
        probImage : IInputArray *
        window : Rectangle byref *
        criteria : MCvTermCriteria -> RotatedRect

Parameters

probImage
Type: Emgu.CVIInputArray
Back projection of object histogram
window
Type: System.DrawingRectangle
Initial search window
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Criteria applied to determine when the window search should be finished

Return Value

Type: RotatedRect
Circumscribed box for the object, contains object size and orientation
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Canny Method

CvInvokeCanny Method

Overload List
Name | Description
Canny(IInputArray, IInputArray, IOutputArray, Double, Double, Boolean) | Finds the edges on the input dx, dy and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.
Canny(IInputArray, IOutputArray, Double, Double, Int32, Boolean) | Finds the edges on the input image and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Canny Method (IInputArray, IInputArray, IOutputArray, Double, Double, Boolean)

CvInvokeCanny Method (IInputArray, IInputArray, IOutputArray, Double, Double, Boolean)

http://www.emgu.com
Finds the edges on the input dx, dy and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Canny(
    IInputArray dx,
    IInputArray dy,
    IOutputArray edges,
    double threshold1,
    double threshold2,
    bool l2Gradient = false
)
Public Shared Sub Canny (
    dx As IInputArray,
    dy As IInputArray,
    edges As IOutputArray,
    threshold1 As Double,
    threshold2 As Double,
    Optional l2Gradient As Boolean = false
)
public:
static void Canny(
    IInputArray^ dx,
    IInputArray^ dy,
    IOutputArray^ edges,
    double threshold1,
    double threshold2,
    bool l2Gradient = false
)
static member Canny :
        dx : IInputArray *
        dy : IInputArray *
        edges : IOutputArray *
        threshold1 : float *
        threshold2 : float *
        ?l2Gradient : bool
(* Defaults:
        let _l2Gradient = defaultArg l2Gradient false
*)
-> unit

Parameters

dx
Type: Emgu.CVIInputArray
16-bit x derivative of input image
dy
Type: Emgu.CVIInputArray
16-bit y derivative of input image
edges
Type: Emgu.CVIOutputArray
Image to store the edges found by the function
threshold1
Type: SystemDouble
The first threshold
threshold2
Type: SystemDouble
The second threshold.
l2Gradient (Optional)
Type: SystemBoolean
a flag, indicating whether a more accurate norm should be used to calculate the image gradient magnitude ( L2gradient=true ), or whether the default norm is enough ( L2gradient=false ).
See Also

Reference

CvInvoke Class
Canny Overload
Emgu.CV Namespace


CvInvoke.Canny Method (IInputArray, IOutputArray, Double, Double, Int32, Boolean)

CvInvokeCanny Method (IInputArray, IOutputArray, Double, Double, Int32, Boolean)

http://www.emgu.com
Finds the edges on the input image and marks them in the output image edges using the Canny algorithm. The smallest of threshold1 and threshold2 is used for edge linking, the largest - to find initial segments of strong edges.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Canny(
    IInputArray image,
    IOutputArray edges,
    double threshold1,
    double threshold2,
    int apertureSize = 3,
    bool l2Gradient = false
)
Public Shared Sub Canny (
    image As IInputArray,
    edges As IOutputArray,
    threshold1 As Double,
    threshold2 As Double,
    Optional apertureSize As Integer = 3,
    Optional l2Gradient As Boolean = false
)
public:
static void Canny(
    IInputArray^ image,
    IOutputArray^ edges,
    double threshold1,
    double threshold2,
    int apertureSize = 3,
    bool l2Gradient = false
)
static member Canny :
        image : IInputArray *
        edges : IOutputArray *
        threshold1 : float *
        threshold2 : float *
        ?apertureSize : int *
        ?l2Gradient : bool
(* Defaults:
        let _apertureSize = defaultArg apertureSize 3
        let _l2Gradient = defaultArg l2Gradient false
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Input image
edges
Type: Emgu.CVIOutputArray
Image to store the edges found by the function
threshold1
Type: SystemDouble
The first threshold
threshold2
Type: SystemDouble
The second threshold.
apertureSize (Optional)
Type: SystemInt32
Aperture parameter for Sobel operator
l2Gradient (Optional)
Type: SystemBoolean
a flag, indicating whether a more accurate norm should be used to calculate the image gradient magnitude ( L2gradient=true ), or whether the default norm is enough ( L2gradient=false ).
See Also

Reference

CvInvoke Class
Canny Overload
Emgu.CV Namespace


CvInvoke.CartToPolar Method

CvInvokeCartToPolar Method

Calculates the magnitude and angle of 2D vectors. magnitude(I)=sqrt( x(I)^2+y(I)^2 ), angle(I)=atan2( y(I)/x(I) ) The angles are calculated with accuracy about 0.3 degrees. For the point (0,0), the angle is set to 0.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CartToPolar(
    IInputArray x,
    IInputArray y,
    IOutputArray magnitude,
    IOutputArray angle,
    bool angleInDegrees = false
)
Public Shared Sub CartToPolar (
    x As IInputArray,
    y As IInputArray,
    magnitude As IOutputArray,
    angle As IOutputArray,
    Optional angleInDegrees As Boolean = false
)
public:
static void CartToPolar(
    IInputArray^ x,
    IInputArray^ y,
    IOutputArray^ magnitude,
    IOutputArray^ angle,
    bool angleInDegrees = false
)
static member CartToPolar :
        x : IInputArray *
        y : IInputArray *
        magnitude : IOutputArray *
        angle : IOutputArray *
        ?angleInDegrees : bool
(* Defaults:
        let _angleInDegrees = defaultArg angleInDegrees false
*)
-> unit

Parameters

x
Type: Emgu.CVIInputArray
Array of x-coordinates; this must be a single-precision or double-precision floating-point array.
y
Type: Emgu.CVIInputArray
Array of y-coordinates, that must have the same size and same type as x.
magnitude
Type: Emgu.CVIOutputArray
Output array of magnitudes of the same size and type as x.
angle
Type: Emgu.CVIOutputArray
Output array of angles that has the same size and type as x; the angles are measured in radians (from 0 to 2*Pi) or in degrees (0 to 360 degrees).
angleInDegrees (Optional)
Type: SystemBoolean
A flag, indicating whether the angles are measured in radians (which is by default), or in degrees.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CheckLibraryLoaded Method

CvInvokeCheckLibraryLoaded Method

Check to make sure all the unmanaged libraries are loaded

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool CheckLibraryLoaded()
Public Shared Function CheckLibraryLoaded As Boolean
public:
static bool CheckLibraryLoaded()
static member CheckLibraryLoaded : unit -> bool

Return Value

Type: Boolean
True if library loaded
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CheckRange Method

CvInvokeCheckRange Method

Check that every array element is neither NaN nor +- inf. The functions also check that each value is between minVal and maxVal. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions either return false (when quiet=true) or throw an exception.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool CheckRange(
    IInputArray arr,
    bool quiet,
    ref Point pos,
    double minVal,
    double maxVal
)
Public Shared Function CheckRange (
    arr As IInputArray,
    quiet As Boolean,
    ByRef pos As Point,
    minVal As Double,
    maxVal As Double
) As Boolean
public:
static bool CheckRange(
    IInputArray^ arr,
    bool quiet,
    Point^% pos,
    double minVal,
    double maxVal
)
static member CheckRange :
        arr : IInputArray *
        quiet : bool *
        pos : Point byref *
        minVal : float *
        maxVal : float -> bool

Parameters

arr
Type: Emgu.CVIInputArray
The array to check
quiet
Type: SystemBoolean
The flag indicating whether the functions quietly return false when the array elements are out of range, or they throw an exception
pos
Type: System.DrawingPoint
This will be filled with the position of the first outlier
minVal
Type: SystemDouble
The inclusive lower boundary of valid values range
maxVal
Type: SystemDouble
The exclusive upper boundary of valid values range

Return Value

Type: Boolean
If quiet, return true if all values are in range
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Circle Method

CvInvokeCircle Method

Draws a simple or filled circle with given center and radius. The circle is clipped by ROI rectangle.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Circle(
    IInputOutputArray img,
    Point center,
    int radius,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub Circle (
    img As IInputOutputArray,
    center As Point,
    radius As Integer,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void Circle(
    IInputOutputArray^ img,
    Point^ center,
    int radius,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
static member Circle :
        img : IInputOutputArray *
        center : Point *
        radius : int *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image where the circle is drawn
center
Type: System.DrawingPoint
Center of the circle
radius
Type: SystemInt32
Radius of the circle.
color
Type: Emgu.CV.StructureMCvScalar
Color of the circle
thickness (Optional)
Type: SystemInt32
Thickness of the circle outline if positive, otherwise indicates that a filled circle has to be drawn
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CLAHE Method

CvInvokeCLAHE Method

Contrast Limited Adaptive Histogram Equalization (CLAHE)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CLAHE(
    IInputArray src,
    double clipLimit,
    Size tileGridSize,
    IOutputArray dst
)
Public Shared Sub CLAHE (
    src As IInputArray,
    clipLimit As Double,
    tileGridSize As Size,
    dst As IOutputArray
)
public:
static void CLAHE(
    IInputArray^ src,
    double clipLimit,
    Size^ tileGridSize,
    IOutputArray^ dst
)
static member CLAHE :
        src : IInputArray *
        clipLimit : float *
        tileGridSize : Size *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
clipLimit
Type: SystemDouble
Clip Limit, use 40 for default
tileGridSize
Type: System.DrawingSize
Tile grid size, use (8, 8) for default
dst
Type: Emgu.CVIOutputArray
The destination image
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ClipLine Method

CvInvokeClipLine Method

Calculates a part of the line segment which is entirely in the rectangle.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool ClipLine(
    Rectangle rectangle,
    ref Point pt1,
    ref Point pt2
)
Public Shared Function ClipLine (
    rectangle As Rectangle,
    ByRef pt1 As Point,
    ByRef pt2 As Point
) As Boolean
public:
static bool ClipLine(
    Rectangle^ rectangle,
    Point^% pt1,
    Point^% pt2
)
static member ClipLine :
        rectangle : Rectangle *
        pt1 : Point byref *
        pt2 : Point byref -> bool

Parameters

rectangle
Type: System.DrawingRectangle
The rectangle
pt1
Type: System.DrawingPoint
First ending point of the line segment. It is modified by the function
pt2
Type: System.DrawingPoint
Second ending point of the line segment. It is modified by the function.

Return Value

Type: Boolean
It returns false if the line segment is completely outside the rectangle and true otherwise.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ColorChange Method

CvInvokeColorChange Method

Given an original color image, two differently colored versions of this image can be mixed seamlessly.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ColorChange(
    IInputArray src,
    IInputArray mask,
    IOutputArray dst,
    float redMul = 1f,
    float greenMul = 1f,
    float blueMul = 1f
)
Public Shared Sub ColorChange (
    src As IInputArray,
    mask As IInputArray,
    dst As IOutputArray,
    Optional redMul As Single = 1F,
    Optional greenMul As Single = 1F,
    Optional blueMul As Single = 1F
)
public:
static void ColorChange(
    IInputArray^ src,
    IInputArray^ mask,
    IOutputArray^ dst,
    float redMul = 1f,
    float greenMul = 1f,
    float blueMul = 1f
)
static member ColorChange :
        src : IInputArray *
        mask : IInputArray *
        dst : IOutputArray *
        ?redMul : float32 *
        ?greenMul : float32 *
        ?blueMul : float32
(* Defaults:
        let _redMul = defaultArg redMul 1f
        let _greenMul = defaultArg greenMul 1f
        let _blueMul = defaultArg blueMul 1f
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image.
mask
Type: Emgu.CVIInputArray
Input 8-bit 1 or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src .
redMul (Optional)
Type: SystemSingle
R-channel multiply factor. Multiplication factor is between .5 to 2.5.
greenMul (Optional)
Type: SystemSingle
G-channel multiply factor. Multiplication factor is between .5 to 2.5.
blueMul (Optional)
Type: SystemSingle
B-channel multiply factor. Multiplication factor is between .5 to 2.5.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Compare Method

CvInvokeCompare Method

Compares the corresponding elements of two arrays and fills the destination mask array: dst(I)=src1(I) op src2(I), dst(I) is set to 0xff (all '1'-bits) if the particular relation between the elements is true and 0 otherwise. All the arrays must have the same type, except the destination, and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Compare(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    CmpType cmpOp
)
Public Shared Sub Compare (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    cmpOp As CmpType
)
public:
static void Compare(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    CmpType^ cmpOp
)
static member Compare :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        cmpOp : CmpType -> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first image to compare with
src2
Type: Emgu.CVIInputArray
The second image to compare with
dst
Type: Emgu.CVIOutputArray
dst(I) is set to 0xff (all '1'-bits) if the particular relation between the elements is true and 0 otherwise.
cmpOp
Type: Emgu.CV.CvEnumCmpType
The comparison operator type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CompareHist Method

CvInvokeCompareHist Method

Compares two histograms.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CompareHist(
    IInputArray h1,
    IInputArray h2,
    HistogramCompMethod method
)
Public Shared Function CompareHist (
    h1 As IInputArray,
    h2 As IInputArray,
    method As HistogramCompMethod
) As Double
public:
static double CompareHist(
    IInputArray^ h1,
    IInputArray^ h2,
    HistogramCompMethod^ method
)
static member CompareHist :
        h1 : IInputArray *
        h2 : IInputArray *
        method : HistogramCompMethod -> float

Parameters

h1
Type: Emgu.CVIInputArray
First compared histogram.
h2
Type: Emgu.CVIInputArray
Second compared histogram of the same size as H1 .
method
Type: Emgu.CV.CvEnumHistogramCompMethod
Comparison method

Return Value

Type: Double
The distance between the histogram
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Compute Method

CvInvokeCompute Method

Computes disparity map for the specified stereo pair

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Compute(
    this IStereoMatcher matcher,
    IInputArray left,
    IInputArray right,
    IOutputArray disparity
)
<ExtensionAttribute>
Public Shared Sub Compute (
    matcher As IStereoMatcher,
    left As IInputArray,
    right As IInputArray,
    disparity As IOutputArray
)
public:
[ExtensionAttribute]
static void Compute(
    IStereoMatcher^ matcher,
    IInputArray^ left,
    IInputArray^ right,
    IOutputArray^ disparity
)
[<ExtensionAttribute>]
static member Compute :
        matcher : IStereoMatcher *
        left : IInputArray *
        right : IInputArray *
        disparity : IOutputArray -> unit

Parameters

matcher
Type: Emgu.CVIStereoMatcher
The stereo matcher
left
Type: Emgu.CVIInputArray
Left 8-bit single-channel image.
right
Type: Emgu.CVIInputArray
Right image of the same size and the same type as the left one.
disparity
Type: Emgu.CVIOutputArray
Output disparity map. It has the same size as the input images. Some algorithms, like StereoBM or StereoSGBM compute 16-bit fixed-point disparity map (where each disparity value has 4 fractional bits), whereas other algorithms output 32-bit floating-point disparity map

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IStereoMatcher. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ComputeCorrespondEpilines Method

CvInvokeComputeCorrespondEpilines Method

For every point in one of the two images of stereo-pair the function cvComputeCorrespondEpilines finds equation of a line that contains the corresponding point (i.e. projection of the same 3D point) in the other image. Each line is encoded by a vector of 3 elements l=[a,b,c]^T, so that: l^T*[x, y, 1]^T=0, or a*x + b*y + c = 0 From the fundamental matrix definition (see cvFindFundamentalMatrix discussion), line l2 for a point p1 in the first image (which_image=1) can be computed as: l2=F*p1 and the line l1 for a point p2 in the second image (which_image=1) can be computed as: l1=F^T*p2Line coefficients are defined up to a scale. They are normalized (a2+b2=1) are stored into correspondent_lines

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ComputeCorrespondEpilines(
    IInputArray points,
    int whichImage,
    IInputArray fundamentalMatrix,
    IOutputArray correspondentLines
)
Public Shared Sub ComputeCorrespondEpilines (
    points As IInputArray,
    whichImage As Integer,
    fundamentalMatrix As IInputArray,
    correspondentLines As IOutputArray
)
public:
static void ComputeCorrespondEpilines(
    IInputArray^ points,
    int whichImage,
    IInputArray^ fundamentalMatrix,
    IOutputArray^ correspondentLines
)
static member ComputeCorrespondEpilines :
        points : IInputArray *
        whichImage : int *
        fundamentalMatrix : IInputArray *
        correspondentLines : IOutputArray -> unit

Parameters

points
Type: Emgu.CVIInputArray
The input points. 2xN, Nx2, 3xN or Nx3 array (where N number of points). Multi-channel 1xN or Nx1 array is also acceptable.
whichImage
Type: SystemInt32
Index of the image (1 or 2) that contains the points
fundamentalMatrix
Type: Emgu.CVIInputArray
Fundamental matrix
correspondentLines
Type: Emgu.CVIOutputArray
Computed epilines, 3xN or Nx3 array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConnectedComponents Method

CvInvokeConnectedComponents Method

Computes the connected components labeled image of boolean image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int ConnectedComponents(
    IInputArray image,
    IOutputArray labels,
    LineType connectivity = 8,
    DepthType labelType = 4
)
Public Shared Function ConnectedComponents (
    image As IInputArray,
    labels As IOutputArray,
    Optional connectivity As LineType = 8,
    Optional labelType As DepthType = 4
) As Integer
public:
static int ConnectedComponents(
    IInputArray^ image,
    IOutputArray^ labels,
    LineType^ connectivity = 8,
    DepthType^ labelType = 4
)
static member ConnectedComponents :
        image : IInputArray *
        labels : IOutputArray *
        ?connectivity : LineType *
        ?labelType : DepthType
(* Defaults:
        let _connectivity = defaultArg connectivity 8
        let _labelType = defaultArg labelType 4
*)
-> int

Parameters

image
Type: Emgu.CVIInputArray
The boolean image
labels
Type: Emgu.CVIOutputArray
The connected components labeled image of boolean image
connectivity (Optional)
Type: Emgu.CV.CvEnumLineType
4 or 8 way connectivity
labelType (Optional)
Type: Emgu.CV.CvEnumDepthType
Specifies the output label image type, an important consideration based on the total number of labels or alternatively the total number of pixels in the source image

Return Value

Type: Int32
N, the total number of labels [0, N-1] where 0 represents the background label.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConnectedComponentsWithStats Method

CvInvokeConnectedComponentsWithStats Method

Computes the connected components labeled image of boolean image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int ConnectedComponentsWithStats(
    IInputArray image,
    IOutputArray labels,
    IOutputArray stats,
    IOutputArray centroids,
    LineType connectivity = 8,
    DepthType labelType = 4
)
Public Shared Function ConnectedComponentsWithStats (
    image As IInputArray,
    labels As IOutputArray,
    stats As IOutputArray,
    centroids As IOutputArray,
    Optional connectivity As LineType = 8,
    Optional labelType As DepthType = 4
) As Integer
public:
static int ConnectedComponentsWithStats(
    IInputArray^ image,
    IOutputArray^ labels,
    IOutputArray^ stats,
    IOutputArray^ centroids,
    LineType^ connectivity = 8,
    DepthType^ labelType = 4
)
static member ConnectedComponentsWithStats :
        image : IInputArray *
        labels : IOutputArray *
        stats : IOutputArray *
        centroids : IOutputArray *
        ?connectivity : LineType *
        ?labelType : DepthType
(* Defaults:
        let _connectivity = defaultArg connectivity 8
        let _labelType = defaultArg labelType 4
*)
-> int

Parameters

image
Type: Emgu.CVIInputArray
The boolean image
labels
Type: Emgu.CVIOutputArray
The connected components labeled image of boolean image
stats
Type: Emgu.CVIOutputArray
Statistics output for each label, including the background label, see below for available statistics. Statistics are accessed via stats(label, COLUMN) where COLUMN is one of cv::ConnectedComponentsTypes. The data type is CV_32S
centroids
Type: Emgu.CVIOutputArray
Centroid output for each label, including the background label. Centroids are accessed via centroids(label, 0) for x and centroids(label, 1) for y. The data type CV_64F.
connectivity (Optional)
Type: Emgu.CV.CvEnumLineType
4 or 8 way connectivity
labelType (Optional)
Type: Emgu.CV.CvEnumDepthType
Specifies the output label image type, an important consideration based on the total number of labels or alternatively the total number of pixels in the source image

Return Value

Type: Int32
N, the total number of labels [0, N-1] where 0 represents the background label.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ContourArea Method

CvInvokeContourArea Method

Calculates area of the whole contour or contour section.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double ContourArea(
    IInputArray contour,
    bool oriented = false
)
Public Shared Function ContourArea (
    contour As IInputArray,
    Optional oriented As Boolean = false
) As Double
public:
static double ContourArea(
    IInputArray^ contour,
    bool oriented = false
)
static member ContourArea :
        contour : IInputArray *
        ?oriented : bool
(* Defaults:
        let _oriented = defaultArg oriented false
*)
-> float

Parameters

contour
Type: Emgu.CVIInputArray
Input vector of 2D points (contour vertices), stored in std::vector or Mat.
oriented (Optional)
Type: SystemBoolean
Oriented area flag. If it is true, the function returns a signed area value, depending on the contour orientation (clockwise or counter-clockwise). Using this feature you can determine orientation of a contour by taking the sign of an area. By default, the parameter is false, which means that the absolute value is returned.

Return Value

Type: Double
The area of the whole contour or contour section
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConvertMaps Method

CvInvokeConvertMaps Method

Converts image transformation maps from one representation to another.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ConvertMaps(
    IInputArray map1,
    IInputArray map2,
    IOutputArray dstmap1,
    IOutputArray dstmap2,
    DepthType dstmap1Depth,
    int dstmap1Channels,
    bool nninterpolation = false
)
Public Shared Sub ConvertMaps (
    map1 As IInputArray,
    map2 As IInputArray,
    dstmap1 As IOutputArray,
    dstmap2 As IOutputArray,
    dstmap1Depth As DepthType,
    dstmap1Channels As Integer,
    Optional nninterpolation As Boolean = false
)
public:
static void ConvertMaps(
    IInputArray^ map1,
    IInputArray^ map2,
    IOutputArray^ dstmap1,
    IOutputArray^ dstmap2,
    DepthType^ dstmap1Depth,
    int dstmap1Channels,
    bool nninterpolation = false
)
static member ConvertMaps :
        map1 : IInputArray *
        map2 : IInputArray *
        dstmap1 : IOutputArray *
        dstmap2 : IOutputArray *
        dstmap1Depth : DepthType *
        dstmap1Channels : int *
        ?nninterpolation : bool
(* Defaults:
        let _nninterpolation = defaultArg nninterpolation false
*)
-> unit

Parameters

map1
Type: Emgu.CVIInputArray
The first input map of type CV_16SC2 , CV_32FC1 , or CV_32FC2 .
map2
Type: Emgu.CVIInputArray
The second input map of type CV_16UC1 , CV_32FC1 , or none (empty matrix), respectively.
dstmap1
Type: Emgu.CVIOutputArray
The first output map that has the type dstmap1type and the same size as src .
dstmap2
Type: Emgu.CVIOutputArray
The second output map.
dstmap1Depth
Type: Emgu.CV.CvEnumDepthType
Depth type of the first output map that should be CV_16SC2 , CV_32FC1 , or CV_32FC2.
dstmap1Channels
Type: SystemInt32
The number of channels in the dst map.
nninterpolation (Optional)
Type: SystemBoolean
Flag indicating whether the fixed-point maps are used for the nearest-neighbor or for a more complex interpolation.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConvertPointsFromHomogeneous Method

CvInvokeConvertPointsFromHomogeneous Method

Converts points from homogeneous to Euclidean space.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ConvertPointsFromHomogeneous(
    IInputArray src,
    IOutputArray dst
)
Public Shared Sub ConvertPointsFromHomogeneous (
    src As IInputArray,
    dst As IOutputArray
)
public:
static void ConvertPointsFromHomogeneous(
    IInputArray^ src,
    IOutputArray^ dst
)
static member ConvertPointsFromHomogeneous :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input vector of N-dimensional points.
dst
Type: Emgu.CVIOutputArray
Output vector of N-1-dimensional points.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConvertPointsToHomogeneous Method

CvInvokeConvertPointsToHomogeneous Method

Converts points from Euclidean to homogeneous space.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ConvertPointsToHomogeneous(
    IInputArray src,
    IOutputArray dst
)
Public Shared Sub ConvertPointsToHomogeneous (
    src As IInputArray,
    dst As IOutputArray
)
public:
static void ConvertPointsToHomogeneous(
    IInputArray^ src,
    IOutputArray^ dst
)
static member ConvertPointsToHomogeneous :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input vector of N-dimensional points.
dst
Type: Emgu.CVIOutputArray
Output vector of N+1-dimensional points.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConvertScaleAbs Method

CvInvokeConvertScaleAbs Method

Similar to cvCvtScale but it stores absolute values of the conversion results: dst(I)=abs(src(I)*scale + (shift,shift,...)) The function supports only destination arrays of 8u (8-bit unsigned integers) type, for other types the function can be emulated by combination of cvConvertScale and cvAbs functions.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ConvertScaleAbs(
    IInputArray src,
    IOutputArray dst,
    double scale,
    double shift
)
Public Shared Sub ConvertScaleAbs (
    src As IInputArray,
    dst As IOutputArray,
    scale As Double,
    shift As Double
)
public:
static void ConvertScaleAbs(
    IInputArray^ src,
    IOutputArray^ dst,
    double scale,
    double shift
)
static member ConvertScaleAbs :
        src : IInputArray *
        dst : IOutputArray *
        scale : float *
        shift : float -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source array
dst
Type: Emgu.CVIOutputArray
Destination array (should have 8u depth).
scale
Type: SystemDouble
ScaleAbs factor
shift
Type: SystemDouble
Value added to the scaled source array elements
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConvexHull Method

CvInvokeConvexHull Method

Overload List
Name | Description
ConvexHull(PointF, Boolean) | Finds convex hull of 2D point set using Sklansky's algorithm
ConvexHull(IInputArray, IOutputArray, Boolean, Boolean) | The function cvConvexHull2 finds convex hull of 2D point set using Sklansky's algorithm.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ConvexHull Method (PointF[], Boolean)

CvInvokeConvexHull Method (PointF, Boolean)

http://www.emgu.com
Finds convex hull of 2D point set using Sklansky's algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static PointF[] ConvexHull(
    PointF[] points,
    bool clockwise = false
)
Public Shared Function ConvexHull (
    points As PointF(),
    Optional clockwise As Boolean = false
) As PointF()
public:
static array<PointF^>^ ConvexHull(
    array<PointF^>^ points,
    bool clockwise = false
)
static member ConvexHull :
        points : PointF[] *
        ?clockwise : bool
(* Defaults:
        let _clockwise = defaultArg clockwise false
*)
-> PointF[]

Parameters

points
Type: System.DrawingPointF
The points to find convex hull from
clockwise (Optional)
Type: SystemBoolean
Orientation flag. If it is true, the output convex hull is oriented clockwise. Otherwise, it is oriented counter-clockwise. The assumed coordinate system has its X axis pointing to the right, and its Y axis pointing upwards.

Return Value

Type: PointF
The convex hull of the points
See Also

Reference

CvInvoke Class
ConvexHull Overload
Emgu.CV Namespace


CvInvoke.ConvexHull Method (IInputArray, IOutputArray, Boolean, Boolean)

CvInvokeConvexHull Method (IInputArray, IOutputArray, Boolean, Boolean)

http://www.emgu.com
The function cvConvexHull2 finds convex hull of 2D point set using Sklansky's algorithm.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ConvexHull(
    IInputArray points,
    IOutputArray hull,
    bool clockwise = false,
    bool returnPoints = true
)
Public Shared Sub ConvexHull (
    points As IInputArray,
    hull As IOutputArray,
    Optional clockwise As Boolean = false,
    Optional returnPoints As Boolean = true
)
public:
static void ConvexHull(
    IInputArray^ points,
    IOutputArray^ hull,
    bool clockwise = false,
    bool returnPoints = true
)
static member ConvexHull :
        points : IInputArray *
        hull : IOutputArray *
        ?clockwise : bool *
        ?returnPoints : bool
(* Defaults:
        let _clockwise = defaultArg clockwise false
        let _returnPoints = defaultArg returnPoints true
*)
-> unit

Parameters

points
Type: Emgu.CVIInputArray
Input 2D point set
hull
Type: Emgu.CVIOutputArray
Output convex hull. It is either an integer vector of indices or vector of points. In the first case, the hull elements are 0-based indices of the convex hull points in the original array (since the set of convex hull points is a subset of the original point set). In the second case, hull elements are the convex hull points themselves.
clockwise (Optional)
Type: SystemBoolean
Orientation flag. If it is true, the output convex hull is oriented clockwise. Otherwise, it is oriented counter-clockwise. The assumed coordinate system has its X axis pointing to the right, and its Y axis pointing upwards.
returnPoints (Optional)
Type: SystemBoolean
Operation flag. In case of a matrix, when the flag is true, the function returns convex hull points. Otherwise, it returns indices of the convex hull points. When the output array is std::vector, the flag is ignored, and the output depends on the type of the vector
See Also

Reference

CvInvoke Class
ConvexHull Overload
Emgu.CV Namespace


CvInvoke.ConvexityDefects Method

CvInvokeConvexityDefects Method

Finds the convexity defects of a contour.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ConvexityDefects(
    IInputArray contour,
    IInputArray convexhull,
    IOutputArray convexityDefects
)
Public Shared Sub ConvexityDefects (
    contour As IInputArray,
    convexhull As IInputArray,
    convexityDefects As IOutputArray
)
public:
static void ConvexityDefects(
    IInputArray^ contour,
    IInputArray^ convexhull,
    IOutputArray^ convexityDefects
)
static member ConvexityDefects :
        contour : IInputArray *
        convexhull : IInputArray *
        convexityDefects : IOutputArray -> unit

Parameters

contour
Type: Emgu.CVIInputArray
Input contour
convexhull
Type: Emgu.CVIInputArray
Convex hull obtained using ConvexHull that should contain pointers or indices to the contour points, not the hull points themselves, i.e. return_points parameter in cvConvexHull2 should be 0
convexityDefects
Type: Emgu.CVIOutputArray
The output vector of convexity defects. Each convexity defect is represented as 4-element integer vector (a.k.a. cv::Vec4i): (start_index, end_index, farthest_pt_index, fixpt_depth), where indices are 0-based indices in the original contour of the convexity defect beginning, end and the farthest point, and fixpt_depth is fixed-point approximation (with 8 fractional bits) of the distance between the farthest contour point and the hull. That is, to get the floating-point value of the depth will be fixpt_depth/256.0.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CopyMakeBorder Method

CvInvokeCopyMakeBorder Method

Copies the source 2D array into interior of destination array and makes a border of the specified type around the copied area. The function is useful when one needs to emulate border type that is different from the one embedded into a specific algorithm implementation. For example, morphological functions, as well as most of other filtering functions in OpenCV, internally use replication border type, while the user may need zero border or a border, filled with 1's or 255's

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CopyMakeBorder(
    IInputArray src,
    IOutputArray dst,
    int top,
    int bottom,
    int left,
    int right,
    BorderType bordertype,
    MCvScalar value = null
)
Public Shared Sub CopyMakeBorder (
    src As IInputArray,
    dst As IOutputArray,
    top As Integer,
    bottom As Integer,
    left As Integer,
    right As Integer,
    bordertype As BorderType,
    Optional value As MCvScalar = Nothing
)
public:
static void CopyMakeBorder(
    IInputArray^ src,
    IOutputArray^ dst,
    int top,
    int bottom,
    int left,
    int right,
    BorderType^ bordertype,
    MCvScalar^ value = nullptr
)
static member CopyMakeBorder :
        src : IInputArray *
        dst : IOutputArray *
        top : int *
        bottom : int *
        left : int *
        right : int *
        bordertype : BorderType *
        ?value : MCvScalar
(* Defaults:
        let _value = defaultArg value null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
dst
Type: Emgu.CVIOutputArray
The destination image
top
Type: SystemInt32
Parameter specifying how many pixels in each direction from the source image rectangle to extrapolate.
bottom
Type: SystemInt32
Parameter specifying how many pixels in each direction from the source image rectangle to extrapolate.
left
Type: SystemInt32
Parameter specifying how many pixels in each direction from the source image rectangle to extrapolate.
right
Type: SystemInt32
Parameter specifying how many pixels in each direction from the source image rectangle to extrapolate.
bordertype
Type: Emgu.CV.CvEnumBorderType
Type of the border to create around the copied source image rectangle
value (Optional)
Type: Emgu.CV.StructureMCvScalar
Value of the border pixels if bordertype=CONSTANT
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CornerHarris Method

CvInvokeCornerHarris Method

Runs the Harris edge detector on image. Similarly to cvCornerMinEigenVal and cvCornerEigenValsAndVecs, for each pixel it calculates 2x2 gradient covariation matrix M over block_size x block_size neighborhood. Then, it stores det(M) - k*trace(M)^2 to the destination image. Corners in the image can be found as local maxima of the destination image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CornerHarris(
    IInputArray image,
    IOutputArray harrisResponse,
    int blockSize,
    int apertureSize = 3,
    double k = 0.04,
    BorderType borderType = 4
)
Public Shared Sub CornerHarris (
    image As IInputArray,
    harrisResponse As IOutputArray,
    blockSize As Integer,
    Optional apertureSize As Integer = 3,
    Optional k As Double = 0.04,
    Optional borderType As BorderType = 4
)
public:
static void CornerHarris(
    IInputArray^ image,
    IOutputArray^ harrisResponse,
    int blockSize,
    int apertureSize = 3,
    double k = 0.04,
    BorderType^ borderType = 4
)
static member CornerHarris :
        image : IInputArray *
        harrisResponse : IOutputArray *
        blockSize : int *
        ?apertureSize : int *
        ?k : float *
        ?borderType : BorderType
(* Defaults:
        let _apertureSize = defaultArg apertureSize 3
        let _k = defaultArg k 0.04
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Input image
harrisResponse
Type: Emgu.CVIOutputArray
Image to store the Harris detector responces. Should have the same size as image
blockSize
Type: SystemInt32
Neighborhood size
apertureSize (Optional)
Type: SystemInt32
Aperture parameter for Sobel operator (see cvSobel). format. In the case of floating-point input format this parameter is the number of the fixed float filter used for differencing.
k (Optional)
Type: SystemDouble
Harris detector free parameter.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CornerSubPix Method

CvInvokeCornerSubPix Method

Iterates to find the sub-pixel accurate location of corners, or radial saddle points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CornerSubPix(
    IInputArray image,
    IInputOutputArray corners,
    Size win,
    Size zeroZone,
    MCvTermCriteria criteria
)
Public Shared Sub CornerSubPix (
    image As IInputArray,
    corners As IInputOutputArray,
    win As Size,
    zeroZone As Size,
    criteria As MCvTermCriteria
)
public:
static void CornerSubPix(
    IInputArray^ image,
    IInputOutputArray^ corners,
    Size^ win,
    Size^ zeroZone,
    MCvTermCriteria^ criteria
)
static member CornerSubPix :
        image : IInputArray *
        corners : IInputOutputArray *
        win : Size *
        zeroZone : Size *
        criteria : MCvTermCriteria -> unit

Parameters

image
Type: Emgu.CVIInputArray
Input image
corners
Type: Emgu.CVIInputOutputArray
Initial coordinates of the input corners and refined coordinates on output
win
Type: System.DrawingSize
Half sizes of the search window. For example, if win=(5,5) then 5*2+1 x 5*2+1 = 11 x 11 search window is used
zeroZone
Type: System.DrawingSize
Half size of the dead region in the middle of the search zone over which the summation in formulae below is not done. It is used sometimes to avoid possible singularities of the autocorrelation matrix. The value of (-1,-1) indicates that there is no such size
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Criteria for termination of the iterative process of corner refinement. That is, the process of corner position refinement stops either after certain number of iteration or when a required accuracy is achieved. The criteria may specify either of or both the maximum number of iteration and the required accuracy
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CorrectMatches Method

CvInvokeCorrectMatches Method

Refines coordinates of corresponding points.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CorrectMatches(
    IInputArray f,
    IInputArray points1,
    IInputArray points2,
    IOutputArray newPoints1,
    IOutputArray newPoints2
)
Public Shared Sub CorrectMatches (
    f As IInputArray,
    points1 As IInputArray,
    points2 As IInputArray,
    newPoints1 As IOutputArray,
    newPoints2 As IOutputArray
)
public:
static void CorrectMatches(
    IInputArray^ f,
    IInputArray^ points1,
    IInputArray^ points2,
    IOutputArray^ newPoints1,
    IOutputArray^ newPoints2
)
static member CorrectMatches :
        f : IInputArray *
        points1 : IInputArray *
        points2 : IInputArray *
        newPoints1 : IOutputArray *
        newPoints2 : IOutputArray -> unit

Parameters

f
Type: Emgu.CVIInputArray
3x3 fundamental matrix.
points1
Type: Emgu.CVIInputArray
1xN array containing the first set of points.
points2
Type: Emgu.CVIInputArray
1xN array containing the second set of points.
newPoints1
Type: Emgu.CVIOutputArray
The optimized points1.
newPoints2
Type: Emgu.CVIOutputArray
The optimized points2.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CountNonZero Method

CvInvokeCountNonZero Method

Returns the number of non-zero elements in arr: result = sumI arr(I)!=0 In case of IplImage both ROI and COI are supported.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int CountNonZero(
    IInputArray arr
)
Public Shared Function CountNonZero (
    arr As IInputArray
) As Integer
public:
static int CountNonZero(
    IInputArray^ arr
)
static member CountNonZero :
        arr : IInputArray -> int

Parameters

arr
Type: Emgu.CVIInputArray
The image

Return Value

Type: Int32
the number of non-zero elements in image
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CreateHanningWindow Method

CvInvokeCreateHanningWindow Method

This function computes a Hanning window coefficients in two dimensions.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CreateHanningWindow(
    IOutputArray dst,
    Size winSize,
    DepthType type
)
Public Shared Sub CreateHanningWindow (
    dst As IOutputArray,
    winSize As Size,
    type As DepthType
)
public:
static void CreateHanningWindow(
    IOutputArray^ dst,
    Size^ winSize,
    DepthType^ type
)
static member CreateHanningWindow :
        dst : IOutputArray *
        winSize : Size *
        type : DepthType -> unit

Parameters

dst
Type: Emgu.CVIOutputArray
Destination array to place Hann coefficients in
winSize
Type: System.DrawingSize
The window size specifications
type
Type: Emgu.CV.CvEnumDepthType
Created array type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CvArrToMat Method

CvInvokeCvArrToMat Method

Converts CvMat, IplImage , or CvMatND to Mat.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat CvArrToMat(
    IntPtr arr,
    bool copyData = false,
    bool allowND = true,
    int coiMode = 0
)
Public Shared Function CvArrToMat (
    arr As IntPtr,
    Optional copyData As Boolean = false,
    Optional allowND As Boolean = true,
    Optional coiMode As Integer = 0
) As Mat
public:
static Mat^ CvArrToMat(
    IntPtr arr,
    bool copyData = false,
    bool allowND = true,
    int coiMode = 0
)
static member CvArrToMat :
        arr : IntPtr *
        ?copyData : bool *
        ?allowND : bool *
        ?coiMode : int
(* Defaults:
        let _copyData = defaultArg copyData false
        let _allowND = defaultArg allowND true
        let _coiMode = defaultArg coiMode 0
*)
-> Mat

Parameters

arr
Type: SystemIntPtr
Input CvMat, IplImage , or CvMatND.
copyData (Optional)
Type: SystemBoolean
When false (default value), no data is copied and only the new header is created, in this case, the original array should not be deallocated while the new matrix header is used; if the parameter is true, all the data is copied and you may deallocate the original array right after the conversion.
allowND (Optional)
Type: SystemBoolean
When true (default value), CvMatND is converted to 2-dimensional Mat, if it is possible (see the discussion below); if it is not possible, or when the parameter is false, the function will report an error
coiMode (Optional)
Type: SystemInt32
Parameter specifying how the IplImage COI (when set) is handled. If coiMode=0 and COI is set, the function reports an error. If coiMode=1 , the function never reports an error. Instead, it returns the header to the whole original image and you will have to check and process COI manually.

Return Value

Type: Mat
The Mat header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvCheckArr Method

CvInvokecvCheckArr Method

Checks that every array element is neither NaN nor Infinity. If CV_CHECK_RANGE is set, it also checks that every element is greater than or equal to minVal and less than maxVal.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int cvCheckArr(
    IntPtr arr,
    CheckType flags,
    double minVal,
    double maxVal
)
Public Shared Function cvCheckArr (
    arr As IntPtr,
    flags As CheckType,
    minVal As Double,
    maxVal As Double
) As Integer
public:
static int cvCheckArr(
    IntPtr arr,
    CheckType^ flags,
    double minVal,
    double maxVal
)
static member cvCheckArr :
        arr : IntPtr *
        flags : CheckType *
        minVal : float *
        maxVal : float -> int

Parameters

arr
Type: SystemIntPtr
The array to check.
flags
Type: Emgu.CV.CvEnumCheckType
The operation flags, CHECK_NAN_INFINITY or combination of CHECK_RANGE - if set, the function checks that every value of array is within [minVal,maxVal) range, otherwise it just checks that every element is neither NaN nor Infinity. CHECK_QUIET - if set, the function does not raises an error if an element is invalid or out of range
minVal
Type: SystemDouble
The inclusive lower boundary of valid values range. It is used only if CHECK_RANGE is set.
maxVal
Type: SystemDouble
The exclusive upper boundary of valid values range. It is used only if CHECK_RANGE is set.

Return Value

Type: Int32
Returns nonzero if the check succeeded, i.e. all elements are valid and within the range, and zero otherwise. In the latter case if CV_CHECK_QUIET flag is not set, the function raises runtime error.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvClearND Method

CvInvokecvClearND Method

Clears (sets to zero) the particular element of dense array or deletes the element of sparse array. If the element does not exists, the function does nothing

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvClearND(
    IntPtr arr,
    int[] idx
)
Public Shared Sub cvClearND (
    arr As IntPtr,
    idx As Integer()
)
public:
static void cvClearND(
    IntPtr arr,
    [InAttribute] array<int>^ idx
)
static member cvClearND :
        arr : IntPtr *
        idx : int[] -> unit

Parameters

arr
Type: SystemIntPtr
Input array
idx
Type: SystemInt32
Array of the element indices
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvConvertScale Method

CvInvokecvConvertScale Method

This function has several different purposes and thus has several synonyms. It copies one array to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel arrays are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination array element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate cvConvert synonym. If source and destination array types have equal types, this is also a special case that can be used to scale and shift a matrix or an image and that fits to cvScale synonym.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvConvertScale(
    IntPtr src,
    IntPtr dst,
    double scale,
    double shift
)
Public Shared Sub cvConvertScale (
    src As IntPtr,
    dst As IntPtr,
    scale As Double,
    shift As Double
)
public:
static void cvConvertScale(
    IntPtr src,
    IntPtr dst,
    double scale,
    double shift
)
static member cvConvertScale :
        src : IntPtr *
        dst : IntPtr *
        scale : float *
        shift : float -> unit

Parameters

src
Type: SystemIntPtr
Source array
dst
Type: SystemIntPtr
Destination array
scale
Type: SystemDouble
Scale factor
shift
Type: SystemDouble
Value added to the scaled source array elements
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvCopy Method

CvInvokecvCopy Method

Copies selected elements from input array to output array: dst(I)=src(I) if mask(I)!=0. If any of the passed arrays is of IplImage type, then its ROI and COI fields are used. Both arrays must have the same type, the same number of dimensions and the same size. The function can also copy sparse arrays (mask is not supported in this case).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvCopy(
    IntPtr src,
    IntPtr des,
    IntPtr mask
)
Public Shared Sub cvCopy (
    src As IntPtr,
    des As IntPtr,
    mask As IntPtr
)
public:
static void cvCopy(
    IntPtr src,
    IntPtr des,
    IntPtr mask
)
static member cvCopy :
        src : IntPtr *
        des : IntPtr *
        mask : IntPtr -> unit

Parameters

src
Type: SystemIntPtr
The source array
des
Type: SystemIntPtr
The destination array
mask
Type: SystemIntPtr
Operation mask, 8-bit single channel array; specifies elements of destination array to be changed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvCreateImage Method

CvInvokecvCreateImage Method

Creates the header and allocates data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvCreateImage(
    Size size,
    IplDepth depth,
    int channels
)
Public Shared Function cvCreateImage (
    size As Size,
    depth As IplDepth,
    channels As Integer
) As IntPtr
public:
static IntPtr cvCreateImage(
    Size^ size,
    IplDepth^ depth,
    int channels
)
static member cvCreateImage :
        size : Size *
        depth : IplDepth *
        channels : int -> IntPtr

Parameters

size
Type: System.DrawingSize
Image width and height.
depth
Type: Emgu.CV.CvEnumIplDepth
Bit depth of image elements
channels
Type: SystemInt32
Number of channels per element(pixel). Can be 1, 2, 3 or 4. The channels are interleaved, for example the usual data layout of a color image is: b0 g0 r0 b1 g1 r1 ...

Return Value

Type: IntPtr
A pointer to IplImage
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvCreateImageHeader Method

CvInvokecvCreateImageHeader Method

Allocates, initializes, and returns the structure IplImage.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvCreateImageHeader(
    Size size,
    IplDepth depth,
    int channels
)
Public Shared Function cvCreateImageHeader (
    size As Size,
    depth As IplDepth,
    channels As Integer
) As IntPtr
public:
static IntPtr cvCreateImageHeader(
    Size^ size,
    IplDepth^ depth,
    int channels
)
static member cvCreateImageHeader :
        size : Size *
        depth : IplDepth *
        channels : int -> IntPtr

Parameters

size
Type: System.DrawingSize
Image width and height.
depth
Type: Emgu.CV.CvEnumIplDepth
Bit depth of image elements
channels
Type: SystemInt32
Number of channels per element(pixel). Can be 1, 2, 3 or 4. The channels are interleaved, for example the usual data layout of a color image is: b0 g0 r0 b1 g1 r1 ...

Return Value

Type: IntPtr
The structure IplImage
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvCreateMat Method

CvInvokecvCreateMat Method

Allocates header for the new matrix and underlying data, and returns a pointer to the created matrix. Matrices are stored row by row. All the rows are aligned by 4 bytes.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvCreateMat(
    int rows,
    int cols,
    DepthType type
)
Public Shared Function cvCreateMat (
    rows As Integer,
    cols As Integer,
    type As DepthType
) As IntPtr
public:
static IntPtr cvCreateMat(
    int rows,
    int cols,
    DepthType^ type
)
static member cvCreateMat :
        rows : int *
        cols : int *
        type : DepthType -> IntPtr

Parameters

rows
Type: SystemInt32
Number of rows in the matrix.
cols
Type: SystemInt32
Number of columns in the matrix.
type
Type: Emgu.CV.CvEnumDepthType
Type of the matrix elements.

Return Value

Type: IntPtr
A pointer to the created matrix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvCreateSparseMat Method

CvInvokecvCreateSparseMat Method

The function allocates a multi-dimensional sparse array. Initially the array contain no elements, that is Get or GetReal returns zero for every index

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvCreateSparseMat(
    int dims,
    IntPtr sizes,
    DepthType type
)
Public Shared Function cvCreateSparseMat (
    dims As Integer,
    sizes As IntPtr,
    type As DepthType
) As IntPtr
public:
static IntPtr cvCreateSparseMat(
    int dims,
    IntPtr sizes,
    DepthType^ type
)
static member cvCreateSparseMat :
        dims : int *
        sizes : IntPtr *
        type : DepthType -> IntPtr

Parameters

dims
Type: SystemInt32
Number of array dimensions
sizes
Type: SystemIntPtr
Array of dimension sizes
type
Type: Emgu.CV.CvEnumDepthType
Type of array elements

Return Value

Type: IntPtr
Pointer to the array header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGet1D Method

CvInvokecvGet1D Method

Return the particular array element

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar cvGet1D(
    IntPtr arr,
    int idx0
)
Public Shared Function cvGet1D (
    arr As IntPtr,
    idx0 As Integer
) As MCvScalar
public:
static MCvScalar^ cvGet1D(
    IntPtr arr,
    int idx0
)
static member cvGet1D :
        arr : IntPtr *
        idx0 : int -> MCvScalar

Parameters

arr
Type: SystemIntPtr
Input array. Must have a single channel
idx0
Type: SystemInt32
The first zero-based component of the element index

Return Value

Type: MCvScalar
the particular array element
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGet2D Method

CvInvokecvGet2D Method

Return the particular array element

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar cvGet2D(
    IntPtr arr,
    int idx0,
    int idx1
)
Public Shared Function cvGet2D (
    arr As IntPtr,
    idx0 As Integer,
    idx1 As Integer
) As MCvScalar
public:
static MCvScalar^ cvGet2D(
    IntPtr arr,
    int idx0,
    int idx1
)
static member cvGet2D :
        arr : IntPtr *
        idx0 : int *
        idx1 : int -> MCvScalar

Parameters

arr
Type: SystemIntPtr
Input array. Must have a single channel
idx0
Type: SystemInt32
The first zero-based component of the element index
idx1
Type: SystemInt32
The second zero-based component of the element index

Return Value

Type: MCvScalar
the particular array element
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGet3D Method

CvInvokecvGet3D Method

Return the particular array element

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar cvGet3D(
    IntPtr arr,
    int idx0,
    int idx1,
    int idx2
)
Public Shared Function cvGet3D (
    arr As IntPtr,
    idx0 As Integer,
    idx1 As Integer,
    idx2 As Integer
) As MCvScalar
public:
static MCvScalar^ cvGet3D(
    IntPtr arr,
    int idx0,
    int idx1,
    int idx2
)
static member cvGet3D :
        arr : IntPtr *
        idx0 : int *
        idx1 : int *
        idx2 : int -> MCvScalar

Parameters

arr
Type: SystemIntPtr
Input array. Must have a single channel
idx0
Type: SystemInt32
The first zero-based component of the element index
idx1
Type: SystemInt32
The second zero-based component of the element index
idx2
Type: SystemInt32
The third zero-based component of the element index

Return Value

Type: MCvScalar
the particular array element
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetCol Method

CvInvokecvGetCol Method

Return the header, corresponding to a specified column of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetCol(
    IntPtr arr,
    IntPtr submat,
    int col
)
Public Shared Function cvGetCol (
    arr As IntPtr,
    submat As IntPtr,
    col As Integer
) As IntPtr
public:
static IntPtr cvGetCol(
    IntPtr arr,
    IntPtr submat,
    int col
)
static member cvGetCol :
        arr : IntPtr *
        submat : IntPtr *
        col : int -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
submat
Type: SystemIntPtr
Pointer to the prelocate memory of the resulting sub-array header
col
Type: SystemInt32
Zero-based index of the selected column

Return Value

Type: IntPtr
The header, corresponding to a specified column of the input array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetCols Method

CvInvokecvGetCols Method

Return the header, corresponding to a specified col span of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetCols(
    IntPtr arr,
    IntPtr submat,
    int startCol,
    int endCol
)
Public Shared Function cvGetCols (
    arr As IntPtr,
    submat As IntPtr,
    startCol As Integer,
    endCol As Integer
) As IntPtr
public:
static IntPtr cvGetCols(
    IntPtr arr,
    IntPtr submat,
    int startCol,
    int endCol
)
static member cvGetCols :
        arr : IntPtr *
        submat : IntPtr *
        startCol : int *
        endCol : int -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
submat
Type: SystemIntPtr
Pointer to the prelocated memory of the resulting sub-array header
startCol
Type: SystemInt32
Zero-based index of the selected column
endCol
Type: SystemInt32
Zero-based index of the ending column (exclusive) of the span

Return Value

Type: IntPtr
The header, corresponding to a specified col span of the input array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetDiag Method

CvInvokecvGetDiag Method

returns the header, corresponding to a specified diagonal of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetDiag(
    IntPtr arr,
    IntPtr submat,
    int diag
)
Public Shared Function cvGetDiag (
    arr As IntPtr,
    submat As IntPtr,
    diag As Integer
) As IntPtr
public:
static IntPtr cvGetDiag(
    IntPtr arr,
    IntPtr submat,
    int diag
)
static member cvGetDiag :
        arr : IntPtr *
        submat : IntPtr *
        diag : int -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
submat
Type: SystemIntPtr
Pointer to the resulting sub-array header
diag
Type: SystemInt32
Array diagonal. Zero corresponds to the main diagonal, -1 corresponds to the diagonal above the main etc., 1 corresponds to the diagonal below the main etc

Return Value

Type: IntPtr
Pointer to the resulting sub-array header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetImage Method

CvInvokecvGetImage Method

Returns image header for the input array that can be matrix - CvMat*, or image - IplImage*.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetImage(
    IntPtr arr,
    IntPtr imageHeader
)
Public Shared Function cvGetImage (
    arr As IntPtr,
    imageHeader As IntPtr
) As IntPtr
public:
static IntPtr cvGetImage(
    IntPtr arr,
    IntPtr imageHeader
)
static member cvGetImage :
        arr : IntPtr *
        imageHeader : IntPtr -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array.
imageHeader
Type: SystemIntPtr
Pointer to IplImage structure used as a temporary buffer.

Return Value

Type: IntPtr
Returns image header for the input array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetImageCOI Method

CvInvokecvGetImageCOI Method

Returns channel of interest of the image (it returns 0 if all the channels are selected).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int cvGetImageCOI(
    IntPtr image
)
Public Shared Function cvGetImageCOI (
    image As IntPtr
) As Integer
public:
static int cvGetImageCOI(
    IntPtr image
)
static member cvGetImageCOI :
        image : IntPtr -> int

Parameters

image
Type: SystemIntPtr
Image header.

Return Value

Type: Int32
channel of interest of the image (it returns 0 if all the channels are selected)
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetImageROI Method

CvInvokecvGetImageROI Method

Returns channel of interest of the image (it returns 0 if all the channels are selected).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Rectangle cvGetImageROI(
    IntPtr image
)
Public Shared Function cvGetImageROI (
    image As IntPtr
) As Rectangle
public:
static Rectangle^ cvGetImageROI(
    IntPtr image
)
static member cvGetImageROI :
        image : IntPtr -> Rectangle

Parameters

image
Type: SystemIntPtr
Image header.

Return Value

Type: Rectangle
channel of interest of the image (it returns 0 if all the channels are selected)
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetMat Method

CvInvokecvGetMat Method

Returns matrix header for the input array that can be matrix - CvMat, image - IplImage or multi-dimensional dense array - CvMatND* (latter case is allowed only if allowND != 0) . In the case of matrix the function simply returns the input pointer. In the case of IplImage* or CvMatND* it initializes header structure with parameters of the current image ROI and returns pointer to this temporary structure. Because COI is not supported by CvMat, it is returned separately.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetMat(
    IntPtr arr,
    IntPtr header,
    out int coi,
    int allowNd
)
Public Shared Function cvGetMat (
    arr As IntPtr,
    header As IntPtr,
    <OutAttribute> ByRef coi As Integer,
    allowNd As Integer
) As IntPtr
public:
static IntPtr cvGetMat(
    IntPtr arr,
    IntPtr header,
    [OutAttribute] int% coi,
    int allowNd
)
static member cvGetMat :
        arr : IntPtr *
        header : IntPtr *
        coi : int byref *
        allowNd : int -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
header
Type: SystemIntPtr
Pointer to CvMat structure used as a temporary buffer
coi
Type: SystemInt32
Optional output parameter for storing COI
allowNd
Type: SystemInt32
If non-zero, the function accepts multi-dimensional dense arrays (CvMatND*) and returns 2D (if CvMatND has two dimensions) or 1D matrix (when CvMatND has 1 dimension or more than 2 dimensions). The array must be continuous

Return Value

Type: IntPtr
Returns matrix header for the input array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetRawData Method

CvInvokecvGetRawData Method

Fills output variables with low-level information about the array data. All output parameters are optional, so some of the pointers may be set to NULL. If the array is IplImage with ROI set, parameters of ROI are returned.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvGetRawData(
    IntPtr arr,
    out IntPtr data,
    out int step,
    out Size roiSize
)
Public Shared Sub cvGetRawData (
    arr As IntPtr,
    <OutAttribute> ByRef data As IntPtr,
    <OutAttribute> ByRef step As Integer,
    <OutAttribute> ByRef roiSize As Size
)
public:
static void cvGetRawData(
    IntPtr arr,
    [OutAttribute] IntPtr% data,
    [OutAttribute] int% step,
    [OutAttribute] Size^% roiSize
)
static member cvGetRawData :
        arr : IntPtr *
        data : IntPtr byref *
        step : int byref *
        roiSize : Size byref -> unit

Parameters

arr
Type: SystemIntPtr
Array header
data
Type: SystemIntPtr
Output pointer to the whole image origin or ROI origin if ROI is set
step
Type: SystemInt32
Output full row length in bytes
roiSize
Type: System.DrawingSize
Output ROI size
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetReal1D Method

CvInvokecvGetReal1D Method

Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double cvGetReal1D(
    IntPtr arr,
    int idx0
)
Public Shared Function cvGetReal1D (
    arr As IntPtr,
    idx0 As Integer
) As Double
public:
static double cvGetReal1D(
    IntPtr arr,
    int idx0
)
static member cvGetReal1D :
        arr : IntPtr *
        idx0 : int -> float

Parameters

arr
Type: SystemIntPtr
Input array. Must have a single channel
idx0
Type: SystemInt32
The first zero-based component of the element index

Return Value

Type: Double
the particular element of single-channel array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetReal2D Method

CvInvokecvGetReal2D Method

Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double cvGetReal2D(
    IntPtr arr,
    int idx0,
    int idx1
)
Public Shared Function cvGetReal2D (
    arr As IntPtr,
    idx0 As Integer,
    idx1 As Integer
) As Double
public:
static double cvGetReal2D(
    IntPtr arr,
    int idx0,
    int idx1
)
static member cvGetReal2D :
        arr : IntPtr *
        idx0 : int *
        idx1 : int -> float

Parameters

arr
Type: SystemIntPtr
Input array. Must have a single channel
idx0
Type: SystemInt32
The first zero-based component of the element index
idx1
Type: SystemInt32
The second zero-based component of the element index

Return Value

Type: Double
the particular element of single-channel array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetReal3D Method

CvInvokecvGetReal3D Method

Return the particular element of single-channel array. If the array has multiple channels, runtime error is raised. Note that cvGet*D function can be used safely for both single-channel and multiple-channel arrays though they are a bit slower.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double cvGetReal3D(
    IntPtr arr,
    int idx0,
    int idx1,
    int idx2
)
Public Shared Function cvGetReal3D (
    arr As IntPtr,
    idx0 As Integer,
    idx1 As Integer,
    idx2 As Integer
) As Double
public:
static double cvGetReal3D(
    IntPtr arr,
    int idx0,
    int idx1,
    int idx2
)
static member cvGetReal3D :
        arr : IntPtr *
        idx0 : int *
        idx1 : int *
        idx2 : int -> float

Parameters

arr
Type: SystemIntPtr
Input array. Must have a single channel
idx0
Type: SystemInt32
The first zero-based component of the element index
idx1
Type: SystemInt32
The second zero-based component of the element index
idx2
Type: SystemInt32
The third zero-based component of the element index

Return Value

Type: Double
the particular element of single-channel array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetRow Method

CvInvokecvGetRow Method

Return the header, corresponding to a specified row of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetRow(
    IntPtr arr,
    IntPtr submat,
    int row
)
Public Shared Function cvGetRow (
    arr As IntPtr,
    submat As IntPtr,
    row As Integer
) As IntPtr
public:
static IntPtr cvGetRow(
    IntPtr arr,
    IntPtr submat,
    int row
)
static member cvGetRow :
        arr : IntPtr *
        submat : IntPtr *
        row : int -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
submat
Type: SystemIntPtr
Pointer to the prelocate memory of the resulting sub-array header
row
Type: SystemInt32
Zero-based index of the selected row

Return Value

Type: IntPtr
The header, corresponding to a specified row of the input array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetRows Method

CvInvokecvGetRows Method

Return the header, corresponding to a specified row span of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetRows(
    IntPtr arr,
    IntPtr submat,
    int startRow,
    int endRow,
    int deltaRow
)
Public Shared Function cvGetRows (
    arr As IntPtr,
    submat As IntPtr,
    startRow As Integer,
    endRow As Integer,
    deltaRow As Integer
) As IntPtr
public:
static IntPtr cvGetRows(
    IntPtr arr,
    IntPtr submat,
    int startRow,
    int endRow,
    int deltaRow
)
static member cvGetRows :
        arr : IntPtr *
        submat : IntPtr *
        startRow : int *
        endRow : int *
        deltaRow : int -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
submat
Type: SystemIntPtr
Pointer to the prelocated memory of resulting sub-array header
startRow
Type: SystemInt32
Zero-based index of the starting row (inclusive) of the span
endRow
Type: SystemInt32
Zero-based index of the ending row (exclusive) of the span
deltaRow
Type: SystemInt32
Index step in the row span. That is, the function extracts every delta_row-th row from start_row and up to (but not including) end_row

Return Value

Type: IntPtr
The header, corresponding to a specified row span of the input array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetSize Method

CvInvokecvGetSize Method

Returns number of rows (CvSize::height) and number of columns (CvSize::width) of the input matrix or image. In case of image the size of ROI is returned.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Size cvGetSize(
    IntPtr arr
)
Public Shared Function cvGetSize (
    arr As IntPtr
) As Size
public:
static Size^ cvGetSize(
    IntPtr arr
)
static member cvGetSize :
        arr : IntPtr -> Size

Parameters

arr
Type: SystemIntPtr
array header

Return Value

Type: Size
number of rows (CvSize::height) and number of columns (CvSize::width) of the input matrix or image. In case of image the size of ROI is returned.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvGetSubRect Method

CvInvokecvGetSubRect Method

Returns header, corresponding to a specified rectangle of the input array. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array. ROI is taken into account by the function so the sub-array of ROI is actually extracted.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvGetSubRect(
    IntPtr arr,
    IntPtr submat,
    Rectangle rect
)
Public Shared Function cvGetSubRect (
    arr As IntPtr,
    submat As IntPtr,
    rect As Rectangle
) As IntPtr
public:
static IntPtr cvGetSubRect(
    IntPtr arr,
    IntPtr submat,
    Rectangle^ rect
)
static member cvGetSubRect :
        arr : IntPtr *
        submat : IntPtr *
        rect : Rectangle -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
submat
Type: SystemIntPtr
Pointer to the resultant sub-array header.
rect
Type: System.DrawingRectangle
Zero-based coordinates of the rectangle of interest.

Return Value

Type: IntPtr
the resultant sub-array header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvInitImageHeader Method

CvInvokecvInitImageHeader Method

Initializes the image header structure, pointer to which is passed by the user, and returns the pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvInitImageHeader(
    IntPtr image,
    Size size,
    IplDepth depth,
    int channels,
    int origin,
    int align
)
Public Shared Function cvInitImageHeader (
    image As IntPtr,
    size As Size,
    depth As IplDepth,
    channels As Integer,
    origin As Integer,
    align As Integer
) As IntPtr
public:
static IntPtr cvInitImageHeader(
    IntPtr image,
    Size^ size,
    IplDepth^ depth,
    int channels,
    int origin,
    int align
)
static member cvInitImageHeader :
        image : IntPtr *
        size : Size *
        depth : IplDepth *
        channels : int *
        origin : int *
        align : int -> IntPtr

Parameters

image
Type: SystemIntPtr
Image header to initialize.
size
Type: System.DrawingSize
Image width and height.
depth
Type: Emgu.CV.CvEnumIplDepth
Image depth
channels
Type: SystemInt32
Number of channels
origin
Type: SystemInt32
IPL_ORIGIN_TL or IPL_ORIGIN_BL.
align
Type: SystemInt32
Alignment for image rows, typically 4 or 8 bytes.

Return Value

Type: IntPtr
Pointer to the image header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvInitMatHeader Method

CvInvokecvInitMatHeader Method

Initializes already allocated CvMat structure. It can be used to process raw data with OpenCV matrix functions.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvInitMatHeader(
    IntPtr mat,
    int rows,
    int cols,
    int type,
    IntPtr data,
    int step
)
Public Shared Function cvInitMatHeader (
    mat As IntPtr,
    rows As Integer,
    cols As Integer,
    type As Integer,
    data As IntPtr,
    step As Integer
) As IntPtr
public:
static IntPtr cvInitMatHeader(
    IntPtr mat,
    int rows,
    int cols,
    int type,
    IntPtr data,
    int step
)
static member cvInitMatHeader :
        mat : IntPtr *
        rows : int *
        cols : int *
        type : int *
        data : IntPtr *
        step : int -> IntPtr

Parameters

mat
Type: SystemIntPtr
Pointer to the matrix header to be initialized.
rows
Type: SystemInt32
Number of rows in the matrix.
cols
Type: SystemInt32
Number of columns in the matrix.
type
Type: SystemInt32
Type of the matrix elements.
data
Type: SystemIntPtr
Optional data pointer assigned to the matrix header
step
Type: SystemInt32
Full row width in bytes of the data assigned. By default, the minimal possible step is used, i.e., no gaps is assumed between subsequent rows of the matrix.

Return Value

Type: IntPtr
Pointer to the CvMat
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvInitMatNDHeader Method

CvInvokecvInitMatNDHeader Method

Initializes CvMatND structure allocated by the user

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvInitMatNDHeader(
    IntPtr mat,
    int dims,
    int[] sizes,
    DepthType type,
    IntPtr data
)
Public Shared Function cvInitMatNDHeader (
    mat As IntPtr,
    dims As Integer,
    sizes As Integer(),
    type As DepthType,
    data As IntPtr
) As IntPtr
public:
static IntPtr cvInitMatNDHeader(
    IntPtr mat,
    int dims,
    [InAttribute] array<int>^ sizes,
    DepthType^ type,
    IntPtr data
)
static member cvInitMatNDHeader :
        mat : IntPtr *
        dims : int *
        sizes : int[] *
        type : DepthType *
        data : IntPtr -> IntPtr

Parameters

mat
Type: SystemIntPtr
Pointer to the array header to be initialized
dims
Type: SystemInt32
Number of array dimensions
sizes
Type: SystemInt32
Array of dimension sizes
type
Type: Emgu.CV.CvEnumDepthType
Type of array elements
data
Type: SystemIntPtr
Optional data pointer assigned to the matrix header

Return Value

Type: IntPtr
Pointer to the array header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvMaxRect Method

CvInvokecvMaxRect Method

Finds minimum area rectangle that contains both input rectangles inside

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Rectangle cvMaxRect(
    Rectangle rect1,
    Rectangle rect2
)
Public Shared Function cvMaxRect (
    rect1 As Rectangle,
    rect2 As Rectangle
) As Rectangle
public:
static Rectangle^ cvMaxRect(
    Rectangle^ rect1,
    Rectangle^ rect2
)
static member cvMaxRect :
        rect1 : Rectangle *
        rect2 : Rectangle -> Rectangle

Parameters

rect1
Type: System.DrawingRectangle
First rectangle
rect2
Type: System.DrawingRectangle
Second rectangle

Return Value

Type: Rectangle
The minimum area rectangle that contains both input rectangles inside
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvRange Method

CvInvokecvRange Method

Initializes the matrix as following: arr(i,j)=(end-start)*(i*cols(arr)+j)/(cols(arr)*rows(arr))

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvRange(
    IntPtr mat,
    double start,
    double end
)
Public Shared Sub cvRange (
    mat As IntPtr,
    start As Double,
    end As Double
)
public:
static void cvRange(
    IntPtr mat,
    double start,
    double end
)
static member cvRange :
        mat : IntPtr *
        start : float *
        end : float -> unit

Parameters

mat
Type: SystemIntPtr
The matrix to initialize. It should be single-channel 32-bit, integer or floating-point
start
Type: SystemDouble
The lower inclusive boundary of the range
end
Type: SystemDouble
The upper exclusive boundary of the range
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvReleaseImage Method

CvInvokecvReleaseImage Method

Releases the header and the image data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvReleaseImage(
    ref IntPtr image
)
Public Shared Sub cvReleaseImage (
    ByRef image As IntPtr
)
public:
static void cvReleaseImage(
    IntPtr% image
)
static member cvReleaseImage :
        image : IntPtr byref -> unit

Parameters

image
Type: SystemIntPtr
Double pointer to the header of the deallocated image
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvReleaseImageHeader Method

CvInvokecvReleaseImageHeader Method

Releases the header.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvReleaseImageHeader(
    ref IntPtr image
)
Public Shared Sub cvReleaseImageHeader (
    ByRef image As IntPtr
)
public:
static void cvReleaseImageHeader(
    IntPtr% image
)
static member cvReleaseImageHeader :
        image : IntPtr byref -> unit

Parameters

image
Type: SystemIntPtr
Pointer to the deallocated header.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvReleaseMat Method

CvInvokecvReleaseMat Method

Decrements the matrix data reference counter and releases matrix header

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvReleaseMat(
    ref IntPtr mat
)
Public Shared Sub cvReleaseMat (
    ByRef mat As IntPtr
)
public:
static void cvReleaseMat(
    IntPtr% mat
)
static member cvReleaseMat :
        mat : IntPtr byref -> unit

Parameters

mat
Type: SystemIntPtr
Double pointer to the matrix.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvReleaseSparseMat Method

CvInvokecvReleaseSparseMat Method

The function releases the sparse array and clears the array pointer upon exit.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvReleaseSparseMat(
    ref IntPtr mat
)
Public Shared Sub cvReleaseSparseMat (
    ByRef mat As IntPtr
)
public:
static void cvReleaseSparseMat(
    IntPtr% mat
)
static member cvReleaseSparseMat :
        mat : IntPtr byref -> unit

Parameters

mat
Type: SystemIntPtr
Reference of the pointer to the array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvResetImageROI Method

CvInvokecvResetImageROI Method

Releases image ROI. After that the whole image is considered selected.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvResetImageROI(
    IntPtr image
)
Public Shared Sub cvResetImageROI (
    image As IntPtr
)
public:
static void cvResetImageROI(
    IntPtr image
)
static member cvResetImageROI :
        image : IntPtr -> unit

Parameters

image
Type: SystemIntPtr
Image header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvReshape Method

CvInvokecvReshape Method

initializes CvMat header so that it points to the same data as the original array but has different shape - different number of channels, different number of rows or both

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr cvReshape(
    IntPtr arr,
    IntPtr header,
    int newCn,
    int newRows
)
Public Shared Function cvReshape (
    arr As IntPtr,
    header As IntPtr,
    newCn As Integer,
    newRows As Integer
) As IntPtr
public:
static IntPtr cvReshape(
    IntPtr arr,
    IntPtr header,
    int newCn,
    int newRows
)
static member cvReshape :
        arr : IntPtr *
        header : IntPtr *
        newCn : int *
        newRows : int -> IntPtr

Parameters

arr
Type: SystemIntPtr
Input array
header
Type: SystemIntPtr
Output header to be filled
newCn
Type: SystemInt32
New number of channels. new_cn = 0 means that number of channels remains unchanged
newRows
Type: SystemInt32
New number of rows. new_rows = 0 means that number of rows remains unchanged unless it needs to be changed according to new_cn value. destination array to be changed

Return Value

Type: IntPtr
The CvMat header
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSet2D Method

CvInvokecvSet2D Method

Assign the new value to the particular element of array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSet2D(
    IntPtr arr,
    int idx0,
    int idx1,
    MCvScalar value
)
Public Shared Sub cvSet2D (
    arr As IntPtr,
    idx0 As Integer,
    idx1 As Integer,
    value As MCvScalar
)
public:
static void cvSet2D(
    IntPtr arr,
    int idx0,
    int idx1,
    MCvScalar^ value
)
static member cvSet2D :
        arr : IntPtr *
        idx0 : int *
        idx1 : int *
        value : MCvScalar -> unit

Parameters

arr
Type: SystemIntPtr
Input array.
idx0
Type: SystemInt32
The first zero-based component of the element index
idx1
Type: SystemInt32
The second zero-based component of the element index
value
Type: Emgu.CV.StructureMCvScalar
The assigned value
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSetData Method

CvInvokecvSetData Method

Assigns user data to the array header.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSetData(
    IntPtr arr,
    IntPtr data,
    int step
)
Public Shared Sub cvSetData (
    arr As IntPtr,
    data As IntPtr,
    step As Integer
)
public:
static void cvSetData(
    IntPtr arr,
    IntPtr data,
    int step
)
static member cvSetData :
        arr : IntPtr *
        data : IntPtr *
        step : int -> unit

Parameters

arr
Type: SystemIntPtr
Array header.
data
Type: SystemIntPtr
User data.
step
Type: SystemInt32
Full row length in bytes.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSetImageCOI Method

CvInvokecvSetImageCOI Method

Sets the channel of interest to a given value. Value 0 means that all channels are selected, 1 means that the first channel is selected etc. If ROI is NULL and coi != 0, ROI is allocated.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSetImageCOI(
    IntPtr image,
    int coi
)
Public Shared Sub cvSetImageCOI (
    image As IntPtr,
    coi As Integer
)
public:
static void cvSetImageCOI(
    IntPtr image,
    int coi
)
static member cvSetImageCOI :
        image : IntPtr *
        coi : int -> unit

Parameters

image
Type: SystemIntPtr
Image header
coi
Type: SystemInt32
Channel of interest starting from 1. If 0, the COI is unset.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSetImageROI Method

CvInvokecvSetImageROI Method

Sets the image ROI to a given rectangle. If ROI is NULL and the value of the parameter rect is not equal to the whole image, ROI is allocated.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSetImageROI(
    IntPtr image,
    Rectangle rect
)
Public Shared Sub cvSetImageROI (
    image As IntPtr,
    rect As Rectangle
)
public:
static void cvSetImageROI(
    IntPtr image,
    Rectangle^ rect
)
static member cvSetImageROI :
        image : IntPtr *
        rect : Rectangle -> unit

Parameters

image
Type: SystemIntPtr
Image header.
rect
Type: System.DrawingRectangle
ROI rectangle.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSetReal1D Method

CvInvokecvSetReal1D Method

Assign the new value to the particular element of single-channel array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSetReal1D(
    IntPtr arr,
    int idx0,
    double value
)
Public Shared Sub cvSetReal1D (
    arr As IntPtr,
    idx0 As Integer,
    value As Double
)
public:
static void cvSetReal1D(
    IntPtr arr,
    int idx0,
    double value
)
static member cvSetReal1D :
        arr : IntPtr *
        idx0 : int *
        value : float -> unit

Parameters

arr
Type: SystemIntPtr
Input array
idx0
Type: SystemInt32
The first zero-based component of the element index
value
Type: SystemDouble
The assigned value
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSetReal2D Method

CvInvokecvSetReal2D Method

Assign the new value to the particular element of single-channel array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSetReal2D(
    IntPtr arr,
    int idx0,
    int idx1,
    double value
)
Public Shared Sub cvSetReal2D (
    arr As IntPtr,
    idx0 As Integer,
    idx1 As Integer,
    value As Double
)
public:
static void cvSetReal2D(
    IntPtr arr,
    int idx0,
    int idx1,
    double value
)
static member cvSetReal2D :
        arr : IntPtr *
        idx0 : int *
        idx1 : int *
        value : float -> unit

Parameters

arr
Type: SystemIntPtr
Input array
idx0
Type: SystemInt32
The first zero-based component of the element index
idx1
Type: SystemInt32
The second zero-based component of the element index
value
Type: SystemDouble
The assigned value
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSetReal3D Method

CvInvokecvSetReal3D Method

Assign the new value to the particular element of single-channel array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSetReal3D(
    IntPtr arr,
    int idx0,
    int idx1,
    int idx2,
    double value
)
Public Shared Sub cvSetReal3D (
    arr As IntPtr,
    idx0 As Integer,
    idx1 As Integer,
    idx2 As Integer,
    value As Double
)
public:
static void cvSetReal3D(
    IntPtr arr,
    int idx0,
    int idx1,
    int idx2,
    double value
)
static member cvSetReal3D :
        arr : IntPtr *
        idx0 : int *
        idx1 : int *
        idx2 : int *
        value : float -> unit

Parameters

arr
Type: SystemIntPtr
Input array
idx0
Type: SystemInt32
The first zero-based component of the element index
idx1
Type: SystemInt32
The second zero-based component of the element index
idx2
Type: SystemInt32
The third zero-based component of the element index
value
Type: SystemDouble
The assigned value
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.cvSetRealND Method

CvInvokecvSetRealND Method

Assign the new value to the particular element of single-channel array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void cvSetRealND(
    IntPtr arr,
    int[] idx,
    double value
)
Public Shared Sub cvSetRealND (
    arr As IntPtr,
    idx As Integer(),
    value As Double
)
public:
static void cvSetRealND(
    IntPtr arr,
    [InAttribute] array<int>^ idx,
    double value
)
static member cvSetRealND :
        arr : IntPtr *
        idx : int[] *
        value : float -> unit

Parameters

arr
Type: SystemIntPtr
Input array
idx
Type: SystemInt32
Array of the element indices
value
Type: SystemDouble
The assigned value
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CvtColor Method

CvInvokeCvtColor Method

Overload List
Name | Description
CvtColor(IInputArray, IOutputArray, ColorConversion, Int32) | Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).
CvtColor(IInputArray, IOutputArray, Type, Type) | Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CvtColor Method (IInputArray, IOutputArray, ColorConversion, Int32)

CvInvokeCvtColor Method (IInputArray, IOutputArray, ColorConversion, Int32)

http://www.emgu.com
Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CvtColor(
    IInputArray src,
    IOutputArray dst,
    ColorConversion code,
    int dstCn = 0
)
Public Shared Sub CvtColor (
    src As IInputArray,
    dst As IOutputArray,
    code As ColorConversion,
    Optional dstCn As Integer = 0
)
public:
static void CvtColor(
    IInputArray^ src,
    IOutputArray^ dst,
    ColorConversion^ code,
    int dstCn = 0
)
static member CvtColor :
        src : IInputArray *
        dst : IOutputArray *
        code : ColorConversion *
        ?dstCn : int
(* Defaults:
        let _dstCn = defaultArg dstCn 0
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source 8-bit (8u), 16-bit (16u) or single-precision floating-point (32f) image
dst
Type: Emgu.CVIOutputArray
The destination image of the same data type as the source one. The number of channels may be different
code
Type: Emgu.CV.CvEnumColorConversion
Color conversion operation that can be specifed using CV_src_color_space2dst_color_space constants
dstCn (Optional)
Type: SystemInt32
number of channels in the destination image; if the parameter is 0, the number of the channels is derived automatically from src and code .
See Also

Reference

CvInvoke Class
CvtColor Overload
Emgu.CV Namespace


CvInvoke.CvtColor Method (IInputArray, IOutputArray, Type, Type)

CvInvokeCvtColor Method (IInputArray, IOutputArray, Type, Type)

http://www.emgu.com
Converts input image from one color space to another. The function ignores colorModel and channelSeq fields of IplImage header, so the source image color space should be specified correctly (including order of the channels in case of RGB space, e.g. BGR means 24-bit format with B0 G0 R0 B1 G1 R1 ... layout, whereas RGB means 24-bit format with R0 G0 B0 R1 G1 B1 ... layout).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CvtColor(
    IInputArray src,
    IOutputArray dest,
    Type srcColor,
    Type destColor
)
Public Shared Sub CvtColor (
    src As IInputArray,
    dest As IOutputArray,
    srcColor As Type,
    destColor As Type
)
public:
static void CvtColor(
    IInputArray^ src,
    IOutputArray^ dest,
    Type^ srcColor,
    Type^ destColor
)
static member CvtColor :
        src : IInputArray *
        dest : IOutputArray *
        srcColor : Type *
        destColor : Type -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source 8-bit (8u), 16-bit (16u) or single-precision floating-point (32f) image
dest
Type: Emgu.CVIOutputArray
The destination image of the same data type as the source one. The number of channels may be different
srcColor
Type: SystemType
Source color type.
destColor
Type: SystemType
Destination color type
See Also

Reference

CvInvoke Class
CvtColor Overload
Emgu.CV Namespace


CvInvoke.Dct Method

CvInvokeDct Method

Performs forward or inverse transform of 1D or 2D floating-point array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Dct(
    IInputArray src,
    IOutputArray dst,
    DctType flags
)
Public Shared Sub Dct (
    src As IInputArray,
    dst As IOutputArray,
    flags As DctType
)
public:
static void Dct(
    IInputArray^ src,
    IOutputArray^ dst,
    DctType^ flags
)
static member Dct :
        src : IInputArray *
        dst : IOutputArray *
        flags : DctType -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source array, real 1D or 2D array
dst
Type: Emgu.CVIOutputArray
Destination array of the same size and same type as the source
flags
Type: Emgu.CV.CvEnumDctType
Transformation flags
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Decolor Method

CvInvokeDecolor Method

Transforms a color image to a grayscale image. It is a basic tool in digital printing, stylized black-and-white photograph rendering, and in many single channel image processing applications

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Decolor(
    IInputArray src,
    IOutputArray grayscale,
    IOutputArray colorBoost
)
Public Shared Sub Decolor (
    src As IInputArray,
    grayscale As IOutputArray,
    colorBoost As IOutputArray
)
public:
static void Decolor(
    IInputArray^ src,
    IOutputArray^ grayscale,
    IOutputArray^ colorBoost
)
static member Decolor :
        src : IInputArray *
        grayscale : IOutputArray *
        colorBoost : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image.
grayscale
Type: Emgu.CVIOutputArray
Output 8-bit 1-channel image.
colorBoost
Type: Emgu.CVIOutputArray
Output 8-bit 3-channel image.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DefaultLoadUnmanagedModules Method

CvInvokeDefaultLoadUnmanagedModules Method

Attempts to load opencv modules from the specific location

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool DefaultLoadUnmanagedModules(
    string[] modules
)
Public Shared Function DefaultLoadUnmanagedModules (
    modules As String()
) As Boolean
public:
static bool DefaultLoadUnmanagedModules(
    array<String^>^ modules
)
static member DefaultLoadUnmanagedModules :
        modules : string[] -> bool

Parameters

modules
Type: SystemString
The names of opencv modules. e.g. "opencv_core.dll" on windows.

Return Value

Type: Boolean
True if all the modules has been loaded successfully
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DenoiseTVL1 Method

CvInvokeDenoiseTVL1 Method

Primal-dual algorithm is an algorithm for solving special types of variational problems (that is, finding a function to minimize some functional). As the image denoising, in particular, may be seen as the variational problem, primal-dual algorithm then can be used to perform denoising and this is exactly what is implemented.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DenoiseTVL1(
    Mat[] observations,
    Mat result,
    double lambda,
    int niters
)
Public Shared Sub DenoiseTVL1 (
    observations As Mat(),
    result As Mat,
    lambda As Double,
    niters As Integer
)
public:
static void DenoiseTVL1(
    array<Mat^>^ observations,
    Mat^ result,
    double lambda,
    int niters
)
static member DenoiseTVL1 :
        observations : Mat[] *
        result : Mat *
        lambda : float *
        niters : int -> unit

Parameters

observations
Type: Emgu.CVMat
This array should contain one or more noised versions of the image that is to be restored.
result
Type: Emgu.CVMat
Here the denoised image will be stored. There is no need to do pre-allocation of storage space, as it will be automatically allocated, if necessary.
lambda
Type: SystemDouble
Corresponds to in the formulas above. As it is enlarged, the smooth (blurred) images are treated more favorably than detailed (but maybe more noised) ones. Roughly speaking, as it becomes smaller, the result will be more blur but more sever outliers will be removed.
niters
Type: SystemInt32
Number of iterations that the algorithm will run. Of course, as more iterations as better, but it is hard to quantitatively refine this statement, so just use the default and increase it if the results are poor.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DestroyAllWindows Method

CvInvokeDestroyAllWindows Method

Destroys all of the HighGUI windows.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DestroyAllWindows()
Public Shared Sub DestroyAllWindows
public:
static void DestroyAllWindows()
static member DestroyAllWindows : unit -> unit
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DestroyWindow Method

CvInvokeDestroyWindow Method

Destroys the window with a given name

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DestroyWindow(
    string name
)
Public Shared Sub DestroyWindow (
    name As String
)
public:
static void DestroyWindow(
    String^ name
)
static member DestroyWindow :
        name : string -> unit

Parameters

name
Type: SystemString
Name of the window to be destroyed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DetailEnhance Method

CvInvokeDetailEnhance Method

This filter enhances the details of a particular image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DetailEnhance(
    IInputArray src,
    IOutputArray dst,
    float sigmaS = 10f,
    float sigmaR = 0.15f
)
Public Shared Sub DetailEnhance (
    src As IInputArray,
    dst As IOutputArray,
    Optional sigmaS As Single = 10F,
    Optional sigmaR As Single = 0.15F
)
public:
static void DetailEnhance(
    IInputArray^ src,
    IOutputArray^ dst,
    float sigmaS = 10f,
    float sigmaR = 0.15f
)
static member DetailEnhance :
        src : IInputArray *
        dst : IOutputArray *
        ?sigmaS : float32 *
        ?sigmaR : float32
(* Defaults:
        let _sigmaS = defaultArg sigmaS 10f
        let _sigmaR = defaultArg sigmaR 0.15f
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src
sigmaS (Optional)
Type: SystemSingle
Range between 0 to 200
sigmaR (Optional)
Type: SystemSingle
Range between 0 to 1
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Determinant Method

CvInvokeDeterminant Method

Returns determinant of the square matrix mat. The direct method is used for small matrices and Gaussian elimination is used for larger matrices. For symmetric positive-determined matrices it is also possible to run SVD with U=V=NULL and then calculate determinant as a product of the diagonal elements of W

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Determinant(
    IInputArray mat
)
Public Shared Function Determinant (
    mat As IInputArray
) As Double
public:
static double Determinant(
    IInputArray^ mat
)
static member Determinant :
        mat : IInputArray -> float

Parameters

mat
Type: Emgu.CVIInputArray
The pointer to the matrix

Return Value

Type: Double
determinant of the square matrix mat
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Dft Method

CvInvokeDft Method

Performs forward or inverse transform of 1D or 2D floating-point array In case of real (single-channel) data, the packed format, borrowed from IPL, is used to to represent a result of forward Fourier transform or input for inverse Fourier transform

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Dft(
    IInputArray src,
    IOutputArray dst,
    DxtType flags,
    int nonzeroRows
)
Public Shared Sub Dft (
    src As IInputArray,
    dst As IOutputArray,
    flags As DxtType,
    nonzeroRows As Integer
)
public:
static void Dft(
    IInputArray^ src,
    IOutputArray^ dst,
    DxtType^ flags,
    int nonzeroRows
)
static member Dft :
        src : IInputArray *
        dst : IOutputArray *
        flags : DxtType *
        nonzeroRows : int -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source array, real or complex
dst
Type: Emgu.CVIOutputArray
Destination array of the same size and same type as the source
flags
Type: Emgu.CV.CvEnumDxtType
Transformation flags
nonzeroRows
Type: SystemInt32
Number of nonzero rows to in the source array (in case of forward 2d transform), or a number of rows of interest in the destination array (in case of inverse 2d transform). If the value is negative, zero, or greater than the total number of rows, it is ignored. The parameter can be used to speed up 2d convolution/correlation when computing them via DFT. See the sample below
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Dilate Method

CvInvokeDilate Method

Dilates the source image using the specified structuring element that determines the shape of a pixel neighborhood over which the maximum is taken The function supports the in-place mode. Dilation can be applied several (iterations) times. In case of color image each channel is processed independently

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Dilate(
    IInputArray src,
    IOutputArray dst,
    IInputArray element,
    Point anchor,
    int iterations,
    BorderType borderType,
    MCvScalar borderValue
)
Public Shared Sub Dilate (
    src As IInputArray,
    dst As IOutputArray,
    element As IInputArray,
    anchor As Point,
    iterations As Integer,
    borderType As BorderType,
    borderValue As MCvScalar
)
public:
static void Dilate(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ element,
    Point^ anchor,
    int iterations,
    BorderType^ borderType,
    MCvScalar^ borderValue
)
static member Dilate :
        src : IInputArray *
        dst : IOutputArray *
        element : IInputArray *
        anchor : Point *
        iterations : int *
        borderType : BorderType *
        borderValue : MCvScalar -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Destination image
element
Type: Emgu.CVIInputArray
Structuring element used for erosion. If it is IntPtr.Zero, a 3x3 rectangular structuring element is used
anchor
Type: System.DrawingPoint
Position of the anchor within the element; default value (-1, -1) means that the anchor is at the element center.
iterations
Type: SystemInt32
Number of times erosion is applied
borderType
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
borderValue
Type: Emgu.CV.StructureMCvScalar
Border value in case of a constant border
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DistanceTransform Method

CvInvokeDistanceTransform Method

Calculates distance to closest zero pixel for all non-zero pixels of source image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DistanceTransform(
    IInputArray src,
    IOutputArray dst,
    IOutputArray labels,
    DistType distanceType,
    int maskSize,
    DistLabelType labelType = 0
)
Public Shared Sub DistanceTransform (
    src As IInputArray,
    dst As IOutputArray,
    labels As IOutputArray,
    distanceType As DistType,
    maskSize As Integer,
    Optional labelType As DistLabelType = 0
)
public:
static void DistanceTransform(
    IInputArray^ src,
    IOutputArray^ dst,
    IOutputArray^ labels,
    DistType^ distanceType,
    int maskSize,
    DistLabelType^ labelType = 0
)
static member DistanceTransform :
        src : IInputArray *
        dst : IOutputArray *
        labels : IOutputArray *
        distanceType : DistType *
        maskSize : int *
        ?labelType : DistLabelType
(* Defaults:
        let _labelType = defaultArg labelType 0
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source 8-bit single-channel (binary) image.
dst
Type: Emgu.CVIOutputArray
Output image with calculated distances (32-bit floating-point, single-channel).
labels
Type: Emgu.CVIOutputArray
The optional output 2d array of labels of integer type and the same size as src and dst. Can be null if not needed
distanceType
Type: Emgu.CV.CvEnumDistType
Type of distance
maskSize
Type: SystemInt32
Size of distance transform mask; can be 3 or 5. In case of CV_DIST_L1 or CV_DIST_C the parameter is forced to 3, because 3x3 mask gives the same result as 5x5 yet it is faster.
labelType (Optional)
Type: Emgu.CV.CvEnumDistLabelType
Type of the label array to build. If labelType==CCOMP then each connected component of zeros in src (as well as all the non-zero pixels closest to the connected component) will be assigned the same label. If labelType==PIXEL then each zero pixel (and all the non-zero pixels closest to it) gets its own label.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Divide Method

CvInvokeDivide Method

Divides one array by another: dst(I)=scale * src1(I)/src2(I), if src1!=IntPtr.Zero; dst(I)=scale/src2(I), if src1==IntPtr.Zero; All the arrays must have the same type, and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Divide(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    double scale = 1,
    DepthType dtype = -1
)
Public Shared Sub Divide (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional scale As Double = 1,
    Optional dtype As DepthType = -1
)
public:
static void Divide(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    double scale = 1,
    DepthType^ dtype = -1
)
static member Divide :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?scale : float *
        ?dtype : DepthType
(* Defaults:
        let _scale = defaultArg scale 1
        let _dtype = defaultArg dtype -1
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array. If the pointer is IntPtr.Zero, the array is assumed to be all 1s.
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
scale (Optional)
Type: SystemDouble
Optional scale factor
dtype (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DrawChessboardCorners Method

CvInvokeDrawChessboardCorners Method

Draws the individual chessboard corners detected (as red circles) in case if the board was not found (pattern_was_found=0) or the colored corners connected with lines when the board was found (pattern_was_found != 0).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawChessboardCorners(
    IInputOutputArray image,
    Size patternSize,
    IInputArray corners,
    bool patternWasFound
)
Public Shared Sub DrawChessboardCorners (
    image As IInputOutputArray,
    patternSize As Size,
    corners As IInputArray,
    patternWasFound As Boolean
)
public:
static void DrawChessboardCorners(
    IInputOutputArray^ image,
    Size^ patternSize,
    IInputArray^ corners,
    bool patternWasFound
)
static member DrawChessboardCorners :
        image : IInputOutputArray *
        patternSize : Size *
        corners : IInputArray *
        patternWasFound : bool -> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
The destination image; it must be 8-bit color image
patternSize
Type: System.DrawingSize
The number of inner corners per chessboard row and column
corners
Type: Emgu.CVIInputArray
The array of corners detected
patternWasFound
Type: SystemBoolean
Indicates whether the complete board was found (!=0) or not (=0). One may just pass the return value cvFindChessboardCorners here.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DrawContours Method

CvInvokeDrawContours Method

Draws contours outlines or filled contours.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawContours(
    IInputOutputArray image,
    IInputArrayOfArrays contours,
    int contourIdx,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    IInputArray hierarchy = null,
    int maxLevel = 2147483647,
    Point offset = null
)
Public Shared Sub DrawContours (
    image As IInputOutputArray,
    contours As IInputArrayOfArrays,
    contourIdx As Integer,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional hierarchy As IInputArray = Nothing,
    Optional maxLevel As Integer = 2147483647,
    Optional offset As Point = Nothing
)
public:
static void DrawContours(
    IInputOutputArray^ image,
    IInputArrayOfArrays^ contours,
    int contourIdx,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    IInputArray^ hierarchy = nullptr,
    int maxLevel = 2147483647,
    Point^ offset = nullptr
)
static member DrawContours :
        image : IInputOutputArray *
        contours : IInputArrayOfArrays *
        contourIdx : int *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?hierarchy : IInputArray *
        ?maxLevel : int *
        ?offset : Point
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _hierarchy = defaultArg hierarchy null
        let _maxLevel = defaultArg maxLevel 2147483647
        let _offset = defaultArg offset null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
Image where the contours are to be drawn. Like in any other drawing function, the contours are clipped with the ROI
contours
Type: Emgu.CVIInputArrayOfArrays
All the input contours. Each contour is stored as a point vector.
contourIdx
Type: SystemInt32
Parameter indicating a contour to draw. If it is negative, all the contours are drawn.
color
Type: Emgu.CV.StructureMCvScalar
Color of the contours
thickness (Optional)
Type: SystemInt32
Thickness of lines the contours are drawn with. If it is negative the contour interiors are drawn
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the contour segments
hierarchy (Optional)
Type: Emgu.CVIInputArray
Optional information about hierarchy. It is only needed if you want to draw only some of the contours
maxLevel (Optional)
Type: SystemInt32
Maximal level for drawn contours. If 0, only contour is drawn. If 1, the contour and all contours after it on the same level are drawn. If 2, all contours after and all contours one level below the contours are drawn, etc. If the value is negative, the function does not draw the contours following after contour but draws child contours of contour up to abs(maxLevel)-1 level.
offset (Optional)
Type: System.DrawingPoint
Shift all the point coordinates by the specified value. It is useful in case if the contours retrieved in some image ROI and then the ROI offset needs to be taken into account during the rendering.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.DrawMarker Method

CvInvokeDrawMarker Method

[Missing <summary> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawMarker(
    IInputOutputArray img,
    Point position,
    MCvScalar color,
    MarkerTypes markerType,
    int markerSize = 20,
    int thickness = 1,
    LineType lineType = 8
)
Public Shared Sub DrawMarker (
    img As IInputOutputArray,
    position As Point,
    color As MCvScalar,
    markerType As MarkerTypes,
    Optional markerSize As Integer = 20,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8
)
public:
static void DrawMarker(
    IInputOutputArray^ img,
    Point^ position,
    MCvScalar^ color,
    MarkerTypes^ markerType,
    int markerSize = 20,
    int thickness = 1,
    LineType^ lineType = 8
)
static member DrawMarker :
        img : IInputOutputArray *
        position : Point *
        color : MCvScalar *
        markerType : MarkerTypes *
        ?markerSize : int *
        ?thickness : int *
        ?lineType : LineType
(* Defaults:
        let _markerSize = defaultArg markerSize 20
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray

[Missing <param name="img"/> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

position
Type: System.DrawingPoint

[Missing <param name="position"/> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

color
Type: Emgu.CV.StructureMCvScalar

[Missing <param name="color"/> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

markerType
Type: Emgu.CV.CvEnumMarkerTypes

[Missing <param name="markerType"/> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

markerSize (Optional)
Type: SystemInt32

[Missing <param name="markerSize"/> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

thickness (Optional)
Type: SystemInt32

[Missing <param name="thickness"/> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

lineType (Optional)
Type: Emgu.CV.CvEnumLineType

[Missing <param name="lineType"/> documentation for "M:Emgu.CV.CvInvoke.DrawMarker(Emgu.CV.IInputOutputArray,System.Drawing.Point,Emgu.CV.Structure.MCvScalar,Emgu.CV.CvEnum.MarkerTypes,System.Int32,System.Int32,Emgu.CV.CvEnum.LineType)"]

See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.EdgePreservingFilter Method

CvInvokeEdgePreservingFilter Method

Filtering is the fundamental operation in image and video processing. Edge-preserving smoothing filters are used in many different applications.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void EdgePreservingFilter(
    IInputArray src,
    IOutputArray dst,
    EdgePreservingFilterFlag flags = 1,
    float sigmaS = 60f,
    float sigmaR = 0.4f
)
Public Shared Sub EdgePreservingFilter (
    src As IInputArray,
    dst As IOutputArray,
    Optional flags As EdgePreservingFilterFlag = 1,
    Optional sigmaS As Single = 60F,
    Optional sigmaR As Single = 0.4F
)
public:
static void EdgePreservingFilter(
    IInputArray^ src,
    IOutputArray^ dst,
    EdgePreservingFilterFlag^ flags = 1,
    float sigmaS = 60f,
    float sigmaR = 0.4f
)
static member EdgePreservingFilter :
        src : IInputArray *
        dst : IOutputArray *
        ?flags : EdgePreservingFilterFlag *
        ?sigmaS : float32 *
        ?sigmaR : float32
(* Defaults:
        let _flags = defaultArg flags 1
        let _sigmaS = defaultArg sigmaS 60f
        let _sigmaR = defaultArg sigmaR 0.4f
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image
dst
Type: Emgu.CVIOutputArray
Output 8-bit 3-channel image
flags (Optional)
Type: Emgu.CV.CvEnumEdgePreservingFilterFlag
Edge preserving filters
sigmaS (Optional)
Type: SystemSingle
Range between 0 to 200
sigmaR (Optional)
Type: SystemSingle
Range between 0 to 1
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Eigen Method

CvInvokeEigen Method

Computes eigenvalues and eigenvectors of a symmetric matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Eigen(
    IInputArray src,
    IOutputArray eigenValues,
    IOutputArray eigenVectors = null
)
Public Shared Sub Eigen (
    src As IInputArray,
    eigenValues As IOutputArray,
    Optional eigenVectors As IOutputArray = Nothing
)
public:
static void Eigen(
    IInputArray^ src,
    IOutputArray^ eigenValues,
    IOutputArray^ eigenVectors = nullptr
)
static member Eigen :
        src : IInputArray *
        eigenValues : IOutputArray *
        ?eigenVectors : IOutputArray
(* Defaults:
        let _eigenVectors = defaultArg eigenVectors null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The input symmetric square matrix, modified during the processing
eigenValues
Type: Emgu.CVIOutputArray
The output vector of eigenvalues, stored in the descending order (order of eigenvalues and eigenvectors is syncronized, of course)
eigenVectors (Optional)
Type: Emgu.CVIOutputArray
The output matrix of eigenvectors, stored as subsequent rows
Remarks
Currently the function is slower than cvSVD yet less accurate, so if A is known to be positivelydefined (for example, it is a covariance matrix)it is recommended to use cvSVD to find eigenvalues and eigenvectors of A, especially if eigenvectors are not required.
Examples
To calculate the largest eigenvector/-value set lowindex = highindex = 1. For legacy reasons this function always returns a square matrix the same size as the source matrix with eigenvectors and a vector the length of the source matrix with eigenvalues. The selected eigenvectors/-values are always in the first highindex - lowindex + 1 rows.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Ellipse Method

CvInvokeEllipse Method

Overload List
Name | Description
Ellipse(IInputOutputArray, RotatedRect, MCvScalar, Int32, LineType, Int32) | Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.
Ellipse(IInputOutputArray, Point, Size, Double, Double, Double, MCvScalar, Int32, LineType, Int32) | Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Ellipse Method (IInputOutputArray, RotatedRect, MCvScalar, Int32, LineType, Int32)

CvInvokeEllipse Method (IInputOutputArray, RotatedRect, MCvScalar, Int32, LineType, Int32)

http://www.emgu.com
Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Ellipse(
    IInputOutputArray img,
    RotatedRect box,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub Ellipse (
    img As IInputOutputArray,
    box As RotatedRect,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void Ellipse(
    IInputOutputArray^ img,
    RotatedRect^ box,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
static member Ellipse :
        img : IInputOutputArray *
        box : RotatedRect *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image
box
Type: Emgu.CV.StructureRotatedRect
The box the define the ellipse area
color
Type: Emgu.CV.StructureMCvScalar
Ellipse color
thickness (Optional)
Type: SystemInt32
Thickness of the ellipse arc
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the ellipse boundary
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and axes' values
See Also

Reference

CvInvoke Class
Ellipse Overload
Emgu.CV Namespace


CvInvoke.Ellipse Method (IInputOutputArray, Point, Size, Double, Double, Double, MCvScalar, Int32, LineType, Int32)

CvInvokeEllipse Method (IInputOutputArray, Point, Size, Double, Double, Double, MCvScalar, Int32, LineType, Int32)

http://www.emgu.com
Draws a simple or thick elliptic arc or fills an ellipse sector. The arc is clipped by ROI rectangle. A piecewise-linear approximation is used for antialiased arcs and thick arcs. All the angles are given in degrees.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Ellipse(
    IInputOutputArray img,
    Point center,
    Size axes,
    double angle,
    double startAngle,
    double endAngle,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub Ellipse (
    img As IInputOutputArray,
    center As Point,
    axes As Size,
    angle As Double,
    startAngle As Double,
    endAngle As Double,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void Ellipse(
    IInputOutputArray^ img,
    Point^ center,
    Size^ axes,
    double angle,
    double startAngle,
    double endAngle,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
static member Ellipse :
        img : IInputOutputArray *
        center : Point *
        axes : Size *
        angle : float *
        startAngle : float *
        endAngle : float *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image
center
Type: System.DrawingPoint
Center of the ellipse
axes
Type: System.DrawingSize
Length of the ellipse axes
angle
Type: SystemDouble
Rotation angle
startAngle
Type: SystemDouble
Starting angle of the elliptic arc
endAngle
Type: SystemDouble
Ending angle of the elliptic arc
color
Type: Emgu.CV.StructureMCvScalar
Ellipse color
thickness (Optional)
Type: SystemInt32
Thickness of the ellipse arc
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the ellipse boundary
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and axes' values
See Also

Reference

CvInvoke Class
Ellipse Overload
Emgu.CV Namespace


CvInvoke.EMD Method

CvInvokeEMD Method

Computes the 'minimal work' distance between two weighted point configurations.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static float EMD(
    IInputArray signature1,
    IInputArray signature2,
    DistType distType,
    IInputArray cost = null,
    float[] lowerBound = null,
    IOutputArray flow = null
)
Public Shared Function EMD (
    signature1 As IInputArray,
    signature2 As IInputArray,
    distType As DistType,
    Optional cost As IInputArray = Nothing,
    Optional lowerBound As Single() = Nothing,
    Optional flow As IOutputArray = Nothing
) As Single
public:
static float EMD(
    IInputArray^ signature1,
    IInputArray^ signature2,
    DistType^ distType,
    IInputArray^ cost = nullptr,
    array<float>^ lowerBound = nullptr,
    IOutputArray^ flow = nullptr
)
static member EMD :
        signature1 : IInputArray *
        signature2 : IInputArray *
        distType : DistType *
        ?cost : IInputArray *
        ?lowerBound : float32[] *
        ?flow : IOutputArray
(* Defaults:
        let _cost = defaultArg cost null
        let _lowerBound = defaultArg lowerBound null
        let _flow = defaultArg flow null
*)
-> float32

Parameters

signature1
Type: Emgu.CVIInputArray
First signature, a size1 x dims + 1 floating-point matrix. Each row stores the point weight followed by the point coordinates. The matrix is allowed to have a single column (weights only) if the user-defined cost matrix is used.
signature2
Type: Emgu.CVIInputArray
Second signature of the same format as signature1 , though the number of rows may be different. The total weights may be different. In this case an extra 'dummy' point is added to either signature1 or signature2
distType
Type: Emgu.CV.CvEnumDistType
Used metric. CV_DIST_L1, CV_DIST_L2 , and CV_DIST_C stand for one of the standard metrics. CV_DIST_USER means that a pre-calculated cost matrix cost is used.
cost (Optional)
Type: Emgu.CVIInputArray
User-defined size1 x size2 cost matrix. Also, if a cost matrix is used, lower boundary lowerBound cannot be calculated because it needs a metric function.
lowerBound (Optional)
Type: SystemSingle
Optional input/output parameter: lower boundary of a distance between the two signatures that is a distance between mass centers. The lower boundary may not be calculated if the user-defined cost matrix is used, the total weights of point configurations are not equal, or if the signatures consist of weights only (the signature matrices have a single column).
flow (Optional)
Type: Emgu.CVIOutputArray
Resultant size1 x size2 flow matrix

Return Value

Type: Single
The 'minimal work' distance between two weighted point configurations.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.EqualizeHist Method

CvInvokeEqualizeHist Method

The algorithm normalizes brightness and increases contrast of the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void EqualizeHist(
    IInputArray src,
    IOutputArray dst
)
Public Shared Sub EqualizeHist (
    src As IInputArray,
    dst As IOutputArray
)
public:
static void EqualizeHist(
    IInputArray^ src,
    IOutputArray^ dst
)
static member EqualizeHist :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The input 8-bit single-channel image
dst
Type: Emgu.CVIOutputArray
The output image of the same size and the same data type as src
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Erode Method

CvInvokeErode Method

Erodes the source image using the specified structuring element that determines the shape of a pixel neighborhood over which the minimum is taken: dst=erode(src,element): dst(x,y)=min((x',y') in element)) src(x+x',y+y') The function supports the in-place mode. Erosion can be applied several (iterations) times. In case of color image each channel is processed independently.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Erode(
    IInputArray src,
    IOutputArray dst,
    IInputArray element,
    Point anchor,
    int iterations,
    BorderType borderType,
    MCvScalar borderValue
)
Public Shared Sub Erode (
    src As IInputArray,
    dst As IOutputArray,
    element As IInputArray,
    anchor As Point,
    iterations As Integer,
    borderType As BorderType,
    borderValue As MCvScalar
)
public:
static void Erode(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ element,
    Point^ anchor,
    int iterations,
    BorderType^ borderType,
    MCvScalar^ borderValue
)
static member Erode :
        src : IInputArray *
        dst : IOutputArray *
        element : IInputArray *
        anchor : Point *
        iterations : int *
        borderType : BorderType *
        borderValue : MCvScalar -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image.
dst
Type: Emgu.CVIOutputArray
Destination image
element
Type: Emgu.CVIInputArray
Structuring element used for erosion. If it is IntPtr.Zero, a 3x3 rectangular structuring element is used.
anchor
Type: System.DrawingPoint
Position of the anchor within the element; default value (-1, -1) means that the anchor is at the element center.
iterations
Type: SystemInt32
Number of times erosion is applied.
borderType
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
borderValue
Type: Emgu.CV.StructureMCvScalar
Border value in case of a constant border, use Constant for default
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ErrorStr Method

CvInvokeErrorStr Method

Returns the textual description for the specified error status code. In case of unknown status the function returns NULL pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string ErrorStr(
    int status
)
Public Shared Function ErrorStr (
    status As Integer
) As String
public:
static String^ ErrorStr(
    int status
)
static member ErrorStr :
        status : int -> string

Parameters

status
Type: SystemInt32
The error status

Return Value

Type: String
the textual description for the specified error status code.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.EstimateAffine2D Method

CvInvokeEstimateAffine2D Method

Overload List
Name | Description
EstimateAffine2D(PointF, PointF, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32) | Computes an optimal affine transformation between two 2D point sets.
EstimateAffine2D(IInputArray, IInputArray, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32) | Computes an optimal affine transformation between two 2D point sets.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.EstimateAffine2D Method (PointF[], PointF[], IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)

CvInvokeEstimateAffine2D Method (PointF, PointF, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)

http://www.emgu.com
Computes an optimal affine transformation between two 2D point sets.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat EstimateAffine2D(
    PointF[] from,
    PointF[] to,
    IOutputArray inliners = null,
    RobustEstimationAlgorithm method = 8,
    double ransacReprojThreshold = 3,
    int maxIters = 2000,
    double confidence = 0.99,
    int refineIters = 10
)
Public Shared Function EstimateAffine2D (
    from As PointF(),
    to As PointF(),
    Optional inliners As IOutputArray = Nothing,
    Optional method As RobustEstimationAlgorithm = 8,
    Optional ransacReprojThreshold As Double = 3,
    Optional maxIters As Integer = 2000,
    Optional confidence As Double = 0.99,
    Optional refineIters As Integer = 10
) As Mat
public:
static Mat^ EstimateAffine2D(
    array<PointF^>^ from,
    array<PointF^>^ to,
    IOutputArray^ inliners = nullptr,
    RobustEstimationAlgorithm^ method = 8,
    double ransacReprojThreshold = 3,
    int maxIters = 2000,
    double confidence = 0.99,
    int refineIters = 10
)
static member EstimateAffine2D :
        from : PointF[] *
        to : PointF[] *
        ?inliners : IOutputArray *
        ?method : RobustEstimationAlgorithm *
        ?ransacReprojThreshold : float *
        ?maxIters : int *
        ?confidence : float *
        ?refineIters : int
(* Defaults:
        let _inliners = defaultArg inliners null
        let _method = defaultArg method 8
        let _ransacReprojThreshold = defaultArg ransacReprojThreshold 3
        let _maxIters = defaultArg maxIters 2000
        let _confidence = defaultArg confidence 0.99
        let _refineIters = defaultArg refineIters 10
*)
-> Mat

Parameters

from
Type: System.DrawingPointF
First input 2D point set containing (X,Y).
to
Type: System.DrawingPointF
Second input 2D point set containing (x,y).
inliners (Optional)
Type: Emgu.CVIOutputArray
Output vector indicating which points are inliers (1-inlier, 0-outlier).
method (Optional)
Type: Emgu.CV.CvEnumRobustEstimationAlgorithm
Robust method used to compute transformation.
ransacReprojThreshold (Optional)
Type: SystemDouble
Maximum reprojection error in the RANSAC algorithm to consider a point as an inlier. Applies only to RANSAC.
maxIters (Optional)
Type: SystemInt32
The maximum number of robust method iterations.
confidence (Optional)
Type: SystemDouble
Confidence level, between 0 and 1, for the estimated transformation. Anything between 0.95 and 0.99 is usually good enough. Values too close to 1 can slow down the estimation significantly. Values lower than 0.8-0.9 can result in an incorrectly estimated transformation.
refineIters (Optional)
Type: SystemInt32
Maximum number of iterations of refining algorithm (Levenberg-Marquardt). Passing 0 will disable refining, so the output matrix will be output of robust method.

Return Value

Type: Mat
Output 2D affine transformation matrix 2×3 or empty matrix if transformation could not be estimated.
See Also

Reference

CvInvoke Class
EstimateAffine2D Overload
Emgu.CV Namespace


CvInvoke.EstimateAffine2D Method (IInputArray, IInputArray, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)

CvInvokeEstimateAffine2D Method (IInputArray, IInputArray, IOutputArray, RobustEstimationAlgorithm, Double, Int32, Double, Int32)

http://www.emgu.com
Computes an optimal affine transformation between two 2D point sets.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat EstimateAffine2D(
    IInputArray from,
    IInputArray to,
    IOutputArray inliners = null,
    RobustEstimationAlgorithm method = 8,
    double ransacReprojThreshold = 3,
    int maxIters = 2000,
    double confidence = 0.99,
    int refineIters = 10
)
Public Shared Function EstimateAffine2D (
    from As IInputArray,
    to As IInputArray,
    Optional inliners As IOutputArray = Nothing,
    Optional method As RobustEstimationAlgorithm = 8,
    Optional ransacReprojThreshold As Double = 3,
    Optional maxIters As Integer = 2000,
    Optional confidence As Double = 0.99,
    Optional refineIters As Integer = 10
) As Mat
public:
static Mat^ EstimateAffine2D(
    IInputArray^ from,
    IInputArray^ to,
    IOutputArray^ inliners = nullptr,
    RobustEstimationAlgorithm^ method = 8,
    double ransacReprojThreshold = 3,
    int maxIters = 2000,
    double confidence = 0.99,
    int refineIters = 10
)
static member EstimateAffine2D :
        from : IInputArray *
        to : IInputArray *
        ?inliners : IOutputArray *
        ?method : RobustEstimationAlgorithm *
        ?ransacReprojThreshold : float *
        ?maxIters : int *
        ?confidence : float *
        ?refineIters : int
(* Defaults:
        let _inliners = defaultArg inliners null
        let _method = defaultArg method 8
        let _ransacReprojThreshold = defaultArg ransacReprojThreshold 3
        let _maxIters = defaultArg maxIters 2000
        let _confidence = defaultArg confidence 0.99
        let _refineIters = defaultArg refineIters 10
*)
-> Mat

Parameters

from
Type: Emgu.CVIInputArray
First input 2D point set containing (X,Y).
to
Type: Emgu.CVIInputArray
Second input 2D point set containing (x,y).
inliners (Optional)
Type: Emgu.CVIOutputArray
Output vector indicating which points are inliers (1-inlier, 0-outlier).
method (Optional)
Type: Emgu.CV.CvEnumRobustEstimationAlgorithm
Robust method used to compute transformation.
ransacReprojThreshold (Optional)
Type: SystemDouble
Maximum reprojection error in the RANSAC algorithm to consider a point as an inlier. Applies only to RANSAC.
maxIters (Optional)
Type: SystemInt32
The maximum number of robust method iterations.
confidence (Optional)
Type: SystemDouble
Confidence level, between 0 and 1, for the estimated transformation. Anything between 0.95 and 0.99 is usually good enough. Values too close to 1 can slow down the estimation significantly. Values lower than 0.8-0.9 can result in an incorrectly estimated transformation.
refineIters (Optional)
Type: SystemInt32
Maximum number of iterations of refining algorithm (Levenberg-Marquardt). Passing 0 will disable refining, so the output matrix will be output of robust method.

Return Value

Type: Mat
Output 2D affine transformation matrix 2×3 or empty matrix if transformation could not be estimated.
See Also

Reference

CvInvoke Class
EstimateAffine2D Overload
Emgu.CV Namespace


CvInvoke.EstimateAffine3D Method

CvInvokeEstimateAffine3D Method

Overload List
Name | Description
EstimateAffine3D(IInputArray, IInputArray, IOutputArray, IOutputArray, Double, Double) | Computes an optimal affine transformation between two 3D point sets.
EstimateAffine3D(MCvPoint3D32f, MCvPoint3D32f, MatrixDouble, Byte, Double, Double) | Computes an optimal affine transformation between two 3D point sets.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.EstimateAffine3D Method (IInputArray, IInputArray, IOutputArray, IOutputArray, Double, Double)

CvInvokeEstimateAffine3D Method (IInputArray, IInputArray, IOutputArray, IOutputArray, Double, Double)

http://www.emgu.com
Computes an optimal affine transformation between two 3D point sets.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int EstimateAffine3D(
    IInputArray src,
    IInputArray dst,
    IOutputArray affineEstimate,
    IOutputArray inliers,
    double ransacThreshold = 3,
    double confidence = 0.99
)
Public Shared Function EstimateAffine3D (
    src As IInputArray,
    dst As IInputArray,
    affineEstimate As IOutputArray,
    inliers As IOutputArray,
    Optional ransacThreshold As Double = 3,
    Optional confidence As Double = 0.99
) As Integer
public:
static int EstimateAffine3D(
    IInputArray^ src,
    IInputArray^ dst,
    IOutputArray^ affineEstimate,
    IOutputArray^ inliers,
    double ransacThreshold = 3,
    double confidence = 0.99
)
static member EstimateAffine3D :
        src : IInputArray *
        dst : IInputArray *
        affineEstimate : IOutputArray *
        inliers : IOutputArray *
        ?ransacThreshold : float *
        ?confidence : float
(* Defaults:
        let _ransacThreshold = defaultArg ransacThreshold 3
        let _confidence = defaultArg confidence 0.99
*)
-> int

Parameters

src
Type: Emgu.CVIInputArray
First input 3D point set.
dst
Type: Emgu.CVIInputArray
Second input 3D point set.
affineEstimate
Type: Emgu.CVIOutputArray
Output 3D affine transformation matrix 3 x 4
inliers
Type: Emgu.CVIOutputArray
Output vector indicating which points are inliers.
ransacThreshold (Optional)
Type: SystemDouble
Maximum reprojection error in the RANSAC algorithm to consider a point as an inlier.
confidence (Optional)
Type: SystemDouble
Confidence level, between 0 and 1, for the estimated transformation. Anything between 0.95 and 0.99 is usually good enough. Values too close to 1 can slow down the estimation significantly. Values lower than 0.8-0.9 can result in an incorrectly estimated transformation.

Return Value

Type: Int32
the result
See Also

Reference

CvInvoke Class
EstimateAffine3D Overload
Emgu.CV Namespace


CvInvoke.EstimateAffine3D Method (MCvPoint3D32f[], MCvPoint3D32f[], Matrix(Double), Byte[], Double, Double)

CvInvokeEstimateAffine3D Method (MCvPoint3D32f, MCvPoint3D32f, MatrixDouble, Byte, Double, Double)

http://www.emgu.com
Computes an optimal affine transformation between two 3D point sets.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int EstimateAffine3D(
    MCvPoint3D32f[] src,
    MCvPoint3D32f[] dst,
    out Matrix<double> estimate,
    out byte[] inliers,
    double ransacThreshold,
    double confidence
)
Public Shared Function EstimateAffine3D (
    src As MCvPoint3D32f(),
    dst As MCvPoint3D32f(),
    <OutAttribute> ByRef estimate As Matrix(Of Double),
    <OutAttribute> ByRef inliers As Byte(),
    ransacThreshold As Double,
    confidence As Double
) As Integer
public:
static int EstimateAffine3D(
    array<MCvPoint3D32f^>^ src,
    array<MCvPoint3D32f^>^ dst,
    [OutAttribute] Matrix<double>^% estimate,
    [OutAttribute] array<unsigned char>^% inliers,
    double ransacThreshold,
    double confidence
)
static member EstimateAffine3D :
        src : MCvPoint3D32f[] *
        dst : MCvPoint3D32f[] *
        estimate : Matrix<float> byref *
        inliers : byte[] byref *
        ransacThreshold : float *
        confidence : float -> int

Parameters

src
Type: Emgu.CV.StructureMCvPoint3D32f
First input 3D point set.
dst
Type: Emgu.CV.StructureMCvPoint3D32f
Second input 3D point set.
estimate
Type: Emgu.CVMatrix Double
Output 3D affine transformation matrix.
inliers
Type: SystemByte
Output vector indicating which points are inliers.
ransacThreshold
Type: SystemDouble
Maximum reprojection error in the RANSAC algorithm to consider a point as an inlier.
confidence
Type: SystemDouble
Confidence level, between 0 and 1, for the estimated transformation. Anything between 0.95 and 0.99 is usually good enough. Values too close to 1 can slow down the estimation significantly. Values lower than 0.8-0.9 can result in an incorrectly estimated transformation.

Return Value

Type: Int32
The result
See Also

Reference

CvInvoke Class
EstimateAffine3D Overload
Emgu.CV Namespace


CvInvoke.EstimateAffinePartial2D Method

CvInvokeEstimateAffinePartial2D Method

Computes an optimal limited affine transformation with 4 degrees of freedom between two 2D point sets.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat EstimateAffinePartial2D(
    IInputArray from,
    IInputArray to,
    IOutputArray inliners,
    RobustEstimationAlgorithm method,
    double ransacReprojThreshold,
    int maxIters,
    double confidence,
    int refineIters
)
Public Shared Function EstimateAffinePartial2D (
    from As IInputArray,
    to As IInputArray,
    inliners As IOutputArray,
    method As RobustEstimationAlgorithm,
    ransacReprojThreshold As Double,
    maxIters As Integer,
    confidence As Double,
    refineIters As Integer
) As Mat
public:
static Mat^ EstimateAffinePartial2D(
    IInputArray^ from,
    IInputArray^ to,
    IOutputArray^ inliners,
    RobustEstimationAlgorithm^ method,
    double ransacReprojThreshold,
    int maxIters,
    double confidence,
    int refineIters
)
static member EstimateAffinePartial2D :
        from : IInputArray *
        to : IInputArray *
        inliners : IOutputArray *
        method : RobustEstimationAlgorithm *
        ransacReprojThreshold : float *
        maxIters : int *
        confidence : float *
        refineIters : int -> Mat

Parameters

from
Type: Emgu.CVIInputArray
First input 2D point set.
to
Type: Emgu.CVIInputArray
Second input 2D point set.
inliners
Type: Emgu.CVIOutputArray
Output vector indicating which points are inliers.
method
Type: Emgu.CV.CvEnumRobustEstimationAlgorithm
Robust method used to compute transformation.
ransacReprojThreshold
Type: SystemDouble
Maximum reprojection error in the RANSAC algorithm to consider a point as an inlier. Applies only to RANSAC.
maxIters
Type: SystemInt32
The maximum number of robust method iterations.
confidence
Type: SystemDouble
Confidence level, between 0 and 1, for the estimated transformation. Anything between 0.95 and 0.99 is usually good enough. Values too close to 1 can slow down the estimation significantly. Values lower than 0.8-0.9 can result in an incorrectly estimated transformation.
refineIters
Type: SystemInt32
Maximum number of iterations of refining algorithm (Levenberg-Marquardt). Passing 0 will disable refining, so the output matrix will be output of robust method.

Return Value

Type: Mat
Output 2D affine transformation (4 degrees of freedom) matrix 2×3 or empty matrix if transformation could not be estimated.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Exp Method

CvInvokeExp Method

Calculates exponent of every element of input array: dst(I)=exp(src(I)) Maximum relative error is 7e-6. Currently, the function converts denormalized values to zeros on output

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Exp(
    IInputArray src,
    IOutputArray dst
)
Public Shared Sub Exp (
    src As IInputArray,
    dst As IOutputArray
)
public:
static void Exp(
    IInputArray^ src,
    IOutputArray^ dst
)
static member Exp :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source array
dst
Type: Emgu.CVIOutputArray
The destination array, it should have double type or the same type as the source
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ExtractChannel Method

CvInvokeExtractChannel Method

Extract the specific channel from the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ExtractChannel(
    IInputArray src,
    IOutputArray dst,
    int coi
)
Public Shared Sub ExtractChannel (
    src As IInputArray,
    dst As IOutputArray,
    coi As Integer
)
public:
static void ExtractChannel(
    IInputArray^ src,
    IOutputArray^ dst,
    int coi
)
static member ExtractChannel :
        src : IInputArray *
        dst : IOutputArray *
        coi : int -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
dst
Type: Emgu.CVIOutputArray
The channel
coi
Type: SystemInt32
0 based index of the channel to be extracted
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FastNlMeansDenoising Method

CvInvokeFastNlMeansDenoising Method

Perform image denoising using Non-local Means Denoising algorithm: http://www.ipol.im/pub/algo/bcm_non_local_means_denoising/ with several computational optimizations. Noise expected to be a Gaussian white noise.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FastNlMeansDenoising(
    IInputArray src,
    IOutputArray dst,
    float h = 3f,
    int templateWindowSize = 7,
    int searchWindowSize = 21
)
Public Shared Sub FastNlMeansDenoising (
    src As IInputArray,
    dst As IOutputArray,
    Optional h As Single = 3F,
    Optional templateWindowSize As Integer = 7,
    Optional searchWindowSize As Integer = 21
)
public:
static void FastNlMeansDenoising(
    IInputArray^ src,
    IOutputArray^ dst,
    float h = 3f,
    int templateWindowSize = 7,
    int searchWindowSize = 21
)
static member FastNlMeansDenoising :
        src : IInputArray *
        dst : IOutputArray *
        ?h : float32 *
        ?templateWindowSize : int *
        ?searchWindowSize : int
(* Defaults:
        let _h = defaultArg h 3f
        let _templateWindowSize = defaultArg templateWindowSize 7
        let _searchWindowSize = defaultArg searchWindowSize 21
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 1-channel, 2-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src.
h (Optional)
Type: SystemSingle
Parameter regulating filter strength. Big h value perfectly removes noise but also removes image details, smaller h value preserves details but also preserves some noise.
templateWindowSize (Optional)
Type: SystemInt32
Size in pixels of the template patch that is used to compute weights. Should be odd.
searchWindowSize (Optional)
Type: SystemInt32
Size in pixels of the window that is used to compute weighted average for given pixel. Should be odd. Affect performance linearly: greater searchWindowsSize - greater denoising time.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FastNlMeansDenoisingColored Method

CvInvokeFastNlMeansDenoisingColored Method

Perform image denoising using Non-local Means Denoising algorithm (modified for color image): http://www.ipol.im/pub/algo/bcm_non_local_means_denoising/ with several computational optimizations. Noise expected to be a Gaussian white noise. The function converts image to CIELAB colorspace and then separately denoise L and AB components with given h parameters using fastNlMeansDenoising function.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FastNlMeansDenoisingColored(
    IInputArray src,
    IOutputArray dst,
    float h = 3f,
    float hColor = 3f,
    int templateWindowSize = 7,
    int searchWindowSize = 21
)
Public Shared Sub FastNlMeansDenoisingColored (
    src As IInputArray,
    dst As IOutputArray,
    Optional h As Single = 3F,
    Optional hColor As Single = 3F,
    Optional templateWindowSize As Integer = 7,
    Optional searchWindowSize As Integer = 21
)
public:
static void FastNlMeansDenoisingColored(
    IInputArray^ src,
    IOutputArray^ dst,
    float h = 3f,
    float hColor = 3f,
    int templateWindowSize = 7,
    int searchWindowSize = 21
)
static member FastNlMeansDenoisingColored :
        src : IInputArray *
        dst : IOutputArray *
        ?h : float32 *
        ?hColor : float32 *
        ?templateWindowSize : int *
        ?searchWindowSize : int
(* Defaults:
        let _h = defaultArg h 3f
        let _hColor = defaultArg hColor 3f
        let _templateWindowSize = defaultArg templateWindowSize 7
        let _searchWindowSize = defaultArg searchWindowSize 21
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 1-channel, 2-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src.
h (Optional)
Type: SystemSingle
Parameter regulating filter strength. Big h value perfectly removes noise but also removes image details, smaller h value preserves details but also preserves some noise.
hColor (Optional)
Type: SystemSingle
The same as h but for color components. For most images value equals 10 will be enought to remove colored noise and do not distort colors.
templateWindowSize (Optional)
Type: SystemInt32
Size in pixels of the template patch that is used to compute weights. Should be odd.
searchWindowSize (Optional)
Type: SystemInt32
Size in pixels of the window that is used to compute weighted average for given pixel. Should be odd. Affect performance linearly: greater searchWindowsSize - greater denoising time.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FillConvexPoly Method

CvInvokeFillConvexPoly Method

Fills convex polygon interior. This function is much faster than The function cvFillPoly and can fill not only the convex polygons but any monotonic polygon, i.e. a polygon whose contour intersects every horizontal line (scan line) twice at the most

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FillConvexPoly(
    IInputOutputArray img,
    IInputArray points,
    MCvScalar color,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub FillConvexPoly (
    img As IInputOutputArray,
    points As IInputArray,
    color As MCvScalar,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void FillConvexPoly(
    IInputOutputArray^ img,
    IInputArray^ points,
    MCvScalar^ color,
    LineType^ lineType = 8,
    int shift = 0
)
static member FillConvexPoly :
        img : IInputOutputArray *
        points : IInputArray *
        color : MCvScalar *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image
points
Type: Emgu.CVIInputArray
Array of pointers to a single polygon
color
Type: Emgu.CV.StructureMCvScalar
Polygon color
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the polygon boundaries
shift (Optional)
Type: SystemInt32
Number of fractional bits in the vertex coordinates
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FillPoly Method

CvInvokeFillPoly Method

Fills the area bounded by one or more polygons.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FillPoly(
    IInputOutputArray img,
    IInputArray points,
    MCvScalar color,
    LineType lineType = 8,
    int shift = 0,
    Point offset = null
)
Public Shared Sub FillPoly (
    img As IInputOutputArray,
    points As IInputArray,
    color As MCvScalar,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0,
    Optional offset As Point = Nothing
)
public:
static void FillPoly(
    IInputOutputArray^ img,
    IInputArray^ points,
    MCvScalar^ color,
    LineType^ lineType = 8,
    int shift = 0,
    Point^ offset = nullptr
)
static member FillPoly :
        img : IInputOutputArray *
        points : IInputArray *
        color : MCvScalar *
        ?lineType : LineType *
        ?shift : int *
        ?offset : Point
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
        let _offset = defaultArg offset null
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image.
points
Type: Emgu.CVIInputArray
Array of polygons where each polygon is represented as an array of points.
color
Type: Emgu.CV.StructureMCvScalar
Polygon color
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the polygon boundaries.
shift (Optional)
Type: SystemInt32
Number of fractional bits in the vertex coordinates.
offset (Optional)
Type: System.DrawingPoint
Optional offset of all points of the contours.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Filter2D Method

CvInvokeFilter2D Method

Applies arbitrary linear filter to the image. In-place operation is supported. When the aperture is partially outside the image, the function interpolates outlier pixel values from the nearest pixels that is inside the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Filter2D(
    IInputArray src,
    IOutputArray dst,
    IInputArray kernel,
    Point anchor,
    double delta = 0,
    BorderType borderType = 4
)
Public Shared Sub Filter2D (
    src As IInputArray,
    dst As IOutputArray,
    kernel As IInputArray,
    anchor As Point,
    Optional delta As Double = 0,
    Optional borderType As BorderType = 4
)
public:
static void Filter2D(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ kernel,
    Point^ anchor,
    double delta = 0,
    BorderType^ borderType = 4
)
static member Filter2D :
        src : IInputArray *
        dst : IOutputArray *
        kernel : IInputArray *
        anchor : Point *
        ?delta : float *
        ?borderType : BorderType
(* Defaults:
        let _delta = defaultArg delta 0
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
dst
Type: Emgu.CVIOutputArray
The destination image
kernel
Type: Emgu.CVIInputArray
Convolution kernel, single-channel floating point matrix. If you want to apply different kernels to different channels, split the image using cvSplit into separate color planes and process them individually
anchor
Type: System.DrawingPoint
The anchor of the kernel that indicates the relative position of a filtered point within the kernel. The anchor shoud lie within the kernel. The special default value (-1,-1) means that it is at the kernel center
delta (Optional)
Type: SystemDouble
The optional value added to the filtered pixels before storing them in dst
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The pixel extrapolation method.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FilterSpeckles Method

CvInvokeFilterSpeckles Method

Filters off small noise blobs (speckles) in the disparity map.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FilterSpeckles(
    IInputOutputArray img,
    double newVal,
    int maxSpeckleSize,
    double maxDiff,
    IInputOutputArray buf = null
)
Public Shared Sub FilterSpeckles (
    img As IInputOutputArray,
    newVal As Double,
    maxSpeckleSize As Integer,
    maxDiff As Double,
    Optional buf As IInputOutputArray = Nothing
)
public:
static void FilterSpeckles(
    IInputOutputArray^ img,
    double newVal,
    int maxSpeckleSize,
    double maxDiff,
    IInputOutputArray^ buf = nullptr
)
static member FilterSpeckles :
        img : IInputOutputArray *
        newVal : float *
        maxSpeckleSize : int *
        maxDiff : float *
        ?buf : IInputOutputArray
(* Defaults:
        let _buf = defaultArg buf null
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
The input 16-bit signed disparity image
newVal
Type: SystemDouble
The disparity value used to paint-off the speckles
maxSpeckleSize
Type: SystemInt32
The maximum speckle size to consider it a speckle. Larger blobs are not affected by the algorithm
maxDiff
Type: SystemDouble
Maximum difference between neighbor disparity pixels to put them into the same blob. Note that since StereoBM, StereoSGBM and may be other algorithms return a fixed-point disparity map, where disparity values are multiplied by 16, this scale factor should be taken into account when specifying this parameter value.
buf (Optional)
Type: Emgu.CVIInputOutputArray
The optional temporary buffer to avoid memory allocation within the function.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Find4QuadCornerSubpix Method

CvInvokeFind4QuadCornerSubpix Method

Finds subpixel-accurate positions of the chessboard corners

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool Find4QuadCornerSubpix(
    IInputArray image,
    IInputOutputArray corners,
    Size regionSize
)
Public Shared Function Find4QuadCornerSubpix (
    image As IInputArray,
    corners As IInputOutputArray,
    regionSize As Size
) As Boolean
public:
static bool Find4QuadCornerSubpix(
    IInputArray^ image,
    IInputOutputArray^ corners,
    Size^ regionSize
)
static member Find4QuadCornerSubpix :
        image : IInputArray *
        corners : IInputOutputArray *
        regionSize : Size -> bool

Parameters

image
Type: Emgu.CVIInputArray
Source chessboard view; it must be 8-bit grayscale or color image
corners
Type: Emgu.CVIInputOutputArray
Pointer to the output array of corners(PointF) detected
regionSize
Type: System.DrawingSize
region size

Return Value

Type: Boolean
True if successful
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindChessboardCorners Method

CvInvokeFindChessboardCorners Method

Attempts to determine whether the input image is a view of the chessboard pattern and locate internal chessboard corners

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool FindChessboardCorners(
    IInputArray image,
    Size patternSize,
    IOutputArray corners,
    CalibCbType flags = 3
)
Public Shared Function FindChessboardCorners (
    image As IInputArray,
    patternSize As Size,
    corners As IOutputArray,
    Optional flags As CalibCbType = 3
) As Boolean
public:
static bool FindChessboardCorners(
    IInputArray^ image,
    Size^ patternSize,
    IOutputArray^ corners,
    CalibCbType^ flags = 3
)
static member FindChessboardCorners :
        image : IInputArray *
        patternSize : Size *
        corners : IOutputArray *
        ?flags : CalibCbType
(* Defaults:
        let _flags = defaultArg flags 3
*)
-> bool

Parameters

image
Type: Emgu.CVIInputArray
Source chessboard view; it must be 8-bit grayscale or color image
patternSize
Type: System.DrawingSize
The number of inner corners per chessboard row and column
corners
Type: Emgu.CVIOutputArray
Pointer to the output array of corners(PointF) detected
flags (Optional)
Type: Emgu.CV.CvEnumCalibCbType
Various operation flags

Return Value

Type: Boolean
True if all the corners have been found and they have been placed in a certain order (row by row, left to right in every row), otherwise, if the function fails to find all the corners or reorder them, it returns 0
Remarks
The coordinates detected are approximate, and to determine their position more accurately, the user may use the function cvFindCornerSubPix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindChessboardCornersSB Method

CvInvokeFindChessboardCornersSB Method

Finds the positions of internal corners of the chessboard using a sector based approach.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool FindChessboardCornersSB(
    IInputArray image,
    Size patternSize,
    IOutputArray corners,
    CalibCbType flags = 0
)
Public Shared Function FindChessboardCornersSB (
    image As IInputArray,
    patternSize As Size,
    corners As IOutputArray,
    Optional flags As CalibCbType = 0
) As Boolean
public:
static bool FindChessboardCornersSB(
    IInputArray^ image,
    Size^ patternSize,
    IOutputArray^ corners,
    CalibCbType^ flags = 0
)
static member FindChessboardCornersSB :
        image : IInputArray *
        patternSize : Size *
        corners : IOutputArray *
        ?flags : CalibCbType
(* Defaults:
        let _flags = defaultArg flags 0
*)
-> bool

Parameters

image
Type: Emgu.CVIInputArray
Source chessboard view. It must be an 8-bit grayscale or color image.
patternSize
Type: System.DrawingSize
Number of inner corners per a chessboard row and column ( patternSize = cv::Size(points_per_row,points_per_colum) = cv::Size(columns,rows) ).
corners
Type: Emgu.CVIOutputArray
Output array of detected corners.
flags (Optional)
Type: Emgu.CV.CvEnumCalibCbType
Various operation flags

Return Value

Type: Boolean
True if chessboard corners found
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindCirclesGrid Method

CvInvokeFindCirclesGrid Method

Overload List
Name | Description
FindCirclesGrid(ImageGray, Byte, Size, CalibCgType, Feature2D) | Finds centers in the grid of circles
FindCirclesGrid(IInputArray, Size, IOutputArray, CalibCgType, Feature2D) | Finds centers in the grid of circles
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindCirclesGrid Method (Image(Gray, Byte), Size, CalibCgType, Feature2D)

CvInvokeFindCirclesGrid Method (ImageGray, Byte, Size, CalibCgType, Feature2D)

http://www.emgu.com
Finds centers in the grid of circles

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static PointF[] FindCirclesGrid(
    Image<Gray, byte> image,
    Size patternSize,
    CalibCgType flags,
    Feature2D featureDetector
)
Public Shared Function FindCirclesGrid (
    image As Image(Of Gray, Byte),
    patternSize As Size,
    flags As CalibCgType,
    featureDetector As Feature2D
) As PointF()
public:
static array<PointF^>^ FindCirclesGrid(
    Image<Gray^, unsigned char>^ image,
    Size^ patternSize,
    CalibCgType^ flags,
    Feature2D^ featureDetector
)
static member FindCirclesGrid :
        image : Image<Gray, byte> *
        patternSize : Size *
        flags : CalibCgType *
        featureDetector : Feature2D -> PointF[]

Parameters

image
Type: Emgu.CVImage Gray, Byte
Source chessboard view
patternSize
Type: System.DrawingSize
The number of inner circle per chessboard row and column
flags
Type: Emgu.CV.CvEnumCalibCgType
Various operation flags
featureDetector
Type: Emgu.CV.Features2DFeature2D
The feature detector. Use a SimpleBlobDetector for default

Return Value

Type: PointF
The center of circles detected if the chess board pattern is found, otherwise null is returned
See Also

Reference

CvInvoke Class
FindCirclesGrid Overload
Emgu.CV Namespace


CvInvoke.FindCirclesGrid Method (IInputArray, Size, IOutputArray, CalibCgType, Feature2D)

CvInvokeFindCirclesGrid Method (IInputArray, Size, IOutputArray, CalibCgType, Feature2D)

http://www.emgu.com
Finds centers in the grid of circles

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool FindCirclesGrid(
    IInputArray image,
    Size patternSize,
    IOutputArray centers,
    CalibCgType flags,
    Feature2D featureDetector
)
Public Shared Function FindCirclesGrid (
    image As IInputArray,
    patternSize As Size,
    centers As IOutputArray,
    flags As CalibCgType,
    featureDetector As Feature2D
) As Boolean
public:
static bool FindCirclesGrid(
    IInputArray^ image,
    Size^ patternSize,
    IOutputArray^ centers,
    CalibCgType^ flags,
    Feature2D^ featureDetector
)
static member FindCirclesGrid :
        image : IInputArray *
        patternSize : Size *
        centers : IOutputArray *
        flags : CalibCgType *
        featureDetector : Feature2D -> bool

Parameters

image
Type: Emgu.CVIInputArray
Source chessboard view
patternSize
Type: System.DrawingSize
The number of inner circle per chessboard row and column
centers
Type: Emgu.CVIOutputArray
output array of detected centers.
flags
Type: Emgu.CV.CvEnumCalibCgType
Various operation flags
featureDetector
Type: Emgu.CV.Features2DFeature2D
The feature detector. Use a SimpleBlobDetector for default

Return Value

Type: Boolean
True if grid found.
See Also

Reference

CvInvoke Class
FindCirclesGrid Overload
Emgu.CV Namespace


CvInvoke.FindContours Method

CvInvokeFindContours Method

Retrieves contours from the binary image and returns the number of retrieved contours. The pointer firstContour is filled by the function. It will contain pointer to the first most outer contour or IntPtr.Zero if no contours is detected (if the image is completely black). Other contours may be reached from firstContour using h_next and v_next links. The sample in cvDrawContours discussion shows how to use contours for connected component detection. Contours can be also used for shape analysis and object recognition - see squares.c in OpenCV sample directory The function modifies the source image content

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FindContours(
    IInputOutputArray image,
    IOutputArray contours,
    IOutputArray hierarchy,
    RetrType mode,
    ChainApproxMethod method,
    Point offset = null
)
Public Shared Sub FindContours (
    image As IInputOutputArray,
    contours As IOutputArray,
    hierarchy As IOutputArray,
    mode As RetrType,
    method As ChainApproxMethod,
    Optional offset As Point = Nothing
)
public:
static void FindContours(
    IInputOutputArray^ image,
    IOutputArray^ contours,
    IOutputArray^ hierarchy,
    RetrType^ mode,
    ChainApproxMethod^ method,
    Point^ offset = nullptr
)
static member FindContours :
        image : IInputOutputArray *
        contours : IOutputArray *
        hierarchy : IOutputArray *
        mode : RetrType *
        method : ChainApproxMethod *
        ?offset : Point
(* Defaults:
        let _offset = defaultArg offset null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
The source 8-bit single channel image. Non-zero pixels are treated as 1s, zero pixels remain 0s - that is image treated as binary. To get such a binary image from grayscale, one may use cvThreshold, cvAdaptiveThreshold or cvCanny. The function modifies the source image content
contours
Type: Emgu.CVIOutputArray
Detected contours. Each contour is stored as a vector of points.
hierarchy
Type: Emgu.CVIOutputArray
Optional output vector, containing information about the image topology.
mode
Type: Emgu.CV.CvEnumRetrType
Retrieval mode
method
Type: Emgu.CV.CvEnumChainApproxMethod
Approximation method (for all the modes, except CV_RETR_RUNS, which uses built-in approximation).
offset (Optional)
Type: System.DrawingPoint
Offset, by which every contour point is shifted. This is useful if the contours are extracted from the image ROI and then they should be analyzed in the whole image context

Return Value

Type:
The number of countours
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindContourTree Method

CvInvokeFindContourTree Method

Retrieves contours from the binary image as a contour tree. The pointer firstContour is filled by the function. It is provided as a convenient way to obtain the hierarchy value as int[,]. The function modifies the source image content

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int[,] FindContourTree(
    IInputOutputArray image,
    IOutputArray contours,
    ChainApproxMethod method,
    Point offset = null
)
Public Shared Function FindContourTree (
    image As IInputOutputArray,
    contours As IOutputArray,
    method As ChainApproxMethod,
    Optional offset As Point = Nothing
) As Integer(,)
public:
static array<int,2>^ FindContourTree(
    IInputOutputArray^ image,
    IOutputArray^ contours,
    ChainApproxMethod^ method,
    Point^ offset = nullptr
)
static member FindContourTree :
        image : IInputOutputArray *
        contours : IOutputArray *
        method : ChainApproxMethod *
        ?offset : Point
(* Defaults:
        let _offset = defaultArg offset null
*)
-> int[,]

Parameters

image
Type: Emgu.CVIInputOutputArray
The source 8-bit single channel image. Non-zero pixels are treated as 1s, zero pixels remain 0s - that is image treated as binary. To get such a binary image from grayscale, one may use cvThreshold, cvAdaptiveThreshold or cvCanny. The function modifies the source image content
contours
Type: Emgu.CVIOutputArray
Detected contours. Each contour is stored as a vector of points.
method
Type: Emgu.CV.CvEnumChainApproxMethod
Approximation method (for all the modes, except CV_RETR_RUNS, which uses built-in approximation).
offset (Optional)
Type: System.DrawingPoint
Offset, by which every contour point is shifted. This is useful if the contours are extracted from the image ROI and then they should be analyzed in the whole image context

Return Value

Type: Int32
The contour hierarchy
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindEssentialMat Method

CvInvokeFindEssentialMat Method

Calculates an essential matrix from the corresponding points in two images.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat FindEssentialMat(
    IInputArray points1,
    IInputArray points2,
    IInputArray cameraMatrix,
    FmType method = 10,
    double prob = 0.999,
    double threshold = 1,
    IOutputArray mask = null
)
Public Shared Function FindEssentialMat (
    points1 As IInputArray,
    points2 As IInputArray,
    cameraMatrix As IInputArray,
    Optional method As FmType = 10,
    Optional prob As Double = 0.999,
    Optional threshold As Double = 1,
    Optional mask As IOutputArray = Nothing
) As Mat
public:
static Mat^ FindEssentialMat(
    IInputArray^ points1,
    IInputArray^ points2,
    IInputArray^ cameraMatrix,
    FmType^ method = 10,
    double prob = 0.999,
    double threshold = 1,
    IOutputArray^ mask = nullptr
)
static member FindEssentialMat :
        points1 : IInputArray *
        points2 : IInputArray *
        cameraMatrix : IInputArray *
        ?method : FmType *
        ?prob : float *
        ?threshold : float *
        ?mask : IOutputArray
(* Defaults:
        let _method = defaultArg method 10
        let _prob = defaultArg prob 0.999
        let _threshold = defaultArg threshold 1
        let _mask = defaultArg mask null
*)
-> Mat

Parameters

points1
Type: Emgu.CVIInputArray
Array of N (N >= 5) 2D points from the first image. The point coordinates should be floating-point (single or double precision).
points2
Type: Emgu.CVIInputArray
Array of the second image points of the same size and format as points1
cameraMatrix
Type: Emgu.CVIInputArray
Camera matrix K=[[fx 0 cx][0 fy cy][0 0 1]]. Note that this function assumes that points1 and points2 are feature points from cameras with the same camera matrix.
method (Optional)
Type: Emgu.CV.CvEnumFmType
Method for computing a fundamental matrix. RANSAC for the RANSAC algorithm. LMEDS for the LMedS algorithm
prob (Optional)
Type: SystemDouble
Parameter used for the RANSAC or LMedS methods only. It specifies a desirable level of confidence (probability) that the estimated matrix is correct.
threshold (Optional)
Type: SystemDouble
Parameter used for RANSAC. It is the maximum distance from a point to an epipolar line in pixels, beyond which the point is considered an outlier and is not used for computing the final fundamental matrix. It can be set to something like 1-3, depending on the accuracy of the point localization, image resolution, and the image noise.
mask (Optional)
Type: Emgu.CVIOutputArray
Output array of N elements, every element of which is set to 0 for outliers and to 1 for the other points. The array is computed only in the RANSAC and LMedS methods.

Return Value

Type: Mat
The essential mat
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindFundamentalMat Method

CvInvokeFindFundamentalMat Method

Calculates fundamental matrix using one of four methods listed above and returns the number of fundamental matrices found (1 or 3) and 0, if no matrix is found.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat FindFundamentalMat(
    IInputArray points1,
    IInputArray points2,
    FmType method = 10,
    double param1 = 3,
    double param2 = 0.99,
    IOutputArray mask = null
)
Public Shared Function FindFundamentalMat (
    points1 As IInputArray,
    points2 As IInputArray,
    Optional method As FmType = 10,
    Optional param1 As Double = 3,
    Optional param2 As Double = 0.99,
    Optional mask As IOutputArray = Nothing
) As Mat
public:
static Mat^ FindFundamentalMat(
    IInputArray^ points1,
    IInputArray^ points2,
    FmType^ method = 10,
    double param1 = 3,
    double param2 = 0.99,
    IOutputArray^ mask = nullptr
)
static member FindFundamentalMat :
        points1 : IInputArray *
        points2 : IInputArray *
        ?method : FmType *
        ?param1 : float *
        ?param2 : float *
        ?mask : IOutputArray
(* Defaults:
        let _method = defaultArg method 10
        let _param1 = defaultArg param1 3
        let _param2 = defaultArg param2 0.99
        let _mask = defaultArg mask null
*)
-> Mat

Parameters

points1
Type: Emgu.CVIInputArray
Array of N points from the first image. The point coordinates should be floating-point (single or double precision).
points2
Type: Emgu.CVIInputArray
Array of the second image points of the same size and format as points1
method (Optional)
Type: Emgu.CV.CvEnumFmType
Method for computing the fundamental matrix
param1 (Optional)
Type: SystemDouble
Parameter used for RANSAC. It is the maximum distance from a point to an epipolar line in pixels, beyond which the point is considered an outlier and is not used for computing the final fundamental matrix. It can be set to something like 1-3, depending on the accuracy of the point localization, image resolution, and the image noise.
param2 (Optional)
Type: SystemDouble
Parameter used for the RANSAC or LMedS methods only. It specifies a desirable level of confidence (probability) that the estimated matrix is correct.
mask (Optional)
Type: Emgu.CVIOutputArray
The optional pointer to output array of N elements, every element of which is set to 0 for outliers and to 1 for the "inliers", i.e. points that comply well with the estimated epipolar geometry. The array is computed only in RANSAC and LMedS methods. For other methods it is set to all 1.

Return Value

Type: Mat
The calculated fundamental matrix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindHomography Method

CvInvokeFindHomography Method

Overload List
Name | Description
FindHomography(PointF, PointF, RobustEstimationAlgorithm, Double, IOutputArray) | Finds perspective transformation H=||h_ij|| between the source and the destination planes
FindHomography(IInputArray, IInputArray, RobustEstimationAlgorithm, Double, IOutputArray) | Finds perspective transformation H=||hij|| between the source and the destination planes
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindHomography Method (PointF[], PointF[], RobustEstimationAlgorithm, Double, IOutputArray)

CvInvokeFindHomography Method (PointF, PointF, RobustEstimationAlgorithm, Double, IOutputArray)

http://www.emgu.com
Finds perspective transformation H=||h_ij|| between the source and the destination planes

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat FindHomography(
    PointF[] srcPoints,
    PointF[] dstPoints,
    RobustEstimationAlgorithm method = 0,
    double ransacReprojThreshold = 3,
    IOutputArray mask = null
)
Public Shared Function FindHomography (
    srcPoints As PointF(),
    dstPoints As PointF(),
    Optional method As RobustEstimationAlgorithm = 0,
    Optional ransacReprojThreshold As Double = 3,
    Optional mask As IOutputArray = Nothing
) As Mat
public:
static Mat^ FindHomography(
    array<PointF^>^ srcPoints,
    array<PointF^>^ dstPoints,
    RobustEstimationAlgorithm^ method = 0,
    double ransacReprojThreshold = 3,
    IOutputArray^ mask = nullptr
)
static member FindHomography :
        srcPoints : PointF[] *
        dstPoints : PointF[] *
        ?method : RobustEstimationAlgorithm *
        ?ransacReprojThreshold : float *
        ?mask : IOutputArray
(* Defaults:
        let _method = defaultArg method 0
        let _ransacReprojThreshold = defaultArg ransacReprojThreshold 3
        let _mask = defaultArg mask null
*)
-> Mat

Parameters

srcPoints
Type: System.DrawingPointF
Point coordinates in the original plane
dstPoints
Type: System.DrawingPointF
Point coordinates in the destination plane
method (Optional)
Type: Emgu.CV.CvEnumRobustEstimationAlgorithm
FindHomography method
ransacReprojThreshold (Optional)
Type: SystemDouble
The maximum allowed reprojection error to treat a point pair as an inlier. The parameter is only used in RANSAC-based homography estimation. E.g. if dst_points coordinates are measured in pixels with pixel-accurate precision, it makes sense to set this parameter somewhere in the range ~1..3
mask (Optional)
Type: Emgu.CVIOutputArray
Optional output mask set by a robust method ( CV_RANSAC or CV_LMEDS ). Note that the input mask values are ignored.

Return Value

Type: Mat
The 3x3 homography matrix if found. Null if not found.
See Also

Reference

CvInvoke Class
FindHomography Overload
Emgu.CV Namespace


CvInvoke.FindHomography Method (IInputArray, IInputArray, RobustEstimationAlgorithm, Double, IOutputArray)

CvInvokeFindHomography Method (IInputArray, IInputArray, RobustEstimationAlgorithm, Double, IOutputArray)

http://www.emgu.com
Finds perspective transformation H=||hij|| between the source and the destination planes

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat FindHomography(
    IInputArray srcPoints,
    IInputArray dstPoints,
    RobustEstimationAlgorithm method = 0,
    double ransacReprojThreshold = 3,
    IOutputArray mask = null
)
Public Shared Function FindHomography (
    srcPoints As IInputArray,
    dstPoints As IInputArray,
    Optional method As RobustEstimationAlgorithm = 0,
    Optional ransacReprojThreshold As Double = 3,
    Optional mask As IOutputArray = Nothing
) As Mat
public:
static Mat^ FindHomography(
    IInputArray^ srcPoints,
    IInputArray^ dstPoints,
    RobustEstimationAlgorithm^ method = 0,
    double ransacReprojThreshold = 3,
    IOutputArray^ mask = nullptr
)
static member FindHomography :
        srcPoints : IInputArray *
        dstPoints : IInputArray *
        ?method : RobustEstimationAlgorithm *
        ?ransacReprojThreshold : float *
        ?mask : IOutputArray
(* Defaults:
        let _method = defaultArg method 0
        let _ransacReprojThreshold = defaultArg ransacReprojThreshold 3
        let _mask = defaultArg mask null
*)
-> Mat

Parameters

srcPoints
Type: Emgu.CVIInputArray
Point coordinates in the original plane, 2xN, Nx2, 3xN or Nx3 array (the latter two are for representation in homogeneous coordinates), where N is the number of points.
dstPoints
Type: Emgu.CVIInputArray
Point coordinates in the destination plane, 2xN, Nx2, 3xN or Nx3 array (the latter two are for representation in homogeneous coordinates)
method (Optional)
Type: Emgu.CV.CvEnumRobustEstimationAlgorithm
The type of the method
ransacReprojThreshold (Optional)
Type: SystemDouble
The maximum allowed re-projection error to treat a point pair as an inlier. The parameter is only used in RANSAC-based homography estimation. E.g. if dst_points coordinates are measured in pixels with pixel-accurate precision, it makes sense to set this parameter somewhere in the range ~1..3
mask (Optional)
Type: Emgu.CVIOutputArray
The optional output mask set by a robust method (RANSAC or LMEDS).

Return Value

Type: Mat
Output 3x3 homography matrix. Homography matrix is determined up to a scale, thus it is normalized to make h33=1
See Also

Reference

CvInvoke Class
FindHomography Overload
Emgu.CV Namespace


CvInvoke.FindNonZero Method

CvInvokeFindNonZero Method

Find the location of the non-zero pixel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FindNonZero(
    IInputArray src,
    IOutputArray idx
)
Public Shared Sub FindNonZero (
    src As IInputArray,
    idx As IOutputArray
)
public:
static void FindNonZero(
    IInputArray^ src,
    IOutputArray^ idx
)
static member FindNonZero :
        src : IInputArray *
        idx : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source array
idx
Type: Emgu.CVIOutputArray
The output array where the location of the pixels are sorted
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FindTransformECC Method

CvInvokeFindTransformECC Method

Finds the geometric transform (warp) between two images in terms of the ECC criterion

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double FindTransformECC(
    IInputArray templateImage,
    IInputArray inputImage,
    IInputOutputArray warpMatrix,
    MotionType motionType,
    MCvTermCriteria criteria,
    IInputArray inputMask = null
)
Public Shared Function FindTransformECC (
    templateImage As IInputArray,
    inputImage As IInputArray,
    warpMatrix As IInputOutputArray,
    motionType As MotionType,
    criteria As MCvTermCriteria,
    Optional inputMask As IInputArray = Nothing
) As Double
public:
static double FindTransformECC(
    IInputArray^ templateImage,
    IInputArray^ inputImage,
    IInputOutputArray^ warpMatrix,
    MotionType^ motionType,
    MCvTermCriteria^ criteria,
    IInputArray^ inputMask = nullptr
)
static member FindTransformECC :
        templateImage : IInputArray *
        inputImage : IInputArray *
        warpMatrix : IInputOutputArray *
        motionType : MotionType *
        criteria : MCvTermCriteria *
        ?inputMask : IInputArray
(* Defaults:
        let _inputMask = defaultArg inputMask null
*)
-> float

Parameters

templateImage
Type: Emgu.CVIInputArray
single-channel template image; CV_8U or CV_32F array.
inputImage
Type: Emgu.CVIInputArray
single-channel input image which should be warped with the final warpMatrix in order to provide an image similar to templateImage, same type as temlateImage.
warpMatrix
Type: Emgu.CVIInputOutputArray
floating-point 2×3 or 3×3 mapping matrix (warp).
motionType
Type: Emgu.CV.CvEnumMotionType
Specifying the type of motion. Use Affine for default
criteria
Type: Emgu.CV.StructureMCvTermCriteria
specifying the termination criteria of the ECC algorithm; criteria.epsilon defines the threshold of the increment in the correlation coefficient between two iterations (a negative criteria.epsilon makes criteria.maxcount the only termination criterion). Default values can use 50 iteration and 0.001 eps.
inputMask (Optional)
Type: Emgu.CVIInputArray
An optional mask to indicate valid values of inputImage.

Return Value

Type: Double
The final enhanced correlation coefficient, that is the correlation coefficient between the template image and the final warped input image.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FitEllipse Method

CvInvokeFitEllipse Method

Fits an ellipse around a set of 2D points.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotatedRect FitEllipse(
    IInputArray points
)
Public Shared Function FitEllipse (
    points As IInputArray
) As RotatedRect
public:
static RotatedRect^ FitEllipse(
    IInputArray^ points
)
static member FitEllipse :
        points : IInputArray -> RotatedRect

Parameters

points
Type: Emgu.CVIInputArray
Input 2D point set

Return Value

Type: RotatedRect
The ellipse that fits best (in least-squares sense) to a set of 2D points
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FitEllipseAMS Method

CvInvokeFitEllipseAMS Method

The function calculates the ellipse that fits a set of 2D points. The Approximate Mean Square (AMS) is used.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotatedRect FitEllipseAMS(
    IInputArray points
)
Public Shared Function FitEllipseAMS (
    points As IInputArray
) As RotatedRect
public:
static RotatedRect^ FitEllipseAMS(
    IInputArray^ points
)
static member FitEllipseAMS :
        points : IInputArray -> RotatedRect

Parameters

points
Type: Emgu.CVIInputArray
Input 2D point set

Return Value

Type: RotatedRect
The rotated rectangle in which the ellipse is inscribed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FitEllipseDirect Method

CvInvokeFitEllipseDirect Method

The function calculates the ellipse that fits a set of 2D points. The Direct least square (Direct) method by [58] is used.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotatedRect FitEllipseDirect(
    IInputArray points
)
Public Shared Function FitEllipseDirect (
    points As IInputArray
) As RotatedRect
public:
static RotatedRect^ FitEllipseDirect(
    IInputArray^ points
)
static member FitEllipseDirect :
        points : IInputArray -> RotatedRect

Parameters

points
Type: Emgu.CVIInputArray
Input 2D point set

Return Value

Type: RotatedRect
The rotated rectangle in which the ellipse is inscribed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FitLine Method

CvInvokeFitLine Method

Overload List
Name | Description
FitLine(IInputArray, IOutputArray, DistType, Double, Double, Double) | Fits line to 2D or 3D point set
FitLine(PointF, PointF, PointF, DistType, Double, Double, Double) | Fits line to 2D or 3D point set
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FitLine Method (IInputArray, IOutputArray, DistType, Double, Double, Double)

CvInvokeFitLine Method (IInputArray, IOutputArray, DistType, Double, Double, Double)

http://www.emgu.com
Fits line to 2D or 3D point set

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FitLine(
    IInputArray points,
    IOutputArray line,
    DistType distType,
    double param,
    double reps,
    double aeps
)
Public Shared Sub FitLine (
    points As IInputArray,
    line As IOutputArray,
    distType As DistType,
    param As Double,
    reps As Double,
    aeps As Double
)
public:
static void FitLine(
    IInputArray^ points,
    IOutputArray^ line,
    DistType^ distType,
    double param,
    double reps,
    double aeps
)
static member FitLine :
        points : IInputArray *
        line : IOutputArray *
        distType : DistType *
        param : float *
        reps : float *
        aeps : float -> unit

Parameters

points
Type: Emgu.CVIInputArray
Input vector of 2D or 3D points, stored in std::vector or Mat.
line
Type: Emgu.CVIOutputArray
Output line parameters. In case of 2D fitting, it should be a vector of 4 elements (like Vec4f) - (vx, vy, x0, y0), where (vx, vy) is a normalized vector collinear to the line and (x0, y0) is a point on the line. In case of 3D fitting, it should be a vector of 6 elements (like Vec6f) - (vx, vy, vz, x0, y0, z0), where (vx, vy, vz) is a normalized vector collinear to the line and (x0, y0, z0) is a point on the line.
distType
Type: Emgu.CV.CvEnumDistType
The distance used for fitting
param
Type: SystemDouble
Numerical parameter (C) for some types of distances, if 0 then some optimal value is chosen
reps
Type: SystemDouble
Sufficient accuracy for radius (distance between the coordinate origin and the line), 0.01 would be a good default
aeps
Type: SystemDouble
Sufficient accuracy for angle, 0.01 would be a good default
See Also

Reference

CvInvoke Class
FitLine Overload
Emgu.CV Namespace


CvInvoke.FitLine Method (PointF[], PointF, PointF, DistType, Double, Double, Double)

CvInvokeFitLine Method (PointF, PointF, PointF, DistType, Double, Double, Double)

http://www.emgu.com
Fits line to 2D or 3D point set

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FitLine(
    PointF[] points,
    out PointF direction,
    out PointF pointOnLine,
    DistType distType,
    double param,
    double reps,
    double aeps
)
Public Shared Sub FitLine (
    points As PointF(),
    <OutAttribute> ByRef direction As PointF,
    <OutAttribute> ByRef pointOnLine As PointF,
    distType As DistType,
    param As Double,
    reps As Double,
    aeps As Double
)
public:
static void FitLine(
    array<PointF^>^ points,
    [OutAttribute] PointF^% direction,
    [OutAttribute] PointF^% pointOnLine,
    DistType^ distType,
    double param,
    double reps,
    double aeps
)
static member FitLine :
        points : PointF[] *
        direction : PointF byref *
        pointOnLine : PointF byref *
        distType : DistType *
        param : float *
        reps : float *
        aeps : float -> unit

Parameters

points
Type: System.DrawingPointF
Input vector of 2D points.
direction
Type: System.DrawingPointF
A normalized vector collinear to the line
pointOnLine
Type: System.DrawingPointF
A point on the line.
distType
Type: Emgu.CV.CvEnumDistType
The distance used for fitting
param
Type: SystemDouble
Numerical parameter (C) for some types of distances, if 0 then some optimal value is chosen
reps
Type: SystemDouble
Sufficient accuracy for radius (distance between the coordinate origin and the line), 0.01 would be a good default
aeps
Type: SystemDouble
Sufficient accuracy for angle, 0.01 would be a good default
See Also

Reference

CvInvoke Class
FitLine Overload
Emgu.CV Namespace


CvInvoke.Flip Method

CvInvokeFlip Method

Flips the array in one of different 3 ways (row and column indices are 0-based)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Flip(
    IInputArray src,
    IOutputArray dst,
    FlipType flipType
)
Public Shared Sub Flip (
    src As IInputArray,
    dst As IOutputArray,
    flipType As FlipType
)
public:
static void Flip(
    IInputArray^ src,
    IOutputArray^ dst,
    FlipType^ flipType
)
static member Flip :
        src : IInputArray *
        dst : IOutputArray *
        flipType : FlipType -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source array.
dst
Type: Emgu.CVIOutputArray
Destination array.
flipType
Type: Emgu.CV.CvEnumFlipType
Specifies how to flip the array.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.FloodFill Method

CvInvokeFloodFill Method

Fills a connected component with given color.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int FloodFill(
    IInputOutputArray src,
    IInputOutputArray mask,
    Point seedPoint,
    MCvScalar newVal,
    out Rectangle rect,
    MCvScalar loDiff,
    MCvScalar upDiff,
    Connectivity connectivity = 4,
    FloodFillType flags = 0
)
Public Shared Function FloodFill (
    src As IInputOutputArray,
    mask As IInputOutputArray,
    seedPoint As Point,
    newVal As MCvScalar,
    <OutAttribute> ByRef rect As Rectangle,
    loDiff As MCvScalar,
    upDiff As MCvScalar,
    Optional connectivity As Connectivity = 4,
    Optional flags As FloodFillType = 0
) As Integer
public:
static int FloodFill(
    IInputOutputArray^ src,
    IInputOutputArray^ mask,
    Point^ seedPoint,
    MCvScalar^ newVal,
    [OutAttribute] Rectangle^% rect,
    MCvScalar^ loDiff,
    MCvScalar^ upDiff,
    Connectivity^ connectivity = 4,
    FloodFillType^ flags = 0
)
static member FloodFill :
        src : IInputOutputArray *
        mask : IInputOutputArray *
        seedPoint : Point *
        newVal : MCvScalar *
        rect : Rectangle byref *
        loDiff : MCvScalar *
        upDiff : MCvScalar *
        ?connectivity : Connectivity *
        ?flags : FloodFillType
(* Defaults:
        let _connectivity = defaultArg connectivity 4
        let _flags = defaultArg flags 0
*)
-> int

Parameters

src
Type: Emgu.CVIInputOutputArray
Input 1- or 3-channel, 8-bit or floating-point image. It is modified by the function unless CV_FLOODFILL_MASK_ONLY flag is set.
mask
Type: Emgu.CVIInputOutputArray
Operation mask, should be singe-channel 8-bit image, 2 pixels wider and 2 pixels taller than image. If not IntPtr.Zero, the function uses and updates the mask, so user takes responsibility of initializing mask content. Floodfilling can't go across non-zero pixels in the mask, for example, an edge detector output can be used as a mask to stop filling at edges. Or it is possible to use the same mask in multiple calls to the function to make sure the filled area do not overlap. Note: because mask is larger than the filled image, pixel in mask that corresponds to (x,y) pixel in image will have coordinates (x+1,y+1).
seedPoint
Type: System.DrawingPoint
The starting point.
newVal
Type: Emgu.CV.StructureMCvScalar
New value of repainted domain pixels.
rect
Type: System.DrawingRectangle
Output parameter set by the function to the minimum bounding rectangle of the repainted domain.
loDiff
Type: Emgu.CV.StructureMCvScalar
Maximal lower brightness/color difference between the currently observed pixel and one of its neighbor belong to the component or seed pixel to add the pixel to component. In case of 8-bit color images it is packed value.
upDiff
Type: Emgu.CV.StructureMCvScalar
Maximal upper brightness/color difference between the currently observed pixel and one of its neighbor belong to the component or seed pixel to add the pixel to component. In case of 8-bit color images it is packed value.
connectivity (Optional)
Type: Emgu.CV.CvEnumConnectivity
Flood fill connectivity
flags (Optional)
Type: Emgu.CV.CvEnumFloodFillType
The operation flags.

Return Value

Type: Int32
The area of the connected component
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GaussianBlur Method

CvInvokeGaussianBlur Method

Blurs an image using a Gaussian filter.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GaussianBlur(
    IInputArray src,
    IOutputArray dst,
    Size ksize,
    double sigmaX,
    double sigmaY = 0,
    BorderType borderType = 4
)
Public Shared Sub GaussianBlur (
    src As IInputArray,
    dst As IOutputArray,
    ksize As Size,
    sigmaX As Double,
    Optional sigmaY As Double = 0,
    Optional borderType As BorderType = 4
)
public:
static void GaussianBlur(
    IInputArray^ src,
    IOutputArray^ dst,
    Size^ ksize,
    double sigmaX,
    double sigmaY = 0,
    BorderType^ borderType = 4
)
static member GaussianBlur :
        src : IInputArray *
        dst : IOutputArray *
        ksize : Size *
        sigmaX : float *
        ?sigmaY : float *
        ?borderType : BorderType
(* Defaults:
        let _sigmaY = defaultArg sigmaY 0
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
input image; the image can have any number of channels, which are processed independently, but the depth should be CV_8U, CV_16U, CV_16S, CV_32F or CV_64F.
dst
Type: Emgu.CVIOutputArray
output image of the same size and type as src.
ksize
Type: System.DrawingSize
Gaussian kernel size. ksize.width and ksize.height can differ but they both must be positive and odd. Or, they can be zero’s and then they are computed from sigma* .
sigmaX
Type: SystemDouble
Gaussian kernel standard deviation in X direction.
sigmaY (Optional)
Type: SystemDouble
Gaussian kernel standard deviation in Y direction; if sigmaY is zero, it is set to be equal to sigmaX, if both sigmas are zeros, they are computed from ksize.width and ksize.height , respectively (see getGaussianKernel() for details); to fully control the result regardless of possible future modifications of all this semantics, it is recommended to specify all of ksize, sigmaX, and sigmaY.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Gemm Method

CvInvokeGemm Method

Performs generalized matrix multiplication: dst = alpha*op(src1)*op(src2) + beta*op(src3), where op(X) is X or XT

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Gemm(
    IInputArray src1,
    IInputArray src2,
    double alpha,
    IInputArray src3,
    double beta,
    IOutputArray dst,
    GemmType tAbc = 0
)
Public Shared Sub Gemm (
    src1 As IInputArray,
    src2 As IInputArray,
    alpha As Double,
    src3 As IInputArray,
    beta As Double,
    dst As IOutputArray,
    Optional tAbc As GemmType = 0
)
public:
static void Gemm(
    IInputArray^ src1,
    IInputArray^ src2,
    double alpha,
    IInputArray^ src3,
    double beta,
    IOutputArray^ dst,
    GemmType^ tAbc = 0
)
static member Gemm :
        src1 : IInputArray *
        src2 : IInputArray *
        alpha : float *
        src3 : IInputArray *
        beta : float *
        dst : IOutputArray *
        ?tAbc : GemmType
(* Defaults:
        let _tAbc = defaultArg tAbc 0
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array.
src2
Type: Emgu.CVIInputArray
The second source array.
alpha
Type: SystemDouble
The scalar
src3
Type: Emgu.CVIInputArray
The third source array (shift). Can be null, if there is no shift.
beta
Type: SystemDouble
The scalar
dst
Type: Emgu.CVIOutputArray
The destination array.
tAbc (Optional)
Type: Emgu.CV.CvEnumGemmType
The Gemm operation type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetAffineTransform Method

CvInvokeGetAffineTransform Method

Overload List
Name | Description
GetAffineTransform(PointF, PointF) | Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.
GetAffineTransform(IInputArray, IOutputArray) | Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetAffineTransform Method (PointF[], PointF[])

CvInvokeGetAffineTransform Method (PointF, PointF)

http://www.emgu.com
Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetAffineTransform(
    PointF[] src,
    PointF[] dest
)
Public Shared Function GetAffineTransform (
    src As PointF(),
    dest As PointF()
) As Mat
public:
static Mat^ GetAffineTransform(
    array<PointF^>^ src,
    array<PointF^>^ dest
)
static member GetAffineTransform :
        src : PointF[] *
        dest : PointF[] -> Mat

Parameters

src
Type: System.DrawingPointF
Coordinates of 3 triangle vertices in the source image. If the array contains more than 3 points, only the first 3 will be used
dest
Type: System.DrawingPointF
Coordinates of the 3 corresponding triangle vertices in the destination image. If the array contains more than 3 points, only the first 3 will be used

Return Value

Type: Mat
The 2x3 rotation matrix that defines the Affine transform
See Also

Reference

CvInvoke Class
GetAffineTransform Overload
Emgu.CV Namespace


CvInvoke.GetAffineTransform Method (IInputArray, IOutputArray)

CvInvokeGetAffineTransform Method (IInputArray, IOutputArray)

http://www.emgu.com
Calculates the matrix of an affine transform such that: (x'_i,y'_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..2.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetAffineTransform(
    IInputArray src,
    IOutputArray dst
)
Public Shared Function GetAffineTransform (
    src As IInputArray,
    dst As IOutputArray
) As Mat
public:
static Mat^ GetAffineTransform(
    IInputArray^ src,
    IOutputArray^ dst
)
static member GetAffineTransform :
        src : IInputArray *
        dst : IOutputArray -> Mat

Parameters

src
Type: Emgu.CVIInputArray
Pointer to an array of PointF, Coordinates of 3 triangle vertices in the source image.
dst
Type: Emgu.CVIOutputArray
Pointer to an array of PointF, Coordinates of the 3 corresponding triangle vertices in the destination image

Return Value

Type: Mat
The destination 2x3 matrix
See Also

Reference

CvInvoke Class
GetAffineTransform Overload
Emgu.CV Namespace


CvInvoke.GetCvStructSizes Method

CvInvokeGetCvStructSizes Method

This function retrieve the Open CV structure sizes in unmanaged code

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static CvStructSizes GetCvStructSizes()
Public Shared Function GetCvStructSizes As CvStructSizes
public:
static CvStructSizes^ GetCvStructSizes()
static member GetCvStructSizes : unit -> CvStructSizes

Return Value

Type: CvStructSizes
The structure that will hold the Open CV structure sizes
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetDefaultNewCameraMatrix Method

CvInvokeGetDefaultNewCameraMatrix Method

Returns the default new camera matrix.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetDefaultNewCameraMatrix(
    IInputArray cameraMatrix,
    Size imgsize = null,
    bool centerPrincipalPoint = false
)
Public Shared Function GetDefaultNewCameraMatrix (
    cameraMatrix As IInputArray,
    Optional imgsize As Size = Nothing,
    Optional centerPrincipalPoint As Boolean = false
) As Mat
public:
static Mat^ GetDefaultNewCameraMatrix(
    IInputArray^ cameraMatrix,
    Size^ imgsize = nullptr,
    bool centerPrincipalPoint = false
)
static member GetDefaultNewCameraMatrix :
        cameraMatrix : IInputArray *
        ?imgsize : Size *
        ?centerPrincipalPoint : bool
(* Defaults:
        let _imgsize = defaultArg imgsize null
        let _centerPrincipalPoint = defaultArg centerPrincipalPoint false
*)
-> Mat

Parameters

cameraMatrix
Type: Emgu.CVIInputArray
Input camera matrix.
imgsize (Optional)
Type: System.DrawingSize
Camera view image size in pixels.
centerPrincipalPoint (Optional)
Type: SystemBoolean
Location of the principal point in the new camera matrix. The parameter indicates whether this location should be at the image center or not.

Return Value

Type: Mat
The default new camera matrix.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetDepthType Method

CvInvokeGetDepthType Method

Overload List
Name | Description
GetDepthType(Type) | Get the corresponding opencv depth type
GetDepthType(DepthType) | Get the corresponding depth type
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetDepthType Method (Type)

CvInvokeGetDepthType Method (Type)

http://www.emgu.com
Get the corresponding opencv depth type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static DepthType GetDepthType(
    Type t
)
Public Shared Function GetDepthType (
    t As Type
) As DepthType
public:
static DepthType^ GetDepthType(
    Type^ t
)
static member GetDepthType :
        t : Type -> DepthType

Parameters

t
Type: SystemType
The element type

Return Value

Type: DepthType
The equivalent opencv depth type
See Also

Reference

CvInvoke Class
GetDepthType Overload
Emgu.CV Namespace


CvInvoke.GetDepthType Method (DepthType)

CvInvokeGetDepthType Method (DepthType)

http://www.emgu.com
Get the corresponding depth type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Type GetDepthType(
    DepthType t
)
Public Shared Function GetDepthType (
    t As DepthType
) As Type
public:
static Type^ GetDepthType(
    DepthType^ t
)
static member GetDepthType :
        t : DepthType -> Type

Parameters

t
Type: Emgu.CV.CvEnumDepthType
The opencv depth type

Return Value

Type: Type
The equivalent depth type
See Also

Reference

CvInvoke Class
GetDepthType Overload
Emgu.CV Namespace


CvInvoke.GetErrMode Method

CvInvokeGetErrMode Method

Returns the current error mode

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int GetErrMode()
Public Shared Function GetErrMode As Integer
public:
static int GetErrMode()
static member GetErrMode : unit -> int

Return Value

Type: Int32
The error mode
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetErrStatus Method

CvInvokeGetErrStatus Method

Returns the current error status - the value set with the last cvSetErrStatus call. Note, that in Leaf mode the program terminates immediately after error occurred, so to always get control after the function call, one should call cvSetErrMode and set Parent or Silent error mode.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int GetErrStatus()
Public Shared Function GetErrStatus As Integer
public:
static int GetErrStatus()
static member GetErrStatus : unit -> int

Return Value

Type: Int32
The current error status
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetModuleFormatString Method

CvInvokeGetModuleFormatString Method

Get the module format string.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string GetModuleFormatString()
Public Shared Function GetModuleFormatString As String
public:
static String^ GetModuleFormatString()
static member GetModuleFormatString : unit -> string

Return Value

Type: String
On Windows, "{0}".dll will be returned; On Linux, "lib{0}.so" will be returned; Otherwise {0} is returned.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetOptimalDFTSize Method

CvInvokeGetOptimalDFTSize Method

Returns the minimum number N that is greater to equal to size0, such that DFT of a vector of size N can be computed fast. In the current implementation N=2^p x 3^q x 5^r for some p, q, r.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int GetOptimalDFTSize(
    int vecsize
)
Public Shared Function GetOptimalDFTSize (
    vecsize As Integer
) As Integer
public:
static int GetOptimalDFTSize(
    int vecsize
)
static member GetOptimalDFTSize :
        vecsize : int -> int

Parameters

vecsize
Type: SystemInt32
Vector size

Return Value

Type: Int32
The minimum number N that is greater to equal to size0, such that DFT of a vector of size N can be computed fast. In the current implementation N=2^p x 3^q x 5^r for some p, q, r.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetOptimalNewCameraMatrix Method

CvInvokeGetOptimalNewCameraMatrix Method

Returns the new camera matrix based on the free scaling parameter.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetOptimalNewCameraMatrix(
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    Size imageSize,
    double alpha,
    Size newImgSize,
    ref Rectangle validPixROI,
    bool centerPrincipalPoint = false
)
Public Shared Function GetOptimalNewCameraMatrix (
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    imageSize As Size,
    alpha As Double,
    newImgSize As Size,
    ByRef validPixROI As Rectangle,
    Optional centerPrincipalPoint As Boolean = false
) As Mat
public:
static Mat^ GetOptimalNewCameraMatrix(
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    Size^ imageSize,
    double alpha,
    Size^ newImgSize,
    Rectangle^% validPixROI,
    bool centerPrincipalPoint = false
)
static member GetOptimalNewCameraMatrix :
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        imageSize : Size *
        alpha : float *
        newImgSize : Size *
        validPixROI : Rectangle byref *
        ?centerPrincipalPoint : bool
(* Defaults:
        let _centerPrincipalPoint = defaultArg centerPrincipalPoint false
*)
-> Mat

Parameters

cameraMatrix
Type: Emgu.CVIInputArray
Input camera matrix.
distCoeffs
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6[,s1,s2,s3,s4[,?x,?y]]]]) of 4, 5, 8, 12 or 14 elements. If the vector is NULL/empty, the zero distortion coefficients are assumed.
imageSize
Type: System.DrawingSize
Original image size.
alpha
Type: SystemDouble
Free scaling parameter between 0 (when all the pixels in the undistorted image are valid) and 1 (when all the source image pixels are retained in the undistorted image).
newImgSize
Type: System.DrawingSize
Image size after rectification. By default,it is set to imageSize .
validPixROI
Type: System.DrawingRectangle
output rectangle that outlines all-good-pixels region in the undistorted image.
centerPrincipalPoint (Optional)
Type: SystemBoolean
indicates whether in the new camera matrix the principal point should be at the image center or not. By default, the principal point is chosen to best fit a subset of the source image (determined by alpha) to the corrected image.

Return Value

Type: Mat
The new camera matrix based on the free scaling parameter.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetPerspectiveTransform Method

CvInvokeGetPerspectiveTransform Method

Overload List
Name | Description
GetPerspectiveTransform(PointF, PointF) | calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.
GetPerspectiveTransform(IInputArray, IInputArray) | calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetPerspectiveTransform Method (PointF[], PointF[])

CvInvokeGetPerspectiveTransform Method (PointF, PointF)

http://www.emgu.com
calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)^T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetPerspectiveTransform(
    PointF[] src,
    PointF[] dest
)
Public Shared Function GetPerspectiveTransform (
    src As PointF(),
    dest As PointF()
) As Mat
public:
static Mat^ GetPerspectiveTransform(
    array<PointF^>^ src,
    array<PointF^>^ dest
)
static member GetPerspectiveTransform :
        src : PointF[] *
        dest : PointF[] -> Mat

Parameters

src
Type: System.DrawingPointF
Coordinates of 4 quadrangle vertices in the source image
dest
Type: System.DrawingPointF
Coordinates of the 4 corresponding quadrangle vertices in the destination image

Return Value

Type: Mat
The 3x3 Homography matrix
See Also

Reference

CvInvoke Class
GetPerspectiveTransform Overload
Emgu.CV Namespace


CvInvoke.GetPerspectiveTransform Method (IInputArray, IInputArray)

CvInvokeGetPerspectiveTransform Method (IInputArray, IInputArray)

http://www.emgu.com
calculates matrix of perspective transform such that: (t_i x'_i,t_i y'_i,t_i)^T=map_matrix (x_i,y_i,1)T where dst(i)=(x'_i,y'_i), src(i)=(x_i,y_i), i=0..3.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetPerspectiveTransform(
    IInputArray src,
    IInputArray dst
)
Public Shared Function GetPerspectiveTransform (
    src As IInputArray,
    dst As IInputArray
) As Mat
public:
static Mat^ GetPerspectiveTransform(
    IInputArray^ src,
    IInputArray^ dst
)
static member GetPerspectiveTransform :
        src : IInputArray *
        dst : IInputArray -> Mat

Parameters

src
Type: Emgu.CVIInputArray
Coordinates of 4 quadrangle vertices in the source image
dst
Type: Emgu.CVIInputArray
Coordinates of the 4 corresponding quadrangle vertices in the destination image

Return Value

Type: Mat
The perspective transform matrix
See Also

Reference

CvInvoke Class
GetPerspectiveTransform Overload
Emgu.CV Namespace


CvInvoke.GetRectSubPix Method

CvInvokeGetRectSubPix Method

Extracts pixels from src: dst(x, y) = src(x + center.x - (width(dst)-1)*0.5, y + center.y - (height(dst)-1)*0.5) where the values of pixels at non-integer coordinates are retrieved using bilinear interpolation. Every channel of multiple-channel images is processed independently. Whereas the rectangle center must be inside the image, the whole rectangle may be partially occluded. In this case, the replication border mode is used to get pixel values beyond the image boundaries.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GetRectSubPix(
    IInputArray image,
    Size patchSize,
    PointF center,
    IOutputArray patch,
    DepthType patchType = -1
)
Public Shared Sub GetRectSubPix (
    image As IInputArray,
    patchSize As Size,
    center As PointF,
    patch As IOutputArray,
    Optional patchType As DepthType = -1
)
public:
static void GetRectSubPix(
    IInputArray^ image,
    Size^ patchSize,
    PointF^ center,
    IOutputArray^ patch,
    DepthType^ patchType = -1
)
static member GetRectSubPix :
        image : IInputArray *
        patchSize : Size *
        center : PointF *
        patch : IOutputArray *
        ?patchType : DepthType
(* Defaults:
        let _patchType = defaultArg patchType -1
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Source image
patchSize
Type: System.DrawingSize
Size of the extracted patch.
center
Type: System.DrawingPointF
Floating point coordinates of the extracted rectangle center within the source image. The center must be inside the image.
patch
Type: Emgu.CVIOutputArray
Extracted rectangle
patchType (Optional)
Type: Emgu.CV.CvEnumDepthType
Depth of the extracted pixels. By default, they have the same depth as image.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetRotationMatrix2D Method

CvInvokeGetRotationMatrix2D Method

Calculates rotation matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GetRotationMatrix2D(
    PointF center,
    double angle,
    double scale,
    IOutputArray mapMatrix
)
Public Shared Sub GetRotationMatrix2D (
    center As PointF,
    angle As Double,
    scale As Double,
    mapMatrix As IOutputArray
)
public:
static void GetRotationMatrix2D(
    PointF^ center,
    double angle,
    double scale,
    IOutputArray^ mapMatrix
)
static member GetRotationMatrix2D :
        center : PointF *
        angle : float *
        scale : float *
        mapMatrix : IOutputArray -> unit

Parameters

center
Type: System.DrawingPointF
Center of the rotation in the source image.
angle
Type: SystemDouble
The rotation angle in degrees. Positive values mean couter-clockwise rotation (the coordiate origin is assumed at top-left corner).
scale
Type: SystemDouble
Isotropic scale factor
mapMatrix
Type: Emgu.CVIOutputArray
Pointer to the destination 2x3 matrix

Return Value

Type:
Pointer to the destination 2x3 matrix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetStructuringElement Method

CvInvokeGetStructuringElement Method

Returns a structuring element of the specified size and shape for morphological operations.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetStructuringElement(
    ElementShape shape,
    Size ksize,
    Point anchor
)
Public Shared Function GetStructuringElement (
    shape As ElementShape,
    ksize As Size,
    anchor As Point
) As Mat
public:
static Mat^ GetStructuringElement(
    ElementShape^ shape,
    Size^ ksize,
    Point^ anchor
)
static member GetStructuringElement :
        shape : ElementShape *
        ksize : Size *
        anchor : Point -> Mat

Parameters

shape
Type: Emgu.CV.CvEnumElementShape
Element shape
ksize
Type: System.DrawingSize
Size of the structuring element.
anchor
Type: System.DrawingPoint
Anchor position within the element. The value (-1, -1) means that the anchor is at the center. Note that only the shape of a cross-shaped element depends on the anchor position. In other cases the anchor just regulates how much the result of the morphological operation is shifted.

Return Value

Type: Mat
The structuring element
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GetTextSize Method

CvInvokeGetTextSize Method

Calculates the width and height of a text string.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Size GetTextSize(
    string text,
    FontFace fontFace,
    double fontScale,
    int thickness,
    ref int baseLine
)
Public Shared Function GetTextSize (
    text As String,
    fontFace As FontFace,
    fontScale As Double,
    thickness As Integer,
    ByRef baseLine As Integer
) As Size
public:
static Size^ GetTextSize(
    String^ text,
    FontFace^ fontFace,
    double fontScale,
    int thickness,
    int% baseLine
)
static member GetTextSize :
        text : string *
        fontFace : FontFace *
        fontScale : float *
        thickness : int *
        baseLine : int byref -> Size

Parameters

text
Type: SystemString
Input text string.
fontFace
Type: Emgu.CV.CvEnumFontFace
Font to use
fontScale
Type: SystemDouble
Font scale factor that is multiplied by the font-specific base size.
thickness
Type: SystemInt32
Thickness of lines used to render the text.
baseLine
Type: SystemInt32
Y-coordinate of the baseline relative to the bottom-most text point.

Return Value

Type: Size
The size of a box that contains the specified text.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GrabCut Method

CvInvokeGrabCut Method

The grab cut algorithm for segmentation

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GrabCut(
    IInputArray img,
    IInputOutputArray mask,
    Rectangle rect,
    IInputOutputArray bgdModel,
    IInputOutputArray fgdModel,
    int iterCount,
    GrabcutInitType type
)
Public Shared Sub GrabCut (
    img As IInputArray,
    mask As IInputOutputArray,
    rect As Rectangle,
    bgdModel As IInputOutputArray,
    fgdModel As IInputOutputArray,
    iterCount As Integer,
    type As GrabcutInitType
)
public:
static void GrabCut(
    IInputArray^ img,
    IInputOutputArray^ mask,
    Rectangle^ rect,
    IInputOutputArray^ bgdModel,
    IInputOutputArray^ fgdModel,
    int iterCount,
    GrabcutInitType^ type
)
static member GrabCut :
        img : IInputArray *
        mask : IInputOutputArray *
        rect : Rectangle *
        bgdModel : IInputOutputArray *
        fgdModel : IInputOutputArray *
        iterCount : int *
        type : GrabcutInitType -> unit

Parameters

img
Type: Emgu.CVIInputArray
The 8-bit 3-channel image to be segmented
mask
Type: Emgu.CVIInputOutputArray
Input/output 8-bit single-channel mask. The mask is initialized by the function when mode is set to GC_INIT_WITH_RECT. Its elements may have one of following values: 0 (GC_BGD) defines an obvious background pixels. 1 (GC_FGD) defines an obvious foreground (object) pixel. 2 (GC_PR_BGR) defines a possible background pixel. 3 (GC_PR_FGD) defines a possible foreground pixel.
rect
Type: System.DrawingRectangle
The rectangle to initialize the segmentation
bgdModel
Type: Emgu.CVIInputOutputArray
Temporary array for the background model. Do not modify it while you are processing the same image.
fgdModel
Type: Emgu.CVIInputOutputArray
Temporary arrays for the foreground model. Do not modify it while you are processing the same image.
iterCount
Type: SystemInt32
The number of iterations
type
Type: Emgu.CV.CvEnumGrabcutInitType
The initialization type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GroupRectangles Method

CvInvokeGroupRectangles Method

Overload List
Name | Description
GroupRectangles(VectorOfRect, Int32, Double) | Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, VectorOfInt, Int32, Double) | Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, VectorOfInt, VectorOfDouble, Int32, Double) | Groups the object candidate rectangles.
GroupRectangles(VectorOfRect, Int32, Double, VectorOfInt, VectorOfDouble) | Groups the object candidate rectangles.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.GroupRectangles Method (VectorOfRect, Int32, Double)

CvInvokeGroupRectangles Method (VectorOfRect, Int32, Double)

http://www.emgu.com
Groups the object candidate rectangles.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GroupRectangles(
    VectorOfRect rectList,
    int groupThreshold,
    double eps = 0.2
)
Public Shared Sub GroupRectangles (
    rectList As VectorOfRect,
    groupThreshold As Integer,
    Optional eps As Double = 0.2
)
public:
static void GroupRectangles(
    VectorOfRect^ rectList,
    int groupThreshold,
    double eps = 0.2
)
static member GroupRectangles :
        rectList : VectorOfRect *
        groupThreshold : int *
        ?eps : float
(* Defaults:
        let _eps = defaultArg eps 0.2
*)
-> unit

Parameters

rectList
Type: Emgu.CV.UtilVectorOfRect
Input/output vector of rectangles. Output vector includes retained and grouped rectangles.
groupThreshold
Type: SystemInt32
Minimum possible number of rectangles minus 1. The threshold is used in a group of rectangles to retain it.
eps (Optional)
Type: SystemDouble
Relative difference between sides of the rectangles to merge them into a group.
See Also

Reference

CvInvoke Class
GroupRectangles Overload
Emgu.CV Namespace


CvInvoke.GroupRectangles Method (VectorOfRect, VectorOfInt, Int32, Double)

CvInvokeGroupRectangles Method (VectorOfRect, VectorOfInt, Int32, Double)

http://www.emgu.com
Groups the object candidate rectangles.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GroupRectangles(
    VectorOfRect rectList,
    VectorOfInt weights,
    int groupThreshold,
    double eps = 0.2
)
Public Shared Sub GroupRectangles (
    rectList As VectorOfRect,
    weights As VectorOfInt,
    groupThreshold As Integer,
    Optional eps As Double = 0.2
)
public:
static void GroupRectangles(
    VectorOfRect^ rectList,
    VectorOfInt^ weights,
    int groupThreshold,
    double eps = 0.2
)
static member GroupRectangles :
        rectList : VectorOfRect *
        weights : VectorOfInt *
        groupThreshold : int *
        ?eps : float
(* Defaults:
        let _eps = defaultArg eps 0.2
*)
-> unit

Parameters

rectList
Type: Emgu.CV.UtilVectorOfRect
Input/output vector of rectangles. Output vector includes retained and grouped rectangles.
weights
Type: Emgu.CV.UtilVectorOfInt
Weights
groupThreshold
Type: SystemInt32
Minimum possible number of rectangles minus 1. The threshold is used in a group of rectangles to retain it.
eps (Optional)
Type: SystemDouble
Relative difference between sides of the rectangles to merge them into a group.
See Also

Reference

CvInvoke Class
GroupRectangles Overload
Emgu.CV Namespace


CvInvoke.GroupRectangles Method (VectorOfRect, VectorOfInt, VectorOfDouble, Int32, Double)

CvInvokeGroupRectangles Method (VectorOfRect, VectorOfInt, VectorOfDouble, Int32, Double)

http://www.emgu.com
Groups the object candidate rectangles.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GroupRectangles(
    VectorOfRect rectList,
    VectorOfInt rejectLevels,
    VectorOfDouble levelWeights,
    int groupThreshold,
    double eps = 0.2
)
Public Shared Sub GroupRectangles (
    rectList As VectorOfRect,
    rejectLevels As VectorOfInt,
    levelWeights As VectorOfDouble,
    groupThreshold As Integer,
    Optional eps As Double = 0.2
)
public:
static void GroupRectangles(
    VectorOfRect^ rectList,
    VectorOfInt^ rejectLevels,
    VectorOfDouble^ levelWeights,
    int groupThreshold,
    double eps = 0.2
)
static member GroupRectangles :
        rectList : VectorOfRect *
        rejectLevels : VectorOfInt *
        levelWeights : VectorOfDouble *
        groupThreshold : int *
        ?eps : float
(* Defaults:
        let _eps = defaultArg eps 0.2
*)
-> unit

Parameters

rectList
Type: Emgu.CV.UtilVectorOfRect
Input/output vector of rectangles. Output vector includes retained and grouped rectangles.
rejectLevels
Type: Emgu.CV.UtilVectorOfInt
reject levels
levelWeights
Type: Emgu.CV.UtilVectorOfDouble
level weights
groupThreshold
Type: SystemInt32
Minimum possible number of rectangles minus 1. The threshold is used in a group of rectangles to retain it.
eps (Optional)
Type: SystemDouble
Relative difference between sides of the rectangles to merge them into a group.
See Also

Reference

CvInvoke Class
GroupRectangles Overload
Emgu.CV Namespace


CvInvoke.GroupRectangles Method (VectorOfRect, Int32, Double, VectorOfInt, VectorOfDouble)

CvInvokeGroupRectangles Method (VectorOfRect, Int32, Double, VectorOfInt, VectorOfDouble)

http://www.emgu.com
Groups the object candidate rectangles.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GroupRectangles(
    VectorOfRect rectList,
    int groupThreshold,
    double eps,
    VectorOfInt weights,
    VectorOfDouble levelWeights
)
Public Shared Sub GroupRectangles (
    rectList As VectorOfRect,
    groupThreshold As Integer,
    eps As Double,
    weights As VectorOfInt,
    levelWeights As VectorOfDouble
)
public:
static void GroupRectangles(
    VectorOfRect^ rectList,
    int groupThreshold,
    double eps,
    VectorOfInt^ weights,
    VectorOfDouble^ levelWeights
)
static member GroupRectangles :
        rectList : VectorOfRect *
        groupThreshold : int *
        eps : float *
        weights : VectorOfInt *
        levelWeights : VectorOfDouble -> unit

Parameters

rectList
Type: Emgu.CV.UtilVectorOfRect
Input/output vector of rectangles. Output vector includes retained and grouped rectangles.
groupThreshold
Type: SystemInt32
Minimum possible number of rectangles minus 1. The threshold is used in a group of rectangles to retain it.
eps
Type: SystemDouble
Relative difference between sides of the rectangles to merge them into a group.
weights
Type: Emgu.CV.UtilVectorOfInt
weights
levelWeights
Type: Emgu.CV.UtilVectorOfDouble
level weights
See Also

Reference

CvInvoke Class
GroupRectangles Overload
Emgu.CV Namespace


CvInvoke.GroupRectanglesMeanshift Method

CvInvokeGroupRectanglesMeanshift Method

Groups the object candidate rectangles.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GroupRectanglesMeanshift(
    VectorOfRect rectList,
    VectorOfDouble foundWeights,
    VectorOfDouble foundScales,
    double detectThreshold,
    Size winDetSize
)
Public Shared Sub GroupRectanglesMeanshift (
    rectList As VectorOfRect,
    foundWeights As VectorOfDouble,
    foundScales As VectorOfDouble,
    detectThreshold As Double,
    winDetSize As Size
)
public:
static void GroupRectanglesMeanshift(
    VectorOfRect^ rectList,
    VectorOfDouble^ foundWeights,
    VectorOfDouble^ foundScales,
    double detectThreshold,
    Size^ winDetSize
)
static member GroupRectanglesMeanshift :
        rectList : VectorOfRect *
        foundWeights : VectorOfDouble *
        foundScales : VectorOfDouble *
        detectThreshold : float *
        winDetSize : Size -> unit

Parameters

rectList
Type: Emgu.CV.UtilVectorOfRect
Input/output vector of rectangles. Output vector includes retained and grouped rectangles.
foundWeights
Type: Emgu.CV.UtilVectorOfDouble
found weights
foundScales
Type: Emgu.CV.UtilVectorOfDouble
found scales
detectThreshold
Type: SystemDouble
detect threshold, use 0 for default
winDetSize
Type: System.DrawingSize
win det size, use (64, 128) for default
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HConcat Method

CvInvokeHConcat Method

Horizontally concatenate two images

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void HConcat(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst
)
Public Shared Sub HConcat (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray
)
public:
static void HConcat(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst
)
static member HConcat :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray -> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first image
src2
Type: Emgu.CVIInputArray
The second image
dst
Type: Emgu.CVIOutputArray
The result image
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HoughCircles Method

CvInvokeHoughCircles Method

Overload List
Name | Description
HoughCircles(IInputArray, HoughType, Double, Double, Double, Double, Int32, Int32) | Finds circles in a grayscale image using the Hough transform
HoughCircles(IInputArray, IOutputArray, HoughType, Double, Double, Double, Double, Int32, Int32) | Finds circles in grayscale image using some modification of Hough transform
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HoughCircles Method (IInputArray, HoughType, Double, Double, Double, Double, Int32, Int32)

CvInvokeHoughCircles Method (IInputArray, HoughType, Double, Double, Double, Double, Int32, Int32)

http://www.emgu.com
Finds circles in a grayscale image using the Hough transform

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static CircleF[] HoughCircles(
    IInputArray image,
    HoughType method,
    double dp,
    double minDist,
    double param1 = 100,
    double param2 = 100,
    int minRadius = 0,
    int maxRadius = 0
)
Public Shared Function HoughCircles (
    image As IInputArray,
    method As HoughType,
    dp As Double,
    minDist As Double,
    Optional param1 As Double = 100,
    Optional param2 As Double = 100,
    Optional minRadius As Integer = 0,
    Optional maxRadius As Integer = 0
) As CircleF()
public:
static array<CircleF^>^ HoughCircles(
    IInputArray^ image,
    HoughType^ method,
    double dp,
    double minDist,
    double param1 = 100,
    double param2 = 100,
    int minRadius = 0,
    int maxRadius = 0
)
static member HoughCircles :
        image : IInputArray *
        method : HoughType *
        dp : float *
        minDist : float *
        ?param1 : float *
        ?param2 : float *
        ?minRadius : int *
        ?maxRadius : int
(* Defaults:
        let _param1 = defaultArg param1 100
        let _param2 = defaultArg param2 100
        let _minRadius = defaultArg minRadius 0
        let _maxRadius = defaultArg maxRadius 0
*)
-> CircleF[]

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel, grayscale input image.
method
Type: Emgu.CV.CvEnumHoughType
Detection method to use. Currently, the only implemented method is CV_HOUGH_GRADIENT , which is basically 21HT
dp
Type: SystemDouble
Inverse ratio of the accumulator resolution to the image resolution. For example, if dp=1 , the accumulator has the same resolution as the input image. If dp=2 , the accumulator has half as big width and height.
minDist
Type: SystemDouble
Minimum distance between the centers of the detected circles. If the parameter is too small, multiple neighbor circles may be falsely detected in addition to a true one. If it is too large, some circles may be missed.
param1 (Optional)
Type: SystemDouble
First method-specific parameter. In case of CV_HOUGH_GRADIENT , it is the higher threshold of the two passed to the Canny() edge detector (the lower one is twice smaller).
param2 (Optional)
Type: SystemDouble
Second method-specific parameter. In case of CV_HOUGH_GRADIENT , it is the accumulator threshold for the circle centers at the detection stage. The smaller it is, the more false circles may be detected. Circles, corresponding to the larger accumulator values, will be returned first.
minRadius (Optional)
Type: SystemInt32
Minimum circle radius.
maxRadius (Optional)
Type: SystemInt32
Maximum circle radius.

Return Value

Type: CircleF
The circles detected
See Also

Reference

CvInvoke Class
HoughCircles Overload
Emgu.CV Namespace


CvInvoke.HoughCircles Method (IInputArray, IOutputArray, HoughType, Double, Double, Double, Double, Int32, Int32)

CvInvokeHoughCircles Method (IInputArray, IOutputArray, HoughType, Double, Double, Double, Double, Int32, Int32)

http://www.emgu.com
Finds circles in grayscale image using some modification of Hough transform

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void HoughCircles(
    IInputArray image,
    IOutputArray circles,
    HoughType method,
    double dp,
    double minDist,
    double param1 = 100,
    double param2 = 100,
    int minRadius = 0,
    int maxRadius = 0
)
Public Shared Sub HoughCircles (
    image As IInputArray,
    circles As IOutputArray,
    method As HoughType,
    dp As Double,
    minDist As Double,
    Optional param1 As Double = 100,
    Optional param2 As Double = 100,
    Optional minRadius As Integer = 0,
    Optional maxRadius As Integer = 0
)
public:
static void HoughCircles(
    IInputArray^ image,
    IOutputArray^ circles,
    HoughType^ method,
    double dp,
    double minDist,
    double param1 = 100,
    double param2 = 100,
    int minRadius = 0,
    int maxRadius = 0
)
static member HoughCircles :
        image : IInputArray *
        circles : IOutputArray *
        method : HoughType *
        dp : float *
        minDist : float *
        ?param1 : float *
        ?param2 : float *
        ?minRadius : int *
        ?maxRadius : int
(* Defaults:
        let _param1 = defaultArg param1 100
        let _param2 = defaultArg param2 100
        let _minRadius = defaultArg minRadius 0
        let _maxRadius = defaultArg maxRadius 0
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The input 8-bit single-channel grayscale image
circles
Type: Emgu.CVIOutputArray
The storage for the circles detected. It can be a memory storage (in this case a sequence of circles is created in the storage and returned by the function) or single row/single column matrix (CvMat*) of type CV_32FC3, to which the circles' parameters are written. The matrix header is modified by the function so its cols or rows will contain a number of lines detected. If circle_storage is a matrix and the actual number of lines exceeds the matrix size, the maximum possible number of circles is returned. Every circle is encoded as 3 floating-point numbers: center coordinates (x,y) and the radius
method
Type: Emgu.CV.CvEnumHoughType
Currently, the only implemented method is CV_HOUGH_GRADIENT
dp
Type: SystemDouble
Resolution of the accumulator used to detect centers of the circles. For example, if it is 1, the accumulator will have the same resolution as the input image, if it is 2 - accumulator will have twice smaller width and height, etc
minDist
Type: SystemDouble
Minimum distance between centers of the detected circles. If the parameter is too small, multiple neighbor circles may be falsely detected in addition to a true one. If it is too large, some circles may be missed
param1 (Optional)
Type: SystemDouble
The first method-specific parameter. In case of CV_HOUGH_GRADIENT it is the higher threshold of the two passed to Canny edge detector (the lower one will be twice smaller).
param2 (Optional)
Type: SystemDouble
The second method-specific parameter. In case of CV_HOUGH_GRADIENT it is accumulator threshold at the center detection stage. The smaller it is, the more false circles may be detected. Circles, corresponding to the larger accumulator values, will be returned first
minRadius (Optional)
Type: SystemInt32
Minimal radius of the circles to search for
maxRadius (Optional)
Type: SystemInt32
Maximal radius of the circles to search for. By default the maximal radius is set to max(image_width, image_height).

Return Value

Type:
Pointer to the sequence of circles
See Also

Reference

CvInvoke Class
HoughCircles Overload
Emgu.CV Namespace


CvInvoke.HoughLines Method

CvInvokeHoughLines Method

Finds lines in a binary image using the standard Hough transform.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void HoughLines(
    IInputArray image,
    IOutputArray lines,
    double rho,
    double theta,
    int threshold,
    double srn = 0,
    double stn = 0
)
Public Shared Sub HoughLines (
    image As IInputArray,
    lines As IOutputArray,
    rho As Double,
    theta As Double,
    threshold As Integer,
    Optional srn As Double = 0,
    Optional stn As Double = 0
)
public:
static void HoughLines(
    IInputArray^ image,
    IOutputArray^ lines,
    double rho,
    double theta,
    int threshold,
    double srn = 0,
    double stn = 0
)
static member HoughLines :
        image : IInputArray *
        lines : IOutputArray *
        rho : float *
        theta : float *
        threshold : int *
        ?srn : float *
        ?stn : float
(* Defaults:
        let _srn = defaultArg srn 0
        let _stn = defaultArg stn 0
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel binary source image. The image may be modified by the function.
lines
Type: Emgu.CVIOutputArray
Output vector of lines. Each line is represented by a two-element vector
rho
Type: SystemDouble
Distance resolution of the accumulator in pixels.
theta
Type: SystemDouble
Angle resolution of the accumulator in radians.
threshold
Type: SystemInt32
Accumulator threshold parameter. Only those lines are returned that get enough votes (> threshold)
srn (Optional)
Type: SystemDouble
For the multi-scale Hough transform, it is a divisor for the distance resolution rho . The coarse accumulator distance resolution is rho and the accurate accumulator resolution is rho/srn . If both srn=0 and stn=0 , the classical Hough transform is used. Otherwise, both these parameters should be positive.
stn (Optional)
Type: SystemDouble
For the multi-scale Hough transform, it is a divisor for the distance resolution theta
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HoughLinesP Method

CvInvokeHoughLinesP Method

Overload List
Name | Description
HoughLinesP(IInputArray, Double, Double, Int32, Double, Double) | Finds line segments in a binary image using the probabilistic Hough transform.
HoughLinesP(IInputArray, IOutputArray, Double, Double, Int32, Double, Double) | Finds line segments in a binary image using the probabilistic Hough transform.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HoughLinesP Method (IInputArray, Double, Double, Int32, Double, Double)

CvInvokeHoughLinesP Method (IInputArray, Double, Double, Int32, Double, Double)

http://www.emgu.com
Finds line segments in a binary image using the probabilistic Hough transform.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static LineSegment2D[] HoughLinesP(
    IInputArray image,
    double rho,
    double theta,
    int threshold,
    double minLineLength = 0,
    double maxGap = 0
)
Public Shared Function HoughLinesP (
    image As IInputArray,
    rho As Double,
    theta As Double,
    threshold As Integer,
    Optional minLineLength As Double = 0,
    Optional maxGap As Double = 0
) As LineSegment2D()
public:
static array<LineSegment2D^>^ HoughLinesP(
    IInputArray^ image,
    double rho,
    double theta,
    int threshold,
    double minLineLength = 0,
    double maxGap = 0
)
static member HoughLinesP :
        image : IInputArray *
        rho : float *
        theta : float *
        threshold : int *
        ?minLineLength : float *
        ?maxGap : float
(* Defaults:
        let _minLineLength = defaultArg minLineLength 0
        let _maxGap = defaultArg maxGap 0
*)
-> LineSegment2D[]

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel binary source image. The image may be modified by the function.
rho
Type: SystemDouble
Distance resolution of the accumulator in pixels
theta
Type: SystemDouble
Angle resolution of the accumulator in radians
threshold
Type: SystemInt32
Accumulator threshold parameter. Only those lines are returned that get enough votes
minLineLength (Optional)
Type: SystemDouble
Minimum line length. Line segments shorter than that are rejected.
maxGap (Optional)
Type: SystemDouble
Maximum allowed gap between points on the same line to link them.

Return Value

Type: LineSegment2D
The found line segments
See Also

Reference

CvInvoke Class
HoughLinesP Overload
Emgu.CV Namespace


CvInvoke.HoughLinesP Method (IInputArray, IOutputArray, Double, Double, Int32, Double, Double)

CvInvokeHoughLinesP Method (IInputArray, IOutputArray, Double, Double, Int32, Double, Double)

http://www.emgu.com
Finds line segments in a binary image using the probabilistic Hough transform.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void HoughLinesP(
    IInputArray image,
    IOutputArray lines,
    double rho,
    double theta,
    int threshold,
    double minLineLength = 0,
    double maxGap = 0
)
Public Shared Sub HoughLinesP (
    image As IInputArray,
    lines As IOutputArray,
    rho As Double,
    theta As Double,
    threshold As Integer,
    Optional minLineLength As Double = 0,
    Optional maxGap As Double = 0
)
public:
static void HoughLinesP(
    IInputArray^ image,
    IOutputArray^ lines,
    double rho,
    double theta,
    int threshold,
    double minLineLength = 0,
    double maxGap = 0
)
static member HoughLinesP :
        image : IInputArray *
        lines : IOutputArray *
        rho : float *
        theta : float *
        threshold : int *
        ?minLineLength : float *
        ?maxGap : float
(* Defaults:
        let _minLineLength = defaultArg minLineLength 0
        let _maxGap = defaultArg maxGap 0
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel binary source image. The image may be modified by the function.
lines
Type: Emgu.CVIOutputArray
Output vector of lines. Each line is represented by a 4-element vector (x1, y1, x2, y2)
rho
Type: SystemDouble
Distance resolution of the accumulator in pixels
theta
Type: SystemDouble
Angle resolution of the accumulator in radians
threshold
Type: SystemInt32
Accumulator threshold parameter. Only those lines are returned that get enough votes
minLineLength (Optional)
Type: SystemDouble
Minimum line length. Line segments shorter than that are rejected.
maxGap (Optional)
Type: SystemDouble
Maximum allowed gap between points on the same line to link them.
See Also

Reference

CvInvoke Class
HoughLinesP Overload
Emgu.CV Namespace


CvInvoke.HuMoments Method

CvInvokeHuMoments Method

Overload List
Name | Description
HuMoments(Moments) | Calculates seven Hu invariants
HuMoments(Moments, IOutputArray) | Calculates seven Hu invariants
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.HuMoments Method (Moments)

CvInvokeHuMoments Method (Moments)

http://www.emgu.com
Calculates seven Hu invariants

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double[] HuMoments(
    Moments m
)
Public Shared Function HuMoments (
    m As Moments
) As Double()
public:
static array<double>^ HuMoments(
    Moments^ m
)
static member HuMoments :
        m : Moments -> float[]

Parameters

m
Type: Emgu.CVMoments
The image moment

Return Value

Type: Double
The output Hu moments.
See Also

Reference

CvInvoke Class
HuMoments Overload
Emgu.CV Namespace


CvInvoke.HuMoments Method (Moments, IOutputArray)

CvInvokeHuMoments Method (Moments, IOutputArray)

http://www.emgu.com
Calculates seven Hu invariants

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void HuMoments(
    Moments m,
    IOutputArray hu
)
Public Shared Sub HuMoments (
    m As Moments,
    hu As IOutputArray
)
public:
static void HuMoments(
    Moments^ m,
    IOutputArray^ hu
)
static member HuMoments :
        m : Moments *
        hu : IOutputArray -> unit

Parameters

m
Type: Emgu.CVMoments
The image moment
hu
Type: Emgu.CVIOutputArray
The output Hu moments. e.g. a Mat can be passed here.
See Also

Reference

CvInvoke Class
HuMoments Overload
Emgu.CV Namespace


CvInvoke.IlluminationChange Method

CvInvokeIlluminationChange Method

Applying an appropriate non-linear transformation to the gradient field inside the selection and then integrating back with a Poisson solver, modifies locally the apparent illumination of an image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void IlluminationChange(
    IInputArray src,
    IInputArray mask,
    IOutputArray dst,
    float alpha = 0.2f,
    float beta = 0.4f
)
Public Shared Sub IlluminationChange (
    src As IInputArray,
    mask As IInputArray,
    dst As IOutputArray,
    Optional alpha As Single = 0.2F,
    Optional beta As Single = 0.4F
)
public:
static void IlluminationChange(
    IInputArray^ src,
    IInputArray^ mask,
    IOutputArray^ dst,
    float alpha = 0.2f,
    float beta = 0.4f
)
static member IlluminationChange :
        src : IInputArray *
        mask : IInputArray *
        dst : IOutputArray *
        ?alpha : float32 *
        ?beta : float32
(* Defaults:
        let _alpha = defaultArg alpha 0.2f
        let _beta = defaultArg beta 0.4f
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image.
mask
Type: Emgu.CVIInputArray
Input 8-bit 1 or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src.
alpha (Optional)
Type: SystemSingle
Value ranges between 0-2.
beta (Optional)
Type: SystemSingle
Value ranges between 0-2.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Imdecode Method

CvInvokeImdecode Method

Overload List
Name | Description
Imdecode(Byte, ImreadModes, Mat) | Decode image stored in the buffer
Imdecode(IInputArray, ImreadModes, Mat) | Decode image stored in the buffer
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Imdecode Method (Byte[], ImreadModes, Mat)

CvInvokeImdecode Method (Byte, ImreadModes, Mat)

http://www.emgu.com
Decode image stored in the buffer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Imdecode(
    byte[] buf,
    ImreadModes loadType,
    Mat dst
)
Public Shared Sub Imdecode (
    buf As Byte(),
    loadType As ImreadModes,
    dst As Mat
)
public:
static void Imdecode(
    array<unsigned char>^ buf,
    ImreadModes^ loadType,
    Mat^ dst
)
static member Imdecode :
        buf : byte[] *
        loadType : ImreadModes *
        dst : Mat -> unit

Parameters

buf
Type: SystemByte
The buffer
loadType
Type: Emgu.CV.CvEnumImreadModes
The image loading type
dst
Type: Emgu.CVMat
The output placeholder for the decoded matrix.
See Also

Reference

CvInvoke Class
Imdecode Overload
Emgu.CV Namespace


CvInvoke.Imdecode Method (IInputArray, ImreadModes, Mat)

CvInvokeImdecode Method (IInputArray, ImreadModes, Mat)

http://www.emgu.com
Decode image stored in the buffer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Imdecode(
    IInputArray buf,
    ImreadModes loadType,
    Mat dst
)
Public Shared Sub Imdecode (
    buf As IInputArray,
    loadType As ImreadModes,
    dst As Mat
)
public:
static void Imdecode(
    IInputArray^ buf,
    ImreadModes^ loadType,
    Mat^ dst
)
static member Imdecode :
        buf : IInputArray *
        loadType : ImreadModes *
        dst : Mat -> unit

Parameters

buf
Type: Emgu.CVIInputArray
The buffer
loadType
Type: Emgu.CV.CvEnumImreadModes
The image loading type
dst
Type: Emgu.CVMat
The output placeholder for the decoded matrix.
See Also

Reference

CvInvoke Class
Imdecode Overload
Emgu.CV Namespace


CvInvoke.Imencode Method

CvInvokeImencode Method

encode image and store the result as a byte vector.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Imencode(
    string ext,
    IInputArray image,
    VectorOfByte buf,
    params KeyValuePair<ImwriteFlags, int>[] parameters
)
Public Shared Sub Imencode (
    ext As String,
    image As IInputArray,
    buf As VectorOfByte,
    ParamArray parameters As KeyValuePair(Of ImwriteFlags, Integer)()
)
public:
static void Imencode(
    String^ ext,
    IInputArray^ image,
    VectorOfByte^ buf,
    ... array<KeyValuePair<ImwriteFlags^, int>^>^ parameters
)
static member Imencode :
        ext : string *
        image : IInputArray *
        buf : VectorOfByte *
        parameters : KeyValuePair<ImwriteFlags, int>[] -> unit

Parameters

ext
Type: SystemString
The image format
image
Type: Emgu.CVIInputArray
The image
buf
Type: Emgu.CV.UtilVectorOfByte
Output buffer resized to fit the compressed image.
parameters
Type: System.Collections.GenericKeyValuePair ImwriteFlags, Int32
The pointer to the array of integers, which contains the parameter for encoding, use IntPtr.Zero for default
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Imread Method

CvInvokeImread Method

Loads an image from the specified file and returns the pointer to the loaded image. Currently the following file formats are supported:
Windows bitmaps - BMP, DIB;
JPEG files - JPEG, JPG, JPE;
Portable Network Graphics - PNG;
Portable image format - PBM, PGM, PPM;
Sun rasters - SR, RAS;
TIFF files - TIFF, TIF;
OpenEXR HDR images - EXR;
JPEG 2000 images - jp2.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat Imread(
    string filename,
    ImreadModes loadType = 1
)
Public Shared Function Imread (
    filename As String,
    Optional loadType As ImreadModes = 1
) As Mat
public:
static Mat^ Imread(
    String^ filename,
    ImreadModes^ loadType = 1
)
static member Imread :
        filename : string *
        ?loadType : ImreadModes
(* Defaults:
        let _loadType = defaultArg loadType 1
*)
-> Mat

Parameters

filename
Type: SystemString
The name of the file to be loaded
loadType (Optional)
Type: Emgu.CV.CvEnumImreadModes
The image loading type

Return Value

Type: Mat
The loaded image
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Imreadmulti Method

CvInvokeImreadmulti Method

The function imreadmulti loads a multi-page image from the specified file into a vector of Mat objects.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat[] Imreadmulti(
    string filename,
    ImreadModes flags = 4
)
Public Shared Function Imreadmulti (
    filename As String,
    Optional flags As ImreadModes = 4
) As Mat()
public:
static array<Mat^>^ Imreadmulti(
    String^ filename,
    ImreadModes^ flags = 4
)
static member Imreadmulti :
        filename : string *
        ?flags : ImreadModes
(* Defaults:
        let _flags = defaultArg flags 4
*)
-> Mat[]

Parameters

filename
Type: SystemString
Name of file to be loaded.
flags (Optional)
Type: Emgu.CV.CvEnumImreadModes
Read flags

Return Value

Type: Mat
Null if the reading fails, otherwise, an array of Mat from the file
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Imshow Method

CvInvokeImshow Method

Shows the image in the specified window

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Imshow(
    string name,
    IInputArray image
)
Public Shared Sub Imshow (
    name As String,
    image As IInputArray
)
public:
static void Imshow(
    String^ name,
    IInputArray^ image
)
static member Imshow :
        name : string *
        image : IInputArray -> unit

Parameters

name
Type: SystemString
Name of the window
image
Type: Emgu.CVIInputArray
Image to be shown
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Imwrite Method

CvInvokeImwrite Method

Saves the image to the specified file. The image format is chosen depending on the filename extension, see cvLoadImage. Only 8-bit single-channel or 3-channel (with 'BGR' channel order) images can be saved using this function. If the format, depth or channel order is different, use cvCvtScale and cvCvtColor to convert it before saving, or use universal cvSave to save the image to XML or YAML format

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool Imwrite(
    string filename,
    IInputArray image,
    params KeyValuePair<ImwriteFlags, int>[] parameters
)
Public Shared Function Imwrite (
    filename As String,
    image As IInputArray,
    ParamArray parameters As KeyValuePair(Of ImwriteFlags, Integer)()
) As Boolean
public:
static bool Imwrite(
    String^ filename,
    IInputArray^ image,
    ... array<KeyValuePair<ImwriteFlags^, int>^>^ parameters
)
static member Imwrite :
        filename : string *
        image : IInputArray *
        parameters : KeyValuePair<ImwriteFlags, int>[] -> bool

Parameters

filename
Type: SystemString
The name of the file to be saved to
image
Type: Emgu.CVIInputArray
The image to be saved
parameters
Type: System.Collections.GenericKeyValuePair ImwriteFlags, Int32
The parameters

Return Value

Type: Boolean
true if success
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.InitCameraMatrix2D Method

CvInvokeInitCameraMatrix2D Method

Finds an initial camera matrix from 3D-2D point correspondences.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat InitCameraMatrix2D(
    IInputArrayOfArrays objectPoints,
    IInputArrayOfArrays imagePoints,
    Size imageSize,
    double aspectRatio = 1
)
Public Shared Function InitCameraMatrix2D (
    objectPoints As IInputArrayOfArrays,
    imagePoints As IInputArrayOfArrays,
    imageSize As Size,
    Optional aspectRatio As Double = 1
) As Mat
public:
static Mat^ InitCameraMatrix2D(
    IInputArrayOfArrays^ objectPoints,
    IInputArrayOfArrays^ imagePoints,
    Size^ imageSize,
    double aspectRatio = 1
)
static member InitCameraMatrix2D :
        objectPoints : IInputArrayOfArrays *
        imagePoints : IInputArrayOfArrays *
        imageSize : Size *
        ?aspectRatio : float
(* Defaults:
        let _aspectRatio = defaultArg aspectRatio 1
*)
-> Mat

Parameters

objectPoints
Type: Emgu.CVIInputArrayOfArrays
Vector of vectors of the calibration pattern points in the calibration pattern coordinate space.
imagePoints
Type: Emgu.CVIInputArrayOfArrays
Vector of vectors of the projections of the calibration pattern points.
imageSize
Type: System.DrawingSize
Image size in pixels used to initialize the principal point.
aspectRatio (Optional)
Type: SystemDouble
If it is zero or negative, both fx and fy are estimated independently. Otherwise, fx=fy*aspectRatio.

Return Value

Type: Mat
An initial camera matrix for the camera calibration process.
Remarks
Currently, the function only supports planar calibration patterns, which are patterns where each object point has z-coordinate =0.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.InitUndistortRectifyMap Method

CvInvokeInitUndistortRectifyMap Method

This function is an extended version of cvInitUndistortMap. That is, in addition to the correction of lens distortion, the function can also apply arbitrary perspective transformation R and finally it can scale and shift the image according to the new camera matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void InitUndistortRectifyMap(
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IInputArray R,
    IInputArray newCameraMatrix,
    Size size,
    DepthType depthType,
    IOutputArray map1,
    IOutputArray map2 = null
)
Public Shared Sub InitUndistortRectifyMap (
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    R As IInputArray,
    newCameraMatrix As IInputArray,
    size As Size,
    depthType As DepthType,
    map1 As IOutputArray,
    Optional map2 As IOutputArray = Nothing
)
public:
static void InitUndistortRectifyMap(
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IInputArray^ R,
    IInputArray^ newCameraMatrix,
    Size^ size,
    DepthType^ depthType,
    IOutputArray^ map1,
    IOutputArray^ map2 = nullptr
)
static member InitUndistortRectifyMap :
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        R : IInputArray *
        newCameraMatrix : IInputArray *
        size : Size *
        depthType : DepthType *
        map1 : IOutputArray *
        ?map2 : IOutputArray
(* Defaults:
        let _map2 = defaultArg map2 null
*)
-> unit

Parameters

cameraMatrix
Type: Emgu.CVIInputArray
The camera matrix A=[fx 0 cx; 0 fy cy; 0 0 1]
distCoeffs
Type: Emgu.CVIInputArray
The vector of distortion coefficients, 4x1, 1x4, 5x1 or 1x5
R
Type: Emgu.CVIInputArray
The rectification transformation in object space (3x3 matrix). R1 or R2, computed by cvStereoRectify can be passed here. If the parameter is IntPtr.Zero, the identity matrix is used
newCameraMatrix
Type: Emgu.CVIInputArray
The new camera matrix A'=[fx' 0 cx'; 0 fy' cy'; 0 0 1]
size
Type: System.DrawingSize
Undistorted image size.
depthType
Type: Emgu.CV.CvEnumDepthType
Depth type of the first output map that can be CV_32FC1 or CV_16SC2 .
map1
Type: Emgu.CVIOutputArray
The first output map.
map2 (Optional)
Type: Emgu.CVIOutputArray
The second output map.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Inpaint Method

CvInvokeInpaint Method

Reconstructs the selected image area from the pixel near the area boundary. The function may be used to remove dust and scratches from a scanned photo, or to remove undesirable objects from still images or video.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Inpaint(
    IInputArray src,
    IInputArray mask,
    IOutputArray dst,
    double inpaintRadius,
    InpaintType flags
)
Public Shared Sub Inpaint (
    src As IInputArray,
    mask As IInputArray,
    dst As IOutputArray,
    inpaintRadius As Double,
    flags As InpaintType
)
public:
static void Inpaint(
    IInputArray^ src,
    IInputArray^ mask,
    IOutputArray^ dst,
    double inpaintRadius,
    InpaintType^ flags
)
static member Inpaint :
        src : IInputArray *
        mask : IInputArray *
        dst : IOutputArray *
        inpaintRadius : float *
        flags : InpaintType -> unit

Parameters

src
Type: Emgu.CVIInputArray
The input 8-bit 1-channel or 3-channel image
mask
Type: Emgu.CVIInputArray
The inpainting mask, 8-bit 1-channel image. Non-zero pixels indicate the area that needs to be inpainted
dst
Type: Emgu.CVIOutputArray
The output image of the same format and the same size as input
inpaintRadius
Type: SystemDouble
The radius of circular neighborhood of each point inpainted that is considered by the algorithm
flags
Type: Emgu.CV.CvEnumInpaintType
The inpainting method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.InRange Method

CvInvokeInRange Method

Performs range check for every element of the input array: dst(I)=lower(I)_0 <= src(I)_0 <= upper(I)_0 For single-channel arrays, dst(I)=lower(I)_0 <= src(I)_0 <= upper(I)_0 && lower(I)_1 <= src(I)_1 <= upper(I)_1 For two-channel arrays etc. dst(I) is set to 0xff (all '1'-bits) if src(I) is within the range and 0 otherwise. All the arrays must have the same type, except the destination, and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void InRange(
    IInputArray src,
    IInputArray lower,
    IInputArray upper,
    IOutputArray dst
)
Public Shared Sub InRange (
    src As IInputArray,
    lower As IInputArray,
    upper As IInputArray,
    dst As IOutputArray
)
public:
static void InRange(
    IInputArray^ src,
    IInputArray^ lower,
    IInputArray^ upper,
    IOutputArray^ dst
)
static member InRange :
        src : IInputArray *
        lower : IInputArray *
        upper : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
lower
Type: Emgu.CVIInputArray
The lower values stored in an image of same type & size as src
upper
Type: Emgu.CVIInputArray
The upper values stored in an image of same type & size as src
dst
Type: Emgu.CVIOutputArray
The resulting mask
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.InsertChannel Method

CvInvokeInsertChannel Method

Insert the specific channel to the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void InsertChannel(
    IInputArray src,
    IInputOutputArray dst,
    int coi
)
Public Shared Sub InsertChannel (
    src As IInputArray,
    dst As IInputOutputArray,
    coi As Integer
)
public:
static void InsertChannel(
    IInputArray^ src,
    IInputOutputArray^ dst,
    int coi
)
static member InsertChannel :
        src : IInputArray *
        dst : IInputOutputArray *
        coi : int -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source channel
dst
Type: Emgu.CVIInputOutputArray
The destination image where the channel will be inserted into
coi
Type: SystemInt32
0-based index of the channel to be inserted
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Integral Method

CvInvokeIntegral Method

Calculates one or more integral images for the source image Using these integral images, one may calculate sum, mean, standard deviation over arbitrary up-right or rotated rectangular region of the image in a constant time. It makes possible to do a fast blurring or fast block correlation with variable window size etc. In case of multi-channel images sums for each channel are accumulated independently.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Integral(
    IInputArray image,
    IOutputArray sum,
    IOutputArray sqsum = null,
    IOutputArray tiltedSum = null,
    DepthType sdepth = -1,
    DepthType sqdepth = -1
)
Public Shared Sub Integral (
    image As IInputArray,
    sum As IOutputArray,
    Optional sqsum As IOutputArray = Nothing,
    Optional tiltedSum As IOutputArray = Nothing,
    Optional sdepth As DepthType = -1,
    Optional sqdepth As DepthType = -1
)
public:
static void Integral(
    IInputArray^ image,
    IOutputArray^ sum,
    IOutputArray^ sqsum = nullptr,
    IOutputArray^ tiltedSum = nullptr,
    DepthType^ sdepth = -1,
    DepthType^ sqdepth = -1
)
static member Integral :
        image : IInputArray *
        sum : IOutputArray *
        ?sqsum : IOutputArray *
        ?tiltedSum : IOutputArray *
        ?sdepth : DepthType *
        ?sqdepth : DepthType
(* Defaults:
        let _sqsum = defaultArg sqsum null
        let _tiltedSum = defaultArg tiltedSum null
        let _sdepth = defaultArg sdepth -1
        let _sqdepth = defaultArg sqdepth -1
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The source image, WxH, 8-bit or floating-point (32f or 64f) image.
sum
Type: Emgu.CVIOutputArray
The integral image, W+1xH+1, 32-bit integer or double precision floating-point (64f).
sqsum (Optional)
Type: Emgu.CVIOutputArray
The integral image for squared pixel values, W+1xH+1, double precision floating-point (64f).
tiltedSum (Optional)
Type: Emgu.CVIOutputArray
The integral for the image rotated by 45 degrees, W+1xH+1, the same data type as sum.
sdepth (Optional)
Type: Emgu.CV.CvEnumDepthType
Desired depth of the integral and the tilted integral images, CV_32S, CV_32F, or CV_64F.
sqdepth (Optional)
Type: Emgu.CV.CvEnumDepthType
Desired depth of the integral image of squared pixel values, CV_32F or CV_64F.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.IntersectConvexConvex Method

CvInvokeIntersectConvexConvex Method

finds intersection of two convex polygons

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static float IntersectConvexConvex(
    IInputArray p1,
    IInputArray p2,
    IOutputArray p12,
    bool handleNested = true
)
Public Shared Function IntersectConvexConvex (
    p1 As IInputArray,
    p2 As IInputArray,
    p12 As IOutputArray,
    Optional handleNested As Boolean = true
) As Single
public:
static float IntersectConvexConvex(
    IInputArray^ p1,
    IInputArray^ p2,
    IOutputArray^ p12,
    bool handleNested = true
)
static member IntersectConvexConvex :
        p1 : IInputArray *
        p2 : IInputArray *
        p12 : IOutputArray *
        ?handleNested : bool
(* Defaults:
        let _handleNested = defaultArg handleNested true
*)
-> float32

Parameters

p1
Type: Emgu.CVIInputArray
The first convex polygon
p2
Type: Emgu.CVIInputArray
The second convex polygon
p12
Type: Emgu.CVIOutputArray
The intersection of the convex polygon
handleNested (Optional)
Type: SystemBoolean
Handle nest

Return Value

Type: Single

[Missing <returns> documentation for "M:Emgu.CV.CvInvoke.IntersectConvexConvex(Emgu.CV.IInputArray,Emgu.CV.IInputArray,Emgu.CV.IOutputArray,System.Boolean)"]

See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Invert Method

CvInvokeInvert Method

Finds the inverse or pseudo-inverse of a matrix. This function inverts the matrix src and stores the result in dst . When the matrix src is singular or non-square, the function calculates the pseudo-inverse matrix (the dst matrix) so that norm(src*dst - I) is minimal, where I is an identity matrix.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Invert(
    IInputArray src,
    IOutputArray dst,
    DecompMethod method
)
Public Shared Function Invert (
    src As IInputArray,
    dst As IOutputArray,
    method As DecompMethod
) As Double
public:
static double Invert(
    IInputArray^ src,
    IOutputArray^ dst,
    DecompMethod^ method
)
static member Invert :
        src : IInputArray *
        dst : IOutputArray *
        method : DecompMethod -> float

Parameters

src
Type: Emgu.CVIInputArray
The input floating-point M x N matrix.
dst
Type: Emgu.CVIOutputArray
The output matrix of N x M size and the same type as src.
method
Type: Emgu.CV.CvEnumDecompMethod
Inversion method

Return Value

Type: Double
In case of the DECOMP_LU method, the function returns non-zero value if the inverse has been successfully calculated and 0 if src is singular. In case of the DECOMP_SVD method, the function returns the inverse condition number of src (the ratio of the smallest singular value to the largest singular value) and 0 if src is singular. The SVD method calculates a pseudo-inverse matrix if src is singular. Similarly to DECOMP_LU, the method DECOMP_CHOLESKY works only with non-singular square matrices that should also be symmetrical and positively defined. In this case, the function stores the inverted matrix in dst and returns non-zero. Otherwise, it returns 0.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.InvertAffineTransform Method

CvInvokeInvertAffineTransform Method

Inverts an affine transformation

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void InvertAffineTransform(
    IInputArray m,
    IOutputArray im
)
Public Shared Sub InvertAffineTransform (
    m As IInputArray,
    im As IOutputArray
)
public:
static void InvertAffineTransform(
    IInputArray^ m,
    IOutputArray^ im
)
static member InvertAffineTransform :
        m : IInputArray *
        im : IOutputArray -> unit

Parameters

m
Type: Emgu.CVIInputArray
Original affine transformation
im
Type: Emgu.CVIOutputArray
Output reverse affine transformation.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.IsContourConvex Method

CvInvokeIsContourConvex Method

The function tests whether the input contour is convex or not. The contour must be simple, that is, without self-intersections. Otherwise, the function output is undefined.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsContourConvex(
    IInputArray contour
)
Public Shared Function IsContourConvex (
    contour As IInputArray
) As Boolean
public:
static bool IsContourConvex(
    IInputArray^ contour
)
static member IsContourConvex :
        contour : IInputArray -> bool

Parameters

contour
Type: Emgu.CVIInputArray
Input vector of 2D points

Return Value

Type: Boolean
true if input is convex
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Kmeans Method

CvInvokeKmeans Method

Implements k-means algorithm that finds centers of cluster_count clusters and groups the input samples around the clusters. On output labels(i) contains a cluster index for sample stored in the i-th row of samples matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Kmeans(
    IInputArray data,
    int k,
    IOutputArray bestLabels,
    MCvTermCriteria termcrit,
    int attempts,
    KMeansInitType flags,
    IOutputArray centers = null
)
Public Shared Function Kmeans (
    data As IInputArray,
    k As Integer,
    bestLabels As IOutputArray,
    termcrit As MCvTermCriteria,
    attempts As Integer,
    flags As KMeansInitType,
    Optional centers As IOutputArray = Nothing
) As Double
public:
static double Kmeans(
    IInputArray^ data,
    int k,
    IOutputArray^ bestLabels,
    MCvTermCriteria^ termcrit,
    int attempts,
    KMeansInitType^ flags,
    IOutputArray^ centers = nullptr
)
static member Kmeans :
        data : IInputArray *
        k : int *
        bestLabels : IOutputArray *
        termcrit : MCvTermCriteria *
        attempts : int *
        flags : KMeansInitType *
        ?centers : IOutputArray
(* Defaults:
        let _centers = defaultArg centers null
*)
-> float

Parameters

data
Type: Emgu.CVIInputArray
Floating-point matrix of input samples, one row per sample
k
Type: SystemInt32
Number of clusters to split the set by.
bestLabels
Type: Emgu.CVIOutputArray
Output integer vector storing cluster indices for every sample
termcrit
Type: Emgu.CV.StructureMCvTermCriteria
Specifies maximum number of iterations and/or accuracy (distance the centers move by between the subsequent iterations)
attempts
Type: SystemInt32
The number of attempts. Use 2 if not sure
flags
Type: Emgu.CV.CvEnumKMeansInitType
Flags, use 0 if not sure
centers (Optional)
Type: Emgu.CVIOutputArray
Pointer to array of centers, use IntPtr.Zero if not sure

Return Value

Type: Double
The function returns the compactness measure. The best (minimum) value is chosen and the corresponding labels and the compactness value are returned by the function.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Laplacian Method

CvInvokeLaplacian Method

Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator: dst(x,y) = d2src/dx2 + d2src/dy2 Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0| Similar to cvSobel function, no scaling is done and the same combinations of input and output formats are supported.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Laplacian(
    IInputArray src,
    IOutputArray dst,
    DepthType ddepth,
    int ksize = 1,
    double scale = 1,
    double delta = 0,
    BorderType borderType = 4
)
Public Shared Sub Laplacian (
    src As IInputArray,
    dst As IOutputArray,
    ddepth As DepthType,
    Optional ksize As Integer = 1,
    Optional scale As Double = 1,
    Optional delta As Double = 0,
    Optional borderType As BorderType = 4
)
public:
static void Laplacian(
    IInputArray^ src,
    IOutputArray^ dst,
    DepthType^ ddepth,
    int ksize = 1,
    double scale = 1,
    double delta = 0,
    BorderType^ borderType = 4
)
static member Laplacian :
        src : IInputArray *
        dst : IOutputArray *
        ddepth : DepthType *
        ?ksize : int *
        ?scale : float *
        ?delta : float *
        ?borderType : BorderType
(* Defaults:
        let _ksize = defaultArg ksize 1
        let _scale = defaultArg scale 1
        let _delta = defaultArg delta 0
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image.
dst
Type: Emgu.CVIOutputArray
Destination image. Should have type of float
ddepth
Type: Emgu.CV.CvEnumDepthType
Desired depth of the destination image.
ksize (Optional)
Type: SystemInt32
Aperture size used to compute the second-derivative filters.
scale (Optional)
Type: SystemDouble
Optional scale factor for the computed Laplacian values. By default, no scaling is applied.
delta (Optional)
Type: SystemDouble
Optional delta value that is added to the results prior to storing them in dst.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Line Method

CvInvokeLine Method

Draws the line segment between pt1 and pt2 points in the image. The line is clipped by the image or ROI rectangle. For non-antialiased lines with integer coordinates the 8-connected or 4-connected Bresenham algorithm is used. Thick lines are drawn with rounding endings. Antialiased lines are drawn using Gaussian filtering.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Line(
    IInputOutputArray img,
    Point pt1,
    Point pt2,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub Line (
    img As IInputOutputArray,
    pt1 As Point,
    pt2 As Point,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void Line(
    IInputOutputArray^ img,
    Point^ pt1,
    Point^ pt2,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
static member Line :
        img : IInputOutputArray *
        pt1 : Point *
        pt2 : Point *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
The image
pt1
Type: System.DrawingPoint
First point of the line segment
pt2
Type: System.DrawingPoint
Second point of the line segment
color
Type: Emgu.CV.StructureMCvScalar
Line color
thickness (Optional)
Type: SystemInt32
Line thickness.
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the line: 8 (or 0) - 8-connected line. 4 - 4-connected line. CV_AA - antialiased line.
shift (Optional)
Type: SystemInt32
Number of fractional bits in the point coordinates
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.LinearPolar Method

CvInvokeLinearPolar Method

The function emulates the human "foveal" vision and can be used for fast scale and rotation-invariant template matching, for object tracking etc.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void LinearPolar(
    IInputArray src,
    IOutputArray dst,
    PointF center,
    double maxRadius,
    Inter interpolationType = 1,
    Warp warpType = 8
)
Public Shared Sub LinearPolar (
    src As IInputArray,
    dst As IOutputArray,
    center As PointF,
    maxRadius As Double,
    Optional interpolationType As Inter = 1,
    Optional warpType As Warp = 8
)
public:
static void LinearPolar(
    IInputArray^ src,
    IOutputArray^ dst,
    PointF^ center,
    double maxRadius,
    Inter^ interpolationType = 1,
    Warp^ warpType = 8
)
static member LinearPolar :
        src : IInputArray *
        dst : IOutputArray *
        center : PointF *
        maxRadius : float *
        ?interpolationType : Inter *
        ?warpType : Warp
(* Defaults:
        let _interpolationType = defaultArg interpolationType 1
        let _warpType = defaultArg warpType 8
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Destination image
center
Type: System.DrawingPointF
The transformation center, where the output precision is maximal
maxRadius
Type: SystemDouble
Maximum radius
interpolationType (Optional)
Type: Emgu.CV.CvEnumInter
Interpolation method
warpType (Optional)
Type: Emgu.CV.CvEnumWarp
Warp method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.LoadUnmanagedModules Method

CvInvokeLoadUnmanagedModules Method

Attempts to load opencv modules from the specific location

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool LoadUnmanagedModules(
    string loadDirectory,
    params string[] unmanagedModules
)
Public Shared Function LoadUnmanagedModules (
    loadDirectory As String,
    ParamArray unmanagedModules As String()
) As Boolean
public:
static bool LoadUnmanagedModules(
    String^ loadDirectory,
    ... array<String^>^ unmanagedModules
)
static member LoadUnmanagedModules :
        loadDirectory : string *
        unmanagedModules : string[] -> bool

Parameters

loadDirectory
Type: SystemString
The directory where the unmanaged modules will be loaded. If it is null, the default location will be used.
unmanagedModules
Type: SystemString
The names of opencv modules. e.g. "opencv_cxcore.dll" on windows.

Return Value

Type: Boolean
True if all the modules has been loaded successfully
Remarks
If loadDirectory is null, the default location on windows is the dll's path appended by either "x64" or "x86", depends on the applications current mode.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Log Method

CvInvokeLog Method

Calculates natural logarithm of absolute value of every element of input array: dst(I)=log(abs(src(I))), src(I)!=0 dst(I)=C, src(I)=0 Where C is large negative number (-700 in the current implementation)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Log(
    IInputArray src,
    IOutputArray dst
)
Public Shared Sub Log (
    src As IInputArray,
    dst As IOutputArray
)
public:
static void Log(
    IInputArray^ src,
    IOutputArray^ dst
)
static member Log :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source array
dst
Type: Emgu.CVIOutputArray
The destination array, it should have double type or the same type as the source
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.LogPolar Method

CvInvokeLogPolar Method

The function emulates the human "foveal" vision and can be used for fast scale and rotation-invariant template matching, for object tracking etc.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void LogPolar(
    IInputArray src,
    IOutputArray dst,
    PointF center,
    double M,
    Inter interpolationType = 1,
    Warp warpType = 8
)
Public Shared Sub LogPolar (
    src As IInputArray,
    dst As IOutputArray,
    center As PointF,
    M As Double,
    Optional interpolationType As Inter = 1,
    Optional warpType As Warp = 8
)
public:
static void LogPolar(
    IInputArray^ src,
    IOutputArray^ dst,
    PointF^ center,
    double M,
    Inter^ interpolationType = 1,
    Warp^ warpType = 8
)
static member LogPolar :
        src : IInputArray *
        dst : IOutputArray *
        center : PointF *
        M : float *
        ?interpolationType : Inter *
        ?warpType : Warp
(* Defaults:
        let _interpolationType = defaultArg interpolationType 1
        let _warpType = defaultArg warpType 8
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Destination image
center
Type: System.DrawingPointF
The transformation center, where the output precision is maximal
M
Type: SystemDouble
Magnitude scale parameter
interpolationType (Optional)
Type: Emgu.CV.CvEnumInter
Interpolation method
warpType (Optional)
Type: Emgu.CV.CvEnumWarp
warp method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.LUT Method

CvInvokeLUT Method

Fills the destination array with values from the look-up table. Indices of the entries are taken from the source array. That is, the function processes each element of src as following: dst(I)=lut[src(I)+DELTA] where DELTA=0 if src has depth CV_8U, and DELTA=128 if src has depth CV_8S

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void LUT(
    IInputArray src,
    IInputArray lut,
    IOutputArray dst
)
Public Shared Sub LUT (
    src As IInputArray,
    lut As IInputArray,
    dst As IOutputArray
)
public:
static void LUT(
    IInputArray^ src,
    IInputArray^ lut,
    IOutputArray^ dst
)
static member LUT :
        src : IInputArray *
        lut : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source array of 8-bit elements
lut
Type: Emgu.CVIInputArray
Look-up table of 256 elements; should have the same depth as the destination array. In case of multi-channel source and destination arrays, the table should either have a single-channel (in this case the same table is used for all channels), or the same number of channels as the source/destination array
dst
Type: Emgu.CVIOutputArray
Destination array of arbitrary depth and of the same number of channels as the source array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Mahalanobis Method

CvInvokeMahalanobis Method

Calculates the weighted distance between two vectors and returns it

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Mahalanobis(
    IInputArray v1,
    IInputArray v2,
    IInputArray iconvar
)
Public Shared Function Mahalanobis (
    v1 As IInputArray,
    v2 As IInputArray,
    iconvar As IInputArray
) As Double
public:
static double Mahalanobis(
    IInputArray^ v1,
    IInputArray^ v2,
    IInputArray^ iconvar
)
static member Mahalanobis :
        v1 : IInputArray *
        v2 : IInputArray *
        iconvar : IInputArray -> float

Parameters

v1
Type: Emgu.CVIInputArray
The first 1D source vector
v2
Type: Emgu.CVIInputArray
The second 1D source vector
iconvar
Type: Emgu.CVIInputArray
The inverse covariation matrix

Return Value

Type: Double
the Mahalanobis distance
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MakeType Method

CvInvokeMakeType Method

This function performs the same as MakeType macro

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int MakeType(
    DepthType depth,
    int channels
)
Public Shared Function MakeType (
    depth As DepthType,
    channels As Integer
) As Integer
public:
static int MakeType(
    DepthType^ depth,
    int channels
)
static member MakeType :
        depth : DepthType *
        channels : int -> int

Parameters

depth
Type: Emgu.CV.CvEnumDepthType
The type of depth
channels
Type: SystemInt32
The number of channels

Return Value

Type: Int32
An interger tha represent a mat type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MatchShapes Method

CvInvokeMatchShapes Method

Compares two shapes. The 3 implemented methods all use Hu moments

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double MatchShapes(
    IInputArray contour1,
    IInputArray contour2,
    ContoursMatchType method,
    double parameter = 0
)
Public Shared Function MatchShapes (
    contour1 As IInputArray,
    contour2 As IInputArray,
    method As ContoursMatchType,
    Optional parameter As Double = 0
) As Double
public:
static double MatchShapes(
    IInputArray^ contour1,
    IInputArray^ contour2,
    ContoursMatchType^ method,
    double parameter = 0
)
static member MatchShapes :
        contour1 : IInputArray *
        contour2 : IInputArray *
        method : ContoursMatchType *
        ?parameter : float
(* Defaults:
        let _parameter = defaultArg parameter 0
*)
-> float

Parameters

contour1
Type: Emgu.CVIInputArray
First contour or grayscale image
contour2
Type: Emgu.CVIInputArray
Second contour or grayscale image
method
Type: Emgu.CV.CvEnumContoursMatchType
Comparison method
parameter (Optional)
Type: SystemDouble
Method-specific parameter (is not used now)

Return Value

Type: Double
The result of the comparison
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MatchTemplate Method

CvInvokeMatchTemplate Method

This function is similiar to cvCalcBackProjectPatch. It slids through image, compares overlapped patches of size wxh with templ using the specified method and stores the comparison results to result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MatchTemplate(
    IInputArray image,
    IInputArray templ,
    IOutputArray result,
    TemplateMatchingType method,
    IInputArray mask = null
)
Public Shared Sub MatchTemplate (
    image As IInputArray,
    templ As IInputArray,
    result As IOutputArray,
    method As TemplateMatchingType,
    Optional mask As IInputArray = Nothing
)
public:
static void MatchTemplate(
    IInputArray^ image,
    IInputArray^ templ,
    IOutputArray^ result,
    TemplateMatchingType^ method,
    IInputArray^ mask = nullptr
)
static member MatchTemplate :
        image : IInputArray *
        templ : IInputArray *
        result : IOutputArray *
        method : TemplateMatchingType *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Image where the search is running. It should be 8-bit or 32-bit floating-point
templ
Type: Emgu.CVIInputArray
Searched template; must be not greater than the source image and the same data type as the image
result
Type: Emgu.CVIOutputArray
A map of comparison results; single-channel 32-bit floating-point. If image is WxH and templ is wxh then result must be W-w+1xH-h+1.
method
Type: Emgu.CV.CvEnumTemplateMatchingType
Specifies the way the template must be compared with image regions
mask (Optional)
Type: Emgu.CVIInputArray
Mask of searched template. It must have the same datatype and size with templ. It is not set by default.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Max Method

CvInvokeMax Method

Calculates per-element maximum of two arrays: dst(I)=max(src1(I), src2(I)) All the arrays must have a single channel, the same data type and the same size (or ROI size).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Max(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst
)
Public Shared Sub Max (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray
)
public:
static void Max(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst
)
static member Max :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray -> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array.
dst
Type: Emgu.CVIOutputArray
The destination array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Mean Method

CvInvokeMean Method

Calculates the average value M of array elements, independently for each channel: N = sumI mask(I)!=0 Mc = 1/N * sumI,mask(I)!=0 arr(I)c If the array is IplImage and COI is set, the function processes the selected channel only and stores the average to the first scalar component (S0).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar Mean(
    IInputArray arr,
    IInputArray mask = null
)
Public Shared Function Mean (
    arr As IInputArray,
    Optional mask As IInputArray = Nothing
) As MCvScalar
public:
static MCvScalar^ Mean(
    IInputArray^ arr,
    IInputArray^ mask = nullptr
)
static member Mean :
        arr : IInputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> MCvScalar

Parameters

arr
Type: Emgu.CVIInputArray
The array
mask (Optional)
Type: Emgu.CVIInputArray
The optional operation mask

Return Value

Type: MCvScalar
average (mean) of array elements
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MeanShift Method

CvInvokeMeanShift Method

Iterates to find the object center given its back projection and initial position of search window. The iterations are made until the search window center moves by less than the given value and/or until the function has done the maximum number of iterations.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int MeanShift(
    IInputArray probImage,
    ref Rectangle window,
    MCvTermCriteria criteria
)
Public Shared Function MeanShift (
    probImage As IInputArray,
    ByRef window As Rectangle,
    criteria As MCvTermCriteria
) As Integer
public:
static int MeanShift(
    IInputArray^ probImage,
    Rectangle^% window,
    MCvTermCriteria^ criteria
)
static member MeanShift :
        probImage : IInputArray *
        window : Rectangle byref *
        criteria : MCvTermCriteria -> int

Parameters

probImage
Type: Emgu.CVIInputArray
Back projection of object histogram
window
Type: System.DrawingRectangle
Initial search window
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Criteria applied to determine when the window search should be finished.

Return Value

Type: Int32
The number of iterations made
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MeanStdDev Method

CvInvokeMeanStdDev Method

Overload List
Name | Description
MeanStdDev(IInputArray, IOutputArray, IOutputArray, IInputArray) | Calculates a mean and standard deviation of array elements.
MeanStdDev(IInputArray, MCvScalar, MCvScalar, IInputArray) | The function cvAvgSdv calculates the average value and standard deviation of array elements, independently for each channel
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MeanStdDev Method (IInputArray, IOutputArray, IOutputArray, IInputArray)

CvInvokeMeanStdDev Method (IInputArray, IOutputArray, IOutputArray, IInputArray)

http://www.emgu.com
Calculates a mean and standard deviation of array elements.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MeanStdDev(
    IInputArray arr,
    IOutputArray mean,
    IOutputArray stdDev,
    IInputArray mask = null
)
Public Shared Sub MeanStdDev (
    arr As IInputArray,
    mean As IOutputArray,
    stdDev As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
static void MeanStdDev(
    IInputArray^ arr,
    IOutputArray^ mean,
    IOutputArray^ stdDev,
    IInputArray^ mask = nullptr
)
static member MeanStdDev :
        arr : IInputArray *
        mean : IOutputArray *
        stdDev : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

arr
Type: Emgu.CVIInputArray
Input array that should have from 1 to 4 channels so that the results can be stored in MCvScalar
mean
Type: Emgu.CVIOutputArray
Calculated mean value
stdDev
Type: Emgu.CVIOutputArray
Calculated standard deviation
mask (Optional)
Type: Emgu.CVIInputArray
Optional operation mask
See Also

Reference

CvInvoke Class
MeanStdDev Overload
Emgu.CV Namespace


CvInvoke.MeanStdDev Method (IInputArray, MCvScalar, MCvScalar, IInputArray)

CvInvokeMeanStdDev Method (IInputArray, MCvScalar, MCvScalar, IInputArray)

http://www.emgu.com
The function cvAvgSdv calculates the average value and standard deviation of array elements, independently for each channel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MeanStdDev(
    IInputArray arr,
    ref MCvScalar mean,
    ref MCvScalar stdDev,
    IInputArray mask = null
)
Public Shared Sub MeanStdDev (
    arr As IInputArray,
    ByRef mean As MCvScalar,
    ByRef stdDev As MCvScalar,
    Optional mask As IInputArray = Nothing
)
public:
static void MeanStdDev(
    IInputArray^ arr,
    MCvScalar^% mean,
    MCvScalar^% stdDev,
    IInputArray^ mask = nullptr
)
static member MeanStdDev :
        arr : IInputArray *
        mean : MCvScalar byref *
        stdDev : MCvScalar byref *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

arr
Type: Emgu.CVIInputArray
The array
mean
Type: Emgu.CV.StructureMCvScalar
Pointer to the mean value
stdDev
Type: Emgu.CV.StructureMCvScalar
Pointer to the standard deviation
mask (Optional)
Type: Emgu.CVIInputArray
The optional operation mask
Remarks
If the array is IplImage and COI is set, the function processes the selected channel only and stores the average and standard deviation to the first compoenents of output scalars (M0 and S0).
See Also

Reference

CvInvoke Class
MeanStdDev Overload
Emgu.CV Namespace


CvInvoke.MedianBlur Method

CvInvokeMedianBlur Method

Blurs an image using the median filter.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MedianBlur(
    IInputArray src,
    IOutputArray dst,
    int ksize
)
Public Shared Sub MedianBlur (
    src As IInputArray,
    dst As IOutputArray,
    ksize As Integer
)
public:
static void MedianBlur(
    IInputArray^ src,
    IOutputArray^ dst,
    int ksize
)
static member MedianBlur :
        src : IInputArray *
        dst : IOutputArray *
        ksize : int -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 1-, 3-, or 4-channel image; when ksize is 3 or 5, the image depth should be CV_8U, CV_16U, or CV_32F, for larger aperture sizes, it can only be CV_8U.
dst
Type: Emgu.CVIOutputArray
Destination array of the same size and type as src.
ksize
Type: SystemInt32
Aperture linear size; it must be odd and greater than 1, for example: 3, 5, 7 ...
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Merge Method

CvInvokeMerge Method

This function is the opposite to cvSplit. If the destination array has N channels then if the first N input channels are not IntPtr.Zero, all they are copied to the destination array, otherwise if only a single source channel of the first N is not IntPtr.Zero, this particular channel is copied into the destination array, otherwise an error is raised. Rest of source channels (beyond the first N) must always be IntPtr.Zero. For IplImage cvCopy with COI set can be also used to insert a single channel into the image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Merge(
    IInputArrayOfArrays mv,
    IOutputArray dst
)
Public Shared Sub Merge (
    mv As IInputArrayOfArrays,
    dst As IOutputArray
)
public:
static void Merge(
    IInputArrayOfArrays^ mv,
    IOutputArray^ dst
)
static member Merge :
        mv : IInputArrayOfArrays *
        dst : IOutputArray -> unit

Parameters

mv
Type: Emgu.CVIInputArrayOfArrays
Input vector of matrices to be merged; all the matrices in mv must have the same size and the same depth.
dst
Type: Emgu.CVIOutputArray
output array of the same size and the same depth as mv[0]; The number of channels will be the total number of channels in the matrix array.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Min Method

CvInvokeMin Method

Calculates per-element minimum of two arrays: dst(I)=min(src1(I),src2(I)) All the arrays must have a single channel, the same data type and the same size (or ROI size).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Min(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst
)
Public Shared Sub Min (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray
)
public:
static void Min(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst
)
static member Min :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray -> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MinAreaRect Method

CvInvokeMinAreaRect Method

Overload List
Name | Description
MinAreaRect(PointF) | Find the bounding rectangle for the specific array of points
MinAreaRect(IInputArray) | Finds a rotated rectangle of the minimum area enclosing the input 2D point set.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MinAreaRect Method (PointF[])

CvInvokeMinAreaRect Method (PointF)

http://www.emgu.com
Find the bounding rectangle for the specific array of points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotatedRect MinAreaRect(
    PointF[] points
)
Public Shared Function MinAreaRect (
    points As PointF()
) As RotatedRect
public:
static RotatedRect^ MinAreaRect(
    array<PointF^>^ points
)
static member MinAreaRect :
        points : PointF[] -> RotatedRect

Parameters

points
Type: System.DrawingPointF
The collection of points

Return Value

Type: RotatedRect
The bounding rectangle for the array of points
See Also

Reference

CvInvoke Class
MinAreaRect Overload
Emgu.CV Namespace


CvInvoke.MinAreaRect Method (IInputArray)

CvInvokeMinAreaRect Method (IInputArray)

http://www.emgu.com
Finds a rotated rectangle of the minimum area enclosing the input 2D point set.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotatedRect MinAreaRect(
    IInputArray points
)
Public Shared Function MinAreaRect (
    points As IInputArray
) As RotatedRect
public:
static RotatedRect^ MinAreaRect(
    IInputArray^ points
)
static member MinAreaRect :
        points : IInputArray -> RotatedRect

Parameters

points
Type: Emgu.CVIInputArray
Input vector of 2D points

Return Value

Type: RotatedRect
a circumscribed rectangle of the minimal area for 2D point set
See Also

Reference

CvInvoke Class
MinAreaRect Overload
Emgu.CV Namespace


CvInvoke.MinEnclosingCircle Method

CvInvokeMinEnclosingCircle Method

Overload List
Name | Description
MinEnclosingCircle(PointF) | Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)
MinEnclosingCircle(IInputArray) | Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MinEnclosingCircle Method (PointF[])

CvInvokeMinEnclosingCircle Method (PointF)

http://www.emgu.com
Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static CircleF MinEnclosingCircle(
    PointF[] points
)
Public Shared Function MinEnclosingCircle (
    points As PointF()
) As CircleF
public:
static CircleF^ MinEnclosingCircle(
    array<PointF^>^ points
)
static member MinEnclosingCircle :
        points : PointF[] -> CircleF

Parameters

points
Type: System.DrawingPointF
Sequence or array of 2D points

Return Value

Type: CircleF
The minimal circumscribed circle for 2D point set
See Also

Reference

CvInvoke Class
MinEnclosingCircle Overload
Emgu.CV Namespace


CvInvoke.MinEnclosingCircle Method (IInputArray)

CvInvokeMinEnclosingCircle Method (IInputArray)

http://www.emgu.com
Finds the minimal circumscribed circle for 2D point set using iterative algorithm. It returns nonzero if the resultant circle contains all the input points and zero otherwise (i.e. algorithm failed)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static CircleF MinEnclosingCircle(
    IInputArray points
)
Public Shared Function MinEnclosingCircle (
    points As IInputArray
) As CircleF
public:
static CircleF^ MinEnclosingCircle(
    IInputArray^ points
)
static member MinEnclosingCircle :
        points : IInputArray -> CircleF

Parameters

points
Type: Emgu.CVIInputArray
Sequence or array of 2D points

Return Value

Type: CircleF
The minimal circumscribed circle for 2D point set
See Also

Reference

CvInvoke Class
MinEnclosingCircle Overload
Emgu.CV Namespace


CvInvoke.MinEnclosingTriangle Method

CvInvokeMinEnclosingTriangle Method

Finds a triangle of minimum area enclosing a 2D point set and returns its area.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double MinEnclosingTriangle(
    IInputArray points,
    IOutputArray triangles
)
Public Shared Function MinEnclosingTriangle (
    points As IInputArray,
    triangles As IOutputArray
) As Double
public:
static double MinEnclosingTriangle(
    IInputArray^ points,
    IOutputArray^ triangles
)
static member MinEnclosingTriangle :
        points : IInputArray *
        triangles : IOutputArray -> float

Parameters

points
Type: Emgu.CVIInputArray
Input vector of 2D points with depth CV_32S or CV_32F
triangles
Type: Emgu.CVIOutputArray
Output vector of three 2D points defining the vertices of the triangle. The depth of the OutputArray must be CV_32F.

Return Value

Type: Double
The triangle's area
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MinMaxIdx Method

CvInvokeMinMaxIdx Method

Finds the global minimum and maximum in an array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MinMaxIdx(
    IInputArray src,
    out double minVal,
    out double maxVal,
    int[] minIdx,
    int[] maxIdx,
    IInputArray mask = null
)
Public Shared Sub MinMaxIdx (
    src As IInputArray,
    <OutAttribute> ByRef minVal As Double,
    <OutAttribute> ByRef maxVal As Double,
    minIdx As Integer(),
    maxIdx As Integer(),
    Optional mask As IInputArray = Nothing
)
public:
static void MinMaxIdx(
    IInputArray^ src,
    [OutAttribute] double% minVal,
    [OutAttribute] double% maxVal,
    array<int>^ minIdx,
    array<int>^ maxIdx,
    IInputArray^ mask = nullptr
)
static member MinMaxIdx :
        src : IInputArray *
        minVal : float byref *
        maxVal : float byref *
        minIdx : int[] *
        maxIdx : int[] *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input single-channel array.
minVal
Type: SystemDouble
The returned minimum value
maxVal
Type: SystemDouble
The returned maximum value
minIdx
Type: SystemInt32
The returned minimum location
maxIdx
Type: SystemInt32
The returned maximum location
mask (Optional)
Type: Emgu.CVIInputArray
The extremums are searched across the whole array if mask is IntPtr.Zert. Otherwise, search is performed in the specified array region.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MinMaxLoc Method

CvInvokeMinMaxLoc Method

Finds minimum and maximum element values and their positions. The extremums are searched over the whole array, selected ROI (in case of IplImage) or, if mask is not IntPtr.Zero, in the specified array region. If the array has more than one channel, it must be IplImage with COI set. In case if multi-dimensional arrays min_loc->x and max_loc->x will contain raw (linear) positions of the extremums

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MinMaxLoc(
    IInputArray arr,
    ref double minVal,
    ref double maxVal,
    ref Point minLoc,
    ref Point maxLoc,
    IInputArray mask = null
)
Public Shared Sub MinMaxLoc (
    arr As IInputArray,
    ByRef minVal As Double,
    ByRef maxVal As Double,
    ByRef minLoc As Point,
    ByRef maxLoc As Point,
    Optional mask As IInputArray = Nothing
)
public:
static void MinMaxLoc(
    IInputArray^ arr,
    double% minVal,
    double% maxVal,
    Point^% minLoc,
    Point^% maxLoc,
    IInputArray^ mask = nullptr
)
static member MinMaxLoc :
        arr : IInputArray *
        minVal : float byref *
        maxVal : float byref *
        minLoc : Point byref *
        maxLoc : Point byref *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

arr
Type: Emgu.CVIInputArray
The source array, single-channel or multi-channel with COI set
minVal
Type: SystemDouble
Pointer to returned minimum value
maxVal
Type: SystemDouble
Pointer to returned maximum value
minLoc
Type: System.DrawingPoint
Pointer to returned minimum location
maxLoc
Type: System.DrawingPoint
Pointer to returned maximum location
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask that is used to select a subarray. Use IntPtr.Zero if not needed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MixChannels Method

CvInvokeMixChannels Method

The function cvMixChannels is a generalized form of cvSplit and cvMerge and some forms of cvCvtColor. It can be used to change the order of the planes, add/remove alpha channel, extract or insert a single plane or multiple planes etc.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MixChannels(
    IInputArrayOfArrays src,
    IInputOutputArray dst,
    int[] fromTo
)
Public Shared Sub MixChannels (
    src As IInputArrayOfArrays,
    dst As IInputOutputArray,
    fromTo As Integer()
)
public:
static void MixChannels(
    IInputArrayOfArrays^ src,
    IInputOutputArray^ dst,
    array<int>^ fromTo
)
static member MixChannels :
        src : IInputArrayOfArrays *
        dst : IInputOutputArray *
        fromTo : int[] -> unit

Parameters

src
Type: Emgu.CVIInputArrayOfArrays
The array of input arrays.
dst
Type: Emgu.CVIInputOutputArray
The array of output arrays
fromTo
Type: SystemInt32
The array of pairs of indices of the planes copied. from_to[k*2] is the 0-based index of the input plane, and from_to[k*2+1] is the index of the output plane, where the continuous numbering of the planes over all the input and over all the output arrays is used. When from_to[k*2] is negative, the corresponding output plane is filled with 0's.
Remarks
Unlike many other new-style C++ functions in OpenCV, mixChannels requires the output arrays to be pre-allocated before calling the function.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Moments Method

CvInvokeMoments Method

Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characeteristics including 7 Hu invariants.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Moments Moments(
    IInputArray arr,
    bool binaryImage = false
)
Public Shared Function Moments (
    arr As IInputArray,
    Optional binaryImage As Boolean = false
) As Moments
public:
static Moments^ Moments(
    IInputArray^ arr,
    bool binaryImage = false
)
static member Moments :
        arr : IInputArray *
        ?binaryImage : bool
(* Defaults:
        let _binaryImage = defaultArg binaryImage false
*)
-> Moments

Parameters

arr
Type: Emgu.CVIInputArray
Image (1-channel or 3-channel with COI set) or polygon (CvSeq of points or a vector of points)
binaryImage (Optional)
Type: SystemBoolean
(For images only) If the flag is true, all the zero pixel values are treated as zeroes, all the others are treated as 1s

Return Value

Type: Moments
The moment
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MorphologyEx Method

CvInvokeMorphologyEx Method

Performs advanced morphological transformations.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MorphologyEx(
    IInputArray src,
    IOutputArray dst,
    MorphOp operation,
    IInputArray kernel,
    Point anchor,
    int iterations,
    BorderType borderType,
    MCvScalar borderValue
)
Public Shared Sub MorphologyEx (
    src As IInputArray,
    dst As IOutputArray,
    operation As MorphOp,
    kernel As IInputArray,
    anchor As Point,
    iterations As Integer,
    borderType As BorderType,
    borderValue As MCvScalar
)
public:
static void MorphologyEx(
    IInputArray^ src,
    IOutputArray^ dst,
    MorphOp^ operation,
    IInputArray^ kernel,
    Point^ anchor,
    int iterations,
    BorderType^ borderType,
    MCvScalar^ borderValue
)
static member MorphologyEx :
        src : IInputArray *
        dst : IOutputArray *
        operation : MorphOp *
        kernel : IInputArray *
        anchor : Point *
        iterations : int *
        borderType : BorderType *
        borderValue : MCvScalar -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image.
dst
Type: Emgu.CVIOutputArray
Destination image.
operation
Type: Emgu.CV.CvEnumMorphOp
Type of morphological operation.
kernel
Type: Emgu.CVIInputArray
Structuring element.
anchor
Type: System.DrawingPoint
Anchor position with the kernel. Negative values mean that the anchor is at the kernel center.
iterations
Type: SystemInt32
Number of times erosion and dilation are applied.
borderType
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method.
borderValue
Type: Emgu.CV.StructureMCvScalar
Border value in case of a constant border.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MulSpectrums Method

CvInvokeMulSpectrums Method

Performs per-element multiplication of the two CCS-packed or complex matrices that are results of real or complex Fourier transform.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MulSpectrums(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    MulSpectrumsType flags,
    bool conjB = false
)
Public Shared Sub MulSpectrums (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    flags As MulSpectrumsType,
    Optional conjB As Boolean = false
)
public:
static void MulSpectrums(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    MulSpectrumsType^ flags,
    bool conjB = false
)
static member MulSpectrums :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        flags : MulSpectrumsType *
        ?conjB : bool
(* Defaults:
        let _conjB = defaultArg conjB false
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array of the same type and the same size of the sources
flags
Type: Emgu.CV.CvEnumMulSpectrumsType
Operation flags; currently, the only supported flag is DFT_ROWS, which indicates that each row of src1 and src2 is an independent 1D Fourier spectrum.
conjB (Optional)
Type: SystemBoolean
Optional flag that conjugates the second input array before the multiplication (true) or not (false).
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Multiply Method

CvInvokeMultiply Method

Calculates per-element product of two arrays: dst(I)=scale*src1(I)*src2(I) All the arrays must have the same type, and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Multiply(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    double scale = 1,
    DepthType dtype = -1
)
Public Shared Sub Multiply (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional scale As Double = 1,
    Optional dtype As DepthType = -1
)
public:
static void Multiply(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    double scale = 1,
    DepthType^ dtype = -1
)
static member Multiply :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?scale : float *
        ?dtype : DepthType
(* Defaults:
        let _scale = defaultArg scale 1
        let _dtype = defaultArg dtype -1
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array.
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
scale (Optional)
Type: SystemDouble
Optional scale factor
dtype (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MulTransposed Method

CvInvokeMulTransposed Method

Calculates the product of src and its transposition. The function evaluates dst=scale(src-delta)*(src-delta)^T if order=0, and dst=scale(src-delta)^T*(src-delta) otherwise.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MulTransposed(
    IInputArray src,
    IOutputArray dst,
    bool aTa,
    IInputArray delta = null,
    double scale = 1,
    DepthType dtype = -1
)
Public Shared Sub MulTransposed (
    src As IInputArray,
    dst As IOutputArray,
    aTa As Boolean,
    Optional delta As IInputArray = Nothing,
    Optional scale As Double = 1,
    Optional dtype As DepthType = -1
)
public:
static void MulTransposed(
    IInputArray^ src,
    IOutputArray^ dst,
    bool aTa,
    IInputArray^ delta = nullptr,
    double scale = 1,
    DepthType^ dtype = -1
)
static member MulTransposed :
        src : IInputArray *
        dst : IOutputArray *
        aTa : bool *
        ?delta : IInputArray *
        ?scale : float *
        ?dtype : DepthType
(* Defaults:
        let _delta = defaultArg delta null
        let _scale = defaultArg scale 1
        let _dtype = defaultArg dtype -1
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source matrix
dst
Type: Emgu.CVIOutputArray
The destination matrix
aTa
Type: SystemBoolean
Order of multipliers
delta (Optional)
Type: Emgu.CVIInputArray
An optional array, subtracted from src before multiplication
scale (Optional)
Type: SystemDouble
An optional scaling
dtype (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth type of the output array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.NamedWindow Method

CvInvokeNamedWindow Method

Creates a window which can be used as a placeholder for images and trackbars. Created windows are reffered by their names. If the window with such a name already exists, the function does nothing.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void NamedWindow(
    string name,
    NamedWindowType flags = 1
)
Public Shared Sub NamedWindow (
    name As String,
    Optional flags As NamedWindowType = 1
)
public:
static void NamedWindow(
    String^ name,
    NamedWindowType^ flags = 1
)
static member NamedWindow :
        name : string *
        ?flags : NamedWindowType
(* Defaults:
        let _flags = defaultArg flags 1
*)
-> unit

Parameters

name
Type: SystemString
Name of the window which is used as window identifier and appears in the window caption
flags (Optional)
Type: Emgu.CV.CvEnumNamedWindowType
Flags of the window.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Norm Method

CvInvokeNorm Method

Overload List
Name | Description
Norm(IInputArray, NormType, IInputArray) | Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.
Norm(IInputArray, IInputOutputArray, NormType, IInputArray) | Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Norm Method (IInputArray, NormType, IInputArray)

CvInvokeNorm Method (IInputArray, NormType, IInputArray)

http://www.emgu.com
Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Norm(
    IInputArray arr1,
    NormType normType = 4,
    IInputArray mask = null
)
Public Shared Function Norm (
    arr1 As IInputArray,
    Optional normType As NormType = 4,
    Optional mask As IInputArray = Nothing
) As Double
public:
static double Norm(
    IInputArray^ arr1,
    NormType^ normType = 4,
    IInputArray^ mask = nullptr
)
static member Norm :
        arr1 : IInputArray *
        ?normType : NormType *
        ?mask : IInputArray
(* Defaults:
        let _normType = defaultArg normType 4
        let _mask = defaultArg mask null
*)
-> float

Parameters

arr1
Type: Emgu.CVIInputArray
The first source image
normType (Optional)
Type: Emgu.CV.CvEnumNormType
Type of norm
mask (Optional)
Type: Emgu.CVIInputArray
The optional operation mask

Return Value

Type: Double
The calculated norm
See Also

Reference

CvInvoke Class
Norm Overload
Emgu.CV Namespace


CvInvoke.Norm Method (IInputArray, IInputOutputArray, NormType, IInputArray)

CvInvokeNorm Method (IInputArray, IInputOutputArray, NormType, IInputArray)

http://www.emgu.com
Returns the calculated norm. The multiple-channel array are treated as single-channel, that is, the results for all channels are combined.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Norm(
    IInputArray arr1,
    IInputOutputArray arr2,
    NormType normType = 4,
    IInputArray mask = null
)
Public Shared Function Norm (
    arr1 As IInputArray,
    arr2 As IInputOutputArray,
    Optional normType As NormType = 4,
    Optional mask As IInputArray = Nothing
) As Double
public:
static double Norm(
    IInputArray^ arr1,
    IInputOutputArray^ arr2,
    NormType^ normType = 4,
    IInputArray^ mask = nullptr
)
static member Norm :
        arr1 : IInputArray *
        arr2 : IInputOutputArray *
        ?normType : NormType *
        ?mask : IInputArray
(* Defaults:
        let _normType = defaultArg normType 4
        let _mask = defaultArg mask null
*)
-> float

Parameters

arr1
Type: Emgu.CVIInputArray
The first source image
arr2
Type: Emgu.CVIInputOutputArray
The second source image. If it is null, the absolute norm of arr1 is calculated, otherwise absolute or relative norm of arr1-arr2 is calculated
normType (Optional)
Type: Emgu.CV.CvEnumNormType
Type of norm
mask (Optional)
Type: Emgu.CVIInputArray
The optional operation mask

Return Value

Type: Double
The calculated norm
See Also

Reference

CvInvoke Class
Norm Overload
Emgu.CV Namespace


CvInvoke.Normalize Method

CvInvokeNormalize Method

normalizes the input array so that it's norm or value range takes the certain value(s).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Normalize(
    IInputArray src,
    IOutputArray dst,
    double alpha = 1,
    double beta = 0,
    NormType normType = 4,
    DepthType dType = -1,
    IInputArray mask = null
)
Public Shared Sub Normalize (
    src As IInputArray,
    dst As IOutputArray,
    Optional alpha As Double = 1,
    Optional beta As Double = 0,
    Optional normType As NormType = 4,
    Optional dType As DepthType = -1,
    Optional mask As IInputArray = Nothing
)
public:
static void Normalize(
    IInputArray^ src,
    IOutputArray^ dst,
    double alpha = 1,
    double beta = 0,
    NormType^ normType = 4,
    DepthType^ dType = -1,
    IInputArray^ mask = nullptr
)
static member Normalize :
        src : IInputArray *
        dst : IOutputArray *
        ?alpha : float *
        ?beta : float *
        ?normType : NormType *
        ?dType : DepthType *
        ?mask : IInputArray
(* Defaults:
        let _alpha = defaultArg alpha 1
        let _beta = defaultArg beta 0
        let _normType = defaultArg normType 4
        let _dType = defaultArg dType -1
        let _mask = defaultArg mask null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The input array
dst
Type: Emgu.CVIOutputArray
The output array; in-place operation is supported
alpha (Optional)
Type: SystemDouble
The minimum/maximum value of the output array or the norm of output array
beta (Optional)
Type: SystemDouble
The maximum/minimum value of the output array
normType (Optional)
Type: Emgu.CV.CvEnumNormType
The normalization type
dType (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth type for the dst array
mask (Optional)
Type: Emgu.CVIInputArray
The operation mask. Makes the function consider and normalize only certain array elements
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.OclFinish Method

CvInvokeOclFinish Method

Finishes OpenCL queue.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void OclFinish()
Public Shared Sub OclFinish
public:
static void OclFinish()
static member OclFinish : unit -> unit
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.OclGetPlatformsSummary Method

CvInvokeOclGetPlatformsSummary Method

Get the OpenCL platform summary as a string

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string OclGetPlatformsSummary()
Public Shared Function OclGetPlatformsSummary As String
public:
static String^ OclGetPlatformsSummary()
static member OclGetPlatformsSummary : unit -> string

Return Value

Type: String
An OpenCL platform summary
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.OclSetDefaultDevice Method

CvInvokeOclSetDefaultDevice Method

Set the default opencl device

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void OclSetDefaultDevice(
    string deviceName
)
Public Shared Sub OclSetDefaultDevice (
    deviceName As String
)
public:
static void OclSetDefaultDevice(
    String^ deviceName
)
static member OclSetDefaultDevice :
        deviceName : string -> unit

Parameters

deviceName
Type: SystemString
The name of the opencl device
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PatchNaNs Method

CvInvokePatchNaNs Method

Converts NaN's to the given number

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PatchNaNs(
    IInputOutputArray a,
    double val = 0
)
Public Shared Sub PatchNaNs (
    a As IInputOutputArray,
    Optional val As Double = 0
)
public:
static void PatchNaNs(
    IInputOutputArray^ a,
    double val = 0
)
static member PatchNaNs :
        a : IInputOutputArray *
        ?val : float
(* Defaults:
        let _val = defaultArg val 0
*)
-> unit

Parameters

a
Type: Emgu.CVIInputOutputArray
The array where NaN needs to be converted
val (Optional)
Type: SystemDouble
The value to convert to
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PCABackProject Method

CvInvokePCABackProject Method

Reconstructs vectors from their PC projections.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PCABackProject(
    IInputArray data,
    IInputArray mean,
    IInputArray eigenvectors,
    IOutputArray result
)
Public Shared Sub PCABackProject (
    data As IInputArray,
    mean As IInputArray,
    eigenvectors As IInputArray,
    result As IOutputArray
)
public:
static void PCABackProject(
    IInputArray^ data,
    IInputArray^ mean,
    IInputArray^ eigenvectors,
    IOutputArray^ result
)
static member PCABackProject :
        data : IInputArray *
        mean : IInputArray *
        eigenvectors : IInputArray *
        result : IOutputArray -> unit

Parameters

data
Type: Emgu.CVIInputArray
Coordinates of the vectors in the principal component subspace
mean
Type: Emgu.CVIInputArray
The mean.
eigenvectors
Type: Emgu.CVIInputArray
The eigenvectors.
result
Type: Emgu.CVIOutputArray
The result.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PCACompute Method

CvInvokePCACompute Method

Overload List
Name | Description
PCACompute(IInputArray, IInputOutputArray, IOutputArray, Double) | Performs Principal Component Analysis of the supplied dataset.
PCACompute(IInputArray, IInputOutputArray, IOutputArray, Int32) | Performs Principal Component Analysis of the supplied dataset.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PCACompute Method (IInputArray, IInputOutputArray, IOutputArray, Double)

CvInvokePCACompute Method (IInputArray, IInputOutputArray, IOutputArray, Double)

http://www.emgu.com
Performs Principal Component Analysis of the supplied dataset.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PCACompute(
    IInputArray data,
    IInputOutputArray mean,
    IOutputArray eigenvectors,
    double retainedVariance
)
Public Shared Sub PCACompute (
    data As IInputArray,
    mean As IInputOutputArray,
    eigenvectors As IOutputArray,
    retainedVariance As Double
)
public:
static void PCACompute(
    IInputArray^ data,
    IInputOutputArray^ mean,
    IOutputArray^ eigenvectors,
    double retainedVariance
)
static member PCACompute :
        data : IInputArray *
        mean : IInputOutputArray *
        eigenvectors : IOutputArray *
        retainedVariance : float -> unit

Parameters

data
Type: Emgu.CVIInputArray
Input samples stored as the matrix rows or as the matrix columns.
mean
Type: Emgu.CVIInputOutputArray
Optional mean value; if the matrix is empty, the mean is computed from the data.
eigenvectors
Type: Emgu.CVIOutputArray
The eigenvectors.
retainedVariance
Type: SystemDouble
Percentage of variance that PCA should retain. Using this parameter will let the PCA decided how many components to retain but it will always keep at least 2.
See Also

Reference

CvInvoke Class
PCACompute Overload
Emgu.CV Namespace


CvInvoke.PCACompute Method (IInputArray, IInputOutputArray, IOutputArray, Int32)

CvInvokePCACompute Method (IInputArray, IInputOutputArray, IOutputArray, Int32)

http://www.emgu.com
Performs Principal Component Analysis of the supplied dataset.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PCACompute(
    IInputArray data,
    IInputOutputArray mean,
    IOutputArray eigenvectors,
    int maxComponents = 0
)
Public Shared Sub PCACompute (
    data As IInputArray,
    mean As IInputOutputArray,
    eigenvectors As IOutputArray,
    Optional maxComponents As Integer = 0
)
public:
static void PCACompute(
    IInputArray^ data,
    IInputOutputArray^ mean,
    IOutputArray^ eigenvectors,
    int maxComponents = 0
)
static member PCACompute :
        data : IInputArray *
        mean : IInputOutputArray *
        eigenvectors : IOutputArray *
        ?maxComponents : int
(* Defaults:
        let _maxComponents = defaultArg maxComponents 0
*)
-> unit

Parameters

data
Type: Emgu.CVIInputArray
Input samples stored as the matrix rows or as the matrix columns.
mean
Type: Emgu.CVIInputOutputArray
Optional mean value; if the matrix is empty, the mean is computed from the data.
eigenvectors
Type: Emgu.CVIOutputArray
The eigenvectors.
maxComponents (Optional)
Type: SystemInt32
Maximum number of components that PCA should retain; by default, all the components are retained.
See Also

Reference

CvInvoke Class
PCACompute Overload
Emgu.CV Namespace


CvInvoke.PCAProject Method

CvInvokePCAProject Method

Projects vector(s) to the principal component subspace.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PCAProject(
    IInputArray data,
    IInputArray mean,
    IInputArray eigenvectors,
    IOutputArray result
)
Public Shared Sub PCAProject (
    data As IInputArray,
    mean As IInputArray,
    eigenvectors As IInputArray,
    result As IOutputArray
)
public:
static void PCAProject(
    IInputArray^ data,
    IInputArray^ mean,
    IInputArray^ eigenvectors,
    IOutputArray^ result
)
static member PCAProject :
        data : IInputArray *
        mean : IInputArray *
        eigenvectors : IInputArray *
        result : IOutputArray -> unit

Parameters

data
Type: Emgu.CVIInputArray
Input vector(s); must have the same dimensionality and the same layout as the input data used at PCA phase
mean
Type: Emgu.CVIInputArray
The mean.
eigenvectors
Type: Emgu.CVIInputArray
The eigenvectors.
result
Type: Emgu.CVIOutputArray
The result.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PencilSketch Method

CvInvokePencilSketch Method

Pencil-like non-photorealistic line drawing

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PencilSketch(
    IInputArray src,
    IOutputArray dst1,
    IOutputArray dst2,
    float sigmaS = 60f,
    float sigmaR = 0.07f,
    float shadeFactor = 0.02f
)
Public Shared Sub PencilSketch (
    src As IInputArray,
    dst1 As IOutputArray,
    dst2 As IOutputArray,
    Optional sigmaS As Single = 60F,
    Optional sigmaR As Single = 0.07F,
    Optional shadeFactor As Single = 0.02F
)
public:
static void PencilSketch(
    IInputArray^ src,
    IOutputArray^ dst1,
    IOutputArray^ dst2,
    float sigmaS = 60f,
    float sigmaR = 0.07f,
    float shadeFactor = 0.02f
)
static member PencilSketch :
        src : IInputArray *
        dst1 : IOutputArray *
        dst2 : IOutputArray *
        ?sigmaS : float32 *
        ?sigmaR : float32 *
        ?shadeFactor : float32
(* Defaults:
        let _sigmaS = defaultArg sigmaS 60f
        let _sigmaR = defaultArg sigmaR 0.07f
        let _shadeFactor = defaultArg shadeFactor 0.02f
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image
dst1
Type: Emgu.CVIOutputArray
Output 8-bit 1-channel image
dst2
Type: Emgu.CVIOutputArray
Output image with the same size and type as src
sigmaS (Optional)
Type: SystemSingle
Range between 0 to 200
sigmaR (Optional)
Type: SystemSingle
Range between 0 to 1
shadeFactor (Optional)
Type: SystemSingle
Range between 0 to 0.1
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PerspectiveTransform Method

CvInvokePerspectiveTransform Method

Overload List
Name | Description
PerspectiveTransform(PointF, IInputArray) | Transforms every element of src in the following way: (x, y) -> (x'/w, y'/w), where (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise
PerspectiveTransform(IInputArray, IOutputArray, IInputArray) | Transforms every element of src (by treating it as 2D or 3D vector) in the following way: (x, y, z) -> (x'/w, y'/w, z'/w) or (x, y) -> (x'/w, y'/w), where (x', y', z', w') = mat4x4 * (x, y, z, 1) or (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PerspectiveTransform Method (PointF[], IInputArray)

CvInvokePerspectiveTransform Method (PointF, IInputArray)

http://www.emgu.com
Transforms every element of src in the following way: (x, y) -> (x'/w, y'/w), where (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static PointF[] PerspectiveTransform(
    PointF[] src,
    IInputArray mat
)
Public Shared Function PerspectiveTransform (
    src As PointF(),
    mat As IInputArray
) As PointF()
public:
static array<PointF^>^ PerspectiveTransform(
    array<PointF^>^ src,
    IInputArray^ mat
)
static member PerspectiveTransform :
        src : PointF[] *
        mat : IInputArray -> PointF[]

Parameters

src
Type: System.DrawingPointF
The source points
mat
Type: Emgu.CVIInputArray
3x3 floating-point transformation matrix.

Return Value

Type: PointF
The destination points
See Also

Reference

CvInvoke Class
PerspectiveTransform Overload
Emgu.CV Namespace


CvInvoke.PerspectiveTransform Method (IInputArray, IOutputArray, IInputArray)

CvInvokePerspectiveTransform Method (IInputArray, IOutputArray, IInputArray)

http://www.emgu.com
Transforms every element of src (by treating it as 2D or 3D vector) in the following way: (x, y, z) -> (x'/w, y'/w, z'/w) or (x, y) -> (x'/w, y'/w), where (x', y', z', w') = mat4x4 * (x, y, z, 1) or (x', y', w') = mat3x3 * (x, y, 1) and w = w' if w'!=0, inf otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PerspectiveTransform(
    IInputArray src,
    IOutputArray dst,
    IInputArray mat
)
Public Shared Sub PerspectiveTransform (
    src As IInputArray,
    dst As IOutputArray,
    mat As IInputArray
)
public:
static void PerspectiveTransform(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ mat
)
static member PerspectiveTransform :
        src : IInputArray *
        dst : IOutputArray *
        mat : IInputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source three-channel floating-point array
dst
Type: Emgu.CVIOutputArray
The destination three-channel floating-point array
mat
Type: Emgu.CVIInputArray
3x3 or 4x4 floating-point transformation matrix.
See Also

Reference

CvInvoke Class
PerspectiveTransform Overload
Emgu.CV Namespace


CvInvoke.PhaseCorrelate Method

CvInvokePhaseCorrelate Method

The function is used to detect translational shifts that occur between two images. The operation takes advantage of the Fourier shift theorem for detecting the translational shift in the frequency domain. It can be used for fast image registration as well as motion estimation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint2D64f PhaseCorrelate(
    IInputArray src1,
    IInputArray src2,
    IInputArray window,
    out double response
)
Public Shared Function PhaseCorrelate (
    src1 As IInputArray,
    src2 As IInputArray,
    window As IInputArray,
    <OutAttribute> ByRef response As Double
) As MCvPoint2D64f
public:
static MCvPoint2D64f^ PhaseCorrelate(
    IInputArray^ src1,
    IInputArray^ src2,
    IInputArray^ window,
    [OutAttribute] double% response
)
static member PhaseCorrelate :
        src1 : IInputArray *
        src2 : IInputArray *
        window : IInputArray *
        response : float byref -> MCvPoint2D64f

Parameters

src1
Type: Emgu.CVIInputArray
Source floating point array (CV_32FC1 or CV_64FC1)
src2
Type: Emgu.CVIInputArray
Source floating point array (CV_32FC1 or CV_64FC1)
window
Type: Emgu.CVIInputArray
Floating point array with windowing coefficients to reduce edge effects (optional).
response
Type: SystemDouble
Signal power within the 5x5 centroid around the peak, between 0 and 1

Return Value

Type: MCvPoint2D64f
The translational shifts that occur between two images
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PointPolygonTest Method

CvInvokePointPolygonTest Method

Determines whether the point is inside contour, outside, or lies on an edge (or coinsides with a vertex). It returns positive, negative or zero value, correspondingly

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double PointPolygonTest(
    IInputArray contour,
    PointF pt,
    bool measureDist
)
Public Shared Function PointPolygonTest (
    contour As IInputArray,
    pt As PointF,
    measureDist As Boolean
) As Double
public:
static double PointPolygonTest(
    IInputArray^ contour,
    PointF^ pt,
    bool measureDist
)
static member PointPolygonTest :
        contour : IInputArray *
        pt : PointF *
        measureDist : bool -> float

Parameters

contour
Type: Emgu.CVIInputArray
Input contour
pt
Type: System.DrawingPointF
The point tested against the contour
measureDist
Type: SystemBoolean
If != 0, the function estimates distance from the point to the nearest contour edge

Return Value

Type: Double
When measureDist = false, the return value is >0 (inside), <0 (outside) and =0 (on edge), respectively. When measureDist != true, it is a signed distance between the point and the nearest contour edge
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PolarToCart Method

CvInvokePolarToCart Method

Calculates either x-coordinate, y-coordinate or both of every vector magnitude(I)* exp(angle(I)*j), j=sqrt(-1): x(I)=magnitude(I)*cos(angle(I)), y(I)=magnitude(I)*sin(angle(I))

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PolarToCart(
    IInputArray magnitude,
    IInputArray angle,
    IOutputArray x,
    IOutputArray y,
    bool angleInDegrees = false
)
Public Shared Sub PolarToCart (
    magnitude As IInputArray,
    angle As IInputArray,
    x As IOutputArray,
    y As IOutputArray,
    Optional angleInDegrees As Boolean = false
)
public:
static void PolarToCart(
    IInputArray^ magnitude,
    IInputArray^ angle,
    IOutputArray^ x,
    IOutputArray^ y,
    bool angleInDegrees = false
)
static member PolarToCart :
        magnitude : IInputArray *
        angle : IInputArray *
        x : IOutputArray *
        y : IOutputArray *
        ?angleInDegrees : bool
(* Defaults:
        let _angleInDegrees = defaultArg angleInDegrees false
*)
-> unit

Parameters

magnitude
Type: Emgu.CVIInputArray
Input floating-point array of magnitudes of 2D vectors; it can be an empty matrix (=Mat()), in this case, the function assumes that all the magnitudes are =1; if it is not empty, it must have the same size and type as angle
angle
Type: Emgu.CVIInputArray
input floating-point array of angles of 2D vectors.
x
Type: Emgu.CVIOutputArray
Output array of x-coordinates of 2D vectors; it has the same size and type as angle.
y
Type: Emgu.CVIOutputArray
Output array of y-coordinates of 2D vectors; it has the same size and type as angle.
angleInDegrees (Optional)
Type: SystemBoolean
The flag indicating whether the angles are measured in radians or in degrees
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Polylines Method

CvInvokePolylines Method

Overload List
Name | Description
Polylines(IInputOutputArray, IInputArray, Boolean, MCvScalar, Int32, LineType, Int32) | Draws a single or multiple polygonal curves
Polylines(IInputOutputArray, Point, Boolean, MCvScalar, Int32, LineType, Int32) | Draws a single or multiple polygonal curves
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Polylines Method (IInputOutputArray, IInputArray, Boolean, MCvScalar, Int32, LineType, Int32)

CvInvokePolylines Method (IInputOutputArray, IInputArray, Boolean, MCvScalar, Int32, LineType, Int32)

http://www.emgu.com
Draws a single or multiple polygonal curves

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Polylines(
    IInputOutputArray img,
    IInputArray pts,
    bool isClosed,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub Polylines (
    img As IInputOutputArray,
    pts As IInputArray,
    isClosed As Boolean,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void Polylines(
    IInputOutputArray^ img,
    IInputArray^ pts,
    bool isClosed,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
static member Polylines :
        img : IInputOutputArray *
        pts : IInputArray *
        isClosed : bool *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image
pts
Type: Emgu.CVIInputArray
Array of pointers to polylines
isClosed
Type: SystemBoolean
Indicates whether the polylines must be drawn closed. If !=0, the function draws the line from the last vertex of every contour to the first vertex.
color
Type: Emgu.CV.StructureMCvScalar
Polyline color
thickness (Optional)
Type: SystemInt32
Thickness of the polyline edges
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the line segments, see cvLine description
shift (Optional)
Type: SystemInt32
Number of fractional bits in the vertex coordinates
See Also

Reference

CvInvoke Class
Polylines Overload
Emgu.CV Namespace


CvInvoke.Polylines Method (IInputOutputArray, Point[], Boolean, MCvScalar, Int32, LineType, Int32)

CvInvokePolylines Method (IInputOutputArray, Point, Boolean, MCvScalar, Int32, LineType, Int32)

http://www.emgu.com
Draws a single or multiple polygonal curves

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Polylines(
    IInputOutputArray img,
    Point[] pts,
    bool isClosed,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub Polylines (
    img As IInputOutputArray,
    pts As Point(),
    isClosed As Boolean,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void Polylines(
    IInputOutputArray^ img,
    array<Point^>^ pts,
    bool isClosed,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
static member Polylines :
        img : IInputOutputArray *
        pts : Point[] *
        isClosed : bool *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image
pts
Type: System.DrawingPoint
Array points
isClosed
Type: SystemBoolean
Indicates whether the polylines must be drawn closed. If !=0, the function draws the line from the last vertex of every contour to the first vertex.
color
Type: Emgu.CV.StructureMCvScalar
Polyline color
thickness (Optional)
Type: SystemInt32
Thickness of the polyline edges
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the line segments, see cvLine description
shift (Optional)
Type: SystemInt32
Number of fractional bits in the vertex coordinates
See Also

Reference

CvInvoke Class
Polylines Overload
Emgu.CV Namespace


CvInvoke.Pow Method

CvInvokePow Method

Raises every element of input array to p: dst(I)=src(I)p, if p is integer dst(I)=abs(src(I))p, otherwise That is, for non-integer power exponent the absolute values of input array elements are used. However, it is possible to get true values for negative values using some extra operations, as the following sample, computing cube root of array elements, shows: CvSize size = cvGetSize(src); CvMat* mask = cvCreateMat( size.height, size.width, CV_8UC1 ); cvCmpS( src, 0, mask, CV_CMP_LT ); /* find negative elements */ cvPow( src, dst, 1./3 ); cvSubRS( dst, cvScalarAll(0), dst, mask ); /* negate the results of negative inputs */ cvReleaseMat( &mask ); For some values of power, such as integer values, 0.5 and -0.5, specialized faster algorithms are used.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Pow(
    IInputArray src,
    double power,
    IOutputArray dst
)
Public Shared Sub Pow (
    src As IInputArray,
    power As Double,
    dst As IOutputArray
)
public:
static void Pow(
    IInputArray^ src,
    double power,
    IOutputArray^ dst
)
static member Pow :
        src : IInputArray *
        power : float *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source array
power
Type: SystemDouble
The exponent of power
dst
Type: Emgu.CVIOutputArray
The destination array, should be the same type as the source
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ProjectPoints Method

CvInvokeProjectPoints Method

Overload List
Name | Description
ProjectPoints(MCvPoint3D32f, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, Double) | Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters.
ProjectPoints(IInputArray, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Double) | Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters. Note, that with intrinsic and/or extrinsic parameters set to special values, the function can be used to compute just extrinsic transformation or just intrinsic transformation (i.e. distortion of a sparse set of points).
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ProjectPoints Method (MCvPoint3D32f[], IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, Double)

CvInvokeProjectPoints Method (MCvPoint3D32f, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, Double)

http://www.emgu.com
Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static PointF[] ProjectPoints(
    MCvPoint3D32f[] objectPoints,
    IInputArray rvec,
    IInputArray tvec,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IOutputArray jacobian = null,
    double aspectRatio = 0
)
Public Shared Function ProjectPoints (
    objectPoints As MCvPoint3D32f(),
    rvec As IInputArray,
    tvec As IInputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    Optional jacobian As IOutputArray = Nothing,
    Optional aspectRatio As Double = 0
) As PointF()
public:
static array<PointF^>^ ProjectPoints(
    array<MCvPoint3D32f^>^ objectPoints,
    IInputArray^ rvec,
    IInputArray^ tvec,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IOutputArray^ jacobian = nullptr,
    double aspectRatio = 0
)
static member ProjectPoints :
        objectPoints : MCvPoint3D32f[] *
        rvec : IInputArray *
        tvec : IInputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        ?jacobian : IOutputArray *
        ?aspectRatio : float
(* Defaults:
        let _jacobian = defaultArg jacobian null
        let _aspectRatio = defaultArg aspectRatio 0
*)
-> PointF[]

Parameters

objectPoints
Type: Emgu.CV.StructureMCvPoint3D32f
The array of object points.
rvec
Type: Emgu.CVIInputArray
The rotation vector, 1x3 or 3x1
tvec
Type: Emgu.CVIInputArray
The translation vector, 1x3 or 3x1
cameraMatrix
Type: Emgu.CVIInputArray
The camera matrix (A) [fx 0 cx; 0 fy cy; 0 0 1].
distCoeffs
Type: Emgu.CVIInputArray
The vector of distortion coefficients, 4x1 or 1x4 [k1, k2, p1, p2]. If it is IntPtr.Zero, all distortion coefficients are considered 0's
jacobian (Optional)
Type: Emgu.CVIOutputArray
Optional output 2Nx(10+<numDistCoeffs>) jacobian matrix of derivatives of image points with respect to components of the rotation vector, translation vector, focal lengths, coordinates of the principal point and the distortion coefficients. In the old interface different components of the jacobian are returned via different output parameters.
aspectRatio (Optional)
Type: SystemDouble
Aspect ratio

Return Value

Type: PointF
The output array of image points, 2xN or Nx2, where N is the total number of points in the view

Return Value

Type: PointF
The array of image points which is the projection of objectPoints
Remarks
Note, that with intrinsic and/or extrinsic parameters set to special values, the function can be used to compute just extrinsic transformation or just intrinsic transformation (i.e. distortion of a sparse set of points)
See Also

Reference

CvInvoke Class
ProjectPoints Overload
Emgu.CV Namespace


CvInvoke.ProjectPoints Method (IInputArray, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Double)

CvInvokeProjectPoints Method (IInputArray, IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Double)

http://www.emgu.com
Computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes jacobians - matrices of partial derivatives of image points as functions of all the input parameters w.r.t. the particular parameters, intrinsic and/or extrinsic. The jacobians are used during the global optimization in cvCalibrateCamera2 and cvFindExtrinsicCameraParams2. The function itself is also used to compute back-projection error for with current intrinsic and extrinsic parameters. Note, that with intrinsic and/or extrinsic parameters set to special values, the function can be used to compute just extrinsic transformation or just intrinsic transformation (i.e. distortion of a sparse set of points).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ProjectPoints(
    IInputArray objectPoints,
    IInputArray rvec,
    IInputArray tvec,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IOutputArray imagePoints,
    IOutputArray jacobian = null,
    double aspectRatio = 0
)
Public Shared Sub ProjectPoints (
    objectPoints As IInputArray,
    rvec As IInputArray,
    tvec As IInputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    imagePoints As IOutputArray,
    Optional jacobian As IOutputArray = Nothing,
    Optional aspectRatio As Double = 0
)
public:
static void ProjectPoints(
    IInputArray^ objectPoints,
    IInputArray^ rvec,
    IInputArray^ tvec,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IOutputArray^ imagePoints,
    IOutputArray^ jacobian = nullptr,
    double aspectRatio = 0
)
static member ProjectPoints :
        objectPoints : IInputArray *
        rvec : IInputArray *
        tvec : IInputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        imagePoints : IOutputArray *
        ?jacobian : IOutputArray *
        ?aspectRatio : float
(* Defaults:
        let _jacobian = defaultArg jacobian null
        let _aspectRatio = defaultArg aspectRatio 0
*)
-> unit

Parameters

objectPoints
Type: Emgu.CVIInputArray
The array of object points, 3xN or Nx3, where N is the number of points in the view
rvec
Type: Emgu.CVIInputArray
The rotation vector, 1x3 or 3x1
tvec
Type: Emgu.CVIInputArray
The translation vector, 1x3 or 3x1
cameraMatrix
Type: Emgu.CVIInputArray
The camera matrix (A) [fx 0 cx; 0 fy cy; 0 0 1].
distCoeffs
Type: Emgu.CVIInputArray
The vector of distortion coefficients, 4x1 or 1x4 [k1, k2, p1, p2]. If it is IntPtr.Zero, all distortion coefficients are considered 0's
imagePoints
Type: Emgu.CVIOutputArray
The output array of image points, 2xN or Nx2, where N is the total number of points in the view
jacobian (Optional)
Type: Emgu.CVIOutputArray
Optional output 2Nx(10+<numDistCoeffs>) jacobian matrix of derivatives of image points with respect to components of the rotation vector, translation vector, focal lengths, coordinates of the principal point and the distortion coefficients. In the old interface different components of the jacobian are returned via different output parameters.
aspectRatio (Optional)
Type: SystemDouble
Aspect ratio
See Also

Reference

CvInvoke Class
ProjectPoints Overload
Emgu.CV Namespace


CvInvoke.PSNR Method

CvInvokePSNR Method

Computes PSNR image/video quality metric

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double PSNR(
    IInputArray src1,
    IInputArray src2
)
Public Shared Function PSNR (
    src1 As IInputArray,
    src2 As IInputArray
) As Double
public:
static double PSNR(
    IInputArray^ src1,
    IInputArray^ src2
)
static member PSNR :
        src1 : IInputArray *
        src2 : IInputArray -> float

Parameters

src1
Type: Emgu.CVIInputArray
The first source image
src2
Type: Emgu.CVIInputArray
The second source image

Return Value

Type: Double
the quality metric
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PutText Method

CvInvokePutText Method

Renders the text in the image with the specified font and color. The printed text is clipped by ROI rectangle. Symbols that do not belong to the specified font are replaced with the rectangle symbol.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PutText(
    IInputOutputArray img,
    string text,
    Point org,
    FontFace fontFace,
    double fontScale,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    bool bottomLeftOrigin = false
)
Public Shared Sub PutText (
    img As IInputOutputArray,
    text As String,
    org As Point,
    fontFace As FontFace,
    fontScale As Double,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional bottomLeftOrigin As Boolean = false
)
public:
static void PutText(
    IInputOutputArray^ img,
    String^ text,
    Point^ org,
    FontFace^ fontFace,
    double fontScale,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    bool bottomLeftOrigin = false
)
static member PutText :
        img : IInputOutputArray *
        text : string *
        org : Point *
        fontFace : FontFace *
        fontScale : float *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?bottomLeftOrigin : bool
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _bottomLeftOrigin = defaultArg bottomLeftOrigin false
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Input image
text
Type: SystemString
String to print
org
Type: System.DrawingPoint
Coordinates of the bottom-left corner of the first letter
fontFace
Type: Emgu.CV.CvEnumFontFace
Font type.
fontScale
Type: SystemDouble
Font scale factor that is multiplied by the font-specific base size.
color
Type: Emgu.CV.StructureMCvScalar
Text color
thickness (Optional)
Type: SystemInt32
Thickness of the lines used to draw a text.
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
bottomLeftOrigin (Optional)
Type: SystemBoolean
When true, the image data origin is at the bottom-left corner. Otherwise, it is at the top-left corner.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PyrDown Method

CvInvokePyrDown Method

Performs downsampling step of Gaussian pyramid decomposition. First it convolves source image with the specified filter and then downsamples the image by rejecting even rows and columns.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PyrDown(
    IInputArray src,
    IOutputArray dst,
    BorderType borderType = 4
)
Public Shared Sub PyrDown (
    src As IInputArray,
    dst As IOutputArray,
    Optional borderType As BorderType = 4
)
public:
static void PyrDown(
    IInputArray^ src,
    IOutputArray^ dst,
    BorderType^ borderType = 4
)
static member PyrDown :
        src : IInputArray *
        dst : IOutputArray *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image.
dst
Type: Emgu.CVIOutputArray
The destination image, should have 2x smaller width and height than the source.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PyrMeanShiftFiltering Method

CvInvokePyrMeanShiftFiltering Method

Filters image using meanshift algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PyrMeanShiftFiltering(
    IInputArray src,
    IOutputArray dst,
    double sp,
    double sr,
    int maxLevel,
    MCvTermCriteria termcrit
)
Public Shared Sub PyrMeanShiftFiltering (
    src As IInputArray,
    dst As IOutputArray,
    sp As Double,
    sr As Double,
    maxLevel As Integer,
    termcrit As MCvTermCriteria
)
public:
static void PyrMeanShiftFiltering(
    IInputArray^ src,
    IOutputArray^ dst,
    double sp,
    double sr,
    int maxLevel,
    MCvTermCriteria^ termcrit
)
static member PyrMeanShiftFiltering :
        src : IInputArray *
        dst : IOutputArray *
        sp : float *
        sr : float *
        maxLevel : int *
        termcrit : MCvTermCriteria -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Result image
sp
Type: SystemDouble
The spatial window radius.
sr
Type: SystemDouble
The color window radius.
maxLevel
Type: SystemInt32
Maximum level of the pyramid for the segmentation. Use 1 as default value
termcrit
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria: when to stop meanshift iterations. Use new MCvTermCriteria(5, 1) as default value
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.PyrUp Method

CvInvokePyrUp Method

Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples the source image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the destination image is four times larger than the source image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PyrUp(
    IInputArray src,
    IOutputArray dst,
    BorderType borderType = 4
)
Public Shared Sub PyrUp (
    src As IInputArray,
    dst As IOutputArray,
    Optional borderType As BorderType = 4
)
public:
static void PyrUp(
    IInputArray^ src,
    IOutputArray^ dst,
    BorderType^ borderType = 4
)
static member PyrUp :
        src : IInputArray *
        dst : IOutputArray *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image.
dst
Type: Emgu.CVIOutputArray
The destination image, should have 2x smaller width and height than the source.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Randn Method

CvInvokeRandn Method

Overload List
Name | Description
Randn(IInputOutputArray, IInputArray, IInputArray) | Fills the array with normally distributed random numbers.
Randn(IInputOutputArray, MCvScalar, MCvScalar) | Fills the array with normally distributed random numbers.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Randn Method (IInputOutputArray, IInputArray, IInputArray)

CvInvokeRandn Method (IInputOutputArray, IInputArray, IInputArray)

http://www.emgu.com
Fills the array with normally distributed random numbers.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Randn(
    IInputOutputArray dst,
    IInputArray mean,
    IInputArray stddev
)
Public Shared Sub Randn (
    dst As IInputOutputArray,
    mean As IInputArray,
    stddev As IInputArray
)
public:
static void Randn(
    IInputOutputArray^ dst,
    IInputArray^ mean,
    IInputArray^ stddev
)
static member Randn :
        dst : IInputOutputArray *
        mean : IInputArray *
        stddev : IInputArray -> unit

Parameters

dst
Type: Emgu.CVIInputOutputArray
Output array of random numbers; the array must be pre-allocated and have 1 to 4 channels.
mean
Type: Emgu.CVIInputArray
Mean value (expectation) of the generated random numbers.
stddev
Type: Emgu.CVIInputArray
Standard deviation of the generated random numbers; it can be either a vector (in which case a diagonal standard deviation matrix is assumed) or a square matrix.
See Also

Reference

CvInvoke Class
Randn Overload
Emgu.CV Namespace


CvInvoke.Randn Method (IInputOutputArray, MCvScalar, MCvScalar)

CvInvokeRandn Method (IInputOutputArray, MCvScalar, MCvScalar)

http://www.emgu.com
Fills the array with normally distributed random numbers.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Randn(
    IInputOutputArray dst,
    MCvScalar mean,
    MCvScalar stddev
)
Public Shared Sub Randn (
    dst As IInputOutputArray,
    mean As MCvScalar,
    stddev As MCvScalar
)
public:
static void Randn(
    IInputOutputArray^ dst,
    MCvScalar^ mean,
    MCvScalar^ stddev
)
static member Randn :
        dst : IInputOutputArray *
        mean : MCvScalar *
        stddev : MCvScalar -> unit

Parameters

dst
Type: Emgu.CVIInputOutputArray
Output array of random numbers; the array must be pre-allocated and have 1 to 4 channels.
mean
Type: Emgu.CV.StructureMCvScalar
Mean value (expectation) of the generated random numbers.
stddev
Type: Emgu.CV.StructureMCvScalar
Standard deviation of the generated random numbers; it can be either a vector (in which case a diagonal standard deviation matrix is assumed) or a square matrix.
See Also

Reference

CvInvoke Class
Randn Overload
Emgu.CV Namespace


CvInvoke.RandShuffle Method

CvInvokeRandShuffle Method

Shuffles the matrix by swapping randomly chosen pairs of the matrix elements on each iteration (where each element may contain several components in case of multi-channel arrays)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void RandShuffle(
    IInputOutputArray mat,
    double iterFactor,
    ulong rng
)
Public Shared Sub RandShuffle (
    mat As IInputOutputArray,
    iterFactor As Double,
    rng As ULong
)
public:
static void RandShuffle(
    IInputOutputArray^ mat,
    double iterFactor,
    unsigned long long rng
)
static member RandShuffle :
        mat : IInputOutputArray *
        iterFactor : float *
        rng : uint64 -> unit

Parameters

mat
Type: Emgu.CVIInputOutputArray
The input/output matrix. It is shuffled in-place.
iterFactor
Type: SystemDouble
The relative parameter that characterizes intensity of the shuffling performed. The number of iterations (i.e. pairs swapped) is round(iter_factor*rows(mat)*cols(mat)), so iter_factor=0 means that no shuffling is done, iter_factor=1 means that the function swaps rows(mat)*cols(mat) random pairs etc
rng
Type: SystemUInt64
Pointer to MCvRNG random number generator. Use 0 if not sure
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Randu Method

CvInvokeRandu Method

Overload List
Name | Description
Randu(IInputOutputArray, IInputArray, IInputArray) | Generates a single uniformly-distributed random number or an array of random numbers.
Randu(IInputOutputArray, MCvScalar, MCvScalar) | Generates a single uniformly-distributed random number or an array of random numbers.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Randu Method (IInputOutputArray, IInputArray, IInputArray)

CvInvokeRandu Method (IInputOutputArray, IInputArray, IInputArray)

http://www.emgu.com
Generates a single uniformly-distributed random number or an array of random numbers.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Randu(
    IInputOutputArray dst,
    IInputArray low,
    IInputArray high
)
Public Shared Sub Randu (
    dst As IInputOutputArray,
    low As IInputArray,
    high As IInputArray
)
public:
static void Randu(
    IInputOutputArray^ dst,
    IInputArray^ low,
    IInputArray^ high
)
static member Randu :
        dst : IInputOutputArray *
        low : IInputArray *
        high : IInputArray -> unit

Parameters

dst
Type: Emgu.CVIInputOutputArray
Output array of random numbers; the array must be pre-allocated.
low
Type: Emgu.CVIInputArray
Inclusive lower boundary of the generated random numbers.
high
Type: Emgu.CVIInputArray
Exclusive upper boundary of the generated random numbers.
See Also

Reference

CvInvoke Class
Randu Overload
Emgu.CV Namespace


CvInvoke.Randu Method (IInputOutputArray, MCvScalar, MCvScalar)

CvInvokeRandu Method (IInputOutputArray, MCvScalar, MCvScalar)

http://www.emgu.com
Generates a single uniformly-distributed random number or an array of random numbers.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Randu(
    IInputOutputArray dst,
    MCvScalar low,
    MCvScalar high
)
Public Shared Sub Randu (
    dst As IInputOutputArray,
    low As MCvScalar,
    high As MCvScalar
)
public:
static void Randu(
    IInputOutputArray^ dst,
    MCvScalar^ low,
    MCvScalar^ high
)
static member Randu :
        dst : IInputOutputArray *
        low : MCvScalar *
        high : MCvScalar -> unit

Parameters

dst
Type: Emgu.CVIInputOutputArray
Output array of random numbers; the array must be pre-allocated.
low
Type: Emgu.CV.StructureMCvScalar
Inclusive lower boundary of the generated random numbers.
high
Type: Emgu.CV.StructureMCvScalar
Exclusive upper boundary of the generated random numbers.
See Also

Reference

CvInvoke Class
Randu Overload
Emgu.CV Namespace


CvInvoke.ReadCloud Method

CvInvokeReadCloud Method

Read point cloud from file

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat ReadCloud(
    string file,
    IOutputArray colors = null,
    IOutputArray normals = null
)
Public Shared Function ReadCloud (
    file As String,
    Optional colors As IOutputArray = Nothing,
    Optional normals As IOutputArray = Nothing
) As Mat
public:
static Mat^ ReadCloud(
    String^ file,
    IOutputArray^ colors = nullptr,
    IOutputArray^ normals = nullptr
)
static member ReadCloud :
        file : string *
        ?colors : IOutputArray *
        ?normals : IOutputArray
(* Defaults:
        let _colors = defaultArg colors null
        let _normals = defaultArg normals null
*)
-> Mat

Parameters

file
Type: SystemString
The point cloud file
colors (Optional)
Type: Emgu.CVIOutputArray
The color of the points
normals (Optional)
Type: Emgu.CVIOutputArray
The normal of the points

Return Value

Type: Mat
The points
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Rectangle Method

CvInvokeRectangle Method

Draws a rectangle specified by a CvRect structure

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Rectangle(
    IInputOutputArray img,
    Rectangle rect,
    MCvScalar color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Shared Sub Rectangle (
    img As IInputOutputArray,
    rect As Rectangle,
    color As MCvScalar,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
static void Rectangle(
    IInputOutputArray^ img,
    Rectangle^ rect,
    MCvScalar^ color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
static member Rectangle :
        img : IInputOutputArray *
        rect : Rectangle *
        color : MCvScalar *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image
rect
Type: System.DrawingRectangle
The rectangle to be drawn
color
Type: Emgu.CV.StructureMCvScalar
Line color
thickness (Optional)
Type: SystemInt32
Thickness of lines that make up the rectangle. Negative values make the function to draw a filled rectangle.
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the line
shift (Optional)
Type: SystemInt32
Number of fractional bits in the point coordinates
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.RedirectError Method

CvInvokeRedirectError Method

Overload List
Name | Description
RedirectError(IntPtr, IntPtr, IntPtr) | Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.
RedirectError(CvInvokeCvErrorCallback, IntPtr, IntPtr) | Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.RedirectError Method (IntPtr, IntPtr, IntPtr)

CvInvokeRedirectError Method (IntPtr, IntPtr, IntPtr)

http://www.emgu.com
Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr RedirectError(
    IntPtr errorHandler,
    IntPtr userdata,
    IntPtr prevUserdata
)
Public Shared Function RedirectError (
    errorHandler As IntPtr,
    userdata As IntPtr,
    prevUserdata As IntPtr
) As IntPtr
public:
static IntPtr RedirectError(
    IntPtr errorHandler,
    IntPtr userdata,
    IntPtr prevUserdata
)
static member RedirectError :
        errorHandler : IntPtr *
        userdata : IntPtr *
        prevUserdata : IntPtr -> IntPtr

Parameters

errorHandler
Type: SystemIntPtr
Pointer to the new error handler
userdata
Type: SystemIntPtr
Arbitrary pointer that is transparently passed to the error handler.
prevUserdata
Type: SystemIntPtr
Pointer to the previously assigned user data pointer.

Return Value

Type: IntPtr
Pointer to the old error handler
See Also

Reference

CvInvoke Class
RedirectError Overload
Emgu.CV Namespace


CvInvoke.RedirectError Method (CvInvoke.CvErrorCallback, IntPtr, IntPtr)

CvInvokeRedirectError Method (CvInvokeCvErrorCallback, IntPtr, IntPtr)

http://www.emgu.com
Sets a new error handler that can be one of standard handlers or a custom handler that has the certain interface. The handler takes the same parameters as cvError function. If the handler returns non-zero value, the program is terminated, otherwise, it continues. The error handler may check the current error mode with cvGetErrMode to make a decision.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr RedirectError(
    CvInvokeCvErrorCallback errorHandler,
    IntPtr userdata,
    IntPtr prevUserdata
)
Public Shared Function RedirectError (
    errorHandler As CvInvokeCvErrorCallback,
    userdata As IntPtr,
    prevUserdata As IntPtr
) As IntPtr
public:
static IntPtr RedirectError(
    CvInvokeCvErrorCallback^ errorHandler,
    IntPtr userdata,
    IntPtr prevUserdata
)
static member RedirectError :
        errorHandler : CvInvokeCvErrorCallback *
        userdata : IntPtr *
        prevUserdata : IntPtr -> IntPtr

Parameters

errorHandler
Type: Emgu.CVCvInvokeCvErrorCallback
The new error handler
userdata
Type: SystemIntPtr
Arbitrary pointer that is transparently passed to the error handler.
prevUserdata
Type: SystemIntPtr
Pointer to the previously assigned user data pointer.

Return Value

Type: IntPtr
Pointer to the old error handler
See Also

Reference

CvInvoke Class
RedirectError Overload
Emgu.CV Namespace


CvInvoke.Reduce Method

CvInvokeReduce Method

Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Reduce(
    IInputArray src,
    IOutputArray dst,
    ReduceDimension dim = -1,
    ReduceType type = 0,
    DepthType dtype = -1
)
Public Shared Sub Reduce (
    src As IInputArray,
    dst As IOutputArray,
    Optional dim As ReduceDimension = -1,
    Optional type As ReduceType = 0,
    Optional dtype As DepthType = -1
)
public:
static void Reduce(
    IInputArray^ src,
    IOutputArray^ dst,
    ReduceDimension^ dim = -1,
    ReduceType^ type = 0,
    DepthType^ dtype = -1
)
static member Reduce :
        src : IInputArray *
        dst : IOutputArray *
        ?dim : ReduceDimension *
        ?type : ReduceType *
        ?dtype : DepthType
(* Defaults:
        let _dim = defaultArg dim -1
        let _type = defaultArg type 0
        let _dtype = defaultArg dtype -1
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The input matrix
dst
Type: Emgu.CVIOutputArray
The output single-row/single-column vector that accumulates somehow all the matrix rows/columns
dim (Optional)
Type: Emgu.CV.CvEnumReduceDimension
The dimension index along which the matrix is reduce.
type (Optional)
Type: Emgu.CV.CvEnumReduceType
The reduction operation type
dtype (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth type of the output array
Remarks
The function can be used to compute horizontal and vertical projections of an raster image. In case of CV_REDUCE_SUM and CV_REDUCE_AVG the output may have a larger element bit-depth to preserve accuracy. And multi-channel arrays are also supported in these two reduction modes
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Remap Method

CvInvokeRemap Method

Applies a generic geometrical transformation to an image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Remap(
    IInputArray src,
    IOutputArray dst,
    IInputArray map1,
    IInputArray map2,
    Inter interpolation,
    BorderType borderMode = 0,
    MCvScalar borderValue = null
)
Public Shared Sub Remap (
    src As IInputArray,
    dst As IOutputArray,
    map1 As IInputArray,
    map2 As IInputArray,
    interpolation As Inter,
    Optional borderMode As BorderType = 0,
    Optional borderValue As MCvScalar = Nothing
)
public:
static void Remap(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ map1,
    IInputArray^ map2,
    Inter^ interpolation,
    BorderType^ borderMode = 0,
    MCvScalar^ borderValue = nullptr
)
static member Remap :
        src : IInputArray *
        dst : IOutputArray *
        map1 : IInputArray *
        map2 : IInputArray *
        interpolation : Inter *
        ?borderMode : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _borderMode = defaultArg borderMode 0
        let _borderValue = defaultArg borderValue null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Destination image
map1
Type: Emgu.CVIInputArray
The first map of either (x,y) points or just x values having the type CV_16SC2 , CV_32FC1 , or CV_32FC2 . See convertMaps() for details on converting a floating point representation to fixed-point for speed.
map2
Type: Emgu.CVIInputArray
The second map of y values having the type CV_16UC1 , CV_32FC1 , or none (empty map if map1 is (x,y) points), respectively.
interpolation
Type: Emgu.CV.CvEnumInter
Interpolation method (see resize() ). The method 'Area' is not supported by this function.
borderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
A value used to fill outliers
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Repeat Method

CvInvokeRepeat Method

Fills the destination array with source array tiled: dst(i,j)=src(i mod rows(src), j mod cols(src))So the destination array may be as larger as well as smaller than the source array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Repeat(
    IInputArray src,
    int ny,
    int nx,
    IOutputArray dst
)
Public Shared Sub Repeat (
    src As IInputArray,
    ny As Integer,
    nx As Integer,
    dst As IOutputArray
)
public:
static void Repeat(
    IInputArray^ src,
    int ny,
    int nx,
    IOutputArray^ dst
)
static member Repeat :
        src : IInputArray *
        ny : int *
        nx : int *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source array, image or matrix
ny
Type: SystemInt32
Flag to specify how many times the src is repeated along the horizontal axis.
nx
Type: SystemInt32
Flag to specify how many times the src is repeated along the vertical axis.
dst
Type: Emgu.CVIOutputArray
Destination array, image or matrix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ReprojectImageTo3D Method

CvInvokeReprojectImageTo3D Method

Transforms 1-channel disparity map to 3-channel image, a 3D surface.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ReprojectImageTo3D(
    IInputArray disparity,
    IOutputArray image3D,
    IInputArray q,
    bool handleMissingValues = false,
    DepthType ddepth = -1
)
Public Shared Sub ReprojectImageTo3D (
    disparity As IInputArray,
    image3D As IOutputArray,
    q As IInputArray,
    Optional handleMissingValues As Boolean = false,
    Optional ddepth As DepthType = -1
)
public:
static void ReprojectImageTo3D(
    IInputArray^ disparity,
    IOutputArray^ image3D,
    IInputArray^ q,
    bool handleMissingValues = false,
    DepthType^ ddepth = -1
)
static member ReprojectImageTo3D :
        disparity : IInputArray *
        image3D : IOutputArray *
        q : IInputArray *
        ?handleMissingValues : bool *
        ?ddepth : DepthType
(* Defaults:
        let _handleMissingValues = defaultArg handleMissingValues false
        let _ddepth = defaultArg ddepth -1
*)
-> unit

Parameters

disparity
Type: Emgu.CVIInputArray
Disparity map
image3D
Type: Emgu.CVIOutputArray
3-channel, 16-bit integer or 32-bit floating-point image - the output map of 3D points
q
Type: Emgu.CVIInputArray
The reprojection 4x4 matrix, can be arbitrary, e.g. the one, computed by cvStereoRectify
handleMissingValues (Optional)
Type: SystemBoolean
Indicates, whether the function should handle missing values (i.e. points where the disparity was not computed). If handleMissingValues=true, then pixels with the minimal disparity that corresponds to the outliers (see StereoMatcher::compute ) are transformed to 3D points with a very large Z value (currently set to 10000).
ddepth (Optional)
Type: Emgu.CV.CvEnumDepthType
The optional output array depth. If it is -1, the output image will have CV_32F depth. ddepth can also be set to CV_16S, CV_32S or CV_32F.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Resize Method

CvInvokeResize Method

Resizes the image src down to or up to the specified size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Resize(
    IInputArray src,
    IOutputArray dst,
    Size dsize,
    double fx = 0,
    double fy = 0,
    Inter interpolation = 1
)
Public Shared Sub Resize (
    src As IInputArray,
    dst As IOutputArray,
    dsize As Size,
    Optional fx As Double = 0,
    Optional fy As Double = 0,
    Optional interpolation As Inter = 1
)
public:
static void Resize(
    IInputArray^ src,
    IOutputArray^ dst,
    Size^ dsize,
    double fx = 0,
    double fy = 0,
    Inter^ interpolation = 1
)
static member Resize :
        src : IInputArray *
        dst : IOutputArray *
        dsize : Size *
        ?fx : float *
        ?fy : float *
        ?interpolation : Inter
(* Defaults:
        let _fx = defaultArg fx 0
        let _fy = defaultArg fy 0
        let _interpolation = defaultArg interpolation 1
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image.
dst
Type: Emgu.CVIOutputArray
Destination image
dsize
Type: System.DrawingSize
Output image size; if it equals zero, it is computed as: dsize=Size(round(fx*src.cols), round(fy * src.rows)). Either dsize or both fx and fy must be non-zero.
fx (Optional)
Type: SystemDouble
Scale factor along the horizontal axis
fy (Optional)
Type: SystemDouble
Scale factor along the vertical axis;
interpolation (Optional)
Type: Emgu.CV.CvEnumInter
Interpolation method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ResizeForFrame Method

CvInvokeResizeForFrame Method

Resize an image such that it fits in a given frame

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ResizeForFrame(
    IInputArray src,
    IOutputArray dst,
    Size frameSize,
    Inter interpolationMethod = 1,
    bool scaleDownOnly = true
)
Public Shared Sub ResizeForFrame (
    src As IInputArray,
    dst As IOutputArray,
    frameSize As Size,
    Optional interpolationMethod As Inter = 1,
    Optional scaleDownOnly As Boolean = true
)
public:
static void ResizeForFrame(
    IInputArray^ src,
    IOutputArray^ dst,
    Size^ frameSize,
    Inter^ interpolationMethod = 1,
    bool scaleDownOnly = true
)
static member ResizeForFrame :
        src : IInputArray *
        dst : IOutputArray *
        frameSize : Size *
        ?interpolationMethod : Inter *
        ?scaleDownOnly : bool
(* Defaults:
        let _interpolationMethod = defaultArg interpolationMethod 1
        let _scaleDownOnly = defaultArg scaleDownOnly true
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
dst
Type: Emgu.CVIOutputArray
The result image
frameSize
Type: System.DrawingSize
The size of the frame
interpolationMethod (Optional)
Type: Emgu.CV.CvEnumInter
The interpolation method
scaleDownOnly (Optional)
Type: SystemBoolean
If true, it will not try to scale up the image to fit the frame
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Rodrigues Method

CvInvokeRodrigues Method

Converts a rotation vector to rotation matrix or vice versa. Rotation vector is a compact representation of rotation matrix. Direction of the rotation vector is the rotation axis and the length of the vector is the rotation angle around the axis.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Rodrigues(
    IInputArray src,
    IOutputArray dst,
    IOutputArray jacobian = null
)
Public Shared Sub Rodrigues (
    src As IInputArray,
    dst As IOutputArray,
    Optional jacobian As IOutputArray = Nothing
)
public:
static void Rodrigues(
    IInputArray^ src,
    IOutputArray^ dst,
    IOutputArray^ jacobian = nullptr
)
static member Rodrigues :
        src : IInputArray *
        dst : IOutputArray *
        ?jacobian : IOutputArray
(* Defaults:
        let _jacobian = defaultArg jacobian null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The input rotation vector (3x1 or 1x3) or rotation matrix (3x3).
dst
Type: Emgu.CVIOutputArray
The output rotation matrix (3x3) or rotation vector (3x1 or 1x3), respectively
jacobian (Optional)
Type: Emgu.CVIOutputArray
Optional output Jacobian matrix, 3x9 or 9x3 - partial derivatives of the output array components w.r.t the input array components
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Rotate Method

CvInvokeRotate Method

Rotates a 2D array in multiples of 90 degrees.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Rotate(
    IInputArray src,
    IOutputArray dst,
    RotateFlags rotateCode
)
Public Shared Sub Rotate (
    src As IInputArray,
    dst As IOutputArray,
    rotateCode As RotateFlags
)
public:
static void Rotate(
    IInputArray^ src,
    IOutputArray^ dst,
    RotateFlags^ rotateCode
)
static member Rotate :
        src : IInputArray *
        dst : IOutputArray *
        rotateCode : RotateFlags -> unit

Parameters

src
Type: Emgu.CVIInputArray
input array.
dst
Type: Emgu.CVIOutputArray
output array of the same type as src. The size is the same with ROTATE_180, and the rows and cols are switched for ROTATE_90 and ROTATE_270.
rotateCode
Type: Emgu.CV.CvEnumRotateFlags
an enum to specify how to rotate the array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.RotatedRectangleIntersection Method

CvInvokeRotatedRectangleIntersection Method

Finds out if there is any intersection between two rotated rectangles.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RectIntersectType RotatedRectangleIntersection(
    RotatedRect rect1,
    RotatedRect rect2,
    IOutputArray intersectingRegion
)
Public Shared Function RotatedRectangleIntersection (
    rect1 As RotatedRect,
    rect2 As RotatedRect,
    intersectingRegion As IOutputArray
) As RectIntersectType
public:
static RectIntersectType^ RotatedRectangleIntersection(
    RotatedRect^ rect1,
    RotatedRect^ rect2,
    IOutputArray^ intersectingRegion
)
static member RotatedRectangleIntersection :
        rect1 : RotatedRect *
        rect2 : RotatedRect *
        intersectingRegion : IOutputArray -> RectIntersectType

Parameters

rect1
Type: Emgu.CV.StructureRotatedRect
First rectangle
rect2
Type: Emgu.CV.StructureRotatedRect
Second rectangle
intersectingRegion
Type: Emgu.CVIOutputArray
The output array of the verticies of the intersecting region. It returns at most 8 vertices. Stored as VectorOfPointF or Mat as Mx1 of type CV_32FC2.

Return Value

Type: RectIntersectType
The intersect type
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SanityCheck Method

CvInvokeSanityCheck Method

Check if the size of the C structures match those of C#

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool SanityCheck()
Public Shared Function SanityCheck As Boolean
public:
static bool SanityCheck()
static member SanityCheck : unit -> bool

Return Value

Type: Boolean
True if the size matches
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Scharr Method

CvInvokeScharr Method

Calculates the first x- or y- image derivative using Scharr operator.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Scharr(
    IInputArray src,
    IOutputArray dst,
    DepthType ddepth,
    int dx,
    int dy,
    double scale = 1,
    double delta = 0,
    BorderType borderType = 4
)
Public Shared Sub Scharr (
    src As IInputArray,
    dst As IOutputArray,
    ddepth As DepthType,
    dx As Integer,
    dy As Integer,
    Optional scale As Double = 1,
    Optional delta As Double = 0,
    Optional borderType As BorderType = 4
)
public:
static void Scharr(
    IInputArray^ src,
    IOutputArray^ dst,
    DepthType^ ddepth,
    int dx,
    int dy,
    double scale = 1,
    double delta = 0,
    BorderType^ borderType = 4
)
static member Scharr :
        src : IInputArray *
        dst : IOutputArray *
        ddepth : DepthType *
        dx : int *
        dy : int *
        ?scale : float *
        ?delta : float *
        ?borderType : BorderType
(* Defaults:
        let _scale = defaultArg scale 1
        let _delta = defaultArg delta 0
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
input image.
dst
Type: Emgu.CVIOutputArray
output image of the same size and the same number of channels as src.
ddepth
Type: Emgu.CV.CvEnumDepthType
output image depth
dx
Type: SystemInt32
order of the derivative x.
dy
Type: SystemInt32
order of the derivative y.
scale (Optional)
Type: SystemDouble
optional scale factor for the computed derivative values; by default, no scaling is applied
delta (Optional)
Type: SystemDouble
optional delta value that is added to the results prior to storing them in dst.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
pixel extrapolation method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SeamlessClone Method

CvInvokeSeamlessClone Method

Image editing tasks concern either global changes (color/intensity corrections, filters, deformations) or local changes concerned to a selection. Here we are interested in achieving local changes, ones that are restricted to a region manually selected (ROI), in a seamless and effortless manner. The extent of the changes ranges from slight distortions to complete replacement by novel content

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SeamlessClone(
    IInputArray src,
    IInputArray dst,
    IInputArray mask,
    Point p,
    IOutputArray blend,
    CloningMethod flags
)
Public Shared Sub SeamlessClone (
    src As IInputArray,
    dst As IInputArray,
    mask As IInputArray,
    p As Point,
    blend As IOutputArray,
    flags As CloningMethod
)
public:
static void SeamlessClone(
    IInputArray^ src,
    IInputArray^ dst,
    IInputArray^ mask,
    Point^ p,
    IOutputArray^ blend,
    CloningMethod^ flags
)
static member SeamlessClone :
        src : IInputArray *
        dst : IInputArray *
        mask : IInputArray *
        p : Point *
        blend : IOutputArray *
        flags : CloningMethod -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image.
dst
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image.
mask
Type: Emgu.CVIInputArray
Input 8-bit 1 or 3-channel image.
p
Type: System.DrawingPoint
Point in dst image where object is placed.
blend
Type: Emgu.CVIOutputArray
Output image with the same size and type as dst.
flags
Type: Emgu.CV.CvEnumCloningMethod
Cloning method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SegmentMotion Method

CvInvokeSegmentMotion Method

Finds all the motion segments and marks them in segMask with individual values each (1,2,...). It also returns a sequence of CvConnectedComp structures, one per each motion components. After than the motion direction for every component can be calculated with cvCalcGlobalOrientation using extracted mask of the particular component (using cvCmp)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SegmentMotion(
    IInputArray mhi,
    IOutputArray segMask,
    VectorOfRect boundingRects,
    double timestamp,
    double segThresh
)
Public Shared Sub SegmentMotion (
    mhi As IInputArray,
    segMask As IOutputArray,
    boundingRects As VectorOfRect,
    timestamp As Double,
    segThresh As Double
)
public:
static void SegmentMotion(
    IInputArray^ mhi,
    IOutputArray^ segMask,
    VectorOfRect^ boundingRects,
    double timestamp,
    double segThresh
)
static member SegmentMotion :
        mhi : IInputArray *
        segMask : IOutputArray *
        boundingRects : VectorOfRect *
        timestamp : float *
        segThresh : float -> unit

Parameters

mhi
Type: Emgu.CVIInputArray
Motion history image
segMask
Type: Emgu.CVIOutputArray
Image where the mask found should be stored, single-channel, 32-bit floating-point
boundingRects
Type: Emgu.CV.UtilVectorOfRect
Vector containing ROIs of motion connected components.
timestamp
Type: SystemDouble
Current time in milliseconds or other units
segThresh
Type: SystemDouble
Segmentation threshold; recommended to be equal to the interval between motion history "steps" or greater
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SelectROI Method

CvInvokeSelectROI Method

Selects ROI on the given image. Function creates a window and allows user to select a ROI using mouse. Controls: use space or enter to finish selection, use key c to cancel selection (function will return the zero cv::Rect).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Rectangle SelectROI(
    string windowName,
    IInputArray img,
    bool showCrosshair = true,
    bool fromCenter = false
)
Public Shared Function SelectROI (
    windowName As String,
    img As IInputArray,
    Optional showCrosshair As Boolean = true,
    Optional fromCenter As Boolean = false
) As Rectangle
public:
static Rectangle^ SelectROI(
    String^ windowName,
    IInputArray^ img,
    bool showCrosshair = true,
    bool fromCenter = false
)
static member SelectROI :
        windowName : string *
        img : IInputArray *
        ?showCrosshair : bool *
        ?fromCenter : bool
(* Defaults:
        let _showCrosshair = defaultArg showCrosshair true
        let _fromCenter = defaultArg fromCenter false
*)
-> Rectangle

Parameters

windowName
Type: SystemString
Name of the window where selection process will be shown.
img
Type: Emgu.CVIInputArray
Image to select a ROI.
showCrosshair (Optional)
Type: SystemBoolean
If true crosshair of selection rectangle will be shown.
fromCenter (Optional)
Type: SystemBoolean
If true center of selection will match initial mouse position. In opposite case a corner of selection rectangle will correspont to the initial mouse position.

Return Value

Type: Rectangle
Selected ROI or empty rect if selection canceled.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SelectROIs Method

CvInvokeSelectROIs Method

Selects ROIs on the given image. Function creates a window and allows user to select a ROIs using mouse. Controls: use space or enter to finish current selection and start a new one, use esc to terminate multiple ROI selection process.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Rectangle[] SelectROIs(
    string windowName,
    IInputArray img,
    bool showCrosshair = true,
    bool fromCenter = false
)
Public Shared Function SelectROIs (
    windowName As String,
    img As IInputArray,
    Optional showCrosshair As Boolean = true,
    Optional fromCenter As Boolean = false
) As Rectangle()
public:
static array<Rectangle^>^ SelectROIs(
    String^ windowName,
    IInputArray^ img,
    bool showCrosshair = true,
    bool fromCenter = false
)
static member SelectROIs :
        windowName : string *
        img : IInputArray *
        ?showCrosshair : bool *
        ?fromCenter : bool
(* Defaults:
        let _showCrosshair = defaultArg showCrosshair true
        let _fromCenter = defaultArg fromCenter false
*)
-> Rectangle[]

Parameters

windowName
Type: SystemString
Name of the window where selection process will be shown.
img
Type: Emgu.CVIInputArray
Image to select a ROI.
showCrosshair (Optional)
Type: SystemBoolean
If true crosshair of selection rectangle will be shown.
fromCenter (Optional)
Type: SystemBoolean
If true center of selection will match initial mouse position. In opposite case a corner of selection rectangle will correspont to the initial mouse position.

Return Value

Type: Rectangle
Selected ROIs.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SepFilter2D Method

CvInvokeSepFilter2D Method

The function applies a separable linear filter to the image. That is, first, every row of src is filtered with the 1D kernel kernelX. Then, every column of the result is filtered with the 1D kernel kernelY. The final result shifted by delta is stored in dst .

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SepFilter2D(
    IInputArray src,
    IOutputArray dst,
    DepthType ddepth,
    IInputArray kernelX,
    IInputArray kernelY,
    Point anchor,
    double delta = 0,
    BorderType borderType = 4
)
Public Shared Sub SepFilter2D (
    src As IInputArray,
    dst As IOutputArray,
    ddepth As DepthType,
    kernelX As IInputArray,
    kernelY As IInputArray,
    anchor As Point,
    Optional delta As Double = 0,
    Optional borderType As BorderType = 4
)
public:
static void SepFilter2D(
    IInputArray^ src,
    IOutputArray^ dst,
    DepthType^ ddepth,
    IInputArray^ kernelX,
    IInputArray^ kernelY,
    Point^ anchor,
    double delta = 0,
    BorderType^ borderType = 4
)
static member SepFilter2D :
        src : IInputArray *
        dst : IOutputArray *
        ddepth : DepthType *
        kernelX : IInputArray *
        kernelY : IInputArray *
        anchor : Point *
        ?delta : float *
        ?borderType : BorderType
(* Defaults:
        let _delta = defaultArg delta 0
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image.
dst
Type: Emgu.CVIOutputArray
Destination image of the same size and the same number of channels as src.
ddepth
Type: Emgu.CV.CvEnumDepthType
Destination image depth
kernelX
Type: Emgu.CVIInputArray
Coefficients for filtering each row.
kernelY
Type: Emgu.CVIInputArray
Coefficients for filtering each column.
anchor
Type: System.DrawingPoint
Anchor position within the kernel. The value (-1,-1) means that the anchor is at the kernel center.
delta (Optional)
Type: SystemDouble
Value added to the filtered results before storing them.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SetErrMode Method

CvInvokeSetErrMode Method

Sets the specified error mode.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SetErrMode(
    int errorMode
)
Public Shared Function SetErrMode (
    errorMode As Integer
) As Integer
public:
static int SetErrMode(
    int errorMode
)
static member SetErrMode :
        errorMode : int -> int

Parameters

errorMode
Type: SystemInt32
The error mode

Return Value

Type: Int32
The previous error mode
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SetErrStatus Method

CvInvokeSetErrStatus Method

Sets the error status to the specified value. Mostly, the function is used to reset the error status (set to it CV_StsOk) to recover after error. In other cases it is more natural to call cvError or CV_ERROR.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SetErrStatus(
    ErrorCodes code
)
Public Shared Sub SetErrStatus (
    code As ErrorCodes
)
public:
static void SetErrStatus(
    ErrorCodes^ code
)
static member SetErrStatus :
        code : ErrorCodes -> unit

Parameters

code
Type: Emgu.CV.CvEnumErrorCodes
The error status.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SetIdentity Method

CvInvokeSetIdentity Method

Initializes scaled identity matrix: arr(i,j)=value if i=j, 0 otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SetIdentity(
    IInputOutputArray mat,
    MCvScalar value
)
Public Shared Sub SetIdentity (
    mat As IInputOutputArray,
    value As MCvScalar
)
public:
static void SetIdentity(
    IInputOutputArray^ mat,
    MCvScalar^ value
)
static member SetIdentity :
        mat : IInputOutputArray *
        value : MCvScalar -> unit

Parameters

mat
Type: Emgu.CVIInputOutputArray
The matrix to initialize (not necessarily square).
value
Type: Emgu.CV.StructureMCvScalar
The value to assign to the diagonal elements.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Sobel Method

CvInvokeSobel Method

The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative. The first case corresponds to

              |-1  0  1|
              |-2  0  2|
              |-1  0  1|
kernel and the second one corresponds to
              |-1 -2 -1|
              | 0  0  0|
              | 1  2  1|
or
              | 1  2  1|
              | 0  0  0|
              |-1 -2 -1|
kernel, depending on the image origin (origin field of IplImage structure). No scaling is done, so the destination image usually has larger by absolute value numbers than the source image. To avoid overflow, the function requires 16-bit destination image if the source image is 8-bit. The result can be converted back to 8-bit using cvConvertScale or cvConvertScaleAbs functions. Besides 8-bit images the function can process 32-bit floating-point images. Both source and destination must be single-channel images of equal size or ROI size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Sobel(
    IInputArray src,
    IOutputArray dst,
    DepthType ddepth,
    int xorder,
    int yorder,
    int kSize = 3,
    double scale = 1,
    double delta = 0,
    BorderType borderType = 4
)
Public Shared Sub Sobel (
    src As IInputArray,
    dst As IOutputArray,
    ddepth As DepthType,
    xorder As Integer,
    yorder As Integer,
    Optional kSize As Integer = 3,
    Optional scale As Double = 1,
    Optional delta As Double = 0,
    Optional borderType As BorderType = 4
)
public:
static void Sobel(
    IInputArray^ src,
    IOutputArray^ dst,
    DepthType^ ddepth,
    int xorder,
    int yorder,
    int kSize = 3,
    double scale = 1,
    double delta = 0,
    BorderType^ borderType = 4
)
static member Sobel :
        src : IInputArray *
        dst : IOutputArray *
        ddepth : DepthType *
        xorder : int *
        yorder : int *
        ?kSize : int *
        ?scale : float *
        ?delta : float *
        ?borderType : BorderType
(* Defaults:
        let _kSize = defaultArg kSize 3
        let _scale = defaultArg scale 1
        let _delta = defaultArg delta 0
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image.
dst
Type: Emgu.CVIOutputArray
Destination image
ddepth
Type: Emgu.CV.CvEnumDepthType
output image depth; the following combinations of src.depth() and ddepth are supported:

src.depth() = CV_8U, ddepth = -1/CV_16S/CV_32F/CV_64F

src.depth() = CV_16U/CV_16S, ddepth = -1/CV_32F/CV_64F

src.depth() = CV_32F, ddepth = -1/CV_32F/CV_64F

src.depth() = CV_64F, ddepth = -1/CV_64F

when ddepth=-1, the destination image will have the same depth as the source; in the case of 8-bit input images it will result in truncated derivatives.
xorder
Type: SystemInt32
Order of the derivative x
yorder
Type: SystemInt32
Order of the derivative y
kSize (Optional)
Type: SystemInt32
Size of the extended Sobel kernel, must be 1, 3, 5 or 7.
scale (Optional)
Type: SystemDouble
Optional scale factor for the computed derivative values
delta (Optional)
Type: SystemDouble
Optional delta value that is added to the results prior to storing them in dst
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Solve Method

CvInvokeSolve Method

Solves linear system (src1)*(dst) = (src2)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int Solve(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    DecompMethod method
)
Public Shared Function Solve (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    method As DecompMethod
) As Integer
public:
static int Solve(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    DecompMethod^ method
)
static member Solve :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        method : DecompMethod -> int

Parameters

src1
Type: Emgu.CVIInputArray
The source matrix in the LHS
src2
Type: Emgu.CVIInputArray
The source matrix in the RHS
dst
Type: Emgu.CVIOutputArray
The result
method
Type: Emgu.CV.CvEnumDecompMethod
The method for solving the equation

Return Value

Type: Int32
0 if src1 is a singular and CV_LU method is used
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolveCubic Method

CvInvokeSolveCubic Method

finds real roots of a cubic equation: coeffs[0]*x^3 + coeffs[1]*x^2 + coeffs[2]*x + coeffs[3] = 0 (if coeffs is 4-element vector) or x^3 + coeffs[0]*x^2 + coeffs[1]*x + coeffs[2] = 0 (if coeffs is 3-element vector)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SolveCubic(
    IInputArray coeffs,
    IOutputArray roots
)
Public Shared Function SolveCubic (
    coeffs As IInputArray,
    roots As IOutputArray
) As Integer
public:
static int SolveCubic(
    IInputArray^ coeffs,
    IOutputArray^ roots
)
static member SolveCubic :
        coeffs : IInputArray *
        roots : IOutputArray -> int

Parameters

coeffs
Type: Emgu.CVIInputArray
The equation coefficients, array of 3 or 4 elements
roots
Type: Emgu.CVIOutputArray
The output array of real roots. Should have 3 elements. Padded with zeros if there is only one root

Return Value

Type: Int32
the number of real roots found
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolveLP Method

CvInvokeSolveLP Method

Solve given (non-integer) linear programming problem using the Simplex Algorithm (Simplex Method). What we mean here by “linear programming problem” (or LP problem, for short) can be formulated as: Maximize c x subject to: Ax <= b and x >= 0

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static SolveLPResult SolveLP(
    Mat functionMatrix,
    Mat constraintMatrix,
    Mat zMatrix
)
Public Shared Function SolveLP (
    functionMatrix As Mat,
    constraintMatrix As Mat,
    zMatrix As Mat
) As SolveLPResult
public:
static SolveLPResult^ SolveLP(
    Mat^ functionMatrix,
    Mat^ constraintMatrix,
    Mat^ zMatrix
)
static member SolveLP :
        functionMatrix : Mat *
        constraintMatrix : Mat *
        zMatrix : Mat -> SolveLPResult

Parameters

functionMatrix
Type: Emgu.CVMat
This row-vector corresponds to c in the LP problem formulation (see above). It should contain 32- or 64-bit floating point numbers. As a convenience, column-vector may be also submitted, in the latter case it is understood to correspond to c^T.
constraintMatrix
Type: Emgu.CVMat
m-by-n+1 matrix, whose rightmost column corresponds to b in formulation above and the remaining to A. It should containt 32- or 64-bit floating point numbers.
zMatrix
Type: Emgu.CVMat
The solution will be returned here as a column-vector - it corresponds to c in the formulation above. It will contain 64-bit floating point numbers.

Return Value

Type: SolveLPResult
The return codes
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolveP3P Method

CvInvokeSolveP3P Method

Finds an object pose from 3 3D-2D point correspondences.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SolveP3P(
    IInputArray objectPoints,
    IInputArray imagePoints,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IOutputArrayOfArrays rvecs,
    IOutputArrayOfArrays tvecs,
    SolvePnpMethod flags
)
Public Shared Function SolveP3P (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvecs As IOutputArrayOfArrays,
    tvecs As IOutputArrayOfArrays,
    flags As SolvePnpMethod
) As Integer
public:
static int SolveP3P(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IOutputArrayOfArrays^ rvecs,
    IOutputArrayOfArrays^ tvecs,
    SolvePnpMethod^ flags
)
static member SolveP3P :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvecs : IOutputArrayOfArrays *
        tvecs : IOutputArrayOfArrays *
        flags : SolvePnpMethod -> int

Parameters

objectPoints
Type: Emgu.CVIInputArray
Array of object points in the object coordinate space, 3x3 1-channel or 1x3/3x1 3-channel. VectorOfPoint3f can be also passed here.
imagePoints
Type: Emgu.CVIInputArray
Array of corresponding image points, 3x2 1-channel or 1x3/3x1 2-channel. VectorOfPoint2f can be also passed here.
cameraMatrix
Type: Emgu.CVIInputArray
Input camera matrix A=[[fx 0 0] [0 fy 0] [cx cy 1]] .
distCoeffs
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6[,s1,s2,s3,s4[,τx,τy]]]]) of 4, 5, 8, 12 or 14 elements. If the vector is NULL/empty, the zero distortion coefficients are assumed.
rvecs
Type: Emgu.CVIOutputArrayOfArrays
Output rotation vectors (see Rodrigues ) that, together with tvecs , brings points from the model coordinate system to the camera coordinate system. A P3P problem has up to 4 solutions.
tvecs
Type: Emgu.CVIOutputArrayOfArrays
Output translation vectors.
flags
Type: Emgu.CV.CvEnumSolvePnpMethod
Method for solving a P3P problem: either P3P or AP3P

Return Value

Type: Int32
Number of solutions
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolvePnP Method

CvInvokeSolvePnP Method

Overload List
Name | Description
SolvePnP(IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod) | Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error
SolvePnP(MCvPoint3D32f, PointF, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod) | Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error.
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolvePnP Method (IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)

CvInvokeSolvePnP Method (IInputArray, IInputArray, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)

http://www.emgu.com
Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool SolvePnP(
    IInputArray objectPoints,
    IInputArray imagePoints,
    IInputArray intrinsicMatrix,
    IInputArray distortionCoeffs,
    IOutputArray rotationVector,
    IOutputArray translationVector,
    bool useExtrinsicGuess = false,
    SolvePnpMethod flags = 0
)
Public Shared Function SolvePnP (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    intrinsicMatrix As IInputArray,
    distortionCoeffs As IInputArray,
    rotationVector As IOutputArray,
    translationVector As IOutputArray,
    Optional useExtrinsicGuess As Boolean = false,
    Optional flags As SolvePnpMethod = 0
) As Boolean
public:
static bool SolvePnP(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    IInputArray^ intrinsicMatrix,
    IInputArray^ distortionCoeffs,
    IOutputArray^ rotationVector,
    IOutputArray^ translationVector,
    bool useExtrinsicGuess = false,
    SolvePnpMethod^ flags = 0
)
static member SolvePnP :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        intrinsicMatrix : IInputArray *
        distortionCoeffs : IInputArray *
        rotationVector : IOutputArray *
        translationVector : IOutputArray *
        ?useExtrinsicGuess : bool *
        ?flags : SolvePnpMethod
(* Defaults:
        let _useExtrinsicGuess = defaultArg useExtrinsicGuess false
        let _flags = defaultArg flags 0
*)
-> bool

Parameters

objectPoints
Type: Emgu.CVIInputArray
The array of object points, 3xN or Nx3, where N is the number of points in the view
imagePoints
Type: Emgu.CVIInputArray
The array of corresponding image points, 2xN or Nx2, where N is the number of points in the view
intrinsicMatrix
Type: Emgu.CVIInputArray
The camera matrix (A) [fx 0 cx; 0 fy cy; 0 0 1].
distortionCoeffs
Type: Emgu.CVIInputArray
The vector of distortion coefficients, 4x1 or 1x4 [k1, k2, p1, p2]. If it is IntPtr.Zero, all distortion coefficients are considered 0's.
rotationVector
Type: Emgu.CVIOutputArray
The output 3x1 or 1x3 rotation vector (compact representation of a rotation matrix, see cvRodrigues2).
translationVector
Type: Emgu.CVIOutputArray
The output 3x1 or 1x3 translation vector
useExtrinsicGuess (Optional)
Type: SystemBoolean
Use the input rotation and translation parameters as a guess
flags (Optional)
Type: Emgu.CV.CvEnumSolvePnpMethod
Method for solving a PnP problem

Return Value

Type: Boolean
True if successful
See Also

Reference

CvInvoke Class
SolvePnP Overload
Emgu.CV Namespace


CvInvoke.SolvePnP Method (MCvPoint3D32f[], PointF[], IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)

CvInvokeSolvePnP Method (MCvPoint3D32f, PointF, IInputArray, IInputArray, IOutputArray, IOutputArray, Boolean, SolvePnpMethod)

http://www.emgu.com
Estimates extrinsic camera parameters using known intrinsic parameters and extrinsic parameters for each view. The coordinates of 3D object points and their correspondent 2D projections must be specified. This function also minimizes back-projection error.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool SolvePnP(
    MCvPoint3D32f[] objectPoints,
    PointF[] imagePoints,
    IInputArray intrinsicMatrix,
    IInputArray distortionCoeffs,
    IOutputArray rotationVector,
    IOutputArray translationVector,
    bool useExtrinsicGuess = false,
    SolvePnpMethod method = 0
)
Public Shared Function SolvePnP (
    objectPoints As MCvPoint3D32f(),
    imagePoints As PointF(),
    intrinsicMatrix As IInputArray,
    distortionCoeffs As IInputArray,
    rotationVector As IOutputArray,
    translationVector As IOutputArray,
    Optional useExtrinsicGuess As Boolean = false,
    Optional method As SolvePnpMethod = 0
) As Boolean
public:
static bool SolvePnP(
    array<MCvPoint3D32f^>^ objectPoints,
    array<PointF^>^ imagePoints,
    IInputArray^ intrinsicMatrix,
    IInputArray^ distortionCoeffs,
    IOutputArray^ rotationVector,
    IOutputArray^ translationVector,
    bool useExtrinsicGuess = false,
    SolvePnpMethod^ method = 0
)
static member SolvePnP :
        objectPoints : MCvPoint3D32f[] *
        imagePoints : PointF[] *
        intrinsicMatrix : IInputArray *
        distortionCoeffs : IInputArray *
        rotationVector : IOutputArray *
        translationVector : IOutputArray *
        ?useExtrinsicGuess : bool *
        ?method : SolvePnpMethod
(* Defaults:
        let _useExtrinsicGuess = defaultArg useExtrinsicGuess false
        let _method = defaultArg method 0
*)
-> bool

Parameters

objectPoints
Type: Emgu.CV.StructureMCvPoint3D32f
The array of object points
imagePoints
Type: System.DrawingPointF
The array of corresponding image points
intrinsicMatrix
Type: Emgu.CVIInputArray
The camera matrix (A) [fx 0 cx; 0 fy cy; 0 0 1].
distortionCoeffs
Type: Emgu.CVIInputArray
The vector of distortion coefficients, 4x1 or 1x4 [k1, k2, p1, p2]. If it is IntPtr.Zero, all distortion coefficients are considered 0's.
rotationVector
Type: Emgu.CVIOutputArray
The output 3x1 or 1x3 rotation vector (compact representation of a rotation matrix, see cvRodrigues2).
translationVector
Type: Emgu.CVIOutputArray
The output 3x1 or 1x3 translation vector
useExtrinsicGuess (Optional)
Type: SystemBoolean
Use the input rotation and translation parameters as a guess
method (Optional)
Type: Emgu.CV.CvEnumSolvePnpMethod
Method for solving a PnP problem

Return Value

Type: Boolean
True if successful
See Also

Reference

CvInvoke Class
SolvePnP Overload
Emgu.CV Namespace


CvInvoke.SolvePnPGeneric Method

CvInvokeSolvePnPGeneric Method

Finds an object pose from 3D-2D point correspondences.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SolvePnPGeneric(
    IInputArray objectPoints,
    IInputArray imagePoints,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IOutputArrayOfArrays rvecs,
    IOutputArrayOfArrays tvecs,
    bool useExtrinsicGuess = false,
    SolvePnpMethod flags = 0,
    IInputArray rvec = null,
    IInputArray tvec = null,
    IOutputArray reprojectionError = null
)
Public Shared Function SolvePnPGeneric (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvecs As IOutputArrayOfArrays,
    tvecs As IOutputArrayOfArrays,
    Optional useExtrinsicGuess As Boolean = false,
    Optional flags As SolvePnpMethod = 0,
    Optional rvec As IInputArray = Nothing,
    Optional tvec As IInputArray = Nothing,
    Optional reprojectionError As IOutputArray = Nothing
) As Integer
public:
static int SolvePnPGeneric(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IOutputArrayOfArrays^ rvecs,
    IOutputArrayOfArrays^ tvecs,
    bool useExtrinsicGuess = false,
    SolvePnpMethod^ flags = 0,
    IInputArray^ rvec = nullptr,
    IInputArray^ tvec = nullptr,
    IOutputArray^ reprojectionError = nullptr
)
static member SolvePnPGeneric :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvecs : IOutputArrayOfArrays *
        tvecs : IOutputArrayOfArrays *
        ?useExtrinsicGuess : bool *
        ?flags : SolvePnpMethod *
        ?rvec : IInputArray *
        ?tvec : IInputArray *
        ?reprojectionError : IOutputArray
(* Defaults:
        let _useExtrinsicGuess = defaultArg useExtrinsicGuess false
        let _flags = defaultArg flags 0
        let _rvec = defaultArg rvec null
        let _tvec = defaultArg tvec null
        let _reprojectionError = defaultArg reprojectionError null
*)
-> int

Parameters

objectPoints
Type: Emgu.CVIInputArray
Array of object points in the object coordinate space, Nx3 1-channel or 1xN/Nx1 3-channel, where N is the number of points. VectorOfPoint3f can also be passed here.
imagePoints
Type: Emgu.CVIInputArray
Array of corresponding image points, Nx2 1-channel or 1xN/Nx1 2-channel, where N is the number of points. VectorOfPoint2f can also be passed here.
cameraMatrix
Type: Emgu.CVIInputArray
Input camera matrix A=[[fx,0,0],[0,fy,0][cx,cy,1]].
distCoeffs
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6[,s1,s2,s3,s4[,τx,τy]]]]) of 4, 5, 8, 12 or 14 elements. If the vector is NULL/empty, the zero distortion coefficients are assumed.
rvecs
Type: Emgu.CVIOutputArrayOfArrays
Vector of output rotation vectors (see Rodrigues ) that, together with tvecs, brings points from the model coordinate system to the camera coordinate system.
tvecs
Type: Emgu.CVIOutputArrayOfArrays
Vector of output translation vectors.
useExtrinsicGuess (Optional)
Type: SystemBoolean
Parameter used for SOLVEPNP_ITERATIVE. If true, the function uses the provided rvec and tvec values as initial approximations of the rotation and translation vectors, respectively, and further optimizes them.
flags (Optional)
Type: Emgu.CV.CvEnumSolvePnpMethod
Method for solving a PnP problem
rvec (Optional)
Type: Emgu.CVIInputArray
Rotation vector used to initialize an iterative PnP refinement algorithm, when flag is SOLVEPNP_ITERATIVE and useExtrinsicGuess is set to true.
tvec (Optional)
Type: Emgu.CVIInputArray
Translation vector used to initialize an iterative PnP refinement algorithm, when flag is SOLVEPNP_ITERATIVE and useExtrinsicGuess is set to true.
reprojectionError (Optional)
Type: Emgu.CVIOutputArray
Optional vector of reprojection error, that is the RMS error between the input image points and the 3D object points projected with the estimated pose.

Return Value

Type: Int32

[Missing <returns> documentation for "M:Emgu.CV.CvInvoke.SolvePnPGeneric(Emgu.CV.IInputArray,Emgu.CV.IInputArray,Emgu.CV.IInputArray,Emgu.CV.IInputArray,Emgu.CV.IOutputArrayOfArrays,Emgu.CV.IOutputArrayOfArrays,System.Boolean,Emgu.CV.CvEnum.SolvePnpMethod,Emgu.CV.IInputArray,Emgu.CV.IInputArray,Emgu.CV.IOutputArray)"]

See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolvePnPRansac Method

CvInvokeSolvePnPRansac Method

Finds an object pose from 3D-2D point correspondences using the RANSAC scheme.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool SolvePnPRansac(
    IInputArray objectPoints,
    IInputArray imagePoints,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IOutputArray rvec,
    IOutputArray tvec,
    bool useExtrinsicGuess = false,
    int iterationsCount = 100,
    float reprojectionError = 8f,
    double confident = 0.99,
    IOutputArray inliers = null,
    SolvePnpMethod flags = 0
)
Public Shared Function SolvePnPRansac (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvec As IOutputArray,
    tvec As IOutputArray,
    Optional useExtrinsicGuess As Boolean = false,
    Optional iterationsCount As Integer = 100,
    Optional reprojectionError As Single = 8F,
    Optional confident As Double = 0.99,
    Optional inliers As IOutputArray = Nothing,
    Optional flags As SolvePnpMethod = 0
) As Boolean
public:
static bool SolvePnPRansac(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IOutputArray^ rvec,
    IOutputArray^ tvec,
    bool useExtrinsicGuess = false,
    int iterationsCount = 100,
    float reprojectionError = 8f,
    double confident = 0.99,
    IOutputArray^ inliers = nullptr,
    SolvePnpMethod^ flags = 0
)
static member SolvePnPRansac :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvec : IOutputArray *
        tvec : IOutputArray *
        ?useExtrinsicGuess : bool *
        ?iterationsCount : int *
        ?reprojectionError : float32 *
        ?confident : float *
        ?inliers : IOutputArray *
        ?flags : SolvePnpMethod
(* Defaults:
        let _useExtrinsicGuess = defaultArg useExtrinsicGuess false
        let _iterationsCount = defaultArg iterationsCount 100
        let _reprojectionError = defaultArg reprojectionError 8f
        let _confident = defaultArg confident 0.99
        let _inliers = defaultArg inliers null
        let _flags = defaultArg flags 0
*)
-> bool

Parameters

objectPoints
Type: Emgu.CVIInputArray
Array of object points in the object coordinate space, 3xN/Nx3 1-channel or 1xN/Nx1 3-channel, where N is the number of points. VectorOfPoint3D32f can be also passed here.
imagePoints
Type: Emgu.CVIInputArray
Array of corresponding image points, 2xN/Nx2 1-channel or 1xN/Nx1 2-channel, where N is the number of points. VectorOfPointF can be also passed here.
cameraMatrix
Type: Emgu.CVIInputArray
Input camera matrix
distCoeffs
Type: Emgu.CVIInputArray
Input vector of distortion coefficients of 4, 5, 8 or 12 elements. If the vector is null/empty, the zero distortion coefficients are assumed.
rvec
Type: Emgu.CVIOutputArray
Output rotation vector
tvec
Type: Emgu.CVIOutputArray
Output translation vector.
useExtrinsicGuess (Optional)
Type: SystemBoolean
If true, the function uses the provided rvec and tvec values as initial approximations of the rotation and translation vectors, respectively, and further optimizes them.
iterationsCount (Optional)
Type: SystemInt32
Number of iterations.
reprojectionError (Optional)
Type: SystemSingle
Inlier threshold value used by the RANSAC procedure. The parameter value is the maximum allowed distance between the observed and computed point projections to consider it an inlier.
confident (Optional)
Type: SystemDouble
The probability that the algorithm produces a useful result.
inliers (Optional)
Type: Emgu.CVIOutputArray
Output vector that contains indices of inliers in objectPoints and imagePoints .
flags (Optional)
Type: Emgu.CV.CvEnumSolvePnpMethod
Method for solving a PnP problem

Return Value

Type: Boolean
True if successful
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolvePnPRefineLM Method

CvInvokeSolvePnPRefineLM Method

Refine a pose (the translation and the rotation that transform a 3D point expressed in the object coordinate frame to the camera coordinate frame) from a 3D-2D point correspondences and starting from an initial solution

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SolvePnPRefineLM(
    IInputArray objectPoints,
    IInputArray imagePoints,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IInputOutputArray rvec,
    IInputOutputArray tvec,
    MCvTermCriteria criteria
)
Public Shared Sub SolvePnPRefineLM (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvec As IInputOutputArray,
    tvec As IInputOutputArray,
    criteria As MCvTermCriteria
)
public:
static void SolvePnPRefineLM(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IInputOutputArray^ rvec,
    IInputOutputArray^ tvec,
    MCvTermCriteria^ criteria
)
static member SolvePnPRefineLM :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvec : IInputOutputArray *
        tvec : IInputOutputArray *
        criteria : MCvTermCriteria -> unit

Parameters

objectPoints
Type: Emgu.CVIInputArray
Array of object points in the object coordinate space, Nx3 1-channel or 1xN/Nx1 3-channel, where N is the number of points. VectorOfPoint3f can also be passed here.
imagePoints
Type: Emgu.CVIInputArray
Array of corresponding image points, Nx2 1-channel or 1xN/Nx1 2-channel, where N is the number of points. VectorOfPoint2f can also be passed here.
cameraMatrix
Type: Emgu.CVIInputArray
Input camera matrix A=[[fx,0,0],[0,fy,0][cx,cy,1]].
distCoeffs
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6[,s1,s2,s3,s4[,τx,τy]]]]) of 4, 5, 8, 12 or 14 elements. If the vector is NULL/empty, the zero distortion coefficients are assumed.
rvec
Type: Emgu.CVIInputOutputArray
Input/Output rotation vector (see Rodrigues ) that, together with tvec, brings points from the model coordinate system to the camera coordinate system. Input values are used as an initial solution.
tvec
Type: Emgu.CVIInputOutputArray
Input/Output translation vector. Input values are used as an initial solution.
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Criteria when to stop the Levenberg-Marquard iterative algorithm.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolvePnPRefineVVS Method

CvInvokeSolvePnPRefineVVS Method

Refine a pose (the translation and the rotation that transform a 3D point expressed in the object coordinate frame to the camera coordinate frame) from a 3D-2D point correspondences and starting from an initial solution.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SolvePnPRefineVVS(
    IInputArray objectPoints,
    IInputArray imagePoints,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IInputOutputArray rvec,
    IInputOutputArray tvec,
    MCvTermCriteria criteria,
    double VVSlambda
)
Public Shared Sub SolvePnPRefineVVS (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvec As IInputOutputArray,
    tvec As IInputOutputArray,
    criteria As MCvTermCriteria,
    VVSlambda As Double
)
public:
static void SolvePnPRefineVVS(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IInputOutputArray^ rvec,
    IInputOutputArray^ tvec,
    MCvTermCriteria^ criteria,
    double VVSlambda
)
static member SolvePnPRefineVVS :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvec : IInputOutputArray *
        tvec : IInputOutputArray *
        criteria : MCvTermCriteria *
        VVSlambda : float -> unit

Parameters

objectPoints
Type: Emgu.CVIInputArray
Array of object points in the object coordinate space, Nx3 1-channel or 1xN/Nx1 3-channel, where N is the number of points. VectorOfPoint3f can also be passed here.
imagePoints
Type: Emgu.CVIInputArray
Array of corresponding image points, Nx2 1-channel or 1xN/Nx1 2-channel, where N is the number of points. VectorOfPoint2f can also be passed here.
cameraMatrix
Type: Emgu.CVIInputArray
Input camera matrix A=[[fx,0,0],[0,fy,0][cx,cy,1]].
distCoeffs
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6[,s1,s2,s3,s4[,τx,τy]]]]) of 4, 5, 8, 12 or 14 elements. If the vector is NULL/empty, the zero distortion coefficients are assumed.
rvec
Type: Emgu.CVIInputOutputArray
Input/Output rotation vector (see Rodrigues ) that, together with tvec, brings points from the model coordinate system to the camera coordinate system. Input values are used as an initial solution.
tvec
Type: Emgu.CVIInputOutputArray
Input/Output translation vector. Input values are used as an initial solution.
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Criteria when to stop the Levenberg-Marquard iterative algorithm.
VVSlambda
Type: SystemDouble
Gain for the virtual visual servoing control law, equivalent to the α gain in the Damped Gauss-Newton formulation.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SolvePoly Method

CvInvokeSolvePoly Method

Finds all real and complex roots of any degree polynomial with real coefficients

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double SolvePoly(
    IInputArray coeffs,
    IOutputArray roots,
    int maxiter = 300
)
Public Shared Function SolvePoly (
    coeffs As IInputArray,
    roots As IOutputArray,
    Optional maxiter As Integer = 300
) As Double
public:
static double SolvePoly(
    IInputArray^ coeffs,
    IOutputArray^ roots,
    int maxiter = 300
)
static member SolvePoly :
        coeffs : IInputArray *
        roots : IOutputArray *
        ?maxiter : int
(* Defaults:
        let _maxiter = defaultArg maxiter 300
*)
-> float

Parameters

coeffs
Type: Emgu.CVIInputArray
The (degree + 1)-length array of equation coefficients (CV_32FC1 or CV_64FC1)
roots
Type: Emgu.CVIOutputArray
The degree-length output array of real or complex roots (CV_32FC2 or CV_64FC2)
maxiter (Optional)
Type: SystemInt32
The maximum number of iterations

Return Value

Type: Double

[Missing <returns> documentation for "M:Emgu.CV.CvInvoke.SolvePoly(Emgu.CV.IInputArray,Emgu.CV.IOutputArray,System.Int32)"]

See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Sort Method

CvInvokeSort Method

Sorts each matrix row or each matrix column in ascending or descending order.So you should pass two operation flags to get desired behaviour.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Sort(
    IInputArray src,
    IOutputArray dst,
    SortFlags flags
)
Public Shared Sub Sort (
    src As IInputArray,
    dst As IOutputArray,
    flags As SortFlags
)
public:
static void Sort(
    IInputArray^ src,
    IOutputArray^ dst,
    SortFlags^ flags
)
static member Sort :
        src : IInputArray *
        dst : IOutputArray *
        flags : SortFlags -> unit

Parameters

src
Type: Emgu.CVIInputArray
input single-channel array.
dst
Type: Emgu.CVIOutputArray
output array of the same size and type as src.
flags
Type: Emgu.CV.CvEnumSortFlags
operation flags
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SortIdx Method

CvInvokeSortIdx Method

Sorts each matrix row or each matrix column in the ascending or descending order.So you should pass two operation flags to get desired behaviour. Instead of reordering the elements themselves, it stores the indices of sorted elements in the output array.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SortIdx(
    IInputArray src,
    IOutputArray dst,
    SortFlags flags
)
Public Shared Sub SortIdx (
    src As IInputArray,
    dst As IOutputArray,
    flags As SortFlags
)
public:
static void SortIdx(
    IInputArray^ src,
    IOutputArray^ dst,
    SortFlags^ flags
)
static member SortIdx :
        src : IInputArray *
        dst : IOutputArray *
        flags : SortFlags -> unit

Parameters

src
Type: Emgu.CVIInputArray
input single-channel array.
dst
Type: Emgu.CVIOutputArray
output integer array of the same size as src.
flags
Type: Emgu.CV.CvEnumSortFlags
operation flags
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SpatialGradient Method

CvInvokeSpatialGradient Method

Calculates the first order image derivative in both x and y using a Sobel operator. Equivalent to calling: Sobel(src, dx, CV_16SC1, 1, 0, 3 ); Sobel(src, dy, CV_16SC1, 0, 1, 3 );

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SpatialGradient(
    IInputArray src,
    IOutputArray dx,
    IOutputArray dy,
    int ksize = 3,
    BorderType borderType = 4
)
Public Shared Sub SpatialGradient (
    src As IInputArray,
    dx As IOutputArray,
    dy As IOutputArray,
    Optional ksize As Integer = 3,
    Optional borderType As BorderType = 4
)
public:
static void SpatialGradient(
    IInputArray^ src,
    IOutputArray^ dx,
    IOutputArray^ dy,
    int ksize = 3,
    BorderType^ borderType = 4
)
static member SpatialGradient :
        src : IInputArray *
        dx : IOutputArray *
        dy : IOutputArray *
        ?ksize : int *
        ?borderType : BorderType
(* Defaults:
        let _ksize = defaultArg ksize 3
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
input image.
dx
Type: Emgu.CVIOutputArray
output image with first-order derivative in x.
dy
Type: Emgu.CVIOutputArray
output image with first-order derivative in y.
ksize (Optional)
Type: SystemInt32
size of Sobel kernel. It must be 3.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
pixel extrapolation method
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Split Method

CvInvokeSplit Method

Divides a multi-channel array into separate single-channel arrays. Two modes are available for the operation. If the source array has N channels then if the first N destination channels are not IntPtr.Zero, all they are extracted from the source array, otherwise if only a single destination channel of the first N is not IntPtr.Zero, this particular channel is extracted, otherwise an error is raised. Rest of destination channels (beyond the first N) must always be IntPtr.Zero. For IplImage cvCopy with COI set can be also used to extract a single channel from the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Split(
    IInputArray src,
    IOutputArray mv
)
Public Shared Sub Split (
    src As IInputArray,
    mv As IOutputArray
)
public:
static void Split(
    IInputArray^ src,
    IOutputArray^ mv
)
static member Split :
        src : IInputArray *
        mv : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input multi-channel array
mv
Type: Emgu.CVIOutputArray
Output array or vector of arrays
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SqrBoxFilter Method

CvInvokeSqrBoxFilter Method

Calculates the normalized sum of squares of the pixel values overlapping the filter. For every pixel(x, y) in the source image, the function calculates the sum of squares of those neighboring pixel values which overlap the filter placed over the pixel(x, y). The unnormalized square box filter can be useful in computing local image statistics such as the the local variance and standard deviation around the neighborhood of a pixel.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SqrBoxFilter(
    IInputArray src,
    IOutputArray dst,
    DepthType ddepth,
    Size ksize,
    Point anchor,
    bool normalize = true,
    BorderType borderType = 4
)
Public Shared Sub SqrBoxFilter (
    src As IInputArray,
    dst As IOutputArray,
    ddepth As DepthType,
    ksize As Size,
    anchor As Point,
    Optional normalize As Boolean = true,
    Optional borderType As BorderType = 4
)
public:
static void SqrBoxFilter(
    IInputArray^ src,
    IOutputArray^ dst,
    DepthType^ ddepth,
    Size^ ksize,
    Point^ anchor,
    bool normalize = true,
    BorderType^ borderType = 4
)
static member SqrBoxFilter :
        src : IInputArray *
        dst : IOutputArray *
        ddepth : DepthType *
        ksize : Size *
        anchor : Point *
        ?normalize : bool *
        ?borderType : BorderType
(* Defaults:
        let _normalize = defaultArg normalize true
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
input image
dst
Type: Emgu.CVIOutputArray
output image of the same size and type as src
ddepth
Type: Emgu.CV.CvEnumDepthType
the output image depth (-1 to use src.depth())
ksize
Type: System.DrawingSize
kernel size
anchor
Type: System.DrawingPoint
kernel anchor point. The default value of Point(-1, -1) denotes that the anchor is at the kernel center
normalize (Optional)
Type: SystemBoolean
flag, specifying whether the kernel is to be normalized by it's area or not.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
border mode used to extrapolate pixels outside of the image
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Sqrt Method

CvInvokeSqrt Method

Calculate square root of each source array element. in the case of multichannel arrays each channel is processed independently. The function accuracy is approximately the same as of the built-in std::sqrt.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Sqrt(
    IInputArray src,
    IOutputArray dst
)
Public Shared Sub Sqrt (
    src As IInputArray,
    dst As IOutputArray
)
public:
static void Sqrt(
    IInputArray^ src,
    IOutputArray^ dst
)
static member Sqrt :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source floating-point array
dst
Type: Emgu.CVIOutputArray
The destination array; will have the same size and the same type as src
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.StereoCalibrate Method

CvInvokeStereoCalibrate Method

Overload List
Name | Description
StereoCalibrate(IInputArray, IInputArray, IInputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the fist camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T
StereoCalibrate(MCvPoint3D32f, PointF, PointF, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the first camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.StereoCalibrate Method (IInputArray, IInputArray, IInputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

CvInvokeStereoCalibrate Method (IInputArray, IInputArray, IInputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

http://www.emgu.com
Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the fist camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double StereoCalibrate(
    IInputArray objectPoints,
    IInputArray imagePoints1,
    IInputArray imagePoints2,
    IInputOutputArray cameraMatrix1,
    IInputOutputArray distCoeffs1,
    IInputOutputArray cameraMatrix2,
    IInputOutputArray distCoeffs2,
    Size imageSize,
    IOutputArray r,
    IOutputArray t,
    IOutputArray e,
    IOutputArray f,
    CalibType flags,
    MCvTermCriteria termCrit
)
Public Shared Function StereoCalibrate (
    objectPoints As IInputArray,
    imagePoints1 As IInputArray,
    imagePoints2 As IInputArray,
    cameraMatrix1 As IInputOutputArray,
    distCoeffs1 As IInputOutputArray,
    cameraMatrix2 As IInputOutputArray,
    distCoeffs2 As IInputOutputArray,
    imageSize As Size,
    r As IOutputArray,
    t As IOutputArray,
    e As IOutputArray,
    f As IOutputArray,
    flags As CalibType,
    termCrit As MCvTermCriteria
) As Double
public:
static double StereoCalibrate(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints1,
    IInputArray^ imagePoints2,
    IInputOutputArray^ cameraMatrix1,
    IInputOutputArray^ distCoeffs1,
    IInputOutputArray^ cameraMatrix2,
    IInputOutputArray^ distCoeffs2,
    Size^ imageSize,
    IOutputArray^ r,
    IOutputArray^ t,
    IOutputArray^ e,
    IOutputArray^ f,
    CalibType^ flags,
    MCvTermCriteria^ termCrit
)
static member StereoCalibrate :
        objectPoints : IInputArray *
        imagePoints1 : IInputArray *
        imagePoints2 : IInputArray *
        cameraMatrix1 : IInputOutputArray *
        distCoeffs1 : IInputOutputArray *
        cameraMatrix2 : IInputOutputArray *
        distCoeffs2 : IInputOutputArray *
        imageSize : Size *
        r : IOutputArray *
        t : IOutputArray *
        e : IOutputArray *
        f : IOutputArray *
        flags : CalibType *
        termCrit : MCvTermCriteria -> float

Parameters

objectPoints
Type: Emgu.CVIInputArray
The joint matrix of object points, 3xN or Nx3, where N is the total number of points in all views
imagePoints1
Type: Emgu.CVIInputArray
The joint matrix of corresponding image points in the views from the 1st camera, 2xN or Nx2, where N is the total number of points in all views
imagePoints2
Type: Emgu.CVIInputArray
The joint matrix of corresponding image points in the views from the 2nd camera, 2xN or Nx2, where N is the total number of points in all views
cameraMatrix1
Type: Emgu.CVIInputOutputArray
The input/output camera matrices [fxk 0 cxk; 0 fyk cyk; 0 0 1]. If CV_CALIB_USE_INTRINSIC_GUESS or CV_CALIB_FIX_ASPECT_RATIO are specified, some or all of the elements of the matrices must be initialized
distCoeffs1
Type: Emgu.CVIInputOutputArray
The input/output vectors of distortion coefficients for each camera, 4x1, 1x4, 5x1 or 1x5
cameraMatrix2
Type: Emgu.CVIInputOutputArray
The input/output camera matrices [fxk 0 cxk; 0 fyk cyk; 0 0 1]. If CV_CALIB_USE_INTRINSIC_GUESS or CV_CALIB_FIX_ASPECT_RATIO are specified, some or all of the elements of the matrices must be initialized
distCoeffs2
Type: Emgu.CVIInputOutputArray
The input/output vectors of distortion coefficients for each camera, 4x1, 1x4, 5x1 or 1x5
imageSize
Type: System.DrawingSize
Size of the image, used only to initialize intrinsic camera matrix
r
Type: Emgu.CVIOutputArray
The rotation matrix between the 1st and the 2nd cameras' coordinate systems
t
Type: Emgu.CVIOutputArray
The translation vector between the cameras' coordinate systems
e
Type: Emgu.CVIOutputArray
The optional output essential matrix
f
Type: Emgu.CVIOutputArray
The optional output fundamental matrix
flags
Type: Emgu.CV.CvEnumCalibType
The calibration flags
termCrit
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm

Return Value

Type: Double
The final value of the re-projection error.
See Also

Reference

CvInvoke Class
StereoCalibrate Overload
Emgu.CV Namespace


CvInvoke.StereoCalibrate Method (MCvPoint3D32f[][], PointF[][], PointF[][], IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

CvInvokeStereoCalibrate Method (MCvPoint3D32f, PointF, PointF, IInputOutputArray, IInputOutputArray, IInputOutputArray, IInputOutputArray, Size, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

http://www.emgu.com
Estimates transformation between the 2 cameras making a stereo pair. If we have a stereo camera, where the relative position and orientatation of the 2 cameras is fixed, and if we computed poses of an object relative to the first camera and to the second camera, (R1, T1) and (R2, T2), respectively (that can be done with cvFindExtrinsicCameraParams2), obviously, those poses will relate to each other, i.e. given (R1, T1) it should be possible to compute (R2, T2) - we only need to know the position and orientation of the 2nd camera relative to the 1st camera. That's what the described function does. It computes (R, T) such that: R2=R*R1, T2=R*T1 + T

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double StereoCalibrate(
    MCvPoint3D32f[][] objectPoints,
    PointF[][] imagePoints1,
    PointF[][] imagePoints2,
    IInputOutputArray cameraMatrix1,
    IInputOutputArray distCoeffs1,
    IInputOutputArray cameraMatrix2,
    IInputOutputArray distCoeffs2,
    Size imageSize,
    IOutputArray r,
    IOutputArray t,
    IOutputArray e,
    IOutputArray f,
    CalibType flags,
    MCvTermCriteria termCrit
)
Public Shared Function StereoCalibrate (
    objectPoints As MCvPoint3D32f()(),
    imagePoints1 As PointF()(),
    imagePoints2 As PointF()(),
    cameraMatrix1 As IInputOutputArray,
    distCoeffs1 As IInputOutputArray,
    cameraMatrix2 As IInputOutputArray,
    distCoeffs2 As IInputOutputArray,
    imageSize As Size,
    r As IOutputArray,
    t As IOutputArray,
    e As IOutputArray,
    f As IOutputArray,
    flags As CalibType,
    termCrit As MCvTermCriteria
) As Double
public:
static double StereoCalibrate(
    array<array<MCvPoint3D32f^>^>^ objectPoints,
    array<array<PointF^>^>^ imagePoints1,
    array<array<PointF^>^>^ imagePoints2,
    IInputOutputArray^ cameraMatrix1,
    IInputOutputArray^ distCoeffs1,
    IInputOutputArray^ cameraMatrix2,
    IInputOutputArray^ distCoeffs2,
    Size^ imageSize,
    IOutputArray^ r,
    IOutputArray^ t,
    IOutputArray^ e,
    IOutputArray^ f,
    CalibType^ flags,
    MCvTermCriteria^ termCrit
)
static member StereoCalibrate :
        objectPoints : MCvPoint3D32f[][] *
        imagePoints1 : PointF[][] *
        imagePoints2 : PointF[][] *
        cameraMatrix1 : IInputOutputArray *
        distCoeffs1 : IInputOutputArray *
        cameraMatrix2 : IInputOutputArray *
        distCoeffs2 : IInputOutputArray *
        imageSize : Size *
        r : IOutputArray *
        t : IOutputArray *
        e : IOutputArray *
        f : IOutputArray *
        flags : CalibType *
        termCrit : MCvTermCriteria -> float

Parameters

objectPoints
Type: Emgu.CV.StructureMCvPoint3D32f
The 3D location of the object points. The first index is the index of image, second index is the index of the point
imagePoints1
Type: System.DrawingPointF
The 2D image location of the points for camera 1. The first index is the index of the image, second index is the index of the point
imagePoints2
Type: System.DrawingPointF
The 2D image location of the points for camera 2. The first index is the index of the image, second index is the index of the point
cameraMatrix1
Type: Emgu.CVIInputOutputArray
The input/output camera matrices [fxk 0 cxk; 0 fyk cyk; 0 0 1]. If CV_CALIB_USE_INTRINSIC_GUESS or CV_CALIB_FIX_ASPECT_RATIO are specified, some or all of the elements of the matrices must be initialized
distCoeffs1
Type: Emgu.CVIInputOutputArray
The input/output vectors of distortion coefficients for each camera, 4x1, 1x4, 5x1 or 1x5
cameraMatrix2
Type: Emgu.CVIInputOutputArray
The input/output camera matrices [fxk 0 cxk; 0 fyk cyk; 0 0 1]. If CV_CALIB_USE_INTRINSIC_GUESS or CV_CALIB_FIX_ASPECT_RATIO are specified, some or all of the elements of the matrices must be initialized
distCoeffs2
Type: Emgu.CVIInputOutputArray
The input/output vectors of distortion coefficients for each camera, 4x1, 1x4, 5x1 or 1x5
imageSize
Type: System.DrawingSize
Size of the image, used only to initialize intrinsic camera matrix
r
Type: Emgu.CVIOutputArray
The rotation matrix between the 1st and the 2nd cameras' coordinate systems
t
Type: Emgu.CVIOutputArray
The translation vector between the cameras' coordinate systems
e
Type: Emgu.CVIOutputArray
The optional output essential matrix
f
Type: Emgu.CVIOutputArray
The optional output fundamental matrix
flags
Type: Emgu.CV.CvEnumCalibType
The calibration flags
termCrit
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm

Return Value

Type: Double
The final value of the re-projection error.
See Also

Reference

CvInvoke Class
StereoCalibrate Overload
Emgu.CV Namespace


CvInvoke.StereoRectify Method

CvInvokeStereoRectify Method

computes the rotation matrices for each camera that (virtually) make both camera image planes the same plane. Consequently, that makes all the epipolar lines parallel and thus simplifies the dense stereo correspondence problem. On input the function takes the matrices computed by cvStereoCalibrate and on output it gives 2 rotation matrices and also 2 projection matrices in the new coordinates. The function is normally called after cvStereoCalibrate that computes both camera matrices, the distortion coefficients, R and T

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void StereoRectify(
    IInputArray cameraMatrix1,
    IInputArray distCoeffs1,
    IInputArray cameraMatrix2,
    IInputArray distCoeffs2,
    Size imageSize,
    IInputArray r,
    IInputArray t,
    IOutputArray r1,
    IOutputArray r2,
    IOutputArray p1,
    IOutputArray p2,
    IOutputArray q,
    StereoRectifyType flags,
    double alpha,
    Size newImageSize,
    ref Rectangle validPixRoi1,
    ref Rectangle validPixRoi2
)
Public Shared Sub StereoRectify (
    cameraMatrix1 As IInputArray,
    distCoeffs1 As IInputArray,
    cameraMatrix2 As IInputArray,
    distCoeffs2 As IInputArray,
    imageSize As Size,
    r As IInputArray,
    t As IInputArray,
    r1 As IOutputArray,
    r2 As IOutputArray,
    p1 As IOutputArray,
    p2 As IOutputArray,
    q As IOutputArray,
    flags As StereoRectifyType,
    alpha As Double,
    newImageSize As Size,
    ByRef validPixRoi1 As Rectangle,
    ByRef validPixRoi2 As Rectangle
)
public:
static void StereoRectify(
    IInputArray^ cameraMatrix1,
    IInputArray^ distCoeffs1,
    IInputArray^ cameraMatrix2,
    IInputArray^ distCoeffs2,
    Size^ imageSize,
    IInputArray^ r,
    IInputArray^ t,
    IOutputArray^ r1,
    IOutputArray^ r2,
    IOutputArray^ p1,
    IOutputArray^ p2,
    IOutputArray^ q,
    StereoRectifyType^ flags,
    double alpha,
    Size^ newImageSize,
    Rectangle^% validPixRoi1,
    Rectangle^% validPixRoi2
)
static member StereoRectify :
        cameraMatrix1 : IInputArray *
        distCoeffs1 : IInputArray *
        cameraMatrix2 : IInputArray *
        distCoeffs2 : IInputArray *
        imageSize : Size *
        r : IInputArray *
        t : IInputArray *
        r1 : IOutputArray *
        r2 : IOutputArray *
        p1 : IOutputArray *
        p2 : IOutputArray *
        q : IOutputArray *
        flags : StereoRectifyType *
        alpha : float *
        newImageSize : Size *
        validPixRoi1 : Rectangle byref *
        validPixRoi2 : Rectangle byref -> unit

Parameters

cameraMatrix1
Type: Emgu.CVIInputArray
The camera matrices [fx_k 0 cx_k; 0 fy_k cy_k; 0 0 1]
distCoeffs1
Type: Emgu.CVIInputArray
The vectors of distortion coefficients for first camera, 4x1, 1x4, 5x1 or 1x5
cameraMatrix2
Type: Emgu.CVIInputArray
The camera matrices [fx_k 0 cx_k; 0 fy_k cy_k; 0 0 1]
distCoeffs2
Type: Emgu.CVIInputArray
The vectors of distortion coefficients for second camera, 4x1, 1x4, 5x1 or 1x5
imageSize
Type: System.DrawingSize
Size of the image used for stereo calibration
r
Type: Emgu.CVIInputArray
The rotation matrix between the 1st and the 2nd cameras' coordinate systems
t
Type: Emgu.CVIInputArray
The translation vector between the cameras' coordinate systems
r1
Type: Emgu.CVIOutputArray
3x3 Rectification transforms (rotation matrices) for the first camera
r2
Type: Emgu.CVIOutputArray
3x3 Rectification transforms (rotation matrices) for the second camera
p1
Type: Emgu.CVIOutputArray
3x4 Projection matrices in the new (rectified) coordinate systems
p2
Type: Emgu.CVIOutputArray
3x4 Projection matrices in the new (rectified) coordinate systems
q
Type: Emgu.CVIOutputArray
The optional output disparity-to-depth mapping matrix, 4x4, see cvReprojectImageTo3D.
flags
Type: Emgu.CV.CvEnumStereoRectifyType
The operation flags, use ZeroDisparity for default
alpha
Type: SystemDouble
Use -1 for default
newImageSize
Type: System.DrawingSize
Use Size.Empty for default
validPixRoi1
Type: System.DrawingRectangle
The valid pixel ROI for image1
validPixRoi2
Type: System.DrawingRectangle
The valid pixel ROI for image2
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.StereoRectifyUncalibrated Method

CvInvokeStereoRectifyUncalibrated Method

Computes the rectification transformations without knowing intrinsic parameters of the cameras and their relative position in space, hence the suffix "Uncalibrated". Another related difference from cvStereoRectify is that the function outputs not the rectification transformations in the object (3D) space, but the planar perspective transformations, encoded by the homography matrices H1 and H2. The function implements the following algorithm [Hartley99].

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool StereoRectifyUncalibrated(
    IInputArray points1,
    IInputArray points2,
    IInputArray f,
    Size imgSize,
    IOutputArray h1,
    IOutputArray h2,
    double threshold = 5
)
Public Shared Function StereoRectifyUncalibrated (
    points1 As IInputArray,
    points2 As IInputArray,
    f As IInputArray,
    imgSize As Size,
    h1 As IOutputArray,
    h2 As IOutputArray,
    Optional threshold As Double = 5
) As Boolean
public:
static bool StereoRectifyUncalibrated(
    IInputArray^ points1,
    IInputArray^ points2,
    IInputArray^ f,
    Size^ imgSize,
    IOutputArray^ h1,
    IOutputArray^ h2,
    double threshold = 5
)
static member StereoRectifyUncalibrated :
        points1 : IInputArray *
        points2 : IInputArray *
        f : IInputArray *
        imgSize : Size *
        h1 : IOutputArray *
        h2 : IOutputArray *
        ?threshold : float
(* Defaults:
        let _threshold = defaultArg threshold 5
*)
-> bool

Parameters

points1
Type: Emgu.CVIInputArray
The array of 2D points
points2
Type: Emgu.CVIInputArray
The array of 2D points
f
Type: Emgu.CVIInputArray
Fundamental matrix. It can be computed using the same set of point pairs points1 and points2 using cvFindFundamentalMat
imgSize
Type: System.DrawingSize
Size of the image
h1
Type: Emgu.CVIOutputArray
The rectification homography matrices for the first images
h2
Type: Emgu.CVIOutputArray
The rectification homography matrices for the second images
threshold (Optional)
Type: SystemDouble
If the parameter is greater than zero, then all the point pairs that do not comply the epipolar geometry well enough (that is, the points for which fabs(points2[i]T*F*points1[i])>threshold) are rejected prior to computing the homographies

Return Value

Type: Boolean
True if successful
Remarks
Note that while the algorithm does not need to know the intrinsic parameters of the cameras, it heavily depends on the epipolar geometry. Therefore, if the camera lenses have significant distortion, it would better be corrected before computing the fundamental matrix and calling this function. For example, distortion coefficients can be estimated for each head of stereo camera separately by using cvCalibrateCamera2 and then the images can be corrected using cvUndistort2
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Stylization Method

CvInvokeStylization Method

Stylization aims to produce digital imagery with a wide variety of effects not focused on photorealism. Edge-aware filters are ideal for stylization, as they can abstract regions of low contrast while preserving, or enhancing, high-contrast features.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Stylization(
    IInputArray src,
    IOutputArray dst,
    float sigmaS = 60f,
    float sigmaR = 0.45f
)
Public Shared Sub Stylization (
    src As IInputArray,
    dst As IOutputArray,
    Optional sigmaS As Single = 60F,
    Optional sigmaR As Single = 0.45F
)
public:
static void Stylization(
    IInputArray^ src,
    IOutputArray^ dst,
    float sigmaS = 60f,
    float sigmaR = 0.45f
)
static member Stylization :
        src : IInputArray *
        dst : IOutputArray *
        ?sigmaS : float32 *
        ?sigmaR : float32
(* Defaults:
        let _sigmaS = defaultArg sigmaS 60f
        let _sigmaR = defaultArg sigmaR 0.45f
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image.
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src.
sigmaS (Optional)
Type: SystemSingle
Range between 0 to 200.
sigmaR (Optional)
Type: SystemSingle
Range between 0 to 1.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Subtract Method

CvInvokeSubtract Method

Subtracts one array from another one: dst(I)=src1(I)-src2(I) if mask(I)!=0 All the arrays must have the same type, except the mask, and the same size (or ROI size)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Subtract(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null,
    DepthType dtype = -1
)
Public Shared Sub Subtract (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional dtype As DepthType = -1
)
public:
static void Subtract(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    DepthType^ dtype = -1
)
static member Subtract :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?dtype : DepthType
(* Defaults:
        let _mask = defaultArg mask null
        let _dtype = defaultArg dtype -1
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array
src2
Type: Emgu.CVIInputArray
The second source array
dst
Type: Emgu.CVIOutputArray
The destination array
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask, 8-bit single channel array; specifies elements of destination array to be changed
dtype (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Sum Method

CvInvokeSum Method

Calculates sum S of array elements, independently for each channel Sc = sumI arr(I)c If the array is IplImage and COI is set, the function processes the selected channel only and stores the sum to the first scalar component (S0).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar Sum(
    IInputArray src
)
Public Shared Function Sum (
    src As IInputArray
) As MCvScalar
public:
static MCvScalar^ Sum(
    IInputArray^ src
)
static member Sum :
        src : IInputArray -> MCvScalar

Parameters

src
Type: Emgu.CVIInputArray
The array

Return Value

Type: MCvScalar
The sum of array elements
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SVBackSubst Method

CvInvokeSVBackSubst Method

Performs a singular value back substitution.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SVBackSubst(
    IInputArray w,
    IInputArray u,
    IInputArray vt,
    IInputArray rhs,
    IOutputArray dst
)
Public Shared Sub SVBackSubst (
    w As IInputArray,
    u As IInputArray,
    vt As IInputArray,
    rhs As IInputArray,
    dst As IOutputArray
)
public:
static void SVBackSubst(
    IInputArray^ w,
    IInputArray^ u,
    IInputArray^ vt,
    IInputArray^ rhs,
    IOutputArray^ dst
)
static member SVBackSubst :
        w : IInputArray *
        u : IInputArray *
        vt : IInputArray *
        rhs : IInputArray *
        dst : IOutputArray -> unit

Parameters

w
Type: Emgu.CVIInputArray
Singular values
u
Type: Emgu.CVIInputArray
Left singular vectors
vt
Type: Emgu.CVIInputArray
Transposed matrix of right singular vectors.
rhs
Type: Emgu.CVIInputArray
Right-hand side of a linear system
dst
Type: Emgu.CVIOutputArray
Found solution of the system.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.SVDecomp Method

CvInvokeSVDecomp Method

Decomposes matrix A into a product of a diagonal matrix and two orthogonal matrices: A=U*W*VT Where W is diagonal matrix of singular values that can be coded as a 1D vector of singular values and U and V. All the singular values are non-negative and sorted (together with U and V columns) in descenting order.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SVDecomp(
    IInputArray src,
    IOutputArray w,
    IOutputArray u,
    IOutputArray v,
    SvdFlag flags
)
Public Shared Sub SVDecomp (
    src As IInputArray,
    w As IOutputArray,
    u As IOutputArray,
    v As IOutputArray,
    flags As SvdFlag
)
public:
static void SVDecomp(
    IInputArray^ src,
    IOutputArray^ w,
    IOutputArray^ u,
    IOutputArray^ v,
    SvdFlag^ flags
)
static member SVDecomp :
        src : IInputArray *
        w : IOutputArray *
        u : IOutputArray *
        v : IOutputArray *
        flags : SvdFlag -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source MxN matrix
w
Type: Emgu.CVIOutputArray
Resulting singular value matrix (MxN or NxN) or vector (Nx1).
u
Type: Emgu.CVIOutputArray
Optional left orthogonal matrix (MxM or MxN). If CV_SVD_U_T is specified, the number of rows and columns in the sentence above should be swapped
v
Type: Emgu.CVIOutputArray
Optional right orthogonal matrix (NxN)
flags
Type: Emgu.CV.CvEnumSvdFlag
Operation flags
Remarks
SVD algorithm is numerically robust and its typical applications include: 1. accurate eigenvalue problem solution when matrix A is square, symmetric and positively defined matrix, for example, when it is a covariation matrix. W in this case will be a vector of eigen values, and U=V is matrix of eigen vectors (thus, only one of U or V needs to be calculated if the eigen vectors are required) 2. accurate solution of poor-conditioned linear systems 3. least-squares solution of overdetermined linear systems. This and previous is done by cvSolve function with CV_SVD method 4. accurate calculation of different matrix characteristics such as rank (number of non-zero singular values), condition number (ratio of the largest singular value to the smallest one), determinant (absolute value of determinant is equal to the product of singular values). All the things listed in this item do not require calculation of U and V matrices.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Swap Method

CvInvokeSwap Method

Overload List
Name | Description
Swap(Mat, Mat) | Swaps two matrices
Swap(UMat, UMat) | Swaps two matrices
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Swap Method (Mat, Mat)

CvInvokeSwap Method (Mat, Mat)

http://www.emgu.com
Swaps two matrices

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Swap(
    Mat m1,
    Mat m2
)
Public Shared Sub Swap (
    m1 As Mat,
    m2 As Mat
)
public:
static void Swap(
    Mat^ m1,
    Mat^ m2
)
static member Swap :
        m1 : Mat *
        m2 : Mat -> unit

Parameters

m1
Type: Emgu.CVMat
The Mat to be swapped
m2
Type: Emgu.CVMat
The Mat to be swapped
See Also

Reference

CvInvoke Class
Swap Overload
Emgu.CV Namespace


CvInvoke.Swap Method (UMat, UMat)

CvInvokeSwap Method (UMat, UMat)

http://www.emgu.com
Swaps two matrices

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Swap(
    UMat m1,
    UMat m2
)
Public Shared Sub Swap (
    m1 As UMat,
    m2 As UMat
)
public:
static void Swap(
    UMat^ m1,
    UMat^ m2
)
static member Swap :
        m1 : UMat *
        m2 : UMat -> unit

Parameters

m1
Type: Emgu.CVUMat
The UMat to be swapped
m2
Type: Emgu.CVUMat
The UMat to be swapped
See Also

Reference

CvInvoke Class
Swap Overload
Emgu.CV Namespace


CvInvoke.TextureFlattening Method

CvInvokeTextureFlattening Method

By retaining only the gradients at edge locations, before integrating with the Poisson solver, one washes out the texture of the selected region, giving its contents a flat aspect. Here Canny Edge Detector is used.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void TextureFlattening(
    IInputArray src,
    IInputArray mask,
    IOutputArray dst,
    float lowThreshold = 30f,
    float highThreshold = 45f,
    int kernelSize = 3
)
Public Shared Sub TextureFlattening (
    src As IInputArray,
    mask As IInputArray,
    dst As IOutputArray,
    Optional lowThreshold As Single = 30F,
    Optional highThreshold As Single = 45F,
    Optional kernelSize As Integer = 3
)
public:
static void TextureFlattening(
    IInputArray^ src,
    IInputArray^ mask,
    IOutputArray^ dst,
    float lowThreshold = 30f,
    float highThreshold = 45f,
    int kernelSize = 3
)
static member TextureFlattening :
        src : IInputArray *
        mask : IInputArray *
        dst : IOutputArray *
        ?lowThreshold : float32 *
        ?highThreshold : float32 *
        ?kernelSize : int
(* Defaults:
        let _lowThreshold = defaultArg lowThreshold 30f
        let _highThreshold = defaultArg highThreshold 45f
        let _kernelSize = defaultArg kernelSize 3
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit 3-channel image.
mask
Type: Emgu.CVIInputArray
Input 8-bit 1 or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src.
lowThreshold (Optional)
Type: SystemSingle
Range from 0 to 100.
highThreshold (Optional)
Type: SystemSingle
Value > 100
kernelSize (Optional)
Type: SystemInt32
The size of the Sobel kernel to be used.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Threshold Method

CvInvokeThreshold Method

Applies a fixed-level threshold to each array element. The function applies fixed-level thresholding to a multiple-channel array. The function is typically used to get a bi-level (binary) image out of a grayscale image ( compare could be also used for this purpose) or for removing a noise, that is, filtering out pixels with too small or too large values. There are several types of thresholding supported by the function. They are determined by type parameter.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Threshold(
    IInputArray src,
    IOutputArray dst,
    double threshold,
    double maxValue,
    ThresholdType thresholdType
)
Public Shared Function Threshold (
    src As IInputArray,
    dst As IOutputArray,
    threshold As Double,
    maxValue As Double,
    thresholdType As ThresholdType
) As Double
public:
static double Threshold(
    IInputArray^ src,
    IOutputArray^ dst,
    double threshold,
    double maxValue,
    ThresholdType^ thresholdType
)
static member Threshold :
        src : IInputArray *
        dst : IOutputArray *
        threshold : float *
        maxValue : float *
        thresholdType : ThresholdType -> float

Parameters

src
Type: Emgu.CVIInputArray
Input array (multiple-channel, 8-bit or 32-bit floating point).
dst
Type: Emgu.CVIOutputArray
Output array of the same size and type and the same number of channels as src.
threshold
Type: SystemDouble
Threshold value
maxValue
Type: SystemDouble
Maximum value to use with CV_THRESH_BINARY and CV_THRESH_BINARY_INV thresholding types
thresholdType
Type: Emgu.CV.CvEnumThresholdType
Thresholding type

Return Value

Type: Double

[Missing <returns> documentation for "M:Emgu.CV.CvInvoke.Threshold(Emgu.CV.IInputArray,Emgu.CV.IOutputArray,System.Double,System.Double,Emgu.CV.CvEnum.ThresholdType)"]

See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Trace Method

CvInvokeTrace Method

Returns sum of diagonal elements of the matrix mat.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar Trace(
    IInputArray mat
)
Public Shared Function Trace (
    mat As IInputArray
) As MCvScalar
public:
static MCvScalar^ Trace(
    IInputArray^ mat
)
static member Trace :
        mat : IInputArray -> MCvScalar

Parameters

mat
Type: Emgu.CVIInputArray
the matrix

Return Value

Type: MCvScalar
sum of diagonal elements of the matrix src1
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Transform Method

CvInvokeTransform Method

Performs matrix transformation of every element of array src and stores the results in dst Both source and destination arrays should have the same depth and the same size or selected ROI size. transmat and shiftvec should be real floating-point matrices.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Transform(
    IInputArray src,
    IOutputArray dst,
    IInputArray m
)
Public Shared Sub Transform (
    src As IInputArray,
    dst As IOutputArray,
    m As IInputArray
)
public:
static void Transform(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ m
)
static member Transform :
        src : IInputArray *
        dst : IOutputArray *
        m : IInputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The first source array
dst
Type: Emgu.CVIOutputArray
The destination array
m
Type: Emgu.CVIInputArray
transformation 2x2 or 2x3 floating-point matrix.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Transpose Method

CvInvokeTranspose Method

Transposes matrix src1: dst(i,j)=src(j,i) Note that no complex conjugation is done in case of complex matrix. Conjugation should be done separately: look at the sample code in cvXorS for example

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Transpose(
    IInputArray src,
    IOutputArray dst
)
Public Shared Sub Transpose (
    src As IInputArray,
    dst As IOutputArray
)
public:
static void Transpose(
    IInputArray^ src,
    IOutputArray^ dst
)
static member Transpose :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source matrix
dst
Type: Emgu.CVIOutputArray
The destination matrix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.TriangulatePoints Method

CvInvokeTriangulatePoints Method

Reconstructs points by triangulation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void TriangulatePoints(
    IInputArray projMat1,
    IInputArray projMat2,
    IInputArray projPoints1,
    IInputArray projPoints2,
    IOutputArray points4D
)
Public Shared Sub TriangulatePoints (
    projMat1 As IInputArray,
    projMat2 As IInputArray,
    projPoints1 As IInputArray,
    projPoints2 As IInputArray,
    points4D As IOutputArray
)
public:
static void TriangulatePoints(
    IInputArray^ projMat1,
    IInputArray^ projMat2,
    IInputArray^ projPoints1,
    IInputArray^ projPoints2,
    IOutputArray^ points4D
)
static member TriangulatePoints :
        projMat1 : IInputArray *
        projMat2 : IInputArray *
        projPoints1 : IInputArray *
        projPoints2 : IInputArray *
        points4D : IOutputArray -> unit

Parameters

projMat1
Type: Emgu.CVIInputArray
3x4 projection matrix of the first camera.
projMat2
Type: Emgu.CVIInputArray
3x4 projection matrix of the second camera.
projPoints1
Type: Emgu.CVIInputArray
2xN array of feature points in the first image. It can be also a vector of feature points or two-channel matrix of size 1xN or Nx1
projPoints2
Type: Emgu.CVIInputArray
2xN array of corresponding points in the second image. It can be also a vector of feature points or two-channel matrix of size 1xN or Nx1.
points4D
Type: Emgu.CVIOutputArray
4xN array of reconstructed points in homogeneous coordinates.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Undistort Method

CvInvokeUndistort Method

Transforms the image to compensate radial and tangential lens distortion.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Undistort(
    IInputArray src,
    IOutputArray dst,
    IInputArray cameraMatrix,
    IInputArray distortionCoeffs,
    IInputArray newCameraMatrix = null
)
Public Shared Sub Undistort (
    src As IInputArray,
    dst As IOutputArray,
    cameraMatrix As IInputArray,
    distortionCoeffs As IInputArray,
    Optional newCameraMatrix As IInputArray = Nothing
)
public:
static void Undistort(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ cameraMatrix,
    IInputArray^ distortionCoeffs,
    IInputArray^ newCameraMatrix = nullptr
)
static member Undistort :
        src : IInputArray *
        dst : IOutputArray *
        cameraMatrix : IInputArray *
        distortionCoeffs : IInputArray *
        ?newCameraMatrix : IInputArray
(* Defaults:
        let _newCameraMatrix = defaultArg newCameraMatrix null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The input (distorted) image
dst
Type: Emgu.CVIOutputArray
The output (corrected) image
cameraMatrix
Type: Emgu.CVIInputArray
The camera matrix (A) [fx 0 cx; 0 fy cy; 0 0 1].
distortionCoeffs
Type: Emgu.CVIInputArray
The vector of distortion coefficients, 4x1 or 1x4 [k1, k2, p1, p2].
newCameraMatrix (Optional)
Type: Emgu.CVIInputArray
Camera matrix of the distorted image. By default it is the same as cameraMatrix, but you may additionally scale and shift the result by using some different matrix
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.UndistortPoints Method

CvInvokeUndistortPoints Method

Similar to cvInitUndistortRectifyMap and is opposite to it at the same time. The functions are similar in that they both are used to correct lens distortion and to perform the optional perspective (rectification) transformation. They are opposite because the function cvInitUndistortRectifyMap does actually perform the reverse transformation in order to initialize the maps properly, while this function does the forward transformation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void UndistortPoints(
    IInputArray src,
    IOutputArray dst,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IInputArray R = null,
    IInputArray P = null
)
Public Shared Sub UndistortPoints (
    src As IInputArray,
    dst As IOutputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    Optional R As IInputArray = Nothing,
    Optional P As IInputArray = Nothing
)
public:
static void UndistortPoints(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IInputArray^ R = nullptr,
    IInputArray^ P = nullptr
)
static member UndistortPoints :
        src : IInputArray *
        dst : IOutputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        ?R : IInputArray *
        ?P : IInputArray
(* Defaults:
        let _R = defaultArg R null
        let _P = defaultArg P null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The observed point coordinates
dst
Type: Emgu.CVIOutputArray
The ideal point coordinates, after undistortion and reverse perspective transformation.
cameraMatrix
Type: Emgu.CVIInputArray
The camera matrix A=[fx 0 cx; 0 fy cy; 0 0 1]
distCoeffs
Type: Emgu.CVIInputArray
The vector of distortion coefficients, 4x1, 1x4, 5x1 or 1x5.
R (Optional)
Type: Emgu.CVIInputArray
The rectification transformation in object space (3x3 matrix). R1 or R2, computed by cvStereoRectify can be passed here. If the parameter is IntPtr.Zero, the identity matrix is used.
P (Optional)
Type: Emgu.CVIInputArray
The new camera matrix (3x3) or the new projection matrix (3x4). P1 or P2, computed by cvStereoRectify can be passed here. If the parameter is IntPtr.Zero, the identity matrix is used.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.UpdateMotionHistory Method

CvInvokeUpdateMotionHistory Method

Updates the motion history image as following:
mhi(x,y)=timestamp  if silhouette(x,y)!=0
        0          if silhouette(x,y)=0 and mhi(x,y)<timestamp-duration
        mhi(x,y)   otherwise
That is, MHI pixels where motion occurs are set to the current timestamp, while the pixels where motion happened far ago are cleared.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void UpdateMotionHistory(
    IInputArray silhouette,
    IInputOutputArray mhi,
    double timestamp,
    double duration
)
Public Shared Sub UpdateMotionHistory (
    silhouette As IInputArray,
    mhi As IInputOutputArray,
    timestamp As Double,
    duration As Double
)
public:
static void UpdateMotionHistory(
    IInputArray^ silhouette,
    IInputOutputArray^ mhi,
    double timestamp,
    double duration
)
static member UpdateMotionHistory :
        silhouette : IInputArray *
        mhi : IInputOutputArray *
        timestamp : float *
        duration : float -> unit

Parameters

silhouette
Type: Emgu.CVIInputArray
Silhouette mask that has non-zero pixels where the motion occurs.
mhi
Type: Emgu.CVIInputOutputArray
Motion history image, that is updated by the function (single-channel, 32-bit floating-point)
timestamp
Type: SystemDouble
Current time in milliseconds or other units.
duration
Type: SystemDouble
Maximal duration of motion track in the same units as timestamp.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.VConcat Method

CvInvokeVConcat Method

Vertically concatenate two images

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void VConcat(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst
)
Public Shared Sub VConcat (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray
)
public:
static void VConcat(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst
)
static member VConcat :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray -> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first image
src2
Type: Emgu.CVIInputArray
The second image
dst
Type: Emgu.CVIOutputArray
The result image
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.WaitKey Method

CvInvokeWaitKey Method

Waits for key event infinitely (delay <= 0) or for "delay" milliseconds.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int WaitKey(
    int delay = 0
)
Public Shared Function WaitKey (
    Optional delay As Integer = 0
) As Integer
public:
static int WaitKey(
    int delay = 0
)
static member WaitKey :
        ?delay : int
(* Defaults:
        let _delay = defaultArg delay 0
*)
-> int

Parameters

delay (Optional)
Type: SystemInt32
Delay in milliseconds.

Return Value

Type: Int32
The code of the pressed key or -1 if no key were pressed until the specified timeout has elapsed
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.WarpAffine Method

CvInvokeWarpAffine Method

Applies an affine transformation to an image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void WarpAffine(
    IInputArray src,
    IOutputArray dst,
    IInputArray mapMatrix,
    Size dsize,
    Inter interpMethod = 1,
    Warp warpMethod = 0,
    BorderType borderMode = 0,
    MCvScalar borderValue = null
)
Public Shared Sub WarpAffine (
    src As IInputArray,
    dst As IOutputArray,
    mapMatrix As IInputArray,
    dsize As Size,
    Optional interpMethod As Inter = 1,
    Optional warpMethod As Warp = 0,
    Optional borderMode As BorderType = 0,
    Optional borderValue As MCvScalar = Nothing
)
public:
static void WarpAffine(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ mapMatrix,
    Size^ dsize,
    Inter^ interpMethod = 1,
    Warp^ warpMethod = 0,
    BorderType^ borderMode = 0,
    MCvScalar^ borderValue = nullptr
)
static member WarpAffine :
        src : IInputArray *
        dst : IOutputArray *
        mapMatrix : IInputArray *
        dsize : Size *
        ?interpMethod : Inter *
        ?warpMethod : Warp *
        ?borderMode : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _interpMethod = defaultArg interpMethod 1
        let _warpMethod = defaultArg warpMethod 0
        let _borderMode = defaultArg borderMode 0
        let _borderValue = defaultArg borderValue null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Destination image
mapMatrix
Type: Emgu.CVIInputArray
2x3 transformation matrix
dsize
Type: System.DrawingSize
Size of the output image.
interpMethod (Optional)
Type: Emgu.CV.CvEnumInter
Interpolation method
warpMethod (Optional)
Type: Emgu.CV.CvEnumWarp
Warp method
borderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
A value used to fill outliers
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.WarpPerspective Method

CvInvokeWarpPerspective Method

Applies a perspective transformation to an image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void WarpPerspective(
    IInputArray src,
    IOutputArray dst,
    IInputArray mapMatrix,
    Size dsize,
    Inter interpolationType = 1,
    Warp warpType = 0,
    BorderType borderMode = 0,
    MCvScalar borderValue = null
)
Public Shared Sub WarpPerspective (
    src As IInputArray,
    dst As IOutputArray,
    mapMatrix As IInputArray,
    dsize As Size,
    Optional interpolationType As Inter = 1,
    Optional warpType As Warp = 0,
    Optional borderMode As BorderType = 0,
    Optional borderValue As MCvScalar = Nothing
)
public:
static void WarpPerspective(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ mapMatrix,
    Size^ dsize,
    Inter^ interpolationType = 1,
    Warp^ warpType = 0,
    BorderType^ borderMode = 0,
    MCvScalar^ borderValue = nullptr
)
static member WarpPerspective :
        src : IInputArray *
        dst : IOutputArray *
        mapMatrix : IInputArray *
        dsize : Size *
        ?interpolationType : Inter *
        ?warpType : Warp *
        ?borderMode : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _interpolationType = defaultArg interpolationType 1
        let _warpType = defaultArg warpType 0
        let _borderMode = defaultArg borderMode 0
        let _borderValue = defaultArg borderValue null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Destination image
mapMatrix
Type: Emgu.CVIInputArray
3x3 transformation matrix
dsize
Type: System.DrawingSize
Size of the output image
interpolationType (Optional)
Type: Emgu.CV.CvEnumInter
Interpolation method
warpType (Optional)
Type: Emgu.CV.CvEnumWarp
Warp method
borderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
value used in case of a constant border
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.Watershed Method

CvInvokeWatershed Method

Implements one of the variants of watershed, non-parametric marker-based segmentation algorithm, described in [Meyer92] Before passing the image to the function, user has to outline roughly the desired regions in the image markers with positive (>0) indices, i.e. every region is represented as one or more connected components with the pixel values 1, 2, 3 etc. Those components will be "seeds" of the future image regions. All the other pixels in markers, which relation to the outlined regions is not known and should be defined by the algorithm, should be set to 0's. On the output of the function, each pixel in markers is set to one of values of the "seed" components, or to -1 at boundaries between the regions.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Watershed(
    IInputArray image,
    IInputOutputArray markers
)
Public Shared Sub Watershed (
    image As IInputArray,
    markers As IInputOutputArray
)
public:
static void Watershed(
    IInputArray^ image,
    IInputOutputArray^ markers
)
static member Watershed :
        image : IInputArray *
        markers : IInputOutputArray -> unit

Parameters

image
Type: Emgu.CVIInputArray
The input 8-bit 3-channel image
markers
Type: Emgu.CVIInputOutputArray
The input/output Int32 depth single-channel image (map) of markers.
Remarks
Note, that it is not necessary that every two neighbor connected components are separated by a watershed boundary (-1's pixels), for example, in case when such tangent components exist in the initial marker image.
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.WriteCloud Method

CvInvokeWriteCloud Method

Write point cloud to file

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void WriteCloud(
    string file,
    IInputArray cloud,
    IInputArray colors = null,
    IInputArray normals = null
)
Public Shared Sub WriteCloud (
    file As String,
    cloud As IInputArray,
    Optional colors As IInputArray = Nothing,
    Optional normals As IInputArray = Nothing
)
public:
static void WriteCloud(
    String^ file,
    IInputArray^ cloud,
    IInputArray^ colors = nullptr,
    IInputArray^ normals = nullptr
)
static member WriteCloud :
        file : string *
        cloud : IInputArray *
        ?colors : IInputArray *
        ?normals : IInputArray
(* Defaults:
        let _colors = defaultArg colors null
        let _normals = defaultArg normals null
*)
-> unit

Parameters

file
Type: SystemString
The point cloud file name
cloud
Type: Emgu.CVIInputArray
The point cloud
colors (Optional)
Type: Emgu.CVIInputArray
The color
normals (Optional)
Type: Emgu.CVIInputArray
The normals
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke Fields

The CvInvoke type exposes the following members.

Fields
Name | Description
BoolMarshalType | Represent a bool value in C++
BoolToIntMarshalType | Represent a int value in C++
CvCallingConvention | Opencv's calling convention
CvErrorHandlerIgnoreError | An error handler which will ignore any error and continue
CvErrorHandlerThrowException | The default Exception callback to handle Error thrown by OpenCV
ExternCudaLibrary | The file name of the cvextern library
ExternLibrary | The file name of the cvextern library
MorphologyDefaultBorderValue | The default morphology value.
OpencvFFMpegLibrary | The file name of the opencv_ffmpeg library
OpenCVModuleList | The List of the opencv modules
StringMarshalType | string marshaling type
Top
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BoolMarshalType Field

CvInvokeBoolMarshalType Field

Represent a bool value in C++

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const UnmanagedType BoolMarshalType = 4
Public Const BoolMarshalType As UnmanagedType = 4
public:
literal UnmanagedType^ BoolMarshalType = 4
static val mutable BoolMarshalType: UnmanagedType

Field Value

Type: UnmanagedType
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.BoolToIntMarshalType Field

CvInvokeBoolToIntMarshalType Field

Represent a int value in C++

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const UnmanagedType BoolToIntMarshalType = 2
Public Const BoolToIntMarshalType As UnmanagedType = 2
public:
literal UnmanagedType^ BoolToIntMarshalType = 2
static val mutable BoolToIntMarshalType: UnmanagedType

Field Value

Type: UnmanagedType
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CvCallingConvention Field

CvInvokeCvCallingConvention Field

Opencv's calling convention

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CallingConvention CvCallingConvention = 2
Public Const CvCallingConvention As CallingConvention = 2
public:
literal CallingConvention^ CvCallingConvention = 2
static val mutable CvCallingConvention: CallingConvention

Field Value

Type: CallingConvention
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CvErrorHandlerIgnoreError Field

CvInvokeCvErrorHandlerIgnoreError Field

An error handler which will ignore any error and continue

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly CvInvokeCvErrorCallback CvErrorHandlerIgnoreError
Public Shared ReadOnly CvErrorHandlerIgnoreError As CvInvokeCvErrorCallback
public:
static initonly CvInvokeCvErrorCallback^ CvErrorHandlerIgnoreError
static val CvErrorHandlerIgnoreError: CvInvokeCvErrorCallback

Field Value

Type: CvInvokeCvErrorCallback
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CvErrorHandlerThrowException Field

CvInvokeCvErrorHandlerThrowException Field

The default Exception callback to handle Error thrown by OpenCV

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly CvInvokeCvErrorCallback CvErrorHandlerThrowException
Public Shared ReadOnly CvErrorHandlerThrowException As CvInvokeCvErrorCallback
public:
static initonly CvInvokeCvErrorCallback^ CvErrorHandlerThrowException
static val CvErrorHandlerThrowException: CvInvokeCvErrorCallback

Field Value

Type: CvInvokeCvErrorCallback
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ExternCudaLibrary Field

CvInvokeExternCudaLibrary Field

The file name of the cvextern library

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const string ExternCudaLibrary = "cvextern"
Public Const ExternCudaLibrary As String = "cvextern"
public:
literal String^ ExternCudaLibrary = "cvextern"
static val mutable ExternCudaLibrary: string

Field Value

Type: String
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.ExternLibrary Field

CvInvokeExternLibrary Field

The file name of the cvextern library

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const string ExternLibrary = "cvextern"
Public Const ExternLibrary As String = "cvextern"
public:
literal String^ ExternLibrary = "cvextern"
static val mutable ExternLibrary: string

Field Value

Type: String
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.MorphologyDefaultBorderValue Field

CvInvokeMorphologyDefaultBorderValue Field

The default morphology value.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar MorphologyDefaultBorderValue
Public Shared MorphologyDefaultBorderValue As MCvScalar
public:
static MCvScalar^ MorphologyDefaultBorderValue
static val mutable MorphologyDefaultBorderValue: MCvScalar

Field Value

Type: MCvScalar
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.OpencvFFMpegLibrary Field

CvInvokeOpencvFFMpegLibrary Field

The file name of the opencv_ffmpeg library

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const string OpencvFFMpegLibrary = "opencv_videoio_ffmpeg420_64"
Public Const OpencvFFMpegLibrary As String = "opencv_videoio_ffmpeg420_64"
public:
literal String^ OpencvFFMpegLibrary = "opencv_videoio_ffmpeg420_64"
static val mutable OpencvFFMpegLibrary: string

Field Value

Type: String
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.OpenCVModuleList Field

CvInvokeOpenCVModuleList Field

The List of the opencv modules

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static List<string> OpenCVModuleList
Public Shared OpenCVModuleList As List(Of String)
public:
static List<String^>^ OpenCVModuleList
static val mutable OpenCVModuleList: List<string>

Field Value

Type: List String
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.StringMarshalType Field

CvInvokeStringMarshalType Field

string marshaling type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const UnmanagedType StringMarshalType = 20
Public Const StringMarshalType As UnmanagedType = 20
public:
literal UnmanagedType^ StringMarshalType = 20
static val mutable StringMarshalType: UnmanagedType

Field Value

Type: UnmanagedType
See Also

Reference

CvInvoke Class
Emgu.CV Namespace


CvInvoke.CvErrorCallback Class

CvInvokeCvErrorCallback Class

Define an error callback that can be registered using cvRedirectError function
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Emgu.CVCvInvokeCvErrorCallback

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CvErrorCallback : MulticastDelegate
Public NotInheritable Class CvErrorCallback
    Inherits MulticastDelegate
public ref class CvErrorCallback sealed : public MulticastDelegate
[<SealedAttribute>]
type CvErrorCallback =
    class
        inherit MulticastDelegate
    end

Return Value

Type:

The CvInvokeCvErrorCallback type exposes the following members.

Constructors
 | Name | Description
Public method | CvInvokeCvErrorCallback | Initializes a new instance of the CvInvokeCvErrorCallback class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate.)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate.)
Protected method | CombineImpl | Combines this Delegate with the specified Delegate to form a new delegate. (Inherited from MulticastDelegate.)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate.)
Protected method | DynamicInvokeImpl | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate.)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate.)
Protected method | GetMethodImpl | Returns a static method represented by the current MulticastDelegate. (Inherited from MulticastDelegate.)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RemoveImpl | Removes an element from the invocation list of this MulticastDelegate that is equal to the specified delegate. (Inherited from MulticastDelegate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.CV Namespace


CvInvoke.CvErrorCallback Constructor

CvInvokeCvErrorCallback Constructor

Initializes a new instance of the CvInvokeCvErrorCallback class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvErrorCallback(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)
public:
CvErrorCallback(
    Object^ object,
    IntPtr method
)
new :
        object : Object *
        method : IntPtr -> CvErrorCallback

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

CvInvokeCvErrorCallback Class
Emgu.CV Namespace


CvErrorCallback Properties

The CvInvokeCvErrorCallback type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate.)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate.)
Top
See Also

Reference

CvInvokeCvErrorCallback Class
Emgu.CV Namespace


CvErrorCallback Methods

The CvInvokeCvErrorCallback type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate.)
Protected method | CombineImpl | Combines this Delegate with the specified Delegate to form a new delegate. (Inherited from MulticastDelegate.)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate.)
Protected method | DynamicInvokeImpl | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate.)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate.)
Protected method | GetMethodImpl | Returns a static method represented by the current MulticastDelegate. (Inherited from MulticastDelegate.)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RemoveImpl | Removes an element from the invocation list of this MulticastDelegate that is equal to the specified delegate. (Inherited from MulticastDelegate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CvInvokeCvErrorCallback Class
Emgu.CV Namespace


CvInvoke.CvErrorCallback.BeginInvoke Method

CvInvokeCvErrorCallbackBeginInvoke Method

[Missing <summary> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual IAsyncResult BeginInvoke(
    int status,
    IntPtr funcName,
    IntPtr errMsg,
    IntPtr fileName,
    int line,
    IntPtr userData,
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    status As Integer,
    funcName As IntPtr,
    errMsg As IntPtr,
    fileName As IntPtr,
    line As Integer,
    userData As IntPtr,
    callback As AsyncCallback,
    object As Object
) As IAsyncResult
public:
virtual IAsyncResult^ BeginInvoke(
    int status,
    IntPtr funcName,
    IntPtr errMsg,
    IntPtr fileName,
    int line,
    IntPtr userData,
    AsyncCallback^ callback,
    Object^ object
)
abstract BeginInvoke :
        status : int *
        funcName : IntPtr *
        errMsg : IntPtr *
        fileName : IntPtr *
        line : int *
        userData : IntPtr *
        callback : AsyncCallback *
        object : Object -> IAsyncResult
override BeginInvoke :
        status : int *
        funcName : IntPtr *
        errMsg : IntPtr *
        fileName : IntPtr *
        line : int *
        userData : IntPtr *
        callback : AsyncCallback *
        object : Object -> IAsyncResult

Parameters

status
Type: SystemInt32

[Missing <param name="status"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

funcName
Type: SystemIntPtr

[Missing <param name="funcName"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

errMsg
Type: SystemIntPtr

[Missing <param name="errMsg"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

fileName
Type: SystemIntPtr

[Missing <param name="fileName"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

line
Type: SystemInt32

[Missing <param name="line"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

userData
Type: SystemIntPtr

[Missing <param name="userData"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.BeginInvoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr,System.AsyncCallback,System.Object)"]

See Also

Reference

CvInvokeCvErrorCallback Class
Emgu.CV Namespace


CvInvoke.CvErrorCallback.EndInvoke Method

CvInvokeCvErrorCallbackEndInvoke Method

[Missing <summary> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.EndInvoke(System.IAsyncResult)"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual int EndInvoke(
    IAsyncResult result
)
Public Overridable Function EndInvoke (
    result As IAsyncResult
) As Integer
public:
virtual int EndInvoke(
    IAsyncResult^ result
)
abstract EndInvoke :
        result : IAsyncResult -> int
override EndInvoke :
        result : IAsyncResult -> int

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.EndInvoke(System.IAsyncResult)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.EndInvoke(System.IAsyncResult)"]

See Also

Reference

CvInvokeCvErrorCallback Class
Emgu.CV Namespace


CvInvoke.CvErrorCallback.Invoke Method

CvInvokeCvErrorCallbackInvoke Method

[Missing <summary> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual int Invoke(
    int status,
    IntPtr funcName,
    IntPtr errMsg,
    IntPtr fileName,
    int line,
    IntPtr userData
)
Public Overridable Function Invoke (
    status As Integer,
    funcName As IntPtr,
    errMsg As IntPtr,
    fileName As IntPtr,
    line As Integer,
    userData As IntPtr
) As Integer
public:
virtual int Invoke(
    int status,
    IntPtr funcName,
    IntPtr errMsg,
    IntPtr fileName,
    int line,
    IntPtr userData
)
abstract Invoke :
        status : int *
        funcName : IntPtr *
        errMsg : IntPtr *
        fileName : IntPtr *
        line : int *
        userData : IntPtr -> int
override Invoke :
        status : int *
        funcName : IntPtr *
        errMsg : IntPtr *
        fileName : IntPtr *
        line : int *
        userData : IntPtr -> int

Parameters

status
Type: SystemInt32

[Missing <param name="status"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

funcName
Type: SystemIntPtr

[Missing <param name="funcName"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

errMsg
Type: SystemIntPtr

[Missing <param name="errMsg"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

fileName
Type: SystemIntPtr

[Missing <param name="fileName"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

line
Type: SystemInt32

[Missing <param name="line"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

userData
Type: SystemIntPtr

[Missing <param name="userData"/> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Emgu.CV.CvInvoke.CvErrorCallback.Invoke(System.Int32,System.IntPtr,System.IntPtr,System.IntPtr,System.Int32,System.IntPtr)"]

See Also

Reference

CvInvokeCvErrorCallback Class
Emgu.CV Namespace


CvString Class

Wrapper for cv::String. This class support UTF-8 chars.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvString

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CvString : UnmanagedObject
Public Class CvString
    Inherits UnmanagedObject
public ref class CvString : public UnmanagedObject
type CvString =
    class
        inherit UnmanagedObject
    end

The CvString type exposes the following members.

Constructors
 | Name | Description
Public method | CvString | Create an empty CvString
Public method | CvString(String) | Create a CvString from System.String
Top
Properties
 | Name | Description
Public property | Length | Gets the length of the string
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Get the string representation of the CvString (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


CvString Constructor

Overload List
 | Name | Description
Public method | CvString | Create an empty CvString
Public method | CvString(String) | Create a CvString from System.String
Top
See Also

Reference

CvString Class
Emgu.CV Namespace


CvString Constructor

Create an empty CvString

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvString()
Public Sub New
public:
CvString()
new : unit -> CvString
See Also

Reference

CvString Class
CvString Overload
Emgu.CV Namespace


CvString Constructor (String)

Create a CvString from System.String

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvString(
    string s
)
Public Sub New (
    s As String
)
public:
CvString(
    String^ s
)
new :
        s : string -> CvString

Parameters

s
Type: SystemString
The System.String object to be converted to CvString
See Also

Reference

CvString Class
CvString Overload
Emgu.CV Namespace


CvString Properties

The CvString type exposes the following members.

Properties
 | Name | Description
Public property | Length | Gets the length of the string
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CvString Class
Emgu.CV Namespace


CvString.Length Property

CvStringLength Property

Gets the length of the string

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
member Length : int with get

Property Value

Type: Int32
The length of the string
See Also

Reference

CvString Class
Emgu.CV Namespace


CvString Methods

The CvString type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Get the string representation of the CvString (Overrides ObjectToString.)
Top
See Also

Reference

CvString Class
Emgu.CV Namespace


CvString.DisposeObject Method

CvStringDisposeObject Method

Release all the unmanaged resource associated with this object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CvString Class
Emgu.CV Namespace


CvString.ToString Method

CvStringToString Method

Get the string representation of the CvString

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of the CvString
See Also

Reference

CvString Class
Emgu.CV Namespace


CvString Fields

The CvString type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CvString Class
Emgu.CV Namespace


DenseHistogram Class

A Uniform Multi-dimensional Dense Histogram
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMatDataAllocator
Emgu.CVMat
Emgu.CVDenseHistogram

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DenseHistogram : Mat
Public Class DenseHistogram
    Inherits Mat
public ref class DenseHistogram : public Mat
type DenseHistogram =
    class
        inherit Mat
    end

The DenseHistogram type exposes the following members.

Constructors
 | Name | Description
Public method | DenseHistogram(Int32, RangeF) | Creates a uniform 1-D histogram of the specified size
Public method | DenseHistogram(Int32, RangeF) | Creates a uniform multi-dimension histogram of the specified size
Top
Properties
 | Name | Description
Public property | BinDimension | Get the size of the bin dimensions
Public property | Cols | The number of columns (Inherited from Mat.)
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | DataPointer | Pointer to the beginning of the raw data (Inherited from Mat.)
Public property | Depth | Depth type (Inherited from Mat.)
Public property | Dims | The matrix dimensionality (Inherited from Mat.)
Public property | ElementSize | The size of the elements in this matrix (Inherited from Mat.)
Public property | Height | Get the height of the mat. (Inherited from Mat.)
Public property | IsContinuous | True if the data is continues (Inherited from Mat.)
Public property | IsEmpty | True if the Mat is empty (Inherited from Mat.)
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix (Inherited from Mat.)
Public property | NumberOfChannels | Number of channels (Inherited from Mat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Ranges | Get the ranges of this histogram
Public property | Rows | The number of rows (Inherited from Mat.)
Public property | Size | The size of this matrix (Inherited from Mat.)
Public property | SizeOfDimension | Get an array of the size of the dimensions. e.g. if the mat is 9x10x11, the array of {9, 10, 11} will be returned. (Inherited from Mat.)
Public property | Step | Step (Inherited from Mat.)
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image) (Inherited from Mat.)
Public property | Width | Get the width of the mat (Inherited from Mat.)
Top
Methods
 | Name | Description
Public method | BackProjectTDepth(ImageGray, TDepth) | Backproject the histogram into a gray scale image
Public method | BackProjectTDepth(MatrixTDepth) | Backproject the histogram into a matrix
Public method | CalculateTDepth(ImageGray, TDepth, Boolean, ImageGray, Byte) | Project the images to the histogram bins
Public method | CalculateTDepth(MatrixTDepth, Boolean, MatrixByte) | Project the matrices to the histogram bins
Public method | Clear | Clear this histogram
Public method | Clone | Make a clone of the current Mat (Inherited from Mat.)
Public method | Col | Creates a matrix header for the specified matrix column. (Inherited from Mat.)
Public method | ConvertTo | Converts an array to another data type with optional scaling. (Inherited from Mat.)
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this cv::Mat to an output array (Inherited from Mat.)
Public method | CopyToT(T) | Copy data from this Mat to the managed array (Inherited from Mat.)
Public method | Create | Allocates new array data if needed. (Inherited from Mat.)
Public method | Cross | Computes a cross-product of two 3-element vectors. (Inherited from Mat.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from Mat.)
Public method | Diag | Extracts a diagonal from a matrix. The method makes a new header for the specified matrix diagonal. The new matrix is represented as a single-column matrix. Similarly to Mat::row and Mat::col, this is an O(1) operation. (Inherited from Mat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Inherited from Mat.)
Public method | Dot | Computes a dot-product of two vectors. (Inherited from Mat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Mat) | Compares two Mats and check if they are equal (Inherited from Mat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBinValues | Gets the bin values.
Public method | GetData | Get a copy of the data values as an array (Inherited from Mat.)
Public method | GetDataPointer | Get a pointer to the raw data given the specific index (Inherited from Mat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from Mat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from Mat.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from Mat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from Mat.)
Public method | GetRawData | Gets the binary data from the specific indices. (Inherited from Mat.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Convert this Mat to UMat (Inherited from Mat.)
Public method | GetValueRange | Get the minimum and maximum value across all channels of the mat (Inherited from Mat.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from Mat.)
Public method | PopBack | The method removes one or more rows from the bottom of the matrix (Inherited from Mat.)
Public method | PushBack | Adds elements to the bottom of the matrix (Inherited from Mat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data. (Inherited from Mat.)
Public method | Row | Creates a matrix header for the specified matrix row. (Inherited from Mat.)
Public method | Save | Save this image to the specific file. (Inherited from Mat.)
Public method | SetTo(IInputArray, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetTo(MCvScalar, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetToT(T) | Copy data from managed array to this Mat (Inherited from Mat.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from Mat.)
Public method | T | Transposes a matrix. (Inherited from Mat.)
Public method | ToImageTColor, TDepth | Convert this Mat to Image (Inherited from Mat.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


DenseHistogram Constructor

Overload List
 | Name | Description
Public method | DenseHistogram(Int32, RangeF) | Creates a uniform 1-D histogram of the specified size
Public method | DenseHistogram(Int32, RangeF) | Creates a uniform multi-dimension histogram of the specified size
Top
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram Constructor (Int32, RangeF)

Creates a uniform 1-D histogram of the specified size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DenseHistogram(
    int binSize,
    RangeF range
)
Public Sub New (
    binSize As Integer,
    range As RangeF
)
public:
DenseHistogram(
    int binSize,
    RangeF^ range
)
new :
        binSize : int *
        range : RangeF -> DenseHistogram

Parameters

binSize
Type: SystemInt32
The number of bins in this 1-D histogram.
range
Type: Emgu.CV.StructureRangeF
The upper and lower boundary of the bin
See Also

Reference

DenseHistogram Class
DenseHistogram Overload
Emgu.CV Namespace


DenseHistogram Constructor (Int32[], RangeF[])

DenseHistogram Constructor (Int32, RangeF)

http://www.emgu.com
Creates a uniform multi-dimension histogram of the specified size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DenseHistogram(
    int[] binSizes,
    RangeF[] ranges
)
Public Sub New (
    binSizes As Integer(),
    ranges As RangeF()
)
public:
DenseHistogram(
    array<int>^ binSizes,
    array<RangeF^>^ ranges
)
new :
        binSizes : int[] *
        ranges : RangeF[] -> DenseHistogram

Parameters

binSizes
Type: SystemInt32
The length of this array is the dimension of the histogram. The values of the array contains the number of bins in each dimension. The total number of bins eaquals the multiplication of all numbers in the array
ranges
Type: Emgu.CV.StructureRangeF
the upper and lower boundaries of the bins
See Also

Reference

DenseHistogram Class
DenseHistogram Overload
Emgu.CV Namespace


DenseHistogram Properties

The DenseHistogram type exposes the following members.

Properties
 | Name | Description
Public property | BinDimension | Get the size of the bin dimensions
Public property | Cols | The number of columns (Inherited from Mat.)
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | DataPointer | Pointer to the beginning of the raw data (Inherited from Mat.)
Public property | Depth | Depth type (Inherited from Mat.)
Public property | Dims | The matrix dimensionality (Inherited from Mat.)
Public property | ElementSize | The size of the elements in this matrix (Inherited from Mat.)
Public property | Height | Get the height of the mat. (Inherited from Mat.)
Public property | IsContinuous | True if the data is continues (Inherited from Mat.)
Public property | IsEmpty | True if the Mat is empty (Inherited from Mat.)
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix (Inherited from Mat.)
Public property | NumberOfChannels | Number of channels (Inherited from Mat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Ranges | Get the ranges of this histogram
Public property | Rows | The number of rows (Inherited from Mat.)
Public property | Size | The size of this matrix (Inherited from Mat.)
Public property | SizeOfDimension | Get an array of the size of the dimensions. e.g. if the mat is 9x10x11, the array of {9, 10, 11} will be returned. (Inherited from Mat.)
Public property | Step | Step (Inherited from Mat.)
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image) (Inherited from Mat.)
Public property | Width | Get the width of the mat (Inherited from Mat.)
Top
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram.BinDimension Property

DenseHistogramBinDimension Property

Get the size of the bin dimensions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] BinDimension { get; }
Public ReadOnly Property BinDimension As Integer()
    Get
public:
property array<int>^ BinDimension {
    array<int>^ get ();
}
member BinDimension : int[] with get

Property Value

Type: Int32
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram.Ranges Property

DenseHistogramRanges Property

Get the ranges of this histogram

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RangeF[] Ranges { get; }
Public ReadOnly Property Ranges As RangeF()
    Get
public:
property array<RangeF^>^ Ranges {
    array<RangeF^>^ get ();
}
member Ranges : RangeF[] with get

Property Value

Type: RangeF
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram Methods

The DenseHistogram type exposes the following members.

Methods
 | Name | Description
Public method | BackProjectTDepth(ImageGray, TDepth) | Backproject the histogram into a gray scale image
Public method | BackProjectTDepth(MatrixTDepth) | Backproject the histogram into a matrix
Public method | CalculateTDepth(ImageGray, TDepth, Boolean, ImageGray, Byte) | Project the images to the histogram bins
Public method | CalculateTDepth(MatrixTDepth, Boolean, MatrixByte) | Project the matrices to the histogram bins
Public method | Clear | Clear this histogram
Public method | Clone | Make a clone of the current Mat (Inherited from Mat.)
Public method | Col | Creates a matrix header for the specified matrix column. (Inherited from Mat.)
Public method | ConvertTo | Converts an array to another data type with optional scaling. (Inherited from Mat.)
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this cv::Mat to an output array (Inherited from Mat.)
Public method | CopyToT(T) | Copy data from this Mat to the managed array (Inherited from Mat.)
Public method | Create | Allocates new array data if needed. (Inherited from Mat.)
Public method | Cross | Computes a cross-product of two 3-element vectors. (Inherited from Mat.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from Mat.)
Public method | Diag | Extracts a diagonal from a matrix. The method makes a new header for the specified matrix diagonal. The new matrix is represented as a single-column matrix. Similarly to Mat::row and Mat::col, this is an O(1) operation. (Inherited from Mat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Inherited from Mat.)
Public method | Dot | Computes a dot-product of two vectors. (Inherited from Mat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Mat) | Compares two Mats and check if they are equal (Inherited from Mat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBinValues | Gets the bin values.
Public method | GetData | Get a copy of the data values as an array (Inherited from Mat.)
Public method | GetDataPointer | Get a pointer to the raw data given the specific index (Inherited from Mat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from Mat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from Mat.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from Mat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from Mat.)
Public method | GetRawData | Gets the binary data from the specific indices. (Inherited from Mat.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Convert this Mat to UMat (Inherited from Mat.)
Public method | GetValueRange | Get the minimum and maximum value across all channels of the mat (Inherited from Mat.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from Mat.)
Public method | PopBack | The method removes one or more rows from the bottom of the matrix (Inherited from Mat.)
Public method | PushBack | Adds elements to the bottom of the matrix (Inherited from Mat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data. (Inherited from Mat.)
Public method | Row | Creates a matrix header for the specified matrix row. (Inherited from Mat.)
Public method | Save | Save this image to the specific file. (Inherited from Mat.)
Public method | SetTo(IInputArray, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetTo(MCvScalar, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetToT(T) | Copy data from managed array to this Mat (Inherited from Mat.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from Mat.)
Public method | T | Transposes a matrix. (Inherited from Mat.)
Public method | ToImageTColor, TDepth | Convert this Mat to Image (Inherited from Mat.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram.BackProject Method

DenseHistogramBackProject Method

Overload List
 | Name | Description
Public method | BackProjectTDepth(ImageGray, TDepth) | Backproject the histogram into a gray scale image
Public method | BackProjectTDepth(MatrixTDepth) | Backproject the histogram into a matrix
Top
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram.BackProject(TDepth) Method (Image(Gray, TDepth)[])

DenseHistogramBackProjectTDepth Method (ImageGray, TDepth)

http://www.emgu.com
Backproject the histogram into a gray scale image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, TDepth> BackProject<TDepth>(
    Image<Gray, TDepth>[] srcs
)
where TDepth : new()

Public Function BackProject(Of TDepth As New) (
    srcs As Image(Of Gray, TDepth)()
) As Image(Of Gray, TDepth)
public:
generic<typename TDepth>
where TDepth : gcnew()
Image<Gray^, TDepth>^ BackProject(
    array<Image<Gray^, TDepth>^>^ srcs
)
member BackProject :
        srcs : Image<Gray, 'TDepth>[] -> Image<Gray, 'TDepth>  when 'TDepth : new()

Parameters

srcs
Type: Emgu.CVImage Gray, TDepth
Source images, all are of the same size and type

Type Parameters

TDepth
The type of depth of the image

Return Value

Type: Image Gray, TDepth
Destination back projection image of the same type as the source images
See Also

Reference

DenseHistogram Class
BackProject Overload
Emgu.CV Namespace


DenseHistogram.BackProject(TDepth) Method (Matrix(TDepth)[])

DenseHistogramBackProjectTDepth Method (MatrixTDepth)

http://www.emgu.com
Backproject the histogram into a matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> BackProject<TDepth>(
    Matrix<TDepth>[] srcs
)
where TDepth : new()

Public Function BackProject(Of TDepth As New) (
    srcs As Matrix(Of TDepth)()
) As Matrix(Of TDepth)
public:
generic<typename TDepth>
where TDepth : gcnew()
Matrix<TDepth>^ BackProject(
    array<Matrix<TDepth>^>^ srcs
)
member BackProject :
        srcs : Matrix<'TDepth>[] -> Matrix<'TDepth>  when 'TDepth : new()

Parameters

srcs
Type: Emgu.CVMatrix TDepth
Source matrices, all are of the same size and type

Type Parameters

TDepth
The type of depth of the matrix

Return Value

Type: Matrix TDepth
Destination back projection matrix of the sametype as the source matrices
See Also

Reference

DenseHistogram Class
BackProject Overload
Emgu.CV Namespace


DenseHistogram.Calculate Method

DenseHistogramCalculate Method

Overload List
 | Name | Description
Public method | CalculateTDepth(ImageGray, TDepth, Boolean, ImageGray, Byte) | Project the images to the histogram bins
Public method | CalculateTDepth(MatrixTDepth, Boolean, MatrixByte) | Project the matrices to the histogram bins
Top
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram.Calculate(TDepth) Method (Image(Gray, TDepth)[], Boolean, Image(Gray, Byte))

DenseHistogramCalculateTDepth Method (ImageGray, TDepth, Boolean, ImageGray, Byte)

http://www.emgu.com
Project the images to the histogram bins

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Calculate<TDepth>(
    Image<Gray, TDepth>[] imgs,
    bool accumulate,
    Image<Gray, byte> mask
)
where TDepth : new()

Public Sub Calculate(Of TDepth As New) (
    imgs As Image(Of Gray, TDepth)(),
    accumulate As Boolean,
    mask As Image(Of Gray, Byte)
)
public:
generic<typename TDepth>
where TDepth : gcnew()
void Calculate(
    array<Image<Gray^, TDepth>^>^ imgs,
    bool accumulate,
    Image<Gray^, unsigned char>^ mask
)
member Calculate :
        imgs : Image<Gray, 'TDepth>[] *
        accumulate : bool *
        mask : Image<Gray, byte> -> unit  when 'TDepth : new()

Parameters

imgs
Type: Emgu.CVImage Gray, TDepth
images to project
accumulate
Type: SystemBoolean
If it is true, the histogram is not cleared in the beginning. This feature allows user to compute a single histogram from several images, or to update the histogram online.
mask
Type: Emgu.CVImage Gray, Byte
Can be null if not needed. The operation mask, determines what pixels of the source images are counted

Type Parameters

TDepth
The type of depth of the image
See Also

Reference

DenseHistogram Class
Calculate Overload
Emgu.CV Namespace


DenseHistogram.Calculate(TDepth) Method (Matrix(TDepth)[], Boolean, Matrix(Byte))

DenseHistogramCalculateTDepth Method (MatrixTDepth, Boolean, MatrixByte)

http://www.emgu.com
Project the matrices to the histogram bins

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Calculate<TDepth>(
    Matrix<TDepth>[] matrices,
    bool accumulate,
    Matrix<byte> mask
)
where TDepth : new()

Public Sub Calculate(Of TDepth As New) (
    matrices As Matrix(Of TDepth)(),
    accumulate As Boolean,
    mask As Matrix(Of Byte)
)
public:
generic<typename TDepth>
where TDepth : gcnew()
void Calculate(
    array<Matrix<TDepth>^>^ matrices,
    bool accumulate,
    Matrix<unsigned char>^ mask
)
member Calculate :
        matrices : Matrix<'TDepth>[] *
        accumulate : bool *
        mask : Matrix<byte> -> unit  when 'TDepth : new()

Parameters

matrices
Type: Emgu.CVMatrix TDepth
Matrices to project
accumulate
Type: SystemBoolean
If it is true, the histogram is not cleared in the beginning. This feature allows user to compute a single histogram from several images, or to update the histogram online.
mask
Type: Emgu.CVMatrix Byte
Can be null if not needed. The operation mask, determines what pixels of the source images are counted

Type Parameters

TDepth
The type of depth of the image
See Also

Reference

DenseHistogram Class
Calculate Overload
Emgu.CV Namespace


DenseHistogram.Clear Method

DenseHistogramClear Method

Clear this histogram

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram.GetBinValues Method

DenseHistogramGetBinValues Method

Gets the bin values.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float[] GetBinValues()
Public Function GetBinValues As Single()
public:
array<float>^ GetBinValues()
member GetBinValues : unit -> float32[]

Return Value

Type: Single
The bin values
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseHistogram Fields

The DenseHistogram type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DenseHistogram Class
Emgu.CV Namespace


DenseOpticalFlowExtensions Class

Extension methods for IDenseOpticalFlow
Inheritance Hierarchy
SystemObject
Emgu.CVDenseOpticalFlowExtensions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class DenseOpticalFlowExtensions
<ExtensionAttribute>
Public NotInheritable Class DenseOpticalFlowExtensions
[ExtensionAttribute]
public ref class DenseOpticalFlowExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type DenseOpticalFlowExtensions =  class end

The DenseOpticalFlowExtensions type exposes the following members.

Methods
Name | Description
Calc | Calculates an optical flow.
Top
See Also

Reference

Emgu.CV Namespace


DenseOpticalFlowExtensions Methods

The DenseOpticalFlowExtensions type exposes the following members.

Methods
Name | Description
Calc | Calculates an optical flow.
Top
See Also

Reference

DenseOpticalFlowExtensions Class
Emgu.CV Namespace


DenseOpticalFlowExtensions.Calc Method

DenseOpticalFlowExtensionsCalc Method

Calculates an optical flow.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Calc(
    this IDenseOpticalFlow opticalFlow,
    IInputArray i0,
    IInputArray i1,
    IInputOutputArray flow
)
<ExtensionAttribute>
Public Shared Sub Calc (
    opticalFlow As IDenseOpticalFlow,
    i0 As IInputArray,
    i1 As IInputArray,
    flow As IInputOutputArray
)
public:
[ExtensionAttribute]
static void Calc(
    IDenseOpticalFlow^ opticalFlow,
    IInputArray^ i0,
    IInputArray^ i1,
    IInputOutputArray^ flow
)
[<ExtensionAttribute>]
static member Calc :
        opticalFlow : IDenseOpticalFlow *
        i0 : IInputArray *
        i1 : IInputArray *
        flow : IInputOutputArray -> unit

Parameters

opticalFlow
Type: Emgu.CVIDenseOpticalFlow
The dense optical flow object
i0
Type: Emgu.CVIInputArray
First 8-bit single-channel input image.
i1
Type: Emgu.CVIInputArray
Second input image of the same size and the same type as prev.
flow
Type: Emgu.CVIInputOutputArray
Computed flow image that has the same size as prev and type CV_32FC2

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDenseOpticalFlow. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DenseOpticalFlowExtensions Class
Emgu.CV Namespace


DenseRLOFOpticalFlow Class

Fast dense optical flow computation based on robust local optical flow (RLOF) algorithms and sparse-to-dense interpolation scheme.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CVDenseRLOFOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DenseRLOFOpticalFlow : SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
Public Class DenseRLOFOpticalFlow
    Inherits SharedPtrObject
    Implements IDenseOpticalFlow, IAlgorithm
public ref class DenseRLOFOpticalFlow : public SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
type DenseRLOFOpticalFlow =
    class
        inherit SharedPtrObject
        interface IDenseOpticalFlow
        interface IAlgorithm
    end

The DenseRLOFOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | DenseRLOFOpticalFlow | Creates instance of DenseRLOFOpticalFlow
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


DenseRLOFOpticalFlow Constructor

Creates instance of DenseRLOFOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DenseRLOFOpticalFlow(
    RLOFOpticalFlowParameter parameter,
    float forwardBackwardThreshold,
    Size gridStep,
    DenseRLOFOpticalFlowInterpolationType interpType = 1,
    int epicK = 128,
    float epicSigma = 0.05f,
    float epicLambda = 999f,
    bool usePostProc = true,
    float fgsLambda = 500f,
    float fgsSigma = 1.5f
)
Public Sub New (
    parameter As RLOFOpticalFlowParameter,
    forwardBackwardThreshold As Single,
    gridStep As Size,
    Optional interpType As DenseRLOFOpticalFlowInterpolationType = 1,
    Optional epicK As Integer = 128,
    Optional epicSigma As Single = 0.05F,
    Optional epicLambda As Single = 999F,
    Optional usePostProc As Boolean = true,
    Optional fgsLambda As Single = 500F,
    Optional fgsSigma As Single = 1.5F
)
public:
DenseRLOFOpticalFlow(
    RLOFOpticalFlowParameter^ parameter,
    float forwardBackwardThreshold,
    Size^ gridStep,
    DenseRLOFOpticalFlowInterpolationType^ interpType = 1,
    int epicK = 128,
    float epicSigma = 0.05f,
    float epicLambda = 999f,
    bool usePostProc = true,
    float fgsLambda = 500f,
    float fgsSigma = 1.5f
)
new :
        parameter : RLOFOpticalFlowParameter *
        forwardBackwardThreshold : float32 *
        gridStep : Size *
        ?interpType : DenseRLOFOpticalFlowInterpolationType *
        ?epicK : int *
        ?epicSigma : float32 *
        ?epicLambda : float32 *
        ?usePostProc : bool *
        ?fgsLambda : float32 *
        ?fgsSigma : float32
(* Defaults:
        let _interpType = defaultArg interpType 1
        let _epicK = defaultArg epicK 128
        let _epicSigma = defaultArg epicSigma 0.05f
        let _epicLambda = defaultArg epicLambda 999f
        let _usePostProc = defaultArg usePostProc true
        let _fgsLambda = defaultArg fgsLambda 500f
        let _fgsSigma = defaultArg fgsSigma 1.5f
*)
-> DenseRLOFOpticalFlow

Parameters

parameter
Type: Emgu.CVRLOFOpticalFlowParameter
The RLOF optical flow parameters
forwardBackwardThreshold
Type: SystemSingle
Threshold for the forward backward confidence check. Use 1.0f for default
gridStep
Type: System.DrawingSize
Size of the grid to spawn the motion vectors. Use (6, 6) for default
interpType (Optional)
Type: Emgu.CVDenseRLOFOpticalFlowInterpolationType
Interpolation used to compute the dense optical flow.
epicK (Optional)
Type: SystemInt32
See Ximgproc.EdgeAwareInterpolator() K value.
epicSigma (Optional)
Type: SystemSingle
See Ximgproc.EdgeAwareInterpolator() sigma value.
epicLambda (Optional)
Type: SystemSingle
See Ximgproc.EdgeAwareInterpolator() lambda value.
usePostProc (Optional)
Type: SystemBoolean
Enables Ximgproc.fastGlobalSmootherFilter
fgsLambda (Optional)
Type: SystemSingle
See Ximgproc.EdgeAwareInterpolator().
fgsSigma (Optional)
Type: SystemSingle
See Ximgproc.EdgeAwareInterpolator().
See Also

Reference

DenseRLOFOpticalFlow Class
Emgu.CV Namespace


DenseRLOFOpticalFlow Properties

The DenseRLOFOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DenseRLOFOpticalFlow Class
Emgu.CV Namespace


DenseRLOFOpticalFlow.AlgorithmPtr Property

DenseRLOFOpticalFlowAlgorithmPtr Property

Return the pointer to the algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

DenseRLOFOpticalFlow Class
Emgu.CV Namespace


DenseRLOFOpticalFlow.DenseOpticalFlowPtr Property

DenseRLOFOpticalFlowDenseOpticalFlowPtr Property

Gets the dense optical flow pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
The pointer to the dense optical flow object.

Implements

IDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

DenseRLOFOpticalFlow Class
Emgu.CV Namespace


DenseRLOFOpticalFlow Methods

The DenseRLOFOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

DenseRLOFOpticalFlow Class
Emgu.CV Namespace


DenseRLOFOpticalFlow.DisposeObject Method

DenseRLOFOpticalFlowDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DenseRLOFOpticalFlow Class
Emgu.CV Namespace


DenseRLOFOpticalFlow Fields

The DenseRLOFOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DenseRLOFOpticalFlow Class
Emgu.CV Namespace


DenseRLOFOpticalFlow.InterpolationType Class

DenseRLOFOpticalFlowInterpolationType Class

Interpolation type used to compute the dense optical flow.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVDenseRLOFOpticalFlowInterpolationType

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InterpolationType : Enum
Public NotInheritable Class InterpolationType
    Inherits Enum
public ref class InterpolationType sealed : public Enum
[<SealedAttribute>]
type InterpolationType =
    class
        inherit Enum
    end

The DenseRLOFOpticalFlowInterpolationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Epic | Edge-preserving interpolation
 | Geo | Fast geodesic interpolation
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


InterpolationType Methods

The DenseRLOFOpticalFlowInterpolationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DenseRLOFOpticalFlowInterpolationType Class
Emgu.CV Namespace


InterpolationType Fields

The DenseRLOFOpticalFlowInterpolationType type exposes the following members.

Fields
 | Name | Description
 | Epic | Edge-preserving interpolation
 | Geo | Fast geodesic interpolation
Public field | value__ |
Top
See Also

Reference

DenseRLOFOpticalFlowInterpolationType Class
Emgu.CV Namespace


DenseRLOFOpticalFlow.InterpolationType.Epic Field

DenseRLOFOpticalFlowInterpolationTypeEpic Field

Edge-preserving interpolation

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DenseRLOFOpticalFlowInterpolationType Epic = 1
Public Const Epic As DenseRLOFOpticalFlowInterpolationType = 1
public:
literal DenseRLOFOpticalFlowInterpolationType^ Epic = 1
static val mutable Epic: DenseRLOFOpticalFlowInterpolationType

Field Value

Type: DenseRLOFOpticalFlowInterpolationType
See Also

Reference

DenseRLOFOpticalFlowInterpolationType Class
Emgu.CV Namespace


DenseRLOFOpticalFlow.InterpolationType.Geo Field

DenseRLOFOpticalFlowInterpolationTypeGeo Field

Fast geodesic interpolation

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DenseRLOFOpticalFlowInterpolationType Geo = 0
Public Const Geo As DenseRLOFOpticalFlowInterpolationType = 0
public:
literal DenseRLOFOpticalFlowInterpolationType^ Geo = 0
static val mutable Geo: DenseRLOFOpticalFlowInterpolationType

Field Value

Type: DenseRLOFOpticalFlowInterpolationType
See Also

Reference

DenseRLOFOpticalFlowInterpolationType Class
Emgu.CV Namespace


DenseRLOFOpticalFlow.InterpolationType.value__ Field

DenseRLOFOpticalFlowInterpolationTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.DenseRLOFOpticalFlow.InterpolationType.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DenseRLOFOpticalFlowInterpolationType Class
Emgu.CV Namespace


DISOpticalFlow Class

DIS optical flow algorithm. This class implements the Dense Inverse Search(DIS) optical flow algorithm.Includes three presets with preselected parameters to provide reasonable trade-off between speed and quality.However, even the slowest preset is still relatively fast, use DeepFlow if you need better quality and don't care about speed. More details about the algorithm can be found at: Till Kroeger, Radu Timofte, Dengxin Dai, and Luc Van Gool. Fast optical flow using dense inverse search. In Proceedings of the European Conference on Computer Vision (ECCV), 2016.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVDISOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DISOpticalFlow : UnmanagedObject,
    IDenseOpticalFlow, IAlgorithm
Public Class DISOpticalFlow
    Inherits UnmanagedObject
    Implements IDenseOpticalFlow, IAlgorithm
public ref class DISOpticalFlow : public UnmanagedObject,
    IDenseOpticalFlow, IAlgorithm
type DISOpticalFlow =
    class
        inherit UnmanagedObject
        interface IDenseOpticalFlow
        interface IAlgorithm
    end

The DISOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | DISOpticalFlow | Create an instance of DIS optical flow algorithm.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | DenseOpticalFlowPtr | Pointer to native cv::DenseOpticalFlow
Public property | FinestScale | Finest level of the Gaussian pyramid on which the flow is computed (zero level corresponds to the original image resolution). The final flow is obtained by bilinear upscaling.
Public property | GradientDescentIterations | Maximum number of gradient descent iterations in the patch inverse search stage. Higher values may improve quality in some cases.
Public property | PatchSize | Size of an image patch for matching (in pixels). Normally, default 8x8 patches work well enough in most cases.
Public property | PatchStride | Stride between neighbor patches. Must be less than patch size. Lower values correspond to higher flow quality.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | UseMeanNormalization | Whether to use mean-normalization of patches when computing patch distance. It is turned on by default as it typically provides a noticeable quality boost because of increased robustness to illumination variations. Turn it off if you are certain that your sequence doesn't contain any changes in illumination.
Public property | UseSpatialPropagation | Whether to use spatial propagation of good optical flow vectors. This option is turned on by default, as it tends to work better on average and can sometimes help recover from major errors introduced by the coarse-to-fine scheme employed by the DIS optical flow algorithm. Turning this option off can make the output flow field a bit smoother, however.
Public property | VariationalRefinementAlpha | Weight of the smoothness term
Public property | VariationalRefinementDelta | Weight of the color constancy term
Public property | VariationalRefinementGamma | Weight of the gradient constancy term
Public property | VariationalRefinementIterations | Number of fixed point iterations of variational refinement per scale. Set to zero to disable variational refinement completely. Higher values will typically result in more smooth and high-quality flow.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Optical flow algorithm. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


DISOpticalFlow Constructor

Create an instance of DIS optical flow algorithm.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DISOpticalFlow(
    DISOpticalFlowPreset preset = 1
)
Public Sub New (
    Optional preset As DISOpticalFlowPreset = 1
)
public:
DISOpticalFlow(
    DISOpticalFlowPreset^ preset = 1
)
new :
        ?preset : DISOpticalFlowPreset
(* Defaults:
        let _preset = defaultArg preset 1
*)
-> DISOpticalFlow

Parameters

preset (Optional)
Type: Emgu.CVDISOpticalFlowPreset
Algorithm preset
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow Properties

The DISOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | DenseOpticalFlowPtr | Pointer to native cv::DenseOpticalFlow
Public property | FinestScale | Finest level of the Gaussian pyramid on which the flow is computed (zero level corresponds to the original image resolution). The final flow is obtained by bilinear upscaling.
Public property | GradientDescentIterations | Maximum number of gradient descent iterations in the patch inverse search stage. Higher values may improve quality in some cases.
Public property | PatchSize | Size of an image patch for matching (in pixels). Normally, default 8x8 patches work well enough in most cases.
Public property | PatchStride | Stride between neighbor patches. Must be less than patch size. Lower values correspond to higher flow quality.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | UseMeanNormalization | Whether to use mean-normalization of patches when computing patch distance. It is turned on by default as it typically provides a noticeable quality boost because of increased robustness to illumination variations. Turn it off if you are certain that your sequence doesn't contain any changes in illumination.
Public property | UseSpatialPropagation | Whether to use spatial propagation of good optical flow vectors. This option is turned on by default, as it tends to work better on average and can sometimes help recover from major errors introduced by the coarse-to-fine scheme employed by the DIS optical flow algorithm. Turning this option off can make the output flow field a bit smoother, however.
Public property | VariationalRefinementAlpha | Weight of the smoothness term
Public property | VariationalRefinementDelta | Weight of the color constancy term
Public property | VariationalRefinementGamma | Weight of the gradient constancy term
Public property | VariationalRefinementIterations | Number of fixed point iterations of variational refinement per scale. Set to zero to disable variational refinement completely. Higher values will typically result in more smooth and high-quality flow.
Top
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.AlgorithmPtr Property

DISOpticalFlowAlgorithmPtr Property

Pointer to cv::Algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.DenseOpticalFlowPtr Property

DISOpticalFlowDenseOpticalFlowPtr Property

Pointer to native cv::DenseOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.FinestScale Property

DISOpticalFlowFinestScale Property

Finest level of the Gaussian pyramid on which the flow is computed (zero level corresponds to the original image resolution). The final flow is obtained by bilinear upscaling.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int FinestScale { get; set; }
Public Property FinestScale As Integer
    Get
    Set
public:
property int FinestScale {
    int get ();
    void set (int value);
}
member FinestScale : int with get, set

Property Value

Type: Int32
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.GradientDescentIterations Property

DISOpticalFlowGradientDescentIterations Property

Maximum number of gradient descent iterations in the patch inverse search stage. Higher values may improve quality in some cases.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GradientDescentIterations { get; set; }
Public Property GradientDescentIterations As Integer
    Get
    Set
public:
property int GradientDescentIterations {
    int get ();
    void set (int value);
}
member GradientDescentIterations : int with get, set

Property Value

Type: Int32
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.PatchSize Property

DISOpticalFlowPatchSize Property

Size of an image patch for matching (in pixels). Normally, default 8x8 patches work well enough in most cases.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int PatchSize { get; set; }
Public Property PatchSize As Integer
    Get
    Set
public:
property int PatchSize {
    int get ();
    void set (int value);
}
member PatchSize : int with get, set

Property Value

Type: Int32
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.PatchStride Property

DISOpticalFlowPatchStride Property

Stride between neighbor patches. Must be less than patch size. Lower values correspond to higher flow quality.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int PatchStride { get; set; }
Public Property PatchStride As Integer
    Get
    Set
public:
property int PatchStride {
    int get ();
    void set (int value);
}
member PatchStride : int with get, set

Property Value

Type: Int32
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.UseMeanNormalization Property

DISOpticalFlowUseMeanNormalization Property

Whether to use mean-normalization of patches when computing patch distance. It is turned on by default as it typically provides a noticeable quality boost because of increased robustness to illumination variations. Turn it off if you are certain that your sequence doesn't contain any changes in illumination.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseMeanNormalization { get; set; }
Public Property UseMeanNormalization As Boolean
    Get
    Set
public:
property bool UseMeanNormalization {
    bool get ();
    void set (bool value);
}
member UseMeanNormalization : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.UseSpatialPropagation Property

DISOpticalFlowUseSpatialPropagation Property

Whether to use spatial propagation of good optical flow vectors. This option is turned on by default, as it tends to work better on average and can sometimes help recover from major errors introduced by the coarse-to-fine scheme employed by the DIS optical flow algorithm. Turning this option off can make the output flow field a bit smoother, however.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseSpatialPropagation { get; set; }
Public Property UseSpatialPropagation As Boolean
    Get
    Set
public:
property bool UseSpatialPropagation {
    bool get ();
    void set (bool value);
}
member UseSpatialPropagation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.VariationalRefinementAlpha Property

DISOpticalFlowVariationalRefinementAlpha Property

Weight of the smoothness term

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float VariationalRefinementAlpha { get; set; }
Public Property VariationalRefinementAlpha As Single
    Get
    Set
public:
property float VariationalRefinementAlpha {
    float get ();
    void set (float value);
}
member VariationalRefinementAlpha : float32 with get, set

Property Value

Type: Single
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.VariationalRefinementDelta Property

DISOpticalFlowVariationalRefinementDelta Property

Weight of the color constancy term

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float VariationalRefinementDelta { get; set; }
Public Property VariationalRefinementDelta As Single
    Get
    Set
public:
property float VariationalRefinementDelta {
    float get ();
    void set (float value);
}
member VariationalRefinementDelta : float32 with get, set

Property Value

Type: Single
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.VariationalRefinementGamma Property

DISOpticalFlowVariationalRefinementGamma Property

Weight of the gradient constancy term

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float VariationalRefinementGamma { get; set; }
Public Property VariationalRefinementGamma As Single
    Get
    Set
public:
property float VariationalRefinementGamma {
    float get ();
    void set (float value);
}
member VariationalRefinementGamma : float32 with get, set

Property Value

Type: Single
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.VariationalRefinementIterations Property

DISOpticalFlowVariationalRefinementIterations Property

Number of fixed point iterations of variational refinement per scale. Set to zero to disable variational refinement completely. Higher values will typically result in more smooth and high-quality flow.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int VariationalRefinementIterations { get; set; }
Public Property VariationalRefinementIterations As Integer
    Get
    Set
public:
property int VariationalRefinementIterations {
    int get ();
    void set (int value);
}
member VariationalRefinementIterations : int with get, set

Property Value

Type: Int32
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow Methods

The DISOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Optical flow algorithm. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.DisposeObject Method

DISOpticalFlowDisposeObject Method

Release the unmanaged memory associated with this Optical flow algorithm.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow Fields

The DISOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DISOpticalFlow Class
Emgu.CV Namespace


DISOpticalFlow.Preset Class

DISOpticalFlowPreset Class

Preset
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVDISOpticalFlowPreset

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Preset : Enum
Public NotInheritable Class Preset
    Inherits Enum
public ref class Preset sealed : public Enum
[<SealedAttribute>]
type Preset =
    class
        inherit Enum
    end

The DISOpticalFlowPreset type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Fast | Fast
 | Medium | Medium
 | UltraFast | Ultra fast
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


Preset Methods

The DISOpticalFlowPreset type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DISOpticalFlowPreset Class
Emgu.CV Namespace


Preset Fields

The DISOpticalFlowPreset type exposes the following members.

Fields
 | Name | Description
 | Fast | Fast
 | Medium | Medium
 | UltraFast | Ultra fast
Public field | value__ |
Top
See Also

Reference

DISOpticalFlowPreset Class
Emgu.CV Namespace


DISOpticalFlow.Preset.Fast Field

DISOpticalFlowPresetFast Field

Fast

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DISOpticalFlowPreset Fast = 1
Public Const Fast As DISOpticalFlowPreset = 1
public:
literal DISOpticalFlowPreset^ Fast = 1
static val mutable Fast: DISOpticalFlowPreset

Field Value

Type: DISOpticalFlowPreset
See Also

Reference

DISOpticalFlowPreset Class
Emgu.CV Namespace


DISOpticalFlow.Preset.Medium Field

DISOpticalFlowPresetMedium Field

Medium

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DISOpticalFlowPreset Medium = 2
Public Const Medium As DISOpticalFlowPreset = 2
public:
literal DISOpticalFlowPreset^ Medium = 2
static val mutable Medium: DISOpticalFlowPreset

Field Value

Type: DISOpticalFlowPreset
See Also

Reference

DISOpticalFlowPreset Class
Emgu.CV Namespace


DISOpticalFlow.Preset.UltraFast Field

DISOpticalFlowPresetUltraFast Field

Ultra fast

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DISOpticalFlowPreset UltraFast = 0
Public Const UltraFast As DISOpticalFlowPreset = 0
public:
literal DISOpticalFlowPreset^ UltraFast = 0
static val mutable UltraFast: DISOpticalFlowPreset

Field Value

Type: DISOpticalFlowPreset
See Also

Reference

DISOpticalFlowPreset Class
Emgu.CV Namespace


DISOpticalFlow.Preset.value__ Field

DISOpticalFlowPresetvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.DISOpticalFlow.Preset.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DISOpticalFlowPreset Class
Emgu.CV Namespace


DualTVL1OpticalFlow Class

Dual TV L1 Optical Flow Algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CVDualTVL1OpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DualTVL1OpticalFlow : SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
Public Class DualTVL1OpticalFlow
    Inherits SharedPtrObject
    Implements IDenseOpticalFlow, IAlgorithm
public ref class DualTVL1OpticalFlow : public SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
type DualTVL1OpticalFlow =
    class
        inherit SharedPtrObject
        interface IDenseOpticalFlow
        interface IAlgorithm
    end

The DualTVL1OpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | DualTVL1OpticalFlow | Create Dual TV L1 Optical Flow.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Public property | Epsilon | Stopping criterion threshold used in the numerical scheme, which is a trade-off between precision and running time
Public property | Gamma | Coefficient for additional illumination variation term
Public property | InnerIterations | Inner iterations (between outlier filtering) used in the numerical scheme
Public property | Lambda | Weight parameter for the data term, attachment parameter
Public property | MedianFiltering | Median filter kernel size (1 = no filter) (3 or 5)
Public property | OuterIterations | Outer iterations (number of inner loops) used in the numerical scheme
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ScalesNumber | Number of scales used to create the pyramid of images
Public property | ScaleStep | Step between scales (less than 1)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | Tau | Time step of the numerical scheme
Public property | Theta | Weight parameter for (u - v)^2, tightness parameter
Public property | UseInitialFlow | Use initial flow
Public property | WarpingsNumber | Number of warpings per scale
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


DualTVL1OpticalFlow Constructor

Create Dual TV L1 Optical Flow.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DualTVL1OpticalFlow()
Public Sub New
public:
DualTVL1OpticalFlow()
new : unit -> DualTVL1OpticalFlow
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow Properties

The DualTVL1OpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Public property | Epsilon | Stopping criterion threshold used in the numerical scheme, which is a trade-off between precision and running time
Public property | Gamma | Coefficient for additional illumination variation term
Public property | InnerIterations | Inner iterations (between outlier filtering) used in the numerical scheme
Public property | Lambda | Weight parameter for the data term, attachment parameter
Public property | MedianFiltering | Median filter kernel size (1 = no filter) (3 or 5)
Public property | OuterIterations | Outer iterations (number of inner loops) used in the numerical scheme
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ScalesNumber | Number of scales used to create the pyramid of images
Public property | ScaleStep | Step between scales (less than 1)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | Tau | Time step of the numerical scheme
Public property | Theta | Weight parameter for (u - v)^2, tightness parameter
Public property | UseInitialFlow | Use initial flow
Public property | WarpingsNumber | Number of warpings per scale
Top
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.AlgorithmPtr Property

DualTVL1OpticalFlowAlgorithmPtr Property

Return the pointer to the algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.DenseOpticalFlowPtr Property

DualTVL1OpticalFlowDenseOpticalFlowPtr Property

Gets the dense optical flow pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
The pointer to the dense optical flow object.

Implements

IDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.Epsilon Property

DualTVL1OpticalFlowEpsilon Property

Stopping criterion threshold used in the numerical scheme, which is a trade-off between precision and running time

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Epsilon { get; set; }
Public Property Epsilon As Double
    Get
    Set
public:
property double Epsilon {
    double get ();
    void set (double value);
}
member Epsilon : float with get, set

Property Value

Type: Double
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.Gamma Property

DualTVL1OpticalFlowGamma Property

Coefficient for additional illumination variation term

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Gamma { get; set; }
Public Property Gamma As Double
    Get
    Set
public:
property double Gamma {
    double get ();
    void set (double value);
}
member Gamma : float with get, set

Property Value

Type: Double
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.InnerIterations Property

DualTVL1OpticalFlowInnerIterations Property

Inner iterations (between outlier filtering) used in the numerical scheme

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int InnerIterations { get; set; }
Public Property InnerIterations As Integer
    Get
    Set
public:
property int InnerIterations {
    int get ();
    void set (int value);
}
member InnerIterations : int with get, set

Property Value

Type: Int32
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.Lambda Property

DualTVL1OpticalFlowLambda Property

Weight parameter for the data term, attachment parameter

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Lambda { get; set; }
Public Property Lambda As Double
    Get
    Set
public:
property double Lambda {
    double get ();
    void set (double value);
}
member Lambda : float with get, set

Property Value

Type: Double
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.MedianFiltering Property

DualTVL1OpticalFlowMedianFiltering Property

Median filter kernel size (1 = no filter) (3 or 5)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MedianFiltering { get; set; }
Public Property MedianFiltering As Integer
    Get
    Set
public:
property int MedianFiltering {
    int get ();
    void set (int value);
}
member MedianFiltering : int with get, set

Property Value

Type: Int32
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.OuterIterations Property

DualTVL1OpticalFlowOuterIterations Property

Outer iterations (number of inner loops) used in the numerical scheme

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int OuterIterations { get; set; }
Public Property OuterIterations As Integer
    Get
    Set
public:
property int OuterIterations {
    int get ();
    void set (int value);
}
member OuterIterations : int with get, set

Property Value

Type: Int32
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.ScalesNumber Property

DualTVL1OpticalFlowScalesNumber Property

Number of scales used to create the pyramid of images

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ScalesNumber { get; set; }
Public Property ScalesNumber As Integer
    Get
    Set
public:
property int ScalesNumber {
    int get ();
    void set (int value);
}
member ScalesNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.ScaleStep Property

DualTVL1OpticalFlowScaleStep Property

Step between scales (less than 1)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ScaleStep { get; set; }
Public Property ScaleStep As Double
    Get
    Set
public:
property double ScaleStep {
    double get ();
    void set (double value);
}
member ScaleStep : float with get, set

Property Value

Type: Double
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.Tau Property

DualTVL1OpticalFlowTau Property

Time step of the numerical scheme

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Tau { get; set; }
Public Property Tau As Double
    Get
    Set
public:
property double Tau {
    double get ();
    void set (double value);
}
member Tau : float with get, set

Property Value

Type: Double
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.Theta Property

DualTVL1OpticalFlowTheta Property

Weight parameter for (u - v)^2, tightness parameter

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Theta { get; set; }
Public Property Theta As Double
    Get
    Set
public:
property double Theta {
    double get ();
    void set (double value);
}
member Theta : float with get, set

Property Value

Type: Double
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.UseInitialFlow Property

DualTVL1OpticalFlowUseInitialFlow Property

Use initial flow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseInitialFlow { get; set; }
Public Property UseInitialFlow As Boolean
    Get
    Set
public:
property bool UseInitialFlow {
    bool get ();
    void set (bool value);
}
member UseInitialFlow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.WarpingsNumber Property

DualTVL1OpticalFlowWarpingsNumber Property

Number of warpings per scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int WarpingsNumber { get; set; }
Public Property WarpingsNumber As Integer
    Get
    Set
public:
property int WarpingsNumber {
    int get ();
    void set (int value);
}
member WarpingsNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow Methods

The DualTVL1OpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow.DisposeObject Method

DualTVL1OpticalFlowDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


DualTVL1OpticalFlow Fields

The DualTVL1OpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DualTVL1OpticalFlow Class
Emgu.CV Namespace


FarnebackOpticalFlow Class

Class computing a dense optical flow using the Gunnar Farneback's algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVFarnebackOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FarnebackOpticalFlow : UnmanagedObject,
    IDenseOpticalFlow, IAlgorithm
Public Class FarnebackOpticalFlow
    Inherits UnmanagedObject
    Implements IDenseOpticalFlow, IAlgorithm
public ref class FarnebackOpticalFlow : public UnmanagedObject,
    IDenseOpticalFlow, IAlgorithm
type FarnebackOpticalFlow =
    class
        inherit UnmanagedObject
        interface IDenseOpticalFlow
        interface IAlgorithm
    end

The FarnebackOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | FarnebackOpticalFlow | Create a FarnebackOpticalFlow object
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


FarnebackOpticalFlow Constructor

Create a FarnebackOpticalFlow object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FarnebackOpticalFlow(
    int numLevels = 5,
    double pyrScale = 0.5,
    bool fastPyramids = false,
    int winSize = 13,
    int numIters = 10,
    int polyN = 5,
    double polySigma = 1.1,
    OpticalflowFarnebackFlag flags = 0
)
Public Sub New (
    Optional numLevels As Integer = 5,
    Optional pyrScale As Double = 0.5,
    Optional fastPyramids As Boolean = false,
    Optional winSize As Integer = 13,
    Optional numIters As Integer = 10,
    Optional polyN As Integer = 5,
    Optional polySigma As Double = 1.1,
    Optional flags As OpticalflowFarnebackFlag = 0
)
public:
FarnebackOpticalFlow(
    int numLevels = 5,
    double pyrScale = 0.5,
    bool fastPyramids = false,
    int winSize = 13,
    int numIters = 10,
    int polyN = 5,
    double polySigma = 1.1,
    OpticalflowFarnebackFlag^ flags = 0
)
new :
        ?numLevels : int *
        ?pyrScale : float *
        ?fastPyramids : bool *
        ?winSize : int *
        ?numIters : int *
        ?polyN : int *
        ?polySigma : float *
        ?flags : OpticalflowFarnebackFlag
(* Defaults:
        let _numLevels = defaultArg numLevels 5
        let _pyrScale = defaultArg pyrScale 0.5
        let _fastPyramids = defaultArg fastPyramids false
        let _winSize = defaultArg winSize 13
        let _numIters = defaultArg numIters 10
        let _polyN = defaultArg polyN 5
        let _polySigma = defaultArg polySigma 1.1
        let _flags = defaultArg flags 0
*)
-> FarnebackOpticalFlow

Parameters

numLevels (Optional)
Type: SystemInt32
The number of pyramid layers, including the initial image. levels=1 means that no extra layers are created and only the original images are used
pyrScale (Optional)
Type: SystemDouble
Specifies the image scale (!1) to build the pyramids for each image. pyrScale=0.5 means the classical pyramid, where each next layer is twice smaller than the previous
fastPyramids (Optional)
Type: SystemBoolean
Fast Pyramids
winSize (Optional)
Type: SystemInt32
The averaging window size; The larger values increase the algorithm robustness to image noise and give more chances for fast motion detection, but yield more blurred motion field
numIters (Optional)
Type: SystemInt32
The number of iterations the algorithm does at each pyramid level
polyN (Optional)
Type: SystemInt32
Size of the pixel neighborhood used to find polynomial expansion in each pixel. The larger values mean that the image will be approximated with smoother surfaces, yielding more robust algorithm and more blurred motion field. Typically, poly n=5 or 7
polySigma (Optional)
Type: SystemDouble
Standard deviation of the Gaussian that is used to smooth derivatives that are used as a basis for the polynomial expansion. For poly n=5 you can set poly sigma=1.1, for poly n=7 a good value would be poly sigma=1.5
flags (Optional)
Type: Emgu.CV.CvEnumOpticalflowFarnebackFlag
The operation flags
See Also

Reference

FarnebackOpticalFlow Class
Emgu.CV Namespace


FarnebackOpticalFlow Properties

The FarnebackOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FarnebackOpticalFlow Class
Emgu.CV Namespace


FarnebackOpticalFlow.AlgorithmPtr Property

FarnebackOpticalFlowAlgorithmPtr Property

Return the pointer to the algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

FarnebackOpticalFlow Class
Emgu.CV Namespace


FarnebackOpticalFlow.DenseOpticalFlowPtr Property

FarnebackOpticalFlowDenseOpticalFlowPtr Property

Gets the dense optical flow pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
The pointer to the dense optical flow object.

Implements

IDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

FarnebackOpticalFlow Class
Emgu.CV Namespace


FarnebackOpticalFlow Methods

The FarnebackOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

FarnebackOpticalFlow Class
Emgu.CV Namespace


FarnebackOpticalFlow.DisposeObject Method

FarnebackOpticalFlowDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FarnebackOpticalFlow Class
Emgu.CV Namespace


FarnebackOpticalFlow Fields

The FarnebackOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FarnebackOpticalFlow Class
Emgu.CV Namespace


FileNode Class

File Storage Node class. The node is used to store each and every element of the file storage opened for reading. When XML/YAML file is read, it is first parsed and stored in the memory as a hierarchical collection of nodes. Each node can be a "leaf" that is contain a single number or a string, or be a collection of other nodes. There can be named collections (mappings) where each element has a name and it is accessed by a name, and ordered collections (sequences) where elements do not have names but rather accessed by index. Type of the file node can be determined using FileNode::type method. Note that file nodes are only used for navigating file storages opened for reading. When a file storage is opened for writing, no data is stored in memory after it is written.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVFileNode

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FileNode : UnmanagedObject
Public Class FileNode
    Inherits UnmanagedObject
public ref class FileNode : public UnmanagedObject
type FileNode =
    class
        inherit UnmanagedObject
    end

The FileNode type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Returns true if the node is empty
Public property | IsInt | Returns true if the node is an integer
Public property | IsMap | Returns true if the node is a mapping
Public property | IsNamed | Returns true if the node has a name
Public property | IsNone | Returns true if the node is a "none" object
Public property | IsReal | Returns true if the node is a floating-point number
Public property | IsSeq | Returns true if the node is a sequence
Public property | IsString | Returns true if the node is a text string
Public property | NodeType | Gets the type of the node.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadDouble | Reads the double from the node.
Public method | ReadFloat | Reads the float from the node.
Public method | ReadInt | Reads the int from the node.
Public method | ReadMat | Reads a Mat from the node
Public method | ReadString | Reads the string from the node
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


FileNode Properties

The FileNode type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Returns true if the node is empty
Public property | IsInt | Returns true if the node is an integer
Public property | IsMap | Returns true if the node is a mapping
Public property | IsNamed | Returns true if the node has a name
Public property | IsNone | Returns true if the node is a "none" object
Public property | IsReal | Returns true if the node is a floating-point number
Public property | IsSeq | Returns true if the node is a sequence
Public property | IsString | Returns true if the node is a text string
Public property | NodeType | Gets the type of the node.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsEmpty Property

FileNodeIsEmpty Property

Returns true if the node is empty

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsInt Property

FileNodeIsInt Property

Returns true if the node is an integer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsInt { get; }
Public ReadOnly Property IsInt As Boolean
    Get
public:
property bool IsInt {
    bool get ();
}
member IsInt : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsMap Property

FileNodeIsMap Property

Returns true if the node is a mapping

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsMap { get; }
Public ReadOnly Property IsMap As Boolean
    Get
public:
property bool IsMap {
    bool get ();
}
member IsMap : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsNamed Property

FileNodeIsNamed Property

Returns true if the node has a name

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsNamed { get; }
Public ReadOnly Property IsNamed As Boolean
    Get
public:
property bool IsNamed {
    bool get ();
}
member IsNamed : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsNone Property

FileNodeIsNone Property

Returns true if the node is a "none" object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsNone { get; }
Public ReadOnly Property IsNone As Boolean
    Get
public:
property bool IsNone {
    bool get ();
}
member IsNone : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsReal Property

FileNodeIsReal Property

Returns true if the node is a floating-point number

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsReal { get; }
Public ReadOnly Property IsReal As Boolean
    Get
public:
property bool IsReal {
    bool get ();
}
member IsReal : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsSeq Property

FileNodeIsSeq Property

Returns true if the node is a sequence

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSeq { get; }
Public ReadOnly Property IsSeq As Boolean
    Get
public:
property bool IsSeq {
    bool get ();
}
member IsSeq : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.IsString Property

FileNodeIsString Property

Returns true if the node is a text string

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsString { get; }
Public ReadOnly Property IsString As Boolean
    Get
public:
property bool IsString {
    bool get ();
}
member IsString : bool with get

Property Value

Type: Boolean
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.NodeType Property

FileNodeNodeType Property

Gets the type of the node.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FileNodeType NodeType { get; }
Public ReadOnly Property NodeType As FileNodeType
    Get
public:
property FileNodeType^ NodeType {
    FileNodeType^ get ();
}
member NodeType : FileNodeType with get

Property Value

Type: FileNodeType
The type of the node.
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode Methods

The FileNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadDouble | Reads the double from the node.
Public method | ReadFloat | Reads the float from the node.
Public method | ReadInt | Reads the int from the node.
Public method | ReadMat | Reads a Mat from the node
Public method | ReadString | Reads the string from the node
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.DisposeObject Method

FileNodeDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.ReadDouble Method

FileNodeReadDouble Method

Reads the double from the node.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ReadDouble(
    double defaultDouble = -1.79769313486232E+308
)
Public Function ReadDouble (
    Optional defaultDouble As Double = -1.79769313486232E+308
) As Double
public:
double ReadDouble(
    double defaultDouble = -1.79769313486232E+308
)
member ReadDouble :
        ?defaultDouble : float
(* Defaults:
        let _defaultDouble = defaultArg defaultDouble -1.79769313486232E+308
*)
-> float

Parameters

defaultDouble (Optional)
Type: SystemDouble
The default value if one is not found in the node.

Return Value

Type: Double
The double from the node.
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.ReadFloat Method

FileNodeReadFloat Method

Reads the float from the node.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ReadFloat(
    float defaultFloat = -3.402823E+38f
)
Public Function ReadFloat (
    Optional defaultFloat As Single = -3.402823E+38F
) As Single
public:
float ReadFloat(
    float defaultFloat = -3.402823E+38f
)
member ReadFloat :
        ?defaultFloat : float32
(* Defaults:
        let _defaultFloat = defaultArg defaultFloat -3.402823E+38f
*)
-> float32

Parameters

defaultFloat (Optional)
Type: SystemSingle
The default value if one is not found in the node.

Return Value

Type: Single
The float from the node.
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.ReadInt Method

FileNodeReadInt Method

Reads the int from the node.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ReadInt(
    int defaultInt = -2147483648
)
Public Function ReadInt (
    Optional defaultInt As Integer = -2147483648
) As Integer
public:
int ReadInt(
    int defaultInt = -2147483648
)
member ReadInt :
        ?defaultInt : int
(* Defaults:
        let _defaultInt = defaultArg defaultInt -2147483648
*)
-> int

Parameters

defaultInt (Optional)
Type: SystemInt32
The default value if one is not found in the node.

Return Value

Type: Int32
The int from the node.
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.ReadMat Method

FileNodeReadMat Method

Reads a Mat from the node

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReadMat(
    Mat mat,
    Mat defaultMat = null
)
Public Sub ReadMat (
    mat As Mat,
    Optional defaultMat As Mat = Nothing
)
public:
void ReadMat(
    Mat^ mat,
    Mat^ defaultMat = nullptr
)
member ReadMat :
        mat : Mat *
        ?defaultMat : Mat
(* Defaults:
        let _defaultMat = defaultArg defaultMat null
*)
-> unit

Parameters

mat
Type: Emgu.CVMat
The Mat where the result is read into
defaultMat (Optional)
Type: Emgu.CVMat
The default mat.
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.ReadString Method

FileNodeReadString Method

Reads the string from the node

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ReadString(
    string defaultString = null
)
Public Function ReadString (
    Optional defaultString As String = Nothing
) As String
public:
String^ ReadString(
    String^ defaultString = nullptr
)
member ReadString :
        ?defaultString : string
(* Defaults:
        let _defaultString = defaultArg defaultString null
*)
-> string

Parameters

defaultString (Optional)
Type: SystemString
The default value if one is not found in the node.

Return Value

Type: String
The string from the node
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode Fields

The FileNode type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FileNode Class
Emgu.CV Namespace


FileNode.Type Class

FileNodeType Class

Type of the file storage node
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVFileNodeType

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Type : Enum
Public NotInheritable Class Type
    Inherits Enum
public ref class Type sealed : public Enum
[<SealedAttribute>]
type Type =
    class
        inherit Enum
    end

The FileNodeType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Empty | Empty structure (sequence or mapping)
 | Float | Synonym or Real
 | Flow | Compact representation of a sequence or mapping. Used only by YAML writer
 | Int | an integer
 | Map | Mapping
 | Named | The node has a name (i.e. it is element of a mapping)
 | None | Empty node
 | Real | Floating-point number
 | Ref | Integer of size size_t. Typically used for storing complex dynamic structures where some elements reference the others
 | Seq | The sequence
 | Str | Text string in UTF-8 encoding
 | String | Synonym for Str
 | TypeMask | The type mask
 | User | A registered object (e.g. a matrix)
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


Type Methods

The FileNodeType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


Type Fields

The FileNodeType type exposes the following members.

Fields
 | Name | Description
 | Empty | Empty structure (sequence or mapping)
 | Float | Synonym or Real
 | Flow | Compact representation of a sequence or mapping. Used only by YAML writer
 | Int | an integer
 | Map | Mapping
 | Named | The node has a name (i.e. it is element of a mapping)
 | None | Empty node
 | Real | Floating-point number
 | Ref | Integer of size size_t. Typically used for storing complex dynamic structures where some elements reference the others
 | Seq | The sequence
 | Str | Text string in UTF-8 encoding
 | String | Synonym for Str
 | TypeMask | The type mask
 | User | A registered object (e.g. a matrix)
Public field | value__ |
Top
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Empty Field

FileNodeTypeEmpty Field

Empty structure (sequence or mapping)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Empty = 32
Public Const Empty As FileNodeType = 32
public:
literal FileNodeType^ Empty = 32
static val mutable Empty: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Float Field

FileNodeTypeFloat Field

Synonym or Real

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Float = 2
Public Const Float As FileNodeType = 2
public:
literal FileNodeType^ Float = 2
static val mutable Float: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Flow Field

FileNodeTypeFlow Field

Compact representation of a sequence or mapping. Used only by YAML writer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Flow = 8
Public Const Flow As FileNodeType = 8
public:
literal FileNodeType^ Flow = 8
static val mutable Flow: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Int Field

FileNodeTypeInt Field

an integer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Int = 1
Public Const Int As FileNodeType = 1
public:
literal FileNodeType^ Int = 1
static val mutable Int: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Map Field

FileNodeTypeMap Field

Mapping

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Map = 6
Public Const Map As FileNodeType = 6
public:
literal FileNodeType^ Map = 6
static val mutable Map: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Named Field

FileNodeTypeNamed Field

The node has a name (i.e. it is element of a mapping)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Named = 64
Public Const Named As FileNodeType = 64
public:
literal FileNodeType^ Named = 64
static val mutable Named: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.None Field

FileNodeTypeNone Field

Empty node

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType None = 0
Public Const None As FileNodeType = 0
public:
literal FileNodeType^ None = 0
static val mutable None: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Real Field

FileNodeTypeReal Field

Floating-point number

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Real = 2
Public Const Real As FileNodeType = 2
public:
literal FileNodeType^ Real = 2
static val mutable Real: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Ref Field

FileNodeTypeRef Field

Integer of size size_t. Typically used for storing complex dynamic structures where some elements reference the others

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Ref = 4
Public Const Ref As FileNodeType = 4
public:
literal FileNodeType^ Ref = 4
static val mutable Ref: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Seq Field

FileNodeTypeSeq Field

The sequence

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Seq = 5
Public Const Seq As FileNodeType = 5
public:
literal FileNodeType^ Seq = 5
static val mutable Seq: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.Str Field

FileNodeTypeStr Field

Text string in UTF-8 encoding

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType Str = 3
Public Const Str As FileNodeType = 3
public:
literal FileNodeType^ Str = 3
static val mutable Str: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.String Field

FileNodeTypeString Field

Synonym for Str

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType String = 3
Public Const String As FileNodeType = 3
public:
literal FileNodeType^ String = 3
static val mutable String: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.TypeMask Field

FileNodeTypeTypeMask Field

The type mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType TypeMask = 7
Public Const TypeMask As FileNodeType = 7
public:
literal FileNodeType^ TypeMask = 7
static val mutable TypeMask: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.User Field

FileNodeTypeUser Field

A registered object (e.g. a matrix)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileNodeType User = 16
Public Const User As FileNodeType = 16
public:
literal FileNodeType^ User = 16
static val mutable User: FileNodeType

Field Value

Type: FileNodeType
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileNode.Type.value__ Field

FileNodeTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.FileNode.Type.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FileNodeType Class
Emgu.CV Namespace


FileStorage Class

XML/YAML file storage class that encapsulates all the information necessary for writing or reading data to/from a file.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVFileStorage

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FileStorage : UnmanagedObject
Public Class FileStorage
    Inherits UnmanagedObject
public ref class FileStorage : public UnmanagedObject
type FileStorage =
    class
        inherit UnmanagedObject
    end

The FileStorage type exposes the following members.

Constructors
 | Name | Description
Public method | FileStorage | Initializes a new instance of the FileStorage class.
Top
Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether this instance is opened.
Public property | Item | Gets the FileNode with the specified node name.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetFirstTopLevelNode | Gets the first element of the top-level mapping.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNode | Gets the specified element of the top-level mapping.
Public method | GetRoot | Gets the top-level mapping.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Similar to the << operator in C++, we cannot have the operator overload to << in C# where the second parameter is not an int. Therefore we use this function instead.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseAndGetString | Closes the file and releases all the memory buffers Call this method after all I/O operations with the storage are finished. If the storage was opened for writing data and FileStorage.Mode.Write was specified
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(Double, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Int32, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Single, String) | Writes the specified Mat to the node with the specific name
Public method | Write(String, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Mat, String) | Writes the specified Mat to the node with the specific name.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


FileStorage Constructor

Initializes a new instance of the FileStorage class.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FileStorage(
    string source,
    FileStorageMode flags,
    string encoding = null
)
Public Sub New (
    source As String,
    flags As FileStorageMode,
    Optional encoding As String = Nothing
)
public:
FileStorage(
    String^ source,
    FileStorageMode^ flags,
    String^ encoding = nullptr
)
new :
        source : string *
        flags : FileStorageMode *
        ?encoding : string
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> FileStorage

Parameters

source
Type: SystemString
Name of the file to open or the text string to read the data from. Extension of the file (.xml or .yml/.yaml) determines its format (XML or YAML respectively). Also you can append .gz to work with compressed files, for example myHugeMatrix.xml.gz. If both FileStorage::WRITE and FileStorage::MEMORY flags are specified, source is used just to specify the output file format (e.g. mydata.xml, .yml etc.).
flags
Type: Emgu.CVFileStorageMode
Mode of operation.
encoding (Optional)
Type: SystemString
Encoding of the file. Note that UTF-16 XML encoding is not supported currently and you should use 8-bit encoding instead of it.
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage Properties

The FileStorage type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether this instance is opened.
Public property | Item | Gets the FileNode with the specified node name.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.IsOpened Property

FileStorageIsOpened Property

Gets a value indicating whether this instance is opened.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOpened { get; }
Public ReadOnly Property IsOpened As Boolean
    Get
public:
property bool IsOpened {
    bool get ();
}
member IsOpened : bool with get

Property Value

Type: Boolean
true if the object is associated with the current file; otherwise, false.
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.Item Property

FileStorageItem Property

Gets the FileNode with the specified node name.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FileNode this[
    string nodeName
] { get; }
Public ReadOnly Property Item (
    nodeName As String
) As FileNode
    Get
public:
property FileNode^ Item[String^ nodeName] {
    FileNode^ get (String^ nodeName);
}
member Item : FileNode with get

Parameters

nodeName
Type: SystemString
Name of the node.

Property Value

Type: FileNode
The FileNode.

Return Value

Type: FileNode
The file node
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage Methods

The FileStorage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetFirstTopLevelNode | Gets the first element of the top-level mapping.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNode | Gets the specified element of the top-level mapping.
Public method | GetRoot | Gets the top-level mapping.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Similar to the << operator in C++, we cannot have the operator overload to << in C# where the second parameter is not an int. Therefore we use this function instead.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseAndGetString | Closes the file and releases all the memory buffers Call this method after all I/O operations with the storage are finished. If the storage was opened for writing data and FileStorage.Mode.Write was specified
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(Double, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Int32, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Single, String) | Writes the specified Mat to the node with the specific name
Public method | Write(String, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Mat, String) | Writes the specified Mat to the node with the specific name.
Top
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.DisposeObject Method

FileStorageDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.GetFirstTopLevelNode Method

FileStorageGetFirstTopLevelNode Method

Gets the first element of the top-level mapping.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FileNode GetFirstTopLevelNode()
Public Function GetFirstTopLevelNode As FileNode
public:
FileNode^ GetFirstTopLevelNode()
member GetFirstTopLevelNode : unit -> FileNode

Return Value

Type: FileNode
The first element of the top-level mapping.
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.GetNode Method

FileStorageGetNode Method

Gets the specified element of the top-level mapping.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FileNode GetNode(
    string nodeName
)
Public Function GetNode (
    nodeName As String
) As FileNode
public:
FileNode^ GetNode(
    String^ nodeName
)
member GetNode :
        nodeName : string -> FileNode

Parameters

nodeName
Type: SystemString
Name of the node.

Return Value

Type: FileNode
The specified element of the top-level mapping.
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.GetRoot Method

FileStorageGetRoot Method

Gets the top-level mapping.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FileNode GetRoot(
    int streamIdx = 0
)
Public Function GetRoot (
    Optional streamIdx As Integer = 0
) As FileNode
public:
FileNode^ GetRoot(
    int streamIdx = 0
)
member GetRoot :
        ?streamIdx : int
(* Defaults:
        let _streamIdx = defaultArg streamIdx 0
*)
-> FileNode

Parameters

streamIdx (Optional)
Type: SystemInt32
Zero-based index of the stream. In most cases there is only one stream in the file. However, YAML supports multiple streams and so there can be several.

Return Value

Type: FileNode
The top-level mapping
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.Insert Method

FileStorageInsert Method

Similar to the << operator in C++, we cannot have the operator overload to << in C# where the second parameter is not an int. Therefore we use this function instead.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    string value
)
Public Sub Insert (
    value As String
)
public:
void Insert(
    String^ value
)
member Insert :
        value : string -> unit

Parameters

value
Type: SystemString
The string value to insert.
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.ReleaseAndGetString Method

FileStorageReleaseAndGetString Method

Closes the file and releases all the memory buffers Call this method after all I/O operations with the storage are finished. If the storage was opened for writing data and FileStorage.Mode.Write was specified

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ReleaseAndGetString()
Public Function ReleaseAndGetString As String
public:
String^ ReleaseAndGetString()
member ReleaseAndGetString : unit -> string

Return Value

Type: String
The string that represent the text in the FileStorage
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.Write Method

FileStorageWrite Method

Overload List
 | Name | Description
Public method | Write(Double, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Int32, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Single, String) | Writes the specified Mat to the node with the specific name
Public method | Write(String, String) | Writes the specified Mat to the node with the specific name
Public method | Write(Mat, String) | Writes the specified Mat to the node with the specific name.
Top
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.Write Method (Double, String)

FileStorageWrite Method (Double, String)

http://www.emgu.com
Writes the specified Mat to the node with the specific name

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    double value,
    string nodeName = null
)
Public Sub Write (
    value As Double,
    Optional nodeName As String = Nothing
)
public:
void Write(
    double value,
    String^ nodeName = nullptr
)
member Write :
        value : float *
        ?nodeName : string
(* Defaults:
        let _nodeName = defaultArg nodeName null
*)
-> unit

Parameters

value
Type: SystemDouble
The value to be written to the file storage
nodeName (Optional)
Type: SystemString
The name of the node.
See Also

Reference

FileStorage Class
Write Overload
Emgu.CV Namespace


FileStorage.Write Method (Int32, String)

FileStorageWrite Method (Int32, String)

http://www.emgu.com
Writes the specified Mat to the node with the specific name

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    int value,
    string nodeName = null
)
Public Sub Write (
    value As Integer,
    Optional nodeName As String = Nothing
)
public:
void Write(
    int value,
    String^ nodeName = nullptr
)
member Write :
        value : int *
        ?nodeName : string
(* Defaults:
        let _nodeName = defaultArg nodeName null
*)
-> unit

Parameters

value
Type: SystemInt32
The value to be written to the file storage
nodeName (Optional)
Type: SystemString
The name of the node.
See Also

Reference

FileStorage Class
Write Overload
Emgu.CV Namespace


FileStorage.Write Method (Single, String)

FileStorageWrite Method (Single, String)

http://www.emgu.com
Writes the specified Mat to the node with the specific name

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    float value,
    string nodeName = null
)
Public Sub Write (
    value As Single,
    Optional nodeName As String = Nothing
)
public:
void Write(
    float value,
    String^ nodeName = nullptr
)
member Write :
        value : float32 *
        ?nodeName : string
(* Defaults:
        let _nodeName = defaultArg nodeName null
*)
-> unit

Parameters

value
Type: SystemSingle
The value to be written to the file storage
nodeName (Optional)
Type: SystemString
The name of the node.
See Also

Reference

FileStorage Class
Write Overload
Emgu.CV Namespace


FileStorage.Write Method (String, String)

FileStorageWrite Method (String, String)

http://www.emgu.com
Writes the specified Mat to the node with the specific name

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string value,
    string nodeName = null
)
Public Sub Write (
    value As String,
    Optional nodeName As String = Nothing
)
public:
void Write(
    String^ value,
    String^ nodeName = nullptr
)
member Write :
        value : string *
        ?nodeName : string
(* Defaults:
        let _nodeName = defaultArg nodeName null
*)
-> unit

Parameters

value
Type: SystemString
The value to be written to the file storage
nodeName (Optional)
Type: SystemString
The name of the node.
See Also

Reference

FileStorage Class
Write Overload
Emgu.CV Namespace


FileStorage.Write Method (Mat, String)

FileStorageWrite Method (Mat, String)

http://www.emgu.com
Writes the specified Mat to the node with the specific name.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    Mat m,
    string nodeName = null
)
Public Sub Write (
    m As Mat,
    Optional nodeName As String = Nothing
)
public:
void Write(
    Mat^ m,
    String^ nodeName = nullptr
)
member Write :
        m : Mat *
        ?nodeName : string
(* Defaults:
        let _nodeName = defaultArg nodeName null
*)
-> unit

Parameters

m
Type: Emgu.CVMat
The Mat to be written to the file storage
nodeName (Optional)
Type: SystemString
The name of the node.
See Also

Reference

FileStorage Class
Write Overload
Emgu.CV Namespace


FileStorage Fields

The FileStorage type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FileStorage Class
Emgu.CV Namespace


FileStorage.Mode Class

FileStorageMode Class

File storage mode
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVFileStorageMode

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class Mode : Enum
<FlagsAttribute>
Public NotInheritable Class Mode
    Inherits Enum
[FlagsAttribute]
public ref class Mode sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type Mode =
    class
        inherit Enum
    end

The FileStorageMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Append | Open the file for appending
 | Base64 | Write rawdata in Base64 by default. (consider using WriteBase64)
 | FormatAuto | Auto format
 | FormatJson | JSON format
 | FormatMask | Mask for format flags
 | FormatXml | XML format
 | FormatYaml | YAML format
 | Memory | ReadMat data from source or write data to the internal buffer
 | Read | Open the file for reading
Public field | value__ |
 | Write | Open the file for writing
 | WriteBase64 | enable both Write and Base64
Top
See Also

Reference

Emgu.CV Namespace


Mode Methods

The FileStorageMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


Mode Fields

The FileStorageMode type exposes the following members.

Fields
 | Name | Description
 | Append | Open the file for appending
 | Base64 | Write rawdata in Base64 by default. (consider using WriteBase64)
 | FormatAuto | Auto format
 | FormatJson | JSON format
 | FormatMask | Mask for format flags
 | FormatXml | XML format
 | FormatYaml | YAML format
 | Memory | ReadMat data from source or write data to the internal buffer
 | Read | Open the file for reading
Public field | value__ |
 | Write | Open the file for writing
 | WriteBase64 | enable both Write and Base64
Top
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.Append Field

FileStorageModeAppend Field

Open the file for appending

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode Append = 2
Public Const Append As FileStorageMode = 2
public:
literal FileStorageMode^ Append = 2
static val mutable Append: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.Base64 Field

FileStorageModeBase64 Field

Write rawdata in Base64 by default. (consider using WriteBase64)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode Base64 = 64
Public Const Base64 As FileStorageMode = 64
public:
literal FileStorageMode^ Base64 = 64
static val mutable Base64: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.FormatAuto Field

FileStorageModeFormatAuto Field

Auto format

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode FormatAuto = 0
Public Const FormatAuto As FileStorageMode = 0
public:
literal FileStorageMode^ FormatAuto = 0
static val mutable FormatAuto: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.FormatJson Field

FileStorageModeFormatJson Field

JSON format

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode FormatJson = 24
Public Const FormatJson As FileStorageMode = 24
public:
literal FileStorageMode^ FormatJson = 24
static val mutable FormatJson: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.FormatMask Field

FileStorageModeFormatMask Field

Mask for format flags

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode FormatMask = 56
Public Const FormatMask As FileStorageMode = 56
public:
literal FileStorageMode^ FormatMask = 56
static val mutable FormatMask: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.FormatXml Field

FileStorageModeFormatXml Field

XML format

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode FormatXml = 8
Public Const FormatXml As FileStorageMode = 8
public:
literal FileStorageMode^ FormatXml = 8
static val mutable FormatXml: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.FormatYaml Field

FileStorageModeFormatYaml Field

YAML format

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode FormatYaml = 16
Public Const FormatYaml As FileStorageMode = 16
public:
literal FileStorageMode^ FormatYaml = 16
static val mutable FormatYaml: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.Memory Field

FileStorageModeMemory Field

ReadMat data from source or write data to the internal buffer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode Memory = 4
Public Const Memory As FileStorageMode = 4
public:
literal FileStorageMode^ Memory = 4
static val mutable Memory: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.Read Field

FileStorageModeRead Field

Open the file for reading

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode Read = 0
Public Const Read As FileStorageMode = 0
public:
literal FileStorageMode^ Read = 0
static val mutable Read: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.value__ Field

FileStorageModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.FileStorage.Mode.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.Write Field

FileStorageModeWrite Field

Open the file for writing

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode Write = 1
Public Const Write As FileStorageMode = 1
public:
literal FileStorageMode^ Write = 1
static val mutable Write: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


FileStorage.Mode.WriteBase64 Field

FileStorageModeWriteBase64 Field

enable both Write and Base64

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FileStorageMode WriteBase64 = 65
Public Const WriteBase64 As FileStorageMode = 65
public:
literal FileStorageMode^ WriteBase64 = 65
static val mutable WriteBase64: FileStorageMode

Field Value

Type: FileStorageMode
See Also

Reference

FileStorageMode Class
Emgu.CV Namespace


Fisheye Class

Fisheye Camera model
Inheritance Hierarchy
SystemObject
Emgu.CVFisheye

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class Fisheye
Public NotInheritable Class Fisheye
public ref class Fisheye abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Fisheye =  class end

The Fisheye type exposes the following members.

Methods
Name | Description
Calibrate | Performs camera calibaration.
DistortPoints | Distorts 2D points using fisheye model.
EstimateNewCameraMatrixForUndistorRectify | Estimates new camera matrix for undistortion or rectification.
InitUndistorRectifyMap | Computes undistortion and rectification maps for image transform by cv::remap(). If D is empty zero distortion is used, if R or P is empty identity matrixes are used.
ProjectPoints | Projects points using fisheye model. The function computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes Jacobians - matrices of partial derivatives of image points coordinates (as functions of all the input parameters) with respect to the particular parameters, intrinsic and/or extrinsic.
StereoCalibrate | Performs stereo calibration.
SteteoRectify | Stereo rectification for fisheye camera model.
UndistorImage | Transforms an image to compensate for fisheye lens distortion. The function is simply a combination of fisheye::initUndistortRectifyMap (with unity R ) and remap (with bilinear interpolation).
UndistorPoints | Transforms an image to compensate for fisheye lens distortion.
Top
See Also

Reference

Emgu.CV Namespace


Fisheye Methods

The Fisheye type exposes the following members.

Methods
Name | Description
Calibrate | Performs camera calibaration.
DistortPoints | Distorts 2D points using fisheye model.
EstimateNewCameraMatrixForUndistorRectify | Estimates new camera matrix for undistortion or rectification.
InitUndistorRectifyMap | Computes undistortion and rectification maps for image transform by cv::remap(). If D is empty zero distortion is used, if R or P is empty identity matrixes are used.
ProjectPoints | Projects points using fisheye model. The function computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes Jacobians - matrices of partial derivatives of image points coordinates (as functions of all the input parameters) with respect to the particular parameters, intrinsic and/or extrinsic.
StereoCalibrate | Performs stereo calibration.
SteteoRectify | Stereo rectification for fisheye camera model.
UndistorImage | Transforms an image to compensate for fisheye lens distortion. The function is simply a combination of fisheye::initUndistortRectifyMap (with unity R ) and remap (with bilinear interpolation).
UndistorPoints | Transforms an image to compensate for fisheye lens distortion.
Top
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.Calibrate Method

FisheyeCalibrate Method

Performs camera calibaration.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Calibrate(
    IInputArray objectPoints,
    IInputArray imagePoints,
    Size imageSize,
    IInputOutputArray K,
    IInputOutputArray D,
    IOutputArray rvecs,
    IOutputArray tvecs,
    FisheyeCalibrationFlag flags,
    MCvTermCriteria criteria
)
Public Shared Sub Calibrate (
    objectPoints As IInputArray,
    imagePoints As IInputArray,
    imageSize As Size,
    K As IInputOutputArray,
    D As IInputOutputArray,
    rvecs As IOutputArray,
    tvecs As IOutputArray,
    flags As FisheyeCalibrationFlag,
    criteria As MCvTermCriteria
)
public:
static void Calibrate(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints,
    Size^ imageSize,
    IInputOutputArray^ K,
    IInputOutputArray^ D,
    IOutputArray^ rvecs,
    IOutputArray^ tvecs,
    FisheyeCalibrationFlag^ flags,
    MCvTermCriteria^ criteria
)
static member Calibrate :
        objectPoints : IInputArray *
        imagePoints : IInputArray *
        imageSize : Size *
        K : IInputOutputArray *
        D : IInputOutputArray *
        rvecs : IOutputArray *
        tvecs : IOutputArray *
        flags : FisheyeCalibrationFlag *
        criteria : MCvTermCriteria -> unit

Parameters

objectPoints
Type: Emgu.CVIInputArray
vector of vectors of calibration pattern points in the calibration pattern coordinate space.
imagePoints
Type: Emgu.CVIInputArray
vector of vectors of the projections of calibration pattern points. imagePoints.size() and objectPoints.size() and imagePoints[i].size() must be equal to objectPoints[i].size() for each i.
imageSize
Type: System.DrawingSize
Size of the image used only to initialize the intrinsic camera matrix.
K
Type: Emgu.CVIInputOutputArray
Output 3x3 floating-point camera matrix. If UseIntrisicGuess is specified, some or all of fx, fy, cx, cy must be initialized before calling the function.
D
Type: Emgu.CVIInputOutputArray
Output vector of distortion coefficients (k1,k2,k3,k4).
rvecs
Type: Emgu.CVIOutputArray
Output vector of rotation vectors (see Rodrigues ) estimated for each pattern view. That is, each k-th rotation vector together with the corresponding k-th translation vector (see the next output parameter description) brings the calibration pattern from the model coordinate space (in which object points are specified) to the world coordinate space, that is, a real position of the calibration pattern in the k-th pattern view (k=0.. M -1).
tvecs
Type: Emgu.CVIOutputArray
Output vector of translation vectors estimated for each pattern view.
flags
Type: Emgu.CVFisheyeCalibrationFlag
Different flags
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.DistortPoints Method

FisheyeDistortPoints Method

Distorts 2D points using fisheye model.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DistortPoints(
    IInputArray undistored,
    IOutputArray distorted,
    IInputArray K,
    IInputArray D,
    double alpha = 0
)
Public Shared Sub DistortPoints (
    undistored As IInputArray,
    distorted As IOutputArray,
    K As IInputArray,
    D As IInputArray,
    Optional alpha As Double = 0
)
public:
static void DistortPoints(
    IInputArray^ undistored,
    IOutputArray^ distorted,
    IInputArray^ K,
    IInputArray^ D,
    double alpha = 0
)
static member DistortPoints :
        undistored : IInputArray *
        distorted : IOutputArray *
        K : IInputArray *
        D : IInputArray *
        ?alpha : float
(* Defaults:
        let _alpha = defaultArg alpha 0
*)
-> unit

Parameters

undistored
Type: Emgu.CVIInputArray
Array of object points, 1xN/Nx1 2-channel (or vector<Point2f> ), where N is the number of points in the view.
distorted
Type: Emgu.CVIOutputArray
Output array of image points, 1xN/Nx1 2-channel, or vector<Point2f> .
K
Type: Emgu.CVIInputArray
Camera matrix
D
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,k3,k4).
alpha (Optional)
Type: SystemDouble
The skew coefficient.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.EstimateNewCameraMatrixForUndistorRectify Method

FisheyeEstimateNewCameraMatrixForUndistorRectify Method

Estimates new camera matrix for undistortion or rectification.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void EstimateNewCameraMatrixForUndistorRectify(
    IInputArray K,
    IInputArray D,
    Size imageSize,
    IInputArray R,
    IOutputArray P,
    double balance = 0,
    Size newSize = null,
    double fovScale = 1
)
Public Shared Sub EstimateNewCameraMatrixForUndistorRectify (
    K As IInputArray,
    D As IInputArray,
    imageSize As Size,
    R As IInputArray,
    P As IOutputArray,
    Optional balance As Double = 0,
    Optional newSize As Size = Nothing,
    Optional fovScale As Double = 1
)
public:
static void EstimateNewCameraMatrixForUndistorRectify(
    IInputArray^ K,
    IInputArray^ D,
    Size^ imageSize,
    IInputArray^ R,
    IOutputArray^ P,
    double balance = 0,
    Size^ newSize = nullptr,
    double fovScale = 1
)
static member EstimateNewCameraMatrixForUndistorRectify :
        K : IInputArray *
        D : IInputArray *
        imageSize : Size *
        R : IInputArray *
        P : IOutputArray *
        ?balance : float *
        ?newSize : Size *
        ?fovScale : float
(* Defaults:
        let _balance = defaultArg balance 0
        let _newSize = defaultArg newSize null
        let _fovScale = defaultArg fovScale 1
*)
-> unit

Parameters

K
Type: Emgu.CVIInputArray
Camera matrix
D
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,k3,k4).
imageSize
Type: System.DrawingSize

[Missing <param name="imageSize"/> documentation for "M:Emgu.CV.Fisheye.EstimateNewCameraMatrixForUndistorRectify(Emgu.CV.IInputArray,Emgu.CV.IInputArray,System.Drawing.Size,Emgu.CV.IInputArray,Emgu.CV.IOutputArray,System.Double,System.Drawing.Size,System.Double)"]

R
Type: Emgu.CVIInputArray
Rectification transformation in the object space: 3x3 1-channel, or vector: 3x1/1x3 1-channel or 1x1 3-channel
P
Type: Emgu.CVIOutputArray
New camera matrix (3x3) or new projection matrix (3x4)
balance (Optional)
Type: SystemDouble
Sets the new focal length in range between the min focal length and the max focal length. Balance is in range of [0, 1]
newSize (Optional)
Type: System.DrawingSize

[Missing <param name="newSize"/> documentation for "M:Emgu.CV.Fisheye.EstimateNewCameraMatrixForUndistorRectify(Emgu.CV.IInputArray,Emgu.CV.IInputArray,System.Drawing.Size,Emgu.CV.IInputArray,Emgu.CV.IOutputArray,System.Double,System.Drawing.Size,System.Double)"]

fovScale (Optional)
Type: SystemDouble
Divisor for new focal length.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.InitUndistorRectifyMap Method

FisheyeInitUndistorRectifyMap Method

Computes undistortion and rectification maps for image transform by cv::remap(). If D is empty zero distortion is used, if R or P is empty identity matrixes are used.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void InitUndistorRectifyMap(
    IInputArray K,
    IInputArray D,
    IInputArray R,
    IInputArray P,
    Size size,
    DepthType m1Type,
    IOutputArray map1,
    IOutputArray map2
)
Public Shared Sub InitUndistorRectifyMap (
    K As IInputArray,
    D As IInputArray,
    R As IInputArray,
    P As IInputArray,
    size As Size,
    m1Type As DepthType,
    map1 As IOutputArray,
    map2 As IOutputArray
)
public:
static void InitUndistorRectifyMap(
    IInputArray^ K,
    IInputArray^ D,
    IInputArray^ R,
    IInputArray^ P,
    Size^ size,
    DepthType^ m1Type,
    IOutputArray^ map1,
    IOutputArray^ map2
)
static member InitUndistorRectifyMap :
        K : IInputArray *
        D : IInputArray *
        R : IInputArray *
        P : IInputArray *
        size : Size *
        m1Type : DepthType *
        map1 : IOutputArray *
        map2 : IOutputArray -> unit

Parameters

K
Type: Emgu.CVIInputArray
Camera matrix
D
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,k3,k4).
R
Type: Emgu.CVIInputArray
Rectification transformation in the object space: 3x3 1-channel, or vector: 3x1/1x3 1-channel or 1x1 3-channel
P
Type: Emgu.CVIInputArray
New camera matrix (3x3) or new projection matrix (3x4)
size
Type: System.DrawingSize
Undistorted image size.
m1Type
Type: Emgu.CV.CvEnumDepthType
Type of the first output map that can be CV_32FC1 or CV_16SC2 . See convertMaps() for details.
map1
Type: Emgu.CVIOutputArray
The first output map.
map2
Type: Emgu.CVIOutputArray
The second output map.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.ProjectPoints Method

FisheyeProjectPoints Method

Projects points using fisheye model. The function computes projections of 3D points to the image plane given intrinsic and extrinsic camera parameters. Optionally, the function computes Jacobians - matrices of partial derivatives of image points coordinates (as functions of all the input parameters) with respect to the particular parameters, intrinsic and/or extrinsic.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ProjectPoints(
    IInputArray objectPoints,
    IOutputArray imagePoints,
    IInputArray rvec,
    IInputArray tvec,
    IInputArray K,
    IInputArray D,
    double alpha = 0,
    IOutputArray jacobian = null
)
Public Shared Sub ProjectPoints (
    objectPoints As IInputArray,
    imagePoints As IOutputArray,
    rvec As IInputArray,
    tvec As IInputArray,
    K As IInputArray,
    D As IInputArray,
    Optional alpha As Double = 0,
    Optional jacobian As IOutputArray = Nothing
)
public:
static void ProjectPoints(
    IInputArray^ objectPoints,
    IOutputArray^ imagePoints,
    IInputArray^ rvec,
    IInputArray^ tvec,
    IInputArray^ K,
    IInputArray^ D,
    double alpha = 0,
    IOutputArray^ jacobian = nullptr
)
static member ProjectPoints :
        objectPoints : IInputArray *
        imagePoints : IOutputArray *
        rvec : IInputArray *
        tvec : IInputArray *
        K : IInputArray *
        D : IInputArray *
        ?alpha : float *
        ?jacobian : IOutputArray
(* Defaults:
        let _alpha = defaultArg alpha 0
        let _jacobian = defaultArg jacobian null
*)
-> unit

Parameters

objectPoints
Type: Emgu.CVIInputArray
Array of object points, 1xN/Nx1 3-channel (or vector<Point3f> ), where N is the number of points in the view.
imagePoints
Type: Emgu.CVIOutputArray
Output array of image points, 2xN/Nx2 1-channel or 1xN/Nx1 2-channel, or vector<Point2f>.
rvec
Type: Emgu.CVIInputArray
rotation vector
tvec
Type: Emgu.CVIInputArray
translation vector
K
Type: Emgu.CVIInputArray
Camera matrix
D
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,k3,k4).
alpha (Optional)
Type: SystemDouble
The skew coefficient.
jacobian (Optional)
Type: Emgu.CVIOutputArray
Optional output 2Nx15 jacobian matrix of derivatives of image points with respect to components of the focal lengths, coordinates of the principal point, distortion coefficients, rotation vector, translation vector, and the skew. In the old interface different components of the jacobian are returned via different output parameters.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.StereoCalibrate Method

FisheyeStereoCalibrate Method

Performs stereo calibration.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void StereoCalibrate(
    IInputArray objectPoints,
    IInputArray imagePoints1,
    IInputArray imagePoints2,
    IInputOutputArray K1,
    IInputOutputArray D1,
    IInputOutputArray K2,
    IInputOutputArray D2,
    Size imageSize,
    IOutputArray R,
    IOutputArray T,
    FisheyeCalibrationFlag flags,
    MCvTermCriteria criteria
)
Public Shared Sub StereoCalibrate (
    objectPoints As IInputArray,
    imagePoints1 As IInputArray,
    imagePoints2 As IInputArray,
    K1 As IInputOutputArray,
    D1 As IInputOutputArray,
    K2 As IInputOutputArray,
    D2 As IInputOutputArray,
    imageSize As Size,
    R As IOutputArray,
    T As IOutputArray,
    flags As FisheyeCalibrationFlag,
    criteria As MCvTermCriteria
)
public:
static void StereoCalibrate(
    IInputArray^ objectPoints,
    IInputArray^ imagePoints1,
    IInputArray^ imagePoints2,
    IInputOutputArray^ K1,
    IInputOutputArray^ D1,
    IInputOutputArray^ K2,
    IInputOutputArray^ D2,
    Size^ imageSize,
    IOutputArray^ R,
    IOutputArray^ T,
    FisheyeCalibrationFlag^ flags,
    MCvTermCriteria^ criteria
)
static member StereoCalibrate :
        objectPoints : IInputArray *
        imagePoints1 : IInputArray *
        imagePoints2 : IInputArray *
        K1 : IInputOutputArray *
        D1 : IInputOutputArray *
        K2 : IInputOutputArray *
        D2 : IInputOutputArray *
        imageSize : Size *
        R : IOutputArray *
        T : IOutputArray *
        flags : FisheyeCalibrationFlag *
        criteria : MCvTermCriteria -> unit

Parameters

objectPoints
Type: Emgu.CVIInputArray
Vector of vectors of the calibration pattern points.
imagePoints1
Type: Emgu.CVIInputArray
Vector of vectors of the projections of the calibration pattern points, observed by the first camera.
imagePoints2
Type: Emgu.CVIInputArray
Vector of vectors of the projections of the calibration pattern points, observed by the second camera.
K1
Type: Emgu.CVIInputOutputArray
Input/output first camera matrix.If FixIntrinsic is specified, some or all of the matrix components must be initialized.
D1
Type: Emgu.CVIInputOutputArray
Input/output vector of distortion coefficients (k1,k2,k3,k4) of 4 elements.
K2
Type: Emgu.CVIInputOutputArray
Input/output second camera matrix. The parameter is similar to K1
D2
Type: Emgu.CVIInputOutputArray
Input/output lens distortion coefficients for the second camera. The parameter is similar to D1
imageSize
Type: System.DrawingSize
Size of the image used only to initialize intrinsic camera matrix.
R
Type: Emgu.CVIOutputArray
Output rotation matrix between the 1st and the 2nd camera coordinate systems.
T
Type: Emgu.CVIOutputArray
Output translation vector between the coordinate systems of the cameras.
flags
Type: Emgu.CVFisheyeCalibrationFlag
Fish eye calibration flags
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.SteteoRectify Method

FisheyeSteteoRectify Method

Stereo rectification for fisheye camera model.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SteteoRectify(
    IInputArray K1,
    IInputArray D1,
    IInputArray K2,
    IInputArray D2,
    Size imageSize,
    IInputArray R,
    IInputArray tvec,
    IOutputArray R1,
    IOutputArray R2,
    IOutputArray P1,
    IOutputArray P2,
    IOutputArray Q,
    int flags,
    Size newImageSize = null,
    double balance = 0,
    double fovScale = 1
)
Public Shared Sub SteteoRectify (
    K1 As IInputArray,
    D1 As IInputArray,
    K2 As IInputArray,
    D2 As IInputArray,
    imageSize As Size,
    R As IInputArray,
    tvec As IInputArray,
    R1 As IOutputArray,
    R2 As IOutputArray,
    P1 As IOutputArray,
    P2 As IOutputArray,
    Q As IOutputArray,
    flags As Integer,
    Optional newImageSize As Size = Nothing,
    Optional balance As Double = 0,
    Optional fovScale As Double = 1
)
public:
static void SteteoRectify(
    IInputArray^ K1,
    IInputArray^ D1,
    IInputArray^ K2,
    IInputArray^ D2,
    Size^ imageSize,
    IInputArray^ R,
    IInputArray^ tvec,
    IOutputArray^ R1,
    IOutputArray^ R2,
    IOutputArray^ P1,
    IOutputArray^ P2,
    IOutputArray^ Q,
    int flags,
    Size^ newImageSize = nullptr,
    double balance = 0,
    double fovScale = 1
)
static member SteteoRectify :
        K1 : IInputArray *
        D1 : IInputArray *
        K2 : IInputArray *
        D2 : IInputArray *
        imageSize : Size *
        R : IInputArray *
        tvec : IInputArray *
        R1 : IOutputArray *
        R2 : IOutputArray *
        P1 : IOutputArray *
        P2 : IOutputArray *
        Q : IOutputArray *
        flags : int *
        ?newImageSize : Size *
        ?balance : float *
        ?fovScale : float
(* Defaults:
        let _newImageSize = defaultArg newImageSize null
        let _balance = defaultArg balance 0
        let _fovScale = defaultArg fovScale 1
*)
-> unit

Parameters

K1
Type: Emgu.CVIInputArray
First camera matrix.
D1
Type: Emgu.CVIInputArray
First camera distortion parameters.
K2
Type: Emgu.CVIInputArray
Second camera matrix.
D2
Type: Emgu.CVIInputArray
Second camera distortion parameters.
imageSize
Type: System.DrawingSize
Size of the image used for stereo calibration.
R
Type: Emgu.CVIInputArray
Rotation matrix between the coordinate systems of the first and the second cameras.
tvec
Type: Emgu.CVIInputArray
Translation vector between coordinate systems of the cameras.
R1
Type: Emgu.CVIOutputArray
Output 3x3 rectification transform (rotation matrix) for the first camera.
R2
Type: Emgu.CVIOutputArray
Output 3x3 rectification transform (rotation matrix) for the second camera.
P1
Type: Emgu.CVIOutputArray
Output 3x4 projection matrix in the new (rectified) coordinate systems for the first camera.
P2
Type: Emgu.CVIOutputArray
Output 3x4 projection matrix in the new (rectified) coordinate systems for the second camera.
Q
Type: Emgu.CVIOutputArray
Output 4×4 disparity-to-depth mapping matrix (see reprojectImageTo3D ).
flags
Type: SystemInt32
Operation flags that may be zero or ZeroDisparity . If the flag is set, the function makes the principal points of each camera have the same pixel coordinates in the rectified views. And if the flag is not set, the function may still shift the images in the horizontal or vertical direction (depending on the orientation of epipolar lines) to maximize the useful image area.
newImageSize (Optional)
Type: System.DrawingSize
New image resolution after rectification. The same size should be passed to initUndistortRectifyMap. When (0,0) is passed (default), it is set to the original imageSize . Setting it to larger value can help you preserve details in the original image, especially when there is a big radial distortion.
balance (Optional)
Type: SystemDouble
Sets the new focal length in range between the min focal length and the max focal length. Balance is in range of [0, 1].
fovScale (Optional)
Type: SystemDouble
Divisor for new focal length.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.UndistorImage Method

FisheyeUndistorImage Method

Transforms an image to compensate for fisheye lens distortion. The function is simply a combination of fisheye::initUndistortRectifyMap (with unity R ) and remap (with bilinear interpolation).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void UndistorImage(
    IInputArray distorted,
    IOutputArray undistored,
    IInputArray K,
    IInputArray D,
    IInputArray Knew = null,
    Size newSize = null
)
Public Shared Sub UndistorImage (
    distorted As IInputArray,
    undistored As IOutputArray,
    K As IInputArray,
    D As IInputArray,
    Optional Knew As IInputArray = Nothing,
    Optional newSize As Size = Nothing
)
public:
static void UndistorImage(
    IInputArray^ distorted,
    IOutputArray^ undistored,
    IInputArray^ K,
    IInputArray^ D,
    IInputArray^ Knew = nullptr,
    Size^ newSize = nullptr
)
static member UndistorImage :
        distorted : IInputArray *
        undistored : IOutputArray *
        K : IInputArray *
        D : IInputArray *
        ?Knew : IInputArray *
        ?newSize : Size
(* Defaults:
        let _Knew = defaultArg Knew null
        let _newSize = defaultArg newSize null
*)
-> unit

Parameters

distorted
Type: Emgu.CVIInputArray
Image with fisheye lens distortion.
undistored
Type: Emgu.CVIOutputArray
Output image with compensated fisheye lens distortion.
K
Type: Emgu.CVIInputArray
Camera matrix
D
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,k3,k4).
Knew (Optional)
Type: Emgu.CVIInputArray
Camera matrix of the distorted image. By default, it is the identity matrix but you may additionally scale and shift the result by using a different matrix.
newSize (Optional)
Type: System.DrawingSize
The function transforms an image to compensate radial and tangential lens distortion.
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.UndistorPoints Method

FisheyeUndistorPoints Method

Transforms an image to compensate for fisheye lens distortion.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void UndistorPoints(
    IInputArray distorted,
    IOutputArray undistorted,
    IInputArray K,
    IInputArray D,
    IInputArray R = null,
    IInputArray P = null
)
Public Shared Sub UndistorPoints (
    distorted As IInputArray,
    undistorted As IOutputArray,
    K As IInputArray,
    D As IInputArray,
    Optional R As IInputArray = Nothing,
    Optional P As IInputArray = Nothing
)
public:
static void UndistorPoints(
    IInputArray^ distorted,
    IOutputArray^ undistorted,
    IInputArray^ K,
    IInputArray^ D,
    IInputArray^ R = nullptr,
    IInputArray^ P = nullptr
)
static member UndistorPoints :
        distorted : IInputArray *
        undistorted : IOutputArray *
        K : IInputArray *
        D : IInputArray *
        ?R : IInputArray *
        ?P : IInputArray
(* Defaults:
        let _R = defaultArg R null
        let _P = defaultArg P null
*)
-> unit

Parameters

distorted
Type: Emgu.CVIInputArray
Array of object points, 1xN/Nx1 2-channel (or vector<Point2f> ), where N is the number of points in the view.
undistorted
Type: Emgu.CVIOutputArray
Output array of image points, 1xN/Nx1 2-channel, or vector<Point2f>.
K
Type: Emgu.CVIInputArray
Camera matrix
D
Type: Emgu.CVIInputArray
Input vector of distortion coefficients (k1,k2,k3,k4).
R (Optional)
Type: Emgu.CVIInputArray
Rectification transformation in the object space: 3x3 1-channel, or vector: 3x1/1x3 1-channel or 1x1 3-channel
P (Optional)
Type: Emgu.CVIInputArray
New camera matrix (3x3) or new projection matrix (3x4)
See Also

Reference

Fisheye Class
Emgu.CV Namespace


Fisheye.CalibrationFlag Class

FisheyeCalibrationFlag Class

Fisheye calibration flag.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVFisheyeCalibrationFlag

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CalibrationFlag : Enum
Public NotInheritable Class CalibrationFlag
    Inherits Enum
public ref class CalibrationFlag sealed : public Enum
[<SealedAttribute>]
type CalibrationFlag =
    class
        inherit Enum
    end

The FisheyeCalibrationFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CheckCond | The functions will check validity of condition number.
 | Default | Default flag
 | FixIntrinsic | Fix intrinsic
 | FixK1 | Selected distortion coefficients are set to zeros and stay zero.
 | FixK2 | Selected distortion coefficients are set to zeros and stay zero.
 | FixK3 | Selected distortion coefficients are set to zeros and stay zero.
 | FixK4 | Selected distortion coefficients are set to zeros and stay zero.
 | FixSkew | Skew coefficient (alpha) is set to zero and stay zero.
 | RecomputeExtrinsic | Extrinsic will be recomputed after each iteration of intrinsic optimization.
 | UseIntrinsicGuess | cameraMatrix contains valid initial values of fx, fy, cx, cy that are optimized further. Otherwise, (cx, cy) is initially set to the image center ( imageSize is used), and focal distances are computed in a least-squares fashion.
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


CalibrationFlag Methods

The FisheyeCalibrationFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


CalibrationFlag Fields

The FisheyeCalibrationFlag type exposes the following members.

Fields
 | Name | Description
 | CheckCond | The functions will check validity of condition number.
 | Default | Default flag
 | FixIntrinsic | Fix intrinsic
 | FixK1 | Selected distortion coefficients are set to zeros and stay zero.
 | FixK2 | Selected distortion coefficients are set to zeros and stay zero.
 | FixK3 | Selected distortion coefficients are set to zeros and stay zero.
 | FixK4 | Selected distortion coefficients are set to zeros and stay zero.
 | FixSkew | Skew coefficient (alpha) is set to zero and stay zero.
 | RecomputeExtrinsic | Extrinsic will be recomputed after each iteration of intrinsic optimization.
 | UseIntrinsicGuess | cameraMatrix contains valid initial values of fx, fy, cx, cy that are optimized further. Otherwise, (cx, cy) is initially set to the image center ( imageSize is used), and focal distances are computed in a least-squares fashion.
Public field | value__ |
Top
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.CheckCond Field

FisheyeCalibrationFlagCheckCond Field

The functions will check validity of condition number.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag CheckCond = 4
Public Const CheckCond As FisheyeCalibrationFlag = 4
public:
literal FisheyeCalibrationFlag^ CheckCond = 4
static val mutable CheckCond: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.Default Field

FisheyeCalibrationFlagDefault Field

Default flag

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag Default = 0
Public Const Default As FisheyeCalibrationFlag = 0
public:
literal FisheyeCalibrationFlag^ Default = 0
static val mutable Default: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.FixIntrinsic Field

FisheyeCalibrationFlagFixIntrinsic Field

Fix intrinsic

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag FixIntrinsic = 256
Public Const FixIntrinsic As FisheyeCalibrationFlag = 256
public:
literal FisheyeCalibrationFlag^ FixIntrinsic = 256
static val mutable FixIntrinsic: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.FixK1 Field

FisheyeCalibrationFlagFixK1 Field

Selected distortion coefficients are set to zeros and stay zero.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag FixK1 = 16
Public Const FixK1 As FisheyeCalibrationFlag = 16
public:
literal FisheyeCalibrationFlag^ FixK1 = 16
static val mutable FixK1: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.FixK2 Field

FisheyeCalibrationFlagFixK2 Field

Selected distortion coefficients are set to zeros and stay zero.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag FixK2 = 32
Public Const FixK2 As FisheyeCalibrationFlag = 32
public:
literal FisheyeCalibrationFlag^ FixK2 = 32
static val mutable FixK2: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.FixK3 Field

FisheyeCalibrationFlagFixK3 Field

Selected distortion coefficients are set to zeros and stay zero.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag FixK3 = 64
Public Const FixK3 As FisheyeCalibrationFlag = 64
public:
literal FisheyeCalibrationFlag^ FixK3 = 64
static val mutable FixK3: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.FixK4 Field

FisheyeCalibrationFlagFixK4 Field

Selected distortion coefficients are set to zeros and stay zero.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag FixK4 = 128
Public Const FixK4 As FisheyeCalibrationFlag = 128
public:
literal FisheyeCalibrationFlag^ FixK4 = 128
static val mutable FixK4: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.FixSkew Field

FisheyeCalibrationFlagFixSkew Field

Skew coefficient (alpha) is set to zero and stay zero.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag FixSkew = 8
Public Const FixSkew As FisheyeCalibrationFlag = 8
public:
literal FisheyeCalibrationFlag^ FixSkew = 8
static val mutable FixSkew: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.RecomputeExtrinsic Field

FisheyeCalibrationFlagRecomputeExtrinsic Field

Extrinsic will be recomputed after each iteration of intrinsic optimization.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag RecomputeExtrinsic = 2
Public Const RecomputeExtrinsic As FisheyeCalibrationFlag = 2
public:
literal FisheyeCalibrationFlag^ RecomputeExtrinsic = 2
static val mutable RecomputeExtrinsic: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.UseIntrinsicGuess Field

FisheyeCalibrationFlagUseIntrinsicGuess Field

cameraMatrix contains valid initial values of fx, fy, cx, cy that are optimized further. Otherwise, (cx, cy) is initially set to the image center ( imageSize is used), and focal distances are computed in a least-squares fashion.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FisheyeCalibrationFlag UseIntrinsicGuess = 1
Public Const UseIntrinsicGuess As FisheyeCalibrationFlag = 1
public:
literal FisheyeCalibrationFlag^ UseIntrinsicGuess = 1
static val mutable UseIntrinsicGuess: FisheyeCalibrationFlag

Field Value

Type: FisheyeCalibrationFlag
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


Fisheye.CalibrationFlag.value__ Field

FisheyeCalibrationFlagvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Fisheye.CalibrationFlag.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FisheyeCalibrationFlag Class
Emgu.CV Namespace


HOGDescriptor Class

A HOG descriptor
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVHOGDescriptor

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class HOGDescriptor : UnmanagedObject
Public Class HOGDescriptor
    Inherits UnmanagedObject
public ref class HOGDescriptor : public UnmanagedObject
type HOGDescriptor =
    class
        inherit UnmanagedObject
    end

The HOGDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | HOGDescriptor | Create a new HOGDescriptor
Public method | HOGDescriptor(Size, Size, Size, Size, Int32, Int32, Double, Double, Boolean) | Create a new HOGDescriptor using the specific parameters.
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the size of the descriptor
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compute | Computes HOG descriptors of given image.
Public method | DetectMultiScale | Performs object detection with increasing detection window.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this HOGDescriptor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
 | GetDefaultPeopleDetector | Return the default people detector
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetSVMDetector | Set the SVM detector
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


HOGDescriptor Constructor

Overload List
 | Name | Description
Public method | HOGDescriptor | Create a new HOGDescriptor
Public method | HOGDescriptor(Size, Size, Size, Size, Int32, Int32, Double, Double, Boolean) | Create a new HOGDescriptor using the specific parameters.
Top
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor Constructor

Create a new HOGDescriptor

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public HOGDescriptor()
Public Sub New
public:
HOGDescriptor()
new : unit -> HOGDescriptor
See Also

Reference

HOGDescriptor Class
HOGDescriptor Overload
Emgu.CV Namespace


HOGDescriptor Constructor (Size, Size, Size, Size, Int32, Int32, Double, Double, Boolean)

Create a new HOGDescriptor using the specific parameters.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public HOGDescriptor(
    Size winSize,
    Size blockSize,
    Size blockStride,
    Size cellSize,
    int nbins = 9,
    int derivAperture = 1,
    double winSigma = -1,
    double L2HysThreshold = 0.2,
    bool gammaCorrection = true
)
Public Sub New (
    winSize As Size,
    blockSize As Size,
    blockStride As Size,
    cellSize As Size,
    Optional nbins As Integer = 9,
    Optional derivAperture As Integer = 1,
    Optional winSigma As Double = -1,
    Optional L2HysThreshold As Double = 0.2,
    Optional gammaCorrection As Boolean = true
)
public:
HOGDescriptor(
    Size^ winSize,
    Size^ blockSize,
    Size^ blockStride,
    Size^ cellSize,
    int nbins = 9,
    int derivAperture = 1,
    double winSigma = -1,
    double L2HysThreshold = 0.2,
    bool gammaCorrection = true
)
new :
        winSize : Size *
        blockSize : Size *
        blockStride : Size *
        cellSize : Size *
        ?nbins : int *
        ?derivAperture : int *
        ?winSigma : float *
        ?L2HysThreshold : float *
        ?gammaCorrection : bool
(* Defaults:
        let _nbins = defaultArg nbins 9
        let _derivAperture = defaultArg derivAperture 1
        let _winSigma = defaultArg winSigma -1
        let _L2HysThreshold = defaultArg L2HysThreshold 0.2
        let _gammaCorrection = defaultArg gammaCorrection true
*)
-> HOGDescriptor

Parameters

winSize
Type: System.DrawingSize
Detection window size. Must be aligned to block size and block stride. Must match the size of the training image. Use (64, 128) for default.
blockSize
Type: System.DrawingSize
Block size in cells. Use (16, 16) for default.
blockStride
Type: System.DrawingSize
Block stride. Must be a multiple of cell size. Use (8,8) for default.
cellSize
Type: System.DrawingSize
Cell size. Use (8, 8) for default.
nbins (Optional)
Type: SystemInt32
Number of bins.
derivAperture (Optional)
Type: SystemInt32
Deriv Aperture
winSigma (Optional)
Type: SystemDouble
Gaussian smoothing window parameter.
L2HysThreshold (Optional)
Type: SystemDouble
L2-Hys normalization method shrinkage.
gammaCorrection (Optional)
Type: SystemBoolean
Do gamma correction preprocessing or not.
See Also

Reference

HOGDescriptor Class
HOGDescriptor Overload
Emgu.CV Namespace


HOGDescriptor Properties

The HOGDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the size of the descriptor
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor.DescriptorSize Property

HOGDescriptorDescriptorSize Property

Get the size of the descriptor

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint DescriptorSize { get; }
Public ReadOnly Property DescriptorSize As UInteger
    Get
public:
property unsigned int DescriptorSize {
    unsigned int get ();
}
member DescriptorSize : uint32 with get

Property Value

Type: UInt32
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor Methods

The HOGDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Computes HOG descriptors of given image.
Public method | DetectMultiScale | Performs object detection with increasing detection window.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this HOGDescriptor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
 | GetDefaultPeopleDetector | Return the default people detector
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetSVMDetector | Set the SVM detector
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor.Compute Method

HOGDescriptorCompute Method

Computes HOG descriptors of given image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float[] Compute(
    IInputArray image,
    Size winStride = null,
    Size padding = null,
    Point[] locations = null
)
Public Function Compute (
    image As IInputArray,
    Optional winStride As Size = Nothing,
    Optional padding As Size = Nothing,
    Optional locations As Point() = Nothing
) As Single()
public:
array<float>^ Compute(
    IInputArray^ image,
    Size^ winStride = nullptr,
    Size^ padding = nullptr,
    array<Point^>^ locations = nullptr
)
member Compute :
        image : IInputArray *
        ?winStride : Size *
        ?padding : Size *
        ?locations : Point[]
(* Defaults:
        let _winStride = defaultArg winStride null
        let _padding = defaultArg padding null
        let _locations = defaultArg locations null
*)
-> float32[]

Parameters

image
Type: Emgu.CVIInputArray
The image
winStride (Optional)
Type: System.DrawingSize
Window stride. Must be a multiple of block stride. Use Size.Empty for default
padding (Optional)
Type: System.DrawingSize
Padding. Use Size.Empty for default
locations (Optional)
Type: System.DrawingPoint
Locations for the computation. Can be null if not needed

Return Value

Type: Single
The descriptor vector
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor.DetectMultiScale Method

HOGDescriptorDetectMultiScale Method

Performs object detection with increasing detection window.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvObjectDetection[] DetectMultiScale(
    IInputArray image,
    double hitThreshold = 0,
    Size winStride = null,
    Size padding = null,
    double scale = 1.05,
    double finalThreshold = 2,
    bool useMeanshiftGrouping = false
)
Public Function DetectMultiScale (
    image As IInputArray,
    Optional hitThreshold As Double = 0,
    Optional winStride As Size = Nothing,
    Optional padding As Size = Nothing,
    Optional scale As Double = 1.05,
    Optional finalThreshold As Double = 2,
    Optional useMeanshiftGrouping As Boolean = false
) As MCvObjectDetection()
public:
array<MCvObjectDetection^>^ DetectMultiScale(
    IInputArray^ image,
    double hitThreshold = 0,
    Size^ winStride = nullptr,
    Size^ padding = nullptr,
    double scale = 1.05,
    double finalThreshold = 2,
    bool useMeanshiftGrouping = false
)
member DetectMultiScale :
        image : IInputArray *
        ?hitThreshold : float *
        ?winStride : Size *
        ?padding : Size *
        ?scale : float *
        ?finalThreshold : float *
        ?useMeanshiftGrouping : bool
(* Defaults:
        let _hitThreshold = defaultArg hitThreshold 0
        let _winStride = defaultArg winStride null
        let _padding = defaultArg padding null
        let _scale = defaultArg scale 1.05
        let _finalThreshold = defaultArg finalThreshold 2
        let _useMeanshiftGrouping = defaultArg useMeanshiftGrouping false
*)
-> MCvObjectDetection[]

Parameters

image
Type: Emgu.CVIInputArray
The image to search in
hitThreshold (Optional)
Type: SystemDouble
Threshold for the distance between features and SVM classifying plane. Usually it is 0 and should be specified in the detector coefficients (as the last free coefficient). But if the free coefficient is omitted (which is allowed), you can specify it manually here.
winStride (Optional)
Type: System.DrawingSize
Window stride. Must be a multiple of block stride.
padding (Optional)
Type: System.DrawingSize
Padding
scale (Optional)
Type: SystemDouble
Coefficient of the detection window increase.
finalThreshold (Optional)
Type: SystemDouble
After detection some objects could be covered by many rectangles. This coefficient regulates similarity threshold. 0 means don't perform grouping. Should be an integer if not using meanshift grouping.
useMeanshiftGrouping (Optional)
Type: SystemBoolean
If true, it will use meanshift grouping.

Return Value

Type: MCvObjectDetection
The regions where positives are found
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor.DisposeObject Method

HOGDescriptorDisposeObject Method

Release the unmanaged memory associated with this HOGDescriptor

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor.GetDefaultPeopleDetector Method

HOGDescriptorGetDefaultPeopleDetector Method

Return the default people detector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static float[] GetDefaultPeopleDetector()
Public Shared Function GetDefaultPeopleDetector As Single()
public:
static array<float>^ GetDefaultPeopleDetector()
static member GetDefaultPeopleDetector : unit -> float32[]

Return Value

Type: Single
The default people detector
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor.SetSVMDetector Method

HOGDescriptorSetSVMDetector Method

Set the SVM detector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetSVMDetector(
    float[] detector
)
Public Sub SetSVMDetector (
    detector As Single()
)
public:
void SetSVMDetector(
    array<float>^ detector
)
member SetSVMDetector :
        detector : float32[] -> unit

Parameters

detector
Type: SystemSingle
The SVM detector
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


HOGDescriptor Fields

The HOGDescriptor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HOGDescriptor Class
Emgu.CV Namespace


IAlgorithm Interface

Interface to the algorithm class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IAlgorithm
Public Interface IAlgorithm
public interface class IAlgorithm
type IAlgorithm =  interface end

The IAlgorithm type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IAlgorithm Properties

The IAlgorithm type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Top
See Also

Reference

IAlgorithm Interface
Emgu.CV Namespace


IAlgorithm.AlgorithmPtr Property

IAlgorithmAlgorithmPtr Property

Return the pointer to the algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr AlgorithmPtr { get; }
ReadOnly Property AlgorithmPtr As IntPtr
    Get
property IntPtr AlgorithmPtr {
    IntPtr get ();
}
abstract AlgorithmPtr : IntPtr with get

Return Value

Type: IntPtr
The pointer to the algorithm object
See Also

Reference

IAlgorithm Interface
Emgu.CV Namespace


IAlgorithm Methods

The IAlgorithm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IAlgorithm Interface
Emgu.CV Namespace


IBackgroundSubtractor Interface

Interface to the BackgroundSubtractor class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IBackgroundSubtractor : IAlgorithm
Public Interface IBackgroundSubtractor
    Inherits IAlgorithm
public interface class IBackgroundSubtractor : IAlgorithm
type IBackgroundSubtractor =
    interface
        interface IAlgorithm
    end

The IBackgroundSubtractor type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | BackgroundSubtractorPtr | Pointer to the native BackgroundSubstractor object
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IBackgroundSubtractor Properties

The IBackgroundSubtractor type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | BackgroundSubtractorPtr | Pointer to the native BackgroundSubstractor object
Top
See Also

Reference

IBackgroundSubtractor Interface
Emgu.CV Namespace


IBackgroundSubtractor.BackgroundSubtractorPtr Property

IBackgroundSubtractorBackgroundSubtractorPtr Property

Pointer to the native BackgroundSubstractor object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr BackgroundSubtractorPtr { get; }
ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
property IntPtr BackgroundSubtractorPtr {
    IntPtr get ();
}
abstract BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IBackgroundSubtractor Interface
Emgu.CV Namespace


IBackgroundSubtractor Methods

The IBackgroundSubtractor type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IBackgroundSubtractor Interface
Emgu.CV Namespace


ICapture Interface

The interface that is used for WCF to provide a image capture service

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface ICapture
Public Interface ICapture
public interface class ICapture
type ICapture =  interface end

The ICapture type exposes the following members.

Methods
 | Name | Description
Public method | QueryFrame | Capture a Bgr image frame
Public method | QuerySmallFrame | Capture a Bgr image frame that is half width and half height
Top
See Also

Reference

Emgu.CV Namespace


ICapture Methods

The ICapture type exposes the following members.

Methods
 | Name | Description
Public method | QueryFrame | Capture a Bgr image frame
Public method | QuerySmallFrame | Capture a Bgr image frame that is half width and half height
Top
See Also

Reference

ICapture Interface
Emgu.CV Namespace


ICapture.QueryFrame Method

ICaptureQueryFrame Method

Capture a Bgr image frame

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
Mat QueryFrame()
Function QueryFrame As Mat
Mat^ QueryFrame()
abstract QueryFrame : unit -> Mat

Return Value

Type: Mat
A Bgr image frame
See Also

Reference

ICapture Interface
Emgu.CV Namespace


ICapture.QuerySmallFrame Method

ICaptureQuerySmallFrame Method

Capture a Bgr image frame that is half width and half height

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
Mat QuerySmallFrame()
Function QuerySmallFrame As Mat
Mat^ QuerySmallFrame()
abstract QuerySmallFrame : unit -> Mat

Return Value

Type: Mat
A Bgr image frame that is half width and half height
See Also

Reference

ICapture Interface
Emgu.CV Namespace


IColor Interface

A color type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IColor
Public Interface IColor
public interface class IColor
type IColor =  interface end

The IColor type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of the color type
Public property | MCvScalar | The equivalent MCvScalar value
Top
See Also

Reference

Emgu.CV Namespace


IColor Properties

The IColor type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of the color type
Public property | MCvScalar | The equivalent MCvScalar value
Top
See Also

Reference

IColor Interface
Emgu.CV Namespace


IColor.Dimension Property

IColorDimension Property

Get the dimension of the color type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
int Dimension { get; }
ReadOnly Property Dimension As Integer
    Get
property int Dimension {
    int get ();
}
abstract Dimension : int with get

Property Value

Type: Int32
See Also

Reference

IColor Interface
Emgu.CV Namespace


IColor.MCvScalar Property

IColorMCvScalar Property

The equivalent MCvScalar value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
MCvScalar MCvScalar { get; set; }
Property MCvScalar As MCvScalar
    Get
    Set
property MCvScalar^ MCvScalar {
    MCvScalar^ get ();
    void set (MCvScalar^ value);
}
abstract MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar
See Also

Reference

IColor Interface
Emgu.CV Namespace


IConvexPolygon Interface

An interface for the convex polygon

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IConvexPolygon
Public Interface IConvexPolygon
public interface class IConvexPolygon
type IConvexPolygon =  interface end

The IConvexPolygon type exposes the following members.

Methods
 | Name | Description
Public method | GetVertices | Get the vertices of this convex polygon
Top
See Also

Reference

Emgu.CV Namespace


IConvexPolygon Methods

The IConvexPolygon type exposes the following members.

Methods
 | Name | Description
Public method | GetVertices | Get the vertices of this convex polygon
Top
See Also

Reference

IConvexPolygon Interface
Emgu.CV Namespace


IConvexPolygon.GetVertices Method

IConvexPolygonGetVertices Method

Get the vertices of this convex polygon

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
Point[] GetVertices()
Function GetVertices As Point()
array<Point^>^ GetVertices()
abstract GetVertices : unit -> Point[]

Return Value

Type: Point
The vertices of this convex polygon
See Also

Reference

IConvexPolygon Interface
Emgu.CV Namespace


IConvexPolygonF Interface

An interface for the convex polygon

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IConvexPolygonF
Public Interface IConvexPolygonF
public interface class IConvexPolygonF
type IConvexPolygonF =  interface end

The IConvexPolygonF type exposes the following members.

Methods
 | Name | Description
Public method | GetVertices | Get the vertices of this convex polygon
Top
See Also

Reference

Emgu.CV Namespace


IConvexPolygonF Methods

The IConvexPolygonF type exposes the following members.

Methods
 | Name | Description
Public method | GetVertices | Get the vertices of this convex polygon
Top
See Also

Reference

IConvexPolygonF Interface
Emgu.CV Namespace


IConvexPolygonF.GetVertices Method

IConvexPolygonFGetVertices Method

Get the vertices of this convex polygon

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
PointF[] GetVertices()
Function GetVertices As PointF()
array<PointF^>^ GetVertices()
abstract GetVertices : unit -> PointF[]

Return Value

Type: PointF
The vertices of this convex polygon
See Also

Reference

IConvexPolygonF Interface
Emgu.CV Namespace


IDenseOpticalFlow Interface

Dense Optical flow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IDenseOpticalFlow : IAlgorithm
Public Interface IDenseOpticalFlow
    Inherits IAlgorithm
public interface class IDenseOpticalFlow : IAlgorithm
type IDenseOpticalFlow =
    interface
        interface IAlgorithm
    end

The IDenseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IDenseOpticalFlow Properties

The IDenseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | DenseOpticalFlowPtr | Gets the dense optical flow pointer.
Top
See Also

Reference

IDenseOpticalFlow Interface
Emgu.CV Namespace


IDenseOpticalFlow.DenseOpticalFlowPtr Property

IDenseOpticalFlowDenseOpticalFlowPtr Property

Gets the dense optical flow pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr DenseOpticalFlowPtr { get; }
ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
property IntPtr DenseOpticalFlowPtr {
    IntPtr get ();
}
abstract DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
The dense optical flow .
See Also

Reference

IDenseOpticalFlow Interface
Emgu.CV Namespace


IDenseOpticalFlow Methods

The IDenseOpticalFlow type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IDenseOpticalFlow Interface
Emgu.CV Namespace


IDuplexCapture Interface

The interface to request a duplex image capture

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IDuplexCapture
Public Interface IDuplexCapture
public interface class IDuplexCapture
type IDuplexCapture =  interface end

The IDuplexCapture type exposes the following members.

Methods
 | Name | Description
Public method | DuplexQueryFrame | Request a frame from server
Public method | DuplexQuerySmallFrame | Request a frame from server which is half width and half height
Top
See Also

Reference

Emgu.CV Namespace


IDuplexCapture Methods

The IDuplexCapture type exposes the following members.

Methods
 | Name | Description
Public method | DuplexQueryFrame | Request a frame from server
Public method | DuplexQuerySmallFrame | Request a frame from server which is half width and half height
Top
See Also

Reference

IDuplexCapture Interface
Emgu.CV Namespace


IDuplexCapture.DuplexQueryFrame Method

IDuplexCaptureDuplexQueryFrame Method

Request a frame from server

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
void DuplexQueryFrame()
Sub DuplexQueryFrame
void DuplexQueryFrame()
abstract DuplexQueryFrame : unit -> unit
See Also

Reference

IDuplexCapture Interface
Emgu.CV Namespace


IDuplexCapture.DuplexQuerySmallFrame Method

IDuplexCaptureDuplexQuerySmallFrame Method

Request a frame from server which is half width and half height

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
void DuplexQuerySmallFrame()
Sub DuplexQuerySmallFrame
void DuplexQuerySmallFrame()
abstract DuplexQuerySmallFrame : unit -> unit
See Also

Reference

IDuplexCapture Interface
Emgu.CV Namespace


IDuplexCaptureCallback Interface

The interface for DuplexCaptureCallback

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IDuplexCaptureCallback
Public Interface IDuplexCaptureCallback
public interface class IDuplexCaptureCallback
type IDuplexCaptureCallback =  interface end

The IDuplexCaptureCallback type exposes the following members.

Methods
 | Name | Description
Public method | ReceiveFrame | Function to call when an image is received
Top
See Also

Reference

Emgu.CV Namespace


IDuplexCaptureCallback Methods

The IDuplexCaptureCallback type exposes the following members.

Methods
 | Name | Description
Public method | ReceiveFrame | Function to call when an image is received
Top
See Also

Reference

IDuplexCaptureCallback Interface
Emgu.CV Namespace


IDuplexCaptureCallback.ReceiveFrame Method

IDuplexCaptureCallbackReceiveFrame Method

Function to call when an image is received

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
void ReceiveFrame(
    Mat img
)
Sub ReceiveFrame (
    img As Mat
)
void ReceiveFrame(
    Mat^ img
)
abstract ReceiveFrame :
        img : Mat -> unit

Parameters

img
Type: Emgu.CVMat
The image received
See Also

Reference

IDuplexCaptureCallback Interface
Emgu.CV Namespace


IInputArray Interface

This is the proxy class for passing read-only input arrays into OpenCV functions.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IInputArray : IDisposable
Public Interface IInputArray
    Inherits IDisposable
public interface class IInputArray : IDisposable
type IInputArray =
    interface
        interface IDisposable
    end

The IInputArray type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array.
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IInputArray Methods

The IInputArray type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array.
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

IInputArray Interface
Emgu.CV Namespace


IInputArray.GetInputArray Method

IInputArrayGetInputArray Method

The unmanaged pointer to the input array.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
InputArray GetInputArray()
Function GetInputArray As InputArray
InputArray^ GetInputArray()
abstract GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array
See Also

Reference

IInputArray Interface
Emgu.CV Namespace


IInputArrayExtensions Class

Extension methods for IInputArrays
Inheritance Hierarchy
SystemObject
Emgu.CVIInputArrayExtensions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class IInputArrayExtensions
<ExtensionAttribute>
Public NotInheritable Class IInputArrayExtensions
[ExtensionAttribute]
public ref class IInputArrayExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type IInputArrayExtensions =  class end

The IInputArrayExtensions type exposes the following members.

Methods
Name | Description
ForEachDuplicateChannel(IInputArray, ActionIInputArray, Int32) | Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor
ForEachDuplicateChannelTReturn(IInputArray, FuncIInputArray, Int32, TReturn) | Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor
IsUmat | Determines whether the specified input array is umat.
Top
See Also

Reference

Emgu.CV Namespace


IInputArrayExtensions Methods

The IInputArrayExtensions type exposes the following members.

Methods
Name | Description
ForEachDuplicateChannel(IInputArray, ActionIInputArray, Int32) | Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor
ForEachDuplicateChannelTReturn(IInputArray, FuncIInputArray, Int32, TReturn) | Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor
IsUmat | Determines whether the specified input array is umat.
Top
See Also

Reference

IInputArrayExtensions Class
Emgu.CV Namespace


IInputArrayExtensions.ForEachDuplicateChannel Method

IInputArrayExtensionsForEachDuplicateChannel Method

Overload List
Name | Description
ForEachDuplicateChannel(IInputArray, ActionIInputArray, Int32) | Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor
ForEachDuplicateChannelTReturn(IInputArray, FuncIInputArray, Int32, TReturn) | Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor
Top
See Also

Reference

IInputArrayExtensions Class
Emgu.CV Namespace


IInputArrayExtensions.ForEachDuplicateChannel Method (IInputArray, Action(IInputArray, Int32))

IInputArrayExtensionsForEachDuplicateChannel Method (IInputArray, ActionIInputArray, Int32)

http://www.emgu.com
Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ForEachDuplicateChannel(
    this IInputArray image,
    Action<IInputArray, int> action
)
<ExtensionAttribute>
Public Shared Sub ForEachDuplicateChannel (
    image As IInputArray,
    action As Action(Of IInputArray, Integer)
)
public:
[ExtensionAttribute]
static void ForEachDuplicateChannel(
    IInputArray^ image,
    Action<IInputArray^, int>^ action
)
[<ExtensionAttribute>]
static member ForEachDuplicateChannel :
        image : IInputArray *
        action : Action<IInputArray, int> -> unit

Parameters

image
Type: Emgu.CVIInputArray
The source image
action
Type: SystemAction IInputArray, Int32
The converter such that accept the IntPtr of a single channel IplImage, and image channel index which returning result of type R

Return Value

Type:
An array which contains result for each channel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IInputArray. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IInputArrayExtensions Class
ForEachDuplicateChannel Overload
Emgu.CV Namespace


IInputArrayExtensions.ForEachDuplicateChannel(TReturn) Method (IInputArray, Func(IInputArray, Int32, TReturn))

IInputArrayExtensionsForEachDuplicateChannelTReturn Method (IInputArray, FuncIInputArray, Int32, TReturn)

http://www.emgu.com
Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static TReturn[] ForEachDuplicateChannel<TReturn>(
    this IInputArray image,
    Func<IInputArray, int, TReturn> conv
)

<ExtensionAttribute>
Public Shared Function ForEachDuplicateChannel(Of TReturn) (
    image As IInputArray,
    conv As Func(Of IInputArray, Integer, TReturn)
) As TReturn()
public:
[ExtensionAttribute]
generic<typename TReturn>
static array<TReturn>^ ForEachDuplicateChannel(
    IInputArray^ image,
    Func<IInputArray^, int, TReturn>^ conv
)
[<ExtensionAttribute>]
static member ForEachDuplicateChannel :
        image : IInputArray *
        conv : Func<IInputArray, int, 'TReturn> -> 'TReturn[]

Parameters

image
Type: Emgu.CVIInputArray
The source image
conv
Type: SystemFunc IInputArray, Int32, TReturn
The converter such that accept the IntPtr of a single channel IplImage, and image channel index which returning result of type R

Type Parameters

TReturn
The return type

Return Value

Type: TReturn
An array which contains result for each channel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IInputArray. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IInputArrayExtensions Class
ForEachDuplicateChannel Overload
Emgu.CV Namespace


IInputArrayExtensions.IsUmat Method

IInputArrayExtensionsIsUmat Method

Determines whether the specified input array is umat.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsUmat(
    this IInputArray arr
)
<ExtensionAttribute>
Public Shared Function IsUmat (
    arr As IInputArray
) As Boolean
public:
[ExtensionAttribute]
static bool IsUmat(
    IInputArray^ arr
)
[<ExtensionAttribute>]
static member IsUmat :
        arr : IInputArray -> bool

Parameters

arr
Type: Emgu.CVIInputArray
The array

Return Value

Type: Boolean
True if it is a umat

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IInputArray. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IInputArrayExtensions Class
Emgu.CV Namespace


IInputArrayOfArrays Interface

InputArrayOfArrays

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IInputArrayOfArrays : IInputArray,
    IDisposable
Public Interface IInputArrayOfArrays
    Inherits IInputArray, IDisposable
public interface class IInputArrayOfArrays : IInputArray,
    IDisposable
type IInputArrayOfArrays =
    interface
        interface IInputArray
        interface IDisposable
    end

The IInputArrayOfArrays type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IInputArrayOfArrays Methods

The IInputArrayOfArrays type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

IInputArrayOfArrays Interface
Emgu.CV Namespace


IInputOutputArray Interface

This type is very similar to InputArray except that it is used for input/output function parameters.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IInputOutputArray : IInputArray,
    IDisposable, IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays
Public Interface IInputOutputArray
    Inherits IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
public interface class IInputOutputArray : IInputArray,
    IDisposable, IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays
type IInputOutputArray =
    interface
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The IInputOutputArray type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Public method | GetInputOutputArray | The unmanaged pointer to the input/output array
Public method | GetOutputArray | The unmanaged pointer to the output array (Inherited from IOutputArray.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IInputOutputArray Methods

The IInputOutputArray type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Public method | GetInputOutputArray | The unmanaged pointer to the input/output array
Public method | GetOutputArray | The unmanaged pointer to the output array (Inherited from IOutputArray.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

IInputOutputArray Interface
Emgu.CV Namespace


IInputOutputArray.GetInputOutputArray Method

IInputOutputArrayGetInputOutputArray Method

The unmanaged pointer to the input/output array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
InputOutputArray GetInputOutputArray()
Function GetInputOutputArray As InputOutputArray
InputOutputArray^ GetInputOutputArray()
abstract GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
Get the input output array
See Also

Reference

IInputOutputArray Interface
Emgu.CV Namespace


Image(TColor, TDepth) Class

ImageTColor, TDepth Class

An Image is a wrapper to IplImage of OpenCV.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArray TDepth
Emgu.CVImageTColor, TDepth
Emgu.CVMapTColor, TDepth
Emgu.CVTimedImageTColor, TDepth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Image<TColor, TDepth> : CvArray<TDepth>,
    IEquatable<Image<TColor, TDepth>>, IInputOutputArray, IInputArray,
    IDisposable, IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays
where TColor : struct, new(), IColor
where TDepth : new()

<SerializableAttribute>
Public Class Image(Of TColor As {Structure, New, IColor}, TDepth As New)
    Inherits CvArray(Of TDepth)
    Implements IEquatable(Of Image(Of TColor, TDepth)),
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[SerializableAttribute]
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
public ref class Image : public CvArray<TDepth>,
    IEquatable<Image<TColor, TDepth>^>, IInputOutputArray, IInputArray,
    IDisposable, IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays
[<SerializableAttribute>]
type Image<'TColor, 'TDepth when 'TColor : struct, new() and IColor when 'TDepth : new()> =
    class
        inherit CvArray<'TDepth>
        interface IEquatable<Image<'TColor, 'TDepth>>
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

Type Parameters

TColor
Color type of this image (either Gray, Bgr, Bgra, Hsv, Hls, Lab, Luv, Xyz, Ycc, Rgb or Rbga)
TDepth
Depth of this image (either Byte, SByte, Single, double, UInt16, Int16 or Int32)

The ImageTColor, TDepth type exposes the following members.

Constructors
 | Name | Description
Protected method | ImageTColor, TDepth | Create an empty Image
Public method | ImageTColor, TDepth(Size) | Create a blank Image of the specific size
Public method | ImageTColor, TDepth(String) | Read image from a file
Public method | ImageTColor, TDepth(TDepth) | Create image from the specific multi-dimensional data, where the 1st dimesion is # of rows (height), the 2nd dimension is # cols (width) and the 3rd dimension is the channel
Public method | ImageTColor, TDepth(ImageGray, TDepth) | Create a multi-channel image from multiple gray scale images
Public method | ImageTColor, TDepth(Int32, Int32) | Create a blank Image of the specified width and height.
Public method | ImageTColor, TDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | ImageTColor, TDepth(Int32, Int32, TColor) | Create a blank Image of the specified width, height and color.
Public method | ImageTColor, TDepth(Int32, Int32, Int32, IntPtr) | Create an Image from unmanaged data.
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
 | CvDepth | Get the equivalent opencv depth type for this image
Public property | Data | Get or Set the data for this matrix. The Get function has O(1) complexity. The Set function make a copy of the data
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | IsROISet | Indicates if the region of interest has been set
Public property | ItemPoint | Get or Set the color in the location
Public property | ItemInt32 | Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image.
Public property | ItemInt32, Int32 | Get or Set the color in the rowth row (y direction) and columnth column (x direction)
Public property | ManagedArray | Get the underneath managed array (Overrides CvArrayTDepthManagedArray.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MIplImage | The IplImage structure
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this image (Overrides CvArrayTDepthNumberOfChannels.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | ROI | Get or Set the region of interest for this image. To clear the ROI, set it to System.Drawing.Rectangle.Empty
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Overrides CvArrayTDepthSize.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Dilate | Dilates this image inplace using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times
Public method | _EqualizeHist | The algorithm inplace normalizes brightness and increases contrast of the image. For color images, a HSV representation of the image is first obtained and the V (value) channel is histogram normalized
Public method | _Erode | Erodes this image inplace using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times
Public method | _Flip | Inplace flip the image
Public method | _GammaCorrect | Gamma corrects this image inplace. The image must have a depth type of Byte.
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _MorphologyEx | Perform inplace advanced morphological transformations using erosion and dilation as basic operations.
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _SmoothGaussian(Int32) | Perform Gaussian Smoothing inplace for the current image
Public method | _SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing inplace for the current image
Public method | _ThresholdBinary | Threshold the image inplace such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise
Public method | _ThresholdBinaryInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise
Public method | _ThresholdToZero | Threshold the image inplace such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise
Public method | _ThresholdToZeroInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise
Public method | _ThresholdTrunc | Threshold the image inplace such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise
Public method | AbsDiff(TColor) | Computes absolute different between this image and the specific color
Public method | AbsDiff(ImageTColor, TDepth) | Computes absolute different between this image and the other image
Public method | Accumulate(ImageTColor, TDepth) | Accumulate img2 to the current image using the specific mask
Public method | Accumulate(ImageTColor, TDepth, ImageGray, Byte) | Accumulate img2 to the current image using the specific mask
Public method | AccumulateWeighted(ImageTColor, TDepth, Double) | Update Running Average. this = (1-alpha)*this + alpha*img
Public method | AccumulateWeighted(ImageTColor, TDepth, Double, ImageGray, Byte) | Update Running Average. this = (1-alpha)*this + alpha*img, using the mask
Public method | Action(ActionTDepth) | perform an generic action based on each element of the image
Public method | ActionTOtherDepth(ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth) | Perform an generic operation based on the elements of the two images
Public method | Add(TColor) | Elementwise add a color val to the current image
Public method | Add(ImageTColor, TDepth) | Elementwise add another image with the current image
Public method | Add(ImageTColor, TDepth, ImageGray, Byte) | Elementwise add img2 with the current image, using a mask
Public method | AddWeighted | Return the weighted sum such that: res = this * alpha + img2 * beta + gamma
Protected method | AllocateData | Re-allocate data for the array (Overrides CvArrayTDepthAllocateData(Int32, Int32, Int32).)
Public method | And(TColor) | Perform an binary AND operation with some color
Public method | And(ImageTColor, TDepth) | Perform an elementwise AND operation with another image and return the result
Public method | And(TColor, ImageGray, Byte) | Perform an binary AND operation with some color using a mask
Public method | And(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise AND operation with another image, using a mask, and return the result
Public method | AvgSdv(TColor, MCvScalar) | Calculates the average value and standard deviation of array elements, independently for each channel
Public method | AvgSdv(TColor, MCvScalar, ImageGray, Byte) | Calculates the average value and standard deviation of array elements, independently for each channel
Public method | BuildPyramid | Compute the image pyramid
Public method | Canny(Double, Double) | Find the edges on this image and marked them in the returned image.
Public method | Canny(Double, Double, Int32, Boolean) | Find the edges on this image and marked them in the returned image.
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a clone of the current image. All image data as well as the COI and ROI are cloned
Public method | Cmp(Double, CmpType) | Compare the current image with value and returns the comparison mask
Public method | Cmp(ImageTColor, TDepth, CmpType) | Compare the current image with img2 and returns the comparison mask
Public method | ConcateHorizontal | Concate the current image with another image horizontally.
Public method | ConcateVertical | Concate the current image with another image vertically.
Public method | ConvertTOtherDepth(FuncTDepth, TOtherDepth) | Compute the element of the new image based on element of this image
Public method | ConvertTOtherDepth(FuncTDepth, Int32, Int32, TOtherDepth) | Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image
Public method | ConvertTOtherColor, TOtherDepth | Convert the current image to the specific color and depth
Public method | ConvertTDepth2, TDepth3(ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3) | Compute the element of the new image based on the elements of the two image
Public method | ConvertTDepth2, TDepth3, TDepth4(ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4) | Compute the element of the new image based on the elements of the three image
Public method | ConvertTDepth2, TDepth3, TDepth4, TDepth5(ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5) | Compute the element of the new image based on the elements of the four image
Public method | ConvertFrom(IInputArray) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Public method | ConvertFromTSrcColor, TSrcDepth(ImageTSrcColor, TSrcDepth) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Public method | ConvertScaleTOtherDepth | Convert the current image to the specific depth, at the same time scale and shift the values of the pixel
Public method | Convolution | Performs a convolution using the specific kernel
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination
Public method | CopyBlank | Create an image of the same size
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Public method | CountNonzero | Count the non Zero elements for each channel
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dilate | Dilates this image using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associate with the image (Overrides CvArrayTDepthDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon using the specific color and thickness
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(ImageTColor, TDepth) | Compare two images, returns true if the each of the pixels are equal, false otherwise
Public method | Erode | Erodes this image using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times
Public method | Exp | Calculates exponent of every element of input array: dst(I)=exp(src(I))
Public method | FillConvexPoly | Fill the convex polygon with the specific color
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindCornerSubPix | Iterates to find the sub-pixel accurate location of corners, or radial saddle points
Public method | Flip | Return a flipped copy of the current image
 | FromIplImagePtr | Get the managed image from an unmanaged IplImagePointer
Public method | GetAverage | Get the average value on this image
Public method | GetAverage(ImageGray, Byte) | Get the average value on this image, using the specific mask
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetMoments | Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characteristics including 7 Hu invariants.
Public method | GetObjectData | A function used for runtime serialization of the object (Overrides CvArrayTDepthGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a subimage which image data is shared with the current image.
Public method | GetSum | Get the sum for each color channel
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrabCut | Use grabcut to perform background foreground segmentation.
Public method | HoughCircles | First apply Canny Edge Detector on the current image, then apply Hough transform to find circles
Public method | HoughLines | Apply Canny Edge Detector follows by Probabilistic Hough transform to find line segments in the image
Public method | HoughLinesBinary | Apply Probabilistic Hough transform to find line segments. The current image must be a binary image (eg. the edges as a result of the Canny edge detector)
Public method | InPaint | Use inpaint to recover the intensity of the pixels which location defined by mask on this image
Public method | InRange(TColor, TColor) | Checks that image elements lie between two scalars
Public method | InRange(ImageTColor, TDepth, ImageTColor, TDepth) | Checks that image elements lie between values defined by two images of same size and type
Public method | Integral | Calculates integral images for the source image
Public method | Integral(ImageTColor, Double, ImageTColor, Double) | Calculates integral images for the source image
Public method | Integral(ImageTColor, Double, ImageTColor, Double, ImageTColor, Double) | Calculates one or more integral images for the source image
Public method | Laplace | Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator. Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0|
Public method | Log | Calculates natural logarithm of absolute value of every element of input array
Public method | LogPolar | Convert the image to log polar, simulating the human foveal vision
Protected method | MapDataToImage | Let this Image object use the specific Image data.
Public method | MatchTemplate | The function slides through image, compares overlapped patches of size wxh with templ using the specified method and return the comparison results
Public method | Max(Double) | Find the elementwise maximum value
Public method | Max(ImageTColor, TDepth) | Find the elementwise maximum value
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Min(Double) | Find the elementwise minimum value
Public method | Min(ImageTColor, TDepth) | Find the elementwise minimum value
Public method | MinMax | Returns the min / max location and values for the image
Public method | MorphologyEx | Perform advanced morphological transformations using erosion and dilation as basic operations.
Public method | Mul(Double) | Elementwise multiply the current image with scale
Public method | Mul(ImageTColor, TDepth) | Elementwise multiply img2 with the current image
Public method | Mul(ImageTColor, TDepth, Double) | Elementwise multiply another image with the current image and the scale
Public method | Not | Compute the complement image
Public method | Or(TColor) | Perform an elementwise OR operation with some color
Public method | Or(ImageTColor, TDepth) | Perform an elementwise OR operation with another image and return the result
Public method | Or(TColor, ImageGray, Byte) | Perform an elementwise OR operation with some color using a mask
Public method | Or(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise OR operation with another image, using a mask, and return the result
Public method | Pow | Raises every element of input array to p dst(I)=src(I)^p, if p is integer dst(I)=abs(src(I))^p, otherwise
Public method | PyrDown | Performs downsampling step of Gaussian pyramid decomposition. First it convolves this image with the specified filter and then downsamples the image by rejecting even rows and columns.
Public method | PyrUp | Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples this image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the resulting image is four times larger than the source image.
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Resize(Double, Inter) | Scale the image to the specific size: width *= scale; height *= scale
Public method | Resize(Int32, Int32, Inter) | Scale the image to the specific size
Public method | Resize(Int32, Int32, Inter, Boolean) | Scale the image to the specific size
 | RoiParam | Return parameters based on ROI
Public method | Rotate(Double, TColor) | Rotate the image the specified angle cropping the result to the original size
Public method | Rotate(Double, TColor, Boolean) | Rotate this image the specified angle
Public method | Rotate(Double, PointF, Inter, TColor, Boolean) | Rotate this image the specified angle
Public method | Save | Save this image to the specific file. (Overrides CvArrayTDepthSave(String).)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor) | Set every pixel of the image to the specific color
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor, ImageGray, Byte) | Set every pixel of the image to the specific color, using a mask
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | SmoothBilateral | Applying bilateral 3x3 filtering
Public method | SmoothBlur(Int32, Int32) | Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2)
Public method | SmoothBlur(Int32, Int32, Boolean) | Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2)
Public method | SmoothGaussian(Int32) | Perform Gaussian Smoothing in the current image and return the result
Public method | SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing in the current image and return the result
Public method | SmoothMedian | Finding median of sizexsize neighborhood
Public method | Sobel | Calculates the image derivative by convolving the image with the appropriate kernel The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative.
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image
Public method | Sub(TColor) | Elementwise subtract a color from the current image
Public method | Sub(ImageTColor, TDepth) | Elementwise subtract another image from the current image
Public method | Sub(ImageTColor, TDepth, ImageGray, Byte) | Elementwise subtract another image from the current image, using a mask
Public method | SubR(TColor) | result = val - this
Public method | SubR(TColor, ImageGray, Byte) | result = val - this, using a mask
Public method | ThresholdAdaptive | Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1.
Public method | ThresholdBinary | Threshold the image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise
Public method | ThresholdBinaryInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise
Public method | ThresholdToZero | Threshold the image such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise
Public method | ThresholdToZeroInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise
Public method | ThresholdTrunc | Threshold the image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise
Public method | ToJpegData | Get the jpeg representation of the image
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WarpAffine(Mat, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpAffine(Mat, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Public method | Xor(TColor) | Perform an binary XOR operation with some color
Public method | Xor(ImageTColor, TDepth) | Perform an elementwise XOR operation with another image and return the result
Public method | Xor(TColor, ImageGray, Byte) | Perform an binary XOR operation with some color using a mask
Public method | Xor(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise XOR operation with another image, using a mask, and return the result
Top
Operators
Name | Description
Addition(Double, ImageTColor, TDepth) | Element wise add img1 with val
Addition(TColor, ImageTColor, TDepth) | Element wise add image with value
Addition(ImageTColor, TDepth, ImageTColor, TDepth) | Element wise add img1 with img2
Addition(ImageTColor, TDepth, Double) | Element wise add image with value
Addition(ImageTColor, TDepth, TColor) | Element wise add image with value
BitwiseAnd(Double, ImageTColor, TDepth) | Perform an element wise AND operation using an images and a color
BitwiseAnd(TColor, ImageTColor, TDepth) | Perform an element wise AND operation using an images and a color
BitwiseAnd(ImageTColor, TDepth, ImageTColor, TDepth) | Perform an element wise AND operation on the two images
BitwiseAnd(ImageTColor, TDepth, Double) | Perform an element wise AND operation using an images and a color
BitwiseAnd(ImageTColor, TDepth, TColor) | Perform an element wise AND operation using an images and a color
BitwiseOr(Double, ImageTColor, TDepth) | Perform an binary OR operation with some color
BitwiseOr(TColor, ImageTColor, TDepth) | Perform an binary OR operation with some color
BitwiseOr(ImageTColor, TDepth, ImageTColor, TDepth) | Perform an element wise OR operation with another image and return the result
BitwiseOr(ImageTColor, TDepth, Double) | Perform an binary OR operation with some color
BitwiseOr(ImageTColor, TDepth, TColor) | Perform an binary OR operation with some color
Division(Double, ImageTColor, TDepth) | scale / image
Division(ImageTColor, TDepth, Double) | image / scale
Multiply(Double, ImageTColor, TDepth) | scale*image
Multiply(ImageTColor, TDepth, ConvolutionKernelF) | Perform the convolution with kernel on image
Multiply(ImageTColor, TDepth, Double) | image * scale
OnesComplement | Compute the complement image
Subtraction(Double, ImageTColor, TDepth) | value - image
Subtraction(TColor, ImageTColor, TDepth) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, ImageTColor, TDepth) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, Double) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, TColor) | Element wise subtract another image from the current image
Top
Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


Image(TColor, TDepth) Constructor

ImageTColor, TDepth Constructor

Overload List
 | Name | Description
Protected method | ImageTColor, TDepth | Create an empty Image
Public method | ImageTColor, TDepth(Size) | Create a blank Image of the specific size
Public method | ImageTColor, TDepth(String) | Read image from a file
Public method | ImageTColor, TDepth(TDepth) | Create image from the specific multi-dimensional data, where the 1st dimesion is # of rows (height), the 2nd dimension is # cols (width) and the 3rd dimension is the channel
Public method | ImageTColor, TDepth(ImageGray, TDepth) | Create a multi-channel image from multiple gray scale images
Public method | ImageTColor, TDepth(Int32, Int32) | Create a blank Image of the specified width and height.
Public method | ImageTColor, TDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | ImageTColor, TDepth(Int32, Int32, TColor) | Create a blank Image of the specified width, height and color.
Public method | ImageTColor, TDepth(Int32, Int32, Int32, IntPtr) | Create an Image from unmanaged data.
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth) Constructor

ImageTColor, TDepth Constructor

Create an empty Image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Image()
Protected Sub New
protected:
Image()
new : unit -> Image
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (Size)

ImageTColor, TDepth Constructor (Size)

http://www.emgu.com
Create a blank Image of the specific size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    Size size
)
Public Sub New (
    size As Size
)
public:
Image(
    Size^ size
)
new :
        size : Size -> Image

Parameters

size
Type: System.DrawingSize
The size of the image
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (String)

ImageTColor, TDepth Constructor (String)

http://www.emgu.com
Read image from a file

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
Image(
    String^ fileName
)
new :
        fileName : string -> Image

Parameters

fileName
Type: SystemString
the name of the file that contains the image
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (TDepth[,])

ImageTColor, TDepth Constructor (TDepth)

http://www.emgu.com
Create image from the specific multi-dimensional data, where the 1st dimesion is # of rows (height), the 2nd dimension is # cols (width) and the 3rd dimension is the channel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    TDepth[,,] data
)
Public Sub New (
    data As TDepth(,,)
)
public:
Image(
    array<TDepth,3>^ data
)
new :
        data : 'TDepth[,,] -> Image

Parameters

data
Type: TDepth
The multi-dimensional data where the 1st dimension is # of rows (height), the 2nd dimension is # cols (width) and the 3rd dimension is the channel
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (Image(Gray, TDepth)[])

ImageTColor, TDepth Constructor (ImageGray, TDepth)

http://www.emgu.com
Create a multi-channel image from multiple gray scale images

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    Image<Gray, TDepth>[] channels
)
Public Sub New (
    channels As Image(Of Gray, TDepth)()
)
public:
Image(
    array<Image<Gray^, TDepth>^>^ channels
)
new :
        channels : Image<Gray, 'TDepth>[] -> Image

Parameters

channels
Type: Emgu.CVImage Gray, TDepth
The image channels to be merged into a single image
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (Int32, Int32)

ImageTColor, TDepth Constructor (Int32, Int32)

http://www.emgu.com
Create a blank Image of the specified width and height.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    int width,
    int height
)
Public Sub New (
    width As Integer,
    height As Integer
)
public:
Image(
    int width,
    int height
)
new :
        width : int *
        height : int -> Image

Parameters

width
Type: SystemInt32
The width of the image
height
Type: SystemInt32
The height of the image
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (SerializationInfo, StreamingContext)

ImageTColor, TDepth Constructor (SerializationInfo, StreamingContext)

http://www.emgu.com
Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
Image(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> Image

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (Int32, Int32, TColor)

ImageTColor, TDepth Constructor (Int32, Int32, TColor)

http://www.emgu.com
Create a blank Image of the specified width, height and color.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    int width,
    int height,
    TColor value
)
Public Sub New (
    width As Integer,
    height As Integer,
    value As TColor
)
public:
Image(
    int width,
    int height,
    TColor value
)
new :
        width : int *
        height : int *
        value : 'TColor -> Image

Parameters

width
Type: SystemInt32
The width of the image
height
Type: SystemInt32
The height of the image
value
Type: TColor
The initial color of the image
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Constructor (Int32, Int32, Int32, IntPtr)

ImageTColor, TDepth Constructor (Int32, Int32, Int32, IntPtr)

http://www.emgu.com
Create an Image from unmanaged data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image(
    int width,
    int height,
    int stride,
    IntPtr scan0
)
Public Sub New (
    width As Integer,
    height As Integer,
    stride As Integer,
    scan0 As IntPtr
)
public:
Image(
    int width,
    int height,
    int stride,
    IntPtr scan0
)
new :
        width : int *
        height : int *
        stride : int *
        scan0 : IntPtr -> Image

Parameters

width
Type: SystemInt32
The width of the image
height
Type: SystemInt32
The height of the image
stride
Type: SystemInt32
Size of aligned image row in bytes
scan0
Type: SystemIntPtr
Pointer to aligned image data, where each row should be 4-align
Remarks
The caller is responsible for allocating and freeing the block of memory specified by the scan0 parameter, however, the memory should not be released until the related Image is released.
See Also

Reference

ImageTColor, TDepth Class
ImageTColor, TDepth Overload
Emgu.CV Namespace


Image(TColor, TDepth) Properties

ImageTColor, TDepth Properties

The ImageTColor, TDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
 | CvDepth | Get the equivalent opencv depth type for this image
Public property | Data | Get or Set the data for this matrix. The Get function has O(1) complexity. The Set function make a copy of the data
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | IsROISet | Indicates if the region of interest has been set
Public property | ItemPoint | Get or Set the color in the location
Public property | ItemInt32 | Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image.
Public property | ItemInt32, Int32 | Get or Set the color in the rowth row (y direction) and columnth column (x direction)
Public property | ManagedArray | Get the underneath managed array (Overrides CvArrayTDepthManagedArray.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MIplImage | The IplImage structure
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this image (Overrides CvArrayTDepthNumberOfChannels.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | ROI | Get or Set the region of interest for this image. To clear the ROI, set it to System.Drawing.Rectangle.Empty
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Overrides CvArrayTDepthSize.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).CvDepth Property

ImageTColor, TDepthCvDepth Property

Get the equivalent opencv depth type for this image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IplDepth CvDepth { get; }
Public Shared ReadOnly Property CvDepth As IplDepth
    Get
public:
static property IplDepth^ CvDepth {
    IplDepth^ get ();
}
static member CvDepth : IplDepth with get

Property Value

Type: IplDepth
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Data Property

ImageTColor, TDepthData Property

Get or Set the data for this matrix. The Get function has O(1) complexity. The Set function make a copy of the data

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TDepth[,,] Data { get; set; }
Public Property Data As TDepth(,,)
    Get
    Set
public:
property array<TDepth,3>^ Data {
    array<TDepth,3>^ get ();
    void set (array<TDepth,3>^ value);
}
member Data : 'TDepth[,,] with get, set

Property Value

Type: TDepth
Remarks
If the image contains Byte and width is not a multiple of 4. The second dimension of the array might be larger than the Width of this image. This is necessary since the length of a row need to be 4 align for OpenCV optimization. The Set function always make a copy of the specific value. If the image contains Byte and width is not a multiple of 4. The second dimension of the array created might be larger than the Width of this image.
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).IsROISet Property

ImageTColor, TDepthIsROISet Property

Indicates if the region of interest has been set

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsROISet { get; }
Public ReadOnly Property IsROISet As Boolean
    Get
public:
property bool IsROISet {
    bool get ();
}
member IsROISet : bool with get

Property Value

Type: Boolean
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Item Property

ImageTColor, TDepthItem Property

Overload List
 | Name | Description
Public property | ItemPoint | Get or Set the color in the location
Public property | ItemInt32 | Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image.
Public property | ItemInt32, Int32 | Get or Set the color in the rowth row (y direction) and columnth column (x direction)
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Item Property (Point)

ImageTColor, TDepthItem Property (Point)

http://www.emgu.com
Get or Set the color in the location

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TColor this[
    Point location
] { get; set; }
Public Property Item (
    location As Point
) As TColor
    Get
    Set
public:
property TColor Item[Point^ location] {
    TColor get (Point^ location);
    void set (Point^ location, TColor value);
}
member Item : 'TColor with get, set

Parameters

location
Type: System.DrawingPoint
the location of the pixel

Return Value

Type: TColor
the color in the location
See Also

Reference

ImageTColor, TDepth Class
Item Overload
Emgu.CV Namespace


Image(TColor, TDepth).Item Property (Int32)

ImageTColor, TDepthItem Property (Int32)

http://www.emgu.com
Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, TDepth> this[
    int channel
] { get; set; }
Public Property Item (
    channel As Integer
) As Image(Of Gray, TDepth)
    Get
    Set
public:
property Image<Gray^, TDepth>^ Item[int channel] {
    Image<Gray^, TDepth>^ get (int channel);
    void set (int channel, Image<Gray^, TDepth>^ value);
}
member Item : Image<Gray, 'TDepth> with get, set

Parameters

channel
Type: SystemInt32
The channel to get from the current image, zero based index

Return Value

Type: Image Gray, TDepth
The specific channel of the current image
See Also

Reference

ImageTColor, TDepth Class
Item Overload
Emgu.CV Namespace


Image(TColor, TDepth).Item Property (Int32, Int32)

ImageTColor, TDepthItem Property (Int32, Int32)

http://www.emgu.com
Get or Set the color in the rowth row (y direction) and columnth column (x direction)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TColor this[
    int row,
    int column
] { get; set; }
Public Property Item (
    row As Integer,
    column As Integer
) As TColor
    Get
    Set
public:
property TColor Item[int row, int column] {
    TColor get (int row, int column);
    void set (int row, int column, TColor value);
}
member Item : 'TColor with get, set

Parameters

row
Type: SystemInt32
The zero-based row (y direction) of the pixel
column
Type: SystemInt32
The zero-based column (x direction) of the pixel

Return Value

Type: TColor
The color in the specific row and column
See Also

Reference

ImageTColor, TDepth Class
Item Overload
Emgu.CV Namespace


Image(TColor, TDepth).ManagedArray Property

ImageTColor, TDepthManagedArray Property

Get the underneath managed array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override Array ManagedArray { get; set; }
Public Overrides Property ManagedArray As Array
    Get
    Set
public:
virtual property Array^ ManagedArray {
    Array^ get () override;
    void set (Array^ value) override;
}
abstract ManagedArray : Array with get, set
override ManagedArray : Array with get, set

Property Value

Type: Array
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).MIplImage Property

ImageTColor, TDepthMIplImage Property

The IplImage structure

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MIplImage MIplImage { get; }
Public ReadOnly Property MIplImage As MIplImage
    Get
public:
property MIplImage^ MIplImage {
    MIplImage^ get ();
}
member MIplImage : MIplImage with get

Property Value

Type: MIplImage
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).NumberOfChannels Property

ImageTColor, TDepthNumberOfChannels Property

Get the number of channels for this image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override int NumberOfChannels { get; }
Public Overrides ReadOnly Property NumberOfChannels As Integer
    Get
public:
virtual property int NumberOfChannels {
    int get () override;
}
abstract NumberOfChannels : int with get
override NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ROI Property

ImageTColor, TDepthROI Property

Get or Set the region of interest for this image. To clear the ROI, set it to System.Drawing.Rectangle.Empty

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle ROI { get; set; }
Public Property ROI As Rectangle
    Get
    Set
public:
property Rectangle^ ROI {
    Rectangle^ get ();
    void set (Rectangle^ value);
}
member ROI : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Size Property

ImageTColor, TDepthSize Property

Get the size of the array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override Size Size { get; }
Public Overrides ReadOnly Property Size As Size
    Get
public:
virtual property Size^ Size {
    Size^ get () override;
}
abstract Size : Size with get
override Size : Size with get

Property Value

Type: Size
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth) Methods

ImageTColor, TDepth Methods

The ImageTColor, TDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Dilate | Dilates this image inplace using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times
Public method | _EqualizeHist | The algorithm inplace normalizes brightness and increases contrast of the image. For color images, a HSV representation of the image is first obtained and the V (value) channel is histogram normalized
Public method | _Erode | Erodes this image inplace using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times
Public method | _Flip | Inplace flip the image
Public method | _GammaCorrect | Gamma corrects this image inplace. The image must have a depth type of Byte.
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _MorphologyEx | Perform inplace advanced morphological transformations using erosion and dilation as basic operations.
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _SmoothGaussian(Int32) | Perform Gaussian Smoothing inplace for the current image
Public method | _SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing inplace for the current image
Public method | _ThresholdBinary | Threshold the image inplace such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise
Public method | _ThresholdBinaryInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise
Public method | _ThresholdToZero | Threshold the image inplace such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise
Public method | _ThresholdToZeroInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise
Public method | _ThresholdTrunc | Threshold the image inplace such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise
Public method | AbsDiff(TColor) | Computes absolute different between this image and the specific color
Public method | AbsDiff(ImageTColor, TDepth) | Computes absolute different between this image and the other image
Public method | Accumulate(ImageTColor, TDepth) | Accumulate img2 to the current image using the specific mask
Public method | Accumulate(ImageTColor, TDepth, ImageGray, Byte) | Accumulate img2 to the current image using the specific mask
Public method | AccumulateWeighted(ImageTColor, TDepth, Double) | Update Running Average. this = (1-alpha)*this + alpha*img
Public method | AccumulateWeighted(ImageTColor, TDepth, Double, ImageGray, Byte) | Update Running Average. this = (1-alpha)*this + alpha*img, using the mask
Public method | Action(ActionTDepth) | perform an generic action based on each element of the image
Public method | ActionTOtherDepth(ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth) | Perform an generic operation based on the elements of the two images
Public method | Add(TColor) | Elementwise add a color val to the current image
Public method | Add(ImageTColor, TDepth) | Elementwise add another image with the current image
Public method | Add(ImageTColor, TDepth, ImageGray, Byte) | Elementwise add img2 with the current image, using a mask
Public method | AddWeighted | Return the weighted sum such that: res = this * alpha + img2 * beta + gamma
Protected method | AllocateData | Re-allocate data for the array (Overrides CvArrayTDepthAllocateData(Int32, Int32, Int32).)
Public method | And(TColor) | Perform an binary AND operation with some color
Public method | And(ImageTColor, TDepth) | Perform an elementwise AND operation with another image and return the result
Public method | And(TColor, ImageGray, Byte) | Perform an binary AND operation with some color using a mask
Public method | And(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise AND operation with another image, using a mask, and return the result
Public method | AvgSdv(TColor, MCvScalar) | Calculates the average value and standard deviation of array elements, independently for each channel
Public method | AvgSdv(TColor, MCvScalar, ImageGray, Byte) | Calculates the average value and standard deviation of array elements, independently for each channel
Public method | BuildPyramid | Compute the image pyramid
Public method | Canny(Double, Double) | Find the edges on this image and marked them in the returned image.
Public method | Canny(Double, Double, Int32, Boolean) | Find the edges on this image and marked them in the returned image.
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a clone of the current image. All image data as well as the COI and ROI are cloned
Public method | Cmp(Double, CmpType) | Compare the current image with value and returns the comparison mask
Public method | Cmp(ImageTColor, TDepth, CmpType) | Compare the current image with img2 and returns the comparison mask
Public method | ConcateHorizontal | Concate the current image with another image horizontally.
Public method | ConcateVertical | Concate the current image with another image vertically.
Public method | ConvertTOtherDepth(FuncTDepth, TOtherDepth) | Compute the element of the new image based on element of this image
Public method | ConvertTOtherDepth(FuncTDepth, Int32, Int32, TOtherDepth) | Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image
Public method | ConvertTOtherColor, TOtherDepth | Convert the current image to the specific color and depth
Public method | ConvertTDepth2, TDepth3(ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3) | Compute the element of the new image based on the elements of the two image
Public method | ConvertTDepth2, TDepth3, TDepth4(ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4) | Compute the element of the new image based on the elements of the three image
Public method | ConvertTDepth2, TDepth3, TDepth4, TDepth5(ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5) | Compute the element of the new image based on the elements of the four image
Public method | ConvertFrom(IInputArray) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Public method | ConvertFromTSrcColor, TSrcDepth(ImageTSrcColor, TSrcDepth) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Public method | ConvertScaleTOtherDepth | Convert the current image to the specific depth, at the same time scale and shift the values of the pixel
Public method | Convolution | Performs a convolution using the specific kernel
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination
Public method | CopyBlank | Create an image of the same size
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Public method | CountNonzero | Count the non Zero elements for each channel
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dilate | Dilates this image using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associate with the image (Overrides CvArrayTDepthDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon using the specific color and thickness
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(ImageTColor, TDepth) | Compare two images, returns true if the each of the pixels are equal, false otherwise
Public method | Erode | Erodes this image using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times
Public method | Exp | Calculates exponent of every element of input array: dst(I)=exp(src(I))
Public method | FillConvexPoly | Fill the convex polygon with the specific color
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindCornerSubPix | Iterates to find the sub-pixel accurate location of corners, or radial saddle points
Public method | Flip | Return a flipped copy of the current image
 | FromIplImagePtr | Get the managed image from an unmanaged IplImagePointer
Public method | GetAverage | Get the average value on this image
Public method | GetAverage(ImageGray, Byte) | Get the average value on this image, using the specific mask
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetMoments | Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characteristics including 7 Hu invariants.
Public method | GetObjectData | A function used for runtime serialization of the object (Overrides CvArrayTDepthGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a subimage which image data is shared with the current image.
Public method | GetSum | Get the sum for each color channel
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrabCut | Use grabcut to perform background foreground segmentation.
Public method | HoughCircles | First apply Canny Edge Detector on the current image, then apply Hough transform to find circles
Public method | HoughLines | Apply Canny Edge Detector follows by Probabilistic Hough transform to find line segments in the image
Public method | HoughLinesBinary | Apply Probabilistic Hough transform to find line segments. The current image must be a binary image (eg. the edges as a result of the Canny edge detector)
Public method | InPaint | Use inpaint to recover the intensity of the pixels which location defined by mask on this image
Public method | InRange(TColor, TColor) | Checks that image elements lie between two scalars
Public method | InRange(ImageTColor, TDepth, ImageTColor, TDepth) | Checks that image elements lie between values defined by two images of same size and type
Public method | Integral | Calculates integral images for the source image
Public method | Integral(ImageTColor, Double, ImageTColor, Double) | Calculates integral images for the source image
Public method | Integral(ImageTColor, Double, ImageTColor, Double, ImageTColor, Double) | Calculates one or more integral images for the source image
Public method | Laplace | Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator. Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0|
Public method | Log | Calculates natural logarithm of absolute value of every element of input array
Public method | LogPolar | Convert the image to log polar, simulating the human foveal vision
Protected method | MapDataToImage | Let this Image object use the specific Image data.
Public method | MatchTemplate | The function slides through image, compares overlapped patches of size wxh with templ using the specified method and return the comparison results
Public method | Max(Double) | Find the elementwise maximum value
Public method | Max(ImageTColor, TDepth) | Find the elementwise maximum value
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Min(Double) | Find the elementwise minimum value
Public method | Min(ImageTColor, TDepth) | Find the elementwise minimum value
Public method | MinMax | Returns the min / max location and values for the image
Public method | MorphologyEx | Perform advanced morphological transformations using erosion and dilation as basic operations.
Public method | Mul(Double) | Elementwise multiply the current image with scale
Public method | Mul(ImageTColor, TDepth) | Elementwise multiply img2 with the current image
Public method | Mul(ImageTColor, TDepth, Double) | Elementwise multiply another image with the current image and the scale
Public method | Not | Compute the complement image
Public method | Or(TColor) | Perform an elementwise OR operation with some color
Public method | Or(ImageTColor, TDepth) | Perform an elementwise OR operation with another image and return the result
Public method | Or(TColor, ImageGray, Byte) | Perform an elementwise OR operation with some color using a mask
Public method | Or(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise OR operation with another image, using a mask, and return the result
Public method | Pow | Raises every element of input array to p dst(I)=src(I)^p, if p is integer dst(I)=abs(src(I))^p, otherwise
Public method | PyrDown | Performs downsampling step of Gaussian pyramid decomposition. First it convolves this image with the specified filter and then downsamples the image by rejecting even rows and columns.
Public method | PyrUp | Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples this image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the resulting image is four times larger than the source image.
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Resize(Double, Inter) | Scale the image to the specific size: width *= scale; height *= scale
Public method | Resize(Int32, Int32, Inter) | Scale the image to the specific size
Public method | Resize(Int32, Int32, Inter, Boolean) | Scale the image to the specific size
 | RoiParam | Return parameters based on ROI
Public method | Rotate(Double, TColor) | Rotate the image the specified angle cropping the result to the original size
Public method | Rotate(Double, TColor, Boolean) | Rotate this image the specified angle
Public method | Rotate(Double, PointF, Inter, TColor, Boolean) | Rotate this image the specified angle
Public method | Save | Save this image to the specific file. (Overrides CvArrayTDepthSave(String).)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor) | Set every pixel of the image to the specific color
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor, ImageGray, Byte) | Set every pixel of the image to the specific color, using a mask
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | SmoothBilateral | Applying bilateral 3x3 filtering
Public method | SmoothBlur(Int32, Int32) | Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2)
Public method | SmoothBlur(Int32, Int32, Boolean) | Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2)
Public method | SmoothGaussian(Int32) | Perform Gaussian Smoothing in the current image and return the result
Public method | SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing in the current image and return the result
Public method | SmoothMedian | Finding median of sizexsize neighborhood
Public method | Sobel | Calculates the image derivative by convolving the image with the appropriate kernel The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative.
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image
Public method | Sub(TColor) | Elementwise subtract a color from the current image
Public method | Sub(ImageTColor, TDepth) | Elementwise subtract another image from the current image
Public method | Sub(ImageTColor, TDepth, ImageGray, Byte) | Elementwise subtract another image from the current image, using a mask
Public method | SubR(TColor) | result = val - this
Public method | SubR(TColor, ImageGray, Byte) | result = val - this, using a mask
Public method | ThresholdAdaptive | Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1.
Public method | ThresholdBinary | Threshold the image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise
Public method | ThresholdBinaryInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise
Public method | ThresholdToZero | Threshold the image such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise
Public method | ThresholdToZeroInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise
Public method | ThresholdTrunc | Threshold the image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise
Public method | ToJpegData | Get the jpeg representation of the image
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WarpAffine(Mat, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpAffine(Mat, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Public method | Xor(TColor) | Perform an binary XOR operation with some color
Public method | Xor(ImageTColor, TDepth) | Perform an elementwise XOR operation with another image and return the result
Public method | Xor(TColor, ImageGray, Byte) | Perform an binary XOR operation with some color using a mask
Public method | Xor(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise XOR operation with another image, using a mask, and return the result
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._Dilate Method

ImageTColor, TDepth_Dilate Method

Dilates this image inplace using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Dilate(
    int iterations
)
Public Sub _Dilate (
    iterations As Integer
)
public:
void _Dilate(
    int iterations
)
member _Dilate :
        iterations : int -> unit

Parameters

iterations
Type: SystemInt32
The number of dilate iterations
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._EqualizeHist Method

ImageTColor, TDepth_EqualizeHist Method

The algorithm inplace normalizes brightness and increases contrast of the image. For color images, a HSV representation of the image is first obtained and the V (value) channel is histogram normalized

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _EqualizeHist()
Public Sub _EqualizeHist
public:
void _EqualizeHist()
member _EqualizeHist : unit -> unit
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._Erode Method

ImageTColor, TDepth_Erode Method

Erodes this image inplace using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Erode(
    int iterations
)
Public Sub _Erode (
    iterations As Integer
)
public:
void _Erode(
    int iterations
)
member _Erode :
        iterations : int -> unit

Parameters

iterations
Type: SystemInt32
The number of erode iterations
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._Flip Method

ImageTColor, TDepth_Flip Method

Inplace flip the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _Flip(
    FlipType flipType
)
Public Sub _Flip (
    flipType As FlipType
)
public:
void _Flip(
    FlipType^ flipType
)
member _Flip :
        flipType : FlipType -> unit

Parameters

flipType
Type: Emgu.CV.CvEnumFlipType
The type of the flipping

Return Value

Type:
The flipped copy of this image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._GammaCorrect Method

ImageTColor, TDepth_GammaCorrect Method

Gamma corrects this image inplace. The image must have a depth type of Byte.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _GammaCorrect(
    double gamma
)
Public Sub _GammaCorrect (
    gamma As Double
)
public:
void _GammaCorrect(
    double gamma
)
member _GammaCorrect :
        gamma : float -> unit

Parameters

gamma
Type: SystemDouble
The gamma value
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._MorphologyEx Method

ImageTColor, TDepth_MorphologyEx Method

Perform inplace advanced morphological transformations using erosion and dilation as basic operations.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _MorphologyEx(
    MorphOp operation,
    IInputArray kernel,
    Point anchor,
    int iterations,
    BorderType borderType,
    MCvScalar borderValue
)
Public Sub _MorphologyEx (
    operation As MorphOp,
    kernel As IInputArray,
    anchor As Point,
    iterations As Integer,
    borderType As BorderType,
    borderValue As MCvScalar
)
public:
void _MorphologyEx(
    MorphOp^ operation,
    IInputArray^ kernel,
    Point^ anchor,
    int iterations,
    BorderType^ borderType,
    MCvScalar^ borderValue
)
member _MorphologyEx :
        operation : MorphOp *
        kernel : IInputArray *
        anchor : Point *
        iterations : int *
        borderType : BorderType *
        borderValue : MCvScalar -> unit

Parameters

operation
Type: Emgu.CV.CvEnumMorphOp
Type of morphological operation
kernel
Type: Emgu.CVIInputArray
Structuring element
anchor
Type: System.DrawingPoint
Anchor position with the kernel. Negative values mean that the anchor is at the kernel center.
iterations
Type: SystemInt32
Number of times erosion and dilation are applied
borderType
Type: Emgu.CV.CvEnumBorderType
Border type
borderValue
Type: Emgu.CV.StructureMCvScalar
Border value
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._SmoothGaussian Method

ImageTColor, TDepth_SmoothGaussian Method

Overload List
 | Name | Description
Public method | _SmoothGaussian(Int32) | Perform Gaussian Smoothing inplace for the current image
Public method | _SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing inplace for the current image
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._SmoothGaussian Method (Int32)

ImageTColor, TDepth_SmoothGaussian Method (Int32)

http://www.emgu.com
Perform Gaussian Smoothing inplace for the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _SmoothGaussian(
    int kernelSize
)
Public Sub _SmoothGaussian (
    kernelSize As Integer
)
public:
void _SmoothGaussian(
    int kernelSize
)
member _SmoothGaussian :
        kernelSize : int -> unit

Parameters

kernelSize
Type: SystemInt32
The size of the Gaussian kernel (kernelSize x kernelSize)
See Also

Reference

ImageTColor, TDepth Class
_SmoothGaussian Overload
Emgu.CV Namespace


Image(TColor, TDepth)._SmoothGaussian Method (Int32, Int32, Double, Double)

ImageTColor, TDepth_SmoothGaussian Method (Int32, Int32, Double, Double)

http://www.emgu.com
Perform Gaussian Smoothing inplace for the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _SmoothGaussian(
    int kernelWidth,
    int kernelHeight,
    double sigma1,
    double sigma2
)
Public Sub _SmoothGaussian (
    kernelWidth As Integer,
    kernelHeight As Integer,
    sigma1 As Double,
    sigma2 As Double
)
public:
void _SmoothGaussian(
    int kernelWidth,
    int kernelHeight,
    double sigma1,
    double sigma2
)
member _SmoothGaussian :
        kernelWidth : int *
        kernelHeight : int *
        sigma1 : float *
        sigma2 : float -> unit

Parameters

kernelWidth
Type: SystemInt32
The width of the Gaussian kernel
kernelHeight
Type: SystemInt32
The height of the Gaussian kernel
sigma1
Type: SystemDouble
The standard deviation of the Gaussian kernel in the horizontal dimension
sigma2
Type: SystemDouble
The standard deviation of the Gaussian kernel in the vertical dimension
See Also

Reference

ImageTColor, TDepth Class
_SmoothGaussian Overload
Emgu.CV Namespace


Image(TColor, TDepth)._ThresholdBinary Method

ImageTColor, TDepth_ThresholdBinary Method

Threshold the image inplace such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _ThresholdBinary(
    TColor threshold,
    TColor maxValue
)
Public Sub _ThresholdBinary (
    threshold As TColor,
    maxValue As TColor
)
public:
void _ThresholdBinary(
    TColor threshold,
    TColor maxValue
)
member _ThresholdBinary :
        threshold : 'TColor *
        maxValue : 'TColor -> unit

Parameters

threshold
Type: TColor
The threshold value
maxValue
Type: TColor
The maximum value of the pixel on the result
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._ThresholdBinaryInv Method

ImageTColor, TDepth_ThresholdBinaryInv Method

Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _ThresholdBinaryInv(
    TColor threshold,
    TColor maxValue
)
Public Sub _ThresholdBinaryInv (
    threshold As TColor,
    maxValue As TColor
)
public:
void _ThresholdBinaryInv(
    TColor threshold,
    TColor maxValue
)
member _ThresholdBinaryInv :
        threshold : 'TColor *
        maxValue : 'TColor -> unit

Parameters

threshold
Type: TColor
The threshold value
maxValue
Type: TColor
The maximum value of the pixel on the result
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._ThresholdToZero Method

ImageTColor, TDepth_ThresholdToZero Method

Threshold the image inplace such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _ThresholdToZero(
    TColor threshold
)
Public Sub _ThresholdToZero (
    threshold As TColor
)
public:
void _ThresholdToZero(
    TColor threshold
)
member _ThresholdToZero :
        threshold : 'TColor -> unit

Parameters

threshold
Type: TColor
The threshold value
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._ThresholdToZeroInv Method

ImageTColor, TDepth_ThresholdToZeroInv Method

Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _ThresholdToZeroInv(
    TColor threshold
)
Public Sub _ThresholdToZeroInv (
    threshold As TColor
)
public:
void _ThresholdToZeroInv(
    TColor threshold
)
member _ThresholdToZeroInv :
        threshold : 'TColor -> unit

Parameters

threshold
Type: TColor
The threshold value
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth)._ThresholdTrunc Method

ImageTColor, TDepth_ThresholdTrunc Method

Threshold the image inplace such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void _ThresholdTrunc(
    TColor threshold
)
Public Sub _ThresholdTrunc (
    threshold As TColor
)
public:
void _ThresholdTrunc(
    TColor threshold
)
member _ThresholdTrunc :
        threshold : 'TColor -> unit

Parameters

threshold
Type: TColor
The threshold value
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).AbsDiff Method

ImageTColor, TDepthAbsDiff Method

Overload List
 | Name | Description
Public method | AbsDiff(TColor) | Computes absolute different between this image and the specific color
Public method | AbsDiff(ImageTColor, TDepth) | Computes absolute different between this image and the other image
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).AbsDiff Method (TColor)

ImageTColor, TDepthAbsDiff Method (TColor)

http://www.emgu.com
Computes absolute different between this image and the specific color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> AbsDiff(
    TColor color
)
Public Function AbsDiff (
    color As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ AbsDiff(
    TColor color
)
member AbsDiff :
        color : 'TColor -> Image<'TColor, 'TDepth>

Parameters

color
Type: TColor
The color to compute absolute different with

Return Value

Type: Image TColor, TDepth
The image that contains the absolute different value
See Also

Reference

ImageTColor, TDepth Class
AbsDiff Overload
Emgu.CV Namespace


Image(TColor, TDepth).AbsDiff Method (Image(TColor, TDepth))

ImageTColor, TDepthAbsDiff Method (ImageTColor, TDepth)

http://www.emgu.com
Computes absolute different between this image and the other image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> AbsDiff(
    Image<TColor, TDepth> img2
)
Public Function AbsDiff (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ AbsDiff(
    Image<TColor, TDepth>^ img2
)
member AbsDiff :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The other image to compute absolute different with

Return Value

Type: Image TColor, TDepth
The image that contains the absolute different value
See Also

Reference

ImageTColor, TDepth Class
AbsDiff Overload
Emgu.CV Namespace


Image(TColor, TDepth).Accumulate Method

ImageTColor, TDepthAccumulate Method

Overload List
 | Name | Description
Public method | Accumulate(ImageTColor, TDepth) | Accumulate img2 to the current image using the specific mask
Public method | Accumulate(ImageTColor, TDepth, ImageGray, Byte) | Accumulate img2 to the current image using the specific mask
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Accumulate Method (Image(TColor, TDepth))

ImageTColor, TDepthAccumulate Method (ImageTColor, TDepth)

http://www.emgu.com
Accumulate img2 to the current image using the specific mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Accumulate(
    Image<TColor, TDepth> img2
)
Public Sub Accumulate (
    img2 As Image(Of TColor, TDepth)
)
public:
void Accumulate(
    Image<TColor, TDepth>^ img2
)
member Accumulate :
        img2 : Image<'TColor, 'TDepth> -> unit

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The image to be added to the current image
See Also

Reference

ImageTColor, TDepth Class
Accumulate Overload
Emgu.CV Namespace


Image(TColor, TDepth).Accumulate Method (Image(TColor, TDepth), Image(Gray, Byte))

ImageTColor, TDepthAccumulate Method (ImageTColor, TDepth, ImageGray, Byte)

http://www.emgu.com
Accumulate img2 to the current image using the specific mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Accumulate(
    Image<TColor, TDepth> img2,
    Image<Gray, byte> mask
)
Public Sub Accumulate (
    img2 As Image(Of TColor, TDepth),
    mask As Image(Of Gray, Byte)
)
public:
void Accumulate(
    Image<TColor, TDepth>^ img2,
    Image<Gray^, unsigned char>^ mask
)
member Accumulate :
        img2 : Image<'TColor, 'TDepth> *
        mask : Image<Gray, byte> -> unit

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The image to be added to the current image
mask
Type: Emgu.CVImage Gray, Byte
the mask
See Also

Reference

ImageTColor, TDepth Class
Accumulate Overload
Emgu.CV Namespace


Image(TColor, TDepth).AccumulateWeighted Method

ImageTColor, TDepthAccumulateWeighted Method

Overload List
 | Name | Description
Public method | AccumulateWeighted(ImageTColor, TDepth, Double) | Update Running Average. this = (1-alpha)*this + alpha*img
Public method | AccumulateWeighted(ImageTColor, TDepth, Double, ImageGray, Byte) | Update Running Average. this = (1-alpha)*this + alpha*img, using the mask
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).AccumulateWeighted Method (Image(TColor, TDepth), Double)

ImageTColor, TDepthAccumulateWeighted Method (ImageTColor, TDepth, Double)

http://www.emgu.com
Update Running Average. this = (1-alpha)*this + alpha*img

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void AccumulateWeighted(
    Image<TColor, TDepth> img,
    double alpha
)
Public Sub AccumulateWeighted (
    img As Image(Of TColor, TDepth),
    alpha As Double
)
public:
void AccumulateWeighted(
    Image<TColor, TDepth>^ img,
    double alpha
)
member AccumulateWeighted :
        img : Image<'TColor, 'TDepth> *
        alpha : float -> unit

Parameters

img
Type: Emgu.CVImage TColor, TDepth
Input image, 1- or 3-channel, Byte or Single (each channel of multi-channel image is processed independently).
alpha
Type: SystemDouble
the weight of img
See Also

Reference

ImageTColor, TDepth Class
AccumulateWeighted Overload
Emgu.CV Namespace


Image(TColor, TDepth).AccumulateWeighted Method (Image(TColor, TDepth), Double, Image(Gray, Byte))

ImageTColor, TDepthAccumulateWeighted Method (ImageTColor, TDepth, Double, ImageGray, Byte)

http://www.emgu.com
Update Running Average. this = (1-alpha)*this + alpha*img, using the mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void AccumulateWeighted(
    Image<TColor, TDepth> img,
    double alpha,
    Image<Gray, byte> mask
)
Public Sub AccumulateWeighted (
    img As Image(Of TColor, TDepth),
    alpha As Double,
    mask As Image(Of Gray, Byte)
)
public:
void AccumulateWeighted(
    Image<TColor, TDepth>^ img,
    double alpha,
    Image<Gray^, unsigned char>^ mask
)
member AccumulateWeighted :
        img : Image<'TColor, 'TDepth> *
        alpha : float *
        mask : Image<Gray, byte> -> unit

Parameters

img
Type: Emgu.CVImage TColor, TDepth
Input image, 1- or 3-channel, Byte or Single (each channel of multi-channel image is processed independently).
alpha
Type: SystemDouble
The weight of img
mask
Type: Emgu.CVImage Gray, Byte
The mask for the running average
See Also

Reference

ImageTColor, TDepth Class
AccumulateWeighted Overload
Emgu.CV Namespace


Image(TColor, TDepth).Action Method

ImageTColor, TDepthAction Method

Overload List
 | Name | Description
Public method | Action(ActionTDepth) | perform an generic action based on each element of the image
Public method | ActionTOtherDepth(ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth) | Perform an generic operation based on the elements of the two images
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Action Method (Action(TDepth))

ImageTColor, TDepthAction Method (ActionTDepth)

http://www.emgu.com
perform an generic action based on each element of the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Action(
    Action<TDepth> action
)
Public Sub Action (
    action As Action(Of TDepth)
)
public:
void Action(
    Action<TDepth>^ action
)
member Action :
        action : Action<'TDepth> -> unit

Parameters

action
Type: SystemAction TDepth
The action to be applied to each element of the image
See Also

Reference

ImageTColor, TDepth Class
Action Overload
Emgu.CV Namespace


Image(TColor, TDepth).Action(TOtherDepth) Method (Image(TColor, TOtherDepth), Action(TDepth, TOtherDepth))

ImageTColor, TDepthActionTOtherDepth Method (ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth)

http://www.emgu.com
Perform an generic operation based on the elements of the two images

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Action<TOtherDepth>(
    Image<TColor, TOtherDepth> img2,
    Action<TDepth, TOtherDepth> action
)
where TOtherDepth : new()

Public Sub Action(Of TOtherDepth As New) (
    img2 As Image(Of TColor, TOtherDepth),
    action As Action(Of TDepth, TOtherDepth)
)
public:
generic<typename TOtherDepth>
where TOtherDepth : gcnew()
void Action(
    Image<TColor, TOtherDepth>^ img2,
    Action<TDepth, TOtherDepth>^ action
)
member Action :
        img2 : Image<'TColor, 'TOtherDepth> *
        action : Action<'TDepth, 'TOtherDepth> -> unit  when 'TOtherDepth : new()

Parameters

img2
Type: Emgu.CVImage TColor, TOtherDepth
The second image to perform action on
action
Type: SystemAction TDepth, TOtherDepth
An action such that the first parameter is the a single channel of a pixel from the first image, the second parameter is the corresponding channel of the correspondind pixel from the second image

Type Parameters

TOtherDepth
The depth of the second image
See Also

Reference

ImageTColor, TDepth Class
Action Overload
Emgu.CV Namespace


Image(TColor, TDepth).Add Method

ImageTColor, TDepthAdd Method

Overload List
 | Name | Description
Public method | Add(TColor) | Elementwise add a color val to the current image
Public method | Add(ImageTColor, TDepth) | Elementwise add another image with the current image
Public method | Add(ImageTColor, TDepth, ImageGray, Byte) | Elementwise add img2 with the current image, using a mask
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Add Method (TColor)

ImageTColor, TDepthAdd Method (TColor)

http://www.emgu.com
Elementwise add a color val to the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Add(
    TColor val
)
Public Function Add (
    val As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Add(
    TColor val
)
member Add :
        val : 'TColor -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color value to be added to the current image

Return Value

Type: Image TColor, TDepth
The result of elementwise adding color val from the current image
See Also

Reference

ImageTColor, TDepth Class
Add Overload
Emgu.CV Namespace


Image(TColor, TDepth).Add Method (Image(TColor, TDepth))

ImageTColor, TDepthAdd Method (ImageTColor, TDepth)

http://www.emgu.com
Elementwise add another image with the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Add(
    Image<TColor, TDepth> img2
)
Public Function Add (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Add(
    Image<TColor, TDepth>^ img2
)
member Add :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The image to be added to the current image

Return Value

Type: Image TColor, TDepth
The result of elementwise adding img2 to the current image
See Also

Reference

ImageTColor, TDepth Class
Add Overload
Emgu.CV Namespace


Image(TColor, TDepth).Add Method (Image(TColor, TDepth), Image(Gray, Byte))

ImageTColor, TDepthAdd Method (ImageTColor, TDepth, ImageGray, Byte)

http://www.emgu.com
Elementwise add img2 with the current image, using a mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Add(
    Image<TColor, TDepth> img2,
    Image<Gray, byte> mask
)
Public Function Add (
    img2 As Image(Of TColor, TDepth),
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Add(
    Image<TColor, TDepth>^ img2,
    Image<Gray^, unsigned char>^ mask
)
member Add :
        img2 : Image<'TColor, 'TDepth> *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The image to be added to the current image
mask
Type: Emgu.CVImage Gray, Byte
The mask for the add operation

Return Value

Type: Image TColor, TDepth
The result of elementwise adding img2 to the current image, using the specific mask
See Also

Reference

ImageTColor, TDepth Class
Add Overload
Emgu.CV Namespace


Image(TColor, TDepth).AddWeighted Method

ImageTColor, TDepthAddWeighted Method

Return the weighted sum such that: res = this * alpha + img2 * beta + gamma

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> AddWeighted(
    Image<TColor, TDepth> img2,
    double alpha,
    double beta,
    double gamma
)
Public Function AddWeighted (
    img2 As Image(Of TColor, TDepth),
    alpha As Double,
    beta As Double,
    gamma As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ AddWeighted(
    Image<TColor, TDepth>^ img2,
    double alpha,
    double beta,
    double gamma
)
member AddWeighted :
        img2 : Image<'TColor, 'TDepth> *
        alpha : float *
        beta : float *
        gamma : float -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
img2 in: res = this * alpha + img2 * beta + gamma
alpha
Type: SystemDouble
alpha in: res = this * alpha + img2 * beta + gamma
beta
Type: SystemDouble
beta in: res = this * alpha + img2 * beta + gamma
gamma
Type: SystemDouble
gamma in: res = this * alpha + img2 * beta + gamma

Return Value

Type: Image TColor, TDepth
this * alpha + img2 * beta + gamma
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).AllocateData Method

ImageTColor, TDepthAllocateData Method

Re-allocate data for the array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
)
Protected Overrides Sub AllocateData (
    rows As Integer,
    cols As Integer,
    numberOfChannels As Integer
)
protected:
virtual void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
) override
abstract AllocateData :
        rows : int *
        cols : int *
        numberOfChannels : int -> unit
override AllocateData :
        rows : int *
        cols : int *
        numberOfChannels : int -> unit

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of columns
numberOfChannels
Type: SystemInt32
The number of channels of this image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).And Method

ImageTColor, TDepthAnd Method

Overload List
 | Name | Description
Public method | And(TColor) | Perform an binary AND operation with some color
Public method | And(ImageTColor, TDepth) | Perform an elementwise AND operation with another image and return the result
Public method | And(TColor, ImageGray, Byte) | Perform an binary AND operation with some color using a mask
Public method | And(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise AND operation with another image, using a mask, and return the result
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).And Method (TColor)

ImageTColor, TDepthAnd Method (TColor)

http://www.emgu.com
Perform an binary AND operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> And(
    TColor val
)
Public Function And (
    val As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ And(
    TColor val
)
member And :
        val : 'TColor -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color for the AND operation

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
And Overload
Emgu.CV Namespace


Image(TColor, TDepth).And Method (Image(TColor, TDepth))

ImageTColor, TDepthAnd Method (ImageTColor, TDepth)

http://www.emgu.com
Perform an elementwise AND operation with another image and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> And(
    Image<TColor, TDepth> img2
)
Public Function And (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ And(
    Image<TColor, TDepth>^ img2
)
member And :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the AND operation

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
And Overload
Emgu.CV Namespace


Image(TColor, TDepth).And Method (TColor, Image(Gray, Byte))

ImageTColor, TDepthAnd Method (TColor, ImageGray, Byte)

http://www.emgu.com
Perform an binary AND operation with some color using a mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> And(
    TColor val,
    Image<Gray, byte> mask
)
Public Function And (
    val As TColor,
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ And(
    TColor val,
    Image<Gray^, unsigned char>^ mask
)
member And :
        val : 'TColor *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color for the AND operation
mask
Type: Emgu.CVImage Gray, Byte
The mask for the AND operation

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
And Overload
Emgu.CV Namespace


Image(TColor, TDepth).And Method (Image(TColor, TDepth), Image(Gray, Byte))

ImageTColor, TDepthAnd Method (ImageTColor, TDepth, ImageGray, Byte)

http://www.emgu.com
Perform an elementwise AND operation with another image, using a mask, and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> And(
    Image<TColor, TDepth> img2,
    Image<Gray, byte> mask
)
Public Function And (
    img2 As Image(Of TColor, TDepth),
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ And(
    Image<TColor, TDepth>^ img2,
    Image<Gray^, unsigned char>^ mask
)
member And :
        img2 : Image<'TColor, 'TDepth> *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the AND operation
mask
Type: Emgu.CVImage Gray, Byte
The mask for the AND operation

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
And Overload
Emgu.CV Namespace


Image(TColor, TDepth).AvgSdv Method

ImageTColor, TDepthAvgSdv Method

Overload List
 | Name | Description
Public method | AvgSdv(TColor, MCvScalar) | Calculates the average value and standard deviation of array elements, independently for each channel
Public method | AvgSdv(TColor, MCvScalar, ImageGray, Byte) | Calculates the average value and standard deviation of array elements, independently for each channel
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).AvgSdv Method (TColor, MCvScalar)

ImageTColor, TDepthAvgSdv Method (TColor, MCvScalar)

http://www.emgu.com
Calculates the average value and standard deviation of array elements, independently for each channel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void AvgSdv(
    out TColor avg,
    out MCvScalar sdv
)
Public Sub AvgSdv (
    <OutAttribute> ByRef avg As TColor,
    <OutAttribute> ByRef sdv As MCvScalar
)
public:
void AvgSdv(
    [OutAttribute] TColor% avg,
    [OutAttribute] MCvScalar^% sdv
)
member AvgSdv :
        avg : 'TColor byref *
        sdv : MCvScalar byref -> unit

Parameters

avg
Type: TColor
The avg color
sdv
Type: Emgu.CV.StructureMCvScalar
The standard deviation for each channel
See Also

Reference

ImageTColor, TDepth Class
AvgSdv Overload
Emgu.CV Namespace


Image(TColor, TDepth).AvgSdv Method (TColor, MCvScalar, Image(Gray, Byte))

ImageTColor, TDepthAvgSdv Method (TColor, MCvScalar, ImageGray, Byte)

http://www.emgu.com
Calculates the average value and standard deviation of array elements, independently for each channel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void AvgSdv(
    out TColor average,
    out MCvScalar sdv,
    Image<Gray, byte> mask
)
Public Sub AvgSdv (
    <OutAttribute> ByRef average As TColor,
    <OutAttribute> ByRef sdv As MCvScalar,
    mask As Image(Of Gray, Byte)
)
public:
void AvgSdv(
    [OutAttribute] TColor% average,
    [OutAttribute] MCvScalar^% sdv,
    Image<Gray^, unsigned char>^ mask
)
member AvgSdv :
        average : 'TColor byref *
        sdv : MCvScalar byref *
        mask : Image<Gray, byte> -> unit

Parameters

average
Type: TColor
The avg color
sdv
Type: Emgu.CV.StructureMCvScalar
The standard deviation for each channel
mask
Type: Emgu.CVImage Gray, Byte
The operation mask
See Also

Reference

ImageTColor, TDepth Class
AvgSdv Overload
Emgu.CV Namespace


Image(TColor, TDepth).BuildPyramid Method

ImageTColor, TDepthBuildPyramid Method

Compute the image pyramid

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth>[] BuildPyramid(
    int maxLevel
)
Public Function BuildPyramid (
    maxLevel As Integer
) As Image(Of TColor, TDepth)()
public:
array<Image<TColor, TDepth>^>^ BuildPyramid(
    int maxLevel
)
member BuildPyramid :
        maxLevel : int -> Image<'TColor, 'TDepth>[]

Parameters

maxLevel
Type: SystemInt32
The number of level's for the pyramid; Level 0 referes to the current image, level n is computed by calling the PyrDown() function on level n-1

Return Value

Type: Image TColor, TDepth
The image pyramid
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Canny Method

ImageTColor, TDepthCanny Method

Overload List
 | Name | Description
Public method | Canny(Double, Double) | Find the edges on this image and marked them in the returned image.
Public method | Canny(Double, Double, Int32, Boolean) | Find the edges on this image and marked them in the returned image.
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Canny Method (Double, Double)

ImageTColor, TDepthCanny Method (Double, Double)

http://www.emgu.com
Find the edges on this image and marked them in the returned image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, byte> Canny(
    double thresh,
    double threshLinking
)
Public Function Canny (
    thresh As Double,
    threshLinking As Double
) As Image(Of Gray, Byte)
public:
Image<Gray^, unsigned char>^ Canny(
    double thresh,
    double threshLinking
)
member Canny :
        thresh : float *
        threshLinking : float -> Image<Gray, byte>

Parameters

thresh
Type: SystemDouble
The threshhold to find initial segments of strong edges
threshLinking
Type: SystemDouble
The threshold used for edge Linking

Return Value

Type: Image Gray, Byte
The edges found by the Canny edge detector
See Also

Reference

ImageTColor, TDepth Class
Canny Overload
Emgu.CV Namespace


Image(TColor, TDepth).Canny Method (Double, Double, Int32, Boolean)

ImageTColor, TDepthCanny Method (Double, Double, Int32, Boolean)

http://www.emgu.com
Find the edges on this image and marked them in the returned image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, byte> Canny(
    double thresh,
    double threshLinking,
    int apertureSize,
    bool l2Gradient
)
Public Function Canny (
    thresh As Double,
    threshLinking As Double,
    apertureSize As Integer,
    l2Gradient As Boolean
) As Image(Of Gray, Byte)
public:
Image<Gray^, unsigned char>^ Canny(
    double thresh,
    double threshLinking,
    int apertureSize,
    bool l2Gradient
)
member Canny :
        thresh : float *
        threshLinking : float *
        apertureSize : int *
        l2Gradient : bool -> Image<Gray, byte>

Parameters

thresh
Type: SystemDouble
The threshhold to find initial segments of strong edges
threshLinking
Type: SystemDouble
The threshold used for edge Linking
apertureSize
Type: SystemInt32
The aperture size, use 3 for default
l2Gradient
Type: SystemBoolean
a flag, indicating whether a more accurate norm should be used to calculate the image gradient magnitude ( L2gradient=true ), or whether the default norm is enough ( L2gradient=false ).

Return Value

Type: Image Gray, Byte
The edges found by the Canny edge detector
See Also

Reference

ImageTColor, TDepth Class
Canny Overload
Emgu.CV Namespace


Image(TColor, TDepth).Clone Method

ImageTColor, TDepthClone Method

Make a clone of the current image. All image data as well as the COI and ROI are cloned

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Clone()
Public Function Clone As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Clone()
member Clone : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
A clone of the current image. All image data as well as the COI and ROI are cloned
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Cmp Method

ImageTColor, TDepthCmp Method

Overload List
 | Name | Description
Public method | Cmp(Double, CmpType) | Compare the current image with value and returns the comparison mask
Public method | Cmp(ImageTColor, TDepth, CmpType) | Compare the current image with img2 and returns the comparison mask
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Cmp Method (Double, CmpType)

ImageTColor, TDepthCmp Method (Double, CmpType)

http://www.emgu.com
Compare the current image with value and returns the comparison mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, byte> Cmp(
    double value,
    CmpType comparisonType
)
Public Function Cmp (
    value As Double,
    comparisonType As CmpType
) As Image(Of TColor, Byte)
public:
Image<TColor, unsigned char>^ Cmp(
    double value,
    CmpType^ comparisonType
)
member Cmp :
        value : float *
        comparisonType : CmpType -> Image<'TColor, byte>

Parameters

value
Type: SystemDouble
The value to compare with
comparisonType
Type: Emgu.CV.CvEnumCmpType
The comparison type

Return Value

Type: Image TColor, Byte
The result of the comparison as a mask
See Also

Reference

ImageTColor, TDepth Class
Cmp Overload
Emgu.CV Namespace


Image(TColor, TDepth).Cmp Method (Image(TColor, TDepth), CmpType)

ImageTColor, TDepthCmp Method (ImageTColor, TDepth, CmpType)

http://www.emgu.com
Compare the current image with img2 and returns the comparison mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, byte> Cmp(
    Image<TColor, TDepth> img2,
    CmpType cmpType
)
Public Function Cmp (
    img2 As Image(Of TColor, TDepth),
    cmpType As CmpType
) As Image(Of TColor, Byte)
public:
Image<TColor, unsigned char>^ Cmp(
    Image<TColor, TDepth>^ img2,
    CmpType^ cmpType
)
member Cmp :
        img2 : Image<'TColor, 'TDepth> *
        cmpType : CmpType -> Image<'TColor, byte>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The other image to compare with
cmpType
Type: Emgu.CV.CvEnumCmpType
The comparison type

Return Value

Type: Image TColor, Byte
The result of the comparison as a mask
See Also

Reference

ImageTColor, TDepth Class
Cmp Overload
Emgu.CV Namespace


Image(TColor, TDepth).ConcateHorizontal Method

ImageTColor, TDepthConcateHorizontal Method

Concate the current image with another image horizontally.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ConcateHorizontal(
    Image<TColor, TDepth> otherImage
)
Public Function ConcateHorizontal (
    otherImage As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ConcateHorizontal(
    Image<TColor, TDepth>^ otherImage
)
member ConcateHorizontal :
        otherImage : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

otherImage
Type: Emgu.CVImage TColor, TDepth
The other image to concate

Return Value

Type: Image TColor, TDepth
A new image that is the horizontal concatening of this image and otherImage
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ConcateVertical Method

ImageTColor, TDepthConcateVertical Method

Concate the current image with another image vertically.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ConcateVertical(
    Image<TColor, TDepth> otherImage
)
Public Function ConcateVertical (
    otherImage As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ConcateVertical(
    Image<TColor, TDepth>^ otherImage
)
member ConcateVertical :
        otherImage : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

otherImage
Type: Emgu.CVImage TColor, TDepth
The other image to concate

Return Value

Type: Image TColor, TDepth
A new image that is the vertical concatening of this image and otherImage
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Convert Method

ImageTColor, TDepthConvert Method

Overload List
 | Name | Description
Public method | ConvertTOtherColor, TOtherDepth | Convert the current image to the specific color and depth
Public method | ConvertTOtherDepth(FuncTDepth, TOtherDepth) | Compute the element of the new image based on element of this image
Public method | ConvertTOtherDepth(FuncTDepth, Int32, Int32, TOtherDepth) | Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image
Public method | ConvertTDepth2, TDepth3(ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3) | Compute the element of the new image based on the elements of the two image
Public method | ConvertTDepth2, TDepth3, TDepth4(ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4) | Compute the element of the new image based on the elements of the three image
Public method | ConvertTDepth2, TDepth3, TDepth4, TDepth5(ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5) | Compute the element of the new image based on the elements of the four image
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Convert(TOtherColor, TOtherDepth) Method

ImageTColor, TDepthConvertTOtherColor, TOtherDepth Method

Convert the current image to the specific color and depth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TOtherColor, TOtherDepth> Convert<TOtherColor, TOtherDepth>()
where TOtherColor : struct, new(), IColor
where TOtherDepth : new()

Public Function Convert(Of TOtherColor As {Structure, New, IColor}, TOtherDepth As New) As Image(Of TOtherColor, TOtherDepth)
public:
generic<typename TOtherColor, typename TOtherDepth>
where TOtherColor : value class, gcnew(), IColor
where TOtherDepth : gcnew()
Image<TOtherColor, TOtherDepth>^ Convert()
member Convert : unit -> Image<'TOtherColor, 'TOtherDepth>  when 'TOtherColor : struct, new() and IColor when 'TOtherDepth : new()

Type Parameters

TOtherColor
The type of color to be converted to
TOtherDepth
The type of pixel depth to be converted to

Return Value

Type: Image TOtherColor, TOtherDepth
Image of the specific color and depth
See Also

Reference

ImageTColor, TDepth Class
Convert Overload
Emgu.CV Namespace


Image(TColor, TDepth).Convert(TOtherDepth) Method (Func(TDepth, TOtherDepth))

ImageTColor, TDepthConvertTOtherDepth Method (FuncTDepth, TOtherDepth)

http://www.emgu.com
Compute the element of the new image based on element of this image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TOtherDepth> Convert<TOtherDepth>(
    Func<TDepth, TOtherDepth> converter
)
where TOtherDepth : new()

Public Function Convert(Of TOtherDepth As New) (
    converter As Func(Of TDepth, TOtherDepth)
) As Image(Of TColor, TOtherDepth)
public:
generic<typename TOtherDepth>
where TOtherDepth : gcnew()
Image<TColor, TOtherDepth>^ Convert(
    Func<TDepth, TOtherDepth>^ converter
)
member Convert :
        converter : Func<'TDepth, 'TOtherDepth> -> Image<'TColor, 'TOtherDepth>  when 'TOtherDepth : new()

Parameters

converter
Type: SystemFunc TDepth, TOtherDepth
The function to be applied to the image pixels

Type Parameters

TOtherDepth
The depth type of the result image

Return Value

Type: Image TColor, TOtherDepth
The result image
See Also

Reference

ImageTColor, TDepth Class
Convert Overload
Emgu.CV Namespace


Image(TColor, TDepth).Convert(TOtherDepth) Method (Func(TDepth, Int32, Int32, TOtherDepth))

ImageTColor, TDepthConvertTOtherDepth Method (FuncTDepth, Int32, Int32, TOtherDepth)

http://www.emgu.com
Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TOtherDepth> Convert<TOtherDepth>(
    Func<TDepth, int, int, TOtherDepth> converter
)
where TOtherDepth : new()

Public Function Convert(Of TOtherDepth As New) (
    converter As Func(Of TDepth, Integer, Integer, TOtherDepth)
) As Image(Of TColor, TOtherDepth)
public:
generic<typename TOtherDepth>
where TOtherDepth : gcnew()
Image<TColor, TOtherDepth>^ Convert(
    Func<TDepth, int, int, TOtherDepth>^ converter
)
member Convert :
        converter : Func<'TDepth, int, int, 'TOtherDepth> -> Image<'TColor, 'TOtherDepth>  when 'TOtherDepth : new()

Parameters

converter
Type: SystemFunc TDepth, Int32, Int32, TOtherDepth
The function to be applied to the image pixels

Type Parameters

TOtherDepth

[Missing <typeparam name="TOtherDepth"/> documentation for "M:Emgu.CV.Image`2.Convert``1(System.Func{`1,System.Int32,System.Int32,``0})"]

Return Value

Type: Image TColor, TOtherDepth
The result image
See Also

Reference

ImageTColor, TDepth Class
Convert Overload
Emgu.CV Namespace


Image(TColor, TDepth).Convert(TDepth2, TDepth3) Method (Image(TColor, TDepth2), Func(TDepth, TDepth2, TDepth3))

ImageTColor, TDepthConvertTDepth2, TDepth3 Method (ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3)

http://www.emgu.com
Compute the element of the new image based on the elements of the two image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth3> Convert<TDepth2, TDepth3>(
    Image<TColor, TDepth2> img2,
    Func<TDepth, TDepth2, TDepth3> converter
)
where TDepth2 : new()
where TDepth3 : new()

Public Function Convert(Of TDepth2 As New, TDepth3 As New) (
    img2 As Image(Of TColor, TDepth2),
    converter As Func(Of TDepth, TDepth2, TDepth3)
) As Image(Of TColor, TDepth3)
public:
generic<typename TDepth2, typename TDepth3>
where TDepth2 : gcnew()
where TDepth3 : gcnew()
Image<TColor, TDepth3>^ Convert(
    Image<TColor, TDepth2>^ img2,
    Func<TDepth, TDepth2, TDepth3>^ converter
)
member Convert :
        img2 : Image<'TColor, 'TDepth2> *
        converter : Func<'TDepth, 'TDepth2, 'TDepth3> -> Image<'TColor, 'TDepth3>  when 'TDepth2 : new() when 'TDepth3 : new()

Parameters

img2
Type: Emgu.CVImage TColor, TDepth2
The second image
converter
Type: SystemFunc TDepth, TDepth2, TDepth3
The function to be applied to the image pixels

Type Parameters

TDepth2
The depth type of img2
TDepth3
The depth type of the result image

Return Value

Type: Image TColor, TDepth3
The result image
See Also

Reference

ImageTColor, TDepth Class
Convert Overload
Emgu.CV Namespace


Image(TColor, TDepth).Convert(TDepth2, TDepth3, TDepth4) Method (Image(TColor, TDepth2), Image(TColor, TDepth3), Func(TDepth, TDepth2, TDepth3, TDepth4))

ImageTColor, TDepthConvertTDepth2, TDepth3, TDepth4 Method (ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4)

http://www.emgu.com
Compute the element of the new image based on the elements of the three image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth4> Convert<TDepth2, TDepth3, TDepth4>(
    Image<TColor, TDepth2> img2,
    Image<TColor, TDepth3> img3,
    Func<TDepth, TDepth2, TDepth3, TDepth4> converter
)
where TDepth2 : new()
where TDepth3 : new()
where TDepth4 : new()

Public Function Convert(Of TDepth2 As New, TDepth3 As New, TDepth4 As New) (
    img2 As Image(Of TColor, TDepth2),
    img3 As Image(Of TColor, TDepth3),
    converter As Func(Of TDepth, TDepth2, TDepth3, TDepth4)
) As Image(Of TColor, TDepth4)
public:
generic<typename TDepth2, typename TDepth3, typename TDepth4>
where TDepth2 : gcnew()
where TDepth3 : gcnew()
where TDepth4 : gcnew()
Image<TColor, TDepth4>^ Convert(
    Image<TColor, TDepth2>^ img2,
    Image<TColor, TDepth3>^ img3,
    Func<TDepth, TDepth2, TDepth3, TDepth4>^ converter
)
member Convert :
        img2 : Image<'TColor, 'TDepth2> *
        img3 : Image<'TColor, 'TDepth3> *
        converter : Func<'TDepth, 'TDepth2, 'TDepth3, 'TDepth4> -> Image<'TColor, 'TDepth4>  when 'TDepth2 : new() when 'TDepth3 : new() when 'TDepth4 : new()

Parameters

img2
Type: Emgu.CVImage TColor, TDepth2
The second image
img3
Type: Emgu.CVImage TColor, TDepth3
The third image
converter
Type: SystemFunc TDepth, TDepth2, TDepth3, TDepth4
The function to be applied to the image pixels

Type Parameters

TDepth2
The depth type of img2
TDepth3
The depth type of img3
TDepth4
The depth type of the result image

Return Value

Type: Image TColor, TDepth4
The result image
See Also

Reference

ImageTColor, TDepth Class
Convert Overload
Emgu.CV Namespace


Image(TColor, TDepth).Convert(TDepth2, TDepth3, TDepth4, TDepth5) Method (Image(TColor, TDepth2), Image(TColor, TDepth3), Image(TColor, TDepth4), Func(TDepth, TDepth2, TDepth3, TDepth4, TDepth5))

ImageTColor, TDepthConvertTDepth2, TDepth3, TDepth4, TDepth5 Method (ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5)

http://www.emgu.com
Compute the element of the new image based on the elements of the four image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth5> Convert<TDepth2, TDepth3, TDepth4, TDepth5>(
    Image<TColor, TDepth2> img2,
    Image<TColor, TDepth3> img3,
    Image<TColor, TDepth4> img4,
    Func<TDepth, TDepth2, TDepth3, TDepth4, TDepth5> converter
)
where TDepth2 : new()
where TDepth3 : new()
where TDepth4 : new()
where TDepth5 : new()

Public Function Convert(Of TDepth2 As New, TDepth3 As New, TDepth4 As New, TDepth5 As New) (
    img2 As Image(Of TColor, TDepth2),
    img3 As Image(Of TColor, TDepth3),
    img4 As Image(Of TColor, TDepth4),
    converter As Func(Of TDepth, TDepth2, TDepth3, TDepth4, TDepth5)
) As Image(Of TColor, TDepth5)
public:
generic<typename TDepth2, typename TDepth3, typename TDepth4, typename TDepth5>
where TDepth2 : gcnew()
where TDepth3 : gcnew()
where TDepth4 : gcnew()
where TDepth5 : gcnew()
Image<TColor, TDepth5>^ Convert(
    Image<TColor, TDepth2>^ img2,
    Image<TColor, TDepth3>^ img3,
    Image<TColor, TDepth4>^ img4,
    Func<TDepth, TDepth2, TDepth3, TDepth4, TDepth5>^ converter
)
member Convert :
        img2 : Image<'TColor, 'TDepth2> *
        img3 : Image<'TColor, 'TDepth3> *
        img4 : Image<'TColor, 'TDepth4> *
        converter : Func<'TDepth, 'TDepth2, 'TDepth3, 'TDepth4, 'TDepth5> -> Image<'TColor, 'TDepth5>  when 'TDepth2 : new() when 'TDepth3 : new() when 'TDepth4 : new() when 'TDepth5 : new()

Parameters

img2
Type: Emgu.CVImage TColor, TDepth2
The second image
img3
Type: Emgu.CVImage TColor, TDepth3
The third image
img4
Type: Emgu.CVImage TColor, TDepth4
The fourth image
converter
Type: SystemFunc TDepth, TDepth2, TDepth3, TDepth4, TDepth5
The function to be applied to the image pixels

Type Parameters

TDepth2
The depth type of img2
TDepth3
The depth type of img3
TDepth4
The depth type of img4
TDepth5
The depth type of the result image

Return Value

Type: Image TColor, TDepth5
The result image
See Also

Reference

ImageTColor, TDepth Class
Convert Overload
Emgu.CV Namespace


Image(TColor, TDepth).ConvertFrom Method

ImageTColor, TDepthConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(IInputArray) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Public method | ConvertFromTSrcColor, TSrcDepth(ImageTSrcColor, TSrcDepth) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ConvertFrom Method (IInputArray)

ImageTColor, TDepthConvertFrom Method (IInputArray)

http://www.emgu.com
Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ConvertFrom(
    IInputArray srcImage
)
Public Sub ConvertFrom (
    srcImage As IInputArray
)
public:
void ConvertFrom(
    IInputArray^ srcImage
)
member ConvertFrom :
        srcImage : IInputArray -> unit

Parameters

srcImage
Type: Emgu.CVIInputArray
The sourceImage
See Also

Reference

ImageTColor, TDepth Class
ConvertFrom Overload
Emgu.CV Namespace


Image(TColor, TDepth).ConvertFrom(TSrcColor, TSrcDepth) Method (Image(TSrcColor, TSrcDepth))

ImageTColor, TDepthConvertFromTSrcColor, TSrcDepth Method (ImageTSrcColor, TSrcDepth)

http://www.emgu.com
Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ConvertFrom<TSrcColor, TSrcDepth>(
    Image<TSrcColor, TSrcDepth> srcImage
)
where TSrcColor : struct, new(), IColor
where TSrcDepth : new()

Public Sub ConvertFrom(Of TSrcColor As {Structure, New, IColor}, TSrcDepth As New) (
    srcImage As Image(Of TSrcColor, TSrcDepth)
)
public:
generic<typename TSrcColor, typename TSrcDepth>
where TSrcColor : value class, gcnew(), IColor
where TSrcDepth : gcnew()
void ConvertFrom(
    Image<TSrcColor, TSrcDepth>^ srcImage
)
member ConvertFrom :
        srcImage : Image<'TSrcColor, 'TSrcDepth> -> unit  when 'TSrcColor : struct, new() and IColor when 'TSrcDepth : new()

Parameters

srcImage
Type: Emgu.CVImage TSrcColor, TSrcDepth
The sourceImage

Type Parameters

TSrcColor
The color type of the source image
TSrcDepth
The color depth of the source image
See Also

Reference

ImageTColor, TDepth Class
ConvertFrom Overload
Emgu.CV Namespace


Image(TColor, TDepth).ConvertScale(TOtherDepth) Method

ImageTColor, TDepthConvertScaleTOtherDepth Method

Convert the current image to the specific depth, at the same time scale and shift the values of the pixel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TOtherDepth> ConvertScale<TOtherDepth>(
    double scale,
    double shift
)
where TOtherDepth : new()

Public Function ConvertScale(Of TOtherDepth As New) (
    scale As Double,
    shift As Double
) As Image(Of TColor, TOtherDepth)
public:
generic<typename TOtherDepth>
where TOtherDepth : gcnew()
Image<TColor, TOtherDepth>^ ConvertScale(
    double scale,
    double shift
)
member ConvertScale :
        scale : float *
        shift : float -> Image<'TColor, 'TOtherDepth>  when 'TOtherDepth : new()

Parameters

scale
Type: SystemDouble
The value to be multiplied with the pixel
shift
Type: SystemDouble
The value to be added to the pixel

Type Parameters

TOtherDepth
The type of depth to convert to

Return Value

Type: Image TColor, TOtherDepth
Image of the specific depth, val = val * scale + shift
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Convolution Method

ImageTColor, TDepthConvolution Method

Performs a convolution using the specific kernel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, float> Convolution(
    ConvolutionKernelF kernel,
    double delta = 0,
    BorderType borderType = 4
)
Public Function Convolution (
    kernel As ConvolutionKernelF,
    Optional delta As Double = 0,
    Optional borderType As BorderType = 4
) As Image(Of TColor, Single)
public:
Image<TColor, float>^ Convolution(
    ConvolutionKernelF^ kernel,
    double delta = 0,
    BorderType^ borderType = 4
)
member Convolution :
        kernel : ConvolutionKernelF *
        ?delta : float *
        ?borderType : BorderType
(* Defaults:
        let _delta = defaultArg delta 0
        let _borderType = defaultArg borderType 4
*)
-> Image<'TColor, float32>

Parameters

kernel
Type: Emgu.CVConvolutionKernelF
The convolution kernel
delta (Optional)
Type: SystemDouble
The optional value added to the filtered pixels before storing them in dst
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The pixel extrapolation method.

Return Value

Type: Image TColor, Single
The result of the convolution
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Copy Method

ImageTColor, TDepthCopy Method

Overload List
 | Name | Description
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Copy Method

ImageTColor, TDepthCopy Method

Make a copy of the image, if ROI is set, only copy the ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Copy()
Public Function Copy As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Copy()
member Copy : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
A copy of the image
See Also

Reference

ImageTColor, TDepth Class
Copy Overload
Emgu.CV Namespace


Image(TColor, TDepth).Copy Method (Rectangle)

ImageTColor, TDepthCopy Method (Rectangle)

http://www.emgu.com
Make a copy of the specific ROI (Region of Interest) from the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Copy(
    Rectangle roi
)
Public Function Copy (
    roi As Rectangle
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Copy(
    Rectangle^ roi
)
member Copy :
        roi : Rectangle -> Image<'TColor, 'TDepth>

Parameters

roi
Type: System.DrawingRectangle
The roi to be copied

Return Value

Type: Image TColor, TDepth
The region of interest
See Also

Reference

ImageTColor, TDepth Class
Copy Overload
Emgu.CV Namespace


Image(TColor, TDepth).Copy Method (Image(Gray, Byte))

ImageTColor, TDepthCopy Method (ImageGray, Byte)

http://www.emgu.com
Make a copy of the image using a mask, if ROI is set, only copy the ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Copy(
    Image<Gray, byte> mask
)
Public Function Copy (
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Copy(
    Image<Gray^, unsigned char>^ mask
)
member Copy :
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

mask
Type: Emgu.CVImage Gray, Byte
the mask for coping

Return Value

Type: Image TColor, TDepth
A copy of the image
See Also

Reference

ImageTColor, TDepth Class
Copy Overload
Emgu.CV Namespace


Image(TColor, TDepth).Copy Method (RotatedRect)

ImageTColor, TDepthCopy Method (RotatedRect)

http://www.emgu.com
Get a copy of the boxed region of the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Copy(
    RotatedRect box
)
Public Function Copy (
    box As RotatedRect
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Copy(
    RotatedRect^ box
)
member Copy :
        box : RotatedRect -> Image<'TColor, 'TDepth>

Parameters

box
Type: Emgu.CV.StructureRotatedRect
The boxed region of the image

Return Value

Type: Image TColor, TDepth
A copy of the boxed region of the image
See Also

Reference

ImageTColor, TDepth Class
Copy Overload
Emgu.CV Namespace


Image(TColor, TDepth).Copy Method (Image(TColor, TDepth), Image(Gray, Byte))

ImageTColor, TDepthCopy Method (ImageTColor, TDepth, ImageGray, Byte)

http://www.emgu.com
Copy the masked area of this image to destination

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Copy(
    Image<TColor, TDepth> dest,
    Image<Gray, byte> mask
)
Public Sub Copy (
    dest As Image(Of TColor, TDepth),
    mask As Image(Of Gray, Byte)
)
public:
void Copy(
    Image<TColor, TDepth>^ dest,
    Image<Gray^, unsigned char>^ mask
)
member Copy :
        dest : Image<'TColor, 'TDepth> *
        mask : Image<Gray, byte> -> unit

Parameters

dest
Type: Emgu.CVImage TColor, TDepth
the destination to copy to
mask
Type: Emgu.CVImage Gray, Byte
the mask for copy
See Also

Reference

ImageTColor, TDepth Class
Copy Overload
Emgu.CV Namespace


Image(TColor, TDepth).CopyBlank Method

ImageTColor, TDepthCopyBlank Method

Create an image of the same size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> CopyBlank()
Public Function CopyBlank As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ CopyBlank()
member CopyBlank : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
The image of the same size
Remarks
The initial pixel in the image equals zero
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).CountNonzero Method

ImageTColor, TDepthCountNonzero Method

Count the non Zero elements for each channel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] CountNonzero()
Public Function CountNonzero As Integer()
public:
array<int>^ CountNonzero()
member CountNonzero : unit -> int[]

Return Value

Type: Int32
Count the non Zero elements for each channel
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Dilate Method

ImageTColor, TDepthDilate Method

Dilates this image using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Dilate(
    int iterations
)
Public Function Dilate (
    iterations As Integer
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Dilate(
    int iterations
)
member Dilate :
        iterations : int -> Image<'TColor, 'TDepth>

Parameters

iterations
Type: SystemInt32
The number of dilate iterations

Return Value

Type: Image TColor, TDepth
The dilated image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).DisposeObject Method

ImageTColor, TDepthDisposeObject Method

Release all unmanaged memory associate with the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method

ImageTColor, TDepthDraw Method

Overload List
 | Name | Description
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon using the specific color and thickness
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (Cross2DF, TColor, Int32)

ImageTColor, TDepthDraw Method (Cross2DF, TColor, Int32)

http://www.emgu.com
Draw a 2D Cross using the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    Cross2DF cross,
    TColor color,
    int thickness
)
Public Sub Draw (
    cross As Cross2DF,
    color As TColor,
    thickness As Integer
)
public:
void Draw(
    Cross2DF^ cross,
    TColor color,
    int thickness
)
member Draw :
        cross : Cross2DF *
        color : 'TColor *
        thickness : int -> unit

Parameters

cross
Type: Emgu.CV.StructureCross2DF
The 2D Cross to be drawn
color
Type: TColor
The color of the cross
thickness
Type: SystemInt32
Must be > 0
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (IConvexPolygonF, TColor, Int32)

ImageTColor, TDepthDraw Method (IConvexPolygonF, TColor, Int32)

http://www.emgu.com
Draw a convex polygon using the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Draw(
    IConvexPolygonF polygon,
    TColor color,
    int thickness
)
Public Overridable Sub Draw (
    polygon As IConvexPolygonF,
    color As TColor,
    thickness As Integer
)
public:
virtual void Draw(
    IConvexPolygonF^ polygon,
    TColor color,
    int thickness
)
abstract Draw :
        polygon : IConvexPolygonF *
        color : 'TColor *
        thickness : int -> unit
override Draw :
        polygon : IConvexPolygonF *
        color : 'TColor *
        thickness : int -> unit

Parameters

polygon
Type: Emgu.CVIConvexPolygonF
The convex polygon to be drawn
color
Type: TColor
The color of the triangle
thickness
Type: SystemInt32
If thickness is less than 1, the triangle is filled up
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (Point[], TColor, Int32, LineType, Point)

ImageTColor, TDepthDraw Method (Point, TColor, Int32, LineType, Point)

http://www.emgu.com
Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    Point[] contours,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    Point offset = null
)
Public Sub Draw (
    contours As Point(),
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional offset As Point = Nothing
)
public:
void Draw(
    array<Point^>^ contours,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    Point^ offset = nullptr
)
member Draw :
        contours : Point[] *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?offset : Point
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _offset = defaultArg offset null
*)
-> unit

Parameters

contours
Type: System.DrawingPoint
The input contour stored as a point vector.
color
Type: TColor
Color of the contours
thickness (Optional)
Type: SystemInt32
Thickness of lines the contours are drawn with. If it is negative the contour interiors are drawn
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the contour segments
offset (Optional)
Type: System.DrawingPoint
Shift all the point coordinates by the specified value. It is useful in case if the contours retrieved in some image ROI and then the ROI offset needs to be taken into account during the rendering.
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (Rectangle, TColor, Int32, LineType, Int32)

ImageTColor, TDepthDraw Method (Rectangle, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw an Rectangle of the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Draw(
    Rectangle rect,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Overridable Sub Draw (
    rect As Rectangle,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
virtual void Draw(
    Rectangle^ rect,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
abstract Draw :
        rect : Rectangle *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit
override Draw :
        rect : Rectangle *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle to be drawn
color
Type: TColor
The color of the rectangle
thickness (Optional)
Type: SystemInt32
If thickness is less than 1, the rectangle is filled up
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (CircleF, TColor, Int32, LineType, Int32)

ImageTColor, TDepthDraw Method (CircleF, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw a Circle of the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Draw(
    CircleF circle,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Overridable Sub Draw (
    circle As CircleF,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
virtual void Draw(
    CircleF^ circle,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
abstract Draw :
        circle : CircleF *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit
override Draw :
        circle : CircleF *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

circle
Type: Emgu.CV.StructureCircleF
The circle to be drawn
color
Type: TColor
The color of the circle
thickness (Optional)
Type: SystemInt32
If thickness is less than 1, the circle is filled up
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (Ellipse, TColor, Int32, LineType, Int32)

ImageTColor, TDepthDraw Method (Ellipse, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw a Ellipse of the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    Ellipse ellipse,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Sub Draw (
    ellipse As Ellipse,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
void Draw(
    Ellipse^ ellipse,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
member Draw :
        ellipse : Ellipse *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

ellipse
Type: Emgu.CV.StructureEllipse
The ellipse to be draw
color
Type: TColor
The color of the ellipse
thickness (Optional)
Type: SystemInt32
If thickness is less than 1, the ellipse is filled up
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (LineSegment2D, TColor, Int32, LineType, Int32)

ImageTColor, TDepthDraw Method (LineSegment2D, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw a line segment using the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Draw(
    LineSegment2D line,
    TColor color,
    int thickness,
    LineType lineType = 8,
    int shift = 0
)
Public Overridable Sub Draw (
    line As LineSegment2D,
    color As TColor,
    thickness As Integer,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
virtual void Draw(
    LineSegment2D^ line,
    TColor color,
    int thickness,
    LineType^ lineType = 8,
    int shift = 0
)
abstract Draw :
        line : LineSegment2D *
        color : 'TColor *
        thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit
override Draw :
        line : LineSegment2D *
        color : 'TColor *
        thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

line
Type: Emgu.CV.StructureLineSegment2D
The line segment to be drawn
color
Type: TColor
The color of the line segment
thickness
Type: SystemInt32
The thickness of the line segment
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (LineSegment2DF, TColor, Int32, LineType, Int32)

ImageTColor, TDepthDraw Method (LineSegment2DF, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw a line segment using the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Draw(
    LineSegment2DF line,
    TColor color,
    int thickness,
    LineType lineType = 8,
    int shift = 0
)
Public Overridable Sub Draw (
    line As LineSegment2DF,
    color As TColor,
    thickness As Integer,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
virtual void Draw(
    LineSegment2DF^ line,
    TColor color,
    int thickness,
    LineType^ lineType = 8,
    int shift = 0
)
abstract Draw :
        line : LineSegment2DF *
        color : 'TColor *
        thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit
override Draw :
        line : LineSegment2DF *
        color : 'TColor *
        thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

line
Type: Emgu.CV.StructureLineSegment2DF
The line segment to be drawn
color
Type: TColor
The color of the line segment
thickness
Type: SystemInt32
The thickness of the line segment
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (String, Point, FontFace, Double, TColor, Int32, LineType, Boolean)

ImageTColor, TDepthDraw Method (String, Point, FontFace, Double, TColor, Int32, LineType, Boolean)

http://www.emgu.com
Draw the text using the specific font on the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Draw(
    string message,
    Point bottomLeft,
    FontFace fontFace,
    double fontScale,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    bool bottomLeftOrigin = false
)
Public Overridable Sub Draw (
    message As String,
    bottomLeft As Point,
    fontFace As FontFace,
    fontScale As Double,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional bottomLeftOrigin As Boolean = false
)
public:
virtual void Draw(
    String^ message,
    Point^ bottomLeft,
    FontFace^ fontFace,
    double fontScale,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    bool bottomLeftOrigin = false
)
abstract Draw :
        message : string *
        bottomLeft : Point *
        fontFace : FontFace *
        fontScale : float *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?bottomLeftOrigin : bool
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _bottomLeftOrigin = defaultArg bottomLeftOrigin false
*)
-> unit
override Draw :
        message : string *
        bottomLeft : Point *
        fontFace : FontFace *
        fontScale : float *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?bottomLeftOrigin : bool
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _bottomLeftOrigin = defaultArg bottomLeftOrigin false
*)
-> unit

Parameters

message
Type: SystemString
The text message to be draw
bottomLeft
Type: System.DrawingPoint
The location of the bottom left corner of the font
fontFace
Type: Emgu.CV.CvEnumFontFace
Font type.
fontScale
Type: SystemDouble
Font scale factor that is multiplied by the font-specific base size.
color
Type: TColor
The color of the text
thickness (Optional)
Type: SystemInt32
Thickness of the lines used to draw a text.
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
bottomLeftOrigin (Optional)
Type: SystemBoolean
When true, the image data origin is at the bottom-left corner. Otherwise, it is at the top-left corner.
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).Draw Method (IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point)

ImageTColor, TDepthDraw Method (IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point)

http://www.emgu.com
Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    IInputArrayOfArrays contours,
    int contourIdx,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    IInputArray hierarchy = null,
    int maxLevel = 2147483647,
    Point offset = null
)
Public Sub Draw (
    contours As IInputArrayOfArrays,
    contourIdx As Integer,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional hierarchy As IInputArray = Nothing,
    Optional maxLevel As Integer = 2147483647,
    Optional offset As Point = Nothing
)
public:
void Draw(
    IInputArrayOfArrays^ contours,
    int contourIdx,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    IInputArray^ hierarchy = nullptr,
    int maxLevel = 2147483647,
    Point^ offset = nullptr
)
member Draw :
        contours : IInputArrayOfArrays *
        contourIdx : int *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?hierarchy : IInputArray *
        ?maxLevel : int *
        ?offset : Point
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _hierarchy = defaultArg hierarchy null
        let _maxLevel = defaultArg maxLevel 2147483647
        let _offset = defaultArg offset null
*)
-> unit

Parameters

contours
Type: Emgu.CVIInputArrayOfArrays
All the input contours. Each contour is stored as a point vector.
contourIdx
Type: SystemInt32
Parameter indicating a contour to draw. If it is negative, all the contours are drawn.
color
Type: TColor
Color of the contours
thickness (Optional)
Type: SystemInt32
Thickness of lines the contours are drawn with. If it is negative the contour interiors are drawn
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Type of the contour segments
hierarchy (Optional)
Type: Emgu.CVIInputArray
Optional information about hierarchy. It is only needed if you want to draw only some of the contours
maxLevel (Optional)
Type: SystemInt32
Maximal level for drawn contours. If 0, only contour is drawn. If 1, the contour and all contours after it on the same level are drawn. If 2, all contours after and all contours one level below the contours are drawn, etc. If the value is negative, the function does not draw the contours following after contour but draws child contours of contour up to abs(maxLevel)-1 level.
offset (Optional)
Type: System.DrawingPoint
Shift all the point coordinates by the specified value. It is useful in case if the contours retrieved in some image ROI and then the ROI offset needs to be taken into account during the rendering.
See Also

Reference

ImageTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Image(TColor, TDepth).DrawPolyline Method

ImageTColor, TDepthDrawPolyline Method

Overload List
 | Name | Description
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).DrawPolyline Method (Point[], Boolean, TColor, Int32, LineType, Int32)

ImageTColor, TDepthDrawPolyline Method (Point, Boolean, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw the polyline defined by the array of 2D points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DrawPolyline(
    Point[] pts,
    bool isClosed,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Sub DrawPolyline (
    pts As Point(),
    isClosed As Boolean,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
void DrawPolyline(
    array<Point^>^ pts,
    bool isClosed,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
member DrawPolyline :
        pts : Point[] *
        isClosed : bool *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

pts
Type: System.DrawingPoint
A polyline defined by its point
isClosed
Type: SystemBoolean
if true, the last line segment is defined by the last point of the array and the first point of the array
color
Type: TColor
the color used for drawing
thickness (Optional)
Type: SystemInt32
the thinkness of the line
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
DrawPolyline Overload
Emgu.CV Namespace


Image(TColor, TDepth).DrawPolyline Method (Point[][], Boolean, TColor, Int32, LineType, Int32)

ImageTColor, TDepthDrawPolyline Method (Point, Boolean, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw the polylines defined by the array of array of 2D points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DrawPolyline(
    Point[][] pts,
    bool isClosed,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Sub DrawPolyline (
    pts As Point()(),
    isClosed As Boolean,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
void DrawPolyline(
    array<array<Point^>^>^ pts,
    bool isClosed,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
)
member DrawPolyline :
        pts : Point[][] *
        isClosed : bool *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

pts
Type: System.DrawingPoint
An array of polylines each represented by an array of points
isClosed
Type: SystemBoolean
if true, the last line segment is defined by the last point of the array and the first point of the array
color
Type: TColor
the color used for drawing
thickness (Optional)
Type: SystemInt32
the thickness of the line
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
DrawPolyline Overload
Emgu.CV Namespace


Image(TColor, TDepth).Equals Method

ImageTColor, TDepthEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(ImageTColor, TDepth) | Compare two images, returns true if the each of the pixels are equal, false otherwise
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Equals Method (Image(TColor, TDepth))

ImageTColor, TDepthEquals Method (ImageTColor, TDepth)

http://www.emgu.com
Compare two images, returns true if the each of the pixels are equal, false otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Image<TColor, TDepth> img2
)
Public Function Equals (
    img2 As Image(Of TColor, TDepth)
) As Boolean
public:
virtual bool Equals(
    Image<TColor, TDepth>^ img2
) sealed
abstract Equals :
        img2 : Image<'TColor, 'TDepth> -> bool
override Equals :
        img2 : Image<'TColor, 'TDepth> -> bool

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The other image to compare with

Return Value

Type: Boolean
true if the each of the pixels for the two images are equal, false otherwise

Implements

IEquatableTEquals(T)
See Also

Reference

ImageTColor, TDepth Class
Equals Overload
Emgu.CV Namespace


Image(TColor, TDepth).Erode Method

ImageTColor, TDepthErode Method

Erodes this image using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Erode(
    int iterations
)
Public Function Erode (
    iterations As Integer
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Erode(
    int iterations
)
member Erode :
        iterations : int -> Image<'TColor, 'TDepth>

Parameters

iterations
Type: SystemInt32
The number of erode iterations

Return Value

Type: Image TColor, TDepth
The eroded image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Exp Method

ImageTColor, TDepthExp Method

Calculates exponent of every element of input array: dst(I)=exp(src(I))

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Exp()
Public Function Exp As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Exp()
member Exp : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
The exponent image
Remarks
Maximum relative error is ~7e-6. Currently, the function converts denormalized values to zeros on output.
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).FillConvexPoly Method

ImageTColor, TDepthFillConvexPoly Method

Fill the convex polygon with the specific color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FillConvexPoly(
    Point[] pts,
    TColor color,
    LineType lineType = 8,
    int shift = 0
)
Public Sub FillConvexPoly (
    pts As Point(),
    color As TColor,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
void FillConvexPoly(
    array<Point^>^ pts,
    TColor color,
    LineType^ lineType = 8,
    int shift = 0
)
member FillConvexPoly :
        pts : Point[] *
        color : 'TColor *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

pts
Type: System.DrawingPoint
The array of points that define the convex polygon
color
Type: TColor
The color to fill the polygon with
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).FindCornerSubPix Method

ImageTColor, TDepthFindCornerSubPix Method

Iterates to find the sub-pixel accurate location of corners, or radial saddle points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FindCornerSubPix(
    PointF[][] corners,
    Size win,
    Size zeroZone,
    MCvTermCriteria criteria
)
Public Sub FindCornerSubPix (
    corners As PointF()(),
    win As Size,
    zeroZone As Size,
    criteria As MCvTermCriteria
)
public:
void FindCornerSubPix(
    array<array<PointF^>^>^ corners,
    Size^ win,
    Size^ zeroZone,
    MCvTermCriteria^ criteria
)
member FindCornerSubPix :
        corners : PointF[][] *
        win : Size *
        zeroZone : Size *
        criteria : MCvTermCriteria -> unit

Parameters

corners
Type: System.DrawingPointF
Coordinates of the input corners, the values will be modified by this function call
win
Type: System.DrawingSize
Half sizes of the search window. For example, if win=(5,5) then 5*2+1 x 5*2+1 = 11 x 11 search window is used
zeroZone
Type: System.DrawingSize
Half size of the dead region in the middle of the search zone over which the summation in formulae below is not done. It is used sometimes to avoid possible singularities of the autocorrelation matrix. The value of (-1,-1) indicates that there is no such size
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Criteria for termination of the iterative process of corner refinement. That is, the process of corner position refinement stops either after certain number of iteration or when a required accuracy is achieved. The criteria may specify either of or both the maximum number of iteration and the required accuracy

Return Value

Type:
Refined corner coordinates
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Flip Method

ImageTColor, TDepthFlip Method

Return a flipped copy of the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Flip(
    FlipType flipType
)
Public Function Flip (
    flipType As FlipType
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Flip(
    FlipType^ flipType
)
member Flip :
        flipType : FlipType -> Image<'TColor, 'TDepth>

Parameters

flipType
Type: Emgu.CV.CvEnumFlipType
The type of the flipping

Return Value

Type: Image TColor, TDepth
The flipped copy of this image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).FromIplImagePtr Method

ImageTColor, TDepthFromIplImagePtr Method

Get the managed image from an unmanaged IplImagePointer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> FromIplImagePtr(
    IntPtr iplImage
)
Public Shared Function FromIplImagePtr (
    iplImage As IntPtr
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ FromIplImagePtr(
    IntPtr iplImage
)
static member FromIplImagePtr :
        iplImage : IntPtr -> Image<'TColor, 'TDepth>

Parameters

iplImage
Type: SystemIntPtr
The pointer to the iplImage

Return Value

Type: Image TColor, TDepth
The managed image from the iplImage pointer
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).GetAverage Method

ImageTColor, TDepthGetAverage Method

Overload List
 | Name | Description
Public method | GetAverage | Get the average value on this image
Public method | GetAverage(ImageGray, Byte) | Get the average value on this image, using the specific mask
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).GetAverage Method

ImageTColor, TDepthGetAverage Method

Get the average value on this image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TColor GetAverage()
Public Function GetAverage As TColor
public:
TColor GetAverage()
member GetAverage : unit -> 'TColor

Return Value

Type: TColor
The average color of the image
See Also

Reference

ImageTColor, TDepth Class
GetAverage Overload
Emgu.CV Namespace


Image(TColor, TDepth).GetAverage Method (Image(Gray, Byte))

ImageTColor, TDepthGetAverage Method (ImageGray, Byte)

http://www.emgu.com
Get the average value on this image, using the specific mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TColor GetAverage(
    Image<Gray, byte> mask
)
Public Function GetAverage (
    mask As Image(Of Gray, Byte)
) As TColor
public:
TColor GetAverage(
    Image<Gray^, unsigned char>^ mask
)
member GetAverage :
        mask : Image<Gray, byte> -> 'TColor

Parameters

mask
Type: Emgu.CVImage Gray, Byte
The mask for find the average value

Return Value

Type: TColor
The average color of the masked area
See Also

Reference

ImageTColor, TDepth Class
GetAverage Overload
Emgu.CV Namespace


Image(TColor, TDepth).GetMoments Method

ImageTColor, TDepthGetMoments Method

Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characteristics including 7 Hu invariants.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Moments GetMoments(
    bool binary
)
Public Function GetMoments (
    binary As Boolean
) As Moments
public:
Moments^ GetMoments(
    bool binary
)
member GetMoments :
        binary : bool -> Moments

Parameters

binary
Type: SystemBoolean
If the flag is true, all the zero pixel values are treated as zeroes, all the others are treated as 1's

Return Value

Type: Moments
spatial and central moments up to the third order
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).GetObjectData Method

ImageTColor, TDepthGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).GetSubRect Method

ImageTColor, TDepthGetSubRect Method

Get a subimage which image data is shared with the current image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> GetSubRect(
    Rectangle rect
)
Public Function GetSubRect (
    rect As Rectangle
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ GetSubRect(
    Rectangle^ rect
)
member GetSubRect :
        rect : Rectangle -> Image<'TColor, 'TDepth>

Parameters

rect
Type: System.DrawingRectangle
The rectangle area of the sub-image

Return Value

Type: Image TColor, TDepth
A subimage which image data is shared with the current image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).GetSum Method

ImageTColor, TDepthGetSum Method

Get the sum for each color channel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TColor GetSum()
Public Function GetSum As TColor
public:
TColor GetSum()
member GetSum : unit -> 'TColor

Return Value

Type: TColor
The sum for each color channel
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).GrabCut Method

ImageTColor, TDepthGrabCut Method

Use grabcut to perform background foreground segmentation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, byte> GrabCut(
    Rectangle rect,
    int iteration
)
Public Function GrabCut (
    rect As Rectangle,
    iteration As Integer
) As Image(Of Gray, Byte)
public:
Image<Gray^, unsigned char>^ GrabCut(
    Rectangle^ rect,
    int iteration
)
member GrabCut :
        rect : Rectangle *
        iteration : int -> Image<Gray, byte>

Parameters

rect
Type: System.DrawingRectangle
The initial rectangle region for the foreground
iteration
Type: SystemInt32
The number of iterations to run GrabCut

Return Value

Type: Image Gray, Byte
The background foreground mask where 2 indicates background and 3 indicates foreground
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).HoughCircles Method

ImageTColor, TDepthHoughCircles Method

First apply Canny Edge Detector on the current image, then apply Hough transform to find circles

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CircleF[][] HoughCircles(
    TColor cannyThreshold,
    TColor accumulatorThreshold,
    double dp,
    double minDist,
    int minRadius = 0,
    int maxRadius = 0
)
Public Function HoughCircles (
    cannyThreshold As TColor,
    accumulatorThreshold As TColor,
    dp As Double,
    minDist As Double,
    Optional minRadius As Integer = 0,
    Optional maxRadius As Integer = 0
) As CircleF()()
public:
array<array<CircleF^>^>^ HoughCircles(
    TColor cannyThreshold,
    TColor accumulatorThreshold,
    double dp,
    double minDist,
    int minRadius = 0,
    int maxRadius = 0
)
member HoughCircles :
        cannyThreshold : 'TColor *
        accumulatorThreshold : 'TColor *
        dp : float *
        minDist : float *
        ?minRadius : int *
        ?maxRadius : int
(* Defaults:
        let _minRadius = defaultArg minRadius 0
        let _maxRadius = defaultArg maxRadius 0
*)
-> CircleF[][]

Parameters

cannyThreshold
Type: TColor
The higher threshold of the two passed to Canny edge detector (the lower one will be twice smaller).
accumulatorThreshold
Type: TColor
Accumulator threshold at the center detection stage. The smaller it is, the more false circles may be detected. Circles, corresponding to the larger accumulator values, will be returned first
dp
Type: SystemDouble
Resolution of the accumulator used to detect centers of the circles. For example, if it is 1, the accumulator will have the same resolution as the input image, if it is 2 - accumulator will have twice smaller width and height, etc
minDist
Type: SystemDouble
Minimum distance between centers of the detected circles. If the parameter is too small, multiple neighbor circles may be falsely detected in addition to a true one. If it is too large, some circles may be missed
minRadius (Optional)
Type: SystemInt32
Minimal radius of the circles to search for
maxRadius (Optional)
Type: SystemInt32
Maximal radius of the circles to search for

Return Value

Type: CircleF
The circle detected for each of the channels
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).HoughLines Method

ImageTColor, TDepthHoughLines Method

Apply Canny Edge Detector follows by Probabilistic Hough transform to find line segments in the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment2D[][] HoughLines(
    double cannyThreshold,
    double cannyThresholdLinking,
    double rhoResolution,
    double thetaResolution,
    int threshold,
    double minLineWidth,
    double gapBetweenLines
)
Public Function HoughLines (
    cannyThreshold As Double,
    cannyThresholdLinking As Double,
    rhoResolution As Double,
    thetaResolution As Double,
    threshold As Integer,
    minLineWidth As Double,
    gapBetweenLines As Double
) As LineSegment2D()()
public:
array<array<LineSegment2D^>^>^ HoughLines(
    double cannyThreshold,
    double cannyThresholdLinking,
    double rhoResolution,
    double thetaResolution,
    int threshold,
    double minLineWidth,
    double gapBetweenLines
)
member HoughLines :
        cannyThreshold : float *
        cannyThresholdLinking : float *
        rhoResolution : float *
        thetaResolution : float *
        threshold : int *
        minLineWidth : float *
        gapBetweenLines : float -> LineSegment2D[][]

Parameters

cannyThreshold
Type: SystemDouble
The threshold to find initial segments of strong edges
cannyThresholdLinking
Type: SystemDouble
The threshold used for edge Linking
rhoResolution
Type: SystemDouble
Distance resolution in pixel-related units.
thetaResolution
Type: SystemDouble
Angle resolution measured in radians
threshold
Type: SystemInt32
A line is returned by the function if the corresponding accumulator value is greater than threshold
minLineWidth
Type: SystemDouble
Minimum width of a line
gapBetweenLines
Type: SystemDouble
Minimum gap between lines

Return Value

Type: LineSegment2D
The line segments detected for each of the channels
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).HoughLinesBinary Method

ImageTColor, TDepthHoughLinesBinary Method

Apply Probabilistic Hough transform to find line segments. The current image must be a binary image (eg. the edges as a result of the Canny edge detector)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment2D[][] HoughLinesBinary(
    double rhoResolution,
    double thetaResolution,
    int threshold,
    double minLineWidth,
    double gapBetweenLines
)
Public Function HoughLinesBinary (
    rhoResolution As Double,
    thetaResolution As Double,
    threshold As Integer,
    minLineWidth As Double,
    gapBetweenLines As Double
) As LineSegment2D()()
public:
array<array<LineSegment2D^>^>^ HoughLinesBinary(
    double rhoResolution,
    double thetaResolution,
    int threshold,
    double minLineWidth,
    double gapBetweenLines
)
member HoughLinesBinary :
        rhoResolution : float *
        thetaResolution : float *
        threshold : int *
        minLineWidth : float *
        gapBetweenLines : float -> LineSegment2D[][]

Parameters

rhoResolution
Type: SystemDouble
Distance resolution in pixel-related units.
thetaResolution
Type: SystemDouble
Angle resolution measured in radians
threshold
Type: SystemInt32
A line is returned by the function if the corresponding accumulator value is greater than threshold
minLineWidth
Type: SystemDouble
Minimum width of a line
gapBetweenLines
Type: SystemDouble
Minimum gap between lines

Return Value

Type: LineSegment2D
The line segments detected for each of the channels
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).InPaint Method

ImageTColor, TDepthInPaint Method

Use inpaint to recover the intensity of the pixels which location defined by mask on this image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> InPaint(
    Image<Gray, byte> mask,
    double radius
)
Public Function InPaint (
    mask As Image(Of Gray, Byte),
    radius As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ InPaint(
    Image<Gray^, unsigned char>^ mask,
    double radius
)
member InPaint :
        mask : Image<Gray, byte> *
        radius : float -> Image<'TColor, 'TDepth>

Parameters

mask
Type: Emgu.CVImage Gray, Byte
The inpainting mask. Non-zero pixels indicate the area that needs to be inpainted
radius
Type: SystemDouble
The radius of circular neighborhood of each point inpainted that is considered by the algorithm

Return Value

Type: Image TColor, TDepth
The inpainted image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).InRange Method

ImageTColor, TDepthInRange Method

Overload List
 | Name | Description
Public method | InRange(TColor, TColor) | Checks that image elements lie between two scalars
Public method | InRange(ImageTColor, TDepth, ImageTColor, TDepth) | Checks that image elements lie between values defined by two images of same size and type
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).InRange Method (TColor, TColor)

ImageTColor, TDepthInRange Method (TColor, TColor)

http://www.emgu.com
Checks that image elements lie between two scalars

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, byte> InRange(
    TColor lower,
    TColor higher
)
Public Function InRange (
    lower As TColor,
    higher As TColor
) As Image(Of Gray, Byte)
public:
Image<Gray^, unsigned char>^ InRange(
    TColor lower,
    TColor higher
)
member InRange :
        lower : 'TColor *
        higher : 'TColor -> Image<Gray, byte>

Parameters

lower
Type: TColor
The inclusive lower limit of color value
higher
Type: TColor
The inclusive upper limit of color value

Return Value

Type: Image Gray, Byte
res[i,j] = 255 if lower <= this[i,j] <= higher, 0 otherwise
See Also

Reference

ImageTColor, TDepth Class
InRange Overload
Emgu.CV Namespace


Image(TColor, TDepth).InRange Method (Image(TColor, TDepth), Image(TColor, TDepth))

ImageTColor, TDepthInRange Method (ImageTColor, TDepth, ImageTColor, TDepth)

http://www.emgu.com
Checks that image elements lie between values defined by two images of same size and type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, byte> InRange(
    Image<TColor, TDepth> lower,
    Image<TColor, TDepth> higher
)
Public Function InRange (
    lower As Image(Of TColor, TDepth),
    higher As Image(Of TColor, TDepth)
) As Image(Of Gray, Byte)
public:
Image<Gray^, unsigned char>^ InRange(
    Image<TColor, TDepth>^ lower,
    Image<TColor, TDepth>^ higher
)
member InRange :
        lower : Image<'TColor, 'TDepth> *
        higher : Image<'TColor, 'TDepth> -> Image<Gray, byte>

Parameters

lower
Type: Emgu.CVImage TColor, TDepth
The inclusive lower limit of color value
higher
Type: Emgu.CVImage TColor, TDepth
The inclusive upper limit of color value

Return Value

Type: Image Gray, Byte
res[i,j] = 255 if lower[i,j] <= this[i,j] <= higher[i,j], 0 otherwise
See Also

Reference

ImageTColor, TDepth Class
InRange Overload
Emgu.CV Namespace


Image(TColor, TDepth).Integral Method

ImageTColor, TDepthIntegral Method

Overload List
 | Name | Description
Public method | Integral | Calculates integral images for the source image
Public method | Integral(ImageTColor, Double, ImageTColor, Double) | Calculates integral images for the source image
Public method | Integral(ImageTColor, Double, ImageTColor, Double, ImageTColor, Double) | Calculates one or more integral images for the source image
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Integral Method

ImageTColor, TDepthIntegral Method

Calculates integral images for the source image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, double> Integral()
Public Function Integral As Image(Of TColor, Double)
public:
Image<TColor, double>^ Integral()
member Integral : unit -> Image<'TColor, float>

Return Value

Type: Image TColor, Double
The integral image
See Also

Reference

ImageTColor, TDepth Class
Integral Overload
Emgu.CV Namespace


Image(TColor, TDepth).Integral Method (Image(TColor, Double), Image(TColor, Double))

ImageTColor, TDepthIntegral Method (ImageTColor, Double, ImageTColor, Double)

http://www.emgu.com
Calculates integral images for the source image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Integral(
    out Image<TColor, double> sum,
    out Image<TColor, double> squareSum
)
Public Sub Integral (
    <OutAttribute> ByRef sum As Image(Of TColor, Double),
    <OutAttribute> ByRef squareSum As Image(Of TColor, Double)
)
public:
void Integral(
    [OutAttribute] Image<TColor, double>^% sum,
    [OutAttribute] Image<TColor, double>^% squareSum
)
member Integral :
        sum : Image<'TColor, float> byref *
        squareSum : Image<'TColor, float> byref -> unit

Parameters

sum
Type: Emgu.CVImage TColor, Double
The integral image
squareSum
Type: Emgu.CVImage TColor, Double
The integral image for squared pixel values

Return Value

Type:
The integral image
See Also

Reference

ImageTColor, TDepth Class
Integral Overload
Emgu.CV Namespace


Image(TColor, TDepth).Integral Method (Image(TColor, Double), Image(TColor, Double), Image(TColor, Double))

ImageTColor, TDepthIntegral Method (ImageTColor, Double, ImageTColor, Double, ImageTColor, Double)

http://www.emgu.com
Calculates one or more integral images for the source image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Integral(
    out Image<TColor, double> sum,
    out Image<TColor, double> squareSum,
    out Image<TColor, double> titledSum
)
Public Sub Integral (
    <OutAttribute> ByRef sum As Image(Of TColor, Double),
    <OutAttribute> ByRef squareSum As Image(Of TColor, Double),
    <OutAttribute> ByRef titledSum As Image(Of TColor, Double)
)
public:
void Integral(
    [OutAttribute] Image<TColor, double>^% sum,
    [OutAttribute] Image<TColor, double>^% squareSum,
    [OutAttribute] Image<TColor, double>^% titledSum
)
member Integral :
        sum : Image<'TColor, float> byref *
        squareSum : Image<'TColor, float> byref *
        titledSum : Image<'TColor, float> byref -> unit

Parameters

sum
Type: Emgu.CVImage TColor, Double
The integral image
squareSum
Type: Emgu.CVImage TColor, Double
The integral image for squared pixel values
titledSum
Type: Emgu.CVImage TColor, Double
The integral for the image rotated by 45 degrees
See Also

Reference

ImageTColor, TDepth Class
Integral Overload
Emgu.CV Namespace


Image(TColor, TDepth).Laplace Method

ImageTColor, TDepthLaplace Method

Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator. Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0|

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, float> Laplace(
    int apertureSize
)
Public Function Laplace (
    apertureSize As Integer
) As Image(Of TColor, Single)
public:
Image<TColor, float>^ Laplace(
    int apertureSize
)
member Laplace :
        apertureSize : int -> Image<'TColor, float32>

Parameters

apertureSize
Type: SystemInt32
Aperture size

Return Value

Type: Image TColor, Single
The Laplacian of the image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Log Method

ImageTColor, TDepthLog Method

Calculates natural logarithm of absolute value of every element of input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Log()
Public Function Log As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Log()
member Log : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
Natural logarithm of absolute value of every element of input array
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).LogPolar Method

ImageTColor, TDepthLogPolar Method

Convert the image to log polar, simulating the human foveal vision

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> LogPolar(
    PointF center,
    double magnitude,
    Inter interpolationType = 1,
    Warp warpType = 8
)
Public Function LogPolar (
    center As PointF,
    magnitude As Double,
    Optional interpolationType As Inter = 1,
    Optional warpType As Warp = 8
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ LogPolar(
    PointF^ center,
    double magnitude,
    Inter^ interpolationType = 1,
    Warp^ warpType = 8
)
member LogPolar :
        center : PointF *
        magnitude : float *
        ?interpolationType : Inter *
        ?warpType : Warp
(* Defaults:
        let _interpolationType = defaultArg interpolationType 1
        let _warpType = defaultArg warpType 8
*)
-> Image<'TColor, 'TDepth>

Parameters

center
Type: System.DrawingPointF
The transformation center, where the output precision is maximal
magnitude
Type: SystemDouble
Magnitude scale parameter
interpolationType (Optional)
Type: Emgu.CV.CvEnumInter
interpolation type
warpType (Optional)
Type: Emgu.CV.CvEnumWarp
Warp type

Return Value

Type: Image TColor, TDepth
The converted image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).MapDataToImage Method

ImageTColor, TDepthMapDataToImage Method

Let this Image object use the specific Image data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected void MapDataToImage(
    int width,
    int height,
    int stride,
    IntPtr scan0
)
Protected Sub MapDataToImage (
    width As Integer,
    height As Integer,
    stride As Integer,
    scan0 As IntPtr
)
protected:
void MapDataToImage(
    int width,
    int height,
    int stride,
    IntPtr scan0
)
member MapDataToImage :
        width : int *
        height : int *
        stride : int *
        scan0 : IntPtr -> unit

Parameters

width
Type: SystemInt32
The width of the image
height
Type: SystemInt32
The height of the image
stride
Type: SystemInt32
The data stride (bytes per row)
scan0
Type: SystemIntPtr
The origin of the data
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).MatchTemplate Method

ImageTColor, TDepthMatchTemplate Method

The function slides through image, compares overlapped patches of size wxh with templ using the specified method and return the comparison results

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, float> MatchTemplate(
    Image<TColor, TDepth> template,
    TemplateMatchingType method
)
Public Function MatchTemplate (
    template As Image(Of TColor, TDepth),
    method As TemplateMatchingType
) As Image(Of Gray, Single)
public:
Image<Gray^, float>^ MatchTemplate(
    Image<TColor, TDepth>^ template,
    TemplateMatchingType^ method
)
member MatchTemplate :
        template : Image<'TColor, 'TDepth> *
        method : TemplateMatchingType -> Image<Gray, float32>

Parameters

template
Type: Emgu.CVImage TColor, TDepth
Searched template; must be not greater than the source image and the same data type as the image
method
Type: Emgu.CV.CvEnumTemplateMatchingType
Specifies the way the template must be compared with image regions

Return Value

Type: Image Gray, Single
The comparison result: width = this.Width - template.Width + 1; height = this.Height - template.Height + 1
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Max Method

ImageTColor, TDepthMax Method

Overload List
 | Name | Description
Public method | Max(Double) | Find the elementwise maximum value
Public method | Max(ImageTColor, TDepth) | Find the elementwise maximum value
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Max Method (Double)

ImageTColor, TDepthMax Method (Double)

http://www.emgu.com
Find the elementwise maximum value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Max(
    double value
)
Public Function Max (
    value As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Max(
    double value
)
member Max :
        value : float -> Image<'TColor, 'TDepth>

Parameters

value
Type: SystemDouble
The value to compare with

Return Value

Type: Image TColor, TDepth
An image where each pixel is the maximum of this image and value
See Also

Reference

ImageTColor, TDepth Class
Max Overload
Emgu.CV Namespace


Image(TColor, TDepth).Max Method (Image(TColor, TDepth))

ImageTColor, TDepthMax Method (ImageTColor, TDepth)

http://www.emgu.com
Find the elementwise maximum value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Max(
    Image<TColor, TDepth> img2
)
Public Function Max (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Max(
    Image<TColor, TDepth>^ img2
)
member Max :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the Max operation

Return Value

Type: Image TColor, TDepth
An image where each pixel is the maximum of this image and the parameter image
See Also

Reference

ImageTColor, TDepth Class
Max Overload
Emgu.CV Namespace


Image(TColor, TDepth).Min Method

ImageTColor, TDepthMin Method

Overload List
 | Name | Description
Public method | Min(Double) | Find the elementwise minimum value
Public method | Min(ImageTColor, TDepth) | Find the elementwise minimum value
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Min Method (Double)

ImageTColor, TDepthMin Method (Double)

http://www.emgu.com
Find the elementwise minimum value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Min(
    double value
)
Public Function Min (
    value As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Min(
    double value
)
member Min :
        value : float -> Image<'TColor, 'TDepth>

Parameters

value
Type: SystemDouble
The value to compare with

Return Value

Type: Image TColor, TDepth
An image where each pixel is the minimum of this image and value
See Also

Reference

ImageTColor, TDepth Class
Min Overload
Emgu.CV Namespace


Image(TColor, TDepth).Min Method (Image(TColor, TDepth))

ImageTColor, TDepthMin Method (ImageTColor, TDepth)

http://www.emgu.com
Find the elementwise minimum value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Min(
    Image<TColor, TDepth> img2
)
Public Function Min (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Min(
    Image<TColor, TDepth>^ img2
)
member Min :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the Min operation

Return Value

Type: Image TColor, TDepth
An image where each pixel is the minimum of this image and the parameter image
See Also

Reference

ImageTColor, TDepth Class
Min Overload
Emgu.CV Namespace


Image(TColor, TDepth).MinMax Method

ImageTColor, TDepthMinMax Method

Returns the min / max location and values for the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MinMax(
    out double[] minValues,
    out double[] maxValues,
    out Point[] minLocations,
    out Point[] maxLocations
)
Public Sub MinMax (
    <OutAttribute> ByRef minValues As Double(),
    <OutAttribute> ByRef maxValues As Double(),
    <OutAttribute> ByRef minLocations As Point(),
    <OutAttribute> ByRef maxLocations As Point()
)
public:
void MinMax(
    [OutAttribute] array<double>^% minValues,
    [OutAttribute] array<double>^% maxValues,
    [OutAttribute] array<Point^>^% minLocations,
    [OutAttribute] array<Point^>^% maxLocations
)
member MinMax :
        minValues : float[] byref *
        maxValues : float[] byref *
        minLocations : Point[] byref *
        maxLocations : Point[] byref -> unit

Parameters

minValues
Type: SystemDouble
The minimum values for each channel
maxValues
Type: SystemDouble
The maximum values for each channel
minLocations
Type: System.DrawingPoint
The minimum locations for each channel
maxLocations
Type: System.DrawingPoint
The maximum locations for each channel
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).MorphologyEx Method

ImageTColor, TDepthMorphologyEx Method

Perform advanced morphological transformations using erosion and dilation as basic operations.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> MorphologyEx(
    MorphOp operation,
    IInputArray kernel,
    Point anchor,
    int iterations,
    BorderType borderType,
    MCvScalar borderValue
)
Public Function MorphologyEx (
    operation As MorphOp,
    kernel As IInputArray,
    anchor As Point,
    iterations As Integer,
    borderType As BorderType,
    borderValue As MCvScalar
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ MorphologyEx(
    MorphOp^ operation,
    IInputArray^ kernel,
    Point^ anchor,
    int iterations,
    BorderType^ borderType,
    MCvScalar^ borderValue
)
member MorphologyEx :
        operation : MorphOp *
        kernel : IInputArray *
        anchor : Point *
        iterations : int *
        borderType : BorderType *
        borderValue : MCvScalar -> Image<'TColor, 'TDepth>

Parameters

operation
Type: Emgu.CV.CvEnumMorphOp
Type of morphological operation
kernel
Type: Emgu.CVIInputArray
Structuring element
anchor
Type: System.DrawingPoint
Anchor position with the kernel. Negative values mean that the anchor is at the kernel center.
iterations
Type: SystemInt32
Number of times erosion and dilation are applied
borderType
Type: Emgu.CV.CvEnumBorderType
Border type
borderValue
Type: Emgu.CV.StructureMCvScalar
Border value

Return Value

Type: Image TColor, TDepth
The result of the morphological operation
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Mul Method

ImageTColor, TDepthMul Method

Overload List
 | Name | Description
Public method | Mul(Double) | Elementwise multiply the current image with scale
Public method | Mul(ImageTColor, TDepth) | Elementwise multiply img2 with the current image
Public method | Mul(ImageTColor, TDepth, Double) | Elementwise multiply another image with the current image and the scale
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Mul Method (Double)

ImageTColor, TDepthMul Method (Double)

http://www.emgu.com
Elementwise multiply the current image with scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Mul(
    double scale
)
Public Function Mul (
    scale As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Mul(
    double scale
)
member Mul :
        scale : float -> Image<'TColor, 'TDepth>

Parameters

scale
Type: SystemDouble
The scale to be multiplied

Return Value

Type: Image TColor, TDepth
The scaled image
See Also

Reference

ImageTColor, TDepth Class
Mul Overload
Emgu.CV Namespace


Image(TColor, TDepth).Mul Method (Image(TColor, TDepth))

ImageTColor, TDepthMul Method (ImageTColor, TDepth)

http://www.emgu.com
Elementwise multiply img2 with the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Mul(
    Image<TColor, TDepth> img2
)
Public Function Mul (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Mul(
    Image<TColor, TDepth>^ img2
)
member Mul :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The image to be elementwise multiplied to the current image

Return Value

Type: Image TColor, TDepth
this .* img2
See Also

Reference

ImageTColor, TDepth Class
Mul Overload
Emgu.CV Namespace


Image(TColor, TDepth).Mul Method (Image(TColor, TDepth), Double)

ImageTColor, TDepthMul Method (ImageTColor, TDepth, Double)

http://www.emgu.com
Elementwise multiply another image with the current image and the scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Mul(
    Image<TColor, TDepth> img2,
    double scale
)
Public Function Mul (
    img2 As Image(Of TColor, TDepth),
    scale As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Mul(
    Image<TColor, TDepth>^ img2,
    double scale
)
member Mul :
        img2 : Image<'TColor, 'TDepth> *
        scale : float -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The image to be elementwise multiplied to the current image
scale
Type: SystemDouble
The scale to be multiplied

Return Value

Type: Image TColor, TDepth
this .* img2 * scale
See Also

Reference

ImageTColor, TDepth Class
Mul Overload
Emgu.CV Namespace


Image(TColor, TDepth).Not Method

ImageTColor, TDepthNot Method

Compute the complement image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Not()
Public Function Not As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Not()
member Not : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
The complement image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Or Method

ImageTColor, TDepthOr Method

Overload List
 | Name | Description
Public method | Or(TColor) | Perform an elementwise OR operation with some color
Public method | Or(ImageTColor, TDepth) | Perform an elementwise OR operation with another image and return the result
Public method | Or(TColor, ImageGray, Byte) | Perform an elementwise OR operation with some color using a mask
Public method | Or(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise OR operation with another image, using a mask, and return the result
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Or Method (TColor)

ImageTColor, TDepthOr Method (TColor)

http://www.emgu.com
Perform an elementwise OR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Or(
    TColor val
)
Public Function Or (
    val As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Or(
    TColor val
)
member Or :
        val : 'TColor -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The value for the OR operation

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
Or Overload
Emgu.CV Namespace


Image(TColor, TDepth).Or Method (Image(TColor, TDepth))

ImageTColor, TDepthOr Method (ImageTColor, TDepth)

http://www.emgu.com
Perform an elementwise OR operation with another image and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Or(
    Image<TColor, TDepth> img2
)
Public Function Or (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Or(
    Image<TColor, TDepth>^ img2
)
member Or :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the OR operation

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
Or Overload
Emgu.CV Namespace


Image(TColor, TDepth).Or Method (TColor, Image(Gray, Byte))

ImageTColor, TDepthOr Method (TColor, ImageGray, Byte)

http://www.emgu.com
Perform an elementwise OR operation with some color using a mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Or(
    TColor val,
    Image<Gray, byte> mask
)
Public Function Or (
    val As TColor,
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Or(
    TColor val,
    Image<Gray^, unsigned char>^ mask
)
member Or :
        val : 'TColor *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color for the OR operation
mask
Type: Emgu.CVImage Gray, Byte
The mask for the OR operation

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
Or Overload
Emgu.CV Namespace


Image(TColor, TDepth).Or Method (Image(TColor, TDepth), Image(Gray, Byte))

ImageTColor, TDepthOr Method (ImageTColor, TDepth, ImageGray, Byte)

http://www.emgu.com
Perform an elementwise OR operation with another image, using a mask, and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Or(
    Image<TColor, TDepth> img2,
    Image<Gray, byte> mask
)
Public Function Or (
    img2 As Image(Of TColor, TDepth),
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Or(
    Image<TColor, TDepth>^ img2,
    Image<Gray^, unsigned char>^ mask
)
member Or :
        img2 : Image<'TColor, 'TDepth> *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the OR operation
mask
Type: Emgu.CVImage Gray, Byte
The mask for the OR operation

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
Or Overload
Emgu.CV Namespace


Image(TColor, TDepth).Pow Method

ImageTColor, TDepthPow Method

Raises every element of input array to p dst(I)=src(I)^p, if p is integer dst(I)=abs(src(I))^p, otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Pow(
    double power
)
Public Function Pow (
    power As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Pow(
    double power
)
member Pow :
        power : float -> Image<'TColor, 'TDepth>

Parameters

power
Type: SystemDouble
The exponent of power

Return Value

Type: Image TColor, TDepth
The power image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).PyrDown Method

ImageTColor, TDepthPyrDown Method

Performs downsampling step of Gaussian pyramid decomposition. First it convolves this image with the specified filter and then downsamples the image by rejecting even rows and columns.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> PyrDown()
Public Function PyrDown As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ PyrDown()
member PyrDown : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
The downsampled image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).PyrUp Method

ImageTColor, TDepthPyrUp Method

Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples this image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the resulting image is four times larger than the source image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> PyrUp()
Public Function PyrUp As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ PyrUp()
member PyrUp : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
The upsampled image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Resize Method

ImageTColor, TDepthResize Method

Overload List
 | Name | Description
Public method | Resize(Double, Inter) | Scale the image to the specific size: width *= scale; height *= scale
Public method | Resize(Int32, Int32, Inter) | Scale the image to the specific size
Public method | Resize(Int32, Int32, Inter, Boolean) | Scale the image to the specific size
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Resize Method (Double, Inter)

ImageTColor, TDepthResize Method (Double, Inter)

http://www.emgu.com
Scale the image to the specific size: width *= scale; height *= scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Resize(
    double scale,
    Inter interpolationType
)
Public Function Resize (
    scale As Double,
    interpolationType As Inter
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Resize(
    double scale,
    Inter^ interpolationType
)
member Resize :
        scale : float *
        interpolationType : Inter -> Image<'TColor, 'TDepth>

Parameters

scale
Type: SystemDouble
The scale to resize
interpolationType
Type: Emgu.CV.CvEnumInter
The type of interpolation

Return Value

Type: Image TColor, TDepth
The scaled image
See Also

Reference

ImageTColor, TDepth Class
Resize Overload
Emgu.CV Namespace


Image(TColor, TDepth).Resize Method (Int32, Int32, Inter)

ImageTColor, TDepthResize Method (Int32, Int32, Inter)

http://www.emgu.com
Scale the image to the specific size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Resize(
    int width,
    int height,
    Inter interpolationType
)
Public Function Resize (
    width As Integer,
    height As Integer,
    interpolationType As Inter
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Resize(
    int width,
    int height,
    Inter^ interpolationType
)
member Resize :
        width : int *
        height : int *
        interpolationType : Inter -> Image<'TColor, 'TDepth>

Parameters

width
Type: SystemInt32
The width of the returned image.
height
Type: SystemInt32
The height of the returned image.
interpolationType
Type: Emgu.CV.CvEnumInter
The type of interpolation

Return Value

Type: Image TColor, TDepth
The resized image
See Also

Reference

ImageTColor, TDepth Class
Resize Overload
Emgu.CV Namespace


Image(TColor, TDepth).Resize Method (Int32, Int32, Inter, Boolean)

ImageTColor, TDepthResize Method (Int32, Int32, Inter, Boolean)

http://www.emgu.com
Scale the image to the specific size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Resize(
    int width,
    int height,
    Inter interpolationType,
    bool preserveScale
)
Public Function Resize (
    width As Integer,
    height As Integer,
    interpolationType As Inter,
    preserveScale As Boolean
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Resize(
    int width,
    int height,
    Inter^ interpolationType,
    bool preserveScale
)
member Resize :
        width : int *
        height : int *
        interpolationType : Inter *
        preserveScale : bool -> Image<'TColor, 'TDepth>

Parameters

width
Type: SystemInt32
The width of the returned image.
height
Type: SystemInt32
The height of the returned image.
interpolationType
Type: Emgu.CV.CvEnumInter
The type of interpolation
preserveScale
Type: SystemBoolean
if true, the scale is preservered and the resulting image has maximum width(height) possible that is <= width (height), if false, this function is equaivalent to Resize(int width, int height)

Return Value

Type: Image TColor, TDepth
The resized image
See Also

Reference

ImageTColor, TDepth Class
Resize Overload
Emgu.CV Namespace


Image(TColor, TDepth).RoiParam Method

ImageTColor, TDepthRoiParam Method

Return parameters based on ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected static void RoiParam(
    IntPtr ptr,
    out long start,
    out int rows,
    out int elementCount,
    out int byteWidth,
    out int widthStep
)
Protected Shared Sub RoiParam (
    ptr As IntPtr,
    <OutAttribute> ByRef start As Long,
    <OutAttribute> ByRef rows As Integer,
    <OutAttribute> ByRef elementCount As Integer,
    <OutAttribute> ByRef byteWidth As Integer,
    <OutAttribute> ByRef widthStep As Integer
)
protected:
static void RoiParam(
    IntPtr ptr,
    [OutAttribute] long long% start,
    [OutAttribute] int% rows,
    [OutAttribute] int% elementCount,
    [OutAttribute] int% byteWidth,
    [OutAttribute] int% widthStep
)
static member RoiParam :
        ptr : IntPtr *
        start : int64 byref *
        rows : int byref *
        elementCount : int byref *
        byteWidth : int byref *
        widthStep : int byref -> unit

Parameters

ptr
Type: SystemIntPtr
The Pointer to the IplImage
start
Type: SystemInt64
The address of the pointer that point to the start of the Bytes taken into consideration ROI
rows
Type: SystemInt32
The number of rows taken into consideration ROI
elementCount
Type: SystemInt32
ROI.Width * ColorType.Dimension
byteWidth
Type: SystemInt32
The number of bytes in a row taken into consideration ROI
widthStep
Type: SystemInt32
The width step required to jump to the next row
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Rotate Method

ImageTColor, TDepthRotate Method

Overload List
 | Name | Description
Public method | Rotate(Double, TColor) | Rotate the image the specified angle cropping the result to the original size
Public method | Rotate(Double, TColor, Boolean) | Rotate this image the specified angle
Public method | Rotate(Double, PointF, Inter, TColor, Boolean) | Rotate this image the specified angle
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Rotate Method (Double, TColor)

ImageTColor, TDepthRotate Method (Double, TColor)

http://www.emgu.com
Rotate the image the specified angle cropping the result to the original size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Rotate(
    double angle,
    TColor background
)
Public Function Rotate (
    angle As Double,
    background As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Rotate(
    double angle,
    TColor background
)
member Rotate :
        angle : float *
        background : 'TColor -> Image<'TColor, 'TDepth>

Parameters

angle
Type: SystemDouble
The angle of rotation in degrees.
background
Type: TColor
The color with which to fill the background

Return Value

Type: Image TColor, TDepth
The image rotates by the specific angle
See Also

Reference

ImageTColor, TDepth Class
Rotate Overload
Emgu.CV Namespace


Image(TColor, TDepth).Rotate Method (Double, TColor, Boolean)

ImageTColor, TDepthRotate Method (Double, TColor, Boolean)

http://www.emgu.com
Rotate this image the specified angle

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Rotate(
    double angle,
    TColor background,
    bool crop
)
Public Function Rotate (
    angle As Double,
    background As TColor,
    crop As Boolean
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Rotate(
    double angle,
    TColor background,
    bool crop
)
member Rotate :
        angle : float *
        background : 'TColor *
        crop : bool -> Image<'TColor, 'TDepth>

Parameters

angle
Type: SystemDouble
The angle of rotation in degrees.
background
Type: TColor
The color with which to fill the background
crop
Type: SystemBoolean
If set to true the image is cropped to its original size, possibly losing corners information. If set to false the result image has different size than original and all rotation information is preserved

Return Value

Type: Image TColor, TDepth
The rotated image
See Also

Reference

ImageTColor, TDepth Class
Rotate Overload
Emgu.CV Namespace


Image(TColor, TDepth).Rotate Method (Double, PointF, Inter, TColor, Boolean)

ImageTColor, TDepthRotate Method (Double, PointF, Inter, TColor, Boolean)

http://www.emgu.com
Rotate this image the specified angle

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Rotate(
    double angle,
    PointF center,
    Inter interpolationMethod,
    TColor background,
    bool crop
)
Public Function Rotate (
    angle As Double,
    center As PointF,
    interpolationMethod As Inter,
    background As TColor,
    crop As Boolean
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Rotate(
    double angle,
    PointF^ center,
    Inter^ interpolationMethod,
    TColor background,
    bool crop
)
member Rotate :
        angle : float *
        center : PointF *
        interpolationMethod : Inter *
        background : 'TColor *
        crop : bool -> Image<'TColor, 'TDepth>

Parameters

angle
Type: SystemDouble
The angle of rotation in degrees. Positive means clockwise.
center
Type: System.DrawingPointF
The center of rotation
interpolationMethod
Type: Emgu.CV.CvEnumInter
The interpolation method
background
Type: TColor
The color with with to fill the background
crop
Type: SystemBoolean
If set to true the image is cropped to its original size, possibly losing corners information. If set to false the result image has different size than original and all rotation information is preserved

Return Value

Type: Image TColor, TDepth
The rotated image
See Also

Reference

ImageTColor, TDepth Class
Rotate Overload
Emgu.CV Namespace


Image(TColor, TDepth).Save Method

ImageTColor, TDepthSave Method

Save this image to the specific file.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void Save(
    string fileName
)
Public Overrides Sub Save (
    fileName As String
)
public:
virtual void Save(
    String^ fileName
) override
abstract Save :
        fileName : string -> unit
override Save :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The name of the file to be saved to
Remarks
The image format is chosen depending on the filename extension, see cvLoadImage. Only 8-bit single-channel or 3-channel (with 'BGR' channel order) images can be saved using this function. If the format, depth or channel order is different, use cvCvtScale and cvCvtColor to convert it before saving, or use universal cvSave to save the image to XML or YAML format.
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).SetValue Method

ImageTColor, TDepthSetValue Method

Overload List
 | Name | Description
Public method | SetValue(TColor) | Set every pixel of the image to the specific color
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor, ImageGray, Byte) | Set every pixel of the image to the specific color, using a mask
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).SetValue Method (TColor)

ImageTColor, TDepthSetValue Method (TColor)

http://www.emgu.com
Set every pixel of the image to the specific color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    TColor color
)
Public Sub SetValue (
    color As TColor
)
public:
void SetValue(
    TColor color
)
member SetValue :
        color : 'TColor -> unit

Parameters

color
Type: TColor
The color to be set
See Also

Reference

ImageTColor, TDepth Class
SetValue Overload
Emgu.CV Namespace


Image(TColor, TDepth).SetValue Method (TColor, Image(Gray, Byte))

ImageTColor, TDepthSetValue Method (TColor, ImageGray, Byte)

http://www.emgu.com
Set every pixel of the image to the specific color, using a mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    TColor color,
    Image<Gray, byte> mask
)
Public Sub SetValue (
    color As TColor,
    mask As Image(Of Gray, Byte)
)
public:
void SetValue(
    TColor color,
    Image<Gray^, unsigned char>^ mask
)
member SetValue :
        color : 'TColor *
        mask : Image<Gray, byte> -> unit

Parameters

color
Type: TColor
The color to be set
mask
Type: Emgu.CVImage Gray, Byte
The mask for setting color
See Also

Reference

ImageTColor, TDepth Class
SetValue Overload
Emgu.CV Namespace


Image(TColor, TDepth).SmoothBilateral Method

ImageTColor, TDepthSmoothBilateral Method

Applying bilateral 3x3 filtering

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SmoothBilateral(
    int kernelSize,
    int colorSigma,
    int spaceSigma
)
Public Function SmoothBilateral (
    kernelSize As Integer,
    colorSigma As Integer,
    spaceSigma As Integer
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SmoothBilateral(
    int kernelSize,
    int colorSigma,
    int spaceSigma
)
member SmoothBilateral :
        kernelSize : int *
        colorSigma : int *
        spaceSigma : int -> Image<'TColor, 'TDepth>

Parameters

kernelSize
Type: SystemInt32
The size of the bilateral kernel
colorSigma
Type: SystemInt32
Color sigma
spaceSigma
Type: SystemInt32
Space sigma

Return Value

Type: Image TColor, TDepth
The result of bilateral smooth
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).SmoothBlur Method

ImageTColor, TDepthSmoothBlur Method

Overload List
 | Name | Description
Public method | SmoothBlur(Int32, Int32) | Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2)
Public method | SmoothBlur(Int32, Int32, Boolean) | Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2)
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).SmoothBlur Method (Int32, Int32)

ImageTColor, TDepthSmoothBlur Method (Int32, Int32)

http://www.emgu.com
Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SmoothBlur(
    int width,
    int height
)
Public Function SmoothBlur (
    width As Integer,
    height As Integer
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SmoothBlur(
    int width,
    int height
)
member SmoothBlur :
        width : int *
        height : int -> Image<'TColor, 'TDepth>

Parameters

width
Type: SystemInt32
The width of the window
height
Type: SystemInt32
The height of the window

Return Value

Type: Image TColor, TDepth
The result of blur
See Also

Reference

ImageTColor, TDepth Class
SmoothBlur Overload
Emgu.CV Namespace


Image(TColor, TDepth).SmoothBlur Method (Int32, Int32, Boolean)

ImageTColor, TDepthSmoothBlur Method (Int32, Int32, Boolean)

http://www.emgu.com
Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SmoothBlur(
    int width,
    int height,
    bool scale
)
Public Function SmoothBlur (
    width As Integer,
    height As Integer,
    scale As Boolean
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SmoothBlur(
    int width,
    int height,
    bool scale
)
member SmoothBlur :
        width : int *
        height : int *
        scale : bool -> Image<'TColor, 'TDepth>

Parameters

width
Type: SystemInt32
The width of the window
height
Type: SystemInt32
The height of the window
scale
Type: SystemBoolean
If true, the result is subsequent scaled by 1/(param1 x param2)

Return Value

Type: Image TColor, TDepth
The result of blur
See Also

Reference

ImageTColor, TDepth Class
SmoothBlur Overload
Emgu.CV Namespace


Image(TColor, TDepth).SmoothGaussian Method

ImageTColor, TDepthSmoothGaussian Method

Overload List
 | Name | Description
Public method | SmoothGaussian(Int32) | Perform Gaussian Smoothing in the current image and return the result
Public method | SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing in the current image and return the result
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).SmoothGaussian Method (Int32)

ImageTColor, TDepthSmoothGaussian Method (Int32)

http://www.emgu.com
Perform Gaussian Smoothing in the current image and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SmoothGaussian(
    int kernelSize
)
Public Function SmoothGaussian (
    kernelSize As Integer
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SmoothGaussian(
    int kernelSize
)
member SmoothGaussian :
        kernelSize : int -> Image<'TColor, 'TDepth>

Parameters

kernelSize
Type: SystemInt32
The size of the Gaussian kernel (kernelSize x kernelSize)

Return Value

Type: Image TColor, TDepth
The smoothed image
See Also

Reference

ImageTColor, TDepth Class
SmoothGaussian Overload
Emgu.CV Namespace


Image(TColor, TDepth).SmoothGaussian Method (Int32, Int32, Double, Double)

ImageTColor, TDepthSmoothGaussian Method (Int32, Int32, Double, Double)

http://www.emgu.com
Perform Gaussian Smoothing in the current image and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SmoothGaussian(
    int kernelWidth,
    int kernelHeight,
    double sigma1,
    double sigma2
)
Public Function SmoothGaussian (
    kernelWidth As Integer,
    kernelHeight As Integer,
    sigma1 As Double,
    sigma2 As Double
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SmoothGaussian(
    int kernelWidth,
    int kernelHeight,
    double sigma1,
    double sigma2
)
member SmoothGaussian :
        kernelWidth : int *
        kernelHeight : int *
        sigma1 : float *
        sigma2 : float -> Image<'TColor, 'TDepth>

Parameters

kernelWidth
Type: SystemInt32
The width of the Gaussian kernel
kernelHeight
Type: SystemInt32
The height of the Gaussian kernel
sigma1
Type: SystemDouble
The standard deviation of the Gaussian kernel in the horizontal dimension
sigma2
Type: SystemDouble
The standard deviation of the Gaussian kernel in the vertical dimension

Return Value

Type: Image TColor, TDepth
The smoothed image
See Also

Reference

ImageTColor, TDepth Class
SmoothGaussian Overload
Emgu.CV Namespace


Image(TColor, TDepth).SmoothMedian Method

ImageTColor, TDepthSmoothMedian Method

Finding median of sizexsize neighborhood

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SmoothMedian(
    int size
)
Public Function SmoothMedian (
    size As Integer
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SmoothMedian(
    int size
)
member SmoothMedian :
        size : int -> Image<'TColor, 'TDepth>

Parameters

size
Type: SystemInt32
The size (width & height) of the window

Return Value

Type: Image TColor, TDepth
The result of median smooth
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Sobel Method

ImageTColor, TDepthSobel Method

Calculates the image derivative by convolving the image with the appropriate kernel The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, float> Sobel(
    int xorder,
    int yorder,
    int apertureSize
)
Public Function Sobel (
    xorder As Integer,
    yorder As Integer,
    apertureSize As Integer
) As Image(Of TColor, Single)
public:
Image<TColor, float>^ Sobel(
    int xorder,
    int yorder,
    int apertureSize
)
member Sobel :
        xorder : int *
        yorder : int *
        apertureSize : int -> Image<'TColor, float32>

Parameters

xorder
Type: SystemInt32
Order of the derivative x
yorder
Type: SystemInt32
Order of the derivative y
apertureSize
Type: SystemInt32
Size of the extended Sobel kernel, must be 1, 3, 5 or 7. In all cases except 1, aperture_size xaperture_size separable kernel will be used to calculate the derivative.

Return Value

Type: Image TColor, Single
The result of the sobel edge detector
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Split Method

ImageTColor, TDepthSplit Method

Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, TDepth>[] Split()
Public Function Split As Image(Of Gray, TDepth)()
public:
array<Image<Gray^, TDepth>^>^ Split()
member Split : unit -> Image<Gray, 'TDepth>[]

Return Value

Type: Image Gray, TDepth
An array of gray scale images where each element in the array represent a single color channel of the original image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Sub Method

ImageTColor, TDepthSub Method

Overload List
 | Name | Description
Public method | Sub(TColor) | Elementwise subtract a color from the current image
Public method | Sub(ImageTColor, TDepth) | Elementwise subtract another image from the current image
Public method | Sub(ImageTColor, TDepth, ImageGray, Byte) | Elementwise subtract another image from the current image, using a mask
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Sub Method (TColor)

ImageTColor, TDepthSub Method (TColor)

http://www.emgu.com
Elementwise subtract a color from the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Sub(
    TColor val
)
Public Function Sub (
    val As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Sub(
    TColor val
)
member Sub :
        val : 'TColor -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color value to be subtracted from the current image

Return Value

Type: Image TColor, TDepth
The result of elementwise subtracting color 'val' from the current image
See Also

Reference

ImageTColor, TDepth Class
Sub Overload
Emgu.CV Namespace


Image(TColor, TDepth).Sub Method (Image(TColor, TDepth))

ImageTColor, TDepthSub Method (ImageTColor, TDepth)

http://www.emgu.com
Elementwise subtract another image from the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Sub(
    Image<TColor, TDepth> img2
)
Public Function Sub (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Sub(
    Image<TColor, TDepth>^ img2
)
member Sub :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image to be subtracted from the current image

Return Value

Type: Image TColor, TDepth
The result of elementwise subtracting img2 from the current image
See Also

Reference

ImageTColor, TDepth Class
Sub Overload
Emgu.CV Namespace


Image(TColor, TDepth).Sub Method (Image(TColor, TDepth), Image(Gray, Byte))

ImageTColor, TDepthSub Method (ImageTColor, TDepth, ImageGray, Byte)

http://www.emgu.com
Elementwise subtract another image from the current image, using a mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Sub(
    Image<TColor, TDepth> img2,
    Image<Gray, byte> mask
)
Public Function Sub (
    img2 As Image(Of TColor, TDepth),
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Sub(
    Image<TColor, TDepth>^ img2,
    Image<Gray^, unsigned char>^ mask
)
member Sub :
        img2 : Image<'TColor, 'TDepth> *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The image to be subtracted from the current image
mask
Type: Emgu.CVImage Gray, Byte
The mask for the subtract operation

Return Value

Type: Image TColor, TDepth
The result of elementwise subtracting img2 from the current image, using the specific mask
See Also

Reference

ImageTColor, TDepth Class
Sub Overload
Emgu.CV Namespace


Image(TColor, TDepth).SubR Method

ImageTColor, TDepthSubR Method

Overload List
 | Name | Description
Public method | SubR(TColor) | result = val - this
Public method | SubR(TColor, ImageGray, Byte) | result = val - this, using a mask
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).SubR Method (TColor)

ImageTColor, TDepthSubR Method (TColor)

http://www.emgu.com
result = val - this

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SubR(
    TColor val
)
Public Function SubR (
    val As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SubR(
    TColor val
)
member SubR :
        val : 'TColor -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
the value which subtract this image

Return Value

Type: Image TColor, TDepth
val - this
See Also

Reference

ImageTColor, TDepth Class
SubR Overload
Emgu.CV Namespace


Image(TColor, TDepth).SubR Method (TColor, Image(Gray, Byte))

ImageTColor, TDepthSubR Method (TColor, ImageGray, Byte)

http://www.emgu.com
result = val - this, using a mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> SubR(
    TColor val,
    Image<Gray, byte> mask
)
Public Function SubR (
    val As TColor,
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ SubR(
    TColor val,
    Image<Gray^, unsigned char>^ mask
)
member SubR :
        val : 'TColor *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The value which subtract this image
mask
Type: Emgu.CVImage Gray, Byte
The mask for subtraction

Return Value

Type: Image TColor, TDepth
val - this, with mask
See Also

Reference

ImageTColor, TDepth Class
SubR Overload
Emgu.CV Namespace


Image(TColor, TDepth).ThresholdAdaptive Method

ImageTColor, TDepthThresholdAdaptive Method

Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ThresholdAdaptive(
    TColor maxValue,
    AdaptiveThresholdType adaptiveType,
    ThresholdType thresholdType,
    int blockSize,
    TColor param1
)
Public Function ThresholdAdaptive (
    maxValue As TColor,
    adaptiveType As AdaptiveThresholdType,
    thresholdType As ThresholdType,
    blockSize As Integer,
    param1 As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ThresholdAdaptive(
    TColor maxValue,
    AdaptiveThresholdType^ adaptiveType,
    ThresholdType^ thresholdType,
    int blockSize,
    TColor param1
)
member ThresholdAdaptive :
        maxValue : 'TColor *
        adaptiveType : AdaptiveThresholdType *
        thresholdType : ThresholdType *
        blockSize : int *
        param1 : 'TColor -> Image<'TColor, 'TDepth>

Parameters

maxValue
Type: TColor
Maximum value to use with CV_THRESH_BINARY and CV_THRESH_BINARY_INV thresholding types
adaptiveType
Type: Emgu.CV.CvEnumAdaptiveThresholdType
Adaptive_method
thresholdType
Type: Emgu.CV.CvEnumThresholdType
Thresholding type. must be one of CV_THRESH_BINARY, CV_THRESH_BINARY_INV
blockSize
Type: SystemInt32
The size of a pixel neighborhood that is used to calculate a threshold value for the pixel: 3, 5, 7, ...
param1
Type: TColor
Constant subtracted from mean or weighted mean. It may be negative.

Return Value

Type: Image TColor, TDepth
The result of the adaptive threshold
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ThresholdBinary Method

ImageTColor, TDepthThresholdBinary Method

Threshold the image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ThresholdBinary(
    TColor threshold,
    TColor maxValue
)
Public Function ThresholdBinary (
    threshold As TColor,
    maxValue As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ThresholdBinary(
    TColor threshold,
    TColor maxValue
)
member ThresholdBinary :
        threshold : 'TColor *
        maxValue : 'TColor -> Image<'TColor, 'TDepth>

Parameters

threshold
Type: TColor
The threshold value
maxValue
Type: TColor
The maximum value of the pixel on the result

Return Value

Type: Image TColor, TDepth
The image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ThresholdBinaryInv Method

ImageTColor, TDepthThresholdBinaryInv Method

Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ThresholdBinaryInv(
    TColor threshold,
    TColor maxValue
)
Public Function ThresholdBinaryInv (
    threshold As TColor,
    maxValue As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ThresholdBinaryInv(
    TColor threshold,
    TColor maxValue
)
member ThresholdBinaryInv :
        threshold : 'TColor *
        maxValue : 'TColor -> Image<'TColor, 'TDepth>

Parameters

threshold
Type: TColor
The threshold value
maxValue
Type: TColor
The maximum value of the pixel on the result

Return Value

Type: Image TColor, TDepth
The image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ThresholdToZero Method

ImageTColor, TDepthThresholdToZero Method

Threshold the image such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ThresholdToZero(
    TColor threshold
)
Public Function ThresholdToZero (
    threshold As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ThresholdToZero(
    TColor threshold
)
member ThresholdToZero :
        threshold : 'TColor -> Image<'TColor, 'TDepth>

Parameters

threshold
Type: TColor
The threshold value

Return Value

Type: Image TColor, TDepth
dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ThresholdToZeroInv Method

ImageTColor, TDepthThresholdToZeroInv Method

Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ThresholdToZeroInv(
    TColor threshold
)
Public Function ThresholdToZeroInv (
    threshold As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ThresholdToZeroInv(
    TColor threshold
)
member ThresholdToZeroInv :
        threshold : 'TColor -> Image<'TColor, 'TDepth>

Parameters

threshold
Type: TColor
The threshold value

Return Value

Type: Image TColor, TDepth
The image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ThresholdTrunc Method

ImageTColor, TDepthThresholdTrunc Method

Threshold the image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ThresholdTrunc(
    TColor threshold
)
Public Function ThresholdTrunc (
    threshold As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ThresholdTrunc(
    TColor threshold
)
member ThresholdTrunc :
        threshold : 'TColor -> Image<'TColor, 'TDepth>

Parameters

threshold
Type: TColor
The threshold value

Return Value

Type: Image TColor, TDepth
The image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).ToJpegData Method

ImageTColor, TDepthToJpegData Method

Get the jpeg representation of the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] ToJpegData(
    int quality = 95
)
Public Function ToJpegData (
    Optional quality As Integer = 95
) As Byte()
public:
array<unsigned char>^ ToJpegData(
    int quality = 95
)
member ToJpegData :
        ?quality : int
(* Defaults:
        let _quality = defaultArg quality 95
*)
-> byte[]

Parameters

quality (Optional)
Type: SystemInt32
The jpeg quality

Return Value

Type: Byte
An byte array that contains the image as jpeg data
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).WarpAffine Method

ImageTColor, TDepthWarpAffine Method

Overload List
 | Name | Description
Public method | WarpAffine(Mat, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpAffine(Mat, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).WarpAffine Method (Mat, Inter, Warp, BorderType, TColor)

ImageTColor, TDepthWarpAffine Method (Mat, Inter, Warp, BorderType, TColor)

http://www.emgu.com
Transforms source image using the specified matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> WarpAffine(
    Mat mapMatrix,
    Inter interpolationType,
    Warp warpType,
    BorderType borderMode,
    TColor backgroundColor
)
Public Function WarpAffine (
    mapMatrix As Mat,
    interpolationType As Inter,
    warpType As Warp,
    borderMode As BorderType,
    backgroundColor As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ WarpAffine(
    Mat^ mapMatrix,
    Inter^ interpolationType,
    Warp^ warpType,
    BorderType^ borderMode,
    TColor backgroundColor
)
member WarpAffine :
        mapMatrix : Mat *
        interpolationType : Inter *
        warpType : Warp *
        borderMode : BorderType *
        backgroundColor : 'TColor -> Image<'TColor, 'TDepth>

Parameters

mapMatrix
Type: Emgu.CVMat
2x3 transformation matrix
interpolationType
Type: Emgu.CV.CvEnumInter
Interpolation type
warpType
Type: Emgu.CV.CvEnumWarp
Warp type
borderMode
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
backgroundColor
Type: TColor
A value used to fill outliers

Return Value

Type: Image TColor, TDepth
The result of the transformation
See Also

Reference

ImageTColor, TDepth Class
WarpAffine Overload
Emgu.CV Namespace


Image(TColor, TDepth).WarpAffine Method (Mat, Int32, Int32, Inter, Warp, BorderType, TColor)

ImageTColor, TDepthWarpAffine Method (Mat, Int32, Int32, Inter, Warp, BorderType, TColor)

http://www.emgu.com
Transforms source image using the specified matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> WarpAffine(
    Mat mapMatrix,
    int width,
    int height,
    Inter interpolationType,
    Warp warpType,
    BorderType borderMode,
    TColor backgroundColor
)
Public Function WarpAffine (
    mapMatrix As Mat,
    width As Integer,
    height As Integer,
    interpolationType As Inter,
    warpType As Warp,
    borderMode As BorderType,
    backgroundColor As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ WarpAffine(
    Mat^ mapMatrix,
    int width,
    int height,
    Inter^ interpolationType,
    Warp^ warpType,
    BorderType^ borderMode,
    TColor backgroundColor
)
member WarpAffine :
        mapMatrix : Mat *
        width : int *
        height : int *
        interpolationType : Inter *
        warpType : Warp *
        borderMode : BorderType *
        backgroundColor : 'TColor -> Image<'TColor, 'TDepth>

Parameters

mapMatrix
Type: Emgu.CVMat
2x3 transformation matrix
width
Type: SystemInt32
The width of the resulting image
height
Type: SystemInt32
the height of the resulting image
interpolationType
Type: Emgu.CV.CvEnumInter
Interpolation type
warpType
Type: Emgu.CV.CvEnumWarp
Warp type
borderMode
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
backgroundColor
Type: TColor
A value used to fill outliers

Return Value

Type: Image TColor, TDepth
The result of the transformation
See Also

Reference

ImageTColor, TDepth Class
WarpAffine Overload
Emgu.CV Namespace


Image(TColor, TDepth).WarpPerspective Method

ImageTColor, TDepthWarpPerspective Method

Overload List
 | Name | Description
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).WarpPerspective(TMapDepth) Method (Matrix(TMapDepth), Inter, Warp, BorderType, TColor)

ImageTColor, TDepthWarpPerspectiveTMapDepth Method (MatrixTMapDepth, Inter, Warp, BorderType, TColor)

http://www.emgu.com
Transforms source image using the specified matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> WarpPerspective<TMapDepth>(
    Matrix<TMapDepth> mapMatrix,
    Inter interpolationType,
    Warp warpType,
    BorderType borderMode,
    TColor backgroundColor
)
where TMapDepth : new()

Public Function WarpPerspective(Of TMapDepth As New) (
    mapMatrix As Matrix(Of TMapDepth),
    interpolationType As Inter,
    warpType As Warp,
    borderMode As BorderType,
    backgroundColor As TColor
) As Image(Of TColor, TDepth)
public:
generic<typename TMapDepth>
where TMapDepth : gcnew()
Image<TColor, TDepth>^ WarpPerspective(
    Matrix<TMapDepth>^ mapMatrix,
    Inter^ interpolationType,
    Warp^ warpType,
    BorderType^ borderMode,
    TColor backgroundColor
)
member WarpPerspective :
        mapMatrix : Matrix<'TMapDepth> *
        interpolationType : Inter *
        warpType : Warp *
        borderMode : BorderType *
        backgroundColor : 'TColor -> Image<'TColor, 'TDepth>  when 'TMapDepth : new()

Parameters

mapMatrix
Type: Emgu.CVMatrix TMapDepth
3x3 transformation matrix
interpolationType
Type: Emgu.CV.CvEnumInter
Interpolation type
warpType
Type: Emgu.CV.CvEnumWarp
Warp type
borderMode
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
backgroundColor
Type: TColor
A value used to fill outliers

Type Parameters

TMapDepth
The depth type of mapMatrix, should be either float or double

Return Value

Type: Image TColor, TDepth
The result of the transformation
See Also

Reference

ImageTColor, TDepth Class
WarpPerspective Overload
Emgu.CV Namespace


Image(TColor, TDepth).WarpPerspective(TMapDepth) Method (Matrix(TMapDepth), Int32, Int32, Inter, Warp, BorderType, TColor)

ImageTColor, TDepthWarpPerspectiveTMapDepth Method (MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor)

http://www.emgu.com
Transforms source image using the specified matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> WarpPerspective<TMapDepth>(
    Matrix<TMapDepth> mapMatrix,
    int width,
    int height,
    Inter interpolationType,
    Warp warpType,
    BorderType borderType,
    TColor backgroundColor
)
where TMapDepth : new()

Public Function WarpPerspective(Of TMapDepth As New) (
    mapMatrix As Matrix(Of TMapDepth),
    width As Integer,
    height As Integer,
    interpolationType As Inter,
    warpType As Warp,
    borderType As BorderType,
    backgroundColor As TColor
) As Image(Of TColor, TDepth)
public:
generic<typename TMapDepth>
where TMapDepth : gcnew()
Image<TColor, TDepth>^ WarpPerspective(
    Matrix<TMapDepth>^ mapMatrix,
    int width,
    int height,
    Inter^ interpolationType,
    Warp^ warpType,
    BorderType^ borderType,
    TColor backgroundColor
)
member WarpPerspective :
        mapMatrix : Matrix<'TMapDepth> *
        width : int *
        height : int *
        interpolationType : Inter *
        warpType : Warp *
        borderType : BorderType *
        backgroundColor : 'TColor -> Image<'TColor, 'TDepth>  when 'TMapDepth : new()

Parameters

mapMatrix
Type: Emgu.CVMatrix TMapDepth
3x3 transformation matrix
width
Type: SystemInt32
The width of the resulting image
height
Type: SystemInt32
the height of the resulting image
interpolationType
Type: Emgu.CV.CvEnumInter
Interpolation type
warpType
Type: Emgu.CV.CvEnumWarp
Warp type
borderType
Type: Emgu.CV.CvEnumBorderType
Border type
backgroundColor
Type: TColor
A value used to fill outliers

Type Parameters

TMapDepth
The depth type of mapMatrix, should be either float or double

Return Value

Type: Image TColor, TDepth
The result of the transformation
See Also

Reference

ImageTColor, TDepth Class
WarpPerspective Overload
Emgu.CV Namespace


Image(TColor, TDepth).Xor Method

ImageTColor, TDepthXor Method

Overload List
 | Name | Description
Public method | Xor(TColor) | Perform an binary XOR operation with some color
Public method | Xor(ImageTColor, TDepth) | Perform an elementwise XOR operation with another image and return the result
Public method | Xor(TColor, ImageGray, Byte) | Perform an binary XOR operation with some color using a mask
Public method | Xor(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise XOR operation with another image, using a mask, and return the result
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Xor Method (TColor)

ImageTColor, TDepthXor Method (TColor)

http://www.emgu.com
Perform an binary XOR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Xor(
    TColor val
)
Public Function Xor (
    val As TColor
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Xor(
    TColor val
)
member Xor :
        val : 'TColor -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The value for the XOR operation

Return Value

Type: Image TColor, TDepth
The result of the XOR operation
See Also

Reference

ImageTColor, TDepth Class
Xor Overload
Emgu.CV Namespace


Image(TColor, TDepth).Xor Method (Image(TColor, TDepth))

ImageTColor, TDepthXor Method (ImageTColor, TDepth)

http://www.emgu.com
Perform an elementwise XOR operation with another image and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Xor(
    Image<TColor, TDepth> img2
)
Public Function Xor (
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Xor(
    Image<TColor, TDepth>^ img2
)
member Xor :
        img2 : Image<'TColor, 'TDepth> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the XOR operation

Return Value

Type: Image TColor, TDepth
The result of the XOR operation
See Also

Reference

ImageTColor, TDepth Class
Xor Overload
Emgu.CV Namespace


Image(TColor, TDepth).Xor Method (TColor, Image(Gray, Byte))

ImageTColor, TDepthXor Method (TColor, ImageGray, Byte)

http://www.emgu.com
Perform an binary XOR operation with some color using a mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Xor(
    TColor val,
    Image<Gray, byte> mask
)
Public Function Xor (
    val As TColor,
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Xor(
    TColor val,
    Image<Gray^, unsigned char>^ mask
)
member Xor :
        val : 'TColor *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color for the XOR operation
mask
Type: Emgu.CVImage Gray, Byte
The mask for the XOR operation

Return Value

Type: Image TColor, TDepth
The result of the XOR operation
See Also

Reference

ImageTColor, TDepth Class
Xor Overload
Emgu.CV Namespace


Image(TColor, TDepth).Xor Method (Image(TColor, TDepth), Image(Gray, Byte))

ImageTColor, TDepthXor Method (ImageTColor, TDepth, ImageGray, Byte)

http://www.emgu.com
Perform an elementwise XOR operation with another image, using a mask, and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> Xor(
    Image<TColor, TDepth> img2,
    Image<Gray, byte> mask
)
Public Function Xor (
    img2 As Image(Of TColor, TDepth),
    mask As Image(Of Gray, Byte)
) As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ Xor(
    Image<TColor, TDepth>^ img2,
    Image<Gray^, unsigned char>^ mask
)
member Xor :
        img2 : Image<'TColor, 'TDepth> *
        mask : Image<Gray, byte> -> Image<'TColor, 'TDepth>

Parameters

img2
Type: Emgu.CVImage TColor, TDepth
The second image for the XOR operation
mask
Type: Emgu.CVImage Gray, Byte
The mask for the XOR operation

Return Value

Type: Image TColor, TDepth
The result of the XOR operation
See Also

Reference

ImageTColor, TDepth Class
Xor Overload
Emgu.CV Namespace


Image(TColor, TDepth) Operators

ImageTColor, TDepth Operators

The ImageTColor, TDepth generic type exposes the following members.

Operators
Name | Description
Addition(Double, ImageTColor, TDepth) | Element wise add img1 with val
Addition(TColor, ImageTColor, TDepth) | Element wise add image with value
Addition(ImageTColor, TDepth, ImageTColor, TDepth) | Element wise add img1 with img2
Addition(ImageTColor, TDepth, Double) | Element wise add image with value
Addition(ImageTColor, TDepth, TColor) | Element wise add image with value
BitwiseAnd(Double, ImageTColor, TDepth) | Perform an element wise AND operation using an images and a color
BitwiseAnd(TColor, ImageTColor, TDepth) | Perform an element wise AND operation using an images and a color
BitwiseAnd(ImageTColor, TDepth, ImageTColor, TDepth) | Perform an element wise AND operation on the two images
BitwiseAnd(ImageTColor, TDepth, Double) | Perform an element wise AND operation using an images and a color
BitwiseAnd(ImageTColor, TDepth, TColor) | Perform an element wise AND operation using an images and a color
BitwiseOr(Double, ImageTColor, TDepth) | Perform an binary OR operation with some color
BitwiseOr(TColor, ImageTColor, TDepth) | Perform an binary OR operation with some color
BitwiseOr(ImageTColor, TDepth, ImageTColor, TDepth) | Perform an element wise OR operation with another image and return the result
BitwiseOr(ImageTColor, TDepth, Double) | Perform an binary OR operation with some color
BitwiseOr(ImageTColor, TDepth, TColor) | Perform an binary OR operation with some color
Division(Double, ImageTColor, TDepth) | scale / image
Division(ImageTColor, TDepth, Double) | image / scale
Multiply(Double, ImageTColor, TDepth) | scale*image
Multiply(ImageTColor, TDepth, ConvolutionKernelF) | Perform the convolution with kernel on image
Multiply(ImageTColor, TDepth, Double) | image * scale
OnesComplement | Compute the complement image
Subtraction(Double, ImageTColor, TDepth) | value - image
Subtraction(TColor, ImageTColor, TDepth) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, ImageTColor, TDepth) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, Double) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, TColor) | Element wise subtract another image from the current image
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Addition Operator

ImageTColor, TDepthAddition Operator

Overload List
Name | Description
Addition(Double, ImageTColor, TDepth) | Element wise add img1 with val
Addition(TColor, ImageTColor, TDepth) | Element wise add image with value
Addition(ImageTColor, TDepth, ImageTColor, TDepth) | Element wise add img1 with img2
Addition(ImageTColor, TDepth, Double) | Element wise add image with value
Addition(ImageTColor, TDepth, TColor) | Element wise add image with value
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Addition Operator (Double, Image(TColor, TDepth))

ImageTColor, TDepthAddition Operator (Double, ImageTColor, TDepth)

http://www.emgu.com
Element wise add img1 with val

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator +(
    double val,
    Image<TColor, TDepth> img1
)
Public Shared Operator + (
    val As Double,
    img1 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator +(
    double val,
    Image<TColor, TDepth>^ img1
)
static let inline (+)
        val : float *
        img1 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

val
Type: SystemDouble
The value to be added
img1
Type: Emgu.CVImage TColor, TDepth
The image to be added

Return Value

Type: Image TColor, TDepth
The images plus the color
See Also

Reference

ImageTColor, TDepth Class
Addition Overload
Emgu.CV Namespace


Image(TColor, TDepth).Addition Operator (TColor, Image(TColor, TDepth))

ImageTColor, TDepthAddition Operator (TColor, ImageTColor, TDepth)

http://www.emgu.com
Element wise add image with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator +(
    TColor value,
    Image<TColor, TDepth> image
)
Public Shared Operator + (
    value As TColor,
    image As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator +(
    TColor value,
    Image<TColor, TDepth>^ image
)
static let inline (+)
        value : 'TColor *
        image : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

value
Type: TColor
The color to be added
image
Type: Emgu.CVImage TColor, TDepth
The image to be added

Return Value

Type: Image TColor, TDepth
The images plus the color
See Also

Reference

ImageTColor, TDepth Class
Addition Overload
Emgu.CV Namespace


Image(TColor, TDepth).Addition Operator (Image(TColor, TDepth), Image(TColor, TDepth))

ImageTColor, TDepthAddition Operator (ImageTColor, TDepth, ImageTColor, TDepth)

http://www.emgu.com
Element wise add img1 with img2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator +(
    Image<TColor, TDepth> img1,
    Image<TColor, TDepth> img2
)
Public Shared Operator + (
    img1 As Image(Of TColor, TDepth),
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator +(
    Image<TColor, TDepth>^ img1,
    Image<TColor, TDepth>^ img2
)
static let inline (+)
        img1 : Image<'TColor, 'TDepth> *
        img2 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

img1
Type: Emgu.CVImage TColor, TDepth
The first image to be added
img2
Type: Emgu.CVImage TColor, TDepth
The second image to be added

Return Value

Type: Image TColor, TDepth
The sum of the two images
See Also

Reference

ImageTColor, TDepth Class
Addition Overload
Emgu.CV Namespace


Image(TColor, TDepth).Addition Operator (Image(TColor, TDepth), Double)

ImageTColor, TDepthAddition Operator (ImageTColor, TDepth, Double)

http://www.emgu.com
Element wise add image with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator +(
    Image<TColor, TDepth> image,
    double value
)
Public Shared Operator + (
    image As Image(Of TColor, TDepth),
    value As Double
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator +(
    Image<TColor, TDepth>^ image,
    double value
)
static let inline (+)
        image : Image<'TColor, 'TDepth> *
        value : float  : Image<'TColor, 'TDepth>

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image to be added
value
Type: SystemDouble
The value to be added

Return Value

Type: Image TColor, TDepth
The images plus the color
See Also

Reference

ImageTColor, TDepth Class
Addition Overload
Emgu.CV Namespace


Image(TColor, TDepth).Addition Operator (Image(TColor, TDepth), TColor)

ImageTColor, TDepthAddition Operator (ImageTColor, TDepth, TColor)

http://www.emgu.com
Element wise add image with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator +(
    Image<TColor, TDepth> image,
    TColor value
)
Public Shared Operator + (
    image As Image(Of TColor, TDepth),
    value As TColor
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator +(
    Image<TColor, TDepth>^ image,
    TColor value
)
static let inline (+)
        image : Image<'TColor, 'TDepth> *
        value : 'TColor  : Image<'TColor, 'TDepth>

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image to be added
value
Type: TColor
The color to be added

Return Value

Type: Image TColor, TDepth
The images plus the color
See Also

Reference

ImageTColor, TDepth Class
Addition Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseAnd Operator

ImageTColor, TDepthBitwiseAnd Operator

Overload List
Name | Description
BitwiseAnd(Double, ImageTColor, TDepth) | Perform an element wise AND operation using an images and a color
BitwiseAnd(TColor, ImageTColor, TDepth) | Perform an element wise AND operation using an images and a color
BitwiseAnd(ImageTColor, TDepth, ImageTColor, TDepth) | Perform an element wise AND operation on the two images
BitwiseAnd(ImageTColor, TDepth, Double) | Perform an element wise AND operation using an images and a color
BitwiseAnd(ImageTColor, TDepth, TColor) | Perform an element wise AND operation using an images and a color
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseAnd Operator (Double, Image(TColor, TDepth))

ImageTColor, TDepthBitwiseAnd Operator (Double, ImageTColor, TDepth)

http://www.emgu.com
Perform an element wise AND operation using an images and a color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator &(
    double val,
    Image<TColor, TDepth> img1
)
Public Shared Operator And (
    val As Double,
    img1 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator &(
    double val,
    Image<TColor, TDepth>^ img1
)
static let inline (&&&)
        val : float *
        img1 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

val
Type: SystemDouble
The color to AND
img1
Type: Emgu.CVImage TColor, TDepth
The first image to AND

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseAnd Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseAnd Operator (TColor, Image(TColor, TDepth))

ImageTColor, TDepthBitwiseAnd Operator (TColor, ImageTColor, TDepth)

http://www.emgu.com
Perform an element wise AND operation using an images and a color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator &(
    TColor val,
    Image<TColor, TDepth> img1
)
Public Shared Operator And (
    val As TColor,
    img1 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator &(
    TColor val,
    Image<TColor, TDepth>^ img1
)
static let inline (&&&)
        val : 'TColor *
        img1 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color to AND
img1
Type: Emgu.CVImage TColor, TDepth
The first image to AND

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseAnd Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseAnd Operator (Image(TColor, TDepth), Image(TColor, TDepth))

ImageTColor, TDepthBitwiseAnd Operator (ImageTColor, TDepth, ImageTColor, TDepth)

http://www.emgu.com
Perform an element wise AND operation on the two images

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator &(
    Image<TColor, TDepth> img1,
    Image<TColor, TDepth> img2
)
Public Shared Operator And (
    img1 As Image(Of TColor, TDepth),
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator &(
    Image<TColor, TDepth>^ img1,
    Image<TColor, TDepth>^ img2
)
static let inline (&&&)
        img1 : Image<'TColor, 'TDepth> *
        img2 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

img1
Type: Emgu.CVImage TColor, TDepth
The first image to AND
img2
Type: Emgu.CVImage TColor, TDepth
The second image to AND

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseAnd Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseAnd Operator (Image(TColor, TDepth), Double)

ImageTColor, TDepthBitwiseAnd Operator (ImageTColor, TDepth, Double)

http://www.emgu.com
Perform an element wise AND operation using an images and a color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator &(
    Image<TColor, TDepth> img1,
    double val
)
Public Shared Operator And (
    img1 As Image(Of TColor, TDepth),
    val As Double
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator &(
    Image<TColor, TDepth>^ img1,
    double val
)
static let inline (&&&)
        img1 : Image<'TColor, 'TDepth> *
        val : float  : Image<'TColor, 'TDepth>

Parameters

img1
Type: Emgu.CVImage TColor, TDepth
The first image to AND
val
Type: SystemDouble
The color to AND

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseAnd Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseAnd Operator (Image(TColor, TDepth), TColor)

ImageTColor, TDepthBitwiseAnd Operator (ImageTColor, TDepth, TColor)

http://www.emgu.com
Perform an element wise AND operation using an images and a color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator &(
    Image<TColor, TDepth> img1,
    TColor val
)
Public Shared Operator And (
    img1 As Image(Of TColor, TDepth),
    val As TColor
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator &(
    Image<TColor, TDepth>^ img1,
    TColor val
)
static let inline (&&&)
        img1 : Image<'TColor, 'TDepth> *
        val : 'TColor  : Image<'TColor, 'TDepth>

Parameters

img1
Type: Emgu.CVImage TColor, TDepth
The first image to AND
val
Type: TColor
The color to AND

Return Value

Type: Image TColor, TDepth
The result of the AND operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseAnd Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseOr Operator

ImageTColor, TDepthBitwiseOr Operator

Overload List
Name | Description
BitwiseOr(Double, ImageTColor, TDepth) | Perform an binary OR operation with some color
BitwiseOr(TColor, ImageTColor, TDepth) | Perform an binary OR operation with some color
BitwiseOr(ImageTColor, TDepth, ImageTColor, TDepth) | Perform an element wise OR operation with another image and return the result
BitwiseOr(ImageTColor, TDepth, Double) | Perform an binary OR operation with some color
BitwiseOr(ImageTColor, TDepth, TColor) | Perform an binary OR operation with some color
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseOr Operator (Double, Image(TColor, TDepth))

ImageTColor, TDepthBitwiseOr Operator (Double, ImageTColor, TDepth)

http://www.emgu.com
Perform an binary OR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator |(
    double val,
    Image<TColor, TDepth> img1
)
Public Shared Operator Or (
    val As Double,
    img1 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator |(
    double val,
    Image<TColor, TDepth>^ img1
)
static let inline (|||)
        val : float *
        img1 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

val
Type: SystemDouble
The color to OR
img1
Type: Emgu.CVImage TColor, TDepth
The image to OR

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseOr Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseOr Operator (TColor, Image(TColor, TDepth))

ImageTColor, TDepthBitwiseOr Operator (TColor, ImageTColor, TDepth)

http://www.emgu.com
Perform an binary OR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator |(
    TColor val,
    Image<TColor, TDepth> img1
)
Public Shared Operator Or (
    val As TColor,
    img1 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator |(
    TColor val,
    Image<TColor, TDepth>^ img1
)
static let inline (|||)
        val : 'TColor *
        img1 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

val
Type: TColor
The color to OR
img1
Type: Emgu.CVImage TColor, TDepth
The image to OR

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseOr Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseOr Operator (Image(TColor, TDepth), Image(TColor, TDepth))

ImageTColor, TDepthBitwiseOr Operator (ImageTColor, TDepth, ImageTColor, TDepth)

http://www.emgu.com
Perform an element wise OR operation with another image and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator |(
    Image<TColor, TDepth> img1,
    Image<TColor, TDepth> img2
)
Public Shared Operator Or (
    img1 As Image(Of TColor, TDepth),
    img2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator |(
    Image<TColor, TDepth>^ img1,
    Image<TColor, TDepth>^ img2
)
static let inline (|||)
        img1 : Image<'TColor, 'TDepth> *
        img2 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

img1
Type: Emgu.CVImage TColor, TDepth
The first image to apply bitwise OR operation
img2
Type: Emgu.CVImage TColor, TDepth
The second image to apply bitwise OR operation

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseOr Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseOr Operator (Image(TColor, TDepth), Double)

ImageTColor, TDepthBitwiseOr Operator (ImageTColor, TDepth, Double)

http://www.emgu.com
Perform an binary OR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator |(
    Image<TColor, TDepth> img1,
    double val
)
Public Shared Operator Or (
    img1 As Image(Of TColor, TDepth),
    val As Double
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator |(
    Image<TColor, TDepth>^ img1,
    double val
)
static let inline (|||)
        img1 : Image<'TColor, 'TDepth> *
        val : float  : Image<'TColor, 'TDepth>

Parameters

img1
Type: Emgu.CVImage TColor, TDepth
The image to OR
val
Type: SystemDouble
The color to OR

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseOr Overload
Emgu.CV Namespace


Image(TColor, TDepth).BitwiseOr Operator (Image(TColor, TDepth), TColor)

ImageTColor, TDepthBitwiseOr Operator (ImageTColor, TDepth, TColor)

http://www.emgu.com
Perform an binary OR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator |(
    Image<TColor, TDepth> img1,
    TColor val
)
Public Shared Operator Or (
    img1 As Image(Of TColor, TDepth),
    val As TColor
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator |(
    Image<TColor, TDepth>^ img1,
    TColor val
)
static let inline (|||)
        img1 : Image<'TColor, 'TDepth> *
        val : 'TColor  : Image<'TColor, 'TDepth>

Parameters

img1
Type: Emgu.CVImage TColor, TDepth
The image to OR
val
Type: TColor
The color to OR

Return Value

Type: Image TColor, TDepth
The result of the OR operation
See Also

Reference

ImageTColor, TDepth Class
BitwiseOr Overload
Emgu.CV Namespace


Image(TColor, TDepth).Division Operator

ImageTColor, TDepthDivision Operator

Overload List
Name | Description
Division(Double, ImageTColor, TDepth) | scale / image
Division(ImageTColor, TDepth, Double) | image / scale
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Division Operator (Double, Image(TColor, TDepth))

ImageTColor, TDepthDivision Operator (Double, ImageTColor, TDepth)

http://www.emgu.com
scale / image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator /(
    double scale,
    Image<TColor, TDepth> image
)
Public Shared Operator / (
    scale As Double,
    image As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator /(
    double scale,
    Image<TColor, TDepth>^ image
)
static let inline (/)
        scale : float *
        image : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

scale
Type: SystemDouble
The scale
image
Type: Emgu.CVImage TColor, TDepth
The image

Return Value

Type: Image TColor, TDepth
scale / image
See Also

Reference

ImageTColor, TDepth Class
Division Overload
Emgu.CV Namespace


Image(TColor, TDepth).Division Operator (Image(TColor, TDepth), Double)

ImageTColor, TDepthDivision Operator (ImageTColor, TDepth, Double)

http://www.emgu.com
image / scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator /(
    Image<TColor, TDepth> image,
    double scale
)
Public Shared Operator / (
    image As Image(Of TColor, TDepth),
    scale As Double
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator /(
    Image<TColor, TDepth>^ image,
    double scale
)
static let inline (/)
        image : Image<'TColor, 'TDepth> *
        scale : float  : Image<'TColor, 'TDepth>

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image
scale
Type: SystemDouble
The division scale

Return Value

Type: Image TColor, TDepth
image / scale
See Also

Reference

ImageTColor, TDepth Class
Division Overload
Emgu.CV Namespace


Image(TColor, TDepth).Multiply Operator

ImageTColor, TDepthMultiply Operator

Overload List
Name | Description
Multiply(Double, ImageTColor, TDepth) | scale*image
Multiply(ImageTColor, TDepth, ConvolutionKernelF) | Perform the convolution with kernel on image
Multiply(ImageTColor, TDepth, Double) | image * scale
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Multiply Operator (Double, Image(TColor, TDepth))

ImageTColor, TDepthMultiply Operator (Double, ImageTColor, TDepth)

http://www.emgu.com
scale*image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator *(
    double scale,
    Image<TColor, TDepth> image
)
Public Shared Operator * (
    scale As Double,
    image As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator *(
    double scale,
    Image<TColor, TDepth>^ image
)
static let inline (*)
        scale : float *
        image : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

scale
Type: SystemDouble
The multiplication scale
image
Type: Emgu.CVImage TColor, TDepth
The image

Return Value

Type: Image TColor, TDepth
scale*image
See Also

Reference

ImageTColor, TDepth Class
Multiply Overload
Emgu.CV Namespace


Image(TColor, TDepth).Multiply Operator (Image(TColor, TDepth), ConvolutionKernelF)

ImageTColor, TDepthMultiply Operator (ImageTColor, TDepth, ConvolutionKernelF)

http://www.emgu.com
Perform the convolution with kernel on image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, float> operator *(
    Image<TColor, TDepth> image,
    ConvolutionKernelF kernel
)
Public Shared Operator * (
    image As Image(Of TColor, TDepth),
    kernel As ConvolutionKernelF
) As Image(Of TColor, Single)
public:
static Image<TColor, float>^ operator *(
    Image<TColor, TDepth>^ image,
    ConvolutionKernelF^ kernel
)
static let inline (*)
        image : Image<'TColor, 'TDepth> *
        kernel : ConvolutionKernelF  : Image<'TColor, float32>

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image
kernel
Type: Emgu.CVConvolutionKernelF
The kernel

Return Value

Type: Image TColor, Single
Result of the convolution
See Also

Reference

ImageTColor, TDepth Class
Multiply Overload
Emgu.CV Namespace


Image(TColor, TDepth).Multiply Operator (Image(TColor, TDepth), Double)

ImageTColor, TDepthMultiply Operator (ImageTColor, TDepth, Double)

http://www.emgu.com
image * scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator *(
    Image<TColor, TDepth> image,
    double scale
)
Public Shared Operator * (
    image As Image(Of TColor, TDepth),
    scale As Double
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator *(
    Image<TColor, TDepth>^ image,
    double scale
)
static let inline (*)
        image : Image<'TColor, 'TDepth> *
        scale : float  : Image<'TColor, 'TDepth>

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image
scale
Type: SystemDouble
The multiplication scale

Return Value

Type: Image TColor, TDepth
image * scale
See Also

Reference

ImageTColor, TDepth Class
Multiply Overload
Emgu.CV Namespace


Image(TColor, TDepth).OnesComplement Operator

ImageTColor, TDepthOnesComplement Operator

Compute the complement image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator ~(
    Image<TColor, TDepth> image
)
Public Shared Operator ~ (
    image As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator ~(
    Image<TColor, TDepth>^ image
)
F# does not support this operator.

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image to be inverted

Return Value

Type: Image TColor, TDepth
The complement image
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Subtraction Operator

ImageTColor, TDepthSubtraction Operator

Overload List
Name | Description
Subtraction(Double, ImageTColor, TDepth) | value - image
Subtraction(TColor, ImageTColor, TDepth) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, ImageTColor, TDepth) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, Double) | Element wise subtract another image from the current image
Subtraction(ImageTColor, TDepth, TColor) | Element wise subtract another image from the current image
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


Image(TColor, TDepth).Subtraction Operator (Double, Image(TColor, TDepth))

ImageTColor, TDepthSubtraction Operator (Double, ImageTColor, TDepth)

http://www.emgu.com
value - image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator -(
    double value,
    Image<TColor, TDepth> image
)
Public Shared Operator - (
    value As Double,
    image As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator -(
    double value,
    Image<TColor, TDepth>^ image
)
static let inline (-)
        value : float *
        image : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

value
Type: SystemDouble
The value to be subtracted
image
Type: Emgu.CVImage TColor, TDepth
The image to be subtracted

Return Value

Type: Image TColor, TDepth
value - image
See Also

Reference

ImageTColor, TDepth Class
Subtraction Overload
Emgu.CV Namespace


Image(TColor, TDepth).Subtraction Operator (TColor, Image(TColor, TDepth))

ImageTColor, TDepthSubtraction Operator (TColor, ImageTColor, TDepth)

http://www.emgu.com
Element wise subtract another image from the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator -(
    TColor value,
    Image<TColor, TDepth> image
)
Public Shared Operator - (
    value As TColor,
    image As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator -(
    TColor value,
    Image<TColor, TDepth>^ image
)
static let inline (-)
        value : 'TColor *
        image : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

value
Type: TColor
The color to be subtracted
image
Type: Emgu.CVImage TColor, TDepth
The image to be subtracted

Return Value

Type: Image TColor, TDepth
value - image
See Also

Reference

ImageTColor, TDepth Class
Subtraction Overload
Emgu.CV Namespace


Image(TColor, TDepth).Subtraction Operator (Image(TColor, TDepth), Image(TColor, TDepth))

ImageTColor, TDepthSubtraction Operator (ImageTColor, TDepth, ImageTColor, TDepth)

http://www.emgu.com
Element wise subtract another image from the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator -(
    Image<TColor, TDepth> image1,
    Image<TColor, TDepth> image2
)
Public Shared Operator - (
    image1 As Image(Of TColor, TDepth),
    image2 As Image(Of TColor, TDepth)
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator -(
    Image<TColor, TDepth>^ image1,
    Image<TColor, TDepth>^ image2
)
static let inline (-)
        image1 : Image<'TColor, 'TDepth> *
        image2 : Image<'TColor, 'TDepth>  : Image<'TColor, 'TDepth>

Parameters

image1
Type: Emgu.CVImage TColor, TDepth
The image to be subtracted
image2
Type: Emgu.CVImage TColor, TDepth
The second image to be subtracted from image1

Return Value

Type: Image TColor, TDepth
The result of element wise subtracting img2 from image1
See Also

Reference

ImageTColor, TDepth Class
Subtraction Overload
Emgu.CV Namespace


Image(TColor, TDepth).Subtraction Operator (Image(TColor, TDepth), Double)

ImageTColor, TDepthSubtraction Operator (ImageTColor, TDepth, Double)

http://www.emgu.com
Element wise subtract another image from the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator -(
    Image<TColor, TDepth> image,
    double value
)
Public Shared Operator - (
    image As Image(Of TColor, TDepth),
    value As Double
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator -(
    Image<TColor, TDepth>^ image,
    double value
)
static let inline (-)
        image : Image<'TColor, 'TDepth> *
        value : float  : Image<'TColor, 'TDepth>

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image to be subtracted
value
Type: SystemDouble
The value to be subtracted

Return Value

Type: Image TColor, TDepth
image - value
See Also

Reference

ImageTColor, TDepth Class
Subtraction Overload
Emgu.CV Namespace


Image(TColor, TDepth).Subtraction Operator (Image(TColor, TDepth), TColor)

ImageTColor, TDepthSubtraction Operator (ImageTColor, TDepth, TColor)

http://www.emgu.com
Element wise subtract another image from the current image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Image<TColor, TDepth> operator -(
    Image<TColor, TDepth> image,
    TColor value
)
Public Shared Operator - (
    image As Image(Of TColor, TDepth),
    value As TColor
) As Image(Of TColor, TDepth)
public:
static Image<TColor, TDepth>^ operator -(
    Image<TColor, TDepth>^ image,
    TColor value
)
static let inline (-)
        image : Image<'TColor, 'TDepth> *
        value : 'TColor  : Image<'TColor, 'TDepth>

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image to be subtracted
value
Type: TColor
The color to be subtracted

Return Value

Type: Image TColor, TDepth
The result of element wise subtracting value from image
See Also

Reference

ImageTColor, TDepth Class
Subtraction Overload
Emgu.CV Namespace


Image(TColor, TDepth) Fields

ImageTColor, TDepth Fields

The ImageTColor, TDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ImageTColor, TDepth Class
Emgu.CV Namespace


InputArray Class

This is the proxy class for passing read-only input arrays into OpenCV functions.
This is the proxy class for passing read-only input arrays into OpenCV functions.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVInputArray
Emgu.CVOutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class InputArray : UnmanagedObject
Public Class InputArray
    Inherits UnmanagedObject
public ref class InputArray : public UnmanagedObject
type InputArray =
    class
        inherit UnmanagedObject
    end

The InputArray type exposes the following members.

Constructors
 | Name | Description
Public method | InputArray | Create a Input array from an existing unmanaged inputArray pointer
Top
Properties
 | Name | Description
Public property | IsEmpty | Return true if the input array is empty
Public property | IsMat | True if the input array is a Mat
Public property | IsMatVector | True if the input array is a vector of Mat
Public property | IsMatx | True if the input array is a Matx
Public property | IsUMat | True if the input array is an UMat
Public property | IsUMatVector | True if the input array is a vector of UMat
Public property | Kind | The type of the input array
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | CopyTo | Copy this Input array to another.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this InputArray (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetChannels | Get the number of channels
Public method | GetDepth | Get the depth type
Public method | GetDims | Get the number of dimensions
 | GetEmpty | Get an empty input array
Public method | GetGpuMat | Get the GpuMat from the input array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMat | Get the Mat from the input array
Public method | GetSize | Get the size of the input array
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Get the UMat from the input array
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


InputArray Constructor

Create a Input array from an existing unmanaged inputArray pointer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray(
    IntPtr inputArrayPtr,
    Object parent
)
Public Sub New (
    inputArrayPtr As IntPtr,
    parent As Object
)
public:
InputArray(
    IntPtr inputArrayPtr,
    Object^ parent
)
new :
        inputArrayPtr : IntPtr *
        parent : Object -> InputArray

Parameters

inputArrayPtr
Type: SystemIntPtr
The unmanaged pointer the the InputArray
parent
Type: SystemObject
The parent object to keep reference to
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray Properties

The InputArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Return true if the input array is empty
Public property | IsMat | True if the input array is a Mat
Public property | IsMatVector | True if the input array is a vector of Mat
Public property | IsMatx | True if the input array is a Matx
Public property | IsUMat | True if the input array is an UMat
Public property | IsUMatVector | True if the input array is a vector of UMat
Public property | Kind | The type of the input array
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.IsEmpty Property

InputArrayIsEmpty Property

Return true if the input array is empty

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.IsMat Property

InputArrayIsMat Property

True if the input array is a Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsMat { get; }
Public ReadOnly Property IsMat As Boolean
    Get
public:
property bool IsMat {
    bool get ();
}
member IsMat : bool with get

Property Value

Type: Boolean
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.IsMatVector Property

InputArrayIsMatVector Property

True if the input array is a vector of Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsMatVector { get; }
Public ReadOnly Property IsMatVector As Boolean
    Get
public:
property bool IsMatVector {
    bool get ();
}
member IsMatVector : bool with get

Property Value

Type: Boolean
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.IsMatx Property

InputArrayIsMatx Property

True if the input array is a Matx

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsMatx { get; }
Public ReadOnly Property IsMatx As Boolean
    Get
public:
property bool IsMatx {
    bool get ();
}
member IsMatx : bool with get

Property Value

Type: Boolean
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.IsUMat Property

InputArrayIsUMat Property

True if the input array is an UMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsUMat { get; }
Public ReadOnly Property IsUMat As Boolean
    Get
public:
property bool IsUMat {
    bool get ();
}
member IsUMat : bool with get

Property Value

Type: Boolean
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.IsUMatVector Property

InputArrayIsUMatVector Property

True if the input array is a vector of UMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsUMatVector { get; }
Public ReadOnly Property IsUMatVector As Boolean
    Get
public:
property bool IsUMatVector {
    bool get ();
}
member IsUMatVector : bool with get

Property Value

Type: Boolean
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.Kind Property

InputArrayKind Property

The type of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArrayType Kind { get; }
Public ReadOnly Property Kind As InputArrayType
    Get
public:
property InputArrayType^ Kind {
    InputArrayType^ get ();
}
member Kind : InputArrayType with get

Property Value

Type: InputArrayType
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray Methods

The InputArray type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copy this Input array to another.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this InputArray (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetChannels | Get the number of channels
Public method | GetDepth | Get the depth type
Public method | GetDims | Get the number of dimensions
 | GetEmpty | Get an empty input array
Public method | GetGpuMat | Get the GpuMat from the input array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMat | Get the Mat from the input array
Public method | GetSize | Get the size of the input array
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Get the UMat from the input array
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.CopyTo Method

InputArrayCopyTo Method

Copy this Input array to another.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    IOutputArray arr,
    IInputArray mask = null
)
Public Sub CopyTo (
    arr As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
void CopyTo(
    IOutputArray^ arr,
    IInputArray^ mask = nullptr
)
member CopyTo :
        arr : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

arr
Type: Emgu.CVIOutputArray
The destination array.
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask.
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.DisposeObject Method

InputArrayDisposeObject Method

Release all the unmanaged memory associated with this InputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetChannels Method

InputArrayGetChannels Method

Get the number of channels

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetChannels(
    int idx = -1
)
Public Function GetChannels (
    Optional idx As Integer = -1
) As Integer
public:
int GetChannels(
    int idx = -1
)
member GetChannels :
        ?idx : int
(* Defaults:
        let _idx = defaultArg idx -1
*)
-> int

Parameters

idx (Optional)
Type: SystemInt32
The optional index

Return Value

Type: Int32
The number of channels
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetDepth Method

InputArrayGetDepth Method

Get the depth type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DepthType GetDepth(
    int idx = -1
)
Public Function GetDepth (
    Optional idx As Integer = -1
) As DepthType
public:
DepthType^ GetDepth(
    int idx = -1
)
member GetDepth :
        ?idx : int
(* Defaults:
        let _idx = defaultArg idx -1
*)
-> DepthType

Parameters

idx (Optional)
Type: SystemInt32
The optional index

Return Value

Type: DepthType
The depth type
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetDims Method

InputArrayGetDims Method

Get the number of dimensions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetDims(
    int i = -1
)
Public Function GetDims (
    Optional i As Integer = -1
) As Integer
public:
int GetDims(
    int i = -1
)
member GetDims :
        ?i : int
(* Defaults:
        let _i = defaultArg i -1
*)
-> int

Parameters

i (Optional)
Type: SystemInt32
The optional index

Return Value

Type: Int32
The dimensions
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetEmpty Method

InputArrayGetEmpty Method

Get an empty input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static InputArray GetEmpty()
Public Shared Function GetEmpty As InputArray
public:
static InputArray^ GetEmpty()
static member GetEmpty : unit -> InputArray

Return Value

Type: InputArray
An empty input array
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetGpuMat Method

InputArrayGetGpuMat Method

Get the GpuMat from the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat GetGpuMat()
Public Function GetGpuMat As GpuMat
public:
GpuMat^ GetGpuMat()
member GetGpuMat : unit -> GpuMat

Return Value

Type: GpuMat
The GpuMat
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetMat Method

InputArrayGetMat Method

Get the Mat from the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat GetMat(
    int idx = -1
)
Public Function GetMat (
    Optional idx As Integer = -1
) As Mat
public:
Mat^ GetMat(
    int idx = -1
)
member GetMat :
        ?idx : int
(* Defaults:
        let _idx = defaultArg idx -1
*)
-> Mat

Parameters

idx (Optional)
Type: SystemInt32
The index, in case if this is an VectorOfMat

Return Value

Type: Mat
The Mat
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetSize Method

InputArrayGetSize Method

Get the size of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size GetSize(
    int idx = -1
)
Public Function GetSize (
    Optional idx As Integer = -1
) As Size
public:
Size^ GetSize(
    int idx = -1
)
member GetSize :
        ?idx : int
(* Defaults:
        let _idx = defaultArg idx -1
*)
-> Size

Parameters

idx (Optional)
Type: SystemInt32
The optional index

Return Value

Type: Size
The size of the input array
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.GetUMat Method

InputArrayGetUMat Method

Get the UMat from the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat GetUMat(
    int idx = -1
)
Public Function GetUMat (
    Optional idx As Integer = -1
) As UMat
public:
UMat^ GetUMat(
    int idx = -1
)
member GetUMat :
        ?idx : int
(* Defaults:
        let _idx = defaultArg idx -1
*)
-> UMat

Parameters

idx (Optional)
Type: SystemInt32
The index, in case if this is an VectorOfUMat

Return Value

Type: UMat
The UMat
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray Fields

The InputArray type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

InputArray Class
Emgu.CV Namespace


InputArray.Type Class

InputArrayType Class

Input array type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVInputArrayType

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class Type : Enum
<FlagsAttribute>
Public NotInheritable Class Type
    Inherits Enum
[FlagsAttribute]
public ref class Type sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type Type =
    class
        inherit Enum
    end

The InputArrayType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CudaGpuMat | Cuda GpuMat
 | CudaHostMem | Cuda Host Mem
 | Expr | Expr
 | FixedSize | Fixed size
 | FixedType | Fixed type
 | KindMask | Kind mask
 | KindShift | kind shift
 | Mat | Mat
 | Matx | Matx
 | None | None
 | OpenglBuffer | Opengl buffer
 | StdBoolVector | StdBoolVector
 | StdVector | StdVector
 | StdVectorCudaGpuMat | StdVectorCudaGpuMat
 | StdVectorMat | StdVectorMat
 | StdVectorUMat | StdVectorUMat
 | StdVectorVector | StdVectorVector
 | UMat | UMat
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


Type Methods

The InputArrayType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


Type Fields

The InputArrayType type exposes the following members.

Fields
 | Name | Description
 | CudaGpuMat | Cuda GpuMat
 | CudaHostMem | Cuda Host Mem
 | Expr | Expr
 | FixedSize | Fixed size
 | FixedType | Fixed type
 | KindMask | Kind mask
 | KindShift | kind shift
 | Mat | Mat
 | Matx | Matx
 | None | None
 | OpenglBuffer | Opengl buffer
 | StdBoolVector | StdBoolVector
 | StdVector | StdVector
 | StdVectorCudaGpuMat | StdVectorCudaGpuMat
 | StdVectorMat | StdVectorMat
 | StdVectorUMat | StdVectorUMat
 | StdVectorVector | StdVectorVector
 | UMat | UMat
Public field | value__ |
Top
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.CudaGpuMat Field

InputArrayTypeCudaGpuMat Field

Cuda GpuMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType CudaGpuMat = 589824
Public Const CudaGpuMat As InputArrayType = 589824
public:
literal InputArrayType^ CudaGpuMat = 589824
static val mutable CudaGpuMat: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.CudaHostMem Field

InputArrayTypeCudaHostMem Field

Cuda Host Mem

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType CudaHostMem = 524288
Public Const CudaHostMem As InputArrayType = 524288
public:
literal InputArrayType^ CudaHostMem = 524288
static val mutable CudaHostMem: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.Expr Field

InputArrayTypeExpr Field

Expr

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType Expr = 393216
Public Const Expr As InputArrayType = 393216
public:
literal InputArrayType^ Expr = 393216
static val mutable Expr: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.FixedSize Field

InputArrayTypeFixedSize Field

Fixed size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType FixedSize = 1073741824
Public Const FixedSize As InputArrayType = 1073741824
public:
literal InputArrayType^ FixedSize = 1073741824
static val mutable FixedSize: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.FixedType Field

InputArrayTypeFixedType Field

Fixed type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType FixedType = -2147483648
Public Const FixedType As InputArrayType = -2147483648
public:
literal InputArrayType^ FixedType = -2147483648
static val mutable FixedType: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.KindMask Field

InputArrayTypeKindMask Field

Kind mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType KindMask = 2031616
Public Const KindMask As InputArrayType = 2031616
public:
literal InputArrayType^ KindMask = 2031616
static val mutable KindMask: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.KindShift Field

InputArrayTypeKindShift Field

kind shift

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType KindShift = 16
Public Const KindShift As InputArrayType = 16
public:
literal InputArrayType^ KindShift = 16
static val mutable KindShift: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.Mat Field

InputArrayTypeMat Field

Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType Mat = 65536
Public Const Mat As InputArrayType = 65536
public:
literal InputArrayType^ Mat = 65536
static val mutable Mat: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.Matx Field

InputArrayTypeMatx Field

Matx

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType Matx = 131072
Public Const Matx As InputArrayType = 131072
public:
literal InputArrayType^ Matx = 131072
static val mutable Matx: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.None Field

InputArrayTypeNone Field

None

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType None = 0
Public Const None As InputArrayType = 0
public:
literal InputArrayType^ None = 0
static val mutable None: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.OpenglBuffer Field

InputArrayTypeOpenglBuffer Field

Opengl buffer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType OpenglBuffer = 458752
Public Const OpenglBuffer As InputArrayType = 458752
public:
literal InputArrayType^ OpenglBuffer = 458752
static val mutable OpenglBuffer: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.StdBoolVector Field

InputArrayTypeStdBoolVector Field

StdBoolVector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType StdBoolVector = 786432
Public Const StdBoolVector As InputArrayType = 786432
public:
literal InputArrayType^ StdBoolVector = 786432
static val mutable StdBoolVector: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.StdVector Field

InputArrayTypeStdVector Field

StdVector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType StdVector = 196608
Public Const StdVector As InputArrayType = 196608
public:
literal InputArrayType^ StdVector = 196608
static val mutable StdVector: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.StdVectorCudaGpuMat Field

InputArrayTypeStdVectorCudaGpuMat Field

StdVectorCudaGpuMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType StdVectorCudaGpuMat = 851968
Public Const StdVectorCudaGpuMat As InputArrayType = 851968
public:
literal InputArrayType^ StdVectorCudaGpuMat = 851968
static val mutable StdVectorCudaGpuMat: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.StdVectorMat Field

InputArrayTypeStdVectorMat Field

StdVectorMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType StdVectorMat = 327680
Public Const StdVectorMat As InputArrayType = 327680
public:
literal InputArrayType^ StdVectorMat = 327680
static val mutable StdVectorMat: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.StdVectorUMat Field

InputArrayTypeStdVectorUMat Field

StdVectorUMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType StdVectorUMat = 720896
Public Const StdVectorUMat As InputArrayType = 720896
public:
literal InputArrayType^ StdVectorUMat = 720896
static val mutable StdVectorUMat: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.StdVectorVector Field

InputArrayTypeStdVectorVector Field

StdVectorVector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType StdVectorVector = 262144
Public Const StdVectorVector As InputArrayType = 262144
public:
literal InputArrayType^ StdVectorVector = 262144
static val mutable StdVectorVector: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.UMat Field

InputArrayTypeUMat Field

UMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InputArrayType UMat = 655360
Public Const UMat As InputArrayType = 655360
public:
literal InputArrayType^ UMat = 655360
static val mutable UMat: InputArrayType

Field Value

Type: InputArrayType
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputArray.Type.value__ Field

InputArrayTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.InputArray.Type.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

InputArrayType Class
Emgu.CV Namespace


InputOutputArray Class

This type is very similar to InputArray except that it is used for input/output function parameters.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVInputArray
Emgu.CVOutputArray
Emgu.CVInputOutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class InputOutputArray : OutputArray
Public Class InputOutputArray
    Inherits OutputArray
public ref class InputOutputArray : public OutputArray
type InputOutputArray =
    class
        inherit OutputArray
    end

The InputOutputArray type exposes the following members.

Constructors
 | Name | Description
Public method | InputOutputArray | Create an InputOutputArray from an existing unmanaged inputOutputArray pointer
Top
Properties
 | Name | Description
Public property | FixedSize | True if the output array is fixed size (Inherited from OutputArray.)
Public property | FixedType | True if the output array is fixed type (Inherited from OutputArray.)
Public property | IsEmpty | Return true if the input array is empty (Inherited from InputArray.)
Public property | IsMat | True if the input array is a Mat (Inherited from InputArray.)
Public property | IsMatVector | True if the input array is a vector of Mat (Inherited from InputArray.)
Public property | IsMatx | True if the input array is a Matx (Inherited from InputArray.)
Public property | IsUMat | True if the input array is an UMat (Inherited from InputArray.)
Public property | IsUMatVector | True if the input array is a vector of UMat (Inherited from InputArray.)
Public property | Kind | The type of the input array (Inherited from InputArray.)
Public property | Needed | True if the output array is needed (Inherited from OutputArray.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | CopyTo | Copy this Input array to another. (Inherited from InputArray.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this InputOutputArry (Overrides OutputArrayDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetChannels | Get the number of channels (Inherited from InputArray.)
Public method | GetDepth | Get the depth type (Inherited from InputArray.)
Public method | GetDims | Get the number of dimensions (Inherited from InputArray.)
 | GetEmpty | Get an empty InputOutputArray
Public method | GetGpuMat | Get the GpuMat from the input array (Inherited from InputArray.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMat | Get the Mat from the input array (Inherited from InputArray.)
Public method | GetSize | Get the size of the input array (Inherited from InputArray.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Get the UMat from the input array (Inherited from InputArray.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


InputOutputArray Constructor

Create an InputOutputArray from an existing unmanaged inputOutputArray pointer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray(
    IntPtr inputOutputArrayPtr,
    Object parent
)
Public Sub New (
    inputOutputArrayPtr As IntPtr,
    parent As Object
)
public:
InputOutputArray(
    IntPtr inputOutputArrayPtr,
    Object^ parent
)
new :
        inputOutputArrayPtr : IntPtr *
        parent : Object -> InputOutputArray

Parameters

inputOutputArrayPtr
Type: SystemIntPtr
The pointer to the existing inputOutputArray
parent
Type: SystemObject
The parent object to keep reference to
See Also

Reference

InputOutputArray Class
Emgu.CV Namespace


InputOutputArray Properties

The InputOutputArray type exposes the following members.

Properties
 | Name | Description
Public property | FixedSize | True if the output array is fixed size (Inherited from OutputArray.)
Public property | FixedType | True if the output array is fixed type (Inherited from OutputArray.)
Public property | IsEmpty | Return true if the input array is empty (Inherited from InputArray.)
Public property | IsMat | True if the input array is a Mat (Inherited from InputArray.)
Public property | IsMatVector | True if the input array is a vector of Mat (Inherited from InputArray.)
Public property | IsMatx | True if the input array is a Matx (Inherited from InputArray.)
Public property | IsUMat | True if the input array is an UMat (Inherited from InputArray.)
Public property | IsUMatVector | True if the input array is a vector of UMat (Inherited from InputArray.)
Public property | Kind | The type of the input array (Inherited from InputArray.)
Public property | Needed | True if the output array is needed (Inherited from OutputArray.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

InputOutputArray Class
Emgu.CV Namespace


InputOutputArray Methods

The InputOutputArray type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copy this Input array to another. (Inherited from InputArray.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this InputOutputArry (Overrides OutputArrayDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetChannels | Get the number of channels (Inherited from InputArray.)
Public method | GetDepth | Get the depth type (Inherited from InputArray.)
Public method | GetDims | Get the number of dimensions (Inherited from InputArray.)
 | GetEmpty | Get an empty InputOutputArray
Public method | GetGpuMat | Get the GpuMat from the input array (Inherited from InputArray.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMat | Get the Mat from the input array (Inherited from InputArray.)
Public method | GetSize | Get the size of the input array (Inherited from InputArray.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Get the UMat from the input array (Inherited from InputArray.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InputOutputArray Class
Emgu.CV Namespace


InputOutputArray.DisposeObject Method

InputOutputArrayDisposeObject Method

Release all the memory associated with this InputOutputArry

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

InputOutputArray Class
Emgu.CV Namespace


InputOutputArray.GetEmpty Method

InputOutputArrayGetEmpty Method

Get an empty InputOutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static InputOutputArray GetEmpty()
Public Shared Function GetEmpty As InputOutputArray
public:
static InputOutputArray^ GetEmpty()
static member GetEmpty : unit -> InputOutputArray

Return Value

Type: InputOutputArray
An empty InputOutputArray
See Also

Reference

InputOutputArray Class
Emgu.CV Namespace


InputOutputArray Fields

The InputOutputArray type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

InputOutputArray Class
Emgu.CV Namespace


IOutputArray Interface

This type is very similar to InputArray except that it is used for output function parameters.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IOutputArray : IInputArray,
    IDisposable
Public Interface IOutputArray
    Inherits IInputArray, IDisposable
public interface class IOutputArray : IInputArray,
    IDisposable
type IOutputArray =
    interface
        interface IInputArray
        interface IDisposable
    end

The IOutputArray type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Public method | GetOutputArray | The unmanaged pointer to the output array
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IOutputArray Methods

The IOutputArray type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Public method | GetOutputArray | The unmanaged pointer to the output array
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

IOutputArray Interface
Emgu.CV Namespace


IOutputArray.GetOutputArray Method

IOutputArrayGetOutputArray Method

The unmanaged pointer to the output array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
OutputArray GetOutputArray()
Function GetOutputArray As OutputArray
OutputArray^ GetOutputArray()
abstract GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
Get the output array
See Also

Reference

IOutputArray Interface
Emgu.CV Namespace


IOutputArrayOfArrays Interface

OutputArrayOfArrays

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IOutputArrayOfArrays : IOutputArray,
    IInputArray, IDisposable
Public Interface IOutputArrayOfArrays
    Inherits IOutputArray, IInputArray, IDisposable
public interface class IOutputArrayOfArrays : IOutputArray,
    IInputArray, IDisposable
type IOutputArrayOfArrays =
    interface
        interface IOutputArray
        interface IInputArray
        interface IDisposable
    end

The IOutputArrayOfArrays type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Public method | GetOutputArray | The unmanaged pointer to the output array (Inherited from IOutputArray.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


IOutputArrayOfArrays Methods

The IOutputArrayOfArrays type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from IInputArray.)
Public method | GetOutputArray | The unmanaged pointer to the output array (Inherited from IOutputArray.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

IOutputArrayOfArrays Interface
Emgu.CV Namespace


ISparseOpticalFlow Interface

Sparse Optical flow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface ISparseOpticalFlow : IAlgorithm
Public Interface ISparseOpticalFlow
    Inherits IAlgorithm
public interface class ISparseOpticalFlow : IAlgorithm
type ISparseOpticalFlow =
    interface
        interface IAlgorithm
    end

The ISparseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SparseOpticalFlowPtr | Gets the sparse optical flow pointer.
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by SparseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


ISparseOpticalFlow Properties

The ISparseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SparseOpticalFlowPtr | Gets the sparse optical flow pointer.
Top
See Also

Reference

ISparseOpticalFlow Interface
Emgu.CV Namespace


ISparseOpticalFlow.SparseOpticalFlowPtr Property

ISparseOpticalFlowSparseOpticalFlowPtr Property

Gets the sparse optical flow pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr SparseOpticalFlowPtr { get; }
ReadOnly Property SparseOpticalFlowPtr As IntPtr
    Get
property IntPtr SparseOpticalFlowPtr {
    IntPtr get ();
}
abstract SparseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
The sparse optical flow .
See Also

Reference

ISparseOpticalFlow Interface
Emgu.CV Namespace


ISparseOpticalFlow Methods

The ISparseOpticalFlow type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by SparseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

ISparseOpticalFlow Interface
Emgu.CV Namespace


IStereoMatcher Interface

The stereo matcher interface

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IStereoMatcher
Public Interface IStereoMatcher
public interface class IStereoMatcher
type IStereoMatcher =  interface end

The IStereoMatcher type exposes the following members.

Properties
 | Name | Description
Public property | StereoMatcherPtr | Pointer to the stereo matcher
Top
Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

Emgu.CV Namespace


IStereoMatcher Properties

The IStereoMatcher type exposes the following members.

Properties
 | Name | Description
Public property | StereoMatcherPtr | Pointer to the stereo matcher
Top
See Also

Reference

IStereoMatcher Interface
Emgu.CV Namespace


IStereoMatcher.StereoMatcherPtr Property

IStereoMatcherStereoMatcherPtr Property

Pointer to the stereo matcher

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr StereoMatcherPtr { get; }
ReadOnly Property StereoMatcherPtr As IntPtr
    Get
property IntPtr StereoMatcherPtr {
    IntPtr get ();
}
abstract StereoMatcherPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IStereoMatcher Interface
Emgu.CV Namespace


IStereoMatcher Methods

The IStereoMatcher type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

IStereoMatcher Interface
Emgu.CV Namespace


IWidget Interface

Interface for all widgets

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IWidget
Public Interface IWidget
public interface class IWidget
type IWidget =  interface end

The IWidget type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object
Top
See Also

Reference

Emgu.CV Namespace


IWidget Properties

The IWidget type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object
Top
See Also

Reference

IWidget Interface
Emgu.CV Namespace


IWidget.GetWidget Property

IWidgetGetWidget Property

Get the pointer to the widget object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr GetWidget { get; }
ReadOnly Property GetWidget As IntPtr
    Get
property IntPtr GetWidget {
    IntPtr get ();
}
abstract GetWidget : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IWidget Interface
Emgu.CV Namespace


IWidget2D Interface

Interface for all widget2D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IWidget2D : IWidget
Public Interface IWidget2D
    Inherits IWidget
public interface class IWidget2D : IWidget
type IWidget2D =
    interface
        interface IWidget
    end

The IWidget2D type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object (Inherited from IWidget.)
Public property | GetWidget2D | Get the pointer to the widget2D object
Top
See Also

Reference

Emgu.CV Namespace


IWidget2D Properties

The IWidget2D type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object (Inherited from IWidget.)
Public property | GetWidget2D | Get the pointer to the widget2D object
Top
See Also

Reference

IWidget2D Interface
Emgu.CV Namespace


IWidget2D.GetWidget2D Property

IWidget2DGetWidget2D Property

Get the pointer to the widget2D object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr GetWidget2D { get; }
ReadOnly Property GetWidget2D As IntPtr
    Get
property IntPtr GetWidget2D {
    IntPtr get ();
}
abstract GetWidget2D : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IWidget2D Interface
Emgu.CV Namespace


IWidget3D Interface

Interface for all widget3D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IWidget3D : IWidget
Public Interface IWidget3D
    Inherits IWidget
public interface class IWidget3D : IWidget
type IWidget3D =
    interface
        interface IWidget
    end

The IWidget3D type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object (Inherited from IWidget.)
Public property | GetWidget3D | Get the pointer to the widget3D object
Top
See Also

Reference

Emgu.CV Namespace


IWidget3D Properties

The IWidget3D type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object (Inherited from IWidget.)
Public property | GetWidget3D | Get the pointer to the widget3D object
Top
See Also

Reference

IWidget3D Interface
Emgu.CV Namespace


IWidget3D.GetWidget3D Property

IWidget3DGetWidget3D Property

Get the pointer to the widget3D object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr GetWidget3D { get; }
ReadOnly Property GetWidget3D As IntPtr
    Get
property IntPtr GetWidget3D {
    IntPtr get ();
}
abstract GetWidget3D : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IWidget3D Interface
Emgu.CV Namespace


KalmanFilter Class

The class implements a standard Kalman filter. However, you can modify transitionMatrix, controlMatrix, and measurementMatrix to get an extended Kalman filter functionality.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVKalmanFilter

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class KalmanFilter : UnmanagedObject
Public Class KalmanFilter
    Inherits UnmanagedObject
public ref class KalmanFilter : public UnmanagedObject
type KalmanFilter =
    class
        inherit UnmanagedObject
    end

The KalmanFilter type exposes the following members.

Constructors
 | Name | Description
Public method | KalmanFilter | Initializes a new instance of the KalmanFilter class.
Top
Properties
 | Name | Description
Public property | ControlMatrix | Control matrix (B) (not used if there is no control)
Public property | ErrorCovPost | posteriori error estimate covariance matrix (P(k)): P(k)=(I-K(k)*H)*P'(k)
Public property | ErrorCovPre | priori error estimate covariance matrix (P'(k)): P'(k)=A*P(k-1)*At + Q)
Public property | Gain | Kalman gain matrix (K(k)): K(k)=P'(k)*Ht*inv(H*P'(k)*Ht+R)
Public property | MeasurementMatrix | Measurement matrix (H)
Public property | MeasurementNoiseCov | Measurement noise covariance matrix (R)
Public property | ProcessNoiseCov | Process noise covariance matrix (Q)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | StatePost | Corrected state (x(k)): x(k)=x'(k)+K(k)*(z(k)-H*x'(k))
Public property | StatePre | Predicted state (x'(k)): x(k)=A*x(k-1)+B*u(k)
Public property | TransitionMatrix | State transition matrix (A)
Top
Methods
 | Name | Description
Public method | Correct | Updates the predicted state from the measurement.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Perform the predict operation using the option control input
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


KalmanFilter Constructor

Initializes a new instance of the KalmanFilter class.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public KalmanFilter(
    int dynamParams,
    int measureParams,
    int controlParams,
    DepthType type = 5
)
Public Sub New (
    dynamParams As Integer,
    measureParams As Integer,
    controlParams As Integer,
    Optional type As DepthType = 5
)
public:
KalmanFilter(
    int dynamParams,
    int measureParams,
    int controlParams,
    DepthType^ type = 5
)
new :
        dynamParams : int *
        measureParams : int *
        controlParams : int *
        ?type : DepthType
(* Defaults:
        let _type = defaultArg type 5
*)
-> KalmanFilter

Parameters

dynamParams
Type: SystemInt32
Dimensionality of the state.
measureParams
Type: SystemInt32
Dimensionality of the measurement.
controlParams
Type: SystemInt32
Dimensionality of the control vector.
type (Optional)
Type: Emgu.CV.CvEnumDepthType
Type of the created matrices that should be Cv32F or Cv64F
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter Properties

The KalmanFilter type exposes the following members.

Properties
 | Name | Description
Public property | ControlMatrix | Control matrix (B) (not used if there is no control)
Public property | ErrorCovPost | posteriori error estimate covariance matrix (P(k)): P(k)=(I-K(k)*H)*P'(k)
Public property | ErrorCovPre | priori error estimate covariance matrix (P'(k)): P'(k)=A*P(k-1)*At + Q)
Public property | Gain | Kalman gain matrix (K(k)): K(k)=P'(k)*Ht*inv(H*P'(k)*Ht+R)
Public property | MeasurementMatrix | Measurement matrix (H)
Public property | MeasurementNoiseCov | Measurement noise covariance matrix (R)
Public property | ProcessNoiseCov | Process noise covariance matrix (Q)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | StatePost | Corrected state (x(k)): x(k)=x'(k)+K(k)*(z(k)-H*x'(k))
Public property | StatePre | Predicted state (x'(k)): x(k)=A*x(k-1)+B*u(k)
Public property | TransitionMatrix | State transition matrix (A)
Top
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.ControlMatrix Property

KalmanFilterControlMatrix Property

Control matrix (B) (not used if there is no control)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat ControlMatrix { get; }
Public ReadOnly Property ControlMatrix As Mat
    Get
public:
property Mat^ ControlMatrix {
    Mat^ get ();
}
member ControlMatrix : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.ErrorCovPost Property

KalmanFilterErrorCovPost Property

posteriori error estimate covariance matrix (P(k)): P(k)=(I-K(k)*H)*P'(k)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat ErrorCovPost { get; }
Public ReadOnly Property ErrorCovPost As Mat
    Get
public:
property Mat^ ErrorCovPost {
    Mat^ get ();
}
member ErrorCovPost : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.ErrorCovPre Property

KalmanFilterErrorCovPre Property

priori error estimate covariance matrix (P'(k)): P'(k)=A*P(k-1)*At + Q)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat ErrorCovPre { get; }
Public ReadOnly Property ErrorCovPre As Mat
    Get
public:
property Mat^ ErrorCovPre {
    Mat^ get ();
}
member ErrorCovPre : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.Gain Property

KalmanFilterGain Property

Kalman gain matrix (K(k)): K(k)=P'(k)*Ht*inv(H*P'(k)*Ht+R)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Gain { get; }
Public ReadOnly Property Gain As Mat
    Get
public:
property Mat^ Gain {
    Mat^ get ();
}
member Gain : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.MeasurementMatrix Property

KalmanFilterMeasurementMatrix Property

Measurement matrix (H)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat MeasurementMatrix { get; }
Public ReadOnly Property MeasurementMatrix As Mat
    Get
public:
property Mat^ MeasurementMatrix {
    Mat^ get ();
}
member MeasurementMatrix : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.MeasurementNoiseCov Property

KalmanFilterMeasurementNoiseCov Property

Measurement noise covariance matrix (R)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat MeasurementNoiseCov { get; }
Public ReadOnly Property MeasurementNoiseCov As Mat
    Get
public:
property Mat^ MeasurementNoiseCov {
    Mat^ get ();
}
member MeasurementNoiseCov : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.ProcessNoiseCov Property

KalmanFilterProcessNoiseCov Property

Process noise covariance matrix (Q)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat ProcessNoiseCov { get; }
Public ReadOnly Property ProcessNoiseCov As Mat
    Get
public:
property Mat^ ProcessNoiseCov {
    Mat^ get ();
}
member ProcessNoiseCov : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.StatePost Property

KalmanFilterStatePost Property

Corrected state (x(k)): x(k)=x'(k)+K(k)*(z(k)-H*x'(k))

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat StatePost { get; }
Public ReadOnly Property StatePost As Mat
    Get
public:
property Mat^ StatePost {
    Mat^ get ();
}
member StatePost : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.StatePre Property

KalmanFilterStatePre Property

Predicted state (x'(k)): x(k)=A*x(k-1)+B*u(k)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat StatePre { get; }
Public ReadOnly Property StatePre As Mat
    Get
public:
property Mat^ StatePre {
    Mat^ get ();
}
member StatePre : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.TransitionMatrix Property

KalmanFilterTransitionMatrix Property

State transition matrix (A)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat TransitionMatrix { get; }
Public ReadOnly Property TransitionMatrix As Mat
    Get
public:
property Mat^ TransitionMatrix {
    Mat^ get ();
}
member TransitionMatrix : Mat with get

Return Value

Type: Mat
The result
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter Methods

The KalmanFilter type exposes the following members.

Methods
 | Name | Description
Public method | Correct | Updates the predicted state from the measurement.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Perform the predict operation using the option control input
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.Correct Method

KalmanFilterCorrect Method

Updates the predicted state from the measurement.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Correct(
    Mat measurement
)
Public Function Correct (
    measurement As Mat
) As Mat
public:
Mat^ Correct(
    Mat^ measurement
)
member Correct :
        measurement : Mat -> Mat

Parameters

measurement
Type: Emgu.CVMat
The measured system parameters

Return Value

Type: Mat

[Missing <returns> documentation for "M:Emgu.CV.KalmanFilter.Correct(Emgu.CV.Mat)"]

See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.DisposeObject Method

KalmanFilterDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter.Predict Method

KalmanFilterPredict Method

Perform the predict operation using the option control input

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Predict(
    Mat control = null
)
Public Function Predict (
    Optional control As Mat = Nothing
) As Mat
public:
Mat^ Predict(
    Mat^ control = nullptr
)
member Predict :
        ?control : Mat
(* Defaults:
        let _control = defaultArg control null
*)
-> Mat

Parameters

control (Optional)
Type: Emgu.CVMat
The control.

Return Value

Type: Mat
The predicted state.
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


KalmanFilter Fields

The KalmanFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

KalmanFilter Class
Emgu.CV Namespace


LineIterator Class

The class is used to iterate over all the pixels on the raster line segment connecting two specified points.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVLineIterator

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LineIterator : UnmanagedObject
Public Class LineIterator
    Inherits UnmanagedObject
public ref class LineIterator : public UnmanagedObject
type LineIterator =
    class
        inherit UnmanagedObject
    end

The LineIterator type exposes the following members.

Constructors
 | Name | Description
Public method | LineIterator | Create a LineIterator that can be used to get each pixel of a raster line. The line will be clipped on the image boundaries
Top
Properties
 | Name | Description
Public property | Count | The total number of pixels in the line
Public property | Data | Get or set the pixel data in the current position
Public property | DataPtr | Native pointer to the pixel data at the current position
Public property | Pos | returns the current position in the image
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Move to the next point
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
 | SampleLine | Copy the pixel data in the line to a new Mat that is of the same type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


LineIterator Constructor

Create a LineIterator that can be used to get each pixel of a raster line. The line will be clipped on the image boundaries

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineIterator(
    Mat img,
    Point p1,
    Point p2,
    int connectivity = 8,
    bool leftToRight = false
)
Public Sub New (
    img As Mat,
    p1 As Point,
    p2 As Point,
    Optional connectivity As Integer = 8,
    Optional leftToRight As Boolean = false
)
public:
LineIterator(
    Mat^ img,
    Point^ p1,
    Point^ p2,
    int connectivity = 8,
    bool leftToRight = false
)
new :
        img : Mat *
        p1 : Point *
        p2 : Point *
        ?connectivity : int *
        ?leftToRight : bool
(* Defaults:
        let _connectivity = defaultArg connectivity 8
        let _leftToRight = defaultArg leftToRight false
*)
-> LineIterator

Parameters

img
Type: Emgu.CVMat
The image
p1
Type: System.DrawingPoint
The first point
p2
Type: System.DrawingPoint
The second point
connectivity (Optional)
Type: SystemInt32
8-connected or 4-connected
leftToRight (Optional)
Type: SystemBoolean
If true, then the iteration is always done from the left-most point to the right most, not to depend on the ordering of pt1 and pt2 parameters
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator Properties

The LineIterator type exposes the following members.

Properties
 | Name | Description
Public property | Count | The total number of pixels in the line
Public property | Data | Get or set the pixel data in the current position
Public property | DataPtr | Native pointer to the pixel data at the current position
Public property | Pos | returns the current position in the image
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator.Count Property

LineIteratorCount Property

The total number of pixels in the line

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
public:
property int Count {
    int get ();
    void set (int value);
}
member Count : int with get, set

Property Value

Type: Int32
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator.Data Property

LineIteratorData Property

Get or set the pixel data in the current position

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Array Data { get; set; }
Public Property Data As Array
    Get
    Set
public:
property Array^ Data {
    Array^ get ();
    void set (Array^ value);
}
member Data : Array with get, set

Property Value

Type: Array
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator.DataPtr Property

LineIteratorDataPtr Property

Native pointer to the pixel data at the current position

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DataPtr { get; }
Public ReadOnly Property DataPtr As IntPtr
    Get
public:
property IntPtr DataPtr {
    IntPtr get ();
}
member DataPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator.Pos Property

LineIteratorPos Property

returns the current position in the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point Pos { get; }
Public ReadOnly Property Pos As Point
    Get
public:
property Point^ Pos {
    Point^ get ();
}
member Pos : Point with get

Property Value

Type: Point
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator Methods

The LineIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Move to the next point
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
 | SampleLine | Copy the pixel data in the line to a new Mat that is of the same type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator.DisposeObject Method

LineIteratorDisposeObject Method

Release unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator.MoveNext Method

LineIteratorMoveNext Method

Move to the next point

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MoveNext()
Public Sub MoveNext
public:
void MoveNext()
member MoveNext : unit -> unit
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator.SampleLine Method

LineIteratorSampleLine Method

Copy the pixel data in the line to a new Mat that is of the same type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat SampleLine(
    Mat img,
    Point p1,
    Point p2,
    int connectivity = 8,
    bool leftToRight = false
)
Public Shared Function SampleLine (
    img As Mat,
    p1 As Point,
    p2 As Point,
    Optional connectivity As Integer = 8,
    Optional leftToRight As Boolean = false
) As Mat
public:
static Mat^ SampleLine(
    Mat^ img,
    Point^ p1,
    Point^ p2,
    int connectivity = 8,
    bool leftToRight = false
)
static member SampleLine :
        img : Mat *
        p1 : Point *
        p2 : Point *
        ?connectivity : int *
        ?leftToRight : bool
(* Defaults:
        let _connectivity = defaultArg connectivity 8
        let _leftToRight = defaultArg leftToRight false
*)
-> Mat

Parameters

img
Type: Emgu.CVMat
The image to sample from
p1
Type: System.DrawingPoint
The first point
p2
Type: System.DrawingPoint
The second point
connectivity (Optional)
Type: SystemInt32
8-connected or 4-connected
leftToRight (Optional)
Type: SystemBoolean
If true, then the iteration is always done from the left-most point to the right most, not to depend on the ordering of pt1 and pt2 parameters

Return Value

Type: Mat
A new single column Mat of the same data type. The number of rows equals to the number of points on the sample line.
See Also

Reference

LineIterator Class
Emgu.CV Namespace


LineIterator Fields

The LineIterator type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

LineIterator Class
Emgu.CV Namespace


Map(TColor, TDepth) Class

MapTColor, TDepth Class

A Map is similar to an Image, except that the location of the pixels is defined by its area and resolution
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArray TDepth
Emgu.CVImage TColor, TDepth
Emgu.CVMapTColor, TDepth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Map<TColor, TDepth> : Image<TColor, TDepth>
where TColor : struct, new(), IColor
where TDepth : new()

<SerializableAttribute>
Public Class Map(Of TColor As {Structure, New, IColor}, TDepth As New)
    Inherits Image(Of TColor, TDepth)
[SerializableAttribute]
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
public ref class Map : public Image<TColor, TDepth>
[<SerializableAttribute>]
type Map<'TColor, 'TDepth when 'TColor : struct, new() and IColor when 'TDepth : new()> =
    class
        inherit Image<'TColor, 'TDepth>
    end

Type Parameters

TColor
The color of this map
TDepth
The depth of this map

The MapTColor, TDepth type exposes the following members.

Constructors
 | Name | Description
Public method | MapTColor, TDepth(RectangleF, PointF) | Create a new Image Map defined by the Rectangle area. The center (0.0, 0.0) of this map is defined by the center of the rectangle. The initial value of the map is 0.0
Public method | MapTColor, TDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | MapTColor, TDepth(RectangleF, PointF, TColor) | Create a new Image Map defined by the Rectangle area. The center (0.0, 0.0) of this map is defined by the center of the rectangle.
Top
Properties
 | Name | Description
Public property | Area | Get the area of this map as a rectangle
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix. The Get function has O(1) complexity. The Set function make a copy of the data (Inherited from ImageTColor, TDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | IsROISet | Indicates if the region of interest has been set (Inherited from ImageTColor, TDepth.)
Public property | ItemPoint | Get or Set the color in the location (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32 | Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image. (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32, Int32 | Get or Set the color in the rowth row (y direction) and columnth column (x direction) (Inherited from ImageTColor, TDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from ImageTColor, TDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MIplImage | The IplImage structure (Inherited from ImageTColor, TDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this image (Inherited from ImageTColor, TDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Resolution | Get the resolution of this map as a 2D point
Public property | ROI | Get or Set the region of interest for this map. To clear the ROI, set it to System.Drawing.RectangleF.Empty
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from ImageTColor, TDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Dilate | Dilates this image inplace using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _EqualizeHist | The algorithm inplace normalizes brightness and increases contrast of the image. For color images, a HSV representation of the image is first obtained and the V (value) channel is histogram normalized (Inherited from ImageTColor, TDepth.)
Public method | _Erode | Erodes this image inplace using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _Flip | Inplace flip the image (Inherited from ImageTColor, TDepth.)
Public method | _GammaCorrect | Gamma corrects this image inplace. The image must have a depth type of Byte. (Inherited from ImageTColor, TDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _MorphologyEx | Perform inplace advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _SmoothGaussian(Int32) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinary | Threshold the image inplace such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinaryInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZero | Threshold the image inplace such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZeroInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdTrunc | Threshold the image inplace such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | AbsDiff(ImageTColor, TDepth) | Computes absolute different between this image and the other image (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth, ImageGray, Byte) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double) | Update Running Average. this = (1-alpha)*this + alpha*img (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double, ImageGray, Byte) | Update Running Average. this = (1-alpha)*this + alpha*img, using the mask (Inherited from ImageTColor, TDepth.)
Public method | Action(ActionTDepth) | perform an generic action based on each element of the image (Inherited from ImageTColor, TDepth.)
Public method | ActionTOtherDepth(ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth) | Perform an generic operation based on the elements of the two images (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth) | Elementwise add another image with the current image (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth, ImageGray, Byte) | Elementwise add img2 with the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | AddWeighted | Return the weighted sum such that: res = this * alpha + img2 * beta + gamma (Inherited from ImageTColor, TDepth.)
Protected method | AllocateData | Re-allocate data for the array (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth) | Perform an elementwise AND operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise AND operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar, ImageGray, Byte) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | BuildPyramid | Compute the image pyramid (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double, Int32, Boolean) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a clone of the current image. All image data as well as the COI and ROI are cloned (Inherited from ImageTColor, TDepth.)
Public method | Cmp(Double, CmpType) | Compare the current image with value and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | Cmp(ImageTColor, TDepth, CmpType) | Compare the current image with img2 and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | ConcateHorizontal | Concate the current image with another image horizontally. (Inherited from ImageTColor, TDepth.)
Public method | ConcateVertical | Concate the current image with another image vertically. (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, TOtherDepth) | Compute the element of the new image based on element of this image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, Int32, Int32, TOtherDepth) | Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherColor, TOtherDepth | Convert the current image to the specific color and depth (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3(ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3) | Compute the element of the new image based on the elements of the two image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4(ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4) | Compute the element of the new image based on the elements of the three image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4, TDepth5(ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5) | Compute the element of the new image based on the elements of the four image (Inherited from ImageTColor, TDepth.)
Public method | ConvertFrom(IInputArray) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertFromTSrcColor, TSrcDepth(ImageTSrcColor, TSrcDepth) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertScaleTOtherDepth | Convert the current image to the specific depth, at the same time scale and shift the values of the pixel (Inherited from ImageTColor, TDepth.)
Public method | Convolution | Performs a convolution using the specific kernel (Inherited from ImageTColor, TDepth.)
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(RectangleF) | Get a copy of the map in the specific area
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination (Inherited from ImageTColor, TDepth.)
Public method | CopyBlank | Create an image of the same size (Inherited from ImageTColor, TDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Public method | CountNonzero | Count the non Zero elements for each channel (Inherited from ImageTColor, TDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dilate | Dilates this image using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associate with the image (Inherited from ImageTColor, TDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Draw(RectangleF, TColor, Int32) | Draw a rectangle in the map
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon of the specific color and thickness (Overrides ImageTColor, TDepthDraw(IConvexPolygonF, TColor, Int32).)
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness (Overrides ImageTColor, TDepthDraw(CircleF, TColor, Int32, LineType, Int32).)
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment in the map (Overrides ImageTColor, TDepthDraw(LineSegment2DF, TColor, Int32, LineType, Int32).)
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image (Overrides ImageTColor, TDepthDraw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean).)
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(PointF, Boolean, TColor, Int32) | Draw the polyline defined by the array of 2D points
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(ImageTColor, TDepth) | Compare two images, returns true if the each of the pixels are equal, false otherwise (Inherited from ImageTColor, TDepth.)
Public method | Erode | Erodes this image using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Exp | Calculates exponent of every element of input array: dst(I)=exp(src(I)) (Inherited from ImageTColor, TDepth.)
Public method | FillConvexPoly | Fill the convex polygon with the specific color (Inherited from ImageTColor, TDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindCornerSubPix | Iterates to find the sub-pixel accurate location of corners, or radial saddle points (Inherited from ImageTColor, TDepth.)
Public method | Flip | Return a flipped copy of the current image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage | Get the average value on this image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage(ImageGray, Byte) | Get the average value on this image, using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetMoments | Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characteristics including 7 Hu invariants. (Inherited from ImageTColor, TDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Overrides ImageTColor, TDepthGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a subimage which image data is shared with the current image. (Inherited from ImageTColor, TDepth.)
Public method | GetSum | Get the sum for each color channel (Inherited from ImageTColor, TDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrabCut | Use grabcut to perform background foreground segmentation. (Inherited from ImageTColor, TDepth.)
Public method | HoughCircles | First apply Canny Edge Detector on the current image, then apply Hough transform to find circles (Inherited from ImageTColor, TDepth.)
Public method | HoughLines | Apply Canny Edge Detector follows by Probabilistic Hough transform to find line segments in the image (Inherited from ImageTColor, TDepth.)
Public method | HoughLinesBinary | Apply Probabilistic Hough transform to find line segments. The current image must be a binary image (eg. the edges as a result of the Canny edge detector) (Inherited from ImageTColor, TDepth.)
Public method | ImagePointToMapPoint | Map an image point to a Map point
Public method | InPaint | Use inpaint to recover the intensity of the pixels which location defined by mask on this image (Inherited from ImageTColor, TDepth.)
Public method | InRange(TColor, TColor) | Checks that image elements lie between two scalars (Inherited from ImageTColor, TDepth.)
Public method | InRange(ImageTColor, TDepth, ImageTColor, TDepth) | Checks that image elements lie between values defined by two images of same size and type (Inherited from ImageTColor, TDepth.)
Public method | Integral | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double) | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double, ImageTColor, Double) | Calculates one or more integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Laplace | Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator. Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0| (Inherited from ImageTColor, TDepth.)
Public method | Log | Calculates natural logarithm of absolute value of every element of input array (Inherited from ImageTColor, TDepth.)
Public method | LogPolar | Convert the image to log polar, simulating the human foveal vision (Inherited from ImageTColor, TDepth.)
Protected method | MapDataToImage | Let this Image object use the specific Image data. (Inherited from ImageTColor, TDepth.)
Public method | MapPointToImagePoint(PointF) | Map a point to a position in the internal image
Public method | MapPointToImagePoint(MCvPoint2D64f) | Map a point to a position in the internal image
Public method | MatchTemplate | The function slides through image, compares overlapped patches of size wxh with templ using the specified method and return the comparison results (Inherited from ImageTColor, TDepth.)
Public method | Max(Double) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Public method | Max(ImageTColor, TDepth) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Min(Double) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | Min(ImageTColor, TDepth) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from ImageTColor, TDepth.)
Public method | MorphologyEx | Perform advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | Mul(Double) | Elementwise multiply the current image with scale (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth) | Elementwise multiply img2 with the current image (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth, Double) | Elementwise multiply another image with the current image and the scale (Inherited from ImageTColor, TDepth.)
Public method | Not | Compute the complement image (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth) | Perform an elementwise OR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise OR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | Pow | Raises every element of input array to p dst(I)=src(I)^p, if p is integer dst(I)=abs(src(I))^p, otherwise (Inherited from ImageTColor, TDepth.)
Public method | PyrDown | Performs downsampling step of Gaussian pyramid decomposition. First it convolves this image with the specified filter and then downsamples the image by rejecting even rows and columns. (Inherited from ImageTColor, TDepth.)
Public method | PyrUp | Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples this image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the resulting image is four times larger than the source image. (Inherited from ImageTColor, TDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Resize(Double, Inter) | Scale the image to the specific size: width *= scale; height *= scale (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter, Boolean) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor) | Rotate the image the specified angle cropping the result to the original size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, PointF, Inter, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Save | Save this image to the specific file. (Inherited from ImageTColor, TDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor) | Set every pixel of the image to the specific color (Inherited from ImageTColor, TDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor, ImageGray, Byte) | Set every pixel of the image to the specific color, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | SmoothBilateral | Applying bilateral 3x3 filtering (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32) | Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32, Boolean) | Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothMedian | Finding median of sizexsize neighborhood (Inherited from ImageTColor, TDepth.)
Public method | Sobel | Calculates the image derivative by convolving the image with the appropriate kernel The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative. (Inherited from ImageTColor, TDepth.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth) | Elementwise subtract another image from the current image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth, ImageGray, Byte) | Elementwise subtract another image from the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor) | result = val - this (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor, ImageGray, Byte) | result = val - this, using a mask (Inherited from ImageTColor, TDepth.)
Public method | ThresholdAdaptive | Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1. (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinary | Threshold the image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinaryInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZero | Threshold the image such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZeroInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdTrunc | Threshold the image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ToJpegData | Get the jpeg representation of the image (Inherited from ImageTColor, TDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WarpAffine(Mat, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpAffine(Mat, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Public method | Xor(ImageTColor, TDepth) | Perform an elementwise XOR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Xor(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise XOR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Top
Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


Map(TColor, TDepth) Constructor

MapTColor, TDepth Constructor

Overload List
 | Name | Description
Public method | MapTColor, TDepth(RectangleF, PointF) | Create a new Image Map defined by the Rectangle area. The center (0.0, 0.0) of this map is defined by the center of the rectangle. The initial value of the map is 0.0
Public method | MapTColor, TDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | MapTColor, TDepth(RectangleF, PointF, TColor) | Create a new Image Map defined by the Rectangle area. The center (0.0, 0.0) of this map is defined by the center of the rectangle.
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth) Constructor (RectangleF, PointF)

MapTColor, TDepth Constructor (RectangleF, PointF)

http://www.emgu.com
Create a new Image Map defined by the Rectangle area. The center (0.0, 0.0) of this map is defined by the center of the rectangle. The initial value of the map is 0.0

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Map(
    RectangleF area,
    PointF resolution
)
Public Sub New (
    area As RectangleF,
    resolution As PointF
)
public:
Map(
    RectangleF^ area,
    PointF^ resolution
)
new :
        area : RectangleF *
        resolution : PointF -> Map

Parameters

area
Type: System.DrawingRectangleF
The area this map covers.
resolution
Type: System.DrawingPointF
The resolution of x (y), (e.g. a value of 0.5 means each cell in the map is 0.5 unit in x (y) dimension)
See Also

Reference

MapTColor, TDepth Class
MapTColor, TDepth Overload
Emgu.CV Namespace


Map(TColor, TDepth) Constructor (SerializationInfo, StreamingContext)

MapTColor, TDepth Constructor (SerializationInfo, StreamingContext)

http://www.emgu.com
Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Map(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
Map(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> Map

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

MapTColor, TDepth Class
MapTColor, TDepth Overload
Emgu.CV Namespace


Map(TColor, TDepth) Constructor (RectangleF, PointF, TColor)

MapTColor, TDepth Constructor (RectangleF, PointF, TColor)

http://www.emgu.com
Create a new Image Map defined by the Rectangle area. The center (0.0, 0.0) of this map is defined by the center of the rectangle.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Map(
    RectangleF area,
    PointF resolution,
    TColor color
)
Public Sub New (
    area As RectangleF,
    resolution As PointF,
    color As TColor
)
public:
Map(
    RectangleF^ area,
    PointF^ resolution,
    TColor color
)
new :
        area : RectangleF *
        resolution : PointF *
        color : 'TColor -> Map

Parameters

area
Type: System.DrawingRectangleF
The area this map covers.
resolution
Type: System.DrawingPointF
The resolution of x (y), (e.g. a value of 0.5 means each cell in the map is 0.5 unit in x (y) dimension)
color
Type: TColor
The initial color of the map
See Also

Reference

MapTColor, TDepth Class
MapTColor, TDepth Overload
Emgu.CV Namespace


Map(TColor, TDepth) Properties

MapTColor, TDepth Properties

The MapTColor, TDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Area | Get the area of this map as a rectangle
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix. The Get function has O(1) complexity. The Set function make a copy of the data (Inherited from ImageTColor, TDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | IsROISet | Indicates if the region of interest has been set (Inherited from ImageTColor, TDepth.)
Public property | ItemPoint | Get or Set the color in the location (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32 | Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image. (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32, Int32 | Get or Set the color in the rowth row (y direction) and columnth column (x direction) (Inherited from ImageTColor, TDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from ImageTColor, TDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MIplImage | The IplImage structure (Inherited from ImageTColor, TDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this image (Inherited from ImageTColor, TDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Resolution | Get the resolution of this map as a 2D point
Public property | ROI | Get or Set the region of interest for this map. To clear the ROI, set it to System.Drawing.RectangleF.Empty
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from ImageTColor, TDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).Area Property

MapTColor, TDepthArea Property

Get the area of this map as a rectangle

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF Area { get; }
Public ReadOnly Property Area As RectangleF
    Get
public:
property RectangleF^ Area {
    RectangleF^ get ();
}
member Area : RectangleF with get

Property Value

Type: RectangleF
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).Resolution Property

MapTColor, TDepthResolution Property

Get the resolution of this map as a 2D point

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Resolution { get; }
Public ReadOnly Property Resolution As PointF
    Get
public:
property PointF^ Resolution {
    PointF^ get ();
}
member Resolution : PointF with get

Property Value

Type: PointF
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).ROI Property

MapTColor, TDepthROI Property

Get or Set the region of interest for this map. To clear the ROI, set it to System.Drawing.RectangleF.Empty

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF ROI { get; set; }
Public Property ROI As RectangleF
    Get
    Set
public:
property RectangleF^ ROI {
    RectangleF^ get ();
    void set (RectangleF^ value);
}
member ROI : RectangleF with get, set

Property Value

Type: RectangleF
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth) Methods

MapTColor, TDepth Methods

The MapTColor, TDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Dilate | Dilates this image inplace using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _EqualizeHist | The algorithm inplace normalizes brightness and increases contrast of the image. For color images, a HSV representation of the image is first obtained and the V (value) channel is histogram normalized (Inherited from ImageTColor, TDepth.)
Public method | _Erode | Erodes this image inplace using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _Flip | Inplace flip the image (Inherited from ImageTColor, TDepth.)
Public method | _GammaCorrect | Gamma corrects this image inplace. The image must have a depth type of Byte. (Inherited from ImageTColor, TDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _MorphologyEx | Perform inplace advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _SmoothGaussian(Int32) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinary | Threshold the image inplace such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinaryInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZero | Threshold the image inplace such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZeroInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdTrunc | Threshold the image inplace such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | AbsDiff(ImageTColor, TDepth) | Computes absolute different between this image and the other image (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth, ImageGray, Byte) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double) | Update Running Average. this = (1-alpha)*this + alpha*img (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double, ImageGray, Byte) | Update Running Average. this = (1-alpha)*this + alpha*img, using the mask (Inherited from ImageTColor, TDepth.)
Public method | Action(ActionTDepth) | perform an generic action based on each element of the image (Inherited from ImageTColor, TDepth.)
Public method | ActionTOtherDepth(ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth) | Perform an generic operation based on the elements of the two images (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth) | Elementwise add another image with the current image (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth, ImageGray, Byte) | Elementwise add img2 with the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | AddWeighted | Return the weighted sum such that: res = this * alpha + img2 * beta + gamma (Inherited from ImageTColor, TDepth.)
Protected method | AllocateData | Re-allocate data for the array (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth) | Perform an elementwise AND operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise AND operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar, ImageGray, Byte) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | BuildPyramid | Compute the image pyramid (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double, Int32, Boolean) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a clone of the current image. All image data as well as the COI and ROI are cloned (Inherited from ImageTColor, TDepth.)
Public method | Cmp(Double, CmpType) | Compare the current image with value and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | Cmp(ImageTColor, TDepth, CmpType) | Compare the current image with img2 and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | ConcateHorizontal | Concate the current image with another image horizontally. (Inherited from ImageTColor, TDepth.)
Public method | ConcateVertical | Concate the current image with another image vertically. (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, TOtherDepth) | Compute the element of the new image based on element of this image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, Int32, Int32, TOtherDepth) | Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherColor, TOtherDepth | Convert the current image to the specific color and depth (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3(ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3) | Compute the element of the new image based on the elements of the two image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4(ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4) | Compute the element of the new image based on the elements of the three image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4, TDepth5(ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5) | Compute the element of the new image based on the elements of the four image (Inherited from ImageTColor, TDepth.)
Public method | ConvertFrom(IInputArray) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertFromTSrcColor, TSrcDepth(ImageTSrcColor, TSrcDepth) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertScaleTOtherDepth | Convert the current image to the specific depth, at the same time scale and shift the values of the pixel (Inherited from ImageTColor, TDepth.)
Public method | Convolution | Performs a convolution using the specific kernel (Inherited from ImageTColor, TDepth.)
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(RectangleF) | Get a copy of the map in the specific area
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination (Inherited from ImageTColor, TDepth.)
Public method | CopyBlank | Create an image of the same size (Inherited from ImageTColor, TDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Public method | CountNonzero | Count the non Zero elements for each channel (Inherited from ImageTColor, TDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dilate | Dilates this image using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associate with the image (Inherited from ImageTColor, TDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Draw(RectangleF, TColor, Int32) | Draw a rectangle in the map
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon of the specific color and thickness (Overrides ImageTColor, TDepthDraw(IConvexPolygonF, TColor, Int32).)
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness (Overrides ImageTColor, TDepthDraw(CircleF, TColor, Int32, LineType, Int32).)
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment in the map (Overrides ImageTColor, TDepthDraw(LineSegment2DF, TColor, Int32, LineType, Int32).)
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image (Overrides ImageTColor, TDepthDraw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean).)
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(PointF, Boolean, TColor, Int32) | Draw the polyline defined by the array of 2D points
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(ImageTColor, TDepth) | Compare two images, returns true if the each of the pixels are equal, false otherwise (Inherited from ImageTColor, TDepth.)
Public method | Erode | Erodes this image using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Exp | Calculates exponent of every element of input array: dst(I)=exp(src(I)) (Inherited from ImageTColor, TDepth.)
Public method | FillConvexPoly | Fill the convex polygon with the specific color (Inherited from ImageTColor, TDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindCornerSubPix | Iterates to find the sub-pixel accurate location of corners, or radial saddle points (Inherited from ImageTColor, TDepth.)
Public method | Flip | Return a flipped copy of the current image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage | Get the average value on this image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage(ImageGray, Byte) | Get the average value on this image, using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetMoments | Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characteristics including 7 Hu invariants. (Inherited from ImageTColor, TDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Overrides ImageTColor, TDepthGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a subimage which image data is shared with the current image. (Inherited from ImageTColor, TDepth.)
Public method | GetSum | Get the sum for each color channel (Inherited from ImageTColor, TDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrabCut | Use grabcut to perform background foreground segmentation. (Inherited from ImageTColor, TDepth.)
Public method | HoughCircles | First apply Canny Edge Detector on the current image, then apply Hough transform to find circles (Inherited from ImageTColor, TDepth.)
Public method | HoughLines | Apply Canny Edge Detector follows by Probabilistic Hough transform to find line segments in the image (Inherited from ImageTColor, TDepth.)
Public method | HoughLinesBinary | Apply Probabilistic Hough transform to find line segments. The current image must be a binary image (eg. the edges as a result of the Canny edge detector) (Inherited from ImageTColor, TDepth.)
Public method | ImagePointToMapPoint | Map an image point to a Map point
Public method | InPaint | Use inpaint to recover the intensity of the pixels which location defined by mask on this image (Inherited from ImageTColor, TDepth.)
Public method | InRange(TColor, TColor) | Checks that image elements lie between two scalars (Inherited from ImageTColor, TDepth.)
Public method | InRange(ImageTColor, TDepth, ImageTColor, TDepth) | Checks that image elements lie between values defined by two images of same size and type (Inherited from ImageTColor, TDepth.)
Public method | Integral | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double) | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double, ImageTColor, Double) | Calculates one or more integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Laplace | Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator. Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0| (Inherited from ImageTColor, TDepth.)
Public method | Log | Calculates natural logarithm of absolute value of every element of input array (Inherited from ImageTColor, TDepth.)
Public method | LogPolar | Convert the image to log polar, simulating the human foveal vision (Inherited from ImageTColor, TDepth.)
Protected method | MapDataToImage | Let this Image object use the specific Image data. (Inherited from ImageTColor, TDepth.)
Public method | MapPointToImagePoint(PointF) | Map a point to a position in the internal image
Public method | MapPointToImagePoint(MCvPoint2D64f) | Map a point to a position in the internal image
Public method | MatchTemplate | The function slides through image, compares overlapped patches of size wxh with templ using the specified method and return the comparison results (Inherited from ImageTColor, TDepth.)
Public method | Max(Double) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Public method | Max(ImageTColor, TDepth) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Min(Double) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | Min(ImageTColor, TDepth) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from ImageTColor, TDepth.)
Public method | MorphologyEx | Perform advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | Mul(Double) | Elementwise multiply the current image with scale (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth) | Elementwise multiply img2 with the current image (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth, Double) | Elementwise multiply another image with the current image and the scale (Inherited from ImageTColor, TDepth.)
Public method | Not | Compute the complement image (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth) | Perform an elementwise OR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise OR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | Pow | Raises every element of input array to p dst(I)=src(I)^p, if p is integer dst(I)=abs(src(I))^p, otherwise (Inherited from ImageTColor, TDepth.)
Public method | PyrDown | Performs downsampling step of Gaussian pyramid decomposition. First it convolves this image with the specified filter and then downsamples the image by rejecting even rows and columns. (Inherited from ImageTColor, TDepth.)
Public method | PyrUp | Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples this image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the resulting image is four times larger than the source image. (Inherited from ImageTColor, TDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Resize(Double, Inter) | Scale the image to the specific size: width *= scale; height *= scale (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter, Boolean) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor) | Rotate the image the specified angle cropping the result to the original size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, PointF, Inter, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Save | Save this image to the specific file. (Inherited from ImageTColor, TDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor) | Set every pixel of the image to the specific color (Inherited from ImageTColor, TDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor, ImageGray, Byte) | Set every pixel of the image to the specific color, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | SmoothBilateral | Applying bilateral 3x3 filtering (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32) | Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32, Boolean) | Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothMedian | Finding median of sizexsize neighborhood (Inherited from ImageTColor, TDepth.)
Public method | Sobel | Calculates the image derivative by convolving the image with the appropriate kernel The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative. (Inherited from ImageTColor, TDepth.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth) | Elementwise subtract another image from the current image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth, ImageGray, Byte) | Elementwise subtract another image from the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor) | result = val - this (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor, ImageGray, Byte) | result = val - this, using a mask (Inherited from ImageTColor, TDepth.)
Public method | ThresholdAdaptive | Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1. (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinary | Threshold the image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinaryInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZero | Threshold the image such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZeroInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdTrunc | Threshold the image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ToJpegData | Get the jpeg representation of the image (Inherited from ImageTColor, TDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WarpAffine(Mat, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpAffine(Mat, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Public method | Xor(ImageTColor, TDepth) | Perform an elementwise XOR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Xor(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise XOR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).Copy Method

MapTColor, TDepthCopy Method

Overload List
 | Name | Description
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(RectangleF) | Get a copy of the map in the specific area
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination (Inherited from ImageTColor, TDepth.)
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).Copy Method (RectangleF)

MapTColor, TDepthCopy Method (RectangleF)

http://www.emgu.com
Get a copy of the map in the specific area

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Map<TColor, TDepth> Copy(
    RectangleF area
)
Public Function Copy (
    area As RectangleF
) As Map(Of TColor, TDepth)
public:
Map<TColor, TDepth>^ Copy(
    RectangleF^ area
)
member Copy :
        area : RectangleF -> Map<'TColor, 'TDepth>

Parameters

area
Type: System.DrawingRectangleF
the area of the map to be retrieve

Return Value

Type: Map TColor, TDepth
The area of the map
See Also

Reference

MapTColor, TDepth Class
Copy Overload
Emgu.CV Namespace


Map(TColor, TDepth).Draw Method

MapTColor, TDepthDraw Method

Overload List
 | Name | Description
Public method | Draw(RectangleF, TColor, Int32) | Draw a rectangle in the map
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon of the specific color and thickness (Overrides ImageTColor, TDepthDraw(IConvexPolygonF, TColor, Int32).)
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness (Overrides ImageTColor, TDepthDraw(CircleF, TColor, Int32, LineType, Int32).)
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment in the map (Overrides ImageTColor, TDepthDraw(LineSegment2DF, TColor, Int32, LineType, Int32).)
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image (Overrides ImageTColor, TDepthDraw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean).)
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).Draw Method (RectangleF, TColor, Int32)

MapTColor, TDepthDraw Method (RectangleF, TColor, Int32)

http://www.emgu.com
Draw a rectangle in the map

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    RectangleF rect,
    TColor color,
    int thickness
)
Public Sub Draw (
    rect As RectangleF,
    color As TColor,
    thickness As Integer
)
public:
void Draw(
    RectangleF^ rect,
    TColor color,
    int thickness
)
member Draw :
        rect : RectangleF *
        color : 'TColor *
        thickness : int -> unit

Parameters

rect
Type: System.DrawingRectangleF
The rectangle to draw
color
Type: TColor
The color for the rectangle
thickness
Type: SystemInt32
The thickness of the rectangle, any value less than or equal to 0 will result in a filled rectangle
See Also

Reference

MapTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Map(TColor, TDepth).Draw Method (IConvexPolygonF, TColor, Int32)

MapTColor, TDepthDraw Method (IConvexPolygonF, TColor, Int32)

http://www.emgu.com
Draw a convex polygon of the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void Draw(
    IConvexPolygonF polygon,
    TColor color,
    int thickness
)
Public Overrides Sub Draw (
    polygon As IConvexPolygonF,
    color As TColor,
    thickness As Integer
)
public:
virtual void Draw(
    IConvexPolygonF^ polygon,
    TColor color,
    int thickness
) override
abstract Draw :
        polygon : IConvexPolygonF *
        color : 'TColor *
        thickness : int -> unit
override Draw :
        polygon : IConvexPolygonF *
        color : 'TColor *
        thickness : int -> unit

Parameters

polygon
Type: Emgu.CVIConvexPolygonF
The convex polygon to be drawn
color
Type: TColor
The color of the convex polygon
thickness
Type: SystemInt32
If thickness is less than 1, the triangle is filled up
See Also

Reference

MapTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Map(TColor, TDepth).Draw Method (CircleF, TColor, Int32, LineType, Int32)

MapTColor, TDepthDraw Method (CircleF, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw a Circle of the specific color and thickness

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void Draw(
    CircleF circle,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    int shift = 0
)
Public Overrides Sub Draw (
    circle As CircleF,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
virtual void Draw(
    CircleF^ circle,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    int shift = 0
) override
abstract Draw :
        circle : CircleF *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit
override Draw :
        circle : CircleF *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

circle
Type: Emgu.CV.StructureCircleF
The circle to be drawn
color
Type: TColor
The color of the circle
thickness (Optional)
Type: SystemInt32
If thickness is less than 1, the circle is filled up
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

MapTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Map(TColor, TDepth).Draw Method (LineSegment2DF, TColor, Int32, LineType, Int32)

MapTColor, TDepthDraw Method (LineSegment2DF, TColor, Int32, LineType, Int32)

http://www.emgu.com
Draw a line segment in the map

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void Draw(
    LineSegment2DF line,
    TColor color,
    int thickness,
    LineType lineType = 8,
    int shift = 0
)
Public Overrides Sub Draw (
    line As LineSegment2DF,
    color As TColor,
    thickness As Integer,
    Optional lineType As LineType = 8,
    Optional shift As Integer = 0
)
public:
virtual void Draw(
    LineSegment2DF^ line,
    TColor color,
    int thickness,
    LineType^ lineType = 8,
    int shift = 0
) override
abstract Draw :
        line : LineSegment2DF *
        color : 'TColor *
        thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit
override Draw :
        line : LineSegment2DF *
        color : 'TColor *
        thickness : int *
        ?lineType : LineType *
        ?shift : int
(* Defaults:
        let _lineType = defaultArg lineType 8
        let _shift = defaultArg shift 0
*)
-> unit

Parameters

line
Type: Emgu.CV.StructureLineSegment2DF
The line to be draw
color
Type: TColor
The color for the line
thickness
Type: SystemInt32
The thickness of the line
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
shift (Optional)
Type: SystemInt32
Number of fractional bits in the center coordinates and radius value
See Also

Reference

MapTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Map(TColor, TDepth).Draw Method (String, Point, FontFace, Double, TColor, Int32, LineType, Boolean)

MapTColor, TDepthDraw Method (String, Point, FontFace, Double, TColor, Int32, LineType, Boolean)

http://www.emgu.com
Draw the text using the specific font on the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void Draw(
    string message,
    Point bottomLeft,
    FontFace fontFace,
    double fontScale,
    TColor color,
    int thickness = 1,
    LineType lineType = 8,
    bool bottomLeftOrigin = false
)
Public Overrides Sub Draw (
    message As String,
    bottomLeft As Point,
    fontFace As FontFace,
    fontScale As Double,
    color As TColor,
    Optional thickness As Integer = 1,
    Optional lineType As LineType = 8,
    Optional bottomLeftOrigin As Boolean = false
)
public:
virtual void Draw(
    String^ message,
    Point^ bottomLeft,
    FontFace^ fontFace,
    double fontScale,
    TColor color,
    int thickness = 1,
    LineType^ lineType = 8,
    bool bottomLeftOrigin = false
) override
abstract Draw :
        message : string *
        bottomLeft : Point *
        fontFace : FontFace *
        fontScale : float *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?bottomLeftOrigin : bool
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _bottomLeftOrigin = defaultArg bottomLeftOrigin false
*)
-> unit
override Draw :
        message : string *
        bottomLeft : Point *
        fontFace : FontFace *
        fontScale : float *
        color : 'TColor *
        ?thickness : int *
        ?lineType : LineType *
        ?bottomLeftOrigin : bool
(* Defaults:
        let _thickness = defaultArg thickness 1
        let _lineType = defaultArg lineType 8
        let _bottomLeftOrigin = defaultArg bottomLeftOrigin false
*)
-> unit

Parameters

message
Type: SystemString
The text message to be draw
bottomLeft
Type: System.DrawingPoint
The location of the bottom left corner of the font
fontFace
Type: Emgu.CV.CvEnumFontFace
Font type.
fontScale
Type: SystemDouble
Font scale factor that is multiplied by the font-specific base size.
color
Type: TColor
The color of the text
thickness (Optional)
Type: SystemInt32
Thickness of the lines used to draw a text.
lineType (Optional)
Type: Emgu.CV.CvEnumLineType
Line type
bottomLeftOrigin (Optional)
Type: SystemBoolean
When true, the image data origin is at the bottom-left corner. Otherwise, it is at the top-left corner.
See Also

Reference

MapTColor, TDepth Class
Draw Overload
Emgu.CV Namespace


Map(TColor, TDepth).DrawPolyline Method

MapTColor, TDepthDrawPolyline Method

Overload List
 | Name | Description
Public method | DrawPolyline(PointF, Boolean, TColor, Int32) | Draw the polyline defined by the array of 2D points
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points (Inherited from ImageTColor, TDepth.)
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).DrawPolyline Method (PointF[], Boolean, TColor, Int32)

MapTColor, TDepthDrawPolyline Method (PointF, Boolean, TColor, Int32)

http://www.emgu.com
Draw the polyline defined by the array of 2D points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DrawPolyline(
    PointF[] pts,
    bool isClosed,
    TColor color,
    int thickness
)
Public Sub DrawPolyline (
    pts As PointF(),
    isClosed As Boolean,
    color As TColor,
    thickness As Integer
)
public:
void DrawPolyline(
    array<PointF^>^ pts,
    bool isClosed,
    TColor color,
    int thickness
)
member DrawPolyline :
        pts : PointF[] *
        isClosed : bool *
        color : 'TColor *
        thickness : int -> unit

Parameters

pts
Type: System.DrawingPointF
the points that defines the poly line
isClosed
Type: SystemBoolean
if true, the last line segment is defined by the last point of the array and the first point of the array
color
Type: TColor
the color used for drawing
thickness
Type: SystemInt32
the thinkness of the line
See Also

Reference

MapTColor, TDepth Class
DrawPolyline Overload
Emgu.CV Namespace


Map(TColor, TDepth).GetObjectData Method

MapTColor, TDepthGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).ImagePointToMapPoint Method

MapTColor, TDepthImagePointToMapPoint Method

Map an image point to a Map point

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF ImagePointToMapPoint(
    Point pt
)
Public Function ImagePointToMapPoint (
    pt As Point
) As PointF
public:
PointF^ ImagePointToMapPoint(
    Point^ pt
)
member ImagePointToMapPoint :
        pt : Point -> PointF

Parameters

pt
Type: System.DrawingPoint
The point on image

Return Value

Type: PointF
The point on map
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).MapPointToImagePoint Method

MapTColor, TDepthMapPointToImagePoint Method

Overload List
 | Name | Description
Public method | MapPointToImagePoint(PointF) | Map a point to a position in the internal image
Public method | MapPointToImagePoint(MCvPoint2D64f) | Map a point to a position in the internal image
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Map(TColor, TDepth).MapPointToImagePoint Method (PointF)

MapTColor, TDepthMapPointToImagePoint Method (PointF)

http://www.emgu.com
Map a point to a position in the internal image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point MapPointToImagePoint(
    PointF pt
)
Public Function MapPointToImagePoint (
    pt As PointF
) As Point
public:
Point^ MapPointToImagePoint(
    PointF^ pt
)
member MapPointToImagePoint :
        pt : PointF -> Point

Parameters

pt
Type: System.DrawingPointF
The point on the map

Return Value

Type: Point
The point on the image
See Also

Reference

MapTColor, TDepth Class
MapPointToImagePoint Overload
Emgu.CV Namespace


Map(TColor, TDepth).MapPointToImagePoint Method (MCvPoint2D64f)

MapTColor, TDepthMapPointToImagePoint Method (MCvPoint2D64f)

http://www.emgu.com
Map a point to a position in the internal image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point MapPointToImagePoint(
    MCvPoint2D64f pt
)
Public Function MapPointToImagePoint (
    pt As MCvPoint2D64f
) As Point
public:
Point^ MapPointToImagePoint(
    MCvPoint2D64f^ pt
)
member MapPointToImagePoint :
        pt : MCvPoint2D64f -> Point

Parameters

pt
Type: Emgu.CV.StructureMCvPoint2D64f
The point on the map

Return Value

Type: Point
The point on the image
See Also

Reference

MapTColor, TDepth Class
MapPointToImagePoint Overload
Emgu.CV Namespace


Map(TColor, TDepth) Fields

MapTColor, TDepth Fields

The MapTColor, TDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MapTColor, TDepth Class
Emgu.CV Namespace


Mat Class

The equivalent of cv::Mat
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMatDataAllocator
Emgu.CVMat
Emgu.CVDenseHistogram
Emgu.CVRotationMatrix2D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Mat : MatDataAllocator, IEquatable<Mat>,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class Mat
    Inherits MatDataAllocator
    Implements IEquatable(Of Mat), IInputOutputArray,
    IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays,
    ISerializable
[SerializableAttribute]
public ref class Mat : public MatDataAllocator,
    IEquatable<Mat^>, IInputOutputArray, IInputArray, IDisposable,
    IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type Mat =
    class
        inherit MatDataAllocator
        interface IEquatable<Mat>
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The Mat type exposes the following members.

Constructors
 | Name | Description
Public method | Mat | Create an empty cv::Mat
Public method | Mat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | Mat(String, ImreadModes) | Load the Mat from file
Public method | Mat(Mat, Rectangle) | Create a mat header for the specific ROI
Public method | Mat(Size, DepthType, Int32) | Create a mat of the specific type.
Public method | Mat(Mat, Range, Range) | Create a mat header for the specific ROI
Public method | Mat(Int32, Int32, DepthType, Int32) | Create a mat of the specific type.
Public method | Mat(Int32, DepthType, IntPtr, IntPtr) | Create multi-dimension mat using existing data.
Public method | Mat(Size, DepthType, Int32, IntPtr, Int32) | Create a Mat header from existing data
Public method | Mat(Int32, Int32, DepthType, Int32, IntPtr, Int32) | Create a Mat header from existing data
Top
Properties
 | Name | Description
Public property | Cols | The number of columns
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | DataPointer | Pointer to the beginning of the raw data
Public property | Depth | Depth type
Public property | Dims | The matrix dimensionality
Public property | ElementSize | The size of the elements in this matrix
Public property | Height | Get the height of the mat.
Public property | IsContinuous | True if the data is continues
Public property | IsEmpty | True if the Mat is empty
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix
Public property | NumberOfChannels | Number of channels
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rows | The number of rows
Public property | Size | The size of this matrix
Public property | SizeOfDimension | Get an array of the size of the dimensions. e.g. if the mat is 9x10x11, the array of {9, 10, 11} will be returned.
Public property | Step | Step
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image)
Public property | Width | Get the width of the mat
Top
Methods
 | Name | Description
Public method | Clone | Make a clone of the current Mat
Public method | Col | Creates a matrix header for the specified matrix column.
Public method | ConvertTo | Converts an array to another data type with optional scaling.
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this cv::Mat to an output array
Public method | CopyToT(T) | Copy data from this Mat to the managed array
Public method | Create | Allocates new array data if needed.
Public method | Cross | Computes a cross-product of two 3-element vectors.
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object
Public method | Diag | Extracts a diagonal from a matrix. The method makes a new header for the specified matrix diagonal. The new matrix is represented as a single-column matrix. Similarly to Mat::row and Mat::col, this is an O(1) operation.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Overrides MatDataAllocatorDisposeObject.)
Public method | Dot | Computes a dot-product of two vectors.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Mat) | Compares two Mats and check if they are equal
 | Eye | Returns an identity matrix of the specified size and type.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array
Public method | GetDataPointer | Get a pointer to the raw data given the specific index
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray
Public method | GetInputOutputArray | Pointer to the InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Pointer to the OutputArray
Public method | GetRawData | Gets the binary data from the specific indices.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Convert this Mat to UMat
Public method | GetValueRange | Get the minimum and maximum value across all channels of the mat
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image
 | Ones | Returns an array of all 1's of the specified size and type.
Public method | PopBack | The method removes one or more rows from the bottom of the matrix
Public method | PushBack | Adds elements to the bottom of the matrix
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data.
Public method | Row | Creates a matrix header for the specified matrix row.
Public method | Save | Save this image to the specific file.
Public method | SetTo(IInputArray, IInputArray) | Set the mat to the specific value
Public method | SetTo(MCvScalar, IInputArray) | Set the mat to the specific value
Public method | SetToT(T) | Copy data from managed array to this Mat
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image
Public method | T | Transposes a matrix.
Public method | ToImageTColor, TDepth | Convert this Mat to Image
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Zeros | Returns a zero array of the specified size and type.
Top
Operators
Name | Description
Addition(Double, Mat) | Element wise add mat1 with value
Addition(Mat, Mat) | Element wise add mat1 with mat2
Addition(Mat, MCvScalar) | Element wise add mat with value
Addition(Mat, Double) | Element wise add mat with value
Addition(MCvScalar, Mat) | Element wise add mat with value
BitwiseAnd(Double, Mat) | Perform an element wise AND operation using a mat and a color
BitwiseAnd(Mat, Mat) | Perform an element wise AND operation on the two mats
BitwiseAnd(Mat, MCvScalar) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(Mat, Double) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(MCvScalar, Mat) | Perform an element wise AND operation using a mat and a scalar
BitwiseOr(Double, Mat) | Perform an binary OR operation with some color
BitwiseOr(Mat, Mat) | Perform an element wise OR operation with another mat and return the result
BitwiseOr(Mat, MCvScalar) | Perform an binary OR operation with some scalar
BitwiseOr(Mat, Double) | Perform an binary OR operation with some value
BitwiseOr(MCvScalar, Mat) | Perform an binary OR operation with some scalar
Division(Double, Mat) | scale / mat
Division(Mat, Double) | mat / scale
Multiply(Double, Mat) | scale*mat
Multiply(Mat, Double) | mat * scale
OnesComplement | Compute the complement Mat
Subtraction(Double, Mat) | value - mat
Subtraction(Mat, Mat) | Element wise subtract another mat from the current mat
Subtraction(Mat, MCvScalar) | Element wise subtract another mat from the current mat
Subtraction(Mat, Double) | Element wise subtract value from the current mat
Subtraction(MCvScalar, Mat) | Element wise subtract value from the current mat
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


Mat Constructor

Overload List
 | Name | Description
Public method | Mat | Create an empty cv::Mat
Public method | Mat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | Mat(String, ImreadModes) | Load the Mat from file
Public method | Mat(Mat, Rectangle) | Create a mat header for the specific ROI
Public method | Mat(Size, DepthType, Int32) | Create a mat of the specific type.
Public method | Mat(Mat, Range, Range) | Create a mat header for the specific ROI
Public method | Mat(Int32, Int32, DepthType, Int32) | Create a mat of the specific type.
Public method | Mat(Int32, DepthType, IntPtr, IntPtr) | Create multi-dimension mat using existing data.
Public method | Mat(Size, DepthType, Int32, IntPtr, Int32) | Create a Mat header from existing data
Public method | Mat(Int32, Int32, DepthType, Int32, IntPtr, Int32) | Create a Mat header from existing data
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat Constructor

Create an empty cv::Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat()
Public Sub New
public:
Mat()
new : unit -> Mat
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
Mat(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> Mat

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (String, ImreadModes)

Load the Mat from file

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    string fileName,
    ImreadModes loadType = 1
)
Public Sub New (
    fileName As String,
    Optional loadType As ImreadModes = 1
)
public:
Mat(
    String^ fileName,
    ImreadModes^ loadType = 1
)
new :
        fileName : string *
        ?loadType : ImreadModes
(* Defaults:
        let _loadType = defaultArg loadType 1
*)
-> Mat

Parameters

fileName
Type: SystemString
The name of the file
loadType (Optional)
Type: Emgu.CV.CvEnumImreadModes
File loading method
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (Mat, Rectangle)

Create a mat header for the specific ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    Mat mat,
    Rectangle roi
)
Public Sub New (
    mat As Mat,
    roi As Rectangle
)
public:
Mat(
    Mat^ mat,
    Rectangle^ roi
)
new :
        mat : Mat *
        roi : Rectangle -> Mat

Parameters

mat
Type: Emgu.CVMat
The mat where the new Mat header will share data from
roi
Type: System.DrawingRectangle
The region of interest
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (Size, DepthType, Int32)

Create a mat of the specific type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    Size size,
    DepthType type,
    int channels
)
Public Sub New (
    size As Size,
    type As DepthType,
    channels As Integer
)
public:
Mat(
    Size^ size,
    DepthType^ type,
    int channels
)
new :
        size : Size *
        type : DepthType *
        channels : int -> Mat

Parameters

size
Type: System.DrawingSize
Size of the Mat
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (Mat, Range, Range)

Create a mat header for the specific ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    Mat mat,
    Range rowRange,
    Range colRange
)
Public Sub New (
    mat As Mat,
    rowRange As Range,
    colRange As Range
)
public:
Mat(
    Mat^ mat,
    Range^ rowRange,
    Range^ colRange
)
new :
        mat : Mat *
        rowRange : Range *
        colRange : Range -> Mat

Parameters

mat
Type: Emgu.CVMat
The mat where the new Mat header will share data from
rowRange
Type: Emgu.CV.StructureRange
The region of interest
colRange
Type: Emgu.CV.StructureRange
The region of interest
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (Int32, Int32, DepthType, Int32)

Create a mat of the specific type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    int rows,
    int cols,
    DepthType type,
    int channels
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer
)
public:
Mat(
    int rows,
    int cols,
    DepthType^ type,
    int channels
)
new :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int -> Mat

Parameters

rows
Type: SystemInt32
Number of rows in a 2D array.
cols
Type: SystemInt32
Number of columns in a 2D array.
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (Int32[], DepthType, IntPtr, IntPtr[])

Mat Constructor (Int32, DepthType, IntPtr, IntPtr)

http://www.emgu.com
Create multi-dimension mat using existing data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    int[] sizes,
    DepthType type,
    IntPtr data,
    IntPtr[] steps = null
)
Public Sub New (
    sizes As Integer(),
    type As DepthType,
    data As IntPtr,
    Optional steps As IntPtr() = Nothing
)
public:
Mat(
    array<int>^ sizes,
    DepthType^ type,
    IntPtr data,
    array<IntPtr>^ steps = nullptr
)
new :
        sizes : int[] *
        type : DepthType *
        data : IntPtr *
        ?steps : IntPtr[]
(* Defaults:
        let _steps = defaultArg steps null
*)
-> Mat

Parameters

sizes
Type: SystemInt32
The sizes of each dimension
type
Type: Emgu.CV.CvEnumDepthType
The type of data
data
Type: SystemIntPtr
The pointer to the unmanaged data
steps (Optional)
Type: SystemIntPtr
The steps
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (Size, DepthType, Int32, IntPtr, Int32)

Create a Mat header from existing data

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    Size size,
    DepthType type,
    int channels,
    IntPtr data,
    int step
)
Public Sub New (
    size As Size,
    type As DepthType,
    channels As Integer,
    data As IntPtr,
    step As Integer
)
public:
Mat(
    Size^ size,
    DepthType^ type,
    int channels,
    IntPtr data,
    int step
)
new :
        size : Size *
        type : DepthType *
        channels : int *
        data : IntPtr *
        step : int -> Mat

Parameters

size
Type: System.DrawingSize
Size of the Mat
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels
data
Type: SystemIntPtr
Pointer to the user data. Matrix constructors that take data and step parameters do not allocate matrix data. Instead, they just initialize the matrix header that points to the specified data, which means that no data is copied. This operation is very efficient and can be used to process external data using OpenCV functions. The external data is not automatically deallocated, so you should take care of it.
step
Type: SystemInt32
Number of bytes each matrix row occupies. The value should include the padding bytes at the end of each row, if any.
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Constructor (Int32, Int32, DepthType, Int32, IntPtr, Int32)

Create a Mat header from existing data

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat(
    int rows,
    int cols,
    DepthType type,
    int channels,
    IntPtr data,
    int step
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer,
    data As IntPtr,
    step As Integer
)
public:
Mat(
    int rows,
    int cols,
    DepthType^ type,
    int channels,
    IntPtr data,
    int step
)
new :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int *
        data : IntPtr *
        step : int -> Mat

Parameters

rows
Type: SystemInt32
Number of rows in a 2D array.
cols
Type: SystemInt32
Number of columns in a 2D array.
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels
data
Type: SystemIntPtr
Pointer to the user data. Matrix constructors that take data and step parameters do not allocate matrix data. Instead, they just initialize the matrix header that points to the specified data, which means that no data is copied. This operation is very efficient and can be used to process external data using OpenCV functions. The external data is not automatically deallocated, so you should take care of it.
step
Type: SystemInt32
Number of bytes each matrix row occupies. The value should include the padding bytes at the end of each row, if any.
See Also

Reference

Mat Class
Mat Overload
Emgu.CV Namespace


Mat Properties

The Mat type exposes the following members.

Properties
 | Name | Description
Public property | Cols | The number of columns
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | DataPointer | Pointer to the beginning of the raw data
Public property | Depth | Depth type
Public property | Dims | The matrix dimensionality
Public property | ElementSize | The size of the elements in this matrix
Public property | Height | Get the height of the mat.
Public property | IsContinuous | True if the data is continues
Public property | IsEmpty | True if the Mat is empty
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix
Public property | NumberOfChannels | Number of channels
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rows | The number of rows
Public property | Size | The size of this matrix
Public property | SizeOfDimension | Get an array of the size of the dimensions. e.g. if the mat is 9x10x11, the array of {9, 10, 11} will be returned.
Public property | Step | Step
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image)
Public property | Width | Get the width of the mat
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Cols Property

MatCols Property

The number of columns

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Cols { get; }
Public ReadOnly Property Cols As Integer
    Get
public:
property int Cols {
    int get ();
}
member Cols : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.DataPointer Property

MatDataPointer Property

Pointer to the beginning of the raw data

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DataPointer { get; }
Public ReadOnly Property DataPointer As IntPtr
    Get
public:
property IntPtr DataPointer {
    IntPtr get ();
}
member DataPointer : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Depth Property

MatDepth Property

Depth type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DepthType Depth { get; }
Public ReadOnly Property Depth As DepthType
    Get
public:
property DepthType^ Depth {
    DepthType^ get ();
}
member Depth : DepthType with get

Property Value

Type: DepthType
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Dims Property

MatDims Property

The matrix dimensionality

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dims { get; }
Public ReadOnly Property Dims As Integer
    Get
public:
property int Dims {
    int get ();
}
member Dims : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.ElementSize Property

MatElementSize Property

The size of the elements in this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ElementSize { get; }
Public ReadOnly Property ElementSize As Integer
    Get
public:
property int ElementSize {
    int get ();
}
member ElementSize : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Height Property

MatHeight Property

Get the height of the mat.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
property int Height {
    int get ();
}
member Height : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.IsContinuous Property

MatIsContinuous Property

True if the data is continues

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsContinuous { get; }
Public ReadOnly Property IsContinuous As Boolean
    Get
public:
property bool IsContinuous {
    bool get ();
}
member IsContinuous : bool with get

Property Value

Type: Boolean
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.IsEmpty Property

MatIsEmpty Property

True if the Mat is empty

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.IsSubmatrix Property

MatIsSubmatrix Property

True if the matrix is a submatrix of another matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSubmatrix { get; }
Public ReadOnly Property IsSubmatrix As Boolean
    Get
public:
property bool IsSubmatrix {
    bool get ();
}
member IsSubmatrix : bool with get

Property Value

Type: Boolean
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.NumberOfChannels Property

MatNumberOfChannels Property

Number of channels

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfChannels { get; }
Public ReadOnly Property NumberOfChannels As Integer
    Get
public:
property int NumberOfChannels {
    int get ();
}
member NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Rows Property

MatRows Property

The number of rows

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get
public:
property int Rows {
    int get ();
}
member Rows : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Size Property

MatSize Property

The size of this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get
public:
property Size^ Size {
    Size^ get ();
}
member Size : Size with get

Property Value

Type: Size
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.SizeOfDimension Property

MatSizeOfDimension Property

Get an array of the size of the dimensions. e.g. if the mat is 9x10x11, the array of {9, 10, 11} will be returned.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] SizeOfDimension { get; }
Public ReadOnly Property SizeOfDimension As Integer()
    Get
public:
property array<int>^ SizeOfDimension {
    array<int>^ get ();
}
member SizeOfDimension : int[] with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Step Property

MatStep Property

Step

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Step { get; }
Public ReadOnly Property Step As Integer
    Get
public:
property int Step {
    int get ();
}
member Step : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Total Property

MatTotal Property

The method returns the number of array elements (a number of pixels if the array represents an image)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Total { get; }
Public ReadOnly Property Total As IntPtr
    Get
public:
property IntPtr Total {
    IntPtr get ();
}
member Total : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Width Property

MatWidth Property

Get the width of the mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}
member Width : int with get

Property Value

Type: Int32
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat Methods

The Mat type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Make a clone of the current Mat
Public method | Col | Creates a matrix header for the specified matrix column.
Public method | ConvertTo | Converts an array to another data type with optional scaling.
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this cv::Mat to an output array
Public method | CopyToT(T) | Copy data from this Mat to the managed array
Public method | Create | Allocates new array data if needed.
Public method | Cross | Computes a cross-product of two 3-element vectors.
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object
Public method | Diag | Extracts a diagonal from a matrix. The method makes a new header for the specified matrix diagonal. The new matrix is represented as a single-column matrix. Similarly to Mat::row and Mat::col, this is an O(1) operation.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Overrides MatDataAllocatorDisposeObject.)
Public method | Dot | Computes a dot-product of two vectors.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Mat) | Compares two Mats and check if they are equal
 | Eye | Returns an identity matrix of the specified size and type.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array
Public method | GetDataPointer | Get a pointer to the raw data given the specific index
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray
Public method | GetInputOutputArray | Pointer to the InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Pointer to the OutputArray
Public method | GetRawData | Gets the binary data from the specific indices.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Convert this Mat to UMat
Public method | GetValueRange | Get the minimum and maximum value across all channels of the mat
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image
 | Ones | Returns an array of all 1's of the specified size and type.
Public method | PopBack | The method removes one or more rows from the bottom of the matrix
Public method | PushBack | Adds elements to the bottom of the matrix
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data.
Public method | Row | Creates a matrix header for the specified matrix row.
Public method | Save | Save this image to the specific file.
Public method | SetTo(IInputArray, IInputArray) | Set the mat to the specific value
Public method | SetTo(MCvScalar, IInputArray) | Set the mat to the specific value
Public method | SetToT(T) | Copy data from managed array to this Mat
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image
Public method | T | Transposes a matrix.
Public method | ToImageTColor, TDepth | Convert this Mat to Image
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Zeros | Returns a zero array of the specified size and type.
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Clone Method

MatClone Method

Make a clone of the current Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Clone()
Public Function Clone As Mat
public:
Mat^ Clone()
member Clone : unit -> Mat

Return Value

Type: Mat
A clone of the current Mat
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Col Method

MatCol Method

Creates a matrix header for the specified matrix column.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Col(
    int x
)
Public Function Col (
    x As Integer
) As Mat
public:
Mat^ Col(
    int x
)
member Col :
        x : int -> Mat

Parameters

x
Type: SystemInt32
A 0-based column index.

Return Value

Type: Mat
A matrix header for the specified matrix column.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.ConvertTo Method

MatConvertTo Method

Converts an array to another data type with optional scaling.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ConvertTo(
    IOutputArray m,
    DepthType rtype,
    double alpha = 1,
    double beta = 0
)
Public Sub ConvertTo (
    m As IOutputArray,
    rtype As DepthType,
    Optional alpha As Double = 1,
    Optional beta As Double = 0
)
public:
void ConvertTo(
    IOutputArray^ m,
    DepthType^ rtype,
    double alpha = 1,
    double beta = 0
)
member ConvertTo :
        m : IOutputArray *
        rtype : DepthType *
        ?alpha : float *
        ?beta : float
(* Defaults:
        let _alpha = defaultArg alpha 1
        let _beta = defaultArg beta 0
*)
-> unit

Parameters

m
Type: Emgu.CVIOutputArray
Output matrix; if it does not have a proper size or type before the operation, it is reallocated.
rtype
Type: Emgu.CV.CvEnumDepthType
Desired output matrix type or, rather, the depth since the number of channels are the same as the input has; if rtype is negative, the output matrix will have the same type as the input.
alpha (Optional)
Type: SystemDouble
Optional scale factor.
beta (Optional)
Type: SystemDouble
Optional delta added to the scaled values.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.CopyTo Method

MatCopyTo Method

Overload List
 | Name | Description
Public method | CopyToT(T) | Copy data from this Mat to the managed array
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this cv::Mat to an output array
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.CopyTo(T) Method (T[])

MatCopyToT Method (T)

http://www.emgu.com
Copy data from this Mat to the managed array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo<T>(
    T[] data
)

Public Sub CopyTo(Of T) (
    data As T()
)
public:
generic<typename T>
void CopyTo(
    array<T>^ data
)
member CopyTo :
        data : 'T[] -> unit

Parameters

data
Type: T
The managed array where data will be copied to.

Type Parameters

T
The type of managed data array
See Also

Reference

Mat Class
CopyTo Overload
Emgu.CV Namespace


Mat.CopyTo Method (IOutputArray, IInputArray)

MatCopyTo Method (IOutputArray, IInputArray)

http://www.emgu.com
Copy the data in this cv::Mat to an output array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    IOutputArray m,
    IInputArray mask = null
)
Public Sub CopyTo (
    m As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
void CopyTo(
    IOutputArray^ m,
    IInputArray^ mask = nullptr
)
member CopyTo :
        m : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

m
Type: Emgu.CVIOutputArray
The output array to copy to
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask. Its non-zero elements indicate which matrix elements need to be copied.
See Also

Reference

Mat Class
CopyTo Overload
Emgu.CV Namespace


Mat.Create Method

MatCreate Method

Allocates new array data if needed.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Create(
    int rows,
    int cols,
    DepthType type,
    int channels
)
Public Sub Create (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer
)
public:
void Create(
    int rows,
    int cols,
    DepthType^ type,
    int channels
)
member Create :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int -> unit

Parameters

rows
Type: SystemInt32
New number of rows.
cols
Type: SystemInt32
New number of columns.
type
Type: Emgu.CV.CvEnumDepthType
New matrix element depth type.
channels
Type: SystemInt32
New matrix number of channels
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Cross Method

MatCross Method

Computes a cross-product of two 3-element vectors.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Cross(
    IInputArray m
)
Public Function Cross (
    m As IInputArray
) As Mat
public:
Mat^ Cross(
    IInputArray^ m
)
member Cross :
        m : IInputArray -> Mat

Parameters

m
Type: Emgu.CVIInputArray
Another cross-product operand.

Return Value

Type: Mat
Cross-product of two 3-element vectors.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.DeserializeObjectData Method

MatDeserializeObjectData Method

A function used for runtime deserailization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void DeserializeObjectData(
    SerializationInfo info,
    StreamingContext context
)
Protected Overridable Sub DeserializeObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
virtual void DeserializeObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
)
abstract DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Diag Method

MatDiag Method

Extracts a diagonal from a matrix. The method makes a new header for the specified matrix diagonal. The new matrix is represented as a single-column matrix. Similarly to Mat::row and Mat::col, this is an O(1) operation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Diag(
    int d = 0
)
Public Function Diag (
    Optional d As Integer = 0
) As Mat
public:
Mat^ Diag(
    int d = 0
)
member Diag :
        ?d : int
(* Defaults:
        let _d = defaultArg d 0
*)
-> Mat

Parameters

d (Optional)
Type: SystemInt32
Index of the diagonal, with the following values: d=0 is the main diagonal; d < 0 is a diagonal from the lower half. For example, d=-1 means the diagonal is set immediately below the main one; d > 0 is a diagonal from the upper half. For example, d=1 means the diagonal is set immediately above the main one.

Return Value

Type: Mat
A diagonal from a matrix
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.DisposeObject Method

MatDisposeObject Method

Release all the unmanaged memory associated with this object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Dot Method

MatDot Method

Computes a dot-product of two vectors.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Dot(
    IInputArray m
)
Public Function Dot (
    m As IInputArray
) As Double
public:
double Dot(
    IInputArray^ m
)
member Dot :
        m : IInputArray -> float

Parameters

m
Type: Emgu.CVIInputArray
Another dot-product operand

Return Value

Type: Double
The dot-product of two vectors.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Equals Method

MatEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Mat) | Compares two Mats and check if they are equal
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Equals Method (Mat)

MatEquals Method (Mat)

http://www.emgu.com
Compares two Mats and check if they are equal

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Mat other
)
Public Function Equals (
    other As Mat
) As Boolean
public:
virtual bool Equals(
    Mat^ other
) sealed
abstract Equals :
        other : Mat -> bool
override Equals :
        other : Mat -> bool

Parameters

other
Type: Emgu.CVMat
The other mat to compare with

Return Value

Type: Boolean
True if the two Mats are equal

Implements

IEquatableTEquals(T)
See Also

Reference

Mat Class
Equals Overload
Emgu.CV Namespace


Mat.Eye Method

MatEye Method

Returns an identity matrix of the specified size and type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat Eye(
    int rows,
    int cols,
    DepthType type,
    int channels
)
Public Shared Function Eye (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer
) As Mat
public:
static Mat^ Eye(
    int rows,
    int cols,
    DepthType^ type,
    int channels
)
static member Eye :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int -> Mat

Parameters

rows
Type: SystemInt32
Number of rows.
cols
Type: SystemInt32
Number of columns.
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels

Return Value

Type: Mat
An identity matrix of the specified size and type.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetData Method

MatGetData Method

Get a copy of the data values as an array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Array GetData(
    bool jagged = true
)
Public Function GetData (
    Optional jagged As Boolean = true
) As Array
public:
Array^ GetData(
    bool jagged = true
)
member GetData :
        ?jagged : bool
(* Defaults:
        let _jagged = defaultArg jagged true
*)
-> Array

Parameters

jagged (Optional)
Type: SystemBoolean
If true, a jagged array will returned. Otherwise it will return a regular array.

Return Value

Type: Array
a copy of the data values as an array
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetDataPointer Method

MatGetDataPointer Method

Get a pointer to the raw data given the specific index

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetDataPointer(
    params int[] index
)
Public Function GetDataPointer (
    ParamArray index As Integer()
) As IntPtr
public:
IntPtr GetDataPointer(
    ... array<int>^ index
)
member GetDataPointer :
        index : int[] -> IntPtr

Parameters

index
Type: SystemInt32
The index to the Mat data

Return Value

Type: IntPtr
A pointer to the raw data given the specific index
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetInputArray Method

MatGetInputArray Method

Pointer to the InputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetInputOutputArray Method

MatGetInputOutputArray Method

Pointer to the InputOutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetObjectData Method

MatGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetOutputArray Method

MatGetOutputArray Method

Pointer to the OutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetRawData Method

MatGetRawData Method

Gets the binary data from the specific indices.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] GetRawData(
    params int[] indices
)
Public Function GetRawData (
    ParamArray indices As Integer()
) As Byte()
public:
array<unsigned char>^ GetRawData(
    ... array<int>^ indices
)
member GetRawData :
        indices : int[] -> byte[]

Parameters

indices
Type: SystemInt32
The indices.

Return Value

Type: Byte
The raw data in byte
Exceptions
Exception | Condition
NotImplementedException | Indices of length more than 2 is not implemented
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetUMat Method

MatGetUMat Method

Convert this Mat to UMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat GetUMat(
    AccessType access,
    UMatUsage usageFlags = 0
)
Public Function GetUMat (
    access As AccessType,
    Optional usageFlags As UMatUsage = 0
) As UMat
public:
UMat^ GetUMat(
    AccessType^ access,
    UMatUsage^ usageFlags = 0
)
member GetUMat :
        access : AccessType *
        ?usageFlags : UMatUsage
(* Defaults:
        let _usageFlags = defaultArg usageFlags 0
*)
-> UMat

Parameters

access
Type: Emgu.CV.CvEnumAccessType
Access type
usageFlags (Optional)
Type: Emgu.CVUMatUsage
Usage flags

Return Value

Type: UMat
The UMat
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.GetValueRange Method

MatGetValueRange Method

Get the minimum and maximum value across all channels of the mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RangeF GetValueRange()
Public Function GetValueRange As RangeF
public:
RangeF^ GetValueRange()
member GetValueRange : unit -> RangeF

Return Value

Type: RangeF
The range that contains the minimum and maximum values
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.MinMax Method

MatMinMax Method

Returns the min / max location and values for the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MinMax(
    out double[] minValues,
    out double[] maxValues,
    out Point[] minLocations,
    out Point[] maxLocations
)
Public Sub MinMax (
    <OutAttribute> ByRef minValues As Double(),
    <OutAttribute> ByRef maxValues As Double(),
    <OutAttribute> ByRef minLocations As Point(),
    <OutAttribute> ByRef maxLocations As Point()
)
public:
void MinMax(
    [OutAttribute] array<double>^% minValues,
    [OutAttribute] array<double>^% maxValues,
    [OutAttribute] array<Point^>^% minLocations,
    [OutAttribute] array<Point^>^% maxLocations
)
member MinMax :
        minValues : float[] byref *
        maxValues : float[] byref *
        minLocations : Point[] byref *
        maxLocations : Point[] byref -> unit

Parameters

minValues
Type: SystemDouble
The minimum values for each channel
maxValues
Type: SystemDouble
The maximum values for each channel
minLocations
Type: System.DrawingPoint
The minimum locations for each channel
maxLocations
Type: System.DrawingPoint
The maximum locations for each channel
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Ones Method

MatOnes Method

Returns an array of all 1's of the specified size and type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat Ones(
    int rows,
    int cols,
    DepthType type,
    int channels
)
Public Shared Function Ones (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer
) As Mat
public:
static Mat^ Ones(
    int rows,
    int cols,
    DepthType^ type,
    int channels
)
static member Ones :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int -> Mat

Parameters

rows
Type: SystemInt32
Number of rows.
cols
Type: SystemInt32
Number of columns.
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels

Return Value

Type: Mat
An array of all 1's of the specified size and type.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.PopBack Method

MatPopBack Method

The method removes one or more rows from the bottom of the matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void PopBack(
    int value
)
Public Sub PopBack (
    value As Integer
)
public:
void PopBack(
    int value
)
member PopBack :
        value : int -> unit

Parameters

value
Type: SystemInt32
The value
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.PushBack Method

MatPushBack Method

Adds elements to the bottom of the matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void PushBack(
    Mat value
)
Public Sub PushBack (
    value As Mat
)
public:
void PushBack(
    Mat^ value
)
member PushBack :
        value : Mat -> unit

Parameters

value
Type: Emgu.CVMat
The value
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Reshape Method

MatReshape Method

Changes the shape and/or the number of channels of a 2D matrix without copying the data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Reshape(
    int cn,
    int rows = 0
)
Public Function Reshape (
    cn As Integer,
    Optional rows As Integer = 0
) As Mat
public:
Mat^ Reshape(
    int cn,
    int rows = 0
)
member Reshape :
        cn : int *
        ?rows : int
(* Defaults:
        let _rows = defaultArg rows 0
*)
-> Mat

Parameters

cn
Type: SystemInt32
New number of channels. If the parameter is 0, the number of channels remains the same.
rows (Optional)
Type: SystemInt32
New number of rows. If the parameter is 0, the number of rows remains the same.

Return Value

Type: Mat
A new mat header that has different shape
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Row Method

MatRow Method

Creates a matrix header for the specified matrix row.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Row(
    int y
)
Public Function Row (
    y As Integer
) As Mat
public:
Mat^ Row(
    int y
)
member Row :
        y : int -> Mat

Parameters

y
Type: SystemInt32
A 0-based row index.

Return Value

Type: Mat
A matrix header for the specified matrix row.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Save Method

MatSave Method

Save this image to the specific file.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Save(
    string fileName
)
Public Sub Save (
    fileName As String
)
public:
void Save(
    String^ fileName
)
member Save :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The name of the file to be saved to
Remarks
The image format is chosen depending on the filename extension, see cvLoadImage. Only 8-bit single-channel or 3-channel (with 'BGR' channel order) images can be saved using this function. If the format, depth or channel order is different, use cvCvtScale and cvCvtColor to convert it before saving, or use universal cvSave to save the image to XML or YAML format.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.SetTo Method

MatSetTo Method

Overload List
 | Name | Description
Public method | SetToT(T) | Copy data from managed array to this Mat
Public method | SetTo(IInputArray, IInputArray) | Set the mat to the specific value
Public method | SetTo(MCvScalar, IInputArray) | Set the mat to the specific value
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.SetTo(T) Method (T[])

MatSetToT Method (T)

http://www.emgu.com
Copy data from managed array to this Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTo<T>(
    T[] data
)

Public Sub SetTo(Of T) (
    data As T()
)
public:
generic<typename T>
void SetTo(
    array<T>^ data
)
member SetTo :
        data : 'T[] -> unit

Parameters

data
Type: T
The managed array where data will be copied from

Type Parameters

T
The type of managed data array
See Also

Reference

Mat Class
SetTo Overload
Emgu.CV Namespace


Mat.SetTo Method (IInputArray, IInputArray)

MatSetTo Method (IInputArray, IInputArray)

http://www.emgu.com
Set the mat to the specific value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTo(
    IInputArray value,
    IInputArray mask = null
)
Public Sub SetTo (
    value As IInputArray,
    Optional mask As IInputArray = Nothing
)
public:
void SetTo(
    IInputArray^ value,
    IInputArray^ mask = nullptr
)
member SetTo :
        value : IInputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

value
Type: Emgu.CVIInputArray
The value to set to
mask (Optional)
Type: Emgu.CVIInputArray
Optional mask
See Also

Reference

Mat Class
SetTo Overload
Emgu.CV Namespace


Mat.SetTo Method (MCvScalar, IInputArray)

MatSetTo Method (MCvScalar, IInputArray)

http://www.emgu.com
Set the mat to the specific value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTo(
    MCvScalar value,
    IInputArray mask = null
)
Public Sub SetTo (
    value As MCvScalar,
    Optional mask As IInputArray = Nothing
)
public:
void SetTo(
    MCvScalar^ value,
    IInputArray^ mask = nullptr
)
member SetTo :
        value : MCvScalar *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

value
Type: Emgu.CV.StructureMCvScalar
The value to set to
mask (Optional)
Type: Emgu.CVIInputArray
Optional mask
See Also

Reference

Mat Class
SetTo Overload
Emgu.CV Namespace


Mat.Split Method

MatSplit Method

Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat[] Split()
Public Function Split As Mat()
public:
array<Mat^>^ Split()
member Split : unit -> Mat[]

Return Value

Type: Mat
An array of gray scale images where each element in the array represent a single color channel of the original image
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.T Method

MatT Method

Transposes a matrix.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat T()
Public Function T As Mat
public:
Mat^ T()
member T : unit -> Mat

Return Value

Type: Mat
The transposes of the matrix.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.ToImage(TColor, TDepth) Method

MatToImageTColor, TDepth Method

Convert this Mat to Image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ToImage<TColor, TDepth>(
    bool tryShareData = false
)
where TColor : struct, new(), IColor
where TDepth : new()

Public Function ToImage(Of TColor As {Structure, New, IColor}, TDepth As New) (
    Optional tryShareData As Boolean = false
) As Image(Of TColor, TDepth)
public:
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
Image<TColor, TDepth>^ ToImage(
    bool tryShareData = false
)
member ToImage :
        ?tryShareData : bool
(* Defaults:
        let _tryShareData = defaultArg tryShareData false
*)
-> Image<'TColor, 'TDepth>  when 'TColor : struct, new() and IColor when 'TDepth : new()

Parameters

tryShareData (Optional)
Type: SystemBoolean
If true, we will try to see if we can create an Image object that shared the pixel memory with this Mat.

Type Parameters

TColor
The type of Color
TDepth
The type of Depth

Return Value

Type: Image TColor, TDepth
The image
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Zeros Method

MatZeros Method

Returns a zero array of the specified size and type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat Zeros(
    int rows,
    int cols,
    DepthType type,
    int channels
)
Public Shared Function Zeros (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer
) As Mat
public:
static Mat^ Zeros(
    int rows,
    int cols,
    DepthType^ type,
    int channels
)
static member Zeros :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int -> Mat

Parameters

rows
Type: SystemInt32
Number of rows.
cols
Type: SystemInt32
Number of columns.
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels

Return Value

Type: Mat
A zero array of the specified size and type.
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat Operators

The Mat type exposes the following members.

Operators
Name | Description
Addition(Double, Mat) | Element wise add mat1 with value
Addition(Mat, Mat) | Element wise add mat1 with mat2
Addition(Mat, MCvScalar) | Element wise add mat with value
Addition(Mat, Double) | Element wise add mat with value
Addition(MCvScalar, Mat) | Element wise add mat with value
BitwiseAnd(Double, Mat) | Perform an element wise AND operation using a mat and a color
BitwiseAnd(Mat, Mat) | Perform an element wise AND operation on the two mats
BitwiseAnd(Mat, MCvScalar) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(Mat, Double) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(MCvScalar, Mat) | Perform an element wise AND operation using a mat and a scalar
BitwiseOr(Double, Mat) | Perform an binary OR operation with some color
BitwiseOr(Mat, Mat) | Perform an element wise OR operation with another mat and return the result
BitwiseOr(Mat, MCvScalar) | Perform an binary OR operation with some scalar
BitwiseOr(Mat, Double) | Perform an binary OR operation with some value
BitwiseOr(MCvScalar, Mat) | Perform an binary OR operation with some scalar
Division(Double, Mat) | scale / mat
Division(Mat, Double) | mat / scale
Multiply(Double, Mat) | scale*mat
Multiply(Mat, Double) | mat * scale
OnesComplement | Compute the complement Mat
Subtraction(Double, Mat) | value - mat
Subtraction(Mat, Mat) | Element wise subtract another mat from the current mat
Subtraction(Mat, MCvScalar) | Element wise subtract another mat from the current mat
Subtraction(Mat, Double) | Element wise subtract value from the current mat
Subtraction(MCvScalar, Mat) | Element wise subtract value from the current mat
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Addition Operator

MatAddition Operator

Overload List
Name | Description
Addition(Double, Mat) | Element wise add mat1 with value
Addition(Mat, Mat) | Element wise add mat1 with mat2
Addition(Mat, MCvScalar) | Element wise add mat with value
Addition(Mat, Double) | Element wise add mat with value
Addition(MCvScalar, Mat) | Element wise add mat with value
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Addition Operator (Double, Mat)

MatAddition Operator (Double, Mat)

http://www.emgu.com
Element wise add mat1 with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator +(
    double value,
    Mat mat1
)
Public Shared Operator + (
    value As Double,
    mat1 As Mat
) As Mat
public:
static Mat^ operator +(
    double value,
    Mat^ mat1
)
static let inline (+)
        value : float *
        mat1 : Mat  : Mat

Parameters

value
Type: SystemDouble
The value to be added
mat1
Type: Emgu.CVMat
The mat to be added

Return Value

Type: Mat
The mat plus the value
See Also

Reference

Mat Class
Addition Overload
Emgu.CV Namespace


Mat.Addition Operator (Mat, Mat)

MatAddition Operator (Mat, Mat)

http://www.emgu.com
Element wise add mat1 with mat2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator +(
    Mat mat1,
    Mat mat2
)
Public Shared Operator + (
    mat1 As Mat,
    mat2 As Mat
) As Mat
public:
static Mat^ operator +(
    Mat^ mat1,
    Mat^ mat2
)
static let inline (+)
        mat1 : Mat *
        mat2 : Mat  : Mat

Parameters

mat1
Type: Emgu.CVMat
The first image to be added
mat2
Type: Emgu.CVMat
The second image to be added

Return Value

Type: Mat
The sum of the two images
See Also

Reference

Mat Class
Addition Overload
Emgu.CV Namespace


Mat.Addition Operator (Mat, MCvScalar)

MatAddition Operator (Mat, MCvScalar)

http://www.emgu.com
Element wise add mat with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator +(
    Mat mat,
    MCvScalar value
)
Public Shared Operator + (
    mat As Mat,
    value As MCvScalar
) As Mat
public:
static Mat^ operator +(
    Mat^ mat,
    MCvScalar^ value
)
static let inline (+)
        mat : Mat *
        value : MCvScalar  : Mat

Parameters

mat
Type: Emgu.CVMat
The mat to be added
value
Type: Emgu.CV.StructureMCvScalar
The value to be added

Return Value

Type: Mat
The mat plus the value
See Also

Reference

Mat Class
Addition Overload
Emgu.CV Namespace


Mat.Addition Operator (Mat, Double)

MatAddition Operator (Mat, Double)

http://www.emgu.com
Element wise add mat with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator +(
    Mat mat,
    double value
)
Public Shared Operator + (
    mat As Mat,
    value As Double
) As Mat
public:
static Mat^ operator +(
    Mat^ mat,
    double value
)
static let inline (+)
        mat : Mat *
        value : float  : Mat

Parameters

mat
Type: Emgu.CVMat
The mat to be added
value
Type: SystemDouble
The value to be added

Return Value

Type: Mat
The images plus the value
See Also

Reference

Mat Class
Addition Overload
Emgu.CV Namespace


Mat.Addition Operator (MCvScalar, Mat)

MatAddition Operator (MCvScalar, Mat)

http://www.emgu.com
Element wise add mat with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator +(
    MCvScalar value,
    Mat mat
)
Public Shared Operator + (
    value As MCvScalar,
    mat As Mat
) As Mat
public:
static Mat^ operator +(
    MCvScalar^ value,
    Mat^ mat
)
static let inline (+)
        value : MCvScalar *
        mat : Mat  : Mat

Parameters

value
Type: Emgu.CV.StructureMCvScalar
The color to be added
mat
Type: Emgu.CVMat
The mat to be added

Return Value

Type: Mat
The images plus the color
See Also

Reference

Mat Class
Addition Overload
Emgu.CV Namespace


Mat.BitwiseAnd Operator

MatBitwiseAnd Operator

Overload List
Name | Description
BitwiseAnd(Double, Mat) | Perform an element wise AND operation using a mat and a color
BitwiseAnd(Mat, Mat) | Perform an element wise AND operation on the two mats
BitwiseAnd(Mat, MCvScalar) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(Mat, Double) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(MCvScalar, Mat) | Perform an element wise AND operation using a mat and a scalar
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.BitwiseAnd Operator (Double, Mat)

MatBitwiseAnd Operator (Double, Mat)

http://www.emgu.com
Perform an element wise AND operation using a mat and a color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator &(
    double val,
    Mat mat1
)
Public Shared Operator And (
    val As Double,
    mat1 As Mat
) As Mat
public:
static Mat^ operator &(
    double val,
    Mat^ mat1
)
static let inline (&&&)
        val : float *
        mat1 : Mat  : Mat

Parameters

val
Type: SystemDouble
The value to AND
mat1
Type: Emgu.CVMat
The first mat to AND

Return Value

Type: Mat
The result of the AND operation
See Also

Reference

Mat Class
BitwiseAnd Overload
Emgu.CV Namespace


Mat.BitwiseAnd Operator (Mat, Mat)

MatBitwiseAnd Operator (Mat, Mat)

http://www.emgu.com
Perform an element wise AND operation on the two mats

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator &(
    Mat mat1,
    Mat mat2
)
Public Shared Operator And (
    mat1 As Mat,
    mat2 As Mat
) As Mat
public:
static Mat^ operator &(
    Mat^ mat1,
    Mat^ mat2
)
static let inline (&&&)
        mat1 : Mat *
        mat2 : Mat  : Mat

Parameters

mat1
Type: Emgu.CVMat
The first mat to AND
mat2
Type: Emgu.CVMat
The second mat to AND

Return Value

Type: Mat
The result of the AND operation
See Also

Reference

Mat Class
BitwiseAnd Overload
Emgu.CV Namespace


Mat.BitwiseAnd Operator (Mat, MCvScalar)

MatBitwiseAnd Operator (Mat, MCvScalar)

http://www.emgu.com
Perform an element wise AND operation using a mat and a scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator &(
    Mat mat1,
    MCvScalar val
)
Public Shared Operator And (
    mat1 As Mat,
    val As MCvScalar
) As Mat
public:
static Mat^ operator &(
    Mat^ mat1,
    MCvScalar^ val
)
static let inline (&&&)
        mat1 : Mat *
        val : MCvScalar  : Mat

Parameters

mat1
Type: Emgu.CVMat
The first mat to AND
val
Type: Emgu.CV.StructureMCvScalar
The value to AND

Return Value

Type: Mat
The result of the AND operation
See Also

Reference

Mat Class
BitwiseAnd Overload
Emgu.CV Namespace


Mat.BitwiseAnd Operator (Mat, Double)

MatBitwiseAnd Operator (Mat, Double)

http://www.emgu.com
Perform an element wise AND operation using a mat and a scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator &(
    Mat mat1,
    double val
)
Public Shared Operator And (
    mat1 As Mat,
    val As Double
) As Mat
public:
static Mat^ operator &(
    Mat^ mat1,
    double val
)
static let inline (&&&)
        mat1 : Mat *
        val : float  : Mat

Parameters

mat1
Type: Emgu.CVMat
The first image to AND
val
Type: SystemDouble
The value to AND

Return Value

Type: Mat
The result of the AND operation
See Also

Reference

Mat Class
BitwiseAnd Overload
Emgu.CV Namespace


Mat.BitwiseAnd Operator (MCvScalar, Mat)

MatBitwiseAnd Operator (MCvScalar, Mat)

http://www.emgu.com
Perform an element wise AND operation using a mat and a scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator &(
    MCvScalar val,
    Mat mat1
)
Public Shared Operator And (
    val As MCvScalar,
    mat1 As Mat
) As Mat
public:
static Mat^ operator &(
    MCvScalar^ val,
    Mat^ mat1
)
static let inline (&&&)
        val : MCvScalar *
        mat1 : Mat  : Mat

Parameters

val
Type: Emgu.CV.StructureMCvScalar
The scalar to AND
mat1
Type: Emgu.CVMat
The first mat to AND

Return Value

Type: Mat
The result of the AND operation
See Also

Reference

Mat Class
BitwiseAnd Overload
Emgu.CV Namespace


Mat.BitwiseOr Operator

MatBitwiseOr Operator

Overload List
Name | Description
BitwiseOr(Double, Mat) | Perform an binary OR operation with some color
BitwiseOr(Mat, Mat) | Perform an element wise OR operation with another mat and return the result
BitwiseOr(Mat, MCvScalar) | Perform an binary OR operation with some scalar
BitwiseOr(Mat, Double) | Perform an binary OR operation with some value
BitwiseOr(MCvScalar, Mat) | Perform an binary OR operation with some scalar
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.BitwiseOr Operator (Double, Mat)

MatBitwiseOr Operator (Double, Mat)

http://www.emgu.com
Perform an binary OR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator |(
    double val,
    Mat mat1
)
Public Shared Operator Or (
    val As Double,
    mat1 As Mat
) As Mat
public:
static Mat^ operator |(
    double val,
    Mat^ mat1
)
static let inline (|||)
        val : float *
        mat1 : Mat  : Mat

Parameters

val
Type: SystemDouble
The color to OR
mat1
Type: Emgu.CVMat
The mat to OR

Return Value

Type: Mat
The result of the OR operation
See Also

Reference

Mat Class
BitwiseOr Overload
Emgu.CV Namespace


Mat.BitwiseOr Operator (Mat, Mat)

MatBitwiseOr Operator (Mat, Mat)

http://www.emgu.com
Perform an element wise OR operation with another mat and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator |(
    Mat mat1,
    Mat mat2
)
Public Shared Operator Or (
    mat1 As Mat,
    mat2 As Mat
) As Mat
public:
static Mat^ operator |(
    Mat^ mat1,
    Mat^ mat2
)
static let inline (|||)
        mat1 : Mat *
        mat2 : Mat  : Mat

Parameters

mat1
Type: Emgu.CVMat
The first mat to apply bitwise OR operation
mat2
Type: Emgu.CVMat
The second mat to apply bitwise OR operation

Return Value

Type: Mat
The result of the OR operation
See Also

Reference

Mat Class
BitwiseOr Overload
Emgu.CV Namespace


Mat.BitwiseOr Operator (Mat, MCvScalar)

MatBitwiseOr Operator (Mat, MCvScalar)

http://www.emgu.com
Perform an binary OR operation with some scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator |(
    Mat mat1,
    MCvScalar val
)
Public Shared Operator Or (
    mat1 As Mat,
    val As MCvScalar
) As Mat
public:
static Mat^ operator |(
    Mat^ mat1,
    MCvScalar^ val
)
static let inline (|||)
        mat1 : Mat *
        val : MCvScalar  : Mat

Parameters

mat1
Type: Emgu.CVMat
The mat to OR
val
Type: Emgu.CV.StructureMCvScalar
The value to OR

Return Value

Type: Mat
The result of the OR operation
See Also

Reference

Mat Class
BitwiseOr Overload
Emgu.CV Namespace


Mat.BitwiseOr Operator (Mat, Double)

MatBitwiseOr Operator (Mat, Double)

http://www.emgu.com
Perform an binary OR operation with some value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator |(
    Mat mat1,
    double val
)
Public Shared Operator Or (
    mat1 As Mat,
    val As Double
) As Mat
public:
static Mat^ operator |(
    Mat^ mat1,
    double val
)
static let inline (|||)
        mat1 : Mat *
        val : float  : Mat

Parameters

mat1
Type: Emgu.CVMat
The mat to OR
val
Type: SystemDouble
The color to OR

Return Value

Type: Mat
The result of the OR operation
See Also

Reference

Mat Class
BitwiseOr Overload
Emgu.CV Namespace


Mat.BitwiseOr Operator (MCvScalar, Mat)

MatBitwiseOr Operator (MCvScalar, Mat)

http://www.emgu.com
Perform an binary OR operation with some scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator |(
    MCvScalar val,
    Mat mat1
)
Public Shared Operator Or (
    val As MCvScalar,
    mat1 As Mat
) As Mat
public:
static Mat^ operator |(
    MCvScalar^ val,
    Mat^ mat1
)
static let inline (|||)
        val : MCvScalar *
        mat1 : Mat  : Mat

Parameters

val
Type: Emgu.CV.StructureMCvScalar
The color to OR
mat1
Type: Emgu.CVMat
The mat to OR

Return Value

Type: Mat
The result of the OR operation
See Also

Reference

Mat Class
BitwiseOr Overload
Emgu.CV Namespace


Mat.Division Operator

MatDivision Operator

Overload List
Name | Description
Division(Double, Mat) | scale / mat
Division(Mat, Double) | mat / scale
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Division Operator (Double, Mat)

MatDivision Operator (Double, Mat)

http://www.emgu.com
scale / mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator /(
    double scale,
    Mat mat
)
Public Shared Operator / (
    scale As Double,
    mat As Mat
) As Mat
public:
static Mat^ operator /(
    double scale,
    Mat^ mat
)
static let inline (/)
        scale : float *
        mat : Mat  : Mat

Parameters

scale
Type: SystemDouble
The scale
mat
Type: Emgu.CVMat
The mat

Return Value

Type: Mat
scale / mat
See Also

Reference

Mat Class
Division Overload
Emgu.CV Namespace


Mat.Division Operator (Mat, Double)

MatDivision Operator (Mat, Double)

http://www.emgu.com
mat / scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator /(
    Mat mat,
    double scale
)
Public Shared Operator / (
    mat As Mat,
    scale As Double
) As Mat
public:
static Mat^ operator /(
    Mat^ mat,
    double scale
)
static let inline (/)
        mat : Mat *
        scale : float  : Mat

Parameters

mat
Type: Emgu.CVMat
The mat
scale
Type: SystemDouble
The division scale

Return Value

Type: Mat
mat / scale
See Also

Reference

Mat Class
Division Overload
Emgu.CV Namespace


Mat.Multiply Operator

MatMultiply Operator

Overload List
Name | Description
Multiply(Double, Mat) | scale*mat
Multiply(Mat, Double) | mat * scale
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Multiply Operator (Double, Mat)

MatMultiply Operator (Double, Mat)

http://www.emgu.com
scale*mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator *(
    double scale,
    Mat mat
)
Public Shared Operator * (
    scale As Double,
    mat As Mat
) As Mat
public:
static Mat^ operator *(
    double scale,
    Mat^ mat
)
static let inline (*)
        scale : float *
        mat : Mat  : Mat

Parameters

scale
Type: SystemDouble
The multiplication scale
mat
Type: Emgu.CVMat
The mat

Return Value

Type: Mat
scale*mat
See Also

Reference

Mat Class
Multiply Overload
Emgu.CV Namespace


Mat.Multiply Operator (Mat, Double)

MatMultiply Operator (Mat, Double)

http://www.emgu.com
mat * scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator *(
    Mat mat,
    double scale
)
Public Shared Operator * (
    mat As Mat,
    scale As Double
) As Mat
public:
static Mat^ operator *(
    Mat^ mat,
    double scale
)
static let inline (*)
        mat : Mat *
        scale : float  : Mat

Parameters

mat
Type: Emgu.CVMat
The mat
scale
Type: SystemDouble
The multiplication scale

Return Value

Type: Mat
mat * scale
See Also

Reference

Mat Class
Multiply Overload
Emgu.CV Namespace


Mat.OnesComplement Operator

MatOnesComplement Operator

Compute the complement Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator ~(
    Mat mat
)
Public Shared Operator ~ (
    mat As Mat
) As Mat
public:
static Mat^ operator ~(
    Mat^ mat
)
F# does not support this operator.

Parameters

mat
Type: Emgu.CVMat
The mat to be inverted

Return Value

Type: Mat
The complement image
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Subtraction Operator

MatSubtraction Operator

Overload List
Name | Description
Subtraction(Double, Mat) | value - mat
Subtraction(Mat, Mat) | Element wise subtract another mat from the current mat
Subtraction(Mat, MCvScalar) | Element wise subtract another mat from the current mat
Subtraction(Mat, Double) | Element wise subtract value from the current mat
Subtraction(MCvScalar, Mat) | Element wise subtract value from the current mat
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


Mat.Subtraction Operator (Double, Mat)

MatSubtraction Operator (Double, Mat)

http://www.emgu.com
value - mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator -(
    double value,
    Mat mat
)
Public Shared Operator - (
    value As Double,
    mat As Mat
) As Mat
public:
static Mat^ operator -(
    double value,
    Mat^ mat
)
static let inline (-)
        value : float *
        mat : Mat  : Mat

Parameters

value
Type: SystemDouble
The value to be subtracted
mat
Type: Emgu.CVMat
The mat to be subtracted

Return Value

Type: Mat
value - mat
See Also

Reference

Mat Class
Subtraction Overload
Emgu.CV Namespace


Mat.Subtraction Operator (Mat, Mat)

MatSubtraction Operator (Mat, Mat)

http://www.emgu.com
Element wise subtract another mat from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator -(
    Mat mat1,
    Mat mat2
)
Public Shared Operator - (
    mat1 As Mat,
    mat2 As Mat
) As Mat
public:
static Mat^ operator -(
    Mat^ mat1,
    Mat^ mat2
)
static let inline (-)
        mat1 : Mat *
        mat2 : Mat  : Mat

Parameters

mat1
Type: Emgu.CVMat
The mat to be subtracted from.
mat2
Type: Emgu.CVMat
The second image to be subtracted from mat1

Return Value

Type: Mat
The result of element wise subtracting img2 from mat1
See Also

Reference

Mat Class
Subtraction Overload
Emgu.CV Namespace


Mat.Subtraction Operator (Mat, MCvScalar)

MatSubtraction Operator (Mat, MCvScalar)

http://www.emgu.com
Element wise subtract another mat from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator -(
    Mat mat,
    MCvScalar value
)
Public Shared Operator - (
    mat As Mat,
    value As MCvScalar
) As Mat
public:
static Mat^ operator -(
    Mat^ mat,
    MCvScalar^ value
)
static let inline (-)
        mat : Mat *
        value : MCvScalar  : Mat

Parameters

mat
Type: Emgu.CVMat
The mat to be subtracted
value
Type: Emgu.CV.StructureMCvScalar
The value to be subtracted

Return Value

Type: Mat
The result of element wise subtracting value from mat
See Also

Reference

Mat Class
Subtraction Overload
Emgu.CV Namespace


Mat.Subtraction Operator (Mat, Double)

MatSubtraction Operator (Mat, Double)

http://www.emgu.com
Element wise subtract value from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator -(
    Mat mat,
    double value
)
Public Shared Operator - (
    mat As Mat,
    value As Double
) As Mat
public:
static Mat^ operator -(
    Mat^ mat,
    double value
)
static let inline (-)
        mat : Mat *
        value : float  : Mat

Parameters

mat
Type: Emgu.CVMat
The mat to be subtracted
value
Type: SystemDouble
The value to be subtracted

Return Value

Type: Mat
mat - value
See Also

Reference

Mat Class
Subtraction Overload
Emgu.CV Namespace


Mat.Subtraction Operator (MCvScalar, Mat)

MatSubtraction Operator (MCvScalar, Mat)

http://www.emgu.com
Element wise subtract value from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat operator -(
    MCvScalar value,
    Mat mat
)
Public Shared Operator - (
    value As MCvScalar,
    mat As Mat
) As Mat
public:
static Mat^ operator -(
    MCvScalar^ value,
    Mat^ mat
)
static let inline (-)
        value : MCvScalar *
        mat : Mat  : Mat

Parameters

value
Type: Emgu.CV.StructureMCvScalar
The color to be subtracted
mat
Type: Emgu.CVMat
The mat to be subtracted

Return Value

Type: Mat
value - mat
See Also

Reference

Mat Class
Subtraction Overload
Emgu.CV Namespace


Mat Fields

The Mat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Mat Class
Emgu.CV Namespace


MatDataAllocator Class

Matrix data allocator. Base class for Mat that handles the matrix data allocation and deallocation
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMatDataAllocator
Emgu.CVMat
Emgu.CVUMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class MatDataAllocator : UnmanagedObject
Public MustInherit Class MatDataAllocator
    Inherits UnmanagedObject
public ref class MatDataAllocator abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type MatDataAllocator =
    class
        inherit UnmanagedObject
    end

The MatDataAllocator type exposes the following members.

Constructors
 | Name | Description
Protected method | MatDataAllocator | Initializes a new instance of the MatDataAllocator class
Top
Properties
 | Name | Description
Public property | Data | Get the managed data used by the Mat
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


MatDataAllocator Constructor

Initializes a new instance of the MatDataAllocator class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected MatDataAllocator()
Protected Sub New
protected:
MatDataAllocator()
new : unit -> MatDataAllocator
See Also

Reference

MatDataAllocator Class
Emgu.CV Namespace


MatDataAllocator Properties

The MatDataAllocator type exposes the following members.

Properties
 | Name | Description
Public property | Data | Get the managed data used by the Mat
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MatDataAllocator Class
Emgu.CV Namespace


MatDataAllocator.Data Property

MatDataAllocatorData Property

Get the managed data used by the Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Array Data { get; }
Public ReadOnly Property Data As Array
    Get
public:
property Array^ Data {
    Array^ get ();
}
member Data : Array with get

Property Value

Type: Array
See Also

Reference

MatDataAllocator Class
Emgu.CV Namespace


MatDataAllocator Methods

The MatDataAllocator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MatDataAllocator Class
Emgu.CV Namespace


MatDataAllocator.DisposeObject Method

MatDataAllocatorDisposeObject Method

Release resource associated with this object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MatDataAllocator Class
Emgu.CV Namespace


MatDataAllocator Fields

The MatDataAllocator type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MatDataAllocator Class
Emgu.CV Namespace


MatND(TDepth) Class

MatNDTDepth Class

A MatND is a wrapper to cvMatND of OpenCV.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArray TDepth
Emgu.CVMatNDTDepth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class MatND<TDepth> : CvArray<TDepth>,
    IEquatable<MatND<TDepth>>
where TDepth : new()

<SerializableAttribute>
Public Class MatND(Of TDepth As New)
    Inherits CvArray(Of TDepth)
    Implements IEquatable(Of MatND(Of TDepth))
[SerializableAttribute]
generic<typename TDepth>
where TDepth : gcnew()
public ref class MatND : public CvArray<TDepth>,
    IEquatable<MatND<TDepth>^>
[<SerializableAttribute>]
type MatND<'TDepth when 'TDepth : new()> =
    class
        inherit CvArray<'TDepth>
        interface IEquatable<MatND<'TDepth>>
    end

Type Parameters

TDepth
The type of depth

The MatNDTDepth type exposes the following members.

Constructors
 | Name | Description
Public method | MatNDTDepth(Int32) | Create a N-dimensional matrix
Public method | MatNDTDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
 | CvDepth | Get the depth representation for Open CV
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | ManagedArray | Get the underneath managed array (Overrides CvArrayTDepthManagedArray.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMatND | The MCvMatND structure
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | This function is not implemented for MatND (Overrides CvArrayTDepthNumberOfChannels.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from CvArrayTDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Protected method | AllocateData | This function is not implemented for MatND (Overrides CvArrayTDepthAllocateData(Int32, Int32, Int32).)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | ConvertTOtherDepth | Convert this matrix to different depth
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Overrides CvArrayTDepthDeserializeObjectData(SerializationInfo, StreamingContext).)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Overrides CvArrayTDepthDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatNDTDepth) | Check if the two MatND are equal
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Overrides CvArrayTDepthGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadXml | Not Implemented (Overrides CvArrayTDepthReadXml(XmlReader).)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WriteXml | Not Implemented (Overrides CvArrayTDepthWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


MatND(TDepth) Constructor

MatNDTDepth Constructor

Overload List
 | Name | Description
Public method | MatNDTDepth(Int32) | Create a N-dimensional matrix
Public method | MatNDTDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth) Constructor (Int32[])

MatNDTDepth Constructor (Int32)

http://www.emgu.com
Create a N-dimensional matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MatND(
    params int[] sizes
)
Public Sub New (
    ParamArray sizes As Integer()
)
public:
MatND(
    ... array<int>^ sizes
)
new :
        sizes : int[] -> MatND

Parameters

sizes
Type: SystemInt32
The size for each dimension
See Also

Reference

MatNDTDepth Class
MatNDTDepth Overload
Emgu.CV Namespace


MatND(TDepth) Constructor (SerializationInfo, StreamingContext)

MatNDTDepth Constructor (SerializationInfo, StreamingContext)

http://www.emgu.com
Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MatND(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
MatND(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MatND

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

MatNDTDepth Class
MatNDTDepth Overload
Emgu.CV Namespace


MatND(TDepth) Properties

MatNDTDepth Properties

The MatNDTDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
 | CvDepth | Get the depth representation for Open CV
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | ManagedArray | Get the underneath managed array (Overrides CvArrayTDepthManagedArray.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMatND | The MCvMatND structure
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | This function is not implemented for MatND (Overrides CvArrayTDepthNumberOfChannels.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from CvArrayTDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).CvDepth Property

MatNDTDepthCvDepth Property

Get the depth representation for Open CV

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected static DepthType CvDepth { get; }
Protected Shared ReadOnly Property CvDepth As DepthType
    Get
protected:
static property DepthType^ CvDepth {
    DepthType^ get ();
}
static member CvDepth : DepthType with get

Property Value

Type: DepthType
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).ManagedArray Property

MatNDTDepthManagedArray Property

Get the underneath managed array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override Array ManagedArray { get; set; }
Public Overrides Property ManagedArray As Array
    Get
    Set
public:
virtual property Array^ ManagedArray {
    Array^ get () override;
    void set (Array^ value) override;
}
abstract ManagedArray : Array with get, set
override ManagedArray : Array with get, set

Property Value

Type: Array
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).MCvMatND Property

MatNDTDepthMCvMatND Property

The MCvMatND structure

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatND MCvMatND { get; }
Public ReadOnly Property MCvMatND As MCvMatND
    Get
public:
property MCvMatND^ MCvMatND {
    MCvMatND^ get ();
}
member MCvMatND : MCvMatND with get

Property Value

Type: MCvMatND
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).NumberOfChannels Property

MatNDTDepthNumberOfChannels Property

This function is not implemented for MatND

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override int NumberOfChannels { get; }
Public Overrides ReadOnly Property NumberOfChannels As Integer
    Get
public:
virtual property int NumberOfChannels {
    int get () override;
}
abstract NumberOfChannels : int with get
override NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth) Methods

MatNDTDepth Methods

The MatNDTDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Protected method | AllocateData | This function is not implemented for MatND (Overrides CvArrayTDepthAllocateData(Int32, Int32, Int32).)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | ConvertTOtherDepth | Convert this matrix to different depth
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Overrides CvArrayTDepthDeserializeObjectData(SerializationInfo, StreamingContext).)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Overrides CvArrayTDepthDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatNDTDepth) | Check if the two MatND are equal
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Overrides CvArrayTDepthGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadXml | Not Implemented (Overrides CvArrayTDepthReadXml(XmlReader).)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WriteXml | Not Implemented (Overrides CvArrayTDepthWriteXml(XmlWriter).)
Top
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).AllocateData Method

MatNDTDepthAllocateData Method

This function is not implemented for MatND

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
)
Protected Overrides Sub AllocateData (
    rows As Integer,
    cols As Integer,
    numberOfChannels As Integer
)
protected:
virtual void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
) override
abstract AllocateData :
        rows : int *
        cols : int *
        numberOfChannels : int -> unit
override AllocateData :
        rows : int *
        cols : int *
        numberOfChannels : int -> unit

Parameters

rows
Type: SystemInt32
Not implemented
cols
Type: SystemInt32
Not implemented
numberOfChannels
Type: SystemInt32
Not implemented
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).Convert(TOtherDepth) Method

MatNDTDepthConvertTOtherDepth Method

Convert this matrix to different depth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MatND<TOtherDepth> Convert<TOtherDepth>()
where TOtherDepth : new()

Public Function Convert(Of TOtherDepth As New) As MatND(Of TOtherDepth)
public:
generic<typename TOtherDepth>
where TOtherDepth : gcnew()
MatND<TOtherDepth>^ Convert()
member Convert : unit -> MatND<'TOtherDepth>  when 'TOtherDepth : new()

Type Parameters

TOtherDepth
The depth type to convert to

Return Value

Type: MatND TOtherDepth
Matrix of different depth
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).DeserializeObjectData Method

MatNDTDepthDeserializeObjectData Method

A function used for runtime deserailization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DeserializeObjectData(
    SerializationInfo info,
    StreamingContext context
)
Protected Overrides Sub DeserializeObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
virtual void DeserializeObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) override
abstract DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).DisposeObject Method

MatNDTDepthDisposeObject Method

Release the matrix and all the memory associate with it

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).Equals Method

MatNDTDepthEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatNDTDepth) | Check if the two MatND are equal
Top
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).Equals Method (MatND(TDepth))

MatNDTDepthEquals Method (MatNDTDepth)

http://www.emgu.com
Check if the two MatND are equal

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    MatND<TDepth> other
)
Public Function Equals (
    other As MatND(Of TDepth)
) As Boolean
public:
virtual bool Equals(
    MatND<TDepth>^ other
) sealed
abstract Equals :
        other : MatND<'TDepth> -> bool
override Equals :
        other : MatND<'TDepth> -> bool

Parameters

other
Type: Emgu.CVMatND TDepth
The other MatND to compares to

Return Value

Type: Boolean
True if the two MatND equals

Implements

IEquatableTEquals(T)
See Also

Reference

MatNDTDepth Class
Equals Overload
Emgu.CV Namespace


MatND(TDepth).GetObjectData Method

MatNDTDepthGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).ReadXml Method

MatNDTDepthReadXml Method

Not Implemented

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The XmlReader

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth).WriteXml Method

MatNDTDepthWriteXml Method

Not Implemented

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The XmlWriter

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


MatND(TDepth) Fields

MatNDTDepth Fields

The MatNDTDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MatNDTDepth Class
Emgu.CV Namespace


Matrix(TDepth) Class

MatrixTDepth Class

A Matrix is a wrapper to cvMat of OpenCV.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArray TDepth
Emgu.CVMatrixTDepth
Emgu.CVConvolutionKernelF
Emgu.CVRotationVector3D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Matrix<TDepth> : CvArray<TDepth>,
    IEquatable<Matrix<TDepth>>, ICloneable
where TDepth : new()

<SerializableAttribute>
Public Class Matrix(Of TDepth As New)
    Inherits CvArray(Of TDepth)
    Implements IEquatable(Of Matrix(Of TDepth)),
    ICloneable
[SerializableAttribute]
generic<typename TDepth>
where TDepth : gcnew()
public ref class Matrix : public CvArray<TDepth>,
    IEquatable<Matrix<TDepth>^>, ICloneable
[<SerializableAttribute>]
type Matrix<'TDepth when 'TDepth : new()> =
    class
        inherit CvArray<'TDepth>
        interface IEquatable<Matrix<'TDepth>>
        interface ICloneable
    end

Type Parameters

TDepth
Depth of this matrix (either Byte, SByte, Single, double, UInt16, Int16 or Int32)

The MatrixTDepth type exposes the following members.

Constructors
 | Name | Description
Protected method | MatrixTDepth | The default constructor which allows Data to be set later on
Public method | MatrixTDepth(Size) | Create a matrix of the specific size
Public method | MatrixTDepth(TDepth) | Create a matrix using the specific data.
Public method | MatrixTDepth(TDepth) | Create a matrix using the specific data
Public method | MatrixTDepth(Int32, Int32) | Create a matrix of the specific size
Public method | MatrixTDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | MatrixTDepth(Int32, Int32, Int32) | Create a matrix of the specific size and channels
Public method | MatrixTDepth(Int32, Int32, IntPtr) | Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class
Public method | MatrixTDepth(Int32, Int32, IntPtr, Int32) | Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class
Public method | MatrixTDepth(Int32, Int32, Int32, IntPtr, Int32) | Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix
Public property | Det | Returns determinant of the square matrix
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | Item | Get or Set the value in the specific row and col
Public property | ManagedArray | Get the underneath managed array (Overrides CvArrayTDepthManagedArray.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMat | The MCvMat structure format
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this matrix (Overrides CvArrayTDepthNumberOfChannels.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Overrides CvArrayTDepthSize.)
Public property | Sum | Return the sum of the elements in this matrix
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | Add(TDepth) | Elementwise add a color val to the current matrix
Public method | Add(MatrixTDepth) | Elementwise add another matrix with the current matrix
Protected method | AllocateData | Allocate data for the array (Overrides CvArrayTDepthAllocateData(Int32, Int32, Int32).)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a copy of this matrix
Public method | Cmp | This function compare the current matrix with mat2 and returns the comparison mask
Public method | ConcateHorizontal | Concate the current matrix with another matrix horizontally. If this matrix is n x m1 and otherMatrix is n x m2, the resulting matrix is n x (m1 + m2).
Public method | ConcateVertical | Concate the current matrix with another matrix vertically. If this matrix is n1 x m and otherMatrix is n2 x m, the resulting matrix is (n1+n2) x m.
Public method | ConvertTOtherDepth | Convert this matrix to different depth
Public method | CopyBlank | Return a matrix of the same size with all elements equals 0
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Overrides CvArrayTDepthDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatrixTDepth) | Return true if every element of this matrix equals elements in mat2
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetCol | Get the specific column of the matrix
Public method | GetCols | Get the Matrix, corresponding to a specified column span of the input array
Public method | GetDiag | Return the main diagonal element of this matrix
Public method | GetDiag(Int32) | Return the specific diagonal elements of this matrix
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from CvArrayTDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetRow | Get the specific row of the matrix
Public method | GetRows | Return the matrix corresponding to a specified row span of the input array
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a submatrix corresponding to a specified rectangle
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max locations and values for the matrix
Public method | Mul(Double) | Multiply the current matrix with scale
Public method | Mul(MatrixTDepth) | Multiply the current matrix with mat2
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveCols | Return the matrix without a specified column span of the input array
Public method | RemoveRows | Return the matrix without a specified row span of the input array
Public method | Reshape | Get reshaped matrix which also share the same data with the current matrix
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | Split | Get all channels for the multi channel matrix
Public method | Sub(TDepth) | Elementwise subtract a color val to the current matrix
Public method | Sub(MatrixTDepth) | Elementwise subtract another matrix from the current matrix
Public method | SubR | result = val - this
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | Transpose | Returns the transpose of this matrix
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Top
Operators
Name | Description
Addition(Double, MatrixTDepth) | val + mat1
Addition(MatrixTDepth, MatrixTDepth) | Elementwise add mat1 with mat2
Addition(MatrixTDepth, Double) | Elementwise add mat1 with val
Division | mat1 / val
Multiply(Double, MatrixTDepth) | val * mat1
Multiply(MatrixTDepth, MatrixTDepth) | mat1 * mat2
Multiply(MatrixTDepth, Double) | mat1 * val
Subtraction(Double, MatrixTDepth) | val - mat1
Subtraction(MatrixTDepth, MatrixTDepth) | mat1 - mat2
Subtraction(MatrixTDepth, Double) | mat1 - val
Top
Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


Matrix(TDepth) Constructor

MatrixTDepth Constructor

Overload List
 | Name | Description
Protected method | MatrixTDepth | The default constructor which allows Data to be set later on
Public method | MatrixTDepth(Size) | Create a matrix of the specific size
Public method | MatrixTDepth(TDepth) | Create a matrix using the specific data.
Public method | MatrixTDepth(TDepth) | Create a matrix using the specific data
Public method | MatrixTDepth(Int32, Int32) | Create a matrix of the specific size
Public method | MatrixTDepth(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | MatrixTDepth(Int32, Int32, Int32) | Create a matrix of the specific size and channels
Public method | MatrixTDepth(Int32, Int32, IntPtr) | Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class
Public method | MatrixTDepth(Int32, Int32, IntPtr, Int32) | Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class
Public method | MatrixTDepth(Int32, Int32, Int32, IntPtr, Int32) | Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth) Constructor

MatrixTDepth Constructor

The default constructor which allows Data to be set later on

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Matrix()
Protected Sub New
protected:
Matrix()
new : unit -> Matrix
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (Size)

MatrixTDepth Constructor (Size)

http://www.emgu.com
Create a matrix of the specific size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    Size size
)
Public Sub New (
    size As Size
)
public:
Matrix(
    Size^ size
)
new :
        size : Size -> Matrix

Parameters

size
Type: System.DrawingSize
The size of the matrix
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (TDepth[,])

MatrixTDepth Constructor (TDepth)

http://www.emgu.com
Create a matrix using the specific data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    TDepth[,] data
)
Public Sub New (
    data As TDepth(,)
)
public:
Matrix(
    array<TDepth,2>^ data
)
new :
        data : 'TDepth[,] -> Matrix

Parameters

data
Type: TDepth
The data will be used as the Matrix data storage. You need to make sure that the data object live as long as this Matrix object
Remarks
The data will be used as the Matrix data storage. You need to make sure that the data object live as long as this Matrix object
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (TDepth[])

MatrixTDepth Constructor (TDepth)

http://www.emgu.com
Create a matrix using the specific data

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    TDepth[] data
)
Public Sub New (
    data As TDepth()
)
public:
Matrix(
    array<TDepth>^ data
)
new :
        data : 'TDepth[] -> Matrix

Parameters

data
Type: TDepth
the data for this matrix
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (Int32, Int32)

MatrixTDepth Constructor (Int32, Int32)

http://www.emgu.com
Create a matrix of the specific size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    int rows,
    int cols
)
Public Sub New (
    rows As Integer,
    cols As Integer
)
public:
Matrix(
    int rows,
    int cols
)
new :
        rows : int *
        cols : int -> Matrix

Parameters

rows
Type: SystemInt32
The number of rows (height)
cols
Type: SystemInt32
The number of cols (width)
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (SerializationInfo, StreamingContext)

MatrixTDepth Constructor (SerializationInfo, StreamingContext)

http://www.emgu.com
Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
Matrix(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> Matrix

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (Int32, Int32, Int32)

MatrixTDepth Constructor (Int32, Int32, Int32)

http://www.emgu.com
Create a matrix of the specific size and channels

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    int rows,
    int cols,
    int channels
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    channels As Integer
)
public:
Matrix(
    int rows,
    int cols,
    int channels
)
new :
        rows : int *
        cols : int *
        channels : int -> Matrix

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of cols
channels
Type: SystemInt32
The number of channels
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (Int32, Int32, IntPtr)

MatrixTDepth Constructor (Int32, Int32, IntPtr)

http://www.emgu.com
Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    int rows,
    int cols,
    IntPtr data
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    data As IntPtr
)
public:
Matrix(
    int rows,
    int cols,
    IntPtr data
)
new :
        rows : int *
        cols : int *
        data : IntPtr -> Matrix

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of cols
data
Type: SystemIntPtr
The Pinned/Unmanaged data, the data must not be release before the Matrix is Disposed
Remarks
The caller is responsible for allocating and freeing the block of memory specified by the data parameter, however, the memory should not be released until the related Matrix is released.
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (Int32, Int32, IntPtr, Int32)

MatrixTDepth Constructor (Int32, Int32, IntPtr, Int32)

http://www.emgu.com
Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    int rows,
    int cols,
    IntPtr data,
    int step
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    data As IntPtr,
    step As Integer
)
public:
Matrix(
    int rows,
    int cols,
    IntPtr data,
    int step
)
new :
        rows : int *
        cols : int *
        data : IntPtr *
        step : int -> Matrix

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of cols
data
Type: SystemIntPtr
The Pinned/Unmanaged data, the data must not be release before the Matrix is Disposed
step
Type: SystemInt32
The step (row stride in bytes)
Remarks
The caller is responsible for allocating and freeing the block of memory specified by the data parameter, however, the memory should not be released until the related Matrix is released.
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Constructor (Int32, Int32, Int32, IntPtr, Int32)

MatrixTDepth Constructor (Int32, Int32, Int32, IntPtr, Int32)

http://www.emgu.com
Create a Matrix (only header is allocated) using the Pinned/Unmanaged data. The data is not freed by the disposed function of this class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    int rows,
    int cols,
    int channels,
    IntPtr data,
    int step
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    channels As Integer,
    data As IntPtr,
    step As Integer
)
public:
Matrix(
    int rows,
    int cols,
    int channels,
    IntPtr data,
    int step
)
new :
        rows : int *
        cols : int *
        channels : int *
        data : IntPtr *
        step : int -> Matrix

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of cols
channels
Type: SystemInt32
The number of channels
data
Type: SystemIntPtr
The Pinned/Unmanaged data, the data must not be release before the Matrix is Disposed
step
Type: SystemInt32
The step (row stride in bytes)
Remarks
The caller is responsible for allocating and freeing the block of memory specified by the data parameter, however, the memory should not be released until the related Matrix is released.
See Also

Reference

MatrixTDepth Class
MatrixTDepth Overload
Emgu.CV Namespace


Matrix(TDepth) Properties

MatrixTDepth Properties

The MatrixTDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix
Public property | Det | Returns determinant of the square matrix
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | Item | Get or Set the value in the specific row and col
Public property | ManagedArray | Get the underneath managed array (Overrides CvArrayTDepthManagedArray.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMat | The MCvMat structure format
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this matrix (Overrides CvArrayTDepthNumberOfChannels.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Overrides CvArrayTDepthSize.)
Public property | Sum | Return the sum of the elements in this matrix
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Data Property

MatrixTDepthData Property

Get or Set the data for this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TDepth[,] Data { get; set; }
Public Property Data As TDepth(,)
    Get
    Set
public:
property array<TDepth,2>^ Data {
    array<TDepth,2>^ get ();
    void set (array<TDepth,2>^ value);
}
member Data : 'TDepth[,] with get, set

Property Value

Type: TDepth
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Det Property

MatrixTDepthDet Property

Returns determinant of the square matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Det { get; }
Public ReadOnly Property Det As Double
    Get
public:
property double Det {
    double get ();
}
member Det : float with get

Property Value

Type: Double
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Item Property

MatrixTDepthItem Property

Get or Set the value in the specific row and col

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TDepth this[
    int row,
    int col
] { get; set; }
Public Property Item (
    row As Integer,
    col As Integer
) As TDepth
    Get
    Set
public:
property TDepth Item[int row, int col] {
    TDepth get (int row, int col);
    void set (int row, int col, TDepth value);
}
member Item : 'TDepth with get, set

Parameters

row
Type: SystemInt32
the row of the element
col
Type: SystemInt32
the col of the element

Return Value

Type: TDepth
The element on the specific row and col
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).ManagedArray Property

MatrixTDepthManagedArray Property

Get the underneath managed array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override Array ManagedArray { get; set; }
Public Overrides Property ManagedArray As Array
    Get
    Set
public:
virtual property Array^ ManagedArray {
    Array^ get () override;
    void set (Array^ value) override;
}
abstract ManagedArray : Array with get, set
override ManagedArray : Array with get, set

Property Value

Type: Array
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).MCvMat Property

MatrixTDepthMCvMat Property

The MCvMat structure format

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMat MCvMat { get; }
Public ReadOnly Property MCvMat As MCvMat
    Get
public:
property MCvMat^ MCvMat {
    MCvMat^ get ();
}
member MCvMat : MCvMat with get

Property Value

Type: MCvMat
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).NumberOfChannels Property

MatrixTDepthNumberOfChannels Property

Get the number of channels for this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override int NumberOfChannels { get; }
Public Overrides ReadOnly Property NumberOfChannels As Integer
    Get
public:
virtual property int NumberOfChannels {
    int get () override;
}
abstract NumberOfChannels : int with get
override NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Size Property

MatrixTDepthSize Property

Get the size of the array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override Size Size { get; }
Public Overrides ReadOnly Property Size As Size
    Get
public:
virtual property Size^ Size {
    Size^ get () override;
}
abstract Size : Size with get
override Size : Size with get

Property Value

Type: Size
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Sum Property

MatrixTDepthSum Property

Return the sum of the elements in this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Sum { get; }
Public ReadOnly Property Sum As Double
    Get
public:
property double Sum {
    double get ();
}
member Sum : float with get

Property Value

Type: Double
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth) Methods

MatrixTDepth Methods

The MatrixTDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | Add(TDepth) | Elementwise add a color val to the current matrix
Public method | Add(MatrixTDepth) | Elementwise add another matrix with the current matrix
Protected method | AllocateData | Allocate data for the array (Overrides CvArrayTDepthAllocateData(Int32, Int32, Int32).)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a copy of this matrix
Public method | Cmp | This function compare the current matrix with mat2 and returns the comparison mask
Public method | ConcateHorizontal | Concate the current matrix with another matrix horizontally. If this matrix is n x m1 and otherMatrix is n x m2, the resulting matrix is n x (m1 + m2).
Public method | ConcateVertical | Concate the current matrix with another matrix vertically. If this matrix is n1 x m and otherMatrix is n2 x m, the resulting matrix is (n1+n2) x m.
Public method | ConvertTOtherDepth | Convert this matrix to different depth
Public method | CopyBlank | Return a matrix of the same size with all elements equals 0
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Overrides CvArrayTDepthDisposeObject.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatrixTDepth) | Return true if every element of this matrix equals elements in mat2
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetCol | Get the specific column of the matrix
Public method | GetCols | Get the Matrix, corresponding to a specified column span of the input array
Public method | GetDiag | Return the main diagonal element of this matrix
Public method | GetDiag(Int32) | Return the specific diagonal elements of this matrix
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from CvArrayTDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetRow | Get the specific row of the matrix
Public method | GetRows | Return the matrix corresponding to a specified row span of the input array
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a submatrix corresponding to a specified rectangle
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max locations and values for the matrix
Public method | Mul(Double) | Multiply the current matrix with scale
Public method | Mul(MatrixTDepth) | Multiply the current matrix with mat2
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveCols | Return the matrix without a specified column span of the input array
Public method | RemoveRows | Return the matrix without a specified row span of the input array
Public method | Reshape | Get reshaped matrix which also share the same data with the current matrix
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | Split | Get all channels for the multi channel matrix
Public method | Sub(TDepth) | Elementwise subtract a color val to the current matrix
Public method | Sub(MatrixTDepth) | Elementwise subtract another matrix from the current matrix
Public method | SubR | result = val - this
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | Transpose | Returns the transpose of this matrix
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Add Method

MatrixTDepthAdd Method

Overload List
 | Name | Description
Public method | Add(TDepth) | Elementwise add a color val to the current matrix
Public method | Add(MatrixTDepth) | Elementwise add another matrix with the current matrix
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Add Method (TDepth)

MatrixTDepthAdd Method (TDepth)

http://www.emgu.com
Elementwise add a color val to the current matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Add(
    TDepth val
)
Public Function Add (
    val As TDepth
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Add(
    TDepth val
)
member Add :
        val : 'TDepth -> Matrix<'TDepth>

Parameters

val
Type: TDepth
The value to be added to the current matrix

Return Value

Type: Matrix TDepth
The result of elementwise adding val from the current matrix
See Also

Reference

MatrixTDepth Class
Add Overload
Emgu.CV Namespace


Matrix(TDepth).Add Method (Matrix(TDepth))

MatrixTDepthAdd Method (MatrixTDepth)

http://www.emgu.com
Elementwise add another matrix with the current matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Add(
    Matrix<TDepth> mat2
)
Public Function Add (
    mat2 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Add(
    Matrix<TDepth>^ mat2
)
member Add :
        mat2 : Matrix<'TDepth> -> Matrix<'TDepth>

Parameters

mat2
Type: Emgu.CVMatrix TDepth
The matrix to be added to the current matrix

Return Value

Type: Matrix TDepth
The result of elementwise adding mat2 to the current matrix
See Also

Reference

MatrixTDepth Class
Add Overload
Emgu.CV Namespace


Matrix(TDepth).AllocateData Method

MatrixTDepthAllocateData Method

Allocate data for the array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
)
Protected Overrides Sub AllocateData (
    rows As Integer,
    cols As Integer,
    numberOfChannels As Integer
)
protected:
virtual void AllocateData(
    int rows,
    int cols,
    int numberOfChannels
) override
abstract AllocateData :
        rows : int *
        cols : int *
        numberOfChannels : int -> unit
override AllocateData :
        rows : int *
        cols : int *
        numberOfChannels : int -> unit

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of columns
numberOfChannels
Type: SystemInt32
The number of channels for this matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Clone Method

MatrixTDepthClone Method

Make a copy of this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual Matrix<TDepth> Clone()
Public Overridable Function Clone As Matrix(Of TDepth)
public:
virtual Matrix<TDepth>^ Clone()
abstract Clone : unit -> Matrix<'TDepth>
override Clone : unit -> Matrix<'TDepth>

Return Value

Type: Matrix TDepth
A copy if this matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Cmp Method

MatrixTDepthCmp Method

This function compare the current matrix with mat2 and returns the comparison mask

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<byte> Cmp(
    Matrix<TDepth> mat2,
    CmpType type
)
Public Function Cmp (
    mat2 As Matrix(Of TDepth),
    type As CmpType
) As Matrix(Of Byte)
public:
Matrix<unsigned char>^ Cmp(
    Matrix<TDepth>^ mat2,
    CmpType^ type
)
member Cmp :
        mat2 : Matrix<'TDepth> *
        type : CmpType -> Matrix<byte>

Parameters

mat2
Type: Emgu.CVMatrix TDepth
The other matrix to compare with
type
Type: Emgu.CV.CvEnumCmpType
Comparison type

Return Value

Type: Matrix Byte
The comparison mask
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).ConcateHorizontal Method

MatrixTDepthConcateHorizontal Method

Concate the current matrix with another matrix horizontally. If this matrix is n x m1 and otherMatrix is n x m2, the resulting matrix is n x (m1 + m2).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> ConcateHorizontal(
    Matrix<TDepth> otherMatrix
)
Public Function ConcateHorizontal (
    otherMatrix As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ ConcateHorizontal(
    Matrix<TDepth>^ otherMatrix
)
member ConcateHorizontal :
        otherMatrix : Matrix<'TDepth> -> Matrix<'TDepth>

Parameters

otherMatrix
Type: Emgu.CVMatrix TDepth
The other matrix to concate

Return Value

Type: Matrix TDepth
A matrix that is the horizontal concatening of this matrix and otherMatrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).ConcateVertical Method

MatrixTDepthConcateVertical Method

Concate the current matrix with another matrix vertically. If this matrix is n1 x m and otherMatrix is n2 x m, the resulting matrix is (n1+n2) x m.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> ConcateVertical(
    Matrix<TDepth> otherMatrix
)
Public Function ConcateVertical (
    otherMatrix As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ ConcateVertical(
    Matrix<TDepth>^ otherMatrix
)
member ConcateVertical :
        otherMatrix : Matrix<'TDepth> -> Matrix<'TDepth>

Parameters

otherMatrix
Type: Emgu.CVMatrix TDepth
The other matrix to concate

Return Value

Type: Matrix TDepth
A new matrix that is the vertical concatening of this matrix and otherMatrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Convert(TOtherDepth) Method

MatrixTDepthConvertTOtherDepth Method

Convert this matrix to different depth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TOtherDepth> Convert<TOtherDepth>(
    double scale = 1,
    double shift = 0
)
where TOtherDepth : new()

Public Function Convert(Of TOtherDepth As New) (
    Optional scale As Double = 1,
    Optional shift As Double = 0
) As Matrix(Of TOtherDepth)
public:
generic<typename TOtherDepth>
where TOtherDepth : gcnew()
Matrix<TOtherDepth>^ Convert(
    double scale = 1,
    double shift = 0
)
member Convert :
        ?scale : float *
        ?shift : float
(* Defaults:
        let _scale = defaultArg scale 1
        let _shift = defaultArg shift 0
*)
-> Matrix<'TOtherDepth>  when 'TOtherDepth : new()

Parameters

scale (Optional)
Type: SystemDouble
the scaling factor to apply during conversion (defaults to 1.0 -- no scaling)
shift (Optional)
Type: SystemDouble
the shift factor to apply during conversion (defaults to 0.0 -- no shifting)

Type Parameters

TOtherDepth
The depth type to convert to

Return Value

Type: Matrix TOtherDepth
Matrix of different depth
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).CopyBlank Method

MatrixTDepthCopyBlank Method

Return a matrix of the same size with all elements equals 0

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> CopyBlank()
Public Function CopyBlank As Matrix(Of TDepth)
public:
Matrix<TDepth>^ CopyBlank()
member CopyBlank : unit -> Matrix<'TDepth>

Return Value

Type: Matrix TDepth
A matrix of the same size with all elements equals 0
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).DisposeObject Method

MatrixTDepthDisposeObject Method

Release the matrix and all the memory associate with it

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Equals Method

MatrixTDepthEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatrixTDepth) | Return true if every element of this matrix equals elements in mat2
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Equals Method (Matrix(TDepth))

MatrixTDepthEquals Method (MatrixTDepth)

http://www.emgu.com
Return true if every element of this matrix equals elements in mat2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Matrix<TDepth> mat2
)
Public Function Equals (
    mat2 As Matrix(Of TDepth)
) As Boolean
public:
virtual bool Equals(
    Matrix<TDepth>^ mat2
) sealed
abstract Equals :
        mat2 : Matrix<'TDepth> -> bool
override Equals :
        mat2 : Matrix<'TDepth> -> bool

Parameters

mat2
Type: Emgu.CVMatrix TDepth
The other matrix to compare with

Return Value

Type: Boolean
true if every element of this matrix equals elements in mat2

Implements

IEquatableTEquals(T)
See Also

Reference

MatrixTDepth Class
Equals Overload
Emgu.CV Namespace


Matrix(TDepth).GetCol Method

MatrixTDepthGetCol Method

Get the specific column of the matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> GetCol(
    int col
)
Public Function GetCol (
    col As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ GetCol(
    int col
)
member GetCol :
        col : int -> Matrix<'TDepth>

Parameters

col
Type: SystemInt32
the index of the column to be reterived

Return Value

Type: Matrix TDepth
the specific column of the matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).GetCols Method

MatrixTDepthGetCols Method

Get the Matrix, corresponding to a specified column span of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> GetCols(
    int startCol,
    int endCol
)
Public Function GetCols (
    startCol As Integer,
    endCol As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ GetCols(
    int startCol,
    int endCol
)
member GetCols :
        startCol : int *
        endCol : int -> Matrix<'TDepth>

Parameters

startCol
Type: SystemInt32
Zero-based index of the selected column
endCol
Type: SystemInt32
Zero-based index of the ending column (exclusive) of the span

Return Value

Type: Matrix TDepth
the specific column span of the matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).GetDiag Method

MatrixTDepthGetDiag Method

Overload List
 | Name | Description
Public method | GetDiag | Return the main diagonal element of this matrix
Public method | GetDiag(Int32) | Return the specific diagonal elements of this matrix
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).GetDiag Method

MatrixTDepthGetDiag Method

Return the main diagonal element of this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> GetDiag()
Public Function GetDiag As Matrix(Of TDepth)
public:
Matrix<TDepth>^ GetDiag()
member GetDiag : unit -> Matrix<'TDepth>

Return Value

Type: Matrix TDepth
The main diagonal element of this matrix
See Also

Reference

MatrixTDepth Class
GetDiag Overload
Emgu.CV Namespace


Matrix(TDepth).GetDiag Method (Int32)

MatrixTDepthGetDiag Method (Int32)

http://www.emgu.com
Return the specific diagonal elements of this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> GetDiag(
    int diag
)
Public Function GetDiag (
    diag As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ GetDiag(
    int diag
)
member GetDiag :
        diag : int -> Matrix<'TDepth>

Parameters

diag
Type: SystemInt32
Array diagonal. Zero corresponds to the main diagonal, -1 corresponds to the diagonal above the main etc., 1 corresponds to the diagonal below the main etc

Return Value

Type: Matrix TDepth
The specific diagonal elements of this matrix
See Also

Reference

MatrixTDepth Class
GetDiag Overload
Emgu.CV Namespace


Matrix(TDepth).GetRow Method

MatrixTDepthGetRow Method

Get the specific row of the matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> GetRow(
    int row
)
Public Function GetRow (
    row As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ GetRow(
    int row
)
member GetRow :
        row : int -> Matrix<'TDepth>

Parameters

row
Type: SystemInt32
the index of the row to be reterived

Return Value

Type: Matrix TDepth
the specific row of the matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).GetRows Method

MatrixTDepthGetRows Method

Return the matrix corresponding to a specified row span of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> GetRows(
    int startRow,
    int endRow,
    int deltaRow
)
Public Function GetRows (
    startRow As Integer,
    endRow As Integer,
    deltaRow As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ GetRows(
    int startRow,
    int endRow,
    int deltaRow
)
member GetRows :
        startRow : int *
        endRow : int *
        deltaRow : int -> Matrix<'TDepth>

Parameters

startRow
Type: SystemInt32
Zero-based index of the starting row (inclusive) of the span
endRow
Type: SystemInt32
Zero-based index of the ending row (exclusive) of the span
deltaRow
Type: SystemInt32
Index step in the row span. That is, the function extracts every delta_row-th row from start_row and up to (but not including) end_row

Return Value

Type: Matrix TDepth
A matrix corresponding to a specified row span of the input array
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).GetSubRect Method

MatrixTDepthGetSubRect Method

Get a submatrix corresponding to a specified rectangle

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> GetSubRect(
    Rectangle rect
)
Public Function GetSubRect (
    rect As Rectangle
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ GetSubRect(
    Rectangle^ rect
)
member GetSubRect :
        rect : Rectangle -> Matrix<'TDepth>

Parameters

rect
Type: System.DrawingRectangle
the rectangle area of the sub-matrix

Return Value

Type: Matrix TDepth
A submatrix corresponding to a specified rectangle
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).MinMax Method

MatrixTDepthMinMax Method

Returns the min / max locations and values for the matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MinMax(
    out double minValue,
    out double maxValue,
    out Point minLocation,
    out Point maxLocation,
    IInputArray mask = null
)
Public Sub MinMax (
    <OutAttribute> ByRef minValue As Double,
    <OutAttribute> ByRef maxValue As Double,
    <OutAttribute> ByRef minLocation As Point,
    <OutAttribute> ByRef maxLocation As Point,
    Optional mask As IInputArray = Nothing
)
public:
void MinMax(
    [OutAttribute] double% minValue,
    [OutAttribute] double% maxValue,
    [OutAttribute] Point^% minLocation,
    [OutAttribute] Point^% maxLocation,
    IInputArray^ mask = nullptr
)
member MinMax :
        minValue : float byref *
        maxValue : float byref *
        minLocation : Point byref *
        maxLocation : Point byref *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

minValue
Type: SystemDouble
The minimum value
maxValue
Type: SystemDouble
The maximum value
minLocation
Type: System.DrawingPoint
The minimum location
maxLocation
Type: System.DrawingPoint
The maximum location
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Mul Method

MatrixTDepthMul Method

Overload List
 | Name | Description
Public method | Mul(Double) | Multiply the current matrix with scale
Public method | Mul(MatrixTDepth) | Multiply the current matrix with mat2
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Mul Method (Double)

MatrixTDepthMul Method (Double)

http://www.emgu.com
Multiply the current matrix with scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Mul(
    double scale
)
Public Function Mul (
    scale As Double
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Mul(
    double scale
)
member Mul :
        scale : float -> Matrix<'TDepth>

Parameters

scale
Type: SystemDouble
The scale to be multiplied

Return Value

Type: Matrix TDepth
The scaled matrix
See Also

Reference

MatrixTDepth Class
Mul Overload
Emgu.CV Namespace


Matrix(TDepth).Mul Method (Matrix(TDepth))

MatrixTDepthMul Method (MatrixTDepth)

http://www.emgu.com
Multiply the current matrix with mat2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Mul(
    Matrix<TDepth> mat2
)
Public Function Mul (
    mat2 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Mul(
    Matrix<TDepth>^ mat2
)
member Mul :
        mat2 : Matrix<'TDepth> -> Matrix<'TDepth>

Parameters

mat2
Type: Emgu.CVMatrix TDepth
The matrix to be multiplied

Return Value

Type: Matrix TDepth
Result matrix of the multiplication
See Also

Reference

MatrixTDepth Class
Mul Overload
Emgu.CV Namespace


Matrix(TDepth).RemoveCols Method

MatrixTDepthRemoveCols Method

Return the matrix without a specified column span of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> RemoveCols(
    int startCol,
    int endCol
)
Public Function RemoveCols (
    startCol As Integer,
    endCol As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ RemoveCols(
    int startCol,
    int endCol
)
member RemoveCols :
        startCol : int *
        endCol : int -> Matrix<'TDepth>

Parameters

startCol
Type: SystemInt32
Zero-based index of the starting column (inclusive) of the span
endCol
Type: SystemInt32
Zero-based index of the ending column (exclusive) of the span

Return Value

Type: Matrix TDepth
The matrix without a specified column span of the input array
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).RemoveRows Method

MatrixTDepthRemoveRows Method

Return the matrix without a specified row span of the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> RemoveRows(
    int startRow,
    int endRow
)
Public Function RemoveRows (
    startRow As Integer,
    endRow As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ RemoveRows(
    int startRow,
    int endRow
)
member RemoveRows :
        startRow : int *
        endRow : int -> Matrix<'TDepth>

Parameters

startRow
Type: SystemInt32
Zero-based index of the starting row (inclusive) of the span
endRow
Type: SystemInt32
Zero-based index of the ending row (exclusive) of the span

Return Value

Type: Matrix TDepth
The matrix without a specified row span of the input array
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Reshape Method

MatrixTDepthReshape Method

Get reshaped matrix which also share the same data with the current matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Reshape(
    int newChannels,
    int newRows
)
Public Function Reshape (
    newChannels As Integer,
    newRows As Integer
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Reshape(
    int newChannels,
    int newRows
)
member Reshape :
        newChannels : int *
        newRows : int -> Matrix<'TDepth>

Parameters

newChannels
Type: SystemInt32
the new number of channles
newRows
Type: SystemInt32
The new number of rows

Return Value

Type: Matrix TDepth
A reshaped matrix which also share the same data with the current matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Split Method

MatrixTDepthSplit Method

Get all channels for the multi channel matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth>[] Split()
Public Function Split As Matrix(Of TDepth)()
public:
array<Matrix<TDepth>^>^ Split()
member Split : unit -> Matrix<'TDepth>[]

Return Value

Type: Matrix TDepth
Each individual channel of this matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Sub Method

MatrixTDepthSub Method

Overload List
 | Name | Description
Public method | Sub(TDepth) | Elementwise subtract a color val to the current matrix
Public method | Sub(MatrixTDepth) | Elementwise subtract another matrix from the current matrix
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Sub Method (TDepth)

MatrixTDepthSub Method (TDepth)

http://www.emgu.com
Elementwise subtract a color val to the current matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Sub(
    TDepth val
)
Public Function Sub (
    val As TDepth
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Sub(
    TDepth val
)
member Sub :
        val : 'TDepth -> Matrix<'TDepth>

Parameters

val
Type: TDepth
The value to be subtracted from the current matrix

Return Value

Type: Matrix TDepth
The result of elementwise subtracting val from the current matrix
See Also

Reference

MatrixTDepth Class
Sub Overload
Emgu.CV Namespace


Matrix(TDepth).Sub Method (Matrix(TDepth))

MatrixTDepthSub Method (MatrixTDepth)

http://www.emgu.com
Elementwise subtract another matrix from the current matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Sub(
    Matrix<TDepth> mat2
)
Public Function Sub (
    mat2 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Sub(
    Matrix<TDepth>^ mat2
)
member Sub :
        mat2 : Matrix<'TDepth> -> Matrix<'TDepth>

Parameters

mat2
Type: Emgu.CVMatrix TDepth
The matrix to be subtracted to the current matrix

Return Value

Type: Matrix TDepth
The result of elementwise subtracting mat2 from the current matrix
See Also

Reference

MatrixTDepth Class
Sub Overload
Emgu.CV Namespace


Matrix(TDepth).SubR Method

MatrixTDepthSubR Method

result = val - this

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> SubR(
    TDepth val
)
Public Function SubR (
    val As TDepth
) As Matrix(Of TDepth)
public:
Matrix<TDepth>^ SubR(
    TDepth val
)
member SubR :
        val : 'TDepth -> Matrix<'TDepth>

Parameters

val
Type: TDepth
The value which subtract this matrix

Return Value

Type: Matrix TDepth
val - this
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Transpose Method

MatrixTDepthTranspose Method

Returns the transpose of this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> Transpose()
Public Function Transpose As Matrix(Of TDepth)
public:
Matrix<TDepth>^ Transpose()
member Transpose : unit -> Matrix<'TDepth>

Return Value

Type: Matrix TDepth
The transpose of this matrix
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth) Operators

MatrixTDepth Operators

The MatrixTDepth generic type exposes the following members.

Operators
Name | Description
Addition(Double, MatrixTDepth) | val + mat1
Addition(MatrixTDepth, MatrixTDepth) | Elementwise add mat1 with mat2
Addition(MatrixTDepth, Double) | Elementwise add mat1 with val
Division | mat1 / val
Multiply(Double, MatrixTDepth) | val * mat1
Multiply(MatrixTDepth, MatrixTDepth) | mat1 * mat2
Multiply(MatrixTDepth, Double) | mat1 * val
Subtraction(Double, MatrixTDepth) | val - mat1
Subtraction(MatrixTDepth, MatrixTDepth) | mat1 - mat2
Subtraction(MatrixTDepth, Double) | mat1 - val
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Addition Operator

MatrixTDepthAddition Operator

Overload List
Name | Description
Addition(Double, MatrixTDepth) | val + mat1
Addition(MatrixTDepth, MatrixTDepth) | Elementwise add mat1 with mat2
Addition(MatrixTDepth, Double) | Elementwise add mat1 with val
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Addition Operator (Double, Matrix(TDepth))

MatrixTDepthAddition Operator (Double, MatrixTDepth)

http://www.emgu.com
val + mat1

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator +(
    double val,
    Matrix<TDepth> mat1
)
Public Shared Operator + (
    val As Double,
    mat1 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator +(
    double val,
    Matrix<TDepth>^ mat1
)
static let inline (+)
        val : float *
        mat1 : Matrix<'TDepth>  : Matrix<'TDepth>

Parameters

val
Type: SystemDouble
The value to be added
mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be added

Return Value

Type: Matrix TDepth
The matrix plus the value
See Also

Reference

MatrixTDepth Class
Addition Overload
Emgu.CV Namespace


Matrix(TDepth).Addition Operator (Matrix(TDepth), Matrix(TDepth))

MatrixTDepthAddition Operator (MatrixTDepth, MatrixTDepth)

http://www.emgu.com
Elementwise add mat1 with mat2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator +(
    Matrix<TDepth> mat1,
    Matrix<TDepth> mat2
)
Public Shared Operator + (
    mat1 As Matrix(Of TDepth),
    mat2 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator +(
    Matrix<TDepth>^ mat1,
    Matrix<TDepth>^ mat2
)
static let inline (+)
        mat1 : Matrix<'TDepth> *
        mat2 : Matrix<'TDepth>  : Matrix<'TDepth>

Parameters

mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be added
mat2
Type: Emgu.CVMatrix TDepth
The Matrix to be added

Return Value

Type: Matrix TDepth
The elementwise sum of the two matrices
See Also

Reference

MatrixTDepth Class
Addition Overload
Emgu.CV Namespace


Matrix(TDepth).Addition Operator (Matrix(TDepth), Double)

MatrixTDepthAddition Operator (MatrixTDepth, Double)

http://www.emgu.com
Elementwise add mat1 with val

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator +(
    Matrix<TDepth> mat1,
    double val
)
Public Shared Operator + (
    mat1 As Matrix(Of TDepth),
    val As Double
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator +(
    Matrix<TDepth>^ mat1,
    double val
)
static let inline (+)
        mat1 : Matrix<'TDepth> *
        val : float  : Matrix<'TDepth>

Parameters

mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be added
val
Type: SystemDouble
The value to be added

Return Value

Type: Matrix TDepth
The matrix plus the value
See Also

Reference

MatrixTDepth Class
Addition Overload
Emgu.CV Namespace


Matrix(TDepth).Division Operator

MatrixTDepthDivision Operator

mat1 / val

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator /(
    Matrix<TDepth> mat1,
    double val
)
Public Shared Operator / (
    mat1 As Matrix(Of TDepth),
    val As Double
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator /(
    Matrix<TDepth>^ mat1,
    double val
)
static let inline (/)
        mat1 : Matrix<'TDepth> *
        val : float  : Matrix<'TDepth>

Parameters

mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be divided
val
Type: SystemDouble
The value to be divided

Return Value

Type: Matrix TDepth
mat1 / val
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Multiply Operator

MatrixTDepthMultiply Operator

Overload List
Name | Description
Multiply(Double, MatrixTDepth) | val * mat1
Multiply(MatrixTDepth, MatrixTDepth) | mat1 * mat2
Multiply(MatrixTDepth, Double) | mat1 * val
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Multiply Operator (Double, Matrix(TDepth))

MatrixTDepthMultiply Operator (Double, MatrixTDepth)

http://www.emgu.com
val * mat1

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator *(
    double val,
    Matrix<TDepth> mat1
)
Public Shared Operator * (
    val As Double,
    mat1 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator *(
    double val,
    Matrix<TDepth>^ mat1
)
static let inline (*)
        val : float *
        mat1 : Matrix<'TDepth>  : Matrix<'TDepth>

Parameters

val
Type: SystemDouble
The value to be multiplied
mat1
Type: Emgu.CVMatrix TDepth
The matrix to be multiplied

Return Value

Type: Matrix TDepth
val * mat1
See Also

Reference

MatrixTDepth Class
Multiply Overload
Emgu.CV Namespace


Matrix(TDepth).Multiply Operator (Matrix(TDepth), Matrix(TDepth))

MatrixTDepthMultiply Operator (MatrixTDepth, MatrixTDepth)

http://www.emgu.com
mat1 * mat2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator *(
    Matrix<TDepth> mat1,
    Matrix<TDepth> mat2
)
Public Shared Operator * (
    mat1 As Matrix(Of TDepth),
    mat2 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator *(
    Matrix<TDepth>^ mat1,
    Matrix<TDepth>^ mat2
)
static let inline (*)
        mat1 : Matrix<'TDepth> *
        mat2 : Matrix<'TDepth>  : Matrix<'TDepth>

Parameters

mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be multiplied
mat2
Type: Emgu.CVMatrix TDepth
The Matrix to be multiplied

Return Value

Type: Matrix TDepth
mat1 * mat2
See Also

Reference

MatrixTDepth Class
Multiply Overload
Emgu.CV Namespace


Matrix(TDepth).Multiply Operator (Matrix(TDepth), Double)

MatrixTDepthMultiply Operator (MatrixTDepth, Double)

http://www.emgu.com
mat1 * val

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator *(
    Matrix<TDepth> mat1,
    double val
)
Public Shared Operator * (
    mat1 As Matrix(Of TDepth),
    val As Double
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator *(
    Matrix<TDepth>^ mat1,
    double val
)
static let inline (*)
        mat1 : Matrix<'TDepth> *
        val : float  : Matrix<'TDepth>

Parameters

mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be multiplied
val
Type: SystemDouble
The value to be multiplied

Return Value

Type: Matrix TDepth
mat1 * val
See Also

Reference

MatrixTDepth Class
Multiply Overload
Emgu.CV Namespace


Matrix(TDepth).Subtraction Operator

MatrixTDepthSubtraction Operator

Overload List
Name | Description
Subtraction(Double, MatrixTDepth) | val - mat1
Subtraction(MatrixTDepth, MatrixTDepth) | mat1 - mat2
Subtraction(MatrixTDepth, Double) | mat1 - val
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


Matrix(TDepth).Subtraction Operator (Double, Matrix(TDepth))

MatrixTDepthSubtraction Operator (Double, MatrixTDepth)

http://www.emgu.com
val - mat1

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator -(
    double val,
    Matrix<TDepth> mat1
)
Public Shared Operator - (
    val As Double,
    mat1 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator -(
    double val,
    Matrix<TDepth>^ mat1
)
static let inline (-)
        val : float *
        mat1 : Matrix<'TDepth>  : Matrix<'TDepth>

Parameters

val
Type: SystemDouble
The value to be subtracted
mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be subtracted

Return Value

Type: Matrix TDepth
val - mat1
See Also

Reference

MatrixTDepth Class
Subtraction Overload
Emgu.CV Namespace


Matrix(TDepth).Subtraction Operator (Matrix(TDepth), Matrix(TDepth))

MatrixTDepthSubtraction Operator (MatrixTDepth, MatrixTDepth)

http://www.emgu.com
mat1 - mat2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator -(
    Matrix<TDepth> mat1,
    Matrix<TDepth> mat2
)
Public Shared Operator - (
    mat1 As Matrix(Of TDepth),
    mat2 As Matrix(Of TDepth)
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator -(
    Matrix<TDepth>^ mat1,
    Matrix<TDepth>^ mat2
)
static let inline (-)
        mat1 : Matrix<'TDepth> *
        mat2 : Matrix<'TDepth>  : Matrix<'TDepth>

Parameters

mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be subtracted
mat2
Type: Emgu.CVMatrix TDepth
The matrix to subtract

Return Value

Type: Matrix TDepth
mat1 - mat2
See Also

Reference

MatrixTDepth Class
Subtraction Overload
Emgu.CV Namespace


Matrix(TDepth).Subtraction Operator (Matrix(TDepth), Double)

MatrixTDepthSubtraction Operator (MatrixTDepth, Double)

http://www.emgu.com
mat1 - val

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<TDepth> operator -(
    Matrix<TDepth> mat1,
    double val
)
Public Shared Operator - (
    mat1 As Matrix(Of TDepth),
    val As Double
) As Matrix(Of TDepth)
public:
static Matrix<TDepth>^ operator -(
    Matrix<TDepth>^ mat1,
    double val
)
static let inline (-)
        mat1 : Matrix<'TDepth> *
        val : float  : Matrix<'TDepth>

Parameters

mat1
Type: Emgu.CVMatrix TDepth
The Matrix to be subtracted
val
Type: SystemDouble
The value to be subtracted

Return Value

Type: Matrix TDepth
mat1 - val
See Also

Reference

MatrixTDepth Class
Subtraction Overload
Emgu.CV Namespace


Matrix(TDepth) Fields

MatrixTDepth Fields

The MatrixTDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MatrixTDepth Class
Emgu.CV Namespace


MergeDebevec Class

The resulting HDR image is calculated as weighted average of the exposures considering exposure values and camera response.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMergeExposures
Emgu.CVMergeDebevec

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MergeDebevec : MergeExposures
Public Class MergeDebevec
    Inherits MergeExposures
public ref class MergeDebevec : public MergeExposures
type MergeDebevec =
    class
        inherit MergeExposures
    end

The MergeDebevec type exposes the following members.

Constructors
 | Name | Description
Public method | MergeDebevec | Creates MergeDebevec object.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the MergeDebevec object (Overrides MergeExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Merges images. (Inherited from MergeExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object (Inherited from MergeExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


MergeDebevec Constructor

Creates MergeDebevec object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MergeDebevec()
Public Sub New
public:
MergeDebevec()
new : unit -> MergeDebevec
See Also

Reference

MergeDebevec Class
Emgu.CV Namespace


MergeDebevec Properties

The MergeDebevec type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeDebevec Class
Emgu.CV Namespace


MergeDebevec Methods

The MergeDebevec type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the MergeDebevec object (Overrides MergeExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Merges images. (Inherited from MergeExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeDebevec Class
Emgu.CV Namespace


MergeDebevec.DisposeObject Method

MergeDebevecDisposeObject Method

Release the MergeDebevec object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MergeDebevec Class
Emgu.CV Namespace


MergeDebevec Fields

The MergeDebevec type exposes the following members.

Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object (Inherited from MergeExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeDebevec Class
Emgu.CV Namespace


MergeExposures Class

The base class algorithms that can merge exposure sequence to a single image.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMergeExposures
Emgu.CVMergeDebevec
Emgu.CVMergeMertens
Emgu.CVMergeRobertson

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class MergeExposures : UnmanagedObject
Public MustInherit Class MergeExposures
    Inherits UnmanagedObject
public ref class MergeExposures abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type MergeExposures =
    class
        inherit UnmanagedObject
    end

The MergeExposures type exposes the following members.

Constructors
 | Name | Description
Protected method | MergeExposures | Initializes a new instance of the MergeExposures class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the native pointer to the MergeExposure object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Merges images.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


MergeExposures Constructor

Initializes a new instance of the MergeExposures class

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected MergeExposures()
Protected Sub New
protected:
MergeExposures()
new : unit -> MergeExposures
See Also

Reference

MergeExposures Class
Emgu.CV Namespace


MergeExposures Properties

The MergeExposures type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeExposures Class
Emgu.CV Namespace


MergeExposures Methods

The MergeExposures type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the native pointer to the MergeExposure object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Merges images.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeExposures Class
Emgu.CV Namespace


MergeExposures.DisposeObject Method

MergeExposuresDisposeObject Method

Reset the native pointer to the MergeExposure object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MergeExposures Class
Emgu.CV Namespace


MergeExposures.Process Method

MergeExposuresProcess Method

Merges images.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Process(
    IInputArray src,
    IOutputArray dst,
    IInputArray times,
    IInputArray response
)
Public Sub Process (
    src As IInputArray,
    dst As IOutputArray,
    times As IInputArray,
    response As IInputArray
)
public:
void Process(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ times,
    IInputArray^ response
)
member Process :
        src : IInputArray *
        dst : IOutputArray *
        times : IInputArray *
        response : IInputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Vector of input images
dst
Type: Emgu.CVIOutputArray
Result image
times
Type: Emgu.CVIInputArray
Vector of exposure time values for each image
response
Type: Emgu.CVIInputArray
256x1 matrix with inverse camera response function for each pixel value, it should have the same number of channels as images.
See Also

Reference

MergeExposures Class
Emgu.CV Namespace


MergeExposures Fields

The MergeExposures type exposes the following members.

Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeExposures Class
Emgu.CV Namespace


MergeExposures._mergeExposuresPtr Field

MergeExposures_mergeExposuresPtr Field

The pointer to the unmanaged MergeExposure object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _mergeExposuresPtr
Protected _mergeExposuresPtr As IntPtr
protected:
IntPtr _mergeExposuresPtr
val mutable _mergeExposuresPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MergeExposures Class
Emgu.CV Namespace


MergeMertens Class

Pixels are weighted using contrast, saturation and well-exposedness measures, than images are combined using laplacian pyramids. The resulting image weight is constructed as weighted average of contrast, saturation and well-exposedness measures. The resulting image doesn't require tonemapping and can be converted to 8-bit image by multiplying by 255, but it's recommended to apply gamma correction and/or linear tonemapping.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMergeExposures
Emgu.CVMergeMertens

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MergeMertens : MergeExposures
Public Class MergeMertens
    Inherits MergeExposures
public ref class MergeMertens : public MergeExposures
type MergeMertens =
    class
        inherit MergeExposures
    end

The MergeMertens type exposes the following members.

Constructors
 | Name | Description
Public method | MergeMertens | Creates MergeMertens object.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this MergeMertens object (Overrides MergeExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process(IInputArray, IOutputArray) | Merges images.
Public method | Process(IInputArray, IOutputArray, IInputArray, IInputArray) | Merges images. (Inherited from MergeExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object (Inherited from MergeExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


MergeMertens Constructor

Creates MergeMertens object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MergeMertens(
    float contrastWeight = 1f,
    float saturationWeight = 1f,
    float exposureWeight = 0f
)
Public Sub New (
    Optional contrastWeight As Single = 1F,
    Optional saturationWeight As Single = 1F,
    Optional exposureWeight As Single = 0F
)
public:
MergeMertens(
    float contrastWeight = 1f,
    float saturationWeight = 1f,
    float exposureWeight = 0f
)
new :
        ?contrastWeight : float32 *
        ?saturationWeight : float32 *
        ?exposureWeight : float32
(* Defaults:
        let _contrastWeight = defaultArg contrastWeight 1f
        let _saturationWeight = defaultArg saturationWeight 1f
        let _exposureWeight = defaultArg exposureWeight 0f
*)
-> MergeMertens

Parameters

contrastWeight (Optional)
Type: SystemSingle
contrast measure weight.
saturationWeight (Optional)
Type: SystemSingle
saturation measure weight
exposureWeight (Optional)
Type: SystemSingle
well-exposedness measure weight
See Also

Reference

MergeMertens Class
Emgu.CV Namespace


MergeMertens Properties

The MergeMertens type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeMertens Class
Emgu.CV Namespace


MergeMertens Methods

The MergeMertens type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this MergeMertens object (Overrides MergeExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process(IInputArray, IOutputArray) | Merges images.
Public method | Process(IInputArray, IOutputArray, IInputArray, IInputArray) | Merges images. (Inherited from MergeExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeMertens Class
Emgu.CV Namespace


MergeMertens.DisposeObject Method

MergeMertensDisposeObject Method

Release the unmanaged memory associated with this MergeMertens object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MergeMertens Class
Emgu.CV Namespace


MergeMertens.Process Method

MergeMertensProcess Method

Overload List
 | Name | Description
Public method | Process(IInputArray, IOutputArray) | Merges images.
Public method | Process(IInputArray, IOutputArray, IInputArray, IInputArray) | Merges images. (Inherited from MergeExposures.)
Top
See Also

Reference

MergeMertens Class
Emgu.CV Namespace


MergeMertens.Process Method (IInputArray, IOutputArray)

MergeMertensProcess Method (IInputArray, IOutputArray)

http://www.emgu.com
Merges images.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Process(
    IInputArray src,
    IOutputArray dst
)
Public Sub Process (
    src As IInputArray,
    dst As IOutputArray
)
public:
void Process(
    IInputArray^ src,
    IOutputArray^ dst
)
member Process :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Vector of input images
dst
Type: Emgu.CVIOutputArray
Result image
See Also

Reference

MergeMertens Class
Process Overload
Emgu.CV Namespace


MergeMertens Fields

The MergeMertens type exposes the following members.

Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object (Inherited from MergeExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeMertens Class
Emgu.CV Namespace


MergeRobertson Class

The resulting HDR image is calculated as weighted average of the exposures considering exposure values and camera response
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMergeExposures
Emgu.CVMergeRobertson

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MergeRobertson : MergeExposures
Public Class MergeRobertson
    Inherits MergeExposures
public ref class MergeRobertson : public MergeExposures
type MergeRobertson =
    class
        inherit MergeExposures
    end

The MergeRobertson type exposes the following members.

Constructors
 | Name | Description
Public method | MergeRobertson | Creates MergeRobertson object.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this MergeRobertson object (Overrides MergeExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Merges images. (Inherited from MergeExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object (Inherited from MergeExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


MergeRobertson Constructor

Creates MergeRobertson object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MergeRobertson()
Public Sub New
public:
MergeRobertson()
new : unit -> MergeRobertson
See Also

Reference

MergeRobertson Class
Emgu.CV Namespace


MergeRobertson Properties

The MergeRobertson type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeRobertson Class
Emgu.CV Namespace


MergeRobertson Methods

The MergeRobertson type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this MergeRobertson object (Overrides MergeExposuresDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Merges images. (Inherited from MergeExposures.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeRobertson Class
Emgu.CV Namespace


MergeRobertson.DisposeObject Method

MergeRobertsonDisposeObject Method

Release the unmanaged memory associated with this MergeRobertson object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MergeRobertson Class
Emgu.CV Namespace


MergeRobertson Fields

The MergeRobertson type exposes the following members.

Fields
 | Name | Description
Protected field | _mergeExposuresPtr | The pointer to the unmanaged MergeExposure object (Inherited from MergeExposures.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MergeRobertson Class
Emgu.CV Namespace


Moments Class

The equivalent of cv::Moments
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMoments

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Moments : UnmanagedObject
Public Class Moments
    Inherits UnmanagedObject
public ref class Moments : public UnmanagedObject
type Moments =
    class
        inherit UnmanagedObject
    end

The Moments type exposes the following members.

Constructors
 | Name | Description
Public method | Moments | Create an empty Moment object
Top
Properties
 | Name | Description
Public property | GravityCenter | The Gravity Center of this Moment
Public property | M00 | M00
Public property | M01 | M01
Public property | M02 | M02
Public property | M03 | M03
Public property | M10 | M10
Public property | M11 | M11
Public property | M12 | M12
Public property | M20 | M20
Public property | M21 | M21
Public property | M30 | M30
Public property | Mu02 | Mu02
Public property | Mu03 | Mu03
Public property | Mu11 | Mu11
Public property | Mu12 | Mu12
Public property | Mu20 | Mu20
Public property | Mu21 | Mu21
Public property | Mu30 | Mu30
Public property | Nu02 | Nu02
Public property | Nu03 | Nu03
Public property | Nu11 | Nu11
Public property | Nu12 | Nu12
Public property | Nu20 | Nu20
Public property | Nu21 | Nu21
Public property | Nu30 | Nu30
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


Moments Constructor

Create an empty Moment object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Moments()
Public Sub New
public:
Moments()
new : unit -> Moments
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments Properties

The Moments type exposes the following members.

Properties
 | Name | Description
Public property | GravityCenter | The Gravity Center of this Moment
Public property | M00 | M00
Public property | M01 | M01
Public property | M02 | M02
Public property | M03 | M03
Public property | M10 | M10
Public property | M11 | M11
Public property | M12 | M12
Public property | M20 | M20
Public property | M21 | M21
Public property | M30 | M30
Public property | Mu02 | Mu02
Public property | Mu03 | Mu03
Public property | Mu11 | Mu11
Public property | Mu12 | Mu12
Public property | Mu20 | Mu20
Public property | Mu21 | Mu21
Public property | Mu30 | Mu30
Public property | Nu02 | Nu02
Public property | Nu03 | Nu03
Public property | Nu11 | Nu11
Public property | Nu12 | Nu12
Public property | Nu20 | Nu20
Public property | Nu21 | Nu21
Public property | Nu30 | Nu30
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.GravityCenter Property

MomentsGravityCenter Property

The Gravity Center of this Moment

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint2D64f GravityCenter { get; }
Public ReadOnly Property GravityCenter As MCvPoint2D64f
    Get
public:
property MCvPoint2D64f^ GravityCenter {
    MCvPoint2D64f^ get ();
}
member GravityCenter : MCvPoint2D64f with get

Property Value

Type: MCvPoint2D64f
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M00 Property

MomentsM00 Property

M00

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M00 { get; set; }
Public Property M00 As Double
    Get
    Set
public:
property double M00 {
    double get ();
    void set (double value);
}
member M00 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M01 Property

MomentsM01 Property

M01

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M01 { get; set; }
Public Property M01 As Double
    Get
    Set
public:
property double M01 {
    double get ();
    void set (double value);
}
member M01 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M02 Property

MomentsM02 Property

M02

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M02 { get; set; }
Public Property M02 As Double
    Get
    Set
public:
property double M02 {
    double get ();
    void set (double value);
}
member M02 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M03 Property

MomentsM03 Property

M03

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M03 { get; set; }
Public Property M03 As Double
    Get
    Set
public:
property double M03 {
    double get ();
    void set (double value);
}
member M03 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M10 Property

MomentsM10 Property

M10

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M10 { get; set; }
Public Property M10 As Double
    Get
    Set
public:
property double M10 {
    double get ();
    void set (double value);
}
member M10 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M11 Property

MomentsM11 Property

M11

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M11 { get; set; }
Public Property M11 As Double
    Get
    Set
public:
property double M11 {
    double get ();
    void set (double value);
}
member M11 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M12 Property

MomentsM12 Property

M12

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M12 { get; set; }
Public Property M12 As Double
    Get
    Set
public:
property double M12 {
    double get ();
    void set (double value);
}
member M12 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M20 Property

MomentsM20 Property

M20

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M20 { get; set; }
Public Property M20 As Double
    Get
    Set
public:
property double M20 {
    double get ();
    void set (double value);
}
member M20 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M21 Property

MomentsM21 Property

M21

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M21 { get; set; }
Public Property M21 As Double
    Get
    Set
public:
property double M21 {
    double get ();
    void set (double value);
}
member M21 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.M30 Property

MomentsM30 Property

M30

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M30 { get; set; }
Public Property M30 As Double
    Get
    Set
public:
property double M30 {
    double get ();
    void set (double value);
}
member M30 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Mu02 Property

MomentsMu02 Property

Mu02

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Mu02 { get; set; }
Public Property Mu02 As Double
    Get
    Set
public:
property double Mu02 {
    double get ();
    void set (double value);
}
member Mu02 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Mu03 Property

MomentsMu03 Property

Mu03

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Mu03 { get; set; }
Public Property Mu03 As Double
    Get
    Set
public:
property double Mu03 {
    double get ();
    void set (double value);
}
member Mu03 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Mu11 Property

MomentsMu11 Property

Mu11

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Mu11 { get; set; }
Public Property Mu11 As Double
    Get
    Set
public:
property double Mu11 {
    double get ();
    void set (double value);
}
member Mu11 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Mu12 Property

MomentsMu12 Property

Mu12

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Mu12 { get; set; }
Public Property Mu12 As Double
    Get
    Set
public:
property double Mu12 {
    double get ();
    void set (double value);
}
member Mu12 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Mu20 Property

MomentsMu20 Property

Mu20

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Mu20 { get; set; }
Public Property Mu20 As Double
    Get
    Set
public:
property double Mu20 {
    double get ();
    void set (double value);
}
member Mu20 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Mu21 Property

MomentsMu21 Property

Mu21

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Mu21 { get; set; }
Public Property Mu21 As Double
    Get
    Set
public:
property double Mu21 {
    double get ();
    void set (double value);
}
member Mu21 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Mu30 Property

MomentsMu30 Property

Mu30

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Mu30 { get; set; }
Public Property Mu30 As Double
    Get
    Set
public:
property double Mu30 {
    double get ();
    void set (double value);
}
member Mu30 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Nu02 Property

MomentsNu02 Property

Nu02

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu02 { get; set; }
Public Property Nu02 As Double
    Get
    Set
public:
property double Nu02 {
    double get ();
    void set (double value);
}
member Nu02 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Nu03 Property

MomentsNu03 Property

Nu03

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu03 { get; set; }
Public Property Nu03 As Double
    Get
    Set
public:
property double Nu03 {
    double get ();
    void set (double value);
}
member Nu03 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Nu11 Property

MomentsNu11 Property

Nu11

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu11 { get; set; }
Public Property Nu11 As Double
    Get
    Set
public:
property double Nu11 {
    double get ();
    void set (double value);
}
member Nu11 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Nu12 Property

MomentsNu12 Property

Nu12

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu12 { get; set; }
Public Property Nu12 As Double
    Get
    Set
public:
property double Nu12 {
    double get ();
    void set (double value);
}
member Nu12 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Nu20 Property

MomentsNu20 Property

Nu20

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu20 { get; set; }
Public Property Nu20 As Double
    Get
    Set
public:
property double Nu20 {
    double get ();
    void set (double value);
}
member Nu20 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Nu21 Property

MomentsNu21 Property

Nu21

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu21 { get; set; }
Public Property Nu21 As Double
    Get
    Set
public:
property double Nu21 {
    double get ();
    void set (double value);
}
member Nu21 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.Nu30 Property

MomentsNu30 Property

Nu30

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu30 { get; set; }
Public Property Nu30 As Double
    Get
    Set
public:
property double Nu30 {
    double get ();
    void set (double value);
}
member Nu30 : float with get, set

Property Value

Type: Double
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments Methods

The Moments type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments.DisposeObject Method

MomentsDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Moments Class
Emgu.CV Namespace


Moments Fields

The Moments type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Moments Class
Emgu.CV Namespace


MotionHistory Class

The motion history class
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.CVMotionHistory

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MotionHistory : DisposableObject
Public Class MotionHistory
    Inherits DisposableObject
public ref class MotionHistory : public DisposableObject
type MotionHistory =
    class
        inherit DisposableObject
    end

The MotionHistory type exposes the following members.

Constructors
 | Name | Description
Public method | MotionHistory(Double, Double, Double) | Create a motion history object
Public method | MotionHistory(Double, Double, Double, DateTime) | Create a motion history object
Top
Properties
 | Name | Description
Public property | Mask | The motion mask. Do not dispose this image.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMotionComponents | Get a sequence of motion component
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MotionInfo | Given a rectangle area of the motion, output the angle of the motion and the number of pixels that are considered to be motion pixel
Protected method | ReleaseManagedResources | Release any images associated with this object (Overrides DisposableObjectReleaseManagedResources.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Mat) | Update the motion history with the specific image and current timestamp
Public method | Update(Mat, DateTime) | Update the motion history with the specific image and the specific timestamp
Top
Remarks
For help on using this class, take a look at the Motion Detection example
See Also

Reference

Emgu.CV Namespace


MotionHistory Constructor

Overload List
 | Name | Description
Public method | MotionHistory(Double, Double, Double) | Create a motion history object
Public method | MotionHistory(Double, Double, Double, DateTime) | Create a motion history object
Top
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory Constructor (Double, Double, Double)

Create a motion history object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MotionHistory(
    double mhiDuration,
    double maxTimeDelta,
    double minTimeDelta
)
Public Sub New (
    mhiDuration As Double,
    maxTimeDelta As Double,
    minTimeDelta As Double
)
public:
MotionHistory(
    double mhiDuration,
    double maxTimeDelta,
    double minTimeDelta
)
new :
        mhiDuration : float *
        maxTimeDelta : float *
        minTimeDelta : float -> MotionHistory

Parameters

mhiDuration
Type: SystemDouble
In second, the duration of motion history you wants to keep
maxTimeDelta
Type: SystemDouble
In second. Any change happens between a time interval greater than this will not be considered
minTimeDelta
Type: SystemDouble
In second. Any change happens between a time interval smaller than this will not be considered.
See Also

Reference

MotionHistory Class
MotionHistory Overload
Emgu.CV Namespace


MotionHistory Constructor (Double, Double, Double, DateTime)

Create a motion history object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MotionHistory(
    double mhiDuration,
    double maxTimeDelta,
    double minTimeDelta,
    DateTime startTime
)
Public Sub New (
    mhiDuration As Double,
    maxTimeDelta As Double,
    minTimeDelta As Double,
    startTime As DateTime
)
public:
MotionHistory(
    double mhiDuration,
    double maxTimeDelta,
    double minTimeDelta,
    DateTime^ startTime
)
new :
        mhiDuration : float *
        maxTimeDelta : float *
        minTimeDelta : float *
        startTime : DateTime -> MotionHistory

Parameters

mhiDuration
Type: SystemDouble
In second, the duration of motion history you wants to keep
maxTimeDelta
Type: SystemDouble
In second. Any change happens between a time interval larger than this will not be considered
minTimeDelta
Type: SystemDouble
In second. Any change happens between a time interval smaller than this will not be considered.
startTime
Type: SystemDateTime
The start time of the motion history
See Also

Reference

MotionHistory Class
MotionHistory Overload
Emgu.CV Namespace


MotionHistory Properties

The MotionHistory type exposes the following members.

Properties
 | Name | Description
Public property | Mask | The motion mask. Do not dispose this image.
Top
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory.Mask Property

MotionHistoryMask Property

The motion mask. Do not dispose this image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Mask { get; }
Public ReadOnly Property Mask As Mat
    Get
public:
property Mat^ Mask {
    Mat^ get ();
}
member Mask : Mat with get

Property Value

Type: Mat
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory Methods

The MotionHistory type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMotionComponents | Get a sequence of motion component
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MotionInfo | Given a rectangle area of the motion, output the angle of the motion and the number of pixels that are considered to be motion pixel
Protected method | ReleaseManagedResources | Release any images associated with this object (Overrides DisposableObjectReleaseManagedResources.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Mat) | Update the motion history with the specific image and current timestamp
Public method | Update(Mat, DateTime) | Update the motion history with the specific image and the specific timestamp
Top
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory.DisposeObject Method

MotionHistoryDisposeObject Method

Release unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory.GetMotionComponents Method

MotionHistoryGetMotionComponents Method

Get a sequence of motion component

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetMotionComponents(
    IOutputArray segMask,
    VectorOfRect boundingRects
)
Public Sub GetMotionComponents (
    segMask As IOutputArray,
    boundingRects As VectorOfRect
)
public:
void GetMotionComponents(
    IOutputArray^ segMask,
    VectorOfRect^ boundingRects
)
member GetMotionComponents :
        segMask : IOutputArray *
        boundingRects : VectorOfRect -> unit

Parameters

segMask
Type: Emgu.CVIOutputArray
The output mask of motion components
boundingRects
Type: Emgu.CV.UtilVectorOfRect
The bounding rectangles of the motion components
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory.MotionInfo Method

MotionHistoryMotionInfo Method

Given a rectangle area of the motion, output the angle of the motion and the number of pixels that are considered to be motion pixel

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MotionInfo(
    Mat forgroundMask,
    Rectangle motionRectangle,
    out double angle,
    out double motionPixelCount
)
Public Sub MotionInfo (
    forgroundMask As Mat,
    motionRectangle As Rectangle,
    <OutAttribute> ByRef angle As Double,
    <OutAttribute> ByRef motionPixelCount As Double
)
public:
void MotionInfo(
    Mat^ forgroundMask,
    Rectangle^ motionRectangle,
    [OutAttribute] double% angle,
    [OutAttribute] double% motionPixelCount
)
member MotionInfo :
        forgroundMask : Mat *
        motionRectangle : Rectangle *
        angle : float byref *
        motionPixelCount : float byref -> unit

Parameters

forgroundMask
Type: Emgu.CVMat
The foreground mask used to calculate the motion info.
motionRectangle
Type: System.DrawingRectangle
The rectangle area of the motion
angle
Type: SystemDouble
The orientation of the motion
motionPixelCount
Type: SystemDouble
Number of motion pixels within silhouette ROI
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory.ReleaseManagedResources Method

MotionHistoryReleaseManagedResources Method

Release any images associated with this object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void ReleaseManagedResources()
Protected Overrides Sub ReleaseManagedResources
protected:
virtual void ReleaseManagedResources() override
abstract ReleaseManagedResources : unit -> unit
override ReleaseManagedResources : unit -> unit
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory.Update Method

MotionHistoryUpdate Method

Overload List
 | Name | Description
Public method | Update(Mat) | Update the motion history with the specific image and current timestamp
Public method | Update(Mat, DateTime) | Update the motion history with the specific image and the specific timestamp
Top
See Also

Reference

MotionHistory Class
Emgu.CV Namespace


MotionHistory.Update Method (Mat)

MotionHistoryUpdate Method (Mat)

http://www.emgu.com
Update the motion history with the specific image and current timestamp

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    Mat image
)
Public Sub Update (
    image As Mat
)
public:
void Update(
    Mat^ image
)
member Update :
        image : Mat -> unit

Parameters

image
Type: Emgu.CVMat
The image to be added to history
See Also

Reference

MotionHistory Class
Update Overload
Emgu.CV Namespace


MotionHistory.Update Method (Mat, DateTime)

MotionHistoryUpdate Method (Mat, DateTime)

http://www.emgu.com
Update the motion history with the specific image and the specific timestamp

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    Mat foregroundMask,
    DateTime timestamp
)
Public Sub Update (
    foregroundMask As Mat,
    timestamp As DateTime
)
public:
void Update(
    Mat^ foregroundMask,
    DateTime^ timestamp
)
member Update :
        foregroundMask : Mat *
        timestamp : DateTime -> unit

Parameters

foregroundMask
Type: Emgu.CVMat
The foreground of the image to be added to history
timestamp
Type: SystemDateTime
The time when the image is captured
See Also

Reference

MotionHistory Class
Update Overload
Emgu.CV Namespace


OptFlowDeepFlow Class

DeepFlow optical flow algorithm implementation.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CVOptFlowDeepFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class OptFlowDeepFlow : SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
Public Class OptFlowDeepFlow
    Inherits SharedPtrObject
    Implements IDenseOpticalFlow, IAlgorithm
public ref class OptFlowDeepFlow : public SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
type OptFlowDeepFlow =
    class
        inherit SharedPtrObject
        interface IDenseOpticalFlow
        interface IAlgorithm
    end

The OptFlowDeepFlow type exposes the following members.

Constructors
 | Name | Description
Public method | OptFlowDeepFlow | Create an instance of DeepFlow optical flow algorithm.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged cv::Algorithm
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged cv::DenseOpticalFlow
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


OptFlowDeepFlow Constructor

Create an instance of DeepFlow optical flow algorithm.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OptFlowDeepFlow()
Public Sub New
public:
OptFlowDeepFlow()
new : unit -> OptFlowDeepFlow
See Also

Reference

OptFlowDeepFlow Class
Emgu.CV Namespace


OptFlowDeepFlow Properties

The OptFlowDeepFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged cv::Algorithm
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged cv::DenseOpticalFlow
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

OptFlowDeepFlow Class
Emgu.CV Namespace


OptFlowDeepFlow.AlgorithmPtr Property

OptFlowDeepFlowAlgorithmPtr Property

Pointer to the unmanaged cv::Algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

OptFlowDeepFlow Class
Emgu.CV Namespace


OptFlowDeepFlow.DenseOpticalFlowPtr Property

OptFlowDeepFlowDenseOpticalFlowPtr Property

Pointer to the unmanaged cv::DenseOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

OptFlowDeepFlow Class
Emgu.CV Namespace


OptFlowDeepFlow Methods

The OptFlowDeepFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

OptFlowDeepFlow Class
Emgu.CV Namespace


OptFlowDeepFlow.DisposeObject Method

OptFlowDeepFlowDisposeObject Method

Release the unmanaged memory associated with this Object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

OptFlowDeepFlow Class
Emgu.CV Namespace


OptFlowDeepFlow Fields

The OptFlowDeepFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

OptFlowDeepFlow Class
Emgu.CV Namespace


OpticalFlowPCAFlow Class

PCAFlow algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CVOpticalFlowPCAFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class OpticalFlowPCAFlow : SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
Public Class OpticalFlowPCAFlow
    Inherits SharedPtrObject
    Implements IDenseOpticalFlow, IAlgorithm
public ref class OpticalFlowPCAFlow : public SharedPtrObject,
    IDenseOpticalFlow, IAlgorithm
type OpticalFlowPCAFlow =
    class
        inherit SharedPtrObject
        interface IDenseOpticalFlow
        interface IAlgorithm
    end

The OpticalFlowPCAFlow type exposes the following members.

Constructors
 | Name | Description
Public method | OpticalFlowPCAFlow | Creates an instance of PCAFlow
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | DenseOpticalFlowPtr | Pointer to native cv::DenseOpticalFlow
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this PCA Flow algorithm (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


OpticalFlowPCAFlow Constructor

Creates an instance of PCAFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OpticalFlowPCAFlow()
Public Sub New
public:
OpticalFlowPCAFlow()
new : unit -> OpticalFlowPCAFlow
See Also

Reference

OpticalFlowPCAFlow Class
Emgu.CV Namespace


OpticalFlowPCAFlow Properties

The OpticalFlowPCAFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | DenseOpticalFlowPtr | Pointer to native cv::DenseOpticalFlow
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

OpticalFlowPCAFlow Class
Emgu.CV Namespace


OpticalFlowPCAFlow.AlgorithmPtr Property

OpticalFlowPCAFlowAlgorithmPtr Property

Pointer to cv::Algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

OpticalFlowPCAFlow Class
Emgu.CV Namespace


OpticalFlowPCAFlow.DenseOpticalFlowPtr Property

OpticalFlowPCAFlowDenseOpticalFlowPtr Property

Pointer to native cv::DenseOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

OpticalFlowPCAFlow Class
Emgu.CV Namespace


OpticalFlowPCAFlow Methods

The OpticalFlowPCAFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this PCA Flow algorithm (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

OpticalFlowPCAFlow Class
Emgu.CV Namespace


OpticalFlowPCAFlow.DisposeObject Method

OpticalFlowPCAFlowDisposeObject Method

Release the memory associated with this PCA Flow algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

OpticalFlowPCAFlow Class
Emgu.CV Namespace


OpticalFlowPCAFlow Fields

The OpticalFlowPCAFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

OpticalFlowPCAFlow Class
Emgu.CV Namespace


OutputArray Class

This type is very similar to InputArray except that it is used for output function parameters.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVInputArray
Emgu.CVOutputArray
Emgu.CVInputOutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class OutputArray : InputArray
Public Class OutputArray
    Inherits InputArray
public ref class OutputArray : public InputArray
type OutputArray =
    class
        inherit InputArray
    end

The OutputArray type exposes the following members.

Constructors
 | Name | Description
Public method | OutputArray | Create an OutputArray from an existing unmanaged outputArray pointer
Top
Properties
 | Name | Description
Public property | FixedSize | True if the output array is fixed size
Public property | FixedType | True if the output array is fixed type
Public property | IsEmpty | Return true if the input array is empty (Inherited from InputArray.)
Public property | IsMat | True if the input array is a Mat (Inherited from InputArray.)
Public property | IsMatVector | True if the input array is a vector of Mat (Inherited from InputArray.)
Public property | IsMatx | True if the input array is a Matx (Inherited from InputArray.)
Public property | IsUMat | True if the input array is an UMat (Inherited from InputArray.)
Public property | IsUMatVector | True if the input array is a vector of UMat (Inherited from InputArray.)
Public property | Kind | The type of the input array (Inherited from InputArray.)
Public property | Needed | True if the output array is needed
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | CopyTo | Copy this Input array to another. (Inherited from InputArray.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this output array. (Overrides InputArrayDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetChannels | Get the number of channels (Inherited from InputArray.)
Public method | GetDepth | Get the depth type (Inherited from InputArray.)
Public method | GetDims | Get the number of dimensions (Inherited from InputArray.)
 | GetEmpty | Get an empty output array
Public method | GetGpuMat | Get the GpuMat from the input array (Inherited from InputArray.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMat | Get the Mat from the input array (Inherited from InputArray.)
Public method | GetSize | Get the size of the input array (Inherited from InputArray.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Get the UMat from the input array (Inherited from InputArray.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


OutputArray Constructor

Create an OutputArray from an existing unmanaged outputArray pointer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray(
    IntPtr outputArrayPtr,
    Object parent
)
Public Sub New (
    outputArrayPtr As IntPtr,
    parent As Object
)
public:
OutputArray(
    IntPtr outputArrayPtr,
    Object^ parent
)
new :
        outputArrayPtr : IntPtr *
        parent : Object -> OutputArray

Parameters

outputArrayPtr
Type: SystemIntPtr
The pointer to the unmanaged outputArray
parent
Type: SystemObject
The parent object to keep reference to
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray Properties

The OutputArray type exposes the following members.

Properties
 | Name | Description
Public property | FixedSize | True if the output array is fixed size
Public property | FixedType | True if the output array is fixed type
Public property | IsEmpty | Return true if the input array is empty (Inherited from InputArray.)
Public property | IsMat | True if the input array is a Mat (Inherited from InputArray.)
Public property | IsMatVector | True if the input array is a vector of Mat (Inherited from InputArray.)
Public property | IsMatx | True if the input array is a Matx (Inherited from InputArray.)
Public property | IsUMat | True if the input array is an UMat (Inherited from InputArray.)
Public property | IsUMatVector | True if the input array is a vector of UMat (Inherited from InputArray.)
Public property | Kind | The type of the input array (Inherited from InputArray.)
Public property | Needed | True if the output array is needed
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray.FixedSize Property

OutputArrayFixedSize Property

True if the output array is fixed size

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FixedSize { get; }
Public ReadOnly Property FixedSize As Boolean
    Get
public:
property bool FixedSize {
    bool get ();
}
member FixedSize : bool with get

Property Value

Type: Boolean
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray.FixedType Property

OutputArrayFixedType Property

True if the output array is fixed type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FixedType { get; }
Public ReadOnly Property FixedType As Boolean
    Get
public:
property bool FixedType {
    bool get ();
}
member FixedType : bool with get

Property Value

Type: Boolean
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray.Needed Property

OutputArrayNeeded Property

True if the output array is needed

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Needed { get; }
Public ReadOnly Property Needed As Boolean
    Get
public:
property bool Needed {
    bool get ();
}
member Needed : bool with get

Property Value

Type: Boolean
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray Methods

The OutputArray type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copy this Input array to another. (Inherited from InputArray.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this output array. (Overrides InputArrayDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetChannels | Get the number of channels (Inherited from InputArray.)
Public method | GetDepth | Get the depth type (Inherited from InputArray.)
Public method | GetDims | Get the number of dimensions (Inherited from InputArray.)
 | GetEmpty | Get an empty output array
Public method | GetGpuMat | Get the GpuMat from the input array (Inherited from InputArray.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMat | Get the Mat from the input array (Inherited from InputArray.)
Public method | GetSize | Get the size of the input array (Inherited from InputArray.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Get the UMat from the input array (Inherited from InputArray.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray.DisposeObject Method

OutputArrayDisposeObject Method

Release the unmanaged memory associated with this output array.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray.GetEmpty Method

OutputArrayGetEmpty Method

Get an empty output array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static OutputArray GetEmpty()
Public Shared Function GetEmpty As OutputArray
public:
static OutputArray^ GetEmpty()
static member GetEmpty : unit -> OutputArray

Return Value

Type: OutputArray
An empty output array
See Also

Reference

OutputArray Class
Emgu.CV Namespace


OutputArray Fields

The OutputArray type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

OutputArray Class
Emgu.CV Namespace


PointCollection Class

A collection of points
Inheritance Hierarchy
SystemObject
Emgu.CVPointCollection

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class PointCollection
Public NotInheritable Class PointCollection
public ref class PointCollection abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PointCollection =  class end

The PointCollection type exposes the following members.

Methods
Name | Description
BoundingRectangle | Find the bounding rectangle for the specific array of points
EllipseLeastSquareFitting | Fit an ellipse to the points collection
GeneratePointCloud | Generate a random point cloud around the ellipse.
PolyLine(Point, Boolean) | convert a series of System.Drawing.Point to LineSegment2D
PolyLine(PointF, Boolean) | convert a series of points to LineSegment2D
ReprojectImageTo3D | Re-project pixels on a 1-channel disparity map to array of 3D points.
Top
See Also

Reference

Emgu.CV Namespace


PointCollection Methods

The PointCollection type exposes the following members.

Methods
Name | Description
BoundingRectangle | Find the bounding rectangle for the specific array of points
EllipseLeastSquareFitting | Fit an ellipse to the points collection
GeneratePointCloud | Generate a random point cloud around the ellipse.
PolyLine(Point, Boolean) | convert a series of System.Drawing.Point to LineSegment2D
PolyLine(PointF, Boolean) | convert a series of points to LineSegment2D
ReprojectImageTo3D | Re-project pixels on a 1-channel disparity map to array of 3D points.
Top
See Also

Reference

PointCollection Class
Emgu.CV Namespace


PointCollection.BoundingRectangle Method

PointCollectionBoundingRectangle Method

Find the bounding rectangle for the specific array of points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Rectangle BoundingRectangle(
    PointF[] points
)
Public Shared Function BoundingRectangle (
    points As PointF()
) As Rectangle
public:
static Rectangle^ BoundingRectangle(
    array<PointF^>^ points
)
static member BoundingRectangle :
        points : PointF[] -> Rectangle

Parameters

points
Type: System.DrawingPointF
The collection of points

Return Value

Type: Rectangle
The bounding rectangle for the array of points
See Also

Reference

PointCollection Class
Emgu.CV Namespace


PointCollection.EllipseLeastSquareFitting Method

PointCollectionEllipseLeastSquareFitting Method

Fit an ellipse to the points collection

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Ellipse EllipseLeastSquareFitting(
    PointF[] points
)
Public Shared Function EllipseLeastSquareFitting (
    points As PointF()
) As Ellipse
public:
static Ellipse^ EllipseLeastSquareFitting(
    array<PointF^>^ points
)
static member EllipseLeastSquareFitting :
        points : PointF[] -> Ellipse

Parameters

points
Type: System.DrawingPointF
The points to be fitted

Return Value

Type: Ellipse
An ellipse
See Also

Reference

PointCollection Class
Emgu.CV Namespace


PointCollection.GeneratePointCloud Method

PointCollectionGeneratePointCloud Method

Generate a random point cloud around the ellipse.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static PointF[] GeneratePointCloud(
    Ellipse e,
    int numberOfPoints
)
Public Shared Function GeneratePointCloud (
    e As Ellipse,
    numberOfPoints As Integer
) As PointF()
public:
static array<PointF^>^ GeneratePointCloud(
    Ellipse^ e,
    int numberOfPoints
)
static member GeneratePointCloud :
        e : Ellipse *
        numberOfPoints : int -> PointF[]

Parameters

e
Type: Emgu.CV.StructureEllipse
The region where the point cloud will be generated. The axes of e corresponds to std of the random point cloud.
numberOfPoints
Type: SystemInt32
The number of points to be generated

Return Value

Type: PointF
A random point cloud around the ellipse
See Also

Reference

PointCollection Class
Emgu.CV Namespace


PointCollection.PolyLine Method

PointCollectionPolyLine Method

Overload List
Name | Description
PolyLine(Point, Boolean) | convert a series of System.Drawing.Point to LineSegment2D
PolyLine(PointF, Boolean) | convert a series of points to LineSegment2D
Top
See Also

Reference

PointCollection Class
Emgu.CV Namespace


PointCollection.PolyLine Method (Point[], Boolean)

PointCollectionPolyLine Method (Point, Boolean)

http://www.emgu.com
convert a series of System.Drawing.Point to LineSegment2D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static LineSegment2D[] PolyLine(
    Point[] points,
    bool closed
)
Public Shared Function PolyLine (
    points As Point(),
    closed As Boolean
) As LineSegment2D()
public:
static array<LineSegment2D^>^ PolyLine(
    array<Point^>^ points,
    bool closed
)
static member PolyLine :
        points : Point[] *
        closed : bool -> LineSegment2D[]

Parameters

points
Type: System.DrawingPoint
the array of points
closed
Type: SystemBoolean
if true, the last line segment is defined by the last point of the array and the first point of the array

Return Value

Type: LineSegment2D
array of LineSegment2D
See Also

Reference

PointCollection Class
PolyLine Overload
Emgu.CV Namespace


PointCollection.PolyLine Method (PointF[], Boolean)

PointCollectionPolyLine Method (PointF, Boolean)

http://www.emgu.com
convert a series of points to LineSegment2D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static LineSegment2DF[] PolyLine(
    PointF[] points,
    bool closed
)
Public Shared Function PolyLine (
    points As PointF(),
    closed As Boolean
) As LineSegment2DF()
public:
static array<LineSegment2DF^>^ PolyLine(
    array<PointF^>^ points,
    bool closed
)
static member PolyLine :
        points : PointF[] *
        closed : bool -> LineSegment2DF[]

Parameters

points
Type: System.DrawingPointF
the array of points
closed
Type: SystemBoolean
if true, the last line segment is defined by the last point of the array and the first point of the array

Return Value

Type: LineSegment2DF
array of LineSegment2D
See Also

Reference

PointCollection Class
PolyLine Overload
Emgu.CV Namespace


PointCollection.ReprojectImageTo3D Method

PointCollectionReprojectImageTo3D Method

Re-project pixels on a 1-channel disparity map to array of 3D points.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D32f[] ReprojectImageTo3D(
    IInputArray disparity,
    IInputArray Q
)
Public Shared Function ReprojectImageTo3D (
    disparity As IInputArray,
    Q As IInputArray
) As MCvPoint3D32f()
public:
static array<MCvPoint3D32f^>^ ReprojectImageTo3D(
    IInputArray^ disparity,
    IInputArray^ Q
)
static member ReprojectImageTo3D :
        disparity : IInputArray *
        Q : IInputArray -> MCvPoint3D32f[]

Parameters

disparity
Type: Emgu.CVIInputArray
Disparity map
Q
Type: Emgu.CVIInputArray
The re-projection 4x4 matrix, can be arbitrary, e.g. the one, computed by cvStereoRectify

Return Value

Type: MCvPoint3D32f
The reprojected 3D points
See Also

Reference

PointCollection Class
Emgu.CV Namespace


QRCodeDetector Class

A QR code detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVQRCodeDetector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class QRCodeDetector : UnmanagedObject
Public Class QRCodeDetector
    Inherits UnmanagedObject
public ref class QRCodeDetector : public UnmanagedObject
type QRCodeDetector =
    class
        inherit UnmanagedObject
    end

The QRCodeDetector type exposes the following members.

Constructors
 | Name | Description
Public method | QRCodeDetector | Create a new QR code detector
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Decode | Decodes QR code in image once it's found by the detect() method.
Public method | Detect | Detector the location of the QR code
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this HOGDescriptor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetEpsX | EpsX
Public method | SetEpsY | EpsY
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


QRCodeDetector Constructor

Create a new QR code detector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QRCodeDetector()
Public Sub New
public:
QRCodeDetector()
new : unit -> QRCodeDetector
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector Properties

The QRCodeDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector Methods

The QRCodeDetector type exposes the following members.

Methods
 | Name | Description
Public method | Decode | Decodes QR code in image once it's found by the detect() method.
Public method | Detect | Detector the location of the QR code
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this HOGDescriptor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetEpsX | EpsX
Public method | SetEpsY | EpsY
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector.Decode Method

QRCodeDetectorDecode Method

Decodes QR code in image once it's found by the detect() method.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Decode(
    IInputArray image,
    IInputArray points,
    IOutputArray straightQrcode = null
)
Public Function Decode (
    image As IInputArray,
    points As IInputArray,
    Optional straightQrcode As IOutputArray = Nothing
) As String
public:
String^ Decode(
    IInputArray^ image,
    IInputArray^ points,
    IOutputArray^ straightQrcode = nullptr
)
member Decode :
        image : IInputArray *
        points : IInputArray *
        ?straightQrcode : IOutputArray
(* Defaults:
        let _straightQrcode = defaultArg straightQrcode null
*)
-> string

Parameters

image
Type: Emgu.CVIInputArray
grayscale or color (BGR) image containing QR code.
points
Type: Emgu.CVIInputArray
Quadrangle vertices found by detect() method (or some other algorithm).
straightQrcode (Optional)
Type: Emgu.CVIOutputArray
The optional output image containing rectified and binarized QR code

Return Value

Type: String
UTF8-encoded output string or empty string if the code cannot be decoded.
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector.Detect Method

QRCodeDetectorDetect Method

Detector the location of the QR code

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Detect(
    IInputArray input,
    IOutputArray points
)
Public Function Detect (
    input As IInputArray,
    points As IOutputArray
) As Boolean
public:
bool Detect(
    IInputArray^ input,
    IOutputArray^ points
)
member Detect :
        input : IInputArray *
        points : IOutputArray -> bool

Parameters

input
Type: Emgu.CVIInputArray
The input image
points
Type: Emgu.CVIOutputArray
The location of the QR code in the image

Return Value

Type: Boolean
True if a QRCode is found.
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector.DisposeObject Method

QRCodeDetectorDisposeObject Method

Release the unmanaged memory associated with this HOGDescriptor

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector.SetEpsX Method

QRCodeDetectorSetEpsX Method

EpsX

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetEpsX(
    double value
)
Public Sub SetEpsX (
    value As Double
)
public:
void SetEpsX(
    double value
)
member SetEpsX :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector.SetEpsY Method

QRCodeDetectorSetEpsY Method

EpsY

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetEpsY(
    double value
)
Public Sub SetEpsY (
    value As Double
)
public:
void SetEpsY(
    double value
)
member SetEpsY :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


QRCodeDetector Fields

The QRCodeDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

QRCodeDetector Class
Emgu.CV Namespace


Quaternions Class

A unit quaternions that defines rotation in 3D
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CVQuaternions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Quaternions : ValueType,
    IEquatable<Quaternions>
<SerializableAttribute>
Public NotInheritable Class Quaternions
    Inherits ValueType
    Implements IEquatable(Of Quaternions)
[SerializableAttribute]
public ref class Quaternions sealed : public ValueType,
    IEquatable<Quaternions^>
[<SealedAttribute>]
[<SerializableAttribute>]
type Quaternions =
    class
        inherit ValueType
        interface IEquatable<Quaternions>
    end

The Quaternions type exposes the following members.

Constructors
 | Name | Description
Public method | Quaternions | Create a quaternion with the specific values
Top
Properties
 | Name | Description
Public property | AxisAngle | Get or set the equivalent axis angle representation. (x,y,z) is the rotation axis and |(x,y,z)| is the rotation angle in radians
Public property | RotationAngle | Get the rotation angle in radian
Public property | RotationAxis | Get the rotation axis of the quaternion
Public property | W | The W component of the quaternion: the value for cos(rotation angle / 2)
Public property | X | The X component of the vector: rotation axis * sin(rotation angle / 2)
Public property | Y | The Y component of the vector: rotation axis * sin(rotation angle / 2)
Public property | Z | The Z component of the vector: rotation axis * sin(rotation angle / 2)
Top
Methods
 | Name | Description
Public method | Conjugate | Compute the conjugate of the quaternions
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Quaternions) | Check if this quaternions equals to other
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEuler | Get the equivalent euler angle
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetRotationMatrix | Fill the (3x3) rotation matrix with the value such that it represent the quaternions
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Multiply | Multiply the current Quaternions with quaternionsOther
Public method | RotatePoint | Rotate the specific point and return the result
Public method | RotatePoints | Rotate the points in pointsSrc and save the result in pointsDst. In-place operation is supported (pointsSrc == pointsDst).
Public method | SetEuler | Set the value of the quaternions using euler angle
Public method | Slerp | Perform quaternions linear interpolation
Public method | ToString | Get the string representation of the Quaternions (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Multiply | Computes the multiplication of two quaternions
Top
Fields
Name | Description
Empty | Get the quaternions that represent a rotation of 0 degrees.
Top
See Also

Reference

Emgu.CV Namespace


Quaternions Constructor

Create a quaternion with the specific values

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Quaternions(
    double w,
    double x,
    double y,
    double z
)
Public Sub New (
    w As Double,
    x As Double,
    y As Double,
    z As Double
)
public:
Quaternions(
    double w,
    double x,
    double y,
    double z
)
new :
        w : float *
        x : float *
        y : float *
        z : float -> Quaternions

Parameters

w
Type: SystemDouble
The W component of the quaternion: the value for cos(rotation angle / 2)
x
Type: SystemDouble
The X component of the vector: rotation axis * sin(rotation angle / 2)
y
Type: SystemDouble
The Y component of the vector: rotation axis * sin(rotation angle / 2)
z
Type: SystemDouble
The Z component of the vector: rotation axis * sin(rotation angle / 2)
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions Properties

The Quaternions type exposes the following members.

Properties
 | Name | Description
Public property | AxisAngle | Get or set the equivalent axis angle representation. (x,y,z) is the rotation axis and |(x,y,z)| is the rotation angle in radians
Public property | RotationAngle | Get the rotation angle in radian
Public property | RotationAxis | Get the rotation axis of the quaternion
Public property | W | The W component of the quaternion: the value for cos(rotation angle / 2)
Public property | X | The X component of the vector: rotation axis * sin(rotation angle / 2)
Public property | Y | The Y component of the vector: rotation axis * sin(rotation angle / 2)
Public property | Z | The Z component of the vector: rotation axis * sin(rotation angle / 2)
Top
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.AxisAngle Property

QuaternionsAxisAngle Property

Get or set the equivalent axis angle representation. (x,y,z) is the rotation axis and |(x,y,z)| is the rotation angle in radians

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f AxisAngle { get; set; }
Public Property AxisAngle As MCvPoint3D64f
    Get
    Set
public:
property MCvPoint3D64f^ AxisAngle {
    MCvPoint3D64f^ get ();
    void set (MCvPoint3D64f^ value);
}
member AxisAngle : MCvPoint3D64f with get, set

Property Value

Type: MCvPoint3D64f
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.RotationAngle Property

QuaternionsRotationAngle Property

Get the rotation angle in radian

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RotationAngle { get; }
Public ReadOnly Property RotationAngle As Double
    Get
public:
property double RotationAngle {
    double get ();
}
member RotationAngle : float with get

Property Value

Type: Double
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.RotationAxis Property

QuaternionsRotationAxis Property

Get the rotation axis of the quaternion

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f RotationAxis { get; }
Public ReadOnly Property RotationAxis As MCvPoint3D64f
    Get
public:
property MCvPoint3D64f^ RotationAxis {
    MCvPoint3D64f^ get ();
}
member RotationAxis : MCvPoint3D64f with get

Property Value

Type: MCvPoint3D64f
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.W Property

QuaternionsW Property

The W component of the quaternion: the value for cos(rotation angle / 2)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double W { get; set; }
Public Property W As Double
    Get
    Set
public:
property double W {
    double get ();
    void set (double value);
}
member W : float with get, set

Property Value

Type: Double
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.X Property

QuaternionsX Property

The X component of the vector: rotation axis * sin(rotation angle / 2)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double X { get; set; }
Public Property X As Double
    Get
    Set
public:
property double X {
    double get ();
    void set (double value);
}
member X : float with get, set

Property Value

Type: Double
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Y Property

QuaternionsY Property

The Y component of the vector: rotation axis * sin(rotation angle / 2)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Y { get; set; }
Public Property Y As Double
    Get
    Set
public:
property double Y {
    double get ();
    void set (double value);
}
member Y : float with get, set

Property Value

Type: Double
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Z Property

QuaternionsZ Property

The Z component of the vector: rotation axis * sin(rotation angle / 2)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Z { get; set; }
Public Property Z As Double
    Get
    Set
public:
property double Z {
    double get ();
    void set (double value);
}
member Z : float with get, set

Property Value

Type: Double
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions Methods

The Quaternions type exposes the following members.

Methods
 | Name | Description
Public method | Conjugate | Compute the conjugate of the quaternions
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Quaternions) | Check if this quaternions equals to other
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEuler | Get the equivalent euler angle
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetRotationMatrix | Fill the (3x3) rotation matrix with the value such that it represent the quaternions
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Multiply | Multiply the current Quaternions with quaternionsOther
Public method | RotatePoint | Rotate the specific point and return the result
Public method | RotatePoints | Rotate the points in pointsSrc and save the result in pointsDst. In-place operation is supported (pointsSrc == pointsDst).
Public method | SetEuler | Set the value of the quaternions using euler angle
Public method | Slerp | Perform quaternions linear interpolation
Public method | ToString | Get the string representation of the Quaternions (Overrides ValueTypeToString.)
Top
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Conjugate Method

QuaternionsConjugate Method

Compute the conjugate of the quaternions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Conjugate()
Public Sub Conjugate
public:
void Conjugate()
member Conjugate : unit -> unit
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Equals Method

QuaternionsEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Quaternions) | Check if this quaternions equals to other
Top
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Equals Method (Quaternions)

QuaternionsEquals Method (Quaternions)

http://www.emgu.com
Check if this quaternions equals to other

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Quaternions other
)
Public Function Equals (
    other As Quaternions
) As Boolean
public:
virtual bool Equals(
    Quaternions^ other
) sealed
abstract Equals :
        other : Quaternions -> bool
override Equals :
        other : Quaternions -> bool

Parameters

other
Type: Emgu.CVQuaternions
The quaternions to be compared

Return Value

Type: Boolean
True if two quaternions equals, false otherwise

Implements

IEquatableTEquals(T)
See Also

Reference

Quaternions Class
Equals Overload
Emgu.CV Namespace


Quaternions.GetEuler Method

QuaternionsGetEuler Method

Get the equivalent euler angle

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetEuler(
    ref double x,
    ref double y,
    ref double z
)
Public Sub GetEuler (
    ByRef x As Double,
    ByRef y As Double,
    ByRef z As Double
)
public:
void GetEuler(
    double% x,
    double% y,
    double% z
)
member GetEuler :
        x : float byref *
        y : float byref *
        z : float byref -> unit

Parameters

x
Type: SystemDouble
Rotation around x-axis (roll) in radian
y
Type: SystemDouble
Rotation around y-axis (pitch) in radian
z
Type: SystemDouble
rotation around z-axis (yaw) in radian
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.GetRotationMatrix Method

QuaternionsGetRotationMatrix Method

Fill the (3x3) rotation matrix with the value such that it represent the quaternions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetRotationMatrix(
    Matrix<double> rotation
)
Public Sub GetRotationMatrix (
    rotation As Matrix(Of Double)
)
public:
void GetRotationMatrix(
    Matrix<double>^ rotation
)
member GetRotationMatrix :
        rotation : Matrix<float> -> unit

Parameters

rotation
Type: Emgu.CVMatrix Double
The (3x3) rotation matrix which values will be set to represent this quaternions
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Multiply Method

QuaternionsMultiply Method

Multiply the current Quaternions with quaternionsOther

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Quaternions Multiply(
    Quaternions quaternionsOther
)
Public Function Multiply (
    quaternionsOther As Quaternions
) As Quaternions
public:
Quaternions^ Multiply(
    Quaternions^ quaternionsOther
)
member Multiply :
        quaternionsOther : Quaternions -> Quaternions

Parameters

quaternionsOther
Type: Emgu.CVQuaternions
The other rotation

Return Value

Type: Quaternions
A composition of the two rotations
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.RotatePoint Method

QuaternionsRotatePoint Method

Rotate the specific point and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f RotatePoint(
    MCvPoint3D64f point
)
Public Function RotatePoint (
    point As MCvPoint3D64f
) As MCvPoint3D64f
public:
MCvPoint3D64f^ RotatePoint(
    MCvPoint3D64f^ point
)
member RotatePoint :
        point : MCvPoint3D64f -> MCvPoint3D64f

Parameters

point
Type: Emgu.CV.StructureMCvPoint3D64f
The point to be rotated

Return Value

Type: MCvPoint3D64f
The rotated point
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.RotatePoints Method

QuaternionsRotatePoints Method

Rotate the points in pointsSrc and save the result in pointsDst. In-place operation is supported (pointsSrc == pointsDst).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RotatePoints(
    Matrix<double> pointsSrc,
    Matrix<double> pointsDst
)
Public Sub RotatePoints (
    pointsSrc As Matrix(Of Double),
    pointsDst As Matrix(Of Double)
)
public:
void RotatePoints(
    Matrix<double>^ pointsSrc,
    Matrix<double>^ pointsDst
)
member RotatePoints :
        pointsSrc : Matrix<float> *
        pointsDst : Matrix<float> -> unit

Parameters

pointsSrc
Type: Emgu.CVMatrix Double
The points to be rotated
pointsDst
Type: Emgu.CVMatrix Double
The result of the rotation, should be the same size as pointsSrc, can be pointsSrc as well for inplace rotation
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.SetEuler Method

QuaternionsSetEuler Method

Set the value of the quaternions using euler angle

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetEuler(
    double x,
    double y,
    double z
)
Public Sub SetEuler (
    x As Double,
    y As Double,
    z As Double
)
public:
void SetEuler(
    double x,
    double y,
    double z
)
member SetEuler :
        x : float *
        y : float *
        z : float -> unit

Parameters

x
Type: SystemDouble
Rotation around x-axis (roll) in radian
y
Type: SystemDouble
Rotation around y-axis (pitch) in radian
z
Type: SystemDouble
rotation around z-axis (yaw) in radian
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Slerp Method

QuaternionsSlerp Method

Perform quaternions linear interpolation

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Quaternions Slerp(
    Quaternions quaternionsOther,
    double weightForOther
)
Public Function Slerp (
    quaternionsOther As Quaternions,
    weightForOther As Double
) As Quaternions
public:
Quaternions^ Slerp(
    Quaternions^ quaternionsOther,
    double weightForOther
)
member Slerp :
        quaternionsOther : Quaternions *
        weightForOther : float -> Quaternions

Parameters

quaternionsOther
Type: Emgu.CVQuaternions
The other quaternions to interpolate with
weightForOther
Type: SystemDouble
If 0.0, the result is the same as this quaternions. If 1.0 the result is the same as quaternionsOther

Return Value

Type: Quaternions
The linear interpolated quaternions
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.ToString Method

QuaternionsToString Method

Get the string representation of the Quaternions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions Operators

The Quaternions type exposes the following members.

Operators
Name | Description
Multiply | Computes the multiplication of two quaternions
Top
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Multiply Operator

QuaternionsMultiply Operator

Computes the multiplication of two quaternions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Quaternions operator *(
    Quaternions q1,
    Quaternions q2
)
Public Shared Operator * (
    q1 As Quaternions,
    q2 As Quaternions
) As Quaternions
public:
static Quaternions^ operator *(
    Quaternions^ q1,
    Quaternions^ q2
)
static let inline (*)
        q1 : Quaternions *
        q2 : Quaternions  : Quaternions

Parameters

q1
Type: Emgu.CVQuaternions
The quaternions to be multiplied
q2
Type: Emgu.CVQuaternions
The quaternions to be multiplied

Return Value

Type: Quaternions
The multiplication of two quaternions
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions Fields

The Quaternions type exposes the following members.

Fields
Name | Description
Empty | Get the quaternions that represent a rotation of 0 degrees.
Top
See Also

Reference

Quaternions Class
Emgu.CV Namespace


Quaternions.Empty Field

QuaternionsEmpty Field

Get the quaternions that represent a rotation of 0 degrees.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly Quaternions Empty
Public Shared ReadOnly Empty As Quaternions
public:
static initonly Quaternions^ Empty
static val Empty: Quaternions

Field Value

Type: Quaternions
See Also

Reference

Quaternions Class
Emgu.CV Namespace


RLOFOpticalFlowParameter Class

This is used store and set up the parameters of the robust local optical flow (RLOF) algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVRLOFOpticalFlowParameter

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RLOFOpticalFlowParameter : UnmanagedObject
Public Class RLOFOpticalFlowParameter
    Inherits UnmanagedObject
public ref class RLOFOpticalFlowParameter : public UnmanagedObject
type RLOFOpticalFlowParameter =
    class
        inherit UnmanagedObject
    end

The RLOFOpticalFlowParameter type exposes the following members.

Constructors
 | Name | Description
Public method | RLOFOpticalFlowParameter | Create a RLOF Optical Flow Parameter with default parameters.
Top
Properties
 | Name | Description
Public property | CrossSegmentationThreshold | Color similarity threshold used by cross-based segmentation. Only used if supportRegionType is Cross. With the cross-bassed segmentation motion boundaries can be computed more accurately
Public property | GlobalMotionRansacThreshold | To apply the global motion prior motion vectors will be computed on a regularly sampled which are the basis for Homography estimation using RANSAC. The reprojection threshold is based on n-th percentil (given by this value [0 ... 100]) of the motion vectors magnitude.
Public property | LargeWinSize | Maximal window size of the support region. If supportRegionType is Fixed this gives the exact support region size. The speed of the RLOF is related to the applied win sizes. The smaller the window size the lower is the runtime, but the more sensitive to noise is the method.
Public property | MaxIteration | Number of maximal iterations used for the iterative refinement. Lower values can reduce the runtime but also the accuracy.
Public property | MaxLevel | Maximal number of pyramid level used. The large this value is the more likely it is to obtain accurate solutions for long-range motions. The runtime is linear related to this parameter
Public property | MinEigenValue | Threshold for the minimal eigenvalue of the gradient matrix defines when to abort the iterative refinement.
Public property | NormSigma0 | parameter of the shrinked Hampel norm
Public property | NormSigma1 | parameter of the shrinked Hampel norm
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SmallWinSize | Minimal window size of the support region. This parameter is only used if supportRegionType is Cross
Public property | Solver | Variable specifies the iterative refinement strategy
Public property | SupportRegion | Variable specifies the support region shape extraction or shrinking strategy
Public property | UseGlobalMotionPrior | Use global motion prior initialisation. It allows to be more accurate for long-range motion. The computational complexity is slightly increased by enabling the global motion prior initialisation.
Public property | UseIlluminationModel | Use the Gennert and Negahdaripour illumination model instead of the intensity brightness constraint.
Public property | UseInitialFlow | Use next point list as initial values. A good initialization can improve the algorithm accuracy and reduce the runtime by a faster convergence of the iteration refinement
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


RLOFOpticalFlowParameter Constructor

Create a RLOF Optical Flow Parameter with default parameters.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RLOFOpticalFlowParameter()
Public Sub New
public:
RLOFOpticalFlowParameter()
new : unit -> RLOFOpticalFlowParameter
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter Properties

The RLOFOpticalFlowParameter type exposes the following members.

Properties
 | Name | Description
Public property | CrossSegmentationThreshold | Color similarity threshold used by cross-based segmentation. Only used if supportRegionType is Cross. With the cross-bassed segmentation motion boundaries can be computed more accurately
Public property | GlobalMotionRansacThreshold | To apply the global motion prior motion vectors will be computed on a regularly sampled which are the basis for Homography estimation using RANSAC. The reprojection threshold is based on n-th percentil (given by this value [0 ... 100]) of the motion vectors magnitude.
Public property | LargeWinSize | Maximal window size of the support region. If supportRegionType is Fixed this gives the exact support region size. The speed of the RLOF is related to the applied win sizes. The smaller the window size the lower is the runtime, but the more sensitive to noise is the method.
Public property | MaxIteration | Number of maximal iterations used for the iterative refinement. Lower values can reduce the runtime but also the accuracy.
Public property | MaxLevel | Maximal number of pyramid level used. The large this value is the more likely it is to obtain accurate solutions for long-range motions. The runtime is linear related to this parameter
Public property | MinEigenValue | Threshold for the minimal eigenvalue of the gradient matrix defines when to abort the iterative refinement.
Public property | NormSigma0 | parameter of the shrinked Hampel norm
Public property | NormSigma1 | parameter of the shrinked Hampel norm
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SmallWinSize | Minimal window size of the support region. This parameter is only used if supportRegionType is Cross
Public property | Solver | Variable specifies the iterative refinement strategy
Public property | SupportRegion | Variable specifies the support region shape extraction or shrinking strategy
Public property | UseGlobalMotionPrior | Use global motion prior initialisation. It allows to be more accurate for long-range motion. The computational complexity is slightly increased by enabling the global motion prior initialisation.
Public property | UseIlluminationModel | Use the Gennert and Negahdaripour illumination model instead of the intensity brightness constraint.
Public property | UseInitialFlow | Use next point list as initial values. A good initialization can improve the algorithm accuracy and reduce the runtime by a faster convergence of the iteration refinement
Top
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.CrossSegmentationThreshold Property

RLOFOpticalFlowParameterCrossSegmentationThreshold Property

Color similarity threshold used by cross-based segmentation. Only used if supportRegionType is Cross. With the cross-bassed segmentation motion boundaries can be computed more accurately

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CrossSegmentationThreshold { get; set; }
Public Property CrossSegmentationThreshold As Integer
    Get
    Set
public:
property int CrossSegmentationThreshold {
    int get ();
    void set (int value);
}
member CrossSegmentationThreshold : int with get, set

Property Value

Type: Int32
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.GlobalMotionRansacThreshold Property

RLOFOpticalFlowParameterGlobalMotionRansacThreshold Property

To apply the global motion prior motion vectors will be computed on a regularly sampled which are the basis for Homography estimation using RANSAC. The reprojection threshold is based on n-th percentil (given by this value [0 ... 100]) of the motion vectors magnitude.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float GlobalMotionRansacThreshold { get; set; }
Public Property GlobalMotionRansacThreshold As Single
    Get
    Set
public:
property float GlobalMotionRansacThreshold {
    float get ();
    void set (float value);
}
member GlobalMotionRansacThreshold : float32 with get, set

Property Value

Type: Single
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.LargeWinSize Property

RLOFOpticalFlowParameterLargeWinSize Property

Maximal window size of the support region. If supportRegionType is Fixed this gives the exact support region size. The speed of the RLOF is related to the applied win sizes. The smaller the window size the lower is the runtime, but the more sensitive to noise is the method.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int LargeWinSize { get; set; }
Public Property LargeWinSize As Integer
    Get
    Set
public:
property int LargeWinSize {
    int get ();
    void set (int value);
}
member LargeWinSize : int with get, set

Property Value

Type: Int32
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.MaxIteration Property

RLOFOpticalFlowParameterMaxIteration Property

Number of maximal iterations used for the iterative refinement. Lower values can reduce the runtime but also the accuracy.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxIteration { get; set; }
Public Property MaxIteration As Integer
    Get
    Set
public:
property int MaxIteration {
    int get ();
    void set (int value);
}
member MaxIteration : int with get, set

Property Value

Type: Int32
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.MaxLevel Property

RLOFOpticalFlowParameterMaxLevel Property

Maximal number of pyramid level used. The large this value is the more likely it is to obtain accurate solutions for long-range motions. The runtime is linear related to this parameter

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxLevel { get; set; }
Public Property MaxLevel As Integer
    Get
    Set
public:
property int MaxLevel {
    int get ();
    void set (int value);
}
member MaxLevel : int with get, set

Property Value

Type: Int32
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.MinEigenValue Property

RLOFOpticalFlowParameterMinEigenValue Property

Threshold for the minimal eigenvalue of the gradient matrix defines when to abort the iterative refinement.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MinEigenValue { get; set; }
Public Property MinEigenValue As Single
    Get
    Set
public:
property float MinEigenValue {
    float get ();
    void set (float value);
}
member MinEigenValue : float32 with get, set

Property Value

Type: Single
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.NormSigma0 Property

RLOFOpticalFlowParameterNormSigma0 Property

parameter of the shrinked Hampel norm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float NormSigma0 { get; set; }
Public Property NormSigma0 As Single
    Get
    Set
public:
property float NormSigma0 {
    float get ();
    void set (float value);
}
member NormSigma0 : float32 with get, set

Property Value

Type: Single
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.NormSigma1 Property

RLOFOpticalFlowParameterNormSigma1 Property

parameter of the shrinked Hampel norm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float NormSigma1 { get; set; }
Public Property NormSigma1 As Single
    Get
    Set
public:
property float NormSigma1 {
    float get ();
    void set (float value);
}
member NormSigma1 : float32 with get, set

Property Value

Type: Single
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SmallWinSize Property

RLOFOpticalFlowParameterSmallWinSize Property

Minimal window size of the support region. This parameter is only used if supportRegionType is Cross

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int SmallWinSize { get; set; }
Public Property SmallWinSize As Integer
    Get
    Set
public:
property int SmallWinSize {
    int get ();
    void set (int value);
}
member SmallWinSize : int with get, set

Property Value

Type: Int32
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.Solver Property

RLOFOpticalFlowParameterSolver Property

Variable specifies the iterative refinement strategy

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RLOFOpticalFlowParameterSolverType Solver { get; set; }
Public Property Solver As RLOFOpticalFlowParameterSolverType
    Get
    Set
public:
property RLOFOpticalFlowParameterSolverType^ Solver {
    RLOFOpticalFlowParameterSolverType^ get ();
    void set (RLOFOpticalFlowParameterSolverType^ value);
}
member Solver : RLOFOpticalFlowParameterSolverType with get, set

Property Value

Type: RLOFOpticalFlowParameterSolverType
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SupportRegion Property

RLOFOpticalFlowParameterSupportRegion Property

Variable specifies the support region shape extraction or shrinking strategy

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RLOFOpticalFlowParameterSupportRegionType SupportRegion { get; set; }
Public Property SupportRegion As RLOFOpticalFlowParameterSupportRegionType
    Get
    Set
public:
property RLOFOpticalFlowParameterSupportRegionType^ SupportRegion {
    RLOFOpticalFlowParameterSupportRegionType^ get ();
    void set (RLOFOpticalFlowParameterSupportRegionType^ value);
}
member SupportRegion : RLOFOpticalFlowParameterSupportRegionType with get, set

Property Value

Type: RLOFOpticalFlowParameterSupportRegionType
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.UseGlobalMotionPrior Property

RLOFOpticalFlowParameterUseGlobalMotionPrior Property

Use global motion prior initialisation. It allows to be more accurate for long-range motion. The computational complexity is slightly increased by enabling the global motion prior initialisation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseGlobalMotionPrior { get; set; }
Public Property UseGlobalMotionPrior As Boolean
    Get
    Set
public:
property bool UseGlobalMotionPrior {
    bool get ();
    void set (bool value);
}
member UseGlobalMotionPrior : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.UseIlluminationModel Property

RLOFOpticalFlowParameterUseIlluminationModel Property

Use the Gennert and Negahdaripour illumination model instead of the intensity brightness constraint.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseIlluminationModel { get; set; }
Public Property UseIlluminationModel As Boolean
    Get
    Set
public:
property bool UseIlluminationModel {
    bool get ();
    void set (bool value);
}
member UseIlluminationModel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.UseInitialFlow Property

RLOFOpticalFlowParameterUseInitialFlow Property

Use next point list as initial values. A good initialization can improve the algorithm accuracy and reduce the runtime by a faster convergence of the iteration refinement

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseInitialFlow { get; set; }
Public Property UseInitialFlow As Boolean
    Get
    Set
public:
property bool UseInitialFlow {
    bool get ();
    void set (bool value);
}
member UseInitialFlow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter Methods

The RLOFOpticalFlowParameter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.DisposeObject Method

RLOFOpticalFlowParameterDisposeObject Method

Release the unmanaged memory associated with this Object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter Fields

The RLOFOpticalFlowParameter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RLOFOpticalFlowParameter Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SolverType Class

RLOFOpticalFlowParameterSolverType Class

The solver type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVRLOFOpticalFlowParameterSolverType

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SolverType : Enum
Public NotInheritable Class SolverType
    Inherits Enum
public ref class SolverType sealed : public Enum
[<SealedAttribute>]
type SolverType =
    class
        inherit Enum
    end

The RLOFOpticalFlowParameterSolverType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Bilinear | Apply optimized iterative refinement based bilinear equation solutions
 | Standard | Apply standard iterative refinement
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


SolverType Methods

The RLOFOpticalFlowParameterSolverType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RLOFOpticalFlowParameterSolverType Class
Emgu.CV Namespace


SolverType Fields

The RLOFOpticalFlowParameterSolverType type exposes the following members.

Fields
 | Name | Description
 | Bilinear | Apply optimized iterative refinement based bilinear equation solutions
 | Standard | Apply standard iterative refinement
Public field | value__ |
Top
See Also

Reference

RLOFOpticalFlowParameterSolverType Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SolverType.Bilinear Field

RLOFOpticalFlowParameterSolverTypeBilinear Field

Apply optimized iterative refinement based bilinear equation solutions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RLOFOpticalFlowParameterSolverType Bilinear = 1
Public Const Bilinear As RLOFOpticalFlowParameterSolverType = 1
public:
literal RLOFOpticalFlowParameterSolverType^ Bilinear = 1
static val mutable Bilinear: RLOFOpticalFlowParameterSolverType

Field Value

Type: RLOFOpticalFlowParameterSolverType
See Also

Reference

RLOFOpticalFlowParameterSolverType Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SolverType.Standard Field

RLOFOpticalFlowParameterSolverTypeStandard Field

Apply standard iterative refinement

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RLOFOpticalFlowParameterSolverType Standard = 0
Public Const Standard As RLOFOpticalFlowParameterSolverType = 0
public:
literal RLOFOpticalFlowParameterSolverType^ Standard = 0
static val mutable Standard: RLOFOpticalFlowParameterSolverType

Field Value

Type: RLOFOpticalFlowParameterSolverType
See Also

Reference

RLOFOpticalFlowParameterSolverType Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SolverType.value__ Field

RLOFOpticalFlowParameterSolverTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.RLOFOpticalFlowParameter.SolverType.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RLOFOpticalFlowParameterSolverType Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SupportRegionType Class

RLOFOpticalFlowParameterSupportRegionType Class

The support region type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVRLOFOpticalFlowParameterSupportRegionType

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SupportRegionType : Enum
Public NotInheritable Class SupportRegionType
    Inherits Enum
public ref class SupportRegionType sealed : public Enum
[<SealedAttribute>]
type SupportRegionType =
    class
        inherit Enum
    end

The RLOFOpticalFlowParameterSupportRegionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cross | Apply a adaptive support region obtained by cross-based segmentation
 | Fixed | Apply a constant support region
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


SupportRegionType Methods

The RLOFOpticalFlowParameterSupportRegionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RLOFOpticalFlowParameterSupportRegionType Class
Emgu.CV Namespace


SupportRegionType Fields

The RLOFOpticalFlowParameterSupportRegionType type exposes the following members.

Fields
 | Name | Description
 | Cross | Apply a adaptive support region obtained by cross-based segmentation
 | Fixed | Apply a constant support region
Public field | value__ |
Top
See Also

Reference

RLOFOpticalFlowParameterSupportRegionType Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SupportRegionType.Cross Field

RLOFOpticalFlowParameterSupportRegionTypeCross Field

Apply a adaptive support region obtained by cross-based segmentation

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RLOFOpticalFlowParameterSupportRegionType Cross = 1
Public Const Cross As RLOFOpticalFlowParameterSupportRegionType = 1
public:
literal RLOFOpticalFlowParameterSupportRegionType^ Cross = 1
static val mutable Cross: RLOFOpticalFlowParameterSupportRegionType

Field Value

Type: RLOFOpticalFlowParameterSupportRegionType
See Also

Reference

RLOFOpticalFlowParameterSupportRegionType Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SupportRegionType.Fixed Field

RLOFOpticalFlowParameterSupportRegionTypeFixed Field

Apply a constant support region

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RLOFOpticalFlowParameterSupportRegionType Fixed = 0
Public Const Fixed As RLOFOpticalFlowParameterSupportRegionType = 0
public:
literal RLOFOpticalFlowParameterSupportRegionType^ Fixed = 0
static val mutable Fixed: RLOFOpticalFlowParameterSupportRegionType

Field Value

Type: RLOFOpticalFlowParameterSupportRegionType
See Also

Reference

RLOFOpticalFlowParameterSupportRegionType Class
Emgu.CV Namespace


RLOFOpticalFlowParameter.SupportRegionType.value__ Field

RLOFOpticalFlowParameterSupportRegionTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.RLOFOpticalFlowParameter.SupportRegionType.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RLOFOpticalFlowParameterSupportRegionType Class
Emgu.CV Namespace


RNG Class

Random Number Generator.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVRNG

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RNG : UnmanagedObject
Public Class RNG
    Inherits UnmanagedObject
public ref class RNG : public UnmanagedObject
type RNG =
    class
        inherit UnmanagedObject
    end

The RNG type exposes the following members.

Constructors
 | Name | Description
Public method | RNG | Create a Random Number Generator.
Public method | RNG(UInt64) | Create a Random Number Generator using a seed.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill(IInputOutputArray, RNGDistType, IInputArray, IInputArray, Boolean) | Fills arrays with random numbers.
Public method | Fill(IInputOutputArray, RNGDistType, MCvScalar, MCvScalar, Boolean) | Fills arrays with random numbers.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Gaussian | Returns the next random number sampled from the Gaussian distribution.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | The method updates the state using the MWC algorithm and returns the next 32-bit random number.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Uniform(Double, Double) | Returns uniformly distributed random double number from [a,b) range
Public method | Uniform(Int32, Int32) | Returns uniformly distributed integer random number from [a,b) range
Public method | Uniform(Single, Single) | Returns uniformly distributed random float number from [a,b) range
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


RNG Constructor

Overload List
 | Name | Description
Public method | RNG | Create a Random Number Generator.
Public method | RNG(UInt64) | Create a Random Number Generator using a seed.
Top
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG Constructor

Create a Random Number Generator.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RNG()
Public Sub New
public:
RNG()
new : unit -> RNG
See Also

Reference

RNG Class
RNG Overload
Emgu.CV Namespace


RNG Constructor (UInt64)

Create a Random Number Generator using a seed.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RNG(
    ulong state
)
Public Sub New (
    state As ULong
)
public:
RNG(
    unsigned long long state
)
new :
        state : uint64 -> RNG

Parameters

state
Type: SystemUInt64
64-bit value used to initialize the RNG
See Also

Reference

RNG Class
RNG Overload
Emgu.CV Namespace


RNG Properties

The RNG type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG Methods

The RNG type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill(IInputOutputArray, RNGDistType, IInputArray, IInputArray, Boolean) | Fills arrays with random numbers.
Public method | Fill(IInputOutputArray, RNGDistType, MCvScalar, MCvScalar, Boolean) | Fills arrays with random numbers.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Gaussian | Returns the next random number sampled from the Gaussian distribution.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | The method updates the state using the MWC algorithm and returns the next 32-bit random number.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Uniform(Double, Double) | Returns uniformly distributed random double number from [a,b) range
Public method | Uniform(Int32, Int32) | Returns uniformly distributed integer random number from [a,b) range
Public method | Uniform(Single, Single) | Returns uniformly distributed random float number from [a,b) range
Top
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG.DisposeObject Method

RNGDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG.Fill Method

RNGFill Method

Overload List
 | Name | Description
Public method | Fill(IInputOutputArray, RNGDistType, IInputArray, IInputArray, Boolean) | Fills arrays with random numbers.
Public method | Fill(IInputOutputArray, RNGDistType, MCvScalar, MCvScalar, Boolean) | Fills arrays with random numbers.
Top
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG.Fill Method (IInputOutputArray, RNG.DistType, IInputArray, IInputArray, Boolean)

RNGFill Method (IInputOutputArray, RNGDistType, IInputArray, IInputArray, Boolean)

http://www.emgu.com
Fills arrays with random numbers.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Fill(
    IInputOutputArray mat,
    RNGDistType distType,
    IInputArray a,
    IInputArray b,
    bool saturateRange = false
)
Public Sub Fill (
    mat As IInputOutputArray,
    distType As RNGDistType,
    a As IInputArray,
    b As IInputArray,
    Optional saturateRange As Boolean = false
)
public:
void Fill(
    IInputOutputArray^ mat,
    RNGDistType^ distType,
    IInputArray^ a,
    IInputArray^ b,
    bool saturateRange = false
)
member Fill :
        mat : IInputOutputArray *
        distType : RNGDistType *
        a : IInputArray *
        b : IInputArray *
        ?saturateRange : bool
(* Defaults:
        let _saturateRange = defaultArg saturateRange false
*)
-> unit

Parameters

mat
Type: Emgu.CVIInputOutputArray
2D or N-dimensional matrix; currently matrices with more than 4 channels are not supported by the methods, use Mat::reshape as a possible workaround.
distType
Type: Emgu.CVRNGDistType
distribution type
a
Type: Emgu.CVIInputArray
First distribution parameter; in case of the uniform distribution, this is an inclusive lower boundary, in case of the normal distribution, this is a mean value.
b
Type: Emgu.CVIInputArray
Second distribution parameter; in case of the uniform distribution, this is a non-inclusive upper boundary, in case of the normal distribution, this is a standard deviation (diagonal of the standard deviation matrix or the full standard deviation matrix).
saturateRange (Optional)
Type: SystemBoolean
Pre-saturation flag; for uniform distribution only; if true, the method will first convert a and b to the acceptable value range (according to the mat datatype) and then will generate uniformly distributed random numbers within the range [saturate(a), saturate(b)), if saturateRange=false, the method will generate uniformly distributed random numbers in the original range [a, b) and then will saturate them
See Also

Reference

RNG Class
Fill Overload
Emgu.CV Namespace


RNG.Fill Method (IInputOutputArray, RNG.DistType, MCvScalar, MCvScalar, Boolean)

RNGFill Method (IInputOutputArray, RNGDistType, MCvScalar, MCvScalar, Boolean)

http://www.emgu.com
Fills arrays with random numbers.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Fill(
    IInputOutputArray mat,
    RNGDistType distType,
    MCvScalar a,
    MCvScalar b,
    bool saturateRange = false
)
Public Sub Fill (
    mat As IInputOutputArray,
    distType As RNGDistType,
    a As MCvScalar,
    b As MCvScalar,
    Optional saturateRange As Boolean = false
)
public:
void Fill(
    IInputOutputArray^ mat,
    RNGDistType^ distType,
    MCvScalar^ a,
    MCvScalar^ b,
    bool saturateRange = false
)
member Fill :
        mat : IInputOutputArray *
        distType : RNGDistType *
        a : MCvScalar *
        b : MCvScalar *
        ?saturateRange : bool
(* Defaults:
        let _saturateRange = defaultArg saturateRange false
*)
-> unit

Parameters

mat
Type: Emgu.CVIInputOutputArray
2D or N-dimensional matrix; currently matrices with more than 4 channels are not supported by the methods, use Mat::reshape as a possible workaround.
distType
Type: Emgu.CVRNGDistType
distribution type
a
Type: Emgu.CV.StructureMCvScalar
First distribution parameter; in case of the uniform distribution, this is an inclusive lower boundary, in case of the normal distribution, this is a mean value.
b
Type: Emgu.CV.StructureMCvScalar
Second distribution parameter; in case of the uniform distribution, this is a non-inclusive upper boundary, in case of the normal distribution, this is a standard deviation (diagonal of the standard deviation matrix or the full standard deviation matrix).
saturateRange (Optional)
Type: SystemBoolean
Pre-saturation flag; for uniform distribution only; if true, the method will first convert a and b to the acceptable value range (according to the mat datatype) and then will generate uniformly distributed random numbers within the range [saturate(a), saturate(b)), if saturateRange=false, the method will generate uniformly distributed random numbers in the original range [a, b) and then will saturate them
See Also

Reference

RNG Class
Fill Overload
Emgu.CV Namespace


RNG.Gaussian Method

RNGGaussian Method

Returns the next random number sampled from the Gaussian distribution.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Gaussian(
    double sigma
)
Public Function Gaussian (
    sigma As Double
) As Double
public:
double Gaussian(
    double sigma
)
member Gaussian :
        sigma : float -> float

Parameters

sigma
Type: SystemDouble
standard deviation of the distribution.

Return Value

Type: Double
Returns the next random number from the Gaussian distribution N(0,sigma) . That is, the mean value of the returned random numbers is zero and the standard deviation is the specified sigma .
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG.Next Method

RNGNext Method

The method updates the state using the MWC algorithm and returns the next 32-bit random number.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Next()
Public Function Next As UInteger
public:
unsigned int Next()
member Next : unit -> uint32

Return Value

Type: UInt32
The next 32-bit random number
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG.Uniform Method

RNGUniform Method

Overload List
 | Name | Description
Public method | Uniform(Double, Double) | Returns uniformly distributed random double number from [a,b) range
Public method | Uniform(Int32, Int32) | Returns uniformly distributed integer random number from [a,b) range
Public method | Uniform(Single, Single) | Returns uniformly distributed random float number from [a,b) range
Top
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG.Uniform Method (Double, Double)

RNGUniform Method (Double, Double)

http://www.emgu.com
Returns uniformly distributed random double number from [a,b) range

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Uniform(
    double a,
    double b
)
Public Function Uniform (
    a As Double,
    b As Double
) As Double
public:
double Uniform(
    double a,
    double b
)
member Uniform :
        a : float *
        b : float -> float

Parameters

a
Type: SystemDouble
Lower inclusive boundary of the returned random number.
b
Type: SystemDouble
Upper non-inclusive boundary of the returned random number.

Return Value

Type: Double
Uniformly distributed random double number from [a,b) range
See Also

Reference

RNG Class
Uniform Overload
Emgu.CV Namespace


RNG.Uniform Method (Int32, Int32)

RNGUniform Method (Int32, Int32)

http://www.emgu.com
Returns uniformly distributed integer random number from [a,b) range

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Uniform(
    int a,
    int b
)
Public Function Uniform (
    a As Integer,
    b As Integer
) As Integer
public:
int Uniform(
    int a,
    int b
)
member Uniform :
        a : int *
        b : int -> int

Parameters

a
Type: SystemInt32
Lower inclusive boundary of the returned random number.
b
Type: SystemInt32
Upper non-inclusive boundary of the returned random number.

Return Value

Type: Int32
Uniformly distributed integer random number from [a,b) range
See Also

Reference

RNG Class
Uniform Overload
Emgu.CV Namespace


RNG.Uniform Method (Single, Single)

RNGUniform Method (Single, Single)

http://www.emgu.com
Returns uniformly distributed random float number from [a,b) range

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Uniform(
    float a,
    float b
)
Public Function Uniform (
    a As Single,
    b As Single
) As Single
public:
float Uniform(
    float a,
    float b
)
member Uniform :
        a : float32 *
        b : float32 -> float32

Parameters

a
Type: SystemSingle
Lower inclusive boundary of the returned random number.
b
Type: SystemSingle
Upper non-inclusive boundary of the returned random number.

Return Value

Type: Single
Uniformly distributed random float number from [a,b) range
See Also

Reference

RNG Class
Uniform Overload
Emgu.CV Namespace


RNG Fields

The RNG type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RNG Class
Emgu.CV Namespace


RNG.DistType Class

RNGDistType Class

Distribution type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVRNGDistType

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DistType : Enum
Public NotInheritable Class DistType
    Inherits Enum
public ref class DistType sealed : public Enum
[<SealedAttribute>]
type DistType =
    class
        inherit Enum
    end

The RNGDistType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Normal | Normal distribution
 | Uniform | Uniform distribution
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


DistType Methods

The RNGDistType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RNGDistType Class
Emgu.CV Namespace


DistType Fields

The RNGDistType type exposes the following members.

Fields
 | Name | Description
 | Normal | Normal distribution
 | Uniform | Uniform distribution
Public field | value__ |
Top
See Also

Reference

RNGDistType Class
Emgu.CV Namespace


RNG.DistType.Normal Field

RNGDistTypeNormal Field

Normal distribution

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RNGDistType Normal = 1
Public Const Normal As RNGDistType = 1
public:
literal RNGDistType^ Normal = 1
static val mutable Normal: RNGDistType

Field Value

Type: RNGDistType
See Also

Reference

RNGDistType Class
Emgu.CV Namespace


RNG.DistType.Uniform Field

RNGDistTypeUniform Field

Uniform distribution

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RNGDistType Uniform = 0
Public Const Uniform As RNGDistType = 0
public:
literal RNGDistType^ Uniform = 0
static val mutable Uniform: RNGDistType

Field Value

Type: RNGDistType
See Also

Reference

RNGDistType Class
Emgu.CV Namespace


RNG.DistType.value__ Field

RNGDistTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.RNG.DistType.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RNGDistType Class
Emgu.CV Namespace


RotationMatrix2D Class

A (2x3) 2D rotation matrix. This Matrix defines an Affine Transform
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMatDataAllocator
Emgu.CVMat
Emgu.CVRotationMatrix2D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RotationMatrix2D : Mat
<SerializableAttribute>
Public Class RotationMatrix2D
    Inherits Mat
[SerializableAttribute]
public ref class RotationMatrix2D : public Mat
[<SerializableAttribute>]
type RotationMatrix2D =
    class
        inherit Mat
    end

The RotationMatrix2D type exposes the following members.

Constructors
 | Name | Description
Public method | RotationMatrix2D | Create an empty (2x3) 2D rotation matrix
Public method | RotationMatrix2D(PointF, Double, Double) | Create a (2x3) 2D rotation matrix
Top
Properties
 | Name | Description
Public property | Cols | The number of columns (Inherited from Mat.)
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | DataPointer | Pointer to the beginning of the raw data (Inherited from Mat.)
Public property | Depth | Depth type (Inherited from Mat.)
Public property | Dims | The matrix dimensionality (Inherited from Mat.)
Public property | ElementSize | The size of the elements in this matrix (Inherited from Mat.)
Public property | Height | Get the height of the mat. (Inherited from Mat.)
Public property | IsContinuous | True if the data is continues (Inherited from Mat.)
Public property | IsEmpty | True if the Mat is empty (Inherited from Mat.)
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix (Inherited from Mat.)
Public property | NumberOfChannels | Number of channels (Inherited from Mat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rows | The number of rows (Inherited from Mat.)
Public property | Size | The size of this matrix (Inherited from Mat.)
Public property | SizeOfDimension | Get an array of the size of the dimensions. e.g. if the mat is 9x10x11, the array of {9, 10, 11} will be returned. (Inherited from Mat.)
Public property | Step | Step (Inherited from Mat.)
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image) (Inherited from Mat.)
Public property | Width | Get the width of the mat (Inherited from Mat.)
Top
Methods
 | Name | Description
Public method | Clone | Return a clone of the Matrix
Public method | Col | Creates a matrix header for the specified matrix column. (Inherited from Mat.)
Public method | ConvertTo | Converts an array to another data type with optional scaling. (Inherited from Mat.)
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this cv::Mat to an output array (Inherited from Mat.)
Public method | CopyToT(T) | Copy data from this Mat to the managed array (Inherited from Mat.)
Public method | Create | Allocates new array data if needed. (Inherited from Mat.)
 | CreateRotationMatrix | Create a rotation matrix for rotating an image
Public method | Cross | Computes a cross-product of two 3-element vectors. (Inherited from Mat.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from Mat.)
Public method | Diag | Extracts a diagonal from a matrix. The method makes a new header for the specified matrix diagonal. The new matrix is represented as a single-column matrix. Similarly to Mat::row and Mat::col, this is an O(1) operation. (Inherited from Mat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Inherited from Mat.)
Public method | Dot | Computes a dot-product of two vectors. (Inherited from Mat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Mat) | Compares two Mats and check if they are equal (Inherited from Mat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array (Inherited from Mat.)
Public method | GetDataPointer | Get a pointer to the raw data given the specific index (Inherited from Mat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from Mat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from Mat.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from Mat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from Mat.)
Public method | GetRawData | Gets the binary data from the specific indices. (Inherited from Mat.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Convert this Mat to UMat (Inherited from Mat.)
Public method | GetValueRange | Get the minimum and maximum value across all channels of the mat (Inherited from Mat.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from Mat.)
Public method | PopBack | The method removes one or more rows from the bottom of the matrix (Inherited from Mat.)
Public method | PushBack | Adds elements to the bottom of the matrix (Inherited from Mat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data. (Inherited from Mat.)
Public method | RotateLines | Rotate the lineSegments, the value of the input lineSegments will be changed.
Public method | RotatePoints(PointF) | Rotate the points, the value of the input points will be changed.
Public method | RotatePoints(MCvPoint2D64f) | Rotate the points, the value of the input points will be changed.
Public method | RotatePointsTDepth(MatrixTDepth) | Rotate the single channel Nx2 matrix where N is the number of 2D points. The value of the matrix is changed after rotation.
Public method | Row | Creates a matrix header for the specified matrix row. (Inherited from Mat.)
Public method | Save | Save this image to the specific file. (Inherited from Mat.)
Public method | SetRotation | Set the values of the rotation matrix
Public method | SetTo(IInputArray, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetTo(MCvScalar, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetToT(T) | Copy data from managed array to this Mat (Inherited from Mat.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from Mat.)
Public method | T | Transposes a matrix. (Inherited from Mat.)
Public method | ToImageTColor, TDepth | Convert this Mat to Image (Inherited from Mat.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


RotationMatrix2D Constructor

Overload List
 | Name | Description
Public method | RotationMatrix2D | Create an empty (2x3) 2D rotation matrix
Public method | RotationMatrix2D(PointF, Double, Double) | Create a (2x3) 2D rotation matrix
Top
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D Constructor

Create an empty (2x3) 2D rotation matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotationMatrix2D()
Public Sub New
public:
RotationMatrix2D()
new : unit -> RotationMatrix2D
See Also

Reference

RotationMatrix2D Class
RotationMatrix2D Overload
Emgu.CV Namespace


RotationMatrix2D Constructor (PointF, Double, Double)

Create a (2x3) 2D rotation matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotationMatrix2D(
    PointF center,
    double angle,
    double scale
)
Public Sub New (
    center As PointF,
    angle As Double,
    scale As Double
)
public:
RotationMatrix2D(
    PointF^ center,
    double angle,
    double scale
)
new :
        center : PointF *
        angle : float *
        scale : float -> RotationMatrix2D

Parameters

center
Type: System.DrawingPointF
Center of the rotation in the source image
angle
Type: SystemDouble
The rotation angle in degrees. Positive values mean couter-clockwise rotation (the coordiate origin is assumed at top-left corner).
scale
Type: SystemDouble
Isotropic scale factor.
See Also

Reference

RotationMatrix2D Class
RotationMatrix2D Overload
Emgu.CV Namespace


RotationMatrix2D Properties

The RotationMatrix2D type exposes the following members.

Properties
 | Name | Description
Public property | Cols | The number of columns (Inherited from Mat.)
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | DataPointer | Pointer to the beginning of the raw data (Inherited from Mat.)
Public property | Depth | Depth type (Inherited from Mat.)
Public property | Dims | The matrix dimensionality (Inherited from Mat.)
Public property | ElementSize | The size of the elements in this matrix (Inherited from Mat.)
Public property | Height | Get the height of the mat. (Inherited from Mat.)
Public property | IsContinuous | True if the data is continues (Inherited from Mat.)
Public property | IsEmpty | True if the Mat is empty (Inherited from Mat.)
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix (Inherited from Mat.)
Public property | NumberOfChannels | Number of channels (Inherited from Mat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rows | The number of rows (Inherited from Mat.)
Public property | Size | The size of this matrix (Inherited from Mat.)
Public property | SizeOfDimension | Get an array of the size of the dimensions. e.g. if the mat is 9x10x11, the array of {9, 10, 11} will be returned. (Inherited from Mat.)
Public property | Step | Step (Inherited from Mat.)
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image) (Inherited from Mat.)
Public property | Width | Get the width of the mat (Inherited from Mat.)
Top
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D Methods

The RotationMatrix2D type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Return a clone of the Matrix
Public method | Col | Creates a matrix header for the specified matrix column. (Inherited from Mat.)
Public method | ConvertTo | Converts an array to another data type with optional scaling. (Inherited from Mat.)
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this cv::Mat to an output array (Inherited from Mat.)
Public method | CopyToT(T) | Copy data from this Mat to the managed array (Inherited from Mat.)
Public method | Create | Allocates new array data if needed. (Inherited from Mat.)
 | CreateRotationMatrix | Create a rotation matrix for rotating an image
Public method | Cross | Computes a cross-product of two 3-element vectors. (Inherited from Mat.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from Mat.)
Public method | Diag | Extracts a diagonal from a matrix. The method makes a new header for the specified matrix diagonal. The new matrix is represented as a single-column matrix. Similarly to Mat::row and Mat::col, this is an O(1) operation. (Inherited from Mat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Inherited from Mat.)
Public method | Dot | Computes a dot-product of two vectors. (Inherited from Mat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Mat) | Compares two Mats and check if they are equal (Inherited from Mat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array (Inherited from Mat.)
Public method | GetDataPointer | Get a pointer to the raw data given the specific index (Inherited from Mat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from Mat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from Mat.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from Mat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from Mat.)
Public method | GetRawData | Gets the binary data from the specific indices. (Inherited from Mat.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUMat | Convert this Mat to UMat (Inherited from Mat.)
Public method | GetValueRange | Get the minimum and maximum value across all channels of the mat (Inherited from Mat.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from Mat.)
Public method | PopBack | The method removes one or more rows from the bottom of the matrix (Inherited from Mat.)
Public method | PushBack | Adds elements to the bottom of the matrix (Inherited from Mat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data. (Inherited from Mat.)
Public method | RotateLines | Rotate the lineSegments, the value of the input lineSegments will be changed.
Public method | RotatePoints(PointF) | Rotate the points, the value of the input points will be changed.
Public method | RotatePoints(MCvPoint2D64f) | Rotate the points, the value of the input points will be changed.
Public method | RotatePointsTDepth(MatrixTDepth) | Rotate the single channel Nx2 matrix where N is the number of 2D points. The value of the matrix is changed after rotation.
Public method | Row | Creates a matrix header for the specified matrix row. (Inherited from Mat.)
Public method | Save | Save this image to the specific file. (Inherited from Mat.)
Public method | SetRotation | Set the values of the rotation matrix
Public method | SetTo(IInputArray, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetTo(MCvScalar, IInputArray) | Set the mat to the specific value (Inherited from Mat.)
Public method | SetToT(T) | Copy data from managed array to this Mat (Inherited from Mat.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from Mat.)
Public method | T | Transposes a matrix. (Inherited from Mat.)
Public method | ToImageTColor, TDepth | Convert this Mat to Image (Inherited from Mat.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D.Clone Method

RotationMatrix2DClone Method

Return a clone of the Matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotationMatrix2D Clone()
Public Function Clone As RotationMatrix2D
public:
RotationMatrix2D^ Clone()
member Clone : unit -> RotationMatrix2D

Return Value

Type: RotationMatrix2D
A clone of the Matrix
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D.CreateRotationMatrix Method

RotationMatrix2DCreateRotationMatrix Method

Create a rotation matrix for rotating an image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotationMatrix2D CreateRotationMatrix(
    PointF center,
    double angle,
    Size srcImageSize,
    out Size dstImageSize
)
Public Shared Function CreateRotationMatrix (
    center As PointF,
    angle As Double,
    srcImageSize As Size,
    <OutAttribute> ByRef dstImageSize As Size
) As RotationMatrix2D
public:
static RotationMatrix2D^ CreateRotationMatrix(
    PointF^ center,
    double angle,
    Size^ srcImageSize,
    [OutAttribute] Size^% dstImageSize
)
static member CreateRotationMatrix :
        center : PointF *
        angle : float *
        srcImageSize : Size *
        dstImageSize : Size byref -> RotationMatrix2D

Parameters

center
Type: System.DrawingPointF
The rotation center
angle
Type: SystemDouble
The rotation angle in degrees. Positive values mean couter-clockwise rotation (the coordiate origin is assumed at image centre).
srcImageSize
Type: System.DrawingSize
The source image size
dstImageSize
Type: System.DrawingSize
The minimun size of the destination image

Return Value

Type: RotationMatrix2D
The rotation matrix that rotate the source image to the destination image.
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D.RotateLines Method

RotationMatrix2DRotateLines Method

Rotate the lineSegments, the value of the input lineSegments will be changed.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RotateLines(
    LineSegment2DF[] lineSegments
)
Public Sub RotateLines (
    lineSegments As LineSegment2DF()
)
public:
void RotateLines(
    array<LineSegment2DF^>^ lineSegments
)
member RotateLines :
        lineSegments : LineSegment2DF[] -> unit

Parameters

lineSegments
Type: Emgu.CV.StructureLineSegment2DF
The line segments to be rotated
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D.RotatePoints Method

RotationMatrix2DRotatePoints Method

Overload List
 | Name | Description
Public method | RotatePoints(PointF) | Rotate the points, the value of the input points will be changed.
Public method | RotatePointsTDepth(MatrixTDepth) | Rotate the single channel Nx2 matrix where N is the number of 2D points. The value of the matrix is changed after rotation.
Public method | RotatePoints(MCvPoint2D64f) | Rotate the points, the value of the input points will be changed.
Top
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D.RotatePoints Method (PointF[])

RotationMatrix2DRotatePoints Method (PointF)

http://www.emgu.com
Rotate the points, the value of the input points will be changed.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RotatePoints(
    PointF[] points
)
Public Sub RotatePoints (
    points As PointF()
)
public:
void RotatePoints(
    array<PointF^>^ points
)
member RotatePoints :
        points : PointF[] -> unit

Parameters

points
Type: System.DrawingPointF
The points to be rotated, its value will be modified
See Also

Reference

RotationMatrix2D Class
RotatePoints Overload
Emgu.CV Namespace


RotationMatrix2D.RotatePoints(TDepth) Method (Matrix(TDepth))

RotationMatrix2DRotatePointsTDepth Method (MatrixTDepth)

http://www.emgu.com
Rotate the single channel Nx2 matrix where N is the number of 2D points. The value of the matrix is changed after rotation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RotatePoints<TDepth>(
    Matrix<TDepth> points
)
where TDepth : new()

Public Sub RotatePoints(Of TDepth As New) (
    points As Matrix(Of TDepth)
)
public:
generic<typename TDepth>
where TDepth : gcnew()
void RotatePoints(
    Matrix<TDepth>^ points
)
member RotatePoints :
        points : Matrix<'TDepth> -> unit  when 'TDepth : new()

Parameters

points
Type: Emgu.CVMatrix TDepth
The N 2D-points to be rotated

Type Parameters

TDepth
The depth of the points, must be double or float
See Also

Reference

RotationMatrix2D Class
RotatePoints Overload
Emgu.CV Namespace


RotationMatrix2D.RotatePoints Method (MCvPoint2D64f[])

RotationMatrix2DRotatePoints Method (MCvPoint2D64f)

http://www.emgu.com
Rotate the points, the value of the input points will be changed.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RotatePoints(
    MCvPoint2D64f[] points
)
Public Sub RotatePoints (
    points As MCvPoint2D64f()
)
public:
void RotatePoints(
    array<MCvPoint2D64f^>^ points
)
member RotatePoints :
        points : MCvPoint2D64f[] -> unit

Parameters

points
Type: Emgu.CV.StructureMCvPoint2D64f
The points to be rotated, its value will be modified
See Also

Reference

RotationMatrix2D Class
RotatePoints Overload
Emgu.CV Namespace


RotationMatrix2D.SetRotation Method

RotationMatrix2DSetRotation Method

Set the values of the rotation matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetRotation(
    PointF center,
    double angle,
    double scale
)
Public Sub SetRotation (
    center As PointF,
    angle As Double,
    scale As Double
)
public:
void SetRotation(
    PointF^ center,
    double angle,
    double scale
)
member SetRotation :
        center : PointF *
        angle : float *
        scale : float -> unit

Parameters

center
Type: System.DrawingPointF
Center of the rotation in the source image
angle
Type: SystemDouble
The rotation angle in degrees. Positive values mean couter-clockwise rotation (the coordiate origin is assumed at top-left corner).
scale
Type: SystemDouble
Isotropic scale factor.
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationMatrix2D Fields

The RotationMatrix2D type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RotationMatrix2D Class
Emgu.CV Namespace


RotationVector3D Class

A (3x1) Rodrigues rotation vector. Rotation vector is a compact representation of rotation matrix. Direction of the rotation vector is the rotation axis and the length of the vector is the rotation angle around the axis.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArray Double
Emgu.CVMatrix Double
Emgu.CVRotationVector3D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RotationVector3D : Matrix<double>
<SerializableAttribute>
Public Class RotationVector3D
    Inherits Matrix(Of Double)
[SerializableAttribute]
public ref class RotationVector3D : public Matrix<double>
[<SerializableAttribute>]
type RotationVector3D =
    class
        inherit Matrix<float>
    end

The RotationVector3D type exposes the following members.

Constructors
 | Name | Description
Public method | RotationVector3D | Create a 3D rotation vector (3x1 Matrix).
Public method | RotationVector3D(Double) | Create a rotation vector using the specific values
Public method | RotationVector3D(SerializationInfo, StreamingContext) | Constructor used to deserialize 3D rotation vector
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix (Inherited from MatrixTDepth.)
Public property | Det | Returns determinant of the square matrix (Inherited from MatrixTDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | Item | Get or Set the value in the specific row and col (Inherited from MatrixTDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from MatrixTDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMat | The MCvMat structure format (Inherited from MatrixTDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this matrix (Inherited from MatrixTDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | RotationMatrix | Get or Set the (3x3) rotation matrix represented by this rotation vector.
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from MatrixTDepth.)
Public property | Sum | Return the sum of the elements in this matrix (Inherited from MatrixTDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | Add(TDepth) | Elementwise add a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Add(MatrixTDepth) | Elementwise add another matrix with the current matrix (Inherited from MatrixTDepth.)
Protected method | AllocateData | Allocate data for the array (Inherited from MatrixTDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a copy of this matrix (Inherited from MatrixTDepth.)
Public method | Cmp | This function compare the current matrix with mat2 and returns the comparison mask (Inherited from MatrixTDepth.)
Public method | ConcateHorizontal | Concate the current matrix with another matrix horizontally. If this matrix is n x m1 and otherMatrix is n x m2, the resulting matrix is n x (m1 + m2). (Inherited from MatrixTDepth.)
Public method | ConcateVertical | Concate the current matrix with another matrix vertically. If this matrix is n1 x m and otherMatrix is n2 x m, the resulting matrix is (n1+n2) x m. (Inherited from MatrixTDepth.)
Public method | ConvertTOtherDepth | Convert this matrix to different depth (Inherited from MatrixTDepth.)
Public method | CopyBlank | Return a matrix of the same size with all elements equals 0 (Inherited from MatrixTDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Inherited from MatrixTDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatrixTDepth) | Return true if every element of this matrix equals elements in mat2 (Inherited from MatrixTDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetCol | Get the specific column of the matrix (Inherited from MatrixTDepth.)
Public method | GetCols | Get the Matrix, corresponding to a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | GetDiag | Return the main diagonal element of this matrix (Inherited from MatrixTDepth.)
Public method | GetDiag(Int32) | Return the specific diagonal elements of this matrix (Inherited from MatrixTDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from CvArrayTDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetRow | Get the specific row of the matrix (Inherited from MatrixTDepth.)
Public method | GetRows | Return the matrix corresponding to a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a submatrix corresponding to a specified rectangle (Inherited from MatrixTDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max locations and values for the matrix (Inherited from MatrixTDepth.)
Public method | Mul(Double) | Multiply the current matrix with scale (Inherited from MatrixTDepth.)
Public method | Mul(MatrixTDepth) | Multiply the current matrix with mat2 (Inherited from MatrixTDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveCols | Return the matrix without a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | RemoveRows | Return the matrix without a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | Reshape | Get reshaped matrix which also share the same data with the current matrix (Inherited from MatrixTDepth.)
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | Split | Get all channels for the multi channel matrix (Inherited from MatrixTDepth.)
Public method | Sub(TDepth) | Elementwise subtract a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Sub(MatrixTDepth) | Elementwise subtract another matrix from the current matrix (Inherited from MatrixTDepth.)
Public method | SubR | result = val - this (Inherited from MatrixTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | Transpose | Returns the transpose of this matrix (Inherited from MatrixTDepth.)
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Top
Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


RotationVector3D Constructor

Overload List
 | Name | Description
Public method | RotationVector3D | Create a 3D rotation vector (3x1 Matrix).
Public method | RotationVector3D(Double) | Create a rotation vector using the specific values
Public method | RotationVector3D(SerializationInfo, StreamingContext) | Constructor used to deserialize 3D rotation vector
Top
See Also

Reference

RotationVector3D Class
Emgu.CV Namespace


RotationVector3D Constructor

Create a 3D rotation vector (3x1 Matrix).

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotationVector3D()
Public Sub New
public:
RotationVector3D()
new : unit -> RotationVector3D
See Also

Reference

RotationVector3D Class
RotationVector3D Overload
Emgu.CV Namespace


RotationVector3D Constructor (Double[])

RotationVector3D Constructor (Double)

http://www.emgu.com
Create a rotation vector using the specific values

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotationVector3D(
    double[] value
)
Public Sub New (
    value As Double()
)
public:
RotationVector3D(
    array<double>^ value
)
new :
        value : float[] -> RotationVector3D

Parameters

value
Type: SystemDouble
The values of the (3 x 1) Rodrigues rotation vector
See Also

Reference

RotationVector3D Class
RotationVector3D Overload
Emgu.CV Namespace


RotationVector3D Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize 3D rotation vector

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotationVector3D(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
RotationVector3D(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> RotationVector3D

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

RotationVector3D Class
RotationVector3D Overload
Emgu.CV Namespace


RotationVector3D Properties

The RotationVector3D type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix (Inherited from MatrixTDepth.)
Public property | Det | Returns determinant of the square matrix (Inherited from MatrixTDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | Item | Get or Set the value in the specific row and col (Inherited from MatrixTDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from MatrixTDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MCvMat | The MCvMat structure format (Inherited from MatrixTDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this matrix (Inherited from MatrixTDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | RotationMatrix | Get or Set the (3x3) rotation matrix represented by this rotation vector.
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from MatrixTDepth.)
Public property | Sum | Return the sum of the elements in this matrix (Inherited from MatrixTDepth.)
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
See Also

Reference

RotationVector3D Class
Emgu.CV Namespace


RotationVector3D.RotationMatrix Property

RotationVector3DRotationMatrix Property

Get or Set the (3x3) rotation matrix represented by this rotation vector.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat RotationMatrix { get; set; }
Public Property RotationMatrix As Mat
    Get
    Set
public:
property Mat^ RotationMatrix {
    Mat^ get ();
    void set (Mat^ value);
}
member RotationMatrix : Mat with get, set

Property Value

Type: Mat
See Also

Reference

RotationVector3D Class
Emgu.CV Namespace


RotationVector3D Methods

The RotationVector3D type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | Add(TDepth) | Elementwise add a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Add(MatrixTDepth) | Elementwise add another matrix with the current matrix (Inherited from MatrixTDepth.)
Protected method | AllocateData | Allocate data for the array (Inherited from MatrixTDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a copy of this matrix (Inherited from MatrixTDepth.)
Public method | Cmp | This function compare the current matrix with mat2 and returns the comparison mask (Inherited from MatrixTDepth.)
Public method | ConcateHorizontal | Concate the current matrix with another matrix horizontally. If this matrix is n x m1 and otherMatrix is n x m2, the resulting matrix is n x (m1 + m2). (Inherited from MatrixTDepth.)
Public method | ConcateVertical | Concate the current matrix with another matrix vertically. If this matrix is n1 x m and otherMatrix is n2 x m, the resulting matrix is (n1+n2) x m. (Inherited from MatrixTDepth.)
Public method | ConvertTOtherDepth | Convert this matrix to different depth (Inherited from MatrixTDepth.)
Public method | CopyBlank | Return a matrix of the same size with all elements equals 0 (Inherited from MatrixTDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the matrix and all the memory associate with it (Inherited from MatrixTDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(MatrixTDepth) | Return true if every element of this matrix equals elements in mat2 (Inherited from MatrixTDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetCol | Get the specific column of the matrix (Inherited from MatrixTDepth.)
Public method | GetCols | Get the Matrix, corresponding to a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | GetDiag | Return the main diagonal element of this matrix (Inherited from MatrixTDepth.)
Public method | GetDiag(Int32) | Return the specific diagonal elements of this matrix (Inherited from MatrixTDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from CvArrayTDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetRow | Get the specific row of the matrix (Inherited from MatrixTDepth.)
Public method | GetRows | Return the matrix corresponding to a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a submatrix corresponding to a specified rectangle (Inherited from MatrixTDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max locations and values for the matrix (Inherited from MatrixTDepth.)
Public method | Mul(Double) | Multiply the current matrix with scale (Inherited from MatrixTDepth.)
Public method | Mul(MatrixTDepth) | Multiply the current matrix with mat2 (Inherited from MatrixTDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveCols | Return the matrix without a specified column span of the input array (Inherited from MatrixTDepth.)
Public method | RemoveRows | Return the matrix without a specified row span of the input array (Inherited from MatrixTDepth.)
Public method | Reshape | Get reshaped matrix which also share the same data with the current matrix (Inherited from MatrixTDepth.)
Public method | Save | Save the CvArray as image (Inherited from CvArrayTDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | Split | Get all channels for the multi channel matrix (Inherited from MatrixTDepth.)
Public method | Sub(TDepth) | Elementwise subtract a color val to the current matrix (Inherited from MatrixTDepth.)
Public method | Sub(MatrixTDepth) | Elementwise subtract another matrix from the current matrix (Inherited from MatrixTDepth.)
Public method | SubR | result = val - this (Inherited from MatrixTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | Transpose | Returns the transpose of this matrix (Inherited from MatrixTDepth.)
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Top
See Also

Reference

RotationVector3D Class
Emgu.CV Namespace


RotationVector3D Fields

The RotationVector3D type exposes the following members.

Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RotationVector3D Class
Emgu.CV Namespace


ScalarArray Class

An implementation of IInputArray intented to convert data to IInputArray
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVScalarArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ScalarArray : UnmanagedObject,
    IInputArray, IDisposable
Public Class ScalarArray
    Inherits UnmanagedObject
    Implements IInputArray, IDisposable
public ref class ScalarArray : public UnmanagedObject,
    IInputArray, IDisposable
type ScalarArray =
    class
        inherit UnmanagedObject
        interface IInputArray
        interface IDisposable
    end

The ScalarArray type exposes the following members.

Constructors
 | Name | Description
Public method | ScalarArray(Double) | Create an InputArray from a double value
Public method | ScalarArray(MCvScalar) | Create an InputArray from MCvScalar
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this InputArray (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The pointer to the input array
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
(Double to ScalarArray) | Convert double scalar to InputArray
(MCvScalar to ScalarArray) | Convert MCvScalar to InputArray
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


ScalarArray Constructor

Overload List
 | Name | Description
Public method | ScalarArray(Double) | Create an InputArray from a double value
Public method | ScalarArray(MCvScalar) | Create an InputArray from MCvScalar
Top
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


ScalarArray Constructor (Double)

Create an InputArray from a double value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ScalarArray(
    double scalar
)
Public Sub New (
    scalar As Double
)
public:
ScalarArray(
    double scalar
)
new :
        scalar : float -> ScalarArray

Parameters

scalar
Type: SystemDouble
The double value to be converted to InputArray
See Also

Reference

ScalarArray Class
ScalarArray Overload
Emgu.CV Namespace


ScalarArray Constructor (MCvScalar)

Create an InputArray from MCvScalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ScalarArray(
    MCvScalar scalar
)
Public Sub New (
    scalar As MCvScalar
)
public:
ScalarArray(
    MCvScalar^ scalar
)
new :
        scalar : MCvScalar -> ScalarArray

Parameters

scalar
Type: Emgu.CV.StructureMCvScalar
The MCvScalar to be converted to InputArray
See Also

Reference

ScalarArray Class
ScalarArray Overload
Emgu.CV Namespace


ScalarArray Properties

The ScalarArray type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


ScalarArray Methods

The ScalarArray type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this InputArray (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The pointer to the input array
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


ScalarArray.DisposeObject Method

ScalarArrayDisposeObject Method

Release all the unmanaged memory associated with this InputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


ScalarArray.GetInputArray Method

ScalarArrayGetInputArray Method

The pointer to the input array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


ScalarArray Type Conversions

Operators
Name | Description
(Double to ScalarArray) | Convert double scalar to InputArray
(MCvScalar to ScalarArray) | Convert MCvScalar to InputArray
Top
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


ScalarArray Explicit Conversion Operators

ScalarArray Conversion Operators

Overload List
Name | Description
(Double to ScalarArray) | Convert double scalar to InputArray
(MCvScalar to ScalarArray) | Convert MCvScalar to InputArray
Top
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


ScalarArray Explicit Conversion (Double to ScalarArray)

ScalarArray Conversion (Double to ScalarArray)

http://www.emgu.com
Convert double scalar to InputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static explicit operator ScalarArray (
    double scalar
)
Public Shared Narrowing Operator CType (
    scalar As Double
) As ScalarArray
static explicit operator ScalarArray^ (
    double scalar
)
F# does not support the declaration of new casting operators.

Parameters

scalar
Type: SystemDouble
The double scalar

Return Value

Type: ScalarArray
The InputArray
See Also

Reference

ScalarArray Class
Overload
Emgu.CV Namespace


ScalarArray Explicit Conversion (MCvScalar to ScalarArray)

ScalarArray Conversion (MCvScalar to ScalarArray)

http://www.emgu.com
Convert MCvScalar to InputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static explicit operator ScalarArray (
    MCvScalar scalar
)
Public Shared Narrowing Operator CType (
    scalar As MCvScalar
) As ScalarArray
static explicit operator ScalarArray^ (
    MCvScalar^ scalar
)
F# does not support the declaration of new casting operators.

Parameters

scalar
Type: Emgu.CV.StructureMCvScalar
The MCvScalar

Return Value

Type: ScalarArray
The InputArray
See Also

Reference

ScalarArray Class
Overload
Emgu.CV Namespace


ScalarArray Fields

The ScalarArray type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ScalarArray Class
Emgu.CV Namespace


SparseMatrix(TDepth) Class

SparseMatrixTDepth Class

Create a sparse matrix
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVSparseMatrixTDepth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SparseMatrix<TDepth> : UnmanagedObject
where TDepth : new()

Public Class SparseMatrix(Of TDepth As New)
    Inherits UnmanagedObject
generic<typename TDepth>
where TDepth : gcnew()
public ref class SparseMatrix : public UnmanagedObject
type SparseMatrix<'TDepth when 'TDepth : new()> =
    class
        inherit UnmanagedObject
    end

Type Parameters

TDepth
The type of elements in this matrix

The SparseMatrixTDepth type exposes the following members.

Constructors
 | Name | Description
Public method | SparseMatrixTDepth | Create a sparse matrix of the specific dimension
Top
Properties
 | Name | Description
Public property | Item | Get or Set the value in the specific row and col
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this sparse matrix (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


SparseMatrix(TDepth) Constructor

SparseMatrixTDepth Constructor

Create a sparse matrix of the specific dimension

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SparseMatrix(
    int[] dimension
)
Public Sub New (
    dimension As Integer()
)
public:
SparseMatrix(
    array<int>^ dimension
)
new :
        dimension : int[] -> SparseMatrix

Parameters

dimension
Type: SystemInt32
The dimension of the sparse matrix
See Also

Reference

SparseMatrixTDepth Class
Emgu.CV Namespace


SparseMatrix(TDepth) Properties

SparseMatrixTDepth Properties

The SparseMatrixTDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get or Set the value in the specific row and col
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SparseMatrixTDepth Class
Emgu.CV Namespace


SparseMatrix(TDepth).Item Property

SparseMatrixTDepthItem Property

Get or Set the value in the specific row and col

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double this[
    int row,
    int col
] { get; set; }
Public Property Item (
    row As Integer,
    col As Integer
) As Double
    Get
    Set
public:
property double Item[int row, int col] {
    double get (int row, int col);
    void set (int row, int col, double value);
}
member Item : float with get, set

Parameters

row
Type: SystemInt32
the row of the element
col
Type: SystemInt32
the col of the element

Return Value

Type: Double
The element on the specific row and col
See Also

Reference

SparseMatrixTDepth Class
Emgu.CV Namespace


SparseMatrix(TDepth) Methods

SparseMatrixTDepth Methods

The SparseMatrixTDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this sparse matrix (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SparseMatrixTDepth Class
Emgu.CV Namespace


SparseMatrix(TDepth).DisposeObject Method

SparseMatrixTDepthDisposeObject Method

Release the unmanaged memory associated with this sparse matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SparseMatrixTDepth Class
Emgu.CV Namespace


SparseMatrix(TDepth) Fields

SparseMatrixTDepth Fields

The SparseMatrixTDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SparseMatrixTDepth Class
Emgu.CV Namespace


SparseOpticalFlowExtensions Class

Extension methods for ISparseOpticalFlow
Inheritance Hierarchy
SystemObject
Emgu.CVSparseOpticalFlowExtensions

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class SparseOpticalFlowExtensions
<ExtensionAttribute>
Public NotInheritable Class SparseOpticalFlowExtensions
[ExtensionAttribute]
public ref class SparseOpticalFlowExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type SparseOpticalFlowExtensions =  class end

The SparseOpticalFlowExtensions type exposes the following members.

Methods
Name | Description
Calc | Calculates a sparse optical flow.
Top
See Also

Reference

Emgu.CV Namespace


SparseOpticalFlowExtensions Methods

The SparseOpticalFlowExtensions type exposes the following members.

Methods
Name | Description
Calc | Calculates a sparse optical flow.
Top
See Also

Reference

SparseOpticalFlowExtensions Class
Emgu.CV Namespace


SparseOpticalFlowExtensions.Calc Method

SparseOpticalFlowExtensionsCalc Method

Calculates a sparse optical flow.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Calc(
    this ISparseOpticalFlow opticalFlow,
    IInputArray prevImg,
    IInputArray nextImg,
    IInputArray prevPts,
    IInputOutputArray nextPts,
    IOutputArray status,
    IOutputArray error = null
)
<ExtensionAttribute>
Public Shared Sub Calc (
    opticalFlow As ISparseOpticalFlow,
    prevImg As IInputArray,
    nextImg As IInputArray,
    prevPts As IInputArray,
    nextPts As IInputOutputArray,
    status As IOutputArray,
    Optional error As IOutputArray = Nothing
)
public:
[ExtensionAttribute]
static void Calc(
    ISparseOpticalFlow^ opticalFlow,
    IInputArray^ prevImg,
    IInputArray^ nextImg,
    IInputArray^ prevPts,
    IInputOutputArray^ nextPts,
    IOutputArray^ status,
    IOutputArray^ error = nullptr
)
[<ExtensionAttribute>]
static member Calc :
        opticalFlow : ISparseOpticalFlow *
        prevImg : IInputArray *
        nextImg : IInputArray *
        prevPts : IInputArray *
        nextPts : IInputOutputArray *
        status : IOutputArray *
        ?error : IOutputArray
(* Defaults:
        let _error = defaultArg error null
*)
-> unit

Parameters

opticalFlow
Type: Emgu.CVISparseOpticalFlow
The sparse optical flow
prevImg
Type: Emgu.CVIInputArray
First input image.
nextImg
Type: Emgu.CVIInputArray
Second input image of the same size and the same type as prevImg.
prevPts
Type: Emgu.CVIInputArray
Vector of 2D points for which the flow needs to be found.
nextPts
Type: Emgu.CVIInputOutputArray
Output vector of 2D points containing the calculated new positions of input features in the second image.
status
Type: Emgu.CVIOutputArray
Output status vector. Each element of the vector is set to 1 if the flow for the corresponding features has been found.Otherwise, it is set to 0.
error (Optional)
Type: Emgu.CVIOutputArray
Optional output vector that contains error response for each point (inverse confidence).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISparseOpticalFlow. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SparseOpticalFlowExtensions Class
Emgu.CV Namespace


SparsePyrLKOpticalFlow Class

The class can calculate an optical flow for a sparse feature set using the iterative Lucas-Kanade method with pyramids.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVSparsePyrLKOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SparsePyrLKOpticalFlow : UnmanagedObject,
    ISparseOpticalFlow, IAlgorithm
Public Class SparsePyrLKOpticalFlow
    Inherits UnmanagedObject
    Implements ISparseOpticalFlow, IAlgorithm
public ref class SparsePyrLKOpticalFlow : public UnmanagedObject,
    ISparseOpticalFlow, IAlgorithm
type SparsePyrLKOpticalFlow =
    class
        inherit UnmanagedObject
        interface ISparseOpticalFlow
        interface IAlgorithm
    end

The SparsePyrLKOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | SparsePyrLKOpticalFlow | Create a SparsePyrLKOpticalFlow object
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SparseOpticalFlowPtr | Pointer to the unmanaged SparseOpticalFlow object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by SparseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


SparsePyrLKOpticalFlow Constructor

Create a SparsePyrLKOpticalFlow object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SparsePyrLKOpticalFlow(
    Size winSize,
    int maxLevel,
    MCvTermCriteria crit,
    LKFlowFlag flags,
    double minEigThreshold
)
Public Sub New (
    winSize As Size,
    maxLevel As Integer,
    crit As MCvTermCriteria,
    flags As LKFlowFlag,
    minEigThreshold As Double
)
public:
SparsePyrLKOpticalFlow(
    Size^ winSize,
    int maxLevel,
    MCvTermCriteria^ crit,
    LKFlowFlag^ flags,
    double minEigThreshold
)
new :
        winSize : Size *
        maxLevel : int *
        crit : MCvTermCriteria *
        flags : LKFlowFlag *
        minEigThreshold : float -> SparsePyrLKOpticalFlow

Parameters

winSize
Type: System.DrawingSize
size of the search window at each pyramid level.
maxLevel
Type: SystemInt32
0-based maximal pyramid level number; if set to 0, pyramids are not used (single level), if set to 1, two levels are used, and so on; if pyramids are passed to input then algorithm will use as many levels as pyramids have but no more than maxLevel.
crit
Type: Emgu.CV.StructureMCvTermCriteria
specifying the termination criteria of the iterative search algorithm (after the specified maximum number of iterations criteria.maxCount or when the search window moves by less than criteria.epsilon.
flags
Type: Emgu.CV.CvEnumLKFlowFlag
operation flags
minEigThreshold
Type: SystemDouble
the algorithm calculates the minimum eigen value of a 2x2 normal matrix of optical flow equations, divided by number of pixels in a window; if this value is less than minEigThreshold, then a corresponding feature is filtered out and its flow is not processed, so it allows to remove bad points and get a performance boost.
See Also

Reference

SparsePyrLKOpticalFlow Class
Emgu.CV Namespace


SparsePyrLKOpticalFlow Properties

The SparsePyrLKOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SparseOpticalFlowPtr | Pointer to the unmanaged SparseOpticalFlow object
Top
See Also

Reference

SparsePyrLKOpticalFlow Class
Emgu.CV Namespace


SparsePyrLKOpticalFlow.AlgorithmPtr Property

SparsePyrLKOpticalFlowAlgorithmPtr Property

Return the pointer to the algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

SparsePyrLKOpticalFlow Class
Emgu.CV Namespace


SparsePyrLKOpticalFlow.SparseOpticalFlowPtr Property

SparsePyrLKOpticalFlowSparseOpticalFlowPtr Property

Pointer to the unmanaged SparseOpticalFlow object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SparseOpticalFlowPtr { get; }
Public ReadOnly Property SparseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr SparseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract SparseOpticalFlowPtr : IntPtr with get
override SparseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ISparseOpticalFlowSparseOpticalFlowPtr
See Also

Reference

SparsePyrLKOpticalFlow Class
Emgu.CV Namespace


SparsePyrLKOpticalFlow Methods

The SparsePyrLKOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by SparseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

SparsePyrLKOpticalFlow Class
Emgu.CV Namespace


SparsePyrLKOpticalFlow.DisposeObject Method

SparsePyrLKOpticalFlowDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SparsePyrLKOpticalFlow Class
Emgu.CV Namespace


SparsePyrLKOpticalFlow Fields

The SparsePyrLKOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SparsePyrLKOpticalFlow Class
Emgu.CV Namespace


SparseRLOFOpticalFlow Class

Class used for calculation sparse optical flow and feature tracking with robust local optical flow (RLOF) algorithms.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CVSparseRLOFOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SparseRLOFOpticalFlow : SharedPtrObject,
    ISparseOpticalFlow, IAlgorithm
Public Class SparseRLOFOpticalFlow
    Inherits SharedPtrObject
    Implements ISparseOpticalFlow, IAlgorithm
public ref class SparseRLOFOpticalFlow : public SharedPtrObject,
    ISparseOpticalFlow, IAlgorithm
type SparseRLOFOpticalFlow =
    class
        inherit SharedPtrObject
        interface ISparseOpticalFlow
        interface IAlgorithm
    end

The SparseRLOFOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | SparseRLOFOpticalFlow | Creates instance of SparseRLOFOpticalFlow
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | SparseOpticalFlowPtr | Gets the sparse optical flow pointer.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by SparseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


SparseRLOFOpticalFlow Constructor

Creates instance of SparseRLOFOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SparseRLOFOpticalFlow(
    RLOFOpticalFlowParameter parameter,
    float forwardBackwardThreshold
)
Public Sub New (
    parameter As RLOFOpticalFlowParameter,
    forwardBackwardThreshold As Single
)
public:
SparseRLOFOpticalFlow(
    RLOFOpticalFlowParameter^ parameter,
    float forwardBackwardThreshold
)
new :
        parameter : RLOFOpticalFlowParameter *
        forwardBackwardThreshold : float32 -> SparseRLOFOpticalFlow

Parameters

parameter
Type: Emgu.CVRLOFOpticalFlowParameter
The RLOF optical flow parameters
forwardBackwardThreshold
Type: SystemSingle
Threshold for the forward backward confidence check. Use 1.0f for default
See Also

Reference

SparseRLOFOpticalFlow Class
Emgu.CV Namespace


SparseRLOFOpticalFlow Properties

The SparseRLOFOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | SparseOpticalFlowPtr | Gets the sparse optical flow pointer.
Top
See Also

Reference

SparseRLOFOpticalFlow Class
Emgu.CV Namespace


SparseRLOFOpticalFlow.AlgorithmPtr Property

SparseRLOFOpticalFlowAlgorithmPtr Property

Return the pointer to the algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

SparseRLOFOpticalFlow Class
Emgu.CV Namespace


SparseRLOFOpticalFlow.SparseOpticalFlowPtr Property

SparseRLOFOpticalFlowSparseOpticalFlowPtr Property

Gets the sparse optical flow pointer.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SparseOpticalFlowPtr { get; }
Public ReadOnly Property SparseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr SparseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract SparseOpticalFlowPtr : IntPtr with get
override SparseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
The pointer to the sparse optical flow object.

Implements

ISparseOpticalFlowSparseOpticalFlowPtr
See Also

Reference

SparseRLOFOpticalFlow Class
Emgu.CV Namespace


SparseRLOFOpticalFlow Methods

The SparseRLOFOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by SparseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

SparseRLOFOpticalFlow Class
Emgu.CV Namespace


SparseRLOFOpticalFlow.DisposeObject Method

SparseRLOFOpticalFlowDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SparseRLOFOpticalFlow Class
Emgu.CV Namespace


SparseRLOFOpticalFlow Fields

The SparseRLOFOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

SparseRLOFOpticalFlow Class
Emgu.CV Namespace


StereoBM Class

Class for computing stereo correspondence using the block matching algorithm, introduced and contributed to OpenCV by K. Konolige.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CVStereoBM

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class StereoBM : SharedPtrObject, IStereoMatcher
Public Class StereoBM
    Inherits SharedPtrObject
    Implements IStereoMatcher
public ref class StereoBM : public SharedPtrObject,
    IStereoMatcher
type StereoBM =
    class
        inherit SharedPtrObject
        interface IStereoMatcher
    end

The StereoBM type exposes the following members.

Constructors
 | Name | Description
Public method | StereoBM | Create a stereoBM object
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | StereoMatcherPtr | Pointer to the stereo matcher
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the stereo state and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

Emgu.CV Namespace


StereoBM Constructor

Create a stereoBM object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StereoBM(
    int numberOfDisparities = 0,
    int blockSize = 21
)
Public Sub New (
    Optional numberOfDisparities As Integer = 0,
    Optional blockSize As Integer = 21
)
public:
StereoBM(
    int numberOfDisparities = 0,
    int blockSize = 21
)
new :
        ?numberOfDisparities : int *
        ?blockSize : int
(* Defaults:
        let _numberOfDisparities = defaultArg numberOfDisparities 0
        let _blockSize = defaultArg blockSize 21
*)
-> StereoBM

Parameters

numberOfDisparities (Optional)
Type: SystemInt32
the disparity search range. For each pixel algorithm will find the best disparity from 0 (default minimum disparity) to numberOfDisparities. The search range can then be shifted by changing the minimum disparity.
blockSize (Optional)
Type: SystemInt32
the linear size of the blocks compared by the algorithm. The size should be odd (as the block is centered at the current pixel). Larger block size implies smoother, though less accurate disparity map. Smaller block size gives more detailed disparity map, but there is higher chance for algorithm to find a wrong correspondence.
See Also

Reference

StereoBM Class
Emgu.CV Namespace


StereoBM Properties

The StereoBM type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | StereoMatcherPtr | Pointer to the stereo matcher
Top
See Also

Reference

StereoBM Class
Emgu.CV Namespace


StereoBM.StereoMatcherPtr Property

StereoBMStereoMatcherPtr Property

Pointer to the stereo matcher

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StereoMatcherPtr { get; }
Public ReadOnly Property StereoMatcherPtr As IntPtr
    Get
public:
virtual property IntPtr StereoMatcherPtr {
    IntPtr get () sealed;
}
abstract StereoMatcherPtr : IntPtr with get
override StereoMatcherPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IStereoMatcherStereoMatcherPtr
See Also

Reference

StereoBM Class
Emgu.CV Namespace


StereoBM Methods

The StereoBM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the stereo state and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

StereoBM Class
Emgu.CV Namespace


StereoBM.DisposeObject Method

StereoBMDisposeObject Method

Release the stereo state and all the memory associate with it

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

StereoBM Class
Emgu.CV Namespace


StereoBM Fields

The StereoBM type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

StereoBM Class
Emgu.CV Namespace


StereoSGBM Class

This is a variation of "Stereo Processing by Semiglobal Matching and Mutual Information" by Heiko Hirschmuller. We match blocks rather than individual pixels, thus the algorithm is called SGBM (Semi-global block matching)
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CVStereoSGBM

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class StereoSGBM : SharedPtrObject, IStereoMatcher
Public Class StereoSGBM
    Inherits SharedPtrObject
    Implements IStereoMatcher
public ref class StereoSGBM : public SharedPtrObject,
    IStereoMatcher
type StereoSGBM =
    class
        inherit SharedPtrObject
        interface IStereoMatcher
    end

The StereoSGBM type exposes the following members.

Constructors
 | Name | Description
Public method | StereoSGBM | Create a stereo disparity solver using StereoSGBM algorithm (combination of H. Hirschmuller + K. Konolige approaches)
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | StereoMatcherPtr | Pointer to the StereoMatcher
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this stereo solver (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

Emgu.CV Namespace


StereoSGBM Constructor

Create a stereo disparity solver using StereoSGBM algorithm (combination of H. Hirschmuller + K. Konolige approaches)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StereoSGBM(
    int minDisparity,
    int numDisparities,
    int blockSize,
    int p1 = 0,
    int p2 = 0,
    int disp12MaxDiff = 0,
    int preFilterCap = 0,
    int uniquenessRatio = 0,
    int speckleWindowSize = 0,
    int speckleRange = 0,
    StereoSGBMMode mode = 0
)
Public Sub New (
    minDisparity As Integer,
    numDisparities As Integer,
    blockSize As Integer,
    Optional p1 As Integer = 0,
    Optional p2 As Integer = 0,
    Optional disp12MaxDiff As Integer = 0,
    Optional preFilterCap As Integer = 0,
    Optional uniquenessRatio As Integer = 0,
    Optional speckleWindowSize As Integer = 0,
    Optional speckleRange As Integer = 0,
    Optional mode As StereoSGBMMode = 0
)
public:
StereoSGBM(
    int minDisparity,
    int numDisparities,
    int blockSize,
    int p1 = 0,
    int p2 = 0,
    int disp12MaxDiff = 0,
    int preFilterCap = 0,
    int uniquenessRatio = 0,
    int speckleWindowSize = 0,
    int speckleRange = 0,
    StereoSGBMMode^ mode = 0
)
new :
        minDisparity : int *
        numDisparities : int *
        blockSize : int *
        ?p1 : int *
        ?p2 : int *
        ?disp12MaxDiff : int *
        ?preFilterCap : int *
        ?uniquenessRatio : int *
        ?speckleWindowSize : int *
        ?speckleRange : int *
        ?mode : StereoSGBMMode
(* Defaults:
        let _p1 = defaultArg p1 0
        let _p2 = defaultArg p2 0
        let _disp12MaxDiff = defaultArg disp12MaxDiff 0
        let _preFilterCap = defaultArg preFilterCap 0
        let _uniquenessRatio = defaultArg uniquenessRatio 0
        let _speckleWindowSize = defaultArg speckleWindowSize 0
        let _speckleRange = defaultArg speckleRange 0
        let _mode = defaultArg mode 0
*)
-> StereoSGBM

Parameters

minDisparity
Type: SystemInt32
Minimum possible disparity value. Normally, it is zero but sometimes rectification algorithms can shift images, so this parameter needs to be adjusted accordingly.
numDisparities
Type: SystemInt32
Maximum disparity minus minimum disparity. The value is always greater than zero. In the current implementation, this parameter must be divisible by 16.
blockSize
Type: SystemInt32
Matched block size. It must be an odd number >=1 . Normally, it should be somewhere in the 3..11 range. Use 0 for default.
p1 (Optional)
Type: SystemInt32
The first parameter controlling the disparity smoothness. It is the penalty on the disparity change by plus or minus 1 between neighbor pixels. Reasonably good value is 8*number_of_image_channels*SADWindowSize*SADWindowSize. Use 0 for default
p2 (Optional)
Type: SystemInt32
The second parameter controlling the disparity smoothness. It is the penalty on the disparity change by more than 1 between neighbor pixels. The algorithm requires p2 > p1. Reasonably good value is 32*number_of_image_channels*SADWindowSize*SADWindowSize. Use 0 for default
disp12MaxDiff (Optional)
Type: SystemInt32
Maximum allowed difference (in integer pixel units) in the left-right disparity check. Set it to a non-positive value to disable the check.
preFilterCap (Optional)
Type: SystemInt32
Truncation value for the prefiltered image pixels. The algorithm first computes x-derivative at each pixel and clips its value by [-preFilterCap, preFilterCap] interval. The result values are passed to the Birchfield-Tomasi pixel cost function.
uniquenessRatio (Optional)
Type: SystemInt32
Margin in percentage by which the best (minimum) computed cost function value should “win” the second best value to consider the found match correct. Normally, a value within the 5-15 range is good enough.
speckleWindowSize (Optional)
Type: SystemInt32
Maximum size of smooth disparity regions to consider their noise speckles and invalidate. Set it to 0 to disable speckle filtering. Otherwise, set it somewhere in the 50-200 range
speckleRange (Optional)
Type: SystemInt32
Maximum disparity variation within each connected component. If you do speckle filtering, set the parameter to a positive value, it will be implicitly multiplied by 16. Normally, 1 or 2 is good enough.
mode (Optional)
Type: Emgu.CVStereoSGBMMode
Set it to HH to run the full-scale two-pass dynamic programming algorithm. It will consume O(W*H*numDisparities) bytes, which is large for 640x480 stereo and huge for HD-size pictures. By default, it is set to false.
See Also

Reference

StereoSGBM Class
Emgu.CV Namespace


StereoSGBM Properties

The StereoSGBM type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | StereoMatcherPtr | Pointer to the StereoMatcher
Top
See Also

Reference

StereoSGBM Class
Emgu.CV Namespace


StereoSGBM.StereoMatcherPtr Property

StereoSGBMStereoMatcherPtr Property

Pointer to the StereoMatcher

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StereoMatcherPtr { get; }
Public ReadOnly Property StereoMatcherPtr As IntPtr
    Get
public:
virtual property IntPtr StereoMatcherPtr {
    IntPtr get () sealed;
}
abstract StereoMatcherPtr : IntPtr with get
override StereoMatcherPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IStereoMatcherStereoMatcherPtr
See Also

Reference

StereoSGBM Class
Emgu.CV Namespace


StereoSGBM Methods

The StereoSGBM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this stereo solver (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

StereoSGBM Class
Emgu.CV Namespace


StereoSGBM.DisposeObject Method

StereoSGBMDisposeObject Method

Release the unmanaged memory associated with this stereo solver

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

StereoSGBM Class
Emgu.CV Namespace


StereoSGBM Fields

The StereoSGBM type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

StereoSGBM Class
Emgu.CV Namespace


StereoSGBM.Mode Class

StereoSGBMMode Class

The SGBM mode
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVStereoSGBMMode

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Mode : Enum
Public NotInheritable Class Mode
    Inherits Enum
public ref class Mode sealed : public Enum
[<SealedAttribute>]
type Mode =
    class
        inherit Enum
    end

The StereoSGBMMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | HH | Run the full-scale two-pass dynamic programming algorithm. It will consume O(W*H*numDisparities) bytes, which is large for 640x480 stereo and huge for HD-size pictures.
 | SGBM | This is the default mode, the algorithm is single-pass, which means that you consider only 5 directions instead of 8
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


Mode Methods

The StereoSGBMMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

StereoSGBMMode Class
Emgu.CV Namespace


Mode Fields

The StereoSGBMMode type exposes the following members.

Fields
 | Name | Description
 | HH | Run the full-scale two-pass dynamic programming algorithm. It will consume O(W*H*numDisparities) bytes, which is large for 640x480 stereo and huge for HD-size pictures.
 | SGBM | This is the default mode, the algorithm is single-pass, which means that you consider only 5 directions instead of 8
Public field | value__ |
Top
See Also

Reference

StereoSGBMMode Class
Emgu.CV Namespace


StereoSGBM.Mode.HH Field

StereoSGBMModeHH Field

Run the full-scale two-pass dynamic programming algorithm. It will consume O(W*H*numDisparities) bytes, which is large for 640x480 stereo and huge for HD-size pictures.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StereoSGBMMode HH = 1
Public Const HH As StereoSGBMMode = 1
public:
literal StereoSGBMMode^ HH = 1
static val mutable HH: StereoSGBMMode

Field Value

Type: StereoSGBMMode
See Also

Reference

StereoSGBMMode Class
Emgu.CV Namespace


StereoSGBM.Mode.SGBM Field

StereoSGBMModeSGBM Field

This is the default mode, the algorithm is single-pass, which means that you consider only 5 directions instead of 8

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StereoSGBMMode SGBM = 0
Public Const SGBM As StereoSGBMMode = 0
public:
literal StereoSGBMMode^ SGBM = 0
static val mutable SGBM: StereoSGBMMode

Field Value

Type: StereoSGBMMode
See Also

Reference

StereoSGBMMode Class
Emgu.CV Namespace


StereoSGBM.Mode.value__ Field

StereoSGBMModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.StereoSGBM.Mode.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

StereoSGBMMode Class
Emgu.CV Namespace


Subdiv2D Class

Planar Subdivision, can be use to compute Delaunnay's triangulation or Voroni diagram.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVSubdiv2D

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Subdiv2D : UnmanagedObject
Public Class Subdiv2D
    Inherits UnmanagedObject
public ref class Subdiv2D : public UnmanagedObject
type Subdiv2D =
    class
        inherit UnmanagedObject
    end

The Subdiv2D type exposes the following members.

Constructors
 | Name | Description
Public method | Subdiv2D(Rectangle) | Start the Delaunay's triangulation in the specific region of interest.
Public method | Subdiv2D(PointF, Boolean) | Create a planar subdivision from the given points. The ROI is computed as the minimum bounding Rectangle for the input points
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindNearest | Finds subdivision vertex that is the closest to the input point. It is not necessarily one of vertices of the facet containing the input point, though the facet (located using cvSubdiv2DLocate) is used as a starting point.
Public method | GetDelaunayTriangles | Returns the triangles subdivision of the current planar subdivision.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVoronoiFacets | Obtains the list of Voronoi Facets
Public method | Insert(PointF) | Insert a point to the triangulation.
Public method | Insert(PointF, Boolean) | Insert a collection of points to this planar subdivision
Public method | Locate | Locates input point within subdivision
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


Subdiv2D Constructor

Overload List
 | Name | Description
Public method | Subdiv2D(Rectangle) | Start the Delaunay's triangulation in the specific region of interest.
Public method | Subdiv2D(PointF, Boolean) | Create a planar subdivision from the given points. The ROI is computed as the minimum bounding Rectangle for the input points
Top
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D Constructor (Rectangle)

Start the Delaunay's triangulation in the specific region of interest.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Subdiv2D(
    Rectangle roi
)
Public Sub New (
    roi As Rectangle
)
public:
Subdiv2D(
    Rectangle^ roi
)
new :
        roi : Rectangle -> Subdiv2D

Parameters

roi
Type: System.DrawingRectangle
The region of interest of the triangulation
See Also

Reference

Subdiv2D Class
Subdiv2D Overload
Emgu.CV Namespace


Subdiv2D Constructor (PointF[], Boolean)

Subdiv2D Constructor (PointF, Boolean)

http://www.emgu.com
Create a planar subdivision from the given points. The ROI is computed as the minimum bounding Rectangle for the input points

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Subdiv2D(
    PointF[] points,
    bool silent = false
)
Public Sub New (
    points As PointF(),
    Optional silent As Boolean = false
)
public:
Subdiv2D(
    array<PointF^>^ points,
    bool silent = false
)
new :
        points : PointF[] *
        ?silent : bool
(* Defaults:
        let _silent = defaultArg silent false
*)
-> Subdiv2D

Parameters

points
Type: System.DrawingPointF
The points to be inserted to this planar subdivision
silent (Optional)
Type: SystemBoolean
If true, any exception during insert will be ignored
See Also

Reference

Subdiv2D Class
Subdiv2D Overload
Emgu.CV Namespace


Subdiv2D Properties

The Subdiv2D type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D Methods

The Subdiv2D type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindNearest | Finds subdivision vertex that is the closest to the input point. It is not necessarily one of vertices of the facet containing the input point, though the facet (located using cvSubdiv2DLocate) is used as a starting point.
Public method | GetDelaunayTriangles | Returns the triangles subdivision of the current planar subdivision.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVoronoiFacets | Obtains the list of Voronoi Facets
Public method | Insert(PointF) | Insert a point to the triangulation.
Public method | Insert(PointF, Boolean) | Insert a collection of points to this planar subdivision
Public method | Locate | Locates input point within subdivision
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D.DisposeObject Method

Subdiv2DDisposeObject Method

Release unmanaged resources

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D.FindNearest Method

Subdiv2DFindNearest Method

Finds subdivision vertex that is the closest to the input point. It is not necessarily one of vertices of the facet containing the input point, though the facet (located using cvSubdiv2DLocate) is used as a starting point.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Subdiv2DPointLocationType FindNearest(
    PointF point,
    out PointF nearestPoint
)
Public Function FindNearest (
    point As PointF,
    <OutAttribute> ByRef nearestPoint As PointF
) As Subdiv2DPointLocationType
public:
Subdiv2DPointLocationType^ FindNearest(
    PointF^ point,
    [OutAttribute] PointF^% nearestPoint
)
member FindNearest :
        point : PointF *
        nearestPoint : PointF byref -> Subdiv2DPointLocationType

Parameters

point
Type: System.DrawingPointF
Input point
nearestPoint
Type: System.DrawingPointF
The nearest subdivision vertex

Return Value

Type: Subdiv2DPointLocationType
The location type of the point
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D.GetDelaunayTriangles Method

Subdiv2DGetDelaunayTriangles Method

Returns the triangles subdivision of the current planar subdivision.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Triangle2DF[] GetDelaunayTriangles(
    bool includeVirtualPoints = false
)
Public Function GetDelaunayTriangles (
    Optional includeVirtualPoints As Boolean = false
) As Triangle2DF()
public:
array<Triangle2DF^>^ GetDelaunayTriangles(
    bool includeVirtualPoints = false
)
member GetDelaunayTriangles :
        ?includeVirtualPoints : bool
(* Defaults:
        let _includeVirtualPoints = defaultArg includeVirtualPoints false
*)
-> Triangle2DF[]

Parameters

includeVirtualPoints (Optional)
Type: SystemBoolean
If true, will include the virtual points in the resulting triangles

Return Value

Type: Triangle2DF
The triangles subdivision in the current planar subdivision
Remarks
The triangles might contains virtual points that do not belongs to the inserted points, if you do not want those points, set includeVirtualPoints
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D.GetVoronoiFacets Method

Subdiv2DGetVoronoiFacets Method

Obtains the list of Voronoi Facets

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VoronoiFacet[] GetVoronoiFacets(
    int[] idx = null
)
Public Function GetVoronoiFacets (
    Optional idx As Integer() = Nothing
) As VoronoiFacet()
public:
array<VoronoiFacet^>^ GetVoronoiFacets(
    array<int>^ idx = nullptr
)
member GetVoronoiFacets :
        ?idx : int[]
(* Defaults:
        let _idx = defaultArg idx null
*)
-> VoronoiFacet[]

Parameters

idx (Optional)
Type: SystemInt32
Vector of vertices IDs to consider. For all vertices you can pass empty vector.

Return Value

Type: VoronoiFacet
The list of Voronoi Facets
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D.Insert Method

Subdiv2DInsert Method

Overload List
 | Name | Description
Public method | Insert(PointF) | Insert a point to the triangulation.
Public method | Insert(PointF, Boolean) | Insert a collection of points to this planar subdivision
Top
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D.Insert Method (PointF)

Subdiv2DInsert Method (PointF)

http://www.emgu.com
Insert a point to the triangulation.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    PointF point
)
Public Sub Insert (
    point As PointF
)
public:
void Insert(
    PointF^ point
)
member Insert :
        point : PointF -> unit

Parameters

point
Type: System.DrawingPointF
The point to be inserted
See Also

Reference

Subdiv2D Class
Insert Overload
Emgu.CV Namespace


Subdiv2D.Insert Method (PointF[], Boolean)

Subdiv2DInsert Method (PointF, Boolean)

http://www.emgu.com
Insert a collection of points to this planar subdivision

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    PointF[] points,
    bool silent
)
Public Sub Insert (
    points As PointF(),
    silent As Boolean
)
public:
void Insert(
    array<PointF^>^ points,
    bool silent
)
member Insert :
        points : PointF[] *
        silent : bool -> unit

Parameters

points
Type: System.DrawingPointF
The points to be inserted to this planar subdivision
silent
Type: SystemBoolean
If true, any exception during insert will be ignored
See Also

Reference

Subdiv2D Class
Insert Overload
Emgu.CV Namespace


Subdiv2D.Locate Method

Subdiv2DLocate Method

Locates input point within subdivision

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Subdiv2DPointLocationType Locate(
    PointF pt,
    out int subdiv2DEdge,
    out int subdiv2DPoint
)
Public Function Locate (
    pt As PointF,
    <OutAttribute> ByRef subdiv2DEdge As Integer,
    <OutAttribute> ByRef subdiv2DPoint As Integer
) As Subdiv2DPointLocationType
public:
Subdiv2DPointLocationType^ Locate(
    PointF^ pt,
    [OutAttribute] int% subdiv2DEdge,
    [OutAttribute] int% subdiv2DPoint
)
member Locate :
        pt : PointF *
        subdiv2DEdge : int byref *
        subdiv2DPoint : int byref -> Subdiv2DPointLocationType

Parameters

pt
Type: System.DrawingPointF
The point to locate
subdiv2DEdge
Type: SystemInt32
The output edge the point falls onto or right to
subdiv2DPoint
Type: SystemInt32
Optional output vertex double pointer the input point coincides with

Return Value

Type: Subdiv2DPointLocationType
The type of location for the point
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


Subdiv2D Fields

The Subdiv2D type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Subdiv2D Class
Emgu.CV Namespace


TimedImage(TColor, TDepth) Class

TimedImageTColor, TDepth Class

The Image which contains time stamp which specified what time this image is created
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVCvArray TDepth
Emgu.CVImage TColor, TDepth
Emgu.CVTimedImageTColor, TDepth

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TimedImage<TColor, TDepth> : Image<TColor, TDepth>
where TColor : struct, new(), IColor
where TDepth : new()

<SerializableAttribute>
Public Class TimedImage(Of TColor As {Structure, New, IColor}, TDepth As New)
    Inherits Image(Of TColor, TDepth)
[SerializableAttribute]
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
public ref class TimedImage : public Image<TColor, TDepth>
[<SerializableAttribute>]
type TimedImage<'TColor, 'TDepth when 'TColor : struct, new() and IColor when 'TDepth : new()> =
    class
        inherit Image<'TColor, 'TDepth>
    end

Type Parameters

TColor
The color of this map
TDepth
The depth of this map

The TimedImageTColor, TDepth type exposes the following members.

Constructors
 | Name | Description
Protected method | TimedImageTColor, TDepth | Create a empty Image
Public method | TimedImageTColor, TDepth(Int32, Int32) | Create an empty Image of the specified width and height
Public method | TimedImageTColor, TDepth(Int32, Int32, TColor) | Create a blank Image of the specified width, height, depth and color.
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix. The Get function has O(1) complexity. The Set function make a copy of the data (Inherited from ImageTColor, TDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | IsROISet | Indicates if the region of interest has been set (Inherited from ImageTColor, TDepth.)
Public property | ItemPoint | Get or Set the color in the location (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32 | Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image. (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32, Int32 | Get or Set the color in the rowth row (y direction) and columnth column (x direction) (Inherited from ImageTColor, TDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from ImageTColor, TDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MIplImage | The IplImage structure (Inherited from ImageTColor, TDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this image (Inherited from ImageTColor, TDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | ROI | Get or Set the region of interest for this image. To clear the ROI, set it to System.Drawing.Rectangle.Empty (Inherited from ImageTColor, TDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from ImageTColor, TDepth.)
Public property | Timestamp | The time this image is captured
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Dilate | Dilates this image inplace using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _EqualizeHist | The algorithm inplace normalizes brightness and increases contrast of the image. For color images, a HSV representation of the image is first obtained and the V (value) channel is histogram normalized (Inherited from ImageTColor, TDepth.)
Public method | _Erode | Erodes this image inplace using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _Flip | Inplace flip the image (Inherited from ImageTColor, TDepth.)
Public method | _GammaCorrect | Gamma corrects this image inplace. The image must have a depth type of Byte. (Inherited from ImageTColor, TDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _MorphologyEx | Perform inplace advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _SmoothGaussian(Int32) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinary | Threshold the image inplace such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinaryInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZero | Threshold the image inplace such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZeroInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdTrunc | Threshold the image inplace such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | AbsDiff(ImageTColor, TDepth) | Computes absolute different between this image and the other image (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth, ImageGray, Byte) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double) | Update Running Average. this = (1-alpha)*this + alpha*img (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double, ImageGray, Byte) | Update Running Average. this = (1-alpha)*this + alpha*img, using the mask (Inherited from ImageTColor, TDepth.)
Public method | Action(ActionTDepth) | perform an generic action based on each element of the image (Inherited from ImageTColor, TDepth.)
Public method | ActionTOtherDepth(ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth) | Perform an generic operation based on the elements of the two images (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth) | Elementwise add another image with the current image (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth, ImageGray, Byte) | Elementwise add img2 with the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | AddWeighted | Return the weighted sum such that: res = this * alpha + img2 * beta + gamma (Inherited from ImageTColor, TDepth.)
Protected method | AllocateData | Re-allocate data for the array (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth) | Perform an elementwise AND operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise AND operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar, ImageGray, Byte) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | BuildPyramid | Compute the image pyramid (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double, Int32, Boolean) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a clone of the current image. All image data as well as the COI and ROI are cloned (Inherited from ImageTColor, TDepth.)
Public method | Cmp(Double, CmpType) | Compare the current image with value and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | Cmp(ImageTColor, TDepth, CmpType) | Compare the current image with img2 and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | ConcateHorizontal | Concate the current image with another image horizontally. (Inherited from ImageTColor, TDepth.)
Public method | ConcateVertical | Concate the current image with another image vertically. (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, TOtherDepth) | Compute the element of the new image based on element of this image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, Int32, Int32, TOtherDepth) | Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherColor, TOtherDepth | Convert the current image to the specific color and depth (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3(ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3) | Compute the element of the new image based on the elements of the two image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4(ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4) | Compute the element of the new image based on the elements of the three image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4, TDepth5(ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5) | Compute the element of the new image based on the elements of the four image (Inherited from ImageTColor, TDepth.)
Public method | ConvertFrom(IInputArray) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertFromTSrcColor, TSrcDepth(ImageTSrcColor, TSrcDepth) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertScaleTOtherDepth | Convert the current image to the specific depth, at the same time scale and shift the values of the pixel (Inherited from ImageTColor, TDepth.)
Public method | Convolution | Performs a convolution using the specific kernel (Inherited from ImageTColor, TDepth.)
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination (Inherited from ImageTColor, TDepth.)
Public method | CopyBlank | Create an image of the same size (Inherited from ImageTColor, TDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Public method | CountNonzero | Count the non Zero elements for each channel (Inherited from ImageTColor, TDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dilate | Dilates this image using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associate with the image (Inherited from ImageTColor, TDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image (Inherited from ImageTColor, TDepth.)
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(ImageTColor, TDepth) | Compare two images, returns true if the each of the pixels are equal, false otherwise (Inherited from ImageTColor, TDepth.)
Public method | Erode | Erodes this image using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Exp | Calculates exponent of every element of input array: dst(I)=exp(src(I)) (Inherited from ImageTColor, TDepth.)
Public method | FillConvexPoly | Fill the convex polygon with the specific color (Inherited from ImageTColor, TDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindCornerSubPix | Iterates to find the sub-pixel accurate location of corners, or radial saddle points (Inherited from ImageTColor, TDepth.)
Public method | Flip | Return a flipped copy of the current image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage | Get the average value on this image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage(ImageGray, Byte) | Get the average value on this image, using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetMoments | Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characteristics including 7 Hu invariants. (Inherited from ImageTColor, TDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from ImageTColor, TDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a subimage which image data is shared with the current image. (Inherited from ImageTColor, TDepth.)
Public method | GetSum | Get the sum for each color channel (Inherited from ImageTColor, TDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrabCut | Use grabcut to perform background foreground segmentation. (Inherited from ImageTColor, TDepth.)
Public method | HoughCircles | First apply Canny Edge Detector on the current image, then apply Hough transform to find circles (Inherited from ImageTColor, TDepth.)
Public method | HoughLines | Apply Canny Edge Detector follows by Probabilistic Hough transform to find line segments in the image (Inherited from ImageTColor, TDepth.)
Public method | HoughLinesBinary | Apply Probabilistic Hough transform to find line segments. The current image must be a binary image (eg. the edges as a result of the Canny edge detector) (Inherited from ImageTColor, TDepth.)
Public method | InPaint | Use inpaint to recover the intensity of the pixels which location defined by mask on this image (Inherited from ImageTColor, TDepth.)
Public method | InRange(TColor, TColor) | Checks that image elements lie between two scalars (Inherited from ImageTColor, TDepth.)
Public method | InRange(ImageTColor, TDepth, ImageTColor, TDepth) | Checks that image elements lie between values defined by two images of same size and type (Inherited from ImageTColor, TDepth.)
Public method | Integral | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double) | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double, ImageTColor, Double) | Calculates one or more integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Laplace | Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator. Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0| (Inherited from ImageTColor, TDepth.)
Public method | Log | Calculates natural logarithm of absolute value of every element of input array (Inherited from ImageTColor, TDepth.)
Public method | LogPolar | Convert the image to log polar, simulating the human foveal vision (Inherited from ImageTColor, TDepth.)
Protected method | MapDataToImage | Let this Image object use the specific Image data. (Inherited from ImageTColor, TDepth.)
Public method | MatchTemplate | The function slides through image, compares overlapped patches of size wxh with templ using the specified method and return the comparison results (Inherited from ImageTColor, TDepth.)
Public method | Max(Double) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Public method | Max(ImageTColor, TDepth) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Min(Double) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | Min(ImageTColor, TDepth) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from ImageTColor, TDepth.)
Public method | MorphologyEx | Perform advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | Mul(Double) | Elementwise multiply the current image with scale (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth) | Elementwise multiply img2 with the current image (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth, Double) | Elementwise multiply another image with the current image and the scale (Inherited from ImageTColor, TDepth.)
Public method | Not | Compute the complement image (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth) | Perform an elementwise OR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise OR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | Pow | Raises every element of input array to p dst(I)=src(I)^p, if p is integer dst(I)=abs(src(I))^p, otherwise (Inherited from ImageTColor, TDepth.)
Public method | PyrDown | Performs downsampling step of Gaussian pyramid decomposition. First it convolves this image with the specified filter and then downsamples the image by rejecting even rows and columns. (Inherited from ImageTColor, TDepth.)
Public method | PyrUp | Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples this image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the resulting image is four times larger than the source image. (Inherited from ImageTColor, TDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Resize(Double, Inter) | Scale the image to the specific size: width *= scale; height *= scale (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter, Boolean) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor) | Rotate the image the specified angle cropping the result to the original size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, PointF, Inter, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Save | Save this image to the specific file. (Inherited from ImageTColor, TDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor) | Set every pixel of the image to the specific color (Inherited from ImageTColor, TDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor, ImageGray, Byte) | Set every pixel of the image to the specific color, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | SmoothBilateral | Applying bilateral 3x3 filtering (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32) | Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32, Boolean) | Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothMedian | Finding median of sizexsize neighborhood (Inherited from ImageTColor, TDepth.)
Public method | Sobel | Calculates the image derivative by convolving the image with the appropriate kernel The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative. (Inherited from ImageTColor, TDepth.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth) | Elementwise subtract another image from the current image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth, ImageGray, Byte) | Elementwise subtract another image from the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor) | result = val - this (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor, ImageGray, Byte) | result = val - this, using a mask (Inherited from ImageTColor, TDepth.)
Public method | ThresholdAdaptive | Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1. (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinary | Threshold the image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinaryInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZero | Threshold the image such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZeroInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdTrunc | Threshold the image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ToJpegData | Get the jpeg representation of the image (Inherited from ImageTColor, TDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WarpAffine(Mat, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpAffine(Mat, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Public method | Xor(ImageTColor, TDepth) | Perform an elementwise XOR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Xor(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise XOR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Top
Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


TimedImage(TColor, TDepth) Constructor

TimedImageTColor, TDepth Constructor

Overload List
 | Name | Description
Protected method | TimedImageTColor, TDepth | Create a empty Image
Public method | TimedImageTColor, TDepth(Int32, Int32) | Create an empty Image of the specified width and height
Public method | TimedImageTColor, TDepth(Int32, Int32, TColor) | Create a blank Image of the specified width, height, depth and color.
Top
See Also

Reference

TimedImageTColor, TDepth Class
Emgu.CV Namespace


TimedImage(TColor, TDepth) Constructor

TimedImageTColor, TDepth Constructor

Create a empty Image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected TimedImage()
Protected Sub New
protected:
TimedImage()
new : unit -> TimedImage
See Also

Reference

TimedImageTColor, TDepth Class
TimedImageTColor, TDepth Overload
Emgu.CV Namespace


TimedImage(TColor, TDepth) Constructor (Int32, Int32)

TimedImageTColor, TDepth Constructor (Int32, Int32)

http://www.emgu.com
Create an empty Image of the specified width and height

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TimedImage(
    int width,
    int height
)
Public Sub New (
    width As Integer,
    height As Integer
)
public:
TimedImage(
    int width,
    int height
)
new :
        width : int *
        height : int -> TimedImage

Parameters

width
Type: SystemInt32
The width of the image
height
Type: SystemInt32
The height of the image
See Also

Reference

TimedImageTColor, TDepth Class
TimedImageTColor, TDepth Overload
Emgu.CV Namespace


TimedImage(TColor, TDepth) Constructor (Int32, Int32, TColor)

TimedImageTColor, TDepth Constructor (Int32, Int32, TColor)

http://www.emgu.com
Create a blank Image of the specified width, height, depth and color.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TimedImage(
    int width,
    int height,
    TColor value
)
Public Sub New (
    width As Integer,
    height As Integer,
    value As TColor
)
public:
TimedImage(
    int width,
    int height,
    TColor value
)
new :
        width : int *
        height : int *
        value : 'TColor -> TimedImage

Parameters

width
Type: SystemInt32
The width of the image
height
Type: SystemInt32
The height of the image
value
Type: TColor
The initial color of the image
See Also

Reference

TimedImageTColor, TDepth Class
TimedImageTColor, TDepth Overload
Emgu.CV Namespace


TimedImage(TColor, TDepth) Properties

TimedImageTColor, TDepth Properties

The TimedImageTColor, TDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set an Array of bytes that represent the data in this array (Inherited from CvArrayTDepth.)
Public property | Cols | The number of cols for this array (Inherited from CvArrayTDepth.)
Public property | Data | Get or Set the data for this matrix. The Get function has O(1) complexity. The Set function make a copy of the data (Inherited from ImageTColor, TDepth.)
Public property | Height | Get the height (Rows) of the cvArray. If ROI is set, the height of the ROI (Inherited from CvArrayTDepth.)
Public property | IsROISet | Indicates if the region of interest has been set (Inherited from ImageTColor, TDepth.)
Public property | ItemPoint | Get or Set the color in the location (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32 | Get or Set the specific channel of the current image. For Get operation, a copy of the specific channel is returned. For Set operation, the specific channel is copied to this image. (Inherited from ImageTColor, TDepth.)
Public property | ItemInt32, Int32 | Get or Set the color in the rowth row (y direction) and columnth column (x direction) (Inherited from ImageTColor, TDepth.)
Public property | ManagedArray | Get the underneath managed array (Inherited from ImageTColor, TDepth.)
Public property | Mat | Get the Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Public property | MIplImage | The IplImage structure (Inherited from ImageTColor, TDepth.)
Public property | Norm | The norm of this Array (Inherited from CvArrayTDepth.)
Public property | NumberOfChannels | Get the number of channels for this image (Inherited from ImageTColor, TDepth.)
Public property | Ptr | The pointer to the internal structure (Inherited from CvArrayTDepth.)
Public property | ROI | Get or Set the region of interest for this image. To clear the ROI, set it to System.Drawing.Rectangle.Empty (Inherited from ImageTColor, TDepth.)
Public property | Rows | The number of rows for this array (Inherited from CvArrayTDepth.)
Public property | SerializationCompressionRatio | Get or set the Compression Ratio for serialization. A number between 0 - 9. 0 means no compression at all, while 9 means best compression (Inherited from CvArrayTDepth.)
Public property | Size | Get the size of the array (Inherited from ImageTColor, TDepth.)
Public property | Timestamp | The time this image is captured
Public property | Trace | Sum of diagonal elements of the matrix (Inherited from CvArrayTDepth.)
Public property | Width | Get the width (Cols) of the cvArray. If ROI is set, the width of the ROI (Inherited from CvArrayTDepth.)
Top
See Also

Reference

TimedImageTColor, TDepth Class
Emgu.CV Namespace


TimedImage(TColor, TDepth).Timestamp Property

TimedImageTColor, TDepthTimestamp Property

The time this image is captured

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime^ Timestamp {
    DateTime^ get ();
    void set (DateTime^ value);
}
member Timestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

TimedImageTColor, TDepth Class
Emgu.CV Namespace


TimedImage(TColor, TDepth) Methods

TimedImageTColor, TDepth Methods

The TimedImageTColor, TDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | _And | Inplace And operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _Dilate | Dilates this image inplace using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _EqualizeHist | The algorithm inplace normalizes brightness and increases contrast of the image. For color images, a HSV representation of the image is first obtained and the V (value) channel is histogram normalized (Inherited from ImageTColor, TDepth.)
Public method | _Erode | Erodes this image inplace using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | _Flip | Inplace flip the image (Inherited from ImageTColor, TDepth.)
Public method | _GammaCorrect | Gamma corrects this image inplace. The image must have a depth type of Byte. (Inherited from ImageTColor, TDepth.)
Public method | _Max(Double) | Inplace compute the elementwise maximum value with value (Inherited from CvArrayTDepth.)
Public method | _Max(CvArrayTDepth) | Inplace elementwise maximize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _Min(Double) | Inplace compute the elementwise minimum value (Inherited from CvArrayTDepth.)
Public method | _Min(CvArrayTDepth) | Inplace elementwise minimize the current Array with other (Inherited from CvArrayTDepth.)
Public method | _MorphologyEx | Perform inplace advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | _Mul(Double) | Inplace multiply elements of the Array by scale (Inherited from CvArrayTDepth.)
Public method | _Mul(CvArrayTDepth) | Inplace elementwise multiply the current Array with src2 (Inherited from CvArrayTDepth.)
Public method | _Not | Inplace compute the complement for all array elements (Inherited from CvArrayTDepth.)
Public method | _Or | Inplace Or operation with otherArray (Inherited from CvArrayTDepth.)
Public method | _SmoothGaussian(Int32) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing inplace for the current image (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinary | Threshold the image inplace such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdBinaryInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZero | Threshold the image inplace such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdToZeroInv | Threshold the image inplace such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | _ThresholdTrunc | Threshold the image inplace such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | AbsDiff(ImageTColor, TDepth) | Computes absolute different between this image and the other image (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | Accumulate(ImageTColor, TDepth, ImageGray, Byte) | Accumulate img2 to the current image using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double) | Update Running Average. this = (1-alpha)*this + alpha*img (Inherited from ImageTColor, TDepth.)
Public method | AccumulateWeighted(ImageTColor, TDepth, Double, ImageGray, Byte) | Update Running Average. this = (1-alpha)*this + alpha*img, using the mask (Inherited from ImageTColor, TDepth.)
Public method | Action(ActionTDepth) | perform an generic action based on each element of the image (Inherited from ImageTColor, TDepth.)
Public method | ActionTOtherDepth(ImageTColor, TOtherDepth, ActionTDepth, TOtherDepth) | Perform an generic operation based on the elements of the two images (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth) | Elementwise add another image with the current image (Inherited from ImageTColor, TDepth.)
Public method | Add(ImageTColor, TDepth, ImageGray, Byte) | Elementwise add img2 with the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | AddWeighted | Return the weighted sum such that: res = this * alpha + img2 * beta + gamma (Inherited from ImageTColor, TDepth.)
Protected method | AllocateData | Re-allocate data for the array (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth) | Perform an elementwise AND operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | And(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise AND operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | AvgSdv(TColor, MCvScalar, ImageGray, Byte) | Calculates the average value and standard deviation of array elements, independently for each channel (Inherited from ImageTColor, TDepth.)
Public method | BuildPyramid | Compute the image pyramid (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | Canny(Double, Double, Int32, Boolean) | Find the edges on this image and marked them in the returned image. (Inherited from ImageTColor, TDepth.)
Public method | CheckRange | Check that every array element is neither NaN nor +- inf. The functions also check that each value is between min and max. in the case of multi-channel arrays each channel is processed independently. If some values are out of range, position of the first outlier is stored in pos, and then the functions return false. (Inherited from CvArrayTDepth.)
Public method | Clone | Make a clone of the current image. All image data as well as the COI and ROI are cloned (Inherited from ImageTColor, TDepth.)
Public method | Cmp(Double, CmpType) | Compare the current image with value and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | Cmp(ImageTColor, TDepth, CmpType) | Compare the current image with img2 and returns the comparison mask (Inherited from ImageTColor, TDepth.)
Public method | ConcateHorizontal | Concate the current image with another image horizontally. (Inherited from ImageTColor, TDepth.)
Public method | ConcateVertical | Concate the current image with another image vertically. (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, TOtherDepth) | Compute the element of the new image based on element of this image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherDepth(FuncTDepth, Int32, Int32, TOtherDepth) | Compute the element of a new image based on the value as well as the x and y positions of each pixel on the image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTOtherColor, TOtherDepth | Convert the current image to the specific color and depth (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3(ImageTColor, TDepth2, FuncTDepth, TDepth2, TDepth3) | Compute the element of the new image based on the elements of the two image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4(ImageTColor, TDepth2, ImageTColor, TDepth3, FuncTDepth, TDepth2, TDepth3, TDepth4) | Compute the element of the new image based on the elements of the three image (Inherited from ImageTColor, TDepth.)
Public method | ConvertTDepth2, TDepth3, TDepth4, TDepth5(ImageTColor, TDepth2, ImageTColor, TDepth3, ImageTColor, TDepth4, FuncTDepth, TDepth2, TDepth3, TDepth4, TDepth5) | Compute the element of the new image based on the elements of the four image (Inherited from ImageTColor, TDepth.)
Public method | ConvertFrom(IInputArray) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertFromTSrcColor, TSrcDepth(ImageTSrcColor, TSrcDepth) | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage. (Inherited from ImageTColor, TDepth.)
Public method | ConvertScaleTOtherDepth | Convert the current image to the specific depth, at the same time scale and shift the values of the pixel (Inherited from ImageTColor, TDepth.)
Public method | Convolution | Performs a convolution using the specific kernel (Inherited from ImageTColor, TDepth.)
Public method | Copy | Make a copy of the image, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(Rectangle) | Make a copy of the specific ROI (Region of Interest) from the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(ImageGray, Byte) | Make a copy of the image using a mask, if ROI is set, only copy the ROI (Inherited from ImageTColor, TDepth.)
Public method | Copy(RotatedRect) | Get a copy of the boxed region of the image (Inherited from ImageTColor, TDepth.)
Public method | Copy(ImageTColor, TDepth, ImageGray, Byte) | Copy the masked area of this image to destination (Inherited from ImageTColor, TDepth.)
Public method | CopyBlank | Create an image of the same size (Inherited from ImageTColor, TDepth.)
Public method | CopyTo | Copy the current array to destination (Inherited from CvArrayTDepth.)
Public method | CountNonzero | Count the non Zero elements for each channel (Inherited from ImageTColor, TDepth.)
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object (Inherited from CvArrayTDepth.)
Public method | Dilate | Dilates this image using a 3x3 rectangular structuring element. Dilation are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associate with the image (Inherited from ImageTColor, TDepth.)
Public method | DotProduct | Calculates and returns the Euclidean dot product of two arrays. src1 dot src2 = sumI(src1(I)*src2(I)) (Inherited from CvArrayTDepth.)
Public method | Draw(Cross2DF, TColor, Int32) | Draw a 2D Cross using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(IConvexPolygonF, TColor, Int32) | Draw a convex polygon using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(Point, TColor, Int32, LineType, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | Draw(Rectangle, TColor, Int32, LineType, Int32) | Draw an Rectangle of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(CircleF, TColor, Int32, LineType, Int32) | Draw a Circle of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(Ellipse, TColor, Int32, LineType, Int32) | Draw a Ellipse of the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2D, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(LineSegment2DF, TColor, Int32, LineType, Int32) | Draw a line segment using the specific color and thickness (Inherited from ImageTColor, TDepth.)
Public method | Draw(String, Point, FontFace, Double, TColor, Int32, LineType, Boolean) | Draw the text using the specific font on the image (Inherited from ImageTColor, TDepth.)
Public method | Draw(IInputArrayOfArrays, Int32, TColor, Int32, LineType, IInputArray, Int32, Point) | Draws contour outlines in the image if thickness>=0 or fills area bounded by the contours if thickness<0 (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polyline defined by the array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | DrawPolyline(Point, Boolean, TColor, Int32, LineType, Int32) | Draw the polylines defined by the array of array of 2D points (Inherited from ImageTColor, TDepth.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(ImageTColor, TDepth) | Compare two images, returns true if the each of the pixels are equal, false otherwise (Inherited from ImageTColor, TDepth.)
Public method | Erode | Erodes this image using a 3x3 rectangular structuring element. Erosion are applied several (iterations) times (Inherited from ImageTColor, TDepth.)
Public method | Exp | Calculates exponent of every element of input array: dst(I)=exp(src(I)) (Inherited from ImageTColor, TDepth.)
Public method | FillConvexPoly | Fill the convex polygon with the specific color (Inherited from ImageTColor, TDepth.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindCornerSubPix | Iterates to find the sub-pixel accurate location of corners, or radial saddle points (Inherited from ImageTColor, TDepth.)
Public method | Flip | Return a flipped copy of the current image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage | Get the average value on this image (Inherited from ImageTColor, TDepth.)
Public method | GetAverage(ImageGray, Byte) | Get the average value on this image, using the specific mask (Inherited from ImageTColor, TDepth.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | The unmanaged pointer to the input array. (Inherited from CvArrayTDepth.)
Public method | GetInputOutputArray | The unmanaged pointer to the input output array. (Inherited from CvArrayTDepth.)
Public method | GetMoments | Calculates spatial and central moments up to the third order and writes them to moments. The moments may be used then to calculate gravity center of the shape, its area, main axises and various shape characteristics including 7 Hu invariants. (Inherited from ImageTColor, TDepth.)
Public method | GetObjectData | A function used for runtime serialization of the object (Inherited from ImageTColor, TDepth.)
Public method | GetOutputArray | The unmanaged pointer to the output array. (Inherited from CvArrayTDepth.)
Public method | GetSchema | Get the xml schema (Inherited from CvArrayTDepth.)
Public method | GetSubRect | Get a subimage which image data is shared with the current image. (Inherited from ImageTColor, TDepth.)
Public method | GetSum | Get the sum for each color channel (Inherited from ImageTColor, TDepth.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrabCut | Use grabcut to perform background foreground segmentation. (Inherited from ImageTColor, TDepth.)
Public method | HoughCircles | First apply Canny Edge Detector on the current image, then apply Hough transform to find circles (Inherited from ImageTColor, TDepth.)
Public method | HoughLines | Apply Canny Edge Detector follows by Probabilistic Hough transform to find line segments in the image (Inherited from ImageTColor, TDepth.)
Public method | HoughLinesBinary | Apply Probabilistic Hough transform to find line segments. The current image must be a binary image (eg. the edges as a result of the Canny edge detector) (Inherited from ImageTColor, TDepth.)
Public method | InPaint | Use inpaint to recover the intensity of the pixels which location defined by mask on this image (Inherited from ImageTColor, TDepth.)
Public method | InRange(TColor, TColor) | Checks that image elements lie between two scalars (Inherited from ImageTColor, TDepth.)
Public method | InRange(ImageTColor, TDepth, ImageTColor, TDepth) | Checks that image elements lie between values defined by two images of same size and type (Inherited from ImageTColor, TDepth.)
Public method | Integral | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double) | Calculates integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Integral(ImageTColor, Double, ImageTColor, Double, ImageTColor, Double) | Calculates one or more integral images for the source image (Inherited from ImageTColor, TDepth.)
Public method | Laplace | Calculates Laplacian of the source image by summing second x- and y- derivatives calculated using Sobel operator. Specifying aperture_size=1 gives the fastest variant that is equal to convolving the image with the following kernel: |0 1 0| |1 -4 1| |0 1 0| (Inherited from ImageTColor, TDepth.)
Public method | Log | Calculates natural logarithm of absolute value of every element of input array (Inherited from ImageTColor, TDepth.)
Public method | LogPolar | Convert the image to log polar, simulating the human foveal vision (Inherited from ImageTColor, TDepth.)
Protected method | MapDataToImage | Let this Image object use the specific Image data. (Inherited from ImageTColor, TDepth.)
Public method | MatchTemplate | The function slides through image, compares overlapped patches of size wxh with templ using the specified method and return the comparison results (Inherited from ImageTColor, TDepth.)
Public method | Max(Double) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Public method | Max(ImageTColor, TDepth) | Find the elementwise maximum value (Inherited from ImageTColor, TDepth.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Min(Double) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | Min(ImageTColor, TDepth) | Find the elementwise minimum value (Inherited from ImageTColor, TDepth.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from ImageTColor, TDepth.)
Public method | MorphologyEx | Perform advanced morphological transformations using erosion and dilation as basic operations. (Inherited from ImageTColor, TDepth.)
Public method | Mul(Double) | Elementwise multiply the current image with scale (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth) | Elementwise multiply img2 with the current image (Inherited from ImageTColor, TDepth.)
Public method | Mul(ImageTColor, TDepth, Double) | Elementwise multiply another image with the current image and the scale (Inherited from ImageTColor, TDepth.)
Public method | Not | Compute the complement image (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth) | Perform an elementwise OR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Or(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise OR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Public method | Pow | Raises every element of input array to p dst(I)=src(I)^p, if p is integer dst(I)=abs(src(I))^p, otherwise (Inherited from ImageTColor, TDepth.)
Public method | PyrDown | Performs downsampling step of Gaussian pyramid decomposition. First it convolves this image with the specified filter and then downsamples the image by rejecting even rows and columns. (Inherited from ImageTColor, TDepth.)
Public method | PyrUp | Performs up-sampling step of Gaussian pyramid decomposition. First it upsamples this image by injecting even zero rows and columns and then convolves result with the specified filter multiplied by 4 for interpolation. So the resulting image is four times larger than the source image. (Inherited from ImageTColor, TDepth.)
Public method | ReadXml | Function to call when deserializing this object from XML (Inherited from CvArrayTDepth.)
Public method | ReduceTOtherDepth | Reduces matrix to a vector by treating the matrix rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained. (Inherited from CvArrayTDepth.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Resize(Double, Inter) | Scale the image to the specific size: width *= scale; height *= scale (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Resize(Int32, Int32, Inter, Boolean) | Scale the image to the specific size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor) | Rotate the image the specified angle cropping the result to the original size (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Rotate(Double, PointF, Inter, TColor, Boolean) | Rotate this image the specified angle (Inherited from ImageTColor, TDepth.)
Public method | Save | Save this image to the specific file. (Inherited from ImageTColor, TDepth.)
Public method | SetIdentity | Initialize the identity matrix (Inherited from CvArrayTDepth.)
Public method | SetIdentity(MCvScalar) | Initializes scaled identity matrix (Inherited from CvArrayTDepth.)
Public method | SetRandNormal | Inplace fills Array with normally distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetRandUniform | Inplace fills Array with uniformly distributed random numbers (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor) | Set every pixel of the image to the specific color (Inherited from ImageTColor, TDepth.)
Public method | SetValue(Double, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetValue(TColor, ImageGray, Byte) | Set every pixel of the image to the specific color, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SetValue(MCvScalar, CvArrayByte) | Set the element of the Array to value, using the specific mask (Inherited from CvArrayTDepth.)
Public method | SetZero | Set the values to zero (Inherited from CvArrayTDepth.)
Public method | SmoothBilateral | Applying bilateral 3x3 filtering (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32) | Summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothBlur(Int32, Int32, Boolean) | Summation over a pixel param1 x param2 neighborhood. If scale is true, the result is subsequent scaled by 1/(param1 x param2) (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothGaussian(Int32, Int32, Double, Double) | Perform Gaussian Smoothing in the current image and return the result (Inherited from ImageTColor, TDepth.)
Public method | SmoothMedian | Finding median of sizexsize neighborhood (Inherited from ImageTColor, TDepth.)
Public method | Sobel | Calculates the image derivative by convolving the image with the appropriate kernel The Sobel operators combine Gaussian smoothing and differentiation so the result is more or less robust to the noise. Most often, the function is called with (xorder=1, yorder=0, aperture_size=3) or (xorder=0, yorder=1, aperture_size=3) to calculate first x- or y- image derivative. (Inherited from ImageTColor, TDepth.)
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth) | Elementwise subtract another image from the current image (Inherited from ImageTColor, TDepth.)
Public method | Sub(ImageTColor, TDepth, ImageGray, Byte) | Elementwise subtract another image from the current image, using a mask (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor) | result = val - this (Inherited from ImageTColor, TDepth.)
Public method | SubR(TColor, ImageGray, Byte) | result = val - this, using a mask (Inherited from ImageTColor, TDepth.)
Public method | ThresholdAdaptive | Transforms grayscale image to binary image. Threshold calculated individually for each pixel. For the method CV_ADAPTIVE_THRESH_MEAN_C it is a mean of blockSize x blockSize pixel neighborhood, subtracted by param1. For the method CV_ADAPTIVE_THRESH_GAUSSIAN_C it is a weighted sum (gaussian) of blockSize x blockSize pixel neighborhood, subtracted by param1. (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinary | Threshold the image such that: dst(x,y) = max_value, if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdBinaryInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; max_value, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZero | Threshold the image such that: dst(x,y) = src(x,y), if src(x,y)>threshold; 0, otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdToZeroInv | Threshold the image such that: dst(x,y) = 0, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ThresholdTrunc | Threshold the image such that: dst(x,y) = threshold, if src(x,y)>threshold; src(x,y), otherwise (Inherited from ImageTColor, TDepth.)
Public method | ToJpegData | Get the jpeg representation of the image (Inherited from ImageTColor, TDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUMat | Get the umat representation of this mat (Inherited from CvArrayTDepth.)
Public method | WarpAffine(Mat, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpAffine(Mat, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WarpPerspectiveTMapDepth(MatrixTMapDepth, Int32, Int32, Inter, Warp, BorderType, TColor) | Transforms source image using the specified matrix (Inherited from ImageTColor, TDepth.)
Public method | WriteXml | Function to call when serializing this object to XML (Inherited from CvArrayTDepth.)
Public method | Xor(ImageTColor, TDepth) | Perform an elementwise XOR operation with another image and return the result (Inherited from ImageTColor, TDepth.)
Public method | Xor(ImageTColor, TDepth, ImageGray, Byte) | Perform an elementwise XOR operation with another image, using a mask, and return the result (Inherited from ImageTColor, TDepth.)
Top
See Also

Reference

TimedImageTColor, TDepth Class
Emgu.CV Namespace


TimedImage(TColor, TDepth) Fields

TimedImageTColor, TDepth Fields

The TimedImageTColor, TDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _cvMat | The Mat header that represent this CvArr (Inherited from CvArrayTDepth.)
Protected field | _dataHandle | The pinned GCHandle to _array; (Inherited from CvArrayTDepth.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TimedImageTColor, TDepth Class
Emgu.CV Namespace


Tonemap Class

Base class for tonemapping algorithms - tools that are used to map HDR image to 8-bit range.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVTonemap
Emgu.CVTonemapDrago
Emgu.CVTonemapMantiuk
Emgu.CVTonemapReinhard
Emgu.CV.XPhotoTonemapDurand

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Tonemap : UnmanagedObject, IAlgorithm
Public Class Tonemap
    Inherits UnmanagedObject
    Implements IAlgorithm
public ref class Tonemap : public UnmanagedObject,
    IAlgorithm
type Tonemap =
    class
        inherit UnmanagedObject
        interface IAlgorithm
    end

The Tonemap type exposes the following members.

Constructors
 | Name | Description
Public method | Tonemap(Single) | Creates simple linear mapper with gamma correction.
Protected method | Tonemap(IntPtr, IntPtr) | Default constructor that creates empty Tonemap
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Tonemap (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


Tonemap Constructor

Overload List
 | Name | Description
Public method | Tonemap(Single) | Creates simple linear mapper with gamma correction.
Protected method | Tonemap(IntPtr, IntPtr) | Default constructor that creates empty Tonemap
Top
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap Constructor (Single)

Creates simple linear mapper with gamma correction.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Tonemap(
    float gamma = 1f
)
Public Sub New (
    Optional gamma As Single = 1F
)
public:
Tonemap(
    float gamma = 1f
)
new :
        ?gamma : float32
(* Defaults:
        let _gamma = defaultArg gamma 1f
*)
-> Tonemap

Parameters

gamma (Optional)
Type: SystemSingle
positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. Generally gamma > 1 brightens the image and gamma < 1 darkens it.
See Also

Reference

Tonemap Class
Tonemap Overload
Emgu.CV Namespace


Tonemap Constructor (IntPtr, IntPtr)

Default constructor that creates empty Tonemap

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Tonemap(
    IntPtr ptr,
    IntPtr tonemapPtr
)
Protected Sub New (
    ptr As IntPtr,
    tonemapPtr As IntPtr
)
protected:
Tonemap(
    IntPtr ptr,
    IntPtr tonemapPtr
)
new :
        ptr : IntPtr *
        tonemapPtr : IntPtr -> Tonemap

Parameters

ptr
Type: SystemIntPtr
The pointer to the unmanaged object
tonemapPtr
Type: SystemIntPtr
The pointer to the tonemap object
See Also

Reference

Tonemap Class
Tonemap Overload
Emgu.CV Namespace


Tonemap Properties

The Tonemap type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap.AlgorithmPtr Property

TonemapAlgorithmPtr Property

The pointer to the unamanged Algorith object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap.Gamma Property

TonemapGamma Property

Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Gamma { get; set; }
Public Property Gamma As Single
    Get
    Set
public:
property float Gamma {
    float get ();
    void set (float value);
}
member Gamma : float32 with get, set

Property Value

Type: Single
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap Methods

The Tonemap type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Tonemap (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap.DisposeObject Method

TonemapDisposeObject Method

Release the unmanaged memory associated with this Tonemap

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap.Process Method

TonemapProcess Method

Tonemaps image.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Process(
    IInputArray src,
    IOutputArray dst
)
Public Sub Process (
    src As IInputArray,
    dst As IOutputArray
)
public:
void Process(
    IInputArray^ src,
    IOutputArray^ dst
)
member Process :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image - 32-bit 3-channel Mat
dst
Type: Emgu.CVIOutputArray
destination image - 32-bit 3-channel Mat with values in [0, 1] range
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap Fields

The Tonemap type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object
Top
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap._algorithmPtr Field

Tonemap_algorithmPtr Field

The pointer to the unmanaged Algorithm object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _algorithmPtr
Protected _algorithmPtr As IntPtr
protected:
IntPtr _algorithmPtr
val mutable _algorithmPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

Tonemap Class
Emgu.CV Namespace


Tonemap._tonemapPtr Field

Tonemap_tonemapPtr Field

The pointer to the unmanaged Tonemap object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _tonemapPtr
Protected _tonemapPtr As IntPtr
protected:
IntPtr _tonemapPtr
val mutable _tonemapPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

Tonemap Class
Emgu.CV Namespace


TonemapDrago Class

Adaptive logarithmic mapping is a fast global tonemapping algorithm that scales the image in logarithmic domain. Since it's a global operator the same function is applied to all the pixels, it is controlled by the bias parameter.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVTonemap
Emgu.CVTonemapDrago

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TonemapDrago : Tonemap
Public Class TonemapDrago
    Inherits Tonemap
public ref class TonemapDrago : public Tonemap
type TonemapDrago =
    class
        inherit Tonemap
    end

The TonemapDrago type exposes the following members.

Constructors
 | Name | Description
Public method | TonemapDrago | Creates TonemapDrago object.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | Bias | Value for bias function in [0, 1] range. Values from 0.7 to 0.9 usually give best results, default value is 0.85.
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Saturation | Positive saturation enhancement value. 1.0 preserves saturation, values greater than 1 increase saturation and values less than 1 decrease it.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapDrago (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

Emgu.CV Namespace


TonemapDrago Constructor

Creates TonemapDrago object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TonemapDrago(
    float gamma = 1f,
    float saturation = 1f,
    float bias = 0.85f
)
Public Sub New (
    Optional gamma As Single = 1F,
    Optional saturation As Single = 1F,
    Optional bias As Single = 0.85F
)
public:
TonemapDrago(
    float gamma = 1f,
    float saturation = 1f,
    float bias = 0.85f
)
new :
        ?gamma : float32 *
        ?saturation : float32 *
        ?bias : float32
(* Defaults:
        let _gamma = defaultArg gamma 1f
        let _saturation = defaultArg saturation 1f
        let _bias = defaultArg bias 0.85f
*)
-> TonemapDrago

Parameters

gamma (Optional)
Type: SystemSingle
gamma value for gamma correction.
saturation (Optional)
Type: SystemSingle
positive saturation enhancement value. 1.0 preserves saturation, values greater than 1 increase saturation and values less than 1 decrease it.
bias (Optional)
Type: SystemSingle
value for bias function in [0, 1] range. Values from 0.7 to 0.9 usually give best results, default value is 0.85.
See Also

Reference

TonemapDrago Class
Emgu.CV Namespace


TonemapDrago Properties

The TonemapDrago type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | Bias | Value for bias function in [0, 1] range. Values from 0.7 to 0.9 usually give best results, default value is 0.85.
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Saturation | Positive saturation enhancement value. 1.0 preserves saturation, values greater than 1 increase saturation and values less than 1 decrease it.
Top
See Also

Reference

TonemapDrago Class
Emgu.CV Namespace


TonemapDrago.Bias Property

TonemapDragoBias Property

Value for bias function in [0, 1] range. Values from 0.7 to 0.9 usually give best results, default value is 0.85.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Bias { get; set; }
Public Property Bias As Single
    Get
    Set
public:
property float Bias {
    float get ();
    void set (float value);
}
member Bias : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapDrago Class
Emgu.CV Namespace


TonemapDrago.Saturation Property

TonemapDragoSaturation Property

Positive saturation enhancement value. 1.0 preserves saturation, values greater than 1 increase saturation and values less than 1 decrease it.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Saturation { get; set; }
Public Property Saturation As Single
    Get
    Set
public:
property float Saturation {
    float get ();
    void set (float value);
}
member Saturation : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapDrago Class
Emgu.CV Namespace


TonemapDrago Methods

The TonemapDrago type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapDrago (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TonemapDrago Class
Emgu.CV Namespace


TonemapDrago.DisposeObject Method

TonemapDragoDisposeObject Method

Release the unmanaged memory associated with this TonemapDrago

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TonemapDrago Class
Emgu.CV Namespace


TonemapDrago Fields

The TonemapDrago type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

TonemapDrago Class
Emgu.CV Namespace


TonemapMantiuk Class

This algorithm transforms image to contrast using gradients on all levels of gaussian pyramid, transforms contrast values to HVS response and scales the response. After this the image is reconstructed from new contrast values.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVTonemap
Emgu.CVTonemapMantiuk

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TonemapMantiuk : Tonemap
Public Class TonemapMantiuk
    Inherits Tonemap
public ref class TonemapMantiuk : public Tonemap
type TonemapMantiuk =
    class
        inherit Tonemap
    end

The TonemapMantiuk type exposes the following members.

Constructors
 | Name | Description
Public method | TonemapMantiuk | Creates TonemapMantiuk object
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Saturation | Saturation enhancement value.
Public property | Scale | Contrast scale factor. HVS response is multiplied by this parameter, thus compressing dynamic range. Values from 0.6 to 0.9 produce best results.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapMantiuk (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

Emgu.CV Namespace


TonemapMantiuk Constructor

Creates TonemapMantiuk object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TonemapMantiuk(
    float gamma = 1f,
    float scale = 0.7f,
    float saturation = 1f
)
Public Sub New (
    Optional gamma As Single = 1F,
    Optional scale As Single = 0.7F,
    Optional saturation As Single = 1F
)
public:
TonemapMantiuk(
    float gamma = 1f,
    float scale = 0.7f,
    float saturation = 1f
)
new :
        ?gamma : float32 *
        ?scale : float32 *
        ?saturation : float32
(* Defaults:
        let _gamma = defaultArg gamma 1f
        let _scale = defaultArg scale 0.7f
        let _saturation = defaultArg saturation 1f
*)
-> TonemapMantiuk

Parameters

gamma (Optional)
Type: SystemSingle
gamma value for gamma correction.
scale (Optional)
Type: SystemSingle
contrast scale factor. HVS response is multiplied by this parameter, thus compressing dynamic range. Values from 0.6 to 0.9 produce best results.
saturation (Optional)
Type: SystemSingle
saturation enhancement value.
See Also

Reference

TonemapMantiuk Class
Emgu.CV Namespace


TonemapMantiuk Properties

The TonemapMantiuk type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Saturation | Saturation enhancement value.
Public property | Scale | Contrast scale factor. HVS response is multiplied by this parameter, thus compressing dynamic range. Values from 0.6 to 0.9 produce best results.
Top
See Also

Reference

TonemapMantiuk Class
Emgu.CV Namespace


TonemapMantiuk.Saturation Property

TonemapMantiukSaturation Property

Saturation enhancement value.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Saturation { get; set; }
Public Property Saturation As Single
    Get
    Set
public:
property float Saturation {
    float get ();
    void set (float value);
}
member Saturation : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapMantiuk Class
Emgu.CV Namespace


TonemapMantiuk.Scale Property

TonemapMantiukScale Property

Contrast scale factor. HVS response is multiplied by this parameter, thus compressing dynamic range. Values from 0.6 to 0.9 produce best results.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Scale { get; set; }
Public Property Scale As Single
    Get
    Set
public:
property float Scale {
    float get ();
    void set (float value);
}
member Scale : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapMantiuk Class
Emgu.CV Namespace


TonemapMantiuk Methods

The TonemapMantiuk type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapMantiuk (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TonemapMantiuk Class
Emgu.CV Namespace


TonemapMantiuk.DisposeObject Method

TonemapMantiukDisposeObject Method

Release the unmanaged memory associated with this TonemapMantiuk

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TonemapMantiuk Class
Emgu.CV Namespace


TonemapMantiuk Fields

The TonemapMantiuk type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

TonemapMantiuk Class
Emgu.CV Namespace


TonemapReinhard Class

This is a global tonemapping operator that models human visual system. Mapping function is controlled by adaptation parameter, that is computed using light adaptation and color adaptation.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVTonemap
Emgu.CVTonemapReinhard

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TonemapReinhard : Tonemap
Public Class TonemapReinhard
    Inherits Tonemap
public ref class TonemapReinhard : public Tonemap
type TonemapReinhard =
    class
        inherit Tonemap
    end

The TonemapReinhard type exposes the following members.

Constructors
 | Name | Description
Public method | TonemapReinhard | Creates TonemapReinhard object.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | ColorAdaptation | chromatic adaptation in [0, 1] range. If 1 channels are treated independently, if 0 adaptation level is the same for each channel.
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Intensity | Result intensity in [-8, 8] range. Greater intensity produces brighter results.
Public property | LightAdaptation | Light adaptation in [0, 1] range. If 1 adaptation is based only on pixel value, if 0 it is global, otherwise it is a weighted mean of this two cases.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapReinhard (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

Emgu.CV Namespace


TonemapReinhard Constructor

Creates TonemapReinhard object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TonemapReinhard(
    float gamma = 1f,
    float intensity = 0f,
    float lightAdapt = 1f,
    float colorAdapt = 0f
)
Public Sub New (
    Optional gamma As Single = 1F,
    Optional intensity As Single = 0F,
    Optional lightAdapt As Single = 1F,
    Optional colorAdapt As Single = 0F
)
public:
TonemapReinhard(
    float gamma = 1f,
    float intensity = 0f,
    float lightAdapt = 1f,
    float colorAdapt = 0f
)
new :
        ?gamma : float32 *
        ?intensity : float32 *
        ?lightAdapt : float32 *
        ?colorAdapt : float32
(* Defaults:
        let _gamma = defaultArg gamma 1f
        let _intensity = defaultArg intensity 0f
        let _lightAdapt = defaultArg lightAdapt 1f
        let _colorAdapt = defaultArg colorAdapt 0f
*)
-> TonemapReinhard

Parameters

gamma (Optional)
Type: SystemSingle
gamma value for gamma correction
intensity (Optional)
Type: SystemSingle
result intensity in [-8, 8] range. Greater intensity produces brighter results.
lightAdapt (Optional)
Type: SystemSingle
light adaptation in [0, 1] range. If 1 adaptation is based only on pixel value, if 0 it's global, otherwise it's a weighted mean of this two cases.
colorAdapt (Optional)
Type: SystemSingle
chromatic adaptation in [0, 1] range. If 1 channels are treated independently, if 0 adaptation level is the same for each channel.
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


TonemapReinhard Properties

The TonemapReinhard type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | ColorAdaptation | chromatic adaptation in [0, 1] range. If 1 channels are treated independently, if 0 adaptation level is the same for each channel.
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Intensity | Result intensity in [-8, 8] range. Greater intensity produces brighter results.
Public property | LightAdaptation | Light adaptation in [0, 1] range. If 1 adaptation is based only on pixel value, if 0 it is global, otherwise it is a weighted mean of this two cases.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


TonemapReinhard.ColorAdaptation Property

TonemapReinhardColorAdaptation Property

chromatic adaptation in [0, 1] range. If 1 channels are treated independently, if 0 adaptation level is the same for each channel.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ColorAdaptation { get; set; }
Public Property ColorAdaptation As Single
    Get
    Set
public:
property float ColorAdaptation {
    float get ();
    void set (float value);
}
member ColorAdaptation : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


TonemapReinhard.Intensity Property

TonemapReinhardIntensity Property

Result intensity in [-8, 8] range. Greater intensity produces brighter results.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Intensity { get; set; }
Public Property Intensity As Single
    Get
    Set
public:
property float Intensity {
    float get ();
    void set (float value);
}
member Intensity : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


TonemapReinhard.LightAdaptation Property

TonemapReinhardLightAdaptation Property

Light adaptation in [0, 1] range. If 1 adaptation is based only on pixel value, if 0 it is global, otherwise it is a weighted mean of this two cases.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float LightAdaptation { get; set; }
Public Property LightAdaptation As Single
    Get
    Set
public:
property float LightAdaptation {
    float get ();
    void set (float value);
}
member LightAdaptation : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


TonemapReinhard Methods

The TonemapReinhard type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapReinhard (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


TonemapReinhard.DisposeObject Method

TonemapReinhardDisposeObject Method

Release the unmanaged memory associated with this TonemapReinhard

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


TonemapReinhard Fields

The TonemapReinhard type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

TonemapReinhard Class
Emgu.CV Namespace


UMat Class

The equivalent of cv::Mat, should only be used if you know what you are doing. In most case you should use the Matrix class instead
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVMatDataAllocator
Emgu.CVUMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class UMat : MatDataAllocator, IEquatable<UMat>,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class UMat
    Inherits MatDataAllocator
    Implements IEquatable(Of UMat), IInputOutputArray,
    IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays,
    ISerializable
[SerializableAttribute]
public ref class UMat : public MatDataAllocator,
    IEquatable<UMat^>, IInputOutputArray, IInputArray, IDisposable,
    IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type UMat =
    class
        inherit MatDataAllocator
        interface IEquatable<UMat>
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The UMat type exposes the following members.

Constructors
 | Name | Description
Public method | UMat | Create an empty cv::UMat
Public method | UMat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | UMat(String, ImreadModes) | Read a UMat from file.
Public method | UMat(UMat, Rectangle) | Get the Umat header for the specific roi of the parent
Public method | UMat(UMat, Range, Range) | Create a umat header for the specific ROI
Public method | UMat(Size, DepthType, Int32, UMatUsage) | Create a umat of the specific type.
Public method | UMat(Int32, Int32, DepthType, Int32, UMatUsage) | Create a umat of the specific type.
Top
Properties
 | Name | Description
Public property | Bytes | Get or Set the raw image data
Public property | Cols | The number of columns
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | Depth | Depth type
Public property | Dims | The matrix dimensionality
Public property | ElementSize | The size of the elements in this matrix
Public property | IsContinuous | True if the data is continues
Public property | IsEmpty | True if the matrix is empty
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix
Public property | NumberOfChannels | Number of channels
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rows | The number of rows
Public property | Size | The size of this matrix
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image)
Top
Methods
 | Name | Description
Public method | Clone | Make a clone of the current UMat.
Public method | Col | Creates a matrix header for the specified matrix column.
Public method | ConvertTo | Converts an array to another data type with optional scaling.
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this umat to the other mat
Public method | CopyToT(T) | Copy data from this Mat to the managed array
Public method | Create | Allocates new array data if needed.
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Overrides MatDataAllocatorDisposeObject.)
Public method | Dot | Computes the dot product of two mats
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(UMat) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray
Public method | GetInputOutputArray | Pointer to the InputOutputArray
Public method | GetMat | Return the Mat representation of the UMat
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Pointer to the OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data.
Public method | Row | Creates a matrix header for the specified matrix row.
Public method | Save | Save this image to the specific file.
Public method | SetTo(IInputArray, IInputArray) | Sets all or some of the array elements to the specified value.
Public method | SetTo(MCvScalar, IInputArray) | Sets all or some of the array elements to the specified value.
Public method | SetToT(T) | Copy data from managed array to this Mat
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image
Public method | ToImageTColor, TDepth | Convert this Mat to Image
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Addition(Double, UMat) | Element wise add mat1 with value
Addition(MCvScalar, UMat) | Element wise add mat with value
Addition(UMat, MCvScalar) | Element wise add mat with value
Addition(UMat, UMat) | Element wise add mat1 with mat2
Addition(UMat, Double) | Element wise add mat with value
BitwiseAnd(Double, UMat) | Perform an element wise AND operation using a mat and a color
BitwiseAnd(MCvScalar, UMat) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(UMat, MCvScalar) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(UMat, UMat) | Perform an element wise AND operation on the two mats
BitwiseAnd(UMat, Double) | Perform an element wise AND operation using a mat and a scalar
BitwiseOr(Double, UMat) | Perform an binary OR operation with some color
BitwiseOr(MCvScalar, UMat) | Perform an binary OR operation with some scalar
BitwiseOr(UMat, MCvScalar) | Perform an binary OR operation with some scalar
BitwiseOr(UMat, UMat) | Perform an element wise OR operation with another mat and return the result
BitwiseOr(UMat, Double) | Perform an binary OR operation with some value
Division(Double, UMat) | scale / mat
Division(UMat, Double) | mat / scale
Multiply(Double, UMat) | scale*mat
Multiply(UMat, Double) | mat * scale
OnesComplement | Compute the complement Mat
Subtraction(Double, UMat) | value - mat
Subtraction(MCvScalar, UMat) | Element wise subtract value from the current mat
Subtraction(UMat, MCvScalar) | Element wise subtract another mat from the current mat
Subtraction(UMat, UMat) | Element wise subtract another mat from the current mat
Subtraction(UMat, Double) | Element wise subtract value from the current mat
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV Namespace


UMat Constructor

Overload List
 | Name | Description
Public method | UMat | Create an empty cv::UMat
Public method | UMat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Public method | UMat(String, ImreadModes) | Read a UMat from file.
Public method | UMat(UMat, Rectangle) | Get the Umat header for the specific roi of the parent
Public method | UMat(UMat, Range, Range) | Create a umat header for the specific ROI
Public method | UMat(Size, DepthType, Int32, UMatUsage) | Create a umat of the specific type.
Public method | UMat(Int32, Int32, DepthType, Int32, UMatUsage) | Create a umat of the specific type.
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat Constructor

Create an empty cv::UMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat()
Public Sub New
public:
UMat()
new : unit -> UMat
See Also

Reference

UMat Class
UMat Overload
Emgu.CV Namespace


UMat Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
UMat(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> UMat

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

UMat Class
UMat Overload
Emgu.CV Namespace


UMat Constructor (String, ImreadModes)

Read a UMat from file.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat(
    string fileName,
    ImreadModes loadType
)
Public Sub New (
    fileName As String,
    loadType As ImreadModes
)
public:
UMat(
    String^ fileName,
    ImreadModes^ loadType
)
new :
        fileName : string *
        loadType : ImreadModes -> UMat

Parameters

fileName
Type: SystemString
The name of the file
loadType
Type: Emgu.CV.CvEnumImreadModes
The read mode
See Also

Reference

UMat Class
UMat Overload
Emgu.CV Namespace


UMat Constructor (UMat, Rectangle)

Get the Umat header for the specific roi of the parent

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat(
    UMat parent,
    Rectangle roi
)
Public Sub New (
    parent As UMat,
    roi As Rectangle
)
public:
UMat(
    UMat^ parent,
    Rectangle^ roi
)
new :
        parent : UMat *
        roi : Rectangle -> UMat

Parameters

parent
Type: Emgu.CVUMat
The parent Umat
roi
Type: System.DrawingRectangle
The region of interest
See Also

Reference

UMat Class
UMat Overload
Emgu.CV Namespace


UMat Constructor (UMat, Range, Range)

Create a umat header for the specific ROI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat(
    UMat umat,
    Range rowRange,
    Range colRange
)
Public Sub New (
    umat As UMat,
    rowRange As Range,
    colRange As Range
)
public:
UMat(
    UMat^ umat,
    Range^ rowRange,
    Range^ colRange
)
new :
        umat : UMat *
        rowRange : Range *
        colRange : Range -> UMat

Parameters

umat
Type: Emgu.CVUMat
The umat where the new UMat header will share data from
rowRange
Type: Emgu.CV.StructureRange
The region of interest
colRange
Type: Emgu.CV.StructureRange
The region of interest
See Also

Reference

UMat Class
UMat Overload
Emgu.CV Namespace


UMat Constructor (Size, DepthType, Int32, UMat.Usage)

UMat Constructor (Size, DepthType, Int32, UMatUsage)

http://www.emgu.com
Create a umat of the specific type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat(
    Size size,
    DepthType type,
    int channels,
    UMatUsage usage = 0
)
Public Sub New (
    size As Size,
    type As DepthType,
    channels As Integer,
    Optional usage As UMatUsage = 0
)
public:
UMat(
    Size^ size,
    DepthType^ type,
    int channels,
    UMatUsage^ usage = 0
)
new :
        size : Size *
        type : DepthType *
        channels : int *
        ?usage : UMatUsage
(* Defaults:
        let _usage = defaultArg usage 0
*)
-> UMat

Parameters

size
Type: System.DrawingSize
Size of the UMat
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels
usage (Optional)
Type: Emgu.CVUMatUsage
Allocation Usage
See Also

Reference

UMat Class
UMat Overload
Emgu.CV Namespace


UMat Constructor (Int32, Int32, DepthType, Int32, UMat.Usage)

UMat Constructor (Int32, Int32, DepthType, Int32, UMatUsage)

http://www.emgu.com
Create a umat of the specific type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat(
    int rows,
    int cols,
    DepthType type,
    int channels,
    UMatUsage usage = 0
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer,
    Optional usage As UMatUsage = 0
)
public:
UMat(
    int rows,
    int cols,
    DepthType^ type,
    int channels,
    UMatUsage^ usage = 0
)
new :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int *
        ?usage : UMatUsage
(* Defaults:
        let _usage = defaultArg usage 0
*)
-> UMat

Parameters

rows
Type: SystemInt32
Number of rows in a 2D array.
cols
Type: SystemInt32
Number of columns in a 2D array.
type
Type: Emgu.CV.CvEnumDepthType
Mat element type
channels
Type: SystemInt32
Number of channels
usage (Optional)
Type: Emgu.CVUMatUsage
Allocation Usage
See Also

Reference

UMat Class
UMat Overload
Emgu.CV Namespace


UMat Properties

The UMat type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Get or Set the raw image data
Public property | Cols | The number of columns
Public property | Data | Get the managed data used by the Mat (Inherited from MatDataAllocator.)
Public property | Depth | Depth type
Public property | Dims | The matrix dimensionality
Public property | ElementSize | The size of the elements in this matrix
Public property | IsContinuous | True if the data is continues
Public property | IsEmpty | True if the matrix is empty
Public property | IsSubmatrix | True if the matrix is a submatrix of another matrix
Public property | NumberOfChannels | Number of channels
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rows | The number of rows
Public property | Size | The size of this matrix
Public property | Total | The method returns the number of array elements (a number of pixels if the array represents an image)
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Bytes Property

UMatBytes Property

Get or Set the raw image data

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] Bytes { get; set; }
Public Property Bytes As Byte()
    Get
    Set
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Bytes : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Cols Property

UMatCols Property

The number of columns

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Cols { get; }
Public ReadOnly Property Cols As Integer
    Get
public:
property int Cols {
    int get ();
}
member Cols : int with get

Property Value

Type: Int32
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Depth Property

UMatDepth Property

Depth type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DepthType Depth { get; }
Public ReadOnly Property Depth As DepthType
    Get
public:
property DepthType^ Depth {
    DepthType^ get ();
}
member Depth : DepthType with get

Property Value

Type: DepthType
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Dims Property

UMatDims Property

The matrix dimensionality

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dims { get; }
Public ReadOnly Property Dims As Integer
    Get
public:
property int Dims {
    int get ();
}
member Dims : int with get

Property Value

Type: Int32
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.ElementSize Property

UMatElementSize Property

The size of the elements in this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ElementSize { get; }
Public ReadOnly Property ElementSize As Integer
    Get
public:
property int ElementSize {
    int get ();
}
member ElementSize : int with get

Property Value

Type: Int32
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.IsContinuous Property

UMatIsContinuous Property

True if the data is continues

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsContinuous { get; }
Public ReadOnly Property IsContinuous As Boolean
    Get
public:
property bool IsContinuous {
    bool get ();
}
member IsContinuous : bool with get

Property Value

Type: Boolean
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.IsEmpty Property

UMatIsEmpty Property

True if the matrix is empty

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.IsSubmatrix Property

UMatIsSubmatrix Property

True if the matrix is a submatrix of another matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSubmatrix { get; }
Public ReadOnly Property IsSubmatrix As Boolean
    Get
public:
property bool IsSubmatrix {
    bool get ();
}
member IsSubmatrix : bool with get

Property Value

Type: Boolean
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.NumberOfChannels Property

UMatNumberOfChannels Property

Number of channels

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfChannels { get; }
Public ReadOnly Property NumberOfChannels As Integer
    Get
public:
property int NumberOfChannels {
    int get ();
}
member NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Rows Property

UMatRows Property

The number of rows

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get
public:
property int Rows {
    int get ();
}
member Rows : int with get

Property Value

Type: Int32
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Size Property

UMatSize Property

The size of this matrix

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get
public:
property Size^ Size {
    Size^ get ();
}
member Size : Size with get

Property Value

Type: Size
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Total Property

UMatTotal Property

The method returns the number of array elements (a number of pixels if the array represents an image)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Total { get; }
Public ReadOnly Property Total As IntPtr
    Get
public:
property IntPtr Total {
    IntPtr get ();
}
member Total : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat Methods

The UMat type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Make a clone of the current UMat.
Public method | Col | Creates a matrix header for the specified matrix column.
Public method | ConvertTo | Converts an array to another data type with optional scaling.
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this umat to the other mat
Public method | CopyToT(T) | Copy data from this Mat to the managed array
Public method | Create | Allocates new array data if needed.
Protected method | DeserializeObjectData | A function used for runtime deserailization of the object
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object. (Overrides MatDataAllocatorDisposeObject.)
Public method | Dot | Computes the dot product of two mats
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(UMat) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray
Public method | GetInputOutputArray | Pointer to the InputOutputArray
Public method | GetMat | Return the Mat representation of the UMat
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Pointer to the OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinMax | Returns the min / max location and values for the image
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes the shape and/or the number of channels of a 2D matrix without copying the data.
Public method | Row | Creates a matrix header for the specified matrix row.
Public method | Save | Save this image to the specific file.
Public method | SetTo(IInputArray, IInputArray) | Sets all or some of the array elements to the specified value.
Public method | SetTo(MCvScalar, IInputArray) | Sets all or some of the array elements to the specified value.
Public method | SetToT(T) | Copy data from managed array to this Mat
Public method | Split | Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image
Public method | ToImageTColor, TDepth | Convert this Mat to Image
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Clone Method

UMatClone Method

Make a clone of the current UMat.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat Clone()
Public Function Clone As UMat
public:
UMat^ Clone()
member Clone : unit -> UMat

Return Value

Type: UMat
A clone of the current UMat.
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Col Method

UMatCol Method

Creates a matrix header for the specified matrix column.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat Col(
    int x
)
Public Function Col (
    x As Integer
) As UMat
public:
UMat^ Col(
    int x
)
member Col :
        x : int -> UMat

Parameters

x
Type: SystemInt32
A 0-based column index.

Return Value

Type: UMat
A matrix header for the specified matrix column.
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.ConvertTo Method

UMatConvertTo Method

Converts an array to another data type with optional scaling.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ConvertTo(
    IOutputArray m,
    DepthType rtype,
    double alpha = 1,
    double beta = 0
)
Public Sub ConvertTo (
    m As IOutputArray,
    rtype As DepthType,
    Optional alpha As Double = 1,
    Optional beta As Double = 0
)
public:
void ConvertTo(
    IOutputArray^ m,
    DepthType^ rtype,
    double alpha = 1,
    double beta = 0
)
member ConvertTo :
        m : IOutputArray *
        rtype : DepthType *
        ?alpha : float *
        ?beta : float
(* Defaults:
        let _alpha = defaultArg alpha 1
        let _beta = defaultArg beta 0
*)
-> unit

Parameters

m
Type: Emgu.CVIOutputArray
Output matrix; if it does not have a proper size or type before the operation, it is reallocated.
rtype
Type: Emgu.CV.CvEnumDepthType
Desired output matrix type or, rather, the depth since the number of channels are the same as the input has; if rtype is negative, the output matrix will have the same type as the input.
alpha (Optional)
Type: SystemDouble
Optional scale factor.
beta (Optional)
Type: SystemDouble
Optional delta added to the scaled values.
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.CopyTo Method

UMatCopyTo Method

Overload List
 | Name | Description
Public method | CopyToT(T) | Copy data from this Mat to the managed array
Public method | CopyTo(IOutputArray, IInputArray) | Copy the data in this umat to the other mat
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.CopyTo(T) Method (T[])

UMatCopyToT Method (T)

http://www.emgu.com
Copy data from this Mat to the managed array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo<T>(
    T[] data
)

Public Sub CopyTo(Of T) (
    data As T()
)
public:
generic<typename T>
void CopyTo(
    array<T>^ data
)
member CopyTo :
        data : 'T[] -> unit

Parameters

data
Type: T
The managed array where data will be copied to.

Type Parameters

T
The type of managed data array
See Also

Reference

UMat Class
CopyTo Overload
Emgu.CV Namespace


UMat.CopyTo Method (IOutputArray, IInputArray)

UMatCopyTo Method (IOutputArray, IInputArray)

http://www.emgu.com
Copy the data in this umat to the other mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    IOutputArray m,
    IInputArray mask = null
)
Public Sub CopyTo (
    m As IOutputArray,
    Optional mask As IInputArray = Nothing
)
public:
void CopyTo(
    IOutputArray^ m,
    IInputArray^ mask = nullptr
)
member CopyTo :
        m : IOutputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

m
Type: Emgu.CVIOutputArray
The input array to copy to
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask. Its non-zero elements indicate which matrix elements need to be copied.
See Also

Reference

UMat Class
CopyTo Overload
Emgu.CV Namespace


UMat.Create Method

UMatCreate Method

Allocates new array data if needed.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Create(
    int rows,
    int cols,
    DepthType type,
    int channels,
    UMatUsage usage = 0
)
Public Sub Create (
    rows As Integer,
    cols As Integer,
    type As DepthType,
    channels As Integer,
    Optional usage As UMatUsage = 0
)
public:
void Create(
    int rows,
    int cols,
    DepthType^ type,
    int channels,
    UMatUsage^ usage = 0
)
member Create :
        rows : int *
        cols : int *
        type : DepthType *
        channels : int *
        ?usage : UMatUsage
(* Defaults:
        let _usage = defaultArg usage 0
*)
-> unit

Parameters

rows
Type: SystemInt32
New number of rows.
cols
Type: SystemInt32
New number of columns.
type
Type: Emgu.CV.CvEnumDepthType
New matrix element depth type.
channels
Type: SystemInt32
New matrix number of channels
usage (Optional)
Type: Emgu.CVUMatUsage
Allocation Usage
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.DeserializeObjectData Method

UMatDeserializeObjectData Method

A function used for runtime deserailization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void DeserializeObjectData(
    SerializationInfo info,
    StreamingContext context
)
Protected Overridable Sub DeserializeObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
virtual void DeserializeObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
)
abstract DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override DeserializeObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.DisposeObject Method

UMatDisposeObject Method

Release all the unmanaged memory associated with this object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Dot Method

UMatDot Method

Computes the dot product of two mats

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Dot(
    IInputArray mat
)
Public Function Dot (
    mat As IInputArray
) As Double
public:
double Dot(
    IInputArray^ mat
)
member Dot :
        mat : IInputArray -> float

Parameters

mat
Type: Emgu.CVIInputArray
The matrix to compute dot product with

Return Value

Type: Double
The dot product
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Equals Method

UMatEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(UMat) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Equals Method (UMat)

UMatEquals Method (UMat)

http://www.emgu.com
Indicates whether the current object is equal to another object of the same type.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    UMat other
)
Public Function Equals (
    other As UMat
) As Boolean
public:
virtual bool Equals(
    UMat^ other
) sealed
abstract Equals :
        other : UMat -> bool
override Equals :
        other : UMat -> bool

Parameters

other
Type: Emgu.CVUMat
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

UMat Class
Equals Overload
Emgu.CV Namespace


UMat.GetData Method

UMatGetData Method

Get a copy of the data values as an array

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Array GetData(
    bool jagged = true
)
Public Function GetData (
    Optional jagged As Boolean = true
) As Array
public:
Array^ GetData(
    bool jagged = true
)
member GetData :
        ?jagged : bool
(* Defaults:
        let _jagged = defaultArg jagged true
*)
-> Array

Parameters

jagged (Optional)
Type: SystemBoolean
If true, a jagged array will returned. Otherwise it will return a regular array.

Return Value

Type: Array
a copy of the data values as an array
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.GetInputArray Method

UMatGetInputArray Method

Pointer to the InputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.GetInputOutputArray Method

UMatGetInputOutputArray Method

Pointer to the InputOutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.GetMat Method

UMatGetMat Method

Return the Mat representation of the UMat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat GetMat(
    AccessType access
)
Public Function GetMat (
    access As AccessType
) As Mat
public:
Mat^ GetMat(
    AccessType^ access
)
member GetMat :
        access : AccessType -> Mat

Parameters

access
Type: Emgu.CV.CvEnumAccessType
The access type

Return Value

Type: Mat
The Mat representation of the UMat
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.GetObjectData Method

UMatGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.GetOutputArray Method

UMatGetOutputArray Method

Pointer to the OutputArray

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.MinMax Method

UMatMinMax Method

Returns the min / max location and values for the image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MinMax(
    out double[] minValues,
    out double[] maxValues,
    out Point[] minLocations,
    out Point[] maxLocations
)
Public Sub MinMax (
    <OutAttribute> ByRef minValues As Double(),
    <OutAttribute> ByRef maxValues As Double(),
    <OutAttribute> ByRef minLocations As Point(),
    <OutAttribute> ByRef maxLocations As Point()
)
public:
void MinMax(
    [OutAttribute] array<double>^% minValues,
    [OutAttribute] array<double>^% maxValues,
    [OutAttribute] array<Point^>^% minLocations,
    [OutAttribute] array<Point^>^% maxLocations
)
member MinMax :
        minValues : float[] byref *
        maxValues : float[] byref *
        minLocations : Point[] byref *
        maxLocations : Point[] byref -> unit

Parameters

minValues
Type: SystemDouble
The minimum values for each channel
maxValues
Type: SystemDouble
The maximum values for each channel
minLocations
Type: System.DrawingPoint
The minimum locations for each channel
maxLocations
Type: System.DrawingPoint
The maximum locations for each channel
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Reshape Method

UMatReshape Method

Changes the shape and/or the number of channels of a 2D matrix without copying the data.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat Reshape(
    int cn,
    int rows = 0
)
Public Function Reshape (
    cn As Integer,
    Optional rows As Integer = 0
) As UMat
public:
UMat^ Reshape(
    int cn,
    int rows = 0
)
member Reshape :
        cn : int *
        ?rows : int
(* Defaults:
        let _rows = defaultArg rows 0
*)
-> UMat

Parameters

cn
Type: SystemInt32
New number of channels. If the parameter is 0, the number of channels remains the same.
rows (Optional)
Type: SystemInt32
New number of rows. If the parameter is 0, the number of rows remains the same.

Return Value

Type: UMat
A new mat header that has different shape
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Row Method

UMatRow Method

Creates a matrix header for the specified matrix row.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat Row(
    int y
)
Public Function Row (
    y As Integer
) As UMat
public:
UMat^ Row(
    int y
)
member Row :
        y : int -> UMat

Parameters

y
Type: SystemInt32
A 0-based row index.

Return Value

Type: UMat
A matrix header for the specified matrix row.
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Save Method

UMatSave Method

Save this image to the specific file.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Save(
    string fileName
)
Public Sub Save (
    fileName As String
)
public:
void Save(
    String^ fileName
)
member Save :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The name of the file to be saved to
Remarks
The image format is chosen depending on the filename extension, see cvLoadImage. Only 8-bit single-channel or 3-channel (with 'BGR' channel order) images can be saved using this function. If the format, depth or channel order is different, use cvCvtScale and cvCvtColor to convert it before saving, or use universal cvSave to save the image to XML or YAML format.
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.SetTo Method

UMatSetTo Method

Overload List
 | Name | Description
Public method | SetToT(T) | Copy data from managed array to this Mat
Public method | SetTo(IInputArray, IInputArray) | Sets all or some of the array elements to the specified value.
Public method | SetTo(MCvScalar, IInputArray) | Sets all or some of the array elements to the specified value.
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.SetTo(T) Method (T[])

UMatSetToT Method (T)

http://www.emgu.com
Copy data from managed array to this Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTo<T>(
    T[] data
)

Public Sub SetTo(Of T) (
    data As T()
)
public:
generic<typename T>
void SetTo(
    array<T>^ data
)
member SetTo :
        data : 'T[] -> unit

Parameters

data
Type: T
The managed array where data will be copied from

Type Parameters

T
The type of managed data array
See Also

Reference

UMat Class
SetTo Overload
Emgu.CV Namespace


UMat.SetTo Method (IInputArray, IInputArray)

UMatSetTo Method (IInputArray, IInputArray)

http://www.emgu.com
Sets all or some of the array elements to the specified value.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTo(
    IInputArray value,
    IInputArray mask = null
)
Public Sub SetTo (
    value As IInputArray,
    Optional mask As IInputArray = Nothing
)
public:
void SetTo(
    IInputArray^ value,
    IInputArray^ mask = nullptr
)
member SetTo :
        value : IInputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

value
Type: Emgu.CVIInputArray
Assigned scalar converted to the actual array type.
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask of the same size as the umat.
See Also

Reference

UMat Class
SetTo Overload
Emgu.CV Namespace


UMat.SetTo Method (MCvScalar, IInputArray)

UMatSetTo Method (MCvScalar, IInputArray)

http://www.emgu.com
Sets all or some of the array elements to the specified value.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTo(
    MCvScalar value,
    IInputArray mask = null
)
Public Sub SetTo (
    value As MCvScalar,
    Optional mask As IInputArray = Nothing
)
public:
void SetTo(
    MCvScalar^ value,
    IInputArray^ mask = nullptr
)
member SetTo :
        value : MCvScalar *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

value
Type: Emgu.CV.StructureMCvScalar
Assigned scalar value.
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask of the same size as the umat.
See Also

Reference

UMat Class
SetTo Overload
Emgu.CV Namespace


UMat.Split Method

UMatSplit Method

Split current Image into an array of gray scale images where each element in the array represent a single color channel of the original image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat[] Split()
Public Function Split As UMat()
public:
array<UMat^>^ Split()
member Split : unit -> UMat[]

Return Value

Type: UMat
An array of gray scale images where each element in the array represent a single color channel of the original image
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.ToImage(TColor, TDepth) Method

UMatToImageTColor, TDepth Method

Convert this Mat to Image

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ToImage<TColor, TDepth>()
where TColor : struct, new(), IColor
where TDepth : new()

Public Function ToImage(Of TColor As {Structure, New, IColor}, TDepth As New) As Image(Of TColor, TDepth)
public:
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
Image<TColor, TDepth>^ ToImage()
member ToImage : unit -> Image<'TColor, 'TDepth>  when 'TColor : struct, new() and IColor when 'TDepth : new()

Type Parameters

TColor
The type of Color
TDepth
The type of Depth

Return Value

Type: Image TColor, TDepth
The image
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat Operators

The UMat type exposes the following members.

Operators
Name | Description
Addition(Double, UMat) | Element wise add mat1 with value
Addition(MCvScalar, UMat) | Element wise add mat with value
Addition(UMat, MCvScalar) | Element wise add mat with value
Addition(UMat, UMat) | Element wise add mat1 with mat2
Addition(UMat, Double) | Element wise add mat with value
BitwiseAnd(Double, UMat) | Perform an element wise AND operation using a mat and a color
BitwiseAnd(MCvScalar, UMat) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(UMat, MCvScalar) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(UMat, UMat) | Perform an element wise AND operation on the two mats
BitwiseAnd(UMat, Double) | Perform an element wise AND operation using a mat and a scalar
BitwiseOr(Double, UMat) | Perform an binary OR operation with some color
BitwiseOr(MCvScalar, UMat) | Perform an binary OR operation with some scalar
BitwiseOr(UMat, MCvScalar) | Perform an binary OR operation with some scalar
BitwiseOr(UMat, UMat) | Perform an element wise OR operation with another mat and return the result
BitwiseOr(UMat, Double) | Perform an binary OR operation with some value
Division(Double, UMat) | scale / mat
Division(UMat, Double) | mat / scale
Multiply(Double, UMat) | scale*mat
Multiply(UMat, Double) | mat * scale
OnesComplement | Compute the complement Mat
Subtraction(Double, UMat) | value - mat
Subtraction(MCvScalar, UMat) | Element wise subtract value from the current mat
Subtraction(UMat, MCvScalar) | Element wise subtract another mat from the current mat
Subtraction(UMat, UMat) | Element wise subtract another mat from the current mat
Subtraction(UMat, Double) | Element wise subtract value from the current mat
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Addition Operator

UMatAddition Operator

Overload List
Name | Description
Addition(Double, UMat) | Element wise add mat1 with value
Addition(MCvScalar, UMat) | Element wise add mat with value
Addition(UMat, MCvScalar) | Element wise add mat with value
Addition(UMat, UMat) | Element wise add mat1 with mat2
Addition(UMat, Double) | Element wise add mat with value
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Addition Operator (Double, UMat)

UMatAddition Operator (Double, UMat)

http://www.emgu.com
Element wise add mat1 with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator +(
    double value,
    UMat mat1
)
Public Shared Operator + (
    value As Double,
    mat1 As UMat
) As UMat
public:
static UMat^ operator +(
    double value,
    UMat^ mat1
)
static let inline (+)
        value : float *
        mat1 : UMat  : UMat

Parameters

value
Type: SystemDouble
The value to be added
mat1
Type: Emgu.CVUMat
The mat to be added

Return Value

Type: UMat
The mat plus the value
See Also

Reference

UMat Class
Addition Overload
Emgu.CV Namespace


UMat.Addition Operator (MCvScalar, UMat)

UMatAddition Operator (MCvScalar, UMat)

http://www.emgu.com
Element wise add mat with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator +(
    MCvScalar value,
    UMat mat
)
Public Shared Operator + (
    value As MCvScalar,
    mat As UMat
) As UMat
public:
static UMat^ operator +(
    MCvScalar^ value,
    UMat^ mat
)
static let inline (+)
        value : MCvScalar *
        mat : UMat  : UMat

Parameters

value
Type: Emgu.CV.StructureMCvScalar
The color to be added
mat
Type: Emgu.CVUMat
The mat to be added

Return Value

Type: UMat
The images plus the color
See Also

Reference

UMat Class
Addition Overload
Emgu.CV Namespace


UMat.Addition Operator (UMat, MCvScalar)

UMatAddition Operator (UMat, MCvScalar)

http://www.emgu.com
Element wise add mat with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator +(
    UMat mat,
    MCvScalar value
)
Public Shared Operator + (
    mat As UMat,
    value As MCvScalar
) As UMat
public:
static UMat^ operator +(
    UMat^ mat,
    MCvScalar^ value
)
static let inline (+)
        mat : UMat *
        value : MCvScalar  : UMat

Parameters

mat
Type: Emgu.CVUMat
The mat to be added
value
Type: Emgu.CV.StructureMCvScalar
The value to be added

Return Value

Type: UMat
The mat plus the value
See Also

Reference

UMat Class
Addition Overload
Emgu.CV Namespace


UMat.Addition Operator (UMat, UMat)

UMatAddition Operator (UMat, UMat)

http://www.emgu.com
Element wise add mat1 with mat2

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator +(
    UMat mat1,
    UMat mat2
)
Public Shared Operator + (
    mat1 As UMat,
    mat2 As UMat
) As UMat
public:
static UMat^ operator +(
    UMat^ mat1,
    UMat^ mat2
)
static let inline (+)
        mat1 : UMat *
        mat2 : UMat  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The first mat to be added
mat2
Type: Emgu.CVUMat
The second mat to be added

Return Value

Type: UMat
The sum of the two images
See Also

Reference

UMat Class
Addition Overload
Emgu.CV Namespace


UMat.Addition Operator (UMat, Double)

UMatAddition Operator (UMat, Double)

http://www.emgu.com
Element wise add mat with value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator +(
    UMat mat,
    double value
)
Public Shared Operator + (
    mat As UMat,
    value As Double
) As UMat
public:
static UMat^ operator +(
    UMat^ mat,
    double value
)
static let inline (+)
        mat : UMat *
        value : float  : UMat

Parameters

mat
Type: Emgu.CVUMat
The mat to be added
value
Type: SystemDouble
The value to be added

Return Value

Type: UMat
The images plus the value
See Also

Reference

UMat Class
Addition Overload
Emgu.CV Namespace


UMat.BitwiseAnd Operator

UMatBitwiseAnd Operator

Overload List
Name | Description
BitwiseAnd(Double, UMat) | Perform an element wise AND operation using a mat and a color
BitwiseAnd(MCvScalar, UMat) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(UMat, MCvScalar) | Perform an element wise AND operation using a mat and a scalar
BitwiseAnd(UMat, UMat) | Perform an element wise AND operation on the two mats
BitwiseAnd(UMat, Double) | Perform an element wise AND operation using a mat and a scalar
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.BitwiseAnd Operator (Double, UMat)

UMatBitwiseAnd Operator (Double, UMat)

http://www.emgu.com
Perform an element wise AND operation using a mat and a color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator &(
    double val,
    UMat mat1
)
Public Shared Operator And (
    val As Double,
    mat1 As UMat
) As UMat
public:
static UMat^ operator &(
    double val,
    UMat^ mat1
)
static let inline (&&&)
        val : float *
        mat1 : UMat  : UMat

Parameters

val
Type: SystemDouble
The value to AND
mat1
Type: Emgu.CVUMat
The first mat to AND

Return Value

Type: UMat
The result of the AND operation
See Also

Reference

UMat Class
BitwiseAnd Overload
Emgu.CV Namespace


UMat.BitwiseAnd Operator (MCvScalar, UMat)

UMatBitwiseAnd Operator (MCvScalar, UMat)

http://www.emgu.com
Perform an element wise AND operation using a mat and a scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator &(
    MCvScalar val,
    UMat mat1
)
Public Shared Operator And (
    val As MCvScalar,
    mat1 As UMat
) As UMat
public:
static UMat^ operator &(
    MCvScalar^ val,
    UMat^ mat1
)
static let inline (&&&)
        val : MCvScalar *
        mat1 : UMat  : UMat

Parameters

val
Type: Emgu.CV.StructureMCvScalar
The scalar to AND
mat1
Type: Emgu.CVUMat
The first mat to AND

Return Value

Type: UMat
The result of the AND operation
See Also

Reference

UMat Class
BitwiseAnd Overload
Emgu.CV Namespace


UMat.BitwiseAnd Operator (UMat, MCvScalar)

UMatBitwiseAnd Operator (UMat, MCvScalar)

http://www.emgu.com
Perform an element wise AND operation using a mat and a scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator &(
    UMat mat1,
    MCvScalar val
)
Public Shared Operator And (
    mat1 As UMat,
    val As MCvScalar
) As UMat
public:
static UMat^ operator &(
    UMat^ mat1,
    MCvScalar^ val
)
static let inline (&&&)
        mat1 : UMat *
        val : MCvScalar  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The first mat to AND
val
Type: Emgu.CV.StructureMCvScalar
The value to AND

Return Value

Type: UMat
The result of the AND operation
See Also

Reference

UMat Class
BitwiseAnd Overload
Emgu.CV Namespace


UMat.BitwiseAnd Operator (UMat, UMat)

UMatBitwiseAnd Operator (UMat, UMat)

http://www.emgu.com
Perform an element wise AND operation on the two mats

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator &(
    UMat mat1,
    UMat mat2
)
Public Shared Operator And (
    mat1 As UMat,
    mat2 As UMat
) As UMat
public:
static UMat^ operator &(
    UMat^ mat1,
    UMat^ mat2
)
static let inline (&&&)
        mat1 : UMat *
        mat2 : UMat  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The first mat to AND
mat2
Type: Emgu.CVUMat
The second mat to AND

Return Value

Type: UMat
The result of the AND operation
See Also

Reference

UMat Class
BitwiseAnd Overload
Emgu.CV Namespace


UMat.BitwiseAnd Operator (UMat, Double)

UMatBitwiseAnd Operator (UMat, Double)

http://www.emgu.com
Perform an element wise AND operation using a mat and a scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator &(
    UMat mat1,
    double val
)
Public Shared Operator And (
    mat1 As UMat,
    val As Double
) As UMat
public:
static UMat^ operator &(
    UMat^ mat1,
    double val
)
static let inline (&&&)
        mat1 : UMat *
        val : float  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The first image to AND
val
Type: SystemDouble
The value to AND

Return Value

Type: UMat
The result of the AND operation
See Also

Reference

UMat Class
BitwiseAnd Overload
Emgu.CV Namespace


UMat.BitwiseOr Operator

UMatBitwiseOr Operator

Overload List
Name | Description
BitwiseOr(Double, UMat) | Perform an binary OR operation with some color
BitwiseOr(MCvScalar, UMat) | Perform an binary OR operation with some scalar
BitwiseOr(UMat, MCvScalar) | Perform an binary OR operation with some scalar
BitwiseOr(UMat, UMat) | Perform an element wise OR operation with another mat and return the result
BitwiseOr(UMat, Double) | Perform an binary OR operation with some value
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.BitwiseOr Operator (Double, UMat)

UMatBitwiseOr Operator (Double, UMat)

http://www.emgu.com
Perform an binary OR operation with some color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator |(
    double val,
    UMat mat1
)
Public Shared Operator Or (
    val As Double,
    mat1 As UMat
) As UMat
public:
static UMat^ operator |(
    double val,
    UMat^ mat1
)
static let inline (|||)
        val : float *
        mat1 : UMat  : UMat

Parameters

val
Type: SystemDouble
The color to OR
mat1
Type: Emgu.CVUMat
The mat to OR

Return Value

Type: UMat
The result of the OR operation
See Also

Reference

UMat Class
BitwiseOr Overload
Emgu.CV Namespace


UMat.BitwiseOr Operator (MCvScalar, UMat)

UMatBitwiseOr Operator (MCvScalar, UMat)

http://www.emgu.com
Perform an binary OR operation with some scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator |(
    MCvScalar val,
    UMat mat1
)
Public Shared Operator Or (
    val As MCvScalar,
    mat1 As UMat
) As UMat
public:
static UMat^ operator |(
    MCvScalar^ val,
    UMat^ mat1
)
static let inline (|||)
        val : MCvScalar *
        mat1 : UMat  : UMat

Parameters

val
Type: Emgu.CV.StructureMCvScalar
The color to OR
mat1
Type: Emgu.CVUMat
The mat to OR

Return Value

Type: UMat
The result of the OR operation
See Also

Reference

UMat Class
BitwiseOr Overload
Emgu.CV Namespace


UMat.BitwiseOr Operator (UMat, MCvScalar)

UMatBitwiseOr Operator (UMat, MCvScalar)

http://www.emgu.com
Perform an binary OR operation with some scalar

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator |(
    UMat mat1,
    MCvScalar val
)
Public Shared Operator Or (
    mat1 As UMat,
    val As MCvScalar
) As UMat
public:
static UMat^ operator |(
    UMat^ mat1,
    MCvScalar^ val
)
static let inline (|||)
        mat1 : UMat *
        val : MCvScalar  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The mat to OR
val
Type: Emgu.CV.StructureMCvScalar
The value to OR

Return Value

Type: UMat
The result of the OR operation
See Also

Reference

UMat Class
BitwiseOr Overload
Emgu.CV Namespace


UMat.BitwiseOr Operator (UMat, UMat)

UMatBitwiseOr Operator (UMat, UMat)

http://www.emgu.com
Perform an element wise OR operation with another mat and return the result

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator |(
    UMat mat1,
    UMat mat2
)
Public Shared Operator Or (
    mat1 As UMat,
    mat2 As UMat
) As UMat
public:
static UMat^ operator |(
    UMat^ mat1,
    UMat^ mat2
)
static let inline (|||)
        mat1 : UMat *
        mat2 : UMat  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The first mat to apply bitwise OR operation
mat2
Type: Emgu.CVUMat
The second mat to apply bitwise OR operation

Return Value

Type: UMat
The result of the OR operation
See Also

Reference

UMat Class
BitwiseOr Overload
Emgu.CV Namespace


UMat.BitwiseOr Operator (UMat, Double)

UMatBitwiseOr Operator (UMat, Double)

http://www.emgu.com
Perform an binary OR operation with some value

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator |(
    UMat mat1,
    double val
)
Public Shared Operator Or (
    mat1 As UMat,
    val As Double
) As UMat
public:
static UMat^ operator |(
    UMat^ mat1,
    double val
)
static let inline (|||)
        mat1 : UMat *
        val : float  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The mat to OR
val
Type: SystemDouble
The color to OR

Return Value

Type: UMat
The result of the OR operation
See Also

Reference

UMat Class
BitwiseOr Overload
Emgu.CV Namespace


UMat.Division Operator

UMatDivision Operator

Overload List
Name | Description
Division(Double, UMat) | scale / mat
Division(UMat, Double) | mat / scale
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Division Operator (Double, UMat)

UMatDivision Operator (Double, UMat)

http://www.emgu.com
scale / mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator /(
    double scale,
    UMat mat
)
Public Shared Operator / (
    scale As Double,
    mat As UMat
) As UMat
public:
static UMat^ operator /(
    double scale,
    UMat^ mat
)
static let inline (/)
        scale : float *
        mat : UMat  : UMat

Parameters

scale
Type: SystemDouble
The scale
mat
Type: Emgu.CVUMat
The mat

Return Value

Type: UMat
scale / mat
See Also

Reference

UMat Class
Division Overload
Emgu.CV Namespace


UMat.Division Operator (UMat, Double)

UMatDivision Operator (UMat, Double)

http://www.emgu.com
mat / scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator /(
    UMat mat,
    double scale
)
Public Shared Operator / (
    mat As UMat,
    scale As Double
) As UMat
public:
static UMat^ operator /(
    UMat^ mat,
    double scale
)
static let inline (/)
        mat : UMat *
        scale : float  : UMat

Parameters

mat
Type: Emgu.CVUMat
The mat
scale
Type: SystemDouble
The division scale

Return Value

Type: UMat
mat / scale
See Also

Reference

UMat Class
Division Overload
Emgu.CV Namespace


UMat.Multiply Operator

UMatMultiply Operator

Overload List
Name | Description
Multiply(Double, UMat) | scale*mat
Multiply(UMat, Double) | mat * scale
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Multiply Operator (Double, UMat)

UMatMultiply Operator (Double, UMat)

http://www.emgu.com
scale*mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator *(
    double scale,
    UMat mat
)
Public Shared Operator * (
    scale As Double,
    mat As UMat
) As UMat
public:
static UMat^ operator *(
    double scale,
    UMat^ mat
)
static let inline (*)
        scale : float *
        mat : UMat  : UMat

Parameters

scale
Type: SystemDouble
The multiplication scale
mat
Type: Emgu.CVUMat
The mat

Return Value

Type: UMat
scale*mat
See Also

Reference

UMat Class
Multiply Overload
Emgu.CV Namespace


UMat.Multiply Operator (UMat, Double)

UMatMultiply Operator (UMat, Double)

http://www.emgu.com
mat * scale

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator *(
    UMat mat,
    double scale
)
Public Shared Operator * (
    mat As UMat,
    scale As Double
) As UMat
public:
static UMat^ operator *(
    UMat^ mat,
    double scale
)
static let inline (*)
        mat : UMat *
        scale : float  : UMat

Parameters

mat
Type: Emgu.CVUMat
The mat
scale
Type: SystemDouble
The multiplication scale

Return Value

Type: UMat
mat * scale
See Also

Reference

UMat Class
Multiply Overload
Emgu.CV Namespace


UMat.OnesComplement Operator

UMatOnesComplement Operator

Compute the complement Mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator ~(
    UMat mat
)
Public Shared Operator ~ (
    mat As UMat
) As UMat
public:
static UMat^ operator ~(
    UMat^ mat
)
F# does not support this operator.

Parameters

mat
Type: Emgu.CVUMat
The mat to be inverted

Return Value

Type: UMat
The complement image
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Subtraction Operator

UMatSubtraction Operator

Overload List
Name | Description
Subtraction(Double, UMat) | value - mat
Subtraction(MCvScalar, UMat) | Element wise subtract value from the current mat
Subtraction(UMat, MCvScalar) | Element wise subtract another mat from the current mat
Subtraction(UMat, UMat) | Element wise subtract another mat from the current mat
Subtraction(UMat, Double) | Element wise subtract value from the current mat
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Subtraction Operator (Double, UMat)

UMatSubtraction Operator (Double, UMat)

http://www.emgu.com
value - mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator -(
    double value,
    UMat mat
)
Public Shared Operator - (
    value As Double,
    mat As UMat
) As UMat
public:
static UMat^ operator -(
    double value,
    UMat^ mat
)
static let inline (-)
        value : float *
        mat : UMat  : UMat

Parameters

value
Type: SystemDouble
The value to be subtracted
mat
Type: Emgu.CVUMat
The mat to be subtracted

Return Value

Type: UMat
value - mat
See Also

Reference

UMat Class
Subtraction Overload
Emgu.CV Namespace


UMat.Subtraction Operator (MCvScalar, UMat)

UMatSubtraction Operator (MCvScalar, UMat)

http://www.emgu.com
Element wise subtract value from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator -(
    MCvScalar value,
    UMat mat
)
Public Shared Operator - (
    value As MCvScalar,
    mat As UMat
) As UMat
public:
static UMat^ operator -(
    MCvScalar^ value,
    UMat^ mat
)
static let inline (-)
        value : MCvScalar *
        mat : UMat  : UMat

Parameters

value
Type: Emgu.CV.StructureMCvScalar
The color to be subtracted
mat
Type: Emgu.CVUMat
The mat to be subtracted

Return Value

Type: UMat
value - mat
See Also

Reference

UMat Class
Subtraction Overload
Emgu.CV Namespace


UMat.Subtraction Operator (UMat, MCvScalar)

UMatSubtraction Operator (UMat, MCvScalar)

http://www.emgu.com
Element wise subtract another mat from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator -(
    UMat mat,
    MCvScalar value
)
Public Shared Operator - (
    mat As UMat,
    value As MCvScalar
) As UMat
public:
static UMat^ operator -(
    UMat^ mat,
    MCvScalar^ value
)
static let inline (-)
        mat : UMat *
        value : MCvScalar  : UMat

Parameters

mat
Type: Emgu.CVUMat
The mat to be subtracted
value
Type: Emgu.CV.StructureMCvScalar
The value to be subtracted

Return Value

Type: UMat
The result of element wise subtracting value from mat
See Also

Reference

UMat Class
Subtraction Overload
Emgu.CV Namespace


UMat.Subtraction Operator (UMat, UMat)

UMatSubtraction Operator (UMat, UMat)

http://www.emgu.com
Element wise subtract another mat from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator -(
    UMat mat1,
    UMat mat2
)
Public Shared Operator - (
    mat1 As UMat,
    mat2 As UMat
) As UMat
public:
static UMat^ operator -(
    UMat^ mat1,
    UMat^ mat2
)
static let inline (-)
        mat1 : UMat *
        mat2 : UMat  : UMat

Parameters

mat1
Type: Emgu.CVUMat
The mat to be subtracted from.
mat2
Type: Emgu.CVUMat
The second image to be subtracted from mat1

Return Value

Type: UMat
The result of element wise subtracting img2 from mat1
See Also

Reference

UMat Class
Subtraction Overload
Emgu.CV Namespace


UMat.Subtraction Operator (UMat, Double)

UMatSubtraction Operator (UMat, Double)

http://www.emgu.com
Element wise subtract value from the current mat

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static UMat operator -(
    UMat mat,
    double value
)
Public Shared Operator - (
    mat As UMat,
    value As Double
) As UMat
public:
static UMat^ operator -(
    UMat^ mat,
    double value
)
static let inline (-)
        mat : UMat *
        value : float  : UMat

Parameters

mat
Type: Emgu.CVUMat
The mat to be subtracted
value
Type: SystemDouble
The value to be subtracted

Return Value

Type: UMat
mat - value
See Also

Reference

UMat Class
Subtraction Overload
Emgu.CV Namespace


UMat Fields

The UMat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

UMat Class
Emgu.CV Namespace


UMat.Usage Class

UMatUsage Class

Allocation usage.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVUMatUsage

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Usage : Enum
Public NotInheritable Class Usage
    Inherits Enum
public ref class Usage sealed : public Enum
[<SealedAttribute>]
type Usage =
    class
        inherit Enum
    end

The UMatUsage type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AllocateDeviceMemory | Buffer allocation policy is platform and usage specific
 | AllocateHostMemory | Buffer allocation policy is platform and usage specific
 | AllocateSharedMemory | Buffer allocation policy is platform and usage specific It is not equal to: AllocateHostMemory | AllocateDeviceMemory
 | Default | Default
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


Usage Methods

The UMatUsage type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

UMatUsage Class
Emgu.CV Namespace


Usage Fields

The UMatUsage type exposes the following members.

Fields
 | Name | Description
 | AllocateDeviceMemory | Buffer allocation policy is platform and usage specific
 | AllocateHostMemory | Buffer allocation policy is platform and usage specific
 | AllocateSharedMemory | Buffer allocation policy is platform and usage specific It is not equal to: AllocateHostMemory | AllocateDeviceMemory
 | Default | Default
Public field | value__ |
Top
See Also

Reference

UMatUsage Class
Emgu.CV Namespace


UMat.Usage.AllocateDeviceMemory Field

UMatUsageAllocateDeviceMemory Field

Buffer allocation policy is platform and usage specific

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const UMatUsage AllocateDeviceMemory = 2
Public Const AllocateDeviceMemory As UMatUsage = 2
public:
literal UMatUsage^ AllocateDeviceMemory = 2
static val mutable AllocateDeviceMemory: UMatUsage

Field Value

Type: UMatUsage
See Also

Reference

UMatUsage Class
Emgu.CV Namespace


UMat.Usage.AllocateHostMemory Field

UMatUsageAllocateHostMemory Field

Buffer allocation policy is platform and usage specific

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const UMatUsage AllocateHostMemory = 1
Public Const AllocateHostMemory As UMatUsage = 1
public:
literal UMatUsage^ AllocateHostMemory = 1
static val mutable AllocateHostMemory: UMatUsage

Field Value

Type: UMatUsage
See Also

Reference

UMatUsage Class
Emgu.CV Namespace


UMat.Usage.AllocateSharedMemory Field

UMatUsageAllocateSharedMemory Field

Buffer allocation policy is platform and usage specific It is not equal to: AllocateHostMemory | AllocateDeviceMemory

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const UMatUsage AllocateSharedMemory = 4
Public Const AllocateSharedMemory As UMatUsage = 4
public:
literal UMatUsage^ AllocateSharedMemory = 4
static val mutable AllocateSharedMemory: UMatUsage

Field Value

Type: UMatUsage
See Also

Reference

UMatUsage Class
Emgu.CV Namespace


UMat.Usage.Default Field

UMatUsageDefault Field

Default

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const UMatUsage Default = 0
Public Const Default As UMatUsage = 0
public:
literal UMatUsage^ Default = 0
static val mutable Default: UMatUsage

Field Value

Type: UMatUsage
See Also

Reference

UMatUsage Class
Emgu.CV Namespace


UMat.Usage.value__ Field

UMatUsagevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.UMat.Usage.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

UMatUsage Class
Emgu.CV Namespace


VariationalRefinement Class

This class implements variational refinement of the input flow field.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVVariationalRefinement

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class VariationalRefinement : UnmanagedObject,
    IDenseOpticalFlow, IAlgorithm
Public Class VariationalRefinement
    Inherits UnmanagedObject
    Implements IDenseOpticalFlow, IAlgorithm
public ref class VariationalRefinement : public UnmanagedObject,
    IDenseOpticalFlow, IAlgorithm
type VariationalRefinement =
    class
        inherit UnmanagedObject
        interface IDenseOpticalFlow
        interface IAlgorithm
    end

The VariationalRefinement type exposes the following members.

Constructors
 | Name | Description
Public method | VariationalRefinement | Create an instance of Variational Refinement.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged cv::Algorithm
Public property | Alpha | Weight of the smoothness term
Public property | Delta | Weight of the color constancy term
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged cv::DenseOpticalFlow
Public property | FixedPointIterations | Number of outer (fixed-point) iterations in the minimization procedure.
Public property | Gamma | Weight of the gradient constancy term
Public property | Omega | Relaxation factor in SOR
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SorIterations | Number of inner successive over-relaxation (SOR) iterations in the minimization procedure to solve the respective linear system.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Optical flow algorithm. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
Remarks
See: Thomas Brox, Andres Bruhn, Nils Papenberg, and Joachim Weickert. High accuracy optical flow estimation based on a theory for warping. In Computer Vision-ECCV 2004, pages 25-36. Springer, 2004.
See Also

Reference

Emgu.CV Namespace


VariationalRefinement Constructor

Create an instance of Variational Refinement.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VariationalRefinement()
Public Sub New
public:
VariationalRefinement()
new : unit -> VariationalRefinement
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement Properties

The VariationalRefinement type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged cv::Algorithm
Public property | Alpha | Weight of the smoothness term
Public property | Delta | Weight of the color constancy term
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged cv::DenseOpticalFlow
Public property | FixedPointIterations | Number of outer (fixed-point) iterations in the minimization procedure.
Public property | Gamma | Weight of the gradient constancy term
Public property | Omega | Relaxation factor in SOR
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SorIterations | Number of inner successive over-relaxation (SOR) iterations in the minimization procedure to solve the respective linear system.
Top
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.AlgorithmPtr Property

VariationalRefinementAlgorithmPtr Property

Pointer to the unmanaged cv::Algorithm

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.Alpha Property

VariationalRefinementAlpha Property

Weight of the smoothness term

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Alpha { get; set; }
Public Property Alpha As Single
    Get
    Set
public:
property float Alpha {
    float get ();
    void set (float value);
}
member Alpha : float32 with get, set

Property Value

Type: Single
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.Delta Property

VariationalRefinementDelta Property

Weight of the color constancy term

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Delta { get; set; }
Public Property Delta As Single
    Get
    Set
public:
property float Delta {
    float get ();
    void set (float value);
}
member Delta : float32 with get, set

Property Value

Type: Single
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.DenseOpticalFlowPtr Property

VariationalRefinementDenseOpticalFlowPtr Property

Pointer to the unmanaged cv::DenseOpticalFlow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.FixedPointIterations Property

VariationalRefinementFixedPointIterations Property

Number of outer (fixed-point) iterations in the minimization procedure.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int FixedPointIterations { get; set; }
Public Property FixedPointIterations As Integer
    Get
    Set
public:
property int FixedPointIterations {
    int get ();
    void set (int value);
}
member FixedPointIterations : int with get, set

Property Value

Type: Int32
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.Gamma Property

VariationalRefinementGamma Property

Weight of the gradient constancy term

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Gamma { get; set; }
Public Property Gamma As Single
    Get
    Set
public:
property float Gamma {
    float get ();
    void set (float value);
}
member Gamma : float32 with get, set

Property Value

Type: Single
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.Omega Property

VariationalRefinementOmega Property

Relaxation factor in SOR

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Omega { get; set; }
Public Property Omega As Single
    Get
    Set
public:
property float Omega {
    float get ();
    void set (float value);
}
member Omega : float32 with get, set

Property Value

Type: Single
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.SorIterations Property

VariationalRefinementSorIterations Property

Number of inner successive over-relaxation (SOR) iterations in the minimization procedure to solve the respective linear system.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int SorIterations { get; set; }
Public Property SorIterations As Integer
    Get
    Set
public:
property int SorIterations {
    int get ();
    void set (int value);
}
member SorIterations : int with get, set

Property Value

Type: Int32
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement Methods

The VariationalRefinement type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Optical flow algorithm. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates an optical flow. (Defined by DenseOpticalFlowExtensions.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement.DisposeObject Method

VariationalRefinementDisposeObject Method

Release the unmanaged memory associated with this Optical flow algorithm.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VariationalRefinement Fields

The VariationalRefinement type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VariationalRefinement Class
Emgu.CV Namespace


VideoCapture Class

Capture images from either camera or video file.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVVideoCapture

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class VideoCapture : UnmanagedObject,
    ICapture
Public Class VideoCapture
    Inherits UnmanagedObject
    Implements ICapture
public ref class VideoCapture : public UnmanagedObject,
    ICapture
type VideoCapture =
    class
        inherit UnmanagedObject
        interface ICapture
    end

The VideoCapture type exposes the following members.

Constructors
 | Name | Description
Public method | VideoCapture(Int32, VideoCaptureAPI) | Create a capture using the specific camera
Public method | VideoCapture(String, VideoCaptureAPI) | Create a capture from file or a video stream
Top
Properties
 | Name | Description
Public property | BackendName | The name of the backend used by this VideoCapture
Public property | CaptureSource | Get the type of the capture module
Public property | FlipHorizontal | Get or Set if the captured image should be flipped horizontally
Public property | FlipType | Get and set the flip type
Public property | FlipVertical | Get or Set if the captured image should be flipped vertically
Public property | Height | The height of this capture
Public property | IsOpened | True if the camera is opened
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Width | The width of this capture
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the resource for this capture (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetCaptureProperty | Obtain the capture property
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Grab | Grab a frame
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause | Pause the grab process if it is running.
Public method | QueryFrame | Capture a Bgr image frame
Public method | QuerySmallFrame | Capture a Bgr image frame that is half width and half height. Mainly used by WCF when sending image to remote locations in a bandwidth conservative scenario
Public method | Read | Similar to the C++ implementation of cv::Capture >> Mat. It first call Grab() function follows by Retrieve()
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Retrieve | Decodes and returns the grabbed video frame.
Public method | SetCaptureProperty | Sets the specified property of video capturing
Public method | Start | Start the grab process in a separate thread. Once started, use the ImageGrabbed event handler and RetrieveGrayFrame/RetrieveBgrFrame to obtain the images.
Public method | Stop | Stop the grabbing thread
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ImageGrabbed | The event to be called when an image is grabbed
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Remarks
VideoCapture class is NOT implemented in Open CV for Android, iOS or UWP platforms
See Also

Reference

Emgu.CV Namespace


VideoCapture Constructor

Overload List
 | Name | Description
Public method | VideoCapture(Int32, VideoCaptureAPI) | Create a capture using the specific camera
Public method | VideoCapture(String, VideoCaptureAPI) | Create a capture from file or a video stream
Top
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture Constructor (Int32, VideoCapture.API)

VideoCapture Constructor (Int32, VideoCaptureAPI)

http://www.emgu.com
Create a capture using the specific camera

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VideoCapture(
    int camIndex = 0,
    VideoCaptureAPI captureApi = 0
)
Public Sub New (
    Optional camIndex As Integer = 0,
    Optional captureApi As VideoCaptureAPI = 0
)
public:
VideoCapture(
    int camIndex = 0,
    VideoCaptureAPI^ captureApi = 0
)
new :
        ?camIndex : int *
        ?captureApi : VideoCaptureAPI
(* Defaults:
        let _camIndex = defaultArg camIndex 0
        let _captureApi = defaultArg captureApi 0
*)
-> VideoCapture

Parameters

camIndex (Optional)
Type: SystemInt32
The index of the camera to create capture from, starting from 0
captureApi (Optional)
Type: Emgu.CVVideoCaptureAPI
The preferred Capture API backends to use. Can be used to enforce a specific reader implementation if multiple are available.
See Also

Reference

VideoCapture Class
VideoCapture Overload
Emgu.CV Namespace


VideoCapture Constructor (String, VideoCapture.API)

VideoCapture Constructor (String, VideoCaptureAPI)

http://www.emgu.com
Create a capture from file or a video stream

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VideoCapture(
    string fileName,
    VideoCaptureAPI captureApi = 0
)
Public Sub New (
    fileName As String,
    Optional captureApi As VideoCaptureAPI = 0
)
public:
VideoCapture(
    String^ fileName,
    VideoCaptureAPI^ captureApi = 0
)
new :
        fileName : string *
        ?captureApi : VideoCaptureAPI
(* Defaults:
        let _captureApi = defaultArg captureApi 0
*)
-> VideoCapture

Parameters

fileName
Type: SystemString
The name of a file, or an url pointed to a stream.
captureApi (Optional)
Type: Emgu.CVVideoCaptureAPI
The preferred Capture API backends to use. Can be used to enforce a specific reader implementation if multiple are available.
See Also

Reference

VideoCapture Class
VideoCapture Overload
Emgu.CV Namespace


VideoCapture Properties

The VideoCapture type exposes the following members.

Properties
 | Name | Description
Public property | BackendName | The name of the backend used by this VideoCapture
Public property | CaptureSource | Get the type of the capture module
Public property | FlipHorizontal | Get or Set if the captured image should be flipped horizontally
Public property | FlipType | Get and set the flip type
Public property | FlipVertical | Get or Set if the captured image should be flipped vertically
Public property | Height | The height of this capture
Public property | IsOpened | True if the camera is opened
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Width | The width of this capture
Top
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.BackendName Property

VideoCaptureBackendName Property

The name of the backend used by this VideoCapture

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string BackendName { get; }
Public ReadOnly Property BackendName As String
    Get
public:
property String^ BackendName {
    String^ get ();
}
member BackendName : string with get

Property Value

Type: String
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.CaptureSource Property

VideoCaptureCaptureSource Property

Get the type of the capture module

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VideoCaptureCaptureModuleType CaptureSource { get; }
Public ReadOnly Property CaptureSource As VideoCaptureCaptureModuleType
    Get
public:
property VideoCaptureCaptureModuleType^ CaptureSource {
    VideoCaptureCaptureModuleType^ get ();
}
member CaptureSource : VideoCaptureCaptureModuleType with get

Property Value

Type: VideoCaptureCaptureModuleType
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.FlipHorizontal Property

VideoCaptureFlipHorizontal Property

Get or Set if the captured image should be flipped horizontally

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FlipHorizontal { get; set; }
Public Property FlipHorizontal As Boolean
    Get
    Set
public:
property bool FlipHorizontal {
    bool get ();
    void set (bool value);
}
member FlipHorizontal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.FlipType Property

VideoCaptureFlipType Property

Get and set the flip type

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FlipType FlipType { get; set; }
Public Property FlipType As FlipType
    Get
    Set
public:
property FlipType^ FlipType {
    FlipType^ get ();
    void set (FlipType^ value);
}
member FlipType : FlipType with get, set

Property Value

Type: FlipType
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.FlipVertical Property

VideoCaptureFlipVertical Property

Get or Set if the captured image should be flipped vertically

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FlipVertical { get; set; }
Public Property FlipVertical As Boolean
    Get
    Set
public:
property bool FlipVertical {
    bool get ();
    void set (bool value);
}
member FlipVertical : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Height Property

VideoCaptureHeight Property

The height of this capture

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
property int Height {
    int get ();
}
member Height : int with get

Property Value

Type: Int32
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.IsOpened Property

VideoCaptureIsOpened Property

True if the camera is opened

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOpened { get; }
Public ReadOnly Property IsOpened As Boolean
    Get
public:
property bool IsOpened {
    bool get ();
}
member IsOpened : bool with get

Property Value

Type: Boolean
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Width Property

VideoCaptureWidth Property

The width of this capture

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}
member Width : int with get

Property Value

Type: Int32
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture Methods

The VideoCapture type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the resource for this capture (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetCaptureProperty | Obtain the capture property
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Grab | Grab a frame
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause | Pause the grab process if it is running.
Public method | QueryFrame | Capture a Bgr image frame
Public method | QuerySmallFrame | Capture a Bgr image frame that is half width and half height. Mainly used by WCF when sending image to remote locations in a bandwidth conservative scenario
Public method | Read | Similar to the C++ implementation of cv::Capture >> Mat. It first call Grab() function follows by Retrieve()
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Retrieve | Decodes and returns the grabbed video frame.
Public method | SetCaptureProperty | Sets the specified property of video capturing
Public method | Start | Start the grab process in a separate thread. Once started, use the ImageGrabbed event handler and RetrieveGrayFrame/RetrieveBgrFrame to obtain the images.
Public method | Stop | Stop the grabbing thread
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.DisposeObject Method

VideoCaptureDisposeObject Method

Release the resource for this capture

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.GetCaptureProperty Method

VideoCaptureGetCaptureProperty Method

Obtain the capture property

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double GetCaptureProperty(
    CapProp index
)
Public Function GetCaptureProperty (
    index As CapProp
) As Double
public:
double GetCaptureProperty(
    CapProp^ index
)
member GetCaptureProperty :
        index : CapProp -> float

Parameters

index
Type: Emgu.CV.CvEnumCapProp
The index for the property

Return Value

Type: Double
The value of the specific property
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Grab Method

VideoCaptureGrab Method

Grab a frame

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool Grab()
Public Overridable Function Grab As Boolean
public:
virtual bool Grab()
abstract Grab : unit -> bool
override Grab : unit -> bool

Return Value

Type: Boolean
True on success
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Pause Method

VideoCapturePause Method

Pause the grab process if it is running.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Pause()
Public Sub Pause
public:
void Pause()
member Pause : unit -> unit
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.QueryFrame Method

VideoCaptureQueryFrame Method

Capture a Bgr image frame

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual Mat QueryFrame()
Public Overridable Function QueryFrame As Mat
public:
virtual Mat^ QueryFrame()
abstract QueryFrame : unit -> Mat
override QueryFrame : unit -> Mat

Return Value

Type: Mat
A Bgr image frame. If no more frames are available, null will be returned.

Implements

ICaptureQueryFrame
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.QuerySmallFrame Method

VideoCaptureQuerySmallFrame Method

Capture a Bgr image frame that is half width and half height. Mainly used by WCF when sending image to remote locations in a bandwidth conservative scenario

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual Mat QuerySmallFrame()
Public Overridable Function QuerySmallFrame As Mat
public:
virtual Mat^ QuerySmallFrame()
abstract QuerySmallFrame : unit -> Mat
override QuerySmallFrame : unit -> Mat

Return Value

Type: Mat
A Bgr image frame that is half width and half height

Implements

ICaptureQuerySmallFrame
Remarks
Internally, this is a cvQueryFrame operation follow by a cvPyrDown
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Read Method

VideoCaptureRead Method

Similar to the C++ implementation of cv::Capture >> Mat. It first call Grab() function follows by Retrieve()

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Read(
    Mat m
)
Public Sub Read (
    m As Mat
)
public:
void Read(
    Mat^ m
)
member Read :
        m : Mat -> unit

Parameters

m
Type: Emgu.CVMat
The matrix the image will be read into.
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Retrieve Method

VideoCaptureRetrieve Method

Decodes and returns the grabbed video frame.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool Retrieve(
    IOutputArray image,
    int flag = 0
)
Public Overridable Function Retrieve (
    image As IOutputArray,
    Optional flag As Integer = 0
) As Boolean
public:
virtual bool Retrieve(
    IOutputArray^ image,
    int flag = 0
)
abstract Retrieve :
        image : IOutputArray *
        ?flag : int
(* Defaults:
        let _flag = defaultArg flag 0
*)
-> bool
override Retrieve :
        image : IOutputArray *
        ?flag : int
(* Defaults:
        let _flag = defaultArg flag 0
*)
-> bool

Parameters

image
Type: Emgu.CVIOutputArray
The video frame is returned here. If no frames has been grabbed the image will be empty.
flag (Optional)
Type: SystemInt32
It could be a frame index or a driver specific flag

Return Value

Type: Boolean
False if no frames has been grabbed
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.SetCaptureProperty Method

VideoCaptureSetCaptureProperty Method

Sets the specified property of video capturing

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SetCaptureProperty(
    CapProp property,
    double value
)
Public Function SetCaptureProperty (
    property As CapProp,
    value As Double
) As Boolean
public:
bool SetCaptureProperty(
    CapProp^ property,
    double value
)
member SetCaptureProperty :
        property : CapProp *
        value : float -> bool

Parameters

property
Type: Emgu.CV.CvEnumCapProp
Property identifier
value
Type: SystemDouble
Value of the property

Return Value

Type: Boolean
True if success
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Start Method

VideoCaptureStart Method

Start the grab process in a separate thread. Once started, use the ImageGrabbed event handler and RetrieveGrayFrame/RetrieveBgrFrame to obtain the images.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.Stop Method

VideoCaptureStop Method

Stop the grabbing thread

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
void Stop()
member Stop : unit -> unit
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture Events

The VideoCapture type exposes the following members.

Events
 | Name | Description
Public event | ImageGrabbed | The event to be called when an image is grabbed
Top
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.ImageGrabbed Event

VideoCaptureImageGrabbed Event

The event to be called when an image is grabbed

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ImageGrabbed
Public Event ImageGrabbed As EventHandler
public:
 event EventHandler^ ImageGrabbed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ImageGrabbed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture Fields

The VideoCapture type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VideoCapture Class
Emgu.CV Namespace


VideoCapture.API Class

VideoCaptureAPI Class

VideoCapture API backends identifier.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVVideoCaptureAPI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class API : Enum
Public NotInheritable Class API
    Inherits Enum
public ref class API sealed : public Enum
[<SealedAttribute>]
type API =
    class
        inherit Enum
    end

The VideoCaptureAPI type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Android | Android - not used
 | Any | Auto detect
 | Aravis | Aravis SDK
 | AVFoundation | AVFoundation framework for iOS (OS X Lion will have the same API)
 | CMU1394 | IEEE 1394 drivers
 | DC1394 | IEEE 1394 drivers
 | DShow | DirectShow (via videoInput)
 | Ffmpeg | Open and record video file or stream using the FFMPEG library
 | Firewire | IEEE 1394 drivers
 | Giganetix | Smartek Giganetix GigEVisionSDK
 | Gphoto2 | gPhoto2 connection
 | Gstreamer | GStreamer
 | IEEE1394 | IEEE 1394 drivers
 | Images | OpenCV Image Sequence (e.g. img_%02d.jpg)
 | IntelMfx | Intel MediaSDK
 | IntelPerc | Intel Perceptual Computing SDK
 | Msmf | Microsoft Media Foundation (via videoInput)
 | OpencvMjpeg | Built-in OpenCV MotionJPEG codec
 | OpenNI | OpenNI (for Kinect)
 | Openni2 | OpenNI2 (for Kinect)
 | Openni2Asus | OpenNI2 (for Asus Xtion and Occipital Structure sensors)
 | OpenNIAsus | OpenNI (for Asus Xtion)
 | Pvapi | PvAPI, Prosilica GigE SDK
 | QT | QuickTime (obsolete, removed)
 | Unicap | Unicap drivers (obsolete, removed)
 | V4L | V4L/V4L2 capturing support
 | V4L2 | Same as CAP_V4L
Public field | value__ |
 | Vfw | Video For Windows (obsolete, removed)
 | Winrt | Microsoft Windows Runtime using Media Foundation
 | XiApi | XIMEA Camera API
 | Xine | XINE engine (Linux)
Top
See Also

Reference

Emgu.CV Namespace


API Methods

The VideoCaptureAPI type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


API Fields

The VideoCaptureAPI type exposes the following members.

Fields
 | Name | Description
 | Android | Android - not used
 | Any | Auto detect
 | Aravis | Aravis SDK
 | AVFoundation | AVFoundation framework for iOS (OS X Lion will have the same API)
 | CMU1394 | IEEE 1394 drivers
 | DC1394 | IEEE 1394 drivers
 | DShow | DirectShow (via videoInput)
 | Ffmpeg | Open and record video file or stream using the FFMPEG library
 | Firewire | IEEE 1394 drivers
 | Giganetix | Smartek Giganetix GigEVisionSDK
 | Gphoto2 | gPhoto2 connection
 | Gstreamer | GStreamer
 | IEEE1394 | IEEE 1394 drivers
 | Images | OpenCV Image Sequence (e.g. img_%02d.jpg)
 | IntelMfx | Intel MediaSDK
 | IntelPerc | Intel Perceptual Computing SDK
 | Msmf | Microsoft Media Foundation (via videoInput)
 | OpencvMjpeg | Built-in OpenCV MotionJPEG codec
 | OpenNI | OpenNI (for Kinect)
 | Openni2 | OpenNI2 (for Kinect)
 | Openni2Asus | OpenNI2 (for Asus Xtion and Occipital Structure sensors)
 | OpenNIAsus | OpenNI (for Asus Xtion)
 | Pvapi | PvAPI, Prosilica GigE SDK
 | QT | QuickTime (obsolete, removed)
 | Unicap | Unicap drivers (obsolete, removed)
 | V4L | V4L/V4L2 capturing support
 | V4L2 | Same as CAP_V4L
Public field | value__ |
 | Vfw | Video For Windows (obsolete, removed)
 | Winrt | Microsoft Windows Runtime using Media Foundation
 | XiApi | XIMEA Camera API
 | Xine | XINE engine (Linux)
Top
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Android Field

VideoCaptureAPIAndroid Field

Android - not used

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Android = 1000
Public Const Android As VideoCaptureAPI = 1000
public:
literal VideoCaptureAPI^ Android = 1000
static val mutable Android: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Any Field

VideoCaptureAPIAny Field

Auto detect

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Any = 0
Public Const Any As VideoCaptureAPI = 0
public:
literal VideoCaptureAPI^ Any = 0
static val mutable Any: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Aravis Field

VideoCaptureAPIAravis Field

Aravis SDK

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Aravis = 2100
Public Const Aravis As VideoCaptureAPI = 2100
public:
literal VideoCaptureAPI^ Aravis = 2100
static val mutable Aravis: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.AVFoundation Field

VideoCaptureAPIAVFoundation Field

AVFoundation framework for iOS (OS X Lion will have the same API)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI AVFoundation = 1200
Public Const AVFoundation As VideoCaptureAPI = 1200
public:
literal VideoCaptureAPI^ AVFoundation = 1200
static val mutable AVFoundation: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.CMU1394 Field

VideoCaptureAPICMU1394 Field

IEEE 1394 drivers

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI CMU1394 = 300
Public Const CMU1394 As VideoCaptureAPI = 300
public:
literal VideoCaptureAPI^ CMU1394 = 300
static val mutable CMU1394: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.DC1394 Field

VideoCaptureAPIDC1394 Field

IEEE 1394 drivers

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI DC1394 = 300
Public Const DC1394 As VideoCaptureAPI = 300
public:
literal VideoCaptureAPI^ DC1394 = 300
static val mutable DC1394: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.DShow Field

VideoCaptureAPIDShow Field

DirectShow (via videoInput)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI DShow = 700
Public Const DShow As VideoCaptureAPI = 700
public:
literal VideoCaptureAPI^ DShow = 700
static val mutable DShow: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Ffmpeg Field

VideoCaptureAPIFfmpeg Field

Open and record video file or stream using the FFMPEG library

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Ffmpeg = 1900
Public Const Ffmpeg As VideoCaptureAPI = 1900
public:
literal VideoCaptureAPI^ Ffmpeg = 1900
static val mutable Ffmpeg: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Firewire Field

VideoCaptureAPIFirewire Field

IEEE 1394 drivers

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Firewire = 300
Public Const Firewire As VideoCaptureAPI = 300
public:
literal VideoCaptureAPI^ Firewire = 300
static val mutable Firewire: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Giganetix Field

VideoCaptureAPIGiganetix Field

Smartek Giganetix GigEVisionSDK

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Giganetix = 1300
Public Const Giganetix As VideoCaptureAPI = 1300
public:
literal VideoCaptureAPI^ Giganetix = 1300
static val mutable Giganetix: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Gphoto2 Field

VideoCaptureAPIGphoto2 Field

gPhoto2 connection

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Gphoto2 = 1700
Public Const Gphoto2 As VideoCaptureAPI = 1700
public:
literal VideoCaptureAPI^ Gphoto2 = 1700
static val mutable Gphoto2: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Gstreamer Field

VideoCaptureAPIGstreamer Field

GStreamer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Gstreamer = 1800
Public Const Gstreamer As VideoCaptureAPI = 1800
public:
literal VideoCaptureAPI^ Gstreamer = 1800
static val mutable Gstreamer: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.IEEE1394 Field

VideoCaptureAPIIEEE1394 Field

IEEE 1394 drivers

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI IEEE1394 = 300
Public Const IEEE1394 As VideoCaptureAPI = 300
public:
literal VideoCaptureAPI^ IEEE1394 = 300
static val mutable IEEE1394: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Images Field

VideoCaptureAPIImages Field

OpenCV Image Sequence (e.g. img_%02d.jpg)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Images = 2000
Public Const Images As VideoCaptureAPI = 2000
public:
literal VideoCaptureAPI^ Images = 2000
static val mutable Images: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.IntelMfx Field

VideoCaptureAPIIntelMfx Field

Intel MediaSDK

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI IntelMfx = 2300
Public Const IntelMfx As VideoCaptureAPI = 2300
public:
literal VideoCaptureAPI^ IntelMfx = 2300
static val mutable IntelMfx: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.IntelPerc Field

VideoCaptureAPIIntelPerc Field

Intel Perceptual Computing SDK

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI IntelPerc = 1500
Public Const IntelPerc As VideoCaptureAPI = 1500
public:
literal VideoCaptureAPI^ IntelPerc = 1500
static val mutable IntelPerc: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Msmf Field

VideoCaptureAPIMsmf Field

Microsoft Media Foundation (via videoInput)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Msmf = 1400
Public Const Msmf As VideoCaptureAPI = 1400
public:
literal VideoCaptureAPI^ Msmf = 1400
static val mutable Msmf: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.OpencvMjpeg Field

VideoCaptureAPIOpencvMjpeg Field

Built-in OpenCV MotionJPEG codec

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI OpencvMjpeg = 2200
Public Const OpencvMjpeg As VideoCaptureAPI = 2200
public:
literal VideoCaptureAPI^ OpencvMjpeg = 2200
static val mutable OpencvMjpeg: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.OpenNI Field

VideoCaptureAPIOpenNI Field

OpenNI (for Kinect)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI OpenNI = 900
Public Const OpenNI As VideoCaptureAPI = 900
public:
literal VideoCaptureAPI^ OpenNI = 900
static val mutable OpenNI: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Openni2 Field

VideoCaptureAPIOpenni2 Field

OpenNI2 (for Kinect)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Openni2 = 1600
Public Const Openni2 As VideoCaptureAPI = 1600
public:
literal VideoCaptureAPI^ Openni2 = 1600
static val mutable Openni2: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Openni2Asus Field

VideoCaptureAPIOpenni2Asus Field

OpenNI2 (for Asus Xtion and Occipital Structure sensors)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Openni2Asus = 1610
Public Const Openni2Asus As VideoCaptureAPI = 1610
public:
literal VideoCaptureAPI^ Openni2Asus = 1610
static val mutable Openni2Asus: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.OpenNIAsus Field

VideoCaptureAPIOpenNIAsus Field

OpenNI (for Asus Xtion)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI OpenNIAsus = 910
Public Const OpenNIAsus As VideoCaptureAPI = 910
public:
literal VideoCaptureAPI^ OpenNIAsus = 910
static val mutable OpenNIAsus: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Pvapi Field

VideoCaptureAPIPvapi Field

PvAPI, Prosilica GigE SDK

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Pvapi = 800
Public Const Pvapi As VideoCaptureAPI = 800
public:
literal VideoCaptureAPI^ Pvapi = 800
static val mutable Pvapi: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.QT Field

VideoCaptureAPIQT Field

QuickTime (obsolete, removed)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI QT = 500
Public Const QT As VideoCaptureAPI = 500
public:
literal VideoCaptureAPI^ QT = 500
static val mutable QT: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Unicap Field

VideoCaptureAPIUnicap Field

Unicap drivers (obsolete, removed)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Unicap = 600
Public Const Unicap As VideoCaptureAPI = 600
public:
literal VideoCaptureAPI^ Unicap = 600
static val mutable Unicap: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.V4L Field

VideoCaptureAPIV4L Field

V4L/V4L2 capturing support

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI V4L = 200
Public Const V4L As VideoCaptureAPI = 200
public:
literal VideoCaptureAPI^ V4L = 200
static val mutable V4L: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.V4L2 Field

VideoCaptureAPIV4L2 Field

Same as CAP_V4L

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI V4L2 = 200
Public Const V4L2 As VideoCaptureAPI = 200
public:
literal VideoCaptureAPI^ V4L2 = 200
static val mutable V4L2: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.value__ Field

VideoCaptureAPIvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.VideoCapture.API.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Vfw Field

VideoCaptureAPIVfw Field

Video For Windows (obsolete, removed)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Vfw = 200
Public Const Vfw As VideoCaptureAPI = 200
public:
literal VideoCaptureAPI^ Vfw = 200
static val mutable Vfw: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Winrt Field

VideoCaptureAPIWinrt Field

Microsoft Windows Runtime using Media Foundation

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Winrt = 1410
Public Const Winrt As VideoCaptureAPI = 1410
public:
literal VideoCaptureAPI^ Winrt = 1410
static val mutable Winrt: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.XiApi Field

VideoCaptureAPIXiApi Field

XIMEA Camera API

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI XiApi = 1100
Public Const XiApi As VideoCaptureAPI = 1100
public:
literal VideoCaptureAPI^ XiApi = 1100
static val mutable XiApi: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.API.Xine Field

VideoCaptureAPIXine Field

XINE engine (Linux)

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureAPI Xine = 2400
Public Const Xine As VideoCaptureAPI = 2400
public:
literal VideoCaptureAPI^ Xine = 2400
static val mutable Xine: VideoCaptureAPI

Field Value

Type: VideoCaptureAPI
See Also

Reference

VideoCaptureAPI Class
Emgu.CV Namespace


VideoCapture.CaptureModuleType Class

VideoCaptureCaptureModuleType Class

The type of capture source
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVVideoCaptureCaptureModuleType

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CaptureModuleType : Enum
Public NotInheritable Class CaptureModuleType
    Inherits Enum
public ref class CaptureModuleType sealed : public Enum
[<SealedAttribute>]
type CaptureModuleType =
    class
        inherit Enum
    end

The VideoCaptureCaptureModuleType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Camera | Capture from camera
 | Highgui | Capture from file using HighGUI
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


CaptureModuleType Methods

The VideoCaptureCaptureModuleType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

VideoCaptureCaptureModuleType Class
Emgu.CV Namespace


CaptureModuleType Fields

The VideoCaptureCaptureModuleType type exposes the following members.

Fields
 | Name | Description
 | Camera | Capture from camera
 | Highgui | Capture from file using HighGUI
Public field | value__ |
Top
See Also

Reference

VideoCaptureCaptureModuleType Class
Emgu.CV Namespace


VideoCapture.CaptureModuleType.Camera Field

VideoCaptureCaptureModuleTypeCamera Field

Capture from camera

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureCaptureModuleType Camera = 0
Public Const Camera As VideoCaptureCaptureModuleType = 0
public:
literal VideoCaptureCaptureModuleType^ Camera = 0
static val mutable Camera: VideoCaptureCaptureModuleType

Field Value

Type: VideoCaptureCaptureModuleType
See Also

Reference

VideoCaptureCaptureModuleType Class
Emgu.CV Namespace


VideoCapture.CaptureModuleType.Highgui Field

VideoCaptureCaptureModuleTypeHighgui Field

Capture from file using HighGUI

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoCaptureCaptureModuleType Highgui = 1
Public Const Highgui As VideoCaptureCaptureModuleType = 1
public:
literal VideoCaptureCaptureModuleType^ Highgui = 1
static val mutable Highgui: VideoCaptureCaptureModuleType

Field Value

Type: VideoCaptureCaptureModuleType
See Also

Reference

VideoCaptureCaptureModuleType Class
Emgu.CV Namespace


VideoCapture.CaptureModuleType.value__ Field

VideoCaptureCaptureModuleTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.VideoCapture.CaptureModuleType.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

VideoCaptureCaptureModuleType Class
Emgu.CV Namespace


VideoWriter Class

Create a video writer that write images to video format
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVVideoWriter

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class VideoWriter : UnmanagedObject
Public Class VideoWriter
    Inherits UnmanagedObject
public ref class VideoWriter : public UnmanagedObject
type VideoWriter =
    class
        inherit UnmanagedObject
    end

The VideoWriter type exposes the following members.

Constructors
 | Name | Description
Public method | VideoWriter(String, Int32, Size, Boolean) | Create a video writer using the specific information. On windows, it will open a codec selection dialog. On linux, it will use the default codec for the specified filename
Public method | VideoWriter(String, Int32, Double, Size, Boolean) | Create a video writer using the specific information
Public method | VideoWriter(String, Int32, Int32, Double, Size, Boolean) | Create a video writer using the specific information
Top
Properties
 | Name | Description
Public property | IsOpened | Returns true if video writer has been successfully initialized.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the video writer and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
 | Fourcc | Generate 4-character code of codec used to compress the frames. For example, CV_FOURCC('P','I','M','1') is MPEG-1 codec, CV_FOURCC('M','J','P','G') is motion-jpeg codec etc.
Public method | Get | Returns the specified VideoWriter property.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Set | Sets a property in the VideoWriter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Write a single frame to the video writer
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


VideoWriter Constructor

Overload List
 | Name | Description
Public method | VideoWriter(String, Int32, Size, Boolean) | Create a video writer using the specific information. On windows, it will open a codec selection dialog. On linux, it will use the default codec for the specified filename
Public method | VideoWriter(String, Int32, Double, Size, Boolean) | Create a video writer using the specific information
Public method | VideoWriter(String, Int32, Int32, Double, Size, Boolean) | Create a video writer using the specific information
Top
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter Constructor (String, Int32, Size, Boolean)

Create a video writer using the specific information. On windows, it will open a codec selection dialog. On linux, it will use the default codec for the specified filename

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VideoWriter(
    string fileName,
    int fps,
    Size size,
    bool isColor
)
Public Sub New (
    fileName As String,
    fps As Integer,
    size As Size,
    isColor As Boolean
)
public:
VideoWriter(
    String^ fileName,
    int fps,
    Size^ size,
    bool isColor
)
new :
        fileName : string *
        fps : int *
        size : Size *
        isColor : bool -> VideoWriter

Parameters

fileName
Type: SystemString
The name of the video file to be written to
fps
Type: SystemInt32
frame rate per second
size
Type: System.DrawingSize
the size of the frame
isColor
Type: SystemBoolean
true if this is a color video, false otherwise
See Also

Reference

VideoWriter Class
VideoWriter Overload
Emgu.CV Namespace


VideoWriter Constructor (String, Int32, Double, Size, Boolean)

Create a video writer using the specific information

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VideoWriter(
    string fileName,
    int compressionCode,
    double fps,
    Size size,
    bool isColor
)
Public Sub New (
    fileName As String,
    compressionCode As Integer,
    fps As Double,
    size As Size,
    isColor As Boolean
)
public:
VideoWriter(
    String^ fileName,
    int compressionCode,
    double fps,
    Size^ size,
    bool isColor
)
new :
        fileName : string *
        compressionCode : int *
        fps : float *
        size : Size *
        isColor : bool -> VideoWriter

Parameters

fileName
Type: SystemString
The name of the video file to be written to
compressionCode
Type: SystemInt32
Compression code. Usually computed using CvInvoke.CV_FOURCC. On windows use -1 to open a codec selection dialog. On Linux, use CvInvoke.CV_FOURCC('I', 'Y', 'U', 'V') for default codec for the specific file name.
fps
Type: SystemDouble
frame rate per second
size
Type: System.DrawingSize
the size of the frame
isColor
Type: SystemBoolean
true if this is a color video, false otherwise
See Also

Reference

VideoWriter Class
VideoWriter Overload
Emgu.CV Namespace


VideoWriter Constructor (String, Int32, Int32, Double, Size, Boolean)

Create a video writer using the specific information

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VideoWriter(
    string fileName,
    int apiPreference,
    int compressionCode,
    double fps,
    Size size,
    bool isColor
)
Public Sub New (
    fileName As String,
    apiPreference As Integer,
    compressionCode As Integer,
    fps As Double,
    size As Size,
    isColor As Boolean
)
public:
VideoWriter(
    String^ fileName,
    int apiPreference,
    int compressionCode,
    double fps,
    Size^ size,
    bool isColor
)
new :
        fileName : string *
        apiPreference : int *
        compressionCode : int *
        fps : float *
        size : Size *
        isColor : bool -> VideoWriter

Parameters

fileName
Type: SystemString
The name of the video file to be written to
apiPreference
Type: SystemInt32
Allows to specify API backends to use.
compressionCode
Type: SystemInt32
Compression code. Usually computed using CvInvoke.CV_FOURCC. On windows use -1 to open a codec selection dialog. On Linux, use CvInvoke.CV_FOURCC('I', 'Y', 'U', 'V') for default codec for the specific file name.
fps
Type: SystemDouble
frame rate per second
size
Type: System.DrawingSize
the size of the frame
isColor
Type: SystemBoolean
true if this is a color video, false otherwise
See Also

Reference

VideoWriter Class
VideoWriter Overload
Emgu.CV Namespace


VideoWriter Properties

The VideoWriter type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Returns true if video writer has been successfully initialized.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter.IsOpened Property

VideoWriterIsOpened Property

Returns true if video writer has been successfully initialized.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOpened { get; }
Public ReadOnly Property IsOpened As Boolean
    Get
public:
property bool IsOpened {
    bool get ();
}
member IsOpened : bool with get

Property Value

Type: Boolean
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter Methods

The VideoWriter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the video writer and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
 | Fourcc | Generate 4-character code of codec used to compress the frames. For example, CV_FOURCC('P','I','M','1') is MPEG-1 codec, CV_FOURCC('M','J','P','G') is motion-jpeg codec etc.
Public method | Get | Returns the specified VideoWriter property.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Set | Sets a property in the VideoWriter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Write a single frame to the video writer
Top
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter.DisposeObject Method

VideoWriterDisposeObject Method

Release the video writer and all the memory associate with it

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter.Fourcc Method

VideoWriterFourcc Method

Generate 4-character code of codec used to compress the frames. For example, CV_FOURCC('P','I','M','1') is MPEG-1 codec, CV_FOURCC('M','J','P','G') is motion-jpeg codec etc.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int Fourcc(
    char c1,
    char c2,
    char c3,
    char c4
)
Public Shared Function Fourcc (
    c1 As Char,
    c2 As Char,
    c3 As Char,
    c4 As Char
) As Integer
public:
static int Fourcc(
    wchar_t c1,
    wchar_t c2,
    wchar_t c3,
    wchar_t c4
)
static member Fourcc :
        c1 : char *
        c2 : char *
        c3 : char *
        c4 : char -> int

Parameters

c1
Type: SystemChar
C1
c2
Type: SystemChar
C2
c3
Type: SystemChar
C3
c4
Type: SystemChar
C4

Return Value

Type: Int32
The integer value calculated from the four cc code
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter.Get Method

VideoWriterGet Method

Returns the specified VideoWriter property.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Get(
    VideoWriterWriterProperty prop
)
Public Function Get (
    prop As VideoWriterWriterProperty
) As Double
public:
double Get(
    VideoWriterWriterProperty^ prop
)
member Get :
        prop : VideoWriterWriterProperty -> float

Parameters

prop
Type: Emgu.CVVideoWriterWriterProperty
Property identifier.

Return Value

Type: Double
The value of the specific property
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter.Set Method

VideoWriterSet Method

Sets a property in the VideoWriter.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    VideoWriterWriterProperty prop,
    double value
)
Public Function Set (
    prop As VideoWriterWriterProperty,
    value As Double
) As Boolean
public:
bool Set(
    VideoWriterWriterProperty^ prop,
    double value
)
member Set :
        prop : VideoWriterWriterProperty *
        value : float -> bool

Parameters

prop
Type: Emgu.CVVideoWriterWriterProperty
Property identifier
value
Type: SystemDouble
Value of the property.

Return Value

Type: Boolean
The value of the specific property
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter.Write Method

VideoWriterWrite Method

Write a single frame to the video writer

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    Mat frame
)
Public Sub Write (
    frame As Mat
)
public:
void Write(
    Mat^ frame
)
member Write :
        frame : Mat -> unit

Parameters

frame
Type: Emgu.CVMat
The frame to be written to the video writer
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter Fields

The VideoWriter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VideoWriter Class
Emgu.CV Namespace


VideoWriter.WriterProperty Class

VideoWriterWriterProperty Class

The VideoWriter property
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CVVideoWriterWriterProperty

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class WriterProperty : Enum
Public NotInheritable Class WriterProperty
    Inherits Enum
public ref class WriterProperty sealed : public Enum
[<SealedAttribute>]
type WriterProperty =
    class
        inherit Enum
    end

The VideoWriterWriterProperty type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Framebytes | (Read-only): Size of just encoded video frame. Note that the encoding order may be different from representation order.
 | NStripes | Number of stripes for parallel encoding. -1 for auto detection.
 | Quality | Current quality (0..100%) of the encoded videostream. Can be adjusted dynamically in some codecs.
Public field | value__ |
Top
See Also

Reference

Emgu.CV Namespace


WriterProperty Methods

The VideoWriterWriterProperty type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

VideoWriterWriterProperty Class
Emgu.CV Namespace


WriterProperty Fields

The VideoWriterWriterProperty type exposes the following members.

Fields
 | Name | Description
 | Framebytes | (Read-only): Size of just encoded video frame. Note that the encoding order may be different from representation order.
 | NStripes | Number of stripes for parallel encoding. -1 for auto detection.
 | Quality | Current quality (0..100%) of the encoded videostream. Can be adjusted dynamically in some codecs.
Public field | value__ |
Top
See Also

Reference

VideoWriterWriterProperty Class
Emgu.CV Namespace


VideoWriter.WriterProperty.Framebytes Field

VideoWriterWriterPropertyFramebytes Field

(Read-only): Size of just encoded video frame. Note that the encoding order may be different from representation order.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoWriterWriterProperty Framebytes = 2
Public Const Framebytes As VideoWriterWriterProperty = 2
public:
literal VideoWriterWriterProperty^ Framebytes = 2
static val mutable Framebytes: VideoWriterWriterProperty

Field Value

Type: VideoWriterWriterProperty
See Also

Reference

VideoWriterWriterProperty Class
Emgu.CV Namespace


VideoWriter.WriterProperty.NStripes Field

VideoWriterWriterPropertyNStripes Field

Number of stripes for parallel encoding. -1 for auto detection.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoWriterWriterProperty NStripes = 3
Public Const NStripes As VideoWriterWriterProperty = 3
public:
literal VideoWriterWriterProperty^ NStripes = 3
static val mutable NStripes: VideoWriterWriterProperty

Field Value

Type: VideoWriterWriterProperty
See Also

Reference

VideoWriterWriterProperty Class
Emgu.CV Namespace


VideoWriter.WriterProperty.Quality Field

VideoWriterWriterPropertyQuality Field

Current quality (0..100%) of the encoded videostream. Can be adjusted dynamically in some codecs.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VideoWriterWriterProperty Quality = 1
Public Const Quality As VideoWriterWriterProperty = 1
public:
literal VideoWriterWriterProperty^ Quality = 1
static val mutable Quality: VideoWriterWriterProperty

Field Value

Type: VideoWriterWriterProperty
See Also

Reference

VideoWriterWriterProperty Class
Emgu.CV Namespace


VideoWriter.WriterProperty.value__ Field

VideoWriterWriterPropertyvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.VideoWriter.WriterProperty.value__"]

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

VideoWriterWriterProperty Class
Emgu.CV Namespace


Viz3d Class

Represents a 3D visualizer window.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVViz3d

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Viz3d : UnmanagedObject
Public Class Viz3d
    Inherits UnmanagedObject
public ref class Viz3d : public UnmanagedObject
type Viz3d =
    class
        inherit UnmanagedObject
    end

The Viz3d type exposes the following members.

Constructors
 | Name | Description
Public method | Viz3d | Create a new 3D visualizer windows
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WasStopped | Returns whether the event loop has been stopped.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Viz3d object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveWidget | Removes a widget from the window.
Public method | SetBackgroundMeshLab | Set the background color
Public method | SetWidgetPose | Sets pose of a widget in the window.
Public method | ShowWidget | Show a widget in the window
Public method | Spin | The window renders and starts the event loop.
Public method | SpinOnce | Starts the event loop for a given time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


Viz3d Constructor

Create a new 3D visualizer windows

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Viz3d(
    string windowName
)
Public Sub New (
    windowName As String
)
public:
Viz3d(
    String^ windowName
)
new :
        windowName : string -> Viz3d

Parameters

windowName
Type: SystemString
The name of the windows
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d Properties

The Viz3d type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WasStopped | Returns whether the event loop has been stopped.
Top
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.WasStopped Property

Viz3dWasStopped Property

Returns whether the event loop has been stopped.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool WasStopped { get; }
Public ReadOnly Property WasStopped As Boolean
    Get
public:
property bool WasStopped {
    bool get ();
}
member WasStopped : bool with get

Property Value

Type: Boolean
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d Methods

The Viz3d type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Viz3d object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | RemoveWidget | Removes a widget from the window.
Public method | SetBackgroundMeshLab | Set the background color
Public method | SetWidgetPose | Sets pose of a widget in the window.
Public method | ShowWidget | Show a widget in the window
Public method | Spin | The window renders and starts the event loop.
Public method | SpinOnce | Starts the event loop for a given time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.DisposeObject Method

Viz3dDisposeObject Method

Release the unmanaged memory associated with this Viz3d object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.RemoveWidget Method

Viz3dRemoveWidget Method

Removes a widget from the window.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveWidget(
    string id
)
Public Sub RemoveWidget (
    id As String
)
public:
void RemoveWidget(
    String^ id
)
member RemoveWidget :
        id : string -> unit

Parameters

id
Type: SystemString
The id of the widget that will be removed.
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.SetBackgroundMeshLab Method

Viz3dSetBackgroundMeshLab Method

Set the background color

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetBackgroundMeshLab()
Public Sub SetBackgroundMeshLab
public:
void SetBackgroundMeshLab()
member SetBackgroundMeshLab : unit -> unit
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.SetWidgetPose Method

Viz3dSetWidgetPose Method

Sets pose of a widget in the window.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetWidgetPose(
    string id,
    Affine3d pose
)
Public Sub SetWidgetPose (
    id As String,
    pose As Affine3d
)
public:
void SetWidgetPose(
    String^ id,
    Affine3d^ pose
)
member SetWidgetPose :
        id : string *
        pose : Affine3d -> unit

Parameters

id
Type: SystemString
The id of the widget whose pose will be set.
pose
Type: Emgu.CVAffine3d
The new pose of the widget.
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.ShowWidget Method

Viz3dShowWidget Method

Show a widget in the window

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ShowWidget(
    string id,
    IWidget widget,
    Affine3d pose = null
)
Public Sub ShowWidget (
    id As String,
    widget As IWidget,
    Optional pose As Affine3d = Nothing
)
public:
void ShowWidget(
    String^ id,
    IWidget^ widget,
    Affine3d^ pose = nullptr
)
member ShowWidget :
        id : string *
        widget : IWidget *
        ?pose : Affine3d
(* Defaults:
        let _pose = defaultArg pose null
*)
-> unit

Parameters

id
Type: SystemString
A unique id for the widget.
widget
Type: Emgu.CVIWidget
The widget to be displayed in the window.
pose (Optional)
Type: Emgu.CVAffine3d
Pose of the widget.
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.Spin Method

Viz3dSpin Method

The window renders and starts the event loop.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Spin()
Public Sub Spin
public:
void Spin()
member Spin : unit -> unit
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d.SpinOnce Method

Viz3dSpinOnce Method

Starts the event loop for a given time.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SpinOnce(
    int time = 1,
    bool forceRedraw = false
)
Public Sub SpinOnce (
    Optional time As Integer = 1,
    Optional forceRedraw As Boolean = false
)
public:
void SpinOnce(
    int time = 1,
    bool forceRedraw = false
)
member SpinOnce :
        ?time : int *
        ?forceRedraw : bool
(* Defaults:
        let _time = defaultArg time 1
        let _forceRedraw = defaultArg forceRedraw false
*)
-> unit

Parameters

time (Optional)
Type: SystemInt32
Amount of time in milliseconds for the event loop to keep running.
forceRedraw (Optional)
Type: SystemBoolean
If true, window renders.
See Also

Reference

Viz3d Class
Emgu.CV Namespace


Viz3d Fields

The Viz3d type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Viz3d Class
Emgu.CV Namespace


VoronoiFacet Class

A Voronoi Facet
Inheritance Hierarchy
SystemObject
Emgu.CVVoronoiFacet

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class VoronoiFacet
Public Class VoronoiFacet
public ref class VoronoiFacet
type VoronoiFacet =  class end

The VoronoiFacet type exposes the following members.

Constructors
 | Name | Description
Public method | VoronoiFacet | Create a Voronoi facet using the specific point and polyline
Top
Properties
 | Name | Description
Public property | Point | The point this facet associates to
Public property | Vertices | Get or set the vertices of this facet
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.CV Namespace


VoronoiFacet Constructor

Create a Voronoi facet using the specific point and polyline

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VoronoiFacet(
    PointF point,
    PointF[] polyline
)
Public Sub New (
    point As PointF,
    polyline As PointF()
)
public:
VoronoiFacet(
    PointF^ point,
    array<PointF^>^ polyline
)
new :
        point : PointF *
        polyline : PointF[] -> VoronoiFacet

Parameters

point
Type: System.DrawingPointF
The point this facet associate with
polyline
Type: System.DrawingPointF
The points that defines the contour of this facet
See Also

Reference

VoronoiFacet Class
Emgu.CV Namespace


VoronoiFacet Properties

The VoronoiFacet type exposes the following members.

Properties
 | Name | Description
Public property | Point | The point this facet associates to
Public property | Vertices | Get or set the vertices of this facet
Top
See Also

Reference

VoronoiFacet Class
Emgu.CV Namespace


VoronoiFacet.Point Property

VoronoiFacetPoint Property

The point this facet associates to

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Point { get; set; }
Public Property Point As PointF
    Get
    Set
public:
property PointF^ Point {
    PointF^ get ();
    void set (PointF^ value);
}
member Point : PointF with get, set

Property Value

Type: PointF
See Also

Reference

VoronoiFacet Class
Emgu.CV Namespace


VoronoiFacet.Vertices Property

VoronoiFacetVertices Property

Get or set the vertices of this facet

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF[] Vertices { get; set; }
Public Property Vertices As PointF()
    Get
    Set
public:
property array<PointF^>^ Vertices {
    array<PointF^>^ get ();
    void set (array<PointF^>^ value);
}
member Vertices : PointF[] with get, set

Property Value

Type: PointF
See Also

Reference

VoronoiFacet Class
Emgu.CV Namespace


VoronoiFacet Methods

The VoronoiFacet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VoronoiFacet Class
Emgu.CV Namespace


WArrow Class

This 3D Widget defines an arrow.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWArrow

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WArrow : UnmanagedObject, IWidget3D,
    IWidget
Public Class WArrow
    Inherits UnmanagedObject
    Implements IWidget3D, IWidget
public ref class WArrow : public UnmanagedObject,
    IWidget3D, IWidget
type WArrow =
    class
        inherit UnmanagedObject
        interface IWidget3D
        interface IWidget
    end

The WArrow type exposes the following members.

Constructors
 | Name | Description
Public method | WArrow | Constructs an WArrow.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WArrow object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WArrow Constructor

Constructs an WArrow.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WArrow(
    MCvPoint3D64f pt1,
    MCvPoint3D64f pt2,
    double thickness,
    MCvScalar color
)
Public Sub New (
    pt1 As MCvPoint3D64f,
    pt2 As MCvPoint3D64f,
    thickness As Double,
    color As MCvScalar
)
public:
WArrow(
    MCvPoint3D64f^ pt1,
    MCvPoint3D64f^ pt2,
    double thickness,
    MCvScalar^ color
)
new :
        pt1 : MCvPoint3D64f *
        pt2 : MCvPoint3D64f *
        thickness : float *
        color : MCvScalar -> WArrow

Parameters

pt1
Type: Emgu.CV.StructureMCvPoint3D64f
Start point of the arrow.
pt2
Type: Emgu.CV.StructureMCvPoint3D64f
End point of the arrow.
thickness
Type: SystemDouble
Thickness of the arrow. Thickness of arrow head is also adjusted accordingly.
color
Type: Emgu.CV.StructureMCvScalar
Color of the arrow.
See Also

Reference

WArrow Class
Emgu.CV Namespace


WArrow Properties

The WArrow type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WArrow Class
Emgu.CV Namespace


WArrow.GetWidget Property

WArrowGetWidget Property

Get the pointer to the Widget obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WArrow Class
Emgu.CV Namespace


WArrow.GetWidget3D Property

WArrowGetWidget3D Property

Get the pointer to the Widget3D obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget3D { get; }
Public ReadOnly Property GetWidget3D As IntPtr
    Get
public:
virtual property IntPtr GetWidget3D {
    IntPtr get () sealed;
}
abstract GetWidget3D : IntPtr with get
override GetWidget3D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget3DGetWidget3D
See Also

Reference

WArrow Class
Emgu.CV Namespace


WArrow Methods

The WArrow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WArrow object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WArrow Class
Emgu.CV Namespace


WArrow.DisposeObject Method

WArrowDisposeObject Method

Release the unmanaged memory associated with this WArrow object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WArrow Class
Emgu.CV Namespace


WArrow Fields

The WArrow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WArrow Class
Emgu.CV Namespace


WCircle Class

This 3D Widget defines a circle.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWCircle

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WCircle : UnmanagedObject, IWidget3D,
    IWidget
Public Class WCircle
    Inherits UnmanagedObject
    Implements IWidget3D, IWidget
public ref class WCircle : public UnmanagedObject,
    IWidget3D, IWidget
type WCircle =
    class
        inherit UnmanagedObject
        interface IWidget3D
        interface IWidget
    end

The WCircle type exposes the following members.

Constructors
 | Name | Description
Public method | WCircle(Double, Double, MCvScalar) | Constructs default planar circle centred at origin with plane normal along z-axis.
Public method | WCircle(Double, MCvPoint3D64f, MCvPoint3D64f, Double, MCvScalar) | Constructs repositioned planar circle.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCircle object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WCircle Constructor

Overload List
 | Name | Description
Public method | WCircle(Double, Double, MCvScalar) | Constructs default planar circle centred at origin with plane normal along z-axis.
Public method | WCircle(Double, MCvPoint3D64f, MCvPoint3D64f, Double, MCvScalar) | Constructs repositioned planar circle.
Top
See Also

Reference

WCircle Class
Emgu.CV Namespace


WCircle Constructor (Double, Double, MCvScalar)

Constructs default planar circle centred at origin with plane normal along z-axis.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCircle(
    double radius,
    double thickness,
    MCvScalar color
)
Public Sub New (
    radius As Double,
    thickness As Double,
    color As MCvScalar
)
public:
WCircle(
    double radius,
    double thickness,
    MCvScalar^ color
)
new :
        radius : float *
        thickness : float *
        color : MCvScalar -> WCircle

Parameters

radius
Type: SystemDouble
Radius of the circle.
thickness
Type: SystemDouble
Thickness of the circle.
color
Type: Emgu.CV.StructureMCvScalar
Color of the circle.
See Also

Reference

WCircle Class
WCircle Overload
Emgu.CV Namespace


WCircle Constructor (Double, MCvPoint3D64f, MCvPoint3D64f, Double, MCvScalar)

Constructs repositioned planar circle.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCircle(
    double radius,
    MCvPoint3D64f center,
    MCvPoint3D64f normal,
    double thickness,
    MCvScalar color
)
Public Sub New (
    radius As Double,
    center As MCvPoint3D64f,
    normal As MCvPoint3D64f,
    thickness As Double,
    color As MCvScalar
)
public:
WCircle(
    double radius,
    MCvPoint3D64f^ center,
    MCvPoint3D64f^ normal,
    double thickness,
    MCvScalar^ color
)
new :
        radius : float *
        center : MCvPoint3D64f *
        normal : MCvPoint3D64f *
        thickness : float *
        color : MCvScalar -> WCircle

Parameters

radius
Type: SystemDouble
Radius of the circle.
center
Type: Emgu.CV.StructureMCvPoint3D64f
Center of the circle.
normal
Type: Emgu.CV.StructureMCvPoint3D64f
Normal of the plane in which the circle lies.
thickness
Type: SystemDouble
Thickness of the circle.
color
Type: Emgu.CV.StructureMCvScalar
Color of the circle.
See Also

Reference

WCircle Class
WCircle Overload
Emgu.CV Namespace


WCircle Properties

The WCircle type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCircle Class
Emgu.CV Namespace


WCircle.GetWidget Property

WCircleGetWidget Property

Get the pointer to the Widget obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WCircle Class
Emgu.CV Namespace


WCircle.GetWidget3D Property

WCircleGetWidget3D Property

Get the pointer to the Widget3D obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget3D { get; }
Public ReadOnly Property GetWidget3D As IntPtr
    Get
public:
virtual property IntPtr GetWidget3D {
    IntPtr get () sealed;
}
abstract GetWidget3D : IntPtr with get
override GetWidget3D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget3DGetWidget3D
See Also

Reference

WCircle Class
Emgu.CV Namespace


WCircle Methods

The WCircle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCircle object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WCircle Class
Emgu.CV Namespace


WCircle.DisposeObject Method

WCircleDisposeObject Method

Release the unmanaged memory associated with this WCircle object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WCircle Class
Emgu.CV Namespace


WCircle Fields

The WCircle type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCircle Class
Emgu.CV Namespace


WCloud Class

This 3D Widget defines a point cloud.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWCloud

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WCloud : UnmanagedObject, IWidget3D,
    IWidget
Public Class WCloud
    Inherits UnmanagedObject
    Implements IWidget3D, IWidget
public ref class WCloud : public UnmanagedObject,
    IWidget3D, IWidget
type WCloud =
    class
        inherit UnmanagedObject
        interface IWidget3D
        interface IWidget
    end

The WCloud type exposes the following members.

Constructors
 | Name | Description
Public method | WCloud(IInputArray, IInputArray) | Constructs a WCloud.
Public method | WCloud(IInputArray, MCvScalar) | Constructs a WCloud.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCloud (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WCloud Constructor

Overload List
 | Name | Description
Public method | WCloud(IInputArray, IInputArray) | Constructs a WCloud.
Public method | WCloud(IInputArray, MCvScalar) | Constructs a WCloud.
Top
See Also

Reference

WCloud Class
Emgu.CV Namespace


WCloud Constructor (IInputArray, IInputArray)

Constructs a WCloud.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCloud(
    IInputArray cloud,
    IInputArray color
)
Public Sub New (
    cloud As IInputArray,
    color As IInputArray
)
public:
WCloud(
    IInputArray^ cloud,
    IInputArray^ color
)
new :
        cloud : IInputArray *
        color : IInputArray -> WCloud

Parameters

cloud
Type: Emgu.CVIInputArray
Set of points which can be of type: CV_32FC3, CV_32FC4, CV_64FC3, CV_64FC4.
color
Type: Emgu.CVIInputArray
Set of colors. It has to be of the same size with cloud.
See Also

Reference

WCloud Class
WCloud Overload
Emgu.CV Namespace


WCloud Constructor (IInputArray, MCvScalar)

Constructs a WCloud.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCloud(
    IInputArray cloud,
    MCvScalar color
)
Public Sub New (
    cloud As IInputArray,
    color As MCvScalar
)
public:
WCloud(
    IInputArray^ cloud,
    MCvScalar^ color
)
new :
        cloud : IInputArray *
        color : MCvScalar -> WCloud

Parameters

cloud
Type: Emgu.CVIInputArray
Set of points which can be of type: CV_32FC3, CV_32FC4, CV_64FC3, CV_64FC4.
color
Type: Emgu.CV.StructureMCvScalar
A single Color for the whole cloud.
See Also

Reference

WCloud Class
WCloud Overload
Emgu.CV Namespace


WCloud Properties

The WCloud type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCloud Class
Emgu.CV Namespace


WCloud.GetWidget Property

WCloudGetWidget Property

Get the pointer to the Widget obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WCloud Class
Emgu.CV Namespace


WCloud.GetWidget3D Property

WCloudGetWidget3D Property

Get the pointer to the Widget3D obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget3D { get; }
Public ReadOnly Property GetWidget3D As IntPtr
    Get
public:
virtual property IntPtr GetWidget3D {
    IntPtr get () sealed;
}
abstract GetWidget3D : IntPtr with get
override GetWidget3D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget3DGetWidget3D
See Also

Reference

WCloud Class
Emgu.CV Namespace


WCloud Methods

The WCloud type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCloud (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WCloud Class
Emgu.CV Namespace


WCloud.DisposeObject Method

WCloudDisposeObject Method

Release the unmanaged memory associated with this WCloud

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WCloud Class
Emgu.CV Namespace


WCloud Fields

The WCloud type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCloud Class
Emgu.CV Namespace


WCone Class

This 3D Widget defines a cone.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWCone

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WCone : UnmanagedObject, IWidget3D,
    IWidget
Public Class WCone
    Inherits UnmanagedObject
    Implements IWidget3D, IWidget
public ref class WCone : public UnmanagedObject,
    IWidget3D, IWidget
type WCone =
    class
        inherit UnmanagedObject
        interface IWidget3D
        interface IWidget
    end

The WCone type exposes the following members.

Constructors
 | Name | Description
Public method | WCone(Double, Double, Int32, MCvScalar) | Constructs default cone oriented along x-axis with center of its base located at origin.
Public method | WCone(Double, MCvPoint3D64f, MCvPoint3D64f, Int32, MCvScalar) | Constructs repositioned planar cone.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCone object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WCone Constructor

Overload List
 | Name | Description
Public method | WCone(Double, Double, Int32, MCvScalar) | Constructs default cone oriented along x-axis with center of its base located at origin.
Public method | WCone(Double, MCvPoint3D64f, MCvPoint3D64f, Int32, MCvScalar) | Constructs repositioned planar cone.
Top
See Also

Reference

WCone Class
Emgu.CV Namespace


WCone Constructor (Double, Double, Int32, MCvScalar)

Constructs default cone oriented along x-axis with center of its base located at origin.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCone(
    double length,
    double radius,
    int resolution,
    MCvScalar color
)
Public Sub New (
    length As Double,
    radius As Double,
    resolution As Integer,
    color As MCvScalar
)
public:
WCone(
    double length,
    double radius,
    int resolution,
    MCvScalar^ color
)
new :
        length : float *
        radius : float *
        resolution : int *
        color : MCvScalar -> WCone

Parameters

length
Type: SystemDouble
Length of the cone.
radius
Type: SystemDouble
Radius of the cone.
resolution
Type: SystemInt32
Resolution of the cone.
color
Type: Emgu.CV.StructureMCvScalar
Color of the cone.
See Also

Reference

WCone Class
WCone Overload
Emgu.CV Namespace


WCone Constructor (Double, MCvPoint3D64f, MCvPoint3D64f, Int32, MCvScalar)

Constructs repositioned planar cone.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCone(
    double radius,
    MCvPoint3D64f center,
    MCvPoint3D64f tip,
    int resolution,
    MCvScalar color
)
Public Sub New (
    radius As Double,
    center As MCvPoint3D64f,
    tip As MCvPoint3D64f,
    resolution As Integer,
    color As MCvScalar
)
public:
WCone(
    double radius,
    MCvPoint3D64f^ center,
    MCvPoint3D64f^ tip,
    int resolution,
    MCvScalar^ color
)
new :
        radius : float *
        center : MCvPoint3D64f *
        tip : MCvPoint3D64f *
        resolution : int *
        color : MCvScalar -> WCone

Parameters

radius
Type: SystemDouble
Radius of the cone.
center
Type: Emgu.CV.StructureMCvPoint3D64f
Center of the cone base.
tip
Type: Emgu.CV.StructureMCvPoint3D64f
Tip of the cone.
resolution
Type: SystemInt32
Resolution of the cone.
color
Type: Emgu.CV.StructureMCvScalar
Color of the cone.
See Also

Reference

WCone Class
WCone Overload
Emgu.CV Namespace


WCone Properties

The WCone type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCone Class
Emgu.CV Namespace


WCone.GetWidget Property

WConeGetWidget Property

Get the pointer to the Widget obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WCone Class
Emgu.CV Namespace


WCone.GetWidget3D Property

WConeGetWidget3D Property

Get the pointer to the Widget3D obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget3D { get; }
Public ReadOnly Property GetWidget3D As IntPtr
    Get
public:
virtual property IntPtr GetWidget3D {
    IntPtr get () sealed;
}
abstract GetWidget3D : IntPtr with get
override GetWidget3D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget3DGetWidget3D
See Also

Reference

WCone Class
Emgu.CV Namespace


WCone Methods

The WCone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCone object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WCone Class
Emgu.CV Namespace


WCone.DisposeObject Method

WConeDisposeObject Method

Release the unmanaged memory associated with this WCone object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WCone Class
Emgu.CV Namespace


WCone Fields

The WCone type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCone Class
Emgu.CV Namespace


WCoordinateSystem Class

This 3D Widget represents a coordinate system.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWCoordinateSystem

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WCoordinateSystem : UnmanagedObject,
    IWidget3D, IWidget
Public Class WCoordinateSystem
    Inherits UnmanagedObject
    Implements IWidget3D, IWidget
public ref class WCoordinateSystem : public UnmanagedObject,
    IWidget3D, IWidget
type WCoordinateSystem =
    class
        inherit UnmanagedObject
        interface IWidget3D
        interface IWidget
    end

The WCoordinateSystem type exposes the following members.

Constructors
 | Name | Description
Public method | WCoordinateSystem | Constructs a WCoordinateSystem.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCoordinateSysyem object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WCoordinateSystem Constructor

Constructs a WCoordinateSystem.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCoordinateSystem(
    double scale = 1
)
Public Sub New (
    Optional scale As Double = 1
)
public:
WCoordinateSystem(
    double scale = 1
)
new :
        ?scale : float
(* Defaults:
        let _scale = defaultArg scale 1
*)
-> WCoordinateSystem

Parameters

scale (Optional)
Type: SystemDouble
Determines the size of the axes.
See Also

Reference

WCoordinateSystem Class
Emgu.CV Namespace


WCoordinateSystem Properties

The WCoordinateSystem type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCoordinateSystem Class
Emgu.CV Namespace


WCoordinateSystem.GetWidget Property

WCoordinateSystemGetWidget Property

Get the pointer to the Widget obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WCoordinateSystem Class
Emgu.CV Namespace


WCoordinateSystem.GetWidget3D Property

WCoordinateSystemGetWidget3D Property

Get the pointer to the Widget3D obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget3D { get; }
Public ReadOnly Property GetWidget3D As IntPtr
    Get
public:
virtual property IntPtr GetWidget3D {
    IntPtr get () sealed;
}
abstract GetWidget3D : IntPtr with get
override GetWidget3D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget3DGetWidget3D
See Also

Reference

WCoordinateSystem Class
Emgu.CV Namespace


WCoordinateSystem Methods

The WCoordinateSystem type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCoordinateSysyem object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WCoordinateSystem Class
Emgu.CV Namespace


WCoordinateSystem.DisposeObject Method

WCoordinateSystemDisposeObject Method

Release the unmanaged memory associated with this WCoordinateSysyem object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WCoordinateSystem Class
Emgu.CV Namespace


WCoordinateSystem Fields

The WCoordinateSystem type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCoordinateSystem Class
Emgu.CV Namespace


WCube Class

This 3D Widget defines a cube.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWCube

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WCube : UnmanagedObject, IWidget3D,
    IWidget
Public Class WCube
    Inherits UnmanagedObject
    Implements IWidget3D, IWidget
public ref class WCube : public UnmanagedObject,
    IWidget3D, IWidget
type WCube =
    class
        inherit UnmanagedObject
        interface IWidget3D
        interface IWidget
    end

The WCube type exposes the following members.

Constructors
 | Name | Description
Public method | WCube | Constructs a WCube.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCube object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WCube Constructor

Constructs a WCube.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCube(
    MCvPoint3D64f minPoint,
    MCvPoint3D64f maxPoint,
    bool wireFrame,
    MCvScalar color
)
Public Sub New (
    minPoint As MCvPoint3D64f,
    maxPoint As MCvPoint3D64f,
    wireFrame As Boolean,
    color As MCvScalar
)
public:
WCube(
    MCvPoint3D64f^ minPoint,
    MCvPoint3D64f^ maxPoint,
    bool wireFrame,
    MCvScalar^ color
)
new :
        minPoint : MCvPoint3D64f *
        maxPoint : MCvPoint3D64f *
        wireFrame : bool *
        color : MCvScalar -> WCube

Parameters

minPoint
Type: Emgu.CV.StructureMCvPoint3D64f
Specifies minimum point of the bounding box.
maxPoint
Type: Emgu.CV.StructureMCvPoint3D64f
Specifies maximum point of the bounding box.
wireFrame
Type: SystemBoolean
If true, cube is represented as wireframe.
color
Type: Emgu.CV.StructureMCvScalar
Color of the cube.
See Also

Reference

WCube Class
Emgu.CV Namespace


WCube Properties

The WCube type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCube Class
Emgu.CV Namespace


WCube.GetWidget Property

WCubeGetWidget Property

Get the pointer to the Widget obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WCube Class
Emgu.CV Namespace


WCube.GetWidget3D Property

WCubeGetWidget3D Property

Get the pointer to the Widget3D obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget3D { get; }
Public ReadOnly Property GetWidget3D As IntPtr
    Get
public:
virtual property IntPtr GetWidget3D {
    IntPtr get () sealed;
}
abstract GetWidget3D : IntPtr with get
override GetWidget3D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget3DGetWidget3D
See Also

Reference

WCube Class
Emgu.CV Namespace


WCube Methods

The WCube type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCube object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WCube Class
Emgu.CV Namespace


WCube.DisposeObject Method

WCubeDisposeObject Method

Release the unmanaged memory associated with this WCube object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WCube Class
Emgu.CV Namespace


WCube Fields

The WCube type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCube Class
Emgu.CV Namespace


WCylinder Class

This 3D Widget defines a cylinder.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWCylinder

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WCylinder : UnmanagedObject, IWidget3D,
    IWidget
Public Class WCylinder
    Inherits UnmanagedObject
    Implements IWidget3D, IWidget
public ref class WCylinder : public UnmanagedObject,
    IWidget3D, IWidget
type WCylinder =
    class
        inherit UnmanagedObject
        interface IWidget3D
        interface IWidget
    end

The WCylinder type exposes the following members.

Constructors
 | Name | Description
Public method | WCylinder | Constructs a WCylinder.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCylinder object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WCylinder Constructor

Constructs a WCylinder.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WCylinder(
    ref MCvPoint3D64f axisPoint1,
    MCvPoint3D64f axisPoint2,
    double radius,
    int numsides,
    MCvScalar color
)
Public Sub New (
    ByRef axisPoint1 As MCvPoint3D64f,
    axisPoint2 As MCvPoint3D64f,
    radius As Double,
    numsides As Integer,
    color As MCvScalar
)
public:
WCylinder(
    MCvPoint3D64f^% axisPoint1,
    MCvPoint3D64f^ axisPoint2,
    double radius,
    int numsides,
    MCvScalar^ color
)
new :
        axisPoint1 : MCvPoint3D64f byref *
        axisPoint2 : MCvPoint3D64f *
        radius : float *
        numsides : int *
        color : MCvScalar -> WCylinder

Parameters

axisPoint1
Type: Emgu.CV.StructureMCvPoint3D64f
A point1 on the axis of the cylinder.
axisPoint2
Type: Emgu.CV.StructureMCvPoint3D64f
A point2 on the axis of the cylinder.
radius
Type: SystemDouble
Radius of the cylinder.
numsides
Type: SystemInt32
Resolution of the cylinder.
color
Type: Emgu.CV.StructureMCvScalar
Color of the cylinder.
See Also

Reference

WCylinder Class
Emgu.CV Namespace


WCylinder Properties

The WCylinder type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the Widget obj
Public property | GetWidget3D | Get the pointer to the Widget3D obj
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCylinder Class
Emgu.CV Namespace


WCylinder.GetWidget Property

WCylinderGetWidget Property

Get the pointer to the Widget obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WCylinder Class
Emgu.CV Namespace


WCylinder.GetWidget3D Property

WCylinderGetWidget3D Property

Get the pointer to the Widget3D obj

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget3D { get; }
Public ReadOnly Property GetWidget3D As IntPtr
    Get
public:
virtual property IntPtr GetWidget3D {
    IntPtr get () sealed;
}
abstract GetWidget3D : IntPtr with get
override GetWidget3D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget3DGetWidget3D
See Also

Reference

WCylinder Class
Emgu.CV Namespace


WCylinder Methods

The WCylinder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this WCylinder object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WCylinder Class
Emgu.CV Namespace


WCylinder.DisposeObject Method

WCylinderDisposeObject Method

Release the unmanaged memory associated with this WCylinder object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WCylinder Class
Emgu.CV Namespace


WCylinder Fields

The WCylinder type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WCylinder Class
Emgu.CV Namespace


WText Class

This 2D Widget represents text overlay.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVWText

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WText : UnmanagedObject, IWidget2D,
    IWidget
Public Class WText
    Inherits UnmanagedObject
    Implements IWidget2D, IWidget
public ref class WText : public UnmanagedObject,
    IWidget2D, IWidget
type WText =
    class
        inherit UnmanagedObject
        interface IWidget2D
        interface IWidget
    end

The WText type exposes the following members.

Constructors
 | Name | Description
Public method | WText | Constructs a WText.
Top
Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object.
Public property | GetWidget2D | Get the pointer to the widget2D object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Viz3d object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV Namespace


WText Constructor

Constructs a WText.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WText(
    string text,
    Point pos,
    int fontSize,
    MCvScalar color
)
Public Sub New (
    text As String,
    pos As Point,
    fontSize As Integer,
    color As MCvScalar
)
public:
WText(
    String^ text,
    Point^ pos,
    int fontSize,
    MCvScalar^ color
)
new :
        text : string *
        pos : Point *
        fontSize : int *
        color : MCvScalar -> WText

Parameters

text
Type: SystemString
Text content of the widget.
pos
Type: System.DrawingPoint
Position of the text.
fontSize
Type: SystemInt32
Font size.
color
Type: Emgu.CV.StructureMCvScalar
Color of the text.
See Also

Reference

WText Class
Emgu.CV Namespace


WText Properties

The WText type exposes the following members.

Properties
 | Name | Description
Public property | GetWidget | Get the pointer to the widget object.
Public property | GetWidget2D | Get the pointer to the widget2D object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WText Class
Emgu.CV Namespace


WText.GetWidget Property

WTextGetWidget Property

Get the pointer to the widget object.

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget { get; }
Public ReadOnly Property GetWidget As IntPtr
    Get
public:
virtual property IntPtr GetWidget {
    IntPtr get () sealed;
}
abstract GetWidget : IntPtr with get
override GetWidget : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidgetGetWidget
See Also

Reference

WText Class
Emgu.CV Namespace


WText.GetWidget2D Property

WTextGetWidget2D Property

Get the pointer to the widget2D object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetWidget2D { get; }
Public ReadOnly Property GetWidget2D As IntPtr
    Get
public:
virtual property IntPtr GetWidget2D {
    IntPtr get () sealed;
}
abstract GetWidget2D : IntPtr with get
override GetWidget2D : IntPtr with get

Property Value

Type: IntPtr

Implements

IWidget2DGetWidget2D
See Also

Reference

WText Class
Emgu.CV Namespace


WText Methods

The WText type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Viz3d object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WText Class
Emgu.CV Namespace


WText.DisposeObject Method

WTextDisposeObject Method

Release the unmanaged memory associated with this Viz3d object

Namespace: Emgu.CV
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WText Class
Emgu.CV Namespace


WText Fields

The WText type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WText Class
Emgu.CV Namespace


Emgu.CV.Aruco Namespace

ArUco Marker Detection
Classes
 | Class | Description
Public class | ArucoInvoke | Entry points for the Aruco module.
Public class | CharucoBoard | A ChArUco board is a planar board where the markers are placed inside the white squares of a chessboard.The benefits of ChArUco boards is that they provide both, ArUco markers versatility and chessboard corner precision, which is important for calibration and pose estimation.
Public class | DetectorParameters | Parameters for the detectMarker process
Public class | DetectorParametersRefinementMethod | Type of corner refinement method
Public class | Dictionary | Dictionary/Set of markers. It contains the inner codification.
Public class | DictionaryPredefinedDictionaryName | The name of the predefined dictionary
Public class | GridBoard | Planar board with grid arrangement of markers More common type of board. All markers are placed in the same plane in a grid arrangment.
Interfaces
 | Interface | Description
Public interface | IBoard | Board of markers


ArucoInvoke Class

Entry points for the Aruco module.
Inheritance Hierarchy
SystemObject
Emgu.CV.ArucoArucoInvoke

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class ArucoInvoke
Public NotInheritable Class ArucoInvoke
public ref class ArucoInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ArucoInvoke =  class end

The ArucoInvoke type exposes the following members.

Methods
Name | Description
CalibrateCameraAruco(IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using aruco markers.
CalibrateCameraAruco(IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using aruco markers.
CalibrateCameraCharuco(IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using Charuco corners.
CalibrateCameraCharuco(IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using Charuco corners.
DetectCharucoDiamond | Detect ChArUco Diamond markers
DetectMarkers | Performs marker detection in the input image. Only markers included in the specific dictionary are searched. For each detected marker, it returns the 2D position of its corner in the image and its corresponding identifier. Note that this function does not perform pose estimation.
DrawAxis | Given the pose estimation of a marker or board, this function draws the axis of the world coordinate system, i.e. the system centered on the marker/board. Useful for debugging purposes.
DrawCharucoDiamond | Draw a ChArUco Diamond marker
DrawDetectedCornersCharuco | Draws a set of Charuco corners
DrawDetectedDiamonds | Draw a set of detected ChArUco Diamond markers
DrawDetectedMarkers | Draw detected markers in image.
DrawMarker | Draw a canonical marker image.
DrawPlanarBoard | Draw a planar board.
EstimatePoseBoard | Pose estimation for a board of markers.
EstimatePoseCharucoBoard | Pose estimation for a ChArUco board given some of their corners
EstimatePoseSingleMarkers | This function receives the detected markers and returns their pose estimation respect to the camera individually. So for each marker, one rotation and translation vector is returned. The returned transformation is the one that transforms points from each marker coordinate system to the camera coordinate system. The marker corrdinate system is centered on the middle of the marker, with the Z axis perpendicular to the marker plane. The coordinates of the four corners of the marker in its own coordinate system are: (-markerLength/2, markerLength/2, 0), (markerLength/2, markerLength/2, 0), (markerLength/2, -markerLength/2, 0), (-markerLength/2, -markerLength/2, 0)
GetBoardObjectAndImagePoints | Given a board configuration and a set of detected markers, returns the corresponding image points and object points to call solvePnP.
InterpolateCornersCharuco | Interpolate position of ChArUco board corners
RefineDetectedMarkers | Refine not detected markers based on the already detected and the board layout.
Top
See Also

Reference

Emgu.CV.Aruco Namespace


ArucoInvoke Methods

The ArucoInvoke type exposes the following members.

Methods
Name | Description
CalibrateCameraAruco(IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using aruco markers.
CalibrateCameraAruco(IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using aruco markers.
CalibrateCameraCharuco(IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using Charuco corners.
CalibrateCameraCharuco(IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using Charuco corners.
DetectCharucoDiamond | Detect ChArUco Diamond markers
DetectMarkers | Performs marker detection in the input image. Only markers included in the specific dictionary are searched. For each detected marker, it returns the 2D position of its corner in the image and its corresponding identifier. Note that this function does not perform pose estimation.
DrawAxis | Given the pose estimation of a marker or board, this function draws the axis of the world coordinate system, i.e. the system centered on the marker/board. Useful for debugging purposes.
DrawCharucoDiamond | Draw a ChArUco Diamond marker
DrawDetectedCornersCharuco | Draws a set of Charuco corners
DrawDetectedDiamonds | Draw a set of detected ChArUco Diamond markers
DrawDetectedMarkers | Draw detected markers in image.
DrawMarker | Draw a canonical marker image.
DrawPlanarBoard | Draw a planar board.
EstimatePoseBoard | Pose estimation for a board of markers.
EstimatePoseCharucoBoard | Pose estimation for a ChArUco board given some of their corners
EstimatePoseSingleMarkers | This function receives the detected markers and returns their pose estimation respect to the camera individually. So for each marker, one rotation and translation vector is returned. The returned transformation is the one that transforms points from each marker coordinate system to the camera coordinate system. The marker corrdinate system is centered on the middle of the marker, with the Z axis perpendicular to the marker plane. The coordinates of the four corners of the marker in its own coordinate system are: (-markerLength/2, markerLength/2, 0), (markerLength/2, markerLength/2, 0), (markerLength/2, -markerLength/2, 0), (-markerLength/2, -markerLength/2, 0)
GetBoardObjectAndImagePoints | Given a board configuration and a set of detected markers, returns the corresponding image points and object points to call solvePnP.
InterpolateCornersCharuco | Interpolate position of ChArUco board corners
RefineDetectedMarkers | Refine not detected markers based on the already detected and the board layout.
Top
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.CalibrateCameraAruco Method

ArucoInvokeCalibrateCameraAruco Method

Overload List
Name | Description
CalibrateCameraAruco(IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using aruco markers.
CalibrateCameraAruco(IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using aruco markers.
Top
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.CalibrateCameraAruco Method (IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

ArucoInvokeCalibrateCameraAruco Method (IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

http://www.emgu.com
Calibrate a camera using aruco markers.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CalibrateCameraAruco(
    IInputArrayOfArrays corners,
    IInputArray ids,
    IInputArray counter,
    IBoard board,
    Size imageSize,
    IInputOutputArray cameraMatrix,
    IInputOutputArray distCoeffs,
    IOutputArray rvecs,
    IOutputArray tvecs,
    CalibType flags,
    MCvTermCriteria criteria
)
Public Shared Function CalibrateCameraAruco (
    corners As IInputArrayOfArrays,
    ids As IInputArray,
    counter As IInputArray,
    board As IBoard,
    imageSize As Size,
    cameraMatrix As IInputOutputArray,
    distCoeffs As IInputOutputArray,
    rvecs As IOutputArray,
    tvecs As IOutputArray,
    flags As CalibType,
    criteria As MCvTermCriteria
) As Double
public:
static double CalibrateCameraAruco(
    IInputArrayOfArrays^ corners,
    IInputArray^ ids,
    IInputArray^ counter,
    IBoard^ board,
    Size^ imageSize,
    IInputOutputArray^ cameraMatrix,
    IInputOutputArray^ distCoeffs,
    IOutputArray^ rvecs,
    IOutputArray^ tvecs,
    CalibType^ flags,
    MCvTermCriteria^ criteria
)
static member CalibrateCameraAruco :
        corners : IInputArrayOfArrays *
        ids : IInputArray *
        counter : IInputArray *
        board : IBoard *
        imageSize : Size *
        cameraMatrix : IInputOutputArray *
        distCoeffs : IInputOutputArray *
        rvecs : IOutputArray *
        tvecs : IOutputArray *
        flags : CalibType *
        criteria : MCvTermCriteria -> float

Parameters

corners
Type: Emgu.CVIInputArrayOfArrays
Vector of detected marker corners in all frames. The corners should have the same format returned by detectMarkers
ids
Type: Emgu.CVIInputArray
List of identifiers for each marker in corners
counter
Type: Emgu.CVIInputArray
Number of markers in each frame so that corners and ids can be split
board
Type: Emgu.CV.ArucoIBoard
Marker Board layout
imageSize
Type: System.DrawingSize
Size of the image used only to initialize the intrinsic camera matrix.
cameraMatrix
Type: Emgu.CVIInputOutputArray
Output 3x3 floating-point camera matrix.
distCoeffs
Type: Emgu.CVIInputOutputArray
Output vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
rvecs
Type: Emgu.CVIOutputArray
Output vector of rotation vectors (see Rodrigues ) estimated for each board view (e.g. std::vector<cv::Mat>). That is, each k-th rotation vector together with the corresponding k-th translation vector (see the next output parameter description) brings the board pattern from the model coordinate space (in which object points are specified) to the world coordinate space, that is, a real position of the board pattern in the k-th pattern view (k=0.. M -1).
tvecs
Type: Emgu.CVIOutputArray
Output vector of translation vectors estimated for each pattern view.
flags
Type: Emgu.CV.CvEnumCalibType
Flags Different flags for the calibration process
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm.

Return Value

Type: Double
The final re-projection error.
See Also

Reference

ArucoInvoke Class
CalibrateCameraAruco Overload
Emgu.CV.Aruco Namespace


ArucoInvoke.CalibrateCameraAruco Method (IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

ArucoInvokeCalibrateCameraAruco Method (IInputArrayOfArrays, IInputArray, IInputArray, IBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

http://www.emgu.com
Calibrate a camera using aruco markers.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CalibrateCameraAruco(
    IInputArrayOfArrays corners,
    IInputArray ids,
    IInputArray counter,
    IBoard board,
    Size imageSize,
    IInputOutputArray cameraMatrix,
    IInputOutputArray distCoeffs,
    IOutputArray rvecs,
    IOutputArray tvecs,
    IOutputArray stdDeviationsIntrinsics,
    IOutputArray stdDeviationsExtrinsics,
    IOutputArray perViewErrors,
    CalibType flags,
    MCvTermCriteria criteria
)
Public Shared Function CalibrateCameraAruco (
    corners As IInputArrayOfArrays,
    ids As IInputArray,
    counter As IInputArray,
    board As IBoard,
    imageSize As Size,
    cameraMatrix As IInputOutputArray,
    distCoeffs As IInputOutputArray,
    rvecs As IOutputArray,
    tvecs As IOutputArray,
    stdDeviationsIntrinsics As IOutputArray,
    stdDeviationsExtrinsics As IOutputArray,
    perViewErrors As IOutputArray,
    flags As CalibType,
    criteria As MCvTermCriteria
) As Double
public:
static double CalibrateCameraAruco(
    IInputArrayOfArrays^ corners,
    IInputArray^ ids,
    IInputArray^ counter,
    IBoard^ board,
    Size^ imageSize,
    IInputOutputArray^ cameraMatrix,
    IInputOutputArray^ distCoeffs,
    IOutputArray^ rvecs,
    IOutputArray^ tvecs,
    IOutputArray^ stdDeviationsIntrinsics,
    IOutputArray^ stdDeviationsExtrinsics,
    IOutputArray^ perViewErrors,
    CalibType^ flags,
    MCvTermCriteria^ criteria
)
static member CalibrateCameraAruco :
        corners : IInputArrayOfArrays *
        ids : IInputArray *
        counter : IInputArray *
        board : IBoard *
        imageSize : Size *
        cameraMatrix : IInputOutputArray *
        distCoeffs : IInputOutputArray *
        rvecs : IOutputArray *
        tvecs : IOutputArray *
        stdDeviationsIntrinsics : IOutputArray *
        stdDeviationsExtrinsics : IOutputArray *
        perViewErrors : IOutputArray *
        flags : CalibType *
        criteria : MCvTermCriteria -> float

Parameters

corners
Type: Emgu.CVIInputArrayOfArrays
Vector of detected marker corners in all frames. The corners should have the same format returned by detectMarkers
ids
Type: Emgu.CVIInputArray
List of identifiers for each marker in corners
counter
Type: Emgu.CVIInputArray
Number of markers in each frame so that corners and ids can be split
board
Type: Emgu.CV.ArucoIBoard
Marker Board layout
imageSize
Type: System.DrawingSize
Size of the image used only to initialize the intrinsic camera matrix.
cameraMatrix
Type: Emgu.CVIInputOutputArray
Output 3x3 floating-point camera matrix.
distCoeffs
Type: Emgu.CVIInputOutputArray
Output vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
rvecs
Type: Emgu.CVIOutputArray
Output vector of rotation vectors (see Rodrigues ) estimated for each board view (e.g. std::vector<cv::Mat>). That is, each k-th rotation vector together with the corresponding k-th translation vector (see the next output parameter description) brings the board pattern from the model coordinate space (in which object points are specified) to the world coordinate space, that is, a real position of the board pattern in the k-th pattern view (k=0.. M -1).
tvecs
Type: Emgu.CVIOutputArray
Output vector of translation vectors estimated for each pattern view.
stdDeviationsIntrinsics
Type: Emgu.CVIOutputArray
Output vector of standard deviations estimated for intrinsic parameters. Order of deviations values: (fx,fy,cx,cy,k1,k2,p1,p2,k3,k4,k5,k6,s1,s2,s3,s4,τx,τy) If one of parameters is not estimated, it's deviation is equals to zero.
stdDeviationsExtrinsics
Type: Emgu.CVIOutputArray
Output vector of standard deviations estimated for extrinsic parameters. Order of deviations values: (R1,T1,…,RM,TM) where M is number of pattern views, Ri,Ti are concatenated 1x3 vectors.
perViewErrors
Type: Emgu.CVIOutputArray
Output vector of average re-projection errors estimated for each pattern view.
flags
Type: Emgu.CV.CvEnumCalibType
Flags Different flags for the calibration process
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm.

Return Value

Type: Double
The final re-projection error.
See Also

Reference

ArucoInvoke Class
CalibrateCameraAruco Overload
Emgu.CV.Aruco Namespace


ArucoInvoke.CalibrateCameraCharuco Method

ArucoInvokeCalibrateCameraCharuco Method

Overload List
Name | Description
CalibrateCameraCharuco(IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using Charuco corners.
CalibrateCameraCharuco(IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria) | Calibrate a camera using Charuco corners.
Top
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.CalibrateCameraCharuco Method (IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

ArucoInvokeCalibrateCameraCharuco Method (IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

http://www.emgu.com
Calibrate a camera using Charuco corners.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CalibrateCameraCharuco(
    IInputArrayOfArrays charucoCorners,
    IInputArrayOfArrays charucoIds,
    CharucoBoard board,
    Size imageSize,
    IInputOutputArray cameraMatrix,
    IInputOutputArray distCoeffs,
    IOutputArray rvecs,
    IOutputArray tvecs,
    CalibType flags,
    MCvTermCriteria criteria
)
Public Shared Function CalibrateCameraCharuco (
    charucoCorners As IInputArrayOfArrays,
    charucoIds As IInputArrayOfArrays,
    board As CharucoBoard,
    imageSize As Size,
    cameraMatrix As IInputOutputArray,
    distCoeffs As IInputOutputArray,
    rvecs As IOutputArray,
    tvecs As IOutputArray,
    flags As CalibType,
    criteria As MCvTermCriteria
) As Double
public:
static double CalibrateCameraCharuco(
    IInputArrayOfArrays^ charucoCorners,
    IInputArrayOfArrays^ charucoIds,
    CharucoBoard^ board,
    Size^ imageSize,
    IInputOutputArray^ cameraMatrix,
    IInputOutputArray^ distCoeffs,
    IOutputArray^ rvecs,
    IOutputArray^ tvecs,
    CalibType^ flags,
    MCvTermCriteria^ criteria
)
static member CalibrateCameraCharuco :
        charucoCorners : IInputArrayOfArrays *
        charucoIds : IInputArrayOfArrays *
        board : CharucoBoard *
        imageSize : Size *
        cameraMatrix : IInputOutputArray *
        distCoeffs : IInputOutputArray *
        rvecs : IOutputArray *
        tvecs : IOutputArray *
        flags : CalibType *
        criteria : MCvTermCriteria -> float

Parameters

charucoCorners
Type: Emgu.CVIInputArrayOfArrays
Vector of detected charuco corners per frame
charucoIds
Type: Emgu.CVIInputArrayOfArrays
List of identifiers for each corner in charucoCorners per frame
board
Type: Emgu.CV.ArucoCharucoBoard
Marker Board layout
imageSize
Type: System.DrawingSize
Size of the image used only to initialize the intrinsic camera matrix.
cameraMatrix
Type: Emgu.CVIInputOutputArray
Output 3x3 floating-point camera matrix.
distCoeffs
Type: Emgu.CVIInputOutputArray
Output vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
rvecs
Type: Emgu.CVIOutputArray
Output vector of rotation vectors (see Rodrigues ) estimated for each board view (e.g. std::vector<cv::Mat>). That is, each k-th rotation vector together with the corresponding k-th translation vector (see the next output parameter description) brings the board pattern from the model coordinate space (in which object points are specified) to the world coordinate space, that is, a real position of the board pattern in the k-th pattern view (k=0.. M -1).
tvecs
Type: Emgu.CVIOutputArray
Output vector of translation vectors estimated for each pattern view.
flags
Type: Emgu.CV.CvEnumCalibType
Flags Different flags for the calibration process
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm.

Return Value

Type: Double
The final re-projection error.
See Also

Reference

ArucoInvoke Class
CalibrateCameraCharuco Overload
Emgu.CV.Aruco Namespace


ArucoInvoke.CalibrateCameraCharuco Method (IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

ArucoInvokeCalibrateCameraCharuco Method (IInputArrayOfArrays, IInputArrayOfArrays, CharucoBoard, Size, IInputOutputArray, IInputOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, IOutputArray, CalibType, MCvTermCriteria)

http://www.emgu.com
Calibrate a camera using Charuco corners.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double CalibrateCameraCharuco(
    IInputArrayOfArrays charucoCorners,
    IInputArrayOfArrays charucoIds,
    CharucoBoard board,
    Size imageSize,
    IInputOutputArray cameraMatrix,
    IInputOutputArray distCoeffs,
    IOutputArray rvecs,
    IOutputArray tvecs,
    IOutputArray stdDeviationsIntrinsics,
    IOutputArray stdDeviationsExtrinsics,
    IOutputArray perViewErrors,
    CalibType flags,
    MCvTermCriteria criteria
)
Public Shared Function CalibrateCameraCharuco (
    charucoCorners As IInputArrayOfArrays,
    charucoIds As IInputArrayOfArrays,
    board As CharucoBoard,
    imageSize As Size,
    cameraMatrix As IInputOutputArray,
    distCoeffs As IInputOutputArray,
    rvecs As IOutputArray,
    tvecs As IOutputArray,
    stdDeviationsIntrinsics As IOutputArray,
    stdDeviationsExtrinsics As IOutputArray,
    perViewErrors As IOutputArray,
    flags As CalibType,
    criteria As MCvTermCriteria
) As Double
public:
static double CalibrateCameraCharuco(
    IInputArrayOfArrays^ charucoCorners,
    IInputArrayOfArrays^ charucoIds,
    CharucoBoard^ board,
    Size^ imageSize,
    IInputOutputArray^ cameraMatrix,
    IInputOutputArray^ distCoeffs,
    IOutputArray^ rvecs,
    IOutputArray^ tvecs,
    IOutputArray^ stdDeviationsIntrinsics,
    IOutputArray^ stdDeviationsExtrinsics,
    IOutputArray^ perViewErrors,
    CalibType^ flags,
    MCvTermCriteria^ criteria
)
static member CalibrateCameraCharuco :
        charucoCorners : IInputArrayOfArrays *
        charucoIds : IInputArrayOfArrays *
        board : CharucoBoard *
        imageSize : Size *
        cameraMatrix : IInputOutputArray *
        distCoeffs : IInputOutputArray *
        rvecs : IOutputArray *
        tvecs : IOutputArray *
        stdDeviationsIntrinsics : IOutputArray *
        stdDeviationsExtrinsics : IOutputArray *
        perViewErrors : IOutputArray *
        flags : CalibType *
        criteria : MCvTermCriteria -> float

Parameters

charucoCorners
Type: Emgu.CVIInputArrayOfArrays
Vector of detected charuco corners per frame
charucoIds
Type: Emgu.CVIInputArrayOfArrays
List of identifiers for each corner in charucoCorners per frame
board
Type: Emgu.CV.ArucoCharucoBoard
Marker Board layout
imageSize
Type: System.DrawingSize
Size of the image used only to initialize the intrinsic camera matrix.
cameraMatrix
Type: Emgu.CVIInputOutputArray
Output 3x3 floating-point camera matrix.
distCoeffs
Type: Emgu.CVIInputOutputArray
Output vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
rvecs
Type: Emgu.CVIOutputArray
Output vector of rotation vectors (see Rodrigues ) estimated for each board view (e.g. std::vector<cv::Mat>). That is, each k-th rotation vector together with the corresponding k-th translation vector (see the next output parameter description) brings the board pattern from the model coordinate space (in which object points are specified) to the world coordinate space, that is, a real position of the board pattern in the k-th pattern view (k=0.. M -1).
tvecs
Type: Emgu.CVIOutputArray
Output vector of translation vectors estimated for each pattern view.
stdDeviationsIntrinsics
Type: Emgu.CVIOutputArray
Output vector of standard deviations estimated for intrinsic parameters. Order of deviations values: (fx,fy,cx,cy,k1,k2,p1,p2,k3,k4,k5,k6,s1,s2,s3,s4,τx,τy) If one of parameters is not estimated, it's deviation is equals to zero.
stdDeviationsExtrinsics
Type: Emgu.CVIOutputArray
Output vector of standard deviations estimated for extrinsic parameters. Order of deviations values: (R1,T1,…,RM,TM) where M is number of pattern views, Ri,Ti are concatenated 1x3 vectors.
perViewErrors
Type: Emgu.CVIOutputArray
Output vector of average re-projection errors estimated for each pattern view.
flags
Type: Emgu.CV.CvEnumCalibType
Flags Different flags for the calibration process
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria for the iterative optimization algorithm.

Return Value

Type: Double
The final re-projection error.
See Also

Reference

ArucoInvoke Class
CalibrateCameraCharuco Overload
Emgu.CV.Aruco Namespace


ArucoInvoke.DetectCharucoDiamond Method

ArucoInvokeDetectCharucoDiamond Method

Detect ChArUco Diamond markers

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DetectCharucoDiamond(
    IInputArray image,
    IInputArray markerCorners,
    IInputArray markerIds,
    float squareMarkerLengthRate,
    IOutputArray diamondCorners,
    IOutputArray diamondIds,
    IInputArray cameraMatrix = null,
    IInputArray distCoeffs = null
)
Public Shared Sub DetectCharucoDiamond (
    image As IInputArray,
    markerCorners As IInputArray,
    markerIds As IInputArray,
    squareMarkerLengthRate As Single,
    diamondCorners As IOutputArray,
    diamondIds As IOutputArray,
    Optional cameraMatrix As IInputArray = Nothing,
    Optional distCoeffs As IInputArray = Nothing
)
public:
static void DetectCharucoDiamond(
    IInputArray^ image,
    IInputArray^ markerCorners,
    IInputArray^ markerIds,
    float squareMarkerLengthRate,
    IOutputArray^ diamondCorners,
    IOutputArray^ diamondIds,
    IInputArray^ cameraMatrix = nullptr,
    IInputArray^ distCoeffs = nullptr
)
static member DetectCharucoDiamond :
        image : IInputArray *
        markerCorners : IInputArray *
        markerIds : IInputArray *
        squareMarkerLengthRate : float32 *
        diamondCorners : IOutputArray *
        diamondIds : IOutputArray *
        ?cameraMatrix : IInputArray *
        ?distCoeffs : IInputArray
(* Defaults:
        let _cameraMatrix = defaultArg cameraMatrix null
        let _distCoeffs = defaultArg distCoeffs null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
input image necessary for corner subpixel.
markerCorners
Type: Emgu.CVIInputArray
list of detected marker corners from detectMarkers function.
markerIds
Type: Emgu.CVIInputArray
list of marker ids in markerCorners.
squareMarkerLengthRate
Type: SystemSingle
rate between square and marker length: squareMarkerLengthRate = squareLength / markerLength.The real units are not necessary.
diamondCorners
Type: Emgu.CVIOutputArray
output list of detected diamond corners (4 corners per diamond). The order is the same than in marker corners: top left, top right, bottom right and bottom left. Similar format than the corners returned by detectMarkers(e.g VectorOfVectorOfPointF ).
diamondIds
Type: Emgu.CVIOutputArray
ids of the diamonds in diamondCorners. The id of each diamond is in fact of type Vec4i, so each diamond has 4 ids, which are the ids of the aruco markers composing the diamond.
cameraMatrix (Optional)
Type: Emgu.CVIInputArray
Optional camera calibration matrix.
distCoeffs (Optional)
Type: Emgu.CVIInputArray
Optional camera distortion coefficients.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DetectMarkers Method

ArucoInvokeDetectMarkers Method

Performs marker detection in the input image. Only markers included in the specific dictionary are searched. For each detected marker, it returns the 2D position of its corner in the image and its corresponding identifier. Note that this function does not perform pose estimation.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DetectMarkers(
    IInputArray image,
    Dictionary dict,
    IOutputArrayOfArrays corners,
    IOutputArray ids,
    DetectorParameters parameters,
    IOutputArrayOfArrays rejectedImgPoints = null
)
Public Shared Sub DetectMarkers (
    image As IInputArray,
    dict As Dictionary,
    corners As IOutputArrayOfArrays,
    ids As IOutputArray,
    parameters As DetectorParameters,
    Optional rejectedImgPoints As IOutputArrayOfArrays = Nothing
)
public:
static void DetectMarkers(
    IInputArray^ image,
    Dictionary^ dict,
    IOutputArrayOfArrays^ corners,
    IOutputArray^ ids,
    DetectorParameters^ parameters,
    IOutputArrayOfArrays^ rejectedImgPoints = nullptr
)
static member DetectMarkers :
        image : IInputArray *
        dict : Dictionary *
        corners : IOutputArrayOfArrays *
        ids : IOutputArray *
        parameters : DetectorParameters *
        ?rejectedImgPoints : IOutputArrayOfArrays
(* Defaults:
        let _rejectedImgPoints = defaultArg rejectedImgPoints null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
input image
dict
Type: Emgu.CV.ArucoDictionary
indicates the type of markers that will be searched
corners
Type: Emgu.CVIOutputArrayOfArrays
Vector of detected marker corners. For each marker, its four corners are provided, (e.g VectorOfVectorOfPointF ). For N detected markers, the dimensions of this array is Nx4. The order of the corners is clockwise.
ids
Type: Emgu.CVIOutputArray
vector of identifiers of the detected markers. The identifier is of type int (e.g. VectorOfInt). For N detected markers, the size of ids is also N. The identifiers have the same order than the markers in the imgPoints array.
parameters
Type: Emgu.CV.ArucoDetectorParameters
marker detection parameters
rejectedImgPoints (Optional)
Type: Emgu.CVIOutputArrayOfArrays
contains the imgPoints of those squares whose inner code has not a correct codification. Useful for debugging purposes.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DrawAxis Method

ArucoInvokeDrawAxis Method

Given the pose estimation of a marker or board, this function draws the axis of the world coordinate system, i.e. the system centered on the marker/board. Useful for debugging purposes.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawAxis(
    IInputOutputArray image,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IInputArray rvec,
    IInputArray tvec,
    float length
)
Public Shared Sub DrawAxis (
    image As IInputOutputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvec As IInputArray,
    tvec As IInputArray,
    length As Single
)
public:
static void DrawAxis(
    IInputOutputArray^ image,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IInputArray^ rvec,
    IInputArray^ tvec,
    float length
)
static member DrawAxis :
        image : IInputOutputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvec : IInputArray *
        tvec : IInputArray *
        length : float32 -> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
input/output image. It must have 1 or 3 channels. The number of channels is not altered.
cameraMatrix
Type: Emgu.CVIInputArray
input 3x3 floating-point camera matrix
distCoeffs
Type: Emgu.CVIInputArray
vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
rvec
Type: Emgu.CVIInputArray
rotation vector of the coordinate system that will be drawn.
tvec
Type: Emgu.CVIInputArray
translation vector of the coordinate system that will be drawn.
length
Type: SystemSingle
length of the painted axis in the same unit than tvec (usually in meters)
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DrawCharucoDiamond Method

ArucoInvokeDrawCharucoDiamond Method

Draw a ChArUco Diamond marker

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawCharucoDiamond(
    Dictionary dictionary,
    int[] ids,
    int squareLength,
    int markerLength,
    IOutputArray img,
    int marginSize = 0,
    int borderBits = 1
)
Public Shared Sub DrawCharucoDiamond (
    dictionary As Dictionary,
    ids As Integer(),
    squareLength As Integer,
    markerLength As Integer,
    img As IOutputArray,
    Optional marginSize As Integer = 0,
    Optional borderBits As Integer = 1
)
public:
static void DrawCharucoDiamond(
    Dictionary^ dictionary,
    array<int>^ ids,
    int squareLength,
    int markerLength,
    IOutputArray^ img,
    int marginSize = 0,
    int borderBits = 1
)
static member DrawCharucoDiamond :
        dictionary : Dictionary *
        ids : int[] *
        squareLength : int *
        markerLength : int *
        img : IOutputArray *
        ?marginSize : int *
        ?borderBits : int
(* Defaults:
        let _marginSize = defaultArg marginSize 0
        let _borderBits = defaultArg borderBits 1
*)
-> unit

Parameters

dictionary
Type: Emgu.CV.ArucoDictionary
dictionary of markers indicating the type of markers.
ids
Type: SystemInt32
list of 4 ids for each ArUco marker in the ChArUco marker.
squareLength
Type: SystemInt32
size of the chessboard squares in pixels.
markerLength
Type: SystemInt32
size of the markers in pixels.
img
Type: Emgu.CVIOutputArray
output image with the marker. The size of this image will be 3*squareLength + 2*marginSize.
marginSize (Optional)
Type: SystemInt32
minimum margins (in pixels) of the marker in the output image
borderBits (Optional)
Type: SystemInt32
width of the marker borders.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DrawDetectedCornersCharuco Method

ArucoInvokeDrawDetectedCornersCharuco Method

Draws a set of Charuco corners

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawDetectedCornersCharuco(
    IInputOutputArray image,
    IInputArray charucoCorners,
    IInputArray charucoIds,
    MCvScalar cornerColor
)
Public Shared Sub DrawDetectedCornersCharuco (
    image As IInputOutputArray,
    charucoCorners As IInputArray,
    charucoIds As IInputArray,
    cornerColor As MCvScalar
)
public:
static void DrawDetectedCornersCharuco(
    IInputOutputArray^ image,
    IInputArray^ charucoCorners,
    IInputArray^ charucoIds,
    MCvScalar^ cornerColor
)
static member DrawDetectedCornersCharuco :
        image : IInputOutputArray *
        charucoCorners : IInputArray *
        charucoIds : IInputArray *
        cornerColor : MCvScalar -> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
image input/output image. It must have 1 or 3 channels. The number of channels is not altered.
charucoCorners
Type: Emgu.CVIInputArray
vector of detected charuco corners
charucoIds
Type: Emgu.CVIInputArray
list of identifiers for each corner in charucoCorners
cornerColor
Type: Emgu.CV.StructureMCvScalar
color of the square surrounding each corner
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DrawDetectedDiamonds Method

ArucoInvokeDrawDetectedDiamonds Method

Draw a set of detected ChArUco Diamond markers

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawDetectedDiamonds(
    IInputOutputArray image,
    IInputArrayOfArrays diamondCorners,
    IInputArray diamondIds,
    MCvScalar borderColor
)
Public Shared Sub DrawDetectedDiamonds (
    image As IInputOutputArray,
    diamondCorners As IInputArrayOfArrays,
    diamondIds As IInputArray,
    borderColor As MCvScalar
)
public:
static void DrawDetectedDiamonds(
    IInputOutputArray^ image,
    IInputArrayOfArrays^ diamondCorners,
    IInputArray^ diamondIds,
    MCvScalar^ borderColor
)
static member DrawDetectedDiamonds :
        image : IInputOutputArray *
        diamondCorners : IInputArrayOfArrays *
        diamondIds : IInputArray *
        borderColor : MCvScalar -> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
input/output image. It must have 1 or 3 channels. The number of channels is not altered.
diamondCorners
Type: Emgu.CVIInputArrayOfArrays
positions of diamond corners in the same format returned by detectCharucoDiamond(). (e.g VectorOfVectorOfPointF ). For N detected markers, the dimensions of this array should be Nx4. The order of the corners should be clockwise.
diamondIds
Type: Emgu.CVIInputArray
vector of identifiers for diamonds in diamondCorners, in the same format returned by detectCharucoDiamond() (e.g. VectorOfMat ). Optional, if not provided, ids are not painted.
borderColor
Type: Emgu.CV.StructureMCvScalar
color of marker borders. Rest of colors (text color and first corner color) are calculated based on this one.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DrawDetectedMarkers Method

ArucoInvokeDrawDetectedMarkers Method

Draw detected markers in image.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawDetectedMarkers(
    IInputOutputArray image,
    IInputArray corners,
    IInputArray ids,
    MCvScalar borderColor
)
Public Shared Sub DrawDetectedMarkers (
    image As IInputOutputArray,
    corners As IInputArray,
    ids As IInputArray,
    borderColor As MCvScalar
)
public:
static void DrawDetectedMarkers(
    IInputOutputArray^ image,
    IInputArray^ corners,
    IInputArray^ ids,
    MCvScalar^ borderColor
)
static member DrawDetectedMarkers :
        image : IInputOutputArray *
        corners : IInputArray *
        ids : IInputArray *
        borderColor : MCvScalar -> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
Input/output image. It must have 1 or 3 channels. The number of channels is not altered.
corners
Type: Emgu.CVIInputArray
Positions of marker corners on input image. (e.g std::vector<std::vector<cv::Point2f> > ). For N detected markers, the dimensions of this array should be Nx4. The order of the corners should be clockwise.
ids
Type: Emgu.CVIInputArray
Vector of identifiers for markers in markersCorners . Optional, if not provided, ids are not painted.
borderColor
Type: Emgu.CV.StructureMCvScalar
Color of marker borders. Rest of colors (text color and first corner color) are calculated based on this one to improve visualization.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DrawMarker Method

ArucoInvokeDrawMarker Method

Draw a canonical marker image.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawMarker(
    Dictionary dict,
    int id,
    int sidePixels,
    IOutputArray img,
    int borderBits = 1
)
Public Shared Sub DrawMarker (
    dict As Dictionary,
    id As Integer,
    sidePixels As Integer,
    img As IOutputArray,
    Optional borderBits As Integer = 1
)
public:
static void DrawMarker(
    Dictionary^ dict,
    int id,
    int sidePixels,
    IOutputArray^ img,
    int borderBits = 1
)
static member DrawMarker :
        dict : Dictionary *
        id : int *
        sidePixels : int *
        img : IOutputArray *
        ?borderBits : int
(* Defaults:
        let _borderBits = defaultArg borderBits 1
*)
-> unit

Parameters

dict
Type: Emgu.CV.ArucoDictionary
dictionary of markers indicating the type of markers
id
Type: SystemInt32
identifier of the marker that will be returned. It has to be a valid id in the specified dictionary.
sidePixels
Type: SystemInt32
size of the image in pixels
img
Type: Emgu.CVIOutputArray
output image with the marker
borderBits (Optional)
Type: SystemInt32
width of the marker border.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.DrawPlanarBoard Method

ArucoInvokeDrawPlanarBoard Method

Draw a planar board.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawPlanarBoard(
    IBoard board,
    Size outSize,
    IOutputArray img,
    int marginSize = 0,
    int borderBits = 1
)
Public Shared Sub DrawPlanarBoard (
    board As IBoard,
    outSize As Size,
    img As IOutputArray,
    Optional marginSize As Integer = 0,
    Optional borderBits As Integer = 1
)
public:
static void DrawPlanarBoard(
    IBoard^ board,
    Size^ outSize,
    IOutputArray^ img,
    int marginSize = 0,
    int borderBits = 1
)
static member DrawPlanarBoard :
        board : IBoard *
        outSize : Size *
        img : IOutputArray *
        ?marginSize : int *
        ?borderBits : int
(* Defaults:
        let _marginSize = defaultArg marginSize 0
        let _borderBits = defaultArg borderBits 1
*)
-> unit

Parameters

board
Type: Emgu.CV.ArucoIBoard
Layout of the board that will be drawn. The board should be planar, z coordinate is ignored
outSize
Type: System.DrawingSize
Size of the output image in pixels.
img
Type: Emgu.CVIOutputArray
Output image with the board. The size of this image will be outSize and the board will be on the center, keeping the board proportions.
marginSize (Optional)
Type: SystemInt32
Minimum margins (in pixels) of the board in the output image
borderBits (Optional)
Type: SystemInt32
Width of the marker borders.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.EstimatePoseBoard Method

ArucoInvokeEstimatePoseBoard Method

Pose estimation for a board of markers.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int EstimatePoseBoard(
    IInputArrayOfArrays corners,
    IInputArray ids,
    IBoard board,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IInputOutputArray rvec,
    IInputOutputArray tvec,
    bool useExtrinsicGuess = false
)
Public Shared Function EstimatePoseBoard (
    corners As IInputArrayOfArrays,
    ids As IInputArray,
    board As IBoard,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvec As IInputOutputArray,
    tvec As IInputOutputArray,
    Optional useExtrinsicGuess As Boolean = false
) As Integer
public:
static int EstimatePoseBoard(
    IInputArrayOfArrays^ corners,
    IInputArray^ ids,
    IBoard^ board,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IInputOutputArray^ rvec,
    IInputOutputArray^ tvec,
    bool useExtrinsicGuess = false
)
static member EstimatePoseBoard :
        corners : IInputArrayOfArrays *
        ids : IInputArray *
        board : IBoard *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvec : IInputOutputArray *
        tvec : IInputOutputArray *
        ?useExtrinsicGuess : bool
(* Defaults:
        let _useExtrinsicGuess = defaultArg useExtrinsicGuess false
*)
-> int

Parameters

corners
Type: Emgu.CVIInputArrayOfArrays
Vector of already detected markers corners. For each marker, its four corners are provided, (e.g std::vector>std::vector>cv::Point2f< < ). For N detected markers, the dimensions of this array should be Nx4. The order of the corners should be clockwise.
ids
Type: Emgu.CVIInputArray
List of identifiers for each marker in corners
board
Type: Emgu.CV.ArucoIBoard
Layout of markers in the board. The layout is composed by the marker identifiers and the positions of each marker corner in the board reference system.
cameraMatrix
Type: Emgu.CVIInputArray
Input 3x3 floating-point camera matrix
distCoeffs
Type: Emgu.CVIInputArray
Vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
rvec
Type: Emgu.CVIInputOutputArray
Output vector (e.g. cv::Mat) corresponding to the rotation vector of the board (see cv::Rodrigues). Used as initial guess if not empty.
tvec
Type: Emgu.CVIInputOutputArray
Output vector (e.g. cv::Mat) corresponding to the translation vector of the board.
useExtrinsicGuess (Optional)
Type: SystemBoolean
Defines whether initial guess for rvec and tvec will be used or not. Used as initial guess if not empty.

Return Value

Type: Int32
The function returns the number of markers from the input employed for the board pose estimation. Note that returning a 0 means the pose has not been estimated.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.EstimatePoseCharucoBoard Method

ArucoInvokeEstimatePoseCharucoBoard Method

Pose estimation for a ChArUco board given some of their corners

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool EstimatePoseCharucoBoard(
    IInputArray charucoCorners,
    IInputArray charucoIds,
    CharucoBoard board,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IInputOutputArray rvec,
    IInputOutputArray tvec,
    bool useExtrinsicGuess = false
)
Public Shared Function EstimatePoseCharucoBoard (
    charucoCorners As IInputArray,
    charucoIds As IInputArray,
    board As CharucoBoard,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvec As IInputOutputArray,
    tvec As IInputOutputArray,
    Optional useExtrinsicGuess As Boolean = false
) As Boolean
public:
static bool EstimatePoseCharucoBoard(
    IInputArray^ charucoCorners,
    IInputArray^ charucoIds,
    CharucoBoard^ board,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IInputOutputArray^ rvec,
    IInputOutputArray^ tvec,
    bool useExtrinsicGuess = false
)
static member EstimatePoseCharucoBoard :
        charucoCorners : IInputArray *
        charucoIds : IInputArray *
        board : CharucoBoard *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvec : IInputOutputArray *
        tvec : IInputOutputArray *
        ?useExtrinsicGuess : bool
(* Defaults:
        let _useExtrinsicGuess = defaultArg useExtrinsicGuess false
*)
-> bool

Parameters

charucoCorners
Type: Emgu.CVIInputArray
vector of detected charuco corners
charucoIds
Type: Emgu.CVIInputArray
list of identifiers for each corner in charucoCorners
board
Type: Emgu.CV.ArucoCharucoBoard
layout of ChArUco board.
cameraMatrix
Type: Emgu.CVIInputArray
input 3x3 floating-point camera matrix
distCoeffs
Type: Emgu.CVIInputArray
vector of distortion coefficients, 4, 5, 8 or 12 elements
rvec
Type: Emgu.CVIInputOutputArray
Output vector (e.g. cv::Mat) corresponding to the rotation vector of the board
tvec
Type: Emgu.CVIInputOutputArray
Output vector (e.g. cv::Mat) corresponding to the translation vector of the board.
useExtrinsicGuess (Optional)
Type: SystemBoolean
defines whether initial guess for rvec and tvec will be used or not.

Return Value

Type: Boolean
If pose estimation is valid, returns true, else returns false.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.EstimatePoseSingleMarkers Method

ArucoInvokeEstimatePoseSingleMarkers Method

This function receives the detected markers and returns their pose estimation respect to the camera individually. So for each marker, one rotation and translation vector is returned. The returned transformation is the one that transforms points from each marker coordinate system to the camera coordinate system. The marker corrdinate system is centered on the middle of the marker, with the Z axis perpendicular to the marker plane. The coordinates of the four corners of the marker in its own coordinate system are: (-markerLength/2, markerLength/2, 0), (markerLength/2, markerLength/2, 0), (markerLength/2, -markerLength/2, 0), (-markerLength/2, -markerLength/2, 0)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void EstimatePoseSingleMarkers(
    IInputArrayOfArrays corners,
    float markerLength,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    IOutputArrayOfArrays rvecs,
    IOutputArrayOfArrays tvecs
)
Public Shared Sub EstimatePoseSingleMarkers (
    corners As IInputArrayOfArrays,
    markerLength As Single,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    rvecs As IOutputArrayOfArrays,
    tvecs As IOutputArrayOfArrays
)
public:
static void EstimatePoseSingleMarkers(
    IInputArrayOfArrays^ corners,
    float markerLength,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    IOutputArrayOfArrays^ rvecs,
    IOutputArrayOfArrays^ tvecs
)
static member EstimatePoseSingleMarkers :
        corners : IInputArrayOfArrays *
        markerLength : float32 *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        rvecs : IOutputArrayOfArrays *
        tvecs : IOutputArrayOfArrays -> unit

Parameters

corners
Type: Emgu.CVIInputArrayOfArrays
vector of already detected markers corners. For each marker, its four corners are provided, (e.g VectorOfVectorOfPointF ). For N detected markers, the dimensions of this array should be Nx4. The order of the corners should be clockwise.
markerLength
Type: SystemSingle
the length of the markers' side. The returning translation vectors will be in the same unit. Normally, unit is meters.
cameraMatrix
Type: Emgu.CVIInputArray
input 3x3 floating-point camera matrix
distCoeffs
Type: Emgu.CVIInputArray
vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
rvecs
Type: Emgu.CVIOutputArrayOfArrays
array of output rotation vectors. Each element in rvecs corresponds to the specific marker in imgPoints.
tvecs
Type: Emgu.CVIOutputArrayOfArrays
array of output translation vectors (e.g. VectorOfPoint3D32F ). Each element in tvecs corresponds to the specific marker in imgPoints.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.GetBoardObjectAndImagePoints Method

ArucoInvokeGetBoardObjectAndImagePoints Method

Given a board configuration and a set of detected markers, returns the corresponding image points and object points to call solvePnP.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GetBoardObjectAndImagePoints(
    IBoard board,
    IInputArray detectedCorners,
    IInputArray detectedIds,
    IOutputArray objPoints,
    IOutputArray imgPoints
)
Public Shared Sub GetBoardObjectAndImagePoints (
    board As IBoard,
    detectedCorners As IInputArray,
    detectedIds As IInputArray,
    objPoints As IOutputArray,
    imgPoints As IOutputArray
)
public:
static void GetBoardObjectAndImagePoints(
    IBoard^ board,
    IInputArray^ detectedCorners,
    IInputArray^ detectedIds,
    IOutputArray^ objPoints,
    IOutputArray^ imgPoints
)
static member GetBoardObjectAndImagePoints :
        board : IBoard *
        detectedCorners : IInputArray *
        detectedIds : IInputArray *
        objPoints : IOutputArray *
        imgPoints : IOutputArray -> unit

Parameters

board
Type: Emgu.CV.ArucoIBoard
Marker board layout.
detectedCorners
Type: Emgu.CVIInputArray
List of detected marker corners of the board.
detectedIds
Type: Emgu.CVIInputArray
List of identifiers for each marker.
objPoints
Type: Emgu.CVIOutputArray
Vector of vectors of board marker points in the board coordinate space.
imgPoints
Type: Emgu.CVIOutputArray
Vector of vectors of the projections of board marker corner points.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.InterpolateCornersCharuco Method

ArucoInvokeInterpolateCornersCharuco Method

Interpolate position of ChArUco board corners

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int InterpolateCornersCharuco(
    IInputArrayOfArrays markerCorners,
    IInputArray markerIds,
    IInputArray image,
    CharucoBoard board,
    IOutputArray charucoCorners,
    IOutputArray charucoIds,
    IInputArray cameraMatrix = null,
    IInputArray distCoeffs = null,
    int minMarkers = 2
)
Public Shared Function InterpolateCornersCharuco (
    markerCorners As IInputArrayOfArrays,
    markerIds As IInputArray,
    image As IInputArray,
    board As CharucoBoard,
    charucoCorners As IOutputArray,
    charucoIds As IOutputArray,
    Optional cameraMatrix As IInputArray = Nothing,
    Optional distCoeffs As IInputArray = Nothing,
    Optional minMarkers As Integer = 2
) As Integer
public:
static int InterpolateCornersCharuco(
    IInputArrayOfArrays^ markerCorners,
    IInputArray^ markerIds,
    IInputArray^ image,
    CharucoBoard^ board,
    IOutputArray^ charucoCorners,
    IOutputArray^ charucoIds,
    IInputArray^ cameraMatrix = nullptr,
    IInputArray^ distCoeffs = nullptr,
    int minMarkers = 2
)
static member InterpolateCornersCharuco :
        markerCorners : IInputArrayOfArrays *
        markerIds : IInputArray *
        image : IInputArray *
        board : CharucoBoard *
        charucoCorners : IOutputArray *
        charucoIds : IOutputArray *
        ?cameraMatrix : IInputArray *
        ?distCoeffs : IInputArray *
        ?minMarkers : int
(* Defaults:
        let _cameraMatrix = defaultArg cameraMatrix null
        let _distCoeffs = defaultArg distCoeffs null
        let _minMarkers = defaultArg minMarkers 2
*)
-> int

Parameters

markerCorners
Type: Emgu.CVIInputArrayOfArrays
vector of already detected markers corners. For each marker, its four corners are provided, (e.g VectorOfVectorOfPointF ). For N detected markers, the dimensions of this array should be Nx4.The order of the corners should be clockwise.
markerIds
Type: Emgu.CVIInputArray
list of identifiers for each marker in corners
image
Type: Emgu.CVIInputArray
input image necesary for corner refinement. Note that markers are not detected and should be sent in corners and ids parameters.
board
Type: Emgu.CV.ArucoCharucoBoard
layout of ChArUco board.
charucoCorners
Type: Emgu.CVIOutputArray
interpolated chessboard corners
charucoIds
Type: Emgu.CVIOutputArray
interpolated chessboard corners identifiers
cameraMatrix (Optional)
Type: Emgu.CVIInputArray
optional 3x3 floating-point camera matrix
distCoeffs (Optional)
Type: Emgu.CVIInputArray
optional vector of distortion coefficients, (k_1, k_2, p_1, p_2[, k_3[, k_4, k_5, k_6],[s_1, s_2, s_3, s_4]]) of 4, 5, 8 or 12 elements
minMarkers (Optional)
Type: SystemInt32
number of adjacent markers that must be detected to return a charuco corner

Return Value

Type: Int32
The number of interpolated corners.
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


ArucoInvoke.RefineDetectedMarkers Method

ArucoInvokeRefineDetectedMarkers Method

Refine not detected markers based on the already detected and the board layout.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void RefineDetectedMarkers(
    IInputArray image,
    IBoard board,
    IInputOutputArray detectedCorners,
    IInputOutputArray detectedIds,
    IInputOutputArray rejectedCorners,
    IInputArray cameraMatrix,
    IInputArray distCoeffs,
    float minRepDistance,
    float errorCorrectionRate,
    bool checkAllOrders,
    IOutputArray recoveredIdxs,
    DetectorParameters parameters
)
Public Shared Sub RefineDetectedMarkers (
    image As IInputArray,
    board As IBoard,
    detectedCorners As IInputOutputArray,
    detectedIds As IInputOutputArray,
    rejectedCorners As IInputOutputArray,
    cameraMatrix As IInputArray,
    distCoeffs As IInputArray,
    minRepDistance As Single,
    errorCorrectionRate As Single,
    checkAllOrders As Boolean,
    recoveredIdxs As IOutputArray,
    parameters As DetectorParameters
)
public:
static void RefineDetectedMarkers(
    IInputArray^ image,
    IBoard^ board,
    IInputOutputArray^ detectedCorners,
    IInputOutputArray^ detectedIds,
    IInputOutputArray^ rejectedCorners,
    IInputArray^ cameraMatrix,
    IInputArray^ distCoeffs,
    float minRepDistance,
    float errorCorrectionRate,
    bool checkAllOrders,
    IOutputArray^ recoveredIdxs,
    DetectorParameters^ parameters
)
static member RefineDetectedMarkers :
        image : IInputArray *
        board : IBoard *
        detectedCorners : IInputOutputArray *
        detectedIds : IInputOutputArray *
        rejectedCorners : IInputOutputArray *
        cameraMatrix : IInputArray *
        distCoeffs : IInputArray *
        minRepDistance : float32 *
        errorCorrectionRate : float32 *
        checkAllOrders : bool *
        recoveredIdxs : IOutputArray *
        parameters : DetectorParameters -> unit

Parameters

image
Type: Emgu.CVIInputArray
Input image
board
Type: Emgu.CV.ArucoIBoard
Layout of markers in the board.
detectedCorners
Type: Emgu.CVIInputOutputArray
Vector of already detected marker corners.
detectedIds
Type: Emgu.CVIInputOutputArray
Vector of already detected marker identifiers.
rejectedCorners
Type: Emgu.CVIInputOutputArray
Vector of rejected candidates during the marker detection process
cameraMatrix
Type: Emgu.CVIInputArray
Optional input 3x3 floating-point camera matrix
distCoeffs
Type: Emgu.CVIInputArray
Optional vector of distortion coefficients (k1,k2,p1,p2[,k3[,k4,k5,k6],[s1,s2,s3,s4]]) of 4, 5, 8 or 12 elements
minRepDistance
Type: SystemSingle
Minimum distance between the corners of the rejected candidate and the reprojected marker in order to consider it as a correspondence. (default 10)
errorCorrectionRate
Type: SystemSingle
Rate of allowed erroneous bits respect to the error correction capability of the used dictionary. -1 ignores the error correction step. (default 3)
checkAllOrders
Type: SystemBoolean
Consider the four posible corner orders in the rejectedCorners array. If it set to false, only the provided corner order is considered (default true).
recoveredIdxs
Type: Emgu.CVIOutputArray
Optional array to returns the indexes of the recovered candidates in the original rejectedCorners array.
parameters
Type: Emgu.CV.ArucoDetectorParameters
marker detection parameters
See Also

Reference

ArucoInvoke Class
Emgu.CV.Aruco Namespace


CharucoBoard Class

A ChArUco board is a planar board where the markers are placed inside the white squares of a chessboard.The benefits of ChArUco boards is that they provide both, ArUco markers versatility and chessboard corner precision, which is important for calibration and pose estimation.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ArucoCharucoBoard

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CharucoBoard : UnmanagedObject,
    IBoard
Public Class CharucoBoard
    Inherits UnmanagedObject
    Implements IBoard
public ref class CharucoBoard : public UnmanagedObject,
    IBoard
type CharucoBoard =
    class
        inherit UnmanagedObject
        interface IBoard
    end

The CharucoBoard type exposes the following members.

Constructors
 | Name | Description
Public method | CharucoBoard | ChArUco board
Top
Properties
 | Name | Description
Public property | BoardPtr | Pointer to native IBoard
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with this ChArUco board (Overrides DisposableObjectDisposeObject.)
Public method | Draw | Draw a ChArUco board
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Aruco Namespace


CharucoBoard Constructor

ChArUco board

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CharucoBoard(
    int squaresX,
    int squaresY,
    float squareLength,
    float markerLength,
    Dictionary dictionary
)
Public Sub New (
    squaresX As Integer,
    squaresY As Integer,
    squareLength As Single,
    markerLength As Single,
    dictionary As Dictionary
)
public:
CharucoBoard(
    int squaresX,
    int squaresY,
    float squareLength,
    float markerLength,
    Dictionary^ dictionary
)
new :
        squaresX : int *
        squaresY : int *
        squareLength : float32 *
        markerLength : float32 *
        dictionary : Dictionary -> CharucoBoard

Parameters

squaresX
Type: SystemInt32
number of chessboard squares in X direction
squaresY
Type: SystemInt32
number of chessboard squares in Y direction
squareLength
Type: SystemSingle
chessboard square side length (normally in meters)
markerLength
Type: SystemSingle
marker side length (same unit than squareLength)
dictionary
Type: Emgu.CV.ArucoDictionary
dictionary of markers indicating the type of markers.
See Also

Reference

CharucoBoard Class
Emgu.CV.Aruco Namespace


CharucoBoard Properties

The CharucoBoard type exposes the following members.

Properties
 | Name | Description
Public property | BoardPtr | Pointer to native IBoard
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CharucoBoard Class
Emgu.CV.Aruco Namespace


CharucoBoard.BoardPtr Property

CharucoBoardBoardPtr Property

Pointer to native IBoard

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BoardPtr { get; }
Public ReadOnly Property BoardPtr As IntPtr
    Get
public:
virtual property IntPtr BoardPtr {
    IntPtr get () sealed;
}
abstract BoardPtr : IntPtr with get
override BoardPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBoardBoardPtr
See Also

Reference

CharucoBoard Class
Emgu.CV.Aruco Namespace


CharucoBoard Methods

The CharucoBoard type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with this ChArUco board (Overrides DisposableObjectDisposeObject.)
Public method | Draw | Draw a ChArUco board
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CharucoBoard Class
Emgu.CV.Aruco Namespace


CharucoBoard.DisposeObject Method

CharucoBoardDisposeObject Method

Release the unmanaged resource associated with this ChArUco board

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CharucoBoard Class
Emgu.CV.Aruco Namespace


CharucoBoard.Draw Method

CharucoBoardDraw Method

Draw a ChArUco board

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    Size outSize,
    IOutputArray img,
    int margindSize = 0,
    int borderBits = 1
)
Public Sub Draw (
    outSize As Size,
    img As IOutputArray,
    Optional margindSize As Integer = 0,
    Optional borderBits As Integer = 1
)
public:
void Draw(
    Size^ outSize,
    IOutputArray^ img,
    int margindSize = 0,
    int borderBits = 1
)
member Draw :
        outSize : Size *
        img : IOutputArray *
        ?margindSize : int *
        ?borderBits : int
(* Defaults:
        let _margindSize = defaultArg margindSize 0
        let _borderBits = defaultArg borderBits 1
*)
-> unit

Parameters

outSize
Type: System.DrawingSize
size of the output image in pixels.
img
Type: Emgu.CVIOutputArray
output image with the board. The size of this image will be outSize and the board will be on the center, keeping the board proportions.
margindSize (Optional)
Type: SystemInt32
minimum margins (in pixels) of the board in the output image
borderBits (Optional)
Type: SystemInt32
width of the marker borders.
See Also

Reference

CharucoBoard Class
Emgu.CV.Aruco Namespace


CharucoBoard Fields

The CharucoBoard type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CharucoBoard Class
Emgu.CV.Aruco Namespace


DetectorParameters Class

Parameters for the detectMarker process
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.ArucoDetectorParameters

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DetectorParameters : ValueType
Public NotInheritable Class DetectorParameters
    Inherits ValueType
public ref class DetectorParameters sealed : public ValueType
[<SealedAttribute>]
type DetectorParameters =
    class
        inherit ValueType
    end

The DetectorParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefault | Get the detector parameters with default values
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | AdaptiveThreshConstant | constant for adaptive thresholding before finding contours (default 7)
Public field | AdaptiveThreshWinSizeMax | maximum window size for adaptive thresholding before finding contours (default 23).
Public field | AdaptiveThreshWinSizeMin | minimum window size for adaptive thresholding before finding contours (default 3)
Public field | AdaptiveThreshWinSizeStep | increments from adaptiveThreshWinSizeMin to adaptiveThreshWinSizeMax during the thresholding (default 10).
Public field | AprilTagCriticalRad | Reject quads where pairs of edges have angles that are close to straight or close to 180 degrees.Zero means that no quads are rejected. (In radians).
Public field | AprilTagDeglitch | should the thresholded image be deglitched? Only useful for very noisy images
Public field | AprilTagMaxLineFitMse | When fitting lines to the contours, what is the maximum mean squared error allowed? This is useful in rejecting contours that are far from being quad shaped; rejecting these quads "early" saves expensive decoding processing.
Public field | AprilTagMaxNmaxima | how many corner candidates to consider when segmenting a group of pixels into a quad.
Public field | AprilTagMinClusterPixels | reject quads containing too few pixels.
Public field | AprilTagMinWhiteBlackDiff | When we build our model of black & white pixels, we add an extra check that the white model must be(overall) brighter than the black model.How much brighter? (in pixel values, [0, 255]).
Public field | AprilTagQuadDecimate | Detection of quads can be done on a lower-resolution image, improving speed at a cost of pose accuracy and a slight decrease in detection rate.Decoding the binary payload is still done at full resolution.
Public field | AprilTagQuadSigma | What Gaussian blur should be applied to the segmented image (used for quad detection?) Parameter is the standard deviation in pixels.Very noisy images benefit from non-zero values(e.g. 0.8).
Public field | CornerRefinementMaxIterations | maximum number of iterations for stop criteria of the corner refinement process (default 30).
Public field | CornerRefinementMethod | Corner refinement method
Public field | CornerRefinementMinAccuracy | minimum error for the stop criteria of the corner refinement process (default: 0.1)
Public field | CornerRefinementWinSize | window size for the corner refinement process (in pixels) (default 5).
Public field | ErrorCorrectionRate | error correction rate respect to the maximun error correction capability for each dictionary. (default 0.6).
Public field | MarkerBorderBits | number of bits of the marker border, i.e. marker border width (default 1).
Public field | MaxErroneousBitsInBorderRate | maximum number of accepted erroneous bits in the border (i.e. number of allowed white bits in the border). Represented as a rate respect to the total number of bits per marker (default 0.35).
Public field | MaxMarkerPerimeterRate | determine maximum perimeter for marker contour to be detected. This is defined as a rate respect to the maximum dimension of the input image (default 4.0).
Public field | MinCornerDistanceRate | minimum distance between corners for detected markers relative to its perimeter (default 0.05)
Public field | MinDistanceToBorder | minimum distance of any corner to the image border for detected markers (in pixels) (default 3)
Public field | MinMarkerDistanceRate | minimum mean distance beetween two marker corners to be considered similar, so that the smaller one is removed. The rate is relative to the smaller perimeter of the two markers (default 0.05).
Public field | MinMarkerPerimeterRate | determine minimum perimeter for marker contour to be detected. This is defined as a rate respect to the maximum dimension of the input image (default 0.03).
Public field | MinOtsuStdDev | minimun standard deviation in pixels values during the decodification step to apply Otsu thresholding (otherwise, all the bits are set to 0 or 1 depending on mean higher than 128 or not) (default 5.0)
Public field | PerspectiveRemoveIgnoredMarginPerCell | width of the margin of pixels on each cell not considered for the determination of the cell bit. Represents the rate respect to the total size of the cell, i.e. perpectiveRemovePixelPerCell (default 0.13)
Public field | PerspectiveRemovePixelPerCell | number of bits (per dimension) for each cell of the marker when removing the perspective (default 8).
Public field | PolygonalApproxAccuracyRate | minimum accuracy during the polygonal approximation process to determine which contours are squares.
Top
See Also

Reference

Emgu.CV.Aruco Namespace


DetectorParameters Methods

The DetectorParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefault | Get the detector parameters with default values
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.GetDefault Method

DetectorParametersGetDefault Method

Get the detector parameters with default values

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static DetectorParameters GetDefault()
Public Shared Function GetDefault As DetectorParameters
public:
static DetectorParameters^ GetDefault()
static member GetDefault : unit -> DetectorParameters

Return Value

Type: DetectorParameters
The default detector parameters
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters Fields

The DetectorParameters type exposes the following members.

Fields
 | Name | Description
Public field | AdaptiveThreshConstant | constant for adaptive thresholding before finding contours (default 7)
Public field | AdaptiveThreshWinSizeMax | maximum window size for adaptive thresholding before finding contours (default 23).
Public field | AdaptiveThreshWinSizeMin | minimum window size for adaptive thresholding before finding contours (default 3)
Public field | AdaptiveThreshWinSizeStep | increments from adaptiveThreshWinSizeMin to adaptiveThreshWinSizeMax during the thresholding (default 10).
Public field | AprilTagCriticalRad | Reject quads where pairs of edges have angles that are close to straight or close to 180 degrees.Zero means that no quads are rejected. (In radians).
Public field | AprilTagDeglitch | should the thresholded image be deglitched? Only useful for very noisy images
Public field | AprilTagMaxLineFitMse | When fitting lines to the contours, what is the maximum mean squared error allowed? This is useful in rejecting contours that are far from being quad shaped; rejecting these quads "early" saves expensive decoding processing.
Public field | AprilTagMaxNmaxima | how many corner candidates to consider when segmenting a group of pixels into a quad.
Public field | AprilTagMinClusterPixels | reject quads containing too few pixels.
Public field | AprilTagMinWhiteBlackDiff | When we build our model of black & white pixels, we add an extra check that the white model must be(overall) brighter than the black model.How much brighter? (in pixel values, [0, 255]).
Public field | AprilTagQuadDecimate | Detection of quads can be done on a lower-resolution image, improving speed at a cost of pose accuracy and a slight decrease in detection rate.Decoding the binary payload is still done at full resolution.
Public field | AprilTagQuadSigma | What Gaussian blur should be applied to the segmented image (used for quad detection?) Parameter is the standard deviation in pixels.Very noisy images benefit from non-zero values(e.g. 0.8).
Public field | CornerRefinementMaxIterations | maximum number of iterations for stop criteria of the corner refinement process (default 30).
Public field | CornerRefinementMethod | Corner refinement method
Public field | CornerRefinementMinAccuracy | minimum error for the stop criteria of the corner refinement process (default: 0.1)
Public field | CornerRefinementWinSize | window size for the corner refinement process (in pixels) (default 5).
Public field | ErrorCorrectionRate | error correction rate respect to the maximun error correction capability for each dictionary. (default 0.6).
Public field | MarkerBorderBits | number of bits of the marker border, i.e. marker border width (default 1).
Public field | MaxErroneousBitsInBorderRate | maximum number of accepted erroneous bits in the border (i.e. number of allowed white bits in the border). Represented as a rate respect to the total number of bits per marker (default 0.35).
Public field | MaxMarkerPerimeterRate | determine maximum perimeter for marker contour to be detected. This is defined as a rate respect to the maximum dimension of the input image (default 4.0).
Public field | MinCornerDistanceRate | minimum distance between corners for detected markers relative to its perimeter (default 0.05)
Public field | MinDistanceToBorder | minimum distance of any corner to the image border for detected markers (in pixels) (default 3)
Public field | MinMarkerDistanceRate | minimum mean distance beetween two marker corners to be considered similar, so that the smaller one is removed. The rate is relative to the smaller perimeter of the two markers (default 0.05).
Public field | MinMarkerPerimeterRate | determine minimum perimeter for marker contour to be detected. This is defined as a rate respect to the maximum dimension of the input image (default 0.03).
Public field | MinOtsuStdDev | minimun standard deviation in pixels values during the decodification step to apply Otsu thresholding (otherwise, all the bits are set to 0 or 1 depending on mean higher than 128 or not) (default 5.0)
Public field | PerspectiveRemoveIgnoredMarginPerCell | width of the margin of pixels on each cell not considered for the determination of the cell bit. Represents the rate respect to the total size of the cell, i.e. perpectiveRemovePixelPerCell (default 0.13)
Public field | PerspectiveRemovePixelPerCell | number of bits (per dimension) for each cell of the marker when removing the perspective (default 8).
Public field | PolygonalApproxAccuracyRate | minimum accuracy during the polygonal approximation process to determine which contours are squares.
Top
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AdaptiveThreshConstant Field

DetectorParametersAdaptiveThreshConstant Field

constant for adaptive thresholding before finding contours (default 7)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double AdaptiveThreshConstant
Public AdaptiveThreshConstant As Double
public:
double AdaptiveThreshConstant
val mutable AdaptiveThreshConstant: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AdaptiveThreshWinSizeMax Field

DetectorParametersAdaptiveThreshWinSizeMax Field

maximum window size for adaptive thresholding before finding contours (default 23).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AdaptiveThreshWinSizeMax
Public AdaptiveThreshWinSizeMax As Integer
public:
int AdaptiveThreshWinSizeMax
val mutable AdaptiveThreshWinSizeMax: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AdaptiveThreshWinSizeMin Field

DetectorParametersAdaptiveThreshWinSizeMin Field

minimum window size for adaptive thresholding before finding contours (default 3)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AdaptiveThreshWinSizeMin
Public AdaptiveThreshWinSizeMin As Integer
public:
int AdaptiveThreshWinSizeMin
val mutable AdaptiveThreshWinSizeMin: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AdaptiveThreshWinSizeStep Field

DetectorParametersAdaptiveThreshWinSizeStep Field

increments from adaptiveThreshWinSizeMin to adaptiveThreshWinSizeMax during the thresholding (default 10).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AdaptiveThreshWinSizeStep
Public AdaptiveThreshWinSizeStep As Integer
public:
int AdaptiveThreshWinSizeStep
val mutable AdaptiveThreshWinSizeStep: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagCriticalRad Field

DetectorParametersAprilTagCriticalRad Field

Reject quads where pairs of edges have angles that are close to straight or close to 180 degrees.Zero means that no quads are rejected. (In radians).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float AprilTagCriticalRad
Public AprilTagCriticalRad As Single
public:
float AprilTagCriticalRad
val mutable AprilTagCriticalRad: float32

Field Value

Type: Single
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagDeglitch Field

DetectorParametersAprilTagDeglitch Field

should the thresholded image be deglitched? Only useful for very noisy images

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AprilTagDeglitch
Public AprilTagDeglitch As Integer
public:
int AprilTagDeglitch
val mutable AprilTagDeglitch: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagMaxLineFitMse Field

DetectorParametersAprilTagMaxLineFitMse Field

When fitting lines to the contours, what is the maximum mean squared error allowed? This is useful in rejecting contours that are far from being quad shaped; rejecting these quads "early" saves expensive decoding processing.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float AprilTagMaxLineFitMse
Public AprilTagMaxLineFitMse As Single
public:
float AprilTagMaxLineFitMse
val mutable AprilTagMaxLineFitMse: float32

Field Value

Type: Single
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagMaxNmaxima Field

DetectorParametersAprilTagMaxNmaxima Field

how many corner candidates to consider when segmenting a group of pixels into a quad.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AprilTagMaxNmaxima
Public AprilTagMaxNmaxima As Integer
public:
int AprilTagMaxNmaxima
val mutable AprilTagMaxNmaxima: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagMinClusterPixels Field

DetectorParametersAprilTagMinClusterPixels Field

reject quads containing too few pixels.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AprilTagMinClusterPixels
Public AprilTagMinClusterPixels As Integer
public:
int AprilTagMinClusterPixels
val mutable AprilTagMinClusterPixels: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagMinWhiteBlackDiff Field

DetectorParametersAprilTagMinWhiteBlackDiff Field

When we build our model of black & white pixels, we add an extra check that the white model must be(overall) brighter than the black model.How much brighter? (in pixel values, [0, 255]).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AprilTagMinWhiteBlackDiff
Public AprilTagMinWhiteBlackDiff As Integer
public:
int AprilTagMinWhiteBlackDiff
val mutable AprilTagMinWhiteBlackDiff: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagQuadDecimate Field

DetectorParametersAprilTagQuadDecimate Field

Detection of quads can be done on a lower-resolution image, improving speed at a cost of pose accuracy and a slight decrease in detection rate.Decoding the binary payload is still done at full resolution.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float AprilTagQuadDecimate
Public AprilTagQuadDecimate As Single
public:
float AprilTagQuadDecimate
val mutable AprilTagQuadDecimate: float32

Field Value

Type: Single
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.AprilTagQuadSigma Field

DetectorParametersAprilTagQuadSigma Field

What Gaussian blur should be applied to the segmented image (used for quad detection?) Parameter is the standard deviation in pixels.Very noisy images benefit from non-zero values(e.g. 0.8).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float AprilTagQuadSigma
Public AprilTagQuadSigma As Single
public:
float AprilTagQuadSigma
val mutable AprilTagQuadSigma: float32

Field Value

Type: Single
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.CornerRefinementMaxIterations Field

DetectorParametersCornerRefinementMaxIterations Field

maximum number of iterations for stop criteria of the corner refinement process (default 30).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CornerRefinementMaxIterations
Public CornerRefinementMaxIterations As Integer
public:
int CornerRefinementMaxIterations
val mutable CornerRefinementMaxIterations: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.CornerRefinementMethod Field

DetectorParametersCornerRefinementMethod Field

Corner refinement method

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DetectorParametersRefinementMethod CornerRefinementMethod
Public CornerRefinementMethod As DetectorParametersRefinementMethod
public:
DetectorParametersRefinementMethod^ CornerRefinementMethod
val mutable CornerRefinementMethod: DetectorParametersRefinementMethod

Field Value

Type: DetectorParametersRefinementMethod
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.CornerRefinementMinAccuracy Field

DetectorParametersCornerRefinementMinAccuracy Field

minimum error for the stop criteria of the corner refinement process (default: 0.1)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double CornerRefinementMinAccuracy
Public CornerRefinementMinAccuracy As Double
public:
double CornerRefinementMinAccuracy
val mutable CornerRefinementMinAccuracy: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.CornerRefinementWinSize Field

DetectorParametersCornerRefinementWinSize Field

window size for the corner refinement process (in pixels) (default 5).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CornerRefinementWinSize
Public CornerRefinementWinSize As Integer
public:
int CornerRefinementWinSize
val mutable CornerRefinementWinSize: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.ErrorCorrectionRate Field

DetectorParametersErrorCorrectionRate Field

error correction rate respect to the maximun error correction capability for each dictionary. (default 0.6).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ErrorCorrectionRate
Public ErrorCorrectionRate As Double
public:
double ErrorCorrectionRate
val mutable ErrorCorrectionRate: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MarkerBorderBits Field

DetectorParametersMarkerBorderBits Field

number of bits of the marker border, i.e. marker border width (default 1).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MarkerBorderBits
Public MarkerBorderBits As Integer
public:
int MarkerBorderBits
val mutable MarkerBorderBits: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MaxErroneousBitsInBorderRate Field

DetectorParametersMaxErroneousBitsInBorderRate Field

maximum number of accepted erroneous bits in the border (i.e. number of allowed white bits in the border). Represented as a rate respect to the total number of bits per marker (default 0.35).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MaxErroneousBitsInBorderRate
Public MaxErroneousBitsInBorderRate As Double
public:
double MaxErroneousBitsInBorderRate
val mutable MaxErroneousBitsInBorderRate: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MaxMarkerPerimeterRate Field

DetectorParametersMaxMarkerPerimeterRate Field

determine maximum perimeter for marker contour to be detected. This is defined as a rate respect to the maximum dimension of the input image (default 4.0).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MaxMarkerPerimeterRate
Public MaxMarkerPerimeterRate As Double
public:
double MaxMarkerPerimeterRate
val mutable MaxMarkerPerimeterRate: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MinCornerDistanceRate Field

DetectorParametersMinCornerDistanceRate Field

minimum distance between corners for detected markers relative to its perimeter (default 0.05)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MinCornerDistanceRate
Public MinCornerDistanceRate As Double
public:
double MinCornerDistanceRate
val mutable MinCornerDistanceRate: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MinDistanceToBorder Field

DetectorParametersMinDistanceToBorder Field

minimum distance of any corner to the image border for detected markers (in pixels) (default 3)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MinDistanceToBorder
Public MinDistanceToBorder As Integer
public:
int MinDistanceToBorder
val mutable MinDistanceToBorder: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MinMarkerDistanceRate Field

DetectorParametersMinMarkerDistanceRate Field

minimum mean distance beetween two marker corners to be considered similar, so that the smaller one is removed. The rate is relative to the smaller perimeter of the two markers (default 0.05).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MinMarkerDistanceRate
Public MinMarkerDistanceRate As Double
public:
double MinMarkerDistanceRate
val mutable MinMarkerDistanceRate: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MinMarkerPerimeterRate Field

DetectorParametersMinMarkerPerimeterRate Field

determine minimum perimeter for marker contour to be detected. This is defined as a rate respect to the maximum dimension of the input image (default 0.03).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MinMarkerPerimeterRate
Public MinMarkerPerimeterRate As Double
public:
double MinMarkerPerimeterRate
val mutable MinMarkerPerimeterRate: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.MinOtsuStdDev Field

DetectorParametersMinOtsuStdDev Field

minimun standard deviation in pixels values during the decodification step to apply Otsu thresholding (otherwise, all the bits are set to 0 or 1 depending on mean higher than 128 or not) (default 5.0)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MinOtsuStdDev
Public MinOtsuStdDev As Double
public:
double MinOtsuStdDev
val mutable MinOtsuStdDev: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.PerspectiveRemoveIgnoredMarginPerCell Field

DetectorParametersPerspectiveRemoveIgnoredMarginPerCell Field

http://www.emgu.com
width of the margin of pixels on each cell not considered for the determination of the cell bit. Represents the rate respect to the total size of the cell, i.e. perpectiveRemovePixelPerCell (default 0.13)

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double PerspectiveRemoveIgnoredMarginPerCell
Public PerspectiveRemoveIgnoredMarginPerCell As Double
public:
double PerspectiveRemoveIgnoredMarginPerCell
val mutable PerspectiveRemoveIgnoredMarginPerCell: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.PerspectiveRemovePixelPerCell Field

DetectorParametersPerspectiveRemovePixelPerCell Field

number of bits (per dimension) for each cell of the marker when removing the perspective (default 8).

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int PerspectiveRemovePixelPerCell
Public PerspectiveRemovePixelPerCell As Integer
public:
int PerspectiveRemovePixelPerCell
val mutable PerspectiveRemovePixelPerCell: int

Field Value

Type: Int32
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.PolygonalApproxAccuracyRate Field

DetectorParametersPolygonalApproxAccuracyRate Field

minimum accuracy during the polygonal approximation process to determine which contours are squares.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double PolygonalApproxAccuracyRate
Public PolygonalApproxAccuracyRate As Double
public:
double PolygonalApproxAccuracyRate
val mutable PolygonalApproxAccuracyRate: float

Field Value

Type: Double
See Also

Reference

DetectorParameters Class
Emgu.CV.Aruco Namespace


DetectorParameters.RefinementMethod Class

DetectorParametersRefinementMethod Class

Type of corner refinement method
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ArucoDetectorParametersRefinementMethod

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RefinementMethod : Enum
Public NotInheritable Class RefinementMethod
    Inherits Enum
public ref class RefinementMethod sealed : public Enum
[<SealedAttribute>]
type RefinementMethod =
    class
        inherit Enum
    end

The DetectorParametersRefinementMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Contour | Refine the corners using the contour-points
 | None | Default corners
 | Subpix | Refine the corners using subpix
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Aruco Namespace


RefinementMethod Methods

The DetectorParametersRefinementMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DetectorParametersRefinementMethod Class
Emgu.CV.Aruco Namespace


RefinementMethod Fields

The DetectorParametersRefinementMethod type exposes the following members.

Fields
 | Name | Description
 | Contour | Refine the corners using the contour-points
 | None | Default corners
 | Subpix | Refine the corners using subpix
Public field | value__ |
Top
See Also

Reference

DetectorParametersRefinementMethod Class
Emgu.CV.Aruco Namespace


DetectorParameters.RefinementMethod.Contour Field

DetectorParametersRefinementMethodContour Field

Refine the corners using the contour-points

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DetectorParametersRefinementMethod Contour = 2
Public Const Contour As DetectorParametersRefinementMethod = 2
public:
literal DetectorParametersRefinementMethod^ Contour = 2
static val mutable Contour: DetectorParametersRefinementMethod

Field Value

Type: DetectorParametersRefinementMethod
See Also

Reference

DetectorParametersRefinementMethod Class
Emgu.CV.Aruco Namespace


DetectorParameters.RefinementMethod.None Field

DetectorParametersRefinementMethodNone Field

Default corners

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DetectorParametersRefinementMethod None = 0
Public Const None As DetectorParametersRefinementMethod = 0
public:
literal DetectorParametersRefinementMethod^ None = 0
static val mutable None: DetectorParametersRefinementMethod

Field Value

Type: DetectorParametersRefinementMethod
See Also

Reference

DetectorParametersRefinementMethod Class
Emgu.CV.Aruco Namespace


DetectorParameters.RefinementMethod.Subpix Field

DetectorParametersRefinementMethodSubpix Field

Refine the corners using subpix

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DetectorParametersRefinementMethod Subpix = 1
Public Const Subpix As DetectorParametersRefinementMethod = 1
public:
literal DetectorParametersRefinementMethod^ Subpix = 1
static val mutable Subpix: DetectorParametersRefinementMethod

Field Value

Type: DetectorParametersRefinementMethod
See Also

Reference

DetectorParametersRefinementMethod Class
Emgu.CV.Aruco Namespace


DetectorParameters.RefinementMethod.value__ Field

DetectorParametersRefinementMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Aruco.DetectorParameters.RefinementMethod.value__"]

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DetectorParametersRefinementMethod Class
Emgu.CV.Aruco Namespace


Dictionary Class

Dictionary/Set of markers. It contains the inner codification.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ArucoDictionary

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Dictionary : UnmanagedObject
Public Class Dictionary
    Inherits UnmanagedObject
public ref class Dictionary : public UnmanagedObject
type Dictionary =
    class
        inherit UnmanagedObject
    end

The Dictionary type exposes the following members.

Constructors
 | Name | Description
Public method | Dictionary(DictionaryPredefinedDictionaryName) | Create a Dictionary using predefined values
Public method | Dictionary(Int32, Int32) | Generates a new customizable marker dictionary.
Public method | Dictionary(Int32, Int32, Dictionary) | Generates a new customizable marker dictionary.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Aruco Namespace


Dictionary Constructor

Overload List
 | Name | Description
Public method | Dictionary(DictionaryPredefinedDictionaryName) | Create a Dictionary using predefined values
Public method | Dictionary(Int32, Int32) | Generates a new customizable marker dictionary.
Public method | Dictionary(Int32, Int32, Dictionary) | Generates a new customizable marker dictionary.
Top
See Also

Reference

Dictionary Class
Emgu.CV.Aruco Namespace


Dictionary Constructor (Dictionary.PredefinedDictionaryName)

Dictionary Constructor (DictionaryPredefinedDictionaryName)

http://www.emgu.com
Create a Dictionary using predefined values

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary(
    DictionaryPredefinedDictionaryName name
)
Public Sub New (
    name As DictionaryPredefinedDictionaryName
)
public:
Dictionary(
    DictionaryPredefinedDictionaryName^ name
)
new :
        name : DictionaryPredefinedDictionaryName -> Dictionary

Parameters

name
Type: Emgu.CV.ArucoDictionaryPredefinedDictionaryName
The name of the predefined dictionary
See Also

Reference

Dictionary Class
Dictionary Overload
Emgu.CV.Aruco Namespace


Dictionary Constructor (Int32, Int32)

Generates a new customizable marker dictionary.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary(
    int nMarkers,
    int markerSize
)
Public Sub New (
    nMarkers As Integer,
    markerSize As Integer
)
public:
Dictionary(
    int nMarkers,
    int markerSize
)
new :
        nMarkers : int *
        markerSize : int -> Dictionary

Parameters

nMarkers
Type: SystemInt32
number of markers in the dictionary
markerSize
Type: SystemInt32
number of bits per dimension of each markers
See Also

Reference

Dictionary Class
Dictionary Overload
Emgu.CV.Aruco Namespace


Dictionary Constructor (Int32, Int32, Dictionary)

Generates a new customizable marker dictionary.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary(
    int nMarkers,
    int markerSize,
    Dictionary baseDictionary
)
Public Sub New (
    nMarkers As Integer,
    markerSize As Integer,
    baseDictionary As Dictionary
)
public:
Dictionary(
    int nMarkers,
    int markerSize,
    Dictionary^ baseDictionary
)
new :
        nMarkers : int *
        markerSize : int *
        baseDictionary : Dictionary -> Dictionary

Parameters

nMarkers
Type: SystemInt32
number of markers in the dictionary
markerSize
Type: SystemInt32
number of bits per dimension of each markers
baseDictionary
Type: Emgu.CV.ArucoDictionary
Include the markers in this dictionary at the beginning (optional)
See Also

Reference

Dictionary Class
Dictionary Overload
Emgu.CV.Aruco Namespace


Dictionary Properties

The Dictionary type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Dictionary Class
Emgu.CV.Aruco Namespace


Dictionary Methods

The Dictionary type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dictionary Class
Emgu.CV.Aruco Namespace


Dictionary.DisposeObject Method

DictionaryDisposeObject Method

Release the unmanaged resource

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Dictionary Class
Emgu.CV.Aruco Namespace


Dictionary Fields

The Dictionary type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Dictionary Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName Class

DictionaryPredefinedDictionaryName Class

The name of the predefined dictionary
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ArucoDictionaryPredefinedDictionaryName

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PredefinedDictionaryName : Enum
Public NotInheritable Class PredefinedDictionaryName
    Inherits Enum
public ref class PredefinedDictionaryName sealed : public Enum
[<SealedAttribute>]
type PredefinedDictionaryName =
    class
        inherit Enum
    end

The DictionaryPredefinedDictionaryName type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Dict4X4_100 | Dict4X4_100
 | Dict4X4_1000 | Dict4X4_1000
 | Dict4X4_250 | Dict4X4_250
 | Dict4X4_50 | Dict4X4_50
 | Dict5X5_100 | Dict5X5_100
 | Dict5X5_1000 | Dict5X5_1000
 | Dict5X5_250 | Dict5X5_250
 | Dict5X5_50 | Dict5X5_50
 | Dict6X6_100 | Dict6X6_100
 | Dict6X6_1000 | Dict6X6_1000
 | Dict6X6_250 | Dict6X6_250
 | Dict6X6_50 | Dict6X6_50
 | Dict7X7_100 | Dict7X7_100
 | Dict7X7_1000 | Dict7X7_1000
 | Dict7X7_250 | Dict7X7_250
 | Dict7X7_50 | Dict7X7_50
 | DictArucoOriginal | standard ArUco Library Markers. 1024 markers, 5x5 bits, 0 minimum distance
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Aruco Namespace


PredefinedDictionaryName Methods

The DictionaryPredefinedDictionaryName type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


PredefinedDictionaryName Fields

The DictionaryPredefinedDictionaryName type exposes the following members.

Fields
 | Name | Description
 | Dict4X4_100 | Dict4X4_100
 | Dict4X4_1000 | Dict4X4_1000
 | Dict4X4_250 | Dict4X4_250
 | Dict4X4_50 | Dict4X4_50
 | Dict5X5_100 | Dict5X5_100
 | Dict5X5_1000 | Dict5X5_1000
 | Dict5X5_250 | Dict5X5_250
 | Dict5X5_50 | Dict5X5_50
 | Dict6X6_100 | Dict6X6_100
 | Dict6X6_1000 | Dict6X6_1000
 | Dict6X6_250 | Dict6X6_250
 | Dict6X6_50 | Dict6X6_50
 | Dict7X7_100 | Dict7X7_100
 | Dict7X7_1000 | Dict7X7_1000
 | Dict7X7_250 | Dict7X7_250
 | Dict7X7_50 | Dict7X7_50
 | DictArucoOriginal | standard ArUco Library Markers. 1024 markers, 5x5 bits, 0 minimum distance
Public field | value__ |
Top
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict4X4_100 Field

DictionaryPredefinedDictionaryNameDict4X4_100 Field

Dict4X4_100

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict4X4_100 = 1
Public Const Dict4X4_100 As DictionaryPredefinedDictionaryName = 1
public:
literal DictionaryPredefinedDictionaryName^ Dict4X4_100 = 1
static val mutable Dict4X4_100: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict4X4_1000 Field

DictionaryPredefinedDictionaryNameDict4X4_1000 Field

Dict4X4_1000

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict4X4_1000 = 3
Public Const Dict4X4_1000 As DictionaryPredefinedDictionaryName = 3
public:
literal DictionaryPredefinedDictionaryName^ Dict4X4_1000 = 3
static val mutable Dict4X4_1000: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict4X4_250 Field

DictionaryPredefinedDictionaryNameDict4X4_250 Field

Dict4X4_250

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict4X4_250 = 2
Public Const Dict4X4_250 As DictionaryPredefinedDictionaryName = 2
public:
literal DictionaryPredefinedDictionaryName^ Dict4X4_250 = 2
static val mutable Dict4X4_250: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict4X4_50 Field

DictionaryPredefinedDictionaryNameDict4X4_50 Field

Dict4X4_50

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict4X4_50 = 0
Public Const Dict4X4_50 As DictionaryPredefinedDictionaryName = 0
public:
literal DictionaryPredefinedDictionaryName^ Dict4X4_50 = 0
static val mutable Dict4X4_50: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict5X5_100 Field

DictionaryPredefinedDictionaryNameDict5X5_100 Field

Dict5X5_100

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict5X5_100 = 5
Public Const Dict5X5_100 As DictionaryPredefinedDictionaryName = 5
public:
literal DictionaryPredefinedDictionaryName^ Dict5X5_100 = 5
static val mutable Dict5X5_100: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict5X5_1000 Field

DictionaryPredefinedDictionaryNameDict5X5_1000 Field

Dict5X5_1000

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict5X5_1000 = 7
Public Const Dict5X5_1000 As DictionaryPredefinedDictionaryName = 7
public:
literal DictionaryPredefinedDictionaryName^ Dict5X5_1000 = 7
static val mutable Dict5X5_1000: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict5X5_250 Field

DictionaryPredefinedDictionaryNameDict5X5_250 Field

Dict5X5_250

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict5X5_250 = 6
Public Const Dict5X5_250 As DictionaryPredefinedDictionaryName = 6
public:
literal DictionaryPredefinedDictionaryName^ Dict5X5_250 = 6
static val mutable Dict5X5_250: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict5X5_50 Field

DictionaryPredefinedDictionaryNameDict5X5_50 Field

Dict5X5_50

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict5X5_50 = 4
Public Const Dict5X5_50 As DictionaryPredefinedDictionaryName = 4
public:
literal DictionaryPredefinedDictionaryName^ Dict5X5_50 = 4
static val mutable Dict5X5_50: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict6X6_100 Field

DictionaryPredefinedDictionaryNameDict6X6_100 Field

Dict6X6_100

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict6X6_100 = 9
Public Const Dict6X6_100 As DictionaryPredefinedDictionaryName = 9
public:
literal DictionaryPredefinedDictionaryName^ Dict6X6_100 = 9
static val mutable Dict6X6_100: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict6X6_1000 Field

DictionaryPredefinedDictionaryNameDict6X6_1000 Field

Dict6X6_1000

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict6X6_1000 = 11
Public Const Dict6X6_1000 As DictionaryPredefinedDictionaryName = 11
public:
literal DictionaryPredefinedDictionaryName^ Dict6X6_1000 = 11
static val mutable Dict6X6_1000: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict6X6_250 Field

DictionaryPredefinedDictionaryNameDict6X6_250 Field

Dict6X6_250

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict6X6_250 = 10
Public Const Dict6X6_250 As DictionaryPredefinedDictionaryName = 10
public:
literal DictionaryPredefinedDictionaryName^ Dict6X6_250 = 10
static val mutable Dict6X6_250: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict6X6_50 Field

DictionaryPredefinedDictionaryNameDict6X6_50 Field

Dict6X6_50

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict6X6_50 = 8
Public Const Dict6X6_50 As DictionaryPredefinedDictionaryName = 8
public:
literal DictionaryPredefinedDictionaryName^ Dict6X6_50 = 8
static val mutable Dict6X6_50: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict7X7_100 Field

DictionaryPredefinedDictionaryNameDict7X7_100 Field

Dict7X7_100

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict7X7_100 = 13
Public Const Dict7X7_100 As DictionaryPredefinedDictionaryName = 13
public:
literal DictionaryPredefinedDictionaryName^ Dict7X7_100 = 13
static val mutable Dict7X7_100: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict7X7_1000 Field

DictionaryPredefinedDictionaryNameDict7X7_1000 Field

Dict7X7_1000

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict7X7_1000 = 15
Public Const Dict7X7_1000 As DictionaryPredefinedDictionaryName = 15
public:
literal DictionaryPredefinedDictionaryName^ Dict7X7_1000 = 15
static val mutable Dict7X7_1000: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict7X7_250 Field

DictionaryPredefinedDictionaryNameDict7X7_250 Field

Dict7X7_250

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict7X7_250 = 14
Public Const Dict7X7_250 As DictionaryPredefinedDictionaryName = 14
public:
literal DictionaryPredefinedDictionaryName^ Dict7X7_250 = 14
static val mutable Dict7X7_250: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.Dict7X7_50 Field

DictionaryPredefinedDictionaryNameDict7X7_50 Field

Dict7X7_50

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName Dict7X7_50 = 12
Public Const Dict7X7_50 As DictionaryPredefinedDictionaryName = 12
public:
literal DictionaryPredefinedDictionaryName^ Dict7X7_50 = 12
static val mutable Dict7X7_50: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.DictArucoOriginal Field

DictionaryPredefinedDictionaryNameDictArucoOriginal Field

standard ArUco Library Markers. 1024 markers, 5x5 bits, 0 minimum distance

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DictionaryPredefinedDictionaryName DictArucoOriginal = 16
Public Const DictArucoOriginal As DictionaryPredefinedDictionaryName = 16
public:
literal DictionaryPredefinedDictionaryName^ DictArucoOriginal = 16
static val mutable DictArucoOriginal: DictionaryPredefinedDictionaryName

Field Value

Type: DictionaryPredefinedDictionaryName
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


Dictionary.PredefinedDictionaryName.value__ Field

DictionaryPredefinedDictionaryNamevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Aruco.Dictionary.PredefinedDictionaryName.value__"]

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DictionaryPredefinedDictionaryName Class
Emgu.CV.Aruco Namespace


GridBoard Class

Planar board with grid arrangement of markers More common type of board. All markers are placed in the same plane in a grid arrangment.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ArucoGridBoard

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GridBoard : UnmanagedObject, IBoard
Public Class GridBoard
    Inherits UnmanagedObject
    Implements IBoard
public ref class GridBoard : public UnmanagedObject,
    IBoard
type GridBoard =
    class
        inherit UnmanagedObject
        interface IBoard
    end

The GridBoard type exposes the following members.

Constructors
 | Name | Description
Public method | GridBoard | Create a GridBoard object.
Top
Properties
 | Name | Description
Public property | BoardPtr | Pointer to native IBoard
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with this GridBoard (Overrides DisposableObjectDisposeObject.)
Public method | Draw | Draw a GridBoard.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Aruco Namespace


GridBoard Constructor

Create a GridBoard object.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GridBoard(
    int markersX,
    int markersY,
    float markerLength,
    float markerSeparation,
    Dictionary dictionary,
    int firstMarker = 0
)
Public Sub New (
    markersX As Integer,
    markersY As Integer,
    markerLength As Single,
    markerSeparation As Single,
    dictionary As Dictionary,
    Optional firstMarker As Integer = 0
)
public:
GridBoard(
    int markersX,
    int markersY,
    float markerLength,
    float markerSeparation,
    Dictionary^ dictionary,
    int firstMarker = 0
)
new :
        markersX : int *
        markersY : int *
        markerLength : float32 *
        markerSeparation : float32 *
        dictionary : Dictionary *
        ?firstMarker : int
(* Defaults:
        let _firstMarker = defaultArg firstMarker 0
*)
-> GridBoard

Parameters

markersX
Type: SystemInt32
number of markers in X direction
markersY
Type: SystemInt32
number of markers in Y direction
markerLength
Type: SystemSingle
marker side length (normally in meters)
markerSeparation
Type: SystemSingle
separation between two markers (same unit than markerLenght)
dictionary
Type: Emgu.CV.ArucoDictionary
dictionary of markers indicating the type of markers. The first markersX*markersY markers in the dictionary are used.
firstMarker (Optional)
Type: SystemInt32
id of first marker in dictionary to use on board.
See Also

Reference

GridBoard Class
Emgu.CV.Aruco Namespace


GridBoard Properties

The GridBoard type exposes the following members.

Properties
 | Name | Description
Public property | BoardPtr | Pointer to native IBoard
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GridBoard Class
Emgu.CV.Aruco Namespace


GridBoard.BoardPtr Property

GridBoardBoardPtr Property

Pointer to native IBoard

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BoardPtr { get; }
Public ReadOnly Property BoardPtr As IntPtr
    Get
public:
virtual property IntPtr BoardPtr {
    IntPtr get () sealed;
}
abstract BoardPtr : IntPtr with get
override BoardPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBoardBoardPtr
See Also

Reference

GridBoard Class
Emgu.CV.Aruco Namespace


GridBoard Methods

The GridBoard type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with this GridBoard (Overrides DisposableObjectDisposeObject.)
Public method | Draw | Draw a GridBoard.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GridBoard Class
Emgu.CV.Aruco Namespace


GridBoard.DisposeObject Method

GridBoardDisposeObject Method

Release the unmanaged resource associated with this GridBoard

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

GridBoard Class
Emgu.CV.Aruco Namespace


GridBoard.Draw Method

GridBoardDraw Method

Draw a GridBoard.

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    Size outSize,
    IOutputArray img,
    int marginSize = 0,
    int borderBits = 1
)
Public Sub Draw (
    outSize As Size,
    img As IOutputArray,
    Optional marginSize As Integer = 0,
    Optional borderBits As Integer = 1
)
public:
void Draw(
    Size^ outSize,
    IOutputArray^ img,
    int marginSize = 0,
    int borderBits = 1
)
member Draw :
        outSize : Size *
        img : IOutputArray *
        ?marginSize : int *
        ?borderBits : int
(* Defaults:
        let _marginSize = defaultArg marginSize 0
        let _borderBits = defaultArg borderBits 1
*)
-> unit

Parameters

outSize
Type: System.DrawingSize
size of the output image in pixels.
img
Type: Emgu.CVIOutputArray
output image with the board. The size of this image will be outSize and the board will be on the center, keeping the board proportions.
marginSize (Optional)
Type: SystemInt32
minimum margins (in pixels) of the board in the output image
borderBits (Optional)
Type: SystemInt32
width of the marker borders.
See Also

Reference

GridBoard Class
Emgu.CV.Aruco Namespace


GridBoard Fields

The GridBoard type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GridBoard Class
Emgu.CV.Aruco Namespace


IBoard Interface

Board of markers

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IBoard
Public Interface IBoard
public interface class IBoard
type IBoard =  interface end

The IBoard type exposes the following members.

Properties
 | Name | Description
Public property | BoardPtr | Pointer to native IBoard
Top
See Also

Reference

Emgu.CV.Aruco Namespace


IBoard Properties

The IBoard type exposes the following members.

Properties
 | Name | Description
Public property | BoardPtr | Pointer to native IBoard
Top
See Also

Reference

IBoard Interface
Emgu.CV.Aruco Namespace


IBoard.BoardPtr Property

IBoardBoardPtr Property

Pointer to native IBoard

Namespace: Emgu.CV.Aruco
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr BoardPtr { get; }
ReadOnly Property BoardPtr As IntPtr
    Get
property IntPtr BoardPtr {
    IntPtr get ();
}
abstract BoardPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IBoard Interface
Emgu.CV.Aruco Namespace


Emgu.CV.BgSegm Namespace

Background Segmentation.
Classes
 | Class | Description
Public class | BackgroundSubtractorCNT | Background subtraction based on counting.
Public class | BackgroundSubtractorGMG | Background Subtractor module based on the algorithm given in: Andrew B. Godbehere, Akihiro Matsukawa, Ken Goldberg, "Visual Tracking of Human Visitors under Variable-Lighting Conditions for a Responsive Audio Art Installation", American Control Conference, Montreal, June 2012.
Public class | BackgroundSubtractorGSOC | Implementation of the different yet better algorithm which is called GSOC, as it was implemented during GSOC and was not originated from any paper.
Public class | BackgroundSubtractorLSBP | Background Subtraction using Local SVD Binary Pattern.
Public class | BackgroundSubtractorLSBPCameraMotionCompensation | Camera Motion compensation mode
Public class | BackgroundSubtractorMOG | Gaussian Mixture-based Background/Foreground Segmentation Algorithm. The class implements the following algorithm: "An improved adaptive background mixture model for real-time tracking with shadow detection" P. KadewTraKuPong and R. Bowden, Proc. 2nd European Workshp on Advanced Video-Based Surveillance Systems, 2001."


BackgroundSubtractorCNT Class

Background subtraction based on counting.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.BgSegmBackgroundSubtractorCNT

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSubtractorCNT : UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
Public Class BackgroundSubtractorCNT
    Inherits UnmanagedObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class BackgroundSubtractorCNT : public UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
type BackgroundSubtractorCNT =
    class
        inherit UnmanagedObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The BackgroundSubtractorCNT type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundSubtractorCNT | Creates a CNT Background Subtractor.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
Remarks
About as fast as MOG2 on a high end system. More than twice faster than MOG2 on cheap hardware (benchmarked on Raspberry Pi3).
See Also

Reference

Emgu.CV.BgSegm Namespace


BackgroundSubtractorCNT Constructor

Creates a CNT Background Subtractor.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundSubtractorCNT(
    int minPixelStability = 15,
    bool useHistory = true,
    int maxPixelStability = 900,
    bool isParallel = true
)
Public Sub New (
    Optional minPixelStability As Integer = 15,
    Optional useHistory As Boolean = true,
    Optional maxPixelStability As Integer = 900,
    Optional isParallel As Boolean = true
)
public:
BackgroundSubtractorCNT(
    int minPixelStability = 15,
    bool useHistory = true,
    int maxPixelStability = 900,
    bool isParallel = true
)
new :
        ?minPixelStability : int *
        ?useHistory : bool *
        ?maxPixelStability : int *
        ?isParallel : bool
(* Defaults:
        let _minPixelStability = defaultArg minPixelStability 15
        let _useHistory = defaultArg useHistory true
        let _maxPixelStability = defaultArg maxPixelStability 900
        let _isParallel = defaultArg isParallel true
*)
-> BackgroundSubtractorCNT

Parameters

minPixelStability (Optional)
Type: SystemInt32
number of frames with same pixel color to consider stable
useHistory (Optional)
Type: SystemBoolean
determines if we're giving a pixel credit for being stable for a long time
maxPixelStability (Optional)
Type: SystemInt32
maximum allowed credit for a pixel in history
isParallel (Optional)
Type: SystemBoolean
determines if we're parallelizing the algorithm
See Also

Reference

BackgroundSubtractorCNT Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorCNT Properties

The BackgroundSubtractorCNT type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorCNT Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorCNT.AlgorithmPtr Property

BackgroundSubtractorCNTAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

BackgroundSubtractorCNT Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorCNT.BackgroundSubtractorPtr Property

BackgroundSubtractorCNTBackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

BackgroundSubtractorCNT Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorCNT Methods

The BackgroundSubtractorCNT type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

BackgroundSubtractorCNT Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorCNT.DisposeObject Method

BackgroundSubtractorCNTDisposeObject Method

Release all the unmanaged memory associated with this background model.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BackgroundSubtractorCNT Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorCNT Fields

The BackgroundSubtractorCNT type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorCNT Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG Class

Background Subtractor module based on the algorithm given in: Andrew B. Godbehere, Akihiro Matsukawa, Ken Goldberg, "Visual Tracking of Human Visitors under Variable-Lighting Conditions for a Responsive Audio Art Installation", American Control Conference, Montreal, June 2012.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.BgSegmBackgroundSubtractorGMG

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSubtractorGMG : UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
Public Class BackgroundSubtractorGMG
    Inherits UnmanagedObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class BackgroundSubtractorGMG : public UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
type BackgroundSubtractorGMG =
    class
        inherit UnmanagedObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The BackgroundSubtractorGMG type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundSubtractorGMG | Create a background subtractor module based on GMG
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG Constructor

Create a background subtractor module based on GMG

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundSubtractorGMG(
    int initializationFrames,
    double decisionThreshold
)
Public Sub New (
    initializationFrames As Integer,
    decisionThreshold As Double
)
public:
BackgroundSubtractorGMG(
    int initializationFrames,
    double decisionThreshold
)
new :
        initializationFrames : int *
        decisionThreshold : float -> BackgroundSubtractorGMG

Parameters

initializationFrames
Type: SystemInt32
Number of frames used to initialize the background models.
decisionThreshold
Type: SystemDouble
Threshold value, above which it is marked foreground, else background.
See Also

Reference

BackgroundSubtractorGMG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG Properties

The BackgroundSubtractorGMG type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorGMG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG.AlgorithmPtr Property

BackgroundSubtractorGMGAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

BackgroundSubtractorGMG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG.BackgroundSubtractorPtr Property

BackgroundSubtractorGMGBackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

BackgroundSubtractorGMG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG Methods

The BackgroundSubtractorGMG type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

BackgroundSubtractorGMG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG.DisposeObject Method

BackgroundSubtractorGMGDisposeObject Method

Release all the unmanaged memory associated with this background model.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BackgroundSubtractorGMG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGMG Fields

The BackgroundSubtractorGMG type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorGMG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC Class

Implementation of the different yet better algorithm which is called GSOC, as it was implemented during GSOC and was not originated from any paper.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.BgSegmBackgroundSubtractorGSOC

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSubtractorGSOC : UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
Public Class BackgroundSubtractorGSOC
    Inherits UnmanagedObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class BackgroundSubtractorGSOC : public UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
type BackgroundSubtractorGSOC =
    class
        inherit UnmanagedObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The BackgroundSubtractorGSOC type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundSubtractorGSOC | Creates an instance of BackgroundSubtractorGSOC algorithm.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC Constructor

Creates an instance of BackgroundSubtractorGSOC algorithm.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundSubtractorGSOC(
    BackgroundSubtractorLSBPCameraMotionCompensation mc = 0,
    int nSamples = 20,
    float replaceRate = 0.003f,
    float propagationRate = 0.01f,
    int hitsThreshold = 32,
    float alpha = 0.01f,
    float beta = 0.0022f,
    float blinkingSupressionDecay = 0.1f,
    float blinkingSupressionMultiplier = 0.1f,
    float noiseRemovalThresholdFacBG = 0.0004f,
    float noiseRemovalThresholdFacFG = 0.0008f
)
Public Sub New (
    Optional mc As BackgroundSubtractorLSBPCameraMotionCompensation = 0,
    Optional nSamples As Integer = 20,
    Optional replaceRate As Single = 0.003F,
    Optional propagationRate As Single = 0.01F,
    Optional hitsThreshold As Integer = 32,
    Optional alpha As Single = 0.01F,
    Optional beta As Single = 0.0022F,
    Optional blinkingSupressionDecay As Single = 0.1F,
    Optional blinkingSupressionMultiplier As Single = 0.1F,
    Optional noiseRemovalThresholdFacBG As Single = 0.0004F,
    Optional noiseRemovalThresholdFacFG As Single = 0.0008F
)
public:
BackgroundSubtractorGSOC(
    BackgroundSubtractorLSBPCameraMotionCompensation^ mc = 0,
    int nSamples = 20,
    float replaceRate = 0.003f,
    float propagationRate = 0.01f,
    int hitsThreshold = 32,
    float alpha = 0.01f,
    float beta = 0.0022f,
    float blinkingSupressionDecay = 0.1f,
    float blinkingSupressionMultiplier = 0.1f,
    float noiseRemovalThresholdFacBG = 0.0004f,
    float noiseRemovalThresholdFacFG = 0.0008f
)
new :
        ?mc : BackgroundSubtractorLSBPCameraMotionCompensation *
        ?nSamples : int *
        ?replaceRate : float32 *
        ?propagationRate : float32 *
        ?hitsThreshold : int *
        ?alpha : float32 *
        ?beta : float32 *
        ?blinkingSupressionDecay : float32 *
        ?blinkingSupressionMultiplier : float32 *
        ?noiseRemovalThresholdFacBG : float32 *
        ?noiseRemovalThresholdFacFG : float32
(* Defaults:
        let _mc = defaultArg mc 0
        let _nSamples = defaultArg nSamples 20
        let _replaceRate = defaultArg replaceRate 0.003f
        let _propagationRate = defaultArg propagationRate 0.01f
        let _hitsThreshold = defaultArg hitsThreshold 32
        let _alpha = defaultArg alpha 0.01f
        let _beta = defaultArg beta 0.0022f
        let _blinkingSupressionDecay = defaultArg blinkingSupressionDecay 0.1f
        let _blinkingSupressionMultiplier = defaultArg blinkingSupressionMultiplier 0.1f
        let _noiseRemovalThresholdFacBG = defaultArg noiseRemovalThresholdFacBG 0.0004f
        let _noiseRemovalThresholdFacFG = defaultArg noiseRemovalThresholdFacFG 0.0008f
*)
-> BackgroundSubtractorGSOC

Parameters

mc (Optional)
Type: Emgu.CV.BgSegmBackgroundSubtractorLSBPCameraMotionCompensation
Whether to use camera motion compensation.
nSamples (Optional)
Type: SystemInt32
Number of samples to maintain at each point of the frame.
replaceRate (Optional)
Type: SystemSingle
Probability of replacing the old sample - how fast the model will update itself.
propagationRate (Optional)
Type: SystemSingle
Probability of propagating to neighbors.
hitsThreshold (Optional)
Type: SystemInt32
How many positives the sample must get before it will be considered as a possible replacement.
alpha (Optional)
Type: SystemSingle
Scale coefficient for threshold.
beta (Optional)
Type: SystemSingle
Bias coefficient for threshold.
blinkingSupressionDecay (Optional)
Type: SystemSingle
Blinking supression decay factor.
blinkingSupressionMultiplier (Optional)
Type: SystemSingle
Blinking supression multiplier.
noiseRemovalThresholdFacBG (Optional)
Type: SystemSingle
Strength of the noise removal for background points.
noiseRemovalThresholdFacFG (Optional)
Type: SystemSingle
Strength of the noise removal for foreground points.
See Also

Reference

BackgroundSubtractorGSOC Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC Properties

The BackgroundSubtractorGSOC type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorGSOC Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC.AlgorithmPtr Property

BackgroundSubtractorGSOCAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

BackgroundSubtractorGSOC Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC.BackgroundSubtractorPtr Property

BackgroundSubtractorGSOCBackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

BackgroundSubtractorGSOC Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC Methods

The BackgroundSubtractorGSOC type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

BackgroundSubtractorGSOC Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC.DisposeObject Method

BackgroundSubtractorGSOCDisposeObject Method

Release all the unmanaged memory associated with this background model.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BackgroundSubtractorGSOC Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorGSOC Fields

The BackgroundSubtractorGSOC type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorGSOC Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP Class

Background Subtraction using Local SVD Binary Pattern.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.BgSegmBackgroundSubtractorLSBP

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSubtractorLSBP : UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
Public Class BackgroundSubtractorLSBP
    Inherits UnmanagedObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class BackgroundSubtractorLSBP : public UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
type BackgroundSubtractorLSBP =
    class
        inherit UnmanagedObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The BackgroundSubtractorLSBP type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundSubtractorLSBP | Creates an instance of BackgroundSubtractorLSBP algorithm.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
Remarks
More details about the algorithm can be found at: L. Guo, D. Xu, and Z. Qiang. Background subtraction using local svd binary pattern. In 2016 IEEE Conference on Computer Vision and Pattern Recognition Workshops (CVPRW), pages 1159–1167, June 2016.
See Also

Reference

Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP Constructor

Creates an instance of BackgroundSubtractorLSBP algorithm.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundSubtractorLSBP(
    BackgroundSubtractorLSBPCameraMotionCompensation mc = 0,
    int nSamples = 20,
    int LSBPRadius = 16,
    float tlower = 2f,
    float tupper = 32f,
    float tinc = 1f,
    float tdec = 0.05f,
    float rscale = 10f,
    float rincdec = 0.005f,
    float noiseRemovalThresholdFacBG = 0.0004f,
    float noiseRemovalThresholdFacFG = 0.0008f,
    int LSBPthreshold = 8,
    int minCount = 2
)
Public Sub New (
    Optional mc As BackgroundSubtractorLSBPCameraMotionCompensation = 0,
    Optional nSamples As Integer = 20,
    Optional LSBPRadius As Integer = 16,
    Optional tlower As Single = 2F,
    Optional tupper As Single = 32F,
    Optional tinc As Single = 1F,
    Optional tdec As Single = 0.05F,
    Optional rscale As Single = 10F,
    Optional rincdec As Single = 0.005F,
    Optional noiseRemovalThresholdFacBG As Single = 0.0004F,
    Optional noiseRemovalThresholdFacFG As Single = 0.0008F,
    Optional LSBPthreshold As Integer = 8,
    Optional minCount As Integer = 2
)
public:
BackgroundSubtractorLSBP(
    BackgroundSubtractorLSBPCameraMotionCompensation^ mc = 0,
    int nSamples = 20,
    int LSBPRadius = 16,
    float tlower = 2f,
    float tupper = 32f,
    float tinc = 1f,
    float tdec = 0.05f,
    float rscale = 10f,
    float rincdec = 0.005f,
    float noiseRemovalThresholdFacBG = 0.0004f,
    float noiseRemovalThresholdFacFG = 0.0008f,
    int LSBPthreshold = 8,
    int minCount = 2
)
new :
        ?mc : BackgroundSubtractorLSBPCameraMotionCompensation *
        ?nSamples : int *
        ?LSBPRadius : int *
        ?tlower : float32 *
        ?tupper : float32 *
        ?tinc : float32 *
        ?tdec : float32 *
        ?rscale : float32 *
        ?rincdec : float32 *
        ?noiseRemovalThresholdFacBG : float32 *
        ?noiseRemovalThresholdFacFG : float32 *
        ?LSBPthreshold : int *
        ?minCount : int
(* Defaults:
        let _mc = defaultArg mc 0
        let _nSamples = defaultArg nSamples 20
        let _LSBPRadius = defaultArg LSBPRadius 16
        let _tlower = defaultArg tlower 2f
        let _tupper = defaultArg tupper 32f
        let _tinc = defaultArg tinc 1f
        let _tdec = defaultArg tdec 0.05f
        let _rscale = defaultArg rscale 10f
        let _rincdec = defaultArg rincdec 0.005f
        let _noiseRemovalThresholdFacBG = defaultArg noiseRemovalThresholdFacBG 0.0004f
        let _noiseRemovalThresholdFacFG = defaultArg noiseRemovalThresholdFacFG 0.0008f
        let _LSBPthreshold = defaultArg LSBPthreshold 8
        let _minCount = defaultArg minCount 2
*)
-> BackgroundSubtractorLSBP

Parameters

mc (Optional)
Type: Emgu.CV.BgSegmBackgroundSubtractorLSBPCameraMotionCompensation
Whether to use camera motion compensation.
nSamples (Optional)
Type: SystemInt32
Number of samples to maintain at each point of the frame.
LSBPRadius (Optional)
Type: SystemInt32
LSBP descriptor radius.
tlower (Optional)
Type: SystemSingle
Lower bound for T-values.
tupper (Optional)
Type: SystemSingle
Upper bound for T-values.
tinc (Optional)
Type: SystemSingle
Increase step for T-values.
tdec (Optional)
Type: SystemSingle
Decrease step for T-values.
rscale (Optional)
Type: SystemSingle
Scale coefficient for threshold values.
rincdec (Optional)
Type: SystemSingle
Increase/Decrease step for threshold values.
noiseRemovalThresholdFacBG (Optional)
Type: SystemSingle
Strength of the noise removal for background points.
noiseRemovalThresholdFacFG (Optional)
Type: SystemSingle
Strength of the noise removal for foreground points.
LSBPthreshold (Optional)
Type: SystemInt32
Threshold for LSBP binary string.
minCount (Optional)
Type: SystemInt32
Minimal number of matches for sample to be considered as foreground.
See Also

Reference

BackgroundSubtractorLSBP Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP Properties

The BackgroundSubtractorLSBP type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorLSBP Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP.AlgorithmPtr Property

BackgroundSubtractorLSBPAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

BackgroundSubtractorLSBP Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP.BackgroundSubtractorPtr Property

BackgroundSubtractorLSBPBackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

BackgroundSubtractorLSBP Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP Methods

The BackgroundSubtractorLSBP type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

BackgroundSubtractorLSBP Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP.DisposeObject Method

BackgroundSubtractorLSBPDisposeObject Method

Release all the unmanaged memory associated with this background model.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BackgroundSubtractorLSBP Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP Fields

The BackgroundSubtractorLSBP type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorLSBP Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP.CameraMotionCompensation Class

BackgroundSubtractorLSBPCameraMotionCompensation Class

Camera Motion compensation mode
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.BgSegmBackgroundSubtractorLSBPCameraMotionCompensation

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CameraMotionCompensation : Enum
Public NotInheritable Class CameraMotionCompensation
    Inherits Enum
public ref class CameraMotionCompensation sealed : public Enum
[<SealedAttribute>]
type CameraMotionCompensation =
    class
        inherit Enum
    end

The BackgroundSubtractorLSBPCameraMotionCompensation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | LK | Use LK camera compensation
 | None | None
Public field | value__ |
Top
See Also

Reference

Emgu.CV.BgSegm Namespace


CameraMotionCompensation Methods

The BackgroundSubtractorLSBPCameraMotionCompensation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BackgroundSubtractorLSBPCameraMotionCompensation Class
Emgu.CV.BgSegm Namespace


CameraMotionCompensation Fields

The BackgroundSubtractorLSBPCameraMotionCompensation type exposes the following members.

Fields
 | Name | Description
 | LK | Use LK camera compensation
 | None | None
Public field | value__ |
Top
See Also

Reference

BackgroundSubtractorLSBPCameraMotionCompensation Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP.CameraMotionCompensation.LK Field

BackgroundSubtractorLSBPCameraMotionCompensationLK Field

Use LK camera compensation

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BackgroundSubtractorLSBPCameraMotionCompensation LK = 1
Public Const LK As BackgroundSubtractorLSBPCameraMotionCompensation = 1
public:
literal BackgroundSubtractorLSBPCameraMotionCompensation^ LK = 1
static val mutable LK: BackgroundSubtractorLSBPCameraMotionCompensation

Field Value

Type: BackgroundSubtractorLSBPCameraMotionCompensation
See Also

Reference

BackgroundSubtractorLSBPCameraMotionCompensation Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP.CameraMotionCompensation.None Field

BackgroundSubtractorLSBPCameraMotionCompensationNone Field

None

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BackgroundSubtractorLSBPCameraMotionCompensation None = 0
Public Const None As BackgroundSubtractorLSBPCameraMotionCompensation = 0
public:
literal BackgroundSubtractorLSBPCameraMotionCompensation^ None = 0
static val mutable None: BackgroundSubtractorLSBPCameraMotionCompensation

Field Value

Type: BackgroundSubtractorLSBPCameraMotionCompensation
See Also

Reference

BackgroundSubtractorLSBPCameraMotionCompensation Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorLSBP.CameraMotionCompensation.value__ Field

BackgroundSubtractorLSBPCameraMotionCompensationvalue__ Field

http://www.emgu.com

[Missing <summary> documentation for "F:Emgu.CV.BgSegm.BackgroundSubtractorLSBP.CameraMotionCompensation.value__"]

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BackgroundSubtractorLSBPCameraMotionCompensation Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG Class

Gaussian Mixture-based Background/Foreground Segmentation Algorithm. The class implements the following algorithm: "An improved adaptive background mixture model for real-time tracking with shadow detection" P. KadewTraKuPong and R. Bowden, Proc. 2nd European Workshp on Advanced Video-Based Surveillance Systems, 2001."
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.BgSegmBackgroundSubtractorMOG

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSubtractorMOG : UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
Public Class BackgroundSubtractorMOG
    Inherits UnmanagedObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class BackgroundSubtractorMOG : public UnmanagedObject,
    IBackgroundSubtractor, IAlgorithm
type BackgroundSubtractorMOG =
    class
        inherit UnmanagedObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The BackgroundSubtractorMOG type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundSubtractorMOG | Create an "Improved adaptive Gaussian mixture model for background subtraction".
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG Constructor

Create an "Improved adaptive Gaussian mixture model for background subtraction".

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundSubtractorMOG(
    int history = 200,
    int nMixtures = 5,
    double backgroundRatio = 0.7,
    double noiseSigma = 0
)
Public Sub New (
    Optional history As Integer = 200,
    Optional nMixtures As Integer = 5,
    Optional backgroundRatio As Double = 0.7,
    Optional noiseSigma As Double = 0
)
public:
BackgroundSubtractorMOG(
    int history = 200,
    int nMixtures = 5,
    double backgroundRatio = 0.7,
    double noiseSigma = 0
)
new :
        ?history : int *
        ?nMixtures : int *
        ?backgroundRatio : float *
        ?noiseSigma : float
(* Defaults:
        let _history = defaultArg history 200
        let _nMixtures = defaultArg nMixtures 5
        let _backgroundRatio = defaultArg backgroundRatio 0.7
        let _noiseSigma = defaultArg noiseSigma 0
*)
-> BackgroundSubtractorMOG

Parameters

history (Optional)
Type: SystemInt32
The length of the history.
nMixtures (Optional)
Type: SystemInt32
The maximum number of gaussian mixtures.
backgroundRatio (Optional)
Type: SystemDouble
Background ratio
noiseSigma (Optional)
Type: SystemDouble
Noise strength (standard deviation of the brightness or each color channel). 0 means some automatic value.
See Also

Reference

BackgroundSubtractorMOG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG Properties

The BackgroundSubtractorMOG type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorMOG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG.AlgorithmPtr Property

BackgroundSubtractorMOGAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

BackgroundSubtractorMOG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG.BackgroundSubtractorPtr Property

BackgroundSubtractorMOGBackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

BackgroundSubtractorMOG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG Methods

The BackgroundSubtractorMOG type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this background model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

BackgroundSubtractorMOG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG.DisposeObject Method

BackgroundSubtractorMOGDisposeObject Method

Release all the unmanaged memory associated with this background model.

Namespace: Emgu.CV.BgSegm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BackgroundSubtractorMOG Class
Emgu.CV.BgSegm Namespace


BackgroundSubtractorMOG Fields

The BackgroundSubtractorMOG type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BackgroundSubtractorMOG Class
Emgu.CV.BgSegm Namespace


Emgu.CV.Bioinspired Namespace

Biologically inspired vision models and derivated tools
Classes
Class Description
Public class BioinspiredInvoke
Entry points to the Open CV bioinspired module
Public class Retina
A wrapper class which allows the Gipsa/Listic Labs model to be used. This retina model allows spatio-temporal image processing (applied on still images, video sequences). As a summary, these are the retina model properties: 1. It applies a spectral whithening (mid-frequency details enhancement); 2. high frequency spatio-temporal noise reduction; 3. low frequency luminance to be reduced (luminance range compression); 4. local logarithmic luminance compression allows details to be enhanced in low light conditions. USE : this model can be used basically for spatio-temporal video effects but also for : _using the getParvo method output matrix : texture analysiswith enhanced signal to noise ratio and enhanced details robust against input images luminance ranges _using the getMagno method output matrix : motion analysis also with the previously cited properties For more information, reer to the following papers : Benoit A., Caplier A., Durette B., Herault, J., "USING HUMAN VISUAL SYSTEM MODELING FOR BIO-INSPIRED LOW LEVEL IMAGE PROCESSING", Elsevier, Computer Vision and Image Understanding 114 (2010), pp. 758-773, DOI: http://dx.doi.org/10.1016/j.cviu.2010.01.011 Vision: Images, Signals and Neural Networks: Models of Neural Processing in Visual Perception (Progress in Neural Processing),By: Jeanny Herault, ISBN: 9814273686. WAPI (Tower ID): 113266891. The retina filter includes the research contributions of phd/research collegues from which code has been redrawn by the author : _take a look at the retinacolor.hpp module to discover Brice Chaix de Lavarene color mosaicing/demosaicing and the reference paper: B. Chaix de Lavarene, D. Alleysson, B. Durette, J. Herault (2007). "Efficient demosaicing through recursive filtering", IEEE International Conference on Image Processing ICIP 2007 _take a look at imagelogpolprojection.hpp to discover retina spatial log sampling which originates from Barthelemy Durette phd with Jeanny Herault. A Retina / V1 cortex projection is also proposed and originates from Jeanny's discussions. more informations in the above cited Jeanny Heraults's book.
Public class RetinaColorSamplingMethod
The retina color sampling method.
Public class RetinaIplMagnoParameters
Inner Plexiform Layer Magnocellular channel (IplMagno)
Public class RetinaOPLandIplParvoParameters
Outer Plexiform Layer (OPL) and Inner Plexiform Layer Parvocellular (IplParvo) parameters
Public class RetinaRetinaParameters
Retina parameters
Public class RetinaFastToneMapping
A wrapper class which allows the tone mapping algorithm of Meylan & al(2007) to be used with OpenCV.


BioinspiredInvoke Class

Entry points to the Open CV bioinspired module
Inheritance Hierarchy
SystemObject
Emgu.CV.BioinspiredBioinspiredInvoke

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class BioinspiredInvoke
Public NotInheritable Class BioinspiredInvoke
public ref class BioinspiredInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BioinspiredInvoke =  class end
See Also

Reference

Emgu.CV.Bioinspired Namespace


Retina Class

A wrapper class which allows the Gipsa/Listic Labs model to be used. This retina model allows spatio-temporal image processing (applied on still images, video sequences). As a summary, these are the retina model properties: 1. It applies a spectral whithening (mid-frequency details enhancement); 2. high frequency spatio-temporal noise reduction; 3. low frequency luminance to be reduced (luminance range compression); 4. local logarithmic luminance compression allows details to be enhanced in low light conditions. USE : this model can be used basically for spatio-temporal video effects but also for : _using the getParvo method output matrix : texture analysiswith enhanced signal to noise ratio and enhanced details robust against input images luminance ranges _using the getMagno method output matrix : motion analysis also with the previously cited properties For more information, reer to the following papers : Benoit A., Caplier A., Durette B., Herault, J., "USING HUMAN VISUAL SYSTEM MODELING FOR BIO-INSPIRED LOW LEVEL IMAGE PROCESSING", Elsevier, Computer Vision and Image Understanding 114 (2010), pp. 758-773, DOI: http://dx.doi.org/10.1016/j.cviu.2010.01.011 Vision: Images, Signals and Neural Networks: Models of Neural Processing in Visual Perception (Progress in Neural Processing),By: Jeanny Herault, ISBN: 9814273686. WAPI (Tower ID): 113266891. The retina filter includes the research contributions of phd/research collegues from which code has been redrawn by the author : _take a look at the retinacolor.hpp module to discover Brice Chaix de Lavarene color mosaicing/demosaicing and the reference paper: B. Chaix de Lavarene, D. Alleysson, B. Durette, J. Herault (2007). "Efficient demosaicing through recursive filtering", IEEE International Conference on Image Processing ICIP 2007 _take a look at imagelogpolprojection.hpp to discover retina spatial log sampling which originates from Barthelemy Durette phd with Jeanny Herault. A Retina / V1 cortex projection is also proposed and originates from Jeanny's discussions. more informations in the above cited Jeanny Heraults's book.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.BioinspiredRetina

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Retina : SharedPtrObject
Public Class Retina
    Inherits SharedPtrObject
public ref class Retina : public SharedPtrObject
type Retina =
    class
        inherit SharedPtrObject
    end

The Retina type exposes the following members.

Constructors
 | Name | Description
Public method | Retina(Size) | Create a retina model
Public method | Retina(Size, Boolean, RetinaColorSamplingMethod, Boolean, Double, Double) | Create a retina model
Top
Properties
 | Name | Description
Public property | Parameters | Get or Set the Retina parameters.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | ClearBuffers | Clear all retina buffers (equivalent to opening the eyes after a long period of eye close.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associated with the retina model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMagno | Accessors of the motion channel of the retina (models peripheral vision)
Public method | GetParvo | Accessors of the details channel of the retina (models foveal vision)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Method which allows retina to be applied on an input image, after run, encapsulated retina module is ready to deliver its outputs using dedicated acccessors. and
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Bioinspired Namespace


Retina Constructor

Overload List
 | Name | Description
Public method | Retina(Size) | Create a retina model
Public method | Retina(Size, Boolean, RetinaColorSamplingMethod, Boolean, Double, Double) | Create a retina model
Top
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina Constructor (Size)

Create a retina model

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Retina(
    Size inputSize
)
Public Sub New (
    inputSize As Size
)
public:
Retina(
    Size^ inputSize
)
new :
        inputSize : Size -> Retina

Parameters

inputSize
Type: System.DrawingSize
The input frame size
See Also

Reference

Retina Class
Retina Overload
Emgu.CV.Bioinspired Namespace


Retina Constructor (Size, Boolean, Retina.ColorSamplingMethod, Boolean, Double, Double)

Retina Constructor (Size, Boolean, RetinaColorSamplingMethod, Boolean, Double, Double)

http://www.emgu.com
Create a retina model

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Retina(
    Size inputSize,
    bool colorMode,
    RetinaColorSamplingMethod colorSamplingMethod,
    bool useRetinaLogSampling,
    double reductionFactor,
    double samplingStrength
)
Public Sub New (
    inputSize As Size,
    colorMode As Boolean,
    colorSamplingMethod As RetinaColorSamplingMethod,
    useRetinaLogSampling As Boolean,
    reductionFactor As Double,
    samplingStrength As Double
)
public:
Retina(
    Size^ inputSize,
    bool colorMode,
    RetinaColorSamplingMethod^ colorSamplingMethod,
    bool useRetinaLogSampling,
    double reductionFactor,
    double samplingStrength
)
new :
        inputSize : Size *
        colorMode : bool *
        colorSamplingMethod : RetinaColorSamplingMethod *
        useRetinaLogSampling : bool *
        reductionFactor : float *
        samplingStrength : float -> Retina

Parameters

inputSize
Type: System.DrawingSize
The input frame size
colorMode
Type: SystemBoolean
Specifies if (true) color is processed of not (false) to then processing gray level image
colorSamplingMethod
Type: Emgu.CV.BioinspiredRetinaColorSamplingMethod
Specifies which kind of color sampling will be used
useRetinaLogSampling
Type: SystemBoolean
Activate retina log sampling, if true, the 2 following parameters can be used
reductionFactor
Type: SystemDouble
Only useful if param useRetinaLogSampling=true, specifies the reduction factor of the output frame (as the center (fovea) is high resolution and corners can be underscaled, then a reduction of the output is allowed without precision leak
samplingStrength
Type: SystemDouble
Only useful if param useRetinaLogSampling=true, specifies the strength of the log scale that is applied
See Also

Reference

Retina Class
Retina Overload
Emgu.CV.Bioinspired Namespace


Retina Properties

The Retina type exposes the following members.

Properties
 | Name | Description
Public property | Parameters | Get or Set the Retina parameters.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina.Parameters Property

RetinaParameters Property

Get or Set the Retina parameters.

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RetinaRetinaParameters Parameters { get; set; }
Public Property Parameters As RetinaRetinaParameters
    Get
    Set
public:
property RetinaRetinaParameters^ Parameters {
    RetinaRetinaParameters^ get ();
    void set (RetinaRetinaParameters^ value);
}
member Parameters : RetinaRetinaParameters with get, set

Property Value

Type: RetinaRetinaParameters
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina Methods

The Retina type exposes the following members.

Methods
 | Name | Description
Public method | ClearBuffers | Clear all retina buffers (equivalent to opening the eyes after a long period of eye close.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associated with the retina model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMagno | Accessors of the motion channel of the retina (models peripheral vision)
Public method | GetParvo | Accessors of the details channel of the retina (models foveal vision)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Method which allows retina to be applied on an input image, after run, encapsulated retina module is ready to deliver its outputs using dedicated acccessors. and
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina.ClearBuffers Method

RetinaClearBuffers Method

Clear all retina buffers (equivalent to opening the eyes after a long period of eye close.

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ClearBuffers()
Public Sub ClearBuffers
public:
void ClearBuffers()
member ClearBuffers : unit -> unit
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina.DisposeObject Method

RetinaDisposeObject Method

Release all unmanaged memory associated with the retina model.

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina.GetMagno Method

RetinaGetMagno Method

Accessors of the motion channel of the retina (models peripheral vision)

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetMagno(
    IOutputArray magno
)
Public Sub GetMagno (
    magno As IOutputArray
)
public:
void GetMagno(
    IOutputArray^ magno
)
member GetMagno :
        magno : IOutputArray -> unit

Parameters

magno
Type: Emgu.CVIOutputArray
The motion channel of the retina.
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina.GetParvo Method

RetinaGetParvo Method

Accessors of the details channel of the retina (models foveal vision)

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetParvo(
    IOutputArray parvo
)
Public Sub GetParvo (
    parvo As IOutputArray
)
public:
void GetParvo(
    IOutputArray^ parvo
)
member GetParvo :
        parvo : IOutputArray -> unit

Parameters

parvo
Type: Emgu.CVIOutputArray
The details channel of the retina.
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina.Run Method

RetinaRun Method

Method which allows retina to be applied on an input image, after run, encapsulated retina module is ready to deliver its outputs using dedicated acccessors. and

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Run(
    IInputArray image
)
Public Sub Run (
    image As IInputArray
)
public:
void Run(
    IInputArray^ image
)
member Run :
        image : IInputArray -> unit

Parameters

image
Type: Emgu.CVIInputArray
The input image to be processed
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace
RetinaGetParvo(IOutputArray)
RetinaGetMagno(IOutputArray)


Retina Fields

The Retina type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Retina Class
Emgu.CV.Bioinspired Namespace


Retina.ColorSamplingMethod Class

RetinaColorSamplingMethod Class

The retina color sampling method.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.BioinspiredRetinaColorSamplingMethod

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ColorSamplingMethod : Enum
Public NotInheritable Class ColorSamplingMethod
    Inherits Enum
public ref class ColorSamplingMethod sealed : public Enum
[<SealedAttribute>]
type ColorSamplingMethod =
    class
        inherit Enum
    end

The RetinaColorSamplingMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ColorBayer | Standard bayer sampling
 | ColorDiagonal | Color sampling is RGBRGBRGB..., line 2 BRGBRGBRG..., line 3, GBRGBRGBR...
 | ColorRandom | Each pixel position is either R, G or B in a random choice
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Bioinspired Namespace


ColorSamplingMethod Methods

The RetinaColorSamplingMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RetinaColorSamplingMethod Class
Emgu.CV.Bioinspired Namespace


ColorSamplingMethod Fields

The RetinaColorSamplingMethod type exposes the following members.

Fields
 | Name | Description
 | ColorBayer | Standard bayer sampling
 | ColorDiagonal | Color sampling is RGBRGBRGB..., line 2 BRGBRGBRG..., line 3, GBRGBRGBR...
 | ColorRandom | Each pixel position is either R, G or B in a random choice
Public field | value__ |
Top
See Also

Reference

RetinaColorSamplingMethod Class
Emgu.CV.Bioinspired Namespace


Retina.ColorSamplingMethod.ColorBayer Field

RetinaColorSamplingMethodColorBayer Field

Standard bayer sampling

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RetinaColorSamplingMethod ColorBayer = 2
Public Const ColorBayer As RetinaColorSamplingMethod = 2
public:
literal RetinaColorSamplingMethod^ ColorBayer = 2
static val mutable ColorBayer: RetinaColorSamplingMethod

Field Value

Type: RetinaColorSamplingMethod
See Also

Reference

RetinaColorSamplingMethod Class
Emgu.CV.Bioinspired Namespace


Retina.ColorSamplingMethod.ColorDiagonal Field

RetinaColorSamplingMethodColorDiagonal Field

Color sampling is RGBRGBRGB..., line 2 BRGBRGBRG..., line 3, GBRGBRGBR...

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RetinaColorSamplingMethod ColorDiagonal = 1
Public Const ColorDiagonal As RetinaColorSamplingMethod = 1
public:
literal RetinaColorSamplingMethod^ ColorDiagonal = 1
static val mutable ColorDiagonal: RetinaColorSamplingMethod

Field Value

Type: RetinaColorSamplingMethod
See Also

Reference

RetinaColorSamplingMethod Class
Emgu.CV.Bioinspired Namespace


Retina.ColorSamplingMethod.ColorRandom Field

RetinaColorSamplingMethodColorRandom Field

Each pixel position is either R, G or B in a random choice

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RetinaColorSamplingMethod ColorRandom = 0
Public Const ColorRandom As RetinaColorSamplingMethod = 0
public:
literal RetinaColorSamplingMethod^ ColorRandom = 0
static val mutable ColorRandom: RetinaColorSamplingMethod

Field Value

Type: RetinaColorSamplingMethod
See Also

Reference

RetinaColorSamplingMethod Class
Emgu.CV.Bioinspired Namespace


Retina.ColorSamplingMethod.value__ Field

RetinaColorSamplingMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Bioinspired.Retina.ColorSamplingMethod.value__"]

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RetinaColorSamplingMethod Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters Class

RetinaIplMagnoParameters Class

Inner Plexiform Layer Magnocellular channel (IplMagno)
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.BioinspiredRetinaIplMagnoParameters

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IplMagnoParameters : ValueType
Public NotInheritable Class IplMagnoParameters
    Inherits ValueType
public ref class IplMagnoParameters sealed : public ValueType
[<SealedAttribute>]
type IplMagnoParameters =
    class
        inherit ValueType
    end

The RetinaIplMagnoParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | AmacrinCellsTemporalCutFrequency | Amacrin cells temporal cut frequency. Use 1.2 for default
Public field | LocalAdaptintegrationK | LocalAdaptintegration_k. Use 7.0 for default
Public field | LocalAdaptintegrationTau | LocalAdaptintegration_tau. Use 0.0 for default
Public field | NormaliseOutput | Normalise output
Public field | ParasolCellsBeta | ParasolCells_beta. Use 0.0 for default
Public field | ParasolCellsK | ParasolCells_k. Use 7.0 for default
Public field | ParasolCellsTau | ParasolCells_tau. Use 0.0 for default
Public field | V0CompressionParameter | V0 compression parameter. Use 0.95 for default
Top
See Also

Reference

Emgu.CV.Bioinspired Namespace


IplMagnoParameters Methods

The RetinaIplMagnoParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


IplMagnoParameters Fields

The RetinaIplMagnoParameters type exposes the following members.

Fields
 | Name | Description
Public field | AmacrinCellsTemporalCutFrequency | Amacrin cells temporal cut frequency. Use 1.2 for default
Public field | LocalAdaptintegrationK | LocalAdaptintegration_k. Use 7.0 for default
Public field | LocalAdaptintegrationTau | LocalAdaptintegration_tau. Use 0.0 for default
Public field | NormaliseOutput | Normalise output
Public field | ParasolCellsBeta | ParasolCells_beta. Use 0.0 for default
Public field | ParasolCellsK | ParasolCells_k. Use 7.0 for default
Public field | ParasolCellsTau | ParasolCells_tau. Use 0.0 for default
Public field | V0CompressionParameter | V0 compression parameter. Use 0.95 for default
Top
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.AmacrinCellsTemporalCutFrequency Field

RetinaIplMagnoParametersAmacrinCellsTemporalCutFrequency Field

http://www.emgu.com
Amacrin cells temporal cut frequency. Use 1.2 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float AmacrinCellsTemporalCutFrequency
Public AmacrinCellsTemporalCutFrequency As Single
public:
float AmacrinCellsTemporalCutFrequency
val mutable AmacrinCellsTemporalCutFrequency: float32

Field Value

Type: Single
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.LocalAdaptintegrationK Field

RetinaIplMagnoParametersLocalAdaptintegrationK Field

LocalAdaptintegration_k. Use 7.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float LocalAdaptintegrationK
Public LocalAdaptintegrationK As Single
public:
float LocalAdaptintegrationK
val mutable LocalAdaptintegrationK: float32

Field Value

Type: Single
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.LocalAdaptintegrationTau Field

RetinaIplMagnoParametersLocalAdaptintegrationTau Field

LocalAdaptintegration_tau. Use 0.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float LocalAdaptintegrationTau
Public LocalAdaptintegrationTau As Single
public:
float LocalAdaptintegrationTau
val mutable LocalAdaptintegrationTau: float32

Field Value

Type: Single
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.NormaliseOutput Field

RetinaIplMagnoParametersNormaliseOutput Field

Normalise output

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool NormaliseOutput
Public NormaliseOutput As Boolean
public:
bool NormaliseOutput
val mutable NormaliseOutput: bool

Field Value

Type: Boolean
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.ParasolCellsBeta Field

RetinaIplMagnoParametersParasolCellsBeta Field

ParasolCells_beta. Use 0.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ParasolCellsBeta
Public ParasolCellsBeta As Single
public:
float ParasolCellsBeta
val mutable ParasolCellsBeta: float32

Field Value

Type: Single
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.ParasolCellsK Field

RetinaIplMagnoParametersParasolCellsK Field

ParasolCells_k. Use 7.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ParasolCellsK
Public ParasolCellsK As Single
public:
float ParasolCellsK
val mutable ParasolCellsK: float32

Field Value

Type: Single
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.ParasolCellsTau Field

RetinaIplMagnoParametersParasolCellsTau Field

ParasolCells_tau. Use 0.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ParasolCellsTau
Public ParasolCellsTau As Single
public:
float ParasolCellsTau
val mutable ParasolCellsTau: float32

Field Value

Type: Single
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.IplMagnoParameters.V0CompressionParameter Field

RetinaIplMagnoParametersV0CompressionParameter Field

V0 compression parameter. Use 0.95 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float V0CompressionParameter
Public V0CompressionParameter As Single
public:
float V0CompressionParameter
val mutable V0CompressionParameter: float32

Field Value

Type: Single
See Also

Reference

RetinaIplMagnoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters Class

RetinaOPLandIplParvoParameters Class

Outer Plexiform Layer (OPL) and Inner Plexiform Layer Parvocellular (IplParvo) parameters
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.BioinspiredRetinaOPLandIplParvoParameters

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class OPLandIplParvoParameters : ValueType
Public NotInheritable Class OPLandIplParvoParameters
    Inherits ValueType
public ref class OPLandIplParvoParameters sealed : public ValueType
[<SealedAttribute>]
type OPLandIplParvoParameters =
    class
        inherit ValueType
    end

The RetinaOPLandIplParvoParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | ColorMode | Specifies if (true) color is processed of not (false) to then processing gray level image
Public field | GanglionCellsSensitivity | Ganglion cells sensitivity. Use 0.7 for default
Public field | HcellsSpatialConstant | Hcells spatial constant. Use 7.0 for default
Public field | HcellsTemporalConstant | Hcells temporal constant. Use 1.0 for default
Public field | HorizontalCellsGain | Horizontal cells gain. Use 0.0 for default
Public field | NormaliseOutput | Normalise output. Use true for default
Public field | PhotoreceptorsLocalAdaptationSensitivity | Photoreceptors local adaptation sensitivity. Use 0.7 for default
Public field | PhotoreceptorsSpatialConstant | Photoreceptors spatial constant. Use 0.53 for default
Public field | PhotoreceptorsTemporalConstant | Photoreceptors temporal constant. Use 0.5 for default
Top
See Also

Reference

Emgu.CV.Bioinspired Namespace


OPLandIplParvoParameters Methods

The RetinaOPLandIplParvoParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


OPLandIplParvoParameters Fields

The RetinaOPLandIplParvoParameters type exposes the following members.

Fields
 | Name | Description
Public field | ColorMode | Specifies if (true) color is processed of not (false) to then processing gray level image
Public field | GanglionCellsSensitivity | Ganglion cells sensitivity. Use 0.7 for default
Public field | HcellsSpatialConstant | Hcells spatial constant. Use 7.0 for default
Public field | HcellsTemporalConstant | Hcells temporal constant. Use 1.0 for default
Public field | HorizontalCellsGain | Horizontal cells gain. Use 0.0 for default
Public field | NormaliseOutput | Normalise output. Use true for default
Public field | PhotoreceptorsLocalAdaptationSensitivity | Photoreceptors local adaptation sensitivity. Use 0.7 for default
Public field | PhotoreceptorsSpatialConstant | Photoreceptors spatial constant. Use 0.53 for default
Public field | PhotoreceptorsTemporalConstant | Photoreceptors temporal constant. Use 0.5 for default
Top
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.ColorMode Field

RetinaOPLandIplParvoParametersColorMode Field

Specifies if (true) color is processed of not (false) to then processing gray level image

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ColorMode
Public ColorMode As Boolean
public:
bool ColorMode
val mutable ColorMode: bool

Field Value

Type: Boolean
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.GanglionCellsSensitivity Field

RetinaOPLandIplParvoParametersGanglionCellsSensitivity Field

Ganglion cells sensitivity. Use 0.7 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float GanglionCellsSensitivity
Public GanglionCellsSensitivity As Single
public:
float GanglionCellsSensitivity
val mutable GanglionCellsSensitivity: float32

Field Value

Type: Single
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.HcellsSpatialConstant Field

RetinaOPLandIplParvoParametersHcellsSpatialConstant Field

Hcells spatial constant. Use 7.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float HcellsSpatialConstant
Public HcellsSpatialConstant As Single
public:
float HcellsSpatialConstant
val mutable HcellsSpatialConstant: float32

Field Value

Type: Single
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.HcellsTemporalConstant Field

RetinaOPLandIplParvoParametersHcellsTemporalConstant Field

Hcells temporal constant. Use 1.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float HcellsTemporalConstant
Public HcellsTemporalConstant As Single
public:
float HcellsTemporalConstant
val mutable HcellsTemporalConstant: float32

Field Value

Type: Single
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.HorizontalCellsGain Field

RetinaOPLandIplParvoParametersHorizontalCellsGain Field

Horizontal cells gain. Use 0.0 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float HorizontalCellsGain
Public HorizontalCellsGain As Single
public:
float HorizontalCellsGain
val mutable HorizontalCellsGain: float32

Field Value

Type: Single
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.NormaliseOutput Field

RetinaOPLandIplParvoParametersNormaliseOutput Field

Normalise output. Use true for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool NormaliseOutput
Public NormaliseOutput As Boolean
public:
bool NormaliseOutput
val mutable NormaliseOutput: bool

Field Value

Type: Boolean
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.PhotoreceptorsLocalAdaptationSensitivity Field

RetinaOPLandIplParvoParametersPhotoreceptorsLocalAdaptationSensitivity Field

http://www.emgu.com
Photoreceptors local adaptation sensitivity. Use 0.7 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float PhotoreceptorsLocalAdaptationSensitivity
Public PhotoreceptorsLocalAdaptationSensitivity As Single
public:
float PhotoreceptorsLocalAdaptationSensitivity
val mutable PhotoreceptorsLocalAdaptationSensitivity: float32

Field Value

Type: Single
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.PhotoreceptorsSpatialConstant Field

RetinaOPLandIplParvoParametersPhotoreceptorsSpatialConstant Field

http://www.emgu.com
Photoreceptors spatial constant. Use 0.53 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float PhotoreceptorsSpatialConstant
Public PhotoreceptorsSpatialConstant As Single
public:
float PhotoreceptorsSpatialConstant
val mutable PhotoreceptorsSpatialConstant: float32

Field Value

Type: Single
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.OPLandIplParvoParameters.PhotoreceptorsTemporalConstant Field

RetinaOPLandIplParvoParametersPhotoreceptorsTemporalConstant Field

http://www.emgu.com
Photoreceptors temporal constant. Use 0.5 for default

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float PhotoreceptorsTemporalConstant
Public PhotoreceptorsTemporalConstant As Single
public:
float PhotoreceptorsTemporalConstant
val mutable PhotoreceptorsTemporalConstant: float32

Field Value

Type: Single
See Also

Reference

RetinaOPLandIplParvoParameters Class
Emgu.CV.Bioinspired Namespace


Retina.RetinaParameters Class

RetinaRetinaParameters Class

Retina parameters
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.BioinspiredRetinaRetinaParameters

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RetinaParameters : ValueType
Public NotInheritable Class RetinaParameters
    Inherits ValueType
public ref class RetinaParameters sealed : public ValueType
[<SealedAttribute>]
type RetinaParameters =
    class
        inherit ValueType
    end

The RetinaRetinaParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | IplMagno | Inner Plexiform Layer Magnocellular channel (IplMagno)
Public field | OPLandIplParvo | Outer Plexiform Layer (OPL) and Inner Plexiform Layer Parvocellular (IplParvo) parameters
Top
See Also

Reference

Emgu.CV.Bioinspired Namespace


RetinaParameters Methods

The RetinaRetinaParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

RetinaRetinaParameters Class
Emgu.CV.Bioinspired Namespace


RetinaParameters Fields

The RetinaRetinaParameters type exposes the following members.

Fields
 | Name | Description
Public field | IplMagno | Inner Plexiform Layer Magnocellular channel (IplMagno)
Public field | OPLandIplParvo | Outer Plexiform Layer (OPL) and Inner Plexiform Layer Parvocellular (IplParvo) parameters
Top
See Also

Reference

RetinaRetinaParameters Class
Emgu.CV.Bioinspired Namespace


Retina.RetinaParameters.IplMagno Field

RetinaRetinaParametersIplMagno Field

Inner Plexiform Layer Magnocellular channel (IplMagno)

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RetinaIplMagnoParameters IplMagno
Public IplMagno As RetinaIplMagnoParameters
public:
RetinaIplMagnoParameters^ IplMagno
val mutable IplMagno: RetinaIplMagnoParameters

Field Value

Type: RetinaIplMagnoParameters
See Also

Reference

RetinaRetinaParameters Class
Emgu.CV.Bioinspired Namespace


Retina.RetinaParameters.OPLandIplParvo Field

RetinaRetinaParametersOPLandIplParvo Field

Outer Plexiform Layer (OPL) and Inner Plexiform Layer Parvocellular (IplParvo) parameters

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RetinaOPLandIplParvoParameters OPLandIplParvo
Public OPLandIplParvo As RetinaOPLandIplParvoParameters
public:
RetinaOPLandIplParvoParameters^ OPLandIplParvo
val mutable OPLandIplParvo: RetinaOPLandIplParvoParameters

Field Value

Type: RetinaOPLandIplParvoParameters
See Also

Reference

RetinaRetinaParameters Class
Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping Class

A wrapper class which allows the tone mapping algorithm of Meylan & al(2007) to be used with OpenCV.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.BioinspiredRetinaFastToneMapping

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RetinaFastToneMapping : SharedPtrObject
Public Class RetinaFastToneMapping
    Inherits SharedPtrObject
public ref class RetinaFastToneMapping : public SharedPtrObject
type RetinaFastToneMapping =
    class
        inherit SharedPtrObject
    end

The RetinaFastToneMapping type exposes the following members.

Constructors
 | Name | Description
Public method | RetinaFastToneMapping | Create a wrapper class which allows the tone mapping algorithm of Meylan & al(2007) to be used with OpenCV.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | ApplyFastToneMapping | Applies a luminance correction (initially High Dynamic Range (HDR) tone mapping)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associated with the RetinaFastToneMapping model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Setup | Updates tone mapping behaviors by adjusting the local luminance computation area
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping Constructor

Create a wrapper class which allows the tone mapping algorithm of Meylan & al(2007) to be used with OpenCV.

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RetinaFastToneMapping(
    Size inputSize
)
Public Sub New (
    inputSize As Size
)
public:
RetinaFastToneMapping(
    Size^ inputSize
)
new :
        inputSize : Size -> RetinaFastToneMapping

Parameters

inputSize
Type: System.DrawingSize
The size of the images to process
See Also

Reference

RetinaFastToneMapping Class
Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping Properties

The RetinaFastToneMapping type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

RetinaFastToneMapping Class
Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping Methods

The RetinaFastToneMapping type exposes the following members.

Methods
 | Name | Description
Public method | ApplyFastToneMapping | Applies a luminance correction (initially High Dynamic Range (HDR) tone mapping)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged memory associated with the RetinaFastToneMapping model. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Setup | Updates tone mapping behaviors by adjusting the local luminance computation area
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RetinaFastToneMapping Class
Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping.ApplyFastToneMapping Method

RetinaFastToneMappingApplyFastToneMapping Method

Applies a luminance correction (initially High Dynamic Range (HDR) tone mapping)

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ApplyFastToneMapping(
    IInputArray inputImage,
    IOutputArray outputToneMappedImage
)
Public Sub ApplyFastToneMapping (
    inputImage As IInputArray,
    outputToneMappedImage As IOutputArray
)
public:
void ApplyFastToneMapping(
    IInputArray^ inputImage,
    IOutputArray^ outputToneMappedImage
)
member ApplyFastToneMapping :
        inputImage : IInputArray *
        outputToneMappedImage : IOutputArray -> unit

Parameters

inputImage
Type: Emgu.CVIInputArray
The input image to process RGB or gray levels
outputToneMappedImage
Type: Emgu.CVIOutputArray
The output tone mapped image
See Also

Reference

RetinaFastToneMapping Class
Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping.DisposeObject Method

RetinaFastToneMappingDisposeObject Method

Release all unmanaged memory associated with the RetinaFastToneMapping model.

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RetinaFastToneMapping Class
Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping.Setup Method

RetinaFastToneMappingSetup Method

Updates tone mapping behaviors by adjusting the local luminance computation area

Namespace: Emgu.CV.Bioinspired
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Setup(
    float photoreceptorsNeighborhoodRadius = 3f,
    float ganglioncellsNeighborhoodRadius = 1f,
    float meanLuminanceModulatorK = 1f
)
Public Sub Setup (
    Optional photoreceptorsNeighborhoodRadius As Single = 3F,
    Optional ganglioncellsNeighborhoodRadius As Single = 1F,
    Optional meanLuminanceModulatorK As Single = 1F
)
public:
void Setup(
    float photoreceptorsNeighborhoodRadius = 3f,
    float ganglioncellsNeighborhoodRadius = 1f,
    float meanLuminanceModulatorK = 1f
)
member Setup :
        ?photoreceptorsNeighborhoodRadius : float32 *
        ?ganglioncellsNeighborhoodRadius : float32 *
        ?meanLuminanceModulatorK : float32
(* Defaults:
        let _photoreceptorsNeighborhoodRadius = defaultArg photoreceptorsNeighborhoodRadius 3f
        let _ganglioncellsNeighborhoodRadius = defaultArg ganglioncellsNeighborhoodRadius 1f
        let _meanLuminanceModulatorK = defaultArg meanLuminanceModulatorK 1f
*)
-> unit

Parameters

photoreceptorsNeighborhoodRadius (Optional)
Type: SystemSingle
The first stage local adaptation area
ganglioncellsNeighborhoodRadius (Optional)
Type: SystemSingle
The second stage local adaptation area
meanLuminanceModulatorK (Optional)
Type: SystemSingle
The factor applied to modulate the meanLuminance information (default is 1, see reference paper)
See Also

Reference

RetinaFastToneMapping Class
Emgu.CV.Bioinspired Namespace


RetinaFastToneMapping Fields

The RetinaFastToneMapping type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

RetinaFastToneMapping Class
Emgu.CV.Bioinspired Namespace


Emgu.CV.Cuda Namespace

NVidia Cuda image processing functions
Classes
 | Class | Description
Public class | AlphaCompTypes | Alpha composite types
Public class | ColumnSumFilter | A vertical 1D box filter.
Public class | CudaBackgroundSubtractorFGD | Background/Foreground Segmentation Algorithm.
Public class | CudaBackgroundSubtractorGMG | Background/Foreground Segmentation Algorithm.
Public class | CudaBackgroundSubtractorMOG | Gaussian Mixture-based Background/Foreground Segmentation Algorithm.
Public class | CudaBackgroundSubtractorMOG2 | Gaussian Mixture-based Background/Foreground Segmentation Algorithm.
Public class | CudaBFMatcher | A Brute force matcher using Cuda
Public class | CudaBoxFilter | Box filter
Public class | CudaBoxMaxFilter | BoxMax filter
Public class | CudaBoxMinFilter | BoxMin filter
Public class | CudaBroxOpticalFlow | Brox optical flow
Public class | CudaCannyEdgeDetector | Cascade Classifier for object detection using Cuda
Public class | CudaCascadeClassifier | Cascade Classifier for object detection using Cuda
Public class | CudaClahe | Contrast Limited Adaptive Histogram Equalization
Public class | CudaConvolution | Base class for convolution (or cross-correlation) operator.
Public class | CudaCornernessCriteria | Base CornernessCriteria class
Public class | CudaDensePyrLKOpticalFlow | PyrLK optical flow
Public class | CudaDerivFilter | A generalized Deriv operator.
Public class | CudaDeviceInfo | The Cuda device information
Public class | CudaDeviceInfoGpuFeature | GPU feature
Public class | CudaDisparityBilateralFilter | Disparity map refinement using joint bilateral filtering given a single color image. Qingxiong Yang, Liang Wang†, Narendra Ahuja http://vision.ai.uiuc.edu/~qyang6/
Public class | CudaFarnebackOpticalFlow | Farneback optical flow
Public class | CudaFastFeatureDetector | A FAST detector using Cuda
Public class | CudaFilter | Base Cuda filter class
Public class | CudaGaussianFilter | Gaussian filter
Public class | CudaGoodFeaturesToTrackDetector | Cuda implementation of GoodFeaturesToTrackDetector
Public class | CudaHarrisCorner | Runs the Harris edge detector on image. Similarly to cvCornerMinEigenVal and cvCornerEigenValsAndVecs, for each pixel it calculates 2x2 gradient covariation matrix M over block_size x block_size neighborhood. Then, it stores det(M) - k*trace(M)^2 to the destination image. Corners in the image can be found as local maxima of the destination image.
Public class | CudaHOG | A HOG descriptor
Public class | CudaHOGDescrFormat | The descriptor format
Public class | CudaHoughCirclesDetector | Base class for circles detector algorithm.
Public class | CudaHoughLinesDetector | Base class for lines detector algorithm.
Public class | CudaHoughSegmentDetector | Base class for line segments detector algorithm.
Public class | CudaImageTColor, TDepth | An CudaImage is very similar to the Emgu.CV.Image except that it is being used for GPU processing
Public class | CudaInvoke | This class wraps the functional calls to the opencv_gpu module
Public class | CudaLaplacianFilter | Laplacian filter
Public class | CudaLinearFilter | Applies arbitrary linear filter to the image. In-place operation is supported. When the aperture is partially outside the image, the function interpolates outlier pixel values from the nearest pixels that is inside the image
Public class | CudaLookUpTable | Gpu look up table
Public class | CudaMinEigenValCorner | Implementation for the minimum eigen value of a 2x2 derivative covariation matrix (the cornerness criteria).
Public class | CudaMorphologyFilter | Morphology filter
Public class | CudaOpticalFlowDualTvl1 | DualTvl1 optical flow
Public class | CudaORBDetector | An ORB detector using Cuda
Public class | CudaSobelFilter | Sobel filter
Public class | CudaSparsePyrLKOpticalFlow | Sparse PyrLK optical flow
Public class | CudaStereoBM | Use Block Matching algorithm to find stereo correspondence
Public class | CudaStereoConstantSpaceBP | A Constant-Space Belief Propagation Algorithm for Stereo Matching. Qingxiong Yang, Liang Wang, Narendra Ahuja. http://vision.ai.uiuc.edu/~qyang6/
Public class | CudaTemplateMatching | Cuda template matching filter.
Public class | CudaVideoReader |
Public class | CudaVideoReaderChromaFormat |
Public class | CudaVideoReaderCodec |
Public class | CudaVideoReaderFormatInfo |
Public class | CudaVideoWriter | Works only under Windows, Supports only H264 video codec and AVI files.
Public class | CudaVideoWriterSurfaceFormat | Surface format
Public class | DemosaicTypes | Bayer Demosaicing (Malvar, He, and Cutler)
Public class | DescriptorMatcher | Descriptor matcher
Public class | Feature2DAsyncExtension | Class that contains extension methods for Feature2DAsync
Public class | GpuMat | A GpuMat, use the generic version if possible. The non generic version is good for use as buffer in stream calls.
Public class | GpuMatTDepth | Similar to CvArray but use GPU for processing
Public class | MedianFilter | median filtering for each point of the source image.
Public class | RowSumFilter | A horizontal 1D box filter.
Public class | ScharrFilter | A vertical or horizontal Scharr operator.
Public class | SeparableLinearFilter | SeparableLinearFilter
Public class | Stream | Encapculates Cuda Stream. Provides interface for async coping. Passed to each function that supports async kernel execution. Reference counting is enabled
Public class | TargetArchs | Gives information about what GPU archs this OpenCV GPU module was compiled for
Public class | VectorOfGpuMat | Wrapped class of the C++ standard vector of GpuMat.
Interfaces
 | Interface | Description
Public interface | ICudaDenseOpticalFlow | Cuda Dense Optical flow
Public interface | ICudaSparseOpticalFlow | Interface to provide access to the cuda::SparseOpticalFlow class.
Public interface | IFeature2DAsync | The feature 2D base class


AlphaCompTypes Class

Alpha composite types
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CudaAlphaCompTypes

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class AlphaCompTypes : Enum
Public NotInheritable Class AlphaCompTypes
    Inherits Enum
public ref class AlphaCompTypes sealed : public Enum
[<SealedAttribute>]
type AlphaCompTypes =
    class
        inherit Enum
    end

The AlphaCompTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Atop | Atop
 | AtopPremul | Atop Premul
 | In | In
 | InPremul | In Premul
 | Out | Out
 | OutPremul | Out Premul
 | Over | Over
 | OverPremul | Over Premul
 | Plus | Plus
 | PlusPremul | Plus Premul
 | Premul | Premul
Public field | value__ |
 | Xor | Xor
 | XorPremul | Xor Premul
Top
See Also

Reference

Emgu.CV.Cuda Namespace


AlphaCompTypes Methods

The AlphaCompTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes Fields

The AlphaCompTypes type exposes the following members.

Fields
 | Name | Description
 | Atop | Atop
 | AtopPremul | Atop Premul
 | In | In
 | InPremul | In Premul
 | Out | Out
 | OutPremul | Out Premul
 | Over | Over
 | OverPremul | Over Premul
 | Plus | Plus
 | PlusPremul | Plus Premul
 | Premul | Premul
Public field | value__ |
 | Xor | Xor
 | XorPremul | Xor Premul
Top
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.Atop Field

AlphaCompTypesAtop Field

Atop

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes Atop = 3
Public Const Atop As AlphaCompTypes = 3
public:
literal AlphaCompTypes^ Atop = 3
static val mutable Atop: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.AtopPremul Field

AlphaCompTypesAtopPremul Field

Atop Premul

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes AtopPremul = 9
Public Const AtopPremul As AlphaCompTypes = 9
public:
literal AlphaCompTypes^ AtopPremul = 9
static val mutable AtopPremul: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.In Field

AlphaCompTypesIn Field

In

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes In = 1
Public Const In As AlphaCompTypes = 1
public:
literal AlphaCompTypes^ In = 1
static val mutable In: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.InPremul Field

AlphaCompTypesInPremul Field

In Premul

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes InPremul = 7
Public Const InPremul As AlphaCompTypes = 7
public:
literal AlphaCompTypes^ InPremul = 7
static val mutable InPremul: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.Out Field

AlphaCompTypesOut Field

Out

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes Out = 2
Public Const Out As AlphaCompTypes = 2
public:
literal AlphaCompTypes^ Out = 2
static val mutable Out: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.OutPremul Field

AlphaCompTypesOutPremul Field

Out Premul

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes OutPremul = 8
Public Const OutPremul As AlphaCompTypes = 8
public:
literal AlphaCompTypes^ OutPremul = 8
static val mutable OutPremul: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.Over Field

AlphaCompTypesOver Field

Over

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes Over = 0
Public Const Over As AlphaCompTypes = 0
public:
literal AlphaCompTypes^ Over = 0
static val mutable Over: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.OverPremul Field

AlphaCompTypesOverPremul Field

Over Premul

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes OverPremul = 6
Public Const OverPremul As AlphaCompTypes = 6
public:
literal AlphaCompTypes^ OverPremul = 6
static val mutable OverPremul: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.Plus Field

AlphaCompTypesPlus Field

Plus

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes Plus = 5
Public Const Plus As AlphaCompTypes = 5
public:
literal AlphaCompTypes^ Plus = 5
static val mutable Plus: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.PlusPremul Field

AlphaCompTypesPlusPremul Field

Plus Premul

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes PlusPremul = 11
Public Const PlusPremul As AlphaCompTypes = 11
public:
literal AlphaCompTypes^ PlusPremul = 11
static val mutable PlusPremul: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.Premul Field

AlphaCompTypesPremul Field

Premul

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes Premul = 12
Public Const Premul As AlphaCompTypes = 12
public:
literal AlphaCompTypes^ Premul = 12
static val mutable Premul: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.value__ Field

AlphaCompTypesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.AlphaCompTypes.value__"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.Xor Field

AlphaCompTypesXor Field

Xor

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes Xor = 4
Public Const Xor As AlphaCompTypes = 4
public:
literal AlphaCompTypes^ Xor = 4
static val mutable Xor: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


AlphaCompTypes.XorPremul Field

AlphaCompTypesXorPremul Field

Xor Premul

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AlphaCompTypes XorPremul = 10
Public Const XorPremul As AlphaCompTypes = 10
public:
literal AlphaCompTypes^ XorPremul = 10
static val mutable XorPremul: AlphaCompTypes

Field Value

Type: AlphaCompTypes
See Also

Reference

AlphaCompTypes Class
Emgu.CV.Cuda Namespace


ColumnSumFilter Class

A vertical 1D box filter.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaColumnSumFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ColumnSumFilter : CudaFilter
Public Class ColumnSumFilter
    Inherits CudaFilter
public ref class ColumnSumFilter : public CudaFilter
type ColumnSumFilter =
    class
        inherit CudaFilter
    end

The ColumnSumFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ColumnSumFilter | Creates a vertical 1D box filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


ColumnSumFilter Constructor

Creates a vertical 1D box filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ColumnSumFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    int ksize,
    int anchor = -1,
    BorderType borderType = 4,
    MCvScalar borderValue = null
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    ksize As Integer,
    Optional anchor As Integer = -1,
    Optional borderType As BorderType = 4,
    Optional borderValue As MCvScalar = Nothing
)
public:
ColumnSumFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    int ksize,
    int anchor = -1,
    BorderType^ borderType = 4,
    MCvScalar^ borderValue = nullptr
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        ksize : int *
        ?anchor : int *
        ?borderType : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _anchor = defaultArg anchor -1
        let _borderType = defaultArg borderType 4
        let _borderValue = defaultArg borderValue null
*)
-> ColumnSumFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
Input image depth.
srcChannels
Type: SystemInt32
Input image channel.
dstDepth
Type: Emgu.CV.CvEnumDepthType
Output image depth.
dstChannels
Type: SystemInt32
Output image channel.
ksize
Type: SystemInt32
Kernel size.
anchor (Optional)
Type: SystemInt32
Anchor point. The default value (-1) means that the anchor is at the kernel center.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
Default border value.
See Also

Reference

ColumnSumFilter Class
Emgu.CV.Cuda Namespace


ColumnSumFilter Properties

The ColumnSumFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

ColumnSumFilter Class
Emgu.CV.Cuda Namespace


ColumnSumFilter Methods

The ColumnSumFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColumnSumFilter Class
Emgu.CV.Cuda Namespace


ColumnSumFilter Fields

The ColumnSumFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

ColumnSumFilter Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorFGD Class

Background/Foreground Segmentation Algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaBackgroundSubtractorFGD

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBackgroundSubtractorFGD : SharedPtrObject
Public Class CudaBackgroundSubtractorFGD
    Inherits SharedPtrObject
public ref class CudaBackgroundSubtractorFGD : public SharedPtrObject
type CudaBackgroundSubtractorFGD =
    class
        inherit SharedPtrObject
    end

The CudaBackgroundSubtractorFGD type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBackgroundSubtractorFGD | Create a Background/Foreground Segmentation model
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Updates the background model
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorFGD Constructor

Create a Background/Foreground Segmentation model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBackgroundSubtractorFGD(
    int Lc = 128,
    int N1c = 15,
    int N2c = 25,
    int Lcc = 64,
    int N1cc = 25,
    int N2cc = 40,
    bool isObjWithoutHoles = true,
    int performMorphing = 1,
    float alpha1 = 0.1f,
    float alpha2 = 0.005f,
    float alpha3 = 0.1f,
    float delta = 2f,
    float T = 0.9f,
    float minArea = 15f
)
Public Sub New (
    Optional Lc As Integer = 128,
    Optional N1c As Integer = 15,
    Optional N2c As Integer = 25,
    Optional Lcc As Integer = 64,
    Optional N1cc As Integer = 25,
    Optional N2cc As Integer = 40,
    Optional isObjWithoutHoles As Boolean = true,
    Optional performMorphing As Integer = 1,
    Optional alpha1 As Single = 0.1F,
    Optional alpha2 As Single = 0.005F,
    Optional alpha3 As Single = 0.1F,
    Optional delta As Single = 2F,
    Optional T As Single = 0.9F,
    Optional minArea As Single = 15F
)
public:
CudaBackgroundSubtractorFGD(
    int Lc = 128,
    int N1c = 15,
    int N2c = 25,
    int Lcc = 64,
    int N1cc = 25,
    int N2cc = 40,
    bool isObjWithoutHoles = true,
    int performMorphing = 1,
    float alpha1 = 0.1f,
    float alpha2 = 0.005f,
    float alpha3 = 0.1f,
    float delta = 2f,
    float T = 0.9f,
    float minArea = 15f
)
new :
        ?Lc : int *
        ?N1c : int *
        ?N2c : int *
        ?Lcc : int *
        ?N1cc : int *
        ?N2cc : int *
        ?isObjWithoutHoles : bool *
        ?performMorphing : int *
        ?alpha1 : float32 *
        ?alpha2 : float32 *
        ?alpha3 : float32 *
        ?delta : float32 *
        ?T : float32 *
        ?minArea : float32
(* Defaults:
        let _Lc = defaultArg Lc 128
        let _N1c = defaultArg N1c 15
        let _N2c = defaultArg N2c 25
        let _Lcc = defaultArg Lcc 64
        let _N1cc = defaultArg N1cc 25
        let _N2cc = defaultArg N2cc 40
        let _isObjWithoutHoles = defaultArg isObjWithoutHoles true
        let _performMorphing = defaultArg performMorphing 1
        let _alpha1 = defaultArg alpha1 0.1f
        let _alpha2 = defaultArg alpha2 0.005f
        let _alpha3 = defaultArg alpha3 0.1f
        let _delta = defaultArg delta 2f
        let _T = defaultArg T 0.9f
        let _minArea = defaultArg minArea 15f
*)
-> CudaBackgroundSubtractorFGD

Parameters

Lc (Optional)
Type: SystemInt32
Quantized levels per 'color' component. Power of two, typically 32, 64 or 128.
N1c (Optional)
Type: SystemInt32
Number of color vectors used to model normal background color variation at a given pixel.
N2c (Optional)
Type: SystemInt32
Used to allow the first N1c vectors to adapt over time to changing background.
Lcc (Optional)
Type: SystemInt32
Quantized levels per 'color co-occurrence' component. Power of two, typically 16, 32 or 64.
N1cc (Optional)
Type: SystemInt32
Number of color co-occurrence vectors used to model normal background color variation at a given pixel.
N2cc (Optional)
Type: SystemInt32
Used to allow the first N1cc vectors to adapt over time to changing background.
isObjWithoutHoles (Optional)
Type: SystemBoolean
If TRUE we ignore holes within foreground blobs. Defaults to TRUE.
performMorphing (Optional)
Type: SystemInt32
These erase one-pixel junk blobs and merge almost-touching blobs. Default value is 1.
alpha1 (Optional)
Type: SystemSingle
Background reference image update parameter
alpha2 (Optional)
Type: SystemSingle
Stat model update parameter. 0.002f ~ 1K frame(~45sec), 0.005 ~ 18sec (if 25fps and absolutely static BG)
alpha3 (Optional)
Type: SystemSingle
start value for alpha parameter (to fast initiate statistic model)
delta (Optional)
Type: SystemSingle
Affects color and color co-occurrence quantization, typically set to 2.
T (Optional)
Type: SystemSingle
T
minArea (Optional)
Type: SystemSingle
Discard foreground blobs whose bounding box is smaller than this threshold.
See Also

Reference

CudaBackgroundSubtractorFGD Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorFGD Properties

The CudaBackgroundSubtractorFGD type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorFGD Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorFGD Methods

The CudaBackgroundSubtractorFGD type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Updates the background model
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaBackgroundSubtractorFGD Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorFGD.Apply Method

CudaBackgroundSubtractorFGDApply Method

Updates the background model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Apply(
    IInputArray frame,
    IOutputArray forgroundMask,
    double learningRate = -1
)
Public Sub Apply (
    frame As IInputArray,
    forgroundMask As IOutputArray,
    Optional learningRate As Double = -1
)
public:
void Apply(
    IInputArray^ frame,
    IOutputArray^ forgroundMask,
    double learningRate = -1
)
member Apply :
        frame : IInputArray *
        forgroundMask : IOutputArray *
        ?learningRate : float
(* Defaults:
        let _learningRate = defaultArg learningRate -1
*)
-> unit

Parameters

frame
Type: Emgu.CVIInputArray
Next video frame.
forgroundMask
Type: Emgu.CVIOutputArray
Output the current forground mask
learningRate (Optional)
Type: SystemDouble
The learning rate, use -1.0f for default value.
See Also

Reference

CudaBackgroundSubtractorFGD Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorFGD.DisposeObject Method

CudaBackgroundSubtractorFGDDisposeObject Method

Release all the unmanaged resource associated with this object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaBackgroundSubtractorFGD Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorFGD Fields

The CudaBackgroundSubtractorFGD type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorFGD Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorGMG Class

Background/Foreground Segmentation Algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaBackgroundSubtractorGMG

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBackgroundSubtractorGMG : SharedPtrObject
Public Class CudaBackgroundSubtractorGMG
    Inherits SharedPtrObject
public ref class CudaBackgroundSubtractorGMG : public SharedPtrObject
type CudaBackgroundSubtractorGMG =
    class
        inherit SharedPtrObject
    end

The CudaBackgroundSubtractorGMG type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBackgroundSubtractorGMG | Create a Background/Foreground Segmentation model
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Updates the background model
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorGMG Constructor

Create a Background/Foreground Segmentation model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBackgroundSubtractorGMG(
    int initializationFrames = 120,
    double decisionThreshold = 0.8
)
Public Sub New (
    Optional initializationFrames As Integer = 120,
    Optional decisionThreshold As Double = 0.8
)
public:
CudaBackgroundSubtractorGMG(
    int initializationFrames = 120,
    double decisionThreshold = 0.8
)
new :
        ?initializationFrames : int *
        ?decisionThreshold : float
(* Defaults:
        let _initializationFrames = defaultArg initializationFrames 120
        let _decisionThreshold = defaultArg decisionThreshold 0.8
*)
-> CudaBackgroundSubtractorGMG

Parameters

initializationFrames (Optional)
Type: SystemInt32
The number of frames used for initialization
decisionThreshold (Optional)
Type: SystemDouble
The decision threshold
See Also

Reference

CudaBackgroundSubtractorGMG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorGMG Properties

The CudaBackgroundSubtractorGMG type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorGMG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorGMG Methods

The CudaBackgroundSubtractorGMG type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Updates the background model
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaBackgroundSubtractorGMG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorGMG.Apply Method

CudaBackgroundSubtractorGMGApply Method

Updates the background model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Apply(
    IInputArray frame,
    IOutputArray foregroundMask,
    double learningRate = -1,
    Stream stream = null
)
Public Sub Apply (
    frame As IInputArray,
    foregroundMask As IOutputArray,
    Optional learningRate As Double = -1,
    Optional stream As Stream = Nothing
)
public:
void Apply(
    IInputArray^ frame,
    IOutputArray^ foregroundMask,
    double learningRate = -1,
    Stream^ stream = nullptr
)
member Apply :
        frame : IInputArray *
        foregroundMask : IOutputArray *
        ?learningRate : float *
        ?stream : Stream
(* Defaults:
        let _learningRate = defaultArg learningRate -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

frame
Type: Emgu.CVIInputArray
Next video frame.
foregroundMask
Type: Emgu.CVIOutputArray
The output foreground mask as an 8-bit binary image.
learningRate (Optional)
Type: SystemDouble
The learning rate, use -1.0f for default value.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaBackgroundSubtractorGMG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorGMG.DisposeObject Method

CudaBackgroundSubtractorGMGDisposeObject Method

Release all the unmanaged resource associated with this object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaBackgroundSubtractorGMG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorGMG Fields

The CudaBackgroundSubtractorGMG type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorGMG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG Class

Gaussian Mixture-based Background/Foreground Segmentation Algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaBackgroundSubtractorMOG

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBackgroundSubtractorMOG : SharedPtrObject,
    IBackgroundSubtractor, IAlgorithm
Public Class CudaBackgroundSubtractorMOG
    Inherits SharedPtrObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class CudaBackgroundSubtractorMOG : public SharedPtrObject,
    IBackgroundSubtractor, IAlgorithm
type CudaBackgroundSubtractorMOG =
    class
        inherit SharedPtrObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The CudaBackgroundSubtractorMOG type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBackgroundSubtractorMOG | Create a Gaussian Mixture-based Background/Foreground Segmentation model
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the background model
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG Constructor

Create a Gaussian Mixture-based Background/Foreground Segmentation model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBackgroundSubtractorMOG(
    int history = 200,
    int nMixtures = 4,
    double backgroundRatio = 0.7,
    double noiseSigma = 0
)
Public Sub New (
    Optional history As Integer = 200,
    Optional nMixtures As Integer = 4,
    Optional backgroundRatio As Double = 0.7,
    Optional noiseSigma As Double = 0
)
public:
CudaBackgroundSubtractorMOG(
    int history = 200,
    int nMixtures = 4,
    double backgroundRatio = 0.7,
    double noiseSigma = 0
)
new :
        ?history : int *
        ?nMixtures : int *
        ?backgroundRatio : float *
        ?noiseSigma : float
(* Defaults:
        let _history = defaultArg history 200
        let _nMixtures = defaultArg nMixtures 4
        let _backgroundRatio = defaultArg backgroundRatio 0.7
        let _noiseSigma = defaultArg noiseSigma 0
*)
-> CudaBackgroundSubtractorMOG

Parameters

history (Optional)
Type: SystemInt32
Length of the history.
nMixtures (Optional)
Type: SystemInt32
Number of Gaussian mixtures.
backgroundRatio (Optional)
Type: SystemDouble
Background ratio.
noiseSigma (Optional)
Type: SystemDouble
Noise strength (standard deviation of the brightness or each color channel). 0 means some automatic value.
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG Properties

The CudaBackgroundSubtractorMOG type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG.AlgorithmPtr Property

CudaBackgroundSubtractorMOGAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG.BackgroundSubtractorPtr Property

CudaBackgroundSubtractorMOGBackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG Methods

The CudaBackgroundSubtractorMOG type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the background model
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG.DisposeObject Method

CudaBackgroundSubtractorMOGDisposeObject Method

Release all the unmanaged resource associated with this object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG.Update Method

CudaBackgroundSubtractorMOGUpdate Method

Updates the background model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    IInputArray frame,
    IOutputArray foregroundMask,
    double learningRate,
    Stream stream = null
)
Public Sub Update (
    frame As IInputArray,
    foregroundMask As IOutputArray,
    learningRate As Double,
    Optional stream As Stream = Nothing
)
public:
void Update(
    IInputArray^ frame,
    IOutputArray^ foregroundMask,
    double learningRate,
    Stream^ stream = nullptr
)
member Update :
        frame : IInputArray *
        foregroundMask : IOutputArray *
        learningRate : float *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

frame
Type: Emgu.CVIInputArray
Next video frame.
foregroundMask
Type: Emgu.CVIOutputArray
The foregroundMask
learningRate
Type: SystemDouble
The learning rate, use -1.0f for default value.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG Fields

The CudaBackgroundSubtractorMOG type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorMOG Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2 Class

Gaussian Mixture-based Background/Foreground Segmentation Algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaBackgroundSubtractorMOG2

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBackgroundSubtractorMOG2 : SharedPtrObject,
    IBackgroundSubtractor, IAlgorithm
Public Class CudaBackgroundSubtractorMOG2
    Inherits SharedPtrObject
    Implements IBackgroundSubtractor, IAlgorithm
public ref class CudaBackgroundSubtractorMOG2 : public SharedPtrObject,
    IBackgroundSubtractor, IAlgorithm
type CudaBackgroundSubtractorMOG2 =
    class
        inherit SharedPtrObject
        interface IBackgroundSubtractor
        interface IAlgorithm
    end

The CudaBackgroundSubtractorMOG2 type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBackgroundSubtractorMOG2 | Create a Gaussian Mixture-based Background/Foreground Segmentation model
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the background model
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2 Constructor

Create a Gaussian Mixture-based Background/Foreground Segmentation model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBackgroundSubtractorMOG2(
    int history = 500,
    double varThreshold = 16,
    bool detectShadows = true
)
Public Sub New (
    Optional history As Integer = 500,
    Optional varThreshold As Double = 16,
    Optional detectShadows As Boolean = true
)
public:
CudaBackgroundSubtractorMOG2(
    int history = 500,
    double varThreshold = 16,
    bool detectShadows = true
)
new :
        ?history : int *
        ?varThreshold : float *
        ?detectShadows : bool
(* Defaults:
        let _history = defaultArg history 500
        let _varThreshold = defaultArg varThreshold 16
        let _detectShadows = defaultArg detectShadows true
*)
-> CudaBackgroundSubtractorMOG2

Parameters

history (Optional)
Type: SystemInt32
Length of the history.
varThreshold (Optional)
Type: SystemDouble
Threshold on the squared Mahalanobis distance between the pixel and the model to decide whether a pixel is well described by the background model. This parameter does not affect the background update.
detectShadows (Optional)
Type: SystemBoolean
If true, the algorithm will detect shadows and mark them. It decreases the speed a bit, so if you do not need this feature, set the parameter to false.
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2 Properties

The CudaBackgroundSubtractorMOG2 type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | BackgroundSubtractorPtr | Pointer to the unmanaged BackgroundSubtractor object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2.AlgorithmPtr Property

CudaBackgroundSubtractorMOG2AlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2.BackgroundSubtractorPtr Property

CudaBackgroundSubtractorMOG2BackgroundSubtractorPtr Property

Pointer to the unmanaged BackgroundSubtractor object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BackgroundSubtractorPtr { get; }
Public ReadOnly Property BackgroundSubtractorPtr As IntPtr
    Get
public:
virtual property IntPtr BackgroundSubtractorPtr {
    IntPtr get () sealed;
}
abstract BackgroundSubtractorPtr : IntPtr with get
override BackgroundSubtractorPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IBackgroundSubtractorBackgroundSubtractorPtr
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2 Methods

The CudaBackgroundSubtractorMOG2 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the background model
Top
Extension Methods
 | Name | Description
Public Extension Method | Apply | Update the background model (Defined by BackgroundSubtractorExtension.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetBackgroundImage | Computes a background image. (Defined by BackgroundSubtractorExtension.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2.DisposeObject Method

CudaBackgroundSubtractorMOG2DisposeObject Method

Release all the unmanaged resource associated with this object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2.Update Method

CudaBackgroundSubtractorMOG2Update Method

Updates the background model

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    IInputArray frame,
    IOutputArray fgmask,
    double learningRate,
    Stream stream = null
)
Public Sub Update (
    frame As IInputArray,
    fgmask As IOutputArray,
    learningRate As Double,
    Optional stream As Stream = Nothing
)
public:
void Update(
    IInputArray^ frame,
    IOutputArray^ fgmask,
    double learningRate,
    Stream^ stream = nullptr
)
member Update :
        frame : IInputArray *
        fgmask : IOutputArray *
        learningRate : float *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

frame
Type: Emgu.CVIInputArray
Next video frame.
fgmask
Type: Emgu.CVIOutputArray
The output forground mask
learningRate
Type: SystemDouble
The learning rate, use -1.0f for default value.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBackgroundSubtractorMOG2 Fields

The CudaBackgroundSubtractorMOG2 type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBackgroundSubtractorMOG2 Class
Emgu.CV.Cuda Namespace


CudaBFMatcher Class

A Brute force matcher using Cuda
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaDescriptorMatcher
Emgu.CV.CudaCudaBFMatcher

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBFMatcher : DescriptorMatcher
Public Class CudaBFMatcher
    Inherits DescriptorMatcher
public ref class CudaBFMatcher : public DescriptorMatcher
type CudaBFMatcher =
    class
        inherit DescriptorMatcher
    end

The CudaBFMatcher type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBFMatcher | Create a CudaBruteForceMatcher using the specific distance type
Top
Properties
 | Name | Description
Public property | Empty | Return True if the matcher is empty (Inherited from DescriptorMatcher.)
Public property | IsMaskSupported | Return True if mask is supported (Inherited from DescriptorMatcher.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Add | Add the model descriptors (Inherited from DescriptorMatcher.)
Public method | Clear | Clear the matcher (Inherited from DescriptorMatcher.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this matcher (Inherited from DescriptorMatcher.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, VectorOfGpuMat, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatchAsync(IInputArray, IOutputArray, Int32, VectorOfGpuMat, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | KnnMatchAsync(IInputArray, IInputArray, IOutputArray, Int32, IInputArray, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | KnnMatchConvert | Converts matches array from internal representation to standard matches vector. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, VectorOfDMatch, VectorOfGpuMat) | Finds the best match for each descriptor from a query set (blocking version). (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set (blocking version). (Inherited from DescriptorMatcher.)
Public method | MatchAsync(IInputArray, IOutputArray, VectorOfGpuMat, Stream) | Finds the best match for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | MatchAsync(IInputArray, IInputArray, IOutputArray, IInputArray, Stream) | Finds the best match for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | MatchConvert | Converts matches array from internal representation to standard matches vector. (Inherited from DescriptorMatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, VectorOfGpuMat, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatchAsync(IInputArray, IOutputArray, Single, VectorOfGpuMat, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatchAsync(IInputArray, IInputArray, IOutputArray, Single, IInputArray, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatchConvert | Converts matches array from internal representation to standard matches vector. (Inherited from DescriptorMatcher.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher. (Inherited from DescriptorMatcher.)
Top
Fields
 | Name | Description
Protected field | _algorithmPtr | Pointer to the native cv::Algorithm (Inherited from DescriptorMatcher.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBFMatcher Constructor

Create a CudaBruteForceMatcher using the specific distance type

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBFMatcher(
    DistanceType distanceType
)
Public Sub New (
    distanceType As DistanceType
)
public:
CudaBFMatcher(
    DistanceType^ distanceType
)
new :
        distanceType : DistanceType -> CudaBFMatcher

Parameters

distanceType
Type: Emgu.CV.Features2DDistanceType
The distance type
See Also

Reference

CudaBFMatcher Class
Emgu.CV.Cuda Namespace


CudaBFMatcher Properties

The CudaBFMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Empty | Return True if the matcher is empty (Inherited from DescriptorMatcher.)
Public property | IsMaskSupported | Return True if mask is supported (Inherited from DescriptorMatcher.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBFMatcher Class
Emgu.CV.Cuda Namespace


CudaBFMatcher Methods

The CudaBFMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add the model descriptors (Inherited from DescriptorMatcher.)
Public method | Clear | Clear the matcher (Inherited from DescriptorMatcher.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this matcher (Inherited from DescriptorMatcher.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, VectorOfGpuMat, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatchAsync(IInputArray, IOutputArray, Int32, VectorOfGpuMat, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | KnnMatchAsync(IInputArray, IInputArray, IOutputArray, Int32, IInputArray, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | KnnMatchConvert | Converts matches array from internal representation to standard matches vector. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, VectorOfDMatch, VectorOfGpuMat) | Finds the best match for each descriptor from a query set (blocking version). (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set (blocking version). (Inherited from DescriptorMatcher.)
Public method | MatchAsync(IInputArray, IOutputArray, VectorOfGpuMat, Stream) | Finds the best match for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | MatchAsync(IInputArray, IInputArray, IOutputArray, IInputArray, Stream) | Finds the best match for each descriptor from a query set (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | MatchConvert | Converts matches array from internal representation to standard matches vector. (Inherited from DescriptorMatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, VectorOfGpuMat, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatchAsync(IInputArray, IOutputArray, Single, VectorOfGpuMat, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatchAsync(IInputArray, IInputArray, IOutputArray, Single, IInputArray, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version). (Inherited from DescriptorMatcher.)
Public method | RadiusMatchConvert | Converts matches array from internal representation to standard matches vector. (Inherited from DescriptorMatcher.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher. (Inherited from DescriptorMatcher.)
Top
See Also

Reference

CudaBFMatcher Class
Emgu.CV.Cuda Namespace


CudaBFMatcher Fields

The CudaBFMatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithmPtr | Pointer to the native cv::Algorithm (Inherited from DescriptorMatcher.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBFMatcher Class
Emgu.CV.Cuda Namespace


CudaBoxFilter Class

Box filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaBoxFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBoxFilter : CudaFilter
Public Class CudaBoxFilter
    Inherits CudaFilter
public ref class CudaBoxFilter : public CudaFilter
type CudaBoxFilter =
    class
        inherit CudaFilter
    end

The CudaBoxFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBoxFilter | Create a BoxMax filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBoxFilter Constructor

Create a BoxMax filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBoxFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    Size ksize,
    Point anchor,
    BorderType borderType = 4,
    MCvScalar borderValue = null
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    ksize As Size,
    anchor As Point,
    Optional borderType As BorderType = 4,
    Optional borderValue As MCvScalar = Nothing
)
public:
CudaBoxFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    Size^ ksize,
    Point^ anchor,
    BorderType^ borderType = 4,
    MCvScalar^ borderValue = nullptr
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        ksize : Size *
        anchor : Point *
        ?borderType : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _borderType = defaultArg borderType 4
        let _borderValue = defaultArg borderValue null
*)
-> CudaBoxFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The source image depth type
srcChannels
Type: SystemInt32
The number of channels in the source image
dstDepth
Type: Emgu.CV.CvEnumDepthType
The destination image depth type
dstChannels
Type: SystemInt32
The number of channels in the destination image
ksize
Type: System.DrawingSize
Size of the kernel
anchor
Type: System.DrawingPoint
The center of the kernel. User (-1, -1) for the default kernel center.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The border type.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The border value.
See Also

Reference

CudaBoxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxFilter Properties

The CudaBoxFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBoxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxFilter Methods

The CudaBoxFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaBoxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxFilter Fields

The CudaBoxFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBoxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMaxFilter Class

BoxMax filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaBoxMaxFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBoxMaxFilter : CudaFilter
Public Class CudaBoxMaxFilter
    Inherits CudaFilter
public ref class CudaBoxMaxFilter : public CudaFilter
type CudaBoxMaxFilter =
    class
        inherit CudaFilter
    end

The CudaBoxMaxFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBoxMaxFilter | Create a BoxMax filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBoxMaxFilter Constructor

Create a BoxMax filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBoxMaxFilter(
    DepthType srcDepth,
    int srcChannels,
    Size ksize,
    Point anchor,
    BorderType borderType = 4,
    MCvScalar borderValue = null
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    ksize As Size,
    anchor As Point,
    Optional borderType As BorderType = 4,
    Optional borderValue As MCvScalar = Nothing
)
public:
CudaBoxMaxFilter(
    DepthType^ srcDepth,
    int srcChannels,
    Size^ ksize,
    Point^ anchor,
    BorderType^ borderType = 4,
    MCvScalar^ borderValue = nullptr
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        ksize : Size *
        anchor : Point *
        ?borderType : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _borderType = defaultArg borderType 4
        let _borderValue = defaultArg borderValue null
*)
-> CudaBoxMaxFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the source image
srcChannels
Type: SystemInt32
The number of channels of the source image
ksize
Type: System.DrawingSize
Size of the kernel
anchor
Type: System.DrawingPoint
The center of the kernel. User (-1, -1) for the default kernel center.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The border type.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The border value.
See Also

Reference

CudaBoxMaxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMaxFilter Properties

The CudaBoxMaxFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBoxMaxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMaxFilter Methods

The CudaBoxMaxFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaBoxMaxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMaxFilter Fields

The CudaBoxMaxFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBoxMaxFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMinFilter Class

BoxMin filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaBoxMinFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBoxMinFilter : CudaFilter
Public Class CudaBoxMinFilter
    Inherits CudaFilter
public ref class CudaBoxMinFilter : public CudaFilter
type CudaBoxMinFilter =
    class
        inherit CudaFilter
    end

The CudaBoxMinFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBoxMinFilter | Create a BoxMin filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBoxMinFilter Constructor

Create a BoxMin filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBoxMinFilter(
    DepthType srcDepth,
    int srcChannels,
    Size ksize,
    Point anchor,
    BorderType borderType = 4,
    MCvScalar borderValue = null
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    ksize As Size,
    anchor As Point,
    Optional borderType As BorderType = 4,
    Optional borderValue As MCvScalar = Nothing
)
public:
CudaBoxMinFilter(
    DepthType^ srcDepth,
    int srcChannels,
    Size^ ksize,
    Point^ anchor,
    BorderType^ borderType = 4,
    MCvScalar^ borderValue = nullptr
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        ksize : Size *
        anchor : Point *
        ?borderType : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _borderType = defaultArg borderType 4
        let _borderValue = defaultArg borderValue null
*)
-> CudaBoxMinFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth of the source image
srcChannels
Type: SystemInt32
The number of channels in the source image
ksize
Type: System.DrawingSize
Size of the kernel
anchor
Type: System.DrawingPoint
The center of the kernel. User (-1, -1) for the default kernel center.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The border type.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The border value.
See Also

Reference

CudaBoxMinFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMinFilter Properties

The CudaBoxMinFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBoxMinFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMinFilter Methods

The CudaBoxMinFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaBoxMinFilter Class
Emgu.CV.Cuda Namespace


CudaBoxMinFilter Fields

The CudaBoxMinFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBoxMinFilter Class
Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow Class

Brox optical flow
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaBroxOpticalFlow

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaBroxOpticalFlow : SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
Public Class CudaBroxOpticalFlow
    Inherits SharedPtrObject
    Implements ICudaDenseOpticalFlow, IAlgorithm
public ref class CudaBroxOpticalFlow : public SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
type CudaBroxOpticalFlow =
    class
        inherit SharedPtrObject
        interface ICudaDenseOpticalFlow
        interface IAlgorithm
    end

The CudaBroxOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | CudaBroxOpticalFlow | Create the Brox optical flow solver
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow Constructor

Create the Brox optical flow solver

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaBroxOpticalFlow(
    double alpha = 0.197,
    double gamma = 50,
    double scaleFactor = 0.8,
    int innerIterations = 5,
    int outerIterations = 150,
    int solverIterations = 10
)
Public Sub New (
    Optional alpha As Double = 0.197,
    Optional gamma As Double = 50,
    Optional scaleFactor As Double = 0.8,
    Optional innerIterations As Integer = 5,
    Optional outerIterations As Integer = 150,
    Optional solverIterations As Integer = 10
)
public:
CudaBroxOpticalFlow(
    double alpha = 0.197,
    double gamma = 50,
    double scaleFactor = 0.8,
    int innerIterations = 5,
    int outerIterations = 150,
    int solverIterations = 10
)
new :
        ?alpha : float *
        ?gamma : float *
        ?scaleFactor : float *
        ?innerIterations : int *
        ?outerIterations : int *
        ?solverIterations : int
(* Defaults:
        let _alpha = defaultArg alpha 0.197
        let _gamma = defaultArg gamma 50
        let _scaleFactor = defaultArg scaleFactor 0.8
        let _innerIterations = defaultArg innerIterations 5
        let _outerIterations = defaultArg outerIterations 150
        let _solverIterations = defaultArg solverIterations 10
*)
-> CudaBroxOpticalFlow

Parameters

alpha (Optional)
Type: SystemDouble
Flow smoothness
gamma (Optional)
Type: SystemDouble
Gradient constancy importance
scaleFactor (Optional)
Type: SystemDouble
Pyramid scale factor
innerIterations (Optional)
Type: SystemInt32
Number of lagged non-linearity iterations (inner loop)
outerIterations (Optional)
Type: SystemInt32
Number of warping iterations (number of pyramid levels)
solverIterations (Optional)
Type: SystemInt32
Number of linear system solver iterations
See Also

Reference

CudaBroxOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow Properties

The CudaBroxOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBroxOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow.AlgorithmPtr Property

CudaBroxOpticalFlowAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

CudaBroxOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow.DenseOpticalFlowPtr Property

CudaBroxOpticalFlowDenseOpticalFlowPtr Property

Pointer to the unmanaged DenseOpticalFlow object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ICudaDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

CudaBroxOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow Methods

The CudaBroxOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

CudaBroxOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow.DisposeObject Method

CudaBroxOpticalFlowDisposeObject Method

Release all the unmanaged memory associated with this optical flow solver.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaBroxOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaBroxOpticalFlow Fields

The CudaBroxOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaBroxOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaCannyEdgeDetector Class

Cascade Classifier for object detection using Cuda
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaCannyEdgeDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaCannyEdgeDetector : SharedPtrObject
Public Class CudaCannyEdgeDetector
    Inherits SharedPtrObject
public ref class CudaCannyEdgeDetector : public SharedPtrObject
type CudaCannyEdgeDetector =
    class
        inherit SharedPtrObject
    end

The CudaCannyEdgeDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CudaCannyEdgeDetector | Canny edge detector using Cuda.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Detect | Finds the edges on the input src and marks them in the output image edges using the Canny algorithm.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this Canny edge detector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaCannyEdgeDetector Constructor

Canny edge detector using Cuda.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaCannyEdgeDetector(
    double lowThreshold,
    double highThreshold,
    int apertureSize = 3,
    bool L2gradient = false
)
Public Sub New (
    lowThreshold As Double,
    highThreshold As Double,
    Optional apertureSize As Integer = 3,
    Optional L2gradient As Boolean = false
)
public:
CudaCannyEdgeDetector(
    double lowThreshold,
    double highThreshold,
    int apertureSize = 3,
    bool L2gradient = false
)
new :
        lowThreshold : float *
        highThreshold : float *
        ?apertureSize : int *
        ?L2gradient : bool
(* Defaults:
        let _apertureSize = defaultArg apertureSize 3
        let _L2gradient = defaultArg L2gradient false
*)
-> CudaCannyEdgeDetector

Parameters

lowThreshold
Type: SystemDouble
The first threshold, used for edge linking
highThreshold
Type: SystemDouble
The second threshold, used to find initial segments of strong edges
apertureSize (Optional)
Type: SystemInt32
Aperture parameter for Sobel operator, use 3 for default
L2gradient (Optional)
Type: SystemBoolean
Use false for default
See Also

Reference

CudaCannyEdgeDetector Class
Emgu.CV.Cuda Namespace


CudaCannyEdgeDetector Properties

The CudaCannyEdgeDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaCannyEdgeDetector Class
Emgu.CV.Cuda Namespace


CudaCannyEdgeDetector Methods

The CudaCannyEdgeDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Finds the edges on the input src and marks them in the output image edges using the Canny algorithm.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this Canny edge detector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaCannyEdgeDetector Class
Emgu.CV.Cuda Namespace


CudaCannyEdgeDetector.Detect Method

CudaCannyEdgeDetectorDetect Method

Finds the edges on the input src and marks them in the output image edges using the Canny algorithm.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Detect(
    IInputArray src,
    IOutputArray edges,
    Stream stream = null
)
Public Sub Detect (
    src As IInputArray,
    edges As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Detect(
    IInputArray^ src,
    IOutputArray^ edges,
    Stream^ stream = nullptr
)
member Detect :
        src : IInputArray *
        edges : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input image
edges
Type: Emgu.CVIOutputArray
Image to store the edges found by the function
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaCannyEdgeDetector Class
Emgu.CV.Cuda Namespace


CudaCannyEdgeDetector.DisposeObject Method

CudaCannyEdgeDetectorDisposeObject Method

Release all the unmanaged memory associate with this Canny edge detector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaCannyEdgeDetector Class
Emgu.CV.Cuda Namespace


CudaCannyEdgeDetector Fields

The CudaCannyEdgeDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaCannyEdgeDetector Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier Class

Cascade Classifier for object detection using Cuda
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaCascadeClassifier

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaCascadeClassifier : SharedPtrObject
Public Class CudaCascadeClassifier
    Inherits SharedPtrObject
public ref class CudaCascadeClassifier : public SharedPtrObject
type CudaCascadeClassifier =
    class
        inherit SharedPtrObject
    end

The CudaCascadeClassifier type exposes the following members.

Constructors
 | Name | Description
Public method | CudaCascadeClassifier(String) | Create a Cuda cascade classifier using the specific file
Public method | CudaCascadeClassifier(FileStorage) | Create a Cuda cascade classifier using the specific file storage
Top
Properties
 | Name | Description
Public property | ClassifierSize | The classifier size
Public property | FindLargestObject | If true, only return the largest object
Public property | MaxNumObjects | The maximum number of objects
Public property | MaxObjectSize | The maximum object size
Public property | MinNeighbors | Parameter specifying how many neighbors each candidate rectangle should have to retain it
Public property | MinObjectSize | The minimum object size
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ScaleFactor | Parameter specifying how much the image size is reduced at each image scale
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Convert | Converts objects array from internal representation to standard vector.
Public method | DetectMultiScale | Detects objects of different sizes in the input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged resources associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaCascadeClassifier Constructor

Overload List
 | Name | Description
Public method | CudaCascadeClassifier(String) | Create a Cuda cascade classifier using the specific file
Public method | CudaCascadeClassifier(FileStorage) | Create a Cuda cascade classifier using the specific file storage
Top
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier Constructor (String)

Create a Cuda cascade classifier using the specific file

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaCascadeClassifier(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
CudaCascadeClassifier(
    String^ fileName
)
new :
        fileName : string -> CudaCascadeClassifier

Parameters

fileName
Type: SystemString
The file to create the classifier from
See Also

Reference

CudaCascadeClassifier Class
CudaCascadeClassifier Overload
Emgu.CV.Cuda Namespace


CudaCascadeClassifier Constructor (FileStorage)

Create a Cuda cascade classifier using the specific file storage

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaCascadeClassifier(
    FileStorage fs
)
Public Sub New (
    fs As FileStorage
)
public:
CudaCascadeClassifier(
    FileStorage^ fs
)
new :
        fs : FileStorage -> CudaCascadeClassifier

Parameters

fs
Type: Emgu.CVFileStorage
The file storage to create the classifier from
See Also

Reference

CudaCascadeClassifier Class
CudaCascadeClassifier Overload
Emgu.CV.Cuda Namespace


CudaCascadeClassifier Properties

The CudaCascadeClassifier type exposes the following members.

Properties
 | Name | Description
Public property | ClassifierSize | The classifier size
Public property | FindLargestObject | If true, only return the largest object
Public property | MaxNumObjects | The maximum number of objects
Public property | MaxObjectSize | The maximum object size
Public property | MinNeighbors | Parameter specifying how many neighbors each candidate rectangle should have to retain it
Public property | MinObjectSize | The minimum object size
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ScaleFactor | Parameter specifying how much the image size is reduced at each image scale
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.ClassifierSize Property

CudaCascadeClassifierClassifierSize Property

The classifier size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size ClassifierSize { get; }
Public ReadOnly Property ClassifierSize As Size
    Get
public:
property Size^ ClassifierSize {
    Size^ get ();
}
member ClassifierSize : Size with get

Property Value

Type: Size
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.FindLargestObject Property

CudaCascadeClassifierFindLargestObject Property

If true, only return the largest object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FindLargestObject { get; set; }
Public Property FindLargestObject As Boolean
    Get
    Set
public:
property bool FindLargestObject {
    bool get ();
    void set (bool value);
}
member FindLargestObject : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.MaxNumObjects Property

CudaCascadeClassifierMaxNumObjects Property

The maximum number of objects

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxNumObjects { get; set; }
Public Property MaxNumObjects As Integer
    Get
    Set
public:
property int MaxNumObjects {
    int get ();
    void set (int value);
}
member MaxNumObjects : int with get, set

Property Value

Type: Int32
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.MaxObjectSize Property

CudaCascadeClassifierMaxObjectSize Property

The maximum object size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size MaxObjectSize { get; set; }
Public Property MaxObjectSize As Size
    Get
    Set
public:
property Size^ MaxObjectSize {
    Size^ get ();
    void set (Size^ value);
}
member MaxObjectSize : Size with get, set

Property Value

Type: Size
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.MinNeighbors Property

CudaCascadeClassifierMinNeighbors Property

Parameter specifying how many neighbors each candidate rectangle should have to retain it

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MinNeighbors { get; set; }
Public Property MinNeighbors As Integer
    Get
    Set
public:
property int MinNeighbors {
    int get ();
    void set (int value);
}
member MinNeighbors : int with get, set

Property Value

Type: Int32
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.MinObjectSize Property

CudaCascadeClassifierMinObjectSize Property

The minimum object size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size MinObjectSize { get; set; }
Public Property MinObjectSize As Size
    Get
    Set
public:
property Size^ MinObjectSize {
    Size^ get ();
    void set (Size^ value);
}
member MinObjectSize : Size with get, set

Property Value

Type: Size
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.ScaleFactor Property

CudaCascadeClassifierScaleFactor Property

Parameter specifying how much the image size is reduced at each image scale

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ScaleFactor { get; set; }
Public Property ScaleFactor As Double
    Get
    Set
public:
property double ScaleFactor {
    double get ();
    void set (double value);
}
member ScaleFactor : float with get, set

Property Value

Type: Double
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier Methods

The CudaCascadeClassifier type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts objects array from internal representation to standard vector.
Public method | DetectMultiScale | Detects objects of different sizes in the input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged resources associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.Convert Method

CudaCascadeClassifierConvert Method

Converts objects array from internal representation to standard vector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle[] Convert(
    IOutputArray objects
)
Public Function Convert (
    objects As IOutputArray
) As Rectangle()
public:
array<Rectangle^>^ Convert(
    IOutputArray^ objects
)
member Convert :
        objects : IOutputArray -> Rectangle[]

Parameters

objects
Type: Emgu.CVIOutputArray
Objects array in internal representation.

Return Value

Type: Rectangle
Resulting array.
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.DetectMultiScale Method

CudaCascadeClassifierDetectMultiScale Method

Detects objects of different sizes in the input image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DetectMultiScale(
    IInputArray image,
    IOutputArray objects,
    Stream stream = null
)
Public Sub DetectMultiScale (
    image As IInputArray,
    objects As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void DetectMultiScale(
    IInputArray^ image,
    IOutputArray^ objects,
    Stream^ stream = nullptr
)
member DetectMultiScale :
        image : IInputArray *
        objects : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Matrix of type CV_8U containing an image where objects should be detected.
objects
Type: Emgu.CVIOutputArray
Buffer to store detected objects (rectangles).
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier.DisposeObject Method

CudaCascadeClassifierDisposeObject Method

Release all unmanaged resources associated with this object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaCascadeClassifier Fields

The CudaCascadeClassifier type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaCascadeClassifier Class
Emgu.CV.Cuda Namespace


CudaClahe Class

Contrast Limited Adaptive Histogram Equalization
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaClahe

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaClahe : SharedPtrObject
Public Class CudaClahe
    Inherits SharedPtrObject
public ref class CudaClahe : public SharedPtrObject
type CudaClahe =
    class
        inherit SharedPtrObject
    end

The CudaClahe type exposes the following members.

Constructors
 | Name | Description
Public method | CudaClahe | Create the Contrast Limited Adaptive Histogram Equalization
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Equalizes the histogram of a grayscale image using Contrast Limited Adaptive Histogram Equalization.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaClahe Constructor

Create the Contrast Limited Adaptive Histogram Equalization

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaClahe(
    double clipLimit,
    Size tileGridSize
)
Public Sub New (
    clipLimit As Double,
    tileGridSize As Size
)
public:
CudaClahe(
    double clipLimit,
    Size^ tileGridSize
)
new :
        clipLimit : float *
        tileGridSize : Size -> CudaClahe

Parameters

clipLimit
Type: SystemDouble
Threshold for contrast limiting. Use 40.0 for default
tileGridSize
Type: System.DrawingSize
Size of grid for histogram equalization. Input image will be divided into equally sized rectangular tiles. This parameter defines the number of tiles in row and column. Use (8, 8) for default
See Also

Reference

CudaClahe Class
Emgu.CV.Cuda Namespace


CudaClahe Properties

The CudaClahe type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaClahe Class
Emgu.CV.Cuda Namespace


CudaClahe Methods

The CudaClahe type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Equalizes the histogram of a grayscale image using Contrast Limited Adaptive Histogram Equalization.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaClahe Class
Emgu.CV.Cuda Namespace


CudaClahe.Apply Method

CudaClaheApply Method

Equalizes the histogram of a grayscale image using Contrast Limited Adaptive Histogram Equalization.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Apply(
    IInputArray source,
    IOutputArray dst,
    Stream stream = null
)
Public Sub Apply (
    source As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Apply(
    IInputArray^ source,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
member Apply :
        source : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

source
Type: Emgu.CVIInputArray
Source image
dst
Type: Emgu.CVIOutputArray
Destination image
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaClahe Class
Emgu.CV.Cuda Namespace


CudaClahe.DisposeObject Method

CudaClaheDisposeObject Method

Release all the unmanaged memory associated with this object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaClahe Class
Emgu.CV.Cuda Namespace


CudaClahe Fields

The CudaClahe type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaClahe Class
Emgu.CV.Cuda Namespace


CudaConvolution Class

Base class for convolution (or cross-correlation) operator.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaConvolution

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaConvolution : SharedPtrObject
Public Class CudaConvolution
    Inherits SharedPtrObject
public ref class CudaConvolution : public SharedPtrObject
type CudaConvolution =
    class
        inherit SharedPtrObject
    end

The CudaConvolution type exposes the following members.

Constructors
 | Name | Description
Public method | CudaConvolution | Create a Cuda Convolution object.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Convolve | Computes a convolution (or cross-correlation) of two images.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaConvolution Constructor

Create a Cuda Convolution object.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaConvolution(
    Size userBlockSize = null
)
Public Sub New (
    Optional userBlockSize As Size = Nothing
)
public:
CudaConvolution(
    Size^ userBlockSize = nullptr
)
new :
        ?userBlockSize : Size
(* Defaults:
        let _userBlockSize = defaultArg userBlockSize null
*)
-> CudaConvolution

Parameters

userBlockSize (Optional)
Type: System.DrawingSize
Block size. If you leave default value Size(0,0) then automatic estimation of block size will be used (which is optimized for speed). By varying user_block_size you can reduce memory requirements at the cost of speed.
See Also

Reference

CudaConvolution Class
Emgu.CV.Cuda Namespace


CudaConvolution Properties

The CudaConvolution type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaConvolution Class
Emgu.CV.Cuda Namespace


CudaConvolution Methods

The CudaConvolution type exposes the following members.

Methods
 | Name | Description
Public method | Convolve | Computes a convolution (or cross-correlation) of two images.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaConvolution Class
Emgu.CV.Cuda Namespace


CudaConvolution.Convolve Method

CudaConvolutionConvolve Method

Computes a convolution (or cross-correlation) of two images.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Convolve(
    IInputArray image,
    IInputArray templ,
    IOutputArray result,
    bool ccorr,
    Stream stream = null
)
Public Sub Convolve (
    image As IInputArray,
    templ As IInputArray,
    result As IOutputArray,
    ccorr As Boolean,
    Optional stream As Stream = Nothing
)
public:
void Convolve(
    IInputArray^ image,
    IInputArray^ templ,
    IOutputArray^ result,
    bool ccorr,
    Stream^ stream = nullptr
)
member Convolve :
        image : IInputArray *
        templ : IInputArray *
        result : IOutputArray *
        ccorr : bool *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Source image. Only CV_32FC1 images are supported for now.
templ
Type: Emgu.CVIInputArray
Template image. The size is not greater than the image size. The type is the same as image .
result
Type: Emgu.CVIOutputArray
Result image. If image is W x H and templ is w x h, then result must be W-w+1 x H-h+1.
ccorr
Type: SystemBoolean
Flags to evaluate cross-correlation instead of convolution.
stream (Optional)
Type: Emgu.CV.CudaStream
Stream for the asynchronous version
See Also

Reference

CudaConvolution Class
Emgu.CV.Cuda Namespace


CudaConvolution.DisposeObject Method

CudaConvolutionDisposeObject Method

Release all the unmanaged memory associated with this object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaConvolution Class
Emgu.CV.Cuda Namespace


CudaConvolution Fields

The CudaConvolution type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaConvolution Class
Emgu.CV.Cuda Namespace


CudaCornernessCriteria Class

Base CornernessCriteria class
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaCornernessCriteria
Emgu.CV.CudaCudaHarrisCorner
Emgu.CV.CudaCudaMinEigenValCorner

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class CudaCornernessCriteria : SharedPtrObject
Public MustInherit Class CudaCornernessCriteria
    Inherits SharedPtrObject
public ref class CudaCornernessCriteria abstract : public SharedPtrObject
[<AbstractClassAttribute>]
type CudaCornernessCriteria =
    class
        inherit SharedPtrObject
    end

The CudaCornernessCriteria type exposes the following members.

Constructors
 | Name | Description
Protected method | CudaCornernessCriteria | Initializes a new instance of the CudaCornernessCriteria class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaCornernessCriteria Constructor

Initializes a new instance of the CudaCornernessCriteria class

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected CudaCornernessCriteria()
Protected Sub New
protected:
CudaCornernessCriteria()
new : unit -> CudaCornernessCriteria
See Also

Reference

CudaCornernessCriteria Class
Emgu.CV.Cuda Namespace


CudaCornernessCriteria Properties

The CudaCornernessCriteria type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaCornernessCriteria Class
Emgu.CV.Cuda Namespace


CudaCornernessCriteria Methods

The CudaCornernessCriteria type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaCornernessCriteria Class
Emgu.CV.Cuda Namespace


CudaCornernessCriteria.Apply Method

CudaCornernessCriteriaApply Method

Apply the cuda filter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Apply(
    IInputArray image,
    IOutputArray dst,
    Stream stream = null
)
Public Sub Apply (
    image As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Apply(
    IInputArray^ image,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
member Apply :
        image : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The source CudaImage where the filter will be applied to
dst
Type: Emgu.CVIOutputArray
The destination CudaImage
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaCornernessCriteria Class
Emgu.CV.Cuda Namespace


CudaCornernessCriteria.DisposeObject Method

CudaCornernessCriteriaDisposeObject Method

Release all the unmanaged memory associated with this gpu filter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaCornernessCriteria Class
Emgu.CV.Cuda Namespace


CudaCornernessCriteria Fields

The CudaCornernessCriteria type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaCornernessCriteria Class
Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow Class

PyrLK optical flow
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaDensePyrLKOpticalFlow

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaDensePyrLKOpticalFlow : SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
Public Class CudaDensePyrLKOpticalFlow
    Inherits SharedPtrObject
    Implements ICudaDenseOpticalFlow, IAlgorithm
public ref class CudaDensePyrLKOpticalFlow : public SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
type CudaDensePyrLKOpticalFlow =
    class
        inherit SharedPtrObject
        interface ICudaDenseOpticalFlow
        interface IAlgorithm
    end

The CudaDensePyrLKOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | CudaDensePyrLKOpticalFlow | Create the PyrLK optical flow solver
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow Constructor

Create the PyrLK optical flow solver

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaDensePyrLKOpticalFlow(
    Size winSize,
    int maxLevel = 3,
    int iters = 30,
    bool useInitialFlow = false
)
Public Sub New (
    winSize As Size,
    Optional maxLevel As Integer = 3,
    Optional iters As Integer = 30,
    Optional useInitialFlow As Boolean = false
)
public:
CudaDensePyrLKOpticalFlow(
    Size^ winSize,
    int maxLevel = 3,
    int iters = 30,
    bool useInitialFlow = false
)
new :
        winSize : Size *
        ?maxLevel : int *
        ?iters : int *
        ?useInitialFlow : bool
(* Defaults:
        let _maxLevel = defaultArg maxLevel 3
        let _iters = defaultArg iters 30
        let _useInitialFlow = defaultArg useInitialFlow false
*)
-> CudaDensePyrLKOpticalFlow

Parameters

winSize
Type: System.DrawingSize
Windows size. Use 21x21 for default
maxLevel (Optional)
Type: SystemInt32
The maximum number of pyramid levels.
iters (Optional)
Type: SystemInt32
The number of iterations.
useInitialFlow (Optional)
Type: SystemBoolean
Weather or not use the initial flow in the input matrix.
See Also

Reference

CudaDensePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow Properties

The CudaDensePyrLKOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaDensePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow.AlgorithmPtr Property

CudaDensePyrLKOpticalFlowAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

CudaDensePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow.DenseOpticalFlowPtr Property

CudaDensePyrLKOpticalFlowDenseOpticalFlowPtr Property

Pointer to the unmanaged DenseOpticalFlow object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ICudaDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

CudaDensePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow Methods

The CudaDensePyrLKOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

CudaDensePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow.DisposeObject Method

CudaDensePyrLKOpticalFlowDisposeObject Method

Release all the unmanaged memory associated with this optical flow solver.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaDensePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaDensePyrLKOpticalFlow Fields

The CudaDensePyrLKOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaDensePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaDerivFilter Class

A generalized Deriv operator.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaDerivFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaDerivFilter : CudaFilter
Public Class CudaDerivFilter
    Inherits CudaFilter
public ref class CudaDerivFilter : public CudaFilter
type CudaDerivFilter =
    class
        inherit CudaFilter
    end

The CudaDerivFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaDerivFilter | Creates a generalized Deriv operator.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaDerivFilter Constructor

Creates a generalized Deriv operator.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaDerivFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    int dx,
    int dy,
    int ksize,
    bool normalize = false,
    double scale = 1,
    BorderType rowBorderType = 4,
    BorderType columnBorderType = -1
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    dx As Integer,
    dy As Integer,
    ksize As Integer,
    Optional normalize As Boolean = false,
    Optional scale As Double = 1,
    Optional rowBorderType As BorderType = 4,
    Optional columnBorderType As BorderType = -1
)
public:
CudaDerivFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    int dx,
    int dy,
    int ksize,
    bool normalize = false,
    double scale = 1,
    BorderType^ rowBorderType = 4,
    BorderType^ columnBorderType = -1
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        dx : int *
        dy : int *
        ksize : int *
        ?normalize : bool *
        ?scale : float *
        ?rowBorderType : BorderType *
        ?columnBorderType : BorderType
(* Defaults:
        let _normalize = defaultArg normalize false
        let _scale = defaultArg scale 1
        let _rowBorderType = defaultArg rowBorderType 4
        let _columnBorderType = defaultArg columnBorderType -1
*)
-> CudaDerivFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
Source image depth.
srcChannels
Type: SystemInt32
Source image channels.
dstDepth
Type: Emgu.CV.CvEnumDepthType
Destination array depth.
dstChannels
Type: SystemInt32
Destination array channels.
dx
Type: SystemInt32
Derivative order in respect of x.
dy
Type: SystemInt32
Derivative order in respect of y.
ksize
Type: SystemInt32
Aperture size.
normalize (Optional)
Type: SystemBoolean
Flag indicating whether to normalize (scale down) the filter coefficients or not.
scale (Optional)
Type: SystemDouble
Optional scale factor for the computed derivative values. By default, no scaling is applied.
rowBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method in the vertical direction.
columnBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method in the horizontal direction.
See Also

Reference

CudaDerivFilter Class
Emgu.CV.Cuda Namespace


CudaDerivFilter Properties

The CudaDerivFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaDerivFilter Class
Emgu.CV.Cuda Namespace


CudaDerivFilter Methods

The CudaDerivFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaDerivFilter Class
Emgu.CV.Cuda Namespace


CudaDerivFilter Fields

The CudaDerivFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaDerivFilter Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo Class

The Cuda device information
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CudaCudaDeviceInfo

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaDeviceInfo : UnmanagedObject
Public Class CudaDeviceInfo
    Inherits UnmanagedObject
public ref class CudaDeviceInfo : public UnmanagedObject
type CudaDeviceInfo =
    class
        inherit UnmanagedObject
    end

The CudaDeviceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CudaDeviceInfo | Query the information of the gpu device that is currently in use.
Public method | CudaDeviceInfo(Int32) | Query the information of the cuda device with the specific id.
Top
Properties
 | Name | Description
Public property | CudaComputeCapability | The compute capability
Public property | FreeMemory | Get the amount of free memory at the moment
Public property | ID | The id of the device
Public property | IsCompatible | Checks whether the Cuda module can be run on the given device
Public property | MultiProcessorCount | The number of single multi processors
Public property | Name | The name of the device
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TotalMemory | Get the amount of total memory
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource related to the GpuDevice (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Supports | Indicates if the device has the specific feature
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaDeviceInfo Constructor

Overload List
 | Name | Description
Public method | CudaDeviceInfo | Query the information of the gpu device that is currently in use.
Public method | CudaDeviceInfo(Int32) | Query the information of the cuda device with the specific id.
Top
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo Constructor

Query the information of the gpu device that is currently in use.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaDeviceInfo()
Public Sub New
public:
CudaDeviceInfo()
new : unit -> CudaDeviceInfo
See Also

Reference

CudaDeviceInfo Class
CudaDeviceInfo Overload
Emgu.CV.Cuda Namespace


CudaDeviceInfo Constructor (Int32)

Query the information of the cuda device with the specific id.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaDeviceInfo(
    int deviceId
)
Public Sub New (
    deviceId As Integer
)
public:
CudaDeviceInfo(
    int deviceId
)
new :
        deviceId : int -> CudaDeviceInfo

Parameters

deviceId
Type: SystemInt32
The device id
See Also

Reference

CudaDeviceInfo Class
CudaDeviceInfo Overload
Emgu.CV.Cuda Namespace


CudaDeviceInfo Properties

The CudaDeviceInfo type exposes the following members.

Properties
 | Name | Description
Public property | CudaComputeCapability | The compute capability
Public property | FreeMemory | Get the amount of free memory at the moment
Public property | ID | The id of the device
Public property | IsCompatible | Checks whether the Cuda module can be run on the given device
Public property | MultiProcessorCount | The number of single multi processors
Public property | Name | The name of the device
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TotalMemory | Get the amount of total memory
Top
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.CudaComputeCapability Property

CudaDeviceInfoCudaComputeCapability Property

The compute capability

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Version CudaComputeCapability { get; }
Public ReadOnly Property CudaComputeCapability As Version
    Get
public:
property Version^ CudaComputeCapability {
    Version^ get ();
}
member CudaComputeCapability : Version with get

Property Value

Type: Version
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.FreeMemory Property

CudaDeviceInfoFreeMemory Property

Get the amount of free memory at the moment

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong FreeMemory { get; }
Public ReadOnly Property FreeMemory As ULong
    Get
public:
property unsigned long long FreeMemory {
    unsigned long long get ();
}
member FreeMemory : uint64 with get

Property Value

Type: UInt64
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.ID Property

CudaDeviceInfoID Property

The id of the device

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get
public:
property int ID {
    int get ();
}
member ID : int with get

Property Value

Type: Int32
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.IsCompatible Property

CudaDeviceInfoIsCompatible Property

Checks whether the Cuda module can be run on the given device

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsCompatible { get; }
Public ReadOnly Property IsCompatible As Boolean
    Get
public:
property bool IsCompatible {
    bool get ();
}
member IsCompatible : bool with get

Property Value

Type: Boolean
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.MultiProcessorCount Property

CudaDeviceInfoMultiProcessorCount Property

The number of single multi processors

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MultiProcessorCount { get; }
Public ReadOnly Property MultiProcessorCount As Integer
    Get
public:
property int MultiProcessorCount {
    int get ();
}
member MultiProcessorCount : int with get

Property Value

Type: Int32
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.Name Property

CudaDeviceInfoName Property

The name of the device

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.TotalMemory Property

CudaDeviceInfoTotalMemory Property

Get the amount of total memory

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong TotalMemory { get; }
Public ReadOnly Property TotalMemory As ULong
    Get
public:
property unsigned long long TotalMemory {
    unsigned long long get ();
}
member TotalMemory : uint64 with get

Property Value

Type: UInt64
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo Methods

The CudaDeviceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource related to the GpuDevice (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Supports | Indicates if the device has the specific feature
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.DisposeObject Method

CudaDeviceInfoDisposeObject Method

Release the unmanaged resource related to the GpuDevice

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.Supports Method

CudaDeviceInfoSupports Method

Indicates if the device has the specific feature

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Supports(
    CudaDeviceInfoGpuFeature feature
)
Public Function Supports (
    feature As CudaDeviceInfoGpuFeature
) As Boolean
public:
bool Supports(
    CudaDeviceInfoGpuFeature^ feature
)
member Supports :
        feature : CudaDeviceInfoGpuFeature -> bool

Parameters

feature
Type: Emgu.CV.CudaCudaDeviceInfoGpuFeature
The device feature

Return Value

Type: Boolean
True if the feature is supported
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo Fields

The CudaDeviceInfo type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CudaDeviceInfo Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature Class

CudaDeviceInfoGpuFeature Class

GPU feature
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CudaCudaDeviceInfoGpuFeature

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class GpuFeature : Enum
Public NotInheritable Class GpuFeature
    Inherits Enum
public ref class GpuFeature sealed : public Enum
[<SealedAttribute>]
type GpuFeature =
    class
        inherit Enum
    end

The CudaDeviceInfoGpuFeature type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Compute10 | Cuda compute 1.0
 | Compute11 | Cuda compute 1.1
 | Compute12 | Cuda compute 1.2
 | Compute13 | Cuda compute 1.3
 | Compute20 | Cuda compute 2.0
 | Compute21 | Cuda compute 2.1
 | GlobalAtomics | Global Atomic
 | NativeDouble | Native double
 | SharedAtomics | Shared Atomic
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Cuda Namespace


GpuFeature Methods

The CudaDeviceInfoGpuFeature type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


GpuFeature Fields

The CudaDeviceInfoGpuFeature type exposes the following members.

Fields
 | Name | Description
 | Compute10 | Cuda compute 1.0
 | Compute11 | Cuda compute 1.1
 | Compute12 | Cuda compute 1.2
 | Compute13 | Cuda compute 1.3
 | Compute20 | Cuda compute 2.0
 | Compute21 | Cuda compute 2.1
 | GlobalAtomics | Global Atomic
 | NativeDouble | Native double
 | SharedAtomics | Shared Atomic
Public field | value__ |
Top
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.Compute10 Field

CudaDeviceInfoGpuFeatureCompute10 Field

Cuda compute 1.0

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature Compute10 = 10
Public Const Compute10 As CudaDeviceInfoGpuFeature = 10
public:
literal CudaDeviceInfoGpuFeature^ Compute10 = 10
static val mutable Compute10: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.Compute11 Field

CudaDeviceInfoGpuFeatureCompute11 Field

Cuda compute 1.1

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature Compute11 = 11
Public Const Compute11 As CudaDeviceInfoGpuFeature = 11
public:
literal CudaDeviceInfoGpuFeature^ Compute11 = 11
static val mutable Compute11: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.Compute12 Field

CudaDeviceInfoGpuFeatureCompute12 Field

Cuda compute 1.2

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature Compute12 = 12
Public Const Compute12 As CudaDeviceInfoGpuFeature = 12
public:
literal CudaDeviceInfoGpuFeature^ Compute12 = 12
static val mutable Compute12: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.Compute13 Field

CudaDeviceInfoGpuFeatureCompute13 Field

Cuda compute 1.3

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature Compute13 = 13
Public Const Compute13 As CudaDeviceInfoGpuFeature = 13
public:
literal CudaDeviceInfoGpuFeature^ Compute13 = 13
static val mutable Compute13: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.Compute20 Field

CudaDeviceInfoGpuFeatureCompute20 Field

Cuda compute 2.0

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature Compute20 = 20
Public Const Compute20 As CudaDeviceInfoGpuFeature = 20
public:
literal CudaDeviceInfoGpuFeature^ Compute20 = 20
static val mutable Compute20: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.Compute21 Field

CudaDeviceInfoGpuFeatureCompute21 Field

Cuda compute 2.1

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature Compute21 = 21
Public Const Compute21 As CudaDeviceInfoGpuFeature = 21
public:
literal CudaDeviceInfoGpuFeature^ Compute21 = 21
static val mutable Compute21: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.GlobalAtomics Field

CudaDeviceInfoGpuFeatureGlobalAtomics Field

Global Atomic

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature GlobalAtomics = 11
Public Const GlobalAtomics As CudaDeviceInfoGpuFeature = 11
public:
literal CudaDeviceInfoGpuFeature^ GlobalAtomics = 11
static val mutable GlobalAtomics: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.NativeDouble Field

CudaDeviceInfoGpuFeatureNativeDouble Field

Native double

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature NativeDouble = 13
Public Const NativeDouble As CudaDeviceInfoGpuFeature = 13
public:
literal CudaDeviceInfoGpuFeature^ NativeDouble = 13
static val mutable NativeDouble: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.SharedAtomics Field

CudaDeviceInfoGpuFeatureSharedAtomics Field

Shared Atomic

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaDeviceInfoGpuFeature SharedAtomics = 12
Public Const SharedAtomics As CudaDeviceInfoGpuFeature = 12
public:
literal CudaDeviceInfoGpuFeature^ SharedAtomics = 12
static val mutable SharedAtomics: CudaDeviceInfoGpuFeature

Field Value

Type: CudaDeviceInfoGpuFeature
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDeviceInfo.GpuFeature.value__ Field

CudaDeviceInfoGpuFeaturevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaDeviceInfo.GpuFeature.value__"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CudaDeviceInfoGpuFeature Class
Emgu.CV.Cuda Namespace


CudaDisparityBilateralFilter Class

Disparity map refinement using joint bilateral filtering given a single color image. Qingxiong Yang, Liang Wang†, Narendra Ahuja http://vision.ai.uiuc.edu/~qyang6/
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaDisparityBilateralFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaDisparityBilateralFilter : SharedPtrObject
Public Class CudaDisparityBilateralFilter
    Inherits SharedPtrObject
public ref class CudaDisparityBilateralFilter : public SharedPtrObject
type CudaDisparityBilateralFilter =
    class
        inherit SharedPtrObject
    end

The CudaDisparityBilateralFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaDisparityBilateralFilter | Create a GpuDisparityBilateralFilter
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the filter to the disparity image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with the filter. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaDisparityBilateralFilter Constructor

Create a GpuDisparityBilateralFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaDisparityBilateralFilter(
    int ndisp = 64,
    int radius = 3,
    int iters = 1
)
Public Sub New (
    Optional ndisp As Integer = 64,
    Optional radius As Integer = 3,
    Optional iters As Integer = 1
)
public:
CudaDisparityBilateralFilter(
    int ndisp = 64,
    int radius = 3,
    int iters = 1
)
new :
        ?ndisp : int *
        ?radius : int *
        ?iters : int
(* Defaults:
        let _ndisp = defaultArg ndisp 64
        let _radius = defaultArg radius 3
        let _iters = defaultArg iters 1
*)
-> CudaDisparityBilateralFilter

Parameters

ndisp (Optional)
Type: SystemInt32
Number of disparities. Use 64 as default
radius (Optional)
Type: SystemInt32
Filter radius, use 3 as default
iters (Optional)
Type: SystemInt32
Number of iterations, use 1 as default
See Also

Reference

CudaDisparityBilateralFilter Class
Emgu.CV.Cuda Namespace


CudaDisparityBilateralFilter Properties

The CudaDisparityBilateralFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaDisparityBilateralFilter Class
Emgu.CV.Cuda Namespace


CudaDisparityBilateralFilter Methods

The CudaDisparityBilateralFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the filter to the disparity image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with the filter. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaDisparityBilateralFilter Class
Emgu.CV.Cuda Namespace


CudaDisparityBilateralFilter.Apply Method

CudaDisparityBilateralFilterApply Method

Apply the filter to the disparity image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Apply(
    IInputArray disparity,
    IInputArray image,
    IOutputArray dst,
    Stream stream = null
)
Public Sub Apply (
    disparity As IInputArray,
    image As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Apply(
    IInputArray^ disparity,
    IInputArray^ image,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
member Apply :
        disparity : IInputArray *
        image : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

disparity
Type: Emgu.CVIInputArray
The input disparity map
image
Type: Emgu.CVIInputArray
The image
dst
Type: Emgu.CVIOutputArray
The output disparity map, should have the same size as the input disparity map
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaDisparityBilateralFilter Class
Emgu.CV.Cuda Namespace


CudaDisparityBilateralFilter.DisposeObject Method

CudaDisparityBilateralFilterDisposeObject Method

Release the unmanaged resources associated with the filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaDisparityBilateralFilter Class
Emgu.CV.Cuda Namespace


CudaDisparityBilateralFilter Fields

The CudaDisparityBilateralFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaDisparityBilateralFilter Class
Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow Class

Farneback optical flow
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFarnebackOpticalFlow

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaFarnebackOpticalFlow : SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
Public Class CudaFarnebackOpticalFlow
    Inherits SharedPtrObject
    Implements ICudaDenseOpticalFlow, IAlgorithm
public ref class CudaFarnebackOpticalFlow : public SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
type CudaFarnebackOpticalFlow =
    class
        inherit SharedPtrObject
        interface ICudaDenseOpticalFlow
        interface IAlgorithm
    end

The CudaFarnebackOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | CudaFarnebackOpticalFlow | Create a CudaFarnebackOpticalFlow object
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unamanged Algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow Constructor

Create a CudaFarnebackOpticalFlow object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaFarnebackOpticalFlow(
    int numLevels = 5,
    double pyrScale = 0.5,
    bool fastPyramids = false,
    int winSize = 13,
    int numIters = 10,
    int polyN = 5,
    double polySigma = 1.1,
    OpticalflowFarnebackFlag flags = 0
)
Public Sub New (
    Optional numLevels As Integer = 5,
    Optional pyrScale As Double = 0.5,
    Optional fastPyramids As Boolean = false,
    Optional winSize As Integer = 13,
    Optional numIters As Integer = 10,
    Optional polyN As Integer = 5,
    Optional polySigma As Double = 1.1,
    Optional flags As OpticalflowFarnebackFlag = 0
)
public:
CudaFarnebackOpticalFlow(
    int numLevels = 5,
    double pyrScale = 0.5,
    bool fastPyramids = false,
    int winSize = 13,
    int numIters = 10,
    int polyN = 5,
    double polySigma = 1.1,
    OpticalflowFarnebackFlag^ flags = 0
)
new :
        ?numLevels : int *
        ?pyrScale : float *
        ?fastPyramids : bool *
        ?winSize : int *
        ?numIters : int *
        ?polyN : int *
        ?polySigma : float *
        ?flags : OpticalflowFarnebackFlag
(* Defaults:
        let _numLevels = defaultArg numLevels 5
        let _pyrScale = defaultArg pyrScale 0.5
        let _fastPyramids = defaultArg fastPyramids false
        let _winSize = defaultArg winSize 13
        let _numIters = defaultArg numIters 10
        let _polyN = defaultArg polyN 5
        let _polySigma = defaultArg polySigma 1.1
        let _flags = defaultArg flags 0
*)
-> CudaFarnebackOpticalFlow

Parameters

numLevels (Optional)
Type: SystemInt32
The number of pyramid layers, including the initial image. levels=1 means that no extra layers are created and only the original images are used
pyrScale (Optional)
Type: SystemDouble
Specifies the image scale (!1) to build the pyramids for each image. pyrScale=0.5 means the classical pyramid, where each next layer is twice smaller than the previous
fastPyramids (Optional)
Type: SystemBoolean
Fast Pyramids
winSize (Optional)
Type: SystemInt32
The averaging window size; The larger values increase the algorithm robustness to image noise and give more chances for fast motion detection, but yield more blurred motion field
numIters (Optional)
Type: SystemInt32
The number of iterations the algorithm does at each pyramid level
polyN (Optional)
Type: SystemInt32
Size of the pixel neighborhood used to find polynomial expansion in each pixel. The larger values mean that the image will be approximated with smoother surfaces, yielding more robust algorithm and more blurred motion field. Typically, poly n=5 or 7
polySigma (Optional)
Type: SystemDouble
Standard deviation of the Gaussian that is used to smooth derivatives that are used as a basis for the polynomial expansion. For poly n=5 you can set poly sigma=1.1, for poly n=7 a good value would be poly sigma=1.5
flags (Optional)
Type: Emgu.CV.CvEnumOpticalflowFarnebackFlag
The operation flags
See Also

Reference

CudaFarnebackOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow Properties

The CudaFarnebackOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unamanged Algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the unmanaged DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaFarnebackOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow.AlgorithmPtr Property

CudaFarnebackOpticalFlowAlgorithmPtr Property

Pointer to the unamanged Algorithm object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

CudaFarnebackOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow.DenseOpticalFlowPtr Property

CudaFarnebackOpticalFlowDenseOpticalFlowPtr Property

Pointer to the unmanaged DenseOpticalFlow object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ICudaDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

CudaFarnebackOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow Methods

The CudaFarnebackOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

CudaFarnebackOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow.DisposeObject Method

CudaFarnebackOpticalFlowDisposeObject Method

Release all the unmanaged memory associated with this optical flow solver.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaFarnebackOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaFarnebackOpticalFlow Fields

The CudaFarnebackOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaFarnebackOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaFastFeatureDetector Class

A FAST detector using Cuda
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DFastFeatureDetector
Emgu.CV.CudaCudaFastFeatureDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaFastFeatureDetector : FastFeatureDetector,
    IFeature2DAsync
Public Class CudaFastFeatureDetector
    Inherits FastFeatureDetector
    Implements IFeature2DAsync
public ref class CudaFastFeatureDetector : public FastFeatureDetector,
    IFeature2DAsync
type CudaFastFeatureDetector =
    class
        inherit FastFeatureDetector
        interface IFeature2DAsync
    end

The CudaFastFeatureDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CudaFastFeatureDetector | Create a fast detector with the specific parameters
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associate to the Detector (Overrides FastFeatureDetectorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ComputeAsync | Compute the descriptors on the image from the given keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | Convert | Converts keypoints array from internal representation to standard vector. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAsync | Detect the features in the image (Defined by Feature2DAsyncExtension.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaFastFeatureDetector Constructor

Create a fast detector with the specific parameters

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaFastFeatureDetector(
    int threshold = 10,
    bool nonmaxSupression = true,
    FastFeatureDetectorDetectorType type = 2,
    int maxNKeypoints = 5000
)
Public Sub New (
    Optional threshold As Integer = 10,
    Optional nonmaxSupression As Boolean = true,
    Optional type As FastFeatureDetectorDetectorType = 2,
    Optional maxNKeypoints As Integer = 5000
)
public:
CudaFastFeatureDetector(
    int threshold = 10,
    bool nonmaxSupression = true,
    FastFeatureDetectorDetectorType^ type = 2,
    int maxNKeypoints = 5000
)
new :
        ?threshold : int *
        ?nonmaxSupression : bool *
        ?type : FastFeatureDetectorDetectorType *
        ?maxNKeypoints : int
(* Defaults:
        let _threshold = defaultArg threshold 10
        let _nonmaxSupression = defaultArg nonmaxSupression true
        let _type = defaultArg type 2
        let _maxNKeypoints = defaultArg maxNKeypoints 5000
*)
-> CudaFastFeatureDetector

Parameters

threshold (Optional)
Type: SystemInt32
Threshold on difference between intensity of center pixel and pixels on circle around this pixel. Use 10 for default.
nonmaxSupression (Optional)
Type: SystemBoolean
Specifiy if non-maximum supression should be used.
type (Optional)
Type: Emgu.CV.Features2DFastFeatureDetectorDetectorType
The detector type
maxNKeypoints (Optional)
Type: SystemInt32
The maximum number of keypoints to be extracted.
See Also

Reference

CudaFastFeatureDetector Class
Emgu.CV.Cuda Namespace


CudaFastFeatureDetector Properties

The CudaFastFeatureDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaFastFeatureDetector Class
Emgu.CV.Cuda Namespace


CudaFastFeatureDetector Methods

The CudaFastFeatureDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associate to the Detector (Overrides FastFeatureDetectorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ComputeAsync | Compute the descriptors on the image from the given keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | Convert | Converts keypoints array from internal representation to standard vector. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAsync | Detect the features in the image (Defined by Feature2DAsyncExtension.)
Top
See Also

Reference

CudaFastFeatureDetector Class
Emgu.CV.Cuda Namespace


CudaFastFeatureDetector.DisposeObject Method

CudaFastFeatureDetectorDisposeObject Method

Release the unmanaged resource associate to the Detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaFastFeatureDetector Class
Emgu.CV.Cuda Namespace


CudaFastFeatureDetector Fields

The CudaFastFeatureDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaFastFeatureDetector Class
Emgu.CV.Cuda Namespace


CudaFilter Class

Base Cuda filter class
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
More...

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class CudaFilter : SharedPtrObject
Public MustInherit Class CudaFilter
    Inherits SharedPtrObject
public ref class CudaFilter abstract : public SharedPtrObject
[<AbstractClassAttribute>]
type CudaFilter =
    class
        inherit SharedPtrObject
    end

The CudaFilter type exposes the following members.

Constructors
 | Name | Description
Protected method | CudaFilter | Initializes a new instance of the CudaFilter class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaColumnSumFilter
Emgu.CV.CudaCudaBoxFilter
Emgu.CV.CudaCudaBoxMaxFilter
Emgu.CV.CudaCudaBoxMinFilter
Emgu.CV.CudaCudaDerivFilter
Emgu.CV.CudaCudaGaussianFilter
Emgu.CV.CudaCudaLaplacianFilter
Emgu.CV.CudaCudaLinearFilter
Emgu.CV.CudaCudaMorphologyFilter
Emgu.CV.CudaCudaSobelFilter
Emgu.CV.CudaMedianFilter
Emgu.CV.CudaRowSumFilter
Emgu.CV.CudaScharrFilter
Emgu.CV.CudaSeparableLinearFilter


CudaFilter Constructor

Initializes a new instance of the CudaFilter class

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected CudaFilter()
Protected Sub New
protected:
CudaFilter()
new : unit -> CudaFilter
See Also

Reference

CudaFilter Class
Emgu.CV.Cuda Namespace


CudaFilter Properties

The CudaFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaFilter Class
Emgu.CV.Cuda Namespace


CudaFilter Methods

The CudaFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaFilter Class
Emgu.CV.Cuda Namespace


CudaFilter.Apply Method

CudaFilterApply Method

Apply the cuda filter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Apply(
    IInputArray image,
    IOutputArray dst,
    Stream stream = null
)
Public Sub Apply (
    image As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Apply(
    IInputArray^ image,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
member Apply :
        image : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The source CudaImage where the filter will be applied to
dst
Type: Emgu.CVIOutputArray
The destination CudaImage
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaFilter Class
Emgu.CV.Cuda Namespace


CudaFilter.DisposeObject Method

CudaFilterDisposeObject Method

Release all the unmanaged memory associated with this gpu filter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaFilter Class
Emgu.CV.Cuda Namespace


CudaFilter Fields

The CudaFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaFilter Class
Emgu.CV.Cuda Namespace


CudaGaussianFilter Class

Gaussian filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaGaussianFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaGaussianFilter : CudaFilter
Public Class CudaGaussianFilter
    Inherits CudaFilter
public ref class CudaGaussianFilter : public CudaFilter
type CudaGaussianFilter =
    class
        inherit CudaFilter
    end

The CudaGaussianFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaGaussianFilter | Create a Gaussian filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaGaussianFilter Constructor

Create a Gaussian filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaGaussianFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    Size ksize,
    double sigma1,
    double sigma2 = 0,
    BorderType rowBorderType = 4,
    BorderType columnBorderType = -1
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    ksize As Size,
    sigma1 As Double,
    Optional sigma2 As Double = 0,
    Optional rowBorderType As BorderType = 4,
    Optional columnBorderType As BorderType = -1
)
public:
CudaGaussianFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    Size^ ksize,
    double sigma1,
    double sigma2 = 0,
    BorderType^ rowBorderType = 4,
    BorderType^ columnBorderType = -1
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        ksize : Size *
        sigma1 : float *
        ?sigma2 : float *
        ?rowBorderType : BorderType *
        ?columnBorderType : BorderType
(* Defaults:
        let _sigma2 = defaultArg sigma2 0
        let _rowBorderType = defaultArg rowBorderType 4
        let _columnBorderType = defaultArg columnBorderType -1
*)
-> CudaGaussianFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the source image
srcChannels
Type: SystemInt32
The number of channels in the source image
dstDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the destination image
dstChannels
Type: SystemInt32
The number of channels in the destination image
ksize
Type: System.DrawingSize
The size of the kernel
sigma1
Type: SystemDouble
This parameter may specify Gaussian sigma (standard deviation). If it is zero, it is calculated from the kernel size.
sigma2 (Optional)
Type: SystemDouble
In case of non-square Gaussian kernel the parameter may be used to specify a different (from param3) sigma in the vertical direction. Use 0 for default
rowBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The row border type.
columnBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The column border type.
See Also

Reference

CudaGaussianFilter Class
Emgu.CV.Cuda Namespace


CudaGaussianFilter Properties

The CudaGaussianFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaGaussianFilter Class
Emgu.CV.Cuda Namespace


CudaGaussianFilter Methods

The CudaGaussianFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaGaussianFilter Class
Emgu.CV.Cuda Namespace


CudaGaussianFilter Fields

The CudaGaussianFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaGaussianFilter Class
Emgu.CV.Cuda Namespace


CudaGoodFeaturesToTrackDetector Class

Cuda implementation of GoodFeaturesToTrackDetector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaGoodFeaturesToTrackDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaGoodFeaturesToTrackDetector : SharedPtrObject
Public Class CudaGoodFeaturesToTrackDetector
    Inherits SharedPtrObject
public ref class CudaGoodFeaturesToTrackDetector : public SharedPtrObject
type CudaGoodFeaturesToTrackDetector =
    class
        inherit SharedPtrObject
    end

The CudaGoodFeaturesToTrackDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CudaGoodFeaturesToTrackDetector | Create the Cuda implementation of GoodFeaturesToTrackDetector
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Detect | Find the good features to track
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this detector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaGoodFeaturesToTrackDetector Constructor

Create the Cuda implementation of GoodFeaturesToTrackDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaGoodFeaturesToTrackDetector(
    DepthType srcDepth,
    int srcChannels,
    int maxCorners = 1000,
    double qualityLevel = 0.01,
    double minDistance = 0,
    int blockSize = 3,
    bool useHarrisDetector = false,
    double harrisK = 0.04
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    Optional maxCorners As Integer = 1000,
    Optional qualityLevel As Double = 0.01,
    Optional minDistance As Double = 0,
    Optional blockSize As Integer = 3,
    Optional useHarrisDetector As Boolean = false,
    Optional harrisK As Double = 0.04
)
public:
CudaGoodFeaturesToTrackDetector(
    DepthType^ srcDepth,
    int srcChannels,
    int maxCorners = 1000,
    double qualityLevel = 0.01,
    double minDistance = 0,
    int blockSize = 3,
    bool useHarrisDetector = false,
    double harrisK = 0.04
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        ?maxCorners : int *
        ?qualityLevel : float *
        ?minDistance : float *
        ?blockSize : int *
        ?useHarrisDetector : bool *
        ?harrisK : float
(* Defaults:
        let _maxCorners = defaultArg maxCorners 1000
        let _qualityLevel = defaultArg qualityLevel 0.01
        let _minDistance = defaultArg minDistance 0
        let _blockSize = defaultArg blockSize 3
        let _useHarrisDetector = defaultArg useHarrisDetector false
        let _harrisK = defaultArg harrisK 0.04
*)
-> CudaGoodFeaturesToTrackDetector

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth of the src image
srcChannels
Type: SystemInt32
The number of channels in the src image
maxCorners (Optional)
Type: SystemInt32
The maximum number of channels
qualityLevel (Optional)
Type: SystemDouble
The quality level
minDistance (Optional)
Type: SystemDouble
The minimum distance
blockSize (Optional)
Type: SystemInt32
The block size
useHarrisDetector (Optional)
Type: SystemBoolean
If true, use Harris detector
harrisK (Optional)
Type: SystemDouble
Harris K
See Also

Reference

CudaGoodFeaturesToTrackDetector Class
Emgu.CV.Cuda Namespace


CudaGoodFeaturesToTrackDetector Properties

The CudaGoodFeaturesToTrackDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaGoodFeaturesToTrackDetector Class
Emgu.CV.Cuda Namespace


CudaGoodFeaturesToTrackDetector Methods

The CudaGoodFeaturesToTrackDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Find the good features to track
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this detector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaGoodFeaturesToTrackDetector Class
Emgu.CV.Cuda Namespace


CudaGoodFeaturesToTrackDetector.Detect Method

CudaGoodFeaturesToTrackDetectorDetect Method

Find the good features to track

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Detect(
    IInputArray image,
    IOutputArray corners,
    IInputArray mask = null,
    Stream stream = null
)
Public Sub Detect (
    image As IInputArray,
    corners As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
void Detect(
    IInputArray^ image,
    IOutputArray^ corners,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
member Detect :
        image : IInputArray *
        corners : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The input image
corners
Type: Emgu.CVIOutputArray
The output corners
mask (Optional)
Type: Emgu.CVIInputArray
Optional mask
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaGoodFeaturesToTrackDetector Class
Emgu.CV.Cuda Namespace


CudaGoodFeaturesToTrackDetector.DisposeObject Method

CudaGoodFeaturesToTrackDetectorDisposeObject Method

Release all the unmanaged memory associated with this detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaGoodFeaturesToTrackDetector Class
Emgu.CV.Cuda Namespace


CudaGoodFeaturesToTrackDetector Fields

The CudaGoodFeaturesToTrackDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaGoodFeaturesToTrackDetector Class
Emgu.CV.Cuda Namespace


CudaHarrisCorner Class

Runs the Harris edge detector on image. Similarly to cvCornerMinEigenVal and cvCornerEigenValsAndVecs, for each pixel it calculates 2x2 gradient covariation matrix M over block_size x block_size neighborhood. Then, it stores det(M) - k*trace(M)^2 to the destination image. Corners in the image can be found as local maxima of the destination image.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaCornernessCriteria
Emgu.CV.CudaCudaHarrisCorner

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaHarrisCorner : CudaCornernessCriteria
Public Class CudaHarrisCorner
    Inherits CudaCornernessCriteria
public ref class CudaHarrisCorner : public CudaCornernessCriteria
type CudaHarrisCorner =
    class
        inherit CudaCornernessCriteria
    end

The CudaHarrisCorner type exposes the following members.

Constructors
 | Name | Description
Public method | CudaHarrisCorner | Create a Cuda Harris Corner detector
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaCornernessCriteria.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaCornernessCriteria.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaHarrisCorner Constructor

Create a Cuda Harris Corner detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaHarrisCorner(
    DepthType srcDepth,
    int srcChannels,
    int blockSize,
    int kSize,
    double k,
    BorderType borderType = 4
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    blockSize As Integer,
    kSize As Integer,
    k As Double,
    Optional borderType As BorderType = 4
)
public:
CudaHarrisCorner(
    DepthType^ srcDepth,
    int srcChannels,
    int blockSize,
    int kSize,
    double k,
    BorderType^ borderType = 4
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        blockSize : int *
        kSize : int *
        k : float *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> CudaHarrisCorner

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth of the source image
srcChannels
Type: SystemInt32
The number of channels in the source image
blockSize
Type: SystemInt32
Neighborhood size
kSize
Type: SystemInt32

[Missing <param name="kSize"/> documentation for "M:Emgu.CV.Cuda.CudaHarrisCorner.#ctor(Emgu.CV.CvEnum.DepthType,System.Int32,System.Int32,System.Int32,System.Double,Emgu.CV.CvEnum.BorderType)"]

k
Type: SystemDouble
Harris detector free parameter.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Boreder type, use REFLECT101 for default
See Also

Reference

CudaHarrisCorner Class
Emgu.CV.Cuda Namespace


CudaHarrisCorner Properties

The CudaHarrisCorner type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHarrisCorner Class
Emgu.CV.Cuda Namespace


CudaHarrisCorner Methods

The CudaHarrisCorner type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaCornernessCriteria.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaCornernessCriteria.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaHarrisCorner Class
Emgu.CV.Cuda Namespace


CudaHarrisCorner Fields

The CudaHarrisCorner type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHarrisCorner Class
Emgu.CV.Cuda Namespace


CudaHOG Class

A HOG descriptor
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaHOG

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaHOG : SharedPtrObject
Public Class CudaHOG
    Inherits SharedPtrObject
public ref class CudaHOG : public SharedPtrObject
type CudaHOG =
    class
        inherit SharedPtrObject
    end

The CudaHOG type exposes the following members.

Constructors
 | Name | Description
Public method | CudaHOG | Create a new HOGDescriptor using the specific parameters
Top
Properties
 | Name | Description
Public property | BlockHistogramSize | Returns the block histogram size.
Public property | DescriptorFormat | The descriptor format
Public property | DescriptorSize | Returns the number of coefficients required for the classification.
Public property | GammaCorrection | Flag to specify whether the gamma correction preprocessing is required or not
Public property | GroupThreshold | Coefficient to regulate the similarity threshold. When detected, some objects can be covered by many rectangles. 0 means not to perform grouping. See groupRectangles.
Public property | HitThreshold | Threshold for the distance between features and SVM classifying plane. Usually it is 0 and should be specfied in the detector coefficients (as the last free coefficient). But if the free coefficient is omitted (which is allowed), you can specify it manually here.
Public property | L2HysThreshold | L2-Hys normalization method shrinkage.
Public property | NumLevels | Maximum number of detection window increases
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ScaleFactor | Coefficient of the detection window increase.
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | WinSigma | Gaussian smoothing window parameter
Public property | WinStride | Window stride. It must be a multiple of block stride.
Top
Methods
 | Name | Description
Public method | DetectMultiScale(IInputArray) | Performs object detection with increasing detection window.
Public method | DetectMultiScale(IInputArray, VectorOfRect, VectorOfDouble) | Performs object detection with a multi-scale window.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this HOGDescriptor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetDefaultPeopleDetector | Returns coefficients of the classifier trained for people detection (for default window size).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetSVMDetector | Set the SVM detector
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaHOG Constructor

Create a new HOGDescriptor using the specific parameters

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaHOG(
    Size winSize,
    Size blockSize,
    Size blockStride,
    Size cellSize,
    int nbins = 9
)
Public Sub New (
    winSize As Size,
    blockSize As Size,
    blockStride As Size,
    cellSize As Size,
    Optional nbins As Integer = 9
)
public:
CudaHOG(
    Size^ winSize,
    Size^ blockSize,
    Size^ blockStride,
    Size^ cellSize,
    int nbins = 9
)
new :
        winSize : Size *
        blockSize : Size *
        blockStride : Size *
        cellSize : Size *
        ?nbins : int
(* Defaults:
        let _nbins = defaultArg nbins 9
*)
-> CudaHOG

Parameters

winSize
Type: System.DrawingSize
Detection window size. Must be aligned to block size and block stride. Must match the size of the training image. Use (64, 128) for default.
blockSize
Type: System.DrawingSize
Block size in cells. Use (16, 16) for default.
blockStride
Type: System.DrawingSize
Block stride. Must be a multiple of cell size. Use (8,8) for default.
cellSize
Type: System.DrawingSize
Cell size. Use (8, 8) for default.
nbins (Optional)
Type: SystemInt32
Number of bins.
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG Properties

The CudaHOG type exposes the following members.

Properties
 | Name | Description
Public property | BlockHistogramSize | Returns the block histogram size.
Public property | DescriptorFormat | The descriptor format
Public property | DescriptorSize | Returns the number of coefficients required for the classification.
Public property | GammaCorrection | Flag to specify whether the gamma correction preprocessing is required or not
Public property | GroupThreshold | Coefficient to regulate the similarity threshold. When detected, some objects can be covered by many rectangles. 0 means not to perform grouping. See groupRectangles.
Public property | HitThreshold | Threshold for the distance between features and SVM classifying plane. Usually it is 0 and should be specfied in the detector coefficients (as the last free coefficient). But if the free coefficient is omitted (which is allowed), you can specify it manually here.
Public property | L2HysThreshold | L2-Hys normalization method shrinkage.
Public property | NumLevels | Maximum number of detection window increases
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ScaleFactor | Coefficient of the detection window increase.
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | WinSigma | Gaussian smoothing window parameter
Public property | WinStride | Window stride. It must be a multiple of block stride.
Top
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.BlockHistogramSize Property

CudaHOGBlockHistogramSize Property

Returns the block histogram size.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BlockHistogramSize { get; }
Public ReadOnly Property BlockHistogramSize As IntPtr
    Get
public:
property IntPtr BlockHistogramSize {
    IntPtr get ();
}
member BlockHistogramSize : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.DescriptorFormat Property

CudaHOGDescriptorFormat Property

The descriptor format

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaHOGDescrFormat DescriptorFormat { get; }
Public ReadOnly Property DescriptorFormat As CudaHOGDescrFormat
    Get
public:
property CudaHOGDescrFormat^ DescriptorFormat {
    CudaHOGDescrFormat^ get ();
}
member DescriptorFormat : CudaHOGDescrFormat with get

Property Value

Type: CudaHOGDescrFormat
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.DescriptorSize Property

CudaHOGDescriptorSize Property

Returns the number of coefficients required for the classification.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DescriptorSize { get; }
Public ReadOnly Property DescriptorSize As IntPtr
    Get
public:
property IntPtr DescriptorSize {
    IntPtr get ();
}
member DescriptorSize : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.GammaCorrection Property

CudaHOGGammaCorrection Property

Flag to specify whether the gamma correction preprocessing is required or not

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool GammaCorrection { get; set; }
Public Property GammaCorrection As Boolean
    Get
    Set
public:
property bool GammaCorrection {
    bool get ();
    void set (bool value);
}
member GammaCorrection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.GroupThreshold Property

CudaHOGGroupThreshold Property

Coefficient to regulate the similarity threshold. When detected, some objects can be covered by many rectangles. 0 means not to perform grouping. See groupRectangles.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GroupThreshold { get; set; }
Public Property GroupThreshold As Integer
    Get
    Set
public:
property int GroupThreshold {
    int get ();
    void set (int value);
}
member GroupThreshold : int with get, set

Property Value

Type: Int32
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.HitThreshold Property

CudaHOGHitThreshold Property

Threshold for the distance between features and SVM classifying plane. Usually it is 0 and should be specfied in the detector coefficients (as the last free coefficient). But if the free coefficient is omitted (which is allowed), you can specify it manually here.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double HitThreshold { get; set; }
Public Property HitThreshold As Double
    Get
    Set
public:
property double HitThreshold {
    double get ();
    void set (double value);
}
member HitThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.L2HysThreshold Property

CudaHOGL2HysThreshold Property

L2-Hys normalization method shrinkage.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double L2HysThreshold { get; set; }
Public Property L2HysThreshold As Double
    Get
    Set
public:
property double L2HysThreshold {
    double get ();
    void set (double value);
}
member L2HysThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.NumLevels Property

CudaHOGNumLevels Property

Maximum number of detection window increases

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumLevels { get; set; }
Public Property NumLevels As Integer
    Get
    Set
public:
property int NumLevels {
    int get ();
    void set (int value);
}
member NumLevels : int with get, set

Property Value

Type: Int32
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.ScaleFactor Property

CudaHOGScaleFactor Property

Coefficient of the detection window increase.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ScaleFactor { get; set; }
Public Property ScaleFactor As Double
    Get
    Set
public:
property double ScaleFactor {
    double get ();
    void set (double value);
}
member ScaleFactor : float with get, set

Property Value

Type: Double
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.WinSigma Property

CudaHOGWinSigma Property

Gaussian smoothing window parameter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double WinSigma { get; set; }
Public Property WinSigma As Double
    Get
    Set
public:
property double WinSigma {
    double get ();
    void set (double value);
}
member WinSigma : float with get, set

Property Value

Type: Double
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.WinStride Property

CudaHOGWinStride Property

Window stride. It must be a multiple of block stride.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size WinStride { get; set; }
Public Property WinStride As Size
    Get
    Set
public:
property Size^ WinStride {
    Size^ get ();
    void set (Size^ value);
}
member WinStride : Size with get, set

Property Value

Type: Size
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG Methods

The CudaHOG type exposes the following members.

Methods
 | Name | Description
Public method | DetectMultiScale(IInputArray) | Performs object detection with increasing detection window.
Public method | DetectMultiScale(IInputArray, VectorOfRect, VectorOfDouble) | Performs object detection with a multi-scale window.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this HOGDescriptor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetDefaultPeopleDetector | Returns coefficients of the classifier trained for people detection (for default window size).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetSVMDetector | Set the SVM detector
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.DetectMultiScale Method

CudaHOGDetectMultiScale Method

Overload List
 | Name | Description
Public method | DetectMultiScale(IInputArray) | Performs object detection with increasing detection window.
Public method | DetectMultiScale(IInputArray, VectorOfRect, VectorOfDouble) | Performs object detection with a multi-scale window.
Top
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.DetectMultiScale Method (IInputArray)

CudaHOGDetectMultiScale Method (IInputArray)

http://www.emgu.com
Performs object detection with increasing detection window.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvObjectDetection[] DetectMultiScale(
    IInputArray image
)
Public Function DetectMultiScale (
    image As IInputArray
) As MCvObjectDetection()
public:
array<MCvObjectDetection^>^ DetectMultiScale(
    IInputArray^ image
)
member DetectMultiScale :
        image : IInputArray -> MCvObjectDetection[]

Parameters

image
Type: Emgu.CVIInputArray
The CudaImage to search in

Return Value

Type: MCvObjectDetection
The regions where positives are found
See Also

Reference

CudaHOG Class
DetectMultiScale Overload
Emgu.CV.Cuda Namespace


CudaHOG.DetectMultiScale Method (IInputArray, VectorOfRect, VectorOfDouble)

CudaHOGDetectMultiScale Method (IInputArray, VectorOfRect, VectorOfDouble)

http://www.emgu.com
Performs object detection with a multi-scale window.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DetectMultiScale(
    IInputArray image,
    VectorOfRect objects,
    VectorOfDouble confident = null
)
Public Sub DetectMultiScale (
    image As IInputArray,
    objects As VectorOfRect,
    Optional confident As VectorOfDouble = Nothing
)
public:
void DetectMultiScale(
    IInputArray^ image,
    VectorOfRect^ objects,
    VectorOfDouble^ confident = nullptr
)
member DetectMultiScale :
        image : IInputArray *
        objects : VectorOfRect *
        ?confident : VectorOfDouble
(* Defaults:
        let _confident = defaultArg confident null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Source image.
objects
Type: Emgu.CV.UtilVectorOfRect
Detected objects boundaries.
confident (Optional)
Type: Emgu.CV.UtilVectorOfDouble
Optional output array for confidences.
See Also

Reference

CudaHOG Class
DetectMultiScale Overload
Emgu.CV.Cuda Namespace


CudaHOG.DisposeObject Method

CudaHOGDisposeObject Method

Release the unmanaged memory associated with this HOGDescriptor

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.GetDefaultPeopleDetector Method

CudaHOGGetDefaultPeopleDetector Method

Returns coefficients of the classifier trained for people detection (for default window size).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat GetDefaultPeopleDetector()
Public Function GetDefaultPeopleDetector As Mat
public:
Mat^ GetDefaultPeopleDetector()
member GetDefaultPeopleDetector : unit -> Mat

Return Value

Type: Mat
The default people detector
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.SetSVMDetector Method

CudaHOGSetSVMDetector Method

Set the SVM detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetSVMDetector(
    IInputArray detector
)
Public Sub SetSVMDetector (
    detector As IInputArray
)
public:
void SetSVMDetector(
    IInputArray^ detector
)
member SetSVMDetector :
        detector : IInputArray -> unit

Parameters

detector
Type: Emgu.CVIInputArray
The SVM detector
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG Fields

The CudaHOG type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHOG Class
Emgu.CV.Cuda Namespace


CudaHOG.DescrFormat Class

CudaHOGDescrFormat Class

The descriptor format
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CudaCudaHOGDescrFormat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DescrFormat : Enum
Public NotInheritable Class DescrFormat
    Inherits Enum
public ref class DescrFormat sealed : public Enum
[<SealedAttribute>]
type DescrFormat =
    class
        inherit Enum
    end

The CudaHOGDescrFormat type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ColByCol | Col by col
 | RowByRow | Row by row
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Cuda Namespace


DescrFormat Methods

The CudaHOGDescrFormat type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CudaHOGDescrFormat Class
Emgu.CV.Cuda Namespace


DescrFormat Fields

The CudaHOGDescrFormat type exposes the following members.

Fields
 | Name | Description
 | ColByCol | Col by col
 | RowByRow | Row by row
Public field | value__ |
Top
See Also

Reference

CudaHOGDescrFormat Class
Emgu.CV.Cuda Namespace


CudaHOG.DescrFormat.ColByCol Field

CudaHOGDescrFormatColByCol Field

Col by col

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaHOGDescrFormat ColByCol = 1
Public Const ColByCol As CudaHOGDescrFormat = 1
public:
literal CudaHOGDescrFormat^ ColByCol = 1
static val mutable ColByCol: CudaHOGDescrFormat

Field Value

Type: CudaHOGDescrFormat
See Also

Reference

CudaHOGDescrFormat Class
Emgu.CV.Cuda Namespace


CudaHOG.DescrFormat.RowByRow Field

CudaHOGDescrFormatRowByRow Field

Row by row

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaHOGDescrFormat RowByRow = 0
Public Const RowByRow As CudaHOGDescrFormat = 0
public:
literal CudaHOGDescrFormat^ RowByRow = 0
static val mutable RowByRow: CudaHOGDescrFormat

Field Value

Type: CudaHOGDescrFormat
See Also

Reference

CudaHOGDescrFormat Class
Emgu.CV.Cuda Namespace


CudaHOG.DescrFormat.value__ Field

CudaHOGDescrFormatvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaHOG.DescrFormat.value__"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CudaHOGDescrFormat Class
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector Class

Base class for circles detector algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaHoughCirclesDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaHoughCirclesDetector : SharedPtrObject
Public Class CudaHoughCirclesDetector
    Inherits SharedPtrObject
public ref class CudaHoughCirclesDetector : public SharedPtrObject
type CudaHoughCirclesDetector =
    class
        inherit SharedPtrObject
    end

The CudaHoughCirclesDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CudaHoughCirclesDetector | Create hough circles detector
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Detect(IInputArray) | Finds circles in a grayscale image using the Hough transform.
Public method | Detect(IInputArray, IOutputArray, Stream) | Finds circles in a grayscale image using the Hough transform.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this circle detector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector Constructor

Create hough circles detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaHoughCirclesDetector(
    float dp,
    float minDist,
    int cannyThreshold,
    int votesThreshold,
    int minRadius,
    int maxRadius,
    int maxCircles = 4096
)
Public Sub New (
    dp As Single,
    minDist As Single,
    cannyThreshold As Integer,
    votesThreshold As Integer,
    minRadius As Integer,
    maxRadius As Integer,
    Optional maxCircles As Integer = 4096
)
public:
CudaHoughCirclesDetector(
    float dp,
    float minDist,
    int cannyThreshold,
    int votesThreshold,
    int minRadius,
    int maxRadius,
    int maxCircles = 4096
)
new :
        dp : float32 *
        minDist : float32 *
        cannyThreshold : int *
        votesThreshold : int *
        minRadius : int *
        maxRadius : int *
        ?maxCircles : int
(* Defaults:
        let _maxCircles = defaultArg maxCircles 4096
*)
-> CudaHoughCirclesDetector

Parameters

dp
Type: SystemSingle
Inverse ratio of the accumulator resolution to the image resolution. For example, if dp=1 , the accumulator has the same resolution as the input image. If dp=2 , the accumulator has half as big width and height.
minDist
Type: SystemSingle
Minimum distance between the centers of the detected circles. If the parameter is too small, multiple neighbor circles may be falsely detected in addition to a true one. If it is too large, some circles may be missed.
cannyThreshold
Type: SystemInt32
The higher threshold of the two passed to Canny edge detector (the lower one is twice smaller).
votesThreshold
Type: SystemInt32
The accumulator threshold for the circle centers at the detection stage. The smaller it is, the more false circles may be detected.
minRadius
Type: SystemInt32
Minimum circle radius.
maxRadius
Type: SystemInt32
Maximum circle radius.
maxCircles (Optional)
Type: SystemInt32
Maximum number of output circles.
See Also

Reference

CudaHoughCirclesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector Properties

The CudaHoughCirclesDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHoughCirclesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector Methods

The CudaHoughCirclesDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect(IInputArray) | Finds circles in a grayscale image using the Hough transform.
Public method | Detect(IInputArray, IOutputArray, Stream) | Finds circles in a grayscale image using the Hough transform.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this circle detector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaHoughCirclesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector.Detect Method

CudaHoughCirclesDetectorDetect Method

Overload List
 | Name | Description
Public method | Detect(IInputArray) | Finds circles in a grayscale image using the Hough transform.
Public method | Detect(IInputArray, IOutputArray, Stream) | Finds circles in a grayscale image using the Hough transform.
Top
See Also

Reference

CudaHoughCirclesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector.Detect Method (IInputArray)

CudaHoughCirclesDetectorDetect Method (IInputArray)

http://www.emgu.com
Finds circles in a grayscale image using the Hough transform.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CircleF[] Detect(
    IInputArray image
)
Public Function Detect (
    image As IInputArray
) As CircleF()
public:
array<CircleF^>^ Detect(
    IInputArray^ image
)
member Detect :
        image : IInputArray -> CircleF[]

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel grayscale input image.

Return Value

Type: CircleF
Circles detected
See Also

Reference

CudaHoughCirclesDetector Class
Detect Overload
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector.Detect Method (IInputArray, IOutputArray, Stream)

CudaHoughCirclesDetectorDetect Method (IInputArray, IOutputArray, Stream)

http://www.emgu.com
Finds circles in a grayscale image using the Hough transform.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Detect(
    IInputArray image,
    IOutputArray circles,
    Stream stream = null
)
Public Sub Detect (
    image As IInputArray,
    circles As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Detect(
    IInputArray^ image,
    IOutputArray^ circles,
    Stream^ stream = nullptr
)
member Detect :
        image : IInputArray *
        circles : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel grayscale input image.
circles
Type: Emgu.CVIOutputArray
Output vector of found circles. Each vector is encoded as a 3-element floating-point vector.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaHoughCirclesDetector Class
Detect Overload
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector.DisposeObject Method

CudaHoughCirclesDetectorDisposeObject Method

Release the unmanaged memory associated with this circle detector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaHoughCirclesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughCirclesDetector Fields

The CudaHoughCirclesDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHoughCirclesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector Class

Base class for lines detector algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaHoughLinesDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaHoughLinesDetector : SharedPtrObject
Public Class CudaHoughLinesDetector
    Inherits SharedPtrObject
public ref class CudaHoughLinesDetector : public SharedPtrObject
type CudaHoughLinesDetector =
    class
        inherit SharedPtrObject
    end

The CudaHoughLinesDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CudaHoughLinesDetector | Create a hough lines detector
Top
Properties
 | Name | Description
Public property | DoSort | Performs lines sort by votes
Public property | MaxLines | Maximum number of output lines
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rho | Distance resolution of the accumulator in pixels
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | Theta | Angle resolution of the accumulator in radians
Public property | Threshold | Accumulator threshold parameter. Only those lines are returned that get enough
Top
Methods
 | Name | Description
Public method | Detect | Finds line segments in a binary image using the probabilistic Hough transform.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated to this line detector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaHoughLinesDetector Constructor

Create a hough lines detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaHoughLinesDetector(
    float rho,
    float theta,
    int threshold,
    bool doSort = false,
    int maxLines = 4096
)
Public Sub New (
    rho As Single,
    theta As Single,
    threshold As Integer,
    Optional doSort As Boolean = false,
    Optional maxLines As Integer = 4096
)
public:
CudaHoughLinesDetector(
    float rho,
    float theta,
    int threshold,
    bool doSort = false,
    int maxLines = 4096
)
new :
        rho : float32 *
        theta : float32 *
        threshold : int *
        ?doSort : bool *
        ?maxLines : int
(* Defaults:
        let _doSort = defaultArg doSort false
        let _maxLines = defaultArg maxLines 4096
*)
-> CudaHoughLinesDetector

Parameters

rho
Type: SystemSingle
Distance resolution of the accumulator in pixels.
theta
Type: SystemSingle
Angle resolution of the accumulator in radians.
threshold
Type: SystemInt32
Accumulator threshold parameter. Only those lines are returned that get enough votes (> threshold).
doSort (Optional)
Type: SystemBoolean
Performs lines sort by votes.
maxLines (Optional)
Type: SystemInt32
Maximum number of output lines.
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector Properties

The CudaHoughLinesDetector type exposes the following members.

Properties
 | Name | Description
Public property | DoSort | Performs lines sort by votes
Public property | MaxLines | Maximum number of output lines
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Rho | Distance resolution of the accumulator in pixels
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | Theta | Angle resolution of the accumulator in radians
Public property | Threshold | Accumulator threshold parameter. Only those lines are returned that get enough
Top
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector.DoSort Property

CudaHoughLinesDetectorDoSort Property

Performs lines sort by votes

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DoSort { get; set; }
Public Property DoSort As Boolean
    Get
    Set
public:
property bool DoSort {
    bool get ();
    void set (bool value);
}
member DoSort : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector.MaxLines Property

CudaHoughLinesDetectorMaxLines Property

Maximum number of output lines

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxLines { get; set; }
Public Property MaxLines As Integer
    Get
    Set
public:
property int MaxLines {
    int get ();
    void set (int value);
}
member MaxLines : int with get, set

Property Value

Type: Int32
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector.Rho Property

CudaHoughLinesDetectorRho Property

Distance resolution of the accumulator in pixels

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Rho { get; set; }
Public Property Rho As Single
    Get
    Set
public:
property float Rho {
    float get ();
    void set (float value);
}
member Rho : float32 with get, set

Property Value

Type: Single
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector.Theta Property

CudaHoughLinesDetectorTheta Property

Angle resolution of the accumulator in radians

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Theta { get; set; }
Public Property Theta As Single
    Get
    Set
public:
property float Theta {
    float get ();
    void set (float value);
}
member Theta : float32 with get, set

Property Value

Type: Single
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector.Threshold Property

CudaHoughLinesDetectorThreshold Property

Accumulator threshold parameter. Only those lines are returned that get enough

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Threshold { get; set; }
Public Property Threshold As Integer
    Get
    Set
public:
property int Threshold {
    int get ();
    void set (int value);
}
member Threshold : int with get, set

Property Value

Type: Int32
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector Methods

The CudaHoughLinesDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Finds line segments in a binary image using the probabilistic Hough transform.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated to this line detector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector.Detect Method

CudaHoughLinesDetectorDetect Method

Finds line segments in a binary image using the probabilistic Hough transform.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Detect(
    IInputArray image,
    IOutputArray lines,
    Stream stream = null
)
Public Sub Detect (
    image As IInputArray,
    lines As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Detect(
    IInputArray^ image,
    IOutputArray^ lines,
    Stream^ stream = nullptr
)
member Detect :
        image : IInputArray *
        lines : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel binary source image
lines
Type: Emgu.CVIOutputArray
Output vector of lines.Output vector of lines. Each line is represented by a two-element vector. The first element is the distance from the coordinate origin (top-left corner of the image). The second element is the line rotation angle in radians.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector.DisposeObject Method

CudaHoughLinesDetectorDisposeObject Method

Release the unmanaged memory associated to this line detector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughLinesDetector Fields

The CudaHoughLinesDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHoughLinesDetector Class
Emgu.CV.Cuda Namespace


CudaHoughSegmentDetector Class

Base class for line segments detector algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaHoughSegmentDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaHoughSegmentDetector : SharedPtrObject
Public Class CudaHoughSegmentDetector
    Inherits SharedPtrObject
public ref class CudaHoughSegmentDetector : public SharedPtrObject
type CudaHoughSegmentDetector =
    class
        inherit SharedPtrObject
    end

The CudaHoughSegmentDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CudaHoughSegmentDetector | Create a hough segment detector
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Detect | Finds line segments in a binary image using the probabilistic Hough transform.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this segment detector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaHoughSegmentDetector Constructor

Create a hough segment detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaHoughSegmentDetector(
    float rho,
    float theta,
    int minLineLength,
    int maxLineGap,
    int maxLines = 4096
)
Public Sub New (
    rho As Single,
    theta As Single,
    minLineLength As Integer,
    maxLineGap As Integer,
    Optional maxLines As Integer = 4096
)
public:
CudaHoughSegmentDetector(
    float rho,
    float theta,
    int minLineLength,
    int maxLineGap,
    int maxLines = 4096
)
new :
        rho : float32 *
        theta : float32 *
        minLineLength : int *
        maxLineGap : int *
        ?maxLines : int
(* Defaults:
        let _maxLines = defaultArg maxLines 4096
*)
-> CudaHoughSegmentDetector

Parameters

rho
Type: SystemSingle
Distance resolution of the accumulator in pixels.
theta
Type: SystemSingle
Angle resolution of the accumulator in radians.
minLineLength
Type: SystemInt32
Minimum line length. Line segments shorter than that are rejected.
maxLineGap
Type: SystemInt32
Maximum allowed gap between points on the same line to link them.
maxLines (Optional)
Type: SystemInt32
Maximum number of output lines.
See Also

Reference

CudaHoughSegmentDetector Class
Emgu.CV.Cuda Namespace


CudaHoughSegmentDetector Properties

The CudaHoughSegmentDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHoughSegmentDetector Class
Emgu.CV.Cuda Namespace


CudaHoughSegmentDetector Methods

The CudaHoughSegmentDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Finds line segments in a binary image using the probabilistic Hough transform.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this segment detector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaHoughSegmentDetector Class
Emgu.CV.Cuda Namespace


CudaHoughSegmentDetector.Detect Method

CudaHoughSegmentDetectorDetect Method

Finds line segments in a binary image using the probabilistic Hough transform.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Detect(
    IInputArray image,
    IOutputArray lines,
    Stream stream = null
)
Public Sub Detect (
    image As IInputArray,
    lines As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Detect(
    IInputArray^ image,
    IOutputArray^ lines,
    Stream^ stream = nullptr
)
member Detect :
        image : IInputArray *
        lines : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
8-bit, single-channel binary source image
lines
Type: Emgu.CVIOutputArray
Output vector of lines. Each line is represented by a 4-element vector (x1, y1, x2, y2) , where (x1, y1) and (x2, y2) are the ending points of each detected line segment.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaHoughSegmentDetector Class
Emgu.CV.Cuda Namespace


CudaHoughSegmentDetector.DisposeObject Method

CudaHoughSegmentDetectorDisposeObject Method

Release the unmanaged memory associated with this segment detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaHoughSegmentDetector Class
Emgu.CV.Cuda Namespace


CudaHoughSegmentDetector Fields

The CudaHoughSegmentDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaHoughSegmentDetector Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Class

CudaImageTColor, TDepth Class

An CudaImage is very similar to the Emgu.CV.Image except that it is being used for GPU processing
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CudaGpuMat
Emgu.CV.CudaGpuMat TDepth
Emgu.CV.CudaCudaImageTColor, TDepth

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaImage<TColor, TDepth> : GpuMat<TDepth>
where TColor : struct, new(), IColor
where TDepth : new()

Public Class CudaImage(Of TColor As {Structure, New, IColor}, TDepth As New)
    Inherits GpuMat(Of TDepth)
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
public ref class CudaImage : public GpuMat<TDepth>
type CudaImage<'TColor, 'TDepth when 'TColor : struct, new() and IColor when 'TDepth : new()> =
    class
        inherit GpuMat<'TDepth>
    end

Type Parameters

TColor
Color type of this image (either Gray, Bgr, Bgra, Hsv, Hls, Lab, Luv, Xyz, Ycc, Rgb or Rbga)
TDepth
Depth of this image (either Byte, SByte, Single, double, UInt16, Int16 or Int32)

The CudaImageTColor, TDepth type exposes the following members.

Constructors
 | Name | Description
Public method | CudaImageTColor, TDepth | Create an empty CudaImage
Public method | CudaImageTColor, TDepth(Size) | Create a CudaImage of the specific size
Public method | CudaImageTColor, TDepth(IInputArray) | Create a GPU image from a regular image
Public method | CudaImageTColor, TDepth(Int32, Int32) | Create a CudaImage of the specific size
Public method | CudaImageTColor, TDepth(Int32, Int32, Boolean) | Create a CudaImage of the specific size
Public method | CudaImageTColor, TDepth(CudaImageTColor, TDepth, Range, Range) | Create a CudaImage from the specific region of image. The data is shared between the two CudaImage
Top
Properties
 | Name | Description
Public property | Depth | Depth type (Inherited from GpuMat.)
Public property | IsContinuous | True if the data is continues (Inherited from GpuMat.)
Public property | IsEmpty | True if the matrix is empty (Inherited from GpuMat.)
Public property | NumberOfChannels | Number of channels (Inherited from GpuMat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the GpuMat size: width == number of columns, height == number of rows (Inherited from GpuMat.)
Public property | Type | Get the type of the GpuMat (Inherited from GpuMat.)
Top
Methods
 | Name | Description
Public method | Clone | Make a clone of the GpuMat (Inherited from GpuMat.)
Public method | Clone(Stream) | Create a clone of this CudaImage
Public method | Col | Returns a CudaImage corresponding to the ith column of the CudaImage. The data is shared with the current Image.
Public method | ColRange | Returns a CudaImage corresponding to the [startend) columns of the CudaImage. The data is shared with the current Image.
Public method | ConvertTOtherColor, TOtherDepth | Convert the current CudaImage to the specific color and depth
Public method | ConvertFromTSrcColor, TSrcDepth | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Public method | ConvertTo | This function has several different purposes and thus has several synonyms. It copies one GpuMat to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel GpuMats are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination GpuMat element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate convertTo synonym. (Inherited from GpuMat.)
Public method | CopyTo | Copy the source GpuMat to destination GpuMat, using an optional mask. (Inherited from GpuMat.)
Public method | Create | allocates new GpuMat data unless the GpuMat already has specified size and type (Inherited from GpuMat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this GpuMat (Inherited from GpuMat.)
Public method | Download | Downloads data from device to host memory. (Inherited from GpuMat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(GpuMat) | Returns true if the two GpuMat equals (Inherited from GpuMat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array (Inherited from GpuMat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from GpuMat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from GpuMat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from GpuMat.)
Public method | GetSubRect | Returns a CudaImage corresponding to a specified rectangle of the current CudaImage. The data is shared with the current matrix. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFrom | Makes multi-channel array out of several single-channel arrays (Inherited from GpuMat.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from GpuMat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes shape of GpuMat without copying data. (Inherited from GpuMat.)
Public method | Resize | Resize the CudaImage. The calling GpuMat be GpuMat%lt;Byte>. If stream is specified, it has to be either 1 or 4 channels.
Public method | Row | Returns a CudaImage corresponding to the ith row of the CudaImage. The data is shared with the current Image.
Public method | RowRange | Returns a CudaImage corresponding to the [startend) rows of the CudaImage. The data is shared with the current Image.
Public method | Save | Save the GpuMat to a file (Inherited from GpuMat.)
Public method | SetTo | Copies scalar value to every selected element of the destination GpuMat: arr(I)=value if mask(I)!=0 (Inherited from GpuMat.)
Public method | Split | Split current GpuMat into an array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat (Inherited from GpuMat.)
Public method | ToImage | Convert the current CudaImage to a regular Image.
Public method | ToMat | Convert the GpuMat to Mat (Inherited from GpuMat.)
Public method | ToMatrix | Convert this GpuMat to a Matrix (Inherited from GpuMatTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upload | Upload data to GpuMat (Inherited from GpuMat.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Constructor

CudaImageTColor, TDepth Constructor

Overload List
 | Name | Description
Public method | CudaImageTColor, TDepth | Create an empty CudaImage
Public method | CudaImageTColor, TDepth(Size) | Create a CudaImage of the specific size
Public method | CudaImageTColor, TDepth(IInputArray) | Create a GPU image from a regular image
Public method | CudaImageTColor, TDepth(Int32, Int32) | Create a CudaImage of the specific size
Public method | CudaImageTColor, TDepth(Int32, Int32, Boolean) | Create a CudaImage of the specific size
Public method | CudaImageTColor, TDepth(CudaImageTColor, TDepth, Range, Range) | Create a CudaImage from the specific region of image. The data is shared between the two CudaImage
Top
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Constructor

CudaImageTColor, TDepth Constructor

Create an empty CudaImage

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage()
Public Sub New
public:
CudaImage()
new : unit -> CudaImage
See Also

Reference

CudaImageTColor, TDepth Class
CudaImageTColor, TDepth Overload
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Constructor (Size)

CudaImageTColor, TDepth Constructor (Size)

http://www.emgu.com
Create a CudaImage of the specific size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage(
    Size size
)
Public Sub New (
    size As Size
)
public:
CudaImage(
    Size^ size
)
new :
        size : Size -> CudaImage

Parameters

size
Type: System.DrawingSize
The size of the image
See Also

Reference

CudaImageTColor, TDepth Class
CudaImageTColor, TDepth Overload
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Constructor (IInputArray)

CudaImageTColor, TDepth Constructor (IInputArray)

http://www.emgu.com
Create a GPU image from a regular image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage(
    IInputArray img
)
Public Sub New (
    img As IInputArray
)
public:
CudaImage(
    IInputArray^ img
)
new :
        img : IInputArray -> CudaImage

Parameters

img
Type: Emgu.CVIInputArray
The image to be converted to GPU image
See Also

Reference

CudaImageTColor, TDepth Class
CudaImageTColor, TDepth Overload
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Constructor (Int32, Int32)

CudaImageTColor, TDepth Constructor (Int32, Int32)

http://www.emgu.com
Create a CudaImage of the specific size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage(
    int rows,
    int cols
)
Public Sub New (
    rows As Integer,
    cols As Integer
)
public:
CudaImage(
    int rows,
    int cols
)
new :
        rows : int *
        cols : int -> CudaImage

Parameters

rows
Type: SystemInt32
The number of rows (height)
cols
Type: SystemInt32
The number of columns (width)
See Also

Reference

CudaImageTColor, TDepth Class
CudaImageTColor, TDepth Overload
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Constructor (Int32, Int32, Boolean)

CudaImageTColor, TDepth Constructor (Int32, Int32, Boolean)

http://www.emgu.com
Create a CudaImage of the specific size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage(
    int rows,
    int cols,
    bool continuous
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    continuous As Boolean
)
public:
CudaImage(
    int rows,
    int cols,
    bool continuous
)
new :
        rows : int *
        cols : int *
        continuous : bool -> CudaImage

Parameters

rows
Type: SystemInt32
The number of rows (height)
cols
Type: SystemInt32
The number of columns (width)
continuous
Type: SystemBoolean
Indicates if the data should be continuous
See Also

Reference

CudaImageTColor, TDepth Class
CudaImageTColor, TDepth Overload
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Constructor (CudaImage(TColor, TDepth), Range, Range)

CudaImageTColor, TDepth Constructor (CudaImageTColor, TDepth, Range, Range)

http://www.emgu.com
Create a CudaImage from the specific region of image. The data is shared between the two CudaImage

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage(
    CudaImage<TColor, TDepth> image,
    Range rowRange,
    Range colRange
)
Public Sub New (
    image As CudaImage(Of TColor, TDepth),
    rowRange As Range,
    colRange As Range
)
public:
CudaImage(
    CudaImage<TColor, TDepth>^ image,
    Range^ rowRange,
    Range^ colRange
)
new :
        image : CudaImage<'TColor, 'TDepth> *
        rowRange : Range *
        colRange : Range -> CudaImage

Parameters

image
Type: Emgu.CV.CudaCudaImage TColor, TDepth
The CudaImage where the region is extracted from
rowRange
Type: Emgu.CV.StructureRange
The row range. Use MCvSlice.WholeSeq for all rows.
colRange
Type: Emgu.CV.StructureRange
The column range. Use MCvSlice.WholeSeq for all columns.
See Also

Reference

CudaImageTColor, TDepth Class
CudaImageTColor, TDepth Overload
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Properties

CudaImageTColor, TDepth Properties

The CudaImageTColor, TDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Depth type (Inherited from GpuMat.)
Public property | IsContinuous | True if the data is continues (Inherited from GpuMat.)
Public property | IsEmpty | True if the matrix is empty (Inherited from GpuMat.)
Public property | NumberOfChannels | Number of channels (Inherited from GpuMat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the GpuMat size: width == number of columns, height == number of rows (Inherited from GpuMat.)
Public property | Type | Get the type of the GpuMat (Inherited from GpuMat.)
Top
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Methods

CudaImageTColor, TDepth Methods

The CudaImageTColor, TDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Make a clone of the GpuMat (Inherited from GpuMat.)
Public method | Clone(Stream) | Create a clone of this CudaImage
Public method | Col | Returns a CudaImage corresponding to the ith column of the CudaImage. The data is shared with the current Image.
Public method | ColRange | Returns a CudaImage corresponding to the [startend) columns of the CudaImage. The data is shared with the current Image.
Public method | ConvertTOtherColor, TOtherDepth | Convert the current CudaImage to the specific color and depth
Public method | ConvertFromTSrcColor, TSrcDepth | Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.
Public method | ConvertTo | This function has several different purposes and thus has several synonyms. It copies one GpuMat to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel GpuMats are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination GpuMat element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate convertTo synonym. (Inherited from GpuMat.)
Public method | CopyTo | Copy the source GpuMat to destination GpuMat, using an optional mask. (Inherited from GpuMat.)
Public method | Create | allocates new GpuMat data unless the GpuMat already has specified size and type (Inherited from GpuMat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this GpuMat (Inherited from GpuMat.)
Public method | Download | Downloads data from device to host memory. (Inherited from GpuMat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(GpuMat) | Returns true if the two GpuMat equals (Inherited from GpuMat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array (Inherited from GpuMat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from GpuMat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from GpuMat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from GpuMat.)
Public method | GetSubRect | Returns a CudaImage corresponding to a specified rectangle of the current CudaImage. The data is shared with the current matrix. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFrom | Makes multi-channel array out of several single-channel arrays (Inherited from GpuMat.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from GpuMat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes shape of GpuMat without copying data. (Inherited from GpuMat.)
Public method | Resize | Resize the CudaImage. The calling GpuMat be GpuMat%lt;Byte>. If stream is specified, it has to be either 1 or 4 channels.
Public method | Row | Returns a CudaImage corresponding to the ith row of the CudaImage. The data is shared with the current Image.
Public method | RowRange | Returns a CudaImage corresponding to the [startend) rows of the CudaImage. The data is shared with the current Image.
Public method | Save | Save the GpuMat to a file (Inherited from GpuMat.)
Public method | SetTo | Copies scalar value to every selected element of the destination GpuMat: arr(I)=value if mask(I)!=0 (Inherited from GpuMat.)
Public method | Split | Split current GpuMat into an array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat (Inherited from GpuMat.)
Public method | ToImage | Convert the current CudaImage to a regular Image.
Public method | ToMat | Convert the GpuMat to Mat (Inherited from GpuMat.)
Public method | ToMatrix | Convert this GpuMat to a Matrix (Inherited from GpuMatTDepth.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upload | Upload data to GpuMat (Inherited from GpuMat.)
Top
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).Clone Method

CudaImageTColor, TDepthClone Method

Overload List
 | Name | Description
Public method | Clone | Make a clone of the GpuMat (Inherited from GpuMat.)
Public method | Clone(Stream) | Create a clone of this CudaImage
Top
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).Clone Method (Stream)

CudaImageTColor, TDepthClone Method (Stream)

http://www.emgu.com
Create a clone of this CudaImage

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TColor, TDepth> Clone(
    Stream stream
)
Public Function Clone (
    stream As Stream
) As CudaImage(Of TColor, TDepth)
public:
CudaImage<TColor, TDepth>^ Clone(
    Stream^ stream
)
member Clone :
        stream : Stream -> CudaImage<'TColor, 'TDepth>

Parameters

stream
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Return Value

Type: CudaImage TColor, TDepth
A clone of this CudaImage
See Also

Reference

CudaImageTColor, TDepth Class
Clone Overload
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).Col Method

CudaImageTColor, TDepthCol Method

Returns a CudaImage corresponding to the ith column of the CudaImage. The data is shared with the current Image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TColor, TDepth> Col(
    int i
)
Public Function Col (
    i As Integer
) As CudaImage(Of TColor, TDepth)
public:
CudaImage<TColor, TDepth>^ Col(
    int i
)
member Col :
        i : int -> CudaImage<'TColor, 'TDepth>

Parameters

i
Type: SystemInt32
The column to be extracted

Return Value

Type: CudaImage TColor, TDepth
The ith column of the CudaImage
Remarks
The parent CudaImage should never be released before the returned CudaImage that represent the subregion
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).ColRange Method

CudaImageTColor, TDepthColRange Method

Returns a CudaImage corresponding to the [startend) columns of the CudaImage. The data is shared with the current Image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TColor, TDepth> ColRange(
    int start,
    int end
)
Public Function ColRange (
    start As Integer,
    end As Integer
) As CudaImage(Of TColor, TDepth)
public:
CudaImage<TColor, TDepth>^ ColRange(
    int start,
    int end
)
member ColRange :
        start : int *
        end : int -> CudaImage<'TColor, 'TDepth>

Parameters

start
Type: SystemInt32
The inclusive stating column to be extracted
end
Type: SystemInt32
The exclusive ending column to be extracted

Return Value

Type: CudaImage TColor, TDepth
The [startend) columns of the CudaImage
Remarks
The parent CudaImage should never be released before the returned CudaImage that represent the subregion
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).Convert(TOtherColor, TOtherDepth) Method

CudaImageTColor, TDepthConvertTOtherColor, TOtherDepth Method

http://www.emgu.com
Convert the current CudaImage to the specific color and depth

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TOtherColor, TOtherDepth> Convert<TOtherColor, TOtherDepth>()
where TOtherColor : struct, new(), IColor
where TOtherDepth : new()

Public Function Convert(Of TOtherColor As {Structure, New, IColor}, TOtherDepth As New) As CudaImage(Of TOtherColor, TOtherDepth)
public:
generic<typename TOtherColor, typename TOtherDepth>
where TOtherColor : value class, gcnew(), IColor
where TOtherDepth : gcnew()
CudaImage<TOtherColor, TOtherDepth>^ Convert()
member Convert : unit -> CudaImage<'TOtherColor, 'TOtherDepth>  when 'TOtherColor : struct, new() and IColor when 'TOtherDepth : new()

Type Parameters

TOtherColor
The type of color to be converted to
TOtherDepth
The type of pixel depth to be converted to

Return Value

Type: CudaImage TOtherColor, TOtherDepth
CudaImage of the specific color and depth
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).ConvertFrom(TSrcColor, TSrcDepth) Method

CudaImageTColor, TDepthConvertFromTSrcColor, TSrcDepth Method

http://www.emgu.com
Convert the source image to the current image, if the size are different, the current image will be a resized version of the srcImage.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ConvertFrom<TSrcColor, TSrcDepth>(
    CudaImage<TSrcColor, TSrcDepth> srcImage
)
where TSrcColor : struct, new(), IColor
where TSrcDepth : new()

Public Sub ConvertFrom(Of TSrcColor As {Structure, New, IColor}, TSrcDepth As New) (
    srcImage As CudaImage(Of TSrcColor, TSrcDepth)
)
public:
generic<typename TSrcColor, typename TSrcDepth>
where TSrcColor : value class, gcnew(), IColor
where TSrcDepth : gcnew()
void ConvertFrom(
    CudaImage<TSrcColor, TSrcDepth>^ srcImage
)
member ConvertFrom :
        srcImage : CudaImage<'TSrcColor, 'TSrcDepth> -> unit  when 'TSrcColor : struct, new() and IColor when 'TSrcDepth : new()

Parameters

srcImage
Type: Emgu.CV.CudaCudaImage TSrcColor, TSrcDepth
The sourceImage

Type Parameters

TSrcColor
The color type of the source image
TSrcDepth
The color depth of the source image
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).GetSubRect Method

CudaImageTColor, TDepthGetSubRect Method

Returns a CudaImage corresponding to a specified rectangle of the current CudaImage. The data is shared with the current matrix. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TColor, TDepth> GetSubRect(
    Rectangle region
)
Public Function GetSubRect (
    region As Rectangle
) As CudaImage(Of TColor, TDepth)
public:
CudaImage<TColor, TDepth>^ GetSubRect(
    Rectangle^ region
)
member GetSubRect :
        region : Rectangle -> CudaImage<'TColor, 'TDepth>

Parameters

region
Type: System.DrawingRectangle
Zero-based coordinates of the rectangle of interest.

Return Value

Type: CudaImage TColor, TDepth
A CudaImage that represent the region of the current CudaImage.
Remarks
The parent CudaImage should never be released before the returned CudaImage that represent the subregion
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).Resize Method

CudaImageTColor, TDepthResize Method

Resize the CudaImage. The calling GpuMat be GpuMat%lt;Byte>. If stream is specified, it has to be either 1 or 4 channels.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TColor, TDepth> Resize(
    Size size,
    Inter interpolationType,
    Stream stream = null
)
Public Function Resize (
    size As Size,
    interpolationType As Inter,
    Optional stream As Stream = Nothing
) As CudaImage(Of TColor, TDepth)
public:
CudaImage<TColor, TDepth>^ Resize(
    Size^ size,
    Inter^ interpolationType,
    Stream^ stream = nullptr
)
member Resize :
        size : Size *
        interpolationType : Inter *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> CudaImage<'TColor, 'TDepth>

Parameters

size
Type: System.DrawingSize
The new size
interpolationType
Type: Emgu.CV.CvEnumInter
The interpolation type
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Return Value

Type: CudaImage TColor, TDepth
A CudaImage of the new size
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).Row Method

CudaImageTColor, TDepthRow Method

Returns a CudaImage corresponding to the ith row of the CudaImage. The data is shared with the current Image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TColor, TDepth> Row(
    int i
)
Public Function Row (
    i As Integer
) As CudaImage(Of TColor, TDepth)
public:
CudaImage<TColor, TDepth>^ Row(
    int i
)
member Row :
        i : int -> CudaImage<'TColor, 'TDepth>

Parameters

i
Type: SystemInt32
The row to be extracted

Return Value

Type: CudaImage TColor, TDepth
The ith row of the CudaImage
Remarks
The parent CudaImage should never be released before the returned CudaImage that represent the subregion
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).RowRange Method

CudaImageTColor, TDepthRowRange Method

Returns a CudaImage corresponding to the [startend) rows of the CudaImage. The data is shared with the current Image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaImage<TColor, TDepth> RowRange(
    int start,
    int end
)
Public Function RowRange (
    start As Integer,
    end As Integer
) As CudaImage(Of TColor, TDepth)
public:
CudaImage<TColor, TDepth>^ RowRange(
    int start,
    int end
)
member RowRange :
        start : int *
        end : int -> CudaImage<'TColor, 'TDepth>

Parameters

start
Type: SystemInt32
The inclusive stating row to be extracted
end
Type: SystemInt32
The exclusive ending row to be extracted

Return Value

Type: CudaImage TColor, TDepth
The [startend) rows of the CudaImage
Remarks
The parent CudaImage should never be released before the returned CudaImage that represent the subregion
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth).ToImage Method

CudaImageTColor, TDepthToImage Method

Convert the current CudaImage to a regular Image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<TColor, TDepth> ToImage()
Public Function ToImage As Image(Of TColor, TDepth)
public:
Image<TColor, TDepth>^ ToImage()
member ToImage : unit -> Image<'TColor, 'TDepth>

Return Value

Type: Image TColor, TDepth
A regular image
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaImage(TColor, TDepth) Fields

CudaImageTColor, TDepth Fields

The CudaImageTColor, TDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CudaImageTColor, TDepth Class
Emgu.CV.Cuda Namespace


CudaInvoke Class

This class wraps the functional calls to the opencv_gpu module
Inheritance Hierarchy
SystemObject
Emgu.CV.CudaCudaInvoke

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class CudaInvoke
<ExtensionAttribute>
Public NotInheritable Class CudaInvoke
[ExtensionAttribute]
public ref class CudaInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type CudaInvoke =  class end

The CudaInvoke type exposes the following members.

Properties
Name | Description
HasCuda | Return true if Cuda is found on the system
Top
Methods
Name | Description
Abs | Computes absolute value of each pixel in an image
Absdiff | Computes element-wise absolute difference of two GpuMats (c = abs(a - b)).
AbsSum | Returns the sum of absolute values for matrix elements.
Add | Adds one matrix to another (c = a + b).
AddWeighted | Computes the weighted sum of two arrays (dst = alpha*src1 + beta*src2 + gamma)
AlphaComp | Composites two images using alpha opacity values contained in each image.
BilateralFilter | Applies bilateral filter to the image.
BitwiseAnd | Calculates per-element bit-wise logical and of two GpuMats: dst(I)=src1(I) & src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BitwiseNot | Calculates per-element bit-wise logical not dst(I)=~src(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BitwiseOr | Calculates per-element bit-wise logical or of two GpuMats: dst(I)=src1(I) | src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BitwiseXor | Calculates per-element bit-wise logical conjunction of two GpuMats: dst(I)=src1(I)^src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BlendLinear | Performs linear blending of two images.
Calc(ICudaDenseOpticalFlow, IInputArray, IInputArray, IInputOutputArray, Stream) | Calculates a dense optical flow.
Calc(ICudaSparseOpticalFlow, IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Stream) | Calculates a sparse optical flow.
CalcAbsSum | Returns the sum of absolute values for matrix elements.
CalcHist | Calculates histogram for one channel 8-bit image.
CalcNorm | Returns the norm of a matrix.
CalcNormDiff | Returns the difference of two matrices.
CalcSqrSum | Returns the squared sum of matrix elements.
CartToPolar | Converts Cartesian coordinates to polar
Compare | Compares elements of two GpuMats (c = a <cmpop> b). Supports CV_8UC4, CV_32FC1 types
CopyMakeBorder | Copies a 2D array to a larger destination array and pads borders with the given constant.
CountNonZero(IInputArray) | Counts non-zero array elements
CountNonZero(IInputArray, IOutputArray, Stream) | Counts non-zero array elements
CvtColor | Converts image from one color space to another
Demosaicing | Converts an image from Bayer pattern to RGB or grayscale.
Dft | Performs a forward or inverse discrete Fourier transform (1D or 2D) of floating point matrix. Param dft_size is the size of DFT transform. If the source matrix is not continous, then additional copy will be done, so to avoid copying ensure the source matrix is continous one. If you want to use preallocated output ensure it is continuous too, otherwise it will be reallocated. Being implemented via CUFFT real-to-complex transform result contains only non-redundant values in CUFFT's format. Result as full complex matrix for such kind of transform cannot be retrieved. For complex-to-real transform it is assumed that the source matrix is packed in CUFFT's format.
Divide | Computes element-wise quotient of the two GpuMat (c = scale * a / b).
DrawColorDisp | Colors a disparity image.
EqualizeHist | Equalizes the histogram of a grayscale image.
Exp | Computes exponent of each matrix element (b = exp(a))
FindMinMaxLoc | Finds global minimum and maximum matrix elements and returns their values with locations.
Flip | Flips the GpuMat<Byte> in one of different 3 ways (row and column indices are 0-based).
GammaCorrection | Routines for correcting image color gamma
Gemm | Performs generalized matrix multiplication: dst = alpha*op(src1)*op(src2) + beta*op(src3), where op(X) is X or XT
GetCudaDevicesSummary | Get the opencl platform summary as a string
GetCudaEnabledDeviceCount | Get the number of Cuda enabled devices
GetDevice | Get the current Cuda device id
GetRegion | Create a GpuMat from the specific region of gpuMat. The data is shared between the two GpuMat.
GetSubRect | Returns header, corresponding to a specified rectangle of the input GpuMat. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.
GpuMatReshape | gpuMatReshape the src GpuMat
GpuMatResize | Resize the GpuMat
HistEven | Calculates histogram with evenly distributed bins for single channel source.
HistRange | Calculates a histogram with bins determined by the levels array
Integral | Computes the integral image and integral for the squared image
Log | Computes natural logarithm of absolute value of each matrix element: b = log(abs(a))
LShift | Shifts a matrix to the left (c = a << scalar)
Magnitude | Computes magnitude of each (x(i), y(i)) vector
MagnitudeSqr | Computes squared magnitude of each (x(i), y(i)) vector
Max | Computes per-element maximum of two GpuMats (dst = max(src1, src2))
MeanShiftFiltering | Performs mean-shift filtering for each point of the source image. It maps each point of the source image into another point, and as the result we have new color and new position of each point.
MeanShiftProc | Performs mean-shift procedure and stores information about processed points (i.e. their colors and positions) into two images.
MeanShiftSegmentation | Performs mean-shift segmentation of the source image and eleminates small segments.
MeanStdDev | Computes mean value and standard deviation
Merge | Makes multi-channel GpuMat out of several single-channel GpuMats
Min | Computes per-element minimum of two GpuMats (dst = min(src1, src2))
MinMaxLoc | Finds minimum and maximum element values and their positions. The extremums are searched over the whole GpuMat or, if mask is not IntPtr.Zero, in the specified GpuMat region.
MulAndScaleSpectrums | Performs a per-element multiplication of two Fourier spectrums and scales the result.
MulSpectrums | Performs a per-element multiplication of two Fourier spectrums.
Multiply | Computes element-wise product of the two GpuMat: c = scale * a * b.
Norm(IInputArray, NormType, IInputArray) | Returns the norm of a matrix.
Norm(IInputArray, IInputArray, NormType) | Computes norm of the difference between two GpuMats
Normalize | Normalizes the norm or value range of an array.
Phase | Computes angle (angle(i)) of each (x(i), y(i)) vector
PolarToCart | Converts polar coordinates to Cartesian
Pow | Computes power of each matrix element: (dst(i,j) = pow( src(i,j) , power), if src.type() is integer; (dst(i,j) = pow(fabs(src(i,j)), power), otherwise. supports all, except depth == CV_64F
PyrDown | Performs downsampling step of Gaussian pyramid decomposition.
PyrUp | Performs up-sampling step of Gaussian pyramid decomposition.
Reduce | Reduces GpuMat to a vector by treating the GpuMat rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.
Remap | DST[x,y] = SRC[xmap[x,y],ymap[x,y]] with bilinear interpolation.
Resize | Resizes the image.
Rotate | Rotates an image around the origin (0,0) and then shifts it.
RShift | Shifts a matrix to the right (c = a >> scalar)
SetDevice | Set the current Gpu Device
SetGlDevice | Sets a CUDA device and initializes it for the current thread with OpenGL interoperability. This function should be explicitly called after OpenGL context creation and before any CUDA calls.
Split | Copies each plane of a multi-channel GpuMat to a dedicated GpuMat
Sqr | Computes square of each pixel in an image
SqrIntegral | Computes squared integral image
SqrSum | Returns the squared sum of matrix elements.
Sqrt | Computes square root of each pixel in an image
Subtract | Subtracts one matrix from another (c = a - b).
SwapChannels | Swap channels.
Threshold | Applies fixed-level thresholding to single-channel array. The function is typically used to get bi-level (binary) image out of grayscale image or for removing a noise, i.e. filtering out pixels with too small or too large values. There are several types of thresholding the function supports that are determined by thresholdType
Transpose | Transposes a matrix.
WarpAffine | Warps the image using affine transformation
WarpPerspective | Warps the image using perspective transformation
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaInvoke Properties

The CudaInvoke type exposes the following members.

Properties
Name | Description
HasCuda | Return true if Cuda is found on the system
Top
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.HasCuda Property

CudaInvokeHasCuda Property

Return true if Cuda is found on the system

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HasCuda { get; }
Public Shared ReadOnly Property HasCuda As Boolean
    Get
public:
static property bool HasCuda {
    bool get ();
}
static member HasCuda : bool with get

Property Value

Type: Boolean
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke Methods

The CudaInvoke type exposes the following members.

Methods
Name | Description
Abs | Computes absolute value of each pixel in an image
Absdiff | Computes element-wise absolute difference of two GpuMats (c = abs(a - b)).
AbsSum | Returns the sum of absolute values for matrix elements.
Add | Adds one matrix to another (c = a + b).
AddWeighted | Computes the weighted sum of two arrays (dst = alpha*src1 + beta*src2 + gamma)
AlphaComp | Composites two images using alpha opacity values contained in each image.
BilateralFilter | Applies bilateral filter to the image.
BitwiseAnd | Calculates per-element bit-wise logical and of two GpuMats: dst(I)=src1(I) & src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BitwiseNot | Calculates per-element bit-wise logical not dst(I)=~src(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BitwiseOr | Calculates per-element bit-wise logical or of two GpuMats: dst(I)=src1(I) | src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BitwiseXor | Calculates per-element bit-wise logical conjunction of two GpuMats: dst(I)=src1(I)^src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size
BlendLinear | Performs linear blending of two images.
Calc(ICudaDenseOpticalFlow, IInputArray, IInputArray, IInputOutputArray, Stream) | Calculates a dense optical flow.
Calc(ICudaSparseOpticalFlow, IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Stream) | Calculates a sparse optical flow.
CalcAbsSum | Returns the sum of absolute values for matrix elements.
CalcHist | Calculates histogram for one channel 8-bit image.
CalcNorm | Returns the norm of a matrix.
CalcNormDiff | Returns the difference of two matrices.
CalcSqrSum | Returns the squared sum of matrix elements.
CartToPolar | Converts Cartesian coordinates to polar
Compare | Compares elements of two GpuMats (c = a <cmpop> b). Supports CV_8UC4, CV_32FC1 types
CopyMakeBorder | Copies a 2D array to a larger destination array and pads borders with the given constant.
CountNonZero(IInputArray) | Counts non-zero array elements
CountNonZero(IInputArray, IOutputArray, Stream) | Counts non-zero array elements
CvtColor | Converts image from one color space to another
Demosaicing | Converts an image from Bayer pattern to RGB or grayscale.
Dft | Performs a forward or inverse discrete Fourier transform (1D or 2D) of floating point matrix. Param dft_size is the size of DFT transform. If the source matrix is not continous, then additional copy will be done, so to avoid copying ensure the source matrix is continous one. If you want to use preallocated output ensure it is continuous too, otherwise it will be reallocated. Being implemented via CUFFT real-to-complex transform result contains only non-redundant values in CUFFT's format. Result as full complex matrix for such kind of transform cannot be retrieved. For complex-to-real transform it is assumed that the source matrix is packed in CUFFT's format.
Divide | Computes element-wise quotient of the two GpuMat (c = scale * a / b).
DrawColorDisp | Colors a disparity image.
EqualizeHist | Equalizes the histogram of a grayscale image.
Exp | Computes exponent of each matrix element (b = exp(a))
FindMinMaxLoc | Finds global minimum and maximum matrix elements and returns their values with locations.
Flip | Flips the GpuMat<Byte> in one of different 3 ways (row and column indices are 0-based).
GammaCorrection | Routines for correcting image color gamma
Gemm | Performs generalized matrix multiplication: dst = alpha*op(src1)*op(src2) + beta*op(src3), where op(X) is X or XT
GetCudaDevicesSummary | Get the opencl platform summary as a string
GetCudaEnabledDeviceCount | Get the number of Cuda enabled devices
GetDevice | Get the current Cuda device id
GetRegion | Create a GpuMat from the specific region of gpuMat. The data is shared between the two GpuMat.
GetSubRect | Returns header, corresponding to a specified rectangle of the input GpuMat. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.
GpuMatReshape | gpuMatReshape the src GpuMat
GpuMatResize | Resize the GpuMat
HistEven | Calculates histogram with evenly distributed bins for single channel source.
HistRange | Calculates a histogram with bins determined by the levels array
Integral | Computes the integral image and integral for the squared image
Log | Computes natural logarithm of absolute value of each matrix element: b = log(abs(a))
LShift | Shifts a matrix to the left (c = a << scalar)
Magnitude | Computes magnitude of each (x(i), y(i)) vector
MagnitudeSqr | Computes squared magnitude of each (x(i), y(i)) vector
Max | Computes per-element maximum of two GpuMats (dst = max(src1, src2))
MeanShiftFiltering | Performs mean-shift filtering for each point of the source image. It maps each point of the source image into another point, and as the result we have new color and new position of each point.
MeanShiftProc | Performs mean-shift procedure and stores information about processed points (i.e. their colors and positions) into two images.
MeanShiftSegmentation | Performs mean-shift segmentation of the source image and eleminates small segments.
MeanStdDev | Computes mean value and standard deviation
Merge | Makes multi-channel GpuMat out of several single-channel GpuMats
Min | Computes per-element minimum of two GpuMats (dst = min(src1, src2))
MinMaxLoc | Finds minimum and maximum element values and their positions. The extremums are searched over the whole GpuMat or, if mask is not IntPtr.Zero, in the specified GpuMat region.
MulAndScaleSpectrums | Performs a per-element multiplication of two Fourier spectrums and scales the result.
MulSpectrums | Performs a per-element multiplication of two Fourier spectrums.
Multiply | Computes element-wise product of the two GpuMat: c = scale * a * b.
Norm(IInputArray, NormType, IInputArray) | Returns the norm of a matrix.
Norm(IInputArray, IInputArray, NormType) | Computes norm of the difference between two GpuMats
Normalize | Normalizes the norm or value range of an array.
Phase | Computes angle (angle(i)) of each (x(i), y(i)) vector
PolarToCart | Converts polar coordinates to Cartesian
Pow | Computes power of each matrix element: (dst(i,j) = pow( src(i,j) , power), if src.type() is integer; (dst(i,j) = pow(fabs(src(i,j)), power), otherwise. supports all, except depth == CV_64F
PyrDown | Performs downsampling step of Gaussian pyramid decomposition.
PyrUp | Performs up-sampling step of Gaussian pyramid decomposition.
Reduce | Reduces GpuMat to a vector by treating the GpuMat rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.
Remap | DST[x,y] = SRC[xmap[x,y],ymap[x,y]] with bilinear interpolation.
Resize | Resizes the image.
Rotate | Rotates an image around the origin (0,0) and then shifts it.
RShift | Shifts a matrix to the right (c = a >> scalar)
SetDevice | Set the current Gpu Device
SetGlDevice | Sets a CUDA device and initializes it for the current thread with OpenGL interoperability. This function should be explicitly called after OpenGL context creation and before any CUDA calls.
Split | Copies each plane of a multi-channel GpuMat to a dedicated GpuMat
Sqr | Computes square of each pixel in an image
SqrIntegral | Computes squared integral image
SqrSum | Returns the squared sum of matrix elements.
Sqrt | Computes square root of each pixel in an image
Subtract | Subtracts one matrix from another (c = a - b).
SwapChannels | Swap channels.
Threshold | Applies fixed-level thresholding to single-channel array. The function is typically used to get bi-level (binary) image out of grayscale image or for removing a noise, i.e. filtering out pixels with too small or too large values. There are several types of thresholding the function supports that are determined by thresholdType
Transpose | Transposes a matrix.
WarpAffine | Warps the image using affine transformation
WarpPerspective | Warps the image using perspective transformation
Top
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Abs Method

CudaInvokeAbs Method

Computes absolute value of each pixel in an image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Abs(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Abs (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Abs(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Abs :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat, support depth of Int16 and float.
dst
Type: Emgu.CVIOutputArray
The resulting GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Absdiff Method

CudaInvokeAbsdiff Method

Computes element-wise absolute difference of two GpuMats (c = abs(a - b)).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Absdiff(
    IInputArray a,
    IInputArray b,
    IOutputArray c,
    Stream stream = null
)
Public Shared Sub Absdiff (
    a As IInputArray,
    b As IInputArray,
    c As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Absdiff(
    IInputArray^ a,
    IInputArray^ b,
    IOutputArray^ c,
    Stream^ stream = nullptr
)
static member Absdiff :
        a : IInputArray *
        b : IInputArray *
        c : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The first GpuMat
b
Type: Emgu.CVIInputArray
The second GpuMat
c
Type: Emgu.CVIOutputArray
The result of the element-wise absolute difference.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.AbsSum Method

CudaInvokeAbsSum Method

Returns the sum of absolute values for matrix elements.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar AbsSum(
    IInputArray src,
    IInputArray mask = null
)
Public Shared Function AbsSum (
    src As IInputArray,
    Optional mask As IInputArray = Nothing
) As MCvScalar
public:
static MCvScalar^ AbsSum(
    IInputArray^ src,
    IInputArray^ mask = nullptr
)
static member AbsSum :
        src : IInputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> MCvScalar

Parameters

src
Type: Emgu.CVIInputArray
Source image of any depth except for CV_64F.
mask (Optional)
Type: Emgu.CVIInputArray
optional operation mask; it must have the same size as src and CV_8UC1 type.

Return Value

Type: MCvScalar
The sum of absolute values for matrix elements.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Add Method

CudaInvokeAdd Method

Adds one matrix to another (c = a + b).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Add(
    IInputArray a,
    IInputArray b,
    IOutputArray c,
    IInputArray mask = null,
    DepthType depthType = -1,
    Stream stream = null
)
Public Shared Sub Add (
    a As IInputArray,
    b As IInputArray,
    c As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional depthType As DepthType = -1,
    Optional stream As Stream = Nothing
)
public:
static void Add(
    IInputArray^ a,
    IInputArray^ b,
    IOutputArray^ c,
    IInputArray^ mask = nullptr,
    DepthType^ depthType = -1,
    Stream^ stream = nullptr
)
static member Add :
        a : IInputArray *
        b : IInputArray *
        c : IOutputArray *
        ?mask : IInputArray *
        ?depthType : DepthType *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _depthType = defaultArg depthType -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The first matrix to be added.
b
Type: Emgu.CVIInputArray
The second matrix to be added.
c
Type: Emgu.CVIOutputArray
The sum of the two matrix
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask that is used to select a subarray. Use null if not needed
depthType (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.AddWeighted Method

CudaInvokeAddWeighted Method

Computes the weighted sum of two arrays (dst = alpha*src1 + beta*src2 + gamma)

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AddWeighted(
    IInputArray src1,
    double alpha,
    IInputArray src2,
    double beta,
    double gamma,
    IOutputArray dst,
    DepthType depthType = -1,
    Stream stream = null
)
Public Shared Sub AddWeighted (
    src1 As IInputArray,
    alpha As Double,
    src2 As IInputArray,
    beta As Double,
    gamma As Double,
    dst As IOutputArray,
    Optional depthType As DepthType = -1,
    Optional stream As Stream = Nothing
)
public:
static void AddWeighted(
    IInputArray^ src1,
    double alpha,
    IInputArray^ src2,
    double beta,
    double gamma,
    IOutputArray^ dst,
    DepthType^ depthType = -1,
    Stream^ stream = nullptr
)
static member AddWeighted :
        src1 : IInputArray *
        alpha : float *
        src2 : IInputArray *
        beta : float *
        gamma : float *
        dst : IOutputArray *
        ?depthType : DepthType *
        ?stream : Stream
(* Defaults:
        let _depthType = defaultArg depthType -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source GpuMat
alpha
Type: SystemDouble
The weight for src1
src2
Type: Emgu.CVIInputArray
The second source GpuMat
beta
Type: SystemDouble
The weight for src2
gamma
Type: SystemDouble
The constant to be added
dst
Type: Emgu.CVIOutputArray
The result
depthType (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.AlphaComp Method

CudaInvokeAlphaComp Method

Composites two images using alpha opacity values contained in each image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AlphaComp(
    IInputArray img1,
    IInputArray img2,
    IOutputArray dst,
    AlphaCompTypes alphaOp,
    Stream stream = null
)
Public Shared Sub AlphaComp (
    img1 As IInputArray,
    img2 As IInputArray,
    dst As IOutputArray,
    alphaOp As AlphaCompTypes,
    Optional stream As Stream = Nothing
)
public:
static void AlphaComp(
    IInputArray^ img1,
    IInputArray^ img2,
    IOutputArray^ dst,
    AlphaCompTypes^ alphaOp,
    Stream^ stream = nullptr
)
static member AlphaComp :
        img1 : IInputArray *
        img2 : IInputArray *
        dst : IOutputArray *
        alphaOp : AlphaCompTypes *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

img1
Type: Emgu.CVIInputArray
First image. Supports CV_8UC4 , CV_16UC4 , CV_32SC4 and CV_32FC4 types.
img2
Type: Emgu.CVIInputArray
Second image. Must have the same size and the same type as img1 .
dst
Type: Emgu.CVIOutputArray
Destination image
alphaOp
Type: Emgu.CV.CudaAlphaCompTypes
Flag specifying the alpha-blending operation
stream (Optional)
Type: Emgu.CV.CudaStream
Stream for the asynchronous version
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.BilateralFilter Method

CudaInvokeBilateralFilter Method

Applies bilateral filter to the image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BilateralFilter(
    IInputArray src,
    IOutputArray dst,
    int kernelSize,
    float sigmaColor,
    float sigmaSpatial,
    BorderType borderType = 4,
    Stream stream = null
)
Public Shared Sub BilateralFilter (
    src As IInputArray,
    dst As IOutputArray,
    kernelSize As Integer,
    sigmaColor As Single,
    sigmaSpatial As Single,
    Optional borderType As BorderType = 4,
    Optional stream As Stream = Nothing
)
public:
static void BilateralFilter(
    IInputArray^ src,
    IOutputArray^ dst,
    int kernelSize,
    float sigmaColor,
    float sigmaSpatial,
    BorderType^ borderType = 4,
    Stream^ stream = nullptr
)
static member BilateralFilter :
        src : IInputArray *
        dst : IOutputArray *
        kernelSize : int *
        sigmaColor : float32 *
        sigmaSpatial : float32 *
        ?borderType : BorderType *
        ?stream : Stream
(* Defaults:
        let _borderType = defaultArg borderType 4
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
dst
Type: Emgu.CVIOutputArray
The destination image; should have the same size and the same type as src
kernelSize
Type: SystemInt32
The diameter of each pixel neighborhood, that is used during filtering.
sigmaColor
Type: SystemSingle
Filter sigma in the color space. Larger value of the parameter means that farther colors within the pixel neighborhood (see sigmaSpace) will be mixed together, resulting in larger areas of semi-equal color
sigmaSpatial
Type: SystemSingle
Filter sigma in the coordinate space. Larger value of the parameter means that farther pixels will influence each other (as long as their colors are close enough; see sigmaColor). Then d>0, it specifies the neighborhood size regardless of sigmaSpace, otherwise d is proportional to sigmaSpace.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method, use DEFAULT for default
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.BitwiseAnd Method

CudaInvokeBitwiseAnd Method

Calculates per-element bit-wise logical and of two GpuMats: dst(I)=src1(I) & src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseAnd(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub BitwiseAnd (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void BitwiseAnd(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member BitwiseAnd :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source GpuMat
src2
Type: Emgu.CVIInputArray
The second source GpuMat
dst
Type: Emgu.CVIOutputArray
The destination GpuMat
mask (Optional)
Type: Emgu.CVIInputArray
Mask, 8-bit single channel GpuMat; specifies elements of destination GpuMat to be changed. Use IntPtr.Zero if not needed.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.BitwiseNot Method

CudaInvokeBitwiseNot Method

Calculates per-element bit-wise logical not dst(I)=~src(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseNot(
    IInputArray src,
    IOutputArray dst,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub BitwiseNot (
    src As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void BitwiseNot(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member BitwiseNot :
        src : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat
dst
Type: Emgu.CVIOutputArray
The destination GpuMat
mask (Optional)
Type: Emgu.CVIInputArray
Mask, 8-bit single channel GpuMat; specifies elements of destination GpuMat to be changed. Use IntPtr.Zero if not needed.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.BitwiseOr Method

CudaInvokeBitwiseOr Method

Calculates per-element bit-wise logical or of two GpuMats: dst(I)=src1(I) | src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseOr(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub BitwiseOr (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void BitwiseOr(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member BitwiseOr :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source GpuMat
src2
Type: Emgu.CVIInputArray
The second source GpuMat
dst
Type: Emgu.CVIOutputArray
The destination GpuMat
mask (Optional)
Type: Emgu.CVIInputArray
Mask, 8-bit single channel GpuMat; specifies elements of destination GpuMat to be changed. Use IntPtr.Zero if not needed.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.BitwiseXor Method

CudaInvokeBitwiseXor Method

Calculates per-element bit-wise logical conjunction of two GpuMats: dst(I)=src1(I)^src2(I) if mask(I)!=0 In the case of floating-point GpuMats their bit representations are used for the operation. All the GpuMats must have the same type, except the mask, and the same size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BitwiseXor(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub BitwiseXor (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void BitwiseXor(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member BitwiseXor :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source GpuMat
src2
Type: Emgu.CVIInputArray
The second source GpuMat
dst
Type: Emgu.CVIOutputArray
The destination GpuMat
mask (Optional)
Type: Emgu.CVIInputArray
Mask, 8-bit single channel GpuMat; specifies elements of destination GpuMat to be changed. Use IntPtr.Zero if not needed.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.BlendLinear Method

CudaInvokeBlendLinear Method

Performs linear blending of two images.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BlendLinear(
    IInputArray img1,
    IInputArray img2,
    IInputArray weights1,
    IInputArray weights2,
    IOutputArray result,
    Stream stream = null
)
Public Shared Sub BlendLinear (
    img1 As IInputArray,
    img2 As IInputArray,
    weights1 As IInputArray,
    weights2 As IInputArray,
    result As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void BlendLinear(
    IInputArray^ img1,
    IInputArray^ img2,
    IInputArray^ weights1,
    IInputArray^ weights2,
    IOutputArray^ result,
    Stream^ stream = nullptr
)
static member BlendLinear :
        img1 : IInputArray *
        img2 : IInputArray *
        weights1 : IInputArray *
        weights2 : IInputArray *
        result : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

img1
Type: Emgu.CVIInputArray
First image. Supports only CV_8U and CV_32F depth.
img2
Type: Emgu.CVIInputArray
Second image. Must have the same size and the same type as img1 .
weights1
Type: Emgu.CVIInputArray
Weights for first image. Must have tha same size as img1. Supports only CV_32F type.
weights2
Type: Emgu.CVIInputArray
Weights for second image. Must have tha same size as img2. Supports only CV_32F type.
result
Type: Emgu.CVIOutputArray
Destination image.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Calc Method

CudaInvokeCalc Method

Overload List
Name | Description
Calc(ICudaDenseOpticalFlow, IInputArray, IInputArray, IInputOutputArray, Stream) | Calculates a dense optical flow.
Calc(ICudaSparseOpticalFlow, IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Stream) | Calculates a sparse optical flow.
Top
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Calc Method (ICudaDenseOpticalFlow, IInputArray, IInputArray, IInputOutputArray, Stream)

CudaInvokeCalc Method (ICudaDenseOpticalFlow, IInputArray, IInputArray, IInputOutputArray, Stream)

http://www.emgu.com
Calculates a dense optical flow.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Calc(
    this ICudaDenseOpticalFlow denseFlow,
    IInputArray i0,
    IInputArray i1,
    IInputOutputArray flow,
    Stream stream = null
)
<ExtensionAttribute>
Public Shared Sub Calc (
    denseFlow As ICudaDenseOpticalFlow,
    i0 As IInputArray,
    i1 As IInputArray,
    flow As IInputOutputArray,
    Optional stream As Stream = Nothing
)
public:
[ExtensionAttribute]
static void Calc(
    ICudaDenseOpticalFlow^ denseFlow,
    IInputArray^ i0,
    IInputArray^ i1,
    IInputOutputArray^ flow,
    Stream^ stream = nullptr
)
[<ExtensionAttribute>]
static member Calc :
        denseFlow : ICudaDenseOpticalFlow *
        i0 : IInputArray *
        i1 : IInputArray *
        flow : IInputOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

denseFlow
Type: Emgu.CV.CudaICudaDenseOpticalFlow
The dense optical flow object
i0
Type: Emgu.CVIInputArray
first input image.
i1
Type: Emgu.CVIInputArray
second input image of the same size and the same type as i0.
flow
Type: Emgu.CVIInputOutputArray
computed flow image that has the same size as I0 and type CV_32FC2.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICudaDenseOpticalFlow. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CudaInvoke Class
Calc Overload
Emgu.CV.Cuda Namespace


CudaInvoke.Calc Method (ICudaSparseOpticalFlow, IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Stream)

CudaInvokeCalc Method (ICudaSparseOpticalFlow, IInputArray, IInputArray, IInputArray, IInputOutputArray, IOutputArray, IOutputArray, Stream)

http://www.emgu.com
Calculates a sparse optical flow.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Calc(
    this ICudaSparseOpticalFlow sparseFlow,
    IInputArray prevImg,
    IInputArray nextImg,
    IInputArray prevPts,
    IInputOutputArray nextPts,
    IOutputArray status,
    IOutputArray err = null,
    Stream stream = null
)
<ExtensionAttribute>
Public Shared Sub Calc (
    sparseFlow As ICudaSparseOpticalFlow,
    prevImg As IInputArray,
    nextImg As IInputArray,
    prevPts As IInputArray,
    nextPts As IInputOutputArray,
    status As IOutputArray,
    Optional err As IOutputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
[ExtensionAttribute]
static void Calc(
    ICudaSparseOpticalFlow^ sparseFlow,
    IInputArray^ prevImg,
    IInputArray^ nextImg,
    IInputArray^ prevPts,
    IInputOutputArray^ nextPts,
    IOutputArray^ status,
    IOutputArray^ err = nullptr,
    Stream^ stream = nullptr
)
[<ExtensionAttribute>]
static member Calc :
        sparseFlow : ICudaSparseOpticalFlow *
        prevImg : IInputArray *
        nextImg : IInputArray *
        prevPts : IInputArray *
        nextPts : IInputOutputArray *
        status : IOutputArray *
        ?err : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _err = defaultArg err null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

sparseFlow
Type: Emgu.CV.CudaICudaSparseOpticalFlow
The sparse optical flow
prevImg
Type: Emgu.CVIInputArray
First input image.
nextImg
Type: Emgu.CVIInputArray
Second input image of the same size and the same type as prevImg.
prevPts
Type: Emgu.CVIInputArray
Vector of 2D points for which the flow needs to be found.
nextPts
Type: Emgu.CVIInputOutputArray
Output vector of 2D points containing the calculated new positions of input features in the second image.
status
Type: Emgu.CVIOutputArray
Output status vector. Each element of the vector is set to 1 if the flow for the corresponding features has been found. Otherwise, it is set to 0.
err (Optional)
Type: Emgu.CVIOutputArray
Optional output vector that contains error response for each point (inverse confidence).
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICudaSparseOpticalFlow. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CudaInvoke Class
Calc Overload
Emgu.CV.Cuda Namespace


CudaInvoke.CalcAbsSum Method

CudaInvokeCalcAbsSum Method

Returns the sum of absolute values for matrix elements.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcAbsSum(
    IInputArray src,
    IOutputArray dst,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub CalcAbsSum (
    src As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void CalcAbsSum(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member CalcAbsSum :
        src : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image of any depth except for CV_64F.
dst
Type: Emgu.CVIOutputArray
The GpuMat where the result will be stored.
mask (Optional)
Type: Emgu.CVIInputArray
optional operation mask; it must have the same size as src1 and CV_8UC1 type.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CalcHist Method

CudaInvokeCalcHist Method

Calculates histogram for one channel 8-bit image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcHist(
    IInputArray src,
    IOutputArray hist,
    Stream stream = null
)
Public Shared Sub CalcHist (
    src As IInputArray,
    hist As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void CalcHist(
    IInputArray^ src,
    IOutputArray^ hist,
    Stream^ stream = nullptr
)
static member CalcHist :
        src : IInputArray *
        hist : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image with CV_8UC1 type.
hist
Type: Emgu.CVIOutputArray
Destination histogram with one row, 256 columns, and the CV_32SC1 type.
stream (Optional)
Type: Emgu.CV.CudaStream
tream for the asynchronous version.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CalcNorm Method

CudaInvokeCalcNorm Method

Returns the norm of a matrix.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcNorm(
    IInputArray src,
    IOutputArray dst,
    NormType normType = 4,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub CalcNorm (
    src As IInputArray,
    dst As IOutputArray,
    Optional normType As NormType = 4,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void CalcNorm(
    IInputArray^ src,
    IOutputArray^ dst,
    NormType^ normType = 4,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member CalcNorm :
        src : IInputArray *
        dst : IOutputArray *
        ?normType : NormType *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _normType = defaultArg normType 4
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source matrix. Any matrices except 64F are supported.
dst
Type: Emgu.CVIOutputArray
The GpuMat to store the result
normType (Optional)
Type: Emgu.CV.CvEnumNormType
Norm type. NORM_L1 , NORM_L2 , and NORM_INF are supported for now.
mask (Optional)
Type: Emgu.CVIInputArray
optional operation mask; it must have the same size as src1 and CV_8UC1 type.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CalcNormDiff Method

CudaInvokeCalcNormDiff Method

Returns the difference of two matrices.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcNormDiff(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    NormType normType = 4,
    Stream stream = null
)
Public Shared Sub CalcNormDiff (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional normType As NormType = 4,
    Optional stream As Stream = Nothing
)
public:
static void CalcNormDiff(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    NormType^ normType = 4,
    Stream^ stream = nullptr
)
static member CalcNormDiff :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?normType : NormType *
        ?stream : Stream
(* Defaults:
        let _normType = defaultArg normType 4
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
Source matrix. Any matrices except 64F are supported.
src2
Type: Emgu.CVIInputArray
Second source matrix (if any) with the same size and type as src1.
dst
Type: Emgu.CVIOutputArray
The GpuMat where the result will be stored in
normType (Optional)
Type: Emgu.CV.CvEnumNormType
Norm type. NORM_L1 , NORM_L2 , and NORM_INF are supported for now.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CalcSqrSum Method

CudaInvokeCalcSqrSum Method

Returns the squared sum of matrix elements.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CalcSqrSum(
    IInputArray src,
    IOutputArray dst,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub CalcSqrSum (
    src As IInputArray,
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void CalcSqrSum(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member CalcSqrSum :
        src : IInputArray *
        dst : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image of any depth except for CV_64F.
dst
Type: Emgu.CVIOutputArray
The GpuMat where the result will be stored
mask (Optional)
Type: Emgu.CVIInputArray
optional operation mask; it must have the same size as src1 and CV_8UC1 type.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CartToPolar Method

CudaInvokeCartToPolar Method

Converts Cartesian coordinates to polar

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CartToPolar(
    IInputArray x,
    IInputArray y,
    IOutputArray magnitude,
    IOutputArray angle,
    bool angleInDegrees = false,
    Stream stream = null
)
Public Shared Sub CartToPolar (
    x As IInputArray,
    y As IInputArray,
    magnitude As IOutputArray,
    angle As IOutputArray,
    Optional angleInDegrees As Boolean = false,
    Optional stream As Stream = Nothing
)
public:
static void CartToPolar(
    IInputArray^ x,
    IInputArray^ y,
    IOutputArray^ magnitude,
    IOutputArray^ angle,
    bool angleInDegrees = false,
    Stream^ stream = nullptr
)
static member CartToPolar :
        x : IInputArray *
        y : IInputArray *
        magnitude : IOutputArray *
        angle : IOutputArray *
        ?angleInDegrees : bool *
        ?stream : Stream
(* Defaults:
        let _angleInDegrees = defaultArg angleInDegrees false
        let _stream = defaultArg stream null
*)
-> unit

Parameters

x
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
y
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
magnitude
Type: Emgu.CVIOutputArray
The destination GpuMat. Supports only floating-point type
angle
Type: Emgu.CVIOutputArray
The destination GpuMat. Supports only floating-point type
angleInDegrees (Optional)
Type: SystemBoolean
If true, the output angle is in degrees, otherwise in radian
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Compare Method

CudaInvokeCompare Method

Compares elements of two GpuMats (c = a <cmpop> b). Supports CV_8UC4, CV_32FC1 types

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Compare(
    IInputArray a,
    IInputArray b,
    IOutputArray c,
    CmpType cmpop,
    Stream stream = null
)
Public Shared Sub Compare (
    a As IInputArray,
    b As IInputArray,
    c As IOutputArray,
    cmpop As CmpType,
    Optional stream As Stream = Nothing
)
public:
static void Compare(
    IInputArray^ a,
    IInputArray^ b,
    IOutputArray^ c,
    CmpType^ cmpop,
    Stream^ stream = nullptr
)
static member Compare :
        a : IInputArray *
        b : IInputArray *
        c : IOutputArray *
        cmpop : CmpType *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The first GpuMat
b
Type: Emgu.CVIInputArray
The second GpuMat
c
Type: Emgu.CVIOutputArray
The result of the comparison.
cmpop
Type: Emgu.CV.CvEnumCmpType
The type of comparison
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CopyMakeBorder Method

CudaInvokeCopyMakeBorder Method

Copies a 2D array to a larger destination array and pads borders with the given constant.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CopyMakeBorder(
    IInputArray src,
    IOutputArray dst,
    int top,
    int bottom,
    int left,
    int right,
    BorderType borderType,
    MCvScalar value = null,
    Stream stream = null
)
Public Shared Sub CopyMakeBorder (
    src As IInputArray,
    dst As IOutputArray,
    top As Integer,
    bottom As Integer,
    left As Integer,
    right As Integer,
    borderType As BorderType,
    Optional value As MCvScalar = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void CopyMakeBorder(
    IInputArray^ src,
    IOutputArray^ dst,
    int top,
    int bottom,
    int left,
    int right,
    BorderType^ borderType,
    MCvScalar^ value = nullptr,
    Stream^ stream = nullptr
)
static member CopyMakeBorder :
        src : IInputArray *
        dst : IOutputArray *
        top : int *
        bottom : int *
        left : int *
        right : int *
        borderType : BorderType *
        ?value : MCvScalar *
        ?stream : Stream
(* Defaults:
        let _value = defaultArg value null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image.
dst
Type: Emgu.CVIOutputArray
Destination image with the same type as src. The size is Size(src.cols+left+right, src.rows+top+bottom).
top
Type: SystemInt32
Number of pixels in each direction from the source image rectangle to extrapolate.
bottom
Type: SystemInt32
Number of pixels in each direction from the source image rectangle to extrapolate.
left
Type: SystemInt32
Number of pixels in each direction from the source image rectangle to extrapolate.
right
Type: SystemInt32
Number of pixels in each direction from the source image rectangle to extrapolate.
borderType
Type: Emgu.CV.CvEnumBorderType
Border Type
value (Optional)
Type: Emgu.CV.StructureMCvScalar
Border value.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CountNonZero Method

CudaInvokeCountNonZero Method

Overload List
Name | Description
CountNonZero(IInputArray) | Counts non-zero array elements
CountNonZero(IInputArray, IOutputArray, Stream) | Counts non-zero array elements
Top
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.CountNonZero Method (IInputArray)

CudaInvokeCountNonZero Method (IInputArray)

http://www.emgu.com
Counts non-zero array elements

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int CountNonZero(
    IInputArray src
)
Public Shared Function CountNonZero (
    src As IInputArray
) As Integer
public:
static int CountNonZero(
    IInputArray^ src
)
static member CountNonZero :
        src : IInputArray -> int

Parameters

src
Type: Emgu.CVIInputArray
Single-channel source image.

Return Value

Type: Int32
The number of non-zero GpuMat elements
See Also

Reference

CudaInvoke Class
CountNonZero Overload
Emgu.CV.Cuda Namespace


CudaInvoke.CountNonZero Method (IInputArray, IOutputArray, Stream)

CudaInvokeCountNonZero Method (IInputArray, IOutputArray, Stream)

http://www.emgu.com
Counts non-zero array elements

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CountNonZero(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub CountNonZero (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void CountNonZero(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member CountNonZero :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Single-channel source image.
dst
Type: Emgu.CVIOutputArray
A Gpu mat to hold the result
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
CountNonZero Overload
Emgu.CV.Cuda Namespace


CudaInvoke.CvtColor Method

CudaInvokeCvtColor Method

Converts image from one color space to another

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CvtColor(
    IInputArray src,
    IOutputArray dst,
    ColorConversion code,
    int dcn = 0,
    Stream stream = null
)
Public Shared Sub CvtColor (
    src As IInputArray,
    dst As IOutputArray,
    code As ColorConversion,
    Optional dcn As Integer = 0,
    Optional stream As Stream = Nothing
)
public:
static void CvtColor(
    IInputArray^ src,
    IOutputArray^ dst,
    ColorConversion^ code,
    int dcn = 0,
    Stream^ stream = nullptr
)
static member CvtColor :
        src : IInputArray *
        dst : IOutputArray *
        code : ColorConversion *
        ?dcn : int *
        ?stream : Stream
(* Defaults:
        let _dcn = defaultArg dcn 0
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat
dst
Type: Emgu.CVIOutputArray
The destination GpuMat
code
Type: Emgu.CV.CvEnumColorConversion
The color conversion code
dcn (Optional)
Type: SystemInt32
Number of channels in the destination image. If the parameter is 0, the number of the channels is derived automatically from src and the code .
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Demosaicing Method

CudaInvokeDemosaicing Method

Converts an image from Bayer pattern to RGB or grayscale.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Demosaicing(
    IInputArray src,
    IOutputArray dst,
    DemosaicTypes code,
    int dcn = -1,
    Stream stream = null
)
Public Shared Sub Demosaicing (
    src As IInputArray,
    dst As IOutputArray,
    code As DemosaicTypes,
    Optional dcn As Integer = -1,
    Optional stream As Stream = Nothing
)
public:
static void Demosaicing(
    IInputArray^ src,
    IOutputArray^ dst,
    DemosaicTypes^ code,
    int dcn = -1,
    Stream^ stream = nullptr
)
static member Demosaicing :
        src : IInputArray *
        dst : IOutputArray *
        code : DemosaicTypes *
        ?dcn : int *
        ?stream : Stream
(* Defaults:
        let _dcn = defaultArg dcn -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image (8-bit or 16-bit single channel).
dst
Type: Emgu.CVIOutputArray
Destination image.
code
Type: Emgu.CV.CudaDemosaicTypes
Color space conversion code (see the description below).
dcn (Optional)
Type: SystemInt32
Number of channels in the destination image. If the parameter is 0, the number of the channels is derived automatically from src and the code .
stream (Optional)
Type: Emgu.CV.CudaStream
Stream for the asynchronous version.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Dft Method

CudaInvokeDft Method

Performs a forward or inverse discrete Fourier transform (1D or 2D) of floating point matrix. Param dft_size is the size of DFT transform. If the source matrix is not continous, then additional copy will be done, so to avoid copying ensure the source matrix is continous one. If you want to use preallocated output ensure it is continuous too, otherwise it will be reallocated. Being implemented via CUFFT real-to-complex transform result contains only non-redundant values in CUFFT's format. Result as full complex matrix for such kind of transform cannot be retrieved. For complex-to-real transform it is assumed that the source matrix is packed in CUFFT's format.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Dft(
    IInputArray src,
    IOutputArray dst,
    Size dftSize,
    DxtType flags = 0,
    Stream stream = null
)
Public Shared Sub Dft (
    src As IInputArray,
    dst As IOutputArray,
    dftSize As Size,
    Optional flags As DxtType = 0,
    Optional stream As Stream = Nothing
)
public:
static void Dft(
    IInputArray^ src,
    IOutputArray^ dst,
    Size^ dftSize,
    DxtType^ flags = 0,
    Stream^ stream = nullptr
)
static member Dft :
        src : IInputArray *
        dst : IOutputArray *
        dftSize : Size *
        ?flags : DxtType *
        ?stream : Stream
(* Defaults:
        let _flags = defaultArg flags 0
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat
dst
Type: Emgu.CVIOutputArray
The resulting GpuMat of the DST, must be pre-allocated and continious. If single channel, the result is real. If double channel, the result is complex
dftSize
Type: System.DrawingSize
Size of a discrete Fourier transform.
flags (Optional)
Type: Emgu.CV.CvEnumDxtType
DFT flags
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Divide Method

CudaInvokeDivide Method

Computes element-wise quotient of the two GpuMat (c = scale * a / b).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Divide(
    IInputArray a,
    IInputArray b,
    IOutputArray c,
    double scale = 1,
    DepthType depthType = -1,
    Stream stream = null
)
Public Shared Sub Divide (
    a As IInputArray,
    b As IInputArray,
    c As IOutputArray,
    Optional scale As Double = 1,
    Optional depthType As DepthType = -1,
    Optional stream As Stream = Nothing
)
public:
static void Divide(
    IInputArray^ a,
    IInputArray^ b,
    IOutputArray^ c,
    double scale = 1,
    DepthType^ depthType = -1,
    Stream^ stream = nullptr
)
static member Divide :
        a : IInputArray *
        b : IInputArray *
        c : IOutputArray *
        ?scale : float *
        ?depthType : DepthType *
        ?stream : Stream
(* Defaults:
        let _scale = defaultArg scale 1
        let _depthType = defaultArg depthType -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The first GpuMat
b
Type: Emgu.CVIInputArray
The second GpuMat
c
Type: Emgu.CVIOutputArray
The element-wise quotient of the two GpuMat
scale (Optional)
Type: SystemDouble
The scale
depthType (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.DrawColorDisp Method

CudaInvokeDrawColorDisp Method

Colors a disparity image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawColorDisp(
    IInputArray srcDisp,
    IOutputArray dstDisp,
    int ndisp,
    Stream stream = null
)
Public Shared Sub DrawColorDisp (
    srcDisp As IInputArray,
    dstDisp As IOutputArray,
    ndisp As Integer,
    Optional stream As Stream = Nothing
)
public:
static void DrawColorDisp(
    IInputArray^ srcDisp,
    IOutputArray^ dstDisp,
    int ndisp,
    Stream^ stream = nullptr
)
static member DrawColorDisp :
        srcDisp : IInputArray *
        dstDisp : IOutputArray *
        ndisp : int *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

srcDisp
Type: Emgu.CVIInputArray
Input single-channel 8-bit unsigned, 16-bit signed, 32-bit signed or 32-bit floating-point disparity image. If 16-bit signed format is used, the values are assumed to have no fractional bits.
dstDisp
Type: Emgu.CVIOutputArray
Output disparity image. It has the same size as src_disp. The type is CV_8UC4 in BGRA format (alpha = 255).
ndisp
Type: SystemInt32
Number of disparities.
stream (Optional)
Type: Emgu.CV.CudaStream
Stream for the asynchronous version.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.EqualizeHist Method

CudaInvokeEqualizeHist Method

Equalizes the histogram of a grayscale image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void EqualizeHist(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub EqualizeHist (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void EqualizeHist(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member EqualizeHist :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image with CV_8UC1 type.
dst
Type: Emgu.CVIOutputArray
Destination image.
stream (Optional)
Type: Emgu.CV.CudaStream
Stream for the asynchronous version.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Exp Method

CudaInvokeExp Method

Computes exponent of each matrix element (b = exp(a))

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Exp(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Exp (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Exp(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Exp :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat. Supports Byte, UInt16, Int16 and float type.
dst
Type: Emgu.CVIOutputArray
The resulting GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.FindMinMaxLoc Method

CudaInvokeFindMinMaxLoc Method

Finds global minimum and maximum matrix elements and returns their values with locations.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FindMinMaxLoc(
    IInputArray src,
    IOutputArray minMaxVals,
    IOutputArray loc,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub FindMinMaxLoc (
    src As IInputArray,
    minMaxVals As IOutputArray,
    loc As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void FindMinMaxLoc(
    IInputArray^ src,
    IOutputArray^ minMaxVals,
    IOutputArray^ loc,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member FindMinMaxLoc :
        src : IInputArray *
        minMaxVals : IOutputArray *
        loc : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Single-channel source image.
minMaxVals
Type: Emgu.CVIOutputArray
The output min and max values
loc
Type: Emgu.CVIOutputArray
The ouput min and max locations
mask (Optional)
Type: Emgu.CVIInputArray
Optional mask to select a sub-matrix.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Flip Method

CudaInvokeFlip Method

Flips the GpuMat<Byte> in one of different 3 ways (row and column indices are 0-based).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Flip(
    IInputArray src,
    IOutputArray dst,
    FlipType flipType,
    Stream stream = null
)
Public Shared Sub Flip (
    src As IInputArray,
    dst As IOutputArray,
    flipType As FlipType,
    Optional stream As Stream = Nothing
)
public:
static void Flip(
    IInputArray^ src,
    IOutputArray^ dst,
    FlipType^ flipType,
    Stream^ stream = nullptr
)
static member Flip :
        src : IInputArray *
        dst : IOutputArray *
        flipType : FlipType *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat. supports 1, 3 and 4 channels GpuMat with Byte, UInt16, int or float depth
dst
Type: Emgu.CVIOutputArray
Destination GpuMat. The same source and type as src
flipType
Type: Emgu.CV.CvEnumFlipType
Specifies how to flip the GpuMat.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GammaCorrection Method

CudaInvokeGammaCorrection Method

Routines for correcting image color gamma

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GammaCorrection(
    IInputArray src,
    IOutputArray dst,
    bool forward = true,
    Stream stream = null
)
Public Shared Sub GammaCorrection (
    src As IInputArray,
    dst As IOutputArray,
    Optional forward As Boolean = true,
    Optional stream As Stream = Nothing
)
public:
static void GammaCorrection(
    IInputArray^ src,
    IOutputArray^ dst,
    bool forward = true,
    Stream^ stream = nullptr
)
static member GammaCorrection :
        src : IInputArray *
        dst : IOutputArray *
        ?forward : bool *
        ?stream : Stream
(* Defaults:
        let _forward = defaultArg forward true
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image (3- or 4-channel 8 bit).
dst
Type: Emgu.CVIOutputArray
Destination image.
forward (Optional)
Type: SystemBoolean
True for forward gamma correction or false for inverse gamma correction.
stream (Optional)
Type: Emgu.CV.CudaStream
Stream for the asynchronous version.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Gemm Method

CudaInvokeGemm Method

Performs generalized matrix multiplication: dst = alpha*op(src1)*op(src2) + beta*op(src3), where op(X) is X or XT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Gemm(
    IInputArray src1,
    IInputArray src2,
    double alpha,
    IInputArray src3,
    double beta,
    IOutputArray dst,
    GemmType tABC = 0,
    Stream stream = null
)
Public Shared Sub Gemm (
    src1 As IInputArray,
    src2 As IInputArray,
    alpha As Double,
    src3 As IInputArray,
    beta As Double,
    dst As IOutputArray,
    Optional tABC As GemmType = 0,
    Optional stream As Stream = Nothing
)
public:
static void Gemm(
    IInputArray^ src1,
    IInputArray^ src2,
    double alpha,
    IInputArray^ src3,
    double beta,
    IOutputArray^ dst,
    GemmType^ tABC = 0,
    Stream^ stream = nullptr
)
static member Gemm :
        src1 : IInputArray *
        src2 : IInputArray *
        alpha : float *
        src3 : IInputArray *
        beta : float *
        dst : IOutputArray *
        ?tABC : GemmType *
        ?stream : Stream
(* Defaults:
        let _tABC = defaultArg tABC 0
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first source array.
src2
Type: Emgu.CVIInputArray
The second source array.
alpha
Type: SystemDouble
The scalar
src3
Type: Emgu.CVIInputArray
The third source array (shift). Can be IntPtr.Zero, if there is no shift.
beta
Type: SystemDouble
The scalar
dst
Type: Emgu.CVIOutputArray
The destination array.
tABC (Optional)
Type: Emgu.CV.CvEnumGemmType
The gemm operation type
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GetCudaDevicesSummary Method

CudaInvokeGetCudaDevicesSummary Method

Get the opencl platform summary as a string

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string GetCudaDevicesSummary()
Public Shared Function GetCudaDevicesSummary As String
public:
static String^ GetCudaDevicesSummary()
static member GetCudaDevicesSummary : unit -> string

Return Value

Type: String
An opencl platfor summary
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GetCudaEnabledDeviceCount Method

CudaInvokeGetCudaEnabledDeviceCount Method

Get the number of Cuda enabled devices

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int GetCudaEnabledDeviceCount()
Public Shared Function GetCudaEnabledDeviceCount As Integer
public:
static int GetCudaEnabledDeviceCount()
static member GetCudaEnabledDeviceCount : unit -> int

Return Value

Type: Int32
The number of Cuda enabled devices
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GetDevice Method

CudaInvokeGetDevice Method

Get the current Cuda device id

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int GetDevice()
Public Shared Function GetDevice As Integer
public:
static int GetDevice()
static member GetDevice : unit -> int

Return Value

Type: Int32
The current Cuda device id
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GetRegion Method

CudaInvokeGetRegion Method

Create a GpuMat from the specific region of gpuMat. The data is shared between the two GpuMat.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetRegion(
    IntPtr gpuMat,
    ref Range rowRange,
    ref Range colRange
)
Public Shared Function GetRegion (
    gpuMat As IntPtr,
    ByRef rowRange As Range,
    ByRef colRange As Range
) As IntPtr
public:
static IntPtr GetRegion(
    IntPtr gpuMat,
    Range^% rowRange,
    Range^% colRange
)
static member GetRegion :
        gpuMat : IntPtr *
        rowRange : Range byref *
        colRange : Range byref -> IntPtr

Parameters

gpuMat
Type: SystemIntPtr
The gpuMat to extract regions from.
rowRange
Type: Emgu.CV.StructureRange
The row range. Use MCvSlice.WholeSeq for all rows.
colRange
Type: Emgu.CV.StructureRange
The column range. Use MCvSlice.WholeSeq for all columns.

Return Value

Type: IntPtr
Pointer to the GpuMat
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GetSubRect Method

CudaInvokeGetSubRect Method

Returns header, corresponding to a specified rectangle of the input GpuMat. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetSubRect(
    IntPtr mat,
    ref Rectangle rect
)
Public Shared Function GetSubRect (
    mat As IntPtr,
    ByRef rect As Rectangle
) As IntPtr
public:
static IntPtr GetSubRect(
    IntPtr mat,
    Rectangle^% rect
)
static member GetSubRect :
        mat : IntPtr *
        rect : Rectangle byref -> IntPtr

Parameters

mat
Type: SystemIntPtr
Input GpuMat
rect
Type: System.DrawingRectangle
Zero-based coordinates of the rectangle of interest.

Return Value

Type: IntPtr
Pointer to the resultant sub-array header.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GpuMatReshape Method

CudaInvokeGpuMatReshape Method

gpuMatReshape the src GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GpuMatReshape(
    IntPtr src,
    IntPtr dst,
    int cn,
    int rows
)
Public Shared Sub GpuMatReshape (
    src As IntPtr,
    dst As IntPtr,
    cn As Integer,
    rows As Integer
)
public:
static void GpuMatReshape(
    IntPtr src,
    IntPtr dst,
    int cn,
    int rows
)
static member GpuMatReshape :
        src : IntPtr *
        dst : IntPtr *
        cn : int *
        rows : int -> unit

Parameters

src
Type: SystemIntPtr
The source GpuMat
dst
Type: SystemIntPtr
The resulting GpuMat, as input it should be an empty GpuMat.
cn
Type: SystemInt32
The new number of channels
rows
Type: SystemInt32
The new number of rows
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.GpuMatResize Method

CudaInvokeGpuMatResize Method

Resize the GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GpuMatResize(
    IntPtr src,
    IntPtr dst,
    Inter interpolation,
    IntPtr stream
)
Public Shared Sub GpuMatResize (
    src As IntPtr,
    dst As IntPtr,
    interpolation As Inter,
    stream As IntPtr
)
public:
static void GpuMatResize(
    IntPtr src,
    IntPtr dst,
    Inter^ interpolation,
    IntPtr stream
)
static member GpuMatResize :
        src : IntPtr *
        dst : IntPtr *
        interpolation : Inter *
        stream : IntPtr -> unit

Parameters

src
Type: SystemIntPtr
The input GpuMat
dst
Type: SystemIntPtr
The resulting GpuMat
interpolation
Type: Emgu.CV.CvEnumInter
The interpolation type
stream
Type: SystemIntPtr
Use a Stream to call the function asynchronously (non-blocking) or IntPtr.Zero to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.HistEven Method

CudaInvokeHistEven Method

Calculates histogram with evenly distributed bins for single channel source.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void HistEven(
    IInputArray src,
    IOutputArray hist,
    int histSize,
    int lowerLevel,
    int upperLevel,
    Stream stream = null
)
Public Shared Sub HistEven (
    src As IInputArray,
    hist As IOutputArray,
    histSize As Integer,
    lowerLevel As Integer,
    upperLevel As Integer,
    Optional stream As Stream = Nothing
)
public:
static void HistEven(
    IInputArray^ src,
    IOutputArray^ hist,
    int histSize,
    int lowerLevel,
    int upperLevel,
    Stream^ stream = nullptr
)
static member HistEven :
        src : IInputArray *
        hist : IOutputArray *
        histSize : int *
        lowerLevel : int *
        upperLevel : int *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat. Supports CV_8UC1, CV_16UC1 and CV_16SC1 types.
hist
Type: Emgu.CVIOutputArray
Histogram with evenly distributed bins. A GpuMat<int> type.
histSize
Type: SystemInt32
The size of histogram (number of levels)
lowerLevel
Type: SystemInt32
The lower level
upperLevel
Type: SystemInt32
The upper level
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Return Value

Type:
Histogram with evenly distributed bins
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.HistRange Method

CudaInvokeHistRange Method

Calculates a histogram with bins determined by the levels array

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void HistRange(
    IInputArray src,
    IOutputArray hist,
    IInputArray levels,
    Stream stream = null
)
Public Shared Sub HistRange (
    src As IInputArray,
    hist As IOutputArray,
    levels As IInputArray,
    Optional stream As Stream = Nothing
)
public:
static void HistRange(
    IInputArray^ src,
    IOutputArray^ hist,
    IInputArray^ levels,
    Stream^ stream = nullptr
)
static member HistRange :
        src : IInputArray *
        hist : IOutputArray *
        levels : IInputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image. CV_8U , CV_16U , or CV_16S depth and 1 or 4 channels are supported. For a four-channel image, all channels are processed separately.
hist
Type: Emgu.CVIOutputArray
Destination histogram with one row, (levels.cols-1) columns, and the CV_32SC1 type.
levels
Type: Emgu.CVIInputArray
Number of levels in the histogram.
stream (Optional)
Type: Emgu.CV.CudaStream
Stream for the asynchronous version.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Integral Method

CudaInvokeIntegral Method

Computes the integral image and integral for the squared image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Integral(
    IInputArray src,
    IOutputArray sum,
    Stream stream = null
)
Public Shared Sub Integral (
    src As IInputArray,
    sum As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Integral(
    IInputArray^ src,
    IOutputArray^ sum,
    Stream^ stream = nullptr
)
static member Integral :
        src : IInputArray *
        sum : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat, supports only CV_8UC1 source type
sum
Type: Emgu.CVIOutputArray
The sum GpuMat, supports only CV_32S source type, but will contain unsigned int values
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Log Method

CudaInvokeLog Method

Computes natural logarithm of absolute value of each matrix element: b = log(abs(a))

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Log(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Log (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Log(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Log :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat. Supports Byte, UInt16, Int16 and float type.
dst
Type: Emgu.CVIOutputArray
The resulting GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.LShift Method

CudaInvokeLShift Method

Shifts a matrix to the left (c = a << scalar)

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void LShift(
    IInputArray a,
    MCvScalar scalar,
    IOutputArray c,
    Stream stream = null
)
Public Shared Sub LShift (
    a As IInputArray,
    scalar As MCvScalar,
    c As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void LShift(
    IInputArray^ a,
    MCvScalar^ scalar,
    IOutputArray^ c,
    Stream^ stream = nullptr
)
static member LShift :
        a : IInputArray *
        scalar : MCvScalar *
        c : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The matrix to be shifted.
scalar
Type: Emgu.CV.StructureMCvScalar
The scalar to shift by.
c
Type: Emgu.CVIOutputArray
The result of the shift
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Magnitude Method

CudaInvokeMagnitude Method

Computes magnitude of each (x(i), y(i)) vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Magnitude(
    IInputArray x,
    IInputArray y,
    IOutputArray magnitude,
    Stream stream = null
)
Public Shared Sub Magnitude (
    x As IInputArray,
    y As IInputArray,
    magnitude As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Magnitude(
    IInputArray^ x,
    IInputArray^ y,
    IOutputArray^ magnitude,
    Stream^ stream = nullptr
)
static member Magnitude :
        x : IInputArray *
        y : IInputArray *
        magnitude : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

x
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
y
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
magnitude
Type: Emgu.CVIOutputArray
The destination GpuMat. Supports only floating-point type
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MagnitudeSqr Method

CudaInvokeMagnitudeSqr Method

Computes squared magnitude of each (x(i), y(i)) vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MagnitudeSqr(
    IInputArray x,
    IInputArray y,
    IOutputArray magnitude,
    Stream stream = null
)
Public Shared Sub MagnitudeSqr (
    x As IInputArray,
    y As IInputArray,
    magnitude As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void MagnitudeSqr(
    IInputArray^ x,
    IInputArray^ y,
    IOutputArray^ magnitude,
    Stream^ stream = nullptr
)
static member MagnitudeSqr :
        x : IInputArray *
        y : IInputArray *
        magnitude : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

x
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
y
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
magnitude
Type: Emgu.CVIOutputArray
The destination GpuMat. Supports only floating-point type
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Max Method

CudaInvokeMax Method

Computes per-element maximum of two GpuMats (dst = max(src1, src2))

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Max(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Max (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Max(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Max :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first GpuMat
src2
Type: Emgu.CVIInputArray
The second GpuMat
dst
Type: Emgu.CVIOutputArray
The result GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MeanShiftFiltering Method

CudaInvokeMeanShiftFiltering Method

Performs mean-shift filtering for each point of the source image. It maps each point of the source image into another point, and as the result we have new color and new position of each point.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MeanShiftFiltering(
    IInputArray src,
    IOutputArray dst,
    int sp,
    int sr,
    MCvTermCriteria criteria,
    Stream stream = null
)
Public Shared Sub MeanShiftFiltering (
    src As IInputArray,
    dst As IOutputArray,
    sp As Integer,
    sr As Integer,
    criteria As MCvTermCriteria,
    Optional stream As Stream = Nothing
)
public:
static void MeanShiftFiltering(
    IInputArray^ src,
    IOutputArray^ dst,
    int sp,
    int sr,
    MCvTermCriteria^ criteria,
    Stream^ stream = nullptr
)
static member MeanShiftFiltering :
        src : IInputArray *
        dst : IOutputArray *
        sp : int *
        sr : int *
        criteria : MCvTermCriteria *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source CudaImage. Only CV 8UC4 images are supported for now.
dst
Type: Emgu.CVIOutputArray
Destination CudaImage, containing color of mapped points. Will have the same size and type as src.
sp
Type: SystemInt32
Spatial window radius.
sr
Type: SystemInt32
Color window radius.
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MeanShiftProc Method

CudaInvokeMeanShiftProc Method

Performs mean-shift procedure and stores information about processed points (i.e. their colors and positions) into two images.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MeanShiftProc(
    IInputArray src,
    IOutputArray dstr,
    IOutputArray dstsp,
    int sp,
    int sr,
    MCvTermCriteria criteria,
    Stream stream = null
)
Public Shared Sub MeanShiftProc (
    src As IInputArray,
    dstr As IOutputArray,
    dstsp As IOutputArray,
    sp As Integer,
    sr As Integer,
    criteria As MCvTermCriteria,
    Optional stream As Stream = Nothing
)
public:
static void MeanShiftProc(
    IInputArray^ src,
    IOutputArray^ dstr,
    IOutputArray^ dstsp,
    int sp,
    int sr,
    MCvTermCriteria^ criteria,
    Stream^ stream = nullptr
)
static member MeanShiftProc :
        src : IInputArray *
        dstr : IOutputArray *
        dstsp : IOutputArray *
        sp : int *
        sr : int *
        criteria : MCvTermCriteria *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source CudaImage. Only CV 8UC4 images are supported for now.
dstr
Type: Emgu.CVIOutputArray
Destination CudaImage, containing color of mapped points. Will have the same size and type as src.
dstsp
Type: Emgu.CVIOutputArray
Destination CudaImage, containing position of mapped points. Will have the same size as src and CV 16SC2 type.
sp
Type: SystemInt32
Spatial window radius.
sr
Type: SystemInt32
Color window radius.
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MeanShiftSegmentation Method

CudaInvokeMeanShiftSegmentation Method

Performs mean-shift segmentation of the source image and eleminates small segments.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MeanShiftSegmentation(
    IInputArray src,
    IOutputArray dst,
    int sp,
    int sr,
    int minSize,
    MCvTermCriteria criteria,
    Stream stream
)
Public Shared Sub MeanShiftSegmentation (
    src As IInputArray,
    dst As IOutputArray,
    sp As Integer,
    sr As Integer,
    minSize As Integer,
    criteria As MCvTermCriteria,
    stream As Stream
)
public:
static void MeanShiftSegmentation(
    IInputArray^ src,
    IOutputArray^ dst,
    int sp,
    int sr,
    int minSize,
    MCvTermCriteria^ criteria,
    Stream^ stream
)
static member MeanShiftSegmentation :
        src : IInputArray *
        dst : IOutputArray *
        sp : int *
        sr : int *
        minSize : int *
        criteria : MCvTermCriteria *
        stream : Stream -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source CudaImage. Only CV 8UC4 images are supported for now.
dst
Type: Emgu.CVIOutputArray
Segmented Image. Will have the same size and type as src. Note that this is an Image type and not CudaImage type
sp
Type: SystemInt32
Spatial window radius.
sr
Type: SystemInt32
Color window radius.
minSize
Type: SystemInt32
Minimum segment size. Smaller segements will be merged.
criteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria.
stream
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MeanStdDev Method

CudaInvokeMeanStdDev Method

Computes mean value and standard deviation

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MeanStdDev(
    IInputArray mtx,
    ref MCvScalar mean,
    ref MCvScalar stddev
)
Public Shared Sub MeanStdDev (
    mtx As IInputArray,
    ByRef mean As MCvScalar,
    ByRef stddev As MCvScalar
)
public:
static void MeanStdDev(
    IInputArray^ mtx,
    MCvScalar^% mean,
    MCvScalar^% stddev
)
static member MeanStdDev :
        mtx : IInputArray *
        mean : MCvScalar byref *
        stddev : MCvScalar byref -> unit

Parameters

mtx
Type: Emgu.CVIInputArray
The GpuMat. Supports only CV_8UC1 type
mean
Type: Emgu.CV.StructureMCvScalar
The mean value
stddev
Type: Emgu.CV.StructureMCvScalar
The standard deviation
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Merge Method

CudaInvokeMerge Method

Makes multi-channel GpuMat out of several single-channel GpuMats

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Merge(
    VectorOfGpuMat srcArr,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Merge (
    srcArr As VectorOfGpuMat,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Merge(
    VectorOfGpuMat^ srcArr,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Merge :
        srcArr : VectorOfGpuMat *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

srcArr
Type: Emgu.CV.CudaVectorOfGpuMat
Pointer to an array of single channel GpuMat pointers
dst
Type: Emgu.CVIOutputArray
The multi-channel gpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or IntPtr.Zero to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Min Method

CudaInvokeMin Method

Computes per-element minimum of two GpuMats (dst = min(src1, src2))

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Min(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Min (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Min(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Min :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
The first GpuMat
src2
Type: Emgu.CVIInputArray
The second GpuMat
dst
Type: Emgu.CVIOutputArray
The result GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MinMaxLoc Method

CudaInvokeMinMaxLoc Method

Finds minimum and maximum element values and their positions. The extremums are searched over the whole GpuMat or, if mask is not IntPtr.Zero, in the specified GpuMat region.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MinMaxLoc(
    IInputArray gpuMat,
    ref double minVal,
    ref double maxVal,
    ref Point minLoc,
    ref Point maxLoc,
    IInputArray mask = null
)
Public Shared Sub MinMaxLoc (
    gpuMat As IInputArray,
    ByRef minVal As Double,
    ByRef maxVal As Double,
    ByRef minLoc As Point,
    ByRef maxLoc As Point,
    Optional mask As IInputArray = Nothing
)
public:
static void MinMaxLoc(
    IInputArray^ gpuMat,
    double% minVal,
    double% maxVal,
    Point^% minLoc,
    Point^% maxLoc,
    IInputArray^ mask = nullptr
)
static member MinMaxLoc :
        gpuMat : IInputArray *
        minVal : float byref *
        maxVal : float byref *
        minLoc : Point byref *
        maxLoc : Point byref *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

gpuMat
Type: Emgu.CVIInputArray
The source GpuMat, single-channel
minVal
Type: SystemDouble
Pointer to returned minimum value
maxVal
Type: SystemDouble
Pointer to returned maximum value
minLoc
Type: System.DrawingPoint
Pointer to returned minimum location
maxLoc
Type: System.DrawingPoint
Pointer to returned maximum location
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask that is used to select a subarray. Use null if not needed
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MulAndScaleSpectrums Method

CudaInvokeMulAndScaleSpectrums Method

Performs a per-element multiplication of two Fourier spectrums and scales the result.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MulAndScaleSpectrums(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    int flags,
    float scale,
    bool conjB = false,
    Stream stream = null
)
Public Shared Sub MulAndScaleSpectrums (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    flags As Integer,
    scale As Single,
    Optional conjB As Boolean = false,
    Optional stream As Stream = Nothing
)
public:
static void MulAndScaleSpectrums(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    int flags,
    float scale,
    bool conjB = false,
    Stream^ stream = nullptr
)
static member MulAndScaleSpectrums :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        flags : int *
        scale : float32 *
        ?conjB : bool *
        ?stream : Stream
(* Defaults:
        let _conjB = defaultArg conjB false
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
First spectrum.
src2
Type: Emgu.CVIInputArray
Second spectrum with the same size and type.
dst
Type: Emgu.CVIOutputArray
Destination spectrum.
flags
Type: SystemInt32
Mock parameter used for CPU/CUDA interfaces similarity, simply add a 0 value.
scale
Type: SystemSingle
Scale constant.
conjB (Optional)
Type: SystemBoolean
Optional flag to specify if the second spectrum needs to be conjugated before the multiplication.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.MulSpectrums Method

CudaInvokeMulSpectrums Method

Performs a per-element multiplication of two Fourier spectrums.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MulSpectrums(
    IInputArray src1,
    IInputArray src2,
    IOutputArray dst,
    int flags,
    bool conjB = false,
    Stream stream = null
)
Public Shared Sub MulSpectrums (
    src1 As IInputArray,
    src2 As IInputArray,
    dst As IOutputArray,
    flags As Integer,
    Optional conjB As Boolean = false,
    Optional stream As Stream = Nothing
)
public:
static void MulSpectrums(
    IInputArray^ src1,
    IInputArray^ src2,
    IOutputArray^ dst,
    int flags,
    bool conjB = false,
    Stream^ stream = nullptr
)
static member MulSpectrums :
        src1 : IInputArray *
        src2 : IInputArray *
        dst : IOutputArray *
        flags : int *
        ?conjB : bool *
        ?stream : Stream
(* Defaults:
        let _conjB = defaultArg conjB false
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src1
Type: Emgu.CVIInputArray
First spectrum.
src2
Type: Emgu.CVIInputArray
Second spectrum with the same size and type.
dst
Type: Emgu.CVIOutputArray
Destination spectrum.
flags
Type: SystemInt32
Mock parameter used for CPU/CUDA interfaces similarity.
conjB (Optional)
Type: SystemBoolean
Optional flag to specify if the second spectrum needs to be conjugated before the multiplication.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Multiply Method

CudaInvokeMultiply Method

Computes element-wise product of the two GpuMat: c = scale * a * b.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Multiply(
    IInputArray a,
    IInputArray b,
    IOutputArray c,
    double scale = 1,
    DepthType depthType = -1,
    Stream stream = null
)
Public Shared Sub Multiply (
    a As IInputArray,
    b As IInputArray,
    c As IOutputArray,
    Optional scale As Double = 1,
    Optional depthType As DepthType = -1,
    Optional stream As Stream = Nothing
)
public:
static void Multiply(
    IInputArray^ a,
    IInputArray^ b,
    IOutputArray^ c,
    double scale = 1,
    DepthType^ depthType = -1,
    Stream^ stream = nullptr
)
static member Multiply :
        a : IInputArray *
        b : IInputArray *
        c : IOutputArray *
        ?scale : float *
        ?depthType : DepthType *
        ?stream : Stream
(* Defaults:
        let _scale = defaultArg scale 1
        let _depthType = defaultArg depthType -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The first GpuMat to be element-wise multiplied.
b
Type: Emgu.CVIInputArray
The second GpuMat to be element-wise multiplied.
c
Type: Emgu.CVIOutputArray
The element-wise multiplication of the two GpuMat
scale (Optional)
Type: SystemDouble
The scale
depthType (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Norm Method

CudaInvokeNorm Method

Overload List
Name | Description
Norm(IInputArray, NormType, IInputArray) | Returns the norm of a matrix.
Norm(IInputArray, IInputArray, NormType) | Computes norm of the difference between two GpuMats
Top
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Norm Method (IInputArray, NormType, IInputArray)

CudaInvokeNorm Method (IInputArray, NormType, IInputArray)

http://www.emgu.com
Returns the norm of a matrix.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Norm(
    IInputArray src,
    NormType normType,
    IInputArray mask = null
)
Public Shared Function Norm (
    src As IInputArray,
    normType As NormType,
    Optional mask As IInputArray = Nothing
) As Double
public:
static double Norm(
    IInputArray^ src,
    NormType^ normType,
    IInputArray^ mask = nullptr
)
static member Norm :
        src : IInputArray *
        normType : NormType *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> float

Parameters

src
Type: Emgu.CVIInputArray
Source matrix. Any matrices except 64F are supported.
normType
Type: Emgu.CV.CvEnumNormType
Norm type. NORM_L1 , NORM_L2 , and NORM_INF are supported for now.
mask (Optional)
Type: Emgu.CVIInputArray
optional operation mask; it must have the same size as src1 and CV_8UC1 type.

Return Value

Type: Double
The norm of a matrix
See Also

Reference

CudaInvoke Class
Norm Overload
Emgu.CV.Cuda Namespace


CudaInvoke.Norm Method (IInputArray, IInputArray, NormType)

CudaInvokeNorm Method (IInputArray, IInputArray, NormType)

http://www.emgu.com
Computes norm of the difference between two GpuMats

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Norm(
    IInputArray src1,
    IInputArray src2,
    NormType normType = 4
)
Public Shared Function Norm (
    src1 As IInputArray,
    src2 As IInputArray,
    Optional normType As NormType = 4
) As Double
public:
static double Norm(
    IInputArray^ src1,
    IInputArray^ src2,
    NormType^ normType = 4
)
static member Norm :
        src1 : IInputArray *
        src2 : IInputArray *
        ?normType : NormType
(* Defaults:
        let _normType = defaultArg normType 4
*)
-> float

Parameters

src1
Type: Emgu.CVIInputArray
The GpuMat. Supports only CV_8UC1 type
src2
Type: Emgu.CVIInputArray
If IntPtr.Zero, norm operation is apply to src1 only. Otherwise, this is the GpuMat of type CV_8UC1
normType (Optional)
Type: Emgu.CV.CvEnumNormType
The norm type. Supports NORM_INF, NORM_L1, NORM_L2.

Return Value

Type: Double
The norm of the src1 if src2 is IntPtr.Zero. Otherwise the norm of the difference between two GpuMats.
See Also

Reference

CudaInvoke Class
Norm Overload
Emgu.CV.Cuda Namespace


CudaInvoke.Normalize Method

CudaInvokeNormalize Method

Normalizes the norm or value range of an array.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Normalize(
    IInputArray src,
    IOutputArray dst,
    double alpha,
    double beta,
    NormType normType,
    DepthType depthType,
    IInputArray mask = null,
    Stream stream = null
)
Public Shared Sub Normalize (
    src As IInputArray,
    dst As IOutputArray,
    alpha As Double,
    beta As Double,
    normType As NormType,
    depthType As DepthType,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void Normalize(
    IInputArray^ src,
    IOutputArray^ dst,
    double alpha,
    double beta,
    NormType^ normType,
    DepthType^ depthType,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
static member Normalize :
        src : IInputArray *
        dst : IOutputArray *
        alpha : float *
        beta : float *
        normType : NormType *
        depthType : DepthType *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input array.
dst
Type: Emgu.CVIOutputArray
Output array of the same size as src .
alpha
Type: SystemDouble
Norm value to normalize to or the lower range boundary in case of the range normalization.
beta
Type: SystemDouble
Upper range boundary in case of the range normalization; it is not used for the norm normalization.
normType
Type: Emgu.CV.CvEnumNormType
Normalization type ( NORM_MINMAX , NORM_L2 , NORM_L1 or NORM_INF ).
depthType
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array.
mask (Optional)
Type: Emgu.CVIInputArray
Optional operation mask.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Phase Method

CudaInvokePhase Method

Computes angle (angle(i)) of each (x(i), y(i)) vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Phase(
    IInputArray x,
    IInputArray y,
    IOutputArray angle,
    bool angleInDegrees = false,
    Stream stream = null
)
Public Shared Sub Phase (
    x As IInputArray,
    y As IInputArray,
    angle As IOutputArray,
    Optional angleInDegrees As Boolean = false,
    Optional stream As Stream = Nothing
)
public:
static void Phase(
    IInputArray^ x,
    IInputArray^ y,
    IOutputArray^ angle,
    bool angleInDegrees = false,
    Stream^ stream = nullptr
)
static member Phase :
        x : IInputArray *
        y : IInputArray *
        angle : IOutputArray *
        ?angleInDegrees : bool *
        ?stream : Stream
(* Defaults:
        let _angleInDegrees = defaultArg angleInDegrees false
        let _stream = defaultArg stream null
*)
-> unit

Parameters

x
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
y
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
angle
Type: Emgu.CVIOutputArray
The destination GpuMat. Supports only floating-point type
angleInDegrees (Optional)
Type: SystemBoolean
If true, the output angle is in degrees, otherwise in radian
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.PolarToCart Method

CudaInvokePolarToCart Method

Converts polar coordinates to Cartesian

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PolarToCart(
    IInputArray magnitude,
    IInputArray angle,
    IOutputArray x,
    IOutputArray y,
    bool angleInDegrees = false,
    Stream stream = null
)
Public Shared Sub PolarToCart (
    magnitude As IInputArray,
    angle As IInputArray,
    x As IOutputArray,
    y As IOutputArray,
    Optional angleInDegrees As Boolean = false,
    Optional stream As Stream = Nothing
)
public:
static void PolarToCart(
    IInputArray^ magnitude,
    IInputArray^ angle,
    IOutputArray^ x,
    IOutputArray^ y,
    bool angleInDegrees = false,
    Stream^ stream = nullptr
)
static member PolarToCart :
        magnitude : IInputArray *
        angle : IInputArray *
        x : IOutputArray *
        y : IOutputArray *
        ?angleInDegrees : bool *
        ?stream : Stream
(* Defaults:
        let _angleInDegrees = defaultArg angleInDegrees false
        let _stream = defaultArg stream null
*)
-> unit

Parameters

magnitude
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
angle
Type: Emgu.CVIInputArray
The source GpuMat. Supports only floating-point type
x
Type: Emgu.CVIOutputArray
The destination GpuMat. Supports only floating-point type
y
Type: Emgu.CVIOutputArray
The destination GpuMat. Supports only floating-point type
angleInDegrees (Optional)
Type: SystemBoolean
If true, the input angle is in degrees, otherwise in radian
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Pow Method

CudaInvokePow Method

Computes power of each matrix element: (dst(i,j) = pow( src(i,j) , power), if src.type() is integer; (dst(i,j) = pow(fabs(src(i,j)), power), otherwise. supports all, except depth == CV_64F

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Pow(
    IInputArray src,
    double power,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Pow (
    src As IInputArray,
    power As Double,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Pow(
    IInputArray^ src,
    double power,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Pow :
        src : IInputArray *
        power : float *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat
power
Type: SystemDouble
The power
dst
Type: Emgu.CVIOutputArray
The resulting GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.PyrDown Method

CudaInvokePyrDown Method

Performs downsampling step of Gaussian pyramid decomposition.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PyrDown(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub PyrDown (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void PyrDown(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member PyrDown :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source CudaImage.
dst
Type: Emgu.CVIOutputArray
The destination CudaImage, should have 2x smaller width and height than the source.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.PyrUp Method

CudaInvokePyrUp Method

Performs up-sampling step of Gaussian pyramid decomposition.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void PyrUp(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub PyrUp (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void PyrUp(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member PyrUp :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source CudaImage.
dst
Type: Emgu.CVIOutputArray
The destination image, should have 2x smaller width and height than the source.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Reduce Method

CudaInvokeReduce Method

Reduces GpuMat to a vector by treating the GpuMat rows/columns as a set of 1D vectors and performing the specified operation on the vectors until a single row/column is obtained.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Reduce(
    IInputArray mtx,
    IOutputArray vec,
    ReduceDimension dim,
    ReduceType reduceOp,
    DepthType dType = -1,
    Stream stream = null
)
Public Shared Sub Reduce (
    mtx As IInputArray,
    vec As IOutputArray,
    dim As ReduceDimension,
    reduceOp As ReduceType,
    Optional dType As DepthType = -1,
    Optional stream As Stream = Nothing
)
public:
static void Reduce(
    IInputArray^ mtx,
    IOutputArray^ vec,
    ReduceDimension^ dim,
    ReduceType^ reduceOp,
    DepthType^ dType = -1,
    Stream^ stream = nullptr
)
static member Reduce :
        mtx : IInputArray *
        vec : IOutputArray *
        dim : ReduceDimension *
        reduceOp : ReduceType *
        ?dType : DepthType *
        ?stream : Stream
(* Defaults:
        let _dType = defaultArg dType -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

mtx
Type: Emgu.CVIInputArray
The input GpuMat
vec
Type: Emgu.CVIOutputArray
Destination vector. Its size and type is defined by dim and dtype parameters
dim
Type: Emgu.CV.CvEnumReduceDimension
Dimension index along which the matrix is reduced. 0 means that the matrix is reduced to a single row. 1 means that the matrix is reduced to a single column.
reduceOp
Type: Emgu.CV.CvEnumReduceType
The reduction operation type
dType (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Remap Method

CudaInvokeRemap Method

DST[x,y] = SRC[xmap[x,y],ymap[x,y]] with bilinear interpolation.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Remap(
    IInputArray src,
    IOutputArray dst,
    IInputArray xmap,
    IInputArray ymap,
    Inter interpolation,
    BorderType borderMode = 0,
    MCvScalar borderValue = null,
    Stream stream = null
)
Public Shared Sub Remap (
    src As IInputArray,
    dst As IOutputArray,
    xmap As IInputArray,
    ymap As IInputArray,
    interpolation As Inter,
    Optional borderMode As BorderType = 0,
    Optional borderValue As MCvScalar = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void Remap(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ xmap,
    IInputArray^ ymap,
    Inter^ interpolation,
    BorderType^ borderMode = 0,
    MCvScalar^ borderValue = nullptr,
    Stream^ stream = nullptr
)
static member Remap :
        src : IInputArray *
        dst : IOutputArray *
        xmap : IInputArray *
        ymap : IInputArray *
        interpolation : Inter *
        ?borderMode : BorderType *
        ?borderValue : MCvScalar *
        ?stream : Stream
(* Defaults:
        let _borderMode = defaultArg borderMode 0
        let _borderValue = defaultArg borderValue null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat. Supports CV_8UC1, CV_8UC3 source types.
dst
Type: Emgu.CVIOutputArray
The dstination GpuMat. Supports CV_8UC1, CV_8UC3 source types.
xmap
Type: Emgu.CVIInputArray
The xmap. Supports CV_32FC1 map type.
ymap
Type: Emgu.CVIInputArray
The ymap. Supports CV_32FC1 map type.
interpolation
Type: Emgu.CV.CvEnumInter
Interpolation type.
borderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
Border mode. Use BORDER_CONSTANT for default.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The value of the border.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Resize Method

CudaInvokeResize Method

Resizes the image.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Resize(
    IInputArray src,
    IOutputArray dst,
    Size dsize,
    double fx = 0,
    double fy = 0,
    Inter interpolation = 1,
    Stream stream = null
)
Public Shared Sub Resize (
    src As IInputArray,
    dst As IOutputArray,
    dsize As Size,
    Optional fx As Double = 0,
    Optional fy As Double = 0,
    Optional interpolation As Inter = 1,
    Optional stream As Stream = Nothing
)
public:
static void Resize(
    IInputArray^ src,
    IOutputArray^ dst,
    Size^ dsize,
    double fx = 0,
    double fy = 0,
    Inter^ interpolation = 1,
    Stream^ stream = nullptr
)
static member Resize :
        src : IInputArray *
        dst : IOutputArray *
        dsize : Size *
        ?fx : float *
        ?fy : float *
        ?interpolation : Inter *
        ?stream : Stream
(* Defaults:
        let _fx = defaultArg fx 0
        let _fy = defaultArg fy 0
        let _interpolation = defaultArg interpolation 1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image. Has to be GpuMat<Byte>. If stream is used, the GpuMat has to be either single channel or 4 channels.
dst
Type: Emgu.CVIOutputArray
The destination image.
dsize
Type: System.DrawingSize
Destination image size. If it is zero, it is computed as: dsize = Size(round(fx* src.cols), round(fy* src.rows)). Either dsize or both fx and fy must be non-zero.
fx (Optional)
Type: SystemDouble
Scale factor along the horizontal axis. If it is zero, it is computed as: (double)dsize.width/src.cols
fy (Optional)
Type: SystemDouble
Scale factor along the vertical axis. If it is zero, it is computed as: (double)dsize.height/src.rows
interpolation (Optional)
Type: Emgu.CV.CvEnumInter
The interpolation type. Supports INTER_NEAREST, INTER_LINEAR.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Rotate Method

CudaInvokeRotate Method

Rotates an image around the origin (0,0) and then shifts it.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Rotate(
    IInputArray src,
    IOutputArray dst,
    Size dSize,
    double angle,
    double xShift = 0,
    double yShift = 0,
    Inter interpolation = 1,
    Stream stream = null
)
Public Shared Sub Rotate (
    src As IInputArray,
    dst As IOutputArray,
    dSize As Size,
    angle As Double,
    Optional xShift As Double = 0,
    Optional yShift As Double = 0,
    Optional interpolation As Inter = 1,
    Optional stream As Stream = Nothing
)
public:
static void Rotate(
    IInputArray^ src,
    IOutputArray^ dst,
    Size^ dSize,
    double angle,
    double xShift = 0,
    double yShift = 0,
    Inter^ interpolation = 1,
    Stream^ stream = nullptr
)
static member Rotate :
        src : IInputArray *
        dst : IOutputArray *
        dSize : Size *
        angle : float *
        ?xShift : float *
        ?yShift : float *
        ?interpolation : Inter *
        ?stream : Stream
(* Defaults:
        let _xShift = defaultArg xShift 0
        let _yShift = defaultArg yShift 0
        let _interpolation = defaultArg interpolation 1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image. Supports 1, 3 or 4 channels images with Byte, UInt16 or float depth
dst
Type: Emgu.CVIOutputArray
Destination image with the same type as src. Must be pre-allocated
dSize
Type: System.DrawingSize
The size of the destination image
angle
Type: SystemDouble
Angle of rotation in degrees
xShift (Optional)
Type: SystemDouble
Shift along the horizontal axis
yShift (Optional)
Type: SystemDouble
Shift along the verticle axis
interpolation (Optional)
Type: Emgu.CV.CvEnumInter
Interpolation method. Only INTER_NEAREST, INTER_LINEAR, and INTER_CUBIC are supported.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.RShift Method

CudaInvokeRShift Method

Shifts a matrix to the right (c = a >> scalar)

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void RShift(
    IInputArray a,
    MCvScalar scalar,
    IOutputArray c,
    Stream stream = null
)
Public Shared Sub RShift (
    a As IInputArray,
    scalar As MCvScalar,
    c As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void RShift(
    IInputArray^ a,
    MCvScalar^ scalar,
    IOutputArray^ c,
    Stream^ stream = nullptr
)
static member RShift :
        a : IInputArray *
        scalar : MCvScalar *
        c : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The matrix to be shifted.
scalar
Type: Emgu.CV.StructureMCvScalar
The scalar to shift by.
c
Type: Emgu.CVIOutputArray
The result of the shift
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.SetDevice Method

CudaInvokeSetDevice Method

Set the current Gpu Device

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SetDevice(
    int deviceId
)
Public Shared Sub SetDevice (
    deviceId As Integer
)
public:
static void SetDevice(
    int deviceId
)
static member SetDevice :
        deviceId : int -> unit

Parameters

deviceId
Type: SystemInt32
The id of the device to be setted as current
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.SetGlDevice Method

CudaInvokeSetGlDevice Method

Sets a CUDA device and initializes it for the current thread with OpenGL interoperability. This function should be explicitly called after OpenGL context creation and before any CUDA calls.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SetGlDevice(
    int device = 0
)
Public Shared Sub SetGlDevice (
    Optional device As Integer = 0
)
public:
static void SetGlDevice(
    int device = 0
)
static member SetGlDevice :
        ?device : int
(* Defaults:
        let _device = defaultArg device 0
*)
-> unit

Parameters

device (Optional)
Type: SystemInt32
System index of a CUDA device starting with 0.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Split Method

CudaInvokeSplit Method

Copies each plane of a multi-channel GpuMat to a dedicated GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Split(
    IInputArray src,
    VectorOfGpuMat dstArray,
    Stream stream = null
)
Public Shared Sub Split (
    src As IInputArray,
    dstArray As VectorOfGpuMat,
    Optional stream As Stream = Nothing
)
public:
static void Split(
    IInputArray^ src,
    VectorOfGpuMat^ dstArray,
    Stream^ stream = nullptr
)
static member Split :
        src : IInputArray *
        dstArray : VectorOfGpuMat *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The multi-channel gpuMat
dstArray
Type: Emgu.CV.CudaVectorOfGpuMat
Pointer to an array of single channel GpuMat pointers
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or IntPtr.Zero to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Sqr Method

CudaInvokeSqr Method

Computes square of each pixel in an image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Sqr(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Sqr (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Sqr(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Sqr :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat, support depth of byte, UInt16, Int16 and float.
dst
Type: Emgu.CVIOutputArray
The resulting GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.SqrIntegral Method

CudaInvokeSqrIntegral Method

Computes squared integral image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SqrIntegral(
    IInputArray src,
    IOutputArray sqsum,
    Stream stream = null
)
Public Shared Sub SqrIntegral (
    src As IInputArray,
    sqsum As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void SqrIntegral(
    IInputArray^ src,
    IOutputArray^ sqsum,
    Stream^ stream = nullptr
)
static member SqrIntegral :
        src : IInputArray *
        sqsum : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat, supports only CV_8UC1 source type
sqsum
Type: Emgu.CVIOutputArray
The sqsum GpuMat, supports only CV32F source type.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.SqrSum Method

CudaInvokeSqrSum Method

Returns the squared sum of matrix elements.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar SqrSum(
    IInputArray src,
    IInputArray mask = null
)
Public Shared Function SqrSum (
    src As IInputArray,
    Optional mask As IInputArray = Nothing
) As MCvScalar
public:
static MCvScalar^ SqrSum(
    IInputArray^ src,
    IInputArray^ mask = nullptr
)
static member SqrSum :
        src : IInputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> MCvScalar

Parameters

src
Type: Emgu.CVIInputArray
Source image of any depth except for CV_64F.
mask (Optional)
Type: Emgu.CVIInputArray
optional operation mask; it must have the same size as src1 and CV_8UC1 type.

Return Value

Type: MCvScalar
The squared sum of matrix elements.
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Sqrt Method

CudaInvokeSqrt Method

Computes square root of each pixel in an image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Sqrt(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Sqrt (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Sqrt(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Sqrt :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat, support depth of byte, UInt16, Int16 and float.
dst
Type: Emgu.CVIOutputArray
The resulting GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Subtract Method

CudaInvokeSubtract Method

Subtracts one matrix from another (c = a - b).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Subtract(
    IInputArray a,
    IInputArray b,
    IOutputArray c,
    IInputArray mask = null,
    DepthType depthType = -1,
    Stream stream = null
)
Public Shared Sub Subtract (
    a As IInputArray,
    b As IInputArray,
    c As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional depthType As DepthType = -1,
    Optional stream As Stream = Nothing
)
public:
static void Subtract(
    IInputArray^ a,
    IInputArray^ b,
    IOutputArray^ c,
    IInputArray^ mask = nullptr,
    DepthType^ depthType = -1,
    Stream^ stream = nullptr
)
static member Subtract :
        a : IInputArray *
        b : IInputArray *
        c : IOutputArray *
        ?mask : IInputArray *
        ?depthType : DepthType *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _depthType = defaultArg depthType -1
        let _stream = defaultArg stream null
*)
-> unit

Parameters

a
Type: Emgu.CVIInputArray
The matrix where subtraction take place
b
Type: Emgu.CVIInputArray
The matrix to be substracted
c
Type: Emgu.CVIOutputArray
The result of a - b
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask that is used to select a subarray. Use null if not needed
depthType (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output array.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.SwapChannels Method

CudaInvokeSwapChannels Method

Swap channels.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SwapChannels(
    IInputOutputArray src,
    int[] dstOrder,
    Stream stream
)
Public Shared Sub SwapChannels (
    src As IInputOutputArray,
    dstOrder As Integer(),
    stream As Stream
)
public:
static void SwapChannels(
    IInputOutputArray^ src,
    array<int>^ dstOrder,
    Stream^ stream
)
static member SwapChannels :
        src : IInputOutputArray *
        dstOrder : int[] *
        stream : Stream -> unit

Parameters

src
Type: Emgu.CVIInputOutputArray
The image where the channels will be swapped
dstOrder
Type: SystemInt32
Integer array describing how channel values are permutated. The n-th entry of the array contains the number of the channel that is stored in the n-th channel of the output image. E.g. Given an RGBA image, aDstOrder = [3,2,1,0] converts this to ABGR channel order.
stream
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Threshold Method

CudaInvokeThreshold Method

Applies fixed-level thresholding to single-channel array. The function is typically used to get bi-level (binary) image out of grayscale image or for removing a noise, i.e. filtering out pixels with too small or too large values. There are several types of thresholding the function supports that are determined by thresholdType

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double Threshold(
    IInputArray src,
    IOutputArray dst,
    double threshold,
    double maxValue,
    ThresholdType thresholdType,
    Stream stream = null
)
Public Shared Function Threshold (
    src As IInputArray,
    dst As IOutputArray,
    threshold As Double,
    maxValue As Double,
    thresholdType As ThresholdType,
    Optional stream As Stream = Nothing
) As Double
public:
static double Threshold(
    IInputArray^ src,
    IOutputArray^ dst,
    double threshold,
    double maxValue,
    ThresholdType^ thresholdType,
    Stream^ stream = nullptr
)
static member Threshold :
        src : IInputArray *
        dst : IOutputArray *
        threshold : float *
        maxValue : float *
        thresholdType : ThresholdType *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> float

Parameters

src
Type: Emgu.CVIInputArray
Source array (single-channel, 8-bit of 32-bit floating point).
dst
Type: Emgu.CVIOutputArray
Destination array; must be either the same type as src or 8-bit.
threshold
Type: SystemDouble
Threshold value
maxValue
Type: SystemDouble
Maximum value to use with CV_THRESH_BINARY and CV_THRESH_BINARY_INV thresholding types
thresholdType
Type: Emgu.CV.CvEnumThresholdType
Thresholding type
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Return Value

Type: Double

[Missing <returns> documentation for "M:Emgu.CV.Cuda.CudaInvoke.Threshold(Emgu.CV.IInputArray,Emgu.CV.IOutputArray,System.Double,System.Double,Emgu.CV.CvEnum.ThresholdType,Emgu.CV.Cuda.Stream)"]

See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.Transpose Method

CudaInvokeTranspose Method

Transposes a matrix.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Transpose(
    IInputArray src,
    IOutputArray dst,
    Stream stream = null
)
Public Shared Sub Transpose (
    src As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
static void Transpose(
    IInputArray^ src,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
static member Transpose :
        src : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source matrix. 1-, 4-, 8-byte element sizes are supported for now.
dst
Type: Emgu.CVIOutputArray
Destination matrix.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.WarpAffine Method

CudaInvokeWarpAffine Method

Warps the image using affine transformation

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void WarpAffine(
    IInputArray src,
    IOutputArray dst,
    IInputArray M,
    Size dSize,
    Inter flags = 1,
    BorderType borderMode = 0,
    MCvScalar borderValue = null,
    Stream stream = null
)
Public Shared Sub WarpAffine (
    src As IInputArray,
    dst As IOutputArray,
    M As IInputArray,
    dSize As Size,
    Optional flags As Inter = 1,
    Optional borderMode As BorderType = 0,
    Optional borderValue As MCvScalar = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void WarpAffine(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ M,
    Size^ dSize,
    Inter^ flags = 1,
    BorderType^ borderMode = 0,
    MCvScalar^ borderValue = nullptr,
    Stream^ stream = nullptr
)
static member WarpAffine :
        src : IInputArray *
        dst : IOutputArray *
        M : IInputArray *
        dSize : Size *
        ?flags : Inter *
        ?borderMode : BorderType *
        ?borderValue : MCvScalar *
        ?stream : Stream
(* Defaults:
        let _flags = defaultArg flags 1
        let _borderMode = defaultArg borderMode 0
        let _borderValue = defaultArg borderValue null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat
dst
Type: Emgu.CVIOutputArray
The destination GpuMat
M
Type: Emgu.CVIInputArray
The 2x3 transformation matrix (pointer to CvArr)
dSize
Type: System.DrawingSize
The size of the destination image
flags (Optional)
Type: Emgu.CV.CvEnumInter
Supports NN, LINEAR, CUBIC
borderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
The border mode, use BORDER_TYPE.CONSTANT for default.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The border value, use new MCvScalar() for default.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaInvoke.WarpPerspective Method

CudaInvokeWarpPerspective Method

Warps the image using perspective transformation

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void WarpPerspective(
    IInputArray src,
    IOutputArray dst,
    IInputArray M,
    Size dSize,
    Inter flags = 1,
    BorderType borderMode = 0,
    MCvScalar borderValue = null,
    Stream stream = null
)
Public Shared Sub WarpPerspective (
    src As IInputArray,
    dst As IOutputArray,
    M As IInputArray,
    dSize As Size,
    Optional flags As Inter = 1,
    Optional borderMode As BorderType = 0,
    Optional borderValue As MCvScalar = Nothing,
    Optional stream As Stream = Nothing
)
public:
static void WarpPerspective(
    IInputArray^ src,
    IOutputArray^ dst,
    IInputArray^ M,
    Size^ dSize,
    Inter^ flags = 1,
    BorderType^ borderMode = 0,
    MCvScalar^ borderValue = nullptr,
    Stream^ stream = nullptr
)
static member WarpPerspective :
        src : IInputArray *
        dst : IOutputArray *
        M : IInputArray *
        dSize : Size *
        ?flags : Inter *
        ?borderMode : BorderType *
        ?borderValue : MCvScalar *
        ?stream : Stream
(* Defaults:
        let _flags = defaultArg flags 1
        let _borderMode = defaultArg borderMode 0
        let _borderValue = defaultArg borderValue null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
The source GpuMat
dst
Type: Emgu.CVIOutputArray
The destination GpuMat
M
Type: Emgu.CVIInputArray
The 2x3 transformation matrix (pointer to CvArr)
dSize
Type: System.DrawingSize
The size of the destination image
flags (Optional)
Type: Emgu.CV.CvEnumInter
Supports NN, LINEAR, CUBIC
borderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
The border mode, use BORDER_TYPE.CONSTANT for default.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The border value, use new MCvScalar() for default.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaInvoke Class
Emgu.CV.Cuda Namespace


CudaLaplacianFilter Class

Laplacian filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaLaplacianFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaLaplacianFilter : CudaFilter
Public Class CudaLaplacianFilter
    Inherits CudaFilter
public ref class CudaLaplacianFilter : public CudaFilter
type CudaLaplacianFilter =
    class
        inherit CudaFilter
    end

The CudaLaplacianFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaLaplacianFilter | Create a Laplacian filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaLaplacianFilter Constructor

Create a Laplacian filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaLaplacianFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    int ksize = 1,
    double scale = 1,
    BorderType borderType = 4,
    MCvScalar borderValue = null
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    Optional ksize As Integer = 1,
    Optional scale As Double = 1,
    Optional borderType As BorderType = 4,
    Optional borderValue As MCvScalar = Nothing
)
public:
CudaLaplacianFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    int ksize = 1,
    double scale = 1,
    BorderType^ borderType = 4,
    MCvScalar^ borderValue = nullptr
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        ?ksize : int *
        ?scale : float *
        ?borderType : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _ksize = defaultArg ksize 1
        let _scale = defaultArg scale 1
        let _borderType = defaultArg borderType 4
        let _borderValue = defaultArg borderValue null
*)
-> CudaLaplacianFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the source image
srcChannels
Type: SystemInt32
The number of channels in the source image
dstDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the destination image
dstChannels
Type: SystemInt32
The number of channels in the destination image
ksize (Optional)
Type: SystemInt32
Either 1 or 3
scale (Optional)
Type: SystemDouble
Optional scale. Use 1.0 for default
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The border type.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The border value.
See Also

Reference

CudaLaplacianFilter Class
Emgu.CV.Cuda Namespace


CudaLaplacianFilter Properties

The CudaLaplacianFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaLaplacianFilter Class
Emgu.CV.Cuda Namespace


CudaLaplacianFilter Methods

The CudaLaplacianFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaLaplacianFilter Class
Emgu.CV.Cuda Namespace


CudaLaplacianFilter Fields

The CudaLaplacianFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaLaplacianFilter Class
Emgu.CV.Cuda Namespace


CudaLinearFilter Class

Applies arbitrary linear filter to the image. In-place operation is supported. When the aperture is partially outside the image, the function interpolates outlier pixel values from the nearest pixels that is inside the image
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaLinearFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaLinearFilter : CudaFilter
Public Class CudaLinearFilter
    Inherits CudaFilter
public ref class CudaLinearFilter : public CudaFilter
type CudaLinearFilter =
    class
        inherit CudaFilter
    end

The CudaLinearFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaLinearFilter | Create a Gpu LinearFilter
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaLinearFilter Constructor

Create a Gpu LinearFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaLinearFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    IInputArray kernel,
    Point anchor,
    BorderType borderType = 4,
    MCvScalar borderValue = null
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    kernel As IInputArray,
    anchor As Point,
    Optional borderType As BorderType = 4,
    Optional borderValue As MCvScalar = Nothing
)
public:
CudaLinearFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    IInputArray^ kernel,
    Point^ anchor,
    BorderType^ borderType = 4,
    MCvScalar^ borderValue = nullptr
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        kernel : IInputArray *
        anchor : Point *
        ?borderType : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _borderType = defaultArg borderType 4
        let _borderValue = defaultArg borderValue null
*)
-> CudaLinearFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the source image
srcChannels
Type: SystemInt32
The number of channels in the source image
dstDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the dest image
dstChannels
Type: SystemInt32
The number of channels in the dest image
kernel
Type: Emgu.CVIInputArray
Convolution kernel, single-channel floating point matrix (e.g. Emgu.CV.Matrix). If you want to apply different kernels to different channels, split the gpu image into separate color planes and process them individually
anchor
Type: System.DrawingPoint
The anchor of the kernel that indicates the relative position of a filtered point within the kernel. The anchor shoud lie within the kernel. The special default value (-1,-1) means that it is at the kernel center
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border type. Use REFLECT101 as default.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
The border value
See Also

Reference

CudaLinearFilter Class
Emgu.CV.Cuda Namespace


CudaLinearFilter Properties

The CudaLinearFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaLinearFilter Class
Emgu.CV.Cuda Namespace


CudaLinearFilter Methods

The CudaLinearFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaLinearFilter Class
Emgu.CV.Cuda Namespace


CudaLinearFilter Fields

The CudaLinearFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaLinearFilter Class
Emgu.CV.Cuda Namespace


CudaLookUpTable Class

Gpu look up table
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaLookUpTable

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaLookUpTable : SharedPtrObject
Public Class CudaLookUpTable
    Inherits SharedPtrObject
public ref class CudaLookUpTable : public SharedPtrObject
type CudaLookUpTable =
    class
        inherit SharedPtrObject
    end

The CudaLookUpTable type exposes the following members.

Constructors
 | Name | Description
Public method | CudaLookUpTable | Create the look up table
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this look up table (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Transform the image using the lookup table
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaLookUpTable Constructor

Create the look up table

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaLookUpTable(
    IInputArray lookUpTable
)
Public Sub New (
    lookUpTable As IInputArray
)
public:
CudaLookUpTable(
    IInputArray^ lookUpTable
)
new :
        lookUpTable : IInputArray -> CudaLookUpTable

Parameters

lookUpTable
Type: Emgu.CVIInputArray
It should be either 1 or 3 channel matrix of 1x256
See Also

Reference

CudaLookUpTable Class
Emgu.CV.Cuda Namespace


CudaLookUpTable Properties

The CudaLookUpTable type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaLookUpTable Class
Emgu.CV.Cuda Namespace


CudaLookUpTable Methods

The CudaLookUpTable type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this look up table (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Transform the image using the lookup table
Top
See Also

Reference

CudaLookUpTable Class
Emgu.CV.Cuda Namespace


CudaLookUpTable.DisposeObject Method

CudaLookUpTableDisposeObject Method

Release all the unmanaged memory associated with this look up table

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaLookUpTable Class
Emgu.CV.Cuda Namespace


CudaLookUpTable.Transform Method

CudaLookUpTableTransform Method

Transform the image using the lookup table

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Transform(
    IInputArray image,
    IOutputArray dst,
    Stream stream = null
)
Public Sub Transform (
    image As IInputArray,
    dst As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Transform(
    IInputArray^ image,
    IOutputArray^ dst,
    Stream^ stream = nullptr
)
member Transform :
        image : IInputArray *
        dst : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The image to be transformed
dst
Type: Emgu.CVIOutputArray
The transformation result
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaLookUpTable Class
Emgu.CV.Cuda Namespace


CudaLookUpTable Fields

The CudaLookUpTable type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaLookUpTable Class
Emgu.CV.Cuda Namespace


CudaMinEigenValCorner Class

Implementation for the minimum eigen value of a 2x2 derivative covariation matrix (the cornerness criteria).
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaCornernessCriteria
Emgu.CV.CudaCudaMinEigenValCorner

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaMinEigenValCorner : CudaCornernessCriteria
Public Class CudaMinEigenValCorner
    Inherits CudaCornernessCriteria
public ref class CudaMinEigenValCorner : public CudaCornernessCriteria
type CudaMinEigenValCorner =
    class
        inherit CudaCornernessCriteria
    end

The CudaMinEigenValCorner type exposes the following members.

Constructors
 | Name | Description
Public method | CudaMinEigenValCorner | Creates implementation for the minimum eigen value of a 2x2 derivative covariation matrix (the cornerness criteria).
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaCornernessCriteria.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaCornernessCriteria.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaMinEigenValCorner Constructor

Creates implementation for the minimum eigen value of a 2x2 derivative covariation matrix (the cornerness criteria).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaMinEigenValCorner(
    DepthType srcDepth,
    int srcChannels,
    int blockSize,
    int kSize,
    BorderType borderType = 4
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    blockSize As Integer,
    kSize As Integer,
    Optional borderType As BorderType = 4
)
public:
CudaMinEigenValCorner(
    DepthType^ srcDepth,
    int srcChannels,
    int blockSize,
    int kSize,
    BorderType^ borderType = 4
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        blockSize : int *
        kSize : int *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> CudaMinEigenValCorner

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
Input source depth. Only 8U and 32F are supported for now.
srcChannels
Type: SystemInt32
Input source type. Only single channel are supported for now.
blockSize
Type: SystemInt32
Neighborhood size.
kSize
Type: SystemInt32
Aperture parameter for the Sobel operator.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method. Only BORDER_REFLECT101 and BORDER_REPLICATE are supported for now.
See Also

Reference

CudaMinEigenValCorner Class
Emgu.CV.Cuda Namespace


CudaMinEigenValCorner Properties

The CudaMinEigenValCorner type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaMinEigenValCorner Class
Emgu.CV.Cuda Namespace


CudaMinEigenValCorner Methods

The CudaMinEigenValCorner type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaCornernessCriteria.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaCornernessCriteria.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaMinEigenValCorner Class
Emgu.CV.Cuda Namespace


CudaMinEigenValCorner Fields

The CudaMinEigenValCorner type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaMinEigenValCorner Class
Emgu.CV.Cuda Namespace


CudaMorphologyFilter Class

Morphology filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaMorphologyFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaMorphologyFilter : CudaFilter
Public Class CudaMorphologyFilter
    Inherits CudaFilter
public ref class CudaMorphologyFilter : public CudaFilter
type CudaMorphologyFilter =
    class
        inherit CudaFilter
    end

The CudaMorphologyFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaMorphologyFilter | Create a Morphology filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaMorphologyFilter Constructor

Create a Morphology filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaMorphologyFilter(
    MorphOp op,
    DepthType srcDepth,
    int srcChannels,
    IInputArray kernel,
    Point anchor,
    int iterations
)
Public Sub New (
    op As MorphOp,
    srcDepth As DepthType,
    srcChannels As Integer,
    kernel As IInputArray,
    anchor As Point,
    iterations As Integer
)
public:
CudaMorphologyFilter(
    MorphOp^ op,
    DepthType^ srcDepth,
    int srcChannels,
    IInputArray^ kernel,
    Point^ anchor,
    int iterations
)
new :
        op : MorphOp *
        srcDepth : DepthType *
        srcChannels : int *
        kernel : IInputArray *
        anchor : Point *
        iterations : int -> CudaMorphologyFilter

Parameters

op
Type: Emgu.CV.CvEnumMorphOp
Type of morphological operation
srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth type of the source image
srcChannels
Type: SystemInt32
The number of channels in the source image
kernel
Type: Emgu.CVIInputArray
2D 8-bit structuring element for the morphological operation.
anchor
Type: System.DrawingPoint
Anchor position within the structuring element. Negative values mean that the anchor is at the center.
iterations
Type: SystemInt32
Number of times erosion and dilation to be applied.
See Also

Reference

CudaMorphologyFilter Class
Emgu.CV.Cuda Namespace


CudaMorphologyFilter Properties

The CudaMorphologyFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaMorphologyFilter Class
Emgu.CV.Cuda Namespace


CudaMorphologyFilter Methods

The CudaMorphologyFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaMorphologyFilter Class
Emgu.CV.Cuda Namespace


CudaMorphologyFilter Fields

The CudaMorphologyFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaMorphologyFilter Class
Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1 Class

DualTvl1 optical flow
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaOpticalFlowDualTvl1

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaOpticalFlowDualTvl1 : SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
Public Class CudaOpticalFlowDualTvl1
    Inherits SharedPtrObject
    Implements ICudaDenseOpticalFlow, IAlgorithm
public ref class CudaOpticalFlowDualTvl1 : public SharedPtrObject,
    ICudaDenseOpticalFlow, IAlgorithm
type CudaOpticalFlowDualTvl1 =
    class
        inherit SharedPtrObject
        interface ICudaDenseOpticalFlow
        interface IAlgorithm
    end

The CudaOpticalFlowDualTvl1 type exposes the following members.

Constructors
 | Name | Description
Public method | CudaOpticalFlowDualTvl1 | Initializes a new instance of the CudaOpticalFlowDualTvl1 class.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1 Constructor

Initializes a new instance of the CudaOpticalFlowDualTvl1 class.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaOpticalFlowDualTvl1(
    double tau = 0.25,
    double lambda = 0.15,
    double theta = 0.3,
    int nscales = 5,
    int warps = 5,
    double epsilon = 0.01,
    int iterations = 300,
    double scaleStep = 0.8,
    double gamma = 0,
    bool useInitialFlow = false
)
Public Sub New (
    Optional tau As Double = 0.25,
    Optional lambda As Double = 0.15,
    Optional theta As Double = 0.3,
    Optional nscales As Integer = 5,
    Optional warps As Integer = 5,
    Optional epsilon As Double = 0.01,
    Optional iterations As Integer = 300,
    Optional scaleStep As Double = 0.8,
    Optional gamma As Double = 0,
    Optional useInitialFlow As Boolean = false
)
public:
CudaOpticalFlowDualTvl1(
    double tau = 0.25,
    double lambda = 0.15,
    double theta = 0.3,
    int nscales = 5,
    int warps = 5,
    double epsilon = 0.01,
    int iterations = 300,
    double scaleStep = 0.8,
    double gamma = 0,
    bool useInitialFlow = false
)
new :
        ?tau : float *
        ?lambda : float *
        ?theta : float *
        ?nscales : int *
        ?warps : int *
        ?epsilon : float *
        ?iterations : int *
        ?scaleStep : float *
        ?gamma : float *
        ?useInitialFlow : bool
(* Defaults:
        let _tau = defaultArg tau 0.25
        let _lambda = defaultArg lambda 0.15
        let _theta = defaultArg theta 0.3
        let _nscales = defaultArg nscales 5
        let _warps = defaultArg warps 5
        let _epsilon = defaultArg epsilon 0.01
        let _iterations = defaultArg iterations 300
        let _scaleStep = defaultArg scaleStep 0.8
        let _gamma = defaultArg gamma 0
        let _useInitialFlow = defaultArg useInitialFlow false
*)
-> CudaOpticalFlowDualTvl1

Parameters

tau (Optional)
Type: SystemDouble
Time step of the numerical scheme.
lambda (Optional)
Type: SystemDouble
Weight parameter for the data term, attachment parameter. This is the most relevant parameter, which determines the smoothness of the output. The smaller this parameter is, the smoother the solutions we obtain. It depends on the range of motions of the images, so its value should be adapted to each image sequence.
theta (Optional)
Type: SystemDouble
Parameter used for motion estimation. It adds a variable allowing for illumination variations Set this parameter to 1. if you have varying illumination.
nscales (Optional)
Type: SystemInt32
Number of scales used to create the pyramid of images.
warps (Optional)
Type: SystemInt32
Number of warpings per scale. Represents the number of times that I1(x+u0) and grad( I1(x+u0) ) are computed per scale. This is a parameter that assures the stability of the method. It also affects the running time, so it is a compromise between speed and accuracy.
epsilon (Optional)
Type: SystemDouble
Stopping criterion threshold used in the numerical scheme, which is a trade-off between precision and running time. A small value will yield more accurate solutions at the expense of a slower convergence.
iterations (Optional)
Type: SystemInt32
Stopping criterion iterations number used in the numerical scheme.
scaleStep (Optional)
Type: SystemDouble
Scale step
gamma (Optional)
Type: SystemDouble
Weight parameter for (u - v)^2, tightness parameter. It serves as a link between the attachment and the regularization terms. In theory, it should have a small value in order to maintain both parts in correspondence. The method is stable for a large range of values of this parameter.
useInitialFlow (Optional)
Type: SystemBoolean
If true, use initial flow.
See Also

Reference

CudaOpticalFlowDualTvl1 Class
Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1 Properties

The CudaOpticalFlowDualTvl1 type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the algorithm object
Public property | DenseOpticalFlowPtr | Pointer to the DenseOpticalFlow object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaOpticalFlowDualTvl1 Class
Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1.AlgorithmPtr Property

CudaOpticalFlowDualTvl1AlgorithmPtr Property

Pointer to the algorithm object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

CudaOpticalFlowDualTvl1 Class
Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1.DenseOpticalFlowPtr Property

CudaOpticalFlowDualTvl1DenseOpticalFlowPtr Property

Pointer to the DenseOpticalFlow object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DenseOpticalFlowPtr { get; }
Public ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr DenseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract DenseOpticalFlowPtr : IntPtr with get
override DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ICudaDenseOpticalFlowDenseOpticalFlowPtr
See Also

Reference

CudaOpticalFlowDualTvl1 Class
Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1 Methods

The CudaOpticalFlowDualTvl1 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

CudaOpticalFlowDualTvl1 Class
Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1.DisposeObject Method

CudaOpticalFlowDualTvl1DisposeObject Method

Release all the unmanaged memory associated with this optical flow solver.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaOpticalFlowDualTvl1 Class
Emgu.CV.Cuda Namespace


CudaOpticalFlowDualTvl1 Fields

The CudaOpticalFlowDualTvl1 type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaOpticalFlowDualTvl1 Class
Emgu.CV.Cuda Namespace


CudaORBDetector Class

An ORB detector using Cuda
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DORBDetector
Emgu.CV.CudaCudaORBDetector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaORBDetector : ORBDetector,
    IFeature2DAsync
Public Class CudaORBDetector
    Inherits ORBDetector
    Implements IFeature2DAsync
public ref class CudaORBDetector : public ORBDetector,
    IFeature2DAsync
type CudaORBDetector =
    class
        inherit ORBDetector
        interface IFeature2DAsync
    end

The CudaORBDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CudaORBDetector | Create a ORBDetector using the specific values
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associate to the Detector (Overrides ORBDetectorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ComputeAsync | Compute the descriptors on the image from the given keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | Convert | Converts keypoints array from internal representation to standard vector. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAsync | Detect the features in the image (Defined by Feature2DAsyncExtension.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaORBDetector Constructor

Create a ORBDetector using the specific values

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaORBDetector(
    int numberOfFeatures = 500,
    float scaleFactor = 1.2f,
    int nLevels = 8,
    int edgeThreshold = 31,
    int firstLevel = 0,
    int WTK_A = 2,
    ORBDetectorScoreType scoreType = 0,
    int patchSize = 31,
    int fastThreshold = 20,
    bool blurForDescriptor = false
)
Public Sub New (
    Optional numberOfFeatures As Integer = 500,
    Optional scaleFactor As Single = 1.2F,
    Optional nLevels As Integer = 8,
    Optional edgeThreshold As Integer = 31,
    Optional firstLevel As Integer = 0,
    Optional WTK_A As Integer = 2,
    Optional scoreType As ORBDetectorScoreType = 0,
    Optional patchSize As Integer = 31,
    Optional fastThreshold As Integer = 20,
    Optional blurForDescriptor As Boolean = false
)
public:
CudaORBDetector(
    int numberOfFeatures = 500,
    float scaleFactor = 1.2f,
    int nLevels = 8,
    int edgeThreshold = 31,
    int firstLevel = 0,
    int WTK_A = 2,
    ORBDetectorScoreType^ scoreType = 0,
    int patchSize = 31,
    int fastThreshold = 20,
    bool blurForDescriptor = false
)
new :
        ?numberOfFeatures : int *
        ?scaleFactor : float32 *
        ?nLevels : int *
        ?edgeThreshold : int *
        ?firstLevel : int *
        ?WTK_A : int *
        ?scoreType : ORBDetectorScoreType *
        ?patchSize : int *
        ?fastThreshold : int *
        ?blurForDescriptor : bool
(* Defaults:
        let _numberOfFeatures = defaultArg numberOfFeatures 500
        let _scaleFactor = defaultArg scaleFactor 1.2f
        let _nLevels = defaultArg nLevels 8
        let _edgeThreshold = defaultArg edgeThreshold 31
        let _firstLevel = defaultArg firstLevel 0
        let _WTK_A = defaultArg WTK_A 2
        let _scoreType = defaultArg scoreType 0
        let _patchSize = defaultArg patchSize 31
        let _fastThreshold = defaultArg fastThreshold 20
        let _blurForDescriptor = defaultArg blurForDescriptor false
*)
-> CudaORBDetector

Parameters

numberOfFeatures (Optional)
Type: SystemInt32
The number of desired features.
scaleFactor (Optional)
Type: SystemSingle
Coefficient by which we divide the dimensions from one scale pyramid level to the next.
nLevels (Optional)
Type: SystemInt32
The number of levels in the scale pyramid.
edgeThreshold (Optional)
Type: SystemInt32
How far from the boundary the points should be.
firstLevel (Optional)
Type: SystemInt32
The level at which the image is given. If 1, that means we will also look at the image.scaleFactor times bigger
WTK_A (Optional)
Type: SystemInt32
How many random points are used to produce each cell of the descriptor (2, 3, 4 ...).
scoreType (Optional)
Type: Emgu.CV.Features2DORBDetectorScoreType
Type of the score to use.
patchSize (Optional)
Type: SystemInt32
Patch size.
fastThreshold (Optional)
Type: SystemInt32
Fast threshold
blurForDescriptor (Optional)
Type: SystemBoolean
Blur for descriptor
See Also

Reference

CudaORBDetector Class
Emgu.CV.Cuda Namespace


CudaORBDetector Properties

The CudaORBDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaORBDetector Class
Emgu.CV.Cuda Namespace


CudaORBDetector Methods

The CudaORBDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associate to the Detector (Overrides ORBDetectorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ComputeAsync | Compute the descriptors on the image from the given keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | Convert | Converts keypoints array from internal representation to standard vector. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAsync | Detect the features in the image (Defined by Feature2DAsyncExtension.)
Top
See Also

Reference

CudaORBDetector Class
Emgu.CV.Cuda Namespace


CudaORBDetector.DisposeObject Method

CudaORBDetectorDisposeObject Method

Release the unmanaged resource associate to the Detector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaORBDetector Class
Emgu.CV.Cuda Namespace


CudaORBDetector Fields

The CudaORBDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaORBDetector Class
Emgu.CV.Cuda Namespace


CudaSobelFilter Class

Sobel filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaSobelFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaSobelFilter : CudaFilter
Public Class CudaSobelFilter
    Inherits CudaFilter
public ref class CudaSobelFilter : public CudaFilter
type CudaSobelFilter =
    class
        inherit CudaFilter
    end

The CudaSobelFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaSobelFilter | Create a Sobel filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaSobelFilter Constructor

Create a Sobel filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaSobelFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    int dx,
    int dy,
    int ksize = 3,
    double scale = 1,
    BorderType rowBorderType = 4,
    BorderType columnBorderType = -1
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    dx As Integer,
    dy As Integer,
    Optional ksize As Integer = 3,
    Optional scale As Double = 1,
    Optional rowBorderType As BorderType = 4,
    Optional columnBorderType As BorderType = -1
)
public:
CudaSobelFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    int dx,
    int dy,
    int ksize = 3,
    double scale = 1,
    BorderType^ rowBorderType = 4,
    BorderType^ columnBorderType = -1
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        dx : int *
        dy : int *
        ?ksize : int *
        ?scale : float *
        ?rowBorderType : BorderType *
        ?columnBorderType : BorderType
(* Defaults:
        let _ksize = defaultArg ksize 3
        let _scale = defaultArg scale 1
        let _rowBorderType = defaultArg rowBorderType 4
        let _columnBorderType = defaultArg columnBorderType -1
*)
-> CudaSobelFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
The depth of the source image
srcChannels
Type: SystemInt32
The number of channels of the source image
dstDepth
Type: Emgu.CV.CvEnumDepthType
The depth of the destination image
dstChannels
Type: SystemInt32
The number of channels of the the destination image
dx
Type: SystemInt32
Order of the derivative x
dy
Type: SystemInt32
Order of the derivative y
ksize (Optional)
Type: SystemInt32
Size of the extended Sobel kernel
scale (Optional)
Type: SystemDouble
Optional scale, use 1 for default.
rowBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The row border type.
columnBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
The column border type.
See Also

Reference

CudaSobelFilter Class
Emgu.CV.Cuda Namespace


CudaSobelFilter Properties

The CudaSobelFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaSobelFilter Class
Emgu.CV.Cuda Namespace


CudaSobelFilter Methods

The CudaSobelFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaSobelFilter Class
Emgu.CV.Cuda Namespace


CudaSobelFilter Fields

The CudaSobelFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaSobelFilter Class
Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow Class

Sparse PyrLK optical flow
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaSparsePyrLKOpticalFlow

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaSparsePyrLKOpticalFlow : SharedPtrObject,
    ICudaSparseOpticalFlow, IAlgorithm
Public Class CudaSparsePyrLKOpticalFlow
    Inherits SharedPtrObject
    Implements ICudaSparseOpticalFlow, IAlgorithm
public ref class CudaSparsePyrLKOpticalFlow : public SharedPtrObject,
    ICudaSparseOpticalFlow, IAlgorithm
type CudaSparsePyrLKOpticalFlow =
    class
        inherit SharedPtrObject
        interface ICudaSparseOpticalFlow
        interface IAlgorithm
    end

The CudaSparsePyrLKOpticalFlow type exposes the following members.

Constructors
 | Name | Description
Public method | CudaSparsePyrLKOpticalFlow | Create the PyrLK optical flow solver
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | SparseOpticalFlowPtr | Pointer to the unmanaged SparseOpticalFlow object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow Constructor

Create the PyrLK optical flow solver

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaSparsePyrLKOpticalFlow(
    Size winSize,
    int maxLevel = 3,
    int iters = 30,
    bool useInitialFlow = false
)
Public Sub New (
    winSize As Size,
    Optional maxLevel As Integer = 3,
    Optional iters As Integer = 30,
    Optional useInitialFlow As Boolean = false
)
public:
CudaSparsePyrLKOpticalFlow(
    Size^ winSize,
    int maxLevel = 3,
    int iters = 30,
    bool useInitialFlow = false
)
new :
        winSize : Size *
        ?maxLevel : int *
        ?iters : int *
        ?useInitialFlow : bool
(* Defaults:
        let _maxLevel = defaultArg maxLevel 3
        let _iters = defaultArg iters 30
        let _useInitialFlow = defaultArg useInitialFlow false
*)
-> CudaSparsePyrLKOpticalFlow

Parameters

winSize
Type: System.DrawingSize
Windows size. Use 21x21 for default
maxLevel (Optional)
Type: SystemInt32
The maximum number of pyramid levels.
iters (Optional)
Type: SystemInt32
The number of iterations.
useInitialFlow (Optional)
Type: SystemBoolean
Weather or not use the initial flow in the input matrix.
See Also

Reference

CudaSparsePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow Properties

The CudaSparsePyrLKOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | SparseOpticalFlowPtr | Pointer to the unmanaged SparseOpticalFlow object
Top
See Also

Reference

CudaSparsePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow.AlgorithmPtr Property

CudaSparsePyrLKOpticalFlowAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

CudaSparsePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow.SparseOpticalFlowPtr Property

CudaSparsePyrLKOpticalFlowSparseOpticalFlowPtr Property

Pointer to the unmanaged SparseOpticalFlow object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SparseOpticalFlowPtr { get; }
Public ReadOnly Property SparseOpticalFlowPtr As IntPtr
    Get
public:
virtual property IntPtr SparseOpticalFlowPtr {
    IntPtr get () sealed;
}
abstract SparseOpticalFlowPtr : IntPtr with get
override SparseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ICudaSparseOpticalFlowSparseOpticalFlowPtr
See Also

Reference

CudaSparsePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow Methods

The CudaSparsePyrLKOpticalFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this optical flow solver. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

CudaSparsePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow.DisposeObject Method

CudaSparsePyrLKOpticalFlowDisposeObject Method

Release all the unmanaged memory associated with this optical flow solver.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaSparsePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaSparsePyrLKOpticalFlow Fields

The CudaSparsePyrLKOpticalFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaSparsePyrLKOpticalFlow Class
Emgu.CV.Cuda Namespace


CudaStereoBM Class

Use Block Matching algorithm to find stereo correspondence
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaStereoBM

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaStereoBM : SharedPtrObject
Public Class CudaStereoBM
    Inherits SharedPtrObject
public ref class CudaStereoBM : public SharedPtrObject
type CudaStereoBM =
    class
        inherit SharedPtrObject
    end

The CudaStereoBM type exposes the following members.

Constructors
 | Name | Description
Public method | CudaStereoBM | Create a stereoBM
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the stereo state and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindStereoCorrespondence | Computes disparity map for the input rectified stereo pair.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaStereoBM Constructor

Create a stereoBM

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaStereoBM(
    int numberOfDisparities = 64,
    int blockSize = 19
)
Public Sub New (
    Optional numberOfDisparities As Integer = 64,
    Optional blockSize As Integer = 19
)
public:
CudaStereoBM(
    int numberOfDisparities = 64,
    int blockSize = 19
)
new :
        ?numberOfDisparities : int *
        ?blockSize : int
(* Defaults:
        let _numberOfDisparities = defaultArg numberOfDisparities 64
        let _blockSize = defaultArg blockSize 19
*)
-> CudaStereoBM

Parameters

numberOfDisparities (Optional)
Type: SystemInt32
The number of disparities. Must be multiple of 8. Use 64 for default
blockSize (Optional)
Type: SystemInt32
The SAD window size. Use 19 for default
See Also

Reference

CudaStereoBM Class
Emgu.CV.Cuda Namespace


CudaStereoBM Properties

The CudaStereoBM type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaStereoBM Class
Emgu.CV.Cuda Namespace


CudaStereoBM Methods

The CudaStereoBM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the stereo state and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindStereoCorrespondence | Computes disparity map for the input rectified stereo pair.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaStereoBM Class
Emgu.CV.Cuda Namespace


CudaStereoBM.DisposeObject Method

CudaStereoBMDisposeObject Method

Release the stereo state and all the memory associate with it

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaStereoBM Class
Emgu.CV.Cuda Namespace


CudaStereoBM.FindStereoCorrespondence Method

CudaStereoBMFindStereoCorrespondence Method

Computes disparity map for the input rectified stereo pair.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FindStereoCorrespondence(
    IInputArray left,
    IInputArray right,
    IOutputArray disparity,
    Stream stream = null
)
Public Sub FindStereoCorrespondence (
    left As IInputArray,
    right As IInputArray,
    disparity As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void FindStereoCorrespondence(
    IInputArray^ left,
    IInputArray^ right,
    IOutputArray^ disparity,
    Stream^ stream = nullptr
)
member FindStereoCorrespondence :
        left : IInputArray *
        right : IInputArray *
        disparity : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

left
Type: Emgu.CVIInputArray
The left single-channel, 8-bit image
right
Type: Emgu.CVIInputArray
The right image of the same size and the same type
disparity
Type: Emgu.CVIOutputArray
The disparity map
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaStereoBM Class
Emgu.CV.Cuda Namespace


CudaStereoBM Fields

The CudaStereoBM type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaStereoBM Class
Emgu.CV.Cuda Namespace


CudaStereoConstantSpaceBP Class

A Constant-Space Belief Propagation Algorithm for Stereo Matching. Qingxiong Yang, Liang Wang, Narendra Ahuja. http://vision.ai.uiuc.edu/~qyang6/
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaStereoConstantSpaceBP

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaStereoConstantSpaceBP : SharedPtrObject
Public Class CudaStereoConstantSpaceBP
    Inherits SharedPtrObject
public ref class CudaStereoConstantSpaceBP : public SharedPtrObject
type CudaStereoConstantSpaceBP =
    class
        inherit SharedPtrObject
    end

The CudaStereoConstantSpaceBP type exposes the following members.

Constructors
 | Name | Description
Public method | CudaStereoConstantSpaceBP | A Constant-Space Belief Propagation Algorithm for Stereo Matching
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindStereoCorrespondence | Computes disparity map for the input rectified stereo pair.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaStereoConstantSpaceBP Constructor

A Constant-Space Belief Propagation Algorithm for Stereo Matching

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaStereoConstantSpaceBP(
    int ndisp = 128,
    int iters = 8,
    int levels = 4,
    int nrPlane = 4
)
Public Sub New (
    Optional ndisp As Integer = 128,
    Optional iters As Integer = 8,
    Optional levels As Integer = 4,
    Optional nrPlane As Integer = 4
)
public:
CudaStereoConstantSpaceBP(
    int ndisp = 128,
    int iters = 8,
    int levels = 4,
    int nrPlane = 4
)
new :
        ?ndisp : int *
        ?iters : int *
        ?levels : int *
        ?nrPlane : int
(* Defaults:
        let _ndisp = defaultArg ndisp 128
        let _iters = defaultArg iters 8
        let _levels = defaultArg levels 4
        let _nrPlane = defaultArg nrPlane 4
*)
-> CudaStereoConstantSpaceBP

Parameters

ndisp (Optional)
Type: SystemInt32
The number of disparities. Use 128 as default
iters (Optional)
Type: SystemInt32
The number of BP iterations on each level. Use 8 as default.
levels (Optional)
Type: SystemInt32
The number of levels. Use 4 as default
nrPlane (Optional)
Type: SystemInt32
The number of active disparity on the first level. Use 4 as default.
See Also

Reference

CudaStereoConstantSpaceBP Class
Emgu.CV.Cuda Namespace


CudaStereoConstantSpaceBP Properties

The CudaStereoConstantSpaceBP type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaStereoConstantSpaceBP Class
Emgu.CV.Cuda Namespace


CudaStereoConstantSpaceBP Methods

The CudaStereoConstantSpaceBP type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindStereoCorrespondence | Computes disparity map for the input rectified stereo pair.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaStereoConstantSpaceBP Class
Emgu.CV.Cuda Namespace


CudaStereoConstantSpaceBP.DisposeObject Method

CudaStereoConstantSpaceBPDisposeObject Method

Release the unmanaged memory

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaStereoConstantSpaceBP Class
Emgu.CV.Cuda Namespace


CudaStereoConstantSpaceBP.FindStereoCorrespondence Method

CudaStereoConstantSpaceBPFindStereoCorrespondence Method

Computes disparity map for the input rectified stereo pair.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FindStereoCorrespondence(
    IInputArray left,
    IInputArray right,
    IOutputArray disparity,
    Stream stream = null
)
Public Sub FindStereoCorrespondence (
    left As IInputArray,
    right As IInputArray,
    disparity As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void FindStereoCorrespondence(
    IInputArray^ left,
    IInputArray^ right,
    IOutputArray^ disparity,
    Stream^ stream = nullptr
)
member FindStereoCorrespondence :
        left : IInputArray *
        right : IInputArray *
        disparity : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

left
Type: Emgu.CVIInputArray
The left single-channel, 8-bit image
right
Type: Emgu.CVIInputArray
The right image of the same size and the same type
disparity
Type: Emgu.CVIOutputArray
The disparity map
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaStereoConstantSpaceBP Class
Emgu.CV.Cuda Namespace


CudaStereoConstantSpaceBP Fields

The CudaStereoConstantSpaceBP type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaStereoConstantSpaceBP Class
Emgu.CV.Cuda Namespace


CudaTemplateMatching Class

Cuda template matching filter.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaTemplateMatching

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaTemplateMatching : SharedPtrObject
Public Class CudaTemplateMatching
    Inherits SharedPtrObject
public ref class CudaTemplateMatching : public SharedPtrObject
type CudaTemplateMatching =
    class
        inherit SharedPtrObject
    end

The CudaTemplateMatching type exposes the following members.

Constructors
 | Name | Description
Public method | CudaTemplateMatching | Create a Cuda template matching filter
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the buffer (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match | This function is similiar to cvCalcBackProjectPatch. It slids through image, compares overlapped patches of size wxh with templ using the specified method and stores the comparison results to result
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaTemplateMatching Constructor

Create a Cuda template matching filter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaTemplateMatching(
    DepthType depthType,
    int channels,
    TemplateMatchingType method,
    Size blockSize = null
)
Public Sub New (
    depthType As DepthType,
    channels As Integer,
    method As TemplateMatchingType,
    Optional blockSize As Size = Nothing
)
public:
CudaTemplateMatching(
    DepthType^ depthType,
    int channels,
    TemplateMatchingType^ method,
    Size^ blockSize = nullptr
)
new :
        depthType : DepthType *
        channels : int *
        method : TemplateMatchingType *
        ?blockSize : Size
(* Defaults:
        let _blockSize = defaultArg blockSize null
*)
-> CudaTemplateMatching

Parameters

depthType
Type: Emgu.CV.CvEnumDepthType
The depth type of the image that will be used in the template matching
channels
Type: SystemInt32
The number of channels of the image that will be used in the template matching
method
Type: Emgu.CV.CvEnumTemplateMatchingType
Specifies the way the template must be compared with image regions
blockSize (Optional)
Type: System.DrawingSize
The block size
See Also

Reference

CudaTemplateMatching Class
Emgu.CV.Cuda Namespace


CudaTemplateMatching Properties

The CudaTemplateMatching type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaTemplateMatching Class
Emgu.CV.Cuda Namespace


CudaTemplateMatching Methods

The CudaTemplateMatching type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the buffer (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match | This function is similiar to cvCalcBackProjectPatch. It slids through image, compares overlapped patches of size wxh with templ using the specified method and stores the comparison results to result
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaTemplateMatching Class
Emgu.CV.Cuda Namespace


CudaTemplateMatching.DisposeObject Method

CudaTemplateMatchingDisposeObject Method

Release the buffer

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaTemplateMatching Class
Emgu.CV.Cuda Namespace


CudaTemplateMatching.Match Method

CudaTemplateMatchingMatch Method

This function is similiar to cvCalcBackProjectPatch. It slids through image, compares overlapped patches of size wxh with templ using the specified method and stores the comparison results to result

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Match(
    IInputArray image,
    IInputArray templ,
    IOutputArray result,
    Stream stream = null
)
Public Sub Match (
    image As IInputArray,
    templ As IInputArray,
    result As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Match(
    IInputArray^ image,
    IInputArray^ templ,
    IOutputArray^ result,
    Stream^ stream = nullptr
)
member Match :
        image : IInputArray *
        templ : IInputArray *
        result : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Image where the search is running. It should be 8-bit or 32-bit floating-point
templ
Type: Emgu.CVIInputArray
Searched template; must be not greater than the source image and the same data type as the image
result
Type: Emgu.CVIOutputArray
A map of comparison results; single-channel 32-bit floating-point. If image is WxH and templ is wxh then result must be W-w+1xH-h+1.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

CudaTemplateMatching Class
Emgu.CV.Cuda Namespace


CudaTemplateMatching Fields

The CudaTemplateMatching type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaTemplateMatching Class
Emgu.CV.Cuda Namespace


CudaVideoReader Class

[Missing <summary> documentation for "T:Emgu.CV.Cuda.CudaVideoReader"]

Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaVideoReader

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaVideoReader : SharedPtrObject
Public Class CudaVideoReader
    Inherits SharedPtrObject
public ref class CudaVideoReader : public SharedPtrObject
type CudaVideoReader =
    class
        inherit SharedPtrObject
    end

The CudaVideoReader type exposes the following members.

Constructors
 | Name | Description
Public method | CudaVideoReader | Initializes a new instance of the CudaVideoReader class
Top
Properties
 | Name | Description
Public property | Format |
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame |
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaVideoReader Constructor

Initializes a new instance of the CudaVideoReader class

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaVideoReader(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
CudaVideoReader(
    String^ fileName
)
new :
        fileName : string -> CudaVideoReader

Parameters

fileName
Type: SystemString

[Missing <param name="fileName"/> documentation for "M:Emgu.CV.Cuda.CudaVideoReader.#ctor(System.String)"]

See Also

Reference

CudaVideoReader Class
Emgu.CV.Cuda Namespace


CudaVideoReader Properties

The CudaVideoReader type exposes the following members.

Properties
 | Name | Description
Public property | Format |
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaVideoReader Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Format Property

CudaVideoReaderFormat Property

[Missing <summary> documentation for "P:Emgu.CV.Cuda.CudaVideoReader.Format"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaVideoReaderFormatInfo Format { get; }
Public ReadOnly Property Format As CudaVideoReaderFormatInfo
    Get
public:
property CudaVideoReaderFormatInfo^ Format {
    CudaVideoReaderFormatInfo^ get ();
}
member Format : CudaVideoReaderFormatInfo with get

Property Value

Type: CudaVideoReaderFormatInfo
See Also

Reference

CudaVideoReader Class
Emgu.CV.Cuda Namespace


CudaVideoReader Methods

The CudaVideoReader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame |
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CudaVideoReader Class
Emgu.CV.Cuda Namespace


CudaVideoReader.DisposeObject Method

CudaVideoReaderDisposeObject Method

[Missing <summary> documentation for "M:Emgu.CV.Cuda.CudaVideoReader.DisposeObject"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaVideoReader Class
Emgu.CV.Cuda Namespace


CudaVideoReader.NextFrame Method

CudaVideoReaderNextFrame Method

[Missing <summary> documentation for "M:Emgu.CV.Cuda.CudaVideoReader.NextFrame(Emgu.CV.Cuda.GpuMat,Emgu.CV.Cuda.Stream)"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool NextFrame(
    GpuMat frame,
    Stream stream = null
)
Public Function NextFrame (
    frame As GpuMat,
    Optional stream As Stream = Nothing
) As Boolean
public:
bool NextFrame(
    GpuMat^ frame,
    Stream^ stream = nullptr
)
member NextFrame :
        frame : GpuMat *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> bool

Parameters

frame
Type: Emgu.CV.CudaGpuMat

[Missing <param name="frame"/> documentation for "M:Emgu.CV.Cuda.CudaVideoReader.NextFrame(Emgu.CV.Cuda.GpuMat,Emgu.CV.Cuda.Stream)"]

stream (Optional)
Type: Emgu.CV.CudaStream

[Missing <param name="stream"/> documentation for "M:Emgu.CV.Cuda.CudaVideoReader.NextFrame(Emgu.CV.Cuda.GpuMat,Emgu.CV.Cuda.Stream)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Emgu.CV.Cuda.CudaVideoReader.NextFrame(Emgu.CV.Cuda.GpuMat,Emgu.CV.Cuda.Stream)"]

See Also

Reference

CudaVideoReader Class
Emgu.CV.Cuda Namespace


CudaVideoReader Fields

The CudaVideoReader type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaVideoReader Class
Emgu.CV.Cuda Namespace


CudaVideoReader.ChromaFormat Class

CudaVideoReaderChromaFormat Class

[Missing <summary> documentation for "T:Emgu.CV.Cuda.CudaVideoReader.ChromaFormat"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CudaCudaVideoReaderChromaFormat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ChromaFormat : Enum
Public NotInheritable Class ChromaFormat
    Inherits Enum
public ref class ChromaFormat sealed : public Enum
[<SealedAttribute>]
type ChromaFormat =
    class
        inherit Enum
    end

The CudaVideoReaderChromaFormat type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Monochrome |
 | NumFormats |
Public field | value__ |
 | YUV420 |
 | YUV422 |
 | YUV444 |
Top
See Also

Reference

Emgu.CV.Cuda Namespace


ChromaFormat Methods

The CudaVideoReaderChromaFormat type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


ChromaFormat Fields

The CudaVideoReaderChromaFormat type exposes the following members.

Fields
 | Name | Description
 | Monochrome |
 | NumFormats |
Public field | value__ |
 | YUV420 |
 | YUV422 |
 | YUV444 |
Top
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


CudaVideoReader.ChromaFormat.Monochrome Field

CudaVideoReaderChromaFormatMonochrome Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.ChromaFormat.Monochrome"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderChromaFormat Monochrome = 0
Public Const Monochrome As CudaVideoReaderChromaFormat = 0
public:
literal CudaVideoReaderChromaFormat^ Monochrome = 0
static val mutable Monochrome: CudaVideoReaderChromaFormat

Field Value

Type: CudaVideoReaderChromaFormat
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


CudaVideoReader.ChromaFormat.NumFormats Field

CudaVideoReaderChromaFormatNumFormats Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.ChromaFormat.NumFormats"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderChromaFormat NumFormats = 4
Public Const NumFormats As CudaVideoReaderChromaFormat = 4
public:
literal CudaVideoReaderChromaFormat^ NumFormats = 4
static val mutable NumFormats: CudaVideoReaderChromaFormat

Field Value

Type: CudaVideoReaderChromaFormat
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


CudaVideoReader.ChromaFormat.value__ Field

CudaVideoReaderChromaFormatvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.ChromaFormat.value__"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


CudaVideoReader.ChromaFormat.YUV420 Field

CudaVideoReaderChromaFormatYUV420 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.ChromaFormat.YUV420"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderChromaFormat YUV420 = 1
Public Const YUV420 As CudaVideoReaderChromaFormat = 1
public:
literal CudaVideoReaderChromaFormat^ YUV420 = 1
static val mutable YUV420: CudaVideoReaderChromaFormat

Field Value

Type: CudaVideoReaderChromaFormat
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


CudaVideoReader.ChromaFormat.YUV422 Field

CudaVideoReaderChromaFormatYUV422 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.ChromaFormat.YUV422"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderChromaFormat YUV422 = 2
Public Const YUV422 As CudaVideoReaderChromaFormat = 2
public:
literal CudaVideoReaderChromaFormat^ YUV422 = 2
static val mutable YUV422: CudaVideoReaderChromaFormat

Field Value

Type: CudaVideoReaderChromaFormat
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


CudaVideoReader.ChromaFormat.YUV444 Field

CudaVideoReaderChromaFormatYUV444 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.ChromaFormat.YUV444"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderChromaFormat YUV444 = 3
Public Const YUV444 As CudaVideoReaderChromaFormat = 3
public:
literal CudaVideoReaderChromaFormat^ YUV444 = 3
static val mutable YUV444: CudaVideoReaderChromaFormat

Field Value

Type: CudaVideoReaderChromaFormat
See Also

Reference

CudaVideoReaderChromaFormat Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec Class

CudaVideoReaderCodec Class

[Missing <summary> documentation for "T:Emgu.CV.Cuda.CudaVideoReader.Codec"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CudaCudaVideoReaderCodec

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Codec : Enum
Public NotInheritable Class Codec
    Inherits Enum
public ref class Codec sealed : public Enum
[<SealedAttribute>]
type Codec =
    class
        inherit Enum
    end

The CudaVideoReaderCodec type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | H264 |
 | H264_MVC |
 | H264_SVC |
 | HEVC |
 | JPEG |
 | MPEG1 |
 | MPEG2 |
 | MPEG4 |
 | NumCodecs |
 | Uncompressed_NV12 |
 | Uncompressed_UYVY |
 | Uncompressed_YUV420 |
 | Uncompressed_YUYV |
 | Uncompressed_YV12 |
Public field | value__ |
 | VC1 |
 | VP8 |
 | VP9 |
Top
See Also

Reference

Emgu.CV.Cuda Namespace


Codec Methods

The CudaVideoReaderCodec type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


Codec Fields

The CudaVideoReaderCodec type exposes the following members.

Fields
 | Name | Description
 | H264 |
 | H264_MVC |
 | H264_SVC |
 | HEVC |
 | JPEG |
 | MPEG1 |
 | MPEG2 |
 | MPEG4 |
 | NumCodecs |
 | Uncompressed_NV12 |
 | Uncompressed_UYVY |
 | Uncompressed_YUV420 |
 | Uncompressed_YUYV |
 | Uncompressed_YV12 |
Public field | value__ |
 | VC1 |
 | VP8 |
 | VP9 |
Top
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.H264 Field

CudaVideoReaderCodecH264 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.H264"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec H264 = 4
Public Const H264 As CudaVideoReaderCodec = 4
public:
literal CudaVideoReaderCodec^ H264 = 4
static val mutable H264: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.H264_MVC Field

CudaVideoReaderCodecH264_MVC Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.H264_MVC"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec H264_MVC = 7
Public Const H264_MVC As CudaVideoReaderCodec = 7
public:
literal CudaVideoReaderCodec^ H264_MVC = 7
static val mutable H264_MVC: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.H264_SVC Field

CudaVideoReaderCodecH264_SVC Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.H264_SVC"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec H264_SVC = 6
Public Const H264_SVC As CudaVideoReaderCodec = 6
public:
literal CudaVideoReaderCodec^ H264_SVC = 6
static val mutable H264_SVC: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.HEVC Field

CudaVideoReaderCodecHEVC Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.HEVC"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec HEVC = 8
Public Const HEVC As CudaVideoReaderCodec = 8
public:
literal CudaVideoReaderCodec^ HEVC = 8
static val mutable HEVC: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.JPEG Field

CudaVideoReaderCodecJPEG Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.JPEG"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec JPEG = 5
Public Const JPEG As CudaVideoReaderCodec = 5
public:
literal CudaVideoReaderCodec^ JPEG = 5
static val mutable JPEG: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.MPEG1 Field

CudaVideoReaderCodecMPEG1 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.MPEG1"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec MPEG1 = 0
Public Const MPEG1 As CudaVideoReaderCodec = 0
public:
literal CudaVideoReaderCodec^ MPEG1 = 0
static val mutable MPEG1: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.MPEG2 Field

CudaVideoReaderCodecMPEG2 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.MPEG2"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec MPEG2 = 1
Public Const MPEG2 As CudaVideoReaderCodec = 1
public:
literal CudaVideoReaderCodec^ MPEG2 = 1
static val mutable MPEG2: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.MPEG4 Field

CudaVideoReaderCodecMPEG4 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.MPEG4"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec MPEG4 = 2
Public Const MPEG4 As CudaVideoReaderCodec = 2
public:
literal CudaVideoReaderCodec^ MPEG4 = 2
static val mutable MPEG4: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.NumCodecs Field

CudaVideoReaderCodecNumCodecs Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.NumCodecs"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec NumCodecs = 11
Public Const NumCodecs As CudaVideoReaderCodec = 11
public:
literal CudaVideoReaderCodec^ NumCodecs = 11
static val mutable NumCodecs: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.Uncompressed_NV12 Field

CudaVideoReaderCodecUncompressed_NV12 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.Uncompressed_NV12"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec Uncompressed_NV12 = 1314271538
Public Const Uncompressed_NV12 As CudaVideoReaderCodec = 1314271538
public:
literal CudaVideoReaderCodec^ Uncompressed_NV12 = 1314271538
static val mutable Uncompressed_NV12: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.Uncompressed_UYVY Field

CudaVideoReaderCodecUncompressed_UYVY Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.Uncompressed_UYVY"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec Uncompressed_UYVY = 1431918169
Public Const Uncompressed_UYVY As CudaVideoReaderCodec = 1431918169
public:
literal CudaVideoReaderCodec^ Uncompressed_UYVY = 1431918169
static val mutable Uncompressed_UYVY: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.Uncompressed_YUV420 Field

CudaVideoReaderCodecUncompressed_YUV420 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.Uncompressed_YUV420"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec Uncompressed_YUV420 = 1230591318
Public Const Uncompressed_YUV420 As CudaVideoReaderCodec = 1230591318
public:
literal CudaVideoReaderCodec^ Uncompressed_YUV420 = 1230591318
static val mutable Uncompressed_YUV420: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.Uncompressed_YUYV Field

CudaVideoReaderCodecUncompressed_YUYV Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.Uncompressed_YUYV"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec Uncompressed_YUYV = 1498765654
Public Const Uncompressed_YUYV As CudaVideoReaderCodec = 1498765654
public:
literal CudaVideoReaderCodec^ Uncompressed_YUYV = 1498765654
static val mutable Uncompressed_YUYV: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.Uncompressed_YV12 Field

CudaVideoReaderCodecUncompressed_YV12 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.Uncompressed_YV12"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec Uncompressed_YV12 = 1498820914
Public Const Uncompressed_YV12 As CudaVideoReaderCodec = 1498820914
public:
literal CudaVideoReaderCodec^ Uncompressed_YV12 = 1498820914
static val mutable Uncompressed_YV12: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.value__ Field

CudaVideoReaderCodecvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.value__"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.VC1 Field

CudaVideoReaderCodecVC1 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.VC1"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec VC1 = 3
Public Const VC1 As CudaVideoReaderCodec = 3
public:
literal CudaVideoReaderCodec^ VC1 = 3
static val mutable VC1: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.VP8 Field

CudaVideoReaderCodecVP8 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.VP8"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec VP8 = 9
Public Const VP8 As CudaVideoReaderCodec = 9
public:
literal CudaVideoReaderCodec^ VP8 = 9
static val mutable VP8: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.Codec.VP9 Field

CudaVideoReaderCodecVP9 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoReader.Codec.VP9"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoReaderCodec VP9 = 10
Public Const VP9 As CudaVideoReaderCodec = 10
public:
literal CudaVideoReaderCodec^ VP9 = 10
static val mutable VP9: CudaVideoReaderCodec

Field Value

Type: CudaVideoReaderCodec
See Also

Reference

CudaVideoReaderCodec Class
Emgu.CV.Cuda Namespace


CudaVideoReader.FormatInfo Class

CudaVideoReaderFormatInfo Class

[Missing <summary> documentation for "T:Emgu.CV.Cuda.CudaVideoReader.FormatInfo"]

Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.CudaCudaVideoReaderFormatInfo

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FormatInfo : ValueType
Public NotInheritable Class FormatInfo
    Inherits ValueType
public ref class FormatInfo sealed : public ValueType
[<SealedAttribute>]
type FormatInfo =
    class
        inherit ValueType
    end

The CudaVideoReaderFormatInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


FormatInfo Methods

The CudaVideoReaderFormatInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

CudaVideoReaderFormatInfo Class
Emgu.CV.Cuda Namespace


CudaVideoWriter Class

Works only under Windows, Supports only H264 video codec and AVI files.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaVideoWriter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CudaVideoWriter : SharedPtrObject
Public Class CudaVideoWriter
    Inherits SharedPtrObject
public ref class CudaVideoWriter : public SharedPtrObject
type CudaVideoWriter =
    class
        inherit SharedPtrObject
    end

The CudaVideoWriter type exposes the following members.

Constructors
 | Name | Description
Public method | CudaVideoWriter | Initializes a new instance of the CudaVideoWriter class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write |
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


CudaVideoWriter Constructor

Initializes a new instance of the CudaVideoWriter class

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CudaVideoWriter(
    string fileName,
    Size frameSize,
    double fps,
    CudaVideoWriterSurfaceFormat format = 5
)
Public Sub New (
    fileName As String,
    frameSize As Size,
    fps As Double,
    Optional format As CudaVideoWriterSurfaceFormat = 5
)
public:
CudaVideoWriter(
    String^ fileName,
    Size^ frameSize,
    double fps,
    CudaVideoWriterSurfaceFormat^ format = 5
)
new :
        fileName : string *
        frameSize : Size *
        fps : float *
        ?format : CudaVideoWriterSurfaceFormat
(* Defaults:
        let _format = defaultArg format 5
*)
-> CudaVideoWriter

Parameters

fileName
Type: SystemString

[Missing <param name="fileName"/> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.#ctor(System.String,System.Drawing.Size,System.Double,Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat)"]

frameSize
Type: System.DrawingSize

[Missing <param name="frameSize"/> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.#ctor(System.String,System.Drawing.Size,System.Double,Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat)"]

fps
Type: SystemDouble

[Missing <param name="fps"/> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.#ctor(System.String,System.Drawing.Size,System.Double,Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat)"]

format (Optional)
Type: Emgu.CV.CudaCudaVideoWriterSurfaceFormat

[Missing <param name="format"/> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.#ctor(System.String,System.Drawing.Size,System.Double,Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat)"]

See Also

Reference

CudaVideoWriter Class
Emgu.CV.Cuda Namespace


CudaVideoWriter Properties

The CudaVideoWriter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaVideoWriter Class
Emgu.CV.Cuda Namespace


CudaVideoWriter Methods

The CudaVideoWriter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write |
Top
See Also

Reference

CudaVideoWriter Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.DisposeObject Method

CudaVideoWriterDisposeObject Method

[Missing <summary> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.DisposeObject"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CudaVideoWriter Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.Write Method

CudaVideoWriterWrite Method

[Missing <summary> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.Write(Emgu.CV.IInputArray,System.Boolean)"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    IInputArray frame,
    bool lastFrame = false
)
Public Sub Write (
    frame As IInputArray,
    Optional lastFrame As Boolean = false
)
public:
void Write(
    IInputArray^ frame,
    bool lastFrame = false
)
member Write :
        frame : IInputArray *
        ?lastFrame : bool
(* Defaults:
        let _lastFrame = defaultArg lastFrame false
*)
-> unit

Parameters

frame
Type: Emgu.CVIInputArray

[Missing <param name="frame"/> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.Write(Emgu.CV.IInputArray,System.Boolean)"]

lastFrame (Optional)
Type: SystemBoolean

[Missing <param name="lastFrame"/> documentation for "M:Emgu.CV.Cuda.CudaVideoWriter.Write(Emgu.CV.IInputArray,System.Boolean)"]

See Also

Reference

CudaVideoWriter Class
Emgu.CV.Cuda Namespace


CudaVideoWriter Fields

The CudaVideoWriter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

CudaVideoWriter Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat Class

CudaVideoWriterSurfaceFormat Class

Surface format
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CudaCudaVideoWriterSurfaceFormat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SurfaceFormat : Enum
Public NotInheritable Class SurfaceFormat
    Inherits Enum
public ref class SurfaceFormat sealed : public Enum
[<SealedAttribute>]
type SurfaceFormat =
    class
        inherit Enum
    end

The CudaVideoWriterSurfaceFormat type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BGR |
 | GRAY |
 | IYUV |
 | NV12 |
 | UYVY |
Public field | value__ |
 | YUY2 |
 | YV12 |
Top
See Also

Reference

Emgu.CV.Cuda Namespace


SurfaceFormat Methods

The CudaVideoWriterSurfaceFormat type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


SurfaceFormat Fields

The CudaVideoWriterSurfaceFormat type exposes the following members.

Fields
 | Name | Description
 | BGR |
 | GRAY |
 | IYUV |
 | NV12 |
 | UYVY |
Public field | value__ |
 | YUY2 |
 | YV12 |
Top
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.BGR Field

CudaVideoWriterSurfaceFormatBGR Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.BGR"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoWriterSurfaceFormat BGR = 5
Public Const BGR As CudaVideoWriterSurfaceFormat = 5
public:
literal CudaVideoWriterSurfaceFormat^ BGR = 5
static val mutable BGR: CudaVideoWriterSurfaceFormat

Field Value

Type: CudaVideoWriterSurfaceFormat
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.GRAY Field

CudaVideoWriterSurfaceFormatGRAY Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.GRAY"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoWriterSurfaceFormat GRAY = 5
Public Const GRAY As CudaVideoWriterSurfaceFormat = 5
public:
literal CudaVideoWriterSurfaceFormat^ GRAY = 5
static val mutable GRAY: CudaVideoWriterSurfaceFormat

Field Value

Type: CudaVideoWriterSurfaceFormat
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.IYUV Field

CudaVideoWriterSurfaceFormatIYUV Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.IYUV"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoWriterSurfaceFormat IYUV = 4
Public Const IYUV As CudaVideoWriterSurfaceFormat = 4
public:
literal CudaVideoWriterSurfaceFormat^ IYUV = 4
static val mutable IYUV: CudaVideoWriterSurfaceFormat

Field Value

Type: CudaVideoWriterSurfaceFormat
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.NV12 Field

CudaVideoWriterSurfaceFormatNV12 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.NV12"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoWriterSurfaceFormat NV12 = 3
Public Const NV12 As CudaVideoWriterSurfaceFormat = 3
public:
literal CudaVideoWriterSurfaceFormat^ NV12 = 3
static val mutable NV12: CudaVideoWriterSurfaceFormat

Field Value

Type: CudaVideoWriterSurfaceFormat
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.UYVY Field

CudaVideoWriterSurfaceFormatUYVY Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.UYVY"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoWriterSurfaceFormat UYVY = 0
Public Const UYVY As CudaVideoWriterSurfaceFormat = 0
public:
literal CudaVideoWriterSurfaceFormat^ UYVY = 0
static val mutable UYVY: CudaVideoWriterSurfaceFormat

Field Value

Type: CudaVideoWriterSurfaceFormat
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.value__ Field

CudaVideoWriterSurfaceFormatvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.value__"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.YUY2 Field

CudaVideoWriterSurfaceFormatYUY2 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.YUY2"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoWriterSurfaceFormat YUY2 = 1
Public Const YUY2 As CudaVideoWriterSurfaceFormat = 1
public:
literal CudaVideoWriterSurfaceFormat^ YUY2 = 1
static val mutable YUY2: CudaVideoWriterSurfaceFormat

Field Value

Type: CudaVideoWriterSurfaceFormat
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


CudaVideoWriter.SurfaceFormat.YV12 Field

CudaVideoWriterSurfaceFormatYV12 Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.CudaVideoWriter.SurfaceFormat.YV12"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CudaVideoWriterSurfaceFormat YV12 = 2
Public Const YV12 As CudaVideoWriterSurfaceFormat = 2
public:
literal CudaVideoWriterSurfaceFormat^ YV12 = 2
static val mutable YV12: CudaVideoWriterSurfaceFormat

Field Value

Type: CudaVideoWriterSurfaceFormat
See Also

Reference

CudaVideoWriterSurfaceFormat Class
Emgu.CV.Cuda Namespace


DemosaicTypes Class

Bayer Demosaicing (Malvar, He, and Cutler)
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CudaDemosaicTypes

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DemosaicTypes : Enum
Public NotInheritable Class DemosaicTypes
    Inherits Enum
public ref class DemosaicTypes sealed : public Enum
[<SealedAttribute>]
type DemosaicTypes =
    class
        inherit Enum
    end

The DemosaicTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BayerBG2BGR_MHT | BayerBG2BGR_MHT
 | BayerBG2GRAY_MHT | BayerBG2GRAY_MHT
 | BayerBG2RGB_MHT | BayerBG2RGB_MHT
 | BayerGB2BGR_MHT | BayerGB2BGR_MHT
 | BayerGB2GRAY_MHT | BayerGB2GRAY_MHT
 | BayerGB2RGB_MHT | BayerGB2RGB_MHT
 | BayerGR2BGR_MHT | BayerGR2BGR_MHT
 | BayerGR2GRAY_MHT | BayerGR2GRAY_MHT
 | BayerGR2RGB_MHT | BayerGR2RGB_MHT
 | BayerRG2BGR_MHT | BayerRG2BGR_MHT
 | BayerRG2GRAY_MHT | BayerRG2GRAY_MHT
 | BayerRG2RGB_MHT | BayerRG2RGB_MHT
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Cuda Namespace


DemosaicTypes Methods

The DemosaicTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes Fields

The DemosaicTypes type exposes the following members.

Fields
 | Name | Description
 | BayerBG2BGR_MHT | BayerBG2BGR_MHT
 | BayerBG2GRAY_MHT | BayerBG2GRAY_MHT
 | BayerBG2RGB_MHT | BayerBG2RGB_MHT
 | BayerGB2BGR_MHT | BayerGB2BGR_MHT
 | BayerGB2GRAY_MHT | BayerGB2GRAY_MHT
 | BayerGB2RGB_MHT | BayerGB2RGB_MHT
 | BayerGR2BGR_MHT | BayerGR2BGR_MHT
 | BayerGR2GRAY_MHT | BayerGR2GRAY_MHT
 | BayerGR2RGB_MHT | BayerGR2RGB_MHT
 | BayerRG2BGR_MHT | BayerRG2BGR_MHT
 | BayerRG2GRAY_MHT | BayerRG2GRAY_MHT
 | BayerRG2RGB_MHT | BayerRG2RGB_MHT
Public field | value__ |
Top
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerBG2BGR_MHT Field

DemosaicTypesBayerBG2BGR_MHT Field

BayerBG2BGR_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerBG2BGR_MHT = 256
Public Const BayerBG2BGR_MHT As DemosaicTypes = 256
public:
literal DemosaicTypes^ BayerBG2BGR_MHT = 256
static val mutable BayerBG2BGR_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerBG2GRAY_MHT Field

DemosaicTypesBayerBG2GRAY_MHT Field

BayerBG2GRAY_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerBG2GRAY_MHT = 260
Public Const BayerBG2GRAY_MHT As DemosaicTypes = 260
public:
literal DemosaicTypes^ BayerBG2GRAY_MHT = 260
static val mutable BayerBG2GRAY_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerBG2RGB_MHT Field

DemosaicTypesBayerBG2RGB_MHT Field

BayerBG2RGB_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerBG2RGB_MHT = 258
Public Const BayerBG2RGB_MHT As DemosaicTypes = 258
public:
literal DemosaicTypes^ BayerBG2RGB_MHT = 258
static val mutable BayerBG2RGB_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerGB2BGR_MHT Field

DemosaicTypesBayerGB2BGR_MHT Field

BayerGB2BGR_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerGB2BGR_MHT = 257
Public Const BayerGB2BGR_MHT As DemosaicTypes = 257
public:
literal DemosaicTypes^ BayerGB2BGR_MHT = 257
static val mutable BayerGB2BGR_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerGB2GRAY_MHT Field

DemosaicTypesBayerGB2GRAY_MHT Field

BayerGB2GRAY_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerGB2GRAY_MHT = 261
Public Const BayerGB2GRAY_MHT As DemosaicTypes = 261
public:
literal DemosaicTypes^ BayerGB2GRAY_MHT = 261
static val mutable BayerGB2GRAY_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerGB2RGB_MHT Field

DemosaicTypesBayerGB2RGB_MHT Field

BayerGB2RGB_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerGB2RGB_MHT = 259
Public Const BayerGB2RGB_MHT As DemosaicTypes = 259
public:
literal DemosaicTypes^ BayerGB2RGB_MHT = 259
static val mutable BayerGB2RGB_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerGR2BGR_MHT Field

DemosaicTypesBayerGR2BGR_MHT Field

BayerGR2BGR_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerGR2BGR_MHT = 259
Public Const BayerGR2BGR_MHT As DemosaicTypes = 259
public:
literal DemosaicTypes^ BayerGR2BGR_MHT = 259
static val mutable BayerGR2BGR_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerGR2GRAY_MHT Field

DemosaicTypesBayerGR2GRAY_MHT Field

BayerGR2GRAY_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerGR2GRAY_MHT = 263
Public Const BayerGR2GRAY_MHT As DemosaicTypes = 263
public:
literal DemosaicTypes^ BayerGR2GRAY_MHT = 263
static val mutable BayerGR2GRAY_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerGR2RGB_MHT Field

DemosaicTypesBayerGR2RGB_MHT Field

BayerGR2RGB_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerGR2RGB_MHT = 257
Public Const BayerGR2RGB_MHT As DemosaicTypes = 257
public:
literal DemosaicTypes^ BayerGR2RGB_MHT = 257
static val mutable BayerGR2RGB_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerRG2BGR_MHT Field

DemosaicTypesBayerRG2BGR_MHT Field

BayerRG2BGR_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerRG2BGR_MHT = 258
Public Const BayerRG2BGR_MHT As DemosaicTypes = 258
public:
literal DemosaicTypes^ BayerRG2BGR_MHT = 258
static val mutable BayerRG2BGR_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerRG2GRAY_MHT Field

DemosaicTypesBayerRG2GRAY_MHT Field

BayerRG2GRAY_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerRG2GRAY_MHT = 262
Public Const BayerRG2GRAY_MHT As DemosaicTypes = 262
public:
literal DemosaicTypes^ BayerRG2GRAY_MHT = 262
static val mutable BayerRG2GRAY_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.BayerRG2RGB_MHT Field

DemosaicTypesBayerRG2RGB_MHT Field

BayerRG2RGB_MHT

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DemosaicTypes BayerRG2RGB_MHT = 256
Public Const BayerRG2RGB_MHT As DemosaicTypes = 256
public:
literal DemosaicTypes^ BayerRG2RGB_MHT = 256
static val mutable BayerRG2RGB_MHT: DemosaicTypes

Field Value

Type: DemosaicTypes
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DemosaicTypes.value__ Field

DemosaicTypesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cuda.DemosaicTypes.value__"]

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DemosaicTypes Class
Emgu.CV.Cuda Namespace


DescriptorMatcher Class

Descriptor matcher
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaDescriptorMatcher
Emgu.CV.CudaCudaBFMatcher

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class DescriptorMatcher : SharedPtrObject,
    IAlgorithm
Public MustInherit Class DescriptorMatcher
    Inherits SharedPtrObject
    Implements IAlgorithm
public ref class DescriptorMatcher abstract : public SharedPtrObject,
    IAlgorithm
[<AbstractClassAttribute>]
type DescriptorMatcher =
    class
        inherit SharedPtrObject
        interface IAlgorithm
    end

The DescriptorMatcher type exposes the following members.

Constructors
 | Name | Description
Protected method | DescriptorMatcher | Initializes a new instance of the DescriptorMatcher class
Top
Properties
 | Name | Description
Public property | Empty | Return True if the matcher is empty
Public property | IsMaskSupported | Return True if mask is supported
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Add | Add the model descriptors
Public method | Clear | Clear the matcher
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this matcher (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, VectorOfGpuMat, Boolean) | Find the k-nearest match
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match
Public method | KnnMatchAsync(IInputArray, IOutputArray, Int32, VectorOfGpuMat, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version).
Public method | KnnMatchAsync(IInputArray, IInputArray, IOutputArray, Int32, IInputArray, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version).
Public method | KnnMatchConvert | Converts matches array from internal representation to standard matches vector.
Public method | Match(IInputArray, VectorOfDMatch, VectorOfGpuMat) | Finds the best match for each descriptor from a query set (blocking version).
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set (blocking version).
Public method | MatchAsync(IInputArray, IOutputArray, VectorOfGpuMat, Stream) | Finds the best match for each descriptor from a query set (asynchronous version).
Public method | MatchAsync(IInputArray, IInputArray, IOutputArray, IInputArray, Stream) | Finds the best match for each descriptor from a query set (asynchronous version).
Public method | MatchConvert | Converts matches array from internal representation to standard matches vector.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, VectorOfGpuMat, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).
Public method | RadiusMatchAsync(IInputArray, IOutputArray, Single, VectorOfGpuMat, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).
Public method | RadiusMatchAsync(IInputArray, IInputArray, IOutputArray, Single, IInputArray, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).
Public method | RadiusMatchConvert | Converts matches array from internal representation to standard matches vector.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher.
Top
Fields
 | Name | Description
Protected field | _algorithmPtr | Pointer to the native cv::Algorithm
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


DescriptorMatcher Constructor

Initializes a new instance of the DescriptorMatcher class

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected DescriptorMatcher()
Protected Sub New
protected:
DescriptorMatcher()
new : unit -> DescriptorMatcher
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher Properties

The DescriptorMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Empty | Return True if the matcher is empty
Public property | IsMaskSupported | Return True if mask is supported
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.Empty Property

DescriptorMatcherEmpty Property

Return True if the matcher is empty

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get

Property Value

Type: Boolean
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.IsMaskSupported Property

DescriptorMatcherIsMaskSupported Property

Return True if mask is supported

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsMaskSupported { get; }
Public ReadOnly Property IsMaskSupported As Boolean
    Get
public:
property bool IsMaskSupported {
    bool get ();
}
member IsMaskSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher Methods

The DescriptorMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add the model descriptors
Public method | Clear | Clear the matcher
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this matcher (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, VectorOfGpuMat, Boolean) | Find the k-nearest match
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match
Public method | KnnMatchAsync(IInputArray, IOutputArray, Int32, VectorOfGpuMat, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version).
Public method | KnnMatchAsync(IInputArray, IInputArray, IOutputArray, Int32, IInputArray, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version).
Public method | KnnMatchConvert | Converts matches array from internal representation to standard matches vector.
Public method | Match(IInputArray, VectorOfDMatch, VectorOfGpuMat) | Finds the best match for each descriptor from a query set (blocking version).
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set (blocking version).
Public method | MatchAsync(IInputArray, IOutputArray, VectorOfGpuMat, Stream) | Finds the best match for each descriptor from a query set (asynchronous version).
Public method | MatchAsync(IInputArray, IInputArray, IOutputArray, IInputArray, Stream) | Finds the best match for each descriptor from a query set (asynchronous version).
Public method | MatchConvert | Converts matches array from internal representation to standard matches vector.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, VectorOfGpuMat, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).
Public method | RadiusMatchAsync(IInputArray, IOutputArray, Single, VectorOfGpuMat, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).
Public method | RadiusMatchAsync(IInputArray, IInputArray, IOutputArray, Single, IInputArray, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).
Public method | RadiusMatchConvert | Converts matches array from internal representation to standard matches vector.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher.
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.Add Method

DescriptorMatcherAdd Method

Add the model descriptors

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    IInputArray modelDescriptors
)
Public Sub Add (
    modelDescriptors As IInputArray
)
public:
void Add(
    IInputArray^ modelDescriptors
)
member Add :
        modelDescriptors : IInputArray -> unit

Parameters

modelDescriptors
Type: Emgu.CVIInputArray
The model descriptors
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.Clear Method

DescriptorMatcherClear Method

Clear the matcher

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.DisposeObject Method

DescriptorMatcherDisposeObject Method

Release all the unmanaged memory associated with this matcher

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.KnnMatch Method

DescriptorMatcherKnnMatch Method

Overload List
 | Name | Description
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, VectorOfGpuMat, Boolean) | Find the k-nearest match
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.KnnMatch Method (IInputArray, VectorOfVectorOfDMatch, Int32, VectorOfGpuMat, Boolean)

DescriptorMatcherKnnMatch Method (IInputArray, VectorOfVectorOfDMatch, Int32, VectorOfGpuMat, Boolean)

http://www.emgu.com
Find the k-nearest match

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnMatch(
    IInputArray queryDescriptors,
    VectorOfVectorOfDMatch matches,
    int k,
    VectorOfGpuMat masks = null,
    bool compactResult = false
)
Public Sub KnnMatch (
    queryDescriptors As IInputArray,
    matches As VectorOfVectorOfDMatch,
    k As Integer,
    Optional masks As VectorOfGpuMat = Nothing,
    Optional compactResult As Boolean = false
)
public:
void KnnMatch(
    IInputArray^ queryDescriptors,
    VectorOfVectorOfDMatch^ matches,
    int k,
    VectorOfGpuMat^ masks = nullptr,
    bool compactResult = false
)
member KnnMatch :
        queryDescriptors : IInputArray *
        matches : VectorOfVectorOfDMatch *
        k : int *
        ?masks : VectorOfGpuMat *
        ?compactResult : bool
(* Defaults:
        let _masks = defaultArg masks null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
An n x m matrix of descriptors to be query for nearest neighbors. n is the number of descriptor and m is the size of the descriptor
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
k
Type: SystemInt32
Number of nearest neighbors to search for
masks (Optional)
Type: Emgu.CV.CudaVectorOfGpuMat
Can be null if not needed. An n x 1 matrix. If 0, the query descriptor in the corresponding row will be ignored.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
KnnMatch Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.KnnMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean)

DescriptorMatcherKnnMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean)

http://www.emgu.com
Find the k-nearest match

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnMatch(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    VectorOfVectorOfDMatch matches,
    int k,
    IInputArray mask = null,
    bool compactResult = false
)
Public Sub KnnMatch (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As VectorOfVectorOfDMatch,
    k As Integer,
    Optional mask As IInputArray = Nothing,
    Optional compactResult As Boolean = false
)
public:
void KnnMatch(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    VectorOfVectorOfDMatch^ matches,
    int k,
    IInputArray^ mask = nullptr,
    bool compactResult = false
)
member KnnMatch :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : VectorOfVectorOfDMatch *
        k : int *
        ?mask : IInputArray *
        ?compactResult : bool
(* Defaults:
        let _mask = defaultArg mask null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
An n x m matrix of descriptors to be query for nearest neighbors. n is the number of descriptor and m is the size of the descriptor
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
k
Type: SystemInt32
Number of nearest neighbors to search for
mask (Optional)
Type: Emgu.CVIInputArray
Can be null if not needed. An n x 1 matrix. If 0, the query descriptor in the corresponding row will be ignored.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
KnnMatch Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.KnnMatchAsync Method

DescriptorMatcherKnnMatchAsync Method

Overload List
 | Name | Description
Public method | KnnMatchAsync(IInputArray, IOutputArray, Int32, VectorOfGpuMat, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version).
Public method | KnnMatchAsync(IInputArray, IInputArray, IOutputArray, Int32, IInputArray, Stream) | Finds the k best matches for each descriptor from a query set (asynchronous version).
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.KnnMatchAsync Method (IInputArray, IOutputArray, Int32, VectorOfGpuMat, Stream)

DescriptorMatcherKnnMatchAsync Method (IInputArray, IOutputArray, Int32, VectorOfGpuMat, Stream)

http://www.emgu.com
Finds the k best matches for each descriptor from a query set (asynchronous version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnMatchAsync(
    IInputArray queryDescriptors,
    IOutputArray matches,
    int k,
    VectorOfGpuMat masks = null,
    Stream stream = null
)
Public Sub KnnMatchAsync (
    queryDescriptors As IInputArray,
    matches As IOutputArray,
    k As Integer,
    Optional masks As VectorOfGpuMat = Nothing,
    Optional stream As Stream = Nothing
)
public:
void KnnMatchAsync(
    IInputArray^ queryDescriptors,
    IOutputArray^ matches,
    int k,
    VectorOfGpuMat^ masks = nullptr,
    Stream^ stream = nullptr
)
member KnnMatchAsync :
        queryDescriptors : IInputArray *
        matches : IOutputArray *
        k : int *
        ?masks : VectorOfGpuMat *
        ?stream : Stream
(* Defaults:
        let _masks = defaultArg masks null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
matches
Type: Emgu.CVIOutputArray
Matches array stored in GPU memory. Internal representation is not defined. Use DescriptorMatcher::knnMatchConvert method to retrieve results in standard representation.
k
Type: SystemInt32
Count of best matches found per each query descriptor or less if a query descriptor has less than k possible matches in total.
masks (Optional)
Type: Emgu.CV.CudaVectorOfGpuMat
Mask specifying permissible matches between an input query and train matrices of descriptors.
stream (Optional)
Type: Emgu.CV.CudaStream
CUDA stream.
See Also

Reference

DescriptorMatcher Class
KnnMatchAsync Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.KnnMatchAsync Method (IInputArray, IInputArray, IOutputArray, Int32, IInputArray, Stream)

DescriptorMatcherKnnMatchAsync Method (IInputArray, IInputArray, IOutputArray, Int32, IInputArray, Stream)

http://www.emgu.com
Finds the k best matches for each descriptor from a query set (asynchronous version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnMatchAsync(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    IOutputArray matches,
    int k,
    IInputArray mask = null,
    Stream stream = null
)
Public Sub KnnMatchAsync (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As IOutputArray,
    k As Integer,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
void KnnMatchAsync(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    IOutputArray^ matches,
    int k,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
member KnnMatchAsync :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : IOutputArray *
        k : int *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CVIOutputArray
Matches array stored in GPU memory. Internal representation is not defined. Use DescriptorMatcher::knnMatchConvert method to retrieve results in standard representation.
k
Type: SystemInt32
Count of best matches found per each query descriptor or less if a query descriptor has less than k possible matches in total.
mask (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
stream (Optional)
Type: Emgu.CV.CudaStream
CUDA stream.
See Also

Reference

DescriptorMatcher Class
KnnMatchAsync Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.KnnMatchConvert Method

DescriptorMatcherKnnMatchConvert Method

Converts matches array from internal representation to standard matches vector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnMatchConvert(
    IInputArray gpuMatches,
    VectorOfVectorOfDMatch matches,
    bool compactResult = false
)
Public Sub KnnMatchConvert (
    gpuMatches As IInputArray,
    matches As VectorOfVectorOfDMatch,
    Optional compactResult As Boolean = false
)
public:
void KnnMatchConvert(
    IInputArray^ gpuMatches,
    VectorOfVectorOfDMatch^ matches,
    bool compactResult = false
)
member KnnMatchConvert :
        gpuMatches : IInputArray *
        matches : VectorOfVectorOfDMatch *
        ?compactResult : bool
(* Defaults:
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

gpuMatches
Type: Emgu.CVIInputArray
Matches
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Vector of DMatch objects.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.Match Method

DescriptorMatcherMatch Method

Overload List
 | Name | Description
Public method | Match(IInputArray, VectorOfDMatch, VectorOfGpuMat) | Finds the best match for each descriptor from a query set (blocking version).
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set (blocking version).
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.Match Method (IInputArray, VectorOfDMatch, VectorOfGpuMat)

DescriptorMatcherMatch Method (IInputArray, VectorOfDMatch, VectorOfGpuMat)

http://www.emgu.com
Finds the best match for each descriptor from a query set (blocking version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Match(
    IInputArray queryDescriptors,
    VectorOfDMatch matches,
    VectorOfGpuMat mask = null
)
Public Sub Match (
    queryDescriptors As IInputArray,
    matches As VectorOfDMatch,
    Optional mask As VectorOfGpuMat = Nothing
)
public:
void Match(
    IInputArray^ queryDescriptors,
    VectorOfDMatch^ matches,
    VectorOfGpuMat^ mask = nullptr
)
member Match :
        queryDescriptors : IInputArray *
        matches : VectorOfDMatch *
        ?mask : VectorOfGpuMat
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
matches
Type: Emgu.CV.UtilVectorOfDMatch
Matches. If a query descriptor is masked out in mask , no match is added for this descriptor. So, matches size may be smaller than the query descriptors count.
mask (Optional)
Type: Emgu.CV.CudaVectorOfGpuMat
Mask specifying permissible matches between an input query and train matrices of descriptors.
See Also

Reference

DescriptorMatcher Class
Match Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.Match Method (IInputArray, IInputArray, VectorOfDMatch, IInputArray)

DescriptorMatcherMatch Method (IInputArray, IInputArray, VectorOfDMatch, IInputArray)

http://www.emgu.com
Finds the best match for each descriptor from a query set (blocking version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Match(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    VectorOfDMatch matches,
    IInputArray mask = null
)
Public Sub Match (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As VectorOfDMatch,
    Optional mask As IInputArray = Nothing
)
public:
void Match(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    VectorOfDMatch^ matches,
    IInputArray^ mask = nullptr
)
member Match :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : VectorOfDMatch *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CV.UtilVectorOfDMatch
Matches. If a query descriptor is masked out in mask , no match is added for this descriptor. So, matches size may be smaller than the query descriptors count.
mask (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
See Also

Reference

DescriptorMatcher Class
Match Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.MatchAsync Method

DescriptorMatcherMatchAsync Method

Overload List
 | Name | Description
Public method | MatchAsync(IInputArray, IOutputArray, VectorOfGpuMat, Stream) | Finds the best match for each descriptor from a query set (asynchronous version).
Public method | MatchAsync(IInputArray, IInputArray, IOutputArray, IInputArray, Stream) | Finds the best match for each descriptor from a query set (asynchronous version).
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.MatchAsync Method (IInputArray, IOutputArray, VectorOfGpuMat, Stream)

DescriptorMatcherMatchAsync Method (IInputArray, IOutputArray, VectorOfGpuMat, Stream)

http://www.emgu.com
Finds the best match for each descriptor from a query set (asynchronous version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MatchAsync(
    IInputArray queryDescriptors,
    IOutputArray matches,
    VectorOfGpuMat masks = null,
    Stream stream = null
)
Public Sub MatchAsync (
    queryDescriptors As IInputArray,
    matches As IOutputArray,
    Optional masks As VectorOfGpuMat = Nothing,
    Optional stream As Stream = Nothing
)
public:
void MatchAsync(
    IInputArray^ queryDescriptors,
    IOutputArray^ matches,
    VectorOfGpuMat^ masks = nullptr,
    Stream^ stream = nullptr
)
member MatchAsync :
        queryDescriptors : IInputArray *
        matches : IOutputArray *
        ?masks : VectorOfGpuMat *
        ?stream : Stream
(* Defaults:
        let _masks = defaultArg masks null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
matches
Type: Emgu.CVIOutputArray
Matches array stored in GPU memory. Internal representation is not defined. Use DescriptorMatcher::matchConvert method to retrieve results in standard representation.
masks (Optional)
Type: Emgu.CV.CudaVectorOfGpuMat
Mask specifying permissible matches between an input query and train matrices of descriptors.
stream (Optional)
Type: Emgu.CV.CudaStream
CUDA stream.
See Also

Reference

DescriptorMatcher Class
MatchAsync Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.MatchAsync Method (IInputArray, IInputArray, IOutputArray, IInputArray, Stream)

DescriptorMatcherMatchAsync Method (IInputArray, IInputArray, IOutputArray, IInputArray, Stream)

http://www.emgu.com
Finds the best match for each descriptor from a query set (asynchronous version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MatchAsync(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    IOutputArray matches,
    IInputArray mask = null,
    Stream stream = null
)
Public Sub MatchAsync (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
void MatchAsync(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    IOutputArray^ matches,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
member MatchAsync :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CVIOutputArray
Matches array stored in GPU memory. Internal representation is not defined. Use DescriptorMatcher::matchConvert method to retrieve results in standard representation.
mask (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
stream (Optional)
Type: Emgu.CV.CudaStream
CUDA stream.
See Also

Reference

DescriptorMatcher Class
MatchAsync Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.MatchConvert Method

DescriptorMatcherMatchConvert Method

Converts matches array from internal representation to standard matches vector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MatchConvert(
    IInputArray gpuMatches,
    VectorOfDMatch matches
)
Public Sub MatchConvert (
    gpuMatches As IInputArray,
    matches As VectorOfDMatch
)
public:
void MatchConvert(
    IInputArray^ gpuMatches,
    VectorOfDMatch^ matches
)
member MatchConvert :
        gpuMatches : IInputArray *
        matches : VectorOfDMatch -> unit

Parameters

gpuMatches
Type: Emgu.CVIInputArray
Matches, returned from MatchAsync.
matches
Type: Emgu.CV.UtilVectorOfDMatch
Vector of DMatch objects.
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.RadiusMatch Method

DescriptorMatcherRadiusMatch Method

Overload List
 | Name | Description
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, VectorOfGpuMat, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.RadiusMatch Method (IInputArray, VectorOfVectorOfDMatch, Single, VectorOfGpuMat, Boolean)

DescriptorMatcherRadiusMatch Method (IInputArray, VectorOfVectorOfDMatch, Single, VectorOfGpuMat, Boolean)

http://www.emgu.com
For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RadiusMatch(
    IInputArray queryDescriptors,
    VectorOfVectorOfDMatch matches,
    float maxDistance,
    VectorOfGpuMat masks = null,
    bool compactResult = false
)
Public Sub RadiusMatch (
    queryDescriptors As IInputArray,
    matches As VectorOfVectorOfDMatch,
    maxDistance As Single,
    Optional masks As VectorOfGpuMat = Nothing,
    Optional compactResult As Boolean = false
)
public:
void RadiusMatch(
    IInputArray^ queryDescriptors,
    VectorOfVectorOfDMatch^ matches,
    float maxDistance,
    VectorOfGpuMat^ masks = nullptr,
    bool compactResult = false
)
member RadiusMatch :
        queryDescriptors : IInputArray *
        matches : VectorOfVectorOfDMatch *
        maxDistance : float32 *
        ?masks : VectorOfGpuMat *
        ?compactResult : bool
(* Defaults:
        let _masks = defaultArg masks null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Found matches.
maxDistance
Type: SystemSingle
Threshold for the distance between matched descriptors. Distance means here metric distance (e.g. Hamming distance), not the distance between coordinates (which is measured in Pixels)!
masks (Optional)
Type: Emgu.CV.CudaVectorOfGpuMat
Mask specifying permissible matches between an input query and train matrices of descriptors.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
RadiusMatch Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.RadiusMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean)

DescriptorMatcherRadiusMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean)

http://www.emgu.com
For each query descriptor, finds the training descriptors not farther than the specified distance (blocking version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RadiusMatch(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    VectorOfVectorOfDMatch matches,
    float maxDistance,
    IInputArray mask = null,
    bool compactResult = false
)
Public Sub RadiusMatch (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As VectorOfVectorOfDMatch,
    maxDistance As Single,
    Optional mask As IInputArray = Nothing,
    Optional compactResult As Boolean = false
)
public:
void RadiusMatch(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    VectorOfVectorOfDMatch^ matches,
    float maxDistance,
    IInputArray^ mask = nullptr,
    bool compactResult = false
)
member RadiusMatch :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : VectorOfVectorOfDMatch *
        maxDistance : float32 *
        ?mask : IInputArray *
        ?compactResult : bool
(* Defaults:
        let _mask = defaultArg mask null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Found matches.
maxDistance
Type: SystemSingle
Threshold for the distance between matched descriptors. Distance means here metric distance (e.g. Hamming distance), not the distance between coordinates (which is measured in Pixels)!
mask (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
RadiusMatch Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.RadiusMatchAsync Method

DescriptorMatcherRadiusMatchAsync Method

Overload List
 | Name | Description
Public method | RadiusMatchAsync(IInputArray, IOutputArray, Single, VectorOfGpuMat, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).
Public method | RadiusMatchAsync(IInputArray, IInputArray, IOutputArray, Single, IInputArray, Stream) | For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.RadiusMatchAsync Method (IInputArray, IOutputArray, Single, VectorOfGpuMat, Stream)

DescriptorMatcherRadiusMatchAsync Method (IInputArray, IOutputArray, Single, VectorOfGpuMat, Stream)

http://www.emgu.com
For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RadiusMatchAsync(
    IInputArray queryDescriptors,
    IOutputArray matches,
    float maxDistance,
    VectorOfGpuMat masks,
    Stream stream
)
Public Sub RadiusMatchAsync (
    queryDescriptors As IInputArray,
    matches As IOutputArray,
    maxDistance As Single,
    masks As VectorOfGpuMat,
    stream As Stream
)
public:
void RadiusMatchAsync(
    IInputArray^ queryDescriptors,
    IOutputArray^ matches,
    float maxDistance,
    VectorOfGpuMat^ masks,
    Stream^ stream
)
member RadiusMatchAsync :
        queryDescriptors : IInputArray *
        matches : IOutputArray *
        maxDistance : float32 *
        masks : VectorOfGpuMat *
        stream : Stream -> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
matches
Type: Emgu.CVIOutputArray
Matches array stored in GPU memory. Internal representation is not defined.
maxDistance
Type: SystemSingle
Threshold for the distance between matched descriptors. Distance means here metric distance (e.g. Hamming distance), not the distance between coordinates (which is measured in Pixels)!
masks
Type: Emgu.CV.CudaVectorOfGpuMat
Mask specifying permissible matches between an input query and train matrices of descriptors.
stream
Type: Emgu.CV.CudaStream
CUDA stream.
See Also

Reference

DescriptorMatcher Class
RadiusMatchAsync Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.RadiusMatchAsync Method (IInputArray, IInputArray, IOutputArray, Single, IInputArray, Stream)

DescriptorMatcherRadiusMatchAsync Method (IInputArray, IInputArray, IOutputArray, Single, IInputArray, Stream)

http://www.emgu.com
For each query descriptor, finds the training descriptors not farther than the specified distance (asynchronous version).

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RadiusMatchAsync(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    IOutputArray matches,
    float maxDistance,
    IInputArray mask = null,
    Stream stream = null
)
Public Sub RadiusMatchAsync (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As IOutputArray,
    maxDistance As Single,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
void RadiusMatchAsync(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    IOutputArray^ matches,
    float maxDistance,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
member RadiusMatchAsync :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : IOutputArray *
        maxDistance : float32 *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CVIOutputArray
Matches array stored in GPU memory. Internal representation is not defined.
maxDistance
Type: SystemSingle
Threshold for the distance between matched descriptors. Distance means here metric distance (e.g. Hamming distance), not the distance between coordinates (which is measured in Pixels)!
mask (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
stream (Optional)
Type: Emgu.CV.CudaStream
CUDA stream.
See Also

Reference

DescriptorMatcher Class
RadiusMatchAsync Overload
Emgu.CV.Cuda Namespace


DescriptorMatcher.RadiusMatchConvert Method

DescriptorMatcherRadiusMatchConvert Method

Converts matches array from internal representation to standard matches vector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RadiusMatchConvert(
    IInputArray gpuMatches,
    VectorOfVectorOfDMatch matches,
    bool compactResult
)
Public Sub RadiusMatchConvert (
    gpuMatches As IInputArray,
    matches As VectorOfVectorOfDMatch,
    compactResult As Boolean
)
public:
void RadiusMatchConvert(
    IInputArray^ gpuMatches,
    VectorOfVectorOfDMatch^ matches,
    bool compactResult
)
member RadiusMatchConvert :
        gpuMatches : IInputArray *
        matches : VectorOfVectorOfDMatch *
        compactResult : bool -> unit

Parameters

gpuMatches
Type: Emgu.CVIInputArray
Matches, returned from DescriptorMatcher.RadiusMatchAsync.
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Vector of DMatch objects.
compactResult
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher.Train Method

DescriptorMatcherTrain Method

Trains a descriptor matcher.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Train()
Public Sub Train
public:
void Train()
member Train : unit -> unit
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher Fields

The DescriptorMatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithmPtr | Pointer to the native cv::Algorithm
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


DescriptorMatcher._algorithmPtr Field

DescriptorMatcher_algorithmPtr Field

Pointer to the native cv::Algorithm

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _algorithmPtr
Protected _algorithmPtr As IntPtr
protected:
IntPtr _algorithmPtr
val mutable _algorithmPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Cuda Namespace


Feature2DAsyncExtension Class

Class that contains extension methods for Feature2DAsync
Inheritance Hierarchy
SystemObject
Emgu.CV.CudaFeature2DAsyncExtension

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class Feature2DAsyncExtension
<ExtensionAttribute>
Public NotInheritable Class Feature2DAsyncExtension
[ExtensionAttribute]
public ref class Feature2DAsyncExtension abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type Feature2DAsyncExtension =  class end

The Feature2DAsyncExtension type exposes the following members.

Methods
Name | Description
ComputeAsync | Compute the descriptors on the image from the given keypoint locations.
Convert | Converts keypoints array from internal representation to standard vector.
DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations.
DetectAsync | Detect the features in the image
Top
See Also

Reference

Emgu.CV.Cuda Namespace


Feature2DAsyncExtension Methods

The Feature2DAsyncExtension type exposes the following members.

Methods
Name | Description
ComputeAsync | Compute the descriptors on the image from the given keypoint locations.
Convert | Converts keypoints array from internal representation to standard vector.
DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations.
DetectAsync | Detect the features in the image
Top
See Also

Reference

Feature2DAsyncExtension Class
Emgu.CV.Cuda Namespace


Feature2DAsyncExtension.ComputeAsync Method

Feature2DAsyncExtensionComputeAsync Method

Compute the descriptors on the image from the given keypoint locations.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ComputeAsync(
    this IFeature2DAsync feature2DAsync,
    IInputArray image,
    IOutputArray keypoints,
    IOutputArray descriptors,
    Stream stream = null
)
<ExtensionAttribute>
Public Shared Sub ComputeAsync (
    feature2DAsync As IFeature2DAsync,
    image As IInputArray,
    keypoints As IOutputArray,
    descriptors As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
[ExtensionAttribute]
static void ComputeAsync(
    IFeature2DAsync^ feature2DAsync,
    IInputArray^ image,
    IOutputArray^ keypoints,
    IOutputArray^ descriptors,
    Stream^ stream = nullptr
)
[<ExtensionAttribute>]
static member ComputeAsync :
        feature2DAsync : IFeature2DAsync *
        image : IInputArray *
        keypoints : IOutputArray *
        descriptors : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

feature2DAsync
Type: Emgu.CV.CudaIFeature2DAsync
The Feature2DAsync object
image
Type: Emgu.CVIInputArray
The image to compute descriptors from
keypoints
Type: Emgu.CVIOutputArray
The keypoints where the descriptor computation is perfromed
descriptors
Type: Emgu.CVIOutputArray
The descriptors from the given keypoints
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IFeature2DAsync. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Feature2DAsyncExtension Class
Emgu.CV.Cuda Namespace


Feature2DAsyncExtension.Convert Method

Feature2DAsyncExtensionConvert Method

Converts keypoints array from internal representation to standard vector.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Convert(
    this IFeature2DAsync feature2DAsync,
    IInputArray gpuKeypoints,
    VectorOfKeyPoint keypoints
)
<ExtensionAttribute>
Public Shared Sub Convert (
    feature2DAsync As IFeature2DAsync,
    gpuKeypoints As IInputArray,
    keypoints As VectorOfKeyPoint
)
public:
[ExtensionAttribute]
static void Convert(
    IFeature2DAsync^ feature2DAsync,
    IInputArray^ gpuKeypoints,
    VectorOfKeyPoint^ keypoints
)
[<ExtensionAttribute>]
static member Convert :
        feature2DAsync : IFeature2DAsync *
        gpuKeypoints : IInputArray *
        keypoints : VectorOfKeyPoint -> unit

Parameters

feature2DAsync
Type: Emgu.CV.CudaIFeature2DAsync
The Feature2DAsync object
gpuKeypoints
Type: Emgu.CVIInputArray
GpuMat representation of the keypoints.
keypoints
Type: Emgu.CV.UtilVectorOfKeyPoint
Vector of keypoints

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IFeature2DAsync. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Feature2DAsyncExtension Class
Emgu.CV.Cuda Namespace


Feature2DAsyncExtension.DetectAndComputeAsync Method

Feature2DAsyncExtensionDetectAndComputeAsync Method

Detect keypoints in an image and compute the descriptors on the image from the keypoint locations.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DetectAndComputeAsync(
    this IFeature2DAsync feature2DAsync,
    IInputArray image,
    IInputArray mask,
    IOutputArray keyPoints,
    IOutputArray descriptors,
    bool useProvidedKeyPoints,
    Stream stream = null
)
<ExtensionAttribute>
Public Shared Sub DetectAndComputeAsync (
    feature2DAsync As IFeature2DAsync,
    image As IInputArray,
    mask As IInputArray,
    keyPoints As IOutputArray,
    descriptors As IOutputArray,
    useProvidedKeyPoints As Boolean,
    Optional stream As Stream = Nothing
)
public:
[ExtensionAttribute]
static void DetectAndComputeAsync(
    IFeature2DAsync^ feature2DAsync,
    IInputArray^ image,
    IInputArray^ mask,
    IOutputArray^ keyPoints,
    IOutputArray^ descriptors,
    bool useProvidedKeyPoints,
    Stream^ stream = nullptr
)
[<ExtensionAttribute>]
static member DetectAndComputeAsync :
        feature2DAsync : IFeature2DAsync *
        image : IInputArray *
        mask : IInputArray *
        keyPoints : IOutputArray *
        descriptors : IOutputArray *
        useProvidedKeyPoints : bool *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

feature2DAsync
Type: Emgu.CV.CudaIFeature2DAsync
The Feature2DAsync object
image
Type: Emgu.CVIInputArray
The image
mask
Type: Emgu.CVIInputArray
The optional mask, can be null if not needed
keyPoints
Type: Emgu.CVIOutputArray
The detected keypoints will be stored in this vector
descriptors
Type: Emgu.CVIOutputArray
The descriptors from the keypoints
useProvidedKeyPoints
Type: SystemBoolean
If true, the method will skip the detection phase and will compute descriptors for the provided keypoints
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IFeature2DAsync. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Feature2DAsyncExtension Class
Emgu.CV.Cuda Namespace


Feature2DAsyncExtension.DetectAsync Method

Feature2DAsyncExtensionDetectAsync Method

Detect the features in the image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DetectAsync(
    this IFeature2DAsync feature2DAsync,
    IInputArray image,
    IOutputArray keypoints,
    IInputArray mask = null,
    Stream stream = null
)
<ExtensionAttribute>
Public Shared Sub DetectAsync (
    feature2DAsync As IFeature2DAsync,
    image As IInputArray,
    keypoints As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
[ExtensionAttribute]
static void DetectAsync(
    IFeature2DAsync^ feature2DAsync,
    IInputArray^ image,
    IOutputArray^ keypoints,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
[<ExtensionAttribute>]
static member DetectAsync :
        feature2DAsync : IFeature2DAsync *
        image : IInputArray *
        keypoints : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

feature2DAsync
Type: Emgu.CV.CudaIFeature2DAsync
The Feature2DAsync object
image
Type: Emgu.CVIInputArray
The image from which the features will be detected from
keypoints
Type: Emgu.CVIOutputArray
The result vector of keypoints
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IFeature2DAsync. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Feature2DAsyncExtension Class
Emgu.CV.Cuda Namespace


GpuMat Class

A GpuMat, use the generic version if possible. The non generic version is good for use as buffer in stream calls.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CudaGpuMat
Emgu.CV.CudaGpuMatTDepth

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GpuMat : UnmanagedObject, IEquatable<GpuMat>,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
Public Class GpuMat
    Inherits UnmanagedObject
    Implements IEquatable(Of GpuMat), IInputOutputArray,
    IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays
public ref class GpuMat : public UnmanagedObject,
    IEquatable<GpuMat^>, IInputOutputArray, IInputArray, IDisposable,
    IOutputArray, IInputArrayOfArrays, IOutputArrayOfArrays
type GpuMat =
    class
        inherit UnmanagedObject
        interface IEquatable<GpuMat>
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The GpuMat type exposes the following members.

Constructors
 | Name | Description
Public method | GpuMat | Create an empty GpuMat
Public method | GpuMat(IInputArray) | Create a GpuMat from an CvArray of the same depth type
Public method | GpuMat(GpuMat, Range, Range) | Create a GpuMat from the specific region of mat. The data is shared between the two GpuMat
Public method | GpuMat(Int32, Int32, DepthType, Int32, Boolean) | Create a GpuMat of the specified size
Top
Properties
 | Name | Description
Public property | Depth | Depth type
Public property | IsContinuous | True if the data is continues
Public property | IsEmpty | True if the matrix is empty
Public property | NumberOfChannels | Number of channels
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the GpuMat size: width == number of columns, height == number of rows
Public property | Type | Get the type of the GpuMat
Top
Methods
 | Name | Description
Public method | Clone | Make a clone of the GpuMat
Public method | Col | Returns a GpuMat corresponding to the ith column of the GpuMat. The data is shared with the current GpuMat.
Public method | ColRange | Returns a GpuMat corresponding to the [startend) columns of the GpuMat. The data is shared with the current GpuMat.
Public method | ConvertTo | This function has several different purposes and thus has several synonyms. It copies one GpuMat to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel GpuMats are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination GpuMat element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate convertTo synonym.
Public method | CopyTo | Copy the source GpuMat to destination GpuMat, using an optional mask.
Public method | Create | allocates new GpuMat data unless the GpuMat already has specified size and type
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this GpuMat (Overrides DisposableObjectDisposeObject.)
Public method | Download | Downloads data from device to host memory.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(GpuMat) | Returns true if the two GpuMat equals
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray
Public method | GetInputOutputArray | Pointer to the InputOutputArray
Public method | GetOutputArray | Pointer to the OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFrom | Makes multi-channel array out of several single-channel arrays
Public method | MinMax | Returns the min / max location and values for the image
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes shape of GpuMat without copying data.
Public method | Row | Returns a GpuMat corresponding to the ith row of the GpuMat. The data is shared with the current GpuMat.
Public method | RowRange | Returns a GpuMat corresponding to the [startend) rows of the GpuMat. The data is shared with the current GpuMat.
Public method | Save | Save the GpuMat to a file
Public method | SetTo | Copies scalar value to every selected element of the destination GpuMat: arr(I)=value if mask(I)!=0
Public method | Split | Split current GpuMat into an array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat
Public method | ToMat | Convert the GpuMat to Mat
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upload | Upload data to GpuMat
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


GpuMat Constructor

Overload List
 | Name | Description
Public method | GpuMat | Create an empty GpuMat
Public method | GpuMat(IInputArray) | Create a GpuMat from an CvArray of the same depth type
Public method | GpuMat(GpuMat, Range, Range) | Create a GpuMat from the specific region of mat. The data is shared between the two GpuMat
Public method | GpuMat(Int32, Int32, DepthType, Int32, Boolean) | Create a GpuMat of the specified size
Top
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat Constructor

Create an empty GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat()
Public Sub New
public:
GpuMat()
new : unit -> GpuMat
See Also

Reference

GpuMat Class
GpuMat Overload
Emgu.CV.Cuda Namespace


GpuMat Constructor (IInputArray)

Create a GpuMat from an CvArray of the same depth type

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat(
    IInputArray arr
)
Public Sub New (
    arr As IInputArray
)
public:
GpuMat(
    IInputArray^ arr
)
new :
        arr : IInputArray -> GpuMat

Parameters

arr
Type: Emgu.CVIInputArray
The CvArray to be converted to GpuMat
See Also

Reference

GpuMat Class
GpuMat Overload
Emgu.CV.Cuda Namespace


GpuMat Constructor (GpuMat, Range, Range)

Create a GpuMat from the specific region of mat. The data is shared between the two GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat(
    GpuMat mat,
    Range rowRange,
    Range colRange
)
Public Sub New (
    mat As GpuMat,
    rowRange As Range,
    colRange As Range
)
public:
GpuMat(
    GpuMat^ mat,
    Range^ rowRange,
    Range^ colRange
)
new :
        mat : GpuMat *
        rowRange : Range *
        colRange : Range -> GpuMat

Parameters

mat
Type: Emgu.CV.CudaGpuMat
The matrix where the region is extracted from
rowRange
Type: Emgu.CV.StructureRange
The row range.
colRange
Type: Emgu.CV.StructureRange
The column range.
See Also

Reference

GpuMat Class
GpuMat Overload
Emgu.CV.Cuda Namespace


GpuMat Constructor (Int32, Int32, DepthType, Int32, Boolean)

Create a GpuMat of the specified size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat(
    int rows,
    int cols,
    DepthType depthType,
    int channels,
    bool continuous = false
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    depthType As DepthType,
    channels As Integer,
    Optional continuous As Boolean = false
)
public:
GpuMat(
    int rows,
    int cols,
    DepthType^ depthType,
    int channels,
    bool continuous = false
)
new :
        rows : int *
        cols : int *
        depthType : DepthType *
        channels : int *
        ?continuous : bool
(* Defaults:
        let _continuous = defaultArg continuous false
*)
-> GpuMat

Parameters

rows
Type: SystemInt32
The number of rows (height)
cols
Type: SystemInt32
The number of columns (width)
depthType
Type: Emgu.CV.CvEnumDepthType
The type of depth
channels
Type: SystemInt32
The number of channels
continuous (Optional)
Type: SystemBoolean
Indicates if the data should be continuous
See Also

Reference

GpuMat Class
GpuMat Overload
Emgu.CV.Cuda Namespace


GpuMat Properties

The GpuMat type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Depth type
Public property | IsContinuous | True if the data is continues
Public property | IsEmpty | True if the matrix is empty
Public property | NumberOfChannels | Number of channels
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the GpuMat size: width == number of columns, height == number of rows
Public property | Type | Get the type of the GpuMat
Top
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Depth Property

GpuMatDepth Property

Depth type

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DepthType Depth { get; }
Public ReadOnly Property Depth As DepthType
    Get
public:
property DepthType^ Depth {
    DepthType^ get ();
}
member Depth : DepthType with get

Property Value

Type: DepthType
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.IsContinuous Property

GpuMatIsContinuous Property

True if the data is continues

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsContinuous { get; }
Public ReadOnly Property IsContinuous As Boolean
    Get
public:
property bool IsContinuous {
    bool get ();
}
member IsContinuous : bool with get

Property Value

Type: Boolean
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.IsEmpty Property

GpuMatIsEmpty Property

True if the matrix is empty

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.NumberOfChannels Property

GpuMatNumberOfChannels Property

Number of channels

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfChannels { get; }
Public ReadOnly Property NumberOfChannels As Integer
    Get
public:
property int NumberOfChannels {
    int get ();
}
member NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Size Property

GpuMatSize Property

Get the GpuMat size: width == number of columns, height == number of rows

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get
public:
property Size^ Size {
    Size^ get ();
}
member Size : Size with get

Property Value

Type: Size
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Type Property

GpuMatType Property

Get the type of the GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Type { get; }
Public ReadOnly Property Type As Integer
    Get
public:
property int Type {
    int get ();
}
member Type : int with get

Property Value

Type: Int32
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat Methods

The GpuMat type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Make a clone of the GpuMat
Public method | Col | Returns a GpuMat corresponding to the ith column of the GpuMat. The data is shared with the current GpuMat.
Public method | ColRange | Returns a GpuMat corresponding to the [startend) columns of the GpuMat. The data is shared with the current GpuMat.
Public method | ConvertTo | This function has several different purposes and thus has several synonyms. It copies one GpuMat to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel GpuMats are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination GpuMat element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate convertTo synonym.
Public method | CopyTo | Copy the source GpuMat to destination GpuMat, using an optional mask.
Public method | Create | allocates new GpuMat data unless the GpuMat already has specified size and type
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this GpuMat (Overrides DisposableObjectDisposeObject.)
Public method | Download | Downloads data from device to host memory.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(GpuMat) | Returns true if the two GpuMat equals
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray
Public method | GetInputOutputArray | Pointer to the InputOutputArray
Public method | GetOutputArray | Pointer to the OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFrom | Makes multi-channel array out of several single-channel arrays
Public method | MinMax | Returns the min / max location and values for the image
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes shape of GpuMat without copying data.
Public method | Row | Returns a GpuMat corresponding to the ith row of the GpuMat. The data is shared with the current GpuMat.
Public method | RowRange | Returns a GpuMat corresponding to the [startend) rows of the GpuMat. The data is shared with the current GpuMat.
Public method | Save | Save the GpuMat to a file
Public method | SetTo | Copies scalar value to every selected element of the destination GpuMat: arr(I)=value if mask(I)!=0
Public method | Split | Split current GpuMat into an array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat
Public method | ToMat | Convert the GpuMat to Mat
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upload | Upload data to GpuMat
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Clone Method

GpuMatClone Method

Make a clone of the GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
Object^ Clone()
member Clone : unit -> Object

Return Value

Type: Object
A clone of the GPU Mat
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Col Method

GpuMatCol Method

Returns a GpuMat corresponding to the ith column of the GpuMat. The data is shared with the current GpuMat.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat Col(
    int i
)
Public Function Col (
    i As Integer
) As GpuMat
public:
GpuMat^ Col(
    int i
)
member Col :
        i : int -> GpuMat

Parameters

i
Type: SystemInt32
The column to be extracted

Return Value

Type: GpuMat
The ith column of the GpuMat
Remarks
The parent GpuMat should never be released before the returned GpuMat that represent the subregion
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.ColRange Method

GpuMatColRange Method

Returns a GpuMat corresponding to the [startend) columns of the GpuMat. The data is shared with the current GpuMat.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat ColRange(
    int start,
    int end
)
Public Function ColRange (
    start As Integer,
    end As Integer
) As GpuMat
public:
GpuMat^ ColRange(
    int start,
    int end
)
member ColRange :
        start : int *
        end : int -> GpuMat

Parameters

start
Type: SystemInt32
The inclusive stating column to be extracted
end
Type: SystemInt32
The exclusive ending column to be extracted

Return Value

Type: GpuMat
The [startend) columns of the GpuMat
Remarks
The parent GpuMat should never be released before the returned GpuMat that represent the subregion
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.ConvertTo Method

GpuMatConvertTo Method

This function has several different purposes and thus has several synonyms. It copies one GpuMat to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel GpuMats are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination GpuMat element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate convertTo synonym.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ConvertTo(
    IOutputArray dst,
    DepthType rtype,
    double scale = 1,
    double shift = 0,
    Stream stream = null
)
Public Sub ConvertTo (
    dst As IOutputArray,
    rtype As DepthType,
    Optional scale As Double = 1,
    Optional shift As Double = 0,
    Optional stream As Stream = Nothing
)
public:
void ConvertTo(
    IOutputArray^ dst,
    DepthType^ rtype,
    double scale = 1,
    double shift = 0,
    Stream^ stream = nullptr
)
member ConvertTo :
        dst : IOutputArray *
        rtype : DepthType *
        ?scale : float *
        ?shift : float *
        ?stream : Stream
(* Defaults:
        let _scale = defaultArg scale 1
        let _shift = defaultArg shift 0
        let _stream = defaultArg stream null
*)
-> unit

Parameters

dst
Type: Emgu.CVIOutputArray
Destination GpuMat
rtype
Type: Emgu.CV.CvEnumDepthType
Result type
scale (Optional)
Type: SystemDouble
Scale factor
shift (Optional)
Type: SystemDouble
Value added to the scaled source GpuMat elements
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or IntPtr.Zero to call the function synchronously (blocking).
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.CopyTo Method

GpuMatCopyTo Method

Copy the source GpuMat to destination GpuMat, using an optional mask.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    IOutputArray dst,
    IInputArray mask = null,
    Stream stream = null
)
Public Sub CopyTo (
    dst As IOutputArray,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
void CopyTo(
    IOutputArray^ dst,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
member CopyTo :
        dst : IOutputArray *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

dst
Type: Emgu.CVIOutputArray
The output array to be copied to
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask, use IntPtr.Zero if not needed.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Create Method

GpuMatCreate Method

allocates new GpuMat data unless the GpuMat already has specified size and type

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Create(
    int rows,
    int cols,
    DepthType depthType,
    int channels
)
Public Sub Create (
    rows As Integer,
    cols As Integer,
    depthType As DepthType,
    channels As Integer
)
public:
void Create(
    int rows,
    int cols,
    DepthType^ depthType,
    int channels
)
member Create :
        rows : int *
        cols : int *
        depthType : DepthType *
        channels : int -> unit

Parameters

rows
Type: SystemInt32
The number of rows
cols
Type: SystemInt32
The number of cols
depthType
Type: Emgu.CV.CvEnumDepthType
The depth type
channels
Type: SystemInt32
The number of channels.
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.DisposeObject Method

GpuMatDisposeObject Method

Release the unmanaged memory associated with this GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Download Method

GpuMatDownload Method

Downloads data from device to host memory.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Download(
    IOutputArray arr,
    Stream stream = null
)
Public Sub Download (
    arr As IOutputArray,
    Optional stream As Stream = Nothing
)
public:
void Download(
    IOutputArray^ arr,
    Stream^ stream = nullptr
)
member Download :
        arr : IOutputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

arr
Type: Emgu.CVIOutputArray
The destination CvArray where the GpuMat data will be downloaded to.
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Equals Method

GpuMatEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(GpuMat) | Returns true if the two GpuMat equals
Top
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Equals Method (GpuMat)

GpuMatEquals Method (GpuMat)

http://www.emgu.com
Returns true if the two GpuMat equals

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    GpuMat other
)
Public Function Equals (
    other As GpuMat
) As Boolean
public:
virtual bool Equals(
    GpuMat^ other
) sealed
abstract Equals :
        other : GpuMat -> bool
override Equals :
        other : GpuMat -> bool

Parameters

other
Type: Emgu.CV.CudaGpuMat
The other GpuMat to be compares with

Return Value

Type: Boolean
True if the two GpuMat equals

Implements

IEquatableTEquals(T)
See Also

Reference

GpuMat Class
Equals Overload
Emgu.CV.Cuda Namespace


GpuMat.GetData Method

GpuMatGetData Method

Get a copy of the data values as an array

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Array GetData(
    bool jagged = true
)
Public Function GetData (
    Optional jagged As Boolean = true
) As Array
public:
Array^ GetData(
    bool jagged = true
)
member GetData :
        ?jagged : bool
(* Defaults:
        let _jagged = defaultArg jagged true
*)
-> Array

Parameters

jagged (Optional)
Type: SystemBoolean
If true, a jagged array will returned. Otherwise it will return a regular array.

Return Value

Type: Array
a copy of the data values as an array
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.GetInputArray Method

GpuMatGetInputArray Method

Pointer to the InputArray

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.GetInputOutputArray Method

GpuMatGetInputOutputArray Method

Pointer to the InputOutputArray

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.GetOutputArray Method

GpuMatGetOutputArray Method

Pointer to the OutputArray

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.MergeFrom Method

GpuMatMergeFrom Method

Makes multi-channel array out of several single-channel arrays

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MergeFrom(
    GpuMat[] gpuMats,
    Stream stream = null
)
Public Sub MergeFrom (
    gpuMats As GpuMat(),
    Optional stream As Stream = Nothing
)
public:
void MergeFrom(
    array<GpuMat^>^ gpuMats,
    Stream^ stream = nullptr
)
member MergeFrom :
        gpuMats : GpuMat[] *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

gpuMats
Type: Emgu.CV.CudaGpuMat
An array of single channel GpuMat where each item in the array represent a single channel of the GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.MinMax Method

GpuMatMinMax Method

Returns the min / max location and values for the image

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void MinMax(
    out double[] minValues,
    out double[] maxValues,
    out Point[] minLocations,
    out Point[] maxLocations
)
Public Sub MinMax (
    <OutAttribute> ByRef minValues As Double(),
    <OutAttribute> ByRef maxValues As Double(),
    <OutAttribute> ByRef minLocations As Point(),
    <OutAttribute> ByRef maxLocations As Point()
)
public:
void MinMax(
    [OutAttribute] array<double>^% minValues,
    [OutAttribute] array<double>^% maxValues,
    [OutAttribute] array<Point^>^% minLocations,
    [OutAttribute] array<Point^>^% maxLocations
)
member MinMax :
        minValues : float[] byref *
        maxValues : float[] byref *
        minLocations : Point[] byref *
        maxLocations : Point[] byref -> unit

Parameters

minValues
Type: SystemDouble
The minimum values for each channel
maxValues
Type: SystemDouble
The maximum values for each channel
minLocations
Type: System.DrawingPoint
The minimum locations for each channel
maxLocations
Type: System.DrawingPoint
The maximum locations for each channel
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Reshape Method

GpuMatReshape Method

Changes shape of GpuMat without copying data.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat Reshape(
    int newCn,
    int newRows = 0
)
Public Function Reshape (
    newCn As Integer,
    Optional newRows As Integer = 0
) As GpuMat
public:
GpuMat^ Reshape(
    int newCn,
    int newRows = 0
)
member Reshape :
        newCn : int *
        ?newRows : int
(* Defaults:
        let _newRows = defaultArg newRows 0
*)
-> GpuMat

Parameters

newCn
Type: SystemInt32
New number of channels. newCn = 0 means that the number of channels remains unchanged.
newRows (Optional)
Type: SystemInt32
New number of rows. newRows = 0 means that the number of rows remains unchanged unless it needs to be changed according to newCn value.

Return Value

Type: GpuMat
A GpuMat of different shape
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Row Method

GpuMatRow Method

Returns a GpuMat corresponding to the ith row of the GpuMat. The data is shared with the current GpuMat.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat Row(
    int i
)
Public Function Row (
    i As Integer
) As GpuMat
public:
GpuMat^ Row(
    int i
)
member Row :
        i : int -> GpuMat

Parameters

i
Type: SystemInt32
The row to be extracted

Return Value

Type: GpuMat
The ith row of the GpuMat
Remarks
The parent GpuMat should never be released before the returned GpuMat that represent the subregion
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.RowRange Method

GpuMatRowRange Method

Returns a GpuMat corresponding to the [startend) rows of the GpuMat. The data is shared with the current GpuMat.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat RowRange(
    int start,
    int end
)
Public Function RowRange (
    start As Integer,
    end As Integer
) As GpuMat
public:
GpuMat^ RowRange(
    int start,
    int end
)
member RowRange :
        start : int *
        end : int -> GpuMat

Parameters

start
Type: SystemInt32
The inclusive stating row to be extracted
end
Type: SystemInt32
The exclusive ending row to be extracted

Return Value

Type: GpuMat
The [startend) rows of the GpuMat
Remarks
The parent GpuMat should never be released before the returned GpuMat that represent the subregion
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Save Method

GpuMatSave Method

Save the GpuMat to a file

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Save(
    string fileName
)
Public Sub Save (
    fileName As String
)
public:
void Save(
    String^ fileName
)
member Save :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The file name
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.SetTo Method

GpuMatSetTo Method

Copies scalar value to every selected element of the destination GpuMat: arr(I)=value if mask(I)!=0

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTo(
    MCvScalar value,
    IInputArray mask = null,
    Stream stream = null
)
Public Sub SetTo (
    value As MCvScalar,
    Optional mask As IInputArray = Nothing,
    Optional stream As Stream = Nothing
)
public:
void SetTo(
    MCvScalar^ value,
    IInputArray^ mask = nullptr,
    Stream^ stream = nullptr
)
member SetTo :
        value : MCvScalar *
        ?mask : IInputArray *
        ?stream : Stream
(* Defaults:
        let _mask = defaultArg mask null
        let _stream = defaultArg stream null
*)
-> unit

Parameters

value
Type: Emgu.CV.StructureMCvScalar
Fill value
mask (Optional)
Type: Emgu.CVIInputArray
Operation mask, 8-bit single channel GpuMat; specifies elements of destination GpuMat to be changed. Can be IntPtr.Zero if not used
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Split Method

GpuMatSplit Method

Split current GpuMat into an array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat[] Split(
    Stream stream = null
)
Public Function Split (
    Optional stream As Stream = Nothing
) As GpuMat()
public:
array<GpuMat^>^ Split(
    Stream^ stream = nullptr
)
member Split :
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> GpuMat[]

Parameters

stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).

Return Value

Type: GpuMat
An array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.ToMat Method

GpuMatToMat Method

Convert the GpuMat to Mat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat ToMat()
Public Function ToMat As Mat
public:
Mat^ ToMat()
member ToMat : unit -> Mat

Return Value

Type: Mat
The Mat that contains the same data as this GpuMat
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat.Upload Method

GpuMatUpload Method

Upload data to GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Upload(
    IInputArray arr,
    Stream stream = null
)
Public Sub Upload (
    arr As IInputArray,
    Optional stream As Stream = Nothing
)
public:
void Upload(
    IInputArray^ arr,
    Stream^ stream = nullptr
)
member Upload :
        arr : IInputArray *
        ?stream : Stream
(* Defaults:
        let _stream = defaultArg stream null
*)
-> unit

Parameters

arr
Type: Emgu.CVIInputArray
The CvArray to be uploaded to GpuMat
stream (Optional)
Type: Emgu.CV.CudaStream
Use a Stream to call the function asynchronously (non-blocking) or null to call the function synchronously (blocking).
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat Fields

The GpuMat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GpuMat Class
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Class

GpuMatTDepth Class

Similar to CvArray but use GPU for processing
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CudaGpuMat
Emgu.CV.CudaGpuMatTDepth
Emgu.CV.CudaCudaImageTColor, TDepth

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GpuMat<TDepth> : GpuMat
where TDepth : new()

Public Class GpuMat(Of TDepth As New)
    Inherits GpuMat
generic<typename TDepth>
where TDepth : gcnew()
public ref class GpuMat : public GpuMat
type GpuMat<'TDepth when 'TDepth : new()> =
    class
        inherit GpuMat
    end

Type Parameters

TDepth
The type of element in the matrix

The GpuMatTDepth type exposes the following members.

Constructors
 | Name | Description
Public method | GpuMatTDepth | Create an empty GpuMat
Public method | GpuMatTDepth(IInputArray) | Create a GpuMat from an CvArray of the same depth type
Public method | GpuMatTDepth(Size, Int32) | Create a GpuMat of the specified size
Public method | GpuMatTDepth(Int32, Int32, Int32, Boolean) | Create a GpuMat of the specified size
Top
Properties
 | Name | Description
Public property | Depth | Depth type (Inherited from GpuMat.)
Public property | IsContinuous | True if the data is continues (Inherited from GpuMat.)
Public property | IsEmpty | True if the matrix is empty (Inherited from GpuMat.)
Public property | NumberOfChannels | Number of channels (Inherited from GpuMat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the GpuMat size: width == number of columns, height == number of rows (Inherited from GpuMat.)
Public property | Type | Get the type of the GpuMat (Inherited from GpuMat.)
Top
Methods
 | Name | Description
Public method | Clone | Make a clone of the GpuMat (Inherited from GpuMat.)
Public method | Col | Returns a GpuMat corresponding to the ith column of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | ColRange | Returns a GpuMat corresponding to the [startend) columns of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | ConvertTo | This function has several different purposes and thus has several synonyms. It copies one GpuMat to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel GpuMats are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination GpuMat element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate convertTo synonym. (Inherited from GpuMat.)
Public method | CopyTo | Copy the source GpuMat to destination GpuMat, using an optional mask. (Inherited from GpuMat.)
Public method | Create | allocates new GpuMat data unless the GpuMat already has specified size and type (Inherited from GpuMat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this GpuMat (Inherited from GpuMat.)
Public method | Download | Downloads data from device to host memory. (Inherited from GpuMat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(GpuMat) | Returns true if the two GpuMat equals (Inherited from GpuMat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array (Inherited from GpuMat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from GpuMat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from GpuMat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from GpuMat.)
Public method | GetSubRect | Returns a GpuMat corresponding to a specified rectangle of the current GpuMat. The data is shared with the current matrix. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFrom | Makes multi-channel array out of several single-channel arrays (Inherited from GpuMat.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from GpuMat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes shape of GpuMat without copying data. (Inherited from GpuMat.)
Public method | Row | Returns a GpuMat corresponding to the ith row of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | RowRange | Returns a GpuMat corresponding to the [startend) rows of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | Save | Save the GpuMat to a file (Inherited from GpuMat.)
Public method | SetTo | Copies scalar value to every selected element of the destination GpuMat: arr(I)=value if mask(I)!=0 (Inherited from GpuMat.)
Public method | Split | Split current GpuMat into an array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat (Inherited from GpuMat.)
Public method | ToMat | Convert the GpuMat to Mat (Inherited from GpuMat.)
Public method | ToMatrix | Convert this GpuMat to a Matrix
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upload | Upload data to GpuMat (Inherited from GpuMat.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


GpuMat(TDepth) Constructor

GpuMatTDepth Constructor

Overload List
 | Name | Description
Public method | GpuMatTDepth | Create an empty GpuMat
Public method | GpuMatTDepth(IInputArray) | Create a GpuMat from an CvArray of the same depth type
Public method | GpuMatTDepth(Size, Int32) | Create a GpuMat of the specified size
Public method | GpuMatTDepth(Int32, Int32, Int32, Boolean) | Create a GpuMat of the specified size
Top
See Also

Reference

GpuMatTDepth Class
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Constructor

GpuMatTDepth Constructor

Create an empty GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat()
Public Sub New
public:
GpuMat()
new : unit -> GpuMat
See Also

Reference

GpuMatTDepth Class
GpuMatTDepth Overload
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Constructor (IInputArray)

GpuMatTDepth Constructor (IInputArray)

http://www.emgu.com
Create a GpuMat from an CvArray of the same depth type

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat(
    IInputArray arr
)
Public Sub New (
    arr As IInputArray
)
public:
GpuMat(
    IInputArray^ arr
)
new :
        arr : IInputArray -> GpuMat

Parameters

arr
Type: Emgu.CVIInputArray
The CvArry to be converted to GpuMat
See Also

Reference

GpuMatTDepth Class
GpuMatTDepth Overload
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Constructor (Size, Int32)

GpuMatTDepth Constructor (Size, Int32)

http://www.emgu.com
Create a GpuMat of the specified size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat(
    Size size,
    int channels
)
Public Sub New (
    size As Size,
    channels As Integer
)
public:
GpuMat(
    Size^ size,
    int channels
)
new :
        size : Size *
        channels : int -> GpuMat

Parameters

size
Type: System.DrawingSize
The size of the GpuMat
channels
Type: SystemInt32
The number of channels
See Also

Reference

GpuMatTDepth Class
GpuMatTDepth Overload
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Constructor (Int32, Int32, Int32, Boolean)

GpuMatTDepth Constructor (Int32, Int32, Int32, Boolean)

http://www.emgu.com
Create a GpuMat of the specified size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat(
    int rows,
    int cols,
    int channels,
    bool continuous = false
)
Public Sub New (
    rows As Integer,
    cols As Integer,
    channels As Integer,
    Optional continuous As Boolean = false
)
public:
GpuMat(
    int rows,
    int cols,
    int channels,
    bool continuous = false
)
new :
        rows : int *
        cols : int *
        channels : int *
        ?continuous : bool
(* Defaults:
        let _continuous = defaultArg continuous false
*)
-> GpuMat

Parameters

rows
Type: SystemInt32
The number of rows (height)
cols
Type: SystemInt32
The number of columns (width)
channels
Type: SystemInt32
The number of channels
continuous (Optional)
Type: SystemBoolean
Indicates if the data should be continuous
See Also

Reference

GpuMatTDepth Class
GpuMatTDepth Overload
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Properties

GpuMatTDepth Properties

The GpuMatTDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Depth type (Inherited from GpuMat.)
Public property | IsContinuous | True if the data is continues (Inherited from GpuMat.)
Public property | IsEmpty | True if the matrix is empty (Inherited from GpuMat.)
Public property | NumberOfChannels | Number of channels (Inherited from GpuMat.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the GpuMat size: width == number of columns, height == number of rows (Inherited from GpuMat.)
Public property | Type | Get the type of the GpuMat (Inherited from GpuMat.)
Top
See Also

Reference

GpuMatTDepth Class
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Methods

GpuMatTDepth Methods

The GpuMatTDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Make a clone of the GpuMat (Inherited from GpuMat.)
Public method | Col | Returns a GpuMat corresponding to the ith column of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | ColRange | Returns a GpuMat corresponding to the [startend) columns of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | ConvertTo | This function has several different purposes and thus has several synonyms. It copies one GpuMat to another with optional scaling, which is performed first, and/or optional type conversion, performed after: dst(I)=src(I)*scale + (shift,shift,...) All the channels of multi-channel GpuMats are processed independently. The type conversion is done with rounding and saturation, that is if a result of scaling + conversion can not be represented exactly by a value of destination GpuMat element type, it is set to the nearest representable value on the real axis. In case of scale=1, shift=0 no prescaling is done. This is a specially optimized case and it has the appropriate convertTo synonym. (Inherited from GpuMat.)
Public method | CopyTo | Copy the source GpuMat to destination GpuMat, using an optional mask. (Inherited from GpuMat.)
Public method | Create | allocates new GpuMat data unless the GpuMat already has specified size and type (Inherited from GpuMat.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this GpuMat (Inherited from GpuMat.)
Public method | Download | Downloads data from device to host memory. (Inherited from GpuMat.)
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(GpuMat) | Returns true if the two GpuMat equals (Inherited from GpuMat.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetData | Get a copy of the data values as an array (Inherited from GpuMat.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Pointer to the InputArray (Inherited from GpuMat.)
Public method | GetInputOutputArray | Pointer to the InputOutputArray (Inherited from GpuMat.)
Public method | GetOutputArray | Pointer to the OutputArray (Inherited from GpuMat.)
Public method | GetSubRect | Returns a GpuMat corresponding to a specified rectangle of the current GpuMat. The data is shared with the current matrix. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFrom | Makes multi-channel array out of several single-channel arrays (Inherited from GpuMat.)
Public method | MinMax | Returns the min / max location and values for the image (Inherited from GpuMat.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Reshape | Changes shape of GpuMat without copying data. (Inherited from GpuMat.)
Public method | Row | Returns a GpuMat corresponding to the ith row of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | RowRange | Returns a GpuMat corresponding to the [startend) rows of the GpuMat. The data is shared with the current GpuMat. (Inherited from GpuMat.)
Public method | Save | Save the GpuMat to a file (Inherited from GpuMat.)
Public method | SetTo | Copies scalar value to every selected element of the destination GpuMat: arr(I)=value if mask(I)!=0 (Inherited from GpuMat.)
Public method | Split | Split current GpuMat into an array of single channel GpuMat where each element in the array represent a single channel of the original GpuMat (Inherited from GpuMat.)
Public method | ToMat | Convert the GpuMat to Mat (Inherited from GpuMat.)
Public method | ToMatrix | Convert this GpuMat to a Matrix
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upload | Upload data to GpuMat (Inherited from GpuMat.)
Top
See Also

Reference

GpuMatTDepth Class
Emgu.CV.Cuda Namespace


GpuMat(TDepth).GetSubRect Method

GpuMatTDepthGetSubRect Method

Returns a GpuMat corresponding to a specified rectangle of the current GpuMat. The data is shared with the current matrix. In other words, it allows the user to treat a rectangular part of input array as a stand-alone array.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat<TDepth> GetSubRect(
    Rectangle region
)
Public Function GetSubRect (
    region As Rectangle
) As GpuMat(Of TDepth)
public:
GpuMat<TDepth>^ GetSubRect(
    Rectangle^ region
)
member GetSubRect :
        region : Rectangle -> GpuMat<'TDepth>

Parameters

region
Type: System.DrawingRectangle
Zero-based coordinates of the rectangle of interest.

Return Value

Type: GpuMat TDepth
A GpuMat that represent the region of the current matrix.
Remarks
The parent GpuMat should never be released before the returned GpuMat the represent the subregion
See Also

Reference

GpuMatTDepth Class
Emgu.CV.Cuda Namespace


GpuMat(TDepth).ToMatrix Method

GpuMatTDepthToMatrix Method

Convert this GpuMat to a Matrix

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Matrix<TDepth> ToMatrix()
Public Function ToMatrix As Matrix(Of TDepth)
public:
Matrix<TDepth>^ ToMatrix()
member ToMatrix : unit -> Matrix<'TDepth>

Return Value

Type: Matrix TDepth
The matrix that contains the same values as this GpuMat
See Also

Reference

GpuMatTDepth Class
Emgu.CV.Cuda Namespace


GpuMat(TDepth) Fields

GpuMatTDepth Fields

The GpuMatTDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GpuMatTDepth Class
Emgu.CV.Cuda Namespace


ICudaDenseOpticalFlow Interface

Cuda Dense Optical flow

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface ICudaDenseOpticalFlow : IAlgorithm
Public Interface ICudaDenseOpticalFlow
    Inherits IAlgorithm
public interface class ICudaDenseOpticalFlow : IAlgorithm
type ICudaDenseOpticalFlow =
    interface
        interface IAlgorithm
    end

The ICudaDenseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | DenseOpticalFlowPtr | Pointer to cv::cuda::denseOpticalFlow
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


ICudaDenseOpticalFlow Properties

The ICudaDenseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | DenseOpticalFlowPtr | Pointer to cv::cuda::denseOpticalFlow
Top
See Also

Reference

ICudaDenseOpticalFlow Interface
Emgu.CV.Cuda Namespace


ICudaDenseOpticalFlow.DenseOpticalFlowPtr Property

ICudaDenseOpticalFlowDenseOpticalFlowPtr Property

Pointer to cv::cuda::denseOpticalFlow

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr DenseOpticalFlowPtr { get; }
ReadOnly Property DenseOpticalFlowPtr As IntPtr
    Get
property IntPtr DenseOpticalFlowPtr {
    IntPtr get ();
}
abstract DenseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

ICudaDenseOpticalFlow Interface
Emgu.CV.Cuda Namespace


ICudaDenseOpticalFlow Methods

The ICudaDenseOpticalFlow type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a dense optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

ICudaDenseOpticalFlow Interface
Emgu.CV.Cuda Namespace


ICudaSparseOpticalFlow Interface

Interface to provide access to the cuda::SparseOpticalFlow class.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface ICudaSparseOpticalFlow : IAlgorithm
Public Interface ICudaSparseOpticalFlow
    Inherits IAlgorithm
public interface class ICudaSparseOpticalFlow : IAlgorithm
type ICudaSparseOpticalFlow =
    interface
        interface IAlgorithm
    end

The ICudaSparseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SparseOpticalFlowPtr | Pointer the the native cuda::sparseOpticalFlow object.
Top
Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


ICudaSparseOpticalFlow Properties

The ICudaSparseOpticalFlow type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SparseOpticalFlowPtr | Pointer the the native cuda::sparseOpticalFlow object.
Top
See Also

Reference

ICudaSparseOpticalFlow Interface
Emgu.CV.Cuda Namespace


ICudaSparseOpticalFlow.SparseOpticalFlowPtr Property

ICudaSparseOpticalFlowSparseOpticalFlowPtr Property

Pointer the the native cuda::sparseOpticalFlow object.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr SparseOpticalFlowPtr { get; }
ReadOnly Property SparseOpticalFlowPtr As IntPtr
    Get
property IntPtr SparseOpticalFlowPtr {
    IntPtr get ();
}
abstract SparseOpticalFlowPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

ICudaSparseOpticalFlow Interface
Emgu.CV.Cuda Namespace


ICudaSparseOpticalFlow Methods

The ICudaSparseOpticalFlow type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Calc | Calculates a sparse optical flow. (Defined by CudaInvoke.)
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

ICudaSparseOpticalFlow Interface
Emgu.CV.Cuda Namespace


IFeature2DAsync Interface

The feature 2D base class

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IFeature2DAsync
Public Interface IFeature2DAsync
public interface class IFeature2DAsync
type IFeature2DAsync =  interface end

The IFeature2DAsync type exposes the following members.

Properties
 | Name | Description
Public property | Feature2DAsyncPtr | Get the pointer to the Feature2DAsync object
Top
Extension Methods
 | Name | Description
Public Extension Method | ComputeAsync | Compute the descriptors on the image from the given keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | Convert | Converts keypoints array from internal representation to standard vector. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAsync | Detect the features in the image (Defined by Feature2DAsyncExtension.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


IFeature2DAsync Properties

The IFeature2DAsync type exposes the following members.

Properties
 | Name | Description
Public property | Feature2DAsyncPtr | Get the pointer to the Feature2DAsync object
Top
See Also

Reference

IFeature2DAsync Interface
Emgu.CV.Cuda Namespace


IFeature2DAsync.Feature2DAsyncPtr Property

IFeature2DAsyncFeature2DAsyncPtr Property

Get the pointer to the Feature2DAsync object

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr Feature2DAsyncPtr { get; }
ReadOnly Property Feature2DAsyncPtr As IntPtr
    Get
property IntPtr Feature2DAsyncPtr {
    IntPtr get ();
}
abstract Feature2DAsyncPtr : IntPtr with get

Return Value

Type: IntPtr
The pointer to the Feature2DAsync object
See Also

Reference

IFeature2DAsync Interface
Emgu.CV.Cuda Namespace


IFeature2DAsync Methods

The IFeature2DAsync type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ComputeAsync | Compute the descriptors on the image from the given keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | Convert | Converts keypoints array from internal representation to standard vector. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAndComputeAsync | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Defined by Feature2DAsyncExtension.)
Public Extension Method | DetectAsync | Detect the features in the image (Defined by Feature2DAsyncExtension.)
Top
See Also

Reference

IFeature2DAsync Interface
Emgu.CV.Cuda Namespace


MedianFilter Class

median filtering for each point of the source image.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaMedianFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MedianFilter : CudaFilter
Public Class MedianFilter
    Inherits CudaFilter
public ref class MedianFilter : public CudaFilter
type MedianFilter =
    class
        inherit CudaFilter
    end

The MedianFilter type exposes the following members.

Constructors
 | Name | Description
Public method | MedianFilter | Create a median filter
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


MedianFilter Constructor

Create a median filter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MedianFilter(
    DepthType srcDepth,
    int srcChannels,
    int windowSize,
    int partition = 128
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    windowSize As Integer,
    Optional partition As Integer = 128
)
public:
MedianFilter(
    DepthType^ srcDepth,
    int srcChannels,
    int windowSize,
    int partition = 128
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        windowSize : int *
        ?partition : int
(* Defaults:
        let _partition = defaultArg partition 128
*)
-> MedianFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
Type of of source image. Only 8U images are supported for now.
srcChannels
Type: SystemInt32
Type of of source image. Only single channel images are supported for now.
windowSize
Type: SystemInt32
Size of the kernerl used for the filtering. Uses a (windowSize x windowSize) filter.
partition (Optional)
Type: SystemInt32
Specifies the parallel granularity of the workload. This parameter should be used GPU experts when optimizing performance.
See Also

Reference

MedianFilter Class
Emgu.CV.Cuda Namespace


MedianFilter Properties

The MedianFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MedianFilter Class
Emgu.CV.Cuda Namespace


MedianFilter Methods

The MedianFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MedianFilter Class
Emgu.CV.Cuda Namespace


MedianFilter Fields

The MedianFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MedianFilter Class
Emgu.CV.Cuda Namespace


RowSumFilter Class

A horizontal 1D box filter.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaRowSumFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RowSumFilter : CudaFilter
Public Class RowSumFilter
    Inherits CudaFilter
public ref class RowSumFilter : public CudaFilter
type RowSumFilter =
    class
        inherit CudaFilter
    end

The RowSumFilter type exposes the following members.

Constructors
 | Name | Description
Public method | RowSumFilter | Creates a horizontal 1D box filter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


RowSumFilter Constructor

Creates a horizontal 1D box filter.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RowSumFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    int ksize,
    int anchor = -1,
    BorderType borderType = 4,
    MCvScalar borderValue = null
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    ksize As Integer,
    Optional anchor As Integer = -1,
    Optional borderType As BorderType = 4,
    Optional borderValue As MCvScalar = Nothing
)
public:
RowSumFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    int ksize,
    int anchor = -1,
    BorderType^ borderType = 4,
    MCvScalar^ borderValue = nullptr
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        ksize : int *
        ?anchor : int *
        ?borderType : BorderType *
        ?borderValue : MCvScalar
(* Defaults:
        let _anchor = defaultArg anchor -1
        let _borderType = defaultArg borderType 4
        let _borderValue = defaultArg borderValue null
*)
-> RowSumFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
Input image depth. Only 8U type is supported for now.
srcChannels
Type: SystemInt32
Input image channel. Only single channel type is supported for now.
dstDepth
Type: Emgu.CV.CvEnumDepthType
Output image depth. Only 32F type is supported for now.
dstChannels
Type: SystemInt32
Output image channel. Only single channel type is supported for now.
ksize
Type: SystemInt32
Kernel size.
anchor (Optional)
Type: SystemInt32
Anchor point. The default value (-1) means that the anchor is at the kernel center.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method.
borderValue (Optional)
Type: Emgu.CV.StructureMCvScalar
Default border value.
See Also

Reference

RowSumFilter Class
Emgu.CV.Cuda Namespace


RowSumFilter Properties

The RowSumFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

RowSumFilter Class
Emgu.CV.Cuda Namespace


RowSumFilter Methods

The RowSumFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RowSumFilter Class
Emgu.CV.Cuda Namespace


RowSumFilter Fields

The RowSumFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

RowSumFilter Class
Emgu.CV.Cuda Namespace


ScharrFilter Class

A vertical or horizontal Scharr operator.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaScharrFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ScharrFilter : CudaFilter
Public Class ScharrFilter
    Inherits CudaFilter
public ref class ScharrFilter : public CudaFilter
type ScharrFilter =
    class
        inherit CudaFilter
    end

The ScharrFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ScharrFilter | Creates a vertical or horizontal Scharr operator.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


ScharrFilter Constructor

Creates a vertical or horizontal Scharr operator.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ScharrFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    int dx,
    int dy,
    double scale = 1,
    BorderType rowBorderMode = 4,
    BorderType columnBorderMode = -1
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    dx As Integer,
    dy As Integer,
    Optional scale As Double = 1,
    Optional rowBorderMode As BorderType = 4,
    Optional columnBorderMode As BorderType = -1
)
public:
ScharrFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    int dx,
    int dy,
    double scale = 1,
    BorderType^ rowBorderMode = 4,
    BorderType^ columnBorderMode = -1
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        dx : int *
        dy : int *
        ?scale : float *
        ?rowBorderMode : BorderType *
        ?columnBorderMode : BorderType
(* Defaults:
        let _scale = defaultArg scale 1
        let _rowBorderMode = defaultArg rowBorderMode 4
        let _columnBorderMode = defaultArg columnBorderMode -1
*)
-> ScharrFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
Source image depth.
srcChannels
Type: SystemInt32
Source image channels.
dstDepth
Type: Emgu.CV.CvEnumDepthType
Destination array depth.
dstChannels
Type: SystemInt32
Destination array channels.
dx
Type: SystemInt32
Order of the derivative x.
dy
Type: SystemInt32
Order of the derivative y.
scale (Optional)
Type: SystemDouble
Optional scale factor for the computed derivative values. By default, no scaling is applied.
rowBorderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method in the vertical direction. For details, see borderInterpolate.
columnBorderMode (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method in the horizontal direction.
See Also

Reference

ScharrFilter Class
Emgu.CV.Cuda Namespace


ScharrFilter Properties

The ScharrFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

ScharrFilter Class
Emgu.CV.Cuda Namespace


ScharrFilter Methods

The ScharrFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScharrFilter Class
Emgu.CV.Cuda Namespace


ScharrFilter Fields

The ScharrFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

ScharrFilter Class
Emgu.CV.Cuda Namespace


SeparableLinearFilter Class

SeparableLinearFilter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaSeparableLinearFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SeparableLinearFilter : CudaFilter
Public Class SeparableLinearFilter
    Inherits CudaFilter
public ref class SeparableLinearFilter : public CudaFilter
type SeparableLinearFilter =
    class
        inherit CudaFilter
    end

The SeparableLinearFilter type exposes the following members.

Constructors
 | Name | Description
Public method | SeparableLinearFilter | Create a SeparableLinearFilter
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


SeparableLinearFilter Constructor

Create a SeparableLinearFilter

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SeparableLinearFilter(
    DepthType srcDepth,
    int srcChannels,
    DepthType dstDepth,
    int dstChannels,
    IInputArray rowKernel,
    IInputArray columnKernel,
    Point anchor,
    BorderType rowBorderType = 4,
    BorderType columnBorderType = 4
)
Public Sub New (
    srcDepth As DepthType,
    srcChannels As Integer,
    dstDepth As DepthType,
    dstChannels As Integer,
    rowKernel As IInputArray,
    columnKernel As IInputArray,
    anchor As Point,
    Optional rowBorderType As BorderType = 4,
    Optional columnBorderType As BorderType = 4
)
public:
SeparableLinearFilter(
    DepthType^ srcDepth,
    int srcChannels,
    DepthType^ dstDepth,
    int dstChannels,
    IInputArray^ rowKernel,
    IInputArray^ columnKernel,
    Point^ anchor,
    BorderType^ rowBorderType = 4,
    BorderType^ columnBorderType = 4
)
new :
        srcDepth : DepthType *
        srcChannels : int *
        dstDepth : DepthType *
        dstChannels : int *
        rowKernel : IInputArray *
        columnKernel : IInputArray *
        anchor : Point *
        ?rowBorderType : BorderType *
        ?columnBorderType : BorderType
(* Defaults:
        let _rowBorderType = defaultArg rowBorderType 4
        let _columnBorderType = defaultArg columnBorderType 4
*)
-> SeparableLinearFilter

Parameters

srcDepth
Type: Emgu.CV.CvEnumDepthType
Source array depth
srcChannels
Type: SystemInt32
Source array channels
dstDepth
Type: Emgu.CV.CvEnumDepthType
Destination array depth
dstChannels
Type: SystemInt32
Destination array channels
rowKernel
Type: Emgu.CVIInputArray
Horizontal filter coefficients. Support kernels with size <= 32 .
columnKernel
Type: Emgu.CVIInputArray
Vertical filter coefficients. Support kernels with size <= 32 .
anchor
Type: System.DrawingPoint
Anchor position within the kernel. Negative values mean that anchor is positioned at the aperture center.
rowBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method in the vertical direction
columnBorderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method in the horizontal direction
See Also

Reference

SeparableLinearFilter Class
Emgu.CV.Cuda Namespace


SeparableLinearFilter Properties

The SeparableLinearFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

SeparableLinearFilter Class
Emgu.CV.Cuda Namespace


SeparableLinearFilter Methods

The SeparableLinearFilter type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the cuda filter (Inherited from CudaFilter.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this gpu filter (Inherited from CudaFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SeparableLinearFilter Class
Emgu.CV.Cuda Namespace


SeparableLinearFilter Fields

The SeparableLinearFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

SeparableLinearFilter Class
Emgu.CV.Cuda Namespace


Stream Class

Encapculates Cuda Stream. Provides interface for async coping. Passed to each function that supports async kernel execution. Reference counting is enabled
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CudaStream

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Stream : UnmanagedObject
Public Class Stream
    Inherits UnmanagedObject
public ref class Stream : public UnmanagedObject
type Stream =
    class
        inherit UnmanagedObject
    end

The Stream type exposes the following members.

Constructors
 | Name | Description
Public method | Stream | Create a new Cuda Stream
Top
Properties
 | Name | Description
Public property | Completed | Check if the stream is completed
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the stream (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForCompletion | Wait for the completion
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


Stream Constructor

Create a new Cuda Stream

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Stream()
Public Sub New
public:
Stream()
new : unit -> Stream
See Also

Reference

Stream Class
Emgu.CV.Cuda Namespace


Stream Properties

The Stream type exposes the following members.

Properties
 | Name | Description
Public property | Completed | Check if the stream is completed
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Stream Class
Emgu.CV.Cuda Namespace


Stream.Completed Property

StreamCompleted Property

Check if the stream is completed

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Completed { get; }
Public ReadOnly Property Completed As Boolean
    Get
public:
property bool Completed {
    bool get ();
}
member Completed : bool with get

Property Value

Type: Boolean
See Also

Reference

Stream Class
Emgu.CV.Cuda Namespace


Stream Methods

The Stream type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the stream (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForCompletion | Wait for the completion
Top
See Also

Reference

Stream Class
Emgu.CV.Cuda Namespace


Stream.DisposeObject Method

StreamDisposeObject Method

Release the stream

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Stream Class
Emgu.CV.Cuda Namespace


Stream.WaitForCompletion Method

StreamWaitForCompletion Method

Wait for the completion

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void WaitForCompletion()
Public Sub WaitForCompletion
public:
void WaitForCompletion()
member WaitForCompletion : unit -> unit
See Also

Reference

Stream Class
Emgu.CV.Cuda Namespace


Stream Fields

The Stream type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Stream Class
Emgu.CV.Cuda Namespace


TargetArchs Class

Gives information about what GPU archs this OpenCV GPU module was compiled for
Inheritance Hierarchy
SystemObject
Emgu.CV.CudaTargetArchs

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class TargetArchs
Public NotInheritable Class TargetArchs
public ref class TargetArchs abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TargetArchs =  class end

The TargetArchs type exposes the following members.

Methods
Name | Description
BuildWith | Check if the GPU module is build with the specific feature set.
Has | Check if the GPU module is targeted for the specific device version
HasBin | Check if the GPU module is targeted for the specific BIN version
HasEqualOrGreater | Check if the GPU module is targeted for equal or greater device version
HasEqualOrGreaterBin | Check if the GPU module is targeted for equal or greater BIN version
HasEqualOrGreaterPtx | Check if the GPU module is targeted for equal or greater PTX version
HasEqualOrLessPtx | Check if the GPU module is targeted for equal or less PTX version
HasPtx | Check if the GPU module is targeted for the specific PTX version
Top
See Also

Reference

Emgu.CV.Cuda Namespace


TargetArchs Methods

The TargetArchs type exposes the following members.

Methods
Name | Description
BuildWith | Check if the GPU module is build with the specific feature set.
Has | Check if the GPU module is targeted for the specific device version
HasBin | Check if the GPU module is targeted for the specific BIN version
HasEqualOrGreater | Check if the GPU module is targeted for equal or greater device version
HasEqualOrGreaterBin | Check if the GPU module is targeted for equal or greater BIN version
HasEqualOrGreaterPtx | Check if the GPU module is targeted for equal or greater PTX version
HasEqualOrLessPtx | Check if the GPU module is targeted for equal or less PTX version
HasPtx | Check if the GPU module is targeted for the specific PTX version
Top
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.BuildWith Method

TargetArchsBuildWith Method

Check if the GPU module is build with the specific feature set.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool BuildWith(
    CudaDeviceInfoGpuFeature featureSet
)
Public Shared Function BuildWith (
    featureSet As CudaDeviceInfoGpuFeature
) As Boolean
public:
static bool BuildWith(
    CudaDeviceInfoGpuFeature^ featureSet
)
static member BuildWith :
        featureSet : CudaDeviceInfoGpuFeature -> bool

Parameters

featureSet
Type: Emgu.CV.CudaCudaDeviceInfoGpuFeature
The feature set to be checked.

Return Value

Type: Boolean
True if the GPU module is build with the specific feature set.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.Has Method

TargetArchsHas Method

Check if the GPU module is targeted for the specific device version

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool Has(
    int major,
    int minor
)
Public Shared Function Has (
    major As Integer,
    minor As Integer
) As Boolean
public:
static bool Has(
    int major,
    int minor
)
static member Has :
        major : int *
        minor : int -> bool

Parameters

major
Type: SystemInt32
The major version
minor
Type: SystemInt32
The minor version

Return Value

Type: Boolean
True if the GPU module is targeted for the specific device version.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.HasBin Method

TargetArchsHasBin Method

Check if the GPU module is targeted for the specific BIN version

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HasBin(
    int major,
    int minor
)
Public Shared Function HasBin (
    major As Integer,
    minor As Integer
) As Boolean
public:
static bool HasBin(
    int major,
    int minor
)
static member HasBin :
        major : int *
        minor : int -> bool

Parameters

major
Type: SystemInt32
The major version
minor
Type: SystemInt32
The minor version

Return Value

Type: Boolean
True if the GPU module is targeted for the specific BIN version.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.HasEqualOrGreater Method

TargetArchsHasEqualOrGreater Method

Check if the GPU module is targeted for equal or greater device version

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HasEqualOrGreater(
    int major,
    int minor
)
Public Shared Function HasEqualOrGreater (
    major As Integer,
    minor As Integer
) As Boolean
public:
static bool HasEqualOrGreater(
    int major,
    int minor
)
static member HasEqualOrGreater :
        major : int *
        minor : int -> bool

Parameters

major
Type: SystemInt32
The major version
minor
Type: SystemInt32
The minor version

Return Value

Type: Boolean
True if the GPU module is targeted for equal or greater device version.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.HasEqualOrGreaterBin Method

TargetArchsHasEqualOrGreaterBin Method

Check if the GPU module is targeted for equal or greater BIN version

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HasEqualOrGreaterBin(
    int major,
    int minor
)
Public Shared Function HasEqualOrGreaterBin (
    major As Integer,
    minor As Integer
) As Boolean
public:
static bool HasEqualOrGreaterBin(
    int major,
    int minor
)
static member HasEqualOrGreaterBin :
        major : int *
        minor : int -> bool

Parameters

major
Type: SystemInt32
The major version
minor
Type: SystemInt32
The minor version

Return Value

Type: Boolean
True if the GPU module is targeted for equal or greater BIN version.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.HasEqualOrGreaterPtx Method

TargetArchsHasEqualOrGreaterPtx Method

Check if the GPU module is targeted for equal or greater PTX version

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HasEqualOrGreaterPtx(
    int major,
    int minor
)
Public Shared Function HasEqualOrGreaterPtx (
    major As Integer,
    minor As Integer
) As Boolean
public:
static bool HasEqualOrGreaterPtx(
    int major,
    int minor
)
static member HasEqualOrGreaterPtx :
        major : int *
        minor : int -> bool

Parameters

major
Type: SystemInt32
The major version
minor
Type: SystemInt32
The minor version

Return Value

Type: Boolean
True if the GPU module is targeted for equal or greater PTX version.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.HasEqualOrLessPtx Method

TargetArchsHasEqualOrLessPtx Method

Check if the GPU module is targeted for equal or less PTX version

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HasEqualOrLessPtx(
    int major,
    int minor
)
Public Shared Function HasEqualOrLessPtx (
    major As Integer,
    minor As Integer
) As Boolean
public:
static bool HasEqualOrLessPtx(
    int major,
    int minor
)
static member HasEqualOrLessPtx :
        major : int *
        minor : int -> bool

Parameters

major
Type: SystemInt32
The major version
minor
Type: SystemInt32
The minor version

Return Value

Type: Boolean
True if the GPU module is targeted for equal or less PTX version.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


TargetArchs.HasPtx Method

TargetArchsHasPtx Method

Check if the GPU module is targeted for the specific PTX version

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool HasPtx(
    int major,
    int minor
)
Public Shared Function HasPtx (
    major As Integer,
    minor As Integer
) As Boolean
public:
static bool HasPtx(
    int major,
    int minor
)
static member HasPtx :
        major : int *
        minor : int -> bool

Parameters

major
Type: SystemInt32
The major version
minor
Type: SystemInt32
The minor version

Return Value

Type: Boolean
True if the GPU module is targeted for the specific PTX version.
See Also

Reference

TargetArchs Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat Class

Wrapped class of the C++ standard vector of GpuMat.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CudaVectorOfGpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfGpuMat : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfGpuMat
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfGpuMat : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfGpuMat =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfGpuMat type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfGpuMat | Create an empty standard vector of GpuMat
Public method | VectorOfGpuMat(Int32) | Create an standard vector of GpuMat of the specific size
Public method | VectorOfGpuMat(GpuMat) | Create an standard vector of GpuMat with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(GpuMat) | Push a value into the standard vector
Public method | Push(GpuMat) | Push multiple values into the standard vector
Public method | Push(VectorOfGpuMat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Cuda Namespace


VectorOfGpuMat Constructor

Overload List
 | Name | Description
Public method | VectorOfGpuMat | Create an empty standard vector of GpuMat
Public method | VectorOfGpuMat(Int32) | Create an standard vector of GpuMat of the specific size
Public method | VectorOfGpuMat(GpuMat) | Create an standard vector of GpuMat with the initial values
Top
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat Constructor

Create an empty standard vector of GpuMat

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfGpuMat()
Public Sub New
public:
VectorOfGpuMat()
new : unit -> VectorOfGpuMat
See Also

Reference

VectorOfGpuMat Class
VectorOfGpuMat Overload
Emgu.CV.Cuda Namespace


VectorOfGpuMat Constructor (Int32)

Create an standard vector of GpuMat of the specific size

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfGpuMat(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfGpuMat(
    int size
)
new :
        size : int -> VectorOfGpuMat

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfGpuMat Class
VectorOfGpuMat Overload
Emgu.CV.Cuda Namespace


VectorOfGpuMat Constructor (GpuMat[])

VectorOfGpuMat Constructor (GpuMat)

http://www.emgu.com
Create an standard vector of GpuMat with the initial values

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfGpuMat(
    params GpuMat[] values
)
Public Sub New (
    ParamArray values As GpuMat()
)
public:
VectorOfGpuMat(
    ... array<GpuMat^>^ values
)
new :
        values : GpuMat[] -> VectorOfGpuMat

Parameters

values
Type: Emgu.CV.CudaGpuMat
The initial values
See Also

Reference

VectorOfGpuMat Class
VectorOfGpuMat Overload
Emgu.CV.Cuda Namespace


VectorOfGpuMat Properties

The VectorOfGpuMat type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.Item Property

VectorOfGpuMatItem Property

Get the item in the specific index

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GpuMat this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As GpuMat
    Get
public:
property GpuMat^ Item[int index] {
    GpuMat^ get (int index);
}
member Item : GpuMat with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: GpuMat
The item in the specific index
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.Size Property

VectorOfGpuMatSize Property

Get the size of the vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.SizeOfItemInBytes Property

VectorOfGpuMatSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat Methods

The VectorOfGpuMat type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(GpuMat) | Push a value into the standard vector
Public method | Push(GpuMat) | Push multiple values into the standard vector
Public method | Push(VectorOfGpuMat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.Clear Method

VectorOfGpuMatClear Method

Clear the vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.DisposeObject Method

VectorOfGpuMatDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.GetInputArray Method

VectorOfGpuMatGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.GetInputOutputArray Method

VectorOfGpuMatGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.GetOutputArray Method

VectorOfGpuMatGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.Push Method

VectorOfGpuMatPush Method

Overload List
 | Name | Description
Public method | Push(GpuMat) | Push a value into the standard vector
Public method | Push(GpuMat) | Push multiple values into the standard vector
Public method | Push(VectorOfGpuMat) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


VectorOfGpuMat.Push Method (GpuMat)

VectorOfGpuMatPush Method (GpuMat)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    GpuMat value
)
Public Sub Push (
    value As GpuMat
)
public:
void Push(
    GpuMat^ value
)
member Push :
        value : GpuMat -> unit

Parameters

value
Type: Emgu.CV.CudaGpuMat
The value to be pushed to the vector
See Also

Reference

VectorOfGpuMat Class
Push Overload
Emgu.CV.Cuda Namespace


VectorOfGpuMat.Push Method (GpuMat[])

VectorOfGpuMatPush Method (GpuMat)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    GpuMat[] values
)
Public Sub Push (
    values As GpuMat()
)
public:
void Push(
    array<GpuMat^>^ values
)
member Push :
        values : GpuMat[] -> unit

Parameters

values
Type: Emgu.CV.CudaGpuMat
The values to be pushed to the vector
See Also

Reference

VectorOfGpuMat Class
Push Overload
Emgu.CV.Cuda Namespace


VectorOfGpuMat.Push Method (VectorOfGpuMat)

VectorOfGpuMatPush Method (VectorOfGpuMat)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Cuda
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfGpuMat other
)
Public Sub Push (
    other As VectorOfGpuMat
)
public:
void Push(
    VectorOfGpuMat^ other
)
member Push :
        other : VectorOfGpuMat -> unit

Parameters

other
Type: Emgu.CV.CudaVectorOfGpuMat
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfGpuMat Class
Push Overload
Emgu.CV.Cuda Namespace


VectorOfGpuMat Fields

The VectorOfGpuMat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfGpuMat Class
Emgu.CV.Cuda Namespace


Emgu.CV.Cvb Namespace

Contains interface for the CvBlob library
Classes
 | Class | Description
Public class | CvBlob | CvBlob
Public class | CvBlobMoments | Blob Moments
Public class | CvBlobDetector | Wrapper for the CvBlob detection functions. The Ptr property points to the label image of the cvb::cvLabel function.
Public class | CvBlobDetectorBlobRenderType | Blob rendering type
Public class | CvBlobs | CvBlobs
Public class | CvTrack | CvTrack
Public class | CvTracks | Blobs tracking


CvBlob Class

CvBlob
Inheritance Hierarchy
SystemObject
Emgu.CV.CvbCvBlob

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CvBlob
Public Class CvBlob
public ref class CvBlob
type CvBlob =  class end

The CvBlob type exposes the following members.

Properties
 | Name | Description
Public property | Area | The number of pixels in this blob
Public property | BlobMoments | Get the Blob Moments
Public property | BoundingBox | The minimum bounding box of the blob
Public property | Centroid | The centroid of the blob
Public property | Label | Get the blob label
Public property | Ptr | Pointer to the blob
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContour | Get the contour that defines the blob
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
(CvBlob to IntPtr) | Implicit operator for IntPtr
Top
See Also

Reference

Emgu.CV.Cvb Namespace


CvBlob Properties

The CvBlob type exposes the following members.

Properties
 | Name | Description
Public property | Area | The number of pixels in this blob
Public property | BlobMoments | Get the Blob Moments
Public property | BoundingBox | The minimum bounding box of the blob
Public property | Centroid | The centroid of the blob
Public property | Label | Get the blob label
Public property | Ptr | Pointer to the blob
Top
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.Area Property

CvBlobArea Property

The number of pixels in this blob

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Area { get; }
Public ReadOnly Property Area As Integer
    Get
public:
property int Area {
    int get ();
}
member Area : int with get

Property Value

Type: Int32
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.BlobMoments Property

CvBlobBlobMoments Property

Get the Blob Moments

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvBlobMoments BlobMoments { get; }
Public ReadOnly Property BlobMoments As CvBlobMoments
    Get
public:
property CvBlobMoments^ BlobMoments {
    CvBlobMoments^ get ();
}
member BlobMoments : CvBlobMoments with get

Property Value

Type: CvBlobMoments
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.BoundingBox Property

CvBlobBoundingBox Property

The minimum bounding box of the blob

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle BoundingBox { get; }
Public ReadOnly Property BoundingBox As Rectangle
    Get
public:
property Rectangle^ BoundingBox {
    Rectangle^ get ();
}
member BoundingBox : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.Centroid Property

CvBlobCentroid Property

The centroid of the blob

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Centroid { get; }
Public ReadOnly Property Centroid As PointF
    Get
public:
property PointF^ Centroid {
    PointF^ get ();
}
member Centroid : PointF with get

Property Value

Type: PointF
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.Label Property

CvBlobLabel Property

Get the blob label

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Label { get; }
Public ReadOnly Property Label As UInteger
    Get
public:
property unsigned int Label {
    unsigned int get ();
}
member Label : uint32 with get

Property Value

Type: UInt32
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.Ptr Property

CvBlobPtr Property

Pointer to the blob

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Ptr { get; }
Public ReadOnly Property Ptr As IntPtr
    Get
public:
property IntPtr Ptr {
    IntPtr get ();
}
member Ptr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob Methods

The CvBlob type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContour | Get the contour that defines the blob
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.GetContour Method

CvBlobGetContour Method

Get the contour that defines the blob

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point[] GetContour()
Public Function GetContour As Point()
public:
array<Point^>^ GetContour()
member GetContour : unit -> Point[]

Return Value

Type: Point
The contour of the blob
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob Type Conversions

The CvBlob type exposes the following members.

Operators
Name | Description
(CvBlob to IntPtr) | Implicit operator for IntPtr
Top
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob Implicit Conversion (CvBlob to IntPtr)

CvBlob Conversion (CvBlob to IntPtr)

http://www.emgu.com
Implicit operator for IntPtr

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static implicit operator IntPtr (
    CvBlob obj
)
Public Shared Widening Operator CType (
    obj As CvBlob
) As IntPtr
static implicit operator IntPtr (
    CvBlob^ obj
)
F# does not support the declaration of new casting operators.

Parameters

obj
Type: Emgu.CV.CvbCvBlob
The CvBlob

Return Value

Type: IntPtr
The unmanaged pointer for this object
See Also

Reference

CvBlob Class
Emgu.CV.Cvb Namespace


CvBlob.Moments Class

CvBlobMoments Class

Blob Moments
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.CvbCvBlobMoments

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Moments : ValueType
Public NotInheritable Class Moments
    Inherits ValueType
public ref class Moments sealed : public ValueType
[<SealedAttribute>]
type Moments =
    class
        inherit ValueType
    end

The CvBlobMoments type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | M00 | Moment 00
Public field | M01 | Moment 01
Public field | M02 | Moment 02
Public field | M10 | Moment 10
Public field | M11 | Moment 11
Public field | M20 | Moment 20
Public field | N02 | Normalized central moment 02
Public field | N11 | Normalized central moment 11
Public field | N20 | Normalized central moment 20
Public field | P1 | Hu moment 1
Public field | P2 | Hu moment 2
Public field | U02 | Central moment 02
Public field | U11 | Central moment 11
Public field | U20 | Central moment 20
Top
See Also

Reference

Emgu.CV.Cvb Namespace


Moments Methods

The CvBlobMoments type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


Moments Fields

The CvBlobMoments type exposes the following members.

Fields
 | Name | Description
Public field | M00 | Moment 00
Public field | M01 | Moment 01
Public field | M02 | Moment 02
Public field | M10 | Moment 10
Public field | M11 | Moment 11
Public field | M20 | Moment 20
Public field | N02 | Normalized central moment 02
Public field | N11 | Normalized central moment 11
Public field | N20 | Normalized central moment 20
Public field | P1 | Hu moment 1
Public field | P2 | Hu moment 2
Public field | U02 | Central moment 02
Public field | U11 | Central moment 11
Public field | U20 | Central moment 20
Top
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.M00 Field

CvBlobMomentsM00 Field

Moment 00

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M00
Public M00 As Double
public:
double M00
val mutable M00: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.M01 Field

CvBlobMomentsM01 Field

Moment 01

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M01
Public M01 As Double
public:
double M01
val mutable M01: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.M02 Field

CvBlobMomentsM02 Field

Moment 02

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M02
Public M02 As Double
public:
double M02
val mutable M02: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.M10 Field

CvBlobMomentsM10 Field

Moment 10

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M10
Public M10 As Double
public:
double M10
val mutable M10: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.M11 Field

CvBlobMomentsM11 Field

Moment 11

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M11
Public M11 As Double
public:
double M11
val mutable M11: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.M20 Field

CvBlobMomentsM20 Field

Moment 20

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double M20
Public M20 As Double
public:
double M20
val mutable M20: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.N02 Field

CvBlobMomentsN02 Field

Normalized central moment 02

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double N02
Public N02 As Double
public:
double N02
val mutable N02: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.N11 Field

CvBlobMomentsN11 Field

Normalized central moment 11

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double N11
Public N11 As Double
public:
double N11
val mutable N11: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.N20 Field

CvBlobMomentsN20 Field

Normalized central moment 20

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double N20
Public N20 As Double
public:
double N20
val mutable N20: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.P1 Field

CvBlobMomentsP1 Field

Hu moment 1

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double P1
Public P1 As Double
public:
double P1
val mutable P1: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.P2 Field

CvBlobMomentsP2 Field

Hu moment 2

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double P2
Public P2 As Double
public:
double P2
val mutable P2: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.U02 Field

CvBlobMomentsU02 Field

Central moment 02

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double U02
Public U02 As Double
public:
double U02
val mutable U02: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.U11 Field

CvBlobMomentsU11 Field

Central moment 11

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double U11
Public U11 As Double
public:
double U11
val mutable U11: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlob.Moments.U20 Field

CvBlobMomentsU20 Field

Central moment 20

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double U20
Public U20 As Double
public:
double U20
val mutable U20: float

Field Value

Type: Double
See Also

Reference

CvBlobMoments Class
Emgu.CV.Cvb Namespace


CvBlobDetector Class

Wrapper for the CvBlob detection functions. The Ptr property points to the label image of the cvb::cvLabel function.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CvbCvBlobDetector

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CvBlobDetector : UnmanagedObject
Public Class CvBlobDetector
    Inherits UnmanagedObject
public ref class CvBlobDetector : public UnmanagedObject
type CvBlobDetector =
    class
        inherit UnmanagedObject
    end

The CvBlobDetector type exposes the following members.

Constructors
 | Name | Description
Public method | CvBlobDetector | Initializes a new instance of the CvBlobDetector class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Detect | Detect blobs from input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Blob detector (Overrides DisposableObjectDisposeObject.)
Public method | DrawBlobs | Draw the blobs on the image
Public method | DrawBlobsMask | Get the binary mask for the blobs listed in the CvBlobs
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeanColor | Calculates mean color of a blob in an image.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Remarks
Algorithm based on paper "A linear-time component-labeling algorithm using contour tracing technique" of Fu Chang, Chun-Jen Chen and Chi-Jen Lu.
See Also

Reference

Emgu.CV.Cvb Namespace


CvBlobDetector Constructor

Initializes a new instance of the CvBlobDetector class

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvBlobDetector()
Public Sub New
public:
CvBlobDetector()
new : unit -> CvBlobDetector
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector Properties

The CvBlobDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector Methods

The CvBlobDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Detect blobs from input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Blob detector (Overrides DisposableObjectDisposeObject.)
Public method | DrawBlobs | Draw the blobs on the image
Public method | DrawBlobsMask | Get the binary mask for the blobs listed in the CvBlobs
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeanColor | Calculates mean color of a blob in an image.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector.Detect Method

CvBlobDetectorDetect Method

Detect blobs from input image.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Detect(
    Image<Gray, byte> img,
    CvBlobs blobs
)
Public Function Detect (
    img As Image(Of Gray, Byte),
    blobs As CvBlobs
) As UInteger
public:
unsigned int Detect(
    Image<Gray^, unsigned char>^ img,
    CvBlobs^ blobs
)
member Detect :
        img : Image<Gray, byte> *
        blobs : CvBlobs -> uint32

Parameters

img
Type: Emgu.CVImage Gray, Byte
The input image
blobs
Type: Emgu.CV.CvbCvBlobs
The storage for the detected blobs

Return Value

Type: UInt32
Number of pixels that has been labeled.
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector.DisposeObject Method

CvBlobDetectorDisposeObject Method

Release all the unmanaged memory associated with this Blob detector

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector.DrawBlobs Method

CvBlobDetectorDrawBlobs Method

Draw the blobs on the image

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Bgr, byte> DrawBlobs(
    Image<Gray, byte> image,
    CvBlobs blobs,
    CvBlobDetectorBlobRenderType type,
    double alpha
)
Public Function DrawBlobs (
    image As Image(Of Gray, Byte),
    blobs As CvBlobs,
    type As CvBlobDetectorBlobRenderType,
    alpha As Double
) As Image(Of Bgr, Byte)
public:
Image<Bgr^, unsigned char>^ DrawBlobs(
    Image<Gray^, unsigned char>^ image,
    CvBlobs^ blobs,
    CvBlobDetectorBlobRenderType^ type,
    double alpha
)
member DrawBlobs :
        image : Image<Gray, byte> *
        blobs : CvBlobs *
        type : CvBlobDetectorBlobRenderType *
        alpha : float -> Image<Bgr, byte>

Parameters

image
Type: Emgu.CVImage Gray, Byte
The binary mask.
blobs
Type: Emgu.CV.CvbCvBlobs
The blobs.
type
Type: Emgu.CV.CvbCvBlobDetectorBlobRenderType
Drawing type.
alpha
Type: SystemDouble
The alpha value. 1.0 for solid color and 0.0 for transparent

Return Value

Type: Image Bgr, Byte
The images with the blobs drawn
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector.DrawBlobsMask Method

CvBlobDetectorDrawBlobsMask Method

Get the binary mask for the blobs listed in the CvBlobs

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image<Gray, byte> DrawBlobsMask(
    CvBlobs blobs
)
Public Function DrawBlobsMask (
    blobs As CvBlobs
) As Image(Of Gray, Byte)
public:
Image<Gray^, unsigned char>^ DrawBlobsMask(
    CvBlobs^ blobs
)
member DrawBlobsMask :
        blobs : CvBlobs -> Image<Gray, byte>

Parameters

blobs
Type: Emgu.CV.CvbCvBlobs
The blobs

Return Value

Type: Image Gray, Byte
The binary mask for the specific blobs
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector.MeanColor Method

CvBlobDetectorMeanColor Method

Calculates mean color of a blob in an image.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Bgr MeanColor(
    CvBlob blob,
    Image<Bgr, byte> originalImage
)
Public Function MeanColor (
    blob As CvBlob,
    originalImage As Image(Of Bgr, Byte)
) As Bgr
public:
Bgr^ MeanColor(
    CvBlob^ blob,
    Image<Bgr^, unsigned char>^ originalImage
)
member MeanColor :
        blob : CvBlob *
        originalImage : Image<Bgr, byte> -> Bgr

Parameters

blob
Type: Emgu.CV.CvbCvBlob
The blob.
originalImage
Type: Emgu.CVImage Bgr, Byte
The original image

Return Value

Type: Bgr
Average color
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector Fields

The CvBlobDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CvBlobDetector Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType Class

CvBlobDetectorBlobRenderType Class

Blob rendering type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvbCvBlobDetectorBlobRenderType

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class BlobRenderType : Enum
<FlagsAttribute>
Public NotInheritable Class BlobRenderType
    Inherits Enum
[FlagsAttribute]
public ref class BlobRenderType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type BlobRenderType =
    class
        inherit Enum
    end

The CvBlobDetectorBlobRenderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Angle | Render angle.
 | BoundingBox | Render bounding box.
 | Centroid | Render centroid.
 | Color | Render each blog with a different color.
 | Default | The default rendering type
 | ToLog | Print blob data to log out.
 | ToStd | Print blob data to std out.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Cvb Namespace


BlobRenderType Methods

The CvBlobDetectorBlobRenderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


BlobRenderType Fields

The CvBlobDetectorBlobRenderType type exposes the following members.

Fields
 | Name | Description
 | Angle | Render angle.
 | BoundingBox | Render bounding box.
 | Centroid | Render centroid.
 | Color | Render each blog with a different color.
 | Default | The default rendering type
 | ToLog | Print blob data to log out.
 | ToStd | Print blob data to std out.
Public field | value__ |
Top
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.Angle Field

CvBlobDetectorBlobRenderTypeAngle Field

Render angle.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CvBlobDetectorBlobRenderType Angle = 8
Public Const Angle As CvBlobDetectorBlobRenderType = 8
public:
literal CvBlobDetectorBlobRenderType^ Angle = 8
static val mutable Angle: CvBlobDetectorBlobRenderType

Field Value

Type: CvBlobDetectorBlobRenderType
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.BoundingBox Field

CvBlobDetectorBlobRenderTypeBoundingBox Field

Render bounding box.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CvBlobDetectorBlobRenderType BoundingBox = 4
Public Const BoundingBox As CvBlobDetectorBlobRenderType = 4
public:
literal CvBlobDetectorBlobRenderType^ BoundingBox = 4
static val mutable BoundingBox: CvBlobDetectorBlobRenderType

Field Value

Type: CvBlobDetectorBlobRenderType
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.Centroid Field

CvBlobDetectorBlobRenderTypeCentroid Field

Render centroid.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CvBlobDetectorBlobRenderType Centroid = 2
Public Const Centroid As CvBlobDetectorBlobRenderType = 2
public:
literal CvBlobDetectorBlobRenderType^ Centroid = 2
static val mutable Centroid: CvBlobDetectorBlobRenderType

Field Value

Type: CvBlobDetectorBlobRenderType
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.Color Field

CvBlobDetectorBlobRenderTypeColor Field

Render each blog with a different color.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CvBlobDetectorBlobRenderType Color = 1
Public Const Color As CvBlobDetectorBlobRenderType = 1
public:
literal CvBlobDetectorBlobRenderType^ Color = 1
static val mutable Color: CvBlobDetectorBlobRenderType

Field Value

Type: CvBlobDetectorBlobRenderType
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.Default Field

CvBlobDetectorBlobRenderTypeDefault Field

The default rendering type

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CvBlobDetectorBlobRenderType Default = 15
Public Const Default As CvBlobDetectorBlobRenderType = 15
public:
literal CvBlobDetectorBlobRenderType^ Default = 15
static val mutable Default: CvBlobDetectorBlobRenderType

Field Value

Type: CvBlobDetectorBlobRenderType
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.ToLog Field

CvBlobDetectorBlobRenderTypeToLog Field

Print blob data to log out.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CvBlobDetectorBlobRenderType ToLog = 16
Public Const ToLog As CvBlobDetectorBlobRenderType = 16
public:
literal CvBlobDetectorBlobRenderType^ ToLog = 16
static val mutable ToLog: CvBlobDetectorBlobRenderType

Field Value

Type: CvBlobDetectorBlobRenderType
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.ToStd Field

CvBlobDetectorBlobRenderTypeToStd Field

Print blob data to std out.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CvBlobDetectorBlobRenderType ToStd = 32
Public Const ToStd As CvBlobDetectorBlobRenderType = 32
public:
literal CvBlobDetectorBlobRenderType^ ToStd = 32
static val mutable ToStd: CvBlobDetectorBlobRenderType

Field Value

Type: CvBlobDetectorBlobRenderType
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobDetector.BlobRenderType.value__ Field

CvBlobDetectorBlobRenderTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Cvb.CvBlobDetector.BlobRenderType.value__"]

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CvBlobDetectorBlobRenderType Class
Emgu.CV.Cvb Namespace


CvBlobs Class

CvBlobs
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CvbCvBlobs

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CvBlobs : UnmanagedObject, IDictionary<uint, CvBlob>,
    ICollection<KeyValuePair<uint, CvBlob>>, IEnumerable<KeyValuePair<uint, CvBlob>>,
    IEnumerable
Public Class CvBlobs
    Inherits UnmanagedObject
    Implements IDictionary(Of UInteger, CvBlob),
    ICollection(Of KeyValuePair(Of UInteger, CvBlob)),
    IEnumerable(Of KeyValuePair(Of UInteger, CvBlob)),
    IEnumerable
public ref class CvBlobs : public UnmanagedObject,
    IDictionary<unsigned int, CvBlob^>, ICollection<KeyValuePair<unsigned int, CvBlob^>^>,
    IEnumerable<KeyValuePair<unsigned int, CvBlob^>^>,
    IEnumerable
type CvBlobs =
    class
        inherit UnmanagedObject
        interface IDictionary<uint32, CvBlob>
        interface ICollection<KeyValuePair<uint32, CvBlob>>
        interface IEnumerable<KeyValuePair<uint32, CvBlob>>
        interface IEnumerable
    end

The CvBlobs type exposes the following members.

Constructors
 | Name | Description
Public method | CvBlobs | Create a new CvBlobs
Top
Properties
 | Name | Description
Public property | Count | Gets the number of label/Blob pairs contained in the collection
Public property | IsReadOnly | Always false
Public property | Item | Get the blob with the speicific label. Set function is not implemented
Public property | Keys | Get a collection containing the labels in the CvBlobs
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Values | Get a collection containing the blobs in the CvBlobs.
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairUInt32, CvBlob) | Adds the specified label and blob to the CvBlobs.
Public method | Add(UInt32, CvBlob) | Adds the specified label and blob to the dictionary.
Public method | Clear | Removes all keys and values
Public method | Contains | Determines whether the CvBlobs contains a specific label and CvBlob.
Public method | ContainsKey | Determines whether the CvBlobs contains the specified label.
Public method | CopyTo | Copies the elements to the array, starting at the specific arrayIndex.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resources used by this CvBlobs (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterByArea | Filter blobs by area. Those blobs whose areas are not in range will be erased from the input list of blobs.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Remove(KeyValuePairUInt32, CvBlob) | Removes a key and value from the dictionary.
Public method | Remove(UInt32) | Removes the blob with the specific label
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the blob associated with the specified label.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Cvb Namespace


CvBlobs Constructor

Create a new CvBlobs

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvBlobs()
Public Sub New
public:
CvBlobs()
new : unit -> CvBlobs
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs Properties

The CvBlobs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of label/Blob pairs contained in the collection
Public property | IsReadOnly | Always false
Public property | Item | Get the blob with the speicific label. Set function is not implemented
Public property | Keys | Get a collection containing the labels in the CvBlobs
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Values | Get a collection containing the blobs in the CvBlobs.
Top
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Count Property

CvBlobsCount Property

Gets the number of label/Blob pairs contained in the collection

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.IsReadOnly Property

CvBlobsIsReadOnly Property

Always false

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Item Property

CvBlobsItem Property

Get the blob with the speicific label. Set function is not implemented

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvBlob this[
    uint label
] { get; set; }
Public Property Item (
    label As UInteger
) As CvBlob
    Get
    Set
public:
virtual property CvBlob^ Item[unsigned int label] {
    CvBlob^ get (unsigned int label) sealed;
    void set (unsigned int label, CvBlob^ value) sealed;
}
abstract Item : CvBlob with get, set
override Item : CvBlob with get, set

Parameters

label
Type: SystemUInt32
The label for the blob

Property Value

Type: CvBlob

Implements

IDictionaryTKey, TValueItemTKey
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Keys Property

CvBlobsKeys Property

Get a collection containing the labels in the CvBlobs

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ICollection<uint> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of UInteger)
    Get
public:
virtual property ICollection<unsigned int>^ Keys {
    ICollection<unsigned int>^ get () sealed;
}
abstract Keys : ICollection<uint32> with get
override Keys : ICollection<uint32> with get

Property Value

Type: ICollection UInt32

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Values Property

CvBlobsValues Property

Get a collection containing the blobs in the CvBlobs.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ICollection<CvBlob> Values { get; }
Public ReadOnly Property Values As ICollection(Of CvBlob)
    Get
public:
virtual property ICollection<CvBlob^>^ Values {
    ICollection<CvBlob^>^ get () sealed;
}
abstract Values : ICollection<CvBlob> with get
override Values : ICollection<CvBlob> with get

Property Value

Type: ICollection CvBlob

Implements

IDictionaryTKey, TValueValues
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs Methods

The CvBlobs type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairUInt32, CvBlob) | Adds the specified label and blob to the CvBlobs.
Public method | Add(UInt32, CvBlob) | Adds the specified label and blob to the dictionary.
Public method | Clear | Removes all keys and values
Public method | Contains | Determines whether the CvBlobs contains a specific label and CvBlob.
Public method | ContainsKey | Determines whether the CvBlobs contains the specified label.
Public method | CopyTo | Copies the elements to the array, starting at the specific arrayIndex.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resources used by this CvBlobs (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterByArea | Filter blobs by area. Those blobs whose areas are not in range will be erased from the input list of blobs.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Remove(KeyValuePairUInt32, CvBlob) | Removes a key and value from the dictionary.
Public method | Remove(UInt32) | Removes the blob with the specific label
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the blob associated with the specified label.
Top
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Add Method

CvBlobsAdd Method

Overload List
 | Name | Description
Public method | Add(KeyValuePairUInt32, CvBlob) | Adds the specified label and blob to the CvBlobs.
Public method | Add(UInt32, CvBlob) | Adds the specified label and blob to the dictionary.
Top
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Add Method (KeyValuePair(UInt32, CvBlob))

CvBlobsAdd Method (KeyValuePairUInt32, CvBlob)

http://www.emgu.com
Adds the specified label and blob to the CvBlobs.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    KeyValuePair<uint, CvBlob> item
)
Public Sub Add (
    item As KeyValuePair(Of UInteger, CvBlob)
)
public:
virtual void Add(
    KeyValuePair<unsigned int, CvBlob^>^ item
) sealed
abstract Add :
        item : KeyValuePair<uint32, CvBlob> -> unit
override Add :
        item : KeyValuePair<uint32, CvBlob> -> unit

Parameters

item
Type: System.Collections.GenericKeyValuePair UInt32, CvBlob
The structure representing the label and blob to add to the CvBlobs

Implements

ICollectionTAdd(T)
See Also

Reference

CvBlobs Class
Add Overload
Emgu.CV.Cvb Namespace


CvBlobs.Add Method (UInt32, CvBlob)

CvBlobsAdd Method (UInt32, CvBlob)

http://www.emgu.com
Adds the specified label and blob to the dictionary.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    uint label,
    CvBlob blob
)
Public Sub Add (
    label As UInteger,
    blob As CvBlob
)
public:
virtual void Add(
    unsigned int label,
    CvBlob^ blob
) sealed
abstract Add :
        label : uint32 *
        blob : CvBlob -> unit
override Add :
        label : uint32 *
        blob : CvBlob -> unit

Parameters

label
Type: SystemUInt32
The label of the blob
blob
Type: Emgu.CV.CvbCvBlob
The blob

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
See Also

Reference

CvBlobs Class
Add Overload
Emgu.CV.Cvb Namespace


CvBlobs.Clear Method

CvBlobsClear Method

Removes all keys and values

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Contains Method

CvBlobsContains Method

Determines whether the CvBlobs contains a specific label and CvBlob.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    KeyValuePair<uint, CvBlob> item
)
Public Function Contains (
    item As KeyValuePair(Of UInteger, CvBlob)
) As Boolean
public:
virtual bool Contains(
    KeyValuePair<unsigned int, CvBlob^>^ item
) sealed
abstract Contains :
        item : KeyValuePair<uint32, CvBlob> -> bool
override Contains :
        item : KeyValuePair<uint32, CvBlob> -> bool

Parameters

item
Type: System.Collections.GenericKeyValuePair UInt32, CvBlob
The label and blob to be located

Return Value

Type: Boolean
True if the specific label and blob is found in the CvBlobs; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.ContainsKey Method

CvBlobsContainsKey Method

Determines whether the CvBlobs contains the specified label.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    uint label
)
Public Function ContainsKey (
    label As UInteger
) As Boolean
public:
virtual bool ContainsKey(
    unsigned int label
) sealed
abstract ContainsKey :
        label : uint32 -> bool
override ContainsKey :
        label : uint32 -> bool

Parameters

label
Type: SystemUInt32
The label (key) to be located

Return Value

Type: Boolean
True if the CvBlobs contains an element with the specific label

Implements

IDictionaryTKey, TValueContainsKey(TKey)
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.CopyTo Method

CvBlobsCopyTo Method

Copies the elements to the array, starting at the specific arrayIndex.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    KeyValuePair<uint, CvBlob>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of UInteger, CvBlob)(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<KeyValuePair<unsigned int, CvBlob^>^>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : KeyValuePair<uint32, CvBlob>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<uint32, CvBlob>[] *
        arrayIndex : int -> unit

Parameters

array
Type: System.Collections.GenericKeyValuePair UInt32, CvBlob
The one-dimensional array that is the defination of the elements copied from the CvBlobs. The array must have zero-base indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.DisposeObject Method

CvBlobsDisposeObject Method

Release all the unmanaged resources used by this CvBlobs

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.FilterByArea Method

CvBlobsFilterByArea Method

Filter blobs by area. Those blobs whose areas are not in range will be erased from the input list of blobs.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FilterByArea(
    int minArea,
    int maxArea
)
Public Sub FilterByArea (
    minArea As Integer,
    maxArea As Integer
)
public:
void FilterByArea(
    int minArea,
    int maxArea
)
member FilterByArea :
        minArea : int *
        maxArea : int -> unit

Parameters

minArea
Type: SystemInt32
Minimun area
maxArea
Type: SystemInt32
Maximun area
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.GetEnumerator Method

CvBlobsGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<KeyValuePair<uint, CvBlob>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of UInteger, CvBlob))
public:
virtual IEnumerator<KeyValuePair<unsigned int, CvBlob^>^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<uint32, CvBlob>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<uint32, CvBlob>>

Return Value

Type: IEnumerator KeyValuePair UInt32, CvBlob
An enumerator that can be used to iterate through the collection

Implements

IEnumerableTGetEnumerator
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Remove Method

CvBlobsRemove Method

Overload List
 | Name | Description
Public method | Remove(KeyValuePairUInt32, CvBlob) | Removes a key and value from the dictionary.
Public method | Remove(UInt32) | Removes the blob with the specific label
Top
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs.Remove Method (KeyValuePair(UInt32, CvBlob))

CvBlobsRemove Method (KeyValuePairUInt32, CvBlob)

http://www.emgu.com
Removes a key and value from the dictionary.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    KeyValuePair<uint, CvBlob> item
)
Public Function Remove (
    item As KeyValuePair(Of UInteger, CvBlob)
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<unsigned int, CvBlob^>^ item
) sealed
abstract Remove :
        item : KeyValuePair<uint32, CvBlob> -> bool
override Remove :
        item : KeyValuePair<uint32, CvBlob> -> bool

Parameters

item
Type: System.Collections.GenericKeyValuePair UInt32, CvBlob
The structure representing the key and value to be removed

Return Value

Type: Boolean
True if the key are value is sucessfully found and removed; otherwise false.

Implements

ICollectionTRemove(T)
See Also

Reference

CvBlobs Class
Remove Overload
Emgu.CV.Cvb Namespace


CvBlobs.Remove Method (UInt32)

CvBlobsRemove Method (UInt32)

http://www.emgu.com
Removes the blob with the specific label

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    uint label
)
Public Function Remove (
    label As UInteger
) As Boolean
public:
virtual bool Remove(
    unsigned int label
) sealed
abstract Remove :
        label : uint32 -> bool
override Remove :
        label : uint32 -> bool

Parameters

label
Type: SystemUInt32
The label of the blob

Return Value

Type: Boolean
True if the element is successfully found and removed; otherwise, false.

Implements

IDictionaryTKey, TValueRemove(TKey)
See Also

Reference

CvBlobs Class
Remove Overload
Emgu.CV.Cvb Namespace


CvBlobs.TryGetValue Method

CvBlobsTryGetValue Method

Gets the blob associated with the specified label.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TryGetValue(
    uint label,
    out CvBlob blob
)
Public Function TryGetValue (
    label As UInteger,
    <OutAttribute> ByRef blob As CvBlob
) As Boolean
public:
virtual bool TryGetValue(
    unsigned int label,
    [OutAttribute] CvBlob^% blob
) sealed
abstract TryGetValue :
        label : uint32 *
        blob : CvBlob byref -> bool
override TryGetValue :
        label : uint32 *
        blob : CvBlob byref -> bool

Parameters

label
Type: SystemUInt32
The blob label
blob
Type: Emgu.CV.CvbCvBlob
When this method returns, contains the blob associated with the specified labe, if the label is found; otherwise, null. This parameter is passed uninitialized.

Return Value

Type: Boolean
True if the blobs contains a blob with the specific label; otherwise, false

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvBlobs Fields

The CvBlobs type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CvBlobs Class
Emgu.CV.Cvb Namespace


CvTrack Class

CvTrack
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.CvbCvTrack

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CvTrack : ValueType,
    IEquatable<CvTrack>
Public NotInheritable Class CvTrack
    Inherits ValueType
    Implements IEquatable(Of CvTrack)
public ref class CvTrack sealed : public ValueType,
    IEquatable<CvTrack^>
[<SealedAttribute>]
type CvTrack =
    class
        inherit ValueType
        interface IEquatable<CvTrack>
    end

The CvTrack type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the minimun bounding rectanble for this track
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(CvTrack) | Compares CvTrack for equality
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Active | Indicates number of frames that has been active from last inactive period.
Public field | BlobLabel | Label assigned to the blob related to this track
Public field | Centroid | Centroid
Public field | Id | Track identification number
Public field | Inactive | Indicates number of frames that has been missing.
Public field | Lifetime | Indicates how much frames the object has been in scene
Public field | MaxX | X max
Public field | MaxY | y max
Public field | MinX | X min
Public field | MinY | Y min
Top
See Also

Reference

Emgu.CV.Cvb Namespace


CvTrack Properties

The CvTrack type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the minimun bounding rectanble for this track
Top
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.BoundingBox Property

CvTrackBoundingBox Property

Get the minimun bounding rectanble for this track

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle BoundingBox { get; }
Public ReadOnly Property BoundingBox As Rectangle
    Get
public:
property Rectangle^ BoundingBox {
    Rectangle^ get ();
}
member BoundingBox : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack Methods

The CvTrack type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(CvTrack) | Compares CvTrack for equality
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.Equals Method

CvTrackEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(CvTrack) | Compares CvTrack for equality
Top
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.Equals Method (CvTrack)

CvTrackEquals Method (CvTrack)

http://www.emgu.com
Compares CvTrack for equality

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    CvTrack other
)
Public Function Equals (
    other As CvTrack
) As Boolean
public:
virtual bool Equals(
    CvTrack^ other
) sealed
abstract Equals :
        other : CvTrack -> bool
override Equals :
        other : CvTrack -> bool

Parameters

other
Type: Emgu.CV.CvbCvTrack
The other track to compares with

Return Value

Type: Boolean
True if the two CvTrack are equal; otherwise false.

Implements

IEquatableTEquals(T)
See Also

Reference

CvTrack Class
Equals Overload
Emgu.CV.Cvb Namespace


CvTrack Fields

The CvTrack type exposes the following members.

Fields
 | Name | Description
Public field | Active | Indicates number of frames that has been active from last inactive period.
Public field | BlobLabel | Label assigned to the blob related to this track
Public field | Centroid | Centroid
Public field | Id | Track identification number
Public field | Inactive | Indicates number of frames that has been missing.
Public field | Lifetime | Indicates how much frames the object has been in scene
Public field | MaxX | X max
Public field | MaxY | y max
Public field | MinX | X min
Public field | MinY | Y min
Top
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.Active Field

CvTrackActive Field

Indicates number of frames that has been active from last inactive period.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Active
Public Active As UInteger
public:
unsigned int Active
val mutable Active: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.BlobLabel Field

CvTrackBlobLabel Field

Label assigned to the blob related to this track

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint BlobLabel
Public BlobLabel As UInteger
public:
unsigned int BlobLabel
val mutable BlobLabel: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.Centroid Field

CvTrackCentroid Field

Centroid

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint2D64f Centroid
Public Centroid As MCvPoint2D64f
public:
MCvPoint2D64f^ Centroid
val mutable Centroid: MCvPoint2D64f

Field Value

Type: MCvPoint2D64f
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.Id Field

CvTrackId Field

Track identification number

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Id
Public Id As UInteger
public:
unsigned int Id
val mutable Id: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.Inactive Field

CvTrackInactive Field

Indicates number of frames that has been missing.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Inactive
Public Inactive As UInteger
public:
unsigned int Inactive
val mutable Inactive: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.Lifetime Field

CvTrackLifetime Field

Indicates how much frames the object has been in scene

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Lifetime
Public Lifetime As UInteger
public:
unsigned int Lifetime
val mutable Lifetime: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.MaxX Field

CvTrackMaxX Field

X max

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MaxX
Public MaxX As UInteger
public:
unsigned int MaxX
val mutable MaxX: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.MaxY Field

CvTrackMaxY Field

y max

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MaxY
Public MaxY As UInteger
public:
unsigned int MaxY
val mutable MaxY: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.MinX Field

CvTrackMinX Field

X min

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MinX
Public MinX As UInteger
public:
unsigned int MinX
val mutable MinX: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTrack.MinY Field

CvTrackMinY Field

Y min

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MinY
Public MinY As UInteger
public:
unsigned int MinY
val mutable MinY: uint32

Field Value

Type: UInt32
See Also

Reference

CvTrack Class
Emgu.CV.Cvb Namespace


CvTracks Class

Blobs tracking
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.CvbCvTracks

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CvTracks : UnmanagedObject, IDictionary<uint, CvTrack>,
    ICollection<KeyValuePair<uint, CvTrack>>, IEnumerable<KeyValuePair<uint, CvTrack>>,
    IEnumerable
Public Class CvTracks
    Inherits UnmanagedObject
    Implements IDictionary(Of UInteger, CvTrack),
    ICollection(Of KeyValuePair(Of UInteger, CvTrack)),
    IEnumerable(Of KeyValuePair(Of UInteger, CvTrack)),
    IEnumerable
public ref class CvTracks : public UnmanagedObject,
    IDictionary<unsigned int, CvTrack^>, ICollection<KeyValuePair<unsigned int, CvTrack^>^>,
    IEnumerable<KeyValuePair<unsigned int, CvTrack^>^>,
    IEnumerable
type CvTracks =
    class
        inherit UnmanagedObject
        interface IDictionary<uint32, CvTrack>
        interface ICollection<KeyValuePair<uint32, CvTrack>>
        interface IEnumerable<KeyValuePair<uint32, CvTrack>>
        interface IEnumerable
    end

The CvTracks type exposes the following members.

Constructors
 | Name | Description
Public method | CvTracks | Create a new CvTracks
Top
Properties
 | Name | Description
Public property | Count | Gets the number of id/track pairs contained in the collection.
Public property | IsReadOnly | Always false.
Public property | Item | Get or Set the Track with the specific id.
Public property | Keys | Get a collection containing the ids in the CvTracks.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Values | Get a collection containing the tracks in the CvTracks.
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairUInt32, CvTrack) | Adds the specified id and track to the CvTracks.
Public method | Add(UInt32, CvTrack) | Adds the specified id and track to the dictionary.
Public method | Clear | Removes all keys and values
Public method | Contains | Determines whether the CvTracks contains a specific id and CvTrack.
Public method | ContainsKey | Determines whether the CvTracks contains the specified id.
Public method | CopyTo | Copies the elements to the array, starting at the specific arrayIndex.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resources used by this CvBlobs (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Remove(KeyValuePairUInt32, CvTrack) | Removes a key and value from the dictionary.
Public method | Remove(UInt32) | Removes the track with the specific id
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the track associated with the specified id.
Public method | Update | Updates list of tracks based on current blobs.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Remarks
Tracking based on: A. Senior, A. Hampapur, Y-L Tian, L. Brown, S. Pankanti, R. Bolle. Appearance Models for Occlusion Handling. Second International workshop on Performance Evaluation of Tracking and Surveillance Systems & CVPR'01. December, 2001. (http://www.research.ibm.com/peoplevision/PETS2001.pdf)
See Also

Reference

Emgu.CV.Cvb Namespace


CvTracks Constructor

Create a new CvTracks

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvTracks()
Public Sub New
public:
CvTracks()
new : unit -> CvTracks
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks Properties

The CvTracks type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of id/track pairs contained in the collection.
Public property | IsReadOnly | Always false.
Public property | Item | Get or Set the Track with the specific id.
Public property | Keys | Get a collection containing the ids in the CvTracks.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Values | Get a collection containing the tracks in the CvTracks.
Top
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Count Property

CvTracksCount Property

Gets the number of id/track pairs contained in the collection.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.IsReadOnly Property

CvTracksIsReadOnly Property

Always false.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Item Property

CvTracksItem Property

Get or Set the Track with the specific id.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvTrack this[
    uint id
] { get; set; }
Public Property Item (
    id As UInteger
) As CvTrack
    Get
    Set
public:
virtual property CvTrack^ Item[unsigned int id] {
    CvTrack^ get (unsigned int id) sealed;
    void set (unsigned int id, CvTrack^ value) sealed;
}
abstract Item : CvTrack with get, set
override Item : CvTrack with get, set

Parameters

id
Type: SystemUInt32
The id of the Track

Property Value

Type: CvTrack

Implements

IDictionaryTKey, TValueItemTKey
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Keys Property

CvTracksKeys Property

Get a collection containing the ids in the CvTracks.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ICollection<uint> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of UInteger)
    Get
public:
virtual property ICollection<unsigned int>^ Keys {
    ICollection<unsigned int>^ get () sealed;
}
abstract Keys : ICollection<uint32> with get
override Keys : ICollection<uint32> with get

Property Value

Type: ICollection UInt32

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Values Property

CvTracksValues Property

Get a collection containing the tracks in the CvTracks.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ICollection<CvTrack> Values { get; }
Public ReadOnly Property Values As ICollection(Of CvTrack)
    Get
public:
virtual property ICollection<CvTrack^>^ Values {
    ICollection<CvTrack^>^ get () sealed;
}
abstract Values : ICollection<CvTrack> with get
override Values : ICollection<CvTrack> with get

Property Value

Type: ICollection CvTrack

Implements

IDictionaryTKey, TValueValues
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks Methods

The CvTracks type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairUInt32, CvTrack) | Adds the specified id and track to the CvTracks.
Public method | Add(UInt32, CvTrack) | Adds the specified id and track to the dictionary.
Public method | Clear | Removes all keys and values
Public method | Contains | Determines whether the CvTracks contains a specific id and CvTrack.
Public method | ContainsKey | Determines whether the CvTracks contains the specified id.
Public method | CopyTo | Copies the elements to the array, starting at the specific arrayIndex.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resources used by this CvBlobs (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Remove(KeyValuePairUInt32, CvTrack) | Removes a key and value from the dictionary.
Public method | Remove(UInt32) | Removes the track with the specific id
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the track associated with the specified id.
Public method | Update | Updates list of tracks based on current blobs.
Top
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Add Method

CvTracksAdd Method

Overload List
 | Name | Description
Public method | Add(KeyValuePairUInt32, CvTrack) | Adds the specified id and track to the CvTracks.
Public method | Add(UInt32, CvTrack) | Adds the specified id and track to the dictionary.
Top
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Add Method (KeyValuePair(UInt32, CvTrack))

CvTracksAdd Method (KeyValuePairUInt32, CvTrack)

http://www.emgu.com
Adds the specified id and track to the CvTracks.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    KeyValuePair<uint, CvTrack> item
)
Public Sub Add (
    item As KeyValuePair(Of UInteger, CvTrack)
)
public:
virtual void Add(
    KeyValuePair<unsigned int, CvTrack^>^ item
) sealed
abstract Add :
        item : KeyValuePair<uint32, CvTrack> -> unit
override Add :
        item : KeyValuePair<uint32, CvTrack> -> unit

Parameters

item
Type: System.Collections.GenericKeyValuePair UInt32, CvTrack
The structure representing the id and track to add to the CvTracks

Implements

ICollectionTAdd(T)
See Also

Reference

CvTracks Class
Add Overload
Emgu.CV.Cvb Namespace


CvTracks.Add Method (UInt32, CvTrack)

CvTracksAdd Method (UInt32, CvTrack)

http://www.emgu.com
Adds the specified id and track to the dictionary.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    uint id,
    CvTrack track
)
Public Sub Add (
    id As UInteger,
    track As CvTrack
)
public:
virtual void Add(
    unsigned int id,
    CvTrack^ track
) sealed
abstract Add :
        id : uint32 *
        track : CvTrack -> unit
override Add :
        id : uint32 *
        track : CvTrack -> unit

Parameters

id
Type: SystemUInt32
The id of the track
track
Type: Emgu.CV.CvbCvTrack
The track

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
See Also

Reference

CvTracks Class
Add Overload
Emgu.CV.Cvb Namespace


CvTracks.Clear Method

CvTracksClear Method

Removes all keys and values

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Contains Method

CvTracksContains Method

Determines whether the CvTracks contains a specific id and CvTrack.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    KeyValuePair<uint, CvTrack> item
)
Public Function Contains (
    item As KeyValuePair(Of UInteger, CvTrack)
) As Boolean
public:
virtual bool Contains(
    KeyValuePair<unsigned int, CvTrack^>^ item
) sealed
abstract Contains :
        item : KeyValuePair<uint32, CvTrack> -> bool
override Contains :
        item : KeyValuePair<uint32, CvTrack> -> bool

Parameters

item
Type: System.Collections.GenericKeyValuePair UInt32, CvTrack
The id and CvTrack to be located

Return Value

Type: Boolean
True if the item is found in the CvTracks; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.ContainsKey Method

CvTracksContainsKey Method

Determines whether the CvTracks contains the specified id.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    uint id
)
Public Function ContainsKey (
    id As UInteger
) As Boolean
public:
virtual bool ContainsKey(
    unsigned int id
) sealed
abstract ContainsKey :
        id : uint32 -> bool
override ContainsKey :
        id : uint32 -> bool

Parameters

id
Type: SystemUInt32
The id (key) to be located

Return Value

Type: Boolean
True if the CvTracks contains an element with the specific id

Implements

IDictionaryTKey, TValueContainsKey(TKey)
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.CopyTo Method

CvTracksCopyTo Method

Copies the elements to the array, starting at the specific arrayIndex.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    KeyValuePair<uint, CvTrack>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of UInteger, CvTrack)(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<KeyValuePair<unsigned int, CvTrack^>^>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : KeyValuePair<uint32, CvTrack>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<uint32, CvTrack>[] *
        arrayIndex : int -> unit

Parameters

array
Type: System.Collections.GenericKeyValuePair UInt32, CvTrack
The one-dimensional array that is the defination of the elements copied from the CvTracks. The array must have zero-base indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.DisposeObject Method

CvTracksDisposeObject Method

Release all the unmanaged resources used by this CvBlobs

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.GetEnumerator Method

CvTracksGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<KeyValuePair<uint, CvTrack>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of UInteger, CvTrack))
public:
virtual IEnumerator<KeyValuePair<unsigned int, CvTrack^>^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<uint32, CvTrack>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<uint32, CvTrack>>

Return Value

Type: IEnumerator KeyValuePair UInt32, CvTrack
An enumerator that can be used to iterate through the collection

Implements

IEnumerableTGetEnumerator
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Remove Method

CvTracksRemove Method

Overload List
 | Name | Description
Public method | Remove(KeyValuePairUInt32, CvTrack) | Removes a key and value from the dictionary.
Public method | Remove(UInt32) | Removes the track with the specific id
Top
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Remove Method (KeyValuePair(UInt32, CvTrack))

CvTracksRemove Method (KeyValuePairUInt32, CvTrack)

http://www.emgu.com
Removes a key and value from the dictionary.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    KeyValuePair<uint, CvTrack> item
)
Public Function Remove (
    item As KeyValuePair(Of UInteger, CvTrack)
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<unsigned int, CvTrack^>^ item
) sealed
abstract Remove :
        item : KeyValuePair<uint32, CvTrack> -> bool
override Remove :
        item : KeyValuePair<uint32, CvTrack> -> bool

Parameters

item
Type: System.Collections.GenericKeyValuePair UInt32, CvTrack
The structure representing the key and value to be removed

Return Value

Type: Boolean
True if the key are value is sucessfully found and removed; otherwise false.

Implements

ICollectionTRemove(T)
See Also

Reference

CvTracks Class
Remove Overload
Emgu.CV.Cvb Namespace


CvTracks.Remove Method (UInt32)

CvTracksRemove Method (UInt32)

http://www.emgu.com
Removes the track with the specific id

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    uint id
)
Public Function Remove (
    id As UInteger
) As Boolean
public:
virtual bool Remove(
    unsigned int id
) sealed
abstract Remove :
        id : uint32 -> bool
override Remove :
        id : uint32 -> bool

Parameters

id
Type: SystemUInt32
The id of the track

Return Value

Type: Boolean
True if the element is successfully found and removed; otherwise, false.

Implements

IDictionaryTKey, TValueRemove(TKey)
See Also

Reference

CvTracks Class
Remove Overload
Emgu.CV.Cvb Namespace


CvTracks.TryGetValue Method

CvTracksTryGetValue Method

Gets the track associated with the specified id.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TryGetValue(
    uint id,
    out CvTrack track
)
Public Function TryGetValue (
    id As UInteger,
    <OutAttribute> ByRef track As CvTrack
) As Boolean
public:
virtual bool TryGetValue(
    unsigned int id,
    [OutAttribute] CvTrack^% track
) sealed
abstract TryGetValue :
        id : uint32 *
        track : CvTrack byref -> bool
override TryGetValue :
        id : uint32 *
        track : CvTrack byref -> bool

Parameters

id
Type: SystemUInt32
The track id
track
Type: Emgu.CV.CvbCvTrack
When this method returns, contains the track associated with the specified id, if the id is found; otherwise, an empty track. This parameter is passed uninitialized.

Return Value

Type: Boolean
True if the tracks contains a track with the specific id; otherwise, false

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks.Update Method

CvTracksUpdate Method

Updates list of tracks based on current blobs.

Namespace: Emgu.CV.Cvb
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    CvBlobs blobs,
    double thDistance,
    uint thInactive,
    uint thActive
)
Public Sub Update (
    blobs As CvBlobs,
    thDistance As Double,
    thInactive As UInteger,
    thActive As UInteger
)
public:
void Update(
    CvBlobs^ blobs,
    double thDistance,
    unsigned int thInactive,
    unsigned int thActive
)
member Update :
        blobs : CvBlobs *
        thDistance : float *
        thInactive : uint32 *
        thActive : uint32 -> unit

Parameters

blobs
Type: Emgu.CV.CvbCvBlobs
List of blobs
thDistance
Type: SystemDouble
Distance Max distance to determine when a track and a blob match
thInactive
Type: SystemUInt32
Inactive Max number of frames a track can be inactive
thActive
Type: SystemUInt32
Active If a track becomes inactive but it has been active less than thActive frames, the track will be deleted.
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


CvTracks Fields

The CvTracks type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CvTracks Class
Emgu.CV.Cvb Namespace


Emgu.CV.CvEnum Namespace

OpenCV Enumeration
Classes
 | Class | Description
Public class | AccessType | Access type
Public class | AdaptiveThresholdType | Types of Adaptive Threshold
Public class | BackOrFront | Specific if it is back or front
Public class | BorderType | The type for CopyMakeBorder function
Public class | CalibCbType | Type of chessboard calibration
Public class | CalibCgType | Type of circles grid calibration
Public class | CalibType | Various camera calibration flags
Public class | CapProp | CV Capture property identifier
Public class | ChainApproxMethod | contour approximation method
Public class | CheckType | Enumeration used by cvCheckArr
Public class | CloningMethod | Seamless clone method
Public class | CmpType | Type used for cvCmp function
Public class | ColorConversion | Color Conversion code
Public class | ColorMapType | The type of color map
Public class | ConnectedComponentsTypes | Connected components algorithm output formats
Public class | Connectivity | The type for cvSampleLine
Public class | ContoursMatchType | Type used by cvMatchShapes
Public class | CovarMethod | cvCalcCovarMatrix method types
Public class | DctType | Flag used for cvDCT
Public class | DecompMethod | cvInvert method
Public class | DepthType | OpenCV depth type
Public class | DistLabelType | Distance transform algorithm flags
Public class | DistType | Defines for Distance Transform
Public class | DxtType | Flag used for cvDFT
Public class | EdgePreservingFilterFlag | Edge preserving filter flag
Public class | EigobjType | IO type for eigen object related functions
Public class | ElementShape | Shape of the Structuring Element
Public class | ErrorCodes | Error codes
Public class | FlipType | Enumeration used by cvFlip
Public class | FloodFillType | Type of floodfill operation
Public class | FmType | Calculates fundamental matrix given a set of corresponding points
Public class | FontFace | Fonts
Public class | GemmType | Flags used for GEMM function
Public class | General | General enumeration
Public class | GrabcutInitType | Grabcut initialization type
Public class | HaarDetectionType | The types for haar detection
Public class | HandEyeCalibrationMethod | HandEyeCalibration Method
Public class | HistogramCompMethod | Histogram comparison method
Public class | HoughType | Hough detection type
Public class | ImreadModes | cvLoadImage type
Public class | ImwriteFlags | Flags for Imwrite function
Public class | InpaintType | Inpaint type
Public class | Inter | Interpolation types
Public class | IplDepth | IPL_DEPTH
Public class | KMeansInitType | KMeans initialization type
Public class | LineType | The type of line for drawing
Public class | LKFlowFlag | Type for cvCalcOpticalFlowPyrLK
Public class | MarkerTypes | The type of Marker for drawing
Public class | MorphOp | Morphology operation type
Public class | MotionType | Motion type for the FindTransformECC function
Public class | MulSpectrumsType | The types for MulSpectrums
Public class | NamedWindowType | The named window type
Public class | NormType | Type for Norm
Public class | OpticalflowFarnebackFlag | The available flags for Farneback optical flow computation
Public class | Orientation | Orientation
Public class | PcaType | PCA Type
Public class | RectIntersectType | Rectangle intersect type
Public class | ReduceDimension | Type used for Reduce function
Public class | ReduceType | Type used for Reduce function
Public class | RetrType | Contour retrieval mode
Public class | RobustEstimationAlgorithm | Type of Robust Estimation Algorithm
Public class | RotateFlags | The rotation type
Public class | SeqEltype | Sequence element type
Public class | SeqFlag | Sequence flag
Public class | SeqKind | The kind of sequence available
Public class | SeqType | Sequence type for point sets
Public class | SmoothType | Interpolation type
Public class | SolveLPResult | The return value for solveLP function
Public class | SolvePnpMethod | Method for solving a PnP problem
Public class | SortFlags | Flags for sorting
Public class | StereoBmPrefilter | Stereo Block Matching Prefilter type
Public class | StereoRectifyType | Type used in cvStereoRectify
Public class | StorageOp | The file storage operation type
Public class | Subdiv2DPointLocationType | The result type of cvSubdiv2DLocate.
Public class | SvdFlag | Type for cvSVD
Public class | TemplateMatchingType | Methods for comparing two array
Public class | TermCritType | CV TERMCRIT type
Public class | ThresholdType | Types of thresholding
Public class | Warp | Types for WarpAffine


AccessType Class

Access type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumAccessType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class AccessType : Enum
Public NotInheritable Class AccessType
    Inherits Enum
public ref class AccessType sealed : public Enum
[<SealedAttribute>]
type AccessType =
    class
        inherit Enum
    end

The AccessType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Fast | Fast
 | Mask | Mask
 | Read | Read
 | ReadWrite | Read and write
Public field | value__ |
 | Write | Write
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


AccessType Methods

The AccessType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AccessType Fields

The AccessType type exposes the following members.

Fields
 | Name | Description
 | Fast | Fast
 | Mask | Mask
 | Read | Read
 | ReadWrite | Read and write
Public field | value__ |
 | Write | Write
Top
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AccessType.Fast Field

AccessTypeFast Field

Fast

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AccessType Fast = 67108864
Public Const Fast As AccessType = 67108864
public:
literal AccessType^ Fast = 67108864
static val mutable Fast: AccessType

Field Value

Type: AccessType
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AccessType.Mask Field

AccessTypeMask Field

Mask

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AccessType Mask = 50331648
Public Const Mask As AccessType = 50331648
public:
literal AccessType^ Mask = 50331648
static val mutable Mask: AccessType

Field Value

Type: AccessType
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AccessType.Read Field

AccessTypeRead Field

Read

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AccessType Read = 16777216
Public Const Read As AccessType = 16777216
public:
literal AccessType^ Read = 16777216
static val mutable Read: AccessType

Field Value

Type: AccessType
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AccessType.ReadWrite Field

AccessTypeReadWrite Field

Read and write

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AccessType ReadWrite = 50331648
Public Const ReadWrite As AccessType = 50331648
public:
literal AccessType^ ReadWrite = 50331648
static val mutable ReadWrite: AccessType

Field Value

Type: AccessType
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AccessType.value__ Field

AccessTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.AccessType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AccessType.Write Field

AccessTypeWrite Field

Write

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AccessType Write = 33554432
Public Const Write As AccessType = 33554432
public:
literal AccessType^ Write = 33554432
static val mutable Write: AccessType

Field Value

Type: AccessType
See Also

Reference

AccessType Class
Emgu.CV.CvEnum Namespace


AdaptiveThresholdType Class

Types of Adaptive Threshold
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumAdaptiveThresholdType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class AdaptiveThresholdType : Enum
Public NotInheritable Class AdaptiveThresholdType
    Inherits Enum
public ref class AdaptiveThresholdType sealed : public Enum
[<SealedAttribute>]
type AdaptiveThresholdType =
    class
        inherit Enum
    end

The AdaptiveThresholdType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | GaussianC | Indicates that Gaussian minus C should be used for adaptive threshold.
 | MeanC | Indicates that Mean minus C should be used for adaptive threshold.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


AdaptiveThresholdType Methods

The AdaptiveThresholdType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

AdaptiveThresholdType Class
Emgu.CV.CvEnum Namespace


AdaptiveThresholdType Fields

The AdaptiveThresholdType type exposes the following members.

Fields
 | Name | Description
 | GaussianC | Indicates that Gaussian minus C should be used for adaptive threshold.
 | MeanC | Indicates that Mean minus C should be used for adaptive threshold.
Public field | value__ |
Top
See Also

Reference

AdaptiveThresholdType Class
Emgu.CV.CvEnum Namespace


AdaptiveThresholdType.GaussianC Field

AdaptiveThresholdTypeGaussianC Field

Indicates that Gaussian minus C should be used for adaptive threshold.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AdaptiveThresholdType GaussianC = 1
Public Const GaussianC As AdaptiveThresholdType = 1
public:
literal AdaptiveThresholdType^ GaussianC = 1
static val mutable GaussianC: AdaptiveThresholdType

Field Value

Type: AdaptiveThresholdType
See Also

Reference

AdaptiveThresholdType Class
Emgu.CV.CvEnum Namespace


AdaptiveThresholdType.MeanC Field

AdaptiveThresholdTypeMeanC Field

Indicates that Mean minus C should be used for adaptive threshold.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AdaptiveThresholdType MeanC = 0
Public Const MeanC As AdaptiveThresholdType = 0
public:
literal AdaptiveThresholdType^ MeanC = 0
static val mutable MeanC: AdaptiveThresholdType

Field Value

Type: AdaptiveThresholdType
See Also

Reference

AdaptiveThresholdType Class
Emgu.CV.CvEnum Namespace


AdaptiveThresholdType.value__ Field

AdaptiveThresholdTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.AdaptiveThresholdType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

AdaptiveThresholdType Class
Emgu.CV.CvEnum Namespace


BackOrFront Class

Specific if it is back or front
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumBackOrFront

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class BackOrFront : Enum
Public NotInheritable Class BackOrFront
    Inherits Enum
public ref class BackOrFront sealed : public Enum
[<SealedAttribute>]
type BackOrFront =
    class
        inherit Enum
    end

The BackOrFront type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Back | Back
 | Front | Front
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


BackOrFront Methods

The BackOrFront type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BackOrFront Class
Emgu.CV.CvEnum Namespace


BackOrFront Fields

The BackOrFront type exposes the following members.

Fields
 | Name | Description
 | Back | Back
 | Front | Front
Public field | value__ |
Top
See Also

Reference

BackOrFront Class
Emgu.CV.CvEnum Namespace


BackOrFront.Back Field

BackOrFrontBack Field

Back

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BackOrFront Back = 0
Public Const Back As BackOrFront = 0
public:
literal BackOrFront^ Back = 0
static val mutable Back: BackOrFront

Field Value

Type: BackOrFront
See Also

Reference

BackOrFront Class
Emgu.CV.CvEnum Namespace


BackOrFront.Front Field

BackOrFrontFront Field

Front

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BackOrFront Front = 1
Public Const Front As BackOrFront = 1
public:
literal BackOrFront^ Front = 1
static val mutable Front: BackOrFront

Field Value

Type: BackOrFront
See Also

Reference

BackOrFront Class
Emgu.CV.CvEnum Namespace


BackOrFront.value__ Field

BackOrFrontvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.BackOrFront.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BackOrFront Class
Emgu.CV.CvEnum Namespace


BorderType Class

The type for CopyMakeBorder function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumBorderType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class BorderType : Enum
Public NotInheritable Class BorderType
    Inherits Enum
public ref class BorderType sealed : public Enum
[<SealedAttribute>]
type BorderType =
    class
        inherit Enum
    end

The BorderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Constant | Border is filled with the fixed value, passed as last parameter of the function
 | Default | The default border interpolation type.
 | Isolated | Do not look outside of ROI
 | NegativeOne | Used by some cuda methods, will pass the value -1 to the function
 | Reflect | Reflect
 | Reflect101 | Reflect 101
 | Replicate | The pixels from the top and bottom rows, the left-most and right-most columns are replicated to fill the border
 | Transparent | Transparent
Public field | value__ |
 | Wrap | Wrap
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


BorderType Methods

The BorderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType Fields

The BorderType type exposes the following members.

Fields
 | Name | Description
 | Constant | Border is filled with the fixed value, passed as last parameter of the function
 | Default | The default border interpolation type.
 | Isolated | Do not look outside of ROI
 | NegativeOne | Used by some cuda methods, will pass the value -1 to the function
 | Reflect | Reflect
 | Reflect101 | Reflect 101
 | Replicate | The pixels from the top and bottom rows, the left-most and right-most columns are replicated to fill the border
 | Transparent | Transparent
Public field | value__ |
 | Wrap | Wrap
Top
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Constant Field

BorderTypeConstant Field

Border is filled with the fixed value, passed as last parameter of the function

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Constant = 0
Public Const Constant As BorderType = 0
public:
literal BorderType^ Constant = 0
static val mutable Constant: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Default Field

BorderTypeDefault Field

The default border interpolation type.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Default = 4
Public Const Default As BorderType = 4
public:
literal BorderType^ Default = 4
static val mutable Default: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Isolated Field

BorderTypeIsolated Field

Do not look outside of ROI

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Isolated = 16
Public Const Isolated As BorderType = 16
public:
literal BorderType^ Isolated = 16
static val mutable Isolated: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.NegativeOne Field

BorderTypeNegativeOne Field

Used by some cuda methods, will pass the value -1 to the function

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType NegativeOne = -1
Public Const NegativeOne As BorderType = -1
public:
literal BorderType^ NegativeOne = -1
static val mutable NegativeOne: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Reflect Field

BorderTypeReflect Field

Reflect

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Reflect = 2
Public Const Reflect As BorderType = 2
public:
literal BorderType^ Reflect = 2
static val mutable Reflect: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Reflect101 Field

BorderTypeReflect101 Field

Reflect 101

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Reflect101 = 4
Public Const Reflect101 As BorderType = 4
public:
literal BorderType^ Reflect101 = 4
static val mutable Reflect101: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Replicate Field

BorderTypeReplicate Field

The pixels from the top and bottom rows, the left-most and right-most columns are replicated to fill the border

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Replicate = 1
Public Const Replicate As BorderType = 1
public:
literal BorderType^ Replicate = 1
static val mutable Replicate: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Transparent Field

BorderTypeTransparent Field

Transparent

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Transparent = 5
Public Const Transparent As BorderType = 5
public:
literal BorderType^ Transparent = 5
static val mutable Transparent: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.value__ Field

BorderTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.BorderType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


BorderType.Wrap Field

BorderTypeWrap Field

Wrap

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BorderType Wrap = 3
Public Const Wrap As BorderType = 3
public:
literal BorderType^ Wrap = 3
static val mutable Wrap: BorderType

Field Value

Type: BorderType
See Also

Reference

BorderType Class
Emgu.CV.CvEnum Namespace


CalibCbType Class

Type of chessboard calibration
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCalibCbType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class CalibCbType : Enum
<FlagsAttribute>
Public NotInheritable Class CalibCbType
    Inherits Enum
[FlagsAttribute]
public ref class CalibCbType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type CalibCbType =
    class
        inherit Enum
    end

The CalibCbType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Accuracy | Up sample input image to improve sub-pixel accuracy due to aliasing effects. This should be used if an accurate camera calibration is required.
 | AdaptiveThresh | Use adaptive thresholding to convert the image to black-n-white, rather than a fixed threshold level (computed from the average image brightness)
 | Default | Default type
 | Exhaustive | Run an exhaustive search to improve detection rate.
 | FastCheck | If it is on, then this check is performed before the main algorithm and if a chessboard is not found, the function returns 0 instead of wasting 0.3-1s on doing the full search.
 | FilterQuads | Use additional criteria (like contour area, perimeter, square-like shape) to filter out false quads that are extracted at the contour retrieval stage
 | NormalizeImage | Normalize the image using cvNormalizeHist before applying fixed or adaptive thresholding.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CalibCbType Methods

The CalibCbType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType Fields

The CalibCbType type exposes the following members.

Fields
 | Name | Description
 | Accuracy | Up sample input image to improve sub-pixel accuracy due to aliasing effects. This should be used if an accurate camera calibration is required.
 | AdaptiveThresh | Use adaptive thresholding to convert the image to black-n-white, rather than a fixed threshold level (computed from the average image brightness)
 | Default | Default type
 | Exhaustive | Run an exhaustive search to improve detection rate.
 | FastCheck | If it is on, then this check is performed before the main algorithm and if a chessboard is not found, the function returns 0 instead of wasting 0.3-1s on doing the full search.
 | FilterQuads | Use additional criteria (like contour area, perimeter, square-like shape) to filter out false quads that are extracted at the contour retrieval stage
 | NormalizeImage | Normalize the image using cvNormalizeHist before applying fixed or adaptive thresholding.
Public field | value__ |
Top
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.Accuracy Field

CalibCbTypeAccuracy Field

Up sample input image to improve sub-pixel accuracy due to aliasing effects. This should be used if an accurate camera calibration is required.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCbType Accuracy = 32
Public Const Accuracy As CalibCbType = 32
public:
literal CalibCbType^ Accuracy = 32
static val mutable Accuracy: CalibCbType

Field Value

Type: CalibCbType
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.AdaptiveThresh Field

CalibCbTypeAdaptiveThresh Field

Use adaptive thresholding to convert the image to black-n-white, rather than a fixed threshold level (computed from the average image brightness)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCbType AdaptiveThresh = 1
Public Const AdaptiveThresh As CalibCbType = 1
public:
literal CalibCbType^ AdaptiveThresh = 1
static val mutable AdaptiveThresh: CalibCbType

Field Value

Type: CalibCbType
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.Default Field

CalibCbTypeDefault Field

Default type

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCbType Default = 0
Public Const Default As CalibCbType = 0
public:
literal CalibCbType^ Default = 0
static val mutable Default: CalibCbType

Field Value

Type: CalibCbType
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.Exhaustive Field

CalibCbTypeExhaustive Field

Run an exhaustive search to improve detection rate.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCbType Exhaustive = 16
Public Const Exhaustive As CalibCbType = 16
public:
literal CalibCbType^ Exhaustive = 16
static val mutable Exhaustive: CalibCbType

Field Value

Type: CalibCbType
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.FastCheck Field

CalibCbTypeFastCheck Field

If it is on, then this check is performed before the main algorithm and if a chessboard is not found, the function returns 0 instead of wasting 0.3-1s on doing the full search.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCbType FastCheck = 8
Public Const FastCheck As CalibCbType = 8
public:
literal CalibCbType^ FastCheck = 8
static val mutable FastCheck: CalibCbType

Field Value

Type: CalibCbType
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.FilterQuads Field

CalibCbTypeFilterQuads Field

Use additional criteria (like contour area, perimeter, square-like shape) to filter out false quads that are extracted at the contour retrieval stage

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCbType FilterQuads = 4
Public Const FilterQuads As CalibCbType = 4
public:
literal CalibCbType^ FilterQuads = 4
static val mutable FilterQuads: CalibCbType

Field Value

Type: CalibCbType
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.NormalizeImage Field

CalibCbTypeNormalizeImage Field

Normalize the image using cvNormalizeHist before applying fixed or adaptive thresholding.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCbType NormalizeImage = 2
Public Const NormalizeImage As CalibCbType = 2
public:
literal CalibCbType^ NormalizeImage = 2
static val mutable NormalizeImage: CalibCbType

Field Value

Type: CalibCbType
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCbType.value__ Field

CalibCbTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CalibCbType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CalibCbType Class
Emgu.CV.CvEnum Namespace


CalibCgType Class

Type of circles grid calibration
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCalibCgType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class CalibCgType : Enum
<FlagsAttribute>
Public NotInheritable Class CalibCgType
    Inherits Enum
[FlagsAttribute]
public ref class CalibCgType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type CalibCgType =
    class
        inherit Enum
    end

The CalibCgType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AsymmetricGrid | Asymmetric grid
 | Clustering | Clustering
 | SymmetricGrid | Symmetric grid
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CalibCgType Methods

The CalibCgType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CalibCgType Class
Emgu.CV.CvEnum Namespace


CalibCgType Fields

The CalibCgType type exposes the following members.

Fields
 | Name | Description
 | AsymmetricGrid | Asymmetric grid
 | Clustering | Clustering
 | SymmetricGrid | Symmetric grid
Public field | value__ |
Top
See Also

Reference

CalibCgType Class
Emgu.CV.CvEnum Namespace


CalibCgType.AsymmetricGrid Field

CalibCgTypeAsymmetricGrid Field

Asymmetric grid

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCgType AsymmetricGrid = 2
Public Const AsymmetricGrid As CalibCgType = 2
public:
literal CalibCgType^ AsymmetricGrid = 2
static val mutable AsymmetricGrid: CalibCgType

Field Value

Type: CalibCgType
See Also

Reference

CalibCgType Class
Emgu.CV.CvEnum Namespace


CalibCgType.Clustering Field

CalibCgTypeClustering Field

Clustering

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCgType Clustering = 4
Public Const Clustering As CalibCgType = 4
public:
literal CalibCgType^ Clustering = 4
static val mutable Clustering: CalibCgType

Field Value

Type: CalibCgType
See Also

Reference

CalibCgType Class
Emgu.CV.CvEnum Namespace


CalibCgType.SymmetricGrid Field

CalibCgTypeSymmetricGrid Field

Symmetric grid

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibCgType SymmetricGrid = 1
Public Const SymmetricGrid As CalibCgType = 1
public:
literal CalibCgType^ SymmetricGrid = 1
static val mutable SymmetricGrid: CalibCgType

Field Value

Type: CalibCgType
See Also

Reference

CalibCgType Class
Emgu.CV.CvEnum Namespace


CalibCgType.value__ Field

CalibCgTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CalibCgType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CalibCgType Class
Emgu.CV.CvEnum Namespace


CalibType Class

Various camera calibration flags
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCalibType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class CalibType : Enum
<FlagsAttribute>
Public NotInheritable Class CalibType
    Inherits Enum
[FlagsAttribute]
public ref class CalibType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type CalibType =
    class
        inherit Enum
    end

The CalibType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The default value
 | FixAspectRatio | The optimization procedure consider only one of fx and fy as independent variable and keeps the aspect ratio fx/fy the same as it was set initially in intrinsic_matrix. In this case the actual initial values of (fx, fy) are either taken from the matrix (when CV_CALIB_USE_INTRINSIC_GUESS is set) or estimated somehow (in the latter case fx, fy may be set to arbitrary values, only their ratio is used)
 | FixFocalLength | The focal length is fixed
 | FixIntrinsic | Only for stereo: Fix intrinsic
 | FixK1 | The 1st distortion coefficient (k1) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK2 | The 2nd distortion coefficient (k2) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK3 | The 3rd distortion coefficient (k3) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK4 | The 4th distortion coefficient (k4) is fixed (see above)
 | FixK5 | The 5th distortion coefficient (k5) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK6 | The 6th distortion coefficient (k6) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixPrincipalPoint | The principal point is not changed during the global optimization, it stays at the center and at the other location specified (when CV_CALIB_FIX_FOCAL_LENGTH - Both fx and fy are fixed. CV_CALIB_USE_INTRINSIC_GUESS is set as well)
 | FixS1S2S3S4 | Fix S1, S2, S3, S4
 | FixTauxTauy | Fix Taux Tauy
 | RationalModel | Rational model
 | SameFocalLength | Only for stereo: Same focal length
 | ThinPrismModel | Thin prism model
 | TiltedModel | Tilted model
 | UseIntrinsicGuess | intrinsic_matrix contains valid initial values of fx, fy, cx, cy that are optimized further. Otherwise, (cx, cy) is initially set to the image center (image_size is used here), and focal distances are computed in some least-squares fashion
 | UseLU | For stereo rectification: use LU instead of SVD decomposition for solving. much faster but potentially less precise
 | UseQR | Use QR instead of SVD decomposition for solving. Faster but potentially less precise
Public field | value__ |
 | ZeroDisparity | For stereo rectification: Zero disparity
 | ZeroTangentDist | Tangential distortion coefficients are set to zeros and do not change during the optimization
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CalibType Methods

The CalibType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType Fields

The CalibType type exposes the following members.

Fields
 | Name | Description
 | Default | The default value
 | FixAspectRatio | The optimization procedure consider only one of fx and fy as independent variable and keeps the aspect ratio fx/fy the same as it was set initially in intrinsic_matrix. In this case the actual initial values of (fx, fy) are either taken from the matrix (when CV_CALIB_USE_INTRINSIC_GUESS is set) or estimated somehow (in the latter case fx, fy may be set to arbitrary values, only their ratio is used)
 | FixFocalLength | The focal length is fixed
 | FixIntrinsic | Only for stereo: Fix intrinsic
 | FixK1 | The 1st distortion coefficient (k1) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK2 | The 2nd distortion coefficient (k2) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK3 | The 3rd distortion coefficient (k3) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK4 | The 4th distortion coefficient (k4) is fixed (see above)
 | FixK5 | The 5th distortion coefficient (k5) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixK6 | The 6th distortion coefficient (k6) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed
 | FixPrincipalPoint | The principal point is not changed during the global optimization, it stays at the center and at the other location specified (when CV_CALIB_FIX_FOCAL_LENGTH - Both fx and fy are fixed. CV_CALIB_USE_INTRINSIC_GUESS is set as well)
 | FixS1S2S3S4 | Fix S1, S2, S3, S4
 | FixTauxTauy | Fix Taux Tauy
 | RationalModel | Rational model
 | SameFocalLength | Only for stereo: Same focal length
 | ThinPrismModel | Thin prism model
 | TiltedModel | Tilted model
 | UseIntrinsicGuess | intrinsic_matrix contains valid initial values of fx, fy, cx, cy that are optimized further. Otherwise, (cx, cy) is initially set to the image center (image_size is used here), and focal distances are computed in some least-squares fashion
 | UseLU | For stereo rectification: use LU instead of SVD decomposition for solving. much faster but potentially less precise
 | UseQR | Use QR instead of SVD decomposition for solving. Faster but potentially less precise
Public field | value__ |
 | ZeroDisparity | For stereo rectification: Zero disparity
 | ZeroTangentDist | Tangential distortion coefficients are set to zeros and do not change during the optimization
Top
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.Default Field

CalibTypeDefault Field

The default value

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType Default = 0
Public Const Default As CalibType = 0
public:
literal CalibType^ Default = 0
static val mutable Default: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixAspectRatio Field

CalibTypeFixAspectRatio Field

The optimization procedure consider only one of fx and fy as independent variable and keeps the aspect ratio fx/fy the same as it was set initially in intrinsic_matrix. In this case the actual initial values of (fx, fy) are either taken from the matrix (when CV_CALIB_USE_INTRINSIC_GUESS is set) or estimated somehow (in the latter case fx, fy may be set to arbitrary values, only their ratio is used)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixAspectRatio = 2
Public Const FixAspectRatio As CalibType = 2
public:
literal CalibType^ FixAspectRatio = 2
static val mutable FixAspectRatio: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixFocalLength Field

CalibTypeFixFocalLength Field

The focal length is fixed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixFocalLength = 16
Public Const FixFocalLength As CalibType = 16
public:
literal CalibType^ FixFocalLength = 16
static val mutable FixFocalLength: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixIntrinsic Field

CalibTypeFixIntrinsic Field

Only for stereo: Fix intrinsic

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixIntrinsic = 256
Public Const FixIntrinsic As CalibType = 256
public:
literal CalibType^ FixIntrinsic = 256
static val mutable FixIntrinsic: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixK1 Field

CalibTypeFixK1 Field

The 1st distortion coefficient (k1) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixK1 = 32
Public Const FixK1 As CalibType = 32
public:
literal CalibType^ FixK1 = 32
static val mutable FixK1: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixK2 Field

CalibTypeFixK2 Field

The 2nd distortion coefficient (k2) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixK2 = 64
Public Const FixK2 As CalibType = 64
public:
literal CalibType^ FixK2 = 64
static val mutable FixK2: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixK3 Field

CalibTypeFixK3 Field

The 3rd distortion coefficient (k3) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixK3 = 128
Public Const FixK3 As CalibType = 128
public:
literal CalibType^ FixK3 = 128
static val mutable FixK3: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixK4 Field

CalibTypeFixK4 Field

The 4th distortion coefficient (k4) is fixed (see above)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixK4 = 2048
Public Const FixK4 As CalibType = 2048
public:
literal CalibType^ FixK4 = 2048
static val mutable FixK4: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixK5 Field

CalibTypeFixK5 Field

The 5th distortion coefficient (k5) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixK5 = 4096
Public Const FixK5 As CalibType = 4096
public:
literal CalibType^ FixK5 = 4096
static val mutable FixK5: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixK6 Field

CalibTypeFixK6 Field

The 6th distortion coefficient (k6) is fixed to 0 or to the initial passed value if CV_CALIB_USE_INTRINSIC_GUESS is passed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixK6 = 8192
Public Const FixK6 As CalibType = 8192
public:
literal CalibType^ FixK6 = 8192
static val mutable FixK6: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixPrincipalPoint Field

CalibTypeFixPrincipalPoint Field

The principal point is not changed during the global optimization, it stays at the center and at the other location specified (when CV_CALIB_FIX_FOCAL_LENGTH - Both fx and fy are fixed. CV_CALIB_USE_INTRINSIC_GUESS is set as well)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixPrincipalPoint = 4
Public Const FixPrincipalPoint As CalibType = 4
public:
literal CalibType^ FixPrincipalPoint = 4
static val mutable FixPrincipalPoint: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixS1S2S3S4 Field

CalibTypeFixS1S2S3S4 Field

Fix S1, S2, S3, S4

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixS1S2S3S4 = 65536
Public Const FixS1S2S3S4 As CalibType = 65536
public:
literal CalibType^ FixS1S2S3S4 = 65536
static val mutable FixS1S2S3S4: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.FixTauxTauy Field

CalibTypeFixTauxTauy Field

Fix Taux Tauy

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType FixTauxTauy = 524288
Public Const FixTauxTauy As CalibType = 524288
public:
literal CalibType^ FixTauxTauy = 524288
static val mutable FixTauxTauy: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.RationalModel Field

CalibTypeRationalModel Field

Rational model

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType RationalModel = 16384
Public Const RationalModel As CalibType = 16384
public:
literal CalibType^ RationalModel = 16384
static val mutable RationalModel: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.SameFocalLength Field

CalibTypeSameFocalLength Field

Only for stereo: Same focal length

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType SameFocalLength = 512
Public Const SameFocalLength As CalibType = 512
public:
literal CalibType^ SameFocalLength = 512
static val mutable SameFocalLength: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.ThinPrismModel Field

CalibTypeThinPrismModel Field

Thin prism model

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType ThinPrismModel = 32768
Public Const ThinPrismModel As CalibType = 32768
public:
literal CalibType^ ThinPrismModel = 32768
static val mutable ThinPrismModel: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.TiltedModel Field

CalibTypeTiltedModel Field

Tilted model

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType TiltedModel = 262144
Public Const TiltedModel As CalibType = 262144
public:
literal CalibType^ TiltedModel = 262144
static val mutable TiltedModel: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.UseIntrinsicGuess Field

CalibTypeUseIntrinsicGuess Field

intrinsic_matrix contains valid initial values of fx, fy, cx, cy that are optimized further. Otherwise, (cx, cy) is initially set to the image center (image_size is used here), and focal distances are computed in some least-squares fashion

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType UseIntrinsicGuess = 1
Public Const UseIntrinsicGuess As CalibType = 1
public:
literal CalibType^ UseIntrinsicGuess = 1
static val mutable UseIntrinsicGuess: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.UseLU Field

CalibTypeUseLU Field

For stereo rectification: use LU instead of SVD decomposition for solving. much faster but potentially less precise

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType UseLU = 131072
Public Const UseLU As CalibType = 131072
public:
literal CalibType^ UseLU = 131072
static val mutable UseLU: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.UseQR Field

CalibTypeUseQR Field

Use QR instead of SVD decomposition for solving. Faster but potentially less precise

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType UseQR = 1048576
Public Const UseQR As CalibType = 1048576
public:
literal CalibType^ UseQR = 1048576
static val mutable UseQR: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.value__ Field

CalibTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CalibType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.ZeroDisparity Field

CalibTypeZeroDisparity Field

For stereo rectification: Zero disparity

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType ZeroDisparity = 1024
Public Const ZeroDisparity As CalibType = 1024
public:
literal CalibType^ ZeroDisparity = 1024
static val mutable ZeroDisparity: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CalibType.ZeroTangentDist Field

CalibTypeZeroTangentDist Field

Tangential distortion coefficients are set to zeros and do not change during the optimization

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CalibType ZeroTangentDist = 8
Public Const ZeroTangentDist As CalibType = 8
public:
literal CalibType^ ZeroTangentDist = 8
static val mutable ZeroTangentDist: CalibType

Field Value

Type: CalibType
See Also

Reference

CalibType Class
Emgu.CV.CvEnum Namespace


CapProp Class

CV Capture property identifier
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCapProp

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CapProp : Enum
Public NotInheritable Class CapProp
    Inherits Enum
public ref class CapProp sealed : public Enum
[<SealedAttribute>]
type CapProp =
    class
        inherit Enum
    end

The CapProp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AndroidAntibanding | Android anti banding
 | AndroidExposeLock | Android expose lock
 | AndroidFlashMode | Android flash mode
 | AndroidFocalLength | Android focal length
 | AndroidFocusDistanceFar | Android focus distance far
 | AndroidFocusDistanceNear | Android focus distance near
 | AndroidFocusDistanceOptimal | Android focus distance optimal
 | AndroidFocusMode | Android focus mode
 | AndroidWhiteBalance | Android white balance
 | AndroidWhitebalanceLock | Android white balance lock
 | AutoExposure | Exposure control done by camera, user can adjust reference level using this feature
 | Autofocus | Auto focus
 | Autograb | property for highgui class CvCapture_Android only
 | AutoWb | Enable/ disable auto white-balance
 | Backend | Current backend (enum VideoCaptureAPIs). Read-only property
 | Backlight | Backlight
 | Brightness | Brightness of the image (only for those cameras that support).
 | Buffersuze | Buffer size
 | Channel | Video input or Channel Number (only for those cameras that support)
 | Contrast | Contrast of the image (only for cameras).
 | ConvertRgb | Boolean flags indicating whether images should be converted to RGB.
 | DC1394ModeAuto | DC1394 mode auto
 | DC1394ModeManual | Set automatically when a value of the feature is set by the user
 | DC1394ModeOnePushAuto | DC1394 mode one push auto
 | DC1394Off | Turn the feature off (not controlled manually nor automatically)
 | Exposure | Exposure (only for those cameras that support).
 | Focus | Focus
 | Format | Format of the %Mat objects returned by VideoCapture::retrieve().
 | FourCC | 4-character code of codec
 | Fps | Frame rate
 | FrameCount | Number of frames in video file
 | FrameHeight | Height of frames in the video stream
 | FrameWidth | Width of frames in the video stream
 | Gain | Gain of the image (only for those cameras that support).
 | Gamma | Gamma
 | GigaFrameHeighMax | Smartek Giganetix Ethernet Vision: frame height max
 | GigaFrameOffsetX | Smartek Giganetix Ethernet Vision: frame offset X
 | GigaFrameOffsetY | Smartek Giganetix Ethernet Vision: frame offset Y
 | GigaFrameSensHeigh | Smartek Giganetix Ethernet Vision: frame sens height
 | GigaFrameSensWidth | Smartek Giganetix Ethernet Vision: frame sens width
 | GigaFrameWidthMax | Smartek Giganetix Ethernet Vision: frame width max
 | GstreamerQueueLength | Properties of cameras available through GStreamer interface. Default is 1
 | Guid | GUID
 | Hue | Hue of the image (only for cameras).
 | IntelpercDepthConfidenceThreshold | Intelperc Depth Confidence Threshold
 | IntelpercDepthFocalLengthHorz | Intelperc Depth Focal Length Horz
 | IntelpercDepthFocalLengthVert | Intelperc Depth Focal Length Vert
 | IntelpercDepthGenerator | Intelperc Depth Generator
 | IntelpercDepthLowConfidenceValue | Intelperc Depth Low Confidence Value
 | IntelpercDepthSaturationValue | Intelperc Depth Saturation Value
 | IntelpercGeneratorsMask | Intelperc Generators Mask
 | IntelpercImageGenerator | Intelperc Image Generator
 | IntelpercProfileCount | Intelperc Profile Count
 | IntelpercProfileIdx | Intelperc Profile Idx
 | IOSDeviceExposure | iOS device exposure
 | IOSDeviceFlash | iOS device flash
 | IOSDeviceFocus | iOS device focus
 | IOSDeviceTorch | iOS device torch
 | IOSDeviceWhitebalance | iOS device white-balance
 | Iris | Iris
 | IsoSpeed | ISO SPEED
 | MaxDC1394 | MAX DC1394
 | Mode | Backend-specific value indicating the current capture mode.
 | Monochrome | Monochrome
 | Openni2Mirror | OpenNI2 Mirror
 | Openni2Sync | OpenNI2 Sync
 | OpenniApproxFrameSync | Approx frame sync
 | OpenniBaseline | Properties of cameras available through OpenNI interfaces, in mm.
 | OpenniCircleBuffer | Circle buffer
 | OpenniDepthGenerator | OpenNI depth generator
 | OpenniDepthGeneratorBaseline | Depth generator baseline, in mm.
 | OpenniDepthGeneratorFocalLength | Depth generator focal length, in pixels.
 | OpenniDepthGeneratorPresent | Depth generator present
 | OpenniDepthGeneratorRegistration | Openni generator registration
 | OpenniDepthGeneratorRegistrationOn | Openni generator registration on
 | OpenniFocalLength | Properties of cameras available through OpenNI interfaces, in pixels.
 | OpenniFrameMaxDepth | Properties of cameras available through OpenNI interfaces, in mm.
 | OpenniGeneratorPresent | Generator present
 | OpenniGeneratorsMask | OpenNI map generators
 | OpenniImageGenerator | OpenNI image generator
 | OpenniImageGeneratorOutputMode | Image generator output mode
 | OpenniImageGeneratorPresent | Openni image generator present
 | OpenniIRGenerator | OpenNI IR generator
 | OpenniIRGeneratorPresent | Openni IR generator present
 | OpenniMaxBufferSize | Max buffer size
 | OpenniMaxTimeDuration | Max time duration
 | OpenniOutputMode | Properties of cameras available through OpenNI interfaces
 | OpenniRegistration | Flag that synchronizes the remapping depth map to image map by changing depth generator's view point (if the flag is "on") or sets this view point to its normal one (if the flag is "off").
 | OpenniRegistrationOn | Flag that synchronizes the remapping depth map to image map by changing depth generator's view point (if the flag is "on") or sets this view point to its normal one (if the flag is "off").
 | Pan | Pan
 | PosAviRatio | Relative position of the video file: 0=start of the film, 1=end of the film.
 | PosFrames | 0-based index of the frame to be decoded/captured next
 | PosMsec | Film current position in milliseconds or video capture timestamp
 | PreviewFormat | readonly, tricky property, returns cpnst char* indeed
 | PvapiBinningX | Horizontal binning factor
 | PvapiBinningY | Vertical binning factor
 | PvapiDecimationHorizontal | Horizontal sub-sampling of the image
 | PvapiDecimationVertical | Vertical sub-sampling of the image
 | PvapiFrameStartTriggerMode | FrameStartTriggerMode: Determines how a frame is initiated
 | PvapiMulticastip | Ip for enable multicast master mode. 0 for disable multicast
 | PvapiPixelFormat | Pixel format
 | Rectification | Rectification flag for stereo cameras (note: only supported by DC1394 v 2.x backend currently).
 | Roll | Roll
 | SarDen | Sample aspect ratio: num/den (den)
 | SarNum | Sample aspect ratio: num/den (num)
 | Saturation | Saturation of the image (only for cameras).
 | Settings | Pop up video/camera filter dialog (note: only supported by DSHOW backend currently. The property value is ignored)
 | Sharpness | Sharpness
 | SupportedPreviewSizesString | readonly, tricky property, returns cpnst char* indeed
 | Temperature | Temperature
 | Tilt | Tilt
 | Trigger | Trigger
 | TriggerDelay | Trigger delay
Public field | value__ |
 | WbTemperature | White-balance color temperature
 | WhiteBalanceBlueU | Currently unsupported.
 | WhiteBalanceRedV | White balance red v
 | XiAcqBufferSize | Acquisition buffer size in buffer_size_unit. Default bytes.
 | XiAcqBufferSizeUnit | Acquisition buffer size unit in bytes. Default 1. E.g. Value 1024 means that buffer_size is in KiBytes
 | XiAcqFrameBurstCount | Sets number of frames acquired by burst. This burst is used only if trigger is set to FrameBurstStart
 | XiAcqTimingMode | Type of sensor frames timing.
 | XiAcqTransportBufferCommit | Number of buffers to commit to low level
 | XiAcqTransportBufferSize | Acquisition transport buffer size in bytes
 | XiAeag | Automatic exposure/gain
 | XiAeagLevel | Average intensity of output signal AEAG should achieve(in %)
 | XiAeagRoiHeight | Automatic exposure/gain ROI Height
 | XiAeagRoiOffsetX | Automatic exposure/gain ROI offset X
 | XiAeagRoiOffsetY | Automatic exposure/gain ROI offset Y
 | XiAeagRoiWidth | Automatic exposure/gain ROI Width
 | XiAeMaxLimit | Maximum limit of exposure in AEAG procedure
 | XiAgMaxLimit | Maximum limit of gain in AEAG procedure
 | XiApplyCms | Enable applying of CMS profiles to xiGetImage (see XI_PRM_INPUT_CMS_PROFILE, XI_PRM_OUTPUT_CMS_PROFILE).
 | XiAutoBandwidthCalculation | Automatic bandwidth calculation,
 | XiAutoWb | Automatic white balance
 | XiAvailableBandwidth | Calculate and return available interface bandwidth(int Megabits)
 | XiBinningHorizontal | Horizontal Binning - number of horizontal photo-sensitive cells to combine together.
 | XiBinningPattern | Binning pattern type.
 | XiBinningSelector | Binning engine selector.
 | XiBinningVertical | Vertical Binning - number of vertical photo-sensitive cells to combine together.
 | XiBpc | Correction of bad pixels
 | XiBufferPolicy | Data move policy
 | XiBuffersQueueSize | Queue of field/frame buffers
 | XiCcMatrix00 | Color Correction Matrix element [0][0]
 | XiCcMatrix01 | Color Correction Matrix element [0][1]
 | XiCcMatrix02 | Color Correction Matrix element [0][2]
 | XiCcMatrix03 | Color Correction Matrix element [0][3]
 | XiCcMatrix10 | Color Correction Matrix element [1][0]
 | XiCcMatrix11 | Color Correction Matrix element [1][1]
 | XiCcMatrix12 | Color Correction Matrix element [1][2]
 | XiCcMatrix13 | Color Correction Matrix element [1][3]
 | XiCcMatrix20 | Color Correction Matrix element [2][0]
 | XiCcMatrix21 | Color Correction Matrix element [2][1]
 | XiCcMatrix22 | Color Correction Matrix element [2][2]
 | XiCcMatrix23 | Color Correction Matrix element [2][3]
 | XiCcMatrix30 | Color Correction Matrix element [3][0]
 | XiCcMatrix31 | Color Correction Matrix element [3][1]
 | XiCcMatrix32 | Color Correction Matrix element [3][2]
 | XiCcMatrix33 | Color Correction Matrix element [3][3]
 | XiChipTemp | Camera sensor temperature
 | XiCms | Mode of color management system.
 | XiColorFilterArray | Returns color filter array type of RAW data.
 | XiColumnFpnCorrection | Correction of column FPN
 | XiCooling | Start camera cooling.
 | XiCounterSelector | Select counter
 | XiCounterValue | Counter status
 | XiDataFormat | Output data format
 | XiDebounceEn | Enable/Disable debounce to selected GPI
 | XiDebouncePol | Debounce polarity (pol = 1 t0 - falling edge, t1 - rising edge)
 | XiDebounceT0 | Debounce time (x * 10us)
 | XiDebounceT1 | Debounce time (x * 10us)
 | XiDebugLevel | Set debug level
 | XiDecimationHorizontal | Horizontal Decimation - horizontal sub-sampling of the image - reduces the horizontal resolution of the image by the specified vertical decimation factor.
 | XiDecimationPattern | Decimation pattern type.
 | XiDecimationSelector | Decimation engine selector.
 | XiDecimationVertical | Vertical Decimation - vertical sub-sampling of the image - reduces the vertical resolution of the image by the specified vertical decimation factor.
 | XiDefaultCcMatrix | Set default Color Correction Matrix
 | XiDeviceModelId | Return device model id
 | XiDeviceReset | Resets the camera to default state.
 | XiDeviceSn | Return device serial number
 | XiDownsampling | Change image resolution by binning or skipping.
 | XiDownsamplingType | Change image downsampling type.
 | XiExposure | Exposure time in microseconds
 | XiExposureBurstCount | Sets the number of times of exposure in one frame.
 | XiExpPriority | Exposure priority (0.5 - exposure 50%, gain 50%).
 | XiFfsAccessKey | Setting of key enables file operations on some cameras.
 | XiFfsFileId | File number.
 | XiFfsFileSize | Size of file.
 | XiFramerate | Define framerate in Hz
 | XiFreeFfsSize | Size of free camera FFS.
 | XiGain | Gain in dB
 | XiGainSelector | Gain selector for parameter Gain allows to select different type of gains.
 | XiGammac | Chromaticity gamma
 | XiGammay | Luminosity gamma
 | XiGpiLevel | Get general purpose level
 | XiGpiMode | Set general purpose input mode
 | XiGpiSelector | Selects general purpose input
 | XiGpoMode | Set general purpose output mode
 | XiGpoSelector | Selects general purpose output
 | XiHdr | Enable High Dynamic Range feature.
 | XiHdrKneepointCount | The number of kneepoints in the PWLR.
 | XiHdrT1 | position of first kneepoint(in % of XI_PRM_EXPOSURE)
 | XiHdrT2 | position of second kneepoint (in % of XI_PRM_EXPOSURE)
 | XiHeight | Height of the Image provided by the device (in pixels).
 | XiHousBackSideTemp | Camera housing back side temperature
 | XiHousTemp | Camera housing temperature
 | XiHwRevision | Returns hardware revision number.
 | XiImageBlackLevel | Last image black level counts. Can be used for Offline processing to recall it.
 | XiImageDataBitDepth | bitdepth of data returned by function xiGetImage
 | XiImageDataFormat | Output data format.
 | XiImageDataFormatRgb32Alpha | The alpha channel of RGB32 output image format.
 | XiImageIsColor | Returns 1 for color cameras.
 | XiImagePayloadSize | Buffer size in bytes sufficient for output image returned by xiGetImage
 | XiIsCooled | Returns 1 for cameras that support cooling.
 | XiIsDeviceExist | Returns 1 if camera connected and works properly.
 | XiKneepoint1 | value of first kneepoint (% of sensor saturation)
 | XiKneepoint2 | value of second kneepoint (% of sensor saturation)
 | XiLedMode | Define camera signaling LED functionality
 | XiLedSelector | Selects camera signaling LED
 | XiLensApertureValue | Current lens aperture value in stops. Examples: 2.8, 4, 5.6, 8, 11
 | XiLensFeature | Allows access to lens feature value currently selected by XI_PRM_LENS_FEATURE_SELECTOR.
 | XiLensFeatureSelector | Selects the current feature which is accessible by XI_PRM_LENS_FEATURE.
 | XiLensFocalLength | Lens focal distance in mm.
 | XiLensFocusDistance | Lens focus distance in cm.
 | XiLensFocusMove | Moves lens focus motor by steps set in XI_PRM_LENS_FOCUS_MOVEMENT_VALUE.
 | XiLensFocusMovementValue | Lens current focus movement value to be used by XI_PRM_LENS_FOCUS_MOVE in motor steps.
 | XiLensMode | Status of lens control interface. This shall be set to XI_ON before any Lens operations.
 | XiLimitBandwidth | Set/get bandwidth(datarate)(in Megabits)
 | XiLutEn | Activates LUT.
 | XiLutIndex | Control the index (offset) of the coefficient to access in the LUT.
 | XiLutValue | Value at entry LUTIndex of the LUT
 | XiManualWb | Calculates White Balance(must be called during acquisition)
 | XiOffsetX | Horizontal offset from the origin to the area of interest (in pixels).
 | XiOffsetY | Vertical offset from the origin to the area of interest (in pixels).
 | XiOutputDataBitDepth | Device output data bit depth.
 | XiOutputDataPacking | Device output data packing (or grouping) enabled. Packing could be enabled if output_data_bit_depth > 8 and packing capability is available.
 | XiOutputDataPackingType | Data packing type. Some cameras supports only specific packing type.
 | XiRecentFrame | GetImage returns most recent frame
 | XiRegionMode | Activates/deactivates Region selected by Region Selector
 | XiRegionSelector | Selects Region in Multiple ROI which parameters are set by width, height, ... ,region mode
 | XiRowFpnCorrection | Correction of row FPN
 | XiSensorBoardTemp | Camera sensor board temperature
 | XiSensorClockFreqHz | Sensor clock frequency in Hz.
 | XiSensorClockFreqIndex | Sensor clock frequency index. Sensor with selected frequencies have possibility to set the frequency only by this index.
 | XiSensorDataBitDepth | Sensor output data bit depth.
 | XiSensorFeatureSelector | Selects the current feature which is accessible by XI_PRM_SENSOR_FEATURE_VALUE.
 | XiSensorFeatureValue | Allows access to sensor feature value currently selected by XI_PRM_SENSOR_FEATURE_SELECTOR.
 | XiSensorMode | Current sensor mode. Allows to select sensor mode by one integer. Setting of this parameter affects: image dimensions and downsampling.
 | XiSensorOutputChannelCount | Number of output channels from sensor used for data transfer.
 | XiSensorTaps | Number of taps
 | XiSharpness | Sharpness Strength
 | XiShutterType | Change sensor shutter type(CMOS sensor).
 | XiTargetTemp | Set sensor target temperature for cooling.
 | XiTestPattern | Selects which test pattern type is generated by the selected generator.
 | XiTestPatternGeneratorSelector | Selects which test pattern generator is controlled by the TestPattern feature.
 | XiTimeout | Image capture timeout in milliseconds
 | XiTransportPixelFormat | Current format of pixels on transport layer.
 | XiTrgDelay | Specifies the delay in microseconds (us) to apply after the trigger reception before activating it.
 | XiTrgSelector | Selects the type of trigger.
 | XiTrgSoftware | Generates an internal trigger. PRM_TRG_SOURCE must be set to TRG_SOFTWARE.
 | XiTrgSource | Defines source of trigger.
 | XiTsRstMode | Defines how time stamp reset engine will be armed
 | XiTsRstSource | Defines which source will be used for timestamp reset. Writing this parameter will trigger settings of engine (arming)
 | XiUsedFfsSize | Size of used camera FFS.
 | XiWbKb | White balance blue coefficient
 | XiWbKg | White balance green coefficient
 | XiWbKr | White balance red coefficient
 | XiWidth | Width of the Image provided by the device (in pixels).
 | Zoom | Zoom
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CapProp Methods

The CapProp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp Fields

The CapProp type exposes the following members.

Fields
 | Name | Description
 | AndroidAntibanding | Android anti banding
 | AndroidExposeLock | Android expose lock
 | AndroidFlashMode | Android flash mode
 | AndroidFocalLength | Android focal length
 | AndroidFocusDistanceFar | Android focus distance far
 | AndroidFocusDistanceNear | Android focus distance near
 | AndroidFocusDistanceOptimal | Android focus distance optimal
 | AndroidFocusMode | Android focus mode
 | AndroidWhiteBalance | Android white balance
 | AndroidWhitebalanceLock | Android white balance lock
 | AutoExposure | Exposure control done by camera, user can adjust reference level using this feature
 | Autofocus | Auto focus
 | Autograb | property for highgui class CvCapture_Android only
 | AutoWb | Enable/ disable auto white-balance
 | Backend | Current backend (enum VideoCaptureAPIs). Read-only property
 | Backlight | Backlight
 | Brightness | Brightness of the image (only for those cameras that support).
 | Buffersuze | Buffer size
 | Channel | Video input or Channel Number (only for those cameras that support)
 | Contrast | Contrast of the image (only for cameras).
 | ConvertRgb | Boolean flags indicating whether images should be converted to RGB.
 | DC1394ModeAuto | DC1394 mode auto
 | DC1394ModeManual | Set automatically when a value of the feature is set by the user
 | DC1394ModeOnePushAuto | DC1394 mode one push auto
 | DC1394Off | Turn the feature off (not controlled manually nor automatically)
 | Exposure | Exposure (only for those cameras that support).
 | Focus | Focus
 | Format | Format of the %Mat objects returned by VideoCapture::retrieve().
 | FourCC | 4-character code of codec
 | Fps | Frame rate
 | FrameCount | Number of frames in video file
 | FrameHeight | Height of frames in the video stream
 | FrameWidth | Width of frames in the video stream
 | Gain | Gain of the image (only for those cameras that support).
 | Gamma | Gamma
 | GigaFrameHeighMax | Smartek Giganetix Ethernet Vision: frame height max
 | GigaFrameOffsetX | Smartek Giganetix Ethernet Vision: frame offset X
 | GigaFrameOffsetY | Smartek Giganetix Ethernet Vision: frame offset Y
 | GigaFrameSensHeigh | Smartek Giganetix Ethernet Vision: frame sens height
 | GigaFrameSensWidth | Smartek Giganetix Ethernet Vision: frame sens width
 | GigaFrameWidthMax | Smartek Giganetix Ethernet Vision: frame width max
 | GstreamerQueueLength | Properties of cameras available through GStreamer interface. Default is 1
 | Guid | GUID
 | Hue | Hue of the image (only for cameras).
 | IntelpercDepthConfidenceThreshold | Intelperc Depth Confidence Threshold
 | IntelpercDepthFocalLengthHorz | Intelperc Depth Focal Length Horz
 | IntelpercDepthFocalLengthVert | Intelperc Depth Focal Length Vert
 | IntelpercDepthGenerator | Intelperc Depth Generator
 | IntelpercDepthLowConfidenceValue | Intelperc Depth Low Confidence Value
 | IntelpercDepthSaturationValue | Intelperc Depth Saturation Value
 | IntelpercGeneratorsMask | Intelperc Generators Mask
 | IntelpercImageGenerator | Intelperc Image Generator
 | IntelpercProfileCount | Intelperc Profile Count
 | IntelpercProfileIdx | Intelperc Profile Idx
 | IOSDeviceExposure | iOS device exposure
 | IOSDeviceFlash | iOS device flash
 | IOSDeviceFocus | iOS device focus
 | IOSDeviceTorch | iOS device torch
 | IOSDeviceWhitebalance | iOS device white-balance
 | Iris | Iris
 | IsoSpeed | ISO SPEED
 | MaxDC1394 | MAX DC1394
 | Mode | Backend-specific value indicating the current capture mode.
 | Monochrome | Monochrome
 | Openni2Mirror | OpenNI2 Mirror
 | Openni2Sync | OpenNI2 Sync
 | OpenniApproxFrameSync | Approx frame sync
 | OpenniBaseline | Properties of cameras available through OpenNI interfaces, in mm.
 | OpenniCircleBuffer | Circle buffer
 | OpenniDepthGenerator | OpenNI depth generator
 | OpenniDepthGeneratorBaseline | Depth generator baseline, in mm.
 | OpenniDepthGeneratorFocalLength | Depth generator focal length, in pixels.
 | OpenniDepthGeneratorPresent | Depth generator present
 | OpenniDepthGeneratorRegistration | Openni generator registration
 | OpenniDepthGeneratorRegistrationOn | Openni generator registration on
 | OpenniFocalLength | Properties of cameras available through OpenNI interfaces, in pixels.
 | OpenniFrameMaxDepth | Properties of cameras available through OpenNI interfaces, in mm.
 | OpenniGeneratorPresent | Generator present
 | OpenniGeneratorsMask | OpenNI map generators
 | OpenniImageGenerator | OpenNI image generator
 | OpenniImageGeneratorOutputMode | Image generator output mode
 | OpenniImageGeneratorPresent | Openni image generator present
 | OpenniIRGenerator | OpenNI IR generator
 | OpenniIRGeneratorPresent | Openni IR generator present
 | OpenniMaxBufferSize | Max buffer size
 | OpenniMaxTimeDuration | Max time duration
 | OpenniOutputMode | Properties of cameras available through OpenNI interfaces
 | OpenniRegistration | Flag that synchronizes the remapping depth map to image map by changing depth generator's view point (if the flag is "on") or sets this view point to its normal one (if the flag is "off").
 | OpenniRegistrationOn | Flag that synchronizes the remapping depth map to image map by changing depth generator's view point (if the flag is "on") or sets this view point to its normal one (if the flag is "off").
 | Pan | Pan
 | PosAviRatio | Relative position of the video file: 0=start of the film, 1=end of the film.
 | PosFrames | 0-based index of the frame to be decoded/captured next
 | PosMsec | Film current position in milliseconds or video capture timestamp
 | PreviewFormat | readonly, tricky property, returns cpnst char* indeed
 | PvapiBinningX | Horizontal binning factor
 | PvapiBinningY | Vertical binning factor
 | PvapiDecimationHorizontal | Horizontal sub-sampling of the image
 | PvapiDecimationVertical | Vertical sub-sampling of the image
 | PvapiFrameStartTriggerMode | FrameStartTriggerMode: Determines how a frame is initiated
 | PvapiMulticastip | Ip for enable multicast master mode. 0 for disable multicast
 | PvapiPixelFormat | Pixel format
 | Rectification | Rectification flag for stereo cameras (note: only supported by DC1394 v 2.x backend currently).
 | Roll | Roll
 | SarDen | Sample aspect ratio: num/den (den)
 | SarNum | Sample aspect ratio: num/den (num)
 | Saturation | Saturation of the image (only for cameras).
 | Settings | Pop up video/camera filter dialog (note: only supported by DSHOW backend currently. The property value is ignored)
 | Sharpness | Sharpness
 | SupportedPreviewSizesString | readonly, tricky property, returns cpnst char* indeed
 | Temperature | Temperature
 | Tilt | Tilt
 | Trigger | Trigger
 | TriggerDelay | Trigger delay
Public field | value__ |
 | WbTemperature | White-balance color temperature
 | WhiteBalanceBlueU | Currently unsupported.
 | WhiteBalanceRedV | White balance red v
 | XiAcqBufferSize | Acquisition buffer size in buffer_size_unit. Default bytes.
 | XiAcqBufferSizeUnit | Acquisition buffer size unit in bytes. Default 1. E.g. Value 1024 means that buffer_size is in KiBytes
 | XiAcqFrameBurstCount | Sets number of frames acquired by burst. This burst is used only if trigger is set to FrameBurstStart
 | XiAcqTimingMode | Type of sensor frames timing.
 | XiAcqTransportBufferCommit | Number of buffers to commit to low level
 | XiAcqTransportBufferSize | Acquisition transport buffer size in bytes
 | XiAeag | Automatic exposure/gain
 | XiAeagLevel | Average intensity of output signal AEAG should achieve(in %)
 | XiAeagRoiHeight | Automatic exposure/gain ROI Height
 | XiAeagRoiOffsetX | Automatic exposure/gain ROI offset X
 | XiAeagRoiOffsetY | Automatic exposure/gain ROI offset Y
 | XiAeagRoiWidth | Automatic exposure/gain ROI Width
 | XiAeMaxLimit | Maximum limit of exposure in AEAG procedure
 | XiAgMaxLimit | Maximum limit of gain in AEAG procedure
 | XiApplyCms | Enable applying of CMS profiles to xiGetImage (see XI_PRM_INPUT_CMS_PROFILE, XI_PRM_OUTPUT_CMS_PROFILE).
 | XiAutoBandwidthCalculation | Automatic bandwidth calculation,
 | XiAutoWb | Automatic white balance
 | XiAvailableBandwidth | Calculate and return available interface bandwidth(int Megabits)
 | XiBinningHorizontal | Horizontal Binning - number of horizontal photo-sensitive cells to combine together.
 | XiBinningPattern | Binning pattern type.
 | XiBinningSelector | Binning engine selector.
 | XiBinningVertical | Vertical Binning - number of vertical photo-sensitive cells to combine together.
 | XiBpc | Correction of bad pixels
 | XiBufferPolicy | Data move policy
 | XiBuffersQueueSize | Queue of field/frame buffers
 | XiCcMatrix00 | Color Correction Matrix element [0][0]
 | XiCcMatrix01 | Color Correction Matrix element [0][1]
 | XiCcMatrix02 | Color Correction Matrix element [0][2]
 | XiCcMatrix03 | Color Correction Matrix element [0][3]
 | XiCcMatrix10 | Color Correction Matrix element [1][0]
 | XiCcMatrix11 | Color Correction Matrix element [1][1]
 | XiCcMatrix12 | Color Correction Matrix element [1][2]
 | XiCcMatrix13 | Color Correction Matrix element [1][3]
 | XiCcMatrix20 | Color Correction Matrix element [2][0]
 | XiCcMatrix21 | Color Correction Matrix element [2][1]
 | XiCcMatrix22 | Color Correction Matrix element [2][2]
 | XiCcMatrix23 | Color Correction Matrix element [2][3]
 | XiCcMatrix30 | Color Correction Matrix element [3][0]
 | XiCcMatrix31 | Color Correction Matrix element [3][1]
 | XiCcMatrix32 | Color Correction Matrix element [3][2]
 | XiCcMatrix33 | Color Correction Matrix element [3][3]
 | XiChipTemp | Camera sensor temperature
 | XiCms | Mode of color management system.
 | XiColorFilterArray | Returns color filter array type of RAW data.
 | XiColumnFpnCorrection | Correction of column FPN
 | XiCooling | Start camera cooling.
 | XiCounterSelector | Select counter
 | XiCounterValue | Counter status
 | XiDataFormat | Output data format
 | XiDebounceEn | Enable/Disable debounce to selected GPI
 | XiDebouncePol | Debounce polarity (pol = 1 t0 - falling edge, t1 - rising edge)
 | XiDebounceT0 | Debounce time (x * 10us)
 | XiDebounceT1 | Debounce time (x * 10us)
 | XiDebugLevel | Set debug level
 | XiDecimationHorizontal | Horizontal Decimation - horizontal sub-sampling of the image - reduces the horizontal resolution of the image by the specified vertical decimation factor.
 | XiDecimationPattern | Decimation pattern type.
 | XiDecimationSelector | Decimation engine selector.
 | XiDecimationVertical | Vertical Decimation - vertical sub-sampling of the image - reduces the vertical resolution of the image by the specified vertical decimation factor.
 | XiDefaultCcMatrix | Set default Color Correction Matrix
 | XiDeviceModelId | Return device model id
 | XiDeviceReset | Resets the camera to default state.
 | XiDeviceSn | Return device serial number
 | XiDownsampling | Change image resolution by binning or skipping.
 | XiDownsamplingType | Change image downsampling type.
 | XiExposure | Exposure time in microseconds
 | XiExposureBurstCount | Sets the number of times of exposure in one frame.
 | XiExpPriority | Exposure priority (0.5 - exposure 50%, gain 50%).
 | XiFfsAccessKey | Setting of key enables file operations on some cameras.
 | XiFfsFileId | File number.
 | XiFfsFileSize | Size of file.
 | XiFramerate | Define framerate in Hz
 | XiFreeFfsSize | Size of free camera FFS.
 | XiGain | Gain in dB
 | XiGainSelector | Gain selector for parameter Gain allows to select different type of gains.
 | XiGammac | Chromaticity gamma
 | XiGammay | Luminosity gamma
 | XiGpiLevel | Get general purpose level
 | XiGpiMode | Set general purpose input mode
 | XiGpiSelector | Selects general purpose input
 | XiGpoMode | Set general purpose output mode
 | XiGpoSelector | Selects general purpose output
 | XiHdr | Enable High Dynamic Range feature.
 | XiHdrKneepointCount | The number of kneepoints in the PWLR.
 | XiHdrT1 | position of first kneepoint(in % of XI_PRM_EXPOSURE)
 | XiHdrT2 | position of second kneepoint (in % of XI_PRM_EXPOSURE)
 | XiHeight | Height of the Image provided by the device (in pixels).
 | XiHousBackSideTemp | Camera housing back side temperature
 | XiHousTemp | Camera housing temperature
 | XiHwRevision | Returns hardware revision number.
 | XiImageBlackLevel | Last image black level counts. Can be used for Offline processing to recall it.
 | XiImageDataBitDepth | bitdepth of data returned by function xiGetImage
 | XiImageDataFormat | Output data format.
 | XiImageDataFormatRgb32Alpha | The alpha channel of RGB32 output image format.
 | XiImageIsColor | Returns 1 for color cameras.
 | XiImagePayloadSize | Buffer size in bytes sufficient for output image returned by xiGetImage
 | XiIsCooled | Returns 1 for cameras that support cooling.
 | XiIsDeviceExist | Returns 1 if camera connected and works properly.
 | XiKneepoint1 | value of first kneepoint (% of sensor saturation)
 | XiKneepoint2 | value of second kneepoint (% of sensor saturation)
 | XiLedMode | Define camera signaling LED functionality
 | XiLedSelector | Selects camera signaling LED
 | XiLensApertureValue | Current lens aperture value in stops. Examples: 2.8, 4, 5.6, 8, 11
 | XiLensFeature | Allows access to lens feature value currently selected by XI_PRM_LENS_FEATURE_SELECTOR.
 | XiLensFeatureSelector | Selects the current feature which is accessible by XI_PRM_LENS_FEATURE.
 | XiLensFocalLength | Lens focal distance in mm.
 | XiLensFocusDistance | Lens focus distance in cm.
 | XiLensFocusMove | Moves lens focus motor by steps set in XI_PRM_LENS_FOCUS_MOVEMENT_VALUE.
 | XiLensFocusMovementValue | Lens current focus movement value to be used by XI_PRM_LENS_FOCUS_MOVE in motor steps.
 | XiLensMode | Status of lens control interface. This shall be set to XI_ON before any Lens operations.
 | XiLimitBandwidth | Set/get bandwidth(datarate)(in Megabits)
 | XiLutEn | Activates LUT.
 | XiLutIndex | Control the index (offset) of the coefficient to access in the LUT.
 | XiLutValue | Value at entry LUTIndex of the LUT
 | XiManualWb | Calculates White Balance(must be called during acquisition)
 | XiOffsetX | Horizontal offset from the origin to the area of interest (in pixels).
 | XiOffsetY | Vertical offset from the origin to the area of interest (in pixels).
 | XiOutputDataBitDepth | Device output data bit depth.
 | XiOutputDataPacking | Device output data packing (or grouping) enabled. Packing could be enabled if output_data_bit_depth > 8 and packing capability is available.
 | XiOutputDataPackingType | Data packing type. Some cameras supports only specific packing type.
 | XiRecentFrame | GetImage returns most recent frame
 | XiRegionMode | Activates/deactivates Region selected by Region Selector
 | XiRegionSelector | Selects Region in Multiple ROI which parameters are set by width, height, ... ,region mode
 | XiRowFpnCorrection | Correction of row FPN
 | XiSensorBoardTemp | Camera sensor board temperature
 | XiSensorClockFreqHz | Sensor clock frequency in Hz.
 | XiSensorClockFreqIndex | Sensor clock frequency index. Sensor with selected frequencies have possibility to set the frequency only by this index.
 | XiSensorDataBitDepth | Sensor output data bit depth.
 | XiSensorFeatureSelector | Selects the current feature which is accessible by XI_PRM_SENSOR_FEATURE_VALUE.
 | XiSensorFeatureValue | Allows access to sensor feature value currently selected by XI_PRM_SENSOR_FEATURE_SELECTOR.
 | XiSensorMode | Current sensor mode. Allows to select sensor mode by one integer. Setting of this parameter affects: image dimensions and downsampling.
 | XiSensorOutputChannelCount | Number of output channels from sensor used for data transfer.
 | XiSensorTaps | Number of taps
 | XiSharpness | Sharpness Strength
 | XiShutterType | Change sensor shutter type(CMOS sensor).
 | XiTargetTemp | Set sensor target temperature for cooling.
 | XiTestPattern | Selects which test pattern type is generated by the selected generator.
 | XiTestPatternGeneratorSelector | Selects which test pattern generator is controlled by the TestPattern feature.
 | XiTimeout | Image capture timeout in milliseconds
 | XiTransportPixelFormat | Current format of pixels on transport layer.
 | XiTrgDelay | Specifies the delay in microseconds (us) to apply after the trigger reception before activating it.
 | XiTrgSelector | Selects the type of trigger.
 | XiTrgSoftware | Generates an internal trigger. PRM_TRG_SOURCE must be set to TRG_SOFTWARE.
 | XiTrgSource | Defines source of trigger.
 | XiTsRstMode | Defines how time stamp reset engine will be armed
 | XiTsRstSource | Defines which source will be used for timestamp reset. Writing this parameter will trigger settings of engine (arming)
 | XiUsedFfsSize | Size of used camera FFS.
 | XiWbKb | White balance blue coefficient
 | XiWbKg | White balance green coefficient
 | XiWbKr | White balance red coefficient
 | XiWidth | Width of the Image provided by the device (in pixels).
 | Zoom | Zoom
Top
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidAntibanding Field

CapPropAndroidAntibanding Field

Android anti banding

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidAntibanding = 8004
Public Const AndroidAntibanding As CapProp = 8004
public:
literal CapProp^ AndroidAntibanding = 8004
static val mutable AndroidAntibanding: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidExposeLock Field

CapPropAndroidExposeLock Field

Android expose lock

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidExposeLock = 8009
Public Const AndroidExposeLock As CapProp = 8009
public:
literal CapProp^ AndroidExposeLock = 8009
static val mutable AndroidExposeLock: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidFlashMode Field

CapPropAndroidFlashMode Field

Android flash mode

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidFlashMode = 8001
Public Const AndroidFlashMode As CapProp = 8001
public:
literal CapProp^ AndroidFlashMode = 8001
static val mutable AndroidFlashMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidFocalLength Field

CapPropAndroidFocalLength Field

Android focal length

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidFocalLength = 8005
Public Const AndroidFocalLength As CapProp = 8005
public:
literal CapProp^ AndroidFocalLength = 8005
static val mutable AndroidFocalLength: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidFocusDistanceFar Field

CapPropAndroidFocusDistanceFar Field

Android focus distance far

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidFocusDistanceFar = 8008
Public Const AndroidFocusDistanceFar As CapProp = 8008
public:
literal CapProp^ AndroidFocusDistanceFar = 8008
static val mutable AndroidFocusDistanceFar: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidFocusDistanceNear Field

CapPropAndroidFocusDistanceNear Field

Android focus distance near

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidFocusDistanceNear = 8006
Public Const AndroidFocusDistanceNear As CapProp = 8006
public:
literal CapProp^ AndroidFocusDistanceNear = 8006
static val mutable AndroidFocusDistanceNear: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidFocusDistanceOptimal Field

CapPropAndroidFocusDistanceOptimal Field

Android focus distance optimal

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidFocusDistanceOptimal = 8007
Public Const AndroidFocusDistanceOptimal As CapProp = 8007
public:
literal CapProp^ AndroidFocusDistanceOptimal = 8007
static val mutable AndroidFocusDistanceOptimal: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidFocusMode Field

CapPropAndroidFocusMode Field

Android focus mode

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidFocusMode = 8002
Public Const AndroidFocusMode As CapProp = 8002
public:
literal CapProp^ AndroidFocusMode = 8002
static val mutable AndroidFocusMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidWhiteBalance Field

CapPropAndroidWhiteBalance Field

Android white balance

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidWhiteBalance = 8003
Public Const AndroidWhiteBalance As CapProp = 8003
public:
literal CapProp^ AndroidWhiteBalance = 8003
static val mutable AndroidWhiteBalance: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AndroidWhitebalanceLock Field

CapPropAndroidWhitebalanceLock Field

Android white balance lock

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AndroidWhitebalanceLock = 8010
Public Const AndroidWhitebalanceLock As CapProp = 8010
public:
literal CapProp^ AndroidWhitebalanceLock = 8010
static val mutable AndroidWhitebalanceLock: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AutoExposure Field

CapPropAutoExposure Field

Exposure control done by camera, user can adjust reference level using this feature

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AutoExposure = 21
Public Const AutoExposure As CapProp = 21
public:
literal CapProp^ AutoExposure = 21
static val mutable AutoExposure: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Autofocus Field

CapPropAutofocus Field

Auto focus

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Autofocus = 39
Public Const Autofocus As CapProp = 39
public:
literal CapProp^ Autofocus = 39
static val mutable Autofocus: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Autograb Field

CapPropAutograb Field

property for highgui class CvCapture_Android only

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Autograb = 1024
Public Const Autograb As CapProp = 1024
public:
literal CapProp^ Autograb = 1024
static val mutable Autograb: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.AutoWb Field

CapPropAutoWb Field

Enable/ disable auto white-balance

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp AutoWb = 44
Public Const AutoWb As CapProp = 44
public:
literal CapProp^ AutoWb = 44
static val mutable AutoWb: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Backend Field

CapPropBackend Field

Current backend (enum VideoCaptureAPIs). Read-only property

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Backend = 42
Public Const Backend As CapProp = 42
public:
literal CapProp^ Backend = 42
static val mutable Backend: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Backlight Field

CapPropBacklight Field

Backlight

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Backlight = 32
Public Const Backlight As CapProp = 32
public:
literal CapProp^ Backlight = 32
static val mutable Backlight: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Brightness Field

CapPropBrightness Field

Brightness of the image (only for those cameras that support).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Brightness = 10
Public Const Brightness As CapProp = 10
public:
literal CapProp^ Brightness = 10
static val mutable Brightness: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Buffersuze Field

CapPropBuffersuze Field

Buffer size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Buffersuze = 38
Public Const Buffersuze As CapProp = 38
public:
literal CapProp^ Buffersuze = 38
static val mutable Buffersuze: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Channel Field

CapPropChannel Field

Video input or Channel Number (only for those cameras that support)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Channel = 43
Public Const Channel As CapProp = 43
public:
literal CapProp^ Channel = 43
static val mutable Channel: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Contrast Field

CapPropContrast Field

Contrast of the image (only for cameras).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Contrast = 11
Public Const Contrast As CapProp = 11
public:
literal CapProp^ Contrast = 11
static val mutable Contrast: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.ConvertRgb Field

CapPropConvertRgb Field

Boolean flags indicating whether images should be converted to RGB.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp ConvertRgb = 16
Public Const ConvertRgb As CapProp = 16
public:
literal CapProp^ ConvertRgb = 16
static val mutable ConvertRgb: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.DC1394ModeAuto Field

CapPropDC1394ModeAuto Field

DC1394 mode auto

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp DC1394ModeAuto = -2
Public Const DC1394ModeAuto As CapProp = -2
public:
literal CapProp^ DC1394ModeAuto = -2
static val mutable DC1394ModeAuto: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.DC1394ModeManual Field

CapPropDC1394ModeManual Field

Set automatically when a value of the feature is set by the user

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp DC1394ModeManual = -3
Public Const DC1394ModeManual As CapProp = -3
public:
literal CapProp^ DC1394ModeManual = -3
static val mutable DC1394ModeManual: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.DC1394ModeOnePushAuto Field

CapPropDC1394ModeOnePushAuto Field

DC1394 mode one push auto

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp DC1394ModeOnePushAuto = -1
Public Const DC1394ModeOnePushAuto As CapProp = -1
public:
literal CapProp^ DC1394ModeOnePushAuto = -1
static val mutable DC1394ModeOnePushAuto: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.DC1394Off Field

CapPropDC1394Off Field

Turn the feature off (not controlled manually nor automatically)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp DC1394Off = -4
Public Const DC1394Off As CapProp = -4
public:
literal CapProp^ DC1394Off = -4
static val mutable DC1394Off: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Exposure Field

CapPropExposure Field

Exposure (only for those cameras that support).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Exposure = 15
Public Const Exposure As CapProp = 15
public:
literal CapProp^ Exposure = 15
static val mutable Exposure: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Focus Field

CapPropFocus Field

Focus

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Focus = 28
Public Const Focus As CapProp = 28
public:
literal CapProp^ Focus = 28
static val mutable Focus: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Format Field

CapPropFormat Field

Format of the %Mat objects returned by VideoCapture::retrieve().

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Format = 8
Public Const Format As CapProp = 8
public:
literal CapProp^ Format = 8
static val mutable Format: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.FourCC Field

CapPropFourCC Field

4-character code of codec

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp FourCC = 6
Public Const FourCC As CapProp = 6
public:
literal CapProp^ FourCC = 6
static val mutable FourCC: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Fps Field

CapPropFps Field

Frame rate

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Fps = 5
Public Const Fps As CapProp = 5
public:
literal CapProp^ Fps = 5
static val mutable Fps: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.FrameCount Field

CapPropFrameCount Field

Number of frames in video file

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp FrameCount = 7
Public Const FrameCount As CapProp = 7
public:
literal CapProp^ FrameCount = 7
static val mutable FrameCount: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.FrameHeight Field

CapPropFrameHeight Field

Height of frames in the video stream

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp FrameHeight = 4
Public Const FrameHeight As CapProp = 4
public:
literal CapProp^ FrameHeight = 4
static val mutable FrameHeight: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.FrameWidth Field

CapPropFrameWidth Field

Width of frames in the video stream

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp FrameWidth = 3
Public Const FrameWidth As CapProp = 3
public:
literal CapProp^ FrameWidth = 3
static val mutable FrameWidth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Gain Field

CapPropGain Field

Gain of the image (only for those cameras that support).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Gain = 14
Public Const Gain As CapProp = 14
public:
literal CapProp^ Gain = 14
static val mutable Gain: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Gamma Field

CapPropGamma Field

Gamma

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Gamma = 22
Public Const Gamma As CapProp = 22
public:
literal CapProp^ Gamma = 22
static val mutable Gamma: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.GigaFrameHeighMax Field

CapPropGigaFrameHeighMax Field

Smartek Giganetix Ethernet Vision: frame height max

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp GigaFrameHeighMax = 10004
Public Const GigaFrameHeighMax As CapProp = 10004
public:
literal CapProp^ GigaFrameHeighMax = 10004
static val mutable GigaFrameHeighMax: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.GigaFrameOffsetX Field

CapPropGigaFrameOffsetX Field

Smartek Giganetix Ethernet Vision: frame offset X

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp GigaFrameOffsetX = 10001
Public Const GigaFrameOffsetX As CapProp = 10001
public:
literal CapProp^ GigaFrameOffsetX = 10001
static val mutable GigaFrameOffsetX: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.GigaFrameOffsetY Field

CapPropGigaFrameOffsetY Field

Smartek Giganetix Ethernet Vision: frame offset Y

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp GigaFrameOffsetY = 10002
Public Const GigaFrameOffsetY As CapProp = 10002
public:
literal CapProp^ GigaFrameOffsetY = 10002
static val mutable GigaFrameOffsetY: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.GigaFrameSensHeigh Field

CapPropGigaFrameSensHeigh Field

Smartek Giganetix Ethernet Vision: frame sens height

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp GigaFrameSensHeigh = 10006
Public Const GigaFrameSensHeigh As CapProp = 10006
public:
literal CapProp^ GigaFrameSensHeigh = 10006
static val mutable GigaFrameSensHeigh: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.GigaFrameSensWidth Field

CapPropGigaFrameSensWidth Field

Smartek Giganetix Ethernet Vision: frame sens width

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp GigaFrameSensWidth = 10005
Public Const GigaFrameSensWidth As CapProp = 10005
public:
literal CapProp^ GigaFrameSensWidth = 10005
static val mutable GigaFrameSensWidth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.GigaFrameWidthMax Field

CapPropGigaFrameWidthMax Field

Smartek Giganetix Ethernet Vision: frame width max

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp GigaFrameWidthMax = 10003
Public Const GigaFrameWidthMax As CapProp = 10003
public:
literal CapProp^ GigaFrameWidthMax = 10003
static val mutable GigaFrameWidthMax: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.GstreamerQueueLength Field

CapPropGstreamerQueueLength Field

Properties of cameras available through GStreamer interface. Default is 1

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp GstreamerQueueLength = 200
Public Const GstreamerQueueLength As CapProp = 200
public:
literal CapProp^ GstreamerQueueLength = 200
static val mutable GstreamerQueueLength: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Guid Field

CapPropGuid Field

GUID

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Guid = 29
Public Const Guid As CapProp = 29
public:
literal CapProp^ Guid = 29
static val mutable Guid: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Hue Field

CapPropHue Field

Hue of the image (only for cameras).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Hue = 13
Public Const Hue As CapProp = 13
public:
literal CapProp^ Hue = 13
static val mutable Hue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercDepthConfidenceThreshold Field

CapPropIntelpercDepthConfidenceThreshold Field

Intelperc Depth Confidence Threshold

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercDepthConfidenceThreshold = 11005
Public Const IntelpercDepthConfidenceThreshold As CapProp = 11005
public:
literal CapProp^ IntelpercDepthConfidenceThreshold = 11005
static val mutable IntelpercDepthConfidenceThreshold: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercDepthFocalLengthHorz Field

CapPropIntelpercDepthFocalLengthHorz Field

Intelperc Depth Focal Length Horz

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercDepthFocalLengthHorz = 11006
Public Const IntelpercDepthFocalLengthHorz As CapProp = 11006
public:
literal CapProp^ IntelpercDepthFocalLengthHorz = 11006
static val mutable IntelpercDepthFocalLengthHorz: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercDepthFocalLengthVert Field

CapPropIntelpercDepthFocalLengthVert Field

Intelperc Depth Focal Length Vert

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercDepthFocalLengthVert = 11007
Public Const IntelpercDepthFocalLengthVert As CapProp = 11007
public:
literal CapProp^ IntelpercDepthFocalLengthVert = 11007
static val mutable IntelpercDepthFocalLengthVert: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercDepthGenerator Field

CapPropIntelpercDepthGenerator Field

Intelperc Depth Generator

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercDepthGenerator = 536870912
Public Const IntelpercDepthGenerator As CapProp = 536870912
public:
literal CapProp^ IntelpercDepthGenerator = 536870912
static val mutable IntelpercDepthGenerator: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercDepthLowConfidenceValue Field

CapPropIntelpercDepthLowConfidenceValue Field

Intelperc Depth Low Confidence Value

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercDepthLowConfidenceValue = 11003
Public Const IntelpercDepthLowConfidenceValue As CapProp = 11003
public:
literal CapProp^ IntelpercDepthLowConfidenceValue = 11003
static val mutable IntelpercDepthLowConfidenceValue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercDepthSaturationValue Field

CapPropIntelpercDepthSaturationValue Field

Intelperc Depth Saturation Value

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercDepthSaturationValue = 11004
Public Const IntelpercDepthSaturationValue As CapProp = 11004
public:
literal CapProp^ IntelpercDepthSaturationValue = 11004
static val mutable IntelpercDepthSaturationValue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercGeneratorsMask Field

CapPropIntelpercGeneratorsMask Field

Intelperc Generators Mask

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercGeneratorsMask = 805306368
Public Const IntelpercGeneratorsMask As CapProp = 805306368
public:
literal CapProp^ IntelpercGeneratorsMask = 805306368
static val mutable IntelpercGeneratorsMask: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercImageGenerator Field

CapPropIntelpercImageGenerator Field

Intelperc Image Generator

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercImageGenerator = 268435456
Public Const IntelpercImageGenerator As CapProp = 268435456
public:
literal CapProp^ IntelpercImageGenerator = 268435456
static val mutable IntelpercImageGenerator: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercProfileCount Field

CapPropIntelpercProfileCount Field

Intelperc Profile Count

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercProfileCount = 11001
Public Const IntelpercProfileCount As CapProp = 11001
public:
literal CapProp^ IntelpercProfileCount = 11001
static val mutable IntelpercProfileCount: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IntelpercProfileIdx Field

CapPropIntelpercProfileIdx Field

Intelperc Profile Idx

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IntelpercProfileIdx = 11002
Public Const IntelpercProfileIdx As CapProp = 11002
public:
literal CapProp^ IntelpercProfileIdx = 11002
static val mutable IntelpercProfileIdx: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IOSDeviceExposure Field

CapPropIOSDeviceExposure Field

iOS device exposure

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IOSDeviceExposure = 9002
Public Const IOSDeviceExposure As CapProp = 9002
public:
literal CapProp^ IOSDeviceExposure = 9002
static val mutable IOSDeviceExposure: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IOSDeviceFlash Field

CapPropIOSDeviceFlash Field

iOS device flash

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IOSDeviceFlash = 9003
Public Const IOSDeviceFlash As CapProp = 9003
public:
literal CapProp^ IOSDeviceFlash = 9003
static val mutable IOSDeviceFlash: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IOSDeviceFocus Field

CapPropIOSDeviceFocus Field

iOS device focus

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IOSDeviceFocus = 9001
Public Const IOSDeviceFocus As CapProp = 9001
public:
literal CapProp^ IOSDeviceFocus = 9001
static val mutable IOSDeviceFocus: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IOSDeviceTorch Field

CapPropIOSDeviceTorch Field

iOS device torch

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IOSDeviceTorch = 9005
Public Const IOSDeviceTorch As CapProp = 9005
public:
literal CapProp^ IOSDeviceTorch = 9005
static val mutable IOSDeviceTorch: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IOSDeviceWhitebalance Field

CapPropIOSDeviceWhitebalance Field

iOS device white-balance

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IOSDeviceWhitebalance = 9004
Public Const IOSDeviceWhitebalance As CapProp = 9004
public:
literal CapProp^ IOSDeviceWhitebalance = 9004
static val mutable IOSDeviceWhitebalance: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Iris Field

CapPropIris Field

Iris

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Iris = 36
Public Const Iris As CapProp = 36
public:
literal CapProp^ Iris = 36
static val mutable Iris: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.IsoSpeed Field

CapPropIsoSpeed Field

ISO SPEED

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp IsoSpeed = 30
Public Const IsoSpeed As CapProp = 30
public:
literal CapProp^ IsoSpeed = 30
static val mutable IsoSpeed: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.MaxDC1394 Field

CapPropMaxDC1394 Field

MAX DC1394

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp MaxDC1394 = 31
Public Const MaxDC1394 As CapProp = 31
public:
literal CapProp^ MaxDC1394 = 31
static val mutable MaxDC1394: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Mode Field

CapPropMode Field

Backend-specific value indicating the current capture mode.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Mode = 9
Public Const Mode As CapProp = 9
public:
literal CapProp^ Mode = 9
static val mutable Mode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Monochrome Field

CapPropMonochrome Field

Monochrome

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Monochrome = 19
Public Const Monochrome As CapProp = 19
public:
literal CapProp^ Monochrome = 19
static val mutable Monochrome: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Openni2Mirror Field

CapPropOpenni2Mirror Field

OpenNI2 Mirror

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Openni2Mirror = 111
Public Const Openni2Mirror As CapProp = 111
public:
literal CapProp^ Openni2Mirror = 111
static val mutable Openni2Mirror: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Openni2Sync Field

CapPropOpenni2Sync Field

OpenNI2 Sync

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Openni2Sync = 110
Public Const Openni2Sync As CapProp = 110
public:
literal CapProp^ Openni2Sync = 110
static val mutable Openni2Sync: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniApproxFrameSync Field

CapPropOpenniApproxFrameSync Field

Approx frame sync

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniApproxFrameSync = 105
Public Const OpenniApproxFrameSync As CapProp = 105
public:
literal CapProp^ OpenniApproxFrameSync = 105
static val mutable OpenniApproxFrameSync: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniBaseline Field

CapPropOpenniBaseline Field

Properties of cameras available through OpenNI interfaces, in mm.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniBaseline = 102
Public Const OpenniBaseline As CapProp = 102
public:
literal CapProp^ OpenniBaseline = 102
static val mutable OpenniBaseline: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniCircleBuffer Field

CapPropOpenniCircleBuffer Field

Circle buffer

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniCircleBuffer = 107
Public Const OpenniCircleBuffer As CapProp = 107
public:
literal CapProp^ OpenniCircleBuffer = 107
static val mutable OpenniCircleBuffer: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniDepthGenerator Field

CapPropOpenniDepthGenerator Field

OpenNI depth generator

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniDepthGenerator = -2147483648
Public Const OpenniDepthGenerator As CapProp = -2147483648
public:
literal CapProp^ OpenniDepthGenerator = -2147483648
static val mutable OpenniDepthGenerator: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniDepthGeneratorBaseline Field

CapPropOpenniDepthGeneratorBaseline Field

Depth generator baseline, in mm.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniDepthGeneratorBaseline = -2147483546
Public Const OpenniDepthGeneratorBaseline As CapProp = -2147483546
public:
literal CapProp^ OpenniDepthGeneratorBaseline = -2147483546
static val mutable OpenniDepthGeneratorBaseline: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniDepthGeneratorFocalLength Field

CapPropOpenniDepthGeneratorFocalLength Field

Depth generator focal length, in pixels.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniDepthGeneratorFocalLength = -2147483545
Public Const OpenniDepthGeneratorFocalLength As CapProp = -2147483545
public:
literal CapProp^ OpenniDepthGeneratorFocalLength = -2147483545
static val mutable OpenniDepthGeneratorFocalLength: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniDepthGeneratorPresent Field

CapPropOpenniDepthGeneratorPresent Field

Depth generator present

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniDepthGeneratorPresent = -2147483539
Public Const OpenniDepthGeneratorPresent As CapProp = -2147483539
public:
literal CapProp^ OpenniDepthGeneratorPresent = -2147483539
static val mutable OpenniDepthGeneratorPresent: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniDepthGeneratorRegistration Field

CapPropOpenniDepthGeneratorRegistration Field

Openni generator registration

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniDepthGeneratorRegistration = -2147483544
Public Const OpenniDepthGeneratorRegistration As CapProp = -2147483544
public:
literal CapProp^ OpenniDepthGeneratorRegistration = -2147483544
static val mutable OpenniDepthGeneratorRegistration: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniDepthGeneratorRegistrationOn Field

CapPropOpenniDepthGeneratorRegistrationOn Field

Openni generator registration on

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniDepthGeneratorRegistrationOn = -2147483544
Public Const OpenniDepthGeneratorRegistrationOn As CapProp = -2147483544
public:
literal CapProp^ OpenniDepthGeneratorRegistrationOn = -2147483544
static val mutable OpenniDepthGeneratorRegistrationOn: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniFocalLength Field

CapPropOpenniFocalLength Field

Properties of cameras available through OpenNI interfaces, in pixels.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniFocalLength = 103
Public Const OpenniFocalLength As CapProp = 103
public:
literal CapProp^ OpenniFocalLength = 103
static val mutable OpenniFocalLength: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniFrameMaxDepth Field

CapPropOpenniFrameMaxDepth Field

Properties of cameras available through OpenNI interfaces, in mm.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniFrameMaxDepth = 101
Public Const OpenniFrameMaxDepth As CapProp = 101
public:
literal CapProp^ OpenniFrameMaxDepth = 101
static val mutable OpenniFrameMaxDepth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniGeneratorPresent Field

CapPropOpenniGeneratorPresent Field

Generator present

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniGeneratorPresent = 109
Public Const OpenniGeneratorPresent As CapProp = 109
public:
literal CapProp^ OpenniGeneratorPresent = 109
static val mutable OpenniGeneratorPresent: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniGeneratorsMask Field

CapPropOpenniGeneratorsMask Field

OpenNI map generators

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniGeneratorsMask = -536870912
Public Const OpenniGeneratorsMask As CapProp = -536870912
public:
literal CapProp^ OpenniGeneratorsMask = -536870912
static val mutable OpenniGeneratorsMask: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniImageGenerator Field

CapPropOpenniImageGenerator Field

OpenNI image generator

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniImageGenerator = 1073741824
Public Const OpenniImageGenerator As CapProp = 1073741824
public:
literal CapProp^ OpenniImageGenerator = 1073741824
static val mutable OpenniImageGenerator: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniImageGeneratorOutputMode Field

CapPropOpenniImageGeneratorOutputMode Field

Image generator output mode

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniImageGeneratorOutputMode = 1073741924
Public Const OpenniImageGeneratorOutputMode As CapProp = 1073741924
public:
literal CapProp^ OpenniImageGeneratorOutputMode = 1073741924
static val mutable OpenniImageGeneratorOutputMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniImageGeneratorPresent Field

CapPropOpenniImageGeneratorPresent Field

Openni image generator present

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniImageGeneratorPresent = 1073741933
Public Const OpenniImageGeneratorPresent As CapProp = 1073741933
public:
literal CapProp^ OpenniImageGeneratorPresent = 1073741933
static val mutable OpenniImageGeneratorPresent: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniIRGenerator Field

CapPropOpenniIRGenerator Field

OpenNI IR generator

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniIRGenerator = 536870912
Public Const OpenniIRGenerator As CapProp = 536870912
public:
literal CapProp^ OpenniIRGenerator = 536870912
static val mutable OpenniIRGenerator: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniIRGeneratorPresent Field

CapPropOpenniIRGeneratorPresent Field

Openni IR generator present

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniIRGeneratorPresent = 536871021
Public Const OpenniIRGeneratorPresent As CapProp = 536871021
public:
literal CapProp^ OpenniIRGeneratorPresent = 536871021
static val mutable OpenniIRGeneratorPresent: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniMaxBufferSize Field

CapPropOpenniMaxBufferSize Field

Max buffer size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniMaxBufferSize = 106
Public Const OpenniMaxBufferSize As CapProp = 106
public:
literal CapProp^ OpenniMaxBufferSize = 106
static val mutable OpenniMaxBufferSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniMaxTimeDuration Field

CapPropOpenniMaxTimeDuration Field

Max time duration

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniMaxTimeDuration = 108
Public Const OpenniMaxTimeDuration As CapProp = 108
public:
literal CapProp^ OpenniMaxTimeDuration = 108
static val mutable OpenniMaxTimeDuration: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniOutputMode Field

CapPropOpenniOutputMode Field

Properties of cameras available through OpenNI interfaces

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniOutputMode = 100
Public Const OpenniOutputMode As CapProp = 100
public:
literal CapProp^ OpenniOutputMode = 100
static val mutable OpenniOutputMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniRegistration Field

CapPropOpenniRegistration Field

Flag that synchronizes the remapping depth map to image map by changing depth generator's view point (if the flag is "on") or sets this view point to its normal one (if the flag is "off").

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniRegistration = 104
Public Const OpenniRegistration As CapProp = 104
public:
literal CapProp^ OpenniRegistration = 104
static val mutable OpenniRegistration: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.OpenniRegistrationOn Field

CapPropOpenniRegistrationOn Field

Flag that synchronizes the remapping depth map to image map by changing depth generator's view point (if the flag is "on") or sets this view point to its normal one (if the flag is "off").

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp OpenniRegistrationOn = 104
Public Const OpenniRegistrationOn As CapProp = 104
public:
literal CapProp^ OpenniRegistrationOn = 104
static val mutable OpenniRegistrationOn: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Pan Field

CapPropPan Field

Pan

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Pan = 33
Public Const Pan As CapProp = 33
public:
literal CapProp^ Pan = 33
static val mutable Pan: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PosAviRatio Field

CapPropPosAviRatio Field

Relative position of the video file: 0=start of the film, 1=end of the film.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PosAviRatio = 2
Public Const PosAviRatio As CapProp = 2
public:
literal CapProp^ PosAviRatio = 2
static val mutable PosAviRatio: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PosFrames Field

CapPropPosFrames Field

0-based index of the frame to be decoded/captured next

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PosFrames = 1
Public Const PosFrames As CapProp = 1
public:
literal CapProp^ PosFrames = 1
static val mutable PosFrames: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PosMsec Field

CapPropPosMsec Field

Film current position in milliseconds or video capture timestamp

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PosMsec = 0
Public Const PosMsec As CapProp = 0
public:
literal CapProp^ PosMsec = 0
static val mutable PosMsec: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PreviewFormat Field

CapPropPreviewFormat Field

readonly, tricky property, returns cpnst char* indeed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PreviewFormat = 1026
Public Const PreviewFormat As CapProp = 1026
public:
literal CapProp^ PreviewFormat = 1026
static val mutable PreviewFormat: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PvapiBinningX Field

CapPropPvapiBinningX Field

Horizontal binning factor

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PvapiBinningX = 304
Public Const PvapiBinningX As CapProp = 304
public:
literal CapProp^ PvapiBinningX = 304
static val mutable PvapiBinningX: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PvapiBinningY Field

CapPropPvapiBinningY Field

Vertical binning factor

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PvapiBinningY = 305
Public Const PvapiBinningY As CapProp = 305
public:
literal CapProp^ PvapiBinningY = 305
static val mutable PvapiBinningY: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PvapiDecimationHorizontal Field

CapPropPvapiDecimationHorizontal Field

Horizontal sub-sampling of the image

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PvapiDecimationHorizontal = 302
Public Const PvapiDecimationHorizontal As CapProp = 302
public:
literal CapProp^ PvapiDecimationHorizontal = 302
static val mutable PvapiDecimationHorizontal: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PvapiDecimationVertical Field

CapPropPvapiDecimationVertical Field

Vertical sub-sampling of the image

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PvapiDecimationVertical = 303
Public Const PvapiDecimationVertical As CapProp = 303
public:
literal CapProp^ PvapiDecimationVertical = 303
static val mutable PvapiDecimationVertical: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PvapiFrameStartTriggerMode Field

CapPropPvapiFrameStartTriggerMode Field

FrameStartTriggerMode: Determines how a frame is initiated

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PvapiFrameStartTriggerMode = 301
Public Const PvapiFrameStartTriggerMode As CapProp = 301
public:
literal CapProp^ PvapiFrameStartTriggerMode = 301
static val mutable PvapiFrameStartTriggerMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PvapiMulticastip Field

CapPropPvapiMulticastip Field

Ip for enable multicast master mode. 0 for disable multicast

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PvapiMulticastip = 300
Public Const PvapiMulticastip As CapProp = 300
public:
literal CapProp^ PvapiMulticastip = 300
static val mutable PvapiMulticastip: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.PvapiPixelFormat Field

CapPropPvapiPixelFormat Field

Pixel format

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp PvapiPixelFormat = 306
Public Const PvapiPixelFormat As CapProp = 306
public:
literal CapProp^ PvapiPixelFormat = 306
static val mutable PvapiPixelFormat: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Rectification Field

CapPropRectification Field

Rectification flag for stereo cameras (note: only supported by DC1394 v 2.x backend currently).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Rectification = 18
Public Const Rectification As CapProp = 18
public:
literal CapProp^ Rectification = 18
static val mutable Rectification: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Roll Field

CapPropRoll Field

Roll

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Roll = 35
Public Const Roll As CapProp = 35
public:
literal CapProp^ Roll = 35
static val mutable Roll: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.SarDen Field

CapPropSarDen Field

Sample aspect ratio: num/den (den)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp SarDen = 41
Public Const SarDen As CapProp = 41
public:
literal CapProp^ SarDen = 41
static val mutable SarDen: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.SarNum Field

CapPropSarNum Field

Sample aspect ratio: num/den (num)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp SarNum = 40
Public Const SarNum As CapProp = 40
public:
literal CapProp^ SarNum = 40
static val mutable SarNum: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Saturation Field

CapPropSaturation Field

Saturation of the image (only for cameras).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Saturation = 12
Public Const Saturation As CapProp = 12
public:
literal CapProp^ Saturation = 12
static val mutable Saturation: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Settings Field

CapPropSettings Field

Pop up video/camera filter dialog (note: only supported by DSHOW backend currently. The property value is ignored)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Settings = 37
Public Const Settings As CapProp = 37
public:
literal CapProp^ Settings = 37
static val mutable Settings: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Sharpness Field

CapPropSharpness Field

Sharpness

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Sharpness = 20
Public Const Sharpness As CapProp = 20
public:
literal CapProp^ Sharpness = 20
static val mutable Sharpness: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.SupportedPreviewSizesString Field

CapPropSupportedPreviewSizesString Field

readonly, tricky property, returns cpnst char* indeed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp SupportedPreviewSizesString = 1025
Public Const SupportedPreviewSizesString As CapProp = 1025
public:
literal CapProp^ SupportedPreviewSizesString = 1025
static val mutable SupportedPreviewSizesString: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Temperature Field

CapPropTemperature Field

Temperature

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Temperature = 23
Public Const Temperature As CapProp = 23
public:
literal CapProp^ Temperature = 23
static val mutable Temperature: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Tilt Field

CapPropTilt Field

Tilt

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Tilt = 34
Public Const Tilt As CapProp = 34
public:
literal CapProp^ Tilt = 34
static val mutable Tilt: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Trigger Field

CapPropTrigger Field

Trigger

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Trigger = 24
Public Const Trigger As CapProp = 24
public:
literal CapProp^ Trigger = 24
static val mutable Trigger: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.TriggerDelay Field

CapPropTriggerDelay Field

Trigger delay

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp TriggerDelay = 25
Public Const TriggerDelay As CapProp = 25
public:
literal CapProp^ TriggerDelay = 25
static val mutable TriggerDelay: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.value__ Field

CapPropvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CapProp.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.WbTemperature Field

CapPropWbTemperature Field

White-balance color temperature

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp WbTemperature = 45
Public Const WbTemperature As CapProp = 45
public:
literal CapProp^ WbTemperature = 45
static val mutable WbTemperature: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.WhiteBalanceBlueU Field

CapPropWhiteBalanceBlueU Field

Currently unsupported.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp WhiteBalanceBlueU = 17
Public Const WhiteBalanceBlueU As CapProp = 17
public:
literal CapProp^ WhiteBalanceBlueU = 17
static val mutable WhiteBalanceBlueU: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.WhiteBalanceRedV Field

CapPropWhiteBalanceRedV Field

White balance red v

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp WhiteBalanceRedV = 26
Public Const WhiteBalanceRedV As CapProp = 26
public:
literal CapProp^ WhiteBalanceRedV = 26
static val mutable WhiteBalanceRedV: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAcqBufferSize Field

CapPropXiAcqBufferSize Field

Acquisition buffer size in buffer_size_unit. Default bytes.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAcqBufferSize = 548
Public Const XiAcqBufferSize As CapProp = 548
public:
literal CapProp^ XiAcqBufferSize = 548
static val mutable XiAcqBufferSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAcqBufferSizeUnit Field

CapPropXiAcqBufferSizeUnit Field

Acquisition buffer size unit in bytes. Default 1. E.g. Value 1024 means that buffer_size is in KiBytes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAcqBufferSizeUnit = 549
Public Const XiAcqBufferSizeUnit As CapProp = 549
public:
literal CapProp^ XiAcqBufferSizeUnit = 549
static val mutable XiAcqBufferSizeUnit: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAcqFrameBurstCount Field

CapPropXiAcqFrameBurstCount Field

Sets number of frames acquired by burst. This burst is used only if trigger is set to FrameBurstStart

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAcqFrameBurstCount = 499
Public Const XiAcqFrameBurstCount As CapProp = 499
public:
literal CapProp^ XiAcqFrameBurstCount = 499
static val mutable XiAcqFrameBurstCount: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAcqTimingMode Field

CapPropXiAcqTimingMode Field

Type of sensor frames timing.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAcqTimingMode = 538
Public Const XiAcqTimingMode As CapProp = 538
public:
literal CapProp^ XiAcqTimingMode = 538
static val mutable XiAcqTimingMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAcqTransportBufferCommit Field

CapPropXiAcqTransportBufferCommit Field

Number of buffers to commit to low level

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAcqTransportBufferCommit = 552
Public Const XiAcqTransportBufferCommit As CapProp = 552
public:
literal CapProp^ XiAcqTransportBufferCommit = 552
static val mutable XiAcqTransportBufferCommit: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAcqTransportBufferSize Field

CapPropXiAcqTransportBufferSize Field

Acquisition transport buffer size in bytes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAcqTransportBufferSize = 550
Public Const XiAcqTransportBufferSize As CapProp = 550
public:
literal CapProp^ XiAcqTransportBufferSize = 550
static val mutable XiAcqTransportBufferSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAeag Field

CapPropXiAeag Field

Automatic exposure/gain

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAeag = 415
Public Const XiAeag As CapProp = 415
public:
literal CapProp^ XiAeag = 415
static val mutable XiAeag: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAeagLevel Field

CapPropXiAeagLevel Field

Average intensity of output signal AEAG should achieve(in %)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAeagLevel = 419
Public Const XiAeagLevel As CapProp = 419
public:
literal CapProp^ XiAeagLevel = 419
static val mutable XiAeagLevel: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAeagRoiHeight Field

CapPropXiAeagRoiHeight Field

Automatic exposure/gain ROI Height

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAeagRoiHeight = 442
Public Const XiAeagRoiHeight As CapProp = 442
public:
literal CapProp^ XiAeagRoiHeight = 442
static val mutable XiAeagRoiHeight: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAeagRoiOffsetX Field

CapPropXiAeagRoiOffsetX Field

Automatic exposure/gain ROI offset X

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAeagRoiOffsetX = 439
Public Const XiAeagRoiOffsetX As CapProp = 439
public:
literal CapProp^ XiAeagRoiOffsetX = 439
static val mutable XiAeagRoiOffsetX: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAeagRoiOffsetY Field

CapPropXiAeagRoiOffsetY Field

Automatic exposure/gain ROI offset Y

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAeagRoiOffsetY = 440
Public Const XiAeagRoiOffsetY As CapProp = 440
public:
literal CapProp^ XiAeagRoiOffsetY = 440
static val mutable XiAeagRoiOffsetY: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAeagRoiWidth Field

CapPropXiAeagRoiWidth Field

Automatic exposure/gain ROI Width

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAeagRoiWidth = 441
Public Const XiAeagRoiWidth As CapProp = 441
public:
literal CapProp^ XiAeagRoiWidth = 441
static val mutable XiAeagRoiWidth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAeMaxLimit Field

CapPropXiAeMaxLimit Field

Maximum limit of exposure in AEAG procedure

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAeMaxLimit = 417
Public Const XiAeMaxLimit As CapProp = 417
public:
literal CapProp^ XiAeMaxLimit = 417
static val mutable XiAeMaxLimit: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAgMaxLimit Field

CapPropXiAgMaxLimit Field

Maximum limit of gain in AEAG procedure

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAgMaxLimit = 418
Public Const XiAgMaxLimit As CapProp = 418
public:
literal CapProp^ XiAgMaxLimit = 418
static val mutable XiAgMaxLimit: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiApplyCms Field

CapPropXiApplyCms Field

Enable applying of CMS profiles to xiGetImage (see XI_PRM_INPUT_CMS_PROFILE, XI_PRM_OUTPUT_CMS_PROFILE).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiApplyCms = 471
Public Const XiApplyCms As CapProp = 471
public:
literal CapProp^ XiApplyCms = 471
static val mutable XiApplyCms: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAutoBandwidthCalculation Field

CapPropXiAutoBandwidthCalculation Field

Automatic bandwidth calculation,

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAutoBandwidthCalculation = 573
Public Const XiAutoBandwidthCalculation As CapProp = 573
public:
literal CapProp^ XiAutoBandwidthCalculation = 573
static val mutable XiAutoBandwidthCalculation: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAutoWb Field

CapPropXiAutoWb Field

Automatic white balance

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAutoWb = 414
Public Const XiAutoWb As CapProp = 414
public:
literal CapProp^ XiAutoWb = 414
static val mutable XiAutoWb: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiAvailableBandwidth Field

CapPropXiAvailableBandwidth Field

Calculate and return available interface bandwidth(int Megabits)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiAvailableBandwidth = 539
Public Const XiAvailableBandwidth As CapProp = 539
public:
literal CapProp^ XiAvailableBandwidth = 539
static val mutable XiAvailableBandwidth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiBinningHorizontal Field

CapPropXiBinningHorizontal Field

Horizontal Binning - number of horizontal photo-sensitive cells to combine together.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiBinningHorizontal = 429
Public Const XiBinningHorizontal As CapProp = 429
public:
literal CapProp^ XiBinningHorizontal = 429
static val mutable XiBinningHorizontal: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiBinningPattern Field

CapPropXiBinningPattern Field

Binning pattern type.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiBinningPattern = 430
Public Const XiBinningPattern As CapProp = 430
public:
literal CapProp^ XiBinningPattern = 430
static val mutable XiBinningPattern: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiBinningSelector Field

CapPropXiBinningSelector Field

Binning engine selector.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiBinningSelector = 427
Public Const XiBinningSelector As CapProp = 427
public:
literal CapProp^ XiBinningSelector = 427
static val mutable XiBinningSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiBinningVertical Field

CapPropXiBinningVertical Field

Vertical Binning - number of vertical photo-sensitive cells to combine together.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiBinningVertical = 428
Public Const XiBinningVertical As CapProp = 428
public:
literal CapProp^ XiBinningVertical = 428
static val mutable XiBinningVertical: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiBpc Field

CapPropXiBpc Field

Correction of bad pixels

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiBpc = 445
Public Const XiBpc As CapProp = 445
public:
literal CapProp^ XiBpc = 445
static val mutable XiBpc: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiBufferPolicy Field

CapPropXiBufferPolicy Field

Data move policy

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiBufferPolicy = 540
Public Const XiBufferPolicy As CapProp = 540
public:
literal CapProp^ XiBufferPolicy = 540
static val mutable XiBufferPolicy: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiBuffersQueueSize Field

CapPropXiBuffersQueueSize Field

Queue of field/frame buffers

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiBuffersQueueSize = 551
Public Const XiBuffersQueueSize As CapProp = 551
public:
literal CapProp^ XiBuffersQueueSize = 551
static val mutable XiBuffersQueueSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix00 Field

CapPropXiCcMatrix00 Field

Color Correction Matrix element [0][0]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix00 = 479
Public Const XiCcMatrix00 As CapProp = 479
public:
literal CapProp^ XiCcMatrix00 = 479
static val mutable XiCcMatrix00: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix01 Field

CapPropXiCcMatrix01 Field

Color Correction Matrix element [0][1]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix01 = 480
Public Const XiCcMatrix01 As CapProp = 480
public:
literal CapProp^ XiCcMatrix01 = 480
static val mutable XiCcMatrix01: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix02 Field

CapPropXiCcMatrix02 Field

Color Correction Matrix element [0][2]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix02 = 481
Public Const XiCcMatrix02 As CapProp = 481
public:
literal CapProp^ XiCcMatrix02 = 481
static val mutable XiCcMatrix02: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix03 Field

CapPropXiCcMatrix03 Field

Color Correction Matrix element [0][3]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix03 = 482
Public Const XiCcMatrix03 As CapProp = 482
public:
literal CapProp^ XiCcMatrix03 = 482
static val mutable XiCcMatrix03: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix10 Field

CapPropXiCcMatrix10 Field

Color Correction Matrix element [1][0]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix10 = 483
Public Const XiCcMatrix10 As CapProp = 483
public:
literal CapProp^ XiCcMatrix10 = 483
static val mutable XiCcMatrix10: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix11 Field

CapPropXiCcMatrix11 Field

Color Correction Matrix element [1][1]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix11 = 484
Public Const XiCcMatrix11 As CapProp = 484
public:
literal CapProp^ XiCcMatrix11 = 484
static val mutable XiCcMatrix11: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix12 Field

CapPropXiCcMatrix12 Field

Color Correction Matrix element [1][2]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix12 = 485
Public Const XiCcMatrix12 As CapProp = 485
public:
literal CapProp^ XiCcMatrix12 = 485
static val mutable XiCcMatrix12: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix13 Field

CapPropXiCcMatrix13 Field

Color Correction Matrix element [1][3]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix13 = 486
Public Const XiCcMatrix13 As CapProp = 486
public:
literal CapProp^ XiCcMatrix13 = 486
static val mutable XiCcMatrix13: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix20 Field

CapPropXiCcMatrix20 Field

Color Correction Matrix element [2][0]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix20 = 487
Public Const XiCcMatrix20 As CapProp = 487
public:
literal CapProp^ XiCcMatrix20 = 487
static val mutable XiCcMatrix20: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix21 Field

CapPropXiCcMatrix21 Field

Color Correction Matrix element [2][1]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix21 = 488
Public Const XiCcMatrix21 As CapProp = 488
public:
literal CapProp^ XiCcMatrix21 = 488
static val mutable XiCcMatrix21: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix22 Field

CapPropXiCcMatrix22 Field

Color Correction Matrix element [2][2]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix22 = 489
Public Const XiCcMatrix22 As CapProp = 489
public:
literal CapProp^ XiCcMatrix22 = 489
static val mutable XiCcMatrix22: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix23 Field

CapPropXiCcMatrix23 Field

Color Correction Matrix element [2][3]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix23 = 490
Public Const XiCcMatrix23 As CapProp = 490
public:
literal CapProp^ XiCcMatrix23 = 490
static val mutable XiCcMatrix23: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix30 Field

CapPropXiCcMatrix30 Field

Color Correction Matrix element [3][0]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix30 = 491
Public Const XiCcMatrix30 As CapProp = 491
public:
literal CapProp^ XiCcMatrix30 = 491
static val mutable XiCcMatrix30: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix31 Field

CapPropXiCcMatrix31 Field

Color Correction Matrix element [3][1]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix31 = 492
Public Const XiCcMatrix31 As CapProp = 492
public:
literal CapProp^ XiCcMatrix31 = 492
static val mutable XiCcMatrix31: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix32 Field

CapPropXiCcMatrix32 Field

Color Correction Matrix element [3][2]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix32 = 493
Public Const XiCcMatrix32 As CapProp = 493
public:
literal CapProp^ XiCcMatrix32 = 493
static val mutable XiCcMatrix32: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCcMatrix33 Field

CapPropXiCcMatrix33 Field

Color Correction Matrix element [3][3]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCcMatrix33 = 494
Public Const XiCcMatrix33 As CapProp = 494
public:
literal CapProp^ XiCcMatrix33 = 494
static val mutable XiCcMatrix33: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiChipTemp Field

CapPropXiChipTemp Field

Camera sensor temperature

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiChipTemp = 468
Public Const XiChipTemp As CapProp = 468
public:
literal CapProp^ XiChipTemp = 468
static val mutable XiChipTemp: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCms Field

CapPropXiCms Field

Mode of color management system.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCms = 470
Public Const XiCms As CapProp = 470
public:
literal CapProp^ XiCms = 470
static val mutable XiCms: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiColorFilterArray Field

CapPropXiColorFilterArray Field

Returns color filter array type of RAW data.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiColorFilterArray = 475
Public Const XiColorFilterArray As CapProp = 475
public:
literal CapProp^ XiColorFilterArray = 475
static val mutable XiColorFilterArray: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiColumnFpnCorrection Field

CapPropXiColumnFpnCorrection Field

Correction of column FPN

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiColumnFpnCorrection = 555
Public Const XiColumnFpnCorrection As CapProp = 555
public:
literal CapProp^ XiColumnFpnCorrection = 555
static val mutable XiColumnFpnCorrection: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCooling Field

CapPropXiCooling Field

Start camera cooling.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCooling = 466
Public Const XiCooling As CapProp = 466
public:
literal CapProp^ XiCooling = 466
static val mutable XiCooling: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCounterSelector Field

CapPropXiCounterSelector Field

Select counter

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCounterSelector = 536
Public Const XiCounterSelector As CapProp = 536
public:
literal CapProp^ XiCounterSelector = 536
static val mutable XiCounterSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiCounterValue Field

CapPropXiCounterValue Field

Counter status

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiCounterValue = 537
Public Const XiCounterValue As CapProp = 537
public:
literal CapProp^ XiCounterValue = 537
static val mutable XiCounterValue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDataFormat Field

CapPropXiDataFormat Field

Output data format

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDataFormat = 401
Public Const XiDataFormat As CapProp = 401
public:
literal CapProp^ XiDataFormat = 401
static val mutable XiDataFormat: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDebounceEn Field

CapPropXiDebounceEn Field

Enable/Disable debounce to selected GPI

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDebounceEn = 507
Public Const XiDebounceEn As CapProp = 507
public:
literal CapProp^ XiDebounceEn = 507
static val mutable XiDebounceEn: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDebouncePol Field

CapPropXiDebouncePol Field

Debounce polarity (pol = 1 t0 - falling edge, t1 - rising edge)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDebouncePol = 510
Public Const XiDebouncePol As CapProp = 510
public:
literal CapProp^ XiDebouncePol = 510
static val mutable XiDebouncePol: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDebounceT0 Field

CapPropXiDebounceT0 Field

Debounce time (x * 10us)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDebounceT0 = 508
Public Const XiDebounceT0 As CapProp = 508
public:
literal CapProp^ XiDebounceT0 = 508
static val mutable XiDebounceT0: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDebounceT1 Field

CapPropXiDebounceT1 Field

Debounce time (x * 10us)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDebounceT1 = 509
Public Const XiDebounceT1 As CapProp = 509
public:
literal CapProp^ XiDebounceT1 = 509
static val mutable XiDebounceT1: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDebugLevel Field

CapPropXiDebugLevel Field

Set debug level

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDebugLevel = 572
Public Const XiDebugLevel As CapProp = 572
public:
literal CapProp^ XiDebugLevel = 572
static val mutable XiDebugLevel: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDecimationHorizontal Field

CapPropXiDecimationHorizontal Field

Horizontal Decimation - horizontal sub-sampling of the image - reduces the horizontal resolution of the image by the specified vertical decimation factor.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDecimationHorizontal = 433
Public Const XiDecimationHorizontal As CapProp = 433
public:
literal CapProp^ XiDecimationHorizontal = 433
static val mutable XiDecimationHorizontal: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDecimationPattern Field

CapPropXiDecimationPattern Field

Decimation pattern type.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDecimationPattern = 434
Public Const XiDecimationPattern As CapProp = 434
public:
literal CapProp^ XiDecimationPattern = 434
static val mutable XiDecimationPattern: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDecimationSelector Field

CapPropXiDecimationSelector Field

Decimation engine selector.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDecimationSelector = 431
Public Const XiDecimationSelector As CapProp = 431
public:
literal CapProp^ XiDecimationSelector = 431
static val mutable XiDecimationSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDecimationVertical Field

CapPropXiDecimationVertical Field

Vertical Decimation - vertical sub-sampling of the image - reduces the vertical resolution of the image by the specified vertical decimation factor.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDecimationVertical = 432
Public Const XiDecimationVertical As CapProp = 432
public:
literal CapProp^ XiDecimationVertical = 432
static val mutable XiDecimationVertical: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDefaultCcMatrix Field

CapPropXiDefaultCcMatrix Field

Set default Color Correction Matrix

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDefaultCcMatrix = 495
Public Const XiDefaultCcMatrix As CapProp = 495
public:
literal CapProp^ XiDefaultCcMatrix = 495
static val mutable XiDefaultCcMatrix: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDeviceModelId Field

CapPropXiDeviceModelId Field

Return device model id

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDeviceModelId = 521
Public Const XiDeviceModelId As CapProp = 521
public:
literal CapProp^ XiDeviceModelId = 521
static val mutable XiDeviceModelId: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDeviceReset Field

CapPropXiDeviceReset Field

Resets the camera to default state.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDeviceReset = 554
Public Const XiDeviceReset As CapProp = 554
public:
literal CapProp^ XiDeviceReset = 554
static val mutable XiDeviceReset: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDeviceSn Field

CapPropXiDeviceSn Field

Return device serial number

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDeviceSn = 522
Public Const XiDeviceSn As CapProp = 522
public:
literal CapProp^ XiDeviceSn = 522
static val mutable XiDeviceSn: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDownsampling Field

CapPropXiDownsampling Field

Change image resolution by binning or skipping.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDownsampling = 400
Public Const XiDownsampling As CapProp = 400
public:
literal CapProp^ XiDownsampling = 400
static val mutable XiDownsampling: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiDownsamplingType Field

CapPropXiDownsamplingType Field

Change image downsampling type.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiDownsamplingType = 426
Public Const XiDownsamplingType As CapProp = 426
public:
literal CapProp^ XiDownsamplingType = 426
static val mutable XiDownsamplingType: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiExposure Field

CapPropXiExposure Field

Exposure time in microseconds

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiExposure = 421
Public Const XiExposure As CapProp = 421
public:
literal CapProp^ XiExposure = 421
static val mutable XiExposure: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiExposureBurstCount Field

CapPropXiExposureBurstCount Field

Sets the number of times of exposure in one frame.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiExposureBurstCount = 422
Public Const XiExposureBurstCount As CapProp = 422
public:
literal CapProp^ XiExposureBurstCount = 422
static val mutable XiExposureBurstCount: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiExpPriority Field

CapPropXiExpPriority Field

Exposure priority (0.5 - exposure 50%, gain 50%).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiExpPriority = 416
Public Const XiExpPriority As CapProp = 416
public:
literal CapProp^ XiExpPriority = 416
static val mutable XiExpPriority: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiFfsAccessKey Field

CapPropXiFfsAccessKey Field

Setting of key enables file operations on some cameras.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiFfsAccessKey = 583
Public Const XiFfsAccessKey As CapProp = 583
public:
literal CapProp^ XiFfsAccessKey = 583
static val mutable XiFfsAccessKey: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiFfsFileId Field

CapPropXiFfsFileId Field

File number.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiFfsFileId = 594
Public Const XiFfsFileId As CapProp = 594
public:
literal CapProp^ XiFfsFileId = 594
static val mutable XiFfsFileId: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiFfsFileSize Field

CapPropXiFfsFileSize Field

Size of file.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiFfsFileSize = 580
Public Const XiFfsFileSize As CapProp = 580
public:
literal CapProp^ XiFfsFileSize = 580
static val mutable XiFfsFileSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiFramerate Field

CapPropXiFramerate Field

Define framerate in Hz

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiFramerate = 535
Public Const XiFramerate As CapProp = 535
public:
literal CapProp^ XiFramerate = 535
static val mutable XiFramerate: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiFreeFfsSize Field

CapPropXiFreeFfsSize Field

Size of free camera FFS.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiFreeFfsSize = 581
Public Const XiFreeFfsSize As CapProp = 581
public:
literal CapProp^ XiFreeFfsSize = 581
static val mutable XiFreeFfsSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGain Field

CapPropXiGain Field

Gain in dB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGain = 424
Public Const XiGain As CapProp = 424
public:
literal CapProp^ XiGain = 424
static val mutable XiGain: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGainSelector Field

CapPropXiGainSelector Field

Gain selector for parameter Gain allows to select different type of gains.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGainSelector = 423
Public Const XiGainSelector As CapProp = 423
public:
literal CapProp^ XiGainSelector = 423
static val mutable XiGainSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGammac Field

CapPropXiGammac Field

Chromaticity gamma

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGammac = 477
Public Const XiGammac As CapProp = 477
public:
literal CapProp^ XiGammac = 477
static val mutable XiGammac: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGammay Field

CapPropXiGammay Field

Luminosity gamma

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGammay = 476
Public Const XiGammay As CapProp = 476
public:
literal CapProp^ XiGammay = 476
static val mutable XiGammay: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGpiLevel Field

CapPropXiGpiLevel Field

Get general purpose level

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGpiLevel = 408
Public Const XiGpiLevel As CapProp = 408
public:
literal CapProp^ XiGpiLevel = 408
static val mutable XiGpiLevel: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGpiMode Field

CapPropXiGpiMode Field

Set general purpose input mode

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGpiMode = 407
Public Const XiGpiMode As CapProp = 407
public:
literal CapProp^ XiGpiMode = 407
static val mutable XiGpiMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGpiSelector Field

CapPropXiGpiSelector Field

Selects general purpose input

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGpiSelector = 406
Public Const XiGpiSelector As CapProp = 406
public:
literal CapProp^ XiGpiSelector = 406
static val mutable XiGpiSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGpoMode Field

CapPropXiGpoMode Field

Set general purpose output mode

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGpoMode = 410
Public Const XiGpoMode As CapProp = 410
public:
literal CapProp^ XiGpoMode = 410
static val mutable XiGpoMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiGpoSelector Field

CapPropXiGpoSelector Field

Selects general purpose output

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiGpoSelector = 409
Public Const XiGpoSelector As CapProp = 409
public:
literal CapProp^ XiGpoSelector = 409
static val mutable XiGpoSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHdr Field

CapPropXiHdr Field

Enable High Dynamic Range feature.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHdr = 559
Public Const XiHdr As CapProp = 559
public:
literal CapProp^ XiHdr = 559
static val mutable XiHdr: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHdrKneepointCount Field

CapPropXiHdrKneepointCount Field

The number of kneepoints in the PWLR.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHdrKneepointCount = 560
Public Const XiHdrKneepointCount As CapProp = 560
public:
literal CapProp^ XiHdrKneepointCount = 560
static val mutable XiHdrKneepointCount: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHdrT1 Field

CapPropXiHdrT1 Field

position of first kneepoint(in % of XI_PRM_EXPOSURE)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHdrT1 = 561
Public Const XiHdrT1 As CapProp = 561
public:
literal CapProp^ XiHdrT1 = 561
static val mutable XiHdrT1: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHdrT2 Field

CapPropXiHdrT2 Field

position of second kneepoint (in % of XI_PRM_EXPOSURE)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHdrT2 = 562
Public Const XiHdrT2 As CapProp = 562
public:
literal CapProp^ XiHdrT2 = 562
static val mutable XiHdrT2: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHeight Field

CapPropXiHeight Field

Height of the Image provided by the device (in pixels).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHeight = 452
Public Const XiHeight As CapProp = 452
public:
literal CapProp^ XiHeight = 452
static val mutable XiHeight: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHousBackSideTemp Field

CapPropXiHousBackSideTemp Field

Camera housing back side temperature

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHousBackSideTemp = 590
Public Const XiHousBackSideTemp As CapProp = 590
public:
literal CapProp^ XiHousBackSideTemp = 590
static val mutable XiHousBackSideTemp: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHousTemp Field

CapPropXiHousTemp Field

Camera housing temperature

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHousTemp = 469
Public Const XiHousTemp As CapProp = 469
public:
literal CapProp^ XiHousTemp = 469
static val mutable XiHousTemp: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiHwRevision Field

CapPropXiHwRevision Field

Returns hardware revision number.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiHwRevision = 571
Public Const XiHwRevision As CapProp = 571
public:
literal CapProp^ XiHwRevision = 571
static val mutable XiHwRevision: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiImageBlackLevel Field

CapPropXiImageBlackLevel Field

Last image black level counts. Can be used for Offline processing to recall it.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiImageBlackLevel = 565
Public Const XiImageBlackLevel As CapProp = 565
public:
literal CapProp^ XiImageBlackLevel = 565
static val mutable XiImageBlackLevel: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiImageDataBitDepth Field

CapPropXiImageDataBitDepth Field

bitdepth of data returned by function xiGetImage

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiImageDataBitDepth = 462
Public Const XiImageDataBitDepth As CapProp = 462
public:
literal CapProp^ XiImageDataBitDepth = 462
static val mutable XiImageDataBitDepth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiImageDataFormat Field

CapPropXiImageDataFormat Field

Output data format.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiImageDataFormat = 435
Public Const XiImageDataFormat As CapProp = 435
public:
literal CapProp^ XiImageDataFormat = 435
static val mutable XiImageDataFormat: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiImageDataFormatRgb32Alpha Field

CapPropXiImageDataFormatRgb32Alpha Field

The alpha channel of RGB32 output image format.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiImageDataFormatRgb32Alpha = 529
Public Const XiImageDataFormatRgb32Alpha As CapProp = 529
public:
literal CapProp^ XiImageDataFormatRgb32Alpha = 529
static val mutable XiImageDataFormatRgb32Alpha: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiImageIsColor Field

CapPropXiImageIsColor Field

Returns 1 for color cameras.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiImageIsColor = 474
Public Const XiImageIsColor As CapProp = 474
public:
literal CapProp^ XiImageIsColor = 474
static val mutable XiImageIsColor: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiImagePayloadSize Field

CapPropXiImagePayloadSize Field

Buffer size in bytes sufficient for output image returned by xiGetImage

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiImagePayloadSize = 530
Public Const XiImagePayloadSize As CapProp = 530
public:
literal CapProp^ XiImagePayloadSize = 530
static val mutable XiImagePayloadSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiIsCooled Field

CapPropXiIsCooled Field

Returns 1 for cameras that support cooling.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiIsCooled = 465
Public Const XiIsCooled As CapProp = 465
public:
literal CapProp^ XiIsCooled = 465
static val mutable XiIsCooled: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiIsDeviceExist Field

CapPropXiIsDeviceExist Field

Returns 1 if camera connected and works properly.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiIsDeviceExist = 547
Public Const XiIsDeviceExist As CapProp = 547
public:
literal CapProp^ XiIsDeviceExist = 547
static val mutable XiIsDeviceExist: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiKneepoint1 Field

CapPropXiKneepoint1 Field

value of first kneepoint (% of sensor saturation)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiKneepoint1 = 563
Public Const XiKneepoint1 As CapProp = 563
public:
literal CapProp^ XiKneepoint1 = 563
static val mutable XiKneepoint1: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiKneepoint2 Field

CapPropXiKneepoint2 Field

value of second kneepoint (% of sensor saturation)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiKneepoint2 = 564
Public Const XiKneepoint2 As CapProp = 564
public:
literal CapProp^ XiKneepoint2 = 564
static val mutable XiKneepoint2: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLedMode Field

CapPropXiLedMode Field

Define camera signaling LED functionality

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLedMode = 412
Public Const XiLedMode As CapProp = 412
public:
literal CapProp^ XiLedMode = 412
static val mutable XiLedMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLedSelector Field

CapPropXiLedSelector Field

Selects camera signaling LED

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLedSelector = 411
Public Const XiLedSelector As CapProp = 411
public:
literal CapProp^ XiLedSelector = 411
static val mutable XiLedSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensApertureValue Field

CapPropXiLensApertureValue Field

Current lens aperture value in stops. Examples: 2.8, 4, 5.6, 8, 11

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensApertureValue = 512
Public Const XiLensApertureValue As CapProp = 512
public:
literal CapProp^ XiLensApertureValue = 512
static val mutable XiLensApertureValue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensFeature Field

CapPropXiLensFeature Field

Allows access to lens feature value currently selected by XI_PRM_LENS_FEATURE_SELECTOR.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensFeature = 518
Public Const XiLensFeature As CapProp = 518
public:
literal CapProp^ XiLensFeature = 518
static val mutable XiLensFeature: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensFeatureSelector Field

CapPropXiLensFeatureSelector Field

Selects the current feature which is accessible by XI_PRM_LENS_FEATURE.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensFeatureSelector = 517
Public Const XiLensFeatureSelector As CapProp = 517
public:
literal CapProp^ XiLensFeatureSelector = 517
static val mutable XiLensFeatureSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensFocalLength Field

CapPropXiLensFocalLength Field

Lens focal distance in mm.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensFocalLength = 516
Public Const XiLensFocalLength As CapProp = 516
public:
literal CapProp^ XiLensFocalLength = 516
static val mutable XiLensFocalLength: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensFocusDistance Field

CapPropXiLensFocusDistance Field

Lens focus distance in cm.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensFocusDistance = 515
Public Const XiLensFocusDistance As CapProp = 515
public:
literal CapProp^ XiLensFocusDistance = 515
static val mutable XiLensFocusDistance: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensFocusMove Field

CapPropXiLensFocusMove Field

Moves lens focus motor by steps set in XI_PRM_LENS_FOCUS_MOVEMENT_VALUE.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensFocusMove = 514
Public Const XiLensFocusMove As CapProp = 514
public:
literal CapProp^ XiLensFocusMove = 514
static val mutable XiLensFocusMove: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensFocusMovementValue Field

CapPropXiLensFocusMovementValue Field

Lens current focus movement value to be used by XI_PRM_LENS_FOCUS_MOVE in motor steps.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensFocusMovementValue = 513
Public Const XiLensFocusMovementValue As CapProp = 513
public:
literal CapProp^ XiLensFocusMovementValue = 513
static val mutable XiLensFocusMovementValue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLensMode Field

CapPropXiLensMode Field

Status of lens control interface. This shall be set to XI_ON before any Lens operations.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLensMode = 511
Public Const XiLensMode As CapProp = 511
public:
literal CapProp^ XiLensMode = 511
static val mutable XiLensMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLimitBandwidth Field

CapPropXiLimitBandwidth Field

Set/get bandwidth(datarate)(in Megabits)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLimitBandwidth = 459
Public Const XiLimitBandwidth As CapProp = 459
public:
literal CapProp^ XiLimitBandwidth = 459
static val mutable XiLimitBandwidth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLutEn Field

CapPropXiLutEn Field

Activates LUT.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLutEn = 541
Public Const XiLutEn As CapProp = 541
public:
literal CapProp^ XiLutEn = 541
static val mutable XiLutEn: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLutIndex Field

CapPropXiLutIndex Field

Control the index (offset) of the coefficient to access in the LUT.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLutIndex = 542
Public Const XiLutIndex As CapProp = 542
public:
literal CapProp^ XiLutIndex = 542
static val mutable XiLutIndex: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiLutValue Field

CapPropXiLutValue Field

Value at entry LUTIndex of the LUT

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiLutValue = 543
Public Const XiLutValue As CapProp = 543
public:
literal CapProp^ XiLutValue = 543
static val mutable XiLutValue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiManualWb Field

CapPropXiManualWb Field

Calculates White Balance(must be called during acquisition)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiManualWb = 413
Public Const XiManualWb As CapProp = 413
public:
literal CapProp^ XiManualWb = 413
static val mutable XiManualWb: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiOffsetX Field

CapPropXiOffsetX Field

Horizontal offset from the origin to the area of interest (in pixels).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiOffsetX = 402
Public Const XiOffsetX As CapProp = 402
public:
literal CapProp^ XiOffsetX = 402
static val mutable XiOffsetX: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiOffsetY Field

CapPropXiOffsetY Field

Vertical offset from the origin to the area of interest (in pixels).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiOffsetY = 403
Public Const XiOffsetY As CapProp = 403
public:
literal CapProp^ XiOffsetY = 403
static val mutable XiOffsetY: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiOutputDataBitDepth Field

CapPropXiOutputDataBitDepth Field

Device output data bit depth.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiOutputDataBitDepth = 461
Public Const XiOutputDataBitDepth As CapProp = 461
public:
literal CapProp^ XiOutputDataBitDepth = 461
static val mutable XiOutputDataBitDepth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiOutputDataPacking Field

CapPropXiOutputDataPacking Field

Device output data packing (or grouping) enabled. Packing could be enabled if output_data_bit_depth > 8 and packing capability is available.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiOutputDataPacking = 463
Public Const XiOutputDataPacking As CapProp = 463
public:
literal CapProp^ XiOutputDataPacking = 463
static val mutable XiOutputDataPacking: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiOutputDataPackingType Field

CapPropXiOutputDataPackingType Field

Data packing type. Some cameras supports only specific packing type.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiOutputDataPackingType = 464
Public Const XiOutputDataPackingType As CapProp = 464
public:
literal CapProp^ XiOutputDataPackingType = 464
static val mutable XiOutputDataPackingType: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiRecentFrame Field

CapPropXiRecentFrame Field

GetImage returns most recent frame

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiRecentFrame = 553
Public Const XiRecentFrame As CapProp = 553
public:
literal CapProp^ XiRecentFrame = 553
static val mutable XiRecentFrame: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiRegionMode Field

CapPropXiRegionMode Field

Activates/deactivates Region selected by Region Selector

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiRegionMode = 595
Public Const XiRegionMode As CapProp = 595
public:
literal CapProp^ XiRegionMode = 595
static val mutable XiRegionMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiRegionSelector Field

CapPropXiRegionSelector Field

Selects Region in Multiple ROI which parameters are set by width, height, ... ,region mode

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiRegionSelector = 589
Public Const XiRegionSelector As CapProp = 589
public:
literal CapProp^ XiRegionSelector = 589
static val mutable XiRegionSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiRowFpnCorrection Field

CapPropXiRowFpnCorrection Field

Correction of row FPN

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiRowFpnCorrection = 591
Public Const XiRowFpnCorrection As CapProp = 591
public:
literal CapProp^ XiRowFpnCorrection = 591
static val mutable XiRowFpnCorrection: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorBoardTemp Field

CapPropXiSensorBoardTemp Field

Camera sensor board temperature

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorBoardTemp = 596
Public Const XiSensorBoardTemp As CapProp = 596
public:
literal CapProp^ XiSensorBoardTemp = 596
static val mutable XiSensorBoardTemp: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorClockFreqHz Field

CapPropXiSensorClockFreqHz Field

Sensor clock frequency in Hz.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorClockFreqHz = 532
Public Const XiSensorClockFreqHz As CapProp = 532
public:
literal CapProp^ XiSensorClockFreqHz = 532
static val mutable XiSensorClockFreqHz: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorClockFreqIndex Field

CapPropXiSensorClockFreqIndex Field

Sensor clock frequency index. Sensor with selected frequencies have possibility to set the frequency only by this index.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorClockFreqIndex = 533
Public Const XiSensorClockFreqIndex As CapProp = 533
public:
literal CapProp^ XiSensorClockFreqIndex = 533
static val mutable XiSensorClockFreqIndex: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorDataBitDepth Field

CapPropXiSensorDataBitDepth Field

Sensor output data bit depth.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorDataBitDepth = 460
Public Const XiSensorDataBitDepth As CapProp = 460
public:
literal CapProp^ XiSensorDataBitDepth = 460
static val mutable XiSensorDataBitDepth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorFeatureSelector Field

CapPropXiSensorFeatureSelector Field

Selects the current feature which is accessible by XI_PRM_SENSOR_FEATURE_VALUE.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorFeatureSelector = 585
Public Const XiSensorFeatureSelector As CapProp = 585
public:
literal CapProp^ XiSensorFeatureSelector = 585
static val mutable XiSensorFeatureSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorFeatureValue Field

CapPropXiSensorFeatureValue Field

Allows access to sensor feature value currently selected by XI_PRM_SENSOR_FEATURE_SELECTOR.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorFeatureValue = 586
Public Const XiSensorFeatureValue As CapProp = 586
public:
literal CapProp^ XiSensorFeatureValue = 586
static val mutable XiSensorFeatureValue: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorMode Field

CapPropXiSensorMode Field

Current sensor mode. Allows to select sensor mode by one integer. Setting of this parameter affects: image dimensions and downsampling.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorMode = 558
Public Const XiSensorMode As CapProp = 558
public:
literal CapProp^ XiSensorMode = 558
static val mutable XiSensorMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorOutputChannelCount Field

CapPropXiSensorOutputChannelCount Field

Number of output channels from sensor used for data transfer.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorOutputChannelCount = 534
Public Const XiSensorOutputChannelCount As CapProp = 534
public:
literal CapProp^ XiSensorOutputChannelCount = 534
static val mutable XiSensorOutputChannelCount: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSensorTaps Field

CapPropXiSensorTaps Field

Number of taps

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSensorTaps = 437
Public Const XiSensorTaps As CapProp = 437
public:
literal CapProp^ XiSensorTaps = 437
static val mutable XiSensorTaps: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiSharpness Field

CapPropXiSharpness Field

Sharpness Strength

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiSharpness = 478
Public Const XiSharpness As CapProp = 478
public:
literal CapProp^ XiSharpness = 478
static val mutable XiSharpness: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiShutterType Field

CapPropXiShutterType Field

Change sensor shutter type(CMOS sensor).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiShutterType = 436
Public Const XiShutterType As CapProp = 436
public:
literal CapProp^ XiShutterType = 436
static val mutable XiShutterType: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTargetTemp Field

CapPropXiTargetTemp Field

Set sensor target temperature for cooling.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTargetTemp = 467
Public Const XiTargetTemp As CapProp = 467
public:
literal CapProp^ XiTargetTemp = 467
static val mutable XiTargetTemp: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTestPattern Field

CapPropXiTestPattern Field

Selects which test pattern type is generated by the selected generator.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTestPattern = 588
Public Const XiTestPattern As CapProp = 588
public:
literal CapProp^ XiTestPattern = 588
static val mutable XiTestPattern: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTestPatternGeneratorSelector Field

CapPropXiTestPatternGeneratorSelector Field

Selects which test pattern generator is controlled by the TestPattern feature.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTestPatternGeneratorSelector = 587
Public Const XiTestPatternGeneratorSelector As CapProp = 587
public:
literal CapProp^ XiTestPatternGeneratorSelector = 587
static val mutable XiTestPatternGeneratorSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTimeout Field

CapPropXiTimeout Field

Image capture timeout in milliseconds

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTimeout = 420
Public Const XiTimeout As CapProp = 420
public:
literal CapProp^ XiTimeout = 420
static val mutable XiTimeout: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTransportPixelFormat Field

CapPropXiTransportPixelFormat Field

Current format of pixels on transport layer.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTransportPixelFormat = 531
Public Const XiTransportPixelFormat As CapProp = 531
public:
literal CapProp^ XiTransportPixelFormat = 531
static val mutable XiTransportPixelFormat: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTrgDelay Field

CapPropXiTrgDelay Field

Specifies the delay in microseconds (us) to apply after the trigger reception before activating it.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTrgDelay = 544
Public Const XiTrgDelay As CapProp = 544
public:
literal CapProp^ XiTrgDelay = 544
static val mutable XiTrgDelay: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTrgSelector Field

CapPropXiTrgSelector Field

Selects the type of trigger.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTrgSelector = 498
Public Const XiTrgSelector As CapProp = 498
public:
literal CapProp^ XiTrgSelector = 498
static val mutable XiTrgSelector: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTrgSoftware Field

CapPropXiTrgSoftware Field

Generates an internal trigger. PRM_TRG_SOURCE must be set to TRG_SOFTWARE.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTrgSoftware = 405
Public Const XiTrgSoftware As CapProp = 405
public:
literal CapProp^ XiTrgSoftware = 405
static val mutable XiTrgSoftware: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTrgSource Field

CapPropXiTrgSource Field

Defines source of trigger.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTrgSource = 404
Public Const XiTrgSource As CapProp = 404
public:
literal CapProp^ XiTrgSource = 404
static val mutable XiTrgSource: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTsRstMode Field

CapPropXiTsRstMode Field

Defines how time stamp reset engine will be armed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTsRstMode = 545
Public Const XiTsRstMode As CapProp = 545
public:
literal CapProp^ XiTsRstMode = 545
static val mutable XiTsRstMode: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiTsRstSource Field

CapPropXiTsRstSource Field

Defines which source will be used for timestamp reset. Writing this parameter will trigger settings of engine (arming)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiTsRstSource = 546
Public Const XiTsRstSource As CapProp = 546
public:
literal CapProp^ XiTsRstSource = 546
static val mutable XiTsRstSource: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiUsedFfsSize Field

CapPropXiUsedFfsSize Field

Size of used camera FFS.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiUsedFfsSize = 582
Public Const XiUsedFfsSize As CapProp = 582
public:
literal CapProp^ XiUsedFfsSize = 582
static val mutable XiUsedFfsSize: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiWbKb Field

CapPropXiWbKb Field

White balance blue coefficient

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiWbKb = 450
Public Const XiWbKb As CapProp = 450
public:
literal CapProp^ XiWbKb = 450
static val mutable XiWbKb: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiWbKg Field

CapPropXiWbKg Field

White balance green coefficient

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiWbKg = 449
Public Const XiWbKg As CapProp = 449
public:
literal CapProp^ XiWbKg = 449
static val mutable XiWbKg: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiWbKr Field

CapPropXiWbKr Field

White balance red coefficient

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiWbKr = 448
Public Const XiWbKr As CapProp = 448
public:
literal CapProp^ XiWbKr = 448
static val mutable XiWbKr: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.XiWidth Field

CapPropXiWidth Field

Width of the Image provided by the device (in pixels).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp XiWidth = 451
Public Const XiWidth As CapProp = 451
public:
literal CapProp^ XiWidth = 451
static val mutable XiWidth: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


CapProp.Zoom Field

CapPropZoom Field

Zoom

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CapProp Zoom = 27
Public Const Zoom As CapProp = 27
public:
literal CapProp^ Zoom = 27
static val mutable Zoom: CapProp

Field Value

Type: CapProp
See Also

Reference

CapProp Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod Class

contour approximation method
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumChainApproxMethod

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ChainApproxMethod : Enum
Public NotInheritable Class ChainApproxMethod
    Inherits Enum
public ref class ChainApproxMethod sealed : public Enum
[<SealedAttribute>]
type ChainApproxMethod =
    class
        inherit Enum
    end

The ChainApproxMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ChainApproxNone | translate all the points from the chain code into points;
 | ChainApproxSimple | compress horizontal, vertical, and diagonal segments, that is, the function leaves only their ending points;
 | ChainApproxTc89Kcos | apply one of the flavors of Teh-Chin chain approximation algorithm
 | ChainApproxTc89L1 |
 | ChainCode | output contours in the Freeman chain code. All other methods output polygons (sequences of vertices).
 | LinkRuns | use completely different contour retrieval algorithm via linking of horizontal segments of 1s. Only LIST retrieval mode can be used with this method
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ChainApproxMethod Methods

The ChainApproxMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod Fields

The ChainApproxMethod type exposes the following members.

Fields
 | Name | Description
 | ChainApproxNone | translate all the points from the chain code into points;
 | ChainApproxSimple | compress horizontal, vertical, and diagonal segments, that is, the function leaves only their ending points;
 | ChainApproxTc89Kcos | apply one of the flavors of Teh-Chin chain approximation algorithm
 | ChainApproxTc89L1 |
 | ChainCode | output contours in the Freeman chain code. All other methods output polygons (sequences of vertices).
 | LinkRuns | use completely different contour retrieval algorithm via linking of horizontal segments of 1s. Only LIST retrieval mode can be used with this method
Public field | value__ |
Top
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod.ChainApproxNone Field

ChainApproxMethodChainApproxNone Field

translate all the points from the chain code into points;

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ChainApproxMethod ChainApproxNone = 1
Public Const ChainApproxNone As ChainApproxMethod = 1
public:
literal ChainApproxMethod^ ChainApproxNone = 1
static val mutable ChainApproxNone: ChainApproxMethod

Field Value

Type: ChainApproxMethod
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod.ChainApproxSimple Field

ChainApproxMethodChainApproxSimple Field

compress horizontal, vertical, and diagonal segments, that is, the function leaves only their ending points;

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ChainApproxMethod ChainApproxSimple = 2
Public Const ChainApproxSimple As ChainApproxMethod = 2
public:
literal ChainApproxMethod^ ChainApproxSimple = 2
static val mutable ChainApproxSimple: ChainApproxMethod

Field Value

Type: ChainApproxMethod
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod.ChainApproxTc89Kcos Field

ChainApproxMethodChainApproxTc89Kcos Field

apply one of the flavors of Teh-Chin chain approximation algorithm

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ChainApproxMethod ChainApproxTc89Kcos = 4
Public Const ChainApproxTc89Kcos As ChainApproxMethod = 4
public:
literal ChainApproxMethod^ ChainApproxTc89Kcos = 4
static val mutable ChainApproxTc89Kcos: ChainApproxMethod

Field Value

Type: ChainApproxMethod
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod.ChainApproxTc89L1 Field

ChainApproxMethodChainApproxTc89L1 Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ChainApproxMethod.ChainApproxTc89L1"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ChainApproxMethod ChainApproxTc89L1 = 3
Public Const ChainApproxTc89L1 As ChainApproxMethod = 3
public:
literal ChainApproxMethod^ ChainApproxTc89L1 = 3
static val mutable ChainApproxTc89L1: ChainApproxMethod

Field Value

Type: ChainApproxMethod
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod.ChainCode Field

ChainApproxMethodChainCode Field

output contours in the Freeman chain code. All other methods output polygons (sequences of vertices).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ChainApproxMethod ChainCode = 0
Public Const ChainCode As ChainApproxMethod = 0
public:
literal ChainApproxMethod^ ChainCode = 0
static val mutable ChainCode: ChainApproxMethod

Field Value

Type: ChainApproxMethod
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod.LinkRuns Field

ChainApproxMethodLinkRuns Field

use completely different contour retrieval algorithm via linking of horizontal segments of 1s. Only LIST retrieval mode can be used with this method

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ChainApproxMethod LinkRuns = 5
Public Const LinkRuns As ChainApproxMethod = 5
public:
literal ChainApproxMethod^ LinkRuns = 5
static val mutable LinkRuns: ChainApproxMethod

Field Value

Type: ChainApproxMethod
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


ChainApproxMethod.value__ Field

ChainApproxMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ChainApproxMethod.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ChainApproxMethod Class
Emgu.CV.CvEnum Namespace


CheckType Class

Enumeration used by cvCheckArr
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCheckType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class CheckType : Enum
<FlagsAttribute>
Public NotInheritable Class CheckType
    Inherits Enum
[FlagsAttribute]
public ref class CheckType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type CheckType =
    class
        inherit Enum
    end

The CheckType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | NanInfinity | Checks that every element is neither NaN nor Infinity
 | Quite | If set, the function does not raises an error if an element is invalid or out of range
 | Range | If set, the function checks that every value of array is within [minVal,maxVal) range, otherwise it just checks that every element is neither NaN nor Infinity
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CheckType Methods

The CheckType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CheckType Class
Emgu.CV.CvEnum Namespace


CheckType Fields

The CheckType type exposes the following members.

Fields
 | Name | Description
 | NanInfinity | Checks that every element is neither NaN nor Infinity
 | Quite | If set, the function does not raises an error if an element is invalid or out of range
 | Range | If set, the function checks that every value of array is within [minVal,maxVal) range, otherwise it just checks that every element is neither NaN nor Infinity
Public field | value__ |
Top
See Also

Reference

CheckType Class
Emgu.CV.CvEnum Namespace


CheckType.NanInfinity Field

CheckTypeNanInfinity Field

Checks that every element is neither NaN nor Infinity

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CheckType NanInfinity = 0
Public Const NanInfinity As CheckType = 0
public:
literal CheckType^ NanInfinity = 0
static val mutable NanInfinity: CheckType

Field Value

Type: CheckType
See Also

Reference

CheckType Class
Emgu.CV.CvEnum Namespace


CheckType.Quite Field

CheckTypeQuite Field

If set, the function does not raises an error if an element is invalid or out of range

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CheckType Quite = 2
Public Const Quite As CheckType = 2
public:
literal CheckType^ Quite = 2
static val mutable Quite: CheckType

Field Value

Type: CheckType
See Also

Reference

CheckType Class
Emgu.CV.CvEnum Namespace


CheckType.Range Field

CheckTypeRange Field

If set, the function checks that every value of array is within [minVal,maxVal) range, otherwise it just checks that every element is neither NaN nor Infinity

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CheckType Range = 1
Public Const Range As CheckType = 1
public:
literal CheckType^ Range = 1
static val mutable Range: CheckType

Field Value

Type: CheckType
See Also

Reference

CheckType Class
Emgu.CV.CvEnum Namespace


CheckType.value__ Field

CheckTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CheckType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CheckType Class
Emgu.CV.CvEnum Namespace


CloningMethod Class

Seamless clone method
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCloningMethod

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CloningMethod : Enum
Public NotInheritable Class CloningMethod
    Inherits Enum
public ref class CloningMethod sealed : public Enum
[<SealedAttribute>]
type CloningMethod =
    class
        inherit Enum
    end

The CloningMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Mixed | The classic method, color-based selection and alpha masking might be time consuming and often leaves an undesirable halo. Seamless cloning, even averaged with the original image, is not effective. Mixed seamless cloning based on a loose selection proves effective.
 | MonochromeTransfer | Monochrome transfer
 | Normal | The power of the method is fully expressed when inserting objects with complex outlines into a new background
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CloningMethod Methods

The CloningMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CloningMethod Class
Emgu.CV.CvEnum Namespace


CloningMethod Fields

The CloningMethod type exposes the following members.

Fields
 | Name | Description
 | Mixed | The classic method, color-based selection and alpha masking might be time consuming and often leaves an undesirable halo. Seamless cloning, even averaged with the original image, is not effective. Mixed seamless cloning based on a loose selection proves effective.
 | MonochromeTransfer | Monochrome transfer
 | Normal | The power of the method is fully expressed when inserting objects with complex outlines into a new background
Public field | value__ |
Top
See Also

Reference

CloningMethod Class
Emgu.CV.CvEnum Namespace


CloningMethod.Mixed Field

CloningMethodMixed Field

The classic method, color-based selection and alpha masking might be time consuming and often leaves an undesirable halo. Seamless cloning, even averaged with the original image, is not effective. Mixed seamless cloning based on a loose selection proves effective.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CloningMethod Mixed = 2
Public Const Mixed As CloningMethod = 2
public:
literal CloningMethod^ Mixed = 2
static val mutable Mixed: CloningMethod

Field Value

Type: CloningMethod
See Also

Reference

CloningMethod Class
Emgu.CV.CvEnum Namespace


CloningMethod.MonochromeTransfer Field

CloningMethodMonochromeTransfer Field

Monochrome transfer

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CloningMethod MonochromeTransfer = 3
Public Const MonochromeTransfer As CloningMethod = 3
public:
literal CloningMethod^ MonochromeTransfer = 3
static val mutable MonochromeTransfer: CloningMethod

Field Value

Type: CloningMethod
See Also

Reference

CloningMethod Class
Emgu.CV.CvEnum Namespace


CloningMethod.Normal Field

CloningMethodNormal Field

The power of the method is fully expressed when inserting objects with complex outlines into a new background

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CloningMethod Normal = 1
Public Const Normal As CloningMethod = 1
public:
literal CloningMethod^ Normal = 1
static val mutable Normal: CloningMethod

Field Value

Type: CloningMethod
See Also

Reference

CloningMethod Class
Emgu.CV.CvEnum Namespace


CloningMethod.value__ Field

CloningMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CloningMethod.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CloningMethod Class
Emgu.CV.CvEnum Namespace


CmpType Class

Type used for cvCmp function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCmpType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CmpType : Enum
Public NotInheritable Class CmpType
    Inherits Enum
public ref class CmpType sealed : public Enum
[<SealedAttribute>]
type CmpType =
    class
        inherit Enum
    end

The CmpType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Equal | src1(I) "equal to" src2(I)
 | GreaterEqual | src1(I) "greater or equal" src2(I)
 | GreaterThan | src1(I) "greater than" src2(I)
 | LessEqual | src1(I) "less or equal" src2(I)
 | LessThan | src1(I) "less than" src2(I)
 | NotEqual | src1(I) "not equal to" src2(I)
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CmpType Methods

The CmpType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType Fields

The CmpType type exposes the following members.

Fields
 | Name | Description
 | Equal | src1(I) "equal to" src2(I)
 | GreaterEqual | src1(I) "greater or equal" src2(I)
 | GreaterThan | src1(I) "greater than" src2(I)
 | LessEqual | src1(I) "less or equal" src2(I)
 | LessThan | src1(I) "less than" src2(I)
 | NotEqual | src1(I) "not equal to" src2(I)
Public field | value__ |
Top
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType.Equal Field

CmpTypeEqual Field

src1(I) "equal to" src2(I)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CmpType Equal = 0
Public Const Equal As CmpType = 0
public:
literal CmpType^ Equal = 0
static val mutable Equal: CmpType

Field Value

Type: CmpType
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType.GreaterEqual Field

CmpTypeGreaterEqual Field

src1(I) "greater or equal" src2(I)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CmpType GreaterEqual = 2
Public Const GreaterEqual As CmpType = 2
public:
literal CmpType^ GreaterEqual = 2
static val mutable GreaterEqual: CmpType

Field Value

Type: CmpType
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType.GreaterThan Field

CmpTypeGreaterThan Field

src1(I) "greater than" src2(I)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CmpType GreaterThan = 1
Public Const GreaterThan As CmpType = 1
public:
literal CmpType^ GreaterThan = 1
static val mutable GreaterThan: CmpType

Field Value

Type: CmpType
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType.LessEqual Field

CmpTypeLessEqual Field

src1(I) "less or equal" src2(I)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CmpType LessEqual = 4
Public Const LessEqual As CmpType = 4
public:
literal CmpType^ LessEqual = 4
static val mutable LessEqual: CmpType

Field Value

Type: CmpType
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType.LessThan Field

CmpTypeLessThan Field

src1(I) "less than" src2(I)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CmpType LessThan = 3
Public Const LessThan As CmpType = 3
public:
literal CmpType^ LessThan = 3
static val mutable LessThan: CmpType

Field Value

Type: CmpType
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType.NotEqual Field

CmpTypeNotEqual Field

src1(I) "not equal to" src2(I)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CmpType NotEqual = 5
Public Const NotEqual As CmpType = 5
public:
literal CmpType^ NotEqual = 5
static val mutable NotEqual: CmpType

Field Value

Type: CmpType
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


CmpType.value__ Field

CmpTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CmpType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CmpType Class
Emgu.CV.CvEnum Namespace


ColorConversion Class

Color Conversion code
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumColorConversion

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ColorConversion : Enum
Public NotInheritable Class ColorConversion
    Inherits Enum
public ref class ColorConversion sealed : public Enum
[<SealedAttribute>]
type ColorConversion =
    class
        inherit Enum
    end

The ColorConversion type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BayerBg2Bgr | Convert BayerBG color to BGR color
 | BayerBg2BgrEa | Convert BayerBG to BGR (Edge-Aware Demosaicing)
 | BayerBg2BgrVng | Convert BayerBG pattern to BGR color using VNG
 | BayerBg2Gray | Convert BayerBG to GRAY
 | BayerBg2Rgb | Convert BayerBG color to BGR color
 | BayerBg2RgbEa | Convert BayerBG to RGB (Edge-Aware Demosaicing)
 | BayerBg2RgbVng | Convert BayerBG pattern to RGB color using VNG
 | BayerGb2Bgr | Convert BayerGB color to BGR color
 | BayerGb2BgrEa | Convert BayerGB to BGR (Edge-Aware Demosaicing)
 | BayerGb2BgrVng | Convert BayerGB pattern to BGR color using VNG
 | BayerGb2Gray | Convert BayerGB to GRAY
 | BayerGb2Rgb | Convert BayerRG color to BGR color
 | BayerGb2RgbEa | Convert BayerGB to RGB (Edge-Aware Demosaicing)
 | BayerGb2RgbVng | Convert BayerGB pattern to RGB color using VNG
 | BayerGr2Bgr | Convert BayerGR color to BGR color
 | BayerGr2BgrEa | Convert BayerGR to BGR (Edge-Aware Demosaicing)
 | BayerGr2BgrVng | Convert BayerGR pattern to BGR color using VNG
 | BayerGr2Gray | Convert BayerGR to GRAY
 | BayerGr2Rgb | Convert BayerGR color to RGB color
 | BayerGr2RgbEa | Convert BayerGR to RGB (Edge-Aware Demosaicing)
 | BayerGr2RgbVng | Convert BayerGR pattern to RGB color using VNG
 | BayerRg2Bgr | Convert BayerRG color to BGR color
 | BayerRg2BgrEa | Convert BayerRG to BGR (Edge-Aware Demosaicing)
 | BayerRg2BgrVng | Convert BayerRG pattern to BGR color using VNG
 | BayerRg2Gray | Convert BayerRG to GRAY
 | BayerRg2Rgb | Convert BayerRG color to RGB color
 | BayerRg2RgbEa | Convert BayerRG to RGB (Edge-Aware Demosaicing)
 | BayerRg2RgbVng | Convert BayerRG pattern to RGB color using VNG
 | Bgr2Bgr555 | Convert BGR color to BGR555 color
 | Bgr2Bgr565 | Convert BGR color to BGR565 color
 | Bgr2Bgra | Convert BGR color to BGRA color
 | Bgr2Gray | Convert BGR color to GRAY color
 | Bgr2Hls | Convert BGR color to HLS color
 | Bgr2HlsFull | Convert BGR to HLS
 | Bgr2Hsv | Convert BGR color to HSV color
 | Bgr2HsvFull | Convert BGR to HSV
 | Bgr2Lab | Convert BGR color to Lab color
 | Bgr2Luv | Convert BGR color to Luv color
 | Bgr2Rgb | Convert BGR color to RGB color
 | Bgr2Rgba | Convert BGR color to RGBA color
 | Bgr2Xyz | Convert BGR color to XYZ color
 | Bgr2YCrCb | Convert BGR color to YCrCb color
 | Bgr2Yuv | Convert BGR color to YUV
 | Bgr2YuvI420 | Convert BGR to YUV_I420
 | Bgr2YuvIyuv | Convert BGR to YUV_IYUV
 | Bgr2YuvYv12 | Convert BGR to YUV_YV12
 | Bgr5552Bgr | Convert BGR555 color to BGR color
 | Bgr5552Bgra | Convert BGR555 color to BGRA color
 | Bgr5552Gray | Convert BGR555 color to GRAY color
 | Bgr5552Rgb | Convert BGR555 color to RGB color
 | Bgr5552Rgba | Convert BGR555 color to RGBA color
 | Bgr5652Bgr | Convert BGR565 color to BGR color
 | Bgr5652Bgra | Convert BGR565 color to BGRA color
 | Bgr5652Gray | Convert BGR565 color to GRAY color
 | Bgr5652Rgb | Convert BGR565 color to RGB color
 | Bgr5652Rgba | Convert BGR565 color to RGBA color
 | Bgra2Bgr | Convert BGRA color to BGR color
 | Bgra2Bgr555 | Convert BGRA color to BGR555 color
 | Bgra2Bgr565 | Convert BGRA color to BGR565 color
 | Bgra2Gray | Convert BGRA color to GRAY color
 | Bgra2Rgb | Convert BGRA color to RGB color
 | Bgra2Rgba | Convert BGRA color to RGBA color
 | Bgra2YuvI420 | Convert BGRA to YUV_I420
 | Bgra2YuvIyuv | Convert BGRA to YUV_IYUV
 | Bgra2YuvYv12 | Convert BGRA to YUV_YV12
 | ColorcvtMax | The max number, do not use
 | Gray2Bgr | Convert GRAY color to BGR color
 | Gray2Bgr555 | Convert GRAY color to BGR555 color
 | Gray2Bgr565 | Convert GRAY color to BGR565 color
 | Gray2Bgra | Convert GRAY color to BGRA color
 | Gray2Rgb | Convert GRAY color to RGB color
 | Gray2Rgba | Convert GRAY color to RGBA color
 | Hls2Bgr | Convert HLS color to BGR color
 | Hls2BgrFull | Convert HLS color to BGR color
 | Hls2Rgb | Convert HLS color to RGB color
 | Hls2RgbFull | Convert HLS color to RGB color
 | Hsv2Bgr | Convert HSV color to BGR color
 | Hsv2BgrFull | Convert HSV color to BGR color
 | Hsv2Rgb | Convert HSV color to RGB color
 | Hsv2RgbFull | Convert HSV color to RGB color
 | Lab2Bgr | Convert Lab color to BGR color
 | Lab2Lbgr | Convert Lab color to sBGR color
 | Lab2Lrgb | Convert Lab color to sRGB color
 | Lab2Rgb | Convert Lab color to RGB color
 | Lbgr2Lab | Convert sBGR color to Lab color
 | Lbgr2Luv | Convert sBGR color to Luv color
 | Lrgb2Lab | Convert sRGB color to Lab color
 | Lrgb2Luv | Convert sRGB color to Luv color
 | Luv2Bgr | Convert Luv color to BGR color
 | Luv2Lbgr | Convert Luv color to sBGR color
 | Luv2Lrgb | Convert Luv color to sRGB color
 | Luv2Rgb | Convert Luv color to RGB color
 | MRgba2Rgba | Alpha premultiplication
 | Rgb2Bgr | Convert RGB color to BGR color
 | Rgb2Bgr555 | Convert RGB color to BGR555 color
 | Rgb2Bgr565 | Convert RGB color to BGR565 color
 | Rgb2Bgra | Convert RGB color to BGRA color
 | Rgb2Gray | Convert RGB color to GRAY color
 | Rgb2Hls | Convert RGB color to HLS color
 | Rgb2HlsFull | Convert RGB to HLS
 | Rgb2Hsv | Convert RGB colot to HSV color
 | Rgb2HsvFull | Convert RGB to HSV
 | Rgb2Lab | Convert RGB color to Lab color
 | Rgb2Luv | Convert RGB color to Luv color
 | Rgb2Rgba | Convert RGB color to RGBA color
 | Rgb2Xyz | Convert RGB color to XYZ color
 | Rgb2YCrCb | Convert RGB color to YCrCb color
 | Rgb2Yuv | Convert RGB color to YUV
 | Rgb2YuvI420 | Convert RGB to YUV_I420
 | Rgb2YuvIyuv | Convert RGB to YUV_IYUV
 | Rgb2YuvYv12 | Convert RGB to YUV_YV12
 | Rgba2Bgr | Convert RGBA color to BGR color
 | Rgba2Bgr555 | Convert RGBA color to BGR555 color
 | Rgba2Bgr565 | Convert RGBA color to BGR565 color
 | Rgba2Bgra | Convert RGBA color to BGRA color
 | Rgba2Gray | Convert RGBA color to GRAY color
 | Rgba2MRgba | Alpha premultiplication
 | Rgba2Rgb | Convert RGBA color to RGB color
 | Rgba2YuvI420 | Convert RGBA to YUV_I420
 | Rgba2YuvIyuv | Convert RGBA to YUV_IYUV
 | Rgba2YuvYv12 | Convert RGBA to YUV_YV12
Public field | value__ |
 | Xyz2Bgr | Convert XYZ color to BGR color
 | Xyz2Rgb | Convert XYZ color to RGB color
 | YCrCb2Bgr | Convert YCrCb color to BGR color
 | YCrCb2Rgb | Convert YCrCb color to RGB color
 | Yuv2Bgr | Convert YUV color to BGR
 | Yuv2BgraI420 | Convert YUV (i420) to BGRA
 | Yuv2BgraIyuv | Convert YUV (iYUV) to BGRA
 | Yuv2BgraUynv | Convert YUV (UYNV) to BGRA
 | Yuv2BgraUyvy | Convert YUV (VYUY) to BGRA
 | Yuv2BgraY422 | Convert YUV (Y422) to BGRA
 | Yuv2BgraYunv | Convert YUV (YUNV) to BGRA
 | Yuv2BgraYuy2 | Convert YUV (YUY2) to BGRA
 | Yuv2BgraYuyv | Convert YUV (YUYV) to BGRA
 | Yuv2BgraYv12 | Convert YUV (YV12) to BGRA
 | Yuv2BgraYvyu | Convert YUV (YVYU) to BGRA
 | Yuv2BgrI420 | Convert YUV (i420) to BGR
 | Yuv2BgrIyuv | Convert YUV (iYUV) to BGR
 | Yuv2BgrUynv | Convert YUV (UYNV) to BGR
 | Yuv2BgrUyvy | Convert YUV (UYVY) to BGR
 | Yuv2BgrY422 | Convert YUV (Y422) to BGR
 | Yuv2BgrYunv | Convert YUV (YUNV) to BGR
 | Yuv2BgrYuy2 | Convert YUV (YUY2) to BGR
 | Yuv2BgrYuyv | Convert YUV (YUYV) to BGR
 | Yuv2BgrYv12 | Convert YUV (YV12) to BGR
 | Yuv2BgrYvyu | Convert YUV (YVYU) to BGR
 | Yuv2Gray420 | Convert YUV 420 to Gray
 | Yuv2GrayI420 | Convert YUV (i420) to Gray
 | Yuv2GrayIyuv | Convert YUV (iYUV) to Gray
 | Yuv2GrayNv12 | Convert YUV NV12 to Gray
 | Yuv2GrayNv21 | Convert YUV NV21 to Gray
 | Yuv2GrayUynv | Convert YUV (UYNV) to Gray
 | Yuv2GrayUyvy | Convert YUV (UYVY) to Gray
 | Yuv2GrayY422 | Convert YUV (Y422) to Gray
 | Yuv2GrayYunv | Convert YUV (YUNV) to Gray
 | Yuv2GrayYuy2 | Convert YUV (YUY2) to Gray
 | Yuv2GrayYuyv | Convert YUV (YUYV) to Gray
 | Yuv2GrayYv12 | Convert YUV YV12 to Gray
 | Yuv2GrayYvyu | Convert YUV (YVYU) to Gray
 | Yuv2Rgb | Convert YUV color to RGB
 | Yuv2RgbaI420 | Convert YUV (i420) to RGBA
 | Yuv2RgbaIyuv | Convert YUV (iYUV) to RGBA
 | Yuv2RgbaUynv | Convert YUV (UYNV) to RGBA
 | Yuv2RgbaUyvy | Convert YUV (UYVY) to RGBA
 | Yuv2RgbaY422 | Convert YUV (Y422) to RGBA
 | Yuv2RgbaYunv | Convert YUV (YUNV) to RGBA
 | Yuv2RgbaYuy2 | Convert YUV (YUY2) to RGBA
 | Yuv2RgbaYuyv | Convert YUV (YUYV) to RGBA
 | Yuv2RgbaYv12 | Convert YUV (YV12) to RGBA
 | Yuv2RgbaYvyu | Convert YUV (YVYU) to RGBA
 | Yuv2RgbI420 | Convert YUV (i420) to RGB
 | Yuv2RgbIyuv | Convert YUV (iYUV) to RGB
 | Yuv2RgbUynv | Convert YUV (UYNY) to RGB
 | Yuv2RgbUyvy | Convert YUV (UYVY) to RGB
 | Yuv2RgbY422 | Convert YUV (Y422) to RGB
 | Yuv2RgbYunv | Convert YUV (YUNV) to RGB
 | Yuv2RgbYuy2 | Convert YUV (YUY2) to RGB
 | Yuv2RgbYuyv | Convert YUV (YUYV) to RGB
 | Yuv2RgbYv12 | Convert YUV (YV12) to RGB
 | Yuv2RgbYvyu | Convert YUV (YVYU) to RGB
 | Yuv420I2Bgr | Convert YUV420i to BGR
 | Yuv420I2Bgra | Convert YUV420i to BGRA
 | Yuv420I2Rgb | Convert YUV420i to RGB
 | Yuv420I2Rgba | Convert YUV320i to RGBA
 | Yuv420P2Bgr | Convert YUV (420p) to BGR
 | Yuv420P2Bgra | Convert YUV (420p) to BGRA
 | Yuv420P2Gray | Convert YUV (420p) to Gray
 | Yuv420P2Rgb | Convert YUV (420p) to RGB
 | Yuv420P2Rgba | Convert YUV (420p) to RGBA
 | Yuv420Sp2Bgr | Convert YUV320sp to BGR
 | Yuv420Sp2Bgra | Convert YUV420sp to BGRA
 | Yuv420Sp2Gray | Convert YUV (420sp) to Gray
 | Yuv420Sp2Rgb | Convert YUV420sp to RGB
 | Yuv420Sp2Rgba | Convert YUV420sp to RGBA
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ColorConversion Methods

The ColorConversion type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion Fields

The ColorConversion type exposes the following members.

Fields
 | Name | Description
 | BayerBg2Bgr | Convert BayerBG color to BGR color
 | BayerBg2BgrEa | Convert BayerBG to BGR (Edge-Aware Demosaicing)
 | BayerBg2BgrVng | Convert BayerBG pattern to BGR color using VNG
 | BayerBg2Gray | Convert BayerBG to GRAY
 | BayerBg2Rgb | Convert BayerBG color to BGR color
 | BayerBg2RgbEa | Convert BayerBG to RGB (Edge-Aware Demosaicing)
 | BayerBg2RgbVng | Convert BayerBG pattern to RGB color using VNG
 | BayerGb2Bgr | Convert BayerGB color to BGR color
 | BayerGb2BgrEa | Convert BayerGB to BGR (Edge-Aware Demosaicing)
 | BayerGb2BgrVng | Convert BayerGB pattern to BGR color using VNG
 | BayerGb2Gray | Convert BayerGB to GRAY
 | BayerGb2Rgb | Convert BayerRG color to BGR color
 | BayerGb2RgbEa | Convert BayerGB to RGB (Edge-Aware Demosaicing)
 | BayerGb2RgbVng | Convert BayerGB pattern to RGB color using VNG
 | BayerGr2Bgr | Convert BayerGR color to BGR color
 | BayerGr2BgrEa | Convert BayerGR to BGR (Edge-Aware Demosaicing)
 | BayerGr2BgrVng | Convert BayerGR pattern to BGR color using VNG
 | BayerGr2Gray | Convert BayerGR to GRAY
 | BayerGr2Rgb | Convert BayerGR color to RGB color
 | BayerGr2RgbEa | Convert BayerGR to RGB (Edge-Aware Demosaicing)
 | BayerGr2RgbVng | Convert BayerGR pattern to RGB color using VNG
 | BayerRg2Bgr | Convert BayerRG color to BGR color
 | BayerRg2BgrEa | Convert BayerRG to BGR (Edge-Aware Demosaicing)
 | BayerRg2BgrVng | Convert BayerRG pattern to BGR color using VNG
 | BayerRg2Gray | Convert BayerRG to GRAY
 | BayerRg2Rgb | Convert BayerRG color to RGB color
 | BayerRg2RgbEa | Convert BayerRG to RGB (Edge-Aware Demosaicing)
 | BayerRg2RgbVng | Convert BayerRG pattern to RGB color using VNG
 | Bgr2Bgr555 | Convert BGR color to BGR555 color
 | Bgr2Bgr565 | Convert BGR color to BGR565 color
 | Bgr2Bgra | Convert BGR color to BGRA color
 | Bgr2Gray | Convert BGR color to GRAY color
 | Bgr2Hls | Convert BGR color to HLS color
 | Bgr2HlsFull | Convert BGR to HLS
 | Bgr2Hsv | Convert BGR color to HSV color
 | Bgr2HsvFull | Convert BGR to HSV
 | Bgr2Lab | Convert BGR color to Lab color
 | Bgr2Luv | Convert BGR color to Luv color
 | Bgr2Rgb | Convert BGR color to RGB color
 | Bgr2Rgba | Convert BGR color to RGBA color
 | Bgr2Xyz | Convert BGR color to XYZ color
 | Bgr2YCrCb | Convert BGR color to YCrCb color
 | Bgr2Yuv | Convert BGR color to YUV
 | Bgr2YuvI420 | Convert BGR to YUV_I420
 | Bgr2YuvIyuv | Convert BGR to YUV_IYUV
 | Bgr2YuvYv12 | Convert BGR to YUV_YV12
 | Bgr5552Bgr | Convert BGR555 color to BGR color
 | Bgr5552Bgra | Convert BGR555 color to BGRA color
 | Bgr5552Gray | Convert BGR555 color to GRAY color
 | Bgr5552Rgb | Convert BGR555 color to RGB color
 | Bgr5552Rgba | Convert BGR555 color to RGBA color
 | Bgr5652Bgr | Convert BGR565 color to BGR color
 | Bgr5652Bgra | Convert BGR565 color to BGRA color
 | Bgr5652Gray | Convert BGR565 color to GRAY color
 | Bgr5652Rgb | Convert BGR565 color to RGB color
 | Bgr5652Rgba | Convert BGR565 color to RGBA color
 | Bgra2Bgr | Convert BGRA color to BGR color
 | Bgra2Bgr555 | Convert BGRA color to BGR555 color
 | Bgra2Bgr565 | Convert BGRA color to BGR565 color
 | Bgra2Gray | Convert BGRA color to GRAY color
 | Bgra2Rgb | Convert BGRA color to RGB color
 | Bgra2Rgba | Convert BGRA color to RGBA color
 | Bgra2YuvI420 | Convert BGRA to YUV_I420
 | Bgra2YuvIyuv | Convert BGRA to YUV_IYUV
 | Bgra2YuvYv12 | Convert BGRA to YUV_YV12
 | ColorcvtMax | The max number, do not use
 | Gray2Bgr | Convert GRAY color to BGR color
 | Gray2Bgr555 | Convert GRAY color to BGR555 color
 | Gray2Bgr565 | Convert GRAY color to BGR565 color
 | Gray2Bgra | Convert GRAY color to BGRA color
 | Gray2Rgb | Convert GRAY color to RGB color
 | Gray2Rgba | Convert GRAY color to RGBA color
 | Hls2Bgr | Convert HLS color to BGR color
 | Hls2BgrFull | Convert HLS color to BGR color
 | Hls2Rgb | Convert HLS color to RGB color
 | Hls2RgbFull | Convert HLS color to RGB color
 | Hsv2Bgr | Convert HSV color to BGR color
 | Hsv2BgrFull | Convert HSV color to BGR color
 | Hsv2Rgb | Convert HSV color to RGB color
 | Hsv2RgbFull | Convert HSV color to RGB color
 | Lab2Bgr | Convert Lab color to BGR color
 | Lab2Lbgr | Convert Lab color to sBGR color
 | Lab2Lrgb | Convert Lab color to sRGB color
 | Lab2Rgb | Convert Lab color to RGB color
 | Lbgr2Lab | Convert sBGR color to Lab color
 | Lbgr2Luv | Convert sBGR color to Luv color
 | Lrgb2Lab | Convert sRGB color to Lab color
 | Lrgb2Luv | Convert sRGB color to Luv color
 | Luv2Bgr | Convert Luv color to BGR color
 | Luv2Lbgr | Convert Luv color to sBGR color
 | Luv2Lrgb | Convert Luv color to sRGB color
 | Luv2Rgb | Convert Luv color to RGB color
 | MRgba2Rgba | Alpha premultiplication
 | Rgb2Bgr | Convert RGB color to BGR color
 | Rgb2Bgr555 | Convert RGB color to BGR555 color
 | Rgb2Bgr565 | Convert RGB color to BGR565 color
 | Rgb2Bgra | Convert RGB color to BGRA color
 | Rgb2Gray | Convert RGB color to GRAY color
 | Rgb2Hls | Convert RGB color to HLS color
 | Rgb2HlsFull | Convert RGB to HLS
 | Rgb2Hsv | Convert RGB colot to HSV color
 | Rgb2HsvFull | Convert RGB to HSV
 | Rgb2Lab | Convert RGB color to Lab color
 | Rgb2Luv | Convert RGB color to Luv color
 | Rgb2Rgba | Convert RGB color to RGBA color
 | Rgb2Xyz | Convert RGB color to XYZ color
 | Rgb2YCrCb | Convert RGB color to YCrCb color
 | Rgb2Yuv | Convert RGB color to YUV
 | Rgb2YuvI420 | Convert RGB to YUV_I420
 | Rgb2YuvIyuv | Convert RGB to YUV_IYUV
 | Rgb2YuvYv12 | Convert RGB to YUV_YV12
 | Rgba2Bgr | Convert RGBA color to BGR color
 | Rgba2Bgr555 | Convert RGBA color to BGR555 color
 | Rgba2Bgr565 | Convert RGBA color to BGR565 color
 | Rgba2Bgra | Convert RGBA color to BGRA color
 | Rgba2Gray | Convert RGBA color to GRAY color
 | Rgba2MRgba | Alpha premultiplication
 | Rgba2Rgb | Convert RGBA color to RGB color
 | Rgba2YuvI420 | Convert RGBA to YUV_I420
 | Rgba2YuvIyuv | Convert RGBA to YUV_IYUV
 | Rgba2YuvYv12 | Convert RGBA to YUV_YV12
Public field | value__ |
 | Xyz2Bgr | Convert XYZ color to BGR color
 | Xyz2Rgb | Convert XYZ color to RGB color
 | YCrCb2Bgr | Convert YCrCb color to BGR color
 | YCrCb2Rgb | Convert YCrCb color to RGB color
 | Yuv2Bgr | Convert YUV color to BGR
 | Yuv2BgraI420 | Convert YUV (i420) to BGRA
 | Yuv2BgraIyuv | Convert YUV (iYUV) to BGRA
 | Yuv2BgraUynv | Convert YUV (UYNV) to BGRA
 | Yuv2BgraUyvy | Convert YUV (VYUY) to BGRA
 | Yuv2BgraY422 | Convert YUV (Y422) to BGRA
 | Yuv2BgraYunv | Convert YUV (YUNV) to BGRA
 | Yuv2BgraYuy2 | Convert YUV (YUY2) to BGRA
 | Yuv2BgraYuyv | Convert YUV (YUYV) to BGRA
 | Yuv2BgraYv12 | Convert YUV (YV12) to BGRA
 | Yuv2BgraYvyu | Convert YUV (YVYU) to BGRA
 | Yuv2BgrI420 | Convert YUV (i420) to BGR
 | Yuv2BgrIyuv | Convert YUV (iYUV) to BGR
 | Yuv2BgrUynv | Convert YUV (UYNV) to BGR
 | Yuv2BgrUyvy | Convert YUV (UYVY) to BGR
 | Yuv2BgrY422 | Convert YUV (Y422) to BGR
 | Yuv2BgrYunv | Convert YUV (YUNV) to BGR
 | Yuv2BgrYuy2 | Convert YUV (YUY2) to BGR
 | Yuv2BgrYuyv | Convert YUV (YUYV) to BGR
 | Yuv2BgrYv12 | Convert YUV (YV12) to BGR
 | Yuv2BgrYvyu | Convert YUV (YVYU) to BGR
 | Yuv2Gray420 | Convert YUV 420 to Gray
 | Yuv2GrayI420 | Convert YUV (i420) to Gray
 | Yuv2GrayIyuv | Convert YUV (iYUV) to Gray
 | Yuv2GrayNv12 | Convert YUV NV12 to Gray
 | Yuv2GrayNv21 | Convert YUV NV21 to Gray
 | Yuv2GrayUynv | Convert YUV (UYNV) to Gray
 | Yuv2GrayUyvy | Convert YUV (UYVY) to Gray
 | Yuv2GrayY422 | Convert YUV (Y422) to Gray
 | Yuv2GrayYunv | Convert YUV (YUNV) to Gray
 | Yuv2GrayYuy2 | Convert YUV (YUY2) to Gray
 | Yuv2GrayYuyv | Convert YUV (YUYV) to Gray
 | Yuv2GrayYv12 | Convert YUV YV12 to Gray
 | Yuv2GrayYvyu | Convert YUV (YVYU) to Gray
 | Yuv2Rgb | Convert YUV color to RGB
 | Yuv2RgbaI420 | Convert YUV (i420) to RGBA
 | Yuv2RgbaIyuv | Convert YUV (iYUV) to RGBA
 | Yuv2RgbaUynv | Convert YUV (UYNV) to RGBA
 | Yuv2RgbaUyvy | Convert YUV (UYVY) to RGBA
 | Yuv2RgbaY422 | Convert YUV (Y422) to RGBA
 | Yuv2RgbaYunv | Convert YUV (YUNV) to RGBA
 | Yuv2RgbaYuy2 | Convert YUV (YUY2) to RGBA
 | Yuv2RgbaYuyv | Convert YUV (YUYV) to RGBA
 | Yuv2RgbaYv12 | Convert YUV (YV12) to RGBA
 | Yuv2RgbaYvyu | Convert YUV (YVYU) to RGBA
 | Yuv2RgbI420 | Convert YUV (i420) to RGB
 | Yuv2RgbIyuv | Convert YUV (iYUV) to RGB
 | Yuv2RgbUynv | Convert YUV (UYNY) to RGB
 | Yuv2RgbUyvy | Convert YUV (UYVY) to RGB
 | Yuv2RgbY422 | Convert YUV (Y422) to RGB
 | Yuv2RgbYunv | Convert YUV (YUNV) to RGB
 | Yuv2RgbYuy2 | Convert YUV (YUY2) to RGB
 | Yuv2RgbYuyv | Convert YUV (YUYV) to RGB
 | Yuv2RgbYv12 | Convert YUV (YV12) to RGB
 | Yuv2RgbYvyu | Convert YUV (YVYU) to RGB
 | Yuv420I2Bgr | Convert YUV420i to BGR
 | Yuv420I2Bgra | Convert YUV420i to BGRA
 | Yuv420I2Rgb | Convert YUV420i to RGB
 | Yuv420I2Rgba | Convert YUV320i to RGBA
 | Yuv420P2Bgr | Convert YUV (420p) to BGR
 | Yuv420P2Bgra | Convert YUV (420p) to BGRA
 | Yuv420P2Gray | Convert YUV (420p) to Gray
 | Yuv420P2Rgb | Convert YUV (420p) to RGB
 | Yuv420P2Rgba | Convert YUV (420p) to RGBA
 | Yuv420Sp2Bgr | Convert YUV320sp to BGR
 | Yuv420Sp2Bgra | Convert YUV420sp to BGRA
 | Yuv420Sp2Gray | Convert YUV (420sp) to Gray
 | Yuv420Sp2Rgb | Convert YUV420sp to RGB
 | Yuv420Sp2Rgba | Convert YUV420sp to RGBA
Top
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerBg2Bgr Field

ColorConversionBayerBg2Bgr Field

Convert BayerBG color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerBg2Bgr = 46
Public Const BayerBg2Bgr As ColorConversion = 46
public:
literal ColorConversion^ BayerBg2Bgr = 46
static val mutable BayerBg2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerBg2BgrEa Field

ColorConversionBayerBg2BgrEa Field

Convert BayerBG to BGR (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerBg2BgrEa = 135
Public Const BayerBg2BgrEa As ColorConversion = 135
public:
literal ColorConversion^ BayerBg2BgrEa = 135
static val mutable BayerBg2BgrEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerBg2BgrVng Field

ColorConversionBayerBg2BgrVng Field

Convert BayerBG pattern to BGR color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerBg2BgrVng = 62
Public Const BayerBg2BgrVng As ColorConversion = 62
public:
literal ColorConversion^ BayerBg2BgrVng = 62
static val mutable BayerBg2BgrVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerBg2Gray Field

ColorConversionBayerBg2Gray Field

Convert BayerBG to GRAY

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerBg2Gray = 86
Public Const BayerBg2Gray As ColorConversion = 86
public:
literal ColorConversion^ BayerBg2Gray = 86
static val mutable BayerBg2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerBg2Rgb Field

ColorConversionBayerBg2Rgb Field

Convert BayerBG color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerBg2Rgb = 48
Public Const BayerBg2Rgb As ColorConversion = 48
public:
literal ColorConversion^ BayerBg2Rgb = 48
static val mutable BayerBg2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerBg2RgbEa Field

ColorConversionBayerBg2RgbEa Field

Convert BayerBG to RGB (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerBg2RgbEa = 137
Public Const BayerBg2RgbEa As ColorConversion = 137
public:
literal ColorConversion^ BayerBg2RgbEa = 137
static val mutable BayerBg2RgbEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerBg2RgbVng Field

ColorConversionBayerBg2RgbVng Field

Convert BayerBG pattern to RGB color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerBg2RgbVng = 64
Public Const BayerBg2RgbVng As ColorConversion = 64
public:
literal ColorConversion^ BayerBg2RgbVng = 64
static val mutable BayerBg2RgbVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGb2Bgr Field

ColorConversionBayerGb2Bgr Field

Convert BayerGB color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGb2Bgr = 47
Public Const BayerGb2Bgr As ColorConversion = 47
public:
literal ColorConversion^ BayerGb2Bgr = 47
static val mutable BayerGb2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGb2BgrEa Field

ColorConversionBayerGb2BgrEa Field

Convert BayerGB to BGR (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGb2BgrEa = 136
Public Const BayerGb2BgrEa As ColorConversion = 136
public:
literal ColorConversion^ BayerGb2BgrEa = 136
static val mutable BayerGb2BgrEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGb2BgrVng Field

ColorConversionBayerGb2BgrVng Field

Convert BayerGB pattern to BGR color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGb2BgrVng = 63
Public Const BayerGb2BgrVng As ColorConversion = 63
public:
literal ColorConversion^ BayerGb2BgrVng = 63
static val mutable BayerGb2BgrVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGb2Gray Field

ColorConversionBayerGb2Gray Field

Convert BayerGB to GRAY

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGb2Gray = 87
Public Const BayerGb2Gray As ColorConversion = 87
public:
literal ColorConversion^ BayerGb2Gray = 87
static val mutable BayerGb2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGb2Rgb Field

ColorConversionBayerGb2Rgb Field

Convert BayerRG color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGb2Rgb = 49
Public Const BayerGb2Rgb As ColorConversion = 49
public:
literal ColorConversion^ BayerGb2Rgb = 49
static val mutable BayerGb2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGb2RgbEa Field

ColorConversionBayerGb2RgbEa Field

Convert BayerGB to RGB (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGb2RgbEa = 138
Public Const BayerGb2RgbEa As ColorConversion = 138
public:
literal ColorConversion^ BayerGb2RgbEa = 138
static val mutable BayerGb2RgbEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGb2RgbVng Field

ColorConversionBayerGb2RgbVng Field

Convert BayerGB pattern to RGB color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGb2RgbVng = 65
Public Const BayerGb2RgbVng As ColorConversion = 65
public:
literal ColorConversion^ BayerGb2RgbVng = 65
static val mutable BayerGb2RgbVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGr2Bgr Field

ColorConversionBayerGr2Bgr Field

Convert BayerGR color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGr2Bgr = 49
Public Const BayerGr2Bgr As ColorConversion = 49
public:
literal ColorConversion^ BayerGr2Bgr = 49
static val mutable BayerGr2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGr2BgrEa Field

ColorConversionBayerGr2BgrEa Field

Convert BayerGR to BGR (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGr2BgrEa = 138
Public Const BayerGr2BgrEa As ColorConversion = 138
public:
literal ColorConversion^ BayerGr2BgrEa = 138
static val mutable BayerGr2BgrEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGr2BgrVng Field

ColorConversionBayerGr2BgrVng Field

Convert BayerGR pattern to BGR color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGr2BgrVng = 65
Public Const BayerGr2BgrVng As ColorConversion = 65
public:
literal ColorConversion^ BayerGr2BgrVng = 65
static val mutable BayerGr2BgrVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGr2Gray Field

ColorConversionBayerGr2Gray Field

Convert BayerGR to GRAY

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGr2Gray = 89
Public Const BayerGr2Gray As ColorConversion = 89
public:
literal ColorConversion^ BayerGr2Gray = 89
static val mutable BayerGr2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGr2Rgb Field

ColorConversionBayerGr2Rgb Field

Convert BayerGR color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGr2Rgb = 47
Public Const BayerGr2Rgb As ColorConversion = 47
public:
literal ColorConversion^ BayerGr2Rgb = 47
static val mutable BayerGr2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGr2RgbEa Field

ColorConversionBayerGr2RgbEa Field

Convert BayerGR to RGB (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGr2RgbEa = 136
Public Const BayerGr2RgbEa As ColorConversion = 136
public:
literal ColorConversion^ BayerGr2RgbEa = 136
static val mutable BayerGr2RgbEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerGr2RgbVng Field

ColorConversionBayerGr2RgbVng Field

Convert BayerGR pattern to RGB color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerGr2RgbVng = 63
Public Const BayerGr2RgbVng As ColorConversion = 63
public:
literal ColorConversion^ BayerGr2RgbVng = 63
static val mutable BayerGr2RgbVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerRg2Bgr Field

ColorConversionBayerRg2Bgr Field

Convert BayerRG color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerRg2Bgr = 48
Public Const BayerRg2Bgr As ColorConversion = 48
public:
literal ColorConversion^ BayerRg2Bgr = 48
static val mutable BayerRg2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerRg2BgrEa Field

ColorConversionBayerRg2BgrEa Field

Convert BayerRG to BGR (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerRg2BgrEa = 137
Public Const BayerRg2BgrEa As ColorConversion = 137
public:
literal ColorConversion^ BayerRg2BgrEa = 137
static val mutable BayerRg2BgrEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerRg2BgrVng Field

ColorConversionBayerRg2BgrVng Field

Convert BayerRG pattern to BGR color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerRg2BgrVng = 64
Public Const BayerRg2BgrVng As ColorConversion = 64
public:
literal ColorConversion^ BayerRg2BgrVng = 64
static val mutable BayerRg2BgrVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerRg2Gray Field

ColorConversionBayerRg2Gray Field

Convert BayerRG to GRAY

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerRg2Gray = 88
Public Const BayerRg2Gray As ColorConversion = 88
public:
literal ColorConversion^ BayerRg2Gray = 88
static val mutable BayerRg2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerRg2Rgb Field

ColorConversionBayerRg2Rgb Field

Convert BayerRG color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerRg2Rgb = 46
Public Const BayerRg2Rgb As ColorConversion = 46
public:
literal ColorConversion^ BayerRg2Rgb = 46
static val mutable BayerRg2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerRg2RgbEa Field

ColorConversionBayerRg2RgbEa Field

Convert BayerRG to RGB (Edge-Aware Demosaicing)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerRg2RgbEa = 135
Public Const BayerRg2RgbEa As ColorConversion = 135
public:
literal ColorConversion^ BayerRg2RgbEa = 135
static val mutable BayerRg2RgbEa: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.BayerRg2RgbVng Field

ColorConversionBayerRg2RgbVng Field

Convert BayerRG pattern to RGB color using VNG

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion BayerRg2RgbVng = 62
Public Const BayerRg2RgbVng As ColorConversion = 62
public:
literal ColorConversion^ BayerRg2RgbVng = 62
static val mutable BayerRg2RgbVng: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Bgr555 Field

ColorConversionBgr2Bgr555 Field

Convert BGR color to BGR555 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Bgr555 = 22
Public Const Bgr2Bgr555 As ColorConversion = 22
public:
literal ColorConversion^ Bgr2Bgr555 = 22
static val mutable Bgr2Bgr555: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Bgr565 Field

ColorConversionBgr2Bgr565 Field

Convert BGR color to BGR565 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Bgr565 = 12
Public Const Bgr2Bgr565 As ColorConversion = 12
public:
literal ColorConversion^ Bgr2Bgr565 = 12
static val mutable Bgr2Bgr565: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Bgra Field

ColorConversionBgr2Bgra Field

Convert BGR color to BGRA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Bgra = 0
Public Const Bgr2Bgra As ColorConversion = 0
public:
literal ColorConversion^ Bgr2Bgra = 0
static val mutable Bgr2Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Gray Field

ColorConversionBgr2Gray Field

Convert BGR color to GRAY color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Gray = 6
Public Const Bgr2Gray As ColorConversion = 6
public:
literal ColorConversion^ Bgr2Gray = 6
static val mutable Bgr2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Hls Field

ColorConversionBgr2Hls Field

Convert BGR color to HLS color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Hls = 52
Public Const Bgr2Hls As ColorConversion = 52
public:
literal ColorConversion^ Bgr2Hls = 52
static val mutable Bgr2Hls: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2HlsFull Field

ColorConversionBgr2HlsFull Field

Convert BGR to HLS

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2HlsFull = 68
Public Const Bgr2HlsFull As ColorConversion = 68
public:
literal ColorConversion^ Bgr2HlsFull = 68
static val mutable Bgr2HlsFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Hsv Field

ColorConversionBgr2Hsv Field

Convert BGR color to HSV color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Hsv = 40
Public Const Bgr2Hsv As ColorConversion = 40
public:
literal ColorConversion^ Bgr2Hsv = 40
static val mutable Bgr2Hsv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2HsvFull Field

ColorConversionBgr2HsvFull Field

Convert BGR to HSV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2HsvFull = 66
Public Const Bgr2HsvFull As ColorConversion = 66
public:
literal ColorConversion^ Bgr2HsvFull = 66
static val mutable Bgr2HsvFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Lab Field

ColorConversionBgr2Lab Field

Convert BGR color to Lab color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Lab = 44
Public Const Bgr2Lab As ColorConversion = 44
public:
literal ColorConversion^ Bgr2Lab = 44
static val mutable Bgr2Lab: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Luv Field

ColorConversionBgr2Luv Field

Convert BGR color to Luv color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Luv = 50
Public Const Bgr2Luv As ColorConversion = 50
public:
literal ColorConversion^ Bgr2Luv = 50
static val mutable Bgr2Luv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Rgb Field

ColorConversionBgr2Rgb Field

Convert BGR color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Rgb = 4
Public Const Bgr2Rgb As ColorConversion = 4
public:
literal ColorConversion^ Bgr2Rgb = 4
static val mutable Bgr2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Rgba Field

ColorConversionBgr2Rgba Field

Convert BGR color to RGBA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Rgba = 2
Public Const Bgr2Rgba As ColorConversion = 2
public:
literal ColorConversion^ Bgr2Rgba = 2
static val mutable Bgr2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Xyz Field

ColorConversionBgr2Xyz Field

Convert BGR color to XYZ color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Xyz = 32
Public Const Bgr2Xyz As ColorConversion = 32
public:
literal ColorConversion^ Bgr2Xyz = 32
static val mutable Bgr2Xyz: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2YCrCb Field

ColorConversionBgr2YCrCb Field

Convert BGR color to YCrCb color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2YCrCb = 36
Public Const Bgr2YCrCb As ColorConversion = 36
public:
literal ColorConversion^ Bgr2YCrCb = 36
static val mutable Bgr2YCrCb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2Yuv Field

ColorConversionBgr2Yuv Field

Convert BGR color to YUV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2Yuv = 82
Public Const Bgr2Yuv As ColorConversion = 82
public:
literal ColorConversion^ Bgr2Yuv = 82
static val mutable Bgr2Yuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2YuvI420 Field

ColorConversionBgr2YuvI420 Field

Convert BGR to YUV_I420

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2YuvI420 = 128
Public Const Bgr2YuvI420 As ColorConversion = 128
public:
literal ColorConversion^ Bgr2YuvI420 = 128
static val mutable Bgr2YuvI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2YuvIyuv Field

ColorConversionBgr2YuvIyuv Field

Convert BGR to YUV_IYUV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2YuvIyuv = 128
Public Const Bgr2YuvIyuv As ColorConversion = 128
public:
literal ColorConversion^ Bgr2YuvIyuv = 128
static val mutable Bgr2YuvIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr2YuvYv12 Field

ColorConversionBgr2YuvYv12 Field

Convert BGR to YUV_YV12

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr2YuvYv12 = 132
Public Const Bgr2YuvYv12 As ColorConversion = 132
public:
literal ColorConversion^ Bgr2YuvYv12 = 132
static val mutable Bgr2YuvYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5552Bgr Field

ColorConversionBgr5552Bgr Field

Convert BGR555 color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5552Bgr = 24
Public Const Bgr5552Bgr As ColorConversion = 24
public:
literal ColorConversion^ Bgr5552Bgr = 24
static val mutable Bgr5552Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5552Bgra Field

ColorConversionBgr5552Bgra Field

Convert BGR555 color to BGRA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5552Bgra = 28
Public Const Bgr5552Bgra As ColorConversion = 28
public:
literal ColorConversion^ Bgr5552Bgra = 28
static val mutable Bgr5552Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5552Gray Field

ColorConversionBgr5552Gray Field

Convert BGR555 color to GRAY color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5552Gray = 31
Public Const Bgr5552Gray As ColorConversion = 31
public:
literal ColorConversion^ Bgr5552Gray = 31
static val mutable Bgr5552Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5552Rgb Field

ColorConversionBgr5552Rgb Field

Convert BGR555 color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5552Rgb = 25
Public Const Bgr5552Rgb As ColorConversion = 25
public:
literal ColorConversion^ Bgr5552Rgb = 25
static val mutable Bgr5552Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5552Rgba Field

ColorConversionBgr5552Rgba Field

Convert BGR555 color to RGBA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5552Rgba = 29
Public Const Bgr5552Rgba As ColorConversion = 29
public:
literal ColorConversion^ Bgr5552Rgba = 29
static val mutable Bgr5552Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5652Bgr Field

ColorConversionBgr5652Bgr Field

Convert BGR565 color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5652Bgr = 14
Public Const Bgr5652Bgr As ColorConversion = 14
public:
literal ColorConversion^ Bgr5652Bgr = 14
static val mutable Bgr5652Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5652Bgra Field

ColorConversionBgr5652Bgra Field

Convert BGR565 color to BGRA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5652Bgra = 18
Public Const Bgr5652Bgra As ColorConversion = 18
public:
literal ColorConversion^ Bgr5652Bgra = 18
static val mutable Bgr5652Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5652Gray Field

ColorConversionBgr5652Gray Field

Convert BGR565 color to GRAY color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5652Gray = 21
Public Const Bgr5652Gray As ColorConversion = 21
public:
literal ColorConversion^ Bgr5652Gray = 21
static val mutable Bgr5652Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5652Rgb Field

ColorConversionBgr5652Rgb Field

Convert BGR565 color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5652Rgb = 15
Public Const Bgr5652Rgb As ColorConversion = 15
public:
literal ColorConversion^ Bgr5652Rgb = 15
static val mutable Bgr5652Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgr5652Rgba Field

ColorConversionBgr5652Rgba Field

Convert BGR565 color to RGBA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgr5652Rgba = 19
Public Const Bgr5652Rgba As ColorConversion = 19
public:
literal ColorConversion^ Bgr5652Rgba = 19
static val mutable Bgr5652Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2Bgr Field

ColorConversionBgra2Bgr Field

Convert BGRA color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2Bgr = 1
Public Const Bgra2Bgr As ColorConversion = 1
public:
literal ColorConversion^ Bgra2Bgr = 1
static val mutable Bgra2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2Bgr555 Field

ColorConversionBgra2Bgr555 Field

Convert BGRA color to BGR555 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2Bgr555 = 26
Public Const Bgra2Bgr555 As ColorConversion = 26
public:
literal ColorConversion^ Bgra2Bgr555 = 26
static val mutable Bgra2Bgr555: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2Bgr565 Field

ColorConversionBgra2Bgr565 Field

Convert BGRA color to BGR565 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2Bgr565 = 16
Public Const Bgra2Bgr565 As ColorConversion = 16
public:
literal ColorConversion^ Bgra2Bgr565 = 16
static val mutable Bgra2Bgr565: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2Gray Field

ColorConversionBgra2Gray Field

Convert BGRA color to GRAY color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2Gray = 10
Public Const Bgra2Gray As ColorConversion = 10
public:
literal ColorConversion^ Bgra2Gray = 10
static val mutable Bgra2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2Rgb Field

ColorConversionBgra2Rgb Field

Convert BGRA color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2Rgb = 3
Public Const Bgra2Rgb As ColorConversion = 3
public:
literal ColorConversion^ Bgra2Rgb = 3
static val mutable Bgra2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2Rgba Field

ColorConversionBgra2Rgba Field

Convert BGRA color to RGBA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2Rgba = 5
Public Const Bgra2Rgba As ColorConversion = 5
public:
literal ColorConversion^ Bgra2Rgba = 5
static val mutable Bgra2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2YuvI420 Field

ColorConversionBgra2YuvI420 Field

Convert BGRA to YUV_I420

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2YuvI420 = 130
Public Const Bgra2YuvI420 As ColorConversion = 130
public:
literal ColorConversion^ Bgra2YuvI420 = 130
static val mutable Bgra2YuvI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2YuvIyuv Field

ColorConversionBgra2YuvIyuv Field

Convert BGRA to YUV_IYUV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2YuvIyuv = 130
Public Const Bgra2YuvIyuv As ColorConversion = 130
public:
literal ColorConversion^ Bgra2YuvIyuv = 130
static val mutable Bgra2YuvIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Bgra2YuvYv12 Field

ColorConversionBgra2YuvYv12 Field

Convert BGRA to YUV_YV12

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Bgra2YuvYv12 = 134
Public Const Bgra2YuvYv12 As ColorConversion = 134
public:
literal ColorConversion^ Bgra2YuvYv12 = 134
static val mutable Bgra2YuvYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.ColorcvtMax Field

ColorConversionColorcvtMax Field

The max number, do not use

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion ColorcvtMax = 139
Public Const ColorcvtMax As ColorConversion = 139
public:
literal ColorConversion^ ColorcvtMax = 139
static val mutable ColorcvtMax: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Gray2Bgr Field

ColorConversionGray2Bgr Field

Convert GRAY color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Gray2Bgr = 8
Public Const Gray2Bgr As ColorConversion = 8
public:
literal ColorConversion^ Gray2Bgr = 8
static val mutable Gray2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Gray2Bgr555 Field

ColorConversionGray2Bgr555 Field

Convert GRAY color to BGR555 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Gray2Bgr555 = 30
Public Const Gray2Bgr555 As ColorConversion = 30
public:
literal ColorConversion^ Gray2Bgr555 = 30
static val mutable Gray2Bgr555: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Gray2Bgr565 Field

ColorConversionGray2Bgr565 Field

Convert GRAY color to BGR565 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Gray2Bgr565 = 20
Public Const Gray2Bgr565 As ColorConversion = 20
public:
literal ColorConversion^ Gray2Bgr565 = 20
static val mutable Gray2Bgr565: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Gray2Bgra Field

ColorConversionGray2Bgra Field

Convert GRAY color to BGRA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Gray2Bgra = 9
Public Const Gray2Bgra As ColorConversion = 9
public:
literal ColorConversion^ Gray2Bgra = 9
static val mutable Gray2Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Gray2Rgb Field

ColorConversionGray2Rgb Field

Convert GRAY color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Gray2Rgb = 8
Public Const Gray2Rgb As ColorConversion = 8
public:
literal ColorConversion^ Gray2Rgb = 8
static val mutable Gray2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Gray2Rgba Field

ColorConversionGray2Rgba Field

Convert GRAY color to RGBA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Gray2Rgba = 9
Public Const Gray2Rgba As ColorConversion = 9
public:
literal ColorConversion^ Gray2Rgba = 9
static val mutable Gray2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hls2Bgr Field

ColorConversionHls2Bgr Field

Convert HLS color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hls2Bgr = 60
Public Const Hls2Bgr As ColorConversion = 60
public:
literal ColorConversion^ Hls2Bgr = 60
static val mutable Hls2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hls2BgrFull Field

ColorConversionHls2BgrFull Field

Convert HLS color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hls2BgrFull = 72
Public Const Hls2BgrFull As ColorConversion = 72
public:
literal ColorConversion^ Hls2BgrFull = 72
static val mutable Hls2BgrFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hls2Rgb Field

ColorConversionHls2Rgb Field

Convert HLS color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hls2Rgb = 61
Public Const Hls2Rgb As ColorConversion = 61
public:
literal ColorConversion^ Hls2Rgb = 61
static val mutable Hls2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hls2RgbFull Field

ColorConversionHls2RgbFull Field

Convert HLS color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hls2RgbFull = 73
Public Const Hls2RgbFull As ColorConversion = 73
public:
literal ColorConversion^ Hls2RgbFull = 73
static val mutable Hls2RgbFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hsv2Bgr Field

ColorConversionHsv2Bgr Field

Convert HSV color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hsv2Bgr = 54
Public Const Hsv2Bgr As ColorConversion = 54
public:
literal ColorConversion^ Hsv2Bgr = 54
static val mutable Hsv2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hsv2BgrFull Field

ColorConversionHsv2BgrFull Field

Convert HSV color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hsv2BgrFull = 70
Public Const Hsv2BgrFull As ColorConversion = 70
public:
literal ColorConversion^ Hsv2BgrFull = 70
static val mutable Hsv2BgrFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hsv2Rgb Field

ColorConversionHsv2Rgb Field

Convert HSV color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hsv2Rgb = 55
Public Const Hsv2Rgb As ColorConversion = 55
public:
literal ColorConversion^ Hsv2Rgb = 55
static val mutable Hsv2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Hsv2RgbFull Field

ColorConversionHsv2RgbFull Field

Convert HSV color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Hsv2RgbFull = 71
Public Const Hsv2RgbFull As ColorConversion = 71
public:
literal ColorConversion^ Hsv2RgbFull = 71
static val mutable Hsv2RgbFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lab2Bgr Field

ColorConversionLab2Bgr Field

Convert Lab color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lab2Bgr = 56
Public Const Lab2Bgr As ColorConversion = 56
public:
literal ColorConversion^ Lab2Bgr = 56
static val mutable Lab2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lab2Lbgr Field

ColorConversionLab2Lbgr Field

Convert Lab color to sBGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lab2Lbgr = 78
Public Const Lab2Lbgr As ColorConversion = 78
public:
literal ColorConversion^ Lab2Lbgr = 78
static val mutable Lab2Lbgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lab2Lrgb Field

ColorConversionLab2Lrgb Field

Convert Lab color to sRGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lab2Lrgb = 79
Public Const Lab2Lrgb As ColorConversion = 79
public:
literal ColorConversion^ Lab2Lrgb = 79
static val mutable Lab2Lrgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lab2Rgb Field

ColorConversionLab2Rgb Field

Convert Lab color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lab2Rgb = 57
Public Const Lab2Rgb As ColorConversion = 57
public:
literal ColorConversion^ Lab2Rgb = 57
static val mutable Lab2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lbgr2Lab Field

ColorConversionLbgr2Lab Field

Convert sBGR color to Lab color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lbgr2Lab = 74
Public Const Lbgr2Lab As ColorConversion = 74
public:
literal ColorConversion^ Lbgr2Lab = 74
static val mutable Lbgr2Lab: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lbgr2Luv Field

ColorConversionLbgr2Luv Field

Convert sBGR color to Luv color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lbgr2Luv = 76
Public Const Lbgr2Luv As ColorConversion = 76
public:
literal ColorConversion^ Lbgr2Luv = 76
static val mutable Lbgr2Luv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lrgb2Lab Field

ColorConversionLrgb2Lab Field

Convert sRGB color to Lab color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lrgb2Lab = 75
Public Const Lrgb2Lab As ColorConversion = 75
public:
literal ColorConversion^ Lrgb2Lab = 75
static val mutable Lrgb2Lab: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Lrgb2Luv Field

ColorConversionLrgb2Luv Field

Convert sRGB color to Luv color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Lrgb2Luv = 77
Public Const Lrgb2Luv As ColorConversion = 77
public:
literal ColorConversion^ Lrgb2Luv = 77
static val mutable Lrgb2Luv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Luv2Bgr Field

ColorConversionLuv2Bgr Field

Convert Luv color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Luv2Bgr = 58
Public Const Luv2Bgr As ColorConversion = 58
public:
literal ColorConversion^ Luv2Bgr = 58
static val mutable Luv2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Luv2Lbgr Field

ColorConversionLuv2Lbgr Field

Convert Luv color to sBGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Luv2Lbgr = 80
Public Const Luv2Lbgr As ColorConversion = 80
public:
literal ColorConversion^ Luv2Lbgr = 80
static val mutable Luv2Lbgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Luv2Lrgb Field

ColorConversionLuv2Lrgb Field

Convert Luv color to sRGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Luv2Lrgb = 81
Public Const Luv2Lrgb As ColorConversion = 81
public:
literal ColorConversion^ Luv2Lrgb = 81
static val mutable Luv2Lrgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Luv2Rgb Field

ColorConversionLuv2Rgb Field

Convert Luv color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Luv2Rgb = 59
Public Const Luv2Rgb As ColorConversion = 59
public:
literal ColorConversion^ Luv2Rgb = 59
static val mutable Luv2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.MRgba2Rgba Field

ColorConversionMRgba2Rgba Field

Alpha premultiplication

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion MRgba2Rgba = 126
Public Const MRgba2Rgba As ColorConversion = 126
public:
literal ColorConversion^ MRgba2Rgba = 126
static val mutable MRgba2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Bgr Field

ColorConversionRgb2Bgr Field

Convert RGB color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Bgr = 4
Public Const Rgb2Bgr As ColorConversion = 4
public:
literal ColorConversion^ Rgb2Bgr = 4
static val mutable Rgb2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Bgr555 Field

ColorConversionRgb2Bgr555 Field

Convert RGB color to BGR555 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Bgr555 = 23
Public Const Rgb2Bgr555 As ColorConversion = 23
public:
literal ColorConversion^ Rgb2Bgr555 = 23
static val mutable Rgb2Bgr555: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Bgr565 Field

ColorConversionRgb2Bgr565 Field

Convert RGB color to BGR565 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Bgr565 = 13
Public Const Rgb2Bgr565 As ColorConversion = 13
public:
literal ColorConversion^ Rgb2Bgr565 = 13
static val mutable Rgb2Bgr565: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Bgra Field

ColorConversionRgb2Bgra Field

Convert RGB color to BGRA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Bgra = 2
Public Const Rgb2Bgra As ColorConversion = 2
public:
literal ColorConversion^ Rgb2Bgra = 2
static val mutable Rgb2Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Gray Field

ColorConversionRgb2Gray Field

Convert RGB color to GRAY color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Gray = 7
Public Const Rgb2Gray As ColorConversion = 7
public:
literal ColorConversion^ Rgb2Gray = 7
static val mutable Rgb2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Hls Field

ColorConversionRgb2Hls Field

Convert RGB color to HLS color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Hls = 53
Public Const Rgb2Hls As ColorConversion = 53
public:
literal ColorConversion^ Rgb2Hls = 53
static val mutable Rgb2Hls: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2HlsFull Field

ColorConversionRgb2HlsFull Field

Convert RGB to HLS

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2HlsFull = 69
Public Const Rgb2HlsFull As ColorConversion = 69
public:
literal ColorConversion^ Rgb2HlsFull = 69
static val mutable Rgb2HlsFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Hsv Field

ColorConversionRgb2Hsv Field

Convert RGB colot to HSV color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Hsv = 41
Public Const Rgb2Hsv As ColorConversion = 41
public:
literal ColorConversion^ Rgb2Hsv = 41
static val mutable Rgb2Hsv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2HsvFull Field

ColorConversionRgb2HsvFull Field

Convert RGB to HSV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2HsvFull = 67
Public Const Rgb2HsvFull As ColorConversion = 67
public:
literal ColorConversion^ Rgb2HsvFull = 67
static val mutable Rgb2HsvFull: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Lab Field

ColorConversionRgb2Lab Field

Convert RGB color to Lab color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Lab = 45
Public Const Rgb2Lab As ColorConversion = 45
public:
literal ColorConversion^ Rgb2Lab = 45
static val mutable Rgb2Lab: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Luv Field

ColorConversionRgb2Luv Field

Convert RGB color to Luv color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Luv = 51
Public Const Rgb2Luv As ColorConversion = 51
public:
literal ColorConversion^ Rgb2Luv = 51
static val mutable Rgb2Luv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Rgba Field

ColorConversionRgb2Rgba Field

Convert RGB color to RGBA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Rgba = 0
Public Const Rgb2Rgba As ColorConversion = 0
public:
literal ColorConversion^ Rgb2Rgba = 0
static val mutable Rgb2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Xyz Field

ColorConversionRgb2Xyz Field

Convert RGB color to XYZ color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Xyz = 33
Public Const Rgb2Xyz As ColorConversion = 33
public:
literal ColorConversion^ Rgb2Xyz = 33
static val mutable Rgb2Xyz: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2YCrCb Field

ColorConversionRgb2YCrCb Field

Convert RGB color to YCrCb color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2YCrCb = 37
Public Const Rgb2YCrCb As ColorConversion = 37
public:
literal ColorConversion^ Rgb2YCrCb = 37
static val mutable Rgb2YCrCb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2Yuv Field

ColorConversionRgb2Yuv Field

Convert RGB color to YUV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2Yuv = 83
Public Const Rgb2Yuv As ColorConversion = 83
public:
literal ColorConversion^ Rgb2Yuv = 83
static val mutable Rgb2Yuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2YuvI420 Field

ColorConversionRgb2YuvI420 Field

Convert RGB to YUV_I420

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2YuvI420 = 127
Public Const Rgb2YuvI420 As ColorConversion = 127
public:
literal ColorConversion^ Rgb2YuvI420 = 127
static val mutable Rgb2YuvI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2YuvIyuv Field

ColorConversionRgb2YuvIyuv Field

Convert RGB to YUV_IYUV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2YuvIyuv = 127
Public Const Rgb2YuvIyuv As ColorConversion = 127
public:
literal ColorConversion^ Rgb2YuvIyuv = 127
static val mutable Rgb2YuvIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgb2YuvYv12 Field

ColorConversionRgb2YuvYv12 Field

Convert RGB to YUV_YV12

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgb2YuvYv12 = 131
Public Const Rgb2YuvYv12 As ColorConversion = 131
public:
literal ColorConversion^ Rgb2YuvYv12 = 131
static val mutable Rgb2YuvYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2Bgr Field

ColorConversionRgba2Bgr Field

Convert RGBA color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2Bgr = 3
Public Const Rgba2Bgr As ColorConversion = 3
public:
literal ColorConversion^ Rgba2Bgr = 3
static val mutable Rgba2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2Bgr555 Field

ColorConversionRgba2Bgr555 Field

Convert RGBA color to BGR555 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2Bgr555 = 27
Public Const Rgba2Bgr555 As ColorConversion = 27
public:
literal ColorConversion^ Rgba2Bgr555 = 27
static val mutable Rgba2Bgr555: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2Bgr565 Field

ColorConversionRgba2Bgr565 Field

Convert RGBA color to BGR565 color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2Bgr565 = 17
Public Const Rgba2Bgr565 As ColorConversion = 17
public:
literal ColorConversion^ Rgba2Bgr565 = 17
static val mutable Rgba2Bgr565: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2Bgra Field

ColorConversionRgba2Bgra Field

Convert RGBA color to BGRA color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2Bgra = 5
Public Const Rgba2Bgra As ColorConversion = 5
public:
literal ColorConversion^ Rgba2Bgra = 5
static val mutable Rgba2Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2Gray Field

ColorConversionRgba2Gray Field

Convert RGBA color to GRAY color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2Gray = 11
Public Const Rgba2Gray As ColorConversion = 11
public:
literal ColorConversion^ Rgba2Gray = 11
static val mutable Rgba2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2MRgba Field

ColorConversionRgba2MRgba Field

Alpha premultiplication

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2MRgba = 125
Public Const Rgba2MRgba As ColorConversion = 125
public:
literal ColorConversion^ Rgba2MRgba = 125
static val mutable Rgba2MRgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2Rgb Field

ColorConversionRgba2Rgb Field

Convert RGBA color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2Rgb = 1
Public Const Rgba2Rgb As ColorConversion = 1
public:
literal ColorConversion^ Rgba2Rgb = 1
static val mutable Rgba2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2YuvI420 Field

ColorConversionRgba2YuvI420 Field

Convert RGBA to YUV_I420

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2YuvI420 = 129
Public Const Rgba2YuvI420 As ColorConversion = 129
public:
literal ColorConversion^ Rgba2YuvI420 = 129
static val mutable Rgba2YuvI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2YuvIyuv Field

ColorConversionRgba2YuvIyuv Field

Convert RGBA to YUV_IYUV

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2YuvIyuv = 129
Public Const Rgba2YuvIyuv As ColorConversion = 129
public:
literal ColorConversion^ Rgba2YuvIyuv = 129
static val mutable Rgba2YuvIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Rgba2YuvYv12 Field

ColorConversionRgba2YuvYv12 Field

Convert RGBA to YUV_YV12

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Rgba2YuvYv12 = 133
Public Const Rgba2YuvYv12 As ColorConversion = 133
public:
literal ColorConversion^ Rgba2YuvYv12 = 133
static val mutable Rgba2YuvYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.value__ Field

ColorConversionvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ColorConversion.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Xyz2Bgr Field

ColorConversionXyz2Bgr Field

Convert XYZ color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Xyz2Bgr = 34
Public Const Xyz2Bgr As ColorConversion = 34
public:
literal ColorConversion^ Xyz2Bgr = 34
static val mutable Xyz2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Xyz2Rgb Field

ColorConversionXyz2Rgb Field

Convert XYZ color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Xyz2Rgb = 35
Public Const Xyz2Rgb As ColorConversion = 35
public:
literal ColorConversion^ Xyz2Rgb = 35
static val mutable Xyz2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.YCrCb2Bgr Field

ColorConversionYCrCb2Bgr Field

Convert YCrCb color to BGR color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion YCrCb2Bgr = 38
Public Const YCrCb2Bgr As ColorConversion = 38
public:
literal ColorConversion^ YCrCb2Bgr = 38
static val mutable YCrCb2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.YCrCb2Rgb Field

ColorConversionYCrCb2Rgb Field

Convert YCrCb color to RGB color

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion YCrCb2Rgb = 39
Public Const YCrCb2Rgb As ColorConversion = 39
public:
literal ColorConversion^ YCrCb2Rgb = 39
static val mutable YCrCb2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2Bgr Field

ColorConversionYuv2Bgr Field

Convert YUV color to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2Bgr = 84
Public Const Yuv2Bgr As ColorConversion = 84
public:
literal ColorConversion^ Yuv2Bgr = 84
static val mutable Yuv2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraI420 Field

ColorConversionYuv2BgraI420 Field

Convert YUV (i420) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraI420 = 105
Public Const Yuv2BgraI420 As ColorConversion = 105
public:
literal ColorConversion^ Yuv2BgraI420 = 105
static val mutable Yuv2BgraI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraIyuv Field

ColorConversionYuv2BgraIyuv Field

Convert YUV (iYUV) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraIyuv = 105
Public Const Yuv2BgraIyuv As ColorConversion = 105
public:
literal ColorConversion^ Yuv2BgraIyuv = 105
static val mutable Yuv2BgraIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraUynv Field

ColorConversionYuv2BgraUynv Field

Convert YUV (UYNV) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraUynv = 112
Public Const Yuv2BgraUynv As ColorConversion = 112
public:
literal ColorConversion^ Yuv2BgraUynv = 112
static val mutable Yuv2BgraUynv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraUyvy Field

ColorConversionYuv2BgraUyvy Field

Convert YUV (VYUY) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraUyvy = 112
Public Const Yuv2BgraUyvy As ColorConversion = 112
public:
literal ColorConversion^ Yuv2BgraUyvy = 112
static val mutable Yuv2BgraUyvy: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraY422 Field

ColorConversionYuv2BgraY422 Field

Convert YUV (Y422) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraY422 = 112
Public Const Yuv2BgraY422 As ColorConversion = 112
public:
literal ColorConversion^ Yuv2BgraY422 = 112
static val mutable Yuv2BgraY422: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraYunv Field

ColorConversionYuv2BgraYunv Field

Convert YUV (YUNV) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraYunv = 120
Public Const Yuv2BgraYunv As ColorConversion = 120
public:
literal ColorConversion^ Yuv2BgraYunv = 120
static val mutable Yuv2BgraYunv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraYuy2 Field

ColorConversionYuv2BgraYuy2 Field

Convert YUV (YUY2) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraYuy2 = 120
Public Const Yuv2BgraYuy2 As ColorConversion = 120
public:
literal ColorConversion^ Yuv2BgraYuy2 = 120
static val mutable Yuv2BgraYuy2: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraYuyv Field

ColorConversionYuv2BgraYuyv Field

Convert YUV (YUYV) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraYuyv = 120
Public Const Yuv2BgraYuyv As ColorConversion = 120
public:
literal ColorConversion^ Yuv2BgraYuyv = 120
static val mutable Yuv2BgraYuyv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraYv12 Field

ColorConversionYuv2BgraYv12 Field

Convert YUV (YV12) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraYv12 = 103
Public Const Yuv2BgraYv12 As ColorConversion = 103
public:
literal ColorConversion^ Yuv2BgraYv12 = 103
static val mutable Yuv2BgraYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgraYvyu Field

ColorConversionYuv2BgraYvyu Field

Convert YUV (YVYU) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgraYvyu = 122
Public Const Yuv2BgraYvyu As ColorConversion = 122
public:
literal ColorConversion^ Yuv2BgraYvyu = 122
static val mutable Yuv2BgraYvyu: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrI420 Field

ColorConversionYuv2BgrI420 Field

Convert YUV (i420) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrI420 = 101
Public Const Yuv2BgrI420 As ColorConversion = 101
public:
literal ColorConversion^ Yuv2BgrI420 = 101
static val mutable Yuv2BgrI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrIyuv Field

ColorConversionYuv2BgrIyuv Field

Convert YUV (iYUV) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrIyuv = 101
Public Const Yuv2BgrIyuv As ColorConversion = 101
public:
literal ColorConversion^ Yuv2BgrIyuv = 101
static val mutable Yuv2BgrIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrUynv Field

ColorConversionYuv2BgrUynv Field

Convert YUV (UYNV) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrUynv = 108
Public Const Yuv2BgrUynv As ColorConversion = 108
public:
literal ColorConversion^ Yuv2BgrUynv = 108
static val mutable Yuv2BgrUynv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrUyvy Field

ColorConversionYuv2BgrUyvy Field

Convert YUV (UYVY) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrUyvy = 108
Public Const Yuv2BgrUyvy As ColorConversion = 108
public:
literal ColorConversion^ Yuv2BgrUyvy = 108
static val mutable Yuv2BgrUyvy: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrY422 Field

ColorConversionYuv2BgrY422 Field

Convert YUV (Y422) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrY422 = 108
Public Const Yuv2BgrY422 As ColorConversion = 108
public:
literal ColorConversion^ Yuv2BgrY422 = 108
static val mutable Yuv2BgrY422: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrYunv Field

ColorConversionYuv2BgrYunv Field

Convert YUV (YUNV) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrYunv = 116
Public Const Yuv2BgrYunv As ColorConversion = 116
public:
literal ColorConversion^ Yuv2BgrYunv = 116
static val mutable Yuv2BgrYunv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrYuy2 Field

ColorConversionYuv2BgrYuy2 Field

Convert YUV (YUY2) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrYuy2 = 116
Public Const Yuv2BgrYuy2 As ColorConversion = 116
public:
literal ColorConversion^ Yuv2BgrYuy2 = 116
static val mutable Yuv2BgrYuy2: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrYuyv Field

ColorConversionYuv2BgrYuyv Field

Convert YUV (YUYV) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrYuyv = 116
Public Const Yuv2BgrYuyv As ColorConversion = 116
public:
literal ColorConversion^ Yuv2BgrYuyv = 116
static val mutable Yuv2BgrYuyv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrYv12 Field

ColorConversionYuv2BgrYv12 Field

Convert YUV (YV12) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrYv12 = 99
Public Const Yuv2BgrYv12 As ColorConversion = 99
public:
literal ColorConversion^ Yuv2BgrYv12 = 99
static val mutable Yuv2BgrYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2BgrYvyu Field

ColorConversionYuv2BgrYvyu Field

Convert YUV (YVYU) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2BgrYvyu = 118
Public Const Yuv2BgrYvyu As ColorConversion = 118
public:
literal ColorConversion^ Yuv2BgrYvyu = 118
static val mutable Yuv2BgrYvyu: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2Gray420 Field

ColorConversionYuv2Gray420 Field

Convert YUV 420 to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2Gray420 = 106
Public Const Yuv2Gray420 As ColorConversion = 106
public:
literal ColorConversion^ Yuv2Gray420 = 106
static val mutable Yuv2Gray420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayI420 Field

ColorConversionYuv2GrayI420 Field

Convert YUV (i420) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayI420 = 106
Public Const Yuv2GrayI420 As ColorConversion = 106
public:
literal ColorConversion^ Yuv2GrayI420 = 106
static val mutable Yuv2GrayI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayIyuv Field

ColorConversionYuv2GrayIyuv Field

Convert YUV (iYUV) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayIyuv = 106
Public Const Yuv2GrayIyuv As ColorConversion = 106
public:
literal ColorConversion^ Yuv2GrayIyuv = 106
static val mutable Yuv2GrayIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayNv12 Field

ColorConversionYuv2GrayNv12 Field

Convert YUV NV12 to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayNv12 = 106
Public Const Yuv2GrayNv12 As ColorConversion = 106
public:
literal ColorConversion^ Yuv2GrayNv12 = 106
static val mutable Yuv2GrayNv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayNv21 Field

ColorConversionYuv2GrayNv21 Field

Convert YUV NV21 to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayNv21 = 106
Public Const Yuv2GrayNv21 As ColorConversion = 106
public:
literal ColorConversion^ Yuv2GrayNv21 = 106
static val mutable Yuv2GrayNv21: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayUynv Field

ColorConversionYuv2GrayUynv Field

Convert YUV (UYNV) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayUynv = 123
Public Const Yuv2GrayUynv As ColorConversion = 123
public:
literal ColorConversion^ Yuv2GrayUynv = 123
static val mutable Yuv2GrayUynv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayUyvy Field

ColorConversionYuv2GrayUyvy Field

Convert YUV (UYVY) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayUyvy = 123
Public Const Yuv2GrayUyvy As ColorConversion = 123
public:
literal ColorConversion^ Yuv2GrayUyvy = 123
static val mutable Yuv2GrayUyvy: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayY422 Field

ColorConversionYuv2GrayY422 Field

Convert YUV (Y422) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayY422 = 123
Public Const Yuv2GrayY422 As ColorConversion = 123
public:
literal ColorConversion^ Yuv2GrayY422 = 123
static val mutable Yuv2GrayY422: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayYunv Field

ColorConversionYuv2GrayYunv Field

Convert YUV (YUNV) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayYunv = 124
Public Const Yuv2GrayYunv As ColorConversion = 124
public:
literal ColorConversion^ Yuv2GrayYunv = 124
static val mutable Yuv2GrayYunv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayYuy2 Field

ColorConversionYuv2GrayYuy2 Field

Convert YUV (YUY2) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayYuy2 = 124
Public Const Yuv2GrayYuy2 As ColorConversion = 124
public:
literal ColorConversion^ Yuv2GrayYuy2 = 124
static val mutable Yuv2GrayYuy2: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayYuyv Field

ColorConversionYuv2GrayYuyv Field

Convert YUV (YUYV) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayYuyv = 124
Public Const Yuv2GrayYuyv As ColorConversion = 124
public:
literal ColorConversion^ Yuv2GrayYuyv = 124
static val mutable Yuv2GrayYuyv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayYv12 Field

ColorConversionYuv2GrayYv12 Field

Convert YUV YV12 to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayYv12 = 106
Public Const Yuv2GrayYv12 As ColorConversion = 106
public:
literal ColorConversion^ Yuv2GrayYv12 = 106
static val mutable Yuv2GrayYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2GrayYvyu Field

ColorConversionYuv2GrayYvyu Field

Convert YUV (YVYU) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2GrayYvyu = 124
Public Const Yuv2GrayYvyu As ColorConversion = 124
public:
literal ColorConversion^ Yuv2GrayYvyu = 124
static val mutable Yuv2GrayYvyu: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2Rgb Field

ColorConversionYuv2Rgb Field

Convert YUV color to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2Rgb = 85
Public Const Yuv2Rgb As ColorConversion = 85
public:
literal ColorConversion^ Yuv2Rgb = 85
static val mutable Yuv2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaI420 Field

ColorConversionYuv2RgbaI420 Field

Convert YUV (i420) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaI420 = 104
Public Const Yuv2RgbaI420 As ColorConversion = 104
public:
literal ColorConversion^ Yuv2RgbaI420 = 104
static val mutable Yuv2RgbaI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaIyuv Field

ColorConversionYuv2RgbaIyuv Field

Convert YUV (iYUV) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaIyuv = 104
Public Const Yuv2RgbaIyuv As ColorConversion = 104
public:
literal ColorConversion^ Yuv2RgbaIyuv = 104
static val mutable Yuv2RgbaIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaUynv Field

ColorConversionYuv2RgbaUynv Field

Convert YUV (UYNV) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaUynv = 111
Public Const Yuv2RgbaUynv As ColorConversion = 111
public:
literal ColorConversion^ Yuv2RgbaUynv = 111
static val mutable Yuv2RgbaUynv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaUyvy Field

ColorConversionYuv2RgbaUyvy Field

Convert YUV (UYVY) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaUyvy = 111
Public Const Yuv2RgbaUyvy As ColorConversion = 111
public:
literal ColorConversion^ Yuv2RgbaUyvy = 111
static val mutable Yuv2RgbaUyvy: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaY422 Field

ColorConversionYuv2RgbaY422 Field

Convert YUV (Y422) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaY422 = 111
Public Const Yuv2RgbaY422 As ColorConversion = 111
public:
literal ColorConversion^ Yuv2RgbaY422 = 111
static val mutable Yuv2RgbaY422: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaYunv Field

ColorConversionYuv2RgbaYunv Field

Convert YUV (YUNV) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaYunv = 119
Public Const Yuv2RgbaYunv As ColorConversion = 119
public:
literal ColorConversion^ Yuv2RgbaYunv = 119
static val mutable Yuv2RgbaYunv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaYuy2 Field

ColorConversionYuv2RgbaYuy2 Field

Convert YUV (YUY2) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaYuy2 = 119
Public Const Yuv2RgbaYuy2 As ColorConversion = 119
public:
literal ColorConversion^ Yuv2RgbaYuy2 = 119
static val mutable Yuv2RgbaYuy2: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaYuyv Field

ColorConversionYuv2RgbaYuyv Field

Convert YUV (YUYV) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaYuyv = 119
Public Const Yuv2RgbaYuyv As ColorConversion = 119
public:
literal ColorConversion^ Yuv2RgbaYuyv = 119
static val mutable Yuv2RgbaYuyv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaYv12 Field

ColorConversionYuv2RgbaYv12 Field

Convert YUV (YV12) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaYv12 = 102
Public Const Yuv2RgbaYv12 As ColorConversion = 102
public:
literal ColorConversion^ Yuv2RgbaYv12 = 102
static val mutable Yuv2RgbaYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbaYvyu Field

ColorConversionYuv2RgbaYvyu Field

Convert YUV (YVYU) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbaYvyu = 121
Public Const Yuv2RgbaYvyu As ColorConversion = 121
public:
literal ColorConversion^ Yuv2RgbaYvyu = 121
static val mutable Yuv2RgbaYvyu: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbI420 Field

ColorConversionYuv2RgbI420 Field

Convert YUV (i420) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbI420 = 100
Public Const Yuv2RgbI420 As ColorConversion = 100
public:
literal ColorConversion^ Yuv2RgbI420 = 100
static val mutable Yuv2RgbI420: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbIyuv Field

ColorConversionYuv2RgbIyuv Field

Convert YUV (iYUV) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbIyuv = 100
Public Const Yuv2RgbIyuv As ColorConversion = 100
public:
literal ColorConversion^ Yuv2RgbIyuv = 100
static val mutable Yuv2RgbIyuv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbUynv Field

ColorConversionYuv2RgbUynv Field

Convert YUV (UYNY) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbUynv = 107
Public Const Yuv2RgbUynv As ColorConversion = 107
public:
literal ColorConversion^ Yuv2RgbUynv = 107
static val mutable Yuv2RgbUynv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbUyvy Field

ColorConversionYuv2RgbUyvy Field

Convert YUV (UYVY) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbUyvy = 107
Public Const Yuv2RgbUyvy As ColorConversion = 107
public:
literal ColorConversion^ Yuv2RgbUyvy = 107
static val mutable Yuv2RgbUyvy: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbY422 Field

ColorConversionYuv2RgbY422 Field

Convert YUV (Y422) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbY422 = 107
Public Const Yuv2RgbY422 As ColorConversion = 107
public:
literal ColorConversion^ Yuv2RgbY422 = 107
static val mutable Yuv2RgbY422: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbYunv Field

ColorConversionYuv2RgbYunv Field

Convert YUV (YUNV) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbYunv = 115
Public Const Yuv2RgbYunv As ColorConversion = 115
public:
literal ColorConversion^ Yuv2RgbYunv = 115
static val mutable Yuv2RgbYunv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbYuy2 Field

ColorConversionYuv2RgbYuy2 Field

Convert YUV (YUY2) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbYuy2 = 115
Public Const Yuv2RgbYuy2 As ColorConversion = 115
public:
literal ColorConversion^ Yuv2RgbYuy2 = 115
static val mutable Yuv2RgbYuy2: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbYuyv Field

ColorConversionYuv2RgbYuyv Field

Convert YUV (YUYV) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbYuyv = 115
Public Const Yuv2RgbYuyv As ColorConversion = 115
public:
literal ColorConversion^ Yuv2RgbYuyv = 115
static val mutable Yuv2RgbYuyv: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbYv12 Field

ColorConversionYuv2RgbYv12 Field

Convert YUV (YV12) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbYv12 = 98
Public Const Yuv2RgbYv12 As ColorConversion = 98
public:
literal ColorConversion^ Yuv2RgbYv12 = 98
static val mutable Yuv2RgbYv12: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv2RgbYvyu Field

ColorConversionYuv2RgbYvyu Field

Convert YUV (YVYU) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv2RgbYvyu = 117
Public Const Yuv2RgbYvyu As ColorConversion = 117
public:
literal ColorConversion^ Yuv2RgbYvyu = 117
static val mutable Yuv2RgbYvyu: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420I2Bgr Field

ColorConversionYuv420I2Bgr Field

Convert YUV420i to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420I2Bgr = 91
Public Const Yuv420I2Bgr As ColorConversion = 91
public:
literal ColorConversion^ Yuv420I2Bgr = 91
static val mutable Yuv420I2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420I2Bgra Field

ColorConversionYuv420I2Bgra Field

Convert YUV420i to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420I2Bgra = 95
Public Const Yuv420I2Bgra As ColorConversion = 95
public:
literal ColorConversion^ Yuv420I2Bgra = 95
static val mutable Yuv420I2Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420I2Rgb Field

ColorConversionYuv420I2Rgb Field

Convert YUV420i to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420I2Rgb = 90
Public Const Yuv420I2Rgb As ColorConversion = 90
public:
literal ColorConversion^ Yuv420I2Rgb = 90
static val mutable Yuv420I2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420I2Rgba Field

ColorConversionYuv420I2Rgba Field

Convert YUV320i to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420I2Rgba = 94
Public Const Yuv420I2Rgba As ColorConversion = 94
public:
literal ColorConversion^ Yuv420I2Rgba = 94
static val mutable Yuv420I2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420P2Bgr Field

ColorConversionYuv420P2Bgr Field

Convert YUV (420p) to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420P2Bgr = 99
Public Const Yuv420P2Bgr As ColorConversion = 99
public:
literal ColorConversion^ Yuv420P2Bgr = 99
static val mutable Yuv420P2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420P2Bgra Field

ColorConversionYuv420P2Bgra Field

Convert YUV (420p) to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420P2Bgra = 103
Public Const Yuv420P2Bgra As ColorConversion = 103
public:
literal ColorConversion^ Yuv420P2Bgra = 103
static val mutable Yuv420P2Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420P2Gray Field

ColorConversionYuv420P2Gray Field

Convert YUV (420p) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420P2Gray = 106
Public Const Yuv420P2Gray As ColorConversion = 106
public:
literal ColorConversion^ Yuv420P2Gray = 106
static val mutable Yuv420P2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420P2Rgb Field

ColorConversionYuv420P2Rgb Field

Convert YUV (420p) to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420P2Rgb = 98
Public Const Yuv420P2Rgb As ColorConversion = 98
public:
literal ColorConversion^ Yuv420P2Rgb = 98
static val mutable Yuv420P2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420P2Rgba Field

ColorConversionYuv420P2Rgba Field

Convert YUV (420p) to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420P2Rgba = 102
Public Const Yuv420P2Rgba As ColorConversion = 102
public:
literal ColorConversion^ Yuv420P2Rgba = 102
static val mutable Yuv420P2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420Sp2Bgr Field

ColorConversionYuv420Sp2Bgr Field

Convert YUV320sp to BGR

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420Sp2Bgr = 93
Public Const Yuv420Sp2Bgr As ColorConversion = 93
public:
literal ColorConversion^ Yuv420Sp2Bgr = 93
static val mutable Yuv420Sp2Bgr: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420Sp2Bgra Field

ColorConversionYuv420Sp2Bgra Field

Convert YUV420sp to BGRA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420Sp2Bgra = 97
Public Const Yuv420Sp2Bgra As ColorConversion = 97
public:
literal ColorConversion^ Yuv420Sp2Bgra = 97
static val mutable Yuv420Sp2Bgra: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420Sp2Gray Field

ColorConversionYuv420Sp2Gray Field

Convert YUV (420sp) to Gray

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420Sp2Gray = 106
Public Const Yuv420Sp2Gray As ColorConversion = 106
public:
literal ColorConversion^ Yuv420Sp2Gray = 106
static val mutable Yuv420Sp2Gray: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420Sp2Rgb Field

ColorConversionYuv420Sp2Rgb Field

Convert YUV420sp to RGB

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420Sp2Rgb = 92
Public Const Yuv420Sp2Rgb As ColorConversion = 92
public:
literal ColorConversion^ Yuv420Sp2Rgb = 92
static val mutable Yuv420Sp2Rgb: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorConversion.Yuv420Sp2Rgba Field

ColorConversionYuv420Sp2Rgba Field

Convert YUV420sp to RGBA

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorConversion Yuv420Sp2Rgba = 96
Public Const Yuv420Sp2Rgba As ColorConversion = 96
public:
literal ColorConversion^ Yuv420Sp2Rgba = 96
static val mutable Yuv420Sp2Rgba: ColorConversion

Field Value

Type: ColorConversion
See Also

Reference

ColorConversion Class
Emgu.CV.CvEnum Namespace


ColorMapType Class

The type of color map
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumColorMapType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ColorMapType : Enum
Public NotInheritable Class ColorMapType
    Inherits Enum
public ref class ColorMapType sealed : public Enum
[<SealedAttribute>]
type ColorMapType =
    class
        inherit Enum
    end

The ColorMapType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Autumn | Autumn
 | Bone | Bone
 | Cividis | Cividis
 | Cool | Cool
 | Hot | Hot
 | Hsv | Hsv
 | Inferno | Inferno
 | Jet | Jet
 | Magma | Magma
 | Ocean | Ocean
 | Parula | Parula
 | Pink | Pink
 | Plasma | Plasma
 | Rainbow | Rainbow
 | Spring | Spring
 | Summer | Summer
 | Turbo | Turbo
 | Twilight | Twilight
 | TwilightShifted | TwilightShifted
Public field | value__ |
 | Viridis | Viridis
 | Winter | Winter
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ColorMapType Methods

The ColorMapType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType Fields

The ColorMapType type exposes the following members.

Fields
 | Name | Description
 | Autumn | Autumn
 | Bone | Bone
 | Cividis | Cividis
 | Cool | Cool
 | Hot | Hot
 | Hsv | Hsv
 | Inferno | Inferno
 | Jet | Jet
 | Magma | Magma
 | Ocean | Ocean
 | Parula | Parula
 | Pink | Pink
 | Plasma | Plasma
 | Rainbow | Rainbow
 | Spring | Spring
 | Summer | Summer
 | Turbo | Turbo
 | Twilight | Twilight
 | TwilightShifted | TwilightShifted
Public field | value__ |
 | Viridis | Viridis
 | Winter | Winter
Top
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Autumn Field

ColorMapTypeAutumn Field

Autumn

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Autumn = 0
Public Const Autumn As ColorMapType = 0
public:
literal ColorMapType^ Autumn = 0
static val mutable Autumn: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Bone Field

ColorMapTypeBone Field

Bone

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Bone = 1
Public Const Bone As ColorMapType = 1
public:
literal ColorMapType^ Bone = 1
static val mutable Bone: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Cividis Field

ColorMapTypeCividis Field

Cividis

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Cividis = 17
Public Const Cividis As ColorMapType = 17
public:
literal ColorMapType^ Cividis = 17
static val mutable Cividis: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Cool Field

ColorMapTypeCool Field

Cool

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Cool = 8
Public Const Cool As ColorMapType = 8
public:
literal ColorMapType^ Cool = 8
static val mutable Cool: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Hot Field

ColorMapTypeHot Field

Hot

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Hot = 11
Public Const Hot As ColorMapType = 11
public:
literal ColorMapType^ Hot = 11
static val mutable Hot: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Hsv Field

ColorMapTypeHsv Field

Hsv

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Hsv = 9
Public Const Hsv As ColorMapType = 9
public:
literal ColorMapType^ Hsv = 9
static val mutable Hsv: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Inferno Field

ColorMapTypeInferno Field

Inferno

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Inferno = 14
Public Const Inferno As ColorMapType = 14
public:
literal ColorMapType^ Inferno = 14
static val mutable Inferno: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Jet Field

ColorMapTypeJet Field

Jet

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Jet = 2
Public Const Jet As ColorMapType = 2
public:
literal ColorMapType^ Jet = 2
static val mutable Jet: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Magma Field

ColorMapTypeMagma Field

Magma

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Magma = 13
Public Const Magma As ColorMapType = 13
public:
literal ColorMapType^ Magma = 13
static val mutable Magma: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Ocean Field

ColorMapTypeOcean Field

Ocean

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Ocean = 5
Public Const Ocean As ColorMapType = 5
public:
literal ColorMapType^ Ocean = 5
static val mutable Ocean: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Parula Field

ColorMapTypeParula Field

Parula

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Parula = 12
Public Const Parula As ColorMapType = 12
public:
literal ColorMapType^ Parula = 12
static val mutable Parula: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Pink Field

ColorMapTypePink Field

Pink

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Pink = 10
Public Const Pink As ColorMapType = 10
public:
literal ColorMapType^ Pink = 10
static val mutable Pink: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Plasma Field

ColorMapTypePlasma Field

Plasma

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Plasma = 15
Public Const Plasma As ColorMapType = 15
public:
literal ColorMapType^ Plasma = 15
static val mutable Plasma: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Rainbow Field

ColorMapTypeRainbow Field

Rainbow

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Rainbow = 4
Public Const Rainbow As ColorMapType = 4
public:
literal ColorMapType^ Rainbow = 4
static val mutable Rainbow: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Spring Field

ColorMapTypeSpring Field

Spring

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Spring = 7
Public Const Spring As ColorMapType = 7
public:
literal ColorMapType^ Spring = 7
static val mutable Spring: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Summer Field

ColorMapTypeSummer Field

Summer

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Summer = 6
Public Const Summer As ColorMapType = 6
public:
literal ColorMapType^ Summer = 6
static val mutable Summer: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Turbo Field

ColorMapTypeTurbo Field

Turbo

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Turbo = 20
Public Const Turbo As ColorMapType = 20
public:
literal ColorMapType^ Turbo = 20
static val mutable Turbo: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Twilight Field

ColorMapTypeTwilight Field

Twilight

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Twilight = 18
Public Const Twilight As ColorMapType = 18
public:
literal ColorMapType^ Twilight = 18
static val mutable Twilight: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.TwilightShifted Field

ColorMapTypeTwilightShifted Field

TwilightShifted

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType TwilightShifted = 19
Public Const TwilightShifted As ColorMapType = 19
public:
literal ColorMapType^ TwilightShifted = 19
static val mutable TwilightShifted: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.value__ Field

ColorMapTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ColorMapType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Viridis Field

ColorMapTypeViridis Field

Viridis

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Viridis = 16
Public Const Viridis As ColorMapType = 16
public:
literal ColorMapType^ Viridis = 16
static val mutable Viridis: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ColorMapType.Winter Field

ColorMapTypeWinter Field

Winter

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ColorMapType Winter = 3
Public Const Winter As ColorMapType = 3
public:
literal ColorMapType^ Winter = 3
static val mutable Winter: ColorMapType

Field Value

Type: ColorMapType
See Also

Reference

ColorMapType Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes Class

Connected components algorithm output formats
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumConnectedComponentsTypes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectedComponentsTypes : Enum
Public NotInheritable Class ConnectedComponentsTypes
    Inherits Enum
public ref class ConnectedComponentsTypes sealed : public Enum
[<SealedAttribute>]
type ConnectedComponentsTypes =
    class
        inherit Enum
    end

The ConnectedComponentsTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Area | The total area (in pixels) of the connected component.
 | Height | The vertical size of the bounding box.
 | Left | The leftmost (x) coordinate which is the inclusive start of the bounding box in the horizontal direction.
 | Max | Max
 | Top | The topmost (y) coordinate which is the inclusive start of the bounding box in the vertical direction.
Public field | value__ |
 | Width | The horizontal size of the bounding box.
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes Methods

The ConnectedComponentsTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes Fields

The ConnectedComponentsTypes type exposes the following members.

Fields
 | Name | Description
 | Area | The total area (in pixels) of the connected component.
 | Height | The vertical size of the bounding box.
 | Left | The leftmost (x) coordinate which is the inclusive start of the bounding box in the horizontal direction.
 | Max | Max
 | Top | The topmost (y) coordinate which is the inclusive start of the bounding box in the vertical direction.
Public field | value__ |
 | Width | The horizontal size of the bounding box.
Top
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes.Area Field

ConnectedComponentsTypesArea Field

The total area (in pixels) of the connected component.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ConnectedComponentsTypes Area = 4
Public Const Area As ConnectedComponentsTypes = 4
public:
literal ConnectedComponentsTypes^ Area = 4
static val mutable Area: ConnectedComponentsTypes

Field Value

Type: ConnectedComponentsTypes
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes.Height Field

ConnectedComponentsTypesHeight Field

The vertical size of the bounding box.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ConnectedComponentsTypes Height = 3
Public Const Height As ConnectedComponentsTypes = 3
public:
literal ConnectedComponentsTypes^ Height = 3
static val mutable Height: ConnectedComponentsTypes

Field Value

Type: ConnectedComponentsTypes
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes.Left Field

ConnectedComponentsTypesLeft Field

The leftmost (x) coordinate which is the inclusive start of the bounding box in the horizontal direction.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ConnectedComponentsTypes Left = 0
Public Const Left As ConnectedComponentsTypes = 0
public:
literal ConnectedComponentsTypes^ Left = 0
static val mutable Left: ConnectedComponentsTypes

Field Value

Type: ConnectedComponentsTypes
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes.Max Field

ConnectedComponentsTypesMax Field

Max

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ConnectedComponentsTypes Max = 5
Public Const Max As ConnectedComponentsTypes = 5
public:
literal ConnectedComponentsTypes^ Max = 5
static val mutable Max: ConnectedComponentsTypes

Field Value

Type: ConnectedComponentsTypes
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes.Top Field

ConnectedComponentsTypesTop Field

The topmost (y) coordinate which is the inclusive start of the bounding box in the vertical direction.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ConnectedComponentsTypes Top = 1
Public Const Top As ConnectedComponentsTypes = 1
public:
literal ConnectedComponentsTypes^ Top = 1
static val mutable Top: ConnectedComponentsTypes

Field Value

Type: ConnectedComponentsTypes
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes.value__ Field

ConnectedComponentsTypesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ConnectedComponentsTypes.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


ConnectedComponentsTypes.Width Field

ConnectedComponentsTypesWidth Field

The horizontal size of the bounding box.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ConnectedComponentsTypes Width = 2
Public Const Width As ConnectedComponentsTypes = 2
public:
literal ConnectedComponentsTypes^ Width = 2
static val mutable Width: ConnectedComponentsTypes

Field Value

Type: ConnectedComponentsTypes
See Also

Reference

ConnectedComponentsTypes Class
Emgu.CV.CvEnum Namespace


Connectivity Class

The type for cvSampleLine
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumConnectivity

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Connectivity : Enum
Public NotInheritable Class Connectivity
    Inherits Enum
public ref class Connectivity sealed : public Enum
[<SealedAttribute>]
type Connectivity =
    class
        inherit Enum
    end

The Connectivity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | EightConnected | 8-connected
 | FourConnected | 4-connected
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


Connectivity Methods

The Connectivity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Connectivity Class
Emgu.CV.CvEnum Namespace


Connectivity Fields

The Connectivity type exposes the following members.

Fields
 | Name | Description
 | EightConnected | 8-connected
 | FourConnected | 4-connected
Public field | value__ |
Top
See Also

Reference

Connectivity Class
Emgu.CV.CvEnum Namespace


Connectivity.EightConnected Field

ConnectivityEightConnected Field

8-connected

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Connectivity EightConnected = 8
Public Const EightConnected As Connectivity = 8
public:
literal Connectivity^ EightConnected = 8
static val mutable EightConnected: Connectivity

Field Value

Type: Connectivity
See Also

Reference

Connectivity Class
Emgu.CV.CvEnum Namespace


Connectivity.FourConnected Field

ConnectivityFourConnected Field

4-connected

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Connectivity FourConnected = 4
Public Const FourConnected As Connectivity = 4
public:
literal Connectivity^ FourConnected = 4
static val mutable FourConnected: Connectivity

Field Value

Type: Connectivity
See Also

Reference

Connectivity Class
Emgu.CV.CvEnum Namespace


Connectivity.value__ Field

Connectivityvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.Connectivity.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Connectivity Class
Emgu.CV.CvEnum Namespace


ContoursMatchType Class

Type used by cvMatchShapes
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumContoursMatchType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ContoursMatchType : Enum
Public NotInheritable Class ContoursMatchType
    Inherits Enum
public ref class ContoursMatchType sealed : public Enum
[<SealedAttribute>]
type ContoursMatchType =
    class
        inherit Enum
    end

The ContoursMatchType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | I1 | I_1(A,B)=sum_{i=1..7} abs(1/m^A_i - 1/m^B_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively
 | I2 | I_2(A,B)=sum_{i=1..7} abs(m^A_i - m^B_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively
 | I3 | I_3(A,B)=sum_{i=1..7} abs(m^A_i - m^B_i)/abs(m^A_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ContoursMatchType Methods

The ContoursMatchType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ContoursMatchType Class
Emgu.CV.CvEnum Namespace


ContoursMatchType Fields

The ContoursMatchType type exposes the following members.

Fields
 | Name | Description
 | I1 | I_1(A,B)=sum_{i=1..7} abs(1/m^A_i - 1/m^B_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively
 | I2 | I_2(A,B)=sum_{i=1..7} abs(m^A_i - m^B_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively
 | I3 | I_3(A,B)=sum_{i=1..7} abs(m^A_i - m^B_i)/abs(m^A_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively
Public field | value__ |
Top
See Also

Reference

ContoursMatchType Class
Emgu.CV.CvEnum Namespace


ContoursMatchType.I1 Field

ContoursMatchTypeI1 Field

I_1(A,B)=sum_{i=1..7} abs(1/m^A_i - 1/m^B_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ContoursMatchType I1 = 1
Public Const I1 As ContoursMatchType = 1
public:
literal ContoursMatchType^ I1 = 1
static val mutable I1: ContoursMatchType

Field Value

Type: ContoursMatchType
See Also

Reference

ContoursMatchType Class
Emgu.CV.CvEnum Namespace


ContoursMatchType.I2 Field

ContoursMatchTypeI2 Field

I_2(A,B)=sum_{i=1..7} abs(m^A_i - m^B_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ContoursMatchType I2 = 2
Public Const I2 As ContoursMatchType = 2
public:
literal ContoursMatchType^ I2 = 2
static val mutable I2: ContoursMatchType

Field Value

Type: ContoursMatchType
See Also

Reference

ContoursMatchType Class
Emgu.CV.CvEnum Namespace


ContoursMatchType.I3 Field

ContoursMatchTypeI3 Field

I_3(A,B)=sum_{i=1..7} abs(m^A_i - m^B_i)/abs(m^A_i) where m^A_i=sign(h^A_i) log(h^A_i), m^B_i=sign(h^B_i) log(h^B_i), h^A_i, h^B_i - Hu moments of A and B, respectively

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ContoursMatchType I3 = 3
Public Const I3 As ContoursMatchType = 3
public:
literal ContoursMatchType^ I3 = 3
static val mutable I3: ContoursMatchType

Field Value

Type: ContoursMatchType
See Also

Reference

ContoursMatchType Class
Emgu.CV.CvEnum Namespace


ContoursMatchType.value__ Field

ContoursMatchTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ContoursMatchType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ContoursMatchType Class
Emgu.CV.CvEnum Namespace


CovarMethod Class

cvCalcCovarMatrix method types
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumCovarMethod

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class CovarMethod : Enum
<FlagsAttribute>
Public NotInheritable Class CovarMethod
    Inherits Enum
[FlagsAttribute]
public ref class CovarMethod sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type CovarMethod =
    class
        inherit Enum
    end

The CovarMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cols | All the input vectors are stored in a single matrix, as its columns
 | Normal | [v1-avg, v2-avg,...] * transpose([v1-avg,v2-avg,...])
 | Rows | All the input vectors are stored in a single matrix, as its rows
 | Scale | Scale the covariance matrix coefficients by number of the vectors
 | Scrambled | Calculates covariation matrix for a set of vectors transpose([v1-avg, v2-avg,...]) * [v1-avg,v2-avg,...]
 | UseAvg | Do not calc average (i.e. mean vector) - use the input vector instead (useful for calculating covariance matrix by parts)
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


CovarMethod Methods

The CovarMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod Fields

The CovarMethod type exposes the following members.

Fields
 | Name | Description
 | Cols | All the input vectors are stored in a single matrix, as its columns
 | Normal | [v1-avg, v2-avg,...] * transpose([v1-avg,v2-avg,...])
 | Rows | All the input vectors are stored in a single matrix, as its rows
 | Scale | Scale the covariance matrix coefficients by number of the vectors
 | Scrambled | Calculates covariation matrix for a set of vectors transpose([v1-avg, v2-avg,...]) * [v1-avg,v2-avg,...]
 | UseAvg | Do not calc average (i.e. mean vector) - use the input vector instead (useful for calculating covariance matrix by parts)
Public field | value__ |
Top
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod.Cols Field

CovarMethodCols Field

All the input vectors are stored in a single matrix, as its columns

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CovarMethod Cols = 16
Public Const Cols As CovarMethod = 16
public:
literal CovarMethod^ Cols = 16
static val mutable Cols: CovarMethod

Field Value

Type: CovarMethod
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod.Normal Field

CovarMethodNormal Field

[v1-avg, v2-avg,...] * transpose([v1-avg,v2-avg,...])

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CovarMethod Normal = 1
Public Const Normal As CovarMethod = 1
public:
literal CovarMethod^ Normal = 1
static val mutable Normal: CovarMethod

Field Value

Type: CovarMethod
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod.Rows Field

CovarMethodRows Field

All the input vectors are stored in a single matrix, as its rows

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CovarMethod Rows = 8
Public Const Rows As CovarMethod = 8
public:
literal CovarMethod^ Rows = 8
static val mutable Rows: CovarMethod

Field Value

Type: CovarMethod
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod.Scale Field

CovarMethodScale Field

Scale the covariance matrix coefficients by number of the vectors

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CovarMethod Scale = 4
Public Const Scale As CovarMethod = 4
public:
literal CovarMethod^ Scale = 4
static val mutable Scale: CovarMethod

Field Value

Type: CovarMethod
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod.Scrambled Field

CovarMethodScrambled Field

Calculates covariation matrix for a set of vectors transpose([v1-avg, v2-avg,...]) * [v1-avg,v2-avg,...]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CovarMethod Scrambled = 0
Public Const Scrambled As CovarMethod = 0
public:
literal CovarMethod^ Scrambled = 0
static val mutable Scrambled: CovarMethod

Field Value

Type: CovarMethod
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod.UseAvg Field

CovarMethodUseAvg Field

Do not calc average (i.e. mean vector) - use the input vector instead (useful for calculating covariance matrix by parts)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CovarMethod UseAvg = 2
Public Const UseAvg As CovarMethod = 2
public:
literal CovarMethod^ UseAvg = 2
static val mutable UseAvg: CovarMethod

Field Value

Type: CovarMethod
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


CovarMethod.value__ Field

CovarMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.CovarMethod.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CovarMethod Class
Emgu.CV.CvEnum Namespace


DctType Class

Flag used for cvDCT
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumDctType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DctType : Enum
Public NotInheritable Class DctType
    Inherits Enum
public ref class DctType sealed : public Enum
[<SealedAttribute>]
type DctType =
    class
        inherit Enum
    end

The DctType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Forward | Do forward 1D or 2D transform. The result is not scaled
 | Inverse | Do inverse 1D or 2D transform. The result is not scaled. CV_DXT_FORWARD and CV_DXT_INVERSE are mutually exclusive, of course
 | Rows | Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


DctType Methods

The DctType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DctType Class
Emgu.CV.CvEnum Namespace


DctType Fields

The DctType type exposes the following members.

Fields
 | Name | Description
 | Forward | Do forward 1D or 2D transform. The result is not scaled
 | Inverse | Do inverse 1D or 2D transform. The result is not scaled. CV_DXT_FORWARD and CV_DXT_INVERSE are mutually exclusive, of course
 | Rows | Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc
Public field | value__ |
Top
See Also

Reference

DctType Class
Emgu.CV.CvEnum Namespace


DctType.Forward Field

DctTypeForward Field

Do forward 1D or 2D transform. The result is not scaled

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DctType Forward = 0
Public Const Forward As DctType = 0
public:
literal DctType^ Forward = 0
static val mutable Forward: DctType

Field Value

Type: DctType
See Also

Reference

DctType Class
Emgu.CV.CvEnum Namespace


DctType.Inverse Field

DctTypeInverse Field

Do inverse 1D or 2D transform. The result is not scaled. CV_DXT_FORWARD and CV_DXT_INVERSE are mutually exclusive, of course

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DctType Inverse = 1
Public Const Inverse As DctType = 1
public:
literal DctType^ Inverse = 1
static val mutable Inverse: DctType

Field Value

Type: DctType
See Also

Reference

DctType Class
Emgu.CV.CvEnum Namespace


DctType.Rows Field

DctTypeRows Field

Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DctType Rows = 4
Public Const Rows As DctType = 4
public:
literal DctType^ Rows = 4
static val mutable Rows: DctType

Field Value

Type: DctType
See Also

Reference

DctType Class
Emgu.CV.CvEnum Namespace


DctType.value__ Field

DctTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.DctType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DctType Class
Emgu.CV.CvEnum Namespace


DecompMethod Class

cvInvert method
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumDecompMethod

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DecompMethod : Enum
Public NotInheritable Class DecompMethod
    Inherits Enum
public ref class DecompMethod sealed : public Enum
[<SealedAttribute>]
type DecompMethod =
    class
        inherit Enum
    end

The DecompMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cholesky | method for a symmetric positively-defined matrix
 | Eig | Eig
 | LU | Gaussian elimination with optimal pivot element chose In case of LU method the function returns src1 determinant (src1 must be square). If it is 0, the matrix is not inverted and src2 is filled with zeros.
 | Normal | Normal
 | QR | QR decomposition
 | Svd | Singular value decomposition (SVD) method In case of SVD methods the function returns the inversed condition number of src1 (ratio of the smallest singular value to the largest singular value) and 0 if src1 is all zeros. The SVD methods calculate a pseudo-inverse matrix if src1 is singular
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


DecompMethod Methods

The DecompMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod Fields

The DecompMethod type exposes the following members.

Fields
 | Name | Description
 | Cholesky | method for a symmetric positively-defined matrix
 | Eig | Eig
 | LU | Gaussian elimination with optimal pivot element chose In case of LU method the function returns src1 determinant (src1 must be square). If it is 0, the matrix is not inverted and src2 is filled with zeros.
 | Normal | Normal
 | QR | QR decomposition
 | Svd | Singular value decomposition (SVD) method In case of SVD methods the function returns the inversed condition number of src1 (ratio of the smallest singular value to the largest singular value) and 0 if src1 is all zeros. The SVD methods calculate a pseudo-inverse matrix if src1 is singular
Public field | value__ |
Top
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod.Cholesky Field

DecompMethodCholesky Field

method for a symmetric positively-defined matrix

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DecompMethod Cholesky = 3
Public Const Cholesky As DecompMethod = 3
public:
literal DecompMethod^ Cholesky = 3
static val mutable Cholesky: DecompMethod

Field Value

Type: DecompMethod
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod.Eig Field

DecompMethodEig Field

Eig

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DecompMethod Eig = 2
Public Const Eig As DecompMethod = 2
public:
literal DecompMethod^ Eig = 2
static val mutable Eig: DecompMethod

Field Value

Type: DecompMethod
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod.LU Field

DecompMethodLU Field

Gaussian elimination with optimal pivot element chose In case of LU method the function returns src1 determinant (src1 must be square). If it is 0, the matrix is not inverted and src2 is filled with zeros.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DecompMethod LU = 0
Public Const LU As DecompMethod = 0
public:
literal DecompMethod^ LU = 0
static val mutable LU: DecompMethod

Field Value

Type: DecompMethod
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod.Normal Field

DecompMethodNormal Field

Normal

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DecompMethod Normal = 16
Public Const Normal As DecompMethod = 16
public:
literal DecompMethod^ Normal = 16
static val mutable Normal: DecompMethod

Field Value

Type: DecompMethod
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod.QR Field

DecompMethodQR Field

QR decomposition

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DecompMethod QR = 4
Public Const QR As DecompMethod = 4
public:
literal DecompMethod^ QR = 4
static val mutable QR: DecompMethod

Field Value

Type: DecompMethod
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod.Svd Field

DecompMethodSvd Field

Singular value decomposition (SVD) method In case of SVD methods the function returns the inversed condition number of src1 (ratio of the smallest singular value to the largest singular value) and 0 if src1 is all zeros. The SVD methods calculate a pseudo-inverse matrix if src1 is singular

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DecompMethod Svd = 1
Public Const Svd As DecompMethod = 1
public:
literal DecompMethod^ Svd = 1
static val mutable Svd: DecompMethod

Field Value

Type: DecompMethod
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DecompMethod.value__ Field

DecompMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.DecompMethod.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DecompMethod Class
Emgu.CV.CvEnum Namespace


DepthType Class

OpenCV depth type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumDepthType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DepthType : Enum
Public NotInheritable Class DepthType
    Inherits Enum
public ref class DepthType sealed : public Enum
[<SealedAttribute>]
type DepthType =
    class
        inherit Enum
    end

The DepthType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cv16S | Int16
 | Cv16U | UInt16
 | Cv32F | float
 | Cv32S | Int32
 | Cv64F | double
 | Cv8S | SByte
 | Cv8U | Byte
 | Default | Default
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


DepthType Methods

The DepthType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType Fields

The DepthType type exposes the following members.

Fields
 | Name | Description
 | Cv16S | Int16
 | Cv16U | UInt16
 | Cv32F | float
 | Cv32S | Int32
 | Cv64F | double
 | Cv8S | SByte
 | Cv8U | Byte
 | Default | Default
Public field | value__ |
Top
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Cv16S Field

DepthTypeCv16S Field

Int16

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Cv16S = 3
Public Const Cv16S As DepthType = 3
public:
literal DepthType^ Cv16S = 3
static val mutable Cv16S: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Cv16U Field

DepthTypeCv16U Field

UInt16

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Cv16U = 2
Public Const Cv16U As DepthType = 2
public:
literal DepthType^ Cv16U = 2
static val mutable Cv16U: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Cv32F Field

DepthTypeCv32F Field

float

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Cv32F = 5
Public Const Cv32F As DepthType = 5
public:
literal DepthType^ Cv32F = 5
static val mutable Cv32F: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Cv32S Field

DepthTypeCv32S Field

Int32

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Cv32S = 4
Public Const Cv32S As DepthType = 4
public:
literal DepthType^ Cv32S = 4
static val mutable Cv32S: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Cv64F Field

DepthTypeCv64F Field

double

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Cv64F = 6
Public Const Cv64F As DepthType = 6
public:
literal DepthType^ Cv64F = 6
static val mutable Cv64F: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Cv8S Field

DepthTypeCv8S Field

SByte

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Cv8S = 1
Public Const Cv8S As DepthType = 1
public:
literal DepthType^ Cv8S = 1
static val mutable Cv8S: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Cv8U Field

DepthTypeCv8U Field

Byte

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Cv8U = 0
Public Const Cv8U As DepthType = 0
public:
literal DepthType^ Cv8U = 0
static val mutable Cv8U: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.Default Field

DepthTypeDefault Field

Default

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DepthType Default = -1
Public Const Default As DepthType = -1
public:
literal DepthType^ Default = -1
static val mutable Default: DepthType

Field Value

Type: DepthType
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DepthType.value__ Field

DepthTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.DepthType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DepthType Class
Emgu.CV.CvEnum Namespace


DistLabelType Class

Distance transform algorithm flags
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumDistLabelType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DistLabelType : Enum
Public NotInheritable Class DistLabelType
    Inherits Enum
public ref class DistLabelType sealed : public Enum
[<SealedAttribute>]
type DistLabelType =
    class
        inherit Enum
    end

The DistLabelType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CComp | Connected component
 | Pixel | The pixel
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


DistLabelType Methods

The DistLabelType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DistLabelType Class
Emgu.CV.CvEnum Namespace


DistLabelType Fields

The DistLabelType type exposes the following members.

Fields
 | Name | Description
 | CComp | Connected component
 | Pixel | The pixel
Public field | value__ |
Top
See Also

Reference

DistLabelType Class
Emgu.CV.CvEnum Namespace


DistLabelType.CComp Field

DistLabelTypeCComp Field

Connected component

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistLabelType CComp = 0
Public Const CComp As DistLabelType = 0
public:
literal DistLabelType^ CComp = 0
static val mutable CComp: DistLabelType

Field Value

Type: DistLabelType
See Also

Reference

DistLabelType Class
Emgu.CV.CvEnum Namespace


DistLabelType.Pixel Field

DistLabelTypePixel Field

The pixel

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistLabelType Pixel = 1
Public Const Pixel As DistLabelType = 1
public:
literal DistLabelType^ Pixel = 1
static val mutable Pixel: DistLabelType

Field Value

Type: DistLabelType
See Also

Reference

DistLabelType Class
Emgu.CV.CvEnum Namespace


DistLabelType.value__ Field

DistLabelTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.DistLabelType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DistLabelType Class
Emgu.CV.CvEnum Namespace


DistType Class

Defines for Distance Transform
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumDistType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DistType : Enum
Public NotInheritable Class DistType
    Inherits Enum
public ref class DistType sealed : public Enum
[<SealedAttribute>]
type DistType =
    class
        inherit Enum
    end

The DistType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | C | distance = max(|x1-x2|,|y1-y2|)
 | Fair | distance = c^2(|x|/c-log(1+|x|/c)), c = 1.3998
 | Huber | distance = |x|<c ? x^2/2 : c(|x|-c/2), c=1.345
 | L1 | distance = |x1-x2| + |y1-y2|
 | L12 | L1-L2 metric: distance = 2(sqrt(1+x*x/2) - 1))
 | L2 | Simple euclidean distance
 | User | User defined distance
Public field | value__ |
 | Welsch | distance = c^2/2(1-exp(-(x/c)^2)), c = 2.9846
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


DistType Methods

The DistType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType Fields

The DistType type exposes the following members.

Fields
 | Name | Description
 | C | distance = max(|x1-x2|,|y1-y2|)
 | Fair | distance = c^2(|x|/c-log(1+|x|/c)), c = 1.3998
 | Huber | distance = |x|<c ? x^2/2 : c(|x|-c/2), c=1.345
 | L1 | distance = |x1-x2| + |y1-y2|
 | L12 | L1-L2 metric: distance = 2(sqrt(1+x*x/2) - 1))
 | L2 | Simple euclidean distance
 | User | User defined distance
Public field | value__ |
 | Welsch | distance = c^2/2(1-exp(-(x/c)^2)), c = 2.9846
Top
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.C Field

DistTypeC Field

distance = max(|x1-x2|,|y1-y2|)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType C = 3
Public Const C As DistType = 3
public:
literal DistType^ C = 3
static val mutable C: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.Fair Field

DistTypeFair Field

distance = c^2(|x|/c-log(1+|x|/c)), c = 1.3998

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Fair = 5
Public Const Fair As DistType = 5
public:
literal DistType^ Fair = 5
static val mutable Fair: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.Huber Field

DistTypeHuber Field

distance = |x|<c ? x^2/2 : c(|x|-c/2), c=1.345

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Huber = 7
Public Const Huber As DistType = 7
public:
literal DistType^ Huber = 7
static val mutable Huber: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.L1 Field

DistTypeL1 Field

distance = |x1-x2| + |y1-y2|

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType L1 = 1
Public Const L1 As DistType = 1
public:
literal DistType^ L1 = 1
static val mutable L1: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.L12 Field

DistTypeL12 Field

L1-L2 metric: distance = 2(sqrt(1+x*x/2) - 1))

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType L12 = 4
Public Const L12 As DistType = 4
public:
literal DistType^ L12 = 4
static val mutable L12: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.L2 Field

DistTypeL2 Field

Simple euclidean distance

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType L2 = 2
Public Const L2 As DistType = 2
public:
literal DistType^ L2 = 2
static val mutable L2: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.User Field

DistTypeUser Field

User defined distance

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType User = -1
Public Const User As DistType = -1
public:
literal DistType^ User = -1
static val mutable User: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.value__ Field

DistTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.DistType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DistType.Welsch Field

DistTypeWelsch Field

distance = c^2/2(1-exp(-(x/c)^2)), c = 2.9846

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Welsch = 6
Public Const Welsch As DistType = 6
public:
literal DistType^ Welsch = 6
static val mutable Welsch: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.CvEnum Namespace


DxtType Class

Flag used for cvDFT
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumDxtType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class DxtType : Enum
<FlagsAttribute>
Public NotInheritable Class DxtType
    Inherits Enum
[FlagsAttribute]
public ref class DxtType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type DxtType =
    class
        inherit Enum
    end

The DxtType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Forward | Do forward 1D or 2D transform. The result is not scaled
 | Inverse | Do inverse 1D or 2D transform. The result is not scaled. CV_DXT_FORWARD and CV_DXT_INVERSE are mutually exclusive, of course
 | InvScale | Inverse and scale
 | Rows | Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc
 | Scale | Scale the result: divide it by the number of array elements. Usually, it is combined with CV_DXT_INVERSE, and one may use a shortcut
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


DxtType Methods

The DxtType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


DxtType Fields

The DxtType type exposes the following members.

Fields
 | Name | Description
 | Forward | Do forward 1D or 2D transform. The result is not scaled
 | Inverse | Do inverse 1D or 2D transform. The result is not scaled. CV_DXT_FORWARD and CV_DXT_INVERSE are mutually exclusive, of course
 | InvScale | Inverse and scale
 | Rows | Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc
 | Scale | Scale the result: divide it by the number of array elements. Usually, it is combined with CV_DXT_INVERSE, and one may use a shortcut
Public field | value__ |
Top
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


DxtType.Forward Field

DxtTypeForward Field

Do forward 1D or 2D transform. The result is not scaled

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DxtType Forward = 0
Public Const Forward As DxtType = 0
public:
literal DxtType^ Forward = 0
static val mutable Forward: DxtType

Field Value

Type: DxtType
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


DxtType.Inverse Field

DxtTypeInverse Field

Do inverse 1D or 2D transform. The result is not scaled. CV_DXT_FORWARD and CV_DXT_INVERSE are mutually exclusive, of course

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DxtType Inverse = 1
Public Const Inverse As DxtType = 1
public:
literal DxtType^ Inverse = 1
static val mutable Inverse: DxtType

Field Value

Type: DxtType
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


DxtType.InvScale Field

DxtTypeInvScale Field

Inverse and scale

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DxtType InvScale = 3
Public Const InvScale As DxtType = 3
public:
literal DxtType^ InvScale = 3
static val mutable InvScale: DxtType

Field Value

Type: DxtType
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


DxtType.Rows Field

DxtTypeRows Field

Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DxtType Rows = 4
Public Const Rows As DxtType = 4
public:
literal DxtType^ Rows = 4
static val mutable Rows: DxtType

Field Value

Type: DxtType
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


DxtType.Scale Field

DxtTypeScale Field

Scale the result: divide it by the number of array elements. Usually, it is combined with CV_DXT_INVERSE, and one may use a shortcut

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DxtType Scale = 2
Public Const Scale As DxtType = 2
public:
literal DxtType^ Scale = 2
static val mutable Scale: DxtType

Field Value

Type: DxtType
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


DxtType.value__ Field

DxtTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.DxtType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DxtType Class
Emgu.CV.CvEnum Namespace


EdgePreservingFilterFlag Class

Edge preserving filter flag
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumEdgePreservingFilterFlag

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class EdgePreservingFilterFlag : Enum
Public NotInheritable Class EdgePreservingFilterFlag
    Inherits Enum
public ref class EdgePreservingFilterFlag sealed : public Enum
[<SealedAttribute>]
type EdgePreservingFilterFlag =
    class
        inherit Enum
    end

The EdgePreservingFilterFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | NormconvFilter | Norm conv filter
 | RecursFilter | Recurs filter
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


EdgePreservingFilterFlag Methods

The EdgePreservingFilterFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

EdgePreservingFilterFlag Class
Emgu.CV.CvEnum Namespace


EdgePreservingFilterFlag Fields

The EdgePreservingFilterFlag type exposes the following members.

Fields
 | Name | Description
 | NormconvFilter | Norm conv filter
 | RecursFilter | Recurs filter
Public field | value__ |
Top
See Also

Reference

EdgePreservingFilterFlag Class
Emgu.CV.CvEnum Namespace


EdgePreservingFilterFlag.NormconvFilter Field

EdgePreservingFilterFlagNormconvFilter Field

Norm conv filter

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EdgePreservingFilterFlag NormconvFilter = 2
Public Const NormconvFilter As EdgePreservingFilterFlag = 2
public:
literal EdgePreservingFilterFlag^ NormconvFilter = 2
static val mutable NormconvFilter: EdgePreservingFilterFlag

Field Value

Type: EdgePreservingFilterFlag
See Also

Reference

EdgePreservingFilterFlag Class
Emgu.CV.CvEnum Namespace


EdgePreservingFilterFlag.RecursFilter Field

EdgePreservingFilterFlagRecursFilter Field

Recurs filter

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EdgePreservingFilterFlag RecursFilter = 1
Public Const RecursFilter As EdgePreservingFilterFlag = 1
public:
literal EdgePreservingFilterFlag^ RecursFilter = 1
static val mutable RecursFilter: EdgePreservingFilterFlag

Field Value

Type: EdgePreservingFilterFlag
See Also

Reference

EdgePreservingFilterFlag Class
Emgu.CV.CvEnum Namespace


EdgePreservingFilterFlag.value__ Field

EdgePreservingFilterFlagvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.EdgePreservingFilterFlag.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

EdgePreservingFilterFlag Class
Emgu.CV.CvEnum Namespace


EigobjType Class

IO type for eigen object related functions
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumEigobjType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class EigobjType : Enum
Public NotInheritable Class EigobjType
    Inherits Enum
public ref class EigobjType sealed : public Enum
[<SealedAttribute>]
type EigobjType =
    class
        inherit Enum
    end

The EigobjType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BothCallback | Both callback
 | InputCallback | Input callback
 | NoCallback | No callback
 | OutputCallback | Output callback
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


EigobjType Methods

The EigobjType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

EigobjType Class
Emgu.CV.CvEnum Namespace


EigobjType Fields

The EigobjType type exposes the following members.

Fields
 | Name | Description
 | BothCallback | Both callback
 | InputCallback | Input callback
 | NoCallback | No callback
 | OutputCallback | Output callback
Public field | value__ |
Top
See Also

Reference

EigobjType Class
Emgu.CV.CvEnum Namespace


EigobjType.BothCallback Field

EigobjTypeBothCallback Field

Both callback

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EigobjType BothCallback = 3
Public Const BothCallback As EigobjType = 3
public:
literal EigobjType^ BothCallback = 3
static val mutable BothCallback: EigobjType

Field Value

Type: EigobjType
See Also

Reference

EigobjType Class
Emgu.CV.CvEnum Namespace


EigobjType.InputCallback Field

EigobjTypeInputCallback Field

Input callback

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EigobjType InputCallback = 1
Public Const InputCallback As EigobjType = 1
public:
literal EigobjType^ InputCallback = 1
static val mutable InputCallback: EigobjType

Field Value

Type: EigobjType
See Also

Reference

EigobjType Class
Emgu.CV.CvEnum Namespace


EigobjType.NoCallback Field

EigobjTypeNoCallback Field

No callback

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EigobjType NoCallback = 0
Public Const NoCallback As EigobjType = 0
public:
literal EigobjType^ NoCallback = 0
static val mutable NoCallback: EigobjType

Field Value

Type: EigobjType
See Also

Reference

EigobjType Class
Emgu.CV.CvEnum Namespace


EigobjType.OutputCallback Field

EigobjTypeOutputCallback Field

Output callback

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EigobjType OutputCallback = 2
Public Const OutputCallback As EigobjType = 2
public:
literal EigobjType^ OutputCallback = 2
static val mutable OutputCallback: EigobjType

Field Value

Type: EigobjType
See Also

Reference

EigobjType Class
Emgu.CV.CvEnum Namespace


EigobjType.value__ Field

EigobjTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.EigobjType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

EigobjType Class
Emgu.CV.CvEnum Namespace


ElementShape Class

Shape of the Structuring Element
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumElementShape

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ElementShape : Enum
Public NotInheritable Class ElementShape
    Inherits Enum
public ref class ElementShape sealed : public Enum
[<SealedAttribute>]
type ElementShape =
    class
        inherit Enum
    end

The ElementShape type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cross | A cross-shaped element.
 | Custom | A user-defined element.
 | Ellipse | An elliptic element.
 | Rectangle | A rectangular element.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ElementShape Methods

The ElementShape type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ElementShape Class
Emgu.CV.CvEnum Namespace


ElementShape Fields

The ElementShape type exposes the following members.

Fields
 | Name | Description
 | Cross | A cross-shaped element.
 | Custom | A user-defined element.
 | Ellipse | An elliptic element.
 | Rectangle | A rectangular element.
Public field | value__ |
Top
See Also

Reference

ElementShape Class
Emgu.CV.CvEnum Namespace


ElementShape.Cross Field

ElementShapeCross Field

A cross-shaped element.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ElementShape Cross = 1
Public Const Cross As ElementShape = 1
public:
literal ElementShape^ Cross = 1
static val mutable Cross: ElementShape

Field Value

Type: ElementShape
See Also

Reference

ElementShape Class
Emgu.CV.CvEnum Namespace


ElementShape.Custom Field

ElementShapeCustom Field

A user-defined element.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ElementShape Custom = 100
Public Const Custom As ElementShape = 100
public:
literal ElementShape^ Custom = 100
static val mutable Custom: ElementShape

Field Value

Type: ElementShape
See Also

Reference

ElementShape Class
Emgu.CV.CvEnum Namespace


ElementShape.Ellipse Field

ElementShapeEllipse Field

An elliptic element.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ElementShape Ellipse = 2
Public Const Ellipse As ElementShape = 2
public:
literal ElementShape^ Ellipse = 2
static val mutable Ellipse: ElementShape

Field Value

Type: ElementShape
See Also

Reference

ElementShape Class
Emgu.CV.CvEnum Namespace


ElementShape.Rectangle Field

ElementShapeRectangle Field

A rectangular element.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ElementShape Rectangle = 0
Public Const Rectangle As ElementShape = 0
public:
literal ElementShape^ Rectangle = 0
static val mutable Rectangle: ElementShape

Field Value

Type: ElementShape
See Also

Reference

ElementShape Class
Emgu.CV.CvEnum Namespace


ElementShape.value__ Field

ElementShapevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ElementShape.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ElementShape Class
Emgu.CV.CvEnum Namespace


ErrorCodes Class

Error codes
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumErrorCodes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ErrorCodes : Enum
Public NotInheritable Class ErrorCodes
    Inherits Enum
public ref class ErrorCodes sealed : public Enum
[<SealedAttribute>]
type ErrorCodes =
    class
        inherit Enum
    end

The ErrorCodes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BadAlign | Bad Align
 | BadAlphaChannel | Bad Alpha channel
 | BadCallback | Bad callback
 | BadCoi | Bad COI
 | BadDataPtr | Bad Data pointer
 | BadDepth | Bad depth
 | BadImageSize | Bad image size
 | BadModelOrChseq | Bad model or chseq
 | BadNumChannel1U | Bad number of channels 1U
 | BadNumChannels | Bad number of channels
 | BadOffset | Bad Offset
 | BadOrder | Bad Order
 | BadOrigin | Bad origin
 | BadRoiSize | Bad ROI size
 | Badstep | Bad step
 | BadTileSize | Bad tile size
 | HeaderIsNull | Header is Null
 | MaskIsTiled | Mask is tiled
 | StsAutoTrace | Auto trace
 | StsBacktrace | Back trace
 | StsBadArg | Bad argument
 | StsBadFlag | Bad flag
 | StsBadFunc | Bad function
 | StsBadMask | Bad mask
 | StsBadMemBlock | Bad memory block
 | StsBadPoint | Bad point
 | StsBadSize | Bad Size
 | StsDivByZero | Division by zero
 | StsError | Error
 | StsFilterOffSetErr | Filter Offset Error
 | StsFilterStructContenterr | Filter Structure Content Error
 | StsInplaceNotSupported | Inplace not supported
 | StsInternal | Internal
 | StsKernelStructContenterr | Kernel Structure Content Error
 | StsNoConv | No Conv
 | StsNoMem | No memory
 | StsNotImplemented | Not Implemented
 | StsNullPtr | Null Pointer
 | StsObjectNotFound | Object Not Found
 | StsOk | Ok
 | StsOutOfRange | Out of range
 | StsParseError | Parse Error
 | StsUnmatchedFormats | Unmatched formats
 | StsUnmatchedSizes | Unmatched sizes
 | StsUnsupportedFormat | Unsupported format
 | StsVecLengthErr | Vec length error
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ErrorCodes Methods

The ErrorCodes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes Fields

The ErrorCodes type exposes the following members.

Fields
 | Name | Description
 | BadAlign | Bad Align
 | BadAlphaChannel | Bad Alpha channel
 | BadCallback | Bad callback
 | BadCoi | Bad COI
 | BadDataPtr | Bad Data pointer
 | BadDepth | Bad depth
 | BadImageSize | Bad image size
 | BadModelOrChseq | Bad model or chseq
 | BadNumChannel1U | Bad number of channels 1U
 | BadNumChannels | Bad number of channels
 | BadOffset | Bad Offset
 | BadOrder | Bad Order
 | BadOrigin | Bad origin
 | BadRoiSize | Bad ROI size
 | Badstep | Bad step
 | BadTileSize | Bad tile size
 | HeaderIsNull | Header is Null
 | MaskIsTiled | Mask is tiled
 | StsAutoTrace | Auto trace
 | StsBacktrace | Back trace
 | StsBadArg | Bad argument
 | StsBadFlag | Bad flag
 | StsBadFunc | Bad function
 | StsBadMask | Bad mask
 | StsBadMemBlock | Bad memory block
 | StsBadPoint | Bad point
 | StsBadSize | Bad Size
 | StsDivByZero | Division by zero
 | StsError | Error
 | StsFilterOffSetErr | Filter Offset Error
 | StsFilterStructContenterr | Filter Structure Content Error
 | StsInplaceNotSupported | Inplace not supported
 | StsInternal | Internal
 | StsKernelStructContenterr | Kernel Structure Content Error
 | StsNoConv | No Conv
 | StsNoMem | No memory
 | StsNotImplemented | Not Implemented
 | StsNullPtr | Null Pointer
 | StsObjectNotFound | Object Not Found
 | StsOk | Ok
 | StsOutOfRange | Out of range
 | StsParseError | Parse Error
 | StsUnmatchedFormats | Unmatched formats
 | StsUnmatchedSizes | Unmatched sizes
 | StsUnsupportedFormat | Unsupported format
 | StsVecLengthErr | Vec length error
Public field | value__ |
Top
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadAlign Field

ErrorCodesBadAlign Field

Bad Align

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadAlign = -21
Public Const BadAlign As ErrorCodes = -21
public:
literal ErrorCodes^ BadAlign = -21
static val mutable BadAlign: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadAlphaChannel Field

ErrorCodesBadAlphaChannel Field

Bad Alpha channel

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadAlphaChannel = -18
Public Const BadAlphaChannel As ErrorCodes = -18
public:
literal ErrorCodes^ BadAlphaChannel = -18
static val mutable BadAlphaChannel: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadCallback Field

ErrorCodesBadCallback Field

Bad callback

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadCallback = -22
Public Const BadCallback As ErrorCodes = -22
public:
literal ErrorCodes^ BadCallback = -22
static val mutable BadCallback: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadCoi Field

ErrorCodesBadCoi Field

Bad COI

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadCoi = -24
Public Const BadCoi As ErrorCodes = -24
public:
literal ErrorCodes^ BadCoi = -24
static val mutable BadCoi: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadDataPtr Field

ErrorCodesBadDataPtr Field

Bad Data pointer

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadDataPtr = -12
Public Const BadDataPtr As ErrorCodes = -12
public:
literal ErrorCodes^ BadDataPtr = -12
static val mutable BadDataPtr: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadDepth Field

ErrorCodesBadDepth Field

Bad depth

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadDepth = -17
Public Const BadDepth As ErrorCodes = -17
public:
literal ErrorCodes^ BadDepth = -17
static val mutable BadDepth: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadImageSize Field

ErrorCodesBadImageSize Field

Bad image size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadImageSize = -10
Public Const BadImageSize As ErrorCodes = -10
public:
literal ErrorCodes^ BadImageSize = -10
static val mutable BadImageSize: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadModelOrChseq Field

ErrorCodesBadModelOrChseq Field

Bad model or chseq

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadModelOrChseq = -14
Public Const BadModelOrChseq As ErrorCodes = -14
public:
literal ErrorCodes^ BadModelOrChseq = -14
static val mutable BadModelOrChseq: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadNumChannel1U Field

ErrorCodesBadNumChannel1U Field

Bad number of channels 1U

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadNumChannel1U = -16
Public Const BadNumChannel1U As ErrorCodes = -16
public:
literal ErrorCodes^ BadNumChannel1U = -16
static val mutable BadNumChannel1U: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadNumChannels Field

ErrorCodesBadNumChannels Field

Bad number of channels

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadNumChannels = -15
Public Const BadNumChannels As ErrorCodes = -15
public:
literal ErrorCodes^ BadNumChannels = -15
static val mutable BadNumChannels: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadOffset Field

ErrorCodesBadOffset Field

Bad Offset

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadOffset = -11
Public Const BadOffset As ErrorCodes = -11
public:
literal ErrorCodes^ BadOffset = -11
static val mutable BadOffset: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadOrder Field

ErrorCodesBadOrder Field

Bad Order

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadOrder = -19
Public Const BadOrder As ErrorCodes = -19
public:
literal ErrorCodes^ BadOrder = -19
static val mutable BadOrder: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadOrigin Field

ErrorCodesBadOrigin Field

Bad origin

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadOrigin = -20
Public Const BadOrigin As ErrorCodes = -20
public:
literal ErrorCodes^ BadOrigin = -20
static val mutable BadOrigin: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadRoiSize Field

ErrorCodesBadRoiSize Field

Bad ROI size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadRoiSize = -25
Public Const BadRoiSize As ErrorCodes = -25
public:
literal ErrorCodes^ BadRoiSize = -25
static val mutable BadRoiSize: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.Badstep Field

ErrorCodesBadstep Field

Bad step

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes Badstep = -13
Public Const Badstep As ErrorCodes = -13
public:
literal ErrorCodes^ Badstep = -13
static val mutable Badstep: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.BadTileSize Field

ErrorCodesBadTileSize Field

Bad tile size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes BadTileSize = -23
Public Const BadTileSize As ErrorCodes = -23
public:
literal ErrorCodes^ BadTileSize = -23
static val mutable BadTileSize: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.HeaderIsNull Field

ErrorCodesHeaderIsNull Field

Header is Null

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes HeaderIsNull = -9
Public Const HeaderIsNull As ErrorCodes = -9
public:
literal ErrorCodes^ HeaderIsNull = -9
static val mutable HeaderIsNull: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.MaskIsTiled Field

ErrorCodesMaskIsTiled Field

Mask is tiled

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes MaskIsTiled = -26
Public Const MaskIsTiled As ErrorCodes = -26
public:
literal ErrorCodes^ MaskIsTiled = -26
static val mutable MaskIsTiled: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsAutoTrace Field

ErrorCodesStsAutoTrace Field

Auto trace

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsAutoTrace = -8
Public Const StsAutoTrace As ErrorCodes = -8
public:
literal ErrorCodes^ StsAutoTrace = -8
static val mutable StsAutoTrace: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBacktrace Field

ErrorCodesStsBacktrace Field

Back trace

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBacktrace = -1
Public Const StsBacktrace As ErrorCodes = -1
public:
literal ErrorCodes^ StsBacktrace = -1
static val mutable StsBacktrace: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBadArg Field

ErrorCodesStsBadArg Field

Bad argument

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBadArg = -5
Public Const StsBadArg As ErrorCodes = -5
public:
literal ErrorCodes^ StsBadArg = -5
static val mutable StsBadArg: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBadFlag Field

ErrorCodesStsBadFlag Field

Bad flag

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBadFlag = -206
Public Const StsBadFlag As ErrorCodes = -206
public:
literal ErrorCodes^ StsBadFlag = -206
static val mutable StsBadFlag: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBadFunc Field

ErrorCodesStsBadFunc Field

Bad function

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBadFunc = -6
Public Const StsBadFunc As ErrorCodes = -6
public:
literal ErrorCodes^ StsBadFunc = -6
static val mutable StsBadFunc: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBadMask Field

ErrorCodesStsBadMask Field

Bad mask

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBadMask = -208
Public Const StsBadMask As ErrorCodes = -208
public:
literal ErrorCodes^ StsBadMask = -208
static val mutable StsBadMask: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBadMemBlock Field

ErrorCodesStsBadMemBlock Field

Bad memory block

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBadMemBlock = -214
Public Const StsBadMemBlock As ErrorCodes = -214
public:
literal ErrorCodes^ StsBadMemBlock = -214
static val mutable StsBadMemBlock: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBadPoint Field

ErrorCodesStsBadPoint Field

Bad point

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBadPoint = -207
Public Const StsBadPoint As ErrorCodes = -207
public:
literal ErrorCodes^ StsBadPoint = -207
static val mutable StsBadPoint: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsBadSize Field

ErrorCodesStsBadSize Field

Bad Size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsBadSize = -201
Public Const StsBadSize As ErrorCodes = -201
public:
literal ErrorCodes^ StsBadSize = -201
static val mutable StsBadSize: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsDivByZero Field

ErrorCodesStsDivByZero Field

Division by zero

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsDivByZero = -202
Public Const StsDivByZero As ErrorCodes = -202
public:
literal ErrorCodes^ StsDivByZero = -202
static val mutable StsDivByZero: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsError Field

ErrorCodesStsError Field

Error

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsError = -2
Public Const StsError As ErrorCodes = -2
public:
literal ErrorCodes^ StsError = -2
static val mutable StsError: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsFilterOffSetErr Field

ErrorCodesStsFilterOffSetErr Field

Filter Offset Error

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsFilterOffSetErr = -31
Public Const StsFilterOffSetErr As ErrorCodes = -31
public:
literal ErrorCodes^ StsFilterOffSetErr = -31
static val mutable StsFilterOffSetErr: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsFilterStructContenterr Field

ErrorCodesStsFilterStructContenterr Field

Filter Structure Content Error

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsFilterStructContenterr = -29
Public Const StsFilterStructContenterr As ErrorCodes = -29
public:
literal ErrorCodes^ StsFilterStructContenterr = -29
static val mutable StsFilterStructContenterr: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsInplaceNotSupported Field

ErrorCodesStsInplaceNotSupported Field

Inplace not supported

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsInplaceNotSupported = -203
Public Const StsInplaceNotSupported As ErrorCodes = -203
public:
literal ErrorCodes^ StsInplaceNotSupported = -203
static val mutable StsInplaceNotSupported: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsInternal Field

ErrorCodesStsInternal Field

Internal

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsInternal = -3
Public Const StsInternal As ErrorCodes = -3
public:
literal ErrorCodes^ StsInternal = -3
static val mutable StsInternal: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsKernelStructContenterr Field

ErrorCodesStsKernelStructContenterr Field

Kernel Structure Content Error

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsKernelStructContenterr = -30
Public Const StsKernelStructContenterr As ErrorCodes = -30
public:
literal ErrorCodes^ StsKernelStructContenterr = -30
static val mutable StsKernelStructContenterr: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsNoConv Field

ErrorCodesStsNoConv Field

No Conv

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsNoConv = -7
Public Const StsNoConv As ErrorCodes = -7
public:
literal ErrorCodes^ StsNoConv = -7
static val mutable StsNoConv: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsNoMem Field

ErrorCodesStsNoMem Field

No memory

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsNoMem = -4
Public Const StsNoMem As ErrorCodes = -4
public:
literal ErrorCodes^ StsNoMem = -4
static val mutable StsNoMem: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsNotImplemented Field

ErrorCodesStsNotImplemented Field

Not Implemented

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsNotImplemented = -213
Public Const StsNotImplemented As ErrorCodes = -213
public:
literal ErrorCodes^ StsNotImplemented = -213
static val mutable StsNotImplemented: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsNullPtr Field

ErrorCodesStsNullPtr Field

Null Pointer

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsNullPtr = -27
Public Const StsNullPtr As ErrorCodes = -27
public:
literal ErrorCodes^ StsNullPtr = -27
static val mutable StsNullPtr: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsObjectNotFound Field

ErrorCodesStsObjectNotFound Field

Object Not Found

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsObjectNotFound = -204
Public Const StsObjectNotFound As ErrorCodes = -204
public:
literal ErrorCodes^ StsObjectNotFound = -204
static val mutable StsObjectNotFound: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsOk Field

ErrorCodesStsOk Field

Ok

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsOk = 0
Public Const StsOk As ErrorCodes = 0
public:
literal ErrorCodes^ StsOk = 0
static val mutable StsOk: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsOutOfRange Field

ErrorCodesStsOutOfRange Field

Out of range

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsOutOfRange = -211
Public Const StsOutOfRange As ErrorCodes = -211
public:
literal ErrorCodes^ StsOutOfRange = -211
static val mutable StsOutOfRange: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsParseError Field

ErrorCodesStsParseError Field

Parse Error

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsParseError = -212
Public Const StsParseError As ErrorCodes = -212
public:
literal ErrorCodes^ StsParseError = -212
static val mutable StsParseError: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsUnmatchedFormats Field

ErrorCodesStsUnmatchedFormats Field

Unmatched formats

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsUnmatchedFormats = -205
Public Const StsUnmatchedFormats As ErrorCodes = -205
public:
literal ErrorCodes^ StsUnmatchedFormats = -205
static val mutable StsUnmatchedFormats: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsUnmatchedSizes Field

ErrorCodesStsUnmatchedSizes Field

Unmatched sizes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsUnmatchedSizes = -209
Public Const StsUnmatchedSizes As ErrorCodes = -209
public:
literal ErrorCodes^ StsUnmatchedSizes = -209
static val mutable StsUnmatchedSizes: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsUnsupportedFormat Field

ErrorCodesStsUnsupportedFormat Field

Unsupported format

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsUnsupportedFormat = -210
Public Const StsUnsupportedFormat As ErrorCodes = -210
public:
literal ErrorCodes^ StsUnsupportedFormat = -210
static val mutable StsUnsupportedFormat: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.StsVecLengthErr Field

ErrorCodesStsVecLengthErr Field

Vec length error

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ErrorCodes StsVecLengthErr = -28
Public Const StsVecLengthErr As ErrorCodes = -28
public:
literal ErrorCodes^ StsVecLengthErr = -28
static val mutable StsVecLengthErr: ErrorCodes

Field Value

Type: ErrorCodes
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


ErrorCodes.value__ Field

ErrorCodesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ErrorCodes.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ErrorCodes Class
Emgu.CV.CvEnum Namespace


FlipType Class

Enumeration used by cvFlip
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumFlipType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class FlipType : Enum
<FlagsAttribute>
Public NotInheritable Class FlipType
    Inherits Enum
[FlagsAttribute]
public ref class FlipType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type FlipType =
    class
        inherit Enum
    end

The FlipType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Horizontal | Flip horizontally
 | None | No flipping
Public field | value__ |
 | Vertical | Flip vertically
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


FlipType Methods

The FlipType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FlipType Class
Emgu.CV.CvEnum Namespace


FlipType Fields

The FlipType type exposes the following members.

Fields
 | Name | Description
 | Horizontal | Flip horizontally
 | None | No flipping
Public field | value__ |
 | Vertical | Flip vertically
Top
See Also

Reference

FlipType Class
Emgu.CV.CvEnum Namespace


FlipType.Horizontal Field

FlipTypeHorizontal Field

Flip horizontally

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FlipType Horizontal = 1
Public Const Horizontal As FlipType = 1
public:
literal FlipType^ Horizontal = 1
static val mutable Horizontal: FlipType

Field Value

Type: FlipType
See Also

Reference

FlipType Class
Emgu.CV.CvEnum Namespace


FlipType.None Field

FlipTypeNone Field

No flipping

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FlipType None = 0
Public Const None As FlipType = 0
public:
literal FlipType^ None = 0
static val mutable None: FlipType

Field Value

Type: FlipType
See Also

Reference

FlipType Class
Emgu.CV.CvEnum Namespace


FlipType.value__ Field

FlipTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.FlipType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FlipType Class
Emgu.CV.CvEnum Namespace


FlipType.Vertical Field

FlipTypeVertical Field

Flip vertically

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FlipType Vertical = 2
Public Const Vertical As FlipType = 2
public:
literal FlipType^ Vertical = 2
static val mutable Vertical: FlipType

Field Value

Type: FlipType
See Also

Reference

FlipType Class
Emgu.CV.CvEnum Namespace


FloodFillType Class

Type of floodfill operation
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumFloodFillType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class FloodFillType : Enum
<FlagsAttribute>
Public NotInheritable Class FloodFillType
    Inherits Enum
[FlagsAttribute]
public ref class FloodFillType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type FloodFillType =
    class
        inherit Enum
    end

The FloodFillType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The default type
 | FixedRange | If set the difference between the current pixel and seed pixel is considered, otherwise difference between neighbor pixels is considered (the range is floating).
 | MaskOnly | If set, the function does not fill the image (new_val is ignored), but the fills mask (that must be non-NULL in this case).
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


FloodFillType Methods

The FloodFillType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FloodFillType Class
Emgu.CV.CvEnum Namespace


FloodFillType Fields

The FloodFillType type exposes the following members.

Fields
 | Name | Description
 | Default | The default type
 | FixedRange | If set the difference between the current pixel and seed pixel is considered, otherwise difference between neighbor pixels is considered (the range is floating).
 | MaskOnly | If set, the function does not fill the image (new_val is ignored), but the fills mask (that must be non-NULL in this case).
Public field | value__ |
Top
See Also

Reference

FloodFillType Class
Emgu.CV.CvEnum Namespace


FloodFillType.Default Field

FloodFillTypeDefault Field

The default type

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FloodFillType Default = 0
Public Const Default As FloodFillType = 0
public:
literal FloodFillType^ Default = 0
static val mutable Default: FloodFillType

Field Value

Type: FloodFillType
See Also

Reference

FloodFillType Class
Emgu.CV.CvEnum Namespace


FloodFillType.FixedRange Field

FloodFillTypeFixedRange Field

If set the difference between the current pixel and seed pixel is considered, otherwise difference between neighbor pixels is considered (the range is floating).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FloodFillType FixedRange = 65536
Public Const FixedRange As FloodFillType = 65536
public:
literal FloodFillType^ FixedRange = 65536
static val mutable FixedRange: FloodFillType

Field Value

Type: FloodFillType
See Also

Reference

FloodFillType Class
Emgu.CV.CvEnum Namespace


FloodFillType.MaskOnly Field

FloodFillTypeMaskOnly Field

If set, the function does not fill the image (new_val is ignored), but the fills mask (that must be non-NULL in this case).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FloodFillType MaskOnly = 131072
Public Const MaskOnly As FloodFillType = 131072
public:
literal FloodFillType^ MaskOnly = 131072
static val mutable MaskOnly: FloodFillType

Field Value

Type: FloodFillType
See Also

Reference

FloodFillType Class
Emgu.CV.CvEnum Namespace


FloodFillType.value__ Field

FloodFillTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.FloodFillType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FloodFillType Class
Emgu.CV.CvEnum Namespace


FmType Class

Calculates fundamental matrix given a set of corresponding points
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumFmType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class FmType : Enum
<FlagsAttribute>
Public NotInheritable Class FmType
    Inherits Enum
[FlagsAttribute]
public ref class FmType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type FmType =
    class
        inherit Enum
    end

The FmType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | EightPoint | for 8-point algorithm. N >= 8
 | LMeds | CV_FM_LMEDS_ONLY | CV_FM_8POINT
 | LMedsOnly | for LMedS algorithm. N >= 8
 | Ransac | CV_FM_RANSAC_ONLY | CV_FM_8POINT
 | RansacOnly | for RANSAC algorithm. N >= 8
 | SevenPoint | for 7-point algorithm. N == 7
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


FmType Methods

The FmType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType Fields

The FmType type exposes the following members.

Fields
 | Name | Description
 | EightPoint | for 8-point algorithm. N >= 8
 | LMeds | CV_FM_LMEDS_ONLY | CV_FM_8POINT
 | LMedsOnly | for LMedS algorithm. N >= 8
 | Ransac | CV_FM_RANSAC_ONLY | CV_FM_8POINT
 | RansacOnly | for RANSAC algorithm. N >= 8
 | SevenPoint | for 7-point algorithm. N == 7
Public field | value__ |
Top
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType.EightPoint Field

FmTypeEightPoint Field

for 8-point algorithm. N >= 8

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FmType EightPoint = 2
Public Const EightPoint As FmType = 2
public:
literal FmType^ EightPoint = 2
static val mutable EightPoint: FmType

Field Value

Type: FmType
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType.LMeds Field

FmTypeLMeds Field

CV_FM_LMEDS_ONLY | CV_FM_8POINT

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FmType LMeds = 6
Public Const LMeds As FmType = 6
public:
literal FmType^ LMeds = 6
static val mutable LMeds: FmType

Field Value

Type: FmType
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType.LMedsOnly Field

FmTypeLMedsOnly Field

for LMedS algorithm. N >= 8

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FmType LMedsOnly = 4
Public Const LMedsOnly As FmType = 4
public:
literal FmType^ LMedsOnly = 4
static val mutable LMedsOnly: FmType

Field Value

Type: FmType
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType.Ransac Field

FmTypeRansac Field

CV_FM_RANSAC_ONLY | CV_FM_8POINT

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FmType Ransac = 10
Public Const Ransac As FmType = 10
public:
literal FmType^ Ransac = 10
static val mutable Ransac: FmType

Field Value

Type: FmType
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType.RansacOnly Field

FmTypeRansacOnly Field

for RANSAC algorithm. N >= 8

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FmType RansacOnly = 8
Public Const RansacOnly As FmType = 8
public:
literal FmType^ RansacOnly = 8
static val mutable RansacOnly: FmType

Field Value

Type: FmType
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType.SevenPoint Field

FmTypeSevenPoint Field

for 7-point algorithm. N == 7

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FmType SevenPoint = 1
Public Const SevenPoint As FmType = 1
public:
literal FmType^ SevenPoint = 1
static val mutable SevenPoint: FmType

Field Value

Type: FmType
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FmType.value__ Field

FmTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.FmType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FmType Class
Emgu.CV.CvEnum Namespace


FontFace Class

Fonts
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumFontFace

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FontFace : Enum
Public NotInheritable Class FontFace
    Inherits Enum
public ref class FontFace sealed : public Enum
[<SealedAttribute>]
type FontFace =
    class
        inherit Enum
    end

The FontFace type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | HersheyComplex | Hershey complex
 | HersheyComplexSmall | Hershey complex small
 | HersheyDuplex | Hershey duplex
 | HersheyPlain | Hershey plain
 | HersheyScriptComplex | Hershey script complex
 | HersheyScriptSimplex | Hershey script simplex
 | HersheySimplex | Hershey simplex
 | HersheyTriplex | Hershey triplex
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


FontFace Methods

The FontFace type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace Fields

The FontFace type exposes the following members.

Fields
 | Name | Description
 | HersheyComplex | Hershey complex
 | HersheyComplexSmall | Hershey complex small
 | HersheyDuplex | Hershey duplex
 | HersheyPlain | Hershey plain
 | HersheyScriptComplex | Hershey script complex
 | HersheyScriptSimplex | Hershey script simplex
 | HersheySimplex | Hershey simplex
 | HersheyTriplex | Hershey triplex
Public field | value__ |
Top
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheyComplex Field

FontFaceHersheyComplex Field

Hershey complex

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheyComplex = 3
Public Const HersheyComplex As FontFace = 3
public:
literal FontFace^ HersheyComplex = 3
static val mutable HersheyComplex: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheyComplexSmall Field

FontFaceHersheyComplexSmall Field

Hershey complex small

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheyComplexSmall = 5
Public Const HersheyComplexSmall As FontFace = 5
public:
literal FontFace^ HersheyComplexSmall = 5
static val mutable HersheyComplexSmall: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheyDuplex Field

FontFaceHersheyDuplex Field

Hershey duplex

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheyDuplex = 2
Public Const HersheyDuplex As FontFace = 2
public:
literal FontFace^ HersheyDuplex = 2
static val mutable HersheyDuplex: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheyPlain Field

FontFaceHersheyPlain Field

Hershey plain

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheyPlain = 1
Public Const HersheyPlain As FontFace = 1
public:
literal FontFace^ HersheyPlain = 1
static val mutable HersheyPlain: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheyScriptComplex Field

FontFaceHersheyScriptComplex Field

Hershey script complex

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheyScriptComplex = 7
Public Const HersheyScriptComplex As FontFace = 7
public:
literal FontFace^ HersheyScriptComplex = 7
static val mutable HersheyScriptComplex: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheyScriptSimplex Field

FontFaceHersheyScriptSimplex Field

Hershey script simplex

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheyScriptSimplex = 6
Public Const HersheyScriptSimplex As FontFace = 6
public:
literal FontFace^ HersheyScriptSimplex = 6
static val mutable HersheyScriptSimplex: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheySimplex Field

FontFaceHersheySimplex Field

Hershey simplex

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheySimplex = 0
Public Const HersheySimplex As FontFace = 0
public:
literal FontFace^ HersheySimplex = 0
static val mutable HersheySimplex: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.HersheyTriplex Field

FontFaceHersheyTriplex Field

Hershey triplex

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FontFace HersheyTriplex = 4
Public Const HersheyTriplex As FontFace = 4
public:
literal FontFace^ HersheyTriplex = 4
static val mutable HersheyTriplex: FontFace

Field Value

Type: FontFace
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


FontFace.value__ Field

FontFacevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.FontFace.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FontFace Class
Emgu.CV.CvEnum Namespace


GemmType Class

Flags used for GEMM function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumGemmType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class GemmType : Enum
<FlagsAttribute>
Public NotInheritable Class GemmType
    Inherits Enum
[FlagsAttribute]
public ref class GemmType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type GemmType =
    class
        inherit Enum
    end

The GemmType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Do not apply transpose to neither matrices
 | Src1Transpose | transpose src1
 | Src2Transpose | transpose src2
 | Src3Transpose | transpose src3
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


GemmType Methods

The GemmType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

GemmType Class
Emgu.CV.CvEnum Namespace


GemmType Fields

The GemmType type exposes the following members.

Fields
 | Name | Description
 | Default | Do not apply transpose to neither matrices
 | Src1Transpose | transpose src1
 | Src2Transpose | transpose src2
 | Src3Transpose | transpose src3
Public field | value__ |
Top
See Also

Reference

GemmType Class
Emgu.CV.CvEnum Namespace


GemmType.Default Field

GemmTypeDefault Field

Do not apply transpose to neither matrices

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const GemmType Default = 0
Public Const Default As GemmType = 0
public:
literal GemmType^ Default = 0
static val mutable Default: GemmType

Field Value

Type: GemmType
See Also

Reference

GemmType Class
Emgu.CV.CvEnum Namespace


GemmType.Src1Transpose Field

GemmTypeSrc1Transpose Field

transpose src1

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const GemmType Src1Transpose = 1
Public Const Src1Transpose As GemmType = 1
public:
literal GemmType^ Src1Transpose = 1
static val mutable Src1Transpose: GemmType

Field Value

Type: GemmType
See Also

Reference

GemmType Class
Emgu.CV.CvEnum Namespace


GemmType.Src2Transpose Field

GemmTypeSrc2Transpose Field

transpose src2

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const GemmType Src2Transpose = 2
Public Const Src2Transpose As GemmType = 2
public:
literal GemmType^ Src2Transpose = 2
static val mutable Src2Transpose: GemmType

Field Value

Type: GemmType
See Also

Reference

GemmType Class
Emgu.CV.CvEnum Namespace


GemmType.Src3Transpose Field

GemmTypeSrc3Transpose Field

transpose src3

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const GemmType Src3Transpose = 4
Public Const Src3Transpose As GemmType = 4
public:
literal GemmType^ Src3Transpose = 4
static val mutable Src3Transpose: GemmType

Field Value

Type: GemmType
See Also

Reference

GemmType Class
Emgu.CV.CvEnum Namespace


GemmType.value__ Field

GemmTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.GemmType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

GemmType Class
Emgu.CV.CvEnum Namespace


General Class

General enumeration
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumGeneral

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class General : Enum
Public NotInheritable Class General
    Inherits Enum
public ref class General sealed : public Enum
[<SealedAttribute>]
type General =
    class
        inherit Enum
    end

The General type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | MaxDim | Max dim
 | SeqMagicVal | Seq magic val
 | SetMagicVal | Set magic val
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


General Methods

The General type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

General Class
Emgu.CV.CvEnum Namespace


General Fields

The General type exposes the following members.

Fields
 | Name | Description
 | MaxDim | Max dim
 | SeqMagicVal | Seq magic val
 | SetMagicVal | Set magic val
Public field | value__ |
Top
See Also

Reference

General Class
Emgu.CV.CvEnum Namespace


General.MaxDim Field

GeneralMaxDim Field

Max dim

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const General MaxDim = 32
Public Const MaxDim As General = 32
public:
literal General^ MaxDim = 32
static val mutable MaxDim: General

Field Value

Type: General
See Also

Reference

General Class
Emgu.CV.CvEnum Namespace


General.SeqMagicVal Field

GeneralSeqMagicVal Field

Seq magic val

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const General SeqMagicVal = 1117323264
Public Const SeqMagicVal As General = 1117323264
public:
literal General^ SeqMagicVal = 1117323264
static val mutable SeqMagicVal: General

Field Value

Type: General
See Also

Reference

General Class
Emgu.CV.CvEnum Namespace


General.SetMagicVal Field

GeneralSetMagicVal Field

Set magic val

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const General SetMagicVal = 1117257728
Public Const SetMagicVal As General = 1117257728
public:
literal General^ SetMagicVal = 1117257728
static val mutable SetMagicVal: General

Field Value

Type: General
See Also

Reference

General Class
Emgu.CV.CvEnum Namespace


General.value__ Field

Generalvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.General.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

General Class
Emgu.CV.CvEnum Namespace


GrabcutInitType Class

Grabcut initialization type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumGrabcutInitType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class GrabcutInitType : Enum
Public NotInheritable Class GrabcutInitType
    Inherits Enum
public ref class GrabcutInitType sealed : public Enum
[<SealedAttribute>]
type GrabcutInitType =
    class
        inherit Enum
    end

The GrabcutInitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Eval | Eval
 | InitWithMask | Initialize with mask
 | InitWithRect | Initialize with rectangle
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


GrabcutInitType Methods

The GrabcutInitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

GrabcutInitType Class
Emgu.CV.CvEnum Namespace


GrabcutInitType Fields

The GrabcutInitType type exposes the following members.

Fields
 | Name | Description
 | Eval | Eval
 | InitWithMask | Initialize with mask
 | InitWithRect | Initialize with rectangle
Public field | value__ |
Top
See Also

Reference

GrabcutInitType Class
Emgu.CV.CvEnum Namespace


GrabcutInitType.Eval Field

GrabcutInitTypeEval Field

Eval

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const GrabcutInitType Eval = 2
Public Const Eval As GrabcutInitType = 2
public:
literal GrabcutInitType^ Eval = 2
static val mutable Eval: GrabcutInitType

Field Value

Type: GrabcutInitType
See Also

Reference

GrabcutInitType Class
Emgu.CV.CvEnum Namespace


GrabcutInitType.InitWithMask Field

GrabcutInitTypeInitWithMask Field

Initialize with mask

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const GrabcutInitType InitWithMask = 1
Public Const InitWithMask As GrabcutInitType = 1
public:
literal GrabcutInitType^ InitWithMask = 1
static val mutable InitWithMask: GrabcutInitType

Field Value

Type: GrabcutInitType
See Also

Reference

GrabcutInitType Class
Emgu.CV.CvEnum Namespace


GrabcutInitType.InitWithRect Field

GrabcutInitTypeInitWithRect Field

Initialize with rectangle

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const GrabcutInitType InitWithRect = 0
Public Const InitWithRect As GrabcutInitType = 0
public:
literal GrabcutInitType^ InitWithRect = 0
static val mutable InitWithRect: GrabcutInitType

Field Value

Type: GrabcutInitType
See Also

Reference

GrabcutInitType Class
Emgu.CV.CvEnum Namespace


GrabcutInitType.value__ Field

GrabcutInitTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.GrabcutInitType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

GrabcutInitType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType Class

The types for haar detection
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumHaarDetectionType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class HaarDetectionType : Enum
<FlagsAttribute>
Public NotInheritable Class HaarDetectionType
    Inherits Enum
[FlagsAttribute]
public ref class HaarDetectionType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type HaarDetectionType =
    class
        inherit Enum
    end

The HaarDetectionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The default type where no optimization is done.
 | DoCannyPruning | If it is set, the function uses Canny edge detector to reject some image regions that contain too few or too much edges and thus can not contain the searched object. The particular threshold values are tuned for face detection and in this case the pruning speeds up the processing
 | DoRoughSearch | It should be used only when CV_HAAR_FIND_BIGGEST_OBJECT is set and min_neighbors > 0. If the flag is set, the function does not look for candidates of a smaller size as soon as it has found the object (with enough neighbor candidates) at the current scale. Typically, when min_neighbors is fixed, the mode yields less accurate (a bit larger) object rectangle than the regular single-object mode (flags=CV_HAAR_FIND_BIGGEST_OBJECT), but it is much faster, up to an order of magnitude. A greater value of min_neighbors may be specified to improve the accuracy
 | FindBiggestObject | If it is set, the function finds the largest object (if any) in the image. That is, the output sequence will contain one (or zero) element(s)
 | ScaleImage | For each scale factor used the function will downscale the image rather than "zoom" the feature coordinates in the classifier cascade. Currently, the option can only be used alone, i.e. the flag can not be set together with the others
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


HaarDetectionType Methods

The HaarDetectionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType Fields

The HaarDetectionType type exposes the following members.

Fields
 | Name | Description
 | Default | The default type where no optimization is done.
 | DoCannyPruning | If it is set, the function uses Canny edge detector to reject some image regions that contain too few or too much edges and thus can not contain the searched object. The particular threshold values are tuned for face detection and in this case the pruning speeds up the processing
 | DoRoughSearch | It should be used only when CV_HAAR_FIND_BIGGEST_OBJECT is set and min_neighbors > 0. If the flag is set, the function does not look for candidates of a smaller size as soon as it has found the object (with enough neighbor candidates) at the current scale. Typically, when min_neighbors is fixed, the mode yields less accurate (a bit larger) object rectangle than the regular single-object mode (flags=CV_HAAR_FIND_BIGGEST_OBJECT), but it is much faster, up to an order of magnitude. A greater value of min_neighbors may be specified to improve the accuracy
 | FindBiggestObject | If it is set, the function finds the largest object (if any) in the image. That is, the output sequence will contain one (or zero) element(s)
 | ScaleImage | For each scale factor used the function will downscale the image rather than "zoom" the feature coordinates in the classifier cascade. Currently, the option can only be used alone, i.e. the flag can not be set together with the others
Public field | value__ |
Top
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType.Default Field

HaarDetectionTypeDefault Field

The default type where no optimization is done.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HaarDetectionType Default = 0
Public Const Default As HaarDetectionType = 0
public:
literal HaarDetectionType^ Default = 0
static val mutable Default: HaarDetectionType

Field Value

Type: HaarDetectionType
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType.DoCannyPruning Field

HaarDetectionTypeDoCannyPruning Field

If it is set, the function uses Canny edge detector to reject some image regions that contain too few or too much edges and thus can not contain the searched object. The particular threshold values are tuned for face detection and in this case the pruning speeds up the processing

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HaarDetectionType DoCannyPruning = 1
Public Const DoCannyPruning As HaarDetectionType = 1
public:
literal HaarDetectionType^ DoCannyPruning = 1
static val mutable DoCannyPruning: HaarDetectionType

Field Value

Type: HaarDetectionType
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType.DoRoughSearch Field

HaarDetectionTypeDoRoughSearch Field

It should be used only when CV_HAAR_FIND_BIGGEST_OBJECT is set and min_neighbors > 0. If the flag is set, the function does not look for candidates of a smaller size as soon as it has found the object (with enough neighbor candidates) at the current scale. Typically, when min_neighbors is fixed, the mode yields less accurate (a bit larger) object rectangle than the regular single-object mode (flags=CV_HAAR_FIND_BIGGEST_OBJECT), but it is much faster, up to an order of magnitude. A greater value of min_neighbors may be specified to improve the accuracy

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HaarDetectionType DoRoughSearch = 8
Public Const DoRoughSearch As HaarDetectionType = 8
public:
literal HaarDetectionType^ DoRoughSearch = 8
static val mutable DoRoughSearch: HaarDetectionType

Field Value

Type: HaarDetectionType
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType.FindBiggestObject Field

HaarDetectionTypeFindBiggestObject Field

If it is set, the function finds the largest object (if any) in the image. That is, the output sequence will contain one (or zero) element(s)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HaarDetectionType FindBiggestObject = 4
Public Const FindBiggestObject As HaarDetectionType = 4
public:
literal HaarDetectionType^ FindBiggestObject = 4
static val mutable FindBiggestObject: HaarDetectionType

Field Value

Type: HaarDetectionType
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType.ScaleImage Field

HaarDetectionTypeScaleImage Field

For each scale factor used the function will downscale the image rather than "zoom" the feature coordinates in the classifier cascade. Currently, the option can only be used alone, i.e. the flag can not be set together with the others

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HaarDetectionType ScaleImage = 2
Public Const ScaleImage As HaarDetectionType = 2
public:
literal HaarDetectionType^ ScaleImage = 2
static val mutable ScaleImage: HaarDetectionType

Field Value

Type: HaarDetectionType
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HaarDetectionType.value__ Field

HaarDetectionTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.HaarDetectionType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

HaarDetectionType Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod Class

HandEyeCalibration Method
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumHandEyeCalibrationMethod

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class HandEyeCalibrationMethod : Enum
Public NotInheritable Class HandEyeCalibrationMethod
    Inherits Enum
public ref class HandEyeCalibrationMethod sealed : public Enum
[<SealedAttribute>]
type HandEyeCalibrationMethod =
    class
        inherit Enum
    end

The HandEyeCalibrationMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Andreff | On-line Hand-Eye Calibration
 | Daniilidis | Hand-Eye Calibration Using Dual Quaternions
 | Horaud | Hand-eye Calibration
 | Park | Robot Sensor Calibration: Solving AX = XB on the Euclidean Group
 | Tsai | A New Technique for Fully Autonomous and Efficient 3D Robotics Hand/Eye Calibration
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod Methods

The HandEyeCalibrationMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod Fields

The HandEyeCalibrationMethod type exposes the following members.

Fields
 | Name | Description
 | Andreff | On-line Hand-Eye Calibration
 | Daniilidis | Hand-Eye Calibration Using Dual Quaternions
 | Horaud | Hand-eye Calibration
 | Park | Robot Sensor Calibration: Solving AX = XB on the Euclidean Group
 | Tsai | A New Technique for Fully Autonomous and Efficient 3D Robotics Hand/Eye Calibration
Public field | value__ |
Top
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod.Andreff Field

HandEyeCalibrationMethodAndreff Field

On-line Hand-Eye Calibration

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HandEyeCalibrationMethod Andreff = 3
Public Const Andreff As HandEyeCalibrationMethod = 3
public:
literal HandEyeCalibrationMethod^ Andreff = 3
static val mutable Andreff: HandEyeCalibrationMethod

Field Value

Type: HandEyeCalibrationMethod
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod.Daniilidis Field

HandEyeCalibrationMethodDaniilidis Field

Hand-Eye Calibration Using Dual Quaternions

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HandEyeCalibrationMethod Daniilidis = 4
Public Const Daniilidis As HandEyeCalibrationMethod = 4
public:
literal HandEyeCalibrationMethod^ Daniilidis = 4
static val mutable Daniilidis: HandEyeCalibrationMethod

Field Value

Type: HandEyeCalibrationMethod
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod.Horaud Field

HandEyeCalibrationMethodHoraud Field

Hand-eye Calibration

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HandEyeCalibrationMethod Horaud = 2
Public Const Horaud As HandEyeCalibrationMethod = 2
public:
literal HandEyeCalibrationMethod^ Horaud = 2
static val mutable Horaud: HandEyeCalibrationMethod

Field Value

Type: HandEyeCalibrationMethod
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod.Park Field

HandEyeCalibrationMethodPark Field

Robot Sensor Calibration: Solving AX = XB on the Euclidean Group

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HandEyeCalibrationMethod Park = 1
Public Const Park As HandEyeCalibrationMethod = 1
public:
literal HandEyeCalibrationMethod^ Park = 1
static val mutable Park: HandEyeCalibrationMethod

Field Value

Type: HandEyeCalibrationMethod
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod.Tsai Field

HandEyeCalibrationMethodTsai Field

A New Technique for Fully Autonomous and Efficient 3D Robotics Hand/Eye Calibration

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HandEyeCalibrationMethod Tsai = 0
Public Const Tsai As HandEyeCalibrationMethod = 0
public:
literal HandEyeCalibrationMethod^ Tsai = 0
static val mutable Tsai: HandEyeCalibrationMethod

Field Value

Type: HandEyeCalibrationMethod
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HandEyeCalibrationMethod.value__ Field

HandEyeCalibrationMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.HandEyeCalibrationMethod.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

HandEyeCalibrationMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod Class

Histogram comparison method
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumHistogramCompMethod

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class HistogramCompMethod : Enum
Public NotInheritable Class HistogramCompMethod
    Inherits Enum
public ref class HistogramCompMethod sealed : public Enum
[<SealedAttribute>]
type HistogramCompMethod =
    class
        inherit Enum
    end

The HistogramCompMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Bhattacharyya | Bhattacharyya distance
 | Chisqr | Chi-Square
 | ChisqrAlt | Alternative Chi-Square
 | Correl | Correlation
 | Hellinger | Synonym for Bhattacharyya
 | Intersect | Intersection
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


HistogramCompMethod Methods

The HistogramCompMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod Fields

The HistogramCompMethod type exposes the following members.

Fields
 | Name | Description
 | Bhattacharyya | Bhattacharyya distance
 | Chisqr | Chi-Square
 | ChisqrAlt | Alternative Chi-Square
 | Correl | Correlation
 | Hellinger | Synonym for Bhattacharyya
 | Intersect | Intersection
Public field | value__ |
Top
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod.Bhattacharyya Field

HistogramCompMethodBhattacharyya Field

Bhattacharyya distance

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HistogramCompMethod Bhattacharyya = 3
Public Const Bhattacharyya As HistogramCompMethod = 3
public:
literal HistogramCompMethod^ Bhattacharyya = 3
static val mutable Bhattacharyya: HistogramCompMethod

Field Value

Type: HistogramCompMethod
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod.Chisqr Field

HistogramCompMethodChisqr Field

Chi-Square

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HistogramCompMethod Chisqr = 1
Public Const Chisqr As HistogramCompMethod = 1
public:
literal HistogramCompMethod^ Chisqr = 1
static val mutable Chisqr: HistogramCompMethod

Field Value

Type: HistogramCompMethod
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod.ChisqrAlt Field

HistogramCompMethodChisqrAlt Field

Alternative Chi-Square

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HistogramCompMethod ChisqrAlt = 4
Public Const ChisqrAlt As HistogramCompMethod = 4
public:
literal HistogramCompMethod^ ChisqrAlt = 4
static val mutable ChisqrAlt: HistogramCompMethod

Field Value

Type: HistogramCompMethod
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod.Correl Field

HistogramCompMethodCorrel Field

Correlation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HistogramCompMethod Correl = 0
Public Const Correl As HistogramCompMethod = 0
public:
literal HistogramCompMethod^ Correl = 0
static val mutable Correl: HistogramCompMethod

Field Value

Type: HistogramCompMethod
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod.Hellinger Field

HistogramCompMethodHellinger Field

Synonym for Bhattacharyya

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HistogramCompMethod Hellinger = 3
Public Const Hellinger As HistogramCompMethod = 3
public:
literal HistogramCompMethod^ Hellinger = 3
static val mutable Hellinger: HistogramCompMethod

Field Value

Type: HistogramCompMethod
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod.Intersect Field

HistogramCompMethodIntersect Field

Intersection

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HistogramCompMethod Intersect = 2
Public Const Intersect As HistogramCompMethod = 2
public:
literal HistogramCompMethod^ Intersect = 2
static val mutable Intersect: HistogramCompMethod

Field Value

Type: HistogramCompMethod
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HistogramCompMethod.value__ Field

HistogramCompMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.HistogramCompMethod.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

HistogramCompMethod Class
Emgu.CV.CvEnum Namespace


HoughType Class

Hough detection type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumHoughType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class HoughType : Enum
Public NotInheritable Class HoughType
    Inherits Enum
public ref class HoughType sealed : public Enum
[<SealedAttribute>]
type HoughType =
    class
        inherit Enum
    end

The HoughType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Gradient | Gradient
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


HoughType Methods

The HoughType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

HoughType Class
Emgu.CV.CvEnum Namespace


HoughType Fields

The HoughType type exposes the following members.

Fields
 | Name | Description
 | Gradient | Gradient
Public field | value__ |
Top
See Also

Reference

HoughType Class
Emgu.CV.CvEnum Namespace


HoughType.Gradient Field

HoughTypeGradient Field

Gradient

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const HoughType Gradient = 3
Public Const Gradient As HoughType = 3
public:
literal HoughType^ Gradient = 3
static val mutable Gradient: HoughType

Field Value

Type: HoughType
See Also

Reference

HoughType Class
Emgu.CV.CvEnum Namespace


HoughType.value__ Field

HoughTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.HoughType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

HoughType Class
Emgu.CV.CvEnum Namespace


ImreadModes Class

cvLoadImage type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumImreadModes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class ImreadModes : Enum
<FlagsAttribute>
Public NotInheritable Class ImreadModes
    Inherits Enum
[FlagsAttribute]
public ref class ImreadModes sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type ImreadModes =
    class
        inherit Enum
    end

The ImreadModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AnyColor | If set, the image is read in any possible color format.
 | AnyDepth | If set, return 16-bit/32-bit image when the input has the corresponding depth, otherwise convert it to 8-bit.
 | Color | If set, always convert image to the 3 channel BGR color image.
 | Grayscale | If set, always convert image to the single channel grayscale image.
 | LoadGdal | If set, use the gdal driver for loading the image.
 | ReducedColor2 | If set, always convert image to the 3 channel BGR color image and the image size reduced 1/2.
 | ReducedColor4 | If set, always convert image to the 3 channel BGR color image and the image size reduced 1/4.
 | ReducedColor8 | If set, always convert image to the 3 channel BGR color image and the image size reduced 1/8.
 | ReducedGrayscale2 | If set, always convert image to the single channel grayscale image and the image size reduced 1/2.
 | ReducedGrayscale4 | If set, always convert image to the single channel grayscale image and the image size reduced 1/4.
 | ReducedGrayscale8 | If set, always convert image to the single channel grayscale image and the image size reduced 1/8.
 | Unchanged | If set, return the loaded image as is (with alpha channel, otherwise it gets cropped).
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ImreadModes Methods

The ImreadModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes Fields

The ImreadModes type exposes the following members.

Fields
 | Name | Description
 | AnyColor | If set, the image is read in any possible color format.
 | AnyDepth | If set, return 16-bit/32-bit image when the input has the corresponding depth, otherwise convert it to 8-bit.
 | Color | If set, always convert image to the 3 channel BGR color image.
 | Grayscale | If set, always convert image to the single channel grayscale image.
 | LoadGdal | If set, use the gdal driver for loading the image.
 | ReducedColor2 | If set, always convert image to the 3 channel BGR color image and the image size reduced 1/2.
 | ReducedColor4 | If set, always convert image to the 3 channel BGR color image and the image size reduced 1/4.
 | ReducedColor8 | If set, always convert image to the 3 channel BGR color image and the image size reduced 1/8.
 | ReducedGrayscale2 | If set, always convert image to the single channel grayscale image and the image size reduced 1/2.
 | ReducedGrayscale4 | If set, always convert image to the single channel grayscale image and the image size reduced 1/4.
 | ReducedGrayscale8 | If set, always convert image to the single channel grayscale image and the image size reduced 1/8.
 | Unchanged | If set, return the loaded image as is (with alpha channel, otherwise it gets cropped).
Public field | value__ |
Top
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.AnyColor Field

ImreadModesAnyColor Field

If set, the image is read in any possible color format.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes AnyColor = 4
Public Const AnyColor As ImreadModes = 4
public:
literal ImreadModes^ AnyColor = 4
static val mutable AnyColor: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.AnyDepth Field

ImreadModesAnyDepth Field

If set, return 16-bit/32-bit image when the input has the corresponding depth, otherwise convert it to 8-bit.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes AnyDepth = 2
Public Const AnyDepth As ImreadModes = 2
public:
literal ImreadModes^ AnyDepth = 2
static val mutable AnyDepth: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.Color Field

ImreadModesColor Field

If set, always convert image to the 3 channel BGR color image.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes Color = 1
Public Const Color As ImreadModes = 1
public:
literal ImreadModes^ Color = 1
static val mutable Color: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.Grayscale Field

ImreadModesGrayscale Field

If set, always convert image to the single channel grayscale image.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes Grayscale = 0
Public Const Grayscale As ImreadModes = 0
public:
literal ImreadModes^ Grayscale = 0
static val mutable Grayscale: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.LoadGdal Field

ImreadModesLoadGdal Field

If set, use the gdal driver for loading the image.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes LoadGdal = 8
Public Const LoadGdal As ImreadModes = 8
public:
literal ImreadModes^ LoadGdal = 8
static val mutable LoadGdal: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.ReducedColor2 Field

ImreadModesReducedColor2 Field

If set, always convert image to the 3 channel BGR color image and the image size reduced 1/2.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes ReducedColor2 = 17
Public Const ReducedColor2 As ImreadModes = 17
public:
literal ImreadModes^ ReducedColor2 = 17
static val mutable ReducedColor2: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.ReducedColor4 Field

ImreadModesReducedColor4 Field

If set, always convert image to the 3 channel BGR color image and the image size reduced 1/4.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes ReducedColor4 = 33
Public Const ReducedColor4 As ImreadModes = 33
public:
literal ImreadModes^ ReducedColor4 = 33
static val mutable ReducedColor4: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.ReducedColor8 Field

ImreadModesReducedColor8 Field

If set, always convert image to the 3 channel BGR color image and the image size reduced 1/8.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes ReducedColor8 = 65
Public Const ReducedColor8 As ImreadModes = 65
public:
literal ImreadModes^ ReducedColor8 = 65
static val mutable ReducedColor8: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.ReducedGrayscale2 Field

ImreadModesReducedGrayscale2 Field

If set, always convert image to the single channel grayscale image and the image size reduced 1/2.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes ReducedGrayscale2 = 16
Public Const ReducedGrayscale2 As ImreadModes = 16
public:
literal ImreadModes^ ReducedGrayscale2 = 16
static val mutable ReducedGrayscale2: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.ReducedGrayscale4 Field

ImreadModesReducedGrayscale4 Field

If set, always convert image to the single channel grayscale image and the image size reduced 1/4.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes ReducedGrayscale4 = 32
Public Const ReducedGrayscale4 As ImreadModes = 32
public:
literal ImreadModes^ ReducedGrayscale4 = 32
static val mutable ReducedGrayscale4: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.ReducedGrayscale8 Field

ImreadModesReducedGrayscale8 Field

If set, always convert image to the single channel grayscale image and the image size reduced 1/8.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes ReducedGrayscale8 = 64
Public Const ReducedGrayscale8 As ImreadModes = 64
public:
literal ImreadModes^ ReducedGrayscale8 = 64
static val mutable ReducedGrayscale8: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.Unchanged Field

ImreadModesUnchanged Field

If set, return the loaded image as is (with alpha channel, otherwise it gets cropped).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImreadModes Unchanged = -1
Public Const Unchanged As ImreadModes = -1
public:
literal ImreadModes^ Unchanged = -1
static val mutable Unchanged: ImreadModes

Field Value

Type: ImreadModes
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImreadModes.value__ Field

ImreadModesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ImreadModes.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ImreadModes Class
Emgu.CV.CvEnum Namespace


ImwriteFlags Class

Flags for Imwrite function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumImwriteFlags

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class ImwriteFlags : Enum
<FlagsAttribute>
Public NotInheritable Class ImwriteFlags
    Inherits Enum
[FlagsAttribute]
public ref class ImwriteFlags sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type ImwriteFlags =
    class
        inherit Enum
    end

The ImwriteFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | JpegChromaQuality | Separate chroma quality level, 0 - 100, default is 0 - don't use.
 | JpegLumaQuality | Separate luma quality level, 0 - 100, default is 0 - don't use.
 | JpegOptimize | Enable JPEG features, 0 or 1, default is False.
 | JpegProgressive | Enable JPEG features, 0 or 1, default is False.
 | JpegQuality | For JPEG, it can be a quality from 0 to 100 (the higher is the better). Default value is 95.
 | JpegRstInterval | JPEG restart interval, 0 - 65535, default is 0 - no restart.
 | PngBilevel | Binary level PNG, 0 or 1, default is 0.
 | PngCompression | For PNG, it can be the compression level from 0 to 9. A higher value means a smaller size and longer compression time. Default value is 3.
 | PngStrategy | One of cv::ImwritePNGFlags, default is IMWRITE_PNG_STRATEGY_DEFAULT.
 | PxmBinary | For PPM, PGM, or PBM, it can be a binary format flag, 0 or 1. Default value is 1.
Public field | value__ |
 | WebpQuality | For WEBP, it can be a quality from 1 to 100 (the higher is the better). By default (without any parameter) and for quality above 100 the lossless compression is used.
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ImwriteFlags Methods

The ImwriteFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags Fields

The ImwriteFlags type exposes the following members.

Fields
 | Name | Description
 | JpegChromaQuality | Separate chroma quality level, 0 - 100, default is 0 - don't use.
 | JpegLumaQuality | Separate luma quality level, 0 - 100, default is 0 - don't use.
 | JpegOptimize | Enable JPEG features, 0 or 1, default is False.
 | JpegProgressive | Enable JPEG features, 0 or 1, default is False.
 | JpegQuality | For JPEG, it can be a quality from 0 to 100 (the higher is the better). Default value is 95.
 | JpegRstInterval | JPEG restart interval, 0 - 65535, default is 0 - no restart.
 | PngBilevel | Binary level PNG, 0 or 1, default is 0.
 | PngCompression | For PNG, it can be the compression level from 0 to 9. A higher value means a smaller size and longer compression time. Default value is 3.
 | PngStrategy | One of cv::ImwritePNGFlags, default is IMWRITE_PNG_STRATEGY_DEFAULT.
 | PxmBinary | For PPM, PGM, or PBM, it can be a binary format flag, 0 or 1. Default value is 1.
Public field | value__ |
 | WebpQuality | For WEBP, it can be a quality from 1 to 100 (the higher is the better). By default (without any parameter) and for quality above 100 the lossless compression is used.
Top
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.JpegChromaQuality Field

ImwriteFlagsJpegChromaQuality Field

Separate chroma quality level, 0 - 100, default is 0 - don't use.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags JpegChromaQuality = 6
Public Const JpegChromaQuality As ImwriteFlags = 6
public:
literal ImwriteFlags^ JpegChromaQuality = 6
static val mutable JpegChromaQuality: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.JpegLumaQuality Field

ImwriteFlagsJpegLumaQuality Field

Separate luma quality level, 0 - 100, default is 0 - don't use.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags JpegLumaQuality = 5
Public Const JpegLumaQuality As ImwriteFlags = 5
public:
literal ImwriteFlags^ JpegLumaQuality = 5
static val mutable JpegLumaQuality: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.JpegOptimize Field

ImwriteFlagsJpegOptimize Field

Enable JPEG features, 0 or 1, default is False.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags JpegOptimize = 3
Public Const JpegOptimize As ImwriteFlags = 3
public:
literal ImwriteFlags^ JpegOptimize = 3
static val mutable JpegOptimize: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.JpegProgressive Field

ImwriteFlagsJpegProgressive Field

Enable JPEG features, 0 or 1, default is False.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags JpegProgressive = 2
Public Const JpegProgressive As ImwriteFlags = 2
public:
literal ImwriteFlags^ JpegProgressive = 2
static val mutable JpegProgressive: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.JpegQuality Field

ImwriteFlagsJpegQuality Field

For JPEG, it can be a quality from 0 to 100 (the higher is the better). Default value is 95.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags JpegQuality = 1
Public Const JpegQuality As ImwriteFlags = 1
public:
literal ImwriteFlags^ JpegQuality = 1
static val mutable JpegQuality: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.JpegRstInterval Field

ImwriteFlagsJpegRstInterval Field

JPEG restart interval, 0 - 65535, default is 0 - no restart.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags JpegRstInterval = 4
Public Const JpegRstInterval As ImwriteFlags = 4
public:
literal ImwriteFlags^ JpegRstInterval = 4
static val mutable JpegRstInterval: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.PngBilevel Field

ImwriteFlagsPngBilevel Field

Binary level PNG, 0 or 1, default is 0.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags PngBilevel = 18
Public Const PngBilevel As ImwriteFlags = 18
public:
literal ImwriteFlags^ PngBilevel = 18
static val mutable PngBilevel: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.PngCompression Field

ImwriteFlagsPngCompression Field

For PNG, it can be the compression level from 0 to 9. A higher value means a smaller size and longer compression time. Default value is 3.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags PngCompression = 16
Public Const PngCompression As ImwriteFlags = 16
public:
literal ImwriteFlags^ PngCompression = 16
static val mutable PngCompression: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.PngStrategy Field

ImwriteFlagsPngStrategy Field

One of cv::ImwritePNGFlags, default is IMWRITE_PNG_STRATEGY_DEFAULT.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags PngStrategy = 17
Public Const PngStrategy As ImwriteFlags = 17
public:
literal ImwriteFlags^ PngStrategy = 17
static val mutable PngStrategy: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.PxmBinary Field

ImwriteFlagsPxmBinary Field

For PPM, PGM, or PBM, it can be a binary format flag, 0 or 1. Default value is 1.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags PxmBinary = 32
Public Const PxmBinary As ImwriteFlags = 32
public:
literal ImwriteFlags^ PxmBinary = 32
static val mutable PxmBinary: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.value__ Field

ImwriteFlagsvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ImwriteFlags.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


ImwriteFlags.WebpQuality Field

ImwriteFlagsWebpQuality Field

For WEBP, it can be a quality from 1 to 100 (the higher is the better). By default (without any parameter) and for quality above 100 the lossless compression is used.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ImwriteFlags WebpQuality = 64
Public Const WebpQuality As ImwriteFlags = 64
public:
literal ImwriteFlags^ WebpQuality = 64
static val mutable WebpQuality: ImwriteFlags

Field Value

Type: ImwriteFlags
See Also

Reference

ImwriteFlags Class
Emgu.CV.CvEnum Namespace


InpaintType Class

Inpaint type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumInpaintType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InpaintType : Enum
Public NotInheritable Class InpaintType
    Inherits Enum
public ref class InpaintType sealed : public Enum
[<SealedAttribute>]
type InpaintType =
    class
        inherit Enum
    end

The InpaintType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | NS | Navier-Stokes based method.
 | Telea | The method by Alexandru Telea
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


InpaintType Methods

The InpaintType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

InpaintType Class
Emgu.CV.CvEnum Namespace


InpaintType Fields

The InpaintType type exposes the following members.

Fields
 | Name | Description
 | NS | Navier-Stokes based method.
 | Telea | The method by Alexandru Telea
Public field | value__ |
Top
See Also

Reference

InpaintType Class
Emgu.CV.CvEnum Namespace


InpaintType.NS Field

InpaintTypeNS Field

Navier-Stokes based method.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InpaintType NS = 0
Public Const NS As InpaintType = 0
public:
literal InpaintType^ NS = 0
static val mutable NS: InpaintType

Field Value

Type: InpaintType
See Also

Reference

InpaintType Class
Emgu.CV.CvEnum Namespace


InpaintType.Telea Field

InpaintTypeTelea Field

The method by Alexandru Telea

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const InpaintType Telea = 1
Public Const Telea As InpaintType = 1
public:
literal InpaintType^ Telea = 1
static val mutable Telea: InpaintType

Field Value

Type: InpaintType
See Also

Reference

InpaintType Class
Emgu.CV.CvEnum Namespace


InpaintType.value__ Field

InpaintTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.InpaintType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

InpaintType Class
Emgu.CV.CvEnum Namespace


Inter Class

Interpolation types
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumInter

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Inter : Enum
Public NotInheritable Class Inter
    Inherits Enum
public ref class Inter sealed : public Enum
[<SealedAttribute>]
type Inter =
    class
        inherit Enum
    end

The Inter type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Area | Bicubic interpolation
 | Cubic | Resampling using pixel area relation. It is the preferred method for image decimation that gives moire-free results. In case of zooming it is similar to CV_INTER_NN method
 | Lanczos4 | Lanczos interpolation over 8x8 neighborhood
 | Linear | Bilinear interpolation
 | LinearExact | Bit exact bilinear interpolation
 | Nearest | Nearest-neighbor interpolation
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


Inter Methods

The Inter type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter Fields

The Inter type exposes the following members.

Fields
 | Name | Description
 | Area | Bicubic interpolation
 | Cubic | Resampling using pixel area relation. It is the preferred method for image decimation that gives moire-free results. In case of zooming it is similar to CV_INTER_NN method
 | Lanczos4 | Lanczos interpolation over 8x8 neighborhood
 | Linear | Bilinear interpolation
 | LinearExact | Bit exact bilinear interpolation
 | Nearest | Nearest-neighbor interpolation
Public field | value__ |
Top
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter.Area Field

InterArea Field

Bicubic interpolation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Inter Area = 3
Public Const Area As Inter = 3
public:
literal Inter^ Area = 3
static val mutable Area: Inter

Field Value

Type: Inter
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter.Cubic Field

InterCubic Field

Resampling using pixel area relation. It is the preferred method for image decimation that gives moire-free results. In case of zooming it is similar to CV_INTER_NN method

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Inter Cubic = 2
Public Const Cubic As Inter = 2
public:
literal Inter^ Cubic = 2
static val mutable Cubic: Inter

Field Value

Type: Inter
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter.Lanczos4 Field

InterLanczos4 Field

Lanczos interpolation over 8x8 neighborhood

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Inter Lanczos4 = 4
Public Const Lanczos4 As Inter = 4
public:
literal Inter^ Lanczos4 = 4
static val mutable Lanczos4: Inter

Field Value

Type: Inter
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter.Linear Field

InterLinear Field

Bilinear interpolation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Inter Linear = 1
Public Const Linear As Inter = 1
public:
literal Inter^ Linear = 1
static val mutable Linear: Inter

Field Value

Type: Inter
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter.LinearExact Field

InterLinearExact Field

Bit exact bilinear interpolation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Inter LinearExact = 5
Public Const LinearExact As Inter = 5
public:
literal Inter^ LinearExact = 5
static val mutable LinearExact: Inter

Field Value

Type: Inter
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter.Nearest Field

InterNearest Field

Nearest-neighbor interpolation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Inter Nearest = 0
Public Const Nearest As Inter = 0
public:
literal Inter^ Nearest = 0
static val mutable Nearest: Inter

Field Value

Type: Inter
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


Inter.value__ Field

Intervalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.Inter.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Inter Class
Emgu.CV.CvEnum Namespace


IplDepth Class

IPL_DEPTH
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumIplDepth

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IplDepth : Enum
Public NotInheritable Class IplDepth
    Inherits Enum
public ref class IplDepth sealed : public Enum
[<SealedAttribute>]
type IplDepth =
    class
        inherit Enum
    end

The IplDepth type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | IplDepth_1U | 1bit unsigned
 | IplDepth_8S | 8bit signed
 | IplDepth_8U | 8bit unsigned (Byte)
 | IplDepth16S | 16bit signed
 | IplDepth16U | 16bit unsigned
 | IplDepth32F | 32bit float (Single)
 | IplDepth32S | 32bit signed
 | IplDepth64F | double
 | IplDepthSign | Indicates if the value is signed
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


IplDepth Methods

The IplDepth type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth Fields

The IplDepth type exposes the following members.

Fields
 | Name | Description
 | IplDepth_1U | 1bit unsigned
 | IplDepth_8S | 8bit signed
 | IplDepth_8U | 8bit unsigned (Byte)
 | IplDepth16S | 16bit signed
 | IplDepth16U | 16bit unsigned
 | IplDepth32F | 32bit float (Single)
 | IplDepth32S | 32bit signed
 | IplDepth64F | double
 | IplDepthSign | Indicates if the value is signed
Public field | value__ |
Top
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth_1U Field

IplDepthIplDepth_1U Field

1bit unsigned

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth_1U = 1
Public Const IplDepth_1U As IplDepth = 1
public:
literal IplDepth^ IplDepth_1U = 1
static val mutable IplDepth_1U: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth_8S Field

IplDepthIplDepth_8S Field

8bit signed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth_8S = 2147483656
Public Const IplDepth_8S As IplDepth = 2147483656
public:
literal IplDepth^ IplDepth_8S = 2147483656
static val mutable IplDepth_8S: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth_8U Field

IplDepthIplDepth_8U Field

8bit unsigned (Byte)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth_8U = 8
Public Const IplDepth_8U As IplDepth = 8
public:
literal IplDepth^ IplDepth_8U = 8
static val mutable IplDepth_8U: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth16S Field

IplDepthIplDepth16S Field

16bit signed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth16S = 2147483664
Public Const IplDepth16S As IplDepth = 2147483664
public:
literal IplDepth^ IplDepth16S = 2147483664
static val mutable IplDepth16S: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth16U Field

IplDepthIplDepth16U Field

16bit unsigned

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth16U = 16
Public Const IplDepth16U As IplDepth = 16
public:
literal IplDepth^ IplDepth16U = 16
static val mutable IplDepth16U: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth32F Field

IplDepthIplDepth32F Field

32bit float (Single)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth32F = 32
Public Const IplDepth32F As IplDepth = 32
public:
literal IplDepth^ IplDepth32F = 32
static val mutable IplDepth32F: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth32S Field

IplDepthIplDepth32S Field

32bit signed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth32S = 2147483680
Public Const IplDepth32S As IplDepth = 2147483680
public:
literal IplDepth^ IplDepth32S = 2147483680
static val mutable IplDepth32S: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepth64F Field

IplDepthIplDepth64F Field

double

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepth64F = 64
Public Const IplDepth64F As IplDepth = 64
public:
literal IplDepth^ IplDepth64F = 64
static val mutable IplDepth64F: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.IplDepthSign Field

IplDepthIplDepthSign Field

Indicates if the value is signed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const IplDepth IplDepthSign = 2147483648
Public Const IplDepthSign As IplDepth = 2147483648
public:
literal IplDepth^ IplDepthSign = 2147483648
static val mutable IplDepthSign: IplDepth

Field Value

Type: IplDepth
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


IplDepth.value__ Field

IplDepthvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.IplDepth.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public uint value__
Public value__ As UInteger
public:
unsigned int value__
val mutable value__: uint32

Field Value

Type: UInt32
See Also

Reference

IplDepth Class
Emgu.CV.CvEnum Namespace


KMeansInitType Class

KMeans initialization type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumKMeansInitType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class KMeansInitType : Enum
Public NotInheritable Class KMeansInitType
    Inherits Enum
public ref class KMeansInitType sealed : public Enum
[<SealedAttribute>]
type KMeansInitType =
    class
        inherit Enum
    end

The KMeansInitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | PPCenters | Uses k-Means++ algorithm for initialization
 | RandomCenters | Chooses random centers for k-Means initialization
 | UseInitialLabels | Uses the user-provided labels for K-Means initialization
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


KMeansInitType Methods

The KMeansInitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

KMeansInitType Class
Emgu.CV.CvEnum Namespace


KMeansInitType Fields

The KMeansInitType type exposes the following members.

Fields
 | Name | Description
 | PPCenters | Uses k-Means++ algorithm for initialization
 | RandomCenters | Chooses random centers for k-Means initialization
 | UseInitialLabels | Uses the user-provided labels for K-Means initialization
Public field | value__ |
Top
See Also

Reference

KMeansInitType Class
Emgu.CV.CvEnum Namespace


KMeansInitType.PPCenters Field

KMeansInitTypePPCenters Field

Uses k-Means++ algorithm for initialization

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KMeansInitType PPCenters = 2
Public Const PPCenters As KMeansInitType = 2
public:
literal KMeansInitType^ PPCenters = 2
static val mutable PPCenters: KMeansInitType

Field Value

Type: KMeansInitType
See Also

Reference

KMeansInitType Class
Emgu.CV.CvEnum Namespace


KMeansInitType.RandomCenters Field

KMeansInitTypeRandomCenters Field

Chooses random centers for k-Means initialization

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KMeansInitType RandomCenters = 0
Public Const RandomCenters As KMeansInitType = 0
public:
literal KMeansInitType^ RandomCenters = 0
static val mutable RandomCenters: KMeansInitType

Field Value

Type: KMeansInitType
See Also

Reference

KMeansInitType Class
Emgu.CV.CvEnum Namespace


KMeansInitType.UseInitialLabels Field

KMeansInitTypeUseInitialLabels Field

Uses the user-provided labels for K-Means initialization

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KMeansInitType UseInitialLabels = 1
Public Const UseInitialLabels As KMeansInitType = 1
public:
literal KMeansInitType^ UseInitialLabels = 1
static val mutable UseInitialLabels: KMeansInitType

Field Value

Type: KMeansInitType
See Also

Reference

KMeansInitType Class
Emgu.CV.CvEnum Namespace


KMeansInitType.value__ Field

KMeansInitTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.KMeansInitType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

KMeansInitType Class
Emgu.CV.CvEnum Namespace


LineType Class

The type of line for drawing
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumLineType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LineType : Enum
Public NotInheritable Class LineType
    Inherits Enum
public ref class LineType sealed : public Enum
[<SealedAttribute>]
type LineType =
    class
        inherit Enum
    end

The LineType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AntiAlias | Anti-alias
 | EightConnected | 8-connected
 | Filled | Filled
 | FourConnected | 4-connected
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


LineType Methods

The LineType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

LineType Class
Emgu.CV.CvEnum Namespace


LineType Fields

The LineType type exposes the following members.

Fields
 | Name | Description
 | AntiAlias | Anti-alias
 | EightConnected | 8-connected
 | Filled | Filled
 | FourConnected | 4-connected
Public field | value__ |
Top
See Also

Reference

LineType Class
Emgu.CV.CvEnum Namespace


LineType.AntiAlias Field

LineTypeAntiAlias Field

Anti-alias

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LineType AntiAlias = 16
Public Const AntiAlias As LineType = 16
public:
literal LineType^ AntiAlias = 16
static val mutable AntiAlias: LineType

Field Value

Type: LineType
See Also

Reference

LineType Class
Emgu.CV.CvEnum Namespace


LineType.EightConnected Field

LineTypeEightConnected Field

8-connected

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LineType EightConnected = 8
Public Const EightConnected As LineType = 8
public:
literal LineType^ EightConnected = 8
static val mutable EightConnected: LineType

Field Value

Type: LineType
See Also

Reference

LineType Class
Emgu.CV.CvEnum Namespace


LineType.Filled Field

LineTypeFilled Field

Filled

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LineType Filled = -1
Public Const Filled As LineType = -1
public:
literal LineType^ Filled = -1
static val mutable Filled: LineType

Field Value

Type: LineType
See Also

Reference

LineType Class
Emgu.CV.CvEnum Namespace


LineType.FourConnected Field

LineTypeFourConnected Field

4-connected

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LineType FourConnected = 4
Public Const FourConnected As LineType = 4
public:
literal LineType^ FourConnected = 4
static val mutable FourConnected: LineType

Field Value

Type: LineType
See Also

Reference

LineType Class
Emgu.CV.CvEnum Namespace


LineType.value__ Field

LineTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.LineType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

LineType Class
Emgu.CV.CvEnum Namespace


LKFlowFlag Class

Type for cvCalcOpticalFlowPyrLK
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumLKFlowFlag

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LKFlowFlag : Enum
Public NotInheritable Class LKFlowFlag
    Inherits Enum
public ref class LKFlowFlag sealed : public Enum
[<SealedAttribute>]
type LKFlowFlag =
    class
        inherit Enum
    end

The LKFlowFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The default type
 | LKGetMinEigenvals | use minimum eigen values as an error measure (see minEigThreshold description); if the flag is not set, then L1 distance between patches around the original and a moved point, divided by number of pixels in a window, is used as a error measure.
 | UserInitialFlow | Uses initial estimations, stored in nextPts; if the flag is not set, then prevPts is copied to nextPts and is considered the initial estimate.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


LKFlowFlag Methods

The LKFlowFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

LKFlowFlag Class
Emgu.CV.CvEnum Namespace


LKFlowFlag Fields

The LKFlowFlag type exposes the following members.

Fields
 | Name | Description
 | Default | The default type
 | LKGetMinEigenvals | use minimum eigen values as an error measure (see minEigThreshold description); if the flag is not set, then L1 distance between patches around the original and a moved point, divided by number of pixels in a window, is used as a error measure.
 | UserInitialFlow | Uses initial estimations, stored in nextPts; if the flag is not set, then prevPts is copied to nextPts and is considered the initial estimate.
Public field | value__ |
Top
See Also

Reference

LKFlowFlag Class
Emgu.CV.CvEnum Namespace


LKFlowFlag.Default Field

LKFlowFlagDefault Field

The default type

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LKFlowFlag Default = 0
Public Const Default As LKFlowFlag = 0
public:
literal LKFlowFlag^ Default = 0
static val mutable Default: LKFlowFlag

Field Value

Type: LKFlowFlag
See Also

Reference

LKFlowFlag Class
Emgu.CV.CvEnum Namespace


LKFlowFlag.LKGetMinEigenvals Field

LKFlowFlagLKGetMinEigenvals Field

use minimum eigen values as an error measure (see minEigThreshold description); if the flag is not set, then L1 distance between patches around the original and a moved point, divided by number of pixels in a window, is used as a error measure.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LKFlowFlag LKGetMinEigenvals = 8
Public Const LKGetMinEigenvals As LKFlowFlag = 8
public:
literal LKFlowFlag^ LKGetMinEigenvals = 8
static val mutable LKGetMinEigenvals: LKFlowFlag

Field Value

Type: LKFlowFlag
See Also

Reference

LKFlowFlag Class
Emgu.CV.CvEnum Namespace


LKFlowFlag.UserInitialFlow Field

LKFlowFlagUserInitialFlow Field

Uses initial estimations, stored in nextPts; if the flag is not set, then prevPts is copied to nextPts and is considered the initial estimate.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LKFlowFlag UserInitialFlow = 4
Public Const UserInitialFlow As LKFlowFlag = 4
public:
literal LKFlowFlag^ UserInitialFlow = 4
static val mutable UserInitialFlow: LKFlowFlag

Field Value

Type: LKFlowFlag
See Also

Reference

LKFlowFlag Class
Emgu.CV.CvEnum Namespace


LKFlowFlag.value__ Field

LKFlowFlagvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.LKFlowFlag.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

LKFlowFlag Class
Emgu.CV.CvEnum Namespace


MarkerTypes Class

The type of Marker for drawing
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumMarkerTypes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MarkerTypes : Enum
Public NotInheritable Class MarkerTypes
    Inherits Enum
public ref class MarkerTypes sealed : public Enum
[<SealedAttribute>]
type MarkerTypes =
    class
        inherit Enum
    end

The MarkerTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cross | A crosshair marker shape
 | Diamond | A diamond marker shape
 | Square | A square marker shape
 | Star | A star marker shape, combination of cross and tilted cross
 | TiltedCross | A 45 degree tilted crosshair marker shape
 | TriangleDown | A downwards pointing triangle marker shape
 | TriangleUp | An upwards pointing triangle marker shape
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


MarkerTypes Methods

The MarkerTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes Fields

The MarkerTypes type exposes the following members.

Fields
 | Name | Description
 | Cross | A crosshair marker shape
 | Diamond | A diamond marker shape
 | Square | A square marker shape
 | Star | A star marker shape, combination of cross and tilted cross
 | TiltedCross | A 45 degree tilted crosshair marker shape
 | TriangleDown | A downwards pointing triangle marker shape
 | TriangleUp | An upwards pointing triangle marker shape
Public field | value__ |
Top
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.Cross Field

MarkerTypesCross Field

A crosshair marker shape

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MarkerTypes Cross = 0
Public Const Cross As MarkerTypes = 0
public:
literal MarkerTypes^ Cross = 0
static val mutable Cross: MarkerTypes

Field Value

Type: MarkerTypes
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.Diamond Field

MarkerTypesDiamond Field

A diamond marker shape

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MarkerTypes Diamond = 3
Public Const Diamond As MarkerTypes = 3
public:
literal MarkerTypes^ Diamond = 3
static val mutable Diamond: MarkerTypes

Field Value

Type: MarkerTypes
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.Square Field

MarkerTypesSquare Field

A square marker shape

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MarkerTypes Square = 4
Public Const Square As MarkerTypes = 4
public:
literal MarkerTypes^ Square = 4
static val mutable Square: MarkerTypes

Field Value

Type: MarkerTypes
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.Star Field

MarkerTypesStar Field

A star marker shape, combination of cross and tilted cross

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MarkerTypes Star = 2
Public Const Star As MarkerTypes = 2
public:
literal MarkerTypes^ Star = 2
static val mutable Star: MarkerTypes

Field Value

Type: MarkerTypes
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.TiltedCross Field

MarkerTypesTiltedCross Field

A 45 degree tilted crosshair marker shape

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MarkerTypes TiltedCross = 1
Public Const TiltedCross As MarkerTypes = 1
public:
literal MarkerTypes^ TiltedCross = 1
static val mutable TiltedCross: MarkerTypes

Field Value

Type: MarkerTypes
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.TriangleDown Field

MarkerTypesTriangleDown Field

A downwards pointing triangle marker shape

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MarkerTypes TriangleDown = 6
Public Const TriangleDown As MarkerTypes = 6
public:
literal MarkerTypes^ TriangleDown = 6
static val mutable TriangleDown: MarkerTypes

Field Value

Type: MarkerTypes
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.TriangleUp Field

MarkerTypesTriangleUp Field

An upwards pointing triangle marker shape

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MarkerTypes TriangleUp = 5
Public Const TriangleUp As MarkerTypes = 5
public:
literal MarkerTypes^ TriangleUp = 5
static val mutable TriangleUp: MarkerTypes

Field Value

Type: MarkerTypes
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MarkerTypes.value__ Field

MarkerTypesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.MarkerTypes.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

MarkerTypes Class
Emgu.CV.CvEnum Namespace


MorphOp Class

Morphology operation type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumMorphOp

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MorphOp : Enum
Public NotInheritable Class MorphOp
    Inherits Enum
public ref class MorphOp sealed : public Enum
[<SealedAttribute>]
type MorphOp =
    class
        inherit Enum
    end

The MorphOp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Blackhat | Black hat
 | Close | Close
 | Dilate | Dilate
 | Erode | Erode
 | Gradient | Gradient
 | HitMiss | Hit or miss. Only supported for CV_8UC1 binary images.
 | Open | Open
 | Tophat | Top hat
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


MorphOp Methods

The MorphOp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp Fields

The MorphOp type exposes the following members.

Fields
 | Name | Description
 | Blackhat | Black hat
 | Close | Close
 | Dilate | Dilate
 | Erode | Erode
 | Gradient | Gradient
 | HitMiss | Hit or miss. Only supported for CV_8UC1 binary images.
 | Open | Open
 | Tophat | Top hat
Public field | value__ |
Top
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.Blackhat Field

MorphOpBlackhat Field

Black hat

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp Blackhat = 6
Public Const Blackhat As MorphOp = 6
public:
literal MorphOp^ Blackhat = 6
static val mutable Blackhat: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.Close Field

MorphOpClose Field

Close

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp Close = 3
Public Const Close As MorphOp = 3
public:
literal MorphOp^ Close = 3
static val mutable Close: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.Dilate Field

MorphOpDilate Field

Dilate

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp Dilate = 1
Public Const Dilate As MorphOp = 1
public:
literal MorphOp^ Dilate = 1
static val mutable Dilate: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.Erode Field

MorphOpErode Field

Erode

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp Erode = 0
Public Const Erode As MorphOp = 0
public:
literal MorphOp^ Erode = 0
static val mutable Erode: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.Gradient Field

MorphOpGradient Field

Gradient

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp Gradient = 4
Public Const Gradient As MorphOp = 4
public:
literal MorphOp^ Gradient = 4
static val mutable Gradient: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.HitMiss Field

MorphOpHitMiss Field

Hit or miss. Only supported for CV_8UC1 binary images.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp HitMiss = 7
Public Const HitMiss As MorphOp = 7
public:
literal MorphOp^ HitMiss = 7
static val mutable HitMiss: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.Open Field

MorphOpOpen Field

Open

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp Open = 2
Public Const Open As MorphOp = 2
public:
literal MorphOp^ Open = 2
static val mutable Open: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.Tophat Field

MorphOpTophat Field

Top hat

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MorphOp Tophat = 5
Public Const Tophat As MorphOp = 5
public:
literal MorphOp^ Tophat = 5
static val mutable Tophat: MorphOp

Field Value

Type: MorphOp
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MorphOp.value__ Field

MorphOpvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.MorphOp.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

MorphOp Class
Emgu.CV.CvEnum Namespace


MotionType Class

Motion type for the FindTransformECC function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumMotionType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MotionType : Enum
Public NotInheritable Class MotionType
    Inherits Enum
public ref class MotionType sealed : public Enum
[<SealedAttribute>]
type MotionType =
    class
        inherit Enum
    end

The MotionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Affine | Sets an affine motion model (DEFAULT); six parameters are estimated; warpMatrix is 2x3.
 | Euclidean | Sets a Euclidean (rigid) transformation as motion model; three parameters are estimated; warpMatrix is 2x3.
 | Homography | Sets a homography as a motion model; eight parameters are estimated; warpMatrix is 3x3.
 | Translation | Sets a translational motion model; warpMatrix is 2x3 with the first 2x2 part being the unity matrix and the rest two parameters being estimated.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


MotionType Methods

The MotionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

MotionType Class
Emgu.CV.CvEnum Namespace


MotionType Fields

The MotionType type exposes the following members.

Fields
 | Name | Description
 | Affine | Sets an affine motion model (DEFAULT); six parameters are estimated; warpMatrix is 2x3.
 | Euclidean | Sets a Euclidean (rigid) transformation as motion model; three parameters are estimated; warpMatrix is 2x3.
 | Homography | Sets a homography as a motion model; eight parameters are estimated; warpMatrix is 3x3.
 | Translation | Sets a translational motion model; warpMatrix is 2x3 with the first 2x2 part being the unity matrix and the rest two parameters being estimated.
Public field | value__ |
Top
See Also

Reference

MotionType Class
Emgu.CV.CvEnum Namespace


MotionType.Affine Field

MotionTypeAffine Field

Sets an affine motion model (DEFAULT); six parameters are estimated; warpMatrix is 2x3.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MotionType Affine = 2
Public Const Affine As MotionType = 2
public:
literal MotionType^ Affine = 2
static val mutable Affine: MotionType

Field Value

Type: MotionType
See Also

Reference

MotionType Class
Emgu.CV.CvEnum Namespace


MotionType.Euclidean Field

MotionTypeEuclidean Field

Sets a Euclidean (rigid) transformation as motion model; three parameters are estimated; warpMatrix is 2x3.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MotionType Euclidean = 1
Public Const Euclidean As MotionType = 1
public:
literal MotionType^ Euclidean = 1
static val mutable Euclidean: MotionType

Field Value

Type: MotionType
See Also

Reference

MotionType Class
Emgu.CV.CvEnum Namespace


MotionType.Homography Field

MotionTypeHomography Field

Sets a homography as a motion model; eight parameters are estimated; warpMatrix is 3x3.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MotionType Homography = 3
Public Const Homography As MotionType = 3
public:
literal MotionType^ Homography = 3
static val mutable Homography: MotionType

Field Value

Type: MotionType
See Also

Reference

MotionType Class
Emgu.CV.CvEnum Namespace


MotionType.Translation Field

MotionTypeTranslation Field

Sets a translational motion model; warpMatrix is 2x3 with the first 2x2 part being the unity matrix and the rest two parameters being estimated.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MotionType Translation = 0
Public Const Translation As MotionType = 0
public:
literal MotionType^ Translation = 0
static val mutable Translation: MotionType

Field Value

Type: MotionType
See Also

Reference

MotionType Class
Emgu.CV.CvEnum Namespace


MotionType.value__ Field

MotionTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.MotionType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

MotionType Class
Emgu.CV.CvEnum Namespace


MulSpectrumsType Class

The types for MulSpectrums
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumMulSpectrumsType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class MulSpectrumsType : Enum
<FlagsAttribute>
Public NotInheritable Class MulSpectrumsType
    Inherits Enum
[FlagsAttribute]
public ref class MulSpectrumsType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type MulSpectrumsType =
    class
        inherit Enum
    end

The MulSpectrumsType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The default type
 | DxtMulConj | Conjugate the second argument of cvMulSpectrums
 | DxtRows | Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


MulSpectrumsType Methods

The MulSpectrumsType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

MulSpectrumsType Class
Emgu.CV.CvEnum Namespace


MulSpectrumsType Fields

The MulSpectrumsType type exposes the following members.

Fields
 | Name | Description
 | Default | The default type
 | DxtMulConj | Conjugate the second argument of cvMulSpectrums
 | DxtRows | Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc
Public field | value__ |
Top
See Also

Reference

MulSpectrumsType Class
Emgu.CV.CvEnum Namespace


MulSpectrumsType.Default Field

MulSpectrumsTypeDefault Field

The default type

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MulSpectrumsType Default = 0
Public Const Default As MulSpectrumsType = 0
public:
literal MulSpectrumsType^ Default = 0
static val mutable Default: MulSpectrumsType

Field Value

Type: MulSpectrumsType
See Also

Reference

MulSpectrumsType Class
Emgu.CV.CvEnum Namespace


MulSpectrumsType.DxtMulConj Field

MulSpectrumsTypeDxtMulConj Field

Conjugate the second argument of cvMulSpectrums

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MulSpectrumsType DxtMulConj = 8
Public Const DxtMulConj As MulSpectrumsType = 8
public:
literal MulSpectrumsType^ DxtMulConj = 8
static val mutable DxtMulConj: MulSpectrumsType

Field Value

Type: MulSpectrumsType
See Also

Reference

MulSpectrumsType Class
Emgu.CV.CvEnum Namespace


MulSpectrumsType.DxtRows Field

MulSpectrumsTypeDxtRows Field

Do forward or inverse transform of every individual row of the input matrix. This flag allows user to transform multiple vectors simultaneously and can be used to decrease the overhead (which is sometimes several times larger than the processing itself), to do 3D and higher-dimensional transforms etc

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const MulSpectrumsType DxtRows = 4
Public Const DxtRows As MulSpectrumsType = 4
public:
literal MulSpectrumsType^ DxtRows = 4
static val mutable DxtRows: MulSpectrumsType

Field Value

Type: MulSpectrumsType
See Also

Reference

MulSpectrumsType Class
Emgu.CV.CvEnum Namespace


MulSpectrumsType.value__ Field

MulSpectrumsTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.MulSpectrumsType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

MulSpectrumsType Class
Emgu.CV.CvEnum Namespace


NamedWindowType Class

The named window type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumNamedWindowType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NamedWindowType : Enum
Public NotInheritable Class NamedWindowType
    Inherits Enum
public ref class NamedWindowType sealed : public Enum
[<SealedAttribute>]
type NamedWindowType =
    class
        inherit Enum
    end

The NamedWindowType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AutoSize | The user cannot resize the window, the size is constrainted by the image displayed
 | FreeRatio | The image expends as much as it can (no ratio constraint)
 | Fullscreen | Change the window to fullscreen
 | KeepRatio | the ratio of the image is respected
 | Normal | The user can resize the window (no constraint) / also use to switch a fullscreen window to a normal size
 | Opengl | Window with opengl support
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


NamedWindowType Methods

The NamedWindowType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType Fields

The NamedWindowType type exposes the following members.

Fields
 | Name | Description
 | AutoSize | The user cannot resize the window, the size is constrainted by the image displayed
 | FreeRatio | The image expends as much as it can (no ratio constraint)
 | Fullscreen | Change the window to fullscreen
 | KeepRatio | the ratio of the image is respected
 | Normal | The user can resize the window (no constraint) / also use to switch a fullscreen window to a normal size
 | Opengl | Window with opengl support
Public field | value__ |
Top
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType.AutoSize Field

NamedWindowTypeAutoSize Field

The user cannot resize the window, the size is constrainted by the image displayed

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NamedWindowType AutoSize = 1
Public Const AutoSize As NamedWindowType = 1
public:
literal NamedWindowType^ AutoSize = 1
static val mutable AutoSize: NamedWindowType

Field Value

Type: NamedWindowType
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType.FreeRatio Field

NamedWindowTypeFreeRatio Field

The image expends as much as it can (no ratio constraint)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NamedWindowType FreeRatio = 256
Public Const FreeRatio As NamedWindowType = 256
public:
literal NamedWindowType^ FreeRatio = 256
static val mutable FreeRatio: NamedWindowType

Field Value

Type: NamedWindowType
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType.Fullscreen Field

NamedWindowTypeFullscreen Field

Change the window to fullscreen

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NamedWindowType Fullscreen = 1
Public Const Fullscreen As NamedWindowType = 1
public:
literal NamedWindowType^ Fullscreen = 1
static val mutable Fullscreen: NamedWindowType

Field Value

Type: NamedWindowType
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType.KeepRatio Field

NamedWindowTypeKeepRatio Field

the ratio of the image is respected

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NamedWindowType KeepRatio = 0
Public Const KeepRatio As NamedWindowType = 0
public:
literal NamedWindowType^ KeepRatio = 0
static val mutable KeepRatio: NamedWindowType

Field Value

Type: NamedWindowType
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType.Normal Field

NamedWindowTypeNormal Field

The user can resize the window (no constraint) / also use to switch a fullscreen window to a normal size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NamedWindowType Normal = 0
Public Const Normal As NamedWindowType = 0
public:
literal NamedWindowType^ Normal = 0
static val mutable Normal: NamedWindowType

Field Value

Type: NamedWindowType
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType.Opengl Field

NamedWindowTypeOpengl Field

Window with opengl support

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NamedWindowType Opengl = 4096
Public Const Opengl As NamedWindowType = 4096
public:
literal NamedWindowType^ Opengl = 4096
static val mutable Opengl: NamedWindowType

Field Value

Type: NamedWindowType
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NamedWindowType.value__ Field

NamedWindowTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.NamedWindowType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

NamedWindowType Class
Emgu.CV.CvEnum Namespace


NormType Class

Type for Norm
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumNormType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class NormType : Enum
<FlagsAttribute>
Public NotInheritable Class NormType
    Inherits Enum
[FlagsAttribute]
public ref class NormType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type NormType =
    class
        inherit Enum
    end

The NormType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | C | if arr2 is NULL, norm = ||arr1||_C = max_I abs(arr1(I)); if arr2 is not NULL, norm = ||arr1-arr2||_C = max_I abs(arr1(I)-arr2(I))
 | Diff | It is used in combination with either CV_C, CV_L1 or CV_L2
 | DiffC | Diff C
 | DiffL1 | Diff L1
 | DiffL2 | Diff L2
 | L1 | if arr2 is NULL, norm = ||arr1||_L1 = sum_I abs(arr1(I)); if arr2 is not NULL, norm = ||arr1-arr2||_L1 = sum_I abs(arr1(I)-arr2(I))
 | L2 | if arr2 is NULL, norm = ||arr1||_L2 = sqrt( sum_I arr1(I)^2); if arr2 is not NULL, norm = ||arr1-arr2||_L2 = sqrt( sum_I (arr1(I)-arr2(I))^2 )
 | MinMax | Min Max
 | NormMask | Norm mask
 | Relative | It is used in combination with either CV_C, CV_L1 or CV_L2
 | RelativeC | norm = ||arr1-arr2||_C/||arr2||_C
 | RelativeL1 | norm = ||arr1-arr2||_L1/||arr2||_L1
 | RelativeL2 | norm = ||arr1-arr2||_L2/||arr2||_L2
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


NormType Methods

The NormType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType Fields

The NormType type exposes the following members.

Fields
 | Name | Description
 | C | if arr2 is NULL, norm = ||arr1||_C = max_I abs(arr1(I)); if arr2 is not NULL, norm = ||arr1-arr2||_C = max_I abs(arr1(I)-arr2(I))
 | Diff | It is used in combination with either CV_C, CV_L1 or CV_L2
 | DiffC | Diff C
 | DiffL1 | Diff L1
 | DiffL2 | Diff L2
 | L1 | if arr2 is NULL, norm = ||arr1||_L1 = sum_I abs(arr1(I)); if arr2 is not NULL, norm = ||arr1-arr2||_L1 = sum_I abs(arr1(I)-arr2(I))
 | L2 | if arr2 is NULL, norm = ||arr1||_L2 = sqrt( sum_I arr1(I)^2); if arr2 is not NULL, norm = ||arr1-arr2||_L2 = sqrt( sum_I (arr1(I)-arr2(I))^2 )
 | MinMax | Min Max
 | NormMask | Norm mask
 | Relative | It is used in combination with either CV_C, CV_L1 or CV_L2
 | RelativeC | norm = ||arr1-arr2||_C/||arr2||_C
 | RelativeL1 | norm = ||arr1-arr2||_L1/||arr2||_L1
 | RelativeL2 | norm = ||arr1-arr2||_L2/||arr2||_L2
Public field | value__ |
Top
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.C Field

NormTypeC Field

if arr2 is NULL, norm = ||arr1||_C = max_I abs(arr1(I)); if arr2 is not NULL, norm = ||arr1-arr2||_C = max_I abs(arr1(I)-arr2(I))

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType C = 1
Public Const C As NormType = 1
public:
literal NormType^ C = 1
static val mutable C: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.Diff Field

NormTypeDiff Field

It is used in combination with either CV_C, CV_L1 or CV_L2

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType Diff = 16
Public Const Diff As NormType = 16
public:
literal NormType^ Diff = 16
static val mutable Diff: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.DiffC Field

NormTypeDiffC Field

Diff C

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType DiffC = 17
Public Const DiffC As NormType = 17
public:
literal NormType^ DiffC = 17
static val mutable DiffC: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.DiffL1 Field

NormTypeDiffL1 Field

Diff L1

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType DiffL1 = 18
Public Const DiffL1 As NormType = 18
public:
literal NormType^ DiffL1 = 18
static val mutable DiffL1: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.DiffL2 Field

NormTypeDiffL2 Field

Diff L2

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType DiffL2 = 20
Public Const DiffL2 As NormType = 20
public:
literal NormType^ DiffL2 = 20
static val mutable DiffL2: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.L1 Field

NormTypeL1 Field

if arr2 is NULL, norm = ||arr1||_L1 = sum_I abs(arr1(I)); if arr2 is not NULL, norm = ||arr1-arr2||_L1 = sum_I abs(arr1(I)-arr2(I))

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType L1 = 2
Public Const L1 As NormType = 2
public:
literal NormType^ L1 = 2
static val mutable L1: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.L2 Field

NormTypeL2 Field

if arr2 is NULL, norm = ||arr1||_L2 = sqrt( sum_I arr1(I)^2); if arr2 is not NULL, norm = ||arr1-arr2||_L2 = sqrt( sum_I (arr1(I)-arr2(I))^2 )

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType L2 = 4
Public Const L2 As NormType = 4
public:
literal NormType^ L2 = 4
static val mutable L2: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.MinMax Field

NormTypeMinMax Field

Min Max

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType MinMax = 32
Public Const MinMax As NormType = 32
public:
literal NormType^ MinMax = 32
static val mutable MinMax: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.NormMask Field

NormTypeNormMask Field

Norm mask

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType NormMask = 7
Public Const NormMask As NormType = 7
public:
literal NormType^ NormMask = 7
static val mutable NormMask: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.Relative Field

NormTypeRelative Field

It is used in combination with either CV_C, CV_L1 or CV_L2

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType Relative = 8
Public Const Relative As NormType = 8
public:
literal NormType^ Relative = 8
static val mutable Relative: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.RelativeC Field

NormTypeRelativeC Field

norm = ||arr1-arr2||_C/||arr2||_C

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType RelativeC = 9
Public Const RelativeC As NormType = 9
public:
literal NormType^ RelativeC = 9
static val mutable RelativeC: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.RelativeL1 Field

NormTypeRelativeL1 Field

norm = ||arr1-arr2||_L1/||arr2||_L1

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType RelativeL1 = 10
Public Const RelativeL1 As NormType = 10
public:
literal NormType^ RelativeL1 = 10
static val mutable RelativeL1: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.RelativeL2 Field

NormTypeRelativeL2 Field

norm = ||arr1-arr2||_L2/||arr2||_L2

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const NormType RelativeL2 = 12
Public Const RelativeL2 As NormType = 12
public:
literal NormType^ RelativeL2 = 12
static val mutable RelativeL2: NormType

Field Value

Type: NormType
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


NormType.value__ Field

NormTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.NormType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

NormType Class
Emgu.CV.CvEnum Namespace


OpticalflowFarnebackFlag Class

The available flags for Farneback optical flow computation
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumOpticalflowFarnebackFlag

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class OpticalflowFarnebackFlag : Enum
<FlagsAttribute>
Public NotInheritable Class OpticalflowFarnebackFlag
    Inherits Enum
[FlagsAttribute]
public ref class OpticalflowFarnebackFlag sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type OpticalflowFarnebackFlag =
    class
        inherit Enum
    end

The OpticalflowFarnebackFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Default
 | FarnebackGaussian | Use a Gaussian winsize x winsizefilter instead of box filter of the same size for optical flow estimation. Usually, this option gives more accurate flow than with a box filter, at the cost of lower speed (and normally winsize for a Gaussian window should be set to a larger value to achieve the same level of robustness)
 | UseInitialFlow | Use the input flow as the initial flow approximation
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


OpticalflowFarnebackFlag Methods

The OpticalflowFarnebackFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

OpticalflowFarnebackFlag Class
Emgu.CV.CvEnum Namespace


OpticalflowFarnebackFlag Fields

The OpticalflowFarnebackFlag type exposes the following members.

Fields
 | Name | Description
 | Default | Default
 | FarnebackGaussian | Use a Gaussian winsize x winsizefilter instead of box filter of the same size for optical flow estimation. Usually, this option gives more accurate flow than with a box filter, at the cost of lower speed (and normally winsize for a Gaussian window should be set to a larger value to achieve the same level of robustness)
 | UseInitialFlow | Use the input flow as the initial flow approximation
Public field | value__ |
Top
See Also

Reference

OpticalflowFarnebackFlag Class
Emgu.CV.CvEnum Namespace


OpticalflowFarnebackFlag.Default Field

OpticalflowFarnebackFlagDefault Field

Default

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OpticalflowFarnebackFlag Default = 0
Public Const Default As OpticalflowFarnebackFlag = 0
public:
literal OpticalflowFarnebackFlag^ Default = 0
static val mutable Default: OpticalflowFarnebackFlag

Field Value

Type: OpticalflowFarnebackFlag
See Also

Reference

OpticalflowFarnebackFlag Class
Emgu.CV.CvEnum Namespace


OpticalflowFarnebackFlag.FarnebackGaussian Field

OpticalflowFarnebackFlagFarnebackGaussian Field

Use a Gaussian winsize x winsizefilter instead of box filter of the same size for optical flow estimation. Usually, this option gives more accurate flow than with a box filter, at the cost of lower speed (and normally winsize for a Gaussian window should be set to a larger value to achieve the same level of robustness)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OpticalflowFarnebackFlag FarnebackGaussian = 256
Public Const FarnebackGaussian As OpticalflowFarnebackFlag = 256
public:
literal OpticalflowFarnebackFlag^ FarnebackGaussian = 256
static val mutable FarnebackGaussian: OpticalflowFarnebackFlag

Field Value

Type: OpticalflowFarnebackFlag
See Also

Reference

OpticalflowFarnebackFlag Class
Emgu.CV.CvEnum Namespace


OpticalflowFarnebackFlag.UseInitialFlow Field

OpticalflowFarnebackFlagUseInitialFlow Field

Use the input flow as the initial flow approximation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OpticalflowFarnebackFlag UseInitialFlow = 4
Public Const UseInitialFlow As OpticalflowFarnebackFlag = 4
public:
literal OpticalflowFarnebackFlag^ UseInitialFlow = 4
static val mutable UseInitialFlow: OpticalflowFarnebackFlag

Field Value

Type: OpticalflowFarnebackFlag
See Also

Reference

OpticalflowFarnebackFlag Class
Emgu.CV.CvEnum Namespace


OpticalflowFarnebackFlag.value__ Field

OpticalflowFarnebackFlagvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.OpticalflowFarnebackFlag.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

OpticalflowFarnebackFlag Class
Emgu.CV.CvEnum Namespace


Orientation Class

Orientation
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumOrientation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Orientation : Enum
Public NotInheritable Class Orientation
    Inherits Enum
public ref class Orientation sealed : public Enum
[<SealedAttribute>]
type Orientation =
    class
        inherit Enum
    end

The Orientation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Clockwise | Clockwise
 | CounterClockwise | Counter clockwise
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


Orientation Methods

The Orientation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Orientation Class
Emgu.CV.CvEnum Namespace


Orientation Fields

The Orientation type exposes the following members.

Fields
 | Name | Description
 | Clockwise | Clockwise
 | CounterClockwise | Counter clockwise
Public field | value__ |
Top
See Also

Reference

Orientation Class
Emgu.CV.CvEnum Namespace


Orientation.Clockwise Field

OrientationClockwise Field

Clockwise

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Orientation Clockwise = 1
Public Const Clockwise As Orientation = 1
public:
literal Orientation^ Clockwise = 1
static val mutable Clockwise: Orientation

Field Value

Type: Orientation
See Also

Reference

Orientation Class
Emgu.CV.CvEnum Namespace


Orientation.CounterClockwise Field

OrientationCounterClockwise Field

Counter clockwise

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Orientation CounterClockwise = 2
Public Const CounterClockwise As Orientation = 2
public:
literal Orientation^ CounterClockwise = 2
static val mutable CounterClockwise: Orientation

Field Value

Type: Orientation
See Also

Reference

Orientation Class
Emgu.CV.CvEnum Namespace


Orientation.value__ Field

Orientationvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.Orientation.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Orientation Class
Emgu.CV.CvEnum Namespace


PcaType Class

PCA Type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumPcaType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class PcaType : Enum
<FlagsAttribute>
Public NotInheritable Class PcaType
    Inherits Enum
[FlagsAttribute]
public ref class PcaType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type PcaType =
    class
        inherit Enum
    end

The PcaType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | DataAsCol | the vectors are stored as columns (i.e. values of a certain vector component are stored continuously)
 | DataAsRow | the vectors are stored as rows (i.e. all the components of a certain vector are stored continously)
 | UseAvg | use pre-computed average vector
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


PcaType Methods

The PcaType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

PcaType Class
Emgu.CV.CvEnum Namespace


PcaType Fields

The PcaType type exposes the following members.

Fields
 | Name | Description
 | DataAsCol | the vectors are stored as columns (i.e. values of a certain vector component are stored continuously)
 | DataAsRow | the vectors are stored as rows (i.e. all the components of a certain vector are stored continously)
 | UseAvg | use pre-computed average vector
Public field | value__ |
Top
See Also

Reference

PcaType Class
Emgu.CV.CvEnum Namespace


PcaType.DataAsCol Field

PcaTypeDataAsCol Field

the vectors are stored as columns (i.e. values of a certain vector component are stored continuously)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PcaType DataAsCol = 1
Public Const DataAsCol As PcaType = 1
public:
literal PcaType^ DataAsCol = 1
static val mutable DataAsCol: PcaType

Field Value

Type: PcaType
See Also

Reference

PcaType Class
Emgu.CV.CvEnum Namespace


PcaType.DataAsRow Field

PcaTypeDataAsRow Field

the vectors are stored as rows (i.e. all the components of a certain vector are stored continously)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PcaType DataAsRow = 0
Public Const DataAsRow As PcaType = 0
public:
literal PcaType^ DataAsRow = 0
static val mutable DataAsRow: PcaType

Field Value

Type: PcaType
See Also

Reference

PcaType Class
Emgu.CV.CvEnum Namespace


PcaType.UseAvg Field

PcaTypeUseAvg Field

use pre-computed average vector

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PcaType UseAvg = 2
Public Const UseAvg As PcaType = 2
public:
literal PcaType^ UseAvg = 2
static val mutable UseAvg: PcaType

Field Value

Type: PcaType
See Also

Reference

PcaType Class
Emgu.CV.CvEnum Namespace


PcaType.value__ Field

PcaTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.PcaType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

PcaType Class
Emgu.CV.CvEnum Namespace


RectIntersectType Class

Rectangle intersect type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumRectIntersectType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RectIntersectType : Enum
Public NotInheritable Class RectIntersectType
    Inherits Enum
public ref class RectIntersectType sealed : public Enum
[<SealedAttribute>]
type RectIntersectType =
    class
        inherit Enum
    end

The RectIntersectType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Full | One of the rectangle is fully enclosed in the other
 | None | No intersection
 | Partial | There is a partial intersection
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


RectIntersectType Methods

The RectIntersectType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RectIntersectType Class
Emgu.CV.CvEnum Namespace


RectIntersectType Fields

The RectIntersectType type exposes the following members.

Fields
 | Name | Description
 | Full | One of the rectangle is fully enclosed in the other
 | None | No intersection
 | Partial | There is a partial intersection
Public field | value__ |
Top
See Also

Reference

RectIntersectType Class
Emgu.CV.CvEnum Namespace


RectIntersectType.Full Field

RectIntersectTypeFull Field

One of the rectangle is fully enclosed in the other

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RectIntersectType Full = 2
Public Const Full As RectIntersectType = 2
public:
literal RectIntersectType^ Full = 2
static val mutable Full: RectIntersectType

Field Value

Type: RectIntersectType
See Also

Reference

RectIntersectType Class
Emgu.CV.CvEnum Namespace


RectIntersectType.None Field

RectIntersectTypeNone Field

No intersection

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RectIntersectType None = 0
Public Const None As RectIntersectType = 0
public:
literal RectIntersectType^ None = 0
static val mutable None: RectIntersectType

Field Value

Type: RectIntersectType
See Also

Reference

RectIntersectType Class
Emgu.CV.CvEnum Namespace


RectIntersectType.Partial Field

RectIntersectTypePartial Field

There is a partial intersection

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RectIntersectType Partial = 1
Public Const Partial As RectIntersectType = 1
public:
literal RectIntersectType^ Partial = 1
static val mutable Partial: RectIntersectType

Field Value

Type: RectIntersectType
See Also

Reference

RectIntersectType Class
Emgu.CV.CvEnum Namespace


RectIntersectType.value__ Field

RectIntersectTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.RectIntersectType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RectIntersectType Class
Emgu.CV.CvEnum Namespace


ReduceDimension Class

Type used for Reduce function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumReduceDimension

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ReduceDimension : Enum
Public NotInheritable Class ReduceDimension
    Inherits Enum
public ref class ReduceDimension sealed : public Enum
[<SealedAttribute>]
type ReduceDimension =
    class
        inherit Enum
    end

The ReduceDimension type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Auto | The dimension is chosen automatically by analysing the dst size
 | SingleCol | The matrix is reduced to a single column
 | SingleRow | The matrix is reduced to a single row
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ReduceDimension Methods

The ReduceDimension type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ReduceDimension Class
Emgu.CV.CvEnum Namespace


ReduceDimension Fields

The ReduceDimension type exposes the following members.

Fields
 | Name | Description
 | Auto | The dimension is chosen automatically by analysing the dst size
 | SingleCol | The matrix is reduced to a single column
 | SingleRow | The matrix is reduced to a single row
Public field | value__ |
Top
See Also

Reference

ReduceDimension Class
Emgu.CV.CvEnum Namespace


ReduceDimension.Auto Field

ReduceDimensionAuto Field

The dimension is chosen automatically by analysing the dst size

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ReduceDimension Auto = -1
Public Const Auto As ReduceDimension = -1
public:
literal ReduceDimension^ Auto = -1
static val mutable Auto: ReduceDimension

Field Value

Type: ReduceDimension
See Also

Reference

ReduceDimension Class
Emgu.CV.CvEnum Namespace


ReduceDimension.SingleCol Field

ReduceDimensionSingleCol Field

The matrix is reduced to a single column

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ReduceDimension SingleCol = 1
Public Const SingleCol As ReduceDimension = 1
public:
literal ReduceDimension^ SingleCol = 1
static val mutable SingleCol: ReduceDimension

Field Value

Type: ReduceDimension
See Also

Reference

ReduceDimension Class
Emgu.CV.CvEnum Namespace


ReduceDimension.SingleRow Field

ReduceDimensionSingleRow Field

The matrix is reduced to a single row

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ReduceDimension SingleRow = 0
Public Const SingleRow As ReduceDimension = 0
public:
literal ReduceDimension^ SingleRow = 0
static val mutable SingleRow: ReduceDimension

Field Value

Type: ReduceDimension
See Also

Reference

ReduceDimension Class
Emgu.CV.CvEnum Namespace


ReduceDimension.value__ Field

ReduceDimensionvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ReduceDimension.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ReduceDimension Class
Emgu.CV.CvEnum Namespace


ReduceType Class

Type used for Reduce function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumReduceType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ReduceType : Enum
Public NotInheritable Class ReduceType
    Inherits Enum
public ref class ReduceType sealed : public Enum
[<SealedAttribute>]
type ReduceType =
    class
        inherit Enum
    end

The ReduceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ReduceAvg | The output is the mean vector of all the matrix rows/columns
 | ReduceMax | The output is the maximum (column/row-wise) of all the matrix rows/columns
 | ReduceMin | The output is the minimum (column/row-wise) of all the matrix rows/columns
 | ReduceSum | The output is the sum of all the matrix rows/columns
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ReduceType Methods

The ReduceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ReduceType Class
Emgu.CV.CvEnum Namespace


ReduceType Fields

The ReduceType type exposes the following members.

Fields
 | Name | Description
 | ReduceAvg | The output is the mean vector of all the matrix rows/columns
 | ReduceMax | The output is the maximum (column/row-wise) of all the matrix rows/columns
 | ReduceMin | The output is the minimum (column/row-wise) of all the matrix rows/columns
 | ReduceSum | The output is the sum of all the matrix rows/columns
Public field | value__ |
Top
See Also

Reference

ReduceType Class
Emgu.CV.CvEnum Namespace


ReduceType.ReduceAvg Field

ReduceTypeReduceAvg Field

The output is the mean vector of all the matrix rows/columns

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ReduceType ReduceAvg = 1
Public Const ReduceAvg As ReduceType = 1
public:
literal ReduceType^ ReduceAvg = 1
static val mutable ReduceAvg: ReduceType

Field Value

Type: ReduceType
See Also

Reference

ReduceType Class
Emgu.CV.CvEnum Namespace


ReduceType.ReduceMax Field

ReduceTypeReduceMax Field

The output is the maximum (column/row-wise) of all the matrix rows/columns

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ReduceType ReduceMax = 2
Public Const ReduceMax As ReduceType = 2
public:
literal ReduceType^ ReduceMax = 2
static val mutable ReduceMax: ReduceType

Field Value

Type: ReduceType
See Also

Reference

ReduceType Class
Emgu.CV.CvEnum Namespace


ReduceType.ReduceMin Field

ReduceTypeReduceMin Field

The output is the minimum (column/row-wise) of all the matrix rows/columns

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ReduceType ReduceMin = 3
Public Const ReduceMin As ReduceType = 3
public:
literal ReduceType^ ReduceMin = 3
static val mutable ReduceMin: ReduceType

Field Value

Type: ReduceType
See Also

Reference

ReduceType Class
Emgu.CV.CvEnum Namespace


ReduceType.ReduceSum Field

ReduceTypeReduceSum Field

The output is the sum of all the matrix rows/columns

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ReduceType ReduceSum = 0
Public Const ReduceSum As ReduceType = 0
public:
literal ReduceType^ ReduceSum = 0
static val mutable ReduceSum: ReduceType

Field Value

Type: ReduceType
See Also

Reference

ReduceType Class
Emgu.CV.CvEnum Namespace


ReduceType.value__ Field

ReduceTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ReduceType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ReduceType Class
Emgu.CV.CvEnum Namespace


RetrType Class

Contour retrieval mode
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumRetrType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RetrType : Enum
Public NotInheritable Class RetrType
    Inherits Enum
public ref class RetrType sealed : public Enum
[<SealedAttribute>]
type RetrType =
    class
        inherit Enum
    end

The RetrType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Ccomp | Retrieve all the contours and organizes them into two-level hierarchy: top level are external boundaries of the components, second level are bounda boundaries of the holes
 | External | Retrieve only the extreme outer contours
 | List | Retrieve all the contours and puts them in the list
 | Tree | Retrieve all the contours and reconstructs the full hierarchy of nested contours
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


RetrType Methods

The RetrType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RetrType Class
Emgu.CV.CvEnum Namespace


RetrType Fields

The RetrType type exposes the following members.

Fields
 | Name | Description
 | Ccomp | Retrieve all the contours and organizes them into two-level hierarchy: top level are external boundaries of the components, second level are bounda boundaries of the holes
 | External | Retrieve only the extreme outer contours
 | List | Retrieve all the contours and puts them in the list
 | Tree | Retrieve all the contours and reconstructs the full hierarchy of nested contours
Public field | value__ |
Top
See Also

Reference

RetrType Class
Emgu.CV.CvEnum Namespace


RetrType.Ccomp Field

RetrTypeCcomp Field

Retrieve all the contours and organizes them into two-level hierarchy: top level are external boundaries of the components, second level are bounda boundaries of the holes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RetrType Ccomp = 2
Public Const Ccomp As RetrType = 2
public:
literal RetrType^ Ccomp = 2
static val mutable Ccomp: RetrType

Field Value

Type: RetrType
See Also

Reference

RetrType Class
Emgu.CV.CvEnum Namespace


RetrType.External Field

RetrTypeExternal Field

Retrieve only the extreme outer contours

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RetrType External = 0
Public Const External As RetrType = 0
public:
literal RetrType^ External = 0
static val mutable External: RetrType

Field Value

Type: RetrType
See Also

Reference

RetrType Class
Emgu.CV.CvEnum Namespace


RetrType.List Field

RetrTypeList Field

Retrieve all the contours and puts them in the list

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RetrType List = 1
Public Const List As RetrType = 1
public:
literal RetrType^ List = 1
static val mutable List: RetrType

Field Value

Type: RetrType
See Also

Reference

RetrType Class
Emgu.CV.CvEnum Namespace


RetrType.Tree Field

RetrTypeTree Field

Retrieve all the contours and reconstructs the full hierarchy of nested contours

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RetrType Tree = 3
Public Const Tree As RetrType = 3
public:
literal RetrType^ Tree = 3
static val mutable Tree: RetrType

Field Value

Type: RetrType
See Also

Reference

RetrType Class
Emgu.CV.CvEnum Namespace


RetrType.value__ Field

RetrTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.RetrType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RetrType Class
Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm Class

Type of Robust Estimation Algorithm
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumRobustEstimationAlgorithm

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RobustEstimationAlgorithm : Enum
Public NotInheritable Class RobustEstimationAlgorithm
    Inherits Enum
public ref class RobustEstimationAlgorithm sealed : public Enum
[<SealedAttribute>]
type RobustEstimationAlgorithm =
    class
        inherit Enum
    end

The RobustEstimationAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AllPoints | regular method using all the point pairs
 | LMEDS | Least-Median robust method
 | Ransac | RANSAC-based robust method
 | RHO | RHO algorithm
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm Methods

The RobustEstimationAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RobustEstimationAlgorithm Class
Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm Fields

The RobustEstimationAlgorithm type exposes the following members.

Fields
 | Name | Description
 | AllPoints | regular method using all the point pairs
 | LMEDS | Least-Median robust method
 | Ransac | RANSAC-based robust method
 | RHO | RHO algorithm
Public field | value__ |
Top
See Also

Reference

RobustEstimationAlgorithm Class
Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm.AllPoints Field

RobustEstimationAlgorithmAllPoints Field

regular method using all the point pairs

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RobustEstimationAlgorithm AllPoints = 0
Public Const AllPoints As RobustEstimationAlgorithm = 0
public:
literal RobustEstimationAlgorithm^ AllPoints = 0
static val mutable AllPoints: RobustEstimationAlgorithm

Field Value

Type: RobustEstimationAlgorithm
See Also

Reference

RobustEstimationAlgorithm Class
Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm.LMEDS Field

RobustEstimationAlgorithmLMEDS Field

Least-Median robust method

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RobustEstimationAlgorithm LMEDS = 4
Public Const LMEDS As RobustEstimationAlgorithm = 4
public:
literal RobustEstimationAlgorithm^ LMEDS = 4
static val mutable LMEDS: RobustEstimationAlgorithm

Field Value

Type: RobustEstimationAlgorithm
See Also

Reference

RobustEstimationAlgorithm Class
Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm.Ransac Field

RobustEstimationAlgorithmRansac Field

RANSAC-based robust method

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RobustEstimationAlgorithm Ransac = 8
Public Const Ransac As RobustEstimationAlgorithm = 8
public:
literal RobustEstimationAlgorithm^ Ransac = 8
static val mutable Ransac: RobustEstimationAlgorithm

Field Value

Type: RobustEstimationAlgorithm
See Also

Reference

RobustEstimationAlgorithm Class
Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm.RHO Field

RobustEstimationAlgorithmRHO Field

RHO algorithm

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RobustEstimationAlgorithm RHO = 16
Public Const RHO As RobustEstimationAlgorithm = 16
public:
literal RobustEstimationAlgorithm^ RHO = 16
static val mutable RHO: RobustEstimationAlgorithm

Field Value

Type: RobustEstimationAlgorithm
See Also

Reference

RobustEstimationAlgorithm Class
Emgu.CV.CvEnum Namespace


RobustEstimationAlgorithm.value__ Field

RobustEstimationAlgorithmvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.RobustEstimationAlgorithm.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RobustEstimationAlgorithm Class
Emgu.CV.CvEnum Namespace


RotateFlags Class

The rotation type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumRotateFlags

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RotateFlags : Enum
Public NotInheritable Class RotateFlags
    Inherits Enum
public ref class RotateFlags sealed : public Enum
[<SealedAttribute>]
type RotateFlags =
    class
        inherit Enum
    end

The RotateFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Rotate180 | Rotate 180 degrees clockwise
 | Rotate90Clockwise | Rotate 90 degrees clockwise
 | Rotate90CounterClockwise | Rotate 270 degrees clockwise
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


RotateFlags Methods

The RotateFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

RotateFlags Class
Emgu.CV.CvEnum Namespace


RotateFlags Fields

The RotateFlags type exposes the following members.

Fields
 | Name | Description
 | Rotate180 | Rotate 180 degrees clockwise
 | Rotate90Clockwise | Rotate 90 degrees clockwise
 | Rotate90CounterClockwise | Rotate 270 degrees clockwise
Public field | value__ |
Top
See Also

Reference

RotateFlags Class
Emgu.CV.CvEnum Namespace


RotateFlags.Rotate180 Field

RotateFlagsRotate180 Field

Rotate 180 degrees clockwise

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RotateFlags Rotate180 = 1
Public Const Rotate180 As RotateFlags = 1
public:
literal RotateFlags^ Rotate180 = 1
static val mutable Rotate180: RotateFlags

Field Value

Type: RotateFlags
See Also

Reference

RotateFlags Class
Emgu.CV.CvEnum Namespace


RotateFlags.Rotate90Clockwise Field

RotateFlagsRotate90Clockwise Field

Rotate 90 degrees clockwise

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RotateFlags Rotate90Clockwise = 0
Public Const Rotate90Clockwise As RotateFlags = 0
public:
literal RotateFlags^ Rotate90Clockwise = 0
static val mutable Rotate90Clockwise: RotateFlags

Field Value

Type: RotateFlags
See Also

Reference

RotateFlags Class
Emgu.CV.CvEnum Namespace


RotateFlags.Rotate90CounterClockwise Field

RotateFlagsRotate90CounterClockwise Field

Rotate 270 degrees clockwise

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const RotateFlags Rotate90CounterClockwise = 2
Public Const Rotate90CounterClockwise As RotateFlags = 2
public:
literal RotateFlags^ Rotate90CounterClockwise = 2
static val mutable Rotate90CounterClockwise: RotateFlags

Field Value

Type: RotateFlags
See Also

Reference

RotateFlags Class
Emgu.CV.CvEnum Namespace


RotateFlags.value__ Field

RotateFlagsvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.RotateFlags.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

RotateFlags Class
Emgu.CV.CvEnum Namespace


SeqEltype Class

Sequence element type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSeqEltype

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SeqEltype : Enum
Public NotInheritable Class SeqEltype
    Inherits Enum
public ref class SeqEltype sealed : public Enum
[<SealedAttribute>]
type SeqEltype =
    class
        inherit Enum
    end

The SeqEltype type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Code | freeman code: 0..7
 | ConnectedComp | connected component
 | Generic | unspecified type of sequence elements
 | GraphEdge | next_o, next_d, vtx_o, vtx_d
 | GraphVertex | first_edge, (x,y)
 | Index | index of element of some other sequence
 | Point | (x,y)
 | Point3D | (x,y,z)
 | Ppoint | pointer to element of other sequence
 | Ptr | =6
 | TrainAtr | vertex of the binary tree
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SeqEltype Methods

The SeqEltype type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype Fields

The SeqEltype type exposes the following members.

Fields
 | Name | Description
 | Code | freeman code: 0..7
 | ConnectedComp | connected component
 | Generic | unspecified type of sequence elements
 | GraphEdge | next_o, next_d, vtx_o, vtx_d
 | GraphVertex | first_edge, (x,y)
 | Index | index of element of some other sequence
 | Point | (x,y)
 | Point3D | (x,y,z)
 | Ppoint | pointer to element of other sequence
 | Ptr | =6
 | TrainAtr | vertex of the binary tree
Public field | value__ |
Top
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.Code Field

SeqEltypeCode Field

freeman code: 0..7

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype Code = 0
Public Const Code As SeqEltype = 0
public:
literal SeqEltype^ Code = 0
static val mutable Code: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.ConnectedComp Field

SeqEltypeConnectedComp Field

connected component

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype ConnectedComp = 0
Public Const ConnectedComp As SeqEltype = 0
public:
literal SeqEltype^ ConnectedComp = 0
static val mutable ConnectedComp: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.Generic Field

SeqEltypeGeneric Field

unspecified type of sequence elements

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype Generic = 0
Public Const Generic As SeqEltype = 0
public:
literal SeqEltype^ Generic = 0
static val mutable Generic: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.GraphEdge Field

SeqEltypeGraphEdge Field

next_o, next_d, vtx_o, vtx_d

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype GraphEdge = 0
Public Const GraphEdge As SeqEltype = 0
public:
literal SeqEltype^ GraphEdge = 0
static val mutable GraphEdge: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.GraphVertex Field

SeqEltypeGraphVertex Field

first_edge, (x,y)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype GraphVertex = 0
Public Const GraphVertex As SeqEltype = 0
public:
literal SeqEltype^ GraphVertex = 0
static val mutable GraphVertex: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.Index Field

SeqEltypeIndex Field

index of element of some other sequence

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype Index = 4
Public Const Index As SeqEltype = 4
public:
literal SeqEltype^ Index = 4
static val mutable Index: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.Point Field

SeqEltypePoint Field

(x,y)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype Point = 12
Public Const Point As SeqEltype = 12
public:
literal SeqEltype^ Point = 12
static val mutable Point: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.Point3D Field

SeqEltypePoint3D Field

(x,y,z)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype Point3D = 56
Public Const Point3D As SeqEltype = 56
public:
literal SeqEltype^ Point3D = 56
static val mutable Point3D: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.Ppoint Field

SeqEltypePpoint Field

pointer to element of other sequence

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype Ppoint = 7
Public Const Ppoint As SeqEltype = 7
public:
literal SeqEltype^ Ppoint = 7
static val mutable Ppoint: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.Ptr Field

SeqEltypePtr Field

=6

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype Ptr = 7
Public Const Ptr As SeqEltype = 7
public:
literal SeqEltype^ Ptr = 7
static val mutable Ptr: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.TrainAtr Field

SeqEltypeTrainAtr Field

vertex of the binary tree

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqEltype TrainAtr = 0
Public Const TrainAtr As SeqEltype = 0
public:
literal SeqEltype^ TrainAtr = 0
static val mutable TrainAtr: SeqEltype

Field Value

Type: SeqEltype
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqEltype.value__ Field

SeqEltypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SeqEltype.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SeqEltype Class
Emgu.CV.CvEnum Namespace


SeqFlag Class

Sequence flag
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSeqFlag

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SeqFlag : Enum
Public NotInheritable Class SeqFlag
    Inherits Enum
public ref class SeqFlag sealed : public Enum
[<SealedAttribute>]
type SeqFlag =
    class
        inherit Enum
    end

The SeqFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Closed | Close sequence
 | Convex | Convex sequence
 | Hole | Hole
 | Simple | Simple sequence
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SeqFlag Methods

The SeqFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SeqFlag Class
Emgu.CV.CvEnum Namespace


SeqFlag Fields

The SeqFlag type exposes the following members.

Fields
 | Name | Description
 | Closed | Close sequence
 | Convex | Convex sequence
 | Hole | Hole
 | Simple | Simple sequence
Public field | value__ |
Top
See Also

Reference

SeqFlag Class
Emgu.CV.CvEnum Namespace


SeqFlag.Closed Field

SeqFlagClosed Field

Close sequence

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqFlag Closed = 16384
Public Const Closed As SeqFlag = 16384
public:
literal SeqFlag^ Closed = 16384
static val mutable Closed: SeqFlag

Field Value

Type: SeqFlag
See Also

Reference

SeqFlag Class
Emgu.CV.CvEnum Namespace


SeqFlag.Convex Field

SeqFlagConvex Field

Convex sequence

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqFlag Convex = 65536
Public Const Convex As SeqFlag = 65536
public:
literal SeqFlag^ Convex = 65536
static val mutable Convex: SeqFlag

Field Value

Type: SeqFlag
See Also

Reference

SeqFlag Class
Emgu.CV.CvEnum Namespace


SeqFlag.Hole Field

SeqFlagHole Field

Hole

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqFlag Hole = 131072
Public Const Hole As SeqFlag = 131072
public:
literal SeqFlag^ Hole = 131072
static val mutable Hole: SeqFlag

Field Value

Type: SeqFlag
See Also

Reference

SeqFlag Class
Emgu.CV.CvEnum Namespace


SeqFlag.Simple Field

SeqFlagSimple Field

Simple sequence

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqFlag Simple = 32768
Public Const Simple As SeqFlag = 32768
public:
literal SeqFlag^ Simple = 32768
static val mutable Simple: SeqFlag

Field Value

Type: SeqFlag
See Also

Reference

SeqFlag Class
Emgu.CV.CvEnum Namespace


SeqFlag.value__ Field

SeqFlagvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SeqFlag.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SeqFlag Class
Emgu.CV.CvEnum Namespace


SeqKind Class

The kind of sequence available
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSeqKind

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SeqKind : Enum
Public NotInheritable Class SeqKind
    Inherits Enum
public ref class SeqKind sealed : public Enum
[<SealedAttribute>]
type SeqKind =
    class
        inherit Enum
    end

The SeqKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BinTree | Dense sequence subtypes
 | Curve | Dense sequence subtypes
 | Generic | Generic (unspecified) kind of sequence
 | Graph | Sparse sequence (or set) subtypes
 | Subdiv2D | Sparse sequence (or set) subtypes
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SeqKind Methods

The SeqKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqKind Fields

The SeqKind type exposes the following members.

Fields
 | Name | Description
 | BinTree | Dense sequence subtypes
 | Curve | Dense sequence subtypes
 | Generic | Generic (unspecified) kind of sequence
 | Graph | Sparse sequence (or set) subtypes
 | Subdiv2D | Sparse sequence (or set) subtypes
Public field | value__ |
Top
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqKind.BinTree Field

SeqKindBinTree Field

Dense sequence subtypes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqKind BinTree = 8192
Public Const BinTree As SeqKind = 8192
public:
literal SeqKind^ BinTree = 8192
static val mutable BinTree: SeqKind

Field Value

Type: SeqKind
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqKind.Curve Field

SeqKindCurve Field

Dense sequence subtypes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqKind Curve = 4096
Public Const Curve As SeqKind = 4096
public:
literal SeqKind^ Curve = 4096
static val mutable Curve: SeqKind

Field Value

Type: SeqKind
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqKind.Generic Field

SeqKindGeneric Field

Generic (unspecified) kind of sequence

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqKind Generic = 0
Public Const Generic As SeqKind = 0
public:
literal SeqKind^ Generic = 0
static val mutable Generic: SeqKind

Field Value

Type: SeqKind
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqKind.Graph Field

SeqKindGraph Field

Sparse sequence (or set) subtypes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqKind Graph = 4096
Public Const Graph As SeqKind = 4096
public:
literal SeqKind^ Graph = 4096
static val mutable Graph: SeqKind

Field Value

Type: SeqKind
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqKind.Subdiv2D Field

SeqKindSubdiv2D Field

Sparse sequence (or set) subtypes

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqKind Subdiv2D = 8192
Public Const Subdiv2D As SeqKind = 8192
public:
literal SeqKind^ Subdiv2D = 8192
static val mutable Subdiv2D: SeqKind

Field Value

Type: SeqKind
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqKind.value__ Field

SeqKindvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SeqKind.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SeqKind Class
Emgu.CV.CvEnum Namespace


SeqType Class

Sequence type for point sets
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSeqType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SeqType : Enum
Public NotInheritable Class SeqType
    Inherits Enum
public ref class SeqType sealed : public Enum
[<SealedAttribute>]
type SeqType =
    class
        inherit Enum
    end

The SeqType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Point3DSet | Point 3D set
 | PointSet | Point set
 | Polygon | Polygon
 | Polyline | Polyline
 | SimplePolygon | Simple Polygon
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SeqType Methods

The SeqType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SeqType Fields

The SeqType type exposes the following members.

Fields
 | Name | Description
 | Point3DSet | Point 3D set
 | PointSet | Point set
 | Polygon | Polygon
 | Polyline | Polyline
 | SimplePolygon | Simple Polygon
Public field | value__ |
Top
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SeqType.Point3DSet Field

SeqTypePoint3DSet Field

Point 3D set

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqType Point3DSet = 56
Public Const Point3DSet As SeqType = 56
public:
literal SeqType^ Point3DSet = 56
static val mutable Point3DSet: SeqType

Field Value

Type: SeqType
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SeqType.PointSet Field

SeqTypePointSet Field

Point set

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqType PointSet = 12
Public Const PointSet As SeqType = 12
public:
literal SeqType^ PointSet = 12
static val mutable PointSet: SeqType

Field Value

Type: SeqType
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SeqType.Polygon Field

SeqTypePolygon Field

Polygon

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqType Polygon = 20492
Public Const Polygon As SeqType = 20492
public:
literal SeqType^ Polygon = 20492
static val mutable Polygon: SeqType

Field Value

Type: SeqType
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SeqType.Polyline Field

SeqTypePolyline Field

Polyline

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqType Polyline = 4108
Public Const Polyline As SeqType = 4108
public:
literal SeqType^ Polyline = 4108
static val mutable Polyline: SeqType

Field Value

Type: SeqType
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SeqType.SimplePolygon Field

SeqTypeSimplePolygon Field

Simple Polygon

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SeqType SimplePolygon = 53260
Public Const SimplePolygon As SeqType = 53260
public:
literal SeqType^ SimplePolygon = 53260
static val mutable SimplePolygon: SeqType

Field Value

Type: SeqType
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SeqType.value__ Field

SeqTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SeqType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SeqType Class
Emgu.CV.CvEnum Namespace


SmoothType Class

Interpolation type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSmoothType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmoothType : Enum
Public NotInheritable Class SmoothType
    Inherits Enum
public ref class SmoothType sealed : public Enum
[<SealedAttribute>]
type SmoothType =
    class
        inherit Enum
    end

The SmoothType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Bilateral | (bilateral filter) - applying bilateral 3x3 filtering with color sigma=param1 and space sigma=param2. Information about bilateral filtering can be found
 | Blur | (simple blur) - summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2).
 | BlurNoScale | (simple blur with no scaling) - summation over a pixel param1 x param2 neighborhood. If the neighborhood size may vary, one may precompute integral image with cvIntegral function
 | Gaussian | (Gaussian blur) - convolving image with param1 x param2 Gaussian kernel.
 | Median | (median blur) - finding median of param1 x param1 neighborhood (i.e. the neighborhood is square).
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SmoothType Methods

The SmoothType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SmoothType Fields

The SmoothType type exposes the following members.

Fields
 | Name | Description
 | Bilateral | (bilateral filter) - applying bilateral 3x3 filtering with color sigma=param1 and space sigma=param2. Information about bilateral filtering can be found
 | Blur | (simple blur) - summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2).
 | BlurNoScale | (simple blur with no scaling) - summation over a pixel param1 x param2 neighborhood. If the neighborhood size may vary, one may precompute integral image with cvIntegral function
 | Gaussian | (Gaussian blur) - convolving image with param1 x param2 Gaussian kernel.
 | Median | (median blur) - finding median of param1 x param1 neighborhood (i.e. the neighborhood is square).
Public field | value__ |
Top
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SmoothType.Bilateral Field

SmoothTypeBilateral Field

(bilateral filter) - applying bilateral 3x3 filtering with color sigma=param1 and space sigma=param2. Information about bilateral filtering can be found

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SmoothType Bilateral = 4
Public Const Bilateral As SmoothType = 4
public:
literal SmoothType^ Bilateral = 4
static val mutable Bilateral: SmoothType

Field Value

Type: SmoothType
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SmoothType.Blur Field

SmoothTypeBlur Field

(simple blur) - summation over a pixel param1 x param2 neighborhood with subsequent scaling by 1/(param1 x param2).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SmoothType Blur = 1
Public Const Blur As SmoothType = 1
public:
literal SmoothType^ Blur = 1
static val mutable Blur: SmoothType

Field Value

Type: SmoothType
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SmoothType.BlurNoScale Field

SmoothTypeBlurNoScale Field

(simple blur with no scaling) - summation over a pixel param1 x param2 neighborhood. If the neighborhood size may vary, one may precompute integral image with cvIntegral function

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SmoothType BlurNoScale = 0
Public Const BlurNoScale As SmoothType = 0
public:
literal SmoothType^ BlurNoScale = 0
static val mutable BlurNoScale: SmoothType

Field Value

Type: SmoothType
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SmoothType.Gaussian Field

SmoothTypeGaussian Field

(Gaussian blur) - convolving image with param1 x param2 Gaussian kernel.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SmoothType Gaussian = 2
Public Const Gaussian As SmoothType = 2
public:
literal SmoothType^ Gaussian = 2
static val mutable Gaussian: SmoothType

Field Value

Type: SmoothType
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SmoothType.Median Field

SmoothTypeMedian Field

(median blur) - finding median of param1 x param1 neighborhood (i.e. the neighborhood is square).

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SmoothType Median = 3
Public Const Median As SmoothType = 3
public:
literal SmoothType^ Median = 3
static val mutable Median: SmoothType

Field Value

Type: SmoothType
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SmoothType.value__ Field

SmoothTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SmoothType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SmoothType Class
Emgu.CV.CvEnum Namespace


SolveLPResult Class

The return value for solveLP function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSolveLPResult

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SolveLPResult : Enum
Public NotInheritable Class SolveLPResult
    Inherits Enum
public ref class SolveLPResult sealed : public Enum
[<SealedAttribute>]
type SolveLPResult =
    class
        inherit Enum
    end

The SolveLPResult type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Multi | there are multiple maxima for target function - the arbitrary one is returned
 | Single | There is only one maximum for target function
 | Unbounded | Problem is unbounded (target function can achieve arbitrary high values)
 | Unfeasible | Problem is unfeasible (there are no points that satisfy all the constraints imposed)
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SolveLPResult Methods

The SolveLPResult type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SolveLPResult Class
Emgu.CV.CvEnum Namespace


SolveLPResult Fields

The SolveLPResult type exposes the following members.

Fields
 | Name | Description
 | Multi | there are multiple maxima for target function - the arbitrary one is returned
 | Single | There is only one maximum for target function
 | Unbounded | Problem is unbounded (target function can achieve arbitrary high values)
 | Unfeasible | Problem is unfeasible (there are no points that satisfy all the constraints imposed)
Public field | value__ |
Top
See Also

Reference

SolveLPResult Class
Emgu.CV.CvEnum Namespace


SolveLPResult.Multi Field

SolveLPResultMulti Field

there are multiple maxima for target function - the arbitrary one is returned

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolveLPResult Multi = 1
Public Const Multi As SolveLPResult = 1
public:
literal SolveLPResult^ Multi = 1
static val mutable Multi: SolveLPResult

Field Value

Type: SolveLPResult
See Also

Reference

SolveLPResult Class
Emgu.CV.CvEnum Namespace


SolveLPResult.Single Field

SolveLPResultSingle Field

There is only one maximum for target function

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolveLPResult Single = 0
Public Const Single As SolveLPResult = 0
public:
literal SolveLPResult^ Single = 0
static val mutable Single: SolveLPResult

Field Value

Type: SolveLPResult
See Also

Reference

SolveLPResult Class
Emgu.CV.CvEnum Namespace


SolveLPResult.Unbounded Field

SolveLPResultUnbounded Field

Problem is unbounded (target function can achieve arbitrary high values)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolveLPResult Unbounded = -2
Public Const Unbounded As SolveLPResult = -2
public:
literal SolveLPResult^ Unbounded = -2
static val mutable Unbounded: SolveLPResult

Field Value

Type: SolveLPResult
See Also

Reference

SolveLPResult Class
Emgu.CV.CvEnum Namespace


SolveLPResult.Unfeasible Field

SolveLPResultUnfeasible Field

Problem is unfeasible (there are no points that satisfy all the constraints imposed)

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolveLPResult Unfeasible = -1
Public Const Unfeasible As SolveLPResult = -1
public:
literal SolveLPResult^ Unfeasible = -1
static val mutable Unfeasible: SolveLPResult

Field Value

Type: SolveLPResult
See Also

Reference

SolveLPResult Class
Emgu.CV.CvEnum Namespace


SolveLPResult.value__ Field

SolveLPResultvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SolveLPResult.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SolveLPResult Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod Class

Method for solving a PnP problem
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSolvePnpMethod

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SolvePnpMethod : Enum
Public NotInheritable Class SolvePnpMethod
    Inherits Enum
public ref class SolvePnpMethod sealed : public Enum
[<SealedAttribute>]
type SolvePnpMethod =
    class
        inherit Enum
    end

The SolvePnpMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AP3P | An Efficient Algebraic Solution to the Perspective-Three-Point Problem
 | Dls | A Direct Least-Squares (DLS) Method for PnP
 | EPnP | EPnP: Efficient Perspective-n-Point Camera Pose Estimation F.Moreno-Noguer, V.Lepetit and P.Fua "EPnP: Efficient Perspective-n-Point Camera Pose Estimation"
 | IPPE | Infinitesimal Plane-Based Pose Estimation. Object points must be coplanar.
 | IPPESquare | Infinitesimal Plane-Based Pose Estimation. This is a special case suitable for marker pose estimation. 4 coplanar object points must be defined in the following order: - point 0: [-squareLength / 2, squareLength / 2, 0] - point 1: [ squareLength / 2, squareLength / 2, 0] - point 2: [ squareLength / 2, -squareLength / 2, 0] - point 3: [-squareLength / 2, -squareLength / 2, 0]
 | Iterative | Iterative
 | P3P | Complete Solution Classification for the Perspective-Three-Point Problem X.S. Gao, X.-R. Hou, J. Tang, H.-F. Chang; "Complete Solution Classification for the Perspective-Three-Point Problem"
 | UPnP | Exhaustive Linearization for Robust Camera Pose and Focal Length Estimation
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SolvePnpMethod Methods

The SolvePnpMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod Fields

The SolvePnpMethod type exposes the following members.

Fields
 | Name | Description
 | AP3P | An Efficient Algebraic Solution to the Perspective-Three-Point Problem
 | Dls | A Direct Least-Squares (DLS) Method for PnP
 | EPnP | EPnP: Efficient Perspective-n-Point Camera Pose Estimation F.Moreno-Noguer, V.Lepetit and P.Fua "EPnP: Efficient Perspective-n-Point Camera Pose Estimation"
 | IPPE | Infinitesimal Plane-Based Pose Estimation. Object points must be coplanar.
 | IPPESquare | Infinitesimal Plane-Based Pose Estimation. This is a special case suitable for marker pose estimation. 4 coplanar object points must be defined in the following order: - point 0: [-squareLength / 2, squareLength / 2, 0] - point 1: [ squareLength / 2, squareLength / 2, 0] - point 2: [ squareLength / 2, -squareLength / 2, 0] - point 3: [-squareLength / 2, -squareLength / 2, 0]
 | Iterative | Iterative
 | P3P | Complete Solution Classification for the Perspective-Three-Point Problem X.S. Gao, X.-R. Hou, J. Tang, H.-F. Chang; "Complete Solution Classification for the Perspective-Three-Point Problem"
 | UPnP | Exhaustive Linearization for Robust Camera Pose and Focal Length Estimation
Public field | value__ |
Top
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.AP3P Field

SolvePnpMethodAP3P Field

An Efficient Algebraic Solution to the Perspective-Three-Point Problem

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod AP3P = 5
Public Const AP3P As SolvePnpMethod = 5
public:
literal SolvePnpMethod^ AP3P = 5
static val mutable AP3P: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.Dls Field

SolvePnpMethodDls Field

A Direct Least-Squares (DLS) Method for PnP

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod Dls = 3
Public Const Dls As SolvePnpMethod = 3
public:
literal SolvePnpMethod^ Dls = 3
static val mutable Dls: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.EPnP Field

SolvePnpMethodEPnP Field

EPnP: Efficient Perspective-n-Point Camera Pose Estimation F.Moreno-Noguer, V.Lepetit and P.Fua "EPnP: Efficient Perspective-n-Point Camera Pose Estimation"

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod EPnP = 1
Public Const EPnP As SolvePnpMethod = 1
public:
literal SolvePnpMethod^ EPnP = 1
static val mutable EPnP: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.IPPE Field

SolvePnpMethodIPPE Field

Infinitesimal Plane-Based Pose Estimation. Object points must be coplanar.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod IPPE = 6
Public Const IPPE As SolvePnpMethod = 6
public:
literal SolvePnpMethod^ IPPE = 6
static val mutable IPPE: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.IPPESquare Field

SolvePnpMethodIPPESquare Field

Infinitesimal Plane-Based Pose Estimation. This is a special case suitable for marker pose estimation. 4 coplanar object points must be defined in the following order: - point 0: [-squareLength / 2, squareLength / 2, 0] - point 1: [ squareLength / 2, squareLength / 2, 0] - point 2: [ squareLength / 2, -squareLength / 2, 0] - point 3: [-squareLength / 2, -squareLength / 2, 0]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod IPPESquare = 7
Public Const IPPESquare As SolvePnpMethod = 7
public:
literal SolvePnpMethod^ IPPESquare = 7
static val mutable IPPESquare: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.Iterative Field

SolvePnpMethodIterative Field

Iterative

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod Iterative = 0
Public Const Iterative As SolvePnpMethod = 0
public:
literal SolvePnpMethod^ Iterative = 0
static val mutable Iterative: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.P3P Field

SolvePnpMethodP3P Field

Complete Solution Classification for the Perspective-Three-Point Problem X.S. Gao, X.-R. Hou, J. Tang, H.-F. Chang; "Complete Solution Classification for the Perspective-Three-Point Problem"

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod P3P = 2
Public Const P3P As SolvePnpMethod = 2
public:
literal SolvePnpMethod^ P3P = 2
static val mutable P3P: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.UPnP Field

SolvePnpMethodUPnP Field

Exhaustive Linearization for Robust Camera Pose and Focal Length Estimation

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SolvePnpMethod UPnP = 4
Public Const UPnP As SolvePnpMethod = 4
public:
literal SolvePnpMethod^ UPnP = 4
static val mutable UPnP: SolvePnpMethod

Field Value

Type: SolvePnpMethod
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SolvePnpMethod.value__ Field

SolvePnpMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SolvePnpMethod.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SolvePnpMethod Class
Emgu.CV.CvEnum Namespace


SortFlags Class

Flags for sorting
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSortFlags

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class SortFlags : Enum
<FlagsAttribute>
Public NotInheritable Class SortFlags
    Inherits Enum
[FlagsAttribute]
public ref class SortFlags sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type SortFlags =
    class
        inherit Enum
    end

The SortFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | SortAscending | Each matrix row is sorted in the ascending order.
 | SortDescending | Each matrix row is sorted in the descending order; this flag and SortAscending are also mutually exclusive.
 | SortEveryColumn | Each matrix column is sorted independently; this flag and SortEveryRow are mutually exclusive.
 | SortEveryRow | Each matrix row is sorted independently
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SortFlags Methods

The SortFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SortFlags Class
Emgu.CV.CvEnum Namespace


SortFlags Fields

The SortFlags type exposes the following members.

Fields
 | Name | Description
 | SortAscending | Each matrix row is sorted in the ascending order.
 | SortDescending | Each matrix row is sorted in the descending order; this flag and SortAscending are also mutually exclusive.
 | SortEveryColumn | Each matrix column is sorted independently; this flag and SortEveryRow are mutually exclusive.
 | SortEveryRow | Each matrix row is sorted independently
Public field | value__ |
Top
See Also

Reference

SortFlags Class
Emgu.CV.CvEnum Namespace


SortFlags.SortAscending Field

SortFlagsSortAscending Field

Each matrix row is sorted in the ascending order.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SortFlags SortAscending = 0
Public Const SortAscending As SortFlags = 0
public:
literal SortFlags^ SortAscending = 0
static val mutable SortAscending: SortFlags

Field Value

Type: SortFlags
See Also

Reference

SortFlags Class
Emgu.CV.CvEnum Namespace


SortFlags.SortDescending Field

SortFlagsSortDescending Field

Each matrix row is sorted in the descending order; this flag and SortAscending are also mutually exclusive.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SortFlags SortDescending = 16
Public Const SortDescending As SortFlags = 16
public:
literal SortFlags^ SortDescending = 16
static val mutable SortDescending: SortFlags

Field Value

Type: SortFlags
See Also

Reference

SortFlags Class
Emgu.CV.CvEnum Namespace


SortFlags.SortEveryColumn Field

SortFlagsSortEveryColumn Field

Each matrix column is sorted independently; this flag and SortEveryRow are mutually exclusive.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SortFlags SortEveryColumn = 1
Public Const SortEveryColumn As SortFlags = 1
public:
literal SortFlags^ SortEveryColumn = 1
static val mutable SortEveryColumn: SortFlags

Field Value

Type: SortFlags
See Also

Reference

SortFlags Class
Emgu.CV.CvEnum Namespace


SortFlags.SortEveryRow Field

SortFlagsSortEveryRow Field

Each matrix row is sorted independently

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SortFlags SortEveryRow = 0
Public Const SortEveryRow As SortFlags = 0
public:
literal SortFlags^ SortEveryRow = 0
static val mutable SortEveryRow: SortFlags

Field Value

Type: SortFlags
See Also

Reference

SortFlags Class
Emgu.CV.CvEnum Namespace


SortFlags.value__ Field

SortFlagsvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SortFlags.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SortFlags Class
Emgu.CV.CvEnum Namespace


StereoBmPrefilter Class

Stereo Block Matching Prefilter type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumStereoBmPrefilter

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class StereoBmPrefilter : Enum
Public NotInheritable Class StereoBmPrefilter
    Inherits Enum
public ref class StereoBmPrefilter sealed : public Enum
[<SealedAttribute>]
type StereoBmPrefilter =
    class
        inherit Enum
    end

The StereoBmPrefilter type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | NormalizedResponse | No prefilter
Public field | value__ |
 | XSobel | XSobel
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


StereoBmPrefilter Methods

The StereoBmPrefilter type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

StereoBmPrefilter Class
Emgu.CV.CvEnum Namespace


StereoBmPrefilter Fields

The StereoBmPrefilter type exposes the following members.

Fields
 | Name | Description
 | NormalizedResponse | No prefilter
Public field | value__ |
 | XSobel | XSobel
Top
See Also

Reference

StereoBmPrefilter Class
Emgu.CV.CvEnum Namespace


StereoBmPrefilter.NormalizedResponse Field

StereoBmPrefilterNormalizedResponse Field

No prefilter

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StereoBmPrefilter NormalizedResponse = 0
Public Const NormalizedResponse As StereoBmPrefilter = 0
public:
literal StereoBmPrefilter^ NormalizedResponse = 0
static val mutable NormalizedResponse: StereoBmPrefilter

Field Value

Type: StereoBmPrefilter
See Also

Reference

StereoBmPrefilter Class
Emgu.CV.CvEnum Namespace


StereoBmPrefilter.value__ Field

StereoBmPrefiltervalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.StereoBmPrefilter.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

StereoBmPrefilter Class
Emgu.CV.CvEnum Namespace


StereoBmPrefilter.XSobel Field

StereoBmPrefilterXSobel Field

XSobel

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StereoBmPrefilter XSobel = 1
Public Const XSobel As StereoBmPrefilter = 1
public:
literal StereoBmPrefilter^ XSobel = 1
static val mutable XSobel: StereoBmPrefilter

Field Value

Type: StereoBmPrefilter
See Also

Reference

StereoBmPrefilter Class
Emgu.CV.CvEnum Namespace


StereoRectifyType Class

Type used in cvStereoRectify
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumStereoRectifyType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class StereoRectifyType : Enum
Public NotInheritable Class StereoRectifyType
    Inherits Enum
public ref class StereoRectifyType sealed : public Enum
[<SealedAttribute>]
type StereoRectifyType =
    class
        inherit Enum
    end

The StereoRectifyType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CalibZeroDisparity | Makes the principal points of each camera have the same pixel coordinates in the rectified views
 | Default | Shift one of the image in horizontal or vertical direction (depending on the orientation of epipolar lines) in order to maximise the useful image area
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


StereoRectifyType Methods

The StereoRectifyType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

StereoRectifyType Class
Emgu.CV.CvEnum Namespace


StereoRectifyType Fields

The StereoRectifyType type exposes the following members.

Fields
 | Name | Description
 | CalibZeroDisparity | Makes the principal points of each camera have the same pixel coordinates in the rectified views
 | Default | Shift one of the image in horizontal or vertical direction (depending on the orientation of epipolar lines) in order to maximise the useful image area
Public field | value__ |
Top
See Also

Reference

StereoRectifyType Class
Emgu.CV.CvEnum Namespace


StereoRectifyType.CalibZeroDisparity Field

StereoRectifyTypeCalibZeroDisparity Field

Makes the principal points of each camera have the same pixel coordinates in the rectified views

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StereoRectifyType CalibZeroDisparity = 1024
Public Const CalibZeroDisparity As StereoRectifyType = 1024
public:
literal StereoRectifyType^ CalibZeroDisparity = 1024
static val mutable CalibZeroDisparity: StereoRectifyType

Field Value

Type: StereoRectifyType
See Also

Reference

StereoRectifyType Class
Emgu.CV.CvEnum Namespace


StereoRectifyType.Default Field

StereoRectifyTypeDefault Field

Shift one of the image in horizontal or vertical direction (depending on the orientation of epipolar lines) in order to maximise the useful image area

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StereoRectifyType Default = 0
Public Const Default As StereoRectifyType = 0
public:
literal StereoRectifyType^ Default = 0
static val mutable Default: StereoRectifyType

Field Value

Type: StereoRectifyType
See Also

Reference

StereoRectifyType Class
Emgu.CV.CvEnum Namespace


StereoRectifyType.value__ Field

StereoRectifyTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.StereoRectifyType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

StereoRectifyType Class
Emgu.CV.CvEnum Namespace


StorageOp Class

The file storage operation type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumStorageOp

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class StorageOp : Enum
Public NotInheritable Class StorageOp
    Inherits Enum
public ref class StorageOp sealed : public Enum
[<SealedAttribute>]
type StorageOp =
    class
        inherit Enum
    end

The StorageOp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Append | The storage is open for append
 | Read | The storage is open for reading
Public field | value__ |
 | Write | The storage is open for writing
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


StorageOp Methods

The StorageOp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

StorageOp Class
Emgu.CV.CvEnum Namespace


StorageOp Fields

The StorageOp type exposes the following members.

Fields
 | Name | Description
 | Append | The storage is open for append
 | Read | The storage is open for reading
Public field | value__ |
 | Write | The storage is open for writing
Top
See Also

Reference

StorageOp Class
Emgu.CV.CvEnum Namespace


StorageOp.Append Field

StorageOpAppend Field

The storage is open for append

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StorageOp Append = 2
Public Const Append As StorageOp = 2
public:
literal StorageOp^ Append = 2
static val mutable Append: StorageOp

Field Value

Type: StorageOp
See Also

Reference

StorageOp Class
Emgu.CV.CvEnum Namespace


StorageOp.Read Field

StorageOpRead Field

The storage is open for reading

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StorageOp Read = 0
Public Const Read As StorageOp = 0
public:
literal StorageOp^ Read = 0
static val mutable Read: StorageOp

Field Value

Type: StorageOp
See Also

Reference

StorageOp Class
Emgu.CV.CvEnum Namespace


StorageOp.value__ Field

StorageOpvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.StorageOp.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

StorageOp Class
Emgu.CV.CvEnum Namespace


StorageOp.Write Field

StorageOpWrite Field

The storage is open for writing

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StorageOp Write = 1
Public Const Write As StorageOp = 1
public:
literal StorageOp^ Write = 1
static val mutable Write: StorageOp

Field Value

Type: StorageOp
See Also

Reference

StorageOp Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType Class

The result type of cvSubdiv2DLocate.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSubdiv2DPointLocationType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Subdiv2DPointLocationType : Enum
Public NotInheritable Class Subdiv2DPointLocationType
    Inherits Enum
public ref class Subdiv2DPointLocationType sealed : public Enum
[<SealedAttribute>]
type Subdiv2DPointLocationType =
    class
        inherit Enum
    end

The Subdiv2DPointLocationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Error | One of input arguments is invalid.
 | Inside | Point falls into some facet
 | OnEdge | Point falls onto the edge
 | OutsideRect | Point is outside the subdivision reference rectangle
Public field | value__ |
 | Vertex | Point coincides with one of subdivision vertices
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType Methods

The Subdiv2DPointLocationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType Fields

The Subdiv2DPointLocationType type exposes the following members.

Fields
 | Name | Description
 | Error | One of input arguments is invalid.
 | Inside | Point falls into some facet
 | OnEdge | Point falls onto the edge
 | OutsideRect | Point is outside the subdivision reference rectangle
Public field | value__ |
 | Vertex | Point coincides with one of subdivision vertices
Top
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType.Error Field

Subdiv2DPointLocationTypeError Field

One of input arguments is invalid.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Subdiv2DPointLocationType Error = -2
Public Const Error As Subdiv2DPointLocationType = -2
public:
literal Subdiv2DPointLocationType^ Error = -2
static val mutable Error: Subdiv2DPointLocationType

Field Value

Type: Subdiv2DPointLocationType
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType.Inside Field

Subdiv2DPointLocationTypeInside Field

Point falls into some facet

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Subdiv2DPointLocationType Inside = 0
Public Const Inside As Subdiv2DPointLocationType = 0
public:
literal Subdiv2DPointLocationType^ Inside = 0
static val mutable Inside: Subdiv2DPointLocationType

Field Value

Type: Subdiv2DPointLocationType
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType.OnEdge Field

Subdiv2DPointLocationTypeOnEdge Field

Point falls onto the edge

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Subdiv2DPointLocationType OnEdge = 2
Public Const OnEdge As Subdiv2DPointLocationType = 2
public:
literal Subdiv2DPointLocationType^ OnEdge = 2
static val mutable OnEdge: Subdiv2DPointLocationType

Field Value

Type: Subdiv2DPointLocationType
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType.OutsideRect Field

Subdiv2DPointLocationTypeOutsideRect Field

Point is outside the subdivision reference rectangle

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Subdiv2DPointLocationType OutsideRect = -1
Public Const OutsideRect As Subdiv2DPointLocationType = -1
public:
literal Subdiv2DPointLocationType^ OutsideRect = -1
static val mutable OutsideRect: Subdiv2DPointLocationType

Field Value

Type: Subdiv2DPointLocationType
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType.value__ Field

Subdiv2DPointLocationTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.Subdiv2DPointLocationType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


Subdiv2DPointLocationType.Vertex Field

Subdiv2DPointLocationTypeVertex Field

Point coincides with one of subdivision vertices

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Subdiv2DPointLocationType Vertex = 1
Public Const Vertex As Subdiv2DPointLocationType = 1
public:
literal Subdiv2DPointLocationType^ Vertex = 1
static val mutable Vertex: Subdiv2DPointLocationType

Field Value

Type: Subdiv2DPointLocationType
See Also

Reference

Subdiv2DPointLocationType Class
Emgu.CV.CvEnum Namespace


SvdFlag Class

Type for cvSVD
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumSvdFlag

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class SvdFlag : Enum
<FlagsAttribute>
Public NotInheritable Class SvdFlag
    Inherits Enum
[FlagsAttribute]
public ref class SvdFlag sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type SvdFlag =
    class
        inherit Enum
    end

The SvdFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The default type
 | FullUV | when the matrix is not square, by default the algorithm produces u and vt matrices of sufficiently large size for the further A reconstruction; if, however, FULL_UV flag is specified, u and vt will be full-size square orthogonal matrices.
 | ModifyA | Enables modification of matrix src1 during the operation. It speeds up the processing.
 | NoUV | indicates that only a vector of singular values 'w' is to be processed, while u and vt will be set to empty matrices
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


SvdFlag Methods

The SvdFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SvdFlag Class
Emgu.CV.CvEnum Namespace


SvdFlag Fields

The SvdFlag type exposes the following members.

Fields
 | Name | Description
 | Default | The default type
 | FullUV | when the matrix is not square, by default the algorithm produces u and vt matrices of sufficiently large size for the further A reconstruction; if, however, FULL_UV flag is specified, u and vt will be full-size square orthogonal matrices.
 | ModifyA | Enables modification of matrix src1 during the operation. It speeds up the processing.
 | NoUV | indicates that only a vector of singular values 'w' is to be processed, while u and vt will be set to empty matrices
Public field | value__ |
Top
See Also

Reference

SvdFlag Class
Emgu.CV.CvEnum Namespace


SvdFlag.Default Field

SvdFlagDefault Field

The default type

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SvdFlag Default = 0
Public Const Default As SvdFlag = 0
public:
literal SvdFlag^ Default = 0
static val mutable Default: SvdFlag

Field Value

Type: SvdFlag
See Also

Reference

SvdFlag Class
Emgu.CV.CvEnum Namespace


SvdFlag.FullUV Field

SvdFlagFullUV Field

when the matrix is not square, by default the algorithm produces u and vt matrices of sufficiently large size for the further A reconstruction; if, however, FULL_UV flag is specified, u and vt will be full-size square orthogonal matrices.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SvdFlag FullUV = 4
Public Const FullUV As SvdFlag = 4
public:
literal SvdFlag^ FullUV = 4
static val mutable FullUV: SvdFlag

Field Value

Type: SvdFlag
See Also

Reference

SvdFlag Class
Emgu.CV.CvEnum Namespace


SvdFlag.ModifyA Field

SvdFlagModifyA Field

Enables modification of matrix src1 during the operation. It speeds up the processing.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SvdFlag ModifyA = 1
Public Const ModifyA As SvdFlag = 1
public:
literal SvdFlag^ ModifyA = 1
static val mutable ModifyA: SvdFlag

Field Value

Type: SvdFlag
See Also

Reference

SvdFlag Class
Emgu.CV.CvEnum Namespace


SvdFlag.NoUV Field

SvdFlagNoUV Field

indicates that only a vector of singular values 'w' is to be processed, while u and vt will be set to empty matrices

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SvdFlag NoUV = 2
Public Const NoUV As SvdFlag = 2
public:
literal SvdFlag^ NoUV = 2
static val mutable NoUV: SvdFlag

Field Value

Type: SvdFlag
See Also

Reference

SvdFlag Class
Emgu.CV.CvEnum Namespace


SvdFlag.value__ Field

SvdFlagvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.SvdFlag.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SvdFlag Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType Class

Methods for comparing two array
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumTemplateMatchingType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TemplateMatchingType : Enum
Public NotInheritable Class TemplateMatchingType
    Inherits Enum
public ref class TemplateMatchingType sealed : public Enum
[<SealedAttribute>]
type TemplateMatchingType =
    class
        inherit Enum
    end

The TemplateMatchingType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Ccoeff | R(x,y)=sumx',y'[T'(x',y') I'(x+x',y+y')], where T'(x',y')=T(x',y') - 1/(wxh) sumx",y"T(x",y") I'(x+x',y+y')=I(x+x',y+y') - 1/(wxh) sumx",y"I(x+x",y+y")
 | CcoeffNormed | R(x,y)=sumx',y'[T'(x',y') I'(x+x',y+y')]/sqrt[sumx',y'T'(x',y')2 sumx',y'I'(x+x',y+y')2]
 | Ccorr | R(x,y)=sumx',y'[T(x',y') I(x+x',y+y')]
 | CcorrNormed | R(x,y)=sumx',y'[T(x',y') I(x+x',y+y')]/sqrt[sumx',y'T(x',y')2 sumx',y'I(x+x',y+y')2]
 | Sqdiff | R(x,y)=sumx',y'[T(x',y')-I(x+x',y+y')]2
 | SqdiffNormed | R(x,y)=sumx',y'[T(x',y')-I(x+x',y+y')]2/sqrt[sumx',y'T(x',y')2 sumx',y'I(x+x',y+y')2]
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


TemplateMatchingType Methods

The TemplateMatchingType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType Fields

The TemplateMatchingType type exposes the following members.

Fields
 | Name | Description
 | Ccoeff | R(x,y)=sumx',y'[T'(x',y') I'(x+x',y+y')], where T'(x',y')=T(x',y') - 1/(wxh) sumx",y"T(x",y") I'(x+x',y+y')=I(x+x',y+y') - 1/(wxh) sumx",y"I(x+x",y+y")
 | CcoeffNormed | R(x,y)=sumx',y'[T'(x',y') I'(x+x',y+y')]/sqrt[sumx',y'T'(x',y')2 sumx',y'I'(x+x',y+y')2]
 | Ccorr | R(x,y)=sumx',y'[T(x',y') I(x+x',y+y')]
 | CcorrNormed | R(x,y)=sumx',y'[T(x',y') I(x+x',y+y')]/sqrt[sumx',y'T(x',y')2 sumx',y'I(x+x',y+y')2]
 | Sqdiff | R(x,y)=sumx',y'[T(x',y')-I(x+x',y+y')]2
 | SqdiffNormed | R(x,y)=sumx',y'[T(x',y')-I(x+x',y+y')]2/sqrt[sumx',y'T(x',y')2 sumx',y'I(x+x',y+y')2]
Public field | value__ |
Top
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType.Ccoeff Field

TemplateMatchingTypeCcoeff Field

R(x,y)=sumx',y'[T'(x',y') I'(x+x',y+y')],
where T'(x',y')=T(x',y') - 1/(wxh) sumx",y"T(x",y")
   I'(x+x',y+y')=I(x+x',y+y') - 1/(wxh) sumx",y"I(x+x",y+y")

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TemplateMatchingType Ccoeff = 4
Public Const Ccoeff As TemplateMatchingType = 4
public:
literal TemplateMatchingType^ Ccoeff = 4
static val mutable Ccoeff: TemplateMatchingType

Field Value

Type: TemplateMatchingType
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType.CcoeffNormed Field

TemplateMatchingTypeCcoeffNormed Field

R(x,y)=sumx',y'[T'(x',y') I'(x+x',y+y')]/sqrt[sumx',y'T'(x',y')2 sumx',y'I'(x+x',y+y')2]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TemplateMatchingType CcoeffNormed = 5
Public Const CcoeffNormed As TemplateMatchingType = 5
public:
literal TemplateMatchingType^ CcoeffNormed = 5
static val mutable CcoeffNormed: TemplateMatchingType

Field Value

Type: TemplateMatchingType
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType.Ccorr Field

TemplateMatchingTypeCcorr Field

R(x,y)=sumx',y'[T(x',y') I(x+x',y+y')]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TemplateMatchingType Ccorr = 2
Public Const Ccorr As TemplateMatchingType = 2
public:
literal TemplateMatchingType^ Ccorr = 2
static val mutable Ccorr: TemplateMatchingType

Field Value

Type: TemplateMatchingType
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType.CcorrNormed Field

TemplateMatchingTypeCcorrNormed Field

R(x,y)=sumx',y'[T(x',y') I(x+x',y+y')]/sqrt[sumx',y'T(x',y')2 sumx',y'I(x+x',y+y')2]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TemplateMatchingType CcorrNormed = 3
Public Const CcorrNormed As TemplateMatchingType = 3
public:
literal TemplateMatchingType^ CcorrNormed = 3
static val mutable CcorrNormed: TemplateMatchingType

Field Value

Type: TemplateMatchingType
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType.Sqdiff Field

TemplateMatchingTypeSqdiff Field

R(x,y)=sumx',y'[T(x',y')-I(x+x',y+y')]2

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TemplateMatchingType Sqdiff = 0
Public Const Sqdiff As TemplateMatchingType = 0
public:
literal TemplateMatchingType^ Sqdiff = 0
static val mutable Sqdiff: TemplateMatchingType

Field Value

Type: TemplateMatchingType
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType.SqdiffNormed Field

TemplateMatchingTypeSqdiffNormed Field

R(x,y)=sumx',y'[T(x',y')-I(x+x',y+y')]2/sqrt[sumx',y'T(x',y')2 sumx',y'I(x+x',y+y')2]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TemplateMatchingType SqdiffNormed = 1
Public Const SqdiffNormed As TemplateMatchingType = 1
public:
literal TemplateMatchingType^ SqdiffNormed = 1
static val mutable SqdiffNormed: TemplateMatchingType

Field Value

Type: TemplateMatchingType
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TemplateMatchingType.value__ Field

TemplateMatchingTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.TemplateMatchingType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

TemplateMatchingType Class
Emgu.CV.CvEnum Namespace


TermCritType Class

CV TERMCRIT type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumTermCritType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class TermCritType : Enum
<FlagsAttribute>
Public NotInheritable Class TermCritType
    Inherits Enum
[FlagsAttribute]
public ref class TermCritType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type TermCritType =
    class
        inherit Enum
    end

The TermCritType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Eps | Epsilon
 | Iter | Iteration
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


TermCritType Methods

The TermCritType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

TermCritType Class
Emgu.CV.CvEnum Namespace


TermCritType Fields

The TermCritType type exposes the following members.

Fields
 | Name | Description
 | Eps | Epsilon
 | Iter | Iteration
Public field | value__ |
Top
See Also

Reference

TermCritType Class
Emgu.CV.CvEnum Namespace


TermCritType.Eps Field

TermCritTypeEps Field

Epsilon

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TermCritType Eps = 2
Public Const Eps As TermCritType = 2
public:
literal TermCritType^ Eps = 2
static val mutable Eps: TermCritType

Field Value

Type: TermCritType
See Also

Reference

TermCritType Class
Emgu.CV.CvEnum Namespace


TermCritType.Iter Field

TermCritTypeIter Field

Iteration

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TermCritType Iter = 1
Public Const Iter As TermCritType = 1
public:
literal TermCritType^ Iter = 1
static val mutable Iter: TermCritType

Field Value

Type: TermCritType
See Also

Reference

TermCritType Class
Emgu.CV.CvEnum Namespace


TermCritType.value__ Field

TermCritTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.TermCritType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

TermCritType Class
Emgu.CV.CvEnum Namespace


ThresholdType Class

Types of thresholding
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumThresholdType

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ThresholdType : Enum
Public NotInheritable Class ThresholdType
    Inherits Enum
public ref class ThresholdType sealed : public Enum
[<SealedAttribute>]
type ThresholdType =
    class
        inherit Enum
    end

The ThresholdType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Binary | value = value > threshold ? max_value : 0
 | BinaryInv | value = value > threshold ? 0 : max_value
 | Mask | Mask
 | Otsu | use Otsu algorithm to choose the optimal threshold value; combine the flag with one of the above CV_THRESH_* values
 | ToZero | value = value > threshold ? value : 0
 | ToZeroInv | value = value > threshold ? 0 : value
 | Triangle | Use Triangle algorithm to choose the optimal threshold value
 | Trunc | value = value > threshold ? threshold : value
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


ThresholdType Methods

The ThresholdType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType Fields

The ThresholdType type exposes the following members.

Fields
 | Name | Description
 | Binary | value = value > threshold ? max_value : 0
 | BinaryInv | value = value > threshold ? 0 : max_value
 | Mask | Mask
 | Otsu | use Otsu algorithm to choose the optimal threshold value; combine the flag with one of the above CV_THRESH_* values
 | ToZero | value = value > threshold ? value : 0
 | ToZeroInv | value = value > threshold ? 0 : value
 | Triangle | Use Triangle algorithm to choose the optimal threshold value
 | Trunc | value = value > threshold ? threshold : value
Public field | value__ |
Top
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.Binary Field

ThresholdTypeBinary Field

value = value > threshold ? max_value : 0

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType Binary = 0
Public Const Binary As ThresholdType = 0
public:
literal ThresholdType^ Binary = 0
static val mutable Binary: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.BinaryInv Field

ThresholdTypeBinaryInv Field

value = value > threshold ? 0 : max_value

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType BinaryInv = 1
Public Const BinaryInv As ThresholdType = 1
public:
literal ThresholdType^ BinaryInv = 1
static val mutable BinaryInv: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.Mask Field

ThresholdTypeMask Field

Mask

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType Mask = 7
Public Const Mask As ThresholdType = 7
public:
literal ThresholdType^ Mask = 7
static val mutable Mask: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.Otsu Field

ThresholdTypeOtsu Field

use Otsu algorithm to choose the optimal threshold value; combine the flag with one of the above CV_THRESH_* values

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType Otsu = 8
Public Const Otsu As ThresholdType = 8
public:
literal ThresholdType^ Otsu = 8
static val mutable Otsu: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.ToZero Field

ThresholdTypeToZero Field

value = value > threshold ? value : 0

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType ToZero = 3
Public Const ToZero As ThresholdType = 3
public:
literal ThresholdType^ ToZero = 3
static val mutable ToZero: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.ToZeroInv Field

ThresholdTypeToZeroInv Field

value = value > threshold ? 0 : value

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType ToZeroInv = 4
Public Const ToZeroInv As ThresholdType = 4
public:
literal ThresholdType^ ToZeroInv = 4
static val mutable ToZeroInv: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.Triangle Field

ThresholdTypeTriangle Field

Use Triangle algorithm to choose the optimal threshold value

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType Triangle = 16
Public Const Triangle As ThresholdType = 16
public:
literal ThresholdType^ Triangle = 16
static val mutable Triangle: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.Trunc Field

ThresholdTypeTrunc Field

value = value > threshold ? threshold : value

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThresholdType Trunc = 2
Public Const Trunc As ThresholdType = 2
public:
literal ThresholdType^ Trunc = 2
static val mutable Trunc: ThresholdType

Field Value

Type: ThresholdType
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


ThresholdType.value__ Field

ThresholdTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.ThresholdType.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ThresholdType Class
Emgu.CV.CvEnum Namespace


Warp Class

Types for WarpAffine
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.CvEnumWarp

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Warp : Enum
Public NotInheritable Class Warp
    Inherits Enum
public ref class Warp sealed : public Enum
[<SealedAttribute>]
type Warp =
    class
        inherit Enum
    end

The Warp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Neither FILL_OUTLIERS nor CV_WRAP_INVERSE_MAP
 | FillOutliers | Fill all the destination image pixels. If some of them correspond to outliers in the source image, they are set to fillval.
 | InverseMap | Indicates that matrix is inverse transform from destination image to source and, thus, can be used directly for pixel interpolation. Otherwise, the function finds the inverse transform from map_matrix.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.CvEnum Namespace


Warp Methods

The Warp type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Warp Class
Emgu.CV.CvEnum Namespace


Warp Fields

The Warp type exposes the following members.

Fields
 | Name | Description
 | Default | Neither FILL_OUTLIERS nor CV_WRAP_INVERSE_MAP
 | FillOutliers | Fill all the destination image pixels. If some of them correspond to outliers in the source image, they are set to fillval.
 | InverseMap | Indicates that matrix is inverse transform from destination image to source and, thus, can be used directly for pixel interpolation. Otherwise, the function finds the inverse transform from map_matrix.
Public field | value__ |
Top
See Also

Reference

Warp Class
Emgu.CV.CvEnum Namespace


Warp.Default Field

WarpDefault Field

Neither FILL_OUTLIERS nor CV_WRAP_INVERSE_MAP

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Warp Default = 0
Public Const Default As Warp = 0
public:
literal Warp^ Default = 0
static val mutable Default: Warp

Field Value

Type: Warp
See Also

Reference

Warp Class
Emgu.CV.CvEnum Namespace


Warp.FillOutliers Field

WarpFillOutliers Field

Fill all the destination image pixels. If some of them correspond to outliers in the source image, they are set to fillval.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Warp FillOutliers = 8
Public Const FillOutliers As Warp = 8
public:
literal Warp^ FillOutliers = 8
static val mutable FillOutliers: Warp

Field Value

Type: Warp
See Also

Reference

Warp Class
Emgu.CV.CvEnum Namespace


Warp.InverseMap Field

WarpInverseMap Field

Indicates that matrix is inverse transform from destination image to source and, thus, can be used directly for pixel interpolation. Otherwise, the function finds the inverse transform from map_matrix.

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Warp InverseMap = 16
Public Const InverseMap As Warp = 16
public:
literal Warp^ InverseMap = 16
static val mutable InverseMap: Warp

Field Value

Type: Warp
See Also

Reference

Warp Class
Emgu.CV.CvEnum Namespace


Warp.value__ Field

Warpvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.CvEnum.Warp.value__"]

Namespace: Emgu.CV.CvEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Warp Class
Emgu.CV.CvEnum Namespace


Emgu.CV.Dnn Namespace

Deep Neural Network module
Classes
 | Class | Description
Public class | Backend | Dnn backend.
Public class | BackendTargetPair | DNN Backend and Target pair
Public class | DnnInvoke | Entry points to the Open CV Dnn module
Public class | Layer | This interface class allows to build new Layers - are building blocks of networks.
Public class | Net | This class allows to create and manipulate comprehensive artificial neural networks.
Public class | Target | Target devices for computations.


Backend Class

Dnn backend.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.DnnBackend

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Backend : Enum
Public NotInheritable Class Backend
    Inherits Enum
public ref class Backend sealed : public Enum
[<SealedAttribute>]
type Backend =
    class
        inherit Enum
    end

The Backend type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cuda | Cuda backend
 | Default | Default equals to InferenceEngine if OpenCV is built with Intel's Inference Engine library or Opencv otherwise.
 | Halide | Halide backend
 | InferenceEngine | Intel's Inference Engine library
 | OpenCV | OpenCV's implementation
Public field | value__ |
 | VkCom | Vulkan based backend
Top
See Also

Reference

Emgu.CV.Dnn Namespace


Backend Methods

The Backend type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend Fields

The Backend type exposes the following members.

Fields
 | Name | Description
 | Cuda | Cuda backend
 | Default | Default equals to InferenceEngine if OpenCV is built with Intel's Inference Engine library or Opencv otherwise.
 | Halide | Halide backend
 | InferenceEngine | Intel's Inference Engine library
 | OpenCV | OpenCV's implementation
Public field | value__ |
 | VkCom | Vulkan based backend
Top
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend.Cuda Field

BackendCuda Field

Cuda backend

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Backend Cuda = 5
Public Const Cuda As Backend = 5
public:
literal Backend^ Cuda = 5
static val mutable Cuda: Backend

Field Value

Type: Backend
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend.Default Field

BackendDefault Field

Default equals to InferenceEngine if OpenCV is built with Intel's Inference Engine library or Opencv otherwise.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Backend Default = 0
Public Const Default As Backend = 0
public:
literal Backend^ Default = 0
static val mutable Default: Backend

Field Value

Type: Backend
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend.Halide Field

BackendHalide Field

Halide backend

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Backend Halide = 1
Public Const Halide As Backend = 1
public:
literal Backend^ Halide = 1
static val mutable Halide: Backend

Field Value

Type: Backend
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend.InferenceEngine Field

BackendInferenceEngine Field

Intel's Inference Engine library

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Backend InferenceEngine = 2
Public Const InferenceEngine As Backend = 2
public:
literal Backend^ InferenceEngine = 2
static val mutable InferenceEngine: Backend

Field Value

Type: Backend
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend.OpenCV Field

BackendOpenCV Field

OpenCV's implementation

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Backend OpenCV = 3
Public Const OpenCV As Backend = 3
public:
literal Backend^ OpenCV = 3
static val mutable OpenCV: Backend

Field Value

Type: Backend
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend.value__ Field

Backendvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Dnn.Backend.value__"]

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


Backend.VkCom Field

BackendVkCom Field

Vulkan based backend

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Backend VkCom = 4
Public Const VkCom As Backend = 4
public:
literal Backend^ VkCom = 4
static val mutable VkCom: Backend

Field Value

Type: Backend
See Also

Reference

Backend Class
Emgu.CV.Dnn Namespace


BackendTargetPair Class

DNN Backend and Target pair
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.DnnBackendTargetPair

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class BackendTargetPair : ValueType
Public NotInheritable Class BackendTargetPair
    Inherits ValueType
public ref class BackendTargetPair sealed : public ValueType
[<SealedAttribute>]
type BackendTargetPair =
    class
        inherit ValueType
    end

The BackendTargetPair type exposes the following members.

Constructors
 | Name | Description
Public method | BackendTargetPair | Dnn Backend and Target pair
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Backend | The backend
Public field | Target | The target
Top
See Also

Reference

Emgu.CV.Dnn Namespace


BackendTargetPair Constructor

Dnn Backend and Target pair

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BackendTargetPair(
    Backend backend,
    Target target
)
Public Sub New (
    backend As Backend,
    target As Target
)
public:
BackendTargetPair(
    Backend^ backend,
    Target^ target
)
new :
        backend : Backend *
        target : Target -> BackendTargetPair

Parameters

backend
Type: Emgu.CV.DnnBackend
The backend
target
Type: Emgu.CV.DnnTarget
The target
See Also

Reference

BackendTargetPair Class
Emgu.CV.Dnn Namespace


BackendTargetPair Methods

The BackendTargetPair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

BackendTargetPair Class
Emgu.CV.Dnn Namespace


BackendTargetPair Fields

The BackendTargetPair type exposes the following members.

Fields
 | Name | Description
Public field | Backend | The backend
Public field | Target | The target
Top
See Also

Reference

BackendTargetPair Class
Emgu.CV.Dnn Namespace


BackendTargetPair.Backend Field

BackendTargetPairBackend Field

The backend

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Backend Backend
Public Backend As Backend
public:
Backend^ Backend
val mutable Backend: Backend

Field Value

Type: Backend
See Also

Reference

BackendTargetPair Class
Emgu.CV.Dnn Namespace


BackendTargetPair.Target Field

BackendTargetPairTarget Field

The target

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Target Target
Public Target As Target
public:
Target^ Target
val mutable Target: Target

Field Value

Type: Target
See Also

Reference

BackendTargetPair Class
Emgu.CV.Dnn Namespace


DnnInvoke Class

Entry points to the Open CV Dnn module
Inheritance Hierarchy
SystemObject
Emgu.CV.DnnDnnInvoke

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class DnnInvoke
Public NotInheritable Class DnnInvoke
public ref class DnnInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DnnInvoke =  class end

The DnnInvoke type exposes the following members.

Methods
Name | Description
BlobFromImage(IInputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImage(IInputArray, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImages(Mat, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImages(IInputArrayOfArrays, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scale factor, swap Blue and Red channels.
GetAvailableBackends | Get the list of available DNN Backends
ImagesFromBlob | Parse a 4D blob and output the images it contains as 2D arrays through a simpler data structure (std::vector<cv::Mat>).
NMSBoxes | Performs non maximum suppression given boxes and corresponding scores.
ReadNet | Read deep learning network represented in one of the supported formats.
ReadNetFromCaffe(Byte, Byte) | Reads a network model stored in Caffe framework's format.
ReadNetFromCaffe(String, String) | Reads a network model stored in Caffe framework's format.
ReadNetFromDarknet(Byte, Byte) | Reads a network model stored in Darknet model files.
ReadNetFromDarknet(String, String) | Reads a network model stored in Darknet model files.
ReadNetFromModelOptimizer | Load a network from Intel's Model Optimizer intermediate representation.
ReadNetFromONNX | Reads a network model ONNX.
ReadNetFromTensorflow(Byte, Byte) | Reads a network model stored in TensorFlow framework's format.
ReadNetFromTensorflow(String, String) | Reads a network model stored in TensorFlow framework's format.
ReadTensorFromONNX | Creates blob from .pb file.
ShrinkCaffeModel | Convert all weights of Caffe network to half precision floating point
WriteTextGraph | Create a text representation for a binary network stored in protocol buffer format.
Top
See Also

Reference

Emgu.CV.Dnn Namespace


DnnInvoke Methods

The DnnInvoke type exposes the following members.

Methods
Name | Description
BlobFromImage(IInputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImage(IInputArray, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImages(Mat, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImages(IInputArrayOfArrays, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scale factor, swap Blue and Red channels.
GetAvailableBackends | Get the list of available DNN Backends
ImagesFromBlob | Parse a 4D blob and output the images it contains as 2D arrays through a simpler data structure (std::vector<cv::Mat>).
NMSBoxes | Performs non maximum suppression given boxes and corresponding scores.
ReadNet | Read deep learning network represented in one of the supported formats.
ReadNetFromCaffe(Byte, Byte) | Reads a network model stored in Caffe framework's format.
ReadNetFromCaffe(String, String) | Reads a network model stored in Caffe framework's format.
ReadNetFromDarknet(Byte, Byte) | Reads a network model stored in Darknet model files.
ReadNetFromDarknet(String, String) | Reads a network model stored in Darknet model files.
ReadNetFromModelOptimizer | Load a network from Intel's Model Optimizer intermediate representation.
ReadNetFromONNX | Reads a network model ONNX.
ReadNetFromTensorflow(Byte, Byte) | Reads a network model stored in TensorFlow framework's format.
ReadNetFromTensorflow(String, String) | Reads a network model stored in TensorFlow framework's format.
ReadTensorFromONNX | Creates blob from .pb file.
ShrinkCaffeModel | Convert all weights of Caffe network to half precision floating point
WriteTextGraph | Create a text representation for a binary network stored in protocol buffer format.
Top
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.BlobFromImage Method

DnnInvokeBlobFromImage Method

Overload List
Name | Description
BlobFromImage(IInputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImage(IInputArray, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
Top
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.BlobFromImage Method (IInputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType)

DnnInvokeBlobFromImage Method (IInputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType)

http://www.emgu.com
Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat BlobFromImage(
    IInputArray image,
    double scaleFactor = 1,
    Size size = null,
    MCvScalar mean = null,
    bool swapRB = false,
    bool crop = false,
    DepthType ddepth = 5
)
Public Shared Function BlobFromImage (
    image As IInputArray,
    Optional scaleFactor As Double = 1,
    Optional size As Size = Nothing,
    Optional mean As MCvScalar = Nothing,
    Optional swapRB As Boolean = false,
    Optional crop As Boolean = false,
    Optional ddepth As DepthType = 5
) As Mat
public:
static Mat^ BlobFromImage(
    IInputArray^ image,
    double scaleFactor = 1,
    Size^ size = nullptr,
    MCvScalar^ mean = nullptr,
    bool swapRB = false,
    bool crop = false,
    DepthType^ ddepth = 5
)
static member BlobFromImage :
        image : IInputArray *
        ?scaleFactor : float *
        ?size : Size *
        ?mean : MCvScalar *
        ?swapRB : bool *
        ?crop : bool *
        ?ddepth : DepthType
(* Defaults:
        let _scaleFactor = defaultArg scaleFactor 1
        let _size = defaultArg size null
        let _mean = defaultArg mean null
        let _swapRB = defaultArg swapRB false
        let _crop = defaultArg crop false
        let _ddepth = defaultArg ddepth 5
*)
-> Mat

Parameters

image
Type: Emgu.CVIInputArray
Input image (with 1- or 3-channels).
scaleFactor (Optional)
Type: SystemDouble
Multiplier for image values.
size (Optional)
Type: System.DrawingSize
Spatial size for output image
mean (Optional)
Type: Emgu.CV.StructureMCvScalar
Scalar with mean values which are subtracted from channels. Values are intended to be in (mean-R, mean-G, mean-B) order if image has BGR ordering and swapRB is true.
swapRB (Optional)
Type: SystemBoolean
Flag which indicates that swap first and last channels in 3-channel image is necessary.
crop (Optional)
Type: SystemBoolean
Flag which indicates whether image will be cropped after resize or not
ddepth (Optional)
Type: Emgu.CV.CvEnumDepthType
Depth of output blob. Choose CV_32F or CV_8U.

Return Value

Type: Mat
4-dimensional Mat with NCHW dimensions order.
See Also

Reference

DnnInvoke Class
BlobFromImage Overload
Emgu.CV.Dnn Namespace


DnnInvoke.BlobFromImage Method (IInputArray, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType)

DnnInvokeBlobFromImage Method (IInputArray, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType)

http://www.emgu.com
Creates 4-dimensional blob from image. Optionally resizes and crops image from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BlobFromImage(
    IInputArray image,
    IOutputArray blob,
    double scaleFactor = 1,
    Size size = null,
    MCvScalar mean = null,
    bool swapRB = false,
    bool crop = false,
    DepthType ddepth = 5
)
Public Shared Sub BlobFromImage (
    image As IInputArray,
    blob As IOutputArray,
    Optional scaleFactor As Double = 1,
    Optional size As Size = Nothing,
    Optional mean As MCvScalar = Nothing,
    Optional swapRB As Boolean = false,
    Optional crop As Boolean = false,
    Optional ddepth As DepthType = 5
)
public:
static void BlobFromImage(
    IInputArray^ image,
    IOutputArray^ blob,
    double scaleFactor = 1,
    Size^ size = nullptr,
    MCvScalar^ mean = nullptr,
    bool swapRB = false,
    bool crop = false,
    DepthType^ ddepth = 5
)
static member BlobFromImage :
        image : IInputArray *
        blob : IOutputArray *
        ?scaleFactor : float *
        ?size : Size *
        ?mean : MCvScalar *
        ?swapRB : bool *
        ?crop : bool *
        ?ddepth : DepthType
(* Defaults:
        let _scaleFactor = defaultArg scaleFactor 1
        let _size = defaultArg size null
        let _mean = defaultArg mean null
        let _swapRB = defaultArg swapRB false
        let _crop = defaultArg crop false
        let _ddepth = defaultArg ddepth 5
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
Input image (with 1- or 3-channels).
blob
Type: Emgu.CVIOutputArray
4-dimensional output array with NCHW dimensions order.
scaleFactor (Optional)
Type: SystemDouble
Multiplier for image values.
size (Optional)
Type: System.DrawingSize
Spatial size for output image
mean (Optional)
Type: Emgu.CV.StructureMCvScalar
Scalar with mean values which are subtracted from channels. Values are intended to be in (mean-R, mean-G, mean-B) order if image has BGR ordering and swapRB is true.
swapRB (Optional)
Type: SystemBoolean
Flag which indicates that swap first and last channels in 3-channel image is necessary.
crop (Optional)
Type: SystemBoolean
Flag which indicates whether image will be cropped after resize or not
ddepth (Optional)
Type: Emgu.CV.CvEnumDepthType
Depth of output blob. Choose CV_32F or CV_8U.
See Also

Reference

DnnInvoke Class
BlobFromImage Overload
Emgu.CV.Dnn Namespace


DnnInvoke.BlobFromImages Method

DnnInvokeBlobFromImages Method

Overload List
Name | Description
BlobFromImages(Mat, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.
BlobFromImages(IInputArrayOfArrays, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType) | Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scale factor, swap Blue and Red channels.
Top
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.BlobFromImages Method (Mat[], Double, Size, MCvScalar, Boolean, Boolean, DepthType)

DnnInvokeBlobFromImages Method (Mat, Double, Size, MCvScalar, Boolean, Boolean, DepthType)

http://www.emgu.com
Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scalefactor, swap Blue and Red channels.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat BlobFromImages(
    Mat[] images,
    double scaleFactor = 1,
    Size size = null,
    MCvScalar mean = null,
    bool swapRB = false,
    bool crop = false,
    DepthType ddepth = 5
)
Public Shared Function BlobFromImages (
    images As Mat(),
    Optional scaleFactor As Double = 1,
    Optional size As Size = Nothing,
    Optional mean As MCvScalar = Nothing,
    Optional swapRB As Boolean = false,
    Optional crop As Boolean = false,
    Optional ddepth As DepthType = 5
) As Mat
public:
static Mat^ BlobFromImages(
    array<Mat^>^ images,
    double scaleFactor = 1,
    Size^ size = nullptr,
    MCvScalar^ mean = nullptr,
    bool swapRB = false,
    bool crop = false,
    DepthType^ ddepth = 5
)
static member BlobFromImages :
        images : Mat[] *
        ?scaleFactor : float *
        ?size : Size *
        ?mean : MCvScalar *
        ?swapRB : bool *
        ?crop : bool *
        ?ddepth : DepthType
(* Defaults:
        let _scaleFactor = defaultArg scaleFactor 1
        let _size = defaultArg size null
        let _mean = defaultArg mean null
        let _swapRB = defaultArg swapRB false
        let _crop = defaultArg crop false
        let _ddepth = defaultArg ddepth 5
*)
-> Mat

Parameters

images
Type: Emgu.CVMat
Input images (all with 1- or 3-channels).
scaleFactor (Optional)
Type: SystemDouble
Multiplier for images values.
size (Optional)
Type: System.DrawingSize
Spatial size for output image
mean (Optional)
Type: Emgu.CV.StructureMCvScalar
Scalar with mean values which are subtracted from channels. Values are intended to be in (mean-R, mean-G, mean-B) order if image has BGR ordering and swapRB is true.
swapRB (Optional)
Type: SystemBoolean
Flag which indicates that swap first and last channels in 3-channel image is necessary.
crop (Optional)
Type: SystemBoolean
Flag which indicates whether image will be cropped after resize or not
ddepth (Optional)
Type: Emgu.CV.CvEnumDepthType
Depth of output blob. Choose CV_32F or CV_8U.

Return Value

Type: Mat
Input image is resized so one side after resize is equal to corresponding dimension in size and another one is equal or larger. Then, crop from the center is performed.
See Also

Reference

DnnInvoke Class
BlobFromImages Overload
Emgu.CV.Dnn Namespace


DnnInvoke.BlobFromImages Method (IInputArrayOfArrays, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType)

DnnInvokeBlobFromImages Method (IInputArrayOfArrays, IOutputArray, Double, Size, MCvScalar, Boolean, Boolean, DepthType)

http://www.emgu.com
Creates 4-dimensional blob from series of images. Optionally resizes and crops images from center, subtract mean values, scales values by scale factor, swap Blue and Red channels.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BlobFromImages(
    IInputArrayOfArrays images,
    IOutputArray blob,
    double scaleFactor = 1,
    Size size = null,
    MCvScalar mean = null,
    bool swapRB = false,
    bool crop = false,
    DepthType ddepth = 5
)
Public Shared Sub BlobFromImages (
    images As IInputArrayOfArrays,
    blob As IOutputArray,
    Optional scaleFactor As Double = 1,
    Optional size As Size = Nothing,
    Optional mean As MCvScalar = Nothing,
    Optional swapRB As Boolean = false,
    Optional crop As Boolean = false,
    Optional ddepth As DepthType = 5
)
public:
static void BlobFromImages(
    IInputArrayOfArrays^ images,
    IOutputArray^ blob,
    double scaleFactor = 1,
    Size^ size = nullptr,
    MCvScalar^ mean = nullptr,
    bool swapRB = false,
    bool crop = false,
    DepthType^ ddepth = 5
)
static member BlobFromImages :
        images : IInputArrayOfArrays *
        blob : IOutputArray *
        ?scaleFactor : float *
        ?size : Size *
        ?mean : MCvScalar *
        ?swapRB : bool *
        ?crop : bool *
        ?ddepth : DepthType
(* Defaults:
        let _scaleFactor = defaultArg scaleFactor 1
        let _size = defaultArg size null
        let _mean = defaultArg mean null
        let _swapRB = defaultArg swapRB false
        let _crop = defaultArg crop false
        let _ddepth = defaultArg ddepth 5
*)
-> unit

Parameters

images
Type: Emgu.CVIInputArrayOfArrays
input images (all with 1-, 3- or 4-channels).
blob
Type: Emgu.CVIOutputArray
4-dimensional OutputArray with NCHW dimensions order.
scaleFactor (Optional)
Type: SystemDouble
multiplier for images values.
size (Optional)
Type: System.DrawingSize
spatial size for output image
mean (Optional)
Type: Emgu.CV.StructureMCvScalar
scalar with mean values which are subtracted from channels. Values are intended to be in (mean-R, mean-G, mean-B) order if image has BGR ordering and swapRB is true.
swapRB (Optional)
Type: SystemBoolean
flag which indicates that swap first and last channels in 3-channel image is necessary.
crop (Optional)
Type: SystemBoolean
flag which indicates whether image will be cropped after resize or not
ddepth (Optional)
Type: Emgu.CV.CvEnumDepthType
Depth of output blob. Choose CV_32F or CV_8U.
See Also

Reference

DnnInvoke Class
BlobFromImages Overload
Emgu.CV.Dnn Namespace


DnnInvoke.GetAvailableBackends Method

DnnInvokeGetAvailableBackends Method

Get the list of available DNN Backends

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static BackendTargetPair[] GetAvailableBackends()
Public Shared Function GetAvailableBackends As BackendTargetPair()
public:
static array<BackendTargetPair^>^ GetAvailableBackends()
static member GetAvailableBackends : unit -> BackendTargetPair[]

Return Value

Type: BackendTargetPair
The available backend and target pair
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ImagesFromBlob Method

DnnInvokeImagesFromBlob Method

Parse a 4D blob and output the images it contains as 2D arrays through a simpler data structure (std::vector<cv::Mat>).

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ImagesFromBlob(
    Mat blob,
    IOutputArrayOfArrays images
)
Public Shared Sub ImagesFromBlob (
    blob As Mat,
    images As IOutputArrayOfArrays
)
public:
static void ImagesFromBlob(
    Mat^ blob,
    IOutputArrayOfArrays^ images
)
static member ImagesFromBlob :
        blob : Mat *
        images : IOutputArrayOfArrays -> unit

Parameters

blob
Type: Emgu.CVMat
4 dimensional array (images, channels, height, width) in floating point precision (CV_32F) from which you would like to extract the images.
images
Type: Emgu.CVIOutputArrayOfArrays
Array of 2D Mat containing the images extracted from the blob in floating point precision (CV_32F). They are non normalized neither mean added. The number of returned images equals the first dimension of the blob (batch size). Every image has a number of channels equals to the second dimension of the blob (depth).
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.NMSBoxes Method

DnnInvokeNMSBoxes Method

Performs non maximum suppression given boxes and corresponding scores.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void NMSBoxes(
    VectorOfRect bboxes,
    VectorOfFloat scores,
    float scoreThreshold,
    float nmsThreshold,
    VectorOfInt indices,
    float eta = 1f,
    int topK = 0
)
Public Shared Sub NMSBoxes (
    bboxes As VectorOfRect,
    scores As VectorOfFloat,
    scoreThreshold As Single,
    nmsThreshold As Single,
    indices As VectorOfInt,
    Optional eta As Single = 1F,
    Optional topK As Integer = 0
)
public:
static void NMSBoxes(
    VectorOfRect^ bboxes,
    VectorOfFloat^ scores,
    float scoreThreshold,
    float nmsThreshold,
    VectorOfInt^ indices,
    float eta = 1f,
    int topK = 0
)
static member NMSBoxes :
        bboxes : VectorOfRect *
        scores : VectorOfFloat *
        scoreThreshold : float32 *
        nmsThreshold : float32 *
        indices : VectorOfInt *
        ?eta : float32 *
        ?topK : int
(* Defaults:
        let _eta = defaultArg eta 1f
        let _topK = defaultArg topK 0
*)
-> unit

Parameters

bboxes
Type: Emgu.CV.UtilVectorOfRect
A set of bounding boxes to apply NMS.
scores
Type: Emgu.CV.UtilVectorOfFloat
A set of corresponding confidences.
scoreThreshold
Type: SystemSingle
A threshold used to filter boxes by score.
nmsThreshold
Type: SystemSingle
A threshold used in non maximum suppression.
indices
Type: Emgu.CV.UtilVectorOfInt
The kept indices of bboxes after NMS.
eta (Optional)
Type: SystemSingle
A coefficient in adaptive threshold
topK (Optional)
Type: SystemInt32
If >0, keep at most top_k picked indices.
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNet Method

DnnInvokeReadNet Method

Read deep learning network represented in one of the supported formats.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNet(
    string model,
    string config = null,
    string framework = null
)
Public Shared Function ReadNet (
    model As String,
    Optional config As String = Nothing,
    Optional framework As String = Nothing
) As Net
public:
static Net^ ReadNet(
    String^ model,
    String^ config = nullptr,
    String^ framework = nullptr
)
static member ReadNet :
        model : string *
        ?config : string *
        ?framework : string
(* Defaults:
        let _config = defaultArg config null
        let _framework = defaultArg framework null
*)
-> Net

Parameters

model
Type: SystemString
Binary file contains trained weights. The following file extensions are expected for models from different frameworks: *.caffemodel(Caffe, http://caffe.berkeleyvision.org/) *.pb (TensorFlow, https://www.tensorflow.org/) *.t7 | *.net (Torch, http://torch.ch/) *.weights (Darknet, https://pjreddie.com/darknet/) *.bin (DLDT, https://software.intel.com/openvino-toolkit)
config (Optional)
Type: SystemString
Text file contains network configuration. It could be a file with the following extensions: *.prototxt(Caffe, http://caffe.berkeleyvision.org/) *.pbtxt (TensorFlow, https://www.tensorflow.org/) *.cfg (Darknet, https://pjreddie.com/darknet/) *.xml (DLDT, https://software.intel.com/openvino-toolkit)
framework (Optional)
Type: SystemString
Explicit framework name tag to determine a format.

Return Value

Type: Net
Net object.
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromCaffe Method

DnnInvokeReadNetFromCaffe Method

Overload List
Name | Description
ReadNetFromCaffe(Byte, Byte) | Reads a network model stored in Caffe framework's format.
ReadNetFromCaffe(String, String) | Reads a network model stored in Caffe framework's format.
Top
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromCaffe Method (Byte[], Byte[])

DnnInvokeReadNetFromCaffe Method (Byte, Byte)

http://www.emgu.com
Reads a network model stored in Caffe framework's format.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromCaffe(
    byte[] prototxt,
    byte[] caffeModel = null
)
Public Shared Function ReadNetFromCaffe (
    prototxt As Byte(),
    Optional caffeModel As Byte() = Nothing
) As Net
public:
static Net^ ReadNetFromCaffe(
    array<unsigned char>^ prototxt,
    array<unsigned char>^ caffeModel = nullptr
)
static member ReadNetFromCaffe :
        prototxt : byte[] *
        ?caffeModel : byte[]
(* Defaults:
        let _caffeModel = defaultArg caffeModel null
*)
-> Net

Parameters

prototxt
Type: SystemByte
Buffer containing the content of the .prototxt file
caffeModel (Optional)
Type: SystemByte
Buffer containing the content of the .caffemodel file

Return Value

Type: Net
Net object.
See Also

Reference

DnnInvoke Class
ReadNetFromCaffe Overload
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromCaffe Method (String, String)

DnnInvokeReadNetFromCaffe Method (String, String)

http://www.emgu.com
Reads a network model stored in Caffe framework's format.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromCaffe(
    string prototxt,
    string caffeModel = null
)
Public Shared Function ReadNetFromCaffe (
    prototxt As String,
    Optional caffeModel As String = Nothing
) As Net
public:
static Net^ ReadNetFromCaffe(
    String^ prototxt,
    String^ caffeModel = nullptr
)
static member ReadNetFromCaffe :
        prototxt : string *
        ?caffeModel : string
(* Defaults:
        let _caffeModel = defaultArg caffeModel null
*)
-> Net

Parameters

prototxt
Type: SystemString
path to the .prototxt file with text description of the network architecture.
caffeModel (Optional)
Type: SystemString
path to the .caffemodel file with learned network.

Return Value

Type: Net
Net object.
See Also

Reference

DnnInvoke Class
ReadNetFromCaffe Overload
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromDarknet Method

DnnInvokeReadNetFromDarknet Method

Overload List
Name | Description
ReadNetFromDarknet(Byte, Byte) | Reads a network model stored in Darknet model files.
ReadNetFromDarknet(String, String) | Reads a network model stored in Darknet model files.
Top
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromDarknet Method (Byte[], Byte[])

DnnInvokeReadNetFromDarknet Method (Byte, Byte)

http://www.emgu.com
Reads a network model stored in Darknet model files.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromDarknet(
    byte[] bufferCfg,
    byte[] bufferModel = null
)
Public Shared Function ReadNetFromDarknet (
    bufferCfg As Byte(),
    Optional bufferModel As Byte() = Nothing
) As Net
public:
static Net^ ReadNetFromDarknet(
    array<unsigned char>^ bufferCfg,
    array<unsigned char>^ bufferModel = nullptr
)
static member ReadNetFromDarknet :
        bufferCfg : byte[] *
        ?bufferModel : byte[]
(* Defaults:
        let _bufferModel = defaultArg bufferModel null
*)
-> Net

Parameters

bufferCfg
Type: SystemByte
Buffer containing the content of the .cfg file with text description of the network architecture.
bufferModel (Optional)
Type: SystemByte
Buffer containing the content of the the .weights file with learned network.

Return Value

Type: Net
Net object.
See Also

Reference

DnnInvoke Class
ReadNetFromDarknet Overload
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromDarknet Method (String, String)

DnnInvokeReadNetFromDarknet Method (String, String)

http://www.emgu.com
Reads a network model stored in Darknet model files.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromDarknet(
    string cfgFile,
    string darknetModel = null
)
Public Shared Function ReadNetFromDarknet (
    cfgFile As String,
    Optional darknetModel As String = Nothing
) As Net
public:
static Net^ ReadNetFromDarknet(
    String^ cfgFile,
    String^ darknetModel = nullptr
)
static member ReadNetFromDarknet :
        cfgFile : string *
        ?darknetModel : string
(* Defaults:
        let _darknetModel = defaultArg darknetModel null
*)
-> Net

Parameters

cfgFile
Type: SystemString
path to the .cfg file with text description of the network architecture.
darknetModel (Optional)
Type: SystemString
path to the .weights file with learned network.

Return Value

Type: Net
Network object that ready to do forward, throw an exception in failure cases.
See Also

Reference

DnnInvoke Class
ReadNetFromDarknet Overload
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromModelOptimizer Method

DnnInvokeReadNetFromModelOptimizer Method

Load a network from Intel's Model Optimizer intermediate representation.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromModelOptimizer(
    string xml,
    string bin
)
Public Shared Function ReadNetFromModelOptimizer (
    xml As String,
    bin As String
) As Net
public:
static Net^ ReadNetFromModelOptimizer(
    String^ xml,
    String^ bin
)
static member ReadNetFromModelOptimizer :
        xml : string *
        bin : string -> Net

Parameters

xml
Type: SystemString
XML configuration file with network's topology.
bin
Type: SystemString
Binary file with trained weights.

Return Value

Type: Net
Net object. Networks imported from Intel's Model Optimizer are launched in Intel's Inference Engine backend.
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromONNX Method

DnnInvokeReadNetFromONNX Method

Reads a network model ONNX.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromONNX(
    string onnxFile
)
Public Shared Function ReadNetFromONNX (
    onnxFile As String
) As Net
public:
static Net^ ReadNetFromONNX(
    String^ onnxFile
)
static member ReadNetFromONNX :
        onnxFile : string -> Net

Parameters

onnxFile
Type: SystemString
Path to the .onnx file with text description of the network architecture.

Return Value

Type: Net
Network object that ready to do forward, throw an exception in failure cases.
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromTensorflow Method

DnnInvokeReadNetFromTensorflow Method

Overload List
Name | Description
ReadNetFromTensorflow(Byte, Byte) | Reads a network model stored in TensorFlow framework's format.
ReadNetFromTensorflow(String, String) | Reads a network model stored in TensorFlow framework's format.
Top
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromTensorflow Method (Byte[], Byte[])

DnnInvokeReadNetFromTensorflow Method (Byte, Byte)

http://www.emgu.com
Reads a network model stored in TensorFlow framework's format.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromTensorflow(
    byte[] model,
    byte[] config = null
)
Public Shared Function ReadNetFromTensorflow (
    model As Byte(),
    Optional config As Byte() = Nothing
) As Net
public:
static Net^ ReadNetFromTensorflow(
    array<unsigned char>^ model,
    array<unsigned char>^ config = nullptr
)
static member ReadNetFromTensorflow :
        model : byte[] *
        ?config : byte[]
(* Defaults:
        let _config = defaultArg config null
*)
-> Net

Parameters

model
Type: SystemByte
buffer containing the content of the pb file
config (Optional)
Type: SystemByte
buffer containing the content of the pbtxt file

Return Value

Type: Net
Net object.
See Also

Reference

DnnInvoke Class
ReadNetFromTensorflow Overload
Emgu.CV.Dnn Namespace


DnnInvoke.ReadNetFromTensorflow Method (String, String)

DnnInvokeReadNetFromTensorflow Method (String, String)

http://www.emgu.com
Reads a network model stored in TensorFlow framework's format.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Net ReadNetFromTensorflow(
    string model,
    string config = null
)
Public Shared Function ReadNetFromTensorflow (
    model As String,
    Optional config As String = Nothing
) As Net
public:
static Net^ ReadNetFromTensorflow(
    String^ model,
    String^ config = nullptr
)
static member ReadNetFromTensorflow :
        model : string *
        ?config : string
(* Defaults:
        let _config = defaultArg config null
*)
-> Net

Parameters

model
Type: SystemString
path to the .pb file with binary protobuf description of the network architecture
config (Optional)
Type: SystemString
path to the .pbtxt file that contains text graph definition in protobuf format. Resulting Net object is built by text graph using weights from a binary one that let us make it more flexible.

Return Value

Type: Net
Net object.
See Also

Reference

DnnInvoke Class
ReadNetFromTensorflow Overload
Emgu.CV.Dnn Namespace


DnnInvoke.ReadTensorFromONNX Method

DnnInvokeReadTensorFromONNX Method

Creates blob from .pb file.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat ReadTensorFromONNX(
    string path
)
Public Shared Function ReadTensorFromONNX (
    path As String
) As Mat
public:
static Mat^ ReadTensorFromONNX(
    String^ path
)
static member ReadTensorFromONNX :
        path : string -> Mat

Parameters

path
Type: SystemString
Path to the .pb file with input tensor.

Return Value

Type: Mat
The blob
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.ShrinkCaffeModel Method

DnnInvokeShrinkCaffeModel Method

Convert all weights of Caffe network to half precision floating point

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ShrinkCaffeModel(
    string src,
    string dst
)
Public Shared Sub ShrinkCaffeModel (
    src As String,
    dst As String
)
public:
static void ShrinkCaffeModel(
    String^ src,
    String^ dst
)
static member ShrinkCaffeModel :
        src : string *
        dst : string -> unit

Parameters

src
Type: SystemString
Path to origin model from Caffe framework contains single precision floating point weights (usually has .caffemodel extension).
dst
Type: SystemString
Path to destination model with updated weights.
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


DnnInvoke.WriteTextGraph Method

DnnInvokeWriteTextGraph Method

Create a text representation for a binary network stored in protocol buffer format.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void WriteTextGraph(
    string model,
    string output
)
Public Shared Sub WriteTextGraph (
    model As String,
    output As String
)
public:
static void WriteTextGraph(
    String^ model,
    String^ output
)
static member WriteTextGraph :
        model : string *
        output : string -> unit

Parameters

model
Type: SystemString
A path to binary network.
output
Type: SystemString
A path to output text file to be created.
See Also

Reference

DnnInvoke Class
Emgu.CV.Dnn Namespace


Layer Class

This interface class allows to build new Layers - are building blocks of networks.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.DnnLayer

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Layer : SharedPtrObject
Public Class Layer
    Inherits SharedPtrObject
public ref class Layer : public SharedPtrObject
type Layer =
    class
        inherit SharedPtrObject
    end

The Layer type exposes the following members.

Properties
 | Name | Description
Public property | Blobs | List of learned parameters must be stored here to allow read them by using Net::getParam().
Public property | Name | The name of the layer
Public property | PreferableTarget | The preferable target
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | Type | The layer type
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Layer. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Dnn Namespace


Layer Properties

The Layer type exposes the following members.

Properties
 | Name | Description
Public property | Blobs | List of learned parameters must be stored here to allow read them by using Net::getParam().
Public property | Name | The name of the layer
Public property | PreferableTarget | The preferable target
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | Type | The layer type
Top
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Layer.Blobs Property

LayerBlobs Property

List of learned parameters must be stored here to allow read them by using Net::getParam().

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfMat Blobs { get; }
Public ReadOnly Property Blobs As VectorOfMat
    Get
public:
property VectorOfMat^ Blobs {
    VectorOfMat^ get ();
}
member Blobs : VectorOfMat with get

Property Value

Type: VectorOfMat
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Layer.Name Property

LayerName Property

The name of the layer

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Layer.PreferableTarget Property

LayerPreferableTarget Property

The preferable target

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Target PreferableTarget { get; }
Public ReadOnly Property PreferableTarget As Target
    Get
public:
property Target^ PreferableTarget {
    Target^ get ();
}
member PreferableTarget : Target with get

Property Value

Type: Target
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Layer.Type Property

LayerType Property

The layer type

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get
public:
property String^ Type {
    String^ get ();
}
member Type : string with get

Property Value

Type: String
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Layer Methods

The Layer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Layer. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Layer.DisposeObject Method

LayerDisposeObject Method

Release the unmanaged memory associated with this Layer.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Layer Fields

The Layer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Layer Class
Emgu.CV.Dnn Namespace


Net Class

This class allows to create and manipulate comprehensive artificial neural networks.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.DnnNet

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Net : UnmanagedObject
Public Class Net
    Inherits UnmanagedObject
public ref class Net : public UnmanagedObject
type Net =
    class
        inherit UnmanagedObject
    end

The Net type exposes the following members.

Constructors
 | Name | Description
Public method | Net | Default constructor.
Top
Properties
 | Name | Description
Public property | Empty | Returns true if there are no layers in the network.
Public property | LayerNames | Return the LayerNames
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | UnconnectedOutLayers | Returns indexes of layers with unconnected outputs.
Public property | UnconnectedOutLayersNames | Returns names of layers with unconnected outputs.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this network. (Overrides DisposableObjectDisposeObject.)
Public method | Dump | Dump net to String
Public method | DumpToFile | Dump net structure, hyperparameters, backend, target and fusion to dot file
Public method | EnableFusion | Enables or disables layer fusion in the network.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Forward(String) | Runs forward pass for the whole network.
Public method | Forward(IOutputArrayOfArrays, String) | Runs forward pass to compute output of layer with name outputName.
Public method | Forward(IOutputArrayOfArrays, String) | Runs forward pass to compute outputs of layers listed in outBlobNames.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayer(Int32) | Returns layer with specified id which the network use.
Public method | GetLayer(String) | Returns layer with specified name which the network use.
Public method | GetLayerId | Converts string name of the layer to the integer identifier.
Public method | GetPerfProfile | Returns overall time for inference and timings (in ticks) for layers. Indexes in returned vector correspond to layers ids. Some layers can be fused with others, in this case zero ticks count will be return for that skipped layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetHalideScheduler | Schedule layers that support Halide backend. Then compile them for specific target. For layers that not represented in scheduling file or if no manual scheduling used at all, automatic scheduling will be applied.
Public method | SetInput | Sets the new value for the layer output blob.
Public method | SetPreferableBackend | Ask network to use specific computation backend where it supported.
Public method | SetPreferableTarget | Ask network to make computations on specific target device.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Dnn Namespace


Net Constructor

Default constructor.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Net()
Public Sub New
public:
Net()
new : unit -> Net
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net Properties

The Net type exposes the following members.

Properties
 | Name | Description
Public property | Empty | Returns true if there are no layers in the network.
Public property | LayerNames | Return the LayerNames
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | UnconnectedOutLayers | Returns indexes of layers with unconnected outputs.
Public property | UnconnectedOutLayersNames | Returns names of layers with unconnected outputs.
Top
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.Empty Property

NetEmpty Property

Returns true if there are no layers in the network.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get

Property Value

Type: Boolean
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.LayerNames Property

NetLayerNames Property

Return the LayerNames

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] LayerNames { get; }
Public ReadOnly Property LayerNames As String()
    Get
public:
property array<String^>^ LayerNames {
    array<String^>^ get ();
}
member LayerNames : string[] with get

Property Value

Type: String
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.UnconnectedOutLayers Property

NetUnconnectedOutLayers Property

Returns indexes of layers with unconnected outputs.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] UnconnectedOutLayers { get; }
Public ReadOnly Property UnconnectedOutLayers As Integer()
    Get
public:
property array<int>^ UnconnectedOutLayers {
    array<int>^ get ();
}
member UnconnectedOutLayers : int[] with get

Property Value

Type: Int32
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.UnconnectedOutLayersNames Property

NetUnconnectedOutLayersNames Property

Returns names of layers with unconnected outputs.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] UnconnectedOutLayersNames { get; }
Public ReadOnly Property UnconnectedOutLayersNames As String()
    Get
public:
property array<String^>^ UnconnectedOutLayersNames {
    array<String^>^ get ();
}
member UnconnectedOutLayersNames : string[] with get

Property Value

Type: String
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net Methods

The Net type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this network. (Overrides DisposableObjectDisposeObject.)
Public method | Dump | Dump net to String
Public method | DumpToFile | Dump net structure, hyperparameters, backend, target and fusion to dot file
Public method | EnableFusion | Enables or disables layer fusion in the network.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Forward(String) | Runs forward pass for the whole network.
Public method | Forward(IOutputArrayOfArrays, String) | Runs forward pass to compute output of layer with name outputName.
Public method | Forward(IOutputArrayOfArrays, String) | Runs forward pass to compute outputs of layers listed in outBlobNames.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayer(Int32) | Returns layer with specified id which the network use.
Public method | GetLayer(String) | Returns layer with specified name which the network use.
Public method | GetLayerId | Converts string name of the layer to the integer identifier.
Public method | GetPerfProfile | Returns overall time for inference and timings (in ticks) for layers. Indexes in returned vector correspond to layers ids. Some layers can be fused with others, in this case zero ticks count will be return for that skipped layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetHalideScheduler | Schedule layers that support Halide backend. Then compile them for specific target. For layers that not represented in scheduling file or if no manual scheduling used at all, automatic scheduling will be applied.
Public method | SetInput | Sets the new value for the layer output blob.
Public method | SetPreferableBackend | Ask network to use specific computation backend where it supported.
Public method | SetPreferableTarget | Ask network to make computations on specific target device.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.DisposeObject Method

NetDisposeObject Method

Release the memory associated with this network.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.Dump Method

NetDump Method

Dump net to String

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Dump()
Public Function Dump As String
public:
String^ Dump()
member Dump : unit -> string

Return Value

Type: String
String with structure, hyperparameters, backend, target and fusion Call method after setInput(). To see correct backend, target and fusion run after forward().
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.DumpToFile Method

NetDumpToFile Method

Dump net structure, hyperparameters, backend, target and fusion to dot file

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DumpToFile(
    string path
)
Public Sub DumpToFile (
    path As String
)
public:
void DumpToFile(
    String^ path
)
member DumpToFile :
        path : string -> unit

Parameters

path
Type: SystemString
Path to output file with .dot extension
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.EnableFusion Method

NetEnableFusion Method

Enables or disables layer fusion in the network.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void EnableFusion(
    bool value
)
Public Sub EnableFusion (
    value As Boolean
)
public:
void EnableFusion(
    bool value
)
member EnableFusion :
        value : bool -> unit

Parameters

value
Type: SystemBoolean
The value
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.Forward Method

NetForward Method

Overload List
 | Name | Description
Public method | Forward(String) | Runs forward pass for the whole network.
Public method | Forward(IOutputArrayOfArrays, String) | Runs forward pass to compute output of layer with name outputName.
Public method | Forward(IOutputArrayOfArrays, String) | Runs forward pass to compute outputs of layers listed in outBlobNames.
Top
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.Forward Method (String)

NetForward Method (String)

http://www.emgu.com
Runs forward pass for the whole network.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat Forward(
    string outputName = ""
)
Public Function Forward (
    Optional outputName As String = ""
) As Mat
public:
Mat^ Forward(
    String^ outputName = L""
)
member Forward :
        ?outputName : string
(* Defaults:
        let _outputName = defaultArg outputName ""
*)
-> Mat

Parameters

outputName (Optional)
Type: SystemString
name for layer which output is needed to get

Return Value

Type: Mat
blob for first output of specified layer
See Also

Reference

Net Class
Forward Overload
Emgu.CV.Dnn Namespace


Net.Forward Method (IOutputArrayOfArrays, String)

NetForward Method (IOutputArrayOfArrays, String)

http://www.emgu.com
Runs forward pass to compute output of layer with name outputName.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Forward(
    IOutputArrayOfArrays outputBlobs,
    string outputName = ""
)
Public Sub Forward (
    outputBlobs As IOutputArrayOfArrays,
    Optional outputName As String = ""
)
public:
void Forward(
    IOutputArrayOfArrays^ outputBlobs,
    String^ outputName = L""
)
member Forward :
        outputBlobs : IOutputArrayOfArrays *
        ?outputName : string
(* Defaults:
        let _outputName = defaultArg outputName ""
*)
-> unit

Parameters

outputBlobs
Type: Emgu.CVIOutputArrayOfArrays
Contains all output blobs for specified layer.
outputName (Optional)
Type: SystemString
Name for layer which output is needed to get
See Also

Reference

Net Class
Forward Overload
Emgu.CV.Dnn Namespace


Net.Forward Method (IOutputArrayOfArrays, String[])

NetForward Method (IOutputArrayOfArrays, String)

http://www.emgu.com
Runs forward pass to compute outputs of layers listed in outBlobNames.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Forward(
    IOutputArrayOfArrays outputBlobs,
    string[] outBlobNames
)
Public Sub Forward (
    outputBlobs As IOutputArrayOfArrays,
    outBlobNames As String()
)
public:
void Forward(
    IOutputArrayOfArrays^ outputBlobs,
    array<String^>^ outBlobNames
)
member Forward :
        outputBlobs : IOutputArrayOfArrays *
        outBlobNames : string[] -> unit

Parameters

outputBlobs
Type: Emgu.CVIOutputArrayOfArrays
Contains blobs for first outputs of specified layers.
outBlobNames
Type: SystemString
Names for layers which outputs are needed to get
See Also

Reference

Net Class
Forward Overload
Emgu.CV.Dnn Namespace


Net.GetLayer Method

NetGetLayer Method

Overload List
 | Name | Description
Public method | GetLayer(Int32) | Returns layer with specified id which the network use.
Public method | GetLayer(String) | Returns layer with specified name which the network use.
Top
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.GetLayer Method (Int32)

NetGetLayer Method (Int32)

http://www.emgu.com
Returns layer with specified id which the network use.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Layer GetLayer(
    int layerId
)
Public Function GetLayer (
    layerId As Integer
) As Layer
public:
Layer^ GetLayer(
    int layerId
)
member GetLayer :
        layerId : int -> Layer

Parameters

layerId
Type: SystemInt32
The id of the layer

Return Value

Type: Layer
Layer with specified id which the network use.
See Also

Reference

Net Class
GetLayer Overload
Emgu.CV.Dnn Namespace


Net.GetLayer Method (String)

NetGetLayer Method (String)

http://www.emgu.com
Returns layer with specified name which the network use.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Layer GetLayer(
    string layerName
)
Public Function GetLayer (
    layerName As String
) As Layer
public:
Layer^ GetLayer(
    String^ layerName
)
member GetLayer :
        layerName : string -> Layer

Parameters

layerName
Type: SystemString
The name of the layer

Return Value

Type: Layer
Layer with specified name which the network use.
See Also

Reference

Net Class
GetLayer Overload
Emgu.CV.Dnn Namespace


Net.GetLayerId Method

NetGetLayerId Method

Converts string name of the layer to the integer identifier.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetLayerId(
    string layerName
)
Public Function GetLayerId (
    layerName As String
) As Integer
public:
int GetLayerId(
    String^ layerName
)
member GetLayerId :
        layerName : string -> int

Parameters

layerName
Type: SystemString
The name of the layer

Return Value

Type: Int32
The id of the layer
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.GetPerfProfile Method

NetGetPerfProfile Method

Returns overall time for inference and timings (in ticks) for layers. Indexes in returned vector correspond to layers ids. Some layers can be fused with others, in this case zero ticks count will be return for that skipped layers.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public long GetPerfProfile(
    VectorOfDouble timings = null
)
Public Function GetPerfProfile (
    Optional timings As VectorOfDouble = Nothing
) As Long
public:
long long GetPerfProfile(
    VectorOfDouble^ timings = nullptr
)
member GetPerfProfile :
        ?timings : VectorOfDouble
(* Defaults:
        let _timings = defaultArg timings null
*)
-> int64

Parameters

timings (Optional)
Type: Emgu.CV.UtilVectorOfDouble
Vector for tick timings for all layers.

Return Value

Type: Int64
Overall ticks for model inference.
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.SetHalideScheduler Method

NetSetHalideScheduler Method

Schedule layers that support Halide backend. Then compile them for specific target. For layers that not represented in scheduling file or if no manual scheduling used at all, automatic scheduling will be applied.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetHalideScheduler(
    string s
)
Public Sub SetHalideScheduler (
    s As String
)
public:
void SetHalideScheduler(
    String^ s
)
member SetHalideScheduler :
        s : string -> unit

Parameters

s
Type: SystemString
The value
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.SetInput Method

NetSetInput Method

Sets the new value for the layer output blob.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetInput(
    IInputArray blob,
    string name = "",
    double scaleFactor = 1,
    MCvScalar mean = null
)
Public Sub SetInput (
    blob As IInputArray,
    Optional name As String = "",
    Optional scaleFactor As Double = 1,
    Optional mean As MCvScalar = Nothing
)
public:
void SetInput(
    IInputArray^ blob,
    String^ name = L"",
    double scaleFactor = 1,
    MCvScalar^ mean = nullptr
)
member SetInput :
        blob : IInputArray *
        ?name : string *
        ?scaleFactor : float *
        ?mean : MCvScalar
(* Defaults:
        let _name = defaultArg name ""
        let _scaleFactor = defaultArg scaleFactor 1
        let _mean = defaultArg mean null
*)
-> unit

Parameters

blob
Type: Emgu.CVIInputArray
Input blob
name (Optional)
Type: SystemString
Descriptor of the updating layer output blob.
scaleFactor (Optional)
Type: SystemDouble
An optional normalization scale.
mean (Optional)
Type: Emgu.CV.StructureMCvScalar
An optional mean subtraction values.
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.SetPreferableBackend Method

NetSetPreferableBackend Method

Ask network to use specific computation backend where it supported.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPreferableBackend(
    Backend value
)
Public Sub SetPreferableBackend (
    value As Backend
)
public:
void SetPreferableBackend(
    Backend^ value
)
member SetPreferableBackend :
        value : Backend -> unit

Parameters

value
Type: Emgu.CV.DnnBackend
The value
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net.SetPreferableTarget Method

NetSetPreferableTarget Method

Ask network to make computations on specific target device.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPreferableTarget(
    Target value
)
Public Sub SetPreferableTarget (
    value As Target
)
public:
void SetPreferableTarget(
    Target^ value
)
member SetPreferableTarget :
        value : Target -> unit

Parameters

value
Type: Emgu.CV.DnnTarget
The value
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Net Fields

The Net type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Net Class
Emgu.CV.Dnn Namespace


Target Class

Target devices for computations.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.DnnTarget

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Target : Enum
Public NotInheritable Class Target
    Inherits Enum
public ref class Target sealed : public Enum
[<SealedAttribute>]
type Target =
    class
        inherit Enum
    end

The Target type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cpu | CPU
 | Cuda | Cuda
 | CudaFp16 | Cuda fp16
 | FPGA | FPGA device with CPU fallbacks using Inference Engine's Heterogeneous plugin.
 | Myriad | Myraid
 | OpenCL | OpenCL
 | OpenCLFp16 | Will fall back to OPENCL if the hardware does not support FP16
Public field | value__ |
 | Vulkan | Vulkan
Top
See Also

Reference

Emgu.CV.Dnn Namespace


Target Methods

The Target type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target Fields

The Target type exposes the following members.

Fields
 | Name | Description
 | Cpu | CPU
 | Cuda | Cuda
 | CudaFp16 | Cuda fp16
 | FPGA | FPGA device with CPU fallbacks using Inference Engine's Heterogeneous plugin.
 | Myriad | Myraid
 | OpenCL | OpenCL
 | OpenCLFp16 | Will fall back to OPENCL if the hardware does not support FP16
Public field | value__ |
 | Vulkan | Vulkan
Top
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.Cpu Field

TargetCpu Field

CPU

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target Cpu = 0
Public Const Cpu As Target = 0
public:
literal Target^ Cpu = 0
static val mutable Cpu: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.Cuda Field

TargetCuda Field

Cuda

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target Cuda = 6
Public Const Cuda As Target = 6
public:
literal Target^ Cuda = 6
static val mutable Cuda: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.CudaFp16 Field

TargetCudaFp16 Field

Cuda fp16

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target CudaFp16 = 7
Public Const CudaFp16 As Target = 7
public:
literal Target^ CudaFp16 = 7
static val mutable CudaFp16: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.FPGA Field

TargetFPGA Field

FPGA device with CPU fallbacks using Inference Engine's Heterogeneous plugin.

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target FPGA = 5
Public Const FPGA As Target = 5
public:
literal Target^ FPGA = 5
static val mutable FPGA: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.Myriad Field

TargetMyriad Field

Myraid

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target Myriad = 3
Public Const Myriad As Target = 3
public:
literal Target^ Myriad = 3
static val mutable Myriad: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.OpenCL Field

TargetOpenCL Field

OpenCL

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target OpenCL = 1
Public Const OpenCL As Target = 1
public:
literal Target^ OpenCL = 1
static val mutable OpenCL: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.OpenCLFp16 Field

TargetOpenCLFp16 Field

Will fall back to OPENCL if the hardware does not support FP16

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target OpenCLFp16 = 2
Public Const OpenCLFp16 As Target = 2
public:
literal Target^ OpenCLFp16 = 2
static val mutable OpenCLFp16: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.value__ Field

Targetvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Dnn.Target.value__"]

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Target.Vulkan Field

TargetVulkan Field

Vulkan

Namespace: Emgu.CV.Dnn
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Target Vulkan = 4
Public Const Vulkan As Target = 4
public:
literal Target^ Vulkan = 4
static val mutable Vulkan: Target

Field Value

Type: Target
See Also

Reference

Target Class
Emgu.CV.Dnn Namespace


Emgu.CV.Dpm Namespace

Deformable Part-based Models
Classes
 | Class | Description
Public class | DpmDetector | A deformable parts model detector
Public class | DpmInvoke | Provide interfaces to the Open CV DPM functions
Public class | ObjectDetection | A DPM detection


DpmDetector Class

A deformable parts model detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.DpmDpmDetector

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DpmDetector : SharedPtrObject
Public Class DpmDetector
    Inherits SharedPtrObject
public ref class DpmDetector : public SharedPtrObject
type DpmDetector =
    class
        inherit SharedPtrObject
    end

The DpmDetector type exposes the following members.

Constructors
 | Name | Description
Public method | DpmDetector | Create a new dpm detector with the specified files and classes
Top
Properties
 | Name | Description
Public property | ClassCount | get the number of classes
Public property | ClassNames | Get the class names
Public property | IsEmpty | Return true if the detector is empty
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Detect | Perform detection on the image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Dispose the unmanaged memory associated with this DPM (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Dpm Namespace


DpmDetector Constructor

Create a new dpm detector with the specified files and classes

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DpmDetector(
    string[] files,
    string[] classes = null
)
Public Sub New (
    files As String(),
    Optional classes As String() = Nothing
)
public:
DpmDetector(
    array<String^>^ files,
    array<String^>^ classes = nullptr
)
new :
        files : string[] *
        ?classes : string[]
(* Defaults:
        let _classes = defaultArg classes null
*)
-> DpmDetector

Parameters

files
Type: SystemString
A set of file names storing the trained detectors (models). Each file contains one model.
classes (Optional)
Type: SystemString
A set of trained models names. If it's empty then the name of each model will be constructed from the name of file containing the model. E.g. the model stored in "/home/user/cat.xml" will get the name "cat".
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector Properties

The DpmDetector type exposes the following members.

Properties
 | Name | Description
Public property | ClassCount | get the number of classes
Public property | ClassNames | Get the class names
Public property | IsEmpty | Return true if the detector is empty
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector.ClassCount Property

DpmDetectorClassCount Property

get the number of classes

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ClassCount { get; }
Public ReadOnly Property ClassCount As Integer
    Get
public:
property int ClassCount {
    int get ();
}
member ClassCount : int with get

Property Value

Type: Int32
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector.ClassNames Property

DpmDetectorClassNames Property

Get the class names

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] ClassNames { get; }
Public ReadOnly Property ClassNames As String()
    Get
public:
property array<String^>^ ClassNames {
    array<String^>^ get ();
}
member ClassNames : string[] with get

Property Value

Type: String
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector.IsEmpty Property

DpmDetectorIsEmpty Property

Return true if the detector is empty

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector Methods

The DpmDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Perform detection on the image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Dispose the unmanaged memory associated with this DPM (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector.Detect Method

DpmDetectorDetect Method

Perform detection on the image

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ObjectDetection[] Detect(
    Mat mat
)
Public Function Detect (
    mat As Mat
) As ObjectDetection()
public:
array<ObjectDetection^>^ Detect(
    Mat^ mat
)
member Detect :
        mat : Mat -> ObjectDetection[]

Parameters

mat
Type: Emgu.CVMat
The image for detection.

Return Value

Type: ObjectDetection
The detection result
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector.DisposeObject Method

DpmDetectorDisposeObject Method

Dispose the unmanaged memory associated with this DPM

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmDetector Fields

The DpmDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DpmDetector Class
Emgu.CV.Dpm Namespace


DpmInvoke Class

Provide interfaces to the Open CV DPM functions
Inheritance Hierarchy
SystemObject
Emgu.CV.DpmDpmInvoke

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class DpmInvoke
Public NotInheritable Class DpmInvoke
public ref class DpmInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DpmInvoke =  class end
See Also

Reference

Emgu.CV.Dpm Namespace


ObjectDetection Class

A DPM detection
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.DpmObjectDetection

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ObjectDetection : ValueType
Public NotInheritable Class ObjectDetection
    Inherits ValueType
public ref class ObjectDetection sealed : public ValueType
[<SealedAttribute>]
type ObjectDetection =
    class
        inherit ValueType
    end

The ObjectDetection type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectDetection | create a detection
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | ClassId | class of the detection
Public field | Rect | rectangle
Public field | Score | detection score
Top
See Also

Reference

Emgu.CV.Dpm Namespace


ObjectDetection Constructor

create a detection

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ObjectDetection(
    Rectangle rect,
    float score,
    int classId
)
Public Sub New (
    rect As Rectangle,
    score As Single,
    classId As Integer
)
public:
ObjectDetection(
    Rectangle^ rect,
    float score,
    int classId
)
new :
        rect : Rectangle *
        score : float32 *
        classId : int -> ObjectDetection

Parameters

rect
Type: System.DrawingRectangle
The rectangle
score
Type: SystemSingle
The score
classId
Type: SystemInt32
The class id
See Also

Reference

ObjectDetection Class
Emgu.CV.Dpm Namespace


ObjectDetection Methods

The ObjectDetection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ObjectDetection Class
Emgu.CV.Dpm Namespace


ObjectDetection Fields

The ObjectDetection type exposes the following members.

Fields
 | Name | Description
Public field | ClassId | class of the detection
Public field | Rect | rectangle
Public field | Score | detection score
Top
See Also

Reference

ObjectDetection Class
Emgu.CV.Dpm Namespace


ObjectDetection.ClassId Field

ObjectDetectionClassId Field

class of the detection

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public readonly int ClassId
Public ReadOnly ClassId As Integer
public:
initonly int ClassId
val ClassId: int

Field Value

Type: Int32
See Also

Reference

ObjectDetection Class
Emgu.CV.Dpm Namespace


ObjectDetection.Rect Field

ObjectDetectionRect Field

rectangle

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public readonly Rectangle Rect
Public ReadOnly Rect As Rectangle
public:
initonly Rectangle^ Rect
val Rect: Rectangle

Field Value

Type: Rectangle
See Also

Reference

ObjectDetection Class
Emgu.CV.Dpm Namespace


ObjectDetection.Score Field

ObjectDetectionScore Field

detection score

Namespace: Emgu.CV.Dpm
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public readonly float Score
Public ReadOnly Score As Single
public:
initonly float Score
val Score: float32

Field Value

Type: Single
See Also

Reference

ObjectDetection Class
Emgu.CV.Dpm Namespace


Emgu.CV.Face Namespace

The module contains some recently added functionality that has not been stabilized, or functionality that is considered optional.
Classes
 | Class | Description
Public class | BasicFaceRecognizer | Basic Face Recognizer
Public class | BIF | Implementation of bio-inspired features (BIF) from the paper: Guo, Guodong, et al. "Human age estimation using bio-inspired features." Computer Vision and Pattern Recognition, 2009. CVPR 2009.
Public class | EigenFaceRecognizer | Eigen face recognizer
Public class | FaceInvoke | Class that contains entry points for the Face module.
Public class | FacemarkAAM | The Facemark AMM model
Public class | FacemarkAAMParams | Parameters for the FacemarkAAM model
Public class | FacemarkLBF | The FacemarkLBF model
Public class | FacemarkLBFParams | Parameters for the FacemarkLBF model
Public class | FaceRecognizer | Face Recognizer
Public class | FaceRecognizerPredictionResult | The prediction result
Public class | FisherFaceRecognizer | Fisher face recognizer
Public class | LBPHFaceRecognizer | LBPH face recognizer
Public class | MACE | Minimum Average Correlation Energy Filter useful for authentication with (cancellable) biometrical features. (does not need many positives to train (10-50), and no negatives at all, also robust to noise/salting)
Interfaces
 | Interface | Description
Public interface | IFacemark | Interface to the Facemark class


BasicFaceRecognizer Class

Basic Face Recognizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FaceFaceRecognizer
Emgu.CV.FaceBasicFaceRecognizer
Emgu.CV.FaceEigenFaceRecognizer
Emgu.CV.FaceFisherFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class BasicFaceRecognizer : FaceRecognizer
Public MustInherit Class BasicFaceRecognizer
    Inherits FaceRecognizer
public ref class BasicFaceRecognizer abstract : public FaceRecognizer
[<AbstractClassAttribute>]
type BasicFaceRecognizer =
    class
        inherit FaceRecognizer
    end

The BasicFaceRecognizer type exposes the following members.

Constructors
 | Name | Description
Protected method | BasicFaceRecognizer | Initializes a new instance of the BasicFaceRecognizer class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FaceRecognizer (Inherited from FaceRecognizer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
Fields
 | Name | Description
Protected field | _basicFaceRecognizerPtr | The native pointer to the BasicFaceRecognizer object
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


BasicFaceRecognizer Constructor

Initializes a new instance of the BasicFaceRecognizer class

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected BasicFaceRecognizer()
Protected Sub New
protected:
BasicFaceRecognizer()
new : unit -> BasicFaceRecognizer
See Also

Reference

BasicFaceRecognizer Class
Emgu.CV.Face Namespace


BasicFaceRecognizer Properties

The BasicFaceRecognizer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BasicFaceRecognizer Class
Emgu.CV.Face Namespace


BasicFaceRecognizer Methods

The BasicFaceRecognizer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FaceRecognizer (Inherited from FaceRecognizer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
See Also

Reference

BasicFaceRecognizer Class
Emgu.CV.Face Namespace


BasicFaceRecognizer Fields

The BasicFaceRecognizer type exposes the following members.

Fields
 | Name | Description
Protected field | _basicFaceRecognizerPtr | The native pointer to the BasicFaceRecognizer object
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BasicFaceRecognizer Class
Emgu.CV.Face Namespace


BasicFaceRecognizer._basicFaceRecognizerPtr Field

BasicFaceRecognizer_basicFaceRecognizerPtr Field

The native pointer to the BasicFaceRecognizer object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _basicFaceRecognizerPtr
Protected _basicFaceRecognizerPtr As IntPtr
protected:
IntPtr _basicFaceRecognizerPtr
val mutable _basicFaceRecognizerPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

BasicFaceRecognizer Class
Emgu.CV.Face Namespace


BIF Class

Implementation of bio-inspired features (BIF) from the paper: Guo, Guodong, et al. "Human age estimation using bio-inspired features." Computer Vision and Pattern Recognition, 2009. CVPR 2009.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FaceBIF

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BIF : SharedPtrObject
Public Class BIF
    Inherits SharedPtrObject
public ref class BIF : public SharedPtrObject
type BIF =
    class
        inherit SharedPtrObject
    end

The BIF type exposes the following members.

Constructors
 | Name | Description
Public method | BIF | Create an instance of bio-inspired features
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Computes features by input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this BIF (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


BIF Constructor

Create an instance of bio-inspired features

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BIF(
    int numBands,
    int numRotations
)
Public Sub New (
    numBands As Integer,
    numRotations As Integer
)
public:
BIF(
    int numBands,
    int numRotations
)
new :
        numBands : int *
        numRotations : int -> BIF

Parameters

numBands
Type: SystemInt32
The number of filter bands used for computing BIF.
numRotations
Type: SystemInt32
The number of image rotations.
See Also

Reference

BIF Class
Emgu.CV.Face Namespace


BIF Properties

The BIF type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BIF Class
Emgu.CV.Face Namespace


BIF Methods

The BIF type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Computes features by input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this BIF (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BIF Class
Emgu.CV.Face Namespace


BIF.Compute Method

BIFCompute Method

Computes features by input image.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Compute(
    IInputArray image,
    IOutputArray features
)
Public Sub Compute (
    image As IInputArray,
    features As IOutputArray
)
public:
void Compute(
    IInputArray^ image,
    IOutputArray^ features
)
member Compute :
        image : IInputArray *
        features : IOutputArray -> unit

Parameters

image
Type: Emgu.CVIInputArray
Input image (CV_32FC1)
features
Type: Emgu.CVIOutputArray
Feature vector (CV_32FC1)
See Also

Reference

BIF Class
Emgu.CV.Face Namespace


BIF.DisposeObject Method

BIFDisposeObject Method

Release the unmanaged memory associated with this BIF

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BIF Class
Emgu.CV.Face Namespace


BIF Fields

The BIF type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BIF Class
Emgu.CV.Face Namespace


EigenFaceRecognizer Class

Eigen face recognizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FaceFaceRecognizer
Emgu.CV.FaceBasicFaceRecognizer
Emgu.CV.FaceEigenFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class EigenFaceRecognizer : BasicFaceRecognizer
Public Class EigenFaceRecognizer
    Inherits BasicFaceRecognizer
public ref class EigenFaceRecognizer : public BasicFaceRecognizer
type EigenFaceRecognizer =
    class
        inherit BasicFaceRecognizer
    end

The EigenFaceRecognizer type exposes the following members.

Constructors
 | Name | Description
Public method | EigenFaceRecognizer | Create an EigenFaceRecognizer
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this EigenFaceRecognizer (Overrides FaceRecognizerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
Fields
 | Name | Description
Protected field | _basicFaceRecognizerPtr | The native pointer to the BasicFaceRecognizer object (Inherited from BasicFaceRecognizer.)
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


EigenFaceRecognizer Constructor

Create an EigenFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EigenFaceRecognizer(
    int numComponents = 0,
    double threshold = 1.79769313486232E+308
)
Public Sub New (
    Optional numComponents As Integer = 0,
    Optional threshold As Double = 1.79769313486232E+308
)
public:
EigenFaceRecognizer(
    int numComponents = 0,
    double threshold = 1.79769313486232E+308
)
new :
        ?numComponents : int *
        ?threshold : float
(* Defaults:
        let _numComponents = defaultArg numComponents 0
        let _threshold = defaultArg threshold 1.79769313486232E+308
*)
-> EigenFaceRecognizer

Parameters

numComponents (Optional)
Type: SystemInt32
The number of components
threshold (Optional)
Type: SystemDouble
The distance threshold
See Also

Reference

EigenFaceRecognizer Class
Emgu.CV.Face Namespace


EigenFaceRecognizer Properties

The EigenFaceRecognizer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

EigenFaceRecognizer Class
Emgu.CV.Face Namespace


EigenFaceRecognizer Methods

The EigenFaceRecognizer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this EigenFaceRecognizer (Overrides FaceRecognizerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
See Also

Reference

EigenFaceRecognizer Class
Emgu.CV.Face Namespace


EigenFaceRecognizer.DisposeObject Method

EigenFaceRecognizerDisposeObject Method

Release the unmanaged memory associated with this EigenFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

EigenFaceRecognizer Class
Emgu.CV.Face Namespace


EigenFaceRecognizer Fields

The EigenFaceRecognizer type exposes the following members.

Fields
 | Name | Description
Protected field | _basicFaceRecognizerPtr | The native pointer to the BasicFaceRecognizer object (Inherited from BasicFaceRecognizer.)
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

EigenFaceRecognizer Class
Emgu.CV.Face Namespace


FaceInvoke Class

Class that contains entry points for the Face module.
Class that contains entry points for the Face module.
Class that contains entry points for the Face module.
Class that contains entry points for the Face module.
Inheritance Hierarchy
SystemObject
Emgu.CV.FaceFaceInvoke

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class FaceInvoke
<ExtensionAttribute>
Public NotInheritable Class FaceInvoke
[ExtensionAttribute]
public ref class FaceInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type FaceInvoke =  class end

The FaceInvoke type exposes the following members.

Methods
Name | Description
DrawFacemarks | Utility to draw the detected facial landmark points.
Fit | Trains a Facemark algorithm using the given dataset.
LoadModel | A function to load the trained model before the fitting process.
Top
See Also

Reference

Emgu.CV.Face Namespace


FaceInvoke Methods

The FaceInvoke type exposes the following members.

Methods
Name | Description
DrawFacemarks | Utility to draw the detected facial landmark points.
Fit | Trains a Facemark algorithm using the given dataset.
LoadModel | A function to load the trained model before the fitting process.
Top
See Also

Reference

FaceInvoke Class
Emgu.CV.Face Namespace


FaceInvoke.DrawFacemarks Method

FaceInvokeDrawFacemarks Method

Utility to draw the detected facial landmark points.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawFacemarks(
    IInputOutputArray image,
    IInputArray points,
    MCvScalar color
)
Public Shared Sub DrawFacemarks (
    image As IInputOutputArray,
    points As IInputArray,
    color As MCvScalar
)
public:
static void DrawFacemarks(
    IInputOutputArray^ image,
    IInputArray^ points,
    MCvScalar^ color
)
static member DrawFacemarks :
        image : IInputOutputArray *
        points : IInputArray *
        color : MCvScalar -> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
The input image to be processed.
points
Type: Emgu.CVIInputArray
Contains the data of points which will be drawn.
color
Type: Emgu.CV.StructureMCvScalar
The color of points in BGR format
See Also

Reference

FaceInvoke Class
Emgu.CV.Face Namespace


FaceInvoke.Fit Method

FaceInvokeFit Method

Trains a Facemark algorithm using the given dataset.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool Fit(
    this IFacemark facemark,
    IInputArray image,
    IInputArray faces,
    IInputOutputArray landmarks
)
<ExtensionAttribute>
Public Shared Function Fit (
    facemark As IFacemark,
    image As IInputArray,
    faces As IInputArray,
    landmarks As IInputOutputArray
) As Boolean
public:
[ExtensionAttribute]
static bool Fit(
    IFacemark^ facemark,
    IInputArray^ image,
    IInputArray^ faces,
    IInputOutputArray^ landmarks
)
[<ExtensionAttribute>]
static member Fit :
        facemark : IFacemark *
        image : IInputArray *
        faces : IInputArray *
        landmarks : IInputOutputArray -> bool

Parameters

facemark
Type: Emgu.CV.FaceIFacemark
The facemark object
image
Type: Emgu.CVIInputArray
Input image.
faces
Type: Emgu.CVIInputArray
Represent region of interest of the detected faces. Each face is stored in cv::Rect container.
landmarks
Type: Emgu.CVIInputOutputArray
The detected landmark points for each faces.

Return Value

Type: Boolean
True if successful

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IFacemark. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

FaceInvoke Class
Emgu.CV.Face Namespace


FaceInvoke.LoadModel Method

FaceInvokeLoadModel Method

A function to load the trained model before the fitting process.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void LoadModel(
    this IFacemark facemark,
    string model
)
<ExtensionAttribute>
Public Shared Sub LoadModel (
    facemark As IFacemark,
    model As String
)
public:
[ExtensionAttribute]
static void LoadModel(
    IFacemark^ facemark,
    String^ model
)
[<ExtensionAttribute>]
static member LoadModel :
        facemark : IFacemark *
        model : string -> unit

Parameters

facemark
Type: Emgu.CV.FaceIFacemark
The facemark object
model
Type: SystemString
A string represent the filename of a trained model.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IFacemark. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

FaceInvoke Class
Emgu.CV.Face Namespace


FacemarkAAM Class

The Facemark AMM model
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FaceFacemarkAAM

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FacemarkAAM : UnmanagedObject,
    IFacemark, IAlgorithm
Public Class FacemarkAAM
    Inherits UnmanagedObject
    Implements IFacemark, IAlgorithm
public ref class FacemarkAAM : public UnmanagedObject,
    IFacemark, IAlgorithm
type FacemarkAAM =
    class
        inherit UnmanagedObject
        interface IFacemark
        interface IAlgorithm
    end

The FacemarkAAM type exposes the following members.

Constructors
 | Name | Description
Public method | FacemarkAAM | Create an instance of FacemarkAAM model
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | FacemarkPtr | Pointer to the unmanaged Facemark object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Facemark (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Fit | Trains a Facemark algorithm using the given dataset. (Defined by FaceInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | LoadModel | A function to load the trained model before the fitting process. (Defined by FaceInvoke.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Face Namespace


FacemarkAAM Constructor

Create an instance of FacemarkAAM model

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FacemarkAAM(
    FacemarkAAMParams parameters
)
Public Sub New (
    parameters As FacemarkAAMParams
)
public:
FacemarkAAM(
    FacemarkAAMParams^ parameters
)
new :
        parameters : FacemarkAAMParams -> FacemarkAAM

Parameters

parameters
Type: Emgu.CV.FaceFacemarkAAMParams
The model parameters
See Also

Reference

FacemarkAAM Class
Emgu.CV.Face Namespace


FacemarkAAM Properties

The FacemarkAAM type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | FacemarkPtr | Pointer to the unmanaged Facemark object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FacemarkAAM Class
Emgu.CV.Face Namespace


FacemarkAAM.AlgorithmPtr Property

FacemarkAAMAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

FacemarkAAM Class
Emgu.CV.Face Namespace


FacemarkAAM.FacemarkPtr Property

FacemarkAAMFacemarkPtr Property

Pointer to the unmanaged Facemark object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr FacemarkPtr { get; }
Public ReadOnly Property FacemarkPtr As IntPtr
    Get
public:
virtual property IntPtr FacemarkPtr {
    IntPtr get () sealed;
}
abstract FacemarkPtr : IntPtr with get
override FacemarkPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IFacemarkFacemarkPtr
See Also

Reference

FacemarkAAM Class
Emgu.CV.Face Namespace


FacemarkAAM Methods

The FacemarkAAM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Facemark (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Fit | Trains a Facemark algorithm using the given dataset. (Defined by FaceInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | LoadModel | A function to load the trained model before the fitting process. (Defined by FaceInvoke.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

FacemarkAAM Class
Emgu.CV.Face Namespace


FacemarkAAM.DisposeObject Method

FacemarkAAMDisposeObject Method

Release all the unmanaged memory associated with this Facemark

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FacemarkAAM Class
Emgu.CV.Face Namespace


FacemarkAAM Fields

The FacemarkAAM type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FacemarkAAM Class
Emgu.CV.Face Namespace


FacemarkAAMParams Class

Parameters for the FacemarkAAM model
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FaceFacemarkAAMParams

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FacemarkAAMParams : UnmanagedObject
Public Class FacemarkAAMParams
    Inherits UnmanagedObject
public ref class FacemarkAAMParams : public UnmanagedObject
type FacemarkAAMParams =
    class
        inherit UnmanagedObject
    end

The FacemarkAAMParams type exposes the following members.

Constructors
 | Name | Description
Public method | FacemarkAAMParams | Create the paramaters with the default values.
Top
Properties
 | Name | Description
Public property | M | M
Public property | MaxM | The maximum value of M
Public property | MaxN | The maximum value of N
Public property | ModelFile | filename where the trained model will be saved
Public property | N | N
Public property | NIter | Number of iteration
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaveModel | flag to save the trained model or not
Public property | Verbose | show the training print-out
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


FacemarkAAMParams Constructor

Create the paramaters with the default values.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FacemarkAAMParams()
Public Sub New
public:
FacemarkAAMParams()
new : unit -> FacemarkAAMParams
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams Properties

The FacemarkAAMParams type exposes the following members.

Properties
 | Name | Description
Public property | M | M
Public property | MaxM | The maximum value of M
Public property | MaxN | The maximum value of N
Public property | ModelFile | filename where the trained model will be saved
Public property | N | N
Public property | NIter | Number of iteration
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaveModel | flag to save the trained model or not
Public property | Verbose | show the training print-out
Top
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.M Property

FacemarkAAMParamsM Property

M

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int M { get; set; }
Public Property M As Integer
    Get
    Set
public:
property int M {
    int get ();
    void set (int value);
}
member M : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.MaxM Property

FacemarkAAMParamsMaxM Property

The maximum value of M

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxM { get; set; }
Public Property MaxM As Integer
    Get
    Set
public:
property int MaxM {
    int get ();
    void set (int value);
}
member MaxM : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.MaxN Property

FacemarkAAMParamsMaxN Property

The maximum value of N

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxN { get; set; }
Public Property MaxN As Integer
    Get
    Set
public:
property int MaxN {
    int get ();
    void set (int value);
}
member MaxN : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.ModelFile Property

FacemarkAAMParamsModelFile Property

filename where the trained model will be saved

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ModelFile { get; set; }
Public Property ModelFile As String
    Get
    Set
public:
property String^ ModelFile {
    String^ get ();
    void set (String^ value);
}
member ModelFile : string with get, set

Property Value

Type: String
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.N Property

FacemarkAAMParamsN Property

N

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int N { get; set; }
Public Property N As Integer
    Get
    Set
public:
property int N {
    int get ();
    void set (int value);
}
member N : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.NIter Property

FacemarkAAMParamsNIter Property

Number of iteration

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NIter { get; set; }
Public Property NIter As Integer
    Get
    Set
public:
property int NIter {
    int get ();
    void set (int value);
}
member NIter : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.SaveModel Property

FacemarkAAMParamsSaveModel Property

flag to save the trained model or not

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SaveModel { get; set; }
Public Property SaveModel As Boolean
    Get
    Set
public:
property bool SaveModel {
    bool get ();
    void set (bool value);
}
member SaveModel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.Verbose Property

FacemarkAAMParamsVerbose Property

show the training print-out

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Verbose { get; set; }
Public Property Verbose As Boolean
    Get
    Set
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}
member Verbose : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams Methods

The FacemarkAAMParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams.DisposeObject Method

FacemarkAAMParamsDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkAAMParams Fields

The FacemarkAAMParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FacemarkAAMParams Class
Emgu.CV.Face Namespace


FacemarkLBF Class

The FacemarkLBF model
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FaceFacemarkLBF

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FacemarkLBF : UnmanagedObject,
    IFacemark, IAlgorithm
Public Class FacemarkLBF
    Inherits UnmanagedObject
    Implements IFacemark, IAlgorithm
public ref class FacemarkLBF : public UnmanagedObject,
    IFacemark, IAlgorithm
type FacemarkLBF =
    class
        inherit UnmanagedObject
        interface IFacemark
        interface IAlgorithm
    end

The FacemarkLBF type exposes the following members.

Constructors
 | Name | Description
Public method | FacemarkLBF | Create an instance of the FacemarkLBF model
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | FacemarkPtr | Pointer to the unmanaged Facemark object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Facemark (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Fit | Trains a Facemark algorithm using the given dataset. (Defined by FaceInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | LoadModel | A function to load the trained model before the fitting process. (Defined by FaceInvoke.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Face Namespace


FacemarkLBF Constructor

Create an instance of the FacemarkLBF model

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FacemarkLBF(
    FacemarkLBFParams parameters
)
Public Sub New (
    parameters As FacemarkLBFParams
)
public:
FacemarkLBF(
    FacemarkLBFParams^ parameters
)
new :
        parameters : FacemarkLBFParams -> FacemarkLBF

Parameters

parameters
Type: Emgu.CV.FaceFacemarkLBFParams
The model parameters
See Also

Reference

FacemarkLBF Class
Emgu.CV.Face Namespace


FacemarkLBF Properties

The FacemarkLBF type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | FacemarkPtr | Pointer to the unmanaged Facemark object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FacemarkLBF Class
Emgu.CV.Face Namespace


FacemarkLBF.AlgorithmPtr Property

FacemarkLBFAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

FacemarkLBF Class
Emgu.CV.Face Namespace


FacemarkLBF.FacemarkPtr Property

FacemarkLBFFacemarkPtr Property

Pointer to the unmanaged Facemark object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr FacemarkPtr { get; }
Public ReadOnly Property FacemarkPtr As IntPtr
    Get
public:
virtual property IntPtr FacemarkPtr {
    IntPtr get () sealed;
}
abstract FacemarkPtr : IntPtr with get
override FacemarkPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IFacemarkFacemarkPtr
See Also

Reference

FacemarkLBF Class
Emgu.CV.Face Namespace


FacemarkLBF Methods

The FacemarkLBF type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Facemark (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Fit | Trains a Facemark algorithm using the given dataset. (Defined by FaceInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | LoadModel | A function to load the trained model before the fitting process. (Defined by FaceInvoke.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

FacemarkLBF Class
Emgu.CV.Face Namespace


FacemarkLBF.DisposeObject Method

FacemarkLBFDisposeObject Method

Release all the unmanaged memory associated with this Facemark

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FacemarkLBF Class
Emgu.CV.Face Namespace


FacemarkLBF Fields

The FacemarkLBF type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FacemarkLBF Class
Emgu.CV.Face Namespace


FacemarkLBFParams Class

Parameters for the FacemarkLBF model
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FaceFacemarkLBFParams

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FacemarkLBFParams : UnmanagedObject
Public Class FacemarkLBFParams
    Inherits UnmanagedObject
public ref class FacemarkLBFParams : public UnmanagedObject
type FacemarkLBFParams =
    class
        inherit UnmanagedObject
    end

The FacemarkLBFParams type exposes the following members.

Constructors
 | Name | Description
Public method | FacemarkLBFParams | Create the paramaters with the default values.
Top
Properties
 | Name | Description
Public property | BaggingOverlap | overlap ratio for training the LBF feature
Public property | CascadeFace | filename of the face detector model
Public property | InitShapeN | multiplier for augment the training data
Public property | ModelFile | filename where the trained model will be saved
Public property | NLandmarks | number of landmark points
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaveModel | flag to save the trained model or not
Public property | ShapeOffset | offset for the loaded face landmark points
Public property | StagesN | number of refinement stages
Public property | TreeDepth | the depth of decision tree, defines the size of feature
Public property | TreeN | number of tree in the model for each landmark point refinement
Public property | Verbose | show the training print-out
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


FacemarkLBFParams Constructor

Create the paramaters with the default values.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FacemarkLBFParams()
Public Sub New
public:
FacemarkLBFParams()
new : unit -> FacemarkLBFParams
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams Properties

The FacemarkLBFParams type exposes the following members.

Properties
 | Name | Description
Public property | BaggingOverlap | overlap ratio for training the LBF feature
Public property | CascadeFace | filename of the face detector model
Public property | InitShapeN | multiplier for augment the training data
Public property | ModelFile | filename where the trained model will be saved
Public property | NLandmarks | number of landmark points
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaveModel | flag to save the trained model or not
Public property | ShapeOffset | offset for the loaded face landmark points
Public property | StagesN | number of refinement stages
Public property | TreeDepth | the depth of decision tree, defines the size of feature
Public property | TreeN | number of tree in the model for each landmark point refinement
Public property | Verbose | show the training print-out
Top
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.BaggingOverlap Property

FacemarkLBFParamsBaggingOverlap Property

overlap ratio for training the LBF feature

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double BaggingOverlap { get; set; }
Public Property BaggingOverlap As Double
    Get
    Set
public:
property double BaggingOverlap {
    double get ();
    void set (double value);
}
member BaggingOverlap : float with get, set

Property Value

Type: Double
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.CascadeFace Property

FacemarkLBFParamsCascadeFace Property

filename of the face detector model

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string CascadeFace { get; set; }
Public Property CascadeFace As String
    Get
    Set
public:
property String^ CascadeFace {
    String^ get ();
    void set (String^ value);
}
member CascadeFace : string with get, set

Property Value

Type: String
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.InitShapeN Property

FacemarkLBFParamsInitShapeN Property

multiplier for augment the training data

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int InitShapeN { get; set; }
Public Property InitShapeN As Integer
    Get
    Set
public:
property int InitShapeN {
    int get ();
    void set (int value);
}
member InitShapeN : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.ModelFile Property

FacemarkLBFParamsModelFile Property

filename where the trained model will be saved

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ModelFile { get; set; }
Public Property ModelFile As String
    Get
    Set
public:
property String^ ModelFile {
    String^ get ();
    void set (String^ value);
}
member ModelFile : string with get, set

Property Value

Type: String
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.NLandmarks Property

FacemarkLBFParamsNLandmarks Property

number of landmark points

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NLandmarks { get; set; }
Public Property NLandmarks As Integer
    Get
    Set
public:
property int NLandmarks {
    int get ();
    void set (int value);
}
member NLandmarks : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.SaveModel Property

FacemarkLBFParamsSaveModel Property

flag to save the trained model or not

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SaveModel { get; set; }
Public Property SaveModel As Boolean
    Get
    Set
public:
property bool SaveModel {
    bool get ();
    void set (bool value);
}
member SaveModel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.ShapeOffset Property

FacemarkLBFParamsShapeOffset Property

offset for the loaded face landmark points

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double ShapeOffset { get; set; }
Public Property ShapeOffset As Double
    Get
    Set
public:
property double ShapeOffset {
    double get ();
    void set (double value);
}
member ShapeOffset : float with get, set

Property Value

Type: Double
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.StagesN Property

FacemarkLBFParamsStagesN Property

number of refinement stages

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int StagesN { get; set; }
Public Property StagesN As Integer
    Get
    Set
public:
property int StagesN {
    int get ();
    void set (int value);
}
member StagesN : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.TreeDepth Property

FacemarkLBFParamsTreeDepth Property

the depth of decision tree, defines the size of feature

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int TreeDepth { get; set; }
Public Property TreeDepth As Integer
    Get
    Set
public:
property int TreeDepth {
    int get ();
    void set (int value);
}
member TreeDepth : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.TreeN Property

FacemarkLBFParamsTreeN Property

number of tree in the model for each landmark point refinement

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int TreeN { get; set; }
Public Property TreeN As Integer
    Get
    Set
public:
property int TreeN {
    int get ();
    void set (int value);
}
member TreeN : int with get, set

Property Value

Type: Int32
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.Verbose Property

FacemarkLBFParamsVerbose Property

show the training print-out

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Verbose { get; set; }
Public Property Verbose As Boolean
    Get
    Set
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}
member Verbose : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams Methods

The FacemarkLBFParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams.DisposeObject Method

FacemarkLBFParamsDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FacemarkLBFParams Fields

The FacemarkLBFParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FacemarkLBFParams Class
Emgu.CV.Face Namespace


FaceRecognizer Class

Face Recognizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FaceFaceRecognizer
Emgu.CV.FaceBasicFaceRecognizer
Emgu.CV.FaceLBPHFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class FaceRecognizer : SharedPtrObject
Public MustInherit Class FaceRecognizer
    Inherits SharedPtrObject
public ref class FaceRecognizer abstract : public SharedPtrObject
[<AbstractClassAttribute>]
type FaceRecognizer =
    class
        inherit SharedPtrObject
    end

The FaceRecognizer type exposes the following members.

Constructors
 | Name | Description
Protected method | FaceRecognizer | Initializes a new instance of the FaceRecognizer class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FaceRecognizer (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image
Public method | Read | Load the FaceRecognizer from the file
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels
Public method | Write | Save the FaceRecognizer to a file
Top
Fields
 | Name | Description
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


FaceRecognizer Constructor

Initializes a new instance of the FaceRecognizer class

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected FaceRecognizer()
Protected Sub New
protected:
FaceRecognizer()
new : unit -> FaceRecognizer
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer Properties

The FaceRecognizer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer Methods

The FaceRecognizer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FaceRecognizer (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image
Public method | Read | Load the FaceRecognizer from the file
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels
Public method | Write | Save the FaceRecognizer to a file
Top
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer.DisposeObject Method

FaceRecognizerDisposeObject Method

Release the unmanaged memory associated with this FaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer.Predict Method

FaceRecognizerPredict Method

Predict the label of the image

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FaceRecognizerPredictionResult Predict(
    IInputArray image
)
Public Function Predict (
    image As IInputArray
) As FaceRecognizerPredictionResult
public:
FaceRecognizerPredictionResult^ Predict(
    IInputArray^ image
)
member Predict :
        image : IInputArray -> FaceRecognizerPredictionResult

Parameters

image
Type: Emgu.CVIInputArray
The image where prediction will be based on

Return Value

Type: FaceRecognizerPredictionResult
The prediction label
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer.Read Method

FaceRecognizerRead Method

Load the FaceRecognizer from the file

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Read(
    string fileName
)
Public Sub Read (
    fileName As String
)
public:
void Read(
    String^ fileName
)
member Read :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The file where the FaceRecognizer will be loaded from
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer.Train Method

FaceRecognizerTrain Method

Overload List
 | Name | Description
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels
Top
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer.Train Method (IInputArray, IInputArray)

FaceRecognizerTrain Method (IInputArray, IInputArray)

http://www.emgu.com
Train the face recognizer with the specific images and labels

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Train(
    IInputArray images,
    IInputArray labels
)
Public Sub Train (
    images As IInputArray,
    labels As IInputArray
)
public:
void Train(
    IInputArray^ images,
    IInputArray^ labels
)
member Train :
        images : IInputArray *
        labels : IInputArray -> unit

Parameters

images
Type: Emgu.CVIInputArray
The images used in the training. This can be a VectorOfMat
labels
Type: Emgu.CVIInputArray
The labels of the images. This can be a VectorOfInt
See Also

Reference

FaceRecognizer Class
Train Overload
Emgu.CV.Face Namespace


FaceRecognizer.Train Method (Mat[], Int32[])

FaceRecognizerTrain Method (Mat, Int32)

http://www.emgu.com
Train the face recognizer with the specific images and labels

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Train(
    Mat[] images,
    int[] labels
)
Public Sub Train (
    images As Mat(),
    labels As Integer()
)
public:
void Train(
    array<Mat^>^ images,
    array<int>^ labels
)
member Train :
        images : Mat[] *
        labels : int[] -> unit

Parameters

images
Type: Emgu.CVMat
The images used in the training.
labels
Type: SystemInt32
The labels of the images.
See Also

Reference

FaceRecognizer Class
Train Overload
Emgu.CV.Face Namespace


FaceRecognizer.Write Method

FaceRecognizerWrite Method

Save the FaceRecognizer to a file

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string fileName
)
Public Sub Write (
    fileName As String
)
public:
void Write(
    String^ fileName
)
member Write :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The file name to be saved to
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer Fields

The FaceRecognizer type exposes the following members.

Fields
 | Name | Description
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer._faceRecognizerPtr Field

FaceRecognizer_faceRecognizerPtr Field

The native pointer to the FaceRecognizer object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _faceRecognizerPtr
Protected _faceRecognizerPtr As IntPtr
protected:
IntPtr _faceRecognizerPtr
val mutable _faceRecognizerPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

FaceRecognizer Class
Emgu.CV.Face Namespace


FaceRecognizer.PredictionResult Class

FaceRecognizerPredictionResult Class

The prediction result
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.FaceFaceRecognizerPredictionResult

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PredictionResult : ValueType
Public NotInheritable Class PredictionResult
    Inherits ValueType
public ref class PredictionResult sealed : public ValueType
[<SealedAttribute>]
type PredictionResult =
    class
        inherit ValueType
    end

The FaceRecognizerPredictionResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Distance | The distance
Public field | Label | The label
Top
See Also

Reference

Emgu.CV.Face Namespace


PredictionResult Methods

The FaceRecognizerPredictionResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

FaceRecognizerPredictionResult Class
Emgu.CV.Face Namespace


PredictionResult Fields

The FaceRecognizerPredictionResult type exposes the following members.

Fields
 | Name | Description
Public field | Distance | The distance
Public field | Label | The label
Top
See Also

Reference

FaceRecognizerPredictionResult Class
Emgu.CV.Face Namespace


FaceRecognizer.PredictionResult.Distance Field

FaceRecognizerPredictionResultDistance Field

The distance

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Distance
Public Distance As Double
public:
double Distance
val mutable Distance: float

Field Value

Type: Double
See Also

Reference

FaceRecognizerPredictionResult Class
Emgu.CV.Face Namespace


FaceRecognizer.PredictionResult.Label Field

FaceRecognizerPredictionResultLabel Field

The label

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Label
Public Label As Integer
public:
int Label
val mutable Label: int

Field Value

Type: Int32
See Also

Reference

FaceRecognizerPredictionResult Class
Emgu.CV.Face Namespace


FisherFaceRecognizer Class

Fisher face recognizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FaceFaceRecognizer
Emgu.CV.FaceBasicFaceRecognizer
Emgu.CV.FaceFisherFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FisherFaceRecognizer : BasicFaceRecognizer
Public Class FisherFaceRecognizer
    Inherits BasicFaceRecognizer
public ref class FisherFaceRecognizer : public BasicFaceRecognizer
type FisherFaceRecognizer =
    class
        inherit BasicFaceRecognizer
    end

The FisherFaceRecognizer type exposes the following members.

Constructors
 | Name | Description
Public method | FisherFaceRecognizer | Create a FisherFaceRecognizer
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FisherFaceRecognizer (Overrides FaceRecognizerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
Fields
 | Name | Description
Protected field | _basicFaceRecognizerPtr | The native pointer to the BasicFaceRecognizer object (Inherited from BasicFaceRecognizer.)
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


FisherFaceRecognizer Constructor

Create a FisherFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FisherFaceRecognizer(
    int numComponents = 0,
    double threshold = 1.79769313486232E+308
)
Public Sub New (
    Optional numComponents As Integer = 0,
    Optional threshold As Double = 1.79769313486232E+308
)
public:
FisherFaceRecognizer(
    int numComponents = 0,
    double threshold = 1.79769313486232E+308
)
new :
        ?numComponents : int *
        ?threshold : float
(* Defaults:
        let _numComponents = defaultArg numComponents 0
        let _threshold = defaultArg threshold 1.79769313486232E+308
*)
-> FisherFaceRecognizer

Parameters

numComponents (Optional)
Type: SystemInt32
The number of components
threshold (Optional)
Type: SystemDouble
The distance threshold
See Also

Reference

FisherFaceRecognizer Class
Emgu.CV.Face Namespace


FisherFaceRecognizer Properties

The FisherFaceRecognizer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FisherFaceRecognizer Class
Emgu.CV.Face Namespace


FisherFaceRecognizer Methods

The FisherFaceRecognizer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FisherFaceRecognizer (Overrides FaceRecognizerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
See Also

Reference

FisherFaceRecognizer Class
Emgu.CV.Face Namespace


FisherFaceRecognizer.DisposeObject Method

FisherFaceRecognizerDisposeObject Method

Release the unmanaged memory associated with this FisherFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FisherFaceRecognizer Class
Emgu.CV.Face Namespace


FisherFaceRecognizer Fields

The FisherFaceRecognizer type exposes the following members.

Fields
 | Name | Description
Protected field | _basicFaceRecognizerPtr | The native pointer to the BasicFaceRecognizer object (Inherited from BasicFaceRecognizer.)
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FisherFaceRecognizer Class
Emgu.CV.Face Namespace


IFacemark Interface

Interface to the Facemark class

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IFacemark : IAlgorithm
Public Interface IFacemark
    Inherits IAlgorithm
public interface class IFacemark : IAlgorithm
type IFacemark =
    interface
        interface IAlgorithm
    end

The IFacemark type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | FacemarkPtr | Return the pointer to the Facemark object
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Fit | Trains a Facemark algorithm using the given dataset. (Defined by FaceInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | LoadModel | A function to load the trained model before the fitting process. (Defined by FaceInvoke.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Face Namespace


IFacemark Properties

The IFacemark type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | FacemarkPtr | Return the pointer to the Facemark object
Top
See Also

Reference

IFacemark Interface
Emgu.CV.Face Namespace


IFacemark.FacemarkPtr Property

IFacemarkFacemarkPtr Property

Return the pointer to the Facemark object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr FacemarkPtr { get; }
ReadOnly Property FacemarkPtr As IntPtr
    Get
property IntPtr FacemarkPtr {
    IntPtr get ();
}
abstract FacemarkPtr : IntPtr with get

Return Value

Type: IntPtr
The pointer to the Facemark object
See Also

Reference

IFacemark Interface
Emgu.CV.Face Namespace


IFacemark Methods

The IFacemark type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Fit | Trains a Facemark algorithm using the given dataset. (Defined by FaceInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | LoadModel | A function to load the trained model before the fitting process. (Defined by FaceInvoke.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IFacemark Interface
Emgu.CV.Face Namespace


LBPHFaceRecognizer Class

LBPH face recognizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FaceFaceRecognizer
Emgu.CV.FaceLBPHFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LBPHFaceRecognizer : FaceRecognizer
Public Class LBPHFaceRecognizer
    Inherits FaceRecognizer
public ref class LBPHFaceRecognizer : public FaceRecognizer
type LBPHFaceRecognizer =
    class
        inherit FaceRecognizer
    end

The LBPHFaceRecognizer type exposes the following members.

Constructors
 | Name | Description
Public method | LBPHFaceRecognizer | Create a LBPH face recognizer
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FisherFaceRecognizer (Overrides FaceRecognizerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Update(IInputArray, IInputArray) | Updates a FaceRecognizer with given data and associated labels.
Public method | Update(Mat, Int32) | Update the face recognizer with the specific images and labels
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
Fields
 | Name | Description
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


LBPHFaceRecognizer Constructor

Create a LBPH face recognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LBPHFaceRecognizer(
    int radius = 1,
    int neighbors = 8,
    int gridX = 8,
    int gridY = 8,
    double threshold = 1.79769313486232E+308
)
Public Sub New (
    Optional radius As Integer = 1,
    Optional neighbors As Integer = 8,
    Optional gridX As Integer = 8,
    Optional gridY As Integer = 8,
    Optional threshold As Double = 1.79769313486232E+308
)
public:
LBPHFaceRecognizer(
    int radius = 1,
    int neighbors = 8,
    int gridX = 8,
    int gridY = 8,
    double threshold = 1.79769313486232E+308
)
new :
        ?radius : int *
        ?neighbors : int *
        ?gridX : int *
        ?gridY : int *
        ?threshold : float
(* Defaults:
        let _radius = defaultArg radius 1
        let _neighbors = defaultArg neighbors 8
        let _gridX = defaultArg gridX 8
        let _gridY = defaultArg gridY 8
        let _threshold = defaultArg threshold 1.79769313486232E+308
*)
-> LBPHFaceRecognizer

Parameters

radius (Optional)
Type: SystemInt32
Radius
neighbors (Optional)
Type: SystemInt32
Neighbors
gridX (Optional)
Type: SystemInt32
Grid X
gridY (Optional)
Type: SystemInt32
Grid Y
threshold (Optional)
Type: SystemDouble
The distance threshold
See Also

Reference

LBPHFaceRecognizer Class
Emgu.CV.Face Namespace


LBPHFaceRecognizer Properties

The LBPHFaceRecognizer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

LBPHFaceRecognizer Class
Emgu.CV.Face Namespace


LBPHFaceRecognizer Methods

The LBPHFaceRecognizer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FisherFaceRecognizer (Overrides FaceRecognizerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the label of the image (Inherited from FaceRecognizer.)
Public method | Read | Load the FaceRecognizer from the file (Inherited from FaceRecognizer.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train(IInputArray, IInputArray) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Train(Mat, Int32) | Train the face recognizer with the specific images and labels (Inherited from FaceRecognizer.)
Public method | Update(IInputArray, IInputArray) | Updates a FaceRecognizer with given data and associated labels.
Public method | Update(Mat, Int32) | Update the face recognizer with the specific images and labels
Public method | Write | Save the FaceRecognizer to a file (Inherited from FaceRecognizer.)
Top
See Also

Reference

LBPHFaceRecognizer Class
Emgu.CV.Face Namespace


LBPHFaceRecognizer.DisposeObject Method

LBPHFaceRecognizerDisposeObject Method

Release the unmanaged memory associated with this FisherFaceRecognizer

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LBPHFaceRecognizer Class
Emgu.CV.Face Namespace


LBPHFaceRecognizer.Update Method

LBPHFaceRecognizerUpdate Method

Overload List
 | Name | Description
Public method | Update(IInputArray, IInputArray) | Updates a FaceRecognizer with given data and associated labels.
Public method | Update(Mat, Int32) | Update the face recognizer with the specific images and labels
Top
See Also

Reference

LBPHFaceRecognizer Class
Emgu.CV.Face Namespace


LBPHFaceRecognizer.Update Method (IInputArray, IInputArray)

LBPHFaceRecognizerUpdate Method (IInputArray, IInputArray)

http://www.emgu.com
Updates a FaceRecognizer with given data and associated labels.

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    IInputArray images,
    IInputArray labels
)
Public Sub Update (
    images As IInputArray,
    labels As IInputArray
)
public:
void Update(
    IInputArray^ images,
    IInputArray^ labels
)
member Update :
        images : IInputArray *
        labels : IInputArray -> unit

Parameters

images
Type: Emgu.CVIInputArray
The training images, that means the faces you want to learn. The data has to be given as a VectorOfMat.
labels
Type: Emgu.CVIInputArray
The labels corresponding to the images
See Also

Reference

LBPHFaceRecognizer Class
Update Overload
Emgu.CV.Face Namespace


LBPHFaceRecognizer.Update Method (Mat[], Int32[])

LBPHFaceRecognizerUpdate Method (Mat, Int32)

http://www.emgu.com
Update the face recognizer with the specific images and labels

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    Mat[] images,
    int[] labels
)
Public Sub Update (
    images As Mat(),
    labels As Integer()
)
public:
void Update(
    array<Mat^>^ images,
    array<int>^ labels
)
member Update :
        images : Mat[] *
        labels : int[] -> unit

Parameters

images
Type: Emgu.CVMat
The images used for updating the face recognizer
labels
Type: SystemInt32
The labels of the images
See Also

Reference

LBPHFaceRecognizer Class
Update Overload
Emgu.CV.Face Namespace


LBPHFaceRecognizer Fields

The LBPHFaceRecognizer type exposes the following members.

Fields
 | Name | Description
Protected field | _faceRecognizerPtr | The native pointer to the FaceRecognizer object (Inherited from FaceRecognizer.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

LBPHFaceRecognizer Class
Emgu.CV.Face Namespace


MACE Class

Minimum Average Correlation Energy Filter useful for authentication with (cancellable) biometrical features. (does not need many positives to train (10-50), and no negatives at all, also robust to noise/salting)
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FaceMACE

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MACE : SharedPtrObject
Public Class MACE
    Inherits SharedPtrObject
public ref class MACE : public SharedPtrObject
type MACE =
    class
        inherit SharedPtrObject
    end

The MACE type exposes the following members.

Constructors
 | Name | Description
Public method | MACE | Create a new MACE object
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this BIF (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Salt | optionally encrypt images with random convolution
Public method | Same | correlate query img and threshold to min class value
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | train it on positive features compute the mace filter: h = D(-1) * X * (X(+) * D(-1) * X)(-1) * C also calculate a minimal threshold for this class, the smallest self-similarity from the train images
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Face Namespace


MACE Constructor

Create a new MACE object

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MACE(
    int imgSize
)
Public Sub New (
    imgSize As Integer
)
public:
MACE(
    int imgSize
)
new :
        imgSize : int -> MACE

Parameters

imgSize
Type: SystemInt32
images will get resized to this (should be an even number)
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


MACE Properties

The MACE type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


MACE Methods

The MACE type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this BIF (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Salt | optionally encrypt images with random convolution
Public method | Same | correlate query img and threshold to min class value
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | train it on positive features compute the mace filter: h = D(-1) * X * (X(+) * D(-1) * X)(-1) * C also calculate a minimal threshold for this class, the smallest self-similarity from the train images
Top
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


MACE.DisposeObject Method

MACEDisposeObject Method

Release the unmanaged memory associated with this BIF

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


MACE.Salt Method

MACESalt Method

optionally encrypt images with random convolution

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Salt(
    string passphrase
)
Public Sub Salt (
    passphrase As String
)
public:
void Salt(
    String^ passphrase
)
member Salt :
        passphrase : string -> unit

Parameters

passphrase
Type: SystemString
a crc64 random seed will get generated from this
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


MACE.Same Method

MACESame Method

correlate query img and threshold to min class value

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Same(
    IInputArray query
)
Public Function Same (
    query As IInputArray
) As Boolean
public:
bool Same(
    IInputArray^ query
)
member Same :
        query : IInputArray -> bool

Parameters

query
Type: Emgu.CVIInputArray
a Mat with query image

Return Value

Type: Boolean
True if the query is the same
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


MACE.Train Method

MACETrain Method

train it on positive features compute the mace filter: h = D(-1) * X * (X(+) * D(-1) * X)(-1) * C also calculate a minimal threshold for this class, the smallest self-similarity from the train images

Namespace: Emgu.CV.Face
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Train(
    IInputArrayOfArrays images
)
Public Sub Train (
    images As IInputArrayOfArrays
)
public:
void Train(
    IInputArrayOfArrays^ images
)
member Train :
        images : IInputArrayOfArrays -> unit

Parameters

images
Type: Emgu.CVIInputArrayOfArrays
A VectorOfMat with the train images
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


MACE Fields

The MACE type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MACE Class
Emgu.CV.Face Namespace


Emgu.CV.Features2D Namespace

Contains classes for 2D feature detection, extraction and matching.
Classes
 | Class | Description
Public class | AgastFeatureDetector | Wrapped AGAST detector
Public class | AgastFeatureDetectorType | Agast feature type
Public class | AKAZE | Wrapped AKAZE detector
Public class | AKAZEDescriptorType | Type of the extracted descriptor
Public class | BFMatcher | Wrapped BFMatcher
Public class | BOWImgDescriptorExtractor | Class to compute an image descriptor using the bag of visual words. Such a computation consists of the following steps: 1. Compute descriptors for a given image and its key points set. 2. Find the nearest visual words from the vocabulary for each key point descriptor. 3. Compute the bag-of-words image descriptor as is a normalized histogram of vocabulary words encountered in the image. The i-th bin of the histogram is a frequency of i-th word of the vocabulary in the given image.
Public class | BOWKMeansTrainer | Kmeans-based class to train visual vocabulary using the bag of visual words approach.
Public class | Brisk | BRISK: Binary Robust Invariant Scalable Keypoints
Public class | DescriptorMatcher | Descriptor matcher
Public class | DistanceType | The match distance type
Public class | FastFeatureDetector | FAST(Features from Accelerated Segment Test) keypoint detector. See Detects corners using FAST algorithm by E. Rosten ("Machine learning for high-speed corner detection, 2006).
Public class | FastFeatureDetectorDetectorType | One of the three neighborhoods as defined in the paper
Public class | Feature2D | The feature 2D base class
Public class | Features2DInvoke | Library to invoke Features2D functions
Public class | Features2DToolbox | Tools for features 2D
Public class | Features2DToolboxKeypointDrawType | Define the Keypoint draw type
Public class | FlannBasedMatcher | This matcher trains flann::Index_ on a train descriptor collection and calls its nearest search methods to find the best matches. So, this matcher may be faster when matching a large train collection than the brute force matcher.
Public class | GFTTDetector | Wrapping class for feature detection using the goodFeaturesToTrack() function.
Public class | KAZE | Wrapped KAZE detector
Public class | KAZEDiffusivity | The diffusivity
Public class | MSERDetector | MSER detector
Public class | ORBDetector | Wrapped ORB detector
Public class | ORBDetectorScoreType | The score type
Public class | SimpleBlobDetector | Simple Blob detector
Public class | SimpleBlobDetectorParams | Parameters for the simple blob detector


AgastFeatureDetector Class

Wrapped AGAST detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DAgastFeatureDetector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class AgastFeatureDetector : Feature2D
Public Class AgastFeatureDetector
    Inherits Feature2D
public ref class AgastFeatureDetector : public Feature2D
type AgastFeatureDetector =
    class
        inherit Feature2D
    end

The AgastFeatureDetector type exposes the following members.

Constructors
 | Name | Description
Public method | AgastFeatureDetector | Create AGAST using the specific values
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


AgastFeatureDetector Constructor

Create AGAST using the specific values

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public AgastFeatureDetector(
    int threshold = 10,
    bool nonmaxSuppression = true,
    AgastFeatureDetectorType type = 3
)
Public Sub New (
    Optional threshold As Integer = 10,
    Optional nonmaxSuppression As Boolean = true,
    Optional type As AgastFeatureDetectorType = 3
)
public:
AgastFeatureDetector(
    int threshold = 10,
    bool nonmaxSuppression = true,
    AgastFeatureDetectorType^ type = 3
)
new :
        ?threshold : int *
        ?nonmaxSuppression : bool *
        ?type : AgastFeatureDetectorType
(* Defaults:
        let _threshold = defaultArg threshold 10
        let _nonmaxSuppression = defaultArg nonmaxSuppression true
        let _type = defaultArg type 3
*)
-> AgastFeatureDetector

Parameters

threshold (Optional)
Type: SystemInt32
Threshold
nonmaxSuppression (Optional)
Type: SystemBoolean
Non maximum suppression
type (Optional)
Type: Emgu.CV.Features2DAgastFeatureDetectorType
Type
See Also

Reference

AgastFeatureDetector Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector Properties

The AgastFeatureDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

AgastFeatureDetector Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector Methods

The AgastFeatureDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AgastFeatureDetector Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector.DisposeObject Method

AgastFeatureDetectorDisposeObject Method

Release the unmanaged resources associated with this object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

AgastFeatureDetector Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector Fields

The AgastFeatureDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

AgastFeatureDetector Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector.Type Class

AgastFeatureDetectorType Class

Agast feature type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.Features2DAgastFeatureDetectorType

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Type : Enum
Public NotInheritable Class Type
    Inherits Enum
public ref class Type sealed : public Enum
[<SealedAttribute>]
type Type =
    class
        inherit Enum
    end

The AgastFeatureDetectorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AGAST_5_8 | AGAST_5_8
 | AGAST_7_12d | AGAST_7_12d
 | AGAST_7_12s | AGAST_7_12s
 | OAST_9_16 | OAST_9_16
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Features2D Namespace


Type Methods

The AgastFeatureDetectorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

AgastFeatureDetectorType Class
Emgu.CV.Features2D Namespace


Type Fields

The AgastFeatureDetectorType type exposes the following members.

Fields
 | Name | Description
 | AGAST_5_8 | AGAST_5_8
 | AGAST_7_12d | AGAST_7_12d
 | AGAST_7_12s | AGAST_7_12s
 | OAST_9_16 | OAST_9_16
Public field | value__ |
Top
See Also

Reference

AgastFeatureDetectorType Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector.Type.AGAST_5_8 Field

AgastFeatureDetectorTypeAGAST_5_8 Field

AGAST_5_8

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AgastFeatureDetectorType AGAST_5_8 = 0
Public Const AGAST_5_8 As AgastFeatureDetectorType = 0
public:
literal AgastFeatureDetectorType^ AGAST_5_8 = 0
static val mutable AGAST_5_8: AgastFeatureDetectorType

Field Value

Type: AgastFeatureDetectorType
See Also

Reference

AgastFeatureDetectorType Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector.Type.AGAST_7_12d Field

AgastFeatureDetectorTypeAGAST_7_12d Field

AGAST_7_12d

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AgastFeatureDetectorType AGAST_7_12d = 1
Public Const AGAST_7_12d As AgastFeatureDetectorType = 1
public:
literal AgastFeatureDetectorType^ AGAST_7_12d = 1
static val mutable AGAST_7_12d: AgastFeatureDetectorType

Field Value

Type: AgastFeatureDetectorType
See Also

Reference

AgastFeatureDetectorType Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector.Type.AGAST_7_12s Field

AgastFeatureDetectorTypeAGAST_7_12s Field

AGAST_7_12s

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AgastFeatureDetectorType AGAST_7_12s = 2
Public Const AGAST_7_12s As AgastFeatureDetectorType = 2
public:
literal AgastFeatureDetectorType^ AGAST_7_12s = 2
static val mutable AGAST_7_12s: AgastFeatureDetectorType

Field Value

Type: AgastFeatureDetectorType
See Also

Reference

AgastFeatureDetectorType Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector.Type.OAST_9_16 Field

AgastFeatureDetectorTypeOAST_9_16 Field

OAST_9_16

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AgastFeatureDetectorType OAST_9_16 = 3
Public Const OAST_9_16 As AgastFeatureDetectorType = 3
public:
literal AgastFeatureDetectorType^ OAST_9_16 = 3
static val mutable OAST_9_16: AgastFeatureDetectorType

Field Value

Type: AgastFeatureDetectorType
See Also

Reference

AgastFeatureDetectorType Class
Emgu.CV.Features2D Namespace


AgastFeatureDetector.Type.value__ Field

AgastFeatureDetectorTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.AgastFeatureDetector.Type.value__"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

AgastFeatureDetectorType Class
Emgu.CV.Features2D Namespace


AKAZE Class

Wrapped AKAZE detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DAKAZE

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class AKAZE : Feature2D
Public Class AKAZE
    Inherits Feature2D
public ref class AKAZE : public Feature2D
type AKAZE =
    class
        inherit Feature2D
    end

The AKAZE type exposes the following members.

Constructors
 | Name | Description
Public method | AKAZE | Create AKAZE using the specific values
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


AKAZE Constructor

Create AKAZE using the specific values

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public AKAZE(
    AKAZEDescriptorType descriptorType = 5,
    int descriptorSize = 0,
    int descriptorChannels = 3,
    float threshold = 0.001f,
    int nOctaves = 4,
    int nOctaveLayers = 4,
    KAZEDiffusivity diffusivity = 1
)
Public Sub New (
    Optional descriptorType As AKAZEDescriptorType = 5,
    Optional descriptorSize As Integer = 0,
    Optional descriptorChannels As Integer = 3,
    Optional threshold As Single = 0.001F,
    Optional nOctaves As Integer = 4,
    Optional nOctaveLayers As Integer = 4,
    Optional diffusivity As KAZEDiffusivity = 1
)
public:
AKAZE(
    AKAZEDescriptorType^ descriptorType = 5,
    int descriptorSize = 0,
    int descriptorChannels = 3,
    float threshold = 0.001f,
    int nOctaves = 4,
    int nOctaveLayers = 4,
    KAZEDiffusivity^ diffusivity = 1
)
new :
        ?descriptorType : AKAZEDescriptorType *
        ?descriptorSize : int *
        ?descriptorChannels : int *
        ?threshold : float32 *
        ?nOctaves : int *
        ?nOctaveLayers : int *
        ?diffusivity : KAZEDiffusivity
(* Defaults:
        let _descriptorType = defaultArg descriptorType 5
        let _descriptorSize = defaultArg descriptorSize 0
        let _descriptorChannels = defaultArg descriptorChannels 3
        let _threshold = defaultArg threshold 0.001f
        let _nOctaves = defaultArg nOctaves 4
        let _nOctaveLayers = defaultArg nOctaveLayers 4
        let _diffusivity = defaultArg diffusivity 1
*)
-> AKAZE

Parameters

descriptorType (Optional)
Type: Emgu.CV.Features2DAKAZEDescriptorType
Type of the extracted descriptor
descriptorSize (Optional)
Type: SystemInt32
Size of the descriptor in bits. 0 -> Full size
descriptorChannels (Optional)
Type: SystemInt32
Number of channels in the descriptor (1, 2, 3)
threshold (Optional)
Type: SystemSingle
Detector response threshold to accept point
nOctaves (Optional)
Type: SystemInt32
Maximum octave evolution of the image
nOctaveLayers (Optional)
Type: SystemInt32
Default number of sublevels per scale level
diffusivity (Optional)
Type: Emgu.CV.Features2DKAZEDiffusivity
Diffusivity type
See Also

Reference

AKAZE Class
Emgu.CV.Features2D Namespace


AKAZE Properties

The AKAZE type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

AKAZE Class
Emgu.CV.Features2D Namespace


AKAZE Methods

The AKAZE type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AKAZE Class
Emgu.CV.Features2D Namespace


AKAZE.DisposeObject Method

AKAZEDisposeObject Method

Release the unmanaged resources associated with this object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

AKAZE Class
Emgu.CV.Features2D Namespace


AKAZE Fields

The AKAZE type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

AKAZE Class
Emgu.CV.Features2D Namespace


AKAZE.DescriptorType Class

AKAZEDescriptorType Class

Type of the extracted descriptor
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.Features2DAKAZEDescriptorType

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DescriptorType : Enum
Public NotInheritable Class DescriptorType
    Inherits Enum
public ref class DescriptorType sealed : public Enum
[<SealedAttribute>]
type DescriptorType =
    class
        inherit Enum
    end

The AKAZEDescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Kaze | The kaze
 | KazeUpright | The kaze upright
 | Mldb | Modified-Local Difference Binary (M-LDB)
 | MldbUpright | Modified-Local Difference Binary (M-LDB), upright
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Features2D Namespace


DescriptorType Methods

The AKAZEDescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

AKAZEDescriptorType Class
Emgu.CV.Features2D Namespace


DescriptorType Fields

The AKAZEDescriptorType type exposes the following members.

Fields
 | Name | Description
 | Kaze | The kaze
 | KazeUpright | The kaze upright
 | Mldb | Modified-Local Difference Binary (M-LDB)
 | MldbUpright | Modified-Local Difference Binary (M-LDB), upright
Public field | value__ |
Top
See Also

Reference

AKAZEDescriptorType Class
Emgu.CV.Features2D Namespace


AKAZE.DescriptorType.Kaze Field

AKAZEDescriptorTypeKaze Field

The kaze

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AKAZEDescriptorType Kaze = 3
Public Const Kaze As AKAZEDescriptorType = 3
public:
literal AKAZEDescriptorType^ Kaze = 3
static val mutable Kaze: AKAZEDescriptorType

Field Value

Type: AKAZEDescriptorType
See Also

Reference

AKAZEDescriptorType Class
Emgu.CV.Features2D Namespace


AKAZE.DescriptorType.KazeUpright Field

AKAZEDescriptorTypeKazeUpright Field

The kaze upright

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AKAZEDescriptorType KazeUpright = 2
Public Const KazeUpright As AKAZEDescriptorType = 2
public:
literal AKAZEDescriptorType^ KazeUpright = 2
static val mutable KazeUpright: AKAZEDescriptorType

Field Value

Type: AKAZEDescriptorType
See Also

Reference

AKAZEDescriptorType Class
Emgu.CV.Features2D Namespace


AKAZE.DescriptorType.Mldb Field

AKAZEDescriptorTypeMldb Field

Modified-Local Difference Binary (M-LDB)

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AKAZEDescriptorType Mldb = 5
Public Const Mldb As AKAZEDescriptorType = 5
public:
literal AKAZEDescriptorType^ Mldb = 5
static val mutable Mldb: AKAZEDescriptorType

Field Value

Type: AKAZEDescriptorType
See Also

Reference

AKAZEDescriptorType Class
Emgu.CV.Features2D Namespace


AKAZE.DescriptorType.MldbUpright Field

AKAZEDescriptorTypeMldbUpright Field

Modified-Local Difference Binary (M-LDB), upright

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AKAZEDescriptorType MldbUpright = 4
Public Const MldbUpright As AKAZEDescriptorType = 4
public:
literal AKAZEDescriptorType^ MldbUpright = 4
static val mutable MldbUpright: AKAZEDescriptorType

Field Value

Type: AKAZEDescriptorType
See Also

Reference

AKAZEDescriptorType Class
Emgu.CV.Features2D Namespace


AKAZE.DescriptorType.value__ Field

AKAZEDescriptorTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.AKAZE.DescriptorType.value__"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

AKAZEDescriptorType Class
Emgu.CV.Features2D Namespace


BFMatcher Class

Wrapped BFMatcher
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.Features2DDescriptorMatcher
Emgu.CV.Features2DBFMatcher

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BFMatcher : DescriptorMatcher
Public Class BFMatcher
    Inherits DescriptorMatcher
public ref class BFMatcher : public DescriptorMatcher
type BFMatcher =
    class
        inherit DescriptorMatcher
    end

The BFMatcher type exposes the following members.

Constructors
 | Name | Description
Public method | BFMatcher | Create a BFMatcher of the specific distance type
Top
Properties
 | Name | Description
Public property | Empty | Returns true if there are no train descriptors in the both collections. (Inherited from DescriptorMatcher.)
Public property | IsMaskSupported | Returns true if the descriptor matcher supports masking permissible matches. (Inherited from DescriptorMatcher.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Add | Add the model descriptors (Inherited from DescriptorMatcher.)
Public method | Clear | Clears the train descriptor collections. (Inherited from DescriptorMatcher.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with the BFMatcher (Overrides DescriptorMatcherDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Finds the k best matches for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, VectorOfDMatch, IInputArrayOfArrays) | Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher (for example, the flann index). In all methods to match, the method train() is run every time before matching.Some descriptor matchers(for example, BruteForceMatcher) have an empty implementation of this method.Other matchers really train their inner structures (for example, FlannBasedMatcher trains flann::Index ). (Inherited from DescriptorMatcher.)
Top
Fields
 | Name | Description
Protected field | _descriptorMatcherPtr | The pointer to the Descriptor matcher (Inherited from DescriptorMatcher.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


BFMatcher Constructor

Create a BFMatcher of the specific distance type

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BFMatcher(
    DistanceType distanceType,
    bool crossCheck = false
)
Public Sub New (
    distanceType As DistanceType,
    Optional crossCheck As Boolean = false
)
public:
BFMatcher(
    DistanceType^ distanceType,
    bool crossCheck = false
)
new :
        distanceType : DistanceType *
        ?crossCheck : bool
(* Defaults:
        let _crossCheck = defaultArg crossCheck false
*)
-> BFMatcher

Parameters

distanceType
Type: Emgu.CV.Features2DDistanceType
The distance type
crossCheck (Optional)
Type: SystemBoolean
Specify whether or not cross check is needed. Use false for default.
See Also

Reference

BFMatcher Class
Emgu.CV.Features2D Namespace


BFMatcher Properties

The BFMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Empty | Returns true if there are no train descriptors in the both collections. (Inherited from DescriptorMatcher.)
Public property | IsMaskSupported | Returns true if the descriptor matcher supports masking permissible matches. (Inherited from DescriptorMatcher.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BFMatcher Class
Emgu.CV.Features2D Namespace


BFMatcher Methods

The BFMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add the model descriptors (Inherited from DescriptorMatcher.)
Public method | Clear | Clears the train descriptor collections. (Inherited from DescriptorMatcher.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with the BFMatcher (Overrides DescriptorMatcherDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Finds the k best matches for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, VectorOfDMatch, IInputArrayOfArrays) | Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher (for example, the flann index). In all methods to match, the method train() is run every time before matching.Some descriptor matchers(for example, BruteForceMatcher) have an empty implementation of this method.Other matchers really train their inner structures (for example, FlannBasedMatcher trains flann::Index ). (Inherited from DescriptorMatcher.)
Top
See Also

Reference

BFMatcher Class
Emgu.CV.Features2D Namespace


BFMatcher.DisposeObject Method

BFMatcherDisposeObject Method

Release the unmanaged resource associated with the BFMatcher

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BFMatcher Class
Emgu.CV.Features2D Namespace


BFMatcher Fields

The BFMatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _descriptorMatcherPtr | The pointer to the Descriptor matcher (Inherited from DescriptorMatcher.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BFMatcher Class
Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor Class

Class to compute an image descriptor using the bag of visual words. Such a computation consists of the following steps: 1. Compute descriptors for a given image and its key points set. 2. Find the nearest visual words from the vocabulary for each key point descriptor. 3. Compute the bag-of-words image descriptor as is a normalized histogram of vocabulary words encountered in the image. The i-th bin of the histogram is a frequency of i-th word of the vocabulary in the given image.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.Features2DBOWImgDescriptorExtractor

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BOWImgDescriptorExtractor : UnmanagedObject
Public Class BOWImgDescriptorExtractor
    Inherits UnmanagedObject
public ref class BOWImgDescriptorExtractor : public UnmanagedObject
type BOWImgDescriptorExtractor =
    class
        inherit UnmanagedObject
    end

The BOWImgDescriptorExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | BOWImgDescriptorExtractor | Create a BOWImgDescriptorExtractor
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compute | Computes an image descriptor using the set visual vocabulary.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetVocabulary | Sets a visual vocabulary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor Constructor

Create a BOWImgDescriptorExtractor

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BOWImgDescriptorExtractor(
    Feature2D descriptorExtractor,
    DescriptorMatcher descriptorMatcher
)
Public Sub New (
    descriptorExtractor As Feature2D,
    descriptorMatcher As DescriptorMatcher
)
public:
BOWImgDescriptorExtractor(
    Feature2D^ descriptorExtractor,
    DescriptorMatcher^ descriptorMatcher
)
new :
        descriptorExtractor : Feature2D *
        descriptorMatcher : DescriptorMatcher -> BOWImgDescriptorExtractor

Parameters

descriptorExtractor
Type: Emgu.CV.Features2DFeature2D
Descriptor extractor that is used to compute descriptors for an input image and its key points.
descriptorMatcher
Type: Emgu.CV.Features2DDescriptorMatcher
Descriptor matcher that is used to find the nearest word of the trained vocabulary for each key point descriptor of the image.
See Also

Reference

BOWImgDescriptorExtractor Class
Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor Properties

The BOWImgDescriptorExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BOWImgDescriptorExtractor Class
Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor Methods

The BOWImgDescriptorExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Computes an image descriptor using the set visual vocabulary.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetVocabulary | Sets a visual vocabulary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BOWImgDescriptorExtractor Class
Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor.Compute Method

BOWImgDescriptorExtractorCompute Method

Computes an image descriptor using the set visual vocabulary.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Compute(
    IInputArray image,
    VectorOfKeyPoint keypoints,
    Mat imgDescriptors
)
Public Sub Compute (
    image As IInputArray,
    keypoints As VectorOfKeyPoint,
    imgDescriptors As Mat
)
public:
void Compute(
    IInputArray^ image,
    VectorOfKeyPoint^ keypoints,
    Mat^ imgDescriptors
)
member Compute :
        image : IInputArray *
        keypoints : VectorOfKeyPoint *
        imgDescriptors : Mat -> unit

Parameters

image
Type: Emgu.CVIInputArray
Image, for which the descriptor is computed
keypoints
Type: Emgu.CV.UtilVectorOfKeyPoint
Key points detected in the input image.
imgDescriptors
Type: Emgu.CVMat
The output image descriptors.
See Also

Reference

BOWImgDescriptorExtractor Class
Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor.DisposeObject Method

BOWImgDescriptorExtractorDisposeObject Method

Release all the unmanaged memory associated with this object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BOWImgDescriptorExtractor Class
Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor.SetVocabulary Method

BOWImgDescriptorExtractorSetVocabulary Method

Sets a visual vocabulary.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetVocabulary(
    Mat vocabulary
)
Public Sub SetVocabulary (
    vocabulary As Mat
)
public:
void SetVocabulary(
    Mat^ vocabulary
)
member SetVocabulary :
        vocabulary : Mat -> unit

Parameters

vocabulary
Type: Emgu.CVMat
The vocabulary
See Also

Reference

BOWImgDescriptorExtractor Class
Emgu.CV.Features2D Namespace


BOWImgDescriptorExtractor Fields

The BOWImgDescriptorExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BOWImgDescriptorExtractor Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer Class

Kmeans-based class to train visual vocabulary using the bag of visual words approach.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.Features2DBOWKMeansTrainer

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BOWKMeansTrainer : UnmanagedObject
Public Class BOWKMeansTrainer
    Inherits UnmanagedObject
public ref class BOWKMeansTrainer : public UnmanagedObject
type BOWKMeansTrainer =
    class
        inherit UnmanagedObject
    end

The BOWKMeansTrainer type exposes the following members.

Constructors
 | Name | Description
Public method | BOWKMeansTrainer | Create a new BOWKmeans trainer
Top
Properties
 | Name | Description
Public property | DescriptorCount | Get the number of descriptors
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Add | Add the descriptors to the trainer
Public method | Cluster | Cluster the descriptors and return the cluster centers
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


BOWKMeansTrainer Constructor

Create a new BOWKmeans trainer

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BOWKMeansTrainer(
    int clusterCount,
    MCvTermCriteria termcrit,
    int attempts = 3,
    KMeansInitType flags = 2
)
Public Sub New (
    clusterCount As Integer,
    termcrit As MCvTermCriteria,
    Optional attempts As Integer = 3,
    Optional flags As KMeansInitType = 2
)
public:
BOWKMeansTrainer(
    int clusterCount,
    MCvTermCriteria^ termcrit,
    int attempts = 3,
    KMeansInitType^ flags = 2
)
new :
        clusterCount : int *
        termcrit : MCvTermCriteria *
        ?attempts : int *
        ?flags : KMeansInitType
(* Defaults:
        let _attempts = defaultArg attempts 3
        let _flags = defaultArg flags 2
*)
-> BOWKMeansTrainer

Parameters

clusterCount
Type: SystemInt32
Number of clusters to split the set by.
termcrit
Type: Emgu.CV.StructureMCvTermCriteria
Specifies maximum number of iterations and/or accuracy (distance the centers move by between the subsequent iterations). Use empty termcrit for default.
attempts (Optional)
Type: SystemInt32
The number of attempts. Use 3 for default
flags (Optional)
Type: Emgu.CV.CvEnumKMeansInitType
Kmeans initialization flag. Use PPCenters for default.
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer Properties

The BOWKMeansTrainer type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorCount | Get the number of descriptors
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer.DescriptorCount Property

BOWKMeansTrainerDescriptorCount Property

Get the number of descriptors

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DescriptorCount { get; }
Public ReadOnly Property DescriptorCount As Integer
    Get
public:
property int DescriptorCount {
    int get ();
}
member DescriptorCount : int with get

Property Value

Type: Int32
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer Methods

The BOWKMeansTrainer type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add the descriptors to the trainer
Public method | Cluster | Cluster the descriptors and return the cluster centers
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer.Add Method

BOWKMeansTrainerAdd Method

Add the descriptors to the trainer

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Mat descriptors
)
Public Sub Add (
    descriptors As Mat
)
public:
void Add(
    Mat^ descriptors
)
member Add :
        descriptors : Mat -> unit

Parameters

descriptors
Type: Emgu.CVMat
The descriptors to be added to the trainer
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer.Cluster Method

BOWKMeansTrainerCluster Method

Cluster the descriptors and return the cluster centers

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Cluster(
    IOutputArray cluster
)
Public Sub Cluster (
    cluster As IOutputArray
)
public:
void Cluster(
    IOutputArray^ cluster
)
member Cluster :
        cluster : IOutputArray -> unit

Parameters

cluster
Type: Emgu.CVIOutputArray
The cluster centers
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer.DisposeObject Method

BOWKMeansTrainerDisposeObject Method

Release all the unmanaged memory associated with this object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


BOWKMeansTrainer Fields

The BOWKMeansTrainer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BOWKMeansTrainer Class
Emgu.CV.Features2D Namespace


Brisk Class

BRISK: Binary Robust Invariant Scalable Keypoints
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DBrisk

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Brisk : Feature2D
Public Class Brisk
    Inherits Feature2D
public ref class Brisk : public Feature2D
type Brisk =
    class
        inherit Feature2D
    end

The Brisk type exposes the following members.

Constructors
 | Name | Description
Public method | Brisk | Create a BRISK keypoint detector and descriptor extractor.
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


Brisk Constructor

Create a BRISK keypoint detector and descriptor extractor.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Brisk(
    int thresh = 30,
    int octaves = 3,
    float patternScale = 1f
)
Public Sub New (
    Optional thresh As Integer = 30,
    Optional octaves As Integer = 3,
    Optional patternScale As Single = 1F
)
public:
Brisk(
    int thresh = 30,
    int octaves = 3,
    float patternScale = 1f
)
new :
        ?thresh : int *
        ?octaves : int *
        ?patternScale : float32
(* Defaults:
        let _thresh = defaultArg thresh 30
        let _octaves = defaultArg octaves 3
        let _patternScale = defaultArg patternScale 1f
*)
-> Brisk

Parameters

thresh (Optional)
Type: SystemInt32
Feature parameters.
octaves (Optional)
Type: SystemInt32
The number of octave layers.
patternScale (Optional)
Type: SystemSingle
Pattern scale
See Also

Reference

Brisk Class
Emgu.CV.Features2D Namespace


Brisk Properties

The Brisk type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Brisk Class
Emgu.CV.Features2D Namespace


Brisk Methods

The Brisk type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Brisk Class
Emgu.CV.Features2D Namespace


Brisk.DisposeObject Method

BriskDisposeObject Method

Release the unmanaged resources associated with this object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Brisk Class
Emgu.CV.Features2D Namespace


Brisk Fields

The Brisk type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Brisk Class
Emgu.CV.Features2D Namespace


DescriptorMatcher Class

Descriptor matcher
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.Features2DDescriptorMatcher
Emgu.CV.Features2DBFMatcher
Emgu.CV.Features2DFlannBasedMatcher

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class DescriptorMatcher : UnmanagedObject,
    IAlgorithm
Public MustInherit Class DescriptorMatcher
    Inherits UnmanagedObject
    Implements IAlgorithm
public ref class DescriptorMatcher abstract : public UnmanagedObject,
    IAlgorithm
[<AbstractClassAttribute>]
type DescriptorMatcher =
    class
        inherit UnmanagedObject
        interface IAlgorithm
    end

The DescriptorMatcher type exposes the following members.

Constructors
 | Name | Description
Protected method | DescriptorMatcher | Initializes a new instance of the DescriptorMatcher class
Top
Properties
 | Name | Description
Public property | Empty | Returns true if there are no train descriptors in the both collections.
Public property | IsMaskSupported | Returns true if the descriptor matcher supports masking permissible matches.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Add | Add the model descriptors
Public method | Clear | Clears the train descriptor collections.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the native pointer upon object disposal (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Finds the k best matches for each descriptor from a query set.
Public method | Match(IInputArray, VectorOfDMatch, IInputArrayOfArrays) | Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used.
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance.
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher (for example, the flann index). In all methods to match, the method train() is run every time before matching.Some descriptor matchers(for example, BruteForceMatcher) have an empty implementation of this method.Other matchers really train their inner structures (for example, FlannBasedMatcher trains flann::Index ).
Top
Fields
 | Name | Description
Protected field | _descriptorMatcherPtr | The pointer to the Descriptor matcher
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


DescriptorMatcher Constructor

Initializes a new instance of the DescriptorMatcher class

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected DescriptorMatcher()
Protected Sub New
protected:
DescriptorMatcher()
new : unit -> DescriptorMatcher
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher Properties

The DescriptorMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Empty | Returns true if there are no train descriptors in the both collections.
Public property | IsMaskSupported | Returns true if the descriptor matcher supports masking permissible matches.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.Empty Property

DescriptorMatcherEmpty Property

Returns true if there are no train descriptors in the both collections.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get

Property Value

Type: Boolean
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.IsMaskSupported Property

DescriptorMatcherIsMaskSupported Property

Returns true if the descriptor matcher supports masking permissible matches.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsMaskSupported { get; }
Public ReadOnly Property IsMaskSupported As Boolean
    Get
public:
property bool IsMaskSupported {
    bool get ();
}
member IsMaskSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher Methods

The DescriptorMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add the model descriptors
Public method | Clear | Clears the train descriptor collections.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the native pointer upon object disposal (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Finds the k best matches for each descriptor from a query set.
Public method | Match(IInputArray, VectorOfDMatch, IInputArrayOfArrays) | Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used.
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance.
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher (for example, the flann index). In all methods to match, the method train() is run every time before matching.Some descriptor matchers(for example, BruteForceMatcher) have an empty implementation of this method.Other matchers really train their inner structures (for example, FlannBasedMatcher trains flann::Index ).
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.Add Method

DescriptorMatcherAdd Method

Add the model descriptors

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    IInputArray modelDescriptors
)
Public Sub Add (
    modelDescriptors As IInputArray
)
public:
void Add(
    IInputArray^ modelDescriptors
)
member Add :
        modelDescriptors : IInputArray -> unit

Parameters

modelDescriptors
Type: Emgu.CVIInputArray
The model descriptors
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.Clear Method

DescriptorMatcherClear Method

Clears the train descriptor collections.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.DisposeObject Method

DescriptorMatcherDisposeObject Method

Reset the native pointer upon object disposal

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.KnnMatch Method

DescriptorMatcherKnnMatch Method

Overload List
 | Name | Description
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Finds the k best matches for each descriptor from a query set.
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.KnnMatch Method (IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean)

DescriptorMatcherKnnMatch Method (IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean)

http://www.emgu.com
Find the k-nearest match

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnMatch(
    IInputArray queryDescriptor,
    VectorOfVectorOfDMatch matches,
    int k,
    IInputArray mask = null,
    bool compactResult = false
)
Public Sub KnnMatch (
    queryDescriptor As IInputArray,
    matches As VectorOfVectorOfDMatch,
    k As Integer,
    Optional mask As IInputArray = Nothing,
    Optional compactResult As Boolean = false
)
public:
void KnnMatch(
    IInputArray^ queryDescriptor,
    VectorOfVectorOfDMatch^ matches,
    int k,
    IInputArray^ mask = nullptr,
    bool compactResult = false
)
member KnnMatch :
        queryDescriptor : IInputArray *
        matches : VectorOfVectorOfDMatch *
        k : int *
        ?mask : IInputArray *
        ?compactResult : bool
(* Defaults:
        let _mask = defaultArg mask null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptor
Type: Emgu.CVIInputArray
An n x m matrix of descriptors to be query for nearest neighbours. n is the number of descriptor and m is the size of the descriptor
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
k
Type: SystemInt32
Number of nearest neighbors to search for
mask (Optional)
Type: Emgu.CVIInputArray
Can be null if not needed. An n x 1 matrix. If 0, the query descriptor in the corresponding row will be ignored.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows.If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
KnnMatch Overload
Emgu.CV.Features2D Namespace


DescriptorMatcher.KnnMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean)

DescriptorMatcherKnnMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean)

http://www.emgu.com
Finds the k best matches for each descriptor from a query set.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnMatch(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    VectorOfVectorOfDMatch matches,
    int k,
    IInputArray mask = null,
    bool compactResult = false
)
Public Sub KnnMatch (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As VectorOfVectorOfDMatch,
    k As Integer,
    Optional mask As IInputArray = Nothing,
    Optional compactResult As Boolean = false
)
public:
void KnnMatch(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    VectorOfVectorOfDMatch^ matches,
    int k,
    IInputArray^ mask = nullptr,
    bool compactResult = false
)
member KnnMatch :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : VectorOfVectorOfDMatch *
        k : int *
        ?mask : IInputArray *
        ?compactResult : bool
(* Defaults:
        let _mask = defaultArg mask null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
k
Type: SystemInt32
Count of best matches found per each query descriptor or less if a query descriptor has less than k possible matches in total.
mask (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
KnnMatch Overload
Emgu.CV.Features2D Namespace


DescriptorMatcher.Match Method

DescriptorMatcherMatch Method

Overload List
 | Name | Description
Public method | Match(IInputArray, VectorOfDMatch, IInputArrayOfArrays) | Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used.
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set.
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.Match Method (IInputArray, VectorOfDMatch, IInputArrayOfArrays)

DescriptorMatcherMatch Method (IInputArray, VectorOfDMatch, IInputArrayOfArrays)

http://www.emgu.com
Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Match(
    IInputArray queryDescriptors,
    VectorOfDMatch matches,
    IInputArrayOfArrays masks = null
)
Public Sub Match (
    queryDescriptors As IInputArray,
    matches As VectorOfDMatch,
    Optional masks As IInputArrayOfArrays = Nothing
)
public:
void Match(
    IInputArray^ queryDescriptors,
    VectorOfDMatch^ matches,
    IInputArrayOfArrays^ masks = nullptr
)
member Match :
        queryDescriptors : IInputArray *
        matches : VectorOfDMatch *
        ?masks : IInputArrayOfArrays
(* Defaults:
        let _masks = defaultArg masks null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
matches
Type: Emgu.CV.UtilVectorOfDMatch
If a query descriptor is masked out in mask , no match is added for this descriptor. So, matches size may be smaller than the query descriptors count.
masks (Optional)
Type: Emgu.CVIInputArrayOfArrays
Mask specifying permissible matches between an input query and train matrices of descriptors.
See Also

Reference

DescriptorMatcher Class
Match Overload
Emgu.CV.Features2D Namespace


DescriptorMatcher.Match Method (IInputArray, IInputArray, VectorOfDMatch, IInputArray)

DescriptorMatcherMatch Method (IInputArray, IInputArray, VectorOfDMatch, IInputArray)

http://www.emgu.com
Finds the best match for each descriptor from a query set.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Match(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    VectorOfDMatch matches,
    IInputArray mask = null
)
Public Sub Match (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As VectorOfDMatch,
    Optional mask As IInputArray = Nothing
)
public:
void Match(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    VectorOfDMatch^ matches,
    IInputArray^ mask = nullptr
)
member Match :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : VectorOfDMatch *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CV.UtilVectorOfDMatch
If a query descriptor is masked out in mask , no match is added for this descriptor. So, matches size may be smaller than the query descriptors count.
mask (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
See Also

Reference

DescriptorMatcher Class
Match Overload
Emgu.CV.Features2D Namespace


DescriptorMatcher.RadiusMatch Method

DescriptorMatcherRadiusMatch Method

Overload List
 | Name | Description
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance.
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance.
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher.RadiusMatch Method (IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean)

DescriptorMatcherRadiusMatch Method (IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean)

http://www.emgu.com
For each query descriptor, finds the training descriptors not farther than the specified distance.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RadiusMatch(
    IInputArray queryDescriptors,
    VectorOfVectorOfDMatch matches,
    float maxDistance,
    IInputArray masks = null,
    bool compactResult = false
)
Public Sub RadiusMatch (
    queryDescriptors As IInputArray,
    matches As VectorOfVectorOfDMatch,
    maxDistance As Single,
    Optional masks As IInputArray = Nothing,
    Optional compactResult As Boolean = false
)
public:
void RadiusMatch(
    IInputArray^ queryDescriptors,
    VectorOfVectorOfDMatch^ matches,
    float maxDistance,
    IInputArray^ masks = nullptr,
    bool compactResult = false
)
member RadiusMatch :
        queryDescriptors : IInputArray *
        matches : VectorOfVectorOfDMatch *
        maxDistance : float32 *
        ?masks : IInputArray *
        ?compactResult : bool
(* Defaults:
        let _masks = defaultArg masks null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Found matches.
maxDistance
Type: SystemSingle
Threshold for the distance between matched descriptors. Distance means here metric distance (e.g. Hamming distance), not the distance between coordinates (which is measured in Pixels)!
masks (Optional)
Type: Emgu.CVIInputArray
Mask specifying permissible matches between an input query and train matrices of descriptors.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
RadiusMatch Overload
Emgu.CV.Features2D Namespace


DescriptorMatcher.RadiusMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean)

DescriptorMatcherRadiusMatch Method (IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean)

http://www.emgu.com
For each query descriptor, finds the training descriptors not farther than the specified distance.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void RadiusMatch(
    IInputArray queryDescriptors,
    IInputArray trainDescriptors,
    VectorOfVectorOfDMatch matches,
    float maxDistance,
    IInputArrayOfArrays mask = null,
    bool compactResult = false
)
Public Sub RadiusMatch (
    queryDescriptors As IInputArray,
    trainDescriptors As IInputArray,
    matches As VectorOfVectorOfDMatch,
    maxDistance As Single,
    Optional mask As IInputArrayOfArrays = Nothing,
    Optional compactResult As Boolean = false
)
public:
void RadiusMatch(
    IInputArray^ queryDescriptors,
    IInputArray^ trainDescriptors,
    VectorOfVectorOfDMatch^ matches,
    float maxDistance,
    IInputArrayOfArrays^ mask = nullptr,
    bool compactResult = false
)
member RadiusMatch :
        queryDescriptors : IInputArray *
        trainDescriptors : IInputArray *
        matches : VectorOfVectorOfDMatch *
        maxDistance : float32 *
        ?mask : IInputArrayOfArrays *
        ?compactResult : bool
(* Defaults:
        let _mask = defaultArg mask null
        let _compactResult = defaultArg compactResult false
*)
-> unit

Parameters

queryDescriptors
Type: Emgu.CVIInputArray
Query set of descriptors.
trainDescriptors
Type: Emgu.CVIInputArray
Train set of descriptors. This set is not added to the train descriptors collection stored in the class object.
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Found matches.
maxDistance
Type: SystemSingle
Threshold for the distance between matched descriptors. Distance means here metric distance (e.g. Hamming distance), not the distance between coordinates (which is measured in Pixels)!
mask (Optional)
Type: Emgu.CVIInputArrayOfArrays
Mask specifying permissible matches between an input query and train matrices of descriptors.
compactResult (Optional)
Type: SystemBoolean
Parameter used when the mask (or masks) is not empty. If compactResult is false, the matches vector has the same size as queryDescriptors rows. If compactResult is true, the matches vector does not contain matches for fully masked-out query descriptors.
See Also

Reference

DescriptorMatcher Class
RadiusMatch Overload
Emgu.CV.Features2D Namespace


DescriptorMatcher.Train Method

DescriptorMatcherTrain Method

Trains a descriptor matcher (for example, the flann index). In all methods to match, the method train() is run every time before matching.Some descriptor matchers(for example, BruteForceMatcher) have an empty implementation of this method.Other matchers really train their inner structures (for example, FlannBasedMatcher trains flann::Index ).

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Train()
Public Sub Train
public:
void Train()
member Train : unit -> unit
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher Fields

The DescriptorMatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _descriptorMatcherPtr | The pointer to the Descriptor matcher
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DescriptorMatcher._descriptorMatcherPtr Field

DescriptorMatcher_descriptorMatcherPtr Field

The pointer to the Descriptor matcher

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _descriptorMatcherPtr
Protected _descriptorMatcherPtr As IntPtr
protected:
IntPtr _descriptorMatcherPtr
val mutable _descriptorMatcherPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

DescriptorMatcher Class
Emgu.CV.Features2D Namespace


DistanceType Class

The match distance type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.Features2DDistanceType

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class DistanceType : Enum
<FlagsAttribute>
Public NotInheritable Class DistanceType
    Inherits Enum
[FlagsAttribute]
public ref class DistanceType sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type DistanceType =
    class
        inherit Enum
    end

The DistanceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Hamming | Hamming distance functor - counts the bit differences between two strings - useful for the Brief descriptor, bit count of A exclusive XOR'ed with B.
 | Hamming2 | Hamming distance functor - counts the bit differences between two strings - useful for the Brief descriptor, bit count of A exclusive XOR'ed with B.
 | Inf |
 | L1 | Manhattan distance (city block distance)
 | L2 | Squared Euclidean distance
 | L2Sqr | Euclidean distance
 | MinMax | MinMax, flag
 | Relative | Relative, flag
 | TypeMask | bit-mask which can be used to separate norm type from norm flags
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Features2D Namespace


DistanceType Methods

The DistanceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType Fields

The DistanceType type exposes the following members.

Fields
 | Name | Description
 | Hamming | Hamming distance functor - counts the bit differences between two strings - useful for the Brief descriptor, bit count of A exclusive XOR'ed with B.
 | Hamming2 | Hamming distance functor - counts the bit differences between two strings - useful for the Brief descriptor, bit count of A exclusive XOR'ed with B.
 | Inf |
 | L1 | Manhattan distance (city block distance)
 | L2 | Squared Euclidean distance
 | L2Sqr | Euclidean distance
 | MinMax | MinMax, flag
 | Relative | Relative, flag
 | TypeMask | bit-mask which can be used to separate norm type from norm flags
Public field | value__ |
Top
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.Hamming Field

DistanceTypeHamming Field

Hamming distance functor - counts the bit differences between two strings - useful for the Brief descriptor, bit count of A exclusive XOR'ed with B.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType Hamming = 6
Public Const Hamming As DistanceType = 6
public:
literal DistanceType^ Hamming = 6
static val mutable Hamming: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.Hamming2 Field

DistanceTypeHamming2 Field

Hamming distance functor - counts the bit differences between two strings - useful for the Brief descriptor, bit count of A exclusive XOR'ed with B.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType Hamming2 = 7
Public Const Hamming2 As DistanceType = 7
public:
literal DistanceType^ Hamming2 = 7
static val mutable Hamming2: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.Inf Field

DistanceTypeInf Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.DistanceType.Inf"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType Inf = 1
Public Const Inf As DistanceType = 1
public:
literal DistanceType^ Inf = 1
static val mutable Inf: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.L1 Field

DistanceTypeL1 Field

Manhattan distance (city block distance)

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType L1 = 2
Public Const L1 As DistanceType = 2
public:
literal DistanceType^ L1 = 2
static val mutable L1: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.L2 Field

DistanceTypeL2 Field

Squared Euclidean distance

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType L2 = 4
Public Const L2 As DistanceType = 4
public:
literal DistanceType^ L2 = 4
static val mutable L2: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.L2Sqr Field

DistanceTypeL2Sqr Field

Euclidean distance

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType L2Sqr = 5
Public Const L2Sqr As DistanceType = 5
public:
literal DistanceType^ L2Sqr = 5
static val mutable L2Sqr: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.MinMax Field

DistanceTypeMinMax Field

MinMax, flag

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType MinMax = 32
Public Const MinMax As DistanceType = 32
public:
literal DistanceType^ MinMax = 32
static val mutable MinMax: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.Relative Field

DistanceTypeRelative Field

Relative, flag

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType Relative = 8
Public Const Relative As DistanceType = 8
public:
literal DistanceType^ Relative = 8
static val mutable Relative: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.TypeMask Field

DistanceTypeTypeMask Field

bit-mask which can be used to separate norm type from norm flags

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistanceType TypeMask = 7
Public Const TypeMask As DistanceType = 7
public:
literal DistanceType^ TypeMask = 7
static val mutable TypeMask: DistanceType

Field Value

Type: DistanceType
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


DistanceType.value__ Field

DistanceTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.DistanceType.value__"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DistanceType Class
Emgu.CV.Features2D Namespace


FastFeatureDetector Class

FAST(Features from Accelerated Segment Test) keypoint detector. See Detects corners using FAST algorithm by E. Rosten ("Machine learning for high-speed corner detection, 2006).
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DFastFeatureDetector
Emgu.CV.CudaCudaFastFeatureDetector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FastFeatureDetector : Feature2D
Public Class FastFeatureDetector
    Inherits Feature2D
public ref class FastFeatureDetector : public Feature2D
type FastFeatureDetector =
    class
        inherit Feature2D
    end

The FastFeatureDetector type exposes the following members.

Constructors
 | Name | Description
Public method | FastFeatureDetector | Create a fast detector with the specific parameters
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


FastFeatureDetector Constructor

Create a fast detector with the specific parameters

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FastFeatureDetector(
    int threshold = 10,
    bool nonmaxSupression = true,
    FastFeatureDetectorDetectorType type = 2
)
Public Sub New (
    Optional threshold As Integer = 10,
    Optional nonmaxSupression As Boolean = true,
    Optional type As FastFeatureDetectorDetectorType = 2
)
public:
FastFeatureDetector(
    int threshold = 10,
    bool nonmaxSupression = true,
    FastFeatureDetectorDetectorType^ type = 2
)
new :
        ?threshold : int *
        ?nonmaxSupression : bool *
        ?type : FastFeatureDetectorDetectorType
(* Defaults:
        let _threshold = defaultArg threshold 10
        let _nonmaxSupression = defaultArg nonmaxSupression true
        let _type = defaultArg type 2
*)
-> FastFeatureDetector

Parameters

threshold (Optional)
Type: SystemInt32
Threshold on difference between intensity of center pixel and pixels on circle around this pixel.
nonmaxSupression (Optional)
Type: SystemBoolean
Specify if non-maximum suppression should be used.
type (Optional)
Type: Emgu.CV.Features2DFastFeatureDetectorDetectorType
One of the three neighborhoods as defined in the paper
See Also

Reference

FastFeatureDetector Class
Emgu.CV.Features2D Namespace


FastFeatureDetector Properties

The FastFeatureDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FastFeatureDetector Class
Emgu.CV.Features2D Namespace


FastFeatureDetector Methods

The FastFeatureDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FastFeatureDetector Class
Emgu.CV.Features2D Namespace


FastFeatureDetector.DisposeObject Method

FastFeatureDetectorDisposeObject Method

Release the unmanaged memory associated with this detector.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FastFeatureDetector Class
Emgu.CV.Features2D Namespace


FastFeatureDetector Fields

The FastFeatureDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FastFeatureDetector Class
Emgu.CV.Features2D Namespace


FastFeatureDetector.DetectorType Class

FastFeatureDetectorDetectorType Class

One of the three neighborhoods as defined in the paper
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.Features2DFastFeatureDetectorDetectorType

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DetectorType : Enum
Public NotInheritable Class DetectorType
    Inherits Enum
public ref class DetectorType sealed : public Enum
[<SealedAttribute>]
type DetectorType =
    class
        inherit Enum
    end

The FastFeatureDetectorDetectorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Type5_8 | The type5_8
 | Type7_12 | The type7_12
 | Type9_16 | The type9_16
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Features2D Namespace


DetectorType Methods

The FastFeatureDetectorDetectorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FastFeatureDetectorDetectorType Class
Emgu.CV.Features2D Namespace


DetectorType Fields

The FastFeatureDetectorDetectorType type exposes the following members.

Fields
 | Name | Description
 | Type5_8 | The type5_8
 | Type7_12 | The type7_12
 | Type9_16 | The type9_16
Public field | value__ |
Top
See Also

Reference

FastFeatureDetectorDetectorType Class
Emgu.CV.Features2D Namespace


FastFeatureDetector.DetectorType.Type5_8 Field

FastFeatureDetectorDetectorTypeType5_8 Field

The type5_8

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FastFeatureDetectorDetectorType Type5_8 = 0
Public Const Type5_8 As FastFeatureDetectorDetectorType = 0
public:
literal FastFeatureDetectorDetectorType^ Type5_8 = 0
static val mutable Type5_8: FastFeatureDetectorDetectorType

Field Value

Type: FastFeatureDetectorDetectorType
See Also

Reference

FastFeatureDetectorDetectorType Class
Emgu.CV.Features2D Namespace


FastFeatureDetector.DetectorType.Type7_12 Field

FastFeatureDetectorDetectorTypeType7_12 Field

The type7_12

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FastFeatureDetectorDetectorType Type7_12 = 1
Public Const Type7_12 As FastFeatureDetectorDetectorType = 1
public:
literal FastFeatureDetectorDetectorType^ Type7_12 = 1
static val mutable Type7_12: FastFeatureDetectorDetectorType

Field Value

Type: FastFeatureDetectorDetectorType
See Also

Reference

FastFeatureDetectorDetectorType Class
Emgu.CV.Features2D Namespace


FastFeatureDetector.DetectorType.Type9_16 Field

FastFeatureDetectorDetectorTypeType9_16 Field

The type9_16

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FastFeatureDetectorDetectorType Type9_16 = 2
Public Const Type9_16 As FastFeatureDetectorDetectorType = 2
public:
literal FastFeatureDetectorDetectorType^ Type9_16 = 2
static val mutable Type9_16: FastFeatureDetectorDetectorType

Field Value

Type: FastFeatureDetectorDetectorType
See Also

Reference

FastFeatureDetectorDetectorType Class
Emgu.CV.Features2D Namespace


FastFeatureDetector.DetectorType.value__ Field

FastFeatureDetectorDetectorTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.FastFeatureDetector.DetectorType.value__"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FastFeatureDetectorDetectorType Class
Emgu.CV.Features2D Namespace


Feature2D Class

The feature 2D base class
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
More...

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class Feature2D : SharedPtrObject,
    IAlgorithm
Public MustInherit Class Feature2D
    Inherits SharedPtrObject
    Implements IAlgorithm
public ref class Feature2D abstract : public SharedPtrObject,
    IAlgorithm
[<AbstractClassAttribute>]
type Feature2D =
    class
        inherit SharedPtrObject
        interface IAlgorithm
    end

The Feature2D type exposes the following members.

Constructors
 | Name | Description
Protected method | Feature2D | Initializes a new instance of the Feature2D class
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor.
Public property | Feature2DPtr | Get the pointer to the Feature2D object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations.
Public method | Detect | Detect the keypoints from the image
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations.
Public method | DetectRaw | Detect the features in the image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointers (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object.
Protected field | _feature2D | The pointer to the Feature2D object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DAgastFeatureDetector
Emgu.CV.Features2DAKAZE
Emgu.CV.Features2DBrisk
Emgu.CV.Features2DFastFeatureDetector
Emgu.CV.Features2DGFTTDetector
Emgu.CV.Features2DKAZE
Emgu.CV.Features2DMSERDetector
Emgu.CV.Features2DORBDetector
Emgu.CV.Features2DSimpleBlobDetector
Emgu.CV.XFeatures2DBoostDesc
Emgu.CV.XFeatures2DBriefDescriptorExtractor
Emgu.CV.XFeatures2DDAISY
Emgu.CV.XFeatures2DFreak
Emgu.CV.XFeatures2DHarrisLaplaceFeatureDetector
Emgu.CV.XFeatures2DLATCH
Emgu.CV.XFeatures2DLUCID
Emgu.CV.XFeatures2DMSDDetector
Emgu.CV.XFeatures2DStarDetector
Emgu.CV.XFeatures2DVGG


Feature2D Constructor

Initializes a new instance of the Feature2D class

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Feature2D()
Protected Sub New
protected:
Feature2D()
new : unit -> Feature2D
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D Properties

The Feature2D type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor.
Public property | Feature2DPtr | Get the pointer to the Feature2D object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D.DescriptorSize Property

Feature2DDescriptorSize Property

Get the number of elements in the descriptor.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DescriptorSize { get; }
Public ReadOnly Property DescriptorSize As Integer
    Get
public:
property int DescriptorSize {
    int get ();
}
member DescriptorSize : int with get

Return Value

Type: Int32
The number of elements in the descriptor
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D.Feature2DPtr Property

Feature2DFeature2DPtr Property

Get the pointer to the Feature2D object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Feature2DPtr { get; }
Public ReadOnly Property Feature2DPtr As IntPtr
    Get
public:
property IntPtr Feature2DPtr {
    IntPtr get ();
}
member Feature2DPtr : IntPtr with get

Return Value

Type: IntPtr
The pointer to the Feature2D object
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D Methods

The Feature2D type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations.
Public method | Detect | Detect the keypoints from the image
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations.
Public method | DetectRaw | Detect the features in the image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointers (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D.Compute Method

Feature2DCompute Method

Compute the descriptors on the image from the given keypoint locations.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Compute(
    IInputArray image,
    VectorOfKeyPoint keyPoints,
    IOutputArray descriptors
)
Public Sub Compute (
    image As IInputArray,
    keyPoints As VectorOfKeyPoint,
    descriptors As IOutputArray
)
public:
void Compute(
    IInputArray^ image,
    VectorOfKeyPoint^ keyPoints,
    IOutputArray^ descriptors
)
member Compute :
        image : IInputArray *
        keyPoints : VectorOfKeyPoint *
        descriptors : IOutputArray -> unit

Parameters

image
Type: Emgu.CVIInputArray
The image to compute descriptors from
keyPoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints where the descriptor computation is perfromed
descriptors
Type: Emgu.CVIOutputArray
The descriptors from the given keypoints
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D.Detect Method

Feature2DDetect Method

Detect the keypoints from the image

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MKeyPoint[] Detect(
    IInputArray image,
    IInputArray mask = null
)
Public Function Detect (
    image As IInputArray,
    Optional mask As IInputArray = Nothing
) As MKeyPoint()
public:
array<MKeyPoint^>^ Detect(
    IInputArray^ image,
    IInputArray^ mask = nullptr
)
member Detect :
        image : IInputArray *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> MKeyPoint[]

Parameters

image
Type: Emgu.CVIInputArray
The image to extract keypoints from
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask.

Return Value

Type: MKeyPoint
An array of key points
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D.DetectAndCompute Method

Feature2DDetectAndCompute Method

Detect keypoints in an image and compute the descriptors on the image from the keypoint locations.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DetectAndCompute(
    IInputArray image,
    IInputArray mask,
    VectorOfKeyPoint keyPoints,
    IOutputArray descriptors,
    bool useProvidedKeyPoints
)
Public Sub DetectAndCompute (
    image As IInputArray,
    mask As IInputArray,
    keyPoints As VectorOfKeyPoint,
    descriptors As IOutputArray,
    useProvidedKeyPoints As Boolean
)
public:
void DetectAndCompute(
    IInputArray^ image,
    IInputArray^ mask,
    VectorOfKeyPoint^ keyPoints,
    IOutputArray^ descriptors,
    bool useProvidedKeyPoints
)
member DetectAndCompute :
        image : IInputArray *
        mask : IInputArray *
        keyPoints : VectorOfKeyPoint *
        descriptors : IOutputArray *
        useProvidedKeyPoints : bool -> unit

Parameters

image
Type: Emgu.CVIInputArray
The image
mask
Type: Emgu.CVIInputArray
The optional mask, can be null if not needed
keyPoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The detected keypoints will be stored in this vector
descriptors
Type: Emgu.CVIOutputArray
The descriptors from the keypoints
useProvidedKeyPoints
Type: SystemBoolean
If true, the method will skip the detection phase and will compute descriptors for the provided keypoints
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D.DetectRaw Method

Feature2DDetectRaw Method

Detect the features in the image

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DetectRaw(
    IInputArray image,
    VectorOfKeyPoint keypoints,
    IInputArray mask = null
)
Public Sub DetectRaw (
    image As IInputArray,
    keypoints As VectorOfKeyPoint,
    Optional mask As IInputArray = Nothing
)
public:
void DetectRaw(
    IInputArray^ image,
    VectorOfKeyPoint^ keypoints,
    IInputArray^ mask = nullptr
)
member DetectRaw :
        image : IInputArray *
        keypoints : VectorOfKeyPoint *
        ?mask : IInputArray
(* Defaults:
        let _mask = defaultArg mask null
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The image from which the features will be detected from
keypoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The result vector of keypoints
mask (Optional)
Type: Emgu.CVIInputArray
The optional mask.
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D.DisposeObject Method

Feature2DDisposeObject Method

Reset the pointers

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D Fields

The Feature2D type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object.
Protected field | _feature2D | The pointer to the Feature2D object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D._algorithm Field

Feature2D_algorithm Field

The pointer to the Algorithm object.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _algorithm
Protected _algorithm As IntPtr
protected:
IntPtr _algorithm
val mutable _algorithm: IntPtr

Field Value

Type: IntPtr
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Feature2D._feature2D Field

Feature2D_feature2D Field

The pointer to the Feature2D object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _feature2D
Protected _feature2D As IntPtr
protected:
IntPtr _feature2D
val mutable _feature2D: IntPtr

Field Value

Type: IntPtr
See Also

Reference

Feature2D Class
Emgu.CV.Features2D Namespace


Features2DInvoke Class

Library to invoke Features2D functions
Inheritance Hierarchy
SystemObject
Emgu.CV.Features2DFeatures2DInvoke

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class Features2DInvoke
Public NotInheritable Class Features2DInvoke
public ref class Features2DInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Features2DInvoke =  class end
See Also

Reference

Emgu.CV.Features2D Namespace


Features2DToolbox Class

Tools for features 2D
Inheritance Hierarchy
SystemObject
Emgu.CV.Features2DFeatures2DToolbox

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class Features2DToolbox
Public NotInheritable Class Features2DToolbox
public ref class Features2DToolbox abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Features2DToolbox =  class end

The Features2DToolbox type exposes the following members.

Methods
Name | Description
DrawKeypoints | Draw the keypoints found on the image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfByte, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observered image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, IInputArray, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observed image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfVectorOfByte, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observered image.
GetHomographyMatrixFromMatchedFeatures | Recover the homography matrix using RANDSAC. If the matrix cannot be recovered, null is returned.
VoteForSizeAndOrientation | Eliminate the matched features whose scale and rotation do not aggree with the majority's scale and rotation.
VoteForUniqueness | Filter the matched Features, such that if a match is not unique, it is rejected.
Top
See Also

Reference

Emgu.CV.Features2D Namespace


Features2DToolbox Methods

The Features2DToolbox type exposes the following members.

Methods
Name | Description
DrawKeypoints | Draw the keypoints found on the image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfByte, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observered image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, IInputArray, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observed image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfVectorOfByte, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observered image.
GetHomographyMatrixFromMatchedFeatures | Recover the homography matrix using RANDSAC. If the matrix cannot be recovered, null is returned.
VoteForSizeAndOrientation | Eliminate the matched features whose scale and rotation do not aggree with the majority's scale and rotation.
VoteForUniqueness | Filter the matched Features, such that if a match is not unique, it is rejected.
Top
See Also

Reference

Features2DToolbox Class
Emgu.CV.Features2D Namespace


Features2DToolbox.DrawKeypoints Method

Features2DToolboxDrawKeypoints Method

Draw the keypoints found on the image.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawKeypoints(
    IInputArray image,
    VectorOfKeyPoint keypoints,
    IInputOutputArray outImage,
    Bgr color,
    Features2DToolboxKeypointDrawType type = 0
)
Public Shared Sub DrawKeypoints (
    image As IInputArray,
    keypoints As VectorOfKeyPoint,
    outImage As IInputOutputArray,
    color As Bgr,
    Optional type As Features2DToolboxKeypointDrawType = 0
)
public:
static void DrawKeypoints(
    IInputArray^ image,
    VectorOfKeyPoint^ keypoints,
    IInputOutputArray^ outImage,
    Bgr^ color,
    Features2DToolboxKeypointDrawType^ type = 0
)
static member DrawKeypoints :
        image : IInputArray *
        keypoints : VectorOfKeyPoint *
        outImage : IInputOutputArray *
        color : Bgr *
        ?type : Features2DToolboxKeypointDrawType
(* Defaults:
        let _type = defaultArg type 0
*)
-> unit

Parameters

image
Type: Emgu.CVIInputArray
The image
keypoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints to be drawn
outImage
Type: Emgu.CVIInputOutputArray
The image with the keypoints drawn
color
Type: Emgu.CV.StructureBgr
The color used to draw the keypoints
type (Optional)
Type: Emgu.CV.Features2DFeatures2DToolboxKeypointDrawType
The drawing type
See Also

Reference

Features2DToolbox Class
Emgu.CV.Features2D Namespace


Features2DToolbox.DrawMatches Method

Features2DToolboxDrawMatches Method

Overload List
Name | Description
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfByte, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observered image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, IInputArray, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observed image.
DrawMatches(IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfVectorOfByte, Features2DToolboxKeypointDrawType) | Draw the matched keypoints between the model image and the observered image.
Top
See Also

Reference

Features2DToolbox Class
Emgu.CV.Features2D Namespace


Features2DToolbox.DrawMatches Method (IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfByte, Features2DToolbox.KeypointDrawType)

Features2DToolboxDrawMatches Method (IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfByte, Features2DToolboxKeypointDrawType)

http://www.emgu.com
Draw the matched keypoints between the model image and the observered image.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawMatches(
    IInputArray modelImage,
    VectorOfKeyPoint modelKeypoints,
    IInputArray observerdImage,
    VectorOfKeyPoint observedKeyPoints,
    VectorOfDMatch matches,
    IInputOutputArray result,
    MCvScalar matchColor,
    MCvScalar singlePointColor,
    VectorOfByte mask = null,
    Features2DToolboxKeypointDrawType flags = 0
)
Public Shared Sub DrawMatches (
    modelImage As IInputArray,
    modelKeypoints As VectorOfKeyPoint,
    observerdImage As IInputArray,
    observedKeyPoints As VectorOfKeyPoint,
    matches As VectorOfDMatch,
    result As IInputOutputArray,
    matchColor As MCvScalar,
    singlePointColor As MCvScalar,
    Optional mask As VectorOfByte = Nothing,
    Optional flags As Features2DToolboxKeypointDrawType = 0
)
public:
static void DrawMatches(
    IInputArray^ modelImage,
    VectorOfKeyPoint^ modelKeypoints,
    IInputArray^ observerdImage,
    VectorOfKeyPoint^ observedKeyPoints,
    VectorOfDMatch^ matches,
    IInputOutputArray^ result,
    MCvScalar^ matchColor,
    MCvScalar^ singlePointColor,
    VectorOfByte^ mask = nullptr,
    Features2DToolboxKeypointDrawType^ flags = 0
)
static member DrawMatches :
        modelImage : IInputArray *
        modelKeypoints : VectorOfKeyPoint *
        observerdImage : IInputArray *
        observedKeyPoints : VectorOfKeyPoint *
        matches : VectorOfDMatch *
        result : IInputOutputArray *
        matchColor : MCvScalar *
        singlePointColor : MCvScalar *
        ?mask : VectorOfByte *
        ?flags : Features2DToolboxKeypointDrawType
(* Defaults:
        let _mask = defaultArg mask null
        let _flags = defaultArg flags 0
*)
-> unit

Parameters

modelImage
Type: Emgu.CVIInputArray
The model image
modelKeypoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints in the model image
observerdImage
Type: Emgu.CVIInputArray
The observed image
observedKeyPoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints in the observed image
matches
Type: Emgu.CV.UtilVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
result
Type: Emgu.CVIInputOutputArray
The image where model and observed image is displayed side by side. Matches are drawn as indicated by the flag
matchColor
Type: Emgu.CV.StructureMCvScalar
The color for the match correspondence lines
singlePointColor
Type: Emgu.CV.StructureMCvScalar
The color for highlighting the keypoints
mask (Optional)
Type: Emgu.CV.UtilVectorOfByte
The mask for the matches. Use null for all matches.
flags (Optional)
Type: Emgu.CV.Features2DFeatures2DToolboxKeypointDrawType
The drawing type
See Also

Reference

Features2DToolbox Class
DrawMatches Overload
Emgu.CV.Features2D Namespace


Features2DToolbox.DrawMatches Method (IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, IInputArray, Features2DToolbox.KeypointDrawType)

Features2DToolboxDrawMatches Method (IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, IInputArray, Features2DToolboxKeypointDrawType)

http://www.emgu.com
Draw the matched keypoints between the model image and the observed image.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawMatches(
    IInputArray modelImage,
    VectorOfKeyPoint modelKeypoints,
    IInputArray observerdImage,
    VectorOfKeyPoint observedKeyPoints,
    VectorOfVectorOfDMatch matches,
    IInputOutputArray result,
    MCvScalar matchColor,
    MCvScalar singlePointColor,
    IInputArray mask = null,
    Features2DToolboxKeypointDrawType flags = 0
)
Public Shared Sub DrawMatches (
    modelImage As IInputArray,
    modelKeypoints As VectorOfKeyPoint,
    observerdImage As IInputArray,
    observedKeyPoints As VectorOfKeyPoint,
    matches As VectorOfVectorOfDMatch,
    result As IInputOutputArray,
    matchColor As MCvScalar,
    singlePointColor As MCvScalar,
    Optional mask As IInputArray = Nothing,
    Optional flags As Features2DToolboxKeypointDrawType = 0
)
public:
static void DrawMatches(
    IInputArray^ modelImage,
    VectorOfKeyPoint^ modelKeypoints,
    IInputArray^ observerdImage,
    VectorOfKeyPoint^ observedKeyPoints,
    VectorOfVectorOfDMatch^ matches,
    IInputOutputArray^ result,
    MCvScalar^ matchColor,
    MCvScalar^ singlePointColor,
    IInputArray^ mask = nullptr,
    Features2DToolboxKeypointDrawType^ flags = 0
)
static member DrawMatches :
        modelImage : IInputArray *
        modelKeypoints : VectorOfKeyPoint *
        observerdImage : IInputArray *
        observedKeyPoints : VectorOfKeyPoint *
        matches : VectorOfVectorOfDMatch *
        result : IInputOutputArray *
        matchColor : MCvScalar *
        singlePointColor : MCvScalar *
        ?mask : IInputArray *
        ?flags : Features2DToolboxKeypointDrawType
(* Defaults:
        let _mask = defaultArg mask null
        let _flags = defaultArg flags 0
*)
-> unit

Parameters

modelImage
Type: Emgu.CVIInputArray
The model image
modelKeypoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints in the model image
observerdImage
Type: Emgu.CVIInputArray
The observed image
observedKeyPoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints in the observed image
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
result
Type: Emgu.CVIInputOutputArray
The image where model and observed image is displayed side by side. Matches are drawn as indicated by the flag
matchColor
Type: Emgu.CV.StructureMCvScalar
The color for the match correspondence lines
singlePointColor
Type: Emgu.CV.StructureMCvScalar
The color for highlighting the keypoints
mask (Optional)
Type: Emgu.CVIInputArray
The mask for the matches. Use null for all matches.
flags (Optional)
Type: Emgu.CV.Features2DFeatures2DToolboxKeypointDrawType
The drawing type
See Also

Reference

Features2DToolbox Class
DrawMatches Overload
Emgu.CV.Features2D Namespace


Features2DToolbox.DrawMatches Method (IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfVectorOfByte, Features2DToolbox.KeypointDrawType)

Features2DToolboxDrawMatches Method (IInputArray, VectorOfKeyPoint, IInputArray, VectorOfKeyPoint, VectorOfVectorOfDMatch, IInputOutputArray, MCvScalar, MCvScalar, VectorOfVectorOfByte, Features2DToolboxKeypointDrawType)

http://www.emgu.com
Draw the matched keypoints between the model image and the observered image.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawMatches(
    IInputArray modelImage,
    VectorOfKeyPoint modelKeypoints,
    IInputArray observerdImage,
    VectorOfKeyPoint observedKeyPoints,
    VectorOfVectorOfDMatch matches,
    IInputOutputArray result,
    MCvScalar matchColor,
    MCvScalar singlePointColor,
    VectorOfVectorOfByte mask = null,
    Features2DToolboxKeypointDrawType flags = 0
)
Public Shared Sub DrawMatches (
    modelImage As IInputArray,
    modelKeypoints As VectorOfKeyPoint,
    observerdImage As IInputArray,
    observedKeyPoints As VectorOfKeyPoint,
    matches As VectorOfVectorOfDMatch,
    result As IInputOutputArray,
    matchColor As MCvScalar,
    singlePointColor As MCvScalar,
    Optional mask As VectorOfVectorOfByte = Nothing,
    Optional flags As Features2DToolboxKeypointDrawType = 0
)
public:
static void DrawMatches(
    IInputArray^ modelImage,
    VectorOfKeyPoint^ modelKeypoints,
    IInputArray^ observerdImage,
    VectorOfKeyPoint^ observedKeyPoints,
    VectorOfVectorOfDMatch^ matches,
    IInputOutputArray^ result,
    MCvScalar^ matchColor,
    MCvScalar^ singlePointColor,
    VectorOfVectorOfByte^ mask = nullptr,
    Features2DToolboxKeypointDrawType^ flags = 0
)
static member DrawMatches :
        modelImage : IInputArray *
        modelKeypoints : VectorOfKeyPoint *
        observerdImage : IInputArray *
        observedKeyPoints : VectorOfKeyPoint *
        matches : VectorOfVectorOfDMatch *
        result : IInputOutputArray *
        matchColor : MCvScalar *
        singlePointColor : MCvScalar *
        ?mask : VectorOfVectorOfByte *
        ?flags : Features2DToolboxKeypointDrawType
(* Defaults:
        let _mask = defaultArg mask null
        let _flags = defaultArg flags 0
*)
-> unit

Parameters

modelImage
Type: Emgu.CVIInputArray
The model image
modelKeypoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints in the model image
observerdImage
Type: Emgu.CVIInputArray
The observed image
observedKeyPoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints in the observed image
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
result
Type: Emgu.CVIInputOutputArray
The image where model and observed image is displayed side by side. Matches are drawn as indicated by the flag
matchColor
Type: Emgu.CV.StructureMCvScalar
The color for the match correspondence lines
singlePointColor
Type: Emgu.CV.StructureMCvScalar
The color for highlighting the keypoints
mask (Optional)
Type: Emgu.CV.UtilVectorOfVectorOfByte
The mask for the matches. Use null for all matches.
flags (Optional)
Type: Emgu.CV.Features2DFeatures2DToolboxKeypointDrawType
The drawing type
See Also

Reference

Features2DToolbox Class
DrawMatches Overload
Emgu.CV.Features2D Namespace


Features2DToolbox.GetHomographyMatrixFromMatchedFeatures Method

Features2DToolboxGetHomographyMatrixFromMatchedFeatures Method

http://www.emgu.com
Recover the homography matrix using RANDSAC. If the matrix cannot be recovered, null is returned.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Mat GetHomographyMatrixFromMatchedFeatures(
    VectorOfKeyPoint model,
    VectorOfKeyPoint observed,
    VectorOfVectorOfDMatch matches,
    Mat mask,
    double ransacReprojThreshold
)
Public Shared Function GetHomographyMatrixFromMatchedFeatures (
    model As VectorOfKeyPoint,
    observed As VectorOfKeyPoint,
    matches As VectorOfVectorOfDMatch,
    mask As Mat,
    ransacReprojThreshold As Double
) As Mat
public:
static Mat^ GetHomographyMatrixFromMatchedFeatures(
    VectorOfKeyPoint^ model,
    VectorOfKeyPoint^ observed,
    VectorOfVectorOfDMatch^ matches,
    Mat^ mask,
    double ransacReprojThreshold
)
static member GetHomographyMatrixFromMatchedFeatures :
        model : VectorOfKeyPoint *
        observed : VectorOfKeyPoint *
        matches : VectorOfVectorOfDMatch *
        mask : Mat *
        ransacReprojThreshold : float -> Mat

Parameters

model
Type: Emgu.CV.UtilVectorOfKeyPoint
The model keypoints
observed
Type: Emgu.CV.UtilVectorOfKeyPoint
The observed keypoints
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
mask
Type: Emgu.CVMat
The mask matrix of which the value might be modified by the function. As input, if the value is 0, the corresponding match will be ignored when computing the homography matrix. If the value is 1 and RANSAC determine the match is an outlier, the value will be set to 0.
ransacReprojThreshold
Type: SystemDouble
The maximum allowed reprojection error to treat a point pair as an inlier. If srcPoints and dstPoints are measured in pixels, it usually makes sense to set this parameter somewhere in the range 1 to 10.

Return Value

Type: Mat
The homography matrix, if it cannot be found, null is returned
See Also

Reference

Features2DToolbox Class
Emgu.CV.Features2D Namespace


Features2DToolbox.VoteForSizeAndOrientation Method

Features2DToolboxVoteForSizeAndOrientation Method

Eliminate the matched features whose scale and rotation do not aggree with the majority's scale and rotation.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int VoteForSizeAndOrientation(
    VectorOfKeyPoint modelKeyPoints,
    VectorOfKeyPoint observedKeyPoints,
    VectorOfVectorOfDMatch matches,
    Mat mask,
    double scaleIncrement,
    int rotationBins
)
Public Shared Function VoteForSizeAndOrientation (
    modelKeyPoints As VectorOfKeyPoint,
    observedKeyPoints As VectorOfKeyPoint,
    matches As VectorOfVectorOfDMatch,
    mask As Mat,
    scaleIncrement As Double,
    rotationBins As Integer
) As Integer
public:
static int VoteForSizeAndOrientation(
    VectorOfKeyPoint^ modelKeyPoints,
    VectorOfKeyPoint^ observedKeyPoints,
    VectorOfVectorOfDMatch^ matches,
    Mat^ mask,
    double scaleIncrement,
    int rotationBins
)
static member VoteForSizeAndOrientation :
        modelKeyPoints : VectorOfKeyPoint *
        observedKeyPoints : VectorOfKeyPoint *
        matches : VectorOfVectorOfDMatch *
        mask : Mat *
        scaleIncrement : float *
        rotationBins : int -> int

Parameters

modelKeyPoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints from the model image
observedKeyPoints
Type: Emgu.CV.UtilVectorOfKeyPoint
The keypoints from the observed image
matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
mask
Type: Emgu.CVMat
This is both input and output. This matrix indicates which row is valid for the matches.
scaleIncrement
Type: SystemDouble
This determines the different in scale for neighbor hood bins, a good value might be 1.5 (which means matched features in bin i+1 is scaled 1.5 times larger than matched features in bin i
rotationBins
Type: SystemInt32
The numbers of bins for rotation, a good value might be 20 (which means each bin covers 18 degree)

Return Value

Type: Int32
The number of non-zero elements in the resulting mask
See Also

Reference

Features2DToolbox Class
Emgu.CV.Features2D Namespace


Features2DToolbox.VoteForUniqueness Method

Features2DToolboxVoteForUniqueness Method

Filter the matched Features, such that if a match is not unique, it is rejected.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void VoteForUniqueness(
    VectorOfVectorOfDMatch matches,
    double uniquenessThreshold,
    Mat mask
)
Public Shared Sub VoteForUniqueness (
    matches As VectorOfVectorOfDMatch,
    uniquenessThreshold As Double,
    mask As Mat
)
public:
static void VoteForUniqueness(
    VectorOfVectorOfDMatch^ matches,
    double uniquenessThreshold,
    Mat^ mask
)
static member VoteForUniqueness :
        matches : VectorOfVectorOfDMatch *
        uniquenessThreshold : float *
        mask : Mat -> unit

Parameters

matches
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
Matches. Each matches[i] is k or less matches for the same query descriptor.
uniquenessThreshold
Type: SystemDouble
The distance different ratio which a match is consider unique, a good number will be 0.8
mask
Type: Emgu.CVMat
This is both input and output. This matrix indicates which row is valid for the matches.
See Also

Reference

Features2DToolbox Class
Emgu.CV.Features2D Namespace


Features2DToolbox.KeypointDrawType Class

Features2DToolboxKeypointDrawType Class

Define the Keypoint draw type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.Features2DFeatures2DToolboxKeypointDrawType

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class KeypointDrawType : Enum
Public NotInheritable Class KeypointDrawType
    Inherits Enum
public ref class KeypointDrawType sealed : public Enum
[<SealedAttribute>]
type KeypointDrawType =
    class
        inherit Enum
    end

The Features2DToolboxKeypointDrawType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Two source image, matches and single keypoints will be drawn. For each keypoint only the center point will be drawn (without the circle around keypoint with keypoint size and orientation).
 | DrawRichKeypoints | For each keypoint the circle around keypoint with keypoint size and orientation will be drawn.
 | NotDrawSinglePoints | Single keypoints will not be drawn.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Features2D Namespace


KeypointDrawType Methods

The Features2DToolboxKeypointDrawType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Features2DToolboxKeypointDrawType Class
Emgu.CV.Features2D Namespace


KeypointDrawType Fields

The Features2DToolboxKeypointDrawType type exposes the following members.

Fields
 | Name | Description
 | Default | Two source image, matches and single keypoints will be drawn. For each keypoint only the center point will be drawn (without the circle around keypoint with keypoint size and orientation).
 | DrawRichKeypoints | For each keypoint the circle around keypoint with keypoint size and orientation will be drawn.
 | NotDrawSinglePoints | Single keypoints will not be drawn.
Public field | value__ |
Top
See Also

Reference

Features2DToolboxKeypointDrawType Class
Emgu.CV.Features2D Namespace


Features2DToolbox.KeypointDrawType.Default Field

Features2DToolboxKeypointDrawTypeDefault Field

Two source image, matches and single keypoints will be drawn. For each keypoint only the center point will be drawn (without the circle around keypoint with keypoint size and orientation).

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Features2DToolboxKeypointDrawType Default = 0
Public Const Default As Features2DToolboxKeypointDrawType = 0
public:
literal Features2DToolboxKeypointDrawType^ Default = 0
static val mutable Default: Features2DToolboxKeypointDrawType

Field Value

Type: Features2DToolboxKeypointDrawType
See Also

Reference

Features2DToolboxKeypointDrawType Class
Emgu.CV.Features2D Namespace


Features2DToolbox.KeypointDrawType.DrawRichKeypoints Field

Features2DToolboxKeypointDrawTypeDrawRichKeypoints Field

For each keypoint the circle around keypoint with keypoint size and orientation will be drawn.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Features2DToolboxKeypointDrawType DrawRichKeypoints = 4
Public Const DrawRichKeypoints As Features2DToolboxKeypointDrawType = 4
public:
literal Features2DToolboxKeypointDrawType^ DrawRichKeypoints = 4
static val mutable DrawRichKeypoints: Features2DToolboxKeypointDrawType

Field Value

Type: Features2DToolboxKeypointDrawType
See Also

Reference

Features2DToolboxKeypointDrawType Class
Emgu.CV.Features2D Namespace


Features2DToolbox.KeypointDrawType.NotDrawSinglePoints Field

Features2DToolboxKeypointDrawTypeNotDrawSinglePoints Field

Single keypoints will not be drawn.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Features2DToolboxKeypointDrawType NotDrawSinglePoints = 2
Public Const NotDrawSinglePoints As Features2DToolboxKeypointDrawType = 2
public:
literal Features2DToolboxKeypointDrawType^ NotDrawSinglePoints = 2
static val mutable NotDrawSinglePoints: Features2DToolboxKeypointDrawType

Field Value

Type: Features2DToolboxKeypointDrawType
See Also

Reference

Features2DToolboxKeypointDrawType Class
Emgu.CV.Features2D Namespace


Features2DToolbox.KeypointDrawType.value__ Field

Features2DToolboxKeypointDrawTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.Features2DToolbox.KeypointDrawType.value__"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Features2DToolboxKeypointDrawType Class
Emgu.CV.Features2D Namespace


FlannBasedMatcher Class

This matcher trains flann::Index_ on a train descriptor collection and calls its nearest search methods to find the best matches. So, this matcher may be faster when matching a large train collection than the brute force matcher.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.Features2DDescriptorMatcher
Emgu.CV.Features2DFlannBasedMatcher

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FlannBasedMatcher : DescriptorMatcher
Public Class FlannBasedMatcher
    Inherits DescriptorMatcher
public ref class FlannBasedMatcher : public DescriptorMatcher
type FlannBasedMatcher =
    class
        inherit DescriptorMatcher
    end

The FlannBasedMatcher type exposes the following members.

Constructors
 | Name | Description
Public method | FlannBasedMatcher | Create a Flann based matcher.
Top
Properties
 | Name | Description
Public property | Empty | Returns true if there are no train descriptors in the both collections. (Inherited from DescriptorMatcher.)
Public property | IsMaskSupported | Returns true if the descriptor matcher supports masking permissible matches. (Inherited from DescriptorMatcher.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Add | Add the model descriptors (Inherited from DescriptorMatcher.)
Public method | Clear | Clears the train descriptor collections. (Inherited from DescriptorMatcher.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Flann based matcher. (Overrides DescriptorMatcherDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Finds the k best matches for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, VectorOfDMatch, IInputArrayOfArrays) | Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher (for example, the flann index). In all methods to match, the method train() is run every time before matching.Some descriptor matchers(for example, BruteForceMatcher) have an empty implementation of this method.Other matchers really train their inner structures (for example, FlannBasedMatcher trains flann::Index ). (Inherited from DescriptorMatcher.)
Top
Fields
 | Name | Description
Protected field | _descriptorMatcherPtr | The pointer to the Descriptor matcher (Inherited from DescriptorMatcher.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


FlannBasedMatcher Constructor

Create a Flann based matcher.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FlannBasedMatcher(
    IIndexParams indexParams,
    SearchParams search
)
Public Sub New (
    indexParams As IIndexParams,
    search As SearchParams
)
public:
FlannBasedMatcher(
    IIndexParams^ indexParams,
    SearchParams^ search
)
new :
        indexParams : IIndexParams *
        search : SearchParams -> FlannBasedMatcher

Parameters

indexParams
Type: Emgu.CV.FlannIIndexParams
The type of index parameters
search
Type: Emgu.CV.FlannSearchParams
The search parameters
See Also

Reference

FlannBasedMatcher Class
Emgu.CV.Features2D Namespace


FlannBasedMatcher Properties

The FlannBasedMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Empty | Returns true if there are no train descriptors in the both collections. (Inherited from DescriptorMatcher.)
Public property | IsMaskSupported | Returns true if the descriptor matcher supports masking permissible matches. (Inherited from DescriptorMatcher.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FlannBasedMatcher Class
Emgu.CV.Features2D Namespace


FlannBasedMatcher Methods

The FlannBasedMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add the model descriptors (Inherited from DescriptorMatcher.)
Public method | Clear | Clears the train descriptor collections. (Inherited from DescriptorMatcher.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Flann based matcher. (Overrides DescriptorMatcherDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnMatch(IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Find the k-nearest match (Inherited from DescriptorMatcher.)
Public method | KnnMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Int32, IInputArray, Boolean) | Finds the k best matches for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, VectorOfDMatch, IInputArrayOfArrays) | Finds the best match for each descriptor from a query set. Train descriptors collection that was set by the Add function is used. (Inherited from DescriptorMatcher.)
Public method | Match(IInputArray, IInputArray, VectorOfDMatch, IInputArray) | Finds the best match for each descriptor from a query set. (Inherited from DescriptorMatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusMatch(IInputArray, VectorOfVectorOfDMatch, Single, IInputArray, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Public method | RadiusMatch(IInputArray, IInputArray, VectorOfVectorOfDMatch, Single, IInputArrayOfArrays, Boolean) | For each query descriptor, finds the training descriptors not farther than the specified distance. (Inherited from DescriptorMatcher.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Trains a descriptor matcher (for example, the flann index). In all methods to match, the method train() is run every time before matching.Some descriptor matchers(for example, BruteForceMatcher) have an empty implementation of this method.Other matchers really train their inner structures (for example, FlannBasedMatcher trains flann::Index ). (Inherited from DescriptorMatcher.)
Top
See Also

Reference

FlannBasedMatcher Class
Emgu.CV.Features2D Namespace


FlannBasedMatcher.DisposeObject Method

FlannBasedMatcherDisposeObject Method

Release the unmanaged memory associated with this Flann based matcher.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FlannBasedMatcher Class
Emgu.CV.Features2D Namespace


FlannBasedMatcher Fields

The FlannBasedMatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _descriptorMatcherPtr | The pointer to the Descriptor matcher (Inherited from DescriptorMatcher.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FlannBasedMatcher Class
Emgu.CV.Features2D Namespace


GFTTDetector Class

Wrapping class for feature detection using the goodFeaturesToTrack() function.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DGFTTDetector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GFTTDetector : Feature2D
Public Class GFTTDetector
    Inherits Feature2D
public ref class GFTTDetector : public Feature2D
type GFTTDetector =
    class
        inherit Feature2D
    end

The GFTTDetector type exposes the following members.

Constructors
 | Name | Description
Public method | GFTTDetector | Create a Good Feature to Track detector
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


GFTTDetector Constructor

Create a Good Feature to Track detector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GFTTDetector(
    int maxCorners = 1000,
    double qualityLevel = 0.01,
    double minDistance = 1,
    int blockSize = 3,
    bool useHarrisDetector = false,
    double k = 0.04
)
Public Sub New (
    Optional maxCorners As Integer = 1000,
    Optional qualityLevel As Double = 0.01,
    Optional minDistance As Double = 1,
    Optional blockSize As Integer = 3,
    Optional useHarrisDetector As Boolean = false,
    Optional k As Double = 0.04
)
public:
GFTTDetector(
    int maxCorners = 1000,
    double qualityLevel = 0.01,
    double minDistance = 1,
    int blockSize = 3,
    bool useHarrisDetector = false,
    double k = 0.04
)
new :
        ?maxCorners : int *
        ?qualityLevel : float *
        ?minDistance : float *
        ?blockSize : int *
        ?useHarrisDetector : bool *
        ?k : float
(* Defaults:
        let _maxCorners = defaultArg maxCorners 1000
        let _qualityLevel = defaultArg qualityLevel 0.01
        let _minDistance = defaultArg minDistance 1
        let _blockSize = defaultArg blockSize 3
        let _useHarrisDetector = defaultArg useHarrisDetector false
        let _k = defaultArg k 0.04
*)
-> GFTTDetector

Parameters

maxCorners (Optional)
Type: SystemInt32
The maximum number of features to be detected.
qualityLevel (Optional)
Type: SystemDouble
Multiplier for the maxmin eigenvalue; specifies minimal accepted quality of image corners.
minDistance (Optional)
Type: SystemDouble
Limit, specifying minimum possible distance between returned corners; Euclidian distance is used.
blockSize (Optional)
Type: SystemInt32
Size of the averaging block, passed to underlying cvCornerMinEigenVal or cvCornerHarris used by the function.
useHarrisDetector (Optional)
Type: SystemBoolean
If true, will use Harris corner detector.
k (Optional)
Type: SystemDouble
K
Remarks
The function first calculates the minimal eigenvalue for every source image pixel using cvCornerMinEigenVal function and stores them in eig_image. Then it performs non-maxima suppression (only local maxima in 3x3 neighborhood remain). The next step is rejecting the corners with the minimal eigenvalue less than quality_level?max(eig_image(x,y)). Finally, the function ensures that all the corners found are distanced enough one from another by considering the corners (the most strongest corners are considered first) and checking that the distance between the newly considered feature and the features considered earlier is larger than min_distance. So, the function removes the features than are too close to the stronger features
See Also

Reference

GFTTDetector Class
Emgu.CV.Features2D Namespace


GFTTDetector Properties

The GFTTDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

GFTTDetector Class
Emgu.CV.Features2D Namespace


GFTTDetector Methods

The GFTTDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GFTTDetector Class
Emgu.CV.Features2D Namespace


GFTTDetector.DisposeObject Method

GFTTDetectorDisposeObject Method

Release the unmanaged memory associated with this detector.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

GFTTDetector Class
Emgu.CV.Features2D Namespace


GFTTDetector Fields

The GFTTDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

GFTTDetector Class
Emgu.CV.Features2D Namespace


KAZE Class

Wrapped KAZE detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DKAZE

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class KAZE : Feature2D
Public Class KAZE
    Inherits Feature2D
public ref class KAZE : public Feature2D
type KAZE =
    class
        inherit Feature2D
    end

The KAZE type exposes the following members.

Constructors
 | Name | Description
Public method | KAZE | Create KAZE using the specific values
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


KAZE Constructor

Create KAZE using the specific values

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public KAZE(
    bool extended = false,
    bool upright = false,
    float threshold = 0.001f,
    int octaves = 4,
    int sublevels = 4,
    KAZEDiffusivity diffusivity = 1
)
Public Sub New (
    Optional extended As Boolean = false,
    Optional upright As Boolean = false,
    Optional threshold As Single = 0.001F,
    Optional octaves As Integer = 4,
    Optional sublevels As Integer = 4,
    Optional diffusivity As KAZEDiffusivity = 1
)
public:
KAZE(
    bool extended = false,
    bool upright = false,
    float threshold = 0.001f,
    int octaves = 4,
    int sublevels = 4,
    KAZEDiffusivity^ diffusivity = 1
)
new :
        ?extended : bool *
        ?upright : bool *
        ?threshold : float32 *
        ?octaves : int *
        ?sublevels : int *
        ?diffusivity : KAZEDiffusivity
(* Defaults:
        let _extended = defaultArg extended false
        let _upright = defaultArg upright false
        let _threshold = defaultArg threshold 0.001f
        let _octaves = defaultArg octaves 4
        let _sublevels = defaultArg sublevels 4
        let _diffusivity = defaultArg diffusivity 1
*)
-> KAZE

Parameters

extended (Optional)
Type: SystemBoolean
Set to enable extraction of extended (128-byte) descriptor.
upright (Optional)
Type: SystemBoolean
Set to enable use of upright descriptors (non rotation-invariant).
threshold (Optional)
Type: SystemSingle
Detector response threshold to accept point
octaves (Optional)
Type: SystemInt32
Maximum octave evolution of the image
sublevels (Optional)
Type: SystemInt32
Default number of sublevels per scale level
diffusivity (Optional)
Type: Emgu.CV.Features2DKAZEDiffusivity
Diffusivity type.
See Also

Reference

KAZE Class
Emgu.CV.Features2D Namespace


KAZE Properties

The KAZE type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

KAZE Class
Emgu.CV.Features2D Namespace


KAZE Methods

The KAZE type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KAZE Class
Emgu.CV.Features2D Namespace


KAZE.DisposeObject Method

KAZEDisposeObject Method

Release the unmanaged resources associated with this object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

KAZE Class
Emgu.CV.Features2D Namespace


KAZE Fields

The KAZE type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

KAZE Class
Emgu.CV.Features2D Namespace


KAZE.Diffusivity Class

KAZEDiffusivity Class

The diffusivity
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.Features2DKAZEDiffusivity

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Diffusivity : Enum
Public NotInheritable Class Diffusivity
    Inherits Enum
public ref class Diffusivity sealed : public Enum
[<SealedAttribute>]
type Diffusivity =
    class
        inherit Enum
    end

The KAZEDiffusivity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Charbonnier | Charbonnier
 | PmG1 | PM G1
 | PmG2 | PM G2
Public field | value__ |
 | Weickert | Weickert
Top
See Also

Reference

Emgu.CV.Features2D Namespace


Diffusivity Methods

The KAZEDiffusivity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

KAZEDiffusivity Class
Emgu.CV.Features2D Namespace


Diffusivity Fields

The KAZEDiffusivity type exposes the following members.

Fields
 | Name | Description
 | Charbonnier | Charbonnier
 | PmG1 | PM G1
 | PmG2 | PM G2
Public field | value__ |
 | Weickert | Weickert
Top
See Also

Reference

KAZEDiffusivity Class
Emgu.CV.Features2D Namespace


KAZE.Diffusivity.Charbonnier Field

KAZEDiffusivityCharbonnier Field

Charbonnier

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KAZEDiffusivity Charbonnier = 3
Public Const Charbonnier As KAZEDiffusivity = 3
public:
literal KAZEDiffusivity^ Charbonnier = 3
static val mutable Charbonnier: KAZEDiffusivity

Field Value

Type: KAZEDiffusivity
See Also

Reference

KAZEDiffusivity Class
Emgu.CV.Features2D Namespace


KAZE.Diffusivity.PmG1 Field

KAZEDiffusivityPmG1 Field

PM G1

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KAZEDiffusivity PmG1 = 0
Public Const PmG1 As KAZEDiffusivity = 0
public:
literal KAZEDiffusivity^ PmG1 = 0
static val mutable PmG1: KAZEDiffusivity

Field Value

Type: KAZEDiffusivity
See Also

Reference

KAZEDiffusivity Class
Emgu.CV.Features2D Namespace


KAZE.Diffusivity.PmG2 Field

KAZEDiffusivityPmG2 Field

PM G2

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KAZEDiffusivity PmG2 = 1
Public Const PmG2 As KAZEDiffusivity = 1
public:
literal KAZEDiffusivity^ PmG2 = 1
static val mutable PmG2: KAZEDiffusivity

Field Value

Type: KAZEDiffusivity
See Also

Reference

KAZEDiffusivity Class
Emgu.CV.Features2D Namespace


KAZE.Diffusivity.value__ Field

KAZEDiffusivityvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.KAZE.Diffusivity.value__"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

KAZEDiffusivity Class
Emgu.CV.Features2D Namespace


KAZE.Diffusivity.Weickert Field

KAZEDiffusivityWeickert Field

Weickert

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KAZEDiffusivity Weickert = 2
Public Const Weickert As KAZEDiffusivity = 2
public:
literal KAZEDiffusivity^ Weickert = 2
static val mutable Weickert: KAZEDiffusivity

Field Value

Type: KAZEDiffusivity
See Also

Reference

KAZEDiffusivity Class
Emgu.CV.Features2D Namespace


MSERDetector Class

MSER detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DMSERDetector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MSERDetector : Feature2D
Public Class MSERDetector
    Inherits Feature2D
public ref class MSERDetector : public Feature2D
type MSERDetector =
    class
        inherit Feature2D
    end

The MSERDetector type exposes the following members.

Constructors
 | Name | Description
Public method | MSERDetector | Create a MSER detector using the specific parameters
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | DetectRegions | Detect MSER regions
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


MSERDetector Constructor

Create a MSER detector using the specific parameters

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MSERDetector(
    int delta = 5,
    int minArea = 60,
    int maxArea = 14400,
    double maxVariation = 0.25,
    double minDiversity = 0.2,
    int maxEvolution = 200,
    double areaThreshold = 1.01,
    double minMargin = 0.003,
    int edgeBlurSize = 5
)
Public Sub New (
    Optional delta As Integer = 5,
    Optional minArea As Integer = 60,
    Optional maxArea As Integer = 14400,
    Optional maxVariation As Double = 0.25,
    Optional minDiversity As Double = 0.2,
    Optional maxEvolution As Integer = 200,
    Optional areaThreshold As Double = 1.01,
    Optional minMargin As Double = 0.003,
    Optional edgeBlurSize As Integer = 5
)
public:
MSERDetector(
    int delta = 5,
    int minArea = 60,
    int maxArea = 14400,
    double maxVariation = 0.25,
    double minDiversity = 0.2,
    int maxEvolution = 200,
    double areaThreshold = 1.01,
    double minMargin = 0.003,
    int edgeBlurSize = 5
)
new :
        ?delta : int *
        ?minArea : int *
        ?maxArea : int *
        ?maxVariation : float *
        ?minDiversity : float *
        ?maxEvolution : int *
        ?areaThreshold : float *
        ?minMargin : float *
        ?edgeBlurSize : int
(* Defaults:
        let _delta = defaultArg delta 5
        let _minArea = defaultArg minArea 60
        let _maxArea = defaultArg maxArea 14400
        let _maxVariation = defaultArg maxVariation 0.25
        let _minDiversity = defaultArg minDiversity 0.2
        let _maxEvolution = defaultArg maxEvolution 200
        let _areaThreshold = defaultArg areaThreshold 1.01
        let _minMargin = defaultArg minMargin 0.003
        let _edgeBlurSize = defaultArg edgeBlurSize 5
*)
-> MSERDetector

Parameters

delta (Optional)
Type: SystemInt32
In the code, it compares (size_{i}-size_{i-delta})/size_{i-delta}
minArea (Optional)
Type: SystemInt32
Prune the area which smaller than min_area
maxArea (Optional)
Type: SystemInt32
Prune the area which bigger than max_area
maxVariation (Optional)
Type: SystemDouble
Prune the area have similar size to its children
minDiversity (Optional)
Type: SystemDouble
Trace back to cut off mser with diversity < min_diversity
maxEvolution (Optional)
Type: SystemInt32
For color image, the evolution steps
areaThreshold (Optional)
Type: SystemDouble
The area threshold to cause re-initialize
minMargin (Optional)
Type: SystemDouble
Ignore too small margin
edgeBlurSize (Optional)
Type: SystemInt32
The aperture size for edge blur
See Also

Reference

MSERDetector Class
Emgu.CV.Features2D Namespace


MSERDetector Properties

The MSERDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MSERDetector Class
Emgu.CV.Features2D Namespace


MSERDetector Methods

The MSERDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | DetectRegions | Detect MSER regions
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MSERDetector Class
Emgu.CV.Features2D Namespace


MSERDetector.DetectRegions Method

MSERDetectorDetectRegions Method

Detect MSER regions

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DetectRegions(
    IInputArray image,
    VectorOfVectorOfPoint msers,
    VectorOfRect bboxes
)
Public Sub DetectRegions (
    image As IInputArray,
    msers As VectorOfVectorOfPoint,
    bboxes As VectorOfRect
)
public:
void DetectRegions(
    IInputArray^ image,
    VectorOfVectorOfPoint^ msers,
    VectorOfRect^ bboxes
)
member DetectRegions :
        image : IInputArray *
        msers : VectorOfVectorOfPoint *
        bboxes : VectorOfRect -> unit

Parameters

image
Type: Emgu.CVIInputArray
input image (8UC1, 8UC3 or 8UC4, must be greater or equal than 3x3)
msers
Type: Emgu.CV.UtilVectorOfVectorOfPoint
resulting list of point sets
bboxes
Type: Emgu.CV.UtilVectorOfRect
resulting bounding boxes
See Also

Reference

MSERDetector Class
Emgu.CV.Features2D Namespace


MSERDetector.DisposeObject Method

MSERDetectorDisposeObject Method

Release the unmanaged memory associated with this detector.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MSERDetector Class
Emgu.CV.Features2D Namespace


MSERDetector Fields

The MSERDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MSERDetector Class
Emgu.CV.Features2D Namespace


ORBDetector Class

Wrapped ORB detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DORBDetector
Emgu.CV.CudaCudaORBDetector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ORBDetector : Feature2D
Public Class ORBDetector
    Inherits Feature2D
public ref class ORBDetector : public Feature2D
type ORBDetector =
    class
        inherit Feature2D
    end

The ORBDetector type exposes the following members.

Constructors
 | Name | Description
Public method | ORBDetector | Create a ORBDetector using the specific values
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


ORBDetector Constructor

Create a ORBDetector using the specific values

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ORBDetector(
    int numberOfFeatures = 500,
    float scaleFactor = 1.2f,
    int nLevels = 8,
    int edgeThreshold = 31,
    int firstLevel = 0,
    int WTK_A = 2,
    ORBDetectorScoreType scoreType = 0,
    int patchSize = 31,
    int fastThreshold = 20
)
Public Sub New (
    Optional numberOfFeatures As Integer = 500,
    Optional scaleFactor As Single = 1.2F,
    Optional nLevels As Integer = 8,
    Optional edgeThreshold As Integer = 31,
    Optional firstLevel As Integer = 0,
    Optional WTK_A As Integer = 2,
    Optional scoreType As ORBDetectorScoreType = 0,
    Optional patchSize As Integer = 31,
    Optional fastThreshold As Integer = 20
)
public:
ORBDetector(
    int numberOfFeatures = 500,
    float scaleFactor = 1.2f,
    int nLevels = 8,
    int edgeThreshold = 31,
    int firstLevel = 0,
    int WTK_A = 2,
    ORBDetectorScoreType^ scoreType = 0,
    int patchSize = 31,
    int fastThreshold = 20
)
new :
        ?numberOfFeatures : int *
        ?scaleFactor : float32 *
        ?nLevels : int *
        ?edgeThreshold : int *
        ?firstLevel : int *
        ?WTK_A : int *
        ?scoreType : ORBDetectorScoreType *
        ?patchSize : int *
        ?fastThreshold : int
(* Defaults:
        let _numberOfFeatures = defaultArg numberOfFeatures 500
        let _scaleFactor = defaultArg scaleFactor 1.2f
        let _nLevels = defaultArg nLevels 8
        let _edgeThreshold = defaultArg edgeThreshold 31
        let _firstLevel = defaultArg firstLevel 0
        let _WTK_A = defaultArg WTK_A 2
        let _scoreType = defaultArg scoreType 0
        let _patchSize = defaultArg patchSize 31
        let _fastThreshold = defaultArg fastThreshold 20
*)
-> ORBDetector

Parameters

numberOfFeatures (Optional)
Type: SystemInt32
The number of desired features.
scaleFactor (Optional)
Type: SystemSingle
Coefficient by which we divide the dimensions from one scale pyramid level to the next.
nLevels (Optional)
Type: SystemInt32
The number of levels in the scale pyramid.
edgeThreshold (Optional)
Type: SystemInt32
How far from the boundary the points should be.
firstLevel (Optional)
Type: SystemInt32
The level at which the image is given. If 1, that means we will also look at the image.scaleFactor times bigger
WTK_A (Optional)
Type: SystemInt32
How many random points are used to produce each cell of the descriptor (2, 3, 4 ...).
scoreType (Optional)
Type: Emgu.CV.Features2DORBDetectorScoreType
Type of the score to use.
patchSize (Optional)
Type: SystemInt32
Patch size.
fastThreshold (Optional)
Type: SystemInt32
FAST threshold
See Also

Reference

ORBDetector Class
Emgu.CV.Features2D Namespace


ORBDetector Properties

The ORBDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

ORBDetector Class
Emgu.CV.Features2D Namespace


ORBDetector Methods

The ORBDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this object (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ORBDetector Class
Emgu.CV.Features2D Namespace


ORBDetector.DisposeObject Method

ORBDetectorDisposeObject Method

Release the unmanaged resources associated with this object

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ORBDetector Class
Emgu.CV.Features2D Namespace


ORBDetector Fields

The ORBDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

ORBDetector Class
Emgu.CV.Features2D Namespace


ORBDetector.ScoreType Class

ORBDetectorScoreType Class

The score type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.Features2DORBDetectorScoreType

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ScoreType : Enum
Public NotInheritable Class ScoreType
    Inherits Enum
public ref class ScoreType sealed : public Enum
[<SealedAttribute>]
type ScoreType =
    class
        inherit Enum
    end

The ORBDetectorScoreType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Fast | Fast
 | Harris | Harris
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Features2D Namespace


ScoreType Methods

The ORBDetectorScoreType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ORBDetectorScoreType Class
Emgu.CV.Features2D Namespace


ScoreType Fields

The ORBDetectorScoreType type exposes the following members.

Fields
 | Name | Description
 | Fast | Fast
 | Harris | Harris
Public field | value__ |
Top
See Also

Reference

ORBDetectorScoreType Class
Emgu.CV.Features2D Namespace


ORBDetector.ScoreType.Fast Field

ORBDetectorScoreTypeFast Field

Fast

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ORBDetectorScoreType Fast = 1
Public Const Fast As ORBDetectorScoreType = 1
public:
literal ORBDetectorScoreType^ Fast = 1
static val mutable Fast: ORBDetectorScoreType

Field Value

Type: ORBDetectorScoreType
See Also

Reference

ORBDetectorScoreType Class
Emgu.CV.Features2D Namespace


ORBDetector.ScoreType.Harris Field

ORBDetectorScoreTypeHarris Field

Harris

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ORBDetectorScoreType Harris = 0
Public Const Harris As ORBDetectorScoreType = 0
public:
literal ORBDetectorScoreType^ Harris = 0
static val mutable Harris: ORBDetectorScoreType

Field Value

Type: ORBDetectorScoreType
See Also

Reference

ORBDetectorScoreType Class
Emgu.CV.Features2D Namespace


ORBDetector.ScoreType.value__ Field

ORBDetectorScoreTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Features2D.ORBDetector.ScoreType.value__"]

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ORBDetectorScoreType Class
Emgu.CV.Features2D Namespace


SimpleBlobDetector Class

Simple Blob detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.Features2DSimpleBlobDetector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SimpleBlobDetector : Feature2D
Public Class SimpleBlobDetector
    Inherits Feature2D
public ref class SimpleBlobDetector : public Feature2D
type SimpleBlobDetector =
    class
        inherit Feature2D
    end

The SimpleBlobDetector type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleBlobDetector | Create a simple blob detector
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


SimpleBlobDetector Constructor

Create a simple blob detector

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SimpleBlobDetector(
    SimpleBlobDetectorParams parameters = null
)
Public Sub New (
    Optional parameters As SimpleBlobDetectorParams = Nothing
)
public:
SimpleBlobDetector(
    SimpleBlobDetectorParams^ parameters = nullptr
)
new :
        ?parameters : SimpleBlobDetectorParams
(* Defaults:
        let _parameters = defaultArg parameters null
*)
-> SimpleBlobDetector

Parameters

parameters (Optional)
Type: Emgu.CV.Features2DSimpleBlobDetectorParams
The parameters for creating a simple blob detector
See Also

Reference

SimpleBlobDetector Class
Emgu.CV.Features2D Namespace


SimpleBlobDetector Properties

The SimpleBlobDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

SimpleBlobDetector Class
Emgu.CV.Features2D Namespace


SimpleBlobDetector Methods

The SimpleBlobDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimpleBlobDetector Class
Emgu.CV.Features2D Namespace


SimpleBlobDetector.DisposeObject Method

SimpleBlobDetectorDisposeObject Method

Release the unmanaged memory associated with this detector.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SimpleBlobDetector Class
Emgu.CV.Features2D Namespace


SimpleBlobDetector Fields

The SimpleBlobDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

SimpleBlobDetector Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams Class

Parameters for the simple blob detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.Features2DSimpleBlobDetectorParams

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SimpleBlobDetectorParams : UnmanagedObject
Public Class SimpleBlobDetectorParams
    Inherits UnmanagedObject
public ref class SimpleBlobDetectorParams : public UnmanagedObject
type SimpleBlobDetectorParams =
    class
        inherit UnmanagedObject
    end

The SimpleBlobDetectorParams type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleBlobDetectorParams | Create parameters for simple blob detector and use default values.
Top
Properties
 | Name | Description
Public property | blobColor | Blob color
Public property | FilterByArea | Filter by area
Public property | FilterByCircularity | Filter by circularity
Public property | FilterByColor | Filter by color
Public property | FilterByConvexity | Filter by convexity
Public property | FilterByInertia | Filter by inertia
Public property | MaxArea | Max area
Public property | MaxCircularity | Max circularity
Public property | MaxConvexity | Max Convexity
Public property | MaxInertiaRatio | Max inertia ratio
Public property | MaxThreshold | Max threshold
Public property | MinArea | Min area
Public property | MinCircularity | Min circularity
Public property | MinConvexity | Min Convexity
Public property | MinDistBetweenBlobs | Min dist between blobs
Public property | MinInertiaRatio | Min inertia ratio
Public property | MinRepeatability | Min Repeatability
Public property | MinThreshold | Min threshold
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ThresholdStep | Threshold step
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this simple blob detector parameter. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams Constructor

Create parameters for simple blob detector and use default values.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SimpleBlobDetectorParams()
Public Sub New
public:
SimpleBlobDetectorParams()
new : unit -> SimpleBlobDetectorParams
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams Properties

The SimpleBlobDetectorParams type exposes the following members.

Properties
 | Name | Description
Public property | blobColor | Blob color
Public property | FilterByArea | Filter by area
Public property | FilterByCircularity | Filter by circularity
Public property | FilterByColor | Filter by color
Public property | FilterByConvexity | Filter by convexity
Public property | FilterByInertia | Filter by inertia
Public property | MaxArea | Max area
Public property | MaxCircularity | Max circularity
Public property | MaxConvexity | Max Convexity
Public property | MaxInertiaRatio | Max inertia ratio
Public property | MaxThreshold | Max threshold
Public property | MinArea | Min area
Public property | MinCircularity | Min circularity
Public property | MinConvexity | Min Convexity
Public property | MinDistBetweenBlobs | Min dist between blobs
Public property | MinInertiaRatio | Min inertia ratio
Public property | MinRepeatability | Min Repeatability
Public property | MinThreshold | Min threshold
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ThresholdStep | Threshold step
Top
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.blobColor Property

SimpleBlobDetectorParamsblobColor Property

Blob color

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte blobColor { get; set; }
Public Property blobColor As Byte
    Get
    Set
public:
property unsigned char blobColor {
    unsigned char get ();
    void set (unsigned char value);
}
member blobColor : byte with get, set

Property Value

Type: Byte
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.FilterByArea Property

SimpleBlobDetectorParamsFilterByArea Property

Filter by area

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterByArea { get; set; }
Public Property FilterByArea As Boolean
    Get
    Set
public:
property bool FilterByArea {
    bool get ();
    void set (bool value);
}
member FilterByArea : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.FilterByCircularity Property

SimpleBlobDetectorParamsFilterByCircularity Property

Filter by circularity

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterByCircularity { get; set; }
Public Property FilterByCircularity As Boolean
    Get
    Set
public:
property bool FilterByCircularity {
    bool get ();
    void set (bool value);
}
member FilterByCircularity : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.FilterByColor Property

SimpleBlobDetectorParamsFilterByColor Property

Filter by color

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterByColor { get; set; }
Public Property FilterByColor As Boolean
    Get
    Set
public:
property bool FilterByColor {
    bool get ();
    void set (bool value);
}
member FilterByColor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.FilterByConvexity Property

SimpleBlobDetectorParamsFilterByConvexity Property

Filter by convexity

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterByConvexity { get; set; }
Public Property FilterByConvexity As Boolean
    Get
    Set
public:
property bool FilterByConvexity {
    bool get ();
    void set (bool value);
}
member FilterByConvexity : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.FilterByInertia Property

SimpleBlobDetectorParamsFilterByInertia Property

Filter by inertia

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterByInertia { get; set; }
Public Property FilterByInertia As Boolean
    Get
    Set
public:
property bool FilterByInertia {
    bool get ();
    void set (bool value);
}
member FilterByInertia : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MaxArea Property

SimpleBlobDetectorParamsMaxArea Property

Max area

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MaxArea { get; set; }
Public Property MaxArea As Single
    Get
    Set
public:
property float MaxArea {
    float get ();
    void set (float value);
}
member MaxArea : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MaxCircularity Property

SimpleBlobDetectorParamsMaxCircularity Property

Max circularity

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MaxCircularity { get; set; }
Public Property MaxCircularity As Single
    Get
    Set
public:
property float MaxCircularity {
    float get ();
    void set (float value);
}
member MaxCircularity : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MaxConvexity Property

SimpleBlobDetectorParamsMaxConvexity Property

Max Convexity

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MaxConvexity { get; set; }
Public Property MaxConvexity As Single
    Get
    Set
public:
property float MaxConvexity {
    float get ();
    void set (float value);
}
member MaxConvexity : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MaxInertiaRatio Property

SimpleBlobDetectorParamsMaxInertiaRatio Property

Max inertia ratio

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MaxInertiaRatio { get; set; }
Public Property MaxInertiaRatio As Single
    Get
    Set
public:
property float MaxInertiaRatio {
    float get ();
    void set (float value);
}
member MaxInertiaRatio : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MaxThreshold Property

SimpleBlobDetectorParamsMaxThreshold Property

Max threshold

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MaxThreshold { get; set; }
Public Property MaxThreshold As Single
    Get
    Set
public:
property float MaxThreshold {
    float get ();
    void set (float value);
}
member MaxThreshold : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MinArea Property

SimpleBlobDetectorParamsMinArea Property

Min area

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MinArea { get; set; }
Public Property MinArea As Single
    Get
    Set
public:
property float MinArea {
    float get ();
    void set (float value);
}
member MinArea : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MinCircularity Property

SimpleBlobDetectorParamsMinCircularity Property

Min circularity

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MinCircularity { get; set; }
Public Property MinCircularity As Single
    Get
    Set
public:
property float MinCircularity {
    float get ();
    void set (float value);
}
member MinCircularity : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MinConvexity Property

SimpleBlobDetectorParamsMinConvexity Property

Min Convexity

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MinConvexity { get; set; }
Public Property MinConvexity As Single
    Get
    Set
public:
property float MinConvexity {
    float get ();
    void set (float value);
}
member MinConvexity : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MinDistBetweenBlobs Property

SimpleBlobDetectorParamsMinDistBetweenBlobs Property

Min dist between blobs

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MinDistBetweenBlobs { get; set; }
Public Property MinDistBetweenBlobs As Single
    Get
    Set
public:
property float MinDistBetweenBlobs {
    float get ();
    void set (float value);
}
member MinDistBetweenBlobs : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MinInertiaRatio Property

SimpleBlobDetectorParamsMinInertiaRatio Property

Min inertia ratio

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MinInertiaRatio { get; set; }
Public Property MinInertiaRatio As Single
    Get
    Set
public:
property float MinInertiaRatio {
    float get ();
    void set (float value);
}
member MinInertiaRatio : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MinRepeatability Property

SimpleBlobDetectorParamsMinRepeatability Property

Min Repeatability

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr MinRepeatability { get; set; }
Public Property MinRepeatability As IntPtr
    Get
    Set
public:
property IntPtr MinRepeatability {
    IntPtr get ();
    void set (IntPtr value);
}
member MinRepeatability : IntPtr with get, set

Property Value

Type: IntPtr
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.MinThreshold Property

SimpleBlobDetectorParamsMinThreshold Property

Min threshold

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MinThreshold { get; set; }
Public Property MinThreshold As Single
    Get
    Set
public:
property float MinThreshold {
    float get ();
    void set (float value);
}
member MinThreshold : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.ThresholdStep Property

SimpleBlobDetectorParamsThresholdStep Property

Threshold step

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ThresholdStep { get; set; }
Public Property ThresholdStep As Single
    Get
    Set
public:
property float ThresholdStep {
    float get ();
    void set (float value);
}
member ThresholdStep : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams Methods

The SimpleBlobDetectorParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this simple blob detector parameter. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams.DisposeObject Method

SimpleBlobDetectorParamsDisposeObject Method

Release all the unmanaged memory associated with this simple blob detector parameter.

Namespace: Emgu.CV.Features2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


SimpleBlobDetectorParams Fields

The SimpleBlobDetectorParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SimpleBlobDetectorParams Class
Emgu.CV.Features2D Namespace


Emgu.CV.Flann Namespace

Fast Library for Approximate Nearest Neighbors (Marius Muja and David Lowe)
Classes
 | Class | Description
Public class | AutotunedIndexParams | When passing an object of this type the index created is automatically tuned to offer the best performance, by choosing the optimal index type (randomized kd-trees, hierarchical kmeans, linear) and parameters for the dataset provided.
Public class | CenterInitType | The Kmeans center initiation types
Public class | CompositeIndexParams | When using a parameters object of this type the index created combines the randomized kd-trees and the hierarchical k-means tree.
Public class | DistType | Distance Type
Public class | HierarchicalClusteringIndexParams | Hierarchical Clustering Index Parameters
Public class | Index | Flann index
Public class | Index3D | Create index for 3D points
Public class | Index3DNeighbor | A neighbor point
Public class | KdTreeIndexParams | When passing an object of this type the index constructed will consist of a set of randomized kd-trees which will be searched in parallel.
Public class | KMeansIndexParams | When passing an object of this type the index constructed will be a hierarchical k-means tree.
Public class | LinearIndexParams | When passing an object of this type, the index will perform a linear, brute-force search.
Public class | LshIndexParams | When using a parameters object of this type the index created uses multi-probe LSH (by Multi-Probe LSH: Efficient Indexing for High-Dimensional Similarity Search by Qin Lv, William Josephson, Zhe Wang, Moses Charikar, Kai Li., Proceedings of the 33rd International Conference on Very Large Data Bases (VLDB). Vienna, Austria. September 2007)
Public class | SearchParams | Search parameters
Interfaces
 | Interface | Description
Public interface | IIndexParams | The index parameters interface


AutotunedIndexParams Class

When passing an object of this type the index created is automatically tuned to offer the best performance, by choosing the optimal index type (randomized kd-trees, hierarchical kmeans, linear) and parameters for the dataset provided.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannAutotunedIndexParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class AutotunedIndexParams : UnmanagedObject,
    IIndexParams
Public Class AutotunedIndexParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class AutotunedIndexParams : public UnmanagedObject,
    IIndexParams
type AutotunedIndexParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The AutotunedIndexParams type exposes the following members.

Constructors
 | Name | Description
Public method | AutotunedIndexParams | Initializes a new instance of the AutotunedIndexParams class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


AutotunedIndexParams Constructor

Initializes a new instance of the AutotunedIndexParams class.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public AutotunedIndexParams(
    float targetPrecision = 0.8f,
    float buildWeight = 0.01f,
    float memoryWeight = 0f,
    float sampleFraction = 0.1f
)
Public Sub New (
    Optional targetPrecision As Single = 0.8F,
    Optional buildWeight As Single = 0.01F,
    Optional memoryWeight As Single = 0F,
    Optional sampleFraction As Single = 0.1F
)
public:
AutotunedIndexParams(
    float targetPrecision = 0.8f,
    float buildWeight = 0.01f,
    float memoryWeight = 0f,
    float sampleFraction = 0.1f
)
new :
        ?targetPrecision : float32 *
        ?buildWeight : float32 *
        ?memoryWeight : float32 *
        ?sampleFraction : float32
(* Defaults:
        let _targetPrecision = defaultArg targetPrecision 0.8f
        let _buildWeight = defaultArg buildWeight 0.01f
        let _memoryWeight = defaultArg memoryWeight 0f
        let _sampleFraction = defaultArg sampleFraction 0.1f
*)
-> AutotunedIndexParams

Parameters

targetPrecision (Optional)
Type: SystemSingle
Is a number between 0 and 1 specifying the percentage of the approximate nearest-neighbor searches that return the exact nearest-neighbor. Using a higher value for this parameter gives more accurate results, but the search takes longer. The optimum value usually depends on the application.
buildWeight (Optional)
Type: SystemSingle
Specifies the importance of the index build time reported to the nearest-neighbor search time. In some applications it’s acceptable for the index build step to take a long time if the subsequent searches in the index can be performed very fast. In other applications it’s required that the index be build as fast as possible even if that leads to slightly longer search times.
memoryWeight (Optional)
Type: SystemSingle
Is used to specify the trade off between time (index build time and search time) and memory used by the index. A value less than 1 gives more importance to the time spent and a value greater than 1 gives more importance to the memory usage.
sampleFraction (Optional)
Type: SystemSingle
Is a number between 0 and 1 indicating what fraction of the dataset to use in the automatic parameter configuration algorithm. Running the algorithm on the full dataset gives the most accurate results, but for very large datasets can take longer than desired. In such case using just a fraction of the data helps speeding up this algorithm while still giving good approximations of the optimum parameters.
See Also

Reference

AutotunedIndexParams Class
Emgu.CV.Flann Namespace


AutotunedIndexParams Properties

The AutotunedIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AutotunedIndexParams Class
Emgu.CV.Flann Namespace


AutotunedIndexParams Methods

The AutotunedIndexParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutotunedIndexParams Class
Emgu.CV.Flann Namespace


AutotunedIndexParams.DisposeObject Method

AutotunedIndexParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

AutotunedIndexParams Class
Emgu.CV.Flann Namespace


AutotunedIndexParams Fields

The AutotunedIndexParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AutotunedIndexParams Class
Emgu.CV.Flann Namespace


CenterInitType Class

The Kmeans center initiation types
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.FlannCenterInitType

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CenterInitType : Enum
Public NotInheritable Class CenterInitType
    Inherits Enum
public ref class CenterInitType sealed : public Enum
[<SealedAttribute>]
type CenterInitType =
    class
        inherit Enum
    end

The CenterInitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Gonzales |
 | Kmeanspp |
 | Random | Random
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Flann Namespace


CenterInitType Methods

The CenterInitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

CenterInitType Class
Emgu.CV.Flann Namespace


CenterInitType Fields

The CenterInitType type exposes the following members.

Fields
 | Name | Description
 | Gonzales |
 | Kmeanspp |
 | Random | Random
Public field | value__ |
Top
See Also

Reference

CenterInitType Class
Emgu.CV.Flann Namespace


CenterInitType.Gonzales Field

CenterInitTypeGonzales Field

[Missing <summary> documentation for "F:Emgu.CV.Flann.CenterInitType.Gonzales"]

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CenterInitType Gonzales = 1
Public Const Gonzales As CenterInitType = 1
public:
literal CenterInitType^ Gonzales = 1
static val mutable Gonzales: CenterInitType

Field Value

Type: CenterInitType
See Also

Reference

CenterInitType Class
Emgu.CV.Flann Namespace


CenterInitType.Kmeanspp Field

CenterInitTypeKmeanspp Field

[Missing <summary> documentation for "F:Emgu.CV.Flann.CenterInitType.Kmeanspp"]

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CenterInitType Kmeanspp = 2
Public Const Kmeanspp As CenterInitType = 2
public:
literal CenterInitType^ Kmeanspp = 2
static val mutable Kmeanspp: CenterInitType

Field Value

Type: CenterInitType
See Also

Reference

CenterInitType Class
Emgu.CV.Flann Namespace


CenterInitType.Random Field

CenterInitTypeRandom Field

Random

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const CenterInitType Random = 0
Public Const Random As CenterInitType = 0
public:
literal CenterInitType^ Random = 0
static val mutable Random: CenterInitType

Field Value

Type: CenterInitType
See Also

Reference

CenterInitType Class
Emgu.CV.Flann Namespace


CenterInitType.value__ Field

CenterInitTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Flann.CenterInitType.value__"]

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

CenterInitType Class
Emgu.CV.Flann Namespace


CompositeIndexParams Class

When using a parameters object of this type the index created combines the randomized kd-trees and the hierarchical k-means tree.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannCompositeIndexParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CompositeIndexParams : UnmanagedObject,
    IIndexParams
Public Class CompositeIndexParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class CompositeIndexParams : public UnmanagedObject,
    IIndexParams
type CompositeIndexParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The CompositeIndexParams type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeIndexParams | Initializes a new instance of the CompositeIndexParams class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


CompositeIndexParams Constructor

Initializes a new instance of the CompositeIndexParams class.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CompositeIndexParams(
    int trees = 4,
    int branching = 32,
    int iterations = 11,
    CenterInitType centersInit = 0,
    float cbIndex = 0.2f
)
Public Sub New (
    Optional trees As Integer = 4,
    Optional branching As Integer = 32,
    Optional iterations As Integer = 11,
    Optional centersInit As CenterInitType = 0,
    Optional cbIndex As Single = 0.2F
)
public:
CompositeIndexParams(
    int trees = 4,
    int branching = 32,
    int iterations = 11,
    CenterInitType^ centersInit = 0,
    float cbIndex = 0.2f
)
new :
        ?trees : int *
        ?branching : int *
        ?iterations : int *
        ?centersInit : CenterInitType *
        ?cbIndex : float32
(* Defaults:
        let _trees = defaultArg trees 4
        let _branching = defaultArg branching 32
        let _iterations = defaultArg iterations 11
        let _centersInit = defaultArg centersInit 0
        let _cbIndex = defaultArg cbIndex 0.2f
*)
-> CompositeIndexParams

Parameters

trees (Optional)
Type: SystemInt32
The number of parallel kd-trees to use. Good values are in the range [1..16]
branching (Optional)
Type: SystemInt32
The branching factor to use for the hierarchical k-means tree
iterations (Optional)
Type: SystemInt32
The maximum number of iterations to use in the k-means clustering stage when building the k-means tree. A value of -1 used here means that the k-means clustering should be iterated until convergence
centersInit (Optional)
Type: Emgu.CV.FlannCenterInitType
The algorithm to use for selecting the initial centers when performing a k-means clustering step. The possible values are CENTERS_RANDOM (picks the initial cluster centers randomly), CENTERS_GONZALES (picks the initial centers using Gonzales’ algorithm) and CENTERS_KMEANSPP (picks the initial centers using the algorithm suggested in arthur_kmeanspp_2007 )
cbIndex (Optional)
Type: SystemSingle
This parameter (cluster boundary index) influences the way exploration is performed in the hierarchical kmeans tree. When cb_index is zero the next kmeans domain to be explored is chosen to be the one with the closest center. A value greater then zero also takes into account the size of the domain.
See Also

Reference

CompositeIndexParams Class
Emgu.CV.Flann Namespace


CompositeIndexParams Properties

The CompositeIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CompositeIndexParams Class
Emgu.CV.Flann Namespace


CompositeIndexParams Methods

The CompositeIndexParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeIndexParams Class
Emgu.CV.Flann Namespace


CompositeIndexParams.DisposeObject Method

CompositeIndexParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CompositeIndexParams Class
Emgu.CV.Flann Namespace


CompositeIndexParams Fields

The CompositeIndexParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CompositeIndexParams Class
Emgu.CV.Flann Namespace


DistType Class

Distance Type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.FlannDistType

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DistType : Enum
Public NotInheritable Class DistType
    Inherits Enum
public ref class DistType sealed : public Enum
[<SealedAttribute>]
type DistType =
    class
        inherit Enum
    end

The DistType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ChiSquare | ChiSquare
 | CS | CS
 | Euclidean | Euclidean
 | Hamming | Hamming
 | Hellinger | Hellinger
 | HistIntersect | HistIntersect
 | KL | KL
 | KullbackLeibler | KullbackLeibler
 | L1 | L1
 | L2 | L2
 | Manhattan | Manhattan
 | Max | Max
 | Minkowski | Minkowski
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Flann Namespace


DistType Methods

The DistType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType Fields

The DistType type exposes the following members.

Fields
 | Name | Description
 | ChiSquare | ChiSquare
 | CS | CS
 | Euclidean | Euclidean
 | Hamming | Hamming
 | Hellinger | Hellinger
 | HistIntersect | HistIntersect
 | KL | KL
 | KullbackLeibler | KullbackLeibler
 | L1 | L1
 | L2 | L2
 | Manhattan | Manhattan
 | Max | Max
 | Minkowski | Minkowski
Public field | value__ |
Top
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.ChiSquare Field

DistTypeChiSquare Field

ChiSquare

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType ChiSquare = 7
Public Const ChiSquare As DistType = 7
public:
literal DistType^ ChiSquare = 7
static val mutable ChiSquare: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.CS Field

DistTypeCS Field

CS

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType CS = 7
Public Const CS As DistType = 7
public:
literal DistType^ CS = 7
static val mutable CS: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.Euclidean Field

DistTypeEuclidean Field

Euclidean

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Euclidean = 1
Public Const Euclidean As DistType = 1
public:
literal DistType^ Euclidean = 1
static val mutable Euclidean: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.Hamming Field

DistTypeHamming Field

Hamming

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Hamming = 9
Public Const Hamming As DistType = 9
public:
literal DistType^ Hamming = 9
static val mutable Hamming: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.Hellinger Field

DistTypeHellinger Field

Hellinger

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Hellinger = 6
Public Const Hellinger As DistType = 6
public:
literal DistType^ Hellinger = 6
static val mutable Hellinger: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.HistIntersect Field

DistTypeHistIntersect Field

HistIntersect

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType HistIntersect = 5
Public Const HistIntersect As DistType = 5
public:
literal DistType^ HistIntersect = 5
static val mutable HistIntersect: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.KL Field

DistTypeKL Field

KL

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType KL = 8
Public Const KL As DistType = 8
public:
literal DistType^ KL = 8
static val mutable KL: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.KullbackLeibler Field

DistTypeKullbackLeibler Field

KullbackLeibler

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType KullbackLeibler = 8
Public Const KullbackLeibler As DistType = 8
public:
literal DistType^ KullbackLeibler = 8
static val mutable KullbackLeibler: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.L1 Field

DistTypeL1 Field

L1

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType L1 = 2
Public Const L1 As DistType = 2
public:
literal DistType^ L1 = 2
static val mutable L1: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.L2 Field

DistTypeL2 Field

L2

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType L2 = 1
Public Const L2 As DistType = 1
public:
literal DistType^ L2 = 1
static val mutable L2: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.Manhattan Field

DistTypeManhattan Field

Manhattan

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Manhattan = 2
Public Const Manhattan As DistType = 2
public:
literal DistType^ Manhattan = 2
static val mutable Manhattan: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.Max Field

DistTypeMax Field

Max

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Max = 4
Public Const Max As DistType = 4
public:
literal DistType^ Max = 4
static val mutable Max: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.Minkowski Field

DistTypeMinkowski Field

Minkowski

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DistType Minkowski = 3
Public Const Minkowski As DistType = 3
public:
literal DistType^ Minkowski = 3
static val mutable Minkowski: DistType

Field Value

Type: DistType
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


DistType.value__ Field

DistTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Flann.DistType.value__"]

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DistType Class
Emgu.CV.Flann Namespace


HierarchicalClusteringIndexParams Class

Hierarchical Clustering Index Parameters
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannHierarchicalClusteringIndexParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class HierarchicalClusteringIndexParams : UnmanagedObject,
    IIndexParams
Public Class HierarchicalClusteringIndexParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class HierarchicalClusteringIndexParams : public UnmanagedObject,
    IIndexParams
type HierarchicalClusteringIndexParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The HierarchicalClusteringIndexParams type exposes the following members.

Constructors
 | Name | Description
Public method | HierarchicalClusteringIndexParams | Initializes a new instance of the HierarchicalClusteringIndexParams.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


HierarchicalClusteringIndexParams Constructor

Initializes a new instance of the HierarchicalClusteringIndexParams.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public HierarchicalClusteringIndexParams(
    int branching = 32,
    CenterInitType centersInit = 0,
    int trees = 4,
    int leafSize = 100
)
Public Sub New (
    Optional branching As Integer = 32,
    Optional centersInit As CenterInitType = 0,
    Optional trees As Integer = 4,
    Optional leafSize As Integer = 100
)
public:
HierarchicalClusteringIndexParams(
    int branching = 32,
    CenterInitType^ centersInit = 0,
    int trees = 4,
    int leafSize = 100
)
new :
        ?branching : int *
        ?centersInit : CenterInitType *
        ?trees : int *
        ?leafSize : int
(* Defaults:
        let _branching = defaultArg branching 32
        let _centersInit = defaultArg centersInit 0
        let _trees = defaultArg trees 4
        let _leafSize = defaultArg leafSize 100
*)
-> HierarchicalClusteringIndexParams

Parameters

branching (Optional)
Type: SystemInt32
branching
centersInit (Optional)
Type: Emgu.CV.FlannCenterInitType
Center initialization method
trees (Optional)
Type: SystemInt32
Trees
leafSize (Optional)
Type: SystemInt32
Leaf Size
See Also

Reference

HierarchicalClusteringIndexParams Class
Emgu.CV.Flann Namespace


HierarchicalClusteringIndexParams Properties

The HierarchicalClusteringIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HierarchicalClusteringIndexParams Class
Emgu.CV.Flann Namespace


HierarchicalClusteringIndexParams Methods

The HierarchicalClusteringIndexParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HierarchicalClusteringIndexParams Class
Emgu.CV.Flann Namespace


HierarchicalClusteringIndexParams.DisposeObject Method

HierarchicalClusteringIndexParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

HierarchicalClusteringIndexParams Class
Emgu.CV.Flann Namespace


HierarchicalClusteringIndexParams Fields

The HierarchicalClusteringIndexParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HierarchicalClusteringIndexParams Class
Emgu.CV.Flann Namespace


IIndexParams Interface

The index parameters interface

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IIndexParams
Public Interface IIndexParams
public interface class IIndexParams
type IIndexParams =  interface end

The IIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | IndexParamPtr | Gets the pointer to the index parameter.
Top
See Also

Reference

Emgu.CV.Flann Namespace


IIndexParams Properties

The IIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | IndexParamPtr | Gets the pointer to the index parameter.
Top
See Also

Reference

IIndexParams Interface
Emgu.CV.Flann Namespace


IIndexParams.IndexParamPtr Property

IIndexParamsIndexParamPtr Property

Gets the pointer to the index parameter.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr IndexParamPtr { get; }
ReadOnly Property IndexParamPtr As IntPtr
    Get
property IntPtr IndexParamPtr {
    IntPtr get ();
}
abstract IndexParamPtr : IntPtr with get

Property Value

Type: IntPtr
The index parameter pointer.
See Also

Reference

IIndexParams Interface
Emgu.CV.Flann Namespace


Index Class

Flann index
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannIndex

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Index : UnmanagedObject
Public Class Index
    Inherits UnmanagedObject
public ref class Index : public UnmanagedObject
type Index =
    class
        inherit UnmanagedObject
    end

The Index type exposes the following members.

Constructors
 | Name | Description
Public method | Index | Create a flann index
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Flann Index (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnSearch | Perform k-nearest-neighbours (KNN) search
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusSearch | Performs a radius nearest neighbor search for multiple query points
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


Index Constructor

Create a flann index

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Index(
    IInputArray values,
    IIndexParams ip,
    DistType distType = 1
)
Public Sub New (
    values As IInputArray,
    ip As IIndexParams,
    Optional distType As DistType = 1
)
public:
Index(
    IInputArray^ values,
    IIndexParams^ ip,
    DistType^ distType = 1
)
new :
        values : IInputArray *
        ip : IIndexParams *
        ?distType : DistType
(* Defaults:
        let _distType = defaultArg distType 1
*)
-> Index

Parameters

values
Type: Emgu.CVIInputArray
A row by row matrix of descriptors
ip
Type: Emgu.CV.FlannIIndexParams
The index parameter
distType (Optional)
Type: Emgu.CV.FlannDistType
The distance type
See Also

Reference

Index Class
Emgu.CV.Flann Namespace


Index Properties

The Index type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Index Class
Emgu.CV.Flann Namespace


Index Methods

The Index type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Flann Index (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KnnSearch | Perform k-nearest-neighbours (KNN) search
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RadiusSearch | Performs a radius nearest neighbor search for multiple query points
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Index Class
Emgu.CV.Flann Namespace


Index.DisposeObject Method

IndexDisposeObject Method

Release the unmanaged memory associated with this Flann Index

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Index Class
Emgu.CV.Flann Namespace


Index.KnnSearch Method

IndexKnnSearch Method

Perform k-nearest-neighbours (KNN) search

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void KnnSearch(
    IInputArray queries,
    IOutputArray indices,
    IOutputArray squareDistances,
    int knn,
    int checks = 32,
    float eps = 0f,
    bool sorted = true
)
Public Sub KnnSearch (
    queries As IInputArray,
    indices As IOutputArray,
    squareDistances As IOutputArray,
    knn As Integer,
    Optional checks As Integer = 32,
    Optional eps As Single = 0F,
    Optional sorted As Boolean = true
)
public:
void KnnSearch(
    IInputArray^ queries,
    IOutputArray^ indices,
    IOutputArray^ squareDistances,
    int knn,
    int checks = 32,
    float eps = 0f,
    bool sorted = true
)
member KnnSearch :
        queries : IInputArray *
        indices : IOutputArray *
        squareDistances : IOutputArray *
        knn : int *
        ?checks : int *
        ?eps : float32 *
        ?sorted : bool
(* Defaults:
        let _checks = defaultArg checks 32
        let _eps = defaultArg eps 0f
        let _sorted = defaultArg sorted true
*)
-> unit

Parameters

queries
Type: Emgu.CVIInputArray
A row by row matrix of descriptors to be query for nearest neighbours
indices
Type: Emgu.CVIOutputArray
The result of the indices of the k-nearest neighbours
squareDistances
Type: Emgu.CVIOutputArray
The square of the Eculidean distance between the neighbours
knn
Type: SystemInt32
Number of nearest neighbors to search for
checks (Optional)
Type: SystemInt32
The number of times the tree(s) in the index should be recursively traversed. A higher value for this parameter would give better search precision, but also take more time. If automatic configuration was used when the index was created, the number of checks required to achieve the specified precision was also computed, in which case this parameter is ignored
eps (Optional)
Type: SystemSingle
The search epsilon
sorted (Optional)
Type: SystemBoolean
If set to true, the search result is sorted
See Also

Reference

Index Class
Emgu.CV.Flann Namespace


Index.RadiusSearch Method

IndexRadiusSearch Method

Performs a radius nearest neighbor search for multiple query points

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int RadiusSearch(
    IInputArray queries,
    IOutputArray indices,
    IOutputArray squareDistances,
    double radius,
    int maxResults,
    int checks = 32,
    float eps = 0f,
    bool sorted = true
)
Public Function RadiusSearch (
    queries As IInputArray,
    indices As IOutputArray,
    squareDistances As IOutputArray,
    radius As Double,
    maxResults As Integer,
    Optional checks As Integer = 32,
    Optional eps As Single = 0F,
    Optional sorted As Boolean = true
) As Integer
public:
int RadiusSearch(
    IInputArray^ queries,
    IOutputArray^ indices,
    IOutputArray^ squareDistances,
    double radius,
    int maxResults,
    int checks = 32,
    float eps = 0f,
    bool sorted = true
)
member RadiusSearch :
        queries : IInputArray *
        indices : IOutputArray *
        squareDistances : IOutputArray *
        radius : float *
        maxResults : int *
        ?checks : int *
        ?eps : float32 *
        ?sorted : bool
(* Defaults:
        let _checks = defaultArg checks 32
        let _eps = defaultArg eps 0f
        let _sorted = defaultArg sorted true
*)
-> int

Parameters

queries
Type: Emgu.CVIInputArray
The query points, one per row
indices
Type: Emgu.CVIOutputArray
Indices of the nearest neighbors found
squareDistances
Type: Emgu.CVIOutputArray
The square of the Eculidean distance between the neighbours
radius
Type: SystemDouble
The search radius
maxResults
Type: SystemInt32
The maximum number of results
checks (Optional)
Type: SystemInt32
The number of times the tree(s) in the index should be recursively traversed. A higher value for this parameter would give better search precision, but also take more time. If automatic configuration was used when the index was created, the number of checks required to achieve the specified precision was also computed, in which case this parameter is ignored
eps (Optional)
Type: SystemSingle
The search epsilon
sorted (Optional)
Type: SystemBoolean
If set to true, the search result is sorted

Return Value

Type: Int32
The number of points in the search radius
See Also

Reference

Index Class
Emgu.CV.Flann Namespace


Index Fields

The Index type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Index Class
Emgu.CV.Flann Namespace


Index3D Class

Create index for 3D points
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannIndex3D

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Index3D : UnmanagedObject
Public Class Index3D
    Inherits UnmanagedObject
public ref class Index3D : public UnmanagedObject
type Index3D =
    class
        inherit UnmanagedObject
    end

The Index3D type exposes the following members.

Constructors
 | Name | Description
Public method | Index3D | Create a flann index for 3D points
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the resource used by this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NearestNeighbor | Find the approximate nearest position in 3D
Public method | RadiusSearch | Perform a search within the given radius
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


Index3D Constructor

Create a flann index for 3D points

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Index3D(
    MCvPoint3D32f[] points,
    IIndexParams ip
)
Public Sub New (
    points As MCvPoint3D32f(),
    ip As IIndexParams
)
public:
Index3D(
    array<MCvPoint3D32f^>^ points,
    IIndexParams^ ip
)
new :
        points : MCvPoint3D32f[] *
        ip : IIndexParams -> Index3D

Parameters

points
Type: Emgu.CV.StructureMCvPoint3D32f
The IPosition3D array
ip
Type: Emgu.CV.FlannIIndexParams
The index parameters
See Also

Reference

Index3D Class
Emgu.CV.Flann Namespace


Index3D Properties

The Index3D type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Index3D Class
Emgu.CV.Flann Namespace


Index3D Methods

The Index3D type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the resource used by this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NearestNeighbor | Find the approximate nearest position in 3D
Public method | RadiusSearch | Perform a search within the given radius
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Index3D Class
Emgu.CV.Flann Namespace


Index3D.DisposeObject Method

Index3DDisposeObject Method

Release the resource used by this object

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Index3D Class
Emgu.CV.Flann Namespace


Index3D.NearestNeighbor Method

Index3DNearestNeighbor Method

Find the approximate nearest position in 3D

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Index3DNeighbor NearestNeighbor(
    MCvPoint3D32f position
)
Public Function NearestNeighbor (
    position As MCvPoint3D32f
) As Index3DNeighbor
public:
Index3DNeighbor^ NearestNeighbor(
    MCvPoint3D32f^ position
)
member NearestNeighbor :
        position : MCvPoint3D32f -> Index3DNeighbor

Parameters

position
Type: Emgu.CV.StructureMCvPoint3D32f
The position to start the search from

Return Value

Type: Index3DNeighbor
The nearest neighbor (may be an approximation, depends in the index type).
See Also

Reference

Index3D Class
Emgu.CV.Flann Namespace


Index3D.RadiusSearch Method

Index3DRadiusSearch Method

Perform a search within the given radius

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Index3DNeighbor[] RadiusSearch(
    MCvPoint3D32f position,
    double radius,
    int maxResults
)
Public Function RadiusSearch (
    position As MCvPoint3D32f,
    radius As Double,
    maxResults As Integer
) As Index3DNeighbor()
public:
array<Index3DNeighbor^>^ RadiusSearch(
    MCvPoint3D32f^ position,
    double radius,
    int maxResults
)
member RadiusSearch :
        position : MCvPoint3D32f *
        radius : float *
        maxResults : int -> Index3DNeighbor[]

Parameters

position
Type: Emgu.CV.StructureMCvPoint3D32f
The center of the search area
radius
Type: SystemDouble
The radius of the search
maxResults
Type: SystemInt32
The maximum number of results to return

Return Value

Type: Index3DNeighbor
The neighbors found
See Also

Reference

Index3D Class
Emgu.CV.Flann Namespace


Index3D Fields

The Index3D type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Index3D Class
Emgu.CV.Flann Namespace


Index3D.Neighbor Class

Index3DNeighbor Class

A neighbor point
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.FlannIndex3DNeighbor

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Neighbor : ValueType
Public NotInheritable Class Neighbor
    Inherits ValueType
public ref class Neighbor sealed : public ValueType
[<SealedAttribute>]
type Neighbor =
    class
        inherit ValueType
    end

The Index3DNeighbor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Index | The index of the point
Public field | SquareDist | The square distance
Top
See Also

Reference

Emgu.CV.Flann Namespace


Neighbor Methods

The Index3DNeighbor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Index3DNeighbor Class
Emgu.CV.Flann Namespace


Neighbor Fields

The Index3DNeighbor type exposes the following members.

Fields
 | Name | Description
Public field | Index | The index of the point
Public field | SquareDist | The square distance
Top
See Also

Reference

Index3DNeighbor Class
Emgu.CV.Flann Namespace


Index3D.Neighbor.Index Field

Index3DNeighborIndex Field

The index of the point

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Index
Public Index As Integer
public:
int Index
val mutable Index: int

Field Value

Type: Int32
See Also

Reference

Index3DNeighbor Class
Emgu.CV.Flann Namespace


Index3D.Neighbor.SquareDist Field

Index3DNeighborSquareDist Field

The square distance

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float SquareDist
Public SquareDist As Single
public:
float SquareDist
val mutable SquareDist: float32

Field Value

Type: Single
See Also

Reference

Index3DNeighbor Class
Emgu.CV.Flann Namespace


KdTreeIndexParams Class

When passing an object of this type the index constructed will consist of a set of randomized kd-trees which will be searched in parallel.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannKdTreeIndexParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class KdTreeIndexParams : UnmanagedObject,
    IIndexParams
Public Class KdTreeIndexParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class KdTreeIndexParams : public UnmanagedObject,
    IIndexParams
type KdTreeIndexParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The KdTreeIndexParams type exposes the following members.

Constructors
 | Name | Description
Public method | KdTreeIndexParams | Initializes a new instance of the KdTreeIndexParams class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


KdTreeIndexParams Constructor

Initializes a new instance of the KdTreeIndexParams class.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public KdTreeIndexParams(
    int trees = 4
)
Public Sub New (
    Optional trees As Integer = 4
)
public:
KdTreeIndexParams(
    int trees = 4
)
new :
        ?trees : int
(* Defaults:
        let _trees = defaultArg trees 4
*)
-> KdTreeIndexParams

Parameters

trees (Optional)
Type: SystemInt32
The number of parallel kd-trees to use. Good values are in the range [1..16]
See Also

Reference

KdTreeIndexParams Class
Emgu.CV.Flann Namespace


KdTreeIndexParams Properties

The KdTreeIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

KdTreeIndexParams Class
Emgu.CV.Flann Namespace


KdTreeIndexParams Methods

The KdTreeIndexParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KdTreeIndexParams Class
Emgu.CV.Flann Namespace


KdTreeIndexParams.DisposeObject Method

KdTreeIndexParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

KdTreeIndexParams Class
Emgu.CV.Flann Namespace


KdTreeIndexParams Fields

The KdTreeIndexParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

KdTreeIndexParams Class
Emgu.CV.Flann Namespace


KMeansIndexParams Class

When passing an object of this type the index constructed will be a hierarchical k-means tree.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannKMeansIndexParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class KMeansIndexParams : UnmanagedObject,
    IIndexParams
Public Class KMeansIndexParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class KMeansIndexParams : public UnmanagedObject,
    IIndexParams
type KMeansIndexParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The KMeansIndexParams type exposes the following members.

Constructors
 | Name | Description
Public method | KMeansIndexParams | Initializes a new instance of the KMeansIndexParams class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


KMeansIndexParams Constructor

Initializes a new instance of the KMeansIndexParams class.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public KMeansIndexParams(
    int branching = 32,
    int iterations = 11,
    CenterInitType centersInit = 0,
    float cbIndex = 0.2f
)
Public Sub New (
    Optional branching As Integer = 32,
    Optional iterations As Integer = 11,
    Optional centersInit As CenterInitType = 0,
    Optional cbIndex As Single = 0.2F
)
public:
KMeansIndexParams(
    int branching = 32,
    int iterations = 11,
    CenterInitType^ centersInit = 0,
    float cbIndex = 0.2f
)
new :
        ?branching : int *
        ?iterations : int *
        ?centersInit : CenterInitType *
        ?cbIndex : float32
(* Defaults:
        let _branching = defaultArg branching 32
        let _iterations = defaultArg iterations 11
        let _centersInit = defaultArg centersInit 0
        let _cbIndex = defaultArg cbIndex 0.2f
*)
-> KMeansIndexParams

Parameters

branching (Optional)
Type: SystemInt32
The branching factor to use for the hierarchical k-means tree
iterations (Optional)
Type: SystemInt32
The maximum number of iterations to use in the k-means clustering stage when building the k-means tree. A value of -1 used here means that the k-means clustering should be iterated until convergence
centersInit (Optional)
Type: Emgu.CV.FlannCenterInitType
The algorithm to use for selecting the initial centers when performing a k-means clustering step. The possible values are CENTERS_RANDOM (picks the initial cluster centers randomly), CENTERS_GONZALES (picks the initial centers using Gonzales’ algorithm) and CENTERS_KMEANSPP (picks the initial centers using the algorithm suggested in arthur_kmeanspp_2007 )
cbIndex (Optional)
Type: SystemSingle
This parameter (cluster boundary index) influences the way exploration is performed in the hierarchical kmeans tree. When cb_index is zero the next kmeans domain to be explored is chosen to be the one with the closest center. A value greater then zero also takes into account the size of the domain.
See Also

Reference

KMeansIndexParams Class
Emgu.CV.Flann Namespace


KMeansIndexParams Properties

The KMeansIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

KMeansIndexParams Class
Emgu.CV.Flann Namespace


KMeansIndexParams Methods

The KMeansIndexParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KMeansIndexParams Class
Emgu.CV.Flann Namespace


KMeansIndexParams.DisposeObject Method

KMeansIndexParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

KMeansIndexParams Class
Emgu.CV.Flann Namespace


KMeansIndexParams Fields

The KMeansIndexParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

KMeansIndexParams Class
Emgu.CV.Flann Namespace


LinearIndexParams Class

When passing an object of this type, the index will perform a linear, brute-force search.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannLinearIndexParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LinearIndexParams : UnmanagedObject,
    IIndexParams
Public Class LinearIndexParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class LinearIndexParams : public UnmanagedObject,
    IIndexParams
type LinearIndexParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The LinearIndexParams type exposes the following members.

Constructors
 | Name | Description
Public method | LinearIndexParams | Initializes a new instance of the LinearIndexParams class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


LinearIndexParams Constructor

Initializes a new instance of the LinearIndexParams class.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LinearIndexParams()
Public Sub New
public:
LinearIndexParams()
new : unit -> LinearIndexParams
See Also

Reference

LinearIndexParams Class
Emgu.CV.Flann Namespace


LinearIndexParams Properties

The LinearIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

LinearIndexParams Class
Emgu.CV.Flann Namespace


LinearIndexParams Methods

The LinearIndexParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinearIndexParams Class
Emgu.CV.Flann Namespace


LinearIndexParams.DisposeObject Method

LinearIndexParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LinearIndexParams Class
Emgu.CV.Flann Namespace


LinearIndexParams Fields

The LinearIndexParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

LinearIndexParams Class
Emgu.CV.Flann Namespace


LshIndexParams Class

When using a parameters object of this type the index created uses multi-probe LSH (by Multi-Probe LSH: Efficient Indexing for High-Dimensional Similarity Search by Qin Lv, William Josephson, Zhe Wang, Moses Charikar, Kai Li., Proceedings of the 33rd International Conference on Very Large Data Bases (VLDB). Vienna, Austria. September 2007)
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannLshIndexParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LshIndexParams : UnmanagedObject,
    IIndexParams
Public Class LshIndexParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class LshIndexParams : public UnmanagedObject,
    IIndexParams
type LshIndexParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The LshIndexParams type exposes the following members.

Constructors
 | Name | Description
Public method | LshIndexParams | Initializes a new instance of the LshIndexParams class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


LshIndexParams Constructor

Initializes a new instance of the LshIndexParams class.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LshIndexParams(
    int tableNumber,
    int keySize,
    int multiProbeLevel
)
Public Sub New (
    tableNumber As Integer,
    keySize As Integer,
    multiProbeLevel As Integer
)
public:
LshIndexParams(
    int tableNumber,
    int keySize,
    int multiProbeLevel
)
new :
        tableNumber : int *
        keySize : int *
        multiProbeLevel : int -> LshIndexParams

Parameters

tableNumber
Type: SystemInt32
The number of hash tables to use (between 10 and 30 usually).
keySize
Type: SystemInt32
The size of the hash key in bits (between 10 and 20 usually).
multiProbeLevel
Type: SystemInt32
The number of bits to shift to check for neighboring buckets (0 is regular LSH, 2 is recommended).
See Also

Reference

LshIndexParams Class
Emgu.CV.Flann Namespace


LshIndexParams Properties

The LshIndexParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

LshIndexParams Class
Emgu.CV.Flann Namespace


LshIndexParams Methods

The LshIndexParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LshIndexParams Class
Emgu.CV.Flann Namespace


LshIndexParams.DisposeObject Method

LshIndexParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LshIndexParams Class
Emgu.CV.Flann Namespace


LshIndexParams Fields

The LshIndexParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

LshIndexParams Class
Emgu.CV.Flann Namespace


SearchParams Class

Search parameters
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.FlannSearchParams

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SearchParams : UnmanagedObject,
    IIndexParams
Public Class SearchParams
    Inherits UnmanagedObject
    Implements IIndexParams
public ref class SearchParams : public UnmanagedObject,
    IIndexParams
type SearchParams =
    class
        inherit UnmanagedObject
        interface IIndexParams
    end

The SearchParams type exposes the following members.

Constructors
 | Name | Description
Public method | SearchParams | Initializes a new instance of the SearchParams class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Flann Namespace


SearchParams Constructor

Initializes a new instance of the SearchParams class.

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SearchParams(
    int checks = 32,
    float eps = 0f,
    bool sorted = true
)
Public Sub New (
    Optional checks As Integer = 32,
    Optional eps As Single = 0F,
    Optional sorted As Boolean = true
)
public:
SearchParams(
    int checks = 32,
    float eps = 0f,
    bool sorted = true
)
new :
        ?checks : int *
        ?eps : float32 *
        ?sorted : bool
(* Defaults:
        let _checks = defaultArg checks 32
        let _eps = defaultArg eps 0f
        let _sorted = defaultArg sorted true
*)
-> SearchParams

Parameters

checks (Optional)
Type: SystemInt32
how many leafs to visit when searching for neighbors (-1 for unlimited)
eps (Optional)
Type: SystemSingle
Search for eps-approximate neighbors
sorted (Optional)
Type: SystemBoolean
Only for radius search, require neighbors sorted by distance
See Also

Reference

SearchParams Class
Emgu.CV.Flann Namespace


SearchParams Properties

The SearchParams type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SearchParams Class
Emgu.CV.Flann Namespace


SearchParams Methods

The SearchParams type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with this IndexParam (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SearchParams Class
Emgu.CV.Flann Namespace


SearchParams.DisposeObject Method

SearchParamsDisposeObject Method

Release all the memory associated with this IndexParam

Namespace: Emgu.CV.Flann
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SearchParams Class
Emgu.CV.Flann Namespace


SearchParams Fields

The SearchParams type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SearchParams Class
Emgu.CV.Flann Namespace


Emgu.CV.Freetype Namespace

Drawing UTF-8 strings with freetype/harfbuzz
Classes
 | Class | Description
Public class | Freetype2 | Draw UTF-8 strings with freetype/harfbuzz.
Public class | FreetypeInvoke | This class wraps the functional calls to the OpenCV Freetype modules


Freetype2 Class

Draw UTF-8 strings with freetype/harfbuzz.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.FreetypeFreetype2

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Freetype2 : SharedPtrObject, IAlgorithm
Public Class Freetype2
    Inherits SharedPtrObject
    Implements IAlgorithm
public ref class Freetype2 : public SharedPtrObject,
    IAlgorithm
type Freetype2 =
    class
        inherit SharedPtrObject
        interface IAlgorithm
    end

The Freetype2 type exposes the following members.

Constructors
 | Name | Description
Public method | Freetype2 | Create instance to draw UTF-8 strings.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Native algorithm pointer
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextSize | Calculates the width and height of a text string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFontData | Load font data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutText | Renders the specified text string in the image. Symbols that cannot be rendered using the specified font are replaced by "Tofu" or non-drawn.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetSplitNumber | Set the number of split points from bezier-curve to line. If you want to draw large glyph, large is better. If you want to draw small glyph, small is better.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Freetype Namespace


Freetype2 Constructor

Create instance to draw UTF-8 strings.

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Freetype2()
Public Sub New
public:
Freetype2()
new : unit -> Freetype2
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2 Properties

The Freetype2 type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Native algorithm pointer
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2.AlgorithmPtr Property

Freetype2AlgorithmPtr Property

Native algorithm pointer

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2 Methods

The Freetype2 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextSize | Calculates the width and height of a text string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFontData | Load font data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutText | Renders the specified text string in the image. Symbols that cannot be rendered using the specified font are replaced by "Tofu" or non-drawn.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetSplitNumber | Set the number of split points from bezier-curve to line. If you want to draw large glyph, large is better. If you want to draw small glyph, small is better.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2.DisposeObject Method

Freetype2DisposeObject Method

Release all the unmanaged memory associate with this object

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2.GetTextSize Method

Freetype2GetTextSize Method

Calculates the width and height of a text string.

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size GetTextSize(
    string text,
    int fontHeight,
    int thickness,
    ref int baseLine
)
Public Function GetTextSize (
    text As String,
    fontHeight As Integer,
    thickness As Integer,
    ByRef baseLine As Integer
) As Size
public:
Size^ GetTextSize(
    String^ text,
    int fontHeight,
    int thickness,
    int% baseLine
)
member GetTextSize :
        text : string *
        fontHeight : int *
        thickness : int *
        baseLine : int byref -> Size

Parameters

text
Type: SystemString
Input text string.
fontHeight
Type: SystemInt32
Drawing font size by pixel unit.
thickness
Type: SystemInt32
Thickness of lines used to render the text.
baseLine
Type: SystemInt32
y-coordinate of the baseline relative to the bottom-most text point.

Return Value

Type: Size
The approximate size of a box that contains the specified text
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2.LoadFontData Method

Freetype2LoadFontData Method

Load font data.

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void LoadFontData(
    string fontFileName,
    int id
)
Public Sub LoadFontData (
    fontFileName As String,
    id As Integer
)
public:
void LoadFontData(
    String^ fontFileName,
    int id
)
member LoadFontData :
        fontFileName : string *
        id : int -> unit

Parameters

fontFileName
Type: SystemString
FontFile Name
id
Type: SystemInt32
Face index to select a font faces in a single file.
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2.PutText Method

Freetype2PutText Method

Renders the specified text string in the image. Symbols that cannot be rendered using the specified font are replaced by "Tofu" or non-drawn.

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void PutText(
    IInputOutputArray img,
    string text,
    Point org,
    int fontHeight,
    MCvScalar color,
    int thickness,
    LineType lineType,
    bool bottomLeftOrigin
)
Public Sub PutText (
    img As IInputOutputArray,
    text As String,
    org As Point,
    fontHeight As Integer,
    color As MCvScalar,
    thickness As Integer,
    lineType As LineType,
    bottomLeftOrigin As Boolean
)
public:
void PutText(
    IInputOutputArray^ img,
    String^ text,
    Point^ org,
    int fontHeight,
    MCvScalar^ color,
    int thickness,
    LineType^ lineType,
    bool bottomLeftOrigin
)
member PutText :
        img : IInputOutputArray *
        text : string *
        org : Point *
        fontHeight : int *
        color : MCvScalar *
        thickness : int *
        lineType : LineType *
        bottomLeftOrigin : bool -> unit

Parameters

img
Type: Emgu.CVIInputOutputArray
Image.
text
Type: SystemString
Text string to be drawn.
org
Type: System.DrawingPoint
Bottom-left/Top-left corner of the text string in the image.
fontHeight
Type: SystemInt32
Drawing font size by pixel unit.
color
Type: Emgu.CV.StructureMCvScalar
Text color.
thickness
Type: SystemInt32
Thickness of the lines used to draw a text when negative, the glyph is filled. Otherwise, the glyph is drawn with this thickness.
lineType
Type: Emgu.CV.CvEnumLineType
Line type
bottomLeftOrigin
Type: SystemBoolean
When true, the image data origin is at the bottom-left corner. Otherwise, it is at the top-left corner.
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2.SetSplitNumber Method

Freetype2SetSplitNumber Method

Set the number of split points from bezier-curve to line. If you want to draw large glyph, large is better. If you want to draw small glyph, small is better.

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetSplitNumber(
    int num
)
Public Sub SetSplitNumber (
    num As Integer
)
public:
void SetSplitNumber(
    int num
)
member SetSplitNumber :
        num : int -> unit

Parameters

num
Type: SystemInt32
Number of split points from bezier-curve to line
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


Freetype2 Fields

The Freetype2 type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Freetype2 Class
Emgu.CV.Freetype Namespace


FreetypeInvoke Class

This class wraps the functional calls to the OpenCV Freetype modules
Inheritance Hierarchy
SystemObject
Emgu.CV.FreetypeFreetypeInvoke

Namespace: Emgu.CV.Freetype
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class FreetypeInvoke
Public NotInheritable Class FreetypeInvoke
public ref class FreetypeInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FreetypeInvoke =  class end
See Also

Reference

Emgu.CV.Freetype Namespace


Emgu.CV.Fuzzy Namespace

Fuzzy image processing
Classes
 | Class | Description
Public class | FuzzyInvoke | The module brings implementation of the image processing algorithms based on fuzzy mathematics.
Public class | FuzzyInvokeFunction | Function type
Public class | FuzzyInvokeInpaintAlgorithm | Inpaint algorithm


FuzzyInvoke Class

The module brings implementation of the image processing algorithms based on fuzzy mathematics.
Inheritance Hierarchy
SystemObject
Emgu.CV.FuzzyFuzzyInvoke

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class FuzzyInvoke
Public NotInheritable Class FuzzyInvoke
public ref class FuzzyInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FuzzyInvoke =  class end

The FuzzyInvoke type exposes the following members.

Methods
Name | Description
CreateKernel(FuzzyInvokeFunction, Int32, IOutputArray, Int32) | Creates kernel from general functions.
CreateKernel(IInputArray, IInputArray, IOutputArray, Int32) | Creates kernel from basic functions.
Filter | Image filtering.
Inpaint | Image inpainting.
Top
See Also

Reference

Emgu.CV.Fuzzy Namespace


FuzzyInvoke Methods

The FuzzyInvoke type exposes the following members.

Methods
Name | Description
CreateKernel(FuzzyInvokeFunction, Int32, IOutputArray, Int32) | Creates kernel from general functions.
CreateKernel(IInputArray, IInputArray, IOutputArray, Int32) | Creates kernel from basic functions.
Filter | Image filtering.
Inpaint | Image inpainting.
Top
See Also

Reference

FuzzyInvoke Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.CreateKernel Method

FuzzyInvokeCreateKernel Method

Overload List
Name | Description
CreateKernel(FuzzyInvokeFunction, Int32, IOutputArray, Int32) | Creates kernel from general functions.
CreateKernel(IInputArray, IInputArray, IOutputArray, Int32) | Creates kernel from basic functions.
Top
See Also

Reference

FuzzyInvoke Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.CreateKernel Method (FuzzyInvoke.Function, Int32, IOutputArray, Int32)

FuzzyInvokeCreateKernel Method (FuzzyInvokeFunction, Int32, IOutputArray, Int32)

http://www.emgu.com
Creates kernel from general functions.

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CreateKernel(
    FuzzyInvokeFunction function,
    int radius,
    IOutputArray kernel,
    int chn = 1
)
Public Shared Sub CreateKernel (
    function As FuzzyInvokeFunction,
    radius As Integer,
    kernel As IOutputArray,
    Optional chn As Integer = 1
)
public:
static void CreateKernel(
    FuzzyInvokeFunction^ function,
    int radius,
    IOutputArray^ kernel,
    int chn = 1
)
static member CreateKernel :
        function : FuzzyInvokeFunction *
        radius : int *
        kernel : IOutputArray *
        ?chn : int
(* Defaults:
        let _chn = defaultArg chn 1
*)
-> unit

Parameters

function
Type: Emgu.CV.FuzzyFuzzyInvokeFunction
Function type
radius
Type: SystemInt32
Radius of the basic function.
kernel
Type: Emgu.CVIOutputArray
Final 32-b kernel.
chn (Optional)
Type: SystemInt32
Number of kernel channels.
See Also

Reference

FuzzyInvoke Class
CreateKernel Overload
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.CreateKernel Method (IInputArray, IInputArray, IOutputArray, Int32)

FuzzyInvokeCreateKernel Method (IInputArray, IInputArray, IOutputArray, Int32)

http://www.emgu.com
Creates kernel from basic functions.

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CreateKernel(
    IInputArray A,
    IInputArray B,
    IOutputArray kernel,
    int chn = 1
)
Public Shared Sub CreateKernel (
    A As IInputArray,
    B As IInputArray,
    kernel As IOutputArray,
    Optional chn As Integer = 1
)
public:
static void CreateKernel(
    IInputArray^ A,
    IInputArray^ B,
    IOutputArray^ kernel,
    int chn = 1
)
static member CreateKernel :
        A : IInputArray *
        B : IInputArray *
        kernel : IOutputArray *
        ?chn : int
(* Defaults:
        let _chn = defaultArg chn 1
*)
-> unit

Parameters

A
Type: Emgu.CVIInputArray
Basic function used in axis x.
B
Type: Emgu.CVIInputArray
Basic function used in axis y.
kernel
Type: Emgu.CVIOutputArray
Final 32-b kernel derived from A and B.
chn (Optional)
Type: SystemInt32
Number of kernel channels.
See Also

Reference

FuzzyInvoke Class
CreateKernel Overload
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.Filter Method

FuzzyInvokeFilter Method

Image filtering.

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Filter(
    Mat image,
    Mat kernel,
    Mat output
)
Public Shared Sub Filter (
    image As Mat,
    kernel As Mat,
    output As Mat
)
public:
static void Filter(
    Mat^ image,
    Mat^ kernel,
    Mat^ output
)
static member Filter :
        image : Mat *
        kernel : Mat *
        output : Mat -> unit

Parameters

image
Type: Emgu.CVMat
Input image.
kernel
Type: Emgu.CVMat
Final 32-b kernel.
output
Type: Emgu.CVMat
Output 32-bit image.
See Also

Reference

FuzzyInvoke Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.Inpaint Method

FuzzyInvokeInpaint Method

Image inpainting.

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Inpaint(
    Mat image,
    Mat mask,
    Mat output,
    int radius = 2,
    FuzzyInvokeFunction function = 1,
    FuzzyInvokeInpaintAlgorithm algorithm = 1
)
Public Shared Sub Inpaint (
    image As Mat,
    mask As Mat,
    output As Mat,
    Optional radius As Integer = 2,
    Optional function As FuzzyInvokeFunction = 1,
    Optional algorithm As FuzzyInvokeInpaintAlgorithm = 1
)
public:
static void Inpaint(
    Mat^ image,
    Mat^ mask,
    Mat^ output,
    int radius = 2,
    FuzzyInvokeFunction^ function = 1,
    FuzzyInvokeInpaintAlgorithm^ algorithm = 1
)
static member Inpaint :
        image : Mat *
        mask : Mat *
        output : Mat *
        ?radius : int *
        ?function : FuzzyInvokeFunction *
        ?algorithm : FuzzyInvokeInpaintAlgorithm
(* Defaults:
        let _radius = defaultArg radius 2
        let _function = defaultArg function 1
        let _algorithm = defaultArg algorithm 1
*)
-> unit

Parameters

image
Type: Emgu.CVMat
Input image.
mask
Type: Emgu.CVMat
Mask used for unwanted area marking.
output
Type: Emgu.CVMat
Output 32-bit image.
radius (Optional)
Type: SystemInt32
Radius of the basic function.
function (Optional)
Type: Emgu.CV.FuzzyFuzzyInvokeFunction
Function type
algorithm (Optional)
Type: Emgu.CV.FuzzyFuzzyInvokeInpaintAlgorithm
Algorithm type
See Also

Reference

FuzzyInvoke Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.Function Class

FuzzyInvokeFunction Class

Function type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.FuzzyFuzzyInvokeFunction

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Function : Enum
Public NotInheritable Class Function
    Inherits Enum
public ref class Function sealed : public Enum
[<SealedAttribute>]
type Function =
    class
        inherit Enum
    end

The FuzzyInvokeFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Linear | Linear
 | Sinus | Sinus
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Fuzzy Namespace


Function Methods

The FuzzyInvokeFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FuzzyInvokeFunction Class
Emgu.CV.Fuzzy Namespace


Function Fields

The FuzzyInvokeFunction type exposes the following members.

Fields
 | Name | Description
 | Linear | Linear
 | Sinus | Sinus
Public field | value__ |
Top
See Also

Reference

FuzzyInvokeFunction Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.Function.Linear Field

FuzzyInvokeFunctionLinear Field

Linear

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FuzzyInvokeFunction Linear = 1
Public Const Linear As FuzzyInvokeFunction = 1
public:
literal FuzzyInvokeFunction^ Linear = 1
static val mutable Linear: FuzzyInvokeFunction

Field Value

Type: FuzzyInvokeFunction
See Also

Reference

FuzzyInvokeFunction Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.Function.Sinus Field

FuzzyInvokeFunctionSinus Field

Sinus

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FuzzyInvokeFunction Sinus = 2
Public Const Sinus As FuzzyInvokeFunction = 2
public:
literal FuzzyInvokeFunction^ Sinus = 2
static val mutable Sinus: FuzzyInvokeFunction

Field Value

Type: FuzzyInvokeFunction
See Also

Reference

FuzzyInvokeFunction Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.Function.value__ Field

FuzzyInvokeFunctionvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Fuzzy.FuzzyInvoke.Function.value__"]

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FuzzyInvokeFunction Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.InpaintAlgorithm Class

FuzzyInvokeInpaintAlgorithm Class

Inpaint algorithm
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.FuzzyFuzzyInvokeInpaintAlgorithm

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InpaintAlgorithm : Enum
Public NotInheritable Class InpaintAlgorithm
    Inherits Enum
public ref class InpaintAlgorithm sealed : public Enum
[<SealedAttribute>]
type InpaintAlgorithm =
    class
        inherit Enum
    end

The FuzzyInvokeInpaintAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Iterative | Iterative algorithm running in more steps using partial computations.
 | MultiStep | Algorithm automaticaly increasing radius of the basic function.
 | OneStep | One step algorithm.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Fuzzy Namespace


InpaintAlgorithm Methods

The FuzzyInvokeInpaintAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FuzzyInvokeInpaintAlgorithm Class
Emgu.CV.Fuzzy Namespace


InpaintAlgorithm Fields

The FuzzyInvokeInpaintAlgorithm type exposes the following members.

Fields
 | Name | Description
 | Iterative | Iterative algorithm running in more steps using partial computations.
 | MultiStep | Algorithm automaticaly increasing radius of the basic function.
 | OneStep | One step algorithm.
Public field | value__ |
Top
See Also

Reference

FuzzyInvokeInpaintAlgorithm Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.InpaintAlgorithm.Iterative Field

FuzzyInvokeInpaintAlgorithmIterative Field

Iterative algorithm running in more steps using partial computations.

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FuzzyInvokeInpaintAlgorithm Iterative = 3
Public Const Iterative As FuzzyInvokeInpaintAlgorithm = 3
public:
literal FuzzyInvokeInpaintAlgorithm^ Iterative = 3
static val mutable Iterative: FuzzyInvokeInpaintAlgorithm

Field Value

Type: FuzzyInvokeInpaintAlgorithm
See Also

Reference

FuzzyInvokeInpaintAlgorithm Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.InpaintAlgorithm.MultiStep Field

FuzzyInvokeInpaintAlgorithmMultiStep Field

Algorithm automaticaly increasing radius of the basic function.

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FuzzyInvokeInpaintAlgorithm MultiStep = 2
Public Const MultiStep As FuzzyInvokeInpaintAlgorithm = 2
public:
literal FuzzyInvokeInpaintAlgorithm^ MultiStep = 2
static val mutable MultiStep: FuzzyInvokeInpaintAlgorithm

Field Value

Type: FuzzyInvokeInpaintAlgorithm
See Also

Reference

FuzzyInvokeInpaintAlgorithm Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.InpaintAlgorithm.OneStep Field

FuzzyInvokeInpaintAlgorithmOneStep Field

One step algorithm.

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FuzzyInvokeInpaintAlgorithm OneStep = 1
Public Const OneStep As FuzzyInvokeInpaintAlgorithm = 1
public:
literal FuzzyInvokeInpaintAlgorithm^ OneStep = 1
static val mutable OneStep: FuzzyInvokeInpaintAlgorithm

Field Value

Type: FuzzyInvokeInpaintAlgorithm
See Also

Reference

FuzzyInvokeInpaintAlgorithm Class
Emgu.CV.Fuzzy Namespace


FuzzyInvoke.InpaintAlgorithm.value__ Field

FuzzyInvokeInpaintAlgorithmvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Fuzzy.FuzzyInvoke.InpaintAlgorithm.value__"]

Namespace: Emgu.CV.Fuzzy
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FuzzyInvokeInpaintAlgorithm Class
Emgu.CV.Fuzzy Namespace


Emgu.CV.Geodetic Namespace

Contains library that can be use for geomatic transformation.
Classes
 | Class | Description
Public class | GeodeticCoordinate | A geodetic coordinate that is defined by its latitude, longitude and altitude


GeodeticCoordinate Class

A geodetic coordinate that is defined by its latitude, longitude and altitude
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.GeodeticGeodeticCoordinate

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class GeodeticCoordinate : ValueType,
    IEquatable<GeodeticCoordinate>
Public NotInheritable Class GeodeticCoordinate
    Inherits ValueType
    Implements IEquatable(Of GeodeticCoordinate)
public ref class GeodeticCoordinate sealed : public ValueType,
    IEquatable<GeodeticCoordinate^>
[<SealedAttribute>]
type GeodeticCoordinate =
    class
        inherit ValueType
        interface IEquatable<GeodeticCoordinate>
    end

The GeodeticCoordinate type exposes the following members.

Constructors
 | Name | Description
Public method | GeodeticCoordinate | Create a geodetic coordinate using the specific values
Top
Properties
 | Name | Description
Public property | Altitude | Altitude (height) in meters
Public property | Latitude | Latitude (phi) in radian
Public property | Longitude | Longitude (lambda) in radian
Top
Methods
 | Name | Description
 | DegreeToRadian | Convert degree to radian
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(GeodeticCoordinate) | Check if this Geodetic coordinate equals other
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RadianToDegree | Convert radian to degree
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Addition | Compute the sum of two GeodeticCoordinates
Multiply | Compute coor * scale
Subtraction | Compute coor1 - coor2
Top
Fields
Name | Description
Empty | Indicates the origin of the Geodetic Coordinate
Top
See Also

Reference

Emgu.CV.Geodetic Namespace


GeodeticCoordinate Constructor

Create a geodetic coordinate using the specific values

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GeodeticCoordinate(
    double latitude,
    double longitude,
    double altitude
)
Public Sub New (
    latitude As Double,
    longitude As Double,
    altitude As Double
)
public:
GeodeticCoordinate(
    double latitude,
    double longitude,
    double altitude
)
new :
        latitude : float *
        longitude : float *
        altitude : float -> GeodeticCoordinate

Parameters

latitude
Type: SystemDouble
Latitude in radian
longitude
Type: SystemDouble
Longitude in radian
altitude
Type: SystemDouble
Altitude in meters
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate Properties

The GeodeticCoordinate type exposes the following members.

Properties
 | Name | Description
Public property | Altitude | Altitude (height) in meters
Public property | Latitude | Latitude (phi) in radian
Public property | Longitude | Longitude (lambda) in radian
Top
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Altitude Property

GeodeticCoordinateAltitude Property

Altitude (height) in meters

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Altitude { get; set; }
Public Property Altitude As Double
    Get
    Set
public:
property double Altitude {
    double get ();
    void set (double value);
}
member Altitude : float with get, set

Property Value

Type: Double
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Latitude Property

GeodeticCoordinateLatitude Property

Latitude (phi) in radian

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}
member Latitude : float with get, set

Property Value

Type: Double
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Longitude Property

GeodeticCoordinateLongitude Property

Longitude (lambda) in radian

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}
member Longitude : float with get, set

Property Value

Type: Double
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate Methods

The GeodeticCoordinate type exposes the following members.

Methods
 | Name | Description
 | DegreeToRadian | Convert degree to radian
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(GeodeticCoordinate) | Check if this Geodetic coordinate equals other
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RadianToDegree | Convert radian to degree
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.DegreeToRadian Method

GeodeticCoordinateDegreeToRadian Method

Convert degree to radian

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double DegreeToRadian(
    double degree
)
Public Shared Function DegreeToRadian (
    degree As Double
) As Double
public:
static double DegreeToRadian(
    double degree
)
static member DegreeToRadian :
        degree : float -> float

Parameters

degree
Type: SystemDouble
degree

Return Value

Type: Double
radian
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Equals Method

GeodeticCoordinateEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(GeodeticCoordinate) | Check if this Geodetic coordinate equals other
Top
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Equals Method (GeodeticCoordinate)

GeodeticCoordinateEquals Method (GeodeticCoordinate)

http://www.emgu.com
Check if this Geodetic coordinate equals other

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    GeodeticCoordinate other
)
Public Function Equals (
    other As GeodeticCoordinate
) As Boolean
public:
virtual bool Equals(
    GeodeticCoordinate^ other
) sealed
abstract Equals :
        other : GeodeticCoordinate -> bool
override Equals :
        other : GeodeticCoordinate -> bool

Parameters

other
Type: Emgu.CV.GeodeticGeodeticCoordinate
The other coordinate to be compared with

Return Value

Type: Boolean
True if two coordinates equals

Implements

IEquatableTEquals(T)
See Also

Reference

GeodeticCoordinate Class
Equals Overload
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.RadianToDegree Method

GeodeticCoordinateRadianToDegree Method

Convert radian to degree

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static double RadianToDegree(
    double radian
)
Public Shared Function RadianToDegree (
    radian As Double
) As Double
public:
static double RadianToDegree(
    double radian
)
static member RadianToDegree :
        radian : float -> float

Parameters

radian
Type: SystemDouble
radian

Return Value

Type: Double
degree
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate Operators

The GeodeticCoordinate type exposes the following members.

Operators
Name | Description
Addition | Compute the sum of two GeodeticCoordinates
Multiply | Compute coor * scale
Subtraction | Compute coor1 - coor2
Top
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Addition Operator

GeodeticCoordinateAddition Operator

Compute the sum of two GeodeticCoordinates

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static GeodeticCoordinate operator +(
    GeodeticCoordinate coor1,
    GeodeticCoordinate coor2
)
Public Shared Operator + (
    coor1 As GeodeticCoordinate,
    coor2 As GeodeticCoordinate
) As GeodeticCoordinate
public:
static GeodeticCoordinate^ operator +(
    GeodeticCoordinate^ coor1,
    GeodeticCoordinate^ coor2
)
static let inline (+)
        coor1 : GeodeticCoordinate *
        coor2 : GeodeticCoordinate  : GeodeticCoordinate

Parameters

coor1
Type: Emgu.CV.GeodeticGeodeticCoordinate
The first coordinate to be added
coor2
Type: Emgu.CV.GeodeticGeodeticCoordinate
The second coordinate to be added

Return Value

Type: GeodeticCoordinate
The sum of two GeodeticCoordinates
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Multiply Operator

GeodeticCoordinateMultiply Operator

Compute coor * scale

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static GeodeticCoordinate operator *(
    GeodeticCoordinate coor,
    double scale
)
Public Shared Operator * (
    coor As GeodeticCoordinate,
    scale As Double
) As GeodeticCoordinate
public:
static GeodeticCoordinate^ operator *(
    GeodeticCoordinate^ coor,
    double scale
)
static let inline (*)
        coor : GeodeticCoordinate *
        scale : float  : GeodeticCoordinate

Parameters

coor
Type: Emgu.CV.GeodeticGeodeticCoordinate
The coordinate
scale
Type: SystemDouble
The scale to be multiplied

Return Value

Type: GeodeticCoordinate
coor * scale
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Subtraction Operator

GeodeticCoordinateSubtraction Operator

Compute coor1 - coor2

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static GeodeticCoordinate operator -(
    GeodeticCoordinate coor1,
    GeodeticCoordinate coor2
)
Public Shared Operator - (
    coor1 As GeodeticCoordinate,
    coor2 As GeodeticCoordinate
) As GeodeticCoordinate
public:
static GeodeticCoordinate^ operator -(
    GeodeticCoordinate^ coor1,
    GeodeticCoordinate^ coor2
)
static let inline (-)
        coor1 : GeodeticCoordinate *
        coor2 : GeodeticCoordinate  : GeodeticCoordinate

Parameters

coor1
Type: Emgu.CV.GeodeticGeodeticCoordinate
The first coordinate
coor2
Type: Emgu.CV.GeodeticGeodeticCoordinate
The coordinate to be subtracted

Return Value

Type: GeodeticCoordinate
coor1 - coor2
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate Fields

The GeodeticCoordinate type exposes the following members.

Fields
Name | Description
Empty | Indicates the origin of the Geodetic Coordinate
Top
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


GeodeticCoordinate.Empty Field

GeodeticCoordinateEmpty Field

Indicates the origin of the Geodetic Coordinate

Namespace: Emgu.CV.Geodetic
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly GeodeticCoordinate Empty
Public Shared ReadOnly Empty As GeodeticCoordinate
public:
static initonly GeodeticCoordinate^ Empty
static val Empty: GeodeticCoordinate

Field Value

Type: GeodeticCoordinate
See Also

Reference

GeodeticCoordinate Class
Emgu.CV.Geodetic Namespace


Emgu.CV.Hfs Namespace

Hierarchical Feature Selection for Efficient Image Segmentation
Classes
 | Class | Description
Public class | HfsInvoke | Entry points to the Open CV HFS module
Public class | HfsSegment | Hierarchical Feature Selection for Efficient Image Segmentation


HfsInvoke Class

Entry points to the Open CV HFS module
Inheritance Hierarchy
SystemObject
Emgu.CV.HfsHfsInvoke

Namespace: Emgu.CV.Hfs
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class HfsInvoke
Public NotInheritable Class HfsInvoke
public ref class HfsInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HfsInvoke =  class end
See Also

Reference

Emgu.CV.Hfs Namespace


HfsSegment Class

Hierarchical Feature Selection for Efficient Image Segmentation
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.HfsHfsSegment

Namespace: Emgu.CV.Hfs
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class HfsSegment : SharedPtrObject, IAlgorithm
Public Class HfsSegment
    Inherits SharedPtrObject
    Implements IAlgorithm
public ref class HfsSegment : public SharedPtrObject,
    IAlgorithm
type HfsSegment =
    class
        inherit SharedPtrObject
        interface IAlgorithm
    end

The HfsSegment type exposes the following members.

Constructors
 | Name | Description
Public method | HfsSegment | Create a hfs object
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Native algorithm pointer
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformSegmentCpu | Segmentation with cpu. This method is only implemented for reference. It is highly NOT recommended to use it.
Public method | PerformSegmentGpu | Segmentation with gpu
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Hfs Namespace


HfsSegment Constructor

Create a hfs object

Namespace: Emgu.CV.Hfs
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public HfsSegment(
    int height,
    int width,
    float segEgbThresholdI = 0.08f,
    int minRegionSizeI = 100,
    float segEgbThresholdII = 0.28f,
    int minRegionSizeII = 200,
    float spatialWeight = 0.6f,
    int slicSpixelSize = 8,
    int numSlicIter = 5
)
Public Sub New (
    height As Integer,
    width As Integer,
    Optional segEgbThresholdI As Single = 0.08F,
    Optional minRegionSizeI As Integer = 100,
    Optional segEgbThresholdII As Single = 0.28F,
    Optional minRegionSizeII As Integer = 200,
    Optional spatialWeight As Single = 0.6F,
    Optional slicSpixelSize As Integer = 8,
    Optional numSlicIter As Integer = 5
)
public:
HfsSegment(
    int height,
    int width,
    float segEgbThresholdI = 0.08f,
    int minRegionSizeI = 100,
    float segEgbThresholdII = 0.28f,
    int minRegionSizeII = 200,
    float spatialWeight = 0.6f,
    int slicSpixelSize = 8,
    int numSlicIter = 5
)
new :
        height : int *
        width : int *
        ?segEgbThresholdI : float32 *
        ?minRegionSizeI : int *
        ?segEgbThresholdII : float32 *
        ?minRegionSizeII : int *
        ?spatialWeight : float32 *
        ?slicSpixelSize : int *
        ?numSlicIter : int
(* Defaults:
        let _segEgbThresholdI = defaultArg segEgbThresholdI 0.08f
        let _minRegionSizeI = defaultArg minRegionSizeI 100
        let _segEgbThresholdII = defaultArg segEgbThresholdII 0.28f
        let _minRegionSizeII = defaultArg minRegionSizeII 200
        let _spatialWeight = defaultArg spatialWeight 0.6f
        let _slicSpixelSize = defaultArg slicSpixelSize 8
        let _numSlicIter = defaultArg numSlicIter 5
*)
-> HfsSegment

Parameters

height
Type: SystemInt32
The height of the input image
width
Type: SystemInt32
The width of the input image
segEgbThresholdI (Optional)
Type: SystemSingle
segEgbThresholdI
minRegionSizeI (Optional)
Type: SystemInt32
minRegionSizeI
segEgbThresholdII (Optional)
Type: SystemSingle
segEgbThresholdII
minRegionSizeII (Optional)
Type: SystemInt32
minRegionSizeII
spatialWeight (Optional)
Type: SystemSingle
spatialWeight
slicSpixelSize (Optional)
Type: SystemInt32
slicSpixelSize
numSlicIter (Optional)
Type: SystemInt32
numSlicIter
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


HfsSegment Properties

The HfsSegment type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Native algorithm pointer
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


HfsSegment.AlgorithmPtr Property

HfsSegmentAlgorithmPtr Property

Native algorithm pointer

Namespace: Emgu.CV.Hfs
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


HfsSegment Methods

The HfsSegment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformSegmentCpu | Segmentation with cpu. This method is only implemented for reference. It is highly NOT recommended to use it.
Public method | PerformSegmentGpu | Segmentation with gpu
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


HfsSegment.DisposeObject Method

HfsSegmentDisposeObject Method

Release all the unmanaged memory associate with this object

Namespace: Emgu.CV.Hfs
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


HfsSegment.PerformSegmentCpu Method

HfsSegmentPerformSegmentCpu Method

Segmentation with cpu. This method is only implemented for reference. It is highly NOT recommended to use it.

Namespace: Emgu.CV.Hfs
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat PerformSegmentCpu(
    IInputArray src,
    bool ifDraw = true
)
Public Function PerformSegmentCpu (
    src As IInputArray,
    Optional ifDraw As Boolean = true
) As Mat
public:
Mat^ PerformSegmentCpu(
    IInputArray^ src,
    bool ifDraw = true
)
member PerformSegmentCpu :
        src : IInputArray *
        ?ifDraw : bool
(* Defaults:
        let _ifDraw = defaultArg ifDraw true
*)
-> Mat

Parameters

src
Type: Emgu.CVIInputArray
The input image
ifDraw (Optional)
Type: SystemBoolean
if draw the image in the returned Mat. if this parameter is false, then the content of the returned Mat is a matrix of index, describing the region each pixel belongs to. And it's data type is CV_16U. If this parameter is true, then the returned Mat is a segmented picture, and color of each region is the average color of all pixels in that region. And it's data type is the same as the input image

Return Value

Type: Mat
Segmentation result
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


HfsSegment.PerformSegmentGpu Method

HfsSegmentPerformSegmentGpu Method

Segmentation with gpu

Namespace: Emgu.CV.Hfs
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat PerformSegmentGpu(
    IInputArray src,
    bool ifDraw = true
)
Public Function PerformSegmentGpu (
    src As IInputArray,
    Optional ifDraw As Boolean = true
) As Mat
public:
Mat^ PerformSegmentGpu(
    IInputArray^ src,
    bool ifDraw = true
)
member PerformSegmentGpu :
        src : IInputArray *
        ?ifDraw : bool
(* Defaults:
        let _ifDraw = defaultArg ifDraw true
*)
-> Mat

Parameters

src
Type: Emgu.CVIInputArray
The input image
ifDraw (Optional)
Type: SystemBoolean
if draw the image in the returned Mat. if this parameter is false, then the content of the returned Mat is a matrix of index, describing the region each pixel belongs to. And it's data type is CV_16U. If this parameter is true, then the returned Mat is a segmented picture, and color of each region is the average color of all pixels in that region. And it's data type is the same as the input image

Return Value

Type: Mat
Segmentation result
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


HfsSegment Fields

The HfsSegment type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

HfsSegment Class
Emgu.CV.Hfs Namespace


Emgu.CV.ImgHash Namespace

The module brings implementations of different image hashing algorithms.
Classes
 | Class | Description
Public class | AverageHash | Computes average hash value of the input image.
Public class | BlockMeanHash | Image hash based on block mean.
Public class | BlockMeanHashMode | Block Mean Hash mode
Public class | ColorMomentHash | Image hash based on color moments.
Public class | ImgHashBase | The Image Hash base class
Public class | MarrHildrethHash | Marr-Hildreth Operator Based Hash, slowest but more discriminative.
Public class | PHash | Slower than average hash, but tolerant of minor modifications
Public class | RadialVarianceHash | Image hash based on Radon transform


AverageHash Class

Computes average hash value of the input image.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
Emgu.CV.ImgHashAverageHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class AverageHash : ImgHashBase
Public Class AverageHash
    Inherits ImgHashBase
public ref class AverageHash : public ImgHashBase
type AverageHash =
    class
        inherit ImgHashBase
    end

The AverageHash type exposes the following members.

Constructors
 | Name | Description
Public method | AverageHash | Create an average hash object.
Top
Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with AverageHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Remarks
This is a fast image hashing algorithm, but only work on simple case.
See Also

Reference

Emgu.CV.ImgHash Namespace


AverageHash Constructor

Create an average hash object.

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public AverageHash()
Public Sub New
public:
AverageHash()
new : unit -> AverageHash
See Also

Reference

AverageHash Class
Emgu.CV.ImgHash Namespace


AverageHash Properties

The AverageHash type exposes the following members.

Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AverageHash Class
Emgu.CV.ImgHash Namespace


AverageHash Methods

The AverageHash type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with AverageHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AverageHash Class
Emgu.CV.ImgHash Namespace


AverageHash.DisposeObject Method

AverageHashDisposeObject Method

Release all the unmanaged resource associated with AverageHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

AverageHash Class
Emgu.CV.ImgHash Namespace


AverageHash Fields

The AverageHash type exposes the following members.

Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AverageHash Class
Emgu.CV.ImgHash Namespace


BlockMeanHash Class

Image hash based on block mean.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
Emgu.CV.ImgHashBlockMeanHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BlockMeanHash : ImgHashBase
Public Class BlockMeanHash
    Inherits ImgHashBase
public ref class BlockMeanHash : public ImgHashBase
type BlockMeanHash =
    class
        inherit ImgHashBase
    end

The BlockMeanHash type exposes the following members.

Constructors
 | Name | Description
Public method | BlockMeanHash | Create a Block Mean Hash object
Top
Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BlockMeanHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.ImgHash Namespace


BlockMeanHash Constructor

Create a Block Mean Hash object

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BlockMeanHash(
    BlockMeanHashMode mode = 0
)
Public Sub New (
    Optional mode As BlockMeanHashMode = 0
)
public:
BlockMeanHash(
    BlockMeanHashMode^ mode = 0
)
new :
        ?mode : BlockMeanHashMode
(* Defaults:
        let _mode = defaultArg mode 0
*)
-> BlockMeanHash

Parameters

mode (Optional)
Type: Emgu.CV.ImgHashBlockMeanHashMode
The hash mode
See Also

Reference

BlockMeanHash Class
Emgu.CV.ImgHash Namespace


BlockMeanHash Properties

The BlockMeanHash type exposes the following members.

Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BlockMeanHash Class
Emgu.CV.ImgHash Namespace


BlockMeanHash Methods

The BlockMeanHash type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BlockMeanHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BlockMeanHash Class
Emgu.CV.ImgHash Namespace


BlockMeanHash.DisposeObject Method

BlockMeanHashDisposeObject Method

Release all the unmanaged resource associated with BlockMeanHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BlockMeanHash Class
Emgu.CV.ImgHash Namespace


BlockMeanHash Fields

The BlockMeanHash type exposes the following members.

Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

BlockMeanHash Class
Emgu.CV.ImgHash Namespace


BlockMeanHash.Mode Class

BlockMeanHashMode Class

Block Mean Hash mode
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ImgHashBlockMeanHashMode

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Mode : Enum
Public NotInheritable Class Mode
    Inherits Enum
public ref class Mode sealed : public Enum
[<SealedAttribute>]
type Mode =
    class
        inherit Enum
    end

The BlockMeanHashMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | HashMode0 | use fewer block and generate 16*16/8 uchar hash value
 | HashMode1 | use block blocks(step sizes/2), generate 31*31/8 + 1 uchar hash value
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ImgHash Namespace


Mode Methods

The BlockMeanHashMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BlockMeanHashMode Class
Emgu.CV.ImgHash Namespace


Mode Fields

The BlockMeanHashMode type exposes the following members.

Fields
 | Name | Description
 | HashMode0 | use fewer block and generate 16*16/8 uchar hash value
 | HashMode1 | use block blocks(step sizes/2), generate 31*31/8 + 1 uchar hash value
Public field | value__ |
Top
See Also

Reference

BlockMeanHashMode Class
Emgu.CV.ImgHash Namespace


BlockMeanHash.Mode.HashMode0 Field

BlockMeanHashModeHashMode0 Field

use fewer block and generate 16*16/8 uchar hash value

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BlockMeanHashMode HashMode0 = 0
Public Const HashMode0 As BlockMeanHashMode = 0
public:
literal BlockMeanHashMode^ HashMode0 = 0
static val mutable HashMode0: BlockMeanHashMode

Field Value

Type: BlockMeanHashMode
See Also

Reference

BlockMeanHashMode Class
Emgu.CV.ImgHash Namespace


BlockMeanHash.Mode.HashMode1 Field

BlockMeanHashModeHashMode1 Field

use block blocks(step sizes/2), generate 31*31/8 + 1 uchar hash value

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BlockMeanHashMode HashMode1 = 1
Public Const HashMode1 As BlockMeanHashMode = 1
public:
literal BlockMeanHashMode^ HashMode1 = 1
static val mutable HashMode1: BlockMeanHashMode

Field Value

Type: BlockMeanHashMode
See Also

Reference

BlockMeanHashMode Class
Emgu.CV.ImgHash Namespace


BlockMeanHash.Mode.value__ Field

BlockMeanHashModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ImgHash.BlockMeanHash.Mode.value__"]

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BlockMeanHashMode Class
Emgu.CV.ImgHash Namespace


ColorMomentHash Class

Image hash based on color moments.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
Emgu.CV.ImgHashColorMomentHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ColorMomentHash : ImgHashBase
Public Class ColorMomentHash
    Inherits ImgHashBase
public ref class ColorMomentHash : public ImgHashBase
type ColorMomentHash =
    class
        inherit ImgHashBase
    end

The ColorMomentHash type exposes the following members.

Constructors
 | Name | Description
Public method | ColorMomentHash | Create a Color Moment Hash object
Top
Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with ColorMomentHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.ImgHash Namespace


ColorMomentHash Constructor

Create a Color Moment Hash object

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ColorMomentHash()
Public Sub New
public:
ColorMomentHash()
new : unit -> ColorMomentHash
See Also

Reference

ColorMomentHash Class
Emgu.CV.ImgHash Namespace


ColorMomentHash Properties

The ColorMomentHash type exposes the following members.

Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ColorMomentHash Class
Emgu.CV.ImgHash Namespace


ColorMomentHash Methods

The ColorMomentHash type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with ColorMomentHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorMomentHash Class
Emgu.CV.ImgHash Namespace


ColorMomentHash.DisposeObject Method

ColorMomentHashDisposeObject Method

Release all the unmanaged resource associated with ColorMomentHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ColorMomentHash Class
Emgu.CV.ImgHash Namespace


ColorMomentHash Fields

The ColorMomentHash type exposes the following members.

Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ColorMomentHash Class
Emgu.CV.ImgHash Namespace


ImgHashBase Class

The Image Hash base class
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
More...

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ImgHashBase : UnmanagedObject
Public MustInherit Class ImgHashBase
    Inherits UnmanagedObject
public ref class ImgHashBase abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type ImgHashBase =
    class
        inherit UnmanagedObject
    end

The ImgHashBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ImgHashBase | Initializes a new instance of the ImgHashBase class
Top
Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo
Public method | Compute | Computes hash of the input image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointers (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.ImgHash Namespace
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
Emgu.CV.ImgHashAverageHash
Emgu.CV.ImgHashBlockMeanHash
Emgu.CV.ImgHashColorMomentHash
Emgu.CV.ImgHashMarrHildrethHash
Emgu.CV.ImgHashPHash
Emgu.CV.ImgHashRadialVarianceHash


ImgHashBase Constructor

Initializes a new instance of the ImgHashBase class

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected ImgHashBase()
Protected Sub New
protected:
ImgHashBase()
new : unit -> ImgHashBase
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase Properties

The ImgHashBase type exposes the following members.

Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase.ImgHashBasePtr Property

ImgHashBaseImgHashBasePtr Property

Get the pointer to the ImgHashBase object

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ImgHashBasePtr { get; }
Public ReadOnly Property ImgHashBasePtr As IntPtr
    Get
public:
property IntPtr ImgHashBasePtr {
    IntPtr get ();
}
member ImgHashBasePtr : IntPtr with get

Return Value

Type: IntPtr
The pointer to the ImgHashBase object
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase Methods

The ImgHashBase type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo
Public method | Compute | Computes hash of the input image
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointers (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase.Compare Method

ImgHashBaseCompare Method

Compare the hash value between inOne and inTwo

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Compare(
    IInputArray hashOne,
    IInputArray hashTwo
)
Public Function Compare (
    hashOne As IInputArray,
    hashTwo As IInputArray
) As Double
public:
double Compare(
    IInputArray^ hashOne,
    IInputArray^ hashTwo
)
member Compare :
        hashOne : IInputArray *
        hashTwo : IInputArray -> float

Parameters

hashOne
Type: Emgu.CVIInputArray
Hash value one
hashTwo
Type: Emgu.CVIInputArray
Hash value two

Return Value

Type: Double
indicate similarity between inOne and inTwo, the meaning of the value vary from algorithms to algorithms
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase.Compute Method

ImgHashBaseCompute Method

Computes hash of the input image

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Compute(
    IInputArray inputArr,
    IOutputArray outputArr
)
Public Sub Compute (
    inputArr As IInputArray,
    outputArr As IOutputArray
)
public:
void Compute(
    IInputArray^ inputArr,
    IOutputArray^ outputArr
)
member Compute :
        inputArr : IInputArray *
        outputArr : IOutputArray -> unit

Parameters

inputArr
Type: Emgu.CVIInputArray
input image to compute hash value
outputArr
Type: Emgu.CVIOutputArray
hash of the image
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase.DisposeObject Method

ImgHashBaseDisposeObject Method

Reset the pointers

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase Fields

The ImgHashBase type exposes the following members.

Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


ImgHashBase._imgHashBase Field

ImgHashBase_imgHashBase Field

The pointer to the ImgHashBase object

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _imgHashBase
Protected _imgHashBase As IntPtr
protected:
IntPtr _imgHashBase
val mutable _imgHashBase: IntPtr

Field Value

Type: IntPtr
See Also

Reference

ImgHashBase Class
Emgu.CV.ImgHash Namespace


MarrHildrethHash Class

Marr-Hildreth Operator Based Hash, slowest but more discriminative.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
Emgu.CV.ImgHashMarrHildrethHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MarrHildrethHash : ImgHashBase
Public Class MarrHildrethHash
    Inherits ImgHashBase
public ref class MarrHildrethHash : public ImgHashBase
type MarrHildrethHash =
    class
        inherit ImgHashBase
    end

The MarrHildrethHash type exposes the following members.

Constructors
 | Name | Description
Public method | MarrHildrethHash | Create a Marr-Hildreth operator based hash.
Top
Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with MarrHildrethHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.ImgHash Namespace


MarrHildrethHash Constructor

Create a Marr-Hildreth operator based hash.

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MarrHildrethHash(
    float alpha = 2f,
    float scale = 1f
)
Public Sub New (
    Optional alpha As Single = 2F,
    Optional scale As Single = 1F
)
public:
MarrHildrethHash(
    float alpha = 2f,
    float scale = 1f
)
new :
        ?alpha : float32 *
        ?scale : float32
(* Defaults:
        let _alpha = defaultArg alpha 2f
        let _scale = defaultArg scale 1f
*)
-> MarrHildrethHash

Parameters

alpha (Optional)
Type: SystemSingle
Scale factor for marr wavelet.
scale (Optional)
Type: SystemSingle
Level of scale factor
See Also

Reference

MarrHildrethHash Class
Emgu.CV.ImgHash Namespace


MarrHildrethHash Properties

The MarrHildrethHash type exposes the following members.

Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MarrHildrethHash Class
Emgu.CV.ImgHash Namespace


MarrHildrethHash Methods

The MarrHildrethHash type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with MarrHildrethHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarrHildrethHash Class
Emgu.CV.ImgHash Namespace


MarrHildrethHash.DisposeObject Method

MarrHildrethHashDisposeObject Method

Release all the unmanaged resource associated with MarrHildrethHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MarrHildrethHash Class
Emgu.CV.ImgHash Namespace


MarrHildrethHash Fields

The MarrHildrethHash type exposes the following members.

Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MarrHildrethHash Class
Emgu.CV.ImgHash Namespace


PHash Class

Slower than average hash, but tolerant of minor modifications
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
Emgu.CV.ImgHashPHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PHash : ImgHashBase
Public Class PHash
    Inherits ImgHashBase
public ref class PHash : public ImgHashBase
type PHash =
    class
        inherit ImgHashBase
    end

The PHash type exposes the following members.

Constructors
 | Name | Description
Public method | PHash | Create a PHash object
Top
Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with AverageHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.ImgHash Namespace


PHash Constructor

Create a PHash object

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PHash()
Public Sub New
public:
PHash()
new : unit -> PHash
See Also

Reference

PHash Class
Emgu.CV.ImgHash Namespace


PHash Properties

The PHash type exposes the following members.

Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

PHash Class
Emgu.CV.ImgHash Namespace


PHash Methods

The PHash type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with AverageHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PHash Class
Emgu.CV.ImgHash Namespace


PHash.DisposeObject Method

PHashDisposeObject Method

Release all the unmanaged resource associated with AverageHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PHash Class
Emgu.CV.ImgHash Namespace


PHash Fields

The PHash type exposes the following members.

Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

PHash Class
Emgu.CV.ImgHash Namespace


RadialVarianceHash Class

Image hash based on Radon transform
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ImgHashImgHashBase
Emgu.CV.ImgHashRadialVarianceHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RadialVarianceHash : ImgHashBase
Public Class RadialVarianceHash
    Inherits ImgHashBase
public ref class RadialVarianceHash : public ImgHashBase
type RadialVarianceHash =
    class
        inherit ImgHashBase
    end

The RadialVarianceHash type exposes the following members.

Constructors
 | Name | Description
Public method | RadialVarianceHash | Create an image hash based on Radon transform
Top
Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with RadialVarianceHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.ImgHash Namespace


RadialVarianceHash Constructor

Create an image hash based on Radon transform

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RadialVarianceHash(
    double sigma = 1,
    int numOfAngleLine = 180
)
Public Sub New (
    Optional sigma As Double = 1,
    Optional numOfAngleLine As Integer = 180
)
public:
RadialVarianceHash(
    double sigma = 1,
    int numOfAngleLine = 180
)
new :
        ?sigma : float *
        ?numOfAngleLine : int
(* Defaults:
        let _sigma = defaultArg sigma 1
        let _numOfAngleLine = defaultArg numOfAngleLine 180
*)
-> RadialVarianceHash

Parameters

sigma (Optional)
Type: SystemDouble
Sigma
numOfAngleLine (Optional)
Type: SystemInt32
Number of angle line
See Also

Reference

RadialVarianceHash Class
Emgu.CV.ImgHash Namespace


RadialVarianceHash Properties

The RadialVarianceHash type exposes the following members.

Properties
 | Name | Description
Public property | ImgHashBasePtr | Get the pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RadialVarianceHash Class
Emgu.CV.ImgHash Namespace


RadialVarianceHash Methods

The RadialVarianceHash type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compare the hash value between inOne and inTwo (Inherited from ImgHashBase.)
Public method | Compute | Computes hash of the input image (Inherited from ImgHashBase.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with RadialVarianceHash (Overrides ImgHashBaseDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RadialVarianceHash Class
Emgu.CV.ImgHash Namespace


RadialVarianceHash.DisposeObject Method

RadialVarianceHashDisposeObject Method

Release all the unmanaged resource associated with RadialVarianceHash

Namespace: Emgu.CV.ImgHash
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RadialVarianceHash Class
Emgu.CV.ImgHash Namespace


RadialVarianceHash Fields

The RadialVarianceHash type exposes the following members.

Fields
 | Name | Description
Protected field | _imgHashBase | The pointer to the ImgHashBase object (Inherited from ImgHashBase.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RadialVarianceHash Class
Emgu.CV.ImgHash Namespace


Emgu.CV.ML Namespace

Wrapper of OpenCV's Machine Learning Library
Classes
 | Class | Description
Public class | ANN_MLP | Neural network
Public class | ANN_MLPAnnMlpActivationFunction | Possible activation functions
Public class | ANN_MLPAnnMlpTrainMethod | Training method for ANN_MLP
Public class | Boost | Boost Tree
Public class | BoostType | Boost Type
Public class | DTrees | Decision Trees
Public class | DTreesFlags | Predict options
Public class | EM | Expectation Maximization model
Public class | EMCovarianMatrixType | The type of the mixture covariation matrices
Public class | KNearest | The KNearest classifier
Public class | KNearestTypes | The type of KNearest search
Public class | LogisticRegression | ML implements logistic regression, which is a probabilistic classification technique.
Public class | LogisticRegressionRegularizationMethod | Specifies the kind of regularization to be applied.
Public class | LogisticRegressionTrainType | Specifies the kind of training method used.
Public class | MCvParamGrid | Wrapped CvParamGrid structure used by SVM
Public class | MlInvoke | This class contains functions to call into machine learning library
Public class | NormalBayesClassifier | A Normal Bayes Classifier
Public class | RTrees | Random trees
Public class | StatModelExtensions | A statistic model
Public class | SVM | Support Vector Machine
Public class | SVMParamType | The type of SVM parameters
Public class | SVMSvmKernelType | SVM kernel type
Public class | SVMSvmType | Type of SVM
Public class | SVMSGD | Support Vector Machine
Public class | SVMSGDMarginType | Margin type
Public class | SVMSGDSvmsgdType | SVMSGD type. ASGD is often the preferable choice.
Public class | TrainData | Train data
Interfaces
 | Interface | Description
Public interface | IStatModel | Interface for statistical models in OpenCV ML.


ANN_MLP Class

Neural network
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLANN_MLP

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ANN_MLP : UnmanagedObject, IStatModel,
    IAlgorithm
Public Class ANN_MLP
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class ANN_MLP : public UnmanagedObject,
    IStatModel, IAlgorithm
type ANN_MLP =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The ANN_MLP type exposes the following members.

Constructors
 | Name | Description
Public method | ANN_MLP | Create a neural network using the specific parameters
Top
Properties
 | Name | Description
Public property | AnnealCoolingRatio | ANNEAL: Update cooling ratio.
Public property | AnnealFinalT | ANNEAL: Update final temperature.
Public property | AnnealInitialT | ANNEAL: Update initial temperature.
Public property | AnnealItePerStep | ANNEAL: Update iteration per step.
Public property | BackpropMomentumScale | BPROP: Strength of the momentum term (the difference between weights on the 2 previous iterations)
Public property | BackpropWeightScale | BPROP: Strength of the weight gradient term
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RpropDW0 | RPROP: Initial value Delta_0 of update-values Delta_{ij}
Public property | RpropDWMax | RPROP: Update-values upper limit
Public property | RpropDWMin | RPROP: Update-values lower limit
Public property | RpropDWMinus | RPROP: Decrease factor
Public property | RpropDWPlus | RPROP: Increase factor
Public property | TermCriteria | Termination criteria of the training algorithm
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this neural network (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetActivationFunction | Initialize the activation function for each neuron.
Public method | SetLayerSizes | Sets the layer sizes.
Public method | SetTrainMethod | Sets training method and common parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


ANN_MLP Constructor

Create a neural network using the specific parameters

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ANN_MLP()
Public Sub New
public:
ANN_MLP()
new : unit -> ANN_MLP
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP Properties

The ANN_MLP type exposes the following members.

Properties
 | Name | Description
Public property | AnnealCoolingRatio | ANNEAL: Update cooling ratio.
Public property | AnnealFinalT | ANNEAL: Update final temperature.
Public property | AnnealInitialT | ANNEAL: Update initial temperature.
Public property | AnnealItePerStep | ANNEAL: Update iteration per step.
Public property | BackpropMomentumScale | BPROP: Strength of the momentum term (the difference between weights on the 2 previous iterations)
Public property | BackpropWeightScale | BPROP: Strength of the weight gradient term
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RpropDW0 | RPROP: Initial value Delta_0 of update-values Delta_{ij}
Public property | RpropDWMax | RPROP: Update-values upper limit
Public property | RpropDWMin | RPROP: Update-values lower limit
Public property | RpropDWMinus | RPROP: Decrease factor
Public property | RpropDWPlus | RPROP: Increase factor
Public property | TermCriteria | Termination criteria of the training algorithm
Top
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.AnnealCoolingRatio Property

ANN_MLPAnnealCoolingRatio Property

ANNEAL: Update cooling ratio.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double AnnealCoolingRatio { get; set; }
Public Property AnnealCoolingRatio As Double
    Get
    Set
public:
property double AnnealCoolingRatio {
    double get ();
    void set (double value);
}
member AnnealCoolingRatio : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.AnnealFinalT Property

ANN_MLPAnnealFinalT Property

ANNEAL: Update final temperature.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double AnnealFinalT { get; set; }
Public Property AnnealFinalT As Double
    Get
    Set
public:
property double AnnealFinalT {
    double get ();
    void set (double value);
}
member AnnealFinalT : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.AnnealInitialT Property

ANN_MLPAnnealInitialT Property

ANNEAL: Update initial temperature.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double AnnealInitialT { get; set; }
Public Property AnnealInitialT As Double
    Get
    Set
public:
property double AnnealInitialT {
    double get ();
    void set (double value);
}
member AnnealInitialT : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.AnnealItePerStep Property

ANN_MLPAnnealItePerStep Property

ANNEAL: Update iteration per step.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AnnealItePerStep { get; set; }
Public Property AnnealItePerStep As Integer
    Get
    Set
public:
property int AnnealItePerStep {
    int get ();
    void set (int value);
}
member AnnealItePerStep : int with get, set

Property Value

Type: Int32
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.BackpropMomentumScale Property

ANN_MLPBackpropMomentumScale Property

BPROP: Strength of the momentum term (the difference between weights on the 2 previous iterations)

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double BackpropMomentumScale { get; set; }
Public Property BackpropMomentumScale As Double
    Get
    Set
public:
property double BackpropMomentumScale {
    double get ();
    void set (double value);
}
member BackpropMomentumScale : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.BackpropWeightScale Property

ANN_MLPBackpropWeightScale Property

BPROP: Strength of the weight gradient term

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double BackpropWeightScale { get; set; }
Public Property BackpropWeightScale As Double
    Get
    Set
public:
property double BackpropWeightScale {
    double get ();
    void set (double value);
}
member BackpropWeightScale : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.RpropDW0 Property

ANN_MLPRpropDW0 Property

RPROP: Initial value Delta_0 of update-values Delta_{ij}

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RpropDW0 { get; set; }
Public Property RpropDW0 As Double
    Get
    Set
public:
property double RpropDW0 {
    double get ();
    void set (double value);
}
member RpropDW0 : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.RpropDWMax Property

ANN_MLPRpropDWMax Property

RPROP: Update-values upper limit

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RpropDWMax { get; set; }
Public Property RpropDWMax As Double
    Get
    Set
public:
property double RpropDWMax {
    double get ();
    void set (double value);
}
member RpropDWMax : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.RpropDWMin Property

ANN_MLPRpropDWMin Property

RPROP: Update-values lower limit

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RpropDWMin { get; set; }
Public Property RpropDWMin As Double
    Get
    Set
public:
property double RpropDWMin {
    double get ();
    void set (double value);
}
member RpropDWMin : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.RpropDWMinus Property

ANN_MLPRpropDWMinus Property

RPROP: Decrease factor

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RpropDWMinus { get; set; }
Public Property RpropDWMinus As Double
    Get
    Set
public:
property double RpropDWMinus {
    double get ();
    void set (double value);
}
member RpropDWMinus : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.RpropDWPlus Property

ANN_MLPRpropDWPlus Property

RPROP: Increase factor

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RpropDWPlus { get; set; }
Public Property RpropDWPlus As Double
    Get
    Set
public:
property double RpropDWPlus {
    double get ();
    void set (double value);
}
member RpropDWPlus : float with get, set

Property Value

Type: Double
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.TermCriteria Property

ANN_MLPTermCriteria Property

Termination criteria of the training algorithm

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria TermCriteria { get; set; }
Public Property TermCriteria As MCvTermCriteria
    Get
    Set
public:
property MCvTermCriteria^ TermCriteria {
    MCvTermCriteria^ get ();
    void set (MCvTermCriteria^ value);
}
member TermCriteria : MCvTermCriteria with get, set

Property Value

Type: MCvTermCriteria
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP Methods

The ANN_MLP type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this neural network (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetActivationFunction | Initialize the activation function for each neuron.
Public method | SetLayerSizes | Sets the layer sizes.
Public method | SetTrainMethod | Sets training method and common parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.DisposeObject Method

ANN_MLPDisposeObject Method

Release the memory associated with this neural network

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.SetActivationFunction Method

ANN_MLPSetActivationFunction Method

Initialize the activation function for each neuron.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetActivationFunction(
    ANN_MLPAnnMlpActivationFunction function,
    double param1 = 0,
    double param2 = 0
)
Public Sub SetActivationFunction (
    function As ANN_MLPAnnMlpActivationFunction,
    Optional param1 As Double = 0,
    Optional param2 As Double = 0
)
public:
void SetActivationFunction(
    ANN_MLPAnnMlpActivationFunction^ function,
    double param1 = 0,
    double param2 = 0
)
member SetActivationFunction :
        function : ANN_MLPAnnMlpActivationFunction *
        ?param1 : float *
        ?param2 : float
(* Defaults:
        let _param1 = defaultArg param1 0
        let _param2 = defaultArg param2 0
*)
-> unit

Parameters

function
Type: Emgu.CV.MLANN_MLPAnnMlpActivationFunction
Currently the default and the only fully supported activation function is SigmoidSym
param1 (Optional)
Type: SystemDouble
The first parameter of the activation function.
param2 (Optional)
Type: SystemDouble
The second parameter of the activation function.
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.SetLayerSizes Method

ANN_MLPSetLayerSizes Method

Sets the layer sizes.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetLayerSizes(
    IInputArray layerSizes
)
Public Sub SetLayerSizes (
    layerSizes As IInputArray
)
public:
void SetLayerSizes(
    IInputArray^ layerSizes
)
member SetLayerSizes :
        layerSizes : IInputArray -> unit

Parameters

layerSizes
Type: Emgu.CVIInputArray
Integer vector specifying the number of neurons in each layer including the input and output layers. The very first element specifies the number of elements in the input layer. The last element - number of elements in the output layer.
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.SetTrainMethod Method

ANN_MLPSetTrainMethod Method

Sets training method and common parameters.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTrainMethod(
    ANN_MLPAnnMlpTrainMethod method = 1,
    double param1 = 0,
    double param2 = 0
)
Public Sub SetTrainMethod (
    Optional method As ANN_MLPAnnMlpTrainMethod = 1,
    Optional param1 As Double = 0,
    Optional param2 As Double = 0
)
public:
void SetTrainMethod(
    ANN_MLPAnnMlpTrainMethod^ method = 1,
    double param1 = 0,
    double param2 = 0
)
member SetTrainMethod :
        ?method : ANN_MLPAnnMlpTrainMethod *
        ?param1 : float *
        ?param2 : float
(* Defaults:
        let _method = defaultArg method 1
        let _param1 = defaultArg param1 0
        let _param2 = defaultArg param2 0
*)
-> unit

Parameters

method (Optional)
Type: Emgu.CV.MLANN_MLPAnnMlpTrainMethod
The training method.
param1 (Optional)
Type: SystemDouble
param1 passed to setRpropDW0 for ANN_MLP::RPROP and to setBackpropWeightScale for ANN_MLP::BACKPROP and to initialT for ANN_MLP::ANNEAL.
param2 (Optional)
Type: SystemDouble
param2 passed to setRpropDWMin for ANN_MLP::RPROP and to setBackpropMomentumScale for ANN_MLP::BACKPROP and to finalT for ANN_MLP::ANNEAL.
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP Fields

The ANN_MLP type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ANN_MLP Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpActivationFunction Class

ANN_MLPAnnMlpActivationFunction Class

Possible activation functions
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLANN_MLPAnnMlpActivationFunction

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class AnnMlpActivationFunction : Enum
Public NotInheritable Class AnnMlpActivationFunction
    Inherits Enum
public ref class AnnMlpActivationFunction sealed : public Enum
[<SealedAttribute>]
type AnnMlpActivationFunction =
    class
        inherit Enum
    end

The ANN_MLPAnnMlpActivationFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Gaussian | Gaussian function: f(x)=beta e^{-alpha x*x}
 | Identity | Identity function: f(x)=x
 | LeakyRelu | Leaky ReLU function: for x>0, $f(x)=x; and x<=0, f(x)=alpha x
 | Relu | ReLU function: f(x)=max(0,x)
 | SigmoidSym | Symmetrical sigmoid: f(x)=beta*(1-e^{-alpha x})/(1+e^{-alpha x})
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


AnnMlpActivationFunction Methods

The ANN_MLPAnnMlpActivationFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


AnnMlpActivationFunction Fields

The ANN_MLPAnnMlpActivationFunction type exposes the following members.

Fields
 | Name | Description
 | Gaussian | Gaussian function: f(x)=beta e^{-alpha x*x}
 | Identity | Identity function: f(x)=x
 | LeakyRelu | Leaky ReLU function: for x>0, $f(x)=x; and x<=0, f(x)=alpha x
 | Relu | ReLU function: f(x)=max(0,x)
 | SigmoidSym | Symmetrical sigmoid: f(x)=beta*(1-e^{-alpha x})/(1+e^{-alpha x})
Public field | value__ |
Top
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpActivationFunction.Gaussian Field

ANN_MLPAnnMlpActivationFunctionGaussian Field

Gaussian function: f(x)=beta e^{-alpha x*x}

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpActivationFunction Gaussian = 2
Public Const Gaussian As ANN_MLPAnnMlpActivationFunction = 2
public:
literal ANN_MLPAnnMlpActivationFunction^ Gaussian = 2
static val mutable Gaussian: ANN_MLPAnnMlpActivationFunction

Field Value

Type: ANN_MLPAnnMlpActivationFunction
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpActivationFunction.Identity Field

ANN_MLPAnnMlpActivationFunctionIdentity Field

Identity function: f(x)=x

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpActivationFunction Identity = 0
Public Const Identity As ANN_MLPAnnMlpActivationFunction = 0
public:
literal ANN_MLPAnnMlpActivationFunction^ Identity = 0
static val mutable Identity: ANN_MLPAnnMlpActivationFunction

Field Value

Type: ANN_MLPAnnMlpActivationFunction
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpActivationFunction.LeakyRelu Field

ANN_MLPAnnMlpActivationFunctionLeakyRelu Field

Leaky ReLU function: for x>0, $f(x)=x; and x<=0, f(x)=alpha x

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpActivationFunction LeakyRelu = 4
Public Const LeakyRelu As ANN_MLPAnnMlpActivationFunction = 4
public:
literal ANN_MLPAnnMlpActivationFunction^ LeakyRelu = 4
static val mutable LeakyRelu: ANN_MLPAnnMlpActivationFunction

Field Value

Type: ANN_MLPAnnMlpActivationFunction
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpActivationFunction.Relu Field

ANN_MLPAnnMlpActivationFunctionRelu Field

ReLU function: f(x)=max(0,x)

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpActivationFunction Relu = 3
Public Const Relu As ANN_MLPAnnMlpActivationFunction = 3
public:
literal ANN_MLPAnnMlpActivationFunction^ Relu = 3
static val mutable Relu: ANN_MLPAnnMlpActivationFunction

Field Value

Type: ANN_MLPAnnMlpActivationFunction
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpActivationFunction.SigmoidSym Field

ANN_MLPAnnMlpActivationFunctionSigmoidSym Field

Symmetrical sigmoid: f(x)=beta*(1-e^{-alpha x})/(1+e^{-alpha x})

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpActivationFunction SigmoidSym = 1
Public Const SigmoidSym As ANN_MLPAnnMlpActivationFunction = 1
public:
literal ANN_MLPAnnMlpActivationFunction^ SigmoidSym = 1
static val mutable SigmoidSym: ANN_MLPAnnMlpActivationFunction

Field Value

Type: ANN_MLPAnnMlpActivationFunction
Remarks
If you are using the default sigmoid activation function with the default parameter values fparam1 = 0 and fparam2 = 0 then the function used is y = 1.7159 * tanh(2/3 * x), so the output will range from[-1.7159, 1.7159], instead of[0, 1].
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpActivationFunction.value__ Field

ANN_MLPAnnMlpActivationFunctionvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.ANN_MLP.AnnMlpActivationFunction.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ANN_MLPAnnMlpActivationFunction Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpTrainMethod Class

ANN_MLPAnnMlpTrainMethod Class

Training method for ANN_MLP
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLANN_MLPAnnMlpTrainMethod

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class AnnMlpTrainMethod : Enum
Public NotInheritable Class AnnMlpTrainMethod
    Inherits Enum
public ref class AnnMlpTrainMethod sealed : public Enum
[<SealedAttribute>]
type AnnMlpTrainMethod =
    class
        inherit Enum
    end

The ANN_MLPAnnMlpTrainMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Anneal | The simulated annealing algorithm.
 | Backprop | Back-propagation algorithm
 | Rprop | Batch RPROP algorithm
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


AnnMlpTrainMethod Methods

The ANN_MLPAnnMlpTrainMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ANN_MLPAnnMlpTrainMethod Class
Emgu.CV.ML Namespace


AnnMlpTrainMethod Fields

The ANN_MLPAnnMlpTrainMethod type exposes the following members.

Fields
 | Name | Description
 | Anneal | The simulated annealing algorithm.
 | Backprop | Back-propagation algorithm
 | Rprop | Batch RPROP algorithm
Public field | value__ |
Top
See Also

Reference

ANN_MLPAnnMlpTrainMethod Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpTrainMethod.Anneal Field

ANN_MLPAnnMlpTrainMethodAnneal Field

The simulated annealing algorithm.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpTrainMethod Anneal = 2
Public Const Anneal As ANN_MLPAnnMlpTrainMethod = 2
public:
literal ANN_MLPAnnMlpTrainMethod^ Anneal = 2
static val mutable Anneal: ANN_MLPAnnMlpTrainMethod

Field Value

Type: ANN_MLPAnnMlpTrainMethod
See Also

Reference

ANN_MLPAnnMlpTrainMethod Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpTrainMethod.Backprop Field

ANN_MLPAnnMlpTrainMethodBackprop Field

Back-propagation algorithm

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpTrainMethod Backprop = 0
Public Const Backprop As ANN_MLPAnnMlpTrainMethod = 0
public:
literal ANN_MLPAnnMlpTrainMethod^ Backprop = 0
static val mutable Backprop: ANN_MLPAnnMlpTrainMethod

Field Value

Type: ANN_MLPAnnMlpTrainMethod
See Also

Reference

ANN_MLPAnnMlpTrainMethod Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpTrainMethod.Rprop Field

ANN_MLPAnnMlpTrainMethodRprop Field

Batch RPROP algorithm

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ANN_MLPAnnMlpTrainMethod Rprop = 1
Public Const Rprop As ANN_MLPAnnMlpTrainMethod = 1
public:
literal ANN_MLPAnnMlpTrainMethod^ Rprop = 1
static val mutable Rprop: ANN_MLPAnnMlpTrainMethod

Field Value

Type: ANN_MLPAnnMlpTrainMethod
See Also

Reference

ANN_MLPAnnMlpTrainMethod Class
Emgu.CV.ML Namespace


ANN_MLP.AnnMlpTrainMethod.value__ Field

ANN_MLPAnnMlpTrainMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.ANN_MLP.AnnMlpTrainMethod.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ANN_MLPAnnMlpTrainMethod Class
Emgu.CV.ML Namespace


Boost Class

Boost Tree
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLBoost

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Boost : UnmanagedObject, IStatModel,
    IAlgorithm
Public Class Boost
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class Boost : public UnmanagedObject,
    IStatModel, IAlgorithm
type Boost =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The Boost type exposes the following members.

Constructors
 | Name | Description
Public method | Boost | Create a default Boost classifier
Top
Properties
 | Name | Description
Public property | CVFolds | If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold
Public property | MaxCategories | Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split
Public property | MaxDepth | The maximum possible depth of the tree
Public property | MinSampleCount | If the number of samples in a node is less than this parameter then the node will not be split
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegressionAccuracy | Termination criteria for regression trees
Public property | TruncatePrunedTree | If true then pruned branches are physically removed from the tree
Public property | Use1SERule | If true then a pruning will be harsher
Public property | UseSurrogates | If true then surrogate splits will be built
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the Boost classifier and all memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


Boost Constructor

Create a default Boost classifier

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Boost()
Public Sub New
public:
Boost()
new : unit -> Boost
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost Properties

The Boost type exposes the following members.

Properties
 | Name | Description
Public property | CVFolds | If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold
Public property | MaxCategories | Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split
Public property | MaxDepth | The maximum possible depth of the tree
Public property | MinSampleCount | If the number of samples in a node is less than this parameter then the node will not be split
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegressionAccuracy | Termination criteria for regression trees
Public property | TruncatePrunedTree | If true then pruned branches are physically removed from the tree
Public property | Use1SERule | If true then a pruning will be harsher
Public property | UseSurrogates | If true then surrogate splits will be built
Top
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.CVFolds Property

BoostCVFolds Property

If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CVFolds { get; set; }
Public Property CVFolds As Integer
    Get
    Set
public:
property int CVFolds {
    int get ();
    void set (int value);
}
member CVFolds : int with get, set

Property Value

Type: Int32
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.MaxCategories Property

BoostMaxCategories Property

Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxCategories { get; set; }
Public Property MaxCategories As Integer
    Get
    Set
public:
property int MaxCategories {
    int get ();
    void set (int value);
}
member MaxCategories : int with get, set

Property Value

Type: Int32
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.MaxDepth Property

BoostMaxDepth Property

The maximum possible depth of the tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxDepth { get; set; }
Public Property MaxDepth As Integer
    Get
    Set
public:
property int MaxDepth {
    int get ();
    void set (int value);
}
member MaxDepth : int with get, set

Property Value

Type: Int32
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.MinSampleCount Property

BoostMinSampleCount Property

If the number of samples in a node is less than this parameter then the node will not be split

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MinSampleCount { get; set; }
Public Property MinSampleCount As Integer
    Get
    Set
public:
property int MinSampleCount {
    int get ();
    void set (int value);
}
member MinSampleCount : int with get, set

Property Value

Type: Int32
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.RegressionAccuracy Property

BoostRegressionAccuracy Property

Termination criteria for regression trees

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float RegressionAccuracy { get; set; }
Public Property RegressionAccuracy As Single
    Get
    Set
public:
property float RegressionAccuracy {
    float get ();
    void set (float value);
}
member RegressionAccuracy : float32 with get, set

Property Value

Type: Single
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.TruncatePrunedTree Property

BoostTruncatePrunedTree Property

If true then pruned branches are physically removed from the tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TruncatePrunedTree { get; set; }
Public Property TruncatePrunedTree As Boolean
    Get
    Set
public:
property bool TruncatePrunedTree {
    bool get ();
    void set (bool value);
}
member TruncatePrunedTree : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.Use1SERule Property

BoostUse1SERule Property

If true then a pruning will be harsher

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Use1SERule { get; set; }
Public Property Use1SERule As Boolean
    Get
    Set
public:
property bool Use1SERule {
    bool get ();
    void set (bool value);
}
member Use1SERule : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.UseSurrogates Property

BoostUseSurrogates Property

If true then surrogate splits will be built

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseSurrogates { get; set; }
Public Property UseSurrogates As Boolean
    Get
    Set
public:
property bool UseSurrogates {
    bool get ();
    void set (bool value);
}
member UseSurrogates : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost Methods

The Boost type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the Boost classifier and all memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.DisposeObject Method

BoostDisposeObject Method

Release the Boost classifier and all memory associate with it

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost Fields

The Boost type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Boost Class
Emgu.CV.ML Namespace


Boost.Type Class

BoostType Class

Boost Type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLBoostType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Type : Enum
Public NotInheritable Class Type
    Inherits Enum
public ref class Type sealed : public Enum
[<SealedAttribute>]
type Type =
    class
        inherit Enum
    end

The BoostType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Discrete | Discrete AdaBoost.
 | Gentle | Gentle AdaBoost. It puts less weight on outlier data points and for that reason is often good with regression data.
 | Logit | LogitBoost. It can produce good regression fits.
 | Real | Real AdaBoost. It is a technique that utilizes confidence-rated predictions and works well with categorical data.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


Type Methods

The BoostType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BoostType Class
Emgu.CV.ML Namespace


Type Fields

The BoostType type exposes the following members.

Fields
 | Name | Description
 | Discrete | Discrete AdaBoost.
 | Gentle | Gentle AdaBoost. It puts less weight on outlier data points and for that reason is often good with regression data.
 | Logit | LogitBoost. It can produce good regression fits.
 | Real | Real AdaBoost. It is a technique that utilizes confidence-rated predictions and works well with categorical data.
Public field | value__ |
Top
See Also

Reference

BoostType Class
Emgu.CV.ML Namespace


Boost.Type.Discrete Field

BoostTypeDiscrete Field

Discrete AdaBoost.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Discrete = 0
Public Const Discrete As BoostType = 0
public:
literal BoostType^ Discrete = 0
static val mutable Discrete: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML Namespace


Boost.Type.Gentle Field

BoostTypeGentle Field

Gentle AdaBoost. It puts less weight on outlier data points and for that reason is often good with regression data.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Gentle = 3
Public Const Gentle As BoostType = 3
public:
literal BoostType^ Gentle = 3
static val mutable Gentle: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML Namespace


Boost.Type.Logit Field

BoostTypeLogit Field

LogitBoost. It can produce good regression fits.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Logit = 2
Public Const Logit As BoostType = 2
public:
literal BoostType^ Logit = 2
static val mutable Logit: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML Namespace


Boost.Type.Real Field

BoostTypeReal Field

Real AdaBoost. It is a technique that utilizes confidence-rated predictions and works well with categorical data.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Real = 1
Public Const Real As BoostType = 1
public:
literal BoostType^ Real = 1
static val mutable Real: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML Namespace


Boost.Type.value__ Field

BoostTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.Boost.Type.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BoostType Class
Emgu.CV.ML Namespace


DTrees Class

Decision Trees
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLDTrees

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DTrees : UnmanagedObject, IStatModel,
    IAlgorithm
Public Class DTrees
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class DTrees : public UnmanagedObject,
    IStatModel, IAlgorithm
type DTrees =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The DTrees type exposes the following members.

Constructors
 | Name | Description
Public method | DTrees | Create a default decision tree
Top
Properties
 | Name | Description
Public property | CVFolds | If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold
Public property | MaxCategories | Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split
Public property | MaxDepth | The maximum possible depth of the tree
Public property | MinSampleCount | If the number of samples in a node is less than this parameter then the node will not be split
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegressionAccuracy | Termination criteria for regression trees
Public property | TruncatePrunedTree | If true then pruned branches are physically removed from the tree
Public property | Use1SERule | If true then a pruning will be harsher
Public property | UseSurrogates | If true then surrogate splits will be built
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the decision tree and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


DTrees Constructor

Create a default decision tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DTrees()
Public Sub New
public:
DTrees()
new : unit -> DTrees
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees Properties

The DTrees type exposes the following members.

Properties
 | Name | Description
Public property | CVFolds | If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold
Public property | MaxCategories | Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split
Public property | MaxDepth | The maximum possible depth of the tree
Public property | MinSampleCount | If the number of samples in a node is less than this parameter then the node will not be split
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegressionAccuracy | Termination criteria for regression trees
Public property | TruncatePrunedTree | If true then pruned branches are physically removed from the tree
Public property | Use1SERule | If true then a pruning will be harsher
Public property | UseSurrogates | If true then surrogate splits will be built
Top
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.CVFolds Property

DTreesCVFolds Property

If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CVFolds { get; set; }
Public Property CVFolds As Integer
    Get
    Set
public:
property int CVFolds {
    int get ();
    void set (int value);
}
member CVFolds : int with get, set

Property Value

Type: Int32
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.MaxCategories Property

DTreesMaxCategories Property

Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxCategories { get; set; }
Public Property MaxCategories As Integer
    Get
    Set
public:
property int MaxCategories {
    int get ();
    void set (int value);
}
member MaxCategories : int with get, set

Property Value

Type: Int32
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.MaxDepth Property

DTreesMaxDepth Property

The maximum possible depth of the tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxDepth { get; set; }
Public Property MaxDepth As Integer
    Get
    Set
public:
property int MaxDepth {
    int get ();
    void set (int value);
}
member MaxDepth : int with get, set

Property Value

Type: Int32
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.MinSampleCount Property

DTreesMinSampleCount Property

If the number of samples in a node is less than this parameter then the node will not be split

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MinSampleCount { get; set; }
Public Property MinSampleCount As Integer
    Get
    Set
public:
property int MinSampleCount {
    int get ();
    void set (int value);
}
member MinSampleCount : int with get, set

Property Value

Type: Int32
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.RegressionAccuracy Property

DTreesRegressionAccuracy Property

Termination criteria for regression trees

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float RegressionAccuracy { get; set; }
Public Property RegressionAccuracy As Single
    Get
    Set
public:
property float RegressionAccuracy {
    float get ();
    void set (float value);
}
member RegressionAccuracy : float32 with get, set

Property Value

Type: Single
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.TruncatePrunedTree Property

DTreesTruncatePrunedTree Property

If true then pruned branches are physically removed from the tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TruncatePrunedTree { get; set; }
Public Property TruncatePrunedTree As Boolean
    Get
    Set
public:
property bool TruncatePrunedTree {
    bool get ();
    void set (bool value);
}
member TruncatePrunedTree : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.Use1SERule Property

DTreesUse1SERule Property

If true then a pruning will be harsher

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Use1SERule { get; set; }
Public Property Use1SERule As Boolean
    Get
    Set
public:
property bool Use1SERule {
    bool get ();
    void set (bool value);
}
member Use1SERule : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.UseSurrogates Property

DTreesUseSurrogates Property

If true then surrogate splits will be built

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseSurrogates { get; set; }
Public Property UseSurrogates As Boolean
    Get
    Set
public:
property bool UseSurrogates {
    bool get ();
    void set (bool value);
}
member UseSurrogates : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees Methods

The DTrees type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the decision tree and all the memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.DisposeObject Method

DTreesDisposeObject Method

Release the decision tree and all the memory associate with it

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees Fields

The DTrees type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DTrees Class
Emgu.CV.ML Namespace


DTrees.Flags Class

DTreesFlags Class

Predict options
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLDTreesFlags

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Flags : Enum
Public NotInheritable Class Flags
    Inherits Enum
public ref class Flags sealed : public Enum
[<SealedAttribute>]
type Flags =
    class
        inherit Enum
    end

The DTreesFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | PredictAuto | Predict auto
 | PredictMask | Predict mask
 | PredictMaxVote | Predict max vote
 | PredictSum | Predict sum
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


Flags Methods

The DTreesFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DTreesFlags Class
Emgu.CV.ML Namespace


Flags Fields

The DTreesFlags type exposes the following members.

Fields
 | Name | Description
 | PredictAuto | Predict auto
 | PredictMask | Predict mask
 | PredictMaxVote | Predict max vote
 | PredictSum | Predict sum
Public field | value__ |
Top
See Also

Reference

DTreesFlags Class
Emgu.CV.ML Namespace


DTrees.Flags.PredictAuto Field

DTreesFlagsPredictAuto Field

Predict auto

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DTreesFlags PredictAuto = 0
Public Const PredictAuto As DTreesFlags = 0
public:
literal DTreesFlags^ PredictAuto = 0
static val mutable PredictAuto: DTreesFlags

Field Value

Type: DTreesFlags
See Also

Reference

DTreesFlags Class
Emgu.CV.ML Namespace


DTrees.Flags.PredictMask Field

DTreesFlagsPredictMask Field

Predict mask

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DTreesFlags PredictMask = 768
Public Const PredictMask As DTreesFlags = 768
public:
literal DTreesFlags^ PredictMask = 768
static val mutable PredictMask: DTreesFlags

Field Value

Type: DTreesFlags
See Also

Reference

DTreesFlags Class
Emgu.CV.ML Namespace


DTrees.Flags.PredictMaxVote Field

DTreesFlagsPredictMaxVote Field

Predict max vote

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DTreesFlags PredictMaxVote = 512
Public Const PredictMaxVote As DTreesFlags = 512
public:
literal DTreesFlags^ PredictMaxVote = 512
static val mutable PredictMaxVote: DTreesFlags

Field Value

Type: DTreesFlags
See Also

Reference

DTreesFlags Class
Emgu.CV.ML Namespace


DTrees.Flags.PredictSum Field

DTreesFlagsPredictSum Field

Predict sum

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DTreesFlags PredictSum = 256
Public Const PredictSum As DTreesFlags = 256
public:
literal DTreesFlags^ PredictSum = 256
static val mutable PredictSum: DTreesFlags

Field Value

Type: DTreesFlags
See Also

Reference

DTreesFlags Class
Emgu.CV.ML Namespace


DTrees.Flags.value__ Field

DTreesFlagsvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.DTrees.Flags.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DTreesFlags Class
Emgu.CV.ML Namespace


EM Class

Expectation Maximization model
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLEM

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class EM : UnmanagedObject, IStatModel, IAlgorithm
Public Class EM
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class EM : public UnmanagedObject,
    IStatModel, IAlgorithm
type EM =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The EM type exposes the following members.

Constructors
 | Name | Description
Public method | EM | Create an Expectation Maximization model
Top
Properties
 | Name | Description
Public property | ClustersNumber | The number of mixtures
Public property | CovarianceMatrixType | The type of the mixture covariation matrices
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TermCriteria | Termination criteria of the procedure. EM algorithm stops either after a certain number of iterations (term_crit.num_iter), or when the parameters change too little (no more than term_crit.epsilon) from iteration to iteration
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this EM model (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the probability of the samples
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | trainE | Estimate the Gaussian mixture parameters from a samples set. This variation starts with Expectation step. You need to provide initial means of mixture components. Optionally you can pass initial weights and covariance matrices of mixture components.
Public method | TrainM | Estimate the Gaussian mixture parameters from a samples set. This variation starts with Expectation step. Initial values of the model parameters will be estimated by the k-means algorithm. Unlike many of the ML models, EM is an unsupervised learning algorithm and it does not take responses (class labels or function values) as input. Instead, it computes the Maximum Likelihood Estimate of the Gaussian mixture parameters from an input sample set, stores all the parameters inside the structure, and optionally computes the output "class label" for each sample. The trained model can be used further for prediction, just like any other classifier.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


EM Constructor

Create an Expectation Maximization model

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EM()
Public Sub New
public:
EM()
new : unit -> EM
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM Properties

The EM type exposes the following members.

Properties
 | Name | Description
Public property | ClustersNumber | The number of mixtures
Public property | CovarianceMatrixType | The type of the mixture covariation matrices
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TermCriteria | Termination criteria of the procedure. EM algorithm stops either after a certain number of iterations (term_crit.num_iter), or when the parameters change too little (no more than term_crit.epsilon) from iteration to iteration
Top
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.ClustersNumber Property

EMClustersNumber Property

The number of mixtures

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ClustersNumber { get; set; }
Public Property ClustersNumber As Integer
    Get
    Set
public:
property int ClustersNumber {
    int get ();
    void set (int value);
}
member ClustersNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.CovarianceMatrixType Property

EMCovarianceMatrixType Property

The type of the mixture covariation matrices

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EMCovarianMatrixType CovarianceMatrixType { get; set; }
Public Property CovarianceMatrixType As EMCovarianMatrixType
    Get
    Set
public:
property EMCovarianMatrixType^ CovarianceMatrixType {
    EMCovarianMatrixType^ get ();
    void set (EMCovarianMatrixType^ value);
}
member CovarianceMatrixType : EMCovarianMatrixType with get, set

Property Value

Type: EMCovarianMatrixType
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.TermCriteria Property

EMTermCriteria Property

Termination criteria of the procedure. EM algorithm stops either after a certain number of iterations (term_crit.num_iter), or when the parameters change too little (no more than term_crit.epsilon) from iteration to iteration

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria TermCriteria { get; set; }
Public Property TermCriteria As MCvTermCriteria
    Get
    Set
public:
property MCvTermCriteria^ TermCriteria {
    MCvTermCriteria^ get ();
    void set (MCvTermCriteria^ value);
}
member TermCriteria : MCvTermCriteria with get, set

Property Value

Type: MCvTermCriteria
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM Methods

The EM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this EM model (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Predict | Predict the probability of the samples
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | trainE | Estimate the Gaussian mixture parameters from a samples set. This variation starts with Expectation step. You need to provide initial means of mixture components. Optionally you can pass initial weights and covariance matrices of mixture components.
Public method | TrainM | Estimate the Gaussian mixture parameters from a samples set. This variation starts with Expectation step. Initial values of the model parameters will be estimated by the k-means algorithm. Unlike many of the ML models, EM is an unsupervised learning algorithm and it does not take responses (class labels or function values) as input. Instead, it computes the Maximum Likelihood Estimate of the Gaussian mixture parameters from an input sample set, stores all the parameters inside the structure, and optionally computes the output "class label" for each sample. The trained model can be used further for prediction, just like any other classifier.
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.DisposeObject Method

EMDisposeObject Method

Release the memory associated with this EM model

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.Predict Method

EMPredict Method

Predict the probability of the samples

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint2D64f Predict(
    IInputArray samples,
    IOutputArray probs = null
)
Public Function Predict (
    samples As IInputArray,
    Optional probs As IOutputArray = Nothing
) As MCvPoint2D64f
public:
MCvPoint2D64f^ Predict(
    IInputArray^ samples,
    IOutputArray^ probs = nullptr
)
member Predict :
        samples : IInputArray *
        ?probs : IOutputArray
(* Defaults:
        let _probs = defaultArg probs null
*)
-> MCvPoint2D64f

Parameters

samples
Type: Emgu.CVIInputArray
The input samples
probs (Optional)
Type: Emgu.CVIOutputArray
The prediction results, should have the same # of rows as the samples

Return Value

Type: MCvPoint2D64f
The results
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.trainE Method

EMtrainE Method

Estimate the Gaussian mixture parameters from a samples set. This variation starts with Expectation step. You need to provide initial means of mixture components. Optionally you can pass initial weights and covariance matrices of mixture components.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void trainE(
    IInputArray samples,
    IInputArray means0,
    IInputArray covs0 = null,
    IInputArray weights0 = null,
    IOutputArray loglikelihoods = null,
    IOutputArray labels = null,
    IOutputArray probs = null
)
Public Sub trainE (
    samples As IInputArray,
    means0 As IInputArray,
    Optional covs0 As IInputArray = Nothing,
    Optional weights0 As IInputArray = Nothing,
    Optional loglikelihoods As IOutputArray = Nothing,
    Optional labels As IOutputArray = Nothing,
    Optional probs As IOutputArray = Nothing
)
public:
void trainE(
    IInputArray^ samples,
    IInputArray^ means0,
    IInputArray^ covs0 = nullptr,
    IInputArray^ weights0 = nullptr,
    IOutputArray^ loglikelihoods = nullptr,
    IOutputArray^ labels = nullptr,
    IOutputArray^ probs = nullptr
)
member trainE :
        samples : IInputArray *
        means0 : IInputArray *
        ?covs0 : IInputArray *
        ?weights0 : IInputArray *
        ?loglikelihoods : IOutputArray *
        ?labels : IOutputArray *
        ?probs : IOutputArray
(* Defaults:
        let _covs0 = defaultArg covs0 null
        let _weights0 = defaultArg weights0 null
        let _loglikelihoods = defaultArg loglikelihoods null
        let _labels = defaultArg labels null
        let _probs = defaultArg probs null
*)
-> unit

Parameters

samples
Type: Emgu.CVIInputArray
Samples from which the Gaussian mixture model will be estimated. It should be a one-channel matrix, each row of which is a sample. If the matrix does not have CV_64F type it will be converted to the inner matrix of such type for the further computing.
means0
Type: Emgu.CVIInputArray
Initial means of mixture components. It is a one-channel matrix of nclusters x dims size. If the matrix does not have CV_64F type it will be converted to the inner matrix of such type for the further computing.
covs0 (Optional)
Type: Emgu.CVIInputArray
The vector of initial covariance matrices of mixture components. Each of covariance matrices is a one-channel matrix of dims x dims size. If the matrices do not have CV_64F type they will be converted to the inner matrices of such type for the further computing.
weights0 (Optional)
Type: Emgu.CVIInputArray
Initial weights of mixture components. It should be a one-channel floating-point matrix with 1 x nclusters or nclusters x 1 size.
loglikelihoods (Optional)
Type: Emgu.CVIOutputArray
The optional output matrix that contains a likelihood logarithm value for each sample. It has nsamples x 1 size and CV_64FC1 type.
labels (Optional)
Type: Emgu.CVIOutputArray
The optional output "class label" (indices of the most probable mixture component for each sample). It has nsamples x 1 size and CV_32SC1 type.
probs (Optional)
Type: Emgu.CVIOutputArray
The optional output matrix that contains posterior probabilities of each Gaussian mixture component given the each sample. It has nsamples x nclusters size and CV_64FC1 type.
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.TrainM Method

EMTrainM Method

Estimate the Gaussian mixture parameters from a samples set. This variation starts with Expectation step. Initial values of the model parameters will be estimated by the k-means algorithm. Unlike many of the ML models, EM is an unsupervised learning algorithm and it does not take responses (class labels or function values) as input. Instead, it computes the Maximum Likelihood Estimate of the Gaussian mixture parameters from an input sample set, stores all the parameters inside the structure, and optionally computes the output "class label" for each sample. The trained model can be used further for prediction, just like any other classifier.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void TrainM(
    IInputArray samples,
    IInputArray probs0,
    IOutputArray logLikelihoods = null,
    IOutputArray labels = null,
    IOutputArray probs = null
)
Public Sub TrainM (
    samples As IInputArray,
    probs0 As IInputArray,
    Optional logLikelihoods As IOutputArray = Nothing,
    Optional labels As IOutputArray = Nothing,
    Optional probs As IOutputArray = Nothing
)
public:
void TrainM(
    IInputArray^ samples,
    IInputArray^ probs0,
    IOutputArray^ logLikelihoods = nullptr,
    IOutputArray^ labels = nullptr,
    IOutputArray^ probs = nullptr
)
member TrainM :
        samples : IInputArray *
        probs0 : IInputArray *
        ?logLikelihoods : IOutputArray *
        ?labels : IOutputArray *
        ?probs : IOutputArray
(* Defaults:
        let _logLikelihoods = defaultArg logLikelihoods null
        let _labels = defaultArg labels null
        let _probs = defaultArg probs null
*)
-> unit

Parameters

samples
Type: Emgu.CVIInputArray
Samples from which the Gaussian mixture model will be estimated. It should be a one-channel matrix, each row of which is a sample. If the matrix does not have CV_64F type it will be converted to the inner matrix of such type for the further computing.
probs0
Type: Emgu.CVIInputArray
The probs0.
logLikelihoods (Optional)
Type: Emgu.CVIOutputArray
The optional output matrix that contains a likelihood logarithm value for each sample. It has nsamples x 1 size and CV_64FC1 type.
labels (Optional)
Type: Emgu.CVIOutputArray
The optional output "class label" for each sample(indices of the most probable mixture component for each sample). It has nsamples x 1 size and CV_32SC1 type.
probs (Optional)
Type: Emgu.CVIOutputArray
The optional output matrix that contains posterior probabilities of each Gaussian mixture component given the each sample. It has nsamples x nclusters size and CV_64FC1 type.
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM Fields

The EM type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

EM Class
Emgu.CV.ML Namespace


EM.CovarianMatrixType Class

EMCovarianMatrixType Class

The type of the mixture covariation matrices
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLEMCovarianMatrixType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CovarianMatrixType : Enum
Public NotInheritable Class CovarianMatrixType
    Inherits Enum
public ref class CovarianMatrixType sealed : public Enum
[<SealedAttribute>]
type CovarianMatrixType =
    class
        inherit Enum
    end

The EMCovarianMatrixType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The default
 | Diagonal | A covariation matrix of each mixture may be arbitrary diagonal matrix with positive diagonal elements, that is, non-diagonal elements are forced to be 0's, so the number of free parameters is d for each matrix. This is most commonly used option yielding good estimation results
 | Generic | A covariation matrix of each mixture may be arbitrary symmetrical positively defined matrix, so the number of free parameters in each matrix is about d2/2. It is not recommended to use this option, unless there is pretty accurate initial estimation of the parameters and/or a huge number of training samples
 | Spherical | A covariation matrix of each mixture is a scaled identity matrix, ?k*I, so the only parameter to be estimated is ?k. The option may be used in special cases, when the constraint is relevant, or as a first step in the optimization (e.g. in case when the data is preprocessed with PCA). The results of such preliminary estimation may be passed again to the optimization procedure, this time with cov_mat_type=COV_MAT_DIAGONAL
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


CovarianMatrixType Methods

The EMCovarianMatrixType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

EMCovarianMatrixType Class
Emgu.CV.ML Namespace


CovarianMatrixType Fields

The EMCovarianMatrixType type exposes the following members.

Fields
 | Name | Description
 | Default | The default
 | Diagonal | A covariation matrix of each mixture may be arbitrary diagonal matrix with positive diagonal elements, that is, non-diagonal elements are forced to be 0's, so the number of free parameters is d for each matrix. This is most commonly used option yielding good estimation results
 | Generic | A covariation matrix of each mixture may be arbitrary symmetrical positively defined matrix, so the number of free parameters in each matrix is about d2/2. It is not recommended to use this option, unless there is pretty accurate initial estimation of the parameters and/or a huge number of training samples
 | Spherical | A covariation matrix of each mixture is a scaled identity matrix, ?k*I, so the only parameter to be estimated is ?k. The option may be used in special cases, when the constraint is relevant, or as a first step in the optimization (e.g. in case when the data is preprocessed with PCA). The results of such preliminary estimation may be passed again to the optimization procedure, this time with cov_mat_type=COV_MAT_DIAGONAL
Public field | value__ |
Top
See Also

Reference

EMCovarianMatrixType Class
Emgu.CV.ML Namespace


EM.CovarianMatrixType.Default Field

EMCovarianMatrixTypeDefault Field

The default

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EMCovarianMatrixType Default = 1
Public Const Default As EMCovarianMatrixType = 1
public:
literal EMCovarianMatrixType^ Default = 1
static val mutable Default: EMCovarianMatrixType

Field Value

Type: EMCovarianMatrixType
See Also

Reference

EMCovarianMatrixType Class
Emgu.CV.ML Namespace


EM.CovarianMatrixType.Diagonal Field

EMCovarianMatrixTypeDiagonal Field

A covariation matrix of each mixture may be arbitrary diagonal matrix with positive diagonal elements, that is, non-diagonal elements are forced to be 0's, so the number of free parameters is d for each matrix. This is most commonly used option yielding good estimation results

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EMCovarianMatrixType Diagonal = 1
Public Const Diagonal As EMCovarianMatrixType = 1
public:
literal EMCovarianMatrixType^ Diagonal = 1
static val mutable Diagonal: EMCovarianMatrixType

Field Value

Type: EMCovarianMatrixType
See Also

Reference

EMCovarianMatrixType Class
Emgu.CV.ML Namespace


EM.CovarianMatrixType.Generic Field

EMCovarianMatrixTypeGeneric Field

A covariation matrix of each mixture may be arbitrary symmetrical positively defined matrix, so the number of free parameters in each matrix is about d2/2. It is not recommended to use this option, unless there is pretty accurate initial estimation of the parameters and/or a huge number of training samples

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EMCovarianMatrixType Generic = 2
Public Const Generic As EMCovarianMatrixType = 2
public:
literal EMCovarianMatrixType^ Generic = 2
static val mutable Generic: EMCovarianMatrixType

Field Value

Type: EMCovarianMatrixType
See Also

Reference

EMCovarianMatrixType Class
Emgu.CV.ML Namespace


EM.CovarianMatrixType.Spherical Field

EMCovarianMatrixTypeSpherical Field

A covariation matrix of each mixture is a scaled identity matrix, ?k*I, so the only parameter to be estimated is ?k. The option may be used in special cases, when the constraint is relevant, or as a first step in the optimization (e.g. in case when the data is preprocessed with PCA). The results of such preliminary estimation may be passed again to the optimization procedure, this time with cov_mat_type=COV_MAT_DIAGONAL

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const EMCovarianMatrixType Spherical = 0
Public Const Spherical As EMCovarianMatrixType = 0
public:
literal EMCovarianMatrixType^ Spherical = 0
static val mutable Spherical: EMCovarianMatrixType

Field Value

Type: EMCovarianMatrixType
See Also

Reference

EMCovarianMatrixType Class
Emgu.CV.ML Namespace


EM.CovarianMatrixType.value__ Field

EMCovarianMatrixTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.EM.CovarianMatrixType.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

EMCovarianMatrixType Class
Emgu.CV.ML Namespace


IStatModel Interface

Interface for statistical models in OpenCV ML.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IStatModel : IAlgorithm
Public Interface IStatModel
    Inherits IAlgorithm
public interface class IStatModel : IAlgorithm
type IStatModel =
    interface
        interface IAlgorithm
    end

The IStatModel type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | StatModelPtr | Return the pointer to the StatModel object
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


IStatModel Properties

The IStatModel type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | StatModelPtr | Return the pointer to the StatModel object
Top
See Also

Reference

IStatModel Interface
Emgu.CV.ML Namespace


IStatModel.StatModelPtr Property

IStatModelStatModelPtr Property

Return the pointer to the StatModel object

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr StatModelPtr { get; }
ReadOnly Property StatModelPtr As IntPtr
    Get
property IntPtr StatModelPtr {
    IntPtr get ();
}
abstract StatModelPtr : IntPtr with get

Return Value

Type: IntPtr
The pointer to the StatModel object
See Also

Reference

IStatModel Interface
Emgu.CV.ML Namespace


IStatModel Methods

The IStatModel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IStatModel Interface
Emgu.CV.ML Namespace


KNearest Class

The KNearest classifier
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.MLKNearest

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class KNearest : SharedPtrObject, IStatModel,
    IAlgorithm
Public Class KNearest
    Inherits SharedPtrObject
    Implements IStatModel, IAlgorithm
public ref class KNearest : public SharedPtrObject,
    IStatModel, IAlgorithm
type KNearest =
    class
        inherit SharedPtrObject
        interface IStatModel
        interface IAlgorithm
    end

The KNearest type exposes the following members.

Constructors
 | Name | Description
Public method | KNearest | Create a default KNearest classifier
Top
Properties
 | Name | Description
Public property | AlgorithmType | Algorithm type
Public property | DefaultK | Default number of neighbors to use in predict method
Public property | Emax | Parameter for KDTree implementation
Public property | IsClassifier | Whether classification or regression model should be trained
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the classifier and all the memory associated with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindNearest | Finds the neighbors and predicts responses for input vectors.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


KNearest Constructor

Create a default KNearest classifier

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public KNearest()
Public Sub New
public:
KNearest()
new : unit -> KNearest
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest Properties

The KNearest type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmType | Algorithm type
Public property | DefaultK | Default number of neighbors to use in predict method
Public property | Emax | Parameter for KDTree implementation
Public property | IsClassifier | Whether classification or regression model should be trained
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest.AlgorithmType Property

KNearestAlgorithmType Property

Algorithm type

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public KNearestTypes AlgorithmType { get; set; }
Public Property AlgorithmType As KNearestTypes
    Get
    Set
public:
property KNearestTypes^ AlgorithmType {
    KNearestTypes^ get ();
    void set (KNearestTypes^ value);
}
member AlgorithmType : KNearestTypes with get, set

Property Value

Type: KNearestTypes
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest.DefaultK Property

KNearestDefaultK Property

Default number of neighbors to use in predict method

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DefaultK { get; set; }
Public Property DefaultK As Integer
    Get
    Set
public:
property int DefaultK {
    int get ();
    void set (int value);
}
member DefaultK : int with get, set

Property Value

Type: Int32
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest.Emax Property

KNearestEmax Property

Parameter for KDTree implementation

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Emax { get; set; }
Public Property Emax As Integer
    Get
    Set
public:
property int Emax {
    int get ();
    void set (int value);
}
member Emax : int with get, set

Property Value

Type: Int32
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest.IsClassifier Property

KNearestIsClassifier Property

Whether classification or regression model should be trained

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsClassifier { get; set; }
Public Property IsClassifier As Boolean
    Get
    Set
public:
property bool IsClassifier {
    bool get ();
    void set (bool value);
}
member IsClassifier : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest Methods

The KNearest type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the classifier and all the memory associated with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | FindNearest | Finds the neighbors and predicts responses for input vectors.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest.DisposeObject Method

KNearestDisposeObject Method

Release the classifier and all the memory associated with it

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest.FindNearest Method

KNearestFindNearest Method

Finds the neighbors and predicts responses for input vectors.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float FindNearest(
    IInputArray samples,
    int k,
    IOutputArray results,
    IOutputArray neighborResponses = null,
    IOutputArray dist = null
)
Public Function FindNearest (
    samples As IInputArray,
    k As Integer,
    results As IOutputArray,
    Optional neighborResponses As IOutputArray = Nothing,
    Optional dist As IOutputArray = Nothing
) As Single
public:
float FindNearest(
    IInputArray^ samples,
    int k,
    IOutputArray^ results,
    IOutputArray^ neighborResponses = nullptr,
    IOutputArray^ dist = nullptr
)
member FindNearest :
        samples : IInputArray *
        k : int *
        results : IOutputArray *
        ?neighborResponses : IOutputArray *
        ?dist : IOutputArray
(* Defaults:
        let _neighborResponses = defaultArg neighborResponses null
        let _dist = defaultArg dist null
*)
-> float32

Parameters

samples
Type: Emgu.CVIInputArray
Input samples stored by rows. It is a single-precision floating-point matrix of <number_of_samples> * k size.
k
Type: SystemInt32
Number of used nearest neighbors. Should be greater than 1.
results
Type: Emgu.CVIOutputArray
Vector with results of prediction (regression or classification) for each input sample. It is a single-precision floating-point vector with <number_of_samples> elements.
neighborResponses (Optional)
Type: Emgu.CVIOutputArray
Optional output values for corresponding neighbors. It is a single- precision floating-point matrix of <number_of_samples> * k size.
dist (Optional)
Type: Emgu.CVIOutputArray
Optional output distances from the input vectors to the corresponding neighbors. It is a single-precision floating-point matrix of <number_of_samples> * k size.

Return Value

Type: Single
If only a single input vector is passed, the predicted value is returned by the method.
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest Fields

The KNearest type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

KNearest Class
Emgu.CV.ML Namespace


KNearest.Types Class

KNearestTypes Class

The type of KNearest search
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLKNearestTypes

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Types : Enum
Public NotInheritable Class Types
    Inherits Enum
public ref class Types sealed : public Enum
[<SealedAttribute>]
type Types =
    class
        inherit Enum
    end

The KNearestTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BruteForce | Using brute force
 | KdTree | Using kd tree
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


Types Methods

The KNearestTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

KNearestTypes Class
Emgu.CV.ML Namespace


Types Fields

The KNearestTypes type exposes the following members.

Fields
 | Name | Description
 | BruteForce | Using brute force
 | KdTree | Using kd tree
Public field | value__ |
Top
See Also

Reference

KNearestTypes Class
Emgu.CV.ML Namespace


KNearest.Types.BruteForce Field

KNearestTypesBruteForce Field

Using brute force

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KNearestTypes BruteForce = 1
Public Const BruteForce As KNearestTypes = 1
public:
literal KNearestTypes^ BruteForce = 1
static val mutable BruteForce: KNearestTypes

Field Value

Type: KNearestTypes
See Also

Reference

KNearestTypes Class
Emgu.CV.ML Namespace


KNearest.Types.KdTree Field

KNearestTypesKdTree Field

Using kd tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KNearestTypes KdTree = 2
Public Const KdTree As KNearestTypes = 2
public:
literal KNearestTypes^ KdTree = 2
static val mutable KdTree: KNearestTypes

Field Value

Type: KNearestTypes
See Also

Reference

KNearestTypes Class
Emgu.CV.ML Namespace


KNearest.Types.value__ Field

KNearestTypesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.KNearest.Types.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

KNearestTypes Class
Emgu.CV.ML Namespace


LogisticRegression Class

ML implements logistic regression, which is a probabilistic classification technique.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLLogisticRegression

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LogisticRegression : UnmanagedObject,
    IStatModel, IAlgorithm
Public Class LogisticRegression
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class LogisticRegression : public UnmanagedObject,
    IStatModel, IAlgorithm
type LogisticRegression =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The LogisticRegression type exposes the following members.

Constructors
 | Name | Description
Public method | LogisticRegression | Initializes a new instance of the LogisticRegression class.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | Iterations | Number of iterations
Public property | LearningRate | Learning rate
Public property | MiniBatchSize | Specifies the number of training samples taken in each step of Mini-Batch Gradient Descent
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Regularization | Kind of regularization to be applied
Public property | StatModelPtr | Return the pointer to the StatModel object
Public property | TermCriteria | Termination criteria of the algorithm
Public property | TrainMethod | Kind of training method to be applied
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


LogisticRegression Constructor

Initializes a new instance of the LogisticRegression class.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LogisticRegression()
Public Sub New
public:
LogisticRegression()
new : unit -> LogisticRegression
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression Properties

The LogisticRegression type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object
Public property | Iterations | Number of iterations
Public property | LearningRate | Learning rate
Public property | MiniBatchSize | Specifies the number of training samples taken in each step of Mini-Batch Gradient Descent
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Regularization | Kind of regularization to be applied
Public property | StatModelPtr | Return the pointer to the StatModel object
Public property | TermCriteria | Termination criteria of the algorithm
Public property | TrainMethod | Kind of training method to be applied
Top
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.AlgorithmPtr Property

LogisticRegressionAlgorithmPtr Property

Return the pointer to the algorithm object

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.Iterations Property

LogisticRegressionIterations Property

Number of iterations

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Iterations { get; set; }
Public Property Iterations As Integer
    Get
    Set
public:
property int Iterations {
    int get ();
    void set (int value);
}
member Iterations : int with get, set

Property Value

Type: Int32
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.LearningRate Property

LogisticRegressionLearningRate Property

Learning rate

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double LearningRate { get; set; }
Public Property LearningRate As Double
    Get
    Set
public:
property double LearningRate {
    double get ();
    void set (double value);
}
member LearningRate : float with get, set

Property Value

Type: Double
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.MiniBatchSize Property

LogisticRegressionMiniBatchSize Property

Specifies the number of training samples taken in each step of Mini-Batch Gradient Descent

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MiniBatchSize { get; set; }
Public Property MiniBatchSize As Integer
    Get
    Set
public:
property int MiniBatchSize {
    int get ();
    void set (int value);
}
member MiniBatchSize : int with get, set

Property Value

Type: Int32
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.Regularization Property

LogisticRegressionRegularization Property

Kind of regularization to be applied

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LogisticRegressionRegularizationMethod Regularization { get; set; }
Public Property Regularization As LogisticRegressionRegularizationMethod
    Get
    Set
public:
property LogisticRegressionRegularizationMethod^ Regularization {
    LogisticRegressionRegularizationMethod^ get ();
    void set (LogisticRegressionRegularizationMethod^ value);
}
member Regularization : LogisticRegressionRegularizationMethod with get, set

Property Value

Type: LogisticRegressionRegularizationMethod
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.StatModelPtr Property

LogisticRegressionStatModelPtr Property

Return the pointer to the StatModel object

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StatModelPtr { get; }
Public ReadOnly Property StatModelPtr As IntPtr
    Get
public:
virtual property IntPtr StatModelPtr {
    IntPtr get () sealed;
}
abstract StatModelPtr : IntPtr with get
override StatModelPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IStatModelStatModelPtr
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.TermCriteria Property

LogisticRegressionTermCriteria Property

Termination criteria of the algorithm

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria TermCriteria { get; set; }
Public Property TermCriteria As MCvTermCriteria
    Get
    Set
public:
property MCvTermCriteria^ TermCriteria {
    MCvTermCriteria^ get ();
    void set (MCvTermCriteria^ value);
}
member TermCriteria : MCvTermCriteria with get, set

Property Value

Type: MCvTermCriteria
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.TrainMethod Property

LogisticRegressionTrainMethod Property

Kind of training method to be applied

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LogisticRegressionTrainType TrainMethod { get; set; }
Public Property TrainMethod As LogisticRegressionTrainType
    Get
    Set
public:
property LogisticRegressionTrainType^ TrainMethod {
    LogisticRegressionTrainType^ get ();
    void set (LogisticRegressionTrainType^ value);
}
member TrainMethod : LogisticRegressionTrainType with get, set

Property Value

Type: LogisticRegressionTrainType
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression Methods

The LogisticRegression type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.DisposeObject Method

LogisticRegressionDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression Fields

The LogisticRegression type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

LogisticRegression Class
Emgu.CV.ML Namespace


LogisticRegression.RegularizationMethod Class

LogisticRegressionRegularizationMethod Class

Specifies the kind of regularization to be applied.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLLogisticRegressionRegularizationMethod

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RegularizationMethod : Enum
Public NotInheritable Class RegularizationMethod
    Inherits Enum
public ref class RegularizationMethod sealed : public Enum
[<SealedAttribute>]
type RegularizationMethod =
    class
        inherit Enum
    end

The LogisticRegressionRegularizationMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Disable | Regularization disabled.
 | L1 | L1 norm
 | L2 | L2 norm
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


RegularizationMethod Methods

The LogisticRegressionRegularizationMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

LogisticRegressionRegularizationMethod Class
Emgu.CV.ML Namespace


RegularizationMethod Fields

The LogisticRegressionRegularizationMethod type exposes the following members.

Fields
 | Name | Description
 | Disable | Regularization disabled.
 | L1 | L1 norm
 | L2 | L2 norm
Public field | value__ |
Top
See Also

Reference

LogisticRegressionRegularizationMethod Class
Emgu.CV.ML Namespace


LogisticRegression.RegularizationMethod.Disable Field

LogisticRegressionRegularizationMethodDisable Field

Regularization disabled.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LogisticRegressionRegularizationMethod Disable = -1
Public Const Disable As LogisticRegressionRegularizationMethod = -1
public:
literal LogisticRegressionRegularizationMethod^ Disable = -1
static val mutable Disable: LogisticRegressionRegularizationMethod

Field Value

Type: LogisticRegressionRegularizationMethod
See Also

Reference

LogisticRegressionRegularizationMethod Class
Emgu.CV.ML Namespace


LogisticRegression.RegularizationMethod.L1 Field

LogisticRegressionRegularizationMethodL1 Field

L1 norm

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LogisticRegressionRegularizationMethod L1 = 0
Public Const L1 As LogisticRegressionRegularizationMethod = 0
public:
literal LogisticRegressionRegularizationMethod^ L1 = 0
static val mutable L1: LogisticRegressionRegularizationMethod

Field Value

Type: LogisticRegressionRegularizationMethod
See Also

Reference

LogisticRegressionRegularizationMethod Class
Emgu.CV.ML Namespace


LogisticRegression.RegularizationMethod.L2 Field

LogisticRegressionRegularizationMethodL2 Field

L2 norm

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LogisticRegressionRegularizationMethod L2 = 1
Public Const L2 As LogisticRegressionRegularizationMethod = 1
public:
literal LogisticRegressionRegularizationMethod^ L2 = 1
static val mutable L2: LogisticRegressionRegularizationMethod

Field Value

Type: LogisticRegressionRegularizationMethod
See Also

Reference

LogisticRegressionRegularizationMethod Class
Emgu.CV.ML Namespace


LogisticRegression.RegularizationMethod.value__ Field

LogisticRegressionRegularizationMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.LogisticRegression.RegularizationMethod.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

LogisticRegressionRegularizationMethod Class
Emgu.CV.ML Namespace


LogisticRegression.TrainType Class

LogisticRegressionTrainType Class

Specifies the kind of training method used.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLLogisticRegressionTrainType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TrainType : Enum
Public NotInheritable Class TrainType
    Inherits Enum
public ref class TrainType sealed : public Enum
[<SealedAttribute>]
type TrainType =
    class
        inherit Enum
    end

The LogisticRegressionTrainType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Batch | Batch method
 | MiniBatch | Set MiniBatchSize to a positive integer when using this method.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


TrainType Methods

The LogisticRegressionTrainType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

LogisticRegressionTrainType Class
Emgu.CV.ML Namespace


TrainType Fields

The LogisticRegressionTrainType type exposes the following members.

Fields
 | Name | Description
 | Batch | Batch method
 | MiniBatch | Set MiniBatchSize to a positive integer when using this method.
Public field | value__ |
Top
See Also

Reference

LogisticRegressionTrainType Class
Emgu.CV.ML Namespace


LogisticRegression.TrainType.Batch Field

LogisticRegressionTrainTypeBatch Field

Batch method

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LogisticRegressionTrainType Batch = 0
Public Const Batch As LogisticRegressionTrainType = 0
public:
literal LogisticRegressionTrainType^ Batch = 0
static val mutable Batch: LogisticRegressionTrainType

Field Value

Type: LogisticRegressionTrainType
See Also

Reference

LogisticRegressionTrainType Class
Emgu.CV.ML Namespace


LogisticRegression.TrainType.MiniBatch Field

LogisticRegressionTrainTypeMiniBatch Field

Set MiniBatchSize to a positive integer when using this method.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LogisticRegressionTrainType MiniBatch = 1
Public Const MiniBatch As LogisticRegressionTrainType = 1
public:
literal LogisticRegressionTrainType^ MiniBatch = 1
static val mutable MiniBatch: LogisticRegressionTrainType

Field Value

Type: LogisticRegressionTrainType
See Also

Reference

LogisticRegressionTrainType Class
Emgu.CV.ML Namespace


LogisticRegression.TrainType.value__ Field

LogisticRegressionTrainTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.LogisticRegression.TrainType.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

LogisticRegressionTrainType Class
Emgu.CV.ML Namespace


MCvParamGrid Class

Wrapped CvParamGrid structure used by SVM
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.MLMCvParamGrid

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MCvParamGrid : ValueType
Public NotInheritable Class MCvParamGrid
    Inherits ValueType
public ref class MCvParamGrid sealed : public ValueType
[<SealedAttribute>]
type MCvParamGrid =
    class
        inherit ValueType
    end

The MCvParamGrid type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | MaxVal | Maximum value
Public field | MinVal | Minimum value
Public field | Step | step
Top
See Also

Reference

Emgu.CV.ML Namespace


MCvParamGrid Methods

The MCvParamGrid type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvParamGrid Class
Emgu.CV.ML Namespace


MCvParamGrid Fields

The MCvParamGrid type exposes the following members.

Fields
 | Name | Description
Public field | MaxVal | Maximum value
Public field | MinVal | Minimum value
Public field | Step | step
Top
See Also

Reference

MCvParamGrid Class
Emgu.CV.ML Namespace


MCvParamGrid.MaxVal Field

MCvParamGridMaxVal Field

Maximum value

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MaxVal
Public MaxVal As Double
public:
double MaxVal
val mutable MaxVal: float

Field Value

Type: Double
See Also

Reference

MCvParamGrid Class
Emgu.CV.ML Namespace


MCvParamGrid.MinVal Field

MCvParamGridMinVal Field

Minimum value

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double MinVal
Public MinVal As Double
public:
double MinVal
val mutable MinVal: float

Field Value

Type: Double
See Also

Reference

MCvParamGrid Class
Emgu.CV.ML Namespace


MCvParamGrid.Step Field

MCvParamGridStep Field

step

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Step
Public Step As Double
public:
double Step
val mutable Step: float

Field Value

Type: Double
See Also

Reference

MCvParamGrid Class
Emgu.CV.ML Namespace


MlInvoke Class

This class contains functions to call into machine learning library
Inheritance Hierarchy
SystemObject
Emgu.CV.MLMlInvoke

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class MlInvoke
Public NotInheritable Class MlInvoke
public ref class MlInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MlInvoke =  class end
See Also

Reference

Emgu.CV.ML Namespace


NormalBayesClassifier Class

A Normal Bayes Classifier
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLNormalBayesClassifier

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class NormalBayesClassifier : UnmanagedObject,
    IStatModel, IAlgorithm
Public Class NormalBayesClassifier
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class NormalBayesClassifier : public UnmanagedObject,
    IStatModel, IAlgorithm
type NormalBayesClassifier =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The NormalBayesClassifier type exposes the following members.

Constructors
 | Name | Description
Public method | NormalBayesClassifier | Create a normal Bayes classifier
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this classifier (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


NormalBayesClassifier Constructor

Create a normal Bayes classifier

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public NormalBayesClassifier()
Public Sub New
public:
NormalBayesClassifier()
new : unit -> NormalBayesClassifier
See Also

Reference

NormalBayesClassifier Class
Emgu.CV.ML Namespace


NormalBayesClassifier Properties

The NormalBayesClassifier type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

NormalBayesClassifier Class
Emgu.CV.ML Namespace


NormalBayesClassifier Methods

The NormalBayesClassifier type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this classifier (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

NormalBayesClassifier Class
Emgu.CV.ML Namespace


NormalBayesClassifier.DisposeObject Method

NormalBayesClassifierDisposeObject Method

Release the memory associated with this classifier

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

NormalBayesClassifier Class
Emgu.CV.ML Namespace


NormalBayesClassifier Fields

The NormalBayesClassifier type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

NormalBayesClassifier Class
Emgu.CV.ML Namespace


RTrees Class

Random trees
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLRTrees

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RTrees : UnmanagedObject, IStatModel,
    IAlgorithm
Public Class RTrees
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class RTrees : public UnmanagedObject,
    IStatModel, IAlgorithm
type RTrees =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The RTrees type exposes the following members.

Constructors
 | Name | Description
Public method | RTrees | Create a random tree
Top
Properties
 | Name | Description
Public property | ActiveVarCount | The size of the randomly selected subset of features at each tree node and that are used to find the best split(s)
Public property | CalculateVarImportance | If true then variable importance will be calculated
Public property | CVFolds | If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold
Public property | MaxCategories | Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split
Public property | MaxDepth | The maximum possible depth of the tree
Public property | MinSampleCount | If the number of samples in a node is less than this parameter then the node will not be split
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegressionAccuracy | Termination criteria for regression trees
Public property | TermCriteria | The termination criteria that specifies when the training algorithm stops
Public property | TruncatePrunedTree | If true then pruned branches are physically removed from the tree
Public property | Use1SERule | If true then a pruning will be harsher
Public property | UseSurrogates | If true then surrogate splits will be built
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the random tree and all memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVotes | Returns the result of each individual tree in the forest. In case the model is a regression problem, the method will return each of the trees' results for each of the sample cases.If the model is a classifier, it will return a Mat with samples + 1 rows, where the first row gives the class number and the following rows return the votes each class had for each sample.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


RTrees Constructor

Create a random tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RTrees()
Public Sub New
public:
RTrees()
new : unit -> RTrees
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees Properties

The RTrees type exposes the following members.

Properties
 | Name | Description
Public property | ActiveVarCount | The size of the randomly selected subset of features at each tree node and that are used to find the best split(s)
Public property | CalculateVarImportance | If true then variable importance will be calculated
Public property | CVFolds | If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold
Public property | MaxCategories | Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split
Public property | MaxDepth | The maximum possible depth of the tree
Public property | MinSampleCount | If the number of samples in a node is less than this parameter then the node will not be split
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegressionAccuracy | Termination criteria for regression trees
Public property | TermCriteria | The termination criteria that specifies when the training algorithm stops
Public property | TruncatePrunedTree | If true then pruned branches are physically removed from the tree
Public property | Use1SERule | If true then a pruning will be harsher
Public property | UseSurrogates | If true then surrogate splits will be built
Top
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.ActiveVarCount Property

RTreesActiveVarCount Property

The size of the randomly selected subset of features at each tree node and that are used to find the best split(s)

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ActiveVarCount { get; set; }
Public Property ActiveVarCount As Integer
    Get
    Set
public:
property int ActiveVarCount {
    int get ();
    void set (int value);
}
member ActiveVarCount : int with get, set

Property Value

Type: Int32
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.CalculateVarImportance Property

RTreesCalculateVarImportance Property

If true then variable importance will be calculated

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool CalculateVarImportance { get; set; }
Public Property CalculateVarImportance As Boolean
    Get
    Set
public:
property bool CalculateVarImportance {
    bool get ();
    void set (bool value);
}
member CalculateVarImportance : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.CVFolds Property

RTreesCVFolds Property

If CVFolds greater than 1 then algorithms prunes the built decision tree using K-fold

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CVFolds { get; set; }
Public Property CVFolds As Integer
    Get
    Set
public:
property int CVFolds {
    int get ();
    void set (int value);
}
member CVFolds : int with get, set

Property Value

Type: Int32
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.MaxCategories Property

RTreesMaxCategories Property

Cluster possible values of a categorical variable into K less than or equals maxCategories clusters to find a suboptimal split

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxCategories { get; set; }
Public Property MaxCategories As Integer
    Get
    Set
public:
property int MaxCategories {
    int get ();
    void set (int value);
}
member MaxCategories : int with get, set

Property Value

Type: Int32
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.MaxDepth Property

RTreesMaxDepth Property

The maximum possible depth of the tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxDepth { get; set; }
Public Property MaxDepth As Integer
    Get
    Set
public:
property int MaxDepth {
    int get ();
    void set (int value);
}
member MaxDepth : int with get, set

Property Value

Type: Int32
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.MinSampleCount Property

RTreesMinSampleCount Property

If the number of samples in a node is less than this parameter then the node will not be split

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MinSampleCount { get; set; }
Public Property MinSampleCount As Integer
    Get
    Set
public:
property int MinSampleCount {
    int get ();
    void set (int value);
}
member MinSampleCount : int with get, set

Property Value

Type: Int32
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.RegressionAccuracy Property

RTreesRegressionAccuracy Property

Termination criteria for regression trees

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float RegressionAccuracy { get; set; }
Public Property RegressionAccuracy As Single
    Get
    Set
public:
property float RegressionAccuracy {
    float get ();
    void set (float value);
}
member RegressionAccuracy : float32 with get, set

Property Value

Type: Single
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.TermCriteria Property

RTreesTermCriteria Property

The termination criteria that specifies when the training algorithm stops

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria TermCriteria { get; set; }
Public Property TermCriteria As MCvTermCriteria
    Get
    Set
public:
property MCvTermCriteria^ TermCriteria {
    MCvTermCriteria^ get ();
    void set (MCvTermCriteria^ value);
}
member TermCriteria : MCvTermCriteria with get, set

Property Value

Type: MCvTermCriteria
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.TruncatePrunedTree Property

RTreesTruncatePrunedTree Property

If true then pruned branches are physically removed from the tree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TruncatePrunedTree { get; set; }
Public Property TruncatePrunedTree As Boolean
    Get
    Set
public:
property bool TruncatePrunedTree {
    bool get ();
    void set (bool value);
}
member TruncatePrunedTree : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.Use1SERule Property

RTreesUse1SERule Property

If true then a pruning will be harsher

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Use1SERule { get; set; }
Public Property Use1SERule As Boolean
    Get
    Set
public:
property bool Use1SERule {
    bool get ();
    void set (bool value);
}
member Use1SERule : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.UseSurrogates Property

RTreesUseSurrogates Property

If true then surrogate splits will be built

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseSurrogates { get; set; }
Public Property UseSurrogates As Boolean
    Get
    Set
public:
property bool UseSurrogates {
    bool get ();
    void set (bool value);
}
member UseSurrogates : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees Methods

The RTrees type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the random tree and all memory associate with it (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVotes | Returns the result of each individual tree in the forest. In case the model is a regression problem, the method will return each of the trees' results for each of the sample cases.If the model is a classifier, it will return a Mat with samples + 1 rows, where the first row gives the class number and the following rows return the votes each class had for each sample.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.DisposeObject Method

RTreesDisposeObject Method

Release the random tree and all memory associate with it

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees.GetVotes Method

RTreesGetVotes Method

Returns the result of each individual tree in the forest. In case the model is a regression problem, the method will return each of the trees' results for each of the sample cases.If the model is a classifier, it will return a Mat with samples + 1 rows, where the first row gives the class number and the following rows return the votes each class had for each sample.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetVotes(
    IInputArray samples,
    IOutputArray results,
    DTreesFlags flags
)
Public Sub GetVotes (
    samples As IInputArray,
    results As IOutputArray,
    flags As DTreesFlags
)
public:
void GetVotes(
    IInputArray^ samples,
    IOutputArray^ results,
    DTreesFlags^ flags
)
member GetVotes :
        samples : IInputArray *
        results : IOutputArray *
        flags : DTreesFlags -> unit

Parameters

samples
Type: Emgu.CVIInputArray
Array containing the samples for which votes will be calculated.
results
Type: Emgu.CVIOutputArray
Array where the result of the calculation will be written.
flags
Type: Emgu.CV.MLDTreesFlags
Flags for defining the type of RTrees.
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


RTrees Fields

The RTrees type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RTrees Class
Emgu.CV.ML Namespace


StatModelExtensions Class

A statistic model
Inheritance Hierarchy
SystemObject
Emgu.CV.MLStatModelExtensions

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class StatModelExtensions
<ExtensionAttribute>
Public NotInheritable Class StatModelExtensions
[ExtensionAttribute]
public ref class StatModelExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type StatModelExtensions =  class end

The StatModelExtensions type exposes the following members.

Methods
Name | Description
Predict | Predicts response(s) for the provided sample(s)
Train(IStatModel, TrainData, Int32) | Trains the statistical model.
Train(IStatModel, IInputArray, DataLayoutType, IInputArray) | Trains the statistical model.
Top
See Also

Reference

Emgu.CV.ML Namespace


StatModelExtensions Methods

The StatModelExtensions type exposes the following members.

Methods
Name | Description
Predict | Predicts response(s) for the provided sample(s)
Train(IStatModel, TrainData, Int32) | Trains the statistical model.
Train(IStatModel, IInputArray, DataLayoutType, IInputArray) | Trains the statistical model.
Top
See Also

Reference

StatModelExtensions Class
Emgu.CV.ML Namespace


StatModelExtensions.Predict Method

StatModelExtensionsPredict Method

Predicts response(s) for the provided sample(s)

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static float Predict(
    this IStatModel model,
    IInputArray samples,
    IOutputArray results = null,
    int flags = 0
)
<ExtensionAttribute>
Public Shared Function Predict (
    model As IStatModel,
    samples As IInputArray,
    Optional results As IOutputArray = Nothing,
    Optional flags As Integer = 0
) As Single
public:
[ExtensionAttribute]
static float Predict(
    IStatModel^ model,
    IInputArray^ samples,
    IOutputArray^ results = nullptr,
    int flags = 0
)
[<ExtensionAttribute>]
static member Predict :
        model : IStatModel *
        samples : IInputArray *
        ?results : IOutputArray *
        ?flags : int
(* Defaults:
        let _results = defaultArg results null
        let _flags = defaultArg flags 0
*)
-> float32

Parameters

model
Type: Emgu.CV.MLIStatModel
The model.
samples
Type: Emgu.CVIInputArray
The input samples, floating-point matrix.
results (Optional)
Type: Emgu.CVIOutputArray
The optional output matrix of results.
flags (Optional)
Type: SystemInt32
The optional flags, model-dependent.

Return Value

Type: Single
Response for the provided sample

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IStatModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StatModelExtensions Class
Emgu.CV.ML Namespace


StatModelExtensions.Train Method

StatModelExtensionsTrain Method

Overload List
Name | Description
Train(IStatModel, TrainData, Int32) | Trains the statistical model.
Train(IStatModel, IInputArray, DataLayoutType, IInputArray) | Trains the statistical model.
Top
See Also

Reference

StatModelExtensions Class
Emgu.CV.ML Namespace


StatModelExtensions.Train Method (IStatModel, TrainData, Int32)

StatModelExtensionsTrain Method (IStatModel, TrainData, Int32)

http://www.emgu.com
Trains the statistical model.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool Train(
    this IStatModel model,
    TrainData trainData,
    int flags = 0
)
<ExtensionAttribute>
Public Shared Function Train (
    model As IStatModel,
    trainData As TrainData,
    Optional flags As Integer = 0
) As Boolean
public:
[ExtensionAttribute]
static bool Train(
    IStatModel^ model,
    TrainData^ trainData,
    int flags = 0
)
[<ExtensionAttribute>]
static member Train :
        model : IStatModel *
        trainData : TrainData *
        ?flags : int
(* Defaults:
        let _flags = defaultArg flags 0
*)
-> bool

Parameters

model
Type: Emgu.CV.MLIStatModel
The model.
trainData
Type: Emgu.CV.MLTrainData
The train data.
flags (Optional)
Type: SystemInt32
The flags.

Return Value

Type: Boolean
True if the training is successful.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IStatModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StatModelExtensions Class
Train Overload
Emgu.CV.ML Namespace


StatModelExtensions.Train Method (IStatModel, IInputArray, DataLayoutType, IInputArray)

StatModelExtensionsTrain Method (IStatModel, IInputArray, DataLayoutType, IInputArray)

http://www.emgu.com
Trains the statistical model.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool Train(
    this IStatModel model,
    IInputArray samples,
    DataLayoutType layoutType,
    IInputArray responses
)
<ExtensionAttribute>
Public Shared Function Train (
    model As IStatModel,
    samples As IInputArray,
    layoutType As DataLayoutType,
    responses As IInputArray
) As Boolean
public:
[ExtensionAttribute]
static bool Train(
    IStatModel^ model,
    IInputArray^ samples,
    DataLayoutType^ layoutType,
    IInputArray^ responses
)
[<ExtensionAttribute>]
static member Train :
        model : IStatModel *
        samples : IInputArray *
        layoutType : DataLayoutType *
        responses : IInputArray -> bool

Parameters

model
Type: Emgu.CV.MLIStatModel
The stat model.
samples
Type: Emgu.CVIInputArray
The training samples.
layoutType
Type: Emgu.CV.ML.MlEnumDataLayoutType
Type of the layout.
responses
Type: Emgu.CVIInputArray
Vector of responses associated with the training samples.

Return Value

Type: Boolean
True if the training is successful.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IStatModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StatModelExtensions Class
Train Overload
Emgu.CV.ML Namespace


SVM Class

Support Vector Machine
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLSVM

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SVM : UnmanagedObject, IStatModel, IAlgorithm
Public Class SVM
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class SVM : public UnmanagedObject,
    IStatModel, IAlgorithm
type SVM =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The SVM type exposes the following members.

Constructors
 | Name | Description
Public method | SVM | Create a support Vector Machine
Top
Properties
 | Name | Description
Public property | C | Parameter C of a SVM optimization problem
Public property | Coef0 | Parameter coef0 of a kernel function
Public property | Degree | Parameter degree of a kernel function
Public property | Gamma | Parameter gamma of a kernel function
Public property | KernelType | Type of a SVM kernel
Public property | Nu | Parameter nu of a SVM optimization problem
Public property | P | Parameter epsilon of a SVM optimization problem
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TermCriteria | Termination criteria of the iterative SVM training procedure which solves a partial case of constrained quadratic optimization problem
Public property | Type | Type of a SVM formulation
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with the SVM (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
 | GetDefaultGrid | Get the default parameter grid for the specific SVM type
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportVectors | Retrieves all the support vectors.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetKernel | Initialize with one of predefined kernels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrainAuto(TrainData, Int32) | The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.
Public method | TrainAuto(TrainData, Int32, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, Boolean) | The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


SVM Constructor

Create a support Vector Machine

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SVM()
Public Sub New
public:
SVM()
new : unit -> SVM
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM Properties

The SVM type exposes the following members.

Properties
 | Name | Description
Public property | C | Parameter C of a SVM optimization problem
Public property | Coef0 | Parameter coef0 of a kernel function
Public property | Degree | Parameter degree of a kernel function
Public property | Gamma | Parameter gamma of a kernel function
Public property | KernelType | Type of a SVM kernel
Public property | Nu | Parameter nu of a SVM optimization problem
Public property | P | Parameter epsilon of a SVM optimization problem
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TermCriteria | Termination criteria of the iterative SVM training procedure which solves a partial case of constrained quadratic optimization problem
Public property | Type | Type of a SVM formulation
Top
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.C Property

SVMC Property

Parameter C of a SVM optimization problem

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double C { get; set; }
Public Property C As Double
    Get
    Set
public:
property double C {
    double get ();
    void set (double value);
}
member C : float with get, set

Property Value

Type: Double
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.Coef0 Property

SVMCoef0 Property

Parameter coef0 of a kernel function

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Coef0 { get; set; }
Public Property Coef0 As Double
    Get
    Set
public:
property double Coef0 {
    double get ();
    void set (double value);
}
member Coef0 : float with get, set

Property Value

Type: Double
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.Degree Property

SVMDegree Property

Parameter degree of a kernel function

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Degree { get; set; }
Public Property Degree As Double
    Get
    Set
public:
property double Degree {
    double get ();
    void set (double value);
}
member Degree : float with get, set

Property Value

Type: Double
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.Gamma Property

SVMGamma Property

Parameter gamma of a kernel function

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Gamma { get; set; }
Public Property Gamma As Double
    Get
    Set
public:
property double Gamma {
    double get ();
    void set (double value);
}
member Gamma : float with get, set

Property Value

Type: Double
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.KernelType Property

SVMKernelType Property

Type of a SVM kernel

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SVMSvmKernelType KernelType { get; }
Public ReadOnly Property KernelType As SVMSvmKernelType
    Get
public:
property SVMSvmKernelType^ KernelType {
    SVMSvmKernelType^ get ();
}
member KernelType : SVMSvmKernelType with get

Property Value

Type: SVMSvmKernelType
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.Nu Property

SVMNu Property

Parameter nu of a SVM optimization problem

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Nu { get; set; }
Public Property Nu As Double
    Get
    Set
public:
property double Nu {
    double get ();
    void set (double value);
}
member Nu : float with get, set

Property Value

Type: Double
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.P Property

SVMP Property

Parameter epsilon of a SVM optimization problem

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double P { get; set; }
Public Property P As Double
    Get
    Set
public:
property double P {
    double get ();
    void set (double value);
}
member P : float with get, set

Property Value

Type: Double
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.TermCriteria Property

SVMTermCriteria Property

Termination criteria of the iterative SVM training procedure which solves a partial case of constrained quadratic optimization problem

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria TermCriteria { get; set; }
Public Property TermCriteria As MCvTermCriteria
    Get
    Set
public:
property MCvTermCriteria^ TermCriteria {
    MCvTermCriteria^ get ();
    void set (MCvTermCriteria^ value);
}
member TermCriteria : MCvTermCriteria with get, set

Property Value

Type: MCvTermCriteria
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.Type Property

SVMType Property

Type of a SVM formulation

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SVMSvmType Type { get; set; }
Public Property Type As SVMSvmType
    Get
    Set
public:
property SVMSvmType^ Type {
    SVMSvmType^ get ();
    void set (SVMSvmType^ value);
}
member Type : SVMSvmType with get, set

Property Value

Type: SVMSvmType
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM Methods

The SVM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with the SVM (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
 | GetDefaultGrid | Get the default parameter grid for the specific SVM type
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportVectors | Retrieves all the support vectors.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetKernel | Initialize with one of predefined kernels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrainAuto(TrainData, Int32) | The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.
Public method | TrainAuto(TrainData, Int32, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, Boolean) | The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.DisposeObject Method

SVMDisposeObject Method

Release all the memory associated with the SVM

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.GetDefaultGrid Method

SVMGetDefaultGrid Method

Get the default parameter grid for the specific SVM type

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvParamGrid GetDefaultGrid(
    SVMParamType type
)
Public Shared Function GetDefaultGrid (
    type As SVMParamType
) As MCvParamGrid
public:
static MCvParamGrid^ GetDefaultGrid(
    SVMParamType^ type
)
static member GetDefaultGrid :
        type : SVMParamType -> MCvParamGrid

Parameters

type
Type: Emgu.CV.MLSVMParamType
The SVM type

Return Value

Type: MCvParamGrid
The default parameter grid for the specific SVM type
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.GetSupportVectors Method

SVMGetSupportVectors Method

Retrieves all the support vectors.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat GetSupportVectors()
Public Function GetSupportVectors As Mat
public:
Mat^ GetSupportVectors()
member GetSupportVectors : unit -> Mat

Return Value

Type: Mat
All the support vector as floating-point matrix, where support vectors are stored as matrix rows.
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.SetKernel Method

SVMSetKernel Method

Initialize with one of predefined kernels

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetKernel(
    SVMSvmKernelType value
)
Public Sub SetKernel (
    value As SVMSvmKernelType
)
public:
void SetKernel(
    SVMSvmKernelType^ value
)
member SetKernel :
        value : SVMSvmKernelType -> unit

Parameters

value
Type: Emgu.CV.MLSVMSvmKernelType
The value
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.TrainAuto Method

SVMTrainAuto Method

Overload List
 | Name | Description
Public method | TrainAuto(TrainData, Int32) | The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.
Public method | TrainAuto(TrainData, Int32, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, Boolean) | The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.
Top
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.TrainAuto Method (TrainData, Int32)

SVMTrainAuto Method (TrainData, Int32)

http://www.emgu.com
The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TrainAuto(
    TrainData trainData,
    int kFold = 10
)
Public Function TrainAuto (
    trainData As TrainData,
    Optional kFold As Integer = 10
) As Boolean
public:
bool TrainAuto(
    TrainData^ trainData,
    int kFold = 10
)
member TrainAuto :
        trainData : TrainData *
        ?kFold : int
(* Defaults:
        let _kFold = defaultArg kFold 10
*)
-> bool

Parameters

trainData
Type: Emgu.CV.MLTrainData
The training data.
kFold (Optional)
Type: SystemInt32
Cross-validation parameter. The training set is divided into k_fold subsets, one subset being used to train the model, the others forming the test set. So, the SVM algorithm is executed k_fold times

Return Value

Type: Boolean
True if training is successful.
See Also

Reference

SVM Class
TrainAuto Overload
Emgu.CV.ML Namespace


SVM.TrainAuto Method (TrainData, Int32, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, Boolean)

SVMTrainAuto Method (TrainData, Int32, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, MCvParamGrid, Boolean)

http://www.emgu.com
The method trains the SVM model automatically by choosing the optimal parameters C, gamma, p, nu, coef0, degree from CvSVMParams. By the optimality one mean that the cross-validation estimate of the test set error is minimal.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TrainAuto(
    TrainData trainData,
    int kFold,
    MCvParamGrid cGrid,
    MCvParamGrid gammaGrid,
    MCvParamGrid pGrid,
    MCvParamGrid nuGrid,
    MCvParamGrid coefGrid,
    MCvParamGrid degreeGrid,
    bool balanced = false
)
Public Function TrainAuto (
    trainData As TrainData,
    kFold As Integer,
    cGrid As MCvParamGrid,
    gammaGrid As MCvParamGrid,
    pGrid As MCvParamGrid,
    nuGrid As MCvParamGrid,
    coefGrid As MCvParamGrid,
    degreeGrid As MCvParamGrid,
    Optional balanced As Boolean = false
) As Boolean
public:
bool TrainAuto(
    TrainData^ trainData,
    int kFold,
    MCvParamGrid^ cGrid,
    MCvParamGrid^ gammaGrid,
    MCvParamGrid^ pGrid,
    MCvParamGrid^ nuGrid,
    MCvParamGrid^ coefGrid,
    MCvParamGrid^ degreeGrid,
    bool balanced = false
)
member TrainAuto :
        trainData : TrainData *
        kFold : int *
        cGrid : MCvParamGrid *
        gammaGrid : MCvParamGrid *
        pGrid : MCvParamGrid *
        nuGrid : MCvParamGrid *
        coefGrid : MCvParamGrid *
        degreeGrid : MCvParamGrid *
        ?balanced : bool
(* Defaults:
        let _balanced = defaultArg balanced false
*)
-> bool

Parameters

trainData
Type: Emgu.CV.MLTrainData
The training data.
kFold
Type: SystemInt32
Cross-validation parameter. The training set is divided into k_fold subsets, one subset being used to train the model, the others forming the test set. So, the SVM algorithm is executed k_fold times
cGrid
Type: Emgu.CV.MLMCvParamGrid
cGrid
gammaGrid
Type: Emgu.CV.MLMCvParamGrid
grid for gamma
pGrid
Type: Emgu.CV.MLMCvParamGrid
grid for p
nuGrid
Type: Emgu.CV.MLMCvParamGrid
grid for nu
coefGrid
Type: Emgu.CV.MLMCvParamGrid
grid for coeff
degreeGrid
Type: Emgu.CV.MLMCvParamGrid
grid for degree
balanced (Optional)
Type: SystemBoolean
If true and the problem is 2-class classification then the method creates more balanced cross-validation subsets that is proportions between classes in subsets are close to such proportion in the whole train dataset.

Return Value

Type: Boolean
True if training is successful.
See Also

Reference

SVM Class
TrainAuto Overload
Emgu.CV.ML Namespace


SVM Fields

The SVM type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SVM Class
Emgu.CV.ML Namespace


SVM.ParamType Class

SVMParamType Class

The type of SVM parameters
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLSVMParamType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ParamType : Enum
Public NotInheritable Class ParamType
    Inherits Enum
public ref class ParamType sealed : public Enum
[<SealedAttribute>]
type ParamType =
    class
        inherit Enum
    end

The SVMParamType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | C | C
 | Coef | COEF
 | Degree | DEGREE
 | Gamma | Gamma
 | Nu | NU
 | P | P
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


ParamType Methods

The SVMParamType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


ParamType Fields

The SVMParamType type exposes the following members.

Fields
 | Name | Description
 | C | C
 | Coef | COEF
 | Degree | DEGREE
 | Gamma | Gamma
 | Nu | NU
 | P | P
Public field | value__ |
Top
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.ParamType.C Field

SVMParamTypeC Field

C

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMParamType C = 0
Public Const C As SVMParamType = 0
public:
literal SVMParamType^ C = 0
static val mutable C: SVMParamType

Field Value

Type: SVMParamType
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.ParamType.Coef Field

SVMParamTypeCoef Field

COEF

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMParamType Coef = 4
Public Const Coef As SVMParamType = 4
public:
literal SVMParamType^ Coef = 4
static val mutable Coef: SVMParamType

Field Value

Type: SVMParamType
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.ParamType.Degree Field

SVMParamTypeDegree Field

DEGREE

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMParamType Degree = 5
Public Const Degree As SVMParamType = 5
public:
literal SVMParamType^ Degree = 5
static val mutable Degree: SVMParamType

Field Value

Type: SVMParamType
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.ParamType.Gamma Field

SVMParamTypeGamma Field

Gamma

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMParamType Gamma = 1
Public Const Gamma As SVMParamType = 1
public:
literal SVMParamType^ Gamma = 1
static val mutable Gamma: SVMParamType

Field Value

Type: SVMParamType
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.ParamType.Nu Field

SVMParamTypeNu Field

NU

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMParamType Nu = 3
Public Const Nu As SVMParamType = 3
public:
literal SVMParamType^ Nu = 3
static val mutable Nu: SVMParamType

Field Value

Type: SVMParamType
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.ParamType.P Field

SVMParamTypeP Field

P

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMParamType P = 2
Public Const P As SVMParamType = 2
public:
literal SVMParamType^ P = 2
static val mutable P: SVMParamType

Field Value

Type: SVMParamType
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.ParamType.value__ Field

SVMParamTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.SVM.ParamType.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SVMParamType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType Class

SVMSvmKernelType Class

SVM kernel type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLSVMSvmKernelType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SvmKernelType : Enum
Public NotInheritable Class SvmKernelType
    Inherits Enum
public ref class SvmKernelType sealed : public Enum
[<SealedAttribute>]
type SvmKernelType =
    class
        inherit Enum
    end

The SVMSvmKernelType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Chi2 | Exponential Chi2 kernel, similar to the RBF kernel
 | Custom | Custom svm kernel type
 | Inter | Histogram intersection kernel. A fast kernel. K(xi,xj)=min(xi,xj).
 | Linear | No mapping is done, linear discrimination (or regression) is done in the original feature space. It is the fastest option. d(x,y) = x y == (x,y)
 | Poly | polynomial kernel: d(x,y) = (gamma*(xy)+coef0)^degree
 | Rbf | Radial-basis-function kernel; a good choice in most cases: d(x,y) = exp(-gamma*|x-y|^2)
 | Sigmoid | sigmoid function is used as a kernel: d(x,y) = tanh(gamma*(xy)+coef0)
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


SvmKernelType Methods

The SVMSvmKernelType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SvmKernelType Fields

The SVMSvmKernelType type exposes the following members.

Fields
 | Name | Description
 | Chi2 | Exponential Chi2 kernel, similar to the RBF kernel
 | Custom | Custom svm kernel type
 | Inter | Histogram intersection kernel. A fast kernel. K(xi,xj)=min(xi,xj).
 | Linear | No mapping is done, linear discrimination (or regression) is done in the original feature space. It is the fastest option. d(x,y) = x y == (x,y)
 | Poly | polynomial kernel: d(x,y) = (gamma*(xy)+coef0)^degree
 | Rbf | Radial-basis-function kernel; a good choice in most cases: d(x,y) = exp(-gamma*|x-y|^2)
 | Sigmoid | sigmoid function is used as a kernel: d(x,y) = tanh(gamma*(xy)+coef0)
Public field | value__ |
Top
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.Chi2 Field

SVMSvmKernelTypeChi2 Field

Exponential Chi2 kernel, similar to the RBF kernel

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmKernelType Chi2 = 4
Public Const Chi2 As SVMSvmKernelType = 4
public:
literal SVMSvmKernelType^ Chi2 = 4
static val mutable Chi2: SVMSvmKernelType

Field Value

Type: SVMSvmKernelType
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.Custom Field

SVMSvmKernelTypeCustom Field

Custom svm kernel type

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmKernelType Custom = -1
Public Const Custom As SVMSvmKernelType = -1
public:
literal SVMSvmKernelType^ Custom = -1
static val mutable Custom: SVMSvmKernelType

Field Value

Type: SVMSvmKernelType
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.Inter Field

SVMSvmKernelTypeInter Field

Histogram intersection kernel. A fast kernel. K(xi,xj)=min(xi,xj).

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmKernelType Inter = 5
Public Const Inter As SVMSvmKernelType = 5
public:
literal SVMSvmKernelType^ Inter = 5
static val mutable Inter: SVMSvmKernelType

Field Value

Type: SVMSvmKernelType
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.Linear Field

SVMSvmKernelTypeLinear Field

No mapping is done, linear discrimination (or regression) is done in the original feature space. It is the fastest option. d(x,y) = x y == (x,y)

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmKernelType Linear = 0
Public Const Linear As SVMSvmKernelType = 0
public:
literal SVMSvmKernelType^ Linear = 0
static val mutable Linear: SVMSvmKernelType

Field Value

Type: SVMSvmKernelType
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.Poly Field

SVMSvmKernelTypePoly Field

polynomial kernel: d(x,y) = (gamma*(xy)+coef0)^degree

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmKernelType Poly = 1
Public Const Poly As SVMSvmKernelType = 1
public:
literal SVMSvmKernelType^ Poly = 1
static val mutable Poly: SVMSvmKernelType

Field Value

Type: SVMSvmKernelType
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.Rbf Field

SVMSvmKernelTypeRbf Field

Radial-basis-function kernel; a good choice in most cases: d(x,y) = exp(-gamma*|x-y|^2)

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmKernelType Rbf = 2
Public Const Rbf As SVMSvmKernelType = 2
public:
literal SVMSvmKernelType^ Rbf = 2
static val mutable Rbf: SVMSvmKernelType

Field Value

Type: SVMSvmKernelType
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.Sigmoid Field

SVMSvmKernelTypeSigmoid Field

sigmoid function is used as a kernel: d(x,y) = tanh(gamma*(xy)+coef0)

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmKernelType Sigmoid = 3
Public Const Sigmoid As SVMSvmKernelType = 3
public:
literal SVMSvmKernelType^ Sigmoid = 3
static val mutable Sigmoid: SVMSvmKernelType

Field Value

Type: SVMSvmKernelType
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmKernelType.value__ Field

SVMSvmKernelTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.SVM.SvmKernelType.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SVMSvmKernelType Class
Emgu.CV.ML Namespace


SVM.SvmType Class

SVMSvmType Class

Type of SVM
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLSVMSvmType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SvmType : Enum
Public NotInheritable Class SvmType
    Inherits Enum
public ref class SvmType sealed : public Enum
[<SealedAttribute>]
type SvmType =
    class
        inherit Enum
    end

The SVMSvmType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CSvc | n-class classification (n>=2), allows imperfect separation of classes with penalty multiplier C for outliers
 | EpsSvr | Regression. The distance between feature vectors from the training set and the fitting hyper-plane must be less than p. For outliers the penalty multiplier C is used
 | NuSvc | n-class classification with possible imperfect separation. Parameter nu (in the range 0..1, the larger the value, the smoother the decision boundary) is used instead of C
 | NuSvr | Regression; nu is used instead of p.
 | OneClass | one-class SVM. All the training data are from the same class, SVM builds a boundary that separates the class from the rest of the feature space
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


SvmType Methods

The SVMSvmType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SvmType Fields

The SVMSvmType type exposes the following members.

Fields
 | Name | Description
 | CSvc | n-class classification (n>=2), allows imperfect separation of classes with penalty multiplier C for outliers
 | EpsSvr | Regression. The distance between feature vectors from the training set and the fitting hyper-plane must be less than p. For outliers the penalty multiplier C is used
 | NuSvc | n-class classification with possible imperfect separation. Parameter nu (in the range 0..1, the larger the value, the smoother the decision boundary) is used instead of C
 | NuSvr | Regression; nu is used instead of p.
 | OneClass | one-class SVM. All the training data are from the same class, SVM builds a boundary that separates the class from the rest of the feature space
Public field | value__ |
Top
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SVM.SvmType.CSvc Field

SVMSvmTypeCSvc Field

n-class classification (n>=2), allows imperfect separation of classes with penalty multiplier C for outliers

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmType CSvc = 100
Public Const CSvc As SVMSvmType = 100
public:
literal SVMSvmType^ CSvc = 100
static val mutable CSvc: SVMSvmType

Field Value

Type: SVMSvmType
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SVM.SvmType.EpsSvr Field

SVMSvmTypeEpsSvr Field

Regression. The distance between feature vectors from the training set and the fitting hyper-plane must be less than p. For outliers the penalty multiplier C is used

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmType EpsSvr = 103
Public Const EpsSvr As SVMSvmType = 103
public:
literal SVMSvmType^ EpsSvr = 103
static val mutable EpsSvr: SVMSvmType

Field Value

Type: SVMSvmType
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SVM.SvmType.NuSvc Field

SVMSvmTypeNuSvc Field

n-class classification with possible imperfect separation. Parameter nu (in the range 0..1, the larger the value, the smoother the decision boundary) is used instead of C

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmType NuSvc = 101
Public Const NuSvc As SVMSvmType = 101
public:
literal SVMSvmType^ NuSvc = 101
static val mutable NuSvc: SVMSvmType

Field Value

Type: SVMSvmType
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SVM.SvmType.NuSvr Field

SVMSvmTypeNuSvr Field

Regression; nu is used instead of p.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmType NuSvr = 104
Public Const NuSvr As SVMSvmType = 104
public:
literal SVMSvmType^ NuSvr = 104
static val mutable NuSvr: SVMSvmType

Field Value

Type: SVMSvmType
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SVM.SvmType.OneClass Field

SVMSvmTypeOneClass Field

one-class SVM. All the training data are from the same class, SVM builds a boundary that separates the class from the rest of the feature space

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSvmType OneClass = 102
Public Const OneClass As SVMSvmType = 102
public:
literal SVMSvmType^ OneClass = 102
static val mutable OneClass: SVMSvmType

Field Value

Type: SVMSvmType
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SVM.SvmType.value__ Field

SVMSvmTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.SVM.SvmType.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SVMSvmType Class
Emgu.CV.ML Namespace


SVMSGD Class

Support Vector Machine
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.MLSVMSGD

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SVMSGD : UnmanagedObject, IStatModel,
    IAlgorithm
Public Class SVMSGD
    Inherits UnmanagedObject
    Implements IStatModel, IAlgorithm
public ref class SVMSGD : public UnmanagedObject,
    IStatModel, IAlgorithm
type SVMSGD =
    class
        inherit UnmanagedObject
        interface IStatModel
        interface IAlgorithm
    end

The SVMSGD type exposes the following members.

Constructors
 | Name | Description
Public method | SVMSGD | Create a support Vector Machine
Top
Properties
 | Name | Description
Public property | InitialStepSize | initialStepSize of a SVMSGD optimization problem
Public property | Margin | Margin type
Public property | MarginRegularization | marginRegularization of a SVMSGD optimization problem
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | StepDecreasingPower | stepDecreasingPower of a SVMSGD optimization problem
Public property | TermCriteria | Termination criteria of the training algorithm.
Public property | Type | Algorithm type
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with the SVMSGD model (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetOptimalParameters | Set the optimal parameters for the given model type
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.ML Namespace


SVMSGD Constructor

Create a support Vector Machine

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SVMSGD()
Public Sub New
public:
SVMSGD()
new : unit -> SVMSGD
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD Properties

The SVMSGD type exposes the following members.

Properties
 | Name | Description
Public property | InitialStepSize | initialStepSize of a SVMSGD optimization problem
Public property | Margin | Margin type
Public property | MarginRegularization | marginRegularization of a SVMSGD optimization problem
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | StepDecreasingPower | stepDecreasingPower of a SVMSGD optimization problem
Public property | TermCriteria | Termination criteria of the training algorithm.
Public property | Type | Algorithm type
Top
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.InitialStepSize Property

SVMSGDInitialStepSize Property

initialStepSize of a SVMSGD optimization problem

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float InitialStepSize { get; set; }
Public Property InitialStepSize As Single
    Get
    Set
public:
property float InitialStepSize {
    float get ();
    void set (float value);
}
member InitialStepSize : float32 with get, set

Property Value

Type: Single
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.Margin Property

SVMSGDMargin Property

Margin type

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SVMSGDMarginType Margin { get; set; }
Public Property Margin As SVMSGDMarginType
    Get
    Set
public:
property SVMSGDMarginType^ Margin {
    SVMSGDMarginType^ get ();
    void set (SVMSGDMarginType^ value);
}
member Margin : SVMSGDMarginType with get, set

Property Value

Type: SVMSGDMarginType
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.MarginRegularization Property

SVMSGDMarginRegularization Property

marginRegularization of a SVMSGD optimization problem

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MarginRegularization { get; set; }
Public Property MarginRegularization As Single
    Get
    Set
public:
property float MarginRegularization {
    float get ();
    void set (float value);
}
member MarginRegularization : float32 with get, set

Property Value

Type: Single
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.StepDecreasingPower Property

SVMSGDStepDecreasingPower Property

stepDecreasingPower of a SVMSGD optimization problem

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float StepDecreasingPower { get; set; }
Public Property StepDecreasingPower As Single
    Get
    Set
public:
property float StepDecreasingPower {
    float get ();
    void set (float value);
}
member StepDecreasingPower : float32 with get, set

Property Value

Type: Single
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.TermCriteria Property

SVMSGDTermCriteria Property

Termination criteria of the training algorithm.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria TermCriteria { get; set; }
Public Property TermCriteria As MCvTermCriteria
    Get
    Set
public:
property MCvTermCriteria^ TermCriteria {
    MCvTermCriteria^ get ();
    void set (MCvTermCriteria^ value);
}
member TermCriteria : MCvTermCriteria with get, set

Property Value

Type: MCvTermCriteria
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.Type Property

SVMSGDType Property

Algorithm type

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SVMSGDSvmsgdType Type { get; set; }
Public Property Type As SVMSGDSvmsgdType
    Get
    Set
public:
property SVMSGDSvmsgdType^ Type {
    SVMSGDSvmsgdType^ get ();
    void set (SVMSGDSvmsgdType^ value);
}
member Type : SVMSGDSvmsgdType with get, set

Property Value

Type: SVMSGDSvmsgdType
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD Methods

The SVMSGD type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the memory associated with the SVMSGD model (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetOptimalParameters | Set the optimal parameters for the given model type
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Predict | Predicts response(s) for the provided sample(s) (Defined by StatModelExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Train(TrainData, Int32) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Train(IInputArray, DataLayoutType, IInputArray) | Overloaded. Trains the statistical model. (Defined by StatModelExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.DisposeObject Method

SVMSGDDisposeObject Method

Release all the memory associated with the SVMSGD model

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.SetOptimalParameters Method

SVMSGDSetOptimalParameters Method

Set the optimal parameters for the given model type

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetOptimalParameters(
    SVMSGDSvmsgdType svmsgdType,
    SVMSGDMarginType marginType
)
Public Sub SetOptimalParameters (
    svmsgdType As SVMSGDSvmsgdType,
    marginType As SVMSGDMarginType
)
public:
void SetOptimalParameters(
    SVMSGDSvmsgdType^ svmsgdType,
    SVMSGDMarginType^ marginType
)
member SetOptimalParameters :
        svmsgdType : SVMSGDSvmsgdType *
        marginType : SVMSGDMarginType -> unit

Parameters

svmsgdType
Type: Emgu.CV.MLSVMSGDSvmsgdType
SVMSGD type
marginType
Type: Emgu.CV.MLSVMSGDMarginType
Margin type
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD Fields

The SVMSGD type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SVMSGD Class
Emgu.CV.ML Namespace


SVMSGD.MarginType Class

SVMSGDMarginType Class

Margin type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLSVMSGDMarginType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MarginType : Enum
Public NotInheritable Class MarginType
    Inherits Enum
public ref class MarginType sealed : public Enum
[<SealedAttribute>]
type MarginType =
    class
        inherit Enum
    end

The SVMSGDMarginType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | HardMargin | More accurate for the case of linearly separable sets.
 | SoftMargin | General case, suits to the case of non-linearly separable sets, allows outliers.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


MarginType Methods

The SVMSGDMarginType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SVMSGDMarginType Class
Emgu.CV.ML Namespace


MarginType Fields

The SVMSGDMarginType type exposes the following members.

Fields
 | Name | Description
 | HardMargin | More accurate for the case of linearly separable sets.
 | SoftMargin | General case, suits to the case of non-linearly separable sets, allows outliers.
Public field | value__ |
Top
See Also

Reference

SVMSGDMarginType Class
Emgu.CV.ML Namespace


SVMSGD.MarginType.HardMargin Field

SVMSGDMarginTypeHardMargin Field

More accurate for the case of linearly separable sets.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSGDMarginType HardMargin = 1
Public Const HardMargin As SVMSGDMarginType = 1
public:
literal SVMSGDMarginType^ HardMargin = 1
static val mutable HardMargin: SVMSGDMarginType

Field Value

Type: SVMSGDMarginType
See Also

Reference

SVMSGDMarginType Class
Emgu.CV.ML Namespace


SVMSGD.MarginType.SoftMargin Field

SVMSGDMarginTypeSoftMargin Field

General case, suits to the case of non-linearly separable sets, allows outliers.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSGDMarginType SoftMargin = 0
Public Const SoftMargin As SVMSGDMarginType = 0
public:
literal SVMSGDMarginType^ SoftMargin = 0
static val mutable SoftMargin: SVMSGDMarginType

Field Value

Type: SVMSGDMarginType
See Also

Reference

SVMSGDMarginType Class
Emgu.CV.ML Namespace


SVMSGD.MarginType.value__ Field

SVMSGDMarginTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.SVMSGD.MarginType.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SVMSGDMarginType Class
Emgu.CV.ML Namespace


SVMSGD.SvmsgdType Class

SVMSGDSvmsgdType Class

SVMSGD type. ASGD is often the preferable choice.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.MLSVMSGDSvmsgdType

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SvmsgdType : Enum
Public NotInheritable Class SvmsgdType
    Inherits Enum
public ref class SvmsgdType sealed : public Enum
[<SealedAttribute>]
type SvmsgdType =
    class
        inherit Enum
    end

The SVMSGDSvmsgdType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Asgd | Average Stochastic Gradient Descent
 | Sgd | Stochastic Gradient Descent
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML Namespace


SvmsgdType Methods

The SVMSGDSvmsgdType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SVMSGDSvmsgdType Class
Emgu.CV.ML Namespace


SvmsgdType Fields

The SVMSGDSvmsgdType type exposes the following members.

Fields
 | Name | Description
 | Asgd | Average Stochastic Gradient Descent
 | Sgd | Stochastic Gradient Descent
Public field | value__ |
Top
See Also

Reference

SVMSGDSvmsgdType Class
Emgu.CV.ML Namespace


SVMSGD.SvmsgdType.Asgd Field

SVMSGDSvmsgdTypeAsgd Field

Average Stochastic Gradient Descent

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSGDSvmsgdType Asgd = 1
Public Const Asgd As SVMSGDSvmsgdType = 1
public:
literal SVMSGDSvmsgdType^ Asgd = 1
static val mutable Asgd: SVMSGDSvmsgdType

Field Value

Type: SVMSGDSvmsgdType
See Also

Reference

SVMSGDSvmsgdType Class
Emgu.CV.ML Namespace


SVMSGD.SvmsgdType.Sgd Field

SVMSGDSvmsgdTypeSgd Field

Stochastic Gradient Descent

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SVMSGDSvmsgdType Sgd = 0
Public Const Sgd As SVMSGDSvmsgdType = 0
public:
literal SVMSGDSvmsgdType^ Sgd = 0
static val mutable Sgd: SVMSGDSvmsgdType

Field Value

Type: SVMSGDSvmsgdType
See Also

Reference

SVMSGDSvmsgdType Class
Emgu.CV.ML Namespace


SVMSGD.SvmsgdType.value__ Field

SVMSGDSvmsgdTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.SVMSGD.SvmsgdType.value__"]

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SVMSGDSvmsgdType Class
Emgu.CV.ML Namespace


TrainData Class

Train data
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.MLTrainData

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrainData : SharedPtrObject
Public Class TrainData
    Inherits SharedPtrObject
public ref class TrainData : public SharedPtrObject
type TrainData =
    class
        inherit SharedPtrObject
    end

The TrainData type exposes the following members.

Constructors
 | Name | Description
Public method | TrainData | Creates training data from in-memory arrays.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.ML Namespace


TrainData Constructor

Creates training data from in-memory arrays.

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrainData(
    IInputArray samples,
    DataLayoutType layoutType,
    IInputArray response,
    IInputArray varIdx = null,
    IInputArray sampleIdx = null,
    IInputArray sampleWeight = null,
    IInputArray varType = null
)
Public Sub New (
    samples As IInputArray,
    layoutType As DataLayoutType,
    response As IInputArray,
    Optional varIdx As IInputArray = Nothing,
    Optional sampleIdx As IInputArray = Nothing,
    Optional sampleWeight As IInputArray = Nothing,
    Optional varType As IInputArray = Nothing
)
public:
TrainData(
    IInputArray^ samples,
    DataLayoutType^ layoutType,
    IInputArray^ response,
    IInputArray^ varIdx = nullptr,
    IInputArray^ sampleIdx = nullptr,
    IInputArray^ sampleWeight = nullptr,
    IInputArray^ varType = nullptr
)
new :
        samples : IInputArray *
        layoutType : DataLayoutType *
        response : IInputArray *
        ?varIdx : IInputArray *
        ?sampleIdx : IInputArray *
        ?sampleWeight : IInputArray *
        ?varType : IInputArray
(* Defaults:
        let _varIdx = defaultArg varIdx null
        let _sampleIdx = defaultArg sampleIdx null
        let _sampleWeight = defaultArg sampleWeight null
        let _varType = defaultArg varType null
*)
-> TrainData

Parameters

samples
Type: Emgu.CVIInputArray
Matrix of samples. It should have CV_32F type.
layoutType
Type: Emgu.CV.ML.MlEnumDataLayoutType
Type of the layout.
response
Type: Emgu.CVIInputArray
Matrix of responses. If the responses are scalar, they should be stored as a single row or as a single column. The matrix should have type CV_32F or CV_32S (in the former case the responses are considered as ordered by default; in the latter case - as categorical)
varIdx (Optional)
Type: Emgu.CVIInputArray
Vector specifying which variables to use for training. It can be an integer vector (CV_32S) containing 0-based variable indices or byte vector (CV_8U) containing a mask of active variables.
sampleIdx (Optional)
Type: Emgu.CVIInputArray
Vector specifying which samples to use for training. It can be an integer vector (CV_32S) containing 0-based sample indices or byte vector (CV_8U) containing a mask of training samples.
sampleWeight (Optional)
Type: Emgu.CVIInputArray
Optional vector with weights for each sample. It should have CV_32F type.
varType (Optional)
Type: Emgu.CVIInputArray
Optional vector of type CV_8U and size <number_of_variables_in_samples> + <number_of_variables_in_responses>, containing types of each input and output variable.
See Also

Reference

TrainData Class
Emgu.CV.ML Namespace


TrainData Properties

The TrainData type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

TrainData Class
Emgu.CV.ML Namespace


TrainData Methods

The TrainData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TrainData Class
Emgu.CV.ML Namespace


TrainData.DisposeObject Method

TrainDataDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV.ML
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrainData Class
Emgu.CV.ML Namespace


TrainData Fields

The TrainData type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

TrainData Class
Emgu.CV.ML Namespace


Emgu.CV.ML.MlEnum Namespace

OpenCV's Machine Learning enumeration
Classes
 | Class | Description
Public class | AnnMlpTrainingFlag | The flags for the neural network training function
Public class | BoostSplitCreiteria | Splitting criteria, used to choose optimal splits during a weak tree construction
Public class | BoostType | Boosting type
Public class | DataLayoutType | The data layout type
Public class | VarType | Variable type


AnnMlpTrainingFlag Class

The flags for the neural network training function
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ML.MlEnumAnnMlpTrainingFlag

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class AnnMlpTrainingFlag : Enum
<FlagsAttribute>
Public NotInheritable Class AnnMlpTrainingFlag
    Inherits Enum
[FlagsAttribute]
public ref class AnnMlpTrainingFlag sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type AnnMlpTrainingFlag =
    class
        inherit Enum
    end

The AnnMlpTrainingFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Default
 | NoInputScale | No input scale
 | NoOutputScale | No output scale
 | UpdateWeights | Update weights
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML.MlEnum Namespace


AnnMlpTrainingFlag Methods

The AnnMlpTrainingFlag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

AnnMlpTrainingFlag Class
Emgu.CV.ML.MlEnum Namespace


AnnMlpTrainingFlag Fields

The AnnMlpTrainingFlag type exposes the following members.

Fields
 | Name | Description
 | Default | Default
 | NoInputScale | No input scale
 | NoOutputScale | No output scale
 | UpdateWeights | Update weights
Public field | value__ |
Top
See Also

Reference

AnnMlpTrainingFlag Class
Emgu.CV.ML.MlEnum Namespace


AnnMlpTrainingFlag.Default Field

AnnMlpTrainingFlagDefault Field

Default

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AnnMlpTrainingFlag Default = 0
Public Const Default As AnnMlpTrainingFlag = 0
public:
literal AnnMlpTrainingFlag^ Default = 0
static val mutable Default: AnnMlpTrainingFlag

Field Value

Type: AnnMlpTrainingFlag
See Also

Reference

AnnMlpTrainingFlag Class
Emgu.CV.ML.MlEnum Namespace


AnnMlpTrainingFlag.NoInputScale Field

AnnMlpTrainingFlagNoInputScale Field

No input scale

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AnnMlpTrainingFlag NoInputScale = 2
Public Const NoInputScale As AnnMlpTrainingFlag = 2
public:
literal AnnMlpTrainingFlag^ NoInputScale = 2
static val mutable NoInputScale: AnnMlpTrainingFlag

Field Value

Type: AnnMlpTrainingFlag
See Also

Reference

AnnMlpTrainingFlag Class
Emgu.CV.ML.MlEnum Namespace


AnnMlpTrainingFlag.NoOutputScale Field

AnnMlpTrainingFlagNoOutputScale Field

No output scale

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AnnMlpTrainingFlag NoOutputScale = 4
Public Const NoOutputScale As AnnMlpTrainingFlag = 4
public:
literal AnnMlpTrainingFlag^ NoOutputScale = 4
static val mutable NoOutputScale: AnnMlpTrainingFlag

Field Value

Type: AnnMlpTrainingFlag
See Also

Reference

AnnMlpTrainingFlag Class
Emgu.CV.ML.MlEnum Namespace


AnnMlpTrainingFlag.UpdateWeights Field

AnnMlpTrainingFlagUpdateWeights Field

Update weights

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const AnnMlpTrainingFlag UpdateWeights = 1
Public Const UpdateWeights As AnnMlpTrainingFlag = 1
public:
literal AnnMlpTrainingFlag^ UpdateWeights = 1
static val mutable UpdateWeights: AnnMlpTrainingFlag

Field Value

Type: AnnMlpTrainingFlag
See Also

Reference

AnnMlpTrainingFlag Class
Emgu.CV.ML.MlEnum Namespace


AnnMlpTrainingFlag.value__ Field

AnnMlpTrainingFlagvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.MlEnum.AnnMlpTrainingFlag.value__"]

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

AnnMlpTrainingFlag Class
Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria Class

Splitting criteria, used to choose optimal splits during a weak tree construction
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ML.MlEnumBoostSplitCreiteria

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class BoostSplitCreiteria : Enum
Public NotInheritable Class BoostSplitCreiteria
    Inherits Enum
public ref class BoostSplitCreiteria sealed : public Enum
[<SealedAttribute>]
type BoostSplitCreiteria =
    class
        inherit Enum
    end

The BoostSplitCreiteria type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Use the default criteria for the particular boosting method
 | Gini | Use Gini index. This is default option for Real AdaBoost; may be also used for Discrete AdaBoost
 | Misclass | Use misclassification rate. This is default option for Discrete AdaBoost; may be also used for Real AdaBoost
 | Sqerr | Use least squares criteria. This is default and the only option for LogitBoost and Gentle AdaBoost
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria Methods

The BoostSplitCreiteria type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BoostSplitCreiteria Class
Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria Fields

The BoostSplitCreiteria type exposes the following members.

Fields
 | Name | Description
 | Default | Use the default criteria for the particular boosting method
 | Gini | Use Gini index. This is default option for Real AdaBoost; may be also used for Discrete AdaBoost
 | Misclass | Use misclassification rate. This is default option for Discrete AdaBoost; may be also used for Real AdaBoost
 | Sqerr | Use least squares criteria. This is default and the only option for LogitBoost and Gentle AdaBoost
Public field | value__ |
Top
See Also

Reference

BoostSplitCreiteria Class
Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria.Default Field

BoostSplitCreiteriaDefault Field

Use the default criteria for the particular boosting method

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostSplitCreiteria Default = 0
Public Const Default As BoostSplitCreiteria = 0
public:
literal BoostSplitCreiteria^ Default = 0
static val mutable Default: BoostSplitCreiteria

Field Value

Type: BoostSplitCreiteria
See Also

Reference

BoostSplitCreiteria Class
Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria.Gini Field

BoostSplitCreiteriaGini Field

Use Gini index. This is default option for Real AdaBoost; may be also used for Discrete AdaBoost

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostSplitCreiteria Gini = 1
Public Const Gini As BoostSplitCreiteria = 1
public:
literal BoostSplitCreiteria^ Gini = 1
static val mutable Gini: BoostSplitCreiteria

Field Value

Type: BoostSplitCreiteria
See Also

Reference

BoostSplitCreiteria Class
Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria.Misclass Field

BoostSplitCreiteriaMisclass Field

Use misclassification rate. This is default option for Discrete AdaBoost; may be also used for Real AdaBoost

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostSplitCreiteria Misclass = 3
Public Const Misclass As BoostSplitCreiteria = 3
public:
literal BoostSplitCreiteria^ Misclass = 3
static val mutable Misclass: BoostSplitCreiteria

Field Value

Type: BoostSplitCreiteria
See Also

Reference

BoostSplitCreiteria Class
Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria.Sqerr Field

BoostSplitCreiteriaSqerr Field

Use least squares criteria. This is default and the only option for LogitBoost and Gentle AdaBoost

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostSplitCreiteria Sqerr = 4
Public Const Sqerr As BoostSplitCreiteria = 4
public:
literal BoostSplitCreiteria^ Sqerr = 4
static val mutable Sqerr: BoostSplitCreiteria

Field Value

Type: BoostSplitCreiteria
See Also

Reference

BoostSplitCreiteria Class
Emgu.CV.ML.MlEnum Namespace


BoostSplitCreiteria.value__ Field

BoostSplitCreiteriavalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.MlEnum.BoostSplitCreiteria.value__"]

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BoostSplitCreiteria Class
Emgu.CV.ML.MlEnum Namespace


BoostType Class

Boosting type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ML.MlEnumBoostType

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class BoostType : Enum
Public NotInheritable Class BoostType
    Inherits Enum
public ref class BoostType sealed : public Enum
[<SealedAttribute>]
type BoostType =
    class
        inherit Enum
    end

The BoostType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Discrete | Discrete AdaBoost
 | Gentle | Gentle AdaBoost
 | Logit | LogitBoost
 | Real | Real AdaBoost
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML.MlEnum Namespace


BoostType Methods

The BoostType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BoostType Class
Emgu.CV.ML.MlEnum Namespace


BoostType Fields

The BoostType type exposes the following members.

Fields
 | Name | Description
 | Discrete | Discrete AdaBoost
 | Gentle | Gentle AdaBoost
 | Logit | LogitBoost
 | Real | Real AdaBoost
Public field | value__ |
Top
See Also

Reference

BoostType Class
Emgu.CV.ML.MlEnum Namespace


BoostType.Discrete Field

BoostTypeDiscrete Field

Discrete AdaBoost

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Discrete = 0
Public Const Discrete As BoostType = 0
public:
literal BoostType^ Discrete = 0
static val mutable Discrete: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML.MlEnum Namespace


BoostType.Gentle Field

BoostTypeGentle Field

Gentle AdaBoost

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Gentle = 3
Public Const Gentle As BoostType = 3
public:
literal BoostType^ Gentle = 3
static val mutable Gentle: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML.MlEnum Namespace


BoostType.Logit Field

BoostTypeLogit Field

LogitBoost

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Logit = 2
Public Const Logit As BoostType = 2
public:
literal BoostType^ Logit = 2
static val mutable Logit: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML.MlEnum Namespace


BoostType.Real Field

BoostTypeReal Field

Real AdaBoost

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostType Real = 1
Public Const Real As BoostType = 1
public:
literal BoostType^ Real = 1
static val mutable Real: BoostType

Field Value

Type: BoostType
See Also

Reference

BoostType Class
Emgu.CV.ML.MlEnum Namespace


BoostType.value__ Field

BoostTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.MlEnum.BoostType.value__"]

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BoostType Class
Emgu.CV.ML.MlEnum Namespace


DataLayoutType Class

The data layout type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ML.MlEnumDataLayoutType

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DataLayoutType : Enum
Public NotInheritable Class DataLayoutType
    Inherits Enum
public ref class DataLayoutType sealed : public Enum
[<SealedAttribute>]
type DataLayoutType =
    class
        inherit Enum
    end

The DataLayoutType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ColSample | Feature vectors are stored as cols
 | RowSample | Feature vectors are stored as rows
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML.MlEnum Namespace


DataLayoutType Methods

The DataLayoutType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DataLayoutType Class
Emgu.CV.ML.MlEnum Namespace


DataLayoutType Fields

The DataLayoutType type exposes the following members.

Fields
 | Name | Description
 | ColSample | Feature vectors are stored as cols
 | RowSample | Feature vectors are stored as rows
Public field | value__ |
Top
See Also

Reference

DataLayoutType Class
Emgu.CV.ML.MlEnum Namespace


DataLayoutType.ColSample Field

DataLayoutTypeColSample Field

Feature vectors are stored as cols

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DataLayoutType ColSample = 1
Public Const ColSample As DataLayoutType = 1
public:
literal DataLayoutType^ ColSample = 1
static val mutable ColSample: DataLayoutType

Field Value

Type: DataLayoutType
See Also

Reference

DataLayoutType Class
Emgu.CV.ML.MlEnum Namespace


DataLayoutType.RowSample Field

DataLayoutTypeRowSample Field

Feature vectors are stored as rows

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DataLayoutType RowSample = 0
Public Const RowSample As DataLayoutType = 0
public:
literal DataLayoutType^ RowSample = 0
static val mutable RowSample: DataLayoutType

Field Value

Type: DataLayoutType
See Also

Reference

DataLayoutType Class
Emgu.CV.ML.MlEnum Namespace


DataLayoutType.value__ Field

DataLayoutTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.MlEnum.DataLayoutType.value__"]

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DataLayoutType Class
Emgu.CV.ML.MlEnum Namespace


VarType Class

Variable type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.ML.MlEnumVarType

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class VarType : Enum
Public NotInheritable Class VarType
    Inherits Enum
public ref class VarType sealed : public Enum
[<SealedAttribute>]
type VarType =
    class
        inherit Enum
    end

The VarType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Categorical | Categorical
 | Numerical | Numerical or Ordered
Public field | value__ |
Top
See Also

Reference

Emgu.CV.ML.MlEnum Namespace


VarType Methods

The VarType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

VarType Class
Emgu.CV.ML.MlEnum Namespace


VarType Fields

The VarType type exposes the following members.

Fields
 | Name | Description
 | Categorical | Categorical
 | Numerical | Numerical or Ordered
Public field | value__ |
Top
See Also

Reference

VarType Class
Emgu.CV.ML.MlEnum Namespace


VarType.Categorical Field

VarTypeCategorical Field

Categorical

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VarType Categorical = 1
Public Const Categorical As VarType = 1
public:
literal VarType^ Categorical = 1
static val mutable Categorical: VarType

Field Value

Type: VarType
See Also

Reference

VarType Class
Emgu.CV.ML.MlEnum Namespace


VarType.Numerical Field

VarTypeNumerical Field

Numerical or Ordered

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VarType Numerical = 0
Public Const Numerical As VarType = 0
public:
literal VarType^ Numerical = 0
static val mutable Numerical: VarType

Field Value

Type: VarType
See Also

Reference

VarType Class
Emgu.CV.ML.MlEnum Namespace


VarType.value__ Field

VarTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.ML.MlEnum.VarType.value__"]

Namespace: Emgu.CV.ML.MlEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

VarType Class
Emgu.CV.ML.MlEnum Namespace


Emgu.CV.Ocl Namespace

Open CL module
Classes
 | Class | Description
Public class | Device | This class contains ocl runtime information
Public class | DeviceType | Ocl Device Type
Public class | FpConfig | Floating point configuration
Public class | Image2D | cv::ocl::Image2D
Public class | Kernel | An opencl kernel
Public class | KernelArg | OpenCL kernel arg
Public class | KernelArgFlags | KernelArg flags
Public class | OclInvoke | Class that contains ocl functions
Public class | PlatformInfo | This class contains ocl platform information
Public class | ProgramSource | Open CL kernel program source code
Public class | Queue | An OpenCL Queue


Device Class

This class contains ocl runtime information
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OclDevice

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Device : UnmanagedObject
Public Class Device
    Inherits UnmanagedObject
public ref class Device : public UnmanagedObject
type Device =
    class
        inherit UnmanagedObject
    end

The Device type exposes the following members.

Constructors
 | Name | Description
Public method | Device | Create a empty OclDevice object
Top
Properties
 | Name | Description
Public property | AddressBits | The AddressBits
Public property | Available | Indicates if the device is available
Public property | CompilerAvailable | Indicates if the compiler is available
 | Default | Get the default OclDevice. Do not dispose this device.
Public property | DeviceVersionMajor | The device major version number
Public property | DeviceVersionMinor | The device minor version number
Public property | DoubleFPConfig | The device double floating point configuration
Public property | DriverVersion | The device driver version
Public property | Extensions | The device extensions
Public property | GlobalMemSize | The global memory size
Public property | HalfFPConfig | The device half floating point configuration
Public property | HostUnifiedMemory | True if the device use unified memory
Public property | Image2DMaxHeight | The image2d max height
Public property | Image2DMaxWidth | The image 2d max width
Public property | IsAMD | Indicates if this is an AMD device
Public property | IsIntel | Indicates if this is an Intel device
Public property | IsNVidia | Indicates if this is an NVidia device
Public property | LinkerAvailable | Indicates if the linker is available
Public property | LocalMemSize | The local memory size
Public property | MaxComputeUnits | The max compute unit
Public property | MaxMemAllocSize | The maximum memory allocation size
Public property | MaxWorkGroupSize | The maximum work group size
Public property | Name | The device name
Public property | NativeDevicePointer | Get the native device pointer
Public property | OpenCLCVersion | The device OpenCL C version
Public property | OpenCLVersion | The device OpenCL version
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SingleFPConfig | The device single floating point configuration
Public property | Type | The ocl device type
Public property | VendorName | The device vendor name
Public property | Version | The device version
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this OclInfo (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Set | Set the native device pointer
Public method | ToString | Get the string representation of this oclDevice (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Ocl Namespace


Device Constructor

Create a empty OclDevice object

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Device()
Public Sub New
public:
Device()
new : unit -> Device
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | AddressBits | The AddressBits
Public property | Available | Indicates if the device is available
Public property | CompilerAvailable | Indicates if the compiler is available
 | Default | Get the default OclDevice. Do not dispose this device.
Public property | DeviceVersionMajor | The device major version number
Public property | DeviceVersionMinor | The device minor version number
Public property | DoubleFPConfig | The device double floating point configuration
Public property | DriverVersion | The device driver version
Public property | Extensions | The device extensions
Public property | GlobalMemSize | The global memory size
Public property | HalfFPConfig | The device half floating point configuration
Public property | HostUnifiedMemory | True if the device use unified memory
Public property | Image2DMaxHeight | The image2d max height
Public property | Image2DMaxWidth | The image 2d max width
Public property | IsAMD | Indicates if this is an AMD device
Public property | IsIntel | Indicates if this is an Intel device
Public property | IsNVidia | Indicates if this is an NVidia device
Public property | LinkerAvailable | Indicates if the linker is available
Public property | LocalMemSize | The local memory size
Public property | MaxComputeUnits | The max compute unit
Public property | MaxMemAllocSize | The maximum memory allocation size
Public property | MaxWorkGroupSize | The maximum work group size
Public property | Name | The device name
Public property | NativeDevicePointer | Get the native device pointer
Public property | OpenCLCVersion | The device OpenCL C version
Public property | OpenCLVersion | The device OpenCL version
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SingleFPConfig | The device single floating point configuration
Public property | Type | The ocl device type
Public property | VendorName | The device vendor name
Public property | Version | The device version
Top
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.AddressBits Property

DeviceAddressBits Property

The AddressBits

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AddressBits { get; }
Public ReadOnly Property AddressBits As Integer
    Get
public:
property int AddressBits {
    int get ();
}
member AddressBits : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Available Property

DeviceAvailable Property

Indicates if the device is available

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Available { get; }
Public ReadOnly Property Available As Boolean
    Get
public:
property bool Available {
    bool get ();
}
member Available : bool with get

Property Value

Type: Boolean
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.CompilerAvailable Property

DeviceCompilerAvailable Property

Indicates if the compiler is available

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool CompilerAvailable { get; }
Public ReadOnly Property CompilerAvailable As Boolean
    Get
public:
property bool CompilerAvailable {
    bool get ();
}
member CompilerAvailable : bool with get

Property Value

Type: Boolean
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Default Property

DeviceDefault Property

Get the default OclDevice. Do not dispose this device.

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Device Default { get; }
Public Shared ReadOnly Property Default As Device
    Get
public:
static property Device^ Default {
    Device^ get ();
}
static member Default : Device with get

Property Value

Type: Device
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.DeviceVersionMajor Property

DeviceDeviceVersionMajor Property

The device major version number

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DeviceVersionMajor { get; }
Public ReadOnly Property DeviceVersionMajor As Integer
    Get
public:
property int DeviceVersionMajor {
    int get ();
}
member DeviceVersionMajor : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.DeviceVersionMinor Property

DeviceDeviceVersionMinor Property

The device minor version number

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DeviceVersionMinor { get; }
Public ReadOnly Property DeviceVersionMinor As Integer
    Get
public:
property int DeviceVersionMinor {
    int get ();
}
member DeviceVersionMinor : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.DoubleFPConfig Property

DeviceDoubleFPConfig Property

The device double floating point configuration

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FpConfig DoubleFPConfig { get; }
Public ReadOnly Property DoubleFPConfig As FpConfig
    Get
public:
property FpConfig^ DoubleFPConfig {
    FpConfig^ get ();
}
member DoubleFPConfig : FpConfig with get

Property Value

Type: FpConfig
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.DriverVersion Property

DeviceDriverVersion Property

The device driver version

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string DriverVersion { get; }
Public ReadOnly Property DriverVersion As String
    Get
public:
property String^ DriverVersion {
    String^ get ();
}
member DriverVersion : string with get

Property Value

Type: String
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Extensions Property

DeviceExtensions Property

The device extensions

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Extensions { get; }
Public ReadOnly Property Extensions As String
    Get
public:
property String^ Extensions {
    String^ get ();
}
member Extensions : string with get

Property Value

Type: String
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.GlobalMemSize Property

DeviceGlobalMemSize Property

The global memory size

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr GlobalMemSize { get; }
Public ReadOnly Property GlobalMemSize As IntPtr
    Get
public:
property IntPtr GlobalMemSize {
    IntPtr get ();
}
member GlobalMemSize : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.HalfFPConfig Property

DeviceHalfFPConfig Property

The device half floating point configuration

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FpConfig HalfFPConfig { get; }
Public ReadOnly Property HalfFPConfig As FpConfig
    Get
public:
property FpConfig^ HalfFPConfig {
    FpConfig^ get ();
}
member HalfFPConfig : FpConfig with get

Property Value

Type: FpConfig
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.HostUnifiedMemory Property

DeviceHostUnifiedMemory Property

True if the device use unified memory

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool HostUnifiedMemory { get; }
Public ReadOnly Property HostUnifiedMemory As Boolean
    Get
public:
property bool HostUnifiedMemory {
    bool get ();
}
member HostUnifiedMemory : bool with get

Property Value

Type: Boolean
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Image2DMaxHeight Property

DeviceImage2DMaxHeight Property

The image2d max height

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Image2DMaxHeight { get; }
Public ReadOnly Property Image2DMaxHeight As Integer
    Get
public:
property int Image2DMaxHeight {
    int get ();
}
member Image2DMaxHeight : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Image2DMaxWidth Property

DeviceImage2DMaxWidth Property

The image 2d max width

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Image2DMaxWidth { get; }
Public ReadOnly Property Image2DMaxWidth As Integer
    Get
public:
property int Image2DMaxWidth {
    int get ();
}
member Image2DMaxWidth : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.IsAMD Property

DeviceIsAMD Property

Indicates if this is an AMD device

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsAMD { get; }
Public ReadOnly Property IsAMD As Boolean
    Get
public:
property bool IsAMD {
    bool get ();
}
member IsAMD : bool with get

Property Value

Type: Boolean
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.IsIntel Property

DeviceIsIntel Property

Indicates if this is an Intel device

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsIntel { get; }
Public ReadOnly Property IsIntel As Boolean
    Get
public:
property bool IsIntel {
    bool get ();
}
member IsIntel : bool with get

Property Value

Type: Boolean
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.IsNVidia Property

DeviceIsNVidia Property

Indicates if this is an NVidia device

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsNVidia { get; }
Public ReadOnly Property IsNVidia As Boolean
    Get
public:
property bool IsNVidia {
    bool get ();
}
member IsNVidia : bool with get

Property Value

Type: Boolean
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.LinkerAvailable Property

DeviceLinkerAvailable Property

Indicates if the linker is available

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool LinkerAvailable { get; }
Public ReadOnly Property LinkerAvailable As Boolean
    Get
public:
property bool LinkerAvailable {
    bool get ();
}
member LinkerAvailable : bool with get

Property Value

Type: Boolean
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.LocalMemSize Property

DeviceLocalMemSize Property

The local memory size

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int LocalMemSize { get; }
Public ReadOnly Property LocalMemSize As Integer
    Get
public:
property int LocalMemSize {
    int get ();
}
member LocalMemSize : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.MaxComputeUnits Property

DeviceMaxComputeUnits Property

The max compute unit

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxComputeUnits { get; }
Public ReadOnly Property MaxComputeUnits As Integer
    Get
public:
property int MaxComputeUnits {
    int get ();
}
member MaxComputeUnits : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.MaxMemAllocSize Property

DeviceMaxMemAllocSize Property

The maximum memory allocation size

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxMemAllocSize { get; }
Public ReadOnly Property MaxMemAllocSize As Integer
    Get
public:
property int MaxMemAllocSize {
    int get ();
}
member MaxMemAllocSize : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.MaxWorkGroupSize Property

DeviceMaxWorkGroupSize Property

The maximum work group size

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxWorkGroupSize { get; }
Public ReadOnly Property MaxWorkGroupSize As Integer
    Get
public:
property int MaxWorkGroupSize {
    int get ();
}
member MaxWorkGroupSize : int with get

Property Value

Type: Int32
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Name Property

DeviceName Property

The device name

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.NativeDevicePointer Property

DeviceNativeDevicePointer Property

Get the native device pointer

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr NativeDevicePointer { get; }
Public ReadOnly Property NativeDevicePointer As IntPtr
    Get
public:
property IntPtr NativeDevicePointer {
    IntPtr get ();
}
member NativeDevicePointer : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.OpenCLCVersion Property

DeviceOpenCLCVersion Property

The device OpenCL C version

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string OpenCLCVersion { get; }
Public ReadOnly Property OpenCLCVersion As String
    Get
public:
property String^ OpenCLCVersion {
    String^ get ();
}
member OpenCLCVersion : string with get

Property Value

Type: String
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.OpenCLVersion Property

DeviceOpenCLVersion Property

The device OpenCL version

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string OpenCLVersion { get; }
Public ReadOnly Property OpenCLVersion As String
    Get
public:
property String^ OpenCLVersion {
    String^ get ();
}
member OpenCLVersion : string with get

Property Value

Type: String
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.SingleFPConfig Property

DeviceSingleFPConfig Property

The device single floating point configuration

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FpConfig SingleFPConfig { get; }
Public ReadOnly Property SingleFPConfig As FpConfig
    Get
public:
property FpConfig^ SingleFPConfig {
    FpConfig^ get ();
}
member SingleFPConfig : FpConfig with get

Property Value

Type: FpConfig
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Type Property

DeviceType Property

The ocl device type

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DeviceType Type { get; }
Public ReadOnly Property Type As DeviceType
    Get
public:
property DeviceType^ Type {
    DeviceType^ get ();
}
member Type : DeviceType with get

Property Value

Type: DeviceType
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.VendorName Property

DeviceVendorName Property

The device vendor name

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string VendorName { get; }
Public ReadOnly Property VendorName As String
    Get
public:
property String^ VendorName {
    String^ get ();
}
member VendorName : string with get

Property Value

Type: String
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Version Property

DeviceVersion Property

The device version

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
member Version : string with get

Property Value

Type: String
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this OclInfo (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Set | Set the native device pointer
Public method | ToString | Get the string representation of this oclDevice (Overrides ObjectToString.)
Top
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.DisposeObject Method

DeviceDisposeObject Method

Release all the unmanaged memory associated with this OclInfo

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.Set Method

DeviceSet Method

Set the native device pointer

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Set(
    IntPtr nativeDevicePointer
)
Public Sub Set (
    nativeDevicePointer As IntPtr
)
public:
void Set(
    IntPtr nativeDevicePointer
)
member Set :
        nativeDevicePointer : IntPtr -> unit

Parameters

nativeDevicePointer
Type: SystemIntPtr

[Missing <param name="nativeDevicePointer"/> documentation for "M:Emgu.CV.Ocl.Device.Set(System.IntPtr)"]

See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device.ToString Method

DeviceToString Method

Get the string representation of this oclDevice

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string representation of this oclDevice
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


Device Fields

The Device type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Device Class
Emgu.CV.Ocl Namespace


DeviceType Class

Ocl Device Type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OclDeviceType

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DeviceType : Enum
Public NotInheritable Class DeviceType
    Inherits Enum
public ref class DeviceType sealed : public Enum
[<SealedAttribute>]
type DeviceType =
    class
        inherit Enum
    end

The DeviceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Accelerator | Accerlerator
 | All | All
 | Cpu | Cpu
 | Default | Default
 | DGpu | DGpu
 | Gpu | Gpu
 | IGpu | IGpu
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Ocl Namespace


DeviceType Methods

The DeviceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType Fields

The DeviceType type exposes the following members.

Fields
 | Name | Description
 | Accelerator | Accerlerator
 | All | All
 | Cpu | Cpu
 | Default | Default
 | DGpu | DGpu
 | Gpu | Gpu
 | IGpu | IGpu
Public field | value__ |
Top
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.Accelerator Field

DeviceTypeAccelerator Field

Accerlerator

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DeviceType Accelerator = 8
Public Const Accelerator As DeviceType = 8
public:
literal DeviceType^ Accelerator = 8
static val mutable Accelerator: DeviceType

Field Value

Type: DeviceType
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.All Field

DeviceTypeAll Field

All

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DeviceType All = -1
Public Const All As DeviceType = -1
public:
literal DeviceType^ All = -1
static val mutable All: DeviceType

Field Value

Type: DeviceType
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.Cpu Field

DeviceTypeCpu Field

Cpu

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DeviceType Cpu = 2
Public Const Cpu As DeviceType = 2
public:
literal DeviceType^ Cpu = 2
static val mutable Cpu: DeviceType

Field Value

Type: DeviceType
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.Default Field

DeviceTypeDefault Field

Default

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DeviceType Default = 1
Public Const Default As DeviceType = 1
public:
literal DeviceType^ Default = 1
static val mutable Default: DeviceType

Field Value

Type: DeviceType
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.DGpu Field

DeviceTypeDGpu Field

DGpu

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DeviceType DGpu = 65540
Public Const DGpu As DeviceType = 65540
public:
literal DeviceType^ DGpu = 65540
static val mutable DGpu: DeviceType

Field Value

Type: DeviceType
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.Gpu Field

DeviceTypeGpu Field

Gpu

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DeviceType Gpu = 4
Public Const Gpu As DeviceType = 4
public:
literal DeviceType^ Gpu = 4
static val mutable Gpu: DeviceType

Field Value

Type: DeviceType
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.IGpu Field

DeviceTypeIGpu Field

IGpu

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DeviceType IGpu = 131076
Public Const IGpu As DeviceType = 131076
public:
literal DeviceType^ IGpu = 131076
static val mutable IGpu: DeviceType

Field Value

Type: DeviceType
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


DeviceType.value__ Field

DeviceTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Ocl.DeviceType.value__"]

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DeviceType Class
Emgu.CV.Ocl Namespace


FpConfig Class

Floating point configuration
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OclFpConfig

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class FpConfig : Enum
<FlagsAttribute>
Public NotInheritable Class FpConfig
    Inherits Enum
[FlagsAttribute]
public ref class FpConfig sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type FpConfig =
    class
        inherit Enum
    end

The FpConfig type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CorrectlyRoundedDivideSqrt | Correctly rounded divide sqrt
 | Denorm | Denorm
 | Fma | FMA
 | InfNan | inf, nan
 | RoundToInf | round to infinite
 | RoundToNearest | round to nearest
 | RoundToZero | round to zero
 | SoftFloat | soft float
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Ocl Namespace


FpConfig Methods

The FpConfig type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig Fields

The FpConfig type exposes the following members.

Fields
 | Name | Description
 | CorrectlyRoundedDivideSqrt | Correctly rounded divide sqrt
 | Denorm | Denorm
 | Fma | FMA
 | InfNan | inf, nan
 | RoundToInf | round to infinite
 | RoundToNearest | round to nearest
 | RoundToZero | round to zero
 | SoftFloat | soft float
Public field | value__ |
Top
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.CorrectlyRoundedDivideSqrt Field

FpConfigCorrectlyRoundedDivideSqrt Field

Correctly rounded divide sqrt

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig CorrectlyRoundedDivideSqrt = 128
Public Const CorrectlyRoundedDivideSqrt As FpConfig = 128
public:
literal FpConfig^ CorrectlyRoundedDivideSqrt = 128
static val mutable CorrectlyRoundedDivideSqrt: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.Denorm Field

FpConfigDenorm Field

Denorm

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig Denorm = 1
Public Const Denorm As FpConfig = 1
public:
literal FpConfig^ Denorm = 1
static val mutable Denorm: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.Fma Field

FpConfigFma Field

FMA

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig Fma = 32
Public Const Fma As FpConfig = 32
public:
literal FpConfig^ Fma = 32
static val mutable Fma: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.InfNan Field

FpConfigInfNan Field

inf, nan

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig InfNan = 2
Public Const InfNan As FpConfig = 2
public:
literal FpConfig^ InfNan = 2
static val mutable InfNan: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.RoundToInf Field

FpConfigRoundToInf Field

round to infinite

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig RoundToInf = 16
Public Const RoundToInf As FpConfig = 16
public:
literal FpConfig^ RoundToInf = 16
static val mutable RoundToInf: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.RoundToNearest Field

FpConfigRoundToNearest Field

round to nearest

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig RoundToNearest = 4
Public Const RoundToNearest As FpConfig = 4
public:
literal FpConfig^ RoundToNearest = 4
static val mutable RoundToNearest: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.RoundToZero Field

FpConfigRoundToZero Field

round to zero

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig RoundToZero = 8
Public Const RoundToZero As FpConfig = 8
public:
literal FpConfig^ RoundToZero = 8
static val mutable RoundToZero: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.SoftFloat Field

FpConfigSoftFloat Field

soft float

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const FpConfig SoftFloat = 64
Public Const SoftFloat As FpConfig = 64
public:
literal FpConfig^ SoftFloat = 64
static val mutable SoftFloat: FpConfig

Field Value

Type: FpConfig
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


FpConfig.value__ Field

FpConfigvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Ocl.FpConfig.value__"]

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

FpConfig Class
Emgu.CV.Ocl Namespace


Image2D Class

cv::ocl::Image2D
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OclImage2D

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Image2D : UnmanagedObject
Public Class Image2D
    Inherits UnmanagedObject
public ref class Image2D : public UnmanagedObject
type Image2D =
    class
        inherit UnmanagedObject
    end

The Image2D type exposes the following members.

Constructors
 | Name | Description
Public method | Image2D | Create an OclImage2D object from UMat
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this OclImage2D (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Ocl Namespace


Image2D Constructor

Create an OclImage2D object from UMat

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Image2D(
    UMat src,
    bool norm = false,
    bool alias = false
)
Public Sub New (
    src As UMat,
    Optional norm As Boolean = false,
    Optional alias As Boolean = false
)
public:
Image2D(
    UMat^ src,
    bool norm = false,
    bool alias = false
)
new :
        src : UMat *
        ?norm : bool *
        ?alias : bool
(* Defaults:
        let _norm = defaultArg norm false
        let _alias = defaultArg alias false
*)
-> Image2D

Parameters

src
Type: Emgu.CVUMat
The UMat from which to get image properties and data
norm (Optional)
Type: SystemBoolean
Flag to enable the use of normalized channel data types
alias (Optional)
Type: SystemBoolean
Flag indicating that the image should alias the src UMat. If true, changes to the image or src will be reflected in both objects.
See Also

Reference

Image2D Class
Emgu.CV.Ocl Namespace


Image2D Properties

The Image2D type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Image2D Class
Emgu.CV.Ocl Namespace


Image2D Methods

The Image2D type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this OclImage2D (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Image2D Class
Emgu.CV.Ocl Namespace


Image2D.DisposeObject Method

Image2DDisposeObject Method

Release the unmanaged memory associated with this OclImage2D

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Image2D Class
Emgu.CV.Ocl Namespace


Image2D Fields

The Image2D type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Image2D Class
Emgu.CV.Ocl Namespace


Kernel Class

An opencl kernel
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OclKernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Kernel : UnmanagedObject
Public Class Kernel
    Inherits UnmanagedObject
public ref class Kernel : public UnmanagedObject
type Kernel =
    class
        inherit UnmanagedObject
    end

The Kernel type exposes the following members.

Constructors
 | Name | Description
Public method | Kernel | Create an opencl kernel
Top
Properties
 | Name | Description
Public property | Empty | Indicates if the kernel is empty
Public property | NativeKernelPtr | The pointer to the native kernel
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Create | Create an opencl kernel
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the opencl kernel (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Execute the kernel
Public method | Set(Int32, Image2D) | Set the parameters for the kernel
Public method | Set(Int32, KernelArg) | Set the parameters for the kernel
Public method | Set(Int32, UMat) | Set the parameters for the kernel
Public method | Set(Int32, Double) | Set the parameters for the kernel
Public method | Set(Int32, Int32) | Set the parameters for the kernel
Public method | Set(Int32, Single) | Set the parameters for the kernel
Public method | Set(Int32, IntPtr, Int32) | Set the parameters for the kernel
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Ocl Namespace


Kernel Constructor

Create an opencl kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Kernel()
Public Sub New
public:
Kernel()
new : unit -> Kernel
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel Properties

The Kernel type exposes the following members.

Properties
 | Name | Description
Public property | Empty | Indicates if the kernel is empty
Public property | NativeKernelPtr | The pointer to the native kernel
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel.Empty Property

KernelEmpty Property

Indicates if the kernel is empty

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get

Property Value

Type: Boolean
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel.NativeKernelPtr Property

KernelNativeKernelPtr Property

The pointer to the native kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr NativeKernelPtr { get; }
Public ReadOnly Property NativeKernelPtr As IntPtr
    Get
public:
property IntPtr NativeKernelPtr {
    IntPtr get ();
}
member NativeKernelPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel Methods

The Kernel type exposes the following members.

Methods
 | Name | Description
Public method | Create | Create an opencl kernel
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the opencl kernel (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Execute the kernel
Public method | Set(Int32, Image2D) | Set the parameters for the kernel
Public method | Set(Int32, KernelArg) | Set the parameters for the kernel
Public method | Set(Int32, UMat) | Set the parameters for the kernel
Public method | Set(Int32, Double) | Set the parameters for the kernel
Public method | Set(Int32, Int32) | Set the parameters for the kernel
Public method | Set(Int32, Single) | Set the parameters for the kernel
Public method | Set(Int32, IntPtr, Int32) | Set the parameters for the kernel
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel.Create Method

KernelCreate Method

Create an opencl kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Create(
    string kernelName,
    ProgramSource programSource,
    string buildOps = null,
    CvString errMsg = null
)
Public Function Create (
    kernelName As String,
    programSource As ProgramSource,
    Optional buildOps As String = Nothing,
    Optional errMsg As CvString = Nothing
) As Boolean
public:
bool Create(
    String^ kernelName,
    ProgramSource^ programSource,
    String^ buildOps = nullptr,
    CvString^ errMsg = nullptr
)
member Create :
        kernelName : string *
        programSource : ProgramSource *
        ?buildOps : string *
        ?errMsg : CvString
(* Defaults:
        let _buildOps = defaultArg buildOps null
        let _errMsg = defaultArg errMsg null
*)
-> bool

Parameters

kernelName
Type: SystemString
The name of the kernel
programSource
Type: Emgu.CV.OclProgramSource
The program source code
buildOps (Optional)
Type: SystemString
The build options
errMsg (Optional)
Type: Emgu.CVCvString
Option error message container that can be passed to this function

Return Value

Type: Boolean
True if the kernel can be created
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel.DisposeObject Method

KernelDisposeObject Method

Release the opencl kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel.Run Method

KernelRun Method

Execute the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Run(
    IntPtr[] globalsize,
    IntPtr[] localsize,
    bool sync,
    Queue q = null
)
Public Function Run (
    globalsize As IntPtr(),
    localsize As IntPtr(),
    sync As Boolean,
    Optional q As Queue = Nothing
) As Boolean
public:
bool Run(
    array<IntPtr>^ globalsize,
    array<IntPtr>^ localsize,
    bool sync,
    Queue^ q = nullptr
)
member Run :
        globalsize : IntPtr[] *
        localsize : IntPtr[] *
        sync : bool *
        ?q : Queue
(* Defaults:
        let _q = defaultArg q null
*)
-> bool

Parameters

globalsize
Type: SystemIntPtr
The global size
localsize
Type: SystemIntPtr
The local size
sync
Type: SystemBoolean
If true, the code is run synchronously (blocking)
q (Optional)
Type: Emgu.CV.OclQueue
Optional Opencl queue

Return Value

Type: Boolean
True if the execution is sucessful
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel.Set Method

KernelSet Method

Overload List
 | Name | Description
Public method | Set(Int32, Image2D) | Set the parameters for the kernel
Public method | Set(Int32, KernelArg) | Set the parameters for the kernel
Public method | Set(Int32, UMat) | Set the parameters for the kernel
Public method | Set(Int32, Double) | Set the parameters for the kernel
Public method | Set(Int32, Int32) | Set the parameters for the kernel
Public method | Set(Int32, Single) | Set the parameters for the kernel
Public method | Set(Int32, IntPtr, Int32) | Set the parameters for the kernel
Top
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


Kernel.Set Method (Int32, Image2D)

KernelSet Method (Int32, Image2D)

http://www.emgu.com
Set the parameters for the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Set(
    int i,
    Image2D image2d
)
Public Function Set (
    i As Integer,
    image2d As Image2D
) As Integer
public:
int Set(
    int i,
    Image2D^ image2d
)
member Set :
        i : int *
        image2d : Image2D -> int

Parameters

i
Type: SystemInt32
The index of the parameter
image2d
Type: Emgu.CV.OclImage2D
The ocl image

Return Value

Type: Int32
The next index value to be set
See Also

Reference

Kernel Class
Set Overload
Emgu.CV.Ocl Namespace


Kernel.Set Method (Int32, KernelArg)

KernelSet Method (Int32, KernelArg)

http://www.emgu.com
Set the parameters for the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Set(
    int i,
    KernelArg kernelArg
)
Public Function Set (
    i As Integer,
    kernelArg As KernelArg
) As Integer
public:
int Set(
    int i,
    KernelArg^ kernelArg
)
member Set :
        i : int *
        kernelArg : KernelArg -> int

Parameters

i
Type: SystemInt32
The index of the parameter
kernelArg
Type: Emgu.CV.OclKernelArg
The kernel arg

Return Value

Type: Int32
The next index value to be set
See Also

Reference

Kernel Class
Set Overload
Emgu.CV.Ocl Namespace


Kernel.Set Method (Int32, UMat)

KernelSet Method (Int32, UMat)

http://www.emgu.com
Set the parameters for the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Set(
    int i,
    UMat umat
)
Public Function Set (
    i As Integer,
    umat As UMat
) As Integer
public:
int Set(
    int i,
    UMat^ umat
)
member Set :
        i : int *
        umat : UMat -> int

Parameters

i
Type: SystemInt32
The index of the parameter
umat
Type: Emgu.CVUMat
The umat

Return Value

Type: Int32
The next index value to be set
See Also

Reference

Kernel Class
Set Overload
Emgu.CV.Ocl Namespace


Kernel.Set Method (Int32, Double)

KernelSet Method (Int32, Double)

http://www.emgu.com
Set the parameters for the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Set(
    int i,
    ref double value
)
Public Function Set (
    i As Integer,
    ByRef value As Double
) As Integer
public:
int Set(
    int i,
    double% value
)
member Set :
        i : int *
        value : float byref -> int

Parameters

i
Type: SystemInt32
The index of the parameter
value
Type: SystemDouble
The value

Return Value

Type: Int32
The next index value to be set
See Also

Reference

Kernel Class
Set Overload
Emgu.CV.Ocl Namespace


Kernel.Set Method (Int32, Int32)

KernelSet Method (Int32, Int32)

http://www.emgu.com
Set the parameters for the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Set(
    int i,
    ref int value
)
Public Function Set (
    i As Integer,
    ByRef value As Integer
) As Integer
public:
int Set(
    int i,
    int% value
)
member Set :
        i : int *
        value : int byref -> int

Parameters

i
Type: SystemInt32
The index of the parameter
value
Type: SystemInt32
The value

Return Value

Type: Int32
The next index value to be set
See Also

Reference

Kernel Class
Set Overload
Emgu.CV.Ocl Namespace


Kernel.Set Method (Int32, Single)

KernelSet Method (Int32, Single)

http://www.emgu.com
Set the parameters for the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Set(
    int i,
    ref float value
)
Public Function Set (
    i As Integer,
    ByRef value As Single
) As Integer
public:
int Set(
    int i,
    float% value
)
member Set :
        i : int *
        value : float32 byref -> int

Parameters

i
Type: SystemInt32
The index of the parameter
value
Type: SystemSingle
The value

Return Value

Type: Int32
The next index value to be set
See Also

Reference

Kernel Class
Set Overload
Emgu.CV.Ocl Namespace


Kernel.Set Method (Int32, IntPtr, Int32)

KernelSet Method (Int32, IntPtr, Int32)

http://www.emgu.com
Set the parameters for the kernel

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Set(
    int i,
    IntPtr data,
    int size
)
Public Function Set (
    i As Integer,
    data As IntPtr,
    size As Integer
) As Integer
public:
int Set(
    int i,
    IntPtr data,
    int size
)
member Set :
        i : int *
        data : IntPtr *
        size : int -> int

Parameters

i
Type: SystemInt32
The index of the parameter
data
Type: SystemIntPtr
The data
size
Type: SystemInt32
The size of the data in number of bytes

Return Value

Type: Int32
The next index value to be set
See Also

Reference

Kernel Class
Set Overload
Emgu.CV.Ocl Namespace


Kernel Fields

The Kernel type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Kernel Class
Emgu.CV.Ocl Namespace


KernelArg Class

OpenCL kernel arg
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OclKernelArg

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class KernelArg : UnmanagedObject
Public Class KernelArg
    Inherits UnmanagedObject
public ref class KernelArg : public UnmanagedObject
type KernelArg =
    class
        inherit UnmanagedObject
    end

The KernelArg type exposes the following members.

Constructors
 | Name | Description
Public method | KernelArg | Create the OCL kernel arg
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Ocl Namespace


KernelArg Constructor

Create the OCL kernel arg

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public KernelArg(
    KernelArgFlags flags,
    UMat m,
    int wscale = 1,
    int iwscale = 1,
    IntPtr obj = null,
    IntPtr sz = null
)
Public Sub New (
    flags As KernelArgFlags,
    m As UMat,
    Optional wscale As Integer = 1,
    Optional iwscale As Integer = 1,
    Optional obj As IntPtr = Nothing,
    Optional sz As IntPtr = Nothing
)
public:
KernelArg(
    KernelArgFlags^ flags,
    UMat^ m,
    int wscale = 1,
    int iwscale = 1,
    IntPtr obj = nullptr,
    IntPtr sz = nullptr
)
new :
        flags : KernelArgFlags *
        m : UMat *
        ?wscale : int *
        ?iwscale : int *
        ?obj : IntPtr *
        ?sz : IntPtr
(* Defaults:
        let _wscale = defaultArg wscale 1
        let _iwscale = defaultArg iwscale 1
        let _obj = defaultArg obj null
        let _sz = defaultArg sz null
*)
-> KernelArg

Parameters

flags
Type: Emgu.CV.OclKernelArgFlags
The flags
m
Type: Emgu.CVUMat
The UMat
wscale (Optional)
Type: SystemInt32
wscale
iwscale (Optional)
Type: SystemInt32
iwscale
obj (Optional)
Type: SystemIntPtr
obj
sz (Optional)
Type: SystemIntPtr
sz
See Also

Reference

KernelArg Class
Emgu.CV.Ocl Namespace


KernelArg Properties

The KernelArg type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

KernelArg Class
Emgu.CV.Ocl Namespace


KernelArg Methods

The KernelArg type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KernelArg Class
Emgu.CV.Ocl Namespace


KernelArg.DisposeObject Method

KernelArgDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

KernelArg Class
Emgu.CV.Ocl Namespace


KernelArg Fields

The KernelArg type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

KernelArg Class
Emgu.CV.Ocl Namespace


KernelArg.Flags Class

KernelArgFlags Class

KernelArg flags
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OclKernelArgFlags

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public sealed class Flags : Enum
<FlagsAttribute>
Public NotInheritable Class Flags
    Inherits Enum
[FlagsAttribute]
public ref class Flags sealed : public Enum
[<SealedAttribute>]
[<FlagsAttribute>]
type Flags =
    class
        inherit Enum
    end

The KernelArgFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Constant | Constant
 | Local | Local
 | NoSize | No size
 | PtrOnly | Ptr only
 | ReadOnly | Read only
 | ReadWrite | Read write
Public field | value__ |
 | WriteOnly | Write only
Top
See Also

Reference

Emgu.CV.Ocl Namespace


Flags Methods

The KernelArgFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


Flags Fields

The KernelArgFlags type exposes the following members.

Fields
 | Name | Description
 | Constant | Constant
 | Local | Local
 | NoSize | No size
 | PtrOnly | Ptr only
 | ReadOnly | Read only
 | ReadWrite | Read write
Public field | value__ |
 | WriteOnly | Write only
Top
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.Constant Field

KernelArgFlagsConstant Field

Constant

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KernelArgFlags Constant = 8
Public Const Constant As KernelArgFlags = 8
public:
literal KernelArgFlags^ Constant = 8
static val mutable Constant: KernelArgFlags

Field Value

Type: KernelArgFlags
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.Local Field

KernelArgFlagsLocal Field

Local

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KernelArgFlags Local = 1
Public Const Local As KernelArgFlags = 1
public:
literal KernelArgFlags^ Local = 1
static val mutable Local: KernelArgFlags

Field Value

Type: KernelArgFlags
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.NoSize Field

KernelArgFlagsNoSize Field

No size

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KernelArgFlags NoSize = 256
Public Const NoSize As KernelArgFlags = 256
public:
literal KernelArgFlags^ NoSize = 256
static val mutable NoSize: KernelArgFlags

Field Value

Type: KernelArgFlags
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.PtrOnly Field

KernelArgFlagsPtrOnly Field

Ptr only

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KernelArgFlags PtrOnly = 16
Public Const PtrOnly As KernelArgFlags = 16
public:
literal KernelArgFlags^ PtrOnly = 16
static val mutable PtrOnly: KernelArgFlags

Field Value

Type: KernelArgFlags
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.ReadOnly Field

KernelArgFlagsReadOnly Field

Read only

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KernelArgFlags ReadOnly = 2
Public Const ReadOnly As KernelArgFlags = 2
public:
literal KernelArgFlags^ ReadOnly = 2
static val mutable ReadOnly: KernelArgFlags

Field Value

Type: KernelArgFlags
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.ReadWrite Field

KernelArgFlagsReadWrite Field

Read write

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KernelArgFlags ReadWrite = 6
Public Const ReadWrite As KernelArgFlags = 6
public:
literal KernelArgFlags^ ReadWrite = 6
static val mutable ReadWrite: KernelArgFlags

Field Value

Type: KernelArgFlags
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.value__ Field

KernelArgFlagsvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Ocl.KernelArg.Flags.value__"]

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


KernelArg.Flags.WriteOnly Field

KernelArgFlagsWriteOnly Field

Write only

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const KernelArgFlags WriteOnly = 4
Public Const WriteOnly As KernelArgFlags = 4
public:
literal KernelArgFlags^ WriteOnly = 4
static val mutable WriteOnly: KernelArgFlags

Field Value

Type: KernelArgFlags
See Also

Reference

KernelArgFlags Class
Emgu.CV.Ocl Namespace


OclInvoke Class

Class that contains ocl functions
Class that contains ocl functions.
Class that contains ocl functions.
Class that contains ocl functions.
Class that contains ocl functions.
Class that contains ocl functions.
Inheritance Hierarchy
SystemObject
Emgu.CV.OclOclInvoke

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class OclInvoke
Public NotInheritable Class OclInvoke
public ref class OclInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OclInvoke =  class end

The OclInvoke type exposes the following members.

Methods
Name | Description
GetPlatformsInfo | Get all the platform info as a vector
TypeToString | Convert the DepthType to a string that represent the OpenCL value type.
Top
See Also

Reference

Emgu.CV.Ocl Namespace


OclInvoke Methods

The OclInvoke type exposes the following members.

Methods
Name | Description
GetPlatformsInfo | Get all the platform info as a vector
TypeToString | Convert the DepthType to a string that represent the OpenCL value type.
Top
See Also

Reference

OclInvoke Class
Emgu.CV.Ocl Namespace


OclInvoke.GetPlatformsInfo Method

OclInvokeGetPlatformsInfo Method

Get all the platform info as a vector

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static VectorOfOclPlatformInfo GetPlatformsInfo()
Public Shared Function GetPlatformsInfo As VectorOfOclPlatformInfo
public:
static VectorOfOclPlatformInfo^ GetPlatformsInfo()
static member GetPlatformsInfo : unit -> VectorOfOclPlatformInfo

Return Value

Type: VectorOfOclPlatformInfo
The vector of Platfom info
See Also

Reference

OclInvoke Class
Emgu.CV.Ocl Namespace


OclInvoke.TypeToString Method

OclInvokeTypeToString Method

Convert the DepthType to a string that represent the OpenCL value type.

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string TypeToString(
    DepthType depthType,
    int channels = 1
)
Public Shared Function TypeToString (
    depthType As DepthType,
    Optional channels As Integer = 1
) As String
public:
static String^ TypeToString(
    DepthType^ depthType,
    int channels = 1
)
static member TypeToString :
        depthType : DepthType *
        ?channels : int
(* Defaults:
        let _channels = defaultArg channels 1
*)
-> string

Parameters

depthType
Type: Emgu.CV.CvEnumDepthType
The depth type
channels (Optional)
Type: SystemInt32
The number of channels

Return Value

Type: String
A string the repsent the OpenCL value type
See Also

Reference

OclInvoke Class
Emgu.CV.Ocl Namespace


PlatformInfo Class

This class contains ocl platform information
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OclPlatformInfo

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PlatformInfo : UnmanagedObject
Public Class PlatformInfo
    Inherits UnmanagedObject
public ref class PlatformInfo : public UnmanagedObject
type PlatformInfo =
    class
        inherit UnmanagedObject
    end

The PlatformInfo type exposes the following members.

Properties
 | Name | Description
Public property | DeviceNumber | The number of devices
Public property | Name | The platform name
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Vendor | The platform vendor
Public property | Version | The platform version
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this OclInfo (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetDevice | Get the OclDevice with the specific index
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Get the string that represent this oclPlatformInfo object (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Ocl Namespace


PlatformInfo Properties

The PlatformInfo type exposes the following members.

Properties
 | Name | Description
Public property | DeviceNumber | The number of devices
Public property | Name | The platform name
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Vendor | The platform vendor
Public property | Version | The platform version
Top
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo.DeviceNumber Property

PlatformInfoDeviceNumber Property

The number of devices

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DeviceNumber { get; }
Public ReadOnly Property DeviceNumber As Integer
    Get
public:
property int DeviceNumber {
    int get ();
}
member DeviceNumber : int with get

Property Value

Type: Int32
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo.Name Property

PlatformInfoName Property

The platform name

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo.Vendor Property

PlatformInfoVendor Property

The platform vendor

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Vendor { get; }
Public ReadOnly Property Vendor As String
    Get
public:
property String^ Vendor {
    String^ get ();
}
member Vendor : string with get

Property Value

Type: String
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo.Version Property

PlatformInfoVersion Property

The platform version

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
member Version : string with get

Property Value

Type: String
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo Methods

The PlatformInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this OclInfo (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetDevice | Get the OclDevice with the specific index
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Get the string that represent this oclPlatformInfo object (Overrides ObjectToString.)
Top
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo.DisposeObject Method

PlatformInfoDisposeObject Method

Release all the unmanaged memory associated with this OclInfo

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo.GetDevice Method

PlatformInfoGetDevice Method

Get the OclDevice with the specific index

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Device GetDevice(
    int d
)
Public Function GetDevice (
    d As Integer
) As Device
public:
Device^ GetDevice(
    int d
)
member GetDevice :
        d : int -> Device

Parameters

d
Type: SystemInt32
The index of the ocl device

Return Value

Type: Device
The ocl device with the specific index
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo.ToString Method

PlatformInfoToString Method

Get the string that represent this oclPlatformInfo object

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represent this oclPlatformInfo object
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


PlatformInfo Fields

The PlatformInfo type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

PlatformInfo Class
Emgu.CV.Ocl Namespace


ProgramSource Class

Open CL kernel program source code
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OclProgramSource

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ProgramSource : UnmanagedObject
Public Class ProgramSource
    Inherits UnmanagedObject
public ref class ProgramSource : public UnmanagedObject
type ProgramSource =
    class
        inherit UnmanagedObject
    end

The ProgramSource type exposes the following members.

Constructors
 | Name | Description
Public method | ProgramSource | Create OpenCL program source code
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Source | Get the source code as String
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Ocl Namespace


ProgramSource Constructor

Create OpenCL program source code

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ProgramSource(
    string source
)
Public Sub New (
    source As String
)
public:
ProgramSource(
    String^ source
)
new :
        source : string -> ProgramSource

Parameters

source
Type: SystemString
The source code
See Also

Reference

ProgramSource Class
Emgu.CV.Ocl Namespace


ProgramSource Properties

The ProgramSource type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Source | Get the source code as String
Top
See Also

Reference

ProgramSource Class
Emgu.CV.Ocl Namespace


ProgramSource.Source Property

ProgramSourceSource Property

Get the source code as String

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Source { get; }
Public ReadOnly Property Source As String
    Get
public:
property String^ Source {
    String^ get ();
}
member Source : string with get

Property Value

Type: String
See Also

Reference

ProgramSource Class
Emgu.CV.Ocl Namespace


ProgramSource Methods

The ProgramSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProgramSource Class
Emgu.CV.Ocl Namespace


ProgramSource.DisposeObject Method

ProgramSourceDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ProgramSource Class
Emgu.CV.Ocl Namespace


ProgramSource Fields

The ProgramSource type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ProgramSource Class
Emgu.CV.Ocl Namespace


Queue Class

An OpenCL Queue
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OclQueue

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Queue : UnmanagedObject
Public Class Queue
    Inherits UnmanagedObject
public ref class Queue : public UnmanagedObject
type Queue =
    class
        inherit UnmanagedObject
    end

The Queue type exposes the following members.

Constructors
 | Name | Description
Public method | Queue | OpenCL queue
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Finish | Wait for the queue to finish
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Ocl Namespace


Queue Constructor

OpenCL queue

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Queue()
Public Sub New
public:
Queue()
new : unit -> Queue
See Also

Reference

Queue Class
Emgu.CV.Ocl Namespace


Queue Properties

The Queue type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Queue Class
Emgu.CV.Ocl Namespace


Queue Methods

The Queue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | Finish | Wait for the queue to finish
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Queue Class
Emgu.CV.Ocl Namespace


Queue.DisposeObject Method

QueueDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Queue Class
Emgu.CV.Ocl Namespace


Queue.Finish Method

QueueFinish Method

Wait for the queue to finish

Namespace: Emgu.CV.Ocl
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Finish()
Public Sub Finish
public:
void Finish()
member Finish : unit -> unit
See Also

Reference

Queue Class
Emgu.CV.Ocl Namespace


Queue Fields

The Queue type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Queue Class
Emgu.CV.Ocl Namespace


Emgu.CV.OCR Namespace

Optical character recognition. Wraps the tesseract-ocr engine.
Classes
 | Class | Description
Public class | LocaleGuard | This class set the locale to specific values and revert it back to the old values when the object is disposed.
Public class | LocaleGuardLocaleCategory | The locale category
Public class | OcrEngineMode | When Tesseract/LSTM is initialized we can choose to instantiate/load/run only the Tesseract part, only the Cube part or both along with the combiner. The preference of which engine to use is stored in tessedit_ocr_engine_mode.
Public class | OcrInvoke | Library to invoke Tesseract OCR functions
Public class | Orientation | The orientation
Public class | PageIterator | The tesseract page iterator
Public class | PageIteratorLevel | Page iterator level
Public class | PageOrientation | Page orientation
Public class | PageSegMode | Tesseract page segmentation mode
Public class | PDFRenderer | Renders tesseract output into searchable PDF
Public class | Pix | Leptonica Pix image structure
Public class | Tesseract | The tesseract OCR engine
Public class | TesseractCharacter | This represent a character that is detected by the OCR engine
Public class | TesseractResult | This structure is primary used for PInvoke
Public class | TextlineOrder | Textline order
Public class | VectorOfTesseractResult | Wrapped class of the C++ standard vector of TesseractResult.
Public class | WritingDirection | Writing direction
Interfaces
 | Interface | Description
Public interface | ITessResultRenderer | Interface to the TesseractResultRender


ITessResultRenderer Interface

Interface to the TesseractResultRender

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface ITessResultRenderer
Public Interface ITessResultRenderer
public interface class ITessResultRenderer
type ITessResultRenderer =  interface end

The ITessResultRenderer type exposes the following members.

Properties
 | Name | Description
Public property | TessResultRendererPtr | Pointer to the unmanaged TessResultRendered
Top
See Also

Reference

Emgu.CV.OCR Namespace


ITessResultRenderer Properties

The ITessResultRenderer type exposes the following members.

Properties
 | Name | Description
Public property | TessResultRendererPtr | Pointer to the unmanaged TessResultRendered
Top
See Also

Reference

ITessResultRenderer Interface
Emgu.CV.OCR Namespace


ITessResultRenderer.TessResultRendererPtr Property

ITessResultRendererTessResultRendererPtr Property

Pointer to the unmanaged TessResultRendered

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr TessResultRendererPtr { get; }
ReadOnly Property TessResultRendererPtr As IntPtr
    Get
property IntPtr TessResultRendererPtr {
    IntPtr get ();
}
abstract TessResultRendererPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

ITessResultRenderer Interface
Emgu.CV.OCR Namespace


LocaleGuard Class

This class set the locale to specific values and revert it back to the old values when the object is disposed.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.CV.OCRLocaleGuard

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LocaleGuard : DisposableObject
Public Class LocaleGuard
    Inherits DisposableObject
public ref class LocaleGuard : public DisposableObject
type LocaleGuard =
    class
        inherit DisposableObject
    end

The LocaleGuard type exposes the following members.

Constructors
 | Name | Description
Public method | LocaleGuard | Create a locale guard to set the locale to specific value. Will revert locale back to previous value when the object is disposed.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Revert back to the old locale (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.CV.OCR Namespace


LocaleGuard Constructor

Create a locale guard to set the locale to specific value. Will revert locale back to previous value when the object is disposed.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LocaleGuard(
    LocaleGuardLocaleCategory category,
    string locale
)
Public Sub New (
    category As LocaleGuardLocaleCategory,
    locale As String
)
public:
LocaleGuard(
    LocaleGuardLocaleCategory^ category,
    String^ locale
)
new :
        category : LocaleGuardLocaleCategory *
        locale : string -> LocaleGuard

Parameters

category
Type: Emgu.CV.OCRLocaleGuardLocaleCategory
The locale category
locale
Type: SystemString
The locale
See Also

Reference

LocaleGuard Class
Emgu.CV.OCR Namespace


LocaleGuard Methods

The LocaleGuard type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Revert back to the old locale (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocaleGuard Class
Emgu.CV.OCR Namespace


LocaleGuard.DisposeObject Method

LocaleGuardDisposeObject Method

Revert back to the old locale

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LocaleGuard Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory Class

LocaleGuardLocaleCategory Class

The locale category
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OCRLocaleGuardLocaleCategory

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LocaleCategory : Enum
Public NotInheritable Class LocaleCategory
    Inherits Enum
public ref class LocaleCategory sealed : public Enum
[<SealedAttribute>]
type LocaleCategory =
    class
        inherit Enum
    end

The LocaleGuardLocaleCategory type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | All
 | Collate | Collate
 | Ctype | Ctype
 | Monetary | Monetary
 | Numeric | Numeric
 | Time | Time
Public field | value__ |
Top
See Also

Reference

Emgu.CV.OCR Namespace


LocaleCategory Methods

The LocaleGuardLocaleCategory type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleCategory Fields

The LocaleGuardLocaleCategory type exposes the following members.

Fields
 | Name | Description
 | All | All
 | Collate | Collate
 | Ctype | Ctype
 | Monetary | Monetary
 | Numeric | Numeric
 | Time | Time
Public field | value__ |
Top
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory.All Field

LocaleGuardLocaleCategoryAll Field

All

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocaleGuardLocaleCategory All = 0
Public Const All As LocaleGuardLocaleCategory = 0
public:
literal LocaleGuardLocaleCategory^ All = 0
static val mutable All: LocaleGuardLocaleCategory

Field Value

Type: LocaleGuardLocaleCategory
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory.Collate Field

LocaleGuardLocaleCategoryCollate Field

Collate

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocaleGuardLocaleCategory Collate = 1
Public Const Collate As LocaleGuardLocaleCategory = 1
public:
literal LocaleGuardLocaleCategory^ Collate = 1
static val mutable Collate: LocaleGuardLocaleCategory

Field Value

Type: LocaleGuardLocaleCategory
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory.Ctype Field

LocaleGuardLocaleCategoryCtype Field

Ctype

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocaleGuardLocaleCategory Ctype = 2
Public Const Ctype As LocaleGuardLocaleCategory = 2
public:
literal LocaleGuardLocaleCategory^ Ctype = 2
static val mutable Ctype: LocaleGuardLocaleCategory

Field Value

Type: LocaleGuardLocaleCategory
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory.Monetary Field

LocaleGuardLocaleCategoryMonetary Field

Monetary

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocaleGuardLocaleCategory Monetary = 3
Public Const Monetary As LocaleGuardLocaleCategory = 3
public:
literal LocaleGuardLocaleCategory^ Monetary = 3
static val mutable Monetary: LocaleGuardLocaleCategory

Field Value

Type: LocaleGuardLocaleCategory
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory.Numeric Field

LocaleGuardLocaleCategoryNumeric Field

Numeric

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocaleGuardLocaleCategory Numeric = 4
Public Const Numeric As LocaleGuardLocaleCategory = 4
public:
literal LocaleGuardLocaleCategory^ Numeric = 4
static val mutable Numeric: LocaleGuardLocaleCategory

Field Value

Type: LocaleGuardLocaleCategory
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory.Time Field

LocaleGuardLocaleCategoryTime Field

Time

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocaleGuardLocaleCategory Time = 5
Public Const Time As LocaleGuardLocaleCategory = 5
public:
literal LocaleGuardLocaleCategory^ Time = 5
static val mutable Time: LocaleGuardLocaleCategory

Field Value

Type: LocaleGuardLocaleCategory
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


LocaleGuard.LocaleCategory.value__ Field

LocaleGuardLocaleCategoryvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.OCR.LocaleGuard.LocaleCategory.value__"]

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

LocaleGuardLocaleCategory Class
Emgu.CV.OCR Namespace


OcrEngineMode Class

When Tesseract/LSTM is initialized we can choose to instantiate/load/run only the Tesseract part, only the Cube part or both along with the combiner. The preference of which engine to use is stored in tessedit_ocr_engine_mode.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OCROcrEngineMode

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class OcrEngineMode : Enum
Public NotInheritable Class OcrEngineMode
    Inherits Enum
public ref class OcrEngineMode sealed : public Enum
[<SealedAttribute>]
type OcrEngineMode =
    class
        inherit Enum
    end

The OcrEngineMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Specify this mode when calling init_*(), to indicate that any of the above modes should be automatically inferred from the variables in the language-specific config, command-line configs, or if not specified in any of the above should be set to the default OEM_TESSERACT_ONLY.
 | LstmOnly | Run just the LSTM line recognizer.
 | TesseractLstmCombined | Run the LSTM recognizer, but allow fallback to Tesseract when things get difficult.
 | TesseractOnly | Run Tesseract only - fastest
Public field | value__ |
Top
See Also

Reference

Emgu.CV.OCR Namespace


OcrEngineMode Methods

The OcrEngineMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

OcrEngineMode Class
Emgu.CV.OCR Namespace


OcrEngineMode Fields

The OcrEngineMode type exposes the following members.

Fields
 | Name | Description
 | Default | Specify this mode when calling init_*(), to indicate that any of the above modes should be automatically inferred from the variables in the language-specific config, command-line configs, or if not specified in any of the above should be set to the default OEM_TESSERACT_ONLY.
 | LstmOnly | Run just the LSTM line recognizer.
 | TesseractLstmCombined | Run the LSTM recognizer, but allow fallback to Tesseract when things get difficult.
 | TesseractOnly | Run Tesseract only - fastest
Public field | value__ |
Top
See Also

Reference

OcrEngineMode Class
Emgu.CV.OCR Namespace


OcrEngineMode.Default Field

OcrEngineModeDefault Field

Specify this mode when calling init_*(), to indicate that any of the above modes should be automatically inferred from the variables in the language-specific config, command-line configs, or if not specified in any of the above should be set to the default OEM_TESSERACT_ONLY.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OcrEngineMode Default = 3
Public Const Default As OcrEngineMode = 3
public:
literal OcrEngineMode^ Default = 3
static val mutable Default: OcrEngineMode

Field Value

Type: OcrEngineMode
See Also

Reference

OcrEngineMode Class
Emgu.CV.OCR Namespace


OcrEngineMode.LstmOnly Field

OcrEngineModeLstmOnly Field

Run just the LSTM line recognizer.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OcrEngineMode LstmOnly = 1
Public Const LstmOnly As OcrEngineMode = 1
public:
literal OcrEngineMode^ LstmOnly = 1
static val mutable LstmOnly: OcrEngineMode

Field Value

Type: OcrEngineMode
See Also

Reference

OcrEngineMode Class
Emgu.CV.OCR Namespace


OcrEngineMode.TesseractLstmCombined Field

OcrEngineModeTesseractLstmCombined Field

Run the LSTM recognizer, but allow fallback to Tesseract when things get difficult.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OcrEngineMode TesseractLstmCombined = 2
Public Const TesseractLstmCombined As OcrEngineMode = 2
public:
literal OcrEngineMode^ TesseractLstmCombined = 2
static val mutable TesseractLstmCombined: OcrEngineMode

Field Value

Type: OcrEngineMode
See Also

Reference

OcrEngineMode Class
Emgu.CV.OCR Namespace


OcrEngineMode.TesseractOnly Field

OcrEngineModeTesseractOnly Field

Run Tesseract only - fastest

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OcrEngineMode TesseractOnly = 0
Public Const TesseractOnly As OcrEngineMode = 0
public:
literal OcrEngineMode^ TesseractOnly = 0
static val mutable TesseractOnly: OcrEngineMode

Field Value

Type: OcrEngineMode
See Also

Reference

OcrEngineMode Class
Emgu.CV.OCR Namespace


OcrEngineMode.value__ Field

OcrEngineModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.OCR.OcrEngineMode.value__"]

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

OcrEngineMode Class
Emgu.CV.OCR Namespace


OcrInvoke Class

Library to invoke Tesseract OCR functions
Inheritance Hierarchy
SystemObject
Emgu.CV.OCROcrInvoke

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class OcrInvoke
Public NotInheritable Class OcrInvoke
public ref class OcrInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OcrInvoke =  class end

The OcrInvoke type exposes the following members.

Methods
Name | Description
SetLocale | The setlocale function installs the specified system locale or its portion as the new C locale. The modifications remain in effect and influences the execution of all locale-sensitive C library functions until the next call to setlocale. If locale is a null pointer, setlocale queries the current C locale without modifying it.
Top
See Also

Reference

Emgu.CV.OCR Namespace


OcrInvoke Methods

The OcrInvoke type exposes the following members.

Methods
Name | Description
SetLocale | The setlocale function installs the specified system locale or its portion as the new C locale. The modifications remain in effect and influences the execution of all locale-sensitive C library functions until the next call to setlocale. If locale is a null pointer, setlocale queries the current C locale without modifying it.
Top
See Also

Reference

OcrInvoke Class
Emgu.CV.OCR Namespace


OcrInvoke.SetLocale Method

OcrInvokeSetLocale Method

The setlocale function installs the specified system locale or its portion as the new C locale. The modifications remain in effect and influences the execution of all locale-sensitive C library functions until the next call to setlocale. If locale is a null pointer, setlocale queries the current C locale without modifying it.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string SetLocale(
    LocaleGuardLocaleCategory category,
    string locale = null
)
Public Shared Function SetLocale (
    category As LocaleGuardLocaleCategory,
    Optional locale As String = Nothing
) As String
public:
static String^ SetLocale(
    LocaleGuardLocaleCategory^ category,
    String^ locale = nullptr
)
static member SetLocale :
        category : LocaleGuardLocaleCategory *
        ?locale : string
(* Defaults:
        let _locale = defaultArg locale null
*)
-> string

Parameters

category
Type: Emgu.CV.OCRLocaleGuardLocaleCategory
Locale category identifier
locale (Optional)
Type: SystemString
System-specific locale identifier. Can be "" for the user-preferred locale or "C" for the minimal locale

Return Value

Type: String
String identifying the C locale after applying the changes, if any, or null pointer on failure. A copy of the returned string along with the category used in this call to std::setlocale may be used later in the program to restore the locale back to the state at the end of this call.
See Also

Reference

OcrInvoke Class
Emgu.CV.OCR Namespace


Orientation Class

The orientation
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.OCROrientation

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Orientation : ValueType
Public NotInheritable Class Orientation
    Inherits ValueType
public ref class Orientation sealed : public ValueType
[<SealedAttribute>]
type Orientation =
    class
        inherit ValueType
    end

The Orientation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | DeskewAngle | after rotating the block so the text orientation is upright, how many radians does one have to rotate the block anti-clockwise for it to be level? -Pi/4 <= deskew_angle <= Pi/4
Public field | PageOrientation | Page orientation
Public field | TextlineOrder | Textline order
Public field | WritingDirection | Writing direction
Top
See Also

Reference

Emgu.CV.OCR Namespace


Orientation Methods

The Orientation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Orientation Class
Emgu.CV.OCR Namespace


Orientation Fields

The Orientation type exposes the following members.

Fields
 | Name | Description
Public field | DeskewAngle | after rotating the block so the text orientation is upright, how many radians does one have to rotate the block anti-clockwise for it to be level? -Pi/4 <= deskew_angle <= Pi/4
Public field | PageOrientation | Page orientation
Public field | TextlineOrder | Textline order
Public field | WritingDirection | Writing direction
Top
See Also

Reference

Orientation Class
Emgu.CV.OCR Namespace


Orientation.DeskewAngle Field

OrientationDeskewAngle Field

after rotating the block so the text orientation is upright, how many radians does one have to rotate the block anti-clockwise for it to be level? -Pi/4 <= deskew_angle <= Pi/4

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float DeskewAngle
Public DeskewAngle As Single
public:
float DeskewAngle
val mutable DeskewAngle: float32

Field Value

Type: Single
See Also

Reference

Orientation Class
Emgu.CV.OCR Namespace


Orientation.PageOrientation Field

OrientationPageOrientation Field

Page orientation

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PageOrientation PageOrientation
Public PageOrientation As PageOrientation
public:
PageOrientation^ PageOrientation
val mutable PageOrientation: PageOrientation

Field Value

Type: PageOrientation
See Also

Reference

Orientation Class
Emgu.CV.OCR Namespace


Orientation.TextlineOrder Field

OrientationTextlineOrder Field

Textline order

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TextlineOrder TextlineOrder
Public TextlineOrder As TextlineOrder
public:
TextlineOrder^ TextlineOrder
val mutable TextlineOrder: TextlineOrder

Field Value

Type: TextlineOrder
See Also

Reference

Orientation Class
Emgu.CV.OCR Namespace


Orientation.WritingDirection Field

OrientationWritingDirection Field

Writing direction

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WritingDirection WritingDirection
Public WritingDirection As WritingDirection
public:
WritingDirection^ WritingDirection
val mutable WritingDirection: WritingDirection

Field Value

Type: WritingDirection
See Also

Reference

Orientation Class
Emgu.CV.OCR Namespace


PageIterator Class

The tesseract page iterator
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OCRPageIterator

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PageIterator : UnmanagedObject
Public Class PageIterator
    Inherits UnmanagedObject
public ref class PageIterator : public UnmanagedObject
type PageIterator =
    class
        inherit UnmanagedObject
    end

The PageIterator type exposes the following members.

Properties
 | Name | Description
Public property | Orientation | Returns orientation for the block the iterator points to.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the page iterator (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBaseLine | Returns the baseline of the current object at the given level. The baseline is the line that passes through (x1, y1) and (x2, y2). WARNING: with vertical text, baselines may be vertical! Returns null if there is no baseline at the current position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.OCR Namespace


PageIterator Properties

The PageIterator type exposes the following members.

Properties
 | Name | Description
Public property | Orientation | Returns orientation for the block the iterator points to.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

PageIterator Class
Emgu.CV.OCR Namespace


PageIterator.Orientation Property

PageIteratorOrientation Property

Returns orientation for the block the iterator points to.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Orientation Orientation { get; }
Public ReadOnly Property Orientation As Orientation
    Get
public:
property Orientation^ Orientation {
    Orientation^ get ();
}
member Orientation : Orientation with get

Property Value

Type: Orientation
See Also

Reference

PageIterator Class
Emgu.CV.OCR Namespace


PageIterator Methods

The PageIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the page iterator (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBaseLine | Returns the baseline of the current object at the given level. The baseline is the line that passes through (x1, y1) and (x2, y2). WARNING: with vertical text, baselines may be vertical! Returns null if there is no baseline at the current position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageIterator Class
Emgu.CV.OCR Namespace


PageIterator.DisposeObject Method

PageIteratorDisposeObject Method

Release the page iterator

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PageIterator Class
Emgu.CV.OCR Namespace


PageIterator.GetBaseLine Method

PageIteratorGetBaseLine Method

Returns the baseline of the current object at the given level. The baseline is the line that passes through (x1, y1) and (x2, y2). WARNING: with vertical text, baselines may be vertical! Returns null if there is no baseline at the current position.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<LineSegment2D> GetBaseLine(
    PageIteratorLevel level
)
Public Function GetBaseLine (
    level As PageIteratorLevel
) As Nullable(Of LineSegment2D)
public:
Nullable<LineSegment2D^>^ GetBaseLine(
    PageIteratorLevel^ level
)
member GetBaseLine :
        level : PageIteratorLevel -> Nullable<LineSegment2D>

Parameters

level
Type: Emgu.CV.OCRPageIteratorLevel
Page iterator level

Return Value

Type: Nullable LineSegment2D
The baseline of the current object at the given level
See Also

Reference

PageIterator Class
Emgu.CV.OCR Namespace


PageIterator Fields

The PageIterator type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

PageIterator Class
Emgu.CV.OCR Namespace


PageIteratorLevel Class

Page iterator level
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OCRPageIteratorLevel

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PageIteratorLevel : Enum
Public NotInheritable Class PageIteratorLevel
    Inherits Enum
public ref class PageIteratorLevel sealed : public Enum
[<SealedAttribute>]
type PageIteratorLevel =
    class
        inherit Enum
    end

The PageIteratorLevel type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Block | Block of text/image/separator line.
 | Para | Paragraph within a block.
 | Symbol | Symbol/character within a word.
 | Textline | Line within a paragraph.
Public field | value__ |
 | Word | Word within a textline.
Top
See Also

Reference

Emgu.CV.OCR Namespace


PageIteratorLevel Methods

The PageIteratorLevel type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageIteratorLevel Fields

The PageIteratorLevel type exposes the following members.

Fields
 | Name | Description
 | Block | Block of text/image/separator line.
 | Para | Paragraph within a block.
 | Symbol | Symbol/character within a word.
 | Textline | Line within a paragraph.
Public field | value__ |
 | Word | Word within a textline.
Top
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageIteratorLevel.Block Field

PageIteratorLevelBlock Field

Block of text/image/separator line.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageIteratorLevel Block = 0
Public Const Block As PageIteratorLevel = 0
public:
literal PageIteratorLevel^ Block = 0
static val mutable Block: PageIteratorLevel

Field Value

Type: PageIteratorLevel
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageIteratorLevel.Para Field

PageIteratorLevelPara Field

Paragraph within a block.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageIteratorLevel Para = 1
Public Const Para As PageIteratorLevel = 1
public:
literal PageIteratorLevel^ Para = 1
static val mutable Para: PageIteratorLevel

Field Value

Type: PageIteratorLevel
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageIteratorLevel.Symbol Field

PageIteratorLevelSymbol Field

Symbol/character within a word.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageIteratorLevel Symbol = 4
Public Const Symbol As PageIteratorLevel = 4
public:
literal PageIteratorLevel^ Symbol = 4
static val mutable Symbol: PageIteratorLevel

Field Value

Type: PageIteratorLevel
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageIteratorLevel.Textline Field

PageIteratorLevelTextline Field

Line within a paragraph.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageIteratorLevel Textline = 2
Public Const Textline As PageIteratorLevel = 2
public:
literal PageIteratorLevel^ Textline = 2
static val mutable Textline: PageIteratorLevel

Field Value

Type: PageIteratorLevel
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageIteratorLevel.value__ Field

PageIteratorLevelvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.OCR.PageIteratorLevel.value__"]

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageIteratorLevel.Word Field

PageIteratorLevelWord Field

Word within a textline.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageIteratorLevel Word = 3
Public Const Word As PageIteratorLevel = 3
public:
literal PageIteratorLevel^ Word = 3
static val mutable Word: PageIteratorLevel

Field Value

Type: PageIteratorLevel
See Also

Reference

PageIteratorLevel Class
Emgu.CV.OCR Namespace


PageOrientation Class

Page orientation
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OCRPageOrientation

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PageOrientation : Enum
Public NotInheritable Class PageOrientation
    Inherits Enum
public ref class PageOrientation sealed : public Enum
[<SealedAttribute>]
type PageOrientation =
    class
        inherit Enum
    end

The PageOrientation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Down | Down
 | Left | Left
 | Right | Right
 | Up | Up
Public field | value__ |
Top
See Also

Reference

Emgu.CV.OCR Namespace


PageOrientation Methods

The PageOrientation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

PageOrientation Class
Emgu.CV.OCR Namespace


PageOrientation Fields

The PageOrientation type exposes the following members.

Fields
 | Name | Description
 | Down | Down
 | Left | Left
 | Right | Right
 | Up | Up
Public field | value__ |
Top
See Also

Reference

PageOrientation Class
Emgu.CV.OCR Namespace


PageOrientation.Down Field

PageOrientationDown Field

Down

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageOrientation Down = 2
Public Const Down As PageOrientation = 2
public:
literal PageOrientation^ Down = 2
static val mutable Down: PageOrientation

Field Value

Type: PageOrientation
See Also

Reference

PageOrientation Class
Emgu.CV.OCR Namespace


PageOrientation.Left Field

PageOrientationLeft Field

Left

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageOrientation Left = 3
Public Const Left As PageOrientation = 3
public:
literal PageOrientation^ Left = 3
static val mutable Left: PageOrientation

Field Value

Type: PageOrientation
See Also

Reference

PageOrientation Class
Emgu.CV.OCR Namespace


PageOrientation.Right Field

PageOrientationRight Field

Right

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageOrientation Right = 1
Public Const Right As PageOrientation = 1
public:
literal PageOrientation^ Right = 1
static val mutable Right: PageOrientation

Field Value

Type: PageOrientation
See Also

Reference

PageOrientation Class
Emgu.CV.OCR Namespace


PageOrientation.Up Field

PageOrientationUp Field

Up

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageOrientation Up = 0
Public Const Up As PageOrientation = 0
public:
literal PageOrientation^ Up = 0
static val mutable Up: PageOrientation

Field Value

Type: PageOrientation
See Also

Reference

PageOrientation Class
Emgu.CV.OCR Namespace


PageOrientation.value__ Field

PageOrientationvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.OCR.PageOrientation.value__"]

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

PageOrientation Class
Emgu.CV.OCR Namespace


PageSegMode Class

Tesseract page segmentation mode
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OCRPageSegMode

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PageSegMode : Enum
Public NotInheritable Class PageSegMode
    Inherits Enum
public ref class PageSegMode sealed : public Enum
[<SealedAttribute>]
type PageSegMode =
    class
        inherit Enum
    end

The PageSegMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Auto | Fully automatic page segmentation, but no OSD.
 | AutoOnly | Automatic page segmentation, but no OSD, or OCR.
 | AutoOsd | Automatic page segmentation with orientation and script detection. (OSD)
 | CircleWord | Treat the image as a single word in a circle.
 | Count | Number of enum entries.
 | OsdOnly | PageOrientation and script detection only.
 | RawLine | Treat the image as a single text line, bypassing hacks that are Tesseract-specific.
 | SingleBlock | Assume a single uniform block of text. (Default.)
 | SingleBlockVertText | Assume a single uniform block of vertically aligned text.
 | SingleChar | Treat the image as a single character.
 | SingleColumn | Assume a single column of text of variable sizes.
 | SingleLine | Treat the image as a single text line.
 | SingleWord | Treat the image as a single word.
 | SparseText | Find as much text as possible in no particular order.
 | SparseTextOsd | Sparse text with orientation and script det.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.OCR Namespace


PageSegMode Methods

The PageSegMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode Fields

The PageSegMode type exposes the following members.

Fields
 | Name | Description
 | Auto | Fully automatic page segmentation, but no OSD.
 | AutoOnly | Automatic page segmentation, but no OSD, or OCR.
 | AutoOsd | Automatic page segmentation with orientation and script detection. (OSD)
 | CircleWord | Treat the image as a single word in a circle.
 | Count | Number of enum entries.
 | OsdOnly | PageOrientation and script detection only.
 | RawLine | Treat the image as a single text line, bypassing hacks that are Tesseract-specific.
 | SingleBlock | Assume a single uniform block of text. (Default.)
 | SingleBlockVertText | Assume a single uniform block of vertically aligned text.
 | SingleChar | Treat the image as a single character.
 | SingleColumn | Assume a single column of text of variable sizes.
 | SingleLine | Treat the image as a single text line.
 | SingleWord | Treat the image as a single word.
 | SparseText | Find as much text as possible in no particular order.
 | SparseTextOsd | Sparse text with orientation and script det.
Public field | value__ |
Top
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.Auto Field

PageSegModeAuto Field

Fully automatic page segmentation, but no OSD.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode Auto = 3
Public Const Auto As PageSegMode = 3
public:
literal PageSegMode^ Auto = 3
static val mutable Auto: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.AutoOnly Field

PageSegModeAutoOnly Field

Automatic page segmentation, but no OSD, or OCR.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode AutoOnly = 2
Public Const AutoOnly As PageSegMode = 2
public:
literal PageSegMode^ AutoOnly = 2
static val mutable AutoOnly: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.AutoOsd Field

PageSegModeAutoOsd Field

Automatic page segmentation with orientation and script detection. (OSD)

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode AutoOsd = 1
Public Const AutoOsd As PageSegMode = 1
public:
literal PageSegMode^ AutoOsd = 1
static val mutable AutoOsd: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.CircleWord Field

PageSegModeCircleWord Field

Treat the image as a single word in a circle.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode CircleWord = 9
Public Const CircleWord As PageSegMode = 9
public:
literal PageSegMode^ CircleWord = 9
static val mutable CircleWord: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.Count Field

PageSegModeCount Field

Number of enum entries.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode Count = 14
Public Const Count As PageSegMode = 14
public:
literal PageSegMode^ Count = 14
static val mutable Count: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.OsdOnly Field

PageSegModeOsdOnly Field

PageOrientation and script detection only.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode OsdOnly = 0
Public Const OsdOnly As PageSegMode = 0
public:
literal PageSegMode^ OsdOnly = 0
static val mutable OsdOnly: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.RawLine Field

PageSegModeRawLine Field

Treat the image as a single text line, bypassing hacks that are Tesseract-specific.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode RawLine = 13
Public Const RawLine As PageSegMode = 13
public:
literal PageSegMode^ RawLine = 13
static val mutable RawLine: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SingleBlock Field

PageSegModeSingleBlock Field

Assume a single uniform block of text. (Default.)

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SingleBlock = 6
Public Const SingleBlock As PageSegMode = 6
public:
literal PageSegMode^ SingleBlock = 6
static val mutable SingleBlock: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SingleBlockVertText Field

PageSegModeSingleBlockVertText Field

Assume a single uniform block of vertically aligned text.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SingleBlockVertText = 5
Public Const SingleBlockVertText As PageSegMode = 5
public:
literal PageSegMode^ SingleBlockVertText = 5
static val mutable SingleBlockVertText: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SingleChar Field

PageSegModeSingleChar Field

Treat the image as a single character.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SingleChar = 10
Public Const SingleChar As PageSegMode = 10
public:
literal PageSegMode^ SingleChar = 10
static val mutable SingleChar: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SingleColumn Field

PageSegModeSingleColumn Field

Assume a single column of text of variable sizes.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SingleColumn = 4
Public Const SingleColumn As PageSegMode = 4
public:
literal PageSegMode^ SingleColumn = 4
static val mutable SingleColumn: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SingleLine Field

PageSegModeSingleLine Field

Treat the image as a single text line.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SingleLine = 7
Public Const SingleLine As PageSegMode = 7
public:
literal PageSegMode^ SingleLine = 7
static val mutable SingleLine: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SingleWord Field

PageSegModeSingleWord Field

Treat the image as a single word.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SingleWord = 8
Public Const SingleWord As PageSegMode = 8
public:
literal PageSegMode^ SingleWord = 8
static val mutable SingleWord: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SparseText Field

PageSegModeSparseText Field

Find as much text as possible in no particular order.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SparseText = 11
Public Const SparseText As PageSegMode = 11
public:
literal PageSegMode^ SparseText = 11
static val mutable SparseText: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.SparseTextOsd Field

PageSegModeSparseTextOsd Field

Sparse text with orientation and script det.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PageSegMode SparseTextOsd = 12
Public Const SparseTextOsd As PageSegMode = 12
public:
literal PageSegMode^ SparseTextOsd = 12
static val mutable SparseTextOsd: PageSegMode

Field Value

Type: PageSegMode
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PageSegMode.value__ Field

PageSegModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.OCR.PageSegMode.value__"]

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

PageSegMode Class
Emgu.CV.OCR Namespace


PDFRenderer Class

Renders tesseract output into searchable PDF
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OCRPDFRenderer

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PDFRenderer : UnmanagedObject,
    ITessResultRenderer
Public Class PDFRenderer
    Inherits UnmanagedObject
    Implements ITessResultRenderer
public ref class PDFRenderer : public UnmanagedObject,
    ITessResultRenderer
type PDFRenderer =
    class
        inherit UnmanagedObject
        interface ITessResultRenderer
    end

The PDFRenderer type exposes the following members.

Constructors
 | Name | Description
Public method | PDFRenderer | Create a PDF renderer
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TessResultRendererPtr | Pointer to the unmanaged TessResultRendered
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Renderer (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.OCR Namespace


PDFRenderer Constructor

Create a PDF renderer

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PDFRenderer(
    string outputBase,
    string dataDir,
    bool textOnly
)
Public Sub New (
    outputBase As String,
    dataDir As String,
    textOnly As Boolean
)
public:
PDFRenderer(
    String^ outputBase,
    String^ dataDir,
    bool textOnly
)
new :
        outputBase : string *
        dataDir : string *
        textOnly : bool -> PDFRenderer

Parameters

outputBase
Type: SystemString
Output base
dataDir
Type: SystemString
dataDir is the location of the TESSDATA. We need it because we load a custom PDF font from this location.
textOnly
Type: SystemBoolean
Text only
See Also

Reference

PDFRenderer Class
Emgu.CV.OCR Namespace


PDFRenderer Properties

The PDFRenderer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TessResultRendererPtr | Pointer to the unmanaged TessResultRendered
Top
See Also

Reference

PDFRenderer Class
Emgu.CV.OCR Namespace


PDFRenderer.TessResultRendererPtr Property

PDFRendererTessResultRendererPtr Property

Pointer to the unmanaged TessResultRendered

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr TessResultRendererPtr { get; }
Public ReadOnly Property TessResultRendererPtr As IntPtr
    Get
public:
virtual property IntPtr TessResultRendererPtr {
    IntPtr get () sealed;
}
abstract TessResultRendererPtr : IntPtr with get
override TessResultRendererPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ITessResultRendererTessResultRendererPtr
See Also

Reference

PDFRenderer Class
Emgu.CV.OCR Namespace


PDFRenderer Methods

The PDFRenderer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this Renderer (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PDFRenderer Class
Emgu.CV.OCR Namespace


PDFRenderer.DisposeObject Method

PDFRendererDisposeObject Method

Release the unmanaged memory associated with this Renderer

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PDFRenderer Class
Emgu.CV.OCR Namespace


PDFRenderer Fields

The PDFRenderer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

PDFRenderer Class
Emgu.CV.OCR Namespace


Pix Class

Leptonica Pix image structure
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OCRPix

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Pix : UnmanagedObject
Public Class Pix
    Inherits UnmanagedObject
public ref class Pix : public UnmanagedObject
type Pix =
    class
        inherit UnmanagedObject
    end

The Pix type exposes the following members.

Constructors
 | Name | Description
Public method | Pix | Create a Pix object by coping data from Mat
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Pix (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.OCR Namespace


Pix Constructor

Create a Pix object by coping data from Mat

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Pix(
    Mat mat
)
Public Sub New (
    mat As Mat
)
public:
Pix(
    Mat^ mat
)
new :
        mat : Mat -> Pix

Parameters

mat
Type: Emgu.CVMat
The Mat to create the Pix object from
See Also

Reference

Pix Class
Emgu.CV.OCR Namespace


Pix Properties

The Pix type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Pix Class
Emgu.CV.OCR Namespace


Pix Methods

The Pix type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Pix (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pix Class
Emgu.CV.OCR Namespace


Pix.DisposeObject Method

PixDisposeObject Method

Release all the unmanaged memory associated with this Pix

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Pix Class
Emgu.CV.OCR Namespace


Pix Fields

The Pix type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Pix Class
Emgu.CV.OCR Namespace


Tesseract Class

The tesseract OCR engine
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OCRTesseract

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Tesseract : UnmanagedObject
Public Class Tesseract
    Inherits UnmanagedObject
public ref class Tesseract : public UnmanagedObject
type Tesseract =
    class
        inherit UnmanagedObject
    end

The Tesseract type exposes the following members.

Constructors
 | Name | Description
Public method | Tesseract(Boolean) | Create a default tesseract engine. Needed to Call Init function to load language files in a later stage.
Public method | Tesseract(String, String, OcrEngineMode, String, Boolean) | Create a Tesseract OCR engine.
Top
Properties
 | Name | Description
 | DefaultTesseractDirectory | Get the default tesseract ocr directory. This should return the folder of the dll in most situations.
Public property | Oem | Get the OCR Engine Mode
Public property | PageSegMode | Gets or sets the page seg mode.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
 | Version | Get the tesseract version
 | VersionString | Get the tesseract version as String
Top
Methods
 | Name | Description
Public method | AnalyseLayout | Runs page layout analysis in the mode set by SetPageSegMode. May optionally be called prior to Recognize to get access to just the page layout results. Returns an iterator to the results. Returns NULL on error or an empty page. The returned iterator must be deleted after use. WARNING! This class points to data held within the TessBaseAPI class, and therefore can only be used while the TessBaseAPI class still exists and has not been subjected to a call of Init, SetImage, Recognize, Clear, End DetectOS, or anything else that changes the internal PAGE_RES.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with this class (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBoxText | The recognized text is returned as coded in the same format as a box file used in training.
Public method | GetCharacters | Detect all the characters in the image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHOCRText | Make a HTML-formatted string with hOCR markup from the internal data structures.
 | GetLangFileUrl | Get the url to download the tessdata file for the specific language
Public method | GetOpenCLDevice | If compiled with OpenCL AND an available OpenCL device is deemed faster than serial code, then "device" is populated with the cl_device_id and returns sizeof(cl_device_id) otherwise *device=nullptr and returns 0.
Public method | GetOsdText | The recognized text
Public method | GetTSVText | Make a TSV-formatted string from the internal data structures.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUNLVText | The recognized text is returned coded as UNLV format Latin-1 with specific reject and suspect codes
Public method | GetUTF8Text | Get all the text in the image
Public method | Init | Initialize the OCR engine using the specific dataPath and language name.
Public method | IsValidWord | Check whether a word is valid according to Tesseract's language model
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessPage | Turn a single image into symbolic text.
Public method | Recognize | Recognize the image from SetAndThresholdImage, generating Tesseract internal structures.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetImage(IInputArray) | Set the image for optical character recognition
Public method | SetImage(Pix) | Set the image for optical character recognition
Public method | SetVariable | Set the variable to the specific value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.OCR Namespace


Tesseract Constructor

Overload List
 | Name | Description
Public method | Tesseract(Boolean) | Create a default tesseract engine. Needed to Call Init function to load language files in a later stage.
Public method | Tesseract(String, String, OcrEngineMode, String, Boolean) | Create a Tesseract OCR engine.
Top
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract Constructor (Boolean)

Create a default tesseract engine. Needed to Call Init function to load language files in a later stage.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Tesseract(
    bool enforceLocale = true
)
Public Sub New (
    Optional enforceLocale As Boolean = true
)
public:
Tesseract(
    bool enforceLocale = true
)
new :
        ?enforceLocale : bool
(* Defaults:
        let _enforceLocale = defaultArg enforceLocale true
*)
-> Tesseract

Parameters

enforceLocale (Optional)
Type: SystemBoolean
If true, it will enforce "C" locale during the initialization.
See Also

Reference

Tesseract Class
Tesseract Overload
Emgu.CV.OCR Namespace


Tesseract Constructor (String, String, OcrEngineMode, String, Boolean)

Create a Tesseract OCR engine.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Tesseract(
    string dataPath,
    string language,
    OcrEngineMode mode,
    string whiteList = null,
    bool enforceLocale = true
)
Public Sub New (
    dataPath As String,
    language As String,
    mode As OcrEngineMode,
    Optional whiteList As String = Nothing,
    Optional enforceLocale As Boolean = true
)
public:
Tesseract(
    String^ dataPath,
    String^ language,
    OcrEngineMode^ mode,
    String^ whiteList = nullptr,
    bool enforceLocale = true
)
new :
        dataPath : string *
        language : string *
        mode : OcrEngineMode *
        ?whiteList : string *
        ?enforceLocale : bool
(* Defaults:
        let _whiteList = defaultArg whiteList null
        let _enforceLocale = defaultArg enforceLocale true
*)
-> Tesseract

Parameters

dataPath
Type: SystemString
The datapath must be the name of the directory of tessdata and must end in / . Any name after the last / will be stripped.
language
Type: SystemString
The language is (usually) an ISO 639-3 string or NULL will default to eng. It is entirely safe (and eventually will be efficient too) to call Init multiple times on the same instance to change language, or just to reset the classifier. The language may be a string of the form [~]%lt;lang>[+[~]<lang>]* indicating that multiple languages are to be loaded. Eg hin+eng will load Hindi and English. Languages may specify internally that they want to be loaded with one or more other languages, so the ~ sign is available to override that. Eg if hin were set to load eng by default, then hin+~eng would force loading only hin. The number of loaded languages is limited only by memory, with the caveat that loading additional languages will impact both speed and accuracy, as there is more work to do to decide on the applicable language, and there is more chance of hallucinating incorrect words.
mode
Type: Emgu.CV.OCROcrEngineMode
OCR engine mode
whiteList (Optional)
Type: SystemString
This can be used to specify a white list for OCR. e.g. specify "1234567890" to recognize digits only. Note that the white list currently seems to only work with OcrEngineMode.OEM_TESSERACT_ONLY
enforceLocale (Optional)
Type: SystemBoolean
If true, we will change the locale to "C" before initializing the tesseract engine and reverting it back once the tesseract initialiation is completer. If false, it will be the user's responsibility to set the locale to "C", otherwise an exception will be thrown. See https://github.com/tesseract-ocr/tesseract/issues/1670
See Also

Reference

Tesseract Class
Tesseract Overload
Emgu.CV.OCR Namespace


Tesseract Properties

The Tesseract type exposes the following members.

Properties
 | Name | Description
 | DefaultTesseractDirectory | Get the default tesseract ocr directory. This should return the folder of the dll in most situations.
Public property | Oem | Get the OCR Engine Mode
Public property | PageSegMode | Gets or sets the page seg mode.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
 | Version | Get the tesseract version
 | VersionString | Get the tesseract version as String
Top
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.DefaultTesseractDirectory Property

TesseractDefaultTesseractDirectory Property

Get the default tesseract ocr directory. This should return the folder of the dll in most situations.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string DefaultTesseractDirectory { get; }
Public Shared ReadOnly Property DefaultTesseractDirectory As String
    Get
public:
static property String^ DefaultTesseractDirectory {
    String^ get ();
}
static member DefaultTesseractDirectory : string with get

Property Value

Type: String
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.Oem Property

TesseractOem Property

Get the OCR Engine Mode

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OcrEngineMode Oem { get; }
Public ReadOnly Property Oem As OcrEngineMode
    Get
public:
property OcrEngineMode^ Oem {
    OcrEngineMode^ get ();
}
member Oem : OcrEngineMode with get

Property Value

Type: OcrEngineMode
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.PageSegMode Property

TesseractPageSegMode Property

Gets or sets the page seg mode.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PageSegMode PageSegMode { get; set; }
Public Property PageSegMode As PageSegMode
    Get
    Set
public:
property PageSegMode^ PageSegMode {
    PageSegMode^ get ();
    void set (PageSegMode^ value);
}
member PageSegMode : PageSegMode with get, set

Property Value

Type: PageSegMode
The page seg mode.
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.Version Property

TesseractVersion Property

Get the tesseract version

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Version Version { get; }
Public Shared ReadOnly Property Version As Version
    Get
public:
static property Version^ Version {
    Version^ get ();
}
static member Version : Version with get

Property Value

Type: Version
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.VersionString Property

TesseractVersionString Property

Get the tesseract version as String

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string VersionString { get; }
Public Shared ReadOnly Property VersionString As String
    Get
public:
static property String^ VersionString {
    String^ get ();
}
static member VersionString : string with get

Property Value

Type: String
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract Methods

The Tesseract type exposes the following members.

Methods
 | Name | Description
Public method | AnalyseLayout | Runs page layout analysis in the mode set by SetPageSegMode. May optionally be called prior to Recognize to get access to just the page layout results. Returns an iterator to the results. Returns NULL on error or an empty page. The returned iterator must be deleted after use. WARNING! This class points to data held within the TessBaseAPI class, and therefore can only be used while the TessBaseAPI class still exists and has not been subjected to a call of Init, SetImage, Recognize, Clear, End DetectOS, or anything else that changes the internal PAGE_RES.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resource associated with this class (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBoxText | The recognized text is returned as coded in the same format as a box file used in training.
Public method | GetCharacters | Detect all the characters in the image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHOCRText | Make a HTML-formatted string with hOCR markup from the internal data structures.
 | GetLangFileUrl | Get the url to download the tessdata file for the specific language
Public method | GetOpenCLDevice | If compiled with OpenCL AND an available OpenCL device is deemed faster than serial code, then "device" is populated with the cl_device_id and returns sizeof(cl_device_id) otherwise *device=nullptr and returns 0.
Public method | GetOsdText | The recognized text
Public method | GetTSVText | Make a TSV-formatted string from the internal data structures.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUNLVText | The recognized text is returned coded as UNLV format Latin-1 with specific reject and suspect codes
Public method | GetUTF8Text | Get all the text in the image
Public method | Init | Initialize the OCR engine using the specific dataPath and language name.
Public method | IsValidWord | Check whether a word is valid according to Tesseract's language model
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessPage | Turn a single image into symbolic text.
Public method | Recognize | Recognize the image from SetAndThresholdImage, generating Tesseract internal structures.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetImage(IInputArray) | Set the image for optical character recognition
Public method | SetImage(Pix) | Set the image for optical character recognition
Public method | SetVariable | Set the variable to the specific value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.AnalyseLayout Method

TesseractAnalyseLayout Method

Runs page layout analysis in the mode set by SetPageSegMode. May optionally be called prior to Recognize to get access to just the page layout results. Returns an iterator to the results. Returns NULL on error or an empty page. The returned iterator must be deleted after use. WARNING! This class points to data held within the TessBaseAPI class, and therefore can only be used while the TessBaseAPI class still exists and has not been subjected to a call of Init, SetImage, Recognize, Clear, End DetectOS, or anything else that changes the internal PAGE_RES.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PageIterator AnalyseLayout(
    bool mergeSimilarWords = false
)
Public Function AnalyseLayout (
    Optional mergeSimilarWords As Boolean = false
) As PageIterator
public:
PageIterator^ AnalyseLayout(
    bool mergeSimilarWords = false
)
member AnalyseLayout :
        ?mergeSimilarWords : bool
(* Defaults:
        let _mergeSimilarWords = defaultArg mergeSimilarWords false
*)
-> PageIterator

Parameters

mergeSimilarWords (Optional)
Type: SystemBoolean
If true merge similar words

Return Value

Type: PageIterator
Page iterator
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.DisposeObject Method

TesseractDisposeObject Method

Release the unmanaged resource associated with this class

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetBoxText Method

TesseractGetBoxText Method

The recognized text is returned as coded in the same format as a box file used in training.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetBoxText(
    int pageNumber = 0
)
Public Function GetBoxText (
    Optional pageNumber As Integer = 0
) As String
public:
String^ GetBoxText(
    int pageNumber = 0
)
member GetBoxText :
        ?pageNumber : int
(* Defaults:
        let _pageNumber = defaultArg pageNumber 0
*)
-> string

Parameters

pageNumber (Optional)
Type: SystemInt32
pageNumber is 0-based but will appear in the output as 1-based.

Return Value

Type: String
The recognized text is returned as coded in the same format as a box file used in training.
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetCharacters Method

TesseractGetCharacters Method

Detect all the characters in the image.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TesseractCharacter[] GetCharacters()
Public Function GetCharacters As TesseractCharacter()
public:
array<TesseractCharacter^>^ GetCharacters()
member GetCharacters : unit -> TesseractCharacter[]

Return Value

Type: TesseractCharacter
All the characters in the image
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetHOCRText Method

TesseractGetHOCRText Method

Make a HTML-formatted string with hOCR markup from the internal data structures.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetHOCRText(
    int pageNumber = 0
)
Public Function GetHOCRText (
    Optional pageNumber As Integer = 0
) As String
public:
String^ GetHOCRText(
    int pageNumber = 0
)
member GetHOCRText :
        ?pageNumber : int
(* Defaults:
        let _pageNumber = defaultArg pageNumber 0
*)
-> string

Parameters

pageNumber (Optional)
Type: SystemInt32
pageNumber is 0-based but will appear in the output as 1-based.

Return Value

Type: String
A HTML-formatted string with hOCR markup from the internal data structures.
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetLangFileUrl Method

TesseractGetLangFileUrl Method

Get the url to download the tessdata file for the specific language

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string GetLangFileUrl(
    string lang
)
Public Shared Function GetLangFileUrl (
    lang As String
) As String
public:
static String^ GetLangFileUrl(
    String^ lang
)
static member GetLangFileUrl :
        lang : string -> string

Parameters

lang
Type: SystemString
The 3 letter language identifier

Return Value

Type: String
the url to download the tessdata file for the specific language
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetOpenCLDevice Method

TesseractGetOpenCLDevice Method

If compiled with OpenCL AND an available OpenCL device is deemed faster than serial code, then "device" is populated with the cl_device_id and returns sizeof(cl_device_id) otherwise *device=nullptr and returns 0.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetOpenCLDevice(
    ref IntPtr device
)
Public Function GetOpenCLDevice (
    ByRef device As IntPtr
) As Integer
public:
int GetOpenCLDevice(
    IntPtr% device
)
member GetOpenCLDevice :
        device : IntPtr byref -> int

Parameters

device
Type: SystemIntPtr
Pointer to the opencl device

Return Value

Type: Int32
0 if no device found. sizeof(cl_device_id) if device is found.
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetOsdText Method

TesseractGetOsdText Method

The recognized text

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetOsdText(
    int pageNumber = 0
)
Public Function GetOsdText (
    Optional pageNumber As Integer = 0
) As String
public:
String^ GetOsdText(
    int pageNumber = 0
)
member GetOsdText :
        ?pageNumber : int
(* Defaults:
        let _pageNumber = defaultArg pageNumber 0
*)
-> string

Parameters

pageNumber (Optional)
Type: SystemInt32
pageNumber is 0-based but will appear in the output as 1-based.

Return Value

Type: String
The recognized text
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetTSVText Method

TesseractGetTSVText Method

Make a TSV-formatted string from the internal data structures.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetTSVText(
    int pageNumber = 0
)
Public Function GetTSVText (
    Optional pageNumber As Integer = 0
) As String
public:
String^ GetTSVText(
    int pageNumber = 0
)
member GetTSVText :
        ?pageNumber : int
(* Defaults:
        let _pageNumber = defaultArg pageNumber 0
*)
-> string

Parameters

pageNumber (Optional)
Type: SystemInt32
pageNumber is 0-based but will appear in the output as 1-based.

Return Value

Type: String
A TSV-formatted string from the internal data structures.
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetUNLVText Method

TesseractGetUNLVText Method

The recognized text is returned coded as UNLV format Latin-1 with specific reject and suspect codes

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetUNLVText(
    int pageNumber = 0
)
Public Function GetUNLVText (
    Optional pageNumber As Integer = 0
) As String
public:
String^ GetUNLVText(
    int pageNumber = 0
)
member GetUNLVText :
        ?pageNumber : int
(* Defaults:
        let _pageNumber = defaultArg pageNumber 0
*)
-> string

Parameters

pageNumber (Optional)
Type: SystemInt32
pageNumber is 0-based but will appear in the output as 1-based.

Return Value

Type: String
The recognized text is returned coded as UNLV format Latin-1 with specific reject and suspect codes
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.GetUTF8Text Method

TesseractGetUTF8Text Method

Get all the text in the image

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetUTF8Text()
Public Function GetUTF8Text As String
public:
String^ GetUTF8Text()
member GetUTF8Text : unit -> string

Return Value

Type: String
All the text in the image
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.Init Method

TesseractInit Method

Initialize the OCR engine using the specific dataPath and language name.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Init(
    string dataPath,
    string language,
    OcrEngineMode mode
)
Public Sub Init (
    dataPath As String,
    language As String,
    mode As OcrEngineMode
)
public:
void Init(
    String^ dataPath,
    String^ language,
    OcrEngineMode^ mode
)
member Init :
        dataPath : string *
        language : string *
        mode : OcrEngineMode -> unit

Parameters

dataPath
Type: SystemString
The datapath must be the name of the parent directory of tessdata and must end in / . Any name after the last / will be stripped.
language
Type: SystemString
The language is (usually) an ISO 639-3 string or NULL will default to eng. It is entirely safe (and eventually will be efficient too) to call Init multiple times on the same instance to change language, or just to reset the classifier. The language may be a string of the form [~]%lt;lang>[+[~]<lang>]* indicating that multiple languages are to be loaded. Eg hin+eng will load Hindi and English. Languages may specify internally that they want to be loaded with one or more other languages, so the ~ sign is available to override that. Eg if hin were set to load eng by default, then hin+~eng would force loading only hin. The number of loaded languages is limited only by memory, with the caveat that loading additional languages will impact both speed and accuracy, as there is more work to do to decide on the applicable language, and there is more chance of hallucinating incorrect words.
mode
Type: Emgu.CV.OCROcrEngineMode
OCR engine mode
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.IsValidWord Method

TesseractIsValidWord Method

Check whether a word is valid according to Tesseract's language model

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int IsValidWord(
    string word
)
Public Function IsValidWord (
    word As String
) As Integer
public:
int IsValidWord(
    String^ word
)
member IsValidWord :
        word : string -> int

Parameters

word
Type: SystemString
The word to be checked.

Return Value

Type: Int32
0 if the word is invalid, non-zero if valid
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.ProcessPage Method

TesseractProcessPage Method

Turn a single image into symbolic text.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ProcessPage(
    Pix pix,
    int pageIndex,
    string filename,
    string retryConfig,
    int timeoutMillisec,
    ITessResultRenderer renderer
)
Public Function ProcessPage (
    pix As Pix,
    pageIndex As Integer,
    filename As String,
    retryConfig As String,
    timeoutMillisec As Integer,
    renderer As ITessResultRenderer
) As Boolean
public:
bool ProcessPage(
    Pix^ pix,
    int pageIndex,
    String^ filename,
    String^ retryConfig,
    int timeoutMillisec,
    ITessResultRenderer^ renderer
)
member ProcessPage :
        pix : Pix *
        pageIndex : int *
        filename : string *
        retryConfig : string *
        timeoutMillisec : int *
        renderer : ITessResultRenderer -> bool

Parameters

pix
Type: Emgu.CV.OCRPix
The pix is the image processed.
pageIndex
Type: SystemInt32
Metadata used by side-effect processes, such as reading a box file or formatting as hOCR.
filename
Type: SystemString
Metadata used by side-effect processes, such as reading a box file or formatting as hOCR.
retryConfig
Type: SystemString
retryConfig is useful for debugging. If not NULL, you can fall back to an alternate configuration if a page fails for some reason.
timeoutMillisec
Type: SystemInt32
terminates processing if any single page takes too long. Set to 0 for unlimited time.
renderer
Type: Emgu.CV.OCRITessResultRenderer
Responsible for creating the output. For example, use the TessTextRenderer if you want plaintext output, or the TessPDFRender to produce searchable PDF.

Return Value

Type: Boolean
Returns true if successful, false on error.
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.Recognize Method

TesseractRecognize Method

Recognize the image from SetAndThresholdImage, generating Tesseract internal structures.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Recognize()
Public Function Recognize As Integer
public:
int Recognize()
member Recognize : unit -> int

Return Value

Type: Int32
Returns 0 on success.
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.SetImage Method

TesseractSetImage Method

Overload List
 | Name | Description
Public method | SetImage(IInputArray) | Set the image for optical character recognition
Public method | SetImage(Pix) | Set the image for optical character recognition
Top
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.SetImage Method (IInputArray)

TesseractSetImage Method (IInputArray)

http://www.emgu.com
Set the image for optical character recognition

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetImage(
    IInputArray image
)
Public Sub SetImage (
    image As IInputArray
)
public:
void SetImage(
    IInputArray^ image
)
member SetImage :
        image : IInputArray -> unit

Parameters

image
Type: Emgu.CVIInputArray
The image where detection took place
See Also

Reference

Tesseract Class
SetImage Overload
Emgu.CV.OCR Namespace


Tesseract.SetImage Method (Pix)

TesseractSetImage Method (Pix)

http://www.emgu.com
Set the image for optical character recognition

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetImage(
    Pix image
)
Public Sub SetImage (
    image As Pix
)
public:
void SetImage(
    Pix^ image
)
member SetImage :
        image : Pix -> unit

Parameters

image
Type: Emgu.CV.OCRPix
The image where detection took place
See Also

Reference

Tesseract Class
SetImage Overload
Emgu.CV.OCR Namespace


Tesseract.SetVariable Method

TesseractSetVariable Method

Set the variable to the specific value.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetVariable(
    string variableName,
    string value
)
Public Sub SetVariable (
    variableName As String,
    value As String
)
public:
void SetVariable(
    String^ variableName,
    String^ value
)
member SetVariable :
        variableName : string *
        value : string -> unit

Parameters

variableName
Type: SystemString
The name of the tesseract variable. e.g. use "tessedit_char_blacklist" to black list characters and "tessedit_char_whitelist" to white list characters. The full list of options can be found in the Tesseract OCR source code "tesseractclass.h"
value
Type: SystemString
The value to be set
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract Fields

The Tesseract type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Tesseract Class
Emgu.CV.OCR Namespace


Tesseract.Character Class

TesseractCharacter Class

This represent a character that is detected by the OCR engine
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.OCRTesseractCharacter

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Character : ValueType
Public NotInheritable Class Character
    Inherits ValueType
public ref class Character sealed : public ValueType
[<SealedAttribute>]
type Character =
    class
        inherit ValueType
    end

The TesseractCharacter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Cost | The cost. The lower it is, the more confident is the result
Public field | Region | The region where the character is detected.
Public field | Text | The text
Top
See Also

Reference

Emgu.CV.OCR Namespace


Character Methods

The TesseractCharacter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

TesseractCharacter Class
Emgu.CV.OCR Namespace


Character Fields

The TesseractCharacter type exposes the following members.

Fields
 | Name | Description
Public field | Cost | The cost. The lower it is, the more confident is the result
Public field | Region | The region where the character is detected.
Public field | Text | The text
Top
See Also

Reference

TesseractCharacter Class
Emgu.CV.OCR Namespace


Tesseract.Character.Cost Field

TesseractCharacterCost Field

The cost. The lower it is, the more confident is the result

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Cost
Public Cost As Single
public:
float Cost
val mutable Cost: float32

Field Value

Type: Single
See Also

Reference

TesseractCharacter Class
Emgu.CV.OCR Namespace


Tesseract.Character.Region Field

TesseractCharacterRegion Field

The region where the character is detected.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle Region
Public Region As Rectangle
public:
Rectangle^ Region
val mutable Region: Rectangle

Field Value

Type: Rectangle
See Also

Reference

TesseractCharacter Class
Emgu.CV.OCR Namespace


Tesseract.Character.Text Field

TesseractCharacterText Field

The text

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Text
Public Text As String
public:
String^ Text
val mutable Text: string

Field Value

Type: String
See Also

Reference

TesseractCharacter Class
Emgu.CV.OCR Namespace


TesseractResult Class

This structure is primary used for PInvoke
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.OCRTesseractResult

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TesseractResult : ValueType
Public NotInheritable Class TesseractResult
    Inherits ValueType
public ref class TesseractResult sealed : public ValueType
[<SealedAttribute>]
type TesseractResult =
    class
        inherit ValueType
    end

The TesseractResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Cost | The cost
Public field | Length | The length
Public field | Region | The region
Top
See Also

Reference

Emgu.CV.OCR Namespace


TesseractResult Methods

The TesseractResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

TesseractResult Class
Emgu.CV.OCR Namespace


TesseractResult Fields

The TesseractResult type exposes the following members.

Fields
 | Name | Description
Public field | Cost | The cost
Public field | Length | The length
Public field | Region | The region
Top
See Also

Reference

TesseractResult Class
Emgu.CV.OCR Namespace


TesseractResult.Cost Field

TesseractResultCost Field

The cost

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Cost
Public Cost As Single
public:
float Cost
val mutable Cost: float32

Field Value

Type: Single
See Also

Reference

TesseractResult Class
Emgu.CV.OCR Namespace


TesseractResult.Length Field

TesseractResultLength Field

The length

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Length
Public Length As Integer
public:
int Length
val mutable Length: int

Field Value

Type: Int32
See Also

Reference

TesseractResult Class
Emgu.CV.OCR Namespace


TesseractResult.Region Field

TesseractResultRegion Field

The region

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle Region
Public Region As Rectangle
public:
Rectangle^ Region
val mutable Region: Rectangle

Field Value

Type: Rectangle
See Also

Reference

TesseractResult Class
Emgu.CV.OCR Namespace


TextlineOrder Class

Textline order
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OCRTextlineOrder

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TextlineOrder : Enum
Public NotInheritable Class TextlineOrder
    Inherits Enum
public ref class TextlineOrder sealed : public Enum
[<SealedAttribute>]
type TextlineOrder =
    class
        inherit Enum
    end

The TextlineOrder type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | LeftToRight | Left to right
 | RightToLeft | Right to left
 | TopToBottom | Top to bottom
Public field | value__ |
Top
See Also

Reference

Emgu.CV.OCR Namespace


TextlineOrder Methods

The TextlineOrder type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

TextlineOrder Class
Emgu.CV.OCR Namespace


TextlineOrder Fields

The TextlineOrder type exposes the following members.

Fields
 | Name | Description
 | LeftToRight | Left to right
 | RightToLeft | Right to left
 | TopToBottom | Top to bottom
Public field | value__ |
Top
See Also

Reference

TextlineOrder Class
Emgu.CV.OCR Namespace


TextlineOrder.LeftToRight Field

TextlineOrderLeftToRight Field

Left to right

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TextlineOrder LeftToRight = 0
Public Const LeftToRight As TextlineOrder = 0
public:
literal TextlineOrder^ LeftToRight = 0
static val mutable LeftToRight: TextlineOrder

Field Value

Type: TextlineOrder
See Also

Reference

TextlineOrder Class
Emgu.CV.OCR Namespace


TextlineOrder.RightToLeft Field

TextlineOrderRightToLeft Field

Right to left

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TextlineOrder RightToLeft = 1
Public Const RightToLeft As TextlineOrder = 1
public:
literal TextlineOrder^ RightToLeft = 1
static val mutable RightToLeft: TextlineOrder

Field Value

Type: TextlineOrder
See Also

Reference

TextlineOrder Class
Emgu.CV.OCR Namespace


TextlineOrder.TopToBottom Field

TextlineOrderTopToBottom Field

Top to bottom

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TextlineOrder TopToBottom = 2
Public Const TopToBottom As TextlineOrder = 2
public:
literal TextlineOrder^ TopToBottom = 2
static val mutable TopToBottom: TextlineOrder

Field Value

Type: TextlineOrder
See Also

Reference

TextlineOrder Class
Emgu.CV.OCR Namespace


TextlineOrder.value__ Field

TextlineOrdervalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.OCR.TextlineOrder.value__"]

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

TextlineOrder Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult Class

Wrapped class of the C++ standard vector of TesseractResult.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.OCRVectorOfTesseractResult

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfTesseractResult : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfTesseractResult
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfTesseractResult : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfTesseractResult =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfTesseractResult type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfTesseractResult | Create an empty standard vector of TesseractResult
Public method | VectorOfTesseractResult(Int32) | Create an standard vector of TesseractResult of the specific size
Public method | VectorOfTesseractResult(TesseractResult) | Create an standard vector of TesseractResult with the initial values
Public method | VectorOfTesseractResult(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(TesseractResult) | Push an array of value into the standard vector
Public method | Push(VectorOfTesseractResult) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of TesseractResult
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.OCR Namespace


VectorOfTesseractResult Constructor

Overload List
 | Name | Description
Public method | VectorOfTesseractResult | Create an empty standard vector of TesseractResult
Public method | VectorOfTesseractResult(Int32) | Create an standard vector of TesseractResult of the specific size
Public method | VectorOfTesseractResult(TesseractResult) | Create an standard vector of TesseractResult with the initial values
Public method | VectorOfTesseractResult(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult Constructor

Create an empty standard vector of TesseractResult

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTesseractResult()
Public Sub New
public:
VectorOfTesseractResult()
new : unit -> VectorOfTesseractResult
See Also

Reference

VectorOfTesseractResult Class
VectorOfTesseractResult Overload
Emgu.CV.OCR Namespace


VectorOfTesseractResult Constructor (Int32)

Create an standard vector of TesseractResult of the specific size

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTesseractResult(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfTesseractResult(
    int size
)
new :
        size : int -> VectorOfTesseractResult

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfTesseractResult Class
VectorOfTesseractResult Overload
Emgu.CV.OCR Namespace


VectorOfTesseractResult Constructor (TesseractResult[])

VectorOfTesseractResult Constructor (TesseractResult)

http://www.emgu.com
Create an standard vector of TesseractResult with the initial values

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTesseractResult(
    TesseractResult[] values
)
Public Sub New (
    values As TesseractResult()
)
public:
VectorOfTesseractResult(
    array<TesseractResult^>^ values
)
new :
        values : TesseractResult[] -> VectorOfTesseractResult

Parameters

values
Type: Emgu.CV.OCRTesseractResult
The initial values
See Also

Reference

VectorOfTesseractResult Class
VectorOfTesseractResult Overload
Emgu.CV.OCR Namespace


VectorOfTesseractResult Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTesseractResult(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfTesseractResult(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfTesseractResult

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfTesseractResult Class
VectorOfTesseractResult Overload
Emgu.CV.OCR Namespace


VectorOfTesseractResult Properties

The VectorOfTesseractResult type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.Item Property

VectorOfTesseractResultItem Property

Get the item in the specific index

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TesseractResult this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As TesseractResult
    Get
public:
property TesseractResult^ Item[int index] {
    TesseractResult^ get (int index);
}
member Item : TesseractResult with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: TesseractResult
The item in the specific index
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.Size Property

VectorOfTesseractResultSize Property

Get the size of the vector

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.SizeOfItemInBytes Property

VectorOfTesseractResultSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.StartAddress Property

VectorOfTesseractResultStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult Methods

The VectorOfTesseractResult type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(TesseractResult) | Push an array of value into the standard vector
Public method | Push(VectorOfTesseractResult) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of TesseractResult
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.Clear Method

VectorOfTesseractResultClear Method

Clear the vector

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.DisposeObject Method

VectorOfTesseractResultDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.GetInputArray Method

VectorOfTesseractResultGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.GetInputOutputArray Method

VectorOfTesseractResultGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.GetObjectData Method

VectorOfTesseractResultGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.GetOutputArray Method

VectorOfTesseractResultGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.Push Method

VectorOfTesseractResultPush Method

Overload List
 | Name | Description
Public method | Push(TesseractResult) | Push an array of value into the standard vector
Public method | Push(VectorOfTesseractResult) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult.Push Method (TesseractResult[])

VectorOfTesseractResultPush Method (TesseractResult)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    TesseractResult[] value
)
Public Sub Push (
    value As TesseractResult()
)
public:
void Push(
    array<TesseractResult^>^ value
)
member Push :
        value : TesseractResult[] -> unit

Parameters

value
Type: Emgu.CV.OCRTesseractResult
The value to be pushed to the vector
See Also

Reference

VectorOfTesseractResult Class
Push Overload
Emgu.CV.OCR Namespace


VectorOfTesseractResult.Push Method (VectorOfTesseractResult)

VectorOfTesseractResultPush Method (VectorOfTesseractResult)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfTesseractResult other
)
Public Sub Push (
    other As VectorOfTesseractResult
)
public:
void Push(
    VectorOfTesseractResult^ other
)
member Push :
        other : VectorOfTesseractResult -> unit

Parameters

other
Type: Emgu.CV.OCRVectorOfTesseractResult
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfTesseractResult Class
Push Overload
Emgu.CV.OCR Namespace


VectorOfTesseractResult.ToArray Method

VectorOfTesseractResultToArray Method

Convert the standard vector to an array of TesseractResult

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TesseractResult[] ToArray()
Public Function ToArray As TesseractResult()
public:
array<TesseractResult^>^ ToArray()
member ToArray : unit -> TesseractResult[]

Return Value

Type: TesseractResult
An array of TesseractResult
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


VectorOfTesseractResult Fields

The VectorOfTesseractResult type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfTesseractResult Class
Emgu.CV.OCR Namespace


WritingDirection Class

Writing direction
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.OCRWritingDirection

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class WritingDirection : Enum
Public NotInheritable Class WritingDirection
    Inherits Enum
public ref class WritingDirection sealed : public Enum
[<SealedAttribute>]
type WritingDirection =
    class
        inherit Enum
    end

The WritingDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | LeftToRight | Left to right
 | RightToLeft | Right to left
 | TopToBottom | Top to bottom
Public field | value__ |
Top
See Also

Reference

Emgu.CV.OCR Namespace


WritingDirection Methods

The WritingDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

WritingDirection Class
Emgu.CV.OCR Namespace


WritingDirection Fields

The WritingDirection type exposes the following members.

Fields
 | Name | Description
 | LeftToRight | Left to right
 | RightToLeft | Right to left
 | TopToBottom | Top to bottom
Public field | value__ |
Top
See Also

Reference

WritingDirection Class
Emgu.CV.OCR Namespace


WritingDirection.LeftToRight Field

WritingDirectionLeftToRight Field

Left to right

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WritingDirection LeftToRight = 0
Public Const LeftToRight As WritingDirection = 0
public:
literal WritingDirection^ LeftToRight = 0
static val mutable LeftToRight: WritingDirection

Field Value

Type: WritingDirection
See Also

Reference

WritingDirection Class
Emgu.CV.OCR Namespace


WritingDirection.RightToLeft Field

WritingDirectionRightToLeft Field

Right to left

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WritingDirection RightToLeft = 1
Public Const RightToLeft As WritingDirection = 1
public:
literal WritingDirection^ RightToLeft = 1
static val mutable RightToLeft: WritingDirection

Field Value

Type: WritingDirection
See Also

Reference

WritingDirection Class
Emgu.CV.OCR Namespace


WritingDirection.TopToBottom Field

WritingDirectionTopToBottom Field

Top to bottom

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WritingDirection TopToBottom = 2
Public Const TopToBottom As WritingDirection = 2
public:
literal WritingDirection^ TopToBottom = 2
static val mutable TopToBottom: WritingDirection

Field Value

Type: WritingDirection
See Also

Reference

WritingDirection Class
Emgu.CV.OCR Namespace


WritingDirection.value__ Field

WritingDirectionvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.OCR.WritingDirection.value__"]

Namespace: Emgu.CV.OCR
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

WritingDirection Class
Emgu.CV.OCR Namespace


Emgu.CV.PhaseUnwrapping Namespace

Phase Unwrapping API
Classes
 | Class | Description
Public class | HistogramPhaseUnwrapping | Class implementing two-dimensional phase unwrapping.
Public class | PhaseUnwrappingInvoke | Provide interfaces to the Open CV PhaseUnwrapping functions


HistogramPhaseUnwrapping Class

Class implementing two-dimensional phase unwrapping.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.PhaseUnwrappingHistogramPhaseUnwrapping

Namespace: Emgu.CV.PhaseUnwrapping
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class HistogramPhaseUnwrapping : UnmanagedObject
Public Class HistogramPhaseUnwrapping
    Inherits UnmanagedObject
public ref class HistogramPhaseUnwrapping : public UnmanagedObject
type HistogramPhaseUnwrapping =
    class
        inherit UnmanagedObject
    end

The HistogramPhaseUnwrapping type exposes the following members.

Constructors
 | Name | Description
Public method | HistogramPhaseUnwrapping | Create a HistogramPhaseUnwrapping instance
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with the HistogramPhaseUnwrapping (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInverseReliabilityMap | Get the reliability map computed from the wrapped phase map.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnwrapPhaseMap | Unwraps a 2D phase map.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Remarks
This algorithm belongs to the quality-guided phase unwrapping methods. First, it computes a reliability map from second differences between a pixel and its eight neighbours. Reliability values lie between 0 and 16*pi*pi. Then, this reliability map is used to compute the reliabilities of "edges". An edge is an entity defined by two pixels that are connected horizontally or vertically. Its reliability is found by adding the reliabilities of the two pixels connected through it. Edges are sorted in a histogram based on their reliability values. This histogram is then used to unwrap pixels, starting from the highest quality pixel.
See Also

Reference

Emgu.CV.PhaseUnwrapping Namespace


HistogramPhaseUnwrapping Constructor

Create a HistogramPhaseUnwrapping instance

Namespace: Emgu.CV.PhaseUnwrapping
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public HistogramPhaseUnwrapping(
    int width = 800,
    int height = 600,
    float histThresh = 29.60881f,
    int nbrOfSmallBins = 10,
    int nbrOfLargeBins = 5
)
Public Sub New (
    Optional width As Integer = 800,
    Optional height As Integer = 600,
    Optional histThresh As Single = 29.60881F,
    Optional nbrOfSmallBins As Integer = 10,
    Optional nbrOfLargeBins As Integer = 5
)
public:
HistogramPhaseUnwrapping(
    int width = 800,
    int height = 600,
    float histThresh = 29.60881f,
    int nbrOfSmallBins = 10,
    int nbrOfLargeBins = 5
)
new :
        ?width : int *
        ?height : int *
        ?histThresh : float32 *
        ?nbrOfSmallBins : int *
        ?nbrOfLargeBins : int
(* Defaults:
        let _width = defaultArg width 800
        let _height = defaultArg height 600
        let _histThresh = defaultArg histThresh 29.60881f
        let _nbrOfSmallBins = defaultArg nbrOfSmallBins 10
        let _nbrOfLargeBins = defaultArg nbrOfLargeBins 5
*)
-> HistogramPhaseUnwrapping

Parameters

width (Optional)
Type: SystemInt32
Phase map width.
height (Optional)
Type: SystemInt32
Phase map height.
histThresh (Optional)
Type: SystemSingle
Bins in the histogram are not of equal size. Default value is 3*pi*pi. The one before "histThresh" value are smaller.
nbrOfSmallBins (Optional)
Type: SystemInt32
Number of bins between 0 and "histThresh". Default value is 10.
nbrOfLargeBins (Optional)
Type: SystemInt32
Number of bins between "histThresh" and 32*pi*pi (highest edge reliability value). Default value is 5.
See Also

Reference

HistogramPhaseUnwrapping Class
Emgu.CV.PhaseUnwrapping Namespace


HistogramPhaseUnwrapping Properties

The HistogramPhaseUnwrapping type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HistogramPhaseUnwrapping Class
Emgu.CV.PhaseUnwrapping Namespace


HistogramPhaseUnwrapping Methods

The HistogramPhaseUnwrapping type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with the HistogramPhaseUnwrapping (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInverseReliabilityMap | Get the reliability map computed from the wrapped phase map.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnwrapPhaseMap | Unwraps a 2D phase map.
Top
See Also

Reference

HistogramPhaseUnwrapping Class
Emgu.CV.PhaseUnwrapping Namespace


HistogramPhaseUnwrapping.DisposeObject Method

HistogramPhaseUnwrappingDisposeObject Method

Release the unmanaged resources associated with the HistogramPhaseUnwrapping

Namespace: Emgu.CV.PhaseUnwrapping
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

HistogramPhaseUnwrapping Class
Emgu.CV.PhaseUnwrapping Namespace


HistogramPhaseUnwrapping.GetInverseReliabilityMap Method

HistogramPhaseUnwrappingGetInverseReliabilityMap Method

Get the reliability map computed from the wrapped phase map.

Namespace: Emgu.CV.PhaseUnwrapping
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetInverseReliabilityMap(
    IOutputArray reliabilityMap
)
Public Sub GetInverseReliabilityMap (
    reliabilityMap As IOutputArray
)
public:
void GetInverseReliabilityMap(
    IOutputArray^ reliabilityMap
)
member GetInverseReliabilityMap :
        reliabilityMap : IOutputArray -> unit

Parameters

reliabilityMap
Type: Emgu.CVIOutputArray
Image where the reliability map is stored.
See Also

Reference

HistogramPhaseUnwrapping Class
Emgu.CV.PhaseUnwrapping Namespace


HistogramPhaseUnwrapping.UnwrapPhaseMap Method

HistogramPhaseUnwrappingUnwrapPhaseMap Method

Unwraps a 2D phase map.

Namespace: Emgu.CV.PhaseUnwrapping
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void UnwrapPhaseMap(
    IInputArray wrappedPhaseMap,
    IOutputArray unwrappedPhaseMap,
    IInputArray shadowMask = null
)
Public Sub UnwrapPhaseMap (
    wrappedPhaseMap As IInputArray,
    unwrappedPhaseMap As IOutputArray,
    Optional shadowMask As IInputArray = Nothing
)
public:
void UnwrapPhaseMap(
    IInputArray^ wrappedPhaseMap,
    IOutputArray^ unwrappedPhaseMap,
    IInputArray^ shadowMask = nullptr
)
member UnwrapPhaseMap :
        wrappedPhaseMap : IInputArray *
        unwrappedPhaseMap : IOutputArray *
        ?shadowMask : IInputArray
(* Defaults:
        let _shadowMask = defaultArg shadowMask null
*)
-> unit

Parameters

wrappedPhaseMap
Type: Emgu.CVIInputArray
The wrapped phase map that needs to be unwrapped.
unwrappedPhaseMap
Type: Emgu.CVIOutputArray
The unwrapped phase map.
shadowMask (Optional)
Type: Emgu.CVIInputArray
Optional parameter used when some pixels do not hold any phase information in the wrapped phase map.
See Also

Reference

HistogramPhaseUnwrapping Class
Emgu.CV.PhaseUnwrapping Namespace


HistogramPhaseUnwrapping Fields

The HistogramPhaseUnwrapping type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HistogramPhaseUnwrapping Class
Emgu.CV.PhaseUnwrapping Namespace


PhaseUnwrappingInvoke Class

Provide interfaces to the Open CV PhaseUnwrapping functions
Inheritance Hierarchy
SystemObject
Emgu.CV.PhaseUnwrappingPhaseUnwrappingInvoke

Namespace: Emgu.CV.PhaseUnwrapping
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class PhaseUnwrappingInvoke
Public NotInheritable Class PhaseUnwrappingInvoke
public ref class PhaseUnwrappingInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PhaseUnwrappingInvoke =  class end
See Also

Reference

Emgu.CV.PhaseUnwrapping Namespace


Emgu.CV.Plot Namespace

This Plot module allows you to easily plot data in 1D or 2D.
Classes
 | Class | Description
Public class | Plot2d | A 2D plot
Public class | PlotInvoke | Entry points for the cv::plot functions


Plot2d Class

A 2D plot
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.PlotPlot2d

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Plot2d : UnmanagedObject
Public Class Plot2d
    Inherits UnmanagedObject
public ref class Plot2d : public UnmanagedObject
type Plot2d =
    class
        inherit UnmanagedObject
    end

The Plot2d type exposes the following members.

Constructors
 | Name | Description
Public method | Plot2d(IInputArray) | Create 2D plot from data
Public method | Plot2d(IInputArray, IInputArray) | Create 2D plot for data
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged memory associated with this plot2d. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Render | Render the plot to the resulting Mat
Public method | SetMaxX | Max X
Public method | SetMaxY | Max Y
Public method | SetMinX | Min X
Public method | SetMinY | Min Y
Public method | SetPlotAxisColor | Set the axis color
Public method | SetPlotBackgroundColor | Set the background color
Public method | SetPlotGridColor | Set the plot grid color
Public method | SetPlotLineColor | Set the line color
Public method | SetPlotLineWidth | Plot line width
Public method | SetPlotSize | Set the plot size
Public method | SetPlotTextColor | Set the plot text color
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Plot Namespace


Plot2d Constructor

Overload List
 | Name | Description
Public method | Plot2d(IInputArray) | Create 2D plot from data
Public method | Plot2d(IInputArray, IInputArray) | Create 2D plot for data
Top
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d Constructor (IInputArray)

Create 2D plot from data

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Plot2d(
    IInputArray data
)
Public Sub New (
    data As IInputArray
)
public:
Plot2d(
    IInputArray^ data
)
new :
        data : IInputArray -> Plot2d

Parameters

data
Type: Emgu.CVIInputArray
The data to be plotted
See Also

Reference

Plot2d Class
Plot2d Overload
Emgu.CV.Plot Namespace


Plot2d Constructor (IInputArray, IInputArray)

Create 2D plot for data

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Plot2d(
    IInputArray dataX,
    IInputArray dataY
)
Public Sub New (
    dataX As IInputArray,
    dataY As IInputArray
)
public:
Plot2d(
    IInputArray^ dataX,
    IInputArray^ dataY
)
new :
        dataX : IInputArray *
        dataY : IInputArray -> Plot2d

Parameters

dataX
Type: Emgu.CVIInputArray
The data for the X-axis
dataY
Type: Emgu.CVIInputArray
The data for the Y-axis
See Also

Reference

Plot2d Class
Plot2d Overload
Emgu.CV.Plot Namespace


Plot2d Properties

The Plot2d type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d Methods

The Plot2d type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release unmanaged memory associated with this plot2d. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Render | Render the plot to the resulting Mat
Public method | SetMaxX | Max X
Public method | SetMaxY | Max Y
Public method | SetMinX | Min X
Public method | SetMinY | Min Y
Public method | SetPlotAxisColor | Set the axis color
Public method | SetPlotBackgroundColor | Set the background color
Public method | SetPlotGridColor | Set the plot grid color
Public method | SetPlotLineColor | Set the line color
Public method | SetPlotLineWidth | Plot line width
Public method | SetPlotSize | Set the plot size
Public method | SetPlotTextColor | Set the plot text color
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.DisposeObject Method

Plot2dDisposeObject Method

Release unmanaged memory associated with this plot2d.

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.Render Method

Plot2dRender Method

Render the plot to the resulting Mat

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Render(
    IOutputArray result
)
Public Sub Render (
    result As IOutputArray
)
public:
void Render(
    IOutputArray^ result
)
member Render :
        result : IOutputArray -> unit

Parameters

result
Type: Emgu.CVIOutputArray
The output plot
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetMaxX Method

Plot2dSetMaxX Method

Max X

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetMaxX(
    double value
)
Public Sub SetMaxX (
    value As Double
)
public:
void SetMaxX(
    double value
)
member SetMaxX :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetMaxY Method

Plot2dSetMaxY Method

Max Y

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetMaxY(
    double value
)
Public Sub SetMaxY (
    value As Double
)
public:
void SetMaxY(
    double value
)
member SetMaxY :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetMinX Method

Plot2dSetMinX Method

Min X

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetMinX(
    double value
)
Public Sub SetMinX (
    value As Double
)
public:
void SetMinX(
    double value
)
member SetMinX :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetMinY Method

Plot2dSetMinY Method

Min Y

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetMinY(
    double value
)
Public Sub SetMinY (
    value As Double
)
public:
void SetMinY(
    double value
)
member SetMinY :
        value : float -> unit

Parameters

value
Type: SystemDouble
The value
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetPlotAxisColor Method

Plot2dSetPlotAxisColor Method

Set the axis color

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlotAxisColor(
    MCvScalar plotAxisColor
)
Public Sub SetPlotAxisColor (
    plotAxisColor As MCvScalar
)
public:
void SetPlotAxisColor(
    MCvScalar^ plotAxisColor
)
member SetPlotAxisColor :
        plotAxisColor : MCvScalar -> unit

Parameters

plotAxisColor
Type: Emgu.CV.StructureMCvScalar
the axis color
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetPlotBackgroundColor Method

Plot2dSetPlotBackgroundColor Method

Set the background color

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlotBackgroundColor(
    MCvScalar plotBackgroundColor
)
Public Sub SetPlotBackgroundColor (
    plotBackgroundColor As MCvScalar
)
public:
void SetPlotBackgroundColor(
    MCvScalar^ plotBackgroundColor
)
member SetPlotBackgroundColor :
        plotBackgroundColor : MCvScalar -> unit

Parameters

plotBackgroundColor
Type: Emgu.CV.StructureMCvScalar
The background color
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetPlotGridColor Method

Plot2dSetPlotGridColor Method

Set the plot grid color

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlotGridColor(
    MCvScalar plotGridColor
)
Public Sub SetPlotGridColor (
    plotGridColor As MCvScalar
)
public:
void SetPlotGridColor(
    MCvScalar^ plotGridColor
)
member SetPlotGridColor :
        plotGridColor : MCvScalar -> unit

Parameters

plotGridColor
Type: Emgu.CV.StructureMCvScalar
The plot grid color
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetPlotLineColor Method

Plot2dSetPlotLineColor Method

Set the line color

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlotLineColor(
    MCvScalar plotLineColor
)
Public Sub SetPlotLineColor (
    plotLineColor As MCvScalar
)
public:
void SetPlotLineColor(
    MCvScalar^ plotLineColor
)
member SetPlotLineColor :
        plotLineColor : MCvScalar -> unit

Parameters

plotLineColor
Type: Emgu.CV.StructureMCvScalar
The plot line color
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetPlotLineWidth Method

Plot2dSetPlotLineWidth Method

Plot line width

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlotLineWidth(
    int value
)
Public Sub SetPlotLineWidth (
    value As Integer
)
public:
void SetPlotLineWidth(
    int value
)
member SetPlotLineWidth :
        value : int -> unit

Parameters

value
Type: SystemInt32
The value
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetPlotSize Method

Plot2dSetPlotSize Method

Set the plot size

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlotSize(
    int width,
    int height
)
Public Sub SetPlotSize (
    width As Integer,
    height As Integer
)
public:
void SetPlotSize(
    int width,
    int height
)
member SetPlotSize :
        width : int *
        height : int -> unit

Parameters

width
Type: SystemInt32
The width
height
Type: SystemInt32
The height
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d.SetPlotTextColor Method

Plot2dSetPlotTextColor Method

Set the plot text color

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlotTextColor(
    MCvScalar plotTextColor
)
Public Sub SetPlotTextColor (
    plotTextColor As MCvScalar
)
public:
void SetPlotTextColor(
    MCvScalar^ plotTextColor
)
member SetPlotTextColor :
        plotTextColor : MCvScalar -> unit

Parameters

plotTextColor
Type: Emgu.CV.StructureMCvScalar
The plot text color
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


Plot2d Fields

The Plot2d type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Plot2d Class
Emgu.CV.Plot Namespace


PlotInvoke Class

Entry points for the cv::plot functions
Inheritance Hierarchy
SystemObject
Emgu.CV.PlotPlotInvoke

Namespace: Emgu.CV.Plot
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class PlotInvoke
Public NotInheritable Class PlotInvoke
public ref class PlotInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PlotInvoke =  class end
See Also

Reference

Emgu.CV.Plot Namespace


Emgu.CV.PpfMatch3d Namespace

[Missing <summary> documentation for "N:Emgu.CV.PpfMatch3d"]

Classes
 | Class | Description
Public class | ICP | This class implements a very efficient and robust variant of the iterative closest point (ICP) algorithm. The task is to register a 3D model (or point cloud) against a set of noisy target data. The variants are put together by myself after certain tests. The task is to be able to match partial, noisy point clouds in cluttered scenes, quickly. You will find that my emphasis is on the performance, while retaining the accuracy.
Public class | ICPSamplingType | The sampling type
Public class | PpfMatch3dInvoke | Entry points to the Open CV Surface Matching module


ICP Class

This class implements a very efficient and robust variant of the iterative closest point (ICP) algorithm. The task is to register a 3D model (or point cloud) against a set of noisy target data. The variants are put together by myself after certain tests. The task is to be able to match partial, noisy point clouds in cluttered scenes, quickly. You will find that my emphasis is on the performance, while retaining the accuracy.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.PpfMatch3dICP

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ICP : UnmanagedObject
Public Class ICP
    Inherits UnmanagedObject
public ref class ICP : public UnmanagedObject
type ICP =
    class
        inherit UnmanagedObject
    end

The ICP type exposes the following members.

Constructors
 | Name | Description
Public method | ICP | Constructor to a very efficient and robust variant of the iterative closest point (ICP) algorithm.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with the ICP (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterModelToScene | Perform registration.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.PpfMatch3d Namespace


ICP Constructor

Constructor to a very efficient and robust variant of the iterative closest point (ICP) algorithm.

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ICP(
    int iterations,
    float tolerence = 0.05f,
    float rejectionScale = 2.5f,
    int numLevels = 6,
    ICPSamplingType sampleType = 0,
    int numMaxCorr = 1
)
Public Sub New (
    iterations As Integer,
    Optional tolerence As Single = 0.05F,
    Optional rejectionScale As Single = 2.5F,
    Optional numLevels As Integer = 6,
    Optional sampleType As ICPSamplingType = 0,
    Optional numMaxCorr As Integer = 1
)
public:
ICP(
    int iterations,
    float tolerence = 0.05f,
    float rejectionScale = 2.5f,
    int numLevels = 6,
    ICPSamplingType^ sampleType = 0,
    int numMaxCorr = 1
)
new :
        iterations : int *
        ?tolerence : float32 *
        ?rejectionScale : float32 *
        ?numLevels : int *
        ?sampleType : ICPSamplingType *
        ?numMaxCorr : int
(* Defaults:
        let _tolerence = defaultArg tolerence 0.05f
        let _rejectionScale = defaultArg rejectionScale 2.5f
        let _numLevels = defaultArg numLevels 6
        let _sampleType = defaultArg sampleType 0
        let _numMaxCorr = defaultArg numMaxCorr 1
*)
-> ICP

Parameters

iterations
Type: SystemInt32
number of iterations
tolerence (Optional)
Type: SystemSingle
Controls the accuracy of registration at each iteration of ICP.
rejectionScale (Optional)
Type: SystemSingle
Robust outlier rejection is applied for robustness. This value actually corresponds to the standard deviation coefficient. Points with rejectionScale * sigma are ignored during registration.
numLevels (Optional)
Type: SystemInt32
Number of pyramid levels to proceed. Deep pyramids increase speed but decrease accuracy. Too coarse pyramids might have computational overhead on top of the inaccurate registrtaion. This parameter should be chosen to optimize a balance. Typical values range from 4 to 10.
sampleType (Optional)
Type: Emgu.CV.PpfMatch3dICPSamplingType
Currently this parameter is ignored and only uniform sampling is applied.
numMaxCorr (Optional)
Type: SystemInt32
Currently this parameter is ignored and only PickyICP is applied. Leave it as 1.
See Also

Reference

ICP Class
Emgu.CV.PpfMatch3d Namespace


ICP Properties

The ICP type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ICP Class
Emgu.CV.PpfMatch3d Namespace


ICP Methods

The ICP type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with the ICP (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterModelToScene | Perform registration.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ICP Class
Emgu.CV.PpfMatch3d Namespace


ICP.DisposeObject Method

ICPDisposeObject Method

Release the unmanaged resources associated with the ICP

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ICP Class
Emgu.CV.PpfMatch3d Namespace


ICP.RegisterModelToScene Method

ICPRegisterModelToScene Method

Perform registration.

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int RegisterModelToScene(
    Mat srcPC,
    Mat dstPC,
    ref double residual,
    Mat pose
)
Public Function RegisterModelToScene (
    srcPC As Mat,
    dstPC As Mat,
    ByRef residual As Double,
    pose As Mat
) As Integer
public:
int RegisterModelToScene(
    Mat^ srcPC,
    Mat^ dstPC,
    double% residual,
    Mat^ pose
)
member RegisterModelToScene :
        srcPC : Mat *
        dstPC : Mat *
        residual : float byref *
        pose : Mat -> int

Parameters

srcPC
Type: Emgu.CVMat
The input point cloud for the model. Expected to have the normals (Nx6). Currently, CV_32F is the only supported data type.
dstPC
Type: Emgu.CVMat
The input point cloud for the scene. It is assumed that the model is registered on the scene. Scene remains static. Expected to have the normals (Nx6). Currently, CV_32F is the only supported data type.
residual
Type: SystemDouble
The output registration error.
pose
Type: Emgu.CVMat
Transformation between srcPC and dstPC.

Return Value

Type: Int32
On successful termination, the function returns 0.
See Also

Reference

ICP Class
Emgu.CV.PpfMatch3d Namespace


ICP Fields

The ICP type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ICP Class
Emgu.CV.PpfMatch3d Namespace


ICP.SamplingType Class

ICPSamplingType Class

The sampling type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.PpfMatch3dICPSamplingType

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SamplingType : Enum
Public NotInheritable Class SamplingType
    Inherits Enum
public ref class SamplingType sealed : public Enum
[<SealedAttribute>]
type SamplingType =
    class
        inherit Enum
    end

The ICPSamplingType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Gelfand | Gelfand
 | Uniform | Uniform
Public field | value__ |
Top
See Also

Reference

Emgu.CV.PpfMatch3d Namespace


SamplingType Methods

The ICPSamplingType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ICPSamplingType Class
Emgu.CV.PpfMatch3d Namespace


SamplingType Fields

The ICPSamplingType type exposes the following members.

Fields
 | Name | Description
 | Gelfand | Gelfand
 | Uniform | Uniform
Public field | value__ |
Top
See Also

Reference

ICPSamplingType Class
Emgu.CV.PpfMatch3d Namespace


ICP.SamplingType.Gelfand Field

ICPSamplingTypeGelfand Field

Gelfand

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ICPSamplingType Gelfand = 1
Public Const Gelfand As ICPSamplingType = 1
public:
literal ICPSamplingType^ Gelfand = 1
static val mutable Gelfand: ICPSamplingType

Field Value

Type: ICPSamplingType
See Also

Reference

ICPSamplingType Class
Emgu.CV.PpfMatch3d Namespace


ICP.SamplingType.Uniform Field

ICPSamplingTypeUniform Field

Uniform

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ICPSamplingType Uniform = 0
Public Const Uniform As ICPSamplingType = 0
public:
literal ICPSamplingType^ Uniform = 0
static val mutable Uniform: ICPSamplingType

Field Value

Type: ICPSamplingType
See Also

Reference

ICPSamplingType Class
Emgu.CV.PpfMatch3d Namespace


ICP.SamplingType.value__ Field

ICPSamplingTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.PpfMatch3d.ICP.SamplingType.value__"]

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ICPSamplingType Class
Emgu.CV.PpfMatch3d Namespace


PpfMatch3dInvoke Class

Entry points to the Open CV Surface Matching module
Inheritance Hierarchy
SystemObject
Emgu.CV.PpfMatch3dPpfMatch3dInvoke

Namespace: Emgu.CV.PpfMatch3d
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class PpfMatch3dInvoke
Public NotInheritable Class PpfMatch3dInvoke
public ref class PpfMatch3dInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PpfMatch3dInvoke =  class end
See Also

Reference

Emgu.CV.PpfMatch3d Namespace


Emgu.CV.Quality Namespace

[Missing <summary> documentation for "N:Emgu.CV.Quality"]

Classes
 | Class | Description
Public class | QualityBRISQUE | BRISQUE (Blind/Referenceless Image Spatial Quality Evaluator) is a No Reference Image Quality Assessment (NR-IQA) algorithm.
Public class | QualityGMSD | Implementation to Gradient Magnitude Similarity Deviation: A Highly Efficient Perceptual Image Quality Index
Public class | QualityInvoke | Class that contains entry points for the Quality module.
Public class | QualityMSE | Mean square error algorithm
Public class | QualityPSNR | Peak signal to noise ratio (PSNR) algorithm
Public class | QualitySSIM | Structural similarity algorithm
Interfaces
 | Interface | Description
Public interface | IQualityBase | Main interface for all quality filters.


IQualityBase Interface

Main interface for all quality filters.

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IQualityBase : IAlgorithm
Public Interface IQualityBase
    Inherits IAlgorithm
public interface class IQualityBase : IAlgorithm
type IQualityBase =
    interface
        interface IAlgorithm
    end

The IQualityBase type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Quality Namespace


IQualityBase Properties

The IQualityBase type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Top
See Also

Reference

IQualityBase Interface
Emgu.CV.Quality Namespace


IQualityBase.QualityBasePtr Property

IQualityBaseQualityBasePtr Property

Pointer to the native QualityBase object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr QualityBasePtr { get; }
ReadOnly Property QualityBasePtr As IntPtr
    Get
property IntPtr QualityBasePtr {
    IntPtr get ();
}
abstract QualityBasePtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IQualityBase Interface
Emgu.CV.Quality Namespace


IQualityBase Methods

The IQualityBase type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IQualityBase Interface
Emgu.CV.Quality Namespace


QualityBRISQUE Class

BRISQUE (Blind/Referenceless Image Spatial Quality Evaluator) is a No Reference Image Quality Assessment (NR-IQA) algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.QualityQualityBRISQUE

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class QualityBRISQUE : SharedPtrObject,
    IQualityBase, IAlgorithm
Public Class QualityBRISQUE
    Inherits SharedPtrObject
    Implements IQualityBase, IAlgorithm
public ref class QualityBRISQUE : public SharedPtrObject,
    IQualityBase, IAlgorithm
type QualityBRISQUE =
    class
        inherit SharedPtrObject
        interface IQualityBase
        interface IAlgorithm
    end

The QualityBRISQUE type exposes the following members.

Constructors
 | Name | Description
Public method | QualityBRISQUE | Create an object which calculates quality.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Quality Namespace


QualityBRISQUE Constructor

Create an object which calculates quality.

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QualityBRISQUE(
    string modelFilePath = "",
    string rangeFilePath = ""
)
Public Sub New (
    Optional modelFilePath As String = "",
    Optional rangeFilePath As String = ""
)
public:
QualityBRISQUE(
    String^ modelFilePath = L"",
    String^ rangeFilePath = L""
)
new :
        ?modelFilePath : string *
        ?rangeFilePath : string
(* Defaults:
        let _modelFilePath = defaultArg modelFilePath ""
        let _rangeFilePath = defaultArg rangeFilePath ""
*)
-> QualityBRISQUE

Parameters

modelFilePath (Optional)
Type: SystemString
Contains a path to the BRISQUE model data. If empty, attempts to load from ${OPENCV_DIR}/testdata/contrib/quality/brisque_model_live.yml
rangeFilePath (Optional)
Type: SystemString
contains a path to the BRISQUE range data. If empty, attempts to load from ${OPENCV_DIR}/testdata/contrib/quality/brisque_range_live.yml
See Also

Reference

QualityBRISQUE Class
Emgu.CV.Quality Namespace


QualityBRISQUE Properties

The QualityBRISQUE type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityBRISQUE Class
Emgu.CV.Quality Namespace


QualityBRISQUE.AlgorithmPtr Property

QualityBRISQUEAlgorithmPtr Property

Pointer to the native algorithm object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

QualityBRISQUE Class
Emgu.CV.Quality Namespace


QualityBRISQUE.QualityBasePtr Property

QualityBRISQUEQualityBasePtr Property

Pointer to the native QualityBase object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr QualityBasePtr { get; }
Public ReadOnly Property QualityBasePtr As IntPtr
    Get
public:
virtual property IntPtr QualityBasePtr {
    IntPtr get () sealed;
}
abstract QualityBasePtr : IntPtr with get
override QualityBasePtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IQualityBaseQualityBasePtr
See Also

Reference

QualityBRISQUE Class
Emgu.CV.Quality Namespace


QualityBRISQUE Methods

The QualityBRISQUE type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

QualityBRISQUE Class
Emgu.CV.Quality Namespace


QualityBRISQUE.DisposeObject Method

QualityBRISQUEDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

QualityBRISQUE Class
Emgu.CV.Quality Namespace


QualityBRISQUE Fields

The QualityBRISQUE type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityBRISQUE Class
Emgu.CV.Quality Namespace


QualityGMSD Class

Implementation to Gradient Magnitude Similarity Deviation: A Highly Efficient Perceptual Image Quality Index
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.QualityQualityGMSD

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class QualityGMSD : SharedPtrObject,
    IQualityBase, IAlgorithm
Public Class QualityGMSD
    Inherits SharedPtrObject
    Implements IQualityBase, IAlgorithm
public ref class QualityGMSD : public SharedPtrObject,
    IQualityBase, IAlgorithm
type QualityGMSD =
    class
        inherit SharedPtrObject
        interface IQualityBase
        interface IAlgorithm
    end

The QualityGMSD type exposes the following members.

Constructors
 | Name | Description
Public method | QualityGMSD | Create a new instance of GMSD quality measurement.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Quality Namespace


QualityGMSD Constructor

Create a new instance of GMSD quality measurement.

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QualityGMSD(
    IInputArrayOfArrays refImgs
)
Public Sub New (
    refImgs As IInputArrayOfArrays
)
public:
QualityGMSD(
    IInputArrayOfArrays^ refImgs
)
new :
        refImgs : IInputArrayOfArrays -> QualityGMSD

Parameters

refImgs
Type: Emgu.CVIInputArrayOfArrays
vector of reference images, converted to internal type
See Also

Reference

QualityGMSD Class
Emgu.CV.Quality Namespace


QualityGMSD Properties

The QualityGMSD type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityGMSD Class
Emgu.CV.Quality Namespace


QualityGMSD.AlgorithmPtr Property

QualityGMSDAlgorithmPtr Property

Pointer to the native algorithm object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

QualityGMSD Class
Emgu.CV.Quality Namespace


QualityGMSD.QualityBasePtr Property

QualityGMSDQualityBasePtr Property

Pointer to the native QualityBase object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr QualityBasePtr { get; }
Public ReadOnly Property QualityBasePtr As IntPtr
    Get
public:
virtual property IntPtr QualityBasePtr {
    IntPtr get () sealed;
}
abstract QualityBasePtr : IntPtr with get
override QualityBasePtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IQualityBaseQualityBasePtr
See Also

Reference

QualityGMSD Class
Emgu.CV.Quality Namespace


QualityGMSD Methods

The QualityGMSD type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

QualityGMSD Class
Emgu.CV.Quality Namespace


QualityGMSD.DisposeObject Method

QualityGMSDDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

QualityGMSD Class
Emgu.CV.Quality Namespace


QualityGMSD Fields

The QualityGMSD type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityGMSD Class
Emgu.CV.Quality Namespace


QualityInvoke Class

Class that contains entry points for the Quality module.
Class that contains entry points for the Quality module.
Class that contains entry points for the Quality module.
Class that contains entry points for the Quality module.
Class that contains entry points for the Quality module.
Inheritance Hierarchy
SystemObject
Emgu.CV.QualityQualityInvoke

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class QualityInvoke
<ExtensionAttribute>
Public NotInheritable Class QualityInvoke
[ExtensionAttribute]
public ref class QualityInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type QualityInvoke =  class end

The QualityInvoke type exposes the following members.

Methods
Name | Description
Compute | Compute quality score per channel with the per-channel score in each element of the result
GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm.
Top
See Also

Reference

Emgu.CV.Quality Namespace


QualityInvoke Methods

The QualityInvoke type exposes the following members.

Methods
Name | Description
Compute | Compute quality score per channel with the per-channel score in each element of the result
GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm.
Top
See Also

Reference

QualityInvoke Class
Emgu.CV.Quality Namespace


QualityInvoke.Compute Method

QualityInvokeCompute Method

Compute quality score per channel with the per-channel score in each element of the result

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvScalar Compute(
    this IQualityBase qualityBase,
    IInputArrayOfArrays cmpImgs
)
<ExtensionAttribute>
Public Shared Function Compute (
    qualityBase As IQualityBase,
    cmpImgs As IInputArrayOfArrays
) As MCvScalar
public:
[ExtensionAttribute]
static MCvScalar^ Compute(
    IQualityBase^ qualityBase,
    IInputArrayOfArrays^ cmpImgs
)
[<ExtensionAttribute>]
static member Compute :
        qualityBase : IQualityBase *
        cmpImgs : IInputArrayOfArrays -> MCvScalar

Parameters

qualityBase
Type: Emgu.CV.QualityIQualityBase
The quality base object
cmpImgs
Type: Emgu.CVIInputArrayOfArrays
Comparison image(s), or image(s) to evaluate for no-reference quality algorithms

Return Value

Type: MCvScalar
Quality score per channel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IQualityBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

QualityInvoke Class
Emgu.CV.Quality Namespace


QualityInvoke.GetQualityMap Method

QualityInvokeGetQualityMap Method

Returns output quality map images that were generated during computation, if supported by the algorithm.

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GetQualityMap(
    this IQualityBase qualityBase,
    IOutputArrayOfArrays dst
)
<ExtensionAttribute>
Public Shared Sub GetQualityMap (
    qualityBase As IQualityBase,
    dst As IOutputArrayOfArrays
)
public:
[ExtensionAttribute]
static void GetQualityMap(
    IQualityBase^ qualityBase,
    IOutputArrayOfArrays^ dst
)
[<ExtensionAttribute>]
static member GetQualityMap :
        qualityBase : IQualityBase *
        dst : IOutputArrayOfArrays -> unit

Parameters

qualityBase
Type: Emgu.CV.QualityIQualityBase
The quality base object
dst
Type: Emgu.CVIOutputArrayOfArrays
Output quality map images that were generated during computation, if supported by the algorithm.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IQualityBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

QualityInvoke Class
Emgu.CV.Quality Namespace


QualityMSE Class

Mean square error algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.QualityQualityMSE

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class QualityMSE : SharedPtrObject, IQualityBase,
    IAlgorithm
Public Class QualityMSE
    Inherits SharedPtrObject
    Implements IQualityBase, IAlgorithm
public ref class QualityMSE : public SharedPtrObject,
    IQualityBase, IAlgorithm
type QualityMSE =
    class
        inherit SharedPtrObject
        interface IQualityBase
        interface IAlgorithm
    end

The QualityMSE type exposes the following members.

Constructors
 | Name | Description
Public method | QualityMSE | Create a new instance of MSE quality measurement.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Quality Namespace


QualityMSE Constructor

Create a new instance of MSE quality measurement.

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QualityMSE(
    IInputArrayOfArrays refImgs
)
Public Sub New (
    refImgs As IInputArrayOfArrays
)
public:
QualityMSE(
    IInputArrayOfArrays^ refImgs
)
new :
        refImgs : IInputArrayOfArrays -> QualityMSE

Parameters

refImgs
Type: Emgu.CVIInputArrayOfArrays
vector of reference images, converted to internal type
See Also

Reference

QualityMSE Class
Emgu.CV.Quality Namespace


QualityMSE Properties

The QualityMSE type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityMSE Class
Emgu.CV.Quality Namespace


QualityMSE.AlgorithmPtr Property

QualityMSEAlgorithmPtr Property

Pointer to the native algorithm object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

QualityMSE Class
Emgu.CV.Quality Namespace


QualityMSE.QualityBasePtr Property

QualityMSEQualityBasePtr Property

Pointer to the native QualityBase object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr QualityBasePtr { get; }
Public ReadOnly Property QualityBasePtr As IntPtr
    Get
public:
virtual property IntPtr QualityBasePtr {
    IntPtr get () sealed;
}
abstract QualityBasePtr : IntPtr with get
override QualityBasePtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IQualityBaseQualityBasePtr
See Also

Reference

QualityMSE Class
Emgu.CV.Quality Namespace


QualityMSE Methods

The QualityMSE type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

QualityMSE Class
Emgu.CV.Quality Namespace


QualityMSE.DisposeObject Method

QualityMSEDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

QualityMSE Class
Emgu.CV.Quality Namespace


QualityMSE Fields

The QualityMSE type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityMSE Class
Emgu.CV.Quality Namespace


QualityPSNR Class

Peak signal to noise ratio (PSNR) algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.QualityQualityPSNR

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class QualityPSNR : SharedPtrObject,
    IQualityBase, IAlgorithm
Public Class QualityPSNR
    Inherits SharedPtrObject
    Implements IQualityBase, IAlgorithm
public ref class QualityPSNR : public SharedPtrObject,
    IQualityBase, IAlgorithm
type QualityPSNR =
    class
        inherit SharedPtrObject
        interface IQualityBase
        interface IAlgorithm
    end

The QualityPSNR type exposes the following members.

Constructors
 | Name | Description
Public method | QualityPSNR | Create an instance of peak signal to noise ratio (PSNR) algorithm
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Quality Namespace


QualityPSNR Constructor

Create an instance of peak signal to noise ratio (PSNR) algorithm

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QualityPSNR(
    IInputArrayOfArrays refImgs,
    double maxPixelValue = 255
)
Public Sub New (
    refImgs As IInputArrayOfArrays,
    Optional maxPixelValue As Double = 255
)
public:
QualityPSNR(
    IInputArrayOfArrays^ refImgs,
    double maxPixelValue = 255
)
new :
        refImgs : IInputArrayOfArrays *
        ?maxPixelValue : float
(* Defaults:
        let _maxPixelValue = defaultArg maxPixelValue 255
*)
-> QualityPSNR

Parameters

refImgs
Type: Emgu.CVIInputArrayOfArrays
Input image(s) to use as the source for comparison
maxPixelValue (Optional)
Type: SystemDouble
maximum per-channel value for any individual pixel; eg 255 for uint8 image
See Also

Reference

QualityPSNR Class
Emgu.CV.Quality Namespace


QualityPSNR Properties

The QualityPSNR type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityPSNR Class
Emgu.CV.Quality Namespace


QualityPSNR.AlgorithmPtr Property

QualityPSNRAlgorithmPtr Property

Pointer to the native algorithm object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

QualityPSNR Class
Emgu.CV.Quality Namespace


QualityPSNR.QualityBasePtr Property

QualityPSNRQualityBasePtr Property

Pointer to the native QualityBase object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr QualityBasePtr { get; }
Public ReadOnly Property QualityBasePtr As IntPtr
    Get
public:
virtual property IntPtr QualityBasePtr {
    IntPtr get () sealed;
}
abstract QualityBasePtr : IntPtr with get
override QualityBasePtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IQualityBaseQualityBasePtr
See Also

Reference

QualityPSNR Class
Emgu.CV.Quality Namespace


QualityPSNR Methods

The QualityPSNR type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

QualityPSNR Class
Emgu.CV.Quality Namespace


QualityPSNR.DisposeObject Method

QualityPSNRDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

QualityPSNR Class
Emgu.CV.Quality Namespace


QualityPSNR Fields

The QualityPSNR type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualityPSNR Class
Emgu.CV.Quality Namespace


QualitySSIM Class

Structural similarity algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.QualityQualitySSIM

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class QualitySSIM : SharedPtrObject,
    IQualityBase, IAlgorithm
Public Class QualitySSIM
    Inherits SharedPtrObject
    Implements IQualityBase, IAlgorithm
public ref class QualitySSIM : public SharedPtrObject,
    IQualityBase, IAlgorithm
type QualitySSIM =
    class
        inherit SharedPtrObject
        interface IQualityBase
        interface IAlgorithm
    end

The QualitySSIM type exposes the following members.

Constructors
 | Name | Description
Public method | QualitySSIM | Create an object which calculates quality via mean square error.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Quality Namespace


QualitySSIM Constructor

Create an object which calculates quality via mean square error.

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QualitySSIM(
    IInputArrayOfArrays refImgs
)
Public Sub New (
    refImgs As IInputArrayOfArrays
)
public:
QualitySSIM(
    IInputArrayOfArrays^ refImgs
)
new :
        refImgs : IInputArrayOfArrays -> QualitySSIM

Parameters

refImgs
Type: Emgu.CVIInputArrayOfArrays
input image(s) to use as the source for comparison
See Also

Reference

QualitySSIM Class
Emgu.CV.Quality Namespace


QualitySSIM Properties

The QualitySSIM type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the native algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | QualityBasePtr | Pointer to the native QualityBase object
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualitySSIM Class
Emgu.CV.Quality Namespace


QualitySSIM.AlgorithmPtr Property

QualitySSIMAlgorithmPtr Property

Pointer to the native algorithm object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

QualitySSIM Class
Emgu.CV.Quality Namespace


QualitySSIM.QualityBasePtr Property

QualitySSIMQualityBasePtr Property

Pointer to the native QualityBase object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr QualityBasePtr { get; }
Public ReadOnly Property QualityBasePtr As IntPtr
    Get
public:
virtual property IntPtr QualityBasePtr {
    IntPtr get () sealed;
}
abstract QualityBasePtr : IntPtr with get
override QualityBasePtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IQualityBaseQualityBasePtr
See Also

Reference

QualitySSIM Class
Emgu.CV.Quality Namespace


QualitySSIM Methods

The QualitySSIM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute quality score per channel with the per-channel score in each element of the result (Defined by QualityInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | GetQualityMap | Returns output quality map images that were generated during computation, if supported by the algorithm. (Defined by QualityInvoke.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

QualitySSIM Class
Emgu.CV.Quality Namespace


QualitySSIM.DisposeObject Method

QualitySSIMDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Quality
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

QualitySSIM Class
Emgu.CV.Quality Namespace


QualitySSIM Fields

The QualitySSIM type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QualitySSIM Class
Emgu.CV.Quality Namespace


Emgu.CV.Reflection Namespace

Code that use reflection to get image information from Emgu CV objects
Classes
 | Class | Description
Public class | ExposableMethodAttribute | Attribute used by ImageBox to generate Operation Menu
Public class | GenericParameter | A generic parameter for the Operation class
Public class | ReflectColorType | A collection of reflection function that can be applied to ColorType object
Public class | ReflectIImage | A collection of reflection function that can be applied to IImage object


ExposableMethodAttribute Class

Attribute used by ImageBox to generate Operation Menu
Inheritance Hierarchy
SystemObject
SystemAttribute
Emgu.CV.ReflectionExposableMethodAttribute

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ExposableMethodAttribute : Attribute
Public NotInheritable Class ExposableMethodAttribute
    Inherits Attribute
public ref class ExposableMethodAttribute sealed : public Attribute
[<SealedAttribute>]
type ExposableMethodAttribute =
    class
        inherit Attribute
    end

The ExposableMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ExposableMethodAttribute | Constructor
Top
Properties
 | Name | Description
Public property | Category | The catefory of this function
Public property | Exposable | Get or Set the exposable value, if true, this function will be displayed in Operation Menu of ImageBox
Public property | GenericParametersOptions | The options for generic parameters
Public property | GenericParametersOptionSizes | The size for each generic parameter Options
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.CV.Reflection Namespace


ExposableMethodAttribute Constructor

Constructor

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ExposableMethodAttribute()
Public Sub New
public:
ExposableMethodAttribute()
new : unit -> ExposableMethodAttribute
See Also

Reference

ExposableMethodAttribute Class
Emgu.CV.Reflection Namespace


ExposableMethodAttribute Properties

The ExposableMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Category | The catefory of this function
Public property | Exposable | Get or Set the exposable value, if true, this function will be displayed in Operation Menu of ImageBox
Public property | GenericParametersOptions | The options for generic parameters
Public property | GenericParametersOptionSizes | The size for each generic parameter Options
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ExposableMethodAttribute Class
Emgu.CV.Reflection Namespace


ExposableMethodAttribute.Category Property

ExposableMethodAttributeCategory Property

The catefory of this function

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Property Value

Type: String
See Also

Reference

ExposableMethodAttribute Class
Emgu.CV.Reflection Namespace


ExposableMethodAttribute.Exposable Property

ExposableMethodAttributeExposable Property

Get or Set the exposable value, if true, this function will be displayed in Operation Menu of ImageBox

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Exposable { get; set; }
Public Property Exposable As Boolean
    Get
    Set
public:
property bool Exposable {
    bool get ();
    void set (bool value);
}
member Exposable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ExposableMethodAttribute Class
Emgu.CV.Reflection Namespace


ExposableMethodAttribute.GenericParametersOptions Property

ExposableMethodAttributeGenericParametersOptions Property

The options for generic parameters

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Type[] GenericParametersOptions { get; set; }
Public Property GenericParametersOptions As Type()
    Get
    Set
public:
property array<Type^>^ GenericParametersOptions {
    array<Type^>^ get ();
    void set (array<Type^>^ value);
}
member GenericParametersOptions : Type[] with get, set

Property Value

Type: Type
See Also

Reference

ExposableMethodAttribute Class
Emgu.CV.Reflection Namespace


ExposableMethodAttribute.GenericParametersOptionSizes Property

ExposableMethodAttributeGenericParametersOptionSizes Property

http://www.emgu.com
The size for each generic parameter Options

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] GenericParametersOptionSizes { get; set; }
Public Property GenericParametersOptionSizes As Integer()
    Get
    Set
public:
property array<int>^ GenericParametersOptionSizes {
    array<int>^ get ();
    void set (array<int>^ value);
}
member GenericParametersOptionSizes : int[] with get, set

Property Value

Type: Int32
See Also

Reference

ExposableMethodAttribute Class
Emgu.CV.Reflection Namespace


ExposableMethodAttribute Methods

The ExposableMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExposableMethodAttribute Class
Emgu.CV.Reflection Namespace


GenericParameter Class

A generic parameter for the Operation class
Inheritance Hierarchy
SystemObject
Emgu.CV.ReflectionGenericParameter

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GenericParameter
Public Class GenericParameter
public ref class GenericParameter
type GenericParameter =  class end

The GenericParameter type exposes the following members.

Constructors
 | Name | Description
Public method | GenericParameter | Create a generic parameter for the Operation class
Top
Properties
 | Name | Description
Public property | AvailableTypes | The types that can be used
Public property | SelectedType | The selected generic parameter type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.CV.Reflection Namespace


GenericParameter Constructor

Create a generic parameter for the Operation class

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GenericParameter(
    Type selectedType,
    Type[] availableType
)
Public Sub New (
    selectedType As Type,
    availableType As Type()
)
public:
GenericParameter(
    Type^ selectedType,
    array<Type^>^ availableType
)
new :
        selectedType : Type *
        availableType : Type[] -> GenericParameter

Parameters

selectedType
Type: SystemType
The selected generic parameter typ
availableType
Type: SystemType
The types that can be used
See Also

Reference

GenericParameter Class
Emgu.CV.Reflection Namespace


GenericParameter Properties

The GenericParameter type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTypes | The types that can be used
Public property | SelectedType | The selected generic parameter type
Top
See Also

Reference

GenericParameter Class
Emgu.CV.Reflection Namespace


GenericParameter.AvailableTypes Property

GenericParameterAvailableTypes Property

The types that can be used

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Type[] AvailableTypes { get; set; }
Public Property AvailableTypes As Type()
    Get
    Set
public:
property array<Type^>^ AvailableTypes {
    array<Type^>^ get ();
    void set (array<Type^>^ value);
}
member AvailableTypes : Type[] with get, set

Property Value

Type: Type
See Also

Reference

GenericParameter Class
Emgu.CV.Reflection Namespace


GenericParameter.SelectedType Property

GenericParameterSelectedType Property

The selected generic parameter type

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Type SelectedType { get; set; }
Public Property SelectedType As Type
    Get
    Set
public:
property Type^ SelectedType {
    Type^ get ();
    void set (Type^ value);
}
member SelectedType : Type with get, set

Property Value

Type: Type
See Also

Reference

GenericParameter Class
Emgu.CV.Reflection Namespace


GenericParameter Methods

The GenericParameter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenericParameter Class
Emgu.CV.Reflection Namespace


ReflectColorType Class

A collection of reflection function that can be applied to ColorType object
Inheritance Hierarchy
SystemObject
Emgu.CV.ReflectionReflectColorType

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class ReflectColorType
Public NotInheritable Class ReflectColorType
public ref class ReflectColorType abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ReflectColorType =  class end

The ReflectColorType type exposes the following members.

Methods
Name | Description
GetDisplayColorOfChannels | Get the display color for each channel
GetNamesOfChannels | Get the names of the channels
Top
See Also

Reference

Emgu.CV.Reflection Namespace


ReflectColorType Methods

The ReflectColorType type exposes the following members.

Methods
Name | Description
GetDisplayColorOfChannels | Get the display color for each channel
GetNamesOfChannels | Get the names of the channels
Top
See Also

Reference

ReflectColorType Class
Emgu.CV.Reflection Namespace


ReflectColorType.GetDisplayColorOfChannels Method

ReflectColorTypeGetDisplayColorOfChannels Method

Get the display color for each channel

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Color[] GetDisplayColorOfChannels(
    IColor color
)
Public Shared Function GetDisplayColorOfChannels (
    color As IColor
) As Color()
public:
static array<Color^>^ GetDisplayColorOfChannels(
    IColor^ color
)
static member GetDisplayColorOfChannels :
        color : IColor -> Color[]

Parameters

color
Type: Emgu.CVIColor
The color

Return Value

Type: Color
The display color for each channel
See Also

Reference

ReflectColorType Class
Emgu.CV.Reflection Namespace


ReflectColorType.GetNamesOfChannels Method

ReflectColorTypeGetNamesOfChannels Method

Get the names of the channels

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string[] GetNamesOfChannels(
    IColor color
)
Public Shared Function GetNamesOfChannels (
    color As IColor
) As String()
public:
static array<String^>^ GetNamesOfChannels(
    IColor^ color
)
static member GetNamesOfChannels :
        color : IColor -> string[]

Parameters

color
Type: Emgu.CVIColor
The color

Return Value

Type: String
The names of the channels
See Also

Reference

ReflectColorType Class
Emgu.CV.Reflection Namespace


ReflectIImage Class

A collection of reflection function that can be applied to IImage object
Inheritance Hierarchy
SystemObject
Emgu.CV.ReflectionReflectIImage

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class ReflectIImage
Public NotInheritable Class ReflectIImage
public ref class ReflectIImage abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ReflectIImage =  class end

The ReflectIImage type exposes the following members.

Methods
Name | Description
GetImageMethods | Get all the methods that belongs to the IImage and Image class with ExposableMethodAttribute set true.
GetPixelColor | Get the color at the specific location of the image
GetTypeOfColor | Get the color type of the image
GetTypeOfDepth | Get the depth type of the image
Top
See Also

Reference

Emgu.CV.Reflection Namespace


ReflectIImage Methods

The ReflectIImage type exposes the following members.

Methods
Name | Description
GetImageMethods | Get all the methods that belongs to the IImage and Image class with ExposableMethodAttribute set true.
GetPixelColor | Get the color at the specific location of the image
GetTypeOfColor | Get the color type of the image
GetTypeOfDepth | Get the depth type of the image
Top
See Also

Reference

ReflectIImage Class
Emgu.CV.Reflection Namespace


ReflectIImage.GetImageMethods Method

ReflectIImageGetImageMethods Method

Get all the methods that belongs to the IImage and Image class with ExposableMethodAttribute set true.

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<KeyValuePair<string, MethodInfo>> GetImageMethods(
    IInputArray image
)
Public Shared Function GetImageMethods (
    image As IInputArray
) As IEnumerable(Of KeyValuePair(Of String, MethodInfo))
public:
static IEnumerable<KeyValuePair<String^, MethodInfo^>^>^ GetImageMethods(
    IInputArray^ image
)
static member GetImageMethods :
        image : IInputArray -> IEnumerable<KeyValuePair<string, MethodInfo>>

Parameters

image
Type: Emgu.CVIInputArray
The IImage object to be refelected for methods marked with ExposableMethodAttribute

Return Value

Type: IEnumerable KeyValuePair String, MethodInfo
All the methods that belongs to the IImage and Image class with ExposableMethodAttribute set true
See Also

Reference

ReflectIImage Class
Emgu.CV.Reflection Namespace


ReflectIImage.GetPixelColor Method

ReflectIImageGetPixelColor Method

Get the color at the specific location of the image

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IColor GetPixelColor(
    IInputArray image,
    Point location
)
Public Shared Function GetPixelColor (
    image As IInputArray,
    location As Point
) As IColor
public:
static IColor^ GetPixelColor(
    IInputArray^ image,
    Point^ location
)
static member GetPixelColor :
        image : IInputArray *
        location : Point -> IColor

Parameters

image
Type: Emgu.CVIInputArray
The image to obtain pixel value from
location
Type: System.DrawingPoint
The location to sample a pixel

Return Value

Type: IColor
The color at the specific location
See Also

Reference

ReflectIImage Class
Emgu.CV.Reflection Namespace


ReflectIImage.GetTypeOfColor Method

ReflectIImageGetTypeOfColor Method

Get the color type of the image

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Type GetTypeOfColor(
    IInputArray image
)
Public Shared Function GetTypeOfColor (
    image As IInputArray
) As Type
public:
static Type^ GetTypeOfColor(
    IInputArray^ image
)
static member GetTypeOfColor :
        image : IInputArray -> Type

Parameters

image
Type: Emgu.CVIInputArray
The image to apply reflection on

Return Value

Type: Type
The color type of the image
See Also

Reference

ReflectIImage Class
Emgu.CV.Reflection Namespace


ReflectIImage.GetTypeOfDepth Method

ReflectIImageGetTypeOfDepth Method

Get the depth type of the image

Namespace: Emgu.CV.Reflection
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Type GetTypeOfDepth(
    IInputArray image
)
Public Shared Function GetTypeOfDepth (
    image As IInputArray
) As Type
public:
static Type^ GetTypeOfDepth(
    IInputArray^ image
)
static member GetTypeOfDepth :
        image : IInputArray -> Type

Parameters

image
Type: Emgu.CVIInputArray
The image to apply reflection on

Return Value

Type: Type
The depth type of the image
See Also

Reference

ReflectIImage Class
Emgu.CV.Reflection Namespace


Emgu.CV.Saliency Namespace

Saliency API
Classes
 | Class | Description
Public class | MotionSaliencyBinWangApr2014 | A Fast Self-tuning Background Subtraction Algorithm.
Public class | ObjectnessBING | Objectness algorithms based on [3] [3] Cheng, Ming-Ming, et al. "BING: Binarized normed gradients for objectness estimation at 300fps." IEEE CVPR. 2014
Public class | SaliencyInvoke | Provide interfaces to the Open CV Saliency functions
Public class | StaticSaliencyFineGrained | The Fine Grained Saliency approach from Sebastian Montabone and Alvaro Soto. Human detection using a mobile platform and novel features derived from a visual saliency mechanism. In Image and Vision Computing, Vol. 28 Issue 3, pages 391–402. Elsevier, 2010.
Public class | StaticSaliencySpectralResidual | simulate the behavior of pre-attentive visual search
Interfaces
 | Interface | Description
Public interface | IMotionSaliency | Base interface for MotionSaliency algorithms
Public interface | IObjectness | Base interface for Objectness algorithms
Public interface | ISaliency | Base interface for Saliency algorithms
Public interface | IStaticSaliency | Base interface for StaticSaliency algorithms


IMotionSaliency Interface

Base interface for MotionSaliency algorithms

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IMotionSaliency : ISaliency,
    IAlgorithm
Public Interface IMotionSaliency
    Inherits ISaliency, IAlgorithm
public interface class IMotionSaliency : ISaliency,
    IAlgorithm
type IMotionSaliency =
    interface
        interface ISaliency
        interface IAlgorithm
    end

The IMotionSaliency type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | MotionSaliencyPtr | Pointer to the unmanaged MotionSaliency object
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object (Inherited from ISaliency.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Saliency Namespace


IMotionSaliency Properties

The IMotionSaliency type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | MotionSaliencyPtr | Pointer to the unmanaged MotionSaliency object
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object (Inherited from ISaliency.)
Top
See Also

Reference

IMotionSaliency Interface
Emgu.CV.Saliency Namespace


IMotionSaliency.MotionSaliencyPtr Property

IMotionSaliencyMotionSaliencyPtr Property

Pointer to the unmanaged MotionSaliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr MotionSaliencyPtr { get; }
ReadOnly Property MotionSaliencyPtr As IntPtr
    Get
property IntPtr MotionSaliencyPtr {
    IntPtr get ();
}
abstract MotionSaliencyPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IMotionSaliency Interface
Emgu.CV.Saliency Namespace


IMotionSaliency Methods

The IMotionSaliency type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IMotionSaliency Interface
Emgu.CV.Saliency Namespace


IObjectness Interface

Base interface for Objectness algorithms

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IObjectness : ISaliency,
    IAlgorithm
Public Interface IObjectness
    Inherits ISaliency, IAlgorithm
public interface class IObjectness : ISaliency,
    IAlgorithm
type IObjectness =
    interface
        interface ISaliency
        interface IAlgorithm
    end

The IObjectness type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | ObjectnessPtr | Pointer to the unmanaged Objectness object
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object (Inherited from ISaliency.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Saliency Namespace


IObjectness Properties

The IObjectness type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | ObjectnessPtr | Pointer to the unmanaged Objectness object
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object (Inherited from ISaliency.)
Top
See Also

Reference

IObjectness Interface
Emgu.CV.Saliency Namespace


IObjectness.ObjectnessPtr Property

IObjectnessObjectnessPtr Property

Pointer to the unmanaged Objectness object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr ObjectnessPtr { get; }
ReadOnly Property ObjectnessPtr As IntPtr
    Get
property IntPtr ObjectnessPtr {
    IntPtr get ();
}
abstract ObjectnessPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IObjectness Interface
Emgu.CV.Saliency Namespace


IObjectness Methods

The IObjectness type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IObjectness Interface
Emgu.CV.Saliency Namespace


ISaliency Interface

Base interface for Saliency algorithms

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface ISaliency : IAlgorithm
Public Interface ISaliency
    Inherits IAlgorithm
public interface class ISaliency : IAlgorithm
type ISaliency =
    interface
        interface IAlgorithm
    end

The ISaliency type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Saliency Namespace


ISaliency Properties

The ISaliency type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Top
See Also

Reference

ISaliency Interface
Emgu.CV.Saliency Namespace


ISaliency.SaliencyPtr Property

ISaliencySaliencyPtr Property

Pointer to the unmanaged Saliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr SaliencyPtr { get; }
ReadOnly Property SaliencyPtr As IntPtr
    Get
property IntPtr SaliencyPtr {
    IntPtr get ();
}
abstract SaliencyPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

ISaliency Interface
Emgu.CV.Saliency Namespace


ISaliency Methods

The ISaliency type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

ISaliency Interface
Emgu.CV.Saliency Namespace


IStaticSaliency Interface

Base interface for StaticSaliency algorithms

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IStaticSaliency : ISaliency,
    IAlgorithm
Public Interface IStaticSaliency
    Inherits ISaliency, IAlgorithm
public interface class IStaticSaliency : ISaliency,
    IAlgorithm
type IStaticSaliency =
    interface
        interface ISaliency
        interface IAlgorithm
    end

The IStaticSaliency type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object (Inherited from ISaliency.)
Public property | StaticSaliencyPtr | Pointer to the unmanaged StaticSaliency object
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | ComputeBinaryMap | Perform a binary map of given saliency map (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Saliency Namespace


IStaticSaliency Properties

The IStaticSaliency type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Return the pointer to the algorithm object (Inherited from IAlgorithm.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object (Inherited from ISaliency.)
Public property | StaticSaliencyPtr | Pointer to the unmanaged StaticSaliency object
Top
See Also

Reference

IStaticSaliency Interface
Emgu.CV.Saliency Namespace


IStaticSaliency.StaticSaliencyPtr Property

IStaticSaliencyStaticSaliencyPtr Property

Pointer to the unmanaged StaticSaliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr StaticSaliencyPtr { get; }
ReadOnly Property StaticSaliencyPtr As IntPtr
    Get
property IntPtr StaticSaliencyPtr {
    IntPtr get ();
}
abstract StaticSaliencyPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IStaticSaliency Interface
Emgu.CV.Saliency Namespace


IStaticSaliency Methods

The IStaticSaliency type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | ComputeBinaryMap | Perform a binary map of given saliency map (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

IStaticSaliency Interface
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014 Class

A Fast Self-tuning Background Subtraction Algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.SaliencyMotionSaliencyBinWangApr2014

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MotionSaliencyBinWangApr2014 : UnmanagedObject,
    IMotionSaliency, ISaliency, IAlgorithm
Public Class MotionSaliencyBinWangApr2014
    Inherits UnmanagedObject
    Implements IMotionSaliency, ISaliency, IAlgorithm
public ref class MotionSaliencyBinWangApr2014 : public UnmanagedObject,
    IMotionSaliency, ISaliency, IAlgorithm
type MotionSaliencyBinWangApr2014 =
    class
        inherit UnmanagedObject
        interface IMotionSaliency
        interface ISaliency
        interface IAlgorithm
    end

The MotionSaliencyBinWangApr2014 type exposes the following members.

Constructors
 | Name | Description
Public method | MotionSaliencyBinWangApr2014 | constructor
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | ImageHeight | Image height
Public property | ImageWidth | Image width
Public property | MotionSaliencyPtr | Pointer to the unmanaged MotionSaliency object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | This function allows the correct initialization of all data structures that will be used by the algorithm.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
Remarks
This background subtraction algorithm is inspired to the work of B. Wang and P. Dudek [2] [2] B. Wang and P. Dudek "A Fast Self-tuning Background Subtraction Algorithm", in proc of IEEE Workshop on Change Detection, 2014
See Also

Reference

Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014 Constructor

constructor

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MotionSaliencyBinWangApr2014()
Public Sub New
public:
MotionSaliencyBinWangApr2014()
new : unit -> MotionSaliencyBinWangApr2014
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014 Properties

The MotionSaliencyBinWangApr2014 type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | ImageHeight | Image height
Public property | ImageWidth | Image width
Public property | MotionSaliencyPtr | Pointer to the unmanaged MotionSaliency object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Top
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014.AlgorithmPtr Property

MotionSaliencyBinWangApr2014AlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014.ImageHeight Property

MotionSaliencyBinWangApr2014ImageHeight Property

Image height

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ImageHeight { get; set; }
Public Property ImageHeight As Integer
    Get
    Set
public:
property int ImageHeight {
    int get ();
    void set (int value);
}
member ImageHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014.ImageWidth Property

MotionSaliencyBinWangApr2014ImageWidth Property

Image width

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ImageWidth { get; set; }
Public Property ImageWidth As Integer
    Get
    Set
public:
property int ImageWidth {
    int get ();
    void set (int value);
}
member ImageWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014.MotionSaliencyPtr Property

MotionSaliencyBinWangApr2014MotionSaliencyPtr Property

Pointer to the unmanaged MotionSaliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr MotionSaliencyPtr { get; }
Public ReadOnly Property MotionSaliencyPtr As IntPtr
    Get
public:
virtual property IntPtr MotionSaliencyPtr {
    IntPtr get () sealed;
}
abstract MotionSaliencyPtr : IntPtr with get
override MotionSaliencyPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IMotionSaliencyMotionSaliencyPtr
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014.SaliencyPtr Property

MotionSaliencyBinWangApr2014SaliencyPtr Property

Pointer to the unmanaged Saliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SaliencyPtr { get; }
Public ReadOnly Property SaliencyPtr As IntPtr
    Get
public:
virtual property IntPtr SaliencyPtr {
    IntPtr get () sealed;
}
abstract SaliencyPtr : IntPtr with get
override SaliencyPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ISaliencySaliencyPtr
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014 Methods

The MotionSaliencyBinWangApr2014 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | This function allows the correct initialization of all data structures that will be used by the algorithm.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014.DisposeObject Method

MotionSaliencyBinWangApr2014DisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014.Init Method

MotionSaliencyBinWangApr2014Init Method

This function allows the correct initialization of all data structures that will be used by the algorithm.

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Init()
Public Function Init As Boolean
public:
bool Init()
member Init : unit -> bool

Return Value

Type: Boolean
The result
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


MotionSaliencyBinWangApr2014 Fields

The MotionSaliencyBinWangApr2014 type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MotionSaliencyBinWangApr2014 Class
Emgu.CV.Saliency Namespace


ObjectnessBING Class

Objectness algorithms based on [3] [3] Cheng, Ming-Ming, et al. "BING: Binarized normed gradients for objectness estimation at 300fps." IEEE CVPR. 2014
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.SaliencyObjectnessBING

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ObjectnessBING : UnmanagedObject,
    IObjectness, ISaliency, IAlgorithm
Public Class ObjectnessBING
    Inherits UnmanagedObject
    Implements IObjectness, ISaliency, IAlgorithm
public ref class ObjectnessBING : public UnmanagedObject,
    IObjectness, ISaliency, IAlgorithm
type ObjectnessBING =
    class
        inherit UnmanagedObject
        interface IObjectness
        interface ISaliency
        interface IAlgorithm
    end

The ObjectnessBING type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectnessBING | constructor
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | NSS | NSS
Public property | ObjectnessPtr | Pointer to the unmanaged Objectness object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Public property | W | W
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectnessValues | Return the list of the rectangles' objectness value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetTrainingPath | set the correct path from which the algorithm will load the trained model.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Saliency Namespace


ObjectnessBING Constructor

constructor

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ObjectnessBING()
Public Sub New
public:
ObjectnessBING()
new : unit -> ObjectnessBING
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING Properties

The ObjectnessBING type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | NSS | NSS
Public property | ObjectnessPtr | Pointer to the unmanaged Objectness object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Public property | W | W
Top
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.AlgorithmPtr Property

ObjectnessBINGAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.NSS Property

ObjectnessBINGNSS Property

NSS

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NSS { get; set; }
Public Property NSS As Integer
    Get
    Set
public:
property int NSS {
    int get ();
    void set (int value);
}
member NSS : int with get, set

Property Value

Type: Int32
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.ObjectnessPtr Property

ObjectnessBINGObjectnessPtr Property

Pointer to the unmanaged Objectness object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ObjectnessPtr { get; }
Public ReadOnly Property ObjectnessPtr As IntPtr
    Get
public:
virtual property IntPtr ObjectnessPtr {
    IntPtr get () sealed;
}
abstract ObjectnessPtr : IntPtr with get
override ObjectnessPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IObjectnessObjectnessPtr
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.SaliencyPtr Property

ObjectnessBINGSaliencyPtr Property

Pointer to the unmanaged Saliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SaliencyPtr { get; }
Public ReadOnly Property SaliencyPtr As IntPtr
    Get
public:
virtual property IntPtr SaliencyPtr {
    IntPtr get () sealed;
}
abstract SaliencyPtr : IntPtr with get
override SaliencyPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ISaliencySaliencyPtr
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.W Property

ObjectnessBINGW Property

W

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int W { get; set; }
Public Property W As Integer
    Get
    Set
public:
property int W {
    int get ();
    void set (int value);
}
member W : int with get, set

Property Value

Type: Int32
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING Methods

The ObjectnessBING type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectnessValues | Return the list of the rectangles' objectness value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetTrainingPath | set the correct path from which the algorithm will load the trained model.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.DisposeObject Method

ObjectnessBINGDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.GetObjectnessValues Method

ObjectnessBINGGetObjectnessValues Method

Return the list of the rectangles' objectness value.

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float[] GetObjectnessValues()
Public Function GetObjectnessValues As Single()
public:
array<float>^ GetObjectnessValues()
member GetObjectnessValues : unit -> float32[]

Return Value

Type: Single
The list of the rectangles' objectness value.
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING.SetTrainingPath Method

ObjectnessBINGSetTrainingPath Method

set the correct path from which the algorithm will load the trained model.

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTrainingPath(
    string trainingPath
)
Public Sub SetTrainingPath (
    trainingPath As String
)
public:
void SetTrainingPath(
    String^ trainingPath
)
member SetTrainingPath :
        trainingPath : string -> unit

Parameters

trainingPath
Type: SystemString
The training path
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


ObjectnessBING Fields

The ObjectnessBING type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ObjectnessBING Class
Emgu.CV.Saliency Namespace


SaliencyInvoke Class

Provide interfaces to the Open CV Saliency functions
Inheritance Hierarchy
SystemObject
Emgu.CV.SaliencySaliencyInvoke

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class SaliencyInvoke
<ExtensionAttribute>
Public NotInheritable Class SaliencyInvoke
[ExtensionAttribute]
public ref class SaliencyInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type SaliencyInvoke =  class end

The SaliencyInvoke type exposes the following members.

Methods
Name | Description
Compute | Compute the saliency.
ComputeBinaryMap | Perform a binary map of given saliency map
Top
See Also

Reference

Emgu.CV.Saliency Namespace


SaliencyInvoke Methods

The SaliencyInvoke type exposes the following members.

Methods
Name | Description
Compute | Compute the saliency.
ComputeBinaryMap | Perform a binary map of given saliency map
Top
See Also

Reference

SaliencyInvoke Class
Emgu.CV.Saliency Namespace


SaliencyInvoke.Compute Method

SaliencyInvokeCompute Method

Compute the saliency.

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool Compute(
    this ISaliency saliency,
    IInputArray image,
    IOutputArray saliencyMap
)
<ExtensionAttribute>
Public Shared Function Compute (
    saliency As ISaliency,
    image As IInputArray,
    saliencyMap As IOutputArray
) As Boolean
public:
[ExtensionAttribute]
static bool Compute(
    ISaliency^ saliency,
    IInputArray^ image,
    IOutputArray^ saliencyMap
)
[<ExtensionAttribute>]
static member Compute :
        saliency : ISaliency *
        image : IInputArray *
        saliencyMap : IOutputArray -> bool

Parameters

saliency
Type: Emgu.CV.SaliencyISaliency
The Saliency object
image
Type: Emgu.CVIInputArray
The image.
saliencyMap
Type: Emgu.CVIOutputArray
The computed saliency map.

Return Value

Type: Boolean
true if the saliency map is computed, false otherwise

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISaliency. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SaliencyInvoke Class
Emgu.CV.Saliency Namespace


SaliencyInvoke.ComputeBinaryMap Method

SaliencyInvokeComputeBinaryMap Method

Perform a binary map of given saliency map

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool ComputeBinaryMap(
    this IStaticSaliency saliency,
    IInputArray saliencyMap,
    IOutputArray binaryMap
)
<ExtensionAttribute>
Public Shared Function ComputeBinaryMap (
    saliency As IStaticSaliency,
    saliencyMap As IInputArray,
    binaryMap As IOutputArray
) As Boolean
public:
[ExtensionAttribute]
static bool ComputeBinaryMap(
    IStaticSaliency^ saliency,
    IInputArray^ saliencyMap,
    IOutputArray^ binaryMap
)
[<ExtensionAttribute>]
static member ComputeBinaryMap :
        saliency : IStaticSaliency *
        saliencyMap : IInputArray *
        binaryMap : IOutputArray -> bool

Parameters

saliency
Type: Emgu.CV.SaliencyIStaticSaliency
The StatucSaliency object
saliencyMap
Type: Emgu.CVIInputArray
the saliency map obtained through one of the specialized algorithms
binaryMap
Type: Emgu.CVIOutputArray
the binary map

Return Value

Type: Boolean
True if the binary map is sucessfully computed

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IStaticSaliency. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SaliencyInvoke Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained Class

The Fine Grained Saliency approach from Sebastian Montabone and Alvaro Soto. Human detection using a mobile platform and novel features derived from a visual saliency mechanism. In Image and Vision Computing, Vol. 28 Issue 3, pages 391–402. Elsevier, 2010.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.SaliencyStaticSaliencyFineGrained

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class StaticSaliencyFineGrained : UnmanagedObject,
    IStaticSaliency, ISaliency, IAlgorithm
Public Class StaticSaliencyFineGrained
    Inherits UnmanagedObject
    Implements IStaticSaliency, ISaliency, IAlgorithm
public ref class StaticSaliencyFineGrained : public UnmanagedObject,
    IStaticSaliency, ISaliency, IAlgorithm
type StaticSaliencyFineGrained =
    class
        inherit UnmanagedObject
        interface IStaticSaliency
        interface ISaliency
        interface IAlgorithm
    end

The StaticSaliencyFineGrained type exposes the following members.

Constructors
 | Name | Description
Public method | StaticSaliencyFineGrained | constructor
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Public property | StaticSaliencyPtr | Pointer to the unmanaged StaticSaliency object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | ComputeBinaryMap | Perform a binary map of given saliency map (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
Remarks
This method calculates saliency based on center-surround differences. High resolution saliency maps are generated in real time by using integral images.
See Also

Reference

Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained Constructor

constructor

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StaticSaliencyFineGrained()
Public Sub New
public:
StaticSaliencyFineGrained()
new : unit -> StaticSaliencyFineGrained
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained Properties

The StaticSaliencyFineGrained type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Public property | StaticSaliencyPtr | Pointer to the unmanaged StaticSaliency object
Top
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained.AlgorithmPtr Property

StaticSaliencyFineGrainedAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained.SaliencyPtr Property

StaticSaliencyFineGrainedSaliencyPtr Property

Pointer to the unmanaged Saliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SaliencyPtr { get; }
Public ReadOnly Property SaliencyPtr As IntPtr
    Get
public:
virtual property IntPtr SaliencyPtr {
    IntPtr get () sealed;
}
abstract SaliencyPtr : IntPtr with get
override SaliencyPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ISaliencySaliencyPtr
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained.StaticSaliencyPtr Property

StaticSaliencyFineGrainedStaticSaliencyPtr Property

Pointer to the unmanaged StaticSaliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StaticSaliencyPtr { get; }
Public ReadOnly Property StaticSaliencyPtr As IntPtr
    Get
public:
virtual property IntPtr StaticSaliencyPtr {
    IntPtr get () sealed;
}
abstract StaticSaliencyPtr : IntPtr with get
override StaticSaliencyPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IStaticSaliencyStaticSaliencyPtr
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained Methods

The StaticSaliencyFineGrained type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | ComputeBinaryMap | Perform a binary map of given saliency map (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained.DisposeObject Method

StaticSaliencyFineGrainedDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencyFineGrained Fields

The StaticSaliencyFineGrained type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

StaticSaliencyFineGrained Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual Class

simulate the behavior of pre-attentive visual search
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.SaliencyStaticSaliencySpectralResidual

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class StaticSaliencySpectralResidual : UnmanagedObject,
    IStaticSaliency, ISaliency, IAlgorithm
Public Class StaticSaliencySpectralResidual
    Inherits UnmanagedObject
    Implements IStaticSaliency, ISaliency, IAlgorithm
public ref class StaticSaliencySpectralResidual : public UnmanagedObject,
    IStaticSaliency, ISaliency, IAlgorithm
type StaticSaliencySpectralResidual =
    class
        inherit UnmanagedObject
        interface IStaticSaliency
        interface ISaliency
        interface IAlgorithm
    end

The StaticSaliencySpectralResidual type exposes the following members.

Constructors
 | Name | Description
Public method | StaticSaliencySpectralResidual | constructor
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Public property | StaticSaliencyPtr | Pointer to the unmanaged StaticSaliency object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | ComputeBinaryMap | Perform a binary map of given saliency map (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual Constructor

constructor

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StaticSaliencySpectralResidual()
Public Sub New
public:
StaticSaliencySpectralResidual()
new : unit -> StaticSaliencySpectralResidual
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual Properties

The StaticSaliencySpectralResidual type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to the unmanaged Algorithm object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaliencyPtr | Pointer to the unmanaged Saliency object
Public property | StaticSaliencyPtr | Pointer to the unmanaged StaticSaliency object
Top
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual.AlgorithmPtr Property

StaticSaliencySpectralResidualAlgorithmPtr Property

Pointer to the unmanaged Algorithm object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual.SaliencyPtr Property

StaticSaliencySpectralResidualSaliencyPtr Property

Pointer to the unmanaged Saliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SaliencyPtr { get; }
Public ReadOnly Property SaliencyPtr As IntPtr
    Get
public:
virtual property IntPtr SaliencyPtr {
    IntPtr get () sealed;
}
abstract SaliencyPtr : IntPtr with get
override SaliencyPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

ISaliencySaliencyPtr
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual.StaticSaliencyPtr Property

StaticSaliencySpectralResidualStaticSaliencyPtr Property

Pointer to the unmanaged StaticSaliency object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StaticSaliencyPtr { get; }
Public ReadOnly Property StaticSaliencyPtr As IntPtr
    Get
public:
virtual property IntPtr StaticSaliencyPtr {
    IntPtr get () sealed;
}
abstract StaticSaliencyPtr : IntPtr with get
override StaticSaliencyPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IStaticSaliencyStaticSaliencyPtr
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual Methods

The StaticSaliencySpectralResidual type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Compute | Compute the saliency. (Defined by SaliencyInvoke.)
Public Extension Method | ComputeBinaryMap | Perform a binary map of given saliency map (Defined by SaliencyInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual.DisposeObject Method

StaticSaliencySpectralResidualDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Saliency
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


StaticSaliencySpectralResidual Fields

The StaticSaliencySpectralResidual type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

StaticSaliencySpectralResidual Class
Emgu.CV.Saliency Namespace


Emgu.CV.Shape Namespace

The module contains algorithms that embed a notion of shape distance. These algorithms may be used for shape matching and retrieval, or shape comparison.
Classes
 | Class | Description
Public class | AffineTransformer | Wrapper class for the OpenCV Affine Transformation algorithm.
Public class | ChiHistogramCostExtractor | An Chi based cost extraction.
Public class | EMDHistogramCostExtractor | An EMD based cost extraction.
Public class | EMDL1HistogramCostExtractor | An EMD-L1 based cost extraction.
Public class | HausdorffDistanceExtractor | A simple Hausdorff distance measure between shapes defined by contours, according to the paper “Comparing Images using the Hausdorff distance.” by D.P. Huttenlocher, G.A. Klanderman, and W.J. Rucklidge. (PAMI 1993).
Public class | HistogramCostExtractor | Abstract base class for histogram cost algorithms.
Public class | NormHistogramCostExtractor | A norm based cost extraction.
Public class | ShapeContextDistanceExtractor | Implementation of the Shape Context descriptor and matching algorithm proposed by Belongie et al. in “Shape Matching and Object Recognition Using Shape Contexts” (PAMI 2002).
Public class | ShapeDistanceExtractor | Abstract base class for shape distance algorithms.
Public class | ShapeInvoke | Library to invoke functions that belongs to the shape module
Public class | ThinPlateSplineShapeTransformer | Definition of the transformation ocupied in the paper “Principal Warps: Thin-Plate Splines and Decomposition of Deformations”, by F.L. Bookstein (PAMI 1989).
Interfaces
 | Interface | Description
Public interface | IShapeTransformer | Abstract base class for shape transformation algorithms.


AffineTransformer Class

Wrapper class for the OpenCV Affine Transformation algorithm.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeAffineTransformer

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class AffineTransformer : UnmanagedObject,
    IShapeTransformer
Public Class AffineTransformer
    Inherits UnmanagedObject
    Implements IShapeTransformer
public ref class AffineTransformer : public UnmanagedObject,
    IShapeTransformer
type AffineTransformer =
    class
        inherit UnmanagedObject
        interface IShapeTransformer
    end

The AffineTransformer type exposes the following members.

Constructors
 | Name | Description
Public method | AffineTransformer | Create an affine transformer
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShapeTransformerPtr | Get the pointer to the native ShapeTransformer
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this ShapeTransformer object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


AffineTransformer Constructor

Create an affine transformer

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public AffineTransformer(
    bool fullAffine
)
Public Sub New (
    fullAffine As Boolean
)
public:
AffineTransformer(
    bool fullAffine
)
new :
        fullAffine : bool -> AffineTransformer

Parameters

fullAffine
Type: SystemBoolean
Full affine
See Also

Reference

AffineTransformer Class
Emgu.CV.Shape Namespace


AffineTransformer Properties

The AffineTransformer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShapeTransformerPtr | Get the pointer to the native ShapeTransformer
Top
See Also

Reference

AffineTransformer Class
Emgu.CV.Shape Namespace


AffineTransformer.ShapeTransformerPtr Property

AffineTransformerShapeTransformerPtr Property

Get the pointer to the native ShapeTransformer

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ShapeTransformerPtr { get; }
Public ReadOnly Property ShapeTransformerPtr As IntPtr
    Get
public:
virtual property IntPtr ShapeTransformerPtr {
    IntPtr get () sealed;
}
abstract ShapeTransformerPtr : IntPtr with get
override ShapeTransformerPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IShapeTransformerShapeTransformerPtr
See Also

Reference

AffineTransformer Class
Emgu.CV.Shape Namespace


AffineTransformer Methods

The AffineTransformer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this ShapeTransformer object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AffineTransformer Class
Emgu.CV.Shape Namespace


AffineTransformer.DisposeObject Method

AffineTransformerDisposeObject Method

Release the unmanaged memory associated with this ShapeTransformer object

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

AffineTransformer Class
Emgu.CV.Shape Namespace


AffineTransformer Fields

The AffineTransformer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

AffineTransformer Class
Emgu.CV.Shape Namespace


ChiHistogramCostExtractor Class

An Chi based cost extraction.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeHistogramCostExtractor
Emgu.CV.ShapeChiHistogramCostExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ChiHistogramCostExtractor : HistogramCostExtractor
Public Class ChiHistogramCostExtractor
    Inherits HistogramCostExtractor
public ref class ChiHistogramCostExtractor : public HistogramCostExtractor
type ChiHistogramCostExtractor =
    class
        inherit HistogramCostExtractor
    end

The ChiHistogramCostExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | ChiHistogramCostExtractor | Create an Chi based cost extraction.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


ChiHistogramCostExtractor Constructor

Create an Chi based cost extraction.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ChiHistogramCostExtractor(
    int nDummies = 25,
    float defaultCost = 0.2f
)
Public Sub New (
    Optional nDummies As Integer = 25,
    Optional defaultCost As Single = 0.2F
)
public:
ChiHistogramCostExtractor(
    int nDummies = 25,
    float defaultCost = 0.2f
)
new :
        ?nDummies : int *
        ?defaultCost : float32
(* Defaults:
        let _nDummies = defaultArg nDummies 25
        let _defaultCost = defaultArg defaultCost 0.2f
*)
-> ChiHistogramCostExtractor

Parameters

nDummies (Optional)
Type: SystemInt32
Number of dummies
defaultCost (Optional)
Type: SystemSingle
Default cost
See Also

Reference

ChiHistogramCostExtractor Class
Emgu.CV.Shape Namespace


ChiHistogramCostExtractor Properties

The ChiHistogramCostExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ChiHistogramCostExtractor Class
Emgu.CV.Shape Namespace


ChiHistogramCostExtractor Methods

The ChiHistogramCostExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChiHistogramCostExtractor Class
Emgu.CV.Shape Namespace


ChiHistogramCostExtractor Fields

The ChiHistogramCostExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

ChiHistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDHistogramCostExtractor Class

An EMD based cost extraction.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeHistogramCostExtractor
Emgu.CV.ShapeEMDHistogramCostExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class EMDHistogramCostExtractor : HistogramCostExtractor
Public Class EMDHistogramCostExtractor
    Inherits HistogramCostExtractor
public ref class EMDHistogramCostExtractor : public HistogramCostExtractor
type EMDHistogramCostExtractor =
    class
        inherit HistogramCostExtractor
    end

The EMDHistogramCostExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | EMDHistogramCostExtractor | Create an EMD based cost extraction.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


EMDHistogramCostExtractor Constructor

Create an EMD based cost extraction.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EMDHistogramCostExtractor(
    DistType flag = 2,
    int nDummies = 25,
    float defaultCost = 0.2f
)
Public Sub New (
    Optional flag As DistType = 2,
    Optional nDummies As Integer = 25,
    Optional defaultCost As Single = 0.2F
)
public:
EMDHistogramCostExtractor(
    DistType^ flag = 2,
    int nDummies = 25,
    float defaultCost = 0.2f
)
new :
        ?flag : DistType *
        ?nDummies : int *
        ?defaultCost : float32
(* Defaults:
        let _flag = defaultArg flag 2
        let _nDummies = defaultArg nDummies 25
        let _defaultCost = defaultArg defaultCost 0.2f
*)
-> EMDHistogramCostExtractor

Parameters

flag (Optional)
Type: Emgu.CV.CvEnumDistType
Distance type
nDummies (Optional)
Type: SystemInt32
Number of dummies
defaultCost (Optional)
Type: SystemSingle
Default cost
See Also

Reference

EMDHistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDHistogramCostExtractor Properties

The EMDHistogramCostExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

EMDHistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDHistogramCostExtractor Methods

The EMDHistogramCostExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EMDHistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDHistogramCostExtractor Fields

The EMDHistogramCostExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

EMDHistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDL1HistogramCostExtractor Class

An EMD-L1 based cost extraction.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeHistogramCostExtractor
Emgu.CV.ShapeEMDL1HistogramCostExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class EMDL1HistogramCostExtractor : HistogramCostExtractor
Public Class EMDL1HistogramCostExtractor
    Inherits HistogramCostExtractor
public ref class EMDL1HistogramCostExtractor : public HistogramCostExtractor
type EMDL1HistogramCostExtractor =
    class
        inherit HistogramCostExtractor
    end

The EMDL1HistogramCostExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | EMDL1HistogramCostExtractor | Create an EMD-L1 based cost extraction.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


EMDL1HistogramCostExtractor Constructor

Create an EMD-L1 based cost extraction.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EMDL1HistogramCostExtractor(
    int nDummies = 25,
    float defaultCost = 0.2f
)
Public Sub New (
    Optional nDummies As Integer = 25,
    Optional defaultCost As Single = 0.2F
)
public:
EMDL1HistogramCostExtractor(
    int nDummies = 25,
    float defaultCost = 0.2f
)
new :
        ?nDummies : int *
        ?defaultCost : float32
(* Defaults:
        let _nDummies = defaultArg nDummies 25
        let _defaultCost = defaultArg defaultCost 0.2f
*)
-> EMDL1HistogramCostExtractor

Parameters

nDummies (Optional)
Type: SystemInt32
Number of dummies
defaultCost (Optional)
Type: SystemSingle
Default cost
See Also

Reference

EMDL1HistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDL1HistogramCostExtractor Properties

The EMDL1HistogramCostExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

EMDL1HistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDL1HistogramCostExtractor Methods

The EMDL1HistogramCostExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EMDL1HistogramCostExtractor Class
Emgu.CV.Shape Namespace


EMDL1HistogramCostExtractor Fields

The EMDL1HistogramCostExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

EMDL1HistogramCostExtractor Class
Emgu.CV.Shape Namespace


HausdorffDistanceExtractor Class

A simple Hausdorff distance measure between shapes defined by contours, according to the paper “Comparing Images using the Hausdorff distance.” by D.P. Huttenlocher, G.A. Klanderman, and W.J. Rucklidge. (PAMI 1993).
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeShapeDistanceExtractor
Emgu.CV.ShapeHausdorffDistanceExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class HausdorffDistanceExtractor : ShapeDistanceExtractor
Public Class HausdorffDistanceExtractor
    Inherits ShapeDistanceExtractor
public ref class HausdorffDistanceExtractor : public ShapeDistanceExtractor
type HausdorffDistanceExtractor =
    class
        inherit ShapeDistanceExtractor
    end

The HausdorffDistanceExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | HausdorffDistanceExtractor | Create Hausdorff distance extractor
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | ComputeDistance(Point, Point) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | ComputeDistance(IInputArray, IInputArray) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this Hausdorff distance extrator (Overrides ShapeDistanceExtractorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _shapeDistanceExtractorPtr | Pointer to the unmanaged ShapeDistanceExtractor (Inherited from ShapeDistanceExtractor.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


HausdorffDistanceExtractor Constructor

Create Hausdorff distance extractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public HausdorffDistanceExtractor(
    DistType distanceFlag = 2,
    float rankProp = 0.6f
)
Public Sub New (
    Optional distanceFlag As DistType = 2,
    Optional rankProp As Single = 0.6F
)
public:
HausdorffDistanceExtractor(
    DistType^ distanceFlag = 2,
    float rankProp = 0.6f
)
new :
        ?distanceFlag : DistType *
        ?rankProp : float32
(* Defaults:
        let _distanceFlag = defaultArg distanceFlag 2
        let _rankProp = defaultArg rankProp 0.6f
*)
-> HausdorffDistanceExtractor

Parameters

distanceFlag (Optional)
Type: Emgu.CV.CvEnumDistType
Rhe norm used to compute the Hausdorff value between two shapes. It can be L1 or L2 norm.
rankProp (Optional)
Type: SystemSingle
The rank proportion (or fractional value) that establish the Kth ranked value of the partial Hausdorff distance. Experimentally had been shown that 0.6 is a good value to compare shapes.
See Also

Reference

HausdorffDistanceExtractor Class
Emgu.CV.Shape Namespace


HausdorffDistanceExtractor Properties

The HausdorffDistanceExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HausdorffDistanceExtractor Class
Emgu.CV.Shape Namespace


HausdorffDistanceExtractor Methods

The HausdorffDistanceExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDistance(Point, Point) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | ComputeDistance(IInputArray, IInputArray) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this Hausdorff distance extrator (Overrides ShapeDistanceExtractorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HausdorffDistanceExtractor Class
Emgu.CV.Shape Namespace


HausdorffDistanceExtractor.DisposeObject Method

HausdorffDistanceExtractorDisposeObject Method

Release the memory associated with this Hausdorff distance extrator

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

HausdorffDistanceExtractor Class
Emgu.CV.Shape Namespace


HausdorffDistanceExtractor Fields

The HausdorffDistanceExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _shapeDistanceExtractorPtr | Pointer to the unmanaged ShapeDistanceExtractor (Inherited from ShapeDistanceExtractor.)
Top
See Also

Reference

HausdorffDistanceExtractor Class
Emgu.CV.Shape Namespace


HistogramCostExtractor Class

Abstract base class for histogram cost algorithms.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeHistogramCostExtractor
Emgu.CV.ShapeChiHistogramCostExtractor
Emgu.CV.ShapeEMDHistogramCostExtractor
Emgu.CV.ShapeEMDL1HistogramCostExtractor
Emgu.CV.ShapeNormHistogramCostExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class HistogramCostExtractor : UnmanagedObject
Public MustInherit Class HistogramCostExtractor
    Inherits UnmanagedObject
public ref class HistogramCostExtractor abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type HistogramCostExtractor =
    class
        inherit UnmanagedObject
    end

The HistogramCostExtractor type exposes the following members.

Constructors
 | Name | Description
Protected method | HistogramCostExtractor | Initializes a new instance of the HistogramCostExtractor class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object.
Top
See Also

Reference

Emgu.CV.Shape Namespace


HistogramCostExtractor Constructor

Initializes a new instance of the HistogramCostExtractor class

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected HistogramCostExtractor()
Protected Sub New
protected:
HistogramCostExtractor()
new : unit -> HistogramCostExtractor
See Also

Reference

HistogramCostExtractor Class
Emgu.CV.Shape Namespace


HistogramCostExtractor Properties

The HistogramCostExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

HistogramCostExtractor Class
Emgu.CV.Shape Namespace


HistogramCostExtractor Methods

The HistogramCostExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HistogramCostExtractor Class
Emgu.CV.Shape Namespace


HistogramCostExtractor.DisposeObject Method

HistogramCostExtractorDisposeObject Method

Release the histogram cost extractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

HistogramCostExtractor Class
Emgu.CV.Shape Namespace


HistogramCostExtractor Fields

The HistogramCostExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object.
Top
See Also

Reference

HistogramCostExtractor Class
Emgu.CV.Shape Namespace


HistogramCostExtractor._sharedPtr Field

HistogramCostExtractor_sharedPtr Field

Pointer native cv::Ptr object.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _sharedPtr
Protected _sharedPtr As IntPtr
protected:
IntPtr _sharedPtr
val mutable _sharedPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

HistogramCostExtractor Class
Emgu.CV.Shape Namespace


IShapeTransformer Interface

Abstract base class for shape transformation algorithms.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IShapeTransformer
Public Interface IShapeTransformer
public interface class IShapeTransformer
type IShapeTransformer =  interface end

The IShapeTransformer type exposes the following members.

Properties
 | Name | Description
Public property | ShapeTransformerPtr | Get the pointer to the unmanaged shape transformer
Top
See Also

Reference

Emgu.CV.Shape Namespace


IShapeTransformer Properties

The IShapeTransformer type exposes the following members.

Properties
 | Name | Description
Public property | ShapeTransformerPtr | Get the pointer to the unmanaged shape transformer
Top
See Also

Reference

IShapeTransformer Interface
Emgu.CV.Shape Namespace


IShapeTransformer.ShapeTransformerPtr Property

IShapeTransformerShapeTransformerPtr Property

Get the pointer to the unmanaged shape transformer

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr ShapeTransformerPtr { get; }
ReadOnly Property ShapeTransformerPtr As IntPtr
    Get
property IntPtr ShapeTransformerPtr {
    IntPtr get ();
}
abstract ShapeTransformerPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IShapeTransformer Interface
Emgu.CV.Shape Namespace


NormHistogramCostExtractor Class

A norm based cost extraction.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeHistogramCostExtractor
Emgu.CV.ShapeNormHistogramCostExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class NormHistogramCostExtractor : HistogramCostExtractor
Public Class NormHistogramCostExtractor
    Inherits HistogramCostExtractor
public ref class NormHistogramCostExtractor : public HistogramCostExtractor
type NormHistogramCostExtractor =
    class
        inherit HistogramCostExtractor
    end

The NormHistogramCostExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | NormHistogramCostExtractor | Create a norm based cost extraction.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


NormHistogramCostExtractor Constructor

Create a norm based cost extraction.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public NormHistogramCostExtractor(
    DistType flag = 2,
    int nDummies = 25,
    float defaultCost = 0.2f
)
Public Sub New (
    Optional flag As DistType = 2,
    Optional nDummies As Integer = 25,
    Optional defaultCost As Single = 0.2F
)
public:
NormHistogramCostExtractor(
    DistType^ flag = 2,
    int nDummies = 25,
    float defaultCost = 0.2f
)
new :
        ?flag : DistType *
        ?nDummies : int *
        ?defaultCost : float32
(* Defaults:
        let _flag = defaultArg flag 2
        let _nDummies = defaultArg nDummies 25
        let _defaultCost = defaultArg defaultCost 0.2f
*)
-> NormHistogramCostExtractor

Parameters

flag (Optional)
Type: Emgu.CV.CvEnumDistType
Distance type
nDummies (Optional)
Type: SystemInt32
Number of dummies
defaultCost (Optional)
Type: SystemSingle
Default cost
See Also

Reference

NormHistogramCostExtractor Class
Emgu.CV.Shape Namespace


NormHistogramCostExtractor Properties

The NormHistogramCostExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

NormHistogramCostExtractor Class
Emgu.CV.Shape Namespace


NormHistogramCostExtractor Methods

The NormHistogramCostExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the histogram cost extractor (Inherited from HistogramCostExtractor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NormHistogramCostExtractor Class
Emgu.CV.Shape Namespace


NormHistogramCostExtractor Fields

The NormHistogramCostExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | Pointer native cv::Ptr object. (Inherited from HistogramCostExtractor.)
Top
See Also

Reference

NormHistogramCostExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor Class

Implementation of the Shape Context descriptor and matching algorithm proposed by Belongie et al. in “Shape Matching and Object Recognition Using Shape Contexts” (PAMI 2002).
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeShapeDistanceExtractor
Emgu.CV.ShapeShapeContextDistanceExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ShapeContextDistanceExtractor : ShapeDistanceExtractor
Public Class ShapeContextDistanceExtractor
    Inherits ShapeDistanceExtractor
public ref class ShapeContextDistanceExtractor : public ShapeDistanceExtractor
type ShapeContextDistanceExtractor =
    class
        inherit ShapeDistanceExtractor
    end

The ShapeContextDistanceExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | ShapeContextDistanceExtractor | Create a shape context distance extractor
Top
Properties
 | Name | Description
Public property | AngularBins | The number of angular bins in the shape context descriptor.
Public property | BendingEnergyWeight | The weight of the Bending Energy in the final distance value.
Public property | ImageAppearanceWeight | The weight of the appearance cost in the final distance value.
Public property | InnerRadius | The value of the inner radius.
Public property | Iterations | The number of iterations
Public property | OuterRadius | The value of the outer radius.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RadialBins | The number of radial bins in the shape context descriptor.
Public property | RotationInvariant | Rotation Invariant
Public property | ShapeContextWeight | The weight of the shape context distance in the final distance value.
Public property | StdDev | Standard Deviation.
Top
Methods
 | Name | Description
Public method | ComputeDistance(Point, Point) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | ComputeDistance(IInputArray, IInputArray) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this shape context distance extractor (Overrides ShapeDistanceExtractorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _shapeDistanceExtractorPtr | Pointer to the unmanaged ShapeDistanceExtractor (Inherited from ShapeDistanceExtractor.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor Constructor

Create a shape context distance extractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ShapeContextDistanceExtractor(
    HistogramCostExtractor comparer,
    IShapeTransformer transformer,
    int nAngularBins = 12,
    int nRadialBins = 4,
    float innerRadius = 0.2f,
    float outerRadius = 3f,
    int iterations = 3
)
Public Sub New (
    comparer As HistogramCostExtractor,
    transformer As IShapeTransformer,
    Optional nAngularBins As Integer = 12,
    Optional nRadialBins As Integer = 4,
    Optional innerRadius As Single = 0.2F,
    Optional outerRadius As Single = 3F,
    Optional iterations As Integer = 3
)
public:
ShapeContextDistanceExtractor(
    HistogramCostExtractor^ comparer,
    IShapeTransformer^ transformer,
    int nAngularBins = 12,
    int nRadialBins = 4,
    float innerRadius = 0.2f,
    float outerRadius = 3f,
    int iterations = 3
)
new :
        comparer : HistogramCostExtractor *
        transformer : IShapeTransformer *
        ?nAngularBins : int *
        ?nRadialBins : int *
        ?innerRadius : float32 *
        ?outerRadius : float32 *
        ?iterations : int
(* Defaults:
        let _nAngularBins = defaultArg nAngularBins 12
        let _nRadialBins = defaultArg nRadialBins 4
        let _innerRadius = defaultArg innerRadius 0.2f
        let _outerRadius = defaultArg outerRadius 3f
        let _iterations = defaultArg iterations 3
*)
-> ShapeContextDistanceExtractor

Parameters

comparer
Type: Emgu.CV.ShapeHistogramCostExtractor
The histogram cost extractor, use ChiHistogramCostExtractor as default
transformer
Type: Emgu.CV.ShapeIShapeTransformer
The shape transformer, use ThinPlateSplineSphapeTransformer as default
nAngularBins (Optional)
Type: SystemInt32
Establish the number of angular bins for the Shape Context Descriptor used in the shape matching pipeline.
nRadialBins (Optional)
Type: SystemInt32
Establish the number of radial bins for the Shape Context Descriptor used in the shape matching pipeline.
innerRadius (Optional)
Type: SystemSingle
Set the inner radius of the shape context descriptor.
outerRadius (Optional)
Type: SystemSingle
Set the outer radius of the shape context descriptor.
iterations (Optional)
Type: SystemInt32
Iterations
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor Properties

The ShapeContextDistanceExtractor type exposes the following members.

Properties
 | Name | Description
Public property | AngularBins | The number of angular bins in the shape context descriptor.
Public property | BendingEnergyWeight | The weight of the Bending Energy in the final distance value.
Public property | ImageAppearanceWeight | The weight of the appearance cost in the final distance value.
Public property | InnerRadius | The value of the inner radius.
Public property | Iterations | The number of iterations
Public property | OuterRadius | The value of the outer radius.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RadialBins | The number of radial bins in the shape context descriptor.
Public property | RotationInvariant | Rotation Invariant
Public property | ShapeContextWeight | The weight of the shape context distance in the final distance value.
Public property | StdDev | Standard Deviation.
Top
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.AngularBins Property

ShapeContextDistanceExtractorAngularBins Property

The number of angular bins in the shape context descriptor.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AngularBins { get; set; }
Public Property AngularBins As Integer
    Get
    Set
public:
property int AngularBins {
    int get ();
    void set (int value);
}
member AngularBins : int with get, set

Property Value

Type: Int32
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.BendingEnergyWeight Property

ShapeContextDistanceExtractorBendingEnergyWeight Property

The weight of the Bending Energy in the final distance value.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float BendingEnergyWeight { get; set; }
Public Property BendingEnergyWeight As Single
    Get
    Set
public:
property float BendingEnergyWeight {
    float get ();
    void set (float value);
}
member BendingEnergyWeight : float32 with get, set

Property Value

Type: Single
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.ImageAppearanceWeight Property

ShapeContextDistanceExtractorImageAppearanceWeight Property

The weight of the appearance cost in the final distance value.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ImageAppearanceWeight { get; set; }
Public Property ImageAppearanceWeight As Single
    Get
    Set
public:
property float ImageAppearanceWeight {
    float get ();
    void set (float value);
}
member ImageAppearanceWeight : float32 with get, set

Property Value

Type: Single
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.InnerRadius Property

ShapeContextDistanceExtractorInnerRadius Property

The value of the inner radius.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float InnerRadius { get; set; }
Public Property InnerRadius As Single
    Get
    Set
public:
property float InnerRadius {
    float get ();
    void set (float value);
}
member InnerRadius : float32 with get, set

Property Value

Type: Single
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.Iterations Property

ShapeContextDistanceExtractorIterations Property

The number of iterations

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Iterations { get; set; }
Public Property Iterations As Integer
    Get
    Set
public:
property int Iterations {
    int get ();
    void set (int value);
}
member Iterations : int with get, set

Property Value

Type: Int32
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.OuterRadius Property

ShapeContextDistanceExtractorOuterRadius Property

The value of the outer radius.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float OuterRadius { get; set; }
Public Property OuterRadius As Single
    Get
    Set
public:
property float OuterRadius {
    float get ();
    void set (float value);
}
member OuterRadius : float32 with get, set

Property Value

Type: Single
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.RadialBins Property

ShapeContextDistanceExtractorRadialBins Property

The number of radial bins in the shape context descriptor.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int RadialBins { get; set; }
Public Property RadialBins As Integer
    Get
    Set
public:
property int RadialBins {
    int get ();
    void set (int value);
}
member RadialBins : int with get, set

Property Value

Type: Int32
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.RotationInvariant Property

ShapeContextDistanceExtractorRotationInvariant Property

Rotation Invariant

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool RotationInvariant { get; set; }
Public Property RotationInvariant As Boolean
    Get
    Set
public:
property bool RotationInvariant {
    bool get ();
    void set (bool value);
}
member RotationInvariant : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.ShapeContextWeight Property

ShapeContextDistanceExtractorShapeContextWeight Property

The weight of the shape context distance in the final distance value.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ShapeContextWeight { get; set; }
Public Property ShapeContextWeight As Single
    Get
    Set
public:
property float ShapeContextWeight {
    float get ();
    void set (float value);
}
member ShapeContextWeight : float32 with get, set

Property Value

Type: Single
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.StdDev Property

ShapeContextDistanceExtractorStdDev Property

Standard Deviation.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float StdDev { get; set; }
Public Property StdDev As Single
    Get
    Set
public:
property float StdDev {
    float get ();
    void set (float value);
}
member StdDev : float32 with get, set

Property Value

Type: Single
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor Methods

The ShapeContextDistanceExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDistance(Point, Point) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | ComputeDistance(IInputArray, IInputArray) | Compute the shape distance between two shapes defined by its contours. (Inherited from ShapeDistanceExtractor.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the memory associated with this shape context distance extractor (Overrides ShapeDistanceExtractorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor.DisposeObject Method

ShapeContextDistanceExtractorDisposeObject Method

Release the memory associated with this shape context distance extractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeContextDistanceExtractor Fields

The ShapeContextDistanceExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _shapeDistanceExtractorPtr | Pointer to the unmanaged ShapeDistanceExtractor (Inherited from ShapeDistanceExtractor.)
Top
See Also

Reference

ShapeContextDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeDistanceExtractor Class

Abstract base class for shape distance algorithms.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeShapeDistanceExtractor
Emgu.CV.ShapeHausdorffDistanceExtractor
Emgu.CV.ShapeShapeContextDistanceExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ShapeDistanceExtractor : UnmanagedObject
Public MustInherit Class ShapeDistanceExtractor
    Inherits UnmanagedObject
public ref class ShapeDistanceExtractor abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type ShapeDistanceExtractor =
    class
        inherit UnmanagedObject
    end

The ShapeDistanceExtractor type exposes the following members.

Constructors
 | Name | Description
Protected method | ShapeDistanceExtractor | Initializes a new instance of the ShapeDistanceExtractor class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | ComputeDistance(Point, Point) | Compute the shape distance between two shapes defined by its contours.
Public method | ComputeDistance(IInputArray, IInputArray) | Compute the shape distance between two shapes defined by its contours.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all memory associated with this ShapeDistanceExtractor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _shapeDistanceExtractorPtr | Pointer to the unmanaged ShapeDistanceExtractor
Top
See Also

Reference

Emgu.CV.Shape Namespace


ShapeDistanceExtractor Constructor

Initializes a new instance of the ShapeDistanceExtractor class

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected ShapeDistanceExtractor()
Protected Sub New
protected:
ShapeDistanceExtractor()
new : unit -> ShapeDistanceExtractor
See Also

Reference

ShapeDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeDistanceExtractor Properties

The ShapeDistanceExtractor type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ShapeDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeDistanceExtractor Methods

The ShapeDistanceExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDistance(Point, Point) | Compute the shape distance between two shapes defined by its contours.
Public method | ComputeDistance(IInputArray, IInputArray) | Compute the shape distance between two shapes defined by its contours.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all memory associated with this ShapeDistanceExtractor (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShapeDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeDistanceExtractor.ComputeDistance Method

ShapeDistanceExtractorComputeDistance Method

Overload List
 | Name | Description
Public method | ComputeDistance(Point, Point) | Compute the shape distance between two shapes defined by its contours.
Public method | ComputeDistance(IInputArray, IInputArray) | Compute the shape distance between two shapes defined by its contours.
Top
See Also

Reference

ShapeDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeDistanceExtractor.ComputeDistance Method (Point[], Point[])

ShapeDistanceExtractorComputeDistance Method (Point, Point)

http://www.emgu.com
Compute the shape distance between two shapes defined by its contours.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ComputeDistance(
    Point[] contour1,
    Point[] contour2
)
Public Function ComputeDistance (
    contour1 As Point(),
    contour2 As Point()
) As Single
public:
float ComputeDistance(
    array<Point^>^ contour1,
    array<Point^>^ contour2
)
member ComputeDistance :
        contour1 : Point[] *
        contour2 : Point[] -> float32

Parameters

contour1
Type: System.DrawingPoint
Contour defining first shape
contour2
Type: System.DrawingPoint
Contour defining second shape

Return Value

Type: Single
The shape distance between two shapes defined by its contours.
See Also

Reference

ShapeDistanceExtractor Class
ComputeDistance Overload
Emgu.CV.Shape Namespace


ShapeDistanceExtractor.ComputeDistance Method (IInputArray, IInputArray)

ShapeDistanceExtractorComputeDistance Method (IInputArray, IInputArray)

http://www.emgu.com
Compute the shape distance between two shapes defined by its contours.

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ComputeDistance(
    IInputArray contour1,
    IInputArray contour2
)
Public Function ComputeDistance (
    contour1 As IInputArray,
    contour2 As IInputArray
) As Single
public:
float ComputeDistance(
    IInputArray^ contour1,
    IInputArray^ contour2
)
member ComputeDistance :
        contour1 : IInputArray *
        contour2 : IInputArray -> float32

Parameters

contour1
Type: Emgu.CVIInputArray
Contour defining first shape
contour2
Type: Emgu.CVIInputArray
Contour defining second shape

Return Value

Type: Single
The shape distance between two shapes defined by its contours.
See Also

Reference

ShapeDistanceExtractor Class
ComputeDistance Overload
Emgu.CV.Shape Namespace


ShapeDistanceExtractor.DisposeObject Method

ShapeDistanceExtractorDisposeObject Method

Release all memory associated with this ShapeDistanceExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ShapeDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeDistanceExtractor Fields

The ShapeDistanceExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _shapeDistanceExtractorPtr | Pointer to the unmanaged ShapeDistanceExtractor
Top
See Also

Reference

ShapeDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeDistanceExtractor._shapeDistanceExtractorPtr Field

ShapeDistanceExtractor_shapeDistanceExtractorPtr Field

Pointer to the unmanaged ShapeDistanceExtractor

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _shapeDistanceExtractorPtr
Protected _shapeDistanceExtractorPtr As IntPtr
protected:
IntPtr _shapeDistanceExtractorPtr
val mutable _shapeDistanceExtractorPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

ShapeDistanceExtractor Class
Emgu.CV.Shape Namespace


ShapeInvoke Class

Library to invoke functions that belongs to the shape module
Inheritance Hierarchy
SystemObject
Emgu.CV.ShapeShapeInvoke

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class ShapeInvoke
Public NotInheritable Class ShapeInvoke
public ref class ShapeInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ShapeInvoke =  class end
See Also

Reference

Emgu.CV.Shape Namespace


ThinPlateSplineShapeTransformer Class

Definition of the transformation ocupied in the paper “Principal Warps: Thin-Plate Splines and Decomposition of Deformations”, by F.L. Bookstein (PAMI 1989).
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.ShapeThinPlateSplineShapeTransformer

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ThinPlateSplineShapeTransformer : UnmanagedObject,
    IShapeTransformer
Public Class ThinPlateSplineShapeTransformer
    Inherits UnmanagedObject
    Implements IShapeTransformer
public ref class ThinPlateSplineShapeTransformer : public UnmanagedObject,
    IShapeTransformer
type ThinPlateSplineShapeTransformer =
    class
        inherit UnmanagedObject
        interface IShapeTransformer
    end

The ThinPlateSplineShapeTransformer type exposes the following members.

Constructors
 | Name | Description
Public method | ThinPlateSplineShapeTransformer | Create a thin plate spline shape transformer
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShapeTransformerPtr | Get the pointer the the native ShapeTransformer
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this ShapeTransformer object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Shape Namespace


ThinPlateSplineShapeTransformer Constructor

Create a thin plate spline shape transformer

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ThinPlateSplineShapeTransformer(
    double regularizationParameter = 0
)
Public Sub New (
    Optional regularizationParameter As Double = 0
)
public:
ThinPlateSplineShapeTransformer(
    double regularizationParameter = 0
)
new :
        ?regularizationParameter : float
(* Defaults:
        let _regularizationParameter = defaultArg regularizationParameter 0
*)
-> ThinPlateSplineShapeTransformer

Parameters

regularizationParameter (Optional)
Type: SystemDouble
The regularization parameter for relaxing the exact interpolation requirements of the TPS algorithm.
See Also

Reference

ThinPlateSplineShapeTransformer Class
Emgu.CV.Shape Namespace


ThinPlateSplineShapeTransformer Properties

The ThinPlateSplineShapeTransformer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | ShapeTransformerPtr | Get the pointer the the native ShapeTransformer
Top
See Also

Reference

ThinPlateSplineShapeTransformer Class
Emgu.CV.Shape Namespace


ThinPlateSplineShapeTransformer.ShapeTransformerPtr Property

ThinPlateSplineShapeTransformerShapeTransformerPtr Property

Get the pointer the the native ShapeTransformer

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ShapeTransformerPtr { get; }
Public ReadOnly Property ShapeTransformerPtr As IntPtr
    Get
public:
virtual property IntPtr ShapeTransformerPtr {
    IntPtr get () sealed;
}
abstract ShapeTransformerPtr : IntPtr with get
override ShapeTransformerPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IShapeTransformerShapeTransformerPtr
See Also

Reference

ThinPlateSplineShapeTransformer Class
Emgu.CV.Shape Namespace


ThinPlateSplineShapeTransformer Methods

The ThinPlateSplineShapeTransformer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this ShapeTransformer object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThinPlateSplineShapeTransformer Class
Emgu.CV.Shape Namespace


ThinPlateSplineShapeTransformer.DisposeObject Method

ThinPlateSplineShapeTransformerDisposeObject Method

Release the unmanaged memory associated with this ShapeTransformer object

Namespace: Emgu.CV.Shape
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ThinPlateSplineShapeTransformer Class
Emgu.CV.Shape Namespace


ThinPlateSplineShapeTransformer Fields

The ThinPlateSplineShapeTransformer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ThinPlateSplineShapeTransformer Class
Emgu.CV.Shape Namespace


Emgu.CV.Stereo Namespace

[Missing <summary> documentation for "N:Emgu.CV.Stereo"]

Classes
 | Class | Description
Public class | QuasiDenseStereo | Class containing the methods needed for Quasi Dense Stereo computation.
Public class | QuasiDenseStereoPropagationParameters | The propagation parameters
Public class | StereoInvoke | Class that contains entry points for the Stereo module.


QuasiDenseStereo Class

Class containing the methods needed for Quasi Dense Stereo computation.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.StereoQuasiDenseStereo

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class QuasiDenseStereo : SharedPtrObject
Public Class QuasiDenseStereo
    Inherits SharedPtrObject
public ref class QuasiDenseStereo : public SharedPtrObject
type QuasiDenseStereo =
    class
        inherit SharedPtrObject
    end

The QuasiDenseStereo type exposes the following members.

Constructors
 | Name | Description
Public method | QuasiDenseStereo | Create a new instance containing the methods needed for Quasi Dense Stereo computation.
Top
Properties
 | Name | Description
Public property | Param | Parameters for the QuasiDenseStereo class
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetDisparity | Compute and return the disparity map based on the correspondences found in the "process" method.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Main process of the algorithm. This method computes the sparse seeds and then densifies them. Initially input images are converted to gray-scale and then the sparseMatching method is called to obtain the sparse stereo. Finally quasiDenseMatching is called to densify the corresponding points.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Stereo Namespace


QuasiDenseStereo Constructor

Create a new instance containing the methods needed for Quasi Dense Stereo computation.

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QuasiDenseStereo(
    Size monoImgSize,
    string paramFilepath = ""
)
Public Sub New (
    monoImgSize As Size,
    Optional paramFilepath As String = ""
)
public:
QuasiDenseStereo(
    Size^ monoImgSize,
    String^ paramFilepath = L""
)
new :
        monoImgSize : Size *
        ?paramFilepath : string
(* Defaults:
        let _paramFilepath = defaultArg paramFilepath ""
*)
-> QuasiDenseStereo

Parameters

monoImgSize
Type: System.DrawingSize
Image size
paramFilepath (Optional)
Type: SystemString
The path for the parameters
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo Properties

The QuasiDenseStereo type exposes the following members.

Properties
 | Name | Description
Public property | Param | Parameters for the QuasiDenseStereo class
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.Param Property

QuasiDenseStereoParam Property

Parameters for the QuasiDenseStereo class

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public QuasiDenseStereoPropagationParameters Param { get; set; }
Public Property Param As QuasiDenseStereoPropagationParameters
    Get
    Set
public:
property QuasiDenseStereoPropagationParameters^ Param {
    QuasiDenseStereoPropagationParameters^ get ();
    void set (QuasiDenseStereoPropagationParameters^ value);
}
member Param : QuasiDenseStereoPropagationParameters with get, set

Property Value

Type: QuasiDenseStereoPropagationParameters
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo Methods

The QuasiDenseStereo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetDisparity | Compute and return the disparity map based on the correspondences found in the "process" method.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Main process of the algorithm. This method computes the sparse seeds and then densifies them. Initially input images are converted to gray-scale and then the sparseMatching method is called to obtain the sparse stereo. Finally quasiDenseMatching is called to densify the corresponding points.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.DisposeObject Method

QuasiDenseStereoDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.GetDisparity Method

QuasiDenseStereoGetDisparity Method

Compute and return the disparity map based on the correspondences found in the "process" method.

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat GetDisparity(
    byte disparityLvls = 50
)
Public Function GetDisparity (
    Optional disparityLvls As Byte = 50
) As Mat
public:
Mat^ GetDisparity(
    unsigned char disparityLvls = 50
)
member GetDisparity :
        ?disparityLvls : byte
(* Defaults:
        let _disparityLvls = defaultArg disparityLvls 50
*)
-> Mat

Parameters

disparityLvls (Optional)
Type: SystemByte
The level of detail in output disparity image.

Return Value

Type: Mat
Mat containing a the disparity image in grayscale.
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.Process Method

QuasiDenseStereoProcess Method

Main process of the algorithm. This method computes the sparse seeds and then densifies them. Initially input images are converted to gray-scale and then the sparseMatching method is called to obtain the sparse stereo. Finally quasiDenseMatching is called to densify the corresponding points.

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Process(
    Mat imgLeft,
    Mat imgRight
)
Public Sub Process (
    imgLeft As Mat,
    imgRight As Mat
)
public:
void Process(
    Mat^ imgLeft,
    Mat^ imgRight
)
member Process :
        imgLeft : Mat *
        imgRight : Mat -> unit

Parameters

imgLeft
Type: Emgu.CVMat
The left Channel of a stereo image pair.
imgRight
Type: Emgu.CVMat
The right Channel of a stereo image pair.
Remarks
If input images are in color, the method assumes that are BGR and converts them to grayscale.
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo Fields

The QuasiDenseStereo type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

QuasiDenseStereo Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters Class

QuasiDenseStereoPropagationParameters Class

The propagation parameters
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StereoQuasiDenseStereoPropagationParameters

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PropagationParameters : ValueType
Public NotInheritable Class PropagationParameters
    Inherits ValueType
public ref class PropagationParameters sealed : public ValueType
[<SealedAttribute>]
type PropagationParameters =
    class
        inherit ValueType
    end

The QuasiDenseStereoPropagationParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | BorderX | border to ignore
Public field | BorderY | border to ignore
Public field | CorrelationThreshold | correlation threshold
Public field | CorrWinSizeX | similarity window
Public field | CorrWinSizeY | similarity window
Public field | DisparityGradient | disparity gradient threshold
Public field | GftMaxNumFeatures | Parameters for GFT algorithm.
Public field | GftMinSeperationDist | Parameters for GFT algorithm.
Public field | GftQualityThres | Parameters for GFT algorithm.
Public field | LkPyrLvl | Parameters for LK flow algorithm
Public field | LkTemplateSize | Parameters for LK flow algorithm
Public field | LkTermParam1 | Parameters for LK flow algorithm
Public field | LkTermParam2 | Parameters for LK flow algorithm
Public field | NeighborhoodSize | neighborhood size
Public field | TextrureThreshold | texture threshold
Top
See Also

Reference

Emgu.CV.Stereo Namespace


PropagationParameters Methods

The QuasiDenseStereoPropagationParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


PropagationParameters Fields

The QuasiDenseStereoPropagationParameters type exposes the following members.

Fields
 | Name | Description
Public field | BorderX | border to ignore
Public field | BorderY | border to ignore
Public field | CorrelationThreshold | correlation threshold
Public field | CorrWinSizeX | similarity window
Public field | CorrWinSizeY | similarity window
Public field | DisparityGradient | disparity gradient threshold
Public field | GftMaxNumFeatures | Parameters for GFT algorithm.
Public field | GftMinSeperationDist | Parameters for GFT algorithm.
Public field | GftQualityThres | Parameters for GFT algorithm.
Public field | LkPyrLvl | Parameters for LK flow algorithm
Public field | LkTemplateSize | Parameters for LK flow algorithm
Public field | LkTermParam1 | Parameters for LK flow algorithm
Public field | LkTermParam2 | Parameters for LK flow algorithm
Public field | NeighborhoodSize | neighborhood size
Public field | TextrureThreshold | texture threshold
Top
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.BorderX Field

QuasiDenseStereoPropagationParametersBorderX Field

border to ignore

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderX
Public BorderX As Integer
public:
int BorderX
val mutable BorderX: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.BorderY Field

QuasiDenseStereoPropagationParametersBorderY Field

border to ignore

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderY
Public BorderY As Integer
public:
int BorderY
val mutable BorderY: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.CorrelationThreshold Field

QuasiDenseStereoPropagationParametersCorrelationThreshold Field

http://www.emgu.com
correlation threshold

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float CorrelationThreshold
Public CorrelationThreshold As Single
public:
float CorrelationThreshold
val mutable CorrelationThreshold: float32

Field Value

Type: Single
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.CorrWinSizeX Field

QuasiDenseStereoPropagationParametersCorrWinSizeX Field

similarity window

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CorrWinSizeX
Public CorrWinSizeX As Integer
public:
int CorrWinSizeX
val mutable CorrWinSizeX: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.CorrWinSizeY Field

QuasiDenseStereoPropagationParametersCorrWinSizeY Field

similarity window

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CorrWinSizeY
Public CorrWinSizeY As Integer
public:
int CorrWinSizeY
val mutable CorrWinSizeY: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.DisparityGradient Field

QuasiDenseStereoPropagationParametersDisparityGradient Field

disparity gradient threshold

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DisparityGradient
Public DisparityGradient As Integer
public:
int DisparityGradient
val mutable DisparityGradient: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.GftMaxNumFeatures Field

QuasiDenseStereoPropagationParametersGftMaxNumFeatures Field

Parameters for GFT algorithm.

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GftMaxNumFeatures
Public GftMaxNumFeatures As Integer
public:
int GftMaxNumFeatures
val mutable GftMaxNumFeatures: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.GftMinSeperationDist Field

QuasiDenseStereoPropagationParametersGftMinSeperationDist Field

http://www.emgu.com
Parameters for GFT algorithm.

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GftMinSeperationDist
Public GftMinSeperationDist As Integer
public:
int GftMinSeperationDist
val mutable GftMinSeperationDist: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.GftQualityThres Field

QuasiDenseStereoPropagationParametersGftQualityThres Field

Parameters for GFT algorithm.

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float GftQualityThres
Public GftQualityThres As Single
public:
float GftQualityThres
val mutable GftQualityThres: float32

Field Value

Type: Single
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.LkPyrLvl Field

QuasiDenseStereoPropagationParametersLkPyrLvl Field

Parameters for LK flow algorithm

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int LkPyrLvl
Public LkPyrLvl As Integer
public:
int LkPyrLvl
val mutable LkPyrLvl: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.LkTemplateSize Field

QuasiDenseStereoPropagationParametersLkTemplateSize Field

Parameters for LK flow algorithm

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int LkTemplateSize
Public LkTemplateSize As Integer
public:
int LkTemplateSize
val mutable LkTemplateSize: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.LkTermParam1 Field

QuasiDenseStereoPropagationParametersLkTermParam1 Field

Parameters for LK flow algorithm

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int LkTermParam1
Public LkTermParam1 As Integer
public:
int LkTermParam1
val mutable LkTermParam1: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.LkTermParam2 Field

QuasiDenseStereoPropagationParametersLkTermParam2 Field

Parameters for LK flow algorithm

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float LkTermParam2
Public LkTermParam2 As Single
public:
float LkTermParam2
val mutable LkTermParam2: float32

Field Value

Type: Single
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.NeighborhoodSize Field

QuasiDenseStereoPropagationParametersNeighborhoodSize Field

neighborhood size

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NeighborhoodSize
Public NeighborhoodSize As Integer
public:
int NeighborhoodSize
val mutable NeighborhoodSize: int

Field Value

Type: Int32
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


QuasiDenseStereo.PropagationParameters.TextrureThreshold Field

QuasiDenseStereoPropagationParametersTextrureThreshold Field

texture threshold

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float TextrureThreshold
Public TextrureThreshold As Single
public:
float TextrureThreshold
val mutable TextrureThreshold: float32

Field Value

Type: Single
See Also

Reference

QuasiDenseStereoPropagationParameters Class
Emgu.CV.Stereo Namespace


StereoInvoke Class

Class that contains entry points for the Stereo module.
Inheritance Hierarchy
SystemObject
Emgu.CV.StereoStereoInvoke

Namespace: Emgu.CV.Stereo
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class StereoInvoke
Public NotInheritable Class StereoInvoke
public ref class StereoInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StereoInvoke =  class end
See Also

Reference

Emgu.CV.Stereo Namespace


Emgu.CV.Stitching Namespace

Image stitching
Classes
 | Class | Description
Public class | Blender | Blender for Image Stitching
Public class | CompressedRectilinearWarper | Compressed rectilinear warper
Public class | FeatherBlender | Simple blender which mixes images at its borders.
Public class | FisheyeWarper | Fisheye Warper
Public class | MercatorWarper | Mercator warper
Public class | MultiBandBlender | Blender which uses multi-band blending algorithm
Public class | PaniniPortraitWarper | Panini portrait warper
Public class | PaniniWarper | Panini warper
Public class | PlaneWarper | Warper that maps an image onto the z = 1 plane.
Public class | SphericalWarper | Warper that maps an image onto the unit sphere located at the origin.
Public class | StereographicWarper | Stereographic Warper
Public class | Stitcher | Image Stitching.
Public class | StitcherMode | Stitch mode
Public class | StitcherStatus | The stitcher statis
Public class | StitcherWaveCorrectionType | Wave correction kind
Public class | StitchingInvoke | Entry points to the Open CV Stitching module.
Public class | TransverseMercatorWarper | Transverse mercator warper
Public class | WarperCreator | Finds features in the given image.


Blender Class

Blender for Image Stitching
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingBlender
Emgu.CV.StitchingFeatherBlender
Emgu.CV.StitchingMultiBandBlender

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class Blender : UnmanagedObject
Public MustInherit Class Blender
    Inherits UnmanagedObject
public ref class Blender abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type Blender =
    class
        inherit UnmanagedObject
    end

The Blender type exposes the following members.

Constructors
 | Name | Description
Protected method | Blender | Initializes a new instance of the Blender class
Top
Properties
 | Name | Description
Public property | BlenderPtr | Pointer to the native Blender object.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the unmanaged pointer associated to this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _blenderPtr | Pointer to the native Blender object.
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


Blender Constructor

Initializes a new instance of the Blender class

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Blender()
Protected Sub New
protected:
Blender()
new : unit -> Blender
See Also

Reference

Blender Class
Emgu.CV.Stitching Namespace


Blender Properties

The Blender type exposes the following members.

Properties
 | Name | Description
Public property | BlenderPtr | Pointer to the native Blender object.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Blender Class
Emgu.CV.Stitching Namespace


Blender.BlenderPtr Property

BlenderBlenderPtr Property

Pointer to the native Blender object.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr BlenderPtr { get; }
Public ReadOnly Property BlenderPtr As IntPtr
    Get
public:
property IntPtr BlenderPtr {
    IntPtr get ();
}
member BlenderPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

Blender Class
Emgu.CV.Stitching Namespace


Blender Methods

The Blender type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the unmanaged pointer associated to this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Blender Class
Emgu.CV.Stitching Namespace


Blender.DisposeObject Method

BlenderDisposeObject Method

Reset the unmanaged pointer associated to this object

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Blender Class
Emgu.CV.Stitching Namespace


Blender Fields

The Blender type exposes the following members.

Fields
 | Name | Description
Protected field | _blenderPtr | Pointer to the native Blender object.
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Blender Class
Emgu.CV.Stitching Namespace


Blender._blenderPtr Field

Blender_blenderPtr Field

Pointer to the native Blender object.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _blenderPtr
Protected _blenderPtr As IntPtr
protected:
IntPtr _blenderPtr
val mutable _blenderPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

Blender Class
Emgu.CV.Stitching Namespace


CompressedRectilinearWarper Class

Compressed rectilinear warper
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingCompressedRectilinearWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CompressedRectilinearWarper : WarperCreator
Public Class CompressedRectilinearWarper
    Inherits WarperCreator
public ref class CompressedRectilinearWarper : public WarperCreator
type CompressedRectilinearWarper =
    class
        inherit WarperCreator
    end

The CompressedRectilinearWarper type exposes the following members.

Constructors
 | Name | Description
Public method | CompressedRectilinearWarper | Create a compressed rectilinear warper
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


CompressedRectilinearWarper Constructor

Create a compressed rectilinear warper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CompressedRectilinearWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
CompressedRectilinearWarper(
    float scale
)
new :
        scale : float32 -> CompressedRectilinearWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

CompressedRectilinearWarper Class
Emgu.CV.Stitching Namespace


CompressedRectilinearWarper Properties

The CompressedRectilinearWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

CompressedRectilinearWarper Class
Emgu.CV.Stitching Namespace


CompressedRectilinearWarper Methods

The CompressedRectilinearWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

CompressedRectilinearWarper Class
Emgu.CV.Stitching Namespace


CompressedRectilinearWarper.DisposeObject Method

CompressedRectilinearWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CompressedRectilinearWarper Class
Emgu.CV.Stitching Namespace


CompressedRectilinearWarper Fields

The CompressedRectilinearWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

CompressedRectilinearWarper Class
Emgu.CV.Stitching Namespace


FeatherBlender Class

Simple blender which mixes images at its borders.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingBlender
Emgu.CV.StitchingFeatherBlender

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FeatherBlender : Blender
Public Class FeatherBlender
    Inherits Blender
public ref class FeatherBlender : public Blender
type FeatherBlender =
    class
        inherit Blender
    end

The FeatherBlender type exposes the following members.

Constructors
 | Name | Description
Public method | FeatherBlender | Create a simple blender which mixes images at its borders
Top
Properties
 | Name | Description
Public property | BlenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this blender (Overrides BlenderDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _blenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


FeatherBlender Constructor

Create a simple blender which mixes images at its borders

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FeatherBlender(
    float sharpness
)
Public Sub New (
    sharpness As Single
)
public:
FeatherBlender(
    float sharpness
)
new :
        sharpness : float32 -> FeatherBlender

Parameters

sharpness
Type: SystemSingle
Sharpness
See Also

Reference

FeatherBlender Class
Emgu.CV.Stitching Namespace


FeatherBlender Properties

The FeatherBlender type exposes the following members.

Properties
 | Name | Description
Public property | BlenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FeatherBlender Class
Emgu.CV.Stitching Namespace


FeatherBlender Methods

The FeatherBlender type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this blender (Overrides BlenderDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FeatherBlender Class
Emgu.CV.Stitching Namespace


FeatherBlender.DisposeObject Method

FeatherBlenderDisposeObject Method

Release all the unmanaged memory associated with this blender

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FeatherBlender Class
Emgu.CV.Stitching Namespace


FeatherBlender Fields

The FeatherBlender type exposes the following members.

Fields
 | Name | Description
Protected field | _blenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FeatherBlender Class
Emgu.CV.Stitching Namespace


FisheyeWarper Class

Fisheye Warper
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingFisheyeWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FisheyeWarper : WarperCreator
Public Class FisheyeWarper
    Inherits WarperCreator
public ref class FisheyeWarper : public WarperCreator
type FisheyeWarper =
    class
        inherit WarperCreator
    end

The FisheyeWarper type exposes the following members.

Constructors
 | Name | Description
Public method | FisheyeWarper | Create a fisheye warper
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


FisheyeWarper Constructor

Create a fisheye warper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FisheyeWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
FisheyeWarper(
    float scale
)
new :
        scale : float32 -> FisheyeWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

FisheyeWarper Class
Emgu.CV.Stitching Namespace


FisheyeWarper Properties

The FisheyeWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

FisheyeWarper Class
Emgu.CV.Stitching Namespace


FisheyeWarper Methods

The FisheyeWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

FisheyeWarper Class
Emgu.CV.Stitching Namespace


FisheyeWarper.DisposeObject Method

FisheyeWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FisheyeWarper Class
Emgu.CV.Stitching Namespace


FisheyeWarper Fields

The FisheyeWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

FisheyeWarper Class
Emgu.CV.Stitching Namespace


MercatorWarper Class

Mercator warper
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingMercatorWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MercatorWarper : WarperCreator
Public Class MercatorWarper
    Inherits WarperCreator
public ref class MercatorWarper : public WarperCreator
type MercatorWarper =
    class
        inherit WarperCreator
    end

The MercatorWarper type exposes the following members.

Constructors
 | Name | Description
Public method | MercatorWarper | Create a Mercator Warper
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


MercatorWarper Constructor

Create a Mercator Warper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MercatorWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
MercatorWarper(
    float scale
)
new :
        scale : float32 -> MercatorWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

MercatorWarper Class
Emgu.CV.Stitching Namespace


MercatorWarper Properties

The MercatorWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

MercatorWarper Class
Emgu.CV.Stitching Namespace


MercatorWarper Methods

The MercatorWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

MercatorWarper Class
Emgu.CV.Stitching Namespace


MercatorWarper.DisposeObject Method

MercatorWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MercatorWarper Class
Emgu.CV.Stitching Namespace


MercatorWarper Fields

The MercatorWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

MercatorWarper Class
Emgu.CV.Stitching Namespace


MultiBandBlender Class

Blender which uses multi-band blending algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingBlender
Emgu.CV.StitchingMultiBandBlender

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MultiBandBlender : Blender
Public Class MultiBandBlender
    Inherits Blender
public ref class MultiBandBlender : public Blender
type MultiBandBlender =
    class
        inherit Blender
    end

The MultiBandBlender type exposes the following members.

Constructors
 | Name | Description
Public method | MultiBandBlender | Create a multiBandBlender
Top
Properties
 | Name | Description
Public property | BlenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged resources associated with this blender (Overrides BlenderDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _blenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


MultiBandBlender Constructor

Create a multiBandBlender

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MultiBandBlender(
    bool tryGpu = true,
    int numBands = 5,
    DepthType weightType = 5
)
Public Sub New (
    Optional tryGpu As Boolean = true,
    Optional numBands As Integer = 5,
    Optional weightType As DepthType = 5
)
public:
MultiBandBlender(
    bool tryGpu = true,
    int numBands = 5,
    DepthType^ weightType = 5
)
new :
        ?tryGpu : bool *
        ?numBands : int *
        ?weightType : DepthType
(* Defaults:
        let _tryGpu = defaultArg tryGpu true
        let _numBands = defaultArg numBands 5
        let _weightType = defaultArg weightType 5
*)
-> MultiBandBlender

Parameters

tryGpu (Optional)
Type: SystemBoolean
If true, will try to use GPU
numBands (Optional)
Type: SystemInt32
Number of bands
weightType (Optional)
Type: Emgu.CV.CvEnumDepthType
The weight type
See Also

Reference

MultiBandBlender Class
Emgu.CV.Stitching Namespace


MultiBandBlender Properties

The MultiBandBlender type exposes the following members.

Properties
 | Name | Description
Public property | BlenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MultiBandBlender Class
Emgu.CV.Stitching Namespace


MultiBandBlender Methods

The MultiBandBlender type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all unmanaged resources associated with this blender (Overrides BlenderDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MultiBandBlender Class
Emgu.CV.Stitching Namespace


MultiBandBlender.DisposeObject Method

MultiBandBlenderDisposeObject Method

Release all unmanaged resources associated with this blender

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MultiBandBlender Class
Emgu.CV.Stitching Namespace


MultiBandBlender Fields

The MultiBandBlender type exposes the following members.

Fields
 | Name | Description
Protected field | _blenderPtr | Pointer to the native Blender object. (Inherited from Blender.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MultiBandBlender Class
Emgu.CV.Stitching Namespace


PaniniPortraitWarper Class

Panini portrait warper
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingPaniniPortraitWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PaniniPortraitWarper : WarperCreator
Public Class PaniniPortraitWarper
    Inherits WarperCreator
public ref class PaniniPortraitWarper : public WarperCreator
type PaniniPortraitWarper =
    class
        inherit WarperCreator
    end

The PaniniPortraitWarper type exposes the following members.

Constructors
 | Name | Description
Public method | PaniniPortraitWarper | Create a panini portrait warper
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


PaniniPortraitWarper Constructor

Create a panini portrait warper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PaniniPortraitWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
PaniniPortraitWarper(
    float scale
)
new :
        scale : float32 -> PaniniPortraitWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

PaniniPortraitWarper Class
Emgu.CV.Stitching Namespace


PaniniPortraitWarper Properties

The PaniniPortraitWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

PaniniPortraitWarper Class
Emgu.CV.Stitching Namespace


PaniniPortraitWarper Methods

The PaniniPortraitWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

PaniniPortraitWarper Class
Emgu.CV.Stitching Namespace


PaniniPortraitWarper.DisposeObject Method

PaniniPortraitWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PaniniPortraitWarper Class
Emgu.CV.Stitching Namespace


PaniniPortraitWarper Fields

The PaniniPortraitWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

PaniniPortraitWarper Class
Emgu.CV.Stitching Namespace


PaniniWarper Class

Panini warper
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingPaniniWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PaniniWarper : WarperCreator
Public Class PaniniWarper
    Inherits WarperCreator
public ref class PaniniWarper : public WarperCreator
type PaniniWarper =
    class
        inherit WarperCreator
    end

The PaniniWarper type exposes the following members.

Constructors
 | Name | Description
Public method | PaniniWarper | Create a Panini warper
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


PaniniWarper Constructor

Create a Panini warper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PaniniWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
PaniniWarper(
    float scale
)
new :
        scale : float32 -> PaniniWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

PaniniWarper Class
Emgu.CV.Stitching Namespace


PaniniWarper Properties

The PaniniWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

PaniniWarper Class
Emgu.CV.Stitching Namespace


PaniniWarper Methods

The PaniniWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

PaniniWarper Class
Emgu.CV.Stitching Namespace


PaniniWarper.DisposeObject Method

PaniniWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PaniniWarper Class
Emgu.CV.Stitching Namespace


PaniniWarper Fields

The PaniniWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

PaniniWarper Class
Emgu.CV.Stitching Namespace


PlaneWarper Class

Warper that maps an image onto the z = 1 plane.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingPlaneWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PlaneWarper : WarperCreator
Public Class PlaneWarper
    Inherits WarperCreator
public ref class PlaneWarper : public WarperCreator
type PlaneWarper =
    class
        inherit WarperCreator
    end

The PlaneWarper type exposes the following members.

Constructors
 | Name | Description
Public method | PlaneWarper | Construct an instance of the plane warper class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


PlaneWarper Constructor

Construct an instance of the plane warper class.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PlaneWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
PlaneWarper(
    float scale
)
new :
        scale : float32 -> PlaneWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

PlaneWarper Class
Emgu.CV.Stitching Namespace


PlaneWarper Properties

The PlaneWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

PlaneWarper Class
Emgu.CV.Stitching Namespace


PlaneWarper Methods

The PlaneWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

PlaneWarper Class
Emgu.CV.Stitching Namespace


PlaneWarper.DisposeObject Method

PlaneWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PlaneWarper Class
Emgu.CV.Stitching Namespace


PlaneWarper Fields

The PlaneWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

PlaneWarper Class
Emgu.CV.Stitching Namespace


SphericalWarper Class

Warper that maps an image onto the unit sphere located at the origin.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingSphericalWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SphericalWarper : WarperCreator
Public Class SphericalWarper
    Inherits WarperCreator
public ref class SphericalWarper : public WarperCreator
type SphericalWarper =
    class
        inherit WarperCreator
    end

The SphericalWarper type exposes the following members.

Constructors
 | Name | Description
Public method | SphericalWarper | Construct an instance of the spherical warper class.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


SphericalWarper Constructor

Construct an instance of the spherical warper class.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SphericalWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
SphericalWarper(
    float scale
)
new :
        scale : float32 -> SphericalWarper

Parameters

scale
Type: SystemSingle
Radius of the projected sphere, in pixels. An image spanning the whole sphere will have a width of 2 * scale * PI pixels.
See Also

Reference

SphericalWarper Class
Emgu.CV.Stitching Namespace


SphericalWarper Properties

The SphericalWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

SphericalWarper Class
Emgu.CV.Stitching Namespace


SphericalWarper Methods

The SphericalWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

SphericalWarper Class
Emgu.CV.Stitching Namespace


SphericalWarper.DisposeObject Method

SphericalWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SphericalWarper Class
Emgu.CV.Stitching Namespace


SphericalWarper Fields

The SphericalWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

SphericalWarper Class
Emgu.CV.Stitching Namespace


StereographicWarper Class

Stereographic Warper
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingStereographicWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class StereographicWarper : WarperCreator
Public Class StereographicWarper
    Inherits WarperCreator
public ref class StereographicWarper : public WarperCreator
type StereographicWarper =
    class
        inherit WarperCreator
    end

The StereographicWarper type exposes the following members.

Constructors
 | Name | Description
Public method | StereographicWarper | Create a stereographic warper
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


StereographicWarper Constructor

Create a stereographic warper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StereographicWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
StereographicWarper(
    float scale
)
new :
        scale : float32 -> StereographicWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

StereographicWarper Class
Emgu.CV.Stitching Namespace


StereographicWarper Properties

The StereographicWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

StereographicWarper Class
Emgu.CV.Stitching Namespace


StereographicWarper Methods

The StereographicWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

StereographicWarper Class
Emgu.CV.Stitching Namespace


StereographicWarper.DisposeObject Method

StereographicWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

StereographicWarper Class
Emgu.CV.Stitching Namespace


StereographicWarper Fields

The StereographicWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

StereographicWarper Class
Emgu.CV.Stitching Namespace


Stitcher Class

Image Stitching.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.StitchingStitcher

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Stitcher : SharedPtrObject
Public Class Stitcher
    Inherits SharedPtrObject
public ref class Stitcher : public SharedPtrObject
type Stitcher =
    class
        inherit SharedPtrObject
    end

The Stitcher type exposes the following members.

Constructors
 | Name | Description
Public method | Stitcher | Creates a Stitcher configured in one of the stitching modes.
Top
Properties
 | Name | Description
Public property | CompositingResol | Get or Set the compositing resolution
Public property | PanoConfidenceThresh | Get or set the pano confidence threshold
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegistrationResol | Get or set the registration resolution
Public property | SeamEstimationResol | Get or Set the seam estimation resolution
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | WaveCorrection | Get or Set a flag to indicate if the stitcher should apply wave correction
Public property | WaveCorrectionKind | The wave correction type.
Public property | WorkScale | The work scale
Top
Methods
 | Name | Description
Public method | ComposePanorama(IOutputArray) | These functions try to match the given images and to estimate rotations of each camera.
Public method | ComposePanorama(IInputArrayOfArrays, IOutputArray) | These functions try to compose the given images (or images stored internally from the other function calls) into the final pano under the assumption that the image transformations were estimated before.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release memory associated with this stitcher (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EstimateTransform | These functions try to match the given images and to estimate rotations of each camera.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetBlender | Set the blender for this stitcher
Public method | SetFeaturesFinder | Set the features finder for this stitcher.
Public method | SetWarper | Set the warper creator for this stitcher.
Public method | Stitch | Compute the panoramic images given the images
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


Stitcher Constructor

Creates a Stitcher configured in one of the stitching modes.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Stitcher(
    StitcherMode mode = 0
)
Public Sub New (
    Optional mode As StitcherMode = 0
)
public:
Stitcher(
    StitcherMode^ mode = 0
)
new :
        ?mode : StitcherMode
(* Defaults:
        let _mode = defaultArg mode 0
*)
-> Stitcher

Parameters

mode (Optional)
Type: Emgu.CV.StitchingStitcherMode
Scenario for stitcher operation. This is usually determined by source of images to stitch and their transformation.
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher Properties

The Stitcher type exposes the following members.

Properties
 | Name | Description
Public property | CompositingResol | Get or Set the compositing resolution
Public property | PanoConfidenceThresh | Get or set the pano confidence threshold
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RegistrationResol | Get or set the registration resolution
Public property | SeamEstimationResol | Get or Set the seam estimation resolution
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | WaveCorrection | Get or Set a flag to indicate if the stitcher should apply wave correction
Public property | WaveCorrectionKind | The wave correction type.
Public property | WorkScale | The work scale
Top
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.CompositingResol Property

StitcherCompositingResol Property

Get or Set the compositing resolution

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double CompositingResol { get; set; }
Public Property CompositingResol As Double
    Get
    Set
public:
property double CompositingResol {
    double get ();
    void set (double value);
}
member CompositingResol : float with get, set

Property Value

Type: Double
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.PanoConfidenceThresh Property

StitcherPanoConfidenceThresh Property

Get or set the pano confidence threshold

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double PanoConfidenceThresh { get; set; }
Public Property PanoConfidenceThresh As Double
    Get
    Set
public:
property double PanoConfidenceThresh {
    double get ();
    void set (double value);
}
member PanoConfidenceThresh : float with get, set

Property Value

Type: Double
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.RegistrationResol Property

StitcherRegistrationResol Property

Get or set the registration resolution

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RegistrationResol { get; set; }
Public Property RegistrationResol As Double
    Get
    Set
public:
property double RegistrationResol {
    double get ();
    void set (double value);
}
member RegistrationResol : float with get, set

Property Value

Type: Double
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.SeamEstimationResol Property

StitcherSeamEstimationResol Property

Get or Set the seam estimation resolution

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double SeamEstimationResol { get; set; }
Public Property SeamEstimationResol As Double
    Get
    Set
public:
property double SeamEstimationResol {
    double get ();
    void set (double value);
}
member SeamEstimationResol : float with get, set

Property Value

Type: Double
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.WaveCorrection Property

StitcherWaveCorrection Property

Get or Set a flag to indicate if the stitcher should apply wave correction

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool WaveCorrection { get; set; }
Public Property WaveCorrection As Boolean
    Get
    Set
public:
property bool WaveCorrection {
    bool get ();
    void set (bool value);
}
member WaveCorrection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.WaveCorrectionKind Property

StitcherWaveCorrectionKind Property

The wave correction type.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StitcherWaveCorrectionType WaveCorrectionKind { get; set; }
Public Property WaveCorrectionKind As StitcherWaveCorrectionType
    Get
    Set
public:
property StitcherWaveCorrectionType^ WaveCorrectionKind {
    StitcherWaveCorrectionType^ get ();
    void set (StitcherWaveCorrectionType^ value);
}
member WaveCorrectionKind : StitcherWaveCorrectionType with get, set

Property Value

Type: StitcherWaveCorrectionType
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.WorkScale Property

StitcherWorkScale Property

The work scale

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double WorkScale { get; }
Public ReadOnly Property WorkScale As Double
    Get
public:
property double WorkScale {
    double get ();
}
member WorkScale : float with get

Property Value

Type: Double
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher Methods

The Stitcher type exposes the following members.

Methods
 | Name | Description
Public method | ComposePanorama(IOutputArray) | These functions try to match the given images and to estimate rotations of each camera.
Public method | ComposePanorama(IInputArrayOfArrays, IOutputArray) | These functions try to compose the given images (or images stored internally from the other function calls) into the final pano under the assumption that the image transformations were estimated before.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release memory associated with this stitcher (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EstimateTransform | These functions try to match the given images and to estimate rotations of each camera.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetBlender | Set the blender for this stitcher
Public method | SetFeaturesFinder | Set the features finder for this stitcher.
Public method | SetWarper | Set the warper creator for this stitcher.
Public method | Stitch | Compute the panoramic images given the images
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.ComposePanorama Method

StitcherComposePanorama Method

Overload List
 | Name | Description
Public method | ComposePanorama(IOutputArray) | These functions try to match the given images and to estimate rotations of each camera.
Public method | ComposePanorama(IInputArrayOfArrays, IOutputArray) | These functions try to compose the given images (or images stored internally from the other function calls) into the final pano under the assumption that the image transformations were estimated before.
Top
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.ComposePanorama Method (IOutputArray)

StitcherComposePanorama Method (IOutputArray)

http://www.emgu.com
These functions try to match the given images and to estimate rotations of each camera.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StitcherStatus ComposePanorama(
    IOutputArray pano
)
Public Function ComposePanorama (
    pano As IOutputArray
) As StitcherStatus
public:
StitcherStatus^ ComposePanorama(
    IOutputArray^ pano
)
member ComposePanorama :
        pano : IOutputArray -> StitcherStatus

Parameters

pano
Type: Emgu.CVIOutputArray
Final pano.

Return Value

Type: StitcherStatus
Status code.
See Also

Reference

Stitcher Class
ComposePanorama Overload
Emgu.CV.Stitching Namespace


Stitcher.ComposePanorama Method (IInputArrayOfArrays, IOutputArray)

StitcherComposePanorama Method (IInputArrayOfArrays, IOutputArray)

http://www.emgu.com
These functions try to compose the given images (or images stored internally from the other function calls) into the final pano under the assumption that the image transformations were estimated before.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StitcherStatus ComposePanorama(
    IInputArrayOfArrays images,
    IOutputArray pano
)
Public Function ComposePanorama (
    images As IInputArrayOfArrays,
    pano As IOutputArray
) As StitcherStatus
public:
StitcherStatus^ ComposePanorama(
    IInputArrayOfArrays^ images,
    IOutputArray^ pano
)
member ComposePanorama :
        images : IInputArrayOfArrays *
        pano : IOutputArray -> StitcherStatus

Parameters

images
Type: Emgu.CVIInputArrayOfArrays
Input images
pano
Type: Emgu.CVIOutputArray
Final pano.

Return Value

Type: StitcherStatus
Status code.
See Also

Reference

Stitcher Class
ComposePanorama Overload
Emgu.CV.Stitching Namespace


Stitcher.DisposeObject Method

StitcherDisposeObject Method

Release memory associated with this stitcher

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.EstimateTransform Method

StitcherEstimateTransform Method

These functions try to match the given images and to estimate rotations of each camera.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StitcherStatus EstimateTransform(
    IInputArrayOfArrays images,
    IInputArrayOfArrays masks = null
)
Public Function EstimateTransform (
    images As IInputArrayOfArrays,
    Optional masks As IInputArrayOfArrays = Nothing
) As StitcherStatus
public:
StitcherStatus^ EstimateTransform(
    IInputArrayOfArrays^ images,
    IInputArrayOfArrays^ masks = nullptr
)
member EstimateTransform :
        images : IInputArrayOfArrays *
        ?masks : IInputArrayOfArrays
(* Defaults:
        let _masks = defaultArg masks null
*)
-> StitcherStatus

Parameters

images
Type: Emgu.CVIInputArrayOfArrays
Input images.
masks (Optional)
Type: Emgu.CVIInputArrayOfArrays
Masks for each input image specifying where to look for keypoints (optional).

Return Value

Type: StitcherStatus
Status code.
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.SetBlender Method

StitcherSetBlender Method

Set the blender for this stitcher

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetBlender(
    Blender blender
)
Public Sub SetBlender (
    blender As Blender
)
public:
void SetBlender(
    Blender^ blender
)
member SetBlender :
        blender : Blender -> unit

Parameters

blender
Type: Emgu.CV.StitchingBlender
The blender
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.SetFeaturesFinder Method

StitcherSetFeaturesFinder Method

Set the features finder for this stitcher.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetFeaturesFinder(
    Feature2D finder
)
Public Sub SetFeaturesFinder (
    finder As Feature2D
)
public:
void SetFeaturesFinder(
    Feature2D^ finder
)
member SetFeaturesFinder :
        finder : Feature2D -> unit

Parameters

finder
Type: Emgu.CV.Features2DFeature2D
The features finder
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.SetWarper Method

StitcherSetWarper Method

Set the warper creator for this stitcher.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetWarper(
    WarperCreator warperCreator
)
Public Sub SetWarper (
    warperCreator As WarperCreator
)
public:
void SetWarper(
    WarperCreator^ warperCreator
)
member SetWarper :
        warperCreator : WarperCreator -> unit

Parameters

warperCreator
Type: Emgu.CV.StitchingWarperCreator
The warper creator
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.Stitch Method

StitcherStitch Method

Compute the panoramic images given the images

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StitcherStatus Stitch(
    IInputArray images,
    IOutputArray pano
)
Public Function Stitch (
    images As IInputArray,
    pano As IOutputArray
) As StitcherStatus
public:
StitcherStatus^ Stitch(
    IInputArray^ images,
    IOutputArray^ pano
)
member Stitch :
        images : IInputArray *
        pano : IOutputArray -> StitcherStatus

Parameters

images
Type: Emgu.CVIInputArray
The input images. This can be, for example, a VectorOfMat
pano
Type: Emgu.CVIOutputArray
The panoramic image

Return Value

Type: StitcherStatus
The stitching status
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher Fields

The Stitcher type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Stitcher Class
Emgu.CV.Stitching Namespace


Stitcher.Mode Class

StitcherMode Class

Stitch mode
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.StitchingStitcherMode

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Mode : Enum
Public NotInheritable Class Mode
    Inherits Enum
public ref class Mode sealed : public Enum
[<SealedAttribute>]
type Mode =
    class
        inherit Enum
    end

The StitcherMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Panorama | Mode for creating photo panoramas. Expects images under perspective transformation and projects resulting pano to sphere.
 | Scans | Mode for composing scans. Expects images under affine transformation does not compensate exposure by default.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Stitching Namespace


Mode Methods

The StitcherMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

StitcherMode Class
Emgu.CV.Stitching Namespace


Mode Fields

The StitcherMode type exposes the following members.

Fields
 | Name | Description
 | Panorama | Mode for creating photo panoramas. Expects images under perspective transformation and projects resulting pano to sphere.
 | Scans | Mode for composing scans. Expects images under affine transformation does not compensate exposure by default.
Public field | value__ |
Top
See Also

Reference

StitcherMode Class
Emgu.CV.Stitching Namespace


Stitcher.Mode.Panorama Field

StitcherModePanorama Field

Mode for creating photo panoramas. Expects images under perspective transformation and projects resulting pano to sphere.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherMode Panorama = 0
Public Const Panorama As StitcherMode = 0
public:
literal StitcherMode^ Panorama = 0
static val mutable Panorama: StitcherMode

Field Value

Type: StitcherMode
See Also

Reference

StitcherMode Class
Emgu.CV.Stitching Namespace


Stitcher.Mode.Scans Field

StitcherModeScans Field

Mode for composing scans. Expects images under affine transformation does not compensate exposure by default.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherMode Scans = 1
Public Const Scans As StitcherMode = 1
public:
literal StitcherMode^ Scans = 1
static val mutable Scans: StitcherMode

Field Value

Type: StitcherMode
See Also

Reference

StitcherMode Class
Emgu.CV.Stitching Namespace


Stitcher.Mode.value__ Field

StitcherModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Stitching.Stitcher.Mode.value__"]

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

StitcherMode Class
Emgu.CV.Stitching Namespace


Stitcher.Status Class

StitcherStatus Class

The stitcher statis
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.StitchingStitcherStatus

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Status : Enum
Public NotInheritable Class Status
    Inherits Enum
public ref class Status sealed : public Enum
[<SealedAttribute>]
type Status =
    class
        inherit Enum
    end

The StitcherStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ErrCameraParamsAdjustFail | Error, camera parameters adjustment failed.
 | ErrHomographyEstFail | Error, homography estimateion failed.
 | ErrNeedMoreImgs | Error, need more images.
 | Ok | Ok.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Stitching Namespace


Status Methods

The StitcherStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

StitcherStatus Class
Emgu.CV.Stitching Namespace


Status Fields

The StitcherStatus type exposes the following members.

Fields
 | Name | Description
 | ErrCameraParamsAdjustFail | Error, camera parameters adjustment failed.
 | ErrHomographyEstFail | Error, homography estimateion failed.
 | ErrNeedMoreImgs | Error, need more images.
 | Ok | Ok.
Public field | value__ |
Top
See Also

Reference

StitcherStatus Class
Emgu.CV.Stitching Namespace


Stitcher.Status.ErrCameraParamsAdjustFail Field

StitcherStatusErrCameraParamsAdjustFail Field

Error, camera parameters adjustment failed.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherStatus ErrCameraParamsAdjustFail = 3
Public Const ErrCameraParamsAdjustFail As StitcherStatus = 3
public:
literal StitcherStatus^ ErrCameraParamsAdjustFail = 3
static val mutable ErrCameraParamsAdjustFail: StitcherStatus

Field Value

Type: StitcherStatus
See Also

Reference

StitcherStatus Class
Emgu.CV.Stitching Namespace


Stitcher.Status.ErrHomographyEstFail Field

StitcherStatusErrHomographyEstFail Field

Error, homography estimateion failed.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherStatus ErrHomographyEstFail = 2
Public Const ErrHomographyEstFail As StitcherStatus = 2
public:
literal StitcherStatus^ ErrHomographyEstFail = 2
static val mutable ErrHomographyEstFail: StitcherStatus

Field Value

Type: StitcherStatus
See Also

Reference

StitcherStatus Class
Emgu.CV.Stitching Namespace


Stitcher.Status.ErrNeedMoreImgs Field

StitcherStatusErrNeedMoreImgs Field

Error, need more images.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherStatus ErrNeedMoreImgs = 1
Public Const ErrNeedMoreImgs As StitcherStatus = 1
public:
literal StitcherStatus^ ErrNeedMoreImgs = 1
static val mutable ErrNeedMoreImgs: StitcherStatus

Field Value

Type: StitcherStatus
See Also

Reference

StitcherStatus Class
Emgu.CV.Stitching Namespace


Stitcher.Status.Ok Field

StitcherStatusOk Field

Ok.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherStatus Ok = 0
Public Const Ok As StitcherStatus = 0
public:
literal StitcherStatus^ Ok = 0
static val mutable Ok: StitcherStatus

Field Value

Type: StitcherStatus
See Also

Reference

StitcherStatus Class
Emgu.CV.Stitching Namespace


Stitcher.Status.value__ Field

StitcherStatusvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Stitching.Stitcher.Status.value__"]

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

StitcherStatus Class
Emgu.CV.Stitching Namespace


Stitcher.WaveCorrectionType Class

StitcherWaveCorrectionType Class

Wave correction kind
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.StitchingStitcherWaveCorrectionType

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class WaveCorrectionType : Enum
Public NotInheritable Class WaveCorrectionType
    Inherits Enum
public ref class WaveCorrectionType sealed : public Enum
[<SealedAttribute>]
type WaveCorrectionType =
    class
        inherit Enum
    end

The StitcherWaveCorrectionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Horiz | horizontal
Public field | value__ |
 | Vert | Vertical
Top
See Also

Reference

Emgu.CV.Stitching Namespace


WaveCorrectionType Methods

The StitcherWaveCorrectionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

StitcherWaveCorrectionType Class
Emgu.CV.Stitching Namespace


WaveCorrectionType Fields

The StitcherWaveCorrectionType type exposes the following members.

Fields
 | Name | Description
 | Horiz | horizontal
Public field | value__ |
 | Vert | Vertical
Top
See Also

Reference

StitcherWaveCorrectionType Class
Emgu.CV.Stitching Namespace


Stitcher.WaveCorrectionType.Horiz Field

StitcherWaveCorrectionTypeHoriz Field

horizontal

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherWaveCorrectionType Horiz = 0
Public Const Horiz As StitcherWaveCorrectionType = 0
public:
literal StitcherWaveCorrectionType^ Horiz = 0
static val mutable Horiz: StitcherWaveCorrectionType

Field Value

Type: StitcherWaveCorrectionType
See Also

Reference

StitcherWaveCorrectionType Class
Emgu.CV.Stitching Namespace


Stitcher.WaveCorrectionType.value__ Field

StitcherWaveCorrectionTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Stitching.Stitcher.WaveCorrectionType.value__"]

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

StitcherWaveCorrectionType Class
Emgu.CV.Stitching Namespace


Stitcher.WaveCorrectionType.Vert Field

StitcherWaveCorrectionTypeVert Field

Vertical

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const StitcherWaveCorrectionType Vert = 1
Public Const Vert As StitcherWaveCorrectionType = 1
public:
literal StitcherWaveCorrectionType^ Vert = 1
static val mutable Vert: StitcherWaveCorrectionType

Field Value

Type: StitcherWaveCorrectionType
See Also

Reference

StitcherWaveCorrectionType Class
Emgu.CV.Stitching Namespace


StitchingInvoke Class

Entry points to the Open CV Stitching module.
Inheritance Hierarchy
SystemObject
Emgu.CV.StitchingStitchingInvoke

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class StitchingInvoke
Public NotInheritable Class StitchingInvoke
public ref class StitchingInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StitchingInvoke =  class end
See Also

Reference

Emgu.CV.Stitching Namespace


TransverseMercatorWarper Class

Transverse mercator warper
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingTransverseMercatorWarper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TransverseMercatorWarper : WarperCreator
Public Class TransverseMercatorWarper
    Inherits WarperCreator
public ref class TransverseMercatorWarper : public WarperCreator
type TransverseMercatorWarper =
    class
        inherit WarperCreator
    end

The TransverseMercatorWarper type exposes the following members.

Constructors
 | Name | Description
Public method | TransverseMercatorWarper | Create a transverse mercator warper
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

Emgu.CV.Stitching Namespace


TransverseMercatorWarper Constructor

Create a transverse mercator warper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TransverseMercatorWarper(
    float scale
)
Public Sub New (
    scale As Single
)
public:
TransverseMercatorWarper(
    float scale
)
new :
        scale : float32 -> TransverseMercatorWarper

Parameters

scale
Type: SystemSingle
Projected image scale multiplier
See Also

Reference

TransverseMercatorWarper Class
Emgu.CV.Stitching Namespace


TransverseMercatorWarper Properties

The TransverseMercatorWarper type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

TransverseMercatorWarper Class
Emgu.CV.Stitching Namespace


TransverseMercatorWarper Methods

The TransverseMercatorWarper type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data. (Inherited from WarperCreator.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this wraper (Overrides WarperCreatorDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image. (Inherited from WarperCreator.)
Top
See Also

Reference

TransverseMercatorWarper Class
Emgu.CV.Stitching Namespace


TransverseMercatorWarper.DisposeObject Method

TransverseMercatorWarperDisposeObject Method

Release the unmanaged memory associated with this wraper

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TransverseMercatorWarper Class
Emgu.CV.Stitching Namespace


TransverseMercatorWarper Fields

The TransverseMercatorWarper type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object (Inherited from WarperCreator.)
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object (Inherited from WarperCreator.)
Top
See Also

Reference

TransverseMercatorWarper Class
Emgu.CV.Stitching Namespace


WarperCreator Class

Finds features in the given image.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
More...

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class WarperCreator : UnmanagedObject
Public MustInherit Class WarperCreator
    Inherits UnmanagedObject
public ref class WarperCreator abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type WarperCreator =
    class
        inherit UnmanagedObject
    end

The WarperCreator type exposes the following members.

Constructors
 | Name | Description
Protected method | WarperCreator | Initializes a new instance of the WarperCreator class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object
Top
Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the unmanaged pointer associated to this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object
Top
See Also

Reference

Emgu.CV.Stitching Namespace
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.StitchingWarperCreator
Emgu.CV.StitchingCompressedRectilinearWarper
Emgu.CV.StitchingFisheyeWarper
Emgu.CV.StitchingMercatorWarper
Emgu.CV.StitchingPaniniPortraitWarper
Emgu.CV.StitchingPaniniWarper
Emgu.CV.StitchingPlaneWarper
Emgu.CV.StitchingSphericalWarper
Emgu.CV.StitchingStereographicWarper
Emgu.CV.StitchingTransverseMercatorWarper


WarperCreator Constructor

Initializes a new instance of the WarperCreator class

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected WarperCreator()
Protected Sub New
protected:
WarperCreator()
new : unit -> WarperCreator
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator Properties

The WarperCreator type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | WarperCreatorPtr | Get a pointer to the unmanaged WarperCreator object
Top
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator.WarperCreatorPtr Property

WarperCreatorWarperCreatorPtr Property

Get a pointer to the unmanaged WarperCreator object

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr WarperCreatorPtr { get; }
Public ReadOnly Property WarperCreatorPtr As IntPtr
    Get
public:
property IntPtr WarperCreatorPtr {
    IntPtr get ();
}
member WarperCreatorPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator Methods

The WarperCreator type exposes the following members.

Methods
 | Name | Description
Public method | BuildMaps | Builds the projection maps according to the given camera data.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the unmanaged pointer associated to this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warp | Projects the image.
Top
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator.BuildMaps Method

WarperCreatorBuildMaps Method

Builds the projection maps according to the given camera data.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle BuildMaps(
    Size srcSize,
    IInputArray K,
    IInputArray R,
    IOutputArray xmap,
    IOutputArray ymap
)
Public Function BuildMaps (
    srcSize As Size,
    K As IInputArray,
    R As IInputArray,
    xmap As IOutputArray,
    ymap As IOutputArray
) As Rectangle
public:
Rectangle^ BuildMaps(
    Size^ srcSize,
    IInputArray^ K,
    IInputArray^ R,
    IOutputArray^ xmap,
    IOutputArray^ ymap
)
member BuildMaps :
        srcSize : Size *
        K : IInputArray *
        R : IInputArray *
        xmap : IOutputArray *
        ymap : IOutputArray -> Rectangle

Parameters

srcSize
Type: System.DrawingSize
Source image size
K
Type: Emgu.CVIInputArray
Camera intrinsic parameters
R
Type: Emgu.CVIInputArray
Camera rotation matrix
xmap
Type: Emgu.CVIOutputArray
Projection map for the x axis
ymap
Type: Emgu.CVIOutputArray
Projection map for the y axis

Return Value

Type: Rectangle
Projected image minimum bounding box
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator.DisposeObject Method

WarperCreatorDisposeObject Method

Reset the unmanaged pointer associated to this object

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator.Warp Method

WarperCreatorWarp Method

Projects the image.

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point Warp(
    IInputArray src,
    IInputArray K,
    IInputArray R,
    Inter interpMode,
    BorderType borderMode,
    IOutputArray dst
)
Public Function Warp (
    src As IInputArray,
    K As IInputArray,
    R As IInputArray,
    interpMode As Inter,
    borderMode As BorderType,
    dst As IOutputArray
) As Point
public:
Point^ Warp(
    IInputArray^ src,
    IInputArray^ K,
    IInputArray^ R,
    Inter^ interpMode,
    BorderType^ borderMode,
    IOutputArray^ dst
)
member Warp :
        src : IInputArray *
        K : IInputArray *
        R : IInputArray *
        interpMode : Inter *
        borderMode : BorderType *
        dst : IOutputArray -> Point

Parameters

src
Type: Emgu.CVIInputArray
Source image
K
Type: Emgu.CVIInputArray
Camera intrinsic parameters
R
Type: Emgu.CVIInputArray
Camera rotation matrix
interpMode
Type: Emgu.CV.CvEnumInter
Interpolation mode
borderMode
Type: Emgu.CV.CvEnumBorderType
Border extrapolation mode
dst
Type: Emgu.CVIOutputArray
Projected image

Return Value

Type: Point
Project image top-left corner
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator Fields

The WarperCreator type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _rotationWarper | Pointer to the unmanaged RotationWarper object
Protected field | _warperCreatorPtr | Pointer to the unmanaged WarperCreator object
Top
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator._rotationWarper Field

WarperCreator_rotationWarper Field

Pointer to the unmanaged RotationWarper object

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _rotationWarper
Protected _rotationWarper As IntPtr
protected:
IntPtr _rotationWarper
val mutable _rotationWarper: IntPtr

Field Value

Type: IntPtr
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


WarperCreator._warperCreatorPtr Field

WarperCreator_warperCreatorPtr Field

Pointer to the unmanaged WarperCreator object

Namespace: Emgu.CV.Stitching
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _warperCreatorPtr
Protected _warperCreatorPtr As IntPtr
protected:
IntPtr _warperCreatorPtr
val mutable _warperCreatorPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

WarperCreator Class
Emgu.CV.Stitching Namespace


Emgu.CV.Structure Namespace

Wrapped OpenCV structures
Classes
 | Class | Description
Public class | Bgr | Defines a Bgr (Blue Green Red) color
Public class | Bgr565 | Defines a Bgr565 (Blue Green Red) color
Public class | Bgra | Defines a Bgra (Blue Green Red Alpha) color
Public class | CircleF | A circle
Public class | ColorPoint | A point with Bgr color information
Public class | Cross2DF | A 2D cross
Public class | Cuboid | A solid resembling a cube, with the rectangular faces not all equal; a rectangular parallelepiped.
Public class | CvStructSizes | This is used to hold the sizes of the Open CV structures
Public class | Ellipse | An ellipse
Public class | Gray | Defines a Gray color
Public class | Hls | Defines a Hls (Hue Lightness Satuation) color
Public class | Hsv | Defines a HSV (Hue Satuation Value) color
Public class | Lab | Defines a CIE Lab color
Public class | LineSegment2D | A line segment
Public class | LineSegment2DF | A line segment
Public class | LineSegment3DF | A 3D line segment
Public class | Luv | Defines a CIE Luv color
Public class | MCvAvgComp | Result of cvHaarDetectObjects
Public class | MCvMat | Managed structure equivalent to CvMat
Public class | MCvMatND | Managed structure equivalent to CvMatND
Public class | MCvMatNDDimension | The MatND Dimension
Public class | MCvObjectDetection | Structure contains the bounding box and confidence level for detected object
Public class | MCvPoint2D64f | Managed Structure equivalent to CvPoint2D64f
Public class | MCvPoint3D32f | Managed Structure equivalent to CvPoint3D32f
Public class | MCvPoint3D64f | Managed Structure equivalent to CvPoint3D64f
Public class | MCvScalar | Managed structure equivalent to CvScalar
Public class | MCvSlice | Managed structure equivalent to CvSlice
Public class | MCvTermCriteria | Managed structure equivalent to CvTermCriteria
Public class | MDMatch | OpenCV's DMatch structure
Public class | MIplImage | Managed structure equivalent to IplImage
Public class | MKeyPoint | OpenCV's KeyPoint class
Public class | Range | The range use to setup the histogram
Public class | RangeF | The range use to setup the histogram
Public class | Rgb | Defines a Rgb (Red Green Blue) color
Public class | Rgba | Defines a Rgba (Red Green Blue Alpha) color
Public class | RotatedRect | Managed structure equivalent to CvBox2D
Public class | Triangle2DF | A 2D triangle
Public class | Triangle3DF | A 3D triangle
Public class | Xyz | Defines a Xyz color (CIE XYZ.Rec 709 with D65 white point)
Public class | Ycc | Defines a Ycc color (YCrCb JPEG)


Bgr Class

Defines a Bgr (Blue Green Red) color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureBgr

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Bgr : ValueType, IColor,
    IEquatable<Bgr>
Public NotInheritable Class Bgr
    Inherits ValueType
    Implements IColor, IEquatable(Of Bgr)
public ref class Bgr sealed : public ValueType,
    IColor, IEquatable<Bgr^>
[<SealedAttribute>]
type Bgr =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Bgr>
    end

The Bgr type exposes the following members.

Constructors
 | Name | Description
Public method | Bgr(Color) | Create a Bgr color using the System.Drawing.Color
Public method | Bgr(Double, Double, Double) | Create a BGR color using the specific values
Top
Properties
 | Name | Description
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgr) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Bgr Constructor

Overload List
 | Name | Description
Public method | Bgr(Color) | Create a Bgr color using the System.Drawing.Color
Public method | Bgr(Double, Double, Double) | Create a BGR color using the specific values
Top
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr Constructor (Color)

Create a Bgr color using the System.Drawing.Color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Bgr(
    Color winColor
)
Public Sub New (
    winColor As Color
)
public:
Bgr(
    Color^ winColor
)
new :
        winColor : Color -> Bgr

Parameters

winColor
Type: System.DrawingColor
System.Drawing.Color
See Also

Reference

Bgr Class
Bgr Overload
Emgu.CV.Structure Namespace


Bgr Constructor (Double, Double, Double)

Create a BGR color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Bgr(
    double blue,
    double green,
    double red
)
Public Sub New (
    blue As Double,
    green As Double,
    red As Double
)
public:
Bgr(
    double blue,
    double green,
    double red
)
new :
        blue : float *
        green : float *
        red : float -> Bgr

Parameters

blue
Type: SystemDouble
The blue value for this color
green
Type: SystemDouble
The green value for this color
red
Type: SystemDouble
The red value for this color
See Also

Reference

Bgr Class
Bgr Overload
Emgu.CV.Structure Namespace


Bgr Properties

The Bgr type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr.Blue Property

BgrBlue Property

Get or set the intensity of the blue color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Blue { get; set; }
Public Property Blue As Double
    Get
    Set
public:
property double Blue {
    double get ();
    void set (double value);
}
member Blue : float with get, set

Property Value

Type: Double
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr.Dimension Property

BgrDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr.Green Property

BgrGreen Property

Get or set the intensity of the green color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Green { get; set; }
Public Property Green As Double
    Get
    Set
public:
property double Green {
    double get ();
    void set (double value);
}
member Green : float with get, set

Property Value

Type: Double
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr.MCvScalar Property

BgrMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr.Red Property

BgrRed Property

Get or set the intensity of the red color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Red { get; set; }
Public Property Red As Double
    Get
    Set
public:
property double Red {
    double get ();
    void set (double value);
}
member Red : float with get, set

Property Value

Type: Double
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr Methods

The Bgr type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgr) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr.Equals Method

BgrEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgr) | Return true if the two color equals
Top
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr.Equals Method (Bgr)

BgrEquals Method (Bgr)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Bgr other
)
Public Function Equals (
    other As Bgr
) As Boolean
public:
virtual bool Equals(
    Bgr^ other
) sealed
abstract Equals :
        other : Bgr -> bool
override Equals :
        other : Bgr -> bool

Parameters

other
Type: Emgu.CV.StructureBgr
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Bgr Class
Equals Overload
Emgu.CV.Structure Namespace


Bgr.ToString Method

BgrToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Bgr Class
Emgu.CV.Structure Namespace


Bgr565 Class

Defines a Bgr565 (Blue Green Red) color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureBgr565

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Bgr565 : ValueType,
    IColor, IEquatable<Bgr565>
Public NotInheritable Class Bgr565
    Inherits ValueType
    Implements IColor, IEquatable(Of Bgr565)
public ref class Bgr565 sealed : public ValueType,
    IColor, IEquatable<Bgr565^>
[<SealedAttribute>]
type Bgr565 =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Bgr565>
    end

The Bgr565 type exposes the following members.

Constructors
 | Name | Description
Public method | Bgr565(Color) | Create a Bgr565 color using the System.Drawing.Color
Public method | Bgr565(Double, Double, Double) | Create a Bgr565 color using the specific values
Top
Properties
 | Name | Description
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgr565) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Bgr565 Constructor

Overload List
 | Name | Description
Public method | Bgr565(Color) | Create a Bgr565 color using the System.Drawing.Color
Public method | Bgr565(Double, Double, Double) | Create a Bgr565 color using the specific values
Top
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565 Constructor (Color)

Create a Bgr565 color using the System.Drawing.Color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Bgr565(
    Color winColor
)
Public Sub New (
    winColor As Color
)
public:
Bgr565(
    Color^ winColor
)
new :
        winColor : Color -> Bgr565

Parameters

winColor
Type: System.DrawingColor
System.Drawing.Color
See Also

Reference

Bgr565 Class
Bgr565 Overload
Emgu.CV.Structure Namespace


Bgr565 Constructor (Double, Double, Double)

Create a Bgr565 color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Bgr565(
    double red,
    double green,
    double blue
)
Public Sub New (
    red As Double,
    green As Double,
    blue As Double
)
public:
Bgr565(
    double red,
    double green,
    double blue
)
new :
        red : float *
        green : float *
        blue : float -> Bgr565

Parameters

red
Type: SystemDouble
The red value for this color
green
Type: SystemDouble
The green value for this color
blue
Type: SystemDouble
The blue value for this color
See Also

Reference

Bgr565 Class
Bgr565 Overload
Emgu.CV.Structure Namespace


Bgr565 Properties

The Bgr565 type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565.Blue Property

Bgr565Blue Property

Get or set the intensity of the blue color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Blue { get; set; }
Public Property Blue As Double
    Get
    Set
public:
property double Blue {
    double get ();
    void set (double value);
}
member Blue : float with get, set

Property Value

Type: Double
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565.Dimension Property

Bgr565Dimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565.Green Property

Bgr565Green Property

Get or set the intensity of the green color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Green { get; set; }
Public Property Green As Double
    Get
    Set
public:
property double Green {
    double get ();
    void set (double value);
}
member Green : float with get, set

Property Value

Type: Double
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565.MCvScalar Property

Bgr565MCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565.Red Property

Bgr565Red Property

Get or set the intensity of the red color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Red { get; set; }
Public Property Red As Double
    Get
    Set
public:
property double Red {
    double get ();
    void set (double value);
}
member Red : float with get, set

Property Value

Type: Double
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565 Methods

The Bgr565 type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgr565) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565.Equals Method

Bgr565Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgr565) | Return true if the two color equals
Top
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgr565.Equals Method (Bgr565)

Bgr565Equals Method (Bgr565)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Bgr565 other
)
Public Function Equals (
    other As Bgr565
) As Boolean
public:
virtual bool Equals(
    Bgr565^ other
) sealed
abstract Equals :
        other : Bgr565 -> bool
override Equals :
        other : Bgr565 -> bool

Parameters

other
Type: Emgu.CV.StructureBgr565
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Bgr565 Class
Equals Overload
Emgu.CV.Structure Namespace


Bgr565.ToString Method

Bgr565ToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Bgr565 Class
Emgu.CV.Structure Namespace


Bgra Class

Defines a Bgra (Blue Green Red Alpha) color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureBgra

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Bgra : ValueType, IColor,
    IEquatable<Bgra>
Public NotInheritable Class Bgra
    Inherits ValueType
    Implements IColor, IEquatable(Of Bgra)
public ref class Bgra sealed : public ValueType,
    IColor, IEquatable<Bgra^>
[<SealedAttribute>]
type Bgra =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Bgra>
    end

The Bgra type exposes the following members.

Constructors
 | Name | Description
Public method | Bgra | Create a BGRA color using the specific values
Top
Properties
 | Name | Description
Public property | Alpha | Get or set the intensity of the alpha color channel
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgra) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Bgra Constructor

Create a BGRA color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Bgra(
    double blue,
    double green,
    double red,
    double alpha
)
Public Sub New (
    blue As Double,
    green As Double,
    red As Double,
    alpha As Double
)
public:
Bgra(
    double blue,
    double green,
    double red,
    double alpha
)
new :
        blue : float *
        green : float *
        red : float *
        alpha : float -> Bgra

Parameters

blue
Type: SystemDouble
The blue value for this color
green
Type: SystemDouble
The green value for this color
red
Type: SystemDouble
The red value for this color
alpha
Type: SystemDouble
The alpha value for this color
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra Properties

The Bgra type exposes the following members.

Properties
 | Name | Description
Public property | Alpha | Get or set the intensity of the alpha color channel
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.Alpha Property

BgraAlpha Property

Get or set the intensity of the alpha color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Alpha { get; set; }
Public Property Alpha As Double
    Get
    Set
public:
property double Alpha {
    double get ();
    void set (double value);
}
member Alpha : float with get, set

Property Value

Type: Double
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.Blue Property

BgraBlue Property

Get or set the intensity of the blue color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Blue { get; set; }
Public Property Blue As Double
    Get
    Set
public:
property double Blue {
    double get ();
    void set (double value);
}
member Blue : float with get, set

Property Value

Type: Double
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.Dimension Property

BgraDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.Green Property

BgraGreen Property

Get or set the intensity of the green color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Green { get; set; }
Public Property Green As Double
    Get
    Set
public:
property double Green {
    double get ();
    void set (double value);
}
member Green : float with get, set

Property Value

Type: Double
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.MCvScalar Property

BgraMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.Red Property

BgraRed Property

Get or set the intensity of the red color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Red { get; set; }
Public Property Red As Double
    Get
    Set
public:
property double Red {
    double get ();
    void set (double value);
}
member Red : float with get, set

Property Value

Type: Double
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra Methods

The Bgra type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgra) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.Equals Method

BgraEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Bgra) | Return true if the two color equals
Top
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


Bgra.Equals Method (Bgra)

BgraEquals Method (Bgra)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Bgra other
)
Public Function Equals (
    other As Bgra
) As Boolean
public:
virtual bool Equals(
    Bgra^ other
) sealed
abstract Equals :
        other : Bgra -> bool
override Equals :
        other : Bgra -> bool

Parameters

other
Type: Emgu.CV.StructureBgra
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Bgra Class
Equals Overload
Emgu.CV.Structure Namespace


Bgra.ToString Method

BgraToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Bgra Class
Emgu.CV.Structure Namespace


CircleF Class

A circle
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureCircleF

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class CircleF : ValueType,
    IEquatable<CircleF>
<SerializableAttribute>
Public NotInheritable Class CircleF
    Inherits ValueType
    Implements IEquatable(Of CircleF)
[SerializableAttribute]
public ref class CircleF sealed : public ValueType,
    IEquatable<CircleF^>
[<SealedAttribute>]
[<SerializableAttribute>]
type CircleF =
    class
        inherit ValueType
        interface IEquatable<CircleF>
    end

The CircleF type exposes the following members.

Constructors
 | Name | Description
Public method | CircleF | Create a circle with the specific center and radius
Top
Properties
 | Name | Description
Public property | Area | The area of the circle
Public property | Center | Get or Set the center of the circle
Public property | Radius | The radius of the circle
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(CircleF) | Compare this circle with circle2
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


CircleF Constructor

Create a circle with the specific center and radius

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CircleF(
    PointF center,
    float radius
)
Public Sub New (
    center As PointF,
    radius As Single
)
public:
CircleF(
    PointF^ center,
    float radius
)
new :
        center : PointF *
        radius : float32 -> CircleF

Parameters

center
Type: System.DrawingPointF
The center of this circle
radius
Type: SystemSingle
The radius of this circle
See Also

Reference

CircleF Class
Emgu.CV.Structure Namespace


CircleF Properties

The CircleF type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of the circle
Public property | Center | Get or Set the center of the circle
Public property | Radius | The radius of the circle
Top
See Also

Reference

CircleF Class
Emgu.CV.Structure Namespace


CircleF.Area Property

CircleFArea Property

The area of the circle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Type: Double
See Also

Reference

CircleF Class
Emgu.CV.Structure Namespace


CircleF.Center Property

CircleFCenter Property

Get or Set the center of the circle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Center { get; set; }
Public Property Center As PointF
    Get
    Set
public:
property PointF^ Center {
    PointF^ get ();
    void set (PointF^ value);
}
member Center : PointF with get, set

Property Value

Type: PointF
See Also

Reference

CircleF Class
Emgu.CV.Structure Namespace


CircleF.Radius Property

CircleFRadius Property

The radius of the circle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Radius { get; set; }
Public Property Radius As Single
    Get
    Set
public:
property float Radius {
    float get ();
    void set (float value);
}
member Radius : float32 with get, set

Property Value

Type: Single
See Also

Reference

CircleF Class
Emgu.CV.Structure Namespace


CircleF Methods

The CircleF type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(CircleF) | Compare this circle with circle2
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

CircleF Class
Emgu.CV.Structure Namespace


CircleF.Equals Method

CircleFEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(CircleF) | Compare this circle with circle2
Top
See Also

Reference

CircleF Class
Emgu.CV.Structure Namespace


CircleF.Equals Method (CircleF)

CircleFEquals Method (CircleF)

http://www.emgu.com
Compare this circle with circle2

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    CircleF circle2
)
Public Function Equals (
    circle2 As CircleF
) As Boolean
public:
virtual bool Equals(
    CircleF^ circle2
) sealed
abstract Equals :
        circle2 : CircleF -> bool
override Equals :
        circle2 : CircleF -> bool

Parameters

circle2
Type: Emgu.CV.StructureCircleF
The other box to be compared

Return Value

Type: Boolean
true if the two boxes equals

Implements

IEquatableTEquals(T)
See Also

Reference

CircleF Class
Equals Overload
Emgu.CV.Structure Namespace


ColorPoint Class

A point with Bgr color information
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureColorPoint

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ColorPoint : ValueType
Public NotInheritable Class ColorPoint
    Inherits ValueType
public ref class ColorPoint sealed : public ValueType
[<SealedAttribute>]
type ColorPoint =
    class
        inherit ValueType
    end

The ColorPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Blue | The blue color
Public field | Green | The green color
Public field | Position | The position in meters
Public field | Red | The red color
Top
See Also

Reference

Emgu.CV.Structure Namespace


ColorPoint Methods

The ColorPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ColorPoint Class
Emgu.CV.Structure Namespace


ColorPoint Fields

The ColorPoint type exposes the following members.

Fields
 | Name | Description
Public field | Blue | The blue color
Public field | Green | The green color
Public field | Position | The position in meters
Public field | Red | The red color
Top
See Also

Reference

ColorPoint Class
Emgu.CV.Structure Namespace


ColorPoint.Blue Field

ColorPointBlue Field

The blue color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Blue
Public Blue As Byte
public:
unsigned char Blue
val mutable Blue: byte

Field Value

Type: Byte
See Also

Reference

ColorPoint Class
Emgu.CV.Structure Namespace


ColorPoint.Green Field

ColorPointGreen Field

The green color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Green
Public Green As Byte
public:
unsigned char Green
val mutable Green: byte

Field Value

Type: Byte
See Also

Reference

ColorPoint Class
Emgu.CV.Structure Namespace


ColorPoint.Position Field

ColorPointPosition Field

The position in meters

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f Position
Public Position As MCvPoint3D32f
public:
MCvPoint3D32f^ Position
val mutable Position: MCvPoint3D32f

Field Value

Type: MCvPoint3D32f
See Also

Reference

ColorPoint Class
Emgu.CV.Structure Namespace


ColorPoint.Red Field

ColorPointRed Field

The red color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Red
Public Red As Byte
public:
unsigned char Red
val mutable Red: byte

Field Value

Type: Byte
See Also

Reference

ColorPoint Class
Emgu.CV.Structure Namespace


Cross2DF Class

A 2D cross
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureCross2DF

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Cross2DF : ValueType
<SerializableAttribute>
Public NotInheritable Class Cross2DF
    Inherits ValueType
[SerializableAttribute]
public ref class Cross2DF sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type Cross2DF =
    class
        inherit ValueType
    end

The Cross2DF type exposes the following members.

Constructors
 | Name | Description
Public method | Cross2DF | Construct a cross
Top
Properties
 | Name | Description
Public property | Center | The center of this cross
Public property | Horizontal | Get the horizonal linesegment of this cross
Public property | Size | The size of this cross
Public property | Vertical | Get the vertical linesegment of this cross
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Cross2DF Constructor

Construct a cross

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Cross2DF(
    PointF center,
    float width,
    float height
)
Public Sub New (
    center As PointF,
    width As Single,
    height As Single
)
public:
Cross2DF(
    PointF^ center,
    float width,
    float height
)
new :
        center : PointF *
        width : float32 *
        height : float32 -> Cross2DF

Parameters

center
Type: System.DrawingPointF
The center of the cross
width
Type: SystemSingle
the width of the cross
height
Type: SystemSingle
the height of the cross
See Also

Reference

Cross2DF Class
Emgu.CV.Structure Namespace


Cross2DF Properties

The Cross2DF type exposes the following members.

Properties
 | Name | Description
Public property | Center | The center of this cross
Public property | Horizontal | Get the horizonal linesegment of this cross
Public property | Size | The size of this cross
Public property | Vertical | Get the vertical linesegment of this cross
Top
See Also

Reference

Cross2DF Class
Emgu.CV.Structure Namespace


Cross2DF.Center Property

Cross2DFCenter Property

The center of this cross

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Center { get; set; }
Public Property Center As PointF
    Get
    Set
public:
property PointF^ Center {
    PointF^ get ();
    void set (PointF^ value);
}
member Center : PointF with get, set

Property Value

Type: PointF
See Also

Reference

Cross2DF Class
Emgu.CV.Structure Namespace


Cross2DF.Horizontal Property

Cross2DFHorizontal Property

Get the horizonal linesegment of this cross

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment2DF Horizontal { get; }
Public ReadOnly Property Horizontal As LineSegment2DF
    Get
public:
property LineSegment2DF^ Horizontal {
    LineSegment2DF^ get ();
}
member Horizontal : LineSegment2DF with get

Property Value

Type: LineSegment2DF
See Also

Reference

Cross2DF Class
Emgu.CV.Structure Namespace


Cross2DF.Size Property

Cross2DFSize Property

The size of this cross

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SizeF Size { get; set; }
Public Property Size As SizeF
    Get
    Set
public:
property SizeF^ Size {
    SizeF^ get ();
    void set (SizeF^ value);
}
member Size : SizeF with get, set

Property Value

Type: SizeF
See Also

Reference

Cross2DF Class
Emgu.CV.Structure Namespace


Cross2DF.Vertical Property

Cross2DFVertical Property

Get the vertical linesegment of this cross

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment2DF Vertical { get; }
Public ReadOnly Property Vertical As LineSegment2DF
    Get
public:
property LineSegment2DF^ Vertical {
    LineSegment2DF^ get ();
}
member Vertical : LineSegment2DF with get

Property Value

Type: LineSegment2DF
See Also

Reference

Cross2DF Class
Emgu.CV.Structure Namespace


Cross2DF Methods

The Cross2DF type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Cross2DF Class
Emgu.CV.Structure Namespace


Cuboid Class

A solid resembling a cube, with the rectangular faces not all equal; a rectangular parallelepiped.
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureCuboid

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Cuboid : ValueType
<SerializableAttribute>
Public NotInheritable Class Cuboid
    Inherits ValueType
[SerializableAttribute]
public ref class Cuboid sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type Cuboid =
    class
        inherit ValueType
    end

The Cuboid type exposes the following members.

Properties
 | Name | Description
Public property | Centroid | Get the centroid of this cuboid
Top
Methods
 | Name | Description
Public method | Contains | Check if the specific point is in the Cuboid
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Max | The coordinate of the lower corner
Public field | Min | The coordinate of the upper corner
Top
See Also

Reference

Emgu.CV.Structure Namespace


Cuboid Properties

The Cuboid type exposes the following members.

Properties
 | Name | Description
Public property | Centroid | Get the centroid of this cuboid
Top
See Also

Reference

Cuboid Class
Emgu.CV.Structure Namespace


Cuboid.Centroid Property

CuboidCentroid Property

Get the centroid of this cuboid

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f Centroid { get; }
Public ReadOnly Property Centroid As MCvPoint3D64f
    Get
public:
property MCvPoint3D64f^ Centroid {
    MCvPoint3D64f^ get ();
}
member Centroid : MCvPoint3D64f with get

Property Value

Type: MCvPoint3D64f
See Also

Reference

Cuboid Class
Emgu.CV.Structure Namespace


Cuboid Methods

The Cuboid type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Check if the specific point is in the Cuboid
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Cuboid Class
Emgu.CV.Structure Namespace


Cuboid.Contains Method

CuboidContains Method

Check if the specific point is in the Cuboid

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    MCvPoint3D64f point
)
Public Function Contains (
    point As MCvPoint3D64f
) As Boolean
public:
bool Contains(
    MCvPoint3D64f^ point
)
member Contains :
        point : MCvPoint3D64f -> bool

Parameters

point
Type: Emgu.CV.StructureMCvPoint3D64f
The point to be checked

Return Value

Type: Boolean
True if the point is in the cuboid
See Also

Reference

Cuboid Class
Emgu.CV.Structure Namespace


Cuboid Fields

The Cuboid type exposes the following members.

Fields
 | Name | Description
Public field | Max | The coordinate of the lower corner
Public field | Min | The coordinate of the upper corner
Top
See Also

Reference

Cuboid Class
Emgu.CV.Structure Namespace


Cuboid.Max Field

CuboidMax Field

The coordinate of the lower corner

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f Max
Public Max As MCvPoint3D64f
public:
MCvPoint3D64f^ Max
val mutable Max: MCvPoint3D64f

Field Value

Type: MCvPoint3D64f
See Also

Reference

Cuboid Class
Emgu.CV.Structure Namespace


Cuboid.Min Field

CuboidMin Field

The coordinate of the upper corner

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f Min
Public Min As MCvPoint3D64f
public:
MCvPoint3D64f^ Min
val mutable Min: MCvPoint3D64f

Field Value

Type: MCvPoint3D64f
See Also

Reference

Cuboid Class
Emgu.CV.Structure Namespace


CvStructSizes Class

This is used to hold the sizes of the Open CV structures
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureCvStructSizes

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class CvStructSizes : ValueType
Public NotInheritable Class CvStructSizes
    Inherits ValueType
public ref class CvStructSizes sealed : public ValueType
[<SealedAttribute>]
type CvStructSizes =
    class
        inherit ValueType
    end

The CvStructSizes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | CvBox2D | The size of CvBox2D
Public field | CvMat | The size of CvMat
Public field | CvMatND | The size of CvMatND
Public field | CvPoint | The size of CvPoint
Public field | CvPoint2D32f | The size of CvPoint2D32f
Public field | CvPoint3D32f | The size of CvPoint3D32f
Public field | CvRect | The size of CvRect
Public field | CvScalar | The size of CvScalar
Public field | CvSize | The size of CvSize
Public field | CvSize2D32f | The size of CvSize2D32f
Public field | CvTermCriteria | The size of CvTermCriteria
Public field | IplImage | The size of IplImage
Top
See Also

Reference

Emgu.CV.Structure Namespace


CvStructSizes Methods

The CvStructSizes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes Fields

The CvStructSizes type exposes the following members.

Fields
 | Name | Description
Public field | CvBox2D | The size of CvBox2D
Public field | CvMat | The size of CvMat
Public field | CvMatND | The size of CvMatND
Public field | CvPoint | The size of CvPoint
Public field | CvPoint2D32f | The size of CvPoint2D32f
Public field | CvPoint3D32f | The size of CvPoint3D32f
Public field | CvRect | The size of CvRect
Public field | CvScalar | The size of CvScalar
Public field | CvSize | The size of CvSize
Public field | CvSize2D32f | The size of CvSize2D32f
Public field | CvTermCriteria | The size of CvTermCriteria
Public field | IplImage | The size of IplImage
Top
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvBox2D Field

CvStructSizesCvBox2D Field

The size of CvBox2D

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvBox2D
Public CvBox2D As Integer
public:
int CvBox2D
val mutable CvBox2D: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvMat Field

CvStructSizesCvMat Field

The size of CvMat

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvMat
Public CvMat As Integer
public:
int CvMat
val mutable CvMat: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvMatND Field

CvStructSizesCvMatND Field

The size of CvMatND

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvMatND
Public CvMatND As Integer
public:
int CvMatND
val mutable CvMatND: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvPoint Field

CvStructSizesCvPoint Field

The size of CvPoint

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvPoint
Public CvPoint As Integer
public:
int CvPoint
val mutable CvPoint: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvPoint2D32f Field

CvStructSizesCvPoint2D32f Field

The size of CvPoint2D32f

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvPoint2D32f
Public CvPoint2D32f As Integer
public:
int CvPoint2D32f
val mutable CvPoint2D32f: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvPoint3D32f Field

CvStructSizesCvPoint3D32f Field

The size of CvPoint3D32f

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvPoint3D32f
Public CvPoint3D32f As Integer
public:
int CvPoint3D32f
val mutable CvPoint3D32f: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvRect Field

CvStructSizesCvRect Field

The size of CvRect

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvRect
Public CvRect As Integer
public:
int CvRect
val mutable CvRect: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvScalar Field

CvStructSizesCvScalar Field

The size of CvScalar

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvScalar
Public CvScalar As Integer
public:
int CvScalar
val mutable CvScalar: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvSize Field

CvStructSizesCvSize Field

The size of CvSize

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvSize
Public CvSize As Integer
public:
int CvSize
val mutable CvSize: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvSize2D32f Field

CvStructSizesCvSize2D32f Field

The size of CvSize2D32f

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvSize2D32f
Public CvSize2D32f As Integer
public:
int CvSize2D32f
val mutable CvSize2D32f: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.CvTermCriteria Field

CvStructSizesCvTermCriteria Field

The size of CvTermCriteria

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int CvTermCriteria
Public CvTermCriteria As Integer
public:
int CvTermCriteria
val mutable CvTermCriteria: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


CvStructSizes.IplImage Field

CvStructSizesIplImage Field

The size of IplImage

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int IplImage
Public IplImage As Integer
public:
int IplImage
val mutable IplImage: int

Field Value

Type: Int32
See Also

Reference

CvStructSizes Class
Emgu.CV.Structure Namespace


Ellipse Class

An ellipse
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureEllipse

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Ellipse : ValueType
Public NotInheritable Class Ellipse
    Inherits ValueType
public ref class Ellipse sealed : public ValueType
[<SealedAttribute>]
type Ellipse =
    class
        inherit ValueType
    end

The Ellipse type exposes the following members.

Constructors
 | Name | Description
Public method | Ellipse(RotatedRect) | Create an ellipse from the specific RotatedRect
Public method | Ellipse(PointF, SizeF, Single) | Create an ellipse with specific parameters
Top
Properties
 | Name | Description
Public property | RotatedRect | The RotatedRect representation of this ellipse
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Ellipse Constructor

Overload List
 | Name | Description
Public method | Ellipse(RotatedRect) | Create an ellipse from the specific RotatedRect
Public method | Ellipse(PointF, SizeF, Single) | Create an ellipse with specific parameters
Top
See Also

Reference

Ellipse Class
Emgu.CV.Structure Namespace


Ellipse Constructor (RotatedRect)

Create an ellipse from the specific RotatedRect

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Ellipse(
    RotatedRect box2d
)
Public Sub New (
    box2d As RotatedRect
)
public:
Ellipse(
    RotatedRect^ box2d
)
new :
        box2d : RotatedRect -> Ellipse

Parameters

box2d
Type: Emgu.CV.StructureRotatedRect
The RotatedRect representation of this ellipse
See Also

Reference

Ellipse Class
Ellipse Overload
Emgu.CV.Structure Namespace


Ellipse Constructor (PointF, SizeF, Single)

Create an ellipse with specific parameters

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Ellipse(
    PointF center,
    SizeF size,
    float angle
)
Public Sub New (
    center As PointF,
    size As SizeF,
    angle As Single
)
public:
Ellipse(
    PointF^ center,
    SizeF^ size,
    float angle
)
new :
        center : PointF *
        size : SizeF *
        angle : float32 -> Ellipse

Parameters

center
Type: System.DrawingPointF
The center of the ellipse
size
Type: System.DrawingSizeF
The width and height of the ellipse
angle
Type: SystemSingle
The rotation angle in radian for the ellipse
See Also

Reference

Ellipse Class
Ellipse Overload
Emgu.CV.Structure Namespace


Ellipse Properties

The Ellipse type exposes the following members.

Properties
 | Name | Description
Public property | RotatedRect | The RotatedRect representation of this ellipse
Top
See Also

Reference

Ellipse Class
Emgu.CV.Structure Namespace


Ellipse.RotatedRect Property

EllipseRotatedRect Property

The RotatedRect representation of this ellipse

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotatedRect RotatedRect { get; set; }
Public Property RotatedRect As RotatedRect
    Get
    Set
public:
property RotatedRect^ RotatedRect {
    RotatedRect^ get ();
    void set (RotatedRect^ value);
}
member RotatedRect : RotatedRect with get, set

Property Value

Type: RotatedRect
See Also

Reference

Ellipse Class
Emgu.CV.Structure Namespace


Ellipse Methods

The Ellipse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Ellipse Class
Emgu.CV.Structure Namespace


Gray Class

Defines a Gray color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureGray

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Gray : ValueType, IColor,
    IEquatable<Gray>
Public NotInheritable Class Gray
    Inherits ValueType
    Implements IColor, IEquatable(Of Gray)
public ref class Gray sealed : public ValueType,
    IColor, IEquatable<Gray^>
[<SealedAttribute>]
type Gray =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Gray>
    end

The Gray type exposes the following members.

Constructors
 | Name | Description
Public method | Gray | Create a Gray color with the given intensity
Top
Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | Intensity | The intensity of the gray color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Gray) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this color (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Gray Constructor

Create a Gray color with the given intensity

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Gray(
    double intensity
)
Public Sub New (
    intensity As Double
)
public:
Gray(
    double intensity
)
new :
        intensity : float -> Gray

Parameters

intensity
Type: SystemDouble
The intensity for this color
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray Properties

The Gray type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | Intensity | The intensity of the gray color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Top
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray.Dimension Property

GrayDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray.Intensity Property

GrayIntensity Property

The intensity of the gray color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set
public:
property double Intensity {
    double get ();
    void set (double value);
}
member Intensity : float with get, set

Property Value

Type: Double
The intensity of the gray color
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray.MCvScalar Property

GrayMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray Methods

The Gray type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Gray) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this color (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray.Equals Method

GrayEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Gray) | Return true if the two color equals
Top
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray.Equals Method (Gray)

GrayEquals Method (Gray)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Gray other
)
Public Function Equals (
    other As Gray
) As Boolean
public:
virtual bool Equals(
    Gray^ other
) sealed
abstract Equals :
        other : Gray -> bool
override Equals :
        other : Gray -> bool

Parameters

other
Type: Emgu.CV.StructureGray
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Gray Class
Equals Overload
Emgu.CV.Structure Namespace


Gray.GetHashCode Method

GrayGetHashCode Method

Returns the hash code for this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
the hash code
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Gray.ToString Method

GrayToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Gray Class
Emgu.CV.Structure Namespace


Hls Class

Defines a Hls (Hue Lightness Satuation) color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureHls

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Hls : ValueType, IColor,
    IEquatable<Hls>
Public NotInheritable Class Hls
    Inherits ValueType
    Implements IColor, IEquatable(Of Hls)
public ref class Hls sealed : public ValueType,
    IColor, IEquatable<Hls^>
[<SealedAttribute>]
type Hls =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Hls>
    end

The Hls type exposes the following members.

Constructors
 | Name | Description
Public method | Hls | Create a Hls color using the specific values
Top
Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | Hue | Get or set the intensity of the hue color channel ( 0 < hue < 180 )
Public property | Lightness | Get or set the intensity of the lightness color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Satuation | Get or set the intensity of the satuation color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Hls) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Hls Constructor

Create a Hls color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Hls(
    double hue,
    double lightness,
    double satuation
)
Public Sub New (
    hue As Double,
    lightness As Double,
    satuation As Double
)
public:
Hls(
    double hue,
    double lightness,
    double satuation
)
new :
        hue : float *
        lightness : float *
        satuation : float -> Hls

Parameters

hue
Type: SystemDouble
The hue value for this color ( 0 < hue < 180 )
lightness
Type: SystemDouble
The lightness for this color
satuation
Type: SystemDouble
The satuation for this color
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls Properties

The Hls type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | Hue | Get or set the intensity of the hue color channel ( 0 < hue < 180 )
Public property | Lightness | Get or set the intensity of the lightness color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Satuation | Get or set the intensity of the satuation color channel
Top
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls.Dimension Property

HlsDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls.Hue Property

HlsHue Property

Get or set the intensity of the hue color channel ( 0 < hue < 180 )

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set
public:
property double Hue {
    double get ();
    void set (double value);
}
member Hue : float with get, set

Property Value

Type: Double
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls.Lightness Property

HlsLightness Property

Get or set the intensity of the lightness color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Lightness { get; set; }
Public Property Lightness As Double
    Get
    Set
public:
property double Lightness {
    double get ();
    void set (double value);
}
member Lightness : float with get, set

Property Value

Type: Double
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls.MCvScalar Property

HlsMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls.Satuation Property

HlsSatuation Property

Get or set the intensity of the satuation color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Satuation { get; set; }
Public Property Satuation As Double
    Get
    Set
public:
property double Satuation {
    double get ();
    void set (double value);
}
member Satuation : float with get, set

Property Value

Type: Double
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls Methods

The Hls type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Hls) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls.Equals Method

HlsEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Hls) | Return true if the two color equals
Top
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hls.Equals Method (Hls)

HlsEquals Method (Hls)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Hls other
)
Public Function Equals (
    other As Hls
) As Boolean
public:
virtual bool Equals(
    Hls^ other
) sealed
abstract Equals :
        other : Hls -> bool
override Equals :
        other : Hls -> bool

Parameters

other
Type: Emgu.CV.StructureHls
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Hls Class
Equals Overload
Emgu.CV.Structure Namespace


Hls.ToString Method

HlsToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Hls Class
Emgu.CV.Structure Namespace


Hsv Class

Defines a HSV (Hue Satuation Value) color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureHsv

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Hsv : ValueType, IColor,
    IEquatable<Hsv>
Public NotInheritable Class Hsv
    Inherits ValueType
    Implements IColor, IEquatable(Of Hsv)
public ref class Hsv sealed : public ValueType,
    IColor, IEquatable<Hsv^>
[<SealedAttribute>]
type Hsv =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Hsv>
    end

The Hsv type exposes the following members.

Constructors
 | Name | Description
Public method | Hsv | Create a HSV color using the specific values
Top
Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | Hue | Get or set the intensity of the hue color channel ( 0 < hue < 180 )
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Satuation | Get or set the intensity of the satuation color channel
Public property | Value | Get or set the intensity of the value color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Hsv) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Hsv Constructor

Create a HSV color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Hsv(
    double hue,
    double satuation,
    double value
)
Public Sub New (
    hue As Double,
    satuation As Double,
    value As Double
)
public:
Hsv(
    double hue,
    double satuation,
    double value
)
new :
        hue : float *
        satuation : float *
        value : float -> Hsv

Parameters

hue
Type: SystemDouble
The hue value for this color ( 0 < hue < 180 )
satuation
Type: SystemDouble
The satuation value for this color
value
Type: SystemDouble
The value for this color
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv Properties

The Hsv type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | Hue | Get or set the intensity of the hue color channel ( 0 < hue < 180 )
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Satuation | Get or set the intensity of the satuation color channel
Public property | Value | Get or set the intensity of the value color channel
Top
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv.Dimension Property

HsvDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv.Hue Property

HsvHue Property

Get or set the intensity of the hue color channel ( 0 < hue < 180 )

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set
public:
property double Hue {
    double get ();
    void set (double value);
}
member Hue : float with get, set

Property Value

Type: Double
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv.MCvScalar Property

HsvMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv.Satuation Property

HsvSatuation Property

Get or set the intensity of the satuation color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Satuation { get; set; }
Public Property Satuation As Double
    Get
    Set
public:
property double Satuation {
    double get ();
    void set (double value);
}
member Satuation : float with get, set

Property Value

Type: Double
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv.Value Property

HsvValue Property

Get or set the intensity of the value color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv Methods

The Hsv type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Hsv) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv.Equals Method

HsvEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Hsv) | Return true if the two color equals
Top
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Hsv.Equals Method (Hsv)

HsvEquals Method (Hsv)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Hsv other
)
Public Function Equals (
    other As Hsv
) As Boolean
public:
virtual bool Equals(
    Hsv^ other
) sealed
abstract Equals :
        other : Hsv -> bool
override Equals :
        other : Hsv -> bool

Parameters

other
Type: Emgu.CV.StructureHsv
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Hsv Class
Equals Overload
Emgu.CV.Structure Namespace


Hsv.ToString Method

HsvToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Hsv Class
Emgu.CV.Structure Namespace


Lab Class

Defines a CIE Lab color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureLab

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Lab : ValueType, IColor,
    IEquatable<Lab>
Public NotInheritable Class Lab
    Inherits ValueType
    Implements IColor, IEquatable(Of Lab)
public ref class Lab sealed : public ValueType,
    IColor, IEquatable<Lab^>
[<SealedAttribute>]
type Lab =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Lab>
    end

The Lab type exposes the following members.

Constructors
 | Name | Description
Public method | Lab | Create a CIE Lab color using the specific values
Top
Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | X | Get or set the intensity of the x color channel
Public property | Y | Get or set the intensity of the y color channel
Public property | Z | Get or set the intensity of the z color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Lab) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Lab Constructor

Create a CIE Lab color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Lab(
    double x,
    double y,
    double z
)
Public Sub New (
    x As Double,
    y As Double,
    z As Double
)
public:
Lab(
    double x,
    double y,
    double z
)
new :
        x : float *
        y : float *
        z : float -> Lab

Parameters

x
Type: SystemDouble
The x value for this color
y
Type: SystemDouble
The y value for this color
z
Type: SystemDouble
The z value for this color
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab Properties

The Lab type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | X | Get or set the intensity of the x color channel
Public property | Y | Get or set the intensity of the y color channel
Public property | Z | Get or set the intensity of the z color channel
Top
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab.Dimension Property

LabDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab.MCvScalar Property

LabMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab.X Property

LabX Property

Get or set the intensity of the x color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double X { get; set; }
Public Property X As Double
    Get
    Set
public:
property double X {
    double get ();
    void set (double value);
}
member X : float with get, set

Property Value

Type: Double
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab.Y Property

LabY Property

Get or set the intensity of the y color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Y { get; set; }
Public Property Y As Double
    Get
    Set
public:
property double Y {
    double get ();
    void set (double value);
}
member Y : float with get, set

Property Value

Type: Double
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab.Z Property

LabZ Property

Get or set the intensity of the z color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Z { get; set; }
Public Property Z As Double
    Get
    Set
public:
property double Z {
    double get ();
    void set (double value);
}
member Z : float with get, set

Property Value

Type: Double
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab Methods

The Lab type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Lab) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab.Equals Method

LabEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Lab) | Return true if the two color equals
Top
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


Lab.Equals Method (Lab)

LabEquals Method (Lab)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Lab other
)
Public Function Equals (
    other As Lab
) As Boolean
public:
virtual bool Equals(
    Lab^ other
) sealed
abstract Equals :
        other : Lab -> bool
override Equals :
        other : Lab -> bool

Parameters

other
Type: Emgu.CV.StructureLab
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Lab Class
Equals Overload
Emgu.CV.Structure Namespace


Lab.ToString Method

LabToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Lab Class
Emgu.CV.Structure Namespace


LineSegment2D Class

A line segment
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureLineSegment2D

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LineSegment2D : ValueType
Public NotInheritable Class LineSegment2D
    Inherits ValueType
public ref class LineSegment2D sealed : public ValueType
[<SealedAttribute>]
type LineSegment2D =
    class
        inherit ValueType
    end

The LineSegment2D type exposes the following members.

Constructors
 | Name | Description
Public method | LineSegment2D | Create a line segment with the specific starting point and end point
Top
Properties
 | Name | Description
Public property | Direction | The direction of the line, the norm of which is 1
Public property | Length | Get the length of the line segment
Public property | P1 | A point on the line
Public property | P2 | An other point on the line
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExteriorAngleDegree | Get the exterior angle between this line and otherLine
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Side | Determine which side of the line the 2D point is at
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


LineSegment2D Constructor

Create a line segment with the specific starting point and end point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment2D(
    Point p1,
    Point p2
)
Public Sub New (
    p1 As Point,
    p2 As Point
)
public:
LineSegment2D(
    Point^ p1,
    Point^ p2
)
new :
        p1 : Point *
        p2 : Point -> LineSegment2D

Parameters

p1
Type: System.DrawingPoint
The first point on the line segment
p2
Type: System.DrawingPoint
The second point on the line segment
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D Properties

The LineSegment2D type exposes the following members.

Properties
 | Name | Description
Public property | Direction | The direction of the line, the norm of which is 1
Public property | Length | Get the length of the line segment
Public property | P1 | A point on the line
Public property | P2 | An other point on the line
Top
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D.Direction Property

LineSegment2DDirection Property

The direction of the line, the norm of which is 1

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Direction { get; }
Public ReadOnly Property Direction As PointF
    Get
public:
property PointF^ Direction {
    PointF^ get ();
}
member Direction : PointF with get

Property Value

Type: PointF
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D.Length Property

LineSegment2DLength Property

Get the length of the line segment

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Type: Double
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D.P1 Property

LineSegment2DP1 Property

A point on the line

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point P1 { get; set; }
Public Property P1 As Point
    Get
    Set
public:
property Point^ P1 {
    Point^ get ();
    void set (Point^ value);
}
member P1 : Point with get, set

Property Value

Type: Point
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D.P2 Property

LineSegment2DP2 Property

An other point on the line

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point P2 { get; set; }
Public Property P2 As Point
    Get
    Set
public:
property Point^ P2 {
    Point^ get ();
    void set (Point^ value);
}
member P2 : Point with get, set

Property Value

Type: Point
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D Methods

The LineSegment2D type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExteriorAngleDegree | Get the exterior angle between this line and otherLine
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Side | Determine which side of the line the 2D point is at
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D.GetExteriorAngleDegree Method

LineSegment2DGetExteriorAngleDegree Method

Get the exterior angle between this line and otherLine

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double GetExteriorAngleDegree(
    LineSegment2D otherLine
)
Public Function GetExteriorAngleDegree (
    otherLine As LineSegment2D
) As Double
public:
double GetExteriorAngleDegree(
    LineSegment2D^ otherLine
)
member GetExteriorAngleDegree :
        otherLine : LineSegment2D -> float

Parameters

otherLine
Type: Emgu.CV.StructureLineSegment2D
The other line

Return Value

Type: Double
The exterior angle between this line and otherLine
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2D.Side Method

LineSegment2DSide Method

Determine which side of the line the 2D point is at

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Side(
    Point point
)
Public Function Side (
    point As Point
) As Integer
public:
int Side(
    Point^ point
)
member Side :
        point : Point -> int

Parameters

point
Type: System.DrawingPoint
the point

Return Value

Type: Int32
1 if on the right hand side; 0 if on the line; -1 if on the left hand side;
See Also

Reference

LineSegment2D Class
Emgu.CV.Structure Namespace


LineSegment2DF Class

A line segment
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureLineSegment2DF

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LineSegment2DF : ValueType
Public NotInheritable Class LineSegment2DF
    Inherits ValueType
public ref class LineSegment2DF sealed : public ValueType
[<SealedAttribute>]
type LineSegment2DF =
    class
        inherit ValueType
    end

The LineSegment2DF type exposes the following members.

Constructors
 | Name | Description
Public method | LineSegment2DF | Create a line segment with the specific start point and end point
Top
Properties
 | Name | Description
Public property | Direction | The direction of the line, the norm of which is 1
Public property | Length | Get the length of the line segment
Public property | P1 | A point on the line
Public property | P2 | An other point on the line
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExteriorAngleDegree | Get the exterior angle between this line and otherLine
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Side | Determin which side of the line the 2D point is at
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Public method | YByX | Obtain the Y value from the X value using first degree interpolation
Top
See Also

Reference

Emgu.CV.Structure Namespace


LineSegment2DF Constructor

Create a line segment with the specific start point and end point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment2DF(
    PointF p1,
    PointF p2
)
Public Sub New (
    p1 As PointF,
    p2 As PointF
)
public:
LineSegment2DF(
    PointF^ p1,
    PointF^ p2
)
new :
        p1 : PointF *
        p2 : PointF -> LineSegment2DF

Parameters

p1
Type: System.DrawingPointF
The first point on the line segment
p2
Type: System.DrawingPointF
The second point on the line segment
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF Properties

The LineSegment2DF type exposes the following members.

Properties
 | Name | Description
Public property | Direction | The direction of the line, the norm of which is 1
Public property | Length | Get the length of the line segment
Public property | P1 | A point on the line
Public property | P2 | An other point on the line
Top
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF.Direction Property

LineSegment2DFDirection Property

The direction of the line, the norm of which is 1

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Direction { get; }
Public ReadOnly Property Direction As PointF
    Get
public:
property PointF^ Direction {
    PointF^ get ();
}
member Direction : PointF with get

Property Value

Type: PointF
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF.Length Property

LineSegment2DFLength Property

Get the length of the line segment

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Type: Double
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF.P1 Property

LineSegment2DFP1 Property

A point on the line

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF P1 { get; set; }
Public Property P1 As PointF
    Get
    Set
public:
property PointF^ P1 {
    PointF^ get ();
    void set (PointF^ value);
}
member P1 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF.P2 Property

LineSegment2DFP2 Property

An other point on the line

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF P2 { get; set; }
Public Property P2 As PointF
    Get
    Set
public:
property PointF^ P2 {
    PointF^ get ();
    void set (PointF^ value);
}
member P2 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF Methods

The LineSegment2DF type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExteriorAngleDegree | Get the exterior angle between this line and otherLine
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Side | Determin which side of the line the 2D point is at
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Public method | YByX | Obtain the Y value from the X value using first degree interpolation
Top
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF.GetExteriorAngleDegree Method

LineSegment2DFGetExteriorAngleDegree Method

Get the exterior angle between this line and otherLine

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double GetExteriorAngleDegree(
    LineSegment2DF otherLine
)
Public Function GetExteriorAngleDegree (
    otherLine As LineSegment2DF
) As Double
public:
double GetExteriorAngleDegree(
    LineSegment2DF^ otherLine
)
member GetExteriorAngleDegree :
        otherLine : LineSegment2DF -> float

Parameters

otherLine
Type: Emgu.CV.StructureLineSegment2DF
The other line

Return Value

Type: Double
The exterior angle between this line and otherLine
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF.Side Method

LineSegment2DFSide Method

Determin which side of the line the 2D point is at

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Side(
    PointF point
)
Public Function Side (
    point As PointF
) As Integer
public:
int Side(
    PointF^ point
)
member Side :
        point : PointF -> int

Parameters

point
Type: System.DrawingPointF
the point

Return Value

Type: Int32
1 if on the right hand side; 0 if on the line; -1 if on the left hand side;
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment2DF.YByX Method

LineSegment2DFYByX Method

Obtain the Y value from the X value using first degree interpolation

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float YByX(
    float x
)
Public Function YByX (
    x As Single
) As Single
public:
float YByX(
    float x
)
member YByX :
        x : float32 -> float32

Parameters

x
Type: SystemSingle
The X value

Return Value

Type: Single
The Y value
See Also

Reference

LineSegment2DF Class
Emgu.CV.Structure Namespace


LineSegment3DF Class

A 3D line segment
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureLineSegment3DF

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LineSegment3DF : ValueType
Public NotInheritable Class LineSegment3DF
    Inherits ValueType
public ref class LineSegment3DF sealed : public ValueType
[<SealedAttribute>]
type LineSegment3DF =
    class
        inherit ValueType
    end

The LineSegment3DF type exposes the following members.

Constructors
 | Name | Description
Public method | LineSegment3DF | Create a line segment with the specific start point and end point
Top
Properties
 | Name | Description
Public property | Length | Get the length of the line segment
Public property | P1 | A point on the line
Public property | P2 | An other point on the line
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


LineSegment3DF Constructor

Create a line segment with the specific start point and end point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment3DF(
    MCvPoint3D32f p1,
    MCvPoint3D32f p2
)
Public Sub New (
    p1 As MCvPoint3D32f,
    p2 As MCvPoint3D32f
)
public:
LineSegment3DF(
    MCvPoint3D32f^ p1,
    MCvPoint3D32f^ p2
)
new :
        p1 : MCvPoint3D32f *
        p2 : MCvPoint3D32f -> LineSegment3DF

Parameters

p1
Type: Emgu.CV.StructureMCvPoint3D32f
The first point on the line segment
p2
Type: Emgu.CV.StructureMCvPoint3D32f
The second point on the line segment
See Also

Reference

LineSegment3DF Class
Emgu.CV.Structure Namespace


LineSegment3DF Properties

The LineSegment3DF type exposes the following members.

Properties
 | Name | Description
Public property | Length | Get the length of the line segment
Public property | P1 | A point on the line
Public property | P2 | An other point on the line
Top
See Also

Reference

LineSegment3DF Class
Emgu.CV.Structure Namespace


LineSegment3DF.Length Property

LineSegment3DFLength Property

Get the length of the line segment

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Type: Double
See Also

Reference

LineSegment3DF Class
Emgu.CV.Structure Namespace


LineSegment3DF.P1 Property

LineSegment3DFP1 Property

A point on the line

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f P1 { get; set; }
Public Property P1 As MCvPoint3D32f
    Get
    Set
public:
property MCvPoint3D32f^ P1 {
    MCvPoint3D32f^ get ();
    void set (MCvPoint3D32f^ value);
}
member P1 : MCvPoint3D32f with get, set

Property Value

Type: MCvPoint3D32f
See Also

Reference

LineSegment3DF Class
Emgu.CV.Structure Namespace


LineSegment3DF.P2 Property

LineSegment3DFP2 Property

An other point on the line

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f P2 { get; set; }
Public Property P2 As MCvPoint3D32f
    Get
    Set
public:
property MCvPoint3D32f^ P2 {
    MCvPoint3D32f^ get ();
    void set (MCvPoint3D32f^ value);
}
member P2 : MCvPoint3D32f with get, set

Property Value

Type: MCvPoint3D32f
See Also

Reference

LineSegment3DF Class
Emgu.CV.Structure Namespace


LineSegment3DF Methods

The LineSegment3DF type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

LineSegment3DF Class
Emgu.CV.Structure Namespace


Luv Class

Defines a CIE Luv color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureLuv

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Luv : ValueType, IColor,
    IEquatable<Luv>
Public NotInheritable Class Luv
    Inherits ValueType
    Implements IColor, IEquatable(Of Luv)
public ref class Luv sealed : public ValueType,
    IColor, IEquatable<Luv^>
[<SealedAttribute>]
type Luv =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Luv>
    end

The Luv type exposes the following members.

Constructors
 | Name | Description
Public method | Luv | Create a CIE Lab color using the specific values
Top
Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | X | The intensity of the x color channel
Public property | Y | The intensity of the y color channel
Public property | Z | The intensity of the z color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Luv) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Luv Constructor

Create a CIE Lab color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Luv(
    double x,
    double y,
    double z
)
Public Sub New (
    x As Double,
    y As Double,
    z As Double
)
public:
Luv(
    double x,
    double y,
    double z
)
new :
        x : float *
        y : float *
        z : float -> Luv

Parameters

x
Type: SystemDouble
The x value for this color
y
Type: SystemDouble
The y value for this color
z
Type: SystemDouble
The z value for this color
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv Properties

The Luv type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | X | The intensity of the x color channel
Public property | Y | The intensity of the y color channel
Public property | Z | The intensity of the z color channel
Top
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv.Dimension Property

LuvDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv.MCvScalar Property

LuvMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv.X Property

LuvX Property

The intensity of the x color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double X { get; set; }
Public Property X As Double
    Get
    Set
public:
property double X {
    double get ();
    void set (double value);
}
member X : float with get, set

Property Value

Type: Double
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv.Y Property

LuvY Property

The intensity of the y color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Y { get; set; }
Public Property Y As Double
    Get
    Set
public:
property double Y {
    double get ();
    void set (double value);
}
member Y : float with get, set

Property Value

Type: Double
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv.Z Property

LuvZ Property

The intensity of the z color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Z { get; set; }
Public Property Z As Double
    Get
    Set
public:
property double Z {
    double get ();
    void set (double value);
}
member Z : float with get, set

Property Value

Type: Double
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv Methods

The Luv type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Luv) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv.Equals Method

LuvEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Luv) | Return true if the two color equals
Top
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


Luv.Equals Method (Luv)

LuvEquals Method (Luv)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Luv other
)
Public Function Equals (
    other As Luv
) As Boolean
public:
virtual bool Equals(
    Luv^ other
) sealed
abstract Equals :
        other : Luv -> bool
override Equals :
        other : Luv -> bool

Parameters

other
Type: Emgu.CV.StructureLuv
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Luv Class
Equals Overload
Emgu.CV.Structure Namespace


Luv.ToString Method

LuvToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Luv Class
Emgu.CV.Structure Namespace


MCvAvgComp Class

Result of cvHaarDetectObjects
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvAvgComp

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvAvgComp : ValueType
<SerializableAttribute>
Public NotInheritable Class MCvAvgComp
    Inherits ValueType
[SerializableAttribute]
public ref class MCvAvgComp sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvAvgComp =
    class
        inherit ValueType
    end

The MCvAvgComp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Neighbors | Number of neighbor rectangles in the group
Public field | Rect | Bounding rectangle for the object (average rectangle of a group)
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvAvgComp Methods

The MCvAvgComp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvAvgComp Class
Emgu.CV.Structure Namespace


MCvAvgComp Fields

The MCvAvgComp type exposes the following members.

Fields
 | Name | Description
Public field | Neighbors | Number of neighbor rectangles in the group
Public field | Rect | Bounding rectangle for the object (average rectangle of a group)
Top
See Also

Reference

MCvAvgComp Class
Emgu.CV.Structure Namespace


MCvAvgComp.Neighbors Field

MCvAvgCompNeighbors Field

Number of neighbor rectangles in the group

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Neighbors
Public Neighbors As Integer
public:
int Neighbors
val mutable Neighbors: int

Field Value

Type: Int32
See Also

Reference

MCvAvgComp Class
Emgu.CV.Structure Namespace


MCvAvgComp.Rect Field

MCvAvgCompRect Field

Bounding rectangle for the object (average rectangle of a group)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle Rect
Public Rect As Rectangle
public:
Rectangle^ Rect
val mutable Rect: Rectangle

Field Value

Type: Rectangle
See Also

Reference

MCvAvgComp Class
Emgu.CV.Structure Namespace


MCvMat Class

Managed structure equivalent to CvMat
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvMat

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MCvMat : ValueType
Public NotInheritable Class MCvMat
    Inherits ValueType
public ref class MCvMat sealed : public ValueType
[<SealedAttribute>]
type MCvMat =
    class
        inherit ValueType
    end

The MCvMat type exposes the following members.

Properties
 | Name | Description
Public property | Height | Height
Public property | NumberOfChannels | Get the number of channels
Public property | Width | Width
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Cols | number of columns
Public field | Data | data pointers
Public field | HdrRefcount | Header reference count
Public field | Refcount | underlying data reference counter
Public field | Rows | number of rows
Public field | Step | full row length in bytes
Public field | Type | CvMat signature (CV_MAT_MAGIC_VAL), element type and flags
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvMat Properties

The MCvMat type exposes the following members.

Properties
 | Name | Description
Public property | Height | Height
Public property | NumberOfChannels | Get the number of channels
Public property | Width | Width
Top
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Height Property

MCvMatHeight Property

Height

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
property int Height {
    int get ();
}
member Height : int with get

Property Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.NumberOfChannels Property

MCvMatNumberOfChannels Property

Get the number of channels

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfChannels { get; }
Public ReadOnly Property NumberOfChannels As Integer
    Get
public:
property int NumberOfChannels {
    int get ();
}
member NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Width Property

MCvMatWidth Property

Width

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}
member Width : int with get

Property Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat Methods

The MCvMat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat Fields

The MCvMat type exposes the following members.

Fields
 | Name | Description
Public field | Cols | number of columns
Public field | Data | data pointers
Public field | HdrRefcount | Header reference count
Public field | Refcount | underlying data reference counter
Public field | Rows | number of rows
Public field | Step | full row length in bytes
Public field | Type | CvMat signature (CV_MAT_MAGIC_VAL), element type and flags
Top
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Cols Field

MCvMatCols Field

number of columns

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Cols
Public Cols As Integer
public:
int Cols
val mutable Cols: int

Field Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Data Field

MCvMatData Field

data pointers

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Data
Public Data As IntPtr
public:
IntPtr Data
val mutable Data: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.HdrRefcount Field

MCvMatHdrRefcount Field

Header reference count

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int HdrRefcount
Public HdrRefcount As Integer
public:
int HdrRefcount
val mutable HdrRefcount: int

Field Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Refcount Field

MCvMatRefcount Field

underlying data reference counter

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Refcount
Public Refcount As IntPtr
public:
IntPtr Refcount
val mutable Refcount: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Rows Field

MCvMatRows Field

number of rows

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Rows
Public Rows As Integer
public:
int Rows
val mutable Rows: int

Field Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Step Field

MCvMatStep Field

full row length in bytes

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Step
Public Step As Integer
public:
int Step
val mutable Step: int

Field Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMat.Type Field

MCvMatType Field

CvMat signature (CV_MAT_MAGIC_VAL), element type and flags

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Type
Public Type As Integer
public:
int Type
val mutable Type: int

Field Value

Type: Int32
See Also

Reference

MCvMat Class
Emgu.CV.Structure Namespace


MCvMatND Class

Managed structure equivalent to CvMatND
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvMatND

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MCvMatND : ValueType
Public NotInheritable Class MCvMatND
    Inherits ValueType
public ref class MCvMatND sealed : public ValueType
[<SealedAttribute>]
type MCvMatND =
    class
        inherit ValueType
    end

The MCvMatND type exposes the following members.

Properties
 | Name | Description
Public property | dim | pairs (number of elements, distance between elements in bytes) for every dimension
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | data | data pointers
Public field | dim0 | pairs (number of elements, distance between elements in bytes)
Public field | dim1 | pairs (number of elements, distance between elements in bytes)
Public field | dim10 | pairs (number of elements, distance between elements in bytes)
Public field | dim11 | pairs (number of elements, distance between elements in bytes)
Public field | dim12 | pairs (number of elements, distance between elements in bytes)
Public field | dim13 | pairs (number of elements, distance between elements in bytes)
Public field | dim14 | pairs (number of elements, distance between elements in bytes)
Public field | dim15 | pairs (number of elements, distance between elements in bytes)
Public field | dim16 | pairs (number of elements, distance between elements in bytes)
Public field | dim17 | pairs (number of elements, distance between elements in bytes)
Public field | dim18 | pairs (number of elements, distance between elements in bytes)
Public field | dim19 | pairs (number of elements, distance between elements in bytes)
Public field | dim2 | pairs (number of elements, distance between elements in bytes)
Public field | dim20 | pairs (number of elements, distance between elements in bytes)
Public field | dim21 | pairs (number of elements, distance between elements in bytes)
Public field | dim22 | pairs (number of elements, distance between elements in bytes)
Public field | dim23 | pairs (number of elements, distance between elements in bytes)
Public field | dim24 | pairs (number of elements, distance between elements in bytes)
Public field | dim25 | pairs (number of elements, distance between elements in bytes)
Public field | dim26 | pairs (number of elements, distance between elements in bytes)
Public field | dim27 | pairs (number of elements, distance between elements in bytes)
Public field | dim28 | pairs (number of elements, distance between elements in bytes)
Public field | dim29 | pairs (number of elements, distance between elements in bytes)
Public field | dim3 | pairs (number of elements, distance between elements in bytes)
Public field | dim30 | pairs (number of elements, distance between elements in bytes)
Public field | dim31 | pairs (number of elements, distance between elements in bytes)
Public field | dim4 | pairs (number of elements, distance between elements in bytes)
Public field | dim5 | pairs (number of elements, distance between elements in bytes)
Public field | dim6 | pairs (number of elements, distance between elements in bytes)
Public field | dim7 | pairs (number of elements, distance between elements in bytes)
Public field | dim8 | pairs (number of elements, distance between elements in bytes)
Public field | dim9 | pairs (number of elements, distance between elements in bytes)
Public field | dims | number of array dimensions
Public field | hdr_refcount | Header reference count
Public field | refcount | underlying data reference counter
Public field | type | CvMatND signature (CV_MATND_MAGIC_VAL), element type and flags
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvMatND Properties

The MCvMatND type exposes the following members.

Properties
 | Name | Description
Public property | dim | pairs (number of elements, distance between elements in bytes) for every dimension
Top
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim Property

MCvMatNDdim Property

pairs (number of elements, distance between elements in bytes) for every dimension

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension[] dim { get; }
Public ReadOnly Property dim As MCvMatNDDimension()
    Get
public:
property array<MCvMatNDDimension^>^ dim {
    array<MCvMatNDDimension^>^ get ();
}
member dim : MCvMatNDDimension[] with get

Property Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND Methods

The MCvMatND type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND Fields

The MCvMatND type exposes the following members.

Fields
 | Name | Description
Public field | data | data pointers
Public field | dim0 | pairs (number of elements, distance between elements in bytes)
Public field | dim1 | pairs (number of elements, distance between elements in bytes)
Public field | dim10 | pairs (number of elements, distance between elements in bytes)
Public field | dim11 | pairs (number of elements, distance between elements in bytes)
Public field | dim12 | pairs (number of elements, distance between elements in bytes)
Public field | dim13 | pairs (number of elements, distance between elements in bytes)
Public field | dim14 | pairs (number of elements, distance between elements in bytes)
Public field | dim15 | pairs (number of elements, distance between elements in bytes)
Public field | dim16 | pairs (number of elements, distance between elements in bytes)
Public field | dim17 | pairs (number of elements, distance between elements in bytes)
Public field | dim18 | pairs (number of elements, distance between elements in bytes)
Public field | dim19 | pairs (number of elements, distance between elements in bytes)
Public field | dim2 | pairs (number of elements, distance between elements in bytes)
Public field | dim20 | pairs (number of elements, distance between elements in bytes)
Public field | dim21 | pairs (number of elements, distance between elements in bytes)
Public field | dim22 | pairs (number of elements, distance between elements in bytes)
Public field | dim23 | pairs (number of elements, distance between elements in bytes)
Public field | dim24 | pairs (number of elements, distance between elements in bytes)
Public field | dim25 | pairs (number of elements, distance between elements in bytes)
Public field | dim26 | pairs (number of elements, distance between elements in bytes)
Public field | dim27 | pairs (number of elements, distance between elements in bytes)
Public field | dim28 | pairs (number of elements, distance between elements in bytes)
Public field | dim29 | pairs (number of elements, distance between elements in bytes)
Public field | dim3 | pairs (number of elements, distance between elements in bytes)
Public field | dim30 | pairs (number of elements, distance between elements in bytes)
Public field | dim31 | pairs (number of elements, distance between elements in bytes)
Public field | dim4 | pairs (number of elements, distance between elements in bytes)
Public field | dim5 | pairs (number of elements, distance between elements in bytes)
Public field | dim6 | pairs (number of elements, distance between elements in bytes)
Public field | dim7 | pairs (number of elements, distance between elements in bytes)
Public field | dim8 | pairs (number of elements, distance between elements in bytes)
Public field | dim9 | pairs (number of elements, distance between elements in bytes)
Public field | dims | number of array dimensions
Public field | hdr_refcount | Header reference count
Public field | refcount | underlying data reference counter
Public field | type | CvMatND signature (CV_MATND_MAGIC_VAL), element type and flags
Top
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.data Field

MCvMatNDdata Field

data pointers

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr data
Public data As IntPtr
public:
IntPtr data
val mutable data: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim0 Field

MCvMatNDdim0 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim0
Public dim0 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim0
val mutable dim0: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim1 Field

MCvMatNDdim1 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim1
Public dim1 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim1
val mutable dim1: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim10 Field

MCvMatNDdim10 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim10
Public dim10 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim10
val mutable dim10: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim11 Field

MCvMatNDdim11 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim11
Public dim11 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim11
val mutable dim11: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim12 Field

MCvMatNDdim12 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim12
Public dim12 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim12
val mutable dim12: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim13 Field

MCvMatNDdim13 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim13
Public dim13 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim13
val mutable dim13: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim14 Field

MCvMatNDdim14 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim14
Public dim14 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim14
val mutable dim14: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim15 Field

MCvMatNDdim15 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim15
Public dim15 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim15
val mutable dim15: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim16 Field

MCvMatNDdim16 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim16
Public dim16 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim16
val mutable dim16: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim17 Field

MCvMatNDdim17 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim17
Public dim17 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim17
val mutable dim17: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim18 Field

MCvMatNDdim18 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim18
Public dim18 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim18
val mutable dim18: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim19 Field

MCvMatNDdim19 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim19
Public dim19 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim19
val mutable dim19: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim2 Field

MCvMatNDdim2 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim2
Public dim2 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim2
val mutable dim2: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim20 Field

MCvMatNDdim20 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim20
Public dim20 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim20
val mutable dim20: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim21 Field

MCvMatNDdim21 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim21
Public dim21 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim21
val mutable dim21: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim22 Field

MCvMatNDdim22 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim22
Public dim22 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim22
val mutable dim22: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim23 Field

MCvMatNDdim23 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim23
Public dim23 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim23
val mutable dim23: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim24 Field

MCvMatNDdim24 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim24
Public dim24 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim24
val mutable dim24: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim25 Field

MCvMatNDdim25 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim25
Public dim25 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim25
val mutable dim25: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim26 Field

MCvMatNDdim26 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim26
Public dim26 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim26
val mutable dim26: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim27 Field

MCvMatNDdim27 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim27
Public dim27 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim27
val mutable dim27: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim28 Field

MCvMatNDdim28 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim28
Public dim28 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim28
val mutable dim28: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim29 Field

MCvMatNDdim29 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim29
Public dim29 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim29
val mutable dim29: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim3 Field

MCvMatNDdim3 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim3
Public dim3 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim3
val mutable dim3: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim30 Field

MCvMatNDdim30 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim30
Public dim30 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim30
val mutable dim30: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim31 Field

MCvMatNDdim31 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim31
Public dim31 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim31
val mutable dim31: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim4 Field

MCvMatNDdim4 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim4
Public dim4 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim4
val mutable dim4: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim5 Field

MCvMatNDdim5 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim5
Public dim5 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim5
val mutable dim5: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim6 Field

MCvMatNDdim6 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim6
Public dim6 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim6
val mutable dim6: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim7 Field

MCvMatNDdim7 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim7
Public dim7 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim7
val mutable dim7: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim8 Field

MCvMatNDdim8 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim8
Public dim8 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim8
val mutable dim8: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dim9 Field

MCvMatNDdim9 Field

pairs (number of elements, distance between elements in bytes)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvMatNDDimension dim9
Public dim9 As MCvMatNDDimension
public:
MCvMatNDDimension^ dim9
val mutable dim9: MCvMatNDDimension

Field Value

Type: MCvMatNDDimension
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.dims Field

MCvMatNDdims Field

number of array dimensions

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int dims
Public dims As Integer
public:
int dims
val mutable dims: int

Field Value

Type: Int32
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.hdr_refcount Field

MCvMatNDhdr_refcount Field

Header reference count

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int hdr_refcount
Public hdr_refcount As Integer
public:
int hdr_refcount
val mutable hdr_refcount: int

Field Value

Type: Int32
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.refcount Field

MCvMatNDrefcount Field

underlying data reference counter

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr refcount
Public refcount As IntPtr
public:
IntPtr refcount
val mutable refcount: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.type Field

MCvMatNDtype Field

CvMatND signature (CV_MATND_MAGIC_VAL), element type and flags

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int type
Public type As Integer
public:
int type
val mutable type: int

Field Value

Type: Int32
See Also

Reference

MCvMatND Class
Emgu.CV.Structure Namespace


MCvMatND.Dimension Class

MCvMatNDDimension Class

The MatND Dimension
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvMatNDDimension

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Dimension : ValueType
Public NotInheritable Class Dimension
    Inherits ValueType
public ref class Dimension sealed : public ValueType
[<SealedAttribute>]
type Dimension =
    class
        inherit ValueType
    end

The MCvMatNDDimension type exposes the following members.

Properties
 | Name | Description
Public property | Size | Number of elements in this dimension
Public property | Step | distance between elements in bytes for this dimension
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Dimension Properties

The MCvMatNDDimension type exposes the following members.

Properties
 | Name | Description
Public property | Size | Number of elements in this dimension
Public property | Step | distance between elements in bytes for this dimension
Top
See Also

Reference

MCvMatNDDimension Class
Emgu.CV.Structure Namespace


MCvMatND.Dimension.Size Property

MCvMatNDDimensionSize Property

Number of elements in this dimension

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set
public:
property int Size {
    int get ();
    void set (int value);
}
member Size : int with get, set

Property Value

Type: Int32
See Also

Reference

MCvMatNDDimension Class
Emgu.CV.Structure Namespace


MCvMatND.Dimension.Step Property

MCvMatNDDimensionStep Property

distance between elements in bytes for this dimension

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Step { get; set; }
Public Property Step As Integer
    Get
    Set
public:
property int Step {
    int get ();
    void set (int value);
}
member Step : int with get, set

Property Value

Type: Int32
See Also

Reference

MCvMatNDDimension Class
Emgu.CV.Structure Namespace


Dimension Methods

The MCvMatNDDimension type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvMatNDDimension Class
Emgu.CV.Structure Namespace


MCvObjectDetection Class

Structure contains the bounding box and confidence level for detected object
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvObjectDetection

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvObjectDetection : ValueType
<SerializableAttribute>
Public NotInheritable Class MCvObjectDetection
    Inherits ValueType
[SerializableAttribute]
public ref class MCvObjectDetection sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvObjectDetection =
    class
        inherit ValueType
    end

The MCvObjectDetection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | ClassId | The class identifier
Public field | Rect | Bounding box for a detected object
Public field | Score | Confidence level
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvObjectDetection Methods

The MCvObjectDetection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvObjectDetection Class
Emgu.CV.Structure Namespace


MCvObjectDetection Fields

The MCvObjectDetection type exposes the following members.

Fields
 | Name | Description
Public field | ClassId | The class identifier
Public field | Rect | Bounding box for a detected object
Public field | Score | Confidence level
Top
See Also

Reference

MCvObjectDetection Class
Emgu.CV.Structure Namespace


MCvObjectDetection.ClassId Field

MCvObjectDetectionClassId Field

The class identifier

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ClassId
Public ClassId As Integer
public:
int ClassId
val mutable ClassId: int

Field Value

Type: Int32
See Also

Reference

MCvObjectDetection Class
Emgu.CV.Structure Namespace


MCvObjectDetection.Rect Field

MCvObjectDetectionRect Field

Bounding box for a detected object

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle Rect
Public Rect As Rectangle
public:
Rectangle^ Rect
val mutable Rect: Rectangle

Field Value

Type: Rectangle
See Also

Reference

MCvObjectDetection Class
Emgu.CV.Structure Namespace


MCvObjectDetection.Score Field

MCvObjectDetectionScore Field

Confidence level

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Score
Public Score As Single
public:
float Score
val mutable Score: float32

Field Value

Type: Single
See Also

Reference

MCvObjectDetection Class
Emgu.CV.Structure Namespace


MCvPoint2D64f Class

Managed Structure equivalent to CvPoint2D64f
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvPoint2D64f

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvPoint2D64f : ValueType,
    IEquatable<MCvPoint2D64f>, IInterpolatable<MCvPoint2D64f>
<SerializableAttribute>
Public NotInheritable Class MCvPoint2D64f
    Inherits ValueType
    Implements IEquatable(Of MCvPoint2D64f), IInterpolatable(Of MCvPoint2D64f)
[SerializableAttribute]
public ref class MCvPoint2D64f sealed : public ValueType,
    IEquatable<MCvPoint2D64f^>, IInterpolatable<MCvPoint2D64f^>
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvPoint2D64f =
    class
        inherit ValueType
        interface IEquatable<MCvPoint2D64f>
        interface IInterpolatable<MCvPoint2D64f>
    end

The MCvPoint2D64f type exposes the following members.

Constructors
 | Name | Description
Public method | MCvPoint2D64f | Create a MCvPoint2D64f structure with the specific x and y coordinates
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint2D64f) | Returns true if the two points equals.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Addition | Compute the sum of two 3D points
Multiply(Double, MCvPoint2D64f) | Multiply the point with a scale
Multiply(MCvPoint2D64f, Double) | Multiply the point with a scale
Subtraction | Subtract p2 from p1
Top
Fields
 | Name | Description
Public field | X | x-coordinate
Public field | Y | y-coordinate
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvPoint2D64f Constructor

Create a MCvPoint2D64f structure with the specific x and y coordinates

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint2D64f(
    double x,
    double y
)
Public Sub New (
    x As Double,
    y As Double
)
public:
MCvPoint2D64f(
    double x,
    double y
)
new :
        x : float *
        y : float -> MCvPoint2D64f

Parameters

x
Type: SystemDouble
x-coordinate
y
Type: SystemDouble
y-coordinate
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f Methods

The MCvPoint2D64f type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint2D64f) | Returns true if the two points equals.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f.Equals Method

MCvPoint2D64fEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint2D64f) | Returns true if the two points equals.
Top
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f.Equals Method (MCvPoint2D64f)

MCvPoint2D64fEquals Method (MCvPoint2D64f)

http://www.emgu.com
Returns true if the two points equals.

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    MCvPoint2D64f other
)
Public Function Equals (
    other As MCvPoint2D64f
) As Boolean
public:
virtual bool Equals(
    MCvPoint2D64f^ other
) sealed
abstract Equals :
        other : MCvPoint2D64f -> bool
override Equals :
        other : MCvPoint2D64f -> bool

Parameters

other
Type: Emgu.CV.StructureMCvPoint2D64f
The other point to compare with

Return Value

Type: Boolean
True if the two points equals

Implements

IEquatableTEquals(T)
See Also

Reference

MCvPoint2D64f Class
Equals Overload
Emgu.CV.Structure Namespace


MCvPoint2D64f Operators

The MCvPoint2D64f type exposes the following members.

Operators
Name | Description
Addition | Compute the sum of two 3D points
Multiply(Double, MCvPoint2D64f) | Multiply the point with a scale
Multiply(MCvPoint2D64f, Double) | Multiply the point with a scale
Subtraction | Subtract p2 from p1
Top
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f.Addition Operator

MCvPoint2D64fAddition Operator

Compute the sum of two 3D points

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint2D64f operator +(
    MCvPoint2D64f p1,
    MCvPoint2D64f p2
)
Public Shared Operator + (
    p1 As MCvPoint2D64f,
    p2 As MCvPoint2D64f
) As MCvPoint2D64f
public:
static MCvPoint2D64f^ operator +(
    MCvPoint2D64f^ p1,
    MCvPoint2D64f^ p2
)
static let inline (+)
        p1 : MCvPoint2D64f *
        p2 : MCvPoint2D64f  : MCvPoint2D64f

Parameters

p1
Type: Emgu.CV.StructureMCvPoint2D64f
The first point to be added
p2
Type: Emgu.CV.StructureMCvPoint2D64f
The second point to be added

Return Value

Type: MCvPoint2D64f
The sum of two points
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f.Multiply Operator

MCvPoint2D64fMultiply Operator

Overload List
Name | Description
Multiply(Double, MCvPoint2D64f) | Multiply the point with a scale
Multiply(MCvPoint2D64f, Double) | Multiply the point with a scale
Top
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f.Multiply Operator (Double, MCvPoint2D64f)

MCvPoint2D64fMultiply Operator (Double, MCvPoint2D64f)

http://www.emgu.com
Multiply the point with a scale

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint2D64f operator *(
    double scale,
    MCvPoint2D64f p
)
Public Shared Operator * (
    scale As Double,
    p As MCvPoint2D64f
) As MCvPoint2D64f
public:
static MCvPoint2D64f^ operator *(
    double scale,
    MCvPoint2D64f^ p
)
static let inline (*)
        scale : float *
        p : MCvPoint2D64f  : MCvPoint2D64f

Parameters

scale
Type: SystemDouble
The scale
p
Type: Emgu.CV.StructureMCvPoint2D64f
The point to be multiplied

Return Value

Type: MCvPoint2D64f
The point multiplied by the scale
See Also

Reference

MCvPoint2D64f Class
Multiply Overload
Emgu.CV.Structure Namespace


MCvPoint2D64f.Multiply Operator (MCvPoint2D64f, Double)

MCvPoint2D64fMultiply Operator (MCvPoint2D64f, Double)

http://www.emgu.com
Multiply the point with a scale

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint2D64f operator *(
    MCvPoint2D64f p,
    double scale
)
Public Shared Operator * (
    p As MCvPoint2D64f,
    scale As Double
) As MCvPoint2D64f
public:
static MCvPoint2D64f^ operator *(
    MCvPoint2D64f^ p,
    double scale
)
static let inline (*)
        p : MCvPoint2D64f *
        scale : float  : MCvPoint2D64f

Parameters

p
Type: Emgu.CV.StructureMCvPoint2D64f
The point to be multiplied
scale
Type: SystemDouble
The scale

Return Value

Type: MCvPoint2D64f
The point multiplied by the scale
See Also

Reference

MCvPoint2D64f Class
Multiply Overload
Emgu.CV.Structure Namespace


MCvPoint2D64f.Subtraction Operator

MCvPoint2D64fSubtraction Operator

Subtract p2 from p1

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint2D64f operator -(
    MCvPoint2D64f p1,
    MCvPoint2D64f p2
)
Public Shared Operator - (
    p1 As MCvPoint2D64f,
    p2 As MCvPoint2D64f
) As MCvPoint2D64f
public:
static MCvPoint2D64f^ operator -(
    MCvPoint2D64f^ p1,
    MCvPoint2D64f^ p2
)
static let inline (-)
        p1 : MCvPoint2D64f *
        p2 : MCvPoint2D64f  : MCvPoint2D64f

Parameters

p1
Type: Emgu.CV.StructureMCvPoint2D64f
The first point
p2
Type: Emgu.CV.StructureMCvPoint2D64f
The point to be added

Return Value

Type: MCvPoint2D64f
The sum of two points
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f Fields

The MCvPoint2D64f type exposes the following members.

Fields
 | Name | Description
Public field | X | x-coordinate
Public field | Y | y-coordinate
Top
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f.X Field

MCvPoint2D64fX Field

x-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double X
Public X As Double
public:
double X
val mutable X: float

Field Value

Type: Double
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint2D64f.Y Field

MCvPoint2D64fY Field

y-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Y
Public Y As Double
public:
double Y
val mutable Y: float

Field Value

Type: Double
See Also

Reference

MCvPoint2D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f Class

Managed Structure equivalent to CvPoint3D32f
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvPoint3D32f

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvPoint3D32f : ValueType,
    IEquatable<MCvPoint3D32f>
<SerializableAttribute>
Public NotInheritable Class MCvPoint3D32f
    Inherits ValueType
    Implements IEquatable(Of MCvPoint3D32f)
[SerializableAttribute]
public ref class MCvPoint3D32f sealed : public ValueType,
    IEquatable<MCvPoint3D32f^>
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvPoint3D32f =
    class
        inherit ValueType
        interface IEquatable<MCvPoint3D32f>
    end

The MCvPoint3D32f type exposes the following members.

Constructors
 | Name | Description
Public method | MCvPoint3D32f | Create a MCvPoint3D32f structure with the specific x and y coordinates
Top
Properties
 | Name | Description
Public property | Norm | return the norm of this 3D point
Top
Methods
 | Name | Description
Public method | CrossProduct | Return the cross product of two 3D point
Public method | DotProduct | Return the dot product of two 3D point
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint3D32f) | Return true if the location of the two points are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetNormalizedPoint | Get the normalized point
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Addition | Compute the sum of two 3D points
(MCvPoint3D32f to MCvPoint3D64f) | The implicit operator to convert MCvPoint3D32f to MCvPoint3D64f
Multiply(Single, MCvPoint3D32f) | Multiply the point with a scale
Multiply(MCvPoint3D32f, Single) | Multiply the point with a scale
Subtraction | Subtract one point from the other
Top
Fields
 | Name | Description
Public field | X | x-coordinate
Public field | Y | y-coordinate
Public field | Z | z-coordinate
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvPoint3D32f Constructor

Create a MCvPoint3D32f structure with the specific x and y coordinates

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f(
    float x,
    float y,
    float z
)
Public Sub New (
    x As Single,
    y As Single,
    z As Single
)
public:
MCvPoint3D32f(
    float x,
    float y,
    float z
)
new :
        x : float32 *
        y : float32 *
        z : float32 -> MCvPoint3D32f

Parameters

x
Type: SystemSingle
x-coordinate
y
Type: SystemSingle
y-coordinate
z
Type: SystemSingle
z-coordinate
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f Properties

The MCvPoint3D32f type exposes the following members.

Properties
 | Name | Description
Public property | Norm | return the norm of this 3D point
Top
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Norm Property

MCvPoint3D32fNorm Property

return the norm of this 3D point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Norm { get; }
Public ReadOnly Property Norm As Double
    Get
public:
property double Norm {
    double get ();
}
member Norm : float with get

Property Value

Type: Double
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f Methods

The MCvPoint3D32f type exposes the following members.

Methods
 | Name | Description
Public method | CrossProduct | Return the cross product of two 3D point
Public method | DotProduct | Return the dot product of two 3D point
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint3D32f) | Return true if the location of the two points are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetNormalizedPoint | Get the normalized point
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.CrossProduct Method

MCvPoint3D32fCrossProduct Method

Return the cross product of two 3D point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f CrossProduct(
    MCvPoint3D32f point
)
Public Function CrossProduct (
    point As MCvPoint3D32f
) As MCvPoint3D32f
public:
MCvPoint3D32f^ CrossProduct(
    MCvPoint3D32f^ point
)
member CrossProduct :
        point : MCvPoint3D32f -> MCvPoint3D32f

Parameters

point
Type: Emgu.CV.StructureMCvPoint3D32f
the other 3D point

Return Value

Type: MCvPoint3D32f
The cross product of the two 3D point
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.DotProduct Method

MCvPoint3D32fDotProduct Method

Return the dot product of two 3D point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float DotProduct(
    MCvPoint3D32f point
)
Public Function DotProduct (
    point As MCvPoint3D32f
) As Single
public:
float DotProduct(
    MCvPoint3D32f^ point
)
member DotProduct :
        point : MCvPoint3D32f -> float32

Parameters

point
Type: Emgu.CV.StructureMCvPoint3D32f
the other 3D point

Return Value

Type: Single
The dot product of the two 3D point
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Equals Method

MCvPoint3D32fEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint3D32f) | Return true if the location of the two points are equal
Top
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Equals Method (MCvPoint3D32f)

MCvPoint3D32fEquals Method (MCvPoint3D32f)

http://www.emgu.com
Return true if the location of the two points are equal

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    MCvPoint3D32f other
)
Public Function Equals (
    other As MCvPoint3D32f
) As Boolean
public:
virtual bool Equals(
    MCvPoint3D32f^ other
) sealed
abstract Equals :
        other : MCvPoint3D32f -> bool
override Equals :
        other : MCvPoint3D32f -> bool

Parameters

other
Type: Emgu.CV.StructureMCvPoint3D32f
The other point to compare with

Return Value

Type: Boolean
True if the location of the two points are equal

Implements

IEquatableTEquals(T)
See Also

Reference

MCvPoint3D32f Class
Equals Overload
Emgu.CV.Structure Namespace


MCvPoint3D32f.GetNormalizedPoint Method

MCvPoint3D32fGetNormalizedPoint Method

Get the normalized point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f GetNormalizedPoint()
Public Function GetNormalizedPoint As MCvPoint3D32f
public:
MCvPoint3D32f^ GetNormalizedPoint()
member GetNormalizedPoint : unit -> MCvPoint3D32f

Return Value

Type: MCvPoint3D32f
The normalized point
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f Operators and Type Conversions

The MCvPoint3D32f type exposes the following members.

Operators
Name | Description
Addition | Compute the sum of two 3D points
(MCvPoint3D32f to MCvPoint3D64f) | The implicit operator to convert MCvPoint3D32f to MCvPoint3D64f
Multiply(Single, MCvPoint3D32f) | Multiply the point with a scale
Multiply(MCvPoint3D32f, Single) | Multiply the point with a scale
Subtraction | Subtract one point from the other
Top
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Addition Operator

MCvPoint3D32fAddition Operator

Compute the sum of two 3D points

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D32f operator +(
    MCvPoint3D32f p1,
    MCvPoint3D32f p2
)
Public Shared Operator + (
    p1 As MCvPoint3D32f,
    p2 As MCvPoint3D32f
) As MCvPoint3D32f
public:
static MCvPoint3D32f^ operator +(
    MCvPoint3D32f^ p1,
    MCvPoint3D32f^ p2
)
static let inline (+)
        p1 : MCvPoint3D32f *
        p2 : MCvPoint3D32f  : MCvPoint3D32f

Parameters

p1
Type: Emgu.CV.StructureMCvPoint3D32f
The first point to be added
p2
Type: Emgu.CV.StructureMCvPoint3D32f
The second point to be added

Return Value

Type: MCvPoint3D32f
The sum of two points
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f Implicit Conversion (MCvPoint3D32f to MCvPoint3D64f)

MCvPoint3D32f Conversion (MCvPoint3D32f to MCvPoint3D64f)

http://www.emgu.com
The implicit operator to convert MCvPoint3D32f to MCvPoint3D64f

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static implicit operator MCvPoint3D64f (
    MCvPoint3D32f point
)
Public Shared Widening Operator CType (
    point As MCvPoint3D32f
) As MCvPoint3D64f
static implicit operator MCvPoint3D64f^ (
    MCvPoint3D32f^ point
)
F# does not support the declaration of new casting operators.

Parameters

point
Type: Emgu.CV.StructureMCvPoint3D32f
The point to be converted

Return Value

Type: MCvPoint3D64f
The converted point
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Multiply Operator

MCvPoint3D32fMultiply Operator

Overload List
Name | Description
Multiply(Single, MCvPoint3D32f) | Multiply the point with a scale
Multiply(MCvPoint3D32f, Single) | Multiply the point with a scale
Top
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Multiply Operator (Single, MCvPoint3D32f)

MCvPoint3D32fMultiply Operator (Single, MCvPoint3D32f)

http://www.emgu.com
Multiply the point with a scale

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D32f operator *(
    float scale,
    MCvPoint3D32f p
)
Public Shared Operator * (
    scale As Single,
    p As MCvPoint3D32f
) As MCvPoint3D32f
public:
static MCvPoint3D32f^ operator *(
    float scale,
    MCvPoint3D32f^ p
)
static let inline (*)
        scale : float32 *
        p : MCvPoint3D32f  : MCvPoint3D32f

Parameters

scale
Type: SystemSingle
The scale
p
Type: Emgu.CV.StructureMCvPoint3D32f
The point to be multiplied

Return Value

Type: MCvPoint3D32f
The point multiplied by the scale
See Also

Reference

MCvPoint3D32f Class
Multiply Overload
Emgu.CV.Structure Namespace


MCvPoint3D32f.Multiply Operator (MCvPoint3D32f, Single)

MCvPoint3D32fMultiply Operator (MCvPoint3D32f, Single)

http://www.emgu.com
Multiply the point with a scale

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D32f operator *(
    MCvPoint3D32f p,
    float scale
)
Public Shared Operator * (
    p As MCvPoint3D32f,
    scale As Single
) As MCvPoint3D32f
public:
static MCvPoint3D32f^ operator *(
    MCvPoint3D32f^ p,
    float scale
)
static let inline (*)
        p : MCvPoint3D32f *
        scale : float32  : MCvPoint3D32f

Parameters

p
Type: Emgu.CV.StructureMCvPoint3D32f
The point to be multiplied
scale
Type: SystemSingle
The scale

Return Value

Type: MCvPoint3D32f
The point multiplied by the scale
See Also

Reference

MCvPoint3D32f Class
Multiply Overload
Emgu.CV.Structure Namespace


MCvPoint3D32f.Subtraction Operator

MCvPoint3D32fSubtraction Operator

Subtract one point from the other

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D32f operator -(
    MCvPoint3D32f p1,
    MCvPoint3D32f p2
)
Public Shared Operator - (
    p1 As MCvPoint3D32f,
    p2 As MCvPoint3D32f
) As MCvPoint3D32f
public:
static MCvPoint3D32f^ operator -(
    MCvPoint3D32f^ p1,
    MCvPoint3D32f^ p2
)
static let inline (-)
        p1 : MCvPoint3D32f *
        p2 : MCvPoint3D32f  : MCvPoint3D32f

Parameters

p1
Type: Emgu.CV.StructureMCvPoint3D32f
The point to subtract from
p2
Type: Emgu.CV.StructureMCvPoint3D32f
The value to be subtracted

Return Value

Type: MCvPoint3D32f
The subtraction of one point from the other
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f Fields

The MCvPoint3D32f type exposes the following members.

Fields
 | Name | Description
Public field | X | x-coordinate
Public field | Y | y-coordinate
Public field | Z | z-coordinate
Top
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.X Field

MCvPoint3D32fX Field

x-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float X
Public X As Single
public:
float X
val mutable X: float32

Field Value

Type: Single
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Y Field

MCvPoint3D32fY Field

y-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Y
Public Y As Single
public:
float Y
val mutable Y: float32

Field Value

Type: Single
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D32f.Z Field

MCvPoint3D32fZ Field

z-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Z
Public Z As Single
public:
float Z
val mutable Z: float32

Field Value

Type: Single
See Also

Reference

MCvPoint3D32f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f Class

Managed Structure equivalent to CvPoint3D64f
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvPoint3D64f

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvPoint3D64f : ValueType,
    IEquatable<MCvPoint3D64f>
<SerializableAttribute>
Public NotInheritable Class MCvPoint3D64f
    Inherits ValueType
    Implements IEquatable(Of MCvPoint3D64f)
[SerializableAttribute]
public ref class MCvPoint3D64f sealed : public ValueType,
    IEquatable<MCvPoint3D64f^>
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvPoint3D64f =
    class
        inherit ValueType
        interface IEquatable<MCvPoint3D64f>
    end

The MCvPoint3D64f type exposes the following members.

Constructors
 | Name | Description
Public method | MCvPoint3D64f | Create a MCvPoint3D64f structure with the specific x and y coordinates
Top
Methods
 | Name | Description
Public method | CrossProduct | Return the cross product of two 3D point
Public method | DotProduct | Return the dot product of two 3D point
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint3D64f) | Check if the other point equals to this point
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Addition | Compute the sum of two 3D points
Multiply(Double, MCvPoint3D64f) | Multiply the point with a scale
Multiply(MCvPoint3D64f, Double) | Multiply the point with a scale
Subtraction | Subtract p2 from p1
Top
Fields
 | Name | Description
Public field | X | x-coordinate
Public field | Y | y-coordinate
Public field | Z | z-coordinate
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvPoint3D64f Constructor

Create a MCvPoint3D64f structure with the specific x and y coordinates

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f(
    double x,
    double y,
    double z
)
Public Sub New (
    x As Double,
    y As Double,
    z As Double
)
public:
MCvPoint3D64f(
    double x,
    double y,
    double z
)
new :
        x : float *
        y : float *
        z : float -> MCvPoint3D64f

Parameters

x
Type: SystemDouble
x-coordinate
y
Type: SystemDouble
y-coordinate
z
Type: SystemDouble
z-coordinate
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f Methods

The MCvPoint3D64f type exposes the following members.

Methods
 | Name | Description
Public method | CrossProduct | Return the cross product of two 3D point
Public method | DotProduct | Return the dot product of two 3D point
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint3D64f) | Check if the other point equals to this point
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.CrossProduct Method

MCvPoint3D64fCrossProduct Method

Return the cross product of two 3D point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D64f CrossProduct(
    MCvPoint3D64f point
)
Public Function CrossProduct (
    point As MCvPoint3D64f
) As MCvPoint3D64f
public:
MCvPoint3D64f^ CrossProduct(
    MCvPoint3D64f^ point
)
member CrossProduct :
        point : MCvPoint3D64f -> MCvPoint3D64f

Parameters

point
Type: Emgu.CV.StructureMCvPoint3D64f
the other 3D point

Return Value

Type: MCvPoint3D64f
The cross product of the two 3D point
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.DotProduct Method

MCvPoint3D64fDotProduct Method

Return the dot product of two 3D point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double DotProduct(
    MCvPoint3D64f point
)
Public Function DotProduct (
    point As MCvPoint3D64f
) As Double
public:
double DotProduct(
    MCvPoint3D64f^ point
)
member DotProduct :
        point : MCvPoint3D64f -> float

Parameters

point
Type: Emgu.CV.StructureMCvPoint3D64f
the other 3D point

Return Value

Type: Double
The dot product of the two 3D point
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.Equals Method

MCvPoint3D64fEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvPoint3D64f) | Check if the other point equals to this point
Top
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.Equals Method (MCvPoint3D64f)

MCvPoint3D64fEquals Method (MCvPoint3D64f)

http://www.emgu.com
Check if the other point equals to this point

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    MCvPoint3D64f other
)
Public Function Equals (
    other As MCvPoint3D64f
) As Boolean
public:
virtual bool Equals(
    MCvPoint3D64f^ other
) sealed
abstract Equals :
        other : MCvPoint3D64f -> bool
override Equals :
        other : MCvPoint3D64f -> bool

Parameters

other
Type: Emgu.CV.StructureMCvPoint3D64f
The point to be compared

Return Value

Type: Boolean
True if the two points are equal

Implements

IEquatableTEquals(T)
See Also

Reference

MCvPoint3D64f Class
Equals Overload
Emgu.CV.Structure Namespace


MCvPoint3D64f Operators

The MCvPoint3D64f type exposes the following members.

Operators
Name | Description
Addition | Compute the sum of two 3D points
Multiply(Double, MCvPoint3D64f) | Multiply the point with a scale
Multiply(MCvPoint3D64f, Double) | Multiply the point with a scale
Subtraction | Subtract p2 from p1
Top
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.Addition Operator

MCvPoint3D64fAddition Operator

Compute the sum of two 3D points

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D64f operator +(
    MCvPoint3D64f p1,
    MCvPoint3D64f p2
)
Public Shared Operator + (
    p1 As MCvPoint3D64f,
    p2 As MCvPoint3D64f
) As MCvPoint3D64f
public:
static MCvPoint3D64f^ operator +(
    MCvPoint3D64f^ p1,
    MCvPoint3D64f^ p2
)
static let inline (+)
        p1 : MCvPoint3D64f *
        p2 : MCvPoint3D64f  : MCvPoint3D64f

Parameters

p1
Type: Emgu.CV.StructureMCvPoint3D64f
The first point to be added
p2
Type: Emgu.CV.StructureMCvPoint3D64f
The second point to be added

Return Value

Type: MCvPoint3D64f
The sum of two points
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.Multiply Operator

MCvPoint3D64fMultiply Operator

Overload List
Name | Description
Multiply(Double, MCvPoint3D64f) | Multiply the point with a scale
Multiply(MCvPoint3D64f, Double) | Multiply the point with a scale
Top
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.Multiply Operator (Double, MCvPoint3D64f)

MCvPoint3D64fMultiply Operator (Double, MCvPoint3D64f)

http://www.emgu.com
Multiply the point with a scale

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D64f operator *(
    double scale,
    MCvPoint3D64f p
)
Public Shared Operator * (
    scale As Double,
    p As MCvPoint3D64f
) As MCvPoint3D64f
public:
static MCvPoint3D64f^ operator *(
    double scale,
    MCvPoint3D64f^ p
)
static let inline (*)
        scale : float *
        p : MCvPoint3D64f  : MCvPoint3D64f

Parameters

scale
Type: SystemDouble
The scale
p
Type: Emgu.CV.StructureMCvPoint3D64f
The point to be multiplied

Return Value

Type: MCvPoint3D64f
The point multiplied by the scale
See Also

Reference

MCvPoint3D64f Class
Multiply Overload
Emgu.CV.Structure Namespace


MCvPoint3D64f.Multiply Operator (MCvPoint3D64f, Double)

MCvPoint3D64fMultiply Operator (MCvPoint3D64f, Double)

http://www.emgu.com
Multiply the point with a scale

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D64f operator *(
    MCvPoint3D64f p,
    double scale
)
Public Shared Operator * (
    p As MCvPoint3D64f,
    scale As Double
) As MCvPoint3D64f
public:
static MCvPoint3D64f^ operator *(
    MCvPoint3D64f^ p,
    double scale
)
static let inline (*)
        p : MCvPoint3D64f *
        scale : float  : MCvPoint3D64f

Parameters

p
Type: Emgu.CV.StructureMCvPoint3D64f
The point to be multiplied
scale
Type: SystemDouble
The scale

Return Value

Type: MCvPoint3D64f
The point multiplied by the scale
See Also

Reference

MCvPoint3D64f Class
Multiply Overload
Emgu.CV.Structure Namespace


MCvPoint3D64f.Subtraction Operator

MCvPoint3D64fSubtraction Operator

Subtract p2 from p1

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvPoint3D64f operator -(
    MCvPoint3D64f p1,
    MCvPoint3D64f p2
)
Public Shared Operator - (
    p1 As MCvPoint3D64f,
    p2 As MCvPoint3D64f
) As MCvPoint3D64f
public:
static MCvPoint3D64f^ operator -(
    MCvPoint3D64f^ p1,
    MCvPoint3D64f^ p2
)
static let inline (-)
        p1 : MCvPoint3D64f *
        p2 : MCvPoint3D64f  : MCvPoint3D64f

Parameters

p1
Type: Emgu.CV.StructureMCvPoint3D64f
The first point
p2
Type: Emgu.CV.StructureMCvPoint3D64f
The point to be added

Return Value

Type: MCvPoint3D64f
The sum of two points
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f Fields

The MCvPoint3D64f type exposes the following members.

Fields
 | Name | Description
Public field | X | x-coordinate
Public field | Y | y-coordinate
Public field | Z | z-coordinate
Top
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.X Field

MCvPoint3D64fX Field

x-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double X
Public X As Double
public:
double X
val mutable X: float

Field Value

Type: Double
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.Y Field

MCvPoint3D64fY Field

y-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Y
Public Y As Double
public:
double Y
val mutable Y: float

Field Value

Type: Double
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvPoint3D64f.Z Field

MCvPoint3D64fZ Field

z-coordinate

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Z
Public Z As Double
public:
double Z
val mutable Z: float

Field Value

Type: Double
See Also

Reference

MCvPoint3D64f Class
Emgu.CV.Structure Namespace


MCvScalar Class

Managed structure equivalent to CvScalar
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvScalar

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvScalar : ValueType,
    ICodeGenerable, IEquatable<MCvScalar>
<SerializableAttribute>
Public NotInheritable Class MCvScalar
    Inherits ValueType
    Implements ICodeGenerable, IEquatable(Of MCvScalar)
[SerializableAttribute]
public ref class MCvScalar sealed : public ValueType,
    ICodeGenerable, IEquatable<MCvScalar^>
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvScalar =
    class
        inherit ValueType
        interface ICodeGenerable
        interface IEquatable<MCvScalar>
    end

The MCvScalar type exposes the following members.

Constructors
 | Name | Description
Public method | MCvScalar(Double) | Create a new MCvScalar structure using the specific values
Public method | MCvScalar(Double, Double) | Create a new MCvScalar structure using the specific values
Public method | MCvScalar(Double, Double, Double) | Create a new MCvScalar structure using the specific values
Public method | MCvScalar(Double, Double, Double, Double) | Create a new MCvScalar structure using the specific values
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvScalar) | Return true if the two MCvScalar equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | The scalar values as a vector (of size 4)
Public method | ToCode | Return the code to generate this MCvScalar from specific language
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | V0 | The scalar value
Public field | V1 | The scalar value
Public field | V2 | The scalar value
Public field | V3 | The scalar value
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvScalar Constructor

Overload List
 | Name | Description
Public method | MCvScalar(Double) | Create a new MCvScalar structure using the specific values
Public method | MCvScalar(Double, Double) | Create a new MCvScalar structure using the specific values
Public method | MCvScalar(Double, Double, Double) | Create a new MCvScalar structure using the specific values
Public method | MCvScalar(Double, Double, Double, Double) | Create a new MCvScalar structure using the specific values
Top
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar Constructor (Double)

Create a new MCvScalar structure using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar(
    double v0
)
Public Sub New (
    v0 As Double
)
public:
MCvScalar(
    double v0
)
new :
        v0 : float -> MCvScalar

Parameters

v0
Type: SystemDouble
v0
See Also

Reference

MCvScalar Class
MCvScalar Overload
Emgu.CV.Structure Namespace


MCvScalar Constructor (Double, Double)

Create a new MCvScalar structure using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar(
    double v0,
    double v1
)
Public Sub New (
    v0 As Double,
    v1 As Double
)
public:
MCvScalar(
    double v0,
    double v1
)
new :
        v0 : float *
        v1 : float -> MCvScalar

Parameters

v0
Type: SystemDouble
v0
v1
Type: SystemDouble
v1
See Also

Reference

MCvScalar Class
MCvScalar Overload
Emgu.CV.Structure Namespace


MCvScalar Constructor (Double, Double, Double)

Create a new MCvScalar structure using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar(
    double v0,
    double v1,
    double v2
)
Public Sub New (
    v0 As Double,
    v1 As Double,
    v2 As Double
)
public:
MCvScalar(
    double v0,
    double v1,
    double v2
)
new :
        v0 : float *
        v1 : float *
        v2 : float -> MCvScalar

Parameters

v0
Type: SystemDouble
v0
v1
Type: SystemDouble
v1
v2
Type: SystemDouble
v2
See Also

Reference

MCvScalar Class
MCvScalar Overload
Emgu.CV.Structure Namespace


MCvScalar Constructor (Double, Double, Double, Double)

Create a new MCvScalar structure using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar(
    double v0,
    double v1,
    double v2,
    double v3
)
Public Sub New (
    v0 As Double,
    v1 As Double,
    v2 As Double,
    v3 As Double
)
public:
MCvScalar(
    double v0,
    double v1,
    double v2,
    double v3
)
new :
        v0 : float *
        v1 : float *
        v2 : float *
        v3 : float -> MCvScalar

Parameters

v0
Type: SystemDouble
v0
v1
Type: SystemDouble
v1
v2
Type: SystemDouble
v2
v3
Type: SystemDouble
v3
See Also

Reference

MCvScalar Class
MCvScalar Overload
Emgu.CV.Structure Namespace


MCvScalar Methods

The MCvScalar type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvScalar) | Return true if the two MCvScalar equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | The scalar values as a vector (of size 4)
Public method | ToCode | Return the code to generate this MCvScalar from specific language
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar.Equals Method

MCvScalarEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(MCvScalar) | Return true if the two MCvScalar equals
Top
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar.Equals Method (MCvScalar)

MCvScalarEquals Method (MCvScalar)

http://www.emgu.com
Return true if the two MCvScalar equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    MCvScalar other
)
Public Function Equals (
    other As MCvScalar
) As Boolean
public:
virtual bool Equals(
    MCvScalar^ other
) sealed
abstract Equals :
        other : MCvScalar -> bool
override Equals :
        other : MCvScalar -> bool

Parameters

other
Type: Emgu.CV.StructureMCvScalar
The other MCvScalar to compare with

Return Value

Type: Boolean
true if the two MCvScalar equals

Implements

IEquatableTEquals(T)
See Also

Reference

MCvScalar Class
Equals Overload
Emgu.CV.Structure Namespace


MCvScalar.ToArray Method

MCvScalarToArray Method

The scalar values as a vector (of size 4)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()
member ToArray : unit -> float[]

Return Value

Type: Double
The scalar values as an array
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar.ToCode Method

MCvScalarToCode Method

Return the code to generate this MCvScalar from specific language

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToCode(
    ProgrammingLanguage language
)
Public Function ToCode (
    language As ProgrammingLanguage
) As String
public:
virtual String^ ToCode(
    ProgrammingLanguage^ language
) sealed
abstract ToCode :
        language : ProgrammingLanguage -> string
override ToCode :
        language : ProgrammingLanguage -> string

Parameters

language
Type: Emgu.Util.TypeEnumProgrammingLanguage
The programming language to generate code from

Return Value

Type: String
The code to generate this MCvScalar from specific language

Implements

ICodeGenerableToCode(ProgrammingLanguage)
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar Fields

The MCvScalar type exposes the following members.

Fields
 | Name | Description
Public field | V0 | The scalar value
Public field | V1 | The scalar value
Public field | V2 | The scalar value
Public field | V3 | The scalar value
Top
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar.V0 Field

MCvScalarV0 Field

The scalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double V0
Public V0 As Double
public:
double V0
val mutable V0: float

Field Value

Type: Double
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar.V1 Field

MCvScalarV1 Field

The scalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double V1
Public V1 As Double
public:
double V1
val mutable V1: float

Field Value

Type: Double
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar.V2 Field

MCvScalarV2 Field

The scalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double V2
Public V2 As Double
public:
double V2
val mutable V2: float

Field Value

Type: Double
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvScalar.V3 Field

MCvScalarV3 Field

The scalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double V3
Public V3 As Double
public:
double V3
val mutable V3: float

Field Value

Type: Double
See Also

Reference

MCvScalar Class
Emgu.CV.Structure Namespace


MCvSlice Class

Managed structure equivalent to CvSlice
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvSlice

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvSlice : ValueType
<SerializableAttribute>
Public NotInheritable Class MCvSlice
    Inherits ValueType
[SerializableAttribute]
public ref class MCvSlice sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvSlice =
    class
        inherit ValueType
    end

The MCvSlice type exposes the following members.

Constructors
 | Name | Description
Public method | MCvSlice | Create a new MCvSlice using the specific start and end index
Top
Properties
Name | Description
WholeSeq | Get the equivalent of CV_WHOLE_SEQ
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | end_index | End index
Public field | start_index | Start index
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvSlice Constructor

Create a new MCvSlice using the specific start and end index

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvSlice(
    int start,
    int end
)
Public Sub New (
    start As Integer,
    end As Integer
)
public:
MCvSlice(
    int start,
    int end
)
new :
        start : int *
        end : int -> MCvSlice

Parameters

start
Type: SystemInt32
start index
end
Type: SystemInt32
end index
See Also

Reference

MCvSlice Class
Emgu.CV.Structure Namespace


MCvSlice Properties

The MCvSlice type exposes the following members.

Properties
Name | Description
WholeSeq | Get the equivalent of CV_WHOLE_SEQ
Top
See Also

Reference

MCvSlice Class
Emgu.CV.Structure Namespace


MCvSlice.WholeSeq Property

MCvSliceWholeSeq Property

Get the equivalent of CV_WHOLE_SEQ

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static MCvSlice WholeSeq { get; }
Public Shared ReadOnly Property WholeSeq As MCvSlice
    Get
public:
static property MCvSlice^ WholeSeq {
    MCvSlice^ get ();
}
static member WholeSeq : MCvSlice with get

Property Value

Type: MCvSlice
See Also

Reference

MCvSlice Class
Emgu.CV.Structure Namespace


MCvSlice Methods

The MCvSlice type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvSlice Class
Emgu.CV.Structure Namespace


MCvSlice Fields

The MCvSlice type exposes the following members.

Fields
 | Name | Description
Public field | end_index | End index
Public field | start_index | Start index
Top
See Also

Reference

MCvSlice Class
Emgu.CV.Structure Namespace


MCvSlice.end_index Field

MCvSliceend_index Field

End index

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int end_index
Public end_index As Integer
public:
int end_index
val mutable end_index: int

Field Value

Type: Int32
See Also

Reference

MCvSlice Class
Emgu.CV.Structure Namespace


MCvSlice.start_index Field

MCvSlicestart_index Field

Start index

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int start_index
Public start_index As Integer
public:
int start_index
val mutable start_index: int

Field Value

Type: Int32
See Also

Reference

MCvSlice Class
Emgu.CV.Structure Namespace


MCvTermCriteria Class

Managed structure equivalent to CvTermCriteria
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMCvTermCriteria

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvTermCriteria : ValueType
<SerializableAttribute>
Public NotInheritable Class MCvTermCriteria
    Inherits ValueType
[SerializableAttribute]
public ref class MCvTermCriteria sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvTermCriteria =
    class
        inherit ValueType
    end

The MCvTermCriteria type exposes the following members.

Constructors
 | Name | Description
Public method | MCvTermCriteria(Double) | Create the termination Criteria using only the constrain of epsilon
Public method | MCvTermCriteria(Int32) | Create the termination criteria using the constrain of maximum iteration
Public method | MCvTermCriteria(Int32, Double) | Create the termination criteria using the constrain of maximum iteration as well as epsilon
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Epsilon | Epsilon
Public field | MaxIter | Maximum iteration
Public field | Type | CV_TERMCRIT value
Top
See Also

Reference

Emgu.CV.Structure Namespace


MCvTermCriteria Constructor

Overload List
 | Name | Description
Public method | MCvTermCriteria(Double) | Create the termination Criteria using only the constrain of epsilon
Public method | MCvTermCriteria(Int32) | Create the termination criteria using the constrain of maximum iteration
Public method | MCvTermCriteria(Int32, Double) | Create the termination criteria using the constrain of maximum iteration as well as epsilon
Top
See Also

Reference

MCvTermCriteria Class
Emgu.CV.Structure Namespace


MCvTermCriteria Constructor (Double)

Create the termination Criteria using only the constrain of epsilon

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria(
    double eps
)
Public Sub New (
    eps As Double
)
public:
MCvTermCriteria(
    double eps
)
new :
        eps : float -> MCvTermCriteria

Parameters

eps
Type: SystemDouble
The epsilon value
See Also

Reference

MCvTermCriteria Class
MCvTermCriteria Overload
Emgu.CV.Structure Namespace


MCvTermCriteria Constructor (Int32)

Create the termination criteria using the constrain of maximum iteration

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria(
    int maxIteration
)
Public Sub New (
    maxIteration As Integer
)
public:
MCvTermCriteria(
    int maxIteration
)
new :
        maxIteration : int -> MCvTermCriteria

Parameters

maxIteration
Type: SystemInt32
The maximum number of iteration allowed
See Also

Reference

MCvTermCriteria Class
MCvTermCriteria Overload
Emgu.CV.Structure Namespace


MCvTermCriteria Constructor (Int32, Double)

Create the termination criteria using the constrain of maximum iteration as well as epsilon

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvTermCriteria(
    int maxIteration,
    double eps
)
Public Sub New (
    maxIteration As Integer,
    eps As Double
)
public:
MCvTermCriteria(
    int maxIteration,
    double eps
)
new :
        maxIteration : int *
        eps : float -> MCvTermCriteria

Parameters

maxIteration
Type: SystemInt32
The maximum number of iteration allowed
eps
Type: SystemDouble
The epsilon value
See Also

Reference

MCvTermCriteria Class
MCvTermCriteria Overload
Emgu.CV.Structure Namespace


MCvTermCriteria Methods

The MCvTermCriteria type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvTermCriteria Class
Emgu.CV.Structure Namespace


MCvTermCriteria Fields

The MCvTermCriteria type exposes the following members.

Fields
 | Name | Description
Public field | Epsilon | Epsilon
Public field | MaxIter | Maximum iteration
Public field | Type | CV_TERMCRIT value
Top
See Also

Reference

MCvTermCriteria Class
Emgu.CV.Structure Namespace


MCvTermCriteria.Epsilon Field

MCvTermCriteriaEpsilon Field

Epsilon

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Epsilon
Public Epsilon As Double
public:
double Epsilon
val mutable Epsilon: float

Field Value

Type: Double
See Also

Reference

MCvTermCriteria Class
Emgu.CV.Structure Namespace


MCvTermCriteria.MaxIter Field

MCvTermCriteriaMaxIter Field

Maximum iteration

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxIter
Public MaxIter As Integer
public:
int MaxIter
val mutable MaxIter: int

Field Value

Type: Int32
See Also

Reference

MCvTermCriteria Class
Emgu.CV.Structure Namespace


MCvTermCriteria.Type Field

MCvTermCriteriaType Field

CV_TERMCRIT value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TermCritType Type
Public Type As TermCritType
public:
TermCritType^ Type
val mutable Type: TermCritType

Field Value

Type: TermCritType
See Also

Reference

MCvTermCriteria Class
Emgu.CV.Structure Namespace


MDMatch Class

OpenCV's DMatch structure
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMDMatch

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MDMatch : ValueType
<SerializableAttribute>
Public NotInheritable Class MDMatch
    Inherits ValueType
[SerializableAttribute]
public ref class MDMatch sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type MDMatch =
    class
        inherit ValueType
    end

The MDMatch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Distance | Distance
Public field | ImgIdx | Train image index
Public field | QueryIdx | Query descriptor index
Public field | TrainIdx | Train descriptor index
Top
See Also

Reference

Emgu.CV.Structure Namespace


MDMatch Methods

The MDMatch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MDMatch Class
Emgu.CV.Structure Namespace


MDMatch Fields

The MDMatch type exposes the following members.

Fields
 | Name | Description
Public field | Distance | Distance
Public field | ImgIdx | Train image index
Public field | QueryIdx | Query descriptor index
Public field | TrainIdx | Train descriptor index
Top
See Also

Reference

MDMatch Class
Emgu.CV.Structure Namespace


MDMatch.Distance Field

MDMatchDistance Field

Distance

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Distance
Public Distance As Single
public:
float Distance
val mutable Distance: float32

Field Value

Type: Single
See Also

Reference

MDMatch Class
Emgu.CV.Structure Namespace


MDMatch.ImgIdx Field

MDMatchImgIdx Field

Train image index

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ImgIdx
Public ImgIdx As Integer
public:
int ImgIdx
val mutable ImgIdx: int

Field Value

Type: Int32
See Also

Reference

MDMatch Class
Emgu.CV.Structure Namespace


MDMatch.QueryIdx Field

MDMatchQueryIdx Field

Query descriptor index

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int QueryIdx
Public QueryIdx As Integer
public:
int QueryIdx
val mutable QueryIdx: int

Field Value

Type: Int32
See Also

Reference

MDMatch Class
Emgu.CV.Structure Namespace


MDMatch.TrainIdx Field

MDMatchTrainIdx Field

Train descriptor index

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int TrainIdx
Public TrainIdx As Integer
public:
int TrainIdx
val mutable TrainIdx: int

Field Value

Type: Int32
See Also

Reference

MDMatch Class
Emgu.CV.Structure Namespace


MIplImage Class

Managed structure equivalent to IplImage
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMIplImage

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MIplImage : ValueType
Public NotInheritable Class MIplImage
    Inherits ValueType
public ref class MIplImage sealed : public ValueType
[<SealedAttribute>]
type MIplImage =
    class
        inherit ValueType
    end

The MIplImage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Align | Alignment of image rows (4 or 8). OpenCV ignores it and uses widthStep instead
Public field | AlphaChannel | ignored by OpenCV
Public field | BorderConst0 | border const, ignored by OpenCV
Public field | BorderConst1 | border const, ignored by OpenCV
Public field | BorderConst2 | border const, ignored by OpenCV
Public field | BorderConst3 | border const, ignored by OpenCV
Public field | BorderMode0 | border completion mode, ignored by OpenCV
Public field | BorderMode1 | border completion mode, ignored by OpenCV
Public field | BorderMode2 | border completion mode, ignored by OpenCV
Public field | BorderMode3 | border completion mode, ignored by OpenCV
Public field | ChannelSeq0 | ignored by OpenCV
Public field | ChannelSeq1 | ignored by OpenCV
Public field | ChannelSeq2 | ignored by OpenCV
Public field | ChannelSeq3 | ignored by OpenCV
Public field | ColorModel0 | ignored by OpenCV
Public field | ColorModel1 | ignored by OpenCV
Public field | ColorModel2 | ignored by OpenCV
Public field | ColorModel3 | ignored by OpenCV
Public field | DataOrder | 0 - interleaved color channels, 1 - separate color channels. cvCreateImage can only create interleaved images
Public field | Depth | pixel depth in bits: IPL_DEPTH_8U, IPL_DEPTH_8S, IPL_DEPTH_16U, IPL_DEPTH_16S, IPL_DEPTH_32S, IPL_DEPTH_32F and IPL_DEPTH_64F are supported
Public field | Height | image height in pixels
Public field | ID | version (=0)
Public field | ImageData | pointer to aligned image data
Public field | ImageDataOrigin | pointer to a very origin of image data (not necessarily aligned) - it is needed for correct image deallocation
Public field | ImageId | ditto
Public field | ImageSize | image data size in bytes (=image->height*image->widthStep in case of interleaved data)
Public field | MaskROI | must be NULL in OpenCV
Public field | NChannels | Most of OpenCV functions support 1,2,3 or 4 channels
Public field | NSize | sizeof(IplImage)
Public field | Origin | 0 - top-left origin, 1 - bottom-left origin (Windows bitmaps style)
Public field | Roi | image ROI. when it is not NULL, this specifies image region to process
Public field | TileInfo | ditto
Public field | Width | image width in pixels
Public field | WidthStep | size of aligned image row in bytes
Top
See Also

Reference

Emgu.CV.Structure Namespace


MIplImage Methods

The MIplImage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage Fields

The MIplImage type exposes the following members.

Fields
 | Name | Description
Public field | Align | Alignment of image rows (4 or 8). OpenCV ignores it and uses widthStep instead
Public field | AlphaChannel | ignored by OpenCV
Public field | BorderConst0 | border const, ignored by OpenCV
Public field | BorderConst1 | border const, ignored by OpenCV
Public field | BorderConst2 | border const, ignored by OpenCV
Public field | BorderConst3 | border const, ignored by OpenCV
Public field | BorderMode0 | border completion mode, ignored by OpenCV
Public field | BorderMode1 | border completion mode, ignored by OpenCV
Public field | BorderMode2 | border completion mode, ignored by OpenCV
Public field | BorderMode3 | border completion mode, ignored by OpenCV
Public field | ChannelSeq0 | ignored by OpenCV
Public field | ChannelSeq1 | ignored by OpenCV
Public field | ChannelSeq2 | ignored by OpenCV
Public field | ChannelSeq3 | ignored by OpenCV
Public field | ColorModel0 | ignored by OpenCV
Public field | ColorModel1 | ignored by OpenCV
Public field | ColorModel2 | ignored by OpenCV
Public field | ColorModel3 | ignored by OpenCV
Public field | DataOrder | 0 - interleaved color channels, 1 - separate color channels. cvCreateImage can only create interleaved images
Public field | Depth | pixel depth in bits: IPL_DEPTH_8U, IPL_DEPTH_8S, IPL_DEPTH_16U, IPL_DEPTH_16S, IPL_DEPTH_32S, IPL_DEPTH_32F and IPL_DEPTH_64F are supported
Public field | Height | image height in pixels
Public field | ID | version (=0)
Public field | ImageData | pointer to aligned image data
Public field | ImageDataOrigin | pointer to a very origin of image data (not necessarily aligned) - it is needed for correct image deallocation
Public field | ImageId | ditto
Public field | ImageSize | image data size in bytes (=image->height*image->widthStep in case of interleaved data)
Public field | MaskROI | must be NULL in OpenCV
Public field | NChannels | Most of OpenCV functions support 1,2,3 or 4 channels
Public field | NSize | sizeof(IplImage)
Public field | Origin | 0 - top-left origin, 1 - bottom-left origin (Windows bitmaps style)
Public field | Roi | image ROI. when it is not NULL, this specifies image region to process
Public field | TileInfo | ditto
Public field | Width | image width in pixels
Public field | WidthStep | size of aligned image row in bytes
Top
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.Align Field

MIplImageAlign Field

Alignment of image rows (4 or 8). OpenCV ignores it and uses widthStep instead

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Align
Public Align As Integer
public:
int Align
val mutable Align: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.AlphaChannel Field

MIplImageAlphaChannel Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int AlphaChannel
Public AlphaChannel As Integer
public:
int AlphaChannel
val mutable AlphaChannel: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderConst0 Field

MIplImageBorderConst0 Field

border const, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderConst0
Public BorderConst0 As Integer
public:
int BorderConst0
val mutable BorderConst0: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderConst1 Field

MIplImageBorderConst1 Field

border const, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderConst1
Public BorderConst1 As Integer
public:
int BorderConst1
val mutable BorderConst1: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderConst2 Field

MIplImageBorderConst2 Field

border const, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderConst2
Public BorderConst2 As Integer
public:
int BorderConst2
val mutable BorderConst2: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderConst3 Field

MIplImageBorderConst3 Field

border const, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderConst3
Public BorderConst3 As Integer
public:
int BorderConst3
val mutable BorderConst3: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderMode0 Field

MIplImageBorderMode0 Field

border completion mode, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderMode0
Public BorderMode0 As Integer
public:
int BorderMode0
val mutable BorderMode0: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderMode1 Field

MIplImageBorderMode1 Field

border completion mode, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderMode1
Public BorderMode1 As Integer
public:
int BorderMode1
val mutable BorderMode1: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderMode2 Field

MIplImageBorderMode2 Field

border completion mode, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderMode2
Public BorderMode2 As Integer
public:
int BorderMode2
val mutable BorderMode2: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.BorderMode3 Field

MIplImageBorderMode3 Field

border completion mode, ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int BorderMode3
Public BorderMode3 As Integer
public:
int BorderMode3
val mutable BorderMode3: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ChannelSeq0 Field

MIplImageChannelSeq0 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ChannelSeq0
Public ChannelSeq0 As Byte
public:
unsigned char ChannelSeq0
val mutable ChannelSeq0: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ChannelSeq1 Field

MIplImageChannelSeq1 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ChannelSeq1
Public ChannelSeq1 As Byte
public:
unsigned char ChannelSeq1
val mutable ChannelSeq1: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ChannelSeq2 Field

MIplImageChannelSeq2 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ChannelSeq2
Public ChannelSeq2 As Byte
public:
unsigned char ChannelSeq2
val mutable ChannelSeq2: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ChannelSeq3 Field

MIplImageChannelSeq3 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ChannelSeq3
Public ChannelSeq3 As Byte
public:
unsigned char ChannelSeq3
val mutable ChannelSeq3: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ColorModel0 Field

MIplImageColorModel0 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ColorModel0
Public ColorModel0 As Byte
public:
unsigned char ColorModel0
val mutable ColorModel0: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ColorModel1 Field

MIplImageColorModel1 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ColorModel1
Public ColorModel1 As Byte
public:
unsigned char ColorModel1
val mutable ColorModel1: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ColorModel2 Field

MIplImageColorModel2 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ColorModel2
Public ColorModel2 As Byte
public:
unsigned char ColorModel2
val mutable ColorModel2: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ColorModel3 Field

MIplImageColorModel3 Field

ignored by OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ColorModel3
Public ColorModel3 As Byte
public:
unsigned char ColorModel3
val mutable ColorModel3: byte

Field Value

Type: Byte
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.DataOrder Field

MIplImageDataOrder Field

0 - interleaved color channels, 1 - separate color channels. cvCreateImage can only create interleaved images

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int DataOrder
Public DataOrder As Integer
public:
int DataOrder
val mutable DataOrder: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.Depth Field

MIplImageDepth Field

pixel depth in bits: IPL_DEPTH_8U, IPL_DEPTH_8S, IPL_DEPTH_16U, IPL_DEPTH_16S, IPL_DEPTH_32S, IPL_DEPTH_32F and IPL_DEPTH_64F are supported

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IplDepth Depth
Public Depth As IplDepth
public:
IplDepth^ Depth
val mutable Depth: IplDepth

Field Value

Type: IplDepth
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.Height Field

MIplImageHeight Field

image height in pixels

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Height
Public Height As Integer
public:
int Height
val mutable Height: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ID Field

MIplImageID Field

version (=0)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ID
Public ID As Integer
public:
int ID
val mutable ID: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ImageData Field

MIplImageImageData Field

pointer to aligned image data

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ImageData
Public ImageData As IntPtr
public:
IntPtr ImageData
val mutable ImageData: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ImageDataOrigin Field

MIplImageImageDataOrigin Field

pointer to a very origin of image data (not necessarily aligned) - it is needed for correct image deallocation

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ImageDataOrigin
Public ImageDataOrigin As IntPtr
public:
IntPtr ImageDataOrigin
val mutable ImageDataOrigin: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ImageId Field

MIplImageImageId Field

ditto

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ImageId
Public ImageId As IntPtr
public:
IntPtr ImageId
val mutable ImageId: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.ImageSize Field

MIplImageImageSize Field

image data size in bytes (=image->height*image->widthStep in case of interleaved data)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ImageSize
Public ImageSize As Integer
public:
int ImageSize
val mutable ImageSize: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.MaskROI Field

MIplImageMaskROI Field

must be NULL in OpenCV

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr MaskROI
Public MaskROI As IntPtr
public:
IntPtr MaskROI
val mutable MaskROI: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.NChannels Field

MIplImageNChannels Field

Most of OpenCV functions support 1,2,3 or 4 channels

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NChannels
Public NChannels As Integer
public:
int NChannels
val mutable NChannels: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.NSize Field

MIplImageNSize Field

sizeof(IplImage)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NSize
Public NSize As Integer
public:
int NSize
val mutable NSize: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.Origin Field

MIplImageOrigin Field

0 - top-left origin, 1 - bottom-left origin (Windows bitmaps style)

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Origin
Public Origin As Integer
public:
int Origin
val mutable Origin: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.Roi Field

MIplImageRoi Field

image ROI. when it is not NULL, this specifies image region to process

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Roi
Public Roi As IntPtr
public:
IntPtr Roi
val mutable Roi: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.TileInfo Field

MIplImageTileInfo Field

ditto

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr TileInfo
Public TileInfo As IntPtr
public:
IntPtr TileInfo
val mutable TileInfo: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.Width Field

MIplImageWidth Field

image width in pixels

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Width
Public Width As Integer
public:
int Width
val mutable Width: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MIplImage.WidthStep Field

MIplImageWidthStep Field

size of aligned image row in bytes

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int WidthStep
Public WidthStep As Integer
public:
int WidthStep
val mutable WidthStep: int

Field Value

Type: Int32
See Also

Reference

MIplImage Class
Emgu.CV.Structure Namespace


MKeyPoint Class

OpenCV's KeyPoint class
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureMKeyPoint

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MKeyPoint : ValueType
<SerializableAttribute>
Public NotInheritable Class MKeyPoint
    Inherits ValueType
[SerializableAttribute]
public ref class MKeyPoint sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type MKeyPoint =
    class
        inherit ValueType
    end

The MKeyPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Angle | Orientation of the keypoint
Public field | ClassId | class id
Public field | Octave | octave
Public field | Point | The location of the keypoint
Public field | Response | Response of the keypoint
Public field | Size | Size of the keypoint
Top
See Also

Reference

Emgu.CV.Structure Namespace


MKeyPoint Methods

The MKeyPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


MKeyPoint Fields

The MKeyPoint type exposes the following members.

Fields
 | Name | Description
Public field | Angle | Orientation of the keypoint
Public field | ClassId | class id
Public field | Octave | octave
Public field | Point | The location of the keypoint
Public field | Response | Response of the keypoint
Public field | Size | Size of the keypoint
Top
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


MKeyPoint.Angle Field

MKeyPointAngle Field

Orientation of the keypoint

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Angle
Public Angle As Single
public:
float Angle
val mutable Angle: float32

Field Value

Type: Single
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


MKeyPoint.ClassId Field

MKeyPointClassId Field

class id

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ClassId
Public ClassId As Integer
public:
int ClassId
val mutable ClassId: int

Field Value

Type: Int32
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


MKeyPoint.Octave Field

MKeyPointOctave Field

octave

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Octave
Public Octave As Integer
public:
int Octave
val mutable Octave: int

Field Value

Type: Int32
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


MKeyPoint.Point Field

MKeyPointPoint Field

The location of the keypoint

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Point
Public Point As PointF
public:
PointF^ Point
val mutable Point: PointF

Field Value

Type: PointF
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


MKeyPoint.Response Field

MKeyPointResponse Field

Response of the keypoint

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Response
Public Response As Single
public:
float Response
val mutable Response: float32

Field Value

Type: Single
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


MKeyPoint.Size Field

MKeyPointSize Field

Size of the keypoint

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Size
Public Size As Single
public:
float Size
val mutable Size: float32

Field Value

Type: Single
See Also

Reference

MKeyPoint Class
Emgu.CV.Structure Namespace


Range Class

The range use to setup the histogram
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureRange

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Range : ValueType,
    IEquatable<Range>
<SerializableAttribute>
Public NotInheritable Class Range
    Inherits ValueType
    Implements IEquatable(Of Range)
[SerializableAttribute]
public ref class Range sealed : public ValueType,
    IEquatable<Range^>
[<SealedAttribute>]
[<SerializableAttribute>]
type Range =
    class
        inherit ValueType
        interface IEquatable<Range>
    end

The Range type exposes the following members.

Constructors
 | Name | Description
Public method | Range | Create a range of the specific min/max value
Top
Properties
 | Name | Description
 | All | return the full range.
Public property | End | The end value of this range
Public property | Start | The start value of this range
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Range) | Return true if the two Range equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Range Constructor

Create a range of the specific min/max value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Range(
    int start,
    int end
)
Public Sub New (
    start As Integer,
    end As Integer
)
public:
Range(
    int start,
    int end
)
new :
        start : int *
        end : int -> Range

Parameters

start
Type: SystemInt32
The start value of this range
end
Type: SystemInt32
The max value of this range
See Also

Reference

Range Class
Emgu.CV.Structure Namespace


Range Properties

The Range type exposes the following members.

Properties
 | Name | Description
 | All | return the full range.
Public property | End | The end value of this range
Public property | Start | The start value of this range
Top
See Also

Reference

Range Class
Emgu.CV.Structure Namespace


Range.All Property

RangeAll Property

return the full range.

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Range All { get; }
Public Shared ReadOnly Property All As Range
    Get
public:
static property Range^ All {
    Range^ get ();
}
static member All : Range with get

Property Value

Type: Range
See Also

Reference

Range Class
Emgu.CV.Structure Namespace


Range.End Property

RangeEnd Property

The end value of this range

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int End { get; set; }
Public Property End As Integer
    Get
    Set
public:
property int End {
    int get ();
    void set (int value);
}
member End : int with get, set

Property Value

Type: Int32
See Also

Reference

Range Class
Emgu.CV.Structure Namespace


Range.Start Property

RangeStart Property

The start value of this range

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Type: Int32
See Also

Reference

Range Class
Emgu.CV.Structure Namespace


Range Methods

The Range type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Range) | Return true if the two Range equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Range Class
Emgu.CV.Structure Namespace


Range.Equals Method

RangeEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Range) | Return true if the two Range equals
Top
See Also

Reference

Range Class
Emgu.CV.Structure Namespace


Range.Equals Method (Range)

RangeEquals Method (Range)

http://www.emgu.com
Return true if the two Range equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Range other
)
Public Function Equals (
    other As Range
) As Boolean
public:
virtual bool Equals(
    Range^ other
) sealed
abstract Equals :
        other : Range -> bool
override Equals :
        other : Range -> bool

Parameters

other
Type: Emgu.CV.StructureRange
The other Range to compare with

Return Value

Type: Boolean
True if the two Range equals

Implements

IEquatableTEquals(T)
See Also

Reference

Range Class
Equals Overload
Emgu.CV.Structure Namespace


RangeF Class

The range use to setup the histogram
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureRangeF

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class RangeF : ValueType,
    IEquatable<RangeF>
<SerializableAttribute>
Public NotInheritable Class RangeF
    Inherits ValueType
    Implements IEquatable(Of RangeF)
[SerializableAttribute]
public ref class RangeF sealed : public ValueType,
    IEquatable<RangeF^>
[<SealedAttribute>]
[<SerializableAttribute>]
type RangeF =
    class
        inherit ValueType
        interface IEquatable<RangeF>
    end

The RangeF type exposes the following members.

Constructors
 | Name | Description
Public method | RangeF | Create a range of the specific min/max value
Top
Properties
 | Name | Description
Public property | Max | The Maximum value of this range
Public property | Min | The minimum value of this range
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(RangeF) | Return true if the two RangeF equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


RangeF Constructor

Create a range of the specific min/max value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RangeF(
    float min,
    float max
)
Public Sub New (
    min As Single,
    max As Single
)
public:
RangeF(
    float min,
    float max
)
new :
        min : float32 *
        max : float32 -> RangeF

Parameters

min
Type: SystemSingle
The min value of this range
max
Type: SystemSingle
The max value of this range
See Also

Reference

RangeF Class
Emgu.CV.Structure Namespace


RangeF Properties

The RangeF type exposes the following members.

Properties
 | Name | Description
Public property | Max | The Maximum value of this range
Public property | Min | The minimum value of this range
Top
See Also

Reference

RangeF Class
Emgu.CV.Structure Namespace


RangeF.Max Property

RangeFMax Property

The Maximum value of this range

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Max { get; set; }
Public Property Max As Single
    Get
    Set
public:
property float Max {
    float get ();
    void set (float value);
}
member Max : float32 with get, set

Property Value

Type: Single
See Also

Reference

RangeF Class
Emgu.CV.Structure Namespace


RangeF.Min Property

RangeFMin Property

The minimum value of this range

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Min { get; set; }
Public Property Min As Single
    Get
    Set
public:
property float Min {
    float get ();
    void set (float value);
}
member Min : float32 with get, set

Property Value

Type: Single
See Also

Reference

RangeF Class
Emgu.CV.Structure Namespace


RangeF Methods

The RangeF type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(RangeF) | Return true if the two RangeF equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

RangeF Class
Emgu.CV.Structure Namespace


RangeF.Equals Method

RangeFEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(RangeF) | Return true if the two RangeF equals
Top
See Also

Reference

RangeF Class
Emgu.CV.Structure Namespace


RangeF.Equals Method (RangeF)

RangeFEquals Method (RangeF)

http://www.emgu.com
Return true if the two RangeF equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    RangeF other
)
Public Function Equals (
    other As RangeF
) As Boolean
public:
virtual bool Equals(
    RangeF^ other
) sealed
abstract Equals :
        other : RangeF -> bool
override Equals :
        other : RangeF -> bool

Parameters

other
Type: Emgu.CV.StructureRangeF
The other RangeF to compare with

Return Value

Type: Boolean
True if the two RangeF equals

Implements

IEquatableTEquals(T)
See Also

Reference

RangeF Class
Equals Overload
Emgu.CV.Structure Namespace


Rgb Class

Defines a Rgb (Red Green Blue) color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureRgb

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Rgb : ValueType, IColor,
    IEquatable<Rgb>
Public NotInheritable Class Rgb
    Inherits ValueType
    Implements IColor, IEquatable(Of Rgb)
public ref class Rgb sealed : public ValueType,
    IColor, IEquatable<Rgb^>
[<SealedAttribute>]
type Rgb =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Rgb>
    end

The Rgb type exposes the following members.

Constructors
 | Name | Description
Public method | Rgb(Color) | Create a Rgb color using the system color
Public method | Rgb(Double, Double, Double) | Create a RGB color using the specific values
Top
Properties
 | Name | Description
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Rgb) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Rgb Constructor

Overload List
 | Name | Description
Public method | Rgb(Color) | Create a Rgb color using the system color
Public method | Rgb(Double, Double, Double) | Create a RGB color using the specific values
Top
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb Constructor (Color)

Create a Rgb color using the system color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rgb(
    Color winColor
)
Public Sub New (
    winColor As Color
)
public:
Rgb(
    Color^ winColor
)
new :
        winColor : Color -> Rgb

Parameters

winColor
Type: System.DrawingColor
color
See Also

Reference

Rgb Class
Rgb Overload
Emgu.CV.Structure Namespace


Rgb Constructor (Double, Double, Double)

Create a RGB color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rgb(
    double red,
    double green,
    double blue
)
Public Sub New (
    red As Double,
    green As Double,
    blue As Double
)
public:
Rgb(
    double red,
    double green,
    double blue
)
new :
        red : float *
        green : float *
        blue : float -> Rgb

Parameters

red
Type: SystemDouble
The red value for this color
green
Type: SystemDouble
The green value for this color
blue
Type: SystemDouble
The blue value for this color
See Also

Reference

Rgb Class
Rgb Overload
Emgu.CV.Structure Namespace


Rgb Properties

The Rgb type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb.Blue Property

RgbBlue Property

Get or set the intensity of the blue color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Blue { get; set; }
Public Property Blue As Double
    Get
    Set
public:
property double Blue {
    double get ();
    void set (double value);
}
member Blue : float with get, set

Property Value

Type: Double
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb.Dimension Property

RgbDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb.Green Property

RgbGreen Property

Get or set the intensity of the green color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Green { get; set; }
Public Property Green As Double
    Get
    Set
public:
property double Green {
    double get ();
    void set (double value);
}
member Green : float with get, set

Property Value

Type: Double
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb.MCvScalar Property

RgbMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb.Red Property

RgbRed Property

Get or set the intensity of the red color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Red { get; set; }
Public Property Red As Double
    Get
    Set
public:
property double Red {
    double get ();
    void set (double value);
}
member Red : float with get, set

Property Value

Type: Double
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb Methods

The Rgb type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Rgb) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb.Equals Method

RgbEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Rgb) | Return true if the two color equals
Top
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgb.Equals Method (Rgb)

RgbEquals Method (Rgb)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Rgb other
)
Public Function Equals (
    other As Rgb
) As Boolean
public:
virtual bool Equals(
    Rgb^ other
) sealed
abstract Equals :
        other : Rgb -> bool
override Equals :
        other : Rgb -> bool

Parameters

other
Type: Emgu.CV.StructureRgb
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Rgb Class
Equals Overload
Emgu.CV.Structure Namespace


Rgb.ToString Method

RgbToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Rgb Class
Emgu.CV.Structure Namespace


Rgba Class

Defines a Rgba (Red Green Blue Alpha) color
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureRgba

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Rgba : ValueType, IColor,
    IEquatable<Rgba>
Public NotInheritable Class Rgba
    Inherits ValueType
    Implements IColor, IEquatable(Of Rgba)
public ref class Rgba sealed : public ValueType,
    IColor, IEquatable<Rgba^>
[<SealedAttribute>]
type Rgba =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Rgba>
    end

The Rgba type exposes the following members.

Constructors
 | Name | Description
Public method | Rgba | Create a RGBA color using the specific values
Top
Properties
 | Name | Description
Public property | Alpha | Get or set the intensity of the alpha color channel
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Rgba) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Rgba Constructor

Create a RGBA color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rgba(
    double red,
    double green,
    double blue,
    double alpha
)
Public Sub New (
    red As Double,
    green As Double,
    blue As Double,
    alpha As Double
)
public:
Rgba(
    double red,
    double green,
    double blue,
    double alpha
)
new :
        red : float *
        green : float *
        blue : float *
        alpha : float -> Rgba

Parameters

red
Type: SystemDouble
The red value for this color
green
Type: SystemDouble
The green value for this color
blue
Type: SystemDouble
The blue value for this color
alpha
Type: SystemDouble
The alpha value for this color
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba Properties

The Rgba type exposes the following members.

Properties
 | Name | Description
Public property | Alpha | Get or set the intensity of the alpha color channel
Public property | Blue | Get or set the intensity of the blue color channel
Public property | Dimension | Get the dimension of this color
Public property | Green | Get or set the intensity of the green color channel
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Red | Get or set the intensity of the red color channel
Top
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.Alpha Property

RgbaAlpha Property

Get or set the intensity of the alpha color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Alpha { get; set; }
Public Property Alpha As Double
    Get
    Set
public:
property double Alpha {
    double get ();
    void set (double value);
}
member Alpha : float with get, set

Property Value

Type: Double
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.Blue Property

RgbaBlue Property

Get or set the intensity of the blue color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Blue { get; set; }
Public Property Blue As Double
    Get
    Set
public:
property double Blue {
    double get ();
    void set (double value);
}
member Blue : float with get, set

Property Value

Type: Double
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.Dimension Property

RgbaDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.Green Property

RgbaGreen Property

Get or set the intensity of the green color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Green { get; set; }
Public Property Green As Double
    Get
    Set
public:
property double Green {
    double get ();
    void set (double value);
}
member Green : float with get, set

Property Value

Type: Double
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.MCvScalar Property

RgbaMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.Red Property

RgbaRed Property

Get or set the intensity of the red color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Red { get; set; }
Public Property Red As Double
    Get
    Set
public:
property double Red {
    double get ();
    void set (double value);
}
member Red : float with get, set

Property Value

Type: Double
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba Methods

The Rgba type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Rgba) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.Equals Method

RgbaEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Rgba) | Return true if the two color equals
Top
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


Rgba.Equals Method (Rgba)

RgbaEquals Method (Rgba)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Rgba other
)
Public Function Equals (
    other As Rgba
) As Boolean
public:
virtual bool Equals(
    Rgba^ other
) sealed
abstract Equals :
        other : Rgba -> bool
override Equals :
        other : Rgba -> bool

Parameters

other
Type: Emgu.CV.StructureRgba
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Rgba Class
Equals Overload
Emgu.CV.Structure Namespace


Rgba.ToString Method

RgbaToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Rgba Class
Emgu.CV.Structure Namespace


RotatedRect Class

Managed structure equivalent to CvBox2D
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureRotatedRect

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class RotatedRect : ValueType,
    IConvexPolygonF, IEquatable<RotatedRect>
<SerializableAttribute>
Public NotInheritable Class RotatedRect
    Inherits ValueType
    Implements IConvexPolygonF, IEquatable(Of RotatedRect)
[SerializableAttribute]
public ref class RotatedRect sealed : public ValueType,
    IConvexPolygonF, IEquatable<RotatedRect^>
[<SealedAttribute>]
[<SerializableAttribute>]
type RotatedRect =
    class
        inherit ValueType
        interface IConvexPolygonF
        interface IEquatable<RotatedRect>
    end

The RotatedRect type exposes the following members.

Constructors
 | Name | Description
Public method | RotatedRect | Create a RotatedRect structure with the specific parameters
Top
Properties
Name | Description
Empty | Represent an uninitialized RotatedRect
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(RotatedRect) | Returns true if the two box are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertices | Get the 4 verticies of this Box.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinAreaRect | Get the minimum enclosing rectangle for this Box
Public method | Offset | Shift the box by the specific amount
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
(RectangleF to RotatedRect) | Convert a RectangleF to RotatedRect
Top
Fields
 | Name | Description
Public field | Angle | The angle between the horizontal axis and the first side (i.e. width) in degrees
Public field | Center | The center of the box
Public field | Size | The size of the box
Top
See Also

Reference

Emgu.CV.Structure Namespace


RotatedRect Constructor

Create a RotatedRect structure with the specific parameters

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RotatedRect(
    PointF center,
    SizeF size,
    float angle
)
Public Sub New (
    center As PointF,
    size As SizeF,
    angle As Single
)
public:
RotatedRect(
    PointF^ center,
    SizeF^ size,
    float angle
)
new :
        center : PointF *
        size : SizeF *
        angle : float32 -> RotatedRect

Parameters

center
Type: System.DrawingPointF
The center of the box
size
Type: System.DrawingSizeF
The size of the box
angle
Type: SystemSingle
The angle of the box in degrees. Possitive value means counter-clock wise rotation
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect Properties

The RotatedRect type exposes the following members.

Properties
Name | Description
Empty | Represent an uninitialized RotatedRect
Top
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.Empty Property

RotatedRectEmpty Property

Represent an uninitialized RotatedRect

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static RotatedRect Empty { get; }
Public Shared ReadOnly Property Empty As RotatedRect
    Get
public:
static property RotatedRect^ Empty {
    RotatedRect^ get ();
}
static member Empty : RotatedRect with get

Property Value

Type: RotatedRect
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect Methods

The RotatedRect type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(RotatedRect) | Returns true if the two box are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertices | Get the 4 verticies of this Box.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinAreaRect | Get the minimum enclosing rectangle for this Box
Public method | Offset | Shift the box by the specific amount
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.Equals Method

RotatedRectEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(RotatedRect) | Returns true if the two box are equal
Top
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.Equals Method (RotatedRect)

RotatedRectEquals Method (RotatedRect)

http://www.emgu.com
Returns true if the two box are equal

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    RotatedRect other
)
Public Function Equals (
    other As RotatedRect
) As Boolean
public:
virtual bool Equals(
    RotatedRect^ other
) sealed
abstract Equals :
        other : RotatedRect -> bool
override Equals :
        other : RotatedRect -> bool

Parameters

other
Type: Emgu.CV.StructureRotatedRect
The other box to compare with

Return Value

Type: Boolean
True if two boxes are equal

Implements

IEquatableTEquals(T)
See Also

Reference

RotatedRect Class
Equals Overload
Emgu.CV.Structure Namespace


RotatedRect.GetVertices Method

RotatedRectGetVertices Method

Get the 4 verticies of this Box.

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF[] GetVertices()
Public Function GetVertices As PointF()
public:
virtual array<PointF^>^ GetVertices() sealed
abstract GetVertices : unit -> PointF[]
override GetVertices : unit -> PointF[]

Return Value

Type: PointF
The vertives of this RotatedRect

Implements

IConvexPolygonFGetVertices
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.MinAreaRect Method

RotatedRectMinAreaRect Method

Get the minimum enclosing rectangle for this Box

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle MinAreaRect()
Public Function MinAreaRect As Rectangle
public:
Rectangle^ MinAreaRect()
member MinAreaRect : unit -> Rectangle

Return Value

Type: Rectangle
The minimum enclosing rectangle for this Box
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.Offset Method

RotatedRectOffset Method

Shift the box by the specific amount

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Offset(
    int x,
    int y
)
Public Sub Offset (
    x As Integer,
    y As Integer
)
public:
void Offset(
    int x,
    int y
)
member Offset :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
The x value to be offseted
y
Type: SystemInt32
The y value to be offseted
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect Type Conversions

The RotatedRect type exposes the following members.

Operators
Name | Description
(RectangleF to RotatedRect) | Convert a RectangleF to RotatedRect
Top
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect Implicit Conversion (RectangleF to RotatedRect)

RotatedRect Conversion (RectangleF to RotatedRect)

http://www.emgu.com
Convert a RectangleF to RotatedRect

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static implicit operator RotatedRect (
    RectangleF rectangle
)
Public Shared Widening Operator CType (
    rectangle As RectangleF
) As RotatedRect
static implicit operator RotatedRect^ (
    RectangleF^ rectangle
)
F# does not support the declaration of new casting operators.

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle

Return Value

Type: RotatedRect
The equivalent RotatedRect
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect Fields

The RotatedRect type exposes the following members.

Fields
 | Name | Description
Public field | Angle | The angle between the horizontal axis and the first side (i.e. width) in degrees
Public field | Center | The center of the box
Public field | Size | The size of the box
Top
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.Angle Field

RotatedRectAngle Field

The angle between the horizontal axis and the first side (i.e. width) in degrees

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Angle
Public Angle As Single
public:
float Angle
val mutable Angle: float32

Field Value

Type: Single
Remarks
Possitive value means counter-clock wise rotation
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.Center Field

RotatedRectCenter Field

The center of the box

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Center
Public Center As PointF
public:
PointF^ Center
val mutable Center: PointF

Field Value

Type: PointF
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


RotatedRect.Size Field

RotatedRectSize Field

The size of the box

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SizeF Size
Public Size As SizeF
public:
SizeF^ Size
val mutable Size: SizeF

Field Value

Type: SizeF
See Also

Reference

RotatedRect Class
Emgu.CV.Structure Namespace


Triangle2DF Class

A 2D triangle
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureTriangle2DF

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Triangle2DF : ValueType,
    IConvexPolygonF, IEquatable<Triangle2DF>
<SerializableAttribute>
Public NotInheritable Class Triangle2DF
    Inherits ValueType
    Implements IConvexPolygonF, IEquatable(Of Triangle2DF)
[SerializableAttribute]
public ref class Triangle2DF sealed : public ValueType,
    IConvexPolygonF, IEquatable<Triangle2DF^>
[<SealedAttribute>]
[<SerializableAttribute>]
type Triangle2DF =
    class
        inherit ValueType
        interface IConvexPolygonF
        interface IEquatable<Triangle2DF>
    end

The Triangle2DF type exposes the following members.

Constructors
 | Name | Description
Public method | Triangle2DF | Create a triangle using the specific vertices
Top
Properties
 | Name | Description
Public property | Area | Get the area of this triangle
Public property | Centeroid | Returns the centroid of this triangle
Public property | V0 | One of the vertex of the triangle
Public property | V1 | One of the vertex of the triangle
Public property | V2 | One of the vertex of the triangle
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Triangle2DF) | Compare two triangles and return true if equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertices | Get the vertices of this triangle
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Triangle2DF Constructor

Create a triangle using the specific vertices

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Triangle2DF(
    PointF v0,
    PointF v1,
    PointF v2
)
Public Sub New (
    v0 As PointF,
    v1 As PointF,
    v2 As PointF
)
public:
Triangle2DF(
    PointF^ v0,
    PointF^ v1,
    PointF^ v2
)
new :
        v0 : PointF *
        v1 : PointF *
        v2 : PointF -> Triangle2DF

Parameters

v0
Type: System.DrawingPointF
The first vertex
v1
Type: System.DrawingPointF
The second vertex
v2
Type: System.DrawingPointF
The third vertex
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF Properties

The Triangle2DF type exposes the following members.

Properties
 | Name | Description
Public property | Area | Get the area of this triangle
Public property | Centeroid | Returns the centroid of this triangle
Public property | V0 | One of the vertex of the triangle
Public property | V1 | One of the vertex of the triangle
Public property | V2 | One of the vertex of the triangle
Top
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF.Area Property

Triangle2DFArea Property

Get the area of this triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Type: Double
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF.Centeroid Property

Triangle2DFCenteroid Property

Returns the centroid of this triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF Centeroid { get; }
Public ReadOnly Property Centeroid As PointF
    Get
public:
property PointF^ Centeroid {
    PointF^ get ();
}
member Centeroid : PointF with get

Property Value

Type: PointF
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF.V0 Property

Triangle2DFV0 Property

One of the vertex of the triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF V0 { get; set; }
Public Property V0 As PointF
    Get
    Set
public:
property PointF^ V0 {
    PointF^ get ();
    void set (PointF^ value);
}
member V0 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF.V1 Property

Triangle2DFV1 Property

One of the vertex of the triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF V1 { get; set; }
Public Property V1 As PointF
    Get
    Set
public:
property PointF^ V1 {
    PointF^ get ();
    void set (PointF^ value);
}
member V1 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF.V2 Property

Triangle2DFV2 Property

One of the vertex of the triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF V2 { get; set; }
Public Property V2 As PointF
    Get
    Set
public:
property PointF^ V2 {
    PointF^ get ();
    void set (PointF^ value);
}
member V2 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF Methods

The Triangle2DF type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Triangle2DF) | Compare two triangles and return true if equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertices | Get the vertices of this triangle
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF.Equals Method

Triangle2DFEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Triangle2DF) | Compare two triangles and return true if equal
Top
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle2DF.Equals Method (Triangle2DF)

Triangle2DFEquals Method (Triangle2DF)

http://www.emgu.com
Compare two triangles and return true if equal

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Triangle2DF tri
)
Public Function Equals (
    tri As Triangle2DF
) As Boolean
public:
virtual bool Equals(
    Triangle2DF^ tri
) sealed
abstract Equals :
        tri : Triangle2DF -> bool
override Equals :
        tri : Triangle2DF -> bool

Parameters

tri
Type: Emgu.CV.StructureTriangle2DF
the other triangles to compare with

Return Value

Type: Boolean
true if the two triangles equals, false otherwise

Implements

IEquatableTEquals(T)
See Also

Reference

Triangle2DF Class
Equals Overload
Emgu.CV.Structure Namespace


Triangle2DF.GetVertices Method

Triangle2DFGetVertices Method

Get the vertices of this triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF[] GetVertices()
Public Function GetVertices As PointF()
public:
virtual array<PointF^>^ GetVertices() sealed
abstract GetVertices : unit -> PointF[]
override GetVertices : unit -> PointF[]

Return Value

Type: PointF
The vertices of this triangle

Implements

IConvexPolygonFGetVertices
See Also

Reference

Triangle2DF Class
Emgu.CV.Structure Namespace


Triangle3DF Class

A 3D triangle
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureTriangle3DF

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Triangle3DF : ValueType,
    IEquatable<Triangle3DF>
<SerializableAttribute>
Public NotInheritable Class Triangle3DF
    Inherits ValueType
    Implements IEquatable(Of Triangle3DF)
[SerializableAttribute]
public ref class Triangle3DF sealed : public ValueType,
    IEquatable<Triangle3DF^>
[<SealedAttribute>]
[<SerializableAttribute>]
type Triangle3DF =
    class
        inherit ValueType
        interface IEquatable<Triangle3DF>
    end

The Triangle3DF type exposes the following members.

Constructors
 | Name | Description
Public method | Triangle3DF | Create a triangle using the specific vertices
Top
Properties
 | Name | Description
Public property | Area | Get the area of this triangle
Public property | Centeroid | Returns the centroid of this triangle
Public property | Normal | Get the normal of this triangle
Public property | V0 | One of the vertex of the triangle
Public property | V1 | One of the vertex of the triangle
Public property | V2 | One of the vertex of the triangle
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Triangle3DF) | Compare two triangles and return true if equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Triangle3DF Constructor

Create a triangle using the specific vertices

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Triangle3DF(
    MCvPoint3D32f v0,
    MCvPoint3D32f v1,
    MCvPoint3D32f v2
)
Public Sub New (
    v0 As MCvPoint3D32f,
    v1 As MCvPoint3D32f,
    v2 As MCvPoint3D32f
)
public:
Triangle3DF(
    MCvPoint3D32f^ v0,
    MCvPoint3D32f^ v1,
    MCvPoint3D32f^ v2
)
new :
        v0 : MCvPoint3D32f *
        v1 : MCvPoint3D32f *
        v2 : MCvPoint3D32f -> Triangle3DF

Parameters

v0
Type: Emgu.CV.StructureMCvPoint3D32f
The first vertex
v1
Type: Emgu.CV.StructureMCvPoint3D32f
The second vertex
v2
Type: Emgu.CV.StructureMCvPoint3D32f
The third vertex
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF Properties

The Triangle3DF type exposes the following members.

Properties
 | Name | Description
Public property | Area | Get the area of this triangle
Public property | Centeroid | Returns the centroid of this triangle
Public property | Normal | Get the normal of this triangle
Public property | V0 | One of the vertex of the triangle
Public property | V1 | One of the vertex of the triangle
Public property | V2 | One of the vertex of the triangle
Top
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.Area Property

Triangle3DFArea Property

Get the area of this triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Type: Double
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.Centeroid Property

Triangle3DFCenteroid Property

Returns the centroid of this triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f Centeroid { get; }
Public ReadOnly Property Centeroid As MCvPoint3D32f
    Get
public:
property MCvPoint3D32f^ Centeroid {
    MCvPoint3D32f^ get ();
}
member Centeroid : MCvPoint3D32f with get

Property Value

Type: MCvPoint3D32f
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.Normal Property

Triangle3DFNormal Property

Get the normal of this triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f Normal { get; }
Public ReadOnly Property Normal As MCvPoint3D32f
    Get
public:
property MCvPoint3D32f^ Normal {
    MCvPoint3D32f^ get ();
}
member Normal : MCvPoint3D32f with get

Property Value

Type: MCvPoint3D32f
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.V0 Property

Triangle3DFV0 Property

One of the vertex of the triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f V0 { get; set; }
Public Property V0 As MCvPoint3D32f
    Get
    Set
public:
property MCvPoint3D32f^ V0 {
    MCvPoint3D32f^ get ();
    void set (MCvPoint3D32f^ value);
}
member V0 : MCvPoint3D32f with get, set

Property Value

Type: MCvPoint3D32f
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.V1 Property

Triangle3DFV1 Property

One of the vertex of the triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f V1 { get; set; }
Public Property V1 As MCvPoint3D32f
    Get
    Set
public:
property MCvPoint3D32f^ V1 {
    MCvPoint3D32f^ get ();
    void set (MCvPoint3D32f^ value);
}
member V1 : MCvPoint3D32f with get, set

Property Value

Type: MCvPoint3D32f
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.V2 Property

Triangle3DFV2 Property

One of the vertex of the triangle

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f V2 { get; set; }
Public Property V2 As MCvPoint3D32f
    Get
    Set
public:
property MCvPoint3D32f^ V2 {
    MCvPoint3D32f^ get ();
    void set (MCvPoint3D32f^ value);
}
member V2 : MCvPoint3D32f with get, set

Property Value

Type: MCvPoint3D32f
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF Methods

The Triangle3DF type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Triangle3DF) | Compare two triangles and return true if equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.Equals Method

Triangle3DFEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Triangle3DF) | Compare two triangles and return true if equal
Top
See Also

Reference

Triangle3DF Class
Emgu.CV.Structure Namespace


Triangle3DF.Equals Method (Triangle3DF)

Triangle3DFEquals Method (Triangle3DF)

http://www.emgu.com
Compare two triangles and return true if equal

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Triangle3DF tri
)
Public Function Equals (
    tri As Triangle3DF
) As Boolean
public:
virtual bool Equals(
    Triangle3DF^ tri
) sealed
abstract Equals :
        tri : Triangle3DF -> bool
override Equals :
        tri : Triangle3DF -> bool

Parameters

tri
Type: Emgu.CV.StructureTriangle3DF
the other triangles to compare with

Return Value

Type: Boolean
true if the two triangles equals, false otherwise

Implements

IEquatableTEquals(T)
See Also

Reference

Triangle3DF Class
Equals Overload
Emgu.CV.Structure Namespace


Xyz Class

Defines a Xyz color (CIE XYZ.Rec 709 with D65 white point)
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureXyz

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Xyz : ValueType, IColor,
    IEquatable<Xyz>
Public NotInheritable Class Xyz
    Inherits ValueType
    Implements IColor, IEquatable(Of Xyz)
public ref class Xyz sealed : public ValueType,
    IColor, IEquatable<Xyz^>
[<SealedAttribute>]
type Xyz =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Xyz>
    end

The Xyz type exposes the following members.

Constructors
 | Name | Description
Public method | Xyz | Create a Xyz color using the specific values
Top
Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | X | Get or set the intensity of the x color channel
Public property | Y | Get or set the intensity of the y color channel
Public property | Z | Get or set the intensity of the z color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Xyz) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Xyz Constructor

Create a Xyz color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Xyz(
    double x,
    double y,
    double z
)
Public Sub New (
    x As Double,
    y As Double,
    z As Double
)
public:
Xyz(
    double x,
    double y,
    double z
)
new :
        x : float *
        y : float *
        z : float -> Xyz

Parameters

x
Type: SystemDouble
The x value for this color
y
Type: SystemDouble
The y value for this color
z
Type: SystemDouble
The z value for this color
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz Properties

The Xyz type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | X | Get or set the intensity of the x color channel
Public property | Y | Get or set the intensity of the y color channel
Public property | Z | Get or set the intensity of the z color channel
Top
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz.Dimension Property

XyzDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz.MCvScalar Property

XyzMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz.X Property

XyzX Property

Get or set the intensity of the x color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double X { get; set; }
Public Property X As Double
    Get
    Set
public:
property double X {
    double get ();
    void set (double value);
}
member X : float with get, set

Property Value

Type: Double
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz.Y Property

XyzY Property

Get or set the intensity of the y color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Y { get; set; }
Public Property Y As Double
    Get
    Set
public:
property double Y {
    double get ();
    void set (double value);
}
member Y : float with get, set

Property Value

Type: Double
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz.Z Property

XyzZ Property

Get or set the intensity of the z color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Z { get; set; }
Public Property Z As Double
    Get
    Set
public:
property double Z {
    double get ();
    void set (double value);
}
member Z : float with get, set

Property Value

Type: Double
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz Methods

The Xyz type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Xyz) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz.Equals Method

XyzEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Xyz) | Return true if the two color equals
Top
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Xyz.Equals Method (Xyz)

XyzEquals Method (Xyz)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Xyz other
)
Public Function Equals (
    other As Xyz
) As Boolean
public:
virtual bool Equals(
    Xyz^ other
) sealed
abstract Equals :
        other : Xyz -> bool
override Equals :
        other : Xyz -> bool

Parameters

other
Type: Emgu.CV.StructureXyz
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Xyz Class
Equals Overload
Emgu.CV.Structure Namespace


Xyz.ToString Method

XyzToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Xyz Class
Emgu.CV.Structure Namespace


Ycc Class

Defines a Ycc color (YCrCb JPEG)
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.StructureYcc

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Ycc : ValueType, IColor,
    IEquatable<Ycc>
Public NotInheritable Class Ycc
    Inherits ValueType
    Implements IColor, IEquatable(Of Ycc)
public ref class Ycc sealed : public ValueType,
    IColor, IEquatable<Ycc^>
[<SealedAttribute>]
type Ycc =
    class
        inherit ValueType
        interface IColor
        interface IEquatable<Ycc>
    end

The Ycc type exposes the following members.

Constructors
 | Name | Description
Public method | Ycc | Create a Ycc color using the specific values
Top
Properties
 | Name | Description
Public property | Cb | Get or set the intensity of the Cb color channel
Public property | Cr | Get or set the intensity of the Cr color channel
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Y | Get or set the intensity of the Y color channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Ycc) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Emgu.CV.Structure Namespace


Ycc Constructor

Create a Ycc color using the specific values

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Ycc(
    double y,
    double cr,
    double cb
)
Public Sub New (
    y As Double,
    cr As Double,
    cb As Double
)
public:
Ycc(
    double y,
    double cr,
    double cb
)
new :
        y : float *
        cr : float *
        cb : float -> Ycc

Parameters

y
Type: SystemDouble
The Y value for this color
cr
Type: SystemDouble
The Cr value for this color
cb
Type: SystemDouble
The Cb value for this color
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc Properties

The Ycc type exposes the following members.

Properties
 | Name | Description
Public property | Cb | Get or set the intensity of the Cb color channel
Public property | Cr | Get or set the intensity of the Cr color channel
Public property | Dimension | Get the dimension of this color
Public property | MCvScalar | Get or Set the equivalent MCvScalar value
Public property | Y | Get or set the intensity of the Y color channel
Top
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc.Cb Property

YccCb Property

Get or set the intensity of the Cb color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Cb { get; set; }
Public Property Cb As Double
    Get
    Set
public:
property double Cb {
    double get ();
    void set (double value);
}
member Cb : float with get, set

Property Value

Type: Double
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc.Cr Property

YccCr Property

Get or set the intensity of the Cr color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Cr { get; set; }
Public Property Cr As Double
    Get
    Set
public:
property double Cr {
    double get ();
    void set (double value);
}
member Cr : float with get, set

Property Value

Type: Double
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc.Dimension Property

YccDimension Property

Get the dimension of this color

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () sealed;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Type: Int32

Implements

IColorDimension
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc.MCvScalar Property

YccMCvScalar Property

Get or Set the equivalent MCvScalar value

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvScalar MCvScalar { get; set; }
Public Property MCvScalar As MCvScalar
    Get
    Set
public:
virtual property MCvScalar^ MCvScalar {
    MCvScalar^ get () sealed;
    void set (MCvScalar^ value) sealed;
}
abstract MCvScalar : MCvScalar with get, set
override MCvScalar : MCvScalar with get, set

Property Value

Type: MCvScalar

Implements

IColorMCvScalar
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc.Y Property

YccY Property

Get or set the intensity of the Y color channel

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double Y { get; set; }
Public Property Y As Double
    Get
    Set
public:
property double Y {
    double get ();
    void set (double value);
}
member Y : float with get, set

Property Value

Type: Double
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc Methods

The Ycc type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Ycc) | Return true if the two color equals
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Represent this color as a String (Overrides ValueTypeToString.)
Top
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc.Equals Method

YccEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | Equals(Ycc) | Return true if the two color equals
Top
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Ycc.Equals Method (Ycc)

YccEquals Method (Ycc)

http://www.emgu.com
Return true if the two color equals

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Ycc other
)
Public Function Equals (
    other As Ycc
) As Boolean
public:
virtual bool Equals(
    Ycc^ other
) sealed
abstract Equals :
        other : Ycc -> bool
override Equals :
        other : Ycc -> bool

Parameters

other
Type: Emgu.CV.StructureYcc
The other color to compare with

Return Value

Type: Boolean
true if the two color equals

Implements

IEquatableTEquals(T)
See Also

Reference

Ycc Class
Equals Overload
Emgu.CV.Structure Namespace


Ycc.ToString Method

YccToString Method

Represent this color as a String

Namespace: Emgu.CV.Structure
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The string representation of this color
See Also

Reference

Ycc Class
Emgu.CV.Structure Namespace


Emgu.CV.Superres Namespace

The Super Resolution module contains a set of functions and classes that can be used to solve the problem of resolution enhancement.
Classes
 | Class | Description
Public class | FrameSource | Create a video frame source
Public class | SuperResolution | Supper resolution
Public class | SuperResolutionOpticalFlowType | The type of optical flow algorithms used for super resolution


FrameSource Class

Create a video frame source
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.SuperresFrameSource
Emgu.CV.SuperresSuperResolution

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FrameSource : UnmanagedObject
Public Class FrameSource
    Inherits UnmanagedObject
public ref class FrameSource : public UnmanagedObject
type FrameSource =
    class
        inherit UnmanagedObject
    end

The FrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | FrameSource(Int32) | Create a framesource using the specific camera
Public method | FrameSource(String, Boolean) | Create video frame source from video file
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this framesource (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Get the next frame
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _frameSourcePtr | The pointer to the frame source
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Superres Namespace


FrameSource Constructor

Overload List
 | Name | Description
Public method | FrameSource(Int32) | Create a framesource using the specific camera
Public method | FrameSource(String, Boolean) | Create video frame source from video file
Top
See Also

Reference

FrameSource Class
Emgu.CV.Superres Namespace


FrameSource Constructor (Int32)

Create a framesource using the specific camera

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FrameSource(
    int camIndex
)
Public Sub New (
    camIndex As Integer
)
public:
FrameSource(
    int camIndex
)
new :
        camIndex : int -> FrameSource

Parameters

camIndex
Type: SystemInt32
The index of the camera to create capture from, starting from 0
See Also

Reference

FrameSource Class
FrameSource Overload
Emgu.CV.Superres Namespace


FrameSource Constructor (String, Boolean)

Create video frame source from video file

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FrameSource(
    string fileName,
    bool tryUseGpu
)
Public Sub New (
    fileName As String,
    tryUseGpu As Boolean
)
public:
FrameSource(
    String^ fileName,
    bool tryUseGpu
)
new :
        fileName : string *
        tryUseGpu : bool -> FrameSource

Parameters

fileName
Type: SystemString
The name of the file
tryUseGpu
Type: SystemBoolean
If true, it will try to create video frame source using gpu
See Also

Reference

FrameSource Class
FrameSource Overload
Emgu.CV.Superres Namespace


FrameSource Properties

The FrameSource type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FrameSource Class
Emgu.CV.Superres Namespace


FrameSource Methods

The FrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this framesource (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Get the next frame
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FrameSource Class
Emgu.CV.Superres Namespace


FrameSource.DisposeObject Method

FrameSourceDisposeObject Method

Release all the unmanaged memory associated with this framesource

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FrameSource Class
Emgu.CV.Superres Namespace


FrameSource.NextFrame Method

FrameSourceNextFrame Method

Get the next frame

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void NextFrame(
    IOutputArray frame
)
Public Sub NextFrame (
    frame As IOutputArray
)
public:
void NextFrame(
    IOutputArray^ frame
)
member NextFrame :
        frame : IOutputArray -> unit

Parameters

frame
Type: Emgu.CVIOutputArray

[Missing <param name="frame"/> documentation for "M:Emgu.CV.Superres.FrameSource.NextFrame(Emgu.CV.IOutputArray)"]

See Also

Reference

FrameSource Class
Emgu.CV.Superres Namespace


FrameSource Fields

The FrameSource type exposes the following members.

Fields
 | Name | Description
Protected field | _frameSourcePtr | The pointer to the frame source
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FrameSource Class
Emgu.CV.Superres Namespace


FrameSource._frameSourcePtr Field

FrameSource_frameSourcePtr Field

The pointer to the frame source

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _frameSourcePtr
Protected _frameSourcePtr As IntPtr
protected:
IntPtr _frameSourcePtr
val mutable _frameSourcePtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

FrameSource Class
Emgu.CV.Superres Namespace


SuperResolution Class

Supper resolution
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.SuperresFrameSource
Emgu.CV.SuperresSuperResolution

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SuperResolution : FrameSource
Public Class SuperResolution
    Inherits FrameSource
public ref class SuperResolution : public FrameSource
type SuperResolution =
    class
        inherit FrameSource
    end

The SuperResolution type exposes the following members.

Constructors
 | Name | Description
Public method | SuperResolution | Create a super resolution solver for the given frameSource
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated to this object (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Get the next frame (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _frameSourcePtr | The pointer to the frame source (Inherited from FrameSource.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Superres Namespace


SuperResolution Constructor

Create a super resolution solver for the given frameSource

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SuperResolution(
    SuperResolutionOpticalFlowType type,
    FrameSource frameSource
)
Public Sub New (
    type As SuperResolutionOpticalFlowType,
    frameSource As FrameSource
)
public:
SuperResolution(
    SuperResolutionOpticalFlowType^ type,
    FrameSource^ frameSource
)
new :
        type : SuperResolutionOpticalFlowType *
        frameSource : FrameSource -> SuperResolution

Parameters

type
Type: Emgu.CV.SuperresSuperResolutionOpticalFlowType
The type of optical flow algorithm to use
frameSource
Type: Emgu.CV.SuperresFrameSource
The frameSource
See Also

Reference

SuperResolution Class
Emgu.CV.Superres Namespace


SuperResolution Properties

The SuperResolution type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SuperResolution Class
Emgu.CV.Superres Namespace


SuperResolution Methods

The SuperResolution type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated to this object (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Get the next frame (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SuperResolution Class
Emgu.CV.Superres Namespace


SuperResolution.DisposeObject Method

SuperResolutionDisposeObject Method

Release all the unmanaged memory associated to this object

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SuperResolution Class
Emgu.CV.Superres Namespace


SuperResolution Fields

The SuperResolution type exposes the following members.

Fields
 | Name | Description
Protected field | _frameSourcePtr | The pointer to the frame source (Inherited from FrameSource.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SuperResolution Class
Emgu.CV.Superres Namespace


SuperResolution.OpticalFlowType Class

SuperResolutionOpticalFlowType Class

The type of optical flow algorithms used for super resolution
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.SuperresSuperResolutionOpticalFlowType

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class OpticalFlowType : Enum
Public NotInheritable Class OpticalFlowType
    Inherits Enum
public ref class OpticalFlowType sealed : public Enum
[<SealedAttribute>]
type OpticalFlowType =
    class
        inherit Enum
    end

The SuperResolutionOpticalFlowType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Btvl | BTVL
 | Btvl1Gpu | BTVL using gpu
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Superres Namespace


OpticalFlowType Methods

The SuperResolutionOpticalFlowType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SuperResolutionOpticalFlowType Class
Emgu.CV.Superres Namespace


OpticalFlowType Fields

The SuperResolutionOpticalFlowType type exposes the following members.

Fields
 | Name | Description
 | Btvl | BTVL
 | Btvl1Gpu | BTVL using gpu
Public field | value__ |
Top
See Also

Reference

SuperResolutionOpticalFlowType Class
Emgu.CV.Superres Namespace


SuperResolution.OpticalFlowType.Btvl Field

SuperResolutionOpticalFlowTypeBtvl Field

BTVL

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SuperResolutionOpticalFlowType Btvl = 0
Public Const Btvl As SuperResolutionOpticalFlowType = 0
public:
literal SuperResolutionOpticalFlowType^ Btvl = 0
static val mutable Btvl: SuperResolutionOpticalFlowType

Field Value

Type: SuperResolutionOpticalFlowType
See Also

Reference

SuperResolutionOpticalFlowType Class
Emgu.CV.Superres Namespace


SuperResolution.OpticalFlowType.Btvl1Gpu Field

SuperResolutionOpticalFlowTypeBtvl1Gpu Field

BTVL using gpu

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SuperResolutionOpticalFlowType Btvl1Gpu = 1
Public Const Btvl1Gpu As SuperResolutionOpticalFlowType = 1
public:
literal SuperResolutionOpticalFlowType^ Btvl1Gpu = 1
static val mutable Btvl1Gpu: SuperResolutionOpticalFlowType

Field Value

Type: SuperResolutionOpticalFlowType
See Also

Reference

SuperResolutionOpticalFlowType Class
Emgu.CV.Superres Namespace


SuperResolution.OpticalFlowType.value__ Field

SuperResolutionOpticalFlowTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Superres.SuperResolution.OpticalFlowType.value__"]

Namespace: Emgu.CV.Superres
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SuperResolutionOpticalFlowType Class
Emgu.CV.Superres Namespace


Emgu.CV.Text Namespace

This module provides different algorithms for text detection and recognition in natural scene images.
Classes
 | Class | Description
Public class | ERFilter | Base class for 1st and 2nd stages of Neumann and Matas scene text detection algorithm
Public class | ERFilterGroupingMethod | The grouping method
Public class | ERFilterNM1 | Extremal Region Filter for the 1st stage classifier of N&M algorithm
Public class | ERFilterNM2 | Extremal Region Filter for the 2nd stage classifier of N&M algorithm
Public class | ERFilterNMMode | computeNMChannels operation modes
Public class | MCvERStat | The ERStat structure represents a class-specific Extremal Region (ER). An ER is a 4-connected set of pixels with all its grey-level values smaller than the values in its outer boundary. A class-specific ER is selected (using a classifier) from all the ER’s in the component tree of the image.
Public class | TextInvoke | This class wraps the functional calls to the OpenCV Text modules
Public class | VectorOfERStat | Wrapped class of the C++ standard vector of ERStat.
Public class | VectorOfVectorOfERStat | Wrapped class of the C++ standard vector of VectorOfERStat.


ERFilter Class

Base class for 1st and 2nd stages of Neumann and Matas scene text detection algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TextERFilter
Emgu.CV.TextERFilterNM1
Emgu.CV.TextERFilterNM2

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ERFilter : UnmanagedObject
Public MustInherit Class ERFilter
    Inherits UnmanagedObject
public ref class ERFilter abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type ERFilter =
    class
        inherit UnmanagedObject
    end

The ERFilter type exposes the following members.

Constructors
 | Name | Description
Protected method | ERFilter | Initializes a new instance of the ERFilter class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this ERFilter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ERGrouping | Find groups of Extremal Regions that are organized as text blocks.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Takes image on input and returns the selected regions in a vector of ERStat only distinctive ERs which correspond to characters are selected by a sequential classifier
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | The native pointer to the shared object.
Top
See Also

Reference

Emgu.CV.Text Namespace


ERFilter Constructor

Initializes a new instance of the ERFilter class

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected ERFilter()
Protected Sub New
protected:
ERFilter()
new : unit -> ERFilter
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter Properties

The ERFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter Methods

The ERFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this ERFilter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ERGrouping | Find groups of Extremal Regions that are organized as text blocks.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Takes image on input and returns the selected regions in a vector of ERStat only distinctive ERs which correspond to characters are selected by a sequential classifier
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter.DisposeObject Method

ERFilterDisposeObject Method

Release all the unmanaged memory associate with this ERFilter

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter.ERGrouping Method

ERFilterERGrouping Method

Find groups of Extremal Regions that are organized as text blocks.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Rectangle[] ERGrouping(
    IInputArray image,
    IInputArrayOfArrays channels,
    VectorOfERStat[] erstats,
    ERFilterGroupingMethod groupMethods = 0,
    string groupingTrainedFileName = null,
    float minProbability = 0.5f
)
Public Shared Function ERGrouping (
    image As IInputArray,
    channels As IInputArrayOfArrays,
    erstats As VectorOfERStat(),
    Optional groupMethods As ERFilterGroupingMethod = 0,
    Optional groupingTrainedFileName As String = Nothing,
    Optional minProbability As Single = 0.5F
) As Rectangle()
public:
static array<Rectangle^>^ ERGrouping(
    IInputArray^ image,
    IInputArrayOfArrays^ channels,
    array<VectorOfERStat^>^ erstats,
    ERFilterGroupingMethod^ groupMethods = 0,
    String^ groupingTrainedFileName = nullptr,
    float minProbability = 0.5f
)
static member ERGrouping :
        image : IInputArray *
        channels : IInputArrayOfArrays *
        erstats : VectorOfERStat[] *
        ?groupMethods : ERFilterGroupingMethod *
        ?groupingTrainedFileName : string *
        ?minProbability : float32
(* Defaults:
        let _groupMethods = defaultArg groupMethods 0
        let _groupingTrainedFileName = defaultArg groupingTrainedFileName null
        let _minProbability = defaultArg minProbability 0.5f
*)
-> Rectangle[]

Parameters

image
Type: Emgu.CVIInputArray
The image where ER grouping is to be perform on
channels
Type: Emgu.CVIInputArrayOfArrays
Array of single channel images from which the regions were extracted
erstats
Type: Emgu.CV.TextVectorOfERStat
Vector of ER’s retrieved from the ERFilter algorithm from each channel
groupMethods (Optional)
Type: Emgu.CV.TextERFilterGroupingMethod
The grouping methods
groupingTrainedFileName (Optional)
Type: SystemString
The XML or YAML file with the classifier model (e.g. trained_classifier_erGrouping.xml)
minProbability (Optional)
Type: SystemSingle
The minimum probability for accepting a group.

Return Value

Type: Rectangle
The output of the algorithm that indicates the text regions
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter.Run Method

ERFilterRun Method

Takes image on input and returns the selected regions in a vector of ERStat only distinctive ERs which correspond to characters are selected by a sequential classifier

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Run(
    IInputArray image,
    VectorOfERStat regions
)
Public Sub Run (
    image As IInputArray,
    regions As VectorOfERStat
)
public:
void Run(
    IInputArray^ image,
    VectorOfERStat^ regions
)
member Run :
        image : IInputArray *
        regions : VectorOfERStat -> unit

Parameters

image
Type: Emgu.CVIInputArray
Single channel image CV_8UC1
regions
Type: Emgu.CV.TextVectorOfERStat
Output for the 1st stage and Input/Output for the 2nd. The selected Extremal Regions are stored here.
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter Fields

The ERFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | The native pointer to the shared object.
Top
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter._sharedPtr Field

ERFilter_sharedPtr Field

The native pointer to the shared object.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _sharedPtr
Protected _sharedPtr As IntPtr
protected:
IntPtr _sharedPtr
val mutable _sharedPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

ERFilter Class
Emgu.CV.Text Namespace


ERFilter.GroupingMethod Class

ERFilterGroupingMethod Class

The grouping method
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.TextERFilterGroupingMethod

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class GroupingMethod : Enum
Public NotInheritable Class GroupingMethod
    Inherits Enum
public ref class GroupingMethod sealed : public Enum
[<SealedAttribute>]
type GroupingMethod =
    class
        inherit Enum
    end

The ERFilterGroupingMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | OrientationAny | Perform grouping in any orientation.
 | OrientationHoriz | Only perform grouping horizontally.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Text Namespace


GroupingMethod Methods

The ERFilterGroupingMethod type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ERFilterGroupingMethod Class
Emgu.CV.Text Namespace


GroupingMethod Fields

The ERFilterGroupingMethod type exposes the following members.

Fields
 | Name | Description
 | OrientationAny | Perform grouping in any orientation.
 | OrientationHoriz | Only perform grouping horizontally.
Public field | value__ |
Top
See Also

Reference

ERFilterGroupingMethod Class
Emgu.CV.Text Namespace


ERFilter.GroupingMethod.OrientationAny Field

ERFilterGroupingMethodOrientationAny Field

Perform grouping in any orientation.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ERFilterGroupingMethod OrientationAny = 1
Public Const OrientationAny As ERFilterGroupingMethod = 1
public:
literal ERFilterGroupingMethod^ OrientationAny = 1
static val mutable OrientationAny: ERFilterGroupingMethod

Field Value

Type: ERFilterGroupingMethod
See Also

Reference

ERFilterGroupingMethod Class
Emgu.CV.Text Namespace


ERFilter.GroupingMethod.OrientationHoriz Field

ERFilterGroupingMethodOrientationHoriz Field

Only perform grouping horizontally.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ERFilterGroupingMethod OrientationHoriz = 0
Public Const OrientationHoriz As ERFilterGroupingMethod = 0
public:
literal ERFilterGroupingMethod^ OrientationHoriz = 0
static val mutable OrientationHoriz: ERFilterGroupingMethod

Field Value

Type: ERFilterGroupingMethod
See Also

Reference

ERFilterGroupingMethod Class
Emgu.CV.Text Namespace


ERFilter.GroupingMethod.value__ Field

ERFilterGroupingMethodvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Text.ERFilter.GroupingMethod.value__"]

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ERFilterGroupingMethod Class
Emgu.CV.Text Namespace


ERFilterNM1 Class

Extremal Region Filter for the 1st stage classifier of N&M algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TextERFilter
Emgu.CV.TextERFilterNM1

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ERFilterNM1 : ERFilter
Public Class ERFilterNM1
    Inherits ERFilter
public ref class ERFilterNM1 : public ERFilter
type ERFilterNM1 =
    class
        inherit ERFilter
    end

The ERFilterNM1 type exposes the following members.

Constructors
 | Name | Description
Public method | ERFilterNM1 | Create an Extremal Region Filter for the 1st stage classifier of N&M algorithm
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this ERFilter (Inherited from ERFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Takes image on input and returns the selected regions in a vector of ERStat only distinctive ERs which correspond to characters are selected by a sequential classifier (Inherited from ERFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | The native pointer to the shared object. (Inherited from ERFilter.)
Top
See Also

Reference

Emgu.CV.Text Namespace


ERFilterNM1 Constructor

Create an Extremal Region Filter for the 1st stage classifier of N&M algorithm

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ERFilterNM1(
    string classifierFileName,
    int thresholdDelta = 1,
    float minArea = 0.00025f,
    float maxArea = 0.13f,
    float minProbability = 0.4f,
    bool nonMaxSuppression = true,
    float minProbabilityDiff = 0.1f
)
Public Sub New (
    classifierFileName As String,
    Optional thresholdDelta As Integer = 1,
    Optional minArea As Single = 0.00025F,
    Optional maxArea As Single = 0.13F,
    Optional minProbability As Single = 0.4F,
    Optional nonMaxSuppression As Boolean = true,
    Optional minProbabilityDiff As Single = 0.1F
)
public:
ERFilterNM1(
    String^ classifierFileName,
    int thresholdDelta = 1,
    float minArea = 0.00025f,
    float maxArea = 0.13f,
    float minProbability = 0.4f,
    bool nonMaxSuppression = true,
    float minProbabilityDiff = 0.1f
)
new :
        classifierFileName : string *
        ?thresholdDelta : int *
        ?minArea : float32 *
        ?maxArea : float32 *
        ?minProbability : float32 *
        ?nonMaxSuppression : bool *
        ?minProbabilityDiff : float32
(* Defaults:
        let _thresholdDelta = defaultArg thresholdDelta 1
        let _minArea = defaultArg minArea 0.00025f
        let _maxArea = defaultArg maxArea 0.13f
        let _minProbability = defaultArg minProbability 0.4f
        let _nonMaxSuppression = defaultArg nonMaxSuppression true
        let _minProbabilityDiff = defaultArg minProbabilityDiff 0.1f
*)
-> ERFilterNM1

Parameters

classifierFileName
Type: SystemString
The file name of the classifier
thresholdDelta (Optional)
Type: SystemInt32
Threshold step in subsequent thresholds when extracting the component tree.
minArea (Optional)
Type: SystemSingle
The minimum area (% of image size) allowed for retreived ER’s.
maxArea (Optional)
Type: SystemSingle
The maximum area (% of image size) allowed for retreived ER’s.
minProbability (Optional)
Type: SystemSingle
The minimum probability P(er|character) allowed for retreived ER’s.
nonMaxSuppression (Optional)
Type: SystemBoolean
Whenever non-maximum suppression is done over the branch probabilities.
minProbabilityDiff (Optional)
Type: SystemSingle
The minimum probability difference between local maxima and local minima ERs.
See Also

Reference

ERFilterNM1 Class
Emgu.CV.Text Namespace


ERFilterNM1 Properties

The ERFilterNM1 type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ERFilterNM1 Class
Emgu.CV.Text Namespace


ERFilterNM1 Methods

The ERFilterNM1 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this ERFilter (Inherited from ERFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Takes image on input and returns the selected regions in a vector of ERStat only distinctive ERs which correspond to characters are selected by a sequential classifier (Inherited from ERFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ERFilterNM1 Class
Emgu.CV.Text Namespace


ERFilterNM1 Fields

The ERFilterNM1 type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | The native pointer to the shared object. (Inherited from ERFilter.)
Top
See Also

Reference

ERFilterNM1 Class
Emgu.CV.Text Namespace


ERFilterNM2 Class

Extremal Region Filter for the 2nd stage classifier of N&M algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TextERFilter
Emgu.CV.TextERFilterNM2

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class ERFilterNM2 : ERFilter
Public Class ERFilterNM2
    Inherits ERFilter
public ref class ERFilterNM2 : public ERFilter
type ERFilterNM2 =
    class
        inherit ERFilter
    end

The ERFilterNM2 type exposes the following members.

Constructors
 | Name | Description
Public method | ERFilterNM2 | Create an Extremal Region Filter for the 2nd stage classifier of N&M algorithm
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this ERFilter (Inherited from ERFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Takes image on input and returns the selected regions in a vector of ERStat only distinctive ERs which correspond to characters are selected by a sequential classifier (Inherited from ERFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | The native pointer to the shared object. (Inherited from ERFilter.)
Top
See Also

Reference

Emgu.CV.Text Namespace


ERFilterNM2 Constructor

Create an Extremal Region Filter for the 2nd stage classifier of N&M algorithm

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ERFilterNM2(
    string classifierFileName,
    float minProbability = 0.3f
)
Public Sub New (
    classifierFileName As String,
    Optional minProbability As Single = 0.3F
)
public:
ERFilterNM2(
    String^ classifierFileName,
    float minProbability = 0.3f
)
new :
        classifierFileName : string *
        ?minProbability : float32
(* Defaults:
        let _minProbability = defaultArg minProbability 0.3f
*)
-> ERFilterNM2

Parameters

classifierFileName
Type: SystemString
The file name of the classifier
minProbability (Optional)
Type: SystemSingle
The minimum probability P(er|character) allowed for retreived ER’s.
See Also

Reference

ERFilterNM2 Class
Emgu.CV.Text Namespace


ERFilterNM2 Properties

The ERFilterNM2 type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

ERFilterNM2 Class
Emgu.CV.Text Namespace


ERFilterNM2 Methods

The ERFilterNM2 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associate with this ERFilter (Inherited from ERFilter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | Run | Takes image on input and returns the selected regions in a vector of ERStat only distinctive ERs which correspond to characters are selected by a sequential classifier (Inherited from ERFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ERFilterNM2 Class
Emgu.CV.Text Namespace


ERFilterNM2 Fields

The ERFilterNM2 type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | The native pointer to the shared object. (Inherited from ERFilter.)
Top
See Also

Reference

ERFilterNM2 Class
Emgu.CV.Text Namespace


ERFilterNMMode Class

computeNMChannels operation modes
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.TextERFilterNMMode

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ERFilterNMMode : Enum
Public NotInheritable Class ERFilterNMMode
    Inherits Enum
public ref class ERFilterNMMode sealed : public Enum
[<SealedAttribute>]
type ERFilterNMMode =
    class
        inherit Enum
    end

The ERFilterNMMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | IHSGrad | In N&M algorithm, the combination of intensity (I), hue (H), saturation (S), and gradient magnitude channels (Grad) are used in order to obtain high localization recall.
 | RGBLGrad | A combination of red (R), green (G), blue (B), lightness (L), and gradient magnitude (Grad).
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Text Namespace


ERFilterNMMode Methods

The ERFilterNMMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ERFilterNMMode Class
Emgu.CV.Text Namespace


ERFilterNMMode Fields

The ERFilterNMMode type exposes the following members.

Fields
 | Name | Description
 | IHSGrad | In N&M algorithm, the combination of intensity (I), hue (H), saturation (S), and gradient magnitude channels (Grad) are used in order to obtain high localization recall.
 | RGBLGrad | A combination of red (R), green (G), blue (B), lightness (L), and gradient magnitude (Grad).
Public field | value__ |
Top
See Also

Reference

ERFilterNMMode Class
Emgu.CV.Text Namespace


ERFilterNMMode.IHSGrad Field

ERFilterNMModeIHSGrad Field

In N&M algorithm, the combination of intensity (I), hue (H), saturation (S), and gradient magnitude channels (Grad) are used in order to obtain high localization recall.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ERFilterNMMode IHSGrad = 1
Public Const IHSGrad As ERFilterNMMode = 1
public:
literal ERFilterNMMode^ IHSGrad = 1
static val mutable IHSGrad: ERFilterNMMode

Field Value

Type: ERFilterNMMode
See Also

Reference

ERFilterNMMode Class
Emgu.CV.Text Namespace


ERFilterNMMode.RGBLGrad Field

ERFilterNMModeRGBLGrad Field

A combination of red (R), green (G), blue (B), lightness (L), and gradient magnitude (Grad).

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ERFilterNMMode RGBLGrad = 0
Public Const RGBLGrad As ERFilterNMMode = 0
public:
literal ERFilterNMMode^ RGBLGrad = 0
static val mutable RGBLGrad: ERFilterNMMode

Field Value

Type: ERFilterNMMode
See Also

Reference

ERFilterNMMode Class
Emgu.CV.Text Namespace


ERFilterNMMode.value__ Field

ERFilterNMModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Text.ERFilterNMMode.value__"]

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ERFilterNMMode Class
Emgu.CV.Text Namespace


MCvERStat Class

The ERStat structure represents a class-specific Extremal Region (ER). An ER is a 4-connected set of pixels with all its grey-level values smaller than the values in its outer boundary. A class-specific ER is selected (using a classifier) from all the ER’s in the component tree of the image.
Inheritance Hierarchy
SystemObject
SystemValueType
Emgu.CV.TextMCvERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class MCvERStat : ValueType
<SerializableAttribute>
Public NotInheritable Class MCvERStat
    Inherits ValueType
[SerializableAttribute]
public ref class MCvERStat sealed : public ValueType
[<SealedAttribute>]
[<SerializableAttribute>]
type MCvERStat =
    class
        inherit ValueType
    end

The MCvERStat type exposes the following members.

Properties
 | Name | Description
Public property | LocalMaxima | If or not the regions is a local maxima of the probability
Public property | Pixels | Get the pixels list.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCenter | Get the center of the region
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Area | Area
Public field | CentralMoments0 | Order 2 central moments to construct the covariance matrix
Public field | CentralMoments1 | Order 2 central moments to construct the covariance matrix
Public field | CentralMoments2 | Order 2 central moments to construct the covariance matrix
Public field | ChildPtr | Pointer to the child ERStat
Public field | ConvexHullRatio | Convex hull ratio
Public field | CrossingsOwner | Pointer owner to horizontal crossings
Public field | CrossingsStored | Pointer to horizontal crossings
Public field | Euler | Euler number
Public field | HoleAreaRatio | Hole area ratio
Public field | Level | Threshold (max grey-level value)
Public field | MaxProbabilityAncestor | Pointer to the ERStat that is the max probability ancestor
Public field | MedCrossings | Median of the crossings at three different height levels
Public field | MinProbabilityAncestor | Pointer to the ERStat that is the min probability ancestor
Public field | NextPtr | Pointer to the next ERStat
Public field | NumInflexionPoints | Number of inflexion points
Public field | ParentPtr | Pointer to the parent ERStat
Public field | Perimeter | Perimeter
Public field | Pixel | Seed point
Public field | PrevPtr | Pointer to the previous ERStat
Public field | probability | Probability that the ER belongs to the class we are looking for
Public field | RawMoments0 | Order 1 raw moments to derive the centroid
Public field | RawMoments1 | Order 1 raw moments to derive the centroid
Public field | Rect | Bounding box
Top
See Also

Reference

Emgu.CV.Text Namespace


MCvERStat Properties

The MCvERStat type exposes the following members.

Properties
 | Name | Description
Public property | LocalMaxima | If or not the regions is a local maxima of the probability
Public property | Pixels | Get the pixels list.
Top
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.LocalMaxima Property

MCvERStatLocalMaxima Property

If or not the regions is a local maxima of the probability

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool LocalMaxima { get; set; }
Public Property LocalMaxima As Boolean
    Get
    Set
public:
property bool LocalMaxima {
    bool get ();
    void set (bool value);
}
member LocalMaxima : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.Pixels Property

MCvERStatPixels Property

Get the pixels list.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfInt Pixels { get; }
Public ReadOnly Property Pixels As VectorOfInt
    Get
public:
property VectorOfInt^ Pixels {
    VectorOfInt^ get ();
}
member Pixels : VectorOfInt with get

Property Value

Type: VectorOfInt
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat Methods

The MCvERStat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCenter | Get the center of the region
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.GetCenter Method

MCvERStatGetCenter Method

Get the center of the region

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point GetCenter(
    int imageWidth
)
Public Function GetCenter (
    imageWidth As Integer
) As Point
public:
Point^ GetCenter(
    int imageWidth
)
member GetCenter :
        imageWidth : int -> Point

Parameters

imageWidth
Type: SystemInt32
The source image width

Return Value

Type: Point
The center of the region
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat Fields

The MCvERStat type exposes the following members.

Fields
 | Name | Description
Public field | Area | Area
Public field | CentralMoments0 | Order 2 central moments to construct the covariance matrix
Public field | CentralMoments1 | Order 2 central moments to construct the covariance matrix
Public field | CentralMoments2 | Order 2 central moments to construct the covariance matrix
Public field | ChildPtr | Pointer to the child ERStat
Public field | ConvexHullRatio | Convex hull ratio
Public field | CrossingsOwner | Pointer owner to horizontal crossings
Public field | CrossingsStored | Pointer to horizontal crossings
Public field | Euler | Euler number
Public field | HoleAreaRatio | Hole area ratio
Public field | Level | Threshold (max grey-level value)
Public field | MaxProbabilityAncestor | Pointer to the ERStat that is the max probability ancestor
Public field | MedCrossings | Median of the crossings at three different height levels
Public field | MinProbabilityAncestor | Pointer to the ERStat that is the min probability ancestor
Public field | NextPtr | Pointer to the next ERStat
Public field | NumInflexionPoints | Number of inflexion points
Public field | ParentPtr | Pointer to the parent ERStat
Public field | Perimeter | Perimeter
Public field | Pixel | Seed point
Public field | PrevPtr | Pointer to the previous ERStat
Public field | probability | Probability that the ER belongs to the class we are looking for
Public field | RawMoments0 | Order 1 raw moments to derive the centroid
Public field | RawMoments1 | Order 1 raw moments to derive the centroid
Public field | Rect | Bounding box
Top
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.Area Field

MCvERStatArea Field

Area

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Area
Public Area As Integer
public:
int Area
val mutable Area: int

Field Value

Type: Int32
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.CentralMoments0 Field

MCvERStatCentralMoments0 Field

Order 2 central moments to construct the covariance matrix

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double CentralMoments0
Public CentralMoments0 As Double
public:
double CentralMoments0
val mutable CentralMoments0: float

Field Value

Type: Double
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.CentralMoments1 Field

MCvERStatCentralMoments1 Field

Order 2 central moments to construct the covariance matrix

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double CentralMoments1
Public CentralMoments1 As Double
public:
double CentralMoments1
val mutable CentralMoments1: float

Field Value

Type: Double
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.CentralMoments2 Field

MCvERStatCentralMoments2 Field

Order 2 central moments to construct the covariance matrix

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double CentralMoments2
Public CentralMoments2 As Double
public:
double CentralMoments2
val mutable CentralMoments2: float

Field Value

Type: Double
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.ChildPtr Field

MCvERStatChildPtr Field

Pointer to the child ERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ChildPtr
Public ChildPtr As IntPtr
public:
IntPtr ChildPtr
val mutable ChildPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.ConvexHullRatio Field

MCvERStatConvexHullRatio Field

Convex hull ratio

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ConvexHullRatio
Public ConvexHullRatio As Single
public:
float ConvexHullRatio
val mutable ConvexHullRatio: float32

Field Value

Type: Single
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.CrossingsOwner Field

MCvERStatCrossingsOwner Field

Pointer owner to horizontal crossings

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr CrossingsOwner
Public CrossingsOwner As IntPtr
public:
IntPtr CrossingsOwner
val mutable CrossingsOwner: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.CrossingsStored Field

MCvERStatCrossingsStored Field

Pointer to horizontal crossings

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr CrossingsStored
Public CrossingsStored As IntPtr
public:
IntPtr CrossingsStored
val mutable CrossingsStored: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.Euler Field

MCvERStatEuler Field

Euler number

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Euler
Public Euler As Integer
public:
int Euler
val mutable Euler: int

Field Value

Type: Int32
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.HoleAreaRatio Field

MCvERStatHoleAreaRatio Field

Hole area ratio

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float HoleAreaRatio
Public HoleAreaRatio As Single
public:
float HoleAreaRatio
val mutable HoleAreaRatio: float32

Field Value

Type: Single
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.Level Field

MCvERStatLevel Field

Threshold (max grey-level value)

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Level
Public Level As Integer
public:
int Level
val mutable Level: int

Field Value

Type: Int32
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.MaxProbabilityAncestor Field

MCvERStatMaxProbabilityAncestor Field

Pointer to the ERStat that is the max probability ancestor

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr MaxProbabilityAncestor
Public MaxProbabilityAncestor As IntPtr
public:
IntPtr MaxProbabilityAncestor
val mutable MaxProbabilityAncestor: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.MedCrossings Field

MCvERStatMedCrossings Field

Median of the crossings at three different height levels

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float MedCrossings
Public MedCrossings As Single
public:
float MedCrossings
val mutable MedCrossings: float32

Field Value

Type: Single
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.MinProbabilityAncestor Field

MCvERStatMinProbabilityAncestor Field

Pointer to the ERStat that is the min probability ancestor

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr MinProbabilityAncestor
Public MinProbabilityAncestor As IntPtr
public:
IntPtr MinProbabilityAncestor
val mutable MinProbabilityAncestor: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.NextPtr Field

MCvERStatNextPtr Field

Pointer to the next ERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr NextPtr
Public NextPtr As IntPtr
public:
IntPtr NextPtr
val mutable NextPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.NumInflexionPoints Field

MCvERStatNumInflexionPoints Field

Number of inflexion points

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float NumInflexionPoints
Public NumInflexionPoints As Single
public:
float NumInflexionPoints
val mutable NumInflexionPoints: float32

Field Value

Type: Single
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.ParentPtr Field

MCvERStatParentPtr Field

Pointer to the parent ERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr ParentPtr
Public ParentPtr As IntPtr
public:
IntPtr ParentPtr
val mutable ParentPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.Perimeter Field

MCvERStatPerimeter Field

Perimeter

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Perimeter
Public Perimeter As Integer
public:
int Perimeter
val mutable Perimeter: int

Field Value

Type: Int32
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.Pixel Field

MCvERStatPixel Field

Seed point

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Pixel
Public Pixel As Integer
public:
int Pixel
val mutable Pixel: int

Field Value

Type: Int32
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.PrevPtr Field

MCvERStatPrevPtr Field

Pointer to the previous ERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr PrevPtr
Public PrevPtr As IntPtr
public:
IntPtr PrevPtr
val mutable PrevPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.probability Field

MCvERStatprobability Field

Probability that the ER belongs to the class we are looking for

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double probability
Public probability As Double
public:
double probability
val mutable probability: float

Field Value

Type: Double
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.RawMoments0 Field

MCvERStatRawMoments0 Field

Order 1 raw moments to derive the centroid

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RawMoments0
Public RawMoments0 As Double
public:
double RawMoments0
val mutable RawMoments0: float

Field Value

Type: Double
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.RawMoments1 Field

MCvERStatRawMoments1 Field

Order 1 raw moments to derive the centroid

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double RawMoments1
Public RawMoments1 As Double
public:
double RawMoments1
val mutable RawMoments1: float

Field Value

Type: Double
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


MCvERStat.Rect Field

MCvERStatRect Field

Bounding box

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle Rect
Public Rect As Rectangle
public:
Rectangle^ Rect
val mutable Rect: Rectangle

Field Value

Type: Rectangle
See Also

Reference

MCvERStat Class
Emgu.CV.Text Namespace


TextInvoke Class

This class wraps the functional calls to the OpenCV Text modules
Inheritance Hierarchy
SystemObject
Emgu.CV.TextTextInvoke

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class TextInvoke
Public NotInheritable Class TextInvoke
public ref class TextInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TextInvoke =  class end

The TextInvoke type exposes the following members.

Methods
Name | Description
ComputeNMChannels | Compute the different channels to be processed independently in the N&M algorithm.
MSERsToERStats | Converts MSER contours (vector of point) to ERStat regions.
Top
See Also

Reference

Emgu.CV.Text Namespace


TextInvoke Methods

The TextInvoke type exposes the following members.

Methods
Name | Description
ComputeNMChannels | Compute the different channels to be processed independently in the N&M algorithm.
MSERsToERStats | Converts MSER contours (vector of point) to ERStat regions.
Top
See Also

Reference

TextInvoke Class
Emgu.CV.Text Namespace


TextInvoke.ComputeNMChannels Method

TextInvokeComputeNMChannels Method

Compute the different channels to be processed independently in the N&M algorithm.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ComputeNMChannels(
    IInputArray src,
    IOutputArrayOfArrays channels,
    ERFilterNMMode mode = 0
)
Public Shared Sub ComputeNMChannels (
    src As IInputArray,
    channels As IOutputArrayOfArrays,
    Optional mode As ERFilterNMMode = 0
)
public:
static void ComputeNMChannels(
    IInputArray^ src,
    IOutputArrayOfArrays^ channels,
    ERFilterNMMode^ mode = 0
)
static member ComputeNMChannels :
        src : IInputArray *
        channels : IOutputArrayOfArrays *
        ?mode : ERFilterNMMode
(* Defaults:
        let _mode = defaultArg mode 0
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image. Must be RGB CV_8UC3.
channels
Type: Emgu.CVIOutputArrayOfArrays
Output vector of Mat where computed channels are stored.
mode (Optional)
Type: Emgu.CV.TextERFilterNMMode
Mode of operation
See Also

Reference

TextInvoke Class
Emgu.CV.Text Namespace


TextInvoke.MSERsToERStats Method

TextInvokeMSERsToERStats Method

Converts MSER contours (vector of point) to ERStat regions.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MSERsToERStats(
    IInputArray image,
    VectorOfVectorOfPoint contours,
    VectorOfVectorOfERStat regions
)
Public Shared Sub MSERsToERStats (
    image As IInputArray,
    contours As VectorOfVectorOfPoint,
    regions As VectorOfVectorOfERStat
)
public:
static void MSERsToERStats(
    IInputArray^ image,
    VectorOfVectorOfPoint^ contours,
    VectorOfVectorOfERStat^ regions
)
static member MSERsToERStats :
        image : IInputArray *
        contours : VectorOfVectorOfPoint *
        regions : VectorOfVectorOfERStat -> unit

Parameters

image
Type: Emgu.CVIInputArray
Source image CV_8UC1 from which the MSERs where extracted.
contours
Type: Emgu.CV.UtilVectorOfVectorOfPoint
Input vector with all the contours (vector of Point).
regions
Type: Emgu.CV.TextVectorOfVectorOfERStat
Output where the ERStat regions are stored.
See Also

Reference

TextInvoke Class
Emgu.CV.Text Namespace


VectorOfERStat Class

Wrapped class of the C++ standard vector of ERStat.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TextVectorOfERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfERStat : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfERStat
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfERStat : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfERStat =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfERStat type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfERStat | Create an empty standard vector of ERStat
Public method | VectorOfERStat(Int32) | Create an standard vector of ERStat of the specific size
Public method | VectorOfERStat(MCvERStat) | Create an standard vector of ERStat with the initial values
Public method | VectorOfERStat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MCvERStat) | Push an array of value into the standard vector
Public method | Push(VectorOfERStat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of ERStat
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Text Namespace


VectorOfERStat Constructor

Overload List
 | Name | Description
Public method | VectorOfERStat | Create an empty standard vector of ERStat
Public method | VectorOfERStat(Int32) | Create an standard vector of ERStat of the specific size
Public method | VectorOfERStat(MCvERStat) | Create an standard vector of ERStat with the initial values
Public method | VectorOfERStat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat Constructor

Create an empty standard vector of ERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfERStat()
Public Sub New
public:
VectorOfERStat()
new : unit -> VectorOfERStat
See Also

Reference

VectorOfERStat Class
VectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfERStat Constructor (Int32)

Create an standard vector of ERStat of the specific size

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfERStat(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfERStat(
    int size
)
new :
        size : int -> VectorOfERStat

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfERStat Class
VectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfERStat Constructor (MCvERStat[])

VectorOfERStat Constructor (MCvERStat)

http://www.emgu.com
Create an standard vector of ERStat with the initial values

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfERStat(
    MCvERStat[] values
)
Public Sub New (
    values As MCvERStat()
)
public:
VectorOfERStat(
    array<MCvERStat^>^ values
)
new :
        values : MCvERStat[] -> VectorOfERStat

Parameters

values
Type: Emgu.CV.TextMCvERStat
The initial values
See Also

Reference

VectorOfERStat Class
VectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfERStat Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfERStat(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfERStat(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfERStat

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfERStat Class
VectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfERStat Properties

The VectorOfERStat type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.Item Property

VectorOfERStatItem Property

Get the item in the specific index

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvERStat this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As MCvERStat
    Get
public:
property MCvERStat^ Item[int index] {
    MCvERStat^ get (int index);
}
member Item : MCvERStat with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: MCvERStat
The item in the specific index
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.Size Property

VectorOfERStatSize Property

Get the size of the vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.SizeOfItemInBytes Property

VectorOfERStatSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.StartAddress Property

VectorOfERStatStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat Methods

The VectorOfERStat type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MCvERStat) | Push an array of value into the standard vector
Public method | Push(VectorOfERStat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of ERStat
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.Clear Method

VectorOfERStatClear Method

Clear the vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.DisposeObject Method

VectorOfERStatDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.GetInputArray Method

VectorOfERStatGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.GetInputOutputArray Method

VectorOfERStatGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.GetObjectData Method

VectorOfERStatGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.GetOutputArray Method

VectorOfERStatGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.Push Method

VectorOfERStatPush Method

Overload List
 | Name | Description
Public method | Push(MCvERStat) | Push an array of value into the standard vector
Public method | Push(VectorOfERStat) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat.Push Method (MCvERStat[])

VectorOfERStatPush Method (MCvERStat)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    MCvERStat[] value
)
Public Sub Push (
    value As MCvERStat()
)
public:
void Push(
    array<MCvERStat^>^ value
)
member Push :
        value : MCvERStat[] -> unit

Parameters

value
Type: Emgu.CV.TextMCvERStat
The value to be pushed to the vector
See Also

Reference

VectorOfERStat Class
Push Overload
Emgu.CV.Text Namespace


VectorOfERStat.Push Method (VectorOfERStat)

VectorOfERStatPush Method (VectorOfERStat)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfERStat other
)
Public Sub Push (
    other As VectorOfERStat
)
public:
void Push(
    VectorOfERStat^ other
)
member Push :
        other : VectorOfERStat -> unit

Parameters

other
Type: Emgu.CV.TextVectorOfERStat
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfERStat Class
Push Overload
Emgu.CV.Text Namespace


VectorOfERStat.ToArray Method

VectorOfERStatToArray Method

Convert the standard vector to an array of ERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvERStat[] ToArray()
Public Function ToArray As MCvERStat()
public:
array<MCvERStat^>^ ToArray()
member ToArray : unit -> MCvERStat[]

Return Value

Type: MCvERStat
An array of ERStat
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfERStat Fields

The VectorOfERStat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Class

Wrapped class of the C++ standard vector of VectorOfERStat.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TextVectorOfVectorOfERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfERStat : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfERStat
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfERStat : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfERStat =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfERStat type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfERStat | Create an empty standard vector of VectorOfERStat
Public method | VectorOfVectorOfERStat(Int32) | Create an standard vector of VectorOfERStat of the specific size
Public method | VectorOfVectorOfERStat(MCvERStat) | Create the standard vector of VectorOfERStat
Public method | VectorOfVectorOfERStat(VectorOfERStat) | Create an standard vector of VectorOfERStat with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfERStat) | Push a value into the standard vector
Public method | Push(VectorOfERStat) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfERStat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Text Namespace


VectorOfVectorOfERStat Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfERStat | Create an empty standard vector of VectorOfERStat
Public method | VectorOfVectorOfERStat(Int32) | Create an standard vector of VectorOfERStat of the specific size
Public method | VectorOfVectorOfERStat(MCvERStat) | Create the standard vector of VectorOfERStat
Public method | VectorOfVectorOfERStat(VectorOfERStat) | Create an standard vector of VectorOfERStat with the initial values
Top
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Constructor

Create an empty standard vector of VectorOfERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfERStat()
Public Sub New
public:
VectorOfVectorOfERStat()
new : unit -> VectorOfVectorOfERStat
See Also

Reference

VectorOfVectorOfERStat Class
VectorOfVectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Constructor (Int32)

Create an standard vector of VectorOfERStat of the specific size

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfERStat(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfERStat(
    int size
)
new :
        size : int -> VectorOfVectorOfERStat

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfERStat Class
VectorOfVectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Constructor (MCvERStat[][])

VectorOfVectorOfERStat Constructor (MCvERStat)

http://www.emgu.com
Create the standard vector of VectorOfERStat

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfERStat(
    MCvERStat[][] values
)
Public Sub New (
    values As MCvERStat()()
)
public:
VectorOfVectorOfERStat(
    array<array<MCvERStat^>^>^ values
)
new :
        values : MCvERStat[][] -> VectorOfVectorOfERStat

Parameters

values
Type: Emgu.CV.TextMCvERStat

[Missing <param name="values"/> documentation for "M:Emgu.CV.Text.VectorOfVectorOfERStat.#ctor(Emgu.CV.Text.MCvERStat[][])"]

See Also

Reference

VectorOfVectorOfERStat Class
VectorOfVectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Constructor (VectorOfERStat[])

VectorOfVectorOfERStat Constructor (VectorOfERStat)

http://www.emgu.com
Create an standard vector of VectorOfERStat with the initial values

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfERStat(
    params VectorOfERStat[] values
)
Public Sub New (
    ParamArray values As VectorOfERStat()
)
public:
VectorOfVectorOfERStat(
    ... array<VectorOfERStat^>^ values
)
new :
        values : VectorOfERStat[] -> VectorOfVectorOfERStat

Parameters

values
Type: Emgu.CV.TextVectorOfERStat
The initial values
See Also

Reference

VectorOfVectorOfERStat Class
VectorOfVectorOfERStat Overload
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Properties

The VectorOfVectorOfERStat type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.Item Property

VectorOfVectorOfERStatItem Property

Get the item in the specific index

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfERStat this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfERStat
    Get
public:
property VectorOfERStat^ Item[int index] {
    VectorOfERStat^ get (int index);
}
member Item : VectorOfERStat with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfERStat
The item in the specific index
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.Size Property

VectorOfVectorOfERStatSize Property

Get the size of the vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.SizeOfItemInBytes Property

VectorOfVectorOfERStatSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Methods

The VectorOfVectorOfERStat type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfERStat) | Push a value into the standard vector
Public method | Push(VectorOfERStat) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfERStat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.Clear Method

VectorOfVectorOfERStatClear Method

Clear the vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.DisposeObject Method

VectorOfVectorOfERStatDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.GetInputArray Method

VectorOfVectorOfERStatGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.GetInputOutputArray Method

VectorOfVectorOfERStatGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.GetOutputArray Method

VectorOfVectorOfERStatGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.Push Method

VectorOfVectorOfERStatPush Method

Overload List
 | Name | Description
Public method | Push(VectorOfERStat) | Push a value into the standard vector
Public method | Push(VectorOfERStat) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfERStat) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.Push Method (VectorOfERStat)

VectorOfVectorOfERStatPush Method (VectorOfERStat)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfERStat value
)
Public Sub Push (
    value As VectorOfERStat
)
public:
void Push(
    VectorOfERStat^ value
)
member Push :
        value : VectorOfERStat -> unit

Parameters

value
Type: Emgu.CV.TextVectorOfERStat
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfERStat Class
Push Overload
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.Push Method (VectorOfERStat[])

VectorOfVectorOfERStatPush Method (VectorOfERStat)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfERStat[] values
)
Public Sub Push (
    values As VectorOfERStat()
)
public:
void Push(
    array<VectorOfERStat^>^ values
)
member Push :
        values : VectorOfERStat[] -> unit

Parameters

values
Type: Emgu.CV.TextVectorOfERStat
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfERStat Class
Push Overload
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.Push Method (VectorOfVectorOfERStat)

VectorOfVectorOfERStatPush Method (VectorOfVectorOfERStat)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfERStat other
)
Public Sub Push (
    other As VectorOfVectorOfERStat
)
public:
void Push(
    VectorOfVectorOfERStat^ other
)
member Push :
        other : VectorOfVectorOfERStat -> unit

Parameters

other
Type: Emgu.CV.TextVectorOfVectorOfERStat
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfERStat Class
Push Overload
Emgu.CV.Text Namespace


VectorOfVectorOfERStat.ToArrayOfArray Method

VectorOfVectorOfERStatToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Text
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvERStat[][] ToArrayOfArray()
Public Function ToArrayOfArray As MCvERStat()()
public:
array<array<MCvERStat^>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> MCvERStat[][]

Return Value

Type: MCvERStat
Arrays of int
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


VectorOfVectorOfERStat Fields

The VectorOfVectorOfERStat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfERStat Class
Emgu.CV.Text Namespace


Emgu.CV.Tiff Namespace

Contains writer classes that can be used to write different tiff formats, such as tile tiff and geotiff.
Classes
 | Class | Description
Public class | TiffWriterTColor, TDepth | A class that can be used for writing geotiff
Public class | TileTiffWriterTColor, TDepth | A writer for writing GeoTiff


TiffWriter(TColor, TDepth) Class

TiffWriterTColor, TDepth Class

A class that can be used for writing geotiff
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TiffTiffWriterTColor, TDepth
Emgu.CV.TiffTileTiffWriterTColor, TDepth

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TiffWriter<TColor, TDepth> : UnmanagedObject
where TColor : struct, new(), IColor
where TDepth : new()

Public Class TiffWriter(Of TColor As {Structure, New, IColor}, TDepth As New)
    Inherits UnmanagedObject
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
public ref class TiffWriter : public UnmanagedObject
type TiffWriter<'TColor, 'TDepth when 'TColor : struct, new() and IColor when 'TDepth : new()> =
    class
        inherit UnmanagedObject
    end

Type Parameters

TColor
The color type of the image to be written
TDepth
The depth type of the image to be written

The TiffWriterTColor, TDepth type exposes the following members.

Constructors
 | Name | Description
Public method | TiffWriterTColor, TDepth | Create a tiff writer to save an image
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the writer and write all data on to disk. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteGeoTag | Write the geo information into the tiff file
Public method | WriteImage | Write the image to the tiff file
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Tiff Namespace


TiffWriter(TColor, TDepth) Constructor

TiffWriterTColor, TDepth Constructor

Create a tiff writer to save an image

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TiffWriter(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
TiffWriter(
    String^ fileName
)
new :
        fileName : string -> TiffWriter

Parameters

fileName
Type: SystemString
The file name to be saved
See Also

Reference

TiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TiffWriter(TColor, TDepth) Properties

TiffWriterTColor, TDepth Properties

The TiffWriterTColor, TDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TiffWriter(TColor, TDepth) Methods

TiffWriterTColor, TDepth Methods

The TiffWriterTColor, TDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the writer and write all data on to disk. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteGeoTag | Write the geo information into the tiff file
Public method | WriteImage | Write the image to the tiff file
Top
See Also

Reference

TiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TiffWriter(TColor, TDepth).DisposeObject Method

TiffWriterTColor, TDepthDisposeObject Method

Release the writer and write all data on to disk.

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TiffWriter(TColor, TDepth).WriteGeoTag Method

TiffWriterTColor, TDepthWriteGeoTag Method

Write the geo information into the tiff file

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void WriteGeoTag(
    double[] modelTiepoint,
    double[] modelPixelScale
)
Public Sub WriteGeoTag (
    modelTiepoint As Double(),
    modelPixelScale As Double()
)
public:
void WriteGeoTag(
    array<double>^ modelTiepoint,
    array<double>^ modelPixelScale
)
member WriteGeoTag :
        modelTiepoint : float[] *
        modelPixelScale : float[] -> unit

Parameters

modelTiepoint
Type: SystemDouble
Model Tie Point, an array of size 6
modelPixelScale
Type: SystemDouble
Model pixel scale, an array of size 3
See Also

Reference

TiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TiffWriter(TColor, TDepth).WriteImage Method

TiffWriterTColor, TDepthWriteImage Method

Write the image to the tiff file

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void WriteImage(
    Image<TColor, TDepth> image
)
Public Overridable Sub WriteImage (
    image As Image(Of TColor, TDepth)
)
public:
virtual void WriteImage(
    Image<TColor, TDepth>^ image
)
abstract WriteImage :
        image : Image<'TColor, 'TDepth> -> unit
override WriteImage :
        image : Image<'TColor, 'TDepth> -> unit

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image to be written
See Also

Reference

TiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TiffWriter(TColor, TDepth) Fields

TiffWriterTColor, TDepth Fields

The TiffWriterTColor, TDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth) Class

TileTiffWriterTColor, TDepth Class

A writer for writing GeoTiff
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TiffTiffWriter TColor, TDepth
Emgu.CV.TiffTileTiffWriterTColor, TDepth

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TileTiffWriter<TColor, TDepth> : TiffWriter<TColor, TDepth>
where TColor : struct, new(), IColor
where TDepth : new()

Public Class TileTiffWriter(Of TColor As {Structure, New, IColor}, TDepth As New)
    Inherits TiffWriter(Of TColor, TDepth)
generic<typename TColor, typename TDepth>
where TColor : value class, gcnew(), IColor
where TDepth : gcnew()
public ref class TileTiffWriter : public TiffWriter<TColor, TDepth>
type TileTiffWriter<'TColor, 'TDepth when 'TColor : struct, new() and IColor when 'TDepth : new()> =
    class
        inherit TiffWriter<'TColor, 'TDepth>
    end

Type Parameters

TColor
The color type of the image to be written
TDepth
The depth type of the image to be written

The TileTiffWriterTColor, TDepth type exposes the following members.

Constructors
 | Name | Description
Public method | TileTiffWriterTColor, TDepth | Create a TitleTiffWriter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TileRowSizeInBytes | Get the number of bytes of a row of data in a tile.
Public property | TileSize | Get tile size in pixels.
Public property | TileSizeInBytes | Get the equivalent size for a tile of data as it would be returned in a call to TIFFReadTile or as it would be expected in a call to TIFFWriteTile.
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the writer and write all data on to disk. (Inherited from TiffWriterTColor, TDepth.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteGeoTag | Write the geo information into the tiff file (Inherited from TiffWriterTColor, TDepth.)
Public method | WriteImage | Write the whole image as tile tiff (Overrides TiffWriterTColor, TDepthWriteImage(ImageTColor, TDepth).)
Public method | WriteTile | Write a tile into the tile tiff
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth) Constructor

TileTiffWriterTColor, TDepth Constructor

Create a TitleTiffWriter.

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TileTiffWriter(
    string fileName,
    Size imageSize,
    Size tileSize
)
Public Sub New (
    fileName As String,
    imageSize As Size,
    tileSize As Size
)
public:
TileTiffWriter(
    String^ fileName,
    Size^ imageSize,
    Size^ tileSize
)
new :
        fileName : string *
        imageSize : Size *
        tileSize : Size -> TileTiffWriter

Parameters

fileName
Type: SystemString
The name of the file to be written to
imageSize
Type: System.DrawingSize
The size of the image
tileSize
Type: System.DrawingSize
The tile size in pixels
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth) Properties

TileTiffWriterTColor, TDepth Properties

The TileTiffWriterTColor, TDepth generic type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | TileRowSizeInBytes | Get the number of bytes of a row of data in a tile.
Public property | TileSize | Get tile size in pixels.
Public property | TileSizeInBytes | Get the equivalent size for a tile of data as it would be returned in a call to TIFFReadTile or as it would be expected in a call to TIFFWriteTile.
Top
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth).TileRowSizeInBytes Property

TileTiffWriterTColor, TDepthTileRowSizeInBytes Property

Get the number of bytes of a row of data in a tile.

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int TileRowSizeInBytes { get; }
Public ReadOnly Property TileRowSizeInBytes As Integer
    Get
public:
property int TileRowSizeInBytes {
    int get ();
}
member TileRowSizeInBytes : int with get

Property Value

Type: Int32
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth).TileSize Property

TileTiffWriterTColor, TDepthTileSize Property

Get tile size in pixels.

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Size TileSize { get; }
Public ReadOnly Property TileSize As Size
    Get
public:
property Size^ TileSize {
    Size^ get ();
}
member TileSize : Size with get

Property Value

Type: Size
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth).TileSizeInBytes Property

TileTiffWriterTColor, TDepthTileSizeInBytes Property

Get the equivalent size for a tile of data as it would be returned in a call to TIFFReadTile or as it would be expected in a call to TIFFWriteTile.

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int TileSizeInBytes { get; }
Public ReadOnly Property TileSizeInBytes As Integer
    Get
public:
property int TileSizeInBytes {
    int get ();
}
member TileSizeInBytes : int with get

Property Value

Type: Int32
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth) Methods

TileTiffWriterTColor, TDepth Methods

The TileTiffWriterTColor, TDepth generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the writer and write all data on to disk. (Inherited from TiffWriterTColor, TDepth.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteGeoTag | Write the geo information into the tiff file (Inherited from TiffWriterTColor, TDepth.)
Public method | WriteImage | Write the whole image as tile tiff (Overrides TiffWriterTColor, TDepthWriteImage(ImageTColor, TDepth).)
Public method | WriteTile | Write a tile into the tile tiff
Top
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth).WriteImage Method

TileTiffWriterTColor, TDepthWriteImage Method

Write the whole image as tile tiff

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public override void WriteImage(
    Image<TColor, TDepth> image
)
Public Overrides Sub WriteImage (
    image As Image(Of TColor, TDepth)
)
public:
virtual void WriteImage(
    Image<TColor, TDepth>^ image
) override
abstract WriteImage :
        image : Image<'TColor, 'TDepth> -> unit
override WriteImage :
        image : Image<'TColor, 'TDepth> -> unit

Parameters

image
Type: Emgu.CVImage TColor, TDepth
The image to be written
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth).WriteTile Method

TileTiffWriterTColor, TDepthWriteTile Method

Write a tile into the tile tiff

Namespace: Emgu.CV.Tiff
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void WriteTile(
    int rowNumber,
    int colNumber,
    Image<TColor, TDepth> tile
)
Public Sub WriteTile (
    rowNumber As Integer,
    colNumber As Integer,
    tile As Image(Of TColor, TDepth)
)
public:
void WriteTile(
    int rowNumber,
    int colNumber,
    Image<TColor, TDepth>^ tile
)
member WriteTile :
        rowNumber : int *
        colNumber : int *
        tile : Image<'TColor, 'TDepth> -> unit

Parameters

rowNumber
Type: SystemInt32
The starting row for the tile
colNumber
Type: SystemInt32
The starting col for the tile
tile
Type: Emgu.CVImage TColor, TDepth
The tile to be written
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


TileTiffWriter(TColor, TDepth) Fields

TileTiffWriterTColor, TDepth Fields

The TileTiffWriterTColor, TDepth generic type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TileTiffWriterTColor, TDepth Class
Emgu.CV.Tiff Namespace


Emgu.CV.Tracking Namespace

Long-term optical tracking API
Classes
 | Class | Description
Public class | MultiTracker | This class is used to track multiple objects using the specified tracker algorithm. The MultiTracker is naive implementation of multiple object tracking. It process the tracked objects independently without any optimization accross the tracked objects.
Public class | Tracker | Long-term tracker
Public class | TrackerBoosting | This is a real-time object tracking based on a novel on-line version of the AdaBoost algorithm. The classifier uses the surrounding background as negative examples in update step to avoid the drifting problem.
Public class | TrackerCSRT | Discriminative Correlation Filter Tracker with Channel and Spatial Reliability
Public class | TrackerGOTURN | GOTURN is kind of trackers based on Convolutional Neural Networks (CNN). While taking all advantages of CNN trackers, GOTURN is much faster due to offline training without online fine-tuning nature. GOTURN tracker addresses the problem of single target tracking: given a bounding box label of an object in the first frame of the video, we track that object through the rest of the video. NOTE: Current method of GOTURN does not handle occlusions; however, it is fairly robust to viewpoint changes, lighting changes, and deformations. Inputs of GOTURN are two RGB patches representing Target and Search patches resized to 227x227. Outputs of GOTURN are predicted bounding box coordinates, relative to Search patch coordinate system, in format X1,Y1,X2,Y2.
Public class | TrackerKCF | KCF is a novel tracking framework that utilizes properties of circulant matrix to enhance the processing speed. The original paper of KCF is available at http://home.isr.uc.pt/~henriques/circulant/index.html as well as the matlab implementation.
Public class | TrackerKCFMode | Feature type to be used in the tracking grayscale, colornames, compressed color-names The modes available now: - "GRAY" -- Use grayscale values as the feature - "CN" -- Color-names feature
Public class | TrackerMedianFlow | Median Flow tracker implementation. The tracker is suitable for very smooth and predictable movements when object is visible throughout the whole sequence.It's quite and accurate for this type of problems (in particular, it was shown by authors to outperform MIL). During the implementation period the code at http://www.aonsquared.co.uk/node/5, the courtesy of the author Arthur Amarra, was used for the reference purpose.
Public class | TrackerMIL | The MIL algorithm trains a classifier in an online manner to separate the object from the background. Multiple Instance Learning avoids the drift problem for a robust tracking. Original code can be found here http://vision.ucsd.edu/~bbabenko/project_miltrack.shtml
Public class | TrackerMOSSE | MOSSE Visual Object Tracking using Adaptive Correlation Filters
Public class | TrackerTLD | TLD is a novel tracking framework that explicitly decomposes the long-term tracking task into tracking, learning and detection.


MultiTracker Class

This class is used to track multiple objects using the specified tracker algorithm. The MultiTracker is naive implementation of multiple object tracking. It process the tracked objects independently without any optimization accross the tracked objects.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingMultiTracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MultiTracker : UnmanagedObject
Public Class MultiTracker
    Inherits UnmanagedObject
public ref class MultiTracker : public UnmanagedObject
type MultiTracker =
    class
        inherit UnmanagedObject
    end

The MultiTracker type exposes the following members.

Constructors
 | Name | Description
Public method | MultiTracker | Constructor. In the case of trackerType is given, it will be set as the default algorithm for all trackers.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Add | Add a new object to be tracked. The defaultAlgorithm will be used the newly added tracker.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this multi-tracker. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjects | Returns the tracked objects, each object corresponds to one tracker algorithm.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the current tracking status. The result will be saved in the internal storage.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Tracking Namespace


MultiTracker Constructor

Constructor. In the case of trackerType is given, it will be set as the default algorithm for all trackers.

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MultiTracker()
Public Sub New
public:
MultiTracker()
new : unit -> MultiTracker
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


MultiTracker Properties

The MultiTracker type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


MultiTracker Methods

The MultiTracker type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a new object to be tracked. The defaultAlgorithm will be used the newly added tracker.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this multi-tracker. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjects | Returns the tracked objects, each object corresponds to one tracker algorithm.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the current tracking status. The result will be saved in the internal storage.
Top
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


MultiTracker.Add Method

MultiTrackerAdd Method

Add a new object to be tracked. The defaultAlgorithm will be used the newly added tracker.

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    Tracker tracker,
    IInputArray image,
    Rectangle boundingBox
)
Public Function Add (
    tracker As Tracker,
    image As IInputArray,
    boundingBox As Rectangle
) As Boolean
public:
bool Add(
    Tracker^ tracker,
    IInputArray^ image,
    Rectangle^ boundingBox
)
member Add :
        tracker : Tracker *
        image : IInputArray *
        boundingBox : Rectangle -> bool

Parameters

tracker
Type: Emgu.CV.TrackingTracker
The tracker to use for tracking the image
image
Type: Emgu.CVIInputArray
Input image
boundingBox
Type: System.DrawingRectangle
A rectangle represents ROI of the tracked object

Return Value

Type: Boolean
True if successfully added
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


MultiTracker.DisposeObject Method

MultiTrackerDisposeObject Method

Release the unmanaged memory associated with this multi-tracker.

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


MultiTracker.GetObjects Method

MultiTrackerGetObjects Method

Returns the tracked objects, each object corresponds to one tracker algorithm.

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle[] GetObjects()
Public Function GetObjects As Rectangle()
public:
array<Rectangle^>^ GetObjects()
member GetObjects : unit -> Rectangle[]

Return Value

Type: Rectangle
The tracked objects, each object corresponds to one tracker algorithm.
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


MultiTracker.Update Method

MultiTrackerUpdate Method

Update the current tracking status. The result will be saved in the internal storage.

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Update(
    Mat image,
    VectorOfRect boundingBox
)
Public Function Update (
    image As Mat,
    boundingBox As VectorOfRect
) As Boolean
public:
bool Update(
    Mat^ image,
    VectorOfRect^ boundingBox
)
member Update :
        image : Mat *
        boundingBox : VectorOfRect -> bool

Parameters

image
Type: Emgu.CVMat
Input image
boundingBox
Type: Emgu.CV.UtilVectorOfRect
the tracking result, represent a list of ROIs of the tracked objects.

Return Value

Type: Boolean
True id update success
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


MultiTracker Fields

The MultiTracker type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

MultiTracker Class
Emgu.CV.Tracking Namespace


Tracker Class

Long-term tracker
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
More...

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class Tracker : UnmanagedObject
Public MustInherit Class Tracker
    Inherits UnmanagedObject
public ref class Tracker abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type Tracker =
    class
        inherit UnmanagedObject
    end

The Tracker type exposes the following members.

Constructors
 | Name | Description
Protected method | Tracker | Initializes a new instance of the Tracker class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this tracker (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker
Top
See Also

Reference

Emgu.CV.Tracking Namespace
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerBoosting
Emgu.CV.TrackingTrackerCSRT
Emgu.CV.TrackingTrackerGOTURN
Emgu.CV.TrackingTrackerKCF
Emgu.CV.TrackingTrackerMedianFlow
Emgu.CV.TrackingTrackerMIL
Emgu.CV.TrackingTrackerMOSSE
Emgu.CV.TrackingTrackerTLD


Tracker Constructor

Initializes a new instance of the Tracker class

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected Tracker()
Protected Sub New
protected:
Tracker()
new : unit -> Tracker
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


Tracker Properties

The Tracker type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


Tracker Methods

The Tracker type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this tracker (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target.
Top
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


Tracker.DisposeObject Method

TrackerDisposeObject Method

Release the unmanaged memory associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


Tracker.Init Method

TrackerInit Method

Initialize the tracker with a know bounding box that surrounding the target.

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Init(
    Mat image,
    Rectangle boundingBox
)
Public Function Init (
    image As Mat,
    boundingBox As Rectangle
) As Boolean
public:
bool Init(
    Mat^ image,
    Rectangle^ boundingBox
)
member Init :
        image : Mat *
        boundingBox : Rectangle -> bool

Parameters

image
Type: Emgu.CVMat
The initial frame
boundingBox
Type: System.DrawingRectangle
The initial bounding box

Return Value

Type: Boolean
True if successful.
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


Tracker.Update Method

TrackerUpdate Method

Update the tracker, find the new most likely bounding box for the target.

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Update(
    Mat image,
    out Rectangle boundingBox
)
Public Function Update (
    image As Mat,
    <OutAttribute> ByRef boundingBox As Rectangle
) As Boolean
public:
bool Update(
    Mat^ image,
    [OutAttribute] Rectangle^% boundingBox
)
member Update :
        image : Mat *
        boundingBox : Rectangle byref -> bool

Parameters

image
Type: Emgu.CVMat
The current frame
boundingBox
Type: System.DrawingRectangle
The bounding box that represent the new target location, if true was returned, not modified otherwise

Return Value

Type: Boolean
True means that target was located and false means that tracker cannot locate target in current frame. Note, that latter does not imply that tracker has failed, maybe target is indeed missing from the frame (say, out of sight)
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


Tracker Fields

The Tracker type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker
Top
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


Tracker._trackerPtr Field

Tracker_trackerPtr Field

The native pointer to the tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _trackerPtr
Protected _trackerPtr As IntPtr
protected:
IntPtr _trackerPtr
val mutable _trackerPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

Tracker Class
Emgu.CV.Tracking Namespace


TrackerBoosting Class

This is a real-time object tracking based on a novel on-line version of the AdaBoost algorithm. The classifier uses the surrounding background as negative examples in update step to avoid the drifting problem.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerBoosting

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerBoosting : Tracker
Public Class TrackerBoosting
    Inherits Tracker
public ref class TrackerBoosting : public Tracker
type TrackerBoosting =
    class
        inherit Tracker
    end

The TrackerBoosting type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerBoosting | Create a Boosting Tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Boosting Tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerBoosting Constructor

Create a Boosting Tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerBoosting(
    int numClassifiers = 100,
    float samplerOverlap = 0.99f,
    float samplerSearchFactor = 1.8f,
    int iterationInit = 50,
    int featureSetNumFeatures = 1050
)
Public Sub New (
    Optional numClassifiers As Integer = 100,
    Optional samplerOverlap As Single = 0.99F,
    Optional samplerSearchFactor As Single = 1.8F,
    Optional iterationInit As Integer = 50,
    Optional featureSetNumFeatures As Integer = 1050
)
public:
TrackerBoosting(
    int numClassifiers = 100,
    float samplerOverlap = 0.99f,
    float samplerSearchFactor = 1.8f,
    int iterationInit = 50,
    int featureSetNumFeatures = 1050
)
new :
        ?numClassifiers : int *
        ?samplerOverlap : float32 *
        ?samplerSearchFactor : float32 *
        ?iterationInit : int *
        ?featureSetNumFeatures : int
(* Defaults:
        let _numClassifiers = defaultArg numClassifiers 100
        let _samplerOverlap = defaultArg samplerOverlap 0.99f
        let _samplerSearchFactor = defaultArg samplerSearchFactor 1.8f
        let _iterationInit = defaultArg iterationInit 50
        let _featureSetNumFeatures = defaultArg featureSetNumFeatures 1050
*)
-> TrackerBoosting

Parameters

numClassifiers (Optional)
Type: SystemInt32
The number of classifiers to use in a OnlineBoosting algorithm
samplerOverlap (Optional)
Type: SystemSingle
Search region parameters to use in a OnlineBoosting algorithm
samplerSearchFactor (Optional)
Type: SystemSingle
search region parameters to use in a OnlineBoosting algorithm
iterationInit (Optional)
Type: SystemInt32
The initial iterations
featureSetNumFeatures (Optional)
Type: SystemInt32
Number of features, a good value would be 10*numClassifiers + iterationInit
See Also

Reference

TrackerBoosting Class
Emgu.CV.Tracking Namespace


TrackerBoosting Properties

The TrackerBoosting type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerBoosting Class
Emgu.CV.Tracking Namespace


TrackerBoosting Methods

The TrackerBoosting type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this Boosting Tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerBoosting Class
Emgu.CV.Tracking Namespace


TrackerBoosting.DisposeObject Method

TrackerBoostingDisposeObject Method

Release all the unmanaged memory associated with this Boosting Tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerBoosting Class
Emgu.CV.Tracking Namespace


TrackerBoosting Fields

The TrackerBoosting type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerBoosting Class
Emgu.CV.Tracking Namespace


TrackerCSRT Class

Discriminative Correlation Filter Tracker with Channel and Spatial Reliability
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerCSRT

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerCSRT : Tracker
Public Class TrackerCSRT
    Inherits Tracker
public ref class TrackerCSRT : public Tracker
type TrackerCSRT =
    class
        inherit Tracker
    end

The TrackerCSRT type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerCSRT | Creates a CSRT tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerCSRT Constructor

Creates a CSRT tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerCSRT(
    bool useHog = true,
    bool useColorNames = true,
    bool useGray = true,
    bool useRgb = false,
    bool useChannelWeights = true,
    bool useSegmentation = true,
    string windowFunction = null,
    float kaiserAlpha = 3.75f,
    float chebAttenuation = 45f,
    float templateSize = 200f,
    float gslSigma = 1f,
    float hogOrientations = 9f,
    float hogClip = 0.2f,
    float padding = 3f,
    float filterLr = 0.02f,
    float weightsLr = 0.02f,
    int numHogChannelsUsed = 18,
    int admmIterations = 4,
    int histogramBins = 16,
    float histogramLr = 0.04f,
    int backgroundRatio = 2,
    int numberOfScales = 33,
    float scaleSigmaFactor = 0.25f,
    float scaleModelMaxArea = 512f,
    float scaleLr = 0.025f,
    float scaleStep = 1.02f
)
Public Sub New (
    Optional useHog As Boolean = true,
    Optional useColorNames As Boolean = true,
    Optional useGray As Boolean = true,
    Optional useRgb As Boolean = false,
    Optional useChannelWeights As Boolean = true,
    Optional useSegmentation As Boolean = true,
    Optional windowFunction As String = Nothing,
    Optional kaiserAlpha As Single = 3.75F,
    Optional chebAttenuation As Single = 45F,
    Optional templateSize As Single = 200F,
    Optional gslSigma As Single = 1F,
    Optional hogOrientations As Single = 9F,
    Optional hogClip As Single = 0.2F,
    Optional padding As Single = 3F,
    Optional filterLr As Single = 0.02F,
    Optional weightsLr As Single = 0.02F,
    Optional numHogChannelsUsed As Integer = 18,
    Optional admmIterations As Integer = 4,
    Optional histogramBins As Integer = 16,
    Optional histogramLr As Single = 0.04F,
    Optional backgroundRatio As Integer = 2,
    Optional numberOfScales As Integer = 33,
    Optional scaleSigmaFactor As Single = 0.25F,
    Optional scaleModelMaxArea As Single = 512F,
    Optional scaleLr As Single = 0.025F,
    Optional scaleStep As Single = 1.02F
)
public:
TrackerCSRT(
    bool useHog = true,
    bool useColorNames = true,
    bool useGray = true,
    bool useRgb = false,
    bool useChannelWeights = true,
    bool useSegmentation = true,
    String^ windowFunction = nullptr,
    float kaiserAlpha = 3.75f,
    float chebAttenuation = 45f,
    float templateSize = 200f,
    float gslSigma = 1f,
    float hogOrientations = 9f,
    float hogClip = 0.2f,
    float padding = 3f,
    float filterLr = 0.02f,
    float weightsLr = 0.02f,
    int numHogChannelsUsed = 18,
    int admmIterations = 4,
    int histogramBins = 16,
    float histogramLr = 0.04f,
    int backgroundRatio = 2,
    int numberOfScales = 33,
    float scaleSigmaFactor = 0.25f,
    float scaleModelMaxArea = 512f,
    float scaleLr = 0.025f,
    float scaleStep = 1.02f
)
new :
        ?useHog : bool *
        ?useColorNames : bool *
        ?useGray : bool *
        ?useRgb : bool *
        ?useChannelWeights : bool *
        ?useSegmentation : bool *
        ?windowFunction : string *
        ?kaiserAlpha : float32 *
        ?chebAttenuation : float32 *
        ?templateSize : float32 *
        ?gslSigma : float32 *
        ?hogOrientations : float32 *
        ?hogClip : float32 *
        ?padding : float32 *
        ?filterLr : float32 *
        ?weightsLr : float32 *
        ?numHogChannelsUsed : int *
        ?admmIterations : int *
        ?histogramBins : int *
        ?histogramLr : float32 *
        ?backgroundRatio : int *
        ?numberOfScales : int *
        ?scaleSigmaFactor : float32 *
        ?scaleModelMaxArea : float32 *
        ?scaleLr : float32 *
        ?scaleStep : float32
(* Defaults:
        let _useHog = defaultArg useHog true
        let _useColorNames = defaultArg useColorNames true
        let _useGray = defaultArg useGray true
        let _useRgb = defaultArg useRgb false
        let _useChannelWeights = defaultArg useChannelWeights true
        let _useSegmentation = defaultArg useSegmentation true
        let _windowFunction = defaultArg windowFunction null
        let _kaiserAlpha = defaultArg kaiserAlpha 3.75f
        let _chebAttenuation = defaultArg chebAttenuation 45f
        let _templateSize = defaultArg templateSize 200f
        let _gslSigma = defaultArg gslSigma 1f
        let _hogOrientations = defaultArg hogOrientations 9f
        let _hogClip = defaultArg hogClip 0.2f
        let _padding = defaultArg padding 3f
        let _filterLr = defaultArg filterLr 0.02f
        let _weightsLr = defaultArg weightsLr 0.02f
        let _numHogChannelsUsed = defaultArg numHogChannelsUsed 18
        let _admmIterations = defaultArg admmIterations 4
        let _histogramBins = defaultArg histogramBins 16
        let _histogramLr = defaultArg histogramLr 0.04f
        let _backgroundRatio = defaultArg backgroundRatio 2
        let _numberOfScales = defaultArg numberOfScales 33
        let _scaleSigmaFactor = defaultArg scaleSigmaFactor 0.25f
        let _scaleModelMaxArea = defaultArg scaleModelMaxArea 512f
        let _scaleLr = defaultArg scaleLr 0.025f
        let _scaleStep = defaultArg scaleStep 1.02f
*)
-> TrackerCSRT

Parameters

useHog (Optional)
Type: SystemBoolean
Use hog
useColorNames (Optional)
Type: SystemBoolean
Use color names
useGray (Optional)
Type: SystemBoolean
Use Gray
useRgb (Optional)
Type: SystemBoolean
Use RGB
useChannelWeights (Optional)
Type: SystemBoolean
Use channel weights
useSegmentation (Optional)
Type: SystemBoolean
Use segmentation
windowFunction (Optional)
Type: SystemString
Windows function
kaiserAlpha (Optional)
Type: SystemSingle
Kaiser alpha
chebAttenuation (Optional)
Type: SystemSingle
Cheb attenuation
templateSize (Optional)
Type: SystemSingle
Template size
gslSigma (Optional)
Type: SystemSingle
Gsl Sigma
hogOrientations (Optional)
Type: SystemSingle
Hog orientations
hogClip (Optional)
Type: SystemSingle
Hog clip
padding (Optional)
Type: SystemSingle
padding
filterLr (Optional)
Type: SystemSingle
filter Lr
weightsLr (Optional)
Type: SystemSingle
weights Lr
numHogChannelsUsed (Optional)
Type: SystemInt32
Number of hog channels used
admmIterations (Optional)
Type: SystemInt32
Admm iterations
histogramBins (Optional)
Type: SystemInt32
Histogram bins
histogramLr (Optional)
Type: SystemSingle
Histogram Lr
backgroundRatio (Optional)
Type: SystemInt32
Background ratio
numberOfScales (Optional)
Type: SystemInt32
Number of scales
scaleSigmaFactor (Optional)
Type: SystemSingle
Scale Sigma factor
scaleModelMaxArea (Optional)
Type: SystemSingle
Scale Model Max Area
scaleLr (Optional)
Type: SystemSingle
Scale Lr
scaleStep (Optional)
Type: SystemSingle
Scale step
See Also

Reference

TrackerCSRT Class
Emgu.CV.Tracking Namespace


TrackerCSRT Properties

The TrackerCSRT type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerCSRT Class
Emgu.CV.Tracking Namespace


TrackerCSRT Methods

The TrackerCSRT type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerCSRT Class
Emgu.CV.Tracking Namespace


TrackerCSRT.DisposeObject Method

TrackerCSRTDisposeObject Method

Release the unmanaged resources associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerCSRT Class
Emgu.CV.Tracking Namespace


TrackerCSRT Fields

The TrackerCSRT type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerCSRT Class
Emgu.CV.Tracking Namespace


TrackerGOTURN Class

GOTURN is kind of trackers based on Convolutional Neural Networks (CNN). While taking all advantages of CNN trackers, GOTURN is much faster due to offline training without online fine-tuning nature. GOTURN tracker addresses the problem of single target tracking: given a bounding box label of an object in the first frame of the video, we track that object through the rest of the video. NOTE: Current method of GOTURN does not handle occlusions; however, it is fairly robust to viewpoint changes, lighting changes, and deformations. Inputs of GOTURN are two RGB patches representing Target and Search patches resized to 227x227. Outputs of GOTURN are predicted bounding box coordinates, relative to Search patch coordinate system, in format X1,Y1,X2,Y2.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerGOTURN

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerGOTURN : Tracker
Public Class TrackerGOTURN
    Inherits Tracker
public ref class TrackerGOTURN : public Tracker
type TrackerGOTURN =
    class
        inherit Tracker
    end

The TrackerGOTURN type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerGOTURN | Create a GOTURN tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
Remarks
Original paper is here: http://davheld.github.io/GOTURN/GOTURN.pdf As long as original authors implementation: https://github.com/davheld/GOTURN#train-the-tracker Implementation of training algorithm is placed in separately here due to 3d-party dependencies: https://github.com/Auron-X/GOTURN_Training_Toolkit GOTURN architecture goturn.prototxt and trained model goturn.caffemodel are accessible on opencv_extra GitHub repository.
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerGOTURN Constructor

Create a GOTURN tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerGOTURN()
Public Sub New
public:
TrackerGOTURN()
new : unit -> TrackerGOTURN
See Also

Reference

TrackerGOTURN Class
Emgu.CV.Tracking Namespace


TrackerGOTURN Properties

The TrackerGOTURN type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerGOTURN Class
Emgu.CV.Tracking Namespace


TrackerGOTURN Methods

The TrackerGOTURN type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerGOTURN Class
Emgu.CV.Tracking Namespace


TrackerGOTURN.DisposeObject Method

TrackerGOTURNDisposeObject Method

Release the unmanaged resources associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerGOTURN Class
Emgu.CV.Tracking Namespace


TrackerGOTURN Fields

The TrackerGOTURN type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerGOTURN Class
Emgu.CV.Tracking Namespace


TrackerKCF Class

KCF is a novel tracking framework that utilizes properties of circulant matrix to enhance the processing speed. The original paper of KCF is available at http://home.isr.uc.pt/~henriques/circulant/index.html as well as the matlab implementation.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerKCF

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerKCF : Tracker
Public Class TrackerKCF
    Inherits Tracker
public ref class TrackerKCF : public Tracker
type TrackerKCF =
    class
        inherit Tracker
    end

The TrackerKCF type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerKCF | Creates a KCF Tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerKCF Constructor

Creates a KCF Tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerKCF(
    float detectThresh = 0.5f,
    float sigma = 0.2f,
    float lambda = 0.01f,
    float interpFactor = 0.075f,
    float outputSigmaFactor = 0.0625f,
    float pcaLearningRate = 0.15f,
    bool resize = true,
    bool splitCoeff = true,
    bool wrapKernel = false,
    bool compressFeature = true,
    int maxPatchSize = 6400,
    int compressedSize = 2,
    TrackerKCFMode descPca = 2,
    TrackerKCFMode descNpca = 1
)
Public Sub New (
    Optional detectThresh As Single = 0.5F,
    Optional sigma As Single = 0.2F,
    Optional lambda As Single = 0.01F,
    Optional interpFactor As Single = 0.075F,
    Optional outputSigmaFactor As Single = 0.0625F,
    Optional pcaLearningRate As Single = 0.15F,
    Optional resize As Boolean = true,
    Optional splitCoeff As Boolean = true,
    Optional wrapKernel As Boolean = false,
    Optional compressFeature As Boolean = true,
    Optional maxPatchSize As Integer = 6400,
    Optional compressedSize As Integer = 2,
    Optional descPca As TrackerKCFMode = 2,
    Optional descNpca As TrackerKCFMode = 1
)
public:
TrackerKCF(
    float detectThresh = 0.5f,
    float sigma = 0.2f,
    float lambda = 0.01f,
    float interpFactor = 0.075f,
    float outputSigmaFactor = 0.0625f,
    float pcaLearningRate = 0.15f,
    bool resize = true,
    bool splitCoeff = true,
    bool wrapKernel = false,
    bool compressFeature = true,
    int maxPatchSize = 6400,
    int compressedSize = 2,
    TrackerKCFMode^ descPca = 2,
    TrackerKCFMode^ descNpca = 1
)
new :
        ?detectThresh : float32 *
        ?sigma : float32 *
        ?lambda : float32 *
        ?interpFactor : float32 *
        ?outputSigmaFactor : float32 *
        ?pcaLearningRate : float32 *
        ?resize : bool *
        ?splitCoeff : bool *
        ?wrapKernel : bool *
        ?compressFeature : bool *
        ?maxPatchSize : int *
        ?compressedSize : int *
        ?descPca : TrackerKCFMode *
        ?descNpca : TrackerKCFMode
(* Defaults:
        let _detectThresh = defaultArg detectThresh 0.5f
        let _sigma = defaultArg sigma 0.2f
        let _lambda = defaultArg lambda 0.01f
        let _interpFactor = defaultArg interpFactor 0.075f
        let _outputSigmaFactor = defaultArg outputSigmaFactor 0.0625f
        let _pcaLearningRate = defaultArg pcaLearningRate 0.15f
        let _resize = defaultArg resize true
        let _splitCoeff = defaultArg splitCoeff true
        let _wrapKernel = defaultArg wrapKernel false
        let _compressFeature = defaultArg compressFeature true
        let _maxPatchSize = defaultArg maxPatchSize 6400
        let _compressedSize = defaultArg compressedSize 2
        let _descPca = defaultArg descPca 2
        let _descNpca = defaultArg descNpca 1
*)
-> TrackerKCF

Parameters

detectThresh (Optional)
Type: SystemSingle
detection confidence threshold
sigma (Optional)
Type: SystemSingle
gaussian kernel bandwidth
lambda (Optional)
Type: SystemSingle
regularization
interpFactor (Optional)
Type: SystemSingle
linear interpolation factor for adaptation
outputSigmaFactor (Optional)
Type: SystemSingle
spatial bandwidth (proportional to target)
pcaLearningRate (Optional)
Type: SystemSingle
compression learning rate
resize (Optional)
Type: SystemBoolean
activate the resize feature to improve the processing speed
splitCoeff (Optional)
Type: SystemBoolean
split the training coefficients into two matrices
wrapKernel (Optional)
Type: SystemBoolean
wrap around the kernel values
compressFeature (Optional)
Type: SystemBoolean
activate the pca method to compress the features
maxPatchSize (Optional)
Type: SystemInt32
threshold for the ROI size
compressedSize (Optional)
Type: SystemInt32
feature size after compression
descPca (Optional)
Type: Emgu.CV.TrackingTrackerKCFMode
compressed descriptors of TrackerKCF::MODE
descNpca (Optional)
Type: Emgu.CV.TrackingTrackerKCFMode
non-compressed descriptors of TrackerKCF::MODE
See Also

Reference

TrackerKCF Class
Emgu.CV.Tracking Namespace


TrackerKCF Properties

The TrackerKCF type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerKCF Class
Emgu.CV.Tracking Namespace


TrackerKCF Methods

The TrackerKCF type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerKCF Class
Emgu.CV.Tracking Namespace


TrackerKCF.DisposeObject Method

TrackerKCFDisposeObject Method

Release the unmanaged resources associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerKCF Class
Emgu.CV.Tracking Namespace


TrackerKCF Fields

The TrackerKCF type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerKCF Class
Emgu.CV.Tracking Namespace


TrackerKCF.Mode Class

TrackerKCFMode Class

Feature type to be used in the tracking grayscale, colornames, compressed color-names The modes available now: - "GRAY" -- Use grayscale values as the feature - "CN" -- Color-names feature
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.TrackingTrackerKCFMode

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Mode : Enum
Public NotInheritable Class Mode
    Inherits Enum
public ref class Mode sealed : public Enum
[<SealedAttribute>]
type Mode =
    class
        inherit Enum
    end

The TrackerKCFMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cn | Color
 | Custom | Custom
 | Gray | Grayscale
Public field | value__ |
Top
See Also

Reference

Emgu.CV.Tracking Namespace


Mode Methods

The TrackerKCFMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

TrackerKCFMode Class
Emgu.CV.Tracking Namespace


Mode Fields

The TrackerKCFMode type exposes the following members.

Fields
 | Name | Description
 | Cn | Color
 | Custom | Custom
 | Gray | Grayscale
Public field | value__ |
Top
See Also

Reference

TrackerKCFMode Class
Emgu.CV.Tracking Namespace


TrackerKCF.Mode.Cn Field

TrackerKCFModeCn Field

Color

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TrackerKCFMode Cn = 2
Public Const Cn As TrackerKCFMode = 2
public:
literal TrackerKCFMode^ Cn = 2
static val mutable Cn: TrackerKCFMode

Field Value

Type: TrackerKCFMode
See Also

Reference

TrackerKCFMode Class
Emgu.CV.Tracking Namespace


TrackerKCF.Mode.Custom Field

TrackerKCFModeCustom Field

Custom

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TrackerKCFMode Custom = 4
Public Const Custom As TrackerKCFMode = 4
public:
literal TrackerKCFMode^ Custom = 4
static val mutable Custom: TrackerKCFMode

Field Value

Type: TrackerKCFMode
See Also

Reference

TrackerKCFMode Class
Emgu.CV.Tracking Namespace


TrackerKCF.Mode.Gray Field

TrackerKCFModeGray Field

Grayscale

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TrackerKCFMode Gray = 1
Public Const Gray As TrackerKCFMode = 1
public:
literal TrackerKCFMode^ Gray = 1
static val mutable Gray: TrackerKCFMode

Field Value

Type: TrackerKCFMode
See Also

Reference

TrackerKCFMode Class
Emgu.CV.Tracking Namespace


TrackerKCF.Mode.value__ Field

TrackerKCFModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.Tracking.TrackerKCF.Mode.value__"]

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

TrackerKCFMode Class
Emgu.CV.Tracking Namespace


TrackerMedianFlow Class

Median Flow tracker implementation. The tracker is suitable for very smooth and predictable movements when object is visible throughout the whole sequence.It's quite and accurate for this type of problems (in particular, it was shown by authors to outperform MIL). During the implementation period the code at http://www.aonsquared.co.uk/node/5, the courtesy of the author Arthur Amarra, was used for the reference purpose.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerMedianFlow

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerMedianFlow : Tracker
Public Class TrackerMedianFlow
    Inherits Tracker
public ref class TrackerMedianFlow : public Tracker
type TrackerMedianFlow =
    class
        inherit Tracker
    end

The TrackerMedianFlow type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerMedianFlow | Create a median flow tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerMedianFlow Constructor

Create a median flow tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerMedianFlow(
    int pointsInGrid,
    Size winSize,
    int maxLevel,
    MCvTermCriteria termCriteria,
    Size winSizeNCC,
    double maxMedianLengthOfDisplacementDifference = 10
)
Public Sub New (
    pointsInGrid As Integer,
    winSize As Size,
    maxLevel As Integer,
    termCriteria As MCvTermCriteria,
    winSizeNCC As Size,
    Optional maxMedianLengthOfDisplacementDifference As Double = 10
)
public:
TrackerMedianFlow(
    int pointsInGrid,
    Size^ winSize,
    int maxLevel,
    MCvTermCriteria^ termCriteria,
    Size^ winSizeNCC,
    double maxMedianLengthOfDisplacementDifference = 10
)
new :
        pointsInGrid : int *
        winSize : Size *
        maxLevel : int *
        termCriteria : MCvTermCriteria *
        winSizeNCC : Size *
        ?maxMedianLengthOfDisplacementDifference : float
(* Defaults:
        let _maxMedianLengthOfDisplacementDifference = defaultArg maxMedianLengthOfDisplacementDifference 10
*)
-> TrackerMedianFlow

Parameters

pointsInGrid
Type: SystemInt32
Points in grid, use 10 for default.
winSize
Type: System.DrawingSize
Win size, use (3, 3) for default
maxLevel
Type: SystemInt32
Max level, use 5 for default.
termCriteria
Type: Emgu.CV.StructureMCvTermCriteria
Termination criteria, use count = 20 and eps = 0.3 for default
winSizeNCC
Type: System.DrawingSize
win size NCC, use (30, 30) for default
maxMedianLengthOfDisplacementDifference (Optional)
Type: SystemDouble
Max median length of displacement difference
See Also

Reference

TrackerMedianFlow Class
Emgu.CV.Tracking Namespace


TrackerMedianFlow Properties

The TrackerMedianFlow type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerMedianFlow Class
Emgu.CV.Tracking Namespace


TrackerMedianFlow Methods

The TrackerMedianFlow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerMedianFlow Class
Emgu.CV.Tracking Namespace


TrackerMedianFlow.DisposeObject Method

TrackerMedianFlowDisposeObject Method

Release the unmanaged resources associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerMedianFlow Class
Emgu.CV.Tracking Namespace


TrackerMedianFlow Fields

The TrackerMedianFlow type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerMedianFlow Class
Emgu.CV.Tracking Namespace


TrackerMIL Class

The MIL algorithm trains a classifier in an online manner to separate the object from the background. Multiple Instance Learning avoids the drift problem for a robust tracking. Original code can be found here http://vision.ucsd.edu/~bbabenko/project_miltrack.shtml
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerMIL

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerMIL : Tracker
Public Class TrackerMIL
    Inherits Tracker
public ref class TrackerMIL : public Tracker
type TrackerMIL =
    class
        inherit Tracker
    end

The TrackerMIL type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerMIL | Creates a MIL Tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerMIL Constructor

Creates a MIL Tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerMIL(
    float samplerInitInRadius = 3f,
    int samplerInitMaxNegNum = 65,
    float samplerSearchWinSize = 25f,
    float samplerTrackInRadius = 4f,
    int samplerTrackMaxPosNum = 100000,
    int samplerTrackMaxNegNum = 65,
    int featureSetNumFeatures = 250
)
Public Sub New (
    Optional samplerInitInRadius As Single = 3F,
    Optional samplerInitMaxNegNum As Integer = 65,
    Optional samplerSearchWinSize As Single = 25F,
    Optional samplerTrackInRadius As Single = 4F,
    Optional samplerTrackMaxPosNum As Integer = 100000,
    Optional samplerTrackMaxNegNum As Integer = 65,
    Optional featureSetNumFeatures As Integer = 250
)
public:
TrackerMIL(
    float samplerInitInRadius = 3f,
    int samplerInitMaxNegNum = 65,
    float samplerSearchWinSize = 25f,
    float samplerTrackInRadius = 4f,
    int samplerTrackMaxPosNum = 100000,
    int samplerTrackMaxNegNum = 65,
    int featureSetNumFeatures = 250
)
new :
        ?samplerInitInRadius : float32 *
        ?samplerInitMaxNegNum : int *
        ?samplerSearchWinSize : float32 *
        ?samplerTrackInRadius : float32 *
        ?samplerTrackMaxPosNum : int *
        ?samplerTrackMaxNegNum : int *
        ?featureSetNumFeatures : int
(* Defaults:
        let _samplerInitInRadius = defaultArg samplerInitInRadius 3f
        let _samplerInitMaxNegNum = defaultArg samplerInitMaxNegNum 65
        let _samplerSearchWinSize = defaultArg samplerSearchWinSize 25f
        let _samplerTrackInRadius = defaultArg samplerTrackInRadius 4f
        let _samplerTrackMaxPosNum = defaultArg samplerTrackMaxPosNum 100000
        let _samplerTrackMaxNegNum = defaultArg samplerTrackMaxNegNum 65
        let _featureSetNumFeatures = defaultArg featureSetNumFeatures 250
*)
-> TrackerMIL

Parameters

samplerInitInRadius (Optional)
Type: SystemSingle
radius for gathering positive instances during init
samplerInitMaxNegNum (Optional)
Type: SystemInt32
negative samples to use during init
samplerSearchWinSize (Optional)
Type: SystemSingle
size of search window
samplerTrackInRadius (Optional)
Type: SystemSingle
radius for gathering positive instances during tracking
samplerTrackMaxPosNum (Optional)
Type: SystemInt32
positive samples to use during tracking
samplerTrackMaxNegNum (Optional)
Type: SystemInt32
negative samples to use during tracking
featureSetNumFeatures (Optional)
Type: SystemInt32
features
See Also

Reference

TrackerMIL Class
Emgu.CV.Tracking Namespace


TrackerMIL Properties

The TrackerMIL type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerMIL Class
Emgu.CV.Tracking Namespace


TrackerMIL Methods

The TrackerMIL type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerMIL Class
Emgu.CV.Tracking Namespace


TrackerMIL.DisposeObject Method

TrackerMILDisposeObject Method

Release all the unmanaged memory associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerMIL Class
Emgu.CV.Tracking Namespace


TrackerMIL Fields

The TrackerMIL type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerMIL Class
Emgu.CV.Tracking Namespace


TrackerMOSSE Class

MOSSE Visual Object Tracking using Adaptive Correlation Filters
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerMOSSE

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerMOSSE : Tracker
Public Class TrackerMOSSE
    Inherits Tracker
public ref class TrackerMOSSE : public Tracker
type TrackerMOSSE =
    class
        inherit Tracker
    end

The TrackerMOSSE type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerMOSSE | Create a MOSSE tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
Remarks
note, that this tracker works with grayscale images, if passed bgr ones, they will get converted internally.
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerMOSSE Constructor

Create a MOSSE tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerMOSSE()
Public Sub New
public:
TrackerMOSSE()
new : unit -> TrackerMOSSE
See Also

Reference

TrackerMOSSE Class
Emgu.CV.Tracking Namespace


TrackerMOSSE Properties

The TrackerMOSSE type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerMOSSE Class
Emgu.CV.Tracking Namespace


TrackerMOSSE Methods

The TrackerMOSSE type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerMOSSE Class
Emgu.CV.Tracking Namespace


TrackerMOSSE.DisposeObject Method

TrackerMOSSEDisposeObject Method

Release the unmanaged resources associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerMOSSE Class
Emgu.CV.Tracking Namespace


TrackerMOSSE Fields

The TrackerMOSSE type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerMOSSE Class
Emgu.CV.Tracking Namespace


TrackerTLD Class

TLD is a novel tracking framework that explicitly decomposes the long-term tracking task into tracking, learning and detection.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.TrackingTracker
Emgu.CV.TrackingTrackerTLD

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TrackerTLD : Tracker
Public Class TrackerTLD
    Inherits Tracker
public ref class TrackerTLD : public Tracker
type TrackerTLD =
    class
        inherit Tracker
    end

The TrackerTLD type exposes the following members.

Constructors
 | Name | Description
Public method | TrackerTLD | Creates a TLD tracker
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
Remarks
The tracker follows the object from frame to frame. The detector localizes all appearances that have been observed so far and corrects the tracker if necessary. The learning estimates detector's errors and updates it to avoid these errors in the future.
See Also

Reference

Emgu.CV.Tracking Namespace


TrackerTLD Constructor

Creates a TLD tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TrackerTLD()
Public Sub New
public:
TrackerTLD()
new : unit -> TrackerTLD
See Also

Reference

TrackerTLD Class
Emgu.CV.Tracking Namespace


TrackerTLD Properties

The TrackerTLD type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TrackerTLD Class
Emgu.CV.Tracking Namespace


TrackerTLD Methods

The TrackerTLD type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources associated with this tracker (Overrides TrackerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initialize the tracker with a know bounding box that surrounding the target. (Inherited from Tracker.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Update the tracker, find the new most likely bounding box for the target. (Inherited from Tracker.)
Top
See Also

Reference

TrackerTLD Class
Emgu.CV.Tracking Namespace


TrackerTLD.DisposeObject Method

TrackerTLDDisposeObject Method

Release the unmanaged resources associated with this tracker

Namespace: Emgu.CV.Tracking
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TrackerTLD Class
Emgu.CV.Tracking Namespace


TrackerTLD Fields

The TrackerTLD type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _trackerPtr | The native pointer to the tracker (Inherited from Tracker.)
Top
See Also

Reference

TrackerTLD Class
Emgu.CV.Tracking Namespace


Emgu.CV.Util Namespace

A collection of utilities used by Emgu.CV projects
Classes
 | Class | Description
Public class | BinaryFileStorageT | A raw data storage
Public class | CvException | The default exception to be thrown when error encounter in Open CV
Public class | CvToolbox | Utilities class
Public class | DataLogger | A DataLogger for unmanaged code to log data back to managed code, using callback.
Public class | DataLoggerT | A generic version of the DataLogger
Public class | SharedPtrObject | An Unmanaged Object is a disposable object with a Ptr property pointing to the unmanaged object
Public class | StructSize | Cache the size of various header in bytes
Public class | TbbTaskScheduler | This class canbe used to initiate TBB. Only usefull if it is compiled with TBB support
Public class | VectorOfByte | Wrapped class of the C++ standard vector of Byte.
Public class | VectorOfColorPoint | Wrapped class of the C++ standard vector of ColorPoint.
Public class | VectorOfCvString | Wrapped class of the C++ standard vector of CvString.
Public class | VectorOfDMatch | Wrapped class of the C++ standard vector of DMatch.
Public class | VectorOfDouble | Wrapped class of the C++ standard vector of Double.
Public class | VectorOfFloat | Wrapped class of the C++ standard vector of Float.
Public class | VectorOfInt | Wrapped class of the C++ standard vector of Int.
Public class | VectorOfKeyPoint | Wrapped class of the C++ standard vector of KeyPoint.
Public class | VectorOfMat | Wrapped class of the C++ standard vector of Mat.
Public class | VectorOfOclPlatformInfo | Wrapped class of the C++ standard vector of OclPlatformInfo.
Public class | VectorOfPoint | Wrapped class of the C++ standard vector of Point.
Public class | VectorOfPoint3D32F | Wrapped class of the C++ standard vector of Point3D32F.
Public class | VectorOfPointF | Wrapped class of the C++ standard vector of PointF.
Public class | VectorOfRect | Wrapped class of the C++ standard vector of Rect.
Public class | VectorOfTriangle2DF | Wrapped class of the C++ standard vector of Triangle2DF.
Public class | VectorOfUMat | Wrapped class of the C++ standard vector of UMat.
Public class | VectorOfVectorOfByte | Wrapped class of the C++ standard vector of VectorOfByte.
Public class | VectorOfVectorOfDMatch | Wrapped class of the C++ standard vector of VectorOfDMatch.
Public class | VectorOfVectorOfInt | Wrapped class of the C++ standard vector of VectorOfInt.
Public class | VectorOfVectorOfPoint | Wrapped class of the C++ standard vector of VectorOfPoint.
Public class | VectorOfVectorOfPoint3D32F | Wrapped class of the C++ standard vector of VectorOfPoint3D32F.
Public class | VectorOfVectorOfPointF | Wrapped class of the C++ standard vector of VectorOfPointF.
Public class | VectorOfVectorOfRect | Wrapped class of the C++ standard vector of VectorOfRect.


BinaryFileStorage(T) Class

BinaryFileStorageT Class

A raw data storage
Inheritance Hierarchy
SystemObject
Emgu.CV.UtilBinaryFileStorageT

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BinaryFileStorage<T> : IEnumerable<T>,
    IEnumerable
where T : struct, new()

Public Class BinaryFileStorage(Of T As {Structure, New})
    Implements IEnumerable(Of T), IEnumerable
generic<typename T>
where T : value class, gcnew()
public ref class BinaryFileStorage : IEnumerable<T>,
    IEnumerable
type BinaryFileStorage<'T when 'T : struct, new()> =
    class
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The type of elements in the storage

The BinaryFileStorageT type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryFileStorageT(String) | Create a binary File Storage
Public method | BinaryFileStorageT(String, IEnumerableT) | Create a binary File Storage with the specific data
Public method | BinaryFileStorageT(String, Int32) | Create a binary File Storage
Top
Properties
 | Name | Description
Public property | FileName | The file name of the storage
Top
Methods
 | Name | Description
Public method | Append | Append the samples to the end of the storage
Public method | Clear | Delete all data in the existing storage, if there is any.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EstimateSize | Estimate the number of elements in this storage as the size of the storage divided by the size of the elements
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get the data in this storage
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSubsamples | Get the sub-sampled data in this storage
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Get a copy of the first element in the storage. If the storage is empty, a default value will be returned
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _fileInfo | The file info
Top
See Also

Reference

Emgu.CV.Util Namespace


BinaryFileStorage(T) Constructor

BinaryFileStorageT Constructor

Overload List
 | Name | Description
Public method | BinaryFileStorageT(String) | Create a binary File Storage
Public method | BinaryFileStorageT(String, IEnumerableT) | Create a binary File Storage with the specific data
Public method | BinaryFileStorageT(String, Int32) | Create a binary File Storage
Top
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T) Constructor (String)

BinaryFileStorageT Constructor (String)

http://www.emgu.com
Create a binary File Storage

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BinaryFileStorage(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
BinaryFileStorage(
    String^ fileName
)
new :
        fileName : string -> BinaryFileStorage

Parameters

fileName
Type: SystemString
The file name of the storage
See Also

Reference

BinaryFileStorageT Class
BinaryFileStorageT Overload
Emgu.CV.Util Namespace


BinaryFileStorage(T) Constructor (String, IEnumerable(T))

BinaryFileStorageT Constructor (String, IEnumerableT)

http://www.emgu.com
Create a binary File Storage with the specific data

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BinaryFileStorage(
    string fileName,
    IEnumerable<T> samples
)
Public Sub New (
    fileName As String,
    samples As IEnumerable(Of T)
)
public:
BinaryFileStorage(
    String^ fileName,
    IEnumerable<T>^ samples
)
new :
        fileName : string *
        samples : IEnumerable<'T> -> BinaryFileStorage

Parameters

fileName
Type: SystemString
The file name of the storage, all data in the existing file will be replaced
samples
Type: System.Collections.GenericIEnumerable T
The data which will be stored in the storage
See Also

Reference

BinaryFileStorageT Class
BinaryFileStorageT Overload
Emgu.CV.Util Namespace


BinaryFileStorage(T) Constructor (String, Int32)

BinaryFileStorageT Constructor (String, Int32)

http://www.emgu.com
Create a binary File Storage

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BinaryFileStorage(
    string fileName,
    int trunkSize
)
Public Sub New (
    fileName As String,
    trunkSize As Integer
)
public:
BinaryFileStorage(
    String^ fileName,
    int trunkSize
)
new :
        fileName : string *
        trunkSize : int -> BinaryFileStorage

Parameters

fileName
Type: SystemString
The file name of the storage
trunkSize
Type: SystemInt32
The data will be read in trunk of this size internally. Can be use to seed up the file read. A good number will be 4096
See Also

Reference

BinaryFileStorageT Class
BinaryFileStorageT Overload
Emgu.CV.Util Namespace


BinaryFileStorage(T) Properties

BinaryFileStorageT Properties

The BinaryFileStorageT generic type exposes the following members.

Properties
 | Name | Description
Public property | FileName | The file name of the storage
Top
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T).FileName Property

BinaryFileStorageTFileName Property

The file name of the storage

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T) Methods

BinaryFileStorageT Methods

The BinaryFileStorageT generic type exposes the following members.

Methods
 | Name | Description
Public method | Append | Append the samples to the end of the storage
Public method | Clear | Delete all data in the existing storage, if there is any.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EstimateSize | Estimate the number of elements in this storage as the size of the storage divided by the size of the elements
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get the data in this storage
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSubsamples | Get the sub-sampled data in this storage
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Get a copy of the first element in the storage. If the storage is empty, a default value will be returned
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T).Append Method

BinaryFileStorageTAppend Method

Append the samples to the end of the storage

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Append(
    IEnumerable<T> samples
)
Public Sub Append (
    samples As IEnumerable(Of T)
)
public:
void Append(
    IEnumerable<T>^ samples
)
member Append :
        samples : IEnumerable<'T> -> unit

Parameters

samples
Type: System.Collections.GenericIEnumerable T
The samples to be appended to the storage
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T).Clear Method

BinaryFileStorageTClear Method

Delete all data in the existing storage, if there is any.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T).EstimateSize Method

BinaryFileStorageTEstimateSize Method

Estimate the number of elements in this storage as the size of the storage divided by the size of the elements

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int EstimateSize()
Public Function EstimateSize As Integer
public:
int EstimateSize()
member EstimateSize : unit -> int

Return Value

Type: Int32
An estimation of the number of elements in this storage
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T).GetEnumerator Method

BinaryFileStorageTGetEnumerator Method

Get the data in this storage

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: IEnumerator T
The data in this storage

Implements

IEnumerableTGetEnumerator
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T).GetSubsamples Method

BinaryFileStorageTGetSubsamples Method

Get the sub-sampled data in this storage

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<T> GetSubsamples(
    int subsampleRate
)
Public Function GetSubsamples (
    subsampleRate As Integer
) As IEnumerable(Of T)
public:
IEnumerable<T>^ GetSubsamples(
    int subsampleRate
)
member GetSubsamples :
        subsampleRate : int -> IEnumerable<'T>

Parameters

subsampleRate
Type: SystemInt32
The sub-sample rate

Return Value

Type: IEnumerable T
The sub-sampled data in this storage
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T).Peek Method

BinaryFileStorageTPeek Method

Get a copy of the first element in the storage. If the storage is empty, a default value will be returned

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public T Peek()
Public Function Peek As T
public:
T Peek()
member Peek : unit -> 'T

Return Value

Type: T
A copy of the first element in the storage. If the storage is empty, a default value will be returned
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T) Fields

BinaryFileStorageT Fields

The BinaryFileStorageT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _fileInfo | The file info
Top
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


BinaryFileStorage(T)._fileInfo Field

BinaryFileStorageT_fileInfo Field

The file info

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected FileInfo _fileInfo
Protected _fileInfo As FileInfo
protected:
FileInfo^ _fileInfo
val mutable _fileInfo: FileInfo

Field Value

Type: FileInfo
See Also

Reference

BinaryFileStorageT Class
Emgu.CV.Util Namespace


CvException Class

The default exception to be thrown when error encounter in Open CV
Inheritance Hierarchy
SystemObject
SystemException
Emgu.CV.UtilCvException

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CvException : Exception
<SerializableAttribute>
Public Class CvException
    Inherits Exception
[SerializableAttribute]
public ref class CvException : public Exception
[<SerializableAttribute>]
type CvException =
    class
        inherit Exception
    end

The CvException type exposes the following members.

Constructors
 | Name | Description
Public method | CvException | The default exception to be thrown when error is encountered in Open CV
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorMessage | A description of the error
Public property | ErrorStr | The corresponding error string for the Status code
Public property | FileName | The source file name where error is encountered
Public property | FunctionName | The name of the function the error is encountered
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Line | The line number in the souce where error is encountered
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | Status | The numeric code for error status
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Emgu.CV.Util Namespace


CvException Constructor

The default exception to be thrown when error is encountered in Open CV

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvException(
    int status,
    string funcName,
    string errMsg,
    string fileName,
    int line
)
Public Sub New (
    status As Integer,
    funcName As String,
    errMsg As String,
    fileName As String,
    line As Integer
)
public:
CvException(
    int status,
    String^ funcName,
    String^ errMsg,
    String^ fileName,
    int line
)
new :
        status : int *
        funcName : string *
        errMsg : string *
        fileName : string *
        line : int -> CvException

Parameters

status
Type: SystemInt32
The numeric code for error status
funcName
Type: SystemString
The source file name where error is encountered
errMsg
Type: SystemString
A description of the error
fileName
Type: SystemString
The source file name where error is encountered
line
Type: SystemInt32
The line number in the souce where error is encountered
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException Properties

The CvException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorMessage | A description of the error
Public property | ErrorStr | The corresponding error string for the Status code
Public property | FileName | The source file name where error is encountered
Public property | FunctionName | The name of the function the error is encountered
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Line | The line number in the souce where error is encountered
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | Status | The numeric code for error status
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException.ErrorMessage Property

CvExceptionErrorMessage Property

A description of the error

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException.ErrorStr Property

CvExceptionErrorStr Property

The corresponding error string for the Status code

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string ErrorStr { get; }
Public ReadOnly Property ErrorStr As String
    Get
public:
property String^ ErrorStr {
    String^ get ();
}
member ErrorStr : string with get

Property Value

Type: String
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException.FileName Property

CvExceptionFileName Property

The source file name where error is encountered

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException.FunctionName Property

CvExceptionFunctionName Property

The name of the function the error is encountered

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string FunctionName { get; set; }
Public Property FunctionName As String
    Get
    Set
public:
property String^ FunctionName {
    String^ get ();
    void set (String^ value);
}
member FunctionName : string with get, set

Property Value

Type: String
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException.Line Property

CvExceptionLine Property

The line number in the souce where error is encountered

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException.Status Property

CvExceptionStatus Property

The numeric code for error status

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Status { get; set; }
Public Property Status As Integer
    Get
    Set
public:
property int Status {
    int get ();
    void set (int value);
}
member Status : int with get, set

Property Value

Type: Int32
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException Methods

The CvException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvException Events

The CvException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CvException Class
Emgu.CV.Util Namespace


CvToolbox Class

Utilities class
Inheritance Hierarchy
SystemObject
Emgu.CV.UtilCvToolbox

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class CvToolbox
Public NotInheritable Class CvToolbox
public ref class CvToolbox abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CvToolbox =  class end

The CvToolbox type exposes the following members.

Methods
Name | Description
CopyMatrixD(IntPtr, D) | Copy a jagged two dimensional array from the unmanaged memory
CopyMatrixTData(TData, IntPtr) | Copy a jagged two dimensional array to the unmanaged memory
CopyVectorTData | Copy a generic vector to the unmanaged memory
GetColorCvtCode | Given the source and destination color type, compute the color conversion code for CvInvoke.cvCvtColor function
GetMatrixFromArraysT | Convert arrays of data to matrix
GetMatrixFromPoints | Convert arrays of points to matrix
GetMinMax | Compute the minimum and maximum value from the points
Memcpy | memcpy function
Top
See Also

Reference

Emgu.CV.Util Namespace


CvToolbox Methods

The CvToolbox type exposes the following members.

Methods
Name | Description
CopyMatrixD(IntPtr, D) | Copy a jagged two dimensional array from the unmanaged memory
CopyMatrixTData(TData, IntPtr) | Copy a jagged two dimensional array to the unmanaged memory
CopyVectorTData | Copy a generic vector to the unmanaged memory
GetColorCvtCode | Given the source and destination color type, compute the color conversion code for CvInvoke.cvCvtColor function
GetMatrixFromArraysT | Convert arrays of data to matrix
GetMatrixFromPoints | Convert arrays of points to matrix
GetMinMax | Compute the minimum and maximum value from the points
Memcpy | memcpy function
Top
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


CvToolbox.CopyMatrix Method

CvToolboxCopyMatrix Method

Overload List
Name | Description
CopyMatrixD(IntPtr, D) | Copy a jagged two dimensional array from the unmanaged memory
CopyMatrixTData(TData, IntPtr) | Copy a jagged two dimensional array to the unmanaged memory
Top
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


CvToolbox.CopyMatrix(D) Method (IntPtr, D[][])

CvToolboxCopyMatrixD Method (IntPtr, D)

http://www.emgu.com
Copy a jagged two dimensional array from the unmanaged memory

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CopyMatrix<D>(
    IntPtr src,
    D[][] dest
)

Public Shared Sub CopyMatrix(Of D) (
    src As IntPtr,
    dest As D()()
)
public:
generic<typename D>
static void CopyMatrix(
    IntPtr src,
    array<array<D>^>^ dest
)
static member CopyMatrix :
        src : IntPtr *
        dest : 'D[][] -> unit

Parameters

src
Type: SystemIntPtr
The src array
dest
Type: D
Pointer to the destination unmanaged memory

Type Parameters

D
The data type of the jagged two dimensional
See Also

Reference

CvToolbox Class
CopyMatrix Overload
Emgu.CV.Util Namespace


CvToolbox.CopyMatrix(TData) Method (TData[][], IntPtr)

CvToolboxCopyMatrixTData Method (TData, IntPtr)

http://www.emgu.com
Copy a jagged two dimensional array to the unmanaged memory

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CopyMatrix<TData>(
    TData[][] source,
    IntPtr dest
)

Public Shared Sub CopyMatrix(Of TData) (
    source As TData()(),
    dest As IntPtr
)
public:
generic<typename TData>
static void CopyMatrix(
    array<array<TData>^>^ source,
    IntPtr dest
)
static member CopyMatrix :
        source : 'TData[][] *
        dest : IntPtr -> unit

Parameters

source
Type: TData
The source array
dest
Type: SystemIntPtr
Pointer to the destination unmanaged memory

Type Parameters

TData
The data type of the jagged two dimensional
See Also

Reference

CvToolbox Class
CopyMatrix Overload
Emgu.CV.Util Namespace


CvToolbox.CopyVector(TData) Method

CvToolboxCopyVectorTData Method

Copy a generic vector to the unmanaged memory

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int CopyVector<TData>(
    TData[] src,
    IntPtr dest,
    int bytesToCopy = -1
)

Public Shared Function CopyVector(Of TData) (
    src As TData(),
    dest As IntPtr,
    Optional bytesToCopy As Integer = -1
) As Integer
public:
generic<typename TData>
static int CopyVector(
    array<TData>^ src,
    IntPtr dest,
    int bytesToCopy = -1
)
static member CopyVector :
        src : 'TData[] *
        dest : IntPtr *
        ?bytesToCopy : int
(* Defaults:
        let _bytesToCopy = defaultArg bytesToCopy -1
*)
-> int

Parameters

src
Type: TData
The source vector
dest
Type: SystemIntPtr
Pointer to the destination unmanaged memory
bytesToCopy (Optional)
Type: SystemInt32
Specify the number of bytes to copy. If this is -1, the number of bytes equals the number of bytes in the src

Type Parameters

TData
The data type of the vector

Return Value

Type: Int32
The number of bytes copied
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


CvToolbox.GetColorCvtCode Method

CvToolboxGetColorCvtCode Method

Given the source and destination color type, compute the color conversion code for CvInvoke.cvCvtColor function

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static ColorConversion GetColorCvtCode(
    Type srcColorType,
    Type destColorType
)
Public Shared Function GetColorCvtCode (
    srcColorType As Type,
    destColorType As Type
) As ColorConversion
public:
static ColorConversion^ GetColorCvtCode(
    Type^ srcColorType,
    Type^ destColorType
)
static member GetColorCvtCode :
        srcColorType : Type *
        destColorType : Type -> ColorConversion

Parameters

srcColorType
Type: SystemType
The source color type. Must be a type inherited from IColor
destColorType
Type: SystemType
The dest color type. Must be a type inherited from IColor

Return Value

Type: ColorConversion
The color conversion code for CvInvoke.cvCvtColor function
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


CvToolbox.GetMatrixFromArrays(T) Method

CvToolboxGetMatrixFromArraysT Method

Convert arrays of data to matrix

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<T> GetMatrixFromArrays<T>(
    T[][] data
)
where T : struct, new()

Public Shared Function GetMatrixFromArrays(Of T As {Structure, New}) (
    data As T()()
) As Matrix(Of T)
public:
generic<typename T>
where T : value class, gcnew()
static Matrix<T>^ GetMatrixFromArrays(
    array<array<T>^>^ data
)
static member GetMatrixFromArrays :
        data : 'T[][] -> Matrix<'T>  when 'T : struct, new()

Parameters

data
Type: T
Arrays of data

Type Parameters

T
The data type of the matrix

Return Value

Type: Matrix T
A two dimension matrix that represent the array
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


CvToolbox.GetMatrixFromPoints Method

CvToolboxGetMatrixFromPoints Method

Convert arrays of points to matrix

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Matrix<double> GetMatrixFromPoints(
    MCvPoint2D64f[][] points
)
Public Shared Function GetMatrixFromPoints (
    points As MCvPoint2D64f()()
) As Matrix(Of Double)
public:
static Matrix<double>^ GetMatrixFromPoints(
    array<array<MCvPoint2D64f^>^>^ points
)
static member GetMatrixFromPoints :
        points : MCvPoint2D64f[][] -> Matrix<float>

Parameters

points
Type: Emgu.CV.StructureMCvPoint2D64f
Arrays of points

Return Value

Type: Matrix Double
A two dimension matrix that represent the points
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


CvToolbox.GetMinMax Method

CvToolboxGetMinMax Method

Compute the minimum and maximum value from the points

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GetMinMax(
    IEnumerable<MCvPoint3D64f> points,
    out MCvPoint3D64f min,
    out MCvPoint3D64f max
)
Public Shared Sub GetMinMax (
    points As IEnumerable(Of MCvPoint3D64f),
    <OutAttribute> ByRef min As MCvPoint3D64f,
    <OutAttribute> ByRef max As MCvPoint3D64f
)
public:
static void GetMinMax(
    IEnumerable<MCvPoint3D64f^>^ points,
    [OutAttribute] MCvPoint3D64f^% min,
    [OutAttribute] MCvPoint3D64f^% max
)
static member GetMinMax :
        points : IEnumerable<MCvPoint3D64f> *
        min : MCvPoint3D64f byref *
        max : MCvPoint3D64f byref -> unit

Parameters

points
Type: System.Collections.GenericIEnumerableMCvPoint3D64f
The points
min
Type: Emgu.CV.StructureMCvPoint3D64f
The minimum x,y,z values
max
Type: Emgu.CV.StructureMCvPoint3D64f
The maximum x,y,z values
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


CvToolbox.Memcpy Method

CvToolboxMemcpy Method

memcpy function

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Memcpy(
    IntPtr dest,
    IntPtr src,
    int len
)
Public Shared Sub Memcpy (
    dest As IntPtr,
    src As IntPtr,
    len As Integer
)
public:
static void Memcpy(
    IntPtr dest,
    IntPtr src,
    int len
)
static member Memcpy :
        dest : IntPtr *
        src : IntPtr *
        len : int -> unit

Parameters

dest
Type: SystemIntPtr
the destination of memory copy
src
Type: SystemIntPtr
the source of memory copy
len
Type: SystemInt32
the number of bytes to be copied
See Also

Reference

CvToolbox Class
Emgu.CV.Util Namespace


DataLogger Class

A DataLogger for unmanaged code to log data back to managed code, using callback.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilDataLogger

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DataLogger : UnmanagedObject
Public Class DataLogger
    Inherits UnmanagedObject
public ref class DataLogger : public UnmanagedObject
type DataLogger =
    class
        inherit UnmanagedObject
    end

The DataLogger type exposes the following members.

Constructors
 | Name | Description
Public method | DataLogger | Create a MessageLogger and register the callback function
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the DataLogger and all the unmanaged memory associated with it. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Log some data
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | OnDataReceived | The event that will be raised when the unmanaged code send over data
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Util Namespace


DataLogger Constructor

Create a MessageLogger and register the callback function

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DataLogger(
    int logLevel
)
Public Sub New (
    logLevel As Integer
)
public:
DataLogger(
    int logLevel
)
new :
        logLevel : int -> DataLogger

Parameters

logLevel
Type: SystemInt32
The log level.
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger Properties

The DataLogger type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger Methods

The DataLogger type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the DataLogger and all the unmanaged memory associated with it. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Log some data
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger.DisposeObject Method

DataLoggerDisposeObject Method

Release the DataLogger and all the unmanaged memory associated with it.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger.Log Method

DataLoggerLog Method

Log some data

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Log(
    IntPtr data,
    int logLevel
)
Public Sub Log (
    data As IntPtr,
    logLevel As Integer
)
public:
void Log(
    IntPtr data,
    int logLevel
)
member Log :
        data : IntPtr *
        logLevel : int -> unit

Parameters

data
Type: SystemIntPtr
Pointer to some unmanaged data
logLevel
Type: SystemInt32
The logLevel. The Log function only logs when the logLevel is greater or equals to the DataLogger's logLevel
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger Events

The DataLogger type exposes the following members.

Events
 | Name | Description
Public event | OnDataReceived | The event that will be raised when the unmanaged code send over data
Top
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger.OnDataReceived Event

DataLoggerOnDataReceived Event

The event that will be raised when the unmanaged code send over data

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs<IntPtr>> OnDataReceived
Public Event OnDataReceived As EventHandler(Of EventArgs(Of IntPtr))
public:
 event EventHandler<EventArgs<IntPtr>^>^ OnDataReceived {
    void add (EventHandler<EventArgs<IntPtr>^>^ value);
    void remove (EventHandler<EventArgs<IntPtr>^>^ value);
}
member OnDataReceived : IEvent<EventHandler<EventArgs<IntPtr>>,
    EventArgs>

Value

Type: SystemEventHandlerEventArgs IntPtr
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger Fields

The DataLogger type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DataLogger Class
Emgu.CV.Util Namespace


DataLogger(T) Class

DataLoggerT Class

A generic version of the DataLogger
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.CV.UtilDataLoggerT

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DataLogger<T> : DisposableObject

Public Class DataLogger(Of T)
    Inherits DisposableObject
generic<typename T>
public ref class DataLogger : public DisposableObject
type DataLogger<'T> =
    class
        inherit DisposableObject
    end

Type Parameters

T
The supported type includes System.String and System.ValueType

The DataLoggerT type exposes the following members.

Constructors
 | Name | Description
Public method | DataLoggerT | Create a new DataLogger
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this DataLogger (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Log some data
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | OnDataReceived | The event that will be raised when the unmanaged code send over data
Top
Operators
Name | Description
(DataLoggerT to IntPtr) | Implicit operator for IntPtr
Top
See Also

Reference

Emgu.CV.Util Namespace


DataLogger(T) Constructor

DataLoggerT Constructor

Create a new DataLogger

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DataLogger(
    int logLevel
)
Public Sub New (
    logLevel As Integer
)
public:
DataLogger(
    int logLevel
)
new :
        logLevel : int -> DataLogger

Parameters

logLevel
Type: SystemInt32
The log level.
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T) Properties

DataLoggerT Properties

The DataLoggerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object
Top
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T).Ptr Property

DataLoggerTPtr Property

Pointer to the unmanaged object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Ptr { get; }
Public ReadOnly Property Ptr As IntPtr
    Get
public:
property IntPtr Ptr {
    IntPtr get ();
}
member Ptr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T) Methods

DataLoggerT Methods

The DataLoggerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this DataLogger (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Log some data
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T).DisposeObject Method

DataLoggerTDisposeObject Method

Release the unmanaged memory associated with this DataLogger

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T).Log Method

DataLoggerTLog Method

Log some data

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Log(
    T data,
    int logLevel
)
Public Sub Log (
    data As T,
    logLevel As Integer
)
public:
void Log(
    T data,
    int logLevel
)
member Log :
        data : 'T *
        logLevel : int -> unit

Parameters

data
Type: T
The data to be logged
logLevel
Type: SystemInt32
The logLevel. The Log function only logs when the logLevel is greater or equals to the DataLogger's logLevel
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T) Events

DataLoggerT Events

The DataLoggerT generic type exposes the following members.

Events
 | Name | Description
Public event | OnDataReceived | The event that will be raised when the unmanaged code send over data
Top
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T).OnDataReceived Event

DataLoggerTOnDataReceived Event

The event that will be raised when the unmanaged code send over data

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs<T>> OnDataReceived
Public Event OnDataReceived As EventHandler(Of EventArgs(Of T))
public:
 event EventHandler<EventArgs<T>^>^ OnDataReceived {
    void add (EventHandler<EventArgs<T>^>^ value);
    void remove (EventHandler<EventArgs<T>^>^ value);
}
member OnDataReceived : IEvent<EventHandler<EventArgs<'T>>,
    EventArgs>

Value

Type: SystemEventHandlerEventArgs T
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T) Type Conversions

DataLoggerT Type Conversions

The DataLoggerT generic type exposes the following members.

Operators
Name | Description
(DataLoggerT to IntPtr) | Implicit operator for IntPtr
Top
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


DataLogger(T) Implicit Conversion (DataLogger(T) to IntPtr)

DataLoggerT Conversion (DataLoggerT to IntPtr)

http://www.emgu.com
Implicit operator for IntPtr

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static implicit operator IntPtr (
    DataLogger<T> obj
)
Public Shared Widening Operator CType (
    obj As DataLogger(Of T)
) As IntPtr
static implicit operator IntPtr (
    DataLogger<T>^ obj
)
F# does not support the declaration of new casting operators.

Parameters

obj
Type: Emgu.CV.UtilDataLogger T
The DataLogger

Return Value

Type: IntPtr
The unmanaged pointer for this DataLogger
See Also

Reference

DataLoggerT Class
Emgu.CV.Util Namespace


SharedPtrObject Class

An Unmanaged Object is a disposable object with a Ptr property pointing to the unmanaged object
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
More...

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SharedPtrObject : UnmanagedObject
Public MustInherit Class SharedPtrObject
    Inherits UnmanagedObject
public ref class SharedPtrObject abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type SharedPtrObject =
    class
        inherit UnmanagedObject
    end

The SharedPtrObject type exposes the following members.

Constructors
 | Name | Description
Protected method | SharedPtrObject | Initializes a new instance of the SharedPtrObject class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Inherited from DisposableObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object
Top
See Also

Reference

Emgu.CV.Util Namespace
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.BioinspiredRetina
Emgu.CV.BioinspiredRetinaFastToneMapping
Emgu.CV.CudaCudaBackgroundSubtractorFGD
Emgu.CV.CudaCudaBackgroundSubtractorGMG
Emgu.CV.CudaCudaBackgroundSubtractorMOG
Emgu.CV.CudaCudaBackgroundSubtractorMOG2
Emgu.CV.CudaCudaBroxOpticalFlow
Emgu.CV.CudaCudaCannyEdgeDetector
Emgu.CV.CudaCudaCascadeClassifier
Emgu.CV.CudaCudaClahe
Emgu.CV.CudaCudaConvolution
Emgu.CV.CudaCudaCornernessCriteria
Emgu.CV.CudaCudaDensePyrLKOpticalFlow
Emgu.CV.CudaCudaDisparityBilateralFilter
Emgu.CV.CudaCudaFarnebackOpticalFlow
Emgu.CV.CudaCudaFilter
Emgu.CV.CudaCudaGoodFeaturesToTrackDetector
Emgu.CV.CudaCudaHOG
Emgu.CV.CudaCudaHoughCirclesDetector
Emgu.CV.CudaCudaHoughLinesDetector
Emgu.CV.CudaCudaHoughSegmentDetector
Emgu.CV.CudaCudaLookUpTable
Emgu.CV.CudaCudaOpticalFlowDualTvl1
Emgu.CV.CudaCudaSparsePyrLKOpticalFlow
Emgu.CV.CudaCudaStereoBM
Emgu.CV.CudaCudaStereoConstantSpaceBP
Emgu.CV.CudaCudaTemplateMatching
Emgu.CV.CudaCudaVideoReader
Emgu.CV.CudaCudaVideoWriter
Emgu.CV.CudaDescriptorMatcher
Emgu.CVDenseRLOFOpticalFlow
Emgu.CV.DnnLayer
Emgu.CV.DpmDpmDetector
Emgu.CVDualTVL1OpticalFlow
Emgu.CV.FaceBIF
Emgu.CV.FaceFaceRecognizer
Emgu.CV.FaceMACE
Emgu.CV.Features2DFeature2D
Emgu.CV.FreetypeFreetype2
Emgu.CV.HfsHfsSegment
Emgu.CV.MLKNearest
Emgu.CV.MLTrainData
Emgu.CVOptFlowDeepFlow
Emgu.CVOpticalFlowPCAFlow
Emgu.CV.QualityQualityBRISQUE
Emgu.CV.QualityQualityGMSD
Emgu.CV.QualityQualityMSE
Emgu.CV.QualityQualityPSNR
Emgu.CV.QualityQualitySSIM
Emgu.CVSparseRLOFOpticalFlow
Emgu.CV.StereoQuasiDenseStereo
Emgu.CVStereoBM
Emgu.CVStereoSGBM
Emgu.CV.StitchingStitcher
Emgu.CV.XFeatures2DPCTSignatures
Emgu.CV.XFeatures2DPCTSignaturesSQFD
Emgu.CV.XImgprocDisparityWLSFilter
Emgu.CV.XImgprocEdgeBoxes
Emgu.CV.XImgprocFastLineDetector
Emgu.CV.XImgprocRidgeDetectionFilter
Emgu.CV.XImgprocRightMatcher


SharedPtrObject Constructor

Initializes a new instance of the SharedPtrObject class

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected SharedPtrObject()
Protected Sub New
protected:
SharedPtrObject()
new : unit -> SharedPtrObject
See Also

Reference

SharedPtrObject Class
Emgu.CV.Util Namespace


SharedPtrObject Properties

The SharedPtrObject type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object
Top
See Also

Reference

SharedPtrObject Class
Emgu.CV.Util Namespace


SharedPtrObject.SharedPtr Property

SharedPtrObjectSharedPtr Property

Pointer to the shared pointer to the unmanaged object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr SharedPtr { get; }
Public ReadOnly Property SharedPtr As IntPtr
    Get
public:
property IntPtr SharedPtr {
    IntPtr get ();
}
member SharedPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

SharedPtrObject Class
Emgu.CV.Util Namespace


SharedPtrObject Methods

The SharedPtrObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Inherited from DisposableObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SharedPtrObject Class
Emgu.CV.Util Namespace


SharedPtrObject Fields

The SharedPtrObject type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object
Top
See Also

Reference

SharedPtrObject Class
Emgu.CV.Util Namespace


SharedPtrObject._sharedPtr Field

SharedPtrObject_sharedPtr Field

A pointer to the shared pointer to the unmanaged object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _sharedPtr
Protected _sharedPtr As IntPtr
protected:
IntPtr _sharedPtr
val mutable _sharedPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

SharedPtrObject Class
Emgu.CV.Util Namespace


StructSize Class

Cache the size of various header in bytes
Inheritance Hierarchy
SystemObject
Emgu.CV.UtilStructSize

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class StructSize
Public NotInheritable Class StructSize
public ref class StructSize abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StructSize =  class end

The StructSize type exposes the following members.

Properties
Name | Description
MCvMat | The size of MCvMat
MCvMatND | The size of MCvMatND
MCvPoint2D64f | The size of PointF
MCvPoint3D32f | The size of MCvPoint3D32f
MIplImage | The size of IplImage
PointF | The size of PointF
RangF | The size of RangF
Top
See Also

Reference

Emgu.CV.Util Namespace


StructSize Properties

The StructSize type exposes the following members.

Properties
Name | Description
MCvMat | The size of MCvMat
MCvMatND | The size of MCvMatND
MCvPoint2D64f | The size of PointF
MCvPoint3D32f | The size of MCvPoint3D32f
MIplImage | The size of IplImage
PointF | The size of PointF
RangF | The size of RangF
Top
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


StructSize.MCvMat Property

StructSizeMCvMat Property

The size of MCvMat

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int MCvMat { get; }
Public Shared ReadOnly Property MCvMat As Integer
    Get
public:
static property int MCvMat {
    int get ();
}
static member MCvMat : int with get

Property Value

Type: Int32
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


StructSize.MCvMatND Property

StructSizeMCvMatND Property

The size of MCvMatND

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int MCvMatND { get; }
Public Shared ReadOnly Property MCvMatND As Integer
    Get
public:
static property int MCvMatND {
    int get ();
}
static member MCvMatND : int with get

Property Value

Type: Int32
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


StructSize.MCvPoint2D64f Property

StructSizeMCvPoint2D64f Property

The size of PointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int MCvPoint2D64f { get; }
Public Shared ReadOnly Property MCvPoint2D64f As Integer
    Get
public:
static property int MCvPoint2D64f {
    int get ();
}
static member MCvPoint2D64f : int with get

Property Value

Type: Int32
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


StructSize.MCvPoint3D32f Property

StructSizeMCvPoint3D32f Property

The size of MCvPoint3D32f

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int MCvPoint3D32f { get; }
Public Shared ReadOnly Property MCvPoint3D32f As Integer
    Get
public:
static property int MCvPoint3D32f {
    int get ();
}
static member MCvPoint3D32f : int with get

Property Value

Type: Int32
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


StructSize.MIplImage Property

StructSizeMIplImage Property

The size of IplImage

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int MIplImage { get; }
Public Shared ReadOnly Property MIplImage As Integer
    Get
public:
static property int MIplImage {
    int get ();
}
static member MIplImage : int with get

Property Value

Type: Int32
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


StructSize.PointF Property

StructSizePointF Property

The size of PointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int PointF { get; }
Public Shared ReadOnly Property PointF As Integer
    Get
public:
static property int PointF {
    int get ();
}
static member PointF : int with get

Property Value

Type: Int32
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


StructSize.RangF Property

StructSizeRangF Property

The size of RangF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int RangF { get; }
Public Shared ReadOnly Property RangF As Integer
    Get
public:
static property int RangF {
    int get ();
}
static member RangF : int with get

Property Value

Type: Int32
See Also

Reference

StructSize Class
Emgu.CV.Util Namespace


TbbTaskScheduler Class

This class canbe used to initiate TBB. Only usefull if it is compiled with TBB support
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilTbbTaskScheduler

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TbbTaskScheduler : UnmanagedObject
Public Class TbbTaskScheduler
    Inherits UnmanagedObject
public ref class TbbTaskScheduler : public UnmanagedObject
type TbbTaskScheduler =
    class
        inherit UnmanagedObject
    end

The TbbTaskScheduler type exposes the following members.

Constructors
 | Name | Description
Public method | TbbTaskScheduler | Initialize the TBB task scheduler
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the TBB task scheduler (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.Util Namespace


TbbTaskScheduler Constructor

Initialize the TBB task scheduler

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TbbTaskScheduler()
Public Sub New
public:
TbbTaskScheduler()
new : unit -> TbbTaskScheduler
See Also

Reference

TbbTaskScheduler Class
Emgu.CV.Util Namespace


TbbTaskScheduler Properties

The TbbTaskScheduler type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TbbTaskScheduler Class
Emgu.CV.Util Namespace


TbbTaskScheduler Methods

The TbbTaskScheduler type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the TBB task scheduler (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbbTaskScheduler Class
Emgu.CV.Util Namespace


TbbTaskScheduler.DisposeObject Method

TbbTaskSchedulerDisposeObject Method

Release the TBB task scheduler

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TbbTaskScheduler Class
Emgu.CV.Util Namespace


TbbTaskScheduler Fields

The TbbTaskScheduler type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TbbTaskScheduler Class
Emgu.CV.Util Namespace


VectorOfByte Class

Wrapped class of the C++ standard vector of Byte.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfByte

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfByte : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfByte
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfByte : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfByte =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfByte type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfByte | Create an empty standard vector of Byte
Public method | VectorOfByte(Byte) | Create an standard vector of Byte with the initial values
Public method | VectorOfByte(Int32) | Create an standard vector of Byte of the specific size
Public method | VectorOfByte(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Byte) | Push an array of value into the standard vector
Public method | Push(VectorOfByte) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Byte
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfByte Constructor

Overload List
 | Name | Description
Public method | VectorOfByte | Create an empty standard vector of Byte
Public method | VectorOfByte(Byte) | Create an standard vector of Byte with the initial values
Public method | VectorOfByte(Int32) | Create an standard vector of Byte of the specific size
Public method | VectorOfByte(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte Constructor

Create an empty standard vector of Byte

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfByte()
Public Sub New
public:
VectorOfByte()
new : unit -> VectorOfByte
See Also

Reference

VectorOfByte Class
VectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfByte Constructor (Byte[])

VectorOfByte Constructor (Byte)

http://www.emgu.com
Create an standard vector of Byte with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfByte(
    byte[] values
)
Public Sub New (
    values As Byte()
)
public:
VectorOfByte(
    array<unsigned char>^ values
)
new :
        values : byte[] -> VectorOfByte

Parameters

values
Type: SystemByte
The initial values
See Also

Reference

VectorOfByte Class
VectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfByte Constructor (Int32)

Create an standard vector of Byte of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfByte(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfByte(
    int size
)
new :
        size : int -> VectorOfByte

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfByte Class
VectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfByte Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfByte(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfByte(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfByte

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfByte Class
VectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfByte Properties

The VectorOfByte type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.Item Property

VectorOfByteItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Byte
    Get
public:
property unsigned char Item[int index] {
    unsigned char get (int index);
}
member Item : byte with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Byte
The item in the specific index
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.Size Property

VectorOfByteSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.SizeOfItemInBytes Property

VectorOfByteSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.StartAddress Property

VectorOfByteStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte Methods

The VectorOfByte type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Byte) | Push an array of value into the standard vector
Public method | Push(VectorOfByte) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Byte
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.Clear Method

VectorOfByteClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.DisposeObject Method

VectorOfByteDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.GetInputArray Method

VectorOfByteGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.GetInputOutputArray Method

VectorOfByteGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.GetObjectData Method

VectorOfByteGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.GetOutputArray Method

VectorOfByteGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.Push Method

VectorOfBytePush Method

Overload List
 | Name | Description
Public method | Push(Byte) | Push an array of value into the standard vector
Public method | Push(VectorOfByte) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte.Push Method (Byte[])

VectorOfBytePush Method (Byte)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    byte[] value
)
Public Sub Push (
    value As Byte()
)
public:
void Push(
    array<unsigned char>^ value
)
member Push :
        value : byte[] -> unit

Parameters

value
Type: SystemByte
The value to be pushed to the vector
See Also

Reference

VectorOfByte Class
Push Overload
Emgu.CV.Util Namespace


VectorOfByte.Push Method (VectorOfByte)

VectorOfBytePush Method (VectorOfByte)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfByte other
)
Public Sub Push (
    other As VectorOfByte
)
public:
void Push(
    VectorOfByte^ other
)
member Push :
        other : VectorOfByte -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfByte
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfByte Class
Push Overload
Emgu.CV.Util Namespace


VectorOfByte.ToArray Method

VectorOfByteToArray Method

Convert the standard vector to an array of Byte

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] ToArray()
Public Function ToArray As Byte()
public:
array<unsigned char>^ ToArray()
member ToArray : unit -> byte[]

Return Value

Type: Byte
An array of Byte
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfByte Fields

The VectorOfByte type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfByte Class
Emgu.CV.Util Namespace


VectorOfColorPoint Class

Wrapped class of the C++ standard vector of ColorPoint.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfColorPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfColorPoint : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfColorPoint
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfColorPoint : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfColorPoint =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfColorPoint type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfColorPoint | Create an empty standard vector of ColorPoint
Public method | VectorOfColorPoint(Int32) | Create an standard vector of ColorPoint of the specific size
Public method | VectorOfColorPoint(ColorPoint) | Create an standard vector of ColorPoint with the initial values
Public method | VectorOfColorPoint(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(ColorPoint) | Push an array of value into the standard vector
Public method | Push(VectorOfColorPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of ColorPoint
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfColorPoint Constructor

Overload List
 | Name | Description
Public method | VectorOfColorPoint | Create an empty standard vector of ColorPoint
Public method | VectorOfColorPoint(Int32) | Create an standard vector of ColorPoint of the specific size
Public method | VectorOfColorPoint(ColorPoint) | Create an standard vector of ColorPoint with the initial values
Public method | VectorOfColorPoint(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint Constructor

Create an empty standard vector of ColorPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfColorPoint()
Public Sub New
public:
VectorOfColorPoint()
new : unit -> VectorOfColorPoint
See Also

Reference

VectorOfColorPoint Class
VectorOfColorPoint Overload
Emgu.CV.Util Namespace


VectorOfColorPoint Constructor (Int32)

Create an standard vector of ColorPoint of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfColorPoint(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfColorPoint(
    int size
)
new :
        size : int -> VectorOfColorPoint

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfColorPoint Class
VectorOfColorPoint Overload
Emgu.CV.Util Namespace


VectorOfColorPoint Constructor (ColorPoint[])

VectorOfColorPoint Constructor (ColorPoint)

http://www.emgu.com
Create an standard vector of ColorPoint with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfColorPoint(
    ColorPoint[] values
)
Public Sub New (
    values As ColorPoint()
)
public:
VectorOfColorPoint(
    array<ColorPoint^>^ values
)
new :
        values : ColorPoint[] -> VectorOfColorPoint

Parameters

values
Type: Emgu.CV.StructureColorPoint
The initial values
See Also

Reference

VectorOfColorPoint Class
VectorOfColorPoint Overload
Emgu.CV.Util Namespace


VectorOfColorPoint Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfColorPoint(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfColorPoint(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfColorPoint

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfColorPoint Class
VectorOfColorPoint Overload
Emgu.CV.Util Namespace


VectorOfColorPoint Properties

The VectorOfColorPoint type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.Item Property

VectorOfColorPointItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ColorPoint this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As ColorPoint
    Get
public:
property ColorPoint^ Item[int index] {
    ColorPoint^ get (int index);
}
member Item : ColorPoint with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: ColorPoint
The item in the specific index
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.Size Property

VectorOfColorPointSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.SizeOfItemInBytes Property

VectorOfColorPointSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.StartAddress Property

VectorOfColorPointStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint Methods

The VectorOfColorPoint type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(ColorPoint) | Push an array of value into the standard vector
Public method | Push(VectorOfColorPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of ColorPoint
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.Clear Method

VectorOfColorPointClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.DisposeObject Method

VectorOfColorPointDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.GetInputArray Method

VectorOfColorPointGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.GetInputOutputArray Method

VectorOfColorPointGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.GetObjectData Method

VectorOfColorPointGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.GetOutputArray Method

VectorOfColorPointGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.Push Method

VectorOfColorPointPush Method

Overload List
 | Name | Description
Public method | Push(ColorPoint) | Push an array of value into the standard vector
Public method | Push(VectorOfColorPoint) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint.Push Method (ColorPoint[])

VectorOfColorPointPush Method (ColorPoint)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    ColorPoint[] value
)
Public Sub Push (
    value As ColorPoint()
)
public:
void Push(
    array<ColorPoint^>^ value
)
member Push :
        value : ColorPoint[] -> unit

Parameters

value
Type: Emgu.CV.StructureColorPoint
The value to be pushed to the vector
See Also

Reference

VectorOfColorPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfColorPoint.Push Method (VectorOfColorPoint)

VectorOfColorPointPush Method (VectorOfColorPoint)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfColorPoint other
)
Public Sub Push (
    other As VectorOfColorPoint
)
public:
void Push(
    VectorOfColorPoint^ other
)
member Push :
        other : VectorOfColorPoint -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfColorPoint
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfColorPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfColorPoint.ToArray Method

VectorOfColorPointToArray Method

Convert the standard vector to an array of ColorPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public ColorPoint[] ToArray()
Public Function ToArray As ColorPoint()
public:
array<ColorPoint^>^ ToArray()
member ToArray : unit -> ColorPoint[]

Return Value

Type: ColorPoint
An array of ColorPoint
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfColorPoint Fields

The VectorOfColorPoint type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfColorPoint Class
Emgu.CV.Util Namespace


VectorOfCvString Class

Wrapped class of the C++ standard vector of CvString.
Wrapped class of the C++ standard vector of CvString.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfCvString

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfCvString : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfCvString
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfCvString : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfCvString =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfCvString type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfCvString | Create an empty standard vector of CvString
Public method | VectorOfCvString(Int32) | Create an standard vector of CvString of the specific size
Public method | VectorOfCvString(String) | Create a VectorOfCvString object from an array of String
Public method | VectorOfCvString(CvString) | Create an standard vector of CvString with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(CvString) | Push a value into the standard vector
Public method | Push(CvString) | Push multiple values into the standard vector
Public method | Push(VectorOfCvString) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of String
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfCvString Constructor

Overload List
 | Name | Description
Public method | VectorOfCvString | Create an empty standard vector of CvString
Public method | VectorOfCvString(Int32) | Create an standard vector of CvString of the specific size
Public method | VectorOfCvString(String) | Create a VectorOfCvString object from an array of String
Public method | VectorOfCvString(CvString) | Create an standard vector of CvString with the initial values
Top
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString Constructor

Create an empty standard vector of CvString

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfCvString()
Public Sub New
public:
VectorOfCvString()
new : unit -> VectorOfCvString
See Also

Reference

VectorOfCvString Class
VectorOfCvString Overload
Emgu.CV.Util Namespace


VectorOfCvString Constructor (Int32)

Create an standard vector of CvString of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfCvString(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfCvString(
    int size
)
new :
        size : int -> VectorOfCvString

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfCvString Class
VectorOfCvString Overload
Emgu.CV.Util Namespace


VectorOfCvString Constructor (String[])

VectorOfCvString Constructor (String)

http://www.emgu.com
Create a VectorOfCvString object from an array of String

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfCvString(
    string[] strings
)
Public Sub New (
    strings As String()
)
public:
VectorOfCvString(
    array<String^>^ strings
)
new :
        strings : string[] -> VectorOfCvString

Parameters

strings
Type: SystemString
The strings to be placed in this VectorOfCvString
See Also

Reference

VectorOfCvString Class
VectorOfCvString Overload
Emgu.CV.Util Namespace


VectorOfCvString Constructor (CvString[])

VectorOfCvString Constructor (CvString)

http://www.emgu.com
Create an standard vector of CvString with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfCvString(
    params CvString[] values
)
Public Sub New (
    ParamArray values As CvString()
)
public:
VectorOfCvString(
    ... array<CvString^>^ values
)
new :
        values : CvString[] -> VectorOfCvString

Parameters

values
Type: Emgu.CVCvString
The initial values
See Also

Reference

VectorOfCvString Class
VectorOfCvString Overload
Emgu.CV.Util Namespace


VectorOfCvString Properties

The VectorOfCvString type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.Item Property

VectorOfCvStringItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CvString this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As CvString
    Get
public:
property CvString^ Item[int index] {
    CvString^ get (int index);
}
member Item : CvString with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: CvString
The item in the specific index
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.Size Property

VectorOfCvStringSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.SizeOfItemInBytes Property

VectorOfCvStringSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString Methods

The VectorOfCvString type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(CvString) | Push a value into the standard vector
Public method | Push(CvString) | Push multiple values into the standard vector
Public method | Push(VectorOfCvString) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of String
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.Clear Method

VectorOfCvStringClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.DisposeObject Method

VectorOfCvStringDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.GetInputArray Method

VectorOfCvStringGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.GetInputOutputArray Method

VectorOfCvStringGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.GetOutputArray Method

VectorOfCvStringGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.Push Method

VectorOfCvStringPush Method

Overload List
 | Name | Description
Public method | Push(CvString) | Push a value into the standard vector
Public method | Push(CvString) | Push multiple values into the standard vector
Public method | Push(VectorOfCvString) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString.Push Method (CvString)

VectorOfCvStringPush Method (CvString)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    CvString value
)
Public Sub Push (
    value As CvString
)
public:
void Push(
    CvString^ value
)
member Push :
        value : CvString -> unit

Parameters

value
Type: Emgu.CVCvString
The value to be pushed to the vector
See Also

Reference

VectorOfCvString Class
Push Overload
Emgu.CV.Util Namespace


VectorOfCvString.Push Method (CvString[])

VectorOfCvStringPush Method (CvString)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    CvString[] values
)
Public Sub Push (
    values As CvString()
)
public:
void Push(
    array<CvString^>^ values
)
member Push :
        values : CvString[] -> unit

Parameters

values
Type: Emgu.CVCvString
The values to be pushed to the vector
See Also

Reference

VectorOfCvString Class
Push Overload
Emgu.CV.Util Namespace


VectorOfCvString.Push Method (VectorOfCvString)

VectorOfCvStringPush Method (VectorOfCvString)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfCvString other
)
Public Sub Push (
    other As VectorOfCvString
)
public:
void Push(
    VectorOfCvString^ other
)
member Push :
        other : VectorOfCvString -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfCvString
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfCvString Class
Push Overload
Emgu.CV.Util Namespace


VectorOfCvString.ToArray Method

VectorOfCvStringToArray Method

Convert the standard vector to an array of String

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] ToArray()
Public Function ToArray As String()
public:
array<String^>^ ToArray()
member ToArray : unit -> string[]

Return Value

Type: String
An array of String
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfCvString Fields

The VectorOfCvString type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfCvString Class
Emgu.CV.Util Namespace


VectorOfDMatch Class

Wrapped class of the C++ standard vector of DMatch.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfDMatch

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfDMatch : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfDMatch
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfDMatch : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfDMatch =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfDMatch type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfDMatch | Create an empty standard vector of DMatch
Public method | VectorOfDMatch(Int32) | Create an standard vector of DMatch of the specific size
Public method | VectorOfDMatch(MDMatch) | Create an standard vector of DMatch with the initial values
Public method | VectorOfDMatch(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MDMatch) | Push an array of value into the standard vector
Public method | Push(VectorOfDMatch) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of DMatch
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfDMatch Constructor

Overload List
 | Name | Description
Public method | VectorOfDMatch | Create an empty standard vector of DMatch
Public method | VectorOfDMatch(Int32) | Create an standard vector of DMatch of the specific size
Public method | VectorOfDMatch(MDMatch) | Create an standard vector of DMatch with the initial values
Public method | VectorOfDMatch(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch Constructor

Create an empty standard vector of DMatch

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDMatch()
Public Sub New
public:
VectorOfDMatch()
new : unit -> VectorOfDMatch
See Also

Reference

VectorOfDMatch Class
VectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfDMatch Constructor (Int32)

Create an standard vector of DMatch of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDMatch(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfDMatch(
    int size
)
new :
        size : int -> VectorOfDMatch

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfDMatch Class
VectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfDMatch Constructor (MDMatch[])

VectorOfDMatch Constructor (MDMatch)

http://www.emgu.com
Create an standard vector of DMatch with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDMatch(
    MDMatch[] values
)
Public Sub New (
    values As MDMatch()
)
public:
VectorOfDMatch(
    array<MDMatch^>^ values
)
new :
        values : MDMatch[] -> VectorOfDMatch

Parameters

values
Type: Emgu.CV.StructureMDMatch
The initial values
See Also

Reference

VectorOfDMatch Class
VectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfDMatch Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDMatch(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfDMatch(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfDMatch

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfDMatch Class
VectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfDMatch Properties

The VectorOfDMatch type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.Item Property

VectorOfDMatchItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MDMatch this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As MDMatch
    Get
public:
property MDMatch^ Item[int index] {
    MDMatch^ get (int index);
}
member Item : MDMatch with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: MDMatch
The item in the specific index
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.Size Property

VectorOfDMatchSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.SizeOfItemInBytes Property

VectorOfDMatchSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.StartAddress Property

VectorOfDMatchStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch Methods

The VectorOfDMatch type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MDMatch) | Push an array of value into the standard vector
Public method | Push(VectorOfDMatch) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of DMatch
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.Clear Method

VectorOfDMatchClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.DisposeObject Method

VectorOfDMatchDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.GetInputArray Method

VectorOfDMatchGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.GetInputOutputArray Method

VectorOfDMatchGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.GetObjectData Method

VectorOfDMatchGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.GetOutputArray Method

VectorOfDMatchGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.Push Method

VectorOfDMatchPush Method

Overload List
 | Name | Description
Public method | Push(MDMatch) | Push an array of value into the standard vector
Public method | Push(VectorOfDMatch) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch.Push Method (MDMatch[])

VectorOfDMatchPush Method (MDMatch)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    MDMatch[] value
)
Public Sub Push (
    value As MDMatch()
)
public:
void Push(
    array<MDMatch^>^ value
)
member Push :
        value : MDMatch[] -> unit

Parameters

value
Type: Emgu.CV.StructureMDMatch
The value to be pushed to the vector
See Also

Reference

VectorOfDMatch Class
Push Overload
Emgu.CV.Util Namespace


VectorOfDMatch.Push Method (VectorOfDMatch)

VectorOfDMatchPush Method (VectorOfDMatch)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfDMatch other
)
Public Sub Push (
    other As VectorOfDMatch
)
public:
void Push(
    VectorOfDMatch^ other
)
member Push :
        other : VectorOfDMatch -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfDMatch
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfDMatch Class
Push Overload
Emgu.CV.Util Namespace


VectorOfDMatch.ToArray Method

VectorOfDMatchToArray Method

Convert the standard vector to an array of DMatch

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MDMatch[] ToArray()
Public Function ToArray As MDMatch()
public:
array<MDMatch^>^ ToArray()
member ToArray : unit -> MDMatch[]

Return Value

Type: MDMatch
An array of DMatch
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDMatch Fields

The VectorOfDMatch type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfDouble Class

Wrapped class of the C++ standard vector of Double.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfDouble

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfDouble : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfDouble
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfDouble : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfDouble =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfDouble type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfDouble | Create an empty standard vector of Double
Public method | VectorOfDouble(Double) | Create an standard vector of Double with the initial values
Public method | VectorOfDouble(Int32) | Create an standard vector of Double of the specific size
Public method | VectorOfDouble(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Double) | Push an array of value into the standard vector
Public method | Push(VectorOfDouble) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Double
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfDouble Constructor

Overload List
 | Name | Description
Public method | VectorOfDouble | Create an empty standard vector of Double
Public method | VectorOfDouble(Double) | Create an standard vector of Double with the initial values
Public method | VectorOfDouble(Int32) | Create an standard vector of Double of the specific size
Public method | VectorOfDouble(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble Constructor

Create an empty standard vector of Double

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDouble()
Public Sub New
public:
VectorOfDouble()
new : unit -> VectorOfDouble
See Also

Reference

VectorOfDouble Class
VectorOfDouble Overload
Emgu.CV.Util Namespace


VectorOfDouble Constructor (Double[])

VectorOfDouble Constructor (Double)

http://www.emgu.com
Create an standard vector of Double with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDouble(
    double[] values
)
Public Sub New (
    values As Double()
)
public:
VectorOfDouble(
    array<double>^ values
)
new :
        values : float[] -> VectorOfDouble

Parameters

values
Type: SystemDouble
The initial values
See Also

Reference

VectorOfDouble Class
VectorOfDouble Overload
Emgu.CV.Util Namespace


VectorOfDouble Constructor (Int32)

Create an standard vector of Double of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDouble(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfDouble(
    int size
)
new :
        size : int -> VectorOfDouble

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfDouble Class
VectorOfDouble Overload
Emgu.CV.Util Namespace


VectorOfDouble Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDouble(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfDouble(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfDouble

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfDouble Class
VectorOfDouble Overload
Emgu.CV.Util Namespace


VectorOfDouble Properties

The VectorOfDouble type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.Item Property

VectorOfDoubleItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Double
    Get
public:
property double Item[int index] {
    double get (int index);
}
member Item : float with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Double
The item in the specific index
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.Size Property

VectorOfDoubleSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.SizeOfItemInBytes Property

VectorOfDoubleSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.StartAddress Property

VectorOfDoubleStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble Methods

The VectorOfDouble type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Double) | Push an array of value into the standard vector
Public method | Push(VectorOfDouble) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Double
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.Clear Method

VectorOfDoubleClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.DisposeObject Method

VectorOfDoubleDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.GetInputArray Method

VectorOfDoubleGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.GetInputOutputArray Method

VectorOfDoubleGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.GetObjectData Method

VectorOfDoubleGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.GetOutputArray Method

VectorOfDoubleGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.Push Method

VectorOfDoublePush Method

Overload List
 | Name | Description
Public method | Push(Double) | Push an array of value into the standard vector
Public method | Push(VectorOfDouble) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble.Push Method (Double[])

VectorOfDoublePush Method (Double)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    double[] value
)
Public Sub Push (
    value As Double()
)
public:
void Push(
    array<double>^ value
)
member Push :
        value : float[] -> unit

Parameters

value
Type: SystemDouble
The value to be pushed to the vector
See Also

Reference

VectorOfDouble Class
Push Overload
Emgu.CV.Util Namespace


VectorOfDouble.Push Method (VectorOfDouble)

VectorOfDoublePush Method (VectorOfDouble)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfDouble other
)
Public Sub Push (
    other As VectorOfDouble
)
public:
void Push(
    VectorOfDouble^ other
)
member Push :
        other : VectorOfDouble -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfDouble
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfDouble Class
Push Overload
Emgu.CV.Util Namespace


VectorOfDouble.ToArray Method

VectorOfDoubleToArray Method

Convert the standard vector to an array of Double

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()
member ToArray : unit -> float[]

Return Value

Type: Double
An array of Double
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfDouble Fields

The VectorOfDouble type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfDouble Class
Emgu.CV.Util Namespace


VectorOfFloat Class

Wrapped class of the C++ standard vector of Float.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfFloat

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfFloat : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfFloat
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfFloat : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfFloat =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfFloat type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfFloat | Create an empty standard vector of Float
Public method | VectorOfFloat(Int32) | Create an standard vector of Float of the specific size
Public method | VectorOfFloat(Single) | Create an standard vector of Float with the initial values
Public method | VectorOfFloat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Single) | Push an array of value into the standard vector
Public method | Push(VectorOfFloat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Float
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfFloat Constructor

Overload List
 | Name | Description
Public method | VectorOfFloat | Create an empty standard vector of Float
Public method | VectorOfFloat(Int32) | Create an standard vector of Float of the specific size
Public method | VectorOfFloat(Single) | Create an standard vector of Float with the initial values
Public method | VectorOfFloat(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat Constructor

Create an empty standard vector of Float

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfFloat()
Public Sub New
public:
VectorOfFloat()
new : unit -> VectorOfFloat
See Also

Reference

VectorOfFloat Class
VectorOfFloat Overload
Emgu.CV.Util Namespace


VectorOfFloat Constructor (Int32)

Create an standard vector of Float of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfFloat(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfFloat(
    int size
)
new :
        size : int -> VectorOfFloat

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfFloat Class
VectorOfFloat Overload
Emgu.CV.Util Namespace


VectorOfFloat Constructor (Single[])

VectorOfFloat Constructor (Single)

http://www.emgu.com
Create an standard vector of Float with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfFloat(
    float[] values
)
Public Sub New (
    values As Single()
)
public:
VectorOfFloat(
    array<float>^ values
)
new :
        values : float32[] -> VectorOfFloat

Parameters

values
Type: SystemSingle
The initial values
See Also

Reference

VectorOfFloat Class
VectorOfFloat Overload
Emgu.CV.Util Namespace


VectorOfFloat Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfFloat(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfFloat(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfFloat

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfFloat Class
VectorOfFloat Overload
Emgu.CV.Util Namespace


VectorOfFloat Properties

The VectorOfFloat type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.Item Property

VectorOfFloatItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Single
    Get
public:
property float Item[int index] {
    float get (int index);
}
member Item : float32 with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Single
The item in the specific index
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.Size Property

VectorOfFloatSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.SizeOfItemInBytes Property

VectorOfFloatSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.StartAddress Property

VectorOfFloatStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat Methods

The VectorOfFloat type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Single) | Push an array of value into the standard vector
Public method | Push(VectorOfFloat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Float
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.Clear Method

VectorOfFloatClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.DisposeObject Method

VectorOfFloatDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.GetInputArray Method

VectorOfFloatGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.GetInputOutputArray Method

VectorOfFloatGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.GetObjectData Method

VectorOfFloatGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.GetOutputArray Method

VectorOfFloatGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.Push Method

VectorOfFloatPush Method

Overload List
 | Name | Description
Public method | Push(Single) | Push an array of value into the standard vector
Public method | Push(VectorOfFloat) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat.Push Method (Single[])

VectorOfFloatPush Method (Single)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    float[] value
)
Public Sub Push (
    value As Single()
)
public:
void Push(
    array<float>^ value
)
member Push :
        value : float32[] -> unit

Parameters

value
Type: SystemSingle
The value to be pushed to the vector
See Also

Reference

VectorOfFloat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfFloat.Push Method (VectorOfFloat)

VectorOfFloatPush Method (VectorOfFloat)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfFloat other
)
Public Sub Push (
    other As VectorOfFloat
)
public:
void Push(
    VectorOfFloat^ other
)
member Push :
        other : VectorOfFloat -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfFloat
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfFloat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfFloat.ToArray Method

VectorOfFloatToArray Method

Convert the standard vector to an array of Float

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float[] ToArray()
Public Function ToArray As Single()
public:
array<float>^ ToArray()
member ToArray : unit -> float32[]

Return Value

Type: Single
An array of Float
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfFloat Fields

The VectorOfFloat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfFloat Class
Emgu.CV.Util Namespace


VectorOfInt Class

Wrapped class of the C++ standard vector of Int.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfInt

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfInt : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfInt
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfInt : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfInt =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfInt type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfInt | Create an empty standard vector of Int
Public method | VectorOfInt(Int32) | Create an standard vector of Int of the specific size
Public method | VectorOfInt(Int32) | Create an standard vector of Int with the initial values
Public method | VectorOfInt(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Int32) | Push an array of value into the standard vector
Public method | Push(VectorOfInt) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfInt Constructor

Overload List
 | Name | Description
Public method | VectorOfInt | Create an empty standard vector of Int
Public method | VectorOfInt(Int32) | Create an standard vector of Int of the specific size
Public method | VectorOfInt(Int32) | Create an standard vector of Int with the initial values
Public method | VectorOfInt(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt Constructor

Create an empty standard vector of Int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfInt()
Public Sub New
public:
VectorOfInt()
new : unit -> VectorOfInt
See Also

Reference

VectorOfInt Class
VectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfInt Constructor (Int32)

Create an standard vector of Int of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfInt(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfInt(
    int size
)
new :
        size : int -> VectorOfInt

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfInt Class
VectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfInt Constructor (Int32[])

VectorOfInt Constructor (Int32)

http://www.emgu.com
Create an standard vector of Int with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfInt(
    int[] values
)
Public Sub New (
    values As Integer()
)
public:
VectorOfInt(
    array<int>^ values
)
new :
        values : int[] -> VectorOfInt

Parameters

values
Type: SystemInt32
The initial values
See Also

Reference

VectorOfInt Class
VectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfInt Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfInt(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfInt(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfInt

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfInt Class
VectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfInt Properties

The VectorOfInt type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.Item Property

VectorOfIntItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Integer
    Get
public:
property int Item[int index] {
    int get (int index);
}
member Item : int with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Int32
The item in the specific index
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.Size Property

VectorOfIntSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.SizeOfItemInBytes Property

VectorOfIntSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.StartAddress Property

VectorOfIntStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt Methods

The VectorOfInt type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Int32) | Push an array of value into the standard vector
Public method | Push(VectorOfInt) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.Clear Method

VectorOfIntClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.DisposeObject Method

VectorOfIntDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.GetInputArray Method

VectorOfIntGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.GetInputOutputArray Method

VectorOfIntGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.GetObjectData Method

VectorOfIntGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.GetOutputArray Method

VectorOfIntGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.Push Method

VectorOfIntPush Method

Overload List
 | Name | Description
Public method | Push(Int32) | Push an array of value into the standard vector
Public method | Push(VectorOfInt) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt.Push Method (Int32[])

VectorOfIntPush Method (Int32)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    int[] value
)
Public Sub Push (
    value As Integer()
)
public:
void Push(
    array<int>^ value
)
member Push :
        value : int[] -> unit

Parameters

value
Type: SystemInt32
The value to be pushed to the vector
See Also

Reference

VectorOfInt Class
Push Overload
Emgu.CV.Util Namespace


VectorOfInt.Push Method (VectorOfInt)

VectorOfIntPush Method (VectorOfInt)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfInt other
)
Public Sub Push (
    other As VectorOfInt
)
public:
void Push(
    VectorOfInt^ other
)
member Push :
        other : VectorOfInt -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfInt
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfInt Class
Push Overload
Emgu.CV.Util Namespace


VectorOfInt.ToArray Method

VectorOfIntToArray Method

Convert the standard vector to an array of Int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] ToArray()
Public Function ToArray As Integer()
public:
array<int>^ ToArray()
member ToArray : unit -> int[]

Return Value

Type: Int32
An array of Int
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfInt Fields

The VectorOfInt type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfInt Class
Emgu.CV.Util Namespace


VectorOfKeyPoint Class

Wrapped class of the C++ standard vector of KeyPoint.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfKeyPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfKeyPoint : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfKeyPoint
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfKeyPoint : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfKeyPoint =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfKeyPoint type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfKeyPoint | Create an empty standard vector of KeyPoint
Public method | VectorOfKeyPoint(Int32) | Create an standard vector of KeyPoint of the specific size
Public method | VectorOfKeyPoint(MKeyPoint) | Create an standard vector of KeyPoint with the initial values
Public method | VectorOfKeyPoint(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterByImageBorder | Remove keypoints within borderPixels of an image edge.
Public method | FilterByKeypointSize | Remove keypoints of sizes out of range.
Public method | FilterByPixelsMask | Remove keypoints from some image by mask for pixels of this image.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MKeyPoint) | Push an array of value into the standard vector
Public method | Push(VectorOfKeyPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of KeyPoint
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfKeyPoint Constructor

Overload List
 | Name | Description
Public method | VectorOfKeyPoint | Create an empty standard vector of KeyPoint
Public method | VectorOfKeyPoint(Int32) | Create an standard vector of KeyPoint of the specific size
Public method | VectorOfKeyPoint(MKeyPoint) | Create an standard vector of KeyPoint with the initial values
Public method | VectorOfKeyPoint(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint Constructor

Create an empty standard vector of KeyPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfKeyPoint()
Public Sub New
public:
VectorOfKeyPoint()
new : unit -> VectorOfKeyPoint
See Also

Reference

VectorOfKeyPoint Class
VectorOfKeyPoint Overload
Emgu.CV.Util Namespace


VectorOfKeyPoint Constructor (Int32)

Create an standard vector of KeyPoint of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfKeyPoint(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfKeyPoint(
    int size
)
new :
        size : int -> VectorOfKeyPoint

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfKeyPoint Class
VectorOfKeyPoint Overload
Emgu.CV.Util Namespace


VectorOfKeyPoint Constructor (MKeyPoint[])

VectorOfKeyPoint Constructor (MKeyPoint)

http://www.emgu.com
Create an standard vector of KeyPoint with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfKeyPoint(
    MKeyPoint[] values
)
Public Sub New (
    values As MKeyPoint()
)
public:
VectorOfKeyPoint(
    array<MKeyPoint^>^ values
)
new :
        values : MKeyPoint[] -> VectorOfKeyPoint

Parameters

values
Type: Emgu.CV.StructureMKeyPoint
The initial values
See Also

Reference

VectorOfKeyPoint Class
VectorOfKeyPoint Overload
Emgu.CV.Util Namespace


VectorOfKeyPoint Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfKeyPoint(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfKeyPoint(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfKeyPoint

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfKeyPoint Class
VectorOfKeyPoint Overload
Emgu.CV.Util Namespace


VectorOfKeyPoint Properties

The VectorOfKeyPoint type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.Item Property

VectorOfKeyPointItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MKeyPoint this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As MKeyPoint
    Get
public:
property MKeyPoint^ Item[int index] {
    MKeyPoint^ get (int index);
}
member Item : MKeyPoint with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: MKeyPoint
The item in the specific index
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.Size Property

VectorOfKeyPointSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.SizeOfItemInBytes Property

VectorOfKeyPointSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.StartAddress Property

VectorOfKeyPointStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint Methods

The VectorOfKeyPoint type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterByImageBorder | Remove keypoints within borderPixels of an image edge.
Public method | FilterByKeypointSize | Remove keypoints of sizes out of range.
Public method | FilterByPixelsMask | Remove keypoints from some image by mask for pixels of this image.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MKeyPoint) | Push an array of value into the standard vector
Public method | Push(VectorOfKeyPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of KeyPoint
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.Clear Method

VectorOfKeyPointClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.DisposeObject Method

VectorOfKeyPointDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.FilterByImageBorder Method

VectorOfKeyPointFilterByImageBorder Method

Remove keypoints within borderPixels of an image edge.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FilterByImageBorder(
    Size imageSize,
    int borderSize
)
Public Sub FilterByImageBorder (
    imageSize As Size,
    borderSize As Integer
)
public:
void FilterByImageBorder(
    Size^ imageSize,
    int borderSize
)
member FilterByImageBorder :
        imageSize : Size *
        borderSize : int -> unit

Parameters

imageSize
Type: System.DrawingSize
Image size
borderSize
Type: SystemInt32
Border size in pixel
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.FilterByKeypointSize Method

VectorOfKeyPointFilterByKeypointSize Method

Remove keypoints of sizes out of range.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FilterByKeypointSize(
    float minSize,
    float maxSize
)
Public Sub FilterByKeypointSize (
    minSize As Single,
    maxSize As Single
)
public:
void FilterByKeypointSize(
    float minSize,
    float maxSize
)
member FilterByKeypointSize :
        minSize : float32 *
        maxSize : float32 -> unit

Parameters

minSize
Type: SystemSingle
Minimum size
maxSize
Type: SystemSingle
Maximum size
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.FilterByPixelsMask Method

VectorOfKeyPointFilterByPixelsMask Method

Remove keypoints from some image by mask for pixels of this image.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void FilterByPixelsMask(
    Image<Gray, byte> mask
)
Public Sub FilterByPixelsMask (
    mask As Image(Of Gray, Byte)
)
public:
void FilterByPixelsMask(
    Image<Gray^, unsigned char>^ mask
)
member FilterByPixelsMask :
        mask : Image<Gray, byte> -> unit

Parameters

mask
Type: Emgu.CVImage Gray, Byte
The mask
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.GetInputArray Method

VectorOfKeyPointGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.GetInputOutputArray Method

VectorOfKeyPointGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.GetObjectData Method

VectorOfKeyPointGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.GetOutputArray Method

VectorOfKeyPointGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.Push Method

VectorOfKeyPointPush Method

Overload List
 | Name | Description
Public method | Push(MKeyPoint) | Push an array of value into the standard vector
Public method | Push(VectorOfKeyPoint) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint.Push Method (MKeyPoint[])

VectorOfKeyPointPush Method (MKeyPoint)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    MKeyPoint[] value
)
Public Sub Push (
    value As MKeyPoint()
)
public:
void Push(
    array<MKeyPoint^>^ value
)
member Push :
        value : MKeyPoint[] -> unit

Parameters

value
Type: Emgu.CV.StructureMKeyPoint
The value to be pushed to the vector
See Also

Reference

VectorOfKeyPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfKeyPoint.Push Method (VectorOfKeyPoint)

VectorOfKeyPointPush Method (VectorOfKeyPoint)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfKeyPoint other
)
Public Sub Push (
    other As VectorOfKeyPoint
)
public:
void Push(
    VectorOfKeyPoint^ other
)
member Push :
        other : VectorOfKeyPoint -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfKeyPoint
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfKeyPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfKeyPoint.ToArray Method

VectorOfKeyPointToArray Method

Convert the standard vector to an array of KeyPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MKeyPoint[] ToArray()
Public Function ToArray As MKeyPoint()
public:
array<MKeyPoint^>^ ToArray()
member ToArray : unit -> MKeyPoint[]

Return Value

Type: MKeyPoint
An array of KeyPoint
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfKeyPoint Fields

The VectorOfKeyPoint type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfKeyPoint Class
Emgu.CV.Util Namespace


VectorOfMat Class

Wrapped class of the C++ standard vector of Mat.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfMat

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfMat : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfMat
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfMat : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfMat =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfMat type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfMat | Create an empty standard vector of Mat
Public method | VectorOfMat(Int32) | Create an standard vector of Mat of the specific size
Public method | VectorOfMat(Mat) | Create an standard vector of Mat with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Mat) | Push a value into the standard vector
Public method | Push(Mat) | Push multiple values into the standard vector
Public method | Push(VectorOfMat) | Push multiple values from the other vector into this vector
Public method | PushTDepth(CvArrayTDepth) | Convert a CvArray to cv::Mat and push it into the vector
Public method | PushTDepth(CvArrayTDepth) | Convert a group of CvArray to cv::Mat and push them into the vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfMat Constructor

Overload List
 | Name | Description
Public method | VectorOfMat | Create an empty standard vector of Mat
Public method | VectorOfMat(Int32) | Create an standard vector of Mat of the specific size
Public method | VectorOfMat(Mat) | Create an standard vector of Mat with the initial values
Top
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat Constructor

Create an empty standard vector of Mat

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfMat()
Public Sub New
public:
VectorOfMat()
new : unit -> VectorOfMat
See Also

Reference

VectorOfMat Class
VectorOfMat Overload
Emgu.CV.Util Namespace


VectorOfMat Constructor (Int32)

Create an standard vector of Mat of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfMat(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfMat(
    int size
)
new :
        size : int -> VectorOfMat

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfMat Class
VectorOfMat Overload
Emgu.CV.Util Namespace


VectorOfMat Constructor (Mat[])

VectorOfMat Constructor (Mat)

http://www.emgu.com
Create an standard vector of Mat with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfMat(
    params Mat[] values
)
Public Sub New (
    ParamArray values As Mat()
)
public:
VectorOfMat(
    ... array<Mat^>^ values
)
new :
        values : Mat[] -> VectorOfMat

Parameters

values
Type: Emgu.CVMat
The initial values
See Also

Reference

VectorOfMat Class
VectorOfMat Overload
Emgu.CV.Util Namespace


VectorOfMat Properties

The VectorOfMat type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.Item Property

VectorOfMatItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Mat
    Get
public:
property Mat^ Item[int index] {
    Mat^ get (int index);
}
member Item : Mat with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Mat
The item in the specific index
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.Size Property

VectorOfMatSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.SizeOfItemInBytes Property

VectorOfMatSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat Methods

The VectorOfMat type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Mat) | Push a value into the standard vector
Public method | Push(Mat) | Push multiple values into the standard vector
Public method | Push(VectorOfMat) | Push multiple values from the other vector into this vector
Public method | PushTDepth(CvArrayTDepth) | Convert a CvArray to cv::Mat and push it into the vector
Public method | PushTDepth(CvArrayTDepth) | Convert a group of CvArray to cv::Mat and push them into the vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.Clear Method

VectorOfMatClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.DisposeObject Method

VectorOfMatDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.GetInputArray Method

VectorOfMatGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.GetInputOutputArray Method

VectorOfMatGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.GetOutputArray Method

VectorOfMatGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.Push Method

VectorOfMatPush Method

Overload List
 | Name | Description
Public method | PushTDepth(CvArrayTDepth) | Convert a CvArray to cv::Mat and push it into the vector
Public method | PushTDepth(CvArrayTDepth) | Convert a group of CvArray to cv::Mat and push them into the vector
Public method | Push(Mat) | Push a value into the standard vector
Public method | Push(Mat) | Push multiple values into the standard vector
Public method | Push(VectorOfMat) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfMat.Push(TDepth) Method (CvArray(TDepth))

VectorOfMatPushTDepth Method (CvArrayTDepth)

http://www.emgu.com
Convert a CvArray to cv::Mat and push it into the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push<TDepth>(
    CvArray<TDepth> cvArray
)
where TDepth : new()

Public Sub Push(Of TDepth As New) (
    cvArray As CvArray(Of TDepth)
)
public:
generic<typename TDepth>
where TDepth : gcnew()
void Push(
    CvArray<TDepth>^ cvArray
)
member Push :
        cvArray : CvArray<'TDepth> -> unit  when 'TDepth : new()

Parameters

cvArray
Type: Emgu.CVCvArray TDepth
The cvArray to be pushed into the vector

Type Parameters

TDepth
The type of depth of the cvArray
See Also

Reference

VectorOfMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfMat.Push(TDepth) Method (CvArray(TDepth)[])

VectorOfMatPushTDepth Method (CvArrayTDepth)

http://www.emgu.com
Convert a group of CvArray to cv::Mat and push them into the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push<TDepth>(
    CvArray<TDepth>[] values
)
where TDepth : new()

Public Sub Push(Of TDepth As New) (
    values As CvArray(Of TDepth)()
)
public:
generic<typename TDepth>
where TDepth : gcnew()
void Push(
    array<CvArray<TDepth>^>^ values
)
member Push :
        values : CvArray<'TDepth>[] -> unit  when 'TDepth : new()

Parameters

values
Type: Emgu.CVCvArray TDepth
The values to be pushed to the vector

Type Parameters

TDepth
The type of depth of the cvArray
See Also

Reference

VectorOfMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfMat.Push Method (Mat)

VectorOfMatPush Method (Mat)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    Mat value
)
Public Sub Push (
    value As Mat
)
public:
void Push(
    Mat^ value
)
member Push :
        value : Mat -> unit

Parameters

value
Type: Emgu.CVMat
The value to be pushed to the vector
See Also

Reference

VectorOfMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfMat.Push Method (Mat[])

VectorOfMatPush Method (Mat)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    Mat[] values
)
Public Sub Push (
    values As Mat()
)
public:
void Push(
    array<Mat^>^ values
)
member Push :
        values : Mat[] -> unit

Parameters

values
Type: Emgu.CVMat
The values to be pushed to the vector
See Also

Reference

VectorOfMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfMat.Push Method (VectorOfMat)

VectorOfMatPush Method (VectorOfMat)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfMat other
)
Public Sub Push (
    other As VectorOfMat
)
public:
void Push(
    VectorOfMat^ other
)
member Push :
        other : VectorOfMat -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfMat
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfMat Fields

The VectorOfMat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfMat Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Class

Wrapped class of the C++ standard vector of OclPlatformInfo.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfOclPlatformInfo

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfOclPlatformInfo : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfOclPlatformInfo
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfOclPlatformInfo : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfOclPlatformInfo =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfOclPlatformInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfOclPlatformInfo | Create an empty standard vector of OclPlatformInfo
Public method | VectorOfOclPlatformInfo(Int32) | Create an standard vector of OclPlatformInfo of the specific size
Public method | VectorOfOclPlatformInfo(PlatformInfo) | Create an standard vector of OclPlatformInfo with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(PlatformInfo) | Push a value into the standard vector
Public method | Push(PlatformInfo) | Push multiple values into the standard vector
Public method | Push(VectorOfOclPlatformInfo) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Constructor

Overload List
 | Name | Description
Public method | VectorOfOclPlatformInfo | Create an empty standard vector of OclPlatformInfo
Public method | VectorOfOclPlatformInfo(Int32) | Create an standard vector of OclPlatformInfo of the specific size
Public method | VectorOfOclPlatformInfo(PlatformInfo) | Create an standard vector of OclPlatformInfo with the initial values
Top
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Constructor

Create an empty standard vector of OclPlatformInfo

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfOclPlatformInfo()
Public Sub New
public:
VectorOfOclPlatformInfo()
new : unit -> VectorOfOclPlatformInfo
See Also

Reference

VectorOfOclPlatformInfo Class
VectorOfOclPlatformInfo Overload
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Constructor (Int32)

Create an standard vector of OclPlatformInfo of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfOclPlatformInfo(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfOclPlatformInfo(
    int size
)
new :
        size : int -> VectorOfOclPlatformInfo

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfOclPlatformInfo Class
VectorOfOclPlatformInfo Overload
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Constructor (PlatformInfo[])

VectorOfOclPlatformInfo Constructor (PlatformInfo)

http://www.emgu.com
Create an standard vector of OclPlatformInfo with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfOclPlatformInfo(
    params PlatformInfo[] values
)
Public Sub New (
    ParamArray values As PlatformInfo()
)
public:
VectorOfOclPlatformInfo(
    ... array<PlatformInfo^>^ values
)
new :
        values : PlatformInfo[] -> VectorOfOclPlatformInfo

Parameters

values
Type: Emgu.CV.OclPlatformInfo
The initial values
See Also

Reference

VectorOfOclPlatformInfo Class
VectorOfOclPlatformInfo Overload
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Properties

The VectorOfOclPlatformInfo type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.Item Property

VectorOfOclPlatformInfoItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PlatformInfo this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As PlatformInfo
    Get
public:
property PlatformInfo^ Item[int index] {
    PlatformInfo^ get (int index);
}
member Item : PlatformInfo with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: PlatformInfo
The item in the specific index
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.Size Property

VectorOfOclPlatformInfoSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.SizeOfItemInBytes Property

VectorOfOclPlatformInfoSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Methods

The VectorOfOclPlatformInfo type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(PlatformInfo) | Push a value into the standard vector
Public method | Push(PlatformInfo) | Push multiple values into the standard vector
Public method | Push(VectorOfOclPlatformInfo) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.Clear Method

VectorOfOclPlatformInfoClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.DisposeObject Method

VectorOfOclPlatformInfoDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.GetInputArray Method

VectorOfOclPlatformInfoGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.GetInputOutputArray Method

VectorOfOclPlatformInfoGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.GetOutputArray Method

VectorOfOclPlatformInfoGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.Push Method

VectorOfOclPlatformInfoPush Method

Overload List
 | Name | Description
Public method | Push(PlatformInfo) | Push a value into the standard vector
Public method | Push(PlatformInfo) | Push multiple values into the standard vector
Public method | Push(VectorOfOclPlatformInfo) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.Push Method (PlatformInfo)

VectorOfOclPlatformInfoPush Method (PlatformInfo)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    PlatformInfo value
)
Public Sub Push (
    value As PlatformInfo
)
public:
void Push(
    PlatformInfo^ value
)
member Push :
        value : PlatformInfo -> unit

Parameters

value
Type: Emgu.CV.OclPlatformInfo
The value to be pushed to the vector
See Also

Reference

VectorOfOclPlatformInfo Class
Push Overload
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.Push Method (PlatformInfo[])

VectorOfOclPlatformInfoPush Method (PlatformInfo)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    PlatformInfo[] values
)
Public Sub Push (
    values As PlatformInfo()
)
public:
void Push(
    array<PlatformInfo^>^ values
)
member Push :
        values : PlatformInfo[] -> unit

Parameters

values
Type: Emgu.CV.OclPlatformInfo
The values to be pushed to the vector
See Also

Reference

VectorOfOclPlatformInfo Class
Push Overload
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo.Push Method (VectorOfOclPlatformInfo)

VectorOfOclPlatformInfoPush Method (VectorOfOclPlatformInfo)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfOclPlatformInfo other
)
Public Sub Push (
    other As VectorOfOclPlatformInfo
)
public:
void Push(
    VectorOfOclPlatformInfo^ other
)
member Push :
        other : VectorOfOclPlatformInfo -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfOclPlatformInfo
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfOclPlatformInfo Class
Push Overload
Emgu.CV.Util Namespace


VectorOfOclPlatformInfo Fields

The VectorOfOclPlatformInfo type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfOclPlatformInfo Class
Emgu.CV.Util Namespace


VectorOfPoint Class

Wrapped class of the C++ standard vector of Point.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfPoint : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfPoint
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfPoint : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfPoint =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfPoint type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfPoint | Create an empty standard vector of Point
Public method | VectorOfPoint(Point) | Create an standard vector of Point with the initial values
Public method | VectorOfPoint(Int32) | Create an standard vector of Point of the specific size
Public method | VectorOfPoint(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Point) | Push an array of value into the standard vector
Public method | Push(VectorOfPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Point
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfPoint Constructor

Overload List
 | Name | Description
Public method | VectorOfPoint | Create an empty standard vector of Point
Public method | VectorOfPoint(Point) | Create an standard vector of Point with the initial values
Public method | VectorOfPoint(Int32) | Create an standard vector of Point of the specific size
Public method | VectorOfPoint(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint Constructor

Create an empty standard vector of Point

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint()
Public Sub New
public:
VectorOfPoint()
new : unit -> VectorOfPoint
See Also

Reference

VectorOfPoint Class
VectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfPoint Constructor (Point[])

VectorOfPoint Constructor (Point)

http://www.emgu.com
Create an standard vector of Point with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint(
    Point[] values
)
Public Sub New (
    values As Point()
)
public:
VectorOfPoint(
    array<Point^>^ values
)
new :
        values : Point[] -> VectorOfPoint

Parameters

values
Type: System.DrawingPoint
The initial values
See Also

Reference

VectorOfPoint Class
VectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfPoint Constructor (Int32)

Create an standard vector of Point of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfPoint(
    int size
)
new :
        size : int -> VectorOfPoint

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfPoint Class
VectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfPoint Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfPoint(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfPoint

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfPoint Class
VectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfPoint Properties

The VectorOfPoint type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.Item Property

VectorOfPointItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Point
    Get
public:
property Point^ Item[int index] {
    Point^ get (int index);
}
member Item : Point with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Point
The item in the specific index
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.Size Property

VectorOfPointSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.SizeOfItemInBytes Property

VectorOfPointSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.StartAddress Property

VectorOfPointStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint Methods

The VectorOfPoint type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Point) | Push an array of value into the standard vector
Public method | Push(VectorOfPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Point
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.Clear Method

VectorOfPointClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.DisposeObject Method

VectorOfPointDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.GetInputArray Method

VectorOfPointGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.GetInputOutputArray Method

VectorOfPointGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.GetObjectData Method

VectorOfPointGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.GetOutputArray Method

VectorOfPointGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.Push Method

VectorOfPointPush Method

Overload List
 | Name | Description
Public method | Push(Point) | Push an array of value into the standard vector
Public method | Push(VectorOfPoint) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint.Push Method (Point[])

VectorOfPointPush Method (Point)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    Point[] value
)
Public Sub Push (
    value As Point()
)
public:
void Push(
    array<Point^>^ value
)
member Push :
        value : Point[] -> unit

Parameters

value
Type: System.DrawingPoint
The value to be pushed to the vector
See Also

Reference

VectorOfPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfPoint.Push Method (VectorOfPoint)

VectorOfPointPush Method (VectorOfPoint)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPoint other
)
Public Sub Push (
    other As VectorOfPoint
)
public:
void Push(
    VectorOfPoint^ other
)
member Push :
        other : VectorOfPoint -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfPoint
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfPoint.ToArray Method

VectorOfPointToArray Method

Convert the standard vector to an array of Point

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point[] ToArray()
Public Function ToArray As Point()
public:
array<Point^>^ ToArray()
member ToArray : unit -> Point[]

Return Value

Type: Point
An array of Point
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint Fields

The VectorOfPoint type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F Class

Wrapped class of the C++ standard vector of Point3D32F.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfPoint3D32F

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfPoint3D32F : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfPoint3D32F
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfPoint3D32F : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfPoint3D32F =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfPoint3D32F type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfPoint3D32F | Create an empty standard vector of Point3D32F
Public method | VectorOfPoint3D32F(Int32) | Create an standard vector of Point3D32F of the specific size
Public method | VectorOfPoint3D32F(MCvPoint3D32f) | Create an standard vector of Point3D32F with the initial values
Public method | VectorOfPoint3D32F(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MCvPoint3D32f) | Push an array of value into the standard vector
Public method | Push(VectorOfPoint3D32F) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Point3D32F
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfPoint3D32F Constructor

Overload List
 | Name | Description
Public method | VectorOfPoint3D32F | Create an empty standard vector of Point3D32F
Public method | VectorOfPoint3D32F(Int32) | Create an standard vector of Point3D32F of the specific size
Public method | VectorOfPoint3D32F(MCvPoint3D32f) | Create an standard vector of Point3D32F with the initial values
Public method | VectorOfPoint3D32F(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F Constructor

Create an empty standard vector of Point3D32F

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint3D32F()
Public Sub New
public:
VectorOfPoint3D32F()
new : unit -> VectorOfPoint3D32F
See Also

Reference

VectorOfPoint3D32F Class
VectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfPoint3D32F Constructor (Int32)

Create an standard vector of Point3D32F of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint3D32F(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfPoint3D32F(
    int size
)
new :
        size : int -> VectorOfPoint3D32F

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfPoint3D32F Class
VectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfPoint3D32F Constructor (MCvPoint3D32f[])

VectorOfPoint3D32F Constructor (MCvPoint3D32f)

http://www.emgu.com
Create an standard vector of Point3D32F with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint3D32F(
    MCvPoint3D32f[] values
)
Public Sub New (
    values As MCvPoint3D32f()
)
public:
VectorOfPoint3D32F(
    array<MCvPoint3D32f^>^ values
)
new :
        values : MCvPoint3D32f[] -> VectorOfPoint3D32F

Parameters

values
Type: Emgu.CV.StructureMCvPoint3D32f
The initial values
See Also

Reference

VectorOfPoint3D32F Class
VectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfPoint3D32F Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint3D32F(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfPoint3D32F(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfPoint3D32F

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfPoint3D32F Class
VectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfPoint3D32F Properties

The VectorOfPoint3D32F type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.Item Property

VectorOfPoint3D32FItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As MCvPoint3D32f
    Get
public:
property MCvPoint3D32f^ Item[int index] {
    MCvPoint3D32f^ get (int index);
}
member Item : MCvPoint3D32f with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: MCvPoint3D32f
The item in the specific index
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.Size Property

VectorOfPoint3D32FSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.SizeOfItemInBytes Property

VectorOfPoint3D32FSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.StartAddress Property

VectorOfPoint3D32FStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F Methods

The VectorOfPoint3D32F type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(MCvPoint3D32f) | Push an array of value into the standard vector
Public method | Push(VectorOfPoint3D32F) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Point3D32F
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.Clear Method

VectorOfPoint3D32FClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.DisposeObject Method

VectorOfPoint3D32FDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.GetInputArray Method

VectorOfPoint3D32FGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.GetInputOutputArray Method

VectorOfPoint3D32FGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.GetObjectData Method

VectorOfPoint3D32FGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.GetOutputArray Method

VectorOfPoint3D32FGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.Push Method

VectorOfPoint3D32FPush Method

Overload List
 | Name | Description
Public method | Push(MCvPoint3D32f) | Push an array of value into the standard vector
Public method | Push(VectorOfPoint3D32F) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F.Push Method (MCvPoint3D32f[])

VectorOfPoint3D32FPush Method (MCvPoint3D32f)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    MCvPoint3D32f[] value
)
Public Sub Push (
    value As MCvPoint3D32f()
)
public:
void Push(
    array<MCvPoint3D32f^>^ value
)
member Push :
        value : MCvPoint3D32f[] -> unit

Parameters

value
Type: Emgu.CV.StructureMCvPoint3D32f
The value to be pushed to the vector
See Also

Reference

VectorOfPoint3D32F Class
Push Overload
Emgu.CV.Util Namespace


VectorOfPoint3D32F.Push Method (VectorOfPoint3D32F)

VectorOfPoint3D32FPush Method (VectorOfPoint3D32F)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPoint3D32F other
)
Public Sub Push (
    other As VectorOfPoint3D32F
)
public:
void Push(
    VectorOfPoint3D32F^ other
)
member Push :
        other : VectorOfPoint3D32F -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfPoint3D32F
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfPoint3D32F Class
Push Overload
Emgu.CV.Util Namespace


VectorOfPoint3D32F.ToArray Method

VectorOfPoint3D32FToArray Method

Convert the standard vector to an array of Point3D32F

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f[] ToArray()
Public Function ToArray As MCvPoint3D32f()
public:
array<MCvPoint3D32f^>^ ToArray()
member ToArray : unit -> MCvPoint3D32f[]

Return Value

Type: MCvPoint3D32f
An array of Point3D32F
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPoint3D32F Fields

The VectorOfPoint3D32F type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfPointF Class

Wrapped class of the C++ standard vector of PointF.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfPointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfPointF : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfPointF
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfPointF : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfPointF =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfPointF type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfPointF | Create an empty standard vector of PointF
Public method | VectorOfPointF(PointF) | Create an standard vector of PointF with the initial values
Public method | VectorOfPointF(Int32) | Create an standard vector of PointF of the specific size
Public method | VectorOfPointF(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(PointF) | Push an array of value into the standard vector
Public method | Push(VectorOfPointF) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of PointF
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfPointF Constructor

Overload List
 | Name | Description
Public method | VectorOfPointF | Create an empty standard vector of PointF
Public method | VectorOfPointF(PointF) | Create an standard vector of PointF with the initial values
Public method | VectorOfPointF(Int32) | Create an standard vector of PointF of the specific size
Public method | VectorOfPointF(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF Constructor

Create an empty standard vector of PointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPointF()
Public Sub New
public:
VectorOfPointF()
new : unit -> VectorOfPointF
See Also

Reference

VectorOfPointF Class
VectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfPointF Constructor (PointF[])

VectorOfPointF Constructor (PointF)

http://www.emgu.com
Create an standard vector of PointF with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPointF(
    PointF[] values
)
Public Sub New (
    values As PointF()
)
public:
VectorOfPointF(
    array<PointF^>^ values
)
new :
        values : PointF[] -> VectorOfPointF

Parameters

values
Type: System.DrawingPointF
The initial values
See Also

Reference

VectorOfPointF Class
VectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfPointF Constructor (Int32)

Create an standard vector of PointF of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPointF(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfPointF(
    int size
)
new :
        size : int -> VectorOfPointF

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfPointF Class
VectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfPointF Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPointF(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfPointF(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfPointF

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfPointF Class
VectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfPointF Properties

The VectorOfPointF type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.Item Property

VectorOfPointFItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As PointF
    Get
public:
property PointF^ Item[int index] {
    PointF^ get (int index);
}
member Item : PointF with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: PointF
The item in the specific index
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.Size Property

VectorOfPointFSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.SizeOfItemInBytes Property

VectorOfPointFSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.StartAddress Property

VectorOfPointFStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF Methods

The VectorOfPointF type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(PointF) | Push an array of value into the standard vector
Public method | Push(VectorOfPointF) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of PointF
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.Clear Method

VectorOfPointFClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.DisposeObject Method

VectorOfPointFDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.GetInputArray Method

VectorOfPointFGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.GetInputOutputArray Method

VectorOfPointFGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.GetObjectData Method

VectorOfPointFGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.GetOutputArray Method

VectorOfPointFGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.Push Method

VectorOfPointFPush Method

Overload List
 | Name | Description
Public method | Push(PointF) | Push an array of value into the standard vector
Public method | Push(VectorOfPointF) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF.Push Method (PointF[])

VectorOfPointFPush Method (PointF)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    PointF[] value
)
Public Sub Push (
    value As PointF()
)
public:
void Push(
    array<PointF^>^ value
)
member Push :
        value : PointF[] -> unit

Parameters

value
Type: System.DrawingPointF
The value to be pushed to the vector
See Also

Reference

VectorOfPointF Class
Push Overload
Emgu.CV.Util Namespace


VectorOfPointF.Push Method (VectorOfPointF)

VectorOfPointFPush Method (VectorOfPointF)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPointF other
)
Public Sub Push (
    other As VectorOfPointF
)
public:
void Push(
    VectorOfPointF^ other
)
member Push :
        other : VectorOfPointF -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfPointF
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfPointF Class
Push Overload
Emgu.CV.Util Namespace


VectorOfPointF.ToArray Method

VectorOfPointFToArray Method

Convert the standard vector to an array of PointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF[] ToArray()
Public Function ToArray As PointF()
public:
array<PointF^>^ ToArray()
member ToArray : unit -> PointF[]

Return Value

Type: PointF
An array of PointF
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfPointF Fields

The VectorOfPointF type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfRect Class

Wrapped class of the C++ standard vector of Rect.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfRect

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfRect : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfRect
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfRect : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfRect =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfRect type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfRect | Create an empty standard vector of Rect
Public method | VectorOfRect(Rectangle) | Create an standard vector of Rect with the initial values
Public method | VectorOfRect(Int32) | Create an standard vector of Rect of the specific size
Public method | VectorOfRect(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Rectangle) | Push an array of value into the standard vector
Public method | Push(VectorOfRect) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Rect
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfRect Constructor

Overload List
 | Name | Description
Public method | VectorOfRect | Create an empty standard vector of Rect
Public method | VectorOfRect(Rectangle) | Create an standard vector of Rect with the initial values
Public method | VectorOfRect(Int32) | Create an standard vector of Rect of the specific size
Public method | VectorOfRect(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect Constructor

Create an empty standard vector of Rect

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfRect()
Public Sub New
public:
VectorOfRect()
new : unit -> VectorOfRect
See Also

Reference

VectorOfRect Class
VectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfRect Constructor (Rectangle[])

VectorOfRect Constructor (Rectangle)

http://www.emgu.com
Create an standard vector of Rect with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfRect(
    Rectangle[] values
)
Public Sub New (
    values As Rectangle()
)
public:
VectorOfRect(
    array<Rectangle^>^ values
)
new :
        values : Rectangle[] -> VectorOfRect

Parameters

values
Type: System.DrawingRectangle
The initial values
See Also

Reference

VectorOfRect Class
VectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfRect Constructor (Int32)

Create an standard vector of Rect of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfRect(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfRect(
    int size
)
new :
        size : int -> VectorOfRect

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfRect Class
VectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfRect Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfRect(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfRect(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfRect

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfRect Class
VectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfRect Properties

The VectorOfRect type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.Item Property

VectorOfRectItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Rectangle
    Get
public:
property Rectangle^ Item[int index] {
    Rectangle^ get (int index);
}
member Item : Rectangle with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Rectangle
The item in the specific index
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.Size Property

VectorOfRectSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.SizeOfItemInBytes Property

VectorOfRectSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.StartAddress Property

VectorOfRectStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect Methods

The VectorOfRect type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Rectangle) | Push an array of value into the standard vector
Public method | Push(VectorOfRect) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Rect
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.Clear Method

VectorOfRectClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.DisposeObject Method

VectorOfRectDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.GetInputArray Method

VectorOfRectGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.GetInputOutputArray Method

VectorOfRectGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.GetObjectData Method

VectorOfRectGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.GetOutputArray Method

VectorOfRectGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.Push Method

VectorOfRectPush Method

Overload List
 | Name | Description
Public method | Push(Rectangle) | Push an array of value into the standard vector
Public method | Push(VectorOfRect) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect.Push Method (Rectangle[])

VectorOfRectPush Method (Rectangle)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    Rectangle[] value
)
Public Sub Push (
    value As Rectangle()
)
public:
void Push(
    array<Rectangle^>^ value
)
member Push :
        value : Rectangle[] -> unit

Parameters

value
Type: System.DrawingRectangle
The value to be pushed to the vector
See Also

Reference

VectorOfRect Class
Push Overload
Emgu.CV.Util Namespace


VectorOfRect.Push Method (VectorOfRect)

VectorOfRectPush Method (VectorOfRect)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfRect other
)
Public Sub Push (
    other As VectorOfRect
)
public:
void Push(
    VectorOfRect^ other
)
member Push :
        other : VectorOfRect -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfRect
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfRect Class
Push Overload
Emgu.CV.Util Namespace


VectorOfRect.ToArray Method

VectorOfRectToArray Method

Convert the standard vector to an array of Rect

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle[] ToArray()
Public Function ToArray As Rectangle()
public:
array<Rectangle^>^ ToArray()
member ToArray : unit -> Rectangle[]

Return Value

Type: Rectangle
An array of Rect
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfRect Fields

The VectorOfRect type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfRect Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF Class

Wrapped class of the C++ standard vector of Triangle2DF.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfTriangle2DF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfTriangle2DF : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
<SerializableAttribute>
Public Class VectorOfTriangle2DF
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays, ISerializable
[SerializableAttribute]
public ref class VectorOfTriangle2DF : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays, ISerializable
[<SerializableAttribute>]
type VectorOfTriangle2DF =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
        interface ISerializable
    end

The VectorOfTriangle2DF type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfTriangle2DF | Create an empty standard vector of Triangle2DF
Public method | VectorOfTriangle2DF(Int32) | Create an standard vector of Triangle2DF of the specific size
Public method | VectorOfTriangle2DF(Triangle2DF) | Create an standard vector of Triangle2DF with the initial values
Public method | VectorOfTriangle2DF(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Triangle2DF) | Push an array of value into the standard vector
Public method | Push(VectorOfTriangle2DF) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Triangle2DF
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfTriangle2DF Constructor

Overload List
 | Name | Description
Public method | VectorOfTriangle2DF | Create an empty standard vector of Triangle2DF
Public method | VectorOfTriangle2DF(Int32) | Create an standard vector of Triangle2DF of the specific size
Public method | VectorOfTriangle2DF(Triangle2DF) | Create an standard vector of Triangle2DF with the initial values
Public method | VectorOfTriangle2DF(SerializationInfo, StreamingContext) | Constructor used to deserialize runtime serialized object
Top
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF Constructor

Create an empty standard vector of Triangle2DF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTriangle2DF()
Public Sub New
public:
VectorOfTriangle2DF()
new : unit -> VectorOfTriangle2DF
See Also

Reference

VectorOfTriangle2DF Class
VectorOfTriangle2DF Overload
Emgu.CV.Util Namespace


VectorOfTriangle2DF Constructor (Int32)

Create an standard vector of Triangle2DF of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTriangle2DF(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfTriangle2DF(
    int size
)
new :
        size : int -> VectorOfTriangle2DF

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfTriangle2DF Class
VectorOfTriangle2DF Overload
Emgu.CV.Util Namespace


VectorOfTriangle2DF Constructor (Triangle2DF[])

VectorOfTriangle2DF Constructor (Triangle2DF)

http://www.emgu.com
Create an standard vector of Triangle2DF with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTriangle2DF(
    Triangle2DF[] values
)
Public Sub New (
    values As Triangle2DF()
)
public:
VectorOfTriangle2DF(
    array<Triangle2DF^>^ values
)
new :
        values : Triangle2DF[] -> VectorOfTriangle2DF

Parameters

values
Type: Emgu.CV.StructureTriangle2DF
The initial values
See Also

Reference

VectorOfTriangle2DF Class
VectorOfTriangle2DF Overload
Emgu.CV.Util Namespace


VectorOfTriangle2DF Constructor (SerializationInfo, StreamingContext)

Constructor used to deserialize runtime serialized object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfTriangle2DF(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
VectorOfTriangle2DF(
    SerializationInfo^ info,
    StreamingContext^ context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> VectorOfTriangle2DF

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info
context
Type: System.Runtime.SerializationStreamingContext
The streaming context
See Also

Reference

VectorOfTriangle2DF Class
VectorOfTriangle2DF Overload
Emgu.CV.Util Namespace


VectorOfTriangle2DF Properties

The VectorOfTriangle2DF type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Public property | StartAddress | The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.
Top
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.Item Property

VectorOfTriangle2DFItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Triangle2DF this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Triangle2DF
    Get
public:
property Triangle2DF^ Item[int index] {
    Triangle2DF^ get (int index);
}
member Item : Triangle2DF with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Triangle2DF
The item in the specific index
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.Size Property

VectorOfTriangle2DFSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.SizeOfItemInBytes Property

VectorOfTriangle2DFSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.StartAddress Property

VectorOfTriangle2DFStartAddress Property

The pointer to the first element on the vector. In case of an empty vector, IntPtr.Zero will be returned.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StartAddress { get; }
Public ReadOnly Property StartAddress As IntPtr
    Get
public:
property IntPtr StartAddress {
    IntPtr get ();
}
member StartAddress : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF Methods

The VectorOfTriangle2DF type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetObjectData | A function used for runtime serialization of the object
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(Triangle2DF) | Push an array of value into the standard vector
Public method | Push(VectorOfTriangle2DF) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArray | Convert the standard vector to an array of Triangle2DF
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.Clear Method

VectorOfTriangle2DFClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.DisposeObject Method

VectorOfTriangle2DFDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.GetInputArray Method

VectorOfTriangle2DFGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.GetInputOutputArray Method

VectorOfTriangle2DFGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.GetObjectData Method

VectorOfTriangle2DFGetObjectData Method

A function used for runtime serialization of the object

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext^ context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.GetOutputArray Method

VectorOfTriangle2DFGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.Push Method

VectorOfTriangle2DFPush Method

Overload List
 | Name | Description
Public method | Push(Triangle2DF) | Push an array of value into the standard vector
Public method | Push(VectorOfTriangle2DF) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF.Push Method (Triangle2DF[])

VectorOfTriangle2DFPush Method (Triangle2DF)

http://www.emgu.com
Push an array of value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    Triangle2DF[] value
)
Public Sub Push (
    value As Triangle2DF()
)
public:
void Push(
    array<Triangle2DF^>^ value
)
member Push :
        value : Triangle2DF[] -> unit

Parameters

value
Type: Emgu.CV.StructureTriangle2DF
The value to be pushed to the vector
See Also

Reference

VectorOfTriangle2DF Class
Push Overload
Emgu.CV.Util Namespace


VectorOfTriangle2DF.Push Method (VectorOfTriangle2DF)

VectorOfTriangle2DFPush Method (VectorOfTriangle2DF)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfTriangle2DF other
)
Public Sub Push (
    other As VectorOfTriangle2DF
)
public:
void Push(
    VectorOfTriangle2DF^ other
)
member Push :
        other : VectorOfTriangle2DF -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfTriangle2DF
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfTriangle2DF Class
Push Overload
Emgu.CV.Util Namespace


VectorOfTriangle2DF.ToArray Method

VectorOfTriangle2DFToArray Method

Convert the standard vector to an array of Triangle2DF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Triangle2DF[] ToArray()
Public Function ToArray As Triangle2DF()
public:
array<Triangle2DF^>^ ToArray()
member ToArray : unit -> Triangle2DF[]

Return Value

Type: Triangle2DF
An array of Triangle2DF
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfTriangle2DF Fields

The VectorOfTriangle2DF type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfTriangle2DF Class
Emgu.CV.Util Namespace


VectorOfUMat Class

Wrapped class of the C++ standard vector of UMat.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfUMat

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfUMat : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfUMat
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfUMat : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfUMat =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfUMat type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfUMat | Create an empty standard vector of UMat
Public method | VectorOfUMat(Int32) | Create an standard vector of UMat of the specific size
Public method | VectorOfUMat(UMat) | Create an standard vector of UMat with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(UMat) | Push a value into the standard vector
Public method | Push(UMat) | Push multiple values into the standard vector
Public method | Push(VectorOfUMat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfUMat Constructor

Overload List
 | Name | Description
Public method | VectorOfUMat | Create an empty standard vector of UMat
Public method | VectorOfUMat(Int32) | Create an standard vector of UMat of the specific size
Public method | VectorOfUMat(UMat) | Create an standard vector of UMat with the initial values
Top
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat Constructor

Create an empty standard vector of UMat

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfUMat()
Public Sub New
public:
VectorOfUMat()
new : unit -> VectorOfUMat
See Also

Reference

VectorOfUMat Class
VectorOfUMat Overload
Emgu.CV.Util Namespace


VectorOfUMat Constructor (Int32)

Create an standard vector of UMat of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfUMat(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfUMat(
    int size
)
new :
        size : int -> VectorOfUMat

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfUMat Class
VectorOfUMat Overload
Emgu.CV.Util Namespace


VectorOfUMat Constructor (UMat[])

VectorOfUMat Constructor (UMat)

http://www.emgu.com
Create an standard vector of UMat with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfUMat(
    params UMat[] values
)
Public Sub New (
    ParamArray values As UMat()
)
public:
VectorOfUMat(
    ... array<UMat^>^ values
)
new :
        values : UMat[] -> VectorOfUMat

Parameters

values
Type: Emgu.CVUMat
The initial values
See Also

Reference

VectorOfUMat Class
VectorOfUMat Overload
Emgu.CV.Util Namespace


VectorOfUMat Properties

The VectorOfUMat type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.Item Property

VectorOfUMatItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public UMat this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As UMat
    Get
public:
property UMat^ Item[int index] {
    UMat^ get (int index);
}
member Item : UMat with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: UMat
The item in the specific index
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.Size Property

VectorOfUMatSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.SizeOfItemInBytes Property

VectorOfUMatSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat Methods

The VectorOfUMat type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(UMat) | Push a value into the standard vector
Public method | Push(UMat) | Push multiple values into the standard vector
Public method | Push(VectorOfUMat) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.Clear Method

VectorOfUMatClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.DisposeObject Method

VectorOfUMatDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.GetInputArray Method

VectorOfUMatGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.GetInputOutputArray Method

VectorOfUMatGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.GetOutputArray Method

VectorOfUMatGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.Push Method

VectorOfUMatPush Method

Overload List
 | Name | Description
Public method | Push(UMat) | Push a value into the standard vector
Public method | Push(UMat) | Push multiple values into the standard vector
Public method | Push(VectorOfUMat) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfUMat.Push Method (UMat)

VectorOfUMatPush Method (UMat)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    UMat value
)
Public Sub Push (
    value As UMat
)
public:
void Push(
    UMat^ value
)
member Push :
        value : UMat -> unit

Parameters

value
Type: Emgu.CVUMat
The value to be pushed to the vector
See Also

Reference

VectorOfUMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfUMat.Push Method (UMat[])

VectorOfUMatPush Method (UMat)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    UMat[] values
)
Public Sub Push (
    values As UMat()
)
public:
void Push(
    array<UMat^>^ values
)
member Push :
        values : UMat[] -> unit

Parameters

values
Type: Emgu.CVUMat
The values to be pushed to the vector
See Also

Reference

VectorOfUMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfUMat.Push Method (VectorOfUMat)

VectorOfUMatPush Method (VectorOfUMat)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfUMat other
)
Public Sub Push (
    other As VectorOfUMat
)
public:
void Push(
    VectorOfUMat^ other
)
member Push :
        other : VectorOfUMat -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfUMat
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfUMat Class
Push Overload
Emgu.CV.Util Namespace


VectorOfUMat Fields

The VectorOfUMat type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfUMat Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte Class

Wrapped class of the C++ standard vector of VectorOfByte.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfVectorOfByte

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfByte : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfByte
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfByte : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfByte =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfByte type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfByte | Create an empty standard vector of VectorOfByte
Public method | VectorOfVectorOfByte(Byte) | Create the standard vector of VectorOfByte
Public method | VectorOfVectorOfByte(Int32) | Create an standard vector of VectorOfByte of the specific size
Public method | VectorOfVectorOfByte(VectorOfByte) | Create an standard vector of VectorOfByte with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfByte) | Push a value into the standard vector
Public method | Push(VectorOfByte) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfByte) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfVectorOfByte Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfByte | Create an empty standard vector of VectorOfByte
Public method | VectorOfVectorOfByte(Byte) | Create the standard vector of VectorOfByte
Public method | VectorOfVectorOfByte(Int32) | Create an standard vector of VectorOfByte of the specific size
Public method | VectorOfVectorOfByte(VectorOfByte) | Create an standard vector of VectorOfByte with the initial values
Top
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte Constructor

Create an empty standard vector of VectorOfByte

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfByte()
Public Sub New
public:
VectorOfVectorOfByte()
new : unit -> VectorOfVectorOfByte
See Also

Reference

VectorOfVectorOfByte Class
VectorOfVectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfVectorOfByte Constructor (Byte[][])

VectorOfVectorOfByte Constructor (Byte)

http://www.emgu.com
Create the standard vector of VectorOfByte

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfByte(
    byte[][] values
)
Public Sub New (
    values As Byte()()
)
public:
VectorOfVectorOfByte(
    array<array<unsigned char>^>^ values
)
new :
        values : byte[][] -> VectorOfVectorOfByte

Parameters

values
Type: SystemByte

[Missing <param name="values"/> documentation for "M:Emgu.CV.Util.VectorOfVectorOfByte.#ctor(System.Byte[][])"]

See Also

Reference

VectorOfVectorOfByte Class
VectorOfVectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfVectorOfByte Constructor (Int32)

Create an standard vector of VectorOfByte of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfByte(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfByte(
    int size
)
new :
        size : int -> VectorOfVectorOfByte

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfByte Class
VectorOfVectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfVectorOfByte Constructor (VectorOfByte[])

VectorOfVectorOfByte Constructor (VectorOfByte)

http://www.emgu.com
Create an standard vector of VectorOfByte with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfByte(
    params VectorOfByte[] values
)
Public Sub New (
    ParamArray values As VectorOfByte()
)
public:
VectorOfVectorOfByte(
    ... array<VectorOfByte^>^ values
)
new :
        values : VectorOfByte[] -> VectorOfVectorOfByte

Parameters

values
Type: Emgu.CV.UtilVectorOfByte
The initial values
See Also

Reference

VectorOfVectorOfByte Class
VectorOfVectorOfByte Overload
Emgu.CV.Util Namespace


VectorOfVectorOfByte Properties

The VectorOfVectorOfByte type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.Item Property

VectorOfVectorOfByteItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfByte this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfByte
    Get
public:
property VectorOfByte^ Item[int index] {
    VectorOfByte^ get (int index);
}
member Item : VectorOfByte with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfByte
The item in the specific index
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.Size Property

VectorOfVectorOfByteSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.SizeOfItemInBytes Property

VectorOfVectorOfByteSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte Methods

The VectorOfVectorOfByte type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfByte) | Push a value into the standard vector
Public method | Push(VectorOfByte) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfByte) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.Clear Method

VectorOfVectorOfByteClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.DisposeObject Method

VectorOfVectorOfByteDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.GetInputArray Method

VectorOfVectorOfByteGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.GetInputOutputArray Method

VectorOfVectorOfByteGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.GetOutputArray Method

VectorOfVectorOfByteGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.Push Method

VectorOfVectorOfBytePush Method

Overload List
 | Name | Description
Public method | Push(VectorOfByte) | Push a value into the standard vector
Public method | Push(VectorOfByte) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfByte) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte.Push Method (VectorOfByte)

VectorOfVectorOfBytePush Method (VectorOfByte)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfByte value
)
Public Sub Push (
    value As VectorOfByte
)
public:
void Push(
    VectorOfByte^ value
)
member Push :
        value : VectorOfByte -> unit

Parameters

value
Type: Emgu.CV.UtilVectorOfByte
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfByte Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfByte.Push Method (VectorOfByte[])

VectorOfVectorOfBytePush Method (VectorOfByte)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfByte[] values
)
Public Sub Push (
    values As VectorOfByte()
)
public:
void Push(
    array<VectorOfByte^>^ values
)
member Push :
        values : VectorOfByte[] -> unit

Parameters

values
Type: Emgu.CV.UtilVectorOfByte
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfByte Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfByte.Push Method (VectorOfVectorOfByte)

VectorOfVectorOfBytePush Method (VectorOfVectorOfByte)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfByte other
)
Public Sub Push (
    other As VectorOfVectorOfByte
)
public:
void Push(
    VectorOfVectorOfByte^ other
)
member Push :
        other : VectorOfVectorOfByte -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfVectorOfByte
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfByte Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfByte.ToArrayOfArray Method

VectorOfVectorOfByteToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[][] ToArrayOfArray()
Public Function ToArrayOfArray As Byte()()
public:
array<array<unsigned char>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> byte[][]

Return Value

Type: Byte
Arrays of int
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfByte Fields

The VectorOfVectorOfByte type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfByte Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Class

Wrapped class of the C++ standard vector of VectorOfDMatch.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfVectorOfDMatch

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfDMatch : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfDMatch
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfDMatch : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfDMatch =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfDMatch type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfDMatch | Create an empty standard vector of VectorOfDMatch
Public method | VectorOfVectorOfDMatch(Int32) | Create an standard vector of VectorOfDMatch of the specific size
Public method | VectorOfVectorOfDMatch(MDMatch) | Create the standard vector of VectorOfDMatch
Public method | VectorOfVectorOfDMatch(VectorOfDMatch) | Create an standard vector of VectorOfDMatch with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfDMatch) | Push a value into the standard vector
Public method | Push(VectorOfDMatch) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfDMatch) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfDMatch | Create an empty standard vector of VectorOfDMatch
Public method | VectorOfVectorOfDMatch(Int32) | Create an standard vector of VectorOfDMatch of the specific size
Public method | VectorOfVectorOfDMatch(MDMatch) | Create the standard vector of VectorOfDMatch
Public method | VectorOfVectorOfDMatch(VectorOfDMatch) | Create an standard vector of VectorOfDMatch with the initial values
Top
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Constructor

Create an empty standard vector of VectorOfDMatch

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfDMatch()
Public Sub New
public:
VectorOfVectorOfDMatch()
new : unit -> VectorOfVectorOfDMatch
See Also

Reference

VectorOfVectorOfDMatch Class
VectorOfVectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Constructor (Int32)

Create an standard vector of VectorOfDMatch of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfDMatch(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfDMatch(
    int size
)
new :
        size : int -> VectorOfVectorOfDMatch

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfDMatch Class
VectorOfVectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Constructor (MDMatch[][])

VectorOfVectorOfDMatch Constructor (MDMatch)

http://www.emgu.com
Create the standard vector of VectorOfDMatch

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfDMatch(
    MDMatch[][] values
)
Public Sub New (
    values As MDMatch()()
)
public:
VectorOfVectorOfDMatch(
    array<array<MDMatch^>^>^ values
)
new :
        values : MDMatch[][] -> VectorOfVectorOfDMatch

Parameters

values
Type: Emgu.CV.StructureMDMatch

[Missing <param name="values"/> documentation for "M:Emgu.CV.Util.VectorOfVectorOfDMatch.#ctor(Emgu.CV.Structure.MDMatch[][])"]

See Also

Reference

VectorOfVectorOfDMatch Class
VectorOfVectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Constructor (VectorOfDMatch[])

VectorOfVectorOfDMatch Constructor (VectorOfDMatch)

http://www.emgu.com
Create an standard vector of VectorOfDMatch with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfDMatch(
    params VectorOfDMatch[] values
)
Public Sub New (
    ParamArray values As VectorOfDMatch()
)
public:
VectorOfVectorOfDMatch(
    ... array<VectorOfDMatch^>^ values
)
new :
        values : VectorOfDMatch[] -> VectorOfVectorOfDMatch

Parameters

values
Type: Emgu.CV.UtilVectorOfDMatch
The initial values
See Also

Reference

VectorOfVectorOfDMatch Class
VectorOfVectorOfDMatch Overload
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Properties

The VectorOfVectorOfDMatch type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.Item Property

VectorOfVectorOfDMatchItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfDMatch this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfDMatch
    Get
public:
property VectorOfDMatch^ Item[int index] {
    VectorOfDMatch^ get (int index);
}
member Item : VectorOfDMatch with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfDMatch
The item in the specific index
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.Size Property

VectorOfVectorOfDMatchSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.SizeOfItemInBytes Property

VectorOfVectorOfDMatchSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Methods

The VectorOfVectorOfDMatch type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfDMatch) | Push a value into the standard vector
Public method | Push(VectorOfDMatch) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfDMatch) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.Clear Method

VectorOfVectorOfDMatchClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.DisposeObject Method

VectorOfVectorOfDMatchDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.GetInputArray Method

VectorOfVectorOfDMatchGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.GetInputOutputArray Method

VectorOfVectorOfDMatchGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.GetOutputArray Method

VectorOfVectorOfDMatchGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.Push Method

VectorOfVectorOfDMatchPush Method

Overload List
 | Name | Description
Public method | Push(VectorOfDMatch) | Push a value into the standard vector
Public method | Push(VectorOfDMatch) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfDMatch) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.Push Method (VectorOfDMatch)

VectorOfVectorOfDMatchPush Method (VectorOfDMatch)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfDMatch value
)
Public Sub Push (
    value As VectorOfDMatch
)
public:
void Push(
    VectorOfDMatch^ value
)
member Push :
        value : VectorOfDMatch -> unit

Parameters

value
Type: Emgu.CV.UtilVectorOfDMatch
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfDMatch Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.Push Method (VectorOfDMatch[])

VectorOfVectorOfDMatchPush Method (VectorOfDMatch)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfDMatch[] values
)
Public Sub Push (
    values As VectorOfDMatch()
)
public:
void Push(
    array<VectorOfDMatch^>^ values
)
member Push :
        values : VectorOfDMatch[] -> unit

Parameters

values
Type: Emgu.CV.UtilVectorOfDMatch
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfDMatch Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.Push Method (VectorOfVectorOfDMatch)

VectorOfVectorOfDMatchPush Method (VectorOfVectorOfDMatch)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfDMatch other
)
Public Sub Push (
    other As VectorOfVectorOfDMatch
)
public:
void Push(
    VectorOfVectorOfDMatch^ other
)
member Push :
        other : VectorOfVectorOfDMatch -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfVectorOfDMatch
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfDMatch Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch.ToArrayOfArray Method

VectorOfVectorOfDMatchToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MDMatch[][] ToArrayOfArray()
Public Function ToArrayOfArray As MDMatch()()
public:
array<array<MDMatch^>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> MDMatch[][]

Return Value

Type: MDMatch
Arrays of int
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfDMatch Fields

The VectorOfVectorOfDMatch type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfDMatch Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt Class

Wrapped class of the C++ standard vector of VectorOfInt.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfVectorOfInt

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfInt : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfInt
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfInt : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfInt =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfInt type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfInt | Create an empty standard vector of VectorOfInt
Public method | VectorOfVectorOfInt(Int32) | Create an standard vector of VectorOfInt of the specific size
Public method | VectorOfVectorOfInt(Int32) | Create the standard vector of VectorOfInt
Public method | VectorOfVectorOfInt(VectorOfInt) | Create an standard vector of VectorOfInt with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfInt) | Push a value into the standard vector
Public method | Push(VectorOfInt) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfInt) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfVectorOfInt Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfInt | Create an empty standard vector of VectorOfInt
Public method | VectorOfVectorOfInt(Int32) | Create an standard vector of VectorOfInt of the specific size
Public method | VectorOfVectorOfInt(Int32) | Create the standard vector of VectorOfInt
Public method | VectorOfVectorOfInt(VectorOfInt) | Create an standard vector of VectorOfInt with the initial values
Top
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt Constructor

Create an empty standard vector of VectorOfInt

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfInt()
Public Sub New
public:
VectorOfVectorOfInt()
new : unit -> VectorOfVectorOfInt
See Also

Reference

VectorOfVectorOfInt Class
VectorOfVectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfVectorOfInt Constructor (Int32)

Create an standard vector of VectorOfInt of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfInt(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfInt(
    int size
)
new :
        size : int -> VectorOfVectorOfInt

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfInt Class
VectorOfVectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfVectorOfInt Constructor (Int32[][])

VectorOfVectorOfInt Constructor (Int32)

http://www.emgu.com
Create the standard vector of VectorOfInt

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfInt(
    int[][] values
)
Public Sub New (
    values As Integer()()
)
public:
VectorOfVectorOfInt(
    array<array<int>^>^ values
)
new :
        values : int[][] -> VectorOfVectorOfInt

Parameters

values
Type: SystemInt32

[Missing <param name="values"/> documentation for "M:Emgu.CV.Util.VectorOfVectorOfInt.#ctor(System.Int32[][])"]

See Also

Reference

VectorOfVectorOfInt Class
VectorOfVectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfVectorOfInt Constructor (VectorOfInt[])

VectorOfVectorOfInt Constructor (VectorOfInt)

http://www.emgu.com
Create an standard vector of VectorOfInt with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfInt(
    params VectorOfInt[] values
)
Public Sub New (
    ParamArray values As VectorOfInt()
)
public:
VectorOfVectorOfInt(
    ... array<VectorOfInt^>^ values
)
new :
        values : VectorOfInt[] -> VectorOfVectorOfInt

Parameters

values
Type: Emgu.CV.UtilVectorOfInt
The initial values
See Also

Reference

VectorOfVectorOfInt Class
VectorOfVectorOfInt Overload
Emgu.CV.Util Namespace


VectorOfVectorOfInt Properties

The VectorOfVectorOfInt type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.Item Property

VectorOfVectorOfIntItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfInt this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfInt
    Get
public:
property VectorOfInt^ Item[int index] {
    VectorOfInt^ get (int index);
}
member Item : VectorOfInt with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfInt
The item in the specific index
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.Size Property

VectorOfVectorOfIntSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.SizeOfItemInBytes Property

VectorOfVectorOfIntSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt Methods

The VectorOfVectorOfInt type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfInt) | Push a value into the standard vector
Public method | Push(VectorOfInt) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfInt) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.Clear Method

VectorOfVectorOfIntClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.DisposeObject Method

VectorOfVectorOfIntDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.GetInputArray Method

VectorOfVectorOfIntGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.GetInputOutputArray Method

VectorOfVectorOfIntGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.GetOutputArray Method

VectorOfVectorOfIntGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.Push Method

VectorOfVectorOfIntPush Method

Overload List
 | Name | Description
Public method | Push(VectorOfInt) | Push a value into the standard vector
Public method | Push(VectorOfInt) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfInt) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt.Push Method (VectorOfInt)

VectorOfVectorOfIntPush Method (VectorOfInt)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfInt value
)
Public Sub Push (
    value As VectorOfInt
)
public:
void Push(
    VectorOfInt^ value
)
member Push :
        value : VectorOfInt -> unit

Parameters

value
Type: Emgu.CV.UtilVectorOfInt
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfInt Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfInt.Push Method (VectorOfInt[])

VectorOfVectorOfIntPush Method (VectorOfInt)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfInt[] values
)
Public Sub Push (
    values As VectorOfInt()
)
public:
void Push(
    array<VectorOfInt^>^ values
)
member Push :
        values : VectorOfInt[] -> unit

Parameters

values
Type: Emgu.CV.UtilVectorOfInt
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfInt Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfInt.Push Method (VectorOfVectorOfInt)

VectorOfVectorOfIntPush Method (VectorOfVectorOfInt)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfInt other
)
Public Sub Push (
    other As VectorOfVectorOfInt
)
public:
void Push(
    VectorOfVectorOfInt^ other
)
member Push :
        other : VectorOfVectorOfInt -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfVectorOfInt
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfInt Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfInt.ToArrayOfArray Method

VectorOfVectorOfIntToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int[][] ToArrayOfArray()
Public Function ToArrayOfArray As Integer()()
public:
array<array<int>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> int[][]

Return Value

Type: Int32
Arrays of int
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfInt Fields

The VectorOfVectorOfInt type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfInt Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Class

Wrapped class of the C++ standard vector of VectorOfPoint.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfVectorOfPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfPoint : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfPoint
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfPoint : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfPoint =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfPoint type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfPoint | Create an empty standard vector of VectorOfPoint
Public method | VectorOfVectorOfPoint(Point) | Create the standard vector of VectorOfPoint
Public method | VectorOfVectorOfPoint(Int32) | Create an standard vector of VectorOfPoint of the specific size
Public method | VectorOfVectorOfPoint(VectorOfPoint) | Create an standard vector of VectorOfPoint with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfPoint) | Push a value into the standard vector
Public method | Push(VectorOfPoint) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfVectorOfPoint Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfPoint | Create an empty standard vector of VectorOfPoint
Public method | VectorOfVectorOfPoint(Point) | Create the standard vector of VectorOfPoint
Public method | VectorOfVectorOfPoint(Int32) | Create an standard vector of VectorOfPoint of the specific size
Public method | VectorOfVectorOfPoint(VectorOfPoint) | Create an standard vector of VectorOfPoint with the initial values
Top
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Constructor

Create an empty standard vector of VectorOfPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint()
Public Sub New
public:
VectorOfVectorOfPoint()
new : unit -> VectorOfVectorOfPoint
See Also

Reference

VectorOfVectorOfPoint Class
VectorOfVectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Constructor (Point[][])

VectorOfVectorOfPoint Constructor (Point)

http://www.emgu.com
Create the standard vector of VectorOfPoint

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint(
    Point[][] values
)
Public Sub New (
    values As Point()()
)
public:
VectorOfVectorOfPoint(
    array<array<Point^>^>^ values
)
new :
        values : Point[][] -> VectorOfVectorOfPoint

Parameters

values
Type: System.DrawingPoint

[Missing <param name="values"/> documentation for "M:Emgu.CV.Util.VectorOfVectorOfPoint.#ctor(System.Drawing.Point[][])"]

See Also

Reference

VectorOfVectorOfPoint Class
VectorOfVectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Constructor (Int32)

Create an standard vector of VectorOfPoint of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfPoint(
    int size
)
new :
        size : int -> VectorOfVectorOfPoint

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfPoint Class
VectorOfVectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Constructor (VectorOfPoint[])

VectorOfVectorOfPoint Constructor (VectorOfPoint)

http://www.emgu.com
Create an standard vector of VectorOfPoint with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint(
    params VectorOfPoint[] values
)
Public Sub New (
    ParamArray values As VectorOfPoint()
)
public:
VectorOfVectorOfPoint(
    ... array<VectorOfPoint^>^ values
)
new :
        values : VectorOfPoint[] -> VectorOfVectorOfPoint

Parameters

values
Type: Emgu.CV.UtilVectorOfPoint
The initial values
See Also

Reference

VectorOfVectorOfPoint Class
VectorOfVectorOfPoint Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Properties

The VectorOfVectorOfPoint type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.Item Property

VectorOfVectorOfPointItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfPoint
    Get
public:
property VectorOfPoint^ Item[int index] {
    VectorOfPoint^ get (int index);
}
member Item : VectorOfPoint with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfPoint
The item in the specific index
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.Size Property

VectorOfVectorOfPointSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.SizeOfItemInBytes Property

VectorOfVectorOfPointSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Methods

The VectorOfVectorOfPoint type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfPoint) | Push a value into the standard vector
Public method | Push(VectorOfPoint) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPoint) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.Clear Method

VectorOfVectorOfPointClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.DisposeObject Method

VectorOfVectorOfPointDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.GetInputArray Method

VectorOfVectorOfPointGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.GetInputOutputArray Method

VectorOfVectorOfPointGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.GetOutputArray Method

VectorOfVectorOfPointGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.Push Method

VectorOfVectorOfPointPush Method

Overload List
 | Name | Description
Public method | Push(VectorOfPoint) | Push a value into the standard vector
Public method | Push(VectorOfPoint) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPoint) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.Push Method (VectorOfPoint)

VectorOfVectorOfPointPush Method (VectorOfPoint)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPoint value
)
Public Sub Push (
    value As VectorOfPoint
)
public:
void Push(
    VectorOfPoint^ value
)
member Push :
        value : VectorOfPoint -> unit

Parameters

value
Type: Emgu.CV.UtilVectorOfPoint
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.Push Method (VectorOfPoint[])

VectorOfVectorOfPointPush Method (VectorOfPoint)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPoint[] values
)
Public Sub Push (
    values As VectorOfPoint()
)
public:
void Push(
    array<VectorOfPoint^>^ values
)
member Push :
        values : VectorOfPoint[] -> unit

Parameters

values
Type: Emgu.CV.UtilVectorOfPoint
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.Push Method (VectorOfVectorOfPoint)

VectorOfVectorOfPointPush Method (VectorOfVectorOfPoint)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfPoint other
)
Public Sub Push (
    other As VectorOfVectorOfPoint
)
public:
void Push(
    VectorOfVectorOfPoint^ other
)
member Push :
        other : VectorOfVectorOfPoint -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfVectorOfPoint
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfPoint Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint.ToArrayOfArray Method

VectorOfVectorOfPointToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Point[][] ToArrayOfArray()
Public Function ToArrayOfArray As Point()()
public:
array<array<Point^>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> Point[][]

Return Value

Type: Point
Arrays of int
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint Fields

The VectorOfVectorOfPoint type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfPoint Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Class

Wrapped class of the C++ standard vector of VectorOfPoint3D32F.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfVectorOfPoint3D32F

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfPoint3D32F : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfPoint3D32F
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfPoint3D32F : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfPoint3D32F =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfPoint3D32F type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfPoint3D32F | Create an empty standard vector of VectorOfPoint3D32F
Public method | VectorOfVectorOfPoint3D32F(Int32) | Create an standard vector of VectorOfPoint3D32F of the specific size
Public method | VectorOfVectorOfPoint3D32F(MCvPoint3D32f) | Create the standard vector of VectorOfPoint3D32F
Public method | VectorOfVectorOfPoint3D32F(VectorOfPoint3D32F) | Create an standard vector of VectorOfPoint3D32F with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfPoint3D32F) | Push a value into the standard vector
Public method | Push(VectorOfPoint3D32F) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPoint3D32F) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfPoint3D32F | Create an empty standard vector of VectorOfPoint3D32F
Public method | VectorOfVectorOfPoint3D32F(Int32) | Create an standard vector of VectorOfPoint3D32F of the specific size
Public method | VectorOfVectorOfPoint3D32F(MCvPoint3D32f) | Create the standard vector of VectorOfPoint3D32F
Public method | VectorOfVectorOfPoint3D32F(VectorOfPoint3D32F) | Create an standard vector of VectorOfPoint3D32F with the initial values
Top
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Constructor

Create an empty standard vector of VectorOfPoint3D32F

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint3D32F()
Public Sub New
public:
VectorOfVectorOfPoint3D32F()
new : unit -> VectorOfVectorOfPoint3D32F
See Also

Reference

VectorOfVectorOfPoint3D32F Class
VectorOfVectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Constructor (Int32)

Create an standard vector of VectorOfPoint3D32F of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint3D32F(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfPoint3D32F(
    int size
)
new :
        size : int -> VectorOfVectorOfPoint3D32F

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfPoint3D32F Class
VectorOfVectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Constructor (MCvPoint3D32f[][])

VectorOfVectorOfPoint3D32F Constructor (MCvPoint3D32f)

http://www.emgu.com
Create the standard vector of VectorOfPoint3D32F

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint3D32F(
    MCvPoint3D32f[][] values
)
Public Sub New (
    values As MCvPoint3D32f()()
)
public:
VectorOfVectorOfPoint3D32F(
    array<array<MCvPoint3D32f^>^>^ values
)
new :
        values : MCvPoint3D32f[][] -> VectorOfVectorOfPoint3D32F

Parameters

values
Type: Emgu.CV.StructureMCvPoint3D32f

[Missing <param name="values"/> documentation for "M:Emgu.CV.Util.VectorOfVectorOfPoint3D32F.#ctor(Emgu.CV.Structure.MCvPoint3D32f[][])"]

See Also

Reference

VectorOfVectorOfPoint3D32F Class
VectorOfVectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Constructor (VectorOfPoint3D32F[])

VectorOfVectorOfPoint3D32F Constructor (VectorOfPoint3D32F)

http://www.emgu.com
Create an standard vector of VectorOfPoint3D32F with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPoint3D32F(
    params VectorOfPoint3D32F[] values
)
Public Sub New (
    ParamArray values As VectorOfPoint3D32F()
)
public:
VectorOfVectorOfPoint3D32F(
    ... array<VectorOfPoint3D32F^>^ values
)
new :
        values : VectorOfPoint3D32F[] -> VectorOfVectorOfPoint3D32F

Parameters

values
Type: Emgu.CV.UtilVectorOfPoint3D32F
The initial values
See Also

Reference

VectorOfVectorOfPoint3D32F Class
VectorOfVectorOfPoint3D32F Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Properties

The VectorOfVectorOfPoint3D32F type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.Item Property

VectorOfVectorOfPoint3D32FItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPoint3D32F this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfPoint3D32F
    Get
public:
property VectorOfPoint3D32F^ Item[int index] {
    VectorOfPoint3D32F^ get (int index);
}
member Item : VectorOfPoint3D32F with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfPoint3D32F
The item in the specific index
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.Size Property

VectorOfVectorOfPoint3D32FSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.SizeOfItemInBytes Property

VectorOfVectorOfPoint3D32FSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Methods

The VectorOfVectorOfPoint3D32F type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfPoint3D32F) | Push a value into the standard vector
Public method | Push(VectorOfPoint3D32F) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPoint3D32F) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.Clear Method

VectorOfVectorOfPoint3D32FClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.DisposeObject Method

VectorOfVectorOfPoint3D32FDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.GetInputArray Method

VectorOfVectorOfPoint3D32FGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.GetInputOutputArray Method

VectorOfVectorOfPoint3D32FGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.GetOutputArray Method

VectorOfVectorOfPoint3D32FGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.Push Method

VectorOfVectorOfPoint3D32FPush Method

Overload List
 | Name | Description
Public method | Push(VectorOfPoint3D32F) | Push a value into the standard vector
Public method | Push(VectorOfPoint3D32F) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPoint3D32F) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.Push Method (VectorOfPoint3D32F)

VectorOfVectorOfPoint3D32FPush Method (VectorOfPoint3D32F)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPoint3D32F value
)
Public Sub Push (
    value As VectorOfPoint3D32F
)
public:
void Push(
    VectorOfPoint3D32F^ value
)
member Push :
        value : VectorOfPoint3D32F -> unit

Parameters

value
Type: Emgu.CV.UtilVectorOfPoint3D32F
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.Push Method (VectorOfPoint3D32F[])

VectorOfVectorOfPoint3D32FPush Method (VectorOfPoint3D32F)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPoint3D32F[] values
)
Public Sub Push (
    values As VectorOfPoint3D32F()
)
public:
void Push(
    array<VectorOfPoint3D32F^>^ values
)
member Push :
        values : VectorOfPoint3D32F[] -> unit

Parameters

values
Type: Emgu.CV.UtilVectorOfPoint3D32F
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.Push Method (VectorOfVectorOfPoint3D32F)

VectorOfVectorOfPoint3D32FPush Method (VectorOfVectorOfPoint3D32F)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfPoint3D32F other
)
Public Sub Push (
    other As VectorOfVectorOfPoint3D32F
)
public:
void Push(
    VectorOfVectorOfPoint3D32F^ other
)
member Push :
        other : VectorOfVectorOfPoint3D32F -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfVectorOfPoint3D32F
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F.ToArrayOfArray Method

VectorOfVectorOfPoint3D32FToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MCvPoint3D32f[][] ToArrayOfArray()
Public Function ToArrayOfArray As MCvPoint3D32f()()
public:
array<array<MCvPoint3D32f^>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> MCvPoint3D32f[][]

Return Value

Type: MCvPoint3D32f
Arrays of int
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPoint3D32F Fields

The VectorOfVectorOfPoint3D32F type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfPoint3D32F Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Class

Wrapped class of the C++ standard vector of VectorOfPointF.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfVectorOfPointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfPointF : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfPointF
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfPointF : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfPointF =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfPointF type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfPointF | Create an empty standard vector of VectorOfPointF
Public method | VectorOfVectorOfPointF(PointF) | Create the standard vector of VectorOfPointF
Public method | VectorOfVectorOfPointF(Int32) | Create an standard vector of VectorOfPointF of the specific size
Public method | VectorOfVectorOfPointF(VectorOfPointF) | Create an standard vector of VectorOfPointF with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfPointF) | Push a value into the standard vector
Public method | Push(VectorOfPointF) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPointF) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfVectorOfPointF Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfPointF | Create an empty standard vector of VectorOfPointF
Public method | VectorOfVectorOfPointF(PointF) | Create the standard vector of VectorOfPointF
Public method | VectorOfVectorOfPointF(Int32) | Create an standard vector of VectorOfPointF of the specific size
Public method | VectorOfVectorOfPointF(VectorOfPointF) | Create an standard vector of VectorOfPointF with the initial values
Top
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Constructor

Create an empty standard vector of VectorOfPointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPointF()
Public Sub New
public:
VectorOfVectorOfPointF()
new : unit -> VectorOfVectorOfPointF
See Also

Reference

VectorOfVectorOfPointF Class
VectorOfVectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Constructor (PointF[][])

VectorOfVectorOfPointF Constructor (PointF)

http://www.emgu.com
Create the standard vector of VectorOfPointF

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPointF(
    PointF[][] values
)
Public Sub New (
    values As PointF()()
)
public:
VectorOfVectorOfPointF(
    array<array<PointF^>^>^ values
)
new :
        values : PointF[][] -> VectorOfVectorOfPointF

Parameters

values
Type: System.DrawingPointF

[Missing <param name="values"/> documentation for "M:Emgu.CV.Util.VectorOfVectorOfPointF.#ctor(System.Drawing.PointF[][])"]

See Also

Reference

VectorOfVectorOfPointF Class
VectorOfVectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Constructor (Int32)

Create an standard vector of VectorOfPointF of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPointF(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfPointF(
    int size
)
new :
        size : int -> VectorOfVectorOfPointF

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfPointF Class
VectorOfVectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Constructor (VectorOfPointF[])

VectorOfVectorOfPointF Constructor (VectorOfPointF)

http://www.emgu.com
Create an standard vector of VectorOfPointF with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfPointF(
    params VectorOfPointF[] values
)
Public Sub New (
    ParamArray values As VectorOfPointF()
)
public:
VectorOfVectorOfPointF(
    ... array<VectorOfPointF^>^ values
)
new :
        values : VectorOfPointF[] -> VectorOfVectorOfPointF

Parameters

values
Type: Emgu.CV.UtilVectorOfPointF
The initial values
See Also

Reference

VectorOfVectorOfPointF Class
VectorOfVectorOfPointF Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Properties

The VectorOfVectorOfPointF type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.Item Property

VectorOfVectorOfPointFItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfPointF this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfPointF
    Get
public:
property VectorOfPointF^ Item[int index] {
    VectorOfPointF^ get (int index);
}
member Item : VectorOfPointF with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfPointF
The item in the specific index
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.Size Property

VectorOfVectorOfPointFSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.SizeOfItemInBytes Property

VectorOfVectorOfPointFSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Methods

The VectorOfVectorOfPointF type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfPointF) | Push a value into the standard vector
Public method | Push(VectorOfPointF) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPointF) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.Clear Method

VectorOfVectorOfPointFClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.DisposeObject Method

VectorOfVectorOfPointFDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.GetInputArray Method

VectorOfVectorOfPointFGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.GetInputOutputArray Method

VectorOfVectorOfPointFGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.GetOutputArray Method

VectorOfVectorOfPointFGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.Push Method

VectorOfVectorOfPointFPush Method

Overload List
 | Name | Description
Public method | Push(VectorOfPointF) | Push a value into the standard vector
Public method | Push(VectorOfPointF) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfPointF) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.Push Method (VectorOfPointF)

VectorOfVectorOfPointFPush Method (VectorOfPointF)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPointF value
)
Public Sub Push (
    value As VectorOfPointF
)
public:
void Push(
    VectorOfPointF^ value
)
member Push :
        value : VectorOfPointF -> unit

Parameters

value
Type: Emgu.CV.UtilVectorOfPointF
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfPointF Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.Push Method (VectorOfPointF[])

VectorOfVectorOfPointFPush Method (VectorOfPointF)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfPointF[] values
)
Public Sub Push (
    values As VectorOfPointF()
)
public:
void Push(
    array<VectorOfPointF^>^ values
)
member Push :
        values : VectorOfPointF[] -> unit

Parameters

values
Type: Emgu.CV.UtilVectorOfPointF
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfPointF Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.Push Method (VectorOfVectorOfPointF)

VectorOfVectorOfPointFPush Method (VectorOfVectorOfPointF)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfPointF other
)
Public Sub Push (
    other As VectorOfVectorOfPointF
)
public:
void Push(
    VectorOfVectorOfPointF^ other
)
member Push :
        other : VectorOfVectorOfPointF -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfVectorOfPointF
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfPointF Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfPointF.ToArrayOfArray Method

VectorOfVectorOfPointFToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PointF[][] ToArrayOfArray()
Public Function ToArrayOfArray As PointF()()
public:
array<array<PointF^>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> PointF[][]

Return Value

Type: PointF
Arrays of int
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfPointF Fields

The VectorOfVectorOfPointF type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfPointF Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect Class

Wrapped class of the C++ standard vector of VectorOfRect.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilVectorOfVectorOfRect

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VectorOfVectorOfRect : UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
<SerializableAttribute>
Public Class VectorOfVectorOfRect
    Inherits UnmanagedObject
    Implements IInputOutputArray, IInputArray, IDisposable, IOutputArray,
    IInputArrayOfArrays, IOutputArrayOfArrays
[SerializableAttribute]
public ref class VectorOfVectorOfRect : public UnmanagedObject,
    IInputOutputArray, IInputArray, IDisposable, IOutputArray, IInputArrayOfArrays,
    IOutputArrayOfArrays
[<SerializableAttribute>]
type VectorOfVectorOfRect =
    class
        inherit UnmanagedObject
        interface IInputOutputArray
        interface IInputArray
        interface IDisposable
        interface IOutputArray
        interface IInputArrayOfArrays
        interface IOutputArrayOfArrays
    end

The VectorOfVectorOfRect type exposes the following members.

Constructors
 | Name | Description
Public method | VectorOfVectorOfRect | Create an empty standard vector of VectorOfRect
Public method | VectorOfVectorOfRect(Rectangle) | Create the standard vector of VectorOfRect
Public method | VectorOfVectorOfRect(Int32) | Create an standard vector of VectorOfRect of the specific size
Public method | VectorOfVectorOfRect(VectorOfRect) | Create an standard vector of VectorOfRect with the initial values
Top
Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfRect) | Push a value into the standard vector
Public method | Push(VectorOfRect) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfRect) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

Emgu.CV.Util Namespace


VectorOfVectorOfRect Constructor

Overload List
 | Name | Description
Public method | VectorOfVectorOfRect | Create an empty standard vector of VectorOfRect
Public method | VectorOfVectorOfRect(Rectangle) | Create the standard vector of VectorOfRect
Public method | VectorOfVectorOfRect(Int32) | Create an standard vector of VectorOfRect of the specific size
Public method | VectorOfVectorOfRect(VectorOfRect) | Create an standard vector of VectorOfRect with the initial values
Top
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect Constructor

Create an empty standard vector of VectorOfRect

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfRect()
Public Sub New
public:
VectorOfVectorOfRect()
new : unit -> VectorOfVectorOfRect
See Also

Reference

VectorOfVectorOfRect Class
VectorOfVectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfVectorOfRect Constructor (Rectangle[][])

VectorOfVectorOfRect Constructor (Rectangle)

http://www.emgu.com
Create the standard vector of VectorOfRect

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfRect(
    Rectangle[][] values
)
Public Sub New (
    values As Rectangle()()
)
public:
VectorOfVectorOfRect(
    array<array<Rectangle^>^>^ values
)
new :
        values : Rectangle[][] -> VectorOfVectorOfRect

Parameters

values
Type: System.DrawingRectangle

[Missing <param name="values"/> documentation for "M:Emgu.CV.Util.VectorOfVectorOfRect.#ctor(System.Drawing.Rectangle[][])"]

See Also

Reference

VectorOfVectorOfRect Class
VectorOfVectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfVectorOfRect Constructor (Int32)

Create an standard vector of VectorOfRect of the specific size

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfRect(
    int size
)
Public Sub New (
    size As Integer
)
public:
VectorOfVectorOfRect(
    int size
)
new :
        size : int -> VectorOfVectorOfRect

Parameters

size
Type: SystemInt32
The size of the vector
See Also

Reference

VectorOfVectorOfRect Class
VectorOfVectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfVectorOfRect Constructor (VectorOfRect[])

VectorOfVectorOfRect Constructor (VectorOfRect)

http://www.emgu.com
Create an standard vector of VectorOfRect with the initial values

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfVectorOfRect(
    params VectorOfRect[] values
)
Public Sub New (
    ParamArray values As VectorOfRect()
)
public:
VectorOfVectorOfRect(
    ... array<VectorOfRect^>^ values
)
new :
        values : VectorOfRect[] -> VectorOfVectorOfRect

Parameters

values
Type: Emgu.CV.UtilVectorOfRect
The initial values
See Also

Reference

VectorOfVectorOfRect Class
VectorOfVectorOfRect Overload
Emgu.CV.Util Namespace


VectorOfVectorOfRect Properties

The VectorOfVectorOfRect type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the item in the specific index
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Size | Get the size of the vector
 | SizeOfItemInBytes | The size of the item in this Vector, counted as size in bytes.
Top
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.Item Property

VectorOfVectorOfRectItem Property

Get the item in the specific index

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VectorOfRect this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As VectorOfRect
    Get
public:
property VectorOfRect^ Item[int index] {
    VectorOfRect^ get (int index);
}
member Item : VectorOfRect with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: VectorOfRect
The item in the specific index
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.Size Property

VectorOfVectorOfRectSize Property

Get the size of the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.SizeOfItemInBytes Property

VectorOfVectorOfRectSizeOfItemInBytes Property

The size of the item in this Vector, counted as size in bytes.

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOfItemInBytes { get; }
Public Shared ReadOnly Property SizeOfItemInBytes As Integer
    Get
public:
static property int SizeOfItemInBytes {
    int get ();
}
static member SizeOfItemInBytes : int with get

Property Value

Type: Int32
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect Methods

The VectorOfVectorOfRect type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the vector
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the standard vector (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInputArray | Get the pointer to cv::_InputArray
Public method | GetInputOutputArray | Get the pointer to cv::_InputOutputArray
Public method | GetOutputArray | Get the pointer to cv::_OutputArray
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push(VectorOfRect) | Push a value into the standard vector
Public method | Push(VectorOfRect) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfRect) | Push multiple values from the other vector into this vector
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToArrayOfArray | Convert the standard vector to arrays of int
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachDuplicateChannel(ActionIInputArray, Int32) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | ForEachDuplicateChannelTReturn(FuncIInputArray, Int32, TReturn) | Overloaded. Apply converter and compute result for each channel of the image, for single channel image, apply converter directly, for multiple channel image, make a copy of each channel to a temperary image and apply the convertor (Defined by IInputArrayExtensions.)
Public Extension Method | IsUmat | Determines whether the specified input array is umat. (Defined by IInputArrayExtensions.)
Top
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.Clear Method

VectorOfVectorOfRectClear Method

Clear the vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.DisposeObject Method

VectorOfVectorOfRectDisposeObject Method

Release the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.GetInputArray Method

VectorOfVectorOfRectGetInputArray Method

Get the pointer to cv::_InputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputArray GetInputArray()
Public Function GetInputArray As InputArray
public:
virtual InputArray^ GetInputArray() sealed
abstract GetInputArray : unit -> InputArray
override GetInputArray : unit -> InputArray

Return Value

Type: InputArray
The input array

Implements

IInputArrayGetInputArray
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.GetInputOutputArray Method

VectorOfVectorOfRectGetInputOutputArray Method

Get the pointer to cv::_InputOutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public InputOutputArray GetInputOutputArray()
Public Function GetInputOutputArray As InputOutputArray
public:
virtual InputOutputArray^ GetInputOutputArray() sealed
abstract GetInputOutputArray : unit -> InputOutputArray
override GetInputOutputArray : unit -> InputOutputArray

Return Value

Type: InputOutputArray
The input output array

Implements

IInputOutputArrayGetInputOutputArray
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.GetOutputArray Method

VectorOfVectorOfRectGetOutputArray Method

Get the pointer to cv::_OutputArray

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OutputArray GetOutputArray()
Public Function GetOutputArray As OutputArray
public:
virtual OutputArray^ GetOutputArray() sealed
abstract GetOutputArray : unit -> OutputArray
override GetOutputArray : unit -> OutputArray

Return Value

Type: OutputArray
The output array

Implements

IOutputArrayGetOutputArray
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.Push Method

VectorOfVectorOfRectPush Method

Overload List
 | Name | Description
Public method | Push(VectorOfRect) | Push a value into the standard vector
Public method | Push(VectorOfRect) | Push multiple values into the standard vector
Public method | Push(VectorOfVectorOfRect) | Push multiple values from the other vector into this vector
Top
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect.Push Method (VectorOfRect)

VectorOfVectorOfRectPush Method (VectorOfRect)

http://www.emgu.com
Push a value into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfRect value
)
Public Sub Push (
    value As VectorOfRect
)
public:
void Push(
    VectorOfRect^ value
)
member Push :
        value : VectorOfRect -> unit

Parameters

value
Type: Emgu.CV.UtilVectorOfRect
The value to be pushed to the vector
See Also

Reference

VectorOfVectorOfRect Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfRect.Push Method (VectorOfRect[])

VectorOfVectorOfRectPush Method (VectorOfRect)

http://www.emgu.com
Push multiple values into the standard vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfRect[] values
)
Public Sub Push (
    values As VectorOfRect()
)
public:
void Push(
    array<VectorOfRect^>^ values
)
member Push :
        values : VectorOfRect[] -> unit

Parameters

values
Type: Emgu.CV.UtilVectorOfRect
The values to be pushed to the vector
See Also

Reference

VectorOfVectorOfRect Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfRect.Push Method (VectorOfVectorOfRect)

VectorOfVectorOfRectPush Method (VectorOfVectorOfRect)

http://www.emgu.com
Push multiple values from the other vector into this vector

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Push(
    VectorOfVectorOfRect other
)
Public Sub Push (
    other As VectorOfVectorOfRect
)
public:
void Push(
    VectorOfVectorOfRect^ other
)
member Push :
        other : VectorOfVectorOfRect -> unit

Parameters

other
Type: Emgu.CV.UtilVectorOfVectorOfRect
The other vector, from which the values will be pushed to the current vector
See Also

Reference

VectorOfVectorOfRect Class
Push Overload
Emgu.CV.Util Namespace


VectorOfVectorOfRect.ToArrayOfArray Method

VectorOfVectorOfRectToArrayOfArray Method

Convert the standard vector to arrays of int

Namespace: Emgu.CV.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle[][] ToArrayOfArray()
Public Function ToArrayOfArray As Rectangle()()
public:
array<array<Rectangle^>^>^ ToArrayOfArray()
member ToArrayOfArray : unit -> Rectangle[][]

Return Value

Type: Rectangle
Arrays of int
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


VectorOfVectorOfRect Fields

The VectorOfVectorOfRect type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

VectorOfVectorOfRect Class
Emgu.CV.Util Namespace


Emgu.CV.VideoStab Namespace

The video stabilization module contains a set of functions and classes that can be used to solve the problem of video stabilization.
Classes
 | Class | Description
Public class | CaptureFrameSource | Use the Capture class as a FrameSource
Public class | FrameSource | A FrameSource that can be used by the Video Stabilizer
Public class | GaussianMotionFilter | Gaussian motion filter
Public class | OnePassStabilizer | A one pass video stabilizer
Public class | TwoPassStabilizer | A two pass video stabilizer


CaptureFrameSource Class

Use the Capture class as a FrameSource
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.VideoStabFrameSource
Emgu.CV.VideoStabCaptureFrameSource

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class CaptureFrameSource : FrameSource
Public Class CaptureFrameSource
    Inherits FrameSource
public ref class CaptureFrameSource : public FrameSource
type CaptureFrameSource =
    class
        inherit FrameSource
    end

The CaptureFrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | CaptureFrameSource | Create a Capture frame source
Top
Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type (Inherited from FrameSource.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this CaptureFrameSource (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource (Inherited from FrameSource.)
Top
See Also

Reference

Emgu.CV.VideoStab Namespace


CaptureFrameSource Constructor

Create a Capture frame source

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public CaptureFrameSource(
    VideoCapture capture
)
Public Sub New (
    capture As VideoCapture
)
public:
CaptureFrameSource(
    VideoCapture^ capture
)
new :
        capture : VideoCapture -> CaptureFrameSource

Parameters

capture
Type: Emgu.CVVideoCapture
The capture object that will be converted to a FrameSource
See Also

Reference

CaptureFrameSource Class
Emgu.CV.VideoStab Namespace


CaptureFrameSource Properties

The CaptureFrameSource type exposes the following members.

Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type (Inherited from FrameSource.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

CaptureFrameSource Class
Emgu.CV.VideoStab Namespace


CaptureFrameSource Methods

The CaptureFrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this CaptureFrameSource (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CaptureFrameSource Class
Emgu.CV.VideoStab Namespace


CaptureFrameSource.DisposeObject Method

CaptureFrameSourceDisposeObject Method

Release the unmanaged memory associated with this CaptureFrameSource

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

CaptureFrameSource Class
Emgu.CV.VideoStab Namespace


CaptureFrameSource Fields

The CaptureFrameSource type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource (Inherited from FrameSource.)
Top
See Also

Reference

CaptureFrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource Class

A FrameSource that can be used by the Video Stabilizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.VideoStabFrameSource
Emgu.CV.VideoStabCaptureFrameSource
Emgu.CV.VideoStabOnePassStabilizer
Emgu.CV.VideoStabTwoPassStabilizer

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class FrameSource : UnmanagedObject
Public MustInherit Class FrameSource
    Inherits UnmanagedObject
public ref class FrameSource abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type FrameSource =
    class
        inherit UnmanagedObject
    end

The FrameSource type exposes the following members.

Constructors
 | Name | Description
Protected method | FrameSource | Initializes a new instance of the FrameSource class
Top
Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FrameSource (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource
Top
See Also

Reference

Emgu.CV.VideoStab Namespace


FrameSource Constructor

Initializes a new instance of the FrameSource class

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected FrameSource()
Protected Sub New
protected:
FrameSource()
new : unit -> FrameSource
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource Properties

The FrameSource type exposes the following members.

Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource.CaptureSource Property

FrameSourceCaptureSource Property

Get or Set the capture type

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VideoCaptureCaptureModuleType CaptureSource { get; set; }
Public Property CaptureSource As VideoCaptureCaptureModuleType
    Get
    Set
public:
property VideoCaptureCaptureModuleType^ CaptureSource {
    VideoCaptureCaptureModuleType^ get ();
    void set (VideoCaptureCaptureModuleType^ value);
}
member CaptureSource : VideoCaptureCaptureModuleType with get, set

Property Value

Type: VideoCaptureCaptureModuleType
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource Methods

The FrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this FrameSource (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource.DisposeObject Method

FrameSourceDisposeObject Method

Release the unmanaged memory associated with this FrameSource

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource.NextFrame Method

FrameSourceNextFrame Method

Retrieve the next frame from the FrameSoure

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Mat NextFrame()
Public Function NextFrame As Mat
public:
Mat^ NextFrame()
member NextFrame : unit -> Mat

Return Value

Type: Mat
The next frame
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource Fields

The FrameSource type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource
Top
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


FrameSource.FrameSourcePtr Field

FrameSourceFrameSourcePtr Field

The unmanaged pointer the the frameSource

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr FrameSourcePtr
Public FrameSourcePtr As IntPtr
public:
IntPtr FrameSourcePtr
val mutable FrameSourcePtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

FrameSource Class
Emgu.CV.VideoStab Namespace


GaussianMotionFilter Class

Gaussian motion filter
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.VideoStabGaussianMotionFilter

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GaussianMotionFilter : UnmanagedObject
Public Class GaussianMotionFilter
    Inherits UnmanagedObject
public ref class GaussianMotionFilter : public UnmanagedObject
type GaussianMotionFilter =
    class
        inherit UnmanagedObject
    end

The GaussianMotionFilter type exposes the following members.

Constructors
 | Name | Description
Public method | GaussianMotionFilter | Create a Gaussian motion filter
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.VideoStab Namespace


GaussianMotionFilter Constructor

Create a Gaussian motion filter

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GaussianMotionFilter(
    int radius,
    float stdev
)
Public Sub New (
    radius As Integer,
    stdev As Single
)
public:
GaussianMotionFilter(
    int radius,
    float stdev
)
new :
        radius : int *
        stdev : float32 -> GaussianMotionFilter

Parameters

radius
Type: SystemInt32
The radius, use 15 for default.
stdev
Type: SystemSingle
The standard deviation, use -1.0f for default
See Also

Reference

GaussianMotionFilter Class
Emgu.CV.VideoStab Namespace


GaussianMotionFilter Properties

The GaussianMotionFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GaussianMotionFilter Class
Emgu.CV.VideoStab Namespace


GaussianMotionFilter Methods

The GaussianMotionFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GaussianMotionFilter Class
Emgu.CV.VideoStab Namespace


GaussianMotionFilter.DisposeObject Method

GaussianMotionFilterDisposeObject Method

Release all the unmanaged memory associated with this object

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

GaussianMotionFilter Class
Emgu.CV.VideoStab Namespace


GaussianMotionFilter Fields

The GaussianMotionFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GaussianMotionFilter Class
Emgu.CV.VideoStab Namespace


OnePassStabilizer Class

A one pass video stabilizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.VideoStabFrameSource
Emgu.CV.VideoStabOnePassStabilizer

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class OnePassStabilizer : FrameSource
Public Class OnePassStabilizer
    Inherits FrameSource
public ref class OnePassStabilizer : public FrameSource
type OnePassStabilizer =
    class
        inherit FrameSource
    end

The OnePassStabilizer type exposes the following members.

Constructors
 | Name | Description
Public method | OnePassStabilizer | Create a one pass stabilizer
Top
Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type (Inherited from FrameSource.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with the stabilizer (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetMotionFilter | Set the Motion Filter
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource (Inherited from FrameSource.)
Top
See Also

Reference

Emgu.CV.VideoStab Namespace


OnePassStabilizer Constructor

Create a one pass stabilizer

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public OnePassStabilizer(
    FrameSource baseFrameSource
)
Public Sub New (
    baseFrameSource As FrameSource
)
public:
OnePassStabilizer(
    FrameSource^ baseFrameSource
)
new :
        baseFrameSource : FrameSource -> OnePassStabilizer

Parameters

baseFrameSource
Type: Emgu.CV.VideoStabFrameSource
The capture object to be stabalized
See Also

Reference

OnePassStabilizer Class
Emgu.CV.VideoStab Namespace


OnePassStabilizer Properties

The OnePassStabilizer type exposes the following members.

Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type (Inherited from FrameSource.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

OnePassStabilizer Class
Emgu.CV.VideoStab Namespace


OnePassStabilizer Methods

The OnePassStabilizer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with the stabilizer (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetMotionFilter | Set the Motion Filter
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OnePassStabilizer Class
Emgu.CV.VideoStab Namespace


OnePassStabilizer.DisposeObject Method

OnePassStabilizerDisposeObject Method

Release the unmanaged memory associated with the stabilizer

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

OnePassStabilizer Class
Emgu.CV.VideoStab Namespace


OnePassStabilizer.SetMotionFilter Method

OnePassStabilizerSetMotionFilter Method

Set the Motion Filter

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetMotionFilter(
    GaussianMotionFilter motionFilter
)
Public Sub SetMotionFilter (
    motionFilter As GaussianMotionFilter
)
public:
void SetMotionFilter(
    GaussianMotionFilter^ motionFilter
)
member SetMotionFilter :
        motionFilter : GaussianMotionFilter -> unit

Parameters

motionFilter
Type: Emgu.CV.VideoStabGaussianMotionFilter
The motion filter
See Also

Reference

OnePassStabilizer Class
Emgu.CV.VideoStab Namespace


OnePassStabilizer Fields

The OnePassStabilizer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource (Inherited from FrameSource.)
Top
See Also

Reference

OnePassStabilizer Class
Emgu.CV.VideoStab Namespace


TwoPassStabilizer Class

A two pass video stabilizer
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.VideoStabFrameSource
Emgu.CV.VideoStabTwoPassStabilizer

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TwoPassStabilizer : FrameSource
Public Class TwoPassStabilizer
    Inherits FrameSource
public ref class TwoPassStabilizer : public FrameSource
type TwoPassStabilizer =
    class
        inherit FrameSource
    end

The TwoPassStabilizer type exposes the following members.

Constructors
 | Name | Description
Public method | TwoPassStabilizer | Create a two pass video stabilizer.
Top
Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type (Inherited from FrameSource.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource (Inherited from FrameSource.)
Top
See Also

Reference

Emgu.CV.VideoStab Namespace


TwoPassStabilizer Constructor

Create a two pass video stabilizer.

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TwoPassStabilizer(
    FrameSource baseFrameSource
)
Public Sub New (
    baseFrameSource As FrameSource
)
public:
TwoPassStabilizer(
    FrameSource^ baseFrameSource
)
new :
        baseFrameSource : FrameSource -> TwoPassStabilizer

Parameters

baseFrameSource
Type: Emgu.CV.VideoStabFrameSource
The capture object to be stabilized. Should not be a camera stream.
See Also

Reference

TwoPassStabilizer Class
Emgu.CV.VideoStab Namespace


TwoPassStabilizer Properties

The TwoPassStabilizer type exposes the following members.

Properties
 | Name | Description
Public property | CaptureSource | Get or Set the capture type (Inherited from FrameSource.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

TwoPassStabilizer Class
Emgu.CV.VideoStab Namespace


TwoPassStabilizer Methods

The TwoPassStabilizer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory (Overrides FrameSourceDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextFrame | Retrieve the next frame from the FrameSoure (Inherited from FrameSource.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwoPassStabilizer Class
Emgu.CV.VideoStab Namespace


TwoPassStabilizer.DisposeObject Method

TwoPassStabilizerDisposeObject Method

Release the unmanaged memory

Namespace: Emgu.CV.VideoStab
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TwoPassStabilizer Class
Emgu.CV.VideoStab Namespace


TwoPassStabilizer Fields

The TwoPassStabilizer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public field | FrameSourcePtr | The unmanaged pointer the the frameSource (Inherited from FrameSource.)
Top
See Also

Reference

TwoPassStabilizer Class
Emgu.CV.VideoStab Namespace


Emgu.CV.XFeatures2D Namespace

Extra 2D Features Framework
Classes
 | Class | Description
Public class | BoostDesc | Class implementing BoostDesc (Learning Image Descriptors with Boosting).
Public class | BoostDescDescriptorType | The type of descriptor
Public class | BriefDescriptorExtractor | BRIEF Descriptor
Public class | DAISY | Daisy descriptor.
Public class | DAISYNormalizationType | Normalization type
Public class | Freak | The FREAK (Fast Retina Keypoint) keypoint descriptor: Alahi, R. Ortiz, and P. Vandergheynst. FREAK: Fast Retina Keypoint. In IEEE Conference on Computer Vision and Pattern Recognition, 2012. CVPR 2012 Open Source Award Winner. The algorithm propose a novel keypoint descriptor inspired by the human visual system and more precisely the retina, coined Fast Retina Key- point (FREAK). A cascade of binary strings is computed by efficiently comparing image intensities over a retinal sampling pattern. FREAKs are in general faster to compute with lower memory load and also more robust than SIFT, SURF or BRISK. They are competitive alternatives to existing keypoints in particular for embedded applications.
Public class | HarrisLaplaceFeatureDetector | Class implementing the Harris-Laplace feature detector
Public class | LATCH | latch Class for computing the LATCH descriptor. If you find this code useful, please add a reference to the following paper in your work: Gil Levi and Tal Hassner, "LATCH: Learned Arrangements of Three Patch Codes", arXiv preprint arXiv:1501.03719, 15 Jan. 2015 LATCH is a binary descriptor based on learned comparisons of triplets of image patches.
Public class | LUCID | The locally uniform comparison image descriptor: An image descriptor that can be computed very fast, while being about as robust as, for example, SURF or BRIEF.
Public class | MSDDetector | Class implementing the MSD (Maximal Self-Dissimilarity) keypoint detector, described in "Federico Tombari and Luigi Di Stefano. Interest points via maximal self-dissimilarities. In Asian Conference on Computer Vision - ACCV 2014, 2014".
Public class | PCTSignatures | Class implementing PCT (position-color-texture) signature extraction as described in: Martin Krulis, Jakub Lokoc, and Tomas Skopal. Efficient extraction of clustering-based feature signatures using GPU architectures. Multimedia Tools Appl., 75(13):8071–8103, 2016. The algorithm is divided to a feature sampler and a clusterizer. Feature sampler produces samples at given set of coordinates. Clusterizer then produces clusters of these samples using k-means algorithm. Resulting set of clusters is the signature of the input image. A signature is an array of SIGNATURE_DIMENSION-dimensional points.Used dimensions are: weight, x, y position; lab color, contrast, entropy.
Public class | PCTSignaturesPointDistributionType | Point distributions supported by random point generator.
Public class | PCTSignaturesSQFD | Class implementing Signature Quadratic Form Distance (SQFD).
Public class | PCTSignaturesSQFDDistanceFunction | Lp distance function selector.
Public class | PCTSignaturesSQFDSimilarityFunction | Similarity function selector.
Public class | StarDetector | StarDetector
Public class | VGG | Class implementing VGG (Oxford Visual Geometry Group) descriptor trained end to end using "Descriptor Learning Using Convex Optimisation" (DLCO) aparatus
Public class | VGGDescriptorType | The VGG descriptor type
Public class | XFeatures2DInvoke | This class wraps the functional calls to the OpenCV XFeatures2D modules


BoostDesc Class

Class implementing BoostDesc (Learning Image Descriptors with Boosting).
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DBoostDesc

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BoostDesc : Feature2D
Public Class BoostDesc
    Inherits Feature2D
public ref class BoostDesc : public Feature2D
type BoostDesc =
    class
        inherit Feature2D
    end

The BoostDesc type exposes the following members.

Constructors
 | Name | Description
Public method | BoostDesc | Create an instance of Boost Descriptor
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Remarks
See: V. Lepetit T. Trzcinski, M. Christoudias and P. Fua. Boosting Binary Keypoint Descriptors. In Computer Vision and Pattern Recognition, 2013. M. Christoudias T. Trzcinski and V. Lepetit. Learning Image Descriptors with Boosting. submitted to IEEE Transactions on Pattern Analysis and Machine Intelligence (PAMI), 2013.
See Also

Reference

Emgu.CV.XFeatures2D Namespace


BoostDesc Constructor

Create an instance of Boost Descriptor

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BoostDesc(
    BoostDescDescriptorType desc = 302,
    bool useScaleOrientation = true,
    float scalefactor = 6.25f
)
Public Sub New (
    Optional desc As BoostDescDescriptorType = 302,
    Optional useScaleOrientation As Boolean = true,
    Optional scalefactor As Single = 6.25F
)
public:
BoostDesc(
    BoostDescDescriptorType^ desc = 302,
    bool useScaleOrientation = true,
    float scalefactor = 6.25f
)
new :
        ?desc : BoostDescDescriptorType *
        ?useScaleOrientation : bool *
        ?scalefactor : float32
(* Defaults:
        let _desc = defaultArg desc 302
        let _useScaleOrientation = defaultArg useScaleOrientation true
        let _scalefactor = defaultArg scalefactor 6.25f
*)
-> BoostDesc

Parameters

desc (Optional)
Type: Emgu.CV.XFeatures2DBoostDescDescriptorType
type of descriptor to use
useScaleOrientation (Optional)
Type: SystemBoolean
sample patterns using keypoints orientation
scalefactor (Optional)
Type: SystemSingle
adjust the sampling window of detected keypoints 6.25f is default and fits for KAZE, SURF detected keypoints window ratio 6.75f should be the scale for SIFT detected keypoints window ratio 5.00f should be the scale for AKAZE, MSD, AGAST, FAST, BRISK keypoints window ratio 0.75f should be the scale for ORB keypoints ratio 1.50f was the default in original implementation
See Also

Reference

BoostDesc Class
Emgu.CV.XFeatures2D Namespace


BoostDesc Properties

The BoostDesc type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BoostDesc Class
Emgu.CV.XFeatures2D Namespace


BoostDesc Methods

The BoostDesc type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BoostDesc Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DisposeObject Method

BoostDescDisposeObject Method

Release all the unmanaged resource associated with BRIEF

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BoostDesc Class
Emgu.CV.XFeatures2D Namespace


BoostDesc Fields

The BoostDesc type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BoostDesc Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType Class

BoostDescDescriptorType Class

The type of descriptor
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XFeatures2DBoostDescDescriptorType

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DescriptorType : Enum
Public NotInheritable Class DescriptorType
    Inherits Enum
public ref class DescriptorType sealed : public Enum
[<SealedAttribute>]
type DescriptorType =
    class
        inherit Enum
    end

The BoostDescDescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Bgm | BGM is the base descriptor where each binary dimension is computed as the output of a single weak learner.
 | BgmBilinear | BGM_BILINEAR refers to same BGM but use different type of gradient binning. In the BGM_BILINEAR that use ASSIGN_BILINEAR binning type the gradient is assigned to the two neighbouring bins.
 | BgmHard | BGM_HARD refers to same BGM but use different type of gradient binning. In the BGM_HARD that use ASSIGN_HARD binning type the gradient is assigned to the nearest orientation bin.
 | Binboost128 | BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.
 | Binboost256 | BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.
 | Binboost64 | BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.
 | Lbgm | LBGM (alias FP-Boost) is the floating point extension where each dimension is computed as a linear combination of the weak learner responses.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


DescriptorType Methods

The BoostDescDescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


DescriptorType Fields

The BoostDescDescriptorType type exposes the following members.

Fields
 | Name | Description
 | Bgm | BGM is the base descriptor where each binary dimension is computed as the output of a single weak learner.
 | BgmBilinear | BGM_BILINEAR refers to same BGM but use different type of gradient binning. In the BGM_BILINEAR that use ASSIGN_BILINEAR binning type the gradient is assigned to the two neighbouring bins.
 | BgmHard | BGM_HARD refers to same BGM but use different type of gradient binning. In the BGM_HARD that use ASSIGN_HARD binning type the gradient is assigned to the nearest orientation bin.
 | Binboost128 | BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.
 | Binboost256 | BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.
 | Binboost64 | BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.
 | Lbgm | LBGM (alias FP-Boost) is the floating point extension where each dimension is computed as a linear combination of the weak learner responses.
Public field | value__ |
Top
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.Bgm Field

BoostDescDescriptorTypeBgm Field

BGM is the base descriptor where each binary dimension is computed as the output of a single weak learner.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostDescDescriptorType Bgm = 100
Public Const Bgm As BoostDescDescriptorType = 100
public:
literal BoostDescDescriptorType^ Bgm = 100
static val mutable Bgm: BoostDescDescriptorType

Field Value

Type: BoostDescDescriptorType
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.BgmBilinear Field

BoostDescDescriptorTypeBgmBilinear Field

BGM_BILINEAR refers to same BGM but use different type of gradient binning. In the BGM_BILINEAR that use ASSIGN_BILINEAR binning type the gradient is assigned to the two neighbouring bins.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostDescDescriptorType BgmBilinear = 102
Public Const BgmBilinear As BoostDescDescriptorType = 102
public:
literal BoostDescDescriptorType^ BgmBilinear = 102
static val mutable BgmBilinear: BoostDescDescriptorType

Field Value

Type: BoostDescDescriptorType
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.BgmHard Field

BoostDescDescriptorTypeBgmHard Field

BGM_HARD refers to same BGM but use different type of gradient binning. In the BGM_HARD that use ASSIGN_HARD binning type the gradient is assigned to the nearest orientation bin.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostDescDescriptorType BgmHard = 101
Public Const BgmHard As BoostDescDescriptorType = 101
public:
literal BoostDescDescriptorType^ BgmHard = 101
static val mutable BgmHard: BoostDescDescriptorType

Field Value

Type: BoostDescDescriptorType
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.Binboost128 Field

BoostDescDescriptorTypeBinboost128 Field

BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostDescDescriptorType Binboost128 = 301
Public Const Binboost128 As BoostDescDescriptorType = 301
public:
literal BoostDescDescriptorType^ Binboost128 = 301
static val mutable Binboost128: BoostDescDescriptorType

Field Value

Type: BoostDescDescriptorType
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.Binboost256 Field

BoostDescDescriptorTypeBinboost256 Field

BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostDescDescriptorType Binboost256 = 302
Public Const Binboost256 As BoostDescDescriptorType = 302
public:
literal BoostDescDescriptorType^ Binboost256 = 302
static val mutable Binboost256: BoostDescDescriptorType

Field Value

Type: BoostDescDescriptorType
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.Binboost64 Field

BoostDescDescriptorTypeBinboost64 Field

BINBOOST and subvariants are the binary extensions of LBGM where each bit is computed as a thresholded linear combination of a set of weak learners.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostDescDescriptorType Binboost64 = 300
Public Const Binboost64 As BoostDescDescriptorType = 300
public:
literal BoostDescDescriptorType^ Binboost64 = 300
static val mutable Binboost64: BoostDescDescriptorType

Field Value

Type: BoostDescDescriptorType
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.Lbgm Field

BoostDescDescriptorTypeLbgm Field

LBGM (alias FP-Boost) is the floating point extension where each dimension is computed as a linear combination of the weak learner responses.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const BoostDescDescriptorType Lbgm = 200
Public Const Lbgm As BoostDescDescriptorType = 200
public:
literal BoostDescDescriptorType^ Lbgm = 200
static val mutable Lbgm: BoostDescDescriptorType

Field Value

Type: BoostDescDescriptorType
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BoostDesc.DescriptorType.value__ Field

BoostDescDescriptorTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XFeatures2D.BoostDesc.DescriptorType.value__"]

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

BoostDescDescriptorType Class
Emgu.CV.XFeatures2D Namespace


BriefDescriptorExtractor Class

BRIEF Descriptor
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DBriefDescriptorExtractor

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class BriefDescriptorExtractor : Feature2D
Public Class BriefDescriptorExtractor
    Inherits Feature2D
public ref class BriefDescriptorExtractor : public Feature2D
type BriefDescriptorExtractor =
    class
        inherit Feature2D
    end

The BriefDescriptorExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | BriefDescriptorExtractor | Create a BRIEF descriptor extractor.
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


BriefDescriptorExtractor Constructor

Create a BRIEF descriptor extractor.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public BriefDescriptorExtractor(
    int descriptorSize = 32
)
Public Sub New (
    Optional descriptorSize As Integer = 32
)
public:
BriefDescriptorExtractor(
    int descriptorSize = 32
)
new :
        ?descriptorSize : int
(* Defaults:
        let _descriptorSize = defaultArg descriptorSize 32
*)
-> BriefDescriptorExtractor

Parameters

descriptorSize (Optional)
Type: SystemInt32
The size of descriptor. It can be equal 16, 32 or 64 bytes.
See Also

Reference

BriefDescriptorExtractor Class
Emgu.CV.XFeatures2D Namespace


BriefDescriptorExtractor Properties

The BriefDescriptorExtractor type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BriefDescriptorExtractor Class
Emgu.CV.XFeatures2D Namespace


BriefDescriptorExtractor Methods

The BriefDescriptorExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BriefDescriptorExtractor Class
Emgu.CV.XFeatures2D Namespace


BriefDescriptorExtractor.DisposeObject Method

BriefDescriptorExtractorDisposeObject Method

Release all the unmanaged resource associated with BRIEF

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

BriefDescriptorExtractor Class
Emgu.CV.XFeatures2D Namespace


BriefDescriptorExtractor Fields

The BriefDescriptorExtractor type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

BriefDescriptorExtractor Class
Emgu.CV.XFeatures2D Namespace


DAISY Class

Daisy descriptor.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DDAISY

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DAISY : Feature2D
Public Class DAISY
    Inherits Feature2D
public ref class DAISY : public Feature2D
type DAISY =
    class
        inherit Feature2D
    end

The DAISY type exposes the following members.

Constructors
 | Name | Description
Public method | DAISY | Create DAISY descriptor extractor
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


DAISY Constructor

Create DAISY descriptor extractor

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DAISY(
    float radius = 15f,
    int qRadius = 3,
    int qTheta = 8,
    int qHist = 8,
    DAISYNormalizationType norm = 100,
    IInputArray H = null,
    bool interpolation = true,
    bool useOrientation = false
)
Public Sub New (
    Optional radius As Single = 15F,
    Optional qRadius As Integer = 3,
    Optional qTheta As Integer = 8,
    Optional qHist As Integer = 8,
    Optional norm As DAISYNormalizationType = 100,
    Optional H As IInputArray = Nothing,
    Optional interpolation As Boolean = true,
    Optional useOrientation As Boolean = false
)
public:
DAISY(
    float radius = 15f,
    int qRadius = 3,
    int qTheta = 8,
    int qHist = 8,
    DAISYNormalizationType^ norm = 100,
    IInputArray^ H = nullptr,
    bool interpolation = true,
    bool useOrientation = false
)
new :
        ?radius : float32 *
        ?qRadius : int *
        ?qTheta : int *
        ?qHist : int *
        ?norm : DAISYNormalizationType *
        ?H : IInputArray *
        ?interpolation : bool *
        ?useOrientation : bool
(* Defaults:
        let _radius = defaultArg radius 15f
        let _qRadius = defaultArg qRadius 3
        let _qTheta = defaultArg qTheta 8
        let _qHist = defaultArg qHist 8
        let _norm = defaultArg norm 100
        let _H = defaultArg H null
        let _interpolation = defaultArg interpolation true
        let _useOrientation = defaultArg useOrientation false
*)
-> DAISY

Parameters

radius (Optional)
Type: SystemSingle
Radius of the descriptor at the initial scale.
qRadius (Optional)
Type: SystemInt32
Amount of radial range division quantity.
qTheta (Optional)
Type: SystemInt32
Amount of angular range division quantity.
qHist (Optional)
Type: SystemInt32
Amount of gradient orientations range division quantity.
norm (Optional)
Type: Emgu.CV.XFeatures2DDAISYNormalizationType
Descriptors normalization type.
H (Optional)
Type: Emgu.CVIInputArray
optional 3x3 homography matrix used to warp the grid of daisy but sampling keypoints remains unwarped on image
interpolation (Optional)
Type: SystemBoolean
Switch to disable interpolation for speed improvement at minor quality loss
useOrientation (Optional)
Type: SystemBoolean
Sample patterns using keypoints orientation, disabled by default.
See Also

Reference

DAISY Class
Emgu.CV.XFeatures2D Namespace


DAISY Properties

The DAISY type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DAISY Class
Emgu.CV.XFeatures2D Namespace


DAISY Methods

The DAISY type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DAISY Class
Emgu.CV.XFeatures2D Namespace


DAISY.DisposeObject Method

DAISYDisposeObject Method

Release all the unmanaged resource associated with BRIEF

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DAISY Class
Emgu.CV.XFeatures2D Namespace


DAISY Fields

The DAISY type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DAISY Class
Emgu.CV.XFeatures2D Namespace


DAISY.NormalizationType Class

DAISYNormalizationType Class

Normalization type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XFeatures2DDAISYNormalizationType

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NormalizationType : Enum
Public NotInheritable Class NormalizationType
    Inherits Enum
public ref class NormalizationType sealed : public Enum
[<SealedAttribute>]
type NormalizationType =
    class
        inherit Enum
    end

The DAISYNormalizationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Full | Descriptors are normalized for L2 norm equal to 1.0
 | None | Will not do any normalization (default)
 | Partial | Histograms are normalized independently for L2 norm equal to 1.0
 | SIFT | Descriptors are normalized for L2 norm equal to 1.0 but no individual one is bigger than 0.154 as in SIFT
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


NormalizationType Methods

The DAISYNormalizationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DAISYNormalizationType Class
Emgu.CV.XFeatures2D Namespace


NormalizationType Fields

The DAISYNormalizationType type exposes the following members.

Fields
 | Name | Description
 | Full | Descriptors are normalized for L2 norm equal to 1.0
 | None | Will not do any normalization (default)
 | Partial | Histograms are normalized independently for L2 norm equal to 1.0
 | SIFT | Descriptors are normalized for L2 norm equal to 1.0 but no individual one is bigger than 0.154 as in SIFT
Public field | value__ |
Top
See Also

Reference

DAISYNormalizationType Class
Emgu.CV.XFeatures2D Namespace


DAISY.NormalizationType.Full Field

DAISYNormalizationTypeFull Field

Descriptors are normalized for L2 norm equal to 1.0

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DAISYNormalizationType Full = 102
Public Const Full As DAISYNormalizationType = 102
public:
literal DAISYNormalizationType^ Full = 102
static val mutable Full: DAISYNormalizationType

Field Value

Type: DAISYNormalizationType
See Also

Reference

DAISYNormalizationType Class
Emgu.CV.XFeatures2D Namespace


DAISY.NormalizationType.None Field

DAISYNormalizationTypeNone Field

Will not do any normalization (default)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DAISYNormalizationType None = 100
Public Const None As DAISYNormalizationType = 100
public:
literal DAISYNormalizationType^ None = 100
static val mutable None: DAISYNormalizationType

Field Value

Type: DAISYNormalizationType
See Also

Reference

DAISYNormalizationType Class
Emgu.CV.XFeatures2D Namespace


DAISY.NormalizationType.Partial Field

DAISYNormalizationTypePartial Field

Histograms are normalized independently for L2 norm equal to 1.0

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DAISYNormalizationType Partial = 101
Public Const Partial As DAISYNormalizationType = 101
public:
literal DAISYNormalizationType^ Partial = 101
static val mutable Partial: DAISYNormalizationType

Field Value

Type: DAISYNormalizationType
See Also

Reference

DAISYNormalizationType Class
Emgu.CV.XFeatures2D Namespace


DAISY.NormalizationType.SIFT Field

DAISYNormalizationTypeSIFT Field

Descriptors are normalized for L2 norm equal to 1.0 but no individual one is bigger than 0.154 as in SIFT

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DAISYNormalizationType SIFT = 103
Public Const SIFT As DAISYNormalizationType = 103
public:
literal DAISYNormalizationType^ SIFT = 103
static val mutable SIFT: DAISYNormalizationType

Field Value

Type: DAISYNormalizationType
See Also

Reference

DAISYNormalizationType Class
Emgu.CV.XFeatures2D Namespace


DAISY.NormalizationType.value__ Field

DAISYNormalizationTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XFeatures2D.DAISY.NormalizationType.value__"]

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DAISYNormalizationType Class
Emgu.CV.XFeatures2D Namespace


Freak Class

The FREAK (Fast Retina Keypoint) keypoint descriptor: Alahi, R. Ortiz, and P. Vandergheynst. FREAK: Fast Retina Keypoint. In IEEE Conference on Computer Vision and Pattern Recognition, 2012. CVPR 2012 Open Source Award Winner. The algorithm propose a novel keypoint descriptor inspired by the human visual system and more precisely the retina, coined Fast Retina Key- point (FREAK). A cascade of binary strings is computed by efficiently comparing image intensities over a retinal sampling pattern. FREAKs are in general faster to compute with lower memory load and also more robust than SIFT, SURF or BRISK. They are competitive alternatives to existing keypoints in particular for embedded applications.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DFreak

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class Freak : Feature2D
Public Class Freak
    Inherits Feature2D
public ref class Freak : public Feature2D
type Freak =
    class
        inherit Feature2D
    end

The Freak type exposes the following members.

Constructors
 | Name | Description
Public method | Freak | Create a Freak descriptor extractor.
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with FREAK (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


Freak Constructor

Create a Freak descriptor extractor.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Freak(
    bool orientationNormalized = true,
    bool scaleNormalized = true,
    float patternScale = 22f,
    int nOctaves = 4
)
Public Sub New (
    Optional orientationNormalized As Boolean = true,
    Optional scaleNormalized As Boolean = true,
    Optional patternScale As Single = 22F,
    Optional nOctaves As Integer = 4
)
public:
Freak(
    bool orientationNormalized = true,
    bool scaleNormalized = true,
    float patternScale = 22f,
    int nOctaves = 4
)
new :
        ?orientationNormalized : bool *
        ?scaleNormalized : bool *
        ?patternScale : float32 *
        ?nOctaves : int
(* Defaults:
        let _orientationNormalized = defaultArg orientationNormalized true
        let _scaleNormalized = defaultArg scaleNormalized true
        let _patternScale = defaultArg patternScale 22f
        let _nOctaves = defaultArg nOctaves 4
*)
-> Freak

Parameters

orientationNormalized (Optional)
Type: SystemBoolean
Enable orientation normalization
scaleNormalized (Optional)
Type: SystemBoolean
Enable scale normalization
patternScale (Optional)
Type: SystemSingle
Scaling of the description pattern
nOctaves (Optional)
Type: SystemInt32
Number of octaves covered by the detected keypoints.
See Also

Reference

Freak Class
Emgu.CV.XFeatures2D Namespace


Freak Properties

The Freak type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Freak Class
Emgu.CV.XFeatures2D Namespace


Freak Methods

The Freak type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with FREAK (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Freak Class
Emgu.CV.XFeatures2D Namespace


Freak.DisposeObject Method

FreakDisposeObject Method

Release all the unmanaged resource associated with FREAK

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

Freak Class
Emgu.CV.XFeatures2D Namespace


Freak Fields

The Freak type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Freak Class
Emgu.CV.XFeatures2D Namespace


HarrisLaplaceFeatureDetector Class

Class implementing the Harris-Laplace feature detector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DHarrisLaplaceFeatureDetector

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class HarrisLaplaceFeatureDetector : Feature2D
Public Class HarrisLaplaceFeatureDetector
    Inherits Feature2D
public ref class HarrisLaplaceFeatureDetector : public Feature2D
type HarrisLaplaceFeatureDetector =
    class
        inherit Feature2D
    end

The HarrisLaplaceFeatureDetector type exposes the following members.

Constructors
 | Name | Description
Public method | HarrisLaplaceFeatureDetector | Create a HarrisLaplaceFeatureDetector
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with FREAK (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


HarrisLaplaceFeatureDetector Constructor

Create a HarrisLaplaceFeatureDetector

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public HarrisLaplaceFeatureDetector(
    int numOctaves,
    float cornThresh,
    float DOGThresh,
    int maxCorners,
    int numLayers
)
Public Sub New (
    numOctaves As Integer,
    cornThresh As Single,
    DOGThresh As Single,
    maxCorners As Integer,
    numLayers As Integer
)
public:
HarrisLaplaceFeatureDetector(
    int numOctaves,
    float cornThresh,
    float DOGThresh,
    int maxCorners,
    int numLayers
)
new :
        numOctaves : int *
        cornThresh : float32 *
        DOGThresh : float32 *
        maxCorners : int *
        numLayers : int -> HarrisLaplaceFeatureDetector

Parameters

numOctaves
Type: SystemInt32
the number of octaves in the scale-space pyramid
cornThresh
Type: SystemSingle
the threshold for the Harris cornerness measure
DOGThresh
Type: SystemSingle
the threshold for the Difference-of-Gaussians scale selection
maxCorners
Type: SystemInt32
the maximum number of corners to consider
numLayers
Type: SystemInt32
the number of intermediate scales per octave
See Also

Reference

HarrisLaplaceFeatureDetector Class
Emgu.CV.XFeatures2D Namespace


HarrisLaplaceFeatureDetector Properties

The HarrisLaplaceFeatureDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

HarrisLaplaceFeatureDetector Class
Emgu.CV.XFeatures2D Namespace


HarrisLaplaceFeatureDetector Methods

The HarrisLaplaceFeatureDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with FREAK (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HarrisLaplaceFeatureDetector Class
Emgu.CV.XFeatures2D Namespace


HarrisLaplaceFeatureDetector.DisposeObject Method

HarrisLaplaceFeatureDetectorDisposeObject Method

Release all the unmanaged resource associated with FREAK

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

HarrisLaplaceFeatureDetector Class
Emgu.CV.XFeatures2D Namespace


HarrisLaplaceFeatureDetector Fields

The HarrisLaplaceFeatureDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

HarrisLaplaceFeatureDetector Class
Emgu.CV.XFeatures2D Namespace


LATCH Class

latch Class for computing the LATCH descriptor. If you find this code useful, please add a reference to the following paper in your work: Gil Levi and Tal Hassner, "LATCH: Learned Arrangements of Three Patch Codes", arXiv preprint arXiv:1501.03719, 15 Jan. 2015 LATCH is a binary descriptor based on learned comparisons of triplets of image patches.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DLATCH

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LATCH : Feature2D
Public Class LATCH
    Inherits Feature2D
public ref class LATCH : public Feature2D
type LATCH =
    class
        inherit Feature2D
    end

The LATCH type exposes the following members.

Constructors
 | Name | Description
Public method | LATCH | Create LATCH descriptor extractor
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


LATCH Constructor

Create LATCH descriptor extractor

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LATCH(
    int bytes = 32,
    bool rotationInvariance = true,
    int halfSsdSize = 3
)
Public Sub New (
    Optional bytes As Integer = 32,
    Optional rotationInvariance As Boolean = true,
    Optional halfSsdSize As Integer = 3
)
public:
LATCH(
    int bytes = 32,
    bool rotationInvariance = true,
    int halfSsdSize = 3
)
new :
        ?bytes : int *
        ?rotationInvariance : bool *
        ?halfSsdSize : int
(* Defaults:
        let _bytes = defaultArg bytes 32
        let _rotationInvariance = defaultArg rotationInvariance true
        let _halfSsdSize = defaultArg halfSsdSize 3
*)
-> LATCH

Parameters

bytes (Optional)
Type: SystemInt32
The size of the descriptor - can be 64, 32, 16, 8, 4, 2 or 1
rotationInvariance (Optional)
Type: SystemBoolean
Whether or not the descriptor should compensate for orientation changes.
halfSsdSize (Optional)
Type: SystemInt32
the size of half of the mini-patches size. For example, if we would like to compare triplets of patches of size 7x7x then the half_ssd_size should be (7-1)/2 = 3.
See Also

Reference

LATCH Class
Emgu.CV.XFeatures2D Namespace


LATCH Properties

The LATCH type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

LATCH Class
Emgu.CV.XFeatures2D Namespace


LATCH Methods

The LATCH type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LATCH Class
Emgu.CV.XFeatures2D Namespace


LATCH.DisposeObject Method

LATCHDisposeObject Method

Release all the unmanaged resource associated with BRIEF

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LATCH Class
Emgu.CV.XFeatures2D Namespace


LATCH Fields

The LATCH type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

LATCH Class
Emgu.CV.XFeatures2D Namespace


LUCID Class

The locally uniform comparison image descriptor: An image descriptor that can be computed very fast, while being about as robust as, for example, SURF or BRIEF.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DLUCID

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LUCID : Feature2D
Public Class LUCID
    Inherits Feature2D
public ref class LUCID : public Feature2D
type LUCID =
    class
        inherit Feature2D
    end

The LUCID type exposes the following members.

Constructors
 | Name | Description
Public method | LUCID | Create a locally uniform comparison image descriptor.
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


LUCID Constructor

Create a locally uniform comparison image descriptor.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LUCID(
    int lucidKernel = 1,
    int blurKernel = 2
)
Public Sub New (
    Optional lucidKernel As Integer = 1,
    Optional blurKernel As Integer = 2
)
public:
LUCID(
    int lucidKernel = 1,
    int blurKernel = 2
)
new :
        ?lucidKernel : int *
        ?blurKernel : int
(* Defaults:
        let _lucidKernel = defaultArg lucidKernel 1
        let _blurKernel = defaultArg blurKernel 2
*)
-> LUCID

Parameters

lucidKernel (Optional)
Type: SystemInt32
Kernel for descriptor construction, where 1=3x3, 2=5x5, 3=7x7 and so forth
blurKernel (Optional)
Type: SystemInt32
kernel for blurring image prior to descriptor construction, where 1=3x3, 2=5x5, 3=7x7 and so forth
See Also

Reference

LUCID Class
Emgu.CV.XFeatures2D Namespace


LUCID Properties

The LUCID type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

LUCID Class
Emgu.CV.XFeatures2D Namespace


LUCID Methods

The LUCID type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with BRIEF (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LUCID Class
Emgu.CV.XFeatures2D Namespace


LUCID.DisposeObject Method

LUCIDDisposeObject Method

Release all the unmanaged resource associated with BRIEF

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LUCID Class
Emgu.CV.XFeatures2D Namespace


LUCID Fields

The LUCID type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

LUCID Class
Emgu.CV.XFeatures2D Namespace


MSDDetector Class

Class implementing the MSD (Maximal Self-Dissimilarity) keypoint detector, described in "Federico Tombari and Luigi Di Stefano. Interest points via maximal self-dissimilarities. In Asian Conference on Computer Vision - ACCV 2014, 2014".
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DMSDDetector

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class MSDDetector : Feature2D
Public Class MSDDetector
    Inherits Feature2D
public ref class MSDDetector : public Feature2D
type MSDDetector =
    class
        inherit Feature2D
    end

The MSDDetector type exposes the following members.

Constructors
 | Name | Description
Public method | MSDDetector | Create a MSD (Maximal Self-Dissimilarity) keypoint detector.
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with MSDDetector (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Remarks
The algorithm implements a novel interest point detector stemming from the intuition that image patches which are highly dissimilar over a relatively large extent of their surroundings hold the property of being repeatable and distinctive. This concept of "contextual self-dissimilarity" reverses the key paradigm of recent successful techniques such as the Local Self-Similarity descriptor and the Non-Local Means filter, which build upon the presence of similar - rather than dissimilar - patches. Moreover, it extends to contextual information the local self-dissimilarity notion embedded in established detectors of corner-like interest points, thereby achieving enhanced repeatability, distinctiveness and localization accuracy.
See Also

Reference

Emgu.CV.XFeatures2D Namespace


MSDDetector Constructor

Create a MSD (Maximal Self-Dissimilarity) keypoint detector.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public MSDDetector(
    int m_patch_radius,
    int m_search_area_radius,
    int m_nms_radius,
    int m_nms_scale_radius,
    float m_th_saliency,
    int m_kNN,
    float m_scale_factor,
    int m_n_scales,
    bool m_compute_orientation
)
Public Sub New (
    m_patch_radius As Integer,
    m_search_area_radius As Integer,
    m_nms_radius As Integer,
    m_nms_scale_radius As Integer,
    m_th_saliency As Single,
    m_kNN As Integer,
    m_scale_factor As Single,
    m_n_scales As Integer,
    m_compute_orientation As Boolean
)
public:
MSDDetector(
    int m_patch_radius,
    int m_search_area_radius,
    int m_nms_radius,
    int m_nms_scale_radius,
    float m_th_saliency,
    int m_kNN,
    float m_scale_factor,
    int m_n_scales,
    bool m_compute_orientation
)
new :
        m_patch_radius : int *
        m_search_area_radius : int *
        m_nms_radius : int *
        m_nms_scale_radius : int *
        m_th_saliency : float32 *
        m_kNN : int *
        m_scale_factor : float32 *
        m_n_scales : int *
        m_compute_orientation : bool -> MSDDetector

Parameters

m_patch_radius
Type: SystemInt32
Patch radius
m_search_area_radius
Type: SystemInt32
Search area raduis
m_nms_radius
Type: SystemInt32
Nms radius
m_nms_scale_radius
Type: SystemInt32
Nms scale radius
m_th_saliency
Type: SystemSingle
Th saliency
m_kNN
Type: SystemInt32
Knn
m_scale_factor
Type: SystemSingle
Scale factor
m_n_scales
Type: SystemInt32
N scales
m_compute_orientation
Type: SystemBoolean
Compute orientation
See Also

Reference

MSDDetector Class
Emgu.CV.XFeatures2D Namespace


MSDDetector Properties

The MSDDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MSDDetector Class
Emgu.CV.XFeatures2D Namespace


MSDDetector Methods

The MSDDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with MSDDetector (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MSDDetector Class
Emgu.CV.XFeatures2D Namespace


MSDDetector.DisposeObject Method

MSDDetectorDisposeObject Method

Release all the unmanaged resource associated with MSDDetector

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

MSDDetector Class
Emgu.CV.XFeatures2D Namespace


MSDDetector Fields

The MSDDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

MSDDetector Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures Class

Class implementing PCT (position-color-texture) signature extraction as described in: Martin Krulis, Jakub Lokoc, and Tomas Skopal. Efficient extraction of clustering-based feature signatures using GPU architectures. Multimedia Tools Appl., 75(13):8071–8103, 2016. The algorithm is divided to a feature sampler and a clusterizer. Feature sampler produces samples at given set of coordinates. Clusterizer then produces clusters of these samples using k-means algorithm. Resulting set of clusters is the signature of the input image. A signature is an array of SIGNATURE_DIMENSION-dimensional points.Used dimensions are: weight, x, y position; lab color, contrast, entropy.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.XFeatures2DPCTSignatures

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PCTSignatures : SharedPtrObject
Public Class PCTSignatures
    Inherits SharedPtrObject
public ref class PCTSignatures : public SharedPtrObject
type PCTSignatures =
    class
        inherit SharedPtrObject
    end

The PCTSignatures type exposes the following members.

Constructors
 | Name | Description
Public method | PCTSignatures(VectorOfPointF, VectorOfInt) | Creates PCTSignatures algorithm using pre-generated sampling points and clusterization seeds indexes.
Public method | PCTSignatures(VectorOfPointF, Int32) | Creates PCTSignatures algorithm using pre-generated sampling points and number of clusterization seeds. It uses the provided sampling points and generates its own clusterization seed indexes.
Public method | PCTSignatures(Int32, Int32, PCTSignaturesPointDistributionType) | Creates PCTSignatures algorithm using sample and seed count. It generates its own sets of sampling points and clusterization seed indexes.
Top
Properties
 | Name | Description
Public property | ClusterMinSize | This parameter multiplied by the index of iteration gives lower limit for cluster size. Clusters containing fewer points than specified by the limit have their centroid dismissed and points are reassigned.
Public property | DistanceFunction | Distance function selector used for measuring distance between two points in k-means.
Public property | DropThreshold | Remove centroids in k-means whose weight is lesser or equal to given threshold.
Public property | GrayscaleBits | Color resolution of the greyscale bitmap represented in allocated bits (i.e., value 4 means that 16 shades of grey are used). The greyscale bitmap is used for computing contrast and entropy values.
Public property | IterationCount | Number of iterations of the k-means clustering. We use fixed number of iterations, since the modified clustering is pruning clusters (not iteratively refining k clusters).
Public property | JoiningDistance | Threshold euclidean distance between two centroids. If two cluster centers are closer than this distance, one of the centroid is dismissed and points are reassigned.
Public property | MaxClustersCount | Maximal number of generated clusters. If the number is exceeded, the clusters are sorted by their weights and the smallest clusters are cropped.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | WeightA | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightB | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightEntropy | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightL | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightX | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightY | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WindowRadius | Size of the texture sampling window used to compute contrast and entropy. (center of the window is always in the pixel selected by x,y coordinates of the corresponding feature sample).
Top
Methods
 | Name | Description
Public method | ComputeSignature | Computes signature of given image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this PCTSignatures object (Overrides DisposableObjectDisposeObject.)
 | DrawSignature | Draws signature in the source image and outputs the result. Signatures are visualized as a circle with radius based on signature weight and color based on signature color. Contrast and entropy are not visualized.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


PCTSignatures Constructor

Overload List
 | Name | Description
Public method | PCTSignatures(VectorOfPointF, VectorOfInt) | Creates PCTSignatures algorithm using pre-generated sampling points and clusterization seeds indexes.
Public method | PCTSignatures(VectorOfPointF, Int32) | Creates PCTSignatures algorithm using pre-generated sampling points and number of clusterization seeds. It uses the provided sampling points and generates its own clusterization seed indexes.
Public method | PCTSignatures(Int32, Int32, PCTSignaturesPointDistributionType) | Creates PCTSignatures algorithm using sample and seed count. It generates its own sets of sampling points and clusterization seed indexes.
Top
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures Constructor (VectorOfPointF, VectorOfInt)

Creates PCTSignatures algorithm using pre-generated sampling points and clusterization seeds indexes.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PCTSignatures(
    VectorOfPointF initSamplingPoints,
    VectorOfInt initClusterSeedIndexes
)
Public Sub New (
    initSamplingPoints As VectorOfPointF,
    initClusterSeedIndexes As VectorOfInt
)
public:
PCTSignatures(
    VectorOfPointF^ initSamplingPoints,
    VectorOfInt^ initClusterSeedIndexes
)
new :
        initSamplingPoints : VectorOfPointF *
        initClusterSeedIndexes : VectorOfInt -> PCTSignatures

Parameters

initSamplingPoints
Type: Emgu.CV.UtilVectorOfPointF
Sampling points used in image sampling.
initClusterSeedIndexes
Type: Emgu.CV.UtilVectorOfInt
Indexes of initial clusterization seeds. Its size must be lower or equal to initSamplingPoints.size().
See Also

Reference

PCTSignatures Class
PCTSignatures Overload
Emgu.CV.XFeatures2D Namespace


PCTSignatures Constructor (VectorOfPointF, Int32)

Creates PCTSignatures algorithm using pre-generated sampling points and number of clusterization seeds. It uses the provided sampling points and generates its own clusterization seed indexes.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PCTSignatures(
    VectorOfPointF initSamplingPoints,
    int initSeedCount
)
Public Sub New (
    initSamplingPoints As VectorOfPointF,
    initSeedCount As Integer
)
public:
PCTSignatures(
    VectorOfPointF^ initSamplingPoints,
    int initSeedCount
)
new :
        initSamplingPoints : VectorOfPointF *
        initSeedCount : int -> PCTSignatures

Parameters

initSamplingPoints
Type: Emgu.CV.UtilVectorOfPointF
Sampling points used in image sampling.
initSeedCount
Type: SystemInt32
Number of initial clusterization seeds. Must be lower or equal to initSamplingPoints.size().
See Also

Reference

PCTSignatures Class
PCTSignatures Overload
Emgu.CV.XFeatures2D Namespace


PCTSignatures Constructor (Int32, Int32, PCTSignatures.PointDistributionType)

PCTSignatures Constructor (Int32, Int32, PCTSignaturesPointDistributionType)

http://www.emgu.com
Creates PCTSignatures algorithm using sample and seed count. It generates its own sets of sampling points and clusterization seed indexes.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PCTSignatures(
    int initSampleCount = 2000,
    int initSeedCount = 400,
    PCTSignaturesPointDistributionType pointDistribution = 0
)
Public Sub New (
    Optional initSampleCount As Integer = 2000,
    Optional initSeedCount As Integer = 400,
    Optional pointDistribution As PCTSignaturesPointDistributionType = 0
)
public:
PCTSignatures(
    int initSampleCount = 2000,
    int initSeedCount = 400,
    PCTSignaturesPointDistributionType^ pointDistribution = 0
)
new :
        ?initSampleCount : int *
        ?initSeedCount : int *
        ?pointDistribution : PCTSignaturesPointDistributionType
(* Defaults:
        let _initSampleCount = defaultArg initSampleCount 2000
        let _initSeedCount = defaultArg initSeedCount 400
        let _pointDistribution = defaultArg pointDistribution 0
*)
-> PCTSignatures

Parameters

initSampleCount (Optional)
Type: SystemInt32
Number of points used for image sampling.
initSeedCount (Optional)
Type: SystemInt32
Number of initial clusterization seeds. Must be lower or equal to initSampleCount
pointDistribution (Optional)
Type: Emgu.CV.XFeatures2DPCTSignaturesPointDistributionType
Distribution of generated points.
See Also

Reference

PCTSignatures Class
PCTSignatures Overload
Emgu.CV.XFeatures2D Namespace


PCTSignatures Properties

The PCTSignatures type exposes the following members.

Properties
 | Name | Description
Public property | ClusterMinSize | This parameter multiplied by the index of iteration gives lower limit for cluster size. Clusters containing fewer points than specified by the limit have their centroid dismissed and points are reassigned.
Public property | DistanceFunction | Distance function selector used for measuring distance between two points in k-means.
Public property | DropThreshold | Remove centroids in k-means whose weight is lesser or equal to given threshold.
Public property | GrayscaleBits | Color resolution of the greyscale bitmap represented in allocated bits (i.e., value 4 means that 16 shades of grey are used). The greyscale bitmap is used for computing contrast and entropy values.
Public property | IterationCount | Number of iterations of the k-means clustering. We use fixed number of iterations, since the modified clustering is pruning clusters (not iteratively refining k clusters).
Public property | JoiningDistance | Threshold euclidean distance between two centroids. If two cluster centers are closer than this distance, one of the centroid is dismissed and points are reassigned.
Public property | MaxClustersCount | Maximal number of generated clusters. If the number is exceeded, the clusters are sorted by their weights and the smallest clusters are cropped.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | WeightA | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightB | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightEntropy | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightL | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightX | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WeightY | Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)
Public property | WindowRadius | Size of the texture sampling window used to compute contrast and entropy. (center of the window is always in the pixel selected by x,y coordinates of the corresponding feature sample).
Top
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.ClusterMinSize Property

PCTSignaturesClusterMinSize Property

This parameter multiplied by the index of iteration gives lower limit for cluster size. Clusters containing fewer points than specified by the limit have their centroid dismissed and points are reassigned.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int ClusterMinSize { get; set; }
Public Property ClusterMinSize As Integer
    Get
    Set
public:
property int ClusterMinSize {
    int get ();
    void set (int value);
}
member ClusterMinSize : int with get, set

Property Value

Type: Int32
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.DistanceFunction Property

PCTSignaturesDistanceFunction Property

Distance function selector used for measuring distance between two points in k-means.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PCTSignaturesPointDistributionType DistanceFunction { get; set; }
Public Property DistanceFunction As PCTSignaturesPointDistributionType
    Get
    Set
public:
property PCTSignaturesPointDistributionType^ DistanceFunction {
    PCTSignaturesPointDistributionType^ get ();
    void set (PCTSignaturesPointDistributionType^ value);
}
member DistanceFunction : PCTSignaturesPointDistributionType with get, set

Property Value

Type: PCTSignaturesPointDistributionType
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.DropThreshold Property

PCTSignaturesDropThreshold Property

Remove centroids in k-means whose weight is lesser or equal to given threshold.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float DropThreshold { get; set; }
Public Property DropThreshold As Single
    Get
    Set
public:
property float DropThreshold {
    float get ();
    void set (float value);
}
member DropThreshold : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.GrayscaleBits Property

PCTSignaturesGrayscaleBits Property

Color resolution of the greyscale bitmap represented in allocated bits (i.e., value 4 means that 16 shades of grey are used). The greyscale bitmap is used for computing contrast and entropy values.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int GrayscaleBits { get; set; }
Public Property GrayscaleBits As Integer
    Get
    Set
public:
property int GrayscaleBits {
    int get ();
    void set (int value);
}
member GrayscaleBits : int with get, set

Property Value

Type: Int32
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.IterationCount Property

PCTSignaturesIterationCount Property

Number of iterations of the k-means clustering. We use fixed number of iterations, since the modified clustering is pruning clusters (not iteratively refining k clusters).

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int IterationCount { get; set; }
Public Property IterationCount As Integer
    Get
    Set
public:
property int IterationCount {
    int get ();
    void set (int value);
}
member IterationCount : int with get, set

Property Value

Type: Int32
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.JoiningDistance Property

PCTSignaturesJoiningDistance Property

Threshold euclidean distance between two centroids. If two cluster centers are closer than this distance, one of the centroid is dismissed and points are reassigned.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float JoiningDistance { get; set; }
Public Property JoiningDistance As Single
    Get
    Set
public:
property float JoiningDistance {
    float get ();
    void set (float value);
}
member JoiningDistance : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.MaxClustersCount Property

PCTSignaturesMaxClustersCount Property

Maximal number of generated clusters. If the number is exceeded, the clusters are sorted by their weights and the smallest clusters are cropped.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaxClustersCount { get; set; }
Public Property MaxClustersCount As Integer
    Get
    Set
public:
property int MaxClustersCount {
    int get ();
    void set (int value);
}
member MaxClustersCount : int with get, set

Property Value

Type: Int32
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.WeightA Property

PCTSignaturesWeightA Property

Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float WeightA { get; set; }
Public Property WeightA As Single
    Get
    Set
public:
property float WeightA {
    float get ();
    void set (float value);
}
member WeightA : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.WeightB Property

PCTSignaturesWeightB Property

Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float WeightB { get; set; }
Public Property WeightB As Single
    Get
    Set
public:
property float WeightB {
    float get ();
    void set (float value);
}
member WeightB : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.WeightEntropy Property

PCTSignaturesWeightEntropy Property

Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float WeightEntropy { get; set; }
Public Property WeightEntropy As Single
    Get
    Set
public:
property float WeightEntropy {
    float get ();
    void set (float value);
}
member WeightEntropy : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.WeightL Property

PCTSignaturesWeightL Property

Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float WeightL { get; set; }
Public Property WeightL As Single
    Get
    Set
public:
property float WeightL {
    float get ();
    void set (float value);
}
member WeightL : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.WeightX Property

PCTSignaturesWeightX Property

Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float WeightX { get; set; }
Public Property WeightX As Single
    Get
    Set
public:
property float WeightX {
    float get ();
    void set (float value);
}
member WeightX : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.WeightY Property

PCTSignaturesWeightY Property

Weights (multiplicative constants) that linearly stretch individual axes of the feature space. (x,y = position. L,a,b = color in CIE Lab space. c = contrast. e = entropy)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float WeightY { get; set; }
Public Property WeightY As Single
    Get
    Set
public:
property float WeightY {
    float get ();
    void set (float value);
}
member WeightY : float32 with get, set

Property Value

Type: Single
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.WindowRadius Property

PCTSignaturesWindowRadius Property

Size of the texture sampling window used to compute contrast and entropy. (center of the window is always in the pixel selected by x,y coordinates of the corresponding feature sample).

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int WindowRadius { get; set; }
Public Property WindowRadius As Integer
    Get
    Set
public:
property int WindowRadius {
    int get ();
    void set (int value);
}
member WindowRadius : int with get, set

Property Value

Type: Int32
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures Methods

The PCTSignatures type exposes the following members.

Methods
 | Name | Description
Public method | ComputeSignature | Computes signature of given image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this PCTSignatures object (Overrides DisposableObjectDisposeObject.)
 | DrawSignature | Draws signature in the source image and outputs the result. Signatures are visualized as a circle with radius based on signature weight and color based on signature color. Contrast and entropy are not visualized.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.ComputeSignature Method

PCTSignaturesComputeSignature Method

Computes signature of given image.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ComputeSignature(
    IInputArray image,
    IOutputArray signature
)
Public Sub ComputeSignature (
    image As IInputArray,
    signature As IOutputArray
)
public:
void ComputeSignature(
    IInputArray^ image,
    IOutputArray^ signature
)
member ComputeSignature :
        image : IInputArray *
        signature : IOutputArray -> unit

Parameters

image
Type: Emgu.CVIInputArray
Input image of CV_8U type.
signature
Type: Emgu.CVIOutputArray
Output computed signature.
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.DisposeObject Method

PCTSignaturesDisposeObject Method

Release the unmanaged memory associated with this PCTSignatures object

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.DrawSignature Method

PCTSignaturesDrawSignature Method

Draws signature in the source image and outputs the result. Signatures are visualized as a circle with radius based on signature weight and color based on signature color. Contrast and entropy are not visualized.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawSignature(
    IInputArray source,
    IInputArray signature,
    IOutputArray result,
    float radiusToShorterSideRatio = 0.125f,
    int borderThickness = 1
)
Public Shared Sub DrawSignature (
    source As IInputArray,
    signature As IInputArray,
    result As IOutputArray,
    Optional radiusToShorterSideRatio As Single = 0.125F,
    Optional borderThickness As Integer = 1
)
public:
static void DrawSignature(
    IInputArray^ source,
    IInputArray^ signature,
    IOutputArray^ result,
    float radiusToShorterSideRatio = 0.125f,
    int borderThickness = 1
)
static member DrawSignature :
        source : IInputArray *
        signature : IInputArray *
        result : IOutputArray *
        ?radiusToShorterSideRatio : float32 *
        ?borderThickness : int
(* Defaults:
        let _radiusToShorterSideRatio = defaultArg radiusToShorterSideRatio 0.125f
        let _borderThickness = defaultArg borderThickness 1
*)
-> unit

Parameters

source
Type: Emgu.CVIInputArray
Source image.
signature
Type: Emgu.CVIInputArray
Image signature.
result
Type: Emgu.CVIOutputArray
Output result.
radiusToShorterSideRatio (Optional)
Type: SystemSingle
Determines maximal radius of signature in the output image.
borderThickness (Optional)
Type: SystemInt32
Border thickness of the visualized signature.
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures Fields

The PCTSignatures type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

PCTSignatures Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.PointDistributionType Class

PCTSignaturesPointDistributionType Class

Point distributions supported by random point generator.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XFeatures2DPCTSignaturesPointDistributionType

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PointDistributionType : Enum
Public NotInheritable Class PointDistributionType
    Inherits Enum
public ref class PointDistributionType sealed : public Enum
[<SealedAttribute>]
type PointDistributionType =
    class
        inherit Enum
    end

The PCTSignaturesPointDistributionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Normal |
 | Regular | Generate points in a regular grid.
 | Uniform | Generate numbers uniformly.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


PointDistributionType Methods

The PCTSignaturesPointDistributionType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

PCTSignaturesPointDistributionType Class
Emgu.CV.XFeatures2D Namespace


PointDistributionType Fields

The PCTSignaturesPointDistributionType type exposes the following members.

Fields
 | Name | Description
 | Normal |
 | Regular | Generate points in a regular grid.
 | Uniform | Generate numbers uniformly.
Public field | value__ |
Top
See Also

Reference

PCTSignaturesPointDistributionType Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.PointDistributionType.Normal Field

PCTSignaturesPointDistributionTypeNormal Field

[Missing <summary> documentation for "F:Emgu.CV.XFeatures2D.PCTSignatures.PointDistributionType.Normal"]

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesPointDistributionType Normal = 2
Public Const Normal As PCTSignaturesPointDistributionType = 2
public:
literal PCTSignaturesPointDistributionType^ Normal = 2
static val mutable Normal: PCTSignaturesPointDistributionType

Field Value

Type: PCTSignaturesPointDistributionType
See Also

Reference

PCTSignaturesPointDistributionType Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.PointDistributionType.Regular Field

PCTSignaturesPointDistributionTypeRegular Field

Generate points in a regular grid.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesPointDistributionType Regular = 1
Public Const Regular As PCTSignaturesPointDistributionType = 1
public:
literal PCTSignaturesPointDistributionType^ Regular = 1
static val mutable Regular: PCTSignaturesPointDistributionType

Field Value

Type: PCTSignaturesPointDistributionType
See Also

Reference

PCTSignaturesPointDistributionType Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.PointDistributionType.Uniform Field

PCTSignaturesPointDistributionTypeUniform Field

Generate numbers uniformly.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesPointDistributionType Uniform = 0
Public Const Uniform As PCTSignaturesPointDistributionType = 0
public:
literal PCTSignaturesPointDistributionType^ Uniform = 0
static val mutable Uniform: PCTSignaturesPointDistributionType

Field Value

Type: PCTSignaturesPointDistributionType
See Also

Reference

PCTSignaturesPointDistributionType Class
Emgu.CV.XFeatures2D Namespace


PCTSignatures.PointDistributionType.value__ Field

PCTSignaturesPointDistributionTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XFeatures2D.PCTSignatures.PointDistributionType.value__"]

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

PCTSignaturesPointDistributionType Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD Class

Class implementing Signature Quadratic Form Distance (SQFD).
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.XFeatures2DPCTSignaturesSQFD

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PCTSignaturesSQFD : SharedPtrObject
Public Class PCTSignaturesSQFD
    Inherits SharedPtrObject
public ref class PCTSignaturesSQFD : public SharedPtrObject
type PCTSignaturesSQFD =
    class
        inherit SharedPtrObject
    end

The PCTSignaturesSQFD type exposes the following members.

Constructors
 | Name | Description
Public method | PCTSignaturesSQFD | Creates the algorithm instance using selected distance function, similarity function and similarity function parameter.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | ComputeQuadraticFormDistance | Computes Signature Quadratic Form Distance of two signatures.
Public method | ComputeQuadraticFormDistances | Computes Signature Quadratic Form Distance between the reference signature and each of the other image signatures.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this PCTSignaturesSQFD object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Remarks
See also: Christian Beecks, Merih Seran Uysal, Thomas Seidl. Signature quadratic form distance. In Proceedings of the ACM International Conference on Image and Video Retrieval, pages 438-445. ACM, 2010.
See Also

Reference

Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD Constructor

Creates the algorithm instance using selected distance function, similarity function and similarity function parameter.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PCTSignaturesSQFD(
    PCTSignaturesSQFDDistanceFunction distanceFunction = 3,
    PCTSignaturesSQFDSimilarityFunction similarityFunction = 2,
    float similarityParameter = 1f
)
Public Sub New (
    Optional distanceFunction As PCTSignaturesSQFDDistanceFunction = 3,
    Optional similarityFunction As PCTSignaturesSQFDSimilarityFunction = 2,
    Optional similarityParameter As Single = 1F
)
public:
PCTSignaturesSQFD(
    PCTSignaturesSQFDDistanceFunction^ distanceFunction = 3,
    PCTSignaturesSQFDSimilarityFunction^ similarityFunction = 2,
    float similarityParameter = 1f
)
new :
        ?distanceFunction : PCTSignaturesSQFDDistanceFunction *
        ?similarityFunction : PCTSignaturesSQFDSimilarityFunction *
        ?similarityParameter : float32
(* Defaults:
        let _distanceFunction = defaultArg distanceFunction 3
        let _similarityFunction = defaultArg similarityFunction 2
        let _similarityParameter = defaultArg similarityParameter 1f
*)
-> PCTSignaturesSQFD

Parameters

distanceFunction (Optional)
Type: Emgu.CV.XFeatures2DPCTSignaturesSQFDDistanceFunction
Distance function selector.
similarityFunction (Optional)
Type: Emgu.CV.XFeatures2DPCTSignaturesSQFDSimilarityFunction
Similarity function selector.
similarityParameter (Optional)
Type: SystemSingle
Parameter of the similarity function.
See Also

Reference

PCTSignaturesSQFD Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD Properties

The PCTSignaturesSQFD type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

PCTSignaturesSQFD Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD Methods

The PCTSignaturesSQFD type exposes the following members.

Methods
 | Name | Description
Public method | ComputeQuadraticFormDistance | Computes Signature Quadratic Form Distance of two signatures.
Public method | ComputeQuadraticFormDistances | Computes Signature Quadratic Form Distance between the reference signature and each of the other image signatures.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this PCTSignaturesSQFD object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PCTSignaturesSQFD Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.ComputeQuadraticFormDistance Method

PCTSignaturesSQFDComputeQuadraticFormDistance Method

Computes Signature Quadratic Form Distance of two signatures.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float ComputeQuadraticFormDistance(
    IInputArray signature0,
    IInputArray signature1
)
Public Function ComputeQuadraticFormDistance (
    signature0 As IInputArray,
    signature1 As IInputArray
) As Single
public:
float ComputeQuadraticFormDistance(
    IInputArray^ signature0,
    IInputArray^ signature1
)
member ComputeQuadraticFormDistance :
        signature0 : IInputArray *
        signature1 : IInputArray -> float32

Parameters

signature0
Type: Emgu.CVIInputArray
The first signature.
signature1
Type: Emgu.CVIInputArray
The second signature.

Return Value

Type: Single
The Signature Quadratic Form Distance of two signatures
See Also

Reference

PCTSignaturesSQFD Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.ComputeQuadraticFormDistances Method

PCTSignaturesSQFDComputeQuadraticFormDistances Method

Computes Signature Quadratic Form Distance between the reference signature and each of the other image signatures.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ComputeQuadraticFormDistances(
    Mat sourceSignature,
    VectorOfMat imageSignatures,
    VectorOfFloat distances
)
Public Sub ComputeQuadraticFormDistances (
    sourceSignature As Mat,
    imageSignatures As VectorOfMat,
    distances As VectorOfFloat
)
public:
void ComputeQuadraticFormDistances(
    Mat^ sourceSignature,
    VectorOfMat^ imageSignatures,
    VectorOfFloat^ distances
)
member ComputeQuadraticFormDistances :
        sourceSignature : Mat *
        imageSignatures : VectorOfMat *
        distances : VectorOfFloat -> unit

Parameters

sourceSignature
Type: Emgu.CVMat
The signature to measure distance of other signatures from.
imageSignatures
Type: Emgu.CV.UtilVectorOfMat
Vector of signatures to measure distance from the source signature.
distances
Type: Emgu.CV.UtilVectorOfFloat
Output vector of measured distances.
See Also

Reference

PCTSignaturesSQFD Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DisposeObject Method

PCTSignaturesSQFDDisposeObject Method

Release the unmanaged memory associated with this PCTSignaturesSQFD object

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PCTSignaturesSQFD Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD Fields

The PCTSignaturesSQFD type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

PCTSignaturesSQFD Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction Class

PCTSignaturesSQFDDistanceFunction Class

Lp distance function selector.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XFeatures2DPCTSignaturesSQFDDistanceFunction

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DistanceFunction : Enum
Public NotInheritable Class DistanceFunction
    Inherits Enum
public ref class DistanceFunction sealed : public Enum
[<SealedAttribute>]
type DistanceFunction =
    class
        inherit Enum
    end

The PCTSignaturesSQFDDistanceFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | L0_25 | L0_25
 | L0_5 | L0_5
 | L1 | L1
 | L2 | L2
 | L2Squared | L2 squared
 | L5 | L5
 | LInfinity | L infinity
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


DistanceFunction Methods

The PCTSignaturesSQFDDistanceFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


DistanceFunction Fields

The PCTSignaturesSQFDDistanceFunction type exposes the following members.

Fields
 | Name | Description
 | L0_25 | L0_25
 | L0_5 | L0_5
 | L1 | L1
 | L2 | L2
 | L2Squared | L2 squared
 | L5 | L5
 | LInfinity | L infinity
Public field | value__ |
Top
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.L0_25 Field

PCTSignaturesSQFDDistanceFunctionL0_25 Field

L0_25

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDDistanceFunction L0_25 = 0
Public Const L0_25 As PCTSignaturesSQFDDistanceFunction = 0
public:
literal PCTSignaturesSQFDDistanceFunction^ L0_25 = 0
static val mutable L0_25: PCTSignaturesSQFDDistanceFunction

Field Value

Type: PCTSignaturesSQFDDistanceFunction
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.L0_5 Field

PCTSignaturesSQFDDistanceFunctionL0_5 Field

L0_5

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDDistanceFunction L0_5 = 1
Public Const L0_5 As PCTSignaturesSQFDDistanceFunction = 1
public:
literal PCTSignaturesSQFDDistanceFunction^ L0_5 = 1
static val mutable L0_5: PCTSignaturesSQFDDistanceFunction

Field Value

Type: PCTSignaturesSQFDDistanceFunction
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.L1 Field

PCTSignaturesSQFDDistanceFunctionL1 Field

L1

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDDistanceFunction L1 = 2
Public Const L1 As PCTSignaturesSQFDDistanceFunction = 2
public:
literal PCTSignaturesSQFDDistanceFunction^ L1 = 2
static val mutable L1: PCTSignaturesSQFDDistanceFunction

Field Value

Type: PCTSignaturesSQFDDistanceFunction
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.L2 Field

PCTSignaturesSQFDDistanceFunctionL2 Field

L2

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDDistanceFunction L2 = 3
Public Const L2 As PCTSignaturesSQFDDistanceFunction = 3
public:
literal PCTSignaturesSQFDDistanceFunction^ L2 = 3
static val mutable L2: PCTSignaturesSQFDDistanceFunction

Field Value

Type: PCTSignaturesSQFDDistanceFunction
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.L2Squared Field

PCTSignaturesSQFDDistanceFunctionL2Squared Field

L2 squared

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDDistanceFunction L2Squared = 4
Public Const L2Squared As PCTSignaturesSQFDDistanceFunction = 4
public:
literal PCTSignaturesSQFDDistanceFunction^ L2Squared = 4
static val mutable L2Squared: PCTSignaturesSQFDDistanceFunction

Field Value

Type: PCTSignaturesSQFDDistanceFunction
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.L5 Field

PCTSignaturesSQFDDistanceFunctionL5 Field

L5

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDDistanceFunction L5 = 5
Public Const L5 As PCTSignaturesSQFDDistanceFunction = 5
public:
literal PCTSignaturesSQFDDistanceFunction^ L5 = 5
static val mutable L5: PCTSignaturesSQFDDistanceFunction

Field Value

Type: PCTSignaturesSQFDDistanceFunction
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.LInfinity Field

PCTSignaturesSQFDDistanceFunctionLInfinity Field

L infinity

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDDistanceFunction LInfinity = 6
Public Const LInfinity As PCTSignaturesSQFDDistanceFunction = 6
public:
literal PCTSignaturesSQFDDistanceFunction^ LInfinity = 6
static val mutable LInfinity: PCTSignaturesSQFDDistanceFunction

Field Value

Type: PCTSignaturesSQFDDistanceFunction
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.DistanceFunction.value__ Field

PCTSignaturesSQFDDistanceFunctionvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XFeatures2D.PCTSignaturesSQFD.DistanceFunction.value__"]

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

PCTSignaturesSQFDDistanceFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.SimilarityFunction Class

PCTSignaturesSQFDSimilarityFunction Class

Similarity function selector.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XFeatures2DPCTSignaturesSQFDSimilarityFunction

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SimilarityFunction : Enum
Public NotInheritable Class SimilarityFunction
    Inherits Enum
public ref class SimilarityFunction sealed : public Enum
[<SealedAttribute>]
type SimilarityFunction =
    class
        inherit Enum
    end

The PCTSignaturesSQFDSimilarityFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Gaussian | e^{ -alpha * d^2(c_i, c_j)}
 | Heuristic | 1 / (alpha + d(c_i, c_j))
 | Minus | -d(c_i, c_j)
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


SimilarityFunction Methods

The PCTSignaturesSQFDSimilarityFunction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

PCTSignaturesSQFDSimilarityFunction Class
Emgu.CV.XFeatures2D Namespace


SimilarityFunction Fields

The PCTSignaturesSQFDSimilarityFunction type exposes the following members.

Fields
 | Name | Description
 | Gaussian | e^{ -alpha * d^2(c_i, c_j)}
 | Heuristic | 1 / (alpha + d(c_i, c_j))
 | Minus | -d(c_i, c_j)
Public field | value__ |
Top
See Also

Reference

PCTSignaturesSQFDSimilarityFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.SimilarityFunction.Gaussian Field

PCTSignaturesSQFDSimilarityFunctionGaussian Field

e^{ -alpha * d^2(c_i, c_j)}

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDSimilarityFunction Gaussian = 1
Public Const Gaussian As PCTSignaturesSQFDSimilarityFunction = 1
public:
literal PCTSignaturesSQFDSimilarityFunction^ Gaussian = 1
static val mutable Gaussian: PCTSignaturesSQFDSimilarityFunction

Field Value

Type: PCTSignaturesSQFDSimilarityFunction
See Also

Reference

PCTSignaturesSQFDSimilarityFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.SimilarityFunction.Heuristic Field

PCTSignaturesSQFDSimilarityFunctionHeuristic Field

1 / (alpha + d(c_i, c_j))

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDSimilarityFunction Heuristic = 2
Public Const Heuristic As PCTSignaturesSQFDSimilarityFunction = 2
public:
literal PCTSignaturesSQFDSimilarityFunction^ Heuristic = 2
static val mutable Heuristic: PCTSignaturesSQFDSimilarityFunction

Field Value

Type: PCTSignaturesSQFDSimilarityFunction
See Also

Reference

PCTSignaturesSQFDSimilarityFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.SimilarityFunction.Minus Field

PCTSignaturesSQFDSimilarityFunctionMinus Field

-d(c_i, c_j)

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const PCTSignaturesSQFDSimilarityFunction Minus = 0
Public Const Minus As PCTSignaturesSQFDSimilarityFunction = 0
public:
literal PCTSignaturesSQFDSimilarityFunction^ Minus = 0
static val mutable Minus: PCTSignaturesSQFDSimilarityFunction

Field Value

Type: PCTSignaturesSQFDSimilarityFunction
See Also

Reference

PCTSignaturesSQFDSimilarityFunction Class
Emgu.CV.XFeatures2D Namespace


PCTSignaturesSQFD.SimilarityFunction.value__ Field

PCTSignaturesSQFDSimilarityFunctionvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XFeatures2D.PCTSignaturesSQFD.SimilarityFunction.value__"]

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

PCTSignaturesSQFDSimilarityFunction Class
Emgu.CV.XFeatures2D Namespace


StarDetector Class

StarDetector
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DStarDetector

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class StarDetector : Feature2D
Public Class StarDetector
    Inherits Feature2D
public ref class StarDetector : public Feature2D
type StarDetector =
    class
        inherit Feature2D
    end

The StarDetector type exposes the following members.

Constructors
 | Name | Description
Public method | StarDetector | Create a star detector with the specific parameters
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


StarDetector Constructor

Create a star detector with the specific parameters

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StarDetector(
    int maxSize = 45,
    int responseThreshold = 30,
    int lineThresholdProjected = 10,
    int lineThresholdBinarized = 8,
    int suppressNonmaxSize = 5
)
Public Sub New (
    Optional maxSize As Integer = 45,
    Optional responseThreshold As Integer = 30,
    Optional lineThresholdProjected As Integer = 10,
    Optional lineThresholdBinarized As Integer = 8,
    Optional suppressNonmaxSize As Integer = 5
)
public:
StarDetector(
    int maxSize = 45,
    int responseThreshold = 30,
    int lineThresholdProjected = 10,
    int lineThresholdBinarized = 8,
    int suppressNonmaxSize = 5
)
new :
        ?maxSize : int *
        ?responseThreshold : int *
        ?lineThresholdProjected : int *
        ?lineThresholdBinarized : int *
        ?suppressNonmaxSize : int
(* Defaults:
        let _maxSize = defaultArg maxSize 45
        let _responseThreshold = defaultArg responseThreshold 30
        let _lineThresholdProjected = defaultArg lineThresholdProjected 10
        let _lineThresholdBinarized = defaultArg lineThresholdBinarized 8
        let _suppressNonmaxSize = defaultArg suppressNonmaxSize 5
*)
-> StarDetector

Parameters

maxSize (Optional)
Type: SystemInt32
Maximum size of the features. The following values of the parameter are supported: 4, 6, 8, 11, 12, 16, 22, 23, 32, 45, 46, 64, 90, 128
responseThreshold (Optional)
Type: SystemInt32
Threshold for the approximated laplacian, used to eliminate weak features. The larger it is, the less features will be retrieved
lineThresholdProjected (Optional)
Type: SystemInt32
Another threshold for the laplacian to eliminate edges. The larger the threshold, the more points you get.
lineThresholdBinarized (Optional)
Type: SystemInt32
Another threshold for the feature size to eliminate edges. The larger the threshold, the more points you get.
suppressNonmaxSize (Optional)
Type: SystemInt32
Suppress Nonmax Size
See Also

Reference

StarDetector Class
Emgu.CV.XFeatures2D Namespace


StarDetector Properties

The StarDetector type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

StarDetector Class
Emgu.CV.XFeatures2D Namespace


StarDetector Methods

The StarDetector type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this detector. (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StarDetector Class
Emgu.CV.XFeatures2D Namespace


StarDetector.DisposeObject Method

StarDetectorDisposeObject Method

Release the unmanaged memory associated with this detector.

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

StarDetector Class
Emgu.CV.XFeatures2D Namespace


StarDetector Fields

The StarDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

StarDetector Class
Emgu.CV.XFeatures2D Namespace


VGG Class

Class implementing VGG (Oxford Visual Geometry Group) descriptor trained end to end using "Descriptor Learning Using Convex Optimisation" (DLCO) aparatus
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.Features2DFeature2D
Emgu.CV.XFeatures2DVGG

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class VGG : Feature2D
Public Class VGG
    Inherits Feature2D
public ref class VGG : public Feature2D
type VGG =
    class
        inherit Feature2D
    end

The VGG type exposes the following members.

Constructors
 | Name | Description
Public method | VGG | Create an instance of VGG
Top
Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with VGG (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Remarks
See: K. Simonyan, A. Vedaldi, and A. Zisserman. Learning local feature descriptors using convex optimisation. IEEE Transactions on Pattern Analysis and Machine Intelligence, 2014.
See Also

Reference

Emgu.CV.XFeatures2D Namespace


VGG Constructor

Create an instance of VGG

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public VGG(
    VGGDescriptorType desc = 100,
    float isigma = 1.4f,
    bool imgNormalize = true,
    bool useScaleOrientation = true,
    float scaleFactor = 6.25f,
    bool dscNormalize = false
)
Public Sub New (
    Optional desc As VGGDescriptorType = 100,
    Optional isigma As Single = 1.4F,
    Optional imgNormalize As Boolean = true,
    Optional useScaleOrientation As Boolean = true,
    Optional scaleFactor As Single = 6.25F,
    Optional dscNormalize As Boolean = false
)
public:
VGG(
    VGGDescriptorType^ desc = 100,
    float isigma = 1.4f,
    bool imgNormalize = true,
    bool useScaleOrientation = true,
    float scaleFactor = 6.25f,
    bool dscNormalize = false
)
new :
        ?desc : VGGDescriptorType *
        ?isigma : float32 *
        ?imgNormalize : bool *
        ?useScaleOrientation : bool *
        ?scaleFactor : float32 *
        ?dscNormalize : bool
(* Defaults:
        let _desc = defaultArg desc 100
        let _isigma = defaultArg isigma 1.4f
        let _imgNormalize = defaultArg imgNormalize true
        let _useScaleOrientation = defaultArg useScaleOrientation true
        let _scaleFactor = defaultArg scaleFactor 6.25f
        let _dscNormalize = defaultArg dscNormalize false
*)
-> VGG

Parameters

desc (Optional)
Type: Emgu.CV.XFeatures2DVGGDescriptorType
Type of descriptor to use
isigma (Optional)
Type: SystemSingle
gaussian kernel value for image blur
imgNormalize (Optional)
Type: SystemBoolean
use image sample intensity normalization
useScaleOrientation (Optional)
Type: SystemBoolean
sample patterns using keypoints orientation
scaleFactor (Optional)
Type: SystemSingle
adjust the sampling window of detected keypoints to 64.0f (VGG sampling window) 6.25f is default and fits for KAZE, SURF detected keypoints window ratio 6.75f should be the scale for SIFT detected keypoints window ratio 5.00f should be the scale for AKAZE, MSD, AGAST, FAST, BRISK keypoints window ratio 0.75f should be the scale for ORB keypoints ratio
dscNormalize (Optional)
Type: SystemBoolean
clamp descriptors to 255 and convert to uchar CV_8UC1
See Also

Reference

VGG Class
Emgu.CV.XFeatures2D Namespace


VGG Properties

The VGG type exposes the following members.

Properties
 | Name | Description
Public property | DescriptorSize | Get the number of elements in the descriptor. (Inherited from Feature2D.)
Public property | Feature2DPtr | Get the pointer to the Feature2D object (Inherited from Feature2D.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

VGG Class
Emgu.CV.XFeatures2D Namespace


VGG Methods

The VGG type exposes the following members.

Methods
 | Name | Description
Public method | Compute | Compute the descriptors on the image from the given keypoint locations. (Inherited from Feature2D.)
Public method | Detect | Detect the keypoints from the image (Inherited from Feature2D.)
Public method | DetectAndCompute | Detect keypoints in an image and compute the descriptors on the image from the keypoint locations. (Inherited from Feature2D.)
Public method | DetectRaw | Detect the features in the image (Inherited from Feature2D.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged resource associated with VGG (Overrides Feature2DDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VGG Class
Emgu.CV.XFeatures2D Namespace


VGG.DisposeObject Method

VGGDisposeObject Method

Release all the unmanaged resource associated with VGG

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

VGG Class
Emgu.CV.XFeatures2D Namespace


VGG Fields

The VGG type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithm | The pointer to the Algorithm object. (Inherited from Feature2D.)
Protected field | _feature2D | The pointer to the Feature2D object (Inherited from Feature2D.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

VGG Class
Emgu.CV.XFeatures2D Namespace


VGG.DescriptorType Class

VGGDescriptorType Class

The VGG descriptor type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XFeatures2DVGGDescriptorType

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DescriptorType : Enum
Public NotInheritable Class DescriptorType
    Inherits Enum
public ref class DescriptorType sealed : public Enum
[<SealedAttribute>]
type DescriptorType =
    class
        inherit Enum
    end

The VGGDescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
Public field | value__ |
 | Vgg120 | 120 dimension float
 | Vgg48 | 48 dimension float
 | Vgg64 | 64 dimension float
 | Vgg80 | 80 dimension float
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


DescriptorType Methods

The VGGDescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

VGGDescriptorType Class
Emgu.CV.XFeatures2D Namespace


DescriptorType Fields

The VGGDescriptorType type exposes the following members.

Fields
 | Name | Description
Public field | value__ |
 | Vgg120 | 120 dimension float
 | Vgg48 | 48 dimension float
 | Vgg64 | 64 dimension float
 | Vgg80 | 80 dimension float
Top
See Also

Reference

VGGDescriptorType Class
Emgu.CV.XFeatures2D Namespace


VGG.DescriptorType.value__ Field

VGGDescriptorTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XFeatures2D.VGG.DescriptorType.value__"]

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

VGGDescriptorType Class
Emgu.CV.XFeatures2D Namespace


VGG.DescriptorType.Vgg120 Field

VGGDescriptorTypeVgg120 Field

120 dimension float

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VGGDescriptorType Vgg120 = 100
Public Const Vgg120 As VGGDescriptorType = 100
public:
literal VGGDescriptorType^ Vgg120 = 100
static val mutable Vgg120: VGGDescriptorType

Field Value

Type: VGGDescriptorType
See Also

Reference

VGGDescriptorType Class
Emgu.CV.XFeatures2D Namespace


VGG.DescriptorType.Vgg48 Field

VGGDescriptorTypeVgg48 Field

48 dimension float

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VGGDescriptorType Vgg48 = 103
Public Const Vgg48 As VGGDescriptorType = 103
public:
literal VGGDescriptorType^ Vgg48 = 103
static val mutable Vgg48: VGGDescriptorType

Field Value

Type: VGGDescriptorType
See Also

Reference

VGGDescriptorType Class
Emgu.CV.XFeatures2D Namespace


VGG.DescriptorType.Vgg64 Field

VGGDescriptorTypeVgg64 Field

64 dimension float

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VGGDescriptorType Vgg64 = 102
Public Const Vgg64 As VGGDescriptorType = 102
public:
literal VGGDescriptorType^ Vgg64 = 102
static val mutable Vgg64: VGGDescriptorType

Field Value

Type: VGGDescriptorType
See Also

Reference

VGGDescriptorType Class
Emgu.CV.XFeatures2D Namespace


VGG.DescriptorType.Vgg80 Field

VGGDescriptorTypeVgg80 Field

80 dimension float

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const VGGDescriptorType Vgg80 = 101
Public Const Vgg80 As VGGDescriptorType = 101
public:
literal VGGDescriptorType^ Vgg80 = 101
static val mutable Vgg80: VGGDescriptorType

Field Value

Type: VGGDescriptorType
See Also

Reference

VGGDescriptorType Class
Emgu.CV.XFeatures2D Namespace


XFeatures2DInvoke Class

This class wraps the functional calls to the OpenCV XFeatures2D modules
Inheritance Hierarchy
SystemObject
Emgu.CV.XFeatures2DXFeatures2DInvoke

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class XFeatures2DInvoke
Public NotInheritable Class XFeatures2DInvoke
public ref class XFeatures2DInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XFeatures2DInvoke =  class end

The XFeatures2DInvoke type exposes the following members.

Methods
Name | Description
MatchGMS | GMS (Grid-based Motion Statistics) feature matching strategy
Top
See Also

Reference

Emgu.CV.XFeatures2D Namespace


XFeatures2DInvoke Methods

The XFeatures2DInvoke type exposes the following members.

Methods
Name | Description
MatchGMS | GMS (Grid-based Motion Statistics) feature matching strategy
Top
See Also

Reference

XFeatures2DInvoke Class
Emgu.CV.XFeatures2D Namespace


XFeatures2DInvoke.MatchGMS Method

XFeatures2DInvokeMatchGMS Method

GMS (Grid-based Motion Statistics) feature matching strategy

Namespace: Emgu.CV.XFeatures2D
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void MatchGMS(
    Size size1,
    Size size2,
    VectorOfKeyPoint keypoints1,
    VectorOfKeyPoint keypoints2,
    VectorOfDMatch matches1to2,
    VectorOfDMatch matchesGMS,
    bool withRotation = false,
    bool withScale = false,
    double thresholdFactor = 6
)
Public Shared Sub MatchGMS (
    size1 As Size,
    size2 As Size,
    keypoints1 As VectorOfKeyPoint,
    keypoints2 As VectorOfKeyPoint,
    matches1to2 As VectorOfDMatch,
    matchesGMS As VectorOfDMatch,
    Optional withRotation As Boolean = false,
    Optional withScale As Boolean = false,
    Optional thresholdFactor As Double = 6
)
public:
static void MatchGMS(
    Size^ size1,
    Size^ size2,
    VectorOfKeyPoint^ keypoints1,
    VectorOfKeyPoint^ keypoints2,
    VectorOfDMatch^ matches1to2,
    VectorOfDMatch^ matchesGMS,
    bool withRotation = false,
    bool withScale = false,
    double thresholdFactor = 6
)
static member MatchGMS :
        size1 : Size *
        size2 : Size *
        keypoints1 : VectorOfKeyPoint *
        keypoints2 : VectorOfKeyPoint *
        matches1to2 : VectorOfDMatch *
        matchesGMS : VectorOfDMatch *
        ?withRotation : bool *
        ?withScale : bool *
        ?thresholdFactor : float
(* Defaults:
        let _withRotation = defaultArg withRotation false
        let _withScale = defaultArg withScale false
        let _thresholdFactor = defaultArg thresholdFactor 6
*)
-> unit

Parameters

size1
Type: System.DrawingSize
Input size of image1.
size2
Type: System.DrawingSize
Input size of image2.
keypoints1
Type: Emgu.CV.UtilVectorOfKeyPoint
Input keypoints of image1.
keypoints2
Type: Emgu.CV.UtilVectorOfKeyPoint
Input keypoints of image2.
matches1to2
Type: Emgu.CV.UtilVectorOfDMatch
Input 1-nearest neighbor matches.
matchesGMS
Type: Emgu.CV.UtilVectorOfDMatch
Matches returned by the GMS matching strategy.
withRotation (Optional)
Type: SystemBoolean
Take rotation transformation into account.
withScale (Optional)
Type: SystemBoolean
Take scale transformation into account.
thresholdFactor (Optional)
Type: SystemDouble
The higher, the less matches.
See Also

Reference

XFeatures2DInvoke Class
Emgu.CV.XFeatures2D Namespace


Emgu.CV.XImgproc Namespace

Extended Image Processing
Classes
 | Class | Description
Public class | DisparityWLSFilter | Disparity map filter based on Weighted Least Squares filter (in form of Fast Global Smoother that is a lot faster than traditional Weighted Least Squares filter implementations) and optional use of left-right-consistency-based confidence to refine the results in half-occlusions and uniform areas.
Public class | DTFilter | Interface for realizations of Domain Transform filter.
Public class | DTFilterMode | The three modes for filtering 2D signals in the article.
Public class | DtFilterType | Domain Transform filter type
Public class | EdgeBoxes | Class implementing EdgeBoxes algorithm from C. Lawrence Zitnick and Piotr Dollár. Edge boxes: Locating object proposals from edges. In ECCV, 2014.
Public class | FastLineDetector | Class implementing the FLD (Fast Line Detector) algorithm
Public class | GraphSegmentation | Graph Based Segmentation Algorithm. The class implements the algorithm described in Pedro F Felzenszwalb and Daniel P Huttenlocher. Efficient graph-based image segmentation. volume 59, pages 167 - 181. Springer, 2004.
Public class | LocalBinarizationMethods | LocalBinarizationMethods type
Public class | RFFeatureGetter | Helper class for training part of [P. Dollar and C. L. Zitnick. Structured Forests for Fast Edge Detection, 2013].
Public class | RidgeDetectionFilter | Applies Ridge Detection Filter to an input image. Implements Ridge detection similar to the one in [Mathematica] (http://reference.wolfram.com/language/ref/RidgeFilter.html) using the eigen values from the Hessian Matrix of the input image using Sobel Derivatives. Additional refinement can be done using Skeletonization and Binarization.
Public class | RightMatcher | The matcher for computing the right-view disparity map that is required in case of filtering with confidence.
Public class | SelectiveSearchSegmentation | Selective search segmentation algorithm The class implements the algorithm described in: Jasper RR Uijlings, Koen EA van de Sande, Theo Gevers, and Arnold WM Smeulders. Selective search for object recognition. International journal of computer vision, 104(2):154–171, 2013.
Public class | StructuredEdgeDetection | Class implementing edge detection algorithm from Piotr Dollar and C Lawrence Zitnick. Structured forests for fast edge detection. In Computer Vision (ICCV), 2013 IEEE International Conference on, pages 1841-1848. IEEE, 2013.
Public class | SuperpixelLSC | Class implementing the LSC (Linear Spectral Clustering) superpixels algorithm described in "Zhengqin Li and Jiansheng Chen. Superpixel segmentation using linear spectral clustering. June 2015."
Public class | SupperpixelSEEDS | Class implementing the SEEDS (Superpixels Extracted via Energy-Driven Sampling) superpixels algorithm described in Michael Van den Bergh, Xavier Boix, Gemma Roig, Benjamin de Capitani, and Luc Van Gool. Seeds: Superpixels extracted via energy-driven sampling. In Computer Vision-ECCV 2012, pages 13-26. Springer, 2012.
Public class | SupperpixelSLIC | Class implementing the SLIC (Simple Linear Iterative Clustering) superpixels algorithm described in Radhakrishna Achanta, Appu Shaji, Kevin Smith, Aurelien Lucchi, Pascal Fua, and Sabine Susstrunk. Slic superpixels compared to state-of-the-art superpixel methods. IEEE Trans. Pattern Anal. Mach. Intell., 34(11):2274-2282, nov 2012.
Public class | SupperpixelSLICAlgorithm | The algorithm to use
Public class | ThinningTypes | Thinning type
Public class | WMFWeightType | Weight type
Public class | XImgprocInvoke | Library to invoke XImgproc functions
Interfaces
 | Interface | Description
Public interface | IDisparityFilter | Main interface for all disparity map filters.


DisparityWLSFilter Class

Disparity map filter based on Weighted Least Squares filter (in form of Fast Global Smoother that is a lot faster than traditional Weighted Least Squares filter implementations) and optional use of left-right-consistency-based confidence to refine the results in half-occlusions and uniform areas.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.XImgprocDisparityWLSFilter

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DisparityWLSFilter : SharedPtrObject,
    IAlgorithm, IDisparityFilter
Public Class DisparityWLSFilter
    Inherits SharedPtrObject
    Implements IAlgorithm, IDisparityFilter
public ref class DisparityWLSFilter : public SharedPtrObject,
    IAlgorithm, IDisparityFilter
type DisparityWLSFilter =
    class
        inherit SharedPtrObject
        interface IAlgorithm
        interface IDisparityFilter
    end

The DisparityWLSFilter type exposes the following members.

Constructors
 | Name | Description
Public method | DisparityWLSFilter(Boolean) | Create instance of DisparityWLSFilter and execute basic initialization routines. When using this method you will need to set-up the ROI, matchers and other parameters by yourself.
Public method | DisparityWLSFilter(IStereoMatcher) | Creates an instance of DisparityWLSFilter and sets up all the relevant filter parameters automatically based on the matcher instance. Currently supports only StereoBM and StereoSGBM.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | DisparityFilterPtr | Pointer to the native DisparityFilter
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this DisparityWLSFilter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Filter | Apply filtering to the disparity map. (Defined by XImgprocInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


DisparityWLSFilter Constructor

Overload List
 | Name | Description
Public method | DisparityWLSFilter(Boolean) | Create instance of DisparityWLSFilter and execute basic initialization routines. When using this method you will need to set-up the ROI, matchers and other parameters by yourself.
Public method | DisparityWLSFilter(IStereoMatcher) | Creates an instance of DisparityWLSFilter and sets up all the relevant filter parameters automatically based on the matcher instance. Currently supports only StereoBM and StereoSGBM.
Top
See Also

Reference

DisparityWLSFilter Class
Emgu.CV.XImgproc Namespace


DisparityWLSFilter Constructor (Boolean)

Create instance of DisparityWLSFilter and execute basic initialization routines. When using this method you will need to set-up the ROI, matchers and other parameters by yourself.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DisparityWLSFilter(
    bool useConfidence
)
Public Sub New (
    useConfidence As Boolean
)
public:
DisparityWLSFilter(
    bool useConfidence
)
new :
        useConfidence : bool -> DisparityWLSFilter

Parameters

useConfidence
Type: SystemBoolean
Filtering with confidence requires two disparity maps (for the left and right views) and is approximately two times slower. However, quality is typically significantly better.
See Also

Reference

DisparityWLSFilter Class
DisparityWLSFilter Overload
Emgu.CV.XImgproc Namespace


DisparityWLSFilter Constructor (IStereoMatcher)

Creates an instance of DisparityWLSFilter and sets up all the relevant filter parameters automatically based on the matcher instance. Currently supports only StereoBM and StereoSGBM.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DisparityWLSFilter(
    IStereoMatcher matcherLeft
)
Public Sub New (
    matcherLeft As IStereoMatcher
)
public:
DisparityWLSFilter(
    IStereoMatcher^ matcherLeft
)
new :
        matcherLeft : IStereoMatcher -> DisparityWLSFilter

Parameters

matcherLeft
Type: Emgu.CVIStereoMatcher
stereo matcher instance that will be used with the filter
See Also

Reference

DisparityWLSFilter Class
DisparityWLSFilter Overload
Emgu.CV.XImgproc Namespace


DisparityWLSFilter Properties

The DisparityWLSFilter type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | DisparityFilterPtr | Pointer to the native DisparityFilter
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DisparityWLSFilter Class
Emgu.CV.XImgproc Namespace


DisparityWLSFilter.AlgorithmPtr Property

DisparityWLSFilterAlgorithmPtr Property

Pointer to cv::Algorithm

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

DisparityWLSFilter Class
Emgu.CV.XImgproc Namespace


DisparityWLSFilter.DisparityFilterPtr Property

DisparityWLSFilterDisparityFilterPtr Property

Pointer to the native DisparityFilter

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr DisparityFilterPtr { get; }
Public ReadOnly Property DisparityFilterPtr As IntPtr
    Get
public:
virtual property IntPtr DisparityFilterPtr {
    IntPtr get () sealed;
}
abstract DisparityFilterPtr : IntPtr with get
override DisparityFilterPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IDisparityFilterDisparityFilterPtr
See Also

Reference

DisparityWLSFilter Class
Emgu.CV.XImgproc Namespace


DisparityWLSFilter Methods

The DisparityWLSFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this DisparityWLSFilter (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | Filter | Apply filtering to the disparity map. (Defined by XImgprocInvoke.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

DisparityWLSFilter Class
Emgu.CV.XImgproc Namespace


DisparityWLSFilter.DisposeObject Method

DisparityWLSFilterDisposeObject Method

Release the unmanaged memory associated with this DisparityWLSFilter

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DisparityWLSFilter Class
Emgu.CV.XImgproc Namespace


DisparityWLSFilter Fields

The DisparityWLSFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

DisparityWLSFilter Class
Emgu.CV.XImgproc Namespace


DTFilter Class

Interface for realizations of Domain Transform filter.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocDTFilter

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class DTFilter : UnmanagedObject
Public Class DTFilter
    Inherits UnmanagedObject
public ref class DTFilter : public UnmanagedObject
type DTFilter =
    class
        inherit UnmanagedObject
    end

The DTFilter type exposes the following members.

Constructors
 | Name | Description
Public method | DTFilter | Create instance of DTFilter and produce initialization routines.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter | Produce domain transform filtering operation on source image.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


DTFilter Constructor

Create instance of DTFilter and produce initialization routines.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public DTFilter(
    IInputArray guide,
    double sigmaSpatial,
    double sigmaColor,
    DTFilterMode mode = 0,
    int numIters = 3
)
Public Sub New (
    guide As IInputArray,
    sigmaSpatial As Double,
    sigmaColor As Double,
    Optional mode As DTFilterMode = 0,
    Optional numIters As Integer = 3
)
public:
DTFilter(
    IInputArray^ guide,
    double sigmaSpatial,
    double sigmaColor,
    DTFilterMode^ mode = 0,
    int numIters = 3
)
new :
        guide : IInputArray *
        sigmaSpatial : float *
        sigmaColor : float *
        ?mode : DTFilterMode *
        ?numIters : int
(* Defaults:
        let _mode = defaultArg mode 0
        let _numIters = defaultArg numIters 3
*)
-> DTFilter

Parameters

guide
Type: Emgu.CVIInputArray
Guided image (used to build transformed distance, which describes edge structure of guided image).
sigmaSpatial
Type: SystemDouble
Parameter in the original article, it's similar to the sigma in the coordinate space into bilateralFilter.
sigmaColor
Type: SystemDouble
Parameter in the original article, it's similar to the sigma in the color space into bilateralFilter.
mode (Optional)
Type: Emgu.CV.XImgprocDTFilterMode
One form three modes DTF_NC, DTF_RF and DTF_IC which corresponds to three modes for filtering 2D signals in the article.
numIters (Optional)
Type: SystemInt32
Optional number of iterations used for filtering, 3 is quite enough.
See Also

Reference

DTFilter Class
Emgu.CV.XImgproc Namespace


DTFilter Properties

The DTFilter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DTFilter Class
Emgu.CV.XImgproc Namespace


DTFilter Methods

The DTFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter | Produce domain transform filtering operation on source image.
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DTFilter Class
Emgu.CV.XImgproc Namespace


DTFilter.DisposeObject Method

DTFilterDisposeObject Method

Release the unmanaged memory associated with this object

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

DTFilter Class
Emgu.CV.XImgproc Namespace


DTFilter.Filter Method

DTFilterFilter Method

Produce domain transform filtering operation on source image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Filter(
    IInputArray src,
    IOutputArray dst,
    DepthType dDepth = -1
)
Public Sub Filter (
    src As IInputArray,
    dst As IOutputArray,
    Optional dDepth As DepthType = -1
)
public:
void Filter(
    IInputArray^ src,
    IOutputArray^ dst,
    DepthType^ dDepth = -1
)
member Filter :
        src : IInputArray *
        dst : IOutputArray *
        ?dDepth : DepthType
(* Defaults:
        let _dDepth = defaultArg dDepth -1
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Filtering image with unsigned 8-bit or floating-point 32-bit depth and up to 4 channels.
dst
Type: Emgu.CVIOutputArray
Destination image.
dDepth (Optional)
Type: Emgu.CV.CvEnumDepthType
Optional depth of the output image. dDepth can be set to Default, which will be equivalent to src.depth().
See Also

Reference

DTFilter Class
Emgu.CV.XImgproc Namespace


DTFilter Fields

The DTFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

DTFilter Class
Emgu.CV.XImgproc Namespace


DTFilter.Mode Class

DTFilterMode Class

The three modes for filtering 2D signals in the article.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XImgprocDTFilterMode

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Mode : Enum
Public NotInheritable Class Mode
    Inherits Enum
public ref class Mode sealed : public Enum
[<SealedAttribute>]
type Mode =
    class
        inherit Enum
    end

The DTFilterMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | IC | IC
 | NC | NC
 | RF | RF
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


Mode Methods

The DTFilterMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DTFilterMode Class
Emgu.CV.XImgproc Namespace


Mode Fields

The DTFilterMode type exposes the following members.

Fields
 | Name | Description
 | IC | IC
 | NC | NC
 | RF | RF
Public field | value__ |
Top
See Also

Reference

DTFilterMode Class
Emgu.CV.XImgproc Namespace


DTFilter.Mode.IC Field

DTFilterModeIC Field

IC

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DTFilterMode IC = 1
Public Const IC As DTFilterMode = 1
public:
literal DTFilterMode^ IC = 1
static val mutable IC: DTFilterMode

Field Value

Type: DTFilterMode
See Also

Reference

DTFilterMode Class
Emgu.CV.XImgproc Namespace


DTFilter.Mode.NC Field

DTFilterModeNC Field

NC

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DTFilterMode NC = 0
Public Const NC As DTFilterMode = 0
public:
literal DTFilterMode^ NC = 0
static val mutable NC: DTFilterMode

Field Value

Type: DTFilterMode
See Also

Reference

DTFilterMode Class
Emgu.CV.XImgproc Namespace


DTFilter.Mode.RF Field

DTFilterModeRF Field

RF

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DTFilterMode RF = 2
Public Const RF As DTFilterMode = 2
public:
literal DTFilterMode^ RF = 2
static val mutable RF: DTFilterMode

Field Value

Type: DTFilterMode
See Also

Reference

DTFilterMode Class
Emgu.CV.XImgproc Namespace


DTFilter.Mode.value__ Field

DTFilterModevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XImgproc.DTFilter.Mode.value__"]

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DTFilterMode Class
Emgu.CV.XImgproc Namespace


DtFilterType Class

Domain Transform filter type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XImgprocDtFilterType

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class DtFilterType : Enum
Public NotInheritable Class DtFilterType
    Inherits Enum
public ref class DtFilterType sealed : public Enum
[<SealedAttribute>]
type DtFilterType =
    class
        inherit Enum
    end

The DtFilterType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | IC | IC
 | NC | NC
 | RF | RF
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


DtFilterType Methods

The DtFilterType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

DtFilterType Class
Emgu.CV.XImgproc Namespace


DtFilterType Fields

The DtFilterType type exposes the following members.

Fields
 | Name | Description
 | IC | IC
 | NC | NC
 | RF | RF
Public field | value__ |
Top
See Also

Reference

DtFilterType Class
Emgu.CV.XImgproc Namespace


DtFilterType.IC Field

DtFilterTypeIC Field

IC

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DtFilterType IC = 1
Public Const IC As DtFilterType = 1
public:
literal DtFilterType^ IC = 1
static val mutable IC: DtFilterType

Field Value

Type: DtFilterType
See Also

Reference

DtFilterType Class
Emgu.CV.XImgproc Namespace


DtFilterType.NC Field

DtFilterTypeNC Field

NC

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DtFilterType NC = 0
Public Const NC As DtFilterType = 0
public:
literal DtFilterType^ NC = 0
static val mutable NC: DtFilterType

Field Value

Type: DtFilterType
See Also

Reference

DtFilterType Class
Emgu.CV.XImgproc Namespace


DtFilterType.RF Field

DtFilterTypeRF Field

RF

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const DtFilterType RF = 2
Public Const RF As DtFilterType = 2
public:
literal DtFilterType^ RF = 2
static val mutable RF: DtFilterType

Field Value

Type: DtFilterType
See Also

Reference

DtFilterType Class
Emgu.CV.XImgproc Namespace


DtFilterType.value__ Field

DtFilterTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XImgproc.DtFilterType.value__"]

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

DtFilterType Class
Emgu.CV.XImgproc Namespace


EdgeBoxes Class

Class implementing EdgeBoxes algorithm from C. Lawrence Zitnick and Piotr Dollár. Edge boxes: Locating object proposals from edges. In ECCV, 2014.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.XImgprocEdgeBoxes

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class EdgeBoxes : SharedPtrObject, IAlgorithm
Public Class EdgeBoxes
    Inherits SharedPtrObject
    Implements IAlgorithm
public ref class EdgeBoxes : public SharedPtrObject,
    IAlgorithm
type EdgeBoxes =
    class
        inherit SharedPtrObject
        interface IAlgorithm
    end

The EdgeBoxes type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeBoxes | Create an EdgeBox
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBoundingBoxes | Returns array containing proposal boxes.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


EdgeBoxes Constructor

Create an EdgeBox

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EdgeBoxes(
    float alpha = 0.65f,
    float beta = 0.75f,
    float eta = 1f,
    float minScore = 0.01f,
    int maxBoxes = 10000,
    float edgeMinMag = 1f,
    float edgeMergeThr = 0.5f,
    float clusterMinMag = 0.5f,
    float maxAspectRatio = 3f,
    float minBoxArea = 1000f,
    float gamma = 2f,
    float kappa = 1.5f
)
Public Sub New (
    Optional alpha As Single = 0.65F,
    Optional beta As Single = 0.75F,
    Optional eta As Single = 1F,
    Optional minScore As Single = 0.01F,
    Optional maxBoxes As Integer = 10000,
    Optional edgeMinMag As Single = 1F,
    Optional edgeMergeThr As Single = 0.5F,
    Optional clusterMinMag As Single = 0.5F,
    Optional maxAspectRatio As Single = 3F,
    Optional minBoxArea As Single = 1000F,
    Optional gamma As Single = 2F,
    Optional kappa As Single = 1.5F
)
public:
EdgeBoxes(
    float alpha = 0.65f,
    float beta = 0.75f,
    float eta = 1f,
    float minScore = 0.01f,
    int maxBoxes = 10000,
    float edgeMinMag = 1f,
    float edgeMergeThr = 0.5f,
    float clusterMinMag = 0.5f,
    float maxAspectRatio = 3f,
    float minBoxArea = 1000f,
    float gamma = 2f,
    float kappa = 1.5f
)
new :
        ?alpha : float32 *
        ?beta : float32 *
        ?eta : float32 *
        ?minScore : float32 *
        ?maxBoxes : int *
        ?edgeMinMag : float32 *
        ?edgeMergeThr : float32 *
        ?clusterMinMag : float32 *
        ?maxAspectRatio : float32 *
        ?minBoxArea : float32 *
        ?gamma : float32 *
        ?kappa : float32
(* Defaults:
        let _alpha = defaultArg alpha 0.65f
        let _beta = defaultArg beta 0.75f
        let _eta = defaultArg eta 1f
        let _minScore = defaultArg minScore 0.01f
        let _maxBoxes = defaultArg maxBoxes 10000
        let _edgeMinMag = defaultArg edgeMinMag 1f
        let _edgeMergeThr = defaultArg edgeMergeThr 0.5f
        let _clusterMinMag = defaultArg clusterMinMag 0.5f
        let _maxAspectRatio = defaultArg maxAspectRatio 3f
        let _minBoxArea = defaultArg minBoxArea 1000f
        let _gamma = defaultArg gamma 2f
        let _kappa = defaultArg kappa 1.5f
*)
-> EdgeBoxes

Parameters

alpha (Optional)
Type: SystemSingle
Step size of sliding window search.
beta (Optional)
Type: SystemSingle
Nms threshold for object proposals.
eta (Optional)
Type: SystemSingle
Adaptation rate for nms threshold.
minScore (Optional)
Type: SystemSingle
Min score of boxes to detect.
maxBoxes (Optional)
Type: SystemInt32
Max number of boxes to detect.
edgeMinMag (Optional)
Type: SystemSingle
Edge min magnitude. Increase to trade off accuracy for speed.
edgeMergeThr (Optional)
Type: SystemSingle
Edge merge threshold. Increase to trade off accuracy for speed.
clusterMinMag (Optional)
Type: SystemSingle
Cluster min magnitude. Increase to trade off accuracy for speed.
maxAspectRatio (Optional)
Type: SystemSingle
Max aspect ratio of boxes.
minBoxArea (Optional)
Type: SystemSingle
Minimum area of boxes.
gamma (Optional)
Type: SystemSingle
Affinity sensitivity.
kappa (Optional)
Type: SystemSingle
Scale sensitivity.
See Also

Reference

EdgeBoxes Class
Emgu.CV.XImgproc Namespace


EdgeBoxes Properties

The EdgeBoxes type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

EdgeBoxes Class
Emgu.CV.XImgproc Namespace


EdgeBoxes.AlgorithmPtr Property

EdgeBoxesAlgorithmPtr Property

Pointer to cv::Algorithm

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

EdgeBoxes Class
Emgu.CV.XImgproc Namespace


EdgeBoxes Methods

The EdgeBoxes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetBoundingBoxes | Returns array containing proposal boxes.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

EdgeBoxes Class
Emgu.CV.XImgproc Namespace


EdgeBoxes.DisposeObject Method

EdgeBoxesDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

EdgeBoxes Class
Emgu.CV.XImgproc Namespace


EdgeBoxes.GetBoundingBoxes Method

EdgeBoxesGetBoundingBoxes Method

Returns array containing proposal boxes.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle[] GetBoundingBoxes(
    IInputArray edgeMap,
    IInputArray orientationMap
)
Public Function GetBoundingBoxes (
    edgeMap As IInputArray,
    orientationMap As IInputArray
) As Rectangle()
public:
array<Rectangle^>^ GetBoundingBoxes(
    IInputArray^ edgeMap,
    IInputArray^ orientationMap
)
member GetBoundingBoxes :
        edgeMap : IInputArray *
        orientationMap : IInputArray -> Rectangle[]

Parameters

edgeMap
Type: Emgu.CVIInputArray
edge image.
orientationMap
Type: Emgu.CVIInputArray
orientation map.

Return Value

Type: Rectangle
Proposal boxes.
See Also

Reference

EdgeBoxes Class
Emgu.CV.XImgproc Namespace


EdgeBoxes Fields

The EdgeBoxes type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

EdgeBoxes Class
Emgu.CV.XImgproc Namespace


FastLineDetector Class

Class implementing the FLD (Fast Line Detector) algorithm
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.XImgprocFastLineDetector

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class FastLineDetector : SharedPtrObject
Public Class FastLineDetector
    Inherits SharedPtrObject
public ref class FastLineDetector : public SharedPtrObject
type FastLineDetector =
    class
        inherit SharedPtrObject
    end

The FastLineDetector type exposes the following members.

Constructors
 | Name | Description
Public method | FastLineDetector | Initializes a new instance of the FastLineDetector object.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Detect | Finds lines in the input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | DrawSegments | Draws the line segments on a given image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


FastLineDetector Constructor

Initializes a new instance of the FastLineDetector object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public FastLineDetector(
    int lengthThreshold = 10,
    float distanceThreshold = 1.414214f,
    double cannyThreshold1 = 50,
    double cannyThreshold2 = 50,
    int cannyApertureSize = 3,
    bool doMerge = false
)
Public Sub New (
    Optional lengthThreshold As Integer = 10,
    Optional distanceThreshold As Single = 1.414214F,
    Optional cannyThreshold1 As Double = 50,
    Optional cannyThreshold2 As Double = 50,
    Optional cannyApertureSize As Integer = 3,
    Optional doMerge As Boolean = false
)
public:
FastLineDetector(
    int lengthThreshold = 10,
    float distanceThreshold = 1.414214f,
    double cannyThreshold1 = 50,
    double cannyThreshold2 = 50,
    int cannyApertureSize = 3,
    bool doMerge = false
)
new :
        ?lengthThreshold : int *
        ?distanceThreshold : float32 *
        ?cannyThreshold1 : float *
        ?cannyThreshold2 : float *
        ?cannyApertureSize : int *
        ?doMerge : bool
(* Defaults:
        let _lengthThreshold = defaultArg lengthThreshold 10
        let _distanceThreshold = defaultArg distanceThreshold 1.414214f
        let _cannyThreshold1 = defaultArg cannyThreshold1 50
        let _cannyThreshold2 = defaultArg cannyThreshold2 50
        let _cannyApertureSize = defaultArg cannyApertureSize 3
        let _doMerge = defaultArg doMerge false
*)
-> FastLineDetector

Parameters

lengthThreshold (Optional)
Type: SystemInt32
Segment shorter than this will be discarded.
distanceThreshold (Optional)
Type: SystemSingle
A point placed from a hypothesis line segment farther than this will be regarded as an outlier.
cannyThreshold1 (Optional)
Type: SystemDouble
First threshold for hysteresis procedure in Canny().
cannyThreshold2 (Optional)
Type: SystemDouble
Second threshold for hysteresis procedure in Canny().
cannyApertureSize (Optional)
Type: SystemInt32
Aperture size for the Sobel operator in Canny().
doMerge (Optional)
Type: SystemBoolean
If true, incremental merging of segments will be performed
See Also

Reference

FastLineDetector Class
Emgu.CV.XImgproc Namespace


FastLineDetector Properties

The FastLineDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FastLineDetector Class
Emgu.CV.XImgproc Namespace


FastLineDetector Methods

The FastLineDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Finds lines in the input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | DrawSegments | Draws the line segments on a given image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FastLineDetector Class
Emgu.CV.XImgproc Namespace


FastLineDetector.Detect Method

FastLineDetectorDetect Method

Finds lines in the input image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LineSegment2DF[] Detect(
    IInputArray image
)
Public Function Detect (
    image As IInputArray
) As LineSegment2DF()
public:
array<LineSegment2DF^>^ Detect(
    IInputArray^ image
)
member Detect :
        image : IInputArray -> LineSegment2DF[]

Parameters

image
Type: Emgu.CVIInputArray
Image to detect lines in.

Return Value

Type: LineSegment2DF
The detected line segments
See Also

Reference

FastLineDetector Class
Emgu.CV.XImgproc Namespace


FastLineDetector.DisposeObject Method

FastLineDetectorDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

FastLineDetector Class
Emgu.CV.XImgproc Namespace


FastLineDetector.DrawSegments Method

FastLineDetectorDrawSegments Method

Draws the line segments on a given image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DrawSegments(
    IInputOutputArray image,
    LineSegment2DF[] lines,
    bool drawArrows = false
)
Public Sub DrawSegments (
    image As IInputOutputArray,
    lines As LineSegment2DF(),
    Optional drawArrows As Boolean = false
)
public:
void DrawSegments(
    IInputOutputArray^ image,
    array<LineSegment2DF^>^ lines,
    bool drawArrows = false
)
member DrawSegments :
        image : IInputOutputArray *
        lines : LineSegment2DF[] *
        ?drawArrows : bool
(* Defaults:
        let _drawArrows = defaultArg drawArrows false
*)
-> unit

Parameters

image
Type: Emgu.CVIInputOutputArray
The image, where the lines will be drawn. Should be bigger or equal to the image, where the lines were found.
lines
Type: Emgu.CV.StructureLineSegment2DF
A vector of the lines that needed to be drawn.
drawArrows (Optional)
Type: SystemBoolean
If true, arrow heads will be drawn.
See Also

Reference

FastLineDetector Class
Emgu.CV.XImgproc Namespace


FastLineDetector Fields

The FastLineDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

FastLineDetector Class
Emgu.CV.XImgproc Namespace


GraphSegmentation Class

Graph Based Segmentation Algorithm. The class implements the algorithm described in Pedro F Felzenszwalb and Daniel P Huttenlocher. Efficient graph-based image segmentation. volume 59, pages 167 - 181. Springer, 2004.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocGraphSegmentation

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GraphSegmentation : UnmanagedObject
Public Class GraphSegmentation
    Inherits UnmanagedObject
public ref class GraphSegmentation : public UnmanagedObject
type GraphSegmentation =
    class
        inherit UnmanagedObject
    end

The GraphSegmentation type exposes the following members.

Constructors
 | Name | Description
Public method | GraphSegmentation | Creates a graph based segmentor.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessImage | Segment an image and store output in dst.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


GraphSegmentation Constructor

Creates a graph based segmentor.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GraphSegmentation(
    double sigma = 0.5,
    float k = 300f,
    int minSize = 100
)
Public Sub New (
    Optional sigma As Double = 0.5,
    Optional k As Single = 300F,
    Optional minSize As Integer = 100
)
public:
GraphSegmentation(
    double sigma = 0.5,
    float k = 300f,
    int minSize = 100
)
new :
        ?sigma : float *
        ?k : float32 *
        ?minSize : int
(* Defaults:
        let _sigma = defaultArg sigma 0.5
        let _k = defaultArg k 300f
        let _minSize = defaultArg minSize 100
*)
-> GraphSegmentation

Parameters

sigma (Optional)
Type: SystemDouble
The sigma parameter, used to smooth image
k (Optional)
Type: SystemSingle
The k parameter of the algorithm
minSize (Optional)
Type: SystemInt32
The minimum size of segments
See Also

Reference

GraphSegmentation Class
Emgu.CV.XImgproc Namespace


GraphSegmentation Properties

The GraphSegmentation type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GraphSegmentation Class
Emgu.CV.XImgproc Namespace


GraphSegmentation Methods

The GraphSegmentation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessImage | Segment an image and store output in dst.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GraphSegmentation Class
Emgu.CV.XImgproc Namespace


GraphSegmentation.DisposeObject Method

GraphSegmentationDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

GraphSegmentation Class
Emgu.CV.XImgproc Namespace


GraphSegmentation.ProcessImage Method

GraphSegmentationProcessImage Method

Segment an image and store output in dst.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ProcessImage(
    IInputArray src,
    IOutputArray dst
)
Public Sub ProcessImage (
    src As IInputArray,
    dst As IOutputArray
)
public:
void ProcessImage(
    IInputArray^ src,
    IOutputArray^ dst
)
member ProcessImage :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
The input image. Any number of channel (1 (Eg: Gray), 3 (Eg: RGB), 4 (Eg: RGB-D)) can be provided
dst
Type: Emgu.CVIOutputArray
The output segmentation. It's a CV_32SC1 Mat with the same number of cols and rows as input image, with an unique, sequential, id for each pixel.
See Also

Reference

GraphSegmentation Class
Emgu.CV.XImgproc Namespace


GraphSegmentation Fields

The GraphSegmentation type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

GraphSegmentation Class
Emgu.CV.XImgproc Namespace


IDisparityFilter Interface

Main interface for all disparity map filters.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IDisparityFilter
Public Interface IDisparityFilter
public interface class IDisparityFilter
type IDisparityFilter =  interface end

The IDisparityFilter type exposes the following members.

Properties
 | Name | Description
Public property | DisparityFilterPtr | Pointer to the native diaprty filter object
Top
Extension Methods
 | Name | Description
Public Extension Method | Filter | Apply filtering to the disparity map. (Defined by XImgprocInvoke.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


IDisparityFilter Properties

The IDisparityFilter type exposes the following members.

Properties
 | Name | Description
Public property | DisparityFilterPtr | Pointer to the native diaprty filter object
Top
See Also

Reference

IDisparityFilter Interface
Emgu.CV.XImgproc Namespace


IDisparityFilter.DisparityFilterPtr Property

IDisparityFilterDisparityFilterPtr Property

Pointer to the native diaprty filter object

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
IntPtr DisparityFilterPtr { get; }
ReadOnly Property DisparityFilterPtr As IntPtr
    Get
property IntPtr DisparityFilterPtr {
    IntPtr get ();
}
abstract DisparityFilterPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IDisparityFilter Interface
Emgu.CV.XImgproc Namespace


IDisparityFilter Methods

The IDisparityFilter type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | Filter | Apply filtering to the disparity map. (Defined by XImgprocInvoke.)
Top
See Also

Reference

IDisparityFilter Interface
Emgu.CV.XImgproc Namespace


LocalBinarizationMethods Class

LocalBinarizationMethods type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XImgprocLocalBinarizationMethods

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LocalBinarizationMethods : Enum
Public NotInheritable Class LocalBinarizationMethods
    Inherits Enum
public ref class LocalBinarizationMethods sealed : public Enum
[<SealedAttribute>]
type LocalBinarizationMethods =
    class
        inherit Enum
    end

The LocalBinarizationMethods type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Niblack | Classic Niblack binarization.
 | NICK | NICK's technique.
 | Sauvola | Sauvola's technique.
Public field | value__ |
 | Wolf | Wolf's technique.
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


LocalBinarizationMethods Methods

The LocalBinarizationMethods type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

LocalBinarizationMethods Class
Emgu.CV.XImgproc Namespace


LocalBinarizationMethods Fields

The LocalBinarizationMethods type exposes the following members.

Fields
 | Name | Description
 | Niblack | Classic Niblack binarization.
 | NICK | NICK's technique.
 | Sauvola | Sauvola's technique.
Public field | value__ |
 | Wolf | Wolf's technique.
Top
See Also

Reference

LocalBinarizationMethods Class
Emgu.CV.XImgproc Namespace


LocalBinarizationMethods.Niblack Field

LocalBinarizationMethodsNiblack Field

Classic Niblack binarization.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocalBinarizationMethods Niblack = 0
Public Const Niblack As LocalBinarizationMethods = 0
public:
literal LocalBinarizationMethods^ Niblack = 0
static val mutable Niblack: LocalBinarizationMethods

Field Value

Type: LocalBinarizationMethods
See Also

Reference

LocalBinarizationMethods Class
Emgu.CV.XImgproc Namespace


LocalBinarizationMethods.NICK Field

LocalBinarizationMethodsNICK Field

NICK's technique.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocalBinarizationMethods NICK = 3
Public Const NICK As LocalBinarizationMethods = 3
public:
literal LocalBinarizationMethods^ NICK = 3
static val mutable NICK: LocalBinarizationMethods

Field Value

Type: LocalBinarizationMethods
See Also

Reference

LocalBinarizationMethods Class
Emgu.CV.XImgproc Namespace


LocalBinarizationMethods.Sauvola Field

LocalBinarizationMethodsSauvola Field

Sauvola's technique.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocalBinarizationMethods Sauvola = 1
Public Const Sauvola As LocalBinarizationMethods = 1
public:
literal LocalBinarizationMethods^ Sauvola = 1
static val mutable Sauvola: LocalBinarizationMethods

Field Value

Type: LocalBinarizationMethods
See Also

Reference

LocalBinarizationMethods Class
Emgu.CV.XImgproc Namespace


LocalBinarizationMethods.value__ Field

LocalBinarizationMethodsvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XImgproc.LocalBinarizationMethods.value__"]

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

LocalBinarizationMethods Class
Emgu.CV.XImgproc Namespace


LocalBinarizationMethods.Wolf Field

LocalBinarizationMethodsWolf Field

Wolf's technique.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const LocalBinarizationMethods Wolf = 2
Public Const Wolf As LocalBinarizationMethods = 2
public:
literal LocalBinarizationMethods^ Wolf = 2
static val mutable Wolf: LocalBinarizationMethods

Field Value

Type: LocalBinarizationMethods
See Also

Reference

LocalBinarizationMethods Class
Emgu.CV.XImgproc Namespace


RFFeatureGetter Class

Helper class for training part of [P. Dollar and C. L. Zitnick. Structured Forests for Fast Edge Detection, 2013].
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocRFFeatureGetter

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RFFeatureGetter : UnmanagedObject
Public Class RFFeatureGetter
    Inherits UnmanagedObject
public ref class RFFeatureGetter : public UnmanagedObject
type RFFeatureGetter =
    class
        inherit UnmanagedObject
    end

The RFFeatureGetter type exposes the following members.

Constructors
 | Name | Description
Public method | RFFeatureGetter | Create a default RFFeatureGetter
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this RFFeatureGetter. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


RFFeatureGetter Constructor

Create a default RFFeatureGetter

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RFFeatureGetter()
Public Sub New
public:
RFFeatureGetter()
new : unit -> RFFeatureGetter
See Also

Reference

RFFeatureGetter Class
Emgu.CV.XImgproc Namespace


RFFeatureGetter Properties

The RFFeatureGetter type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RFFeatureGetter Class
Emgu.CV.XImgproc Namespace


RFFeatureGetter Methods

The RFFeatureGetter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this RFFeatureGetter. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RFFeatureGetter Class
Emgu.CV.XImgproc Namespace


RFFeatureGetter.DisposeObject Method

RFFeatureGetterDisposeObject Method

Release the unmanaged memory associated with this RFFeatureGetter.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RFFeatureGetter Class
Emgu.CV.XImgproc Namespace


RFFeatureGetter Fields

The RFFeatureGetter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

RFFeatureGetter Class
Emgu.CV.XImgproc Namespace


RidgeDetectionFilter Class

Applies Ridge Detection Filter to an input image. Implements Ridge detection similar to the one in [Mathematica] (http://reference.wolfram.com/language/ref/RidgeFilter.html) using the eigen values from the Hessian Matrix of the input image using Sobel Derivatives. Additional refinement can be done using Skeletonization and Binarization.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.XImgprocRidgeDetectionFilter

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RidgeDetectionFilter : SharedPtrObject,
    IAlgorithm
Public Class RidgeDetectionFilter
    Inherits SharedPtrObject
    Implements IAlgorithm
public ref class RidgeDetectionFilter : public SharedPtrObject,
    IAlgorithm
type RidgeDetectionFilter =
    class
        inherit SharedPtrObject
        interface IAlgorithm
    end

The RidgeDetectionFilter type exposes the following members.

Constructors
 | Name | Description
Public method | RidgeDetectionFilter | Create a Ridge detection filter.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRidgeFilteredImage | Apply Ridge detection filter on input image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


RidgeDetectionFilter Constructor

Create a Ridge detection filter.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RidgeDetectionFilter(
    DepthType dDepthType = 5,
    int dChannels = 1,
    int dx = 1,
    int dy = 1,
    int ksize = 3,
    DepthType outDepthType = 0,
    int outChannels = 1,
    double scale = 1,
    double delta = 0,
    BorderType borderType = 4
)
Public Sub New (
    Optional dDepthType As DepthType = 5,
    Optional dChannels As Integer = 1,
    Optional dx As Integer = 1,
    Optional dy As Integer = 1,
    Optional ksize As Integer = 3,
    Optional outDepthType As DepthType = 0,
    Optional outChannels As Integer = 1,
    Optional scale As Double = 1,
    Optional delta As Double = 0,
    Optional borderType As BorderType = 4
)
public:
RidgeDetectionFilter(
    DepthType^ dDepthType = 5,
    int dChannels = 1,
    int dx = 1,
    int dy = 1,
    int ksize = 3,
    DepthType^ outDepthType = 0,
    int outChannels = 1,
    double scale = 1,
    double delta = 0,
    BorderType^ borderType = 4
)
new :
        ?dDepthType : DepthType *
        ?dChannels : int *
        ?dx : int *
        ?dy : int *
        ?ksize : int *
        ?outDepthType : DepthType *
        ?outChannels : int *
        ?scale : float *
        ?delta : float *
        ?borderType : BorderType
(* Defaults:
        let _dDepthType = defaultArg dDepthType 5
        let _dChannels = defaultArg dChannels 1
        let _dx = defaultArg dx 1
        let _dy = defaultArg dy 1
        let _ksize = defaultArg ksize 3
        let _outDepthType = defaultArg outDepthType 0
        let _outChannels = defaultArg outChannels 1
        let _scale = defaultArg scale 1
        let _delta = defaultArg delta 0
        let _borderType = defaultArg borderType 4
*)
-> RidgeDetectionFilter

Parameters

dDepthType (Optional)
Type: Emgu.CV.CvEnumDepthType
Specifies output image depth.
dChannels (Optional)
Type: SystemInt32
Specifies output image channel.
dx (Optional)
Type: SystemInt32
Order of derivative x
dy (Optional)
Type: SystemInt32
Order of derivative y
ksize (Optional)
Type: SystemInt32
Sobel kernel size
outDepthType (Optional)
Type: Emgu.CV.CvEnumDepthType
Converted format for output
outChannels (Optional)
Type: SystemInt32
Converted format for output
scale (Optional)
Type: SystemDouble
Optional scale value for derivative values
delta (Optional)
Type: SystemDouble
Optional bias added to output
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Pixel extrapolation method
See Also

Reference

RidgeDetectionFilter Class
Emgu.CV.XImgproc Namespace


RidgeDetectionFilter Properties

The RidgeDetectionFilter type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | Pointer to cv::Algorithm
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

RidgeDetectionFilter Class
Emgu.CV.XImgproc Namespace


RidgeDetectionFilter.AlgorithmPtr Property

RidgeDetectionFilterAlgorithmPtr Property

Pointer to cv::Algorithm

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AlgorithmPtr { get; }
Public ReadOnly Property AlgorithmPtr As IntPtr
    Get
public:
virtual property IntPtr AlgorithmPtr {
    IntPtr get () sealed;
}
abstract AlgorithmPtr : IntPtr with get
override AlgorithmPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IAlgorithmAlgorithmPtr
See Also

Reference

RidgeDetectionFilter Class
Emgu.CV.XImgproc Namespace


RidgeDetectionFilter Methods

The RidgeDetectionFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRidgeFilteredImage | Apply Ridge detection filter on input image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Clear | Clear the algorithm (Defined by AlgorithmExtensions.)
Public Extension Method | GetDefaultName | Returns the algorithm string identifier. This string is used as top level xml/yml node tag when the object is saved to a file or string. (Defined by AlgorithmExtensions.)
Public Extension Method | IsEmpty | Returns true if the Algorithm is empty. e.g. in the very beginning or after unsuccessful read. (Defined by AlgorithmExtensions.)
Public Extension Method | Load | Loads algorithm from the file (Defined by AlgorithmExtensions.)
Public Extension Method | LoadFromString | Loads algorithm from a String (Defined by AlgorithmExtensions.)
Public Extension Method | Read | Reads algorithm parameters from a file storage. (Defined by AlgorithmExtensions.)
Public Extension Method | Save | Save the algorithm to file (Defined by AlgorithmExtensions.)
Public Extension Method | SaveToString | Save the algorithm to a string (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Public Extension Method | Write(FileStorage, String) | Overloaded. Stores algorithm parameters in a file storage (Defined by AlgorithmExtensions.)
Top
See Also

Reference

RidgeDetectionFilter Class
Emgu.CV.XImgproc Namespace


RidgeDetectionFilter.DisposeObject Method

RidgeDetectionFilterDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RidgeDetectionFilter Class
Emgu.CV.XImgproc Namespace


RidgeDetectionFilter.GetRidgeFilteredImage Method

RidgeDetectionFilterGetRidgeFilteredImage Method

Apply Ridge detection filter on input image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetRidgeFilteredImage(
    IInputArray img,
    IOutputArray output
)
Public Sub GetRidgeFilteredImage (
    img As IInputArray,
    output As IOutputArray
)
public:
void GetRidgeFilteredImage(
    IInputArray^ img,
    IOutputArray^ output
)
member GetRidgeFilteredImage :
        img : IInputArray *
        output : IOutputArray -> unit

Parameters

img
Type: Emgu.CVIInputArray
InputArray as supported by Sobel. img can be 1-Channel or 3-Channels.
output
Type: Emgu.CVIOutputArray
Output image with ridges.
See Also

Reference

RidgeDetectionFilter Class
Emgu.CV.XImgproc Namespace


RidgeDetectionFilter Fields

The RidgeDetectionFilter type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

RidgeDetectionFilter Class
Emgu.CV.XImgproc Namespace


RightMatcher Class

The matcher for computing the right-view disparity map that is required in case of filtering with confidence.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.UtilSharedPtrObject
Emgu.CV.XImgprocRightMatcher

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class RightMatcher : SharedPtrObject,
    IStereoMatcher
Public Class RightMatcher
    Inherits SharedPtrObject
    Implements IStereoMatcher
public ref class RightMatcher : public SharedPtrObject,
    IStereoMatcher
type RightMatcher =
    class
        inherit SharedPtrObject
        interface IStereoMatcher
    end

The RightMatcher type exposes the following members.

Constructors
 | Name | Description
Public method | RightMatcher | Set up the matcher for computing the right-view disparity map that is required in case of filtering with confidence.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | StereoMatcherPtr | Pointer to the stereo matcher
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with the RightMatcher (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


RightMatcher Constructor

Set up the matcher for computing the right-view disparity map that is required in case of filtering with confidence.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public RightMatcher(
    IStereoMatcher matcherLeft
)
Public Sub New (
    matcherLeft As IStereoMatcher
)
public:
RightMatcher(
    IStereoMatcher^ matcherLeft
)
new :
        matcherLeft : IStereoMatcher -> RightMatcher

Parameters

matcherLeft
Type: Emgu.CVIStereoMatcher
Main stereo matcher instance that will be used with the filter
See Also

Reference

RightMatcher Class
Emgu.CV.XImgproc Namespace


RightMatcher Properties

The RightMatcher type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SharedPtr | Pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Public property | StereoMatcherPtr | Pointer to the stereo matcher
Top
See Also

Reference

RightMatcher Class
Emgu.CV.XImgproc Namespace


RightMatcher.StereoMatcherPtr Property

RightMatcherStereoMatcherPtr Property

Pointer to the stereo matcher

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr StereoMatcherPtr { get; }
Public ReadOnly Property StereoMatcherPtr As IntPtr
    Get
public:
virtual property IntPtr StereoMatcherPtr {
    IntPtr get () sealed;
}
abstract StereoMatcherPtr : IntPtr with get
override StereoMatcherPtr : IntPtr with get

Property Value

Type: IntPtr

Implements

IStereoMatcherStereoMatcherPtr
See Also

Reference

RightMatcher Class
Emgu.CV.XImgproc Namespace


RightMatcher Methods

The RightMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with the RightMatcher (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compute | Computes disparity map for the specified stereo pair (Defined by CvInvoke.)
Top
See Also

Reference

RightMatcher Class
Emgu.CV.XImgproc Namespace


RightMatcher.DisposeObject Method

RightMatcherDisposeObject Method

Release the unmanaged memory associated with the RightMatcher

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

RightMatcher Class
Emgu.CV.XImgproc Namespace


RightMatcher Fields

The RightMatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _sharedPtr | A pointer to the shared pointer to the unmanaged object (Inherited from SharedPtrObject.)
Top
See Also

Reference

RightMatcher Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation Class

Selective search segmentation algorithm The class implements the algorithm described in: Jasper RR Uijlings, Koen EA van de Sande, Theo Gevers, and Arnold WM Smeulders. Selective search for object recognition. International journal of computer vision, 104(2):154–171, 2013.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocSelectiveSearchSegmentation

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SelectiveSearchSegmentation : UnmanagedObject
Public Class SelectiveSearchSegmentation
    Inherits UnmanagedObject
public ref class SelectiveSearchSegmentation : public UnmanagedObject
type SelectiveSearchSegmentation =
    class
        inherit UnmanagedObject
    end

The SelectiveSearchSegmentation type exposes the following members.

Constructors
 | Name | Description
Public method | SelectiveSearchSegmentation | Selective search segmentation algorithm
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | AddImage | Add a new image in the list of images to process.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Based on all images, graph segmentations and stragies, computes all possible rects and return them.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetBaseImage | Set a image used by switch* functions to initialize the class.
Public method | SwitchToSelectiveSearchFast | Initialize the class with the 'Selective search fast' parameters
Public method | SwitchToSelectiveSearchQuality | Initialize the class with the 'Selective search quality' parameters
Public method | SwitchToSingleStrategy | Initialize the class with the 'Single stragegy' parameters
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation Constructor

Selective search segmentation algorithm

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SelectiveSearchSegmentation()
Public Sub New
public:
SelectiveSearchSegmentation()
new : unit -> SelectiveSearchSegmentation
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation Properties

The SelectiveSearchSegmentation type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation Methods

The SelectiveSearchSegmentation type exposes the following members.

Methods
 | Name | Description
Public method | AddImage | Add a new image in the list of images to process.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Based on all images, graph segmentations and stragies, computes all possible rects and return them.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | SetBaseImage | Set a image used by switch* functions to initialize the class.
Public method | SwitchToSelectiveSearchFast | Initialize the class with the 'Selective search fast' parameters
Public method | SwitchToSelectiveSearchQuality | Initialize the class with the 'Selective search quality' parameters
Public method | SwitchToSingleStrategy | Initialize the class with the 'Single stragegy' parameters
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation.AddImage Method

SelectiveSearchSegmentationAddImage Method

Add a new image in the list of images to process.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void AddImage(
    IInputArray img
)
Public Sub AddImage (
    img As IInputArray
)
public:
void AddImage(
    IInputArray^ img
)
member AddImage :
        img : IInputArray -> unit

Parameters

img
Type: Emgu.CVIInputArray
The image
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation.DisposeObject Method

SelectiveSearchSegmentationDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation.Process Method

SelectiveSearchSegmentationProcess Method

Based on all images, graph segmentations and stragies, computes all possible rects and return them.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle[] Process()
Public Function Process As Rectangle()
public:
array<Rectangle^>^ Process()
member Process : unit -> Rectangle[]

Return Value

Type: Rectangle
The list of rects. The first ones are more relevents than the lasts ones.
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation.SetBaseImage Method

SelectiveSearchSegmentationSetBaseImage Method

Set a image used by switch* functions to initialize the class.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetBaseImage(
    IInputArray image
)
Public Sub SetBaseImage (
    image As IInputArray
)
public:
void SetBaseImage(
    IInputArray^ image
)
member SetBaseImage :
        image : IInputArray -> unit

Parameters

image
Type: Emgu.CVIInputArray
The image
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation.SwitchToSelectiveSearchFast Method

SelectiveSearchSegmentationSwitchToSelectiveSearchFast Method

http://www.emgu.com
Initialize the class with the 'Selective search fast' parameters

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SwitchToSelectiveSearchFast(
    int baseK = 150,
    int incK = 150,
    float sigma = 0.8f
)
Public Sub SwitchToSelectiveSearchFast (
    Optional baseK As Integer = 150,
    Optional incK As Integer = 150,
    Optional sigma As Single = 0.8F
)
public:
void SwitchToSelectiveSearchFast(
    int baseK = 150,
    int incK = 150,
    float sigma = 0.8f
)
member SwitchToSelectiveSearchFast :
        ?baseK : int *
        ?incK : int *
        ?sigma : float32
(* Defaults:
        let _baseK = defaultArg baseK 150
        let _incK = defaultArg incK 150
        let _sigma = defaultArg sigma 0.8f
*)
-> unit

Parameters

baseK (Optional)
Type: SystemInt32
The k parameter for the first graph segmentation
incK (Optional)
Type: SystemInt32
The increment of the k parameter for all graph segmentations
sigma (Optional)
Type: SystemSingle
The sigma parameter for the graph segmentation
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation.SwitchToSelectiveSearchQuality Method

SelectiveSearchSegmentationSwitchToSelectiveSearchQuality Method

http://www.emgu.com
Initialize the class with the 'Selective search quality' parameters

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SwitchToSelectiveSearchQuality(
    int baseK = 150,
    int incK = 150,
    float sigma = 0.8f
)
Public Sub SwitchToSelectiveSearchQuality (
    Optional baseK As Integer = 150,
    Optional incK As Integer = 150,
    Optional sigma As Single = 0.8F
)
public:
void SwitchToSelectiveSearchQuality(
    int baseK = 150,
    int incK = 150,
    float sigma = 0.8f
)
member SwitchToSelectiveSearchQuality :
        ?baseK : int *
        ?incK : int *
        ?sigma : float32
(* Defaults:
        let _baseK = defaultArg baseK 150
        let _incK = defaultArg incK 150
        let _sigma = defaultArg sigma 0.8f
*)
-> unit

Parameters

baseK (Optional)
Type: SystemInt32
The k parameter for the first graph segmentation
incK (Optional)
Type: SystemInt32
The increment of the k parameter for all graph segmentations
sigma (Optional)
Type: SystemSingle
The sigma parameter for the graph segmentation
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation.SwitchToSingleStrategy Method

SelectiveSearchSegmentationSwitchToSingleStrategy Method

Initialize the class with the 'Single stragegy' parameters

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void SwitchToSingleStrategy(
    int k,
    float sigma
)
Public Sub SwitchToSingleStrategy (
    k As Integer,
    sigma As Single
)
public:
void SwitchToSingleStrategy(
    int k,
    float sigma
)
member SwitchToSingleStrategy :
        k : int *
        sigma : float32 -> unit

Parameters

k
Type: SystemInt32
The k parameter for the graph segmentation
sigma
Type: SystemSingle
The sigma parameter for the graph segmentation
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


SelectiveSearchSegmentation Fields

The SelectiveSearchSegmentation type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SelectiveSearchSegmentation Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection Class

Class implementing edge detection algorithm from Piotr Dollar and C Lawrence Zitnick. Structured forests for fast edge detection. In Computer Vision (ICCV), 2013 IEEE International Conference on, pages 1841-1848. IEEE, 2013.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocStructuredEdgeDetection

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class StructuredEdgeDetection : UnmanagedObject
Public Class StructuredEdgeDetection
    Inherits UnmanagedObject
public ref class StructuredEdgeDetection : public UnmanagedObject
type StructuredEdgeDetection =
    class
        inherit UnmanagedObject
    end

The StructuredEdgeDetection type exposes the following members.

Constructors
 | Name | Description
Public method | StructuredEdgeDetection | Create an edge detection algorithm.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | ComputeOrientation | The function computes orientation from edge image.
Public method | DetectEdges | The function detects edges in src and draw them to dst. The algorithm underlies this function is much more robust to texture presence, than common approaches, e.g. Sobel
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | EdgesNms | The function edgenms in edge image and suppress edges where edge is stronger in orthogonal direction.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


StructuredEdgeDetection Constructor

Create an edge detection algorithm.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public StructuredEdgeDetection(
    string model,
    RFFeatureGetter howToGetFeatures
)
Public Sub New (
    model As String,
    howToGetFeatures As RFFeatureGetter
)
public:
StructuredEdgeDetection(
    String^ model,
    RFFeatureGetter^ howToGetFeatures
)
new :
        model : string *
        howToGetFeatures : RFFeatureGetter -> StructuredEdgeDetection

Parameters

model
Type: SystemString
name of the file where the model is stored
howToGetFeatures
Type: Emgu.CV.XImgprocRFFeatureGetter
optional object inheriting from RFFeatureGetter. You need it only if you would like to train your own forest, pass NULL otherwise
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection Properties

The StructuredEdgeDetection type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection Methods

The StructuredEdgeDetection type exposes the following members.

Methods
 | Name | Description
Public method | ComputeOrientation | The function computes orientation from edge image.
Public method | DetectEdges | The function detects edges in src and draw them to dst. The algorithm underlies this function is much more robust to texture presence, than common approaches, e.g. Sobel
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | EdgesNms | The function edgenms in edge image and suppress edges where edge is stronger in orthogonal direction.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection.ComputeOrientation Method

StructuredEdgeDetectionComputeOrientation Method

The function computes orientation from edge image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void ComputeOrientation(
    IInputArray src,
    IOutputArray dst
)
Public Sub ComputeOrientation (
    src As IInputArray,
    dst As IOutputArray
)
public:
void ComputeOrientation(
    IInputArray^ src,
    IOutputArray^ dst
)
member ComputeOrientation :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Edge image.
dst
Type: Emgu.CVIOutputArray
Orientation image.
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection.DetectEdges Method

StructuredEdgeDetectionDetectEdges Method

The function detects edges in src and draw them to dst. The algorithm underlies this function is much more robust to texture presence, than common approaches, e.g. Sobel

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void DetectEdges(
    IInputArray src,
    IOutputArray dst
)
Public Sub DetectEdges (
    src As IInputArray,
    dst As IOutputArray
)
public:
void DetectEdges(
    IInputArray^ src,
    IOutputArray^ dst
)
member DetectEdges :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
source image (RGB, float, in [0;1]) to detect edges
dst
Type: Emgu.CVIOutputArray
destination image (grayscale, float, in [0;1]) where edges are drawn
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection.DisposeObject Method

StructuredEdgeDetectionDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection.EdgesNms Method

StructuredEdgeDetectionEdgesNms Method

The function edgenms in edge image and suppress edges where edge is stronger in orthogonal direction.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void EdgesNms(
    IInputArray edgeImage,
    IInputArray orientationImage,
    IOutputArray dst,
    int r = 2,
    int s = 0,
    float m = 1f,
    bool isParallel = true
)
Public Sub EdgesNms (
    edgeImage As IInputArray,
    orientationImage As IInputArray,
    dst As IOutputArray,
    Optional r As Integer = 2,
    Optional s As Integer = 0,
    Optional m As Single = 1F,
    Optional isParallel As Boolean = true
)
public:
void EdgesNms(
    IInputArray^ edgeImage,
    IInputArray^ orientationImage,
    IOutputArray^ dst,
    int r = 2,
    int s = 0,
    float m = 1f,
    bool isParallel = true
)
member EdgesNms :
        edgeImage : IInputArray *
        orientationImage : IInputArray *
        dst : IOutputArray *
        ?r : int *
        ?s : int *
        ?m : float32 *
        ?isParallel : bool
(* Defaults:
        let _r = defaultArg r 2
        let _s = defaultArg s 0
        let _m = defaultArg m 1f
        let _isParallel = defaultArg isParallel true
*)
-> unit

Parameters

edgeImage
Type: Emgu.CVIInputArray
edge image from DetectEdges function.
orientationImage
Type: Emgu.CVIInputArray
orientation image from ComputeOrientation function.
dst
Type: Emgu.CVIOutputArray
Suppressed image (grayscale, float, in [0;1])
r (Optional)
Type: SystemInt32
Radius for NMS suppression.
s (Optional)
Type: SystemInt32
Radius for boundary suppression.
m (Optional)
Type: SystemSingle
Multiplier for conservative suppression.
isParallel (Optional)
Type: SystemBoolean
Enables/disables parallel computing.
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


StructuredEdgeDetection Fields

The StructuredEdgeDetection type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

StructuredEdgeDetection Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC Class

Class implementing the LSC (Linear Spectral Clustering) superpixels algorithm described in "Zhengqin Li and Jiansheng Chen. Superpixel segmentation using linear spectral clustering. June 2015."
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocSuperpixelLSC

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SuperpixelLSC : UnmanagedObject
Public Class SuperpixelLSC
    Inherits UnmanagedObject
public ref class SuperpixelLSC : public UnmanagedObject
type SuperpixelLSC =
    class
        inherit UnmanagedObject
    end

The SuperpixelLSC type exposes the following members.

Constructors
 | Name | Description
Public method | SuperpixelLSC | The function initializes a SuperpixelLSC object for the input image.
Top
Properties
 | Name | Description
Public property | NumberOfSuperpixels | Calculates the actual amount of superpixels on a given segmentation computed and stored in SuperpixelLSC object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLabelContourMask | Returns the mask of the superpixel segmentation stored in SuperpixelLSC object.
Public method | GetLabels | Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate | Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelLSC object. This function can be called again without the need of initializing the algorithm with createSuperpixelLSC(). This save the computational cost of allocating memory for all the structures of the algorithm.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Remarks
LSC (Linear Spectral Clustering) produces compact and uniform superpixels with low computational costs. Basically, a normalized cuts formulation of the superpixel segmentation is adopted based on a similarity metric that measures the color similarity and space proximity between image pixels. LSC is of linear computational complexity and high memory efficiency and is able to preserve global properties of images
See Also

Reference

Emgu.CV.XImgproc Namespace


SuperpixelLSC Constructor

The function initializes a SuperpixelLSC object for the input image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SuperpixelLSC(
    IInputArray image,
    int regionSize,
    float ratio
)
Public Sub New (
    image As IInputArray,
    regionSize As Integer,
    ratio As Single
)
public:
SuperpixelLSC(
    IInputArray^ image,
    int regionSize,
    float ratio
)
new :
        image : IInputArray *
        regionSize : int *
        ratio : float32 -> SuperpixelLSC

Parameters

image
Type: Emgu.CVIInputArray
Image to segment
regionSize
Type: SystemInt32
Chooses an average superpixel size measured in pixels
ratio
Type: SystemSingle
Chooses the enforcement of superpixel compactness factor of superpixel
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC Properties

The SuperpixelLSC type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfSuperpixels | Calculates the actual amount of superpixels on a given segmentation computed and stored in SuperpixelLSC object
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC.NumberOfSuperpixels Property

SuperpixelLSCNumberOfSuperpixels Property

Calculates the actual amount of superpixels on a given segmentation computed and stored in SuperpixelLSC object

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSuperpixels { get; }
Public ReadOnly Property NumberOfSuperpixels As Integer
    Get
public:
property int NumberOfSuperpixels {
    int get ();
}
member NumberOfSuperpixels : int with get

Property Value

Type: Int32
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC Methods

The SuperpixelLSC type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLabelContourMask | Returns the mask of the superpixel segmentation stored in SuperpixelLSC object.
Public method | GetLabels | Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate | Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelLSC object. This function can be called again without the need of initializing the algorithm with createSuperpixelLSC(). This save the computational cost of allocating memory for all the structures of the algorithm.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC.DisposeObject Method

SuperpixelLSCDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC.GetLabelContourMask Method

SuperpixelLSCGetLabelContourMask Method

Returns the mask of the superpixel segmentation stored in SuperpixelLSC object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetLabelContourMask(
    IOutputArray image,
    bool thickLine = true
)
Public Sub GetLabelContourMask (
    image As IOutputArray,
    Optional thickLine As Boolean = true
)
public:
void GetLabelContourMask(
    IOutputArray^ image,
    bool thickLine = true
)
member GetLabelContourMask :
        image : IOutputArray *
        ?thickLine : bool
(* Defaults:
        let _thickLine = defaultArg thickLine true
*)
-> unit

Parameters

image
Type: Emgu.CVIOutputArray
Return: CV_8U1 image mask where -1 indicates that the pixel is a superpixel border, and 0 otherwise.
thickLine (Optional)
Type: SystemBoolean
If false, the border is only one pixel wide, otherwise all pixels at the border are masked.
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC.GetLabels Method

SuperpixelLSCGetLabels Method

Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetLabels(
    IOutputArray labels
)
Public Sub GetLabels (
    labels As IOutputArray
)
public:
void GetLabels(
    IOutputArray^ labels
)
member GetLabels :
        labels : IOutputArray -> unit

Parameters

labels
Type: Emgu.CVIOutputArray
A CV_32SC1 integer array containing the labels of the superpixel segmentation. The labels are in the range [0, NumberOfSuperpixels].
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC.Iterate Method

SuperpixelLSCIterate Method

Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelLSC object. This function can be called again without the need of initializing the algorithm with createSuperpixelLSC(). This save the computational cost of allocating memory for all the structures of the algorithm.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Iterate(
    int numIterations = 10
)
Public Sub Iterate (
    Optional numIterations As Integer = 10
)
public:
void Iterate(
    int numIterations = 10
)
member Iterate :
        ?numIterations : int
(* Defaults:
        let _numIterations = defaultArg numIterations 10
*)
-> unit

Parameters

numIterations (Optional)
Type: SystemInt32
Number of iterations. Higher number improves the result.
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SuperpixelLSC Fields

The SuperpixelLSC type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SuperpixelLSC Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS Class

Class implementing the SEEDS (Superpixels Extracted via Energy-Driven Sampling) superpixels algorithm described in Michael Van den Bergh, Xavier Boix, Gemma Roig, Benjamin de Capitani, and Luc Van Gool. Seeds: Superpixels extracted via energy-driven sampling. In Computer Vision-ECCV 2012, pages 13-26. Springer, 2012.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocSupperpixelSEEDS

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SupperpixelSEEDS : UnmanagedObject
Public Class SupperpixelSEEDS
    Inherits UnmanagedObject
public ref class SupperpixelSEEDS : public UnmanagedObject
type SupperpixelSEEDS =
    class
        inherit UnmanagedObject
    end

The SupperpixelSEEDS type exposes the following members.

Constructors
 | Name | Description
Public method | SupperpixelSEEDS | The function initializes a SuperpixelSEEDS object for the input image.
Top
Properties
 | Name | Description
Public property | NumberOfSuperpixels | The function computes the superpixels segmentation of an image with the parameters initialized with the function createSuperpixelSEEDS().
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLabelContourMask | Returns the mask of the superpixel segmentation stored in SuperpixelSEEDS object.
Public method | GetLabels | Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate | Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelSEEDS object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


SupperpixelSEEDS Constructor

The function initializes a SuperpixelSEEDS object for the input image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SupperpixelSEEDS(
    int imageWidth,
    int imageHeight,
    int imageChannels,
    int numSuperpixels,
    int numLevels,
    int prior,
    int histogramBins,
    bool doubleStep
)
Public Sub New (
    imageWidth As Integer,
    imageHeight As Integer,
    imageChannels As Integer,
    numSuperpixels As Integer,
    numLevels As Integer,
    prior As Integer,
    histogramBins As Integer,
    doubleStep As Boolean
)
public:
SupperpixelSEEDS(
    int imageWidth,
    int imageHeight,
    int imageChannels,
    int numSuperpixels,
    int numLevels,
    int prior,
    int histogramBins,
    bool doubleStep
)
new :
        imageWidth : int *
        imageHeight : int *
        imageChannels : int *
        numSuperpixels : int *
        numLevels : int *
        prior : int *
        histogramBins : int *
        doubleStep : bool -> SupperpixelSEEDS

Parameters

imageWidth
Type: SystemInt32
Image width
imageHeight
Type: SystemInt32
Image height
imageChannels
Type: SystemInt32
Number of channels of the image.
numSuperpixels
Type: SystemInt32
Desired number of superpixels. Note that the actual number may be smaller due to restrictions (depending on the image size and num_levels). Use getNumberOfSuperpixels() to get the actual number.
numLevels
Type: SystemInt32
Number of block levels. The more levels, the more accurate is the segmentation, but needs more memory and CPU time.
prior
Type: SystemInt32
Enable 3x3 shape smoothing term if >0. A larger value leads to smoother shapes. prior must be in the range [0, 5].
histogramBins
Type: SystemInt32
Number of histogram bins.
doubleStep
Type: SystemBoolean
If true, iterate each block level twice for higher accuracy.
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS Properties

The SupperpixelSEEDS type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfSuperpixels | The function computes the superpixels segmentation of an image with the parameters initialized with the function createSuperpixelSEEDS().
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS.NumberOfSuperpixels Property

SupperpixelSEEDSNumberOfSuperpixels Property

The function computes the superpixels segmentation of an image with the parameters initialized with the function createSuperpixelSEEDS().

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSuperpixels { get; }
Public ReadOnly Property NumberOfSuperpixels As Integer
    Get
public:
property int NumberOfSuperpixels {
    int get ();
}
member NumberOfSuperpixels : int with get

Property Value

Type: Int32
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS Methods

The SupperpixelSEEDS type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLabelContourMask | Returns the mask of the superpixel segmentation stored in SuperpixelSEEDS object.
Public method | GetLabels | Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate | Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelSEEDS object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS.DisposeObject Method

SupperpixelSEEDSDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS.GetLabelContourMask Method

SupperpixelSEEDSGetLabelContourMask Method

Returns the mask of the superpixel segmentation stored in SuperpixelSEEDS object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetLabelContourMask(
    IOutputArray image,
    bool thickLine = false
)
Public Sub GetLabelContourMask (
    image As IOutputArray,
    Optional thickLine As Boolean = false
)
public:
void GetLabelContourMask(
    IOutputArray^ image,
    bool thickLine = false
)
member GetLabelContourMask :
        image : IOutputArray *
        ?thickLine : bool
(* Defaults:
        let _thickLine = defaultArg thickLine false
*)
-> unit

Parameters

image
Type: Emgu.CVIOutputArray
Return: CV_8UC1 image mask where -1 indicates that the pixel is a superpixel border, and 0 otherwise.
thickLine (Optional)
Type: SystemBoolean
If false, the border is only one pixel wide, otherwise all pixels at the border are masked.
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS.GetLabels Method

SupperpixelSEEDSGetLabels Method

Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetLabels(
    IOutputArray labels
)
Public Sub GetLabels (
    labels As IOutputArray
)
public:
void GetLabels(
    IOutputArray^ labels
)
member GetLabels :
        labels : IOutputArray -> unit

Parameters

labels
Type: Emgu.CVIOutputArray
Return: A CV_32UC1 integer array containing the labels of the superpixel segmentation. The labels are in the range [0, NumberOfSuperpixels].
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS.Iterate Method

SupperpixelSEEDSIterate Method

Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelSEEDS object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Iterate(
    IInputArray img,
    int numIterations = 4
)
Public Sub Iterate (
    img As IInputArray,
    Optional numIterations As Integer = 4
)
public:
void Iterate(
    IInputArray^ img,
    int numIterations = 4
)
member Iterate :
        img : IInputArray *
        ?numIterations : int
(* Defaults:
        let _numIterations = defaultArg numIterations 4
*)
-> unit

Parameters

img
Type: Emgu.CVIInputArray
Input image. Supported formats: CV_8U, CV_16U, CV_32F. Image size & number of channels must match with the initialized image size & channels with the function createSuperpixelSEEDS(). It should be in HSV or Lab color space. Lab is a bit better, but also slower.
numIterations (Optional)
Type: SystemInt32
Number of pixel level iterations. Higher number improves the result.
Remarks
This function can be called again for other images without the need of initializing the algorithm with createSuperpixelSEEDS(). This save the computational cost of allocating memory for all the structures of the algorithm.
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSEEDS Fields

The SupperpixelSEEDS type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SupperpixelSEEDS Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC Class

Class implementing the SLIC (Simple Linear Iterative Clustering) superpixels algorithm described in Radhakrishna Achanta, Appu Shaji, Kevin Smith, Aurelien Lucchi, Pascal Fua, and Sabine Susstrunk. Slic superpixels compared to state-of-the-art superpixel methods. IEEE Trans. Pattern Anal. Mach. Intell., 34(11):2274-2282, nov 2012.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XImgprocSupperpixelSLIC

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SupperpixelSLIC : UnmanagedObject
Public Class SupperpixelSLIC
    Inherits UnmanagedObject
public ref class SupperpixelSLIC : public UnmanagedObject
type SupperpixelSLIC =
    class
        inherit UnmanagedObject
    end

The SupperpixelSLIC type exposes the following members.

Constructors
 | Name | Description
Public method | SupperpixelSLIC | The function initializes a SuperpixelSLIC object for the input image. It sets the parameters of choosed superpixel algorithm, which are: region_size and ruler. It preallocate some buffers for future computing iterations over the given image.
Top
Properties
 | Name | Description
Public property | NumberOfSuperpixels | Calculates the actual amount of superpixels on a given segmentation computed and stored in SuperpixelSLIC object.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | EnforceLabelConnectivity | The function merge component that is too small, assigning the previously found adjacent label to this component.Calling this function may change the final number of superpixels.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLabelContourMask | Returns the mask of the superpixel segmentation stored in SuperpixelSLIC object.
Public method | GetLabels | Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate | Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelSLIC object. This function can be called again without the need of initializing the algorithm with createSuperpixelSLIC(). This save the computational cost of allocating memory for all the structures of the algorithm.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


SupperpixelSLIC Constructor

The function initializes a SuperpixelSLIC object for the input image. It sets the parameters of choosed superpixel algorithm, which are: region_size and ruler. It preallocate some buffers for future computing iterations over the given image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SupperpixelSLIC(
    IInputArray image,
    SupperpixelSLICAlgorithm algorithm,
    int regionSize,
    float ruler
)
Public Sub New (
    image As IInputArray,
    algorithm As SupperpixelSLICAlgorithm,
    regionSize As Integer,
    ruler As Single
)
public:
SupperpixelSLIC(
    IInputArray^ image,
    SupperpixelSLICAlgorithm^ algorithm,
    int regionSize,
    float ruler
)
new :
        image : IInputArray *
        algorithm : SupperpixelSLICAlgorithm *
        regionSize : int *
        ruler : float32 -> SupperpixelSLIC

Parameters

image
Type: Emgu.CVIInputArray
Image to segment
algorithm
Type: Emgu.CV.XImgprocSupperpixelSLICAlgorithm
Chooses the algorithm variant to use
regionSize
Type: SystemInt32
Chooses an average superpixel size measured in pixels
ruler
Type: SystemSingle
Chooses the enforcement of superpixel smoothness factor of superpixel
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC Properties

The SupperpixelSLIC type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfSuperpixels | Calculates the actual amount of superpixels on a given segmentation computed and stored in SuperpixelSLIC object.
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.NumberOfSuperpixels Property

SupperpixelSLICNumberOfSuperpixels Property

Calculates the actual amount of superpixels on a given segmentation computed and stored in SuperpixelSLIC object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSuperpixels { get; }
Public ReadOnly Property NumberOfSuperpixels As Integer
    Get
public:
property int NumberOfSuperpixels {
    int get ();
}
member NumberOfSuperpixels : int with get

Property Value

Type: Int32
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC Methods

The SupperpixelSLIC type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this object. (Overrides DisposableObjectDisposeObject.)
Public method | EnforceLabelConnectivity | The function merge component that is too small, assigning the previously found adjacent label to this component.Calling this function may change the final number of superpixels.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLabelContourMask | Returns the mask of the superpixel segmentation stored in SuperpixelSLIC object.
Public method | GetLabels | Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate | Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelSLIC object. This function can be called again without the need of initializing the algorithm with createSuperpixelSLIC(). This save the computational cost of allocating memory for all the structures of the algorithm.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.DisposeObject Method

SupperpixelSLICDisposeObject Method

Release the unmanaged memory associated with this object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.EnforceLabelConnectivity Method

SupperpixelSLICEnforceLabelConnectivity Method

The function merge component that is too small, assigning the previously found adjacent label to this component.Calling this function may change the final number of superpixels.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void EnforceLabelConnectivity(
    int minElementSize = 25
)
Public Sub EnforceLabelConnectivity (
    Optional minElementSize As Integer = 25
)
public:
void EnforceLabelConnectivity(
    int minElementSize = 25
)
member EnforceLabelConnectivity :
        ?minElementSize : int
(* Defaults:
        let _minElementSize = defaultArg minElementSize 25
*)
-> unit

Parameters

minElementSize (Optional)
Type: SystemInt32
The minimum element size in percents that should be absorbed into a bigger superpixel.Given resulted average superpixel size valid value should be in 0-100 range, 25 means that less then a quarter sized superpixel should be absorbed, this is default.
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.GetLabelContourMask Method

SupperpixelSLICGetLabelContourMask Method

Returns the mask of the superpixel segmentation stored in SuperpixelSLIC object.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetLabelContourMask(
    IOutputArray image,
    bool thickLine = true
)
Public Sub GetLabelContourMask (
    image As IOutputArray,
    Optional thickLine As Boolean = true
)
public:
void GetLabelContourMask(
    IOutputArray^ image,
    bool thickLine = true
)
member GetLabelContourMask :
        image : IOutputArray *
        ?thickLine : bool
(* Defaults:
        let _thickLine = defaultArg thickLine true
*)
-> unit

Parameters

image
Type: Emgu.CVIOutputArray
CV_8U1 image mask where -1 indicates that the pixel is a superpixel border, and 0 otherwise.
thickLine (Optional)
Type: SystemBoolean
If false, the border is only one pixel wide, otherwise all pixels at the border are masked.
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.GetLabels Method

SupperpixelSLICGetLabels Method

Returns the segmentation labeling of the image. Each label represents a superpixel, and each pixel is assigned to one superpixel label.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetLabels(
    IOutputArray labels
)
Public Sub GetLabels (
    labels As IOutputArray
)
public:
void GetLabels(
    IOutputArray^ labels
)
member GetLabels :
        labels : IOutputArray -> unit

Parameters

labels
Type: Emgu.CVIOutputArray
A CV_32SC1 integer array containing the labels of the superpixel segmentation. The labels are in the range [0, NumberOfSuperpixels].
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.Iterate Method

SupperpixelSLICIterate Method

Calculates the superpixel segmentation on a given image with the initialized parameters in the SuperpixelSLIC object. This function can be called again without the need of initializing the algorithm with createSuperpixelSLIC(). This save the computational cost of allocating memory for all the structures of the algorithm.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Iterate(
    int numIterations = 10
)
Public Sub Iterate (
    Optional numIterations As Integer = 10
)
public:
void Iterate(
    int numIterations = 10
)
member Iterate :
        ?numIterations : int
(* Defaults:
        let _numIterations = defaultArg numIterations 10
*)
-> unit

Parameters

numIterations (Optional)
Type: SystemInt32
Number of iterations. Higher number improves the result.
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC Fields

The SupperpixelSLIC type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SupperpixelSLIC Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.Algorithm Class

SupperpixelSLICAlgorithm Class

The algorithm to use
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XImgprocSupperpixelSLICAlgorithm

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Algorithm : Enum
Public NotInheritable Class Algorithm
    Inherits Enum
public ref class Algorithm sealed : public Enum
[<SealedAttribute>]
type Algorithm =
    class
        inherit Enum
    end

The SupperpixelSLICAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | SLIC | SLIC segments image using a desired region_size
 | SLICO | SLICO will choose an adaptive compactness factor.
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


Algorithm Methods

The SupperpixelSLICAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

SupperpixelSLICAlgorithm Class
Emgu.CV.XImgproc Namespace


Algorithm Fields

The SupperpixelSLICAlgorithm type exposes the following members.

Fields
 | Name | Description
 | SLIC | SLIC segments image using a desired region_size
 | SLICO | SLICO will choose an adaptive compactness factor.
Public field | value__ |
Top
See Also

Reference

SupperpixelSLICAlgorithm Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.Algorithm.SLIC Field

SupperpixelSLICAlgorithmSLIC Field

SLIC segments image using a desired region_size

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SupperpixelSLICAlgorithm SLIC = 100
Public Const SLIC As SupperpixelSLICAlgorithm = 100
public:
literal SupperpixelSLICAlgorithm^ SLIC = 100
static val mutable SLIC: SupperpixelSLICAlgorithm

Field Value

Type: SupperpixelSLICAlgorithm
See Also

Reference

SupperpixelSLICAlgorithm Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.Algorithm.SLICO Field

SupperpixelSLICAlgorithmSLICO Field

SLICO will choose an adaptive compactness factor.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const SupperpixelSLICAlgorithm SLICO = 101
Public Const SLICO As SupperpixelSLICAlgorithm = 101
public:
literal SupperpixelSLICAlgorithm^ SLICO = 101
static val mutable SLICO: SupperpixelSLICAlgorithm

Field Value

Type: SupperpixelSLICAlgorithm
See Also

Reference

SupperpixelSLICAlgorithm Class
Emgu.CV.XImgproc Namespace


SupperpixelSLIC.Algorithm.value__ Field

SupperpixelSLICAlgorithmvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XImgproc.SupperpixelSLIC.Algorithm.value__"]

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

SupperpixelSLICAlgorithm Class
Emgu.CV.XImgproc Namespace


ThinningTypes Class

Thinning type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XImgprocThinningTypes

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ThinningTypes : Enum
Public NotInheritable Class ThinningTypes
    Inherits Enum
public ref class ThinningTypes sealed : public Enum
[<SealedAttribute>]
type ThinningTypes =
    class
        inherit Enum
    end

The ThinningTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | GuoHall | Thinning technique of Guo-Hall
Public field | value__ |
 | ZhangSuen | Thinning technique of Zhang-Suen
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


ThinningTypes Methods

The ThinningTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ThinningTypes Class
Emgu.CV.XImgproc Namespace


ThinningTypes Fields

The ThinningTypes type exposes the following members.

Fields
 | Name | Description
 | GuoHall | Thinning technique of Guo-Hall
Public field | value__ |
 | ZhangSuen | Thinning technique of Zhang-Suen
Top
See Also

Reference

ThinningTypes Class
Emgu.CV.XImgproc Namespace


ThinningTypes.GuoHall Field

ThinningTypesGuoHall Field

Thinning technique of Guo-Hall

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThinningTypes GuoHall = 1
Public Const GuoHall As ThinningTypes = 1
public:
literal ThinningTypes^ GuoHall = 1
static val mutable GuoHall: ThinningTypes

Field Value

Type: ThinningTypes
See Also

Reference

ThinningTypes Class
Emgu.CV.XImgproc Namespace


ThinningTypes.value__ Field

ThinningTypesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XImgproc.ThinningTypes.value__"]

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ThinningTypes Class
Emgu.CV.XImgproc Namespace


ThinningTypes.ZhangSuen Field

ThinningTypesZhangSuen Field

Thinning technique of Zhang-Suen

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ThinningTypes ZhangSuen = 0
Public Const ZhangSuen As ThinningTypes = 0
public:
literal ThinningTypes^ ZhangSuen = 0
static val mutable ZhangSuen: ThinningTypes

Field Value

Type: ThinningTypes
See Also

Reference

ThinningTypes Class
Emgu.CV.XImgproc Namespace


WMFWeightType Class

Weight type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XImgprocWMFWeightType

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class WMFWeightType : Enum
Public NotInheritable Class WMFWeightType
    Inherits Enum
public ref class WMFWeightType sealed : public Enum
[<SealedAttribute>]
type WMFWeightType =
    class
        inherit Enum
    end

The WMFWeightType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Cos | dot(I1,I2)/(|I1|*|I2|)
 | Exp | exp(-|I1-I2|^2/(2*sigma^2))
 | Iv1 | (|I1-I2|+sigma)^-1
 | Iv2 | (|I1-I2|^2+sigma^2)^-1
 | Jac | (min(r1,r2)+min(g1,g2)+min(b1,b2))/(max(r1,r2)+max(g1,g2)+max(b1,b2))
 | Off | unweighted
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


WMFWeightType Methods

The WMFWeightType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType Fields

The WMFWeightType type exposes the following members.

Fields
 | Name | Description
 | Cos | dot(I1,I2)/(|I1|*|I2|)
 | Exp | exp(-|I1-I2|^2/(2*sigma^2))
 | Iv1 | (|I1-I2|+sigma)^-1
 | Iv2 | (|I1-I2|^2+sigma^2)^-1
 | Jac | (min(r1,r2)+min(g1,g2)+min(b1,b2))/(max(r1,r2)+max(g1,g2)+max(b1,b2))
 | Off | unweighted
Public field | value__ |
Top
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType.Cos Field

WMFWeightTypeCos Field

dot(I1,I2)/(|I1|*|I2|)

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WMFWeightType Cos = 3
Public Const Cos As WMFWeightType = 3
public:
literal WMFWeightType^ Cos = 3
static val mutable Cos: WMFWeightType

Field Value

Type: WMFWeightType
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType.Exp Field

WMFWeightTypeExp Field

exp(-|I1-I2|^2/(2*sigma^2))

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WMFWeightType Exp = 0
Public Const Exp As WMFWeightType = 0
public:
literal WMFWeightType^ Exp = 0
static val mutable Exp: WMFWeightType

Field Value

Type: WMFWeightType
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType.Iv1 Field

WMFWeightTypeIv1 Field

(|I1-I2|+sigma)^-1

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WMFWeightType Iv1 = 1
Public Const Iv1 As WMFWeightType = 1
public:
literal WMFWeightType^ Iv1 = 1
static val mutable Iv1: WMFWeightType

Field Value

Type: WMFWeightType
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType.Iv2 Field

WMFWeightTypeIv2 Field

(|I1-I2|^2+sigma^2)^-1

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WMFWeightType Iv2 = 2
Public Const Iv2 As WMFWeightType = 2
public:
literal WMFWeightType^ Iv2 = 2
static val mutable Iv2: WMFWeightType

Field Value

Type: WMFWeightType
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType.Jac Field

WMFWeightTypeJac Field

(min(r1,r2)+min(g1,g2)+min(b1,b2))/(max(r1,r2)+max(g1,g2)+max(b1,b2))

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WMFWeightType Jac = 4
Public Const Jac As WMFWeightType = 4
public:
literal WMFWeightType^ Jac = 4
static val mutable Jac: WMFWeightType

Field Value

Type: WMFWeightType
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType.Off Field

WMFWeightTypeOff Field

unweighted

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const WMFWeightType Off = 5
Public Const Off As WMFWeightType = 5
public:
literal WMFWeightType^ Off = 5
static val mutable Off: WMFWeightType

Field Value

Type: WMFWeightType
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


WMFWeightType.value__ Field

WMFWeightTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XImgproc.WMFWeightType.value__"]

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

WMFWeightType Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke Class

Library to invoke XImgproc functions
Extended Image Processing
Inheritance Hierarchy
SystemObject
Emgu.CV.XImgprocXImgprocInvoke

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class XImgprocInvoke
<ExtensionAttribute>
Public NotInheritable Class XImgprocInvoke
[ExtensionAttribute]
public ref class XImgprocInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type XImgprocInvoke =  class end

The XImgprocInvoke type exposes the following members.

Methods
Name | Description
AmFilter | Simple one-line Adaptive Manifold Filter call.
AnisotropicDiffusion | Performs anisotropic diffusion on an image.
BilateralTextureFilter | Applies the bilateral texture filter to an image. It performs structure-preserving texture filter.
BrightEdges | Brighten the edges of the image
CovarianceEstimation | Computes the estimated covariance matrix of an image using the sliding window forumlation.
DtFilter | Simple one-line Domain Transform filter call.
FastGlobalSmootherFilter | Simple one-line Fast Global Smoother filter call.
Filter | Apply filtering to the disparity map.
GradientDericheX | Applies X Deriche filter to an image.
GradientDericheY | Applies Y Deriche filter to an image.
GradientPaillouX | Applies Paillou filter to an image.
GradientPaillouY | Applies Paillou filter to an image.
GuidedFilter | Simple one-line Guided Filter call.
JointBilateralFilter | Applies the joint bilateral filter to an image.
L0Smooth | Global image smoothing via L0 gradient minimization.
NiBlackThreshold | Niblack threshold
RollingGuidanceFilter | Applies the rolling guidance filter to an image
Thinning | Applies a binary blob thinning operation, to achieve a skeletization of the input image. The function transforms a binary blob image into a skeletized form using the technique of Zhang-Suen.
WeightedMedianFilter | Applies weighted median filter to an image.
Top
See Also

Reference

Emgu.CV.XImgproc Namespace


XImgprocInvoke Methods

The XImgprocInvoke type exposes the following members.

Methods
Name | Description
AmFilter | Simple one-line Adaptive Manifold Filter call.
AnisotropicDiffusion | Performs anisotropic diffusion on an image.
BilateralTextureFilter | Applies the bilateral texture filter to an image. It performs structure-preserving texture filter.
BrightEdges | Brighten the edges of the image
CovarianceEstimation | Computes the estimated covariance matrix of an image using the sliding window forumlation.
DtFilter | Simple one-line Domain Transform filter call.
FastGlobalSmootherFilter | Simple one-line Fast Global Smoother filter call.
Filter | Apply filtering to the disparity map.
GradientDericheX | Applies X Deriche filter to an image.
GradientDericheY | Applies Y Deriche filter to an image.
GradientPaillouX | Applies Paillou filter to an image.
GradientPaillouY | Applies Paillou filter to an image.
GuidedFilter | Simple one-line Guided Filter call.
JointBilateralFilter | Applies the joint bilateral filter to an image.
L0Smooth | Global image smoothing via L0 gradient minimization.
NiBlackThreshold | Niblack threshold
RollingGuidanceFilter | Applies the rolling guidance filter to an image
Thinning | Applies a binary blob thinning operation, to achieve a skeletization of the input image. The function transforms a binary blob image into a skeletized form using the technique of Zhang-Suen.
WeightedMedianFilter | Applies weighted median filter to an image.
Top
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.AmFilter Method

XImgprocInvokeAmFilter Method

Simple one-line Adaptive Manifold Filter call.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AmFilter(
    IInputArray joint,
    IInputArray src,
    IOutputArray dst,
    double sigmaS,
    double sigmaR,
    bool adjustOutliers = false
)
Public Shared Sub AmFilter (
    joint As IInputArray,
    src As IInputArray,
    dst As IOutputArray,
    sigmaS As Double,
    sigmaR As Double,
    Optional adjustOutliers As Boolean = false
)
public:
static void AmFilter(
    IInputArray^ joint,
    IInputArray^ src,
    IOutputArray^ dst,
    double sigmaS,
    double sigmaR,
    bool adjustOutliers = false
)
static member AmFilter :
        joint : IInputArray *
        src : IInputArray *
        dst : IOutputArray *
        sigmaS : float *
        sigmaR : float *
        ?adjustOutliers : bool
(* Defaults:
        let _adjustOutliers = defaultArg adjustOutliers false
*)
-> unit

Parameters

joint
Type: Emgu.CVIInputArray
joint (also called as guided) image or array of images with any numbers of channels.
src
Type: Emgu.CVIInputArray
filtering image with any numbers of channels.
dst
Type: Emgu.CVIOutputArray
output image.
sigmaS
Type: SystemDouble
spatial standard deviation.
sigmaR
Type: SystemDouble
color space standard deviation, it is similar to the sigma in the color space into bilateralFilter.
adjustOutliers (Optional)
Type: SystemBoolean
optional, specify perform outliers adjust operation or not, (Eq. 9) in the original paper.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.AnisotropicDiffusion Method

XImgprocInvokeAnisotropicDiffusion Method

Performs anisotropic diffusion on an image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void AnisotropicDiffusion(
    IInputArray src,
    IOutputArray dst,
    float alpha,
    float K,
    int niters
)
Public Shared Sub AnisotropicDiffusion (
    src As IInputArray,
    dst As IOutputArray,
    alpha As Single,
    K As Single,
    niters As Integer
)
public:
static void AnisotropicDiffusion(
    IInputArray^ src,
    IOutputArray^ dst,
    float alpha,
    float K,
    int niters
)
static member AnisotropicDiffusion :
        src : IInputArray *
        dst : IOutputArray *
        alpha : float32 *
        K : float32 *
        niters : int -> unit

Parameters

src
Type: Emgu.CVIInputArray
Grayscale Source image.
dst
Type: Emgu.CVIOutputArray
Destination image of the same size and the same number of channels as src .
alpha
Type: SystemSingle
The amount of time to step forward by on each iteration (normally, it's between 0 and 1).
K
Type: SystemSingle
sensitivity to the edges
niters
Type: SystemInt32
The number of iterations
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.BilateralTextureFilter Method

XImgprocInvokeBilateralTextureFilter Method

Applies the bilateral texture filter to an image. It performs structure-preserving texture filter.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BilateralTextureFilter(
    IInputArray src,
    IOutputArray dst,
    int fr = 3,
    int numIter = 1,
    double sigmaAlpha = -1,
    double sigmaAvg = -1
)
Public Shared Sub BilateralTextureFilter (
    src As IInputArray,
    dst As IOutputArray,
    Optional fr As Integer = 3,
    Optional numIter As Integer = 1,
    Optional sigmaAlpha As Double = -1,
    Optional sigmaAvg As Double = -1
)
public:
static void BilateralTextureFilter(
    IInputArray^ src,
    IOutputArray^ dst,
    int fr = 3,
    int numIter = 1,
    double sigmaAlpha = -1,
    double sigmaAvg = -1
)
static member BilateralTextureFilter :
        src : IInputArray *
        dst : IOutputArray *
        ?fr : int *
        ?numIter : int *
        ?sigmaAlpha : float *
        ?sigmaAvg : float
(* Defaults:
        let _fr = defaultArg fr 3
        let _numIter = defaultArg numIter 1
        let _sigmaAlpha = defaultArg sigmaAlpha -1
        let _sigmaAvg = defaultArg sigmaAvg -1
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image whose depth is 8-bit UINT or 32-bit FLOAT
dst
Type: Emgu.CVIOutputArray
Destination image of the same size and type as src.
fr (Optional)
Type: SystemInt32
Radius of kernel to be used for filtering. It should be positive integer
numIter (Optional)
Type: SystemInt32
Number of iterations of algorithm, It should be positive integer
sigmaAlpha (Optional)
Type: SystemDouble
Controls the sharpness of the weight transition from edges to smooth/texture regions, where a bigger value means sharper transition. When the value is negative, it is automatically calculated.
sigmaAvg (Optional)
Type: SystemDouble
Range blur parameter for texture blurring. Larger value makes result to be more blurred. When the value is negative, it is automatically calculated as described in the paper.
Remarks
For more details about this filter see: Hojin Cho, Hyunjoon Lee, Henry Kang, and Seungyong Lee. Bilateral texture filtering. ACM Transactions on Graphics, 33(4):128:1–128:8, July 2014.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.BrightEdges Method

XImgprocInvokeBrightEdges Method

Brighten the edges of the image

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void BrightEdges(
    Mat original,
    Mat edgeview,
    int contrast,
    int shortrange,
    int longrange
)
Public Shared Sub BrightEdges (
    original As Mat,
    edgeview As Mat,
    contrast As Integer,
    shortrange As Integer,
    longrange As Integer
)
public:
static void BrightEdges(
    Mat^ original,
    Mat^ edgeview,
    int contrast,
    int shortrange,
    int longrange
)
static member BrightEdges :
        original : Mat *
        edgeview : Mat *
        contrast : int *
        shortrange : int *
        longrange : int -> unit

Parameters

original
Type: Emgu.CVMat
The source image
edgeview
Type: Emgu.CVMat
The result
contrast
Type: SystemInt32
Contrast
shortrange
Type: SystemInt32
Short Range
longrange
Type: SystemInt32
Long Range
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.CovarianceEstimation Method

XImgprocInvokeCovarianceEstimation Method

Computes the estimated covariance matrix of an image using the sliding window forumlation.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void CovarianceEstimation(
    IInputArray src,
    IOutputArray dst,
    int windowRows,
    int windowCols
)
Public Shared Sub CovarianceEstimation (
    src As IInputArray,
    dst As IOutputArray,
    windowRows As Integer,
    windowCols As Integer
)
public:
static void CovarianceEstimation(
    IInputArray^ src,
    IOutputArray^ dst,
    int windowRows,
    int windowCols
)
static member CovarianceEstimation :
        src : IInputArray *
        dst : IOutputArray *
        windowRows : int *
        windowCols : int -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image. Input image must be of a complex type.
dst
Type: Emgu.CVIOutputArray
The destination estimated covariance matrix. Output matrix will be size (windowRows*windowCols, windowRows*windowCols).
windowRows
Type: SystemInt32
The number of rows in the window.
windowCols
Type: SystemInt32
The number of cols in the window. The window size parameters control the accuracy of the estimation. The sliding window moves over the entire image from the top-left corner to the bottom right corner. Each location of the window represents a sample. If the window is the size of the image, then this gives the exact covariance matrix. For all other cases, the sizes of the window will impact the number of samples and the number of elements in the estimated covariance matrix.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.DtFilter Method

XImgprocInvokeDtFilter Method

Simple one-line Domain Transform filter call.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DtFilter(
    IInputArray guide,
    IInputArray src,
    IOutputArray dst,
    double sigmaSpatial,
    double sigmaColor,
    DtFilterType mode,
    int numIters = 3
)
Public Shared Sub DtFilter (
    guide As IInputArray,
    src As IInputArray,
    dst As IOutputArray,
    sigmaSpatial As Double,
    sigmaColor As Double,
    mode As DtFilterType,
    Optional numIters As Integer = 3
)
public:
static void DtFilter(
    IInputArray^ guide,
    IInputArray^ src,
    IOutputArray^ dst,
    double sigmaSpatial,
    double sigmaColor,
    DtFilterType^ mode,
    int numIters = 3
)
static member DtFilter :
        guide : IInputArray *
        src : IInputArray *
        dst : IOutputArray *
        sigmaSpatial : float *
        sigmaColor : float *
        mode : DtFilterType *
        ?numIters : int
(* Defaults:
        let _numIters = defaultArg numIters 3
*)
-> unit

Parameters

guide
Type: Emgu.CVIInputArray
guided image (also called as joint image) with unsigned 8-bit or floating-point 32-bit depth and up to 4 channels.
src
Type: Emgu.CVIInputArray
filtering image with unsigned 8-bit or floating-point 32-bit depth and up to 4 channels.
dst
Type: Emgu.CVIOutputArray
output image
sigmaSpatial
Type: SystemDouble
parameter in the original article, it's similar to the sigma in the coordinate space into bilateralFilter.
sigmaColor
Type: SystemDouble
parameter in the original article, it's similar to the sigma in the color space into bilateralFilter.
mode
Type: Emgu.CV.XImgprocDtFilterType
Dt filter mode
numIters (Optional)
Type: SystemInt32
optional number of iterations used for filtering, 3 is quite enough.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.FastGlobalSmootherFilter Method

XImgprocInvokeFastGlobalSmootherFilter Method

Simple one-line Fast Global Smoother filter call.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void FastGlobalSmootherFilter(
    IInputArray guide,
    IInputArray src,
    IOutputArray dst,
    double lambda,
    double sigmaColor,
    double lambdaAttenuation = 0.25,
    int numIter = 3
)
Public Shared Sub FastGlobalSmootherFilter (
    guide As IInputArray,
    src As IInputArray,
    dst As IOutputArray,
    lambda As Double,
    sigmaColor As Double,
    Optional lambdaAttenuation As Double = 0.25,
    Optional numIter As Integer = 3
)
public:
static void FastGlobalSmootherFilter(
    IInputArray^ guide,
    IInputArray^ src,
    IOutputArray^ dst,
    double lambda,
    double sigmaColor,
    double lambdaAttenuation = 0.25,
    int numIter = 3
)
static member FastGlobalSmootherFilter :
        guide : IInputArray *
        src : IInputArray *
        dst : IOutputArray *
        lambda : float *
        sigmaColor : float *
        ?lambdaAttenuation : float *
        ?numIter : int
(* Defaults:
        let _lambdaAttenuation = defaultArg lambdaAttenuation 0.25
        let _numIter = defaultArg numIter 3
*)
-> unit

Parameters

guide
Type: Emgu.CVIInputArray
image serving as guide for filtering. It should have 8-bit depth and either 1 or 3 channels.
src
Type: Emgu.CVIInputArray
source image for filtering with unsigned 8-bit or signed 16-bit or floating-point 32-bit depth and up to 4 channels.
dst
Type: Emgu.CVIOutputArray
destination image.
lambda
Type: SystemDouble
parameter defining the amount of regularization
sigmaColor
Type: SystemDouble
parameter, that is similar to color space sigma in bilateralFilter.
lambdaAttenuation (Optional)
Type: SystemDouble
internal parameter, defining how much lambda decreases after each iteration. Normally, it should be 0.25. Setting it to 1.0 may lead to streaking artifacts.
numIter (Optional)
Type: SystemInt32
number of iterations used for filtering, 3 is usually enough.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.Filter Method

XImgprocInvokeFilter Method

Apply filtering to the disparity map.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Filter(
    this IDisparityFilter filter,
    IInputArray disparityMapLeft,
    IOutputArray leftView,
    IOutputArray filteredDisparityMap,
    IInputArray disparityMapRight = null,
    Rectangle roi = null,
    IInputArray rightView = null
)
<ExtensionAttribute>
Public Shared Sub Filter (
    filter As IDisparityFilter,
    disparityMapLeft As IInputArray,
    leftView As IOutputArray,
    filteredDisparityMap As IOutputArray,
    Optional disparityMapRight As IInputArray = Nothing,
    Optional roi As Rectangle = Nothing,
    Optional rightView As IInputArray = Nothing
)
public:
[ExtensionAttribute]
static void Filter(
    IDisparityFilter^ filter,
    IInputArray^ disparityMapLeft,
    IOutputArray^ leftView,
    IOutputArray^ filteredDisparityMap,
    IInputArray^ disparityMapRight = nullptr,
    Rectangle^ roi = nullptr,
    IInputArray^ rightView = nullptr
)
[<ExtensionAttribute>]
static member Filter :
        filter : IDisparityFilter *
        disparityMapLeft : IInputArray *
        leftView : IOutputArray *
        filteredDisparityMap : IOutputArray *
        ?disparityMapRight : IInputArray *
        ?roi : Rectangle *
        ?rightView : IInputArray
(* Defaults:
        let _disparityMapRight = defaultArg disparityMapRight null
        let _roi = defaultArg roi null
        let _rightView = defaultArg rightView null
*)
-> unit

Parameters

filter
Type: Emgu.CV.XImgprocIDisparityFilter
The disparity filter
disparityMapLeft
Type: Emgu.CVIInputArray
Disparity map of the left view, 1 channel, CV_16S type. Implicitly assumes that disparity values are scaled by 16 (one-pixel disparity corresponds to the value of 16 in the disparity map). Disparity map can have any resolution, it will be automatically resized to fit left_view resolution.
leftView
Type: Emgu.CVIOutputArray
Left view of the original stereo-pair to guide the filtering process, 8-bit single-channel or three-channel image.
filteredDisparityMap
Type: Emgu.CVIOutputArray
Output disparity map.
disparityMapRight (Optional)
Type: Emgu.CVIInputArray
Optional argument, some implementations might also use the disparity map of the right view to compute confidence maps, for instance.
roi (Optional)
Type: System.DrawingRectangle
Region of the disparity map to filter. Optional, usually it should be set automatically.
rightView (Optional)
Type: Emgu.CVIInputArray
Optional argument, some implementations might also use the right view of the original stereo-pair.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDisparityFilter. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.GradientDericheX Method

XImgprocInvokeGradientDericheX Method

Applies X Deriche filter to an image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GradientDericheX(
    IInputArray op,
    IOutputArray dst,
    double alphaDerive,
    double alphaMean
)
Public Shared Sub GradientDericheX (
    op As IInputArray,
    dst As IOutputArray,
    alphaDerive As Double,
    alphaMean As Double
)
public:
static void GradientDericheX(
    IInputArray^ op,
    IOutputArray^ dst,
    double alphaDerive,
    double alphaMean
)
static member GradientDericheX :
        op : IInputArray *
        dst : IOutputArray *
        alphaDerive : float *
        alphaMean : float -> unit

Parameters

op
Type: Emgu.CVIInputArray
Source 8-bit or 16bit image, 1-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
result CV_32FC image with same number of channel than _op.
alphaDerive
Type: SystemDouble
see paper
alphaMean
Type: SystemDouble
see paper
Remarks
For more details about this implementation, please see http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.476.5736&rep=rep1&type=pdf
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.GradientDericheY Method

XImgprocInvokeGradientDericheY Method

Applies Y Deriche filter to an image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GradientDericheY(
    IInputArray op,
    IOutputArray dst,
    double alphaDerive,
    double alphaMean
)
Public Shared Sub GradientDericheY (
    op As IInputArray,
    dst As IOutputArray,
    alphaDerive As Double,
    alphaMean As Double
)
public:
static void GradientDericheY(
    IInputArray^ op,
    IOutputArray^ dst,
    double alphaDerive,
    double alphaMean
)
static member GradientDericheY :
        op : IInputArray *
        dst : IOutputArray *
        alphaDerive : float *
        alphaMean : float -> unit

Parameters

op
Type: Emgu.CVIInputArray
Source 8-bit or 16bit image, 1-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
result CV_32FC image with same number of channel than _op.
alphaDerive
Type: SystemDouble
see paper
alphaMean
Type: SystemDouble
see paper
Remarks
For more details about this implementation, please see here
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.GradientPaillouX Method

XImgprocInvokeGradientPaillouX Method

Applies Paillou filter to an image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GradientPaillouX(
    IInputArray op,
    IOutputArray dst,
    double alpha,
    double omega
)
Public Shared Sub GradientPaillouX (
    op As IInputArray,
    dst As IOutputArray,
    alpha As Double,
    omega As Double
)
public:
static void GradientPaillouX(
    IInputArray^ op,
    IOutputArray^ dst,
    double alpha,
    double omega
)
static member GradientPaillouX :
        op : IInputArray *
        dst : IOutputArray *
        alpha : float *
        omega : float -> unit

Parameters

op
Type: Emgu.CVIInputArray
Source 8-bit or 16bit image, 1-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
result CV_32F image with same number of channel than op.
alpha
Type: SystemDouble
see paper
omega
Type: SystemDouble
see paper
Remarks
For more details about this implementation, please see: Philippe Paillou. Detecting step edges in noisy sar images: a new linear operator. IEEE transactions on geoscience and remote sensing, 35(1):191–196, 1997.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.GradientPaillouY Method

XImgprocInvokeGradientPaillouY Method

Applies Paillou filter to an image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GradientPaillouY(
    IInputArray op,
    IOutputArray dst,
    double alpha,
    double omega
)
Public Shared Sub GradientPaillouY (
    op As IInputArray,
    dst As IOutputArray,
    alpha As Double,
    omega As Double
)
public:
static void GradientPaillouY(
    IInputArray^ op,
    IOutputArray^ dst,
    double alpha,
    double omega
)
static member GradientPaillouY :
        op : IInputArray *
        dst : IOutputArray *
        alpha : float *
        omega : float -> unit

Parameters

op
Type: Emgu.CVIInputArray
Source 8-bit or 16bit image, 1-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
result CV_32F image with same number of channel than op.
alpha
Type: SystemDouble
see paper
omega
Type: SystemDouble
see paper
Remarks
For more details about this implementation, please see: Philippe Paillou. Detecting step edges in noisy sar images: a new linear operator. IEEE transactions on geoscience and remote sensing, 35(1):191–196, 1997.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.GuidedFilter Method

XImgprocInvokeGuidedFilter Method

Simple one-line Guided Filter call.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GuidedFilter(
    IInputArray guide,
    IInputArray src,
    IOutputArray dst,
    int radius,
    double eps,
    DepthType dDepth = -1
)
Public Shared Sub GuidedFilter (
    guide As IInputArray,
    src As IInputArray,
    dst As IOutputArray,
    radius As Integer,
    eps As Double,
    Optional dDepth As DepthType = -1
)
public:
static void GuidedFilter(
    IInputArray^ guide,
    IInputArray^ src,
    IOutputArray^ dst,
    int radius,
    double eps,
    DepthType^ dDepth = -1
)
static member GuidedFilter :
        guide : IInputArray *
        src : IInputArray *
        dst : IOutputArray *
        radius : int *
        eps : float *
        ?dDepth : DepthType
(* Defaults:
        let _dDepth = defaultArg dDepth -1
*)
-> unit

Parameters

guide
Type: Emgu.CVIInputArray
guided image (or array of images) with up to 3 channels, if it have more then 3 channels then only first 3 channels will be used.
src
Type: Emgu.CVIInputArray
filtering image with any numbers of channels.
dst
Type: Emgu.CVIOutputArray
output image.
radius
Type: SystemInt32
radius of Guided Filter.
eps
Type: SystemDouble
regularization term of Guided Filter. eps^2 is similar to the sigma in the color space into bilateralFilter.
dDepth (Optional)
Type: Emgu.CV.CvEnumDepthType
optional depth of the output image.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.JointBilateralFilter Method

XImgprocInvokeJointBilateralFilter Method

Applies the joint bilateral filter to an image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void JointBilateralFilter(
    IInputArray joint,
    IInputArray src,
    IOutputArray dst,
    int d,
    double sigmaColor,
    double sigmaSpace,
    BorderType borderType = 4
)
Public Shared Sub JointBilateralFilter (
    joint As IInputArray,
    src As IInputArray,
    dst As IOutputArray,
    d As Integer,
    sigmaColor As Double,
    sigmaSpace As Double,
    Optional borderType As BorderType = 4
)
public:
static void JointBilateralFilter(
    IInputArray^ joint,
    IInputArray^ src,
    IOutputArray^ dst,
    int d,
    double sigmaColor,
    double sigmaSpace,
    BorderType^ borderType = 4
)
static member JointBilateralFilter :
        joint : IInputArray *
        src : IInputArray *
        dst : IOutputArray *
        d : int *
        sigmaColor : float *
        sigmaSpace : float *
        ?borderType : BorderType
(* Defaults:
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

joint
Type: Emgu.CVIInputArray
Joint 8-bit or floating-point, 1-channel or 3-channel image.
src
Type: Emgu.CVIInputArray
Source 8-bit or floating-point, 1-channel or 3-channel image with the same depth as joint image.
dst
Type: Emgu.CVIOutputArray
Destination image of the same size and type as src .
d
Type: SystemInt32
Diameter of each pixel neighborhood that is used during filtering. If it is non-positive, it is computed from sigmaSpace .
sigmaColor
Type: SystemDouble
Filter sigma in the color space. A larger value of the parameter means that farther colors within the pixel neighborhood (see sigmaSpace ) will be mixed together, resulting in larger areas of semi-equal color.
sigmaSpace
Type: SystemDouble
Filter sigma in the coordinate space. A larger value of the parameter means that farther pixels will influence each other as long as their colors are close enough (see sigmaColor ). When d>0 , it specifies the neighborhood size regardless of sigmaSpace . Otherwise, d is proportional to sigmaSpace .
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border type
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.L0Smooth Method

XImgprocInvokeL0Smooth Method

Global image smoothing via L0 gradient minimization.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void L0Smooth(
    IInputArray src,
    IOutputArray dst,
    double lambda = 0.02,
    double kappa = 2
)
Public Shared Sub L0Smooth (
    src As IInputArray,
    dst As IOutputArray,
    Optional lambda As Double = 0.02,
    Optional kappa As Double = 2
)
public:
static void L0Smooth(
    IInputArray^ src,
    IOutputArray^ dst,
    double lambda = 0.02,
    double kappa = 2
)
static member L0Smooth :
        src : IInputArray *
        dst : IOutputArray *
        ?lambda : float *
        ?kappa : float
(* Defaults:
        let _lambda = defaultArg lambda 0.02
        let _kappa = defaultArg kappa 2
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source image for filtering with unsigned 8-bit or signed 16-bit or floating-point depth.
dst
Type: Emgu.CVIOutputArray
Destination image.
lambda (Optional)
Type: SystemDouble
Parameter defining the smooth term weight.
kappa (Optional)
Type: SystemDouble
Parameter defining the increasing factor of the weight of the gradient data term.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.NiBlackThreshold Method

XImgprocInvokeNiBlackThreshold Method

Niblack threshold

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void NiBlackThreshold(
    IInputArray src,
    IOutputArray dst,
    double maxValue,
    LocalBinarizationMethods type,
    int blockSize,
    double delta
)
Public Shared Sub NiBlackThreshold (
    src As IInputArray,
    dst As IOutputArray,
    maxValue As Double,
    type As LocalBinarizationMethods,
    blockSize As Integer,
    delta As Double
)
public:
static void NiBlackThreshold(
    IInputArray^ src,
    IOutputArray^ dst,
    double maxValue,
    LocalBinarizationMethods^ type,
    int blockSize,
    double delta
)
static member NiBlackThreshold :
        src : IInputArray *
        dst : IOutputArray *
        maxValue : float *
        type : LocalBinarizationMethods *
        blockSize : int *
        delta : float -> unit

Parameters

src
Type: Emgu.CVIInputArray
The source image
dst
Type: Emgu.CVIOutputArray
The output result
maxValue
Type: SystemDouble
Maximum value to use with CV_THRESH_BINARY and CV_THRESH_BINARY_INV thresholding types
type
Type: Emgu.CV.XImgprocLocalBinarizationMethods
Value that defines which local binarization algorithm should be used.
blockSize
Type: SystemInt32
Block size
delta
Type: SystemDouble
delta
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.RollingGuidanceFilter Method

XImgprocInvokeRollingGuidanceFilter Method

Applies the rolling guidance filter to an image

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void RollingGuidanceFilter(
    IInputArray src,
    IOutputArray dst,
    int d = -1,
    double sigmaColor = 25,
    double sigmaSpace = 3,
    int numOfIter = 4,
    BorderType borderType = 4
)
Public Shared Sub RollingGuidanceFilter (
    src As IInputArray,
    dst As IOutputArray,
    Optional d As Integer = -1,
    Optional sigmaColor As Double = 25,
    Optional sigmaSpace As Double = 3,
    Optional numOfIter As Integer = 4,
    Optional borderType As BorderType = 4
)
public:
static void RollingGuidanceFilter(
    IInputArray^ src,
    IOutputArray^ dst,
    int d = -1,
    double sigmaColor = 25,
    double sigmaSpace = 3,
    int numOfIter = 4,
    BorderType^ borderType = 4
)
static member RollingGuidanceFilter :
        src : IInputArray *
        dst : IOutputArray *
        ?d : int *
        ?sigmaColor : float *
        ?sigmaSpace : float *
        ?numOfIter : int *
        ?borderType : BorderType
(* Defaults:
        let _d = defaultArg d -1
        let _sigmaColor = defaultArg sigmaColor 25
        let _sigmaSpace = defaultArg sigmaSpace 3
        let _numOfIter = defaultArg numOfIter 4
        let _borderType = defaultArg borderType 4
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Source 8-bit or floating-point, 1-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Destination image of the same size and type as src.
d (Optional)
Type: SystemInt32
Diameter of each pixel neighborhood that is used during filtering. If it is non-positive, it is computed from sigmaSpace .
sigmaColor (Optional)
Type: SystemDouble
Filter sigma in the color space. A larger value of the parameter means that farther colors within the pixel neighborhood (see sigmaSpace ) will be mixed together, resulting in larger areas of semi-equal color.
sigmaSpace (Optional)
Type: SystemDouble
Filter sigma in the coordinate space. A larger value of the parameter means that farther pixels will influence each other as long as their colors are close enough (see sigmaColor ). When d>0 , it specifies the neighborhood size regardless of sigmaSpace . Otherwise, d is proportional to sigmaSpace .
numOfIter (Optional)
Type: SystemInt32
Number of iterations of joint edge-preserving filtering applied on the source image.
borderType (Optional)
Type: Emgu.CV.CvEnumBorderType
Border type
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.Thinning Method

XImgprocInvokeThinning Method

Applies a binary blob thinning operation, to achieve a skeletization of the input image. The function transforms a binary blob image into a skeletized form using the technique of Zhang-Suen.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Thinning(
    IInputArray src,
    IOutputArray dst,
    ThinningTypes thinningType
)
Public Shared Sub Thinning (
    src As IInputArray,
    dst As IOutputArray,
    thinningType As ThinningTypes
)
public:
static void Thinning(
    IInputArray^ src,
    IOutputArray^ dst,
    ThinningTypes^ thinningType
)
static member Thinning :
        src : IInputArray *
        dst : IOutputArray *
        thinningType : ThinningTypes -> unit

Parameters

src
Type: Emgu.CVIInputArray
Source 8-bit single-channel image, containing binary blobs, with blobs having 255 pixel values.
dst
Type: Emgu.CVIOutputArray
Destination image of the same size and the same type as src. The function can work in-place.
thinningType
Type: Emgu.CV.XImgprocThinningTypes
Value that defines which thinning algorithm should be used.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


XImgprocInvoke.WeightedMedianFilter Method

XImgprocInvokeWeightedMedianFilter Method

Applies weighted median filter to an image.

Namespace: Emgu.CV.XImgproc
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void WeightedMedianFilter(
    IInputArray joint,
    IInputArray src,
    IOutputArray dst,
    int r,
    double sigma = 25.5,
    WMFWeightType weightType = 0,
    Mat mask = null
)
Public Shared Sub WeightedMedianFilter (
    joint As IInputArray,
    src As IInputArray,
    dst As IOutputArray,
    r As Integer,
    Optional sigma As Double = 25.5,
    Optional weightType As WMFWeightType = 0,
    Optional mask As Mat = Nothing
)
public:
static void WeightedMedianFilter(
    IInputArray^ joint,
    IInputArray^ src,
    IOutputArray^ dst,
    int r,
    double sigma = 25.5,
    WMFWeightType^ weightType = 0,
    Mat^ mask = nullptr
)
static member WeightedMedianFilter :
        joint : IInputArray *
        src : IInputArray *
        dst : IOutputArray *
        r : int *
        ?sigma : float *
        ?weightType : WMFWeightType *
        ?mask : Mat
(* Defaults:
        let _sigma = defaultArg sigma 25.5
        let _weightType = defaultArg weightType 0
        let _mask = defaultArg mask null
*)
-> unit

Parameters

joint
Type: Emgu.CVIInputArray
Joint 8-bit, 1-channel or 3-channel image.
src
Type: Emgu.CVIInputArray
Source 8-bit or floating-point, 1-channel or 3-channel image.
dst
Type: Emgu.CVIOutputArray
Destination image.
r
Type: SystemInt32
Radius of filtering kernel, should be a positive integer.
sigma (Optional)
Type: SystemDouble
Filter range standard deviation for the joint image.
weightType (Optional)
Type: Emgu.CV.XImgprocWMFWeightType
The type of weight definition
mask (Optional)
Type: Emgu.CVMat
A 0-1 mask that has the same size with I. This mask is used to ignore the effect of some pixels. If the pixel value on mask is 0, the pixel will be ignored when maintaining the joint-histogram. This is useful for applications like optical flow occlusion handling.
Remarks
For more details about this implementation, please see: Qi Zhang, Li Xu, and Jiaya Jia. 100+ times faster weighted median filter (wmf). In Computer Vision and Pattern Recognition (CVPR), 2014 IEEE Conference on, pages 2830–2837. IEEE, 2014.
See Also

Reference

XImgprocInvoke Class
Emgu.CV.XImgproc Namespace


Emgu.CV.XObjdetect Namespace

Extended object detection
Classes
 | Class | Description
Public class | WBDetector | WaldBoost detector.
Public class | XObjdetectInvoke | Class that contains entry points for the XObjdetect module.


WBDetector Class

WaldBoost detector.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XObjdetectWBDetector

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class WBDetector : UnmanagedObject
Public Class WBDetector
    Inherits UnmanagedObject
public ref class WBDetector : public UnmanagedObject
type WBDetector =
    class
        inherit UnmanagedObject
    end

The WBDetector type exposes the following members.

Constructors
 | Name | Description
Public method | WBDetector | Create instance of WBDetector.
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | Detect | Detect objects on image using WaldBoost detector.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this WBDetector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read detector from FileNode.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Train WaldBoost detector.
Public method | Write | Write detector to FileStorage.
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

Emgu.CV.XObjdetect Namespace


WBDetector Constructor

Create instance of WBDetector.

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public WBDetector()
Public Sub New
public:
WBDetector()
new : unit -> WBDetector
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector Properties

The WBDetector type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector Methods

The WBDetector type exposes the following members.

Methods
 | Name | Description
Public method | Detect | Detect objects on image using WaldBoost detector.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this WBDetector. (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read detector from FileNode.
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Train | Train WaldBoost detector.
Public method | Write | Write detector to FileStorage.
Top
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector.Detect Method

WBDetectorDetect Method

Detect objects on image using WaldBoost detector.

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Detect(
    Mat image,
    VectorOfRect bboxes,
    VectorOfDouble confidences
)
Public Sub Detect (
    image As Mat,
    bboxes As VectorOfRect,
    confidences As VectorOfDouble
)
public:
void Detect(
    Mat^ image,
    VectorOfRect^ bboxes,
    VectorOfDouble^ confidences
)
member Detect :
        image : Mat *
        bboxes : VectorOfRect *
        confidences : VectorOfDouble -> unit

Parameters

image
Type: Emgu.CVMat
Input image for detection
bboxes
Type: Emgu.CV.UtilVectorOfRect
Bounding boxes coordinates output vector
confidences
Type: Emgu.CV.UtilVectorOfDouble
Confidence values for bounding boxes output vector
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector.DisposeObject Method

WBDetectorDisposeObject Method

Release all the unmanaged memory associated with this WBDetector.

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector.Read Method

WBDetectorRead Method

Read detector from FileNode.

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Read(
    FileNode node
)
Public Sub Read (
    node As FileNode
)
public:
void Read(
    FileNode^ node
)
member Read :
        node : FileNode -> unit

Parameters

node
Type: Emgu.CVFileNode
FileNode for input
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector.Train Method

WBDetectorTrain Method

Train WaldBoost detector.

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Train(
    string posSamples,
    string negImgs
)
Public Sub Train (
    posSamples As String,
    negImgs As String
)
public:
void Train(
    String^ posSamples,
    String^ negImgs
)
member Train :
        posSamples : string *
        negImgs : string -> unit

Parameters

posSamples
Type: SystemString
Path to directory with cropped positive samples
negImgs
Type: SystemString
Path to directory with negative (background) images
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector.Write Method

WBDetectorWrite Method

Write detector to FileStorage.

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    FileStorage fs
)
Public Sub Write (
    fs As FileStorage
)
public:
void Write(
    FileStorage^ fs
)
member Write :
        fs : FileStorage -> unit

Parameters

fs
Type: Emgu.CVFileStorage
FileStorage for output
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


WBDetector Fields

The WBDetector type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WBDetector Class
Emgu.CV.XObjdetect Namespace


XObjdetectInvoke Class

Class that contains entry points for the XObjdetect module.
Inheritance Hierarchy
SystemObject
Emgu.CV.XObjdetectXObjdetectInvoke

Namespace: Emgu.CV.XObjdetect
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class XObjdetectInvoke
Public NotInheritable Class XObjdetectInvoke
public ref class XObjdetectInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XObjdetectInvoke =  class end
See Also

Reference

Emgu.CV.XObjdetect Namespace


Emgu.CV.XPhoto Namespace

Additional photo processing algorithms
Classes
 | Class | Description
Public class | Bm3dSteps | BM3D steps
Public class | GrayworldWB | Gray-world white balance algorithm. This algorithm scales the values of pixels based on a gray-world assumption which states that the average of all channels should result in a gray image. It adds a modification which thresholds pixels based on their saturation value and only uses pixels below the provided threshold in finding average pixel values. Saturation is calculated using the following for a 3-channel RGB image per pixel I and is in the range [0, 1]: Saturation[I]= max(R,G,B)-min(R,G,B) / max(R,G,B) A threshold of 1 means that all pixels are used to white-balance, while a threshold of 0 means no pixels are used. Lower thresholds are useful in white-balancing saturated images. Currently supports images of type CV_8UC3 and CV_16UC3.
Public class | LearningBasedWB | More sophisticated learning-based automatic white balance algorithm. As GrayworldWB, this algorithm works by applying different gains to the input image channels, but their computation is a bit more involved compared to the simple gray-world assumption. More details about the algorithm can be found in: Dongliang Cheng, Brian Price, Scott Cohen, and Michael S Brown. Effective learning-based illuminant estimation using simple features. In Proceedings of the IEEE Conference on Computer Vision and Pattern Recognition, pages 1000-1008, 2015. To mask out saturated pixels this function uses only pixels that satisfy the following condition: max(R,G,B) / range_max_val < saturation_thresh Currently supports images of type CV_8UC3 and CV_16UC3.
Public class | SimpleWB | A simple white balance algorithm that works by independently stretching each of the input image channels to the specified range. For increased robustness it ignores the top and bottom p% of pixel values.
Public class | TonemapDurand | This algorithm decomposes image into two layers: base layer and detail layer using bilateral filter and compresses contrast of the base layer thus preserving all the details. This implementation uses regular bilateral filter from opencv.
Public class | TransformTypes | BM3D denoising transform types
Public class | WhiteBalancer | The base class for auto white balance algorithms.
Public class | XPhotoInvoke | Class that contains entry points for the XPhoto module.
Public class | XPhotoInvokeInpaintType | Inpaint type


Bm3dSteps Class

BM3D steps
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XPhotoBm3dSteps

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Bm3dSteps : Enum
Public NotInheritable Class Bm3dSteps
    Inherits Enum
public ref class Bm3dSteps sealed : public Enum
[<SealedAttribute>]
type Bm3dSteps =
    class
        inherit Enum
    end

The Bm3dSteps type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Execute all steps of the algorithm
 | Step1 | Execute only first step of the algorithm
 | Step2 | Execute only second step of the algorithm
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


Bm3dSteps Methods

The Bm3dSteps type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

Bm3dSteps Class
Emgu.CV.XPhoto Namespace


Bm3dSteps Fields

The Bm3dSteps type exposes the following members.

Fields
 | Name | Description
 | All | Execute all steps of the algorithm
 | Step1 | Execute only first step of the algorithm
 | Step2 | Execute only second step of the algorithm
Public field | value__ |
Top
See Also

Reference

Bm3dSteps Class
Emgu.CV.XPhoto Namespace


Bm3dSteps.All Field

Bm3dStepsAll Field

Execute all steps of the algorithm

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Bm3dSteps All = 0
Public Const All As Bm3dSteps = 0
public:
literal Bm3dSteps^ All = 0
static val mutable All: Bm3dSteps

Field Value

Type: Bm3dSteps
See Also

Reference

Bm3dSteps Class
Emgu.CV.XPhoto Namespace


Bm3dSteps.Step1 Field

Bm3dStepsStep1 Field

Execute only first step of the algorithm

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Bm3dSteps Step1 = 1
Public Const Step1 As Bm3dSteps = 1
public:
literal Bm3dSteps^ Step1 = 1
static val mutable Step1: Bm3dSteps

Field Value

Type: Bm3dSteps
See Also

Reference

Bm3dSteps Class
Emgu.CV.XPhoto Namespace


Bm3dSteps.Step2 Field

Bm3dStepsStep2 Field

Execute only second step of the algorithm

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const Bm3dSteps Step2 = 2
Public Const Step2 As Bm3dSteps = 2
public:
literal Bm3dSteps^ Step2 = 2
static val mutable Step2: Bm3dSteps

Field Value

Type: Bm3dSteps
See Also

Reference

Bm3dSteps Class
Emgu.CV.XPhoto Namespace


Bm3dSteps.value__ Field

Bm3dStepsvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XPhoto.Bm3dSteps.value__"]

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

Bm3dSteps Class
Emgu.CV.XPhoto Namespace


GrayworldWB Class

Gray-world white balance algorithm. This algorithm scales the values of pixels based on a gray-world assumption which states that the average of all channels should result in a gray image. It adds a modification which thresholds pixels based on their saturation value and only uses pixels below the provided threshold in finding average pixel values. Saturation is calculated using the following for a 3-channel RGB image per pixel I and is in the range [0, 1]: Saturation[I]= max(R,G,B)-min(R,G,B) / max(R,G,B) A threshold of 1 means that all pixels are used to white-balance, while a threshold of 0 means no pixels are used. Lower thresholds are useful in white-balancing saturated images. Currently supports images of type CV_8UC3 and CV_16UC3.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XPhotoWhiteBalancer
Emgu.CV.XPhotoGrayworldWB

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class GrayworldWB : WhiteBalancer
Public Class GrayworldWB
    Inherits WhiteBalancer
public ref class GrayworldWB : public WhiteBalancer
type GrayworldWB =
    class
        inherit WhiteBalancer
    end

The GrayworldWB type exposes the following members.

Constructors
 | Name | Description
Public method | GrayworldWB | Creates a gray-world white balancer
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaturationThreshold | Maximum saturation for a pixel to be included in the gray-world assumption
Top
Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image. (Inherited from WhiteBalancer.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this white balancer (Overrides WhiteBalancerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object (Inherited from WhiteBalancer.)
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


GrayworldWB Constructor

Creates a gray-world white balancer

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public GrayworldWB()
Public Sub New
public:
GrayworldWB()
new : unit -> GrayworldWB
See Also

Reference

GrayworldWB Class
Emgu.CV.XPhoto Namespace


GrayworldWB Properties

The GrayworldWB type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | SaturationThreshold | Maximum saturation for a pixel to be included in the gray-world assumption
Top
See Also

Reference

GrayworldWB Class
Emgu.CV.XPhoto Namespace


GrayworldWB.SaturationThreshold Property

GrayworldWBSaturationThreshold Property

Maximum saturation for a pixel to be included in the gray-world assumption

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float SaturationThreshold { get; set; }
Public Property SaturationThreshold As Single
    Get
    Set
public:
property float SaturationThreshold {
    float get ();
    void set (float value);
}
member SaturationThreshold : float32 with get, set

Property Value

Type: Single
See Also

Reference

GrayworldWB Class
Emgu.CV.XPhoto Namespace


GrayworldWB Methods

The GrayworldWB type exposes the following members.

Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image. (Inherited from WhiteBalancer.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this white balancer (Overrides WhiteBalancerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GrayworldWB Class
Emgu.CV.XPhoto Namespace


GrayworldWB.DisposeObject Method

GrayworldWBDisposeObject Method

Release all the unmanaged memory associated with this white balancer

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

GrayworldWB Class
Emgu.CV.XPhoto Namespace


GrayworldWB Fields

The GrayworldWB type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object (Inherited from WhiteBalancer.)
Top
See Also

Reference

GrayworldWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB Class

More sophisticated learning-based automatic white balance algorithm. As GrayworldWB, this algorithm works by applying different gains to the input image channels, but their computation is a bit more involved compared to the simple gray-world assumption. More details about the algorithm can be found in: Dongliang Cheng, Brian Price, Scott Cohen, and Michael S Brown. Effective learning-based illuminant estimation using simple features. In Proceedings of the IEEE Conference on Computer Vision and Pattern Recognition, pages 1000-1008, 2015. To mask out saturated pixels this function uses only pixels that satisfy the following condition: max(R,G,B) / range_max_val < saturation_thresh Currently supports images of type CV_8UC3 and CV_16UC3.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XPhotoWhiteBalancer
Emgu.CV.XPhotoLearningBasedWB

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class LearningBasedWB : WhiteBalancer
Public Class LearningBasedWB
    Inherits WhiteBalancer
public ref class LearningBasedWB : public WhiteBalancer
type LearningBasedWB =
    class
        inherit WhiteBalancer
    end

The LearningBasedWB type exposes the following members.

Constructors
 | Name | Description
Public method | LearningBasedWB | Create a learning based white balancer.
Top
Properties
 | Name | Description
Public property | HistBinNum | Defines the size of one dimension of a three-dimensional RGB histogram that is used internally by the algorithm. It often makes sense to increase the number of bins for images with higher bit depth (e.g. 256 bins for a 12 bit image).
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RangeMaxVal | Maximum possible value of the input image (e.g. 255 for 8 bit images, 4095 for 12 bit images)
Public property | SaturationThreshold | Threshold that is used to determine saturated pixels, i.e. pixels where at least one of the channels exceeds saturation_threshold x range_max_val are ignored.
Top
Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image. (Inherited from WhiteBalancer.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this white balancer (Overrides WhiteBalancerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object (Inherited from WhiteBalancer.)
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


LearningBasedWB Constructor

Create a learning based white balancer.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public LearningBasedWB()
Public Sub New
public:
LearningBasedWB()
new : unit -> LearningBasedWB
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB Properties

The LearningBasedWB type exposes the following members.

Properties
 | Name | Description
Public property | HistBinNum | Defines the size of one dimension of a three-dimensional RGB histogram that is used internally by the algorithm. It often makes sense to increase the number of bins for images with higher bit depth (e.g. 256 bins for a 12 bit image).
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | RangeMaxVal | Maximum possible value of the input image (e.g. 255 for 8 bit images, 4095 for 12 bit images)
Public property | SaturationThreshold | Threshold that is used to determine saturated pixels, i.e. pixels where at least one of the channels exceeds saturation_threshold x range_max_val are ignored.
Top
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB.HistBinNum Property

LearningBasedWBHistBinNum Property

Defines the size of one dimension of a three-dimensional RGB histogram that is used internally by the algorithm. It often makes sense to increase the number of bins for images with higher bit depth (e.g. 256 bins for a 12 bit image).

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int HistBinNum { get; set; }
Public Property HistBinNum As Integer
    Get
    Set
public:
property int HistBinNum {
    int get ();
    void set (int value);
}
member HistBinNum : int with get, set

Property Value

Type: Int32
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB.RangeMaxVal Property

LearningBasedWBRangeMaxVal Property

Maximum possible value of the input image (e.g. 255 for 8 bit images, 4095 for 12 bit images)

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int RangeMaxVal { get; set; }
Public Property RangeMaxVal As Integer
    Get
    Set
public:
property int RangeMaxVal {
    int get ();
    void set (int value);
}
member RangeMaxVal : int with get, set

Property Value

Type: Int32
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB.SaturationThreshold Property

LearningBasedWBSaturationThreshold Property

Threshold that is used to determine saturated pixels, i.e. pixels where at least one of the channels exceeds saturation_threshold x range_max_val are ignored.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float SaturationThreshold { get; set; }
Public Property SaturationThreshold As Single
    Get
    Set
public:
property float SaturationThreshold {
    float get ();
    void set (float value);
}
member SaturationThreshold : float32 with get, set

Property Value

Type: Single
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB Methods

The LearningBasedWB type exposes the following members.

Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image. (Inherited from WhiteBalancer.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this white balancer (Overrides WhiteBalancerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB.DisposeObject Method

LearningBasedWBDisposeObject Method

Release all the unmanaged memory associated with this white balancer

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


LearningBasedWB Fields

The LearningBasedWB type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object (Inherited from WhiteBalancer.)
Top
See Also

Reference

LearningBasedWB Class
Emgu.CV.XPhoto Namespace


SimpleWB Class

A simple white balance algorithm that works by independently stretching each of the input image channels to the specified range. For increased robustness it ignores the top and bottom p% of pixel values.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XPhotoWhiteBalancer
Emgu.CV.XPhotoSimpleWB

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class SimpleWB : WhiteBalancer
Public Class SimpleWB
    Inherits WhiteBalancer
public ref class SimpleWB : public WhiteBalancer
type SimpleWB =
    class
        inherit WhiteBalancer
    end

The SimpleWB type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleWB | Creates a simple white balancer
Top
Properties
 | Name | Description
Public property | InputMax | Input image range maximum value
Public property | InputMin | Input image range minimum value
Public property | OutputMax | Output image range maximum value
Public property | OutputMin | Output image range minimum value
Public property | P | Percent of top/bottom values to ignore
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image. (Inherited from WhiteBalancer.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this white balancer (Overrides WhiteBalancerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object (Inherited from WhiteBalancer.)
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


SimpleWB Constructor

Creates a simple white balancer

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public SimpleWB()
Public Sub New
public:
SimpleWB()
new : unit -> SimpleWB
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB Properties

The SimpleWB type exposes the following members.

Properties
 | Name | Description
Public property | InputMax | Input image range maximum value
Public property | InputMin | Input image range minimum value
Public property | OutputMax | Output image range maximum value
Public property | OutputMin | Output image range minimum value
Public property | P | Percent of top/bottom values to ignore
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB.InputMax Property

SimpleWBInputMax Property

Input image range maximum value

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float InputMax { get; set; }
Public Property InputMax As Single
    Get
    Set
public:
property float InputMax {
    float get ();
    void set (float value);
}
member InputMax : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB.InputMin Property

SimpleWBInputMin Property

Input image range minimum value

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float InputMin { get; set; }
Public Property InputMin As Single
    Get
    Set
public:
property float InputMin {
    float get ();
    void set (float value);
}
member InputMin : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB.OutputMax Property

SimpleWBOutputMax Property

Output image range maximum value

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float OutputMax { get; set; }
Public Property OutputMax As Single
    Get
    Set
public:
property float OutputMax {
    float get ();
    void set (float value);
}
member OutputMax : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB.OutputMin Property

SimpleWBOutputMin Property

Output image range minimum value

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float OutputMin { get; set; }
Public Property OutputMin As Single
    Get
    Set
public:
property float OutputMin {
    float get ();
    void set (float value);
}
member OutputMin : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB.P Property

SimpleWBP Property

Percent of top/bottom values to ignore

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float P { get; set; }
Public Property P As Single
    Get
    Set
public:
property float P {
    float get ();
    void set (float value);
}
member P : float32 with get, set

Property Value

Type: Single
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB Methods

The SimpleWB type exposes the following members.

Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image. (Inherited from WhiteBalancer.)
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release all the unmanaged memory associated with this white balancer (Overrides WhiteBalancerDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB.DisposeObject Method

SimpleWBDisposeObject Method

Release all the unmanaged memory associated with this white balancer

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


SimpleWB Fields

The SimpleWB type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object (Inherited from WhiteBalancer.)
Top
See Also

Reference

SimpleWB Class
Emgu.CV.XPhoto Namespace


TonemapDurand Class

This algorithm decomposes image into two layers: base layer and detail layer using bilateral filter and compresses contrast of the base layer thus preserving all the details. This implementation uses regular bilateral filter from opencv.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVTonemap
Emgu.CV.XPhotoTonemapDurand

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class TonemapDurand : Tonemap
Public Class TonemapDurand
    Inherits Tonemap
public ref class TonemapDurand : public Tonemap
type TonemapDurand =
    class
        inherit Tonemap
    end

The TonemapDurand type exposes the following members.

Constructors
 | Name | Description
Public method | TonemapDurand | Creates TonemapDurand object.
Top
Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | Contrast | Resulting contrast on logarithmic scale, i. e. log(max / min), where max and min are maximum and minimum luminance values of the resulting image.
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Saturation | Positive saturation enhancement value. 1.0 preserves saturation, values greater than 1 increase saturation and values less than 1 decrease it.
Public property | SigmaColor | bilateral filter sigma in coordinate space
Public property | SigmaSpace | Bilateral filter sigma in color space
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapDurand (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


TonemapDurand Constructor

Creates TonemapDurand object.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public TonemapDurand(
    float gamma = 1f,
    float contrast = 4f,
    float saturation = 1f,
    float sigmaSpace = 2f,
    float sigmaColor = 2f
)
Public Sub New (
    Optional gamma As Single = 1F,
    Optional contrast As Single = 4F,
    Optional saturation As Single = 1F,
    Optional sigmaSpace As Single = 2F,
    Optional sigmaColor As Single = 2F
)
public:
TonemapDurand(
    float gamma = 1f,
    float contrast = 4f,
    float saturation = 1f,
    float sigmaSpace = 2f,
    float sigmaColor = 2f
)
new :
        ?gamma : float32 *
        ?contrast : float32 *
        ?saturation : float32 *
        ?sigmaSpace : float32 *
        ?sigmaColor : float32
(* Defaults:
        let _gamma = defaultArg gamma 1f
        let _contrast = defaultArg contrast 4f
        let _saturation = defaultArg saturation 1f
        let _sigmaSpace = defaultArg sigmaSpace 2f
        let _sigmaColor = defaultArg sigmaColor 2f
*)
-> TonemapDurand

Parameters

gamma (Optional)
Type: SystemSingle
gamma value for gamma correction.
contrast (Optional)
Type: SystemSingle
resulting contrast on logarithmic scale, i. e. log(max / min), where max and min are maximum and minimum luminance values of the resulting image.
saturation (Optional)
Type: SystemSingle
saturation enhancement value.
sigmaSpace (Optional)
Type: SystemSingle
bilateral filter sigma in color space
sigmaColor (Optional)
Type: SystemSingle
bilateral filter sigma in coordinate space
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand Properties

The TonemapDurand type exposes the following members.

Properties
 | Name | Description
Public property | AlgorithmPtr | The pointer to the unamanged Algorith object (Inherited from Tonemap.)
Public property | Contrast | Resulting contrast on logarithmic scale, i. e. log(max / min), where max and min are maximum and minimum luminance values of the resulting image.
Public property | Gamma | Positive value for gamma correction. Gamma value of 1.0 implies no correction, gamma equal to 2.2f is suitable for most displays. (Inherited from Tonemap.)
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Public property | Saturation | Positive saturation enhancement value. 1.0 preserves saturation, values greater than 1 increase saturation and values less than 1 decrease it.
Public property | SigmaColor | bilateral filter sigma in coordinate space
Public property | SigmaSpace | Bilateral filter sigma in color space
Top
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand.Contrast Property

TonemapDurandContrast Property

Resulting contrast on logarithmic scale, i. e. log(max / min), where max and min are maximum and minimum luminance values of the resulting image.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Contrast { get; set; }
Public Property Contrast As Single
    Get
    Set
public:
property float Contrast {
    float get ();
    void set (float value);
}
member Contrast : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand.Saturation Property

TonemapDurandSaturation Property

Positive saturation enhancement value. 1.0 preserves saturation, values greater than 1 increase saturation and values less than 1 decrease it.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float Saturation { get; set; }
Public Property Saturation As Single
    Get
    Set
public:
property float Saturation {
    float get ();
    void set (float value);
}
member Saturation : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand.SigmaColor Property

TonemapDurandSigmaColor Property

bilateral filter sigma in coordinate space

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float SigmaColor { get; set; }
Public Property SigmaColor As Single
    Get
    Set
public:
property float SigmaColor {
    float get ();
    void set (float value);
}
member SigmaColor : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand.SigmaSpace Property

TonemapDurandSigmaSpace Property

Bilateral filter sigma in color space

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public float SigmaSpace { get; set; }
Public Property SigmaSpace As Single
    Get
    Set
public:
property float SigmaSpace {
    float get ();
    void set (float value);
}
member SigmaSpace : float32 with get, set

Property Value

Type: Single
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand Methods

The TonemapDurand type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged memory associated with this TonemapDurand (Overrides TonemapDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Tonemaps image. (Inherited from Tonemap.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand.DisposeObject Method

TonemapDurandDisposeObject Method

Release the unmanaged memory associated with this TonemapDurand

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TonemapDurand Fields

The TonemapDurand type exposes the following members.

Fields
 | Name | Description
Protected field | _algorithmPtr | The pointer to the unmanaged Algorithm object (Inherited from Tonemap.)
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _tonemapPtr | The pointer to the unmanaged Tonemap object (Inherited from Tonemap.)
Top
See Also

Reference

TonemapDurand Class
Emgu.CV.XPhoto Namespace


TransformTypes Class

BM3D denoising transform types
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XPhotoTransformTypes

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TransformTypes : Enum
Public NotInheritable Class TransformTypes
    Inherits Enum
public ref class TransformTypes sealed : public Enum
[<SealedAttribute>]
type TransformTypes =
    class
        inherit Enum
    end

The TransformTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Haar | Un-normalized Haar transform
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


TransformTypes Methods

The TransformTypes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

TransformTypes Class
Emgu.CV.XPhoto Namespace


TransformTypes Fields

The TransformTypes type exposes the following members.

Fields
 | Name | Description
 | Haar | Un-normalized Haar transform
Public field | value__ |
Top
See Also

Reference

TransformTypes Class
Emgu.CV.XPhoto Namespace


TransformTypes.Haar Field

TransformTypesHaar Field

Un-normalized Haar transform

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const TransformTypes Haar = 0
Public Const Haar As TransformTypes = 0
public:
literal TransformTypes^ Haar = 0
static val mutable Haar: TransformTypes

Field Value

Type: TransformTypes
See Also

Reference

TransformTypes Class
Emgu.CV.XPhoto Namespace


TransformTypes.value__ Field

TransformTypesvalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XPhoto.TransformTypes.value__"]

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

TransformTypes Class
Emgu.CV.XPhoto Namespace


WhiteBalancer Class

The base class for auto white balance algorithms.
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CV.XPhotoWhiteBalancer
Emgu.CV.XPhotoGrayworldWB
Emgu.CV.XPhotoLearningBasedWB
Emgu.CV.XPhotoSimpleWB

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class WhiteBalancer : UnmanagedObject
Public MustInherit Class WhiteBalancer
    Inherits UnmanagedObject
public ref class WhiteBalancer abstract : public UnmanagedObject
[<AbstractClassAttribute>]
type WhiteBalancer =
    class
        inherit UnmanagedObject
    end

The WhiteBalancer type exposes the following members.

Constructors
 | Name | Description
Protected method | WhiteBalancer | Initializes a new instance of the WhiteBalancer class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointer to the native white balancer object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


WhiteBalancer Constructor

Initializes a new instance of the WhiteBalancer class

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected WhiteBalancer()
Protected Sub New
protected:
WhiteBalancer()
new : unit -> WhiteBalancer
See Also

Reference

WhiteBalancer Class
Emgu.CV.XPhoto Namespace


WhiteBalancer Properties

The WhiteBalancer type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object (Inherited from UnmanagedObject.)
Top
See Also

Reference

WhiteBalancer Class
Emgu.CV.XPhoto Namespace


WhiteBalancer Methods

The WhiteBalancer type exposes the following members.

Methods
 | Name | Description
Public method | BalanceWhite | Applies white balancing to the input image.
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Reset the pointer to the native white balancer object (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WhiteBalancer Class
Emgu.CV.XPhoto Namespace


WhiteBalancer.BalanceWhite Method

WhiteBalancerBalanceWhite Method

Applies white balancing to the input image.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void BalanceWhite(
    IInputArray src,
    IOutputArray dst
)
Public Sub BalanceWhite (
    src As IInputArray,
    dst As IOutputArray
)
public:
void BalanceWhite(
    IInputArray^ src,
    IOutputArray^ dst
)
member BalanceWhite :
        src : IInputArray *
        dst : IOutputArray -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input image
dst
Type: Emgu.CVIOutputArray
White balancing result
See Also

Reference

WhiteBalancer Class
Emgu.CV.XPhoto Namespace


WhiteBalancer.DisposeObject Method

WhiteBalancerDisposeObject Method

Reset the pointer to the native white balancer object

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

WhiteBalancer Class
Emgu.CV.XPhoto Namespace


WhiteBalancer Fields

The WhiteBalancer type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object (Inherited from UnmanagedObject.)
Protected field | _whiteBalancerPtr | Pointer to the native white balancer object
Top
See Also

Reference

WhiteBalancer Class
Emgu.CV.XPhoto Namespace


WhiteBalancer._whiteBalancerPtr Field

WhiteBalancer_whiteBalancerPtr Field

Pointer to the native white balancer object

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _whiteBalancerPtr
Protected _whiteBalancerPtr As IntPtr
protected:
IntPtr _whiteBalancerPtr
val mutable _whiteBalancerPtr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

WhiteBalancer Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke Class

Class that contains entry points for the XPhoto module.
Inheritance Hierarchy
SystemObject
Emgu.CV.XPhotoXPhotoInvoke

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class XPhotoInvoke
Public NotInheritable Class XPhotoInvoke
public ref class XPhotoInvoke abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XPhotoInvoke =  class end

The XPhotoInvoke type exposes the following members.

Methods
Name | Description
ApplyChannelGains | Implements an efficient fixed-point approximation for applying channel gains, which is the last step of multiple white balance algorithms.
Bm3dDenoising(IInputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes) | Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.
Bm3dDenoising(IInputArray, IInputOutputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes) | Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.
DctDenoising | The function implements simple dct-based denoising, link: http://www.ipol.im/pub/art/2011/ys-dct/.
Inpaint | The function implements different single-image inpainting algorithms
OilPainting | Oil Painting effect
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


XPhotoInvoke Methods

The XPhotoInvoke type exposes the following members.

Methods
Name | Description
ApplyChannelGains | Implements an efficient fixed-point approximation for applying channel gains, which is the last step of multiple white balance algorithms.
Bm3dDenoising(IInputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes) | Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.
Bm3dDenoising(IInputArray, IInputOutputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes) | Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.
DctDenoising | The function implements simple dct-based denoising, link: http://www.ipol.im/pub/art/2011/ys-dct/.
Inpaint | The function implements different single-image inpainting algorithms
OilPainting | Oil Painting effect
Top
See Also

Reference

XPhotoInvoke Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.ApplyChannelGains Method

XPhotoInvokeApplyChannelGains Method

Implements an efficient fixed-point approximation for applying channel gains, which is the last step of multiple white balance algorithms.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ApplyChannelGains(
    IInputArray src,
    IOutputArray dst,
    float gainB,
    float gainG,
    float gainR
)
Public Shared Sub ApplyChannelGains (
    src As IInputArray,
    dst As IOutputArray,
    gainB As Single,
    gainG As Single,
    gainR As Single
)
public:
static void ApplyChannelGains(
    IInputArray^ src,
    IOutputArray^ dst,
    float gainB,
    float gainG,
    float gainR
)
static member ApplyChannelGains :
        src : IInputArray *
        dst : IOutputArray *
        gainB : float32 *
        gainG : float32 *
        gainR : float32 -> unit

Parameters

src
Type: Emgu.CVIInputArray
Input three-channel image in the BGR color space (either CV_8UC3 or CV_16UC3)
dst
Type: Emgu.CVIOutputArray
Output image of the same size and type as src.
gainB
Type: SystemSingle
Gain for the B channel
gainG
Type: SystemSingle
Gain for the G channel
gainR
Type: SystemSingle
Gain for the R channel
See Also

Reference

XPhotoInvoke Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.Bm3dDenoising Method

XPhotoInvokeBm3dDenoising Method

Overload List
Name | Description
Bm3dDenoising(IInputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes) | Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.
Bm3dDenoising(IInputArray, IInputOutputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes) | Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.
Top
See Also

Reference

XPhotoInvoke Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.Bm3dDenoising Method (IInputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes)

XPhotoInvokeBm3dDenoising Method (IInputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes)

http://www.emgu.com
Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Bm3dDenoising(
    IInputArray src,
    IOutputArray dst,
    float h = 1f,
    int templateWindowSize = 4,
    int searchWindowSize = 16,
    int blockMatchingStep1 = 2500,
    int blockMatchingStep2 = 400,
    int groupSize = 8,
    int slidingStep = 1,
    float beta = 2f,
    NormType normType = 4,
    Bm3dSteps step = 0,
    TransformTypes transformType = 0
)
Public Shared Sub Bm3dDenoising (
    src As IInputArray,
    dst As IOutputArray,
    Optional h As Single = 1F,
    Optional templateWindowSize As Integer = 4,
    Optional searchWindowSize As Integer = 16,
    Optional blockMatchingStep1 As Integer = 2500,
    Optional blockMatchingStep2 As Integer = 400,
    Optional groupSize As Integer = 8,
    Optional slidingStep As Integer = 1,
    Optional beta As Single = 2F,
    Optional normType As NormType = 4,
    Optional step As Bm3dSteps = 0,
    Optional transformType As TransformTypes = 0
)
public:
static void Bm3dDenoising(
    IInputArray^ src,
    IOutputArray^ dst,
    float h = 1f,
    int templateWindowSize = 4,
    int searchWindowSize = 16,
    int blockMatchingStep1 = 2500,
    int blockMatchingStep2 = 400,
    int groupSize = 8,
    int slidingStep = 1,
    float beta = 2f,
    NormType^ normType = 4,
    Bm3dSteps^ step = 0,
    TransformTypes^ transformType = 0
)
static member Bm3dDenoising :
        src : IInputArray *
        dst : IOutputArray *
        ?h : float32 *
        ?templateWindowSize : int *
        ?searchWindowSize : int *
        ?blockMatchingStep1 : int *
        ?blockMatchingStep2 : int *
        ?groupSize : int *
        ?slidingStep : int *
        ?beta : float32 *
        ?normType : NormType *
        ?step : Bm3dSteps *
        ?transformType : TransformTypes
(* Defaults:
        let _h = defaultArg h 1f
        let _templateWindowSize = defaultArg templateWindowSize 4
        let _searchWindowSize = defaultArg searchWindowSize 16
        let _blockMatchingStep1 = defaultArg blockMatchingStep1 2500
        let _blockMatchingStep2 = defaultArg blockMatchingStep2 400
        let _groupSize = defaultArg groupSize 8
        let _slidingStep = defaultArg slidingStep 1
        let _beta = defaultArg beta 2f
        let _normType = defaultArg normType 4
        let _step = defaultArg step 0
        let _transformType = defaultArg transformType 0
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit or 16-bit 1-channel image.
dst
Type: Emgu.CVIOutputArray
Output image with the same size and type as src.
h (Optional)
Type: SystemSingle
Parameter regulating filter strength. Big h value perfectly removes noise but also removes image details, smaller h value preserves details but also preserves some noise.
templateWindowSize (Optional)
Type: SystemInt32
Size in pixels of the template patch that is used for block-matching. Should be power of 2.
searchWindowSize (Optional)
Type: SystemInt32
Size in pixels of the window that is used to perform block-matching. Affect performance linearly: greater searchWindowsSize - greater denoising time. Must be larger than templateWindowSize.
blockMatchingStep1 (Optional)
Type: SystemInt32
Block matching threshold for the first step of BM3D (hard thresholding), i.e. maximum distance for which two blocks are considered similar. Value expressed in euclidean distance.
blockMatchingStep2 (Optional)
Type: SystemInt32
Block matching threshold for the second step of BM3D (Wiener filtering), i.e. maximum distance for which two blocks are considered similar. Value expressed in euclidean distance.
groupSize (Optional)
Type: SystemInt32
Maximum size of the 3D group for collaborative filtering.
slidingStep (Optional)
Type: SystemInt32
Sliding step to process every next reference block.
beta (Optional)
Type: SystemSingle
Kaiser window parameter that affects the sidelobe attenuation of the transform of the window. Kaiser window is used in order to reduce border effects. To prevent usage of the window, set beta to zero.
normType (Optional)
Type: Emgu.CV.CvEnumNormType
Norm used to calculate distance between blocks. L2 is slower than L1 but yields more accurate results.
step (Optional)
Type: Emgu.CV.XPhotoBm3dSteps
Step of BM3D to be executed. Allowed are only BM3D_STEP1 and BM3D_STEPALL. BM3D_STEP2 is not allowed as it requires basic estimate to be present.
transformType (Optional)
Type: Emgu.CV.XPhotoTransformTypes
Type of the orthogonal transform used in collaborative filtering step. Currently only Haar transform is supported.
Remarks
See Also

Reference

XPhotoInvoke Class
Bm3dDenoising Overload
Emgu.CV.XPhoto Namespace


XPhotoInvoke.Bm3dDenoising Method (IInputArray, IInputOutputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes)

XPhotoInvokeBm3dDenoising Method (IInputArray, IInputOutputArray, IOutputArray, Single, Int32, Int32, Int32, Int32, Int32, Int32, Single, NormType, Bm3dSteps, TransformTypes)

http://www.emgu.com
Performs image denoising using the Block-Matching and 3D-filtering algorithm with several computational optimizations. Noise expected to be a gaussian white noise.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Bm3dDenoising(
    IInputArray src,
    IInputOutputArray dstStep1,
    IOutputArray dstStep2,
    float h = 1f,
    int templateWindowSize = 4,
    int searchWindowSize = 16,
    int blockMatchingStep1 = 2500,
    int blockMatchingStep2 = 400,
    int groupSize = 8,
    int slidingStep = 1,
    float beta = 2f,
    NormType normType = 4,
    Bm3dSteps step = 0,
    TransformTypes transformType = 0
)
Public Shared Sub Bm3dDenoising (
    src As IInputArray,
    dstStep1 As IInputOutputArray,
    dstStep2 As IOutputArray,
    Optional h As Single = 1F,
    Optional templateWindowSize As Integer = 4,
    Optional searchWindowSize As Integer = 16,
    Optional blockMatchingStep1 As Integer = 2500,
    Optional blockMatchingStep2 As Integer = 400,
    Optional groupSize As Integer = 8,
    Optional slidingStep As Integer = 1,
    Optional beta As Single = 2F,
    Optional normType As NormType = 4,
    Optional step As Bm3dSteps = 0,
    Optional transformType As TransformTypes = 0
)
public:
static void Bm3dDenoising(
    IInputArray^ src,
    IInputOutputArray^ dstStep1,
    IOutputArray^ dstStep2,
    float h = 1f,
    int templateWindowSize = 4,
    int searchWindowSize = 16,
    int blockMatchingStep1 = 2500,
    int blockMatchingStep2 = 400,
    int groupSize = 8,
    int slidingStep = 1,
    float beta = 2f,
    NormType^ normType = 4,
    Bm3dSteps^ step = 0,
    TransformTypes^ transformType = 0
)
static member Bm3dDenoising :
        src : IInputArray *
        dstStep1 : IInputOutputArray *
        dstStep2 : IOutputArray *
        ?h : float32 *
        ?templateWindowSize : int *
        ?searchWindowSize : int *
        ?blockMatchingStep1 : int *
        ?blockMatchingStep2 : int *
        ?groupSize : int *
        ?slidingStep : int *
        ?beta : float32 *
        ?normType : NormType *
        ?step : Bm3dSteps *
        ?transformType : TransformTypes
(* Defaults:
        let _h = defaultArg h 1f
        let _templateWindowSize = defaultArg templateWindowSize 4
        let _searchWindowSize = defaultArg searchWindowSize 16
        let _blockMatchingStep1 = defaultArg blockMatchingStep1 2500
        let _blockMatchingStep2 = defaultArg blockMatchingStep2 400
        let _groupSize = defaultArg groupSize 8
        let _slidingStep = defaultArg slidingStep 1
        let _beta = defaultArg beta 2f
        let _normType = defaultArg normType 4
        let _step = defaultArg step 0
        let _transformType = defaultArg transformType 0
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input 8-bit or 16-bit 1-channel image.
dstStep1
Type: Emgu.CVIInputOutputArray
Output image of the first step of BM3D with the same size and type as src.
dstStep2
Type: Emgu.CVIOutputArray
Output image of the second step of BM3D with the same size and type as src.
h (Optional)
Type: SystemSingle
Parameter regulating filter strength. Big h value perfectly removes noise but also removes image details, smaller h value preserves details but also preserves some noise.
templateWindowSize (Optional)
Type: SystemInt32
Size in pixels of the template patch that is used for block-matching. Should be power of 2.
searchWindowSize (Optional)
Type: SystemInt32
Size in pixels of the window that is used to perform block-matching. Affect performance linearly: greater searchWindowsSize - greater denoising time. Must be larger than templateWindowSize.
blockMatchingStep1 (Optional)
Type: SystemInt32
Block matching threshold for the first step of BM3D (hard thresholding), i.e. maximum distance for which two blocks are considered similar. Value expressed in euclidean distance.
blockMatchingStep2 (Optional)
Type: SystemInt32
Block matching threshold for the second step of BM3D (Wiener filtering), i.e. maximum distance for which two blocks are considered similar. Value expressed in euclidean distance.
groupSize (Optional)
Type: SystemInt32
Maximum size of the 3D group for collaborative filtering.
slidingStep (Optional)
Type: SystemInt32
Sliding step to process every next reference block.
beta (Optional)
Type: SystemSingle
Kaiser window parameter that affects the sidelobe attenuation of the transform of the window. Kaiser window is used in order to reduce border effects. To prevent usage of the window, set beta to zero.
normType (Optional)
Type: Emgu.CV.CvEnumNormType
Norm used to calculate distance between blocks. L2 is slower than L1 but yields more accurate results.
step (Optional)
Type: Emgu.CV.XPhotoBm3dSteps
Step of BM3D to be executed. Possible variants are: step 1, step 2, both steps.
transformType (Optional)
Type: Emgu.CV.XPhotoTransformTypes
Type of the orthogonal transform used in collaborative filtering step. Currently only Haar transform is supported.
Remarks
See Also

Reference

XPhotoInvoke Class
Bm3dDenoising Overload
Emgu.CV.XPhoto Namespace


XPhotoInvoke.DctDenoising Method

XPhotoInvokeDctDenoising Method

The function implements simple dct-based denoising, link: http://www.ipol.im/pub/art/2011/ys-dct/.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void DctDenoising(
    Mat src,
    Mat dst,
    double sigma,
    int psize = 16
)
Public Shared Sub DctDenoising (
    src As Mat,
    dst As Mat,
    sigma As Double,
    Optional psize As Integer = 16
)
public:
static void DctDenoising(
    Mat^ src,
    Mat^ dst,
    double sigma,
    int psize = 16
)
static member DctDenoising :
        src : Mat *
        dst : Mat *
        sigma : float *
        ?psize : int
(* Defaults:
        let _psize = defaultArg psize 16
*)
-> unit

Parameters

src
Type: Emgu.CVMat
Source image
dst
Type: Emgu.CVMat
Destination image
sigma
Type: SystemDouble
Expected noise standard deviation
psize (Optional)
Type: SystemInt32
Size of block side where dct is computed
See Also

Reference

XPhotoInvoke Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.Inpaint Method

XPhotoInvokeInpaint Method

The function implements different single-image inpainting algorithms

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void Inpaint(
    Mat src,
    Mat mask,
    Mat dst,
    XPhotoInvokeInpaintType algorithmType
)
Public Shared Sub Inpaint (
    src As Mat,
    mask As Mat,
    dst As Mat,
    algorithmType As XPhotoInvokeInpaintType
)
public:
static void Inpaint(
    Mat^ src,
    Mat^ mask,
    Mat^ dst,
    XPhotoInvokeInpaintType^ algorithmType
)
static member Inpaint :
        src : Mat *
        mask : Mat *
        dst : Mat *
        algorithmType : XPhotoInvokeInpaintType -> unit

Parameters

src
Type: Emgu.CVMat
source image, it could be of any type and any number of channels from 1 to 4. In case of 3- and 4-channels images the function expect them in CIELab colorspace or similar one, where first color component shows intensity, while second and third shows colors. Nonetheless you can try any colorspaces.
mask
Type: Emgu.CVMat
mask (CV_8UC1), where non-zero pixels indicate valid image area, while zero pixels indicate area to be inpainted
dst
Type: Emgu.CVMat
destination image
algorithmType
Type: Emgu.CV.XPhotoXPhotoInvokeInpaintType
algorithm type
See Also

Reference

XPhotoInvoke Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.OilPainting Method

XPhotoInvokeOilPainting Method

Oil Painting effect

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static void OilPainting(
    IInputArray src,
    IOutputArray dst,
    int size,
    int dynRatio,
    ColorConversion code = 6
)
Public Shared Sub OilPainting (
    src As IInputArray,
    dst As IOutputArray,
    size As Integer,
    dynRatio As Integer,
    Optional code As ColorConversion = 6
)
public:
static void OilPainting(
    IInputArray^ src,
    IOutputArray^ dst,
    int size,
    int dynRatio,
    ColorConversion^ code = 6
)
static member OilPainting :
        src : IInputArray *
        dst : IOutputArray *
        size : int *
        dynRatio : int *
        ?code : ColorConversion
(* Defaults:
        let _code = defaultArg code 6
*)
-> unit

Parameters

src
Type: Emgu.CVIInputArray
Input three-channel or one channel image (either CV_8UC3 or CV_8UC1)
dst
Type: Emgu.CVIOutputArray
Output image of the same size and type as src.
size
Type: SystemInt32
Neighbouring size is 2-size+1
dynRatio
Type: SystemInt32
Image is divided by dynRatio before histogram processing
code (Optional)
Type: Emgu.CV.CvEnumColorConversion
Color space conversion code(see ColorConversionCodes). Histogram will used only first plane
See Also

Reference

XPhotoInvoke Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.InpaintType Class

XPhotoInvokeInpaintType Class

Inpaint type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.CV.XPhotoXPhotoInvokeInpaintType

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InpaintType : Enum
Public NotInheritable Class InpaintType
    Inherits Enum
public ref class InpaintType sealed : public Enum
[<SealedAttribute>]
type InpaintType =
    class
        inherit Enum
    end

The XPhotoInvokeInpaintType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | FsrBest | Performs Frequency Selective Reconstruction (FSR). Slower but better inpainting
 | FsrFast | Performs Frequency Selective Reconstruction (FSR). Faster inpainting.
 | Shiftmap | Shift map
Public field | value__ |
Top
See Also

Reference

Emgu.CV.XPhoto Namespace


InpaintType Methods

The XPhotoInvokeInpaintType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

XPhotoInvokeInpaintType Class
Emgu.CV.XPhoto Namespace


InpaintType Fields

The XPhotoInvokeInpaintType type exposes the following members.

Fields
 | Name | Description
 | FsrBest | Performs Frequency Selective Reconstruction (FSR). Slower but better inpainting
 | FsrFast | Performs Frequency Selective Reconstruction (FSR). Faster inpainting.
 | Shiftmap | Shift map
Public field | value__ |
Top
See Also

Reference

XPhotoInvokeInpaintType Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.InpaintType.FsrBest Field

XPhotoInvokeInpaintTypeFsrBest Field

Performs Frequency Selective Reconstruction (FSR). Slower but better inpainting

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const XPhotoInvokeInpaintType FsrBest = 1
Public Const FsrBest As XPhotoInvokeInpaintType = 1
public:
literal XPhotoInvokeInpaintType^ FsrBest = 1
static val mutable FsrBest: XPhotoInvokeInpaintType

Field Value

Type: XPhotoInvokeInpaintType
See Also

Reference

XPhotoInvokeInpaintType Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.InpaintType.FsrFast Field

XPhotoInvokeInpaintTypeFsrFast Field

Performs Frequency Selective Reconstruction (FSR). Faster inpainting.

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const XPhotoInvokeInpaintType FsrFast = 2
Public Const FsrFast As XPhotoInvokeInpaintType = 2
public:
literal XPhotoInvokeInpaintType^ FsrFast = 2
static val mutable FsrFast: XPhotoInvokeInpaintType

Field Value

Type: XPhotoInvokeInpaintType
See Also

Reference

XPhotoInvokeInpaintType Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.InpaintType.Shiftmap Field

XPhotoInvokeInpaintTypeShiftmap Field

Shift map

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const XPhotoInvokeInpaintType Shiftmap = 0
Public Const Shiftmap As XPhotoInvokeInpaintType = 0
public:
literal XPhotoInvokeInpaintType^ Shiftmap = 0
static val mutable Shiftmap: XPhotoInvokeInpaintType

Field Value

Type: XPhotoInvokeInpaintType
See Also

Reference

XPhotoInvokeInpaintType Class
Emgu.CV.XPhoto Namespace


XPhotoInvoke.InpaintType.value__ Field

XPhotoInvokeInpaintTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.CV.XPhoto.XPhotoInvoke.InpaintType.value__"]

Namespace: Emgu.CV.XPhoto
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

XPhotoInvokeInpaintType Class
Emgu.CV.XPhoto Namespace


Emgu.Util Namespace

A collection of utilities used by Emgu projects
Classes
 | Class | Description
Public class | DisposableObject | An abstract class that wrap around a disposable object
Public class | EventArgsT | A generic EventArgs
Public class | EventArgsT1, T2 | A generic EventArgs
Public class | PinnedArrayT | A Pinned array of the specific type
Public class | Platform | Provide information for the platform which is using.
Public class | Toolbox | utilities functions for Emgu
Public class | UnmanagedObject | An Unmanaged Object is a disposable object with a Ptr property pointing to the unmanaged object
Interfaces
 | Interface | Description
Public interface | ICodeGenerable | Implement this interface if the object can output code to generate it self.
Public interface | IInterpolatableT | An object that can be interpolated


DisposableObject Class

An abstract class that wrap around a disposable object
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.CVMotionHistory
Emgu.CV.OCRLocaleGuard
Emgu.CV.UtilDataLoggerT
Emgu.UtilPinnedArrayT
Emgu.UtilUnmanagedObject

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class DisposableObject : IDisposable
Public MustInherit Class DisposableObject
    Implements IDisposable
public ref class DisposableObject abstract : IDisposable
[<AbstractClassAttribute>]
type DisposableObject =
    class
        interface IDisposable
    end

The DisposableObject type exposes the following members.

Constructors
 | Name | Description
Protected method | DisposableObject | Initializes a new instance of the DisposableObject class
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface
Protected method | DisposeObject | Release the unmanaged resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.Util Namespace


DisposableObject Constructor

Initializes a new instance of the DisposableObject class

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected DisposableObject()
Protected Sub New
protected:
DisposableObject()
new : unit -> DisposableObject
See Also

Reference

DisposableObject Class
Emgu.Util Namespace


DisposableObject Methods

The DisposableObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface
Protected method | DisposeObject | Release the unmanaged resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisposableObject Class
Emgu.Util Namespace


DisposableObject.Dispose Method

DisposableObjectDispose Method

The dispose function that implements IDisposable interface

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DisposableObject Class
Emgu.Util Namespace


DisposableObject.DisposeObject Method

DisposableObjectDisposeObject Method

Release the unmanaged resources

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected abstract void DisposeObject()
Protected MustOverride Sub DisposeObject
protected:
virtual void DisposeObject() abstract
abstract DisposeObject : unit -> unit
See Also

Reference

DisposableObject Class
Emgu.Util Namespace


DisposableObject.Finalize Method

DisposableObjectFinalize Method

Destructor

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

DisposableObject Class
Emgu.Util Namespace


DisposableObject.ReleaseManagedResources Method

DisposableObjectReleaseManagedResources Method

Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void ReleaseManagedResources()
Protected Overridable Sub ReleaseManagedResources
protected:
virtual void ReleaseManagedResources()
abstract ReleaseManagedResources : unit -> unit
override ReleaseManagedResources : unit -> unit
See Also

Reference

DisposableObject Class
Emgu.Util Namespace


EventArgs(T) Class

EventArgsT Class

A generic EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
Emgu.UtilEventArgsT

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class EventArgs<T> : EventArgs

Public Class EventArgs(Of T)
    Inherits EventArgs
generic<typename T>
public ref class EventArgs : public EventArgs
type EventArgs<'T> =
    class
        inherit EventArgs
    end

Type Parameters

T
The type of arguments

The EventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT | Create a generic EventArgs with the specific value
Top
Properties
 | Name | Description
Public property | Value | The value of the EventArgs
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.Util Namespace


EventArgs(T) Constructor

EventArgsT Constructor

Create a generic EventArgs with the specific value

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EventArgs(
    T value
)
Public Sub New (
    value As T
)
public:
EventArgs(
    T value
)
new :
        value : 'T -> EventArgs

Parameters

value
Type: T
The value
See Also

Reference

EventArgsT Class
Emgu.Util Namespace


EventArgs(T) Properties

EventArgsT Properties

The EventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Value | The value of the EventArgs
Top
See Also

Reference

EventArgsT Class
Emgu.Util Namespace


EventArgs(T).Value Property

EventArgsTValue Property

The value of the EventArgs

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public T Value { get; }
Public ReadOnly Property Value As T
    Get
public:
property T Value {
    T get ();
}
member Value : 'T with get

Property Value

Type: T
See Also

Reference

EventArgsT Class
Emgu.Util Namespace


EventArgs(T) Methods

EventArgsT Methods

The EventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventArgsT Class
Emgu.Util Namespace


EventArgs(T1, T2) Class

EventArgsT1, T2 Class

A generic EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
Emgu.UtilEventArgsT1, T2

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class EventArgs<T1, T2> : EventArgs

Public Class EventArgs(Of T1, T2)
    Inherits EventArgs
generic<typename T1, typename T2>
public ref class EventArgs : public EventArgs
type EventArgs<'T1, 'T2> =
    class
        inherit EventArgs
    end

Type Parameters

T1
The type of the first value
T2
The type of the second value

The EventArgsT1, T2 type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT1, T2 | Create a generic EventArgs with two values
Top
Properties
 | Name | Description
Public property | Value1 | The first value
Public property | Value2 | The second value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.Util Namespace


EventArgs(T1, T2) Constructor

EventArgsT1, T2 Constructor

Create a generic EventArgs with two values

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public EventArgs(
    T1 value1,
    T2 value2
)
Public Sub New (
    value1 As T1,
    value2 As T2
)
public:
EventArgs(
    T1 value1,
    T2 value2
)
new :
        value1 : 'T1 *
        value2 : 'T2 -> EventArgs

Parameters

value1
Type: T1
The first value
value2
Type: T2
The second value
See Also

Reference

EventArgsT1, T2 Class
Emgu.Util Namespace


EventArgs(T1, T2) Properties

EventArgsT1, T2 Properties

The EventArgsT1, T2 generic type exposes the following members.

Properties
 | Name | Description
Public property | Value1 | The first value
Public property | Value2 | The second value
Top
See Also

Reference

EventArgsT1, T2 Class
Emgu.Util Namespace


EventArgs(T1, T2).Value1 Property

EventArgsT1, T2Value1 Property

The first value

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public T1 Value1 { get; }
Public ReadOnly Property Value1 As T1
    Get
public:
property T1 Value1 {
    T1 get ();
}
member Value1 : 'T1 with get

Property Value

Type: T1
See Also

Reference

EventArgsT1, T2 Class
Emgu.Util Namespace


EventArgs(T1, T2).Value2 Property

EventArgsT1, T2Value2 Property

The second value

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public T2 Value2 { get; }
Public ReadOnly Property Value2 As T2
    Get
public:
property T2 Value2 {
    T2 get ();
}
member Value2 : 'T2 with get

Property Value

Type: T2
See Also

Reference

EventArgsT1, T2 Class
Emgu.Util Namespace


EventArgs(T1, T2) Methods

EventArgsT1, T2 Methods

The EventArgsT1, T2 generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventArgsT1, T2 Class
Emgu.Util Namespace


ICodeGenerable Interface

Implement this interface if the object can output code to generate it self.

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface ICodeGenerable
Public Interface ICodeGenerable
public interface class ICodeGenerable
type ICodeGenerable =  interface end

The ICodeGenerable type exposes the following members.

Methods
 | Name | Description
Public method | ToCode | Return the code to generate the object itself from the specific language
Top
See Also

Reference

Emgu.Util Namespace


ICodeGenerable Methods

The ICodeGenerable type exposes the following members.

Methods
 | Name | Description
Public method | ToCode | Return the code to generate the object itself from the specific language
Top
See Also

Reference

ICodeGenerable Interface
Emgu.Util Namespace


ICodeGenerable.ToCode Method

ICodeGenerableToCode Method

Return the code to generate the object itself from the specific language

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
string ToCode(
    ProgrammingLanguage language
)
Function ToCode (
    language As ProgrammingLanguage
) As String
String^ ToCode(
    ProgrammingLanguage^ language
)
abstract ToCode :
        language : ProgrammingLanguage -> string

Parameters

language
Type: Emgu.Util.TypeEnumProgrammingLanguage
The programming language to output code

Return Value

Type: String
The code to generate the object from the specific language
See Also

Reference

ICodeGenerable Interface
Emgu.Util Namespace


IInterpolatable(T) Interface

IInterpolatableT Interface

An object that can be interpolated

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IInterpolatable<T>
where T : new()

Public Interface IInterpolatable(Of T As New)
generic<typename T>
where T : gcnew()
public interface class IInterpolatable
type IInterpolatable<'T when 'T : new()> =  interface end

Type Parameters

T
The type of the object

The IInterpolatableT type exposes the following members.

Properties
 | Name | Description
Public property | InterpolationIndex | The index that will be used for interpolation
Top
Methods
 | Name | Description
Public method | LinearInterpolate | Interpolate base on this point and the other point with the given index
Top
See Also

Reference

Emgu.Util Namespace


IInterpolatable(T) Properties

IInterpolatableT Properties

The IInterpolatableT generic type exposes the following members.

Properties
 | Name | Description
Public property | InterpolationIndex | The index that will be used for interpolation
Top
See Also

Reference

IInterpolatableT Interface
Emgu.Util Namespace


IInterpolatable(T).InterpolationIndex Property

IInterpolatableTInterpolationIndex Property

The index that will be used for interpolation

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
double InterpolationIndex { get; }
ReadOnly Property InterpolationIndex As Double
    Get
property double InterpolationIndex {
    double get ();
}
abstract InterpolationIndex : float with get

Property Value

Type: Double
See Also

Reference

IInterpolatableT Interface
Emgu.Util Namespace


IInterpolatable(T) Methods

IInterpolatableT Methods

The IInterpolatableT generic type exposes the following members.

Methods
 | Name | Description
Public method | LinearInterpolate | Interpolate base on this point and the other point with the given index
Top
See Also

Reference

IInterpolatableT Interface
Emgu.Util Namespace


IInterpolatable(T).LinearInterpolate Method

IInterpolatableTLinearInterpolate Method

Interpolate base on this point and the other point with the given index

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
T LinearInterpolate(
    T other,
    double index
)
Function LinearInterpolate (
    other As T,
    index As Double
) As T
T LinearInterpolate(
    T other,
    double index
)
abstract LinearInterpolate :
        other : 'T *
        index : float -> 'T

Parameters

other
Type: T
The other point
index
Type: SystemDouble
The interpolation index

Return Value

Type: T
The interpolated point
See Also

Reference

IInterpolatableT Interface
Emgu.Util Namespace


PinnedArray(T) Class

PinnedArrayT Class

A Pinned array of the specific type
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilPinnedArrayT

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public class PinnedArray<T> : DisposableObject

Public Class PinnedArray(Of T)
    Inherits DisposableObject
generic<typename T>
public ref class PinnedArray : public DisposableObject
type PinnedArray<'T> =
    class
        inherit DisposableObject
    end

Type Parameters

T
The type of the array

The PinnedArrayT type exposes the following members.

Constructors
 | Name | Description
Public method | PinnedArrayT | Create a Pinnned array of the specific type
Top
Properties
 | Name | Description
Public property | Array | Get the array
Top
Methods
 | Name | Description
Public method | AddrOfPinnedObject | Get the address of the pinned array
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Disposed the unmanaged data (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the GCHandle (Overrides DisposableObjectReleaseManagedResources.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Emgu.Util Namespace


PinnedArray(T) Constructor

PinnedArrayT Constructor

Create a Pinnned array of the specific type

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public PinnedArray(
    int size
)
Public Sub New (
    size As Integer
)
public:
PinnedArray(
    int size
)
new :
        size : int -> PinnedArray

Parameters

size
Type: SystemInt32
The size of the array
See Also

Reference

PinnedArrayT Class
Emgu.Util Namespace


PinnedArray(T) Properties

PinnedArrayT Properties

The PinnedArrayT generic type exposes the following members.

Properties
 | Name | Description
Public property | Array | Get the array
Top
See Also

Reference

PinnedArrayT Class
Emgu.Util Namespace


PinnedArray(T).Array Property

PinnedArrayTArray Property

Get the array

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public T[] Array { get; }
Public ReadOnly Property Array As T()
    Get
public:
property array<T>^ Array {
    array<T>^ get ();
}
member Array : 'T[] with get

Property Value

Type: T
See Also

Reference

PinnedArrayT Class
Emgu.Util Namespace


PinnedArray(T) Methods

PinnedArrayT Methods

The PinnedArrayT generic type exposes the following members.

Methods
 | Name | Description
Public method | AddrOfPinnedObject | Get the address of the pinned array
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Disposed the unmanaged data (Overrides DisposableObjectDisposeObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the GCHandle (Overrides DisposableObjectReleaseManagedResources.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PinnedArrayT Class
Emgu.Util Namespace


PinnedArray(T).AddrOfPinnedObject Method

PinnedArrayTAddrOfPinnedObject Method

Get the address of the pinned array

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr AddrOfPinnedObject()
Public Function AddrOfPinnedObject As IntPtr
public:
IntPtr AddrOfPinnedObject()
member AddrOfPinnedObject : unit -> IntPtr

Return Value

Type: IntPtr
A pointer to the address of the the pinned array
See Also

Reference

PinnedArrayT Class
Emgu.Util Namespace


PinnedArray(T).DisposeObject Method

PinnedArrayTDisposeObject Method

Disposed the unmanaged data

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void DisposeObject()
Protected Overrides Sub DisposeObject
protected:
virtual void DisposeObject() override
abstract DisposeObject : unit -> unit
override DisposeObject : unit -> unit
See Also

Reference

PinnedArrayT Class
Emgu.Util Namespace


PinnedArray(T).ReleaseManagedResources Method

PinnedArrayTReleaseManagedResources Method

Release the GCHandle

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void ReleaseManagedResources()
Protected Overrides Sub ReleaseManagedResources
protected:
virtual void ReleaseManagedResources() override
abstract ReleaseManagedResources : unit -> unit
override ReleaseManagedResources : unit -> unit
See Also

Reference

PinnedArrayT Class
Emgu.Util Namespace


Platform Class

Provide information for the platform which is using.
Inheritance Hierarchy
SystemObject
Emgu.UtilPlatform

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class Platform
Public NotInheritable Class Platform
public ref class Platform abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Platform =  class end

The Platform type exposes the following members.

Properties
Name | Description
ClrType | Get the type of the current runtime environment
OperationSystem | Get the type of the current operating system
Top
See Also

Reference

Emgu.Util Namespace


Platform Properties

The Platform type exposes the following members.

Properties
Name | Description
ClrType | Get the type of the current runtime environment
OperationSystem | Get the type of the current operating system
Top
See Also

Reference

Platform Class
Emgu.Util Namespace


Platform.ClrType Property

PlatformClrType Property

Get the type of the current runtime environment

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static ClrType ClrType { get; }
Public Shared ReadOnly Property ClrType As ClrType
    Get
public:
static property ClrType^ ClrType {
    ClrType^ get ();
}
static member ClrType : ClrType with get

Property Value

Type: ClrType
See Also

Reference

Platform Class
Emgu.Util Namespace


Platform.OperationSystem Property

PlatformOperationSystem Property

Get the type of the current operating system

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static OS OperationSystem { get; }
Public Shared ReadOnly Property OperationSystem As OS
    Get
public:
static property OS^ OperationSystem {
    OS^ get ();
}
static member OperationSystem : OS with get

Property Value

Type: OS
See Also

Reference

Platform Class
Emgu.Util Namespace


Toolbox Class

utilities functions for Emgu
Inheritance Hierarchy
SystemObject
Emgu.UtilToolbox

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static class Toolbox
Public NotInheritable Class Toolbox
public ref class Toolbox abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Toolbox =  class end

The Toolbox type exposes the following members.

Methods
Name | Description
ExecuteCmd | Call a command from command line
FindAssembly | Find the loaded assembly with the specific assembly name
FreeLibrary | Decrements the reference count of the loaded dynamic-link library (DLL). When the reference count reaches zero, the module is unmapped from the address space of the calling process and the handle is no longer valid
GetBaseType | Use reflection to find the base type. If such type do not exist, null is returned
JoinInterpolatablesT | Joining multiple index ascending IInterpolatables together as a single index ascending IInterpolatable.
LinearInterpolateT | Perform first degree interpolation give the sorted data src and the interpolation indexes
LinearSubsampleT | Get subsamples with the specific rate
LoadLibrary | Maps the specified executable module into the address space of the calling process.
MergeBytes | Merges two byte vector into one
SetDllDirectory | Adds a directory to the search path used to locate DLLs for the application
SizeOfT | Similar to Marshal.SizeOf function
ToBytesTData | Convert some generic vector to vector of Bytes
XmlDeserializeT(XDocument) | Convert an xml document to an object
XmlDeserializeT(XDocument, Type) | Convert an xml document to an object
XmlSerializeT(T) | Convert an object to an xml document
XmlSerializeT(T, Type) | Convert an object to an xml document
XmlStringDeserializeT | Convert an xml string to an object
Top
See Also

Reference

Emgu.Util Namespace


Toolbox Methods

The Toolbox type exposes the following members.

Methods
Name | Description
ExecuteCmd | Call a command from command line
FindAssembly | Find the loaded assembly with the specific assembly name
FreeLibrary | Decrements the reference count of the loaded dynamic-link library (DLL). When the reference count reaches zero, the module is unmapped from the address space of the calling process and the handle is no longer valid
GetBaseType | Use reflection to find the base type. If such type do not exist, null is returned
JoinInterpolatablesT | Joining multiple index ascending IInterpolatables together as a single index ascending IInterpolatable.
LinearInterpolateT | Perform first degree interpolation give the sorted data src and the interpolation indexes
LinearSubsampleT | Get subsamples with the specific rate
LoadLibrary | Maps the specified executable module into the address space of the calling process.
MergeBytes | Merges two byte vector into one
SetDllDirectory | Adds a directory to the search path used to locate DLLs for the application
SizeOfT | Similar to Marshal.SizeOf function
ToBytesTData | Convert some generic vector to vector of Bytes
XmlDeserializeT(XDocument) | Convert an xml document to an object
XmlDeserializeT(XDocument, Type) | Convert an xml document to an object
XmlSerializeT(T) | Convert an object to an xml document
XmlSerializeT(T, Type) | Convert an object to an xml document
XmlStringDeserializeT | Convert an xml string to an object
Top
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.ExecuteCmd Method

ToolboxExecuteCmd Method

Call a command from command line

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static string ExecuteCmd(
    string execFileName,
    string arguments
)
Public Shared Function ExecuteCmd (
    execFileName As String,
    arguments As String
) As String
public:
static String^ ExecuteCmd(
    String^ execFileName,
    String^ arguments
)
static member ExecuteCmd :
        execFileName : string *
        arguments : string -> string

Parameters

execFileName
Type: SystemString
The name of the executable
arguments
Type: SystemString
The arguments to the executable

Return Value

Type: String
The standard output
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.FindAssembly Method

ToolboxFindAssembly Method

Find the loaded assembly with the specific assembly name

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Assembly FindAssembly(
    string assembleName
)
Public Shared Function FindAssembly (
    assembleName As String
) As Assembly
public:
static Assembly^ FindAssembly(
    String^ assembleName
)
static member FindAssembly :
        assembleName : string -> Assembly

Parameters

assembleName
Type: SystemString

[Missing <param name="assembleName"/> documentation for "M:Emgu.Util.Toolbox.FindAssembly(System.String)"]

Return Value

Type: Assembly

[Missing <returns> documentation for "M:Emgu.Util.Toolbox.FindAssembly(System.String)"]

See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.FreeLibrary Method

ToolboxFreeLibrary Method

Decrements the reference count of the loaded dynamic-link library (DLL). When the reference count reaches zero, the module is unmapped from the address space of the calling process and the handle is no longer valid

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool FreeLibrary(
    IntPtr handle
)
Public Shared Function FreeLibrary (
    handle As IntPtr
) As Boolean
public:
static bool FreeLibrary(
    IntPtr handle
)
static member FreeLibrary :
        handle : IntPtr -> bool

Parameters

handle
Type: SystemIntPtr
The handle to the library

Return Value

Type: Boolean
If the function succeeds, the return value is true. If the function fails, the return value is false.
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.GetBaseType Method

ToolboxGetBaseType Method

Use reflection to find the base type. If such type do not exist, null is returned

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static Type GetBaseType(
    Type currentType,
    string baseClassName
)
Public Shared Function GetBaseType (
    currentType As Type,
    baseClassName As String
) As Type
public:
static Type^ GetBaseType(
    Type^ currentType,
    String^ baseClassName
)
static member GetBaseType :
        currentType : Type *
        baseClassName : string -> Type

Parameters

currentType
Type: SystemType
The type to search from
baseClassName
Type: SystemString
The name of the base class to search

Return Value

Type: Type
The base type
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.JoinInterpolatables(T) Method

ToolboxJoinInterpolatablesT Method

Joining multiple index ascending IInterpolatables together as a single index ascending IInterpolatable.

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> JoinInterpolatables<T>(
    params IEnumerable<T>[] enums
)
where T : new(), Object, IInterpolatable<T>

Public Shared Function JoinInterpolatables(Of T As {New, Object, IInterpolatable(Of T)}) (
    ParamArray enums As IEnumerable(Of T)()
) As IEnumerable(Of T)
public:
generic<typename T>
where T : gcnew(), Object, IInterpolatable<T>
static IEnumerable<T>^ JoinInterpolatables(
    ... array<IEnumerable<T>^>^ enums
)
static member JoinInterpolatables :
        enums : IEnumerable<'T>[] -> IEnumerable<'T>  when 'T : new() and Object and IInterpolatable<'T>

Parameters

enums
Type: System.Collections.GenericIEnumerableT
The enumerables, each should be stored in index ascending order

Type Parameters

T
The type of objects that will be joined

Return Value

Type: IEnumerableT
A single enumerable sorted in index ascending order
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.LinearInterpolate(T) Method

ToolboxLinearInterpolateT Method

Perform first degree interpolation give the sorted data src and the interpolation indexes

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> LinearInterpolate<T>(
    IEnumerable<T> src,
    IEnumerable<double> indexes
)
where T : new(), Object, IInterpolatable<T>

Public Shared Function LinearInterpolate(Of T As {New, Object, IInterpolatable(Of T)}) (
    src As IEnumerable(Of T),
    indexes As IEnumerable(Of Double)
) As IEnumerable(Of T)
public:
generic<typename T>
where T : gcnew(), Object, IInterpolatable<T>
static IEnumerable<T>^ LinearInterpolate(
    IEnumerable<T>^ src,
    IEnumerable<double>^ indexes
)
static member LinearInterpolate :
        src : IEnumerable<'T> *
        indexes : IEnumerable<float> -> IEnumerable<'T>  when 'T : new() and Object and IInterpolatable<'T>

Parameters

src
Type: System.Collections.GenericIEnumerableT
The sorted data that will be interpolated from
indexes
Type: System.Collections.GenericIEnumerableDouble
The indexes of the interpolate result

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Emgu.Util.Toolbox.LinearInterpolate``1(System.Collections.Generic.IEnumerable{``0},System.Collections.Generic.IEnumerable{System.Double})"]

Return Value

Type: IEnumerableT

[Missing <returns> documentation for "M:Emgu.Util.Toolbox.LinearInterpolate``1(System.Collections.Generic.IEnumerable{``0},System.Collections.Generic.IEnumerable{System.Double})"]

See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.LinearSubsample(T) Method

ToolboxLinearSubsampleT Method

Get subsamples with the specific rate

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> LinearSubsample<T>(
    IEnumerable<T> src,
    double subsampleRate
)
where T : new(), Object, IInterpolatable<T>

Public Shared Function LinearSubsample(Of T As {New, Object, IInterpolatable(Of T)}) (
    src As IEnumerable(Of T),
    subsampleRate As Double
) As IEnumerable(Of T)
public:
generic<typename T>
where T : gcnew(), Object, IInterpolatable<T>
static IEnumerable<T>^ LinearSubsample(
    IEnumerable<T>^ src,
    double subsampleRate
)
static member LinearSubsample :
        src : IEnumerable<'T> *
        subsampleRate : float -> IEnumerable<'T>  when 'T : new() and Object and IInterpolatable<'T>

Parameters

src
Type: System.Collections.GenericIEnumerableT
The source which the subsamples will be derived from
subsampleRate
Type: SystemDouble
The subsample rate

Type Parameters

T
The type of the object

Return Value

Type: IEnumerableT
src subsampled with the specific rate
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.LoadLibrary Method

ToolboxLoadLibrary Method

Maps the specified executable module into the address space of the calling process.

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static IntPtr LoadLibrary(
    string dllname
)
Public Shared Function LoadLibrary (
    dllname As String
) As IntPtr
public:
static IntPtr LoadLibrary(
    String^ dllname
)
static member LoadLibrary :
        dllname : string -> IntPtr

Parameters

dllname
Type: SystemString
The name of the dll

Return Value

Type: IntPtr
The handle to the library
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.MergeBytes Method

ToolboxMergeBytes Method

Merges two byte vector into one

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static byte[] MergeBytes(
    byte[] a,
    byte[] b
)
Public Shared Function MergeBytes (
    a As Byte(),
    b As Byte()
) As Byte()
public:
static array<unsigned char>^ MergeBytes(
    array<unsigned char>^ a,
    array<unsigned char>^ b
)
static member MergeBytes :
        a : byte[] *
        b : byte[] -> byte[]

Parameters

a
Type: SystemByte
the first byte vector to be merged
b
Type: SystemByte
the second byte vector to be merged

Return Value

Type: Byte
The bytes that is a concatenation of a and b
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.SetDllDirectory Method

ToolboxSetDllDirectory Method

Adds a directory to the search path used to locate DLLs for the application

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool SetDllDirectory(
    string path
)
Public Shared Function SetDllDirectory (
    path As String
) As Boolean
public:
static bool SetDllDirectory(
    String^ path
)
static member SetDllDirectory :
        path : string -> bool

Parameters

path
Type: SystemString
The directory to be searched for DLLs

Return Value

Type: Boolean
True if success
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.SizeOf(T) Method

ToolboxSizeOfT Method

Similar to Marshal.SizeOf function

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static int SizeOf<T>()

Public Shared Function SizeOf(Of T) As Integer
public:
generic<typename T>
static int SizeOf()
static member SizeOf : unit -> int

Type Parameters

T
The type

Return Value

Type: Int32
The size of T in bytes
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.ToBytes(TData) Method

ToolboxToBytesTData Method

Convert some generic vector to vector of Bytes

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static byte[] ToBytes<TData>(
    TData[] data
)

Public Shared Function ToBytes(Of TData) (
    data As TData()
) As Byte()
public:
generic<typename TData>
static array<unsigned char>^ ToBytes(
    array<TData>^ data
)
static member ToBytes :
        data : 'TData[] -> byte[]

Parameters

data
Type: TData
array of data

Type Parameters

TData
type of the input vector

Return Value

Type: Byte
the byte vector
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.XmlDeserialize Method

ToolboxXmlDeserialize Method

Overload List
Name | Description
XmlDeserializeT(XDocument) | Convert an xml document to an object
XmlDeserializeT(XDocument, Type) | Convert an xml document to an object
Top
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.XmlDeserialize(T) Method (XDocument)

ToolboxXmlDeserializeT Method (XDocument)

http://www.emgu.com
Convert an xml document to an object

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static T XmlDeserialize<T>(
    XDocument document
)

Public Shared Function XmlDeserialize(Of T) (
    document As XDocument
) As T
public:
generic<typename T>
static T XmlDeserialize(
    XDocument^ document
)
static member XmlDeserialize :
        document : XDocument -> 'T

Parameters

document
Type: System.Xml.LinqXDocument
The xml document

Type Parameters

T
The type of the object to be converted to

Return Value

Type: T
The object representation as a result of the deserialization of the xml document
See Also

Reference

Toolbox Class
XmlDeserialize Overload
Emgu.Util Namespace


Toolbox.XmlDeserialize(T) Method (XDocument, Type[])

ToolboxXmlDeserializeT Method (XDocument, Type)

http://www.emgu.com
Convert an xml document to an object

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static T XmlDeserialize<T>(
    XDocument xDoc,
    Type[] knownTypes
)

Public Shared Function XmlDeserialize(Of T) (
    xDoc As XDocument,
    knownTypes As Type()
) As T
public:
generic<typename T>
static T XmlDeserialize(
    XDocument^ xDoc,
    array<Type^>^ knownTypes
)
static member XmlDeserialize :
        xDoc : XDocument *
        knownTypes : Type[] -> 'T

Parameters

xDoc
Type: System.Xml.LinqXDocument
The xml document
knownTypes
Type: SystemType
Other types that it must known ahead to deserialize the object

Type Parameters

T
The type of the object to be converted to

Return Value

Type: T
The object representation as a result of the deserialization of the xml document
See Also

Reference

Toolbox Class
XmlDeserialize Overload
Emgu.Util Namespace


Toolbox.XmlSerialize Method

ToolboxXmlSerialize Method

Overload List
Name | Description
XmlSerializeT(T) | Convert an object to an xml document
XmlSerializeT(T, Type) | Convert an object to an xml document
Top
See Also

Reference

Toolbox Class
Emgu.Util Namespace


Toolbox.XmlSerialize(T) Method (T)

ToolboxXmlSerializeT Method (T)

http://www.emgu.com
Convert an object to an xml document

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static XDocument XmlSerialize<T>(
    T sourceObject
)

Public Shared Function XmlSerialize(Of T) (
    sourceObject As T
) As XDocument
public:
generic<typename T>
static XDocument^ XmlSerialize(
    T sourceObject
)
static member XmlSerialize :
        sourceObject : 'T -> XDocument

Parameters

sourceObject
Type: T
The object to be serialized

Type Parameters

T
The type of the object to be converted

Return Value

Type: XDocument
An xml document that represents the object
See Also

Reference

Toolbox Class
XmlSerialize Overload
Emgu.Util Namespace


Toolbox.XmlSerialize(T) Method (T, Type[])

ToolboxXmlSerializeT Method (T, Type)

http://www.emgu.com
Convert an object to an xml document

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static XDocument XmlSerialize<T>(
    T sourceObject,
    Type[] knownTypes
)

Public Shared Function XmlSerialize(Of T) (
    sourceObject As T,
    knownTypes As Type()
) As XDocument
public:
generic<typename T>
static XDocument^ XmlSerialize(
    T sourceObject,
    array<Type^>^ knownTypes
)
static member XmlSerialize :
        sourceObject : 'T *
        knownTypes : Type[] -> XDocument

Parameters

sourceObject
Type: T
The object to be serialized
knownTypes
Type: SystemType
Other types that it must known ahead to serialize the object

Type Parameters

T
The type of the object to be converted

Return Value

Type: XDocument
An xml document that represents the object
See Also

Reference

Toolbox Class
XmlSerialize Overload
Emgu.Util Namespace


Toolbox.XmlStringDeserialize(T) Method

ToolboxXmlStringDeserializeT Method

Convert an xml string to an object

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static T XmlStringDeserialize<T>(
    string xmlString
)

Public Shared Function XmlStringDeserialize(Of T) (
    xmlString As String
) As T
public:
generic<typename T>
static T XmlStringDeserialize(
    String^ xmlString
)
static member XmlStringDeserialize :
        xmlString : string -> 'T

Parameters

xmlString
Type: SystemString
The xml document as a string

Type Parameters

T
The type of the object to be converted to

Return Value

Type: T
The object representation as a result of the deserialization of the xml string
See Also

Reference

Toolbox Class
Emgu.Util Namespace


UnmanagedObject Class

An Unmanaged Object is a disposable object with a Ptr property pointing to the unmanaged object
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
More...

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class UnmanagedObject : DisposableObject
Public MustInherit Class UnmanagedObject
    Inherits DisposableObject
public ref class UnmanagedObject abstract : public DisposableObject
[<AbstractClassAttribute>]
type UnmanagedObject =
    class
        inherit DisposableObject
    end

The UnmanagedObject type exposes the following members.

Constructors
 | Name | Description
Protected method | UnmanagedObject | Initializes a new instance of the UnmanagedObject class
Top
Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object
Top
Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Inherited from DisposableObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
(UnmanagedObject to IntPtr) | Implicit operator for IntPtr
Top
Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object
Top
See Also

Reference

Emgu.Util Namespace
Inheritance Hierarchy
SystemObject
Emgu.UtilDisposableObject
Emgu.UtilUnmanagedObject
Emgu.CVAffine3d
Emgu.CVAlignExposures
Emgu.CV.ArucoCharucoBoard
Emgu.CV.ArucoDictionary
Emgu.CV.ArucoGridBoard
Emgu.CVBackgroundSubtractorKNN
Emgu.CVBackgroundSubtractorMOG2
Emgu.CV.BgSegmBackgroundSubtractorCNT
Emgu.CV.BgSegmBackgroundSubtractorGMG
Emgu.CV.BgSegmBackgroundSubtractorGSOC
Emgu.CV.BgSegmBackgroundSubtractorLSBP
Emgu.CV.BgSegmBackgroundSubtractorMOG
Emgu.CVCalibrateCRF
Emgu.CVCascadeClassifier
Emgu.CV.CudaCudaDeviceInfo
Emgu.CV.CudaGpuMat
Emgu.CV.CudaStream
Emgu.CV.CudaVectorOfGpuMat
Emgu.CVCvArrayTDepth
Emgu.CV.CvbCvBlobDetector
Emgu.CV.CvbCvBlobs
Emgu.CV.CvbCvTracks
Emgu.CVCvString
Emgu.CVDISOpticalFlow
Emgu.CV.DnnNet
Emgu.CV.FaceFacemarkAAM
Emgu.CV.FaceFacemarkAAMParams
Emgu.CV.FaceFacemarkLBF
Emgu.CV.FaceFacemarkLBFParams
Emgu.CVFarnebackOpticalFlow
Emgu.CV.Features2DBOWImgDescriptorExtractor
Emgu.CV.Features2DBOWKMeansTrainer
Emgu.CV.Features2DDescriptorMatcher
Emgu.CV.Features2DSimpleBlobDetectorParams
Emgu.CVFileNode
Emgu.CVFileStorage
Emgu.CV.FlannAutotunedIndexParams
Emgu.CV.FlannCompositeIndexParams
Emgu.CV.FlannHierarchicalClusteringIndexParams
Emgu.CV.FlannIndex
Emgu.CV.FlannIndex3D
Emgu.CV.FlannKdTreeIndexParams
Emgu.CV.FlannKMeansIndexParams
Emgu.CV.FlannLinearIndexParams
Emgu.CV.FlannLshIndexParams
Emgu.CV.FlannSearchParams
Emgu.CVHOGDescriptor
Emgu.CV.ImgHashImgHashBase
Emgu.CVInputArray
Emgu.CVKalmanFilter
Emgu.CVLineIterator
Emgu.CVMatDataAllocator
Emgu.CVMergeExposures
Emgu.CV.MLANN_MLP
Emgu.CV.MLBoost
Emgu.CV.MLDTrees
Emgu.CV.MLEM
Emgu.CV.MLLogisticRegression
Emgu.CV.MLNormalBayesClassifier
Emgu.CV.MLRTrees
Emgu.CV.MLSVM
Emgu.CV.MLSVMSGD
Emgu.CVMoments
Emgu.CV.OclDevice
Emgu.CV.OclImage2D
Emgu.CV.OclKernel
Emgu.CV.OclKernelArg
Emgu.CV.OclPlatformInfo
Emgu.CV.OclProgramSource
Emgu.CV.OclQueue
Emgu.CV.OCRPageIterator
Emgu.CV.OCRPDFRenderer
Emgu.CV.OCRPix
Emgu.CV.OCRTesseract
Emgu.CV.OCRVectorOfTesseractResult
Emgu.CV.PhaseUnwrappingHistogramPhaseUnwrapping
Emgu.CV.PlotPlot2d
Emgu.CV.PpfMatch3dICP
Emgu.CVQRCodeDetector
Emgu.CVRLOFOpticalFlowParameter
Emgu.CVRNG
Emgu.CV.SaliencyMotionSaliencyBinWangApr2014
Emgu.CV.SaliencyObjectnessBING
Emgu.CV.SaliencyStaticSaliencyFineGrained
Emgu.CV.SaliencyStaticSaliencySpectralResidual
Emgu.CVScalarArray
Emgu.CV.ShapeAffineTransformer
Emgu.CV.ShapeHistogramCostExtractor
Emgu.CV.ShapeShapeDistanceExtractor
Emgu.CV.ShapeThinPlateSplineShapeTransformer
Emgu.CVSparseMatrixTDepth
Emgu.CVSparsePyrLKOpticalFlow
Emgu.CV.StitchingBlender
Emgu.CV.StitchingWarperCreator
Emgu.CVSubdiv2D
Emgu.CV.SuperresFrameSource
Emgu.CV.TextERFilter
Emgu.CV.TextVectorOfERStat
Emgu.CV.TextVectorOfVectorOfERStat
Emgu.CV.TiffTiffWriterTColor, TDepth
Emgu.CVTonemap
Emgu.CV.TrackingMultiTracker
Emgu.CV.TrackingTracker
Emgu.CV.UtilDataLogger
Emgu.CV.UtilSharedPtrObject
Emgu.CV.UtilTbbTaskScheduler
Emgu.CV.UtilVectorOfByte
Emgu.CV.UtilVectorOfColorPoint
Emgu.CV.UtilVectorOfCvString
Emgu.CV.UtilVectorOfDMatch
Emgu.CV.UtilVectorOfDouble
Emgu.CV.UtilVectorOfFloat
Emgu.CV.UtilVectorOfInt
Emgu.CV.UtilVectorOfKeyPoint
Emgu.CV.UtilVectorOfMat
Emgu.CV.UtilVectorOfOclPlatformInfo
Emgu.CV.UtilVectorOfPoint
Emgu.CV.UtilVectorOfPoint3D32F
Emgu.CV.UtilVectorOfPointF
Emgu.CV.UtilVectorOfRect
Emgu.CV.UtilVectorOfTriangle2DF
Emgu.CV.UtilVectorOfUMat
Emgu.CV.UtilVectorOfVectorOfByte
Emgu.CV.UtilVectorOfVectorOfDMatch
Emgu.CV.UtilVectorOfVectorOfInt
Emgu.CV.UtilVectorOfVectorOfPoint
Emgu.CV.UtilVectorOfVectorOfPoint3D32F
Emgu.CV.UtilVectorOfVectorOfPointF
Emgu.CV.UtilVectorOfVectorOfRect
Emgu.CVVariationalRefinement
Emgu.CVVideoCapture
Emgu.CV.VideoStabFrameSource
Emgu.CV.VideoStabGaussianMotionFilter
Emgu.CVVideoWriter
Emgu.CVViz3d
Emgu.CVWArrow
Emgu.CVWCircle
Emgu.CVWCloud
Emgu.CVWCone
Emgu.CVWCoordinateSystem
Emgu.CVWCube
Emgu.CVWCylinder
Emgu.CVWText
Emgu.CV.XImgprocDTFilter
Emgu.CV.XImgprocGraphSegmentation
Emgu.CV.XImgprocRFFeatureGetter
Emgu.CV.XImgprocSelectiveSearchSegmentation
Emgu.CV.XImgprocStructuredEdgeDetection
Emgu.CV.XImgprocSuperpixelLSC
Emgu.CV.XImgprocSupperpixelSEEDS
Emgu.CV.XImgprocSupperpixelSLIC
Emgu.CV.XObjdetectWBDetector
Emgu.CV.XPhotoWhiteBalancer


UnmanagedObject Constructor

Initializes a new instance of the UnmanagedObject class

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected UnmanagedObject()
Protected Sub New
protected:
UnmanagedObject()
new : unit -> UnmanagedObject
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


UnmanagedObject Properties

The UnmanagedObject type exposes the following members.

Properties
 | Name | Description
Public property | Ptr | Pointer to the unmanaged object
Top
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


UnmanagedObject.Ptr Property

UnmanagedObjectPtr Property

Pointer to the unmanaged object

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public IntPtr Ptr { get; }
Public ReadOnly Property Ptr As IntPtr
    Get
public:
property IntPtr Ptr {
    IntPtr get ();
}
member Ptr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


UnmanagedObject Methods

The UnmanagedObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose function that implements IDisposable interface (Inherited from DisposableObject.)
Protected method | DisposeObject | Release the unmanaged resources (Inherited from DisposableObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor (Inherited from DisposableObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseManagedResources | Release the managed resources. This function will be called during the disposal of the current object. override ride this function if you need to call the Dispose() function on any managed IDisposable object created by the current object (Inherited from DisposableObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


UnmanagedObject Type Conversions

The UnmanagedObject type exposes the following members.

Operators
Name | Description
(UnmanagedObject to IntPtr) | Implicit operator for IntPtr
Top
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


UnmanagedObject Implicit Conversion (UnmanagedObject to IntPtr)

UnmanagedObject Conversion (UnmanagedObject to IntPtr)

http://www.emgu.com
Implicit operator for IntPtr

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public static implicit operator IntPtr (
    UnmanagedObject obj
)
Public Shared Widening Operator CType (
    obj As UnmanagedObject
) As IntPtr
static implicit operator IntPtr (
    UnmanagedObject^ obj
)
F# does not support the declaration of new casting operators.

Parameters

obj
Type: Emgu.UtilUnmanagedObject
The UnmanagedObject

Return Value

Type: IntPtr
The unmanaged pointer for this object
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


UnmanagedObject Fields

The UnmanagedObject type exposes the following members.

Fields
 | Name | Description
Protected field | _ptr | A pointer to the unmanaged object
Top
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


UnmanagedObject._ptr Field

UnmanagedObject_ptr Field

A pointer to the unmanaged object

Namespace: Emgu.Util
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
protected IntPtr _ptr
Protected _ptr As IntPtr
protected:
IntPtr _ptr
val mutable _ptr: IntPtr

Field Value

Type: IntPtr
See Also

Reference

UnmanagedObject Class
Emgu.Util Namespace


Emgu.Util.TypeEnum Namespace

Various enumeration for Emgu.Util namespace
Classes
 | Class | Description
Public class | ClrType | The runtime environment
Public class | OS | Type of operating system
Public class | ProgrammingLanguage | The type of Programming languages


ClrType Class

The runtime environment
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.Util.TypeEnumClrType

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ClrType : Enum
Public NotInheritable Class ClrType
    Inherits Enum
public ref class ClrType sealed : public Enum
[<SealedAttribute>]
type ClrType =
    class
        inherit Enum
    end

The ClrType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | DotNet | .Net runtime
 | Mono | Mono runtime
 | NetFxCore | Windows Store app runtime
 | Unknown | Unknown
Public field | value__ |
Top
See Also

Reference

Emgu.Util.TypeEnum Namespace


ClrType Methods

The ClrType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ClrType Class
Emgu.Util.TypeEnum Namespace


ClrType Fields

The ClrType type exposes the following members.

Fields
 | Name | Description
 | DotNet | .Net runtime
 | Mono | Mono runtime
 | NetFxCore | Windows Store app runtime
 | Unknown | Unknown
Public field | value__ |
Top
See Also

Reference

ClrType Class
Emgu.Util.TypeEnum Namespace


ClrType.DotNet Field

ClrTypeDotNet Field

.Net runtime

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ClrType DotNet = 1
Public Const DotNet As ClrType = 1
public:
literal ClrType^ DotNet = 1
static val mutable DotNet: ClrType

Field Value

Type: ClrType
See Also

Reference

ClrType Class
Emgu.Util.TypeEnum Namespace


ClrType.Mono Field

ClrTypeMono Field

Mono runtime

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ClrType Mono = 3
Public Const Mono As ClrType = 3
public:
literal ClrType^ Mono = 3
static val mutable Mono: ClrType

Field Value

Type: ClrType
See Also

Reference

ClrType Class
Emgu.Util.TypeEnum Namespace


ClrType.NetFxCore Field

ClrTypeNetFxCore Field

Windows Store app runtime

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ClrType NetFxCore = 2
Public Const NetFxCore As ClrType = 2
public:
literal ClrType^ NetFxCore = 2
static val mutable NetFxCore: ClrType

Field Value

Type: ClrType
See Also

Reference

ClrType Class
Emgu.Util.TypeEnum Namespace


ClrType.Unknown Field

ClrTypeUnknown Field

Unknown

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ClrType Unknown = 0
Public Const Unknown As ClrType = 0
public:
literal ClrType^ Unknown = 0
static val mutable Unknown: ClrType

Field Value

Type: ClrType
See Also

Reference

ClrType Class
Emgu.Util.TypeEnum Namespace


ClrType.value__ Field

ClrTypevalue__ Field

[Missing <summary> documentation for "F:Emgu.Util.TypeEnum.ClrType.value__"]

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ClrType Class
Emgu.Util.TypeEnum Namespace


OS Class

Type of operating system
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.Util.TypeEnumOS

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class OS : Enum
Public NotInheritable Class OS
    Inherits Enum
public ref class OS sealed : public Enum
[<SealedAttribute>]
type OS =
    class
        inherit Enum
    end

The OS type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Android | Android devices
 | IOS | iOS devices. iPhone, iPad, iPod Touch
 | Linux | Linux
 | MacOS | Mac OS
 | Unknown | Unknown
Public field | value__ |
 | Windows | Windows
Top
See Also

Reference

Emgu.Util.TypeEnum Namespace


OS Methods

The OS type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS Fields

The OS type exposes the following members.

Fields
 | Name | Description
 | Android | Android devices
 | IOS | iOS devices. iPhone, iPad, iPod Touch
 | Linux | Linux
 | MacOS | Mac OS
 | Unknown | Unknown
Public field | value__ |
 | Windows | Windows
Top
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS.Android Field

OSAndroid Field

Android devices

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OS Android = 5
Public Const Android As OS = 5
public:
literal OS^ Android = 5
static val mutable Android: OS

Field Value

Type: OS
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS.IOS Field

OSIOS Field

iOS devices. iPhone, iPad, iPod Touch

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OS IOS = 4
Public Const IOS As OS = 4
public:
literal OS^ IOS = 4
static val mutable IOS: OS

Field Value

Type: OS
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS.Linux Field

OSLinux Field

Linux

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OS Linux = 2
Public Const Linux As OS = 2
public:
literal OS^ Linux = 2
static val mutable Linux: OS

Field Value

Type: OS
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS.MacOS Field

OSMacOS Field

Mac OS

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OS MacOS = 3
Public Const MacOS As OS = 3
public:
literal OS^ MacOS = 3
static val mutable MacOS: OS

Field Value

Type: OS
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS.Unknown Field

OSUnknown Field

Unknown

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OS Unknown = 0
Public Const Unknown As OS = 0
public:
literal OS^ Unknown = 0
static val mutable Unknown: OS

Field Value

Type: OS
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS.value__ Field

OSvalue__ Field

[Missing <summary> documentation for "F:Emgu.Util.TypeEnum.OS.value__"]

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


OS.Windows Field

OSWindows Field

Windows

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const OS Windows = 1
Public Const Windows As OS = 1
public:
literal OS^ Windows = 1
static val mutable Windows: OS

Field Value

Type: OS
See Also

Reference

OS Class
Emgu.Util.TypeEnum Namespace


ProgrammingLanguage Class

The type of Programming languages
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Emgu.Util.TypeEnumProgrammingLanguage

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ProgrammingLanguage : Enum
Public NotInheritable Class ProgrammingLanguage
    Inherits Enum
public ref class ProgrammingLanguage sealed : public Enum
[<SealedAttribute>]
type ProgrammingLanguage =
    class
        inherit Enum
    end

The ProgrammingLanguage type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CPlusPlus | C++
 | CSharp | C#
Public field | value__ |
Top
See Also

Reference

Emgu.Util.TypeEnum Namespace


ProgrammingLanguage Methods

The ProgrammingLanguage type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum.)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the type code of the underlying type of this enumeration member. (Inherited from Enum.)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum.)
Public method | ToString(IFormatProvider) | Obsolete. This method overload is obsolete; use ToString. (Inherited from Enum.)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum.)
Public method | ToString(String, IFormatProvider) | Obsolete. This method overload is obsolete; use ToString(String). (Inherited from Enum.)
Top
See Also

Reference

ProgrammingLanguage Class
Emgu.Util.TypeEnum Namespace


ProgrammingLanguage Fields

The ProgrammingLanguage type exposes the following members.

Fields
 | Name | Description
 | CPlusPlus | C++
 | CSharp | C#
Public field | value__ |
Top
See Also

Reference

ProgrammingLanguage Class
Emgu.Util.TypeEnum Namespace


ProgrammingLanguage.CPlusPlus Field

ProgrammingLanguageCPlusPlus Field

C++

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ProgrammingLanguage CPlusPlus = 1
Public Const CPlusPlus As ProgrammingLanguage = 1
public:
literal ProgrammingLanguage^ CPlusPlus = 1
static val mutable CPlusPlus: ProgrammingLanguage

Field Value

Type: ProgrammingLanguage
See Also

Reference

ProgrammingLanguage Class
Emgu.Util.TypeEnum Namespace


ProgrammingLanguage.CSharp Field

ProgrammingLanguageCSharp Field

C#

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public const ProgrammingLanguage CSharp = 0
Public Const CSharp As ProgrammingLanguage = 0
public:
literal ProgrammingLanguage^ CSharp = 0
static val mutable CSharp: ProgrammingLanguage

Field Value

Type: ProgrammingLanguage
See Also

Reference

ProgrammingLanguage Class
Emgu.Util.TypeEnum Namespace


ProgrammingLanguage.value__ Field

ProgrammingLanguagevalue__ Field

[Missing <summary> documentation for "F:Emgu.Util.TypeEnum.ProgrammingLanguage.value__"]

Namespace: Emgu.Util.TypeEnum
Assembly: Emgu.CV.World.NetStandard (in Emgu.CV.World.NetStandard.dll) Version: 1.0.0
Syntax
C#
VB
C++
F#
Copy
public int value__
Public value__ As Integer
public:
int value__
val mutable value__: int

Field Value

Type: Int32
See Also

Reference

ProgrammingLanguage Class
Emgu.Util.TypeEnum Namespace